%%ItemTitle%%

.netCHARTING v10.7 Documentation
Home

Thank you for downloading .netCHARTING. This document will help you work with the product and will serve as a programmers reference.

Here are some helpful tips to get started.

Quick Start (Recommended Reading)

As you explore the features and functionality of this component you will find it is extremely powerful and capable of creating virtually any charts you may need. This software has also been developed to be much more flexible than the status quo, which, will enable you to push the charting envelope beyond the standards you may be used to.

This section will give a general overview of how everything works and get you started quickly. So without further ado, let's get to it.

Step 1. Installation

The installation is automated but it also supports xcopy deployment.

Step 2. Explore the samples

After the component is installed, take a look at the samples to get a grasp of the available features. You may see some interesting functionality that will give you ideas for charts you will be creating.

Step 3. Your First Chart

The best way way to get started is to take a sample that is similar to the type of chart you want and modify the property settings.

Because many different charting applications use different terminology, it is also important to know the terminology used in .netCHARTING. Below is a chart image with a few basic terms.

Basic Terminology

More image references: Labels | Lines.

Tips

  • Make use of default properties
    There are several default instances of objects such as Chart.DefaultSeries for example. The properties of this object trickle down to all series on the chart. Using these defaults allows setting properties of many object at once instead of setting them individually. The following image specifies a few different object instances with properties that will end up affecting the given object.

  • Use Label Tokens (%Name, %Value, ...)
    Virtually all labels can show dynamic info about the parent object's values and data. For example, an element's label can show values such as the element's name and Y value.
    See also: Token Reference | Using Labels

Step 3.1. Getting/Using Data

.netCHARTING has a simple yet powerful interface for data acquisition and manipulation. Chart data is represented by SeriesCollection, Series, and Element classes. For more information on this model see this topic. When you are familiar with the general data model, you can explore the connecting to data sources and using query strings sections to learn how to populate these classes automatically.

Advanced
At this point you will be able to generate simple charts, however, this only scratches the surface of what you can do in the data acquisition phase. You can also manipulate, group by dates, limit top x results, and do many other things with your data. When you are ready to explore the more advanced data features, take a look at the other Data Tutorials.

Step 3.2. Chart Type

An important point to remember is that the data model is independent from the chart engine itself. This means that the data structure for one chart type should work with any other chart types just the same. The mechanism behind chart types is also quite flexible.

Step 4. Exploring other features

You will now be able to generate basic charts and have a general idea of how to change the chart type. Most of the time, this is not enough to create the exact chart you need. Fortunately, we have covered only about 5% of the functionality available. Moving forward, there are many tutorials at your disposal. You may also visit the support section of our website to download printable PDF versions of some tutorials so that you can review them at your leisure.

Tutorials
  • Basic Tutorials
    Tutorials describing basic .net usage such as working with fonts and colors.
  • Data Tutorials
    Tutorials describing how to acquire data from different data sources and how to manipulate the chart data model.
  • General Tutorials
    Tutorials describing the functionality of .netCHARTING and its features.

If you have any questions please visit the .netCHARTING support website or contact support.

Send comments on this topic.


Illustrated QuickStart

This tutorial will illustrate the process of downloading the component to creating your first chart.

Show All
Hide All

1. Install

The installation is automated but it also supports xcopy deployment. If you wish to unpack manually and install then follow these steps on a modern OS.

2. Create an application

This section illustrates creating an application. For more details please see the Application Creation tutorial.
1

3. Setup permissions

For detailed information on setting permissions please see the installation instructions.

The folders that require the permissions are:

  • dotnetcharting/Samples/csharp/temp
  • dotnetcharting/Samples/csharp/gallery/temp
  • dotnetcharting/Samples/VisualBasic/temp
  • dotnetcharting/Samples/visualBasic/gallery/temp

  • ..

Steps to add user

  • Open Windows Explorer
  • Select a file or directory.
  • Right click the file and select "Properties"
  • Select the "Security" tab
  • Click the "Edit" and then "Add" button
  • Click the "Locations" button and make sure you select the local machine. (Not the Windows domain if the server belongs to one.)
  • Enter "IIS AppPool\DefaultAppPool" in the "Enter the object names to select:" text box. (Don't forget to change "DefaultAppPool" here to whatever you named your application pool.)
  • Click the "Check Names" button and click "OK"

4. Setup your first chart.

Create a new folder under the dotnetcharting directory application to hold the new charts and the temp directory..

5. Edit your first chart

Send comments on this topic.


Using With MVC
.netCHARTING ASP.NET MVC Chart Library

.netCHARTING is the leading ASP.NET charting library and has a dedicated bundle and sample set for MVC web applications. Easily add over 150 types of charts including pie charts, bar charts, column charts, line charts, financial charts, polar charts and area charts to your web pages. Extensive JavaScript SVG chart support is included without needing to write JavaScript code working with a single Razor page (cshtml) for each sample, you can customize the html and chart elements in one place. For more complex customization, you can modify controllers and add new model as well. With a custom HTML helper included in the project (DNC.cs), in each sample *.cshtml page, you can easily access chart object and set chart properties using intellisense in Visual Studio.

Interactive chart

Using .netCHARTING ASP.NET MVC you can add data for custom drilldown charts, use custom data binding for your datapoints creating interactive charts quickly and easily.

.netCHARTING ASP.NET MVC Chart Library asp-net-mvc-chart .netCHARTING is the leading ASP.NET charting library and has a dedicated bundle and sample set for MVC web applications. Easily add over 150 types of charts including pie charts, bar charts, column charts, line charts, financial charts, polar charts and area charts to your web pages. Extensive JavaScript SVG chart support is included without needing to write JavaScript code working with a single Razor page (cshtml) for each sample, you can customize the html and chart elements in one place. For more complex customization, you can modify controllers and add new model as well. With a custom HTML helper included in the project (DNC.cs), in each sample *.cshtml page, you can easily access chart object and set chart properties using intellisense in Visual Studio. Interactive chart Using .netCHARTING ASP.NET MVC you can add data for custom drilldown charts, use custom data binding for your datapoints creating interactive charts quickly and easily.

Code Sample:

FeaturesController.cs
using System.Web.Mvc;
public ActionResult JSCGanttSummary()
{
return View();
}
JSCGanttSummary.cshtml
@(Html.Chart().ID("summmeryChart").Title("Project Alpha (Click to zoom)")
.Size("840x120").JS(jsOpSum).ChartType(ChartType.Combo).DefaultSeries(defaultSeriesSum)
.DefaultElement(defaultElementSum).LegendBox(legendBox).YAxis(yAxisSum)
.TempDirectory("/temp").SeriesCollection(summarySeries))
@(Html.Chart().ID("detailsChart").Size("840x480").ChartType(ChartType.ComboHorizontal)
.JS(jsOp).DefaultSeries(defaultSeries).DefaultElement(defaultElementSum).YAxis(yAxis)
.LegendBox(legendBox).TempDirectory("/temp").SeriesCollection(detailsSeries))

For better performance, you can directly manipulate client side settings seeing results in real-time and dynamically adjust online content. Chart types can also be selected interactively. More samples are available at www.dotnetcharting.com contact us if you need any assistance or wish to use a specific sample in MVC. .netCHARTING ASP.NET MVC supports interactive and animations charts from your JSON data or use the integrated server side data engine to securely populate the chart from your database without any additional coding required. Charts can also be configured to update in real-time based on your dynamic data sources. For the samples using database, a chartSample.mdb included in the project. You can update the connection string in the web.config and use other data sources including MySQL, SQL Server, and Oracle. If you have a unique data source you wish to use that is not already supported with .netCHARTING please contact us!

.netCHARTING ASP.NET MVC supports interactive and animations charts from your JSON data or use the integrated server side data engine to securely populate the chart from your database without any additional coding required. Charts can also be configured to update in real-time based on your dynamic data sources. For the samples using database, a chartSample.mdb included in the project. You can update the connection string in the web.config and use other data sources including MySQL, SQL Server, and Oracle. If you have a unique data source you wish to use that is not already supported with .netCHARTING please contact us!

Code Sample:

JSCController.cs
using System.Web.Mvc;
public ActionResult JSCPieStyled()
{
return View();
}
JSCPieStyled.cshtml
@(Html.Chart().Title("Countries GDP").ChartType(ChartType.Pies).Size("600x350")
.DefaultElement(defaultElement).ChartArea(chartArea).YAxis(yAxis1).XAxis(xAxis1)
.DefaultAxis(defaultAxis1).TempDirectory("/temp") .PaletteName(Palette.None) .DonutHoleSize(0.7).JsEnabled(true).SeriesCollection(getPieChartData()))

JavaScript and HTML5 Charts

A powerful new JavaScript and HTML charting solution has been added in .netCHARTING 7.0. Easily enable JavaScript Charting with seamless mobile, iOS, Android and tablet support, at no additional charge, with every .netCHARTING license sold. In addition to visual parity with .netCHARTING's stunning server-side output, our JavaScript charts provide advanced animation and rich client side interactivity support.

Code Sample:

JSCController.cs
using System.Web.Mvc;
public ActionResult JSCFitness()
{
return View();
}
JSCFitness.cshtml
@(Html.Chart().ID("Chart1").ChartType(ChartType.Gauges).DefaultSeries(defaultSeries1) .Size("840x240").ChartArea(chartArea1).JsEnabled(true).TempDirectory("/temp") .ShadingEffectMode(ShadingEffectMode.Three).YAxis(yAxis1).XAxis(xAxis1) .DefaultAxis(defaultAxis1).DonutHoleSize(0.7).SeriesCollection(getDataChart1()))

@(Html.Chart().ID("Chart2").ChartType(ChartType.Heatmap).DefaultSeries(defaultSeries2) .Size("840x240").ChartArea(chartArea1).JsEnabled(true).TempDirectory("/temp") .ShadingEffectMode(ShadingEffectMode.Three).DefaultAxis(defaultAxis2) .YAxis(yAxis4).XAxis(xAxis4).SeriesCollection(getDataChart2()))

The MVC sample project uses high performance Single Page Application (SPA) option, but .netCHARTING can also be used in traditional MVC (Model-View-Controller) projects. Easily open the sample project in Visual Studio 2017 and Visual Studio 2019 we always support the latest Microsoft developer tools and have been a Microsoft Certified Partner for over 15 years! If you need help working with an older version of Visual Studio, please contact support.

.netCHARTING is committed to supporting your ASP.NET MVC visualization needs and getting you up and running quickly. Download the free trial with no purchase required.

Trouble shooting

The dotnetCHARTING_MVC solution and project can be opened in Visual Studio 2017 or later. (Recently tested in 2017 & 2019)

Error: When a project is first opened, NuGet may not have initialized until a NuGet operation is performed.

Resolution:

Run NuGet restore: - Right-click on the solution node in the Solution Explorer and select Restore NuGet Packages.

Error: Could not find a part of the path 'C:\dotnetCHARTING_MVC\bin\roslyn\csc.exe':

Resolution:

Open the Package Manager UI - Right-click on References and select Manage NuGet Packages... and run the following command:

Update-Package Microsoft.CodeDom.Providers.DotNetCompilerPlatform -r

Then in apply Build->Rebuild Solution

Error: .Chart() not being recognized as a html helper.

Resolution:

@(Html.Chart() is defined in dnc.cs and it has all the html helper methods for MVC users and should be included in project. dotnetcharting.dll can be used directly with aspx pages or creating chart image programmatically and displaying the image anywhere in the page.

Send comments on this topic.


Overview

.netCHARTING Overview

.netCHARTING combines visually stunning graphics and a comprehensive interface to bring you one of the most compelling charting solutions available.

From the very beginning our goal was clear; to produce a solution with stunning visuals that is also simple to use. No effort was spared in realizing this goal and the result is a unique web control that combines a high performance charting engine with a powerful database and data manipulation system.

.netCHARTING makes use of the most advanced technologies available on the market today including the .NET framework, introduced as a final release early in 2002, and GDI+. These are two of the many new technologies that have enabled us to step beyond existing visual charting standards and produce visuals much stronger than typical dynamic charting solutions. In fact, we hope you will agree that the .netCHARTING visuals are even superior to high end desktop charting applications!

Send comments on this topic.


New Features

New Features in Version 10.7

.NET 9.0 Chart Support

.netCHARTING 10.7 introduces a .NET 9.0 chart nuget package and a .NET 9.0 chart sample bundle, both requiring Visual Studio 2022. With .NET 9.0, developers can enjoy simplified development, improved performance, and increased productivity. We remain committed to enhancing .netCHARTING by continuously adding value and functionality, ensuring compatibility with the latest Visual Studio 2022, Windows Server 2022, and .NET 9.0.

New Features in Version 10.6

.NET 8.0 Chart Support

.netCHARTING 10.6 adds both a .NET 8.0 chart nuget package and .NET 8.0 chart sample bundle (requires Visual Studio 2022) .NET 8.0 provides simplified development, better performance and enhanced productivity. We continue to add value and functionality to .netCHARTING maintaining the latest Visual Studio 2022, Windows Server 2022 and .NET 8.0 support.

New Features in Version 10.5

Right-angle or straight organizational connector lines

We enhanced how organizational connector lines appear by drawing them at right angles by default. You can use the straight option to change this default and draw connector lines directly between points.

Synchronize organizational node widths and heights

We added Element.Annotation.SyncWidth and SyncHeight properties to help you control the sizing and visual balance of organizational chart nodes.

Point hierarchy connector styling and selection

There is now a way to select specific branches in an organizational or Gantt dependency chart using hierarchy path selectors. You can select all branches from a point up the hierarchy, down the hierarchy, up and down, or between two points.

New connector line radius option

We added a connector line radius property (DefaultElement.CornerRadius) to control the rounded corners of organizational connector or Gantt dependency lines.

Control column and bar corner radius

The new DefaultElement.CornerRadius property can be used to control column and bar corner radius.

Enable Axis.TickNumberMaximum to work with JS Charts

It is now easier to control the number of automatically generated axis ticks on a JavaScript chart.

Added Axis.CenterTickMarks support for JS Chart range axis ticks.

For when you want a grid line to center on a range tick.

Improved Shape Label Positioning.

We completed a significant overhaul of the shape label positioning algorithm to handle many labels in different positions more reliably.

Improvements to multiple gauge layout

We enhanced the way multiple gauges and radars are laid out on a chart to make better use of the available space.

Automatic string animations when charts update.

When chart label text changes, the text will animate numbers and words within to indicate a change is taking place.

New Series.DefaultLeafElement Property

To help you work more efficiently with hierarchical charts, you can apply element options to only leaf elements (elements without any elements below them in the hierarchy).

Automatic leaf node vertical layout

JavaScript organizational charts will now optimize organizational chart layouts by stacking leaf points vertically automatically.

More advanced generic annotation positioning

Control annotation positions with a string such as "inside top left" indicating inside the chart area in the top left corner.

Advanced LegendBox position support for JS Charts

Use the same advanced positioning syntax as with annotations to specify legend position. For example: "inside left top" - inside CA top left corner stacked vertically (notice the use of left top vs. top left'.

Added Label.Placement for use with shape label positions.

Use this with shape labels to control whether to place labels inside or outside visuals such as donuts.

Added SmartLabel.Placement to control placing labels inside or outside elements.

To provide better control over label placement either inside or outside the element visuals.

Enable Chart.OverlapFooter to work with JS charts

Enabled for JavaScript charts, you can now design the chart while it shows branding and make sure it will look the same once branding is removed.

Ability to disable automatic label wrapping in JS charts

You can now disable automatic label wrapping in all labels in JavaScript charts.

Added label MaxWidth property.

Want to limit label width? Use the MaxWidth label option to reliably limit the width a label can be.

Automatic label ellipsis text overflow with maxWidth and autoWraping disabled

When using MaxWidth and AutoWrapping=false labels will automatically use overflow ellipsis and limit their size without wrapping text.

New Features in Version 10.4

.NET 6.0 Chart Support

.netCHARTING 10.4 adds both a .NET 6.0 chart nuget package and .NET 6.0 chart sample bundle (requires Visual Studio 2022), .NET 5 was the successor of .NET Core 3.1 and .NET Framework 4.8, aims to provide .NET developers with a new cross-platform development experience. .NET 6.0 expands on this with simplified development, better performance and enhanced productivity. We continue to add value and functionality to .netCHARTING maintaining the latest Visual Studio 2022, Windows Server 2022 and .NET 6.0 support.

New Features in Version 10.3

Automatic Column Rounding

A major leap in aesthetics seamlessly maintained as your data changes, JavaScript charts will apply corner rounding to columns and bars at the appropriate edges automatically. No need to write code to avoid having notches between stacked items or any other problem scenarios. A visually pleasing corner radius is also automatically calculated to soften the column look regardless of size while being subtle enough not to interfere with reading specific chart values.

Legend Line Icons

Legend line icons are enhanced with the addition of dash styles and represent line series of varying widths and dash styles more accurately by scaling both attributes on the legend icon.

New Features in Version 10.2

.NET 5.0 Support

We are proud to announce the first chart built with 100% managed code in .NET 5. .NET 5, the successor of .NET Core 3.1 and .NET Framework 4.8, aims to provide .NET developers with a new cross-platform development experience. .netCHARTING enables your web site to display massive amounts of dynamically generated data quickly and easily through dynamic data visualizations. Built with .NET 5 cross platform and provided with extensive samples, this high performance charting control also contains a feature rich data access and aggregation system with calculation support. We continue to add value and functionality to .netCHARTING maintaining the latest Visual Studio, Windows Server and .NET support.

MVC and Razor Support

.NET Core support

New Features in Version 10.1

Venn and Euler Diagrams

A new Venn and Euler diagram chart type has been added to JS charts.

Automatic Venn Color Blending

Using the default ChartType.Venn option, venn diagram elements that are made up of two or more overlapping shapes will inherit a blend of the underlying colors. Using the ChartType.VennColorByPoint option will assign a unique color to each element.

RTL Text support with JS Charts

The JavaScript output now offers full right-to-left language support. The chart will automatically apply this feature when a RTL language culture string is specified.

Improved First Chart Render Performance

The JavaScript library files needed on the server to render charts are now reduced making the initial JS chart load faster.

Improved JS Chart Interactions Performance

General chart wide performance improvements in JS Charts.

Element.SecondaryColor Support in JS Charts

Secondary color is now applied in JS charts for use with finance candlestick and bar series and circular bar (activity ring) charts.

Label.Outline Support in JS Charts

The native label outline capabilities of .netCHARTING are now supported in client side charts as well.

Three Highlighting Modes in JS Charts

Element and series highlighting is automatically enabled when hovering legend entries and element axis ticks. It is also available when hovering data elements, which is automatically enabled with the Venn chart type.

- HighlightElement - Mutes all data except the hovered element.

- HighlightSeries - Mutes all data except the element of the series being hovered.

- HighlightElementGroup - Mutes all data except the element group being hovered. An element group refers to elements across all series that share the same x value or name.

Specify Hover Actions

You can specify the hover action of data elements, legend entries, and element axis ticks.

Native Series FirstElement and LastElement properties for JS Charts

The native .netCHARTING series now support FirstElement and LastElement properties to specify the settings for the first and last elements. This is useful when applying settings to the chart default series, configuring those elements to show labels or assigning axis ticks to them.

Element.XAxisTick And YAxisTick Support in JS Charts

The x and y axis tick properties of element objects are now fully supported in JS Charts.

Native Element.FocusGlow Property for JS Charts

This property defines the outline of elements when they are hovered in JS charts. With combined tooltips, this outlines all elements mentioned in the tooltip.

Native Axis.Crosshair Property and Support for JS Charts

The axis crosshair in JS charts can now be set through the .netCHARTING Axis.Crosshair property.

Improved JS Chart Tooltip Positioning

Tooltips are now smarter and more aware of elements around them in JS charts. This makes charts easier to read when hovering chart elements with the mouse cursor.

New Features in Version 10.0

Complete Styling Redesign

Image and JavaScript charts have a brand new and modern look.

Spline tension control

The spline tension option has been added to JavaScript charts.

Axis Tick Label Auto-Wrapping

JavaScript charts will automatically wrap Y axis tick labels when they are too long. They will also wrap on the X axis if possible before angling.

First and Last Point Settings

JavaScript chart setting Series.firstPoint and Series.lastPoint can be used to specify options only for those points.

Superimpose Visuals with <absolute>

JavaScript Microcharts can now be wrapped inside an <absolute> tag which allows overlapping several visuals such as sparklines. This provides a more in-depth expression of data inside charts such as calendars.

Improved Auto Tooltip Text

The JavaScript chart automatic tooltips have been improved to automatically provide more useful and relevant information depending on the chart type and data that is shown.

New JavaScript Chart Features in Version 9.3

Gantt Dependencies

The advanced Gantt chart capability of JavaScript Charts is now even more powerful. Project task dependencies for critical path analysis can now be visualized on Gantt charts. Starting tasks can be set to depend on the completion of another task or a number of other tasks as a group.

Axis Range Ticks

'Range ticks' may sounds contradictory at first, but are a powerful new addition for axis labeling. Axis ticks traditionally refer to a specific point on an axis scale; however, now have gained the ability to define a range. Simply specify an array of two numeric values in place of a single numeric tick value to enable the range axis tick visualization. Range ticks can display with three different visualization styles and will select the optimal mode automatically while also allowing for manual configuration.

AxisTick CalendarPattern Values

Combining CalendarPatterns with axis range ticks provides a new and compelling way to visualize time scales. Enabling range ticks to be automatically drawn for every month, quarter, year (or any other interval) is as simple as adding one line of code!

AxisMarker CalendarPattern Values

CalendarPatterns are a powerful shorthand API enabling you to define complex date patterns (such as rules for national holidays) or interval based patterns (such as weekends). These patterns can now be specified as axis marker values to mark important dates that may correlate with your data.

Category Scale Names == Ranges

A new concept for category scales. String category names no longer refer to a single point on an axis, but rather a range. AxisTicks and AxisMarkers now accept either category name values or two category names that refer to a range that encompasses both categories.

Logarithmic Scale Improvements

Logarithmic scales now support zero and negative values. In addition, exponent format string 't' support is now available to shorten the large numeric axis values that often appear in logarithmic scales.

Point Axis Ticks

This feature automates complex coding tasks through a very simple API. A xAxisTick or yAxisTick property can be set directly on any data point (or the default) configuration object which adds an axis tick bound to point itself. The value of this tick will automatically be set to the point value and the tick label includes seamless support for point tokens that describe the point.

Axis Number Shortening and Magnitude Formatting

Large numeric values, which take time to read accurately, waste a lot of screen real estate.. Now, the axis can automatically shorten these values so that 56,000 turns into 56 k, 1,000,000 becomes 1M and so on. This formatting option is also available as the 'a' format string and can be used with any labels outside the axis. When a number is added to the format string such as 'a2', it refers to a specific magnitude.

Datagrid Control

A powerful and tightly integrated data grid that binds to charts and also acts as a stand-alone grid connected directly to your data.

Microchart and Icon Syntax

The simple syntax that allows microcharts to be added to any label on a chart is also supported in datagrid cells. In addition, icon syntax provides access to the full library of icons for seamless usage in datagrid cells.

Token Formatting and Expressions

The same formatting and expressions syntax supported within chart labels can now be used to define data grid column values.

Chart to Datagrid

An existing chart can show an alternative data grid of the charted data by simply setting the datagrid_enabled config option to true. A chart can also populate any div on the page with its data using the chart.toGrid('divId') function.

Export to CSV

When the datagrid CSV export option is enabled, a convenient button is generated that will save the data as a CSV file on the client's computer.

Accessibility

When accessibility is a company-wide requirement, JavaScript Charts offers an uncompromising solution. Whether your organization must comply with section 508 or WCAG 2.0, you now have access to all the options to enable and control your chart accessibility experience. In addition, color palettes optimized for color impaired viewers have been added to further enhance accessibility regardless of the specific form of color impairment.

Line Caps

Line caps add deeper meaning and context to ordinary lines by communicating line direction, colors and symbols. Line Caps are automatically set to enhance visualizations such as Gantt dependencies and range ticks and can also be set for other lines on the chart (even on line series).

Superscript and Subscript

Superscript and subscript text is useful for many advanced labeling needs and avoids having math equations or numeric values written as 10^5. Both superscript and subscript html tags can now be used with any labels in JavaScript Charts and will correctly render as SVG text.

Updated Microchart Styling and Options

Microcharts have been enhanced with a clean and modern look.. Additionally, a rotate option has been introduced which is useful for custom fit and rotation requirements as well as rendering microcharts stacked horizontally or vertically across axis ticks.

New JavaScript Chart Features in Version 9.2

Microchart Visualizations

.netCHARTING js labels are incredibly powerful supporting features such as microcharts and the ability to utilize the full icons library. Version 9.2 expands this support enabling the complete label feature set to be used with any div element on a web page. This allows microchart visualizations to be seamlessly embedded into data driven html pages. The built in SVG icons library can also be used, enhancing visual clarity and creating more aesthetically pleasing experiences.

Mosaic Plot/Variwide/Mekko chart type

Variwide, marimekko, and mosaic are all names associated with this powerful new chart type added in version 9.2. The variwide chart type works with category x axis scales and column series. Combining this type with y axis full stacked mode results in a Marimekko diagram, also known as mosaic plot.

Label html tag improvements

New label html tag support including <hr> and <img> and List support <ul> <li>

Interactive UiItem types

New slider, file and dropdown scroll support user interface controls have been added in .netCHARTING 9.2. Sliders can be used to enhance chart interactivity by adjusting data scope visualization in real-time and include both single and dual handle configuration options.

Crosshairs

This set of features provides greatly enhances analytic chart interactivity. Combined tooltips can be enabled and customized with calculations and microcharts to display quantitative relationships of groups of points that share x values, while crosshairs provide additional contextual detail displayed directly on the axes themselves.

Axis scale break enhancements

Scale breaks can now be defined with calendar patterns. Some source data, such as finance stock prices, may exclude weekends when markets are closed. It is now easier than ever to simply exclude weekends from the timeline x axis using scale breaks with weekend calendar patterns. Additional scale break styling options were added in version 9.2, including break width which can be specified with a seamless mode that does not mark the scale breaks at all.

Data Point Options

Point focus glow styling options have been added which work in conjunction with combined tooltips to highlight relevant data points. In addition, a point '%icon' token can now be used in any point label or tooltip to aid in describing and identifying points. This is useful when multiple points are described in a combined tooltip.

New JavaScript Chart Features in Version 9.1

Calendar Heatmap

Includes many features including automatic views, tooltips and subvalue date grouping. Point binding by date to modify calendar cells. Point attribute merging into single cells and single point binding to multiple cells. Calendar highlights and more.

Calendar Views

18 calendar views that break down time spans from decades to minutes.

Label html tag improvements

New label html tag support including <hr> and <img> and List support <ul> <li>

Vector Icon support through the icon tag

The icon tag can now be added to any text label with the full library of icons available including custom svg path support.

Box layout system

.netCHARTING version 9.1 introduces a major enhancement to the box layout and positioning system, unifying the legend, annotations, and uiItems into a single layout mechanism with positioning options that arrange the boxes either inside or outside chart area.

CSV loading client side

The window.fetch() function can be referenced through JSC.fetch() and is also supported in IE11 through a polyfill.

The JSC.parseCsv(text) function splits CSV text into rows and columns, detects and separates header rows, and parses values into string or numeric values automatically.

Client side SmartLabels

Version 9.1 includes an intelligent point labeling system that is capable of handling label collisions and fit issues automatically without obscuring other points and labels.

New JavaScript Chart Features in Version 9.0

Circular Bar Gauges

A new chart type for project timeline and task management, the Gantt type is now fully implemented with a modern client side and resolution independent approach. A time scale is an advanced scale which enables automatically display of a large variety of time and data hierarchies with automatically selected formatting. This advanced axis scale is now supported for both X and Y axis facilitating seamless Gantt layouts over time.

Circular Overflow Indication

Overflow indication uses a color hue shift that makes the number of times a circular bar overlaps easy to see at a glance.

Linear Gauges

Linear gauges are now supported in JS charts and are a welcome addition to many dashboards. Rounded caps or flat bars can be used to enhance styling flexibility.

Hatch Styling

Hatch patterns can now be applied to JS charts to further strengthen accessibility support (for example aiding color blind users).

Column Complete Visualization

The traditional complete value visualization through a hatch pattern is not available in JS vector charts. This feature is ideal for differentiating elements for black and white display or for those who are color blind.

Organizational Chart Type

Organizational charts are now available using native vector JavaScript chart output and also include interactive panning for larger organizational data sets.

Heatmap Chart Type

A new heatmap chart type is now available and is a perfect match with the enhanced SmartPalette support in .netCHARTING’s seamlessly integrated client side charts.

TreeMap Cushion Shading

A specialized smart shading effect has been added to the JavaScript charts that help visualize the hierarchy of nested TreeMap data.

Custom Legend Entries

The advanced .netCHARTING legend feature set is now supported in JavaScript chart output. Custom legend entries can be used to summarize data or populate a legend manually with custom information.

Legend Template

Legend templates allow you to define legend columns enabling an attractive data-grid inside the chart image. This feature has now been enabled in JS charts and is ideally suited to single file chart / grid export and printing.

Legend AxisMarker Entries

AxisMarkers now add an entry in the legend to clarify the marker meaning and exact value.

Markers for all Series Types

All chart types now support the addition of a marker visual to highlight a specific data point.

Icon Browser

The chart based icon browser provides a streamlined experience for searching and browsing the hundreds of icons available for use within .netCHARTING.

Icon Support in any Label

Icons can now be used in all text labels in the JS chart.

Multiple Shape Labels

Multiple labels can be added to gauge charts to decorate and provide additional contextual information. .netCHARTING will automatically position labels to avoid overlaps.

SmartPalette Legend Support

SmartPalettes are now fully supported in JS charts including legend entries for specific smartColor entries.

Axis Line Breaks

New support has been added for this visual enhancement for axis lines which breaks up the line at tick positions. This feature is now supported on linear and circular axes.

Box Corner Styling

Box corner styling is now fully supported in JS charts.

New JavaScript Chart Features in Version 8.4

Gantt Chart Type with Time Y Axis Scale support
A powerful chart type for project timeline and task management, the Gantt type is now fully implemented with a modern client side and resolution independent approach. A time scale is an advanced scale which enables automatically display of a large variety of time and data hierarchies with automatically selected formatting. This advanced axis scale is now supported for both X and Y axis facilitating seamless Gantt layouts over time.

Dynamic Token Tick & Axis Marker Values
Tick and axis markers can now be seamlessly updated without coding, based on tokens and calculations. This enables the addition of averages and other useful data derived values to display as a dynamic tick mark or axis marker with ease.

Custom Ticks
In addition to the advanced label and tick generation system already in place, .netCHARTING now offers the flexibility of custom ticks to communicate axis specific information more effectively.

Logarithmic Scale
New log scale support enables plotting exponential trends and statistical data.

Stacked Logarithmic Scale
Logarithmic scale support is now integrated for stacked charts, such as stacked bars and other related types.

New JavaScript Chart Features in Version 8.3

Massive set of highly tuned maps doesn’t require any 3rd party map files or mapping experience
.netCHARTING now includes an extensive set of optimized vector based maps which can be displayed with a simple property setting. Maps are included for all countries, states and provinces in the world!

Map context shows surrounding maps automatically
When mapping a specific region, the surrounding geographic areas can be included to provide context and avoid the floating country effect. Best of all, subtle styling is automatically applied to such context areas, so they provide context without visual complexity.

Custom map files using geoJSON and topoJSON (optional)
While the comprenshive set of state, province and country maps will cover most client's complete mapping needs, for advanced users geoJSON and topoJSON files are supported so you can utilize your own files for custom mapping.

Add map layers in real-time for advanced dynamic maps
Since .netCHARTING includes a highly optimized map set the different maps seamlessly link together. This allows for unique dynamic mapping cases where higher detailed areas can be dynamically loaded on top of an existing map, loading and aligning perfectly without user intervention.

Plot lines, markers, and bubbles on maps.
.netCHARTING’s new vector map charts support various series including lines, markers and bubbles to meet your most in depth mapping requirements.

New JavaScript Chart Features in Version 8.2

Smart Scale Breaks
JavaScript Charts can now understand smart scale break settings the dynamically calculate the best breaks as series data or visibility changes.

Funnel/Pyramid/Code/Treemap Types
Powerful new pyramid, funnel and cone charts are now supported in JavaScript Charts as single charts or groups of charts within a given chart area.

Funnel/Pyramid/Code/Treemap Types
Powerful new pyramid, funnel and cone charts are now supported in JavaScript Charts as single charts or groups of charts within a given chart area.

New JavaScript Chart Features in Version 8.1

Label Expressions
Now you can perform common expressions directly within labels in JavaScript Charts using values from template tokens. For example 100-%YValue to show a label calculated as 100 minus the total for that elements Y value.

Circular Gauges
A stunning new gauge / dial chart type has been brought to JavaScript Charts. In addition to supporting a single chart, multiple gauges can be added for instant executive dashboard implementations. Many advanced features are supported with this new type including quarter, half or arbitrary sized gauges.

Pie Slice Lengths
Now individual pie slice lengths can be varied based on a separate data independent of the slice total enabling multidimensional data display.

Pie Starting Angles
Now it is simple to set the starting angle for any pie chart to a specific value required to match your aesthetic requirements.

Radar Charts
Radar and Multi-Radar have been added to JavaScript Charts. Great attention was paid to maintaining visuals across these unique charting types including unique radar optimized shading types.

Range Bars/Columns and Areas
Now bar, column and area charts support points with start and end values in JavaScript Charts. This enables a column or area that starts at a value greater than zero, for example, and allows for effective and attractive display of ranged data.

Error Bars
Complete support for error bars and values has been added to JavaScript Charts along with support to automatically populate element error properties from your own database. As part of a comprehensive system for representing errors in collected data, .netCHARTING leverages multiple sub values support in JavaScript Charts with rendering as error bars, lines and markers.

New in Version 8.0

New Javascript Chart Engine
Complementing the Silverlight Navigator first introduced in version 6.0, a powerful new JavaScript and HTML charting functionality has been added in .netCHARTING 8.0.

Javascript Navigator
Javascript Navigator for finance charts and real-time zooming.

Finance series types
Finance series types such as candlestick and OHLC have been added.

Multiple chart areas (Navigator)
Multiple chart areas are now supported with the JS Navigator.

JavaScript Charts Label Token Support
Native label token support has been added to the Javascript charting layer.

JavaScript Charts Label callbacks
Label callback functions are now supported with JS charts.

Client side formatting and data calculations
Client-side .net style string formatting support has been added. This can be used in label callbacks or other client-side requirements.

Custom Attributes
Custom attributes are a powerful system for linking your own data from a database to the .netCHARTING object model. Now custom attributes can also be used in the JavaScript Charts component.

Smart Default Tooltips
Depending on the data and chart type, the interactive tooltip displays relevant and useful calculations automatically tuned based on the usage case. If the automatic values don't meet your specific needs, you can also customize with your own tooltip template configuration.

Major and minor tick support
Along with major axis ticks, minor axis ticks are now supported in JavaScript Charts as well.

Access to full JavaScript Charts json API
The Chart.JS.Settings property now enables you to specify any settings for client-side chart configuration directly by path.

WinForms Client Framework Support
For corporate and wide deployment without additional installation requirements, .netCHARTING WinForms version 8 and later support a subset of the .NET framework that is pushed automatically with windows update. The end result is easier deployment and smaller installations for your WinForms applications.

WinForms Transparency with Double Buffering
To provide a seamless experience with charts with transparency showing part of your application behind the chart without issue, we have supported transparency with double buffering enabled. This results in both supporting transparency while minimizing visual refresh.

New in Version 7.0

JavaScript / HTML Chart Output
Complementing the Silverlight Navigator first introduced in version 6.0, a powerful new JavaScript and HTML charting functionality has been added in .netCHARTING 7.0. As always, the complete client side functionality is available through our server side model with no client side development experience required. Setting a single property will enable JavaScript Charting or Silverlight Charting.

Comparable Visual and User Experiences
Client side interactive charts typically sacrifice a lot, providing a substantially different visual and functional experience vs server side charts. With .netCHARTING 7.0 you get, for the first time, a level of polish and visual quality that is comparable to server side offerings across the same chart types, while still leveraging animation, touch and mobile specific features.

Browser Compatibility
Our JavaScript Charting is built with a focus on extensive browser support including Chrome, FireFox, Safari, Opera, Internet Explorer (even as far back as version 6) plus mobile and webkit browsers used on the majority of phones and tablets. Advanced interactive and client side charts are now available to the widest audience using .netCHARTING.

Dynamic Tooltips
Advanced tooltips with custom attributes and dynamic coloring provide quick and easy identification of elements with additional useful information such as element value and more through a token based system. Color highlights, seamlessly integrated into the tooltip box, help effortlessly clarify which element is being viewed when working with data dense charts.

Bar Shading Effects
Visual fidelity is maintained between server side and client side charts with client optimized bar shading including animation support.

Animation
Clear and refined animation is built in to JS Charting including axis animations, bar and pie drawing, line growth, real-time drawing operations and more.

Touch-screen support
Working with a phone or tablet? Now you can interact with touch event support to get tooltip data, zoom or scroll through charts.

Real-Time updates
Chart values can be added in real-time and immediately display in the chart area, even dynamically scaling the axis as needed.

Client Side interactivity
A number of interactivity features are supported including advanced dynamic tooltips, touch interaction, zooming, series interaction and a powerful API for advanced customization.

iPhone, iOS, Andoid, WP7 & Tablet support
Our interactive JavaScript charts are just as beautiful and functional on an iPad, iPhone, iPod Touch, Android Phone, Android Tablet, Windows Phone, Mac, PC and more. .netCHARTING version 7 provides the widest support across devices, with a fast-to-load, plugin-free implementation--the goal with JavaScript Charting is to work seamlessly on any device, anywhere.

Image, vector and PDF Export
Client side charts may be saved or exported in a number of formats including JPG or PNG images and native vector PDF files (compatible with Adobe and other PDF tools) in addition to SVG files.

Client side printing support
Full support for client side printing is seamlessly integrated. Click the optionally enabled and customizable print button and you get a true hard-copy representation of the chart being viewed.

Series Hiding
Dynamically hide series and rescale axis to the remaining values without that series enabled, using a simple click on the series entry in the legend. A second click enables the series again with an animated addition.

Element Highlighting
Highlight elements on mouse over for easy identification and visual connection to element specific tooltips.

Zooming
Click and drag to zoom into regions of a given chart to view them in more detail. Return to the original zoom bounds with a single click or tap.

Client-Side JavaScript API
A application programmer’s interface enables advanced developers to further customize and interact with the JavaScript charts, however all features are accessible through our easy to use server side model as well. No experience with JavaScript is required to fully leverage .netCHARTING V7.0’s powerful JavaScript charts just as no experience is required to leverage the compelling .netCHARTING Navigator for Silverlight.

Multiple-Axes Support
As with .netCHARTING, multiple axis support is standard and seamlessly integrated.

.netCHARTING v7.0 New Visuals
Get a fresh new look for your old charts without a single line of code! Automatically improve the look and balance of your legacy charts simply by using the latest version of dotnetcharting.dll. If you are attached to your legacy look--you can easily maintain it with a simple web.config entry and enable the new look on a chart by chart basis instead.

New Default Palette
As part of the new look, a new default palette has been added to complement the new visuals.

New subtle Shading Effect
Subtle shading with a focus on color constancy and crisp visuals has been added and utilized in the new look in .netCHARTING V7.0.

Dynamic Default Shading
A dynamic visualization system has been added to implement shading throughout the chart to enhance the look and feel while maintaining balance between design elements in the chart.

Multi-Color Gradient stops:
Gradients can now support multiple colors and stops to create advanced shading such as the chart area grid fills seen in the new look. This can also be used for any chart objects which support backgrounds such as the chart area.

Shadow Expansion Support:
A new feature for shadow support enables shadows to size larger than the object that throws the shadow for a unique soft or hard edged border effect.

New in Version 6.2

TreeMap Chart support
A powerful new charting type for treemap and heatmaps has been added.

Surface Chart Type
A major new chart type has been added supporting both 2D and 3D surfaces in a new 3D perspective view chart area.

Surface Combination Types
The new surface type supports subtypes which can be combined including 2D and 3D combinations where the 2D view is rendered on the base of the 3D chart area and acts as a projection.

Box Header Orientation
Headers may now be placed on the top, sides or bottom of a box providing unprecedented visual flexibility for box design.

Box Header Ribbon caps
A new visual style for end caps allows you to create highly tuned ribbon visuals to match the latest innovations in web design and seamlessly integrate with your site.

X/Y Surface Types
In addition to the traditional surface mesh or solid fill, .netCHARTING supports X and Y surface charts which render only the X or Y component of the surface creating a unique and innovative visual effect.

Contour Charts
Also supported in combination with other surface types, the Contour type can be added in 2D and 3D variations. The number, or density, of contours can be customized through the ContourCount property.

Floating and Anchored Surface Support
The traditional floating surface chart terminates at the Z value of the points on the edge of the surface. To enhance edge clarity for certain charts, the DropToFloor attribute can be utilized. This drops the surface edge to the minimum value in the surface chart rendering a clear vertical face on the edge.

Surface 3D orthographic projection
You can control the tilt and rotation of the 3D view to display the surface chart in the most effective way possible to communicate your data.

Surface dynamic color support
The .netCHARTING surface system supports automated SmartPalette™ generation from color inputs.

Interpolated Surface Fill
Surface color fills may be mapped 1:1 to their underlying data or interpolation can be utilized to automatically smooth the surface colorings with a configurable setting.

Surface transparent value support
Partial or open surfaces are possible with transparent element support.

AJAX Zoomer Enhancements
We have continued to improve the AJAX zoomer system with enhanced performance and handling and the ability to coexist with the most popular AJAX libraries and usage cases.

Line Transparency support
Now you can customize the line transparency within charts. This is particularly useful in surface charts where lines can be removed, form the chart itself, and be solid colors or custom dynamic colors based on the surface values.

Surface 3D lighting
To enhance realism, surface lighting can be enabled to subtly shade the surface and give dimension to surfaces with a more monochromatic palette.

Z Axis support
A new Z Axis has been added for surface charts and may be customized along with the X and Y axis.

Enhanced box header designer
The box header designer has been enhanced to support the new ribbon and orientation options.

Web based Surface Designer
To help you explore the rich functionality of the new surface chart types, a web based designer has been added. This enables you to play with the various surface options, then copy and paste the generated code to use in your own project or web page.

Range SmartColor Transparency
Smart colors now support transparent and partially transparent colors within their range.

Mapping Range SmartColor Support
.netCHARTING maps can now utilize the new range smart color functionality enabling the displayed color value to be set from the specified value and a gradient of range smart Colors.

Category Data to Surface Chart
New methods have been added to easily convert multiple category series into surface data, which can then be directly consumed to render surface charts.

DateTime Data to Surface Chart
Additional helper methods will convert a DateTime series to surface data and also provide options to group the data based on advanced TimeIntervals.

Surface Coloring
Surface series lines and fills can be controlled independently with dynamic, solid, and transparent color settings.

New in Version 6.1

TreeMap Chart support
A powerful new charting type for treemap and heatmaps has been added.

TreeMap Shading Support
Advanced shading options are available for all treemap charts for enhanced visuals including both the standard shading types and background optimized shading. Shading adds visual polish while maintaining legibility.

Swatch Support
To enhance and support the TreeMap type, a new swatch legend system has been added supporting ranged values and flexible visualization and layout support, in images and even within HTML.

Navigator Enhancements
The .netCHARTING Navigator first introduced in 6.0 has continued to be enhanced including support for chart area hotspots and chart area position tokens.

Navigator Marker Support
Complete axis marker support including axis marker labels are now available.

Navigator Drag and Throw
A unique UI innovation which mimics advanced touch interfaces, drag and throw utilizes acceleration to enable more intuitive and rapid nagivation when using the click and drag interface.

Navigator Interactivity
With the addition of element value at x position, the navigator can return interactive results of click tests within the chart area and display the results in your page.

Navigator Loading Enhancements
Four new animation styles are available for display while the navigator is loading.

Navigator String Customization
The loading strings for the navigator can now be customized to control the message text or modify the string values for internationalization support.

Navigator Preview image enhancements
You can now control if the preview image is displayed or not with a simple property setting. In addition, the preview image has been tuned to more closely match the interactive navigator after it loads.

Navigator Windowless Mode Support
Based on client feedback, you can now support windowless mode to better interact with your own client side elements on the page.

Color Range Support
Smart Palette additions have been made for GetValueColor and GetScaleRange to support the advanced features and functionality of the TreeMap type and swatch legend display.

Box Header Customization
An advanced new box header system has been added supporting 10,000+ unique combinations with the advanced alignment and endcap visuals, shadows, offsets and much more.

Box Header Cap Styles
More than ten unique end cap styles can be applied independently to the start and end of a header for unique visual customizations including pointers, tabs, ribbons and much more.

Box Header Layout Options
Advanced alignment options provide complete flexibility in combination with endcaps to achieve the specific polished header implementation you envision.

Box Header Designer
To help familiarize yourself with the advanced box header support and rapidly prototype header visuals, a new web based box designer has been included in .netCHARTING 6.1. Now you can design boxes and copy / paste the required code to create that header design into your code in seconds.

Winforms 6.1 Updated
Now updated for 6.1, the Winforms release is once again in feature sync with the WebForms release including the new treemap charting types, complete header and swatch support.

New in Version 6.0

Silverlight Navigator
A powerful new charting product has been seamlessly integrated into .netCHARTING. Now developers can provide advanced interactive Silverlight charts with a simple property setting and no Silverlight specific coding required. This high end visualization solution is included at no additional charge with every .netCHARTING license sold.

Navigator Performance
The new Silverlight charting product automatically utilizes multi-core systems for enhanced performance, while it also has been tested and performs well on legacy systems. The .netCHARTING Silverlight Navigator is capable of processing, animating and scaling tens of thousands of elements in real-time.

Navigator Selection Aids
Advanced selection aids provide visual feedback to help clients locate and select data of interest while maintaining continuity in real-time. Values display at the pointer position, while selecting ranges, on hover and for the range displayed in the chart area.

Navigation Bar
A powerful navigation bar gives a centralized location for many interactivity operations including history (undo/redo), date / range selection and quick zoom buttons. Developers can quickly and easily customize the navigation bar options as well as the interactivity features exposed to the end user which are independent of the navigation bar.

Quick Zoom Buttons
Developer customizable for arbitrary ranges and custom labels, quick zoom buttons enable a fixed zoom range to be displayed with one click. For example, the viewer may jump to a range for one month or one day.

Highly optimized user interface
The .netCHARTING navigator has undergone substantial usability testing to help tune the minutia of design to ensure it is as powerful and intuitive as possible. In side by side testing with both Yahoo and Google Finance, the navigator proved to not only have stronger performance but also be much easier to use to accomplish common tasks. The end result was a 2-3x improvement in time to accomplish specific viewing and selection tasks while using the .netCHARTING Navigator!

History
A history system tracks user operations as they occur and supports undo and redo within the collected history by clicking on the arrow buttons in the navigation bar.

Advanced Date and Range selector
Usability testing revealed a major weakness of most interactive charting systems was the range selector. .netCHARTING solved this problem with a ground up re-write of the range selector which works for multiple types of data and is not limited to date selection. This interface has proven to allow faster range selection in side by side tests with traditional date inputs while also maintaining continuity with real-time updates as the range is being selected. Furthermore, the selection is not limited to dates which is very useful for alternate axis support.

Animation Support
Transitions are seamlessly animated to aid user experience continuity and provide natural transitions. Example animations include transitions (movements) between areas within a chart, zooming, deep zooming and rescaling.

Slideshow and Presentation Support
The advanced animation model supports unique slideshow and presentation functionality which enable you to navigate through data to points of interest and provide text notes and descriptions. Users could also do self guided presentations by clicking on points of interest from a list and having such points navigated to automatically.

Advanced Arbitrary Selection Support
Selections may be made directly on the chart area with advanced indicator support for start and stop positions of the selection range in real-time.

Mixed Selection
When both cell and arbitrary selection are enabled, they can be used at the same time. For example you can start by selecting a cell and end the selection at an arbitrary position and vice versa.

Cell Selection Support
In addition to arbitrary selection, selection can be made with cells, snapping to significant regions such as months, days or hours with a single click. This support also enables rapid drill-into support by clicking cells to progress to more detailed views of the data.

Dynamic Help
The .netCHARTING Navigator dynamic help system automatically populates any HTML element with real-time context sensitive help when users hover over the dynamic chart. This system enables formatting and display options for help tips integrated at the page level.

Real-time Navigator AutoTrack™ Support
The navigator supports chart linking to auto track data and trends based on mouse hover. As the user hovers over a preview chart, the navigator seamlessly moves to the applicable data in real-time within the dynamic chart.

Innovative DeepZoom™ Support
Unlike most implementations which cease to allow selection a you zoom due to scroll bar selection, the .netCHARTING navigator automatically rescales the selection preview area as needed to maintain an usable scroll bar at all times. The system even automatically scales out of deep zoom operations as scroll bar size is increased or the selected area increased.

Click and Drag Support
Navigate the chart easily with multiple paths including click and drag (hand) support in addition to traditional scroll bar movements.

Advanced zooming options
Zoom into data using the scroll wheel, scroll bar handle resizing, scroll bar click-hold-resize, cell selection, arbitrary chart area selection and much more. Parallel paths enable users to use the most intuitive options for zooming that fit their expectations while other options remain in the background available, yet not complicating their experience or the user interface.

Smart Handle Support
Scroll bar handles are intelligent and remember past positions. Double click actions on the handles (left or right) enable maximize and return to last position, while double clicking the scroll bar itself supports maximize and return to last size and position for both handles at once.

Silverlight Interactivity with a single setting
Old and new .netCHARTING users can leverage the advanced interactivity with a single property setting. Turn on the navigator and .netCHARTING goes to work in the background seamlessly generating, loading, and displaying the Navigator based on the same server side properties used for a legacy static chart usage case.

Automatic Plug-in detection and down-level support
Seamlessly display a static chart image if the Silverlight Plug-in is not yet installed, display the static chart and prompt to install the plug-in or automatically prompt to install the plug-in. .netCHARTING is optimized to provide the best user experience regardless of their configuration.

JavaScript API
Advanced developers can control chart movements through an intuitive JavaScript API while no such experience is required to get the most from the .netCHARTING navigator, it is available for those that require it.

Legendbox Position Flexibility
A new automated legend box position is supported within the chart area.

Percentage Change Calculation Support
A new token is supported at the series level which provides the percentage change between the first and last element of the series visible on the chart area

New in Version 5.3

Rich ToolTip Support
Complex tooltips are now supported with inline formatted image text, MicroCharts, InfoGrids and even full chart previews ideal for drilldown cases.

Annotation Size Customization
It is now possible to set annotation size directly as well as dynamically size contents in width or height while the other dimension is automatically sized based on the contents.

Pie Annotation Orientation
The pie chart type presents a unique visual challenge for annotations. A specifically tuned orientation enables annotations to ring the outside of the pie, preventing the pie itself from being obstructed.

AJAX Zoomer Category Support
Now you can zoom, pan and scroll category axis charts (such as names or text) in addition to numeric or date axis. You can also specify the zoom starting position and control the axis ticks which determines scale. Large charts have never been simpler to display regardless of if they are employee results by name, product sales by product or any other possibilities.

MicroChart Data Feature Additions
Significant additions have been made to make creating and populating MicroCharts effortless. New functionality includes sub value date grouping, simplified subvalue creation and enhanced calculation methods for sub values.

Organizational Chart Zooming
Advanced pan and scroll support has been added for organizational charts. Now you can easily view an org chart of any size and click to expand or contract nodes within the org hierarchy. As always, organizational charts support simple binding to your database data and advanced annotation formatting and shading to ensure your charts look exceptional.

Organization Chart Drill Down
A .netCHARTING first, org charts now support drill down in addition to expansion. This gives a unique view of charts contained to a single viewing pane with the ability to drill down into or back out of the hiearchy while maintaining a fixed view without scrolling. Level support further complements this feature by allowing more data to be displayed in one frame at a given time.

Organizational Chart Indicators
Unique visualizations are provided for nodes to indicate if they support expansion or contraction. In addition, you can easily customize the display with your own images for actions such as node addition, removal, or expansion / contraction operations.

Dynamic Organization Chart Creation
With .netCHARTING it is simple to create a web based form for dynamic org chart creation. Simply click on a org level to add a node below it or remove a given node all from a easy to use web interface. A sample for dynamic org chart creation is included with .netCHARTING.

Organization Chart Expansion
Expansion allows an organizational chart to grow as nodes are expanded. Here too, there is flexibility for display when using AJAX pan and scroll; the chart can maintain its size or, within a fixed window, elements can be sized smaller on expansion to fit within the specified window. .netCHARTING now provides one of the most advanced organization charting feature sets of any product. As always, these advanced add-ons are included with every .netCHARTING license with no additional cost.

Object Chart Creation
Now you can easily create small chart images from labels and annotations. These charts are particularly well suited for usage in previews, tooltips and dashboard implementations.

Background Shading
The chart background box now supports shading in addition to the chart area box. Two new shading effects specifically designed for use in backgrounds have been added in this release.

Mapping Interactivity Enhancements
.netCHARTING includes advanced mapping functionality with every license purchase; no add-on required! The latest version now supports rich tooltips on maps which can include images and text data along with hotspot interactivity.

Map Shape Annotations
All map shapes now support annotations. Now it is simple to click and view detailed information for a given map location within an annotation. You can also tune the visuals of the generated annotations to specifically match your applications requirements.

MicroChart Feature Additions
A new Image MicroChart including Image sizing and rotation allows for innovative use of MicroCharts as labels for chart elements. The possibilities are endless and options can be controlled programmatically based on your own database data.

New MicroChart Scale Option
A new bottom scale gives additional scale layout functionality for MicroCharts.

MicroChart Interactivity
Interactivity support has been added with the new tooltip and url support for MicroCharts. Using Image MicroChart with URL setting allows for creating clickable icons.

New Token Support
The powerful .netCHARTING token system has continued to be expanded with token support for ID and ParentID for organizational charts along with new calculation based additions for PercentOfSeriesMax, PercentOfMax and PercentOfGroupMax. Now you can inline these values simply be using the template token and the chart will render with the calculated value specific to the object used.

New Visibility Options
Simply control the visibility of a given subvalue or line with the new Visible properties added for these objects.

New in Version 5.2

MicroChart chart type added
A major new chart type has been added which enables small charts, ideal for display in grids and other tabular visualizations. MicroCharts are also well suited for business dashboard implementations.

MicroChart Types
Many different visualizations are possible with MicroCharts including bars, gauges, progress bars, bullets, sparklines, area lines, scales, pies and markers.

MicroChart Label Usage
In addition to stand alone usage, MicroCharts can be used inline within any chart label. This allows unique usage such as labeling a pie slice with a MicroChart of the values that make up that slice or labeling bars with their subvalues.

InfoGrid™ Support
A unique, new, image based grid is now available with .netCHARTING. InfoGrids combine tabular data, line separators, symbols and images using a simple, yet dynamic markup language.

MicroCharts in InfoGrids™
InfoGrids(TM) can also serve as containers for microcharts, providing a powerful mini dashboard implementation that can be easily viewed as a single image or used as part of a larger dashboard implementation.

MicroChart DataGrid Usage
In addition to usage within InfoGrids(tm), MicroCharts can also be used within traditional datagrid or gridview controls.

InfoGrid™ Label Usage
Stand alone or in a label, InfoGrids provide exceptional flexibility and seamless integration with any data visualization.

2D Line & Spline series line caps
Now series lines and splines can be terminated with an endcap such as an arrow to show continuing trend or add visual polish.

New Element Markers
The set of predefined element markers has been expanded with an up arrow, down arrow and inverted triangle.

Pie Start angle
Now it is simple to set the starting angle for any pie chart to a specific value required to match your aesthetic requirements.

Gantt Dependencies
Link tasks with ease using the new Gantt dependency functionality. Dependency lines are automatically routed to provide the best visual balance and avoid overlaps.

Horizontal Rule Markup tag
The new horizontal rule enables you to visually separate data in labels and InfoGrids™.

Dashboard Samples
In addition to the many new feature samples, version 5.2 adds a number of specific dashboard samples which illustrate how multiple charts can be seamlessly integrated into a sophisticated digital dashboard.

Automated Drilldown Weeks to Days
Now you can enable automated drill downs from weeks to days in addition to months to days with a single property setting.

DataEngine SQL Parameter support
New support has been included so that you can add SQL statement parameters using the DataEngine's AddParmater method, the same as you would for a stored procedure.

AJAX Zoomer HotSpot Support
Hotspots are now supported within the AJAX zoom and scroll interface to launch specific URLs on elements. In addition, the complete .netCHARTING token system can be used to pass in values to your target page specific to the element being selected.

New in Version 5.1

Organizational Chart Type
A powerful new type has been added for visualizing organizations and other hierarchical data.

Organizational Vertical Layouts
Vertical linking provides enhanced layout and space savings for organizational charts.

Organizational Shading
The complete set of .netCHARTING shading types are supported within organizational charts including box and header shading support.

Advanced Label Formatting
To complement the new organizational chart type, the label system has been significantly enhanced and now provides layout functionality with embedded image support and independent sub-string formatting within a given label. In addition, this new functionality may be leveraged in all chart types, not just organizational charts.

Block Formatting and features
Now it is simple to define a block within a label and control the font type and style. Visual effects common to labels including outlines, digital readout and more are also supported using simple attributes.

Block Alignment
Alignment control enables quick and easy alignment of labels and values for example, using a common center line by right justifying labels and left justifying values.

Block URL and Tooltip Support
The addition of URL and tooltip supports enables inline links within label text. Both URL and tooltips support multiple definitions per label and support the dynamic token system for data population.

Label Image Streaming Support
In addition to path based image sources, .netCHARTING will also automatically obtain images from remote stream sources such as aspx pages. This enables simple consumption of other dynamic charts or images within a given chart.

AJAX Zooming for Mapping
The AJAX zoom and scrolling functionality added in 5.0 is now supported in mapping. In addition to client side scroll bars, users can navigate maps with the familiar click-drag interface.

Mapping line support
You can now add lines connecting points based on latitude and longitude. Maps utilizing a projection will automatically curve lines appropriately.

Mapping Shape Coordinates
The new GetShapeBounds method returns a bounding box using real-world coordinates (latitude and longitude) for a given shape or part of a map. For example, the coordinate bounding box of a state or county.

Background Transparency
Transparency can now be controlled for any background. Combined with PNG output, transparency can be seamlessly integrated with web page elements in the background.

New Visible Settings
Now it is easy to disable backgrounds and shadows as required using the new Background.Visible and Shadow.Visible properties.

Datagrid custom attribute support
Custom attributes are a powerful system for linking your own data from a database to the .netCHARTING object model. It is then simple to access these values using tokens. Now custom attributes can also be used in the automatically created datagrid with both single and multiple series sources.

GridView support
In addition to custom attribute support, the automatically data population is now supported with the newer GridView control in addition to the DataGrid control.

Access DB Support
Now the newer .accdb files are now automatically detected and supported as with the older .mdb files.

New automated msi based installer
The new installer configures samples / permissions automatically to get you up and running immediately without manual configuration required. In addition, an unpack only option is provided for remote or manual deployments, if preferred.

New in Version 5.0

Digital Readout GaugeType
A new gauge type, the digital readout or LCD display, is now supported. This can be used as a stand alone type, in combination with other gauges or even as a label style.

Ajax Scrolling implementation
.netCHARTING 5.0 adds an advanced AJAX scrolling implementation. Within an user defined viewport, users may use scroll bars or scroll arrows to navigate a larger chart view. Chart rendering occurs only as needed for the currently viewed portion of the chart. In addition to using scroll bars, users can use the familiar click / drag interface, common to mapping applications, to navigate. .netCHARTING Ajax automatically synchronizes the scroll bar positioning when utilizing click drag or scroll bars can be disabled if not required.

Ajax Zooming implementation
In addition to scrolling and click drag navigation, advanced zooming functionality is supported. Users may select from box or cross hair selections for zooming, zoom on x and y concurrently, y only or x only and navigate the zoomed view through scroll bars, click drag or both.

Ajax ToolTip display:
When in a scrolled or zoomed view, tooltip functionality is still available utilizing a transparent callback to obtain the regular element tooltip value and display this clientside on hover for the current cursor position within the chart.

Ajax Auto updating implementation
For scrolling, zooming or both, the underlying chart may now be automatically updated on a fixed interval. This update occurs in the background and the rendered sections in view are automatically and seamlessly updated without refresh in the viewport.

Interpolated value calculations
Now it is simple to obtain the interpolated value for a given x or y value with a single method call. This enables you to obtain the value between elements for example if you had data points of sales for the first of every month you can now plot or obtain the value for any day between those dates.

Axis Range adjustments on a per series basis
Now a simple setting enables you to exclude a given series from .netCHARTING's intelligent axis range calculation.

Selective default element settings
This new feature enables you to apply element defaults conditionally based on specific criteria. In such a case, only the elements matching the criteria you specify will take on the defaults defined. These smart defaults may be applied at the series or series collection levels to apply to any elements they contain.

Inverse Series Trim
Developers have come to depend on series trim as a quick and efficient way to cull data points from a given series. Now a new setting enables the inverse of series trim. For example, if you trimmed weekends for a specific chart and now wanted a similar chart including only weekends, you could accomplish this with a single line of code.

Legend box absolute positioning and sizing
The already flexible legend box has been further enhanced with the ability to utilize any size and position you wish. You may also set only the position and have the size automatically determined based on the legend box contents.

Pie chart absolute positioning and sizing
Now individual pies can be sized and positioned as you wish within the chart. In addition to layout flexibility, this allows for unique pie within slice charts and other custom compositions.

Radar chart absolute positioning and sizing
Individual radar charts can now be sized and positioned within the chart. In addition to layout flexibility this allows for unique combinations of large and small radar charts within the same chart.

Label Image Support
Any chart label can now accept an arbitrary image in place of the label text. This feature opens a new world of labeling and visualization possibilities for your charts.

Smart label absolute positioning
Now you can override the automated label positioning and specify an absolute position if required for your chart design.

Smart Label padding
Labels may now be configured with padding settings which influence the automated layout algorithms ensuring that padded areas do not overlap.

Smart Label Distance
A new maximum distance threshold for smart labels enables .netCHARTING to only render a smartlabel if it can cleanly fit cleanly within the distance threshold defined.

Mapping Label Once Option
For maps it is common to have many small land masses (islands or separated areas) that may contain the same label (e.g. country name). This option ensure that a given entity is only labeled once.

Ranged tick enhancements
When rendering in a compressed area, the new ranged tick implementation self tunes to avoid an overlap or non visually pleasing result.

Pie Labeling Enhancements
In cases where a large number of slices are concentrated in one small section of the pie the labeling system has been enhanced to ensure each can be cleanly labeled.

Multiple Palette support
With the addition of 5 color palettes in 4.4 we have seen requests for multiple palette support. This new feature enables you to add any number of palettes to a chart which will be allocated in order as required.

New shading effects
Continuing our innovative shading effects, .netCHARTING 5.0 provides brushed metal and chrome visualizations for a variety of chart types. Shading effects provide the visual impact of 3D charts with the legibility of 2D charts.

Pie Shading Effect additions
A new glow effect has been added for 2D pie charts. In addition, the new brushed metal and chrome effects are also supported on 2D pies charts.

Bubble Shading effect additions
In addition to the new brushed and chrome shading effects, a new bubble specific visualization option has been added. All three are now supported for both regular and stacked bubbles.

Background Shading additions
The powerful background object in .netCHARTING enables easy customization of annotations, boxes, title boxes and more. The new metal shading effects are now supported for backgrounds.

Thermometer shading additions
Brushed and metal shading are now supported in thermometer gauge charts.

Shaped Bubble shading support
Bubble shapes enable pictorial representations and can scale in size when used in bubble charts. Shading effects for brushed metal and chrome are now supported for bubble shapes.

Axis Tickline linecaps
Line caps are now supported on tick lines and enable enhanced visibility and improved aesthetics for specific chart applications.

Category Axis Ranged Tick support
Now ranged ticks can be easily defined on category axis, for example to select all employees from Bill to Jane. Tick index numbers may also be used to define ranged ticks.

Small Chart Optimization
A dedicated small chart mode enables very small charts ideally suited for absolute positioning and combination charts. Small charts are also useful for including in labels as part of the new image label support.

Optimized Branding Implementation
.netCHARTING is unique in that it offers free development and test licenses for webforms (asp.net) usage. The "not for production use branding" for this free license has been enhanced to ensure very small charts remain legible during development and testing.

Enhanced Documentation
In addition to detailing the extensive new features in .netCHARTING 5.0, the new documentation now includes an improved programmers’ reference which links to real world sample code.

Enhanced Performance for very large data sets
.netCHARTING is ideal for charts with large amounts of data and chart elements. The large data set handling has been further enhanced to increase performance and lower memory requirements.

New in Version 4.4

Digital Readout GaugeType
A new gauge type, the digital readout or LCD display, is now supported. This can be used as a stand alone type, in combination with other gauges or even as a label style.

Segmented Bars Type
A new bar type visualization has been added which renders bars as individual segments.

SunBubble Bubble Shading Type
A new bubble shading effect visualization has been added.

Variable Transparency PNG backgrounds.
An often requested feature, you can now set variable transparency on different charting visuals and have them apply to each other and also to the page background. For example, set the transparency of the chart background and the chart area will appear to cast its shadow directly on your web page's background.

Box Headers
All boxes now support headers which can also be customized with shading effects.

Specify Gauge Sizes
Gauges can now be arbitrarily sized independent of chart size.

Specify Gauge Rectangles (Absolute positioning)
Gauges can now be placed anywhere on a single chart area and combined into digital dashboards with many other series of different gauge types.

Label Drop Shadows
Drop shadows can now be added to all text labels and controlled for distance and diffusion.

Label Glow effect
All labels now support an optional glow effect which extends a secondary color glowing outside the original text.

Background ShadingEffectModes
Shading effects can now be applied to backgrounds to add stunning effects anywhere the background object is supported.

Digital Readout Style Labels
In addition to usage as a new charting type, you can now utilize digital readouts for regular chart labels.

Corner Support for CA
Previously supported for boxes, you can now customize the corners for chart areas. Corner options include square, cut and rounded.

Specify box & CA Corner sizes.
A new option has been added to precisely control corner size in pixels.

Element Outline control
Now you can highlight the border of elements (including 3D border outlines) with a simple property setting.

SeriesCollection.SortElementGroups
Element group sorting enables sort to consider elements that contain values from multiple series (as in the case of stacked elements). Now the total stacked value can easily be used to sort elements even if those elements contain values from other series.

Gradient SmartColors (1-20,Green-Red)
A new SmartColor addition enables seamless transitions between colors across value ranges.

Smart Minor Ticks for log scales
Intelligent addition of significant minor ticks is now supported on log scales.

ImageBars(tm) OneToOne
ImageBars now stack or expand in size to meet the required total. OneToOne support enables repeating precisely sized image bars to match to the actual chart value so in addition to using the axis you can easily determine the value by counting the number of objects drawn.

Donut Chart Support in the Multiple Chart Type
The multiple chart type provides the ability to combine types on a single chart area quickly and easily with automated layout. Donut charts are now supported in combination with other types.

5 Color Palettes
In addition to the current library of 50 color palettes, we have added 46 new 5 color palettes. These new palettes are ideally suited for charts with five or fewer series.

WinForms Mentor
The charing mentor provides useful tips during development runtime to help tune the chart and adjust settings. Previously only available in the WebForms version, support has now been added to the WinForms version.

New in Version 4.3

Linear Vertical Gauge Chart Type Added
Many new chart types have been added for version 4.3 including linear vertical gauge. From progress bars to dashboard applications, this chart type provides a high degree of customization. It also supports .netCHARTING's innovative shading effect modes to provide the polish and visual punch of a 3D chart while maintaining the legibility of a 2D chart.

Linear Horizontal Gauge Chart Type Added
In addition to vertical orientation, horizontal linear gauge is supported. Both options include axis marker support which can be used to optionally indicate value ranges.

Bars Gauge Type Added
A new bars gauge type provides quick summary and comparison of data particularly useful for polls, statistics and digital dashboard implementations.

Indicator Light Gauge Chart Type Added
The indicator light or bulb chart type allows for at a glance status charts. Lights may be shown in combination or with a single light that changes color based on the value.

Vertical and Horizontal Thermometer with shading effects
The thermometer chart type is a visual variant of the linear gauge which supports all shading effect modes in both vertical and horizontal orientations. Thermometers also include full support for the axis marker system, custom axis ticks and the ranged tick system providing even more options for data display.

Custom Image Gauge Needles
Gauge charts can now use custom images for needles. Unique to .netCHARTING is its ability to automatically color custom needles seamlessly to match the element colors used in the chart.

Radial Gauge Labels
A new gauge label mode has been added providing radial labeling for gauges.

New Chart Types: Nested Pie 2D & 3D
Nested pies (also known as stacked pies) provide a unique visualization tool for comparing related sets of data. This new type is supported in both 2D and 3D views.

Individual Pie Slice Lengths
Now individual pie slice lengths can be varied based on a separate data independent of the slice total enabling multidimensional data display.

Individual Pie Slice Heights
In addition to lengths, pie heights can also be varied opening up possibilities to show 3 data values per slice.

Nested Pie Scales
Advanced scaling options allow nested pies to render stacked or overlapping.

Pie BubbleSize based nested sizing
Nested pies can be sized based on bubble size so each pie is proportionally sized based on the series level bubble setting. This setting can be specified on a per series basis or automatically calculated based on the series total.

Nested pies Spacing Setting
Spacing for nested pies can be adjusted in both 2d and 3d views.

Image Marker DynamicColor
Advanced color replacement technology has been added to support image marker customization. Now you can provide image markers and have them dynamically colored based on the chart element color. The system supports gradients and color transitions seamlessly so you are not limited to solid color replacements.

Gauge Chart Box Settings
The power of the .netCHARTING box has been brought to the gauge chart to customize the visual container which includes the gauge.

Multi color legend box bubble, markers, and shaded bars Icons
Legend entry support has been updated to support multi color bubble, markers, and shaded bar icons.

New ImageBars(tm)
Furthering the expansive set of included image bars, version 4.3 adds bamboo, film, tomato, barrel, oil drum, gas nozzle, bricks, apple, present, paint buckets, pan, paint tube, box open and closed, glass, banana, rope, fireworks, garbage can (empty and full), up and down arrows, candy cane, paper clip, toothpaste, cup, two car perspectives and tape measure. This is the most significant template addition since .netCHARTING pioneered ImageBars(tm) nearly a year ago with the release of .netCHARTING 4.0.

New Samples, Documentation and Mentor Improvements
A huge number of new feature and gallery samples have been added as well as new documentation and tutorials. Unique to .netCHARTING 4.3 is a highly tuned set of advanced gauge samples to enable rapid development and deployment of high end gauge and dashboard solutions. The .netCHARTING mentor has also been enhanced to better offer useful tips and information for working with .netCHARTING.

New in Version 4.2

Major new chart types including Funnels, Pyramids and Cones.
Powerful new pyramid, funnel and cone charts are now supported as single charts or groups of charts within a given chart area. Funnels, pyramids and cones are all supported in 2D and 3D views with advanced shading for increased visual impact.

Stacked Bubble Type
A new charting type has been added which enables direct comparison of bubbles sized by value. Multiple shading options allow for different visualization options for this new charting type and bubbles can be shaded individually or as a whole.

Stacked Bubble Alignments
The new stacked bubble type supports stacking bubbles with center or bottom alignment.

New 3D shading support for bars, columns and Gantt charts
Shading mode 5 provides stunning visuals optimized for partial transparency with integrated highlight effects and a high degree of color constancy.

New 2D shading support for bars, columns and Gantt
Shading 5 also supports a tuned variant for 2D charts.

New ImageBars(tm)
Furthering the expansive set of included image bars, version 4.2 adds precious metals including silver, gold, platinum, and gold bars along with stacked bills (currency), batteries, binders, cake, chain, paper stacks in 3 variants (chart, plain and text), a coiled telephone wire and rope.

Bubble Shape Support
Bubble charts now support a full set of 42 predefined shapes which like regular bubbles scale in size proportional to their value.

Bubble Shape Shading
The new bubble shapes support both 2d and advanced 3d extruded modes with a flat or eye-catching shaded appearance.

Multiple Chart Type
The multiple chart type has been expanded to include support for pie, gauge and stacked bubble charts. Now cone, gauge, pyramid, pie, stacked bubble, and funnel charts can be mixed and matched and automatically sized appropriately on a single chart area.

Range Rows Limit
The advanced automated label system supports adding rows for x axis ranged labels should they be required to accurately show the values. This new property enabled you to limit the maximum number of rows the system will utilize.

Analysis Engine
In addition to the large number of statistical and final calculations added in previous versions, this new release adds the following special functions:
Bessel I
Bessel J
Bessel K
Beta
Gamma P
Gamma Q

Smart Element Grouping Control
A new Boolean option has been added to control the smart element grouping behavior.

Smart Scale Break Limit
Building on the extensive scale break support, smart scale breaks now automatically select the number of significant breaks on the chart based on data ranges. In addition, you can now limit the maximum number of scale breaks that will be automatically added by this system.

Element coordinates post render
Now you can obtain element coordinates post rendering to perform advanced drawing operations based on the elements coordinates themselves.

TrendLineLinearScatter Calculation Enhanced
This calculation now automatically supports dates for x values.

Session Streaming Support
Adding to the streaming and file based options for image display a new session streaming option has been added. This enables those users that do not have any write permissions to create a chart file to still take advantage of the built in image map and drill down functionality of .netCHARTING.

DataEngine Datagrid support
Now you can use the built in datagrid population feature of .netCHARTING with your own datagrid object when working directly with the data engine.

New in Version 4.1

Major new chart types including Funnels, Pyramids and Cones.
Powerful new pyramid, funnel and cone charts are now supported as single charts or groups of charts within a given chart area. Funnels, pyramids and cones are all supported in 2D and 3D views with advanced shading for increased visual impact.

Smarter Labels
Our innovative Smart Labels just got smarter. .netCHARTING pioneered the introduction of smart labels in 2003 and 4.1 provides significant enhancements for accuracy and performance in complex labeling cases. As always, smart labels along with the full set of enterprise level features, are included with all versions of .netCHARTING.

Smart Annotation Orientation
Complementary to the smarter smart labels, a new smart annotation orientation feature has been added which orients element annotations to minimize overlaps and collisions with important information on the chart.

Auto Label Wrapping
Now labels can intelligently wrap themselves for optimal display and positioning within a chart.

Smart Pie Label Wrapping
Pie labels have specific tuning to automatically handle wrapping to maximize the size of the actual pie chart within a chart area while still maintaining clear, legible labels.

Data Manipulation Enhancements
New options have been introduced which allow you to easily split or group data using an arbitrary TimeIntervalAdvanced object.

New Combination Pyramid and Cone Charts
New pyramid and cone types are now supported in combo charts. Combo charts are uniquely powerful in .netCHARTING due to the number of different charts they can support and enable the combination of many independent chart types in a single chart area. The pyramid type appears as a pyramid shape and behaves similar to the column / bar types.

New ImageBars(tm)
Expanding the introductory set of image bars included with .netCHARTING 4.0, version 4.1 adds sports balls including soccer, golf, football, rugby, volleyball, bowling, basketball, baseball, tennis, hockey puck, in addition a 3d dollar sign, pills, tablets, coaxial cable, phone cable, ethernet cable, wheat stalk, pipe, glass figures in blue and pink and a DNA helix.

Get Map GPS coordinates from click
Now you can return latitude and longitude coordinates from a clicked position on a map with no special coding required.

Plot GPS coordinate points on map
Plot any arbitrary latitude and longitude positions on a map. Combining with "position from click" and new map marker support you can now easily build interactive mapping applications.

Get Shapes from point on map
Easily retrieve a maps shape file (e.g. a state along with the information for that shape) by clicking on a map position or pass a position programmatically to obtain the shape.

Smart Forecast
Automated linear forecasts are now supported with the addition of a single line of code. As real-time values fill in forecast values you can still see an indicator of the forecast value both when the actual values fail to meet the forecast value and when they exceed them.

Smart Element Name Grouping
Common element names can be intelligently sorted based on their relative order in different series. This is not a sort based on element naming but rather a pattern matching system which ensures relative element ordering fits with the series element orders. For example if you had 3 series each with the following 3 elements s1:8,4,3 s2:4,3,1 s3:9,7,8 it could group them as 978431.

Smarter Scale Breaks
In 2005 .netCHARTING was first to innovate automatic scale breaks. With version 4.1 the built in intelligence for determining automatic break points has been enhanced and the support for multiple scale breaks improved as well.

LegendBox Column Alignments
Building on .netCHARTING's advanced legend box formatting options, you can now control column alignment on a per column basis to establish the ideal visual balance for your legend appearance.

Legend symbols enhanced
Line and spine with markers in the legend now color the connecting line to match marker color.

Extremely powerful and flexible XML support
Building on the previous XML support you can now obtain data directly from any arbitrarily formatted XML document without special programming knowledge required. Developers who are familiar with XML can leverage xpath to reference specific nodes to obtain data from and easily display that data using datafields and custom attributes. XML may also now be loaded directly from a file or provided as a string value without any addition coding required.

New MS Oracle Client support
Adding to the native Oracle client support already present the MS oracle client is now also supported so you can select either client to work with Oracle using the built in database handling in .netCHARTING.

Accessing Data before Chart Generation
The data pipeline has been enhanced to allow access to chart data earlier in the processing pipeline for specific usage cases enabling data manipulation before chart rendering without the use of an event or separate DataEngine object.

Easier DataSource Access
A new method has been added for data objects which enables one to get a DataSource which can be used to evaluate tokens and populate legend boxes. A datasource may also be obtained from a hittest in .netCHARTING Winforms Edition. A datasource is a special container for storing related chart data for use by the token system or consuming data within the chart such as a legend box or annotation.

Programmatic Token Replacement
Now you can replace token values in an arbitrary string using a datasource as the source for token replacement data.

Token system enhancements
New element and series tokens have been added for SeriesElementCount and ElementCount.

Round() expression
A new expression has been added so that you can round values shown in labels using the .netCHARTING token system.

Expression escape character
Now expressions can contain any text, including special control characters which were previously not available.

Compressed Vector Format support
Both PDF and SVG now support file compression to minimize download times. With PDF the compression is automated and with SVG you have the option to use the uncompressed SVG or compressed SVGZ format. Since compression is lossless in both cases, you end up with the exact same vector result with a smaller file size.

XAML official support
With the final release of .NET 3.0 official XAML support has been added to .netCHARTING 4.1. If you have the .NET 3.0 framework distribution and IE7 installed you can load XAML directly in the browser for viewing. XAML support will continue to be enhanced in future versions of .netCHARTING as more developers embrace this new format.

New ImageBars(tm)
Expanding the introductory set of image bars included with .netCHARTING 4.0, version 4.1 adds sports balls including soccer, golf, football, rugby, volleyball, bowling, basketball, baseball, tennis, hockey puck, in addition a 3d dollar sign, pills, tablets, coaxial cable, phone cable, ethernet cable, wheat stalk, pipe, glass figures in blue and pink and a DNA helix.

New in Version 4.0

New Column (vertical bar) shading
A stunning new vertical bar specific shading effect has been added. .netCHARTING continues to push visual boundaries to ensure your applications surpass even the next generation visual standards, soon to be available with new releases including Microsoft’s Vista and Apple’s Mac OS X 10.5 operating systems.

New Horizontal Bar shading
A new horizontal bar shading effect has also been added.

New bubble shading
A major new bubble shading effect has been added with a unique look and feel only .netCHARTING can provide.

New shading type support on 3D Bars
In addition to the new shading support for vertical and horizontal bars, both new and previously supported shading types are now available on the surface of 3D bars.

X and Y Axis Zooming
A compelling new axis zoom feature has been added which allows you to define an axis range which will be used for the source of a zoomed view in a second chart area. This innovative new feature can also be combined with interactive image map features of .netCHARTING for drill down zoom functionality.

Native PDF Support
An industry first, .netCHARTING supports true native PDF vector based support. While lesser vendors claim PDF support by placing a bitmap (picture) image of a chart inside a PDF container, .netCHARTING includes the actual vector data. Zoom to 6500% and see crystal clear results or print for razor sharp charts and text at any size. The included charting control automatically displays the PDF inline within the web page using the Adobe PDF viewer with the window sized as chart size. As always, all features of .netCHARTING 4.0, including high end native PDF support, are available for all 4.0 license holders. This functionality is accessible with the $395 web site license.

Native Flash (SWF) Support
In addition to native PDF native Flash (SWF) has been added. The integrated charting control automatically renders the container so browsers display the chart inline as a native vector image. It has never been easier to right click, zoom, click and drag charts to view the smallest detail. Vector support with small file size: flash is a powerful Enterprise level addition to .netCHARTING 4.0.

Native SVG Support
The new vector support is extremely comprehensive and includes SVG (Scalable Vector Graphics) as well. The control automatically renders with the html required to view the chart using Adobe's SVG viewer and it will also prompt to download and install the plug-in if required.

Native XAML support (beta)
.netCHARTING is future proof. Even before the public release of XAML, (the next generation vector format for Windows Vista / Windows Presentation Foundation) beta support has been added. As the specification and development tools finalize for this new technology it will immediately be fully supported.

ImageBars™
.netCHARTING continues its tradition of breakthrough innovations with the addition of ImageBars™, which provide stunning themed, pictorial representations in bar form.

Horizontal Image BarsNew Column (vertical bar) shading
A stunning new vertical bar specific shading effect has been added. .netCHARTING continues to push visual boundaries to ensure your applications surpass even the next generation visual standards, soon to be available with new releases including Microsoft’s Vista and Apple’s Mac OS X 10.5 operating systems.

New Horizontal Bar shadingNew Column (vertical bar) shading
A stunning new vertical bar specific shading effect has been added. .netCHARTING continues to push visual boundaries to ensure your applications surpass even the next generation visual standards, soon to be available with new releases including Microsoft’s Vista and Apple’s Mac OS X 10.5 operating systems.

New Horizontal Bar shading
A new horizontal bar shading effect has also been added.

New bubble shading
A major new bubble shading effect has been added with a unique look and feel only .netCHARTING can provide.

New shading type support on 3D Bars
In addition to the new shading support for vertical and horizontal bars, both new and previously supported shading types are now available on the surface of 3D bars.

X and Y Axis Zooming
A compelling new axis zoom feature has been added which allows you to define an axis range which will be used for the source of a zoomed view in a second chart area. This innovative new feature can also be combined with interactive image map features of .netCHARTING for drill down zoom functionality.

Image Bar Templates
.netCHARTING commissioned a group of professional artists to create 30 image bar templates and all templates are included with .netCHARTING 4.0 at no additional charge. More image bars will continue to be added in future releases. If you have an idea for a new image bar please email the .netCHARTING team.

New Mapping Chart Type
A massive new feature of .netCHARTING 4.0 is comprehensive mapping support. You can now create a map using only 3 lines of code. Yet don’t let the ease of simple mapping mislead you, .netCHARTING’s SmartMap™ functionality provides power and intelligence never before seen in chart based mapping.

Support for Maps with multiple Layers
Maps support unlimited numbers of layers and can accept real data, readily available online, for the entire globe.

Satellite and composite image layer support
Combine satellite and aerial photography (orthophotos) with your own map data and other mapping layers on a single map surface.

Custom Map Shape Styling
Style map shapes with background images, line and label options, custom fills and images.

Thematic Mapping
Display large quantities of spatial data quickly and easily. Supports color coded ranges as well as custom markers based on data values.

Map Zooming
Show multiple views of the same map with zoomed areas. True vector source and industry standard format support allow for highly detailed maps from the global level down to a single property lot.

Projection Support
Maps are a 2D representation of the Earth’s surface, which is a sphere (or more correctly a geoid). Using projections you can modify the map view to suit customer expectations. Lambert Conic and Mercator Projections are supported in addition to an unprojected view.

Map Attribute DataBinding
SmartMaps™ seamlessly support obtaining attribute data, including labels and other data such as population, length, area and much more. Map attribute databinding allows for quick and easy display of this information in tooltips or even on the mapping surface directly.

Custom Map DataBinding
In addition to data contained within the map itself, you can bind your own custom data from your own database to the map. You can also easily combine map data and your own data on the same map surface.

Programmatic Map Shape Access
Maps are created from points, lines and polygons which can be accessed programmatically. The attribute data associated with such shapes can also be accessed in the same way. Easily tune map elements in code with an easy to understand object model.

Shape Group labeling and styling
Shapes can be combined into groups for the purposes of group labeling or styling based on specific attributes.

Label Outlining Support
Supported in all chart types for all labels, the new label outline system provides enhanced clarity for labels over busy or image backgrounds. This feature is particularly well suited for the new mapping functionality in .netCHARTING 4.0.

Enhanced pie and bubble shading
Current pie and bubble shading has been enhanced. We are totally committed to ensuring the highest visual standards and frequently revisit old features to improve them in addition to innovating with totally new features.

New Pie Bubble shading support
Now you can apply bubble shading effects to 2d pie surfaces for stunning and highly legible pie charts. Enhancing visual impact without negatively impacting chart clarity is something which is carefully considered with every new feature or update.

New File Handling Features
Building on the advanced streaming and automated file handling of previous versions, .netCHARTING 4.0 adds the ability to access any chart as a memory stream without saving it to disk. In addition, the FileManager now handles saving streams automatically.

Event Handler Added
A new OnErrorProcessing event allows special actions to be taken in the case of an error condition with the chart execution.

Native Oracle support *
Due to popular demand native Oracle support has been added to .netCHARTING. Now you can connect to your Oracle databases with the built in series data access system and run all samples against Oracle as well. Of course, the powerful DataEngine is still available to utilize .netCHARTING with any database quickly and easily.

Native MySQL support *
Support was added for MySQL databases directly into the integrated DataEngine and Series level database properties.

Native ODBC support *
In addition to Oracle and MySQL ODBC support was added enabling quick and easy integration with legacy database systems.

New multi-database sample system *
With the extensive new database support, .netCHARTING samples and associated database information can easily be generated and samples switched from the included MS Access database, to your own SQL server, MySQL or Oracle database with a single line of code. Now you can evaluate and work with the complete and powerful set of .netCHARTING samples using your preferred database backend.

Chart Click to Axis Values
A single click on the map now provides actual X,Y values which can be used for interactive charting applications. In addition, axis markers can be used to identify the specific point selected by the user for real-time visual selection feedback.

SmartColors for value ranges
Value ranges define a range of elements that fall within a specific minimum and maximum value. Used in combination with SmartColors, .netCHARTING can easily modify colors based on the range. This feature is ideal for highlighting outlier points or chart data that beats or falls lower than expected estimates.

Label Hotspot Support
Hot spots are now supported for labels in addition to the chart elements they represent. This is particularly useful for cases with small elements that are not easy to mouse over, such as very thin pie slices.

StepLine Chart Type:
Samples are now included demonstrating creation of StepLine charts.

Financial
Expanding the comprehensive selection of financial indicators added previously, version 4.0 adds the following:
PlusDirectionalMovement
MinusDirectionalMovement
TrueRange
DirectionalMotion
DMI signal
Kurtosis
Skewness

Statistical Engine
In addition to the significant number of statistical calculations added in previous versions, this new release adds the following:
Kurtosis
Skewness
TrendlinePolynomial (Enhanced)

New Samples and Documentation
A huge number of new feature and gallery samples have been added as well as new documentation and tutorials.

*Features available with .NET framework 2.0 only.

New in Version 3.4 (12/01/2005)

Powerful New Combination Charts
.netCHARTING has always maintained some of the most advanced and flexible combination chart options (enabling different series chart types to display together on the same chart area). Version 3.4 greatly expands on this flexibility with horizontal combination support for marker, line, spline, bubble, area line, area spline, financial bar, candlestick and more in both 2D and 3D modes.

Shading Effects Supported in 3D Charts
.netCHARTING’s advanced shading effect support provides stunning visuals for 2D charts. Now this support has been added to 3D charts as well, where the effect will apply to the surface of the chart element.

Multi-Pie Labels now have Token Support
Token support has been added for multiple pies enabling run time replacement of token values and custom string manipulation.

New Chart DPI Setting
Setting chart DPI allows one to generate a larger, higher resolution chart image file which is more suited for printing.

Maximum Bubble Size Supported
Now you may set a maximum bubble size and have all bubbles in the chart scale proportionally relative to the maximum size.

Statistical Engine
In addition to the large number of statistical calculations added in previous versions, this new release adds the following:

Control charts:

  • DataDistribution
  • Rchart
  • Schart
  • Runchart

Probability:

  • Exponential distribution
  • Log normal distribution
  • Normal distribution

Financial Indicators
Expanding the rich selection of financial indicators added in previous versions, version 3.4 adds the following:

  • Finite impulse response
  • Market facilitation index
  • Price action indicator

New in Version 3.3 (7/27/2005)

Scale Break Styles
.netCHARTING’s innovative scale break feature has been enhanced to support a number of different styles including: gap, line, zigzag and none. In addition, a line object can be specified to control all aspects of the line formatting, color, size, dash style and more.

Weekend Calendar Pattern Support
Calendar patterns are unique patterns to identify specific date ranges or calendar periods. With the addition of a predefined CalendarPattern.Weekends option you can quickly and easily remove all weekends from your chart (for example) which is a common case in the financial industry.

Scale breaks based on Calendar Pattern
Now it is simple to apply scale breaks based on calendar pattern with the new Axis.ScaleBreakCalendar pattern property.

Arithmetic Expressions in Labels
Now you can perform common expressions directly within labels using values from template tokens. For example 100-%YValue to show a label calculated as 100 minus the total for that elements Y value. In addition, a new formula token has been added which enables simple addition of trend line formula in labels.

Less Intrusive Chart Mentor
The chart mentor provides usage tips based on the settings you are using in a given chart. This mentor has been enhanced to take less space and also supports a seamless ‘hide’ option. As always, the mentor is disabled when the mentor property or the debug property is set to false.

Post Render Box Positioning
.netCHARTING now exposes the exact position of any box after rendering. This enables advanced users to perform custom drawing based on the specific positioning of boxes.

Enhanced Smart Label Alignment
Smart Label Alignment support has been expanded and is now supported for all series types.

New Label Options
Labels can now be centered on elements and the label contrast for labels on top of columns has been improved.

2D Line Series Gradients
Like 3D lines and area lines before them, 2D lines now support seamless gradient transitions between colors.

New Chart Types – 3D Spline and 3D Spline Area
Support has been added for 3D spline and spline areas with enhanced visuals.

New Spline Tension Support
In addition, both 2D and 3D splines now support customizable spline tension settings on a per series basis.

New Background Mode
Brush mode enables a custom brush to be used for a background fill.

SaveState / LoadState
The chart object can now be saved to XML at any point and later restored. This powerful new feature is ideal for templating cases or for sharing a common set of properties among many charts. Options include saving to a string or file on disk. This feature can also be used to save and restore data that does not change such as last years sales data to enhance performance.

New DataField Support for ErrorData
Enhanced parsing and new mappings have been added enabling automatic population of : ErrorHighValue, ErrorLowValue, ErrorPercent, ErrorPlusPercent, ErrorMinusPercent, ErrorOffset, ErrorPlusOffset, and ErrorMinusOffset.

New TimeInterval Support
Minute (Minute by seconds) and Seconds support has been added along with corresponding samples.

Automatic DrillDown Enhancements
Enhanced to enable various international date time formats and support seconds.

Data input XML support enhanced
In addition to the previous support for XML datasets the data property now also accepts XML with attribute and node based data.

Forecasting Engine
The forecasting engine is a subset of the statistics engine and includes advanced forecasting capabilities including:
- Exponential Fitting
- General Linear Trend Line
- Logarithmic Fitting
- Non-Linear Trend Line
- Power Fitting
- Straight Line Fitting

Statistical Engine
In addition to the huge number of statistical additions added in the previous version, this new release adds the following:
- EstimateX
- EstimateY
- Simple Moving Average
- Residuals
- ResidualsAverage

Financial Indicators
Expanding the rich selection of financial indicators added in version 3.2, version 3.3 adds the following:
- ChaikinVolatility
- CommodityChannelIdxOverPeriod
- CrossingExtremeSignal
- CrossingSignal
- DStochastic
- Extreme Value D Signal
- Extreme Value K Signal
- K Fast Stochastic
- NegativeVolume Index
- OnBalanceVolume
- PositiveVolumeIndex

New in Version 3.2 (4/11/2005)

Polar Chart Type
Complete support for polar charts has been added including advanced rendering support for interpolation of data points when using a quantitative axis.

Statistical Analysis
Advanced statistical calculation support is now built in to .netCHARTING including

  • Bollinger Bands
  • C Frequency Table AOL
  • C Frequency Table AOR
  • C Frequency Table BOL
  • C Frequency Table BOR
  • Correlation Coefficient Determination
  • Exponentially Weighted Moving Average
  • Frequency Table OL
  • Frequency Table OR
  • Geometric Mean
  • Geometric Moving Average
  • IQR
  • Kairi
  • Kendall Correlation Coefficient
  • Least Squares Estimate X
  • Least Squares Estimate Y
  • Linearly Weighted Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Pearson Correlation Coef
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • R Frequency Table OL
  • R Frequency Table OR
  • Simple Moving Average
  • Spearman Rank Correlation Test
  • Standard Deviation
  • Statistical Median Moving Average
  • Triangular Moving Average
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average
  • Z Score

Financial Indicators
All major financial indicators have been integrated and samples added for advanced multiple chart area financial and stock charts. Indicators include:

  • Accumulate Distribute Over Period
  • Aroon Down
  • Aroon Down Over Period
  • Aroon Oscillator
  • Aroon Oscillator Over Period
  • Aroon Up
  • Aroon Up Over Period
  • Balance Of Power Over Period
  • Bollinger Bands
  • Chaikin Money Flow Over Period
  • Chaikin Oscillator
  • Commodity Channel Idx Over Period
  • Exponentially Weighted Moving Average
  • Financial Z Score
  • Geometric Mean
  • Geometric Moving Average
  • Inter Quartile Range
  • Kairi
  • Linear Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Median Price
  • Momentum
  • Money Flow Idx Over Period
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • Simple Moving Average
  • Standard Deviation
  • Triangular Moving Average
  • Typical Price
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average

Stacked Radar Columns
In addition to polar chart support, radars have been enhanced with support for the stacked axis scale.

Radar Axis Enhancements
Now radar charts have complete support for date and numeric x and y axis.

Radar Axis Orientation
Radar charts now supports orientation angle and XAxis markers.

Calculated Axis Ticks Shortcut
A new shortcut method has been added to enable quick and easy addition of calculated axis ticks -- for example a tick for a series average.

Axis Marker Bring to Front
A new property has been added which will enable you to bring a given axis marker to the front; automatically placing other chart elements behind it.

Radar Gridline Support Enhanced
Alternating gridline colors are now supported for radar X Axes.

DataEngine Support for xmlDoc
xmlDoc is now supported as a data source when using the Data property.

Include Grouping Data in Sub Values
A new feature has been added to automatically populate sub values based on the original values grouping calculations are made from. For example, if grouping by month a number of data points may be aggregated for that month. When enabled this feature will populate the sub values for that month so the individual values that makeup the element could be shown in addition the element total.

Automated Multiple Series Drilldown Support
A new feature has been added to support drilldown into multiple series for
all date grouping levels. This option determines if drill down occurs into
individual series or the series grouping. When drilling down into a series
grouping all available series will be shown in each hierarchy of the
drilldown chain.

Advanced Limit Support
Now limit can be bound to a specific series. When using this feature first
the series will be limited based on the specified value, then .netCHARTING
will automatically match any remaining series to that limit order rather
than limiting for each series independently.

DataEngine Enhancements
GetSeries now handles Boolean for xAxis or xAxisStart when loading from a
database. Also, GetSeries has been enhanced to support display of full
months of data when using irregular StartDate and EndDate values (mid-month
for example).

Minor Tick Control

New in Version 3.1 (2/25/2005)

Element Marker Visibility
You can now adjust the visibility of element markers with a single property setting allowing control at the chart, series or individual element level.

Minor Tick Control
The addition of Minor tick marks was well received in version 3.0, now in 3.1 complete control over minor ticks has been provided. In addition a new smart minor tick implementation has been added which automatically determines an ideal minor tick interval based on the major tick interval used. As always, automated settings can be overridden providing an high level control over the appearance and functionality of any given chart.

Smart Scale Breaks With Markers
.netCHARTING’s innovative smart scale break technology has been enhanced to work seamlessly with axis markers.

New Chart Mentor
The chart mentor offers useful tips and samples based on the chart you are creating. It can help you resolve problems and improve the implementation of your chart in the most efficient way.

Specify Line cap scale
The relative scale of the line cap (based on line thickness) can now be set.

Printer Optimized Text rendering
A new setting is available to automatically optimize text output for printing.

Multi-Color Legend Entry Support
When legend entries represent a series containing multiple elements with different colors legend entries will now show with the first 3 colors to ease identification.

Enhanced Token Support
Value tokens can now be used in axis ticks with value axes. In addition, the Xvalue token now automatically populates using Name if another value is not provided. Tokens can now be escaped or excluded by prefixing them with a forward slash.

Gridline defaults in Calculated Axes
Calculated axes now draw gridlines without alternating fills to enhance readability.

Error Bar and Error Value Support
Complete support for error bars and values has been added along with support to automatically populate element error properties from your own database. As part of a comprehensive system for representing errors in collected data, .netCHARTING now supports multiple sub values with rendering as error bars, lines and markers.

HTML Event Attributes
A complete system for adding HTML event attributes has been added. Now you can easily define custom DHTML tool tips, use JavaScript alerts and message boxes, set the status bar text and even define your own custom handling client side handling with ease.

Series Collection Saving and Loading
Enables saving a series collection to a file and later restoring it. This can be useful for reusing common sets of data and also for debugging and troubleshooting to provide test data to support.

Arbitrary Tick Addition
A new shortcut method has been added which enables you to add a list of arbitrary ticks to an axis using a single line of code.

Enhanced Range Tick Rendering
The ChartEngine has been enhanced with regards to ranged tick rendering to ensure optimal spacing and alignment regardless of usage scenario. In addition, ranged ticks can be tailored to your specific needs with advanced interval support, along with line and label customization.

Additional FormatString support
Format strings are used by .netCHARTING to take inputs, such as dates, and format them into different string representations. New custom format string support has been added for Q which returns quarter numbers and O which returns ordinal numbers (1st, 2nd, 3rd etc.) for both numeric and date values.

Axis Tick Label Angle
Axis ticks are angled if they would otherwise overlap when rendered parallel to the axis. You can now provide a custom angle for labels to use.

Duplicate Axis Support
In addition to the extensive calculation support which enables axis to be calculated and converted using hundreds of built in unit conversions, .netCHARTING now also supports duplicate axis. These axis are the same as the original and are useful when you wish to have the same axis on both sides of a wide chart. In this way, one can read values off the closest axis to the element they are interested in.

Color From Settings
Using built in palette support colors are often automatically assigned by the ChartEngine. New shortcut properties have been added to set colors of series or elements from other series or elements. This can be useful when manually adding calculated elements, for example, and wishing the color to synchronize with a given series.

Time Label Automation
A unique feature which quickly, intuitively, and with a minimum of labels, conveys time related data on the axis. For example when showing 26 months it is not necessary to repeat the year for every month. In this scenario, the automation feature will automatically render relevant data across “significant date” boundaries. Used in conjunction with ranged tick support Time Label Automation provides a stunning, easy to read, axis that elegantly handles continuous date ranges using indicator arrows.

Additional Data Engine DataType Support
The DataEngine.Data and Series.Data properties now support all objects that implement IEnumerable, ArrayList and HashTable. This enables nearly any data source to be bound to the chart with a single property setting adding to the currently supported DataTable, DataSet, DataView, DataReader, XML and Excel types.

Simple Series Creation per Column
New DataFields support enables the addition of multiple series from a single table using one line of code. With this addition, multiple YValue data definitions are supported in which case each will automatically generate its own series.

Total Series and Total Elements Support
New properties have been provided to return the total series and element counts to aid simplified paging through chart data.

New in Version 3.0 (11/18/2004)

Multiple Chart Area Support
Now you can have multiple independent chart areas within a single chart image. Advanced automatic alignment functionality enables a single axis to span multiple chart areas and automatically align with each other. Now creating perfectly aligned charts with a shared axis is quick and simple. Chart areas can be sized, relatively, by percentage and orientated within a grid layout.

Automatic Drilldown into “Other” data
.netCHARTING offers the ability to limit elements and new series created by its unique SplitBy technology. The result is the automatic creation of an “other” series which contains all data not included in the chart as a single element or new series. Now you can automatically drill down into this “other” data. New limit modes have also been added in addition to limiting the return to the Top x values you can now limit to bottom, exclude top and exclude bottom as well.

Axis Minimum and Maximum support enhanced
Now you can set minimum and maximum scales for log and time scale axis.

Log scale now supports any power
Now you can set the logarithmic base to any power in addition to the default log 10 support. For example base 2, base 5 etc.

Axis Minimum Interval
Set a minimum interval to ensure that the axis does not scale below your unit of business. For example, if you sell units which can not be divided, now you can ensure the axis will at minimum increment by one.

Inverted Scale Support
Creating inverted charts has never been easier! By selecting the inverted scale you can now draw charts from the top down.

Automatic and Custom Time interval Support
Now you can set custom axis intervals even while using the time axis. In addition, the automated interval system has now been enhanced for time axis.

Arbitrary Ticks and AxisMarkers can now affect scale range
.netCHARTING has intelligent automatic scale generation to select the best range possible based on the chart data. Occasionally you may wish axis ticks or AxisMarkers to be included in the automated scale range calculation. Now you can ensure important ticks or markers are always included in your scale with a simple setting.

Smart Scale Breaks
Often a chart has a few outlier data points which result in charts that are not legible for the bulk of the data. For example, if you had a chart of 100 values between 1 and 10 but 2 of the values were over 1,000 you could not accurately determine the values due to a compressed scale. Smart Scale Breaks automatically break the scale to cut out large unused sections so both lower and upper values can be clearly read.

Scale Breaks
In addition to Smart Scale Breaks regular scale breaks can be defined if you wish to break the scale at any arbitrary point.

Element, Axis Marker and Arbitrary Tick Support
Now you can define arbitrary tick marks on the axis with their own gridlines. In addition ticks can be defined for specific elements and axis markers.

Ranged Tick Support
An axis tick typically represents and labels a single value on an axis. Ranged ticks show a range of values on the axis, and are also known as an axis group. For example on a chart of months you could have 12 ticks, one for each month and then 4 ranged ticks showing each quarter. Ranged ticks could also be used to highlight specific data in conjunction with Axis Markers.

New Tick Formatting Options
Now you can set Color, Font / Tick Line & length and Grid Line on a per tick basis.

Axis Tick Ranged Overrides
You can also modify the settings of a range of ticks by value to affect tick formatting for a subset of individual axis ticks.

Image Tick Support
In addition to text or label based ticks you can use images in place of tick labels. For example, you could use a countries flag in place of country name on an axis.

Axis Label and Tick Alignment
New alignment options enable labels and tick alignment to be adjusted to suit your specific needs.

New Axis Orientation
Axis can now be displayed on the top of charts rather than the bottom which is the default. You can also now have multiple axis on the left, right, top of bottom of the chart!

Axis Label Token Support
Now .netCHARTING’s powerful token system can be used in Axis Labels enabling you to dynamically change axis labels based on token values.

Radar Charts Enhanced
Now with multiple radars each radar can have its own axis. In addition, time axis and bubbles are supported on radar charts.

Scatter Charts Enhanced
All series types are now allowed on scatter charts in addition to the previously included bubble and marker support.

Financial Charts Enhanced
Now financial chart types may be used in combination charts and powerful multiple area support provides increased power and flexibly for financial charts.

New Label Alignment support
Now you can adjust label alignment for labels including chart area, title, axis and axis marker labels.

Legend Box Enhancements
Massive enhancements have been made to the legend box including the ability to sort entries, show divider lines between entries, add headers, and add formal legend entries on a per entry basis. Legend boxes can now be positioned arbitrarily on the chart surface, even inside the chart area and can be orientated anywhere around the chart using predefined settings. Multiple legend boxes are now supported with the ability to add entries to any given legend box.

Custom Attribute support for Legend Boxes
In addition to the powerful new visualization options for legend boxes a new data subsystem has been added which supports tokens and custom attributes support. This means you can have your own custom data pulled from a database or set programmatically display in the legend box with ease.

Background Shading Effect
A new background specific shading effect has been added.

Calendar Pattern Support
Now you can define custom calendar patterns to implement axis markers or trim data. Calendar patterns will enable you to highlight a specific event or region of your data which re occurs including marking weekends or other recurring events.

PostDataProcessing Event
A new event has been added which enables developers to programmatically manipulate chart data after it has been processed by the DataEngine but before the chart has been rendered.

SeriesCollection.GetProcessedDataTable
A new method has been added which returns a dataTable of the processed data. This is useful to access the data for other purposes after the ChartEngine has processed it.

Start Date of Year
In addition to the ability to determine the start day of the week for automated week grouping functionality of the DataEngine, you can now use StartDateOfYear to control month start for years and quarters.

New in Version 2.5 (6/14/2004)

Custom Element Attributes
Now you can define any number of custom attributes for your chart elements.
In addition to the extensive built in element attributes such as color, font, line, transparency values, URL and many others, you can set your own custom values to be stored on a per element basis. Enhanced template support enables you to utilize your own custom data in any property that supports element templates such as annotation, URL, tool-tip, and name.

Gauge and Dial Charts
A stunning new gauge / dial chart type has been added. In addition to supporting a single chart, multiple gauges can be added for instant executive dashboard implementations. Many advanced features are supported with this new type including quarter, half or arbitrary sized gauges, with and without clipping, and 3d highlight effects.

Axis Label Marker Support
The new gauge type supports addition of a custom marker on the gauge face using this property.

Cleanup Minimum Age
Continuing the enhancement of the automated cleanup functionality available since the first version release, you can now specify minimum age to prevent deletion of specific files until they reach this age, for example, 30 minutes old.

Date Grouping Calculation Support
The date grouping functionality allows data to be easily grouped by date classes such as months, days, hours, years, quarters etc. It allows the same data to be visualized different ways with no custom programming required. Previously .netCHARTING would automatically aggregate (sum) values but now extensive arithmetic operations are supported including average, minimum, maximum and many more.

New Color Token
Building on the powerful token system a 'color' token has been added. This powerful new feature enables you to maintain color synchronization in drill down charts with ease. In addition, the built-in automated drill down now automatically supports this feature.

ImageMap and ImageMapName Exposed
For those clients that demand complete control .netCHARTING does not disappoint. Version 2.5 exposes the ImageMap text and ImageMap name which, used in conjunction with FileManager, allow you to customize images and independently assign image map data generated by the chart engine.

Per Element Hatch Style Support
Now you can customize elements with hatch styles, ideal for differentiating elements for black and white display or for those who are color blind. In addition to the specific hatch pattern used, you can also define element specific hatch coloring which can be set independent of the item color.

HatchStyle Palette and HatchStyle Palette Name Support
To complement the extensive per element hatch style support, .netCHARTING now provides the ability to define custom groups of hatch styles which are assigned, in order, to elements / series just as a color palette assigns colors. In addition, 5 predefined hatch style palette names are included to quickly and easily assign unique hatch styles using a single setting.

Series Background Support
A new background option has been added for series. This enables powerful background options for the new gauge / dial charts. For example, you could place a photograph of a real gauge in the background and have the needle be set dynamically based on the provided value. .netCHARTING will seamlessly merge the generated needle and background for photorealistic gauge renderings.

Annotation Text Alignment
New alignment support enables you to directly control the alignment of annotations in both the horizontal and vertical directions. Alignment options include left, right, center, top, bottom and middle.

Tiff Image Format Support
Now you can output 'lossless' tiff files with a simple property setting.

Vector Based Image Support
Have you wanted to print massive charts or zoom into the smallest detail without loss of quality? Now you can with native vector image support. Output charts as Enhanced Meta Files (EMF) and scale as large as you wish.

Series Collection Sorting
Now with a single method call you can sort series within the series collection. This new feature is particularly useful for 3D charts where it is advantageous to sort series in order to aid aesthetics such as a 3D area line chart (where keeping smaller series at the front enables them to be seen clearly).

Series Area Line Label Enhancements
Now series area line labels support label alignment similar to the new alignment support added to annotations.

Developer Version SmartBranding Added
The fully functional free developers version is branded not for production use. Typically this does not affect chart elements however with very small charts common in executive dashboards the branding can obscure part of the chart. With version 2.5, .netCHARTING will intelligently vary the branding transparency in such cases to ensure the chart can be visualized effectively in all scenarios.

Enhanced Annotation 'CallOut' Support
In addition to the previously supported top left, top right, bottom right and bottom left callout positioning, annotations now support callouts from the left, right, top and bottom. Combined with the new annotation text alignment features and advanced token system there are thousands of annotation variations now possible.

New in Version 2.4 (4/14/2004)

Custom Element Attributes
Now you can define any number of custom attributes for your chart elements.
In addition to the extensive built in element attributes such as color, font, line, transparency values, URL and many others, you can set your own custom values to be stored on a per element basis. Enhanced template support enables you to utilize your own custom data in any property that supports element templates such as annotation, URL, tool-tip, and name.

Date Grouping Sort
A new option for date grouping is now provided to control the sort order behavior. Date grouping is a powerful feature for grouping values into specific date ranges such as years, quarters, months, days and more.

Data Grid Header Template Support
In addition to stunning chart images, the data represented in the chart can be displayed automatically in a data grid in tabular form. This is useful for meeting accessibility requirements and easily allowing users to copy chart data as text. Now you can have the header set automatically based on chart data with new template support. This is particularly useful for drilldown charts or any chart where data changes dynamically.

Label trimming
Advanced label trimming has been added, allowing you to finely tune the visuals of labels that are too long to display well on the chart. You can now set a maximum length for labels, control the string used to terminate a truncated value e.g. "this is a long." and determine if labels will be truncated from the start, middle or end.

Simple database connectivity just got simpler
Now you can specify the file name of your access database or excel spreadsheet and .netCHARTING will be able to produce stunning charts from it directly with no complicated connection string or additional technical requirements.

Chart URL Mapping Enhanced
Define chart level URL for any surface of the chart to have a hyperlink while maintaining the functionality of any higher level hyperlinks that may be set for elements, legend entries, annotations and more.

Empty Element Handing for DataGrid Values
.netCHARTING has built in support for empty elements and can represent them in a number of different ways visually, or via labels. Now, when empty elements are included in a DataGrid view of your chart data they are seamlessly replaced with your own custom text value as defined with EmptyElementLabel.

Axis Label wrapping
Labels on both the X and Y axis can now be set to automatically wrap horizontally, display on an angle or display perpendicular to the axis.

Axis Label Separators
To make the separation between tick marks clear, particularly when the new wrapping functionality is used, label separators can be added. Options are provided to control the line, style and color for such separators.

Axis Label Rotation
Now you can rotate the Y axis label to read either bottom to top or top to bottom. The ChartEngine will also automatically select the most appropriate setting for each axis if not overridden.

New Palettes
Many new palettes have been added allowing you to chart with a variety of color schemes using one simple setting. As always, you can create your own palettes as well as set palettes at a chart or series level.

Enhanced documentation and Samples
More resources are now available to help you get the most out of .netCHARTING!

New in Version 2.3 (2/19/2004)

Advanced Empty Element Handling
Empty elements have always been handling intelligently and treated differently from 0 elements by .netCHARTING. An empty element is an element with no value which the chart will automatically render breaks for in lines and area lines. New features have been added enabling you to control how empty elements are displayed with custom markers, styles, lines, color, text notation and more! Empty elements may now also be replaced, automatically treated as zero, filled or ignored.

Multicolor Area Lines
This unique feature allows area lines with multiple colors to seamlessly blend together providing powerful visual queues in the chart image.

Annotation Support
A powerful new annotation system has been added which allows for custom messages to be displayed on the chart surface. Annotations may be attached to any element with custom orientation, made clickable and also display tool tips. Annotations accept tokens which are automatically replaced by chart data on the fly from series, axis or element information. Pure image annotations are also supported allowing for image layering with variable transparency.

Bitmap Image Access
To aid in simplified integration with reporting and PDF tools .netCHARTING now has a simple method for obtaining the entire chart as a bitmap.

Advanced Post Processing Support
You can now get the chart image in a bitmap with one simple step allowing for powerful post render operations on the chart. Calculated coordinate information is returned for chart elements allowing for powerful custom image post processing and a simple method is provided to automatically save the file for output.

Legend Image Support
Along with the chart image, you can now access the legend as a separate bitmap. This allows you to use the chart and legend images independently and reference them directly in your page for even more flexible layouts.

Fixed Column Width
By default column / bar width is automatically determined based on the number of elements and size of the chart created. You can now specify a fixed width which is useful when you want a consistent size in different charts or with drill down.

Ranged Area Line
The ranged chart type enables you to set start and end values for a chart. This powerful charting type previously available for other types is now also supported with area lines.

Enhanced Pie Labeling
With .netCHARTING Image is Essential and pie labeling has been further enhanced to ensure optimal alignment.

Enhanced Hotspot Support:
Now even the smallest values are accessible for drilldown, hyperlink or tool tip support with enhanced hotspot support.

Background Bevel Shading
A stunning new background option is supported which creates an attractive bevel on any background.

New Palettes
Additional predefined palettes have been added allowing for simple selection of attractive color schemes. Palettes can be set at a chart or series level (in which case each element takes on a palette color)

New Samples and Documentation
Many new samples have been added and documentation has been enhanced.

New in Version 2.2 (10/29/2003)

Series and Element Level Legend Entries
Now you can easily add legend entries for individual elements or series and control all aspects of legend entries individually. Legend entries can also be removed with a new visible property setting.

Legend Entry ToolTip and DrillDown Support
Legend entries may now be used for tooltip (showing additional data on mouseover) or drill down functionality.

Series Level Palette Support
A new PaletteName property at the series level allows you to have colors assigned on a per element basis within a series with one simple setting. Ideal for creating high impact single series charts the new system also automatically adds legend entries for each element rather than for the single series in such a case.

Axis Tick Label Templates
The powerful .netCHARTING template system has been extended to support full tick label templates. Now you can format and display your data in tick labels exactly as you please.

Enhanced Element Template System
The element template system has been enhanced with many more data values now available for use throughout .netCHARTING.

Format on the fly in Templates
On the fly formatting enables you to embed format string settings for a given template token to ensure the data is represented exactly as you want it without requiring manual formatting.

Automated Series Sorting
Now you can sort elements within a series with a simple method call.

Data Trimming based on set ranges
This powerful new data manipulation method enables you to remove elements outside a specific date or number range.

Series data manipulation with operators
Now series and elements can be manipulated programmatically with arithmetic operators. Add, subtract, multiple and divide any series or element with any other or fixed numbers.

Automatic axis number precision
When the tick mark interval is less than one .netCHARTING will now automatically set the appropriate level of precision for axis numbers.

Enhanced Design Time Support
Now supports declarative code generation and new properties editor GUI sections for customizing chart options. In addition, changes made to the declarative code directly will be reflected in the designer environment.

Selectable First Day Of Week
.netCHARTING's built in date grouping and DataEngine support has further been enhanced with a user definable start day of week. This new setting allows weekly data to be grouped correctly, exactly as you wish, be it Sunday to Saturday, Monday to Sunday or any other permutation.

New Clear Color Settings
New shortcut settings enable the colors to be cleared with a simple property so they may be selectively enabled in a customized fashion.

New in Version 2.1 (9/30/2003)

New Bar Visual Effects
Two stunning new visual effects have been added for 2D bars. These unique visuals add a 3D visual punch to 2D charts. Now you can satisfy your clients with a stunning 3D effect while maintaining the ease of readability you have come to expect from 2D charts.

Enhanced Image Map Support
Image map render order has been improved to more eloquently handle overlapping conditions.

New Bubble Visual Effects
Two new bubble shading options have been added to provide your charts even more visual punch.

Shaded Legend Icon Support
Legend icons are now synchronized with the chart element's shading effects allowing for quick and easy identification of an element from its legend entry.

Maximum Bubble Size Control
You can now control the maximum bubble size and have all bubbles rendered relative to this maximum size.

Per element label controls
Now labels can be controlled on a per element basis with settings for color, font, size, alignment and more!

Enhanced Smart Label Functionality
The label system has been enhanced dramatically and now supports conditional label inclusion depending on spacing, forced label rendering, set vertical rendering and control over label alignment.

Enhanced documentation and Samples
More resources are now available to help you get the most out of .netCHARTING!

New in Version 2.0 (8/11/2003)

Drill Down Support Enables "Clickable" Charts
Complete drill down support is now provided with advanced automatic drill down functionality using our own unique date grouping functionality. Now you can create multi level drill down charts from your own dynamic database in as few as 10 lines of code! Adding drill down support to a chart is as simple as one line - a single property setting! In addition to the automated drill down functionality, complete programmatic control is provided along with a template system for drill down URL to enable passing information on the selected element for subsequent drill down actions. Drill down has never been so simple, or so powerful!

ToolTip Support
Along with drill down support tool tips are now supported on a per element basis. This allows additional information to be displayed when the user rests the cursor over a given element. Through the ToolTip template you can control 30 different values which are automatically set when the chart renders. You can also set the ToolTip automatically from a field in your database with additional information or comments you wish to display to the user but don't want to clutter your chart with.

3D Chart Depth Control
This new property allows you to control the depth of charts when rendered in 3D modes. You can now control the width, length and depth of charts with ease.

Smart Label Support
The new "smart label" system ensures that labels do not collide or overlap even when chart elements are very close to each other. A small pointer is used to reference the element being labeled and the text is rendered on a portion of the chart with space for the label to be displayed. You have complete control over the indicator line color, thickness and style used along with the end cap / pointer included.

Complete Per Element Controls
Now you can control all expects of the chart down to the element level with complete per element controls. Settings include the color, marker, label, url, tooltip, transparency, labeling and much more. Now it is simple to vary colors on a per element basis or make changes to elements programmatically based on their value. For example: iterate through the elements collection and change all elements between 0 and 30 to green, 30-50 to yellow, 50-80 to orange and 80-100 to red. You have complete control over all settings providing an exceptional level of flexibility.

Alternating Axis Grids
You can now set and independently control the axis and alternating axis grids even specifying the background color / image of the axis grids.

Axis Markers
Many times a chart has a unique value which is significant but not directly represented by an element on the chart. For example, it could be a date when a specific promotion began, some other event or a special value (break even point, boiling point etc). With the new axis marker functionality you can mark specific points on any axis and even define ranges (for example weekends). With the advanced marker range background support you can also highlight such areas with any color or image background you wish. Of course you also have complete control of the axis marker line color, thickness and style.

Unlimited Axis and Axis Binding Support
Now unlimited x and y axis are supported for any given chart. Better still, each series can be independently bound to a given axis effectively allow multiple independent charts to display on the same charting surface. This feature is also very useful alongside the powerful combination charting options which allow different chart types to display at the same time in both 2D and 3D views.

New Calculate Axis Support
Along with unlimited axis support comes a powerful new concept in axis creation - the calculated axis. Often charts will display established units such as temperature, distance, weight etc. The calculate axis functionality allows you to create a new axis based on another axis with different units, all with one simple setting. Have a chart of distance in miles? Add a calculated axis with kilometers, yards or feet. Over 1000 different unit conversions are built in and you can define your own functions for unlimited flexibility. Process numeric values: 1, 2 ,3 into numeric names: one, two, three. Process your own conversions with your own custom functions - the possibilities are endless! In addition, you can calculate a new time based axis from one time interface (years) to another (quarters) with the same simple to use system.

Complete Per Axis Controls
Now every feature you can imagine is supported at the axis level with complete per axis controls. Independently set the axis line, background and alternating background, range markers, value markers, tick label overrides, cluster columns per axis, format and culture settings, grid lines, minimum, maximum, interval, padding, orientation, percentage, position (order), scale and much more.

Line Object Support
A new line object enables you to control all aspects of lines used to draw the Title Box, Chart Box, Legend Box, Chart Interior (from 3D mode), smart label pointers and many other areas.

New Background Options
Apply backgrounds to axis markers to highlight a specific range or value on the chart. In addition, backgrounds can be applied to alternating axis grids for a unique and powerful visual impact. The background object has also been enhanced offering new hatch style and hatch color support in addition to the established solid color, gradient, scaled image and tiled image options.

Legend Template Support
Now you can control the order, distribution and appearance of the legend entries with a powerful yet simple to use template system. Include the series name, the series value, and icon along with your own text.

Custom Legend Entries and Icons
Add an unlimited number of custom legend entries with independent text and marker details. This feature is useful for notes on custom markers that have been placed on the chart or to highlight a specific element with additional information. Combined with the new per element controls this functionality enables detailed information to be displayed on customized elements. You can further customize the legend appearance by defining custom legend icons.

Horizontal Cylinder Charting Type
A stunning new horizontal cylinder charting type includes support for percent complete hatching. Cylinder Gantt charts are also possible with the new range support.

Financial Charting Types
Stunning stock charts are now supported with series options for open, close, high, low, financial bar, Candlestick, and High Low Area in Volume chart areas as well as independent price / volume time intervals. New stock specific marker types have been added including split, reverse split, merger, dividend and spin-off. Of course you can specify any custom marker as well on a per element basis.

Donut Charting Type
A visually pleasing new donut charting type has been added. With complete 2D and 3D support this type also allows for transparency control for a very aesthetically pleasing chart.

Extensive New Pie Options
A powerful new labeling system, combined with smart labels, provides some of the most attractive and legible pies ever rendered. Labels can be rendered outside the pie with pointers to the representative slice, render inside the slice when there is room or automatically render inside or outside on best fit and appearance. In addition, pie slices can be individually controlled and exploded with per slice controls for exploded distance.

Range Charting Support
Now bar, cylinder, column and other charts support elements with start and end values. This enables a column that starts at a value greater than zero, for example, and allows for effective and attractive display of ranged data.

Powerful Element Templates
Along with the complete per element controls comes a new template system with 30 template containers. Templates can be controlled on a per element basis and are supported for element value, URL, and ToolTip. For example: %yValue will display the item value as a ToolTip (so when you hover your mouse over the element you will see the value). If you set %yValue for the element value you would see the actual value rendered on the chart. You can also use any number of template containers within any template along with your own text, for example, "Name: %Name, Value: %YValue". Template containers are automatically replaced with the elements name, value etc. when the chart is created.

New Marker System
A powerful new marker system provides an extensive set of 15 marker types in addition to support for any custom marker. Using built in markers you can control the color and size independently on a per marker basis. Markers are now used extensively throughout the product and allow for simple per series or per element customization.

Default Series and Element
A new default series and element allow you to make high level changes to default settings quickly and easily. Settings can take effect for all series on the chart, be overridden for one or more series and then be overridden for any given elements. This powerful new system enables you to have complete control down to the element level when required while maintaining ease of use and quick default settings.

Design-Time Support
Already one of the quickest and easiest solutions to get up and running, new Visual Studio .NET integration enables clients using this powerful IDE to see the chart in design time and observe the actual rendered chart and how it changes in real-time as settings are changed. A new wizard for Visual Studio .NET is also in development to further extend the products ease of use and rapid development for Visual Studio developers and will be available at no additional charge when released.

Updated DataEngine
Our unique DataEngine provides powerful data manipulation and acquisition features enabling you to chart multiple series from your own live database in as little as 8 lines of code! Now you can directly utilize the data engine to create derived series, split series, limit element or derived series returns to the top values and even aggregate "other" series or elements into a dedicated "other" series or element. Work with SQL Statements, Stored Procedures with parameters, Pass your own DataTable / DataSet, or use XML - the choices are endless and you can work with any database accessible within ASP.NET via ADO.NET. You can even chart directly from your own excel spreadsheet!

New DateGrouping Formatting:
You can now have complete control over date formatting, even for automatically generated series and elements created by the DataEngine and DateGrouping system.

Customize DataEngine Generated Series and Elements:
Now you have complete control both by series and element, even when using the advanced DataEngine functionality. Rename generated series, manipulate data, and update settings and visuals prior to creating the chart.

Improved DataGrid Display Options:
You can now control the orientation of the raw chart values for automatic display in a custom datagrid by setting columns by element or series. As always, you have complete control over the position and formatting of the datagrid.

Stock Specific DateGrouping, DataEngine and Drill Down Support:
The data engine supports all charting types from the database / datasource with mappings to any custom field names for expected values. In addition to automatically charting individual elements the DataEngine provides stock specific DateGrouping functionality. With a given element representing as many as 5 specific values (high, low, open, close, volume) the data engine automatically determines an sets the appropriate values as you group by Years, Quarters, Months, Weeks, Days, Hours and Minutes. It even allows for completely automated stock drill down charts with the addition of 1 simple setting.

Automatic Cache Subsystem
Typically charts are rendered in real-time with each request representing different data dynamically with different charts for each client request. However in some cases the same charts are displayed to many clients or the data the charts are based on is infrequently updated. A new cache duration setting can now be used in conjunction with the file name setting which enables the control to automatically determine if a new chart should be rendered or if the previously rendered image should be returned without further processing. The end result is a seamless scalable caching system that enables a given chart image to render only as required by setting one simple property.

Unclustered Cylinder & Bar Support
Clustered cylinders & bars enable values across multiple series to display clustered, in groups, on a per element basis. This allows for easy comparisons between values for a given element across multiple series. Now cylinders and bars support a new unclustered display in 3D modes showing each element behind the next.

Enhanced Transpose Functionality
Now with a single property charts can be transposed, visually exchanging series and element values, without modifying the underlying data. The result is a number of stunning and unique charts including blended transitions. Transpose now supports all available chart types and data combinations providing enhanced flexibility to meet even your most demanding needs.

Chart Area Label
A custom label can now be set for each chart area, enabling you to quickly and easily communicate additional information directly within the chart image. This is particularly useful if you have text that would normally be included in HTML on the same page as your chart, since when the user saves or forwards the chart image that plain text would be lost. Yet with the new chart area label feature it becomes part of the chart image itself. You may also control the font attributes and color used in addition to the text value to ensure the look and feel of your chart is exactly what you desire.

Independent Box Controls
A new box object allow for independent shadow, corner, label line and background customization on a per box basis. Customize the TitleBox and LegendBox to meet your exacting requirements with ease.

Enhanced Calculation Support
Now you can calculate new elements or derived series based by sum, average, median, mode, minimum and maximum. Calculations can run within a given series to product an element or within a series collection to produce a new series. For series calculations new support is added for running sum, running average, running median, running mode, running minimum and running maximum.

New in Version 1.4 (3/21/2003)

Date Scatter Support
In addition to the powerful and automated date grouping functionality, .netCHARTING now supports date scatter. This means you can plot any arbitrary dates relative to their exact position with automatic axis scaling. Choose between years, quarters, months, weeks, days, hours and even minutes with one simple setting!

Quarter & Minute Date Grouping
In addition to the extensive range of date grouping options already available, quarter and minute support has been added. Date grouping automatically aggregates values for a specific date range with no additional development or database coding required!

Gantt Charting Type
The Gantt charting type has been added with stunning 2D and 3D views. Unique to .netCHARTING is the completion indicator which provides a graphical representation of task progress and allows for visual customization.

Axis Numbering Controls
Building on the powerful automated numbering system, .netCHARTING now allows precise control over the axis numbering. Independently control the axis minimum value, maximum value and interval.

Wizard / code Generator
In addition to the extensive suite of samples provided in both C# and VB.NET the .netCHARTING wizard has been enhanced to support both C# and VB.NET code as well.

Axis Overrides
Axis mappings, or overrides, have been added which enable you to define custom labels for numeric values. For example if charting risk you may wish to use none, low, medium ,high in place of 0, 1, 2, and 3. Combined with the new axis numbering controls this feature is particularly powerful.

Excel Data Source Support
Adding to .netCHARTING's seamlessly integrated database support (no more writing database code!) for MS Access and SQL Server, Excel spreadsheets are now supported. That's right, you can now create stunning web based charts directly from your excel spreadsheets using .netCHARTING!

Title Wrapping & Legend Alignment
For long titles the system now automatically wraps to a second line if required. Bottom Legend alignment now supports left justification when more than one element is included and centering when only one element is present for ideally balanced aesthetics.

Automated Series Generation
.netCHARTING's advanced "splitby" functionality allows you to define a single series, generated from your database, and then create additional series splitting on a unique value (For example, show total sales split by customer - each customer would show with its own series). Advanced options are also provided to chart "other" elements aggregated as a single value. Now you can create a 10 series chart dynamically from your database in 6 lines of script!

Bar & Column Effect
Version 1.4 continues to push the visual fidelity of the product forward with a new effect available on bar and column chart types. .netCHARTING maintains incredible ease of use with dynamic database driven charts in a few lines of script while providing the best looking charts of any solution, on any platform!

New in Version 1.3 (2/17/2003)

Negative Value Charts
Full negative number support has been added allowing even complex charting types to display both negative and positive values at the same time. This new feature has been seamlessly integrated and takes effect automatically when negative data is included within any series.

Secondary Y Axis Support
An optional 2nd Y axis can now be added to the right side of a chart and scales as a factor of the original Y axis. For example, a sales chart could represent 2 different currencies by assigning the factor to a currency exchange rate. It would then be simple for values to be read off of the chart in either currency by examining the appropriate Y axis.

Scatter & Bubble Axis Controls
In addition to the control provided by the AxisScale property, two new properties are provided to independently control the scales for the x and y axis for scanner and bubble charts.

Bottom Legend Support
A new legend option is now available which allows for legend to be placed beneath the charting area. This allows for large series names to display cleanly without limiting the width available for the main charting surface.

Series Order Reversal
A new property has been added that enables you to reverse the order of the charted series with 1 easy step. You also have complete control over the positions with the series level position property.

Extruded Pie Support
A stunning new visual effect is available for 2D pie charts. In addition to this new effect, regular 2D pies and true 3D pies are also available.

Size Property
A new shortcut property has been added which enables you to set chart size with a single property.

Chart Level ShowValues
Show values controls if the numeric values for a given element will display on the chart. This new chart level property allows for a default value to be easily controlled. You also can override this setting on a per series basis.

DataGrid Series Name Support
The previous version added datagrid output support for the data values represented on the chart. Now you can also display the series names along with this data and control the name of the column used to display this data.

Date Axis Formatting
The specific date time format can now be controlled for axis that are date / time based.

Logarithmic Axis Scaling
The built in axis scaling options have continued to be enhanced with the addition of a logarithmic scaling option.

Data Table Field Selection
You can now control the fieldnames used when passing series data in a datatable. Options are available for which field to use for the x axis data, y axis data, splitby data, and bubble size data.

AddElement Enhanced
Two new options are available for adding elements to scatter and bubble charts with the addelement method.

New Samples
The included samples have been updated and a new sample has been added to demonstrate creating multiple chart controls programmatically.

New in Version 1.2 (1/14/2003)

Scatter Chart Type
True XY scatter support has been added. This allows both the X and Y axis to plot arbitrary decimal element values. In addition to point, scatter is supported for line and spline charts.

Bubble Chart Type
A unique new charting type which supports 3 data values per point. Bubble works like XY scatter but also supports a third value which controls the bubble size.

Scatter and Bubble Label Options
With the addition of 2 new charting types, powerful new label control options are provided including X, Y, XY, size, and XY size.

Stored Procedure Support
In addition to the built in SqlStatement support the product now allows you to call stored procedures to obtain charting data on a per series basis. Parameters for stored procedures are also supported through the new AddParameter method. A recent addition includes support for raw datatable input on a per series basis if required.

DataGrid Data Output
The included data processing engine performs grouping, aggregation and other calculations. A new DataGrid property has been provided which populates a datagrid of your choice with the tabular data represented in the chart.

Axis Scaling
This new feature ensures that small variations in charting elements are clearly visible. For example if all values were falling between 1000 and 1010 visually you would not see much separation with the axis starting at 0 and ending above 1000. Axis scaling enables the chart axis to scale to the range of the points represented in the chart so the full chart area can be used to reflect the different element values.

Cluster Property
Clustering enables columns to be easily compared by placing them next to each other in a group. This new property allows clustering to be disabled so, for example, so columns can appear behind each other.

Margin Settings
Complete margin controls are now provided for left, top, right and bottom. This allows you to control the amount of space or margin is left between the charting elements and the background. This can be particularly useful for implementing custom borders for your chart in conjunction with the new border background support.

Border Background Support
While extensive background options are already included, a new parameter has been provided to control how background images are handled. By default background images are titled if the image is not large enough to fill the chart area. Now, you can also scale the background to fit the size of the chart. This can be useful when using the background image as a charting border.

Legend and Title Box Style
New style options for the legend and titlebox enable you to control the corners independently from cut, box, or round options.

New in Version 1.1 (12/09/2002)

  • Additional chart type support including Radar and Multi-Radar in both 2D and 3D.
  • New outline controls including style and color for TitleBox, Legend, Graph
  • New line style and color settings for axis lines
  • New Percentage option for Y Axis formatting adds value cap and formatting features.
  • Dot Types are now supported on a per series level
  • Additional Dot Types have been added and now include square, triangle, circle, diamond, and 4 different star options.
  • New Dot Size option controls the size of dots used
  • New dot type option for "cycle" automatically cycles through and assigns unique dot types to any number of series with one simple setting.
  • Powerful new browser based wizard and code generator added! Create charts with point and click ease from your database. Also useful as a powerful learning tool, view the code generated by the wizard - copy and paste into your own scripts or modify further for your own custom needs.

Version 1.0

Initial Release!

Send comments on this topic.


Features

General Features

  • .NET 5, .NET Core, .NET Framework 4, .NET Framework 3, .NET Framework 2 Support
  • .net Framework 2.0, 3.x and 4.0+ Support
  • 2D and 3D rendering of charts.
  • Chart Mentor.
  • Ajax Scrolling
  • Ajax Zooming
  • Ajax Tooltips
  • Ajax auto update
  • Zoomer Performance/Interoperability enhancements
  • WinForms Mentor
  • Printer Friendly Text.
  • Quarter and Ordinal (1st, 2nd) formatting .
  • HTML Hotspot Event Attributes
  • Automatic drill down support.
  • Maintain color synchronization in drill down.
  • ToolTip support.
  • Rich ToolTip support.
  • Specify depth of 3D charts
  • Over 100 data related tokens for label templates.
  • Specify format strings for tokens on the fly within templates.
  • Design-Time support
  • Chart area label
  • Correction Warnings. Improper settings will be automatically corrected.
  • Default Series, Element, Axis, Shadow
  • Specify line objects for the title box, legend box, smart labels and many more.
  • Custom and random color palettes.
  • Separate shadow settings for chart areas, and boxes.
  • Image scaling makes it possible to make the smallest graphs.
  • Custom margins
  • Advanced Background class defines drawing options for virtually all chart objects.
  • Unlimited x and y axes.
  • Bind series to different x and y axes.
  • Label Trimming
  • Chart image links
  • Exposed image map.
  • Get the position and size of any box after chart is rendered
  • Save / Load chart object state in xml.
  • Smart Palette Support
    • Automatically generate a smart palette.
    • Save / Load smart palette in xml.
    • Color Swatch Support
    • Color Range Support
    • Auto Generated SmartPalettes from list of colors
    • Auto Generated SmartPalettes from series values
    • Transparent color support
  • Smart Colors for value ranges
  • Smart Colors with a two color (gradient) range.
  • SmartForecast automation.
  • 46 Five color palettes.
  • Multiple palette support
  • Small chart mode
  • msi Based Installer

JavaScript Charts (JavaScript HTML Charts)

  • JavaScript / HTML Chart output
  • Comparable Visual and User Experiences
  • Dynamic Tooltips
  • Bar Shading Effects
  • Animation
  • Trouch-screen support
  • Real-Time Updates
  • Client Side interactivity
  • iPhone, iOS, Android, WP7 & Tablet Support
  • Browser Compatibility- Supports
    • Chrome
    • FireFox
    • Safari
    • Opera
    • Internet Explorer (version 6+)
    • Mobile WebKit
  • Image, vector and PDF Export
  • Client side printing support.
  • Series Hiding
  • Element Highlighting
  • Zooming
  • Client-side JavaScript API
  • Label Token Support
  • Label Expressions
  • Axis Features
    • Multiple-Axes
    • Smart Axis Scale Breaks
    • Time Y Axis
    • Dynamic Token Tick and AxisMarker Values
    • Custom Ticks
    • Logarithmic Scale
    • Logarithmic Stakced Scale
  • Chart Types
    • Combo
    • ComboHorizontal
    • Pie
    • Pies
    • Pies with varying slice lengths
    • Donut
    • Donuts
    • PiesNested
    • Radars
    • Gauges
    • Funnel
    • Pyramid
    • Cone
    • Treemap
    • Gantt Support
  • Series Types
    • Bar/Column
    • Range Bar/Column
    • Error Bars
    • Line
    • Marker
    • Spline
    • AreaLine
    • AreaSpline
    • Range AreaLine
    • Range AreaSpline
    • Bubble

Silverlight Navigator

  • General
    • Performance
      • Utilizes multi-core processor technology
      • Capable of handling and animating thousands of dataPoints.
    • Usability Testing
    • Windowless Mode Support
    • Generate Preview Image Setting
    • 4 Loading Animations to display while loading
    • Override default loading text
  • Data Analysis
    • ChartArea legend
      • Mouse Tracking
        • Track values at mouse position
        • Track range calculation
      • Selection Tracking (highlight / calculation)
        • on hover
        • while selecting
    • Navigation Bar
      • History Buttons
      • Range Selectors
        • Works with any scale data type
        • Innovate date time handling.
      • Quick Zoom Buttons
  • Presentations
    • Animation & Delay
    • Make a Slideshow examining data.
    • Set starting viewport range
    • Use it as a finance chart (better than any other)
    • Dynamic help messages sent to any HTML element.
    • Make the chart follow along with hovering other charts
  • End user Interactivity
    • ChartArea
      • Drag Scrolling
      • Arbitrary Selection
      • ScrollWheel
      • Drag & Throw support
      • Click and Tooltip support pasing axis values at mouse position
    • Preview Area
      • Handle Dragging
      • Cell Selection
      • Arbitrary Selection
      • Mixed Selection
      • Deep Zooming
    • Scrollbar
      • Handle dragging
      • Double Click to zoom out and back.
      • Drag bar up and down to zoom in or out.
  • Developer Features
    • Creates an interactive Silverlight chart automatically from asp.net chart. (No SL knowledge required)
    • Can make any current combo chart interactive with 1 setting.
    • Silverlight install options.
    • Enable/Disable any part of Navigation bar
    • Enable/Disable any part of Navigator interactivity features on CA and Preview
    • Specify custom quick zoom intervals.
    • Real-Time
      • Get x axis scale range of chart.
      • Control chart movement through JavaScript API.

Chart Areas

  • Multiple Areas
  • Size each chart area (multi areas only)
  • Control spacing between pie/radar/gauge type elements
  • Data info tokens in area label
  • Chart area label alignment.
  • Control padding between chart areas and other boxes.
  • Specify corner sizes
  • Specify CornerStyles for corners not touching axes.

Advanced Empty Element Support

  • Mark with element markers, text, tool tips, colors.
  • Modes: None, Fill, TreatAsZero, and Ignore.
Output Features
  • Get a chart Bitmap.
  • Get a bitmap of the legend only.
  • Save bitmaps with the .netCHARTING system instantly.
  • Work with coordinates for each element after a bitmap is generated.
  • Output images as JPG, PNG, Tiff, WMF, EMF, and BMP.
  • Output as Flash, Svg, Pdf, and Xaml
  • Full Xaml Support
  • Output as Svgz
  • Memory Stream Output
  • Automatic cache subsystem.
  • Session streaming support.
  • PNG Variable Transparency
Annotations
  • Attach to any element or free floating positioning.
  • Dynamic tool tips and link url.
  • Takes Series, Axis Marker or Element as data source for tokens.
  • Vertical & Horizontal text alignment.
  • Smart Orientation to minimize text overlap.
  • Smart Pie Chart Annotation Orientation
  • Box Headers
  • Specify corner size
  • Specify only Width or Height and the other dimention is sized automatically.

Box Headers

  • 11 Box Header Cap Styles
  • Stand and End Alignments
  • Vertical Alignment
  • Box Header Disigner
  • Position Offset
  • Header Shadow
  • Robust settings allowing thousands of different visuals.
  • Applies to any boxes like annotation, title, and legend.
  • Header Orientation
  • Dynamic Ribbon Caps

Background Object
  • Standard Gradient
  • Angled Gradient
  • Solid Color
  • Tiled Image
  • Stretched Image
  • Hatch Style
  • Hatch Color
  • Bevel Effect
  • Use a custom brush to fill the background.
  • Seven shading effect modes.
  • 2 Additional Background shading effects.
  • Visible Setting
  • Transparency Setting
  • Multi-Color Gradients
  • Dynamic Default Shading

Smart Label System
  • Labels will not overlap.
  • Labels point to elements they represent.
  • Custom line pointers.
  • Force labels to be drawn when there is no room.
  • Align labels
  • Supply a list of alignments to try and find the best fit.
  • Use descriptive tokens and mathematical expressions in label strings.
  • Label Hotspots
  • Label Outlining
  • Automatic Wrapping
  • Label Drop Shadows
  • Label Glow Effect
  • Digital readout label style.
  • Image Substitution for label
  • Absolute positioning
  • Smart Label Padding
  • Smart Label Distance Threshold
  • Embedded Layout Markup Support
  • Embedded Font Styling
  • Embedded Tooltips and URL support
  • Block Alignment
  • Embedded Image Streaming from aspx pages
  • Embedded InfoGrids™
  • Embedded MicroCharts

Formatting Features
  • Number Precision
  • String Format
  • Culture Name

Line Object
  • Color
  • Width
  • Dash style
  • Line caps
  • Line cap scaling
  • Line Transparency setting

Axis Features
  • Automatic axis tick calculations (i.e. average of data tick)
  • Automatic Number Precision.
  • Axis Zooming
  • Chart Click to Axis Value
  • Tick label templates.
  • Minor axis Ticks.
  • Smart minor axis ticks.
  • Smart Minor ticks for log scales.
  • Axis tick angling.
  • Duplicate Axis Support.
  • Time Label Automation
    • Specific Mode
  • Smart Mode
  • Range Mode
  • AddRange Mode
  • Clear or hide the axis with a single method.
  • Alternating grid background
  • Specify axis line properties.
  • Specify grid line properties
  • AxisMarkers drawn on top of data Option
  • Axis range markers
  • Axis value markers
  • Tick label overrides.
  • Cluster columns on a per axis basis.
  • Per axis value formatting.
  • Maximum, Minimum, Interval, Time padding
  • Orient vertical axes left or right.
  • Set as a percentage axis.
  • Specify positions of the axes (order)
  • Reverse series of an axis.
  • Reverse series position of an axis.
  • Axis Scales
    • Normal
    • Range
    • Log
    • Time
      • Minutes
      • Hours
      • Days
      • Weeks
      • Quarters
      • Months
      • Years
    • Stacked
    • Full Stacked
    • Logarithmic Stacked
    • Inverted scale support
    • Scale breaks & Automatic (smart) scale breaks
    • Smart scale break limit.
    • Scale break styling
    • Calendar Pattern based Scale Breaks
  • Calculated Axes:
    • Custom method calculation
    • Convert from and to any unit. (1092 Units Available)
    • Shadow a time axis with different time intervals.
  • Control column spacing on a per axis basis.
  • Specify tick line properties including length.
  • Tick label padding.
  • Turn grid lines on or off.
  • Tick label wrapping.
  • Tick label separator.
  • Label rotation.
  • Axis label marker (Gauge chart).
  • Axis label tokens
  • Axis marker label alignment support
  • Axis tick line caps
  • Category axis range tick support

Title Box

  • Intergraded legend.
  • Title & Legend wrapping
  • Left/Right/Center/Full alignment options.
  • Icon Image.
  • Box Edge Styling
  • Background and line drawing objects.
  • Box Headers
  • Specify corner sizes

Legend

  • Multi-color legend entry icons.
  • Value and Name Templates
  • ToolTip Templates
  • Legend entry as link templates.
  • Hide legend entries.
  • Dynamic icons representing data.
  • Display the value of series.
  • Legend element template
  • Add unlimited extra legend elements
  • Custom legend icons.
  • Legend Icons mimic element shading effects.
  • Box Edge Styling
  • Positioning
    • Top Right
    • Middle Right
    • Bottom Right
    • Bottom Middle
    • Bottom Left
    • Middle Left
    • Top Left
    • Top
    • Absolute (pixel x,y) position
    • LegendboxPosition.ChartArea
  • Text Alignment by column
  • Box Header
  • Specify corner sizes
  • Static size setting

Element Features

  • Specify per element:
    • Custom Attributes
    • Legend Entry
    • Axis Marker
    • Color
    • Explode Slice
    • Force Marker
    • Label Template with 29 tokens.
    • URL template with 29 tokens.
    • Tool Tip template with 29 tokens.
    • Marker
    • Secondary color ( stock charts )
    • Show Value
    • Transparency
    • Hatch style & color.
    • Element Outline
    • Label
      • Font
      • Color
      • Smart Label Properties
  • Multiple SubValue support
    • Types
      • Error Bars
      • Lines
      • Icons

Series Features

  • Legend Entry
  • Specify a palette for elements within.
  • Specify a hatch style palette for elements within.
  • Default element
  • Specify line properties for series which draw lines.
  • Specify x and y axes.
  • Exclude series from axis range.
  • Series background support (Gauge & Radar).
  • Calculations
    • Sum
    • Mean
    • Median
    • Mode
    • Average
    • Minimum
    • Maximum
    • Running Sum
    • Running Mean
    • Running Median
    • Running Mode
    • Running Average
    • Running Minimum
    • Running Maximum
    • Trend Line
    • Scatter Trend Line
    • Interpolate value calculation

Series Collection Features

  • Calculate Series
    • (Same as series calculations above)
  • Transpose data.
  • Sort series by any element value.
  • Get processed DataTable
  • Smart Pattern Recognition based element ordering of multiple series.
  • Optionally disable smart pattern recognition.

Element Marker Features

  • Specify a Color
  • Custom Image
  • Specify size.
  • Custom Image DynamicColors
  • Built in Icons
    • None
    • Square
    • Triangle
    • Circle
    • Diamond
    • Four Point Star
    • Five Point Star
    • Six Point Star
    • Seven Point Star
    • Financial Split
    • Financial Reverse Split
    • Financial Merger
    • Financial Dividend Paid
    • Financial Spin-off
    • ArrowUp
    • ArrowDown
    • TriangleUpsideDown

Series Types

  • Marker
  • Line
    • Multiple colors on a single line. in 2D and 3D
    • Line Caps support
  • Spline
    • Multiple colors on a single spline. in 2D and 3D
    • Specify spline tension
    • Line Caps support
  • Area Spline
  • Multiple colors on a single area spline.
  • Range Support
  • 2D and 3D support
  • Area Line
    • Multiple colors on a single area line.
    • Range Support
  • Cone & Pyramid
  • Segmented Bars
  • Column & Cylinder
    • 7 Shading Effects in 2D (3 in 3D) ( Column only )
    • imageBars(tm) including 95 templates.
    • Range Support
    • Percentage Complete hatch support
    • Horizontal Support
    • Advanced hotspot support.
    • Specify a fixed width.
    • ImageBar OneToOne
    • With ComboHorizontal: GanttDependencies
  • Bubble
    • Eight Shading Effect Modes
  • BubbleShapes
    • Shading effect support
    • 2d & 3d versions
    • 42 predefined shapes

Financial Series Types

  • Open
  • Close
  • High
  • Low
  • Financial Bar
  • Candlestick
  • High Low Area

Chart Types

  • Combo Chart
  • Side by Side Combo Chart
  • Horizontal Combo Chart
  • Pie & Donut Chart
    • Single and Multi Pies
    • Smart Pie Label Wrapping.
    • Specify doughnut thickness
    • 2D Pie / Donut extruded effect
    • 4 Unique Shading Effects
    • Explode slices per series or element.
    • Individual pie slice Length
    • Individual pie slice Height
    • Nested or overlapping scales
    • BubbleSize based nested sizing
    • Nested spacing
    • Absolute positioning and sizing
    • Pie Start Angle support
    • Smart labels
      • Inside
      • Outside
      • Automatic
  • PiesNested
    • Supports 2D & 3D
  • Radar Chart
    • Polar & Spider axis modes.
    • Single and multi radars
    • Multiple radars can have separate axes.
    • Time Y Axis scale
    • Bubble series support
    • Column Series Type Support
    • Stacked Columns
    • Stacked Area Lines
    • Quantitative X & Y axis scales
    • Radar Orientation Angle
    • Absolute positioning and sizing
    • Tick Label Modes
      • Normal
      • Angled
      • Next to In
      • Next to Out
  • XY Scatter
  • Bubble Chart
    • 8 Bubble shading effects.
    • Control maximum bubble size.
  • Financial Chart
    • Optional volume chart area
    • Different time intervals for price and volume
  • Gauge Chart
    • Circular Type
      • Custom Image Needles
      • Radial labels mode.
    • Vertical linear
    • Vertical Thermometer
    • Horizontal linear
    • Hrizontal Thermometer
    • Bars
    • Indicator Lights
    • Digital Readout
    • General Gauge Features
      • Specify gauge sizes
      • Specify gauge rectangles (absolute positioning)
  • Multiple Chart Type
    • Funnel Pyramid
    • Funnel Cone
    • Pyramid
    • Cone
    • StackedBubble
      • Shade as one or individual bubbles
      • Alignment options [center / bottom]
    • Pie
    • Donut
    • Gauge
  • TreeMap
    • Shading support including Background 1 & 2 effects.
  • Surface Type
    • Surface Combination types
    • Contour charts
    • X/Y Surface Types
    • Floating and anchored surface support
    • Surface 3D view
    • Interpolated surface fill
    • Surace 3D lighting
    • ZAxis support
    • Web based Surface Designer
  • Mapping
    • Support for Maps with multiple Layers
    • Satellite and composite image layer support
    • Custom Map Shape Styling
    • Thematic Mapping
    • Map Zooming
    • Projection Support
    • Map Attribute DataBinding
    • Custom Map DataBinding
    • Programmatic Map Shape Access
    • Shape Group labeling and styling
    • Get map GPS coordinates from click.
    • Plot GPS coordinates on map.
    • Get shapes from point on map.
    • Label Once option
    • Ajax Zooming and Scrolling
    • Get Shape GPS Bounds
    • Add GPS Points with annotations and hotspots
    • Annotations for any Shapes.
  • Organizational Chart Type
    • Automatic Vertical Layouts
    • Shading Effects for node annotations.
    • Ajax Scrilling
    • Organizational Chart Drilldown
    • Drilldown Breadcrumbs
    • Node Indicators
    • Node Expansion
  • MicroCharts
    • Bar
    • BarGauge
    • Progress
    • ProgressGauge
    • Bullet
    • Sparkline
    • AreaLine
    • Scale
    • ScaleB (Bottom Scale)
    • Pie
    • Pie3D
    • Marker
    • Image
      • Image Rotation
      • Image Sizing
    • MicroChart Tooltip & URL Support.
  • InfoGrids™
    • MicroCharts embedded in InfoGrids™
    • Draw a labels as the chart
    • Draw an annotation as the chart.

Statistical Analysis

  • Bollinger Bands
  • C Frequency Table AOL
  • C Frequency Table AOR
  • C Frequency Table BOL
  • C Frequency Table BOR
  • Correlation Coefficient Determination
  • EstimateX
  • EstimateY
  • Exponentially Weighted Moving Average
  • Frequency Table OL
  • Frequency Table OR
  • Geometric Mean
  • Geometric Moving Average
  • IQR
  • Kairi
  • Kendall Correlation Coefficient
  • Least Squares Estimate X
  • Least Squares Estimate Y
  • Linearly Weighted Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Pearson Correlation Coef
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Range
  • R Frequency Table OL
  • R Frequency Table OR
  • Residuals
  • Residuals Average
  • Simple Moving Average
  • Spearman Rank Correlation Test
  • Standard Deviation
  • Statistical Median Moving Average
  • Triangular Moving Average
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average
  • Z Score
  • Kurtosis
  • Skweness
  • Bessel I
  • Bessel J
  • Bessel K
  • Beta
  • Gamma P
  • Gamma Q

Financial Indicators

  • Accumulate Distribute Over Period
  • Aroon Down
  • Aroon Down Over Period
  • Aroon Oscillator
  • Aroon Oscillator Over Period
  • Aroon Up
  • Aroon Up Over Period
  • Balance Of Power Over Period
  • Bollinger Bands
  • Chaikin Money Flow Over Period
  • Chaikin Oscillator
  • Chaikin Volatility
  • Crossing Extreme Signal
  • Crossing Signal
  • Commodity Channel Idx Over Period
  • D Stochastic
  • K Fast Stochastic
  • Exponentially Weighted Moving Average
  • Extreme Value D Signal
  • Extreme Value K Signal
  • Commodity Channel Idx Over Period
  • Exponentially Weighted Moving Average
  • Financial Z Score
  • Geometric Mean
  • Geometric Moving Average
  • Inter Quartile Range
  • Kairi
  • Linear Moving Average
  • Lower Bollinger Bands
  • Mean
  • Mean Deviation
  • Median
  • Median Moving Average
  • Median Price
  • Momentum
  • Money Flow Idx Over Period
  • Negative Volume Index
  • On Balance Volume
  • Percentile 25
  • Percentile 50
  • Percentile 75
  • Positive Volume Index
  • Range
  • Simple Moving Average
  • Standard Deviation
  • Triangular Moving Average
  • Typical Price
  • Upper Bollinger Bands
  • Variance
  • Weighted Moving Average
  • Plus Directional Movement
  • Minus Directional Movement
  • True Range
  • Directional Movement
  • DMI signal
  • Kurtosis
  • Skewness

Data Manipulation Features

  • Native Oracle Support*
  • Native MySQL Support*
  • Native ODBC Support*
  • MS Access 2007 support (.accdb)
  • Selective Default (apply settings based on criteria)
  • Inverse Series Trim
  • Sort series by any element value.
  • Trim elements within a series that are outside of a given date or numeric range.

  • Add, Subtract, Multiply, and divide any series, or elements with operators ( + - */ ).

  • Perform the same calculations between series/elements and numbers. (Element1 * 5).

  • Addition of a derived series for average or running sum calculated over all, or any specific, series.
  • Addition of a data point for any given series calculated as sum or average for that series.
  • Addition of any arbitrary data point / reference on a individual series basis.
  • Add series data automatically from a database.
  • Split data from an automatic database return to automatically create multiple series.
  • Set a maximum number elements to return / chart.
  • Automatically tabulate top x elements and aggregate others into an "other" element.
  • Seamlessly move between MS Access and SQL server databases by only changing your connection string.
  • Obtain series data from separate databases and graph multiple series on the same chart.
  • Group multiple series on one chart with missing points automatically handled and series matched out.
  • Series order reversal
  • Stored procedure support
  • DataGrid output.
  • DataGrid header template support.
  • DataGrid empty element handling.
  • DataGrid formatting.
  • DataGrid custom attribute support
  • GridView support
  • Quarter & Minute Date Grouping
  • Excel Data Source Support
  • Automated Series Generation
  • Smart database connectivity (specify file names without connection strings)
  • Include grouping data in SubValues
  • Multiple Series Drill-Down
  • Xml XPath support
  • Data access before chart generation.
  • Evaluate tokens from chart data.
  • Split / Group Elements by TimeIntervalAdvanced objects.
  • Sort SeriesCollections by element groups (bar stacks)

Date Handing

  • Automatically add date / date range represented on the graph to the charting header
  • Dates are treated intelligently and database data can automatically be grouped and graphed in a number of date ranges including: day by hour, week by day, month by week, month by day, year by week, and year by month.
  • Date groups automatically create x axis labels as required
  • Selectable first day of the week.
  • Date axis formatting
  • Date grouping sort.
  • Date grouping calculations.

Send comments on this topic.


Install Index

This section describes how to install and use the component in different situations

  • Installation
    Installing the component
    • Application Creation
      How to create an application on the server.
    • Virtual Directory Creation
      How to create a virtual directory.
    • WinForms Installation
      How to install and use with WinForms.
  • WinForms
    Using the component in the WinForms environment.
  • Visual Studio .net Usage
    Using .netCHARTING with Visual Studio .net
  • Visual Studio Toolbox
    Adding the component to various versions of the Visual Studio Toolbox.
Send comments on this topic.


Installing .netCHARTING

This section describes how to install and use the component in different situations

  • Application Creation
    How to create an application on the server.
  • Virtual Directory Creation
    How to create a virtual directory.
  • WinForms Installation
    How to install and use with WinForms.

Send comments on this topic.


WinForms Installation

WinForms Usage

The process to use the WinForms edition of .netCHARTING is simple. The dotnetCHARTING.WinForms.dll file must be added to the visual studio application as a reference. Then add the dll to the toolbox in Visual Studio.

When this is completed drag and drop the charting control from the toolbox onto a form to get started.

See Also

Tutorials

{Interactivity - WinForms}
Send comments on this topic.


Using with WinForms

.netCHARTING Winforms Support

  • Run dotnetCHARTING Winforms msi installer
  • Specify either automatic or manual installation
  • ApplicationDNC property should be set to the purchase key file content or the path to the key file. Note: a key is not required for the trial.
  • Run dotnetChartingSamples.exe, discover the code for various charts is identical. This application provides an interface for viewing different charts along with the source for each in C# and VB.NET. You can also print the source listing or copy it to the clipboard for subsequent use.

The winforms control will not function in a web environment. In addition, the web version (dotnetcharting.dll) will not function outside of a web environment.

WinForms Usage

The process to use the WinForms edition of .netCHARTING is simple. If you are already familiar with .netCHARTING the winforms version will also be familiar. For using in your Visual Studio winforms application, add dotnetCHARTING.WinForms.dll as a reference. Then add the dll to the toolbox in toolbox in Visual Studio. When this is completed drag and drop the charting control from the toolbox onto a form to get started.

.net 4.0 Client Profile

As of .netCHARTING v8 and later, the client profile framework 4 is supported with a separate .netCHARTING assembly. To utilize this version, you can develop against the assembly included in the root and for deployment drop in and replace the assembly with the version included in this folder. The assemblies have the same name and version so you do not need to re-reference or recompile, but the comments will differ if you wish to confirm a given assembly right click on dotnetchartingWinForms.dll, select properties and confirm the product name. The client dll version will note “.netCHARTING WinForms Client” in the name.

Differences from the WebForms version:

  1. The winforms Chart control is inherited from System.Windows.Forms.userControl and you have access to all events,properties and methods of UserControl in addition to the full .netCHARTING object model.
  2. Width and Height properties are "int" type versus WebControl which are Unit type.
  3. HitTest method. This method accepts the X,Y position on the chart image and returns the corresponding object for that point of the Image. These are 3 overloaded methods for HitTest method:

    [C#]

    HitTestInfo  myObj =  HitTest(x,y);

    [Visual Basic]
HitTestInfo  myObj =  HitTest(x,y)
    x,y are int and represent the point you want to get the related object from.

    [C#]
HitTestInfo  myObj =  HitTest(myPoint);

    [Visual Basic]
HitTestInfo  myObj =  HitTest(myPoint)
    myPoint is "Point" type and represents the point you want to get the related object from.

    [C#]
HitTestInfo  myObj =  HitTest();

    [Visual Basic]
HitTestInfo  myObj =  HitTest()
    If you do not pass the cursor position, internally this method uses the position from the Chart control. This usage would be applicable when using the winforms control in a winforms project.

    Currently, the HitTestInfo Class has one property called "Object". It will hold the object clicked and can be used for drilldown or other advanced integration with the chart in a winforms environment.
  4. When you use Object.URL properties, such as Element.URL when you click on the Element, a new browser window will be launched with the URL value specified. URL target has no effect in a winforms environment.

Send comments on this topic.


Using With Visual Studio.net

Visual studio can be used as a development environment for projects using .netCHARTING. Below find step by step instructions for using the samples within an ASP.NET web application. Of course, you could use the sample directly just by running them through a web browser and edit the calling page directly in Visual studio instead which would require no additional setup outside of the regular install.

Installation Instructions:

  1. Create new project, ASP.NET Web Application.
  2. Copy the Data folder from the .netCHARTING bundle into your project root ( for example in c:\inetpub\wwwroot\webApplication)
  3. Copy dotnetCHARTING.dll to the bin folder within your web application (like you did for the data folder in step 2)
  4. Add a reference to dotnetCHARTING.dll under the References node in Solution Explorer.
  5. Select Customize Toolbox from Tools menu and then add the dll to Toolbox or right-click on the tool box > Add/Remove Items > .net tab > browse to the dll > click OK. For more information, see this article.
  6. Copy and Paste the code from any of the .netCHARTING samples included in the bundle to your aspx page (you can delete any default html code which has been created through Visual Studio .NET wizard)
  7. Create a Temp folder in the project path same as step 2 or 3 and modify the permissions to have write access (See installation for more information).
  8. Make sure the path for data/ is set correctly.
  9. When you start the project you should see a chart based on the sample code you added.

Copying the dotnetCHARTING.xml file to your bin folder will enable intellisense in visual studio.

Common Problems and Resolutions:

When I start the WebApplication from Visual Studio I get Empty page.
 Cause: The data folder does not exist in you project folder.
When I start the WebApplication from Visual Studio I get "CreateControl: generic error occurred in GDI+".
Cause: the Temp folder does not exist or does not have Write permissions.
Error in reading Database
Cause: ConnectionString property is not pointing to right path for the database.
When I drag and drop Chart control from Toolbox to Form , I get "error in CreateChildControl"
Solution: Add a reference to dotnetCHARTING.dll and under the References node in Solution Explorer.
I do not see the Chart Control in Toolbox.
Solution: Select Customize Toolbox from Tools menu and then add the dll to Toolbox or right-click on the tool box > Add/Remove Items > .net tab > browse to the dll > click OK.

Design Time Support:
The Chart control can used in design time in Visual Studio .NET (or web matrix).
You can use this control in an ASP.NET web Application (not in desktop or winforms applications)
As with any other control first you should add it to the Toolbox as follows:

  1. From Tools menu option select "Customize Toolbox" then browse and select the dotnetCharting.dll assembly and click OK.
  2. You will now see the chart control listed in the toolboxTool
  3. You may now drag and drop the chart into the aspx page and use it.
  4. You can use the Properties browser to see all chart control properties, and any changes when made on any properties, related code will be generated in code behind file in InitializeComponent() method, you can also write your own code, overriding any properties in the Page_load section or any part of file as you please.

Send comments on this topic.


Adding .netCHARTING to the VS Toolbox

Introduction

To add the .netCHARTING control to Visual Studio toolbox, create a new project (ASP.NET Web Forms or WinForms) and open the designer. The toolbox items will only be visible in the designer window. If the toolbox is not visible, click the View menu.

  • Open Toolbox dialog box form the menu: Tools -> Choose Toolbox Items.
  • Select the .NET Framework Components tab.
  • If the dotnecharting.dll is installed in GAC, the component will be listed in this tab. Otherwise, click browse and select the .netCHARTING dll.
  • Click Ok to finish.
Send comments on this topic.


Chart Tutorials

The following tutorials will get you up to speed using your data with .netCHARTING.

Dissecting the Chart

  • Labels
    Shows what properties chart labels can be controlled with.
  • Lines
    Shows what properties chart lines can be controlled with.

Working with

  • Colors
    Demonstrates how colors are created.
  • Fonts
    Demonstrates how fonts are created.
Send comments on this topic.


Using Colors

A color can be set simply with Color.Name e.g. Color.Red or Color.Blue.
Complete list of color names.

More advanced color creation using RGB, alpha and web color settings

Creates a Color structure from the specified 8-bit color values (red, green, and blue). The alpha value is implicitly 255 (no transparency).

[C#] Color myColor = Color.FromArgb(0, 255,125);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(0, 255,125)

Creates a Color structure from the four ARGB component (alpha, red, green, and blue). Alpha is also known as transparency where 255 is totally solid and 0 is totally transparent.

[C#]
Color myColor = FromArgb(120, 0, 255,125);

[Visual Basic]
Dim myColor As Color = FromArgb(120, 0, 255,125)

Creates a Color from a 32-bit ARGB value. (alpha, red, green, and blue)

[C#]
Color myColor = Color.FromArgb(0x78FF0000);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(&H78FF0000)

Creates a Color from the specified Color Name, but with the new specified alpha value, valid alpha values are between 0 through 255.

[C#]
Color myColor = Color.FromArgb(125,Color.Red);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(125,Color.Red)

For converting a web color:
If the color is "bgcolor="#388B7E" , replace # with 0x(for csharp) or &H (for visual basic), and add an alpha value between 0-7F after that, then add the rest. (0x7F388B7E or &H7F388B7E)

[C#]
Color myColor = Color.FromArgb(0x7F388B7E);

[Visual Basic]
Dim myColor As Color = Color.FromArgb(&H7F388B7E)

Tip: When specifying a color for a box such as a legend or title box, it is useful to use just a slight hint of the specific color. This can be achieve by using code such as Color.FromArgb(15,Color.Green). This will result in a green shade that is virtually transparent.

For advanced information visit: .NET framework Color structure.

See Also
{Element Colors & Palettes}
Send comments on this topic.


Working with Fonts

Initializes a new Font object using a specified size

[C#]
Font myFont = new Font("Arial", 10);

[Visual Basic]
Dim myFont As New Font("Arial", 10)

Initializes a new Font object using a specified size and style

[C#]
Font myFont = new Font("Arial", 10, FontStyle.Bold);

[Visual Basic]
Dim myFont As New Font("Arial", 10, FontStyle.Bold)

Available Font Styles:

  • FontStyle.Bold
  • FontStyle.Italic
  • FontStyle.Regular
  • FontStyle.Strikeout
  • FontStyle.Underline

    For advanced information visit .NET Framework Font class
See Also
{Using labels}
Send comments on this topic.


Labels
Click on any property name for additional information.
See Also
Tokens Reference

Tutorials

{Using labels}
Send comments on this topic.


Lines
Click on any property name for additional information.

Send comments on this topic.


Data Tutorials

The following tutorials will get you up to speed using your data with .netCHARTING.

The Basics

  • Data Objects
    Describes the the classes which contain data consumed by the chart.
  • Data Manipulation
    Shows how easily data can be manipulated using the .netCHARTING data model.
    • Sorting Elements
      This sample describes element sorting functionality.
  • Analysis Engine
    Provides Statistical Calculations and Financial Indicators functionality.

Data acquisition

  • Connecting to data sources
    Shows how to use different sources of data.
  • Getting Data
    Index Page
    • Simple Queries
      How to use queries to retrieve chart ready data.
    • Getting Multiple Series
      How to acquire multiple series from a database.
  • Data field mapping
    Database column to chart data mapping.
  • Custom Attributes
    Bring additional data into chart elements.
  • Data engine features
    More data engine features explained.

For mapping data acquisition please see this tutorial.
Send comments on this topic.


Connecting to Data

Introduction

.netCHARTING provides the DataEngine object which can be used to automatically obtain data from a variety of data sources. The DataEngine returns a SeriesCollection object which contains data that is consumed by the chart.

The DataEngine object is instantiated like so:
[C#]
DataEngine de = new DataEngine();

[Visual Basic]
Dim de As New DataEngine()

Using data sources.

The DataEngine object internally connects to any supported data sources when a ConnectionString is specified. Supported data sources include

  • MS Access
  • MS SQL
  • Oracle*
  • mySQL*
  • ODBC*
  • Excel
  • XML

*Available with .net framework version 2.0 only.

Unsupported data sources can also be utilized by supplying the DataEngine with a data object such as a DataTable.

When connecting to supported data sources data is queried by setting the SqlStatement property of the DataEngine.

If you wish to use MS Access sample database on a x64 system, you must set "Enable 32-bit Application" to true in the Application Pool/Advanced settings in IIS.

Examples

There are different methods of connecting to specific data sources. The following section demonstrates how each supported data source can be utilized.

Access Database

[C#]
de.ConnectionString = @"Provider=Microsoft.Jet.OLEDB.4.0;user id=;password=
                        ; data source=" + Server.MapPath("db.mdb");
// A connection string shortcut for access databases is also available.
de.ConnectionString = "db.mdb";
de.SqlStatement = @"SELECT OrderDate,Sum(Total) FROM Orders ";

[Visual Basic]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;user id=;password=;"_
                        & "data source=" & Server.MapPath("db.mdb")
' A connection string shortcut for access databases is also available.
de.ConnectionString = "db.mdb"
de.SqlStatement = "SELECT OrderDate,Sum(Total) FROM Orders "

SQL Database

[C#]
de.ConnectionString = @"server=server name or IP;uid=username;pwd=password;database=database name";
de.SqlStatement = @"SELECT OrderDate,Sum(Total) FROM Orders ";

[Visual Basic]
de.ConnectionString = "server=server name or IP;uid=username;pwd=password;database=database name"
de.SqlStatement = "SELECT OrderDate,Sum(Total) FROM Orders "

Stored Procedure

[C#]
de.StoredProcedure = "myProcedure";
de.AddParameter("@STARTDATE","3/10/02 12:00:00 AM",FieldType.Date);

[Visual Basic]
de.StoredProcedure = "myProcedure"
de.AddParameter("@STARTDATE","3/10/02 12:00:00 AM",FieldType.Date)

The AddParameter method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored procedure. The following parameter types are supported:

  • Text
  • Date
  • Number
  • LongNumber
  • Currency
  • Double

Excel Files

[C#]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;data source= " + Server.MapPath("myData.xls")
                        + ";Extended Properties=\"Excel 8.0;\"";
de.SqlStatement= @"Select Periods,Sales from [Yearly Summary$]";

[Visual Basic]
de.ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0;data source=" & Server.MapPath("myData.xls") _
                        & ";Extended Properties=\"Excel 8.0;\""
de.SqlStatement= "Select Periods,Sales from [Yearly Summary$]"

XML Files

Xml files can be used as data sources by setting the Data property of the DataEngine with the xml document file name:

[C#]
de.Data = "Orders.xml";

[Visual Basic]
de.Data = "Orders.xml"

Other Sources

Firebird and other unsupported sources

.netCHARTING can also parse supported data objects generated from any data source using the respective .net providers. If you can access your data in your .NET application you can chart it with .netCHARTING in a few simple lines of code.

Supported Data Objects

  • DataSet
  • DataTable
  • DataView
  • String (Raw xml)
  • String (xml file name)
  • XmlDocument

These objects are consumed by the DataEngine's Data property.

Example:

[C#]

de.Data = myDataTable;

[Visual Basic]

de.Data = myDataTable
Send comments on this topic.


Data Model

.netCHARTING Data Classes

The .netCHARTING data model consists of elements which collectively become a series which can be added to a SeriesCollection.

See Illustration

Data Class

Description
Element

Represents an element on the chart and facilitates the following.

  • Provides properties to hold different types of data such as y value, x value, % completed for Gantt charts and many more. Below Element.YValue is demonstrated.
  • Controls all other variables concerning a single element such as it's label color, marker type etc.
Series

Utilizes the ElementCollection class to hold a set of elements and facilitates the following.

  • Provides a mechanism for setting default properties of all elements within it.
  • Controls all series specific properties such as it's LegendEntry or 2D line dash style (if applicable).
  • Derives an element based on a Calculation which is performed on the elements within it.
  • Provides data manipulation methods such as sorting and trimming of it's elements.
SeriesCollection

Contains a collection of series and facilitates the following.

  • Derives series based on a Calculation which is performed on all the series within it.
  • Provides data manipulation methods such as Transpose.
ElementCollection Used by the Series class to hold a collection of elements.

Using Data Classes

The following example creates a SeriesCollection containing one Series which contains a single Element using the following steps.

  1. Instantiates an element and sets it's properties.
  2. Instantiates a series and adds the element to it.
  3. Instantiates a SeriesCollection and adds the series to it.
[C#]
Element e = new Element();    // Instantiate the element
e.Name = "Element 1";      // Name it
e.YValue = 10;             // Set the y value
Series s = new Series();     // Instantiate the series
s.Name = "Series 1";       // Name it
s.Elements.Add(e);         // Add element e to series s.
SeriesCollection sc = new SeriesCollection(); // Instantiate a series collection
sc.Add(s);                 // Add series s to the series collection sc.

//The sc object now contains data we can chart which we add here.

Chart.SeriesCollection.Add(sc);

[Visual Basic]
Dim e As New Element()    ' Instantiate the element
e.Name = "Element 1"      ' Name it
e.YValue = 10             ' Set the y value
Dim s As New Series()     ' Instantiate the series
s.Name = "Series 1"       ' Name it
s.Elements.Add(e)         ' Add element e to series s.
Dim sc As New SeriesCollection() ' Instantiate a series collection
sc.Add(s)                 ' Add series s to the series collection sc.

'The sc object now contains data we can chart which we add here.

Chart.SeriesCollection.Add(sc)

Shortcuts

.netCHARTING provides many shortcuts which can make adding data easier. The previous example can also be achieved using the following shortcuts.

Using Chart.Series shortcut.

[C#]
Element e = new Element();
e.Name = "Element 1";
e.YValue = 10;
Chart.Series.Add(e);
Chart.SeriesCollection.Add(); // Not passing parameters will add the contents of Chart.Series to the Chart.SeriesCollection collection.

[Visual Basic]
Dim e As New Element()
e.Name = "Element 1"
e.YValue = 10
Chart.Series.Add(e)
Chart.SeriesCollection.Add() ' Not passing parameters will add the contents of Chart.Series to the Chart.SeriesCollection collection.

Using the Chart.Element shortcut.

[C#]
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();

[Visual Basic]
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()

Using all the shortcuts allows us to reduce the amount of lines necessary to achieve the same result from 8 to 4. The down side is that after the data is added using Add(), it cannot be retrieved for further manipulation.

Take it to the next step

It is still possible to reduce the code even further using element constructors.

[C#]
Chart.SeriesCollection.Add(new Element("Element1",10));

[Visual Basic]
Chart.SeriesCollection.Add(New Element("Element1",10))

Now we took it from 8 lines to 1.

For more information on code shortcuts, see the Efficient Code tutorial.

Send comments on this topic.


Data Manipulation
The features discussed in this section require that series objects are populated with elements. This does not happen automatically if the DataEngine is not used. Please see this kb for more information.

.netCHARTING facilitates numerous calculations that can be performed on your data. These calculations can be used to

  • Derive an element from a series
  • Derive a series from a SeriesCollection
  • The results can also be used in text reports or as further chart data.

Series.Calculate

First we will construct a simple series with some data we can manipulate.
[C#]
Series s = new Series();
s.Elements.Add(new Element("e 1",5));
s.Elements.Add(new Element("e 2",15));
s.Elements.Add(new Element("e 3",23));
s.Elements.Add(new Element("e 4",13));
s.Elements.Add(new Element("e 5",34));

[Visual Basic]
Dim s As New Series();
s.Elements.Add(new Element("e 1",5))
s.Elements.Add(new Element("e 2",15))
s.Elements.Add(new Element("e 3",23))
s.Elements.Add(new Element("e 4",13))
s.Elements.Add(new Element("e 5",34))

With our series populated with data, we can derive calculations using the Series.Calculate method which returns a single element.

[C#]
Element e = s.Calculate("sum",Calculation.Sum);

[Visual Basic]
Dim e As Element = s.Calculate("sum",Calculation.Sum)

The element e now has yValue of 91 which is the sum of all the element yValues in series s. If the elements of series s had other values such as BubbleSize, the resulting e.BubbleSize would contain the sum of those as well.

Series.Sort

Elements within a series can be sorted by any value in ascending or descending order.

[C#]
// Sort the series by name
s.Sort(ElementValue.Name, "DESC");
// Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC");

[Visual Basic]
' Sort the series by name
s.Sort(ElementValue.Name, "DESC")
' Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC")

Series.Trim

Elements with values that are within a given range can be trimmed form a series using the Series.Trim method. The trim method also

[C#]
// Trim elements with y values between 15 and 20.
s.Trim(ElementValue.YValue, 15,20);

[Visual Basic]
' Trim elements with y values between 15 and 20.
s.Trim(ElementValue.YValue, 15,20)

Samples

  • seriesSort.aspx
  • calendarPattern.aspx

The above example trimmed out elements within the specified range. This method also offers an option to trim outside the specified range using a Boolean parameter as in this code:

[C#]
// Trim elements with y values outside 15 and 20.
s.Trim(ElementValue.YValue, 15, 20, true);

[Visual Basic]
' Trim elements with y values outside 15 and 20.
s.Trim(ElementValue.YValue, 15, 20, true)

Series and SeriesCollection also have a SelectiveElementDefaults method which lets you specify a range of elements in the same way however, it applies specified settings to those elements automatically. SelectiveElementDefaults are discussed in more detail in the Shortcuts and Efficient Code section.

SeriesCollection.Transpose()

The transpose method manipulates the series and elements of a series collection by making the series names, element names and the element names into series names. This is similar to transposing data in Excel. Basically when the data is laid out in columns and rows, the rows become columns and columns become rows. Changing a ChartType from Combo to ComboSideBySide can achieve the same result as using Combo and transposing the series collection.

SeriesCollection.Sort

Series in a SeriesCollection object can be sorted based on their respective element's values.

[C#]
// Consider a SeriesCollection sc that has multiple series, each with several elements.
// Sort the series by name.
sc.Sort(ElementValue.Name,"ASC");
// Sort the series by the sum of their element's y value.
sc.Sort(ElementValue.YValue,"ASC");

[Visual Basic]
' Consider a SeriesCollection sc that has multiple series, each with several elements.
' Sort the series by name.
sc.Sort(ElementValue.Name,"ASC")
' Sort the series by the sum of their element's y value.
sc.Sort(ElementValue.YValue,"ASC")

GetInterpolatedValues() [New in v5.0]

This series method is capable of getting an estimated y value given the x value of a series. A series of elements with quantitative x axis values (meaning elements using a element.XValue or XDateTime instead of Name) can take advantage of this method.

[C#]
object yValue = mySeries.GetInterpolatedYValue((DateTime)xval);

[Visual Basic]
Dim yValue As Object = mySeries.GetInterpolatedYValue(DirectCast(xval, DateTime))

Samples:

ClickPointInterpolatedValue.aspx

ClickPointLineValue.aspx

SeriesCollection.Calculate

We will first create another series and add it to 'sc' so that we have 2 series available for our calculations.

[C#]
Series s2 = new Series();
s2.Elements.Add(new Element("e 1",2));
s2.Elements.Add(new Element("e 2",45));
s2.Elements.Add(new Element("e 3",23));
s2.Elements.Add(new Element("e 4",41));
s2.Elements.Add(new Element("e 5",24));
SeriesCollection sc = new SeriesCollection();
sc.Add(s);
sc.Add(s2);

[Visual Basic]
Dim s2 As New Series();
s2.Elements.Add(new Element("e 1",2))
s2.Elements.Add(new Element("e 2",45))
s2.Elements.Add(new Element("e 3",23))
s2.Elements.Add(new Element("e 4",41))
s2.Elements.Add(new Element("e 5",24))
Dim sc As New SeriesCollection();
sc.Add(s)
sc.Add(s2)

Now we will use the SeriesCollection.Calculate method which returns a single series.

 [C#]
Series s3 = sc.Calculate("Sum Series",Calculation.Sum);
sc.Add(s3);

[Visual Basic]
Dim s3 As Series = sc.Calculate("Sum Series",Calculation.Sum)
sc.Add(s3)

Our derived series now contains the sums of each 'element group' or 'elements with the same name'. The values of series s3 will be '7,60,46,54,58'.

Calculation Shortcuts

You can also use shortcuts to add calculated series to the chart.
[C#]
Chart.SeriesCollection.Add(s);
Chart.SeriesCollection.Add(s2);
Chart.SeriesCollection.Add(Calculation.Sum); // This will add a sum series to the chart.

[Visual Basic]
Chart.SeriesCollection.Add(s)
Chart.SeriesCollection.Add(s2)
Chart.SeriesCollection.Add(Calculation.Sum) ' This will add a sum series to the chart.

Series and element operators ( + - * / )

Series and elements can be manipulated with operators when using c#. For example, the previous code snippet can also be achieved in this way:

[C#]

Chart.SeriesCollection.Add(s);
Chart.SeriesCollection.Add(s2);
Chart.SeriesCollection.Add(s1+s2); // This will add a sum series to the chart.

[Visual Basic]
' Visual Basic operators will be available with .net framework 2.0, however
' methods are available for this functionality.
Chart.SeriesCollection.Add(s)
Chart.SeriesCollection.Add(s2)
Chart.SeriesCollection.Add(s1.Add(s2)) // This will add a sum series to the chart.

The operators can also be used with numbers. Let's say you have a chart that shows the GDP of countries. You can do the following: mySeries *= .000000001; If the value of an element in this series was 7,000,000,000 (seven billion), after this operation the value will be 7. On the axis label we can then say 'GDP (Billions)'. Operators are also useful in situations that require complex manipulation of data such as rates.

Manually iterating elements

We can also iterate through our series collection to do custom manipulation. The following code snippet will test each element and if the value is over 35, the color of that element will become red.

[C#]
foreach(Series mySeries in sc)
  foreach(Element myElement in mySeries.Elements)
      if(myElement.YValue > 35)
          myElement.Color = Color.Red;

[Visual Basic]
Dim mySeries As Series
Dim myElement As Element
For Each mySeries In sc
   For Each myElement in mySeries.Elements
      If myElement.YValue > 35 Then
         myElement.Color = Color.Red
      End If
   Next myElement
Next mySeries

Date Based Manipulation (Advanced DateGrouping)

The series class provides two methods that allow a series of elements to be split up into multiple series based on a TimeIntervalAdvanced interval and then regrouped based on another interval and a calculation. This combination of features allows replicating the DataEngine's DateGrouping functionality a lot more.

Method: SplitRegroup(TimeIntervalAdvanced firstSplit, TimeIntervalAdvanced secondSplit)
Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the web site was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the web site on any Monday would be calculated down to a single element, same for Tuesday and so on.

Method: SplitRegroupCalculate
Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the web site was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the web site on any Monday would be calculated down to a single element, same for Tuesday and so on.

This illustration shows how the data is arranged.

See Also

Tutorials

{Analysis Engine}
Send comments on this topic.


Element Sorting

Introduction

This tutorial will describe how elements are sorted by default and how their sort order can be manipulated. If the elements have x axis values such as numbers or dates, sorting is not very useful because the sequential axis will determine their position, however, when elements use string names for the x axis sorting is much more useful.

Quantitative Axis Sorting

Elements with numeric or dateTime x values and a numeric or dateTime x axis will automatically be sorted sequentially and fall into place where the values appear on the axis. Elements may contain names as well as x values such as dates, however, if both names and values exist, the x axis will default to a category axis which shows names of the elements. To force the axis to use a time scale the following code can be used.

[C#]
Chart.XAxis.Scale = Scale.Time;

[Visual Basic]
Chart.XAxis.Scale = Scale.Time

If the elements have names and numbers using Scale.Normal will have the same effect causing the x axis to become a numeric axis.
For more information on element values and axis scales see the Elements and Axis Scales tutorial.

The chart mentor can be helpful in this case as it can detect your data types, axis scales and report back suggestions.

Category Axis Sorting

Single Series Default Sorting

How They Behave
A single series of elements with names instead of x values will be drawn on the chart in the order the elements are added to the series.

TIP:

  • To reverse the order of elements on an axis, it can be done quickly by using Chart.XAxis.InvertScale = true

Multiple Series Default Sorting

If multiple series are added to the chart with the same element names and in the same order the chart will draw them in the order they are added. When multiple series with elements that are different are added, the chart performs some smart grouping functionality that processes the sort order.This section will describe the element name grouping functionality.

As an example case, elements will be provided for the chart in a segmented order.

3 Series, each with 4 elements:

Series 1: |  |  | C | D | E | F |  |
Series 2: |  |  |  |  | E | F | G | H
Series 3: | A | B | C | D |  |  |  |

SeriesCollection.SmartGrouping = true (Default)

Intended order:

A B C D E F G H

.netCHARTING Will analyze this list and determine what the true intended order should be. This does not employ sorting, it looks for patterns in element orders of different series to determine the original order. In this case the available element names offer enough information to determine the sort order to be the above.

SeriesCollection.SmartGrouping = false

When false, the element order will be based on the orders in which series elements are provided. The above example will result in this order:

C D E F G H A B

The first series defines the order to be CDEF then the second series has two new element names which are added at the end GH. The final series offers AB as new names and that will be added at the end and so on.

Despite any sorting performed on a series, if the x axis is a category axis, the above processing will be applied.

Custom Sorting

Series.Sort (Sort Elements)

Elements within a series can be sorted by any value in ascending or descending order.

[C#]
// Sort the series by name
s.Sort(ElementValue.Name, "DESC");
// Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC");

[Visual Basic]
' Sort the series by name
s.Sort(ElementValue.Name, "DESC")
' Sort the series by YValue
s.Sort(ElementValue.YValue, "DESC")

SeriesCollection.Sort (Sort Series)

Series within a SeriesCollection can also be sorted. This does not affect the element sort order, only the order of the series within the collection. The sorting is based on the sum of any element values within a series.

  • CS
  • VB
mySeriesCollection.Sort(ElementValue.YValue,"DESC");

mySeriesCollection.Sort(ElementValue.YValue,"DESC")

SeriesCollection.SortElementGroups (Sort Element Groups)

Element groups are elements belonging to different series but sharing a name. It is the same as the requirement for a stack chart's stacks. Only element groups can be stacked. In effect, this can be considered a way to sort the columns of a stacked chart.

  • CS
  • VB
mySeriesCollection.SortElementGroups(ElementValue.YValue,"ASC");

mySeriesCollection.SortElementGroups(ElementValue.YValue,"ASC")
Sample: SortElementStacks.aspx
Send comments on this topic.


Analysis Engine

Introduction

The .netCHARTING analysis engine provides many statistical calculations and financial indicators allowing quick and accurate analysis of your data.

Getting Data

The first step is to get a series of data to analyze. Please see the following tutorials as a reference on data acquisition.

  • Data Tutorials
  • Financial Charts
The features discussed in this section require that series objects are populated with elements. This does not happen automatically if the DataEngine is not used. Please see this kb for more information.

Calculated series and financial indicators often use multiple chart areas. For more info, see:

  • Multiple Chart Areas

Analysis Engine

Three classes provide the methods used for analysis.

  • FinancialEngine
  • StatisticalEngine
  • ForecastEngine

The following code snippet demonstrates calculating the mean of a series collection.

[C#]

...
SeriesCollection mySeries = ...; // Original seriesCollection
Series resultSeries = StatisticalEngine.Mean(mySeries);

Chart.SeriesCollection.Add(resultSeries);

[Visual Basic]

...
Dim mySeries As SeriesCollection = ...(seriesCollection)... ' Original seriesCollection
Series resultSeries = StatisticalEngine.Mean(mySeries)

Chart.SeriesCollection.Add(resultSeries)
Many samples are available under the Features / Analysis Engine section that demonstrate this functionality.

ForecastEngine

The forecast engine contains a set of simple methods to perform common forecasting operations. However, the class also contains an advanced set of methods for users familiar with the mathematical formulas.

IndicatorOptions

Both analysis classes contain a static Options class that provides additional options for use with the analysis engine.

  • PopulateSubValues
    When a series is calculated down to a single element, the element values of the original series can be included in the resulting element as SubValues.
    A similar feature is also available in the dataEngine: PopulateDateGroupingSubValues Property
  • MatchColors
    Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature because colors are generally based on a palette at runtime.

The following sample demonstrates using the statistical engine's indicator options.

[C#]

...
SeriesCollection mySeries = ...; // Original seriesCollection

StatisticalEngine.Options.PopulateSubValues = true;
Element resultElement = StatisticalEngine.Mean(mySeries);

Chart.SeriesCollection.Add(resultElement);

[Visual Basic]

...
Dim mySeries As SeriesCollection  ... // Original series

StatisticalEngine.IndicatorOptions.PopulateSubValues = True
Element resultElement = StatisticalEngine.Mean(mySeries)

Chart.SeriesCollection.Add(resultSeries)

See Also
{Data Manipulation}

SubValues

ErrorBars and other SubValues
Send comments on this topic.


Getting Data
  • Using Query Strings
    How to use queries to retrieve chart ready data.
  • Getting Multiple Series
    How to acquire multiple series from a database.
Send comments on this topic.


Using Query Strings

This tutorial describes how database queries can be used to populate chart series and elements.

Simple chart

By default, the first column returned by your query is mapped on the x axis and the second column is mapped onto the y axis.

Consider:
'SELECT name, age FROM Employees'

This query will create a chart where the names are on the x axis, ages on the y axis, and might look something like this:

Figure 1. Using a simple query

Multiple series from a single query

Returning a third column splits the data into series. This feature is referred to as 'SplitBy'.

Consider:
'SELECT name, age, division FROM Employees GROUP BY division'

This time 3 columns are returned and rows are grouped by the division column. Because the third column is supplied, two series are created, one for each unique value of the division column. The resulting chart will look something like this:

Figure 2. Multiple series using a query
Another characteristic of the splitBy functionality is the aggregation of grouped values. For this example consider a database table with 3 fields [ Date, Items_Sold, Sales_Rep ] . Each day an entry is added with the number of items sold for each sales rep. In our database there are two and they have been selling from January - May.
Consider:
'SELECT Date, Items_Sold, Sales_Rep FROM Sales GroupBy Sales_Rep'

In this case the sales of each representative are aggregated for each month.
* This sample also uses the dategrouping setting of (TimeInterval.Month), see dataEngine for more info.

Figure 3. Multiple series with date grouping.

Count occurrences of a fields value.

For this case, let's say we have a table which is a log of logins into your main company server. The table contains a 'date' column and a 'name' column and each row is a login entry. To show the number of logins for each user we can use the following query:

Query:
'SELECT name, 1 FROM Orders GROUP BY name;'

This will create a table with a name and a value (1) for each login. This method takes advantage of the DataEngine's aggregation feature and the second column will be summed.

Figure 4. Counting occurences.
Send comments on this topic.


Getting Multiple Series

Using Query Strings (Series based on field: SplitBy)

To get multiple series automatically using the data engine you must specify a third column in the query string. This feature is referred to as 'SplitBy'.

Consider:

'SELECT name, age, division FROM Employees GROUP BY division'

Three columns are returned and rows are grouped by the division column. Because the third column is supplied, two series are created, one for each unique value of the division column. The resulting chart will look something like this:

Figure 1: Returning a third column splits the data into series.

Using Data Fields with SplitBy

If you are getting many columns from the database and would like to specify which column to use as the splitBy column you can do so using the DataFields property.

[C#]
myDataEngine.DataFields = "Name=name,YValue=age,SplitBy=Division";

[Visual Basic]
myDataEngine.DataFields = "Name=name,YValue=age,SplitBy=Division"

Using a single SQL Statement ( Series Per Column )

Multiple series can be automatically generated for each column using multiple YValue tokens in the DataFields property.

For example, consider the following code:

[C#]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats";
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA,YValue=GroupB,YValue=GroupC";

[Visual Basic]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats"
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA,YValue=GroupB,YValue=GroupC"

Assigning Series Names
This will generate three series, all of which will use the myDate column for the x values and their individual groupX columns for y values. Custom series names can also be specified in the data fields. The following code does the same as the above but will assign custom series names.

[C#]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats";
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA=Group Alpha,YValue=GroupB=Group Beta,YValue=GroupC=Group Gamma";

[Visual Basic]

myDataEngine.SQLStatement = "SELECT myDate, GroupA, GroupB, GroupC FROM Stats"
myDataEngine.DataFields = "XValue=myDate,YValue=GroupA=Group Alpha,YValue=GroupB=Group Beta,YValue=GroupC=Group Gamma"

Query Database Multiple Times

Another way to do this, is to query your database separately for each series.

[C#]

DataEngine de = new DataEngine(connectionString);
de.SqlStatement = "SELECT name, dataOne FROM table";
Chart.SeriesCollection.Add(de.GetSeries());
de.SqlStatement = "SELECT name, dataTwo FROM table";
Chart.SeriesCollection.Add(de.GetSeries());

[Visual Basic]

Dim de As New DataEngine(connectionString)
de.SqlStatement = "SELECT name, dataOne FROM table"
Chart.SeriesCollection.Add(de.GetSeries())
de.SqlStatement = "SELECT name, dataTwo FROM table"
Chart.SeriesCollection.Add(de.GetSeries())

Avoid Querying Multiple Times

If querying the database multiple times is not desirable the same can be accomplished by using a DataTable.

[C#]

DataEngine de = new DataEngine();
DataTable dt = new DataTable();
// Populate the datatable from your database.
dt = (...);
de.Data = dt;
de.DataFields = "YAxis=name,XAxis=DataOne";
Chart.SeriesCollection.Add(de.GetSeries());
de.DataFields = "YAxis=name,XAxis=DataTwo";
Chart.SeriesCollection.Add(de.GetSeries());

[Visual Basic]

Dim de As New DataEngine()
Dim dt As New DataTable()
' Populate the datatable from your database.
dt = (...)
de.Data = dt
de.DataFields = "YAxis=name,XAxis=DataOne"
Chart.SeriesCollection.Add(de.GetSeries())
de.DataFields = "YAxis=name,XAxis=DataTwo"
Chart.SeriesCollection.Add(de.GetSeries())
Send comments on this topic.


Data Field Mapping

Introduction

Data fields are a very useful tool when translating your database structure to chart data. It allows you to map which column of your data table or query populates a given element property.

See Illustration

For example, if you have a column which represents certain information you want to use as a tool tip, it can easily be mapped using data fields. The 'DataFields' property of DataEngine and Chart.Series is a string which can be supplied as a comma delimited list of element property, to data column, relationships.

For example, in the following DataFields string

"YValue=Cost,Name=Brand,ToolTip=Description"; Cost, Brand, and Description are all columns in a data table. YValue, Name, and ToolTip are element values.

Custom tokens can also be used to populate elements with additional database columns which can be used by element tool tips, urls, within labels and so on.

The following table outlines the available element values and shortcuts which can be mapped to your data columns.

Token Name | Description
Name | Sets Element.Name
Yvalue | Sets Element.YValue or Element.YDateTime depending on the column data type.
YValueStart | Sets Element.YValueStart or Element.YDateTimeStart depending on the column data type.
Xvalue | Sets Element.XValue or Element.XDateTime depending on the column data type.
XValueStart | Sets Element.XValueStart or Element.XDateTimeStart depending on the column data type.
BubbleSize | Sets Element.BubbleSize
Complete | Sets Element.Complete
Open | Sets Element.Open
Close | Sets Element.Close
High | Sets Element.High
Low | Sets Element.Low
Volume | Sets Element.Volume
tooltip | Sets Element.ToolTip
urltarget | Sets Element.URLTarget
Url | Sets Element.URL
LabelTemplate | Sets Element..LabelTample
Table | Specifies the name of the table to use when multiple tables exist, for example when a DataSet is used.

Shortcuts and special functionality tokens

Token Name | Description
Bubble | Sets Element.BubbleSize
price | Sets Element.Close
Ganttcomplete | Sets Element.Complete
Ganttname | Sets Element.Name
Ganttenddate | Sets Element.YDateTime
Ganttstartdate | Sets Element.YDateTimeStart
Ganttend | Sets Element.YValue or Element.YDateTime if DateTime data type.
Ganttstart | Sets Element.YValueStart or Element.YStartDateTime if DateTime data type.
Splitby | Sets Element.SplitBy (Special)
Yaxis | Sets the element values associated with the y axis of the chart in use. ChartType.ComboHorizaontal sets Element.Name. All Others set Element.Yvalue, if column type is 'DateTime' Element.YDateTime will be set instead.
Xaxis | Sets the element values associated with the x axis of the chart in use. ChartType.Combo Horizontal sets Element.Yvalue, if column type is 'DateTime' Element.YDateTime will be set instead.. ChartType.Scatter sets Element.Xvalue, if column type is 'DateTime' Element.XDateTime will be set instead. All Other sets Element.Name. and/or if date it sets Element.XDateTime.

Data fields and XML documents

Xml Documents dont store data exactly as databases do.

Using Data Fields

"[Token]=[Data Column],..."

Escape Character
Some database columns can have characters such as commas ','. In order to reference these column names an escape character can be used.
"YAxis=Tom\,Harry"

Sample Data

This data will be used to demonstrate how different chart types can be achieved by mapping the appropriate element values.
Table 1 | Column | (string) Name | (double) StartValue | (double) EndValue | (double) Completed
 | Sample Data | Chris | 3 | 15 | 25
Table 2 | Column | (string) Name | (DateTime) StartValue | (DateTime) EndValue | (double) Completed
 | Sample Data | Chris | 3/5/2003 | 8/10/2003 | 25
Table 3 | Column | (string) Name | (double) Cost | (double) TopSpeed | (double) HorsePower
 | Sample Data | Chevy | 22,000 | 120 | 185
Table 4 | Column | (string) Stock | (double) Close | (double) Open | (double) Low | (double) High | (DateTime) Date
 | Sample Data | MSFT | 176 | 120 | 100 | 185 | 11/12/2003

The above tables are color coded for reference to which table the column name refers. If there is more than one example in sub sections such as 'Simple Graph', they are equivalent.

ChartType.Combo & ChartType.ComboSideBySide
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Simple Graph | "xAxis=Name,yAxis=EndValue" "Name=Name,yValue=EndValue"
Range (Gantt) Columns | "xAxis=Name,yValue=EndValue,yValueStart=StartValue"
Range columns /w Complete indicator | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
Date Range columns /w complete indicator. | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
NOTE: For this chart type "xAxis=Name" is the same as "Name=Name".

ChartType.ComboHorizontal
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Simple Graph | "xAxis=Name,yAxis=EndValue" "Name=Name,yValue=EndValue"
Range (Gantt) Columns | "xAxis=Name,yValue=EndValue,yValueStart=StartValue"
Range columns /w Complete indicator | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
Date Range columns /w complete indicator. | "xAxis=Name,yValue=EndValue,yValueStart=StartValue ,Complete=Completed"
NOTE: For this chart type "xAxis=Name" is the same as "Name=Name".

ChartType.Gantt
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "yValueStart=(1stColumn),yValue=(2stColumn)" "yValueStart=(1stColumn),yValue=(2stColumn),Name=(3rdColumn)" "yValueStart=(1stColumn),yValue=(2ndColumn),Name=(3rdColumn),Complete=(4thColumn)"
Applicable tokens | Element Data Properties YValue, YValueStart, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy Gantt Shortcuts GanttName, GanttStart, GanttEnd, GanttComplete
Examples
Range (Gantt) Bars | "yValueStart=StartValue,yValue=EndValue"
Range Columns /w Complete | "yValueStart=StartValue,yValue=EndValue, Name=Name,Complete=Completed"
Date Range Columns /w Complete | "yValueStart=StartValue,yValue=EndValue,Name=Name,Complete=Completed"

ChartType.Radar & ChartType.Pie
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, Name, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy
Examples
Simple Chart | "yAxis=EndValue,xAxis=Name" Note: Though there are no x and y axes in a pie chart the fields are mapped like so: "yValue=EndValue,Name=Name" Note: The radar graph has both x and y axes.

ChartType.Scatter
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),splitBy=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, XValue, Name, Complete, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, SplitBy
Examples
Simple Scatter Chart | "xAxis=HorsePower,yAxis=TopSpeed" "xValue=HorsePower,yValue=TopSpeed"

ChartType.Bubble
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),BubbleSize=(3rdColumn)"
Applicable tokens | Element Data Properties YValue, XValue, BubbleSize, Name, Tooltip, UrlTarge, Url Shortcuts xAxis, yAxis, Bubble
Examples
Simple Scatter Chart | "xAxis=HorsePower,yAxis=TopSpeed,BubbleSize=Cost" "xValue=HorsePower,yValue=TopSpeed,Bubble=Cost"

ChartType.Financial
Default DataFields | Defaults are chosen based on the number of columns returned by the query. "xAxis=(1stColumn),yAxis=(2stColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),Volume=(3rdColumn)" "xAxis=(1stColumn),yAxis=(2stColumn),Volume=(3rdColumn),SplitBy=(3thColumn)"
Applicable tokens | Element Data Properties Open, Close, High, Low, Volume, Name, Complete, Tooltip, UrlTarget, Url Shortcuts xAxis, yAxis, SplitBy, Price
Examples
HLC Chart | "xAxis=Date,High=High,Low=Low,Price=Close"

ChartType.Organizational
Default DataFields | "InstanceID=(1stColumn),ParentID=(2stColumn),Name=(3rdColumn)"
Examples
Organizational Chart | "InstanceID=ID,InstanceParentID=PID,Name=Name,office,Department,Email,Phone,Picture"
Send comments on this topic.


Custom Data Attributes

Custom element attributes.

Additional information stored in databases can be extracted and used in a chart to provide further information in a tool tip, an element's label, within the element's hot spot URL, and any other related text strings.

Extracting from a database

Extracting attributes from a database can be accomplished with a single line of code using the DataFields property of a DataEngine object..

Assume the following database columns:

  • EmployeeID
  • FullName
  • Department
  • EmailAddress
  • PhoneNumber
  • AveragePerformance

Using this database we will create a chart that shows each employee's name on the x axis and they're average performance on the y axis. When we mouse over a column in the chart we want to see the employee's ID, department, and phone number. When we click a given column we want to send the employee an email.

The first step is to specify the DataFields property.

[C#]
DataEngine de = new DataEngine();
de.ConnectionString = "...";
de.SqlStatement =  "SELECT * FROM
myTable";  de.DataFields="xAxis=FullName,yAxis=AveragePerformance,id=EmployeeID,"
 + "department=Department,email=EmailAddress,phone=PhoneNumber";

[Visual Basic]
Dim de As New DataEngine()
de.ConnectionString = "..."
de.SqlStatement =  "SELECT * FROM
myTable"  de.DataFields="xAxis=FullName,yAxis=AveragePerformance,id=EmployeeID,"_
 & "department=Department,email=EmailAddress,phone=PhoneNumber"

The next step is to specify a template for the element's tooltip and url.

[C#]
Chart.DefaultSeries.DefaultElement.ToolTip = "ID: %id \n Department: %department \n Phone Number: %phone";
Chart.DefaultSeries.DefaultElement.URL = "mailto:%email";

[Visual Basic]
Chart.DefaultSeries.DefaultElement.ToolTip = "ID: %id " & vbCrLf &
" Department: %department " & vbCrLf & " Phone Number: %phone"
Chart.DefaultSeries.DefaultElement.URL = "mailto:%email"

This complex and highly functional chart is now ready.

Adding manually

Element attributes can be populated manually using the following method.

[C#]
Element e = new Element();
e.Name = "myElement";
e.YValue = 15;
e.CustomAttributes["Phone"] = "555-8593";
e.CustomAttributes["Department"] = "Marketing";

[Visual Basic]
Dim e As New Element()
e.Name = "myElement"
e.YValue = 15
e.CustomAttributes("Phone") = "555-8593"
e.CustomAttributes("Department") = "Marketing"

Series Level attributes

Attributes can be added at the series level to specify information common to all elements. These can be used in legend entry labels, legend entry tool tips and URLs.

Let's generate a SeriesCollection using the data engine object from the above example but we will modify it to only extract elements from a specific department.

[C#]
de.SqlStatement = "SELECT * FROM myTable WHERE department = "marketing";
SeriesCollection sc = de.GetSeries();
// The above generated 1 series with a number of employee elements.
// Now we can add some attributes for this specific to the marketing department.
sc[0].Name = "Marketing";
sc[0].DefaultElement.CustomAttributes["DepartmentPhoneNumber"] = "555-2414";
sc[0].DefaultElement.CustomAttributes["DepartmentManagerName"] = "555-2414";
sc[0].DefaultElement.CustomAttributes["DepartmentAddress"] = "555-2414";
[Visual Basic]
de.SqlStatement = "SELECT * FROM myTable WHERE department = "marketing"
Dim sc As SeriesCollection
sc = de.GetSeries()
' The above generated 1 series with a number of employee elements.
' Now we can add some attributes for this specific to the marketing department.
sc(0).Name = "Marketing"
sc(0).DefaultElement.CustomAttributes("DepartmentPhoneNumber") = "555-2414"
sc(0).DefaultElement.CustomAttributes("DepartmentManagerName") = "555-2414"
sc(0).DefaultElement.CustomAttributes("DepartmentAddress") = "555-2414"

The series now has additional information stored. Let's use it in the series' legend entry tool tip.

[C#]
Chart.DefaultSeries.LegendEntry.ToolTip = "Manager: %DepartmentManager \n "
                   + "Phone: %DepartmentPhoneNumber \n Address: %DepartmentAddress";
// Elements can also use the series level attributes
Chart.DefaultSeries.DefaultElement.ToolTip = "%Name \n Phone #: %phone \n "
 + "Department Phone #: %DepartmentPhoneNumber";

[Visual Basic]
Chart.DefaultSeries.LegendEntry.ToolTip = "Manager: %DepartmentManager \r "_
                   & "Phone: %DepartmentPhoneNumber " & vbCrLf & " Address: %DepartmentAddress";
' Elements can also use the series level attributes
Chart.DefaultSeries.DefaultElement.ToolTip = "%Name " & vbCrLf & " Phone #:  %phone "_
 & vbCrLf & " " & "Department Phone #: %DepartmentPhoneNumber"

The above may tool tips may look like this:

John Doe
Phone #: 555-5426
Department Phone #: 555-1349

Sample: customAttributes.aspx

Send comments on this topic.


Data Engine

Data Engine

The DataEngine object connects to databases or consumes data objects such as a 'DataTable' and converts them to a SeriesCollection which can then be manipulated and used to generate a chart. The DataEngine offers many data manipulation features saving countless hours of development, particularly for date specific aggregation.

We encourage you to review the following tutorials before working with the DataEngine:

  • Connecting to Data
  • Using DataFields

The basic concept of using the data engine is to specify a database, connection string and retrieve the SeriesCollection it generates. A basic example:

[C#]

DataEngine de = new DataEngine(connectionString,queryString);
SeriesCollection mySC = de.GetSeries();

[Visual Basic]

Dim de As New DataEngine(connectionString,queryString)
SeriesCollection mySC = de.GetSeries()

Filtering out date ranges

When specifying a start and end date in a database query, the following method should be used.

[C#]
DataEngine de = new DataEngine();     // Instantiate the data engine object
de.StartDate = new DateTime(2002,1,1,8,0,0);     // Specify the start date
de.EndDate = new DateTime(2002,1,1,23,59,59);      // Specify the end date.
//Specify a query.
de.SqlStatement = "SELECT names, values FROM myTable WHERE start > #StartDate# AND end < #EndDate#";

[Visual Basic]
Dim de As New DataEngine()     ' Instantiate the data engine object
de.StartDate = New DateTime(2002,1,1,8,0,0)     ' Specify the start date
de.EndDate = New DateTime(2002,1,1,23,59,59)      ' Specify the end date.
'Specify a query.
de.SqlStatement = "SELECT names, values FROM myTable WHERE start > #StartDate# AND end < #EndDate#"

Notes:

  • The #StartDate# and #EndDate# tokens can be used in SQL statements in which case the dates set for de.StartDate and de.EndDate will replace the tokens before the SqlStatement is executed.
  • StartDate and EndDate properties affects the dates listed in the title when Chart.ShowDateInTitle is used.
  • All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used.
  • See also DataEngine.SqlStatement | DataEngine.StartDate | DataEngine.EndDate

Date grouping

This feature controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time data type.

Example 1

[C#]
de.SqlStatement = "SELECT time, unitsSold FROM sales";
de.DateGrouping = TimeInterval.Days;

[Visual Basic]
de.SqlStatement = "SELECT time, unitsSold FROM sales"
de.DateGrouping = TimeInterval.Days

The above will create an aggregated element for each day within the start and end date of your data. Similar options include:

  • Minutes
  • Hours
  • Days
  • Weeks
  • Months
  • Quarters
  • Years

Example 2

[C#]
myDataEngine.SqlStatement = "SELECT time, unitsSold FROM sales";
myDataEngine.DateGrouping = TimeInterval.Day;

[Visual Basic]
myDataEngine.SqlStatement = "SELECT time, unitsSold FROM sales"
myDataEngine.DateGrouping = TimeInterval.Day

When using day instead of days, data is grouped into 24 elements representing each hour of the day. For example, if the date range spans a week the element representing 11pm will contain the sum of all values that fall into that hour throughout the week.

Options include:

  • Hour ( 60 Minutes )
  • Day (24 Hours)
  • Week (7 Days)
  • Month (31 Days)
  • Quarter (3 Months)
  • Year ( 12 Months)

See also DataEngine.DateGrouping | TimeInterval

Limiting Data

Generated data can be limited in two ways. First, you can limit the number of elements returned for each series by using the 'Limit' property of the data engine.

[C#]
myDataEngine.Limit = "5";

[Visual Basic]
myDataEngine.Limit = "5"

Notes

  • This property is a string not a numeric value.
  • If DateGrouping is used, limit has no effect, you can limit the return with the StartDate and EndDate in such a case.
  • When data is limited, elements with the lowest y value are eliminated first.

The second way is to limit the number of series generated when using split by. For an example of SplitBy, see: Tutorials > Simple Queries > Multiple Series from a Single Query.

[C#]
myDataEngine.SplitByLimit = "2";

[Visual Basic]
myDataEngine.SplitByLimit = "2"

Notes

  • This property is a string not a numeric value.
  • SplitBy Defined - SplitBy occurs automatically based on the values returned by the SqlStatement property. When a 3rd column is returned from your SQL statement it automatically creates any number of new series based on the value provided. This value must be returned as a field in the SQL statement defined for the series. For example if you have a number of sales by customer, you could choose to graph those values by week in which case you would have 1 series with 4 values for a month or, using SplitBy, you could choose to split by customer and see the individual breakdown of sales by customer - with a separate series for each customer! See the SqlStatement property for more information.
  • Series with elements whose summed y values are the lowest are eliminated first.
  • See also DataEngine.Limit | DataEngine.SplitByLimit

Show data eliminated with Limit properties

The additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series or element respectively, and graphed alongside the main data when the ShowOther property is true.

[C#]
myDataEngine.ShowOther = true;
myDataEngine.OtherElementText = "The Rest";

[Visual Basic]
myDataEngine.ShowOther = True
myDataEngine.OtherElementText = "The Rest"

Notes:

  • The 'OtherElementText' property will be used as the name of the aggregated element or as the name of the aggregated series.
  • See also DataEngine.ShowOther | DataEngine.OtherElementLabel

Get data eliminated by Limit properties

If you would like to show series eliminated by Limit or SplitByLimit when drilling down or in a legend box, the LimitMode enumeration can be used. For example if you limit data to 5 and would like to see the rest, the LimitMode.ExcludeTop enumeration member can be used.

[C#]
myDataEngine.LimitMode = LimitMode.ExcludeTop;
myDataEngine.Limit = "5";

[Visual Basic]
myDataEngine.LimitMode = LimitMode.ExcludeTop
myDataEngine.Limit = "5"

Focus Limit on a specific Series

This feature allows limit to be bound to a specific series. First the series will be limited based on the specified value, then .netCHARTING will automatically match any remaining series to that limit order rather than limiting for each series independently.

[C#]

myDataEngine.Limit = "5";
myDataEngine.LimitPrimarySeries = "customers";

[Visual Basic]

myDataEngine.Limit = "5"
myDataEngine.LimitPrimarySeries = "customers"

Formatting

The data engine may populate an element's name property. The name property is a string, therefore, in order to ensure proper formatting of those values we can set the 'FormatString' and 'CultureName' properties of the data engine:

[C#]
myDataEngine.FormatString = "d";
myDataEngine.CultureName = "en-US";

[Visual Basic]
myDataEngine.FormatString = "d"
myDataEngine.CultureName = "en-US"

Notes:

  • "en-US" is the default culture name.
  • See also DataEngine.FormatString | DataEngine.CultureName
Send comments on this topic.


General Tutorials

These tutorials demonstrate the functionality of .netCHARTING and its features.

  • Chart Type Anatomy 101
    How to create different chart types.
    • Gauge Types
      Describes gauge types and features.
    • Organizational Charts
      Describes organizational chart usage and features.
    • Financial Charts
      Demonstrates how financial charts are created.
    • TreeMap Charts
      Describes the TreeMap chart type and usage.
    • Surface Charts
      Describes the Surface chart type and usage.
    • Error Bars and other SubValues
      Shows how to use sub values such as ErrorBars.
    • Element Markers
      Describes element marker features.
    • Element Layout Control
      How axes manipulate element layout.
      • Elements And Axis Scales
        How axis scales are related to elements.
      • Advanced (Z Axis Effect)
        Advanced element layout focusing the the z axis.
    • MicroCharts
      Describes how to use microCharts.
  • Silverlight Navigator Introduction
    About the navigator
    • Overview
      Overview of the Navigator documentation.
    • User Interface (UI)
      How to use the navigator from end user point of view.
    • Programming API
      Describes how control and use the Navigator on web pages.
  • Interactive JavaScript ChartsDescribes functionality and usage of interactive javascript charts.
  • Mapping (GIS)
    Using the .netCHARTING mapping features.
    • Mapping API
      Describes the supporting API for mapping.
    • Data and Layers
      Using and manipulating map data.
    • Map Styling
      How to style and group shapes.
    • Rendering Features
      Covers projections and zooming.
    • Map Interactivity
      Describes features that enable interactivity with the map.
  • Ajax Zoomer Features
    Describes ajax related features like zooming and scrolling.
  • Version 7.0 Defaults and ShadingEffects
    Describes the new visuals and usage introduced in version 7.0
  • Coloring Elements
    Demonstrates how to color different elements.
    • Smart Palettes & Color Swatches
      Describes the SmartPalette features and usage including generating color swatches.
  • Creating And Using Templates
    Demonstrates how templates can be created, saved, and loaded.
  • Interactivity - Hotspots
    How to use image hotspots.
  • Interactivity - WinForms
    Implementing interactivity in WinForms.
  • Calendar Patterns
    Using calendar patterns.
  • Using Labels
    How to use and manipulate element labels.
    • Label Alignment and Control
      Describes how to manipulate element label positions.
    • Label Tokens Reference
      A reference of dynamic content tokens used in labels on a chart.
    • Formatting Values
      How to format values on a chart.
      • Advanced
        Advanced formatting features.
    • Label Layout Markup
      Describes embedded images and font styling options.
    • InfoGrids
      Discusses creating and using infoGrids.
    • MicroCharts
      Describes how to use microCharts.
  • Chart Surface Objects
    • Multiple Chart Areas
      How to use and manipulate multiple chart areas on a single image.
    • ChartArea Zooming
      Demonstrates zooming a cross section of a chart area.
    • Box Tutorial
      Basic box features. Box is the base object of annotations, legend boxes and title boxes.
    • Legend Tutorial
      How to use basic legend features.
      • Advanced
        Advanced legend features.
    • Data Sources
      Data sources used for label tokens and populating custom legend boxes.
  • Axis Tutorials
    A collection of tutorials describing the many features available.
    • Axis Scales
      How different scales behave and how to manipulate them.
      • Scale Synchronization
        How axes can synchronize scales with other axes.
      • Elements & Axis Scales
        How element values determine axis scales.
      • Advanced (Z Axis Effect)
        Advanced element layout focusing the the z axis.
    • Axis Ticks
      Using and manipulating axis ticks.
      • Minor Ticks
        Using minor axis ticks.
      • Axis Time Label Automation
        Using smart time label automation features.
      • Calculated Axis Ticks
        Automatically add axis ticks based on a calculated value.
    • Axis Markers
      Using and manipulating axis markers.
    • Multiple Axes
      Working with multiple axes.
      • Calculated Axes
        Using calculated axes to show data in different contexts.
    • Axis Value from Coordinates
      Shows how to retrieve the values of axes at specific image coordinates.
  • File Handling
    Working with files, caching, and other related issues.
  • Shortcuts and Efficient Code
    How to improve implementation efficiency.
  • Performance
    Discusses features and how they can affect performance.

Send comments on this topic.


Chart Type Anatomy 101

Introduction

Chart types are constructed using several settings. Among them, the most significant are:

  • Chart Type
  • Series Type
  • Axis Scale
  • GaugeType

These properties work in concert to provide unprecedented flexibility.

Chart Types

The most fundamental property, Chart.Type, determines the generic layout of series and in the case of pie, and radar, a type of chart. Axis scales further contribute to how elements are laid out, i.e. (Stacked). The series type determines how the series are drawn (line, bar, etc.).

[C#]

Chart.Type = ChartType.Radar;

[Visual Basic]

Chart.Type = ChartType.Radar
Show All
Hide All

Combo

Combo Chart Type

This chart type supports all the series types. It is vertically oriented so the y axis (value axis) can only contain numeric or time values while the x axis can also contain names of elements (category axis).

Supported Series Types

  • All

Element values (properties) used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize
  • Complete
  • (Financial: Open Close High Low)

Element values used on the (X Axis).

  • XValue
  • XDateTime
  • Name

ComboHorizontal

ComboHorizontal Chart Type

This chart types is horizontally oriented so the x axis can only contain numeric or time values. It is the same as the Combo type except it's oriented horizontally.

Supported Series Types

  • All (New in version 3.4)

Notice the X and Y properties are switched
Element values used on the (Y Axis).

  • XValue
  • XDateTime
  • Name

Element values used on the (X Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize
  • Complete
  • Element.Parent (Gantt Dependencies)
  • Element.InstanceID (Gantt Dependencies)
  • Element.ParentID (Gantt Dependencies)
  • (Financial: Open Close High Low)

Notice that the axes element values are reversed for this chart type, meaning the element XValue actually goes on the Y axis. The reason for this is so that if you change between vertical and horizontal chart types, the result will be the same.

ComboSideBySide

ComboSideBySide Chart Type

This chart type is similar to combo but series are placed side by side and the x axis tick labels show series names instead of element names. This layout can be achieved in a normal combo chart by transposing the data.

Supported Series Types

  • All

Element values used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize
  • Complete
  • (Financial: Open Close High Low)

Element values used on the (X Axis).

  • None (Series.Name us used)

Notes

  • SideBySide does not support unclustered columns.

Pie & Donut

Pie Chart Type

Shows a single pie consisting of all the series added to the chart where each slice represents a series.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • YValue

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.ForceMarker
  • Element.ExplodeSlice
  • Chart.PieLabelMode
  • Chart.ExplodedSliceAmount
  • Chart.DonutHoleSize (Donut Only)
  • Chart.XAxis.OrientationAngle

Notice that the series are slices when using this chart type, hence, if only a single series is used, the chart will have a single 100% slice. To see each element use the plural ChartType.Pies.

PiesNested

PiesNested Chart Type

Shows a series of nested pies.

Scale.Stacked
The width of each ring can also reflect the series total values when Chart.YAxis.Scale = Scale.Stacked is used. Alternatively Series.DefaultElement.BubbleSize can be used to specify ring widths and will be applied when these properties are set.

Scale.Normal
When Scale.Normal is used, the pies are not stacked, the ring width of each pie is measured from the middle point of the pies. This means that if two series have the same ring width, one will completely cover the other.

In this mode, SpacingPercentageNested is not applicable.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • YValue
  • Series.DefaultElement.BubbleSize (Control ring widths).

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.ForceMarker
  • Chart.SpacingPercentageNested
  • Chart.PieLabelMode

Radar

Radar Chart Type

Draws all series on a single radar. Both x and y axes are used. The x axis surrounds the radar and the y axis goes from the center to the outside.

Using this type will force each series to share a single x axis.
Supported Series Types
  • Marker
  • Line
  • AreaLine
  • Bubble
  • Column

Element values used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize

Element values used on the (X Axis).

  • Name
  • XValue
  • XDateTime

Related properties:

  • Chart.RadarLabelMode
  • Axis.RadarMode
  • Chart.XAxis.OrientationAngle
Polar Charts
The radar chart can support standard spider and polar axes. If the x axis uses a category scale, the default will be a spider axis (resembling a spider web). If the axis uses a numeric or time axis, the type will default to Polar. The type can also be specified explicitly using:
[C#]
Chart.XAxis.RadarMode = RadarMode.Polar;

[Visual Basic]
Chart.XAxis.RadarMode = RadarMode.Polar
Lines on polar charts will appear as curves. This is a feature which helps determine the actual values of lines along along the width of the lines.

MultipleGrouped

MultipleGrouped Chart Type

Draws all series as elements of a single object such as types specified by SeriesTypeMultiple.

Supported Series Types (SeriesTypeMultiple)
  • FunnelCone
  • FunnelPyramid
  • Pyramid
  • Cone
  • Pie
  • Donut
  • Gauge
  • StackedBubble (Uses Element.YValue, not Element.BubbleSize)

Element values used on the (Y Axis).

  • YValue

Related properties:

  • Chart.FunnelNozzlePercentage
  • Chart.FunnelNozzleWidthPercentage
  • Chart.SpacingPercentage
  • Chart.BubbleStackShadeAsOne
  • Chart.BubbleCenterStack

Gauges

Gauges Chart Type

Shows each series as a gauge. Each can be a different GaugeType.

Please refer to the Gauges Tutorial for detailed documentation.

Donuts

Donuts Chart Type

The series are laid out in a way that allows for the maximum space usage. One donut for each series.

Supported Series Types
  • N/A

Element values used on the (Y Axis).

  • YValue
  • Height (2D Only)

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.ForceMarker
  • Element.ExplodeSlice
  • Chart.PieLabelMode
  • Chart.ExplodedSliceAmount
  • Chart.DonutHoleSize
  • Chart.XAxis.OrientationAngle
  • Element.Outline

Radars

Radars Chart Type

Shows a radar for each series in the chart.

Supported Series Types
  • Marker
  • Line
  • AreaLine
  • Bubble
  • Column

Element values used on the (Y Axis).

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart
  • BubbleSize

Element values used on the (X Axis).

  • Name
  • XValue
  • XDateTime

Related properties:

  • Chart.RadarLabelMode
  • Axis.RadarMode
  • Chart.XAxis.OrientationAngle
Polar Charts
The radar chart can support standard spider and polar axes. If the x axis uses a category scale, the default will be a spider axis (resembling a spider web). If the axis uses a numeric or time axis, the type will default to Polar. The type can also be specified explicitly using:
[C#]
Chart.XAxis.RadarMode = RadarMode.Polar;

[Visual Basic]
Chart.XAxis.RadarMode = RadarMode.Polar
Lines on polar charts will appear as curves. This is a feature which helps determine the actual values of lines along along the width of the lines.

Multiple

Multiple Chart Type

Draws all series as individual objects. Different types are supported and can be specified by SeriesTypeMultiple for each series simultaneously. The benefit of this chart type is that it allows using different types such as pies, gauges, and the multiple types all on the same chart.

Supported Series Types (SeriesTypeMultiple)
  • FunnelCone
  • FunnelPyramid
  • Pyramid
  • Cone
  • Pie
  • Donut
  • Gauge
  • StackedBubble (Uses Element.YValue, not Element.BubbleSize)

Element values used on the (Y Axis).

  • YValue

Related properties:

  • Chart.FunnelNozzlePercentage
  • Chart.FunnelNozzleWidthPercentage
  • Chart.StackedSpacingPercentage
  • Chart.BubbleStackShadeAsOne
  • Chart.BubbleCenterStack

Pies

Pies Chart Type

Shows a single pie for each series in the chart.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • YValue
  • Height (2D Only)
  • Length

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.ForceMarker
  • Element.ExplodeSlice
  • Chart.PieLabelMode
  • Chart.ExplodedSliceAmount
  • Chart.XAxis.OrientationAngle
  • Element.Outline

Organizational

Organizational Chart Type

Shows an organizational chart based on the elements in the charts series collection.

Only Element annotations are used with this chart type. Annotation text can be specified but if left unpopulated, the element name text will be used inside the annotations.

An organizational chart has a single element at the top with no parent. Every other element will have either ParentID or Parent property set to indicate which other element it is under. All elements can be in a single series, however, the Series.Line property is used to draw connections between elements so multiple series can be used to group elements that use the same connecting line style.

Elements with no names or annotation text can be used to create more complex layouts by drawing a straight line through the location of the element as demonstrated in sample Gallery/M10

This type is explained in more detail in the Organizational Chart Tutorial.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • N/A

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.Annotation
  • Element.Parent
  • Element.InstanceID
  • Element.ParentID
  • Series.Line

TreeMap

TreeMap Chart Type

TreeMap charts are used to display hierarchial tree structure data with nested rectangles. TreeMap charts can be created using live data or manually. The boxes support all bar shading effects and smart label layout. Series.Box can be used to control the styling and header of each series box.

This type is explained in more detail in the TreeMap Charts Tutorial.

Supported Series Types

  • N/A

Element values used on the (Y Axis).

  • N/A

Element values used on the (X Axis).

  • N/A

Related properties:

  • Element.SmartLabel
  • Element.YValue
  • ChartArea.Padding
  • Series.Box
  • XAxis.Label

Surface

Surface Chart Type

The surface chart type enables visualizing 3d surface data. It provides a number of different visualizations and properties to tune them.

This type is explained in more detail in the Surface Tutorial.

Supported Series Types (SeriesTypeSurface)

  • Surface
  • Contour
  • SurfaceX
  • SurfaceY

Chart Properties

  • Chart.View3D.AngleOfTilt
  • Chart.View3D.AngleOfRotation
  • Chart.View3D.EnableLighting
  • Chart.ZAxis

Series Properties

  • Series.ZAxis
  • Series.Background
  • Series.Line

Element values (properties) used on the (Y Axis).

  • YValue

Element values used on the (X Axis).

  • XValue

Element values used on the (Z Axis).

  • ZValue

Other chart types such as Bubble, Scatter, and Gantt are obsolete but available for legacy support. They default to Combo, Combo, and ComboHorizontal respectively and set other properties to resemble the legacy results.

ChartType.Financial is also obsolete and unnecessary. It is provided only for backward compatibility as well.

Series Types

The next major contributor to chart types is the series type. The above chart type list includes a section on supported series types for each. Different series types can be specified for each series simultaneously using the following chart types:

  • Combo
  • ComboSideBySide
  • ComboHorizontal
  • Radar(s)
  • Multiple
  • MultipleGrouped
  • Surface

This allows you to create virtually unlimited number of different chart types.

SeriesType enumeration

[C#]

mySeries.Type = SeriesType.Line;

[Visual Basic]

mySeries.Type = SeriesType.Line

  • Marker
    • In 3D markers have no depth
    • Related Properties
      • Element.Marker
      • Element.YValue
      • Element.YDateTime
      • Series/Element.LegendEntry.Marker

  • Line
    • Supported in 2D and 3D.
    • Each element can have a different color along the same line series.
    • In 2D elements will automatically show element markers.
    • Line caps can be applied to 2D lines through the Series.Line line cap properties.
    • Related Properties
      • Series.Line (2D)
      • Element.YValue
      • Element.YDateTime
      • Element.Marker

  • Spline
    • Supported in 2D and 3D.
    • Each element can have a different color along the same spline series.
    • In 2D elements will automatically show element markers.
    • Line caps can be applied to 2D splines through the Series.Line line cap properties.
    • Related Properties
      • Series.Line (2D)
      • Element.YValue
      • Element.YDateTime
      • Series.SplineTensionPercent
      • Element.Marker

  • AreaLine
    • Supported in 2D and 3D.
    • Each element can have a different color along the same line series.
    • In 2D elements will automatically show element markers.
    • Supports Stacked Axis Scales.
    • Related Properties
      • Series.Line (2D)
      • Element.YValue
      • Element.YDateTime
      • Element.YValueStart
      • Element.YDateTime
      • Element.Marker

  • AreaSpline
    • Supports Stacked Axis Scales.
    • Related Properties
      • Series.Line (2D)
      • Element.YValue
      • Element.YDateTime
      • Element.YValueStart
      • Element.YDateTime
      • Element.Marker

  • Column & Bar
    • Supports Stacked Axis Scales.
    • Supports shading effects.
    • Supports Element.Outline
    • Supports Element.Complete indicator which is useful with Gantt charts.
    • With ComboHorizontal, gantt dependencies can be used and are defined the same way as organizational chart relationships.

  • Cylinder
    • Supports Stacked Axis Scales.
    • Supports Element.Outline
    • Supports 2D and 3D

  • Cone
    • Supports Stacked Axis Scales.
    • Supports Element.Outline

  • Pyramid
    • Supports Stacked Axis Scales.
    • Supports Element.Outline

  • Bubble
    • Requires Element.BubbleSize values.
    • Supports shading effects.
    • Supports Element.Outline
    • Related Properties
      • Element.BubbleSize
      • Chart.MaximumBubbleSize

  • BubbleShape
    • Requires Element.BubbleSize values.
    • Supports ShadingEffectMode.One
    • Supports 2D and 3D views.
    • Supports Element.Outline
    • Related Properties
      • Element.ShapeType
      • Chart.MaximumBubbleSize
      • LegendEntry.ShapeType
      • ShapeType Enumeration

SeriesTypeFinancial enumeration

[C#]

mySeries.Type = SeriesTypeFinancial.CandleStick;

[Visual Basic]

mySeries.Type = SeriesTypeFinancial.CandleStick

  • CandleStick
    • Element values used
      • Open or YValueStart
      • Close or YValue
      • High
      • Low
      • Complete
    • Supports column shading.
  • Bar
    • When a open value is not provided this bar will be an HLC bar, if provided it will be a OHLC.
  • Open
  • Close
  • High
  • Low
  • HighLowArea

SeriesTypeMultiple enumeration

  • FunnelCone
    • Related Properties
      • Chart.FunnelNozzlePercentage
      • Chart.FunnelNozzleWidthPercentage
      • Chart.SpacingPercentage
  • FunnelPyramid
    • Related Properties
      • Chart.FunnelNozzlePercentage
      • Chart.FunnelNozzleWidthPercentage
      • Chart.FunnelSpacingPercentage
  • Cone
  • Pyramid
  • Pie
  • Gauge
  • StackedBubble
    • Related Properties
      • Chart.BubbleCenterStack
      • Chart.BubbleStackShadeAsOne

This series type (SeriesTypeMultiple) applies to charts using ChartType.Multiple & ChartType.MultipleGrouped.

SeriesTypeSurface enumeration

[C#]

mySeries.Type = SeriesTypeSurface.Contour;

[Visual Basic]

mySeries.Type = SeriesTypeSurface.Contour

  • Surface
    • Element values used
      • XValue, YValue, ZValue
    • Related Properties
      • Series.InterpolationFillFactor
  • Contour
    • Element values used
      • XValue, YValue, ZValue
    • Related Properties
      • Series.ContourCount
  • SurfaceX
    • Element values used
      • XValue, YValue, ZValue
  • SurfaceY
    • Element values used
      • XValue, YValue, ZValue
  • Related Properties for All Surface Types
    • Series.DefaultElement.DrawToFloor
    • Series.ZAxis
    • Series.Use3D

Axis Scales

Further customization is achieved by specifying an axis scale. Besides controlling the quantitative scale type, scales also dictate how series behave. For example an axis scale can specify that columns are stacked.

See also: Element Values & Axis Scales | Element Layout and Axes | Z Axis effect

Conclusion

As you can see, the final chart type is fundamentally based on three settings. This mix and match concept may be more complicated than a single property, however, the flexibility it provides makes it well worth understanding.

See Also
{ErrorBars and other SubValues}
{Financial Charts}
{Mapping}
{Element Layout Control}
{Element Layout Control Advanced}
Send comments on this topic.


Gauge Types

Introduction
A number of different gauge types are available within the gauge series type and can be specified by the Series.GaugeType property. Each series on a gauge chart can use a different gauge type setting.

  • CS
  • VB
mySeries.GaugeType = GaugeType.Circular;

mySeries.GaugeType = GaugeType.Circular
Gauges can also be used with ChartType.Multiple and ChartType.MultipleGrouped when Series.Type = SeriesTypeMultiple.Gauges.

Automatic Padding Feature
Generally many of these gauge types are used by themselves without a legend or other features. When the chart detects that the legend is not visible and the chart area is not drawn (by using ChartArea.ClearColors()), it will automatically get rid of additional padding around the gauge.

Manual Sizing and Positioning (New in v4.4)
A static size can be applied to any gauge series by using the Series.Box.Position property and specifying a Size object.

  • CS
  • VB
mySeries.Box.Position = new Size(100,100);

mySeries.Box.Position = new Size(100,100)

This feature also allows absolute positioning of each gauge when a Rectangle object is used instead.

  • CS
  • VB
mySeries.Box.Position = new Rectangle(20,20,100,100);

mySeries.Box.Position = new Rectangle(20,20,100,100)
Circular gauges height must be the same as their width, therefore, only the specified Width is used with this feature.

QuickStart Illustration
The following illustration shows which properties control certain aspects of gauge types.

ImageTitle

Gauge type options (Series.GaugeType)

Circular
The circular type is the default gauge type used.

Custom Image Needles
This type also supports using custom images as needles along with the DynamicColor feature of ElementMarkers. For more information on using custom needles, see the Element Markers.

Supported Features

  • All axis scale types except for stacked scales.
  • Supports axis markers.
  • Multiple needle types
  • Multiple needles within a gauge
  • An icon within the gauge using YAxis.LabelMarker
  • Glass Shading when Chart.ClipGauges = false and Chart.Use3D = true

Related Properties

  • YAxis.Line (border line properties)
  • YAxis.LabelMarker
  • YAxis.OrientationAngle
  • YAxis.RangeAngle
  • YAxis.SweepAngle
  • Series.Background (background color)
  • Series.NeedleType
  • Series.GaugeBorderShape
  • Series.Box
  • Chart.ClipGauges
  • Chart.Use3D (effect when not clipped)

Bars
This gauge type can be useful displaying element values when an axis scale is not necessary.

Supported Features

  • All axis scale types.
  • Axis minimum/maximum settings
  • All bar ShadingEffectModes.
  • The XAxis Tick and Element's Label is used along side of the bars.
  • The tick and element labels can be aligned to right, left, or center (element label only).
  • Segmented Bar type when using Series.Type = SeriesType.BarSegmented

Related Properties

  • Series.Background (background color)
  • Series.GaugeBorderShape
  • Series.Box
  • Series.Type ( Bar or BarSegmented )
  • Chart.ShadingEffectMode

Digital Readout
This gauge type can be used to display element values using a digital readout style.

Supported Features

  • Digital readout font styles include Normal, Italic, Bold, and Bold Italic.
  • The XAxis Tick Label is used along side of the readout.
  • The axis tick and digital labels can be aligned to right or left.

Related Properties

  • Series.Background (background color)
  • Series.GaugeBorderShape
  • Series.Box
  • Series.Type ( Bar or BarSegmented )
  • Element.SmartLabel.Font (Used to specify digital readout font style)

IndicatorLights
These indicator LEDs can be used to convey the status of an element. If the element's value is < 0, the element's LED is grayed out, if the value is above zero, the element's color is used.

SmartPalette
Using smartPalettes with this type, the gray/colored feature based on value is deactivated. The smart palette is used to determine the element's color instead.

The size of the LEDs on a particular chart can be specified with Chart.DefaultElement.Marker.Size, however, by default the LED sizes are determined dynamically. The actual element markers however can be drawn separately on top of the LEDs when Element.ForceMarker is true as shown in sample Gallery/h018.aspx

Supported Features

  • All bubble ShadingEffectModes.
  • The XAxis Tick and Element's Label is used along side of the LEDs.
  • The tick and element labels can be aligned to right, left, or center (element label only).
  • Markers can be drawn on top of the LEDs.

Related Properties

  • Series.Background (background color)
  • Series.GaugeBorderShape
  • Series.Box
  • Chart.ShadingEffectMode
  • Chart.DefaultElement.Marker.Size

Horizontal & Vertical (Includes Thermometers)
The horizontal and vertical gauge types are linear bar gauges with the YAxis but no XAxis. The y axis applies to both horizontal and vertical the same way, when the type is horizontal, the YAxis is the horizontal one and with vertical, the YAxis is vertical.

Normal & Thermometer styles
To use the thermometer variation use the following setting:

  • CS
  • VB
Chart.DefaultSeries.GaugeLinearStyle = GaugeLinearStyle.Thermometer;

Chart.DefaultSeries.GaugeLinearStyle = GaugeLinearStyle.Thermometer

Bar Widths
By default the element widths snap to the size of the gauge's mini chart area, however, the XAxis.SpacingPercentage or XAxis.StaticColumnWidth settings will be used if specified.

Supported Features

  • All axis scale types except for stacked scales.
  • Multiple elements for bars and thermometers.
  • Supports axis markers.
  • Thermometer GaugeLinearStyle
  • All bar shading effect modes for thermometers and bars.
  • Supports Columns BarSegmented and Marker Series Types.
    *Markers not available on thermometers.
  • SubValues
  • Virtually all axis features of combo types are available.
  • ImageBarTemplate support

Related Properties

  • YAxis.Line (border line properties)
  • YAxis members
  • Series.Background (background color)
  • Series.GaugeBorderShape
  • Series.GaugeLinearStyle
  • Series.Box
  • Chart.XAxis.SpacingPercentage
  • Chart.XAxis.StaticColumnWidth
  • Chart.ShadingEffectMode

Please see the Features > Gauge Type Tweaks section in samples for examples using gauge types.

Send comments on this topic.


Organizational Charts

Introduction

Organizational charts can be created using .netCHARTING by getting data from live databases or by adding it manually in code. Organizational nodes can be decorated and styled in many ways by using the element annotation properties. Using the label markup language; custom layout, images and other content can be organized inside each node. Rich interactivity features are provided to enable organizational chart drilldown, node expansion, and AJAX scrolling for large datasets. Other useful navigation features include drilldown breadcrumbs and indicators to accent the node appearance.

About Organizational Charts

As with other charts, each node in an organizational chart is represented by an element object. The element's annotation is used to define node styling and content. Annotation label text can be specified to define the node content, but if not set, the element name will be shown inside the annotations.

An organizational chart has a single element at the top of the hierarchy. Every other element will have either ParentID or Parent properties set to identify its parent element. All elements can be in a single series, however, the Series.Line property is used to style the connections between elements so multiple series can be used to group elements that use the same connecting line style.

Elements with no names or annotation labels can be used as invisible placeholders to create more complex layouts. When used, a straight line is drawn through the location of the element as demonstrated in sample Chart Type Gallery/Organizational/M10.

Data Acquisition

To retrieve an organizational chart from a database table, each row must have an ID and a ParentID. This shows an example of how an organizational chart gets its data. It also adds several attributes to each element from other table columns such as Name, Office, Email, etc..

  • CS
  • VB
DataEngine de = new DataEngine(ConfigurationSettings.AppSettings["DNCConnectionString"]);
de.SqlStatement = @"SELECT * FROM Employees";
de.DataFields = "InstanceID=ID,InstanceParentID=PID,Name=Name,office,Department,Email,Phone,Picture";
Chart.SeriesCollection.Add(de.GetSeries());

Dim de As New DataEngine(ConfigurationSettings.AppSettings("DNCConnectionString"))
de.SqlStatement = "SELECT * FROM Employees"
de.DataFields = "InstanceID=ID,InstanceParentID=PID,Name=Name,office,Department,Email,Phone,Picture"
Chart.SeriesCollection.Add(de.GetSeries())

Custom attributes can be shown in the annotation (node) labels using tokens such as %Office %Email and so on. If iterating the elements in code, attributes can be retrieved using code such as:

string value = element.CustomAttributes["office"];

The attribute keys are case sensitive so if the above code does not work, use the debugger to evaluate the key values of the element.CustomAttributes collection.

For more information, see the Custom Attributes Tutorial.

Organizational SplitBy

Organizational nodes can be grouped into different series automatically based on the value of a specified database column. This code acquires the same data as the above, but it groups the nodes by 'Department'. Note that splitby is specified in the DataFields property.

  • CS
  • VB
DataEngine de = new DataEngine(ConfigurationSettings.AppSettings["DNCConnectionString"]);
de.SqlStatement = @"SELECT * FROM Employees";
de.DataFields = "InstanceID=ID,InstanceParentID=PID,Name=Name,office,Email,Phone,Picture,SplitBy=Department";
Chart.SeriesCollection.Add(de.GetSeries());

Dim de As New DataEngine(ConfigurationSettings.AppSettings("DNCConnectionString"))
de.SqlStatement = "SELECT * FROM Employees"
de.DataFields = "InstanceID=ID,InstanceParentID=PID,Name=Name,office,Email,Phone,Picture,SplitBy=Department"
Chart.SeriesCollection.Add(de.GetSeries())
Samples OrgGroups & OrgGroups2 demonstrate this feature.

Adding Data Manually

When adding organizational elements manually, either the element InstanceParentID or Parent properties must be set. The InstanceParentID property takes a numeric id matching the parent element's InstanceID property. Alternatively, the parent element object can be specified for each child element's Parent property.

This sample demonstrates adding nodes manually without IDs. It is useful because it makes adding data with code easier.

  • CS
  • VB
Element p1 = new Element("Margret Swanson");
Element vp1 = new Element("Mark Hudson");
Element vp2 = new Element("Chris Lysek");
vp1.Parent = p1;
vp2.Parent = p1;
Series s = new Series("", p1, vp1, vp2);

Dim p1 As New Element("Margret Swanson")
Dim vp1 As New Element("Mark Hudson")
Dim vp2 As New Element("Chris Lysek")
vp1.Parent = p1
vp2.Parent = p1
Dim s As New Series("", p1, vp1, vp2)

The following code snippet creates the same chart but using InstanceID and InstanceParentID properties to define the hirerarchy.

  • CS
  • VB
Element p1 = new Element("Margret Swanson");
Element vp1 = new Element("Mark Hudson");
Element vp2 = new Element("Chris Lysek");
p1.InstanceID = 1;
vp1.InstanceID = 2;
vp3.InstanceID = 3;
vp1.InstanceParentID = 1;
vp2.InstanceParentID = 1;
Series s = new Series("", p1, vp1, vp2);

Dim p1 As New Element("Margret Swanson")
Dim vp1 As New Element("Mark Hudson")
Dim vp2 As New Element("Chris Lysek")
p1.InstanceID = 1
vp1.InstanceID = 2
vp3.InstanceID = 3
vp1.InstanceParentID = 1
vp2.InstanceParentID = 1
Dim s As New Series("", p1, vp1, vp2)

Styling Organizational Charts

The chart area padding controls the spacing between nodes and chart edges. The Chart.DefaultSeries.Line property can be used to define the default connecting line styling between nodes.

To specify a default annotation style, instantiate a new annotation object for the Chart.DefaultElement.Annotation property and modify those properties. They will automatically be used by all the annotations on the chart, unless otherwise specified.

Using the .netCHARTING markup language provides a way to control the layout of the text and images inside the annotations. The markup language tutorial explains how to use this markup. The text and markup can be specified with the Annotation.Label.Text property.

Annotations have two content areas. When a string is set with Annotation.HeaderLabel.Text, that content is placed in a header which allows separate background styling.

  • Annotations try to maintain a certain width to height ratio by default which may result in odd rectangles. However, setting Annotation.DynamicSize = false will make the annotation size based on the content.
  • Annotations support a sizing option where only the height or width is provided and the other side sized automatically. This can be done by specifying a size with a value of 0 for the side that should size automatically:
    For example: Annotation.Size = new Size(100,0) Width will be 100 and the height will be automatically determined.

See also:

  • Annotation Class - annotation properties and usage.
  • Box Tutorial (Styling) - basics of box styling.
  • Label Tutorial - Token and attribute usage.

This sample code demonstrates styling the default annotation of a chart:

  • CS
  • VB
Chart.DefaultElement.Annotation = new Annotation();
Chart.DefaultElement.Annotation.Padding = 5;
Chart.DefaultElement.Annotation.Size = new Size(75, 30);
Chart.DefaultElement.Annotation.Background.ShadingEffectMode = ShadingEffectMode.Background2;

Chart.DefaultElement.Annotation = New Annotation()
Chart.DefaultElement.Annotation.Padding = 5
Chart.DefaultElement.Annotation.Size = New Size(75, 30)
Chart.DefaultElement.Annotation.Background.ShadingEffectMode = ShadingEffectMode.Background2

Iterating elements to specify styling individually is done in the same way except element.Annotation would be used for each object instead of Chart.DefaultElement.Annotation. However, the annotation must be instantiated for each element before accessing its properties.

Organizational Chart Navigation

Organizational chart nodes can be fairly large and with many of them on a chart, it is difficult to view them all at the same time. When a large number of nodes is loaded into a chart, the chart will try to render them on a larger image and scale it down to fit the chart area. This can result in nodes showing up very small.

A number of methods and features are provided to facilitate navigating large and complex organizational chars in a simple and intuitive way. This functionality is implemented with a lower level API that is more flexible and allows creating highly customized navigation experiences.

ASP.NET AJAX Scrolling

The most easy to use feature to facilitate navigating large organizational charts, is by using the AJAX Zoomer. Simply use Chart.Zoomer.Enabled = true to enable this feature. This feature behaves differently with organizational charts. There are no context menu options for zooming in or out. It allows the entire set to be loaded into a chart, and if it generates an image too large for the chart area, drag scrolling and scrollbars become available.

Sample: Feature Gallery/Chart Type Tweaks/OrgExpansionDB uses this feature.

Organizational Node DrillDown

This concept provides the ability to click on a node, and navigate into an organizational hierarchy subset without displaying all the nodes at the same time. The Series.Trim method provides this ability, and works by returning a subset of nodes based on the root ID of an element, and the number of subsequent levels of child nodes to include in the result. Annotation hotspots are used with a URL to postback the ID of the clicked annotation. Then the page must get this ID and pass it to the trim method in order to display the correct subset of nodes.

Sample: Feature Gallery/Chart Type Tweaks/OrgDrillDownDB demonstrates organizational drilldown with a live database.

Drilldown Breadcrumbs

Drilldown breadcrumbs provide a way to keep track of the location within an organizational hierarchy when using drilldown features. Breadcrumbs are common and look something like this:

Animals / Feline / Cheetah

Samples such as OrgDrilldown demonstreate how to use this feature in a drilldown context. The sample OrgBreadcrumbs uses this method to get an array of breadcrumb strings, and display them as annotations.

Consider the following code creating a breadcrumb path

string path = series.GetElementBreadcrumbs(elementID, elementCrumb, lastElementCrumb, separator);

The above usage specifies the elementID of the last element or 'Cheetah' in the above example. The elementCrumb is a label template that can use element tokens such as %Name. This would be applied to the underlined crumbs 'Animals' and 'Feline'. Common usage would require these nodes are linked. Using this string as the elementCrumb template will create links for those crumbs:

string elementCrumb = "<block url='?id=%id' fColor='blue' fStyle='underline'>%Name";

The lastElementCrumb can be just the name with no links or styling to indicate it is not clickable:

string lastElementCrumb = "<block>%Name";

The separator also uses the block tag to terminate any block tags previously added by the elementCrumb template.
string separator = " <block>/ ";

The resulting string can be added anywhere on the chart, like in the chart title box, chart area label, or in a floating annotation amongst others.

Organizational Node Attributes

The Series.Trim method also analyzes the dataset and optionally populates element attributes that indicate the level in the hierarchy and node type such as whether elements have parent or child nodes not shown in the resulting subset of nodes.

Sample OrgLevels uses the trim method to not trim the nodes but just to analize the dataset and populate organizational level attributes for each element. Then they are colored based on the hierarchical level.

This table describes the attributes added by the Trim method.

Attribute Name | Values and Descriptions
NodeType | EndNodeWithChildren - Indicates this element's children are trimmed from the result but child elements exist. RootWithParents - Indicates it is the root element in the result but parent nodes exist and were trimmed away. Root - The root of the result and dataset. NoChildren - Node has no children in the result or in the dataset.
OrganizationalLevel | A number ranging from 1 to n levels in the data set indicating the level of each particular element.

Organizational Indicators

The NodeType attributes can also be used to style the annotations by drawing an accent above or below the node. For example, if the element's NodeType attribute value is 'RootWithParents', an accent is drawn above the annotation, and if the value is 'EndNodeWithChildren', it is drawn it below it. This is demonstrated in sample OrgIndicators where these attributes are set manually to display the accent, and in sample OrgDBDrilldown where they are supplied by the trim method.

Organizational Node Expansion

This feature allows the user to click on any node to expand or collapse its children, thereby exploring the hirerarchy while displaying only the expanded nodes. This is similar to drilldown, however, it requires that a comma delimited list of expanded node IDs is maintained by the page code or application. Another overload of the Trim method can take this list of IDs and return only the nodes that should be visible.

Sample: Feature Gallery/Chart Type Tweaks/OrgExpansionDB demonstrates implementing this feature using a live database.

Combining Navigational Features

When using organizational expansion, it is useful to enable the AJAX zoomer so that when the expanded nodes create a large image, scrolling is enabled to help navigate around (Sample: OrgExpansionDB).

Because organizational charts with many elements can result is huge images, making the nodes smaller with less information can help fit much more of a hierarchy onto a chart. The additional information can be displayed in a tooltip. With label markup support for tooltips, the same string and layout used for annotations can be used in tooltips (Sample: OrgDBRichTooltips).

Send comments on this topic.


Financial Charts

Financial charts may create some confusion, never the less, making them works on the same principal as any other chart. There is, however, a difference in acquiring data.

Data Acquisition

First let's get data from a database which already has open, close, high, and low values using the DataEngine. In order to populate OCHL (open, close, high, low) element properties the DataEngine.GetFinancialSeries() method is used instead of GetSeris().

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.QueryString = "SELECT timeCol ,openCol, closeCol, highCol, lowCol, timeCol FROM stockPrice";
de.DataFields = "open=openCol,close=closeCol,high=highCol,low=lowCol,xValue=timeCol";

SeriesCollection stockSC = de.GetFinancialSeries();
stockSC[0].Type = SeriesTypeFinancial.CandleStick;
Chart.SeriesCollection.Add(stockSC);

[Visual Basic]

Dim de As New DataEngine(myConnectionString)
de.QueryString = "SELECT timeCol ,openCol, closeCol, highCol, lowCol, timeCol FROM stockPrice"
de.DataFields = "open=openCol,close=closeCol,high=highCol,low=lowCol,xValue=timeCol"

Dim stockSC As SeriesCollection = de.GetFinancialSeries()
stockSC(0).Type = SeriesTypeFinancial.CandleStick
Chart.SeriesCollection.Add(stockSC)

For the next example, we'll get our data from a database that has only the price column where the entries represent a price snapshot for every hour of the day over several months. We'll want to create the same type of chart as the above but obviously the data is not formatted in this manner. Fortunately the DataEngine is capable of grouping the data properly and calculating the high, low, open, and close prices. The DataEngine will know that this is the result we're going for when we use GetDataFinancial() instead of GetData().

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.DateGrouping = TimeInterval.Days;
de.QueryString = "SELECT timeCol, price FROM stockPrice";

SeriesCollection stockSC = de.GetFinancialSeries();
stockSC.Type = SeriesTypeFinancial.CandleStick;
Chart.SeriesCollection.Add(stockSC);

[Visual Basic]

Dim de As New DataEngine(myConnectionString)
de.DateGrouping = TimeInterval.Days
de.QueryString = "SELECT timeCol, price FROM stockPrice"

Dim stockSC As SeriesCollection = de.GetFinancialSeries()
stockSC.Type = SeriesTypeFinancial.CandleStick
Chart.SeriesCollection.Add(stockSC)

For more information on data acquisition, see: Data Tutorials.

Setting up Charts

ChartType.Financial
Please note that this chart type should not be used. It is there for backward compatibility. Using this chart type, a single series can be used where the element price properties are set as well as the volume value, however, the functionality will be limited. Instead use ChartType.Combo. The following example will show how to create the volume chart area using the newer more capable method.

[C#]

DataEngine de = new DataEngine(myConnectionString);
de.QueryString = "SELECT timeCol, volume, FROM stockVolume";
de.DateGrouping = TimeInterval.Day;
SeriesCollection volSC = de.GetData();

// Create a new chart area, add the volume data and add the area to the chart.
ChartArea vca = new ChartArea(volSC);
vca.HeightPercentage = 30;
Chart.ExtraChartAreas.Add(vca);

[Visual Basic]

Dim de As New DataEngine(myConnectionString)
de.QueryString = "SELECT timeCol, volume, FROM stockVolume"
de.DateGrouping = TimeInterval.Day
Dim volSC As SeriesCollection = de.GetData()

// Create a new chart area, add the volume data and add the area to the chart.
Dim vca As New ChartArea(volSC)
vca.HeightPercentage = 30
Chart.ExtraChartAreas.Add(vca)

For more information on using and manipulating ChartAreas, see: Multiple Chart Areas.

Send comments on this topic.


TreeMap Charts

Introduction

TreeMap charts are used to display hierarchial tree structure data with nested rectangles. TreeMap charts can be created manually or by using live data.

Features

  • Series Labeling - A label can be drawn inside the series rectangle, or a header can be applied to the series rectangle with all header related features supported.
  • Element Labelig - Element labels can dynamically adjust to fit better, and many common label properties are supported.
  • Color Ranges - Elements can be colored based on their values using a specified range of colors.
  • Color Range Swatches - The legend can display the values and their respective colors for reference.
  • Shading Effects - The element rectangles can use all the same shading effects as regular bar and column charts.

To use the treemap chart type, the following code can be used.

  • CS
  • VB
Chart.Type = ChartType.TreeMap;

Chart.Type = ChartType.TreeMap;

A TreeMap Chart

Series Spacing

With a single series on the chart, the spacing is ignored. With multiple series however, the ChartArea.Padding property specifies the space between the series boxes and chart area edges in pixels. The following code will create a 5 pixel gap between the series and chart area.

  • CS
  • VB
Chart.ChartArea.Padding = 5;

Chart.ChartArea.Padding = 5

Series Labeling

The series rectangle can be labeled in two ways on a TreeMap chart. A label can be drawn inside the series rectangle or the series rectangle can utilize a box header label.

Series.Box.Label
The first method involves using the Series.Box.Label property which will be rendered inside the series bounds. Tokens in this label's text will be evaluated for each series and will apply to all of them.

  • CS
  • VB
Chart.DefaultSeries.Box.Label.Text = "%Name %YSum";
Chart.DefaultSeries.Box.Label.LineAlignment = StringAlignment.Far;

Chart.DefaultSeries.Box.Label.Text = "%Name %YSum"
Chart.DefaultSeries.Box.Label.LineAlignment = StringAlignment.Far

Series.Box.Header.Label
The second method involves using the series box header label. In effect, the series rectangle is treated like the box content and the header is used to label it. The box in this context does not support corner styling or shadows.

The box header can place the series label outside the series bounds and can take up more space, however, it helps prevent the label from overlapping the elements and possibly hiding some data. Using Header.VerticalAlignment = EdgeAlignment.Edge is useful in this situation, as it does not intrude too much onto the series rectangle and minimizes the series label use of space.

See the Box Tutorial for more information about manipulating the box header. It offers a robust array of options that affect the way the header is drawn.

  • CS
  • VB
Chart.DefaultSeries.Box.Header.Label = "%Name %YSum";

Chart.DefaultSeries.Box.Header.Label = "%Name %YSum"

Series tokens can be used with both labeling methods and will be evaluated with the series information. See Tokens Reference for a full list of available tokens.

It is also possible to use both types of labels simultaneously. For example, one label can be used to describe the series name and the other to display values or totals.

Element Labeling

Element labels behave much like any other element labels using all the same applicable properties. If there is not enough space to fit the label properly, the chart will attempt to draw the label vertically, or wrap the text so it can be seen.

The following SmartLabel properties can be used.

  • AbsolutePosition
  • Alignment
  • AutoWrap
  • DynamicDisplay
  • ForceVertical
  • Hotspot
  • LineAlignment
  • Padding
  • Text
  • Truncation
  • And common visual enhancements: Color/Font/GlowColor/OutlineColor/Shadow/Type

  • CS
  • VB
Chart.DefaultElement.ShowValue = true;
Chart.DefaultElement.SmartLabel.Text = "%Name %YValue";
Chart.DefaultElement.SmartLabel.DynamicDisplay = false;

Chart.DefaultElement.ShowValue = true
Chart.DefaultElement.SmartLabel.Text = "%Name %YValue"
Chart.DefaultElement.SmartLabel.DynamicDisplay = false

Because SmartLabel overwrites the base label's Alignment property of type StringAlignment with an Alignment property of type LabelAlignment, you must cast the smart label to a label object and then set the base alignment property like so:

((Label)Chart.DefaultElement.SmartLabel).Alignment = StringAlignment.Near;

Coloring Elements

By default, all elements of a series will have the same color. This coloring is the default behavior for all chart types, and TreeMap uses the same generic algorithms. (See Figure 1)

For this chart type it can be useful to color each element with a different color. This is done by setting either Series.Palette or Series.PaletteName properties. (See Figure 2).

A much more useful coloring method is to use color ranges to automatically color elements based on their values. This allows an easy way to quickly understand the values of elements based on their colors. (See Figure 3).

When using color ranges, a legend color swatch may be used to allow the user to match element colors with their approximate values.

The Color Ranges tutorial describes how to use color ranges to apply to elements and how to create the legend color swatches.

Default coloring
Fig 1

Color per element.
Fig 2

Different color ranges
per series.
Fig 3

See Also

Tutorials

Box Headers for Series Tutorial
Color Ranges & Swatches
Send comments on this topic.


Surface Type

Introduction

The surface chart type enables visualizing 3d surface data. It provides a number of different visualizations and properties to tune them. The surfaces can be colorized based on z values utilizing smartPalettes. Any conventional series can be converted to surface data and charted.

The initial settings for a surface chart can look like so:

  • CS
  • VB
chart1.Type = ChartType.Surface;
chart1.Use3D = true;
chart1.LegendBox.Visible = false;
chart1.View3D.AngleOfTilt = 45;
chart1.View3D.AngleOfRotation = 45;

chart1.Type = ChartType.Surface
chart1.Use3D = True
chart1.LegendBox.Visible = False
chart1.View3D.AngleOfTilt = 45
chart1.View3D.AngleOfRotation = 45
QuickStart Tip: The sample SurfaceDesigner was designed to demonstrate all the related settings and provide a way to design a surface chart without writing code. The sample generates the code necessary to create those visuals.

Data Population

The surface chart type only supports a single data set at this time. There are two ways to populate series with surface data. One way is to add elements with the correct, x, y, and z values like with any other chart type. The other way is to supply arrays of these values to the Series.FromSurfaceData() method.

Samples:
SurfaceFromElements - Demonstrates populating data with elements
Surface__ - Nearly all others populate data with arrays

Performance Tip: Using arrays to populate the chart will reduce overhead and result in better performance over using multiple elements to define the data.

Surface Data From regular series.

Category Series to Surface Data

A category series is one where elements use names (strings) as x axis values. The method SeriesCollection.GetSurfaceData() can be used to convert a SeriesCollection of category series for surface charts. When converting, the element names are mapped to the x axis, series names are mapped to the y axis and y values become the z component of surface data.

SeriesCollection.GetSurfaceData(out List<string> xLabels, out List<string> yLabels)

The above method will return a series with surface data and populate the label lists with element and series names that can be used on the axes.

The following code demonstrates how the lists can be used on axes.

  • CS
  • VB
List<string>  xLabels = new List<string>();
List<string>  yLabels = new List<string>();
Series s = GetSurfaceData(out xLabels, out yLabels);
 Chart.XAxis.ClearValues = true;
 for (int i = 0; i < xLabels.Count; i++)
 {
    Chart.XAxis.ExtraTicks.Add(new AxisTick(i, xLabels[i]));
 }

 Chart.YAxis.ClearValues = true;
 for (int i = 0; i < yLabels.Count; i++)
 {
    Chart.YAxis.ExtraTicks.Add(new AxisTick(i, yLabels[i]));
 }

Dim xLabels As List(Of String) = New List(Of String)()
Dim yLabels As List(Of String) = New List(Of String)()
Dim s As Series = GetSurfaceData(xLabels, yLabels)
Chart.XAxis.ClearValues = True
For i As Integer = 0 To xLabels.Count - 1
  Chart.XAxis.ExtraTicks.Add(New AxisTick(i, xLabels(i)))
Next i
Chart.YAxis.ClearValues = True
For i As Integer = 0 To yLabels.Count - 1
  Chart.YAxis.ExtraTicks.Add(New AxisTick(i, yLabels(i)))
Next i

Alternatively, by passing the chart axes to this method, they will be populated automatically.

SeriesCollection.GetSurfaceData(Axis xAxis, Axis yAxis)

Sample:
SurfaceFromCategoryData - Demonstrates converting category data into surface data.

Time Series to Surface Data

The chart provides an easy way to create surface data from any regular time based series by grouping them based on a time interval. When using the Series.GetSurfaceData method on a populated series, an x axis date grouping interval can be specified and the method will return a series containing surface data along with an array of dates to represent the x axis tick values. This enables any series with elements that use XDateTime property to be plotted on a surface chart.

Samples:
SurfaceTimeDB - Demonstrates populating a surface chart with live date based data.
SurfaceDateGrouping - Demonstrates populating a surface chart with live date based data offering an option to select the date grouping interval.

3D View Angles & Lighting

The properties under Chart.View3D provide control over the view angles and lighting. The chart can be rotated between 0 and 180 degrees and tilted between 0-90 degrees. Lighting emulates a light source located at the top of the z axis where the x and y axis minimum values are located.

  • CS
  • VB
chart1.View3D.AngleOfTilt = 45;
chart1.View3D.AngleOfRotation = 45;
chart1.View3D.EnableLighting = true;

chart1.View3D.AngleOfTilt = 45
chart1.View3D.AngleOfRotation = 45
chart1.View3D.EnableLighting = true

Chart.Use3D can be set to true to make the surface chart draw in 3D. Each series has its own Use3D setting as well. This enables mixing 2D and 3D visuals on the same chart.

Series Data Visuals

The surface type offers a flexible API with an endless array of setting combinations that control the visualization.

Four base surface types

Surface charts utilize the SeriesTypeSurface enum members to define the series type when used with the Series.Type property. The following four surface types are available.

  • CS
  • VB
series1.Type = SeriesTypeSurface.Contour;

series1.Type = SeriesTypeSurface.Contour

Surface: The surface type draws a 3D surface or a 2D heatmap. It supports the Series.InterpolationFillFactor property which accepts an integer specifying the number of different x and y color sections to split a single tile into. Surface supports 2D and 3D as well as 2D in 3D mode.

Contour: The contour type draws a 2D or 3D surface partitioning the plane into a number of contours defined by Series.ContourCount. Contour supports 2D, 3D, and 2D in 3D mode.

SurfaceX & SurfaceY: These types are similar to surface except they connect points over only the x or y axis and no surface is filled unless the DrawToFloor option is used. When used with the DrawToFloor option, they resemble AreaLines.

Series layering

Only data from the first series is plotted on a surface chart, however, multiple series can be added with different settings to create more complex visuals. The additional series will render using the first series' data but with their own styling and type settings.

This code can be used to add a 2D contour visualization to a 3D surface chart.

  • CS
  • VB
Series s1 = new Series();
s1.Type = SeriesTypeSurface.Contour;
s1.Use3D = false;
Chart.SeriesCollection.Add(s1);

Series s1 = new Series()
s1.Type = SeriesTypeSurface.Contour
s1.Use3D = false
Chart.SeriesCollection.Add(s1)

Chart with multiple series.

Series Type Variations/Options

The following properties are available per surface series types:

 | ContourCount | InterpolationFillFactor | DrawToFloor | Use3D
Surface |  |  |  |
Contour |  |  |  |
SurfaceX |  |  |  |
SurfaceY |  |  |  |

Series.ContourCount | The contourCount setting specifies the number of contours to divide the surface into when used with SeriesTypeSurface.Contour. The z value range is divided into this number of contours evenly.
Series.InterpolationFillFactor | This property is used with SeriesTypeSurface.Surface. When the setting is higher than 1, the tiles connecting the surface points are split and draws multiple interpolated colors. A setting of 2 divides the tile into 4 different color sections for example (2x2).
DefaultElement.DrawToFloow | When this setting is set to true, 3D surface and contour series fill the outside bounds of the surface connecting them to the chart area floor. It can help enhance visualizing the outside edges of a surface shape. This setting is not applicable with 2D series. When used with SurfaceX or SurfaceY, the visual resembles AreaLines. See image below.
Series.Use3D | This setting indicates whether a series is drawn in 2D or 3D.

Types with DrawToFloor Enabled

Coloring Surface Series

By default, a surface or contour series will use a single color defined by the chart palette or default element of the series. It is much more useful to color surface charts with dynamic colors based on the z value. The smartPalettes enables this functionality. See the SmartPalette tutorial for more info and options.

Legends
Generally, legend boxes are not useful with surface charts so it's best to disable them. Instead color swatches can be used which can be added to any label on the chart.

Surfaces are drawn by connecting elements, then filling sections and drawing the outlines. When dynamic colors are used, static colors can overwrite the styling of lines and fills independently. The fill and line transparencies can be set independently as well. Lines can also use other styling specified with Series.Line properties such as DashStyle. Series.Background is used to control the fill through color and transparency settings.

Styling API Properties

Following are some examples of color and transparency tasks and code necessary to achieve them.

Creating a smart palette from data and a list of colors:

  • CS
  • VB
Chart.SmartPalette = series1.GetSmartPalette(ElementValue.ZValue,Color.Green,Color.Red);

Chart.SmartPalette = series1.GetSmartPalette(ElementValue.ZValue,Color.Green,Color.Red)

Apply uniform transparency for the surface:

  • CS
  • VB
series1.DefaultElement.Transparency = 50;

series1.DefaultElement.Transparency = 50

Control transparency of just the fill:

  • CS
  • VB
series1.Background.Transparency = 20;

series1.Background.Transparency = 20

Control transparency of just the lines:

  • CS
  • VB
series1.Line.Transparency = 20;

series1.Line.Transparency = 20

Use a solid color for the fill:

  • CS
  • VB
series1.Background.Color = Color.White;

series1.Background.Color = Color.White
Tip: Use line transparency of about 70% on solid surface and contour series to achieve a smooth look.

Palette Transparency Features

The SmartPalette also supports transparent colors enabling sections of a surface to be translucent or transparent. A number of samples are available to demonstrate these features.

This sample demonstrates using a palette that includes a transparent color. Color transparency is interpolated between it and solid colors within the palette resulting in a smooth visual.

Sample: Gallery P043

When the smart palette does not encompass a value, those sections will not be rendered.

Sample: SurfaceViewsTransparent

This functionality can be used to render a heatmap on top of an image.

Sample: SurfaceImageHeatmap

Axes and surfaces

The axes of a 3D chart support most of the same features as combo charts. Different scales like logarithmic, inverted, scale breaks, etc. are all supported on surface charts. Surface charts support only numeric axis scales at this time however, time and category scales can be easily emulated as described below and in the Data Population section above. 2D surface charts support only numeric scale also, but they support all other numeric axis features like axisMarkers and range ticks because the core combo chart rendering is used for the chart area and axes. Some features like axis markers are not supported in the 3D view but custom ticks can be used to simulate single value axis markers by changing the tick's gridline properties.

Time / Category Axis Scales

Surface charts support only numeric axis scales at this time, however, other axis features allow replacing the axis labels with strings which enables simulating any type of axis necessary. In order to use string axis labels relating to surface data, create an array holding the text labels and use the array index value instead of the string to specify the x values for the data. Then iterate the string array adding axis ticks with the array index as the value and corresponding string as the tick label text. This will replace the numeric ticks on the axis with the correct labels.

Sample: SurfaceAxisLabels - Demonstrates category scale type axes.

The method Series.GetSurfaceData() outputs a list of DateTime objects that can be mapped to the axis ticks and is demonstrated in the following samples:

Samples:
SurfaceTimeDB - Demonstrates populating a surface chart with live date based data.
SurfaceDateGrouping - Demonstrates populating a surface chart with live date based data offering an option to select the date grouping interval.

For more information, see the Data Population section above.

Axis Scales

By default, axes with a Scale.Normal setting behave slightly different than they do with combo charts. With surface charts, the axis range snaps to data to remove any gaps whereas with combo charts the axis range maximum values are rounded up to the nearest interval.

The supported scales are:

  • Normal
  • Range
  • Logarithmic

Z Axis

The z axis of a surface chart behaves the same as the x and y axes. It can be accessed through the Series.ZAxis and Chart.ZAxis properties.

ScaleBreaks

ScaleBreaks are supported, they are drawn as a line with a zigzag in the middle. This line styling can be controlled through Axis.ScaleBreakLine.

Sample: SurfaceAxisScaleBreak

Send comments on this topic.


ErrorBars and other SubValues

Introduction

.netCHARTING has an advanced system for handing error bars and other sub value types that are used in many statistics charts. Element and series classes have properties that quickly set sub values, however, there is a more powerful system underneath that controls and helps manage these sub elements.

SubValue Class Constructors

Each sub value is represented by a class that is instantiated by a number of sub value constructors that define its value.

SubValue offsets and percent values will be based on the element's yValue.

Constructor | Type | Description
FromHighLowValue(highValue,lowValue) | Range | Creates a range sub value from specified high and low values.
FromPlusMinusOffset(plusOffset,minusOffset) | Relative Range | Creates a range sub value from specified high and low offsets.
FromPlusMinusOffset (o) | Relative Range | Creates a range sub value from specified offset above and blow the element's yValue.
FromPlusMinusPercent (hPercent,lPercent) | Relative Range | Creates a range sub value from specified percentages above and below the element's yValue.
FromPlusMinusPercent (percent) | Relative Range | Creates a range sub value from the specified percentage above and below the element's yValue.
FromOffset(o) | Relative Single Value | Creates a subValue from the specified offset. (-2) will be below the element's yValue and (2) will be above.
FromPercent(p) | Relative Single Value | Creates a subValue from the specified percentage. (-50) will be below the element's yValue and (50) will be above.
FromValue(v) | Single Value | Creates a subValue from the specified value.

Adding SubValues

Each element contains a SubValueCollection under the Element.SubValues property. Adding a sub value can be done simply be adding it to that collection.

[C#]

Element e = new Element();
e.SubValues.Add(SubValue.FromOffset(5));

[Visual Basic]

Dim e As new Element()
e.SubValues.Add(SubValue.FromOffset(5))

The element e now contains a subValue which is equivalent to e.YValue + 5.

SubValues Appearance

There are a few options available that determine how a subVlaue will be drawn with an element. These options are specified with the SubValueType enumeration.

  • SubValueType.ErrorBar
    A traditional error bar stemming from the top of an element.
    NOTE: An idential error bar drawn on top and bottom of the element is achieved when the element values specify a range (YValue and YValueStart is set).

  • SubValueType.Marker
    A marker or two markers for range sub values.
  • SubValueType.Line
    Similar to error bars but without the vertical line.

This code snippet demonstrates how the appearance properties can be used.

[C#]

SubValue sv = SubValue.FromOffset(5);
sv.Type = SubValueType.Marker;
sv.Marker.Type = ElementMarkerType.Circle;
sv.Marker.Color = Color.Red;

SubValue sv2 = SubValue.FromOffset(5);
sv2.Type = SubValueType.Line;
sv2.Line.Color = Color.Black;
sv2.Line.DashStyle = DashStyle.Dash;

[Visual Basic]

Dim sv As SubValue = SubValue.FromOffset(5)
sv.Type = SubValueType.Marker
sv.Marker.Type = ElementMarkerType.Circle
sv.Marker.Color = Color.Red

Dim sv2 As SubValue = SubValue.FromOffset(5)
sv2.Type = SubValueType.Line
sv2.Line.Color = Color.Black
sv2.Line.DashStyle = DashStyle.Dash

Default Settings

SubValues can be quickly added and manipulated for all elements within a series or series collection. When a SubValue is added to a series' default element it is also added to all subsequent elements automatically.

This code snippet automatically adds a subValue to all elements on the chart.

[C#]

Chart.DefaultSeries.DefaultElement.SubValues.Add(SubValue.FromOffset(5));

[Visual Basic]

Chart.DefaultSeries.DefaultElement.SubValues.Add(SubValue.FromOffset(5))

SubValues default appearance can also be specified quickly by using the element's DefaultSubValue properties.

[C#]

Chart.DefaultSeries.DefaultElement.DefaultSubValue.Line.DashStyle = DashStyle.Dash;

[Visual Basic]

Chart.DefaultSeries.DefaultElement.DefaultSubValue.Line.DashStyle = DashStyle.Dash
Limitations
  • SubValues are not available with financial series types.
  • Not available with stacked scales.
  • Time scales don't support error bars.
Send comments on this topic.


Element Markers

Introduction
The SeriesType.Marker series type draws an element marker for each element. The properties of these markers can be accessed through Element.Marker.

Tips:

1. Using Chart.DefaultElement.Marker allows setting all element marker properties simultaneously.

2. When using some series types like line or spline in 2D mode, markers are automatically drawn. They can be turned off by setting Chart.DefaultElement.Marker.Visible = false

3. Markers can always be drawn on any series / chart types by specifying Element.ForceMarker = true.

Element Markers as Shapes
Element Markers can appear in a number of different shapes specified by the ElementMarkerType enumeration.

ElementMarkerType

  • Square
  • Triangle
  • TriangleUpsideDown
  • Circle
  • Diamond
  • ArrowUp
  • ArrowDown
  • FourPointStar
  • FivePointStar
  • SizPointStar
  • SevenPointStar
  • Split (Finance Related)
  • ReverseSplit (Finance Related)
  • Merger (Finance Related)
  • Dividend (Finance Related)
  • Spinoff (Finance Related)

Element Markers as Images
Element markers can also use custom images loaded from disk instead of the pre-defined shapes.

  • CS
  • VB
myElement.Marker = new ElementMarker("image.png");

myElement.Marker = New ElementMarker("image.png")

Using Dynamic Colors with custom images
The DynamicImageColor feature allows colorizing custom marker images to match the colors of elements they represent. The sections of the image that are colorized are based on a specified DynamicColor.

  • CS
  • VB
myElement.Marker.DynamicImageColor = Color.FromArgb(123,123,123);

myElement.Marker.DynamicImageColor = Color.FromArgb(123,123,123)

The Png image format allows variable transparency meaning, a pixel can have a specific color as well as an alpha part which indicates the pixel's transparency from 0(transparent) to 255(solid). The actual color of a particular pixel does not have to change along a fade to a transparent color. The dynamic color feature is capable of maintaining the original transparency of each pixel while replacing it with the element's color, provided the pixel's color matches or closely resembles the specified dynamic color.

DynamicImageColorTolerance

Many times, images don't use solid colors, instead they use antialiasing which blurs hard edges creating a smoother looking transition. By specifying a tolerance (0-100) the dynamic color will cover a wider range of colors based around the main dynamic color. At the same time, it will maintain the difference in deviation from the main color, therefore, the element's color will not be applied to colors within the tolerance range the same way. The color will vary to replicate the original images variations such as slight highlights.

Custom Circular Gauge Needles
The element marker can also be used with the circular gauge and a custom image to allow custom gauge needles. The following illustration shows a sample custom needle image and resulting chart.

  • CS
  • VB
Chart.YAxis.GaugeNeedleType = GaugeNeedleType.UseMarker;
Chart.DefaultElement.Marker = new ElementMarker("../../images/needle2.png");
Chart.DefaultElement.Marker.DynamicImageColor = Color.FromArgb(255, 255, 255);

Chart.YAxis.GaugeNeedleType = GaugeNeedleType.UseMarker
Chart.DefaultElement.Marker = New ElementMarker("../../images/needle2.png")
Chart.DefaultElement.Marker.DynamicImageColor = Color.FromArgb(255, 255, 255)
Send comments on this topic.


Element Layout Control

Element Layout Control

Introduction
This section will describe the following:

  • Sizing Columns
    How axes influence the element behavior and appearance.
  • Clustering Columns
    How axes control column and cylinder clustering.

Besides the obvious, an axis can also control how elements drawn on its scale behave. These behavioral features are determined by the axis that shows element names or x values. For a vertical combo chart this would mean the x axis and y axis for horizontal combo.

Column and Cylinder Widths

  • SpacingPercentage
    Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
  • StaticColumnWidth
    Gets or sets the static bar width in pixels.

Example: This code specifies the column or cylinder widths for a ChartType.Combo chart.

[C#]

Chart.XAxis.SpacingPercentage = 30; // Default is 16
// When this property is set, it takes precedence over spacing percentage.
Chart.XAxis.StaticColumnWidth = 20;

[Visual Basic]

Chart.XAxis.SpacingPercentage = 30 ' Default is 16
' When this property is set, it takes precedence over spacing percentage.
Chart.XAxis.StaticColumnWidth = 20
Tip: The column width control also defines the tool tip hotspot width of area line series types.

Clustering Columns / Cylinders
This feature enables columns in 3D modes to cluster (draw side by side) or not (draw one in front of the other). The default behavior is to cluster and column must be clustered in 2D mode.

[C#]

Chart.Use3D = true;
Chart.XAxis.ClusterColumns = false;

[Visual Basic]

Chart.Use3D = True
Chart.XAxis.ClusterColumns = False

Other options include

  • Position
    The axis positions when 2 or more axes are drawn on the same side of a ChartArea.
  • ReverseSeriesPositions
    Indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
  • ReverseSeries
    Indicates whether the positions of series bound to this axis are reversed.
  • ReverseStack
    Indicates whether the order of stacked elements is reversed.
See Also
{Element Layout Control Advanced}
{Elements & Axis Scales}
Send comments on this topic.


Elements And Axis Scales

Introduction

While there are many options for scales, .netCHARTING can automatically determine the appropriate scales based on your data. This tutorial will demonstrate how element data influences axis scales.

The Y Axis ( value axis )

We will call this the y axis but by 'value axis' we don't literally mean (Y) axis. With ChartType.ComboHorizontal for instance we would be referring to the x axis. For all others however it is the y axis. The element values that influence this axis are

  • YValue
  • YValueStart
  • YDateTime
  • YDateTimeStart

[New in v5.0]
The elements of a series can be excluded from the axis scale range using Series.ExcludeFromAxisRange = true

The automatically chosen axis scales here are either Normal or Time. It is determined by whether the YValue (numeric) or YDateTime (time) values are specified for each element.

The following table shows value settings of these element properties that the chart engine will consider not set.

  • YValue & YValueStart
    Setting: double.NaN
  • YDateTime & YDateTimeStart
    Setting: DateTime.MinValue

The X Axis (Category / Value Axis)

Y Axis using ChartType.ComboHorizontal

The x axis is very powerful, it can operate just like the y axis value axis as well as a category axis. If the elements have names (Element.Name) specified, the axis scale will be a category scale. However, if the elements have either XValue or XDateTime properties set, the appropriate value axis scale will be chosen.

The element properties that influence the x axis type are:

  • Name
  • XValue
  • XValueStart
  • XDateTime
  • XDateTimeStart

Even if all numeric or time values are provided, setting any of the element's Name properties will yield a category axis scale and values will become names for elements without specified names.
The data engine will always provide elements with both, names and values if the names represent numeric or time values. By default this creates a category scale. To use a value scale instead, set the axis scale property to the appropriate scale. Scale.Normal for numeric and Scale.Time for date time values.
Setting the scale through DefaultAxis.Scale will not produce the same result.
  • CS
  • VB
Chart.XAxis.Scale = Scale.Time;

Chart.XAxis.Scale = Scale.Time
Smart Category Axis
A smart category axis scale is one that contains elements with names and values but the names are string representations of the value properties. The 'smart' part is that despite it being a category (string) axis, the elements will be sorted in sequence based on the values they represent.
To use this axis type you must use the DataEngine and specify 'XAxis=valueDBColumn' in its DataFields property.
See Also
Scale Enumeration
Scale Property

Tutorials

Data Field Mapping
Data Engine
Send comments on this topic.


Element Layout Control Advanced

Z-Axis Effect

Using multiple axes with series can yield some interesting results you may not be aware of. We'll explore a situation that simulates a z axis. A basic z axis can be simulated by setting the x axis ClusterColumns property to false:

  • CS
  • VB
Chart.XAxis.ClusterColumns = false;

Chart.XAxis.ClusterColumns = false

This may show a chart that looks like this:

Gantt chart tip:

The CluseterColumns feature is only available when Chart.Use3D = true, however, it is still possible to use this feature in 2D by using 3D but emulating a 2D chart by setting the Chart.Depth property to zero. This trick may be most useful when creating Gantt charts which require element columns from different series (but using the same element names) to occupy the same horizontal space (with vertical 'Combo') or vertical space with ComboHorizontal charts.

Using X Axes

This works well however if we wanted a z axis with two steps and two clustered series on each step we will have to use two X axes. This time we will also omit setting the cluster columns property to false.

  • CS
  • VB
Axis a2 = new Axis();
mySC[0].XAxis = a2;
mySC[1].XAxis = a2;
a2.Clear();

Dim a2 As New Axis()
mySC(0).XAxis = a2
mySC(1).XAxis = a2
a2.Clear()
We "Clear()" the second axis so that only the original one is visible.
Tip: This method also allows overlapping columns
in 2D mode which is useful in Gantt charts:

Using Y Axes
Y axes will typically not affect the z axis. For example using the following code where we give two of the four series a new y axis and set the scale to stacked:
  • CS
  • VB
Axis a2 = new Axis();
mySC[0].YAxis = a2;
mySC[1].YAxis = a2;
a2.Scale = Scale.Stacked;

Dim a2 As New Axis()
mySC(0).YAxis = a2
mySC(1).YAxis = a2
a2.Scale = Scale.Stacked
Will yield this result:

Notice that the new y axis is stacked but still the main x axis manages the clustered - unclustered layout. Therefore if we wanted to uncluster the columns we could have multiple z axis steps and some may be stacked while other wont.

  • CS
  • VB
Chart.XAxis.ClusterColumns = false;

Chart.XAxis.ClusterColumns = false

Please note that using multiple value axes while hiding one of them may result in one going out of sync with the other. This will result in the bars indicating incorrect values (according to the visible value axis). This issue can be resolved by synchronizing the visible with the invisible axes.

For more information see the scale synchronization tutorial.

Sample: AxisDualScales.aspx

Send comments on this topic.


Micro Charts

Introduction

MicroCharts are miniature versions of actual charts, designed to help viewers understand complex relationships between data in repetitive scenarios such as data grids or InfoGrids. MicroCharts are optimized to use very little space and are ideal for data grids, info grids or use as parts of labels within charts. MicroCharts are defined using a markup language inside the chart label text. This means that anywhere a label is used, a microChart can easily be embedded. With the use of tokens, microCharts can be setup using default properties and will automatically represent the label's parent objects token values. InfoGrids are similar to traditional data grids but are generated entirely within chart labels. MicroCharts and InfoGrids are two unique technologies that are ideally suited for each other; MicroCharts enrich InfoGrids with concise data visualizations. Please see the tutorial on InfoGrids for additional information on data grid and dashboard usage.

Basic Usage

To use a microChart in a label, use a syntax that starts with <Chart: then the type of microChart and other options ending with a closing '>' character. Parameters must be specified using a format like param='value' using single quotes around the value as shown below:

  • CS
  • VB
Chart.TitleBox.Label.Text = "<Chart:Bar value='5' max='10'>";

Chart.TitleBox.Label.Text = "<Chart:Bar value='5' max='10'>"

MicroChart Types

Each microChart type has a number of options available. Similar types work alike but all share the same syntax.

  • Bar
    <Chart:Bar value='5' max='10'>
    Draws a basic bar. Usually used with a max attribute so it lines up with other bars in a grid format.
  • BarGauge
    <Chart:BarGauge value='5' max='10'>
    This type is similar to Bar except a full width translucent version of the bar is drawn underneath like GaugeType.Bars on normal Charts.
  • BarFull
    <Chart:BarFull values='5,4,3' >
    Values specified for this type are placed on a 100% stacked axis.
  • Column
    <Chart:Column values='5,4,3' >
    Creates a series of columns based on specified values. This type is different (in appearance) than regular combo column charts because it's optimized for small sizes and does not support shading effects.
  • WinLose
    <Chart:WinLose values='1,1,1,1,-1,-1,-1'>
    This type is similar to Column except it only takes values -1,0,or 1 to represent a loss, tie, or win respectively. It is also useful in showing the status of something like a server functioning normally or being down over time.
  • Progress
    <Chart:Progress value='5' max='10'>
    This type is similar to Bar except the bar is drawn in segments.
  • ProgressGauge
    <Chart:ProgressGauge value='5' max='10'>
    This type is similar to BarGauge except the bar is drawn in segments.
  • Bullet
    <Chart:Bullet values='20,18,8,13' max='25'>
    The bullet type shows a value (bar) a target (vertical line segment) and AxisMarker bands indicate additional target or status.
  • Sparkline
    <Chart:Sparkline values='5,4,3' >
    A sparkline is similar to a line chart but without the extras like grid lines.
  • Arealine
    <Chart:AreaLine values='5,4,3' >
    Similar to an AreaLine chart but without the extras like axes.
  • Scale and ScaleB
    <Chart:Scale min='0' max='100'>
    The scale micro chart is designed to be used in a header of a column that will show micro charts based on that scale range. By specifying the same width for the scale and subsequent charts, it will ensure the charts in that column line up with each other and the scale. Using a scale also requires that the same max parameter value is set for all the charts so the values of each chart correspond to the values indicated by the scale. In some cases, the min parameter may also be required. ScaleB works the same as Scale, except it faces upward instead of facing down like Scale does.
  • Pie
    <Chart:Pie values='5,4,3' >
    Simple pie microChart
  • Pie3D
    <Chart:Pie3D values='5,4,3' >
    Same as pie but uses the 3D effect.
  • Marker
    <Chart:Marker type='square' color='crimson'>
    Draws any available ElementMarkerType. In addition, the circle (default) marker type also supports bubble shading effects when specified.
  • Image
    <Chart:Image src='image.png' rotate='45'>
    Drawn the specified image. Options such as image rotation and sizing are possible with this tag.
  • Spacer
    <Chart:Spacer size='230x15'>
    Acts as a transparent placeholder or spacer. It is useful in a number of scenarios to control layout.

A sample is available for each type of microChart demonstrating all the options available for those given types. These samples are located in the gallery under Chart Types/MicroCharts.

Available Parameters

  • Value
    Used by micro charts that take a single value such as Bar, BarGauge, Progress, ProgressGauge
  • Values
    Specify multiple numeric values for the micro chart.
  • Color
    Specifies a color for micro charts that display a single value. For some cases it is used for a simpleColor feature described in more detail below.
  • Colors
    Used to specify the colors used on the chart.
  • Min / Max
    Specifies the minimum and maximum scale values.
  • Width / Height
    Specifies the width and height of the micro chart in pixels.
  • Size
    Can be used to set the size easier than using width and height separately. Examples: size='100x20' or size='20' (for pies or markers). Setting the size parameter with a single value applies it to both width and height.
  • Shading
    Takes a number between 1 and 7 and specifies the shading effect mode to use on the micro chart.
  • AxisMarker
    Takes a single to draw a reference line or two values that specify a range to highlight similar to range axis markers on regular charts. Sparkline, AreaLine, and Column support this feature.
  • Type
    Specifies the ElementMarkerType for use with a marker micro chart.
  • Url
    Specifies a clickable URL for the microchart.
  • Tooltip
    Specifies a tooltip that will appear when hovering over the micro chart.
  • Src
    Image source path. Used with Chart:Image type.
  • Rotate
    Specifies image rotation in degrees. Used with Chart:Image type.

Sizing MicroCharts

All microCharts have predefined default sizes. Types like Pie, Pie3D use 30x30 and Marker uses 20x20. All other except for Column and WinLose use 100x20. The Column and WinLose types size automatically depending on the number of values specified. This way stacking multiple column microCharts with different number of elements will allow the columns to be the same width. Column types will also automatically left align to support this. The column widths can be controled by specifying only the height parameter, however, using both width and height or just width is also supported.

Shading MicroCharts

A number of micro charts support shading effect modes. These can be specified with the 'shading' parameter which takes a number from 1 to 7 indicating the shading effect mode to use. The micro charts that support shading are:

  • Bar
  • BarGauge
  • Progress
  • ProgressGauge
  • BarFull
  • Bullet
  • Pie
  • Marker - (With markers, only the default 'Circle' marker type supports shading)

Setting Axis Range

The scale micro chart provides a means to describe other horizontal based micro charts. When other micro charts are stacked vertically with a scale in the header row then must sync the scales in order to visualize the information correctly. The scale range can be specified through the Min and Max attributes. The default value of the Min attribute is always 0. The following micro chart types support the min/max axis range attributes:

  • Bar
  • BarGauge
  • Progress
  • ProgressGauge
  • Bullet
  • Scale

The scale can also be used with other microCharts in some situations. For example, if using SparkLines to represent sales in january, a static scale with two labels: "Jan", "Feb" can be used to indicate the range represented by the sparklines.

Values and Colors

While most parameters apply to every type of microChart in a similar fashion, the value(s) and color(s) parameters vary depending on the type of microChart used. The following grid matrix explains how value and color parameters are used with the corresponding type of microChart.

NOTE: While value and color parameters take a single string value, the values and colors parameters (plural) accept a comma delimited list of the same values.

Type | Value / Values | Colors
Bar | Value parameter indicates the bar value. | Color: Sets the bar color. Colors: 1st color sets the bar 2nd color sets the background
BarGauge | Value parameter indicates the bar value. | Color: Sets the bar color.
Progress | Value parameter indicates the bar value. | Color: Sets the bar color. Colors: 1st color sets the bar 2nd color sets the background
ProgressGauge | Value parameter indicates the bar value. | Color: Sets the bar color.
BarFull | Values parameter is used to pass a comma delimited list of values. | Colors: a list of colors for each bar. Color: SimpleColor Feature
Bullet | Values: the sequence of values specify: Value, Target, 1st, and 2nd axis marker positions. If the 3rd value is larger than the 4th. The axis marker colors fill in the opposite direction. | Colors: 1st Color: Bar 2nd Color: Target 3rd Color: Shade 1 4th Color: Shade 2 5th Color: Background Color: SimpleColor Feature
SparkLine | Values parameter is used to pass a comma delimited list of values. | Colors 1st Color: Line 2nd Color: Line ends 3rd Color: Max/Min 4th Color: AxisMarker The word 'Transparent' can be used to omit specifying a color in the colors array.
AreaLine | Values parameter is used to pass a comma delimited list of values. | Colors 1st Color: Line 2nd Color: Line ends 3rd Color: Max/Min 4th Color: AxisMarker The word 'Transparent' can be used to omit specifying a color in the colors array.
Scale & ScaleB | Value: sets the default axis tick label text. ex. '<%Value,Currency>' Values: a comma delimited list of string labels to place on the axis. ex: 'Bad,Good,Great' Because each value will be processed by the chart itself, markup can be used as well such as including images. This is demonstrated in the MicroScaleOptions sample. | Color: Specifies the color for axis and labels Colors: 1st color: labels 2nd color: axis line
Pie | Values parameter is used to pass a comma delimited list of values. | Colors reflect element colors Color: SimpleColor Feature
Pie3D | Values parameter is used to pass a comma delimited list of values. | Colors reflect element colors Color: SimpleColor Feature
Marker | N/A | Color: marker color.
Column | Values parameter is used to pass a comma delimited list of values. | Color: (+)columns Colors: 1st: (+)columns 2nd: (-)columns 3rd: AxisMarker
WinLose | Values parameter is used to pass a comma delimited list of values. The options are -1 = lose, 0 = tie, and 1 = win. | Color: (win)columns Colors: 1st: (win)columns 2nd: (loss)columns 3rd: AxisMarker

SimpleColor Feature
By setting the color parameter for charts that support this feature, multiple colors will be created for all elements based on the specified color. This can allow the ability to quickly apply a primary color of your page to ensure the MicroCharts fit.

Using MicroCharts

Because micro charts can be used anywhere a label appears on a chart, there are an endless number of possibilities, however, below are a number of scenarios in which microCharts can be especially useful.

Scenario | Example
In Labels on charts | Code: Chart.TitleBox.Label.Text = "<Chart:Bar value='5' max='10'>";
In Element Labels | Sample: Dashboards And InfoGrids/ChartMicroPie
On Axis Tick labels | Sample: Dashboards And InfoGrids/ChartMicroAxis
In legend box entries | Sample: Legend Box/LegendSparkLines
In Empty legend box headerLabel. | Sample: Dashboards And InfoGrids/AnnotationInfoGrid1
Inside annotations | Sample: Dashboards And InfoGrids/InfoGridMulti
By themselves as a chart control. | Sample: Dashboards And InfoGrids/InfoGrid1
Inside asp.net DataGrid | Sample: Dashboards And InfoGrids/DataGridDash

MicroChart Helpers

A number of tokens are available to help making microCharts easier. For example, the sample [Dashboards And InfoGrids/ChartMicroSubValues] uses the element token %SubValueList which can be used in the element label inside a microChart tag. Other useful tokens include:

Type | Tokens
Element | %SubValueList - a comma delimited list of sub values.
Series | %YValueList - a list of element y values
SeriesCollection | %YSeriesSumList - a list of of each series y value sum. %YGroupSumList - a list of y value sums for each element group. %ColorList - a list of colors used by the series in the collection.

Extending MicroChart functionality.

If the provided micro chart types do not meet the requirements of your project, custom micro charts can be built from scratch and embedded into chart labels in a similar fashion. Sample: Features/Legend Box/EmbeddedLegendCharts demonstrates this scenario. The sample inserts a Progress type MicroChart into the legend box similar to sample ('LegendCharts' located in the same section), except, the code to generates the indicator chart is stored in a separate file which can be modified.

Send comments on this topic.


Silverlight Navigator

Introduction

The .netCHARTING Silverlight Navigator is a powerful and innovative new chart control which enables users to interact and explore data in real-time. Advancing significantly beyond the Ajax Zoomer and flash based solutions in use by the major financial websites, the .netCHARTING Navigator is a truly next generation real-time visualization solution. Combining the best of breed functionality from finance specific sites with major user interface enhancements, the .netCHARTING Silverlight Navigator supports a huge variety of chart types for use with your own data! Now you can leverage this powerful new real-time interface with your own companies data for sales, performance, traffic and more! The .netCHARTING Silverlight Navigator has undergone significant usability and comparison testing with offerings from the major financial web sites and has proven to be significantly more intuitive and powerful for casual and advanced users alike.

Overview
This section covers some of the basics about what the navigator is and what it can do.

  • Key Benefits
  • How It Works
  • Supported Features

User Interface
Describes the features available to the end user.

  • Navigation
    • The Navigation Bar
    • Chart Area
    • Preview Area
    • Scrollbar
  • Other Features
    • Chart Area Legend
    • Mouse Tracking
    • Selection Tracking
    • Deep Zooming

Programming Interface
Details programming interface available to control the chart on the server side as well as client side.

  • Server side asp.net API
  • Client side JavaScript API
    • Javascript API reference.
  • Performance Considerations
Send comments on this topic.


Silverlight Navigator Intro

Sections

  1. Key Benefits
  2. How it works
  3. Supported Features

Key Benefits

  • Performance
    • Provides unmatched performance navigating large data sets.
    • Ultra-Responsive interface utilizes multi-core technologies.
    • Smooth transitions zooming in and out of data and scrolling to different points in the chart.
    • Ground-up client side design (the heavy lifting is done client side reducing server load and enhancing scalability).
    • Utilizes multi-core processor technology.
  • Usability
    • Provides an innovative user interface.
    • Deep zooming from decades down to milliseconds.
    • Time, numeric, and category scale selection using quick x axis cell selection.
    • Has been put through rigorous usability testing across a range of demographics.
    • Real-time chart sizing.
    • Usable in a SlideShow presentation.
  • Programmability
    • Seamlessly utilizes the .netCHARTING API to speed deployment and minimize development.
    • Provide a highly interactive Silverlight chart solution for your clients without any knowledge or editing of Silverlight required.
    • Existing clients can transform most static dotnetCHARTING charts into Silverlight Navigator versions with a single property setting.

How It Works

.netCHARTING seamlessly handles the complexity of Silverlight deployment, plug-in detection and down-level support so you don't have to. Developers are able to deploy one of the most advanced and innovative Silverlight solutions available utilizing a simple server side API which is already familiar to them. Developers with more advanced requirements are able to access the client side JavaScript API to provide further interactivity between the page and the embedded control. The .netCHARTING Silverlight Navigator is an extremely refined implementation which includes custom UI controls for range selection, automatic transfer of highly compressed data packages client to server and leverages the .netCHARTING data engine to further minimize development on the server side.

Supported Features

Many of the common features are supported; however, there are some limitations.

General Features

Feature | Server Chart Support | Silverlight Chart Support
2D Chart |  |
3D Charts |  |
Data ShadingEffects |  | Effects 1-3 are available
MicroCharts |  |
Label Markup |  |
Rich Tooltips |  |
InfoGrids |  |
Multiple and Custom LegendBoxes |  |
Dynamic Chart Area Legend Entries |  |
Multiple chart areas |  |
Label Tokens and Expressions |  |
Smart Labels |  |
Annotations |  |
Box Headers |  |
Statistical Analysis |  |
Finance Indicators |  |

Chart Types

Chart Types | Server Chart Support | Silverlight Chart Support
Combo |  |
ComboHorizontal |  |
ComboSideBySide |  |
Pie |  |
Donut |  |
Radar |  |
Scatter |  |
Bubble |  |
Financial |  |
Gantt |  |
Gauges |  |
Map |  |
Multiple |  |
Organizational |  |

Series Types

Series Types | Server Chart Support | Silverlight Chart Support
Marker |  |
Markers with custom Images |  |
Line |  |
AreaLine |  |
Line and AreaLine series types support markers at each element position, however, in order to improve the performance of charts, when these series types contain more than 250 elements, the markers will be removed automatically in order to make the charts usable. |  |
Spline |  |
AreaSpline |  |
Column |  |
Cylinder |  | Same as Column.
Bar |  |
Bubble |  |
Pyramid |  |
Cone |  | Same as Pyramid.
BubbleShape |  |
BarSegmented |  |
- Sub Values |  |
- Empty Element Handling |  |
- Element Hotspots (Interactivity) |  |
Series Types Financial |  |
CandleStick |  |
Bar |  |
Open |  |
Close |  |
High |  |
Low |  |
HighLowArea |  |

Axis Features

Axis Features | Server Chart Support | Silverlight Chart Support
Per Series Multiple Axes |  |
Angled X Axis Labels |  |
XAxis Intervals |  | X Axis intervals are always dynamic.
Scale Breaks |  | Scale breaks are available on the x axis.
Label Markup |  |
Axis Orientation |  | The x axis can only be on bottom.
Range Axis Ticks |  | Available on the Y Axis
Tick Label Styling |  |
Axis Markers |  |
Axis Marker Labels on CA |  |
Scales |  |
Normal |  |
Range |  |
Logarithmic |  |
Time |  |
Stacked |  |
FullStacked |  |
Logarithmic Stacked |  |
Inverted (reversed) |  |

See Also

Tutorials

User Interface (UI)
Programming with Navigator
Send comments on this topic.


Silverlight Navigator UserInterface

User Interface

The user interface is comprised of several widgets and features that facilitate navigating through different ranges across the x axis in an intuitive manner. Different features provide similar functionality but each has its own advantages that are ideal for the different tasks one would need to accomplish. This section describes how these features are used by end users.

Navigation

The Navigation Bar

The Navigation bar contains a number of controls to facilitate range selection.

The history back and forward buttons can be used to navigate through previous views similar to a web browser. When history is available the buttons will be active, otherwise they are grayed out.

The quick zoom buttons can automatically zoom to a predefined range such as 1 day or 1 month with time scales or predefined numeric ranges.

The range selectors seen on the right are an innovative new type of date, numeric, and category selector/iterator. When using it with a time scale, it enables quicker date selection than a traditional calendar while still providing day of week and month names. Values can be typed into the text box directly. The arrow buttons can be used to iterate numbers, element names, or the different parts of dates like day, month, and year individually. When using a date entry control (such as a calendar) it is often necessary to iterate the selection by one month or one year and the buttons provide quick and easy way of donig that. However, when large changes are required, the butttons also provide click and hold functionality that iterates many values quickly without using the keyboard to type them in manually. When using click-hold with the day and month buttons, the values will pause when they reach the first day of the month or first month of the year, respectively. This gives a little more control when using click-hold and also provides an easy way to reset the day or month selections back to 1.

Range Selectors

Chart Area

The chart area can be scrolled by dragging it when the hand cursor appears and a new selection can be made when the crosshair cursor is showing. Using the scrollwheel to zoom in and out is available at any time. Dragging is not available when the chart is fully zoomed out. When both dragging and selection is available, the top part of the chart area can be used for dragging and the bottom for selection, the ratio of drag to selection area can be specified programatically.

The chart area axis also supports cell selection.

Preview Area

The preview area is used in conjunction with the scrollbar to visualize the chart area view in relation to the entire range of data. It supports cell and arbitrary selection, dragging handles that mirror the scrollbar handles and scrollwheel zooming. When both cell and arbitrary selection are enabled, they can be used at the same time. For example you can start by selecting a cell and end the selection at an arbitrary position and vice versa. Clicking near the top of the preview area starts the selection in cell mode while clicking near the bottom starts it at an arbitrary position. Moving the mouse pointer up or down allows switching between the modes during selection. Our studies have shown that using only cell selection is more intuitive for first-time users. Using mixed selection is more powerful however, and can be useful when the end user is is someone who uses the chart often.

Note: When using mixed or arbitrary selection, clicking once without draging out a selection will center the scrollbar at the clicked position.
Arbitrary & Cell Selection on the preview area is demonstrated here:
Sample: Feature Set > Navigator > NavigatorSelector

Special Cursors
Different cursors are available in these sections and indicate the available functionality.

Hand Cursor
Indicates drag scrolling is available

Crosshair Cursor
Indicates arbitrary selection is available

Cell Cursor
Indicates cell selection is available

Scrollbar

The scrollbar looks very similar to a traditional scrollbar and it supports all the traditional scrollbar features, however, it also provides a number of new ways to manipulate it.

Traditional Scrollbar Features

  • Drag scrolling
  • Click outside the scrollbar to make it page to the mouse location.
  • Click buttons at each end for smooth and controled movement.

New Features

  • Drag handles of the scrollbar to zoom one side in and out.
  • Double-click scrollbar handles to zoom one side out completely.
  • Double-click the bar to zoom out completely. Double-Click again to zoom back to the previous position.
  • Drag the bar up or down to put it into zoom mode. i.e. drag the horizontal scrollbar up to zoom in and down to zoom out.

Other Features

Chart Area Legend

Each chart area contains a legend that describes the visible data. It updates dynamically as the view changes. This legend also provides information on data at any mouse position when the mouse is hovering the chart area or preview area, and info on data while selecting a new zoom range. These features are mouse and selection tracking described below.

Mouse Tracking

The chart can track the mouse position to determine the values of data at those positions. The mouse is tracked across the chart area and preview area and the values are reported in the respective chart area legends. When hovering cells on axes, the legends will reflect calculations based on the ranges of those cells.

Selection Tracking

When selecting ranges on the axes or chart area, the part of the chart being selected shows in color while the rest is grayed out to indicate what the user is doind. Information about data within the range being selected shown in chart area legends.

Deep Zooming

When the scrollbar becomes very small, it will zoom the preview area in so it can be used more precisely and allow zooming in even farther. The zeep zoom will not always happen as soon as the scrollbar becomes as small as possible. There is a feature that prevents this while hovering the scrollbar area. The purpose of this is to prevent unintentional deep zooming in cases such as when the right handle is moved all the way to the left and you intend on moving the left handle all the way out.

Drag & Throw

When dragging the chart area with the hand cursor, the chart area can be thrown to improve the chart area scrolling usability. This is a common UI feature in many touch-screen applications. In order to achieve this, the mouse button must be let go while the mouse is in motion. The faster the mouse is moving when the button is released, the further the chart will scroll on its own.

See Also

Tutorials

Overview
Programming API
Send comments on this topic.


Silverlight Navigator API

Programming Interface (asp.net API)

The navigator is designed to function with any charts by changing single setting. (Chart.Navigator.Enabled = true) While all current chart types may not be supported, the goal is to support them all soon. There are two API layers in this navigator. One controls the UI and behavior and the other interacts with the chart in real-time.

A temporary directory setting is also required like with image charts where temporary data can be stored for the client to download.

Enabling the Navigator

The following code snippen is an example of the required code to enable the Navigator.

chart.Navigator.Enabled = true
chart.TempDirectory = "temp"
chart.LegendBox.Position = LegendBoxPosition.ChartArea

Using the chart area legendbox position enabled richer functionality.

UI / Behavior API

The chart.Navigator class contains almost all the settings to configure the different navigator options. They provide a way to turn interactivity features on and off, as well as showing and removing parts of the chart. These settings are broken into sections below.

Navigation Bar

Disabling The Navigation Bar
Chart.Navigator.NavigationBar.Visible = false

Disabling History
Chart.Navigator.NavigationBar.EnableHistory = false

Disabling Range Selectors
Chart.Navigator.NavigationBar.EnableRangeSelectors = false

Styling the bar
Chart.Navigator.NavigationBar.Background.Color = Color.Red

Chart.Navigator.NavigationBar inherits from a Box class which offers all the styling properties such as background, padding, and corners.

Sample: Feature Set > Navigator > NavigatorNavBarStyling

Quick Zoom Buttons (Default Setting)
Chart.Navigator.NavigationBar.QuickZoomIntervals = "Auto"

Disabling Quick Zoom Buttons
Chart.Navigator.NavigationBar.QuickZoomIntervals = ""

The Quick Zoom intervals are controled by a single string which can disable the buttons, make them determined automatically, specify what intervals to use, and optionally the label text of the buttons. The buttons support localization so users in different cultures will see the appropriate day/month abbreviations.

The string takes a comma delimited list of intervals and supports custom label specification with an equal sign. Setting it to "Auto" will let the chart determine what the best buttons are.

Syntax

"[Multiplier][TimeInterval]=[Label],..."

Intervals that are larger than the axis range or smaller than the zoomLimit will be omitted.

Sample: Feature Set > Navigator > NavigatorNavBarStyling

Examples

Setting | Result
"" | No buttons
"1min,30min,5h,5d" | [1min][30min][5h][5d]
"Auto" | Automatically determined based on scale range
"1d,5d=FiveDays" | [1d][FiveDays]
"1d,1m,1y,YTD=Year To Date,Max" | [1d][1m][1y][Year To Date][Max]

 Time Interval specifiers
Specifier | Meaning
ms | millisecond
s | second
min | minute
h | hour
d | day
m | month
y | year
YTD | year to date
Max | maximum
Chart Area Legend

Enabling ChartArea Legend
Chart.LegendBox.Position = LegendBoxPosition.ChartArea

Controling the range display
Chart.LegendBox.Value = "%PercentageChange"

Sample: Feature Set > Navigator > NavigatorFinance

Controling the display of a single element's value
DefaultElement.SmartLabel.Text = "%YValue"

Arranging the range display mode
Chart.LegendBox.Template = "%Value%Icon%Name"

Other Samples:

Feature Set > Navigator > NavigatorFinance
Feature Set > Navigator > NavigatorCALegendStyling
Feature Set > Navigator > NavigatorStockDB

When the legend is not in the chart area it is not dynamic and it shows the values for the entire dataset. When the legend is placed inside the chart area however, it behaved dynamically by updating its value in real-time. The display of each series in the chart area as shown above can be specified through the respective LegendBox.Template. When the mouse is on the chart area, it displays the values of each element. This value can be specified with DefaultElement.SmartLabel.Text and all the element tokens can be used.

By setting Series.LegendEntry.Value = "" for any series, the chart will not perform any calculations on the displaying info about the visible or highlighted range.

Chart Area Legend Behavior Notes

  • Legend Entries in the chart area cannot use label markup
  • If LegendEntry.Value is set to "%PercentageChange" and the entry labelStyling color is not set, the color will be dynamic; green for positive change and red for negative.
  • When the legendEntry.LabelStyling color is not set, the legend entry name will use the series color.
Chart Area

Not showing the chart area
Chart.ChartArea.Visible = false

Sample: Feature Set > Navigator > NavigatorSelector

Specifying UI Features
Chart.ChartArea.NavigatorOptions =
ChartAreaNavigationOptions.DragScrolling
| ChartAreaNavigationOptions.ArbitrarySelection
| ChartAreaNavigationOptions.ScrollWheel;

Omiting any options will disable them.

Sample: Feature Set > Navigator > NavigatorSelectorSeparate

Specify drag area vs. selection area
Chart.ChartArea.NavigatorDragAreaPercentage

Chart Area Axis

Make cells smaller then axis ticks available
Chart.Navigator.EnableCellVisualCues = true

  • When the chart area is disabled, the chart area axis will also be collapsed.
  • When the preview area supports cell selection, it will be available on the chart area axis.
  • The chart area axis will inherit its background color from the chart area.

Preview Area

Specifying Preview Area Height
Chart.Navigator.PreviewAreaHeight = 35

Disabling/Hiding Preview Area
Chart.Navigator.PreviewAreaHeight = 0

Disable chart data drawing
Chart.Navigator.EnablePreviewAreaChart = false

Specifying UI Features
Chart.Navigator.PreviewAreaNavigationOptions =
PreviewAreaNavigationOptions.Cells
| PreviewAreaNavigationOptions.ArbitrarySelection
| PreviewAreaNavigationOptions.ScrollWheel;

Omiting any options will disable them.

The preview area provides a visual representation of the time range and data the scrollbar represents. They work together so disabling the scrollbar disables the preview as well. The preview area supports cell and arbitrary selection, dragging handles that mirror the scrollbar handles and scrollwheel zooming..

Disabling the scrollbar will remove the preview area as well.
ScrollBar

Disabling the Scrollbar
Chart.Navigator.EnableXScrollbar = false

Disabling the scrollbar will remove the preview area as well.
Sample: Feature Set > Navigator > NavigatorDetails

General Options

Chart Sizing

A chart size can be specified in the traditional way. However, with the navigator, if the width or height is not specified, the chart will size to 100% of the available width or height.

Sample: Feature Set > Navigator > NavigatorDynamicSizing

Disable Browser Status Help Messages
Chart.Navigator.EnableBrowserStatusHelp = false

This may not work for some browsers by default.
For example, to enable it in IE 8, choose Internet Options > Security tab > custom level > Under Scripting > Allow status bar updates via script, choose the Enable radio button. Using the SetHelpMessageHost javascript property of the client side chart, a text box or other element can be associated with this message.

Silverlight plugin installation handling
The chart provides some options for handling users without silverlight installed. The options are defined by the SilverlightInstall enumeration.
Chart.Navigator.SilverlightInstall = SilverlightInstall.Automatic

Specify Animation Duration (in milliseconds)
Chart.Navigator.AnimationDuration = 200

Disable Mouse Tracking
Chart.Navigator.EnableMouseTracking = false

Limiting the zooming depth
Chart.Navigator.ZoomLimit = TimeInterval.Day
Chart.Navigator.ZoomLimit = TimeSpan.FromDays(5)

Set a starting zoom position
Chart.XAxis.Viewport.ScaleRange
= new ScaleRange(new DateTime(2010,1,1),new DateTime(2010,5,1))

Culcutre Settings
Server and client side charts may be running on machines with different culture settings. By default the client side chart will inherit the hosting machines culture. In some cases this may be a problem, for example if using formatting such as currency for values, using the clients default culture may incorrectly represent monetary values. On the other hand, using the clients culture for x axis time scale labels is useful. Culture settings may be specified for the entire chart or any specific axis:

Chart.DefaultCultureName = "en-US"
Chart.YAxis.CultureName = "en-US"

Windowless Mode
A property is available to allow the Silverlight Navigator plugin to operate in windowless mode. This feature is useful when the navigator obscures other dynamic content on a page. For more information on this feature, see this page.

Chart.Navigator.EnableWindowlessMode = true;
Navigator Initialization

Loading Strings
When the navigator is initializing it displays strings such as "Please Wait...", "Downloading", "Loading". There is a property which allows overwriting these strings if they must be in a different language or just to change the wording.

Chart.Navigator.LoadingTextOverride = "Wait|Downloading(%Percentage)|Loading";

This property takes a single string which can have three different strings separated by a '|' character. The downloading string can contain the token "%Percentage" which will be replaced with the percent downloaded when the chart is loading.

WARNING: The %Percentage token is case sensitive.

LoadingAnimation
There is a number of loading animation visuals available for display while the Navigator is loading.

Chart.Navigator.LoadingAnimation = LoadingAnimation.Snake;

Preview Image Genration
When the Navigator is loading, the chart is capable of displaying a preview of what the navigator will look like when it is loaded. This provides a more seamless experience for end users.

Chart.Navigator.GenerateImagePreview = false;

Preview Image Performance
If the initial navigator view does not contain many elements, this image can be generated very quickly to show while all the data is downloading. However, if the initial view contains a large number of elements (thousands for instance) the preview image may take a moment to generate. In this scenario, it may be worthwhile disabling the preview image. This can improve the time necessary for the navigator to load, but the navigator must load fully before the chart is visible. For most cases, the preview image generates very quickly and it's best to keep it enabled. When it becomes a problem and is affecting the website performance, disable it.

Client Side Programming Interface (Real-Time JavaScript API)

Several properties and methods allow the chart to be manipulated through JavaScript and allows the chart to call functions and update objects on a page. For example the standard navigation bar on top of Navigator charts can be created from HTML elements and communicate with the chart through Javascript directly.

Control The Chart

In order to use the JavaScript interface of the silverlight chart, a unique ID must be specified for the control like with the following asp.net code

Chart.Navigator.ControlID = "slPlugin"

Now the chart object can be accessed from JavaScript on the page. Consider the following code snippet:

<script type="text/javascript">
var chartID = "slPlugin";

function goback() {
var control = document.getElementById(chartID);
control.Content.Chart.PageLeft();
}
</script>

This code defines a function that accesses the chart object and calls the chart's PageLeft() method.

Sample: Feature Set > Navigator > NavigatorPageInteraction

Getting information from the Chart

The Javascript chart interface provides the ability to get information about the position status of the chart. The following JavaScript method gets the time range of the visible chart area and updates the visible range to show only the last 10 days from the current right position.

<script type="text/javascript">
var chartID = "slPlugin";

function leftten() {
var control = document.getElementById(chartID);
var range = control.Content.Chart.GetVisibleRange();
var leftDate = range.ValueHigh;
var tmpDate = range.ValueHigh;
leftDate.setDate(leftDate.getDate() - 10);

control.Content.Chart.NavigateToVisibleRange(leftDate, tmpDate);
}

</script>

Sample: Feature Set > Navigator > NavigatorPageInteraction

Chart Controlling the Page

The chart can call a Javascript functon when the viewport is updated by the user and it can update an HTML element with a help message text.

The following example will let the chart update the text of a div element with a help message while using the navigator. The first part of this task requires registering a method or property with the chart. Consider the following JavaScript code.

<script type="text/javascript">
var chartID = "slPlugin";

// This function registers the location update handler when the silverlight chart loads.
function initEvents() {
var control = document.getElementById("slPlugin");
if (control) {
control.Content.Chart.SetHelpMessageHost("helpDiv.innerHTML");
clearInterval(initID);
}

}

// Try to register the location update handler with the chart until it is succeeds.
var initID = setInterval("initEvents()", 1000);

</script>

The initEvents() method tells the chart to update the innerHTML property of the div tag named helpDiv with a help message. The if, else statement ensures that the silverlight control is loaded before this property is assigned. If it is not loaded, it waits 1000 milliseconds before it tries again.

Samples:
Feature Set > Navigator > NavigatorPageInteraction
Feature Set > Navigator > NavigatorSelector
Feature Set > Navigator > NavigatorSelectorControl
Feature Set > Navigator > NavigatorSelectorSeparate

ChartArea Tokens
The navigator supports all the same label tokens as a static charts. However, it offers a couple additional tokens that are not supported by static charts. The reason this is not available with static charts is because these tokens are evaluated in real-time and based on the mouse position over the chart area. The tokens %XValue and %Value can be used in chart area hotspots. Consider this setting:

Chart.ChartArea.Hotspot.Tooltip = "%XValue, %YValue"

When the mouse is hovering the chart area, a tooltip will appear showing the axis values at the current mouse position. Then can be used in hotspot URL with enables passing the clicked axis values to javascript.

Sample: Feature Set > Navigator > NavigatorGetSeriesValue

Slideshow Presentation with Navigator

Including a Navigator chart in a slideshow presentation is easy to do. Refer to sample [Feature Set > Navigator > NavigatorSlideshow]

It contains information about the slideshow in javascript arrays including a text message, delay in milliseconds, and left and right positions to move the chart for each slide.

var myTextArr = [...];
var delayArr = [...];
var leftDTArr = [...];
var rightDTArr = [...];

A displaySlide function will update the page with the specified slide.

function displaySlide(frame) {
var control = document.getElementById(chartID);
control.Content.Chart.NavigateToVisibleRange(leftDTArr[frame], rightDTArr[frame], delayArr[frame])
var tText = myTextArr[frame];
setTimeout('displayText("' + tText + '");', delayArr[frame]);
}

The startSlideshow() function initiates the slide show and playSlide() function handles itarating the slides with a delay between them. playSlide() ensures only the available slides are shown and initiates the next slide by calling itself on a delay.

function startSlideshow() {
playSlide(0)
}

function playSlide(frame) {
displaySlide(frame);
var nextFrame = frame + 1;
if (nextFrame < myTextArr.length) {
setTimeout('playSlide(' + nextFrame + ')', delayArr[frame] + slidesPause);
}
}

Possible Uses

The interface is designed to allow users to use the chart to control content of the page or let the content of your page control the chart itself. The chart is able to animate between views of data such as zooming in or out which gives the user a better idea of how a subset of the the data relates to a bigger picture. A page that lets the user navigate articles related to specific dates for example can update the chart view to encompass data that is related to those articles.

A page that emulates a slideshow type movie can be connected to a chart so that when each slide is shown the chart animates to the appropriate data. Methods that control the navigation also provide the option to specify the duration any animation between the different ranges.

Sample: FeatureSet > Navigator > NavigatorIncludeInAxisScale

Javascript Interface Reference

Below is a list of available methods provided by this interface.

Method/Property | Description
Control The Chart
PageLeft() | Pages the scrollbar left.
PageRight() | Pages the scrollbar right.
NavigatorForward() | Navigates the zoomer forward to the next location. Same as clicking the forward button on the navigation bar.
NavigateBack() | Navigates the zoomer back to the previous location. Same as clicking the back button on the navigation bar.
NavigateToCenter
(object centerVal, int milliseconds)

Animates the zoomer to center at the specified x axis value maintaining the scrollbar width in the specified amount of time.

  • centerVal - X axis value to center on, this value can be numeric, DateTime or string.
  • milliseconds - Time of the animation in milliseconds
NavigateToCenter
(object centerVal)

Animates the zoomer to center at the specified x axis value maintaining the scrollbar width.

  • centerVal - X axis value to center on, this value can be numeric, DateTime or string.
NavigateToVisibleRange
(object leftVal, object rightVal, int milliseconds)

Animates the view to the specified x axis value range in the specified amount of time.

  • leftVal - Value of the new left position.
  • rightVal - Value of the new right position.
  • milliseconds - Time of the animation in milliseconds
NavigateToVisibleRange
(object leftVal, object rightVal)

Animates the view to the specified x axis value range.

  • leftVal - Value of the new left position.
  • rightVal - Value of the new right position.
NavigateToVisibleRangePerc
(double left, double right, int milliseconds)

Animates the view to the specified percentage range in the specified amount of time. The percentage range is a numeric value from 0 to 1 representing the maximum left and right positions. A range of 0 to 1 means the chart is fully zoomed out.

  • left - Left percent position from 0 to 1. Value must be less than the right position.
  • right - Right percent position from 0 to 1. Value must be more than the left position.
  • milliseconds - Time of the animation in milliseconds.
NavigateToVisibleRangePerc
(double left, double right)

Navigates the view to the specified percentage range. The percentage range is a numeric value from 0 to 1 representing the maximum left and right positions. A range of 0 to 1 means the chart is fully zoomed out.

  • left - Left percent position from 0 to 1. Value must be less than the right position.
  • right - Right percent position from 0 to 1. Value must be more than the left position.
Get info from chart.
ScaleRange GetVisibleRangePerc() | Gets the visible x axis percentage range. The percentage range is a numeric value from 0 to 1 representing the viewport left and right positions. A resulting range of 0 to 1 means the chart is fully zoomed out.
ScaleRange GetVisibleRange() | Gets the visible x axis range values.
double GetSeriesYValueAtX(string name,object xValue)

Gets the element y value of the series specified at a given x position.

  • name - Name of the series to search for elements in.
  • xValue - The x value to match with an element.
Have the chart control the page.
SetLocationUpdateHandler(string) | Sets the name of a JavaScript method with two parameters (lowValue, highValue) on the current page that will be called when the chart viewport is updated and the new range will be passed to it.
SetHelpMessageHost(string) | Sets the property of an HTML or Javascript object on the page which will be updated by the chart with a help message when the user is interacting with the chart.

Notes:

JavaScript DateHandling
Unlike asp.net, when Javascript dates are created they assume the DateTime is given in universal GMT time. When passing dateTime values to the navigator, the navigator will adjust for the timezone difference so that dates passed from javascript to Navigator will be treated as the GMT time is actually the local time. This makes working with dates more convenient without having to adjust the time manually.

This conversion was introduced in version 6.1. If a chart passing dates in parameters to JS methods was developed with version 6.0, time zone conversions were necessary, but they can be removed if the same code will be running with version 6.1.

Range vs RangePerc
The Percentage range of the chart is a coordinate system where 0 = the maximum left and 1 = maximum right chart positions.

The range represents the actual values of the x axis and can be given in DateTime or numeric data types. Category scales also use a numeric scale range numbering each element name from 0-n.

Performance Considerations

This chart is designed to animate large sets of data smoothly utilizing silverlight which is a subset of WPF. While WPF has very powerful graphics capabilities, silverlight does not have all the same capabilities of WPF. There are a few things that can help improve the performance of your charts if they become to slow down.

Bar Charts

A bar series includes some extra graphical elements such as a borders and the bar face itself. A chart with thousands of such bars can be made much more efficient utilizing the finance bar series types. This will make the bars thin but when so many bars are available they will usually be very close together anyway. However, these bar widths can be controled with Series.Line.Width . Using the following code a series can be converted to utilize this performance enhancement.

  • CS
  • VB
mySeries.Type = SeriesTypeFinancial.Bar;
// In order to improve the performance of this chart, the volume series will utilize the finance bars instead of full columns.
foreach (Element el in mySeries.Elements)
{
      // This applies the y value to high and 0 to low so that the finance bars appear as a column series would.
      el.High = el.YValue;
      el.Low = 0;
}

mySeries.Type = SeriesTypeFinancial.Bar
' In order to improve the performance of this chart, the volume series will utilize the finance bars instead of full columns.
For Each el As Element In mySeries.Elements
      ' This applies the y value to high and 0 to low so that the finance bars appear as a column series would.
      el.High = el.YValue
      el.Low = 0
Next
Sample: Feature Set > Navigator > NavigatorStockDB

Line and AreaLine Marker Behavior

Lines with many points have element markers for each. When these elements exceed a count of 250 the element markers will automatically be removed. However, in charts with fewer points, removing the element markers can also improve performance.

Chart Size

The chart size has a great influence on animation performance. If the charts starts getting slow, making it smaller is likely to speed it up a great deal.

Mouse Tracking

Disabling mouse tracking can improve performance of client side charts when the user hovers their mouse over the chart areas.

Element Hotspots

Using element hotspots to make them clickable or with tooltips can add also add a performance penalty when the user hovers their mouse over the chart areas.

Axis AlternateGridBackground & GridLines

Everything that needs to move on the chart area requires processing time. Disabling the alternateGridBackground color can help as a start. In addition, disabling gridlines can help also.

Axis Scale

The chart is capable of scrolling easily, however, when the y axis range updates dynamically the chart area must not only scroll but also scale everything on it. Setting a static axis range (YAxis.ScaleRange = ...) can lock in the axis range making the chart very fast to scroll and zoom.

Caching

The server side processing can be cached so that each request of a page with charts on them doesnt require generating them each time. To use this feature, you must set a static filename for the chart such as: Chart.FileName = "ChartA1"; Then enable fragment caching for the hosting aspx page.

For more information see:

- How To Perform Fragment Caching in ASP.NET by Using Visual C# .NET

- Chart File Handling

See Also

Tutorials

Overview
User Interface
Send comments on this topic.


JavaScript Charts

Intro

JavaScript charts are similar to zoomer and navigator but uses only javascript to render the chart client side. This allows real-time updates of chart properties and data. It uses SVG and VML graphics technologies to increase browser compatibility and chart interactivity which yields a richer experience on devices such as phones and tablets running iOS, Android and more.

Benefits:

  • Browser Compatibility
  • Renders Client-Side
  • Real-Time updates
  • Interactivity
  • Animation
  • Javascript based events.
  • Touch-Screen support.

It is easy to use, by simply setting Chart.JS.Enabled = true a pure javascript chart will render in place of static chart images.

JavaScript charts are a subset of the full DNC library but many of the more important features are supported. The feature differences are discussed in more detail below.

What's new in v9.2

Version 9.2 includes many new features including microcharts and mosaic plots. Some new features include:

  • Microchart Visualizations
  • Mosaic Plot/Variwide/Mekko chart type
  • Interactive UiItem types
  • Crosshairs
  • Axis scale break enhancements
  • Data Point Options

What's new in v9.1

Version 9.1 includes many new features and enhancements. Some new features include:

  • Calendar Heatmap
  • Calendar Views
  • Label html tag improvements
  • Vector Icon support through the icon text tag
  • Box layout system
  • CSV loading client side
  • Client side SmartLabels

What's new in v9.0

Version 9.0 is a major update to JS chart engine that brings JavaScript output much closer to feature parity with image charts. Some new features include:

  • Circular Bar Gauges
  • Circular Overflow Indication
  • Linear Gauges
  • Hatch Styling
  • Column Complete Visualization
  • Organizational Chart Type
  • Heatmap Chart Type
  • TreeMap Cushion Shading
  • Custom Legend Entries
  • Legend Template
  • Legend AxisMarker Entries
  • Markers for all Series Types
  • Icon Browser
  • Icon Support in any Label
  • Multiple Shape Labels
  • SmartPalette Legend Support
  • Axis Line Breaks
  • Box Corner Styling

What's new in v8.4

Version 8.4 introduces a number of features including Gantt support. Some new features include:

  • Time Y Axis
  • Dynamic Token Tick and AxisMarker Values
  • Custom Ticks
  • Logarithmic Scale

What's new in v8.3

Version 8.3 introduces a new simpler way of working with map charts. Some new features include:

  • Map context shows surrounding maps automatically
  • Custom map files using geoJSON and topoJSON (optional)
  • Add map layers in real-time for advanced dynamic maps
  • Plot lines, markers, and bubbles on maps.

What's new in v8.2

Version 8.2 introduces a number of new chart types and improved axis features. Some new features include:

  • Funnel/Pyramid/Code/Treemap Types - Powerful new pyramid, funnel and cone charts are now supported in JSC as single charts or groups of charts within a given chart area.
  • Smart Scale Breaks - JSC can now understand smart scale break settings the dynamically calculate the best breaks as series data or visibility changes.

What's new in v8.1

Version 8.1 introduces a number of new chart types and more robust label support. Some new features include:

  • Label Tokens - Richer token support is not available.
  • Label Expressions - Labels using expressions can now be used on js charts to create dynamic content.
  • Circular Gauge Type - The traditional circular gauge types are now available.
  • Radars - Radar charts are supported with any series types. JavaScript charts also allow bar shading effects on radars which is not supported by image charts.
  • Pie Lengths - The pie length variation between slices is not supported with js charts.
  • Pie Angles - Starting pie angle support.
  • Range Columns/Areas - Columns and area series types now support starting values.
  • Error Bars - Subvalues that create error bars will work with JavaScript charts.

What's new in v8.0

Version 8.0 is a major update to the previous JavaScript charts implementation. Some new features include:

  • Label Tokens and formatting are practically in feature parity with image charts
  • JS Navigator for finance charts and zooming.
  • Client side API for JS charts closely matches DNC API that makes reading the generated JS code easier.
  • The new version of JSC is much easier to work with client-side.
This new version introduces a new client side API, if existing charts are using JS to manipulate the chart, this code may have to be modified.

Supported features

  • Export to raster and vector images
  • Printing support
  • Element Selection
  • Series Visibility
  • Zooming
  • Tooltips
  • Label tokens
  • Label Expressions
  • Label Callbacks
  • Native formatting
  • Client Side Programming
    • Formatting
    • Token evaluation
  • JS Navigator
    • Multiple chart areas
  • Chart Types
    • Combo
    • ComboHorizontal
    • Pie
    • Pies
    • PiesNested
    • Donut
    • Donuts
    • Gauges
    • Radars
    • Funnel
    • Pyramid
    • Cone
    • Treemap
  • Series Types
    • Bar/Column
    • Range Bar/Column
    • Error Bars
    • Line
    • Spline
    • AreaLine
    • AreaSpline
    • Range AreaLine
    • Range AreaSpline
    • Marker
    • Bubble
    • Candlestick (Using JS Navigator)
    • OHLC Bars (Using JS Navigator)
    • Pie slice length.
    • Pie starting angles
  • Real-Time updating

User Interface (UI)

The JavaScript charts user interface is inherently more interactive and dynamic. It offers a number of features described below.

Tooltips
The tooltips have a highlight of the element color so it's easy to see which data point it relates to. Tooltips are also optimized to work with touch devices.

Element Highlighting on Hover
When the mouse hovers on elements, they are highlighted.

Export / Print buttons
Each JavaScript chart can have two buttons. One sends the chart to the printer and the other allows saving the chart as a raster or vector image. Several popular image formats are supported including PDF, PNG, and Jpeg.
Legend Entries
The legend entries are clickable to hide series in any JavaScript chart.

Element selection
When element selection is enabled, clicking on elements selects them and the selected elements can be detected through javascript. With a pie chart, clicking on elements selects them and explodes the selected pie slice.
Zooming
Dynamic zooming is also available when enabled. It allows the user to zoom in and out of the charts range.

Server Side Programming Interface (API)

JavaScript charts are driven by the current .netCHARTING API. Simply enabling JavaScript charts will render the chart in the client-side browser instead of generating an image on the server. JavaScript charts offer the ability to interact with the chart in the browser through Javascript.

Enabling JavaScript charts
To enable JavaScript charts, the following code can be used:

  • CS
  • VB
Chart.JS.Enabled = true;

Chart.JS.Enabled = true;

Initial Animation
When JavaScript charts load, it animates the series drawing. The duration of this animation can be specified in milliseconds and set as in the following code snippet:

  • CS
  • VB
Chart.JS.InitialAnimationDuration = 1000;

Chart.JS.InitialAnimationDuration = 1000

Element Selection
Element selection can be enabled or disabled with the following code:

  • CS
  • VB
Chart.JS.EnableElementSelection = true;

Chart.JS.EnableElementSelection = true

Zooming

To enable zooming for a javascript chart, the Chart.JS.AxisToZoom property can be utilized. It takes a string with possible values of: "X", "Y", "XY".

  • CS
  • VB
Chart.JS.AxisToZoom = "X";

Chart.JS.AxisToZoom = "X"

See Sample: JSCZooming

Client Side Programming Interface (API)

JavaScript charts can interact with Javascript in the browser to update dynamically and notify other javascript code of chart based events.

In order to interact with JavaScript charts, a control ID must be specified for the chart on the server side so it can be referred to in javascript. The following code can be used to achieve this:

  • CS
  • VB
Chart.JS.ControlID = "jscChart";

Chart.JS.ControlID = "jscChart"

The following Javascript snippets assumes the above control id setting is used.

Reading the JS output

When Chart.Debug=true, the generated JS will be legible. When debug is disabled, whitespace is removed.

Unsupported JS settings

There are a few JS API settings that cannot be set through the DNC API such as point states like hover and selected. For this and other such cases, a method is provided that applies settings given a path a value.

  • CS
  • VB
Chart.JS.Settings.Add("defaultSeries.defaultPoint.states.hover.outline.color", "red");

Chart.JS.Settings.Add("defaultSeries.defaultPoint.states.hover.outline.color", "red")

This method takes only strings values, however, any type can be specified. If a value of "true" is passed, it will be a boolean in JS. To use a string with that value, use "'true'" with single quotes. The same applies to numbers. If a JS variable that holds the value in JS must be referenced, prefix the string with "js:". This will prevent quote wrapping and will be used in JS as is. For example, if in JS there is a variable defined as var colorRed = 'red'; to refer to this variable in a string setting server side, use "js:colorRed". This allows passing functions as well for cases like label callbacks. For example: "js:function(txt){return 'text:'+txt}"

See Sample: JSCSettings JSCLabelCallbacks

Axis and AxisMarkers

The following axis related javascript usage is demonstrated in sample:
JscDynamicStylingUpdates

Getting Axis and Data Scale Ranges
First, the Chart.JS.ControlID must be specified, and an ID must be assigned to the axis server side.

  • CS
  • VB
Chart.JS.ControlID = "JscChart";
Chart.YAxis.JsID = "axy";
Chart.XAxis.JsID = "axx";

Chart.JS.ControlID = "JscChart"
Chart.YAxis.JsID = "axy"
Chart.XAxis.JsID = "axx"

Then in JS, the axis range can be acquired using code such as:

var range= JscChart.axes('axy').getRange();

This returns a value such as:

{ min:0, max:100, dataMin:5, dataMax:80}

The result contains the following values:

range.min - Axis scale minimum.
range.max - Axis scale maximum.
range.dataMin - Data scale range minimum.
range.dataMax - Data scale range maximum.

Setting Axis Scale Range
Similar code can be used to apply a new axis scale range.

JscChart.axes('axy').zoom(0,2);

To set a date time based scale, use:

JscChart.axes('axy').zoom(new Date(2011, 0, 2), new Date(2011, 0, 5));

Adding and Removing Axis Markers dynamically.
Axis markers can be added and removed in realtime through Javascript.

The following code snippet adds a range axis marker to the x axis.

JscChart.axes('axx').markers.add({
value:[new Date(2011, 0, 2),new Date(2011, 0, 5)],
color: '#ACFFC5',
id: 'am1'
});

In order to add and remove a single value axis marker which draws as a line instead of an area, the following code can be used.

JscChart.axes('axx').markers.add({
value: new Date(2011, 0, 2),
color: '#ACFFC5', lineWidth:2,
id: 'am1'
});;

To remove this axis marker, the following code can be used:

JscChart.axes('axx').markers('am1').remove();

Real-Time Data Update

Adding a point to a series

To add a point to a series in real time the following javascript function can be used.

series.points.add( pointOptions, { [ shift ], [ animation ] })

PointOptions - Takes an array, or point object. If it is an array, it will be interpreted as x and y values respectively.

The point object contains the following basic properties:

  • color
  • name
  • x
  • y
  • id

shift - When shift is true, one point is shifted off the start of the series as one is appended to the end. Use this option for live charts monitoring a value over time.

animation - true/ false, or the animation duration in milliseconds.

Note: The series must be assigned an ID server side in order to refer to it later.

var series = c
series.points.add([2, 6]);

To use a point object the follwing code can be used:

var series = JscChart.series('s1');
series.points.add({
color: 'Red'
x: 2,
y: 6
});

The series object has the following available functions:

  • remove()
  • select(bool select, bool accumulate)
    select - When true, the point is selected. When false, the point is unselected. When null or undefined, the selection state is toggled.
    accumulate - When true, the selection is added to other selected points. When false, other selected points are deselected. Internally in Highcharts, selected points are accumulated on Control, Shift or Cmd clicking the point.
  • options( seriesOptions )

    seriesOptions - All series options can be updated through this function.

  • remove( ) - Removes the series from the chart.

Adding a series to a chart
To add a new series to a chart the following type of code snippet can be used:

JscChart.series.add({
points: [194.1, 95.6, 54.4, 29.9, 71.5]
});

See sample JscLiveDataUpdate for an example of how points are added to a chart in javascript.

Get a Selected Point
To get the points currectly selected the follwing code can be used:

var selectedPoints = JscChart.series().points({selected:true})

This returns a collection of selected point objects which can be filtered/iterated further.

The point object has the following available functions:

  • remove()
  • select(bool select, bool accumulate)
    select - When true, the point is selected. When false, the point is unselected. When null or undefined, the selection state is toggled.
    accumulate - When true, the selection is added to other selected points. When false, other selected points are deselected. Internally in Highcharts, selected points are accumulated on Control, Shift or Cmd clicking the point.
  • options( pointOptions )

    pointOptions - The setting this point will be updated with.

  • zoomTo( ) - Zooms the related point into view.

The JS point object has the following properties:

  • chart- A reference to the parent JS chart object.
  • series - A reference to the parent JS series object.
  • name - The name of this point.
  • id- The point's ID.
  • x - The x value.
  • y - The y value.

Client-Side Token Parsing

The chart, series, and point objects have the following two functions that allow evaluating tokens client side. The replaceTokens('string with tokens') function processes tokens associated with the point, series, or chart (SeriesCollection) and returns a string. The tokenValue('token') function accepts only one token name and returns the value as its native type. For example calling series.replaceTokens( '%average') will return a string such as "12". However, calling tokenValue('%average') will return the number 12.

The chart version of these two methods also has an optional id parameter. If not specified, the tokens are evaluated against all the series on the chart. If an id value is specified, the tokens are based on the target's type be it a point or series.

Events

Events can be specified server side through the hotspot class and include javascript handlers.

The following code snippet sets a click event handler for the chart and includes a function that adds a point at the clicked location to the chart.

  • CS
  • VB
Chart.DefaultElement.Hotspot.Attributes.Custom.Add("click", "js: function(){if (this.series.points.length > 1) this.remove();}");

Chart.DefaultElement.Hotspot.Attributes.Custom.Add("click", "js: function(){if (this.series.points.length > 1) this.remove();}")

When adding the click event, a function handler with one parameter can be used. The parameter contains the click event information. The above shows how to get the clicked axis values based on the event. The 'this' keyword refers to the javascript chart object.

When using a setting for JSC, prefixing the string value with "js:" indicates the string should be treated as a JS literal. Some label text settings can include js callback functions to process the text when needed.
See sample JscClickAddPoint for an example.

Chart level events

  • click (fires when the chart is clicked)
    Keyword this refers to the chart object.
    One parameter 'event' is pased to a JS function handler. event.xAxis and event.yAxis contain arrays of axes on the chart.
  • addSeries (Fires when a series is added to the chart)
    Keyword this refers to the chart object.
    One parameter 'event' is pased to a JS function handler. event.options gives access to the series being added to the chart.
  • selection (fires when an area of the chart has been selected 'zooming')
    Keyword this refers to the chart object.
    One parameter 'event' is pased to a JS function handler.
    event.preventDefault() will stop the zooming from occuring.
    event.xAxis and event.yAxis contain arrays of axes on the chart.

Events can be specified for an element as well. The following code snippet adds a handler to elements that removes them when clicked:

  • CS
  • VB
Chart.DefaultElement.Hotspot.Attributes.Custom.Add("click", "if (this.series.data.length > 1) this.remove();");

Chart.DefaultElement.Hotspot.Attributes.Custom.Add("click", "if (this.series.data.length > 1) this.remove();")
See sample JscClickAddPoint for an example.

Element level Events

  • click (fires when an element is clicked)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • mouseOver (fires when the mouse hovers an element)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • mouseOut (fires when the mouse leaves an element)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • remove (fires when the element is removed)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • select (fires when the element is selected)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • unselect (fires when the element is unselected)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.
  • update (fires when the element is updated programatically)
    Keyword this refers to the element object.
    One parameter 'event' is pased to a JS function handler.

Send comments on this topic.


Mapping

Introduction

.netCHARTING mapping is a powerful GIS (Geographic Information Systems) tool that allows loading standard shape and (.ecw) files and rendering them in real time. The supporting API also allows dynamic styling of shapes based on data within the shape files as well as data retrieved from other databases.

For more information on GIS visit www.gis.com

Features Include:

  • ShapeFiles import
  • ECW file import
  • ECW Image caching
  • Shape Styling
  • Shape Group labeling and styling.
  • Shape file DataBinding
  • Map Smart Palette (Thematic Mapping)
  • Map Zooming
  • Lambert Conic and Mercator Projections

Shape Files (.shp)

Shape files are a standard GIS format created by ESRI (Environmental Systems Research Institute, Inc) that contains vector based geographical boundaries made up of individual shapes. Each shape may also include information and related statistical data similar to a DataTable found in a corresponding database (.dbf) file. The coordinates of these shapes are usually in longitude/latitude format which provides quick location reference for features such as zooming.

ECW Files (.ecw)

The ECW format is an image compression standard for GIS and other applications. These files contain images as well as real world boundary coordinates that pertain to the image, however, they do not store individual shapes or further information. Instead, they store an image such as a satellite shot of the earth. Because they do store relevant coordinates however, shape files can be layered on top of ecw files to create stunning map images with relevant geographical shapes and information.

Database File (.dbf)

The database file contains meta data on the shapes defined in the shapefile. For example, shape names, population or other data specific to a given shape. A shape can represent a state, province, lake, road, river, city or marker locations like gas stations on a map. Attribute data tells us more about those shapes such as sales, population, volumes etc. In addition to data included with dbf files specific to a given shape file you can bind shapes to your own database. For more details please see Mapping Data and Layers.

Using the ecw file format requires an additional DLLs besides 'dotnetcharting.dll'. They are included in the bundle with dotnetCHARTING.dll.

Simple Usage

Creating a simple map

In order to create a map, the ChartType.Map member of the ChartType enumeration must by specified for the chart. Then a shape or ecw file must be used as the map data source. This code snippet demonstrates simple usage loading a shape file called States.shp.

[C#]

Chart.Type = ChartType.Map;

Chart.Mapping.MapLayerCollection.Add("states.shp");

[Visual Basic]

Chart.Type = ChartType.Map

Chart.Mapping.MapLayerCollection.Add("states.shp")

The following tutorials provide additional information about supported features and usage.

  • Mapping API
    Describes the supporting API for mapping.
  • Data and Layers
    Using and manipulating map data.
  • Map Styling
    How to style and group shapes.
  • Rendering Features
    Covers projections and zooming.
  • Map Ineractivity
    Describes features that enable interactivity with the map.

Send comments on this topic.


Mapping API

Mapping API

The supporting mapping API contains a number of classes and can be found under the dotnetCHARTING.Mapping namespace. The chart object contains the property: 'Chart.Mapping' which exposes all the chart mapping properties necessary to create maps.

The map layers and shapes are laid out in a manner similar to the chart series and element objects. This table demonstrates the relationships.

Mapping | Charting
MapLayerCollection | SeriesCollection
MapLayer | Series
Shape | Element

See Sample Mapping/IteratingShapes.aspx.

Map Layer

The MapLayer object represents a shape file or ecw file and includes data retrieved from those files. Any number of layers can be added to a chart at a time. The object also exposes a number of properties to allow styling manipulation for shapes within a shape file.

The MapLayer provides a DefaultShape property which holds the default settings that will be applied to all shapes within the map layer.

Send comments on this topic.


Mapping Data and Layers

MapDataEngine object

The MapDataEngine class exposes methods that populate MapLayer objects with data and map information retrieved from shape or ecw files. The following code snippet demonstrates simple usage of this engine loading the states.shp shapefile into a map layer:

[C#]

MapLayer myLayer = MapDataEngine.LoadLayer("states.shp");

[Visual Basic]

MapLayer myLayer = MapDataEngine.LoadLayer("states.shp")

The myLayer object now contains visual and statistical data about each US state. These states are represented as Shape objects. Each shape has a number of attributes that contain the statistical data. This data is stored as key value pairs and the keys for the shape attributes are stored under the string array myLayer.AttributeNames.

Sample Mapping/IteratingShapes.aspx styles a number of shapes based on the value of the country code attribute.

Importing database data

One of the above mentioned attribute keys is 'State_Abbr' which represents the state abbreviation. Consider we also have a database containing additional information about these states that we want to use on the map. A column named 'state' in this database contains the same state abbreviations. This will allow matching the map shapes with this data. The first step is to get a DataTable containing the state column along with any other data columns to bind with the map. Next, the mapLayer will be bound with this table.

[C#]

myLayer.ImportData(myDataTable,"State_Abbr","state");

[Visual Basic]

myLayer.ImportData(myDataTable,"State_Abbr","state")

The parameters are the DataTable, the shape attribute and the matching DataTable column name to match. All other columns in the DataTable will be added to the map layer and shapes as additional attributes.

Sample Mapping/ImportShapefileData.aspx imports additional information about states from an access database to be used with the map layer.

Add layers to a map

Adding a layer to the map can be done easily with the following code:

[C#]

Chart.Mapping.MapLayerCollection.Add(myLayer);

[Visual Basic]

Chart.Mapping.MapLayerCollection.Add(myLayer)

Add Points Manually

Shape layers use a single type of shape such as polygons or points. Therefore, a new map layer must be created with points to add to a map. A point can be added based on a Lat/Long GPS coordinate or reversed in the form of Long/Lat as shown below:

[C#]
MapLayer ml = new MapLayer();
ml.AddPoint(50,100);
Chart.Mapping.MapLayerCollection.Add(ml);

[Visual Basic]
Dim ml AS new MapLayer()
ml.AddPoint(50,100)
Chart.Mapping.MapLayerCollection.Add(ml)
Sample: AddMapPoint.aspx

Add Lines manually

Again, a new map layer is required to add lines to a map. Lines can be added using Lat/Long GPS coordinates or reversed in the form of Long/Lat. A line object can be specified in the AddLine parameters to specify the styling when drawn. Line caps are also supported.

Sample: MapAddLine.aspx
Send comments on this topic.


Map Styling

Shapes Styling

The Shape object exposes a Background, Line, ElementMarker, and Label object which determines the shape's appearance. These objects can be manipulated individually for each shape or they can be set simultaneously for all objects through defaults.

The Chart.Mapping object as well as the MapLayer object contain a DefaultShape property which works the same as a normal DefaultSeries or DefaultElement in a regular chart.

See sample Mapping/ShapeStyling.aspx

Thematic Mapping

Thematic mapping is a feature by which a color is applied to shapes conditionally. This feature uses the SmartColor object. The following sample demonstrates using a smart colors to shade US states based on population ranges.

[C#]

Chart.SmartPalette = SmartPalette sp = new SmartPalette();
Color[] cols = new Color[]{Color.FromArgb(2,255,0),Color.FromArgb(186,253,0)};
sp.Add("POPULATION",new SmartColor(cols[0], new ScaleRange(100000,1000000)));
sp.Add("POPULATION",new SmartColor(cols[1], new ScaleRange(1000000,10000000)));

[Visual Basic]

Dim sp As New SmartPalette()
Chart.SmartPalette = sp
Dim cols() As Color = {Color.FromArgb(2, 255, 0), Color.FromArgb(186, 253, 0)}
sp.Add("POPULATION", New SmartColor(cols(0), New ScaleRange(100000, 1000000)))
sp.Add("POPULATION", New SmartColor(cols(1), New ScaleRange(1000000, 10000000)))
For more information on smart colors see this tutorial.

Labels

Similar to labels on normal chart elements, shape labels can contain tokens which represent the data attributes they contain. For instance, the shapes from the above example contain an attribute named 'State_Abbr' which represents the state's abbreviation. If the shape label text contains '%State_Abbr' the resulting label on the map will show the value of this attribute, depending on which state the label could be something like "IL", or "CA". This code snippet sets this label text for all the states within myLayer.

[C#]

myLayer.DefaultShape.Label.Text = "%State_Abbr";

[Visual Basic]

myLayer.DefaultShape.Label.Text = "%State_Abbr"

Additional data imported from other databases (See: Mapping Data and Layers) can also be represented in these labels.

See sample Mapping/ImportShapefileData.aspx

LabelOnce Option [New in v5.0]

In cases where a single shape has multiple polygon parts representing islands for example, the control tends to place the shape's label on each polygon of the shape. Using this option will ensure only one label is used for the collection of polygons belonging to the shape.

  • CS
  • VB
mapLayer.LabelOnce = true;

mapLayer.LabelOnce = true

Sample: MapLabelOnce.aspx

Shape Groups

Shape files often contain a large number of shapes which may be difficult to differentiate between and label. The Group object solves this by conditionally encapsulating a number of shapes. This allows settings to simultaneously be applied to all shapes within that group. A DefaultShape property is provided by this Group object to facilitate this feature.

The conditions that determine whether a shape belongs to a group are based on the data attributes of those shapes. For example a condition may be that only shapes with a 'population' attribute greater than 50,000 are included. The following code snippet demonstrates this example.

[C#]

MapLayer layer = MapDataEngine.LoadLayer( @"mapFiles/canada.shp");
dotnetCHARTING.Mapping.Group gr = new dotnetCHARTING.Mapping.Group("CNTRY_NAME", "Canada");
gr.DefaultShape.Background.Color = Color.Green;
layer.Groups.Add(gr);
Chart.Mapping.MapLayerCollection.Add(layer);

[Visual Basic]

Dim layer As MapLayer = MapDataEngine.LoadLayer("mapFiles/canada.shp")
Dim gr As New dotnetCHARTING.Mapping.Group("CNTRY_NAME", "Canada")
gr.DefaultShape.Background.Color = Color.Green
layer.Groups.Add(gr)
Chart.Mapping.MapLayerCollection.Add(layer)

See sample Mapping/ShapeGrouping.aspx

Group Labels

While the styling properties of the default shape are inherited by all the shapes within the group. The Group.Label property is drawn only once on top of the entire group. Tokens are not allowed in this label's text.

[C#]

MapLayer layer = MapDataEngine.LoadLayer( @"mapFiles/canada.shp");
dotnetCHARTING.Mapping.Group gr = new dotnetCHARTING.Mapping.Group("CNTRY_NAME", "Canada");
gr.Label = new dotnetCHARTING.Label("Canada",new Font("Arial",25,FontStyle.Bold),Color.FromArgb(200,20,20),Color.White);
layer.Groups.Add(gr);
Chart.Mapping.MapLayerCollection.Add(layer);

[Visual Basic]

Dim layer As MapLayer = MapDataEngine.LoadLayer("mapFiles/canada.shp")
Dim gr As New dotnetCHARTING.Mapping.Group("CNTRY_NAME", "Canada")
gr.Label = New dotnetCHARTING.Label("Canada", New Font("Arial", 25, FontStyle.Bold), Color.FromArgb(200, 20, 20), Color.White)
layer.Groups.Add(gr)
Chart.Mapping.MapLayerCollection.Add(layer)

See sample Mapping/ShapeGrouping.aspx
Send comments on this topic.


Mapping Rendering

Rendering

Projections

Projections were created to emulate the surface of the earth on a flat surface such as a monitor. .netCHARTING provides two types of projections; The Lambert Conic, and the Mercator projection.

The following code snippet demonstrates using the Lambert Conic Projection:

[C#]

Chart.Mapping.Projection.Type = ProjectionType.LambertConic;
Chart.Mapping.Projection.Parameters = "-10,-20,-32,49";

[Visual Basic]

Chart.Mapping.Projection.Type = ProjectionType.LambertConic
Chart.Mapping.Projection.Parameters = "-10,-20,-32,49"

See samples:

  • Mapping/Projections.aspx

Projections and Performance

Projecting ecw files is a CPU intensive operation. To remedy this feature in a real time rendering environment, the projected ecw views can be cached as jpeg images. This works by simply providing the path and name of a jpeg file where the cached image can be stored as shown in the following code snippet.:

[C#]

MapLayer myLayer = MapDataEngine.LoadLayer("earth.ecw","earth_ecw.jpg);

[Visual Basic]

MapLayer myLayer = MapDataEngine.LoadLayer("earth.ecw","earth_ecw.jpg)

Zooming

A simple API is provided to facilitate zooming. The feature consists of a ZoomPercentage and ZoomCenterPoint properties.

Since shape and ecw files are generally based on the Longitude/Latitude coordinate system, choosing a center point of your zoom can be easily accomplished by finding the GPS coordinates of the particular location. This code snippet demonstrates a simple zoom:

[C#]

 // Zoom 2250% into the coordinates for chicago.
 Chart.Mapping.ZoomPercentage = 2250;
Chart.Mapping.ZoomCenterPoint = new PointF(41.9f,-87.65f);

[Visual Basic]
 ' Zoom 2250% into the coordinates for chicago.
Chart.Mapping.ZoomPercentage = 2250
Chart.Mapping.ZoomCenterPoint = New PointF( 41.9F, -87.65F)

The following table shows how GPS coordinates are represented in .netCHARTING:

GPS | .netCHARTING
Latitude Longitude: 41°54' N 87°39' W | new PointF( 41.54f, -87.39f)
Latitude Longitude: 34° 56' S 138° 35' E | new PointF( -34.56f, 138.35f )

See sample Mapping/MapZooming.aspx
Send comments on this topic.


Map Interactivity

The mapping functionality offers some unique features to enable interactivity.

Shape Hotspots

Shapes have a Hotspot property which allows mouseover tooltips and other interactive functionality. For more information see hotspots tutorial.

The most useful application of this is to set DefaultShape's hotspot properties as shown in this sample.

Sample: MapHotspots.aspx

Click to GPS (Lat/Long) coordinates

This feature allows a pixel coordinate on the map to be translated into GPS coordinates of the point based on the map. By capturing a user's click coordinate this information can be translated into GPS coordinates to provide zooming on the map or using the GPS position to query information from other services.

[C#]

Chart.FileManager.SaveImage();
PointF gpsPoint = Chart.Mapping.GetLatLongCoordinates("50,100");

[Visual Basic]

Chart.FileManager.SaveImage()
Dim gpsPoint AS Chart.Mapping.GetLatLongCoordinates("50,100")

This feature also works with projections applied to the map.

Samples:
ClickMap.aspx
ClickMapProjected.aspx
ClickMapZoom.aspx

Click to Shapes array

From the click pixel position an array of Shape objects that land under the coordinate can be acquired. This can be used to select specific shapes and display its details or modify any of its properties.

[C#]
Chart.FileManager.SaveImage();
ArrayList shapes =
Chart.Mapping.GetShapesAtPoint("50,100);

[Visual Basic]
Chart.FileManager.SaveImage()
Dim shapes AS
Chart.Mapping.GetShapesAtPoint("50,100)
Sample:
IdentifyShape.aspx
Note: The reason the SaveImage method is called is because the chart must be generated to have the information necessary to process these requests.

Ajax Zoomer

The ajax zoomer feature also supports mapping. This will allow the user to interactively zoom and scroll maps on demand.

Send comments on this topic.


Ajax Zooming

Ajax Features

Introduction

This feature set enables web based zooming and scrolling as well as a user interface for end users to navigate and manipulate the chart zooming. An auto updating implementation also allows the chart to refresh with new data without reloading the web page.

Getting Started

The zoomer features can be accessed through the Chart.Zoomer class. To enable this functionality Chart.Zoomer.Enabled = true must be set. This will allow the user to zoom and navigate the chart via a context menu.

The context menu offers Zoom, Zoom in, and axes to zoom options. 'Zoom In' will automatically zoom into the chart while 'Zoom' will allow the user to select a zoom in area using the mouse.

After zooming using the context menu and selecting an area, the user can drag the chart or use the scrollbars to navigate it.

Options affecting user UI

Chart.Zoomer.DragAfterZoom
The option will determine whether dragging is automatically enabled after a chart is zoomed.

Chart.Zoomer.ScrollType
Determines the scrolling type with options including drag (click / drag), scroll (using scroll bars / arrows) or both.

Chart.Zoomer.AxisToZoom
Options include Both (can select any arbitrary bounding box to zoom to), XAxis (select a specific x axis region only, y axis is fixed to the maximum extent) , YAxis (select a specific y axis region only, x axis is fixed to the maximum extent).

Chart.Zoomer.SelectionStyle
Determines the visual style when selecting a zoomed region. Options include box and cross hair. Box is more aesthetically pleasing and allows for rough selections. Cross hair is more accurate and shows the cross hair lines extending to the axis to select a more accurate region for the zoom.

Other Options

Chart.Zoomer.UseSections
Determines if the chart image is rendered as a single image or in sections.

Chart.Zoomer.PreloadedSections
Determines the number of sections (rows / columns) outside of the viewing portal to render in advance. This can provide a better experience for the user at the cost of performance and bandwidth (loading images that may never be viewed).

Chart.Zoomer.ReloadPeriod
The update interval for the chart in seconds. If data is changing on the server side this interval will refresh the chart image seamlessly based on this time period. This operation is resource intensive and should only be used if it the data for the chart is frequently changing and it is important that the viewer have the latest result immediately.

Chart.Zoomer.ToolTipDelay
Determines the amount time in seconds before the tooltip displays (if a tooltip exists for the area hovered over).

Chart.Zoomer.AjaxHandlerEnabled
By default, .netCHARTING automatically handles all calls. If this boolean is true, a dedicated handler (ashx) page is used instead of the calling page. This option would typically only be used if the application was very performance sensitive and is disabled by default.

Axis Viewport

The Axis.Viewport class provides properties that can be used to specify the zoom depth and position programmatically. It supports numeric, time, and category axes.

Category Axes
With category axes, Viewport.ElementCount can be used to specify how many element groups to fit within the view at a time.

Using the Axis.Viewport properties allows specifying a starting and end position with category axes by setting the Viewport.ScaleRange. The scaleRange should be set using integers referring to the elements numerically from 0 to n elements shown.

Note: The ElementCount property and scaleRange indexes refer to groups of elements, not individual elements so if there are 4 series, a value of two would actually show 8 elements.

Numeric and Time Axes
With quantitative axes, the range can be specified through Viewport.NumericRange or Viewport.TimeInterval. In addition to these properties, Viewport.ScaleRange can also be used for both and because it takes a starting and ending value, it is used to specify a range and a starting zoom position.

Limitations:

  • Supported ChartTypes: Combo, ComboHotizontal, ComboSideBySide, Gantt, Scatter, Mapping, Organizational.
  • Chart must contain only one chart area.
  • 3D mode is not supported.
  • Default medium trust level will not allow the zoomer functionality. A higher trust level must be set or the medium trust level must be modified to allow calling unmanaged code. This is required in order for the chart to quickly create and use vector based representation of the chart from which individual sections can be rendered and streamed to the browser on demand. Asp.net must call unmanaged code internally in order to properly manage this information in memory.

Send comments on this topic.


10.0 Defaults & Shading Effects

Intro

Version 10.0 release of .netCHARTING introduces visual enhancements including a new look & default settings. The idea behind this feature was to introduce a very subtle colorizing enhancement that is true to original settings and boosts aesthetics. It has been designed to work seamlessly with existing charts and to make them pop visually without breaking the visual balance of existing settings. For backward compatibility these default settings are applied internally when the chart begins to render. When checking the property settings before the chart renders, the property values are still the same as before.

The new defaults are primarily color and shading settings including a few font style changes.

The new Background object's fill functionality will ehnance the resulting visuals. Unlike traditional settings, it is setup to take solid colors and adjust the output to appear slightly shaded. The result is a chart that looks like it was designed with a graphics design software without any effort on the developers side.

This shading happens when the background shadingEffectMode setting is set to ShadingEffectMode.Default which is set by default. This setting creates different shading effects depending on the location of the fill. The different effect locations are:

  • Box
  • TitleBox
  • BoxHeader
  • AlternateGridShading
  • AxisMarkers
  • ChartArea
  • GaugeBox
  • JsButton

New Palette

A new default palette has been added. It can be specified manually with Chart.PaletteName = Palette.Default.

When checking or getting the colors of a charts palette, they may change when the chart renders, therefore it's advisable to specify the palette before this is done.

Disabling new Defaults

This effect can be disabled for any individual background property by changing to the ShadingEffectMode to None. By setting Chart.LegacyMode = true the new defaults can be disabled for any individual chart.

This can also be disabled for an entire website by adding the following setting to the web.config file.

<appSettings>
<add key="DNCLegacyMode" value="false" />
</appSettings>

Alternatively, when the new defaults are disabled. Things such as a default shading for a particular element can be enabled. For example this code enables the default shading just for the chart area:

  • CS
  • VB
Chart.ChartArea.Background.ShadingEffectMode = ShadingEffectMode.Default;

Chart.ChartArea.Background.ShadingEffectMode = ShadingEffectMode.Default

Send comments on this topic.


Element Colors & Palettes

Introduction

This tutorial will describe how to use palettes and specify element and series colors as well as some more advanced coloring features.

Using Palettes

There are several 50 color palettes and over 40 5 color palettes available in the Palette enumeration. These can be defined in two ways.

A: Through Chart.PaletteName:

[C#]

Chart.PaletteName = dotnetCHARTING.Palette.Autumn;

[Visual Basic]

Chart.PaletteName = dotnetCHARTING.Palette.Autumn

This code will color each series based on a color in this palette.

B: Through Series.PaletteName

[C#]

mySeries.PaletteName = dotnetCHARTING.Palette.Autumn;

[Visual Basic]

mySeries.PaletteName = dotnetCHARTING.Palette.Autumn

Using palette properties of series will color each element in that series a unique color of the specified palette as well as alter the legend behavior.

NOTE: (Important) By specifying a series palette, the legend box will display an entry for each element instead of entries for each series.
Sample: ColorByElements.aspx

Custom Palettes

There are a number of five color palettes available in the Palette enumeration. These palettes can be combined to form a palette with a larger set of colors using the Chart.PaletteAdd() method.

Sample: MultiplePalettes.aspx

Custom palettes can also be specified by supplying the Chart.Palette or Series.Palette properties with an array of color objects. They will work in the same way as pre-defined palettes.

Coloring Individual Elements

To specify a color for an individual element it needs to be set through the Element.Color property. To specify a color for an entire series of elements, set the Series.DefaultElement.Color property.

In order to specify individual series or element colors, a populated Series or SeriesCollection is required. Please see this kb for more information.

Samples

  • iterateElements.aspx
    Color elements based on value.
  • InvisibleLegendEntry.aspx
    Color elements based on value.

SeriesTypeFinancial

Financial series types like candlestick and bar use Element.SecondaryColor to fill elements that have a lower close price than open price.

SeriesType.Line

A 2D line's thickness, and style can be controlled with the Series.Line property however, the line color is based on individual element colors.

More advanced coloring options are described in the SmartColor & SmartPalette Tutorial.

Send comments on this topic.


Smart Palettes

Overview

  • SmartPalette
    • Manually Defining a SmartPalette
    • Automatically Generating a SmartPalette
    • Saving the SmartPalette
    • Loading the SmartPalette
    • Applying the SmartPalette
  • SmartColor
    • Simple SmartColor (One color)
    • Range SmartColor (Multiple colors)
    • Automatically generate multiple range SmartColors.
  • SmartColor Legend Entries
    • Simple SmartColor (One color)
    • Range SmartColor (Multiple colors)
  • Custom Legend
    • Generating color swatches
      • Markup
      • Examples
      • Swatch Markup Example Details
    • Using Color Swatches
      • In legend
      • Anywhere

The SmartPalette

The SmartPalette object allows you to create a standard color scheme for different charts that show related data. It does this by establishing a list of series or element names and the colors they should use. Fortunately, it does not require you to manually define all these name color pairs as it can do this automatically. A SmartPalette is also used as a collection container for SmartColor objects discussed later in this tutorial.

To create a smart palette automatically that any charts can use, a populated SeriesCollection is required. Then a palette enumeration member or array of colors can be used to generate the SmartPalette based on the names of series in a series collection or element names in a series series. When the SmartPalette object is created it can be saved as XML and loaded by any chart with access to the xml file.

Manually Defining a SmartPalette

The code below demonstrates manually populating a smart palette object.

[C#]

SmartPalette sp = new SmartPalette();
sp.Add("Series 1", Color.Red);
sp.Add("Series 2", Color.Blue);

[Visual Basic]

Dim sp As New SmartPalette()
sp.Add("Series 1", Color.Red)
sp.Add("Series 2", Color.Blue)

Automatically Generating a SmartPalette

This code will generate a smart palette based on the colors specified by the Palette.One enumeration and match them with element names within the mySeries series object.

[C#]
SmartPalette sp = mySeries.GetSmartPalette(Palette.One);

[Visual Basic]
Dim sp As SmartPalette = mySeries.GetSmartPalette(Palette.One)

Saving the SmartPalette

Now that the SmartPalette object is generated and ready to use, it can be used by all charts related to this information. In order to use this object in other web pages it must be saved as xml. The following code demonstrates this.

[C#]

sp.SaveState("ClientSmartPalette.xml");

[Visual Basic]

sp.SaveState("ClientSmartPalette.xml")
Sample: SmartPaletteSaving.aspx
At this point, everything is setup for charts that show clients to use the same colors for each client no matter what page is showing the chart.
Loading the SmartPalette
The following code initializes an instance of the SmartPalette object using the information stored in ClientSmartPalette.xml.
[C#]
SmartPalette sp = new SmartPalette("ClientSmartPalette.xml");
[Visual Basic]
Dim sp As New SmartPalette("ClientSmartPalette.xml")
Sample: SmartPaletteLoading.aspx SmartPaletteSaving.aspx

Applying the SmartPalette

There are a couple ways the smart palette can be used. One way is to specify the SmartPalette for the whole chart. In this case, any element or series that matches a SmartPalette entry will inherit the associated color.

[C#]

Chart.SmartPalette = sp;

[Visual Basic]

Chart.SmartPalette = sp

The other option allows narrowing the use of the smartPalette to a chart area by means of specifying the smartPalette for the chart area's seriesCollection.

[C#]

ChartArea ca = new ChartArea();
ca.SeriesCollection.SmartPalette = sp;
Chart.ExtraChartAreas.Add(ca);

[Visual Basic]

Dim ca As New ChartArea()
ca.SeriesCollection.SmartPalette = sp
Chart.ExtraChartAreas.Add(ca)

SmartColor objects

The SmartColor object provides a feature that sets colors of elements based on a condition. For example, if elements on a chart that are below 0 must be red, this object will provide the functionality to do this automatically. The following code snippet demonstrates how this can be achieved. The parameters in the SmartColor constructor refer to the color that should be used, a range of numeric or DateTime values, and the Element property to compare against the specified range.

Simple SmartColor

[C#]

SmartColor SingleSCol = new SmartColor(Color.Red,new ScaleRange(-1000,0),ElementValue.YValue);
Chart.SmartPalette.Add(SingleSCol);

[Visual Basic]

Dim SingleSCol As new SmartColor(Color.Red,new ScaleRange(-1000,0),ElementValue.YValue)
Chart.SmartPalette.Add(SingleSCol)

Color Range SmartColor

The SmartColor object also contains a SecondaryColor property. When specified, the elements that fall within the smart color's range will be colored based on where they fall within the range. For example, using a range of 0 to 100 with Color.Red and secondary color Color.Yellow; an element with the value of 0 will be red, a value of 100 will yield yellow and 50 results in a mix between the two which would be orange.

The following code will create a single SmartColor object with a gradient color range that will achieve the same coloring functionality as the above legend example, but will require a single SmartColor object.

[C#]

SmartColor scol = new SmartColor(Color.White, Color.Yellow, new ScaleRange(0,50), ElementValue.YValue);
Chart.SmartPalette.Add(scol);

[Visual Basic]

Dim scol As new SmartColor(Color.White, Color.Yellow, new ScaleRange(0,50), ElementValue.YValue)
Chart.SmartPalette.Add(scol)

Multiple range smartColors can also be used with the same palette creating a more complex color scale.

See sample: Features/SmartColorGradient.aspx

Automatically generate multiple range SmartColors

In the above examples, the scale range must be specified manually to create a single smartColor. There are methods to create multiple smartColors automatically from a specified lists of colors.

This code snippet demonstrates how 3 range colors can be created automatically based on a list of 4 colors and a scale range.

  • CS
  • VB
Chart.SmartPalette = SmartPalette.FromColors(ElementValue.YValue, new ScaleRange(0,10), Color.LimeGreen, Color.Yellow, Color.Orange, Color.Red);

Chart.SmartPalette = SmartPalette.FromColors(ElementValue.YValue, New ScaleRange(0,10), Color.LimeGreen, Color.Yellow, Color.Orange, Color.Red)

A value range must be specified with the above usage. However, the series object offers the method GetSmartPalette that will return a smartPalette object with range colors based on the range of its data. The following code uses the GetSmartPalette method to generate a smartPalette based on the series YValue data range.

  • CS
  • VB
Chart.SmartPalette = series1.GetSmartPalette(ElementValue.YValue, Color.Red, Color.Orange, Color.Yellow);

Chart.SmartPalette = series1.GetSmartPalette(ElementValue.YValue, Color.Red, Color.Orange, Color.Yellow)

The SmartColor object is used in conjunction with maps to provide thematic mapping functionality. For more information on thematic mapping see the Map Styling tutorial.

SmartColor Legend Entries

One color SmartColors
SmartColors have a LegendEntry property which is used in the legend as a reference to the chart's color scheme. If tokens are used in the legend entry label text, they will be evaluated for the scale range object.

SmartColors that use a single color will create legend entries that look like these:

Color Range SmartColors

A SmartColor that uses two colors, will create a single icon that will look like this. (Notice the gradient icon)

The following code shows a useful modification of the smartColor legend entry to display like so:

[C#]

scol.LegendEntry.Value = "0";
scol.LegendEntry.Name = "50";

[Visual Basic]

scol.LegendEntry.Value = "0"
scol.LegendEntry.Name = "50"

Custom Legend

SmartPalette Information API

The smartPalette object offers methods that provide information about its values and colors. These methods can be used to obtain all the information necessary to describe the smart palette visually.

Method | Description
SmartPalette .GetScaleRange(string key) | SmartColor can apply to elements or series with a particular name, which is specified using the key parameter. Specifying "*" refers to all keys. This method will return the united scale range defined by the SmartColors object within the palette.
SmartPalette .GetValueColor(string key, double value) | This method returns the color corresponding to the specified key and value.

After establishing the range and color values for the SmartPalette, a color swatch may be generated to display the scale of colors and correspondig numeric values.

Generating Color Swatches

A color swatch is an array of colors defined by the smart palette. By utilizing label markup and InfoGrids, this type of smart palettes can be used to generate a color swatch.

    These swatches are not a hard coded feature of the component. It utilizes our proprietary markup to generatet the visuals so it is not limited to the examples presented here.

Color Swatch Markup
The markup for these swatches is easy to generate programatically by concatenating a string. Although it is very simple, it is not necessary to understand the markup unless more complex swatches (not shown here) are needed. For swatches similar to the examples below, the code to generate them can be taken from the available samples. For information on the markup syntax, see the Label Markup tutorial. This knowledge is also useful in many other unrelated scenarios because all labels on a chart support it. The InfoGrids, and MicroChart tutorials can also be helpful.

Swatch Markup Examples
Here are a number of swatch examples and the associated markup to draw them.

    All these swatches and helper methods to create the markup are available in sample FeatureSet/Palettes/ColorRangeStyling.aspx

A swatch using a row of spacers and a row of colored blocks.

<Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><Chart:Spacer size='35x1'>

                <Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><row>

                <block bgColor='#FFFF00' fColor='#FFFF00'>_<block bgColor='#FFBF00' fColor='#FFBF00'>_

                <block bgColor='#FF8000' fColor='#FF8000'>_<block bgColor='#FF4000' fColor='#FF4000'>_

                <block bgColor='#FF0300' fColor='#FF0300'>_

            Fig 1.

A swatch using a row of spacers and a row of colored blocks with values.

<Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><Chart:Spacer size='35x1'><row><block hAlignment='Center' bgColor='#FFFF00'>0<block hAlignment='Center' bgColor='#FFBF00'>12<block hAlignment='Center' bgColor='#FF8000'>25<block hAlignment='Center' bgColor='#FF4000'>37<block hAlignment='Center' bgColor='#FF0300'>50

            Fig 2.

A swatch using colored blocks and text before and after to represent the mininum and maximum values.

0<block bgColor='#FFFF00' fColor='Transparent'>__<block bgColor='#FFBF00' fColor='Transparent'>__<block bgColor='#FF8000' fColor='Transparent'>__<block bgColor='#FF4000' fColor='Transparent'>__<block bgColor='#FF0300' fColor='Transparent'>__<block>50

            Fig 3.

A swatch with richer styling and description of minimum and maximum values.

<block bgColor='LightGray'>[Outside Temperature]<block bgColor='LightGray'>[Min]<block bgColor='#FFFF00' fColor='Transparent'>__<block bgColor='#FFBF00' fColor='Transparent'>__<block bgColor='#FF8000' fColor='Transparent'>__<block bgColor='#FF4000' fColor='Transparent'>__<block bgColor='#FF0300' fColor='Transparent'>__<block bgColor='LightGray'>[Max]

            Fig 4.

A swatch with a micro chart scale.

<Chart:Scale values='0,25,50' width='75'><row><block bgColor='#FFFF00' fColor='Transparent'>__<block bgColor='#FFBF00' fColor='Transparent'>__<block bgColor='#FF8000' fColor='Transparent'>__<block bgColor='#FF4000' fColor='Transparent'>__<block bgColor='#FF0300' fColor='Transparent'>__

            Fig 5.

A vertical swatch with values.

<block bgColor='#FFFF00'>0<row><block bgColor='#FFBF00'>12<row><block bgColor='#FF8000'>25<row><block bgColor='#FF4000'>37<row><block bgColor='#FF0300'>50

            Fig 6.

A vertical swatch with two colums, using two blocks per row. The the second block of the first middle and last rows also include values in.

<block bgColor='#FFFF00' fColor='Transparent'>__<block>0<row><block bgColor='#FFBF00' fColor='Transparent'>__<block><row><block bgColor='#FF8000' fColor='Transparent'>__<block>25<row><block bgColor='#FF4000' fColor='Transparent'>__<block><row><block bgColor='#FF0300' fColor='Transparent'>__<block>50

            Fig 7.

Swatch Markup Example in Detail

This markup example creates a swatch similar to figure 1 but with only three colors:

"<Chart:Spacer size='10x1'><Chart:Spacer size='10x1'><Chart:Spacer size='10x1'><row><block bgColor='Red'> <block bgColor='White'> <block bgColor='Blue'>"

This example uses two rows and three columns. When all rows in a markup string have the same number of blocks, they will behave like a grid where each column of blocks aligns and has the same width. The three spacer microCharts are used to ensure that the blocks of the next row are the same width. Spacers are treated as blocks.

    When using this method with spacers, the color blocks will be touching like in Figures 1 and 2. Without spacers, the blocks will have small gaps between them like Figures 3, 4, and 5. These swatches use a transparent underscore character inside blocks instead of spacers to give them uniform width.

Swatches that rely on spacers must maintain the same number of blocks in each row. Therefore,  using text inside blocks is superior because it allows for additional text and markup to render around the swatch itself without disfiguring it. Figures 4 and 5 use additional text with the swatch markup.

Generating Swatch Markup Automatically
The following code shows a method that will generate a color swatch string you can insert into any label text on the chart.

It will generate a string that draws this type of visual:

  • CS
    •

  • VB
    •

    string getSwatch(int width, SmartPalette sp, int divisions, bool withValues)
    {
        // Get Maximum Value of the smart palette range
        double max = (double)sp.GetScaleRange("*").ValueHigh;
        // Width of each division.
        int boxWidth = width / divisions;

        string swatch = "", spacers = "";
        // Generate swatch string for each division.
        for (int i = 0; i <= divisions; i++)
        {
            spacers += "<Chart:Spacer size='" + boxWidth + "x1'>";
            // Get the color of the current division.
            string color = getHTMLColor(sp.GetValueColor("", (i * (max / divisions))));
            if (withValues)
                swatch += "<block  bgColor='" + color + "' fColor='Black' fStyle='Regular'>"
                       + (i * (max / divisions));
            else
                swatch += "<block  bgColor='" + color + "' fColor='" + color + "'>_";
        }
        //return the swatch string.
        return spacers + "<row>" + swatch;
    }
    string getHTMLColor(Color c)
    {
        return "#" + c.R.ToString("X2") + c.G.ToString("X2") + c.B.ToString("X2");
    }

Private Function getSwatch(width As Integer, sp As SmartPalette, divisions As Integer, withValues As Boolean) As String
   ' Get Maximum Value of the smart palette range
   Dim max As Double = CDbl(sp.GetScaleRange("*").ValueHigh)
   Dim swatch As String = "", spacers As String = ""
   ' Width of each division.
   Dim boxWidth As Integer = width \ divisions
   ' Generate swatch string for each division.
   For i As Integer = 0 To divisions
     spacers += "<Chart:Spacer size='" & boxWidth & "x1'>"
     ' Get the color of the current division.
     Dim color As String = getHTMLColor(sp.GetValueColor("", (i * (max / divisions))))
     If withValues Then
        swatch += "<block  bgColor='" & color & "' fColor='Black' fStyle='Regular'>" & (i * (max / divisions))
     Else
        swatch += "<block  bgColor='" & color & "' fColor='" & color & "'>_"
     End If
   Next
   'return the swatch string.
   Return spacers & "<row>" & swatch
End Function

The above code first gets the max value of the palettes scale so it can iterate from 0 to that max value. Then it determines the width to use with each spacer. The loop creates a string of spacers to ensure each division is the same width. It gets the current value's color and creates a block setting the color as its background. To use the color in markup, it is converted into the hex format used by HTML. The spacers and swatch blocks are then returned as a single string.

                By setting the withValues prameter to true, a visual that looks like this is created:

This version of the swatch is nice because it does not require any additional labeling. Therefore, it can easily be placed in any other labels on the chart. A new annotation can be used to show the swatch. it can be placed in the title, chart area label or anywhere else.

    The SmartPalette GetValueColor method can be utilized in other scenarios as well. For example, sample AxisTickSwatch uses this method to color the background of axis tick labels based on the tick values.

Using Color Swatches

ColorSwatches in LegendEntries

Using the above getSwatch method, the code below will replace the legend icon with a color swatch to create a legend entry that looks like this.

[C#]

scol.LegendEntry.CustomAttributes.Add("ICON",getSwatch(100,sp,10));

[Visual Basic]

scol.LegendEntry.CustomAttributes.Add("ICON",getSwatch(100,sp,10))

Original

                With Swatch Icon

Instead of using the values on each end of the swatch, a scale microChart legend entry can be added to create a visual like this:

The following code creates a new legend entry and adds it to the top of the entries containing the scale microchart. Setting the sortorder of the entry to -1 ensures it appears before the swatch entry.

[C#]

scol.LegendEntry.Value = "";
scol.LegendEntry.Name = "";
LegendEntry scaleLe = new LegendEntry();
scaleLe.CustomAttributes.Add("ICON", "<Chart:Scale min='0' max='50' width='140'>");
scaleLe.SortOrder = -1;
Chart.LegendBox.ExtraEntries.Add(scaleLe);

[Visual Basic]

scol.LegendEntry.Value = ""
scol.LegendEntry.Name = ""
LegendEntry scaleLe = new LegendEntry()
scaleLe.CustomAttributes.Add("ICON", "<Chart:Scale min='0' max='50' width='140'>")
scaleLe.SortOrder = -1
Chart.LegendBox.ExtraEntries.Add(scaleLe)

ColorSwatches anywhere
Using swatches in the legend works well, but these swatches can also be used in any label on the chart. They can be used inside annotations, chart titles, etc. This approach can even be used to generate an HTML swatch to show on a webpage outside of the chart.

See Also
Tutorials

Label Layout Markup

API Reference

SmartPalette Class

SmartColor Class

Send comments on this topic.


Creating And Using Templates

Introduction
The chart component is capable of saving its state including all property settings, elements, etc. to an XML file. This functionality provides the ability to save a chart template consisting of any color, styling, and label related properties and load it onto charts so that their styles match.

Make a template
To make a template, start with a simple chart with some elements and apply any settings necessary to establish the chart styling. When this is complete, the following code will save the property settings to an xml file called style1.xml.

  • CS
  • VB
Chart.SaveState("style1.xml");

Chart.SaveState("style1.xml")

Make sure to save the state before any elements are added to the chart so that other charts that consume this style dont get the elements along with it.

Loading a template
Every chart that will be using style1.xml can do so with a single line of code:

  • CS
  • VB
Chart.LoadState("style1.xml");

Chart.LoadState("style1.xml")

SmartPalettes provide Element Colors & Palettes, however, if they are included in the chart before it's saved, they will be used when loaded as well.

Send comments on this topic.


Hotspots

Introduction

Hotspots represent areas on the chart image that encapsulate interactive functionality. They also allow you to specify any custom HTML attributes of the generated image map <area> tags. The following objects all contain a Hotspot property.

  • Element
  • Annotation
  • Chart
  • EmptyElement
  • LegendEntry
  • Label (Version 4.0+)
  • Mapping.Shape (Version 4.1+)

Basic Functionality

To set the href, alt, or target attributes of the hotspot the following code can be used. In this case an element will be used as an example but similar code will work for other hotspots as well.

[C#]

Element el = new Element();
el.Hotspot.URL = "?elementName=%Name";
el.Hotspot.URLTarget = "_blank";
el.Hotspot.ToolTip = "%Name: %Value";

[Visual Basic]

Dim el As new Element()
el.Hotspot.URL = "?elementName=%Name"
el.Hotspot.URLTarget = "_blank";
el.Hotspot.ToolTip = "%Name: %Value"

Rich Tooltips

The ToolTip property can also parse and understand the label markup tags, InfoGrids, and MicroCharts. This provides the ability to specify format, layout, and styling inside the tooltip, as well as embedding images or pages that stream images.

More Options

For more advanced java script attributes the Hotspot.Attributes property exposes a number of events:

  • OnClick
  • OnMouseOver
  • OnDoubleClick

Each of these events is an HtmlAttribute class that also exposes several actions that can be created automatically:

  • Alert
  • Redirect
  • RedirectFrame
  • StatusBarMessage

This example demonstrates all the automatic JavaScript attribute features:

[C#]

element.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%SeriesName - %Name: %YValue";
element.Hotspot.Attributes.OnClick.Alert= "%Name Clicked";
element.Hotspot.Attributes.OnDoubleClick.Redirect = "?name=%Name";
element.Hotspot.Attributes.OnDoubleClick.RedirectFrame = "?name=%Name";

[Visual Basic]

element.Hotspot.Attributes.OnMouseOver.StatusBarMessage = "%SeriesName - %Name: %YValue"
element.Hotspot.Attributes.OnClick.Alert= "%Name Clicked"
element.Hotspot.Attributes.OnDoubleClick.Redirect = "?name=%Name"
element.Hotspot.Attributes.OnDoubleClick.RedirectFrame = "?name=%Name";

Custom Attributes

There are several other events and JavaScript functions which are not available in the HtmlAttribute classes. For that reason, custom attributes can be specified. This code shows how to add one of the above attributes manually:

[C#]

element.Hotspot.Attributes.Custom.Add("OnClick","alert('%Name Clicked')");

[Visual Basic]

element.Hotspot.Attributes.Custom.Add("OnClick","alert('%Name Clicked')")

Notes and Limitations:

Ajax Zoomer:

  • Hotspot.Attributes are not supported, only Hotspot.URL and Hotspot.Tooltip can be used.
  • Markup is not allowed in Hotspot.Tooltip properties. Only text should be used. For example a new line character can be used instead of <br>.

Silverlight Navigator

  • Hotspot.Attributes are not supported, only Hotspot.URL and Hotspot.Tooltip can be used.
  • Markup however is usable in tooltips.

See Also
{Axis Value Coordinates}
{ChartArea Zooming}

Tutorials

Label Layout Markup
Micro Charts
InfoGrids
Send comments on this topic.


Interactivity - WinForms

Introduction

Winforms provides a HitTestInfo class which can be acquired by passing an x/y click coordinate to Chart.HitTest(int x,in y). This point is related to the chart image where 0,0 is the top left corner of the chart image. The HitTestInfo class contains information regarding the clicked position including the object that was clicked and how it relates to the data.

To get started, a click (or other event) handler must be set up. This code snippet demonstrates detecting a click on an element and displays a message box with the clicked element's name.

[C#]
this.chart1.Click += new System.EventHandler(this.ClickOnChart);
private void ClickOnChart(Object myObject,EventArgs myEventArgs)
{
   HitTestInfo hit = this.chart1.HitTest();
   if(hit.Object is Element)
   {
      Element el = (Element)hit.Object;

      MessageBox.Show("Element="+el.Name);
   }
}

[Visual Basic]
Me.chart1.Click += New System.EventHandler(Me.ClickOnChart)
Private Sub ClickOnChart(myObject As [Object], myEventArgs As EventArgs)
   Dim hit As HitTestInfo = Me.chart1.HitTest()
   If TypeOf hit.Object Is Element Then
      Dim el As Element = CType(hit.Object, Element)

      MessageBox.Show(("Element=" & el.Name))
   End If
End Sub 'ClickOnChart

HitTestInfo & DataSource

The HitTestInfo class also provides a dataSource object which contains more detailed information about the clicked object. See the DataSource Tutorial for more information. The resulting DataSource object will also provide information regarding the context in which the clicked object is appears. For example the DataSource.SplitBy property could be set to ElementGroup meaning the clicked object represents a group of elements sharing a name or x value. This can result by clicking on the x axis tick which represents the shared element name. The DataSource class can be used to evaluate tokens and expressions by specifying a text string which behaves like a label. The method is string DataSource.EvaluateExpression(string).

Automatic interactivity features

Setting an elements tooltip or url does not require setting up an event handler, this functionality will automatically be provided.

See Also
{Data Sources}
Send comments on this topic.


Calendar Patterns

Introduction

A CalendarPattern class specifies a pattern such as specific days in a week, months in a year etc. You can specify a time unit of any other time unit to form the pattern. For example: weeks of a year, seconds of a minute, days of a year, even milliseconds of a year.

Uses

Calendar patterns can be used with axis markers to highlight parts of a time scale axis and with Series.Trim to trim away elements with time values that land within the calendar pattern. They can also be used to specify a sequence of scale breaks on a time based axis.

Usage

The pattern is represented by an array of boolean values, each boolean value represents the specified PatternUnit and the whole array represents the specified CalendarUnit.

The CalendarPattern.PatternFromString method can be used to quickly create patterns using simple string of zeros (0) and ones (1). A week pattern would look like this: "0000000". A zero for each day of the week starting with saturday and ending with sunday. A pattern that flags the weekend (saturday and sunday) would look like this: "1000001".

Example:

[C#]

CalendarPattern myCalendarPattern = new CalendarPattern();
myCalendarPattern.CalendarUnit = TimeInterval.Week;

myCalendarPattern.PatternUnit = TimeInterval.Day;

myCalendarPattern.Pattern = CalendarPattern.FromString("1000001");

[Visual Basic]

Dim myCalendarPattern As CalendarPattern = new CalendarPattern()
myCalendarPattern.CalendarUnit = TimeInterval.Week

myCalendarPattern.PatternUnit = TimeInterval.Day

myCalendarPattern.Pattern = CalendarPattern.FromString("1000001")

In a pattern the __Unit properties refer to a single value (PatternUnit) and the whole pattern (CalendarUnit) like so:

"1000001" <-- CalendarUnit (Week)
^
PatternUnit of CalendarUnit (Sunday)

The above calendar pattern will flag each saturday and sunday in a given, time span.

If all the values are not provided, the pattern will assume false for the missing values. So if we used "100" for the above pattern, it would be the same as "1000000"

Calendar Patterns require a time axis scale.
When a calendar pattern is used in an axis marker, the axis marker must reside on an axis with a time scale. For more information see Elements & Axis scales.

CalendarPattern Shortcuts

There are two calendarPattern static properties that allow you to initialize an instance of the calendar pattern object quickly. The properties are Weekends and Weekdays.

The following code instantiates a weekend calendarPattern and is the equivalent of the four lines of code shown above.

[C#]

CalendarPattern myCalendarPattern = CalendarPattern.Weekends;

[Visual Basic]

CalendarPattern myCalendarPattern = CalendarPattern.Weekends

Adjustment Unit

Calendar patterns are drawn on the axis at exact time instances like the start of the day, end of the day, etc. If you use a pattern like the above and your data shows days as columns, the actual x axis time of those columns may also be the start of the day. This results in the columns being centered on the edge of the pattern. The expected behavior would be that the pattern edges fall between the day columns. To remedy this issue you may use the AdjustmentUnit. This will allow you to adjust the calendar pattern to show correctly on the axis. If your columns represent hours the correct adjustment unit would be TimeInterval.Hour.

Sample: calendarPattern.aspx
Send comments on this topic.


Using labels

Introduction

.netCHARTING label strings can be used as dynamic templates capable of evaluating mathematical expressions, embedding info about the associated object, and specifying format strings. They can also include layout and embedded font styling information and links. Images can be used inside labels mixed in with text and dynamic streaming charts generated by aspx pages among other features.

Label is a very powerful object that includes a great deal of functionality. This is an overview list of label related features:

Feature | Description
Tokens (Reference) | Tokens can be used to embed information about the object associated with the label.
Expressions | Mathematical expressions can also be evaluated within label text intertwined with tokens.
Formatting | Formatting values.
SmartLabel behavior | SmartLabel functionality and behavior features.
Embedded Styling/Images Markup | Embedding font styling, images, dynamic streaming charts, and layout information by specifying it within the label text.
InfoGrids™ | InfoGrids™ produce results similar to data grid controls; however, they are created and drawn within the chart image itself.
MicroCharts | MicroCharts are defined using a markup language inside the label text.

The following diagram demonstrates the properties used to access different labels.

Chart Labels Diagram

Click on any property name for additional information.

Handling Oversized Labels

The axis tick labels use very advanced algorithms to display labels and provide automatic label wrapping, however, not all labels wrap automatically. There are two ways to remedy issues when long labels are becoming a problem. One way to deal with this is to use label truncation. This feature is accessed through the Label.Truncation property. This feature allows limiting the label text to a specified number of characters.

See sample LabelTruncation.aspx for more info.

Most labels will allow automatic wrapping where the label will dynamically determine when and where to wrap text. This feature must be turned on as shown below:

[C#]
Chart.DefaultElement.SmartLabel.AutoWrap = true;

[Visual Basic]
Chart.DefaultElement.SmartLabel.AutoWrap = True
Samples: AutoWrapLabels.aspx
PieLabelSmartWrapping.aspx

Labels that dont support automatic wrapping can also be wrapped, however, this must be done manually and is achieved by inserting a new line character into the text of the label.

Tokens

Syntax: %{Token}
Example: %Name

Tokens can be used to embed information about the object associated with the label. For example the label of an element can contain the '%Name' token. When parsed, the token will evaluate to the element's name. The Label Token Reference lists objects and the tokens that are available for each.

Sample: ElementTemplate.aspx
Custom Tokens
Custom tokens can also be used to represent miscellaneous information retrieved from a database. For more information on custom tokens see the Custom Attributes tutorial.

Expressions

Syntax: <{Expression}>
Example: <(%YValue+5)/ %PercentOfTotal>

Mathematical expressions can also be evaluated within label strings. An expression must be encapsulated within '<' and '>' characters, similar to an xml tag. An example of a simple expression is '<2+2>' which would result in '4' in the final label text. If this expression string is intended to be taken literally, a preceding '\' character will prevent the expression parser from evaluating it. For example the string '\<2+2>' would result in '<2+2>'. Expressions can group parts of the expression using parentheses: (). Example: <(5+5)*3>. Expressions can also include tokens as values, for example: <%YValue/3>

Caution: Spaces are not allowed within expressions.
Wrong: <5 + %YValue>
Correct: <5+%YValue>

Expression Functions

Besides simple expressions, labels can evaluate advanced functions such as sin, cos, or sqrt.

[C#]

Chart.DefaultElement.SmartLabel.Text = "<%YValue+sin(%YValue)>";

[Visual Basic]

Chart.DefaultElement.SmartLabel.Text = "<%YValue+sin(%YValue)>"

This table lists the available functions.

abs(n) | Evaluates the absolute value of n.
acos(n) | Evaluates the arc cosine of n.
asin(n) | Evaluates the arc sine of n.
atan(n) | Evaluates the arc tangent of n.
cos(n) | Evaluates the cosine of n.
cosh(n) | Evaluates the hyperbolic cosine of n.
exp(n) | Evaluates the exponent of n.
ln(n) | Evaluates the natural logarithm of n.
log(n) | Evaluates the logarithm of n (base 10). Same as logn(n,10)
logn(n1,n2) | Evaluates the logarithm of n1 where n2 is the base of the logarithm.
sin(n) | Evaluates the sine of n.
sinh(n) | Evaluates the hyperbolic sine of n.
sqrt(n) | Evaluates the square root of n.
tan(n) | Evaluates the tangent of n.
tanh(n) | Evaluates the hyperbolic cosine of n.
round(n) | Rounds the number leaving no decimals.

Embedded Format Strings (In-Line Formatting)

Syntax: <<[expression]> | [token], [Format string]>
Example: <%YValue,Currency>

Values can be formatted in-line within the label using the above syntax.

For more information on in-line formatting see the Advanced Formatting tutorial.

Token, Expressions, and In-Line Formatting Examples

The following examples will demonstrate tokens, expressions, and embedded format strings usage.

Label Text | Result
%YValue | 5
%Name | Element 2
<%YValue+5> | 10
<(10+5)-%YValue> | 10
<sqrt(%YValue)+10> | 12.23
<%YValue,Currency> | $5.00
<<(10+5)-%YValue>,Currency> Notice that the expression is encapsulated in <> characters inside the in-line formatting <> tags. | $10.00

See Also
{Label Alignment and Control}
{Formatting Values}

Data Tutorials

{Custom Data Attributes}

Reference

{Labels}
{Tokens}
Send comments on this topic.


Label Alignment and Control

Introduction

Each element contains a SmartLabel object with properties that affect the label's behavior. To show the element labels the following code can be used. The setting will propagate to all elements within the chart.

[C#]

Chart.DefaultElement.ShowValue = true;

[Visual Basic]

Chart.DefaultElement.ShowValue = True

Absolute Position [New in v5.0]

SmartLabels have the ability to be positioned anywhere on the chart by specifying a static Point object representing the label's desired location.

  • CS
  • VB
myElement.SmartLabel.AbsolutePosition = new Point(50, 210);

myElement.SmartLabel.AbsolutePosition = new Point(50, 210)
Sample: AbsoluteLabelPosition.aspx

Dynamic Labels

Force Label Drawing
Labels that cannot fit on the chart will not be shown by default. To force them to appear, the DynamicDisplay property must be set to false.

[C#]

Chart.DefaultElement.SmartLabel.DynamicDisplay = false;

[Visual Basic]

Chart.DefaultElement.SmartLabel.DynamicDisplay = False

Prevent Label Overlap
Non-column series type elements have labels which will dynamically move out of each other's way to prevent overlap. When this happens, a line is drawn to indicate which element the label pertains to. This behavior can be turned off and on using the DynamicPosition property. The following code disables this feature:

[C#]

Chart.DefaultElement.SmartLabel.DynamicPosition = false;

[Visual Basic]

Chart.DefaultElement.SmartLabel.DynamicPosition = False

The line drawn to indicate the element can be modified through the SmartLabel.Line property.

Line caps can be used to make the indicator lines look like arrow pointers.

SmartLabel Padding [New in v5.0]

In some cluttered situations where many elements are close together and in turn surrounding labels are close together as well can make the chart more difficult to understand. Using SmartLabel padding will force a gap between the elements and labels, as well as between the labels themselves.

  • CS
  • VB
Chart.DefaultElement.SmartLabel.Padding = 5;

Chart.DefaultElement.SmartLabel.Padding = 5

The dynamic nature of SmartLabels positioning can result in complex label layouts. If the layout of these labels is not aesthetically pleasing or undesired, adjusting the padding value can have drastic results and in many cases favorable results.

SmartLabel Maximum Distance Threshold [New in v5.0]

With the dynamic nature of data it is possible for the chart not to be able to find any room for a label near an element, in which case, the label can end up far away from the parent element. Using the SmartLabel.MaximumDistance property allows control over how far a label can move away from the source element.

  • CS
  • VB
Chart.DefaultElement.SmartLabel.DistanceMaximum = 50;

Chart.DefaultElement.SmartLabel.DistanceMaximum = 50
Sample: SmartLabelDistances.aspx

Label Alignment

Element labels also have several other alignment options available provided by the LabelAlignment enumeration.

Alignment
A label's default alignment is controlled with the SmartLabel.Alignment property.

[C#]

Chart.DefaultElement.SmartLabel.Alignment = LabelAlignment.Top;

[Visual Basic]

Chart.DefaultElement.SmartLabel.Alignment = LabelAlignment.Top

Column Labeling

Secondary Alignment
Since there may not always be enough room to place the label in desired position (Alignment). The chart engine will look at the AlignmentSecondary property which is a collection of LabelAlignment objects and find the next best one that fits. The following code clears the default secondary alignment settings and sets two options labels can use.

[C#]

Chart.DefaultElement.SmartLabel.SecondaryAlignment.Clear();
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.OutsideTop);
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.Bottom);

[Visual Basic]

Chart.DefaultElement.SmartLabel.SecondaryAlignment.Clear()
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.OutsideTop)
Chart.DefaultElement.SmartLabel.SecondaryAlignment.Add(LabelAlignment.Bottom)

Vertical Label
When a label doesn't fit into a column horizontally it will try to fit vertically. If the label is too tall to fit, the label font will decrease in size until it fits. For cases where columns have both horizontal and vertical labels, column labels may be difficult to read. If this is the case, all labels can be forced to show vertically by using this code:

[C#]

Chart.DefaultElement.SmartLabel.ForceVertical = true;

[Visual Basic]

Chart.DefaultElement.SmartLabel.ForceVertical = True
Note: This feature doesn't affect horizontal charts.
Send comments on this topic.


Tokens

Text label strings allow tokens prefixed with a percentage sign to be replaced by actual data when the chart is rendered. This is particularly useful for item level properties such as Label Template, URL and ToolTip where you can mix your own text with tokens. If you wish to have template values rendered on multiple lines you can use \r where you wish a new line to begin.

Manually Evaluate Tokens

Through the use of DataSource objects tokens can be evaluated in code while working with a chart as described in the DataSource tutorial.

Embedding Token Formatting

Format strings may be included in templates using the following syntax:

<[Token],[FormatString]>

Characters such as">" can not be used in the format string.

Example: <%Value,Currency>

Unrecognized template tokens will be replaced with "?". If you see a question mark included, check the spelling of your token.

Bypass Token Processing

An escape character is available to bypass token processing. Using the forward slash '\' before a token will stop the token from being processed. For example, using '\%Name' will result the string '%Name'.

Show All
Hide All

Element Tokens

Describes an Element object. These tokens are generally used by element legend entries, element labels and in annotations.

Values
Token | Description
%Value = %Yvalue | The y value of this element. Depending on the type of data being used, this will be either numeric: Element.YValue or time: Element.YDateTime.
%Xvalue | The x value of this element. Depending on the type of data being used, this will be either numeric: Element.XValue or time: Element.XDateTime.
%YValueStart = %ValueStart | The starting y value of this element. Depending on the type of data being used, this will be either numeric: Element.YValueStart or time: Element.YDateTimeStart.
%XValueStart | The starting x value of this element. Depending on the type of data being used, this will be either numeric: Element.XValueStart or time: Element.XDateTimeStart.
%BubbleSize | The bubble size value of this element (Element.BubbleSize).
%Complete | The complete value of this element (Element.Complete). This value is useful with Gantt charts.
%Close | Financial close value (Element.Close).
%Open | Financial open value (Element.Open).
%High | Financial high value (Element.High).
%Low | Financial low value (Element.Low).
%Volume | Financial volume value (Element.Volume).
%Length | The Element.Length value.
%Height | The Element.Height value.
%SubValueList | A comma delimited list of subvalues.
Ranges
%YRange = %Range = (%YDays ,%Days if time based) | The range of this element (Element.YValue - Element.YValueStart). If the chart is time based the range will be the number of days between Element.YDateTime and Element.YDateTimeStart.
%YMinutes = %Minutes | The number of minutes between Element.YDateTime and Element.YDateTimeStart if applicable.
%YHours = %Hours | The number of hours between Element.YDateTime and Element.YDateTimeStart if applicable.
Calculations
%PercentOfSeries = %YPercentOfSeries | The percentage of the series this element represents. ( Element.YValue )
%PercentOfTotal = %YPercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.YValue )
%PercentOfGroup = %YPercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.YValue )
%XPercentOfSeries | The percentage of the series this element represents. ( Element.XValue )
%XPercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.XValue )
%XPercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.XValue )
%BubbleSizePercentOfSeries | The percentage of the series this element represents. ( Element.BubbleSize )
%BubbleSizePercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.BubbleSize )
%BubbleSizePercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.BubbleSize )
%CompletePercentOfSeries | The percentage of the series this element represents. ( Element.Complete )
%CompletePercentOfTotal | The percentage of all the series on the chart this element represents. ( Element.Complete )
%CompletePercentOfGroup | The percentage of all the elements with the same name this element represents. ( Element.Complete )
%PercentOfSeriesMax | The percentage of the series maximum Y value this element represents. (Element.YValue)
%PercentOfMax | The percentage of the chart data's maximum Y value this element represents. (Element.YValue)
%PercentOfGroupMax | The percentage of the element group's maximum Y value this element represents. (Element.YValue)
Identification
%Name | The name of this element.
%SeriesElementCount | The number of elements in this series.
%SeriesName | The name of the series this element belongs to.
%XAxisName | The name of the x axis this element is charted on.
%YAxisName | The name of the y axis this element is charted on.
%Color | The color used by the element.
%ID | The Element.InstanceID value useful with organizational chart.
%ParentID | The Element.InstanceParentID value useful with organizational chart.

Series Tokens

Describes a Series object. Generally used by legend entries.

Sums/Values
Token | Description
%Sum = %Ysum = %Yvalue = %Value | The sum of all the element's y values. (Element.YValue). If the chart is time based this token is the same as %YDays.
%Xsum = %XValue | The sum of all the element's x values. (Element.XValue). If the chart is time based this token is the same as %XDays.
%BubbleSize = %BubbleSizeSum | The sum of all the element's bubble sizes. (Element.BubbleSize)
%LastYValue | The y value of the last element in the series.
%YValueList | A comma delimited list of element y values.
Ranges
%Range = %YRange (= %Days & =%YDays if applicable) | The sum of all the element's ranges. (Element.YValue - Element.YValueStart). If the chart is time based this token represents the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If the chart is time based this token represents the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If the chart is time based this token represents the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%XMinutes | If the chart is time based this token represents the sum of minutes between each element's Element.XDateTime and Element.XDateTimeStart values.
%XHours | If the chart is time based this token represents the sum of hours between each element's Element.XDateTime and Element.XDateTimeStart values.
%XDays | If the chart is time based this token represents the sum of days between each element's Element.XDateTime and Element.XDateTimeStart values.
%YSpanDays = %SpanDays = %YSpan = %Span | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanMinutes = %SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanHours = %SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%XSpanDays | If the chart is time based this token represents the range of days between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
Calculations
%High = %YHigh | The highest y value of all the elements within this series. (Element.YValue)
%XHigh | The highest x value of all the elements within this series. (Element.XValue)
%Low = %YLow | The lowest y value of all the elements within this series. (Element.YValue)
%XLow | The lowest x value of all the elements within this series. (Element.XValue)
%BubbleHigh | The highest bubble size value of all the elements within this series. (Element.BubbleSize)
%BubbleLow | The lowest bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteHigh | The highest complete value of all the elements within this series. (Element.Complete)
%CompleteLow | The lowest complete value of all the elements within this series. (Element.Complete)
%CloseHigh | The highest financial close value of all the elements within this series. (Element.Close)
%CloseLow | The lowest financial close value of all the elements within this series. (Element.Close)
%Average = %Yaverage = %Mean = %YMean | The average y value of all the elements within this series. (Element.YValue)
%Xaverage = %XMean | The average x value of all the elements within this series. (Element.XValue)
%BubbleSizeAverage = %BubbleSizeMean | The average bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteAverage = %CompleteMean | The average complete value of all the elements within this series. (Element.Complete)
%CloseAverage = %CloseMean | The average financial close value of all the elements within this series. (Element.Close)
%Median = %YMedian | The median y value of all the elements within this series. (Element.YValue)
%XMedian | The median x value of all the elements within this series. (Element.XValue)
%BubbleSizeMedian | The median bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMedian | The median complete value of all the elements within this series. (Element.Complete)
%CloseMedian | The median financial close value of all the elements within this series. (Element.Close)
%Mode = %YMode | The mode y value of all the elements within this series. (Element.YValue)
%XMode | The mode x value of all the elements within this series. (Element.XValue)
%BubbleSizeMode | The mode bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMode | The mode complete value of all the elements within this series. (Element.Complete)
%CloseMode | The mode financial close value of all the elements within this series. (Element.Close)
%PercentageChange = %PercentageYChange | The percentage change the Y value between the first and last element.
Identification
%Name | The name of this series.
%ElementCount | The number of elements in this series.
%YAxisName | The name of the y axis this series is charted on.
%XAxisName | The name of the x axis this series is charted on.
%Color | The series default element color.

SeriesCollection Tokens

Describes a SeriesCollection object. Generally used in title box labels and chart area labels.

Sums/Values
Token | Description
%Sum = %Ysum = %Yvalue = %Value | The sum of all the element's y values. (Element.YValue). If the chart is time based this token is the same as %YDays.
%Xsum = %XValue | The sum of all the element's x values. (Element.XValue). If the chart is time based this token is the same as %XDays.
%BubbleSize = %BubbleSizeSum | The sum of all the element's bubble sizes. (Element.BubbleSize)
%YSeriesSumList | A comma delimited list of of each series y value sum.
%YGroupSumList | A comma delimited list of y value sums for each element group.
%ColorList | A comma delimited list of colors used by the series in the collection.
Ranges
%Range = %YRange (= %Days & =%YDays if applicable) | The sum of all the element's ranges. (Element.YValue - Element.YValueStart). If the chart is time based this token represents the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If the chart is time based this token represents the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If the chart is time based this token represents the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%XMinutes | If the chart is time based this token represents the sum of minutes between each element's Element.XDateTime and Element.XDateTimeStart values.
%XHours | If the chart is time based this token represents the sum of hours between each element's Element.XDateTime and Element.XDateTimeStart values.
%XDays | If the chart is time based this token represents the sum of days between each element's Element.XDateTime and Element.XDateTimeStart values.
%YSpanDays = %SpanDays = %YSpan = %Span | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanMinutes = %SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%YSpanHours = %SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%XSpanDays | If the chart is time based this token represents the range of days between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
%XSpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.XDateTime and lowest Element.XDateTimeStart value.
Calculations
%High = %YHigh | The highest y value of all the elements within this series. (Element.YValue)
%XHigh | The highest x value of all the elements within this series. (Element.XValue)
%Low = %YLow | The lowest y value of all the elements within this series. (Element.YValue)
%XLow | The lowest x value of all the elements within this series. (Element.XValue)
%BubbleHigh | The highest bubble size value of all the elements within this series. (Element.BubbleSize)
%BubbleLow | The lowest bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteHigh | The highest complete value of all the elements within this series. (Element.Complete)
%CompleteLow | The lowest complete value of all the elements within this series. (Element.Complete)
%CloseHigh | The highest financial close value of all the elements within this series. (Element.Close)
%CloseLow | The lowest financial close value of all the elements within this series. (Element.Close)
%Average = %Yaverage = %Mean = %YMean | The average y value of all the elements within this series. (Element.YValue)
%Xaverage = %XMean | The average x value of all the elements within this series. (Element.XValue)
%BubbleSizeAverage = %BubbleSizeMean | The average bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteAverage = %CompleteMean | The average complete value of all the elements within this series. (Element.Complete)
%CloseAverage = %CloseMean | The average financial close value of all the elements within this series. (Element.Close)
%Median = %YMedian | The median y value of all the elements within this series. (Element.YValue)
%XMedian | The median x value of all the elements within this series. (Element.XValue)
%BubbleSizeMedian | The median bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMedian | The median complete value of all the elements within this series. (Element.Complete)
%CloseMedian | The median financial close value of all the elements within this series. (Element.Close)
%Mode = %YMode | The mode y value of all the elements within this series. (Element.YValue)
%XMode | The mode x value of all the elements within this series. (Element.XValue)
%BubbleSizeMode | The mode bubble size value of all the elements within this series. (Element.BubbleSize)
%CompleteMode | The mode complete value of all the elements within this series. (Element.Complete)
%CloseMode | The mode financial close value of all the elements within this series. (Element.Close)
%MaxValueElementName %MaxYValueElementName | Name of the element with the highest y value (Element.YValue).
%MinValueElementName %MinYValueElementName | Name of the element with the lowest y value (Element.YValue).
%MaxValueElementSeriesName %MaxYValueElementSeriesName | Name of the series that contains the element with the highest y value (Element.YValue).
%MaxValueElementSeriesName %MaxYValueElementSeriesName | Name of the series that contains the element with the lowest y value (Element.YValue).
%MaxValueSeriesName %MaxYValueSeriesName | Name of the series that contains the highest sum of it's element y values.
%MinValueSeriesName %MinYValueSeriesName | Name of the series that contains the lowest sum of it's element y values.

Element Group Tokens

Describes an Element group. Generally used by axis ticks to describe the group they represent.

Calculations
Token | Description
%PercentOfTotal = %YPercentOfTotal | The percent of all the data on the chart this element group represents. (Element.YValue)
%CompletePercentOfTotal | The percent of all the data on the chart this element group represents. (Element.Complete)
%Sum = %YSum = %Yvalue = %Value | The sum of all the elements within this element group. (Element.YValue)
%Average = %Yaverage = %Mean = %YMean | The average of all the elements within this element group. (Element.YValue)
%Median = %YMedian | The median of all the elements within this element group. (Element.YValue)
%Mode = %Ymode | The mode of all the elements within this element group. (Element.YValue)
%CompleteAverage = %CompleteMean | The average of all the elements within this element group. (Element.Complete)
%CompleteMedian | The median of all the elements within this element group. (Element.Complete)
%CompleteMode | The mode of all the elements within this element group. (Element.Complete)
Ranges
%YRange = %Range = (%YDays ,%Days if applicable) | The sum of all the ranges of elements within this group. (Element.YValue - Element.YValueStart) If this chart is time based the token will represent the sum of days between each element's Element.YDateTime and Element.YDateTimeStart values.
%YMinutes = %Minutes | If this chart is time based this token will represent the sum of minutes between each element's Element.YDateTime and Element.YDateTimeStart values.
%YHours = %Hours | If this chart is time based this token will represent the sum of hours between each element's Element.YDateTime and Element.YDateTimeStart values.
%Span = %SpanDays | If the chart is time based this token represents the range of days between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%SpanMinutes | If the chart is time based this token represents the range of minutes between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
%SpanHours | If the chart is time based this token represents the range of hours between the element's highest Element.YDateTime and lowest Element.YDateTimeStart value.
Identification
%Name | The name of the elements in this group.

Axis Marker Tokens

Describes an AxisMarker object. Generally used by the axis marker label and it's legend entry.

Values
Token | Description
%Low | The low value of this axis marker
%High | The high value of this axis marker.
%Range | The range of this marker.
%Minutes | If the marker is a time range this token will represent the minutes between the high and low time values.
%Hours | If the marker is a time range this token will represent the hours between the high and low time values.
%Days | If the marker is a time range this token will represent the days between the high and low time values.
Identification
%Name | The name of this axis marker.

ScaleRange Tokens

Describes a ScaleRange object. These tokens can be used with Axis.Label to describe the axis range.

Values
Token | Description
%Low | The low value of this axis marker
%High | The high value of this axis marker.
%Range | The range of this marker.
%Minutes | If the marker is a time range this token will represent the minutes between the high and low time values.
%Hours | If the marker is a time range this token will represent the hours between the high and low time values.
%Days | If the marker is a time range this token will represent the days between the high and low time values.
%ValueName | If the scale range refers to a category scale numeric values refer to the index of each category. This token evaluates to category name whereas the Low/High tokens are numeric.

AxisTick Tokens

Axis ticks use different tokens depending on the situation.

  • If the axis tick comes from an element (Element.X/YAxisTick) then use Element Tokens.
  • If the axis tick is part of a category axis it use either Element Group or Series Tokens.
  • If the axis tick is part of a value axis use the token '%Value' and if it's a range tick, ScaleRange Tokens apply.
  • If the axis tick is part of an axis marker, use ScaleRange Tokens.

ChartArea Tokens

The chart area tokens are only supported by the Navigator. They are evaluated in real-time based on the mouse cursor position over the chart area.
Values
Token | Description
%Yvalue | The value of the Y axis at the current mouse position.
%Xvalue | The value of the X axis at the current mouse position.
Show Mapping.Shape Tokens

Shapefile shapes store attributes which are determined by the source shapefile. These attributes can be used as tokens in any labels related to shapes.

Syntax: %[AttributeName]

See also: Chart Labels

Send comments on this topic.


Formatting Values

Formatting Basics

Axes host the main format settings for themselves and related values on a chart. This means the the Y axis format string setting will affect the element's y value format in a string. The axis properties associated with formatting are Axis.FormatString and Axis.CultureName.

FormatString

The FormatString property uses the .net string format specifications to parse values.

For more information on using format strings see:

  • Standard Numeric Format Strings
  • Custom Numeric Format Strings
  • Standard DateTime Format Strings
  • Custom DateTime Format Strings
  • Formatting types

Tip: Another way to specify currency formatting within the labels text is to use: "$ <%Value,###,###.##>"

Additional shortcuts and custom format strings are also available:

Shortcuts
• 'Currency'
Formats numeric values based on the currency of the machines current or specified culture.
• 'N:x'
 Shorthand format where 'x' specifies the number of decimal places for numeric values. i.e: 'N:2'

Custom Format Strings
• 'Q'
 With dates, 'q' will represent the quarter. For example: "Quarter: <%Value,q>"

• 'O' (Numeric Values)
 An ordinal number. Adds a suffix to numbers for example: 1st 2nd 3rd etc.

• 'O' (DateTime Values)
 Day as an ordinal number. 1st 2nd 3rd etc.

[C#]

Chart.DefaultAxis.FormatString = "Currency";

[Visual Basic]
Chart.DefaultAxis.FormatString = "Currency"

Sample Settings:
{n:0}
Result: 140 (Number)

d
Result: 1/2/2005 (Date)

CultureName

The CultureName property accepts names from this list . It is used to automatically determine the type of formatting used for numbers or dates by the specified culture and format values accordingly.

[C#]

Chart.DefaultDefaultAxis.CultureName = "en-US";

[Visual Basic]

Chart.DefaultDefaultAxis.CultureName = "en-US"
Note: By default, the server's culture setting is used.

Element Value Formats

Element values on a chart are formatted based on the format settings of the axis related to the value used. This means that an element's YValue format will be based on the y axis and XValue based on the x axis format.

Assuming we have a chart where the x axis is time and y axis is numeric, the following code would properly format the element values.

[C#]

Chart.XAxis.FormatString = "d"; // A date format
Chart.YAxis.FormatString = "{n:0}"; // A numeric format

[Visual Basic]

Chart.XAxis.FormatString = "d" ' A date format
Chart.YAxis.FormatString = "{n:0}" ' A numeric format

Whenever an element or series value is used with multiple x or y axes, the format will be determined by the parent series axis.

Tips

  • Format settings are generally not required; .netCHARTING can automatically determine a suitable format for your data.
See Also
{Formatting Advanced}
Send comments on this topic.


Formatting Advanced

Advanced Formatting

DataEngine
When the data engine generates elements to be used in conjunction with category x axes* the element x values, despite being numeric or time based, are placed in the element.Name property as strings. To specify a format used in this process DataEngine.FormatString and DataEngine.CultureName are used.

* As opposed to a true numeric or time axis scales, category axes show elements by their name.

Note: To bypass using element names and use the actual x values you can specify "XValue=__" in the dataEngine's DataFields property instead of "XAxis=___";

Embedded in Tokens

This section demonstrates how to use different formatting in labels so they dont use the axis format.

All values shown in a chart are based on a label template string which uses tokens that specify which element value to show. For example a regular combo chart shows y values for each element and this can be specified using the following code:

Elements show values when Chart.DefaultSeries.DefaultElement.ShowValue = true
[C#]

Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "%YValue";

[Visual Basic]

Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "%YValue"

To imbed format strings within the element's label template, the following syntax is used:
<Token,Format>

Example element templates:

Template Text | Result
<%YValue,Currency> | $500.00
(<%YValue,Currency>, <%XValue,d>) | ($500.00, 11/18/2004)

Example: The following code will specify a currency format for the default element label template.

[C#]
Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "<%YValue,Currency>";

[Visual Basic]
Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "<%YValue,Currency>"

This will format the labels on the chartArea as currency but not in other places like the legend box.

For a complete list of possible tokens see: Tokens

For a reference of how to access different label on a chart see Using Labels

Advanced Axis Formatting

The axis also provides some additional settings that influence the axis format.

Percent
Setting Axis.Percent = true will format axis tick labels as percentages (in addition to snapping the scales maximum value to 100%)

Decimal Places

A shortcut for setting the number of decimals for axis formats is to specify it with the Axis.NumberPrecision property.

Format strings that specify decimal spaces override this setting.
[C#]

Chart.YAxis.NumberPrecision = 2;

[Visual Basic]

Chart.YAxis.NumberPrecision = 2
Send comments on this topic.


Label Layout Markup

Introduction

.netCHARTING labels are capable of embedding font styling, images, dynamic streaming charts, and layout information by specifying it within the label text using tags. The syntax for these features is simple and easy to follow; however, it offers flexibility that can be used to create rich, data-driven labels something closer to an HTML page rather than GDI strings. It is also capable of making parts of a label clickable and display tooltips. The layout features enable creating a grid configuration to organize the label text.

This markup syntax can also be using with hotspot tooltips to generate rich tooltip layouts such as this:

Quick Examples

This section features a few examples and the code to create them to give a general idea of how the system works.

Code | Result
Label.Text = "Example <block fColor='red'>text<block> styling." |
Label.Text = "Example <block fColor='blue' fStyle='Italic'>text styling." |
Label.Text = "Example <block bgColor='green'>text<block> styling." |

The Language

There are 4 tags that can be used to control label styling and layout. This is a quick overview but these tags will be discussed in more detail.

Tag Name | Description
<block> | This tag is used to identify blocks of text and specify text styling. A block tag indicates that following text will be inside that block until a new block or a row tag is detected. Parameters define the block style. A list of available parameters is shown in the Font Styling section below.
<row> | The row tag is similar to a new line. It indicates that all blocks that follow should render underneath the previous blocks.
<hr> (new in v5.2) | The same as a row tag except a horizontal rule is drawn in its place.
<br> | The break tag '<br>' makes text go to the next line inside a block. If a label does not specify any blocks or rows, it is considered to be in a single block. When this is the case, the break and row tags act like a newline character.
<img> | This tag is used to embed images and streaming dynamic charts from other aspx pages.

Escape Character
In order to use the literal '<block>' text or any other tag as text inside a label, an escape character must be used. For example '\<block>', or '\\<block>' in c# will render as '<block>'.

Block Behavior & Styling Text

All text can be thought of as being inside of a block. In order to format a section of a string, a <block> tag with parameters must be used to specify the styling. The block tag does not require a terminating block tag, the block and the formatting is used until the next block or row tag is detected.

Code | Result
Label.Text = "Test string to demonstrate .netCHARTING markup features." |
Label.Text = "Test string to demonstrate <block fStyle='bold'>.netCHARTING<block> markup features." |

The above example rendering is accomplished by separating the string into 3 individual blocks and handle them individually with different styles. Because these three blocks are side by side, if this string needs to wrap due to width constraints, the behavior will be different; the text will wrap individually inside each block. The following table demonstrates this difference.

String wrapping without formatting

 String wrapping with formatting.

Note: The red lines are only shown to demonstrate the block positions.

This system will not allow embedded formatting with the original wrapping behavior, however, this is a tradeoff that offers a number of advantages that can be quite useful. The benefit is virtual table support; By specifying blocks and rows, a grid configuration can be achieved.

Code Result

Label.Text = "Test string <block>to demonstrate <row><block fStyle='bold'>.netCHARTING<block> markup features."

This results in a 2x2 cell layout. Notice that the top two blocks are lined up with the bottom ones. When the block count is the same for each row, the label will automatically try to align the blocks whenever possible.

Label.Text = "1<block>2<row>3<block>4";
A block is implied at the start of the string or row so it doesnt have to be specified unless needed to style the block with parameters.
Label.Text = "1<block>2<row>3<block>4<block>5";

Note: The red lines are only shown to demonstrate the block positions.

Using a <br> break.

A break tag can be used inside a block as a new line character for the section of text inside the block. If the string does not specify any blocks, it is considered to be in a single block, in which case, the br tag serves as a new line character.

Code | Result
Label.Text = "This is a<br>single block<block>The second block<row>A third block spanning both blocks above." |
Label.Text = "<block hAlign='right'>Name:<br>Age:<br>Sales:<block>%Name<br>%Age<br>%YValue" |
Note: The red lines are only shown to demonstrate the block positions.

Embedded Images

When an image is embedded inside a string, it behaves like a block with a static size. Because it implicitly creates a block, it will change the wrapping behavior. For example, the following sample shows how text behaves next to an image and also demonstrates the difference between a break and row tag.

Code | Result
Label.Text = "<img:cd.png>Text next to<br> an image. |
Label.Text = "<img:cd.png>Text next to<row> an image. |

Embedded chart images

A dynamic chart can be streamed directly into a label if it resides in an aspx page and has Chart.UseFile = false set.

The syntax for this type of image is the same:

<img:page.aspx>

Tokens can be used to pass information to the page rendering the chart as well.

<img:page.aspx?Series=%SeriesName>

The following sample passes the element value to a page that generates a small thermometer based on that value.

Sample: EmbeddedLegendCharts.aspx

Tokens can be placed inside of the image tag as well as the block ToolTip and URL parameters, however, the '<' and '>' characters cannot be used inside the parameters with tokens.

Font Styling

The block tag allows a number of parameter settings that define the formatting.

Parameter Name | Acceptable values | Description
hAlign, hAlignment | Left, Center, Right | Horizontal alignment of text within a block.
vAlign, vAlignment | Bottom, Center, Top | Vertical alignment of text within a block.
FontName, fName | Font Name | Name of the font to use for the text.
FontSize, fSize | size as number. | Font size
FontStyle, fStyle | Bold, Regular, Italic, Underline, Strikeout | Font style
FontColor, fColor | Red, #FFFAEA, ... | Font color
bgColor, back | Red, #FFFAEA, ... | Block background fill color
GlowColor, Glow | Red, #FFFAEA, ... | Font glow color
OutlineColor, Outline | Red, #FFFAEA, ... | Font outline color
Digital | Yes, No | Digital Font
ToolTip | Any text | ToolTip for the block.
Url | Any URL | URL for the block.

Sample: LabelEmbeddedFontStyling.aspx demonstrates using these format styles.

Send comments on this topic.


InfoGrids

Introduction

InfoGrids™ produce results similar to data grid controls; however, they are created and drawn within the chart image itself. As a result, an InfoGrid™ can be styled to produce a significantly more polished and integrated grid that users can take with them, along with that chart, in a single image file. This is made possible by using .netCHARTING's advanced label layout and styling markup features. The markup provides a quick and simple way of creating aesthetically pleasing grids from your data. By utilizing data aggregation and date grouping features of the DataEngine, .netCHARTING provides a complete solution for advanced dashboard development. MicroCharts can be added to InfoGrids™ to provide a clear visual representation of your data or alert users of situations requiring attention. Every label on a chart supports these advanced features, which enables seamlessly integrated charts with a level of detail that was previously not possible. In addition, every chart tooltip can interpret these tags as well. While InfoGrid™ labels are primarily used to describe chart elements and objects, a chart showing only an infoGrid™ is also possible. The property (Chart.ObjectChart) can be used with a Label or Annotation object to generate a chart image comprised of only the label, whether it's a complex matrix of information or a simple text string. This feature will also dynamically size the resulting image based on the output label or infoGrid size.

Markup Tags review

To create InfoGrids™ with .netCHARTING markup only two tags are necessary. A block tag and a row tag. A block tag which indicates a new block or that the text following it will be inside that block until a new block or a row tag is detected. A row tag just goes to the next line or row of blocks. The only requirement is that each row contains the same number of blocks. This signals the label parser to lay them out as a grid.

Q: What constitutes a block?

A: Any text is automatically inside of a block. MicroCharts and embedded images are blocks and blocks can be explicitly defined by using additional <block> tags.

InfoGrid™ Construction Techniques

Creating an InfoGrid™ consists of making a string of text that defines the information and markup tags. The process can be simple:

  • Define a row of header blocks
  • Iterate data adding additional rows of data making sure the block counts in each row are constant.

Take this InfoGrid for example:

It is a 3x4 block grid. To define the header row, the following is used:

string gridText = "<block><block fStyle='Bold'>Today<block fStyle='Bold'>Trend<HR>";

Note: <HR> is the same as <row> except it draws a horizontal line across the label.

This defines 3 blocks and that the text should be bold.

Tip: When defining more complex rows it can be helpful to make an additional string containing the header block tag like so:

string hBlockStyle = "<block fStyle='Bold'>"
string gridText = hBlockStyle + hBlockStyle + "Today" + hBlockStyle + "Trend<HR>";

Doing this allows less typing and easy modification of block styles later on.

Subsequent rows can be defined with:

gridText += "Server 1<block hAlign='Center'>50<Chart:Marker type='Triangle' Color='Green'>";

Alternating color fill

An infoGrid can highlight every other row for easier reading by using a background color in blocks of every other row using code like:

  • CS
  • VB
for(int i = 0; i < rows; i++)
{
    string bg = "";
    if (((i & 1) != 0)) bg = " bgColor='LightGray'";
    sb += "<block " + bg + ">Block Text";
}

For i As Integer = 0 To rows - 1
    Dim bg As String = ""
    If ((i And 1) <> 0) Then
       bg = " bgColor='LightGray'"
    End If
    sb &= "<block " & bg & ">Block Text"
Next i
  • CS
  • VB
A demonstration of this usage can be seen in sample LegendInfoGrid2

Spacer Row

An extra row at the beginning of any grid can be utilized to define widths of each column. A spacer microChart type can be used to achieve this using code like:

string gridText = "<Chart:Spacer width='20'><Chart:Spacer width='30'><Chart:Spacer width='30'> '";

NOTE: The default size of a spacer is 1x1

InfoGrids™, MicroCharts, and the DataEngine

The DataEngine provides a plethora of features that load database data and perform operations such as data aggregation and calculation based date grouping that would otherwise require a great deal of effort. InfoGrids can take advantage of this to display the processed info by building the grid from series and seriesCollections returned by the DataEngine. The series object also includes a method [Series.GetYValueList()] that returns a comma delimited list of y values it contains so that they can be easily used within microChart tags. It is similar to using the %YValueList series token with MicroCharts used in chart labels.

Sample: Dashboards And InfoGrids/InfoGridMulti utilizes the Series.GetYValueList method.

ObjectChart & NoDataLabel

The Chart.ObjectChart property can take a Label or Annotation and when used, it becomes the chart almost like its own chart type. The difference in behavior between this chart type and others, is that with ObjectChart, the resulting image conforms to the size of the label. This sizing can be adjusted by using the Chart.Margin properties. To specify a static size for the resulting image, Chart.NoDataLabel can be used instead. Then the resulting image will be that defined by the chart size/width/height properties. If Chart.ObjectChart is used and the chart series collection is populated with data, SeriesCollection token will be processed for the text set for the label or annotation.

  • CS
  • VB
Chart.ObjectChart = new Label("<Chart:Bar value='10' max='15'>");

Chart.ObjectChart = new Label("<Chart:Bar value='10' max='15'>")

A more complicated arrangement using multiple infoGrids on one chart image can also be achieved by using multiple annotations. In these cases, the annotation positions and chart sizes must be specified explicitly which is not as dynamic of a scenario but it does add the advantage of box styling provided by the annotation.

Sample: InfoGridMulti.aspx demonstrates this multiple InfoGrid usage and styling options.

InfoGrids™ in Charts

IntoGrids can be used with charts to give more detail by displaying the values of the charted elements. This can be achieved in a number of ways. One way is to increase one side of a chart's margin to make room for an annotation and then add the annotation specifying the position and size to fill the empty area. The other and simpler way is to use the legendBox to hold the grid. This is done by using the header label and hiding the series legend entries so only the header has content. This method has the advantage of automatically sizing and fitting both the chart and InfoGrid on the chart.

The LegendInfoGrid* samples demonstrate the latter usage.

These samples utilize the main chart legend box, however, the original legend box does not have to be removed. A new legend box can be created for this purpose as well.

Axis Tick InfoGrids™

The sample GanttDependencies2 shown on the right uses infoGrid techniques to create a table like grid for each gantt task or element. This is possible through the use of the spacer described above. Each axis tick label is assigned with text containing two rows. One row is the spacer string like the above, and the next contains the text describing the element. An additional annotation using the same spacer string is created and absolutely positioned above the axis labels as a header.

Send comments on this topic.


Chart Surface Objects

This section is contains a collection of tutorials describing the functionality and manipulation of objects that appear on a chart image such as a legend box or chart area.

  • Multiple Chart Areas
    How to use and manipulate multiple chart areas on a single image.
  • ChartArea Zooming
    Demonstrates zooming a cross section of a chart area.
  • Box Tutorial
    Basic box and box header features. Box is the base object of annotations, legend boxes and title boxes.
  • Legend Tutorial
    How to use basic legend features.
    • Advanced
      Advanced legend features.
  • Data Sources
    Data sources used for label tokens and populating custom legend boxes.

Send comments on this topic.


Multiple Chart Areas

The Concept

Multiple ChartAreas are a 'smart' feature, hence, the concept here is to have the chart engine do the thinking for you. All you have to do is create some series, specify which axes you want them to use, and which chart areas the series should be placed in. Then the chart engine will take over and lay out the chart areas based on the axis relationships between your series. The 'Layout' section will demonstrate this smart behavior.

Another approach is to specify the axes for chart areas instead of series, in which case the series will acquire the axes of the chart areas they are placed in.

Main / Default Chart Area

Every chart starts with the main chart area. It is referenced through Chart.ChartArea. Properties such as Chart.TitleBox and Chart.LegendBox refer to this area’s title and legend boxes so using Chart.ChartArea.TitleBox and Chart.ChartArea.LegendBox will have the same effect as the two previous properties. They are there simply as shortcuts. There is also a default chart area [Chart.DefaultChartArea]. Even though it is the same object as the main area, it is not used in the same manner. This object provides a vehicle for properties that will propagate to all other chart areas on a chart image automatically. If you would like to set a standard background color of all the chart areas quickly, you would set it through DefaultChartArea.

Adding Areas

Adding chart areas is simple. One must be instantiated and then added to the chart’s ExtraChartAreas collection.

[C#]

ChartArea ca1 = new ChartArea();
Chart.ExtraChartAreas.Add(ca1);

[Visual Basic]

Dim ca1 As New ChartArea()
Chart.ExtraChartAreas.Add(ca1)

This of course will give you an empty chart area. To make use of it, it will also need data to display.

[C#]

ca1.SeriesCollection.Add(mySeries);

[Visual Basic]

ca1.SeriesCollection.Add(mySeries)

At this point you may end up with a chart that looks like this.

Sizing

These 2 charts will be laid out vertically for reasons we’ll get to in a moment. At this stage you can control the layout by specifying what percentage of the full height a particular chart area should occupy. We’ll set the second area’s height to 20%.

[C#]

ca1.HeightPercentage = 20;

[Visual Basic]

ca1.HeightPercentage = 20

This will draw the second chart area at 20% and the main chart area at 80% height.

If there were three or more areas the other two would equally divide up the remaining space.

Sample: ChartAreaSizing.aspx

Axis Relationships

This may be the most complex concept initially but it builds on top of series-axis relationships which you may already be familiar with.

Each new chart area you add will not automatically have x and y axis instances. These axes will be provided by the series added to chart areas and since by default all series use the main x and y axis pair, all areas will share the same x and y axis pair. In the 'Adding Areas' section above you can clearly see that the x axis is shared and so it the y axis, however, it is drawn twice and even though it's the same axis, by default the scale will not remain the same. On the other hand, if the same axis is drawn once across multiple areas like the x axis in the above example then obviously the scale will remain the same.

To preserve the axis scale when it is redrawn, you must set the Axis.SynchronizeScale.PreserveScale property to true.

[C#]

Chart.YAxis.SynchronizeScale.PreserveScale = true;

[Visual Basic]

Chart.YAxis.SynchronizeScale.PreserveScale = True

One way to visualize the axis sharing concept is to pretend the two series are in a single combo chart area, you then make a carbon copy of the chart and erase one of the series from each area.

Setting a property for a new chart area's axis will instantiate a new axis for the area.

So doing:
myChartArea.YAxis.Label.Text = "New Axis";

will create a new axis for myChartArea and the series within it will inherit this new y axis unless they have axes specified already.

Simple enough right?

Layout

If we take the example above but assign a new x axis, the chart areas will be positioned horizontally.

[C#]

ca1.XAxis = new Axis();

[Visual Basic]

ca1.XAxis = New Axis()

This happens because .netCHARTING automatically tries to position chart areas based on axis relationships. In the first example both x and y axes were the same but only the x axis was drawn once across both areas. Because the axis cant be in two places at the same time, it is redrawn. The decision of which axes to draw only once was based on the setting:

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.VerticalPriority;

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.VerticalPriority

This is the default behavior. If we prefer the areas use the y axis across both areas instead of x and without assigning a new axis to the chart area, the following setting can be used:

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.HorizontalPriority;

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.HorizontalPriority

Now that we’re getting the hang of using chart areas and positioning them, let’s further explore this functionality .

Say we want two Y axes on three chart areas. Area A will contain a single series with one y axis, area b, a series with the other y axis and area c will contain two series, each with one of the y axes.

Something like this:

Area A:
Series1.YAxis = YAxisOne
Area B:
Series2.YAxis = YAxisTwo
Area C:
Series3.YAxis = YAxisOne
Series4.YAxis = YAxisTwo

The Code:

[C#]

SeriesCollection mySC = [….];
Axis a1 = new Axis();
Axis a2 = new Axis();

a1.DefaultTick.GridLine.Color = Color.Orange;
a1.Orientation = Orientation.Right;
a2.DefaultTick.GridLine.Color = Color.Green;
ChartArea ca1 = new ChartArea();
ChartArea ca2 = new ChartArea();
ca1.SeriesCollection.Add(mySC[0]);
ca2.SeriesCollection.Add(mySC[2], mySC[3]);

Chart.SeriesCollection.Add(mySC[1]);

mySC[0].YAxis = a1;
mySC[1].YAxis = a2;
mySC[2].YAxis = a1;
mySC[3].YAxis = a2;

[Visual Basic]

Dim mySC As [….] ' Some series collection
Dim a1 As New Axis()
Dim a2 As New Axis()

a1.DefaultTick.GridLine.Color = Color.Orange
a1.Orientation = Orientation.Right
a2.DefaultTick.GridLine.Color = Color.Green
Dim ca1 As New ChartArea()
Dim ca2 As New ChartArea()
ca1.SeriesCollection.Add(mySC(0))
ca2.SeriesCollection.Add(mySC(2), mySC(3))

Chart.SeriesCollection.Add(mySC(1))

mySC[0].YAxis = a1
mySC[1].YAxis = a
mySC[2].YAxis = a1
mySC[3].YAxis = a2
Sample: ChartAreaRelationships.aspx
Quick Note: The axis with orange grid lines was oriented on the right. If it were oriented to the left it would be placed on the left most area that uses it.
The y axes were given different grid line colors to illustrate where they are used. As you can see, the chart areas automatically placed the area that contains both axes in the middle so that no axis relationships are broken. This powerful feature can arrange areas in the best possible order no matter how complex your web of axis relationships get.

The logic behind the mechanism is as follows: Using HorizontalPriority, a group of charts is put together based on their y axis relationships and placed on the first row. Then another group of y axis related areas is placed in the next row, however, they are re-arranged to maintain the maximum x axis relationships between chart areas. So while horizontal relationships are the priority, smart logic is also involved in vertical axis relationships.

Let's go a step further, say we want another chart area with an x axis that is shared with the x axis of the middle area. We will do this by adding the area, instantiating a new x axis for it and setting the same x axis for the existing middle chart area (ca2). We could also assign the new x axis to both the series in the middle area but this way is quicker and achieves the same result.
[C#]
ChartArea ca3 = new ChartArea();
ca3.SeriesCollection.Add(mySC[4]);
ca3.XAxis = new Axis();
ca2.XAxis = ca3.XAxis;
[Visual Basic]
ChartArea ca3 = new ChartArea();
ca3.SeriesCollection.Add(mySC[4]);
ca3.XAxis = new Axis();
ca2.XAxis = ca3.XAxis;
Output:

As you can see, the areas are laid out correctly based on the axis relationships we specified.

Other modes include:

  • HorizontalSmart
  • VerticalSmart

These are similar to their ‘priority’ counterparts. The layout logic is still in use; however, all areas will be placed in a single row or column respectively.

The last mode, Custom, provides full control of chart area positioning.

[C#]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.Custom;
ChartArea.GridPosition = new Point(0,0);
ChartArea2.GridPosition = new Point(0,1);

[Visual Basic]

Chart.ChartAreaLayout.Mode = ChartAreaLayoutMode.Custom;
ChartArea.GridPosition = new Point(0,0)
ChartArea2.GridPosition = new Point(0,1)

Sample: ChartAreaCustomLayout.aspx

This system is a new concept in the charting world. To get the most out of try not to focus on the chart area layout but on the data you're charting and the chart engine will do the rest. If you stumble upon an ingenious way of using this system please let us know. We would love to hear about it and share your achievements with the masses.

Personal Legend boxes

See: LegendBox Advanced Tutorial

Send comments on this topic.


ChartArea Zooming

Introduction
Chart Area Zooming is a new 4.0 feature which allows a portion of a chart to be expanded into a secondary chart area which looks like the following:

Usage
This works by specifying a value range of a particular axis on the main chart area. Passing this information to the ChartArea.GetZoomAreaY() or GetZoomAreaX() methods will return a new chart area which doesn't need to be modified. When added to the Chart.ExtraChartAreas collection it will result in a chart area similar to the above.

[C#]

ChartArea ca = Chart.ChartArea.GetXZoomChartArea(Chart.XAxis, new ScaleRange(new DateTime(2005,1,1),new DateTime(2006,1,1)),
  new Line(Color.LightGreen,DashStyle.Dash));
Chart.ExtraChartAreas.Add(ca);

[Visual Basic]

Dim ca As ChartArea = Chart.ChartArea.GetXZoomChartArea(Chart.XAxis, New ScaleRange(New DateTime(2005, 1, 1), New DateTime(2006, 1, 1)),
  New Line(Color.LightGreen, DashStyle.Dash))
Chart.ExtraChartAreas.Add(ca)

This feature can be used in conjunction with the Axis Value Coordinates feature to allow the user to specify the range to zoom.

Samples

  • YAxisZoom.aspx
  • XAxisZoom.aspx
See Also
{Axis Value Coordinates}
Send comments on this topic.


Box Tutorial

Default Box

A Box object is the foundation (base class) of box like objects such as annotations, legendBoxes, and title boxes. The chart control has a DefaultBox property that is a container for box properties that will be propagated to all other objects on the chart that derive from Box including annotations, legends, and title boxes. The default box corner related settings will also propagate to the chart areas.

Example: This code will make all box shadows red.

[C#]

Chart.DefaultBox.Shadow.Color = Red;

[Visual Basic]

Chart.DefaultBox.Shadow.Color = Red

Styling

Box styling consists of a background, the outline (Line), corner types, headers, and shadows.

Background

A box'es background is accessed through its Background property, which contains properties that effect the background's visual appearance:

Box.Background.__ = __

Example: The following code sample changes the box'es background color to red.

[C#]
Box.Background.Color = Color.Red;

[Visual Basic]
Box.Background.Color = Color.Red

See the Background class for more information.

See sample: BoxStyling.aspx

Shadow

The shadow a box casts can also be modified. Options include color, depth, and whether the shadow is solid or soft, meaning, the edges are blurred for added realism.

[C#]

Box.Shadow.Color = Color.Orange;

[Visual Basic]

Box.Shadow.Color = Color.Orange

Outline

A Line object is used to draw the outline of a box. This enables you to specify many visual properties such as line width, color, and dash style.

Example: Changes the outline dash style.

[C#]

Box.Outline.DashStyle = DashStyle.Dash;

[Visual Basic]

Box.Outline.DashStyle = DashStyle.Dash

See also: Line Class, Chart Lines

Corners

Each of the four corners of a box can be individually styled. This code demonstrates how to specify a rounded top left corner.

[C#]

Box.CornerTopLeft = BoxCorner.Round;

[Visual Basic]

Box.CornerTopLeft = BoxCorner.Round

All four corners can be automatically set using the DefaultCorner property. This will also change the property value of each individual corner.

[C#]

Box.DefaultCorner = BoxCorner.Cut;

[Visual Basic]

Box.DefaultCorner = BoxCorner.Cut

Corner Size
The corner size can also be specified through the Box.CornerSize property. It is given in pixels.

A legendbox corner size it is limited to 0-8 unless the legendbox padding is set to a higher value that will prevent text clipping. Other boxes that use a setting higher than 8 will automatically add padding to fit text inside it.
Tip: Today's styling trends dictate that using a unique corner on opposite ends of a box while keeping the adjacent corners intact is visually pleasing. For Example TopLeft:Cut and BottomRight: Cut while TopRight and BottomLeft setting is: Square.

Padding

The padding property specifies the distance form the box edges to it's content similar to HTML cell padding. The legendBox, which inherits from Box also uses the padding property to determine spacing between legend entries.

[C#]

Box.Padding = 5;

[Visual Basic]

Box.Padding = 5
Note: Custom corners do not effect a box'es padding, hence, additional padding may be required when content is to close to a styled corner like BoxCorner.Cut.

Box Headers

Box headers is a new feature in version 4.4. It allows a header label and background style on top of any box such as TileBox, LegendBox, or Annotation. The header is activated simply by specifying a Box.HeaderLabel.Text string. If there is no text available, the header is not visible. The following example adds a header to the legend box with a different background.

  • CS
  • VB
Chart.LegendBox.HeaderLabel.Text = "Legend Box";
Chart.LegendBox.HeaderBackground.Color = Color.Green;

Chart.LegendBox.HeaderLabel.Text = "Legend Box"
Chart.LegendBox.HeaderBackground.Color = Color.Green

See Sample: Features: BoxHeaders.aspx

Box Header Styling

Version 6.1 introduces a much more advanced header feature set. It provides an API that enables styling headers to emulate many different visualizations. Box.Header is now its own object containing all the header related properties.

Header Cap Styles

The header left and right sides can be styled to change their shape. The header object contains two properties; StartCap, and EndCap which refers to the left and right sides, respectively. Both properties can use any style specified and will render the header accordingly. There are currently 13 box cap styles available allowing 169 different combinations. The styles are described by the BoxCapStyle enumeration, and the code below shows how they can be set.

  • CS
  • VB
Box.Header.StartCap = BoxCapStyle.Triangle;
Box.Header.EndCap = BoxCapStyle.Triangle;

Box.Header.StartCap = BoxCapStyle.Triangle
Box.Header.EndCap = BoxCapStyle.Triangle

BoxCapStyles illustrated.
Fig. 1a

Ribbon Caps

Ribbon caps can be set with BoxCapStyle.RibbonUp/RibbonDown options.

Ribbon caps behavior is slightly more complex as the ends must extend to the back of the parent box. Ribbons may alter their angles in order to reach the back of the parent box.

The ribbons can render differently depending on the header positions. Figure 1b shows headers with the same RibbonDown settings. The banner extens outside the left and right sides while the tab does not and the resulting rendering is different.

If the ribbon setting is not applicable, it will be omitted. For example when the header is above the box and RibbonUp is set, the ribbon cannot reach the parent box moving up so no cap will be rendered.

RibbonDown cap style
Fig. 1b

Vertical Alignment

Header boxes can be positioned vertically in relation to the parent box edge. The EdgeAlignment enumeration specifies this positioning with Inside/Outside/Edge. Figure 1-3 demonstrates the positions when used with the Box.Header.VerticalAlignment property.

  • CS
  • VB
Box1.Header.VerticalAlignment = EdgeAlignment.Inside;
Box2.Header.VerticalAlignment = EdgeAlignment.Edge;
Box3.Header.VerticalAlignment = EdgeAlignment.Outside;

Box1.Header.VerticalAlignment = EdgeAlignment.Inside
Box2.Header.VerticalAlignment = EdgeAlignment.Edge
Box3.Header.VerticalAlignment = EdgeAlignment.Outside

Header.VerticalAlignmet = EdgeAlignment.
Inside Edge Outside

Horizontal Alignment

The header object has two properties; StartAlignment, and EndAlignment. They dictate how the left and right sides of the header are aligned to the parent box and header label, but they do not affect the label alignment to the parent box.

Box.Header.Label.Alignment
The label alignment will dictate the label's position across the entire parent box regardless of any header start and end alignments settings. The label positions are shown below in Figure 4.

  • CS
  • VB
Box.Header.Label.Alignment = StringAlignment.Near;

Box.Header.Label.Alignment = StringAlignment.Near

Fig. 4
Header label StringAlignment
options illustrated.

Box.Header.StartAlignment/EndAlignment
The Header.StartAlignment and Header.EndAlignment properties use the same EdgeAlignmentenumeration as Header.VerticalAlignment property, and they behave similarily. Outside and Edge options will align based on the parent box edge. Inside alignment will align at the label alignment or box edge. The Inside setting also considers if the box sides have a cap. When a header label is aligned to the box edge with a cap, it might offset the label position so both cap and label can be within the parent box bounds. The figures below show what these settings do when used with Header.StartAlignment. The behavior is the same with Header.EndAlignment.

EdgeAlignment.Outside - The header box will extend past the parent box edge by the pixel amount specified with Box.CornerSize.

EdgeAlignment.Edge - The header box will line up with the parent box edge. If specified, a the base of a cap is aligned with the parent box and is rendered just outside the box as shown in figure 7.

Edge Notes

  • In order to have the cap tip touch the box edge, the label must be aligned to that edge and startAlignment = Inside. (See figure 7)
  • When the vertical alignment is Edge and the parent box has corners, the header will be offset by CornerSize as shown in Figure 2.

EdgeAlignment.Inside - When the label is not aligned to this edge, the header side will align with the label. When the label is aligned with this side, and the side has a cap style, the label is pushed in so the header and cap can be rendered inside the box. (See figure 7)

Header Cap Placement

When using BoxCapStyle.Box, no cap is used. With other styles, a cap is drawn outside of the original box. So Box capped headers will be a bit smaller than others. The width of the caps is half the height of the header label. (See Figure 1a)

  • CS
  • VB
Box.Header.StartAlignment = EdgeAlignment.Outside;

Box.Header.StartAlignment = EdgeAlignment.Outside

StartAlignment with a
centered header label.
Fig. 5

StartAlignment with a left
justified header label.
Fig.6

StartAlignment with
a start cap.
Fig. 7

Header Orientation

The property Box.Header.Orientation controls the orientation of the header in relation its parent box. Figure 9 shows how the header is oriented depending on the different orientation settings. All the other alignment settings will behave the same regardless of the orientation. The bottom orientation however orients vertically so it can be read so some settings may change to achieve the same visual. For example cap styles such as RibbonDown will have to change to RibbonUp with Orientation.Bottom. Corner orientations such as TopRight are not supported at this time.

Different behavior when
default settings are used.
Fig. 9

Integrated Header

When both sides of the header are aligned to Edge, and both sides use the Box cap style, the header will integrate with the parent box as the middle box in figure 8 does. These are the default settings.

When integrated, the header.Line is not used to draw an outline. Instead, the parent box outlines the header and content together. Box.InteriorLine is used to draw a divider line between the header and content.

Different behavior when
default settings are used.
Fig. 8

Other settings

Header.Line
This line object is used to draw an outline of the header box shape.

Header.Offset
This property takes a Point object and uses it to offset the header position from the original placement. It is a simple yet powerful feature that can be used to make small visual adjustments to achieve the exact look that is needed.

Header.Shadow
The header shadow defines properties of the shadow cast beneath it.

To create a header visual that appears to be floating above the parent box, try using offset and shadow together.
(See floating visual below).

Visualizations

The header can emulate a number of different visuals such as banners, tabs, pointers and so on. This image shows some examples of these:

Uses

This header styling can be utilized in many scenarios to improve aesthetics of charts and to make elements more visually intuitive.

  • Element Annotations (enhance callout)
  • Arbitrary Annotation / Legend Header Styling

See Also

API Reference

BoxHeaderOptions Class
BoxCapStyle Enumeration
EdgeAlignment Enumeration
Box Class
Send comments on this topic.


LegendBox Tutorial Basic

Styling

Before proceeding, see the Box tutorial for basic styling options.

Fonts:
A legend entry's font can be defined by specifying a default font for all entries.

[C#]
Chart.LegendBox.DefaultEntry.LabelStyle.Font = new Font("Verdana",8);

[Visual Basic]
Chart.LegendBox.DefaultEntry.LabelStyle.Font = New Font("Verdana",8)

See also: Using Fonts

Colors:
Font colors can also be specified in a similar manner:

[C#]
Chart.LegendBox.DefaultEntry.LabelStyle.Color = Color.Black;

[Visual Basic]
Chart.LegendBox.DefaultEntry.LabelStyle.Color = Color.Black

See also: Using Colors

Template

The default columns of a legend are Name, Value, and Icon. They are represented in the Template property as tokens. The Template property allows reordering,exclusion of any particular column, or additional tokens that represent the same as the legend entries such as "%ElementCount".

Example: The following code reorders legend columns.

[C#]
Chart.LegendBox.Template = "%Icon%Value%Name";

[Visual Basic]
Chart.LegendBox.Template = "%Icon%Value%Name"

Example: The following code excludes the icon column.

[C#]

Chart.LegendBox.Template = "%Value%Name";
[Visual Basic]
Chart.LegendBox.Template = "%Value%Name"

Example: The following code inserts additional columns.

[C#]

Chart.LegendBox.Template = "%Value%Name%Icon%ElementCount%Average";
[Visual Basic]
Chart.LegendBox.Template = "%Value%Name%Icon%ElementCount%Average"

Text Alignment

The columns can be either icons or text. When text is used, it can be aligned either to the right or left. These alignment settings can be specified by using an array of StringAlignment enumerations that correspond to the above template tokens (IconValueName) respectively.

Example: The following code specifies the alignment of three columns in a legend box.

[C#]

Chart.LegendBox.ColumnAlignments = new StringAlignment[]{StringAlignment.Far, StringAlignment.Center, StringAlignment.Far};
[Visual Basic]
Chart.LegendBox.ColumnAlignments = New StringAlignment(){StringAlignment.Far, StringAlignment.Center, StringAlignment.Far}

Positioning

Orientation
To position a legend box, the LegendBox.Position or LegendBox.Orientation properties must be defined.

[C#]

LegendBox.Orientation = Orientation.BottomLeft;
[Visual Basic]
LegendBox.Orientation = Orientation.BottomLeft

The position property is an object type and accepts a legacy LegendBoxPosition enumeration or a Point object, which specifies the absolute position in pixels.

    Tip:Using LegendBoxPosition is not recommended because Orientation has more options.

[C#]

LegendBox.Position = LegendBoxPosition.Bottom;

[Visual Basic]

LegendBox.Position = LegendBoxPosition.Bottom

Illustration of legend box positions and corresponding properties.

Absolute Position

Using a Point object will specify an absolute position. Other elements on a chart will not be affected by the position and the legend will overlap objects beneath it.

[C#]

LegendBox.Position = new Point(200,20);

[Visual Basic]

LegendBox.Position = New Point(200,20)

Absolute Position with Size

The legendbox absolute position can also be specified with a size in addition to the point. This is accomplished by using a Rectangle object.

[C#]

LegendBox.Position = new Rectangle(new Point(200,20),new Size(100,100));

[Visual Basic]

LegendBox.Position = New Rectangle(New Point(200, 20), New Size(100, 100))

    Tip: When using an absolute position, it is useful to set a transparency for the box'es background color so underlying objects can still be seen if necessary.

Specifying a LegendBox size

The legendbox.Position property can also take a Size object by itself. In this case, the position of the legendbox is not affected but the size specified is a static size and will not change. It will force the legend entries in the legendbox to display in the best possible way provided there is enough room for them.

[C#]

LegendBox.Position = new Size(100,100);

[Visual Basic]

LegendBox.Position = New Size(100, 100)

In Title box

Another useful option is to completely eliminate the legend box and move the entries into the title box. To accomplish this, a title box position FullWithLegend is used.

[C#]
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;

[Visual Basic]
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend

            Note: The entries in a title box are positioned opposite to the alignment of the title (TitleBox.Label.Alignment). If the title is right-aligned the entries will position themselves on the left side of the title box.

Invisible Legend

To completely eliminate the legend from a chart set the Visibility of the legend to false.

[C#]
Chart.LegendBox.Visible = false;

[Visual Basic]
Chart.LegendBox.Visible = False

Legend Entries

Manipulating the content

Entries in the legend are for most cases generated to represent each series. However, if a Series.Palette or PaletteName is specified, each element in that series will automatically insert its entry into the legend. Legend entries specific to each series and element can be accessed through their parent object. For example, an element's legend entry is accessed through:

myElement.LegendEntry.__ = __

AxisMarker objects used with axes or elements are also automatically inserted into the legend and their entries are accessed through:

myAxisMarker.LegendEntry.__ = __

To prevent an axis marker from entering into the legend, the entry's visibility can be turned off:

[C#]

myAxisMarker.LegendEntry.Visible = false;
[Visual Basic]
myAxisMarker.LegendEntry.Visible = False

To exclude the all series entries from a legend box the following code can be used:

[C#]

Chart.DefaultSeries.LegendEntry.Visible = false;

[Visual Basic]
Chart.DefaultSeries.LegendEntry.Visible = False

Custom Entries

Custom entries can be added to the legend by instantiating and adding them to the ExtraEntries property of a LegendBox.

[C#]

LegendEntry myEntry = new LegendEntry();
myEntry.Name = "CustomName";
myEntry.Value = "CustomValue;
Chart.LegendBox.ExtraEntries.Add(myEntry);

[Visual Basic]

Dim myEntry As New LegendEntry()
myEntry.Name = "CustomName"
myEntry.Value = "CustomValue
Chart.LegendBox.ExtraEntries.Add(myEntry)

Header Entry

Each legend has a ready made header entry. These are used to describe the columns of your legend. The header entry is activated by setting the Visible property.

[C#]

LegendBox.HeaderEntry.Visible = true;

[Visual Basic]

LegendBox.HeaderEntry.Visible = true

Header text can be modified with the traditional text properties.

LegendBox.HeaderEntry.Name = "Series Name";

To change the icon text a custom attribute must be used

[C#]

LegendBox.HeaderEntry.CustomAttributes = "Icon=Icon Header";

[Visual Basic]

LegendBox.HeaderEntry.CustomAttributes.Add("Icon","Icon Header")

            Attributes will be covered further in the advanced tutorial.

    More Tips:

    Using your own entries.

    • In some cases, it is required to use your own custom entries instead of the default ones. The best way to accomplish this is to set Chart.DefaultSeries.LegendEntry.Visible = false; and add your entries as shown above.

    • Moving entries to the title box may save valuable space when there are few series and chart sizes are small.

The features covered in this tutorial are the most common but only scratch the capability surface of LegendBox objects.

For more advanced features go on to the advanced tutorial.

See Also

{LegendBox Advanced}

{Box Tutorial}

Send comments on this topic.


LegendBox Advanced

Introduction

The .netCHARTING legend box is more than just a list of icon-name pairs. It is equipped with template functionality that can detail your data in a grid style form and offers many options that will allow you to modify the box as much as you need.

Legend Positions & Layout

The legend can be positioned in three different ways. It can be placed anywhere around the chart plot areas, inside the title box along with the chart title, and it can be positioned at a specified x,y or absolute position.

Around the plot chart areas
The traditional way to position the boxes used this syntax

[C#]

Chart.LegendBox.Position = LegendBoxPosition.Top;

[Visual Basic]

Chart.LegendBox.Position = LegendBoxPosition.Top

This would specify the box is placed in the upper right corner around the plot area. A more flexible setting is also available, the equivalent of the above is:

[C#]

Chart.LegendBox.Orientation = Orientation.TopRight;

[Visual Basic]

Chart.LegendBox.Orientation = Orientation.TopRight

Orientation exposes all corners and sides available for positioning.

Absolute Positioning

The legend can be placed at any specified x,y position using the same LegendBox.Position property.

[C#]

Chart.LegendBox.Position = new Position(20,20);

[Visual Basic]

Chart.LegendBox.Position = New Position(20,20)

When this method is used, the other object on the chart will not move away to make room for the legend box, however, it may be desirable to place the legend within a ChartArea in some circumstances.

Sample: LegendBoxAbsolute.aspx

In the title box

A legend can be placed in the title of a chart area by specifying to the title box that it should display the legend within it.

[C#]

Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;

[Visual Basic]

Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend

When the legend entries are shown in the title box further positioning features are available. By specifying the title alignment, the legend entries will position themselves to compliment the new title’s layout.

[C#]

Chart.TitleBox.Label.Alignment = StringAlignment.Center;

[Visual Basic]

Chart.TitleBox.Label.Alignment = StringAlignment.Center

The above line will center the title in response, the legend entries will center beneath it.

NOTE: When a legend is shown in the title box, its properties are still controlled through the LegendBox object.
Sample: LegendBoxTitle.aspx

Layout Behavior
When a legend box is located on the left or right side of a chart the default layout will yield a single column legend if it fits. With multiple legends on one side they will be stacked. This means that if a single column configuration will not fit vertically, the legends will try to increase the number of columns to fit all the entries.

Legends positioned on top and bottom will by default create multiple columns to allow the maximum vertical space for a chart.

In either arrangement, entries will list top to bottom. This behavior can be changed by setting LegendBox.ListTopToBottom to false. This setting will list the entries left to right across columns.

Multiple Chart Areas and Legends

Main Chart Area
Every extra chart area has its own legend box (ChartArea.LegendBox) , however, it is not visible by default. When this is the case the chart area’s series entries are placed in the main chart legend box (Chart.LegendBox). In Figure 1, chart areas B and D send series to the main legend box. This is the default behavior.

Figure 1: Illustrates how series of a particular chart area bind to legend boxes and the default legend box settings.

Personal Chart Area Legends
A chart area can place its series in a personal legend box by instantiating a legendBox object and specifying it to the chart area's LegendBox property (Figure 1: Chart Area C). A Chart area can also place its series legend entries into the title box by setting its title box's position to TitleBoxPosition.FullWithLegend (Figure 1: Chart Area A).

[C#]

ChartAreaA.TitleBox.Position = TitleBoxPosition.FullWithLegend;

[Visual Basic]

ChartAreaA.TitleBox.Position = TitleBoxPosition.FullWithLegend
Sample: LegendBoxMultiple.aspx

Custom Legend Boxes
Custom legend box instances can also be added to the Chart.ExtraLegendBoxes collection. Custom entries can be added and data sources specified to populate your custom boxes.

[C#]

Chart.ExtraLegendBoxes.Add(new LegendBox());

[Visual Basic]

Chart.ExtraLegendBoxes.Add(New LegendBox())
Sample: LegendBoxCustom.aspx

Default Legend Box
The default legend box (Chart.DefaultLegendBox) does not appear anywhere on the chart image but is used to quickly specify settings all boxes appearing on chart will acquire. (Figure 1: Custom LegendBox)

The Legend Box

Legend Template

The LegendBox.Template property takes a series of tokens which define the columns of each entry. These tokens can be tokens specific to the object the entry represents or properties of the legend entry (Name, Value, and Icon).

Consider the following code.

[C#]
SeriesA.DefaultElement.CustomAttributes.Add("SeriesDescription","Data Provided by Group A.");

Chart.LegendBox.DefaultEntry.CustomAttributes.Add("EntryCustom","(Max: /%Maximum Min: /%Minimum)");

Chart.LegendBox.Template = "%Name%Icon%Value%EntryCustom%SeriesDescription%YAverage";

[Visual Basic]
SeriesA.DefaultElement.CustomAttributes.Add("SeriesDescription","Data Provided by Group A.")
Chart.LegendBox.DefaultEntry.CustomAttributes.Add("EntryCustom","(Max: %Maximum %Min: %Minimum)")
Chart.LegendBox.Template = "%Name%Icon%Value%EntryCustom%SeriesDescription%YAverage"

We add a custom attribute to a series which we want to end up in the chart’s legend box. Next we add a custom attribute named “EntryCustom” to the legend’s default entry which will propagate it to all the entries in the legend. Finally, we specify a series of tokens for the legend columns.

The following Table shows the path of each column value when the legend is rendered.

LegendBox. Template | %Name | %Icon | %Value | %EntryCustom | %SeriesDescription | %YAverage
LegendEntry source | LE.Name | LE.Marker | LE.Value | LE.CustomAttributes ("EntryCustom") | Because these tokens don't apply to any legend entry source they will be passed down to the data source.
LegendEntry value/result | %Name | LE.Marker | %YSum | (Max: %Maximum Min: %Minimum)
Series source | Series.Name | (Settings contribute to final legend entry marker) | Series Calculation | Series Calculation | Series.DefaultElement. CustomAttributes ("SeriesDescription") | Series Calculation
Final Result | Group A | LE.Marker | 503 | (Max: 40 Min: 2) | Data Provided by Group A. | 34

Table 1: Describes the path of tokens specified in LegendBox.Template

  1. First the legend box column template is examined.
  2. Next it looks at a particular legend entry for matches. The token values our legend entry can provide are %Name %Icon %Value and %custom where custom is the name of an entry’s custom attribute. We added this in the second line of the above sample.
  3. Finally the series or another object the entry represents is examined for column token matches. In this case %YAverage is a token associated with all series and %SeriesDescription a custom series attribute we added in the code above.
  4. Note: LegendBox.Template can only accept tokens. Other text and characters will be ignored.

Sample: LegendBoxCustom.aspx

The Legend Entry

Default Entry
The legend box contains a default legend entry LegendBox.DefaultEntry property. The setting of this entry will propagate to all entries that end up in the legend box. The exception is when a setting is explicitly set for any given entry, in that case the default entry setting will be ignored.

Custom Entries ( ExtraEntries )
Custom legend entries can be created and added to any legend. These may serve as headers or additional info you need to specify.

Custom Attributes
Legend entries contain a collection of custom attributes which can be used to specify further tokens to use with custom legend box column tokens. Or in a case of custom entries in a box with series entries , because the entry doesn't represent a series, custom attributes can fill in the blanks. For example (“%YSum”,”n/a”).

Sample: LegendBoxCustom.aspx

Header specific features
Legend entries are also designed to serve as headers. To add a header to a legend box let's start with creating an entry and specify the header text. The legend sample in "The Legend" section will be the assumed legend we're working with.

[C#]

LegendEntry leHeader = new LegendEntry();
leHeader.Name = “Name”;
leHeader.Value = “Sum”;

[Visual Basic]

Dim leHeader As New LegendEntry()
leHeader.Name = “Name”
leHeader.Value = “Sum”

To specify labels for all the other column tokens they must be added to custom attributes.

[C#]
Le.CustomAttributes.Add(“%EntryCustom”,” Data Range”);
Le.CustomAttributes.Add(“%SeriesDescription”,” Description”);
Le.CustomAttributes.Add(“%YAverage”,”Average”);

[Visual Basic]
Le.CustomAttributes.Add(“%EntryCustom”,” Data Range”)
Le.CustomAttributes.Add(“%SeriesDescription”,” Description”)
Le.CustomAttributes.Add(“%YAverage”,”Average”)

We will also want to use text instead of the entry’s marker for the icon column. This can be achieved by specifying the following custom attribute:

[C#]

Le.CustomAttribute(“%Icon”,”Icon”);

[Visual Basic]

Le.CustomAttribute(“%Icon”,”Icon”)

SortOrder
The header column should be at the top of the legend. This can be done by specifying a sort order for the header entry and all other entries.

[C#]

Le.SortOrder = 0;
LegendBox.DefaultEntry.SortOrder = 1;

[Visual Basic]

Le.SortOrder = 0
LegendBox.DefaultEntry.SortOrder = 1

This will ensure the header entry with the sort order of 0 will appear before all other entries which have the sort order value of 1.

Header Mode
Another way to ensure the header appears at the top is to specify the RepeatOnEachColumn header mode.

[C#]

Le.HeaderMode = LegendEntryHeaderMode.RepeatOnEachColumn;

[Visual Basic]

Le.HeaderMode = LegendEntryHeaderMode.RepeatOnEachColumn

As the name suggests, if the legend splits into multiple columns, this entry will be repeated at the top of each.

Another useful mode is StartNewColumn, when headers are used to group entries in a multi column legend. This mode will allow each group to be placed in separate columns. Such a configuration may make the legend easier to read.

The default mode of all entries is None and doesn’t change the entry behavior.

Divider Line
Up to this point our header doesn’t stand out in any way to indicate it is one. One way to emphasize it is by specifying a DividerLine color.

[C#]
Le.DividerLine.Color = Color.Black;

[Visual Basic]
Le.DividerLine.Color = Color.Black

This line will be drawn beneath the header entry. An extra layer of padding will be added to separate the entry and the next entry evenly from this line.

Top Padding
Single column legends that contain multiple entry groups with headers should use additional padding above each header. This will improve the visual separation of each group.

[C#]

Le.TopPadding = 5;

[Visual Basic]

Le.TopPadding = 5

The following section will demonstrate more options that may improve your headers.

Sample: LegendBoxHeader.aspx

Styling
The header features section describes several styling features. Here we expand on this and tie up some loose ends.

The most fundamental legend entry styling customization is found in the LegendEntry.LabelStyle property. It allows you to set the font, its size, style and color. All entries can be affected by setting the LegendBox.DefaultEntry.LabelStyle property or each individual entry can be customized separately..

[C#]

Le.LabelStyle.Font  = new Font("Verdana",9);
Le.LabelStyle.Color = Color.Green;

[Visual Basic]

Le.LabelStyle.Font  = New Font("Verdana",9)
Le.LabelStyle.Color = Color.Green

Padding
The Box object which LegendBox inherits from contains a padding property. Legend boxes use this property to space entries.

Icon
A legend entry’s icon can be manipulated by a number of its properties. These include

  • Use3D
  • SeriesType
  • ShapeType
  • Marker
  • DashStyle
  • Background

These properties specify the kind of chart element the entry icon is representing. For example, setting SeriesType.Marker gives full control of the icon to the LegendEntry.Marker property.

Now an image can be used instead of the pre defined markers.

NOTE: When an image marker is drawn in the legend its size will be limited to twice the height of the entry’s font height. If larger, it will be scaled down. Alternatively a Marker.Size value can be specified.

Populating Legends with Entries Automatically

See: DataSource Tutorial

Tips & Tricks

  • Entry as a spacer
    An empty entry may be used to separate groups of header entries.
  • Divider Line Style
    Specifying a divider line with a subtle color for the default entry can create a cool effect by dividing each entry. Lowering the padding can bring the entries closer together which may look even better.
  • Control columns
    By adding entries with HeaderMode.StartNewColumn the columns can be controlled.
Send comments on this topic.


Data Sources

Introduction

The DataSource class behaves like a container for chart objects such as Series, AxisMarkers and others to provide dynamic information needed to parse tokens or populate a legend box with entries. The type of data stored in the data source will determine what type of tokens will be replaced in a string.

The class does not relate to database or any other types data sources used to populate charts.

  • Supported DataSource Types

    • Element
    • Element Group ( Elements grouped by name )
    • Series
    • SeriesCollection
    • AxisMarker
    • ScaleRange

Creating DataSources

Creating a DataSource
The following code instantiates a data source containing a series collection.

[C#]
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection);

[Visual Basic]
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection)

The DataSource class also provides implicit casts that alleviate the need to instantiate a DataSource object.

[C#]

LegendEntry.DataSource = mySeriesCollection;
This feature is not supported in VB.Net

Sample: AnnotationDataSource.aspx

Datasources can also be acquired by getting them from a series or series collection like so:

[C#]
DataSource ds = mySeriesCollection.GetDataSource();

[Visual Basic]
Dim ds AS mySeriesCollection.GetDataSource()

Complex DataSources
A DataSource object can contain additional information to properly parse tokens. This information specifies the relationships of SeriesCollections to Series and to Element objects. Specifically, what element is in which series and what SeriesCollection contains that Series. For example, to specify an element with relationships to it's parents, the following code can be used:

[C#]

LegendEntry.DataSource = DataSource.FromElement(mySeriesCollection,1,2);

[Visual Basic]

LegendEntry.DataSource = DataSource.FromElement(mySeriesCollection,1,2)

The parameters of this static constructor are: (Parent SeriesCollection, parent series index in the SeriesCollection, element Index in Series)

The specific reason the token parser may use additional information about an element is so that tokens such as '%PercentOfSeries' can be correctly calculated based on the values of the complete series. If these tokens are not needed a much simpler way to specify an element is by using the implicit cast functionality of DataSource. Simply put, to just specify the element itself (C# Only):

[C#]

LegendEntry.DataSource = myElement;

In VB.Net you can specify the element using a static constructor

[Visual Basic]
LegendEntry.DataSource = DataSource.FromElement(myElement);

Using DataSources

Evaluating Tokens

A datasource object can be used to evaluate tokens manually as shown in this snippet:

[C#]
DataSource ds = mySeries.GetDataSource();
string result = ds.EvaluateExpression("Name:%Name, Sum:%Sum");

[Visual Basic]
Dim ds AS mySeries.GetDataSource()
Dim result AS string
result = ds.EvaluateExpression("Name:%Name, Sum:%Sum")

                    Sample: DataSourceExpressions.aspx

Populating LegendBoxes

The DataSource class can also quickly populate a legend with entries by setting the LegendBox.DataSource property.

Example: This code will populate the legend entry with series entries in a SeriseCollection.

[C#]

LegendBox.DataSource = mySeriesColleciton.GetDataSource();
// or
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection);

[Visual Basic]

LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection)

There is however more flexibility available. The type of legend entries generated can also be specified. The series collection can be split into legend entries for each series, each element, or each element group. This option is defined by the DataSource.SplitInto property.

[C#]

LegendBox.DataSource = mySeriesColleciton.GetDataSource();
LegendBox.DataSoruce.SplitInto = DataSourceType.ElementGroup;

// Or it can be specified in the static constructor:
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection,DataSourceType.ElementGroup);

[Visual Basic]
LegendBox.DataSource = mySeriesColleciton.GetDataSource()
LegendBox.DataSoruce.SplitInto = DataSourceType.ElementGroup

' Or it can be specified in the static constructor:
LegendEntry.DataSource = DataSource.FromSeriesCollection(mySeriesCollection,DataSourceType.ElementGroup)

This functionality will enable you to show different and valuable information about your data in the same chart.

This table shows what splits are available for each data source type.

  Hide This table shows what splits are available for each data source type.

SeriesCollection

  • Series
    •

  • Element Groups
    •

  • Elements
    •

Series

  • Elements
    •

Element Group

  • Series
    •

  • Elements
    •

Element

  • None
    •

Axis Marker

  • None
    •

Scale Range

  • None
    •

                Sample: LegendBoxDataSource.aspx

    LegendEntry DataSource

    Each legend entry can have a data source which is specified through the LegendEntry.DataSource property.

    Annotation DataSource

    Custom annotations can take data sources to process tokens in their labels.

                            Sample: AnnotationDataSource.aspx

Send comments on this topic.


Axis Tutorials

This section is contains a collection of tutorials describing functionality and the many features of axes.

  • Axis Scales
    How different scales behave and how to manipulate them.
    • Scale Synchronization
      How axes can synchronize scales with other axes.
    • Elements & Axis Scales
      How element values determine axis scales.
    • Advanced (Z Axis Effect)
      Advanced element layout focusing the the z axis.
  • Axis Ticks
    Using and manipulating axis ticks.
    • Minor Ticks
      Using minor axis ticks.
    • Axis Time Label Automation
      Using smart time label automation features.
    • Calculated Axis Ticks
      Automatically add axis ticks based on a calculated value.
  • Axis Markers
    Using and manipulating axis markers.
  • Multiple Axes
    Working with multiple axes.
    • Calculated Axes
      Using calculated axes to show data in different contexts.
  • Axis Value Coordinates
    Shows how to get the value of an axis at a specific pixel coordinate.
Send comments on this topic.


Axis Scales

Axis Scales

Introduction
This section will describe the following:

  • Scale Types
    What the different axis scales offer.
  • Intervals
    Controlling numeric and time tick intervals.
  • Scale Range
    Controlling the axis scale start, end, and range.
  • Scale Breaks
    Using scale breaks.
  • Scale Influentials
    Allow axis markers and custom axis tick to influence axis scale ranges.

Scale Types

Axis scales dictate more than just the values on an axis. They also specify element behavior such as stacked, or FullStacked. The options for the Scale enumeration include:

  • Normal
  • Range
  • Logarithmic
  • Time
  • Stacked
  • FullStacked
  • LogarithmicStacked

Between numeric and time scales, .netCHARTING will automatically set the appropriate scale so it does not always need to be specified explicitly. Scales such as Stacked or FullStacked only apply to axes on which the element y values are plotted because these are the values that are stacked. For example with a combo chart, the Chart.YAxis would be the one to specify a stacked scale.

Other properties that control the scale include:

  • LogarithmicBase
    specifies the logarithmic base of intervals.
  • Percent
    A '%' sign will be added to the end of tick labels and the axis maximum will snap to 100% if the plotted data's range falls between 50 and 100.
  • InvertScale
    reverses the sequence of a scale.

Intervals

Intervals come in two flavors, numeric, and time. The latter is more complicated so we’ll tackle numeric first.

Controlling the interval is a simple concept. You can specify a numeric interval using code such as:

[C#]

Chart.YAxis.Interval = 5;

[Visual Basic]

Chart.YAxis.Interval = 5

This will force an interval at every five numeric units. Other interval related properties include:

  • MinimumInterval
    Specifies the minimum numeric interval.
    TIP: This allows you to prevent the axis scale from using intervals that are smaller than a single unit of your data. For example a chart showing votes and the maximum number being 3 may show intervals at .5 which are not desired.
  • TickNumberMaximum
    Specifies the maximum number of ticks to generate.

Time interval

The basic time interval is controlled with the Axis.TimeInterval property

[C#]

Axis.TimeInterval = TimeInterval.Week;

[Visual Basic]

Axis.TimeInterval = TimeInterval.Week

Advanced time interval

A more complex time interval is also available and can be specified through the Axis.TimeIntervalAdvanced property.

Multiplier

Using the advanced time interval version allows you to specify an interval multiplier. For example we can have an interval every 4 days or 2 weeks etc.

[C#]

Axis.TimeIntervalAdvanced.Multiplier = 2;

[Visual Basic]

Axis.TimeIntervalAdvanced.Multiplier = 2

Custom time span

A completely custom time span can be used as a time interval.

[C#]

Axis.TimeIntervalAdvanced.TimeSpan = new TimeSpan(10,5,3);

[Visual Basic]

Axis.TimeIntervalAdvanced.TimeSpan = New TimeSpan(10,5,3)

Custom start time

An interval can also start at any given time. These times can be specified through the following properties:

  • StartMonth
    The month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
  • StartDayOfWeek
    The day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
  • Start
    A DateTime object representing the time instant at which this interval initially occurs. The value of this DateTime structure can be specific down to the millisecond.

Ranges

The scale’s numeric, time, and category axis boundaries can be specified using the Axis.ScaleRange property. New in version 5.0, the scale range can also represent a range on a category axis.

[C#]

Chart.YAxis.ScaleRange.ValueHigh = 100;
Chart.YAxis.ScaleRange.ValueLow = 2;
//Or
Chart.YAxis.ScaleRange.ValueHigh = new DateTime(2000,12,1);
Chart.YAxis.ScaleRange.ValueLow = new DateTime(2000,1,1);

[Visual Basic]

Chart.YAxis.ScaleRange.ValueHigh = 100
Chart.YAxis.ScaleRange.ValueLow = 2
'Or
Chart.YAxis.ScaleRange.ValueHigh = New DateTime(2000,12,1)
Chart.YAxis.ScaleRange.ValueLow = New DateTime(2000,1,1)

Providing a single high or low value without its counterpart is also permitted.

[C#]

YAxis.ScaleRange.ValueLow = 2;

[Visual Basic]

YAxis.ScaleRange.ValueLow = 2;
Note: Numeric intervals start at zero, therefore, if the minimum value doesn’t land on an interval there may be a gap between the scale’s edge and the first axis tick.

Category Axis Scale Ranges

New in version 5.0, the scale range can also represent a category axis range. It can achieved in two ways. The axis tick label text can be used to specify the range. The other way is to use a zero-based indexes to reference the axis ticks. For example, if there are 10 axis ticks they can be referenced using a numeric index of [0-9]. This code demonstrates the two methods.

[C#]

// Using names.
Chart.XAxis.ExtraTicks.Add(new AxisTick("Element 1", "Element 3", "Range"));
// Using indexes.
Chart.XAxis.ExtraTicks.Add(new AxisTick(0, 2, "Range"));

[Visual Basic]

' Using names.
Chart.XAxis.ExtraTicks.Add(New AxisTick("Element 1", "Element 3", "Range"))
' Using indexes.
Chart.XAxis.ExtraTicks.Add(New AxisTick(0, 2, "Range"))

Time Scale Padding

Time scale ranges can be padded with an equal amount of time on either side of the plotted data to produce the final range. This is achieved using Axis.TimePadding.

[C#]

Chart.XAxis.TimePadding = TimeSpan.FromDays(10);

[Visual Basic]

Chart.XAxis.TimePadding = TimeSpan.FromDays(10)

Scale Breaks

Scale breaks are discontinuities in an axis' scale. They are useful in the following scenarios:

  • When there is a large difference between low and high element values.
  • When element value variations are much smaller than the scale range.
  • When specific days of a week should be excluded in the scale, for example, weekends are not needed in financial charts. Scale breaks can work with a calendar pattern in this case.
    Sample: AxisScaleBreakCalendarPattern.aspx

For the first two cases, the chart engine can automatically generate a scale break by setting Axis.SmartScaleBreak to true.

Sample: AxisScaleBreaks.aspx

Scale breaks are added manually like so:

[C#]

Axis.ScaleBreaks.Add( new ScaleRange(0,50) );
//Or for time:
Axis.ScaleBreaks.Add( new ScaleRange(new DateTime(2000,1,1), new DateTime(2000,12,1) ) );

[Visual Basic]

Axis.ScaleBreaks.Add( New ScaleRange(0,50) )
'Or for time:
Axis.ScaleBreaks.Add( New ScaleRange(New DateTime(2000,1,1), New DateTime(2000,12,1) ) )

Sample: AxisScaleBreaksManual.aspx

Scale Break Styles

A number of options are available to achieve the scale break style your charts require. The style can be set with the ScaleBreakStyle enumeration at the axis level as shown below.

[C#]

Chart.YAxis.ScaleBreakStyle = ScaleBreakStyle.ZigZag;

[Visual Basic]

Chart.YAxis.ScaleBreakStyle = ScaleBreakStyle.ZigZag
Sample: AxisScaleBreakStyling.aspx

Scale Influentials
Objects that inherit from ScaleRange, such as AxisMarker and AxisTicks are able to influence the axis’ scale range. For instance, a chart showing bandwidth usage over a period of time with an axis marker representing the bandwidth limit may have elements that will never reach or even come close to the limit marker’s value. Because of this, the limit marker will not be visible on the chart; however, if AxisMarker.IncludeInAxisScale is true, the marker will tell the axis scale range to encompass its value.

Objects that can influence axis scales are:

  • AxisMarker
  • AxisTick
Sample: AxisAffectScale.aspx
Send comments on this topic.


Scale Synchronization

Introduction

Multiple axes of the same type (numeric or time) and orientation (X or Y) can synchronize their scales in a number of ways. They can sync their entire scale, only high or low values, and the origin positions. This is useful if you are using many axes on a single chart that need to sync or different axes throughout chart areas that need to stay on the same scale.

To synchronize two axes, simply specify which axis you want another axis to sync with.

  • CS
  • VB
Chart.YAxis.SynchronizeScale.Add(myNewAxis);

Chart.YAxis.SynchronizeScale.Add(myNewAxis)

You can add as many axes to synchronize as you'd like. By default the entire scale will sync but if you would like to change this behavior you can specify a SynchronizeScaleMode enumeration.

  • CS
  • VB
Chart.YAxis.SynchronizeScale.Mode = SynchronizeScaleMode.High;

Chart.YAxis.SynchronizeScale.Mode = SynchronizeScaleMode.High

This will cause the axes to sync only the high values.

Synchronization Chain

This system also allows for complex sync chains. The above synchronizes the main y axis high value with the high value of myNewAxis. If you would like to synchronize the low value of myNewAxis with another axis you can do this also:

  • CS
  • VB
myNewAxis.SynchronizeScale.Add(myOtherAxis);
myNewAxis.SynchronizeScale.Mode = SynchronizeScaleMode.Low;

myNewAxis.SynchronizeScale.Add(myOtherAxis);
myNewAxis.SynchronizeScale.Mode = SynchronizeScaleMode.Low

This will result in different synchronizations between different axes.

Send comments on this topic.


Axis Ticks

Axis Ticks

Introduction
This section will describe the following:

  • Tick Types
    Different axis tick types.
  • Custom Ticks
    Using custom ticks and placing them at arbitrary positions.
  • String Tokens
    Using tokens in axis ticks to describe elements or tick values.
  • Tick Overrides
    Using ticks to override the properties of a single or multiple ticks.
  • Styling
    Ticks styling.
  • Tick Alignment
    Aligning tick labels with tick marks.

The AxisTick object encapsulates information such as its value, appearance, and grid properties. It can also be used to override a single or range of ticks on an axis.

The Axis.DefaultTick property offers a tick object that will propagate it’s settings to all ticks on the axis. This provides a method of applying settings to all axis ticks quickly.

Another axis tick property is Axis.ZeroTick. This is the axis tick that is added to each numeric axis at its origin (0). This tick can be disabled by setting the property to null.

[C#]

Chart.XAxis.ZeroTick = null;

[Visual Basic]

Chart.XAxis.ZeroTick = Null

Modes
An axis tick can have a single value or two values in which case it will represent a range. Numeric, time, and string ranges can be used.

Normal Axis Ticks

[C#]

AxisTick at = new AxisTick();
At.Value = 10;

[Visual Basic]

Dim at As New AxisTick()
At.Value = 10

Range Ticks

The tick can also represent a numeric or time range.

[C#]

At.ValueHigh = 20;
At.ValueLow = 10;

[Visual Basic]

At.ValueHigh = 20
At.ValueLow = 10

Marker Ticks

Both value and range ticks can be represented by an ElementMarker instead of a label.

[C#]
At.Marker = new ElementMarker(“images/myImage.gif”);

[Visual Basic]
At.Marker = New ElementMarker(“images/myImage.gif”)

Custom / Automatic ticks

The element object contains XAxisTick and YAxisTick properties. These are null by default, however, when instantiated, they will be drawn on the axis the elements belong to and will display the element’s values on the related axis.

Sample: ElementTicks.aspx

The AxisMarker also contains a single AxisTick property. When instantiated, it will represent the marker’s value or range as a range tick, depending on the marker's value.

Sample: AxisMarkerTicks.aspx
AxisTick.IncludeInAxisScale can by used by custom ticks to affect the scale of the axis its added to. See Axis Scale > Scale Influentials above.

Adding Custom Ticks to an axis:

Custom axis ticks can be added to any axis like so:

[C#]

Chart.XAxis.ExtraTicks.Add(At);

[Visual Basic]

Chart.XAxis.ExtraTicks.Add(At)

To quickly add multiple axis ticks you can also list them as parameters in the Add method.

[C#]

Chart.XAxis.ExtraTicks.Add(at1, at2, at3, at4);

[Visual Basic]

Chart.XAxis.ExtraTicks.Add(at1, at2, at3, at4)

Tokens

Tick labels on a category axis can use tokens to display information about element groups they represent. For example the default category tick’s label is “%Name” which will show the element’s name.

Ticks assigned to elements (Element.YAxisTick & Element.XAxisTick) can also use tokens to describe the elements they represent.

Sample: elementTemplate.aspx

Tick labels on a numeric or time axis can also use tokens. A single value tick uses the token '%Value'. A range tick can use either the value token or any tokens related to the ScaleRange object. This functionality is useful with time scales because it allows you to break the time label into multiple lines as the following sample demonstrates:

Sample: AxisTickToken.aspx

See also: Token Reference

Overrides

A tick added to an axis that already contains a tick with the same value will update the old tick properties with its own. For example, if an axis shows a tick at 20 we can override it to display some different text using this code:

[C#]

AxisTick at = new AxisTick();
At.Value = 20;
At.Label.Text = “Twenty”;
XAxis.ExtraTicks.Add(At);

[Visual Basic]

Dim at As New AxisTick()
At.Value = 20
At.Label.Text = “Twenty”
XAxis.ExtraTicks.Add(At)

If a tick at 20 didn’t exist, it would be added as an additional tick.

A tick can also be used to propagate its settings to a range of ticks. Consider a scale from -100 to 100. If we wanted to color all the negative values red we could do so with the following code:

[C#]

AxisTick at = new AxisTick();
At.ValueHigh = -1;
At.ValueLow = -100;
At.Label.Color = Color.Red;
At.OverrideTicks = true;
XAxis.ExtraTicks.Add(At);

[Visual Basic]

Dim at As New AxisTick()
At.ValueHigh = -1
At.ValueLow = -100
At.Label.Color = Color.Red
At.OverrideTicks = True;
XAxis.ExtraTicks.Add(At)
Notice that the AxisTick.OverrideTick setting is required so the axis knows whether override a range of ticks or add a regular range tick.

Styling

The AxisTick object can control its appearance as well as the grid line that stems from it. The TickLine property can also take advantage of the Line.Length and Line.(LineCap related) properties.

Some styling examples:

[C#]
AxisTick at = new AxisTick();

At.Label.Font = new Font(“Verdana”,10);
At.Line.Length = 8;
At.GridLine.DashStyle = Dash;

[Visual Basic]
Dim at As New AxisTick()

At.Label.Font = New Font(“Verdana”,10)
At.Line.Length = 8
At.GridLine.DashStyle = Dash

The axis contains properties that also modify the axis tick appearance.

  • TickLabelMode
    This enumeration allows you to specify the layout behavior of ticks.
  • TickLabelPadding
    A numeric value in pixels that indicates the distance between a tick line and the label.
  • TickLabelSeparatorLine
    Between each tick mark a line can be drawn to accentuate tick label separation. This line is automatically enabled when tick labels decide to wrap.

Tick Alignment
Tick marks can also be drawn between each tick label instead of above it. This is done by setting Axis.CenterTickMarks to false. When this is the case, only Axis.DefaultTick properties are used instead of individual tick line properties because not every tick mark will pertain to a label.

Tip: Centered tick marks are commonly used with category axes [ Group A , Group B, …] and sometimes with time axes [ May, June, … ]
See Also
{Minor Ticks}
{Axis Time Label Automation}
{Axis Calculated Ticks}
Send comments on this topic.


Minor Ticks

Introduction

Minor axis ticks are used to divide scale intervals into smaller logical intervals. This can be done automatically or specified manually.

Smart Minor Ticks (Automatic)

Smart minor ticks will automatically determine a logical minor interval considering the scale's major intervals. For example, a time interval of three months will automatically place a minor tick for every month. To use this feature simply set an axis' SmartMinorTicks property to true.

[C#]

Chart.XAxis.SmartMinorTicks = true;

[Visual Basic]

Chart.XAxis.SmartMinorTicks = True
Sample: AxisSmartMinorTicks.aspx
  • Smart minor ticks are only generated when the interval is determined automatically as opposed to explicitly specified .
  • If smart minor ticks are less than the specified Axis.MinimumInterval, they will not be generated.

Manual Minor Ticks

Minor tick intervals can be controlled through the following axis properties:

  • MinorInterval
    Gets or sets a numeric value that determines the interval of minor axis ticks.
  • MinorTicksPerInterval
    Gets or sets the number of minor axis ticks generated between major axis ticks.
  • MinorTimeIntervalAdvanced
    Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks on a time scale.

Minor Tick Manipulation

While minor ticks don't traditionally have labels or any special styling, in .netCHARTING terms it's just another axis tick. If needed, the minor ticks can have labels, extra long or thick lines etc. All the functionality of an axis tick is available to minor ticks. One difference is that minor ticks will not influence the grid with regards to alternating grid colors of an axis (AlternateGridBackground).

Sample: AxisMinorTicksTrick.aspx
Send comments on this topic.


Axis Time Label Automation

Introduction

This feature is yet another charting innovation brought to you only by .netCHARTING. Axis time label automation is a collection of smart features that accurately describe the time segment shown on a time axis scale. With these user friendly and automatic features, your time based charts will be more intuitive and readable.

How smart is it?

Simply put, quite. This feature is aware of things such as whether your time span crosses into another day, month, or year and will point these things out to the viewer. It is also aware of how specific your data is; meaning, whether it's describing minutes, days, months and so on. This is a complicated task with countless permutations where you may require a behavior other than the default. Fortunately, this feature is also very well equipped with plenty of options that allow meticulous customization.

If this sounds useful for your projects, let's explore the topic a bit further.

Hierarchy & API

There are two separate mechanisms involved with time label automation. One generates single value labels and the other generates range ticks. The behavior of both can be controlled with two properties:

  • Axis.TimeScaleLabels.Mode (Single Value Mechanism)
    Enumeration Members: TimeScaleLabelMode
  • Axis.TimeScaleLabels.RangeMode ( Range Value Mechanism)
    Enumeration Members: TimeScaleLabelRangeMode

Additional options of these features are available through the Axis.TimeScaleLabels property.

Single Value Time Labels

Dynamic Mode

An automatically determined or specified time interval can be used with this mode. This mode will determine what the axis ticks are describing and apply the format strings and axis tick properties that correspond to the time instance of each axis tick. The format strings and axis ticks are found in the TimeScaleLabelInfo class and are covered in depth below.

Let's start with an example. This is a normal time axis without any time automation. Only the time interval is automatically determined:

Now let's see how the automation engine will handle this scale in 'dynamic' mode.

[C#]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Dynamic;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Dynamic

As you can see, the ticks are evaluated and for the most part have been determined to represent months, therefore, they are labeled with the month's name. One of the ticks, however, represents the year and is formatted to show the four digit year.

Smart Mode

The above, 'dynamic mode' uses static formats specified in the TimeScaleLabelInfo class. The smart mode will do the same, however, only if they are specified by the user. Otherwise the formats will be determined automatically based on a number of factors resulting in a detailed and well laid out axis. Considering all the different factors, the smart time automation engine will choose from over 100 formats and templates to produce the most appropriate result.

[C#]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Smart

Hidden Mode

This mode will prevent any single value axis ticks from being shown on the axis. It is useful in conjunction with range labels when they sufficiently describe the time segment and single value ticks are not desired.

[C#]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden;

[Visual Basic]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden

Ranged Time Labels

Default Mode

The default mode does not generate any axis ticks, unless, the time intervals to base those axis ticks on are specified. Adding range time intervals is explained below.

Dynamic Mode

When the TimeScaleLabelRangeMode.Dynamic mode is specified, the time span is analyzed to determine what time intervals should be used to generate ranged axis ticks. The range ticks are then generated based on those intervals. If range time intervals are specified by the user this mode will not generate any extra axis ticks based on automatic time intervals. In effect, it will behave like the Default mode.

Consider the following axis scale:

The chart will be widened below so everything is shown properly.
[C#]

Chart.XAxis.TimeScaleLabels.RangeMode = TimeScaleLabelRangeMode.Dynamic;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.RangeMode = TimeScaleLabelRangeMode.Dynamic

The resulting axis:

Because the axis ticks represent months and span multiple years, range axis ticks were created for both of these units of time.

Sometimes, there may be a large number of range ticks generated which will span multiple rows. Since this may not be desirable, using Axis.TimeScaleLabels.MaximumRangeRows will provide a way to limit the number of rows drawn.

Specifying Range Time Intervals

Time intervals can be added using the Axis.TimeScaleLabels.RangeIntervals property. When added, they are always generated and the dynamically determined time intervals are omitted. This code snippet will also demonstrate using TimeScaleLabelMode.Hidden to hide the single value ticks.

[C#]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden;
Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Month);

[Visual Basic]
Chart.XAxis.TimeScaleLabels.Mode = TimeScaleLabelMode.Hidden
Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Month)

TIP: Multiple range intervals can be added simultaneously using a single line of code:

Chart.XAxis.TimeScaleLabels.RangeIntervals.Add(TimeInterval.Months, TimeInterval.Years)

Custom Styling and Formatting

The time label automation mechanism will describe the time segment accurately, but, it may not describe it exactly as you'd like. This section describes the options available for this customization.

The axis property TimeScaleLabels is an Axis.TimeScaleLabelInfo class. This class contains format strings and axis tick objects that correspond to time units used by these features. Because time automation is based mainly on time instances, the generated labels can be fully controlled through objects you may already be familiar with.

For example, let's consider this is our time scale using dynamic mode:

Format Strings

The labels are long and this is causing them to angle. The day labels don't NEED to spell the whole word out, therefore, the days format string will be modified to only abbreviate the day names using the following code:

[C#]

Chart.XAxis.TimeScaleLabels.DayFormatString = "ddd d";

[Visual Basic]

Chart.XAxis.TimeScaleLabels.DayFormatString = "ddd d"

Label Templates
Now that the labels aren't angled, there is another thing that stands out a bit, or rather, doesn't stand out enough. The February tick can be easily missed and it doesn't tell us what day it is describing. If we change its format to show all this information, this label will be long and cause the labels to angle again. To overt this problem, we will instead manipulate the month's axis tick label to show all the information we need and add a new line character to draw the label on two lines and keep it narrow.

[C#]
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Text = "<%Value,ddd d>\n<%Value,MMMM>";

[Visual Basic]
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Text = "<%Value,ddd d>\n<%Value,MMMM>"

Tip: It may also be useful to use a smaller font to create more room for axis ticks.

Styling

Now the scale looks much better. Still, for those of you who always give 110%, let's go a step further and make those month labels really stand out. As we've seen in the above example, an AxisTick is exposed for each time unit. This gives us complete control over its appearance. This code will modify the month label's font and color.

[C#]

Chart.XAxis.TimeScaleLabels.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Color = Color.DarkBlue;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.MonthTick.Label.Font = New Font("Arial",8,FontStyle.Bold)
Chart.XAxis.TimeScaleLabels.MonthTick.Label.Color = Color.DarkBlue

Range ticks labels can be customized in the same manner. This code modifies the YearTick's font and line color.

[C#]

Chart.XAxis.TimeScaleLabels.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
Chart.XAxis.TimeScaleLabels.YearTick.Line.Color = Color.Blue;

[Visual Basic]

Chart.XAxis.TimeScaleLabels.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold)
Chart.XAxis.TimeScaleLabels.YearTick.Line.Color = Color.Blue

Test your skills

Now that you're a time label automation expert, let's test your skills and see if you can figure out the code used to generate this chart axis:

Answer (code)

[C#]

 Chart.XAxis.FormatString = "d";

 Chart.XAxis.TimeLabelAutomation.RangeIntervals.Add(TimeInterval.Weeks, TimeInterval.Months, TimeInterval.Years);

 Chart.XAxis.TimeLabelAutomation.WeekTick.Label.Text = "Week\n<%Low,dd> - <%High,dd>";

 Chart.XAxis.TimeLabelAutomation.MonthTick.Line.Color = Color.Orange;
 Chart.XAxis.TimeLabelAutomation.YearTick.Line.Color = Color.Green;
 Chart.XAxis.TimeLabelAutomation.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold);
 Chart.XAxis.TimeLabelAutomation.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Italic);

[Visual Basic]

 Chart.XAxis.FormatString = "d"

 Chart.XAxis.TimeLabelAutomation.RangeIntervals.Add(TimeInterval.Weeks, TimeInterval.Months, TimeInterval.Years)
 Chart.XAxis.TimeLabelAutomation.WeekTick.Label.Text = "Week\n<%Low,dd> - <%High,dd>"

 Chart.XAxis.TimeLabelAutomation.MonthTick.Line.Color = Color.Orange
 Chart.XAxis.TimeLabelAutomation.YearTick.Line.Color = Color.Green
 Chart.XAxis.TimeLabelAutomation.YearTick.Label.Font = new Font("Arial",8,FontStyle.Bold)
 Chart.XAxis.TimeLabelAutomation.MonthTick.Label.Font = new Font("Arial",8,FontStyle.Italic)

Send comments on this topic.


Axis Calculated Ticks

Introduction

Previous to version 3.2, to create an axis tick representing a value such as the average of the plotted data, the value had to be calculated, then, an axis tick was manually added to the axis. This process has now been simplified down to one simple line of code.

Calculated Axis Tick

The following code adds a calculated tick to an axis.

[C#]

Chart.YAxis.AddCalculatedTick(Calculation.Average);

[Visual Basic]

Chart.YAxis.AddCalculatedTick(Calculation.Average)

As you can see, this code does not specify any data to perform the calculation on. In this case, the data plotted on the axis is calculated.

Data Specific

A calculation based on only one series of the data shown on an axis is often desired. When this is the case, a single series or any number of series can be specified to base the calculation on.

The following code demonstrates specifying a series:

[C#]

Chart.YAxis.AddCalculatedTick(Calculation.Average, mySeries);

[Visual Basic]

Chart.YAxis.AddCalculatedTick(Calculation.Average, mySeries)
To specify multiple series, place them into a series collection which can be specified as a method parameter.

Using a template

The resulting axis tick will show the calculated value, however, if additional formatting or textual modifications are required, a template can be specified. The '%Value' token in the template will be replaced with the resulting value. The following examples demonstrate template usage.

[C#]

Chart.YAxis.AddCalculatedTick("<%Value,Currency>", Calculation.Average);
Chart.YAxis.AddCalculatedTick("Average: %Value", Calculation.Average);
// Resulting Ticks:
// $123
// Average: 123

[Visual Basic]

Chart.YAxis.AddCalculatedTick("<%Value,Currency>", Calculation.Average)
Chart.YAxis.AddCalculatedTick("Average: %Value", Calculation.Average)
' Resulting Ticks:
' $123
' Average: 123

Calculated Ticks of Shadow Axes

Calculated axis ticks can also be generated for shadow axes. Despite the data not being bound to the actual axis, a shadow axis will base it's calculations on the parent axis' data.

A common task could be to have an original axis show the scale, and a shadow axis on the other side of the chart can show the calculated axis ticks as shown below.

[C#]

Axis axisReplica = Chart.XAxis.Calculate("Replica",true,Orientation.Right);
axisReplica.AddCalculatedTick(Calculation.Average);
Chart.AxisCollection.Add(axisReplica);

[Visual Basic]

Dim axisReplica As Axis = Chart.XAxis.Calculate("Replica",True,Orientation.Right)
axisReplica.AddCalculatedTick(Calculation.Average)
Chart.AxisCollection.Add(axisReplica)

Sample: AxisShadowCalculatedTicks.aspx

Send comments on this topic.


Axis Markers

Introduction

The AxisMarker class can be used to highlight parts of a chart area along an axis. The axis marker can have a single value, a range, or even a CalendarPattern. An axis marker can also be attached to an element in cases where the marker is wanted on a category axis.

Axis markers can also be drawn on top of the chart elements when in 2D mode. This behavior can be specified by setting the AxisMarker.BringToFront property to true.

Single Value AxisMarker

An axis marker can take a number, DateTime, or string value to define it's position. This sample code snippet uses a number and string to insert markers.

[C#]

AxisMarker am1 = new AxisMarker("Marker at 45",new Line(Color.Orange),45);

AxisMarker am2 = new AxisMarker("Text marker at 'Element 0'",new Line(Color.Green),"Element 0");
Chart.XAxis.Markers.Add(am1, am2);

[Visual Basic]

Dim am1 As New AxisMarker("Marker at 45",new Line(Color.Orange),45)

Dim am2 As New AxisMarker("Text marker at 'Element 0'",new Line(Color.Green),"Element 0")
Chart.XAxis.Markers.Add(am1, am2)

Range AxisMarker

Axis markers can also highlight a range on the chart. Even a string range.

String ranges are determined by string comparison where 2 is larger than 12.
[C#]

AxisMarker am3 = new AxisMarker("20-30",new Background(Color.FromArgb(100,Color.LightBlue)),20,30);

AxisMarker am4 = new AxisMarker("'Element 1'-'Element 2'",new Background(Color.FromArgb(100,Color.LightBlue)),"Element 1","Element 2");
am4.Label.LineAlignment = StringAlignment.Near;
Chart.XAxis.Markers.Add(am3, am4);

[Visual Basic]

Dim am3 As New AxisMarker("20-30",New Background(Color.FromArgb(100,Color.LightBlue)),20,30)

Dim am4 As New AxisMarker("'Element 1'-'Element 2'",New Background(Color.FromArgb(100,Color.LightBlue)),"Element 1","Element 2")
am4.Label.LineAlignment = StringAlignment.Near
Chart.XAxis.Markers.Add(am3, am4)

Attached to an element

To attach an axis marker to an element simply instantiate one for the elements in question.

Markers attached to an element only appear on category axes and only if one is available.

[C#]

myElement.AxisMarker = new AxisMarker("Attached to element 3",new Line(Color.Blue),0);

[Visual Basic]

myElement.AxisMarker = New AxisMarker("Attached to element 3",new Line(Color.Blue),0)

AxisMarkerAdvanced.aspx

Calendar Pattern AxisMarker

A calendar pattern can be used to specify sections of time the axis marker is drawn on.

This example highlights the weekdays on a time x axis:

[C#]

CalendarPattern cp = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,"0111110");
cp.AdjustmentUnit = TimeInterval.Day;
AxisMarker am = new AxisMarker("",new Background(Color.FromArgb(100,Color.Orange)),0,0);
am.CalendarPattern = cp;

Chart.XAxis.Markers.Add(am);

[Visual Basic]

Dim cp As New CalendarPattern(TimeInterval.Day,TimeInterval.Week,"0111110")
cp.AdjustmentUnit = TimeInterval.Day
Dim am As New AxisMarker("",New Background(Color.FromArgb(100,Color.Orange)),0,0)
am.CalendarPattern = cp

Chart.XAxis.Markers.Add(am)

See Also: Calendar Pattern Tutorial

Sample: calendarPattern.aspx
Send comments on this topic.


Multiple Axes

Multiple Axes

.netCHARTING employs a straightforward yet effective system to utilize multiple axes. Each series can have it's own x and y axis. By default each series on a chart inherits the main x and y axis

Main Axes

  • Chart.YAxis
  • Chart.XAxis

Axes are defined for series using the following properties:

  • Series.XAxis
  • Series.YAxis

The relationships and identification of axes is maintained by axis object instances. This means instead of specifying an axis name you would specify it by using the axis object itself.

For example, here both series will use the same x axis:

[C#]

Series1.XAxis = new Axis();
Series2.XAxis = Series1.XAxis;

[Visual Basic]

Series1.XAxis = New Axis()
Series2.XAxis = Series1.XAxis

This example will show how two different axes are specified for two series.

[C#]

DataEngine de = new DataEngine();
//(... get data into the engine ...)
SeriesCollection sc = de.GetSeries();
// Let's assume the data engine generated 2 series.
// Specify different axes for each series.
sc[0].XAxis = new Axis();
sc[0].YAxis = new Axis();
sc[1].XAxis = new Axis();
sc[1].YAxis = new Axis();
// Add the series collection to the chart.
Chart.SeriesCollection.Add(sc);

[Visual Basic]

Dim de As New DataEngine()
'(... get data into the engine ...)
Dim sc As SeriesCollection = de.GetSeries()
' Let's assume the data engine generated 2 series.
' Specify different axes for each series.
sc(0).XAxis = New Axis()
sc(0).YAxis = New Axis()
sc(1).XAxis = New Axis()
sc(1).YAxis = New Axis()
' Add the series collection to the chart.
Chart.SeriesCollection.Add(sc)

Samples:

  • RateChart.aspx
  • SeriesAxisBinding.aspx
  • SeriesAxisBindingDB.aspx
  • InvisibleAxis.aspx
See also: Z Axis effect using multiple axes

Send comments on this topic.


Calculated Axes

Introduction

A Calculated axis is a Shadow Axis that mimics another axis that already exists but with a change in behavior.

The different behavioral changes and forms of shadow axes are:

  • Numeric Unit Conversion
  • Time Interval Conversion
  • Custom tick label manipulation delegate method
  • Completely custom replica axis.
Calculated axes do not fill alternating grid areas.

Unit Conversion

.netCHARTING is equipped with calculations for converting between 1092 different units. If you have an axis with a scale that represents some measure, it can be easily converted to another unit. For example feet to inches and so on.

The process for adding a calculated axis is simple:

  • Instantiate a calculated axis by calling the Calculate method of an existing axis.
  • Add it to the Chart.AxisCollection collection.
[C#]

Axis inchAxis = Chart.YAxis.Calculate("Inches",Length.Feet, Length.Inch);
Chart.AxisCollection.Add(inchAxis);

[Visual Basic]

Dim inchAxis As Axis = Chart.YAxis.Calculate("Inches",Length.Feet, Length.Inch)
Chart.AxisCollection.Add(inchAxis)

That is all. The axis will automatically show up on the chart by the original axis.

Do not add axes to AxisCollection that are not calculated axes. See Axis Tutorial > Multiple Axes for information on how additional axes can be used.

There is another feature worth discussing. The new converted unit axis will by default take the parent axis ticks and convert them to the specified unit. The refresh scale option will allow the axis to come up with its own intervals. They will not match the parent axis tick positions exactly but will behave as if it is the original axis. This option is specified in the Calculate method as a parameter and illustrated below.

Sample: interactiveUnitConversion.aspx

Time Interval Conversion

This type of conversion allows the resulting axis to show different time intervals than the original axis. For example, the first axis can show days and the calculated axis can show weeks.

[C#]

Chart.XAxis.TimeInterval = TimeInterval.Days;
Chart.XAxis.Label.Text = "Days";
Chart.AxisCollection.Add(Chart.XAxis.Calculate("Weeks",TimeInterval.Weeks));

[Visual Basic]

Chart.XAxis.TimeInterval = TimeInterval.Days
Chart.XAxis.Label.Text = "Days"
Chart.AxisCollection.Add(Chart.XAxis.Calculate("Weeks",TimeInterval.Weeks))

Sample: CalculatedTimeAxis.aspx

Custom Tick Label Manipulation Method

The third conversion requires a custom delegate method that takes a string and returns a processed string. This gives you full control over the axis tick label text if necessary.

Sample: customFunction.aspx

To only show the calculated axis on the chart and not it's parent, use ParentAxis.Clear()
to make it disappear as shown in the customFunction.aspx sample.
Replica Shadow Axis
This form of shadow axis can be very useful because it allows you to specify data related axis ticks that help describe your data. This code demonstrates how to acquire the replica axis.
[C#]
Axis axisReplica = Chart.XAxis.Calculate("Replica");
Chart.AxisCollection.Add(axisReplica);
[Visual Basic]
Dim axisReplica As Axis = Chart.XAxis.Calculate("Replica")
Chart.AxisCollection.Add(axisReplica)
Some possible uses of this type of shadow axis are shown in the following samples.
  • AxisShadowImportantTicks.aspx
  • AxisShadowSeriesNames.aspx
  • AxisShadowValues.aspx
  • AxisShadowValues2.aspx

After reviewing the above samples you will see that this feature can be useful, however, don't limit yourself to the demonstrated possibilities. The dynamic nature of this feature allows for countless different ways to better describe your data you're plotting.

See Also
{Axis Calculated Ticks}
Send comments on this topic.


Axis Value Coordinates

Introduction

This new version 4.0 feature enables users to click on a chart and obtain the value of any axis, at the specific click location. This allows users to interact with the chart by selecting a point or range on a given axis.

Usage

When the chart is clicked, the coordinates of the mouse click on the image must be supplied to the chart. This is achieved by using a custom image tag with the ISMAP attribute or an image type input tag .

In order to use this feature the default hotspot functionality cannot be used.

For example a working html tag that will return the coordinates will look like this:

<IMG src="dnc-1j4hgd.png" ISMAP>

To get the x y coordinates that can be passed to the axis:

[C#]

string coordinates = Page.Request.QueryString[0];

[Visual Basic]

Dim coordinates As String = Page.Request.QueryString(0)

OR

<FORM method=get> <INPUT Type=Image SRC="dnc-1j8d9ahj.png" Value=Submit > </FORM>

To get the x y coordinates that can be passed to the axis:

[C#]

string coordinates = Page.Request.Params["x"] + "," + Page.Request.Params["y"];

[Visual Basic]

Dim coordinates As String = Page.Request.Params("x") & "," & Page.Request.Params("y")

When the coordinates are retrieved they can be passed to the axis.GetValueAtX() or axis.GetValueAtY() method and the value on the axis at this coordinate is returned as an object. If null is returned, the coordinates were not valid for the particular axis.

In WebForms, because the chart object does not maintain a state through postbacks, the chart must be generated before this method can be called.

For more information on arbitrarily generating the chart, see this kb article.

Samples:

  • XAxisZoom.aspx
  • YAxisZoom.aspx
  • AxisValueClick.aspx
Send comments on this topic.


File Handling

Overview

.netCHARTING includes advanced file handling designed to ensure your charting applications works reliably without the need for special settings. For most users, the default file handling options will meet your needs. Those with advanced requirements can go beyond the intelligent defaults and finely tune their file and image handling for their specific needs. In addition to common properties at the chart level, .netCHARTING includes a file manager class for more advanced file handling.

Cleanup management

Typically .netCHARTING creates a new chart image dynamically for each request. This image is written to disk in a temporary (temp) directory on your web server and an image reference is returned. The result is that the client (web browser) requests the aspx page from the server which renders the chart image and then returns an image reference in HTML. The browser will then request the image file which is served from the web server. This scenario outlines the highest performing option for dynamic chart deployment. Since each request generates a unique chart file which could over time result in wasted space .netCHARTING includes an automated cleanup system which will delete automatically generated files on a regular basis. The default period is 15 minutes and it can be set to any value in minutes through the Chart.CleanUpPeriod property. If set to 0 the cleanup feature will be disabled. Cleanup management is based on 2 settings and can be set independently on a per temp directory basis. As a result, each temp directory setting can have its own independent cleanup period if required. If you mistakenly set different cleanup periods for different scripts that reference the same temp directory the last setting would be used and it would not cause any problems.

Filename generation

When not specified with the Chart.FileName property a random filename is generated to ensure using .netCHARTING is a easy and seamless as possible. All file names generated by the system will be prefixed with dnc and followed by a series of letters and numbers e.g. dnc-5irim3i3.png

Temporary Directory Support
Using the Chart.TempDirectory property you can specify the relative, absolute or physical path which is used for a given charts images.

Examples:

The following examples assume you have a web site (www.site.com) located at c:\inetpub\wwwroot\site1 and an aspx page at c:\inetpub\wwwroot\site1\app1\sub\chart.aspx

Setting | Writes file to | Returns link of | Loading image from
/temp | c:\inetpub\wwwroot\site1\temp | /temp/dnc-123.png | www.site.com/temp/dnc-123.png
temp | c:\inetpub\wwwroot\site1\app1\sub\temp | temp/dnc-123.png | www.site.com/app1/sub/temp/dnc-123.png
../temp | c:\inetpub\wwwroot\site1\app1\temp | ../temp/dnc-123.png | www.site.com/app1/temp/dnc-123.png
../../temp | c:\inetpub\wwwroot\site1\temp | ../../temp/dnc-123.png | www.site.com/temp/dnc-123.png
C:\temp | C:\temp | C:\temp | C:\temp

This latter case (C:\temp) would not work in a web environment unless the
physical path is within the web root and accessible to the site. Typically
physical paths such as c:\temp should not be used.

Browser Cache Defeating

Since it is possible a fixed file name could used for dynamic content, the browser could show an older version because of image caching at the client (browser) level. To prevent this .netCHARTING defeats the browsers image cache by returning a random query string with the image reference. This ensures that clients will load the latest image generated by .netCHARTING even if the same filename is used.

Static filename support

A static filename enables you to select the name used for the chart. When setting a static filename with Chart.FileName each generation will override the last and only a single file will be used for that chart. The filename is provided without extension, which is determined based on the image format selected (see “Multiple image output formats” below for more information).

Output and Fragment caching integration

ASP.NET includes powerful caching features integrated deeply with the architecture of Internet Information Server 6.0 (web server software). .netCHARTING works seamlessly with both output and fragment caching and samples are provided working with both. Output caching enables your entire page including charts to be cached, to work with output caching you need only implement it in your page and set your charts to a specific filename with static filename support. For cases where you only wish to cache the chart and not the other page content fragment caching may be used. Please see outputcache.aspx and fragmentcache.aspx in the feature samples for usage details.

Direct streaming (no file) support

Since disk based charts offer higher performance and more flexibility they are the preferred method of chart image generation. However, in addition to advanced file handling support it is also possible to stream charts directly to the browser. In this case no physical file is written to disk.

There are differences in the way the control can be used between these two image return methods. When using a file reference, you are free to treat the page as you normally would, including HTML and any other web content on the page.

If you are streaming the image back, only the control call should exist on the page because no other HTML will render. This is not a limitation of .netCHARTING but rather specific to the way the HTTP protocol works. Each request is served separately (as such a request to a web site with 3 images is actually 4 unique requests to the web server and the browser does the job of assembling those 4 items into the single web page you see.

Because streaming images does not allow HTML, setting url and tooltip properties of elements on the chart will have no effect. See streaming.aspx for sample usage. Also see streamingusage.aspx for a page which consumes the streaming image. When you request streaming.aspx it is the same as requesting an image file directly. Streamingusage.aspx shows how this aspx page can be referenced as an image within a page so other HTML elements can be included.

Note: Disk based charts offer higher performance and more flexibility -
they are the preferred method of chart image generation. Streaming
should only be used if you have a specific need for it.

Multiple image output formats

.netCHARTING supports multiple image formats for output, set with the Chart.ImageFormat property. PNG is most commonly used as it provides high quality lossless charts. Jpg is useful when using image backgrounds as it can generate a smaller file size. When using jpg you can adjust the quality and level of compression with File Quality property of the file manager which accepts values from 0 to 100. Other supported types include vector output (wmf and emf), tif, and bmp.

Tip: PNG tends to produce the best looking output for most charts however
if your chart includes an image background , consider JPG as it will produce
a smaller file size. See sample bevel.aspx for an example.

Direct bitmap access

In addition to having the chart control return a built in reference to the generated image, you can directly access the chart bitmap for your own advanced uses. See sample postrenderdrawing.aspx which demonstrates obtaining the chart bitmap, making changes to the bitmap and saving the results with the file manager. Using the file manager enables complex tasks to be nearly as simple as using the built in file management since it handles creating a file name and returning a control referencing the newly generated chart image.

Legend and chart area image splitting

In addition to returning the entire chart image as a bitmap, you can also return just the legend with GetLegendBitmap. The advanced image map functionality even allows you to use .netCHARTING generated image maps for tool tips and URL’s on images returned independently from the control so you can place them freely in your page. See imagemaptext.aspx for a complete sample.

Send comments on this topic.


Shortcuts and Efficient Code

Introduction

The .netCHARTING API has been designed to allow users to dramatically cut down on the amount of code necessary to perform common tasks. This topic will demonstrate how many multi-task operations can be done very easily, usually with a single line of code. If you spend much of your time working with charts please read on.

Labels

With the addition of the label markup language, it is possible to apply styling to labels without having to set those style explicitly through label properties. It can be done inline while text is specified for those labels. For example, to make a label reading 'My Chart' bold, you can use '<block fStyle='bold'>MyChart'.

Defaults

One of the most time saving features are the property defaults. These allow you to set properties of all similar objects with a single line of code. For example, a chart can have a large number of series and elements. To quickly set any of those series or element properties a single line of code can be used as shown here:

[C#]

Chart.DefaultSeries.Type = SeriesType.Line;
Chart.DefaultElement.ShowValue = true;

[Visual Basic]

Chart.DefaultSeries.Type = SeriesType.Line
Chart.DefaultElement.ShowValue = True

Not every single objects of the same type has to bet set using defaults. They can also be set selectively for specific groups. For example, all elements of only a particular series can be set without changing element in other series using the following code:

[C#]

mySeries.DefaultElement.ShowValue = true;

[Visual Basic]

mySeries.DefaultElement.ShowValue = True

This is a list of default properties that can be used to quickly specify settings:

  • Axis.DefaultTick
  • Box.DefaultCorner
  • Chart.DefaultAxis
  • Chart.DefaultChartArea
  • Chart.DefaultElement
  • Chart.DefaultLegendBox
  • Chart.DefaultSeries
  • Chart.DefaultShadow
  • Chart.DefaultTitleBox
  • Chart.DefaultBox
  • Chart.DefaultCultureName
  • Chart.DefaultFormatString
  • ChartArea.DefaultElement
  • ChartArea.DefaultSeries
  • Element.DefaultSubValue
  • LegendBox.DefaultEntry
  • Series.DefaultElement

Adding Styled Annotations

Because annotations are often used as buttons and may require specific styling to be set for each of those buttons, a new constructor has beed added. It can take a default annotatation object and will automatically take on the property settings of that annotation. This way all the style specific settings can be specified once and used for any other new annotations. Sample AnnotationConstruction.aspx demonstrates this.

Selective Element Defaults

Using default series or elements can drastically improve programming efficiency, however, they dont help when only certain elements of a particular series that fulfill some criteria need to be modified. For this task a new method 'SelectiveElementDefaults' available at the series and seriescollection level is provided. This method is related to the Series.Trim method as far as specifying which elements are affected. For more information on the trim method, see the DataManipulation tutorial. This method works like the trim method except, instead of cutting those elements out, it takes the properties of a specified element and applies them to the specified range of elements. The specified element is just a new element instance with the settings you want to propagate to the range of elements.

  • CS
  • VB
Element myDefaultElement = new Element();
myDefaultElement.ShowValue = true;
myDefaultElement.Outline.Color = Color.White;
myDefaultElement.SmartLabel.GlowColor = Color.White; mySC.SelectiveElementDefaults(new ScaleRange(30, 50), ElementValue.YValue, myDefaultElement);

Dim myDefaultElement As New Element() myDefaultElement.ShowValue = True
myDefaultElement.Outline.Color = Color.White
myDefaultElement.SmartLabel.GlowColor = Color.White
mySC.SelectiveElementDefaults(New ScaleRange(30, 50), ElementValue.YValue, myDefaultElement)

Sample:

  • SelectiveDefaults.aspx
  • SelectiveDefaultsInclusive.aspx
  • SelectiveDefaultsSC.aspx

Common Collection Construction

Many collection objects in .netCHARTING have methods that make it much faster and easier to create them. Let's take a look at some of these features using the ChartAreaCollection object.

Constructor
public ChartAreaCollection(params ChartArea[] chartAreaList)

This constructor allows you to create a collection with a number of chart areas using a single line of code:

[C#]

ChartAreaCollection cac = new ChartAreaCollection(ca1, ca2, ca3, ca4);

[Visual Basic]

Dim cac As New ChartAreaCollection(ca1, ca2, ca3, ca4)

Add Methods

public void Add(params ChartArea[] chartAreaList)

Objects can be added to existing collections in the same manner as the constructor

[C#]

Chart.ExtraChartAreas.Add(ca1, ca2, ca3, ca4);

[Visual Basic]

Chart.ExtraChartAreas.Add(ca1, ca2, ca3, ca4)

public void Add(ChartAreaCollection chartAreaCollection)

Adding a collection of chart areas to another chart area collection can be done like so:

[C#]

Chart.ExtraChartAreas.Add(myChartAreaCollection);

[Visual Basic]

Chart.ExtraChartAreas.Add(myChartAreaCollection)

Almost all collections contain these shortcut members.

Collection Type Specific Construction & Features

Some collections also have shortcut constructors that are specific to the type of data they represent.

AxisTickCollection

public static AxisTickCollection FromValues(params DateTime[] list)
public static AxisTickCollection FromValues(params double[] list)

This static constructor allows you to add axis ticks with specific values using a single line of code.

[C#]

Chart.YAxis.ClearValues = true;
Chart.YAxis.ExtraTicks.Add(AxisTickCollection.FromValues(1,2,3,4,5,6);

[Visual Basic]

Chart.YAxis.ClearValues = True
Chart.YAxis.ExtraTicks.Add(AxisTickCollection.FromValues(1,2,3,4,5,6)
Notice: The ExtraTicks.Add method is taking an AxisTickCollection.

Series

The Series object is not a collection. The elements are contained in the Series.Elements ElementCollection property. There are, however, features available that allow managing a series' elements simpler. Series can be populated with elements quickly using the FromYValues constructor.

public static Series FromYValues(params double[] yValues)

[C#]

Series s = Series.FromYValues(1,5,6,34,2);

[Visual Basic]

Dim s As Series = Series.FromYValues(1, 5, 6, 34, 2)

The following method allows constructing a series from a list of elements.

public Series(string name, params Element[] elementList)

[C#]

Series s = new Series("mySeries", element1, element2,element3, element4);

[Visual Basic]

Dim s As New Series("mySeries", element1, element2,element3, element4)

There is one more series feature worth noting. As mentioned above, the series is not a collection. Nevertheless, its elements can be accessed easily using the series' indexer:

[C#]

Element myElement = mySeries[1];
// Equivalent to:
Element myElement = mySeries.Elements[1];

[Visual Basic]

Dim myElement As Element = mySeries(1)
' Equivalent to:
Dim myElement As Element = mySeries.Elements(1)

Using these collection object shortcuts will allow you to write code much faster and spend more time focusing on your application logic.

Send comments on this topic.


Performance

Introduction

This section will go over a number of issues that affect the performance of chart rendering. Please note that these tips are not necessarily required in normal scenarios. They are shown here in order to improve performance when it is crucial. There are several things to consider when creating charts that require high availability and performance.

Data Acquisition

The chart DataEngine provides an array of features to group and manipulate data tailored for chart use. If this process becomes inefficient due to large dataSets or other reasons, some improvements can be made.

  • Instead of the DataEngine acquiring data from the database, getting a dataTable manually and passing that to the dataEngine may improve performance.
  • The absolute fastest way to populate a series is to do it manually like most of the gallery samples do. This enables the developer to have full control of the process and apply performance tweaks were necessary.
WinForms Performance
When a WinForms application is run in debug mode with Visual Studio, it executes the app.vshost.exe application in the bin folder and runs much slower than the app.exe file which is also available in the bin folder.

Chart Rendering

Charts with less than 200 Elements.

When there are few data elements on a chart, the data processing time is largely minimal. Drawing the image takes the majority of time. The more fancy the chart, the slower it will render. Not to say that charts render showily, however, in certain circumstances every millisecond counts. So, how can this process be sped up? Consider this, everything that is drawn on a chart requires time and the more complicated the drawing (shading effects, gradients, shadows etc.) the longer it takes.

Another very important fact to consider is the chart size. The larger the chart becomes the longer it will take for GDI to generate it. There is however an exception to this rule. When charts are so small that they have to be scaled down to fit into the image they are actually drawn at a larger size than specified, then scaled down so this will require more processing time. You'll be able to tell how much a chart is scaled by looking at text labels and compare their size to non-scaled versions of the chart.

The following chart grid demonstrates the performance impact of some settings.

Tips & Summary

  1. Dont use chart features that are not useful like element labels that are too small to read.
  2. Use less visually complex elements. (Square markers instead of circles or no shading effects.
  3. Set box background, line, and box shadow colors to Color.Empty.
  4. Use color transparency sparingly.
    A more complex algorithm is necessary to blend backgrounds with partially transparent color fills.
  5. Using Chart.PrinterOptimizedText may seem like it will improve performance because text is not anti-aliased, however, the performance gain is trivial.
  6. Chart size can make a dramatic difference in performance but the gain is lost when the chart gets too small to fit into the image in which case, it is rendered at a larger size and scaled down to the image size.
  7. Using Label.Shadow and Label.GlowColor may introduce a reduction in performance as these operations are CPU intensive.
  8. Use SeriesType.Line instead of SeriesType.Spline if possible. The line type is much faster than spline.

Charts with 200+ elements.

With a large number of elements the performance scale begins to tip towards data processing. Certain element features may take a few extra cpu ticks due to processing such as token replacement for element tool tips, labels and other hotspot attributes. The more tokens used in element properties the longer processing may take. Using element markers for series with thousands of elements might also be a bad idea because each marker must be drawn individually.

Memory performance.

If memory usage is a factor there are a few things to be aware of. First, memory usage can be tweaked only when charts are showing a large number of elements, otherwise, these tips will provide marginal benefits.

Element properties such as smart label, markers and hotspots are not instantiated by default. They are instantiated when the properties of those objects are used. For instance using code such as: Chart.DefaultElement.SmartLabel.Text = "%Name" will create a SmartLabel instance for the default element and eventually for each element on the chart.

Ajax Zoomer Performance

The ajax zoomer can sometimes have performance issues if the chart is too complicated. When the property Chart.Zoomer.UseSections is set to false, the zoomer will generate and upload the entire chart image at once. In some scenarios this can make zoomer charts work faster.

Update your DLL to at least version 6.2 for use with zoomer. A number of performance improvements have been made in the 6.2 release that greatly improve zoomer efficiency.

Use Navigator

The navigator was designed to outperform any other comprable software. It can handle very large dataSets and let users navigate through it similarily to advance yahoo or google finance charts. When possible, it is a good choice over using Zoomer.

Send comments on this topic.


dotnetCHARTING Assembly
Namespaces
Namespace | Description
dotnetCHARTING |
dotnetCHARTING.Mapping |
dotnetCHARTING.Zoomer |
Send Feedback


Inheritance Hierarchy
dotnetCHARTING Namespace
Classes
 | Class | Description
Class | Annotation | Encapsulates a Box object with a position, data source, and hot spot functionality.
Class | AnnotationCollection | Contains a collection of Annotation objects.
Class | Axis | Represents an axis drawn on a ChartArea.
Class | Axis.ScaleSync | An extension to the Axis.SynchronizeScale property. Defines the scale synchronization behavior of an axis.
Class | Axis.TimeScaleLabelInfo | Encapsulates time scale label behavior options in addition to axis ticks and format strings used instead of the main axis ticks when they represent particular instances in time.
Class | AxisCollection | Contains a collection of Axis objects.
Class | AxisLineBreaks | Encompases axis line breaks options that produce gaps in the line at axisTick positions.
Class | AxisMarker | Defines styles and positions used to mark a specified section or point on an axis.
Class | AxisMarkerCollection | Contains a collection of AxisMarker objects.
Class | AxisTick | Encapsulates an axis tick that includes Label or ElementMarker, TickLine, and GridLine styling objects.
Class | AxisTickCollection | Contains a collection of AxisTick objects.
Class | Background | Defines styling properties used to fill the interior of polygons and chart elements such as legend boxes, annotations and other shapes.
Class | Box | Defines a base class for derived objects such as Chart.TitleBox, Chart.LegendBox, and Annotation.
Class | BoxHeaderOptions | Represents a box header with options that control its layout, styling, and contents.
Class | CalendarPattern | Specifies a calendar pattern such as weekends in a week.
Class | Chart | The .netCHARTING control.
Class | ChartArea | Represents an area on which series and elements are plotted.
Class | ChartAreaCollection | Contains a collection of ChartArea objects.
Class | ChartAreaLayout | Encapsulates a set of options that control the layout of multiple chart areas in a single chart image.
Class | DataEngine | Acquires and manipulates data from databases or other sources, then creates a SeriesCollection which is consumed by the chart control.
Class | DataSource | Represents a single or related set of .netCHARTING data-based objects that specify a data source used to parse tokens and populate custom legend boxes with LegendEntry objects.
Class | Element | Represents a element object or data point on the chart.
Class | ElementCollection | Contains a collection of Element objects.
Class | ElementMarker | Defines a graphical object with a specified shape, size, and color or an image used to mark and identify Element objects.
Class | EmptyElement | Defines the behavior and appearance of empty elements for a given Series.
Class | FileManager | Facilitates saving bitmap images and cleanup.
Class | FinancialEngine | Provides a set of methods that perform financial analysis of series and series collections.
Class | FinancialEngine.Options | Defines a set of static options used with FinancialEngine calculations.
Class | ForecastEngine | Provides a set of methods that find the best fit curve of a data set.
Class | ForecastEngine.Advanced | This class contains advanced methods for calculating the best fitting curve of a data set. It allows the user to construct his own function.
Class | ForecastEngine.Options | Defines a set of static options used with FinancialEngine calculations.
Class | GridColumn | Encompasses options for JS GridColumn.
Class | GridColumnCollection | Contains a collection of GridColumn objects.
Class | Hotspot | Represents a hotspot on the image and provides events such as tool tips and redirect URL when clicked.
Class | Hotspot.HtmlAttribute | Encapsulates a number of pre-defined javascript actions and their values.
Class | Hotspot.HtmlAttributes | Encapsulates a set of html event attributes and their values.
Class | HotspotCollection | Contains a collection of Hotspot objects.
Class | JSDataGrid | Encompasses options for JS DataGrid.
Class | JSMapping | Encompasses options for JS Mapping.
Class | JsOptions | Contains the public API definitions for options that control JavaScript chart features and behavior.
Class | JsOptions.JsButtons | Defines the export and print button options for JavaScript charts.
Class | JsOptions.JsCalendar | Encompasses options for the JS calendar chart type.
Class | JsOptions.JsCalendarFilter | Represents a JS calendar filter used to define rules such as weekends, or more complicated rules similar to how dates of national holidays are determined. Calendar filters can also represent complex time intervals such as first weekend of every month. Setting filter property value to "*" indicates an interval at that time span. For example month="*" means every month. Only one property can have an asterisk. To represent every 3 months this configuration can be used: month="*"; every=3; When using options such as year="1/1/2020" the year value is evaluated using the same function applied to dates being tested and is equivalent to year="2020"
Class | JsOptions.JsHighlight | Options that define a calendar filter and styling used to highlight a grouping of points.
Class | JsOptions.LanguageStringSettings | Defines the language string options for JavaScript charts.
Class | Label | Represents a label containing text, a font, color, and other options.
Class | LabelAlignmentCollection | Contains a collection of LabelAlignment objects.
Class | LabelOverrideCollection | Contains a collection of LabelOverride objects.
Class | LegendBox | Encapsulates a collection of LegendEntry objects.
Class | LegendBoxCollection | Contains a collection of LegendBox objects.
Class | LegendEntry | Represents an entry in the legend box.
Class | LegendEntryCollection | Contains a collection of LegendEntry objects.
Class | Line |
Class | ListCollection | A list dictionary variation that allows adding items of the string type using a string.
Class | NavigatorOptions | Contains the definition for options that control the navigator features and behavior.
Class | NavigatorOptions.NavigationBarOptions | Defines the navigation bar at the top of a navigator chart.
Class | Parameter | Represents an SQL parameter to use with a StoredProcedure.
Class | ParameterCollection | Contains a collection of Parameter objects.
Class | ScaleRange | Represents a value or range of values on an axis scale. Values can be numeric, DateTime, and string types.
Class | ScaleRangeCollection | Contains a collection of ScaleRange objects.
Class | Series | Encapsulates a group of elements.
Class | SeriesCollection | Contains a collection of Series objects.
Class | Shadow | Represents a shadow cast by chart objects such as a Box, Annotation, and others.
Class | ShapeLabelCollection | Contains a collection of Label objects.
Class | SmartColor | Defines a SmartColor object that can be used applied to elements or series conditionally based on specific names or elements with values which fall within a specified range.
Class | SmartLabel | Encapsulates a Label object with advanced alignment and collision detection options.
Class | SmartPalette | Contains collection of SmartPalette objects or dictionary like items of string and color pairs where strings refer to series or element names and colors that are assigned to series or elements with those names.
Class | StatisticalEngine | Provides a set of methods that perform statistical analysis of series and series collections.
Class | StatisticalEngine.Options | Defines a set of static options used with StatisticalEngine calculations.
Class | SubValue | Represents a value relative to or independent of the parent element's value.
Class | SubValueCollection | Contains a collection of SubValue objects.
Class | TimeIntervalAdvanced | Represents a time interval and instant at which it occurs.
Class | TimeIntervalCollection | Contains a collection of TimeInterval objects.
Class | Truncation | Defines properties used to shorten long labels.
Class | View3D | Contains properties that control the 3D view angles and options when used with surface charts.
Class | Viewport | An extension to the Axis.ViewRange property. Defines the visible scale range or zoom range when using AJAX scrolling. Setting the properties of this class allows zooming the chart programatically.
Structures
 | Structure | Description
Structure | LabelOverride | Defines a string find and replace pair used by Axis objects to manipulate tick labels.
Structure | Vector |
Delegates
 | Delegate | Description
Delegate | ChangeValueDelegate |
Delegate | ErrorProcessingEventHandler |
Delegate | PostDataProcessingEventHandler |
Enumerations
 | Enumeration | Description
Enumeration | AbsorbedDose |
Enumeration | Acceleration |
Enumeration | Angle |
Enumeration | AngularVelocity |
Enumeration | Area |
Enumeration | BackgroundMode | Specifies a background drawing mode.
Enumeration | BoxCapStyle | Specifies the available box cap styles. These caps can be used with box header StartCap and EndCap properties.
Enumeration | BoxCorner | Specifies a box edge style.
Enumeration | Calculation | Specifies a calculation to be performed on a series or series collection.
Enumeration | Capacitance |
Enumeration | Charge |
Enumeration | ChartAreaLayoutMode | Specifies the positioning behavior of multiple chart areas on a single chart image.
Enumeration | ChartAreaNavigationOptions | Specifies the navigation options of chart areas in the navigator.
Enumeration | ChartType | Represents the chart type of a chart.
Enumeration | ConcentrationMolar |
Enumeration | Current |
Enumeration | Data |
Enumeration | DataProviderType | Specifies a database type.
Enumeration | DataSourceType | Specifies a DataSource type to split the parent DataSource into.
Enumeration | DataTransfer |
Enumeration | Density |
Enumeration | DigitalImageResolution |
Enumeration | EdgeAlignment | Specifies the alignment of an object in relation to an objects side.
Enumeration | ElementMarkerType | Built in element marker icons.
Enumeration | ElementValue | Specifies a value of an element.
Enumeration | EmptyElementMode | Specifies how empty elements are handled.
Enumeration | Energy |
Enumeration | EUCurrency |
Enumeration | FieldType | Specifies a database field data type.
Enumeration | FlowMass |
Enumeration | FlowMolar |
Enumeration | FlowVolumetric |
Enumeration | Force |
Enumeration | FrequencyWavelength |
Enumeration | FuelConsumption |
Enumeration | GaugeBorderShape | Specifies the gauge border shape used on gauges.
Enumeration | GaugeLabelMode | Specifies the circular gauge axis labeling mode.
Enumeration | GaugeLinearStyle | Specifies the linear gauge type.
Enumeration | GaugeNeedleType | Specifies the gauge needle type used on circular gauges.
Enumeration | GaugeType | Specifies the gauge type when using ChartType.Gauges or ChartType.Multiple with SeriesTypeMultiple.Gauge.
Enumeration | HatchStylePalette | Specifies a pre-defined hatch style palette.
Enumeration | HoverAction | (JS Charts Only) Specifies the action caused by hovering the mouse over an item.
Enumeration | Illumination |
Enumeration | ImageFormat | Specifies file save format.
Enumeration | Inductance |
Enumeration | JsOptions.CalendarView | Specifies a JS calendar chart type view.
Enumeration | LabelAlignment | Specifies alignment of a label.
Enumeration | LabelType | Specifies the label type used with labels.
Enumeration | LegendBoxPosition | Specifies the position of the legend box.
Enumeration | LegendEntryHeaderMode | Specifies a header mode for element entries.
Enumeration | Length |
Enumeration | LimitMode | Controls the type of limitation in Limit or SplitByLimit properties.
Enumeration | LoadingAnimation | Specifies a predefined loading animation.
Enumeration | LumberVolume |
Enumeration | Mass |
Enumeration | OrganizationalConnectorType | (JS Charts Only) Specifies whether organizational connector lines are drawn straight between nodes or only using right angles.
Enumeration | Orientation | Specifies the orientation of an object.
Enumeration | Palette | Specifies a pre-defined palette.
Enumeration | Permeability |
Enumeration | PieLabelMode | Specifies pie label behavior.
Enumeration | Placement | (JS Charts Only) Used with labels to specify inside or outside placement.
Enumeration | Power |
Enumeration | Pressure |
Enumeration | PreviewAreaNavigationOptions | Specifies the navigation options of the navigators preview area.
Enumeration | RadarLabelMode | Specifies how tick labels behave on a radar graph.
Enumeration | RadarMode | Specifies the behavior of the x axis on a circular graph such as radar.
Enumeration | Radiation |
Enumeration | Scale | Indicates the scale of an axis.
Enumeration | ScaleBreakStyle | Specifies how a scale break is drawn on a chart.
Enumeration | SeriesType | Specifies how a series will be shown on the chart.
Enumeration | SeriesTypeFinancial | Specifies how a financial series will be shown on the chart.
Enumeration | SeriesTypeMultiple | Specifies how a multiple chart type series will be shown on the chart.
Enumeration | SeriesTypeSurface | Specifies how a surface series type will be shown on the chart.
Enumeration | ShadingEffectMode | Specifies a shading mode.
Enumeration | ShapeType | Specifies how a shape bubble will be drawn.
Enumeration | SilverlightInstall | Defines options used to handle Silverlight plugin installation.
Enumeration | SubValueType | Specifies the how a sub value is drawn.
Enumeration | SyncDimention | (JS Charts Only) Specifies whether organizational chart nodes should sync a dimension like width or height with other all nodes, nodes on the same level, or none.
Enumeration | SynchronizeScaleMode | Specifies an axis scale synchronization mode between two or more axes.
Enumeration | Telecommunications |
Enumeration | Temperature |
Enumeration | TickLabelMode | Specifies how tick labels are laid out.
Enumeration | Time |
Enumeration | TimeInterval | Specifies a time interval.
Enumeration | TimeScaleLabelMode | Specifies the single value time label automation mode.
Enumeration | TimeScaleLabelRangeMode | Specifies the range value time label automation mode.
Enumeration | TitleBoxPosition | Specifies the title box position.
Enumeration | Torque |
Enumeration | TruncationMode | Specifies how to trim characters from a string that exceeds a maximum number of characters.
Enumeration | Typography |
Enumeration | Velocity |
Enumeration | ViscosityDynamic |
Enumeration | ViscosityKinematic |
Enumeration | Volume |
See Also

Reference

dotnetCHARTING Assembly


%%PageItemTitle%%

Members Example

dotnetCHARTING Namespace : Annotation Class
Annotation Class
Encapsulates a Box object with a position, data source, and hot spot functionality.
Object Model
Annotation ClassBackground ClassBoxHeaderOptions ClassHotspot ClassLine ClassLabel ClassLine ClassShadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Annotation
   Inherits Box
'Usage

Dim instance As Annotation
public class Annotation : Box
Remarks
Annotations can either be instantiated for an Element or added to the Chart.Annotation collection. When attached to an element, the annotation will follow the element's position (unless specified) and have a spike indicating which element it's referring to.

When an annotation does not have a size or any text specified and it's Background has an image, the size is will become that of the background's image.
Example
The following code snippet demonstrates using an annotation to simulate a text link on the chart.
  • Visual Basic
Dim a2 As Annotation  = New Annotation("Annotation text.")

'set the position
a2.Position = New Point(60,40)

'We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "https://www.dotnetcharting.com"

' Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = False

'In order for the annotation not to draw the background, outline and so
'on... We'll use a shortcut to clear the colors.
a2.ClearColors()

'Add the annotation to a chart.
Chart.Annotations.Add(a2)
  • C#
Annotation a2 = new Annotation("Annotation text.");

//set the position
a2.Position = new Point(60,40);

// We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "https://www.dotnetcharting.com";

// Make sure the annotation doesn't create a rectangle for the text and wrap it.
 a2.DynamicSize = false;

// In order for the annotation not to draw the background, outline and so
// on... We'll use a shortcut to clear the colors.
a2.ClearColors();

// Add the annotation to a chart.
Chart.Annotations.Add(a2);
Example
Annotation Alignment
Annotation Link
Element Annotation
Header Annotation
Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.Annotation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Members
dotnetCHARTING Namespace

Tutorials

Box Tutorial


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Annotation Class
Annotation Class Members

The following tables list the members exposed by Annotation.

Public Constructors
 | Name | Description
Public Constructor | Annotation Constructor | Overloaded.
Top
Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DataSource | Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DynamicSize | Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | Hotspot | Gets or sets the Hotspot of this Annotation.
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | JsID | Gets or sets the ID of this annotation used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Public Property | Label | Gets or sets the Box.Label of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Orientation | Gets or sets the annotation's orientation around it's Position and draws a spike to it.
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Overridden. Gets or sets this annotation's position.
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Size | Gets or sets the annotation's size.
Public Property | SyncHeight | (JS Charts Only) Synchrinize the annotation height with other nodes on the organizational chart.
Public Property | SyncWidth | (JS Charts Only) Synchrinize the annotation width with other nodes on the organizational chart.
Public Property | ToolTip | Gets or sets this annotation's tool tip.
Public Property | URL | Gets or sets this annotation's hotspot url.
Public Property | URLTarget | Gets or sets the target URL of this annotation's link.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

Annotation Class
dotnetCHARTING Namespace

Tutorials

Box Tutorial


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class : Annotation Constructor
Annotation Constructor
Overload List
Overload | Description
Annotation Constructor() | Initializes a new instance of the Annotation class.
Annotation Constructor(String) | Initializes a new instance of the Annotation class with text.
Annotation Constructor(String,String) | Initializes a new instance of the Annotation class with text and a tool tip.
Annotation Constructor(String,String,String) | Initializes a new instance of the Annotation class with text, tool tip, and a url.
Annotation Constructor(Background) | Initializes a new instance of the Annotation class with a background. Useful when using an image as the annotation.
Annotation Constructor(String,Annotation) | Initializes a new instance of the Annotation class with text and all the settings of the specified defaultAnnotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor()
Annotation Constructor()
Initializes a new instance of the Annotation class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Annotation()
public Annotation()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor(String)
Annotation text.
Annotation Constructor(String)
Initializes a new instance of the Annotation class with text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String _
)
'Usage

Dim text As String

Dim instance As New Annotation(text)
public Annotation(
   string text
)

Parameters

text
Annotation text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor(String,String)
Annotation text.
Annotation tool tip.
Annotation Constructor(String,String)
Initializes a new instance of the Annotation class with text and a tool tip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal toolTip As String _
)
'Usage

Dim text As String
Dim toolTip As String

Dim instance As New Annotation(text, toolTip)
public Annotation(
   string text,
   string toolTip
)

Parameters

text
Annotation text.
toolTip
Annotation tool tip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor(String,String,String)
Annotation text.
Annotation tool tip.
Annotation url.
Annotation Constructor(String,String,String)
Initializes a new instance of the Annotation class with text, tool tip, and a url.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal toolTip As String, _
   ByVal url As String _
)
'Usage

Dim text As String
Dim toolTip As String
Dim url As String

Dim instance As New Annotation(text, toolTip, url)
public Annotation(
   string text,
   string toolTip,
   string url
)

Parameters

text
Annotation text.
toolTip
Annotation tool tip.
url
Annotation url.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor(Background)
Background object for the annotation.
Annotation Constructor(Background)
Initializes a new instance of the Annotation class with a background. Useful when using an image as the annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal background As Background _
)
'Usage

Dim background As Background

Dim instance As New Annotation(background)
public Annotation(
   Background background
)

Parameters

background
Background object for the annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Annotation Class > Annotation Constructor : Annotation Constructor(String,Annotation)
Annotation text.
Annotation whose settings will be inherited.
Annotation Constructor(String,Annotation)
Initializes a new instance of the Annotation class with text and all the settings of the specified defaultAnnotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal defaultAnnotation As Annotation _
)
'Usage

Dim text As String
Dim defaultAnnotation As Annotation

Dim instance As New Annotation(text, defaultAnnotation)
public Annotation(
   string text,
   Annotation defaultAnnotation
)

Parameters

text
Annotation text.
defaultAnnotation
Annotation whose settings will be inherited.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Annotation Class
Annotation Class Properties

For a list of all members of this type, see Annotation members.

Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DataSource | Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DynamicSize | Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | Hotspot | Gets or sets the Hotspot of this Annotation.
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | JsID | Gets or sets the ID of this annotation used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Public Property | Label | Gets or sets the Box.Label of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Orientation | Gets or sets the annotation's orientation around it's Position and draws a spike to it.
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Overridden. Gets or sets this annotation's position.
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Size | Gets or sets the annotation's size.
Public Property | SyncHeight | (JS Charts Only) Synchrinize the annotation height with other nodes on the organizational chart.
Public Property | SyncWidth | (JS Charts Only) Synchrinize the annotation width with other nodes on the organizational chart.
Public Property | ToolTip | Gets or sets this annotation's tool tip.
Public Property | URL | Gets or sets this annotation's hotspot url.
Public Property | URLTarget | Gets or sets the target URL of this annotation's link.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

Annotation Class
dotnetCHARTING Namespace

Tutorials

Box Tutorial


Example

dotnetCHARTING Namespace > Annotation Class : DataSource Property
DataSource Property (Annotation)
Gets or sets the DataSource object used to replace tokens in this annotation's label, tool tip, and URL.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As Object
'Usage

Dim instance As Annotation
Dim value As Object

instance.DataSource = value

value = instance.DataSource
public object DataSource {get; set;}
Remarks
Data sources include Element, Series, and AxisMarker objects. When the source is specified, any tokens associated with the source type may be used.
Example
Instantiates a series and annotation. Sets the series as the DataSource of the annotation. Specifies the '%Name' series token as for the annotation's label. Adds the annotation to a chart.
  • C#
Series mySeries = new Series();
mySeries.Name = "Test Series";
Annotation a = new Annotation();
a.DataSource = mySeries;
a.Label.Text = "%Name";
Chart.Annotations.Add(a);

// When this chart renders, the annotation will read 'Test Series'.
  • Visual Basic
Dim mySeries As New Series()
mySeries.Name = "Test Series"
Dim a As New Annotation()
a.DataSource = mySeries
a.Label.Text = "%Name"
Chart.Annotations.Add(a)

' When this chart renders, the annotation will read 'Test Series'.
Example
Annotation Data Source
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : DynamicSize Property
DynamicSize Property
Gets or sets a value that indicates whether a golden rectangle is maintained as the shape of this annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicSize As Boolean
'Usage

Dim instance As Annotation
Dim value As Boolean

instance.DynamicSize = value

value = instance.DynamicSize
public bool DynamicSize {get; set;}
Remarks
If false, the shape will be determined by the text and will be drawn on a single line unless Size is specified.
Example
Dynamic Annotation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : Hotspot Property
Hotspot Property (Annotation)
Gets or sets the Hotspot of this Annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As Annotation
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Example
Annotation Link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : JsID Property
JsID Property (Annotation)
Gets or sets the ID of this annotation used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsID As String
'Usage

Dim instance As Annotation
Dim value As String

instance.JsID = value

value = instance.JsID
public string JsID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : Orientation Property
Orientation Property (Annotation)
Gets or sets the annotation's orientation around it's Position and draws a spike to it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Orientation As Orientation
'Usage

Dim instance As Annotation
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public new Orientation Orientation {get; set;}
Remarks
If orientation is set to Bottom or Right, BottomRight will be selected. If orientation is set to Top or Left, TopLeft will be selected. If the annotation is added to the Chart.Annotations collection, the default is BottomRight but no spike is drawn.
Example
Annotation Orientation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : Position Property
Position Property (Annotation)
Gets or sets this annotation's position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Position As Object
'Usage

Dim instance As Annotation
Dim value As Object

instance.Position = value

value = instance.Position
public override object Position {get; set;}
Example
Header Annotation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members
Base Implementation in Position


dotnetCHARTING Namespace > Annotation Class : Size Property
Size Property (Annotation)
Gets or sets the annotation's size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Size
'Usage

Dim instance As Annotation
Dim value As Size

instance.Size = value

value = instance.Size
public Size Size {get; set;}
Remarks
If the size is not specified, it is determined by DynamicSize and the size of the specified text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : SyncHeight Property
SyncHeight Property
(JS Charts Only) Synchrinize the annotation height with other nodes on the organizational chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SyncHeight As SyncDimention
'Usage

Dim instance As Annotation
Dim value As SyncDimention

instance.SyncHeight = value

value = instance.SyncHeight
public SyncDimention SyncHeight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : SyncWidth Property
SyncWidth Property
(JS Charts Only) Synchrinize the annotation width with other nodes on the organizational chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SyncWidth As SyncDimention
'Usage

Dim instance As Annotation
Dim value As SyncDimention

instance.SyncWidth = value

value = instance.SyncWidth
public SyncDimention SyncWidth {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


dotnetCHARTING Namespace > Annotation Class : ToolTip Property
ToolTip Property (Annotation)
Gets or sets this annotation's tool tip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As Annotation
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Example

dotnetCHARTING Namespace > Annotation Class : URL Property
URL Property (Annotation)
Gets or sets this annotation's hotspot url.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As Annotation
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}

Property Value

A string representing the url of this annotation.
Example
Usage example.
  • Visual Basic
MyAnnotation.URL = "dotnetcharting.com"
  • C#
myAnnotation.URL = "dotnetcharting.com";
Example
Annotation Link
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


Example

dotnetCHARTING Namespace > Annotation Class : URLTarget Property
URLTarget Property (Annotation)
Gets or sets the target URL of this annotation's link.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As Annotation
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Example
Usage example
  • Visual Basic
MyAnnotation.URLTarget = "_blank"
  • C#
MyAnnotation.URLTarget = "_blank";
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Annotation Class
Annotation Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AnnotationCollection Class
AnnotationCollection Class
Contains a collection of Annotation objects.
Object Model
AnnotationCollection ClassAnnotation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AnnotationCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As AnnotationCollection
public class AnnotationCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AnnotationCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AnnotationCollection Class
AnnotationCollection Class Members

The following tables list the members exposed by AnnotationCollection.

Public Constructors
 | Name | Description
Public Constructor | AnnotationCollection Constructor | Creates a new instance of AnnotationCollection with the specified list of Annotation objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AnnotationCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Annotation.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Annotation in this collection.
Public Method | Insert | Inserts a Annotation into this collection at a specified index.
Public Method | Remove | Removes a specified Annotation from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AnnotationCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > AnnotationCollection Class : AnnotationCollection Constructor
AnnotationCollection Constructor
Creates a new instance of AnnotationCollection with the specified list of Annotation objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray annotationList() As Annotation _
)
'Usage

Dim annotationList() As Annotation

Dim instance As New AnnotationCollection(annotationList)
public AnnotationCollection(
   params Annotation[] annotationList
)

Parameters

annotationList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AnnotationCollection Class
AnnotationCollection Class Methods

For a list of all members of this type, see AnnotationCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AnnotationCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Annotation.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Annotation in this collection.
Public Method | Insert | Inserts a Annotation into this collection at a specified index.
Public Method | Remove | Removes a specified Annotation from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AnnotationCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AnnotationCollection Class : Add Method
Add Method (AnnotationCollection)
Adds a specified AnnotationCollection to this collection.
Overload List
Overload | Description
Add(Annotation) |
Add(AnnotationCollection) | Adds a specified AnnotationCollection to this collection.
Add(Annotation[]) | Adds the specified Annotation objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


dotnetCHARTING Namespace > AnnotationCollection Class > Add Method : Add(Annotation) Method
Add(Annotation) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal annotation As Annotation _
) As Integer
'Usage

Dim instance As AnnotationCollection
Dim annotation As Annotation
Dim value As Integer

value = instance.Add(annotation)
public int Add(
   Annotation annotation
)

Parameters

annotation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members
Overload List


dotnetCHARTING Namespace > AnnotationCollection Class > Add Method : Add(AnnotationCollection) Method
The AnnotationCollection to add.
Add(AnnotationCollection) Method
Adds a specified AnnotationCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal annotationCollection As AnnotationCollection _
)
'Usage

Dim instance As AnnotationCollection
Dim annotationCollection As AnnotationCollection

instance.Add(annotationCollection)
public void Add(
   AnnotationCollection annotationCollection
)

Parameters

annotationCollection
The AnnotationCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members
Overload List


dotnetCHARTING Namespace > AnnotationCollection Class > Add Method : Add(Annotation[]) Method
A list of Annotation objects to add.
Add(Annotation[]) Method
Adds the specified Annotation objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray annotationList() As Annotation _
)
'Usage

Dim instance As AnnotationCollection
Dim annotationList() As Annotation

instance.Add(annotationList)
public void Add(
   params Annotation[] annotationList
)

Parameters

annotationList
A list of Annotation objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members
Overload List


dotnetCHARTING Namespace > AnnotationCollection Class : Contains Method
The Annotation to find.
Contains Method (AnnotationCollection)
Determines whether this collection contains a specified Annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal annotation As Annotation _
) As Boolean
'Usage

Dim instance As AnnotationCollection
Dim annotation As Annotation
Dim value As Boolean

value = instance.Contains(annotation)
public bool Contains(
   Annotation annotation
)

Parameters

annotation
The Annotation to find.

Return Value

true if the specified Annotation belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


dotnetCHARTING Namespace > AnnotationCollection Class : IndexOf Method
The Annotation to find.
IndexOf Method (AnnotationCollection)
Determines the index of a specified Annotation in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal annotation As Annotation _
) As Integer
'Usage

Dim instance As AnnotationCollection
Dim annotation As Annotation
Dim value As Integer

value = instance.IndexOf(annotation)
public int IndexOf(
   Annotation annotation
)

Parameters

annotation
The Annotation to find.

Return Value

The zero-based index of the specified Annotation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


dotnetCHARTING Namespace > AnnotationCollection Class : Insert Method
The zero-based index into the collection at which to insert the Annotation.
The Annotation to insert into this collection.
Insert Method (AnnotationCollection)
Inserts a Annotation into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal annotation As Annotation _
)
'Usage

Dim instance As AnnotationCollection
Dim index As Integer
Dim annotation As Annotation

instance.Insert(index, annotation)
public void Insert(
   int index,
   Annotation annotation
)

Parameters

index
The zero-based index into the collection at which to insert the Annotation.
annotation
The Annotation to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


dotnetCHARTING Namespace > AnnotationCollection Class : Remove Method
The Annotation to remove.
Remove Method (AnnotationCollection)
Removes a specified Annotation from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal annotation As Annotation _
)
'Usage

Dim instance As AnnotationCollection
Dim annotation As Annotation

instance.Remove(annotation)
public void Remove(
   Annotation annotation
)

Parameters

annotation
The Annotation to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AnnotationCollection Class
AnnotationCollection Class Properties

For a list of all members of this type, see AnnotationCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

AnnotationCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AnnotationCollection Class : Item Property
Item Property (AnnotationCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Annotation
'Usage

Dim instance As AnnotationCollection
Dim index As Integer
Dim value As Annotation

instance.Item(index) = value

value = instance.Item(index)
public Annotation this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AnnotationCollection Class
AnnotationCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Axis Class
Axis Class
Represents an axis drawn on a ChartArea.
Object Model
Axis ClassBackground ClassAxisTick ClassAxisTick ClassAxisTick ClassAxisTickCollection ClassAxisTick ClassLabel ClassElementMarker ClassLabelOverrideCollection ClassLabelOverride StructureLine ClassAxisLineBreaks ClassAxisMarkerCollection ClassAxisMarker ClassTimeIntervalAdvanced ClassCalendarPattern ClassLine ClassScaleRangeCollection ClassScaleRange ClassScaleRange ClassAxis.ScaleSync ClassAxis ClassLine ClassTimeIntervalAdvanced ClassAxis.TimeScaleLabelInfo ClassViewport ClassAxisTick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Axis
'Usage

Dim instance As Axis
public class Axis
Remarks
The axis object is a powerful class that does the following.
  • Defines objects used to draw the axis and fill sections of a ChartArea such as grid lines.
  • Facilitates tick label text formatting and numerous manipulation mechanisms.
  • Defines data element layout and order.
  • Defines an axis Scale, range, and tick frequency.
  • Calculates copies of itself that can perform unit conversions between over one thousand defined units, mark time ranges with a specified TimeInterval, and manipulate each tick label with a specified custom method.
Axes can behave in 3 different modes.
Mode | Description
Value Axis | The value axis dynamically displays a numeric or DateTime range. Properties such as Scale, Interval, TimeInterval and others that relate to ranges apply to this type of axis. Using ChartType.Combo, the y axis is a value axis, with ChartType.Horizontal the x axis is.
Label Axis | The label axis does not display a range of values but rather the names of elements or series. Using ChartType.Combo, the x axis is a label axis and with ChartType.Horizontal the y axis is. Using the DataEngine with DataEngine.DateGrouping generates elements with a numeric value in Element.YValue and a DateTime value in Element.XDateTime. Because the Combo chart's x axis is a label axis the date time value cannot be shown. To remedy this, the DataEngine also populates each element's Name property with a string representation of the DateTime value. This allows the x axis to show date values but it does not allow the use of advanced options such as setting the TimeInterval for those dates. To expose this functionality ChartType.Scatter must be used because the x axis for that chart type acts as a value axis.
Calculated Axis | A calculated or shadow axis is created by using of the Axis.Calculate methods and must be added to the Chart.AxisCollection collection. It is drawn by the original axis and represents the same range but displays it in a different way.
Example
Axis Orientation
Inheritance Hierarchy

System.Object
dotnetCHARTING.Axis

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Members
dotnetCHARTING Namespace

Tutorials

Axis Tutorials


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Axis Class
Axis Class Members

The following tables list the members exposed by Axis.

Public Constructors
 | Name | Description
Public Constructor | Axis Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AlternateGridBackground | Gets or sets a Background object used to fill the area between every other grid two grid lines.
Public Property | CenterTickMarks | Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label. (JS Charts) With JavaScript charts, range ticks, which include category scales can be centered by setting this option to true.
Public Property | ClearValues | Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.
Public Property | ClusterColumns | Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.
Public Property | CombinedElementsCalculation | Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.
Public Property | Crosshair | (JS Chart Only) Gets or sets an axis tick that follows the mouse cursor and invokes combined tooltips or if x crosshair is combined with y axis crosshair, the y axis will show multiple crosshairs for all point values at the given x position. Instantiate Crosshair property with an axis tick to enable.
Public Property | CultureName | Gets or sets the culture name used for number and date formatting in conjunction with FormatString.
Public Property | DefaultMinorTick | Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.
Public Property | DefaultTick | Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.
Public Property | ExtraTicks | A collection of AxisTick objects added to the axis.
Public Property | FormatString | Gets or sets the format string used by this axis.
Public Property | GaugeLabelMode | Gets or sets the GaugeLabelMode for axis ticks drawn on this axis when using gauges.
Public Property | GaugeNeedleType | Gets or sets the GaugeNeedleType used with this axis on gauges.
Public Property | GenerateElementTicks | Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.
Public Property | Interval | Gets or sets the numeric tick label interval for this axis.
Public Property | InvertScale | Gets or sets a value that indicates whether the axis scale is inverted.
Public Property | JsID | Gets or sets the ID of this axis used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Public Property | Label | Gets or sets the axis label.
Public Property | LabelMarker | Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.
Public Property | LabelOverrides | A collection of LabelOverride objects.
Public Property | LabelRotate | Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.
Public Property | Line | Gets or sets the axis Line.
Public Property | LineBreaks | (JS Charts only) Gets or sets options for visual axis line gaps at tick positions.
Public Property | LogarithmicBase | Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.
Public Property | Markers | A collection of AxisMarkers used to highlight sections of this axis.
Public Property | Maximum | Gets or sets the upper bounds of this numeric axis' range.
Public Property | Minimum | Gets or sets the lower bounds of this numeric axis' range.
Public Property | MinimumInterval | Gets or sets the numeric minimum interval value.
Public Property | MinorInterval | Gets or sets a numeric value that determines the interval of minor axis ticks.
Public Property | MinorTicksPerInterval | Gets or sets the number of minor axis ticks generated between major axis ticks.
Public Property | MinorTimeIntervalAdvanced | Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.
Public Property | Name | Gets or sets the name of this axis.
Public Property | NumberPrecision | Gets or sets the number of decimal digits of this axis' format.
Public Property | Orientation | Gets or sets the orientation of this axis.
Public Property | OrientationAngle | Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.
Public Property | OverlappingCircularLabelSeparator | Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.
Public Property | Percent | Gets or sets a value that indicates whether this axis displays percent values.
Public Property | Position | Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.
Public Property | RadarMode | Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.
Public Property | RangeAngle | Gets or sets an angle measured in degrees that is centered at the orientation angle.
Public Property | ReverseSeries | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.
Public Property | ReverseSeriesPositions | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Public Property | ReverseStack | Gets or sets a value that indicates whether the order of stacked elements is reversed.
Public Property | Scale | Gets or sets the scale of this axis.
Public Property | ScaleBreakCalendarPattern | Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.
Public Property | ScaleBreakLine | Gets or sets a Line object that is used to outline scale breaks on this axis.
Public Property | ScaleBreaks | A collection of ScaleRange objects that represent discontinuations in this axis' scale.
Public Property | ScaleBreakStyle | Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.
Public Property | ScaleRange | Gets or sets the scale's high and low values.
Public Property | ShowGrid | Gets or sets a value indicating whether grid lines are drawn.
Public Property | SmartMinorTicks | Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.
Public Property | SmartScaleBreak | Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.
Public Property | SmartScaleBreakLimit | Gets of sets the maximum number of scale breaks used when Axis.SmartScaleBreak = true.
Public Property | SpacingPercentage | Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
Public Property | StaticColumnWidth | Gets or sets the static bar width in pixels.
Public Property | SweepAngle | Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.
Public Property | SynchronizeScale | Gets a class that contains options to synchronize the scale of this axis with other scales.
Public Property | TickLabelAngle | Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.
Public Property | TickLabelMode | Gets or sets the label mode that specifies how tick labels behave.
Public Property | TickLabelPadding | Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.
Public Property | TickLabelSeparatorLine | Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.
Public Property | TickNumberMaximum | Gets or sets the maximum number of tick marks for numeric axis scales.
Public Property | TimeInterval | Gets or sets the time interval between tick labels when using the time scale.
Public Property | TimeIntervalAdvanced | Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.
Public Property | TimePadding | Gets or sets the time padding of this axis.
Public Property | TimeScaleLabels | Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.
Public Property | Viewport | Gets a ViewPort object that defines the visible scale range or zoom range when using AJAX scrolling. Setting the properties of this class allows zooming the chart programatically.
Public Property | ZeroTick | Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).
Top
Public Methods
 | Name | Description
Public Method | AddCalculatedTick | Overloaded. Adds an AxisTick with a value based on the specified Calculation.
Public Method | AddLabelOverride | Overloaded. Adds a LabelOverride to the LabelOverrides collection.
Public Method | Calculate | Overloaded. Obtains a copy instance of this Axis and processes it's tick values based on the specified method.
Public Method | Clear | Serves as a shortcut to hide this axis.
Public Method | GetCoordintates | Gets the coordinates of this axis after the chart is rendered.
Public Method | GetValueAtX | Returns the value of this X axis at the specified x/y coordinates.
Public Method | GetValueAtY | Returns the value of this Y axis at the specified x/y coordinates.
Top
See Also

Reference

Axis Class
dotnetCHARTING Namespace

Tutorials

Axis Tutorials


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class : Axis Constructor
Axis Constructor
Overload List
Overload | Description
Axis Constructor() | Initializes a new instance of the Axis class.
Axis Constructor(String) | Initializes a new instance of the Axis class with a name and label.
Axis Constructor(String,Scale) | Initializes a new instance of the Axis class with a name, label, and scale enumeration.
Axis Constructor(String,ChangeValueDelegate,Axis) | Initializes a new instance of the Axis class that will process the tick values of the specified axis based on a custom method.
Axis Constructor(String,Object,Object,Axis) | Initializes a new instance of the Axis class that will convert the tick labels of the specified axis to the specified units.
Axis Constructor(String,TimeInterval,Axis) | Initializes a new instance of the Axis class that will recalculate time intervals of the specified axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor()
Axis Constructor()
Initializes a new instance of the Axis class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Axis()
public Axis()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor(String)
Sets the name and label of this axis.
Axis Constructor(String)
Initializes a new instance of the Axis class with a name and label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New Axis(name)
public Axis(
   string name
)

Parameters

name
Sets the name and label of this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor(String,Scale)
Sets the name and label of this axis.
Sets the scale of this axis.
Axis Constructor(String,Scale)
Initializes a new instance of the Axis class with a name, label, and scale enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal scale As Scale _
)
'Usage

Dim name As String
Dim scale As Scale

Dim instance As New Axis(name, scale)
public Axis(
   string name,
   Scale scale
)

Parameters

name
Sets the name and label of this axis.
scale
Sets the scale of this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor(String,ChangeValueDelegate,Axis)
The name and label of this axis.
A delegate used to pass a custom method used for processing tick values.
The original axis whose tick labels will be processed.
Axis Constructor(String,ChangeValueDelegate,Axis)
Initializes a new instance of the Axis class that will process the tick values of the specified axis based on a custom method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal ChangeValue As ChangeValueDelegate, _
   ByVal axisToShadow As Axis _
)
'Usage

Dim name As String
Dim ChangeValue As ChangeValueDelegate
Dim axisToShadow As Axis

Dim instance As New Axis(name, ChangeValue, axisToShadow)
public Axis(
   string name,
   ChangeValueDelegate ChangeValue,
   Axis axisToShadow
)

Parameters

name
The name and label of this axis.
ChangeValue
A delegate used to pass a custom method used for processing tick values.
axisToShadow
The original axis whose tick labels will be processed.
Remarks
This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart, otherwise, the new instance will have no effect when added to Chart.AxisCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor(String,Object,Object,Axis)
The name and label of this axis.
Units representing the values of the original axis.
Units to convert to.
The original axis whose tick labels are converted.
Axis Constructor(String,Object,Object,Axis)
Initializes a new instance of the Axis class that will convert the tick labels of the specified axis to the specified units.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal fromUnit As Object, _
   ByVal toUnits As Object, _
   ByVal axisToShadow As Axis _
)
'Usage

Dim name As String
Dim fromUnit As Object
Dim toUnits As Object
Dim axisToShadow As Axis

Dim instance As New Axis(name, fromUnit, toUnits, axisToShadow)
public Axis(
   string name,
   object fromUnit,
   object toUnits,
   Axis axisToShadow
)

Parameters

name
The name and label of this axis.
fromUnit
Units representing the values of the original axis.
toUnits
Units to convert to.
axisToShadow
The original axis whose tick labels are converted.
Remarks
This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart, otherwise, the new instance will have no effect when added to Chart.AxisCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis Class > Axis Constructor : Axis Constructor(String,TimeInterval,Axis)
The name and label of this axis.
A TimeInterval enumaration that specifies the new TimeInterval for this axis.
An axis to derived from.
Axis Constructor(String,TimeInterval,Axis)
Initializes a new instance of the Axis class that will recalculate time intervals of the specified axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal timeInterval As TimeInterval, _
   ByVal axisToShadow As Axis _
)
'Usage

Dim name As String
Dim timeInterval As TimeInterval
Dim axisToShadow As Axis

Dim instance As New Axis(name, timeInterval, axisToShadow)
public Axis(
   string name,
   TimeInterval timeInterval,
   Axis axisToShadow
)

Parameters

name
The name and label of this axis.
timeInterval
A TimeInterval enumaration that specifies the new TimeInterval for this axis.
axisToShadow
An axis to derived from.
Remarks
This instance must be added to Chart.AxisCollection. The specified axis must appear on the chart and use Scale.Time, otherwise, the new instance will have no effect when added to Chart.AxisCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Axis Class
Axis Class Methods

For a list of all members of this type, see Axis members.

Public Methods
 | Name | Description
Public Method | AddCalculatedTick | Overloaded. Adds an AxisTick with a value based on the specified Calculation.
Public Method | AddLabelOverride | Overloaded. Adds a LabelOverride to the LabelOverrides collection.
Public Method | Calculate | Overloaded. Obtains a copy instance of this Axis and processes it's tick values based on the specified method.
Public Method | Clear | Serves as a shortcut to hide this axis.
Public Method | GetCoordintates | Gets the coordinates of this axis after the chart is rendered.
Public Method | GetValueAtX | Returns the value of this X axis at the specified x/y coordinates.
Public Method | GetValueAtY | Returns the value of this Y axis at the specified x/y coordinates.
Top
See Also

Reference

Axis Class
dotnetCHARTING Namespace

Tutorials

Axis Tutorials


dotnetCHARTING Namespace > Axis Class : AddCalculatedTick Method
AddCalculatedTick Method
Adds an AxisTick with a value based on the specified Calculation.
Overload List
Overload | Description
AddCalculatedTick(Calculation) | Adds an AxisTick with a value based on the specified Calculation.
AddCalculatedTick(Calculation,Series) | Adds an AxisTick with a value based on the specified Calculation.
AddCalculatedTick(Calculation,SeriesCollection) | Adds an AxisTick with a value based on the specified Calculation.
AddCalculatedTick(String,Calculation) | Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
AddCalculatedTick(String,Calculation,Series) | Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
AddCalculatedTick(String,Calculation,SeriesCollection) | Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(Calculation) Method
Calculation to perform.
AddCalculatedTick(Calculation) Method
Adds an AxisTick with a value based on the specified Calculation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal calculation As Calculation _
)
'Usage

Dim instance As Axis
Dim calculation As Calculation

instance.AddCalculatedTick(calculation)
public void AddCalculatedTick(
   Calculation calculation
)

Parameters

calculation
Calculation to perform.
Remarks
The calculation will be based on all the series using this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(Calculation,Series) Method
Calculation to perform.
Series to perform the calculation on.
AddCalculatedTick(Calculation,Series) Method
Adds an AxisTick with a value based on the specified Calculation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal calculation As Calculation, _
   ByVal series As Series _
)
'Usage

Dim instance As Axis
Dim calculation As Calculation
Dim series As Series

instance.AddCalculatedTick(calculation, series)
public void AddCalculatedTick(
   Calculation calculation,
   Series series
)

Parameters

calculation
Calculation to perform.
series
Series to perform the calculation on.
Remarks
The calculation will be based on the specified Series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(Calculation,SeriesCollection) Method
Calculation to perform.
SeriesCollection to perform the calculation on.
AddCalculatedTick(Calculation,SeriesCollection) Method
Adds an AxisTick with a value based on the specified Calculation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal calculation As Calculation, _
   ByVal series As SeriesCollection _
)
'Usage

Dim instance As Axis
Dim calculation As Calculation
Dim series As SeriesCollection

instance.AddCalculatedTick(calculation, series)
public void AddCalculatedTick(
   Calculation calculation,
   SeriesCollection series
)

Parameters

calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.
Remarks
The calculation will be based on the specified SeriesCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(String,Calculation) Method
A template for the resulting tick label.
Calculation to perform.
AddCalculatedTick(String,Calculation) Method
Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation _
)
'Usage

Dim instance As Axis
Dim labelTemplate As String
Dim calculation As Calculation

instance.AddCalculatedTick(labelTemplate, calculation)
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation
)

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
Remarks

The calculation will be based on all the series using this axis.

The %Value token in the template will be replaced with the resulting value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(String,Calculation,Series) Method
A template for the resulting tick label.
Calculation to perform.
Series to perform the calculation on.
AddCalculatedTick(String,Calculation,Series) Method
Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation, _
   ByVal series As Series _
)
'Usage

Dim instance As Axis
Dim labelTemplate As String
Dim calculation As Calculation
Dim series As Series

instance.AddCalculatedTick(labelTemplate, calculation, series)
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation,
   Series series
)

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
Series to perform the calculation on.
Remarks

The calculation will be based on the specified Series.

The %Value token in the template will be replaced with the resulting value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddCalculatedTick Method : AddCalculatedTick(String,Calculation,SeriesCollection) Method
A template for the resulting tick label.
Calculation to perform.
SeriesCollection to perform the calculation on.
AddCalculatedTick(String,Calculation,SeriesCollection) Method
Adds an AxisTick with a value based on the specified Calculation using a template for the resulting label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddCalculatedTick( _
   ByVal labelTemplate As String, _
   ByVal calculation As Calculation, _
   ByVal series As SeriesCollection _
)
'Usage

Dim instance As Axis
Dim labelTemplate As String
Dim calculation As Calculation
Dim series As SeriesCollection

instance.AddCalculatedTick(labelTemplate, calculation, series)
public void AddCalculatedTick(
   string labelTemplate,
   Calculation calculation,
   SeriesCollection series
)

Parameters

labelTemplate
A template for the resulting tick label.
calculation
Calculation to perform.
series
SeriesCollection to perform the calculation on.
Remarks

The calculation will be based on the specified SeriesCollection.

The %Value token in the template will be replaced with the resulting value.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class : AddLabelOverride Method
AddLabelOverride Method
Adds a LabelOverride to the LabelOverrides collection.
Overload List
Overload | Description
AddLabelOverride(String,String) | Adds a LabelOverride to the LabelOverrides collection.
AddLabelOverride(String,String,Boolean) | Adds a LabelOverride to the LabelOverrides collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class > AddLabelOverride Method : AddLabelOverride(String,String) Method
The string to look for.
The string to replace the key with.
AddLabelOverride(String,String) Method
Adds a LabelOverride to the LabelOverrides collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLabelOverride( _
   ByVal Key As String, _
   ByVal Value As String _
)
'Usage

Dim instance As Axis
Dim Key As String
Dim Value As String

instance.AddLabelOverride(Key, Value)
public void AddLabelOverride(
   string Key,
   string Value
)

Parameters

Key
The string to look for.
Value
The string to replace the key with.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > AddLabelOverride Method : AddLabelOverride(String,String,Boolean) Method
The string to look for.
The string to replace the key with.
A Boolean value indicating whether to ignore case for strings or convert the string to a number for comparison with the key so '0' will match '0.0'
AddLabelOverride(String,String,Boolean) Method
Adds a LabelOverride to the LabelOverrides collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLabelOverride( _
   ByVal Key As String, _
   ByVal Value As String, _
   ByVal IgnoreCase As Boolean _
)
'Usage

Dim instance As Axis
Dim Key As String
Dim Value As String
Dim IgnoreCase As Boolean

instance.AddLabelOverride(Key, Value, IgnoreCase)
public void AddLabelOverride(
   string Key,
   string Value,
   bool IgnoreCase
)

Parameters

Key
The string to look for.
Value
The string to replace the key with.
IgnoreCase
A Boolean value indicating whether to ignore case for strings or convert the string to a number for comparison with the key so '0' will match '0.0'
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class : Calculate Method
Calculate Method (Axis)
Obtains a copy instance of this Axis and processes it's tick values based on the specified method.
Overload List
Overload | Description
Calculate(String,ChangeValueDelegate) | Obtains a copy instance of this Axis and processes it's tick values based on the specified method.
Calculate(String,Object,Object) | Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.
Calculate(String,Object,Object,Boolean) | Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.
Calculate(String,TimeInterval) | Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.
Calculate(String,TimeIntervalAdvanced) | Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.
Calculate(String) | Creates a replica axis object that shadows this axis.
Calculate(String,Boolean) | Creates a replica axis object with a clear values option that shadows this axis.
Calculate(String,Boolean,Orientation) | Creates a replica axis object with an orientation and a value clearing option that shadows this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,ChangeValueDelegate) Method
Name of the new axis instance.
A ChangeValueDelegate pointing to a function that will process the tick labels of the new axis.
Calculate(String,ChangeValueDelegate) Method
Obtains a copy instance of this Axis and processes it's tick values based on the specified method.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal ChangeValue As ChangeValueDelegate _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim ChangeValue As ChangeValueDelegate
Dim value As Axis

value = instance.Calculate(name, ChangeValue)
public Axis Calculate(
   string name,
   ChangeValueDelegate ChangeValue
)

Parameters

name
Name of the new axis instance.
ChangeValue
A ChangeValueDelegate pointing to a function that will process the tick labels of the new axis.

Return Value

A new calculated instance of this axis which must be added to the Chart.AxisCollection collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,Object,Object) Method
Name of the new axis.
Units to convert from.
Units to convert to.
Calculate(String,Object,Object) Method
Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal convertFromUnit As Object, _
   ByVal convertToUnit As Object _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim convertFromUnit As Object
Dim convertToUnit As Object
Dim value As Axis

value = instance.Calculate(name, convertFromUnit, convertToUnit)
public Axis Calculate(
   string name,
   object convertFromUnit,
   object convertToUnit
)

Parameters

name
Name of the new axis.
convertFromUnit
Units to convert from.
convertToUnit
Units to convert to.

Return Value

A new calculated instance of this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,Object,Object,Boolean) Method
Name of the new axis.
Unit to convert from.
Unit to convert to.
If true, the axis ticks will not necessarily match the original ticks. They will have their own appropriate interval and be easier to read in many cases.
Calculate(String,Object,Object,Boolean) Method
Obtains a copy instance of this Axis and performs unit conversion for it's tick values based on the specified units.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal convertFromUnit As Object, _
   ByVal convertToUnit As Object, _
   ByVal refreshScale As Boolean _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim convertFromUnit As Object
Dim convertToUnit As Object
Dim refreshScale As Boolean
Dim value As Axis

value = instance.Calculate(name, convertFromUnit, convertToUnit, refreshScale)
public Axis Calculate(
   string name,
   object convertFromUnit,
   object convertToUnit,
   bool refreshScale
)

Parameters

name
Name of the new axis.
convertFromUnit
Unit to convert from.
convertToUnit
Unit to convert to.
refreshScale
If true, the axis ticks will not necessarily match the original ticks. They will have their own appropriate interval and be easier to read in many cases.

Return Value

A new calculated instance of this axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,TimeInterval) Method
Name of the derived axis.
A TimeInterval enumeration that specifies the new time interval for the resulting axis.
Calculate(String,TimeInterval) Method
Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal timeInterval As TimeInterval _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim timeInterval As TimeInterval
Dim value As Axis

value = instance.Calculate(name, timeInterval)
public Axis Calculate(
   string name,
   TimeInterval timeInterval
)

Parameters

name
Name of the derived axis.
timeInterval
A TimeInterval enumeration that specifies the new time interval for the resulting axis.

Return Value

A new instance of the calculated axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,TimeIntervalAdvanced) Method
Name of the derived axis.
A TimeIntervalAdvanced class that specifies the new time interval for the resulting axis.
Calculate(String,TimeIntervalAdvanced) Method
Obtains a copy instance of this Axis and recalculates it's tick values based a specified TimeInterval.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal timeIntervalAdvanced As TimeIntervalAdvanced _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim timeIntervalAdvanced As TimeIntervalAdvanced
Dim value As Axis

value = instance.Calculate(name, timeIntervalAdvanced)
public Axis Calculate(
   string name,
   TimeIntervalAdvanced timeIntervalAdvanced
)

Parameters

name
Name of the derived axis.
timeIntervalAdvanced
A TimeIntervalAdvanced class that specifies the new time interval for the resulting axis.

Return Value

A new instance of the calculated axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String) Method
Name of the resulting axis.
Calculate(String) Method
Creates a replica axis object that shadows this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim value As Axis

value = instance.Calculate(name)
public Axis Calculate(
   string name
)

Parameters

name
Name of the resulting axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,Boolean) Method
Name of the resulting axis.
Removes the original (automatically generated) axis ticks.
Calculate(String,Boolean) Method
Creates a replica axis object with a clear values option that shadows this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal clearValues As Boolean _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim clearValues As Boolean
Dim value As Axis

value = instance.Calculate(name, clearValues)
public Axis Calculate(
   string name,
   bool clearValues
)

Parameters

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class > Calculate Method : Calculate(String,Boolean,Orientation) Method
Name of the resulting axis.
Removes the original (automatically generated) axis ticks.
Orientation of the axis.
Calculate(String,Boolean,Orientation) Method
Creates a replica axis object with an orientation and a value clearing option that shadows this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal clearValues As Boolean, _
   ByVal axisOrientation As Orientation _
) As Axis
'Usage

Dim instance As Axis
Dim name As String
Dim clearValues As Boolean
Dim axisOrientation As Orientation
Dim value As Axis

value = instance.Calculate(name, clearValues, axisOrientation)
public Axis Calculate(
   string name,
   bool clearValues,
   Orientation axisOrientation
)

Parameters

name
Name of the resulting axis.
clearValues
Removes the original (automatically generated) axis ticks.
axisOrientation
Orientation of the axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Overload List


dotnetCHARTING Namespace > Axis Class : Clear Method
Clear Method (Axis)
Serves as a shortcut to hide this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
'Usage

Dim instance As Axis

instance.Clear()
public void Clear()
Remarks
The axis is cleared by setting the following properties:

            Axis.ClearValues = true;
            Axis.TickLine.Length = 0;
            Axis.Line.Color = Color.Empty;
            Axis.TickLabelPadding = 0;
            Axis.Label.Text = "";
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : GetCoordintates Method
GetCoordintates Method
Gets the coordinates of this axis after the chart is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetCoordintates() As Point()
'Usage

Dim instance As Axis
Dim value() As Point

value = instance.GetCoordintates()
public Point[] GetCoordintates()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : GetValueAtX Method
A string representing the coordinates of the image. For example: "100,230"
GetValueAtX Method
Returns the value of this X axis at the specified x/y coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValueAtX( _
   ByVal coordinates As String _
) As Object
'Usage

Dim instance As Axis
Dim coordinates As String
Dim value As Object

value = instance.GetValueAtX(coordinates)
public object GetValueAtX(
   string coordinates
)

Parameters

coordinates
A string representing the coordinates of the image. For example: "100,230"

Return Value

An object representing the value of the axis at the given position.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : GetValueAtY Method
A string representing the coordinates of the image. For example: "100,230"
GetValueAtY Method
Returns the value of this Y axis at the specified x/y coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValueAtY( _
   ByVal coordinates As String _
) As Object
'Usage

Dim instance As Axis
Dim coordinates As String
Dim value As Object

value = instance.GetValueAtY(coordinates)
public object GetValueAtY(
   string coordinates
)

Parameters

coordinates
A string representing the coordinates of the image. For example: "100,230"

Return Value

An object representing the value of the axis at the given position.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Axis Class
Axis Class Properties

For a list of all members of this type, see Axis members.

Public Properties
 | Name | Description
Public Property | AlternateGridBackground | Gets or sets a Background object used to fill the area between every other grid two grid lines.
Public Property | CenterTickMarks | Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label. (JS Charts) With JavaScript charts, range ticks, which include category scales can be centered by setting this option to true.
Public Property | ClearValues | Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.
Public Property | ClusterColumns | Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.
Public Property | CombinedElementsCalculation | Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.
Public Property | Crosshair | (JS Chart Only) Gets or sets an axis tick that follows the mouse cursor and invokes combined tooltips or if x crosshair is combined with y axis crosshair, the y axis will show multiple crosshairs for all point values at the given x position. Instantiate Crosshair property with an axis tick to enable.
Public Property | CultureName | Gets or sets the culture name used for number and date formatting in conjunction with FormatString.
Public Property | DefaultMinorTick | Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.
Public Property | DefaultTick | Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.
Public Property | ExtraTicks | A collection of AxisTick objects added to the axis.
Public Property | FormatString | Gets or sets the format string used by this axis.
Public Property | GaugeLabelMode | Gets or sets the GaugeLabelMode for axis ticks drawn on this axis when using gauges.
Public Property | GaugeNeedleType | Gets or sets the GaugeNeedleType used with this axis on gauges.
Public Property | GenerateElementTicks | Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.
Public Property | Interval | Gets or sets the numeric tick label interval for this axis.
Public Property | InvertScale | Gets or sets a value that indicates whether the axis scale is inverted.
Public Property | JsID | Gets or sets the ID of this axis used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Public Property | Label | Gets or sets the axis label.
Public Property | LabelMarker | Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.
Public Property | LabelOverrides | A collection of LabelOverride objects.
Public Property | LabelRotate | Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.
Public Property | Line | Gets or sets the axis Line.
Public Property | LineBreaks | (JS Charts only) Gets or sets options for visual axis line gaps at tick positions.
Public Property | LogarithmicBase | Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.
Public Property | Markers | A collection of AxisMarkers used to highlight sections of this axis.
Public Property | Maximum | Gets or sets the upper bounds of this numeric axis' range.
Public Property | Minimum | Gets or sets the lower bounds of this numeric axis' range.
Public Property | MinimumInterval | Gets or sets the numeric minimum interval value.
Public Property | MinorInterval | Gets or sets a numeric value that determines the interval of minor axis ticks.
Public Property | MinorTicksPerInterval | Gets or sets the number of minor axis ticks generated between major axis ticks.
Public Property | MinorTimeIntervalAdvanced | Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.
Public Property | Name | Gets or sets the name of this axis.
Public Property | NumberPrecision | Gets or sets the number of decimal digits of this axis' format.
Public Property | Orientation | Gets or sets the orientation of this axis.
Public Property | OrientationAngle | Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.
Public Property | OverlappingCircularLabelSeparator | Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.
Public Property | Percent | Gets or sets a value that indicates whether this axis displays percent values.
Public Property | Position | Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.
Public Property | RadarMode | Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.
Public Property | RangeAngle | Gets or sets an angle measured in degrees that is centered at the orientation angle.
Public Property | ReverseSeries | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.
Public Property | ReverseSeriesPositions | Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Public Property | ReverseStack | Gets or sets a value that indicates whether the order of stacked elements is reversed.
Public Property | Scale | Gets or sets the scale of this axis.
Public Property | ScaleBreakCalendarPattern | Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.
Public Property | ScaleBreakLine | Gets or sets a Line object that is used to outline scale breaks on this axis.
Public Property | ScaleBreaks | A collection of ScaleRange objects that represent discontinuations in this axis' scale.
Public Property | ScaleBreakStyle | Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.
Public Property | ScaleRange | Gets or sets the scale's high and low values.
Public Property | ShowGrid | Gets or sets a value indicating whether grid lines are drawn.
Public Property | SmartMinorTicks | Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.
Public Property | SmartScaleBreak | Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.
Public Property | SmartScaleBreakLimit | Gets of sets the maximum number of scale breaks used when Axis.SmartScaleBreak = true.
Public Property | SpacingPercentage | Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
Public Property | StaticColumnWidth | Gets or sets the static bar width in pixels.
Public Property | SweepAngle | Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.
Public Property | SynchronizeScale | Gets a class that contains options to synchronize the scale of this axis with other scales.
Public Property | TickLabelAngle | Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.
Public Property | TickLabelMode | Gets or sets the label mode that specifies how tick labels behave.
Public Property | TickLabelPadding | Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.
Public Property | TickLabelSeparatorLine | Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.
Public Property | TickNumberMaximum | Gets or sets the maximum number of tick marks for numeric axis scales.
Public Property | TimeInterval | Gets or sets the time interval between tick labels when using the time scale.
Public Property | TimeIntervalAdvanced | Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.
Public Property | TimePadding | Gets or sets the time padding of this axis.
Public Property | TimeScaleLabels | Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.
Public Property | Viewport | Gets a ViewPort object that defines the visible scale range or zoom range when using AJAX scrolling. Setting the properties of this class allows zooming the chart programatically.
Public Property | ZeroTick | Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).
Top
See Also

Reference

Axis Class
dotnetCHARTING Namespace

Tutorials

Axis Tutorials


dotnetCHARTING Namespace > Axis Class : AlternateGridBackground Property
AlternateGridBackground Property
Gets or sets a Background object used to fill the area between every other grid two grid lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AlternateGridBackground As Background
'Usage

Dim instance As Axis
Dim value As Background

instance.AlternateGridBackground = value

value = instance.AlternateGridBackground
public Background AlternateGridBackground {get; set;}

Property Value

A Background object that will fill every other grid area.
Remarks
To disable this feature, set AlternateGridBackground.Color = Color.Empty.
Example
AlternateGridBackground set to transparent
AxisHorizontalColorBands
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : CenterTickMarks Property
CenterTickMarks Property
Gets or sets a value that indicates whether axis ticks are centered above tick labels or drawn between each label. (JS Charts) With JavaScript charts, range ticks, which include category scales can be centered by setting this option to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CenterTickMarks As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.CenterTickMarks = value

value = instance.CenterTickMarks
public bool CenterTickMarks {get; set;}
Remarks
When false, Axis.DefaultTick.Line properties are used for all tick lines.
Example
Axis Tick Alignment
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : ClearValues Property
ClearValues Property
Gets or sets a value which indicates whether tick labels are cleared before LabelOverrides are applied.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClearValues As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ClearValues = value

value = instance.ClearValues
public bool ClearValues {get; set;}

Property Value

A boolean value which indicates whether tick labels are cleared before LabelOverrides are applied.
Remarks
Only the tick labels that are not overridden are cleared.
Example
Arbitrary Ticks (clears default ticks first)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : ClusterColumns Property
ClusterColumns Property
Gets or sets a value that indicates whether columns and cylinders are drawn side by side or front to back.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClusterColumns As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ClusterColumns = value

value = instance.ClusterColumns
public bool ClusterColumns {get; set;}

Property Value

A boolean value that indicates whether columns and cylinders are drawn side by side or front to back.
Remarks
(Applies to label axes) When true, columns and cylinders are drawn side by side.
Example
Gallery: A14
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Element Layout


dotnetCHARTING Namespace > Axis Class : CombinedElementsCalculation Property
CombinedElementsCalculation Property
Gets or sets the Calculation used when multiple elements on a quantitative x axis are located at the same x position. If the elements are columns they will be combined into a single element using this calculation, otherwise, the original elements are plotted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CombinedElementsCalculation As Calculation
'Usage

Dim instance As Axis
Dim value As Calculation

instance.CombinedElementsCalculation = value

value = instance.CombinedElementsCalculation
public Calculation CombinedElementsCalculation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : Crosshair Property
Crosshair Property
(JS Chart Only) Gets or sets an axis tick that follows the mouse cursor and invokes combined tooltips or if x crosshair is combined with y axis crosshair, the y axis will show multiple crosshairs for all point values at the given x position. Instantiate Crosshair property with an axis tick to enable.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Crosshair As AxisTick
'Usage

Dim instance As Axis
Dim value As AxisTick

instance.Crosshair = value

value = instance.Crosshair
public AxisTick Crosshair {get; set;}
Remarks
Use Chart.ToolTipTemplate to specify the combined tooltip text for crosshair tooltips.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : CultureName Property
CultureName Property (Axis)
Gets or sets the culture name used for number and date formatting in conjunction with FormatString.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CultureName As String
'Usage

Dim instance As Axis
Dim value As String

instance.CultureName = value

value = instance.CultureName
public string CultureName {get; set;}

Property Value

A string representing the culture name of this axis.
Remarks
The culture name is applied to tick values and data charted on this axis. See the System.Globalization.CultureInfo class for possible names of a culture.
(This property applies to value axes)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Formatting Values
Formatting Advanced


dotnetCHARTING Namespace > Axis Class : DefaultMinorTick Property
DefaultMinorTick Property
Gets or sets the default dotnetCHARTING.AxisTick used for all generated minor axis ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultMinorTick As AxisTick
'Usage

Dim instance As Axis
Dim value As AxisTick

instance.DefaultMinorTick = value

value = instance.DefaultMinorTick
public AxisTick DefaultMinorTick {get; set;}
Example
Axis Smart Minor Ticks Trick
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks
Minor Ticks


dotnetCHARTING Namespace > Axis Class : DefaultTick Property
DefaultTick Property
Gets or sets an AxisTick that acts as a vehicle for property settings that will propagate to all other axis ticks on this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultTick As AxisTick
'Usage

Dim instance As Axis
Dim value As AxisTick

instance.DefaultTick = value

value = instance.DefaultTick
public AxisTick DefaultTick {get; set;}
Remarks
The property settings of this object will not overwrite properties explicitly set for any given AxisTick.
Example
AxisTickToken
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : ExtraTicks Property
ExtraTicks Property
A collection of AxisTick objects added to the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExtraTicks As AxisTickCollection
'Usage

Dim instance As Axis
Dim value As AxisTickCollection

value = instance.ExtraTicks
public AxisTickCollection ExtraTicks {get;}
Example
Adding Arbitrary Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Axis Ticks


dotnetCHARTING Namespace > Axis Class : FormatString Property
FormatString Property (Axis)
Gets or sets the format string used by this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FormatString As String
'Usage

Dim instance As Axis
Dim value As String

instance.FormatString = value

value = instance.FormatString
public string FormatString {get; set;}

Property Value

A string representing the format used by values associated with this axis.
Remarks
Tick labels and labels of elements bound to this axis will be formatted with this format string.
(This property applies to value axes)
Example
ArbitraryTicks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Formatting Values
Formatting Advanced


dotnetCHARTING Namespace > Axis Class : GaugeLabelMode Property
GaugeLabelMode Property
Gets or sets the GaugeLabelMode for axis ticks drawn on this axis when using gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeLabelMode As GaugeLabelMode
'Usage

Dim instance As Axis
Dim value As GaugeLabelMode

instance.GaugeLabelMode = value

value = instance.GaugeLabelMode
public GaugeLabelMode GaugeLabelMode {get; set;}
Example
GaugeLabelMode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : GaugeNeedleType Property
GaugeNeedleType Property
Gets or sets the GaugeNeedleType used with this axis on gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeNeedleType As GaugeNeedleType
'Usage

Dim instance As Axis
Dim value As GaugeNeedleType

instance.GaugeNeedleType = value

value = instance.GaugeNeedleType
public GaugeNeedleType GaugeNeedleType {get; set;}
Example
Gauge Custom Needle
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : GenerateElementTicks Property
GenerateElementTicks Property
Gets or sets a value that indicates whether an AxisTick object is generated for each element's position on this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GenerateElementTicks As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.GenerateElementTicks = value

value = instance.GenerateElementTicks
public bool GenerateElementTicks {get; set;}
Example
Element Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : Interval Property
Interval Property
Gets or sets the numeric tick label interval for this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Interval As Double
'Usage

Dim instance As Axis
Dim value As Double

instance.Interval = value

value = instance.Interval
public double Interval {get; set;}

Property Value

A System.Double that specifies the numeric tick label interval for this axis.
Remarks
Tick labels will increment by this value starting at Axis.Minimum and ending at Axis.Maximum if specified. If not set, the interval is automatically determined based on the data range.

(Applies to quantitative axes with numeric scales)
Example
Gauge Clock
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : InvertScale Property
InvertScale Property
Gets or sets a value that indicates whether the axis scale is inverted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InvertScale As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.InvertScale = value

value = instance.InvertScale
public bool InvertScale {get; set;}
Remarks
When true the axis ticks will be reversed.
Example
Invert Scale
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : JsID Property
JsID Property (Axis)
Gets or sets the ID of this axis used in JavaScript charts. By specifying this ID, the axis can be referenced in JS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsID As String
'Usage

Dim instance As Axis
Dim value As String

instance.JsID = value

value = instance.JsID
public string JsID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : Label Property
Label Property (Axis)
Gets or sets the axis label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As Axis
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}

Property Value

The main Label of this axis.
Example
Axis Label Token
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Using Labels


dotnetCHARTING Namespace > Axis Class : LabelMarker Property
LabelMarker Property
Gets or sets an ElementMarker object used on gauge charts in place of the axis' label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelMarker As ElementMarker
'Usage

Dim instance As Axis
Dim value As ElementMarker

instance.LabelMarker = value

value = instance.LabelMarker
public ElementMarker LabelMarker {get; set;}
Remarks
The marker will be positioned between the needle base and the center of the gauge axis.
Example
Axis Tick Overrides (uses a label marker)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


Example

dotnetCHARTING Namespace > Axis Class : LabelOverrides Property
LabelOverrides Property
A collection of LabelOverride objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelOverrides As LabelOverrideCollection
'Usage

Dim instance As Axis
Dim value As LabelOverrideCollection

instance.LabelOverrides = value

value = instance.LabelOverrides
public LabelOverrideCollection LabelOverrides {get; set;}
Remarks
LabelOverrides defines a string find and replace pair used to manipulate tick labels.
Example
This example will replace each tick label value of '10' with 'High'.
  • C#
[C#]
Axis a = new Axis();
a.LabelOverrides.Add( new LabelOverride("10","High") );
  • C#
[Visual Basic]
Dim a As New Axis()
a.LabelOverrides.Add( new LabelOverride("10","High") )
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : LabelRotate Property
LabelRotate Property
Gets or sets a value which indicates whether the axis label of this y axis is facing the tick labels or is facing away.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelRotate As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.LabelRotate = value

value = instance.LabelRotate
public bool LabelRotate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : Line Property
Line Property (Axis)
Gets or sets the axis Line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As Axis
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}

Property Value

A Line object drawn across the axis.
Remarks
When the origin or 'point of zero' is visible on the axis, this line is drawn twice and away from the origin in order for line caps to appear correctly (Line.StartCap, Line.EndCap).
Example
Axis Caps
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : LineBreaks Property
LineBreaks Property
(JS Charts only) Gets or sets options for visual axis line gaps at tick positions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineBreaks As AxisLineBreaks
'Usage

Dim instance As Axis
Dim value As AxisLineBreaks

instance.LineBreaks = value

value = instance.LineBreaks
public AxisLineBreaks LineBreaks {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : LogarithmicBase Property
LogarithmicBase Property
Gets or sets the logarithmic base of logarithmic axis scales. Used only in conjunction with Logarithmic Scales.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LogarithmicBase As Double
'Usage

Dim instance As Axis
Dim value As Double

instance.LogarithmicBase = value

value = instance.LogarithmicBase
public double LogarithmicBase {get; set;}
Remarks
This property is used in conjunction with enumeration members Scale.Logarithmic and Scale.LogarithmicStacked.
Example
Axis Log Bases
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : Markers Property
Markers Property
A collection of AxisMarkers used to highlight sections of this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Markers As AxisMarkerCollection
'Usage

Dim instance As Axis
Dim value As AxisMarkerCollection

instance.Markers = value

value = instance.Markers
public AxisMarkerCollection Markers {get; set;}
Example
Axis Marker Advanced
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Markers


dotnetCHARTING Namespace > Axis Class : Maximum Property
Maximum Property
Gets or sets the upper bounds of this numeric axis' range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Maximum As Object
'Usage

Dim instance As Axis
Dim value As Object

instance.Maximum = value

value = instance.Maximum
public object Maximum {get; set;}

Property Value

A System.Double indicating the maximum value of this axis.
Remarks
Applies to value axes. When not specified, this value is set relative to the maximum range of the plotted data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : Minimum Property
Minimum Property
Gets or sets the lower bounds of this numeric axis' range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Minimum As Object
'Usage

Dim instance As Axis
Dim value As Object

instance.Minimum = value

value = instance.Minimum
public object Minimum {get; set;}

Property Value

A System.Double indicating the minimum value of this axis.
Remarks
Applies to value axes. When not specified, this value defaults to 0. When the range axis scale is used, it will be set relative to the minimum range of the plotted data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : MinimumInterval Property
MinimumInterval Property
Gets or sets the numeric minimum interval value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinimumInterval As Double
'Usage

Dim instance As Axis
Dim value As Double

instance.MinimumInterval = value

value = instance.MinimumInterval
public double MinimumInterval {get; set;}
Remarks
This allows you to prevent the axis scales from using intervals that are smaller than a single unit of your data. For example a chart showing votes where the maximum value is three may show intervals at .5, which cant represent any data for your chart. In this case setting this value to 1 will represent the chart data better.
Example
Axis Minimum Interval
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : MinorInterval Property
MinorInterval Property
Gets or sets a numeric value that determines the interval of minor axis ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorInterval As Double
'Usage

Dim instance As Axis
Dim value As Double

instance.MinorInterval = value

value = instance.MinorInterval
public double MinorInterval {get; set;}
Example
Axis Minor Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Minor Ticks


dotnetCHARTING Namespace > Axis Class : MinorTicksPerInterval Property
MinorTicksPerInterval Property
Gets or sets the number of minor axis ticks generated between major axis ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorTicksPerInterval As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.MinorTicksPerInterval = value

value = instance.MinorTicksPerInterval
public int MinorTicksPerInterval {get; set;}
Example
Gauge Linear Styled
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Minor Ticks

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : MinorTimeIntervalAdvanced Property
MinorTimeIntervalAdvanced Property
Gets or sets a TimeIntervalAdvanced object that determines the interval of minor axis ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinorTimeIntervalAdvanced As TimeIntervalAdvanced
'Usage

Dim instance As Axis
Dim value As TimeIntervalAdvanced

instance.MinorTimeIntervalAdvanced = value

value = instance.MinorTimeIntervalAdvanced
public TimeIntervalAdvanced MinorTimeIntervalAdvanced {get; set;}
Example
Axis Minor Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Minor Ticks


dotnetCHARTING Namespace > Axis Class : Name Property
Name Property (Axis)
Gets or sets the name of this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As Axis
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}

Property Value

A string representing the name of this axis.
Remarks
If Axis.Label.Text is not specified this value will be used. The name is also used to identify the axis with element or series tokens.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : NumberPrecision Property
NumberPrecision Property (Axis)
Gets or sets the number of decimal digits of this axis' format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumberPrecision As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.NumberPrecision = value

value = instance.NumberPrecision
public int NumberPrecision {get; set;}
Remarks
If not specified, this value will be determined automatically.
(Applies to value axes)
Example
Operator Calculations
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Formatting Values


dotnetCHARTING Namespace > Axis Class : Orientation Property
Orientation Property (Axis)
Gets or sets the orientation of this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As Orientation
'Usage

Dim instance As Axis
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public Orientation Orientation {get; set;}

Property Value

An Orientation enumeration which specifies on which side of a ChartArea the axis is rendered.
Example
Axis Orientation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : OrientationAngle Property
OrientationAngle Property
Gets or sets an angle measured in degrees clockwise from the y-axis specifying the direction a gauge axis is oriented.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OrientationAngle As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.OrientationAngle = value

value = instance.OrientationAngle
public int OrientationAngle {get; set;}
Remarks
When RangeAngle is set, the orientation is the point the middle of the axis is facing. When SweepAngle is set, the orientation is the starting angle of the sweep.
Example
Gauge Angles
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : OverlappingCircularLabelSeparator Property
OverlappingCircularLabelSeparator Property
Gets or sets a text label separator used when two axis ticks on a radar's x axis overlap.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverlappingCircularLabelSeparator As String
'Usage

Dim instance As Axis
Dim value As String

instance.OverlappingCircularLabelSeparator = value

value = instance.OverlappingCircularLabelSeparator
public string OverlappingCircularLabelSeparator {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : Percent Property
Percent Property
Gets or sets a value that indicates whether this axis displays percent values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Percent As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.Percent = value

value = instance.Percent
public bool Percent {get; set;}

Property Value

A Boolean value indicating whether this this axis displays percent values.
Remarks
When true, a percent sign sign will be added to the end of tick labels and the Maximum will snap to 100 percent if the plotted data's range falls between 50 and 100.

(Applies to value axes not using Scale.Time)
Example
Progress Bar
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : Position Property
Position Property (Axis)
Gets or sets the axis positions when 2 or more axes are drawn on the same side of a ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.Position = value

value = instance.Position
public int Position {get; set;}

Property Value

An integer specifying the position of the axis.
Remarks
Lower values will be drawn closer to the front. This will also affect the order of series bound the the axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : RadarMode Property
RadarMode Property
Gets or sets the RadarMode of this axis. Applies when this object is the x axis of a radar chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RadarMode As RadarMode
'Usage

Dim instance As Axis
Dim value As RadarMode

instance.RadarMode = value

value = instance.RadarMode
public RadarMode RadarMode {get; set;}
Example
Radar Mode
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : RangeAngle Property
RangeAngle Property
Gets or sets an angle measured in degrees that is centered at the orientation angle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RangeAngle As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.RangeAngle = value

value = instance.RangeAngle
public int RangeAngle {get; set;}
Remarks
Example: If the orientation angle is 100 and the range angle is 100, the axis will begin at 50 degrees and end at 150 degrees.
Example
Radar Angles
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : ReverseSeries Property
ReverseSeries Property
Gets or sets a value that indicates whether the positions of series bound to this axis are reversed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReverseSeries As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ReverseSeries = value

value = instance.ReverseSeries
public bool ReverseSeries {get; set;}

Property Value

A Boolean value that indicates whether the positions of series bound to this axis are reversed.
Remarks
(Applies to label axes)
Example
Manual Settings
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : ReverseSeriesPositions Property
ReverseSeriesPositions Property
Gets or sets a value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReverseSeriesPositions As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ReverseSeriesPositions = value

value = instance.ReverseSeriesPositions
public bool ReverseSeriesPositions {get; set;}

Property Value

A Boolean value that indicates whether the positions of series bound to this axis are reversed without reversing legend positions.
Remarks
Applies to label axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : ReverseStack Property
ReverseStack Property
Gets or sets a value that indicates whether the order of stacked elements is reversed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReverseStack As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ReverseStack = value

value = instance.ReverseStack
public bool ReverseStack {get; set;}

Property Value

A Boolean value that indicates whether the order of stacked elements is reversed.
Remarks
Applies to value axes using a stacked axis Scale.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : Scale Property
Scale Property
Gets or sets the scale of this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Scale As Scale
'Usage

Dim instance As Axis
Dim value As Scale

instance.Scale = value

value = instance.Scale
public Scale Scale {get; set;}

Property Value

The axis Scale.
Remarks
Applies to value axes.
Example
Axis Scale Range
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales
Elements And Axis Scales


dotnetCHARTING Namespace > Axis Class : ScaleBreakCalendarPattern Property
ScaleBreakCalendarPattern Property
Gets or sets a calendar pattern object that specifies the sequence of scale breaks on a time axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleBreakCalendarPattern As CalendarPattern
'Usage

Dim instance As Axis
Dim value As CalendarPattern

instance.ScaleBreakCalendarPattern = value

value = instance.ScaleBreakCalendarPattern
public CalendarPattern ScaleBreakCalendarPattern {get; set;}
Example
Scale Break Calendar Pattern
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales
Calendar Patterns


dotnetCHARTING Namespace > Axis Class : ScaleBreakLine Property
ScaleBreakLine Property
Gets or sets a Line object that is used to outline scale breaks on this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleBreakLine As Line
'Usage

Dim instance As Axis
Dim value As Line

instance.ScaleBreakLine = value

value = instance.ScaleBreakLine
public Line ScaleBreakLine {get; set;}
Example
Scale Break Styling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : ScaleBreaks Property
ScaleBreaks Property
A collection of ScaleRange objects that represent discontinuations in this axis' scale.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ScaleBreaks As ScaleRangeCollection
'Usage

Dim instance As Axis
Dim value As ScaleRangeCollection

value = instance.ScaleBreaks
public ScaleRangeCollection ScaleBreaks {get;}
Example
Axis Scale Breaks Manual
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : ScaleBreakStyle Property
ScaleBreakStyle Property
Gets or set a ScaleBreakStyle enumeration member that specifies the scale break style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleBreakStyle As ScaleBreakStyle
'Usage

Dim instance As Axis
Dim value As ScaleBreakStyle

instance.ScaleBreakStyle = value

value = instance.ScaleBreakStyle
public ScaleBreakStyle ScaleBreakStyle {get; set;}
Example
ScaleBreakStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : ScaleRange Property
ScaleRange Property (Axis)
Gets or sets the scale's high and low values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleRange As ScaleRange
'Usage

Dim instance As Axis
Dim value As ScaleRange

instance.ScaleRange = value

value = instance.ScaleRange
public ScaleRange ScaleRange {get; set;}
Example
Axis Scale Range
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : ShowGrid Property
ShowGrid Property
Gets or sets a value indicating whether grid lines are drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowGrid As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.ShowGrid = value

value = instance.ShowGrid
public bool ShowGrid {get; set;}

Property Value

A boolean value that indicates whether grid lines are drawn.
Remarks
If false, no grid lines will be drawn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : SmartMinorTicks Property
SmartMinorTicks Property
Gets or sets a value that indicates whether relevant minor axis ticks will be automatically determined based on major intervals.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartMinorTicks As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.SmartMinorTicks = value

value = instance.SmartMinorTicks
public bool SmartMinorTicks {get; set;}
Remarks
This property applies to automatic major intervals, not user defined intervals.
Example
Axis Smart Minor Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Minor Ticks

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : SmartScaleBreak Property
SmartScaleBreak Property
Gets or sets a value that indicates whether this axis will insert a discontinuity into it's scale if appropriate.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartScaleBreak As Boolean
'Usage

Dim instance As Axis
Dim value As Boolean

instance.SmartScaleBreak = value

value = instance.SmartScaleBreak
public bool SmartScaleBreak {get; set;}
Example
Axis Scale Breaks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : SmartScaleBreakLimit Property
SmartScaleBreakLimit Property
Gets of sets the maximum number of scale breaks used when Axis.SmartScaleBreak = true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartScaleBreakLimit As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.SmartScaleBreakLimit = value

value = instance.SmartScaleBreakLimit
public int SmartScaleBreakLimit {get; set;}
Example
Smart Scale Break Limit
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : SpacingPercentage Property
SpacingPercentage Property (Axis)
Gets or sets a percentage (0 - 100) which indicates the spacing between columns, cylinders or groups thereof.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SpacingPercentage As Single
'Usage

Dim instance As Axis
Dim value As Single

instance.SpacingPercentage = value

value = instance.SpacingPercentage
public float SpacingPercentage {get; set;}

Property Value

A System.Single value indicating the spacing percentage between columns, cylinders or groups thereof.
Remarks
(Applies to label axes)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property
StaticColumnWidth Property

KB

How to control the width of columns and cylinders.


dotnetCHARTING Namespace > Axis Class : StaticColumnWidth Property
StaticColumnWidth Property
Gets or sets the static bar width in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StaticColumnWidth As Single
'Usage

Dim instance As Axis
Dim value As Single

instance.StaticColumnWidth = value

value = instance.StaticColumnWidth
public float StaticColumnWidth {get; set;}

Property Value

A System.Single value indicating the static width of columns, cylinders or groups thereof.
Remarks
A value of 0 = Automatic and spacing will be based on the SpacingPercentage property.
(Applies to label axes)
Example
Bar Fixed Size
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

KB

How to control the width of columns and cylinders.


dotnetCHARTING Namespace > Axis Class : SweepAngle Property
SweepAngle Property
Gets or sets an angle measured in degrees clockwise from the OrientationAngle to the other side of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SweepAngle As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.SweepAngle = value

value = instance.SweepAngle
public int SweepAngle {get; set;}
Example
Gauge Angles
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : SynchronizeScale Property
SynchronizeScale Property
Gets a class that contains options to synchronize the scale of this axis with other scales.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SynchronizeScale As Axis.ScaleSync
'Usage

Dim instance As Axis
Dim value As Axis.ScaleSync

value = instance.SynchronizeScale
public Axis.ScaleSync SynchronizeScale {get;}
Example
Axis Scale Synchronization
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales
Scale Synchronization


dotnetCHARTING Namespace > Axis Class : TickLabelAngle Property
TickLabelAngle Property
Gets or sets the angle of axis tick labels when they are angled. Setting this property will not automatically angle tick labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickLabelAngle As Single
'Usage

Dim instance As Axis
Dim value As Single

instance.TickLabelAngle = value

value = instance.TickLabelAngle
public float TickLabelAngle {get; set;}
Remarks
To force tick label angles, set Axis.TickLabelMode = Axis.TickLabelMode.Angled.
Example
X Axis Label Angles
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
TickLabelMode Property
TickLabelMode Enumeration

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : TickLabelMode Property
TickLabelMode Property
Gets or sets the label mode that specifies how tick labels behave.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickLabelMode As TickLabelMode
'Usage

Dim instance As Axis
Dim value As TickLabelMode

instance.TickLabelMode = value

value = instance.TickLabelMode
public TickLabelMode TickLabelMode {get; set;}
Example
Tick Label Modes
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : TickLabelPadding Property
TickLabelPadding Property
Gets or sets a value in pixels indicating the padding between axis elements such as the axis label, tick labels, and ticks lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickLabelPadding As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.TickLabelPadding = value

value = instance.TickLabelPadding
public int TickLabelPadding {get; set;}

Property Value

An integer specifying the padding between axis elements.
Example
Axis Label Alignment
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : TickLabelSeparatorLine Property
TickLabelSeparatorLine Property
Gets or sets the a tick label separator. The separator is automatically used when labels are wrapped. To disable or enable, set the this line's color to Color.Transparent or a valid color respectively.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickLabelSeparatorLine As Line
'Usage

Dim instance As Axis
Dim value As Line

instance.TickLabelSeparatorLine = value

value = instance.TickLabelSeparatorLine
public Line TickLabelSeparatorLine {get; set;}
Example
Tick Separators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : TickNumberMaximum Property
TickNumberMaximum Property
Gets or sets the maximum number of tick marks for numeric axis scales.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TickNumberMaximum As Integer
'Usage

Dim instance As Axis
Dim value As Integer

instance.TickNumberMaximum = value

value = instance.TickNumberMaximum
public int TickNumberMaximum {get; set;}

Property Value

An integer specifying the maximum number of tick marks for this axis.
Remarks
. Three (3) is lowest number of tick marks possible.
(Applies to value axes with numeric scales). Applies to time scales in JavaScript charts as well.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


dotnetCHARTING Namespace > Axis Class : TimeInterval Property
TimeInterval Property (Axis)
Gets or sets the time interval between tick labels when using the time scale.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimeInterval As TimeInterval
'Usage

Dim instance As Axis
Dim value As TimeInterval

instance.TimeInterval = value

value = instance.TimeInterval
public TimeInterval TimeInterval {get; set;}

Property Value

A TimeInterval enumeration that specifies the time interval between tick labels when using the time scale.
Remarks
(Applies to quantitative axes using Scale.Time)
Example
Time Interval
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : TimeIntervalAdvanced Property
TimeIntervalAdvanced Property
Gets or sets a class that represents advanced time interval settings to supplement the TimeInterval property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimeIntervalAdvanced As TimeIntervalAdvanced
'Usage

Dim instance As Axis
Dim value As TimeIntervalAdvanced

instance.TimeIntervalAdvanced = value

value = instance.TimeIntervalAdvanced
public TimeIntervalAdvanced TimeIntervalAdvanced {get; set;}
Remarks
This property can be used in conjunction with TimeInterval or override it completley.
Example
Advanced Time Interval
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members
Axis Ticks

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : TimePadding Property
TimePadding Property
Gets or sets the time padding of this axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimePadding As TimeSpan
'Usage

Dim instance As Axis
Dim value As TimeSpan

instance.TimePadding = value

value = instance.TimePadding
public TimeSpan TimePadding {get; set;}

Property Value

A TimeSpan object indicating the amount of time shown before and after the plotted data.
Remarks
(Applies to value axes using Scale.Time)
Example
Financial DB
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Axis Class : TimeScaleLabels Property
TimeScaleLabels Property
Gets the TimeLabelAutomationInfo class that encapsulates axis ticks, format strings, and options of the Time Label Automation features used to represent particular instances in time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TimeScaleLabels As Axis.TimeScaleLabelInfo
'Usage

Dim instance As Axis
Dim value As Axis.TimeScaleLabelInfo

value = instance.TimeScaleLabels
public Axis.TimeScaleLabelInfo TimeScaleLabels {get;}
Example
Axis Smart Time Labels
Auto Time Range Labels
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Time Label Automation
Axis Scales


dotnetCHARTING Namespace > Axis Class : Viewport Property
Viewport Property
Gets a ViewPort object that defines the visible scale range or zoom range when using AJAX scrolling. Setting the properties of this class allows zooming the chart programatically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Viewport As Viewport
'Usage

Dim instance As Axis
Dim value As Viewport

value = instance.Viewport
public Viewport Viewport {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members


dotnetCHARTING Namespace > Axis Class : ZeroTick Property
ZeroTick Property
Gets or sets an AxisTick that replaces automatically generated axis tick with a value of zero (0).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZeroTick As AxisTick
'Usage

Dim instance As Axis
Dim value As AxisTick

instance.ZeroTick = value

value = instance.ZeroTick
public AxisTick ZeroTick {get; set;}
Remarks
This tick can be disabled by setting it to null or it can be overridden by adding a new AxisTick with a value of zero to the ExtraTicks collection. In order to disable the zero tick, set it to null: Axis.ZeroTick = null
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis Class
Axis Members

Tutorials

Axis Ticks


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Axis.ScaleSync Class
Axis.ScaleSync Class
An extension to the Axis.SynchronizeScale property. Defines the scale synchronization behavior of an axis.
Object Model
Axis.ScaleSync ClassAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Axis.ScaleSync
   Inherits AxisCollection
'Usage

Dim instance As Axis.ScaleSync
public class Axis.ScaleSync : AxisCollection
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.ScaleSync Members
dotnetCHARTING Namespace
SynchronizeScale Property


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Axis.ScaleSync Class
Axis.ScaleSync Class Members

The following tables list the members exposed by Axis.ScaleSync.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index. (Inherited from dotnetCHARTING.AxisCollection)
Public Property | Mode | Gets or sets the SynchronizeScaleMode of this scale sync class.
Public Property | PreserveScale | Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisCollection to this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Axis. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Axis in this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Insert | Inserts a Axis into this collection at a specified index. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Remove | Removes a specified Axis from this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

Axis.ScaleSync Class
dotnetCHARTING Namespace
SynchronizeScale Property


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Axis.ScaleSync Class
Axis.ScaleSync Class Properties

For a list of all members of this type, see Axis.ScaleSync members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index. (Inherited from dotnetCHARTING.AxisCollection)
Public Property | Mode | Gets or sets the SynchronizeScaleMode of this scale sync class.
Public Property | PreserveScale | Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.
Top
See Also

Reference

Axis.ScaleSync Class
dotnetCHARTING Namespace
SynchronizeScale Property


dotnetCHARTING Namespace > Axis.ScaleSync Class : Mode Property
Mode Property (Axis.ScaleSync)
Gets or sets the SynchronizeScaleMode of this scale sync class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As SynchronizeScaleMode
'Usage

Dim instance As Axis.ScaleSync
Dim value As SynchronizeScaleMode

instance.Mode = value

value = instance.Mode
public SynchronizeScaleMode Mode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.ScaleSync Class
Axis.ScaleSync Members


dotnetCHARTING Namespace > Axis.ScaleSync Class : PreserveScale Property
PreserveScale Property
Gets or sets a value that determines whether the axis scale will change when re-drawn on another ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreserveScale As Boolean
'Usage

Dim instance As Axis.ScaleSync
Dim value As Boolean

instance.PreserveScale = value

value = instance.PreserveScale
public bool PreserveScale {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.ScaleSync Class
Axis.ScaleSync Members


%%PageItemTitle%%

Members Example

dotnetCHARTING Namespace : Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Class
Encapsulates time scale label behavior options in addition to axis ticks and format strings used instead of the main axis ticks when they represent particular instances in time.
Object Model
Axis.TimeScaleLabelInfo ClassAxisTick ClassAxisTick ClassAxisTick ClassAxisTick ClassAxisTick ClassAxisTick ClassTimeIntervalCollection ClassTimeInterval EnumerationAxisTick ClassAxisTick ClassAxisTick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Axis.TimeScaleLabelInfo
'Usage

Dim instance As Axis.TimeScaleLabelInfo
public class Axis.TimeScaleLabelInfo
Example
  • C#

  • Visual Basic
    •

Inheritance Hierarchy
System.Object
   dotnetCHARTING.Axis.TimeScaleLabelInfo

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Axis.TimeScaleLabelInfo Members

dotnetCHARTING Namespace

Tutorial
Axis Time Label Automation

Formatting Values

Axis Ticks

Related Properties
TimeScaleLabels Property


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Class Members

The following tables list the members exposed by Axis.TimeScaleLabelInfo.

Public Constructors
 | Name | Description
Public Constructor | Axis.TimeScaleLabelInfo Constructor |
Top
Public Properties
 | Name | Description
Public Property | DayFormatString | Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.
Public Property | DayTick | Gets or sets the AxisTick used to represent the instance in time where the day changes.
Public Property | HourFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.
Public Property | HourTick | Gets or sets the AxisTick used to represent the instance in time where the hour changes.
Public Property | MaximumRangeRows | Gets of sets the maximum number or rows automatically generated range ticks will span.
Public Property | MillisecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.
Public Property | MillisecondTick | Gets or sets the axis tick used to represent the instance in time where the millisecond changes.
Public Property | MinuteFormatString | Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.
Public Property | MinuteTick | Gets or sets the AxisTick used to represent the instance in time where the minute changes.
Public Property | Mode | Gets or sets the time label automation mode for single value labels.
Public Property | MonthFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.
Public Property | MonthTick | Gets or sets the AxisTick used to represent the instance in time where the Month changes.
Public Property | PercentEdgeOverlapToRemoveTicks | Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.
Public Property | QuarterFormatString | Gets or sets the format string used with DateTime labels of quarter range ticks.
Public Property | QuarterTick | Gets or sets the AxisTick used to represent a year's quarter range ticks.
Public Property | RangeIntervals | Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.
Public Property | RangeMode | Gets or sets the time label automation mode for range value labels.
Public Property | SecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.
Public Property | SecondTick | Gets or sets the AxisTick used to represent the instance in time where the second changes.
Public Property | WeekFormatString | Gets or sets the format string used with DateTime labels of week range ticks.
Public Property | WeekTick | Gets or sets the AxisTick used to represent a week range ticks.
Public Property | YearFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.
Public Property | YearTick | Gets or sets the AxisTick used to represent the instance in time where the Year changes.
Top
See Also

Reference

Axis.TimeScaleLabelInfo Class
dotnetCHARTING Namespace

Tutorial

Axis Time Label Automation
Formatting Values
Axis Ticks

Related Properties

TimeScaleLabels Property


%%PageItemTitle%%

dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : Axis.TimeScaleLabelInfo Constructor
Axis.TimeScaleLabelInfo Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Axis.TimeScaleLabelInfo()
public Axis.TimeScaleLabelInfo()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Class Properties

For a list of all members of this type, see Axis.TimeScaleLabelInfo members.

Public Properties
 | Name | Description
Public Property | DayFormatString | Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.
Public Property | DayTick | Gets or sets the AxisTick used to represent the instance in time where the day changes.
Public Property | HourFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.
Public Property | HourTick | Gets or sets the AxisTick used to represent the instance in time where the hour changes.
Public Property | MaximumRangeRows | Gets of sets the maximum number or rows automatically generated range ticks will span.
Public Property | MillisecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.
Public Property | MillisecondTick | Gets or sets the axis tick used to represent the instance in time where the millisecond changes.
Public Property | MinuteFormatString | Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.
Public Property | MinuteTick | Gets or sets the AxisTick used to represent the instance in time where the minute changes.
Public Property | Mode | Gets or sets the time label automation mode for single value labels.
Public Property | MonthFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.
Public Property | MonthTick | Gets or sets the AxisTick used to represent the instance in time where the Month changes.
Public Property | PercentEdgeOverlapToRemoveTicks | Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.
Public Property | QuarterFormatString | Gets or sets the format string used with DateTime labels of quarter range ticks.
Public Property | QuarterTick | Gets or sets the AxisTick used to represent a year's quarter range ticks.
Public Property | RangeIntervals | Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.
Public Property | RangeMode | Gets or sets the time label automation mode for range value labels.
Public Property | SecondFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.
Public Property | SecondTick | Gets or sets the AxisTick used to represent the instance in time where the second changes.
Public Property | WeekFormatString | Gets or sets the format string used with DateTime labels of week range ticks.
Public Property | WeekTick | Gets or sets the AxisTick used to represent a week range ticks.
Public Property | YearFormatString | Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.
Public Property | YearTick | Gets or sets the AxisTick used to represent the instance in time where the Year changes.
Top
See Also

Reference

Axis.TimeScaleLabelInfo Class
dotnetCHARTING Namespace

Tutorial

Axis Time Label Automation
Formatting Values
Axis Ticks

Related Properties

TimeScaleLabels Property


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : DayFormatString Property
DayFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time wher%%%(Shortcut to: Element.Hotspot.URL)e the day changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DayFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.DayFormatString = value

value = instance.DayFormatString
public string DayFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : DayTick Property
DayTick Property
Gets or sets the AxisTick used to represent the instance in time where the day changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DayTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.DayTick = value

value = instance.DayTick
public AxisTick DayTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : HourFormatString Property
HourFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time where the hour changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HourFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.HourFormatString = value

value = instance.HourFormatString
public string HourFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : HourTick Property
HourTick Property
Gets or sets the AxisTick used to represent the instance in time where the hour changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HourTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.HourTick = value

value = instance.HourTick
public AxisTick HourTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MaximumRangeRows Property
MaximumRangeRows Property
Gets of sets the maximum number or rows automatically generated range ticks will span.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumRangeRows As Integer
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As Integer

instance.MaximumRangeRows = value

value = instance.MaximumRangeRows
public int MaximumRangeRows {get; set;}
Example
AutoTimeRangeRowLimit
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MillisecondFormatString Property
MillisecondFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time where the millisecond changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MillisecondFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.MillisecondFormatString = value

value = instance.MillisecondFormatString
public string MillisecondFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MillisecondTick Property
MillisecondTick Property
Gets or sets the axis tick used to represent the instance in time where the millisecond changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MillisecondTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.MillisecondTick = value

value = instance.MillisecondTick
public AxisTick MillisecondTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MinuteFormatString Property
MinuteFormatString Property
Gets or sets the format string used with DateTimevalues that represent the instance in time where the minute changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinuteFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.MinuteFormatString = value

value = instance.MinuteFormatString
public string MinuteFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MinuteTick Property
MinuteTick Property
Gets or sets the AxisTick used to represent the instance in time where the minute changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinuteTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.MinuteTick = value

value = instance.MinuteTick
public AxisTick MinuteTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : Mode Property
Mode Property (Axis.TimeScaleLabelInfo)
Gets or sets the time label automation mode for single value labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As TimeScaleLabelMode
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As TimeScaleLabelMode

instance.Mode = value

value = instance.Mode
public TimeScaleLabelMode Mode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members

Tutorial

Axis Time Label Automation


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MonthFormatString Property
MonthFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time where the Month changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MonthFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.MonthFormatString = value

value = instance.MonthFormatString
public string MonthFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : MonthTick Property
MonthTick Property
Gets or sets the AxisTick used to represent the instance in time where the Month changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MonthTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.MonthTick = value

value = instance.MonthTick
public AxisTick MonthTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : PercentEdgeOverlapToRemoveTicks Property
PercentEdgeOverlapToRemoveTicks Property
Gets or sets a value that indicates whether auto-generated range ticks are trimmed if more than the specified percentage of the label lingers outside of the axis bounds.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PercentEdgeOverlapToRemoveTicks As Integer
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As Integer

instance.PercentEdgeOverlapToRemoveTicks = value

value = instance.PercentEdgeOverlapToRemoveTicks
public int PercentEdgeOverlapToRemoveTicks {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : QuarterFormatString Property
QuarterFormatString Property
Gets or sets the format string used with DateTime labels of quarter range ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuarterFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.QuarterFormatString = value

value = instance.QuarterFormatString
public string QuarterFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : QuarterTick Property
QuarterTick Property
Gets or sets the AxisTick used to represent a year's quarter range ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuarterTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.QuarterTick = value

value = instance.QuarterTick
public AxisTick QuarterTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : RangeIntervals Property
RangeIntervals Property
Gets or sets an TimeIntervalCollection used with modes Range and AddRange. When no intervals are specified the intervals will be determined dynamically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RangeIntervals As TimeIntervalCollection
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As TimeIntervalCollection

instance.RangeIntervals = value

value = instance.RangeIntervals
public TimeIntervalCollection RangeIntervals {get; set;}
Example
AutoTimeRangeRowLimit
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : RangeMode Property
RangeMode Property
Gets or sets the time label automation mode for range value labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RangeMode As TimeScaleLabelRangeMode
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As TimeScaleLabelRangeMode

instance.RangeMode = value

value = instance.RangeMode
public TimeScaleLabelRangeMode RangeMode {get; set;}
Example
On Off Chart
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members

Tutorial

Axis Time Label Automation


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : SecondFormatString Property
SecondFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time where the second changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecondFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.SecondFormatString = value

value = instance.SecondFormatString
public string SecondFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : SecondTick Property
SecondTick Property
Gets or sets the AxisTick used to represent the instance in time where the second changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecondTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.SecondTick = value

value = instance.SecondTick
public AxisTick SecondTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : WeekFormatString Property
WeekFormatString Property
Gets or sets the format string used with DateTime labels of week range ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WeekFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.WeekFormatString = value

value = instance.WeekFormatString
public string WeekFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : WeekTick Property
WeekTick Property
Gets or sets the AxisTick used to represent a week range ticks.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WeekTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.WeekTick = value

value = instance.WeekTick
public AxisTick WeekTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : YearFormatString Property
YearFormatString Property
Gets or sets the format string used with DateTime values that represent the instance in time where the year changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YearFormatString As String
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As String

instance.YearFormatString = value

value = instance.YearFormatString
public string YearFormatString {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


dotnetCHARTING Namespace > Axis.TimeScaleLabelInfo Class : YearTick Property
YearTick Property
Gets or sets the AxisTick used to represent the instance in time where the Year changes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YearTick As AxisTick
'Usage

Dim instance As Axis.TimeScaleLabelInfo
Dim value As AxisTick

instance.YearTick = value

value = instance.YearTick
public AxisTick YearTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Axis.TimeScaleLabelInfo Class
Axis.TimeScaleLabelInfo Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisCollection Class
AxisCollection Class
Contains a collection of Axis objects.
Object Model
AxisCollection ClassAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As AxisCollection
public class AxisCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AxisCollection Class
AxisCollection Class Members

The following tables list the members exposed by AxisCollection.

Public Constructors
 | Name | Description
Public Constructor | AxisCollection Constructor | Creates a new instance of AxisCollection with the specified list of Axis objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Axis.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Axis in this collection.
Public Method | Insert | Inserts a Axis into this collection at a specified index.
Public Method | Remove | Removes a specified Axis from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisCollection Class : AxisCollection Constructor
AxisCollection Constructor
Creates a new instance of AxisCollection with the specified list of Axis objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray axisList() As Axis _
)
'Usage

Dim axisList() As Axis

Dim instance As New AxisCollection(axisList)
public AxisCollection(
   params Axis[] axisList
)

Parameters

axisList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AxisCollection Class
AxisCollection Class Methods

For a list of all members of this type, see AxisCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Axis.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Axis in this collection.
Public Method | Insert | Inserts a Axis into this collection at a specified index.
Public Method | Remove | Removes a specified Axis from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisCollection Class : Add Method
Add Method (AxisCollection)
Adds a specified AxisCollection to this collection.
Overload List
Overload | Description
Add(Axis) |
Add(AxisCollection) | Adds a specified AxisCollection to this collection.
Add(Axis[]) | Adds the specified AxisMarker objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


dotnetCHARTING Namespace > AxisCollection Class > Add Method : Add(Axis) Method
Add(Axis) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal axis As Axis _
) As Integer
'Usage

Dim instance As AxisCollection
Dim axis As Axis
Dim value As Integer

value = instance.Add(axis)
public int Add(
   Axis axis
)

Parameters

axis
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members
Overload List


dotnetCHARTING Namespace > AxisCollection Class > Add Method : Add(AxisCollection) Method
The AxisCollection to add.
Add(AxisCollection) Method
Adds a specified AxisCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal axisCollection As AxisCollection _
)
'Usage

Dim instance As AxisCollection
Dim axisCollection As AxisCollection

instance.Add(axisCollection)
public void Add(
   AxisCollection axisCollection
)

Parameters

axisCollection
The AxisCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members
Overload List


dotnetCHARTING Namespace > AxisCollection Class > Add Method : Add(Axis[]) Method
A list of AxisMarker objects to add.
Add(Axis[]) Method
Adds the specified AxisMarker objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray axisList() As Axis _
)
'Usage

Dim instance As AxisCollection
Dim axisList() As Axis

instance.Add(axisList)
public void Add(
   params Axis[] axisList
)

Parameters

axisList
A list of AxisMarker objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members
Overload List


dotnetCHARTING Namespace > AxisCollection Class : Contains Method
The Axis to find.
Contains Method (AxisCollection)
Determines whether this collection contains a specified Axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal axis As Axis _
) As Boolean
'Usage

Dim instance As AxisCollection
Dim axis As Axis
Dim value As Boolean

value = instance.Contains(axis)
public bool Contains(
   Axis axis
)

Parameters

axis
The Axis to find.

Return Value

true if the specified Axis belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


dotnetCHARTING Namespace > AxisCollection Class : IndexOf Method
The Axis to find.
IndexOf Method (AxisCollection)
Determines the index of a specified Axis in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal axis As Axis _
) As Integer
'Usage

Dim instance As AxisCollection
Dim axis As Axis
Dim value As Integer

value = instance.IndexOf(axis)
public int IndexOf(
   Axis axis
)

Parameters

axis
The Axis to find.

Return Value

The zero-based index of the specified Axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


dotnetCHARTING Namespace > AxisCollection Class : Insert Method
The zero-based index into the collection at which to insert the Axis.
The Axis to insert into this collection.
Insert Method (AxisCollection)
Inserts a Axis into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axis As Axis _
)
'Usage

Dim instance As AxisCollection
Dim index As Integer
Dim axis As Axis

instance.Insert(index, axis)
public void Insert(
   int index,
   Axis axis
)

Parameters

index
The zero-based index into the collection at which to insert the Axis.
axis
The Axis to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


dotnetCHARTING Namespace > AxisCollection Class : Remove Method
The Axis to remove.
Remove Method (AxisCollection)
Removes a specified Axis from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal axis As Axis _
)
'Usage

Dim instance As AxisCollection
Dim axis As Axis

instance.Remove(axis)
public void Remove(
   Axis axis
)

Parameters

axis
The Axis to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisCollection Class
AxisCollection Class Properties

For a list of all members of this type, see AxisCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

AxisCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisCollection Class : Item Property
Item Property (AxisCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Axis
'Usage

Dim instance As AxisCollection
Dim index As Integer
Dim value As Axis

instance.Item(index) = value

value = instance.Item(index)
public Axis this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisCollection Class
AxisCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisLineBreaks Class
AxisLineBreaks Class
Encompases axis line breaks options that produce gaps in the line at axisTick positions.
Object Model
AxisLineBreaks Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisLineBreaks
'Usage

Dim instance As AxisLineBreaks
public class AxisLineBreaks
Inheritance Hierarchy

System.Object
dotnetCHARTING.AxisLineBreaks

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : AxisLineBreaks Class
AxisLineBreaks Class Members

The following tables list the members exposed by AxisLineBreaks.

Public Constructors
 | Name | Description
Public Constructor | AxisLineBreaks Constructor |
Top
Public Properties
 | Name | Description
Public Property | Custom | Gets or sets an array of values between 0 and 1 that are used to specify gap positions instead of axisTick positions.
Public Property | Enabled | Gets or sets whether axis line breaks are enabled.
Public Property | Gap | Gets or sets a value between 0 and 1 that specifies the gap amount.
Public Property | Invert | Gets or sets a value that reverses gaps and lines.
Top
See Also

Reference

AxisLineBreaks Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisLineBreaks Class : AxisLineBreaks Constructor
AxisLineBreaks Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New AxisLineBreaks()
public AxisLineBreaks()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Class
AxisLineBreaks Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisLineBreaks Class
AxisLineBreaks Class Properties

For a list of all members of this type, see AxisLineBreaks members.

Public Properties
 | Name | Description
Public Property | Custom | Gets or sets an array of values between 0 and 1 that are used to specify gap positions instead of axisTick positions.
Public Property | Enabled | Gets or sets whether axis line breaks are enabled.
Public Property | Gap | Gets or sets a value between 0 and 1 that specifies the gap amount.
Public Property | Invert | Gets or sets a value that reverses gaps and lines.
Top
See Also

Reference

AxisLineBreaks Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisLineBreaks Class : Custom Property
Custom Property (AxisLineBreaks)
Gets or sets an array of values between 0 and 1 that are used to specify gap positions instead of axisTick positions.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Custom As Double()
'Usage

Dim instance As AxisLineBreaks
Dim value() As Double

instance.Custom = value

value = instance.Custom
public double[] Custom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Class
AxisLineBreaks Members


dotnetCHARTING Namespace > AxisLineBreaks Class : Enabled Property
Enabled Property (AxisLineBreaks)
Gets or sets whether axis line breaks are enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As AxisLineBreaks
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Class
AxisLineBreaks Members


dotnetCHARTING Namespace > AxisLineBreaks Class : Gap Property
Gap Property
Gets or sets a value between 0 and 1 that specifies the gap amount.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Gap As Double
'Usage

Dim instance As AxisLineBreaks
Dim value As Double

instance.Gap = value

value = instance.Gap
public double Gap {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Class
AxisLineBreaks Members


dotnetCHARTING Namespace > AxisLineBreaks Class : Invert Property
Invert Property
Gets or sets a value that reverses gaps and lines.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Invert As Boolean
'Usage

Dim instance As AxisLineBreaks
Dim value As Boolean

instance.Invert = value

value = instance.Invert
public bool Invert {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisLineBreaks Class
AxisLineBreaks Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisMarker Class
AxisMarker Class
Defines styles and positions used to mark a specified section or point on an axis.
Object Model
AxisMarker ClassBackground ClassCalendarPattern ClassLabel ClassLegendEntry ClassLine ClassAxisTick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisMarker
   Inherits ScaleRange
'Usage

Dim instance As AxisMarker
public class AxisMarker : ScaleRange
Remarks
Each marker displayed on the chart will also have a LegendEntry in the Chart.LegendBox.

There are two ways to use AxisMarkers.
  1. Attach to axis
    An AxisMarker can be added to the Axis.Markers collection of any axis. In this case, a numeric, time, or text: value or range must be specified.

    When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
  2. Attach to element
    An AxisMarker is instantiated and passed to the Element.AxisMarker property of any element. In such a case, the axis marker is drawn on the Axis where the element's name is displayed.

See sample 'AxisMarkerAdvanced.aspx' in the download.

Example
Axis Marker Sample
Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Members
dotnetCHARTING Namespace

Tutorials

Axis Marker


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AxisMarker Class
AxisMarker Class Members

The following tables list the members exposed by AxisMarker.

Public Constructors
 | Name | Description
Public Constructor | AxisMarker Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.
Public Property | BringToFront | Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.
Public Property | CalendarPattern | Gets or set a CalendarPattern used by this axis marker instead of the range values.
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | Label | Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.
Public Property | LegendEntry | Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.
Public Property | Line | Gets or sets a Line object drawn on a ChartArea.
Public Property | Tick | Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.
Public Property | Value | Overridden. Gets or sets the numeric, DateTime, or text value of this AxisMarker.
Public Property | ValueHigh | Overridden. Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property | ValueLow | Overridden. Gets or sets the lower bounds of a numeric, DateTime, or text range.
Top
Public Methods
 | Name | Description
Public Method | ToString | (Inherited from dotnetCHARTING.ScaleRange)
Top
See Also

Reference

AxisMarker Class
dotnetCHARTING Namespace

Tutorials

Axis Marker


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class : AxisMarker Constructor
AxisMarker Constructor
Overload List
Overload | Description
AxisMarker Constructor() | Initialize a new instance of the AxisMarker class.
AxisMarker Constructor(String,Background) | Initialize a new instance of the AxisMarker class with a label and Background.
AxisMarker Constructor(String,Background,Object,Object) | Initialize a new instance of the AxisMarker class with a label, Background object, and axis range.
AxisMarker Constructor(String,Background,CalendarPattern) | Initialize a new instance of the AxisMarker class with a label, Background object, and calendar pattern.
AxisMarker Constructor(String,Color,Object,Object) | Initialize a new instance of the AxisMarker class with a label, colort, and axis range.
AxisMarker Constructor(String,Color,CalendarPattern) | Initialize a new instance of the AxisMarker class with a label, colort, and axis range.
AxisMarker Constructor(String,Line,Object) | Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..
AxisMarker Constructor(String,Color,Object) | Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor()
AxisMarker Constructor()
Initialize a new instance of the AxisMarker class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New AxisMarker()
public AxisMarker()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Background)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
Background which fills the an area of the chart within a specified range.
AxisMarker Constructor(String,Background)
Initialize a new instance of the AxisMarker class with a label and Background.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal bg As Background _
)
'Usage

Dim label As String
Dim bg As Background

Dim instance As New AxisMarker(label, bg)
public AxisMarker(
   string label,
   Background bg
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within a specified range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Background,Object,Object)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
Background which fills the an area of the chart within the specified range.
Numeric, DateTime, or Text low axis range.
Numeric, DateTime, or Text high axis range..
AxisMarker Constructor(String,Background,Object,Object)
Initialize a new instance of the AxisMarker class with a label, Background object, and axis range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal bg As Background, _
   ByVal valueLow As Object, _
   ByVal valueHigh As Object _
)
'Usage

Dim label As String
Dim bg As Background
Dim valueLow As Object
Dim valueHigh As Object

Dim instance As New AxisMarker(label, bg, valueLow, valueHigh)
public AxisMarker(
   string label,
   Background bg,
   object valueLow,
   object valueHigh
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Background,CalendarPattern)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
Background which fills the an area of the chart within the specified range.
CalendarPattern of this axis marker.
AxisMarker Constructor(String,Background,CalendarPattern)
Initialize a new instance of the AxisMarker class with a label, Background object, and calendar pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal bg As Background, _
   ByVal calendarPattern As CalendarPattern _
)
'Usage

Dim label As String
Dim bg As Background
Dim calendarPattern As CalendarPattern

Dim instance As New AxisMarker(label, bg, calendarPattern)
public AxisMarker(
   string label,
   Background bg,
   CalendarPattern calendarPattern
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
bg
Background which fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Color,Object,Object)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
The color that fills the an area of the chart within the specified range.
Numeric, DateTime, or Text low axis range.
Numeric, DateTime, or Text high axis range..
AxisMarker Constructor(String,Color,Object,Object)
Initialize a new instance of the AxisMarker class with a label, colort, and axis range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal col As Color, _
   ByVal valueLow As Object, _
   ByVal valueHigh As Object _
)
'Usage

Dim label As String
Dim col As Color
Dim valueLow As Object
Dim valueHigh As Object

Dim instance As New AxisMarker(label, col, valueLow, valueHigh)
public AxisMarker(
   string label,
   Color col,
   object valueLow,
   object valueHigh
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
valueLow
Numeric, DateTime, or Text low axis range.
valueHigh
Numeric, DateTime, or Text high axis range..
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Color,CalendarPattern)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
The color that fills the an area of the chart within the specified range.
CalendarPattern of this axis marker.
AxisMarker Constructor(String,Color,CalendarPattern)
Initialize a new instance of the AxisMarker class with a label, colort, and axis range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal col As Color, _
   ByVal calendarPattern As CalendarPattern _
)
'Usage

Dim label As String
Dim col As Color
Dim calendarPattern As CalendarPattern

Dim instance As New AxisMarker(label, col, calendarPattern)
public AxisMarker(
   string label,
   Color col,
   CalendarPattern calendarPattern
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
col
The color that fills the an area of the chart within the specified range.
calendarPattern
CalendarPattern of this axis marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Line,Object)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
Line to draw at the specified position.
Numeric, DateTime, or Text value representing a point on an axis.
AxisMarker Constructor(String,Line,Object)
Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal line As Line, _
   ByVal myValue As Object _
)
'Usage

Dim label As String
Dim line As Line
Dim myValue As Object

Dim instance As New AxisMarker(label, line, myValue)
public AxisMarker(
   string label,
   Line line,
   object myValue
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
line
Line to draw at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarker Class > AxisMarker Constructor : AxisMarker Constructor(String,Color,Object)
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
The color used to draw line at the specified position.
Numeric, DateTime, or Text value representing a point on an axis.
AxisMarker Constructor(String,Color,Object)
Initialize a new instance of the AxisMarker class with a label, Background object, and a numeric or time value representing a point on an axis..
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As String, _
   ByVal lineColor As Color, _
   ByVal myValue As Object _
)
'Usage

Dim label As String
Dim lineColor As Color
Dim myValue As Object

Dim instance As New AxisMarker(label, lineColor, myValue)
public AxisMarker(
   string label,
   Color lineColor,
   object myValue
)

Parameters

label
The Label drawn on the marker. The label trickles down to this AxisMarker object's LegendEntry.Name property unless one explicitly specified.
lineColor
The color used to draw line at the specified position.
myValue
Numeric, DateTime, or Text value representing a point on an axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisMarker Class
AxisMarker Class Properties

For a list of all members of this type, see AxisMarker members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.
Public Property | BringToFront | Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.
Public Property | CalendarPattern | Gets or set a CalendarPattern used by this axis marker instead of the range values.
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | Label | Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.
Public Property | LegendEntry | Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.
Public Property | Line | Gets or sets a Line object drawn on a ChartArea.
Public Property | Tick | Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.
Public Property | Value | Overridden. Gets or sets the numeric, DateTime, or text value of this AxisMarker.
Public Property | ValueHigh | Overridden. Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property | ValueLow | Overridden. Gets or sets the lower bounds of a numeric, DateTime, or text range.
Top
See Also

Reference

AxisMarker Class
dotnetCHARTING Namespace

Tutorials

Axis Marker


dotnetCHARTING Namespace > AxisMarker Class : Background Property
Background Property (AxisMarker)
Gets or sets a Background object used to fill this AxisMarker object's range on a ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As AxisMarker
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Example
Axis Horizontal Color Bands
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : BringToFront Property
BringToFront Property
Gets or sets a value that indicates whether the AxisMarker is drawn in front of the chart data while in 2D mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BringToFront As Boolean
'Usage

Dim instance As AxisMarker
Dim value As Boolean

instance.BringToFront = value

value = instance.BringToFront
public bool BringToFront {get; set;}
Example
Markers In Front
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : CalendarPattern Property
CalendarPattern Property
Gets or set a CalendarPattern used by this axis marker instead of the range values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CalendarPattern As CalendarPattern
'Usage

Dim instance As AxisMarker
Dim value As CalendarPattern

instance.CalendarPattern = value

value = instance.CalendarPattern
public CalendarPattern CalendarPattern {get; set;}
Example
CalendarPattern
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Calendar Patterns


dotnetCHARTING Namespace > AxisMarker Class : Label Property
Label Property (AxisMarker)
Gets or sets a Label object drawn next to the AxisMarker on a ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As AxisMarker
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : LegendEntry Property
LegendEntry Property (AxisMarker)
Gets or sets a LegendEntry that represents this AxisMarker in a LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendEntry As LegendEntry
'Usage

Dim instance As AxisMarker
Dim value As LegendEntry

instance.LegendEntry = value

value = instance.LegendEntry
public LegendEntry LegendEntry {get; set;}
Example
Axis Horizontal Color Bands
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : Line Property
Line Property (AxisMarker)
Gets or sets a Line object drawn on a ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As AxisMarker
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Remarks
This line is used when ValueHigh and ValueLow are equal or if Value is set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : Tick Property
Tick Property
Gets or sets an AxisTick object that will represent this AxisMarker on the axis where it resides.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Tick As AxisTick
'Usage

Dim instance As AxisMarker
Dim value As AxisTick

instance.Tick = value

value = instance.Tick
public AxisTick Tick {get; set;}
Remarks
By default this tick is null and must be instantiated. If the axis marker is a range, the axis tick will also be a range AxisTick. If a CalendarPattern is used, the tick cannot be used.
Example
Axis Marker Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members


dotnetCHARTING Namespace > AxisMarker Class : Value Property
Value Property (AxisMarker)
Gets or sets the numeric, DateTime, or text value of this AxisMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Value As Object
'Usage

Dim instance As AxisMarker
Dim value As Object

instance.Value = value

value = instance.Value
public override object Value {get; set;}
Remarks
When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Base Implementation in Value


dotnetCHARTING Namespace > AxisMarker Class : ValueHigh Property
ValueHigh Property (AxisMarker)
Gets or sets the upper bounds of a numeric, DateTime, or text range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property ValueHigh As Object
'Usage

Dim instance As AxisMarker
Dim value As Object

instance.ValueHigh = value

value = instance.ValueHigh
public override object ValueHigh {get; set;}
Remarks
When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Example
Axis Marker Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Base Implementation in ValueHigh


dotnetCHARTING Namespace > AxisMarker Class : ValueLow Property
ValueLow Property (AxisMarker)
Gets or sets the lower bounds of a numeric, DateTime, or text range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property ValueLow As Object
'Usage

Dim instance As AxisMarker
Dim value As Object

instance.ValueLow = value

value = instance.ValueLow
public override object ValueLow {get; set;}
Remarks
When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Example
Axis Marker Ticks
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarker Class
AxisMarker Members
Base Implementation in ValueLow


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisMarkerCollection Class
AxisMarkerCollection Class
Contains a collection of AxisMarker objects.
Object Model
AxisMarkerCollection ClassAxisMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisMarkerCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As AxisMarkerCollection
public class AxisMarkerCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisMarkerCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AxisMarkerCollection Class
AxisMarkerCollection Class Members

The following tables list the members exposed by AxisMarkerCollection.

Public Constructors
 | Name | Description
Public Constructor | AxisMarkerCollection Constructor | Creates a new instance of AxisMarkerCollection with the specified list of AxisMarker objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisMarkerCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified AxisMarker.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified AxisMarker in this collection.
Public Method | Insert | Inserts a AxisMarker into this collection at a specified index.
Public Method | Remove | Removes a specified AxisMarker from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisMarkerCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisMarkerCollection Class : AxisMarkerCollection Constructor
AxisMarkerCollection Constructor
Creates a new instance of AxisMarkerCollection with the specified list of AxisMarker objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray axisMarkerList() As AxisMarker _
)
'Usage

Dim axisMarkerList() As AxisMarker

Dim instance As New AxisMarkerCollection(axisMarkerList)
public AxisMarkerCollection(
   params AxisMarker[] axisMarkerList
)

Parameters

axisMarkerList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AxisMarkerCollection Class
AxisMarkerCollection Class Methods

For a list of all members of this type, see AxisMarkerCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisMarkerCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified AxisMarker.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified AxisMarker in this collection.
Public Method | Insert | Inserts a AxisMarker into this collection at a specified index.
Public Method | Remove | Removes a specified AxisMarker from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisMarkerCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisMarkerCollection Class : Add Method
Add Method (AxisMarkerCollection)
Adds a specified AxisMarkerCollection to this collection.
Overload List
Overload | Description
Add(AxisMarker) |
Add(AxisMarkerCollection) | Adds a specified AxisMarkerCollection to this collection.
Add(AxisMarker[]) | Adds the specified AxisMarker objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


dotnetCHARTING Namespace > AxisMarkerCollection Class > Add Method : Add(AxisMarker) Method
Add(AxisMarker) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal axisMarker As AxisMarker _
) As Integer
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarker As AxisMarker
Dim value As Integer

value = instance.Add(axisMarker)
public int Add(
   AxisMarker axisMarker
)

Parameters

axisMarker
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members
Overload List


dotnetCHARTING Namespace > AxisMarkerCollection Class > Add Method : Add(AxisMarkerCollection) Method
The AxisMarkerCollection to add.
Add(AxisMarkerCollection) Method
Adds a specified AxisMarkerCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal axisMarkerCollection As AxisMarkerCollection _
)
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarkerCollection As AxisMarkerCollection

instance.Add(axisMarkerCollection)
public void Add(
   AxisMarkerCollection axisMarkerCollection
)

Parameters

axisMarkerCollection
The AxisMarkerCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members
Overload List


dotnetCHARTING Namespace > AxisMarkerCollection Class > Add Method : Add(AxisMarker[]) Method
A list of AxisMarker objects to add.
Add(AxisMarker[]) Method
Adds the specified AxisMarker objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray axisMarkerList() As AxisMarker _
)
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarkerList() As AxisMarker

instance.Add(axisMarkerList)
public void Add(
   params AxisMarker[] axisMarkerList
)

Parameters

axisMarkerList
A list of AxisMarker objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members
Overload List


dotnetCHARTING Namespace > AxisMarkerCollection Class : Contains Method
The AxisMarker to find.
Contains Method (AxisMarkerCollection)
Determines whether this collection contains a specified AxisMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal axisMarker As AxisMarker _
) As Boolean
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarker As AxisMarker
Dim value As Boolean

value = instance.Contains(axisMarker)
public bool Contains(
   AxisMarker axisMarker
)

Parameters

axisMarker
The AxisMarker to find.

Return Value

true if the specified AxisMarker belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


dotnetCHARTING Namespace > AxisMarkerCollection Class : IndexOf Method
The AxisMarker to find.
IndexOf Method (AxisMarkerCollection)
Determines the index of a specified AxisMarker in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal axisMarker As AxisMarker _
) As Integer
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarker As AxisMarker
Dim value As Integer

value = instance.IndexOf(axisMarker)
public int IndexOf(
   AxisMarker axisMarker
)

Parameters

axisMarker
The AxisMarker to find.

Return Value

The zero-based index of the specified AxisMarker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


dotnetCHARTING Namespace > AxisMarkerCollection Class : Insert Method
The zero-based index into the collection at which to insert the AxisMarker.
The AxisMarker to insert into this collection.
Insert Method (AxisMarkerCollection)
Inserts a AxisMarker into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axisMarker As AxisMarker _
)
'Usage

Dim instance As AxisMarkerCollection
Dim index As Integer
Dim axisMarker As AxisMarker

instance.Insert(index, axisMarker)
public void Insert(
   int index,
   AxisMarker axisMarker
)

Parameters

index
The zero-based index into the collection at which to insert the AxisMarker.
axisMarker
The AxisMarker to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


dotnetCHARTING Namespace > AxisMarkerCollection Class : Remove Method
The AxisMarker to remove.
Remove Method (AxisMarkerCollection)
Removes a specified AxisMarker from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal axisMarker As AxisMarker _
)
'Usage

Dim instance As AxisMarkerCollection
Dim axisMarker As AxisMarker

instance.Remove(axisMarker)
public void Remove(
   AxisMarker axisMarker
)

Parameters

axisMarker
The AxisMarker to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisMarkerCollection Class
AxisMarkerCollection Class Properties

For a list of all members of this type, see AxisMarkerCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

AxisMarkerCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisMarkerCollection Class : Item Property
Item Property (AxisMarkerCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As AxisMarker
'Usage

Dim instance As AxisMarkerCollection
Dim index As Integer
Dim value As AxisMarker

instance.Item(index) = value

value = instance.Item(index)
public AxisMarker this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisMarkerCollection Class
AxisMarkerCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisTick Class
AxisTick Class
Encapsulates an axis tick that includes Label or ElementMarker, TickLine, and GridLine styling objects.
Object Model
AxisTick ClassLine ClassLabel ClassLine ClassElementMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisTick
   Inherits ScaleRange
'Usage

Dim instance As AxisTick
public class AxisTick : ScaleRange
Remarks

Appearance
AxisTick objects can appear in three different ways.

  • Normal axis tick with a label.
  • AxisTick where the label is replaced with the AxisTick.Marker object (Icon or Image).
  • Range AxisTick in which case the tick has a low and high value.

Uses
AxisTick objects can also be used in different ways.

  • As an additional axis tick.
  • To override a tick on an axis.
  • To override multiple ticks on an axis.
Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisTick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Members
dotnetCHARTING Namespace

Tutorials

Axis Ticks
Minor Ticks
Calculated Axis Ticks

Samples

Arbitrary Ticks
Axis Tick Types
Axis Tick Expressions


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AxisTick Class
AxisTick Class Members

The following tables list the members exposed by AxisTick.

Public Constructors
 | Name | Description
Public Constructor | AxisTick Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AxisID | (JS Chart Only) Gets or sets the axis id of the axis that the element tick should be shown when used with Element.XAxisTick or Element.YAxisTick.
Public Property | GridLine | Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action when the mouse hovers over the axis tick when it is set through Element.XAxisTick or Element.YAxisTick. By default the behavior is either HighlightSeries or HighlightPointGroup depending on the orientation of the axis.
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | Label | Gets or sets the Label of this AxisTick.
Public Property | Line | Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.
Public Property | Marker | Gets or sets an ElementMarker object used instead of the label text.
Public Property | OverrideTicks | Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.
Public Property | Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range. (Inherited from dotnetCHARTING.ScaleRange)
Top
Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this AxisTick.
Public Method | SetAllColors | Sets the colors of this AxisTick's Label, Line, and GridLine.
Public Method | ToString | (Inherited from dotnetCHARTING.ScaleRange)
Top
See Also

Reference

AxisTick Class
dotnetCHARTING Namespace

Tutorials

Axis Ticks
Minor Ticks
Calculated Axis Ticks

Samples

Arbitrary Ticks
Axis Tick Types
Axis Tick Expressions


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class : AxisTick Constructor
AxisTick Constructor
Overload List
Overload | Description
AxisTick Constructor() | Initializes a new instance of the AxisTick class.
AxisTick Constructor(String,String) | Initializes a new instance of the AxisTick class with text of an original label and new text to override that label with.
AxisTick Constructor(Object) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value.
AxisTick Constructor(Object,ElementMarker) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and an element marker.
AxisTick Constructor(Object,String) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and a text label.
AxisTick Constructor(Object,Object) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range.
AxisTick Constructor(Object,Object,String) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and label.
AxisTick Constructor(Object,Object,Boolean) | Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and an option to make this axis tick override ticks within it's range instead of appearing on the axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor()
AxisTick Constructor()
Initializes a new instance of the AxisTick class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New AxisTick()
public AxisTick()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(String,String)
Label text of the axis tick to replace.
New label text.
AxisTick Constructor(String,String)
Initializes a new instance of the AxisTick class with text of an original label and new text to override that label with.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal originalLabelText As String, _
   ByVal newLabelText As String _
)
'Usage

Dim originalLabelText As String
Dim newLabelText As String

Dim instance As New AxisTick(originalLabelText, newLabelText)
public AxisTick(
   string originalLabelText,
   string newLabelText
)

Parameters

originalLabelText
Label text of the axis tick to replace.
newLabelText
New label text.
Remarks
Case insensitive.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object)
Axis tick value. The label will automatically represent the value given.(Number or DateTime)
AxisTick Constructor(Object)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal val As Object _
)
'Usage

Dim val As Object

Dim instance As New AxisTick(val)
public AxisTick(
   object val
)

Parameters

val
Axis tick value. The label will automatically represent the value given.(Number or DateTime)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object,ElementMarker)
Axis tick value.(Number or DateTime)
Element Marker
AxisTick Constructor(Object,ElementMarker)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and an element marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal val As Object, _
   ByVal marker As ElementMarker _
)
'Usage

Dim val As Object
Dim marker As ElementMarker

Dim instance As New AxisTick(val, marker)
public AxisTick(
   object val,
   ElementMarker marker
)

Parameters

val
Axis tick value.(Number or DateTime)
marker
Element Marker
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object,String)
Axis tick value.(Number or DateTime)
Label text.
AxisTick Constructor(Object,String)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime value and a text label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal val As Object, _
   ByVal TextOverride As String _
)
'Usage

Dim val As Object
Dim TextOverride As String

Dim instance As New AxisTick(val, TextOverride)
public AxisTick(
   object val,
   string TextOverride
)

Parameters

val
Axis tick value.(Number or DateTime)
TextOverride
Label text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object,Object)
Low value. (Number or DateTime)
High value. (Number or DateTime)
AxisTick Constructor(Object,Object)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object _
)
'Usage

Dim lowValue As Object
Dim highValue As Object

Dim instance As New AxisTick(lowValue, highValue)
public AxisTick(
   object lowValue,
   object highValue
)

Parameters

lowValue
Low value. (Number or DateTime)
highValue
High value. (Number or DateTime)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object,Object,String)
Low value.(Number or DateTime)
High value.(Number or DateTime)
Label text.
AxisTick Constructor(Object,Object,String)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object, _
   ByVal labelText As String _
)
'Usage

Dim lowValue As Object
Dim highValue As Object
Dim labelText As String

Dim instance As New AxisTick(lowValue, highValue, labelText)
public AxisTick(
   object lowValue,
   object highValue,
   string labelText
)

Parameters

lowValue
Low value.(Number or DateTime)
highValue
High value.(Number or DateTime)
labelText
Label text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTick Class > AxisTick Constructor : AxisTick Constructor(Object,Object,Boolean)
Low value.(Number or DateTime)
High value.(Number or DateTime)
When true, the axis tick will override ticks within it's range, otherwise, it will be a range tick.
AxisTick Constructor(Object,Object,Boolean)
Initializes a new instance of the AxisTick class with an arbitrary numeric or DateTime range and an option to make this axis tick override ticks within it's range instead of appearing on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object, _
   ByVal overrideTheTicks As Boolean _
)
'Usage

Dim lowValue As Object
Dim highValue As Object
Dim overrideTheTicks As Boolean

Dim instance As New AxisTick(lowValue, highValue, overrideTheTicks)
public AxisTick(
   object lowValue,
   object highValue,
   bool overrideTheTicks
)

Parameters

lowValue
Low value.(Number or DateTime)
highValue
High value.(Number or DateTime)
overrideTheTicks
When true, the axis tick will override ticks within it's range, otherwise, it will be a range tick.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AxisTick Class
AxisTick Class Methods

For a list of all members of this type, see AxisTick members.

Public Methods
 | Name | Description
Public Method | Dispose | Releases all resources used by this AxisTick.
Public Method | SetAllColors | Sets the colors of this AxisTick's Label, Line, and GridLine.
Public Method | ToString | (Inherited from dotnetCHARTING.ScaleRange)
Top
See Also

Reference

AxisTick Class
dotnetCHARTING Namespace

Tutorials

Axis Ticks
Minor Ticks
Calculated Axis Ticks

Samples

Arbitrary Ticks
Axis Tick Types
Axis Tick Expressions


dotnetCHARTING Namespace > AxisTick Class : Dispose() Method
Dispose() Method
Releases all resources used by this AxisTick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
'Usage

Dim instance As AxisTick

instance.Dispose()
public void Dispose()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : SetAllColors Method
Color to use.
SetAllColors Method
Sets the colors of this AxisTick's Label, Line, and GridLine.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SetAllColors( _
   ByVal color As Color _
)
'Usage

Dim instance As AxisTick
Dim color As Color

instance.SetAllColors(color)
public void SetAllColors(
   Color color
)

Parameters

color
Color to use.
Example
Gallery A63
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisTick Class
AxisTick Class Properties

For a list of all members of this type, see AxisTick members.

Public Properties
 | Name | Description
Public Property | AxisID | (JS Chart Only) Gets or sets the axis id of the axis that the element tick should be shown when used with Element.XAxisTick or Element.YAxisTick.
Public Property | GridLine | Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action when the mouse hovers over the axis tick when it is set through Element.XAxisTick or Element.YAxisTick. By default the behavior is either HighlightSeries or HighlightPointGroup depending on the orientation of the axis.
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | Label | Gets or sets the Label of this AxisTick.
Public Property | Line | Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.
Public Property | Marker | Gets or sets an ElementMarker object used instead of the label text.
Public Property | OverrideTicks | Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.
Public Property | Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range. (Inherited from dotnetCHARTING.ScaleRange)
Public Property | ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range. (Inherited from dotnetCHARTING.ScaleRange)
Top
See Also

Reference

AxisTick Class
dotnetCHARTING Namespace

Tutorials

Axis Ticks
Minor Ticks
Calculated Axis Ticks

Samples

Arbitrary Ticks
Axis Tick Types
Axis Tick Expressions


dotnetCHARTING Namespace > AxisTick Class : AxisID Property
AxisID Property
(JS Chart Only) Gets or sets the axis id of the axis that the element tick should be shown when used with Element.XAxisTick or Element.YAxisTick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisID As String
'Usage

Dim instance As AxisTick
Dim value As String

instance.AxisID = value

value = instance.AxisID
public string AxisID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : GridLine Property
GridLine Property
Gets or sets the properties of the Line drawn on the ChartArea at this AxisTick object's position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridLine As Line
'Usage

Dim instance As AxisTick
Dim value As Line

instance.GridLine = value

value = instance.GridLine
public Line GridLine {get; set;}
Example
Axis Tick Overrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : HoverAction Property
HoverAction Property (AxisTick)
(JS Chart Only) Gets or sets the hover action when the mouse hovers over the axis tick when it is set through Element.XAxisTick or Element.YAxisTick. By default the behavior is either HighlightSeries or HighlightPointGroup depending on the orientation of the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HoverAction As HoverAction
'Usage

Dim instance As AxisTick
Dim value As HoverAction

instance.HoverAction = value

value = instance.HoverAction
public HoverAction HoverAction {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : Label Property
Label Property (AxisTick)
Gets or sets the Label of this AxisTick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As AxisTick
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Example
Axis Tick Overrides
Axis Tick Token
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : Line Property
Line Property (AxisTick)
Gets or sets the tick line of this AxisTick. The property Line.Length will control the length of this tick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As AxisTick
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Example
Axis Tick Overrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : Marker Property
Marker Property (AxisTick)
Gets or sets an ElementMarker object used instead of the label text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As AxisTick
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Example
Axis Tick Overrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > AxisTick Class : OverrideTicks Property
OverrideTicks Property
Gets or sets a value indicating whether this range AxisTick is drawn on an axis or if it's properties are used to override those of other AxisTicks within it's range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverrideTicks As Boolean
'Usage

Dim instance As AxisTick
Dim value As Boolean

instance.OverrideTicks = value

value = instance.OverrideTicks
public bool OverrideTicks {get; set;}
Example
Axis Tick Overrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : AxisTickCollection Class
AxisTickCollection Class
Contains a collection of AxisTick objects.
Object Model
AxisTickCollection ClassAxisTick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class AxisTickCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As AxisTickCollection
public class AxisTickCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.AxisTickCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : AxisTickCollection Class
AxisTickCollection Class Members

The following tables list the members exposed by AxisTickCollection.

Public Constructors
 | Name | Description
Public Constructor | AxisTickCollection Constructor | Creates a new instance of AxisTickCollection with the specified list of AxisTick objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified AxisTick object to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified AxisTick.
static (Shared in Visual Basic) | FromValues | Overloaded. Creates a collection of axis ticks with the specified values.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified AxisTick in this collection.
Public Method | Insert | Inserts a AxisTick into this collection at a specified index.
Public Method | Remove | Removes a specified AxisTick from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisTickCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > AxisTickCollection Class : AxisTickCollection Constructor
AxisTickCollection Constructor
Creates a new instance of AxisTickCollection with the specified list of AxisTick objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray axisTickList() As AxisTick _
)
'Usage

Dim axisTickList() As AxisTick

Dim instance As New AxisTickCollection(axisTickList)
public AxisTickCollection(
   params AxisTick[] axisTickList
)

Parameters

axisTickList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AxisTickCollection Class
AxisTickCollection Class Methods

For a list of all members of this type, see AxisTickCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified AxisTick object to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified AxisTick.
static (Shared in Visual Basic) | FromValues | Overloaded. Creates a collection of axis ticks with the specified values.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified AxisTick in this collection.
Public Method | Insert | Inserts a AxisTick into this collection at a specified index.
Public Method | Remove | Removes a specified AxisTick from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

AxisTickCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisTickCollection Class : Add Method
Add Method (AxisTickCollection)
Adds the specified AxisTick object to this collection.
Overload List
Overload | Description
Add(AxisTick) | Adds the specified axisTick object to this collection.
Add(AxisTickCollection) | Adds a specified AxisTickCollection to this collection.
Add(AxisTick[]) | Adds the specified AxisTick objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


dotnetCHARTING Namespace > AxisTickCollection Class > Add Method : Add(AxisTick) Method
Add(AxisTick) Method
Adds the specified axisTick object to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal axisTick As AxisTick _
) As Integer
'Usage

Dim instance As AxisTickCollection
Dim axisTick As AxisTick
Dim value As Integer

value = instance.Add(axisTick)
public int Add(
   AxisTick axisTick
)

Parameters

axisTick
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members
Overload List


dotnetCHARTING Namespace > AxisTickCollection Class > Add Method : Add(AxisTickCollection) Method
The AxisTickCollection to add.
Add(AxisTickCollection) Method
Adds a specified AxisTickCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal axisTickCollection As AxisTickCollection _
)
'Usage

Dim instance As AxisTickCollection
Dim axisTickCollection As AxisTickCollection

instance.Add(axisTickCollection)
public void Add(
   AxisTickCollection axisTickCollection
)

Parameters

axisTickCollection
The AxisTickCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members
Overload List


dotnetCHARTING Namespace > AxisTickCollection Class > Add Method : Add(AxisTick[]) Method
A list of AxisTick objects to add.
Add(AxisTick[]) Method
Adds the specified AxisTick objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray axisTickList() As AxisTick _
)
'Usage

Dim instance As AxisTickCollection
Dim axisTickList() As AxisTick

instance.Add(axisTickList)
public void Add(
   params AxisTick[] axisTickList
)

Parameters

axisTickList
A list of AxisTick objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members
Overload List


dotnetCHARTING Namespace > AxisTickCollection Class : Contains Method
The AxisTick to find.
Contains Method (AxisTickCollection)
Determines whether this collection contains a specified AxisTick.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal axisTick As AxisTick _
) As Boolean
'Usage

Dim instance As AxisTickCollection
Dim axisTick As AxisTick
Dim value As Boolean

value = instance.Contains(axisTick)
public bool Contains(
   AxisTick axisTick
)

Parameters

axisTick
The AxisTick to find.

Return Value

true if the specified AxisTick belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


dotnetCHARTING Namespace > AxisTickCollection Class : FromValues Method
FromValues Method (AxisTickCollection)
Creates a collection of axis ticks with the specified values.
Overload List
Overload | Description
FromValues(Double[]) | Creates a collection of axis ticks with the specified values.
FromValues(DateTime[]) | Creates a collection of axis ticks with the specified values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


dotnetCHARTING Namespace > AxisTickCollection Class > FromValues Method : FromValues(Double[]) Method
List of double values.
FromValues(Double[]) Method
Creates a collection of axis ticks with the specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromValues( _
   ByVal ParamArray list() As Double _
) As AxisTickCollection
'Usage

Dim list() As Double
Dim value As AxisTickCollection

value = AxisTickCollection.FromValues(list)
public static AxisTickCollection FromValues(
   params double[] list
)

Parameters

list
List of double values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members
Overload List


dotnetCHARTING Namespace > AxisTickCollection Class > FromValues Method : FromValues(DateTime[]) Method
List of %DateTime values.
FromValues(DateTime[]) Method
Creates a collection of axis ticks with the specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromValues( _
   ByVal ParamArray list() As Date _
) As AxisTickCollection
'Usage

Dim list() As Date
Dim value As AxisTickCollection

value = AxisTickCollection.FromValues(list)
public static AxisTickCollection FromValues(
   params DateTime[] list
)

Parameters

list
List of %DateTime values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members
Overload List


dotnetCHARTING Namespace > AxisTickCollection Class : IndexOf Method
The AxisTick to find.
IndexOf Method (AxisTickCollection)
Determines the index of a specified AxisTick in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal axisTick As AxisTick _
) As Integer
'Usage

Dim instance As AxisTickCollection
Dim axisTick As AxisTick
Dim value As Integer

value = instance.IndexOf(axisTick)
public int IndexOf(
   AxisTick axisTick
)

Parameters

axisTick
The AxisTick to find.

Return Value

The zero-based index of the specified AxisTick.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


dotnetCHARTING Namespace > AxisTickCollection Class : Insert Method
The zero-based index into the collection at which to insert the AxisTick.
The AxisTick to insert into this collection.
Insert Method (AxisTickCollection)
Inserts a AxisTick into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal axisTick As AxisTick _
)
'Usage

Dim instance As AxisTickCollection
Dim index As Integer
Dim axisTick As AxisTick

instance.Insert(index, axisTick)
public void Insert(
   int index,
   AxisTick axisTick
)

Parameters

index
The zero-based index into the collection at which to insert the AxisTick.
axisTick
The AxisTick to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


dotnetCHARTING Namespace > AxisTickCollection Class : Remove Method
The AxisTick to remove.
Remove Method (AxisTickCollection)
Removes a specified AxisTick from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal axisTick As AxisTick _
)
'Usage

Dim instance As AxisTickCollection
Dim axisTick As AxisTick

instance.Remove(axisTick)
public void Remove(
   AxisTick axisTick
)

Parameters

axisTick
The AxisTick to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : AxisTickCollection Class
AxisTickCollection Class Properties

For a list of all members of this type, see AxisTickCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

AxisTickCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > AxisTickCollection Class : Item Property
Item Property (AxisTickCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As AxisTick
'Usage

Dim instance As AxisTickCollection
Dim index As Integer
Dim value As AxisTick

instance.Item(index) = value

value = instance.Item(index)
public AxisTick this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTickCollection Class
AxisTickCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Background Class
Background Class
Defines styling properties used to fill the interior of polygons and chart elements such as legend boxes, annotations and other shapes.
Object Model
Background Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Background
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As Background
public class Background : dotnetCHARTING.Mapping.Drawing.Property
Example
Bevel
Box Styling
Inheritance Hierarchy

System.Object
dotnetCHARTING.Background

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Background Class
Background Class Members

The following tables list the members exposed by Background.

Public Constructors
 | Name | Description
Public Constructor | Background Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Bevel | Gets or sets a value that indicates whether this background will use a bevel shading effect.
Public Property | Brush | Gets or sets a brush object that is used to fill objects.
Public Property | Color | Gets or sets the primary Color.
Public Property | ColorPositions | Gets or sets an the color positions used in a multi color gradient fill. This property should be used in conjunction with Colors array where each color corresponds to a color position.
Public Property | Colors | Gets or sets an array of Color objects used in a multi color gradient fill. This property should be used in conjunction with ColorPositions where each color corresponds to a color position.
Public Property | GlassEffect | Gets or sets a value that indicates whether a glass effect is used to fill an object.
Public Property | GradientAngle | Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )
Public Property | HatchColor | Gets or sets a color hatch patterns are drawn with.
Public Property | HatchStyle | Gets or sets a hatch pattern.
Public Property | ImagePath | Gets or sets the path of a fill image.
Public Property | Mode | Gets or sets the fill mode.
Public Property | SecondaryColor | Gets or sets the secondary color.
Public Property | ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration member that indicates a shading effect to use when filling a surface.
Public Property | Transparency | Gets or sets a value from 0 to 100 that indicates the background transparency.
Public Property | Visible | Gets or sets a value that indicates whether this background is visible.
Top
See Also

Reference

Background Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class : Background Constructor
Background Constructor
Overload List
Overload | Description
Background Constructor() | Initializes a new instance of the Background class.
Background Constructor(Color) | Initializes a new instance of the Background object with a color.
Background Constructor(Brush) | Initializes a new instance of the Background object with a Brush.
Background Constructor(Color,Color) | Initializes a new instance of the Background object with gradient colors drawn left to right.
Background Constructor(Color,Color,Single) | Initializes a new instance of the Background object with gradient colors drawn at a specified angle.
Background Constructor(Color[],Single[],Single) | Initializes a new instance of the Background class.
Background Constructor(String) | Initializes a new instance of the Background object with a tiled image.
Background Constructor(String,BackgroundMode) | Initializes a new instance of the Background object with an image and a background mode.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor()
Background Constructor()
Initializes a new instance of the Background class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Background()
public Background()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(Color)
Color to fill with.
Background Constructor(Color)
Initializes a new instance of the Background object with a color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal myColor As Color _
)
'Usage

Dim myColor As Color

Dim instance As New Background(myColor)
public Background(
   Color myColor
)

Parameters

myColor
Color to fill with.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(Brush)
Brush object used to to fill the background.
Background Constructor(Brush)
Initializes a new instance of the Background object with a Brush.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal brush As Brush _
)
'Usage

Dim brush As Brush

Dim instance As New Background(brush)
public Background(
   Brush brush
)

Parameters

brush
Brush object used to to fill the background.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(Color,Color)
First color.
Second color
Background Constructor(Color,Color)
Initializes a new instance of the Background object with gradient colors drawn left to right.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal myColor As Color, _
   ByVal secondColor As Color _
)
'Usage

Dim myColor As Color
Dim secondColor As Color

Dim instance As New Background(myColor, secondColor)
public Background(
   Color myColor,
   Color secondColor
)

Parameters

myColor
First color.
secondColor
Second color
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(Color,Color,Single)
First color.
Second color
Specifies an angle ( left to right = 0, right to left = 180 )
Background Constructor(Color,Color,Single)
Initializes a new instance of the Background object with gradient colors drawn at a specified angle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal myColor As Color, _
   ByVal secondColor As Color, _
   ByVal angle As Single _
)
'Usage

Dim myColor As Color
Dim secondColor As Color
Dim angle As Single

Dim instance As New Background(myColor, secondColor, angle)
public Background(
   Color myColor,
   Color secondColor,
   float angle
)

Parameters

myColor
First color.
secondColor
Second color
angle
Specifies an angle ( left to right = 0, right to left = 180 )
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(Color[],Single[],Single)
Background Constructor(Color[],Single[],Single)
Initializes a new instance of the Background class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal myColors() As Color, _
   ByVal myColorPositions() As Single, _
   ByVal angle As Single _
)
'Usage

Dim myColors() As Color
Dim myColorPositions() As Single
Dim angle As Single

Dim instance As New Background(myColors, myColorPositions, angle)
public Background(
   Color[] myColors,
   float[] myColorPositions,
   float angle
)

Parameters

myColors
myColorPositions
angle
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(String)
Path of an image.
Background Constructor(String)
Initializes a new instance of the Background object with a tiled image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal imagePath As String _
)
'Usage

Dim imagePath As String

Dim instance As New Background(imagePath)
public Background(
   string imagePath
)

Parameters

imagePath
Path of an image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Background Class > Background Constructor : Background Constructor(String,BackgroundMode)
Path of a background image.
Specifies a BackgroundMode to use with the image.
Background Constructor(String,BackgroundMode)
Initializes a new instance of the Background object with an image and a background mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal imagePath As String, _
   ByVal backgroundMode As BackgroundMode _
)
'Usage

Dim imagePath As String
Dim backgroundMode As BackgroundMode

Dim instance As New Background(imagePath, backgroundMode)
public Background(
   string imagePath,
   BackgroundMode backgroundMode
)

Parameters

imagePath
Path of a background image.
backgroundMode
Specifies a BackgroundMode to use with the image.
Remarks
The
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Background Class
Background Class Properties

For a list of all members of this type, see Background members.

Public Properties
 | Name | Description
Public Property | Bevel | Gets or sets a value that indicates whether this background will use a bevel shading effect.
Public Property | Brush | Gets or sets a brush object that is used to fill objects.
Public Property | Color | Gets or sets the primary Color.
Public Property | ColorPositions | Gets or sets an the color positions used in a multi color gradient fill. This property should be used in conjunction with Colors array where each color corresponds to a color position.
Public Property | Colors | Gets or sets an array of Color objects used in a multi color gradient fill. This property should be used in conjunction with ColorPositions where each color corresponds to a color position.
Public Property | GlassEffect | Gets or sets a value that indicates whether a glass effect is used to fill an object.
Public Property | GradientAngle | Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )
Public Property | HatchColor | Gets or sets a color hatch patterns are drawn with.
Public Property | HatchStyle | Gets or sets a hatch pattern.
Public Property | ImagePath | Gets or sets the path of a fill image.
Public Property | Mode | Gets or sets the fill mode.
Public Property | SecondaryColor | Gets or sets the secondary color.
Public Property | ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration member that indicates a shading effect to use when filling a surface.
Public Property | Transparency | Gets or sets a value from 0 to 100 that indicates the background transparency.
Public Property | Visible | Gets or sets a value that indicates whether this background is visible.
Top
See Also

Reference

Background Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > Background Class : Bevel Property
Bevel Property
Gets or sets a value that indicates whether this background will use a bevel shading effect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Bevel As Boolean
'Usage

Dim instance As Background
Dim value As Boolean

instance.Bevel = value

value = instance.Bevel
public bool Bevel {get; set;}
Example
Bevel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Brush Property
Brush Property
Gets or sets a brush object that is used to fill objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Brush As Brush
'Usage

Dim instance As Background
Dim value As Brush

instance.Brush = value

value = instance.Brush
public Brush Brush {get; set;}
Example
Brush Background
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Color Property
Color Property (Background)
Gets or sets the primary Color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As Background
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : ColorPositions Property
ColorPositions Property
Gets or sets an the color positions used in a multi color gradient fill. This property should be used in conjunction with Colors array where each color corresponds to a color position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorPositions As Single()
'Usage

Dim instance As Background
Dim value() As Single

instance.ColorPositions = value

value = instance.ColorPositions
public float[] ColorPositions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Colors Property
Colors Property
Gets or sets an array of Color objects used in a multi color gradient fill. This property should be used in conjunction with ColorPositions where each color corresponds to a color position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Colors As Color()
'Usage

Dim instance As Background
Dim value() As Color

instance.Colors = value

value = instance.Colors
public Color[] Colors {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : GlassEffect Property
GlassEffect Property
Gets or sets a value that indicates whether a glass effect is used to fill an object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GlassEffect As Boolean
'Usage

Dim instance As Background
Dim value As Boolean

instance.GlassEffect = value

value = instance.GlassEffect
public bool GlassEffect {get; set;}
Example
Glass Effect
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : GradientAngle Property
GradientAngle Property
Gets or sets an angle at which gradients are drawn.( left to right = 0, right to left = 180 )
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GradientAngle As Single
'Usage

Dim instance As Background
Dim value As Single

instance.GradientAngle = value

value = instance.GradientAngle
public float GradientAngle {get; set;}
Example
Gradient Background
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : HatchColor Property
HatchColor Property (Background)
Gets or sets a color hatch patterns are drawn with.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchColor As Color
'Usage

Dim instance As Background
Dim value As Color

instance.HatchColor = value

value = instance.HatchColor
public Color HatchColor {get; set;}
Example
Box Styling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : HatchStyle Property
HatchStyle Property (Background)
Gets or sets a hatch pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStyle As HatchStyle
'Usage

Dim instance As Background
Dim value As HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
public HatchStyle HatchStyle {get; set;}
Remarks
If not specified, no hatch will is drawn.
Example
Box Styling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : ImagePath Property
ImagePath Property (Background)
Gets or sets the path of a fill image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImagePath As String
'Usage

Dim instance As Background
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
public string ImagePath {get; set;}
Remarks
An image fill is used when BackgroundMode.ImageTile, BackgroundMode.ImageStretch or BackgroundMode.Image is used.
Example
Background Image
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Mode Property
Mode Property (Background)
Gets or sets the fill mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As BackgroundMode
'Usage

Dim instance As Background
Dim value As BackgroundMode

instance.Mode = value

value = instance.Mode
public BackgroundMode Mode {get; set;}

Property Value

A BackgroundMode enumeration that indicates how the background is filled.
Example
Stretch
Tile
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : SecondaryColor Property
SecondaryColor Property (Background)
Gets or sets the secondary color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecondaryColor As Color
'Usage

Dim instance As Background
Dim value As Color

instance.SecondaryColor = value

value = instance.SecondaryColor
public Color SecondaryColor {get; set;}
Remarks
The secondary color is used with the primary color to create a gradient fill when using BackgroundMode.Gradient.
Example
Gradient Background
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : ShadingEffectMode Property
ShadingEffectMode Property (Background)
Gets or sets a ShadingEffectMode enumeration member that indicates a shading effect to use when filling a surface.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadingEffectMode As ShadingEffectMode
'Usage

Dim instance As Background
Dim value As ShadingEffectMode

instance.ShadingEffectMode = value

value = instance.ShadingEffectMode
public ShadingEffectMode ShadingEffectMode {get; set;}
Example
Box Styling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Transparency Property
Transparency Property (Background)
Gets or sets a value from 0 to 100 that indicates the background transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transparency As Integer
'Usage

Dim instance As Background
Dim value As Integer

instance.Transparency = value

value = instance.Transparency
public int Transparency {get; set;}
Remarks
A value of 0 will have no transparency and 100 will be completely transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


dotnetCHARTING Namespace > Background Class : Visible Property
Visible Property (Background)
Gets or sets a value that indicates whether this background is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Background
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Background Class
Background Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Box Class
Box Class
Defines a base class for derived objects such as Chart.TitleBox, Chart.LegendBox, and Annotation.
Object Model
Box ClassBackground ClassBoxHeaderOptions ClassLine ClassLabel ClassLine ClassShadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Box
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As Box
public class Box : dotnetCHARTING.Mapping.Drawing.Property
Remarks
The box object provides the following
  • Defines objects used to fill the interior, shadow, and outline the box.
  • Defines rectangle edge styles.
  • Defines the position, title box icon, LegendBox layout template, and interior label.
Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.Annotation
dotnetCHARTING.LegendBox
dotnetCHARTING.NavigatorOptions.NavigationBarOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Members
dotnetCHARTING Namespace

Tutorial

Box

Samples

Box Corner Styling
Box Headers
Box Shading Effects


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Box Class
Box Class Members

The following tables list the members exposed by Box.

Public Constructors
 | Name | Description
Public Constructor | Box Constructor | Initializes a new instance of the Box class.
Top
Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property | CornerBottomRight | Gets or sets the bottom right corner style.
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

Public Property | CornerTopLeft | Gets or sets the top left corner style.
Public Property | CornerTopRight | Gets or sets the top right corner style.
Public Property | DefaultCorner | Gets or sets the default box corner style.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content.
Public Property | IconPath | Gets or sets the icon path of this title box.
Public Property | InteriorLine | Gets or sets the interior line of this legend box.
Public Property | Label | Gets or sets the Label of this box.
Public Property | Line | Gets or sets the exterior line of this box.
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea.
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object.
Public Property | Shadow | Gets or sets the Shadow cast under this box.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible.
Top
Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible.
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered.
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.
Top
See Also

Reference

Box Class
dotnetCHARTING Namespace

Tutorial

Box

Samples

Box Corner Styling
Box Headers
Box Shading Effects


%%PageItemTitle%%

dotnetCHARTING Namespace > Box Class : Box Constructor
Box Constructor
Initializes a new instance of the Box class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Box()
public Box()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Box Class
Box Class Methods

For a list of all members of this type, see Box members.

Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible.
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered.
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered.
Top
See Also

Reference

Box Class
dotnetCHARTING Namespace

Tutorial

Box

Samples

Box Corner Styling
Box Headers
Box Shading Effects


Example

dotnetCHARTING Namespace > Box Class : ClearColors Method
ClearColors Method (Box)
Serves as a shortcut to make this box invisible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearColors()
'Usage

Dim instance As Box

instance.ClearColors()
public void ClearColors()
Remarks
The following properties are set when invoked:
Background.Color = Color.Empty
Background.Bevel = false
Line.Color = Color.Empty
Shadow.Color = Color.Empty
InteriorLine.Color = Color.Empty
Example
Clears legend colors.
  • C#
Chart.LegendBox.ClearColors();
  • Visual Basic
Chart.LegendBox.ClearColors()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : GetCoordinates Method
GetCoordinates Method (Box)
Gets the coordinates of this box after the chart is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetCoordinates() As Point()
'Usage

Dim instance As Box
Dim value() As Point

value = instance.GetCoordinates()
public Point[] GetCoordinates()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : GetRectangle Method
GetRectangle Method (Box)
Gets a Rectangle object indicating this boxes position and size after the chart is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetRectangle() As Rectangle
'Usage

Dim instance As Box
Dim value As Rectangle

value = instance.GetRectangle()
public Rectangle GetRectangle()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Box Class
Box Class Properties

For a list of all members of this type, see Box members.

Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property | CornerBottomRight | Gets or sets the bottom right corner style.
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

Public Property | CornerTopLeft | Gets or sets the top left corner style.
Public Property | CornerTopRight | Gets or sets the top right corner style.
Public Property | DefaultCorner | Gets or sets the default box corner style.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content.
Public Property | IconPath | Gets or sets the icon path of this title box.
Public Property | InteriorLine | Gets or sets the interior line of this legend box.
Public Property | Label | Gets or sets the Label of this box.
Public Property | Line | Gets or sets the exterior line of this box.
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea.
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object.
Public Property | Shadow | Gets or sets the Shadow cast under this box.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible.
Top
See Also

Reference

Box Class
dotnetCHARTING Namespace

Tutorial

Box

Samples

Box Corner Styling
Box Headers
Box Shading Effects


dotnetCHARTING Namespace > Box Class : Background Property
Background Property (Box)
Gets or sets a background object used to fill the interior of this box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As Box
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : CornerBottomLeft Property
CornerBottomLeft Property (Box)
Gets or sets the bottom left corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerBottomLeft As BoxCorner
'Usage

Dim instance As Box
Dim value As BoxCorner

instance.CornerBottomLeft = value

value = instance.CornerBottomLeft
public BoxCorner CornerBottomLeft {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : CornerBottomRight Property
CornerBottomRight Property (Box)
Gets or sets the bottom right corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerBottomRight As BoxCorner
'Usage

Dim instance As Box
Dim value As BoxCorner

instance.CornerBottomRight = value

value = instance.CornerBottomRight
public BoxCorner CornerBottomRight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : CornerSize Property
CornerSize Property (Box)

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerSize As Integer
'Usage

Dim instance As Box
Dim value As Integer

instance.CornerSize = value

value = instance.CornerSize
public int CornerSize {get; set;}
Remarks
For a legendbox, this setting is limited to 0-8 pixels, unless the legendbox padding is high enough to accomodate the corner size. For TitleBox and Annotation, a corner size higher than 8 may cause the box padding to increase so that the text on it is not cut off by the corners.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : CornerTopLeft Property
CornerTopLeft Property (Box)
Gets or sets the top left corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerTopLeft As BoxCorner
'Usage

Dim instance As Box
Dim value As BoxCorner

instance.CornerTopLeft = value

value = instance.CornerTopLeft
public BoxCorner CornerTopLeft {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : CornerTopRight Property
CornerTopRight Property (Box)
Gets or sets the top right corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerTopRight As BoxCorner
'Usage

Dim instance As Box
Dim value As BoxCorner

instance.CornerTopRight = value

value = instance.CornerTopRight
public BoxCorner CornerTopRight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


Example

dotnetCHARTING Namespace > Box Class : DefaultCorner Property
DefaultCorner Property (Box)
Gets or sets the default box corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultCorner As BoxCorner
'Usage

Dim instance As Box
Dim value As BoxCorner

instance.DefaultCorner = value

value = instance.DefaultCorner
public BoxCorner DefaultCorner {get; set;}
Remarks
Explicitly set corners will not be overridden.
Example
Usage example.
  • Visual Basic
Chart.LegendBox.DefaultCorner = BoxCorner.Round
  • C#
Chart.LegendBox.DefaultCorner = BoxCorner.Round;
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Header Property
Header Property (Box)
Gets or sets a BoxHeaderOptions object describing this boxes header options and content.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Header As BoxHeaderOptions
'Usage

Dim instance As Box
Dim value As BoxHeaderOptions

instance.Header = value

value = instance.Header
public BoxHeaderOptions Header {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : IconPath Property
IconPath Property
Gets or sets the icon path of this title box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IconPath As String
'Usage

Dim instance As Box
Dim value As String

instance.IconPath = value

value = instance.IconPath
public string IconPath {get; set;}
Remarks
Only the title box supports this feature.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : InteriorLine Property
InteriorLine Property (Box)
Gets or sets the interior line of this legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteriorLine As Line
'Usage

Dim instance As Box
Dim value As Line

instance.InteriorLine = value

value = instance.InteriorLine
public Line InteriorLine {get; set;}
Remarks
Multiple column legend boxes draw this line to separate columns.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Label Property
Label Property (Box)
Gets or sets the Label of this box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As Box
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Remarks
When the box text is not determined by this label, it's font and color properties will be used for any text that appears in the box. When used as a TitleBox and the position is set to FullWithLegend, the font properties of ChartArea.LegendBox.Label will be used for the legend entries and the Chart.TitleBox.Label properties and text will be used for the title.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Line Property
Line Property (Box)
Gets or sets the exterior line of this box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As Box
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Orientation Property
Orientation Property (Box)
Gets or sets this object's orientation around a ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As Orientation
'Usage

Dim instance As Box
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public Orientation Orientation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Padding Property
Padding Property (Box)
Gets or sets a value in pixels that represents the padding between objects within the box and the box walls.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As Integer
'Usage

Dim instance As Box
Dim value As Integer

instance.Padding = value

value = instance.Padding
public int Padding {get; set;}
Remarks
Legend boxes also use this property to set the padding between entries.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


Example

dotnetCHARTING Namespace > Box Class : Position Property
Position Property (Box)
Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Position As Object
'Usage

Dim instance As Box
Dim value As Object

instance.Position = value

value = instance.Position
public virtual object Position {get; set;}

Property Value

TitleBoxPosition, LegendBoxPosition enumeration, or System.Drawing.Point.
Example
Show 3 uses of the property.
  • Visual Basic
'Title position
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend
'Legend box position
Chart.LegendBox.Position = LegendBoxPosition.Top
'Absolute legend position in pixels
Chart.LegendBox.Position = New Point(10,15)
  • C#
//Title position
Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend;
//Legend box position
Chart.LegendBox.Position = LegendBoxPosition.Top;
//Absolute legend position in pixels
Chart.LegendBox.Position = New Point(10,15);
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Shadow Property
Shadow Property (Box)
Gets or sets the Shadow cast under this box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shadow As Shadow
'Usage

Dim instance As Box
Dim value As Shadow

instance.Shadow = value

value = instance.Shadow
public Shadow Shadow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


dotnetCHARTING Namespace > Box Class : Visible Property
Visible Property (Box)
Gets or sets a value that indicates whether this box is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Box
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Box Class
Box Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : BoxHeaderOptions Class
BoxHeaderOptions Class
Represents a box header with options that control its layout, styling, and contents.
Object Model
BoxHeaderOptions ClassBackground ClassLabel ClassLine ClassShadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class BoxHeaderOptions
'Usage

Dim instance As BoxHeaderOptions
public class BoxHeaderOptions
Inheritance Hierarchy

System.Object
dotnetCHARTING.BoxHeaderOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : BoxHeaderOptions Class
BoxHeaderOptions Class Members

The following tables list the members exposed by BoxHeaderOptions.

Public Constructors
 | Name | Description
Public Constructor | BoxHeaderOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that is used to fill the background of this header.
Public Property | EndAlignment | Gets or sets an EdgeAlignment value that controls the alignment of the header's right side in relation to the parent box and the header label.
Public Property | EndCap | Gets or sets a BoxCapStyle describing this headers right cap style.
Public Property | Label | Gets or sets a Label object that is drawn in this header. A header will not be shown if the label does not contain any text.
Public Property | Line | Gets or sets a Line object used to draw the outline of this header.
Public Property | Offset | Gets or sets a Point object representing the offset of this box header in pixels.
Public Property | Orientation | Gets or sets an Orientation enumeration that specifies how the header is oriented in regard to the parent box. Top, Left, Right, and Bottom orientation settings are supported.
Public Property | Shadow | Gets or sets the Shadow cast under this header.
Public Property | StartAlignment | Gets or sets an EdgeAlignment value that controls the alignment of the header's left side in relation to the parent box and the header label.
Public Property | StartCap | Gets or sets a BoxCapStyle describing this headers left cap style.
Public Property | VerticalAlignment | Gets or sets an EdgeAlignment value that controls the vertical alignment of the header in relation to the parent box.
Top
See Also

Reference

BoxHeaderOptions Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > BoxHeaderOptions Class : BoxHeaderOptions Constructor
BoxHeaderOptions Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New BoxHeaderOptions()
public BoxHeaderOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : BoxHeaderOptions Class
BoxHeaderOptions Class Properties

For a list of all members of this type, see BoxHeaderOptions members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that is used to fill the background of this header.
Public Property | EndAlignment | Gets or sets an EdgeAlignment value that controls the alignment of the header's right side in relation to the parent box and the header label.
Public Property | EndCap | Gets or sets a BoxCapStyle describing this headers right cap style.
Public Property | Label | Gets or sets a Label object that is drawn in this header. A header will not be shown if the label does not contain any text.
Public Property | Line | Gets or sets a Line object used to draw the outline of this header.
Public Property | Offset | Gets or sets a Point object representing the offset of this box header in pixels.
Public Property | Orientation | Gets or sets an Orientation enumeration that specifies how the header is oriented in regard to the parent box. Top, Left, Right, and Bottom orientation settings are supported.
Public Property | Shadow | Gets or sets the Shadow cast under this header.
Public Property | StartAlignment | Gets or sets an EdgeAlignment value that controls the alignment of the header's left side in relation to the parent box and the header label.
Public Property | StartCap | Gets or sets a BoxCapStyle describing this headers left cap style.
Public Property | VerticalAlignment | Gets or sets an EdgeAlignment value that controls the vertical alignment of the header in relation to the parent box.
Top
See Also

Reference

BoxHeaderOptions Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > BoxHeaderOptions Class : Background Property
Background Property (BoxHeaderOptions)
Gets or sets a Background object that is used to fill the background of this header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As BoxHeaderOptions
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : EndAlignment Property
EndAlignment Property
Gets or sets an EdgeAlignment value that controls the alignment of the header's right side in relation to the parent box and the header label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndAlignment As EdgeAlignment
'Usage

Dim instance As BoxHeaderOptions
Dim value As EdgeAlignment

instance.EndAlignment = value

value = instance.EndAlignment
public EdgeAlignment EndAlignment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : EndCap Property
EndCap Property (BoxHeaderOptions)
Gets or sets a BoxCapStyle describing this headers right cap style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndCap As BoxCapStyle
'Usage

Dim instance As BoxHeaderOptions
Dim value As BoxCapStyle

instance.EndCap = value

value = instance.EndCap
public BoxCapStyle EndCap {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : Label Property
Label Property (BoxHeaderOptions)
Gets or sets a Label object that is drawn in this header. A header will not be shown if the label does not contain any text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As BoxHeaderOptions
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : Line Property
Line Property (BoxHeaderOptions)
Gets or sets a Line object used to draw the outline of this header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As BoxHeaderOptions
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : Offset Property
Offset Property (BoxHeaderOptions)
Gets or sets a Point object representing the offset of this box header in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Offset As Point
'Usage

Dim instance As BoxHeaderOptions
Dim value As Point

instance.Offset = value

value = instance.Offset
public Point Offset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : Orientation Property
Orientation Property (BoxHeaderOptions)
Gets or sets an Orientation enumeration that specifies how the header is oriented in regard to the parent box. Top, Left, Right, and Bottom orientation settings are supported.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As Orientation
'Usage

Dim instance As BoxHeaderOptions
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public Orientation Orientation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : Shadow Property
Shadow Property (BoxHeaderOptions)
Gets or sets the Shadow cast under this header.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shadow As Shadow
'Usage

Dim instance As BoxHeaderOptions
Dim value As Shadow

instance.Shadow = value

value = instance.Shadow
public Shadow Shadow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : StartAlignment Property
StartAlignment Property
Gets or sets an EdgeAlignment value that controls the alignment of the header's left side in relation to the parent box and the header label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartAlignment As EdgeAlignment
'Usage

Dim instance As BoxHeaderOptions
Dim value As EdgeAlignment

instance.StartAlignment = value

value = instance.StartAlignment
public EdgeAlignment StartAlignment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : StartCap Property
StartCap Property (BoxHeaderOptions)
Gets or sets a BoxCapStyle describing this headers left cap style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartCap As BoxCapStyle
'Usage

Dim instance As BoxHeaderOptions
Dim value As BoxCapStyle

instance.StartCap = value

value = instance.StartCap
public BoxCapStyle StartCap {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


dotnetCHARTING Namespace > BoxHeaderOptions Class : VerticalAlignment Property
VerticalAlignment Property
Gets or sets an EdgeAlignment value that controls the vertical alignment of the header in relation to the parent box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property VerticalAlignment As EdgeAlignment
'Usage

Dim instance As BoxHeaderOptions
Dim value As EdgeAlignment

instance.VerticalAlignment = value

value = instance.VerticalAlignment
public EdgeAlignment VerticalAlignment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

BoxHeaderOptions Class
BoxHeaderOptions Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : CalendarPattern Class
CalendarPattern Class
Specifies a calendar pattern such as weekends in a week.
Object Model
CalendarPattern ClassCalendarPattern ClassCalendarPattern Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class CalendarPattern
'Usage

Dim instance As CalendarPattern
public class CalendarPattern
Remarks

The pattern is represented by an array of boolean values. CalendarPattern.PatternFromString can be used to quickly create patterns using simple strings. A week pattern would look like this: "0000000". A zero for each day of the week. To indicate weekends the pattern will be "1000001". The time units must also be specified.

Each one or zero represents a day:
myCalendarPattern.PatternUnit = TimeInterval.Day

The entire pattern represents a week:
myCalendarPattern.CalendarUnit = TimeInterval.Week

The above calendar pattern will flag each saturday and sunday in a given, time span.

Inheritance Hierarchy

System.Object
dotnetCHARTING.CalendarPattern

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Members
dotnetCHARTING Namespace
AxisMarker Class
Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

Tutorials

Calendar Patterns

Samples

Calendar Pattern
Scale Break Calendar Pattern


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : CalendarPattern Class
CalendarPattern Class Members

The following tables list the members exposed by CalendarPattern.

Public Constructors
 | Name | Description
Public Constructor | CalendarPattern Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AdjustmentUnit | Gets or sets a values by which the time interval is offset on the axis.
Public Property | CalendarUnit | Gets or sets a TimeInterval that represents the time unit of the entire Pattern.
Public Property | Pattern | Gets or sets the calendar pattern.
Public Property | PatternUnit | Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.
static (Shared in Visual Basic) | Weekdays | Gets a calendar pattern instance representing weekdays.
static (Shared in Visual Basic) | Weekends | Gets a calendar pattern instance representing weekends.
Top
Public Methods
 | Name | Description
Public Method | Invert | Inverts this CalendarPattern.
static (Shared in Visual Basic) | PatternFromString | Gets a boolean array from a string of ones (1) and zeros (0).
Top
See Also

Reference

CalendarPattern Class
dotnetCHARTING Namespace
AxisMarker Class
Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

Tutorials

Calendar Patterns

Samples

Calendar Pattern
Scale Break Calendar Pattern


%%PageItemTitle%%

dotnetCHARTING Namespace > CalendarPattern Class : CalendarPattern Constructor
CalendarPattern Constructor
Overload List
Overload | Description
CalendarPattern Constructor() | Initializes a new instance of the CalendarPattern class.
CalendarPattern Constructor(TimeInterval,TimeInterval,Boolean[]) | Initializes a new instance of the CalendarPattern class with time units and a pattern.
CalendarPattern Constructor(TimeInterval,TimeInterval,String) | Initializes a new instance of the CalendarPattern class with time units and a string pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


%%PageItemTitle%%

dotnetCHARTING Namespace > CalendarPattern Class > CalendarPattern Constructor : CalendarPattern Constructor()
CalendarPattern Constructor()
Initializes a new instance of the CalendarPattern class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New CalendarPattern()
public CalendarPattern()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members
Overload List


%%PageItemTitle%%

Example

dotnetCHARTING Namespace > CalendarPattern Class > CalendarPattern Constructor : CalendarPattern Constructor(TimeInterval,TimeInterval,Boolean[])
CalendarPattern Constructor(TimeInterval,TimeInterval,Boolean[])
Initializes a new instance of the CalendarPattern class with time units and a pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal mappedTimeUnit As TimeInterval, _
   ByVal wholeTimeUnit As TimeInterval, _
   ByVal timePattern() As Boolean _
)
'Usage

Dim mappedTimeUnit As TimeInterval
Dim wholeTimeUnit As TimeInterval
Dim timePattern() As Boolean

Dim instance As New CalendarPattern(mappedTimeUnit, wholeTimeUnit, timePattern)
public CalendarPattern(
   TimeInterval mappedTimeUnit,
   TimeInterval wholeTimeUnit,
   bool[] timePattern
)

Parameters

mappedTimeUnit
wholeTimeUnit
timePattern
Example
This instantiates a new CallendarPattern of a week marking the saturday and sunday. It uses the PatternFromString method to simplify adding a pattern by using a string.
  • C#
CalendarPattern newPattern = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,CalendarPattern.PatternFromString("1000001"));
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members
Overload List


%%PageItemTitle%%

Example

dotnetCHARTING Namespace > CalendarPattern Class > CalendarPattern Constructor : CalendarPattern Constructor(TimeInterval,TimeInterval,String)
CalendarPattern Constructor(TimeInterval,TimeInterval,String)
Initializes a new instance of the CalendarPattern class with time units and a string pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal mappedTimeUnit As TimeInterval, _
   ByVal wholeTimeUnit As TimeInterval, _
   ByVal timePattern As String _
)
'Usage

Dim mappedTimeUnit As TimeInterval
Dim wholeTimeUnit As TimeInterval
Dim timePattern As String

Dim instance As New CalendarPattern(mappedTimeUnit, wholeTimeUnit, timePattern)
public CalendarPattern(
   TimeInterval mappedTimeUnit,
   TimeInterval wholeTimeUnit,
   string timePattern
)

Parameters

mappedTimeUnit
wholeTimeUnit
timePattern
Example
This instantiates a new CallendarPattern of a week marking the saturday and sunday.
  • C#
CalendarPattern newPattern = new CalendarPattern(TimeInterval.Day,TimeInterval.Week,"1000001");
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : CalendarPattern Class
CalendarPattern Class Methods

For a list of all members of this type, see CalendarPattern members.

Public Methods
 | Name | Description
Public Method | Invert | Inverts this CalendarPattern.
static (Shared in Visual Basic) | PatternFromString | Gets a boolean array from a string of ones (1) and zeros (0).
Top
See Also

Reference

CalendarPattern Class
dotnetCHARTING Namespace
AxisMarker Class
Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

Tutorials

Calendar Patterns

Samples

Calendar Pattern
Scale Break Calendar Pattern


dotnetCHARTING Namespace > CalendarPattern Class : Invert Method
Invert Method
Inverts this CalendarPattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Invert()
'Usage

Dim instance As CalendarPattern

instance.Invert()
public void Invert()
Remarks
If the pattern is "0011", after this operation it will become "1100".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


dotnetCHARTING Namespace > CalendarPattern Class : PatternFromString Method
A pattern in a string form. A string of "1100" will return [ true, true, false, false ]. The boolean array can be used to set the Pattern property of this CalendPattern.
PatternFromString Method
Gets a boolean array from a string of ones (1) and zeros (0).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function PatternFromString( _
   ByVal str As String _
) As Boolean()
'Usage

Dim str As String
Dim value() As Boolean

value = CalendarPattern.PatternFromString(str)
public static bool[] PatternFromString(
   string str
)

Parameters

str
A pattern in a string form. A string of "1100" will return [ true, true, false, false ]. The boolean array can be used to set the Pattern property of this CalendPattern.

Return Value

bool[]
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : CalendarPattern Class
CalendarPattern Class Properties

For a list of all members of this type, see CalendarPattern members.

Public Properties
 | Name | Description
Public Property | AdjustmentUnit | Gets or sets a values by which the time interval is offset on the axis.
Public Property | CalendarUnit | Gets or sets a TimeInterval that represents the time unit of the entire Pattern.
Public Property | Pattern | Gets or sets the calendar pattern.
Public Property | PatternUnit | Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.
static (Shared in Visual Basic) | Weekdays | Gets a calendar pattern instance representing weekdays.
static (Shared in Visual Basic) | Weekends | Gets a calendar pattern instance representing weekends.
Top
See Also

Reference

CalendarPattern Class
dotnetCHARTING Namespace
AxisMarker Class
Trim(dotnetCHARTING.CalendarPattern, dotnetCHARTING.ElementValue) Method (dotnetCHARTING.Series)

Tutorials

Calendar Patterns

Samples

Calendar Pattern
Scale Break Calendar Pattern


dotnetCHARTING Namespace > CalendarPattern Class : AdjustmentUnit Property
AdjustmentUnit Property
Gets or sets a values by which the time interval is offset on the axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AdjustmentUnit As TimeInterval
'Usage

Dim instance As CalendarPattern
Dim value As TimeInterval

instance.AdjustmentUnit = value

value = instance.AdjustmentUnit
public TimeInterval AdjustmentUnit {get; set;}
Remarks
This property can be useful with axis markers because tick marks may appear at the beginning of a time unit like month. The calendar pattern may need to be adjusted to properly correspond to axis ticks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members

Samples

Calendar Pattern


dotnetCHARTING Namespace > CalendarPattern Class : CalendarUnit Property
CalendarUnit Property
Gets or sets a TimeInterval that represents the time unit of the entire Pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CalendarUnit As TimeInterval
'Usage

Dim instance As CalendarPattern
Dim value As TimeInterval

instance.CalendarUnit = value

value = instance.CalendarUnit
public TimeInterval CalendarUnit {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


dotnetCHARTING Namespace > CalendarPattern Class : Pattern Property
Pattern Property
Gets or sets the calendar pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Pattern As Boolean()
'Usage

Dim instance As CalendarPattern
Dim value() As Boolean

instance.Pattern = value

value = instance.Pattern
public bool[] Pattern {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


dotnetCHARTING Namespace > CalendarPattern Class : PatternUnit Property
PatternUnit Property
Gets or sets a TimeInterval that represents the time unit of each Boolean value in the Pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PatternUnit As TimeInterval
'Usage

Dim instance As CalendarPattern
Dim value As TimeInterval

instance.PatternUnit = value

value = instance.PatternUnit
public TimeInterval PatternUnit {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


dotnetCHARTING Namespace > CalendarPattern Class : Weekdays Property
Weekdays Property
Gets a calendar pattern instance representing weekdays.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Weekdays As CalendarPattern
'Usage

Dim value As CalendarPattern

value = CalendarPattern.Weekdays
public static CalendarPattern Weekdays {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


dotnetCHARTING Namespace > CalendarPattern Class : Weekends Property
Weekends Property
Gets a calendar pattern instance representing weekends.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Weekends As CalendarPattern
'Usage

Dim value As CalendarPattern

value = CalendarPattern.Weekends
public static CalendarPattern Weekends {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

CalendarPattern Class
CalendarPattern Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Chart Class
Chart Class
The .netCHARTING control.
Object Model
Chart ClassAnnotationCollection ClassAnnotation ClassAxisCollection ClassAxis ClassBackground ClassAnnotation ClassChartArea ClassChartAreaLayout ClassAxis ClassBox ClassChartArea ClassElement ClassLegendBox ClassSeries ClassShadow ClassBox ClassChartAreaCollection ClassChartArea ClassLegendBoxCollection ClassLegendBox ClassFileManager ClassHotspot ClassJsOptions ClassLegendBox ClassMapping ClassNavigatorOptions ClassLabel ClassSeries ClassSeriesCollection ClassSeries ClassTimeIntervalAdvanced ClassSmartPalette ClassBox ClassView3D ClassAxis ClassAxis ClassAxis ClassImageZoomer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Chart
   Inherits System.Web.UI.WebControls.WebControl
'Usage

Dim instance As Chart
public class Chart : System.Web.UI.WebControls.WebControl
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart
dotnetCHARTING.Zoomer.ChartControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods Events

dotnetCHARTING Namespace : Chart Class
Chart Class Members

The following tables list the members exposed by Chart.

Public Constructors
 | Name | Description
Public Constructor | Chart Constructor | Initializes a new empty instance of the Chart control.
Top
Public Properties
Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.
Public Property | Annotations | A collection of Annotation objects drawn on the chart.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.
Public Property | AxisCollection | Contains a collection of calculated Axis objects.
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Background | Gets or sets the Background of this chart.
Public Property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from System.Web.UI.Control)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Box

Gets or sets an Annotation object that is drawn as the background for this chart.

Public Property | BubbleCenterStack | Gets or sets a boolean value to control bubble center stack.
Public Property | BubbleStackShadeAsOne | Gets or sets a boolean value to control bubble stack shade.
Public Property | CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.
Public Property | CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.
Public Property | ChartArea | Gets or sets the main ChartArea of the image.
Public Property | ChartAreaLayout | Gets or sets chart area layout options.
Public Property | ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.
Public Property | CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.
Public Property | CleanupPeriod | Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property | DataGrid | Gets or sets the control object or ID of a datagrid control that will be populated with the charted data.
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property | DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart.
Public Property | DefaultAxis | Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.
Public Property | DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.
Public Property | DefaultChartArea | Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.
Public Property | DefaultCultureName | Gets or sets the default culture name which determines number and date formatting.
Public Property | DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.
Public Property | DefaultLegendBox | Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.
Public Property | DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.
Public Property | DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows.
Public Property | DefaultTitleBox | Gets a Box object whose property settings will propagate to all title boxes on the chart image.
Public Property | Depth | Gets or sets depth of the chart when Use3D is true.
Public Property | DisableBrowserCache | Gets or sets a value indicating whether disable browser cache.
Public Property | DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.
Public Property | Dpi | Gets or sets the resolution, in dots per inch, of the chart Bitmap.
Public Property DrillDownChain

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.
Public Property | ExtraChartAreas | Gets a collection of additional ChartArea objects added to the chart.
Public Property | ExtraLegendBoxes | Gets a collection of additional LegendBox objects added to the chart.
Public Property | FileManager | Gets or sets the chart's instance of the FileManager which facilitates saving images.
Public Property | FileName | See Chart.FileManager.FileName.
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FunnelNozzlePercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel height that comprises the funnel's nozzle.
Public Property | FunnelNozzleWidthPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel width that comprises the funnel's nozzle.
Public Property | FunnelSpacingPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the funnel's spacing.
Public Property | GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's Element.Complete value is set.
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.
Public Property | HatchStylePaletteName | Gets or sets a predefined HatchStylePalette that defines element and series hatch style.
Public Property | Height | Overridden. Gets or sets the height of the chart image.
Public Property | Hotspot | Gets or sets the Hotspot property of the chart image.
Public Property | HotspotMinimumSize | Gets or sets a value that indicates the minimum size in pixels a hotspot must be in order for it to be generated.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageFormat | Gets or sets an ImageFormat enumeration specifying the generated image's file type.
Public Property | ImageMapName | Returns a string for the image map name generated for the current chart image.
Public Property | ImageMapText | Returns a string for the image map generated for the current chart image.
Public Property | JS | Provides JavaScript chart functionality.
Public Property | LegacyMode | Gets or sets a value that indicates whether original chart defaults are used instead of new defaults introduced with version 10.
Public Property | LegendBox | Gets or sets a LegendBox object that represents the legend box.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | Mapping | This property is used only when using a map chart: (Chart.Type = ChartType.Map).
Public Property | Margin | Gets or sets a string which automatically sets multiple margins as a shortcut.
Public Property | MarginBottom | Gets or sets the bottom margin of the chart image.
Public Property | MarginLeft | Gets or sets the left margin of the chart image.
Public Property | MarginRight | Gets or sets the right margin of the chart image.
Public Property | MarginTop | Gets or sets the top margin of the chart image.
Public Property | MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.
Public Property | MaximumBubbleSizeValue | Gets or sets the maximum value the bubble size will be based on where a bubble size value of MaximumBubbleSizeValue equals a bubble of size MaximumBubbleSize.
Public Property | Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Navigator | Provides SliverLight functionality.
Public Property | NoDataLabel | Gets or sets a label shown on the chart when no data is available.
Public Property | ObjectChart | Gets or sets an object that will be drawn instead of the chart and will dynamically resize the chart image to fit the object's size. The supported objects are Label and Annotation.
Public Property | OrganizationalConnectorType | (JS Chart Only) Specifies the connector type (straight or right-angle) for organizatioal charts.
Public Property | OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Palette | Gets or sets an array of colors that define element and series colors.
Public Property | PaletteName | Gets or sets a predefined Palette that defines element and series colors.
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing.
Public Property | RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.
Public Property | ReloadPeriod | Gets or sets a System.TimeSpan object that determines how often the page containing this chart will automatically reload.
Public Property | Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property | SeriesCollection | Gets a SeriesCollection object which represents the data this chart will render.
Public Property | ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.
Public Property | ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title. The formatting of the shown dates can be controlled with Chart.DefaultCultureName.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | Size | Sets a string that automatically sets the Height and Width of the chart image.
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmallChartMode | Gets or sets a value that indicates whether this chart uses the SmallChartMode.
Public Property | SmartForecast | Gets or sets a TimeIntervalAdvanced object that specifies a time span shown on the chart. The span shown is an interval which encompasses the time the chart is rendered. A trend line is also added for the entire span shown and uses values not shown in it's calculation to improve accuracy.
Public Property | SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.
Public Property | SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization.
Public Property | SpacingPercentage | Gets or sets the spacing percentage of pyramids, cones, and funnels with ChartType.Multiple .
Public Property | SpacingPercentageNested | Gets or sets a value that indicates the spacing percentage of nested pies.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SubValueDateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.
Public Property | TitleBox | Gets or sets a Box object that represents the title box.
Public Property | ToolTip | Overridden. Gets or sets the Tooltip of the entinre chart image.
Public Property | TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.
Public Property | Transpose | Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.
Public Property | Type | Gets or sets the ChartType of this Chart.
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | URL | Gets or sets the URL of the entinre chart image.
Public Property | URLTarget | Gets or sets the target of the URL link.
Public Property | Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D.
Public Property | UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.
Public Property UseSession

Gets or sets a value indicating whether the generated image is saved
temporarily in a session variable for subsequent streaming from a helper aspx page. This option may only be used when UseFile = false.

Public Property | View3D | Gets or sets the View3D class that contains properties to control the rendering of 3D surface charts.
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Gets or sets the width of the chart image.
Public Property XAxis

Gets or Sets the main XAxis which all series inherit by default.

Public Property YAxis

Gets or Sets the main YAxis which all series inherit by default.

Public Property ZAxis

Gets or Sets the main ZAxis which all series inherit by default. The ZAxis is used with surface charts.

Public Property | Zoomer | Provides AJAX zooming and scrolling feature settings.
Top
Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetChartBitmap | Obtains a System.Drawing.Bitmap of the generated chart.
Public Method | GetChartJS | Returns a string contains the Javascript chart configuration.
Public Method | GetChartMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Public Method | GetChartStream | Returns the memory stream of the image.
Public Method | GetLegendBitmap | Obtains a System.Drawing.Bitmap of the legend generated by the chart.
Public Method | GetLegendMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | HitTest |
Public Method | LoadState | Overloaded. Imports a chart object from the specified xml file.
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | PaletteAdd | Overloaded. Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overridden. Outputs chart server control content to a provided HtmlTextWriter object.
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SaveState | Overloaded. string LoadState() void LoadState(string xmlFilePath,Chart chartObject) string LoadState(Chart chartObject)
Public Method | SaveStateJSON | Overloaded.
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | ErrorProcessing |
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PostDataProcessing | Occurs when the the chart is completed the data processing.
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Chart Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > Chart Class : Chart Constructor
Chart Constructor
Initializes a new empty instance of the Chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Chart()
public Chart()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Chart Class
Chart Class Methods

For a list of all members of this type, see Chart members.

Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetChartBitmap | Obtains a System.Drawing.Bitmap of the generated chart.
Public Method | GetChartJS | Returns a string contains the Javascript chart configuration.
Public Method | GetChartMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Public Method | GetChartStream | Returns the memory stream of the image.
Public Method | GetLegendBitmap | Obtains a System.Drawing.Bitmap of the legend generated by the chart.
Public Method | GetLegendMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | HitTest |
Public Method | LoadState | Overloaded. Imports a chart object from the specified xml file.
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | PaletteAdd | Overloaded. Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Overridden. Outputs chart server control content to a provided HtmlTextWriter object.
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SaveState | Overloaded. string LoadState() void LoadState(string xmlFilePath,Chart chartObject) string LoadState(Chart chartObject)
Public Method | SaveStateJSON | Overloaded.
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Chart Class
dotnetCHARTING Namespace


Example

dotnetCHARTING Namespace > Chart Class : GetChartBitmap Method
GetChartBitmap Method
Obtains a System.Drawing.Bitmap of the generated chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetChartBitmap() As Bitmap
'Usage

Dim instance As Chart
Dim value As Bitmap

value = instance.GetChartBitmap()
public Bitmap GetChartBitmap()

Return Value

A System.Drawing.Bitmap of the chart.
Remarks
When invoked, the Element.Point properties of all elements drawn on the chart will be populated.
Example
  • C#
//Get the bitmap and add a line to the image
Bitmap bmp = Chart.GetChartBitmap();
Graphics g = Graphics.FromImage(bmp);
g.DrawLine(Pens.Red,36,150,480,150);
g.DrawString("This is my line",new Font("Arial",12,FontStyle.Bold),new SolidBrush(Color.Black),new Point(40,150));
g.Dispose();

//Save the image and set the image path to ImageUrl.
string ImagePath = Chart.FileManager.SaveImage(bmp);
Image1.ImageUrl = ImagePath;

//For complete code see PostRenderDrawing.aspx sample
  • Visual Basic
'Get the bitmap and add a line to the image
Dim bmp As Bitmap = Chart.GetChartBitmap()
Dim g As Graphics = Graphics.FromImage(bmp)
g.DrawLine(Pens.Red, 36, 150, 480, 150)
g.DrawString("This is my line", new Font("Arial", 12, FontStyle.Bold), new SolidBrush(Color.Black), new PointF(40F, 150F))
g.Dispose()

'Save the image and set the image path to ImageUrl.
Dim ImagePath As String = Chart.FileManager.SaveImage(bmp)
Image1.ImageUrl = ImagePath

'For complete code see PostRenderDrawing.aspx sample
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : GetChartJS Method
GetChartJS Method
Returns a string contains the Javascript chart configuration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetChartJS() As String
'Usage

Dim instance As Chart
Dim value As String

value = instance.GetChartJS()
public string GetChartJS()

Return Value

A string of the Javascript chart configuration.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : GetChartMetafile Method
GetChartMetafile Method
Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetChartMetafile() As Metafile
'Usage

Dim instance As Chart
Dim value As Metafile

value = instance.GetChartMetafile()
public Metafile GetChartMetafile()

Return Value

A System.Drawing.Imaging.Metafile of the chart image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : GetChartStream Method
GetChartStream Method
Returns the memory stream of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetChartStream() As MemoryStream
'Usage

Dim instance As Chart
Dim value As MemoryStream

value = instance.GetChartStream()
public MemoryStream GetChartStream()

Return Value

A System.IO.MemoryStream of the chart image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : GetLegendBitmap Method
GetLegendBitmap Method
Obtains a System.Drawing.Bitmap of the legend generated by the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLegendBitmap() As Bitmap
'Usage

Dim instance As Chart
Dim value As Bitmap

value = instance.GetLegendBitmap()
public Bitmap GetLegendBitmap()

Return Value

A System.Drawing.Bitmap of the legend.
Remarks
When invoked, the Element.Point properties of all elements drawn on the chart will be populated.
Example
  • C#
//Save the legend as a separate image file
System.Web.UI.WebControls.Image ImageLegend = new System.Web.UI.WebControls.Image();
ImageLegend.ImageUrl = Chart.FileManager.SaveImage(Chart.GetLegendBitmap());
Controls.Add(ImageLegend);

//For complete code see SaveLegendImage.aspx sample
  • Visual Basic
' Save the legend as a separate image file
Dim ImageLegend As System.Web.UI.WebControls.Image = new System.Web.UI.WebControls.Image()
ImageLegend.ImageUrl = Chart.FileManager.SaveImage(Chart.GetLegendBitmap())
Controls.Add(ImageLegend)

'For complete code see SaveLegendImage.aspx sample.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : GetLegendMetafile Method
GetLegendMetafile Method
Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetLegendMetafile() As Metafile
'Usage

Dim instance As Chart
Dim value As Metafile

value = instance.GetLegendMetafile()
public Metafile GetLegendMetafile()

Return Value

A System.Drawing.Imaging.Metafile of the legend box image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : HitTest Method
HitTest Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function HitTest( _
   ByVal x As Integer, _
   ByVal y As Integer _
) As HitTestInfo
'Usage

Dim instance As Chart
Dim x As Integer
Dim y As Integer
Dim value As HitTestInfo

value = instance.HitTest(x, y)
public HitTestInfo HitTest(
   int x,
   int y
)

Parameters

x
y
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : LoadState Method
LoadState Method (Chart)
Imports a chart object from the specified xml file.
Overload List
Overload | Description
LoadState(String) | Imports a chart object from the specified xml file.
LoadState(String,Boolean) | Imports a chart object from the specified xml file.
LoadState(String,Chart) | Set the chart object from the specified xml file.
LoadState(String,Chart,Boolean) | Set the chart object from the specified xml file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class > LoadState Method : LoadState(String) Method
A raw xml string or an xml file name to load.
LoadState(String) Method
Imports a chart object from the specified xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadState( _
   ByVal xmlDataOrFileName As String _
)
'Usage

Dim instance As Chart
Dim xmlDataOrFileName As String

instance.LoadState(xmlDataOrFileName)
public void LoadState(
   string xmlDataOrFileName
)

Parameters

xmlDataOrFileName
A raw xml string or an xml file name to load.

Return Value

A chart object.
Remarks
This property takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");
  • Visual Basic
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


Example

dotnetCHARTING Namespace > Chart Class > LoadState Method : LoadState(String,Boolean) Method
A raw xml string or an xml file name to load.
Determine whether clear the chart object before loading the data.
LoadState(String,Boolean) Method
Imports a chart object from the specified xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal clear As Boolean _
) As Object
'Usage

Dim instance As Chart
Dim xmlDataOrFileName As String
Dim clear As Boolean
Dim value As Object

value = instance.LoadState(xmlDataOrFileName, clear)
public object LoadState(
   string xmlDataOrFileName,
   bool clear
)

Parameters

xmlDataOrFileName
A raw xml string or an xml file name to load.
clear
Determine whether clear the chart object before loading the data.

Return Value

A chart object.
Remarks
This property takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");
  • Visual Basic
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


Example

dotnetCHARTING Namespace > Chart Class > LoadState Method : LoadState(String,Chart) Method
A raw xml string or an xml file name to load.
The chart object that be loaded with XML data.
LoadState(String,Chart) Method
Set the chart object from the specified xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal chartObject As Chart _
)
'Usage

Dim instance As Chart
Dim xmlDataOrFileName As String
Dim chartObject As Chart

instance.LoadState(xmlDataOrFileName, chartObject)
public void LoadState(
   string xmlDataOrFileName,
   Chart chartObject
)

Parameters

xmlDataOrFileName
A raw xml string or an xml file name to load.
chartObject
The chart object that be loaded with XML data.
Remarks
This first parameter takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml");
Chart.LoadState("/app/temp/chart.xml");
Chart.LoadState("chart.xml");
  • Visual Basic
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml")
Chart.LoadState("/app/temp/chart.xml")
Chart.LoadState("chart.xml")
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


Example

dotnetCHARTING Namespace > Chart Class > LoadState Method : LoadState(String,Chart,Boolean) Method
Path of XML file or XML data to load.
The chart object that be loaded with XML data.
Determine whether clear the chart object before loading the data.
LoadState(String,Chart,Boolean) Method
Set the chart object from the specified xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub LoadState( _
   ByVal xmlDataOrFileName As String, _
   ByVal chartObject As Chart, _
   ByVal clear As Boolean _
)
'Usage

Dim instance As Chart
Dim xmlDataOrFileName As String
Dim chartObject As Chart
Dim clear As Boolean

instance.LoadState(xmlDataOrFileName, chartObject, clear)
public void LoadState(
   string xmlDataOrFileName,
   Chart chartObject,
   bool clear
)

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.
chartObject
The chart object that be loaded with XML data.
clear
Determine whether clear the chart object before loading the data.
Remarks
This first parameter takes either a raw xml string or an xml file name. For an xml file name it takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of accessing the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml",chartObject,false);
Chart.LoadState("/app/temp/chart.xml",chartObject,false);
Chart.LoadState("chart.xml",chartObject,false);
  • Visual Basic
Chart.LoadState("c://inetpub/wwwroot/app/temp/chart.xml",chartObject,false)
Chart.LoadState("/app/temp/chart.xml",chartObject,false)
Chart.LoadState("chart.xml",chartObject,false)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class : PaletteAdd Method
PaletteAdd Method
Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Overload List
Overload | Description
PaletteAdd(Palette) | Adds the colors of a predefined palette to the existing palette colors stored in Palette.
PaletteAdd(Color[]) | Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class > PaletteAdd Method : PaletteAdd(Palette) Method
PaletteAdd(Palette) Method
Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PaletteAdd( _
   ByVal palette As Palette _
)
'Usage

Dim instance As Chart
Dim palette As Palette

instance.PaletteAdd(palette)
public void PaletteAdd(
   Palette palette
)

Parameters

palette
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class > PaletteAdd Method : PaletteAdd(Color[]) Method
PaletteAdd(Color[]) Method
Adds the colors of a predefined palette to the existing palette colors stored in Palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub PaletteAdd( _
   ByVal newColors() As Color _
)
'Usage

Dim instance As Chart
Dim newColors() As Color

instance.PaletteAdd(newColors)
public void PaletteAdd(
   Color[] newColors
)

Parameters

newColors
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class : RenderControl(HtmlTextWriter) Method
RenderControl(HtmlTextWriter) Method
Outputs chart server control content to a provided HtmlTextWriter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Sub RenderControl( _
   ByVal writer As HtmlTextWriter _
)
'Usage

Dim instance As Chart
Dim writer As HtmlTextWriter

instance.RenderControl(writer)
public override void RenderControl(
   HtmlTextWriter writer
)

Parameters

writer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Base Implementation in RenderControl(HtmlTextWriter)


dotnetCHARTING Namespace > Chart Class : SaveState Method
SaveState Method (Chart)

string LoadState()

void LoadState(string xmlFilePath,Chart chartObject)

string LoadState(Chart chartObject)

Overload List
Overload | Description
SaveState(String) | Saves this chart instance to an xml file.
SaveState(String,Chart) | Saves the chart instance to an xml file.
SaveState() | Saves this chart instance to an xml string.
SaveState(Chart) | Saves the chart instance to an xml string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class > SaveState Method : SaveState(String) Method
Path of XML file.
SaveState(String) Method
Saves this chart instance to an xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveState( _
   ByVal xmlFilePath As String _
)
'Usage

Dim instance As Chart
Dim xmlFilePath As String

instance.SaveState(xmlFilePath)
public void SaveState(
   string xmlFilePath
)

Parameters

xmlFilePath
Path of XML file.
Remarks
This first parameter takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of saving in the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj);
Chart.SaveState("/app/temp/chart.xml",chartObj);
Chart.SaveState("chart.xml",chartObj);
  • Visual Basic
Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj)
Chart.SaveState("/app/temp/chart.xml",chartObj)
Chart.SaveState("chart.xml",chartObj)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


Example

dotnetCHARTING Namespace > Chart Class > SaveState Method : SaveState(String,Chart) Method
Path of the XML file.
The chart object is being serialized.
SaveState(String,Chart) Method
Saves the chart instance to an xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveState( _
   ByVal xmlFilePath As String, _
   ByVal chartObject As Chart _
)
'Usage

Dim instance As Chart
Dim xmlFilePath As String
Dim chartObject As Chart

instance.SaveState(xmlFilePath, chartObject)
public void SaveState(
   string xmlFilePath,
   Chart chartObject
)

Parameters

xmlFilePath
Path of the XML file.
chartObject
The chart object is being serialized.
Remarks
This first parameter takes either an absolute path 'c:/inetpub/wwwroot/app/chart.xml', a physical UNC path ('\\myUncPath\cahrt.xml'), a relative path ('temp/chart.xml',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/chart.xml), or only a file name 'chart.xml' in the temp directory.
Example
This examples demonstrate different ways of saving in the same xml file in temp directory: 'c:/inetpub/wwwroot/app/temp/Chart.xml' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj);
Chart.SaveState("/app/temp/chart.xml",chartObj);
Chart.SaveState("chart.xml",chartObj);
  • Visual Basic
Chart.SaveState("c://inetpub/wwwroot/app/temp/chart.xml",chartObj)
Chart.SaveState("/app/temp/chart.xml",chartObj)
Chart.SaveState("chart.xml",chartObj)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class > SaveState Method : SaveState() Method
SaveState() Method
Saves this chart instance to an xml string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveState() As String
'Usage

Dim instance As Chart
Dim value As String

value = instance.SaveState()
public string SaveState()

Return Value

The xml string which represent the current chart object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class > SaveState Method : SaveState(Chart) Method
The chart object is being serialized.
SaveState(Chart) Method
Saves the chart instance to an xml string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveState( _
   ByVal chartObject As Chart _
) As String
'Usage

Dim instance As Chart
Dim chartObject As Chart
Dim value As String

value = instance.SaveState(chartObject)
public string SaveState(
   Chart chartObject
)

Parameters

chartObject
The chart object is being serialized.

Return Value

The xml string which represent the chart object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class : SaveStateJSON Method
SaveStateJSON Method
Overload List
Overload | Description
SaveStateJSON() |
SaveStateJSON(Object) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class > SaveStateJSON Method : SaveStateJSON() Method
SaveStateJSON() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveStateJSON() As String
'Usage

Dim instance As Chart
Dim value As String

value = instance.SaveStateJSON()
public string SaveStateJSON()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


dotnetCHARTING Namespace > Chart Class > SaveStateJSON Method : SaveStateJSON(Object) Method
SaveStateJSON(Object) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveStateJSON( _
   ByVal obj As Object _
) As String
'Usage

Dim instance As Chart
Dim obj As Object
Dim value As String

value = instance.SaveStateJSON(obj)
public string SaveStateJSON(
   object obj
)

Parameters

obj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Chart Class
Chart Class Properties

For a list of all members of this type, see Chart members.

Public Properties
Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.
Public Property | Annotations | A collection of Annotation objects drawn on the chart.
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.
Public Property | AxisCollection | Contains a collection of calculated Axis objects.
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Background | Gets or sets the Background of this chart.
Public Property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from System.Web.UI.Control)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Box

Gets or sets an Annotation object that is drawn as the background for this chart.

Public Property | BubbleCenterStack | Gets or sets a boolean value to control bubble center stack.
Public Property | BubbleStackShadeAsOne | Gets or sets a boolean value to control bubble stack shade.
Public Property | CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.
Public Property | CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.
Public Property | ChartArea | Gets or sets the main ChartArea of the image.
Public Property | ChartAreaLayout | Gets or sets chart area layout options.
Public Property | ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.
Public Property | CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.
Public Property | CleanupPeriod | Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property | DataGrid | Gets or sets the control object or ID of a datagrid control that will be populated with the charted data.
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property | DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart.
Public Property | DefaultAxis | Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.
Public Property | DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.
Public Property | DefaultChartArea | Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.
Public Property | DefaultCultureName | Gets or sets the default culture name which determines number and date formatting.
Public Property | DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.
Public Property | DefaultLegendBox | Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.
Public Property | DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.
Public Property | DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows.
Public Property | DefaultTitleBox | Gets a Box object whose property settings will propagate to all title boxes on the chart image.
Public Property | Depth | Gets or sets depth of the chart when Use3D is true.
Public Property | DisableBrowserCache | Gets or sets a value indicating whether disable browser cache.
Public Property | DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.
Public Property | Dpi | Gets or sets the resolution, in dots per inch, of the chart Bitmap.
Public Property DrillDownChain

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.
Public Property | ExtraChartAreas | Gets a collection of additional ChartArea objects added to the chart.
Public Property | ExtraLegendBoxes | Gets a collection of additional LegendBox objects added to the chart.
Public Property | FileManager | Gets or sets the chart's instance of the FileManager which facilitates saving images.
Public Property | FileName | See Chart.FileManager.FileName.
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FunnelNozzlePercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel height that comprises the funnel's nozzle.
Public Property | FunnelNozzleWidthPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel width that comprises the funnel's nozzle.
Public Property | FunnelSpacingPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the funnel's spacing.
Public Property | GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's Element.Complete value is set.
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.
Public Property | HatchStylePaletteName | Gets or sets a predefined HatchStylePalette that defines element and series hatch style.
Public Property | Height | Overridden. Gets or sets the height of the chart image.
Public Property | Hotspot | Gets or sets the Hotspot property of the chart image.
Public Property | HotspotMinimumSize | Gets or sets a value that indicates the minimum size in pixels a hotspot must be in order for it to be generated.
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageFormat | Gets or sets an ImageFormat enumeration specifying the generated image's file type.
Public Property | ImageMapName | Returns a string for the image map name generated for the current chart image.
Public Property | ImageMapText | Returns a string for the image map generated for the current chart image.
Public Property | JS | Provides JavaScript chart functionality.
Public Property | LegacyMode | Gets or sets a value that indicates whether original chart defaults are used instead of new defaults introduced with version 10.
Public Property | LegendBox | Gets or sets a LegendBox object that represents the legend box.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | Mapping | This property is used only when using a map chart: (Chart.Type = ChartType.Map).
Public Property | Margin | Gets or sets a string which automatically sets multiple margins as a shortcut.
Public Property | MarginBottom | Gets or sets the bottom margin of the chart image.
Public Property | MarginLeft | Gets or sets the left margin of the chart image.
Public Property | MarginRight | Gets or sets the right margin of the chart image.
Public Property | MarginTop | Gets or sets the top margin of the chart image.
Public Property | MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.
Public Property | MaximumBubbleSizeValue | Gets or sets the maximum value the bubble size will be based on where a bubble size value of MaximumBubbleSizeValue equals a bubble of size MaximumBubbleSize.
Public Property | Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Navigator | Provides SliverLight functionality.
Public Property | NoDataLabel | Gets or sets a label shown on the chart when no data is available.
Public Property | ObjectChart | Gets or sets an object that will be drawn instead of the chart and will dynamically resize the chart image to fit the object's size. The supported objects are Label and Annotation.
Public Property | OrganizationalConnectorType | (JS Chart Only) Specifies the connector type (straight or right-angle) for organizatioal charts.
Public Property | OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Palette | Gets or sets an array of colors that define element and series colors.
Public Property | PaletteName | Gets or sets a predefined Palette that defines element and series colors.
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing.
Public Property | RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.
Public Property | ReloadPeriod | Gets or sets a System.TimeSpan object that determines how often the page containing this chart will automatically reload.
Public Property | Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property | SeriesCollection | Gets a SeriesCollection object which represents the data this chart will render.
Public Property | ShadingEffectMode | Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.
Public Property | ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title. The formatting of the shown dates can be controlled with Chart.DefaultCultureName.
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | Size | Sets a string that automatically sets the Height and Width of the chart image.
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmallChartMode | Gets or sets a value that indicates whether this chart uses the SmallChartMode.
Public Property | SmartForecast | Gets or sets a TimeIntervalAdvanced object that specifies a time span shown on the chart. The span shown is an interval which encompasses the time the chart is rendered. A trend line is also added for the entire span shown and uses values not shown in it's calculation to improve accuracy.
Public Property | SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.
Public Property | SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization.
Public Property | SpacingPercentage | Gets or sets the spacing percentage of pyramids, cones, and funnels with ChartType.Multiple .
Public Property | SpacingPercentageNested | Gets or sets a value that indicates the spacing percentage of nested pies.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SubValueDateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.
Public Property | TitleBox | Gets or sets a Box object that represents the title box.
Public Property | ToolTip | Overridden. Gets or sets the Tooltip of the entinre chart image.
Public Property | TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.
Public Property | Transpose | Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.
Public Property | Type | Gets or sets the ChartType of this Chart.
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | URL | Gets or sets the URL of the entinre chart image.
Public Property | URLTarget | Gets or sets the target of the URL link.
Public Property | Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D.
Public Property | UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.
Public Property UseSession

Gets or sets a value indicating whether the generated image is saved
temporarily in a session variable for subsequent streaming from a helper aspx page. This option may only be used when UseFile = false.

Public Property | View3D | Gets or sets the View3D class that contains properties to control the rendering of 3D surface charts.
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Overridden. Gets or sets the width of the chart image.
Public Property XAxis

Gets or Sets the main XAxis which all series inherit by default.

Public Property YAxis

Gets or Sets the main YAxis which all series inherit by default.

Public Property ZAxis

Gets or Sets the main ZAxis which all series inherit by default. The ZAxis is used with surface charts.

Public Property | Zoomer | Provides AJAX zooming and scrolling feature settings.
Top
See Also

Reference

Chart Class
dotnetCHARTING Namespace


Example

dotnetCHARTING Namespace > Chart Class : AlternateText Property
AlternateText Property
Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AlternateText As String
'Usage

Dim instance As Chart
Dim value As String

instance.AlternateText = value

value = instance.AlternateText
public string AlternateText {get; set;}
Example
  • C#
Chart.AlternateText = "The image can't be displayed.";
  • Visual Basic
Chart.AlternateText = "The image can't be displayed."
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Annotations Property
Annotations Property
A collection of Annotation objects drawn on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Annotations As AnnotationCollection
'Usage

Dim instance As Chart
Dim value As AnnotationCollection

value = instance.Annotations
public AnnotationCollection Annotations {get;}
Example
The following code snippet demonstrates how an annotation is added to the chart.
  • C#
Annotation a2 = new Annotation("Annotation text.");

//set the position
a2.Position = new Point(60,40);

// We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "https://www.dotnetcharting.com";

// Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = false;

// In order for the annotation not to draw the background, outline and so
// on... We'll use a shortcut to clear the colors.
a2.ClearColors();

// Add the annotation to a chart.
Chart.Annotations.Add(a2);
  • Visual Basic
Dim a2 As Annotation  = new Annotation("Annotation text.")

'set the position
a2.Position = new Point(60,40)

'We'll add a link so when this text is clicked it takes us to a web site.
a2.URL = "https://www.dotnetcharting.com"

' Make sure the annotation doesn't create a rectangle for the text and wrap it.
a2.DynamicSize = false

'In order for the annotation not to draw the background, outline and so
'on... We'll use a shortcut to clear the colors.
a2.ClearColors()

'Add the annotation to a chart.
Chart.Annotations.Add(a2)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

Box Tutorial


Example

dotnetCHARTING Namespace > Chart Class : AutoNameLabels Property
AutoNameLabels Property
Gets or sets a value which indicates whether elements and series are automatically named when no names are provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoNameLabels As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.AutoNameLabels = value

value = instance.AutoNameLabels
public bool AutoNameLabels {get; set;}
Example
  • C#
Chart.AutoNameLabels = true;
  • Visual Basic
Chart.AutoNameLabels = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : AxisCollection Property
AxisCollection Property
Contains a collection of calculated Axis objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AxisCollection As AxisCollection
'Usage

Dim instance As Chart
Dim value As AxisCollection

value = instance.AxisCollection
public AxisCollection AxisCollection {get;}
Remarks
Axes added to this collection must be calculated from axes on the chart, otherwise they are ignored.
Example
  • C#
//Using the built in axis calculation to convert units and add Fahrenheit temperature axis.
Axis F=Chart.YAxis.Calculate("Fahrenheit", Temperature.Celsius,Temperature.Fahrenheit);
F.Orientation = Orientation.Right;
Chart.AxisCollection.Add(F);

//For complete code see UnitConversion.aspx sample.
  • Visual Basic
'Using the built in axis calculation to convert units and add Fahrenheit temperature axis.
Dim F As Axis
F=Chart.YAxis.Calculate("Fahrenheit", Temperature.Celsius,Temperature.Fahrenheit)
F.Orientation = Orientation.Right
Chart.AxisCollection.Add(F)

'For complete code see UnitConversion.aspx sample.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

Multiple Axes
Calculated Axes


Example

dotnetCHARTING Namespace > Chart Class : Background Property
Background Property (Chart)
Gets or sets the Background of this chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As Chart
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Example
  • C#
Chart.Background = new Background(Color.Ivory);
  • Visual Basic
Chart.Background = new Background(Color.Ivory)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : Box Property
Box Property (Chart)

Gets or sets an Annotation object that is drawn as the background for this chart.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Box As Annotation
'Usage

Dim instance As Chart
Dim value As Annotation

instance.Box = value

value = instance.Box
public Annotation Box {get; set;}
Remarks
When using this annotation with a header label, it may be useful to make the chart top margin larger:

Chart.MarginTop = 20

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : BubbleCenterStack Property
BubbleCenterStack Property
Gets or sets a boolean value to control bubble center stack.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BubbleCenterStack As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.BubbleCenterStack = value

value = instance.BubbleCenterStack
public bool BubbleCenterStack {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : BubbleStackShadeAsOne Property
BubbleStackShadeAsOne Property
Gets or sets a boolean value to control bubble stack shade.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BubbleStackShadeAsOne As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.BubbleStackShadeAsOne = value

value = instance.BubbleStackShadeAsOne
public bool BubbleStackShadeAsOne {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : CacheDuration Property
CacheDuration Property
Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CacheDuration As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.CacheDuration = value

value = instance.CacheDuration
public int CacheDuration {get; set;}
Remarks
When set, a given chart image will be generated on the first hit and on all subsequent hits within the cache duration period the same image will be returned with no rendering work by the chart control.
Example
  • C#
//Used the already generated image for upto 45 minutes.
Chart.CacheDuration = 45;
  • Visual Basic
'Used the already generated image for upto 45 minutes.
Chart.CacheDuration = 45
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
CachePeriod Property
CachePeriod Property
CachePeriod Property
CachePeriod Property
CachePeriod Property
CachePeriod Property
CachePeriod Property

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : CalculateEmptyElement Property
CalculateEmptyElement Property
Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CalculateEmptyElement As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.CalculateEmptyElement = value

value = instance.CalculateEmptyElement
public bool CalculateEmptyElement {get; set;}
Remarks
If this property is set to false, in all calculations (average,min,median,mode etc.) only the applicable elements are counted. If set to true, such elements are given 0 values and included in the calculation. This case occurs when you have multiple series and are calculating derived series from them. Defaults to true.
Example
  • C#
Chart.CalculateEmptyElement = true;
  • Visual Basic
Chart.CalculateEmptyElement = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ChartArea Property
ChartArea Property (Chart)
Gets or sets the main ChartArea of the image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartArea As ChartArea
'Usage

Dim instance As Chart
Dim value As ChartArea

instance.ChartArea = value

value = instance.ChartArea
public ChartArea ChartArea {get; set;}
Example
  • C#
ChartArea chartAreaObj= new ChartArea();
 chartAreaObj.Background.Color = Color.LightBlue;
 chartAreaObj.Line.Color=Color.Yellow;
 chartAreaObj.InteriorLine.Color=Color.Blue;
 chartAreaObj.Label.Text="Customized chart area";
 Chart.ChartArea = chartAreaObj;
  • Visual Basic
Dim chartAreaObj As ChartArea = new ChartArea()
chartAreaObj.Background.Color = Color.LightBlue
chartAreaObj.Line.Color=Color.Yellow
chartAreaObj.InteriorLine.Color=Color.Blue
chartAreaObj.Label.Text="Customized chart area"
Chart.ChartArea = chartAreaObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

ChartAreas


dotnetCHARTING Namespace > Chart Class : ChartAreaLayout Property
ChartAreaLayout Property
Gets or sets chart area layout options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ChartAreaLayout As ChartAreaLayout
'Usage

Dim instance As Chart
Dim value As ChartAreaLayout

value = instance.ChartAreaLayout
public ChartAreaLayout ChartAreaLayout {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

Multiple Chart Areas


dotnetCHARTING Namespace > Chart Class : ChartAreaSpacing Property
ChartAreaSpacing Property
Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartAreaSpacing As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.ChartAreaSpacing = value

value = instance.ChartAreaSpacing
public int ChartAreaSpacing {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

Multiple Chart Areas


Example

dotnetCHARTING Namespace > Chart Class : CleanupMinimumAge Property
CleanupMinimumAge Property (Chart)
Gets or sets the minimum number of minutes images are stored in the TempDirectory before they are deleted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CleanupMinimumAge As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.CleanupMinimumAge = value

value = instance.CleanupMinimumAge
public int CleanupMinimumAge {get; set;}
Remarks
When .netCHARTING renders a chart a temporary file is created in the directory set by the TempDirectory property. The CleanupMinimumAge ensures that only files older than this age, in minutes, will be deleted.
Example
  • C#
//delete all temp files older than 10 minutes
Chart.CleanupMinimumAge = 10;
  • Visual Basic
'delete all temp files older than 10 minutes
Chart.CleanupMinimumAge = 10
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : CleanupPeriod Property
CleanupPeriod Property (Chart)
Gets or sets the number of minutes images are stored in the TempDirectory folder before they are deleted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CleanupPeriod As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.CleanupPeriod = value

value = instance.CleanupPeriod
public int CleanupPeriod {get; set;}
Remarks
When .netCHARTING renders a chart a temporary file is created in the directory set by the TempDirectory property. The CleanUpPeriod property determines how frequently (in minutes) this directory is cleaned by deleting old temporary files. The default is 15 minutes and the property can be set to 0 in order to disable the cleanup in which case temp files are not automatically deleted.

Any files that start with 'dnc-' will be deleted in the temp directory.
Example
  • C#
//delete old files every 30 minutes
Chart.CleanupPeriod = 30;
  • Visual Basic
'delete old files every 30 minutes
Chart.CleanupPeriod = 30
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : ClipGauges Property
ClipGauges Property
Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClipGauges As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.ClipGauges = value

value = instance.ClipGauges
public bool ClipGauges {get; set;}
Example
  • C#
Chart.ClipGauges = false;
  • Visual Basic
Chart.ClipGauges = false
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DatabaseCultureName Property
DatabaseCultureName Property (Chart)
Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DatabaseCultureName As String
'Usage

Dim instance As Chart
Dim value As String

instance.DatabaseCultureName = value

value = instance.DatabaseCultureName
public string DatabaseCultureName {get; set;}
Remarks
See the CultureInfo class for possible names of a culture.
Example
  • C#
Chart.DataBaseCultureName = "en-GB";
  • Visual Basic
Chart.DataBaseCultureName = "en-GB"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DataGrid Property
DataGrid Property (Chart)
Gets or sets the control object or ID of a datagrid control that will be populated with the charted data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGrid As Object
'Usage

Dim instance As Chart
Dim value As Object

instance.DataGrid = value

value = instance.DataGrid
public object DataGrid {get; set;}
Remarks
This property accepts a control ID for a datagrid. If set, the data represented in the chart is populated in the datagrid of the same name. You must also define a datagrid control with an appropriately named ID within the same script. This property is useful when displaying tabular chart data along with your charts.
Example
  • C#
Chart.DataGrid = myChartData;
  • Visual Basic
Chart.DataGrid = myChartData
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DataGridCustomAttributes Property
DataGridCustomAttributes Property (Chart)
Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property DataGridCustomAttributes As String
'Usage

Dim instance As Chart

instance.DataGridCustomAttributes = value
public string DataGridCustomAttributes {set;}
Remarks
For complete code see DataGridCustomAttributes.aspx or GridviewCustomAttributes.aspx sample
Example
  • C#
Chart.DataGridCustomAttributes = "Employee No=EmployeeID,Department=Department,Email=email,Phone=PhoneNumber";
  • Visual Basic
Chart.DataGridCustomAttributes = "Employee No=EmployeeID,Department=Department,Email=email,Phone=PhoneNumber"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DataGridFormatString Property
DataGridFormatString Property (Chart)
Gets or sets the format string which determines number formatting in the datagrid.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridFormatString As String
'Usage

Dim instance As Chart
Dim value As String

instance.DataGridFormatString = value

value = instance.DataGridFormatString
public string DataGridFormatString {get; set;}
Remarks
See 'Formatting Types' in your msdn documentation for a complete list of options.

Some shortcuts are also provided for specific settings including "C" for "currency" , "E" for "scientific" , "F" for "fixed" , "G" for "general" and "N,2" for normal and the number after the comma determines the number of decimal places.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DataGridSeriesHeader Property
DataGridSeriesHeader Property (Chart)
Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridSeriesHeader As String
'Usage

Dim instance As Chart
Dim value As String

instance.DataGridSeriesHeader = value

value = instance.DataGridSeriesHeader
public string DataGridSeriesHeader {get; set;}
Remarks
This property controls the header label used for the datagrid series name column. If set to "none" the series name column will be removed. If set to "%XAxisLabel", xAxis label set as the header label of the datagrid.
Example
  • C#
Chart.DataGridSeriesHeader = "Sales for 2003";
  • Visual Basic
Chart.DataGridSeriesHeader = "Sales for 2003"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DataGridTranspose Property
DataGridTranspose Property (Chart)
Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridTranspose As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.DataGridTranspose = value

value = instance.DataGridTranspose
public bool DataGridTranspose {get; set;}
Example
  • C#
Chart.DataGridTranspose = true;
  • Visual Basic
Chart.DataGridTranspose = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DateGrouping Property
DateGrouping Property (Chart)
Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGrouping As TimeInterval
'Usage

Dim instance As Chart
Dim value As TimeInterval

instance.DateGrouping = value

value = instance.DateGrouping
public TimeInterval DateGrouping {get; set;}
Remarks
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.
Example
  • C#
Chart.DateGrouping = TimeInterval.Days;
  • Visual Basic
Chart.DateGrouping = TimeInterval.Days
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property


Example

dotnetCHARTING Namespace > Chart Class : DateGroupingCalculation Property
DateGroupingCalculation Property (Chart)
Gets or sets an enum which determines how values are grouped to create a single element value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingCalculation As Calculation
'Usage

Dim instance As Chart
Dim value As Calculation

instance.DateGroupingCalculation = value

value = instance.DateGroupingCalculation
public Calculation DateGroupingCalculation {get; set;}
Remarks
When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.
Example
  • C#
Chart.DateGroupingCalculation = Calculation.Average;
  • Visual Basic
Chart.DateGroupingCalculation = Calculation.Average
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DateGroupingSort Property
DateGroupingSort Property (Chart)
Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingSort As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.DateGroupingSort = value

value = instance.DateGroupingSort
public bool DateGroupingSort {get; set;}
Remarks
When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.
Example
  • C#
Chart.DateGroupingSort = true;
  • Visual Basic
Chart.DateGroupingSort = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Debug Property
Debug Property
Gets or sets a value that indicates whether debug messages are displayed below the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Debug As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.Debug = value

value = instance.Debug
public bool Debug {get; set;}
Remarks
This property controls if error text is returned below the generated image if a problem occurs. This is typically used for debug purposes when initially developing charts. This is provided as a property so that your end users are not exposed to developer level errors. This property defaults to false
Example
  • C#
Chart.Debug = true;
  • Visual Basic
Chart.Debug = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultAxis Property
DefaultAxis Property
Gets or sets an Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultAxis As Axis
'Usage

Dim instance As Chart
Dim value As Axis

instance.DefaultAxis = value

value = instance.DefaultAxis
public Axis DefaultAxis {get; set;}
Example
  • C#
Axis AxisObj = new Axis();
 AxisObj.Line.Color = Color.Yellow;
 AxisObj.Line.Width = 3;
 Chart.DefaultAxis = AxisObj;
  • Visual Basic
Dim AxisObj As Axis  = new Axis()
AxisObj.Line.Color = Color.Yellow
AxisObj.Line.Width = 3
Chart.DefaultAxis = AxisObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DefaultBox Property
DefaultBox Property
Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultBox As Box
'Usage

Dim instance As Chart
Dim value As Box

value = instance.DefaultBox
public Box DefaultBox {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DefaultChartArea Property
DefaultChartArea Property
Gets a ChartArea object whose property settings will propagate to all other ChartArea objects on the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultChartArea As ChartArea
'Usage

Dim instance As Chart
Dim value As ChartArea

value = instance.DefaultChartArea
public ChartArea DefaultChartArea {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultCultureName Property
DefaultCultureName Property
Gets or sets the default culture name which determines number and date formatting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultCultureName As String
'Usage

Dim instance As Chart
Dim value As String

instance.DefaultCultureName = value

value = instance.DefaultCultureName
public string DefaultCultureName {get; set;}
Remarks
Equivalent to Chart.DefaultAxis.CultureName. See the System.Globalization.CultureInfo class for possible names of a culture.
Example
  • C#
Chart.DefaultCultureName = "en-GB";
  • Visual Basic
Chart.DefaultCultureName = "en-GB"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultElement Property
DefaultElement Property (Chart)
Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultElement As Element
'Usage

Dim instance As Chart
Dim value As Element

instance.DefaultElement = value

value = instance.DefaultElement
public Element DefaultElement {get; set;}
Example
  • C#
Chart.DefaultElement.SmartLabel.Text = "%Name";
  • Visual Basic
Chart.DefaultElement.SmartLabel.Text = "%Name"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultFormatString Property
DefaultFormatString Property
Gets or sets the default format string which determines number and date formatting.

See Chart.DefaultAxis.FormatString.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultFormatString As String
'Usage

Dim instance As Chart
Dim value As String

instance.DefaultFormatString = value

value = instance.DefaultFormatString
public string DefaultFormatString {get; set;}
Remarks
Equivalent to Chart.DefaultAxis.FormatString.

See 'Formatting Types' in your msdn documentation for a complete list of options.

Some shortcuts are also provided for specific settings including "C" or "currency" , "E" or "scientific" , "F" or "fixed" , "G" or "general" and "N,2" for normal and the number after the comma determines the number of decimal places.
Example
  • C#
Chart.DefaultFormatString = "n,2";
Chart.DefaultFormatString = "MM";
  • Visual Basic
Chart.DefaultFormatString = "n,2"
Chart.DefaultFormatString = "MM"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DefaultLegendBox Property
DefaultLegendBox Property
Gets a LegendBox object whose property settings will propagate to all other LegendBox objects on the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultLegendBox As LegendBox
'Usage

Dim instance As Chart
Dim value As LegendBox

value = instance.DefaultLegendBox
public LegendBox DefaultLegendBox {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultSeries Property
DefaultSeries Property (Chart)
Gets or sets a Series object whose properties will trickle to all other series on the chart unless otherwise specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultSeries As Series
'Usage

Dim instance As Chart
Dim value As Series

instance.DefaultSeries = value

value = instance.DefaultSeries
public Series DefaultSeries {get; set;}
Example
  • C#
Chart.DefaultSeries.Type = SeriesType.AreaLine;
  • Visual Basic
Chart.DefaultSeries.Type = SeriesType.AreaLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DefaultShadow Property
DefaultShadow Property
Gets or sets a shadow object whose properties will trickle to all other objects with shadows.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultShadow As Shadow
'Usage

Dim instance As Chart
Dim value As Shadow

instance.DefaultShadow = value

value = instance.DefaultShadow
public Shadow DefaultShadow {get; set;}
Example
  • C#
Shadow shadowObj = new Shadow();
shadowObj.Color = Color.Blue;
shadowObj.Depth = 5;
shadowObj.Soft =true;
Chart.DefaultShadow = shadowObj;
  • Visual Basic
Dim shadowObj As Shadow  = new Shadow()
shadowObj.Color = Color.Blue
shadowObj.Depth = 5
shadowObj.Soft =true
Chart.DefaultShadow = shadowObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DefaultTitleBox Property
DefaultTitleBox Property
Gets a Box object whose property settings will propagate to all title boxes on the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultTitleBox As Box
'Usage

Dim instance As Chart
Dim value As Box

value = instance.DefaultTitleBox
public Box DefaultTitleBox {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Depth Property
Depth Property (Chart)
Gets or sets depth of the chart when Use3D is true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Depth As Unit
'Usage

Dim instance As Chart
Dim value As Unit

instance.Depth = value

value = instance.Depth
public Unit Depth {get; set;}
Example
  • C#
Chart.Depth = 12;
  • Visual Basic
Chart.Depth = Unit.Parse(12)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DisableBrowserCache Property
DisableBrowserCache Property
Gets or sets a value indicating whether disable browser cache.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DisableBrowserCache As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.DisableBrowserCache = value

value = instance.DisableBrowserCache
public bool DisableBrowserCache {get; set;}
Example
  • C#
Chart.DisableBrowserCache = true;
  • Visual Basic
Chart.DisableBrowserCache = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : DonutHoleSize Property
DonutHoleSize Property
Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DonutHoleSize As Double
'Usage

Dim instance As Chart
Dim value As Double

instance.DonutHoleSize = value

value = instance.DonutHoleSize
public double DonutHoleSize {get; set;}
Example
  • C#
Chart.DonutHoleSize = 60;
  • Visual Basic
Chart.DonutHoleSize = 60
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Dpi Property
Dpi Property
Gets or sets the resolution, in dots per inch, of the chart Bitmap.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Dpi As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.Dpi = value

value = instance.Dpi
public int Dpi {get; set;}
Example
  • C#
Chart.Dpi = 300;
  • Visual Basic
Chart.Dpi = 300
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : DrillDownChain Property
DrillDownChain Property

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrillDownChain As String
'Usage

Dim instance As Chart
Dim value As String

instance.DrillDownChain = value

value = instance.DrillDownChain
public string DrillDownChain {get; set;}
Remarks
When using automated drill down with DateGrouping, this property controls the drill down chain, or hierarchy, that is followed. In addition you can override names to be displayed for the different drill down levels.
Example

This samples demonstrate drill down with dategrouping.

For complete drill down samples see Features/Drilldown samples.

  • C#
Chart.DrillDownChain = "Year,Month,Day";
Chart.DrillDownChain = "Year=Current Year,Month=My Month,Day=One day";
  • Visual Basic
Chart.DrillDownChain = "Year,Month,Day"
Chart.DrillDownChain = "Year=Current Year,Month=My Month,Day=One day"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : DrillDownIntoSeries Property
DrillDownIntoSeries Property (Chart)
When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrillDownIntoSeries As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.DrillDownIntoSeries = value

value = instance.DrillDownIntoSeries
public bool DrillDownIntoSeries {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : EmptyElementText Property
EmptyElementText Property
Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EmptyElementText As String
'Usage

Dim instance As Chart
Dim value As String

instance.EmptyElementText = value

value = instance.EmptyElementText
public string EmptyElementText {get; set;}
Example
  • C#
Chart.EmptyElementText = "N/A";
  • Visual Basic
Chart.EmptyElementText = "N/A"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ExplodedSliceAmount Property
ExplodedSliceAmount Property
Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExplodedSliceAmount As Double
'Usage

Dim instance As Chart
Dim value As Double

instance.ExplodedSliceAmount = value

value = instance.ExplodedSliceAmount
public double ExplodedSliceAmount {get; set;}
Example
  • C#
Chart.ExplodedSliceAmount = 30;
  • Visual Basic
Chart.ExplodedSliceAmount = 30
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
ExplodeSlice


dotnetCHARTING Namespace > Chart Class : ExtraChartAreas Property
ExtraChartAreas Property
Gets a collection of additional ChartArea objects added to the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExtraChartAreas As ChartAreaCollection
'Usage

Dim instance As Chart
Dim value As ChartAreaCollection

value = instance.ExtraChartAreas
public ChartAreaCollection ExtraChartAreas {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : ExtraLegendBoxes Property
ExtraLegendBoxes Property
Gets a collection of additional LegendBox objects added to the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExtraLegendBoxes As LegendBoxCollection
'Usage

Dim instance As Chart
Dim value As LegendBoxCollection

value = instance.ExtraLegendBoxes
public LegendBoxCollection ExtraLegendBoxes {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : FileManager Property
FileManager Property
Gets or sets the chart's instance of the FileManager which facilitates saving images.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileManager As FileManager
'Usage

Dim instance As Chart
Dim value As FileManager

instance.FileManager = value

value = instance.FileManager
public FileManager FileManager {get; set;}
Example
  • C#
//Get the bitmap and add a line to the image
Bitmap bmp = Chart.GetChartBitmap();
Graphics g = Graphics.FromImage(bmp);
g.DrawLine(Pens.Red,36,150,480,150);
g.DrawString("This is my line",new Font("Arial",12,FontStyle.Bold),new SolidBrush(Color.Black),new Point(40,150));
g.Dispose();

//Save the image and set the image path to ImageUrl.
string ImagePath = Chart.FileManager.SaveImage(bmp);
Image1.ImageUrl = ImagePath;
  • Visual Basic
'Get the bitmap and add a line to the image
Dim bmp As Bitmap = Chart.GetChartBitmap()
Dim g As Graphics = Graphics.FromImage(bmp)
g.DrawLine(Pens.Red, 36, 150, 480, 150)
g.DrawString("This is my line", new Font("Arial", 12, FontStyle.Bold), new SolidBrush(Color.Black), new PointF(40F, 150F))
g.Dispose()

'Save the image and set the image path to ImageUrl.
Dim ImagePath As String = Chart.FileManager.SaveImage(bmp)
Image1.ImageUrl = ImagePath
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : FileName Property
FileName Property (Chart)
See Chart.FileManager.FileName.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileName As String
'Usage

Dim instance As Chart
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
Example
  • C#
Chart.FileName = "sales1";

//With default image format, the generated file will be "sales1.png"
  • Visual Basic
Chart.FileName = "sales1"

'With default image format, the generated file will be "sales1.png"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : FileQuality Property
FileQuality Property (Chart)
Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileQuality As Long
'Usage

Dim instance As Chart
Dim value As Long

instance.FileQuality = value

value = instance.FileQuality
public long FileQuality {get; set;}
Example
  • C#
Chart.FileQuality = 95;
  • Visual Basic
Chart.FileQuality = 95
Example
Bevel
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


dotnetCHARTING Namespace > Chart Class : FunnelNozzlePercentage Property
FunnelNozzlePercentage Property
Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel height that comprises the funnel's nozzle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FunnelNozzlePercentage As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.FunnelNozzlePercentage = value

value = instance.FunnelNozzlePercentage
public int FunnelNozzlePercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : FunnelNozzleWidthPercentage Property
FunnelNozzleWidthPercentage Property
Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel width that comprises the funnel's nozzle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FunnelNozzleWidthPercentage As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.FunnelNozzleWidthPercentage = value

value = instance.FunnelNozzleWidthPercentage
public int FunnelNozzleWidthPercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : FunnelSpacingPercentage Property
FunnelSpacingPercentage Property
Gets or sets a numeric value between 0 and 100 that indicates the percentage of the funnel's spacing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FunnelSpacingPercentage As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.FunnelSpacingPercentage = value

value = instance.FunnelSpacingPercentage
public int FunnelSpacingPercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : GanttCompleteHatchStyle Property
GanttCompleteHatchStyle Property
Gets or sets the hatch style drawn on columns and cylinders when an element's Element.Complete value is set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GanttCompleteHatchStyle As HatchStyle
'Usage

Dim instance As Chart
Dim value As HatchStyle

instance.GanttCompleteHatchStyle = value

value = instance.GanttCompleteHatchStyle
public HatchStyle GanttCompleteHatchStyle {get; set;}
Remarks
Typically used with Gantt charts to indicate what percentage of a task has been completed.
Example
  • C#
//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Chart.GanttCompleteHatchStyle = HatchStyle.DiagonalCross;
  • Visual Basic
'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Chart.GanttCompleteHatchStyle = HatchStyle.DiagonalCross
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : HatchStylePalette Property
HatchStylePalette Property (Chart)
Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStylePalette As HatchStyle()
'Usage

Dim instance As Chart
Dim value() As HatchStyle

instance.HatchStylePalette = value

value = instance.HatchStylePalette
public HatchStyle[] HatchStylePalette {get; set;}
Remarks
For a complete list of hatch styles see HatchStyle enumeration.
Example
  • C#
Chart.HatchStylePalette = new HatchStylePalette [] {HatchStyle.Cross,HatchStyle.Divot,HatchStyle.Horizontal};
  • Visual Basic
Chart.HatchStylePalette = New HatchStylePalette [] {HatchStyle.Cross,HatchStyle.Divot,HatchStyle.Horizontal}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : HatchStylePaletteName Property
HatchStylePaletteName Property (Chart)
Gets or sets a predefined HatchStylePalette that defines element and series hatch style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStylePaletteName As HatchStylePalette
'Usage

Dim instance As Chart
Dim value As HatchStylePalette

instance.HatchStylePaletteName = value

value = instance.HatchStylePaletteName
public HatchStylePalette HatchStylePaletteName {get; set;}
Example
  • C#
Chart.PaletteName = dotnetCHARTING.HatchStylePalette.One;
  • Visual Basic
Chart.PaletteName = dotnetCHARTING.HatchStylePalette.One
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Height Property
Height Property (Chart)
Gets or sets the height of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Height As Unit
'Usage

Dim instance As Chart
Dim value As Unit

instance.Height = value

value = instance.Height
public override Unit Height {get; set;}
Example
  • C#
Chart.Height = 350;
  • Visual Basic
Chart.Height = Unit.Parse(350)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Base Implementation in Height


dotnetCHARTING Namespace > Chart Class : Hotspot Property
Hotspot Property (Chart)
Gets or sets the Hotspot property of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As Chart
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : HotspotMinimumSize Property
HotspotMinimumSize Property
Gets or sets a value that indicates the minimum size in pixels a hotspot must be in order for it to be generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HotspotMinimumSize As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.HotspotMinimumSize = value

value = instance.HotspotMinimumSize
public int HotspotMinimumSize {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ImageFormat Property
ImageFormat Property (Chart)
Gets or sets an ImageFormat enumeration specifying the generated image's file type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageFormat As ImageFormat
'Usage

Dim instance As Chart
Dim value As ImageFormat

instance.ImageFormat = value

value = instance.ImageFormat
public ImageFormat ImageFormat {get; set;}
Example
  • C#
Chart.ImageFormat = ImageFormat.Jpg;
  • Visual Basic
Chart.ImageFormat = ImageFormat.Jpg
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ImageMapName Property
ImageMapName Property
Returns a string for the image map name generated for the current chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ImageMapName As String
'Usage

Dim instance As Chart
Dim value As String

value = instance.ImageMapName
public string ImageMapName {get;}
Example
  • C#
ImageMapLabel.Text = Chart.ImageMapName; //read only
  • Visual Basic
ImageMapLabel.Text = Chart.ImageMapName //read only
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ImageMapText Property
ImageMapText Property
Returns a string for the image map generated for the current chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ImageMapText As String
'Usage

Dim instance As Chart
Dim value As String

value = instance.ImageMapText
public string ImageMapText {get;}
Example
  • C#
ImageMapLabel.Text = Chart.ImageMapText //read only
  • Visual Basic
ImageMapLabel.Text = Chart.ImageMapText //read only
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : JS Property
JS Property
Provides JavaScript chart functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JS As JsOptions
'Usage

Dim instance As Chart
Dim value As JsOptions

instance.JS = value

value = instance.JS
public JsOptions JS {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : LegacyMode Property
LegacyMode Property
Gets or sets a value that indicates whether original chart defaults are used instead of new defaults introduced with version 10.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegacyMode As Nullable(Of Boolean)
'Usage

Dim instance As Chart
Dim value As Nullable(Of Boolean)

instance.LegacyMode = value

value = instance.LegacyMode
public Nullable<bool> LegacyMode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : LegendBox Property
LegendBox Property (Chart)
Gets or sets a LegendBox object that represents the legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendBox As LegendBox
'Usage

Dim instance As Chart
Dim value As LegendBox

instance.LegendBox = value

value = instance.LegendBox
public LegendBox LegendBox {get; set;}
Remarks
Notes

- To hide the legend box use Chart.LegendBox.Position = LegendBoxPosition.None.

- When Chart.TitleBox.Position = TitleBoxPosition.FullWithLegend is set the legend box will disappear.
Example
  • C#
Chart.LegendBox.Background = new Background(System.Drawing.Color.SkyBlue);
Chart.LegendBox.CornerBottomLeft = BoxCorner.Square;
Chart.LegendBox.CornerBottomRight = BoxCorner.Square;
Chart.LegendBox.CornerTopLeft = BoxCorner.Square;
Chart.LegendBox.CornerTopRight = BoxCorner.Cut;
Chart.LegendBox.IconPath="icon.gif";
Chart.LegendBox.Label =  new dotnetCHARTING.Label("",new Font("Arial",10),Color.DarkSlateBlue);
Chart.LegendBox.Line = new Line(Color.Blue);
Chart.LegendBox.Position = LegendBoxPosition.Top;

//For complete code, see LegendBox.aspx sample
  • Visual Basic
Chart.LegendBox.Background = new Background(System.Drawing.Color.SkyBlue)
Chart.LegendBox.CornerBottomLeft = BoxCorner.Square
Chart.LegendBox.CornerBottomRight = BoxCorner.Square
Chart.LegendBox.CornerTopLeft = BoxCorner.Square
Chart.LegendBox.CornerTopRight = BoxCorner.Cut
Chart.LegendBox.IconPath="icon.gif"
Chart.LegendBox.Label =  new dotnetCHARTING.Label("",new Font("Arial",10),Color.DarkSlateBlue)
Chart.LegendBox.Line = new Line(Color.Blue)
Chart.LegendBox.Position = LegendBoxPosition.Top

'For complete code, see LegendBox.aspx sample
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : LimitPrimarySeries Property
LimitPrimarySeries Property (Chart)
In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LimitPrimarySeries As String
'Usage

Dim instance As Chart
Dim value As String

instance.LimitPrimarySeries = value

value = instance.LimitPrimarySeries
public string LimitPrimarySeries {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : Mapping Property
Mapping Property (Chart)
This property is used only when using a map chart: (Chart.Type = ChartType.Map).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mapping As Mapping
'Usage

Dim instance As Chart
Dim value As Mapping

instance.Mapping = value

value = instance.Mapping
public Mapping Mapping {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Margin Property
Margin Property
Gets or sets a string which automatically sets multiple margins as a shortcut.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property Margin As String
'Usage

Dim instance As Chart

instance.Margin = value
public string Margin {set;}
Remarks
Controls the margins or amount of space in pixels that will be left around the charting elements including the Legend and title box. This property can be used in conjunction with the Chart.Background property to easily implement attractive custom borders or just pad the chart as you please. The property accepts margins "Left, Top, Right, Bottom" in pixels. Negative values are allowed.
Example
  • C#
Chart.Margin = "10"; //set all 4 Margins to 10
Chart.Margin = "10,20"; // set MarginLeft and MarginRight to 10 and MarginTop and Bottom to 20
Chart.Margin = "5,10,15"; // set MarginLeft to 5, MarginTop to 10 and MarginRight to 15
Chart.Margin = "5,10,15,20"; // set MarginLeft to 5, MarginTop to 10, MarginRight to 15 and MarginBottom to 20
  • Visual Basic
Chart.Margin = "10"    'set all 4 Margins to 10
Chart.Margin = "10,20"    'set MarginLeft and MarginRight to 10 and MarginTop and Bottom to 20
Chart.Margin = "5,10,15"    'set MarginLeft to 5, MarginTop to 10 and MarginRight to 15
Chart.Margin = "5,10,15,20"    'set MarginLeft to 5, MarginTop to 10, MarginRight to 15 and MarginBottom to 20
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MarginBottom Property
MarginBottom Property
Gets or sets the bottom margin of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginBottom As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.MarginBottom = value

value = instance.MarginBottom
public int MarginBottom {get; set;}
Remarks
Negative values are allowed.
Example
  • C#
Chart.MarginBottom = 20;
  • Visual Basic
Chart.MarginBottom = 20
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MarginLeft Property
MarginLeft Property
Gets or sets the left margin of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginLeft As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.MarginLeft = value

value = instance.MarginLeft
public int MarginLeft {get; set;}
Remarks
Negative values are allowed.
Example
  • C#
Chart.MarginLeft = 20;
  • Visual Basic
Chart.MarginLeft = 20
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MarginRight Property
MarginRight Property
Gets or sets the right margin of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginRight As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.MarginRight = value

value = instance.MarginRight
public int MarginRight {get; set;}
Remarks
Negative values are allowed.
Example
  • C#
Chart.MarginRight = 20;
  • Visual Basic
Chart.MarginRight = 20
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MarginTop Property
MarginTop Property
Gets or sets the top margin of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MarginTop As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.MarginTop = value

value = instance.MarginTop
public int MarginTop {get; set;}
Remarks
Negative values are allowed.
Example
  • C#
Chart.MarginTop = 20;
  • Visual Basic
Chart.MarginTop = 20
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MaximumBubbleSize Property
MaximumBubbleSize Property
Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumBubbleSize As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.MaximumBubbleSize = value

value = instance.MaximumBubbleSize
public int MaximumBubbleSize {get; set;}
Remarks
When not set, the maximum size is determined dynamically.
Example
  • C#
Chart.MaximumBubbleSize = 120;
  • Visual Basic
Chart.MaximumBubbleSize = 120
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : MaximumBubbleSizeValue Property
MaximumBubbleSizeValue Property
Gets or sets the maximum value the bubble size will be based on where a bubble size value of MaximumBubbleSizeValue equals a bubble of size MaximumBubbleSize.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaximumBubbleSizeValue As Single
'Usage

Dim instance As Chart
Dim value As Single

instance.MaximumBubbleSizeValue = value

value = instance.MaximumBubbleSizeValue
public float MaximumBubbleSizeValue {get; set;}
Example
  • C#
Chart.MaximumBubbleSizeValue = 120;
  • Visual Basic
Chart.MaximumBubbleSizeValue = 120
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : Mentor Property
Mentor Property
Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mentor As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.Mentor = value

value = instance.Mentor
public bool Mentor {get; set;}
Remarks
The mentor also requires that Chart.Debug is set to true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : Navigator Property
Navigator Property
Provides SliverLight functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Navigator As NavigatorOptions
'Usage

Dim instance As Chart
Dim value As NavigatorOptions

instance.Navigator = value

value = instance.Navigator
public NavigatorOptions Navigator {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : NoDataLabel Property
NoDataLabel Property
Gets or sets a label shown on the chart when no data is available.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NoDataLabel As Label
'Usage

Dim instance As Chart
Dim value As Label

instance.NoDataLabel = value

value = instance.NoDataLabel
public Label NoDataLabel {get; set;}
Example
  • C#
Chart.NoDataLabel.Text = "No Data Text";
Chart.NoDataLabel.Color = Color.Red;
  • Visual Basic
Chart.NoDataLabel.Text = "No Data Text"
Chart.NoDataLabel.Color = Color.Red
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : ObjectChart Property
ObjectChart Property
Gets or sets an object that will be drawn instead of the chart and will dynamically resize the chart image to fit the object's size. The supported objects are Label and Annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ObjectChart As Object
'Usage

Dim instance As Chart
Dim value As Object

instance.ObjectChart = value

value = instance.ObjectChart
public object ObjectChart {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : OrganizationalConnectorType Property
OrganizationalConnectorType Property
(JS Chart Only) Specifies the connector type (straight or right-angle) for organizatioal charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OrganizationalConnectorType As OrganizationalConnectorType
'Usage

Dim instance As Chart
Dim value As OrganizationalConnectorType

instance.OrganizationalConnectorType = value

value = instance.OrganizationalConnectorType
public OrganizationalConnectorType OrganizationalConnectorType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : OverlapFooter Property
OverlapFooter Property
Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OverlapFooter As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.OverlapFooter = value

value = instance.OverlapFooter
public bool OverlapFooter {get; set;}
Remarks
If set to false, the rendered chart will exactly match that of a production licensed chart (which does not have the footer or branding in the top right). If set to true, the chart will be resized slightly so that the footer does not overlap the chart. In all cases the final rendered image will be exactly what you set for Chart.Size or Chart.Height and Chart.Width.
Example
  • C#
Chart.OverlapFooter = true;
  • Visual Basic
Chart.OverlapFooter = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Palette Property
Palette Property (Chart)
Gets or sets an array of colors that define element and series colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Palette As Color()
'Usage

Dim instance As Chart
Dim value() As Color

instance.Palette = value

value = instance.Palette
public Color[] Palette {get; set;}
Example
  • C#
Color[] MyColorObjectArray = new Color[3]{Color.Red,Color.Blue,Color.Yellow};
Chart.Palette = MyColorObjectArray;
  • Visual Basic
Dim MyColorObjectArray() As Color  = {Color.Red,Color.Blue,Color.Yellow}
Chart.Palette = MyColorObjectArray
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : PaletteName Property
PaletteName Property (Chart)
Gets or sets a predefined Palette that defines element and series colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaletteName As Palette
'Usage

Dim instance As Chart
Dim value As Palette

instance.PaletteName = value

value = instance.PaletteName
public Palette PaletteName {get; set;}
Example
  • C#
Chart.PaletteName = dotnetCHARTING.Palette.Spring;
  • Visual Basic
Chart.PaletteName = dotnetCHARTING.Palette.Spring
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : PieLabelMode Property
PieLabelMode Property (Chart)
See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PieLabelMode As PieLabelMode
'Usage

Dim instance As Chart
Dim value As PieLabelMode

instance.PieLabelMode = value

value = instance.PieLabelMode
public PieLabelMode PieLabelMode {get; set;}
Example
  • C#
//Dispalys label inside the pie slice.
Chart.PieLabelMode = PieLabelMode.Inside;
  • Visual Basic
'Dispalys label inside the pie slice.
Chart.PieLabelMode = PieLabelMode.Inside
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : PopulateDateGroupingSubValues Property
PopulateDateGroupingSubValues Property (Chart)
When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PopulateDateGroupingSubValues As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.PopulateDateGroupingSubValues = value

value = instance.PopulateDateGroupingSubValues
public bool PopulateDateGroupingSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : PrinterOptimizedText Property
PrinterOptimizedText Property
Gets or sets a value that indicates whether text rendered on the chart optimized for printing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrinterOptimizedText As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.PrinterOptimizedText = value

value = instance.PrinterOptimizedText
public bool PrinterOptimizedText {get; set;}
Example
  • C#
Chart.PrinterOptimizedText = true;
  • Visual Basic
Chart.PrinterOptimizedText = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : RadarLabelMode Property
RadarLabelMode Property (Chart)
See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RadarLabelMode As RadarLabelMode
'Usage

Dim instance As Chart
Dim value As RadarLabelMode

instance.RadarLabelMode = value

value = instance.RadarLabelMode
public RadarLabelMode RadarLabelMode {get; set;}
Example
  • C#
Chart.RadarLabelMode = RadarLabelMode.Outside;
  • Visual Basic
Chart.RadarLabelMode = RadarLabelMode.Outside
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ReloadPeriod Property
ReloadPeriod Property (Chart)
Gets or sets a System.TimeSpan object that determines how often the page containing this chart will automatically reload.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReloadPeriod As TimeSpan
'Usage

Dim instance As Chart
Dim value As TimeSpan

instance.ReloadPeriod = value

value = instance.ReloadPeriod
public TimeSpan ReloadPeriod {get; set;}
Example
  • C#
//Reload the page each one minute
Chart.ReloadPeriod = new TimeSpan(0,1,0)
  • Visual Basic
'Reload the page each one minute
Chart.ReloadPeriod = new TimeSpan(0,1,0)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : Series Property
Series Property (Chart)
Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Series As Series
'Usage

Dim instance As Chart
Dim value As Series

instance.Series = value

value = instance.Series
public Series Series {get; set;}
Example
  • C#
//Adding series programatically
Chart.Series.Name="Vancouver";
Chart.Series.Type = SeriesType.Cylinder;
Chart.Series.Element  = new Element("Mon",2);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Tue",4);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Wed",5);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Thr",6);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Fri",5);
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();
  • Visual Basic
'Adding series programatically
Chart.Series.Name="Vancouver"
Chart.Series.Type = SeriesType.Cylinder
Chart.Series.Element  = new Element("Mon",2)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Tue",4)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Wed",5)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Thr",6)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Fri",5)
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : SeriesCollection Property
SeriesCollection Property (Chart)
Gets a SeriesCollection object which represents the data this chart will render.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SeriesCollection As SeriesCollection
'Usage

Dim instance As Chart
Dim value As SeriesCollection

value = instance.SeriesCollection
public SeriesCollection SeriesCollection {get;}
Example
  • C#
//Adding series programatically
Series sr =new Series();
sr.Name ="Vancouver";
sr.Type = SeriesType.Cylinder;
Element el= new Element("E 1",2);
sr.Elements.Add(el);
Chart.SeriesCollection.Add(sr);
  • Visual Basic
'Adding series programatically
Dim sr As Series =new Series()
sr.Name ="Vancouver"
sr.Type = SeriesType.Cylinder
Dim el As Element  = new Element("E 1",2)
sr.Elements.Add(el)
Chart.SeriesCollection.Add(sr)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ShadingEffectMode Property
ShadingEffectMode Property (Chart)
Gets or sets a ShadingEffectMode enumeration indicating how elements on the chart are shaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShadingEffectMode As ShadingEffectMode
'Usage

Dim instance As Chart
Dim value As ShadingEffectMode

instance.ShadingEffectMode = value

value = instance.ShadingEffectMode
public ShadingEffectMode ShadingEffectMode {get; set;}
Remarks
2D Columns, and Bubbles can use mode One, Two, and Three. 3D Columns, 2D Pies, and 2D Donuts can only use mode 'One'.
Example
  • C#
Chart.ShadingEffectMode = ShadingEffectMode.One;
  • Visual Basic
Chart.ShadingEffectMode = ShadingEffectMode.One
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ShowDateInTitle Property
ShowDateInTitle Property
Gets or sets a value which indicates whether specified dates are shown in the title. The formatting of the shown dates can be controlled with Chart.DefaultCultureName.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowDateInTitle As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.ShowDateInTitle = value

value = instance.ShowDateInTitle
public bool ShowDateInTitle {get; set;}
Remarks
Applicable when Chart.DefaultSeries.Start/EndDate or Chart.Series.Start/EndDate areset.
Example
  • C#
Chart.ShowDateInTitle = true;
  • Visual Basic
Chart.ShowDateInTitle = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Size Property
Size Property (Chart)
Sets a string that automatically sets the Height and Width of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property Size As String
'Usage

Dim instance As Chart

instance.Size = value
public string Size {set;}

Property Value

This property accepts a string formatted as "WidthXHeight".
Example
  • C#
Chart.Size = "640X480";
  • Visual Basic
Chart.Size = "640X480"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SmallChartMode Property
SmallChartMode Property
Gets or sets a value that indicates whether this chart uses the SmallChartMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmallChartMode As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.SmallChartMode = value

value = instance.SmallChartMode
public bool SmallChartMode {get; set;}
Remarks
This mode is designed for miniature charts and automatically gets rid of legendboxes, titles, axes, and margins.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SmartForecast Property
SmartForecast Property
Gets or sets a TimeIntervalAdvanced object that specifies a time span shown on the chart. The span shown is an interval which encompasses the time the chart is rendered. A trend line is also added for the entire span shown and uses values not shown in it's calculation to improve accuracy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartForecast As TimeIntervalAdvanced
'Usage

Dim instance As Chart
Dim value As TimeIntervalAdvanced

instance.SmartForecast = value

value = instance.SmartForecast
public TimeIntervalAdvanced SmartForecast {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SmartPalette Property
SmartPalette Property (Chart)
Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartPalette As SmartPalette
'Usage

Dim instance As Chart
Dim value As SmartPalette

instance.SmartPalette = value

value = instance.SmartPalette
public SmartPalette SmartPalette {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SmartPaletteAutoSync Property
SmartPaletteAutoSync Property
Gets or sets a boolean which controls smart palette synchronization.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartPaletteAutoSync As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.SmartPaletteAutoSync = value

value = instance.SmartPaletteAutoSync
public bool SmartPaletteAutoSync {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SpacingPercentage Property
SpacingPercentage Property (Chart)
Gets or sets the spacing percentage of pyramids, cones, and funnels with ChartType.Multiple .
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SpacingPercentage As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.SpacingPercentage = value

value = instance.SpacingPercentage
public int SpacingPercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : SpacingPercentageNested Property
SpacingPercentageNested Property
Gets or sets a value that indicates the spacing percentage of nested pies.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SpacingPercentageNested As Integer
'Usage

Dim instance As Chart
Dim value As Integer

instance.SpacingPercentageNested = value

value = instance.SpacingPercentageNested
public int SpacingPercentageNested {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : StartDateOfYear Property
StartDateOfYear Property (Chart)
Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDateOfYear As Date
'Usage

Dim instance As Chart
Dim value As Date

instance.StartDateOfYear = value

value = instance.StartDateOfYear
public DateTime StartDateOfYear {get; set;}
Remarks
This property determine the start month of the year. The default is January.
Example
This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.
  • C#
de.StartDateOfYear = new DateTime(2004,3,1);
  • Visual Basic
de.StartDateOfYear = New DateTime(2004, 3, 1)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
DateGrouping Property


Example

dotnetCHARTING Namespace > Chart Class : StartDayOfWeek Property
StartDayOfWeek Property (Chart)
Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDayOfWeek As DayOfWeek
'Usage

Dim instance As Chart
Dim value As DayOfWeek

instance.StartDayOfWeek = value

value = instance.StartDayOfWeek
public DayOfWeek StartDayOfWeek {get; set;}
Example
  • C#
Chart.DateGrouping = TimeInterval.Weeks;
Chart.StartDayOfWeek = DayOfWeek.Monday;

//For complete code, see StartDayOfWeek.aspx sample.
  • Visual Basic
Chart.DateGrouping = TimeInterval.Weeks
Chart.StartDayOfWeek = DayOfWeek.Monday

'For complete code, see StartDayOfWeek.aspx sample.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : SubValueDateGrouping Property
SubValueDateGrouping Property (Chart)
Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SubValueDateGrouping As TimeInterval
'Usage

Dim instance As Chart
Dim value As TimeInterval

instance.SubValueDateGrouping = value

value = instance.SubValueDateGrouping
public TimeInterval SubValueDateGrouping {get; set;}
Remarks
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.
Example
  • C#
Chart.SubValueDateGrouping = TimeInterval.Days;
  • Visual Basic
Chart.SubValueDateGrouping = TimeInterval.Days
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
SubValueDateGrouping Property
DateGrouping Property


Example

dotnetCHARTING Namespace > Chart Class : TempDirectory Property
TempDirectory Property (Chart)
Gets or sets the directory where images generated by the control are temporarily stored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TempDirectory As String
'Usage

Dim instance As Chart
Dim value As String

instance.TempDirectory = value

value = instance.TempDirectory
public string TempDirectory {get; set;}
Remarks
This property takes either an absolute path 'c:/inetpub/wwwroot/app/tmp', a relative path ('tmp', '../tmp',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/tmp).
Example
This examples demonstrate different ways of accessing the same folder: 'c:/inetpub/wwwroot/app/tmp' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.TempDirectory = "c://inetpub/wwwroot/app/tmp";
Chart.TempDirectory = "/app/tmp";
Chart.TempDirectory = "tmp";
  • Visual Basic
Chart.TempDirectory = "c://inetpub/wwwroot/app/tmp"
Chart.TempDirectory = "/app/tmp"
Chart.TempDirectory = "tmp"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Title Property
Title Property (Chart)
Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As String
'Usage

Dim instance As Chart
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
Example
  • C#
Chart.Title = "Chart of Sales for 2003";
  • Visual Basic
Chart.Title = "Chart of Sales for 2003"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : TitleBox Property
TitleBox Property (Chart)
Gets or sets a Box object that represents the title box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TitleBox As Box
'Usage

Dim instance As Chart
Dim value As Box

instance.TitleBox = value

value = instance.TitleBox
public Box TitleBox {get; set;}
Remarks
Notes

- To hide the title box use Chart.TitleBox.Position = TitleBoxPosition.None.

- Setting Chart.TitleBox.Icon = "...IconPath..." draws the image inside the title box.
- When no title, or icon is provided and TitleBoxPosition.FullWithLegend is not set, the title box is automatically hidden.
Example
  • C#
Chart.TitleBox.Background = new Background(System.Drawing.Color.SkyBlue);
Chart.TitleBox.CornerBottomLeft = BoxCorner.Square;
Chart.TitleBox.CornerBottomRight = BoxCorner.Square;
Chart.TitleBox.CornerTopLeft = BoxCorner.Cut;
Chart.TitleBox.CornerTopRight = BoxCorner.Cut;
Chart.TitleBox.IconPath="icon.gif";
Chart.TitleBox.Label =  new dotnetCHARTING.Label("Orders By Customers",new Font("Arial",10),Color.DarkSlateBlue);
Chart.TitleBox.Line = new Line(Color.Blue);
Chart.TitleBox.Position = TitleBoxPosition.Center;
Chart.TitleBox.Shadow.Color = Color.LightBlue;
Chart.TitleBox.Shadow.Depth=40;

//For complete code, see TitleBox.aspx sample
  • Visual Basic
Chart.TitleBox.Background = new Background(System.Drawing.Color.SkyBlue)
Chart.TitleBox.CornerBottomLeft = BoxCorner.Square
Chart.TitleBox.CornerBottomRight = BoxCorner.Square
Chart.TitleBox.CornerTopLeft = BoxCorner.Cut
Chart.TitleBox.CornerTopRight = BoxCorner.Cut
Chart.TitleBox.IconPath="icon.gif"
Chart.TitleBox.Label =  new dotnetCHARTING.Label("Orders By Customers",new Font("Arial",10),Color.DarkSlateBlue)
Chart.TitleBox.Line = new Line(Color.Blue)
Chart.TitleBox.Position = TitleBoxPosition.Center
Chart.TitleBox.Shadow.Color = Color.LightBlue
Chart.TitleBox.Shadow.Depth=40

'For complete code, see TitleBox.aspx sample
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ToolTip Property
ToolTip Property (Chart)
Gets or sets the Tooltip of the entinre chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property ToolTip As String
'Usage

Dim instance As Chart
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public override string ToolTip {get; set;}
Example
  • C#
Chart.ToolTip = "Sales Report";
  • Visual Basic
Chart.ToolTip = "Sales Report"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Base Implementation in ToolTip


Example

dotnetCHARTING Namespace > Chart Class : TotalSeries Property
TotalSeries Property
Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TotalSeries As Integer
'Usage

Dim instance As Chart
Dim value As Integer

value = instance.TotalSeries
public int TotalSeries {get;}
Example
  • C#
int pageSize=3;
    int totalPage = Chart.Total%pageSize==0?Chart.Total/pageSize:(Chart.Total/pageSize)+1;
    if(totalPage>currentPage)
    {
        //Display "Next" button.
    }
  • Visual Basic
Dim pageSize As Integer = 3
    Dim totalPage As Integer = Chart.Total / pageSize;
    If Chart.Total Mod pageSize > 0 Then
        totalPage = totalPage + 1)
    End If
    If totalPage > currentPage Then
        'Display "Next" button.
    End If
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Transpose Property
Transpose Property
Gets or sets a value indicating whether data added to this chart's SeriesCollection property is automatically transposed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transpose As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.Transpose = value

value = instance.Transpose
public bool Transpose {get; set;}
Example
  • C#
Chart.Transpose = true;
  • Visual Basic
Chart.Transpose = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Type Property
Type Property (Chart)
Gets or sets the ChartType of this Chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ChartType
'Usage

Dim instance As Chart
Dim value As ChartType

instance.Type = value

value = instance.Type
public ChartType Type {get; set;}
Example
  • C#
Chart.Type = ChartType.Pie;
  • Visual Basic
Chart.Type = ChartType.Pie
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : URL Property
URL Property (Chart)
Gets or sets the URL of the entinre chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As Chart
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}
Example
  • C#
Chart.URL = "http://www.yahoo.com";
  • Visual Basic
Chart.URL = "http://www.yahoo.com"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : URLTarget Property
URLTarget Property (Chart)
Gets or sets the target of the URL link.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As Chart
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Example
  • C#
Chart.URLTarget = "_blank";
  • Visual Basic
Chart.URLTarget = "_blank"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Use3D Property
Use3D Property (Chart)
Gets or sets a value indicating whether chart elements are rendered in 3D.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use3D As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.Use3D = value

value = instance.Use3D
public bool Use3D {get; set;}
Example
  • C#
Chart.Use3D = true;
  • Visual Basic
Chart.Use3D = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property
Depth Property


Example

dotnetCHARTING Namespace > Chart Class : UseFile Property
UseFile Property
Gets or sets a value indicating whether the generated image is saved as a file in the TempDirectory folder or streamed directly to the browser.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseFile As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.UseFile = value

value = instance.UseFile
public bool UseFile {get; set;}
Remarks
.netCHARTING supports streaming images in addition to returning a reference to a generated file. There are differences in the way the control can be used between these two image return methods. When using a file reference, you are free to treat the page as you normally would, including HTML and any other web content on the page.

If you are streaming the image back, only the control call should exist on the page because no other HTML will render. This is not a limitation of .netCHARTING but rather specific to the HTTP implementation which serves each request separately (as such a request to a web site with 3 images is actually 4 unique requests and the browser does the job of assembling those 4 items into the web page you see.

Becauase streaming images does not allow HTML, setting url and tooltip properties of elements on the chart will have no effect.
Example
  • C#
Chart.UseFile = true;
  • Visual Basic
Chart.UseFile = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


Example

dotnetCHARTING Namespace > Chart Class : UseSession Property
UseSession Property

Gets or sets a value indicating whether the generated image is saved
temporarily in a session variable for subsequent streaming from a helper aspx page. This option may only be used when UseFile = false.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseSession As Boolean
'Usage

Dim instance As Chart
Dim value As Boolean

instance.UseSession = value

value = instance.UseSession
public bool UseSession {get; set;}
Remarks

.netCHARTING supports streaming images directly to the browser in addition
to returning a reference to a generated image file. There are differences in
the way the control can be used between these two image return methods. When using a file reference, you are free to treat the page as you normally would, and include HTML and any other web content on the page.<br/>

Since streaming turns the page you include the control on into the actual
image file return, the browser will not also allow HTML within the same http
request. As a result url, tooltip and drilldown options will not be
enabled. Setting UseSession to true works around this issue by returning an
image reference to the same aspx page for image streaming. The image
stream is temporary stored in a session variable and an aspx page in the
temp directory streams the image to the browser, enabling the regular HTML
and image map based features to work seamlessly with the control.

NOTE: streaming of any kind (direct or through the session helper) has a large performance cost over the file based system which has build in cleanup functionlity and should be used in all possible environments. Streaming
should never be used unless your environment completely prevents write
access which is required for the file based system to operate.<br/>

Example
  • C#
Chart.UseSession = true;
  • Visual Basic
Chart.UseSession = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members

Tutorials

File Handling


dotnetCHARTING Namespace > Chart Class : View3D Property
View3D Property
Gets or sets the View3D class that contains properties to control the rendering of 3D surface charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property View3D As View3D
'Usage

Dim instance As Chart
Dim value As View3D

instance.View3D = value

value = instance.View3D
public View3D View3D {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : Width Property
Width Property (Chart)
Gets or sets the width of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Property Width As Unit
'Usage

Dim instance As Chart
Dim value As Unit

instance.Width = value

value = instance.Width
public override Unit Width {get; set;}
Example
  • C#
Chart.Width = 600;
  • Visual Basic
Chart.Width = Unit.Parse(600)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Base Implementation in Width


Example

dotnetCHARTING Namespace > Chart Class : XAxis Property
XAxis Property (Chart)

Gets or Sets the main XAxis which all series inherit by default.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XAxis As Axis
'Usage

Dim instance As Chart
Dim value As Axis

instance.XAxis = value

value = instance.XAxis
public Axis XAxis {get; set;}
Example
  • C#
//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Axis xAxisObj = new Axis();
 xAxisObj.Line.StartCap = LineCap.RoundAnchor;
 xAxisObj.Line.EndCap = LineCap.ArrowAnchor;
 xAxisObj.Line.Width =3;
 xAxisObj.Label.Text="customized xAxis";
 Chart.XAxis = xAxisObj;
  • Visual Basic
'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Dim xAxisObj As Axis  = new Axis()
xAxisObj.Line.StartCap = LineCap.RoundAnchor
xAxisObj.Line.EndCap = LineCap.ArrowAnchor
xAxisObj.Line.Width = 3
xAxisObj.Label.Text="customized xAxis"
Chart.XAxis = xAxisObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : YAxis Property
YAxis Property (Chart)

Gets or Sets the main YAxis which all series inherit by default.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YAxis As Axis
'Usage

Dim instance As Chart
Dim value As Axis

instance.YAxis = value

value = instance.YAxis
public Axis YAxis {get; set;}
Example
  • C#
//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Axis yAxisObj = new Axis();
 yAxisObj.Line.StartCap = LineCap.RoundAnchor;
 yAxisObj.Line.EndCap = LineCap.ArrowAnchor;
 yAxisObj.Line.Width =3;
 yAxisObj.Label.Text="customized yAxis";
 Chart.YAxis = yAxisObj;
  • Visual Basic
'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
Dim yAxisObj As Axis  = new Axis()
yAxisObj.Line.StartCap = LineCap.RoundAnchor
yAxisObj.Line.EndCap = LineCap.ArrowAnchor
yAxisObj.Line.Width = 3
yAxisObj.Label.Text="customized yAxis"
Chart.YAxis = yAxisObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : ZAxis Property
ZAxis Property (Chart)

Gets or Sets the main ZAxis which all series inherit by default. The ZAxis is used with surface charts.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZAxis As Axis
'Usage

Dim instance As Chart
Dim value As Axis

instance.ZAxis = value

value = instance.ZAxis
public Axis ZAxis {get; set;}
Example
  • C#
//Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Axis zAxisObj = new Axis();
 zAxisObj.Line.StartCap = LineCap.RoundAnchor;
 zAxisObj.Line.EndCap = LineCap.ArrowAnchor;
 zAxisObj.Line.Width =3;
 zAxisObj.Label.Text="customized zAxis";
 Chart.ZAxis = xAxisObj;
  • Visual Basic
'Import Drawing2D : <%@ Import Namespace="System.Drawing.Drawing2D" %>
 Dim zAxisObj As Axis  = new Axis()
zAxisObj.Line.StartCap = LineCap.RoundAnchor
zAxisObj.Line.EndCap = LineCap.ArrowAnchor
zAxisObj.Line.Width = 3
zAxisObj.Label.Text="customized zAxis"
Chart.ZAxis = xAxisObj
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


dotnetCHARTING Namespace > Chart Class : Zoomer Property
Zoomer Property (Chart)
Provides AJAX zooming and scrolling feature settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Zoomer As ImageZoomer
'Usage

Dim instance As Chart
Dim value As ImageZoomer

instance.Zoomer = value

value = instance.Zoomer
public ImageZoomer Zoomer {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


%%PageItemTitle%% $$Events$$

dotnetCHARTING Namespace : Chart Class
Chart Class Events

For a list of all members of this type, see Chart members.

Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | ErrorProcessing |
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PostDataProcessing | Occurs when the the chart is completed the data processing.
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

Chart Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > Chart Class : ErrorProcessing Event
ErrorProcessing Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ErrorProcessing As ErrorProcessingEventHandler
'Usage

Dim instance As Chart
Dim handler As ErrorProcessingEventHandler

AddHandler instance.ErrorProcessing, handler
public event ErrorProcessingEventHandler ErrorProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


Example

dotnetCHARTING Namespace > Chart Class : PostDataProcessing Event
PostDataProcessing Event
Occurs when the the chart is completed the data processing.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event PostDataProcessing As PostDataProcessingEventHandler
'Usage

Dim instance As Chart
Dim handler As PostDataProcessingEventHandler

AddHandler instance.PostDataProcessing, handler
public event PostDataProcessingEventHandler PostDataProcessing
Remarks
This event is very useful for customizing and displaying the processed data specially when using SplitByLimit which generates more than one series from a series.
Example
The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx
  • C#
//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}
  • Visual Basic
'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ChartArea Class
ChartArea Class
Represents an area on which series and elements are plotted.
Object Model
ChartArea ClassBackground ClassElement ClassSeries ClassHotspot ClassLine ClassLabel ClassLegendBox ClassLine ClassSeries ClassSeriesCollection ClassSeries ClassShadow ClassBox ClassLabel ClassAxis ClassAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ChartArea
'Usage

Dim instance As ChartArea
public class ChartArea
Example
ChartAreaCustomLayout
ChartAreaRelationships
ChartAreaDB
Inheritance Hierarchy

System.Object
dotnetCHARTING.ChartArea

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Members
dotnetCHARTING Namespace

Tutorials

Multiple Chart Areas
Chart Area Zooming


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ChartArea Class
ChartArea Class Members

The following tables list the members exposed by ChartArea.

Public Constructors
 | Name | Description
Public Constructor | ChartArea Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this chart area.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property | CornerBottomRight | Gets or sets the bottom right corner style.
Public Property | CornerSize | Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings.
Public Property | CornerTopLeft | Gets or sets the top left corner style.
Public Property | CornerTopRight | Gets or sets the top right corner style.
Public Property | DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | DefaultCorner | Gets or sets the default box corner style.
Public Property | DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property | DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | GridPosition | Gets or sets the layout column and row position of this ChartArea.
Public Property | HeightPercentage | Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.
Public Property | Hotspot | Gets or sets the Hotspot of this ChartArea. This feature is designed for use with Navigator only at this time.
Public Property | IncludeGroupingDataInSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | InteriorLine | Gets or sets a line object which is drawn inside the chart area.
Public Property | Label | Gets or sets a label object which draws a string inside the chart area.
Public Property | LegendBox | Gets or sets a LegendBox object associated with this chart area.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | Line | Gets or sets the Line object used to draw the outline of this chart area.
Public Property | NavigatorDragAreaPercentage | Gets or sets a value that specifies what percentage of the chart area used used for drag scrolling or arbitrary selection.
Public Property | NavigatorOptions | Gets or sets the chart area interactivity features for the Silverlight Navigator.
Public Property | Padding | Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, TreeMap, and gauge charts. When used with JSCharts, the value represents padding percentage from 0 - 100.
Public Property | Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property | SeriesCollection | Adds Series or SeriesCollection objects to the chart area.
Public Property | Shadow | Gets or sets the Shadow cast under this box.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property | Title | Gets or sets the ChartArea's title. Equivalent to ChartArea.TitleBox.Label.Text.
Public Property | TitleBox | Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.
Public Property | ValueLabel | Gets or sets a label that specifies the font and color of element labels drawn on the chart. Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property | Visible | Gets or sets a value that indicates whether this chart area is visible.
Public Property | WidthPercentage | Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.
Public Property | XAxis | Gets or sets the X axis of this chart area.
Public Property | YAxis | Gets or sets the Y axis of this chart area.
Top
Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make the ChartArea transparent.
Public Method | GetCoordinates | Gets the coordinates of this ChartArea after the chart is rendered.
Public Method | GetRectangle | Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.
Public Method | GetXZoomChartArea | Gets a chart area which expands the specified x axis at the specified scale range and allows vieweing data in greater detail.
Public Method | GetYZoomChartArea | Gets a chart area which expands the specified y axis at the specified scale range and allows vieweing data in greater detail.
Top
See Also

Reference

ChartArea Class
dotnetCHARTING Namespace

Tutorials

Multiple Chart Areas
Chart Area Zooming


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class : ChartArea Constructor
ChartArea Constructor
Overload List
Overload | Description
ChartArea Constructor() | Initializes a new instance of the ChartArea class.
ChartArea Constructor(String) | Initializes a new instance of the ChartArea class with a title.
ChartArea Constructor(String,SeriesCollection) | Initializes a new instance of the ChartArea class with a title and SeriesCollection.
ChartArea Constructor(SeriesCollection) | Initializes a new instance of the ChartArea class with a SeriesCollection.
ChartArea Constructor(String,Series) | Initializes a new instance of the ChartArea class with a title and SeriesCollection.
ChartArea Constructor(Series) | Initializes a new instance of the ChartArea class with a Series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor()
ChartArea Constructor()
Initializes a new instance of the ChartArea class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ChartArea()
public ChartArea()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(String)
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
ChartArea Constructor(String)
Initializes a new instance of the ChartArea class with a title.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal title As String _
)
'Usage

Dim title As String

Dim instance As New ChartArea(title)
public ChartArea(
   string title
)

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(String,SeriesCollection)
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
Data plotted in this chart area.
ChartArea Constructor(String,SeriesCollection)
Initializes a new instance of the ChartArea class with a title and SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal title As String, _
   ByVal sc As SeriesCollection _
)
'Usage

Dim title As String
Dim sc As SeriesCollection

Dim instance As New ChartArea(title, sc)
public ChartArea(
   string title,
   SeriesCollection sc
)

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
sc
Data plotted in this chart area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(SeriesCollection)
Data plotted in this chart area.
ChartArea Constructor(SeriesCollection)
Initializes a new instance of the ChartArea class with a SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal sc As SeriesCollection _
)
'Usage

Dim sc As SeriesCollection

Dim instance As New ChartArea(sc)
public ChartArea(
   SeriesCollection sc
)

Parameters

sc
Data plotted in this chart area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(String,Series)
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
A series of data plotted in this chart area.
ChartArea Constructor(String,Series)
Initializes a new instance of the ChartArea class with a title and SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal title As String, _
   ByVal s As Series _
)
'Usage

Dim title As String
Dim s As Series

Dim instance As New ChartArea(title, s)
public ChartArea(
   string title,
   Series s
)

Parameters

title
Chart area's title, equivalent of using: ChartArea.TitleBox.Text.
s
A series of data plotted in this chart area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartArea Class > ChartArea Constructor : ChartArea Constructor(Series)
A series of data plotted in this chart area.
ChartArea Constructor(Series)
Initializes a new instance of the ChartArea class with a Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal s As Series _
)
'Usage

Dim s As Series

Dim instance As New ChartArea(s)
public ChartArea(
   Series s
)

Parameters

s
A series of data plotted in this chart area.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ChartArea Class
ChartArea Class Methods

For a list of all members of this type, see ChartArea members.

Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make the ChartArea transparent.
Public Method | GetCoordinates | Gets the coordinates of this ChartArea after the chart is rendered.
Public Method | GetRectangle | Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.
Public Method | GetXZoomChartArea | Gets a chart area which expands the specified x axis at the specified scale range and allows vieweing data in greater detail.
Public Method | GetYZoomChartArea | Gets a chart area which expands the specified y axis at the specified scale range and allows vieweing data in greater detail.
Top
See Also

Reference

ChartArea Class
dotnetCHARTING Namespace

Tutorials

Multiple Chart Areas
Chart Area Zooming


dotnetCHARTING Namespace > ChartArea Class : ClearColors Method
ClearColors Method (ChartArea)
Serves as a shortcut to make the ChartArea transparent.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ClearColors()
'Usage

Dim instance As ChartArea

instance.ClearColors()
public void ClearColors()
Remarks
The following properties are set:
Background.Color = Color.Empty
Background.Bevel = false
Line.Color = Color.Empty
Shadow.Color = Color.Empty
InteriorLine.Color = Color.Empty
For each axis
AlternateGridBackground.Color = Color.Empty;
AlternateGridBackground.Mode = BackgroundMode.Color;
AlternateGridBackground.Bevel = false;
GridLine.Color = Color.Empty;
ZeroLine.Color = Color.Empty;
Example
Floating Pies
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

FloatingPie


dotnetCHARTING Namespace > ChartArea Class : GetCoordinates Method
GetCoordinates Method (ChartArea)
Gets the coordinates of this ChartArea after the chart is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetCoordinates() As Point()
'Usage

Dim instance As ChartArea
Dim value() As Point

value = instance.GetCoordinates()
public Point[] GetCoordinates()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

GetAxisRange


dotnetCHARTING Namespace > ChartArea Class : GetRectangle Method
GetRectangle Method (ChartArea)
Gets a Rectangle object indicating this ChartArea's position and size after the chart is rendered.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetRectangle() As Rectangle
'Usage

Dim instance As ChartArea
Dim value As Rectangle

value = instance.GetRectangle()
public Rectangle GetRectangle()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

BoxCoordinates


dotnetCHARTING Namespace > ChartArea Class : GetXZoomChartArea Method
The x axis to zoom.
The scale range on the axis to expand.
A line object used to indicate that the resulting chart area is zooming into the original one.
GetXZoomChartArea Method
Gets a chart area which expands the specified x axis at the specified scale range and allows vieweing data in greater detail.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetXZoomChartArea( _
   ByVal axis As Axis, _
   ByVal sr As ScaleRange, _
   ByVal line As Line _
) As ChartArea
'Usage

Dim instance As ChartArea
Dim axis As Axis
Dim sr As ScaleRange
Dim line As Line
Dim value As ChartArea

value = instance.GetXZoomChartArea(axis, sr, line)
public ChartArea GetXZoomChartArea(
   Axis axis,
   ScaleRange sr,
   Line line
)

Parameters

axis
The x axis to zoom.
sr
The scale range on the axis to expand.
line
A line object used to indicate that the resulting chart area is zooming into the original one.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

YAxisZoom


dotnetCHARTING Namespace > ChartArea Class : GetYZoomChartArea Method
The y axis to zoom.
The scale range on the axis to expand.
A line object used to indicate that the resulting chart area is zooming into the original one.
GetYZoomChartArea Method
Gets a chart area which expands the specified y axis at the specified scale range and allows vieweing data in greater detail.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetYZoomChartArea( _
   ByVal axis As Axis, _
   ByVal sr As ScaleRange, _
   ByVal line As Line _
) As ChartArea
'Usage

Dim instance As ChartArea
Dim axis As Axis
Dim sr As ScaleRange
Dim line As Line
Dim value As ChartArea

value = instance.GetYZoomChartArea(axis, sr, line)
public ChartArea GetYZoomChartArea(
   Axis axis,
   ScaleRange sr,
   Line line
)

Parameters

axis
The y axis to zoom.
sr
The scale range on the axis to expand.
line
A line object used to indicate that the resulting chart area is zooming into the original one.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

XAxisZoom


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ChartArea Class
ChartArea Class Properties

For a list of all members of this type, see ChartArea members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this chart area.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style.
Public Property | CornerBottomRight | Gets or sets the bottom right corner style.
Public Property | CornerSize | Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings.
Public Property | CornerTopLeft | Gets or sets the top left corner style.
Public Property | CornerTopRight | Gets or sets the top right corner style.
Public Property | DateGrouping | Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | DefaultCorner | Gets or sets the default box corner style.
Public Property | DefaultElement | Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Public Property | DefaultSeries | Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | GridPosition | Gets or sets the layout column and row position of this ChartArea.
Public Property | HeightPercentage | Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.
Public Property | Hotspot | Gets or sets the Hotspot of this ChartArea. This feature is designed for use with Navigator only at this time.
Public Property | IncludeGroupingDataInSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | InteriorLine | Gets or sets a line object which is drawn inside the chart area.
Public Property | Label | Gets or sets a label object which draws a string inside the chart area.
Public Property | LegendBox | Gets or sets a LegendBox object associated with this chart area.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | Line | Gets or sets the Line object used to draw the outline of this chart area.
Public Property | NavigatorDragAreaPercentage | Gets or sets a value that specifies what percentage of the chart area used used for drag scrolling or arbitrary selection.
Public Property | NavigatorOptions | Gets or sets the chart area interactivity features for the Silverlight Navigator.
Public Property | Padding | Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, TreeMap, and gauge charts. When used with JSCharts, the value represents padding percentage from 0 - 100.
Public Property | Series | Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Public Property | SeriesCollection | Adds Series or SeriesCollection objects to the chart area.
Public Property | Shadow | Gets or sets the Shadow cast under this box.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Public Property | Title | Gets or sets the ChartArea's title. Equivalent to ChartArea.TitleBox.Label.Text.
Public Property | TitleBox | Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.
Public Property | ValueLabel | Gets or sets a label that specifies the font and color of element labels drawn on the chart. Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel
Public Property | Visible | Gets or sets a value that indicates whether this chart area is visible.
Public Property | WidthPercentage | Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.
Public Property | XAxis | Gets or sets the X axis of this chart area.
Public Property | YAxis | Gets or sets the Y axis of this chart area.
Top
See Also

Reference

ChartArea Class
dotnetCHARTING Namespace

Tutorials

Multiple Chart Areas
Chart Area Zooming


dotnetCHARTING Namespace > ChartArea Class : Background Property
Background Property (ChartArea)
Gets or sets a background object used to fill the interior of this chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As ChartArea
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Samples

BoxHeaders


dotnetCHARTING Namespace > ChartArea Class : CornerBottomLeft Property
CornerBottomLeft Property (ChartArea)
Gets or sets the bottom left corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerBottomLeft As BoxCorner
'Usage

Dim instance As ChartArea
Dim value As BoxCorner

instance.CornerBottomLeft = value

value = instance.CornerBottomLeft
public BoxCorner CornerBottomLeft {get; set;}
Remarks
Only corners without axes touching them can be styled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : CornerBottomRight Property
CornerBottomRight Property (ChartArea)
Gets or sets the bottom right corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerBottomRight As BoxCorner
'Usage

Dim instance As ChartArea
Dim value As BoxCorner

instance.CornerBottomRight = value

value = instance.CornerBottomRight
public BoxCorner CornerBottomRight {get; set;}
Remarks
Only corners without axes touching them can be styled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : CornerSize Property
CornerSize Property (ChartArea)
Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerSize As Integer
'Usage

Dim instance As ChartArea
Dim value As Integer

instance.CornerSize = value

value = instance.CornerSize
public int CornerSize {get; set;}
Remarks
Only corners without axes touching them can be styled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : CornerTopLeft Property
CornerTopLeft Property (ChartArea)
Gets or sets the top left corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerTopLeft As BoxCorner
'Usage

Dim instance As ChartArea
Dim value As BoxCorner

instance.CornerTopLeft = value

value = instance.CornerTopLeft
public BoxCorner CornerTopLeft {get; set;}
Remarks
Only corners without axes touching them can be styled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : CornerTopRight Property
CornerTopRight Property (ChartArea)
Gets or sets the top right corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerTopRight As BoxCorner
'Usage

Dim instance As ChartArea
Dim value As BoxCorner

instance.CornerTopRight = value

value = instance.CornerTopRight
public BoxCorner CornerTopRight {get; set;}
Remarks
Only corners without axes touching them can be styled.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Example

dotnetCHARTING Namespace > ChartArea Class : DateGrouping Property
DateGrouping Property (ChartArea)
Gets or sets a TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGrouping As TimeInterval
'Usage

Dim instance As ChartArea
Dim value As TimeInterval

instance.DateGrouping = value

value = instance.DateGrouping
public TimeInterval DateGrouping {get; set;}
Remarks
Controls how the values of a given series are grouped by date. In order to use this option the second column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the second column returned by the SqlStatement.
Example
  • C#
[C#]
Chart.DateGrouping = TimeInterval.Days;
  • C#
[Visual Basic]
Chart.DateGrouping = TimeInterval.Days
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property
DateGrouping Property


Example

dotnetCHARTING Namespace > ChartArea Class : DateGroupingCalculation Property
DateGroupingCalculation Property (ChartArea)
Gets or sets an enum which determines how values are grouped to create a single element value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingCalculation As Calculation
'Usage

Dim instance As ChartArea
Dim value As Calculation

instance.DateGroupingCalculation = value

value = instance.DateGroupingCalculation
public Calculation DateGroupingCalculation {get; set;}
Remarks
When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.
Example
  • C#
[C#]
Chart.DateGroupingCalculation = Calculation.Average;
  • C#
[Visual Basic]
Chart.DateGroupingCalculation = Calculation.Average
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
DateGroupingCalculation Property


Example

dotnetCHARTING Namespace > ChartArea Class : DateGroupingSort Property
DateGroupingSort Property (ChartArea)
Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingSort As Boolean
'Usage

Dim instance As ChartArea
Dim value As Boolean

instance.DateGroupingSort = value

value = instance.DateGroupingSort
public bool DateGroupingSort {get; set;}
Remarks
When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.
Example
  • C#
[C#]
Chart.DateGroupingSort = true;
  • C#
[Visual Basic]
Chart.DateGroupingSort = true
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
DateGroupingSort Property


Example

dotnetCHARTING Namespace > ChartArea Class : DefaultCorner Property
DefaultCorner Property (ChartArea)
Gets or sets the default box corner style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultCorner As BoxCorner
'Usage

Dim instance As ChartArea
Dim value As BoxCorner

instance.DefaultCorner = value

value = instance.DefaultCorner
public BoxCorner DefaultCorner {get; set;}
Remarks
Explicitly set corners will not be overridden. Only corners without axes touching them can be styled.
Example
Usage example.
  • Visual Basic
Chart.LegendBox.DefaultCorner = BoxCorner.Round
  • C#
Chart.LegendBox.DefaultCorner = BoxCorner.Round;
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Example

dotnetCHARTING Namespace > ChartArea Class : DefaultElement Property
DefaultElement Property (ChartArea)
Gets or sets an Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultElement As Element
'Usage

Dim instance As ChartArea
Dim value As Element

instance.DefaultElement = value

value = instance.DefaultElement
public Element DefaultElement {get; set;}
Example
  • C#
myChartArea.DefaultElement.SmartLabel.Text = "%Name";
  • Visual Basic
myChartArea.DefaultElement.SmartLabel.Text = "%Name"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Example

dotnetCHARTING Namespace > ChartArea Class : DefaultSeries Property
DefaultSeries Property (ChartArea)
Gets or sets a Series object whose properties will trickle to all other series in this chart area unless otherwise specified.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultSeries As Series
'Usage

Dim instance As ChartArea
Dim value As Series

instance.DefaultSeries = value

value = instance.DefaultSeries
public Series DefaultSeries {get; set;}
Example
  • C#
myChartArea.DefaultSeries.Type = SeriesType.AreaLine;
  • Visual Basic
myChartArea.DefaultSeries.Type = SeriesType.AreaLine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : DrillDownIntoSeries Property
DrillDownIntoSeries Property (ChartArea)
When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrillDownIntoSeries As Boolean
'Usage

Dim instance As ChartArea
Dim value As Boolean

instance.DrillDownIntoSeries = value

value = instance.DrillDownIntoSeries
public bool DrillDownIntoSeries {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
DrillDownIntoSeries Property


dotnetCHARTING Namespace > ChartArea Class : GridPosition Property
GridPosition Property
Gets or sets the layout column and row position of this ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GridPosition As Point
'Usage

Dim instance As ChartArea
Dim value As Point

instance.GridPosition = value

value = instance.GridPosition
public Point GridPosition {get; set;}
Remarks

The default (top-left) position is 0,0. To place another ChartArea to the right of it, the position would be 1,0.

The format is: ( Column, Row ) or ( X , Y )

Example
ChartArea.GridPosition = new Point(1,0);
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Tutorials

Multiple Chart Areas


dotnetCHARTING Namespace > ChartArea Class : HeightPercentage Property
HeightPercentage Property
Gets or sets a value that specifies what percentage of the full height available for ChartAreas this ChartArea will occupy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeightPercentage As Integer
'Usage

Dim instance As ChartArea
Dim value As Integer

instance.HeightPercentage = value

value = instance.HeightPercentage
public int HeightPercentage {get; set;}
Remarks
Values range from 0 to 100. This property should be used with multiple vertical chart area charts.
Example
ChartAreaSizing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Multiple Chart Areas


dotnetCHARTING Namespace > ChartArea Class : Hotspot Property
Hotspot Property (ChartArea)
Gets or sets the Hotspot of this ChartArea. This feature is designed for use with Navigator only at this time.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As ChartArea
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Remarks
Specialized tokens %YValue and %XValue can be used in this hotspot's strings. Unlike other tokens used with hotspots where the values are the same for the entire hotspot area, these tokens refer to the mouse position on the chart area. For example, if used with tooltips, the tooltip text will change depending on the mouse position.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : IncludeGroupingDataInSubValues Property
IncludeGroupingDataInSubValues Property
When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludeGroupingDataInSubValues As Boolean
'Usage

Dim instance As ChartArea
Dim value As Boolean

instance.IncludeGroupingDataInSubValues = value

value = instance.IncludeGroupingDataInSubValues
public bool IncludeGroupingDataInSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
PopulateDateGroupingSubValues Property


dotnetCHARTING Namespace > ChartArea Class : InteriorLine Property
InteriorLine Property (ChartArea)
Gets or sets a line object which is drawn inside the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InteriorLine As Line
'Usage

Dim instance As ChartArea
Dim value As Line

instance.InteriorLine = value

value = instance.InteriorLine
public Line InteriorLine {get; set;}
Remarks
The interior line can be seen when the chart is drawn in 3D.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : Label Property
Label Property (ChartArea)
Gets or sets a label object which draws a string inside the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As ChartArea
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Remarks
The label will be drawn in the upper left corner of the chart.
Example
FinancialDB
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : LegendBox Property
LegendBox Property (ChartArea)
Gets or sets a LegendBox object associated with this chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendBox As LegendBox
'Usage

Dim instance As ChartArea
Dim value As LegendBox

instance.LegendBox = value

value = instance.LegendBox
public LegendBox LegendBox {get; set;}
Remarks
This property is null by default. By instantiating a new LegendBox, LegendEntry objects of the series or element in this chart area will appear in this LegendBox. Otherwise, they would appear in the main chart area's legend box (Chart.ChartArea.LegendBox).
Example
LegendBoxMultiple
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : LimitPrimarySeries Property
LimitPrimarySeries Property (ChartArea)
In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LimitPrimarySeries As String
'Usage

Dim instance As ChartArea
Dim value As String

instance.LimitPrimarySeries = value

value = instance.LimitPrimarySeries
public string LimitPrimarySeries {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
LimitPrimarySeries Property


dotnetCHARTING Namespace > ChartArea Class : Line Property
Line Property (ChartArea)
Gets or sets the Line object used to draw the outline of this chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As ChartArea
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : NavigatorDragAreaPercentage Property
NavigatorDragAreaPercentage Property
Gets or sets a value that specifies what percentage of the chart area used used for drag scrolling or arbitrary selection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NavigatorDragAreaPercentage As Double
'Usage

Dim instance As ChartArea
Dim value As Double

instance.NavigatorDragAreaPercentage = value

value = instance.NavigatorDragAreaPercentage
public double NavigatorDragAreaPercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : NavigatorOptions Property
NavigatorOptions Property
Gets or sets the chart area interactivity features for the Silverlight Navigator.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NavigatorOptions As ChartAreaNavigationOptions
'Usage

Dim instance As ChartArea
Dim value As ChartAreaNavigationOptions

instance.NavigatorOptions = value

value = instance.NavigatorOptions
public ChartAreaNavigationOptions NavigatorOptions {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : Padding Property
Padding Property (ChartArea)
Gets or sets the padding or spacing of chart objects plotted on this ChartArea. This applies only to radar, pie, TreeMap, and gauge charts. When used with JSCharts, the value represents padding percentage from 0 - 100.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As Integer
'Usage

Dim instance As ChartArea
Dim value As Integer

instance.Padding = value

value = instance.Padding
public int Padding {get; set;}
Remarks
To control column and cylinder spacing see link below.
Example
Padding
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
Column, Cylinder Spacing


Example

dotnetCHARTING Namespace > ChartArea Class : Series Property
Series Property (ChartArea)
Gets or sets a series which is added to the chart's main SeriesCollection when the Chart.SeriesCollection.Add() method is invoked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Series As Series
'Usage

Dim instance As ChartArea
Dim value As Series

instance.Series = value

value = instance.Series
public Series Series {get; set;}
Example
  • C#
[C#]
//Adding series programatically
Chart.Series.Name="Vancouver";
Chart.Series.Type = SeriesType.Cylinder;
Chart.Series.Element  = new Element("Mon",2);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Tue",4);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Wed",5);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Thr",6);
Chart.Series.Elements.Add();
Chart.Series.Element = new Element("Fri",5);
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();
  • C#
[Visual Basic]
'Adding series programatically
Chart.Series.Name="Vancouver"
Chart.Series.Type = SeriesType.Cylinder
Chart.Series.Element  = new Element("Mon",2)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Tue",4)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Wed",5)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Thr",6)
Chart.Series.Elements.Add()
Chart.Series.Element = new Element("Fri",5)
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : SeriesCollection Property
SeriesCollection Property (ChartArea)
Adds Series or SeriesCollection objects to the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SeriesCollection As SeriesCollection
'Usage

Dim instance As ChartArea
Dim value As SeriesCollection

value = instance.SeriesCollection
public SeriesCollection SeriesCollection {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : Shadow Property
Shadow Property (ChartArea)
Gets or sets the Shadow cast under this box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shadow As Shadow
'Usage

Dim instance As ChartArea
Dim value As Shadow

instance.Shadow = value

value = instance.Shadow
public Shadow Shadow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


Example

dotnetCHARTING Namespace > ChartArea Class : StartDateOfYear Property
StartDateOfYear Property (ChartArea)
Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDateOfYear As Date
'Usage

Dim instance As ChartArea
Dim value As Date

instance.StartDateOfYear = value

value = instance.StartDateOfYear
public DateTime StartDateOfYear {get; set;}
Remarks
This property determine the start month of the year. The default is January.
Example
This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.
  • C#
de.StartDateOfYear = new DateTime(2004,3,1);
  • Visual Basic
de.StartDateOfYear = New DateTime(2004, 3, 1)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
DateGrouping Property
StartDateOfYear Property


Example

dotnetCHARTING Namespace > ChartArea Class : StartDayOfWeek Property
StartDayOfWeek Property (ChartArea)
Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when DateGrouping is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDayOfWeek As DayOfWeek
'Usage

Dim instance As ChartArea
Dim value As DayOfWeek

instance.StartDayOfWeek = value

value = instance.StartDayOfWeek
public DayOfWeek StartDayOfWeek {get; set;}
Example
  • C#
[C#]
Chart.DateGrouping = TimeInterval.Weeks;
Chart.StartDayOfWeek = DayOfWeek.Monday;

//For complete code, see StartDayOfWeek.aspx sample.
  • C#
[Visual Basic]
Chart.DateGrouping = TimeInterval.Weeks
Chart.StartDayOfWeek = DayOfWeek.Monday

'For complete code, see StartDayOfWeek.aspx sample.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members
StartDayOfWeek Property


Example

dotnetCHARTING Namespace > ChartArea Class : Title Property
Title Property (ChartArea)
Gets or sets the ChartArea's title.
Equivalent to ChartArea.TitleBox.Label.Text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Title As String
'Usage

Dim instance As ChartArea
Dim value As String

instance.Title = value

value = instance.Title
public string Title {get; set;}
Example
  • C#
ChartArea.Title = "Chart of Sales for 2003";
  • Visual Basic
ChartArea.Title = "Chart of Sales for 2003"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : TitleBox Property
TitleBox Property (ChartArea)
Gets or sets a title box (dotnetCHARTING.Box) object associated with this ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TitleBox As Box
'Usage

Dim instance As ChartArea
Dim value As Box

instance.TitleBox = value

value = instance.TitleBox
public Box TitleBox {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : Visible Property
Visible Property (ChartArea)
Gets or sets a value that indicates whether this chart area is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As ChartArea
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : WidthPercentage Property
WidthPercentage Property

Gets or sets a value that specifies what percentage of the full width available for ChartAreas this ChartArea will occupy.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WidthPercentage As Integer
'Usage

Dim instance As ChartArea
Dim value As Integer

instance.WidthPercentage = value

value = instance.WidthPercentage
public int WidthPercentage {get; set;}
Remarks
Values range from 0 to 100. This property should be used with multiple horizontal chart area charts.
Example
ChartAreaDataDistribution
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members

Tutorials

Multiple Chart Areas


dotnetCHARTING Namespace > ChartArea Class : XAxis Property
XAxis Property (ChartArea)
Gets or sets the X axis of this chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XAxis As Axis
'Usage

Dim instance As ChartArea
Dim value As Axis

instance.XAxis = value

value = instance.XAxis
public Axis XAxis {get; set;}
Remarks
When the axis is specified, series plotted on this area will automatically use this x axis, unless otherwise specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > ChartArea Class : YAxis Property
YAxis Property (ChartArea)
Gets or sets the Y axis of this chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YAxis As Axis
'Usage

Dim instance As ChartArea
Dim value As Axis

instance.YAxis = value

value = instance.YAxis
public Axis YAxis {get; set;}
Remarks
When the axis is specified, series plotted on this area will automatically use this y axis, unless otherwise specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ChartAreaCollection Class
ChartAreaCollection Class
Contains a collection of ChartArea objects.
Object Model
ChartAreaCollection ClassChartArea Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ChartAreaCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ChartAreaCollection
public class ChartAreaCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ChartAreaCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ChartAreaCollection Class
ChartAreaCollection Class Members

The following tables list the members exposed by ChartAreaCollection.

Public Constructors
 | Name | Description
Public Constructor | ChartAreaCollection Constructor | Creates a new instance of ChartAreaCollection with the specified list of ChartArea objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ChartAreaCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified ChartArea.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified ChartArea in this collection.
Public Method | Insert | Inserts a ChartArea into this collection at a specified index.
Public Method | Remove | Removes a specified ChartArea from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartAreaCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > ChartAreaCollection Class : ChartAreaCollection Constructor
ChartAreaCollection Constructor
Creates a new instance of ChartAreaCollection with the specified list of ChartArea objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray chartAreaList() As ChartArea _
)
'Usage

Dim chartAreaList() As ChartArea

Dim instance As New ChartAreaCollection(chartAreaList)
public ChartAreaCollection(
   params ChartArea[] chartAreaList
)

Parameters

chartAreaList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ChartAreaCollection Class
ChartAreaCollection Class Methods

For a list of all members of this type, see ChartAreaCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ChartAreaCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified ChartArea.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified ChartArea in this collection.
Public Method | Insert | Inserts a ChartArea into this collection at a specified index.
Public Method | Remove | Removes a specified ChartArea from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ChartAreaCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ChartAreaCollection Class : Add Method
Add Method (ChartAreaCollection)
Adds a specified ChartAreaCollection to this collection.
Overload List
Overload | Description
Add(ChartArea) |
Add(ChartAreaCollection) | Adds a specified ChartAreaCollection to this collection.
Add(ChartArea[]) | Adds the specified ChartArea objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


dotnetCHARTING Namespace > ChartAreaCollection Class > Add Method : Add(ChartArea) Method
Add(ChartArea) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal chartArea As ChartArea _
) As Integer
'Usage

Dim instance As ChartAreaCollection
Dim chartArea As ChartArea
Dim value As Integer

value = instance.Add(chartArea)
public int Add(
   ChartArea chartArea
)

Parameters

chartArea
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members
Overload List


dotnetCHARTING Namespace > ChartAreaCollection Class > Add Method : Add(ChartAreaCollection) Method
The ChartAreaCollection to add.
Add(ChartAreaCollection) Method
Adds a specified ChartAreaCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal chartAreaCollection As ChartAreaCollection _
)
'Usage

Dim instance As ChartAreaCollection
Dim chartAreaCollection As ChartAreaCollection

instance.Add(chartAreaCollection)
public void Add(
   ChartAreaCollection chartAreaCollection
)

Parameters

chartAreaCollection
The ChartAreaCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members
Overload List


dotnetCHARTING Namespace > ChartAreaCollection Class > Add Method : Add(ChartArea[]) Method
A list of ChartArea objects to add.
Add(ChartArea[]) Method
Adds the specified ChartArea objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray chartAreaList() As ChartArea _
)
'Usage

Dim instance As ChartAreaCollection
Dim chartAreaList() As ChartArea

instance.Add(chartAreaList)
public void Add(
   params ChartArea[] chartAreaList
)

Parameters

chartAreaList
A list of ChartArea objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members
Overload List


dotnetCHARTING Namespace > ChartAreaCollection Class : Contains Method
The ChartArea to find.
Contains Method (ChartAreaCollection)
Determines whether this collection contains a specified ChartArea.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal chartArea As ChartArea _
) As Boolean
'Usage

Dim instance As ChartAreaCollection
Dim chartArea As ChartArea
Dim value As Boolean

value = instance.Contains(chartArea)
public bool Contains(
   ChartArea chartArea
)

Parameters

chartArea
The ChartArea to find.

Return Value

true if the specified ChartArea belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


dotnetCHARTING Namespace > ChartAreaCollection Class : IndexOf Method
The ChartArea to find.
IndexOf Method (ChartAreaCollection)
Determines the index of a specified ChartArea in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal chartArea As ChartArea _
) As Integer
'Usage

Dim instance As ChartAreaCollection
Dim chartArea As ChartArea
Dim value As Integer

value = instance.IndexOf(chartArea)
public int IndexOf(
   ChartArea chartArea
)

Parameters

chartArea
The ChartArea to find.

Return Value

The zero-based index of the specified ChartArea.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


dotnetCHARTING Namespace > ChartAreaCollection Class : Insert Method
The zero-based index into the collection at which to insert the ChartArea.
The ChartArea to insert into this collection.
Insert Method (ChartAreaCollection)
Inserts a ChartArea into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal chartArea As ChartArea _
)
'Usage

Dim instance As ChartAreaCollection
Dim index As Integer
Dim chartArea As ChartArea

instance.Insert(index, chartArea)
public void Insert(
   int index,
   ChartArea chartArea
)

Parameters

index
The zero-based index into the collection at which to insert the ChartArea.
chartArea
The ChartArea to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


dotnetCHARTING Namespace > ChartAreaCollection Class : Remove Method
The ChartArea to remove.
Remove Method (ChartAreaCollection)
Removes a specified ChartArea from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal chartArea As ChartArea _
)
'Usage

Dim instance As ChartAreaCollection
Dim chartArea As ChartArea

instance.Remove(chartArea)
public void Remove(
   ChartArea chartArea
)

Parameters

chartArea
The ChartArea to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ChartAreaCollection Class
ChartAreaCollection Class Properties

For a list of all members of this type, see ChartAreaCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

ChartAreaCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ChartAreaCollection Class : Item Property
Item Property (ChartAreaCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ChartArea
'Usage

Dim instance As ChartAreaCollection
Dim index As Integer
Dim value As ChartArea

instance.Item(index) = value

value = instance.Item(index)
public ChartArea this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaCollection Class
ChartAreaCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ChartAreaLayout Class
ChartAreaLayout Class
Encapsulates a set of options that control the layout of multiple chart areas in a single chart image.
Object Model
ChartAreaLayout Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ChartAreaLayout
'Usage

Dim instance As ChartAreaLayout
public class ChartAreaLayout
Example
ChartAreaCustomLayout
ChartAreaRelationships
CloseChartAreas
Inheritance Hierarchy

System.Object
dotnetCHARTING.ChartAreaLayout

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaLayout Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : ChartAreaLayout Class
ChartAreaLayout Class Members

The following tables list the members exposed by ChartAreaLayout.

Public Properties
 | Name | Description
Public Property | AlignUnrelatedAxis | Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.
Public Property | Mode | Gets or sets the a ChartAreaLayoutMode.
Top
See Also

Reference

ChartAreaLayout Class
dotnetCHARTING Namespace


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ChartAreaLayout Class
ChartAreaLayout Class Properties

For a list of all members of this type, see ChartAreaLayout members.

Public Properties
 | Name | Description
Public Property | AlignUnrelatedAxis | Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.
Public Property | Mode | Gets or sets the a ChartAreaLayoutMode.
Top
See Also

Reference

ChartAreaLayout Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ChartAreaLayout Class : AlignUnrelatedAxis Property
AlignUnrelatedAxis Property
Gets or sets a value that indicates whether chart areas oriented opposite to the grid layout mode's priority orientation can be placed next to chart areas that don't share any axes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AlignUnrelatedAxis As Boolean
'Usage

Dim instance As ChartAreaLayout
Dim value As Boolean

instance.AlignUnrelatedAxis = value

value = instance.AlignUnrelatedAxis
public bool AlignUnrelatedAxis {get; set;}
Remarks
This setting applies only to modes VerticalPriority and HorizontalPriority.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaLayout Class
ChartAreaLayout Members


dotnetCHARTING Namespace > ChartAreaLayout Class : Mode Property
Mode Property (ChartAreaLayout)
Gets or sets the a ChartAreaLayoutMode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As ChartAreaLayoutMode
'Usage

Dim instance As ChartAreaLayout
Dim value As ChartAreaLayoutMode

instance.Mode = value

value = instance.Mode
public ChartAreaLayoutMode Mode {get; set;}
Example
ChartAreaRelationships
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartAreaLayout Class
ChartAreaLayout Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : DataEngine Class
DataEngine Class
Acquires and manipulates data from databases or other sources, then creates a SeriesCollection which is consumed by the chart control.
Object Model
DataEngine ClassChart ClassParameterCollection ClassParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataEngine
'Usage

Dim instance As DataEngine
public class DataEngine
Example
DataEngine
QuickDBChart
PostDataProcessing
Inheritance Hierarchy

System.Object
dotnetCHARTING.DataEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : DataEngine Class
DataEngine Class Members

The following tables list the members exposed by DataEngine.

Public Constructors
 | Name | Description
Public Constructor | DataEngine Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | ChartObject | Sets the Chart object.
Public Property | ChartType | Gets or sets the ChartType enumeration that sets the default DataFields for each type.
Public Property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property | ConnectionString | Gets or sets the string used to open a SQL Server, Access, or Excel database.
Public Property | CultureName | Gets or sets the culture name used when element names are populated with values such as dates.
Public Property | Data | Gets or sets a DataTable, DataSet, DataView, XML file name, Xml string or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property | DataFields | Gets or sets a value that specifies the 'database column' to 'element value' relationship.
Public Property | DataGrid | Gets or sets the control object of a DataGrid or GridView control that will be populated with the charted data.
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Public Property | DataGridFormatString | Gets or sets the format string which determines number formatting in the datagrid.
Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property | DataProviderType | Specifies a database type. Defaults to Sqlite database.
Public Property | DateGrouping | Gets or sets the date grouping of data returned from your database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | EndDate | Gets or sets the ending date used with SqlStatement to query filtered data from a database.
Public Property | ErrorMessage | Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().
Public Property | FormatString | Gets or sets the format string used when element names are populated with values such as dates.
Public Property | Limit | Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.
Public Property | LimitMode | Determine the type of limitation. Default is Top.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | OtherElementLabel | Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property | ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | ShowOther | Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.
Public Property | SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property | SqlStatement | The SQL statement used to obtain the charting data.
Public Property | StartDate | Gets or sets the starting date used with SqlStatement to query filtered data from a database.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.
Public Property | StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property | SubValueDateGrouping | Gets or sets the date grouping for the element subvalue.
Top
Public Methods
 | Name | Description
Public Method | AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
static (Shared in Visual Basic) | ConvertCSVtoDataTable |
static (Shared in Visual Basic) | ConvertExcelToDataTable |
Public Method | GetFinancialSeries | See GetSeries(Object,String).
static (Shared in Visual Basic) | GetSeries | Overloaded. Gets a SeriesCollection based on a data object and mapped DataFields.
Top
See Also

Reference

DataEngine Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class : DataEngine Constructor
DataEngine Constructor
Overload List
Overload | Description
DataEngine Constructor() | Initializes a new instance of the DataEngine class.
DataEngine Constructor(Object) | Initializes a new instance of the DataEngine class with a data object.
DataEngine Constructor(Object,String) | Initializes a new instance of the DataEngine class with a data object and mapped DataFields.
DataEngine Constructor(String) | Initializes a new instance of the DataEngine class with a connection string.
DataEngine Constructor(String,String) | Initializes a new instance of the DataEngine class with a ConnectionString and SqlStatement.
DataEngine Constructor(String,String,String) | Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DataFields.
DataEngine Constructor(String,String,TimeInterval) | Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DateGrouping.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor()
DataEngine Constructor()
Initializes a new instance of the DataEngine class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New DataEngine()
public DataEngine()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(Object)
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or xml string)

DataEngine Constructor(Object)
Initializes a new instance of the DataEngine class with a data object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dataObj As Object _
)
'Usage

Dim dataObj As Object

Dim instance As New DataEngine(dataObj)
public DataEngine(
   object dataObj
)

Parameters

dataObj
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or xml string)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(Object,String)
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or xml string)

See Gettings Started > Tutorials > Data Fields
DataEngine Constructor(Object,String)
Initializes a new instance of the DataEngine class with a data object and mapped DataFields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dataObj As Object, _
   ByVal dataFields As String _
)
'Usage

Dim dataObj As Object
Dim dataFields As String

Dim instance As New DataEngine(dataObj, dataFields)
public DataEngine(
   object dataObj,
   string dataFields
)

Parameters

dataObj
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or xml string)

dataFields
See Gettings Started > Tutorials > Data Fields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(String)
Initial connection string.
DataEngine Constructor(String)
Initializes a new instance of the DataEngine class with a connection string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal conn As String _
)
'Usage

Dim conn As String

Dim instance As New DataEngine(conn)
public DataEngine(
   string conn
)

Parameters

conn
Initial connection string.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(String,String)
DataEngine Constructor(String,String)
Initializes a new instance of the DataEngine class with a ConnectionString and SqlStatement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String _
)
'Usage

Dim conn As String
Dim sqlStatement As String

Dim instance As New DataEngine(conn, sqlStatement)
public DataEngine(
   string conn,
   string sqlStatement
)

Parameters

conn
sqlStatement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(String,String,String)
Connection String
Sql statement
Data fields
DataEngine Constructor(String,String,String)
Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DataFields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String, _
   ByVal dataFields As String _
)
'Usage

Dim conn As String
Dim sqlStatement As String
Dim dataFields As String

Dim instance As New DataEngine(conn, sqlStatement, dataFields)
public DataEngine(
   string conn,
   string sqlStatement,
   string dataFields
)

Parameters

conn
Connection String
sqlStatement
Sql statement
dataFields
Data fields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > DataEngine Class > DataEngine Constructor : DataEngine Constructor(String,String,TimeInterval)
Connection String
Sql statement
DateGrouping
DataEngine Constructor(String,String,TimeInterval)
Initializes a new instance of the DataEngine class with a ConnectionString, SqlStatement, and DateGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal conn As String, _
   ByVal sqlStatement As String, _
   ByVal dateGrouping As TimeInterval _
)
'Usage

Dim conn As String
Dim sqlStatement As String
Dim dateGrouping As TimeInterval

Dim instance As New DataEngine(conn, sqlStatement, dateGrouping)
public DataEngine(
   string conn,
   string sqlStatement,
   TimeInterval dateGrouping
)

Parameters

conn
Connection String
sqlStatement
Sql statement
dateGrouping
DateGrouping
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : DataEngine Class
DataEngine Class Methods

For a list of all members of this type, see DataEngine members.

Public Methods
 | Name | Description
Public Method | AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
static (Shared in Visual Basic) | ConvertCSVtoDataTable |
static (Shared in Visual Basic) | ConvertExcelToDataTable |
Public Method | GetFinancialSeries | See GetSeries(Object,String).
static (Shared in Visual Basic) | GetSeries | Overloaded. Gets a SeriesCollection based on a data object and mapped DataFields.
Top
See Also

Reference

DataEngine Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > DataEngine Class : AddParameter(String,String,FieldType) Method
String specifying the parameter name.
String pecifying the parameter value.
A FieldType enumeration specifying the parameter type.
AddParameter(String,String,FieldType) Method
Adds a stored procedure when to use in conjunction with StoredProcedure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddParameter( _
   ByVal paramName As String, _
   ByVal paramValue As String, _
   ByVal paramType As FieldType _
)
'Usage

Dim instance As DataEngine
Dim paramName As String
Dim paramValue As String
Dim paramType As FieldType

instance.AddParameter(paramName, paramValue, paramType)
public void AddParameter(
   string paramName,
   string paramValue,
   FieldType paramType
)

Parameters

paramName
String specifying the parameter name.
paramValue
String pecifying the parameter value.
paramType
A FieldType enumeration specifying the parameter type.
Remarks
This method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored proc. A number of field types are supported. de.AddParameter("MyParameter","MyValue",FieldType.Text)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : ConvertCSVtoDataTable Method
ConvertCSVtoDataTable Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ConvertCSVtoDataTable( _
   ByVal strFilePath As String _
) As DataTable
'Usage

Dim strFilePath As String
Dim value As DataTable

value = DataEngine.ConvertCSVtoDataTable(strFilePath)
public static DataTable ConvertCSVtoDataTable(
   string strFilePath
)

Parameters

strFilePath
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : ConvertExcelToDataTable Method
ConvertExcelToDataTable Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function ConvertExcelToDataTable( _
   ByVal strFilePath As String, _
   ByVal table As String _
) As DataTable
'Usage

Dim strFilePath As String
Dim table As String
Dim value As DataTable

value = DataEngine.ConvertExcelToDataTable(strFilePath, table)
public static DataTable ConvertExcelToDataTable(
   string strFilePath,
   string table
)

Parameters

strFilePath
table
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : GetFinancialSeries Method
GetFinancialSeries Method
See GetSeries(Object,String).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetFinancialSeries() As SeriesCollection
'Usage

Dim instance As DataEngine
Dim value As SeriesCollection

value = instance.GetFinancialSeries()
public SeriesCollection GetFinancialSeries()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : GetSeries Method
GetSeries Method (DataEngine)
Gets a SeriesCollection based on a data object and mapped DataFields.
Overload List
Overload | Description
GetSeries(Object,String) | Gets a SeriesCollection based on a data object and mapped DataFields.
GetSeries(String,String) | Gets a SeriesCollection based on a connection string and SQL query statement.
GetSeries(String,String,String) | Gets a SeriesCollection based on a connection string and SQL query statement and mapped DataFields.
GetSeries(String,String,TimeInterval) | Gets a SeriesCollection based on a connection string, SQL query statement, and DateGrouping.
GetSeries(Object) | Initiates data acquisition and processing based on the specified data object.
GetSeries() | Initiates data acquisition and processing based on the specified data engine settings.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries(Object,String) Method
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or Xml string)

Mapped DataFields
GetSeries(Object,String) Method
Gets a SeriesCollection based on a data object and mapped DataFields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GetSeries( _
   ByVal dataObject As Object, _
   ByVal dataFields As String _
) As SeriesCollection
'Usage

Dim dataObject As Object
Dim dataFields As String
Dim value As SeriesCollection

value = DataEngine.GetSeries(dataObject, dataFields)
public static SeriesCollection GetSeries(
   object dataObject,
   string dataFields
)

Parameters

dataObject
Supported Data Objects

DataSet

DataTable

DataView

String (xml file name or Xml string)

dataFields
Mapped DataFields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries(String,String) Method
The connection string or path and file name of an mdb database.
The SQL statement.
GetSeries(String,String) Method
Gets a SeriesCollection based on a connection string and SQL query statement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GetSeries( _
   ByVal connectionString As String, _
   ByVal sqlStatement As String _
) As SeriesCollection
'Usage

Dim connectionString As String
Dim sqlStatement As String
Dim value As SeriesCollection

value = DataEngine.GetSeries(connectionString, sqlStatement)
public static SeriesCollection GetSeries(
   string connectionString,
   string sqlStatement
)

Parameters

connectionString
The connection string or path and file name of an mdb database.
sqlStatement
The SQL statement.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries(String,String,String) Method
The connection string or path and file name of an mdb database.
The SQL statement.
Mapped DataFields. See Gettings Started > Tutorials > Data Fields
GetSeries(String,String,String) Method
Gets a SeriesCollection based on a connection string and SQL query statement and mapped DataFields.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GetSeries( _
   ByVal connectionString As String, _
   ByVal sqlStatement As String, _
   ByVal dataFields As String _
) As SeriesCollection
'Usage

Dim connectionString As String
Dim sqlStatement As String
Dim dataFields As String
Dim value As SeriesCollection

value = DataEngine.GetSeries(connectionString, sqlStatement, dataFields)
public static SeriesCollection GetSeries(
   string connectionString,
   string sqlStatement,
   string dataFields
)

Parameters

connectionString
The connection string or path and file name of an mdb database.
sqlStatement
The SQL statement.
dataFields
Mapped DataFields. See Gettings Started > Tutorials > Data Fields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries(String,String,TimeInterval) Method
The connection string or path and file name of an mdb database.
The SQL statement.
Mapped DataFields. See Gettings Started > Tutorials > Data Fields
GetSeries(String,String,TimeInterval) Method
Gets a SeriesCollection based on a connection string, SQL query statement, and DateGrouping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GetSeries( _
   ByVal connectionString As String, _
   ByVal sqlStatement As String, _
   ByVal dateGrouping As TimeInterval _
) As SeriesCollection
'Usage

Dim connectionString As String
Dim sqlStatement As String
Dim dateGrouping As TimeInterval
Dim value As SeriesCollection

value = DataEngine.GetSeries(connectionString, sqlStatement, dateGrouping)
public static SeriesCollection GetSeries(
   string connectionString,
   string sqlStatement,
   TimeInterval dateGrouping
)

Parameters

connectionString
The connection string or path and file name of an mdb database.
sqlStatement
The SQL statement.
dateGrouping
Mapped DataFields. See Gettings Started > Tutorials > Data Fields
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries(Object) Method
A data object.
GetSeries(Object) Method
Initiates data acquisition and processing based on the specified data object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSeries( _
   ByVal dataObj As Object _
) As SeriesCollection
'Usage

Dim instance As DataEngine
Dim dataObj As Object
Dim value As SeriesCollection

value = instance.GetSeries(dataObj)
public SeriesCollection GetSeries(
   object dataObj
)

Parameters

dataObj
A data object.

Return Value

A SeriesCollection containting the resulting chart data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


dotnetCHARTING Namespace > DataEngine Class > GetSeries Method : GetSeries() Method
GetSeries() Method
Initiates data acquisition and processing based on the specified data engine settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSeries() As SeriesCollection
'Usage

Dim instance As DataEngine
Dim value As SeriesCollection

value = instance.GetSeries()
public SeriesCollection GetSeries()

Return Value

A SeriesCollection containting the resulting chart data.
Remarks
When ChartType is set to Financial and DateGrouping is specified, high, low, open, and close element values will be calculated based on the price field. Otherwise they will not be generated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : DataEngine Class
DataEngine Class Properties

For a list of all members of this type, see DataEngine members.

Public Properties
 | Name | Description
Public Property | ChartObject | Sets the Chart object.
Public Property | ChartType | Gets or sets the ChartType enumeration that sets the default DataFields for each type.
Public Property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property | ConnectionString | Gets or sets the string used to open a SQL Server, Access, or Excel database.
Public Property | CultureName | Gets or sets the culture name used when element names are populated with values such as dates.
Public Property | Data | Gets or sets a DataTable, DataSet, DataView, XML file name, Xml string or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Public Property | DataFields | Gets or sets a value that specifies the 'database column' to 'element value' relationship.
Public Property | DataGrid | Gets or sets the control object of a DataGrid or GridView control that will be populated with the charted data.
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Public Property | DataGridFormatString | Gets or sets the format string which determines number formatting in the datagrid.
Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Public Property | DataProviderType | Specifies a database type. Defaults to Sqlite database.
Public Property | DateGrouping | Gets or sets the date grouping of data returned from your database.
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value.
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Public Property | EndDate | Gets or sets the ending date used with SqlStatement to query filtered data from a database.
Public Property | ErrorMessage | Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().
Public Property | FormatString | Gets or sets the format string used when element names are populated with values such as dates.
Public Property | Limit | Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.
Public Property | LimitMode | Determine the type of limitation. Default is Top.
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Public Property | OtherElementLabel | Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property | ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Public Property | ShowOther | Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.
Public Property | SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property | SqlStatement | The SQL statement used to obtain the charting data.
Public Property | StartDate | Gets or sets the starting date used with SqlStatement to query filtered data from a database.
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.
Public Property | StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property | SubValueDateGrouping | Gets or sets the date grouping for the element subvalue.
Top
See Also

Reference

DataEngine Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > DataEngine Class : ChartObject Property
ChartObject Property
Sets the Chart object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property ChartObject As Chart
'Usage

Dim instance As DataEngine

instance.ChartObject = value
public Chart ChartObject {set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : ChartType Property
ChartType Property
Gets or sets the ChartType enumeration that sets the default DataFields for each type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartType As ChartType
'Usage

Dim instance As DataEngine
Dim value As ChartType

instance.ChartType = value

value = instance.ChartType
public ChartType ChartType {get; set;}
Remarks
See Getting Started > Tutorials > DataFields for more info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : CommandTimeout Property
CommandTimeout Property (DataEngine)
Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandTimeout As Integer
'Usage

Dim instance As DataEngine
Dim value As Integer

instance.CommandTimeout = value

value = instance.CommandTimeout
public int CommandTimeout {get; set;}
Remarks
The time (in seconds) to wait for the command to execute. The default value is 30 seconds.
Example
The follwoing example set the command timeout to 45 seconds.
  • C#
de.CommandTimeout=45;
  • Visual Basic
de.CommandTimeout=45
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : ConnectionString Property
ConnectionString Property (DataEngine)
Gets or sets the string used to open a SQL Server, Access, or Excel database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.ConnectionString = value

value = instance.ConnectionString
public string ConnectionString {get; set;}
Remarks
Access, Excel and SQL server are supported and automatically detected based on the connection string specified.
See Getting Started > Tutorials > Connecting to data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : CultureName Property
CultureName Property (DataEngine)
Gets or sets the culture name used when element names are populated with values such as dates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CultureName As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.CultureName = value

value = instance.CultureName
public string CultureName {get; set;}
Remarks
See the CultureInfo class for possible names of a culture.
Example
  • C#
Chart.CultureName = "en-GB";
  • Visual Basic
Chart.CultureName = "en-GB"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : Data Property
Data Property (DataEngine)
Gets or sets a DataTable, DataSet, DataView, XML file name, Xml string or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As Object
'Usage

Dim instance As DataEngine
Dim value As Object

instance.Data = value

value = instance.Data
public object Data {get; set;}
Remarks
When not connecting to a database directly using ConnectionString and SqlStatement, this property offers an alternative method for obtaining database data.
Example
This example sets the data property to a dataTable and defines data fields mapping.
  • C#
DataEngine de = new DataEngine();
de.Data = myDataTable;
de.DataFields = "XAxis=FirstCol,YAxis=SecondCol";
Chart.SeriesCollection.Add(de.GetSeries());
  • Visual Basic
Dim de As New DataEngine()
de.Data = myDataTable
de.DataFields = "XAxis=FirstCol,YAxis=SecondCol"
Chart.SeriesCollection.Add(de.GetSeries())
Example
DataSet
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : DatabaseCultureName Property
DatabaseCultureName Property (DataEngine)
Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DatabaseCultureName As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.DatabaseCultureName = value

value = instance.DatabaseCultureName
public string DatabaseCultureName {get; set;}
Remarks
See the CultureInfo class for possible names of a culture.
Example
  • C#
de.DataBaseCultureName = "en-GB";
  • Visual Basic
de.DataBaseCultureName = "en-GB"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : DataFields Property
DataFields Property (DataEngine)
Gets or sets a value that specifies the 'database column' to 'element value' relationship.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property DataFields As String
'Usage

Dim instance As DataEngine

instance.DataFields = value
public string DataFields {set;}
Remarks
See Getting Started > Tutorials > Data Fields for more info.
Example
  • C#
de.DataFields="xAxis=field1,yAxis=field2,splitby=field3,bubblesize=field4";
  • Visual Basic
de.DataFields="xAxis=field1,yAxis=field2,splitby=field3,bubblesize=field4"
Example
MultiSeriesFromColumns
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DataGrid Property
DataGrid Property (DataEngine)
Gets or sets the control object of a DataGrid or GridView control that will be populated with the charted data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGrid As Object
'Usage

Dim instance As DataEngine
Dim value As Object

instance.DataGrid = value

value = instance.DataGrid
public object DataGrid {get; set;}
Remarks
This property accepts a DataGrid or GridView control object. If set, the data represented in the chart is populated in the DataGrid or GridView of the same name. You must also define a DataGrid or GridView control within the same script. This property is useful when displaying tabular chart data along with your charts.
Example
DataGrid
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : DataGridCustomAttributes Property
DataGridCustomAttributes Property (DataEngine)
Adds element's custom attributes to the DataGrid control specified by the DataGrid property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property DataGridCustomAttributes As String
'Usage

Dim instance As DataEngine

instance.DataGridCustomAttributes = value
public string DataGridCustomAttributes {set;}
Remarks
For complete code see DataGridCustomAttributes.aspx or GridviewCustomAttributes.aspx sample
Example
  • C#
Chart.DataGridCustomAttributes = "Employee No=EmployeeID|Department=Department|Email=email|Phone=PhoneNumber";
  • Visual Basic
Chart.DataGridCustomAttributes = "Employee No=EmployeeID|Department=Department|Email=email|Phone=PhoneNumber"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DataGridFormatString Property
DataGridFormatString Property (DataEngine)
Gets or sets the format string which determines number formatting in the datagrid.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridFormatString As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.DataGridFormatString = value

value = instance.DataGridFormatString
public string DataGridFormatString {get; set;}
Remarks
See 'Formatting Types' in your msdn documentation for a complete list of options.

Some shortcuts are also provided for specific settings including "C" or "currency" , "E" or "scientific" , "F" or "fixed" , "G" or "general" and "N,2" for normal and the number after the comma determines the number of decimal places.
Example
DataGridDataEngine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DataGridSeriesHeader Property
DataGridSeriesHeader Property (DataEngine)
Gets or sets the header label of the DataGrid control specified by the DataGrid property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridSeriesHeader As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.DataGridSeriesHeader = value

value = instance.DataGridSeriesHeader
public string DataGridSeriesHeader {get; set;}
Remarks
This property controls the header label used for the datagrid series name column. If set to "none" the series name column will be removed. If set to "%XAxisLabel", xAxis label set as the header label of the datagrid.
Example
DataGridDataEngine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DataGridTranspose Property
DataGridTranspose Property (DataEngine)
Gets or sets a value indicating whether the data with which the specified DataGrid control is populated will be transposed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGridTranspose As Boolean
'Usage

Dim instance As DataEngine
Dim value As Boolean

instance.DataGridTranspose = value

value = instance.DataGridTranspose
public bool DataGridTranspose {get; set;}
Example
DataGridDataEngine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DataProviderType Property
DataProviderType Property (DataEngine)
Specifies a database type. Defaults to Sqlite database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataProviderType As DataProviderType
'Usage

Dim instance As DataEngine
Dim value As DataProviderType

instance.DataProviderType = value

value = instance.DataProviderType
public DataProviderType DataProviderType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DateGrouping Property
DateGrouping Property (DataEngine)
Gets or sets the date grouping of data returned from your database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGrouping As TimeInterval
'Usage

Dim instance As DataEngine
Dim value As TimeInterval

instance.DateGrouping = value

value = instance.DateGrouping
public TimeInterval DateGrouping {get; set;}
Remarks
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.

See Getting Started > Tutorials > Data Engine
Example
Day
Days
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DateGroupingCalculation Property
DateGroupingCalculation Property (DataEngine)
Gets or sets an enum which determines how values are grouped to create a single element value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingCalculation As Calculation
'Usage

Dim instance As DataEngine
Dim value As Calculation

instance.DateGroupingCalculation = value

value = instance.DateGroupingCalculation
public Calculation DateGroupingCalculation {get; set;}
Remarks
When dategrouping is used, if an element has more than one value, a Calculation is performed on those values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
DateGrouping Property


dotnetCHARTING Namespace > DataEngine Class : DateGroupingSort Property
DateGroupingSort Property (DataEngine)
Gets or sets a value indicating whether to maintain the sort order of the data as it is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DateGroupingSort As Boolean
'Usage

Dim instance As DataEngine
Dim value As Boolean

instance.DateGroupingSort = value

value = instance.DateGroupingSort
public bool DateGroupingSort {get; set;}
Remarks
When dategrouping is used and StartDate or EndDate is not set, the data is sorted by the xAxis field by default. Setting this property to true will maintain the sort order of the data as it is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : DrillDownIntoSeries Property
DrillDownIntoSeries Property (DataEngine)
When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrillDownIntoSeries As Boolean
'Usage

Dim instance As DataEngine
Dim value As Boolean

instance.DrillDownIntoSeries = value

value = instance.DrillDownIntoSeries
public bool DrillDownIntoSeries {get; set;}
Example
drilldownmultiseries2
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : EndDate Property
EndDate Property (DataEngine)
Gets or sets the ending date used with SqlStatement to query filtered data from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndDate As Date
'Usage

Dim instance As DataEngine
Dim value As Date

instance.EndDate = value

value = instance.EndDate
public DateTime EndDate {get; set;}
Remarks
This property is used for the SqlStatement property where the #EndDate# token is replaced with the value set to this property.

See: Getting Started > Tutorials > Data Engine
Example
  • C#
de.EndDate = new DateTime(2004,12,30);
  • Visual Basic
de.EndDate = new DateTime(2004,12,30)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
SqlStatement


dotnetCHARTING Namespace > DataEngine Class : ErrorMessage Property
ErrorMessage Property
Gets an error message which will be available if this DataEngine instance fails after a call to GetSeries().
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ErrorMessage As String
'Usage

Dim instance As DataEngine
Dim value As String

value = instance.ErrorMessage
public string ErrorMessage {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : FormatString Property
FormatString Property (DataEngine)
Gets or sets the format string used when element names are populated with values such as dates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FormatString As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.FormatString = value

value = instance.FormatString
public string FormatString {get; set;}
Remarks

This property usually used with conjunction of date grouping. If it doesn't set, use an appropriate format for the date grouping. For format information see DateTimeFormatInfo or NumberFormatInfo

Example
The following example shows the tick labels in xAxis as full month name.
  • C#
de.FormatString ="MMMM";
  • Visual Basic
de.FormatString ="MMMM"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : Limit Property
Limit Property (DataEngine)
Gets or sets the limit number of elements returned for each series when data is generated. Gets or sets the limit number of elements returned for each series when data is generated. This property determines the number of elements to include in the limited return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group position and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Limit As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.Limit = value

value = instance.Limit
public string Limit {get; set;}
Remarks

If DateGrouping is used, limit has no effect. In such a case, StartDate and EndDate must be used to limit the generated element count.

See Getting Started > Tutorials > Data Engine.

Example
  • C#
de.Limit="3";
de.Limit="2x3";
  • Visual Basic
de.Limit="3"
de.Limit="2x3"
Example
Limit
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
LimitMode Property


Example

dotnetCHARTING Namespace > DataEngine Class : LimitMode Property
LimitMode Property (DataEngine)
Determine the type of limitation. Default is Top.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LimitMode As LimitMode
'Usage

Dim instance As DataEngine
Dim value As LimitMode

instance.LimitMode = value

value = instance.LimitMode
public LimitMode LimitMode {get; set;}
Remarks
This property works in conjunction with Limit or SplitByLimit to determine which elements or series should be included or excluded.
Example
  • C#
de.LimitMode =<see cref="LimitMode">LimitMode</see>.Bottom;
  • Visual Basic
de.LimitMode =<see cref="LimitMode">LimitMode</see>.Bottom
Example
PagingSeries
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
Limit Property


dotnetCHARTING Namespace > DataEngine Class : LimitPrimarySeries Property
LimitPrimarySeries Property (DataEngine)
In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LimitPrimarySeries As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.LimitPrimarySeries = value

value = instance.LimitPrimarySeries
public string LimitPrimarySeries {get; set;}
Example
LimitPrimarySeries
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : OtherElementLabel Property
OtherElementLabel Property
Gets or sets the label used for the element or series created when using Limit or SplitByLimit and setting ShowOther to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OtherElementLabel As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.OtherElementLabel = value

value = instance.OtherElementLabel
public string OtherElementLabel {get; set;}
Remarks
See Getting Started > Tutorials > Data Engine for more info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : ParameterCollection Property
ParameterCollection Property (DataEngine)
Gets or sets a collection of Parameter objects used in conjunction with the StoredProcedure property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ParameterCollection As ParameterCollection
'Usage

Dim instance As DataEngine
Dim value As ParameterCollection

instance.ParameterCollection = value

value = instance.ParameterCollection
public ParameterCollection ParameterCollection {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property
AddParameter(String,String,FieldType) Method
StoredProcedure Property


dotnetCHARTING Namespace > DataEngine Class : PopulateDateGroupingSubValues Property
PopulateDateGroupingSubValues Property (DataEngine)
When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PopulateDateGroupingSubValues As Boolean
'Usage

Dim instance As DataEngine
Dim value As Boolean

instance.PopulateDateGroupingSubValues = value

value = instance.PopulateDateGroupingSubValues
public bool PopulateDateGroupingSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : ShowOther Property
ShowOther Property (DataEngine)
Gets or sets a value that indicates whether the additional series not shown due to the use of SplitByLimit, or elements not shown due to the use of Limit, are aggregated into a single series or element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowOther As Boolean
'Usage

Dim instance As DataEngine
Dim value As Boolean

instance.ShowOther = value

value = instance.ShowOther
public bool ShowOther {get; set;}
Remarks
See Gettings Started > Tutorials > Data Engine for more info.

The default is false.
Example
  • C#
de.ShowOther=true;
  • Visual Basic
de.ShowOther=true
Example
drilldownOtherElement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : SplitByLimit Property
SplitByLimit Property (DataEngine)
Gets or sets the number of series created using SplitBy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplitByLimit As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.SplitByLimit = value

value = instance.SplitByLimit
public string SplitByLimit {get; set;}
Remarks

This property works with conjunction of LimitMode property and determines the number of series to include in the return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum series.

See Getting Started > Tutorials > Data Engine.

Example
  • C#
de.SplitByLimit="3";
de.SplitByLimit="2x3";
  • Visual Basic
de.SplitByLimit="3";
de.SplitByLimit="2x3";
Example
SplitBy
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
LimitMode Property


Example

dotnetCHARTING Namespace > DataEngine Class : SqlStatement Property
SqlStatement Property (DataEngine)
The SQL statement used to obtain the charting data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SqlStatement As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.SqlStatement = value

value = instance.SqlStatement
public string SqlStatement {get; set;}
Remarks

The first column returned is used for the X values, and the second for the Y values. The first also has special handling if dates are returned as the DateGrouping property can be used for intelligent date handling and grouping. The third column is optional and is used only for SplitBy. When a third column is set it is used automatically to create a unique series based on each unique value in this column.

NOTE: All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used. Also the #StartDate# and #EndDate# tokens can be used in which case the dates set for these properties will be set in place of the tokens before the SqlStatement is executed.

See Getting Started > Tutorials > Queries for more info.

Example
  • C#
de.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders";

//If you are doing a SplitBy you would need another field to correspond to your SplitBy value i.e.
de.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders";
  • Visual Basic
de.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders"

'If you are doing a SplitBy you would need another field To correspond To your SplitBy value i.e.
de.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders"
Example
DataEngine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


Example

dotnetCHARTING Namespace > DataEngine Class : StartDate Property
StartDate Property (DataEngine)
Gets or sets the starting date used with SqlStatement to query filtered data from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDate As Date
'Usage

Dim instance As DataEngine
Dim value As Date

instance.StartDate = value

value = instance.StartDate
public DateTime StartDate {get; set;}
Remarks
This property is used for the SqlStatement property where the #StartDate# token is replaced with the value set to this property.

See: Getting Started > Tutorials > Data Engine
Example
  • C#
de.StartDate = new DateTime(2004,12,10);
  • Visual Basic
de.StartDate = new DateTime(2004,12,10)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
SqlStatement


Example

dotnetCHARTING Namespace > DataEngine Class : StartDateOfYear Property
StartDateOfYear Property (DataEngine)
Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDateOfYear As Date
'Usage

Dim instance As DataEngine
Dim value As Date

instance.StartDateOfYear = value

value = instance.StartDateOfYear
public DateTime StartDateOfYear {get; set;}
Remarks
This property determine the start month of the year. The default is January.
Example
This example change the year duration from Jan-Dec to Mar-Feb. Beside month, other values are ignored.
  • C#
de.StartDateOfYear = new DateTime(2004,3,1);
  • Visual Basic
de.StartDateOfYear = New DateTime(2004, 3, 1)
Example
StartMonthOfYear
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members
DateGrouping Property


Example

dotnetCHARTING Namespace > DataEngine Class : StartDayOfWeek Property
StartDayOfWeek Property (DataEngine)
Gets or sets a System.DayOfWeek enumeration that determines the day which will be used as the starting day of the week for the dategrouping functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDayOfWeek As DayOfWeek
'Usage

Dim instance As DataEngine
Dim value As DayOfWeek

instance.StartDayOfWeek = value

value = instance.StartDayOfWeek
public DayOfWeek StartDayOfWeek {get; set;}
Remarks
This property used with conjunction of date grouping by weeks. The default is Sunday.
Example
  • C#
de.DateGrouping = TimeInterval.Weeks;
de.StartDayOfWeek = DayOfWeek.Monday;
  • Visual Basic
de.DateGrouping = TimeInterval.Weeks
de.StartDayOfWeek = DayOfWeek.Monday
Example
StartDayOfWeek
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : StoredProcedure Property
StoredProcedure Property (DataEngine)
This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StoredProcedure As String
'Usage

Dim instance As DataEngine
Dim value As String

instance.StoredProcedure = value

value = instance.StoredProcedure
public string StoredProcedure {get; set;}
Remarks
Stored Procedures also work with parameters, see the AddParameter(String,String,FieldType) method.
See Getting Started > Tutorials > Connecting to Data for more info.
Example
storedProcedure
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataEngine Class : SubValueDateGrouping Property
SubValueDateGrouping Property (DataEngine)
Gets or sets the date grouping for the element subvalue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SubValueDateGrouping As TimeInterval
'Usage

Dim instance As DataEngine
Dim value As TimeInterval

instance.SubValueDateGrouping = value

value = instance.SubValueDateGrouping
public TimeInterval SubValueDateGrouping {get; set;}
Remarks
Controls how the values of a given element subvalue are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.
Controls how the values of a given series are grouped by date. In order to use this option the first column returned by the SqlStatement must be a date/time. Options include Minutes, Hours, Days, Weeks, Months, Quarters and Years where any StartDate and EndDate can be used and the chart will show all values sequentially. There are additional options for Hour/Minute, Day/Hour, Week/Day, Month/Day, Year/Quarter and Year/Month in these cases there are 2 special considerations 1) only a single day / week / month / or year is charted and 2) if the date range is greater than the period type (e.g. 1 day / 1 week / 1 month / 1 year) values are totalled over that period. There are also shortcuts for the grouping cases of Hour (Hours/Minute), Day (Day/Hour), Week(Week/Day), Month (Month/Day) and Year (Year/Month). See all time interval options. This feature automatically groups multiple data points over a given date range into the specific date grouping you select. When DateGrouping is enabled you must ensure that each series within a given chart returns date/time data for the first column returned by the SqlStatement.

See Getting Started > Tutorials > Data Engine
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : DataSource Class
DataSource Class
Represents a single or related set of .netCHARTING data-based objects that specify a data source used to parse tokens and populate custom legend boxes with LegendEntry objects.
Object Model
DataSource ClassAxis ClassAxisMarker ClassElement ClassScaleRange ClassSeries ClassSeriesCollection ClassSeries Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class DataSource
'Usage

Dim instance As DataSource
public class DataSource
Example
LegendBoxDataSource
DataSourceExpressions
AnnotationDataSource
LegendBoxDataSource
Inheritance Hierarchy

System.Object
dotnetCHARTING.DataSource

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Members
dotnetCHARTING Namespace

Tutorials

Data Sources


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : DataSource Class
DataSource Class Members

The following tables list the members exposed by DataSource.

Public Properties
 | Name | Description
Public Property | Axis | Gets or sets the represented axis.
Public Property | AxisMarker | Gets or sets the represented AxisMarker.
Public Property | Element | Gets or sets the represented element.
Public Property | GroupIndex | Gets or sets the index of series for the element group.
Public Property | ScaleRange | Gets or sets the represented ScaleRange object.
Public Property | Series | Gets or sets the represented or parent series.
Public Property | SeriesCollection | Gets or sets the represented or parent SeriesCollection.
Public Property | SplitInto | Specifies the type of DataSource to split this data source into when it is used to populate a legend box.
Public Property | Type | Gets or sets the DataSourceType of this DataSource.
Top
Public Methods
 | Name | Description
Public Method | EvaluateExpression | Evaluates a string containing tokens that relate to this DataSource. For example, if this DataSource represents a series, the string "%Name" will return the actual name of the series. See the token reference for more information on available tokens.
static (Shared in Visual Basic) | FromAxisMarker | Creates an AxisMarker DataSource object from an AxisMarker object.
static (Shared in Visual Basic) | FromElement | Overloaded. Creates a DataSource object from a SeriesColleciton, Series, and Element.
static (Shared in Visual Basic) | FromElementGroup | Overloaded. Creates a DataSource object from a SeriesColleciton, and Element index.
static (Shared in Visual Basic) | FromScaleRange | Creates a DataSource object from an ScaleRange object.
static (Shared in Visual Basic) | FromSeries | Overloaded. Creates a DataSource object from a SeriesColleciton, and Series.
static (Shared in Visual Basic) | FromSeriesCollection | Overloaded. Creates a DataSource object from a SeriesColleciton.
Top
Public Operators
public Operator Implicit Type Conversion Overloaded. Creates a DataSource from the specified SeriesCollection.
Top
See Also

Reference

DataSource Class
dotnetCHARTING Namespace

Tutorials

Data Sources


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : DataSource Class
DataSource Class Methods

For a list of all members of this type, see DataSource members.

Public Methods
 | Name | Description
Public Method | EvaluateExpression | Evaluates a string containing tokens that relate to this DataSource. For example, if this DataSource represents a series, the string "%Name" will return the actual name of the series. See the token reference for more information on available tokens.
static (Shared in Visual Basic) | FromAxisMarker | Creates an AxisMarker DataSource object from an AxisMarker object.
static (Shared in Visual Basic) | FromElement | Overloaded. Creates a DataSource object from a SeriesColleciton, Series, and Element.
static (Shared in Visual Basic) | FromElementGroup | Overloaded. Creates a DataSource object from a SeriesColleciton, and Element index.
static (Shared in Visual Basic) | FromScaleRange | Creates a DataSource object from an ScaleRange object.
static (Shared in Visual Basic) | FromSeries | Overloaded. Creates a DataSource object from a SeriesColleciton, and Series.
static (Shared in Visual Basic) | FromSeriesCollection | Overloaded. Creates a DataSource object from a SeriesColleciton.
Top
See Also

Reference

DataSource Class
dotnetCHARTING Namespace

Tutorials

Data Sources


dotnetCHARTING Namespace > DataSource Class : EvaluateExpression Method
String with tokens to evaluate.
Chart type used with this DataSource.
When true, the returned string is urlEncoded.
EvaluateExpression Method
Evaluates a string containing tokens that relate to this DataSource. For example, if this DataSource represents a series, the string "%Name" will return the actual name of the series. See the token reference for more information on available tokens.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function EvaluateExpression( _
   ByVal text As String, _
   ByVal cType As ChartType, _
   ByVal urlEncode As Boolean _
) As String
'Usage

Dim instance As DataSource
Dim text As String
Dim cType As ChartType
Dim urlEncode As Boolean
Dim value As String

value = instance.EvaluateExpression(text, cType, urlEncode)
public string EvaluateExpression(
   string text,
   ChartType cType,
   bool urlEncode
)

Parameters

text
String with tokens to evaluate.
cType
Chart type used with this DataSource.
urlEncode
When true, the returned string is urlEncoded.
Remarks
All other string features such as expressions and embedded formatting are supported by this method.
Example
DataSourceExpressions
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : FromAxisMarker Method
Axis containing the axis marker.
FromAxisMarker Method
Creates an AxisMarker DataSource object from an AxisMarker object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromAxisMarker( _
   ByVal sourceAxis As Axis, _
   ByVal sourceMarker As AxisMarker _
) As DataSource
'Usage

Dim sourceAxis As Axis
Dim sourceMarker As AxisMarker
Dim value As DataSource

value = DataSource.FromAxisMarker(sourceAxis, sourceMarker)
public static DataSource FromAxisMarker(
   Axis sourceAxis,
   AxisMarker sourceMarker
)

Parameters

sourceAxis
Axis containing the axis marker.
sourceMarker
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : FromElement Method
FromElement Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Overload List
Overload | Description
FromElement(SeriesCollection,Int32,Int32,DataSourceType) | Creates a DataSource object from a SeriesColleciton, Series, and Element.
FromElement(SeriesCollection,String,String,DataSourceType) | Creates a DataSource object from a SeriesColleciton, Series, and Element.
FromElement(SeriesCollection,Int32,String,DataSourceType) | Creates a DataSource object from a SeriesColleciton, Series, and Element.
FromElement(SeriesCollection,Int32,Int32) | Creates a DataSource object class from a SeriesColleciton, Series, and Element.
FromElement(SeriesCollection,String,String) | Creates a DataSource object from a SeriesColleciton, Series, and Element.
FromElement(SeriesCollection,Int32,String) | Creates a DataSource object from a SeriesColleciton, Series, and Element.
FromElement(Element) | Creates a DataSource object from an element Element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,Int32,Int32,DataSourceType) Method
SeriesCollection containing the series of the given element.
Index of the series that contains the given element.
Index of the element in the specified series.
Split into type when this DataSource is used to populate a legend box.
FromElement(SeriesCollection,Int32,Int32,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim sourceElementIndex As Integer
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesIndex, sourceElementIndex, splitIntoType)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   int sourceElementIndex,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,String,String,DataSourceType) Method
SeriesCollection containing the series of the given element.
Name of the series that contains the given element.
Name of the given element.
Split into type when this DataSource is used to populate a legend box.
FromElement(SeriesCollection,String,String,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal sourceElementName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesName As String
Dim sourceElementName As String
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesName, sourceElementName, splitIntoType)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   string sourceElementName,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,Int32,String,DataSourceType) Method
SeriesCollection containing the series of the given element.
Index of the series that contains the given element.
Name of the given element.
Split into type when this DataSource is used to populate a legend box.
FromElement(SeriesCollection,Int32,String,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim sourceElementName As String
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesIndex, sourceElementName, splitIntoType)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   string sourceElementName,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,Int32,Int32) Method
SeriesCollection containing the series of the given element.
Index of the series that contains the given element.
Index of the element in the specified series.
FromElement(SeriesCollection,Int32,Int32) Method
Creates a DataSource object class from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementIndex As Integer _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim sourceElementIndex As Integer
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesIndex, sourceElementIndex)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   int sourceElementIndex
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementIndex
Index of the element in the specified series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,String,String) Method
SeriesCollection containing the series of the given element.
Name of the series that contains the given element.
Name of the given element.
FromElement(SeriesCollection,String,String) Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal sourceElementName As String _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesName As String
Dim sourceElementName As String
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesName, sourceElementName)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   string sourceElementName
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesName
Name of the series that contains the given element.
sourceElementName
Name of the given element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(SeriesCollection,Int32,String) Method
SeriesCollection containing the series of the given element.
Index of the series that contains the given element.
Name of the given element.
FromElement(SeriesCollection,Int32,String) Method
Creates a DataSource object from a SeriesColleciton, Series, and Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal sourceElementName As String _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim sourceElementName As String
Dim value As DataSource

value = DataSource.FromElement(sourceSeriesCollection, sourceSeriesIndex, sourceElementName)
public static DataSource FromElement(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   string sourceElementName
)

Parameters

sourceSeriesCollection
SeriesCollection containing the series of the given element.
sourceSeriesIndex
Index of the series that contains the given element.
sourceElementName
Name of the given element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElement Method : FromElement(Element) Method
The element.
FromElement(Element) Method
Creates a DataSource object from an element Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElement( _
   ByVal e As Element _
) As DataSource
'Usage

Dim e As Element
Dim value As DataSource

value = DataSource.FromElement(e)
public static DataSource FromElement(
   Element e
)

Parameters

e
The element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class : FromElementGroup Method
FromElementGroup Method
Creates a DataSource object from a SeriesColleciton, and Element index.
Overload List
Overload | Description
FromElementGroup(SeriesCollection,Int32,DataSourceType) | Creates a DataSource object from a SeriesColleciton, and Element index.
FromElementGroup(SeriesCollection,String,DataSourceType) | Creates an Element Group DataSource object from a SeriesColleciton, and Element name.
FromElementGroup(SeriesCollection,Int32) | Creates an Element Group DataSource object from a SeriesColleciton, and Element index.
FromElementGroup(SeriesCollection,String) | Creates an Element Group DataSource object from a SeriesColleciton, and Element name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class > FromElementGroup Method : FromElementGroup(SeriesCollection,Int32,DataSourceType) Method
SeriesCollection containing the given group of elements.
Index of the element in each series that makes up the group.
Name of the given element.
FromElementGroup(SeriesCollection,Int32,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, and Element index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceGroupIndex As Integer
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromElementGroup(sourceSeriesCollection, sourceGroupIndex, splitIntoType)
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   int sourceGroupIndex,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.
splitIntoType
Name of the given element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElementGroup Method : FromElementGroup(SeriesCollection,String,DataSourceType) Method
SeriesCollection containing the given group of elements.
Name of the element in each series that makes up the group.
Name of the given element.
FromElementGroup(SeriesCollection,String,DataSourceType) Method
Creates an Element Group DataSource object from a SeriesColleciton, and Element name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceGroupName As String
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromElementGroup(sourceSeriesCollection, sourceGroupName, splitIntoType)
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   string sourceGroupName,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Name of the element in each series that makes up the group.
splitIntoType
Name of the given element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElementGroup Method : FromElementGroup(SeriesCollection,Int32) Method
SeriesCollection containing the given group of elements.
Index of the element in each series that makes up the group.
FromElementGroup(SeriesCollection,Int32) Method
Creates an Element Group DataSource object from a SeriesColleciton, and Element index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupIndex As Integer _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceGroupIndex As Integer
Dim value As DataSource

value = DataSource.FromElementGroup(sourceSeriesCollection, sourceGroupIndex)
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   int sourceGroupIndex
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupIndex
Index of the element in each series that makes up the group.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromElementGroup Method : FromElementGroup(SeriesCollection,String) Method
SeriesCollection containing the given group of elements.
Index of the element in each series that makes up the group.
FromElementGroup(SeriesCollection,String) Method
Creates an Element Group DataSource object from a SeriesColleciton, and Element name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromElementGroup( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceGroupName As String _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceGroupName As String
Dim value As DataSource

value = DataSource.FromElementGroup(sourceSeriesCollection, sourceGroupName)
public static DataSource FromElementGroup(
   SeriesCollection sourceSeriesCollection,
   string sourceGroupName
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given group of elements.
sourceGroupName
Index of the element in each series that makes up the group.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class : FromScaleRange Method
Axis containing the scale range.
Given ScaleRange object.
FromScaleRange Method
Creates a DataSource object from an ScaleRange object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromScaleRange( _
   ByVal sourceAxis As Axis, _
   ByVal sr As ScaleRange _
) As DataSource
'Usage

Dim sourceAxis As Axis
Dim sr As ScaleRange
Dim value As DataSource

value = DataSource.FromScaleRange(sourceAxis, sr)
public static DataSource FromScaleRange(
   Axis sourceAxis,
   ScaleRange sr
)

Parameters

sourceAxis
Axis containing the scale range.
sr
Given ScaleRange object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : FromSeries Method
FromSeries Method
Creates a DataSource object from a SeriesColleciton, and Series.
Overload List
Overload | Description
FromSeries(SeriesCollection,Int32,DataSourceType) | Creates a DataSource object from a SeriesColleciton, and Series.
FromSeries(SeriesCollection,String,DataSourceType) | Creates a DataSource object from a SeriesColleciton, and Series.
FromSeries(SeriesCollection,Int32) | Creates a DataSource object from a SeriesColleciton, and Series.
FromSeries(SeriesCollection,String) | Creates a DataSource object from a SeriesColleciton, and Series.
FromSeries(Series) | Creates a DataSource object from a Series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class > FromSeries Method : FromSeries(SeriesCollection,Int32,DataSourceType) Method
SeriesCollection containing the given series.
Index of the given series.
Split into type when this DataSource is used to populate a legend box.
FromSeries(SeriesCollection,Int32,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, and Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromSeries(sourceSeriesCollection, sourceSeriesIndex, splitIntoType)
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromSeries Method : FromSeries(SeriesCollection,String,DataSourceType) Method
SeriesCollection containing the given series.
Name of the given series.
Split into type when this DataSource is used to populate a legend box.
FromSeries(SeriesCollection,String,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton, and Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesName As String
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromSeries(sourceSeriesCollection, sourceSeriesName, splitIntoType)
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromSeries Method : FromSeries(SeriesCollection,Int32) Method
SeriesCollection containing the given series.
Index of the given series.
FromSeries(SeriesCollection,Int32) Method
Creates a DataSource object from a SeriesColleciton, and Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesIndex As Integer _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesIndex As Integer
Dim value As DataSource

value = DataSource.FromSeries(sourceSeriesCollection, sourceSeriesIndex)
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   int sourceSeriesIndex
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesIndex
Index of the given series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromSeries Method : FromSeries(SeriesCollection,String) Method
SeriesCollection containing the given series.
Name of the given series.
FromSeries(SeriesCollection,String) Method
Creates a DataSource object from a SeriesColleciton, and Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeries( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal sourceSeriesName As String _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim sourceSeriesName As String
Dim value As DataSource

value = DataSource.FromSeries(sourceSeriesCollection, sourceSeriesName)
public static DataSource FromSeries(
   SeriesCollection sourceSeriesCollection,
   string sourceSeriesName
)

Parameters

sourceSeriesCollection
SeriesCollection containing the given series.
sourceSeriesName
Name of the given series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromSeries Method : FromSeries(Series) Method
The series.
FromSeries(Series) Method
Creates a DataSource object from a Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeries( _
   ByVal series As Series _
) As DataSource
'Usage

Dim series As Series
Dim value As DataSource

value = DataSource.FromSeries(series)
public static DataSource FromSeries(
   Series series
)

Parameters

series
The series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class : FromSeriesCollection Method
FromSeriesCollection Method
Creates a DataSource object from a SeriesColleciton.
Overload List
Overload | Description
FromSeriesCollection(SeriesCollection,DataSourceType) | Creates a DataSource object from a SeriesColleciton.
FromSeriesCollection(SeriesCollection) | Creates a DataSource object from a SeriesColleciton.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class > FromSeriesCollection Method : FromSeriesCollection(SeriesCollection,DataSourceType) Method
Given SeriesCollection.
Split into type when this DataSource is used to populate a legend box.
FromSeriesCollection(SeriesCollection,DataSourceType) Method
Creates a DataSource object from a SeriesColleciton.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeriesCollection( _
   ByVal sourceSeriesCollection As SeriesCollection, _
   ByVal splitIntoType As DataSourceType _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim splitIntoType As DataSourceType
Dim value As DataSource

value = DataSource.FromSeriesCollection(sourceSeriesCollection, splitIntoType)
public static DataSource FromSeriesCollection(
   SeriesCollection sourceSeriesCollection,
   DataSourceType splitIntoType
)

Parameters

sourceSeriesCollection
Given SeriesCollection.
splitIntoType
Split into type when this DataSource is used to populate a legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


dotnetCHARTING Namespace > DataSource Class > FromSeriesCollection Method : FromSeriesCollection(SeriesCollection) Method
Given SeriesCollection.
FromSeriesCollection(SeriesCollection) Method
Creates a DataSource object from a SeriesColleciton.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromSeriesCollection( _
   ByVal sourceSeriesCollection As SeriesCollection _
) As DataSource
'Usage

Dim sourceSeriesCollection As SeriesCollection
Dim value As DataSource

value = DataSource.FromSeriesCollection(sourceSeriesCollection)
public static DataSource FromSeriesCollection(
   SeriesCollection sourceSeriesCollection
)

Parameters

sourceSeriesCollection
Given SeriesCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : DataSource Class
DataSource Class Properties

For a list of all members of this type, see DataSource members.

Public Properties
 | Name | Description
Public Property | Axis | Gets or sets the represented axis.
Public Property | AxisMarker | Gets or sets the represented AxisMarker.
Public Property | Element | Gets or sets the represented element.
Public Property | GroupIndex | Gets or sets the index of series for the element group.
Public Property | ScaleRange | Gets or sets the represented ScaleRange object.
Public Property | Series | Gets or sets the represented or parent series.
Public Property | SeriesCollection | Gets or sets the represented or parent SeriesCollection.
Public Property | SplitInto | Specifies the type of DataSource to split this data source into when it is used to populate a legend box.
Public Property | Type | Gets or sets the DataSourceType of this DataSource.
Top
See Also

Reference

DataSource Class
dotnetCHARTING Namespace

Tutorials

Data Sources


dotnetCHARTING Namespace > DataSource Class : Axis Property
Axis Property
Gets or sets the represented axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Axis As Axis
'Usage

Dim instance As DataSource
Dim value As Axis

instance.Axis = value

value = instance.Axis
public Axis Axis {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : AxisMarker Property
AxisMarker Property (DataSource)
Gets or sets the represented AxisMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisMarker As AxisMarker
'Usage

Dim instance As DataSource
Dim value As AxisMarker

instance.AxisMarker = value

value = instance.AxisMarker
public AxisMarker AxisMarker {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : Element Property
Element Property (DataSource)
Gets or sets the represented element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Element As Element
'Usage

Dim instance As DataSource
Dim value As Element

instance.Element = value

value = instance.Element
public Element Element {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : GroupIndex Property
GroupIndex Property
Gets or sets the index of series for the element group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GroupIndex As Integer
'Usage

Dim instance As DataSource
Dim value As Integer

instance.GroupIndex = value

value = instance.GroupIndex
public int GroupIndex {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : ScaleRange Property
ScaleRange Property (DataSource)
Gets or sets the represented ScaleRange object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleRange As ScaleRange
'Usage

Dim instance As DataSource
Dim value As ScaleRange

instance.ScaleRange = value

value = instance.ScaleRange
public ScaleRange ScaleRange {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : Series Property
Series Property (DataSource)
Gets or sets the represented or parent series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Series As Series
'Usage

Dim instance As DataSource
Dim value As Series

instance.Series = value

value = instance.Series
public Series Series {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : SeriesCollection Property
SeriesCollection Property (DataSource)
Gets or sets the represented or parent SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SeriesCollection As SeriesCollection
'Usage

Dim instance As DataSource
Dim value As SeriesCollection

instance.SeriesCollection = value

value = instance.SeriesCollection
public SeriesCollection SeriesCollection {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


dotnetCHARTING Namespace > DataSource Class : SplitInto Property
SplitInto Property
Specifies the type of DataSource to split this data source into when it is used to populate a legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplitInto As DataSourceType
'Usage

Dim instance As DataSource
Dim value As DataSourceType

instance.SplitInto = value

value = instance.SplitInto
public DataSourceType SplitInto {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members

Tutorial

Data Sources


dotnetCHARTING Namespace > DataSource Class : Type Property
Type Property (DataSource)
Gets or sets the DataSourceType of this DataSource.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As DataSourceType
'Usage

Dim instance As DataSource
Dim value As DataSourceType

instance.Type = value

value = instance.Type
public DataSourceType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members

Tutorial

Data Sources


dotnetCHARTING Namespace > DataSource Class : Implicit Type Conversion Operator
Implicit Type Conversion Operator (DataSource)
Creates a DataSource from the specified SeriesCollection.
Overload List
Overload | Description
Implicit Type Conversion(DataSource,SeriesCollection) | Creates a DataSource from the specified SeriesCollection.
Implicit Type Conversion(DataSource,Series) | Creates a DataSource from the specified Series.
Implicit Type Conversion(DataSource,Element) | Creates a DataSource from the specified Element.
Implicit Type Conversion(DataSource,AxisMarker) | Creates a DataSource from the specified AxisMarker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataSource Class
DataSource Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Element Class
Element Class
Represents a element object or data point on the chart.
Object Model
Element ClassAnnotation ClassAxisMarker ClassListCollection ClassSubValue ClassLine ClassHotspot ClassLegendEntry ClassElementMarker ClassLine ClassSmartLabel ClassSubValueCollection ClassSubValue ClassAxisTick ClassAxisTick Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Element
'Usage

Dim instance As Element
public class Element
Remarks
The Element object contains properties that describe it's value such as YValue, YDateTime, BubbleSize etc.. It also defines defines objects and properties that specify the element's behavior and appearance.

Element properties that don't describe it's value can be set simultaneously for all element in a Series by setting them with Series.DefaultElement.___ For example:(Chart.DefaultSeries.DefaultElement.SmartLabel.Text = "%YValue").

See also: Data Model Tutorial
Inheritance Hierarchy

System.Object
dotnetCHARTING.Element

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Members
dotnetCHARTING Namespace

Tutorials

Data Model
Element Sorting
Data Tutorials

Samples

IterateElements
ElementNameGroupingOptions


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Element Class
Element Class Members

The following tables list the members exposed by Element.

Public Constructors
 | Name | Description
Public Constructor | Element Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets this element's Annotation.
Public Property | AxisMarker | Gets or sets this element's AxisMarker.
Public Property | BubbleSize | Gets or sets the bubble size of this element.
Public Property | Close | Gets or sets the financial closing price of this element.
Public Property | Color | Gets or sets this element's color.
Public Property | Complete | Gets or sets the percent complete value of this element.
Public Property | CornerRadius | Gets or sets a value that controls the corner radius of columns and bars. It is not supported with shading effects Five, Six, Seven, or Background1 and Background2.
Public Property | CustomAttributes | Gets a collection of custom attributes associated with this element.
Public Property | DefaultSubValue | Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.
Public Property | DrawToFloor | Gets or sets a value that indicates whether the surface of elements stretches to the floor of the chart area. This property is used with 3D surface charts.
Public Property | ErrorHighValue | Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.
Public Property | ErrorLowValue | Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.
Public Property | ErrorMinusOffset | Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.
Public Property | ErrorMinusPercent | Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.
Public Property | ErrorOffset | Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.
Public Property | ErrorPercent | Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.
Public Property | ErrorPlusOffset | Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.
Public Property | ErrorPlusPercent | Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.
Public Property | ExplodeSlice | Gets or sets a value indicating whether the pie slice represented by this element is exploded.
Public Property | FocusGlow | (JS Chart Only) Gets or sets options for a glow effect when the point is hovered or highlighted by combined tooltip and crosshair.
Public Property | ForceMarker | Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.
Public Property | HatchColor | Gets or sets this element's HatchStyle color.
Public Property | HatchStyle | Gets or sets this element's hatch style.
Public Property | Height | Gets or sets a value which represents the height of pie slices.
Public Property | High | Gets or sets the financial high price of this element.
Public Property | Hotspot | Gets or sets the Hotspot of this Element.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action setting when the mouse hovers an element.
Public Property | InstanceParentID | Gets or sets the InstanceID of the parent element for use in organization charts.
Public Property | JsID | Gets or sets the ID of this element used in JavaScript charts. By specifying this ID, the element can be referenced in JS.
Public Property | JsMap |
Public Property | LegendEntry | Gets or sets this element's LegendEntry.
Public Property | Length | Gets or sets a percent value representing this element's needle length. Also used to represent pie slice length.
Public Property | Low | Gets or sets the financial low price of this element.
Public Property | Marker | Gets or sets this element's Marker.
Public Property | Name | Gets or sets this element's name.
Public Property | Open | Gets or sets the financial open price of this element.
Public Property | Outline | Gets or sets a Line object used to an outline around this element.
Public Property | Parent | Gets or sets the parent of this element for use in organizational charts.
Public Property | Point | Gets the element's pixel coordinate on a chart image.
Public Property | SecondaryColor | Gets or sets this element's secondary color.
Public Property | ShapeType | Gets or sets the shape type of this element when the series type is SeriesType.BubbleShape.
Public Property | ShowValue | Gets or sets a value that indicates whether this element's SmartLabel is visible.
Public Property | SmartLabel | Gets or sets this element's SmartLabel.
Public Property | SubValues | Gets a collection of SubValue objects drawn on this Element.
Public Property | TakeColorFrom | Gets or sets a Series or Element object from which this element's color will be inherited.
Public Property | ToolTip | Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)
Public Property | Transparency | Gets or sets the element color's transparency.
Public Property | URL | Gets or sets the element's URL link. (Shortcut to: Element.Hotspot.URL)
Public Property | URLTarget | Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)
Public Property | Volume | Gets or sets the financial volume of this element.
Public Property | XAxisTick | Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property | XDateTime | Gets or sets the X System.DateTime value of this element.
Public Property | XDateTimeStart | Gets or sets the initial X DateTime value of this element.
Public Property | XValue | Gets or sets the X value of this element.
Public Property | XValueStart | Gets or sets the initial X value of this element.
Public Property | YAxisTick | Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property | YDateTime | Gets or sets the Y DateTime value of this element.
Public Property | YDateTimeStart | Gets or sets the initial Y DateTime value of this element.
Public Property | YValue | Gets or sets the y value of this element.
Public Property | YValueStart | Gets or sets the initial Y value of this element.
Public Property | ZValue | Gets or sets the Z value of this element when used with surface charts.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds the values of two elements.
Public Method | Clone | Creates a copy of the current Element.
static (Shared in Visual Basic) | Divide | Overloaded. Divides an element by another.
Public Method | GetDataSource | Gets a DataSource object representing this Element.
Public Method | GetPolygon | Gets the coordinates of the element after the chart is generated. This can be used to draw on top of the element by knowing its polygon coordinates.
static (Shared in Visual Basic) | Multiply | Overloaded. Multiplies two elements.
static (Shared in Visual Basic) | Subtract | Overloaded. Subtracts an element from another.
Top
Public Operators
public Operator Addition | Overloaded. Adds the values of two elements.
public Operator Division | Overloaded. Divides an element by another.
public Operator Multiplication | Overloaded. Multiplies two elements.
public Operator Subtraction | Overloaded. Subtracts an element from another.
Top
See Also

Reference

Element Class
dotnetCHARTING Namespace

Tutorials

Data Model
Element Sorting
Data Tutorials

Samples

IterateElements
ElementNameGroupingOptions


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class : Element Constructor
Element Constructor
Overload List
Overload | Description
Element Constructor() | Initializes a new instance of the Element class.
Element Constructor(String) | Initializes a new instance of the Element class with the specified name.
Element Constructor(String,Double) | Initialize a new instance of the Element class with (YValue) as the initial element value type.
Element Constructor(String,Double,Double) | Initialize a new instance of the Element class with (YValueStart, YValue) or (XValue, YValue) as the initial element value types.
Element Constructor(String,Double,Double,Double) | Initialize a new instance of the Element class with (YValueStart, YValue, Complete) or (XValue, YValue, BubbleSize) as the initial element value types.
Element Constructor(String,DateTime,Double) | Initialize a new instance of the Element class with (XDateTime, YValue) or (XDateTime, Close) as the initial element value types.
Element Constructor(String,DateTime,DateTime,Double) | Initialize a new instance of the Element class with (YDateTimeStart, YDateTime, Complete) or (XDateTime, YDateTime, BubbleSize) as the initial element value types.
Element Constructor(String,DateTime,DateTime) | Initialize a new instance of the Element class with (YDateTimeStart, YDateTime) or (XDateTime, YDateTime) as the initial element value types.
Element Constructor(String,Double,DateTime) | Initialize a new instance of the Element class with (XValue, YDateTime) as the initial element value types.
Element Constructor(String,DateTime,Double,Double) | Initialize a new instance of the Element class with (XDateTime, YValue, BubbleSize) or (XDateTime, Close, Volume) as the initial element value types.
Element Constructor(String,Double,DateTime,Double) | Initialize a new instance of the Element class with (XValue, YDateTime, BubbleSize) as the initial element value types.
Element Constructor(String,DateTime,Double,Double,Double,Double) | Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close) as the initial element value types.
Element Constructor(String,DateTime,Double,Double,Double,Double,Double) | Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close, Volume) as the initial element value types.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor()
Element Constructor()
Initializes a new instance of the Element class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Element()
public Element()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String)
Name of this element.
Element Constructor(String)
Initializes a new instance of the Element class with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New Element(name)
public Element(
   string name
)

Parameters

name
Name of this element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,Double)
Name of this element.
Sets YValue
Element Constructor(String,Double)
Initialize a new instance of the Element class with (YValue) as the initial element value type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double _
)
'Usage

Dim name As String
Dim double1 As Double

Dim instance As New Element(name, double1)
public Element(
   string name,
   double double1
)

Parameters

name
Name of this element.
double1
Sets YValue
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,Double,Double)
Name of this element.
Sets YValueStart and XValue
Sets YValue
Element Constructor(String,Double,Double)
Initialize a new instance of the Element class with (YValueStart, YValue) or (XValue, YValue) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal double2 As Double _
)
'Usage

Dim name As String
Dim double1 As Double
Dim double2 As Double

Dim instance As New Element(name, double1, double2)
public Element(
   string name,
   double double1,
   double double2
)

Parameters

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,Double,Double,Double)
Name of this element.
Sets YValueStart and XValue
Sets YValue
Sets Complete and BubbleSize
Element Constructor(String,Double,Double,Double)
Initialize a new instance of the Element class with (YValueStart, YValue, Complete) or (XValue, YValue, BubbleSize) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double _
)
'Usage

Dim name As String
Dim double1 As Double
Dim double2 As Double
Dim double3 As Double

Dim instance As New Element(name, double1, double2, double3)
public Element(
   string name,
   double double1,
   double double2,
   double double3
)

Parameters

name
Name of this element.
double1
Sets YValueStart and XValue
double2
Sets YValue
double3
Sets Complete and BubbleSize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,Double)
Name of this element.
Sets XDateTime
Sets YValue and Close
Element Constructor(String,DateTime,Double)
Initialize a new instance of the Element class with (XDateTime, YValue) or (XDateTime, Close) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim double1 As Double

Dim instance As New Element(name, dateTime1, double1)
public Element(
   string name,
   DateTime dateTime1,
   double double1
)

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets YValue and Close
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,DateTime,Double)
Name of this element.
Sets YDateTimeStart and XDateTime
Set YDateTime
Sets Complete and BubbleSize
Element Constructor(String,DateTime,DateTime,Double)
Initialize a new instance of the Element class with (YDateTimeStart, YDateTime, Complete) or (XDateTime, YDateTime, BubbleSize) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal dateTime2 As Date, _
   ByVal double1 As Double _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim dateTime2 As Date
Dim double1 As Double

Dim instance As New Element(name, dateTime1, dateTime2, double1)
public Element(
   string name,
   DateTime dateTime1,
   DateTime dateTime2,
   double double1
)

Parameters

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Set YDateTime
double1
Sets Complete and BubbleSize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,DateTime)
Name of this element.
Sets YDateTimeStart and XDateTime
Sets YDateTime
Element Constructor(String,DateTime,DateTime)
Initialize a new instance of the Element class with (YDateTimeStart, YDateTime) or (XDateTime, YDateTime) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal dateTime2 As Date _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim dateTime2 As Date

Dim instance As New Element(name, dateTime1, dateTime2)
public Element(
   string name,
   DateTime dateTime1,
   DateTime dateTime2
)

Parameters

name
Name of this element.
dateTime1
Sets YDateTimeStart and XDateTime
dateTime2
Sets YDateTime
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,Double,DateTime)
Name of this element.
Sets XValue
Sets YDateTime
Element Constructor(String,Double,DateTime)
Initialize a new instance of the Element class with (XValue, YDateTime) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal dateTime1 As Date _
)
'Usage

Dim name As String
Dim double1 As Double
Dim dateTime1 As Date

Dim instance As New Element(name, double1, dateTime1)
public Element(
   string name,
   double double1,
   DateTime dateTime1
)

Parameters

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,Double,Double)
Name of this element.
Sets XDateTime
Sets Yvalue and Close
Sets BubbleSize and Volume
Element Constructor(String,DateTime,Double,Double)
Initialize a new instance of the Element class with (XDateTime, YValue, BubbleSize) or (XDateTime, Close, Volume) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim double1 As Double
Dim double2 As Double

Dim instance As New Element(name, dateTime1, double1, double2)
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2
)

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets Yvalue and Close
double2
Sets BubbleSize and Volume
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,Double,DateTime,Double)
Name of this element.
Sets XValue
Sets YDateTime
Sets BubbleSize
Element Constructor(String,Double,DateTime,Double)
Initialize a new instance of the Element class with (XValue, YDateTime, BubbleSize) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal double1 As Double, _
   ByVal dateTime1 As Date, _
   ByVal double2 As Double _
)
'Usage

Dim name As String
Dim double1 As Double
Dim dateTime1 As Date
Dim double2 As Double

Dim instance As New Element(name, double1, dateTime1, double2)
public Element(
   string name,
   double double1,
   DateTime dateTime1,
   double double2
)

Parameters

name
Name of this element.
double1
Sets XValue
dateTime1
Sets YDateTime
double2
Sets BubbleSize
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,Double,Double,Double,Double)
Name of this element.
Sets XDateTime
Sets High
Sets Low
Sets Open
Sets Close
Element Constructor(String,DateTime,Double,Double,Double,Double)
Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double, _
   ByVal double4 As Double _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim double1 As Double
Dim double2 As Double
Dim double3 As Double
Dim double4 As Double

Dim instance As New Element(name, dateTime1, double1, double2, double3, double4)
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2,
   double double3,
   double double4
)

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Element Class > Element Constructor : Element Constructor(String,DateTime,Double,Double,Double,Double,Double)
Name of this element.
Sets XDateTime
Sets High
Sets Low
Sets Open
Sets Close
Sets Volume
Element Constructor(String,DateTime,Double,Double,Double,Double,Double)
Initialize a new instance of the Element class with (XDateTime, High, Low, Open, Close, Volume) as the initial element value types.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal dateTime1 As Date, _
   ByVal double1 As Double, _
   ByVal double2 As Double, _
   ByVal double3 As Double, _
   ByVal double4 As Double, _
   ByVal double5 As Double _
)
'Usage

Dim name As String
Dim dateTime1 As Date
Dim double1 As Double
Dim double2 As Double
Dim double3 As Double
Dim double4 As Double
Dim double5 As Double

Dim instance As New Element(name, dateTime1, double1, double2, double3, double4, double5)
public Element(
   string name,
   DateTime dateTime1,
   double double1,
   double double2,
   double double3,
   double double4,
   double double5
)

Parameters

name
Name of this element.
dateTime1
Sets XDateTime
double1
Sets High
double2
Sets Low
double3
Sets Open
double4
Sets Close
double5
Sets Volume
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Element Class
Element Class Methods

For a list of all members of this type, see Element members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds the values of two elements.
Public Method | Clone | Creates a copy of the current Element.
static (Shared in Visual Basic) | Divide | Overloaded. Divides an element by another.
Public Method | GetDataSource | Gets a DataSource object representing this Element.
Public Method | GetPolygon | Gets the coordinates of the element after the chart is generated. This can be used to draw on top of the element by knowing its polygon coordinates.
static (Shared in Visual Basic) | Multiply | Overloaded. Multiplies two elements.
static (Shared in Visual Basic) | Subtract | Overloaded. Subtracts an element from another.
Top
See Also

Reference

Element Class
dotnetCHARTING Namespace

Tutorials

Data Model
Element Sorting
Data Tutorials

Samples

IterateElements
ElementNameGroupingOptions


dotnetCHARTING Namespace > Element Class : Add Method
Add Method (Element)
Adds the values of two elements.
Overload List
Overload | Description
Add(Element,Element) | Adds the values of two elements.
Add(Element,Double) | Adds a value to all values of an element.
Add(Double,Element) | Adds a value to all values of an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class > Add Method : Add(Element,Element) Method
An element.
An element.
Add(Element,Element) Method
Adds the values of two elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Element
Dim value As Element

value = Element.Add(lhs, rhs)
public static Element Add(
   Element lhs,
   Element rhs
)

Parameters

lhs
An element.
rhs
An element.
Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Add Method : Add(Element,Double) Method
An element.
A value.
Add(Element,Double) Method
Adds a value to all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Double
Dim value As Element

value = Element.Add(lhs, rhs)
public static Element Add(
   Element lhs,
   double rhs
)

Parameters

lhs
An element.
rhs
A value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Add Method : Add(Double,Element) Method
A value.
An element.
Add(Double,Element) Method
Adds a value to all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Double
Dim rhs As Element
Dim value As Element

value = Element.Add(lhs, rhs)
public static Element Add(
   double lhs,
   Element rhs
)

Parameters

lhs
A value.
rhs
An element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class : Clone Method
Clone Method (Element)
Creates a copy of the current Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As Element
'Usage

Dim instance As Element
Dim value As Element

value = instance.Clone()
public Element Clone()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Divide Method
Divide Method (Element)
Divides an element by another.
Overload List
Overload | Description
Divide(Element,Element) | Divides an element by another.
Divide(Element,Double) | Divides an element by a number.
Divide(Double,Element) | Divider a number by an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class > Divide Method : Divide(Element,Element) Method
An element.
An element.
Divide(Element,Element) Method
Divides an element by another.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Element
Dim value As Element

value = Element.Divide(lhs, rhs)
public static Element Divide(
   Element lhs,
   Element rhs
)

Parameters

lhs
An element.
rhs
An element.
Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Divide Method : Divide(Element,Double) Method
An element.
A numeric value.
Divide(Element,Double) Method
Divides an element by a number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Double
Dim value As Element

value = Element.Divide(lhs, rhs)
public static Element Divide(
   Element lhs,
   double rhs
)

Parameters

lhs
An element.
rhs
A numeric value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Divide Method : Divide(Double,Element) Method
A numeric value.
An element.
Divide(Double,Element) Method
Divider a number by an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Double
Dim rhs As Element
Dim value As Element

value = Element.Divide(lhs, rhs)
public static Element Divide(
   double lhs,
   Element rhs
)

Parameters

lhs
A numeric value.
rhs
An element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class : GetDataSource Method
GetDataSource Method (Element)
Gets a DataSource object representing this Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDataSource() As DataSource
'Usage

Dim instance As Element
Dim value As DataSource

value = instance.GetDataSource()
public DataSource GetDataSource()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : GetPolygon Method
GetPolygon Method
Gets the coordinates of the element after the chart is generated. This can be used to draw on top of the element by knowing its polygon coordinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetPolygon() As PointF()
'Usage

Dim instance As Element
Dim value() As PointF

value = instance.GetPolygon()
public PointF[] GetPolygon()

Return Value

A PointF array of the element's polygon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Multiply Method
Multiply Method (Element)
Multiplies two elements.
Overload List
Overload | Description
Multiply(Element,Element) | Multiplies two elements.
Multiply(Element,Double) | Multiplies an element by a specified numeric value.
Multiply(Double,Element) | Multiplies an element by a specified numeric value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class > Multiply Method : Multiply(Element,Element) Method
An element.
An element.
Multiply(Element,Element) Method
Multiplies two elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Element
Dim value As Element

value = Element.Multiply(lhs, rhs)
public static Element Multiply(
   Element lhs,
   Element rhs
)

Parameters

lhs
An element.
rhs
An element.
Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Multiply Method : Multiply(Element,Double) Method
An element.
A numeric value.
Multiply(Element,Double) Method
Multiplies an element by a specified numeric value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Double
Dim value As Element

value = Element.Multiply(lhs, rhs)
public static Element Multiply(
   Element lhs,
   double rhs
)

Parameters

lhs
An element.
rhs
A numeric value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Multiply Method : Multiply(Double,Element) Method
A numeric value.
An element.
Multiply(Double,Element) Method
Multiplies an element by a specified numeric value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Double
Dim rhs As Element
Dim value As Element

value = Element.Multiply(lhs, rhs)
public static Element Multiply(
   double lhs,
   Element rhs
)

Parameters

lhs
A numeric value.
rhs
An element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class : Subtract Method
Subtract Method (Element)
Subtracts an element from another.
Overload List
Overload | Description
Subtract(Element,Element) | Subtracts an element from another.
Subtract(Element,Double) | Subtracts a value from all values of an element.
Subtract(Double,Element) | Subtracts all values of an element from specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class > Subtract Method : Subtract(Element,Element) Method
An element.
An element.
Subtract(Element,Element) Method
Subtracts an element from another.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Element
Dim value As Element

value = Element.Subtract(lhs, rhs)
public static Element Subtract(
   Element lhs,
   Element rhs
)

Parameters

lhs
An element.
rhs
An element.
Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Subtract Method : Subtract(Element,Double) Method
An element.
A value.
Subtract(Element,Double) Method
Subtracts a value from all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element
'Usage

Dim lhs As Element
Dim rhs As Double
Dim value As Element

value = Element.Subtract(lhs, rhs)
public static Element Subtract(
   Element lhs,
   double rhs
)

Parameters

lhs
An element.
rhs
A value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


dotnetCHARTING Namespace > Element Class > Subtract Method : Subtract(Double,Element) Method
A value.
An element
Subtract(Double,Element) Method
Subtracts all values of an element from specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element
'Usage

Dim lhs As Double
Dim rhs As Element
Dim value As Element

value = Element.Subtract(lhs, rhs)
public static Element Subtract(
   double lhs,
   Element rhs
)

Parameters

lhs
A value.
rhs
An element
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Element Class
Element Class Properties

For a list of all members of this type, see Element members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets this element's Annotation.
Public Property | AxisMarker | Gets or sets this element's AxisMarker.
Public Property | BubbleSize | Gets or sets the bubble size of this element.
Public Property | Close | Gets or sets the financial closing price of this element.
Public Property | Color | Gets or sets this element's color.
Public Property | Complete | Gets or sets the percent complete value of this element.
Public Property | CornerRadius | Gets or sets a value that controls the corner radius of columns and bars. It is not supported with shading effects Five, Six, Seven, or Background1 and Background2.
Public Property | CustomAttributes | Gets a collection of custom attributes associated with this element.
Public Property | DefaultSubValue | Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.
Public Property | DrawToFloor | Gets or sets a value that indicates whether the surface of elements stretches to the floor of the chart area. This property is used with 3D surface charts.
Public Property | ErrorHighValue | Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.
Public Property | ErrorLowValue | Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.
Public Property | ErrorMinusOffset | Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.
Public Property | ErrorMinusPercent | Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.
Public Property | ErrorOffset | Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.
Public Property | ErrorPercent | Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.
Public Property | ErrorPlusOffset | Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.
Public Property | ErrorPlusPercent | Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.
Public Property | ExplodeSlice | Gets or sets a value indicating whether the pie slice represented by this element is exploded.
Public Property | FocusGlow | (JS Chart Only) Gets or sets options for a glow effect when the point is hovered or highlighted by combined tooltip and crosshair.
Public Property | ForceMarker | Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.
Public Property | HatchColor | Gets or sets this element's HatchStyle color.
Public Property | HatchStyle | Gets or sets this element's hatch style.
Public Property | Height | Gets or sets a value which represents the height of pie slices.
Public Property | High | Gets or sets the financial high price of this element.
Public Property | Hotspot | Gets or sets the Hotspot of this Element.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action setting when the mouse hovers an element.
Public Property | InstanceParentID | Gets or sets the InstanceID of the parent element for use in organization charts.
Public Property | JsID | Gets or sets the ID of this element used in JavaScript charts. By specifying this ID, the element can be referenced in JS.
Public Property | JsMap |
Public Property | LegendEntry | Gets or sets this element's LegendEntry.
Public Property | Length | Gets or sets a percent value representing this element's needle length. Also used to represent pie slice length.
Public Property | Low | Gets or sets the financial low price of this element.
Public Property | Marker | Gets or sets this element's Marker.
Public Property | Name | Gets or sets this element's name.
Public Property | Open | Gets or sets the financial open price of this element.
Public Property | Outline | Gets or sets a Line object used to an outline around this element.
Public Property | Parent | Gets or sets the parent of this element for use in organizational charts.
Public Property | Point | Gets the element's pixel coordinate on a chart image.
Public Property | SecondaryColor | Gets or sets this element's secondary color.
Public Property | ShapeType | Gets or sets the shape type of this element when the series type is SeriesType.BubbleShape.
Public Property | ShowValue | Gets or sets a value that indicates whether this element's SmartLabel is visible.
Public Property | SmartLabel | Gets or sets this element's SmartLabel.
Public Property | SubValues | Gets a collection of SubValue objects drawn on this Element.
Public Property | TakeColorFrom | Gets or sets a Series or Element object from which this element's color will be inherited.
Public Property | ToolTip | Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)
Public Property | Transparency | Gets or sets the element color's transparency.
Public Property | URL | Gets or sets the element's URL link. (Shortcut to: Element.Hotspot.URL)
Public Property | URLTarget | Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)
Public Property | Volume | Gets or sets the financial volume of this element.
Public Property | XAxisTick | Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property | XDateTime | Gets or sets the X System.DateTime value of this element.
Public Property | XDateTimeStart | Gets or sets the initial X DateTime value of this element.
Public Property | XValue | Gets or sets the X value of this element.
Public Property | XValueStart | Gets or sets the initial X value of this element.
Public Property | YAxisTick | Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.
Public Property | YDateTime | Gets or sets the Y DateTime value of this element.
Public Property | YDateTimeStart | Gets or sets the initial Y DateTime value of this element.
Public Property | YValue | Gets or sets the y value of this element.
Public Property | YValueStart | Gets or sets the initial Y value of this element.
Public Property | ZValue | Gets or sets the Z value of this element when used with surface charts.
Top
See Also

Reference

Element Class
dotnetCHARTING Namespace

Tutorials

Data Model
Element Sorting
Data Tutorials

Samples

IterateElements
ElementNameGroupingOptions


dotnetCHARTING Namespace > Element Class : Annotation Property
Annotation Property (Element)
Gets or sets this element's Annotation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Annotation As Annotation
'Usage

Dim instance As Element
Dim value As Annotation

instance.Annotation = value

value = instance.Annotation
public Annotation Annotation {get; set;}
Remarks
The annotation's position will be the same as this element's position, usless specified. Element tokens can be used by this annotation's text to describe the element.
Example
annotationAlignment
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : AxisMarker Property
AxisMarker Property (Element)
Gets or sets this element's AxisMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisMarker As AxisMarker
'Usage

Dim instance As Element
Dim value As AxisMarker

instance.AxisMarker = value

value = instance.AxisMarker
public AxisMarker AxisMarker {get; set;}
Remarks
This axis marker will highlight a section of the axis on which this element's name appears.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : BubbleSize Property
BubbleSize Property
Gets or sets the bubble size of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BubbleSize As Double
'Usage

Dim instance As Element
Dim value As Double

instance.BubbleSize = value

value = instance.BubbleSize
public double BubbleSize {get; set;}
Remarks
This Element value type is used by ChartType.Bubble only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Close Property
Close Property
Gets or sets the financial closing price of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Close As Double
'Usage

Dim instance As Element
Dim value As Double

instance.Close = value

value = instance.Close
public double Close {get; set;}
Remarks
This element value type is used by ChartType.Financial only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Color Property
Color Property (Element)
Gets or sets this element's color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As Element
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Remarks
This color will also trickle to this element's SmartLabel.Color property, unless specified. When this element instance is the Series.DefaultElement of a Series, this color will trickle to that series' Line.Color property, unless specified.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Complete Property
Complete Property
Gets or sets the percent complete value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Complete As Integer
'Usage

Dim instance As Element
Dim value As Integer

instance.Complete = value

value = instance.Complete
public int Complete {get; set;}
Remarks
This Element value type is used by ChartType.Combo, ComboHorizontal, and ComboSideBySide with Column and Cylinder SeriesType. Primarily used to create Gantt charts.
Example
ProgressBar
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : CornerRadius Property
CornerRadius Property
Gets or sets a value that controls the corner radius of columns and bars. It is not supported with shading effects Five, Six, Seven, or Background1 and Background2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CornerRadius As Integer
'Usage

Dim instance As Element
Dim value As Integer

instance.CornerRadius = value

value = instance.CornerRadius
public int CornerRadius {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : CustomAttributes Property
CustomAttributes Property (Element)
Gets a collection of custom attributes associated with this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property CustomAttributes As ListCollection
'Usage

Dim instance As Element
Dim value As ListCollection

value = instance.CustomAttributes
public ListCollection CustomAttributes {get;}
Example
customAttributes
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : DefaultSubValue Property
DefaultSubValue Property
Gets or sets a default SubValue object used to propagate its property settings to all SubValue objects in the SubValues collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultSubValue As SubValue
'Usage

Dim instance As Element
Dim value As SubValue

instance.DefaultSubValue = value

value = instance.DefaultSubValue
public SubValue DefaultSubValue {get; set;}
Example
ElementSubValueStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : DrawToFloor Property
DrawToFloor Property
Gets or sets a value that indicates whether the surface of elements stretches to the floor of the chart area. This property is used with 3D surface charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DrawToFloor As Boolean
'Usage

Dim instance As Element
Dim value As Boolean

instance.DrawToFloor = value

value = instance.DrawToFloor
public bool DrawToFloor {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorHighValue Property
ErrorHighValue Property (Element)
Gets of sets the high error value. When set, a single SubValue is drawn above the element's value. When ErrorLowValue is also set, a range SubValue is drawn between the two values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorHighValue As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorHighValue = value

value = instance.ErrorHighValue
public double ErrorHighValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorLowValue Property
ErrorLowValue Property (Element)
Gets of sets the low error value. When set, a single SubValue is drawn below the element's YValue value or range. When ErrorHighValue is also set, a range SubValue is drawn between the two values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorLowValue As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorLowValue = value

value = instance.ErrorLowValue
public double ErrorLowValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorMinusOffset Property
ErrorMinusOffset Property
Gets of sets the negative error offset. When set, a single SubValue is drawn below the element's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorMinusOffset As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorMinusOffset = value

value = instance.ErrorMinusOffset
public double ErrorMinusOffset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorMinusPercent Property
ErrorMinusPercent Property
Gets or sets the negative error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn below the element's value. When ErrorPlusPercent is also set, a range SubValue is drawn between the two points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorMinusPercent As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorMinusPercent = value

value = instance.ErrorMinusPercent
public double ErrorMinusPercent {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorOffset Property
ErrorOffset Property
Gets or sets the error offset. The offset represents a range, +/- the value of the offset with respect to the element's YValue value or range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorOffset As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorOffset = value

value = instance.ErrorOffset
public double ErrorOffset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorPercent Property
ErrorPercent Property
Gets or sets the error offset based on the specified percentage of the element's YValue value or range. The offset represents a range, +/- the percentage of the element's YValue value or range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorPercent As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorPercent = value

value = instance.ErrorPercent
public double ErrorPercent {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorPlusOffset Property
ErrorPlusOffset Property
Gets of sets the positive error offset. When set, a single SubValue is drawn above the element's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorPlusOffset As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorPlusOffset = value

value = instance.ErrorPlusOffset
public double ErrorPlusOffset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ErrorPlusPercent Property
ErrorPlusPercent Property
Gets or sets the positive error offset based on the specified percentage of the element's YValue value or range. When set, a single SubValue is drawn above the element's value. When ErrorMinusPercent is also set, a range SubValue is drawn between the two points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorPlusPercent As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ErrorPlusPercent = value

value = instance.ErrorPlusPercent
public double ErrorPlusPercent {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ExplodeSlice Property
ExplodeSlice Property
Gets or sets a value indicating whether the pie slice represented by this element is exploded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExplodeSlice As Boolean
'Usage

Dim instance As Element
Dim value As Boolean

instance.ExplodeSlice = value

value = instance.ExplodeSlice
public bool ExplodeSlice {get; set;}
Remarks
When a pie slice represents a series, that series' DefaultElement.ExplodeSlice property indicates whether the slice is exploded.
Example
DrillSlice
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : FocusGlow Property
FocusGlow Property
(JS Chart Only) Gets or sets options for a glow effect when the point is hovered or highlighted by combined tooltip and crosshair.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FocusGlow As Line
'Usage

Dim instance As Element
Dim value As Line

instance.FocusGlow = value

value = instance.FocusGlow
public Line FocusGlow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ForceMarker Property
ForceMarker Property
Gets or sets a value indicating whether this element's ElementMarker is drawn when the parent Series object's SeriesType omits the ElementMarker by default.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForceMarker As Boolean
'Usage

Dim instance As Element
Dim value As Boolean

instance.ForceMarker = value

value = instance.ForceMarker
public bool ForceMarker {get; set;}
Remarks
Only SeriesTypes: Line (when Use3D = false), Spline, and Marker draw ElementMarkers by default.
Example
Element Markers
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : HatchColor Property
HatchColor Property (Element)
Gets or sets this element's HatchStyle color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchColor As Color
'Usage

Dim instance As Element
Dim value As Color

instance.HatchColor = value

value = instance.HatchColor
public Color HatchColor {get; set;}
Example
Hatch Enhanced
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : HatchStyle Property
HatchStyle Property (Element)
Gets or sets this element's hatch style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStyle As HatchStyle
'Usage

Dim instance As Element
Dim value As HatchStyle

instance.HatchStyle = value

value = instance.HatchStyle
public HatchStyle HatchStyle {get; set;}
Remarks
Hatch styles are filled using HatchColor. By default the color is transparent and may need to be specified before the hatch appears.
Example
Hatch Enhanced
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Height Property
Height Property (Element)
Gets or sets a value which represents the height of pie slices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Height As Double
'Usage

Dim instance As Element
Dim value As Double

instance.Height = value

value = instance.Height
public double Height {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : High Property
High Property
Gets or sets the financial high price of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property High As Double
'Usage

Dim instance As Element
Dim value As Double

instance.High = value

value = instance.High
public double High {get; set;}
Remarks
This element value type is used by ChartType.Financial only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Hotspot Property
Hotspot Property (Element)
Gets or sets the Hotspot of this Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As Element
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Example
Hotspots
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : HoverAction Property
HoverAction Property (Element)
(JS Chart Only) Gets or sets the hover action setting when the mouse hovers an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HoverAction As HoverAction
'Usage

Dim instance As Element
Dim value As HoverAction

instance.HoverAction = value

value = instance.HoverAction
public HoverAction HoverAction {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : InstanceParentID Property
InstanceParentID Property
Gets or sets the InstanceID of the parent element for use in organization charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InstanceParentID As Integer
'Usage

Dim instance As Element
Dim value As Integer

instance.InstanceParentID = value

value = instance.InstanceParentID
public int InstanceParentID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : JsID Property
JsID Property (Element)
Gets or sets the ID of this element used in JavaScript charts. By specifying this ID, the element can be referenced in JS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsID As String
'Usage

Dim instance As Element
Dim value As String

instance.JsID = value

value = instance.JsID
public string JsID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : JsMap Property
JsMap Property (Element)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsMap As String
'Usage

Dim instance As Element
Dim value As String

instance.JsMap = value

value = instance.JsMap
public string JsMap {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : LegendEntry Property
LegendEntry Property (Element)
Gets or sets this element's LegendEntry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendEntry As LegendEntry
'Usage

Dim instance As Element
Dim value As LegendEntry

instance.LegendEntry = value

value = instance.LegendEntry
public LegendEntry LegendEntry {get; set;}
Remarks
The legend entry represents this element in the Chart.LegendBox. Most charts types will only show legend entries of series, not individual elements. Changing this behavior to show the element's legend entries is done by setting the series' Series.Palette or Series.PaletteName properties.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Length Property
Length Property (Element)
Gets or sets a percent value representing this element's needle length. Also used to represent pie slice length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Length As Integer
'Usage

Dim instance As Element
Dim value As Integer

instance.Length = value

value = instance.Length
public int Length {get; set;}
Remarks
Applies to gauge charts.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Low Property
Low Property
Gets or sets the financial low price of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Low As Double
'Usage

Dim instance As Element
Dim value As Double

instance.Low = value

value = instance.Low
public double Low {get; set;}
Remarks
This element value type is used by ChartType.Financial only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Marker Property
Marker Property (Element)
Gets or sets this element's Marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As Element
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Remarks
Only SeriesType options: Line (when Use3D = false), Spline, and Marker draw ElementMarkers by default. For other SeriesTypes, ForceMarker must be true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members

Tutorials

Element Markers


dotnetCHARTING Namespace > Element Class : Name Property
Name Property (Element)
Gets or sets this element's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As Element
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Remarks
The name property represents the element on label axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Open Property
Open Property
Gets or sets the financial open price of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Open As Double
'Usage

Dim instance As Element
Dim value As Double

instance.Open = value

value = instance.Open
public double Open {get; set;}
Remarks
This element value type is used by ChartType.Financial only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Outline Property
Outline Property (Element)
Gets or sets a Line object used to an outline around this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Outline As Line
'Usage

Dim instance As Element
Dim value As Line

instance.Outline = value

value = instance.Outline
public Line Outline {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Parent Property
Parent Property
Gets or sets the parent of this element for use in organizational charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parent As Object
'Usage

Dim instance As Element
Dim value As Object

instance.Parent = value

value = instance.Parent
public object Parent {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Point Property
Point Property
Gets the element's pixel coordinate on a chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Point As PointF
'Usage

Dim instance As Element
Dim value As PointF

value = instance.Point
public PointF Point {get;}
Remarks
This position is only available after the chart is rendered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : SecondaryColor Property
SecondaryColor Property (Element)
Gets or sets this element's secondary color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SecondaryColor As Color
'Usage

Dim instance As Element
Dim value As Color

instance.SecondaryColor = value

value = instance.SecondaryColor
public Color SecondaryColor {get; set;}
Remarks
The secondary color is used with financial series types to indicate that the closing price (dotnetCHARTING.Element.Close) is lower than the opening price (dotnetCHARTING.Element.Open).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members
SeriesTypeFinancial Enumeration


dotnetCHARTING Namespace > Element Class : ShapeType Property
ShapeType Property (Element)
Gets or sets the shape type of this element when the series type is SeriesType.BubbleShape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShapeType As ShapeType
'Usage

Dim instance As Element
Dim value As ShapeType

instance.ShapeType = value

value = instance.ShapeType
public ShapeType ShapeType {get; set;}
Example
Gallery/L01
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ShowValue Property
ShowValue Property
Gets or sets a value that indicates whether this element's SmartLabel is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowValue As Boolean
'Usage

Dim instance As Element
Dim value As Boolean

instance.ShowValue = value

value = instance.ShowValue
public bool ShowValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : SmartLabel Property
SmartLabel Property (Element)
Gets or sets this element's SmartLabel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartLabel As SmartLabel
'Usage

Dim instance As Element
Dim value As SmartLabel

instance.SmartLabel = value

value = instance.SmartLabel
public SmartLabel SmartLabel {get; set;}
Remarks
By default this label is hidden unless ShowValue is true.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : SubValues Property
SubValues Property
Gets a collection of SubValue objects drawn on this Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property SubValues As SubValueCollection
'Usage

Dim instance As Element
Dim value As SubValueCollection

value = instance.SubValues
public SubValueCollection SubValues {get;}
Example
ElementSubValueStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : TakeColorFrom Property
TakeColorFrom Property
Gets or sets a Series or Element object from which this element's color will be inherited.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TakeColorFrom As Object
'Usage

Dim instance As Element
Dim value As Object

instance.TakeColorFrom = value

value = instance.TakeColorFrom
public object TakeColorFrom {get; set;}
Remarks
The specified object must be one that is used and in the chart.
Example
TakeColorFrom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ToolTip Property
ToolTip Property (Element)
Gets or sets this elements tool tip. (Shortcut to: Element.Hotspot.Tooltip)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As Element
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}
Remarks
Element tokens can be used to describe this element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members

Tutorials

Hotspots


dotnetCHARTING Namespace > Element Class : Transparency Property
Transparency Property (Element)
Gets or sets the element color's transparency.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transparency As Integer
'Usage

Dim instance As Element
Dim value As Integer

instance.Transparency = value

value = instance.Transparency
public int Transparency {get; set;}
Remarks
A value of 0 will have no transparency and 100 will be completely transparent.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : URL Property
URL Property (Element)
Gets or sets the element's URL link. (Shortcut to: Element.Hotspot.URL)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As Element
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}
Remarks
The chart will create an image map with the specified url for this element. Element tokens can be used to describe this element in the url.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members

Tutorials

Hotspots


dotnetCHARTING Namespace > Element Class : URLTarget Property
URLTarget Property (Element)
Gets or sets the URL target of this element's link URL. (Shortcut to: Element.Hotspot.URLTarget)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As Element
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members

Tutorials

Hotspots


dotnetCHARTING Namespace > Element Class : Volume Property
Volume Property
Gets or sets the financial volume of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Volume As Double
'Usage

Dim instance As Element
Dim value As Double

instance.Volume = value

value = instance.Volume
public double Volume {get; set;}
Remarks
This element value type is used by ChartType.Financial only.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : XAxisTick Property
XAxisTick Property
Gets or sets an AxisTick object that will placed on the x axis at the position of this element's x value. If the x axis is a category axis, AxisTick will not have any effect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XAxisTick As AxisTick
'Usage

Dim instance As Element
Dim value As AxisTick

instance.XAxisTick = value

value = instance.XAxisTick
public AxisTick XAxisTick {get; set;}
Remarks
This value is null by default.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : XDateTime Property
XDateTime Property
Gets or sets the X System.DateTime value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XDateTime As Date
'Usage

Dim instance As Element
Dim value As Date

instance.XDateTime = value

value = instance.XDateTime
public DateTime XDateTime {get; set;}
Remarks
This Element value is used with value x axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : XDateTimeStart Property
XDateTimeStart Property
Gets or sets the initial X DateTime value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XDateTimeStart As Date
'Usage

Dim instance As Element
Dim value As Date

instance.XDateTimeStart = value

value = instance.XDateTimeStart
public DateTime XDateTimeStart {get; set;}
Remarks
Not yet implemented.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : XValue Property
XValue Property
Gets or sets the X value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XValue As Double
'Usage

Dim instance As Element
Dim value As Double

instance.XValue = value

value = instance.XValue
public double XValue {get; set;}
Remarks
This Element value is used with value x axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : XValueStart Property
XValueStart Property
Gets or sets the initial X value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XValueStart As Double
'Usage

Dim instance As Element
Dim value As Double

instance.XValueStart = value

value = instance.XValueStart
public double XValueStart {get; set;}
Remarks
Not yet implemented.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : YAxisTick Property
YAxisTick Property
Gets or sets an AxisTick object that will placed on the y axis at the position of this element's y value. If the x axis is a category axis, AxisTick will not have any effect.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YAxisTick As AxisTick
'Usage

Dim instance As Element
Dim value As AxisTick

instance.YAxisTick = value

value = instance.YAxisTick
public AxisTick YAxisTick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : YDateTime Property
YDateTime Property
Gets or sets the Y DateTime value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YDateTime As Date
'Usage

Dim instance As Element
Dim value As Date

instance.YDateTime = value

value = instance.YDateTime
public DateTime YDateTime {get; set;}
Remarks
Using ChartType.ComboHorizontal the YDateTime value type corresponds to the x axis because this allows the element to be interchangeable between the vertical and horizontal combo chart.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : YDateTimeStart Property
YDateTimeStart Property
Gets or sets the initial Y DateTime value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YDateTimeStart As Date
'Usage

Dim instance As Element
Dim value As Date

instance.YDateTimeStart = value

value = instance.YDateTimeStart
public DateTime YDateTimeStart {get; set;}
Remarks
Using ChartType.ComboHorizontal the YDateTimeStart value type corresponds to the x axis because this allows the element to be interchangeable between the vertical and horizontal combo chart.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : YValue Property
YValue Property
Gets or sets the y value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YValue As Double
'Usage

Dim instance As Element
Dim value As Double

instance.YValue = value

value = instance.YValue
public double YValue {get; set;}
Remarks
YValue is the main value container for elements. It is used at times when the element's value would not officially be considered the y value such as: pie slice value. Using ChartType.ComboHorizontal the YValue type value corresponds to the x axis because this allows the element to be interchangable between the vertical and horizontal combo chart.
This Element value type is used by all chart types except ChartType.Financial.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : YValueStart Property
YValueStart Property
Gets or sets the initial Y value of this element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YValueStart As Double
'Usage

Dim instance As Element
Dim value As Double

instance.YValueStart = value

value = instance.YValueStart
public double YValueStart {get; set;}
Remarks
Using ChartType.ComboHorizontal, the YValueStart type value corresponds to the x axis because this allows the element to be interchangable between the vertical and horizontal combo chart.
This Element value type is used by all chart types except ChartType.Financial.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : ZValue Property
ZValue Property
Gets or sets the Z value of this element when used with surface charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZValue As Double
'Usage

Dim instance As Element
Dim value As Double

instance.ZValue = value

value = instance.ZValue
public double ZValue {get; set;}
Remarks
This Element value is used with value x axes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Addition Operator
Addition Operator (Element)
Adds the values of two elements.
Overload List
Overload | Description
Addition(Element,Element) | Adds the values of two elements.
Addition(Element,Double) | Adds a value to all values of an element.
Addition(Double,Element) | Adds a value to all values of an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Division Operator
Division Operator (Element)
Divides an element by another.
Overload List
Overload | Description
Division(Element,Element) | Divides an element by another.
Division(Element,Double) | Divides an element by a number.
Division(Double,Element) | Divider a number by an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Multiplication Operator
Multiplication Operator (Element)
Multiplies two elements.
Overload List
Overload | Description
Multiplication(Element,Element) | Multiplies two elements.
Multiplication(Element,Double) | Multiplies an element by a specified numeric value.
Multiplication(Double,Element) | Multiplies an element by a specified numeric value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


dotnetCHARTING Namespace > Element Class : Subtraction Operator
Subtraction Operator (Element)
Subtracts an element from another.
Overload List
Overload | Description
Subtraction(Element,Element) | Subtracts an element from another.
Subtraction(Element,Double) | Subtracts a value from all values of an element.
Subtraction(Double,Element) | Subtracts all values of an element from specified value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Element Class
Element Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ElementCollection Class
ElementCollection Class
Contains a collection of Element objects.
Object Model
ElementCollection ClassElement Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ElementCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ElementCollection
public class ElementCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ElementCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ElementCollection Class
ElementCollection Class Members

The following tables list the members exposed by ElementCollection.

Public Constructors
 | Name | Description
Public Constructor | ElementCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the Element at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an element to the collection based on the specified calculation.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Element.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Element in this collection.
Public Method | Insert | Inserts a element into this collection at a specified index.
Public Method | Remove | Removes a specified element from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ElementCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementCollection Class : ElementCollection Constructor
ElementCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ElementCollection()
public ElementCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ElementCollection Class
ElementCollection Class Methods

For a list of all members of this type, see ElementCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds an element to the collection based on the specified calculation.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Element.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Element in this collection.
Public Method | Insert | Inserts a element into this collection at a specified index.
Public Method | Remove | Removes a specified element from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ElementCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ElementCollection Class : Add Method
Add Method (ElementCollection)
Adds an element to the collection based on the specified calculation.
Overload List
Overload | Description
Add(Calculation) | Adds an element to the collection based on the specified calculation.
Add(Calculation,String) | Adds an element to the collection based on the specified collection with the specified name.
Add() | Provided as a shortcut for adding element the chart SeriesCollection.
Add(Element[]) | Adds the specified Elements to this collection.
Add(ElementCollection) | Adds a specified ElementCollection to this collection.
Add(Element) | Adds a specified Element class to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add(Calculation) Method
Calculation to perform on the collection.
Add(Calculation) Method
Adds an element to the collection based on the specified calculation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal calc As Calculation _
) As Integer
'Usage

Dim instance As ElementCollection
Dim calc As Calculation
Dim value As Integer

value = instance.Add(calc)
public int Add(
   Calculation calc
)

Parameters

calc
Calculation to perform on the collection.

Return Value

Numeric index of the added element.
Remarks
This method must be used through Chart.Series.Elements.Add(...).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add(Calculation,String) Method
Calculation to perform on the elements.
Name of the new element.
Add(Calculation,String) Method
Adds an element to the collection based on the specified collection with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal calc As Calculation, _
   ByVal text As String _
) As Integer
'Usage

Dim instance As ElementCollection
Dim calc As Calculation
Dim text As String
Dim value As Integer

value = instance.Add(calc, text)
public int Add(
   Calculation calc,
   string text
)

Parameters

calc
Calculation to perform on the elements.
text
Name of the new element.

Return Value

Numeric index of the added element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


Example

dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add() Method
Add() Method
Provided as a shortcut for adding element the chart SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add() As Integer
'Usage

Dim instance As ElementCollection
Dim value As Integer

value = instance.Add()
public int Add()
Example
  • C#
[C#]
            Chart.Series.Element.YValue = 10;
            Chart.Series.Element.Name = "Element 1";
            Chart.Series.Elements.Add();
            Chart.SeriesCollection.Add();
  • C#
[Visual Basic]
            Chart.Series.Element.YValue = 10
            Chart.Series.Element.Name = "Element 1"
            Chart.Series.Elements.Add()
            Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add(Element[]) Method
List of elements to add.
Add(Element[]) Method
Adds the specified Elements to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray elements() As Element _
)
'Usage

Dim instance As ElementCollection
Dim elements() As Element

instance.Add(elements)
public void Add(
   params Element[] elements
)

Parameters

elements
List of elements to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add(ElementCollection) Method
ElementCollection to add.
Add(ElementCollection) Method
Adds a specified ElementCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal elementCollection As ElementCollection _
) As Integer
'Usage

Dim instance As ElementCollection
Dim elementCollection As ElementCollection
Dim value As Integer

value = instance.Add(elementCollection)
public int Add(
   ElementCollection elementCollection
)

Parameters

elementCollection
ElementCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


dotnetCHARTING Namespace > ElementCollection Class > Add Method : Add(Element) Method
The Element to add.
Add(Element) Method
Adds a specified Element class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal element As Element _
) As Integer
'Usage

Dim instance As ElementCollection
Dim element As Element
Dim value As Integer

value = instance.Add(element)
public int Add(
   Element element
)

Parameters

element
The Element to add.

Return Value

The zero-based index of the added Element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members
Overload List


dotnetCHARTING Namespace > ElementCollection Class : Contains Method
The Element to find.
Contains Method (ElementCollection)
Determines whether this collection contains a specified Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal element As Element _
) As Boolean
'Usage

Dim instance As ElementCollection
Dim element As Element
Dim value As Boolean

value = instance.Contains(element)
public bool Contains(
   Element element
)

Parameters

element
The Element to find.

Return Value

true if the specified Element belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


dotnetCHARTING Namespace > ElementCollection Class : IndexOf Method
The AxisTick to find.
IndexOf Method (ElementCollection)
Determines the index of a specified Element in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal e As Element _
) As Integer
'Usage

Dim instance As ElementCollection
Dim e As Element
Dim value As Integer

value = instance.IndexOf(e)
public int IndexOf(
   Element e
)

Parameters

e
The AxisTick to find.

Return Value

The zero-based index of the specified AxisTick.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


dotnetCHARTING Namespace > ElementCollection Class : Insert Method
The zero-based index into the collection at which to insert the element.
The element to insert into this collection.
Insert Method (ElementCollection)
Inserts a element into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal element As Element _
)
'Usage

Dim instance As ElementCollection
Dim index As Integer
Dim element As Element

instance.Insert(index, element)
public void Insert(
   int index,
   Element element
)

Parameters

index
The zero-based index into the collection at which to insert the element.
element
The element to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


dotnetCHARTING Namespace > ElementCollection Class : Remove Method
The element to remove.
Remove Method (ElementCollection)
Removes a specified element from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal element As Element _
)
'Usage

Dim instance As ElementCollection
Dim element As Element

instance.Remove(element)
public void Remove(
   Element element
)

Parameters

element
The element to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ElementCollection Class
ElementCollection Class Properties

For a list of all members of this type, see ElementCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the Element at a specified index.
Top
See Also

Reference

ElementCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ElementCollection Class : Item(Int32) Property
Item(Int32) Property
Gets or sets the Element at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Item( _
   ByVal index As Integer _
) As Element
'Usage

Dim instance As ElementCollection
Dim index As Integer
Dim value As Element

instance.Item(index) = value

value = instance.Item(index)
public Element Item(
   int index
) {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ElementMarker Class
ElementMarker Class
Defines a graphical object with a specified shape, size, and color or an image used to mark and identify Element objects.
Object Model
ElementMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ElementMarker
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As ElementMarker
public class ElementMarker : dotnetCHARTING.Mapping.Drawing.Property
Inheritance Hierarchy

System.Object
dotnetCHARTING.ElementMarker

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Members
dotnetCHARTING Namespace

Tutorials

Element Markers

Samples

ElementMarkers


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : ElementMarker Class
ElementMarker Class Members

The following tables list the members exposed by ElementMarker.

Public Constructors
 | Name | Description
Public Constructor | ElementMarker Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this element marker.
Public Property | DynamicImageColor | Gets or sets the color in a specified image that will be replaced by the color of the element it represents.
Public Property | DynamicImageColorTolerance | Gets or sets a value between 0 and 100 that represents the tolerance of the DynamicImageColor allowing the replacing color to affect a wider range of color variation from the specified DynamicImageColor.
Public Property | ImagePath | Gets or sets the image path of this marker.
Public Property | Size | Gets or sets the size of this element marker.
Public Property | Type | Gets or sets a predefined shape for this marker.
Public Property | Visible | Gets or sets a value indicating whether the marker is visible.
Top
See Also

Reference

ElementMarker Class
dotnetCHARTING Namespace

Tutorials

Element Markers

Samples

ElementMarkers


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class : ElementMarker Constructor
ElementMarker Constructor
Overload List
Overload | Description
ElementMarker Constructor(String,Int32) | Initializes an instance of ElementMarker with an image and size.
ElementMarker Constructor(String) | Initializes an instance of ElementMarker with an image.
ElementMarker Constructor(ElementMarkerType,Int32,Color) | Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), size, and color.
ElementMarker Constructor(ElementMarkerType,Int32) | Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), and size.
ElementMarker Constructor(ElementMarkerType) | Initializes an instance of ElementMarker with a built in icon (ElementMarkerType).
ElementMarker Constructor() | Initializes an instance of ElementMarker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor(String,Int32)
Absolute path of an image.
Maximum width or height of the image.
ElementMarker Constructor(String,Int32)
Initializes an instance of ElementMarker with an image and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal imagePath As String, _
   ByVal maxSize As Integer _
)
'Usage

Dim imagePath As String
Dim maxSize As Integer

Dim instance As New ElementMarker(imagePath, maxSize)
public ElementMarker(
   string imagePath,
   int maxSize
)

Parameters

imagePath
Absolute path of an image.
maxSize
Maximum width or height of the image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor(String)
Absolute path of an image.
ElementMarker Constructor(String)
Initializes an instance of ElementMarker with an image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal imagePath As String _
)
'Usage

Dim imagePath As String

Dim instance As New ElementMarker(imagePath)
public ElementMarker(
   string imagePath
)

Parameters

imagePath
Absolute path of an image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor(ElementMarkerType,Int32,Color)
Element marker type of this marker.
The size of this marker.
The color of this marker.
ElementMarker Constructor(ElementMarkerType,Int32,Color)
Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), size, and color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dType As ElementMarkerType, _
   ByVal size As Integer, _
   ByVal color As Color _
)
'Usage

Dim dType As ElementMarkerType
Dim size As Integer
Dim color As Color

Dim instance As New ElementMarker(dType, size, color)
public ElementMarker(
   ElementMarkerType dType,
   int size,
   Color color
)

Parameters

dType
Element marker type of this marker.
size
The size of this marker.
color
The color of this marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor(ElementMarkerType,Int32)
Element marker type of this marker.
The size of this marker.
ElementMarker Constructor(ElementMarkerType,Int32)
Initializes an instance of ElementMarker with a built in icon (ElementMarkerType), and size.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dType As ElementMarkerType, _
   ByVal size As Integer _
)
'Usage

Dim dType As ElementMarkerType
Dim size As Integer

Dim instance As New ElementMarker(dType, size)
public ElementMarker(
   ElementMarkerType dType,
   int size
)

Parameters

dType
Element marker type of this marker.
size
The size of this marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor(ElementMarkerType)
Element marker type of this marker.
ElementMarker Constructor(ElementMarkerType)
Initializes an instance of ElementMarker with a built in icon (ElementMarkerType).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal dType As ElementMarkerType _
)
'Usage

Dim dType As ElementMarkerType

Dim instance As New ElementMarker(dType)
public ElementMarker(
   ElementMarkerType dType
)

Parameters

dType
Element marker type of this marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ElementMarker Class > ElementMarker Constructor : ElementMarker Constructor()
ElementMarker Constructor()
Initializes an instance of ElementMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ElementMarker()
public ElementMarker()
Remarks
This element marker will be empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ElementMarker Class
ElementMarker Class Properties

For a list of all members of this type, see ElementMarker members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this element marker.
Public Property | DynamicImageColor | Gets or sets the color in a specified image that will be replaced by the color of the element it represents.
Public Property | DynamicImageColorTolerance | Gets or sets a value between 0 and 100 that represents the tolerance of the DynamicImageColor allowing the replacing color to affect a wider range of color variation from the specified DynamicImageColor.
Public Property | ImagePath | Gets or sets the image path of this marker.
Public Property | Size | Gets or sets the size of this element marker.
Public Property | Type | Gets or sets a predefined shape for this marker.
Public Property | Visible | Gets or sets a value indicating whether the marker is visible.
Top
See Also

Reference

ElementMarker Class
dotnetCHARTING Namespace

Tutorials

Element Markers

Samples

ElementMarkers


dotnetCHARTING Namespace > ElementMarker Class : Color Property
Color Property (ElementMarker)
Gets or sets the color of this element marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As ElementMarker
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


dotnetCHARTING Namespace > ElementMarker Class : DynamicImageColor Property
DynamicImageColor Property
Gets or sets the color in a specified image that will be replaced by the color of the element it represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicImageColor As Color
'Usage

Dim instance As ElementMarker
Dim value As Color

instance.DynamicImageColor = value

value = instance.DynamicImageColor
public Color DynamicImageColor {get; set;}
Example
Dynamic Color Tolerance
Marker Image Color Replace
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members
ImagePath Property


dotnetCHARTING Namespace > ElementMarker Class : DynamicImageColorTolerance Property
DynamicImageColorTolerance Property
Gets or sets a value between 0 and 100 that represents the tolerance of the DynamicImageColor allowing the replacing color to affect a wider range of color variation from the specified DynamicImageColor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicImageColorTolerance As Integer
'Usage

Dim instance As ElementMarker
Dim value As Integer

instance.DynamicImageColorTolerance = value

value = instance.DynamicImageColorTolerance
public int DynamicImageColorTolerance {get; set;}
Example
Dynamic Image Tolerance
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


dotnetCHARTING Namespace > ElementMarker Class : ImagePath Property
ImagePath Property (ElementMarker)
Gets or sets the image path of this marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImagePath As String
'Usage

Dim instance As ElementMarker
Dim value As String

instance.ImagePath = value

value = instance.ImagePath
public string ImagePath {get; set;}
Example
Element Markers
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


dotnetCHARTING Namespace > ElementMarker Class : Size Property
Size Property (ElementMarker)
Gets or sets the size of this element marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Size As Integer
'Usage

Dim instance As ElementMarker
Dim value As Integer

instance.Size = value

value = instance.Size
public int Size {get; set;}

Property Value

Maximum width or height of this marker.
Example
Gallery A46
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


dotnetCHARTING Namespace > ElementMarker Class : Type Property
Type Property (ElementMarker)
Gets or sets a predefined shape for this marker.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ElementMarkerType
'Usage

Dim instance As ElementMarker
Dim value As ElementMarkerType

instance.Type = value

value = instance.Type
public ElementMarkerType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


dotnetCHARTING Namespace > ElementMarker Class : Visible Property
Visible Property (ElementMarker)
Gets or sets a value indicating whether the marker is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As ElementMarker
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Example
InvisibleElementMarkers
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementMarker Class
ElementMarker Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : EmptyElement Class
EmptyElement Class
Defines the behavior and appearance of empty elements for a given Series.
Object Model
EmptyElement ClassHotspot ClassLine ClassElementMarker ClassSmartLabel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class EmptyElement
'Usage

Dim instance As EmptyElement
public class EmptyElement
Example
Empty Elements 1
Empty Elements 2
Inheritance Hierarchy

System.Object
dotnetCHARTING.EmptyElement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Members
dotnetCHARTING Namespace
EmptyElement Property


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : EmptyElement Class
EmptyElement Class Members

The following tables list the members exposed by EmptyElement.

Public Constructors
 | Name | Description
Public Constructor | EmptyElement Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of empty elements.
Public Property | Hotspot | Gets or sets the Hotspot of this EmptyElement.
Public Property | Line | Gets or sets a line which substitutes a series' Series.Line object when empty elements are drawn.
Public Property | Marker | Gets or sets the marker of empty elements.
Public Property | Mode | Gets or sets the empty element mode.
Public Property | SmartLabel | Gets or sets the label of empty elements.
Public Property | ToolTip | Gets or sets the tool tip of empty elements.
Public Property | URL | Gets or sets the URL of empty elements.
Public Property | URLTarget | Gets or sets the target of URLs of empty elements.
Top
See Also

Reference

EmptyElement Class
dotnetCHARTING Namespace
EmptyElement Property


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class : EmptyElement Constructor
EmptyElement Constructor
Overload List
Overload | Description
EmptyElement Constructor() | Initializes a new instance of the EmptyElement class.
EmptyElement Constructor(String,Color) | Initializes a new instance of the EmptyElement class with a label string and color.
EmptyElement Constructor(String,Color,Color) | Initializes a new instance of the EmptyElement class with a label string, color and marker color.
EmptyElement Constructor(String,Color,Color,ElementMarkerType) | Initializes a new instance of the EmptyElement class with a label string, color, marker color and type.
EmptyElement Constructor(String,Color,ElementMarker) | Initializes a new instance of the EmptyElement class with a label string, color, and marker object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class > EmptyElement Constructor : EmptyElement Constructor()
EmptyElement Constructor()
Initializes a new instance of the EmptyElement class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New EmptyElement()
public EmptyElement()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class > EmptyElement Constructor : EmptyElement Constructor(String,Color)
Empty element label text.
Empty element color.
EmptyElement Constructor(String,Color)
Initializes a new instance of the EmptyElement class with a label string and color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color _
)
'Usage

Dim labelText As String
Dim color As Color

Dim instance As New EmptyElement(labelText, color)
public EmptyElement(
   string labelText,
   Color color
)

Parameters

labelText
Empty element label text.
color
Empty element color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class > EmptyElement Constructor : EmptyElement Constructor(String,Color,Color)
Label text.
Color
Marker color.
EmptyElement Constructor(String,Color,Color)
Initializes a new instance of the EmptyElement class with a label string, color and marker color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color, _
   ByVal markerColor As Color _
)
'Usage

Dim labelText As String
Dim color As Color
Dim markerColor As Color

Dim instance As New EmptyElement(labelText, color, markerColor)
public EmptyElement(
   string labelText,
   Color color,
   Color markerColor
)

Parameters

labelText
Label text.
color
Color
markerColor
Marker color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class > EmptyElement Constructor : EmptyElement Constructor(String,Color,Color,ElementMarkerType)
Label text.
Color
Marker color.
Marker type.
EmptyElement Constructor(String,Color,Color,ElementMarkerType)
Initializes a new instance of the EmptyElement class with a label string, color, marker color and type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color, _
   ByVal markerColor As Color, _
   ByVal markerType As ElementMarkerType _
)
'Usage

Dim labelText As String
Dim color As Color
Dim markerColor As Color
Dim markerType As ElementMarkerType

Dim instance As New EmptyElement(labelText, color, markerColor, markerType)
public EmptyElement(
   string labelText,
   Color color,
   Color markerColor,
   ElementMarkerType markerType
)

Parameters

labelText
Label text.
color
Color
markerColor
Marker color.
markerType
Marker type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > EmptyElement Class > EmptyElement Constructor : EmptyElement Constructor(String,Color,ElementMarker)
Label text.
Color
Marker object.
EmptyElement Constructor(String,Color,ElementMarker)
Initializes a new instance of the EmptyElement class with a label string, color, and marker object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal labelText As String, _
   ByVal color As Color, _
   ByVal marker As ElementMarker _
)
'Usage

Dim labelText As String
Dim color As Color
Dim marker As ElementMarker

Dim instance As New EmptyElement(labelText, color, marker)
public EmptyElement(
   string labelText,
   Color color,
   ElementMarker marker
)

Parameters

labelText
Label text.
color
Color
marker
Marker object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : EmptyElement Class
EmptyElement Class Properties

For a list of all members of this type, see EmptyElement members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of empty elements.
Public Property | Hotspot | Gets or sets the Hotspot of this EmptyElement.
Public Property | Line | Gets or sets a line which substitutes a series' Series.Line object when empty elements are drawn.
Public Property | Marker | Gets or sets the marker of empty elements.
Public Property | Mode | Gets or sets the empty element mode.
Public Property | SmartLabel | Gets or sets the label of empty elements.
Public Property | ToolTip | Gets or sets the tool tip of empty elements.
Public Property | URL | Gets or sets the URL of empty elements.
Public Property | URLTarget | Gets or sets the target of URLs of empty elements.
Top
See Also

Reference

EmptyElement Class
dotnetCHARTING Namespace
EmptyElement Property


dotnetCHARTING Namespace > EmptyElement Class : Color Property
Color Property (EmptyElement)
Gets or sets the color of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As EmptyElement
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Remarks
This property will also affect the colors of this empty element's Line, Marker, and SmartLabel objects.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : Hotspot Property
Hotspot Property (EmptyElement)
Gets or sets the Hotspot of this EmptyElement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As EmptyElement
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : Line Property
Line Property (EmptyElement)
Gets or sets a line which substitutes a series' Series.Line object when empty elements are drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As EmptyElement
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : Marker Property
Marker Property (EmptyElement)
Gets or sets the marker of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As EmptyElement
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Remarks
To active this marker the following settings are required:
EmptyElement.Mode = EmptyElementMode.Fill
EmptyElement.Marker = ElementMarkerType.(any other than 'None')
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : Mode Property
Mode Property (EmptyElement)
Gets or sets the empty element mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As EmptyElementMode
'Usage

Dim instance As EmptyElement
Dim value As EmptyElementMode

instance.Mode = value

value = instance.Mode
public EmptyElementMode Mode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : SmartLabel Property
SmartLabel Property (EmptyElement)
Gets or sets the label of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartLabel As SmartLabel
'Usage

Dim instance As EmptyElement
Dim value As SmartLabel

instance.SmartLabel = value

value = instance.SmartLabel
public SmartLabel SmartLabel {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : ToolTip Property
ToolTip Property (EmptyElement)
Gets or sets the tool tip of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As EmptyElement
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : URL Property
URL Property (EmptyElement)
Gets or sets the URL of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As EmptyElement
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


dotnetCHARTING Namespace > EmptyElement Class : URLTarget Property
URLTarget Property (EmptyElement)
Gets or sets the target of URLs of empty elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As EmptyElement
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

EmptyElement Class
EmptyElement Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : FileManager Class
FileManager Class
Facilitates saving bitmap images and cleanup.
Object Model
FileManager Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class FileManager
'Usage

Dim instance As FileManager
public class FileManager
Inheritance Hierarchy

System.Object
dotnetCHARTING.FileManager

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Members
dotnetCHARTING Namespace

Tutorials

File Handling


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : FileManager Class
FileManager Class Members

The following tables list the members exposed by FileManager.

Public Properties
 | Name | Description
Public Property | Cached | Gets a value indicating whether the chart was renderd or a cached image was used.
Public Property | CachePeriod | Gets or sets a System.TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.
Public Property | CleanupMinimumAge | Gets or sets a System.TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.
Public Property | CleanupPeriod | Gets or sets a System.TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.
Public Property | FileName | Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property | ImageFormat | Gets or sets a ImageFormat Enumeration specifying the image file type.
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Top
Public Methods
 | Name | Description
Public Method | SaveImage | Overloaded. Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
Top
See Also

Reference

FileManager Class
dotnetCHARTING Namespace

Tutorials

File Handling


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : FileManager Class
FileManager Class Methods

For a list of all members of this type, see FileManager members.

Public Methods
 | Name | Description
Public Method | SaveImage | Overloaded. Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
Top
See Also

Reference

FileManager Class
dotnetCHARTING Namespace

Tutorials

File Handling


dotnetCHARTING Namespace > FileManager Class : SaveImage Method
SaveImage Method
Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
Overload List
Overload | Description
SaveImage(MemoryStream,Boolean) | Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
SaveImage(MemoryStream) | Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
SaveImage(Bitmap,Boolean) | Saves a System.Drawing.Bitmap in the TempDirectory and displays it in the chart control.
SaveImage() | Causes the chart to generate and returns the path of the saved image.
SaveImage(Metafile) | Saves a System.Drawing.Imaging.Metafile in the TempDirectory and displays it in the chart control.
SaveImage(Metafile,Boolean) | Saves a System.Drawing.Imaging.Metafile in the TempDirectory and displays it in the chart control.
SaveImage(Bitmap) | Saves a System.Drawing.Bitmap in the TempDirectory and displays it in the chart control.
Example
Box Coordinates
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(MemoryStream,Boolean) Method
for later chart display.
SaveImage(MemoryStream,Boolean) Method
Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal memoryStream As MemoryStream, _
   ByVal fileSaved As Boolean _
) As String
'Usage

Dim instance As FileManager
Dim memoryStream As MemoryStream
Dim fileSaved As Boolean
Dim value As String

value = instance.SaveImage(memoryStream, fileSaved)
public string SaveImage(
   MemoryStream memoryStream,
   bool fileSaved
)

Parameters

memoryStream
fileSaved
for later chart display.

Return Value

Path of the saved file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(MemoryStream) Method
SaveImage(MemoryStream) Method
Saves a System.IO.MemoryStream in the TempDirectory with the format set in chart.ImageFormat chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal memoryStream As MemoryStream _
) As String
'Usage

Dim instance As FileManager
Dim memoryStream As MemoryStream
Dim value As String

value = instance.SaveImage(memoryStream)
public string SaveImage(
   MemoryStream memoryStream
)

Parameters

memoryStream

Return Value

Path of the saved file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(Bitmap,Boolean) Method
System.Drawing.Bitmap to save.
for later chart display.
SaveImage(Bitmap,Boolean) Method
Saves a System.Drawing.Bitmap in the TempDirectory and displays it in the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal bmp As Bitmap, _
   ByVal fileSaved As Boolean _
) As String
'Usage

Dim instance As FileManager
Dim bmp As Bitmap
Dim fileSaved As Boolean
Dim value As String

value = instance.SaveImage(bmp, fileSaved)
public string SaveImage(
   Bitmap bmp,
   bool fileSaved
)

Parameters

bmp
System.Drawing.Bitmap to save.
fileSaved
for later chart display.

Return Value

Path of the saved bitmap.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage() Method
SaveImage() Method
Causes the chart to generate and returns the path of the saved image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage() As String
'Usage

Dim instance As FileManager
Dim value As String

value = instance.SaveImage()
public string SaveImage()

Return Value

Path of the saved image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(Metafile) Method
System.Drawing.Imaging.Metafile to save.
SaveImage(Metafile) Method
Saves a System.Drawing.Imaging.Metafile in the TempDirectory and displays it in the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal mf As Metafile _
) As String
'Usage

Dim instance As FileManager
Dim mf As Metafile
Dim value As String

value = instance.SaveImage(mf)
public string SaveImage(
   Metafile mf
)

Parameters

mf
System.Drawing.Imaging.Metafile to save.

Return Value

Path of the saved image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(Metafile,Boolean) Method
System.Drawing.Imaging.Metafile to save.
for later chart display.
SaveImage(Metafile,Boolean) Method
Saves a System.Drawing.Imaging.Metafile in the TempDirectory and displays it in the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal mf As Metafile, _
   ByVal fileSaved As Boolean _
) As String
'Usage

Dim instance As FileManager
Dim mf As Metafile
Dim fileSaved As Boolean
Dim value As String

value = instance.SaveImage(mf, fileSaved)
public string SaveImage(
   Metafile mf,
   bool fileSaved
)

Parameters

mf
System.Drawing.Imaging.Metafile to save.
fileSaved
for later chart display.

Return Value

Path of the saved image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


dotnetCHARTING Namespace > FileManager Class > SaveImage Method : SaveImage(Bitmap) Method
System.Drawing.Bitmap to save.
SaveImage(Bitmap) Method
Saves a System.Drawing.Bitmap in the TempDirectory and displays it in the chart control.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveImage( _
   ByVal bmp As Bitmap _
) As String
'Usage

Dim instance As FileManager
Dim bmp As Bitmap
Dim value As String

value = instance.SaveImage(bmp)
public string SaveImage(
   Bitmap bmp
)

Parameters

bmp
System.Drawing.Bitmap to save.

Return Value

Path of the saved bitmap.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : FileManager Class
FileManager Class Properties

For a list of all members of this type, see FileManager members.

Public Properties
 | Name | Description
Public Property | Cached | Gets a value indicating whether the chart was renderd or a cached image was used.
Public Property | CachePeriod | Gets or sets a System.TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.
Public Property | CleanupMinimumAge | Gets or sets a System.TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.
Public Property | CleanupPeriod | Gets or sets a System.TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.
Public Property | FileName | Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Public Property | ImageFormat | Gets or sets a ImageFormat Enumeration specifying the image file type.
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored.
Top
See Also

Reference

FileManager Class
dotnetCHARTING Namespace

Tutorials

File Handling


dotnetCHARTING Namespace > FileManager Class : Cached Property
Cached Property
Gets a value indicating whether the chart was renderd or a cached image was used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Cached As Boolean
'Usage

Dim instance As FileManager
Dim value As Boolean

value = instance.Cached
public bool Cached {get;}
Remarks
If false no special processing is required because a cached image will be displayed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members

Tutorials

File Handling


dotnetCHARTING Namespace > FileManager Class : CachePeriod Property
CachePeriod Property
Gets or sets a System.TimeSpan object that determines the amount of time an image is cached and displayed on a page before a new one is generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CachePeriod As TimeSpan
'Usage

Dim instance As FileManager
Dim value As TimeSpan

instance.CachePeriod = value

value = instance.CachePeriod
public TimeSpan CachePeriod {get; set;}
Remarks
When set, a given chart image will be generated on the first hit and on all subsequent hits within the cache duration period, the same image will be returned with no rendering work by the chart control.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


dotnetCHARTING Namespace > FileManager Class : CleanupMinimumAge Property
CleanupMinimumAge Property (FileManager)
Gets or sets a System.TimeSpan object that determines the minimum amount of time images are stored in the TempDirectory folder before they are deleted.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CleanupMinimumAge As TimeSpan
'Usage

Dim instance As FileManager
Dim value As TimeSpan

instance.CleanupMinimumAge = value

value = instance.CleanupMinimumAge
public TimeSpan CleanupMinimumAge {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


Example

dotnetCHARTING Namespace > FileManager Class : CleanupPeriod Property
CleanupPeriod Property (FileManager)
Gets or sets a System.TimeSpan object that determines the amount of time the TempDirectory folder would be checked for deleting old image files.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CleanupPeriod As TimeSpan
'Usage

Dim instance As FileManager
Dim value As TimeSpan

instance.CleanupPeriod = value

value = instance.CleanupPeriod
public TimeSpan CleanupPeriod {get; set;}
Example
This example sets the cleanup period every 30 minutes.
  • C#
Chart.FileManager.CleanupPeriod= new TimeSpan(0,30,0);
  • Visual Basic
Chart.FileManager.CleanupPeriod= New TimeSpan(0,30,0)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


Example

dotnetCHARTING Namespace > FileManager Class : FileName Property
FileName Property (FileManager)
Sets the file name to save an image as, or gets the file name of an image that has been saved in the TempDirectory after a chart is generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileName As String
'Usage

Dim instance As FileManager
Dim value As String

instance.FileName = value

value = instance.FileName
public string FileName {get; set;}
Remarks
When empty, a random name will be created. In order for the cleanup system to include custom file names they must start with 'dnc-', the mask is: 'dnc-*.*'.
Example
  • C#
Chart.FileManager.FileName="saleChart";
  • Visual Basic
Chart.FileManager.FileName="saleChart"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


Example

dotnetCHARTING Namespace > FileManager Class : FileQuality Property
FileQuality Property (FileManager)
Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FileQuality As Long
'Usage

Dim instance As FileManager
Dim value As Long

instance.FileQuality = value

value = instance.FileQuality
public long FileQuality {get; set;}
Example
  • C#
Chart.FileManager.FileQuality=75;
  • Visual Basic
Chart.FileManager.FileQuality=75
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


Example

dotnetCHARTING Namespace > FileManager Class : ImageFormat Property
ImageFormat Property (FileManager)
Gets or sets a ImageFormat Enumeration specifying the image file type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageFormat As ImageFormat
'Usage

Dim instance As FileManager
Dim value As ImageFormat

instance.ImageFormat = value

value = instance.ImageFormat
public ImageFormat ImageFormat {get; set;}
Example
  • C#
Chart.FileManager.ImageFormat=ImageFormat.Png;
  • Visual Basic
Chart.FileManager.ImageFormat=ImageFormat.Png
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


Example

dotnetCHARTING Namespace > FileManager Class : TempDirectory Property
TempDirectory Property (FileManager)
Gets or sets the directory where images generated by the control are temporarily stored.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TempDirectory As String
'Usage

Dim instance As FileManager
Dim value As String

instance.TempDirectory = value

value = instance.TempDirectory
public string TempDirectory {get; set;}
Remarks
This property takes either an absolute path 'c:/inetpub/wwwroot/app/tmp', a relative path ('tmp', '../tmp',) or when started with '/' a relative path from c:/inetpub/wwwroot/ ('/app/tmp).
Example
This examples demonstrate different ways of accessing the same folder: 'c:/inetpub/wwwroot/app/tmp' when the applications is located in ...wwwroot/app. when started with '/' the folder resets to c:/inetpub/wwwroot/.
  • C#
Chart.FileManager.TempDirectory = "c://inetpub/wwwroot/app/tmp";
Chart.FileManager.TempDirectory = "/app/tmp";
Chart.FileManager.TempDirectory = "tmp";
  • Visual Basic
Chart.FileManager.TempDirectory = "c://inetpub/wwwroot/app/tmp"
Chart.FileManager.TempDirectory = "/app/tmp"
Chart.FileManager.TempDirectory = "tmp"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FileManager Class
FileManager Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : FinancialEngine Class
FinancialEngine Class
Provides a set of methods that perform financial analysis of series and series collections.
Object Model
FinancialEngine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FinancialEngine
'Usage

Dim instance As FinancialEngine
public sealed class FinancialEngine
Inheritance Hierarchy

System.Object
dotnetCHARTING.FinancialEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Methods

dotnetCHARTING Namespace : FinancialEngine Class
FinancialEngine Class Members

The following tables list the members exposed by FinancialEngine.

Public Methods
Name | Description
static (Shared in Visual Basic) | AcumulateDistributeOverPeriod | Overloaded. Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
static (Shared in Visual Basic) | AroonDown | Overloaded. Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AroonDownOverPeriod | Overloaded. Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AroonOscillator | Overloaded. Evaluates the Aroon Oscillator over the a given period.
static (Shared in Visual Basic) | AroonOscillatorOverPeriod | Overloaded. Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
static (Shared in Visual Basic) | AroonUp | Overloaded. Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
static (Shared in Visual Basic) | AroonUpOverPeriod | Overloaded. Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AveragePrice | Overloaded. Evaluates the Average Price for each periods of a collection of periods.
static (Shared in Visual Basic) | BalanceOfPowerOverPeriod | Overloaded. Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
static (Shared in Visual Basic) | BollingerBands | Overloaded. Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
static (Shared in Visual Basic) | ChaikinMoneyFlowOverPeriod | Overloaded. Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
static (Shared in Visual Basic) | ChaikinOscillator | Overloaded. This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
static (Shared in Visual Basic) | ChaikinVolatility | Overloaded. Chaikin's Volatility indicator compares the spread between a security's high and low prices.
static (Shared in Visual Basic) | CommodityChannelIdxOverPeriod | Overloaded. This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
static (Shared in Visual Basic) | CrossingExtremeSignal | Overloaded. This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
static (Shared in Visual Basic) | CrossingSignal | Overloaded. Implements a general framework for producing trading signals based on the crossing of two Stochastics.
static (Shared in Visual Basic) | DirectionalMotion | Overloaded. Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
static (Shared in Visual Basic) | DMISignal | Overloaded. Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
static (Shared in Visual Basic) | DStochastic | Overloaded. Evaluate the (general) %D Stochastic.
static (Shared in Visual Basic) | ExponentiallyWeightedMovingAverage | Overloaded. Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | ExtremeValueDSignal | Overloaded. Implements a general framework for producing extreme value trading signals using Stochastic indicators.
static (Shared in Visual Basic) | ExtremeValueKSignal | Overloaded. Implements a general framework for producing extreme value trading signals using Stochastic indicators.
static (Shared in Visual Basic) | FiniteImpulseResponse | Overloaded. Calculates a Finite Impulse Response Filter.
static (Shared in Visual Basic) | GeometricMean | Overloaded. Calculates the geometric mean of the series's elements values.
static (Shared in Visual Basic) | GeometricMovingAverage | Overloaded. Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | HighestPeriod | Overloaded. Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
static (Shared in Visual Basic) | InterQuartileRange | Overloaded. Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
static (Shared in Visual Basic) | Kairi | Overloaded. Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
static (Shared in Visual Basic) KFastStochastic Overloaded. Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

static (Shared in Visual Basic) | Kurtosis | Overloaded. Calculates the kurtosis of the currently registered data set.
static (Shared in Visual Basic) | LinearMovingAverage | Overloaded. Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
static (Shared in Visual Basic) | LowerBollingerBands | Overloaded. Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | LowestPeriod | Overloaded. Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
static (Shared in Visual Basic) | MarketFacilitationIndex | Overloaded. Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
static (Shared in Visual Basic) | Mean | Overloaded. Calculates the arithmetic mean of the elements values of the series.
static (Shared in Visual Basic) | MeanDeviation | Overloaded. Calculates the mean deviation of the series's element values.
static (Shared in Visual Basic) | Median | Overloaded. Calculates the mean deviation of the series's element YValues.
static (Shared in Visual Basic) | MedianMovingAverage | Overloaded. Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
static (Shared in Visual Basic) | MedianPrice | Overloaded. Evaluates the Median Price of an asset for a given trading period.
static (Shared in Visual Basic) | MinusDirectionalMovement | Overloaded. Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
static (Shared in Visual Basic) | Momentum | Overloaded. We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
static (Shared in Visual Basic) | MomentumPercent | Overloaded. We calculate the momentum pergentage over a given period.
static (Shared in Visual Basic) | MoneyFlowIdxOverPeriod | Overloaded. Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
static (Shared in Visual Basic) | NegativeVolumeIndex | Overloaded. We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
static (Shared in Visual Basic) | OnBalanceVolume | Overloaded. On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
static (Shared in Visual Basic) | Percentile | Overloaded. Calculates the n-th percentile of the series.
static (Shared in Visual Basic) | Percentile25 | Overloaded. Calculates the first percentile of the series.
static (Shared in Visual Basic) | Percentile50 | Overloaded. Calculates the second percentile of the series.
static (Shared in Visual Basic) | Percentile75 | Overloaded. Calculates the third percentile of the series.
static (Shared in Visual Basic) | PlusDirectionalMovement | Overloaded. Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
static (Shared in Visual Basic) | PositiveVolumeIndex | Overloaded. We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
static (Shared in Visual Basic) | PriceActionIndicator | Overloaded. Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
static (Shared in Visual Basic) | Range | Overloaded. Calculates the range of the series's elements values.
static (Shared in Visual Basic) | RateOfChange | Overloaded. Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
static (Shared in Visual Basic) | RelativeStrengthIndex | Overloaded. Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
static (Shared in Visual Basic) | SimpleMovingAverage | Overloaded. Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | Skewness | Overloaded. Calculates the skewness of the currently registered data set.
static (Shared in Visual Basic) | StandardDeviation | Overloaded. Calculates the sample standard variance of the series's elements values.
static (Shared in Visual Basic) | TriangularMovingAverage | Overloaded. Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | TrueRange | Overloaded. True Range (TR) of a traded asset over a number of periods.
static (Shared in Visual Basic) | TypicalPrice | Overloaded. Evaluates the Typical Price of an asset within a given trading period.
static (Shared in Visual Basic) | UpperBollingerBands | Overloaded. Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Variance | Overloaded. Calculates the sample variance of the series's elements values.
static (Shared in Visual Basic) | WeightedMovingAverage | Overloaded. Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
static (Shared in Visual Basic) | ZScore | Overloaded. Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Top
See Also

Reference

FinancialEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : FinancialEngine Class
FinancialEngine Class Methods

For a list of all members of this type, see FinancialEngine members.

Public Methods
Name | Description
static (Shared in Visual Basic) | AcumulateDistributeOverPeriod | Overloaded. Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
static (Shared in Visual Basic) | AroonDown | Overloaded. Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AroonDownOverPeriod | Overloaded. Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AroonOscillator | Overloaded. Evaluates the Aroon Oscillator over the a given period.
static (Shared in Visual Basic) | AroonOscillatorOverPeriod | Overloaded. Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
static (Shared in Visual Basic) | AroonUp | Overloaded. Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
static (Shared in Visual Basic) | AroonUpOverPeriod | Overloaded. Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | AveragePrice | Overloaded. Evaluates the Average Price for each periods of a collection of periods.
static (Shared in Visual Basic) | BalanceOfPowerOverPeriod | Overloaded. Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
static (Shared in Visual Basic) | BollingerBands | Overloaded. Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
static (Shared in Visual Basic) | ChaikinMoneyFlowOverPeriod | Overloaded. Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
static (Shared in Visual Basic) | ChaikinOscillator | Overloaded. This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
static (Shared in Visual Basic) | ChaikinVolatility | Overloaded. Chaikin's Volatility indicator compares the spread between a security's high and low prices.
static (Shared in Visual Basic) | CommodityChannelIdxOverPeriod | Overloaded. This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
static (Shared in Visual Basic) | CrossingExtremeSignal | Overloaded. This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
static (Shared in Visual Basic) | CrossingSignal | Overloaded. Implements a general framework for producing trading signals based on the crossing of two Stochastics.
static (Shared in Visual Basic) | DirectionalMotion | Overloaded. Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
static (Shared in Visual Basic) | DMISignal | Overloaded. Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
static (Shared in Visual Basic) | DStochastic | Overloaded. Evaluate the (general) %D Stochastic.
static (Shared in Visual Basic) | ExponentiallyWeightedMovingAverage | Overloaded. Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | ExtremeValueDSignal | Overloaded. Implements a general framework for producing extreme value trading signals using Stochastic indicators.
static (Shared in Visual Basic) | ExtremeValueKSignal | Overloaded. Implements a general framework for producing extreme value trading signals using Stochastic indicators.
static (Shared in Visual Basic) | FiniteImpulseResponse | Overloaded. Calculates a Finite Impulse Response Filter.
static (Shared in Visual Basic) | GeometricMean | Overloaded. Calculates the geometric mean of the series's elements values.
static (Shared in Visual Basic) | GeometricMovingAverage | Overloaded. Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | HighestPeriod | Overloaded. Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
static (Shared in Visual Basic) | InterQuartileRange | Overloaded. Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
static (Shared in Visual Basic) | Kairi | Overloaded. Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
static (Shared in Visual Basic) KFastStochastic Overloaded. Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

static (Shared in Visual Basic) | Kurtosis | Overloaded. Calculates the kurtosis of the currently registered data set.
static (Shared in Visual Basic) | LinearMovingAverage | Overloaded. Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
static (Shared in Visual Basic) | LowerBollingerBands | Overloaded. Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | LowestPeriod | Overloaded. Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
static (Shared in Visual Basic) | MarketFacilitationIndex | Overloaded. Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
static (Shared in Visual Basic) | Mean | Overloaded. Calculates the arithmetic mean of the elements values of the series.
static (Shared in Visual Basic) | MeanDeviation | Overloaded. Calculates the mean deviation of the series's element values.
static (Shared in Visual Basic) | Median | Overloaded. Calculates the mean deviation of the series's element YValues.
static (Shared in Visual Basic) | MedianMovingAverage | Overloaded. Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
static (Shared in Visual Basic) | MedianPrice | Overloaded. Evaluates the Median Price of an asset for a given trading period.
static (Shared in Visual Basic) | MinusDirectionalMovement | Overloaded. Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
static (Shared in Visual Basic) | Momentum | Overloaded. We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
static (Shared in Visual Basic) | MomentumPercent | Overloaded. We calculate the momentum pergentage over a given period.
static (Shared in Visual Basic) | MoneyFlowIdxOverPeriod | Overloaded. Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
static (Shared in Visual Basic) | NegativeVolumeIndex | Overloaded. We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
static (Shared in Visual Basic) | OnBalanceVolume | Overloaded. On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
static (Shared in Visual Basic) | Percentile | Overloaded. Calculates the n-th percentile of the series.
static (Shared in Visual Basic) | Percentile25 | Overloaded. Calculates the first percentile of the series.
static (Shared in Visual Basic) | Percentile50 | Overloaded. Calculates the second percentile of the series.
static (Shared in Visual Basic) | Percentile75 | Overloaded. Calculates the third percentile of the series.
static (Shared in Visual Basic) | PlusDirectionalMovement | Overloaded. Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
static (Shared in Visual Basic) | PositiveVolumeIndex | Overloaded. We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
static (Shared in Visual Basic) | PriceActionIndicator | Overloaded. Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
static (Shared in Visual Basic) | Range | Overloaded. Calculates the range of the series's elements values.
static (Shared in Visual Basic) | RateOfChange | Overloaded. Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
static (Shared in Visual Basic) | RelativeStrengthIndex | Overloaded. Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
static (Shared in Visual Basic) | SimpleMovingAverage | Overloaded. Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | Skewness | Overloaded. Calculates the skewness of the currently registered data set.
static (Shared in Visual Basic) | StandardDeviation | Overloaded. Calculates the sample standard variance of the series's elements values.
static (Shared in Visual Basic) | TriangularMovingAverage | Overloaded. Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | TrueRange | Overloaded. True Range (TR) of a traded asset over a number of periods.
static (Shared in Visual Basic) | TypicalPrice | Overloaded. Evaluates the Typical Price of an asset within a given trading period.
static (Shared in Visual Basic) | UpperBollingerBands | Overloaded. Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Variance | Overloaded. Calculates the sample variance of the series's elements values.
static (Shared in Visual Basic) | WeightedMovingAverage | Overloaded. Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
static (Shared in Visual Basic) | ZScore | Overloaded. Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Top
See Also

Reference

FinancialEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > FinancialEngine Class : AcumulateDistributeOverPeriod Method
AcumulateDistributeOverPeriod Method
Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
Overload List
Overload | Description
AcumulateDistributeOverPeriod(String,Series,Int32) | Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
AcumulateDistributeOverPeriod(Series,Int32) | Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
AcumulateDistributeOverPeriod(SeriesCollection,Int32) | Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > AcumulateDistributeOverPeriod Method : AcumulateDistributeOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first term is the most recent period, the second term is the previous period and so on.
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
AcumulateDistributeOverPeriod(String,Series,Int32) Method
Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AcumulateDistributeOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AcumulateDistributeOverPeriod(seriesName, s, lengthOfPeriod)
public static Series AcumulateDistributeOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution(string, Series)) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AcumulateDistributeOverPeriod Method : AcumulateDistributeOverPeriod(Series,Int32) Method
A series where the first term is the most recent period, the second term is the previous period and so on.
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
AcumulateDistributeOverPeriod(Series,Int32) Method
Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AcumulateDistributeOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AcumulateDistributeOverPeriod(s, lengthOfPeriod)
public static Series AcumulateDistributeOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
A series where the first term is the most recent period, the second term is the previous period and so on.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AcumulateDistributeOverPeriod Method : AcumulateDistributeOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
AcumulateDistributeOverPeriod(SeriesCollection,Int32) Method
Evaluates the accumulation/distribution indicator for each of the (sub)collection of periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AcumulateDistributeOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.AcumulateDistributeOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection AcumulateDistributeOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods within each of the (sub)collection of periods over which the indicator is evaluated.
Remarks

The accumulation/distribution indicator illustrates the degree to which an asset is being accumulated or distributed by the market over each of these collection of periods. The indicator uses the closing price's proximity to the high or low over the period to determine if accumulation or reduction is taking place in the market. The proximity measure if then multiplied by the volume over the period in order to give more weight to moves with correspondingly higher volume.

Interpretation

A divergence between the price action and the AccumulationDistribution indicator can signal that a trend is nearing completion, a trends continuation and break-outs from trading ranges. The actual value of this indicator is of no significance, what is significant is its change in value relative to the previous periods which can warn of a possible break-out during a trading range (falling/rising indicator), the continuation of a trend (higher highs in uptrend, or lower lows in downtrend) or a change/completion of a trend (divergence between the price action and the direction of the indicator).

Example

Say for example we know that:

  1. Highs = {3, 4, 3, 4, 5} (i.e. 3 is the latest high)
  2. Lows = {2, 1, 2, 1, 3} (i.e. 2 is the latest low)
  3. Volume = {300, 290, 295, 285, 290} (i.e. 300 is the volume in the latest period.

Now if the lengthOfPeriod considered is 4, then this method will return an array of length two where the first term is the accumulation\distribution indicator (evaluated using AccumulationDistribution) when:

  1. Highs = {3, 4, 3, 4} (i.e. above highs with last element removed)
  2. Lows = {2, 1, 2, 1} (i.e. above highs with last element removed)
  3. Volume = {300, 290, 295, 285} (i.e. above highs with last element removed)
and the second term is the accumulation/distribution indicator when:
  1. Highs = {4, 3, 4, 5} (i.e. the window moves one position back)
  2. Lows = {1, 2, 1, 3} (i.e. the window moves one position back)
  3. Volume = {290, 295, 285, 290} (i.e. the window moves one position back)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : AroonDown Method
AroonDown Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Overload List
Overload | Description
AroonDown(String,Series) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
AroonDown(Series) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
AroonDown(String,SeriesCollection) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
AroonDown(SeriesCollection) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Samples

AroonIndicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonDown Method : AroonDown(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
AroonDown(String,Series) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDown( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = FinancialEngine.AroonDown(elementName, s)
public static Element AroonDown(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonDown Method : AroonDown(Series) Method
A financial series.
AroonDown(Series) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDown( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = FinancialEngine.AroonDown(s)
public static Element AroonDown(
   Series s
)

Parameters

s
A financial series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonDown Method : AroonDown(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonDown(String,SeriesCollection) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDown( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonDown(seriesName, sc)
public static Series AroonDown(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonDown Method : AroonDown(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonDown(SeriesCollection) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDown( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonDown(sc)
public static Series AroonDown(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonDown indicator and calculates the values of the Aroon Down indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class : AroonDownOverPeriod Method
AroonDownOverPeriod Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Overload List
Overload | Description
AroonDownOverPeriod(String,Series,Int32) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
AroonDownOverPeriod(Series,Int32) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
AroonDownOverPeriod(SeriesCollection,Int32) | Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Samples

Aroon Indicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonDownOverPeriod Method : AroonDownOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonDownOverPeriod(String,Series,Int32) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDownOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonDownOverPeriod(seriesName, s, lengthOfPeriod)
public static Series AroonDownOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks
The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class > AroonDownOverPeriod Method : AroonDownOverPeriod(Series,Int32) Method
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonDownOverPeriod(Series,Int32) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDownOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonDownOverPeriod(s, lengthOfPeriod)
public static Series AroonDownOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
A financial series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks
The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class > AroonDownOverPeriod Method : AroonDownOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonDownOverPeriod(SeriesCollection,Int32) Method
Calculates the Aroon Down indicator which measures the relative time since the last lowest low for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonDownOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.AroonDownOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection AroonDownOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks
The indicator for each period will return a value between 0 and 100, where a higher value indicates that the lowest low was achieved more recently. Persistent values between 70 and 100 are said to indicate weakness in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Up indicator, indicates an downward trend.

Evaluation of the Aroon Down Indicator

The Aroon Down indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of FinancialAroonDownOverPeriod indicator and calculates the Aroon Down indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class : AroonOscillator Method
AroonOscillator Method
Evaluates the Aroon Oscillator over the a given period.
Overload List
Overload | Description
AroonOscillator(String,Series) | Evaluates the Aroon Oscillator over the a given period.
AroonOscillator(Series) | Evaluates the Aroon Oscillator over the a given period.
AroonOscillator(String,SeriesCollection) | Evaluates the Aroon Oscillator over the a given period.
AroonOscillator(SeriesCollection) | Evaluates the Aroon Oscillator over the a given period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Sample

Aroon Indicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillator Method : AroonOscillator(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
AroonOscillator(String,Series) Method
Evaluates the Aroon Oscillator over the a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillator( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = FinancialEngine.AroonOscillator(elementName, s)
public static Element AroonOscillator(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillator Method : AroonOscillator(Series) Method
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
AroonOscillator(Series) Method
Evaluates the Aroon Oscillator over the a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillator( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = FinancialEngine.AroonOscillator(s)
public static Element AroonOscillator(
   Series s
)

Parameters

s
A series where the first term is the traded low of the asset within the most recent trading period, the second term is the traded low of the asset within the previous period and so on.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillator Method : AroonOscillator(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonOscillator(String,SeriesCollection) Method
Evaluates the Aroon Oscillator over the a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillator( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonOscillator(seriesName, sc)
public static Series AroonOscillator(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillator Method : AroonOscillator(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonOscillator(SeriesCollection) Method
Evaluates the Aroon Oscillator over the a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillator( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonOscillator(sc)
public static Series AroonOscillator(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
calculates the values of the Aroon Oscillator indicator over all sub-periods of a given length.


dotnetCHARTING Namespace > FinancialEngine Class : AroonOscillatorOverPeriod Method
AroonOscillatorOverPeriod Method
Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
Overload List
Overload | Description
AroonOscillatorOverPeriod(String,Series,Int32) | Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
AroonOscillatorOverPeriod(Series,Int32) | Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
AroonOscillatorOverPeriod(SeriesCollection,Int32) | Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Sample

Aroon Indicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillatorOverPeriod Method : AroonOscillatorOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonOscillatorOverPeriod(String,Series,Int32) Method
Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillatorOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonOscillatorOverPeriod(seriesName, s, lengthOfPeriod)
public static Series AroonOscillatorOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillatorOverPeriod Method : AroonOscillatorOverPeriod(Series,Int32) Method
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonOscillatorOverPeriod(Series,Int32) Method
Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillatorOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonOscillatorOverPeriod(s, lengthOfPeriod)
public static Series AroonOscillatorOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
A series where the first term is the traded high of the asset within the most recent trading period, the second term is the traded high of the asset within the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AroonOscillatorOverPeriod Method : AroonOscillatorOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonOscillatorOverPeriod(SeriesCollection,Int32) Method
Evaluates the Aroon Oscillator over all periods where sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonOscillatorOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.AroonOscillatorOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection AroonOscillatorOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

A series where the first term is the value of the Aroon Oscillator for the most recent period, the second term is the value of the Aroon Oscillator for the previous period and so on.
Remarks

Evaluation of the Aroon Oscillator

The Aroon Oscillator over each period is evaluated using the following formulae:

Aroon Oscillator = (Aroon Up Indicator) - (Aroon Down Indicator)

where 'Aroon Up Indicator' and `Aroon Down Indicator' are evaluated using.

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

The Aroon Down indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : AroonUp Method
AroonUp Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Overload List
Overload | Description
AroonUp(String,Series) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
AroonUp(Series) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
AroonUp(String,SeriesCollection) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
AroonUp(SeriesCollection) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Sample

Aroon Indicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonUp Method : AroonUp(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
AroonUp(String,Series) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUp( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = FinancialEngine.AroonUp(elementName, s)
public static Element AroonUp(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
Remarks
The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonUp Method : AroonUp(Series) Method
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
AroonUp(Series) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUp( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = FinancialEngine.AroonUp(s)
public static Element AroonUp(
   Series s
)

Parameters

s
A series of the trading highs over the last n-periods where the k-th terms of the array if the trading high on the k-th previous period.
Remarks
The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonUp Method : AroonUp(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonUp(String,SeriesCollection) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUp( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonUp(seriesName, sc)
public static Series AroonUp(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class > AroonUp Method : AroonUp(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AroonUp(SeriesCollection) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUp( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = FinancialEngine.AroonUp(sc)
public static Series AroonUp(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The indicator will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range (i.e. 0-30) in the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a generalization of AroonUp indicator and calculates the values of the Aroon Up indicator over all sub-periods of a given length for all possible periods for which sufficient historical data is provided.


dotnetCHARTING Namespace > FinancialEngine Class : AroonUpOverPeriod Method
AroonUpOverPeriod Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
Overload List
Overload | Description
AroonUpOverPeriod(String,Series,Int32) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
AroonUpOverPeriod(Series,Int32) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
AroonUpOverPeriod(SeriesCollection,Int32) | Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Sample

Aroon Indicators


dotnetCHARTING Namespace > FinancialEngine Class > AroonUpOverPeriod Method : AroonUpOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonUpOverPeriod(String,Series,Int32) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUpOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonUpOverPeriod(seriesName, s, lengthOfPeriod)
public static Series AroonUpOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.
Remarks
This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class > AroonUpOverPeriod Method : AroonUpOverPeriod(Series,Int32) Method
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonUpOverPeriod(Series,Int32) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUpOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.AroonUpOverPeriod(s, lengthOfPeriod)
public static Series AroonUpOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
An financial series of the trading highs over the last n-periods where the k-th term of the array if the trading high on the k-th previous period.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.
Remarks
This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class > AroonUpOverPeriod Method : AroonUpOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
AroonUpOverPeriod(SeriesCollection,Int32) Method
Evaluates the Aroon Up indicator which measures the relative time since the last highest high for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AroonUpOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.AroonUpOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection AroonUpOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.

Return Value

Returnsa series where the first term is the values of the Aroon Up indicator over the earliest set of consecutive periods and the second term is the value of the next set of the periods (i.e. the windows is moving one place along), and so on.
Remarks
This indicator for each period will return a value between 0 and 100, where a higher value indicates that the highest high was achieved more recently. Persistent values between 70 and 100 are said to indicate strength in the asset and in conjunction with a low range(i.e. 0-30) of the Aroon Down indicator, indicates an upward trend.

Evaluation of the Aroon Up Indicator

The Aroon Up indicator for each period is given by:

100(n - (number of days since last highest high over n days))/n

where n is the number of days being considered (a reasonable default value for n is 14).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
This indicator is a special case of AroonUpOverPeriod indicator and calculates the Aroon Up indicator for a single period.


dotnetCHARTING Namespace > FinancialEngine Class : AveragePrice Method
AveragePrice Method
Evaluates the Average Price for each periods of a collection of periods.
Overload List
Overload | Description
AveragePrice(String,Series) | Evaluates the Average Price for each periods of a collection of periods.
AveragePrice(Series) | Evaluates the Average Price for each periods of a collection of periods.
AveragePrice(SeriesCollection) | Evaluates the Average Price for each periods of a collection of periods.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members

Samples

Price Action Indicator


dotnetCHARTING Namespace > FinancialEngine Class > AveragePrice Method : AveragePrice(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series, where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
AveragePrice(String,Series) Method
Evaluates the Average Price for each periods of a collection of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AveragePrice( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.AveragePrice(seriesName, s)
public static Series AveragePrice(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series, where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.

Return Value

A series where the first element is the Average Price of the asset on the most recent period considered, the second term is the Average Price on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the High, Low, Open, Close are strictly negative.
Remarks
The Average price is just the average of the High, Low, Open and Close of each of the trading periods ranges, where the period considered will generally a day, however the Average price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AveragePrice Method : AveragePrice(Series) Method
A financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
AveragePrice(Series) Method
Evaluates the Average Price for each periods of a collection of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AveragePrice( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.AveragePrice(s)
public static Series AveragePrice(
   Series s
)

Parameters

s
A financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.

Return Value

A series where the first element is the Average Price of the asset on the most recent period considered, the second term is the Average Price on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the High, Low, Open, Close are strictly negative.
Remarks
The Average price is just the average of the High, Low, Open and Close of each of the trading periods ranges, where the period considered will generally a day, however the Average price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > AveragePrice Method : AveragePrice(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
AveragePrice(SeriesCollection) Method
Evaluates the Average Price for each periods of a collection of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function AveragePrice( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.AveragePrice(sc)
public static SeriesCollection AveragePrice(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The Average price is just the average of the High, Low, Open and Close of each of the trading periods ranges, where the period considered will generally a day, however the Average price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : BalanceOfPowerOverPeriod Method
BalanceOfPowerOverPeriod Method
Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
Overload List
Overload | Description
BalanceOfPowerOverPeriod(String,Series) | Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
BalanceOfPowerOverPeriod(Series) | Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
BalanceOfPowerOverPeriod(SeriesCollection) | Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
Example
MarketStrength
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > BalanceOfPowerOverPeriod Method : BalanceOfPowerOverPeriod(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
BalanceOfPowerOverPeriod(String,Series) Method
Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BalanceOfPowerOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.BalanceOfPowerOverPeriod(seriesName, s)
public static Series BalanceOfPowerOverPeriod(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.

Return Value

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.
Remarks
An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > BalanceOfPowerOverPeriod Method : BalanceOfPowerOverPeriod(Series) Method
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
BalanceOfPowerOverPeriod(Series) Method
Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BalanceOfPowerOverPeriod( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.BalanceOfPowerOverPeriod(s)
public static Series BalanceOfPowerOverPeriod(
   Series s
)

Parameters

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.

Return Value

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.
Remarks
An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > BalanceOfPowerOverPeriod Method : BalanceOfPowerOverPeriod(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
BalanceOfPowerOverPeriod(SeriesCollection) Method
Evaluates the Balance of Power (BOP) indicator, created by Igor Livshin; which captures the struggle between the Bulls and Bears over a number of trading days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BalanceOfPowerOverPeriod( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.BalanceOfPowerOverPeriod(sc)
public static SeriesCollection BalanceOfPowerOverPeriod(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Return Value

A series is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows, closes or opens are strictly negative.
Remarks
An array is returned where the first term corresponds to the BOP of the last trading day, the second term gives the BOP on the previous trading day and so on.

Interpretation

The BOP indicator for each trading day lies within the range [-1,1]. When the BOP indicator is towards the high if its range it will signifies that the Bulls are in control, conversely when the indicator is towards the lows of its range it signifies that the bear are in control. If the indicator move from a high positive range to a lower positive range it signifies that the buying pressure is decreasing. Conversely, if the indicator move from a low negative range to a higher negative range it signifies that the selling pressure is decreasing.

Evaluation

The BOP indicator for each trading days is evaluated by the following formulae:

BOP = (Close - Open)/(High - Low)

where close is the days closing price, open is the days opening price, high is the highest traded price during the day and low is the lowest traded price during the day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : BollingerBands Method
BollingerBands Method (FinancialEngine)
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Overload List
Overload | Description
BollingerBands(Series,ElementValue,Double,Int32) | Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
BollingerBands(SeriesCollection,ElementValue,Double,Int32) | Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > BollingerBands Method : BollingerBands(Series,ElementValue,Double,Int32) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
BollingerBands(Series,ElementValue,Double,Int32) Method
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.BollingerBands(s, elementValue, standardDeviationLevel, lengthOfMA)
public static SeriesCollection BollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > BollingerBands Method : BollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
BollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.BollingerBands(sc, elementValue, standardDeviationLevel, lengthOfMA)
public static SeriesCollection BollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ChaikinMoneyFlowOverPeriod Method
ChaikinMoneyFlowOverPeriod Method
Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
Overload List
Overload | Description
ChaikinMoneyFlowOverPeriod(String,Series,Int32) | Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
ChaikinMoneyFlowOverPeriod(Series,Int32) | Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
ChaikinMoneyFlowOverPeriod(SeriesCollection,Int32) | Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
Example
ChaikinIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinMoneyFlowOverPeriod Method : ChaikinMoneyFlowOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series.
An integer which represents the number of periods over which the indicator is calculated.
ChaikinMoneyFlowOverPeriod(String,Series,Int32) Method
Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.ChaikinMoneyFlowOverPeriod(seriesName, s, lengthOfPeriod)
public static Series ChaikinMoneyFlowOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
Remarks
In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinMoneyFlowOverPeriod Method : ChaikinMoneyFlowOverPeriod(Series,Int32) Method
A financial series.
An integer which represents the number of periods over which the indicator is calculated.
ChaikinMoneyFlowOverPeriod(Series,Int32) Method
Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.ChaikinMoneyFlowOverPeriod(s, lengthOfPeriod)
public static Series ChaikinMoneyFlowOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
A financial series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
Remarks
In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinMoneyFlowOverPeriod Method : ChaikinMoneyFlowOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the number of periods over which the indicator is calculated.
ChaikinMoneyFlowOverPeriod(SeriesCollection,Int32) Method
Iteratively evaluate the Chaikin Money Flow (CMF)indicator over all (sub)collections of periods of a given length for all periods for which data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinMoneyFlowOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.ChaikinMoneyFlowOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection ChaikinMoneyFlowOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the number of periods over which the indicator is calculated.
Remarks
In particular, this method returns an array where the 1st term of the CMF indicator for the latest period, the second term of the CMF in the previous period and so on. Please note that the CMF will be evaluated for all periods for which there is sufficient data (see example below for more details).

Remark: The form in which the Chaikin Money Flow (CMF) in provided here is particularly suitable when wishing to integrated this functionality within a Client side GUI Charting Application.

Details of Chaikin Money Flow (CMF)

Chaikin Money Flow (CMF) is a volume weighted average of Accumulation/Distribution over a specified period, which is usually taken to be 21 days. The CMF offers a volume weighted indicator on the following two principles:

  • The nearer the close is to the high the more accumulation is taking place.
  • The nearer the close is to the low the more distribution is taking place.

Evaluation

The CMF indicator is evaluated for the following steps:

  • Evaluate the Volume Weighted Accumulation/Distribution over each of the days within the period considered for the calculation. The Volume Weighted Accumulation/Distribution on each day is given by:

    (((Close - Low)-(High - Close))/(High - Low)) * Volume
  • Sum the Volume Weighted Accumulation/Distribution over the period and the divide the result by the sum of the volume over the period.

Example of Application

Within this example we illustrate the way this method works when we consider a given 10 period in which the length of period over which the CHM is evaluated is 4. In this case the result will be an array of 7 elements as follows:

  • result[0]: CMF calculated over the last four periods
  • result[1]: CMF calculated over previous four periods
  • ...
  • result[7]: CMF calculated using the periods between the earliest period and the fourth from earliest period.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ChaikinOscillator Method
ChaikinOscillator Method
This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
Overload List
Overload | Description
ChaikinOscillator(String,Series,Double) | This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
ChaikinOscillator(Series,Double) | This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
ChaikinOscillator(SeriesCollection,Int32) | This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
Example
ChaikinIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinOscillator Method : ChaikinOscillator(String,Series,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series.
The number between 0 and 1. The lower the number the more sensitive the indicator is.
ChaikinOscillator(String,Series,Double) Method
This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinOscillator( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal smoothingFactor As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim smoothingFactor As Double
Dim value As Series

value = FinancialEngine.ChaikinOscillator(seriesName, s, smoothingFactor)
public static Series ChaikinOscillator(
   string seriesName,
   Series s,
   double smoothingFactor
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Value

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.
Remarks
The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinOscillator Method : ChaikinOscillator(Series,Double) Method
A financial series.
The number between 0 and 1. The lower the number the more sensitive the indicator is.
ChaikinOscillator(Series,Double) Method
This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinOscillator( _
   ByVal s As Series, _
   ByVal smoothingFactor As Double _
) As Series
'Usage

Dim s As Series
Dim smoothingFactor As Double
Dim value As Series

value = FinancialEngine.ChaikinOscillator(s, smoothingFactor)
public static Series ChaikinOscillator(
   Series s,
   double smoothingFactor
)

Parameters

s
A financial series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Value

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.
Remarks
The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinOscillator Method : ChaikinOscillator(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number between 0 and 1. The lower the number the more sensitive the indicator is.
ChaikinOscillator(SeriesCollection,Int32) Method
This method implements the Chaikin Oscillator (also known as the Chaikin A/D Oscillator) and evaluates this indicator for the latest and all previous periods for which there exists sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinOscillator( _
   ByVal sc As SeriesCollection, _
   ByVal smoothingFactor As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim smoothingFactor As Integer
Dim value As SeriesCollection

value = FinancialEngine.ChaikinOscillator(sc, smoothingFactor)
public static SeriesCollection ChaikinOscillator(
   SeriesCollection sc,
   int smoothingFactor
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1. The lower the number the more sensitive the indicator is.

Return Value

A series where the first term is the value of the oscillator using the last 10 days data, the previous term is the value of the oscillator on the previous period and so on.
Remarks
The Chaikin Oscillator presents the information contained within the A/D indicator in the convenient form of an oscillator. That is, the Chaikin Oscillator is simply the Moving Average Convergence Divergence indicator (MACD) applied to the Accumulation/Distribution Line.

Interpretation

A sell signal is when price action develops a higher high into overbought zones and the Chaikin Oscillator diverges with a lower high and begins to fall. Conversely, a buy signal is generated when price action develops a lower low into oversold zones and the oscillator diverges with a higher low and begins to rise. The Chaikin Oscillator can also be used to time entry to existing trends by either buying the dip (when the oscillator turns down) or selling the rally (when the oscillator turns up).

Evaluation

The Chaiken Oscillator for a given period is given by:

EMA_3(Accumulate/Distribution) - EMA_10(Accumulate/Distribution),

where EMA_3 and EMA_10 is the exponential moving average over 3 and 10 days respectively; and Accumulate/Distribution is the corresponding indicator over those 3 or 10 days respectively.

Illustration

If we are provided within the high, low and volume over the last 15 periods, then we will be able to evaluate the Chaikin Oscillator on the previous 5 trading days. Since the evaluation of the oscillator on a given period requires knowledge of the 10 previous periods data.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ChaikinVolatility Method
ChaikinVolatility Method
Chaikin's Volatility indicator compares the spread between a security's high and low prices.
Overload List
Overload | Description
ChaikinVolatility(String,Series,Int32,Int32) | Chaikin's Volatility indicator compares the spread between a security's high and low prices.
ChaikinVolatility(Series,Int32,Int32) | Chaikin's Volatility indicator compares the spread between a security's high and low prices.
ChaikinVolatility(SeriesCollection,Int32,Int32) | Chaikin's Volatility indicator compares the spread between a security's high and low prices.
Example
ChaikinIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinVolatility Method : ChaikinVolatility(String,Series,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
ChaikinVolatility(String,Series,Int32,Int32) Method
Chaikin's Volatility indicator compares the spread between a security's high and low prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinVolatility( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfMA As Integer
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.ChaikinVolatility(seriesName, s, lengthOfMA, noOfPeriods)
public static Series ChaikinVolatility(
   string seriesName,
   Series s,
   int lengthOfMA,
   int noOfPeriods
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.
Remarks
It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinVolatility Method : ChaikinVolatility(Series,Int32,Int32) Method
A financial series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
ChaikinVolatility(Series,Int32,Int32) Method
Chaikin's Volatility indicator compares the spread between a security's high and low prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinVolatility( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfMA As Integer
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.ChaikinVolatility(s, lengthOfMA, noOfPeriods)
public static Series ChaikinVolatility(
   Series s,
   int lengthOfMA,
   int noOfPeriods
)

Parameters

s
A financial series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.
Remarks
It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ChaikinVolatility Method : ChaikinVolatility(SeriesCollection,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
ChaikinVolatility(SeriesCollection,Int32,Int32) Method
Chaikin's Volatility indicator compares the spread between a security's high and low prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ChaikinVolatility( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim noOfPeriods As Integer
Dim value As SeriesCollection

value = FinancialEngine.ChaikinVolatility(sc, lengthOfMA, noOfPeriods)
public static SeriesCollection ChaikinVolatility(
   SeriesCollection sc,
   int lengthOfMA,
   int noOfPeriods
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
noOfPeriods
An integer which represents the number of previous time periods used over which the comparing moving average is taken.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative or arrays closes or volumes are empty.
Remarks
It quantifies volatility as a widening of the range between the high and the low price.

Indicator Formula

The formula for this indicator is:

  1. chaikinVolatility = ((H-LAverage - H-LAverage_n_periods_ago)/H-LAverage_n_periods_ago)*100
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : CommodityChannelIdxOverPeriod Method
CommodityChannelIdxOverPeriod Method
This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
Overload List
Overload | Description
CommodityChannelIdxOverPeriod(String,Series,Int32) | This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
CommodityChannelIdxOverPeriod(Series,Int32) | This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
CommodityChannelIdxOverPeriod(SeriesCollection,Int32) | This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
Example
CommodityChannelIndex
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > CommodityChannelIdxOverPeriod Method : CommodityChannelIdxOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
CommodityChannelIdxOverPeriod(String,Series,Int32) Method
This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CommodityChannelIdxOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.CommodityChannelIdxOverPeriod(seriesName, s, lengthOfPeriod)
public static Series CommodityChannelIdxOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CommodityChannelIdxOverPeriod Method : CommodityChannelIdxOverPeriod(Series,Int32) Method
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
CommodityChannelIdxOverPeriod(Series,Int32) Method
This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CommodityChannelIdxOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.CommodityChannelIdxOverPeriod(s, lengthOfPeriod)
public static Series CommodityChannelIdxOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
A series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CommodityChannelIdxOverPeriod Method : CommodityChannelIdxOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
CommodityChannelIdxOverPeriod(SeriesCollection,Int32) Method
This indicator is a generalization of the CommodityChannelIndex indicator and calculates the values of the commodityChannelIndex indicator over all sub-periods of a given length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CommodityChannelIdxOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.CommodityChannelIdxOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection CommodityChannelIdxOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the highs, lows or closes are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The CCI measures the variation of a security's price from its statistical mean. High values show that prices are unusually high compared to average prices whereas low values indicate that prices are unusually low. The CCI can be used effectively on any type of security, but clearly it is most applicable where the security has should a strong degree on mean reversion.

Lambert originally commended that the CCI was designed to capture the trade cycle (i.e. low-to-low or high-to-high) turns in commodity markets. The system assumes that commodities move in cycles and uses 1/3 of the cycle period for the evaluation of the CCI. We allow the uses to specify the length of the calculation period used but we advise that you take the calculation cycle to be approximately one third of your estimate for the length of the trade cycle.

Calculation Period: the number of days used in the evaluation of the CCI. In Donald Lambert's original system this was taken to be one third of the estimate length of the trade cycle.

Remark: Within the evaluation procedure (step 2), we multiply the result by the constant 0.015. The constant was originally used in Lambert's system and has been found to ensure that around 70-80 percent of all the values given by the CCI lie the range [-100,+100]. Hence, the constant is just used to calibrate the indicator with respect to the range [-100, +100].

Interpretation
Significant signals are generated when either the CCI starts to diverge from the price action which will signify a correlation in the price, or when the CCI extended (typically above 100 or below -100) which indicates oversold or over brought conditions.

Further details concerning the CCI can be found in an article by Donald Lambert that appeared in the October 1980 issue of Commodities (now known as Futures) Magazine.

Evaluation Procedure
We summaries our basic evaluation procedure by the following three steps:

  • First evaluate the simple moving average (SMA) of the Typical Price Indicator (see Filters) over the calculation period.
  • Evaluate the SMA over the calculation period of the absolute value on each on the calculation period days between the Typical Price on that day and the SMA found in step 1 above, and multiply the result by 0.015.
  • Divide todays typical price minus the SMA of the typical price found in step 1, by the result given by step 2.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : CrossingExtremeSignal Method
CrossingExtremeSignal Method
This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
Overload List
Overload | Description
CrossingExtremeSignal(String,Series,Double,Double,Int32,Int32,Int32) | This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
CrossingExtremeSignal(Series,Double,Double,Int32,Int32,Int32) | This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
CrossingExtremeSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) | This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
Example
ExtremeValueSignal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > CrossingExtremeSignal Method : CrossingExtremeSignal(String,Series,Double,Double,Int32,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
The number of periods over which the moving average is considered.
CrossingExtremeSignal(String,Series,Double,Double,Int32,Int32,Int32) Method
This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingExtremeSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.CrossingExtremeSignal(seriesName, s, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static Series CrossingExtremeSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CrossingExtremeSignal Method : CrossingExtremeSignal(Series,Double,Double,Int32,Int32,Int32) Method
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
The number of periods over which the moving average is considered.
CrossingExtremeSignal(Series,Double,Double,Int32,Int32,Int32) Method
This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingExtremeSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.CrossingExtremeSignal(s, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static Series CrossingExtremeSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CrossingExtremeSignal Method : CrossingExtremeSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
The number of periods over which the moving average is considered.
CrossingExtremeSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method
This trading system combines the features of the crossing and extremum value trading systems by requiring that a signal will only be generated if the fast %K Stochastic crosses the slow %D Stochastic either above or below the extremal values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingExtremeSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.CrossingExtremeSignal(sc, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static SeriesCollection CrossingExtremeSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Trading System Rules

This system generates buy and sell signals respectively when one of the following is triggered:

  1. Buy Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value lower than the extremumLow, then a buy signal is generated.
  2. Sell Signal: When the fast %K Stochastic crosses above the slow %D Stochastic and this crossing takes place at a value higher than the extremumHigh, then a sell signal in generated.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : CrossingSignal Method
CrossingSignal Method
Implements a general framework for producing trading signals based on the crossing of two Stochastics.
Overload List
Overload | Description
CrossingSignal(String,Series,Int32,Int32,Int32) | Implements a general framework for producing trading signals based on the crossing of two Stochastics.
CrossingSignal(Series,Int32,Int32,Int32) | Implements a general framework for producing trading signals based on the crossing of two Stochastics.
CrossingSignal(SeriesCollection,Int32,Int32,Int32) | Implements a general framework for producing trading signals based on the crossing of two Stochastics.
Example
CrossingSignal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > CrossingSignal Method : CrossingSignal(String,Series,Int32,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
The number of periods over which the moving average is considered.
CrossingSignal(String,Series,Int32,Int32,Int32) Method
Implements a general framework for producing trading signals based on the crossing of two Stochastics.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.CrossingSignal(seriesName, s, noOfPeriods, method, lengthOfMA)
public static Series CrossingSignal(
   string seriesName,
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Methodology

Buy when the Stochastic %K, crosses above the MA %D and sell when the Stochastic %K falls below the MA of Stochastic %D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CrossingSignal Method : CrossingSignal(Series,Int32,Int32,Int32) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
The number of periods over which the moving average is considered.
CrossingSignal(Series,Int32,Int32,Int32) Method
Implements a general framework for producing trading signals based on the crossing of two Stochastics.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingSignal( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.CrossingSignal(s, noOfPeriods, method, lengthOfMA)
public static Series CrossingSignal(
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Methodology

Buy when the Stochastic %K, crosses above the MA %D and sell when the Stochastic %K falls below the MA of Stochastic %D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > CrossingSignal Method : CrossingSignal(SeriesCollection,Int32,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
The number of periods over which the moving average is considered.
CrossingSignal(SeriesCollection,Int32,Int32,Int32) Method
Implements a general framework for producing trading signals based on the crossing of two Stochastics.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CrossingSignal( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.CrossingSignal(sc, noOfPeriods, method, lengthOfMA)
public static SeriesCollection CrossingSignal(
   SeriesCollection sc,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.
lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks

Methodology

Buy when the Stochastic %K, crosses above the MA %D and sell when the Stochastic %K falls below the MA of Stochastic %D. Since this approach is prone to being whip-sawed we use two (general) Stochastics so that a MA of the %K Stochastic of the first Stochastic and an even more smoothed second Stochastic. In this case a sell signal is generated if the first (more sensitive) Stochastic cross below the second (smoothed) Stochastic, and a buy signal is generated if the first Stochastic crosses above the second Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : DirectionalMotion Method
DirectionalMotion Method
Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
Overload List
Overload | Description
DirectionalMotion(String,Series) | Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
DirectionalMotion(Series) | Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
DirectionalMotion(SeriesCollection) | Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
Example
DirectionalMovement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > DirectionalMotion Method : DirectionalMotion(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
DirectionalMotion(String,Series) Method
Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DirectionalMotion( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.DirectionalMotion(seriesName, s)
public static Series DirectionalMotion(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the DM of the k-th Bar. That is, where the PDM and MDM parameters where both evaluated with respect to the last two trading periods.
Remarks
This indicator is generally evaluated using 14 periods and is used with the PlusDirectionalMovement and MinusDirectionalMovement indicators.

Evaluation

The Directional Movement Indicator can be summarized by the following formula:

Directional Movement Indicator = 100 * ( (PDM - MDM) / (PDM + MDM) ),

where PDM is the Plus Directional Movement (PDM) indicator over the last two trading periods which can be evaluated using PlusDirectionalMovement and MDM is the Minus Directional Movement (MDM) indicator over the last two trading periods which can be evaluated using MinusDirectionalMovement.

Interpretation

The directional indicator has a range of [0,100], where to higher the value returned the stronger the trend is said to be. If a trend is reliable then the smoothed directional lines (PDM and MDM) will diverge and the indicator will increase. If on the other hand a trend starts to fail and price whip-saws (for example with price is within a trading range) the difference between the smoothed direction lines will decrease and the overall index will decrease.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DirectionalMotion Method : DirectionalMotion(Series) Method
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
DirectionalMotion(Series) Method
Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DirectionalMotion( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.DirectionalMotion(s)
public static Series DirectionalMotion(
   Series s
)

Parameters

s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the DM of the k-th Bar. That is, where the PDM and MDM parameters where both evaluated with respect to the last two trading periods.
Remarks
This indicator is generally evaluated using 14 periods and is used with the PlusDirectionalMovement and MinusDirectionalMovement indicators.

Evaluation

The Directional Movement Indicator can be summarized by the following formula:

Directional Movement Indicator = 100 * ( (PDM - MDM) / (PDM + MDM) ),

where PDM is the Plus Directional Movement (PDM) indicator over the last two trading periods which can be evaluated using PlusDirectionalMovement and MDM is the Minus Directional Movement (MDM) indicator over the last two trading periods which can be evaluated using MinusDirectionalMovement.

Interpretation

The directional indicator has a range of [0,100], where to higher the value returned the stronger the trend is said to be. If a trend is reliable then the smoothed directional lines (PDM and MDM) will diverge and the indicator will increase. If on the other hand a trend starts to fail and price whip-saws (for example with price is within a trading range) the difference between the smoothed direction lines will decrease and the overall index will decrease.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DirectionalMotion Method : DirectionalMotion(SeriesCollection) Method
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
DirectionalMotion(SeriesCollection) Method
Calculates the Directional Indicator which forms the main part of the Directional Movement System developed by Wellas Wilder.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DirectionalMotion( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.DirectionalMotion(sc)
public static SeriesCollection DirectionalMotion(
   SeriesCollection sc
)

Parameters

sc
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A collections of series. Each series has the k-th term corresponds to the DM of the k-th Bar. That is, where the PDM and MDM parameters where both evaluated with respect to the last two trading periods.
Remarks
This indicator is generally evaluated using 14 periods and is used with the PlusDirectionalMovement and MinusDirectionalMovement indicators.

Evaluation

The Directional Movement Indicator can be summarized by the following formula:

Directional Movement Indicator = 100 * ( (PDM - MDM) / (PDM + MDM) ),

where PDM is the Plus Directional Movement (PDM) indicator over the last two trading periods which can be evaluated using PlusDirectionalMovement and MDM is the Minus Directional Movement (MDM) indicator over the last two trading periods which can be evaluated using MinusDirectionalMovement.

Interpretation

The directional indicator has a range of [0,100], where to higher the value returned the stronger the trend is said to be. If a trend is reliable then the smoothed directional lines (PDM and MDM) will diverge and the indicator will increase. If on the other hand a trend starts to fail and price whip-saws (for example with price is within a trading range) the difference between the smoothed direction lines will decrease and the overall index will decrease.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : DMISignal Method
DMISignal Method
Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
Overload List
Overload | Description
DMISignal(String,Series,Int32,Int32) | Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
DMISignal(Series,Int32,Int32) | Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
DMISignal(SeriesCollection,Int32,Int32) | Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
Example
DMI Signal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > DMISignal Method : DMISignal(String,Series,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DMISignal(String,Series,Int32,Int32) Method
Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DMISignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.DMISignal(seriesName, s, method, lengthOfMA)
public static Series DMISignal(
   string seriesName,
   Series s,
   int method,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

Returns -1, 0, or 1 respectively according to whether a sell, no action or buy signal is generated.
Remarks
This signal determines whether a given asset or index should be sold, brought or no action should be taken for a given asset under consideration. This trading signal forms the basis of the DMI Trading System which was developed by Welles Wilder.

At its simplest level to DMI system states that when the PDI crosses above the MDI a buy signal is generated and when the MDI crosses above the PMI then a sell signal is generated. This however may generate an excessive number of signals and hence we offer the possibility to smooth out these indicators according to a moving average which will help to reduce to sensitivity of the trading system.

Advantages to this Approach

This trading approach will reveal a trend before it is detected by most market participants. Once the trend becomes more widely recognized other market participants will tend to buy the tend and hence re-enforcing the trend dynamics. Hence the DMI system offers a good risk/reward trend following system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DMISignal Method : DMISignal(Series,Int32,Int32) Method
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DMISignal(Series,Int32,Int32) Method
Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DMISignal( _
   ByVal s As Series, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.DMISignal(s, method, lengthOfMA)
public static Series DMISignal(
   Series s,
   int method,
   int lengthOfMA
)

Parameters

s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

Returns -1, 0, or 1 respectively according to whether a sell, no action or buy signal is generated.
Remarks
This signal determines whether a given asset or index should be sold, brought or no action should be taken for a given asset under consideration. This trading signal forms the basis of the DMI Trading System which was developed by Welles Wilder.

At its simplest level to DMI system states that when the PDI crosses above the MDI a buy signal is generated and when the MDI crosses above the PMI then a sell signal is generated. This however may generate an excessive number of signals and hence we offer the possibility to smooth out these indicators according to a moving average which will help to reduce to sensitivity of the trading system.

Advantages to this Approach

This trading approach will reveal a trend before it is detected by most market participants. Once the trend becomes more widely recognized other market participants will tend to buy the tend and hence re-enforcing the trend dynamics. Hence the DMI system offers a good risk/reward trend following system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DMISignal Method : DMISignal(SeriesCollection,Int32,Int32) Method
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DMISignal(SeriesCollection,Int32,Int32) Method
Evaluates what is know as the Directional Motion Indicator (MDI) Trading Signal.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DMISignal( _
   ByVal sc As SeriesCollection, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.DMISignal(sc, method, lengthOfMA)
public static SeriesCollection DMISignal(
   SeriesCollection sc,
   int method,
   int lengthOfMA
)

Parameters

sc
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

Returns -1, 0, or 1 respectively according to whether a sell, no action or buy signal is generated.
Remarks
This signal determines whether a given asset or index should be sold, brought or no action should be taken for a given asset under consideration. This trading signal forms the basis of the DMI Trading System which was developed by Welles Wilder.

At its simplest level to DMI system states that when the PDI crosses above the MDI a buy signal is generated and when the MDI crosses above the PMI then a sell signal is generated. This however may generate an excessive number of signals and hence we offer the possibility to smooth out these indicators according to a moving average which will help to reduce to sensitivity of the trading system.

Advantages to this Approach

This trading approach will reveal a trend before it is detected by most market participants. Once the trend becomes more widely recognized other market participants will tend to buy the tend and hence re-enforcing the trend dynamics. Hence the DMI system offers a good risk/reward trend following system.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : DStochastic Method
DStochastic Method
Evaluate the (general) %D Stochastic.
Overload List
Overload | Description
DStochastic(String,Series,Int32,Int32,Int32) | Evaluate the (general) %D Stochastic.
DStochastic(Series,Int32,Int32,Int32) | Evaluate the (general) %D Stochastic.
DStochastic(SeriesCollection,Int32,Int32,Int32) | Evaluate the (general) %D Stochastic.
Example
Stochastic
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > DStochastic Method : DStochastic(String,Series,Int32,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DStochastic(String,Series,Int32,Int32,Int32) Method
Evaluate the (general) %D Stochastic.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DStochastic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.DStochastic(seriesName, s, noOfPeriods, method, lengthOfMA)
public static Series DStochastic(
   string seriesName,
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.
Remarks
This is just the moving average of the (fast) %K Stochastic. When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the (slow) %K Stochastic.

As one would expect the Moving Average %D of the %K Stochastic depends on:

  • %D Periods - The number of periods over which the moving average is evaluated.
  • MA Method - This is the method by which the moving average of the Stochastic %K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the %D Stochastic reduces to what is known as the slow %K Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DStochastic Method : DStochastic(Series,Int32,Int32,Int32) Method
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DStochastic(Series,Int32,Int32,Int32) Method
Evaluate the (general) %D Stochastic.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DStochastic( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.DStochastic(s, noOfPeriods, method, lengthOfMA)
public static Series DStochastic(
   Series s,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.
Remarks
This is just the moving average of the (fast) %K Stochastic. When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the (slow) %K Stochastic.

As one would expect the Moving Average %D of the %K Stochastic depends on:

  • %D Periods - The number of periods over which the moving average is evaluated.
  • MA Method - This is the method by which the moving average of the Stochastic %K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the %D Stochastic reduces to what is known as the slow %K Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > DStochastic Method : DStochastic(SeriesCollection,Int32,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
DStochastic(SeriesCollection,Int32,Int32,Int32) Method
Evaluate the (general) %D Stochastic.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DStochastic( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.DStochastic(sc, noOfPeriods, method, lengthOfMA)
public static SeriesCollection DStochastic(
   SeriesCollection sc,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.
Remarks
This is just the moving average of the (fast) %K Stochastic. When the simple moving average is used and the moving average is take over three days, the resulting indicator to referred to as the (slow) %K Stochastic.

As one would expect the Moving Average %D of the %K Stochastic depends on:

  • %D Periods - The number of periods over which the moving average is evaluated.
  • MA Method - This is the method by which the moving average of the Stochastic %K is evaluated. We offer a range of methods for the evaluation of the moving average, these include: simple, exponential, geometric, weighted, linearly weighted and exponentially weighted.

Remark When the simple moving average is used and it is evaluated over 3-days, then the %D Stochastic reduces to what is known as the slow %K Stochastic.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ExponentiallyWeightedMovingAverage Method
ExponentiallyWeightedMovingAverage Method (FinancialEngine)
Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Overload List
Overload | Description
ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Example
Stochastic
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(String,Series,ElementValue,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.ExponentiallyWeightedMovingAverage(seriesName, s, elementValue, smoothingFactor, lengthOfMA)
public static Series ExponentiallyWeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Int32) Method
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(Series,ElementValue,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.ExponentiallyWeightedMovingAverage(s, elementValue, smoothingFactor, lengthOfMA)
public static Series ExponentiallyWeightedMovingAverage(
   Series s,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

s
A series where the first value corresponds to the value of the asset in the tth period, and the second value corresponds to the value of the asset in the t-1-th period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(SeriesCollection,ElementValue,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average(EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.ExponentiallyWeightedMovingAverage(sc, elementValue, smoothingFactor, lengthOfMA)
public static SeriesCollection ExponentiallyWeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ExtremeValueDSignal Method
ExtremeValueDSignal Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Overload List
Overload | Description
ExtremeValueDSignal(String,Series,Double,Double,Int32,Int32,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
ExtremeValueDSignal(Series,Double,Double,Int32,Int32,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
ExtremeValueDSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Example
ExtremeValueSignal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueDSignal Method : ExtremeValueDSignal(String,Series,Double,Double,Int32,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
ExtremeValueDSignal(String,Series,Double,Double,Int32,Int32,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueDSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.ExtremeValueDSignal(seriesName, s, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static Series ExtremeValueDSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueDSignal Method : ExtremeValueDSignal(Series,Double,Double,Int32,Int32,Int32) Method
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
ExtremeValueDSignal(Series,Double,Double,Int32,Int32,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueDSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.ExtremeValueDSignal(s, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static Series ExtremeValueDSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

s
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueDSignal Method : ExtremeValueDSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

The number of periods over which the moving average is considered.
ExtremeValueDSignal(SeriesCollection,Double,Double,Int32,Int32,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueDSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer, _
   ByVal method As Integer, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim method As Integer
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.ExtremeValueDSignal(sc, extremeLow, extremeHigh, noOfPeriods, method, lengthOfMA)
public static SeriesCollection ExtremeValueDSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods,
   int method,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.
method
Determines the methods used for the evaluation of the moving average in accordance with the following key:
  1. 1 = Simple moving average
  2. 2 = Geometric moving average
  3. 3 = Linearly weighted moving average
  4. 4 = Exponentially Weighted Moving average within smoothing fact set to be 0.5.

For further details concerning the definition of these moving averages please see the accompanying PDF documentation or the API documentation for SimpleMovingAverage(String,Series,ElementValue,Int32).

lengthOfMA
The number of periods over which the moving average is considered.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ides of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the Oscillator the Stochastic %D falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ExtremeValueKSignal Method
ExtremeValueKSignal Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Overload List
Overload | Description
ExtremeValueKSignal(String,Series,Double,Double,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
ExtremeValueKSignal(Series,Double,Double,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
ExtremeValueKSignal(SeriesCollection,Double,Double,Int32) | Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Example
ExtremeValueSignal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueKSignal Method : ExtremeValueKSignal(String,Series,Double,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
ExtremeValueKSignal(String,Series,Double,Double,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueKSignal( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.ExtremeValueKSignal(seriesName, s, extremeLow, extremeHigh, noOfPeriods)
public static Series ExtremeValueKSignal(
   string seriesName,
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueKSignal Method : ExtremeValueKSignal(Series,Double,Double,Int32) Method
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
ExtremeValueKSignal(Series,Double,Double,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueKSignal( _
   ByVal s As Series, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim s As Series
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.ExtremeValueKSignal(s, extremeLow, extremeHigh, noOfPeriods)
public static Series ExtremeValueKSignal(
   Series s,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
)

Parameters

s
A financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ExtremeValueKSignal Method : ExtremeValueKSignal(SeriesCollection,Double,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
An integer which represents the number of periods used over which the closing price is compared.
ExtremeValueKSignal(SeriesCollection,Double,Double,Int32) Method
Implements a general framework for producing extreme value trading signals using Stochastic indicators.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExtremeValueKSignal( _
   ByVal sc As SeriesCollection, _
   ByVal extremeLow As Double, _
   ByVal extremeHigh As Double, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim extremeLow As Double
Dim extremeHigh As Double
Dim noOfPeriods As Integer
Dim value As SeriesCollection

value = FinancialEngine.ExtremeValueKSignal(sc, extremeLow, extremeHigh, noOfPeriods)
public static SeriesCollection ExtremeValueKSignal(
   SeriesCollection sc,
   double extremeLow,
   double extremeHigh,
   int noOfPeriods
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
extremeLow
This is the level at which the Stochastic is believed to indicate an oversold level. The Stochastic always lies between 0 and 100, and a suggested extreme low value to take is 20.
extremeHigh
This is the level at which the Stochastic is believed to indicate an over brought level. The Stochastic always lies between 0 and 100, and a suggested extreme high value is 80.
noOfPeriods
An integer which represents the number of periods used over which the closing price is compared.

Return Value

-1, 0, 1 - this method returns either -1, 0, 1 to indicate that either a sell, no action or buy signal was generated.
Remarks
Note, that the general ideea of this approach is to seek points which are oversold or over brought levels which are turning.

Methodology

Buy when the the Stochastic %K falls below a specific level (e.g. 20) and then rises above that level. Sell when the Oscillator rises above a specific level (e.g. 80) and then falls below that level. This approach is the preferred method of the Stochastics original creator George Lane.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : FiniteImpulseResponse Method
FiniteImpulseResponse Method
Calculates a Finite Impulse Response Filter.
Overload List
Overload | Description
FiniteImpulseResponse(String,Series,ElementValue,Double[]) | Calculates a Finite Impulse Response Filter.
FiniteImpulseResponse(Series,ElementValue,Double[]) | Calculates a Finite Impulse Response Filter.
FiniteImpulseResponse(SeriesCollection,ElementValue,Double[]) | Calculates a Finite Impulse Response Filter.
Example
FiniteImpulseResponse
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > FiniteImpulseResponse Method : FiniteImpulseResponse(String,Series,ElementValue,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A double array which represent the different weights associated with the given prices.
FiniteImpulseResponse(String,Series,ElementValue,Double[]) Method
Calculates a Finite Impulse Response Filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FiniteImpulseResponse( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As Series

value = FinancialEngine.FiniteImpulseResponse(seriesName, s, elementValue, weights)
public static Series FiniteImpulseResponse(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double[] weights
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
A double array which represent the different weights associated with the given prices.

Return Value

A series where the first element is the FIR of the asset on the most recent period considered, the second term is the FIR on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the given series, s, is less than the length of weights double array or if any elements of the s is strictly negative.
Remarks
This is a type of smoothing filter that assigns different weights to prices from the past.

Evaluation

The FIR indicator is evaluated by the following formula:
FIR = ((historicalValues[i]*weights[0]) + historicalValues[i-1]*wights[1] + ...)/(Sum of weights)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > FiniteImpulseResponse Method : FiniteImpulseResponse(Series,ElementValue,Double[]) Method
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A double array which represent the different weights associated with the given prices.
FiniteImpulseResponse(Series,ElementValue,Double[]) Method
Calculates a Finite Impulse Response Filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FiniteImpulseResponse( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As Series

value = FinancialEngine.FiniteImpulseResponse(s, elementValue, weights)
public static Series FiniteImpulseResponse(
   Series s,
   ElementValue elementValue,
   double[] weights
)

Parameters

s
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
A double array which represent the different weights associated with the given prices.

Return Value

A series where the first element is the FIR of the asset on the most recent period considered, the second term is the FIR on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the given series, s, is less than the length of weights double array or if any elements of the s is strictly negative.
Remarks
This is a type of smoothing filter that assigns different weights to prices from the past.

Evaluation

The FIR indicator is evaluated by the following formula:
FIR = ((historicalValues[i]*weights[0]) + historicalValues[i-1]*wights[1] + ...)/(Sum of weights)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > FiniteImpulseResponse Method : FiniteImpulseResponse(SeriesCollection,ElementValue,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A double array which represent the different weights associated with the given prices.
FiniteImpulseResponse(SeriesCollection,ElementValue,Double[]) Method
Calculates a Finite Impulse Response Filter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FiniteImpulseResponse( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As SeriesCollection

value = FinancialEngine.FiniteImpulseResponse(sc, elementValue, weights)
public static SeriesCollection FiniteImpulseResponse(
   SeriesCollection sc,
   ElementValue elementValue,
   double[] weights
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
A double array which represent the different weights associated with the given prices.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the given series, s, is less than the length of weights double array or if any elements of the s is strictly negative.
Remarks
This is a type of smoothing filter that assigns different weights to prices from the past.

Evaluation

The FIR indicator is evaluated by the following formula:
FIR = ((historicalValues[i]*weights[0]) + historicalValues[i-1]*wights[1] + ...)/(Sum of weights)

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : GeometricMean Method
GeometricMean Method (FinancialEngine)
Calculates the geometric mean of the series's elements values.
Overload List
Overload | Description
GeometricMean(String,Series,ElementValue) | Calculates the geometric mean of the series's elements values.
GeometricMean(Series,ElementValue) | Calculates the geometric mean of the series's elements values.
GeometricMean(String,SeriesCollection,ElementValue) | Calculates the geometric mean of the series's elements values.
GeometricMean(SeriesCollection,ElementValue) | Calculates the geometric mean of the series's elements values.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMean Method : GeometricMean(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
GeometricMean(String,Series,ElementValue) Method
Calculates the geometric mean of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.GeometricMean(elementName, s, elementValue)
public static Element GeometricMean(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the arithmetic mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMean Method : GeometricMean(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
GeometricMean(Series,ElementValue) Method
Calculates the geometric mean of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.GeometricMean(s, elementValue)
public static Element GeometricMean(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the arithmetic mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMean Method : GeometricMean(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
GeometricMean(String,SeriesCollection,ElementValue) Method
Calculates the geometric mean of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.GeometricMean(seriesName, sc, elementValue)
public static Series GeometricMean(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the arithmetic mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMean Method : GeometricMean(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
GeometricMean(SeriesCollection,ElementValue) Method
Calculates the geometric mean of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.GeometricMean(sc, elementValue)
public static Series GeometricMean(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the arithmetic mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class : GeometricMovingAverage Method
GeometricMovingAverage Method (FinancialEngine)
Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Overload List
Overload | Description
GeometricMovingAverage(String,Series,ElementValue,Int32) | Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
GeometricMovingAverage(Series,ElementValue,Int32) | Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
GeometricMovingAverage(SeriesCollection,ElementValue,Int32) | Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Example
FinancialMA
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(String,Series,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
GeometricMovingAverage(String,Series,ElementValue,Int32) Method
Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.GeometricMovingAverage(seriesName, s, elementValue, lengthOfMA)
public static Series GeometricMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(Series,ElementValue,Int32) Method
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
GeometricMovingAverage(Series,ElementValue,Int32) Method
Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.GeometricMovingAverage(s, elementValue, lengthOfMA)
public static Series GeometricMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

s
A series containing the values of the time series being considered. Where the first element gives the last historical value, the second term the previous periods value and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(SeriesCollection,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.
GeometricMovingAverage(SeriesCollection,ElementValue,Int32) Method
Calculates the Geometric Moving Average(GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.GeometricMovingAverage(sc, elementValue, lengthOfMA)
public static SeriesCollection GeometricMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day Geometric Moving Average (i.e. passing the length of the GMA of 5), then this method will evaluate the Geometric Moving Average (GMA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : HighestPeriod Method
HighestPeriod Method
Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
Overload List
Overload | Description
HighestPeriod(String,Series,Int32) | Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
HighestPeriod(Series,Int32) | Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
HighestPeriod(SeriesCollection,Int32) | Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > HighestPeriod Method : HighestPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
HighestPeriod(String,Series,Int32) Method
Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function HighestPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.HighestPeriod(seriesName, s, noOfDays)
public static Series HighestPeriod(
   string seriesName,
   Series s,
   int noOfDays
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > HighestPeriod Method : HighestPeriod(Series,Int32) Method
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
HighestPeriod(Series,Int32) Method
Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function HighestPeriod( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.HighestPeriod(s, noOfDays)
public static Series HighestPeriod(
   Series s,
   int noOfDays
)

Parameters

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > HighestPeriod Method : HighestPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of days before to which the closing price is compared.
HighestPeriod(SeriesCollection,Int32) Method
Returns the highest value of prices over all values given. Returns a series which contains the higher highs values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function HighestPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfDays As Integer
Dim value As SeriesCollection

value = FinancialEngine.HighestPeriod(sc, noOfDays)
public static SeriesCollection HighestPeriod(
   SeriesCollection sc,
   int noOfDays
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Value

a series where the first term is the high calculated for the most recent trading period, the second term is the high for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : InterQuartileRange Method
InterQuartileRange Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Overload List
Overload | Description
InterQuartileRange(String,Series,ElementValue) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
InterQuartileRange(Series,ElementValue) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
InterQuartileRange(String,SeriesCollection,ElementValue) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
InterQuartileRange(SeriesCollection,ElementValue) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > InterQuartileRange Method : InterQuartileRange(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
InterQuartileRange(String,Series,ElementValue) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function InterQuartileRange( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.InterQuartileRange(elementName, s, elementValue)
public static Element InterQuartileRange(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > InterQuartileRange Method : InterQuartileRange(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
InterQuartileRange(Series,ElementValue) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function InterQuartileRange( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.InterQuartileRange(s, elementValue)
public static Element InterQuartileRange(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > InterQuartileRange Method : InterQuartileRange(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
InterQuartileRange(String,SeriesCollection,ElementValue) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function InterQuartileRange( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.InterQuartileRange(seriesName, sc, elementValue)
public static Series InterQuartileRange(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > InterQuartileRange Method : InterQuartileRange(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
InterQuartileRange(SeriesCollection,ElementValue) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function InterQuartileRange( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.InterQuartileRange(sc, elementValue)
public static Series InterQuartileRange(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Kairi Method
Kairi Method (FinancialEngine)
Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Overload List
Overload | Description
Kairi(String,Series,ElementValue,Series) | Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Kairi(Series,ElementValue,Series) | Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Kairi(Series,ElementValue,SeriesCollection) | Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Example
FinancialMA
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Kairi Method : Kairi(String,Series,ElementValue,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
Kairi(String,Series,ElementValue,Series) Method
Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverageSeries As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim movingAverageSeries As Series
Dim value As Series

value = FinancialEngine.Kairi(seriesName, s, elementValue, movingAverageSeries)
public static Series Kairi(
   string seriesName,
   Series s,
   ElementValue elementValue,
   Series movingAverageSeries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Value

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Kairi Method : Kairi(Series,ElementValue,Series) Method
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
Kairi(Series,ElementValue,Series) Method
Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverageSeries As Series _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim movingAverageSeries As Series
Dim value As Series

value = FinancialEngine.Kairi(s, elementValue, movingAverageSeries)
public static Series Kairi(
   Series s,
   ElementValue elementValue,
   Series movingAverageSeries
)

Parameters

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverageSeries
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Value

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Kairi Method : Kairi(Series,ElementValue,SeriesCollection) Method
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
Kairi(Series,ElementValue,SeriesCollection) Method
Calculates the Kairi Indicator measure as a percentage of the price, the divergence between the a moving average (generally the simple moving average) of the price and the price itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal movingAverages As SeriesCollection _
) As SeriesCollection
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim movingAverages As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.Kairi(s, elementValue, movingAverages)
public static SeriesCollection Kairi(
   Series s,
   ElementValue elementValue,
   SeriesCollection movingAverages
)

Parameters

s
An series where the first term corresponds to the present price of the underlying asset for the most recent period, the second term corresponds to the present price of the underlying asset for the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
movingAverages
An series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.

Return Value

An series where the first term returns the Kairi indicator expressed as decimal format (i.e. 0.01 = 1 percent) for the most recent period, the second term returns the Kairi indicator for the previous period and so on.
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Application

The Kairi Indicator can be used in order to take advantage of an over extended trending market. For example, in an upwardly trending market when the price gets say more than 10% above the simple moving average, the asset could be sold and repurchased when the next hits the simple moving average again.

The Kairi Indicator could also be used in order to detect market tops and bottom. The idea being that market tops and bottoms often occur when the price is at an extreme value in relation to its moving average. That is, the Kairi Indicator should take an extreme value at market tops and bottoms.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : KFastStochastic Method
KFastStochastic Method
Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

Overload List
Overload Description
KFastStochastic(String,Series,Int32) Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

KFastStochastic(Series,Int32) Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

KFastStochastic(SeriesCollection,Int32) Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

Example
Stichastic
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > KFastStochastic Method : KFastStochastic(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of previous time periods used over which the closing price is compared.
KFastStochastic(String,Series,Int32) Method
Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KFastStochastic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.KFastStochastic(seriesName, s, noOfPeriods)
public static Series KFastStochastic(
   string seriesName,
   Series s,
   int noOfPeriods
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Value

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > KFastStochastic Method : KFastStochastic(Series,Int32) Method
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
An integer which represents the number of previous time periods used over which the closing price is compared.
KFastStochastic(Series,Int32) Method
Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KFastStochastic( _
   ByVal s As Series, _
   ByVal noOfPeriods As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfPeriods As Integer
Dim value As Series

value = FinancialEngine.KFastStochastic(s, noOfPeriods)
public static Series KFastStochastic(
   Series s,
   int noOfPeriods
)

Parameters

s
An financial series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Value

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > KFastStochastic Method : KFastStochastic(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the number of previous time periods used over which the closing price is compared.
KFastStochastic(SeriesCollection,Int32) Method
Evaluation of the Fast %K Stochastic when the number of previous time periods used over which the closing price is compared is given.

Indicator variables

The Stochastic %K depends on the following variable:

  • Periods - the number of previous time periods used over which the closing price is compared.

Now the formulae for the Stochastic %K over a is:

100 x (Last Close - Lowest low)/(Highest high - Lowest low)

where the "lowest low" (respec. "highest high") is the highest (respec. lowest) close of the asset over the period under consideration. Since the "Last close", will lie between the highest high and lowest low this indicator will lie between 0 and 100.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KFastStochastic( _
   ByVal sc As SeriesCollection, _
   ByVal noOfPeriods As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfPeriods As Integer
Dim value As SeriesCollection

value = FinancialEngine.KFastStochastic(sc, noOfPeriods)
public static SeriesCollection KFastStochastic(
   SeriesCollection sc,
   int noOfPeriods
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfPeriods
An integer which represents the number of previous time periods used over which the closing price is compared.

Return Value

A series where the first term is the KFastStochastic calculated for the most recent period, the second term is the KFastStochastic calculated for the previous period and so on.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Kurtosis Method
Kurtosis Method (FinancialEngine)
Calculates the kurtosis of the currently registered data set.
Overload List
Overload | Description
Kurtosis(String,Series,ElementValue) | Calculates the kurtosis of the currently registered data set.
Kurtosis(Series,ElementValue) | Calculates the kurtosis of the currently registered data set.
Kurtosis(String,SeriesCollection,ElementValue) | Calculates the kurtosis of the currently registered data set.
Kurtosis(SeriesCollection,ElementValue) | Calculates the kurtosis of the currently registered data set.
Example
FinancialKurtosisIndicator
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Kurtosis Method : Kurtosis(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Kurtosis(String,Series,ElementValue) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Kurtosis(elementName, s, elementValue)
public static Element Kurtosis(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Kurtosis Method : Kurtosis(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Kurtosis(Series,ElementValue) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Kurtosis(s, elementValue)
public static Element Kurtosis(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Kurtosis Method : Kurtosis(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Kurtosis(String,SeriesCollection,ElementValue) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Kurtosis(seriesName, sc, elementValue)
public static Series Kurtosis(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Kurtosis Method : Kurtosis(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Kurtosis(SeriesCollection,ElementValue) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Kurtosis(sc, elementValue)
public static Series Kurtosis(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : LinearMovingAverage Method
LinearMovingAverage Method
Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
Overload List
Overload | Description
LinearMovingAverage(String,Series,ElementValue,Int32) | Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
LinearMovingAverage(Series,ElementValue,Int32) | Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
LinearMovingAverage(SeriesCollection,ElementValue,Int32) | Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > LinearMovingAverage Method : LinearMovingAverage(String,Series,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the moving average is evaluated for each period.
LinearMovingAverage(String,Series,ElementValue,Int32) Method
Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.LinearMovingAverage(seriesName, s, elementValue, lengthOfMA)
public static Series LinearMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LinearMovingAverage Method : LinearMovingAverage(Series,ElementValue,Int32) Method
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the moving average is evaluated for each period.
LinearMovingAverage(Series,ElementValue,Int32) Method
Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.LinearMovingAverage(s, elementValue, lengthOfMA)
public static Series LinearMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

s
A series where the first element is the price on the earliest period, the second element is the price on the next earliest period and on so.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LinearMovingAverage Method : LinearMovingAverage(SeriesCollection,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
LinearMovingAverage(SeriesCollection,ElementValue,Int32) Method
Returns the value of the Linearly Weighted Moving Average(LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.LinearMovingAverage(sc, elementValue, lengthOfMA)
public static SeriesCollection LinearMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series priceSeries is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average(LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : LowerBollingerBands Method
LowerBollingerBands Method (FinancialEngine)
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Overload List
Overload | Description
LowerBollingerBands(String,Series,ElementValue,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
LowerBollingerBands(Series,ElementValue,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
LowerBollingerBands(SeriesCollection,ElementValue,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > LowerBollingerBands Method : LowerBollingerBands(String,Series,ElementValue,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(String,Series,ElementValue,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.LowerBollingerBands(seriesName, s, elementValue, standardDeviationLevel, lengthOfMA)
public static Series LowerBollingerBands(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LowerBollingerBands Method : LowerBollingerBands(Series,ElementValue,Double,Int32) Method
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(Series,ElementValue,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.LowerBollingerBands(s, elementValue, standardDeviationLevel, lengthOfMA)
public static Series LowerBollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
A series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LowerBollingerBands Method : LowerBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.LowerBollingerBands(sc, elementValue, standardDeviationLevel, lengthOfMA)
public static SeriesCollection LowerBollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : LowestPeriod Method
LowestPeriod Method
Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
Overload List
Overload | Description
LowestPeriod(String,Series,Int32) | Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
LowestPeriod(Series,Int32) | Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
LowestPeriod(SeriesCollection,Int32) | Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > LowestPeriod Method : LowestPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
LowestPeriod(String,Series,Int32) Method
Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowestPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.LowestPeriod(seriesName, s, noOfDays)
public static Series LowestPeriod(
   string seriesName,
   Series s,
   int noOfDays
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LowestPeriod Method : LowestPeriod(Series,Int32) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
LowestPeriod(Series,Int32) Method
Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowestPeriod( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.LowestPeriod(s, noOfDays)
public static Series LowestPeriod(
   Series s,
   int noOfDays
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > LowestPeriod Method : LowestPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of days before to which the closing price is compared.
LowestPeriod(SeriesCollection,Int32) Method
Returns an array which contains the lower lows values of prices array within a given period considering a look back period of n days.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowestPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfDays As Integer
Dim value As SeriesCollection

value = FinancialEngine.LowestPeriod(sc, noOfDays)
public static SeriesCollection LowestPeriod(
   SeriesCollection sc,
   int noOfDays
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the low calculated for the most recent trading period, the second term is the low for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : MarketFacilitationIndex Method
MarketFacilitationIndex Method
Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
Overload List
Overload | Description
MarketFacilitationIndex(String,Series) | Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
MarketFacilitationIndex(Series) | Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
MarketFacilitationIndex(SeriesCollection) | Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
Example
MarketFacilitationIndex
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MarketFacilitationIndex Method : MarketFacilitationIndex(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
MarketFacilitationIndex(String,Series) Method
Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MarketFacilitationIndex( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.MarketFacilitationIndex(seriesName, s)
public static Series MarketFacilitationIndex(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
Remarks

Evaluation

The formula for the calculation of MFI is:
MFI = (high - low)/volume
where high is the highest traded price during the period, low is the lowest traded price during the period and, volume is the overall volume traded on that period.

Interpretation

There are four types of trading sessions called:

  1. Fakes - volume is low but MFI is rising
  2. Fades - both volume and MFI is down (the price might move in the opposite direction)
  3. Squats - the volume is up, MFI is down
  4. Greens - when the MFI and volume are up which represent a strong signal to follow the trendline

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MarketFacilitationIndex Method : MarketFacilitationIndex(Series) Method
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
MarketFacilitationIndex(Series) Method
Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MarketFacilitationIndex( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.MarketFacilitationIndex(s)
public static Series MarketFacilitationIndex(
   Series s
)

Parameters

s
The financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
Remarks

Evaluation

The formula for the calculation of MFI is:
MFI = (high - low)/volume
where high is the highest traded price during the period, low is the lowest traded price during the period and, volume is the overall volume traded on that period.

Interpretation

There are four types of trading sessions called:

  1. Fakes - volume is low but MFI is rising
  2. Fades - both volume and MFI is down (the price might move in the opposite direction)
  3. Squats - the volume is up, MFI is down
  4. Greens - when the MFI and volume are up which represent a strong signal to follow the trendline

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MarketFacilitationIndex Method : MarketFacilitationIndex(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
MarketFacilitationIndex(SeriesCollection) Method
Market Facilitation Index was developed by Dr. Bill Williams and take into consideration the price and volume.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MarketFacilitationIndex( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.MarketFacilitationIndex(sc)
public static SeriesCollection MarketFacilitationIndex(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Evaluation

The formula for the calculation of MFI is:
MFI = (high - low)/volume
where high is the highest traded price during the period, low is the lowest traded price during the period and, volume is the overall volume traded on that period.

Interpretation

There are four types of trading sessions called:

  1. Fakes - volume is low but MFI is rising
  2. Fades - both volume and MFI is down (the price might move in the opposite direction)
  3. Squats - the volume is up, MFI is down
  4. Greens - when the MFI and volume are up which represent a strong signal to follow the trendline

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Mean Method
Mean Method (FinancialEngine)
Calculates the arithmetic mean of the elements values of the series.
Overload List
Overload | Description
Mean(String,Series,ElementValue) | Calculates the arithmetic mean of the elements values of the series.
Mean(Series,ElementValue) | Calculates the arithmetic mean of the elements values of the series.
Mean(String,SeriesCollection,ElementValue) | Calculates the arithmetic mean of the elements values of the series.
Mean(SeriesCollection,ElementValue) | Calculates the arithmetic mean of the elements values of the series.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Mean Method : Mean(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High . In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Mean(String,Series,ElementValue) Method
Calculates the arithmetic mean of the elements values of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Mean(elementName, s, elementValue)
public static Element Mean(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High . In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the geometric mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > Mean Method : Mean(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Mean(Series,ElementValue) Method
Calculates the arithmetic mean of the elements values of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Mean(s, elementValue)
public static Element Mean(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the geometric mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > Mean Method : Mean(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Mean(String,SeriesCollection,ElementValue) Method
Calculates the arithmetic mean of the elements values of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Mean(seriesName, sc, elementValue)
public static Series Mean(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the geometric mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class > Mean Method : Mean(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Mean(SeriesCollection,ElementValue) Method
Calculates the arithmetic mean of the elements values of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Mean(sc, elementValue)
public static Series Mean(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Evaluates the geometric mean of the series.


dotnetCHARTING Namespace > FinancialEngine Class : MeanDeviation Method
MeanDeviation Method (FinancialEngine)
Calculates the mean deviation of the series's element values.
Overload List
Overload | Description
MeanDeviation(String,Series,ElementValue) | Calculates the mean deviation of the series's element values.
MeanDeviation(Series,ElementValue) | Calculates the mean deviation of the series's element values.
MeanDeviation(String,SeriesCollection,ElementValue) | Calculates the mean deviation of the series's element values.
MeanDeviation(SeriesCollection,ElementValue) | Calculates the mean deviation of the series's element values.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MeanDeviation Method : MeanDeviation(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
MeanDeviation(String,Series,ElementValue) Method
Calculates the mean deviation of the series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.MeanDeviation(elementName, s, elementValue)
public static Element MeanDeviation(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MeanDeviation Method : MeanDeviation(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
MeanDeviation(Series,ElementValue) Method
Calculates the mean deviation of the series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.MeanDeviation(s, elementValue)
public static Element MeanDeviation(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MeanDeviation Method : MeanDeviation(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
MeanDeviation(String,SeriesCollection,ElementValue) Method
Calculates the mean deviation of the series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.MeanDeviation(seriesName, sc, elementValue)
public static Series MeanDeviation(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MeanDeviation Method : MeanDeviation(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
MeanDeviation(SeriesCollection,ElementValue) Method
Calculates the mean deviation of the series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.MeanDeviation(sc, elementValue)
public static Series MeanDeviation(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Median Method
Median Method (FinancialEngine)
Calculates the mean deviation of the series's element YValues.
Overload List
Overload | Description
Median(String,Series,ElementValue) | Calculates the mean deviation of the series's element YValues.
Median(Series,ElementValue) | Calculates the mean deviation of the series's element YValues.
Median(String,SeriesCollection,ElementValue) | Calculates the mean deviation of the series's element YValues.
Median(SeriesCollection,ElementValue) | Calculates the mean deviation of the series's element YValues.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Median Method : Median(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Median(String,Series,ElementValue) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Median(elementName, s, elementValue)
public static Element Median(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
A measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > Median Method : Median(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Median(Series,ElementValue) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Median(s, elementValue)
public static Element Median(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
A measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > Median Method : Median(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Median(String,SeriesCollection,ElementValue) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Median(seriesName, sc, elementValue)
public static Series Median(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
A measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > Median Method : Median(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Median(SeriesCollection,ElementValue) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Median(sc, elementValue)
public static Series Median(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
A measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class : MedianMovingAverage Method
MedianMovingAverage Method (FinancialEngine)
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Overload List
Overload | Description
MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
MedianMovingAverage(Series,ElementValue,Series,ElementValue,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MedianMovingAverage Method : MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(String,Series,ElementValue,Series,ElementValue,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal seriesName As String, _
   ByVal highSeries As Series, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeries As Series, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim highSeries As Series
Dim highSeriesElementValue As ElementValue
Dim lowSeries As Series
Dim lowSeriesElementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.MedianMovingAverage(seriesName, highSeries, highSeriesElementValue, lowSeries, lowSeriesElementValue, lengthOfMA)
public static Series MedianMovingAverage(
   string seriesName,
   Series highSeries,
   ElementValue highSeriesElementValue,
   Series lowSeries,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series historicalHigh and historicalLow are of different lengths or if one of these arrays is empty.
Remarks
For example, if we are considering a trading asset and the periods considered are days then by passing an series containing the closing daily prices of a given asset, and by choosing to use the 5-day median moving average (i.e. passing a length of the MA of 5), then we will evaluate the Median Moving Average(GMA) for all days for which the closing price on that day and the four previous days is known.

Remark: This indicator is particularly appropriate for traded assets where the opening and closing prices are unreliable. Such an instance are FTSE stocks which in the first hour of trading experience relatively low volumes and the closing prices are settled through an auction process. Hence for the FTSE market the quoted market price at the beginning and end of the market may not be indicative of where a given stock is trading within a given period. In such markets it may be more appropriate to use the Median Moving Average which will smooth out the effect of uncharacteristic shifts at the ends of the trading day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MedianMovingAverage Method : MedianMovingAverage(Series,ElementValue,Series,ElementValue,Int32) Method
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(Series,ElementValue,Series,ElementValue,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal highSeries As Series, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeries As Series, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim highSeries As Series
Dim highSeriesElementValue As ElementValue
Dim lowSeries As Series
Dim lowSeriesElementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.MedianMovingAverage(highSeries, highSeriesElementValue, lowSeries, lowSeriesElementValue, lengthOfMA)
public static Series MedianMovingAverage(
   Series highSeries,
   ElementValue highSeriesElementValue,
   Series lowSeries,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
)

Parameters

highSeries
An array where the first element corresponds to the highest market price during the last trading period, the second element corresponds to the highest market price in the previous period, and so on.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeries
An array where the first element corresponds to the lowest market price during the last trading period, the second term corresponds to the lowest market price in the previous period, and so on.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series historicalHigh and historicalLow are of different lengths or if one of these arrays is empty.
Remarks
For example, if we are considering a trading asset and the periods considered are days then by passing an series containing the closing daily prices of a given asset, and by choosing to use the 5-day median moving average (i.e. passing a length of the MA of 5), then we will evaluate the Median Moving Average(GMA) for all days for which the closing price on that day and the four previous days is known.

Remark: This indicator is particularly appropriate for traded assets where the opening and closing prices are unreliable. Such an instance are FTSE stocks which in the first hour of trading experience relatively low volumes and the closing prices are settled through an auction process. Hence for the FTSE market the quoted market price at the beginning and end of the market may not be indicative of where a given stock is trading within a given period. In such markets it may be more appropriate to use the Median Moving Average which will smooth out the effect of uncharacteristic shifts at the ends of the trading day.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MedianMovingAverage Method : MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(SeriesCollection,ElementValue,ElementValue,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal highSeriesElementValue As ElementValue, _
   ByVal lowSeriesElementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim sc As SeriesCollection
Dim highSeriesElementValue As ElementValue
Dim lowSeriesElementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.MedianMovingAverage(sc, highSeriesElementValue, lowSeriesElementValue, lengthOfMA)
public static Series MedianMovingAverage(
   SeriesCollection sc,
   ElementValue highSeriesElementValue,
   ElementValue lowSeriesElementValue,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
highSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lowSeriesElementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : MedianPrice Method
MedianPrice Method
Evaluates the Median Price of an asset for a given trading period.
Overload List
Overload | Description
MedianPrice(String,Series) | Evaluates the Median Price of an asset for a given trading period.
MedianPrice(Series) | Evaluates the Median Price of an asset for a given trading period.
MedianPrice(SeriesCollection) | Evaluates the Median Price of an asset for a given trading period.
Example
Filters
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MedianPrice Method : MedianPrice(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
The financial series under consideration.
MedianPrice(String,Series) Method
Evaluates the Median Price of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianPrice( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.MedianPrice(seriesName, s)
public static Series MedianPrice(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series under consideration.
Remarks
The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MedianPrice Method : MedianPrice(Series) Method
The financial series under consideration.
MedianPrice(Series) Method
Evaluates the Median Price of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianPrice( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.MedianPrice(s)
public static Series MedianPrice(
   Series s
)

Parameters

s
The financial series under consideration.
Remarks
The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MedianPrice Method : MedianPrice(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
MedianPrice(SeriesCollection) Method
Evaluates the Median Price of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianPrice( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.MedianPrice(sc)
public static SeriesCollection MedianPrice(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The Median price is just the midpoint of the trading periods range, where the period considered is generally a day, however the Median price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : MinusDirectionalMovement Method
MinusDirectionalMovement Method
Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
Overload List
Overload | Description
MinusDirectionalMovement(String,Series) | Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
MinusDirectionalMovement(Series) | Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
MinusDirectionalMovement(SeriesCollection) | Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
Example
Directional Movement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MinusDirectionalMovement Method : MinusDirectionalMovement(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
MinusDirectionalMovement(String,Series) Method
Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MinusDirectionalMovement( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.MinusDirectionalMovement(seriesName, s)
public static Series MinusDirectionalMovement(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the MDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Minus Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MinusDirectionalMovement Method : MinusDirectionalMovement(Series) Method
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
MinusDirectionalMovement(Series) Method
Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MinusDirectionalMovement( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.MinusDirectionalMovement(s)
public static Series MinusDirectionalMovement(
   Series s
)

Parameters

s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the MDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MinusDirectionalMovement Method : MinusDirectionalMovement(SeriesCollection) Method
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
MinusDirectionalMovement(SeriesCollection) Method
Evaluates the Minus Directional Movement Indicator (MDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MinusDirectionalMovement( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.MinusDirectionalMovement(sc)
public static SeriesCollection MinusDirectionalMovement(
   SeriesCollection sc
)

Parameters

sc
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A collections of series. Each series has the k-th term corresponds to the MDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Minus Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Momentum Method
Momentum Method
We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Overload List
Overload | Description
Momentum(String,Series,Int32) | We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Momentum(Series,Int32) | We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Momentum(SeriesCollection,Int32) | We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Example
Oscillators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Momentum Method : Momentum(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
Momentum(String,Series,Int32) Method
We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Momentum( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.Momentum(seriesName, s, noOfDays)
public static Series Momentum(
   string seriesName,
   Series s,
   int noOfDays
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Momentum Method : Momentum(Series,Int32) Method
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
Momentum(Series,Int32) Method
We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Momentum( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.Momentum(s, noOfDays)
public static Series Momentum(
   Series s,
   int noOfDays
)

Parameters

s
An series of length greate or equal to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Momentum Method : Momentum(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of days before to which the closing price is compared.
Momentum(SeriesCollection,Int32) Method
We evaluate the n-day momentum which is simply the difference between today's closing price and the close price n days ago, for all days for which sufficient historical data is given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Momentum( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfDays As Integer
Dim value As SeriesCollection

value = FinancialEngine.Momentum(sc, noOfDays)
public static SeriesCollection Momentum(
   SeriesCollection sc,
   int noOfDays
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the momentum for the most recent trading period, the second term is the momentum for the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The Momentum indicator as the name suggests is the velocity with which the price is rising or falling, and hence will reflect how aggressively the asset is being purchased or sold.

Remark: Extended values and/or turning points of the momentum are good indicators of oversold or over brought conditions(respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : MomentumPercent Method
MomentumPercent Method
We calculate the momentum pergentage over a given period.
Overload List
Overload | Description
MomentumPercent(String,Series,Int32) | We calculate the momentum pergentage over a given period.
MomentumPercent(Series,Int32) | We calculate the momentum pergentage over a given period.
MomentumPercent(SeriesCollection,Int32) | We calculate the momentum pergentage over a given period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MomentumPercent Method : MomentumPercent(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
MomentumPercent(String,Series,Int32) Method
We calculate the momentum pergentage over a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MomentumPercent( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.MomentumPercent(seriesName, s, noOfDays)
public static Series MomentumPercent(
   string seriesName,
   Series s,
   int noOfDays
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MomentumPercent Method : MomentumPercent(Series,Int32) Method
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
MomentumPercent(Series,Int32) Method
We calculate the momentum pergentage over a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MomentumPercent( _
   ByVal s As Series, _
   ByVal noOfDays As Integer _
) As Series
'Usage

Dim s As Series
Dim noOfDays As Integer
Dim value As Series

value = FinancialEngine.MomentumPercent(s, noOfDays)
public static Series MomentumPercent(
   Series s,
   int noOfDays
)

Parameters

s
An series of length equal or greater to the number of periods considered in the indicator evaluation where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
noOfDays
The number of days before to which the closing price is compared.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MomentumPercent Method : MomentumPercent(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of days before to which the closing price is compared.
MomentumPercent(SeriesCollection,Int32) Method
We calculate the momentum pergentage over a given period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MomentumPercent( _
   ByVal sc As SeriesCollection, _
   ByVal noOfDays As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim noOfDays As Integer
Dim value As SeriesCollection

value = FinancialEngine.MomentumPercent(sc, noOfDays)
public static SeriesCollection MomentumPercent(
   SeriesCollection sc,
   int noOfDays
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
noOfDays
The number of days before to which the closing price is compared.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the given series has strictly negative elements or if the noOfDays argument is greater then the length of prices array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : MoneyFlowIdxOverPeriod Method
MoneyFlowIdxOverPeriod Method
Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
Overload List
Overload | Description
MoneyFlowIdxOverPeriod(String,Series,Int32) | Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
MoneyFlowIdxOverPeriod(Series,Int32) | Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
MoneyFlowIdxOverPeriod(SeriesCollection,Int32) | Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
Example
Oscillators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > MoneyFlowIdxOverPeriod Method : MoneyFlowIdxOverPeriod(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
MoneyFlowIdxOverPeriod(String,Series,Int32) Method
Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MoneyFlowIdxOverPeriod( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.MoneyFlowIdxOverPeriod(seriesName, s, lengthOfPeriod)
public static Series MoneyFlowIdxOverPeriod(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MoneyFlowIdxOverPeriod Method : MoneyFlowIdxOverPeriod(Series,Int32) Method
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
MoneyFlowIdxOverPeriod(Series,Int32) Method
Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MoneyFlowIdxOverPeriod( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.MoneyFlowIdxOverPeriod(s, lengthOfPeriod)
public static Series MoneyFlowIdxOverPeriod(
   Series s,
   int lengthOfPeriod
)

Parameters

s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > MoneyFlowIdxOverPeriod Method : MoneyFlowIdxOverPeriod(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
MoneyFlowIdxOverPeriod(SeriesCollection,Int32) Method
Evaluates the Money Flow Index (MFI) which measures the strength of money flowing in and out of a security over all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MoneyFlowIdxOverPeriod( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.MoneyFlowIdxOverPeriod(sc, lengthOfPeriod)
public static SeriesCollection MoneyFlowIdxOverPeriod(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Exceptions
Exception | Description
System.ArgumentException | Thrown if any elements from the arrays high, low, close or volume are strictly negative, or if the length of the arrays is not equal or the lengthOfPeriod is grater than the length of the array high.
Remarks
The MFI is related to the Directional Movement Indicator of Wellas Wilder, but the MFI system also takes into account the volume as well as the price action.

Interpretation

Divergence of the indicator within a continuing trend indicates that a reversal is imminent. The MFI also is a good means to signal market tops and bottoms. A reasonable rule is a market top is given more significance when the MFI is above 80 and a market bottom is given more significance when the MFI is below 20.

Evaluation

The Money Flow Index (MFI) is evaluated over a given user defined number of trading periods. The evaluation of the MFI follows the below steps:

  • Evaluates the Money Flow on each day. The Money Flow is the product of the Typical Value Indicator (see Filters) for that day and the volume.
  • Each day is either classified as either a Positive Money Flow day, Negative Money Flow day or no Flow day. If the typical price increases then the day is a said to be a Positive Money Day, if it decreasing then it is said to be a negative money day and if it stays then same then it is said the be a no flow day.
  • The Positive Money and Negative Money Flow's are calculated by summing the Money Flow over the Positive Money Flow Days or the Negative Money Flow days respectively.
  • The Money Flow Index (MFI) is evaluated by dividing the Positive Money Flow by the Negative Money Flow.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : NegativeVolumeIndex Method
NegativeVolumeIndex Method
We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
Overload List
Overload | Description
NegativeVolumeIndex(String,Series) | We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
NegativeVolumeIndex(Series) | We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
NegativeVolumeIndex(SeriesCollection) | We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
Example
Volume Indicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > NegativeVolumeIndex Method : NegativeVolumeIndex(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
NegativeVolumeIndex(String,Series) Method
We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NegativeVolumeIndex( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.NegativeVolumeIndex(seriesName, s)
public static Series NegativeVolumeIndex(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empti or contain negative values.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > NegativeVolumeIndex Method : NegativeVolumeIndex(Series) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
NegativeVolumeIndex(Series) Method
We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NegativeVolumeIndex( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.NegativeVolumeIndex(s)
public static Series NegativeVolumeIndex(
   Series s
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty or contain negative values.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > NegativeVolumeIndex Method : NegativeVolumeIndex(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
NegativeVolumeIndex(SeriesCollection) Method
We evaluate the Negative Volume Index(NVI) wich take in the consideration the days where volume decrease from the prevoius day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NegativeVolumeIndex( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.NegativeVolumeIndex(sc)
public static SeriesCollection NegativeVolumeIndex(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series contain negative values.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is less then the yesterday volume then: NVI = Yesterday's NVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's NVI)
If today's volume is greater than or equal to yesterday's volume then:
NVI = Yesterday's NVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : OnBalanceVolume Method
OnBalanceVolume Method
On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
Overload List
Overload | Description
OnBalanceVolume(String,Series) | On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
OnBalanceVolume(Series) | On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
OnBalanceVolume(SeriesCollection) | On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
Example
VolumeIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > OnBalanceVolume Method : OnBalanceVolume(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
OnBalanceVolume(String,Series) Method
On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function OnBalanceVolume( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.OnBalanceVolume(seriesName, s)
public static Series OnBalanceVolume(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > OnBalanceVolume Method : OnBalanceVolume(Series) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
OnBalanceVolume(Series) Method
On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function OnBalanceVolume( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.OnBalanceVolume(s)
public static Series OnBalanceVolume(
   Series s
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > OnBalanceVolume Method : OnBalanceVolume(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
OnBalanceVolume(SeriesCollection) Method
On Balance Volume ("OBV") is a momentum indicator developed by Joe Granville that relates volume to price change.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function OnBalanceVolume( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.OnBalanceVolume(sc)
public static SeriesCollection OnBalanceVolume(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Indicator Formula

The formula for this indicator is:

If today's close is greater than yesterday's close then:
OBV = Yesterday's OBV + Today's Volume
If today's close is less than yesterday's close then:
OBV = Yesterday's OBV - Today's Volume
If today's close is equal to yesterday's close then:
OBV = Yesterday's OBV
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Percentile Method
Percentile Method (FinancialEngine)
Calculates the n-th percentile of the series.
Overload List
Overload | Description
Percentile(String,Series,ElementValue,Int32) | Calculates the n-th percentile of the series.
Percentile(Series,ElementValue,Int32) | Calculates the n-th percentile of the series.
Percentile(String,SeriesCollection,ElementValue,Int32) | Calculates the n-th percentile of the series.
Percentile(SeriesCollection,ElementValue,Int32) | Calculates the n-th percentile of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Percentile Method : Percentile(String,Series,ElementValue,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A value between 1 and 100 which reprezent the percentile of the series.
Percentile(String,Series,ElementValue,Int32) Method
Calculates the n-th percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal percentile As Integer _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim percentile As Integer
Dim value As Element

value = FinancialEngine.Percentile(elementName, s, elementValue, percentile)
public static Element Percentile(
   string elementName,
   Series s,
   ElementValue elementValue,
   int percentile
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
percentile
A value between 1 and 100 which reprezent the percentile of the series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile Method : Percentile(Series,ElementValue,Int32) Method
A FinancialEngine series.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A value between 1 and 100 which reprezent the percentile of the series.
Percentile(Series,ElementValue,Int32) Method
Calculates the n-th percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal percentile As Integer _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim percentile As Integer
Dim value As Element

value = FinancialEngine.Percentile(s, elementValue, percentile)
public static Element Percentile(
   Series s,
   ElementValue elementValue,
   int percentile
)

Parameters

s
A FinancialEngine series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
percentile
A value between 1 and 100 which reprezent the percentile of the series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile Method : Percentile(String,SeriesCollection,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A value between 1 and 100 which reprezent the percentile of the series.
Percentile(String,SeriesCollection,ElementValue,Int32) Method
Calculates the n-th percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal percentile As Integer _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim percentile As Integer
Dim value As Series

value = FinancialEngine.Percentile(seriesName, sc, elementValue, percentile)
public static Series Percentile(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue,
   int percentile
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
percentile
A value between 1 and 100 which reprezent the percentile of the series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile Method : Percentile(SeriesCollection,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A value between 1 and 100 which reprezent the percentile of the series.
Percentile(SeriesCollection,ElementValue,Int32) Method
Calculates the n-th percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal percentile As Integer _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim percentile As Integer
Dim value As Series

value = FinancialEngine.Percentile(sc, elementValue, percentile)
public static Series Percentile(
   SeriesCollection sc,
   ElementValue elementValue,
   int percentile
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
percentile
A value between 1 and 100 which reprezent the percentile of the series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Percentile25 Method
Percentile25 Method (FinancialEngine)
Calculates the first percentile of the series.
Overload List
Overload | Description
Percentile25(String,Series,ElementValue) | Calculates the first percentile of the series.
Percentile25(Series,ElementValue) | Calculates the first percentile of the series.
Percentile25(String,SeriesCollection,ElementValue) | Calculates the first percentile of the series.
Percentile25(SeriesCollection,ElementValue) | Calculates the first percentile of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Percentile25 Method : Percentile25(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile25(String,Series,ElementValue) Method
Calculates the first percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile25(elementName, s, elementValue)
public static Element Percentile25(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile25 Method : Percentile25(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile25(Series,ElementValue) Method
Calculates the first percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile25(s, elementValue)
public static Element Percentile25(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile25 Method : Percentile25(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile25(String,SeriesCollection,ElementValue) Method
Calculates the first percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile25(seriesName, sc, elementValue)
public static Series Percentile25(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile25 Method : Percentile25(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile25(SeriesCollection,ElementValue) Method
Calculates the first percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile25(sc, elementValue)
public static Series Percentile25(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Percentile50 Method
Percentile50 Method (FinancialEngine)
Calculates the second percentile of the series.
Overload List
Overload | Description
Percentile50(String,Series,ElementValue) | Calculates the second percentile of the series.
Percentile50(Series,ElementValue) | Calculates the second percentile of the series.
Percentile50(String,SeriesCollection,ElementValue) | Calculates the second percentile of the series.
Percentile50(SeriesCollection,ElementValue) | Calculates the second percentile of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Percentile50 Method : Percentile50(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile50(String,Series,ElementValue) Method
Calculates the second percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile50(elementName, s, elementValue)
public static Element Percentile50(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile50 Method : Percentile50(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile50(Series,ElementValue) Method
Calculates the second percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile50(s, elementValue)
public static Element Percentile50(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile50 Method : Percentile50(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile50(String,SeriesCollection,ElementValue) Method
Calculates the second percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile50(seriesName, sc, elementValue)
public static Series Percentile50(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile50 Method : Percentile50(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile50(SeriesCollection,ElementValue) Method
Calculates the second percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile50(sc, elementValue)
public static Series Percentile50(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Percentile75 Method
Percentile75 Method (FinancialEngine)
Calculates the third percentile of the series.
Overload List
Overload | Description
Percentile75(String,Series,ElementValue) | Calculates the third percentile of the series.
Percentile75(Series,ElementValue) | Calculates the third percentile of the series.
Percentile75(String,SeriesCollection,ElementValue) | Calculates the third percentile of the series.
Percentile75(SeriesCollection,ElementValue) | Calculates the third percentile of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Percentile75 Method : Percentile75(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile75(String,Series,ElementValue) Method
Calculates the third percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile75(elementName, s, elementValue)
public static Element Percentile75(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile75 Method : Percentile75(Series,ElementValue) Method
A FinancialEngine series.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile75(Series,ElementValue) Method
Calculates the third percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Percentile75(s, elementValue)
public static Element Percentile75(
   Series s,
   ElementValue elementValue
)

Parameters

s
A FinancialEngine series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile75 Method : Percentile75(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile75(String,SeriesCollection,ElementValue) Method
Calculates the third percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile75(seriesName, sc, elementValue)
public static Series Percentile75(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Percentile75 Method : Percentile75(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Percentile75(SeriesCollection,ElementValue) Method
Calculates the third percentile of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Percentile75(sc, elementValue)
public static Series Percentile75(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : PlusDirectionalMovement Method
PlusDirectionalMovement Method
Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
Overload List
Overload | Description
PlusDirectionalMovement(String,Series) | Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
PlusDirectionalMovement(Series) | Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
PlusDirectionalMovement(SeriesCollection) | Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
Example
Directional Movement
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > PlusDirectionalMovement Method : PlusDirectionalMovement(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
PlusDirectionalMovement(String,Series) Method
Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PlusDirectionalMovement( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.PlusDirectionalMovement(seriesName, s)
public static Series PlusDirectionalMovement(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the PDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Plus Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PlusDirectionalMovement Method : PlusDirectionalMovement(Series) Method
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
PlusDirectionalMovement(Series) Method
Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PlusDirectionalMovement( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.PlusDirectionalMovement(s)
public static Series PlusDirectionalMovement(
   Series s
)

Parameters

s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A series with the k-th term corresponds to the PDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Plus Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PlusDirectionalMovement Method : PlusDirectionalMovement(SeriesCollection) Method
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
PlusDirectionalMovement(SeriesCollection) Method
Evaluates the Plus Directional Movement Indicator (PDMI) over a number of periods using price data only.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PlusDirectionalMovement( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.PlusDirectionalMovement(sc)
public static SeriesCollection PlusDirectionalMovement(
   SeriesCollection sc
)

Parameters

sc
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A collections of series. Each series has the k-th term corresponds to the PDMI of the k-th Bar. Please note that if the asset price is constant over any period considered then the Plus Directional Movement Indicator for that period is taken to be zero.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : PositiveVolumeIndex Method
PositiveVolumeIndex Method
We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
Overload List
Overload | Description
PositiveVolumeIndex(String,Series) | We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
PositiveVolumeIndex(Series) | We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
PositiveVolumeIndex(SeriesCollection) | We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
Example
Volume Indicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > PositiveVolumeIndex Method : PositiveVolumeIndex(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
PositiveVolumeIndex(String,Series) Method
We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PositiveVolumeIndex( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.PositiveVolumeIndex(seriesName, s)
public static Series PositiveVolumeIndex(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PositiveVolumeIndex Method : PositiveVolumeIndex(Series) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
PositiveVolumeIndex(Series) Method
We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PositiveVolumeIndex( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.PositiveVolumeIndex(s)
public static Series PositiveVolumeIndex(
   Series s
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PositiveVolumeIndex Method : PositiveVolumeIndex(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
PositiveVolumeIndex(SeriesCollection) Method
We evaluate the Positive Volume Index(PVI) wich take in the consideration the days where volume increase from the previous day.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PositiveVolumeIndex( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.PositiveVolumeIndex(sc)
public static SeriesCollection PositiveVolumeIndex(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Indicator Formula

The formula for this indicator is:

If the volume is greater then the yesterday volume then:
PVI = Yesterday's PVI + (((Close - Yesterday's Close)/Yesterday's Close) *Yesterday's PVI)
If today's volume is less than or equal to yesterday's volume then:
PVI = Yesterday's PVI
Allways the first element of an financial array will be a value of the most recent period considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : PriceActionIndicator Method
PriceActionIndicator Method
Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
Overload List
Overload | Description
PriceActionIndicator(String,Series) | Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
PriceActionIndicator(Series) | Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
PriceActionIndicator(SeriesCollection) | Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
Example
Price Action Indicator
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > PriceActionIndicator Method : PriceActionIndicator(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
PriceActionIndicator(String,Series) Method
Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PriceActionIndicator( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.PriceActionIndicator(seriesName, s)
public static Series PriceActionIndicator(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.

Return Value

A series where the first element is the PAIN of the asset on the most recent period considered, the second term is the PAIN on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the High, Low, Open, Close are strictly negative.
Remarks

Evaluation

The PAIN indicator is evaluated by the following formula:
PAIN = ((Close-Open)+(Close-High)+(Close-Low))/2
where:

  1. (Close-Open) defines Intra-Day Momentum
  2. (Close-Low) defines Late Selling Pressure (LSP)
  3. (Close-High) defines Late Buying Pressure (LBP)
Close is the period closing price, Open is the period opening price, High is the highest traded price during the period and Low is the lowest traded price during the period.

Interpretation

When the close is near the low, the assets's price is under selling pressure. If the close is near the high the asset's price is price is under buying pressure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PriceActionIndicator Method : PriceActionIndicator(Series) Method
A financial series, where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.
PriceActionIndicator(Series) Method
Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PriceActionIndicator( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.PriceActionIndicator(s)
public static Series PriceActionIndicator(
   Series s
)

Parameters

s
A financial series, where the first element is the traded price on the most recent period, the second element is the traded price of the previous periods and so on, for the asset under consideration.

Return Value

A series where the first element is the PAIN of the asset on the most recent period considered, the second term is the PAIN on the period before that and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the High, Low, Open, Close are strictly negative.
Remarks

Evaluation

The PAIN indicator is evaluated by the following formula:
PAIN = ((Close-Open)+(Close-High)+(Close-Low))/2
where:

  1. (Close-Open) defines Intra-Day Momentum
  2. (Close-Low) defines Late Selling Pressure (LSP)
  3. (Close-High) defines Late Buying Pressure (LBP)
Close is the period closing price, Open is the period opening price, High is the highest traded price during the period and Low is the lowest traded price during the period.

Interpretation

When the close is near the low, the assets's price is under selling pressure. If the close is near the high the asset's price is price is under buying pressure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > PriceActionIndicator Method : PriceActionIndicator(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
PriceActionIndicator(SeriesCollection) Method
Evaluates the Price Action Indicator (PAIN) of an asset for a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PriceActionIndicator( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.PriceActionIndicator(sc)
public static SeriesCollection PriceActionIndicator(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the High, Low, Open, Close are strictly negative.
Remarks

Evaluation

The PAIN indicator is evaluated by the following formula:
PAIN = ((Close-Open)+(Close-High)+(Close-Low))/2
where:

  1. (Close-Open) defines Intra-Day Momentum
  2. (Close-Low) defines Late Selling Pressure (LSP)
  3. (Close-High) defines Late Buying Pressure (LBP)
Close is the period closing price, Open is the period opening price, High is the highest traded price during the period and Low is the lowest traded price during the period.

Interpretation

When the close is near the low, the assets's price is under selling pressure. If the close is near the high the asset's price is price is under buying pressure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Range Method
Range Method (FinancialEngine)
Calculates the range of the series's elements values.
Overload List
Overload | Description
Range(String,Series,ElementValue) | Calculates the range of the series's elements values.
Range(Series,ElementValue) | Calculates the range of the series's elements values.
Range(String,SeriesCollection,ElementValue) | Calculates the range of the series's elements values.
Range(SeriesCollection,ElementValue) | Calculates the range of the series's elements values.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Range Method : Range(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Range(String,Series,ElementValue) Method
Calculates the range of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Range(elementName, s, elementValue)
public static Element Range(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Range Method : Range(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Range(Series,ElementValue) Method
Calculates the range of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Range(s, elementValue)
public static Element Range(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Range Method : Range(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Range(String,SeriesCollection,ElementValue) Method
Calculates the range of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Range(seriesName, sc, elementValue)
public static Series Range(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Range Method : Range(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Range(SeriesCollection,ElementValue) Method
Calculates the range of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Range(sc, elementValue)
public static Series Range(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : RateOfChange Method
RateOfChange Method
Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
Overload List
Overload | Description
RateOfChange(String,Series,Int32) | Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
RateOfChange(Series,Int32) | Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
RateOfChange(SeriesCollection,Int32) | Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > RateOfChange Method : RateOfChange(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
RateOfChange(String,Series,Int32) Method
Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RateOfChange( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal numberDays As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim numberDays As Integer
Dim value As Series

value = FinancialEngine.RateOfChange(seriesName, s, numberDays)
public static Series RateOfChange(
   string seriesName,
   Series s,
   int numberDays
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > RateOfChange Method : RateOfChange(Series,Int32) Method
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
The number of days before to which the closing price is compared.
RateOfChange(Series,Int32) Method
Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RateOfChange( _
   ByVal s As Series, _
   ByVal numberDays As Integer _
) As Series
'Usage

Dim s As Series
Dim numberDays As Integer
Dim value As Series

value = FinancialEngine.RateOfChange(s, numberDays)
public static Series RateOfChange(
   Series s,
   int numberDays
)

Parameters

s
An series where the first element is the closing price in the last trading period, the second term is the closing price in the previous trading period and so on.
numberDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > RateOfChange Method : RateOfChange(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of days before to which the closing price is compared.
RateOfChange(SeriesCollection,Int32) Method
Calculate the n-day rate of change (ROC) for all periods for which there is sufficient data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RateOfChange( _
   ByVal sc As SeriesCollection, _
   ByVal numberDays As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim numberDays As Integer
Dim value As SeriesCollection

value = FinancialEngine.RateOfChange(sc, numberDays)
public static SeriesCollection RateOfChange(
   SeriesCollection sc,
   int numberDays
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
numberDays
The number of days before to which the closing price is compared.

Return Value

A series where the first term is the rate of change for the most recent period, the second term is the rate of change for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if either parameter is strictly negative.
Remarks
The (n-day) rate of change (ROC) is just the last closing price divided by the closing price n-days ago.

As with the case with the momentum indicator the rate of change (ROC) indicator on extended values and/or turning points indicates oversold or over brought conditions (respectively).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : RelativeStrengthIndex Method
RelativeStrengthIndex Method
Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
Overload List
Overload | Description
RelativeStrengthIndex(String,Series,Int32) | Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
RelativeStrengthIndex(Series,Int32) | Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
RelativeStrengthIndex(SeriesCollection,Int32) | Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > RelativeStrengthIndex Method : RelativeStrengthIndex(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
RelativeStrengthIndex(String,Series,Int32) Method
Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RelativeStrengthIndex( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.RelativeStrengthIndex(seriesName, s, lengthOfPeriod)
public static Series RelativeStrengthIndex(
   string seriesName,
   Series s,
   int lengthOfPeriod
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks

Evaluation

The RSI indicator is calculated by the following formula:

RSI = 100 - 100/(1+RS),

where:

RS = (Average of noOfPeriods days up closes) / (Average of noOfPeriods days' down closes),

Interpretation

An RSI above 70% is considered overbought and below 30% is considered oversold.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > RelativeStrengthIndex Method : RelativeStrengthIndex(Series,Int32) Method
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
RelativeStrengthIndex(Series,Int32) Method
Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RelativeStrengthIndex( _
   ByVal s As Series, _
   ByVal lengthOfPeriod As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfPeriod As Integer
Dim value As Series

value = FinancialEngine.RelativeStrengthIndex(s, lengthOfPeriod)
public static Series RelativeStrengthIndex(
   Series s,
   int lengthOfPeriod
)

Parameters

s
An series where the first element is the high in the last trading period, the second term is the high in the previous period and so on.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks

Evaluation

The RSI indicator is calculated by the following formula:

RSI = 100 - 100/(1+RS),

where:

RS = (Average of noOfPeriods days up closes) / (Average of noOfPeriods days' down closes),

Interpretation

An RSI above 70% is considered overbought and below 30% is considered oversold.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > RelativeStrengthIndex Method : RelativeStrengthIndex(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
RelativeStrengthIndex(SeriesCollection,Int32) Method
Implements the Relative Strength Indicator (RSI), developed by J. Welles Wilder in 1978; which measures the relative internal strength of a market. Please note that this indicator is not measured against another market or index. RSI measures the relative changes between higher and lower closing prices.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RelativeStrengthIndex( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfPeriod As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfPeriod As Integer
Dim value As SeriesCollection

value = FinancialEngine.RelativeStrengthIndex(sc, lengthOfPeriod)
public static SeriesCollection RelativeStrengthIndex(
   SeriesCollection sc,
   int lengthOfPeriod
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfPeriod
An integer which represents the length of the period over which the indicator will be iteratively evaluated.
Remarks

Evaluation

The RSI indicator is calculated by the following formula:

RSI = 100 - 100/(1+RS),

where:

RS = (Average of noOfPeriods days up closes) / (Average of noOfPeriods days' down closes),

Interpretation

An RSI above 70% is considered overbought and below 30% is considered oversold.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : SimpleMovingAverage Method
SimpleMovingAverage Method (FinancialEngine)
Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Overload List
Overload | Description
SimpleMovingAverage(String,Series,ElementValue,Int32) | Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
SimpleMovingAverage(Series,ElementValue,Int32) | Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
SimpleMovingAverage(SeriesCollection,ElementValue,Int32) | Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(String,Series,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(String,Series,ElementValue,Int32) Method
Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.SimpleMovingAverage(seriesName, s, elementValue, lengthOfMA)
public static Series SimpleMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(Series,ElementValue,Int32) Method
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(Series,ElementValue,Int32) Method
Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.SimpleMovingAverage(s, elementValue, lengthOfMA)
public static Series SimpleMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

s
A series where the first term is the most recent historical price, the second term is the previous historical price and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(SeriesCollection,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(SeriesCollection,ElementValue,Int32) Method
Calculates the arithmetic(or simple) Moving Average(MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.SimpleMovingAverage(sc, elementValue, lengthOfMA)
public static SeriesCollection SimpleMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Remarks

Illustration

If we are considering a traded asset and the periods considered are days then by passing an array containing the closing daily prices of a given asset, and by choosing to use the 5-day moving average (i.e. passing a length of the MA of 5), then this method will evaluate the Moving Average (MA) for all days for which the closing price on that day and the four previous days is known.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Skewness Method
Skewness Method (FinancialEngine)
Calculates the skewness of the currently registered data set.
Overload List
Overload | Description
Skewness(String,Series,ElementValue) | Calculates the skewness of the currently registered data set.
Skewness(Series,ElementValue) | Calculates the skewness of the currently registered data set.
Skewness(String,SeriesCollection,ElementValue) | Calculates the skewness of the currently registered data set.
Skewness(SeriesCollection,ElementValue) | Calculates the skewness of the currently registered data set.
Example
FinancialKurtosisIndicator
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Skewness Method : Skewness(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Skewness(String,Series,ElementValue) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Skewness(elementName, s, elementValue)
public static Element Skewness(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Skewness Method : Skewness(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Skewness(Series,ElementValue) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Skewness(s, elementValue)
public static Element Skewness(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Skewness Method : Skewness(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Skewness(String,SeriesCollection,ElementValue) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Skewness(seriesName, sc, elementValue)
public static Series Skewness(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > Skewness Method : Skewness(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Skewness(SeriesCollection,ElementValue) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Skewness(sc, elementValue)
public static Series Skewness(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : StandardDeviation Method
StandardDeviation Method (FinancialEngine)
Calculates the sample standard variance of the series's elements values.
Overload List
Overload | Description
StandardDeviation(String,Series,ElementValue) | Calculates the sample standard variance of the series's elements values.
StandardDeviation(Series,ElementValue) | Calculates the sample standard variance of the series's elements values.
StandardDeviation(String,SeriesCollection,ElementValue) | Calculates the sample standard variance of the series's elements values.
StandardDeviation(SeriesCollection,ElementValue) | Calculates the sample standard variance of the series's elements values.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > StandardDeviation Method : StandardDeviation(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
StandardDeviation(String,Series,ElementValue) Method
Calculates the sample standard variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.StandardDeviation(elementName, s, elementValue)
public static Element StandardDeviation(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(String,Series,ElementValue) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > StandardDeviation Method : StandardDeviation(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
StandardDeviation(Series,ElementValue) Method
Calculates the sample standard variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.StandardDeviation(s, elementValue)
public static Element StandardDeviation(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(Series,ElementValue) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > StandardDeviation Method : StandardDeviation(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
StandardDeviation(String,SeriesCollection,ElementValue) Method
Calculates the sample standard variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.StandardDeviation(seriesName, sc, elementValue)
public static Series StandardDeviation(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(String,SeriesCollection,ElementValue) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class > StandardDeviation Method : StandardDeviation(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
StandardDeviation(SeriesCollection,ElementValue) Method
Calculates the sample standard variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.StandardDeviation(sc, elementValue)
public static Series StandardDeviation(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(SeriesCollection,ElementValue) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.


dotnetCHARTING Namespace > FinancialEngine Class : TriangularMovingAverage Method
TriangularMovingAverage Method (FinancialEngine)
Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Overload List
Overload | Description
TriangularMovingAverage(String,Series,ElementValue,Int32) | Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
TriangularMovingAverage(Series,ElementValue,Int32) | Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
TriangularMovingAverage(SeriesCollection,ElementValue,Int32) | Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Example
Aroon Indicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(String,Series,ElementValue,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(String,Series,ElementValue,Int32) Method
Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.TriangularMovingAverage(seriesName, s, elementValue, lengthOfMA)
public static Series TriangularMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.
Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(Series,ElementValue,Int32) Method
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(Series,ElementValue,Int32) Method
Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.TriangularMovingAverage(s, elementValue, lengthOfMA)
public static Series TriangularMovingAverage(
   Series s,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

s
An series where the first term corresponds to value of the market variable (for example, closing price) in the last period, the second term corresponds to the value of the market variable in the previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.
Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(SeriesCollection,ElementValue,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(SeriesCollection,ElementValue,Int32) Method
Evaluates the x-period Triangular Moving Average(TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.TriangularMovingAverage(sc, elementValue, lengthOfMA)
public static SeriesCollection TriangularMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the FinancialEngine time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the value of the MA corresponding to the most recent period, the second term is the value of the MA on the previous period and so on.
Remarks

Further Explanation

The TMA is a special case of the WeightedMovingAverage, where the term triangular is motivated by the way in which the weights are chosen for the elements of the time series array. For example, for a 7-period TMA, that is when the time series has length 7, the corresponding weights of the time series elements are: 1, 2, 3, 4, 3, 2, 1. In the case of the 6 period TMA the weights would be 1, 2, 3, 3, 2, 1.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : TrueRange Method
TrueRange Method
True Range (TR) of a traded asset over a number of periods.
Overload List
Overload | Description
TrueRange(String,Series) | True Range (TR) of a traded asset over a number of periods.
TrueRange(Series) | True Range (TR) of a traded asset over a number of periods.
TrueRange(SeriesCollection) | True Range (TR) of a traded asset over a number of periods.
Example
TrueRange
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > TrueRange Method : TrueRange(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
TrueRange(String,Series) Method
True Range (TR) of a traded asset over a number of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrueRange( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.TrueRange(seriesName, s)
public static Series TrueRange(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

An array where the k-term corresponds to the True Range (TR) on the k-th previous period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TrueRange Method : TrueRange(Series) Method
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
TrueRange(Series) Method
True Range (TR) of a traded asset over a number of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrueRange( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.TrueRange(s)
public static Series TrueRange(
   Series s
)

Parameters

s
A financial series where the first element contain the prices of last trading period, the second element represents the prices of the previous periods and so on. Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

An array where the k-term corresponds to the True Range (TR) on the k-th previous period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TrueRange Method : TrueRange(SeriesCollection) Method
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.
TrueRange(SeriesCollection) Method
True Range (TR) of a traded asset over a number of periods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrueRange( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.TrueRange(sc)
public static SeriesCollection TrueRange(
   SeriesCollection sc
)

Parameters

sc
A collection of financial series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.Please note that in order to calculate this indicator the elements of the financial series must contain High, Low and Close values.

Return Value

A collections of series. Each series has the k-th term corresponds to the True Range (TR) on the k-th previous period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : TypicalPrice Method
TypicalPrice Method
Evaluates the Typical Price of an asset within a given trading period.
Overload List
Overload | Description
TypicalPrice(String,Series) | Evaluates the Typical Price of an asset within a given trading period.
TypicalPrice(Series) | Evaluates the Typical Price of an asset within a given trading period.
TypicalPrice(SeriesCollection) | Evaluates the Typical Price of an asset within a given trading period.
Example
Filters
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > TypicalPrice Method : TypicalPrice(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
The financial series.
TypicalPrice(String,Series) Method
Evaluates the Typical Price of an asset within a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TypicalPrice( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = FinancialEngine.TypicalPrice(seriesName, s)
public static Series TypicalPrice(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
The financial series.
Remarks
The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TypicalPrice Method : TypicalPrice(Series) Method
The financial series.
TypicalPrice(Series) Method
Evaluates the Typical Price of an asset within a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TypicalPrice( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = FinancialEngine.TypicalPrice(s)
public static Series TypicalPrice(
   Series s
)

Parameters

s
The financial series.
Remarks
The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > TypicalPrice Method : TypicalPrice(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
TypicalPrice(SeriesCollection) Method
Evaluates the Typical Price of an asset within a given trading period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TypicalPrice( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = FinancialEngine.TypicalPrice(sc)
public static SeriesCollection TypicalPrice(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The typical price is just the arithmetic average of the high, low and closing price for the trading period considered. Generally speaking the period considered will be a single trading day, however the typical price is equally applicable to other time spans and hence the period considered could be (for example) a month or year.

Applications

The Typical Price is often used in place of the closing price in the development of trading systems in which either another intra-day system is used from the intra-period timing of trades, or when the trading party is given discretion on intra-period trading decisions.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : UpperBollingerBands Method
UpperBollingerBands Method (FinancialEngine)
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Overload List
Overload | Description
UpperBollingerBands(String,Series,ElementValue,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
UpperBollingerBands(Series,ElementValue,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
UpperBollingerBands(SeriesCollection,ElementValue,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > UpperBollingerBands Method : UpperBollingerBands(String,Series,ElementValue,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(String,Series,ElementValue,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.UpperBollingerBands(seriesName, s, elementValue, standardDeviationLevel, lengthOfMA)
public static Series UpperBollingerBands(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > UpperBollingerBands Method : UpperBollingerBands(Series,ElementValue,Double,Int32) Method
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(Series,ElementValue,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.UpperBollingerBands(s, elementValue, standardDeviationLevel, lengthOfMA)
public static Series UpperBollingerBands(
   Series s,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
An series where the first term correspond the latest periods price and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > UpperBollingerBands Method : UpperBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(SeriesCollection,ElementValue,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.UpperBollingerBands(sc, elementValue, standardDeviationLevel, lengthOfMA)
public static SeriesCollection UpperBollingerBands(
   SeriesCollection sc,
   ElementValue elementValue,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : Variance Method
Variance Method (FinancialEngine)
Calculates the sample variance of the series's elements values.
Overload List
Overload | Description
Variance(String,Series,ElementValue) | Calculates the sample variance of the series's elements values.
Variance(Series,ElementValue) | Calculates the sample variance of the series's elements values.
Variance(String,SeriesCollection,ElementValue) | Calculates the sample variance of the series's elements values.
Variance(SeriesCollection,ElementValue) | Calculates the sample variance of the series's elements values.
Example
FinancialOneValueIndicators
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > Variance Method : Variance(String,Series,ElementValue) Method
The name of the element which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Variance(String,Series,ElementValue) Method
Calculates the sample variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Variance(elementName, s, elementValue)
public static Element Variance(
   string elementName,
   Series s,
   ElementValue elementValue
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
StandardDeviation(String,Series,ElementValue) Method


dotnetCHARTING Namespace > FinancialEngine Class > Variance Method : Variance(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Variance(Series,ElementValue) Method
Calculates the sample variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Element
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Element

value = FinancialEngine.Variance(s, elementValue)
public static Element Variance(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
StandardDeviation(Series,ElementValue) Method


dotnetCHARTING Namespace > FinancialEngine Class > Variance Method : Variance(String,SeriesCollection,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Variance(String,SeriesCollection,ElementValue) Method
Calculates the sample variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Variance(seriesName, sc, elementValue)
public static Series Variance(
   string seriesName,
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
StandardDeviation(String,SeriesCollection,ElementValue) Method


dotnetCHARTING Namespace > FinancialEngine Class > Variance Method : Variance(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Variance(SeriesCollection,ElementValue) Method
Calculates the sample variance of the series's elements values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.Variance(sc, elementValue)
public static Series Variance(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List
StandardDeviation(SeriesCollection,ElementValue) Method


dotnetCHARTING Namespace > FinancialEngine Class : WeightedMovingAverage Method
WeightedMovingAverage Method (FinancialEngine)
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Overload List
Overload | Description
WeightedMovingAverage(String,Series,ElementValue,Series,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(Series,Series,ElementValue,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(SeriesCollection,ElementValue,Series,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(String,Series,ElementValue,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
WeightedMovingAverage(Series,ElementValue,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
WeightedMovingAverage(SeriesCollection,ElementValue,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(String,Series,ElementValue,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(String,Series,ElementValue,Series,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim weightSeries As Series
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.WeightedMovingAverage(seriesName, s, elementValue, weightSeries, lengthOfMA)
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   Series weightSeries,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(Series,Series,ElementValue,Int32) Method
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(Series,Series,ElementValue,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal elementValue As ElementValue, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim weightSeries As Series
Dim elementValue As ElementValue
Dim lengthOfMA As Integer
Dim value As Series

value = FinancialEngine.WeightedMovingAverage(s, weightSeries, elementValue, lengthOfMA)
public static Series WeightedMovingAverage(
   Series s,
   Series weightSeries,
   ElementValue elementValue,
   int lengthOfMA
)

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(SeriesCollection,ElementValue,Series,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(SeriesCollection,ElementValue,Series,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim weightSeries As Series
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = FinancialEngine.WeightedMovingAverage(sc, elementValue, weightSeries, lengthOfMA)
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   Series weightSeries,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weightSeries
A series which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(String,Series,ElementValue,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(String,Series,ElementValue,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As Series

value = FinancialEngine.WeightedMovingAverage(seriesName, s, elementValue, weights)
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   ElementValue elementValue,
   double[] weights
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to (historicalPrices, weights, lengthOfMovingAverage).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(Series,ElementValue,Double[]) Method
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(Series,ElementValue,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As Series

value = FinancialEngine.WeightedMovingAverage(s, elementValue, weights)
public static Series WeightedMovingAverage(
   Series s,
   ElementValue elementValue,
   double[] weights
)

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to dotnetCHARTING.AnalysisEngine.Implementation.FinancialWeightedMovingAverage

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(SeriesCollection,ElementValue,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(SeriesCollection,ElementValue,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue, _
   ByVal weights() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim weights() As Double
Dim value As SeriesCollection

value = FinancialEngine.WeightedMovingAverage(sc, elementValue, weights)
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   ElementValue elementValue,
   double[] weights
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to WeightedMovingAverage(Series,ElementValue,Double[])

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class : ZScore Method
ZScore Method (FinancialEngine)
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Overload List
Overload | Description
ZScore(String,Series,ElementValue) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
ZScore(Series,ElementValue) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
ZScore(SeriesCollection,ElementValue) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Example
ZScore
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members


dotnetCHARTING Namespace > FinancialEngine Class > ZScore Method : ZScore(String,Series,ElementValue) Method
The name of the series which will be displayed on the chart, i.e. its label.
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
ZScore(String,Series,ElementValue) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.ZScore(seriesName, s, elementValue)
public static Series ZScore(
   string seriesName,
   Series s,
   ElementValue elementValue
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ZScore Method : ZScore(Series,ElementValue) Method
A financial series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
ZScore(Series,ElementValue) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal s As Series, _
   ByVal elementValue As ElementValue _
) As Series
'Usage

Dim s As Series
Dim elementValue As ElementValue
Dim value As Series

value = FinancialEngine.ZScore(s, elementValue)
public static Series ZScore(
   Series s,
   ElementValue elementValue
)

Parameters

s
A financial series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


dotnetCHARTING Namespace > FinancialEngine Class > ZScore Method : ZScore(SeriesCollection,ElementValue) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
ZScore(SeriesCollection,ElementValue) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal sc As SeriesCollection, _
   ByVal elementValue As ElementValue _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim elementValue As ElementValue
Dim value As SeriesCollection

value = FinancialEngine.ZScore(sc, elementValue)
public static SeriesCollection ZScore(
   SeriesCollection sc,
   ElementValue elementValue
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
elementValue
Specifies the particular element value (for example High, Low, Close or Open of the financial time series) which will be considered within this indicator evaluation. In particular, if you wish to use the element value high then you should pass the parameter High. In a similarly fashion if you wish to use the low, close or open, then you should pass the parameter Low, Close, Open, respectively.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine Class
FinancialEngine Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : FinancialEngine.Options Class
FinancialEngine.Options Class
Defines a set of static options used with FinancialEngine calculations.
Object Model
FinancialEngine.Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class FinancialEngine.Options
'Usage

Dim instance As FinancialEngine.Options
public sealed class FinancialEngine.Options
Inheritance Hierarchy

System.Object
dotnetCHARTING.FinancialEngine.Options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine.Options Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : FinancialEngine.Options Class
FinancialEngine.Options Class Members

The following tables list the members exposed by FinancialEngine.Options.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

FinancialEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : FinancialEngine.Options Class
FinancialEngine.Options Class Methods

For a list of all members of this type, see FinancialEngine.Options members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

FinancialEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > FinancialEngine.Options Class : Reset Method
Reset Method (FinancialEngine.Options)
Resets the options to default settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub Reset()
'Usage

FinancialEngine.Options.Reset()
public static void Reset()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine.Options Class
FinancialEngine.Options Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : FinancialEngine.Options Class
FinancialEngine.Options Class Properties

For a list of all members of this type, see FinancialEngine.Options members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
See Also

Reference

FinancialEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > FinancialEngine.Options Class : MatchColors Property
MatchColors Property (FinancialEngine.Options)
Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property MatchColors As Boolean
'Usage

Dim value As Boolean

FinancialEngine.Options.MatchColors = value

value = FinancialEngine.Options.MatchColors
public static bool MatchColors {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine.Options Class
FinancialEngine.Options Members


dotnetCHARTING Namespace > FinancialEngine.Options Class : PopulateSubValues Property
PopulateSubValues Property (FinancialEngine.Options)
Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property PopulateSubValues As Boolean
'Usage

Dim value As Boolean

FinancialEngine.Options.PopulateSubValues = value

value = FinancialEngine.Options.PopulateSubValues
public static bool PopulateSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

FinancialEngine.Options Class
FinancialEngine.Options Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ForecastEngine Class
ForecastEngine Class
Provides a set of methods that find the best fit curve of a data set.
Object Model
ForecastEngine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ForecastEngine
'Usage

Dim instance As ForecastEngine
public sealed class ForecastEngine
Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Methods

dotnetCHARTING Namespace : ForecastEngine Class
ForecastEngine Class Members

The following tables list the members exposed by ForecastEngine.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | TrendLine | Overloaded. Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
static (Shared in Visual Basic) | TrendLineExponential | Overloaded. Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
static (Shared in Visual Basic) | TrendLineLogarithmic | Overloaded. Find the best fit for the function f(x) = a + b * ln(x).
static (Shared in Visual Basic) | TrendLinePolynomial | Overloaded. Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
static (Shared in Visual Basic) | TrendLinePower | Overloaded. Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Top
See Also

Reference

ForecastEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ForecastEngine Class
ForecastEngine Class Methods

For a list of all members of this type, see ForecastEngine members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | TrendLine | Overloaded. Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
static (Shared in Visual Basic) | TrendLineExponential | Overloaded. Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
static (Shared in Visual Basic) | TrendLineLogarithmic | Overloaded. Find the best fit for the function f(x) = a + b * ln(x).
static (Shared in Visual Basic) | TrendLinePolynomial | Overloaded. Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
static (Shared in Visual Basic) | TrendLinePower | Overloaded. Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Top
See Also

Reference

ForecastEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > ForecastEngine Class : TrendLine Method
TrendLine Method
Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
Overload List
Overload | Description
TrendLine(String,Series,Series,Int32) | Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
TrendLine(Series,Series,Int32) | Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
TrendLine(SeriesCollection,Series,Int32) | Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members


dotnetCHARTING Namespace > ForecastEngine Class > TrendLine Method : TrendLine(String,Series,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A series wich contains the standard deviations of the given data point.
When this parameter is 0 the standard deviation will not be considered.
TrendLine(String,Series,Series,Int32) Method
Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLine( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim deviations As Series
Dim mwt As Integer
Dim value As Series

value = ForecastEngine.TrendLine(seriesName, s, deviations, mwt)
public static Series TrendLine(
   string seriesName,
   Series s,
   Series deviations,
   int mwt
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLine Method : TrendLine(Series,Series,Int32) Method
A statistical series.
A series wich contains the standard deviations of the given data point.
When this parameter is 0 the standard deviation will not be considered.
TrendLine(Series,Series,Int32) Method
Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLine( _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As Series
'Usage

Dim s As Series
Dim deviations As Series
Dim mwt As Integer
Dim value As Series

value = ForecastEngine.TrendLine(s, deviations, mwt)
public static Series TrendLine(
   Series s,
   Series deviations,
   int mwt
)

Parameters

s
A statistical series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLine Method : TrendLine(SeriesCollection,Series,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A series wich contains the standard deviations of the given data point.
When this parameter is 0 the standard deviation will not be considered.
TrendLine(SeriesCollection,Series,Int32) Method
Given a set of data points x[0..ndata-1],y[0..ndata-1] with individual standard deviations sig[0..ndata-1], fit them to a straight line y = a + bx by minimizing ¥ö2. Returned are a,b and their respective probable uncertainties siga and sigb, the chi-square chi2, and the goodness-of-fit probability q (that the fit would have ¥ö2 this large or larger). If mwt=0 on input, then the standard deviations are assumed to be unavailable: q is returned as 1.0 and the normalization of chi2 is to unit standard deviation on all points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLine( _
   ByVal sc As SeriesCollection, _
   ByVal deviations As Series, _
   ByVal mwt As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim deviations As Series
Dim mwt As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLine(sc, deviations, mwt)
public static SeriesCollection TrendLine(
   SeriesCollection sc,
   Series deviations,
   int mwt
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
A series wich contains the standard deviations of the given data point.
mwt
When this parameter is 0 the standard deviation will not be considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class : TrendLineExponential Method
TrendLineExponential Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Overload List
Overload | Description
TrendLineExponential(String,Series) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
TrendLineExponential(Series) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
TrendLineExponential(SeriesCollection) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
TrendLineExponential(String,Series,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
TrendLineExponential(Series,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
TrendLineExponential(SeriesCollection,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Example
TrendLineExponential
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
TrendLineExponential(String,Series) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLineExponential(seriesName, s)
public static Series TrendLineExponential(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(Series) Method
A statistical series.
TrendLineExponential(Series) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLineExponential(s)
public static Series TrendLineExponential(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
TrendLineExponential(SeriesCollection) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.TrendLineExponential(sc)
public static SeriesCollection TrendLineExponential(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(String,Series,Double,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineExponential(String,Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLineExponential(seriesName, s, step, forward, backward)
public static Series TrendLineExponential(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(Series,Double,Int32,Int32) Method
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineExponential(Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLineExponential(s, step, forward, backward)
public static Series TrendLineExponential(
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineExponential Method : TrendLineExponential(SeriesCollection,Double,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineExponential(SeriesCollection,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow(e, B*x ) where B = b and A = exp( a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineExponential( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLineExponential(sc, step, forward, backward)
public static SeriesCollection TrendLineExponential(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class : TrendLineLogarithmic Method
TrendLineLogarithmic Method
Find the best fit for the function f(x) = a + b * ln(x).
Overload List
Overload | Description
TrendLineLogarithmic(String,Series) | Find the best fit for the function f(x) = a + b * ln(x).
TrendLineLogarithmic(Series) | Find the best fit for the function f(x) = a + b * ln(x).
TrendLineLogarithmic(SeriesCollection) | Find the best fit for the function f(x) = a + b * ln(x).
TrendLineLogarithmic(String,Series,Double,Int32,Int32) | Find the best fit for the function f(x) = a + b * ln(x).
TrendLineLogarithmic(Series,Double,Int32,Int32) | Find the best fit for the function f(x) = a + b * ln(x).
TrendLineLogarithmic(SeriesCollection,Double,Int32,Int32) | Find the best fit for the function f(x) = a + b * ln(x).
Example
TrendLineLogarithmic
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
TrendLineLogarithmic(String,Series) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLineLogarithmic(seriesName, s)
public static Series TrendLineLogarithmic(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(Series) Method
A statistical series.
TrendLineLogarithmic(Series) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLineLogarithmic(s)
public static Series TrendLineLogarithmic(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
TrendLineLogarithmic(SeriesCollection) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.TrendLineLogarithmic(sc)
public static SeriesCollection TrendLineLogarithmic(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(String,Series,Double,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineLogarithmic(String,Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLineLogarithmic(seriesName, s, step, forward, backward)
public static Series TrendLineLogarithmic(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(Series,Double,Int32,Int32) Method
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineLogarithmic(Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLineLogarithmic(s, step, forward, backward)
public static Series TrendLineLogarithmic(
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLineLogarithmic Method : TrendLineLogarithmic(SeriesCollection,Double,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLineLogarithmic(SeriesCollection,Double,Int32,Int32) Method
Find the best fit for the function f(x) = a + b * ln(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLineLogarithmic( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLineLogarithmic(sc, step, forward, backward)
public static SeriesCollection TrendLineLogarithmic(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class : TrendLinePolynomial Method
TrendLinePolynomial Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
Overload List
Overload | Description
TrendLinePolynomial(String,Series,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
TrendLinePolynomial(Series,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
TrendLinePolynomial(SeriesCollection,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
TrendLinePolynomial(String,Series,Int32,Double,Int32,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
TrendLinePolynomial(Series,Int32,Double,Int32,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
TrendLinePolynomial(SeriesCollection,Int32,Double,Int32,Int32) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
TrendLinePolynomial(String,Series,Int32,DateTime,DateTime) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
TrendLinePolynomial(Series,Int32,DateTime,DateTime) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
TrendLinePolynomial(SeriesCollection,Int32,DateTime,DateTime) | Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Example
TrendLinePolynomial
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
TrendLinePolynomial(String,Series,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal degree As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim degree As Integer
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(seriesName, s, degree)
public static Series TrendLinePolynomial(
   string seriesName,
   Series s,
   int degree
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List
Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(Series,Int32) Method
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
TrendLinePolynomial(Series,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal s As Series, _
   ByVal degree As Integer _
) As Series
'Usage

Dim s As Series
Dim degree As Integer
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(s, degree)
public static Series TrendLinePolynomial(
   Series s,
   int degree
)

Parameters

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List
Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
TrendLinePolynomial(SeriesCollection,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returned the values of the fitted function over the same range of the x-coordinate as the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal sc As SeriesCollection, _
   ByVal degree As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim degree As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLinePolynomial(sc, degree)
public static SeriesCollection TrendLinePolynomial(
   SeriesCollection sc,
   int degree
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List
Allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(String,Series,Int32,Double,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePolynomial(String,Series,Int32,Double,Int32,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim degree As Integer
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(seriesName, s, degree, step, forward, backward)
public static Series TrendLinePolynomial(
   string seriesName,
   Series s,
   int degree,
   double step,
   int forward,
   int backward
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(Series,Int32,Double,Int32,Int32) Method
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePolynomial(Series,Int32,Double,Int32,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim s As Series
Dim degree As Integer
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(s, degree, step, forward, backward)
public static Series TrendLinePolynomial(
   Series s,
   int degree,
   double step,
   int forward,
   int backward
)

Parameters

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(SeriesCollection,Int32,Double,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePolynomial(SeriesCollection,Int32,Double,Int32,Int32) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal sc As SeriesCollection, _
   ByVal degree As Integer, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim degree As Integer
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLinePolynomial(sc, degree, step, forward, backward)
public static SeriesCollection TrendLinePolynomial(
   SeriesCollection sc,
   int degree,
   double step,
   int forward,
   int backward
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(String,Series,Int32,DateTime,DateTime) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The start date of the trend line
The end date of the trend line
TrendLinePolynomial(String,Series,Int32,DateTime,DateTime) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal startDate As Date, _
   ByVal endDate As Date _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim degree As Integer
Dim startDate As Date
Dim endDate As Date
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(seriesName, s, degree, startDate, endDate)
public static Series TrendLinePolynomial(
   string seriesName,
   Series s,
   int degree,
   DateTime startDate,
   DateTime endDate
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
startDate
The start date of the trend line
endDate
The end date of the trend line

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(Series,Int32,DateTime,DateTime) Method
A statistical series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The start date of the trend line
The end date of the trend line
TrendLinePolynomial(Series,Int32,DateTime,DateTime) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal s As Series, _
   ByVal degree As Integer, _
   ByVal startDate As Date, _
   ByVal endDate As Date _
) As Series
'Usage

Dim s As Series
Dim degree As Integer
Dim startDate As Date
Dim endDate As Date
Dim value As Series

value = ForecastEngine.TrendLinePolynomial(s, degree, startDate, endDate)
public static Series TrendLinePolynomial(
   Series s,
   int degree,
   DateTime startDate,
   DateTime endDate
)

Parameters

s
A statistical series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
startDate
The start date of the trend line
endDate
The end date of the trend line

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePolynomial Method : TrendLinePolynomial(SeriesCollection,Int32,DateTime,DateTime) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
The start date of the trend line
The end date of the trend line
TrendLinePolynomial(SeriesCollection,Int32,DateTime,DateTime) Method
Fits a polynomial of a given degree to a data set in accordance with the least squares approach and returns the value of the fitted function over an extended (i.e. above, below or both) range of the x-coordinate values of the given data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePolynomial( _
   ByVal sc As SeriesCollection, _
   ByVal degree As Integer, _
   ByVal startDate As Date, _
   ByVal endDate As Date _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim degree As Integer
Dim startDate As Date
Dim endDate As Date
Dim value As SeriesCollection

value = ForecastEngine.TrendLinePolynomial(sc, degree, startDate, endDate)
public static SeriesCollection TrendLinePolynomial(
   SeriesCollection sc,
   int degree,
   DateTime startDate,
   DateTime endDate
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
degree
The degree of the polynomial which is fitted to the data set given (i.e. if degree is 2, then a quadratic is fitted).
startDate
The start date of the trend line
endDate
The end date of the trend line

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.

Remark: This methods corresponds in functionality to the method of the same name within Microsoft Excel.

Remarks
For example, if we fit a polynomial of degree 2, then we fit the quadratic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2); similarly if we fit a polynomial of degree 3, then we fit the cubic polynomial (i.e. f(x) = a_0 + a_1 x + a_2 x^2 + a_3 x^3).

Remark: The difference between this method and TrendLinePolynomial(String,Series,Int32), is that it allows the values of the fitted function to be evaluated over an extended range. That is, a range in the x-coordinate greater than the original given data set.

Where the extended values are evaluated?

The parameters step, forward, backward allows the position and number of additional points above and/or below the range of the values in the x-coordinate of the original data set to be given. The forward parameter specifies the number of the additional evaluation points of the fitted function which are greater than the values of the x-coordinates of the original data set. Similarly, the backward parameter specifies the number of the additional evaluation points of the fitted function which are lower than the values of the x-coordinates of the original data set. The step specifies the distance in the x-coordinate between each of the additional data points, where the first additional data point either above or below is exactly a distance of step from the points of the original data set which the highest and lowest values in the x-coordinate.

For example, consider the data set x = 1, 2, 3; y = 1, 2, 3. Now if step = 1, forward = 2, and backward = 3, then this method when applied will return a two dimensional array. This two dimensional array will have the following structure: { { -2, f(-2) } { -1, f(-1) } { 0, f(0) }{ 1, 1 } { 2, 2 }{ 3, 3 } { 4, f(4) } { 5, f(5) } }, where f(-2), f(-1), f(0), f(4), f(5) correspond to the value of the fitted functions at the points x = -2, -1, 0, 4, 5, respectively.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class : TrendLinePower Method
TrendLinePower Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Overload List
Overload | Description
TrendLinePower(String,Series) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
TrendLinePower(Series) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
TrendLinePower(SeriesCollection) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
TrendLinePower(String,Series,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
TrendLinePower(Series,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
TrendLinePower(SeriesCollection,Double,Int32,Int32) | Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Example
TrendLinePower
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
TrendLinePower(String,Series) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLinePower(seriesName, s)
public static Series TrendLinePower(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(Series) Method
A statistical series.
TrendLinePower(Series) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.TrendLinePower(s)
public static Series TrendLinePower(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
TrendLinePower(SeriesCollection) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.TrendLinePower(sc)
public static SeriesCollection TrendLinePower(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(String,Series,Double,Int32,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePower(String,Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLinePower(seriesName, s, step, forward, backward)
public static Series TrendLinePower(
   string seriesName,
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(Series,Double,Int32,Int32) Method
A statistical series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePower(Series,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal s As Series, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As Series
'Usage

Dim s As Series
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As Series

value = ForecastEngine.TrendLinePower(s, step, forward, backward)
public static Series TrendLinePower(
   Series s,
   double step,
   int forward,
   int backward
)

Parameters

s
A statistical series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


dotnetCHARTING Namespace > ForecastEngine Class > TrendLinePower Method : TrendLinePower(SeriesCollection,Double,Int32,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.
TrendLinePower(SeriesCollection,Double,Int32,Int32) Method
Find the best fit for the function f(x) = A * pow (x, B ) where B = b and A = pow(e, a).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TrendLinePower( _
   ByVal sc As SeriesCollection, _
   ByVal step As Double, _
   ByVal forward As Integer, _
   ByVal backward As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim step As Double
Dim forward As Integer
Dim backward As Integer
Dim value As SeriesCollection

value = ForecastEngine.TrendLinePower(sc, step, forward, backward)
public static SeriesCollection TrendLinePower(
   SeriesCollection sc,
   double step,
   int forward,
   int backward
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
step
The distance in the x-coordinate between two adjacent extended points. Please note that this also corresponds to the distance in the x-coordinate between the highest and lowest original data point and the first (above or below) additional evaluation point.
forward
The number of additional evaluation points which are evaluated above the x-coordinates of the original given data set.
backward
The number of additional evaluation points which are evaluated below the x-coordinates of the original given data set.

Return Value

A series where the k-th element of the array represents of k-th point (i.e. { x_k, y_k }) of the total set over which the fitted function is evaluated. The total set over which the fitted function is evaluated consists of the `backward' points, original data set points and the `forward' points.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine Class
ForecastEngine Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ForecastEngine.Advanced Class
ForecastEngine.Advanced Class
This class contains advanced methods for calculating the best fitting curve of a data set. It allows the user to construct his own function.
Object Model
ForecastEngine.Advanced Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ForecastEngine.Advanced
'Usage

Dim instance As ForecastEngine.Advanced
public sealed class ForecastEngine.Advanced
Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine.Advanced

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Methods

dotnetCHARTING Namespace : ForecastEngine.Advanced Class
ForecastEngine.Advanced Class Members

The following tables list the members exposed by ForecastEngine.Advanced.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BesselI | Overloaded. Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselJ | Overloaded. Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselK | Overloaded. Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselY | Overloaded. Calcuates the modified Bessel function Yn(x) for any real x and n ≥ 0.
static (Shared in Visual Basic) | Beta | Overloaded. Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
static (Shared in Visual Basic) | ComplementaryErrorFunction | Overloaded. Calcuates the complementary error function erfc(x).
static (Shared in Visual Basic) | ErrorFunction | Overloaded. Calcuates the error function erf(x).
static (Shared in Visual Basic) | GammaLn | Overloaded. Calcuates the logarithm of Gamma function.
static (Shared in Visual Basic) | GammaP | Overloaded. Calcuates the incomplete Gamma function P(a, x).
static (Shared in Visual Basic) | GammaQ | Overloaded. Calcuates the incomplete Gamma function Q(a, x).
static (Shared in Visual Basic) | GeneralLinear | Overloaded. Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
static (Shared in Visual Basic) | NonLinearModel | Overloaded. Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Top
See Also

Reference

ForecastEngine.Advanced Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ForecastEngine.Advanced Class
ForecastEngine.Advanced Class Methods

For a list of all members of this type, see ForecastEngine.Advanced members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BesselI | Overloaded. Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselJ | Overloaded. Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselK | Overloaded. Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
static (Shared in Visual Basic) | BesselY | Overloaded. Calcuates the modified Bessel function Yn(x) for any real x and n ≥ 0.
static (Shared in Visual Basic) | Beta | Overloaded. Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
static (Shared in Visual Basic) | ComplementaryErrorFunction | Overloaded. Calcuates the complementary error function erfc(x).
static (Shared in Visual Basic) | ErrorFunction | Overloaded. Calcuates the error function erf(x).
static (Shared in Visual Basic) | GammaLn | Overloaded. Calcuates the logarithm of Gamma function.
static (Shared in Visual Basic) | GammaP | Overloaded. Calcuates the incomplete Gamma function P(a, x).
static (Shared in Visual Basic) | GammaQ | Overloaded. Calcuates the incomplete Gamma function Q(a, x).
static (Shared in Visual Basic) | GeneralLinear | Overloaded. Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
static (Shared in Visual Basic) | NonLinearModel | Overloaded. Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Top
See Also

Reference

ForecastEngine.Advanced Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : BesselI Method
BesselI Method
Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
Overload List
Overload | Description
BesselI(String,Series,Int32) | Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
BesselI(Series,Int32) | Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
BesselI(SeriesCollection,Int32) | Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
BesselI


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselI Method : BesselI(String,Series,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
The grade of the function.
BesselI(String,Series,Int32) Method
Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselI( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselI(elementName, s, n)
public static Series BesselI(
   string elementName,
   Series s,
   int n
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
n
The grade of the function.

Return Value

Returns the modified Bessel function Ix(x) for any real x and n ≥ 2.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
In(x) ≅ (1/√2πx)exp(x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK
BesselJ
BesselY


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselI Method : BesselI(Series,Int32) Method
A statistical series.
The grade of the function.
BesselI(Series,Int32) Method
Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselI( _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselI(s, n)
public static Series BesselI(
   Series s,
   int n
)

Parameters

s
A statistical series.
n
The grade of the function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
In(x) ≅ (1/√2πx)exp(x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselJ.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselI Method : BesselI(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The grade of the function.
BesselI(SeriesCollection,Int32) Method
Calcuates the modified Bessel function Ix(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselI( _
   ByVal sc As SeriesCollection, _
   ByVal n As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim n As Integer
Dim value As SeriesCollection

value = ForecastEngine.Advanced.BesselI(sc, n)
public static SeriesCollection BesselI(
   SeriesCollection sc,
   int n
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
n
The grade of the function.
Remarks
In(x) ≅ (1/√2πx)exp(x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselJ.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : BesselJ Method
BesselJ Method
Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
Overload List
Overload | Description
BesselJ(String,Series,Int32) | Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
BesselJ(Series,Int32) | Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
BesselJ(SeriesCollection,Int32) | Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
BesselJ


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselJ Method : BesselJ(String,Series,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
The grade of the function.
BesselJ(String,Series,Int32) Method
Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselJ( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselJ(elementName, s, n)
public static Series BesselJ(
   string elementName,
   Series s,
   int n
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
n
The grade of the function.

Return Value

Returns the modified Bessel function Ix(x) for any real x and n ≥ 2.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
Jn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) - Qn(8/x)sin(Xn)] where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK
BesselI
BesselY


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselJ Method : BesselJ(Series,Int32) Method
A statistical series.
The grade of the function.
BesselJ(Series,Int32) Method
Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselJ( _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselJ(s, n)
public static Series BesselJ(
   Series s,
   int n
)

Parameters

s
A statistical series.
n
The grade of the function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
Jn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) - Qn(8/x)sin(Xn)]
where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselI.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselJ Method : BesselJ(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The grade of the function.
BesselJ(SeriesCollection,Int32) Method
Calcuates the modified Bessel function Jx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselJ( _
   ByVal sc As SeriesCollection, _
   ByVal n As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim n As Integer
Dim value As SeriesCollection

value = ForecastEngine.Advanced.BesselJ(sc, n)
public static SeriesCollection BesselJ(
   SeriesCollection sc,
   int n
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
n
The grade of the function.
Remarks
Jn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) - Qn(8/x)sin(Xn)]
where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselI.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : BesselK Method
BesselK Method
Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
Overload List
Overload | Description
BesselK(String,Series,Int32) | Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
BesselK(Series,Int32) | Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
BesselK(SeriesCollection,Int32) | Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
BesselK


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselK Method : BesselK(String,Series,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
The grade of the function.
BesselK(String,Series,Int32) Method
Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselK( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselK(elementName, s, n)
public static Series BesselK(
   string elementName,
   Series s,
   int n
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
n
The grade of the function.

Return Value

Returns the modified Bessel function Ix(x) for any real x and n ≥ 2.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
Kn(x) ≅ (1/√2πx)exp(-x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselJ
BesselI
BesselY


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselK Method : BesselK(Series,Int32) Method
A statistical series.
The grade of the function.
BesselK(Series,Int32) Method
Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselK( _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselK(s, n)
public static Series BesselK(
   Series s,
   int n
)

Parameters

s
A statistical series.
n
The grade of the function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
Kn(x) ≅ (1/√2πx)exp(-x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselJ.
BesselI.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselK Method : BesselK(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The grade of the function.
BesselK(SeriesCollection,Int32) Method
Calcuates the modified Bessel function Kx(x) for any real x and n ≥ 2.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselK( _
   ByVal sc As SeriesCollection, _
   ByVal n As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim n As Integer
Dim value As SeriesCollection

value = ForecastEngine.Advanced.BesselK(sc, n)
public static SeriesCollection BesselK(
   SeriesCollection sc,
   int n
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
n
The grade of the function.
Remarks
Kn(x) ≅ (1/√2πx)exp(-x)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselJ.
BesselI.
BesselY.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : BesselY Method
BesselY Method
Calcuates the modified Bessel function Yn(x) for any real x and n ≥ 0.
Overload List
Overload | Description
BesselY(String,Series,Int32) | Calcuates the modified Bessel function Yn(x) for any real x and n ≥ 0.
BesselY(Series,Int32) | Calcuates the modified Bessel function Yx(x) for any real x and n ≥ 0.
BesselY(SeriesCollection,Int32) | Calcuates the modified Bessel function Yx(x) for any real x and n ≥ 0.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
BesselY


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselY Method : BesselY(String,Series,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
The grade of the function.
BesselY(String,Series,Int32) Method
Calcuates the modified Bessel function Yn(x) for any real x and n ≥ 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselY( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselY(elementName, s, n)
public static Series BesselY(
   string elementName,
   Series s,
   int n
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
n
The grade of the function.

Return Value

Returns the modified Bessel function Ix(x) for any real x and n ≥ 2.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
Yn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) + Qn(8/x)sin(Xn)] where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK
BesselJ
BesselY


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselY Method : BesselY(Series,Int32) Method
A statistical series.
The grade of the function.
BesselY(Series,Int32) Method
Calcuates the modified Bessel function Yx(x) for any real x and n ≥ 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselY( _
   ByVal s As Series, _
   ByVal n As Integer _
) As Series
'Usage

Dim s As Series
Dim n As Integer
Dim value As Series

value = ForecastEngine.Advanced.BesselY(s, n)
public static Series BesselY(
   Series s,
   int n
)

Parameters

s
A statistical series.
n
The grade of the function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
Yn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) + Qn(8/x)sin(Xn)]
where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselI.
BesselJ.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > BesselY Method : BesselY(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The grade of the function.
BesselY(SeriesCollection,Int32) Method
Calcuates the modified Bessel function Yx(x) for any real x and n ≥ 0.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BesselY( _
   ByVal sc As SeriesCollection, _
   ByVal n As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim n As Integer
Dim value As SeriesCollection

value = ForecastEngine.Advanced.BesselY(sc, n)
public static SeriesCollection BesselY(
   SeriesCollection sc,
   int n
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
n
The grade of the function.
Remarks
Yn(x) = √ (1/2πx)[Pn(8/x)cos(Xn) + Qn(8/x)sin(Xn)]
where P,Q are polynomials and Xn ࣕ x - (2n+1)π/4.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List
BesselK.
BesselI.
BesselJ.


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : Beta Method
Beta Method
Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Overload List
Overload | Description
Beta(String,Series,Series) | Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Beta(Series,Series) | Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Beta(SeriesCollection,Series) | Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Beta


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > Beta Method : Beta(String,Series,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
A series.
Beta(String,Series,Series) Method
Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Beta( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal z As Series _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim z As Series
Dim value As Series

value = ForecastEngine.Advanced.Beta(elementName, s, z)
public static Series Beta(
   string elementName,
   Series s,
   Series z
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
z
A series.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > Beta Method : Beta(Series,Series) Method
A statistical series.
A series.
Beta(Series,Series) Method
Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Beta( _
   ByVal s As Series, _
   ByVal z As Series _
) As Series
'Usage

Dim s As Series
Dim z As Series
Dim value As Series

value = ForecastEngine.Advanced.Beta(s, z)
public static Series Beta(
   Series s,
   Series z
)

Parameters

s
A statistical series.
z
A series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > Beta Method : Beta(SeriesCollection,Series) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A series.
Beta(SeriesCollection,Series) Method
Calcuates the Beta function: B(z,w) = B(w,z) = ∫01 tz-1(1-t)w-1dt;.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Beta( _
   ByVal sc As SeriesCollection, _
   ByVal z As Series _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim z As Series
Dim value As SeriesCollection

value = ForecastEngine.Advanced.Beta(sc, z)
public static SeriesCollection Beta(
   SeriesCollection sc,
   Series z
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
z
A series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : ComplementaryErrorFunction Method
ComplementaryErrorFunction Method
Calcuates the complementary error function erfc(x).
Overload List
Overload | Description
ComplementaryErrorFunction(String,Series) | Calcuates the complementary error function erfc(x).
ComplementaryErrorFunction(Series) | Calcuates the complementary error function erfc(x).
ComplementaryErrorFunction(SeriesCollection) | Calcuates the complementary error function erfc(x).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ComplementaryErrorFunction Method : ComplementaryErrorFunction(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
ComplementaryErrorFunction(String,Series) Method
Calcuates the complementary error function erfc(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ComplementaryErrorFunction( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.ComplementaryErrorFunction(elementName, s)
public static Series ComplementaryErrorFunction(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

Returns the complementary error function which is a special case of incomplete gamma function.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
erfc(x) = 1- erf(x) = 2/√π∫x∞e-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ComplementaryErrorFunction Method : ComplementaryErrorFunction(Series) Method
A statistical series.
ComplementaryErrorFunction(Series) Method
Calcuates the complementary error function erfc(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ComplementaryErrorFunction( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.ComplementaryErrorFunction(s)
public static Series ComplementaryErrorFunction(
   Series s
)

Parameters

s
A statistical series.

Return Value

Returns the complementary error function which is a special case of incomplete gamma function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
erfc(x) = 1- erf(x) = 2/√π∫x∞e-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ComplementaryErrorFunction Method : ComplementaryErrorFunction(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ComplementaryErrorFunction(SeriesCollection) Method
Calcuates the complementary error function erfc(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ComplementaryErrorFunction( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.Advanced.ComplementaryErrorFunction(sc)
public static SeriesCollection ComplementaryErrorFunction(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Return Value

Returns the complementary error function which is a special case of incomplete gamma function.
Remarks
erfc(x) = 1- erf(x) = 2/√π∫x∞e-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : ErrorFunction Method
ErrorFunction Method
Calcuates the error function erf(x).
Overload List
Overload | Description
ErrorFunction(String,Series) | Calcuates the error function erf(x).
ErrorFunction(Series) | Calcuates the error function erf(x).
ErrorFunction(SeriesCollection) | Calcuates the error function erf(x).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ErrorFunction Method : ErrorFunction(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
ErrorFunction(String,Series) Method
Calcuates the error function erf(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ErrorFunction( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.ErrorFunction(elementName, s)
public static Series ErrorFunction(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

Returns error function which is a special case of incomplete gamma function.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
erf(x) = 2/√π∫0xe-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ErrorFunction Method : ErrorFunction(Series) Method
A statistical series.
ErrorFunction(Series) Method
Calcuates the error function erf(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ErrorFunction( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.ErrorFunction(s)
public static Series ErrorFunction(
   Series s
)

Parameters

s
A statistical series.

Return Value

Returns error function which is a special case of incomplete gamma function.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
erf(x) = 2/√π∫0xe-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > ErrorFunction Method : ErrorFunction(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ErrorFunction(SeriesCollection) Method
Calcuates the error function erf(x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ErrorFunction( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.Advanced.ErrorFunction(sc)
public static SeriesCollection ErrorFunction(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.

Return Value

Returns error function which is a special case of incomplete gamma function.
Remarks
erf(x) = 2/√π∫0xe-t2>
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : GammaLn Method
GammaLn Method
Calcuates the logarithm of Gamma function.
Overload List
Overload | Description
GammaLn(String,Series) | Calcuates the logarithm of Gamma function.
GammaLn(Series) | Calcuates the logarithm of Gamma function.
GammaLn(SeriesCollection) | Calcuates the logarithm of Gamma function.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaLn Method : GammaLn(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
GammaLn(String,Series) Method
Calcuates the logarithm of Gamma function.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaLn( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.GammaLn(elementName, s)
public static Series GammaLn(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Remarks
Gamma function is described below: Γ(z) = ∫0∞tz-1e-tdt
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaLn Method : GammaLn(Series) Method
A statistical series.
GammaLn(Series) Method
Calcuates the logarithm of Gamma function.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaLn( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = ForecastEngine.Advanced.GammaLn(s)
public static Series GammaLn(
   Series s
)

Parameters

s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Remarks
Gamma function is described below: Γ(z) = ∫0∞tz-1e-tdt
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaLn Method : GammaLn(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
GammaLn(SeriesCollection) Method
Calcuates the logarithm of Gamma function.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaLn( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = ForecastEngine.Advanced.GammaLn(sc)
public static SeriesCollection GammaLn(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Gamma function is described below: Γ(z) = ∫0∞tz-1e-tdt
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : GammaP Method
GammaP Method
Calcuates the incomplete Gamma function P(a, x).
Overload List
Overload | Description
GammaP(String,Series,Double) | Calcuates the incomplete Gamma function P(a, x).
GammaP(Series,Double) | Calcuates the incomplete Gamma function P(a, x).
GammaP(SeriesCollection,Double) | Calcuates the incomplete Gamma function P(a, x).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
GammaP


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaP Method : GammaP(String,Series,Double) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
A double.
GammaP(String,Series,Double) Method
Calcuates the incomplete Gamma function P(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaP( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal a As Double _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim a As Double
Dim value As Series

value = ForecastEngine.Advanced.GammaP(elementName, s, a)
public static Series GammaP(
   string elementName,
   Series s,
   double a
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
a
A double.
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaP Method : GammaP(Series,Double) Method
A statistical series.
A double.
GammaP(Series,Double) Method
Calcuates the incomplete Gamma function P(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaP( _
   ByVal s As Series, _
   ByVal a As Double _
) As Series
'Usage

Dim s As Series
Dim a As Double
Dim value As Series

value = ForecastEngine.Advanced.GammaP(s, a)
public static Series GammaP(
   Series s,
   double a
)

Parameters

s
A statistical series.
a
A double.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaP Method : GammaP(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A double.
GammaP(SeriesCollection,Double) Method
Calcuates the incomplete Gamma function P(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaP( _
   ByVal sc As SeriesCollection, _
   ByVal a As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim a As Double
Dim value As SeriesCollection

value = ForecastEngine.Advanced.GammaP(sc, a)
public static SeriesCollection GammaP(
   SeriesCollection sc,
   double a
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
a
A double.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : GammaQ Method
GammaQ Method
Calcuates the incomplete Gamma function Q(a, x).
Overload List
Overload | Description
GammaQ(String,Series,Double) | Calcuates the incomplete Gamma function Q(a, x).
GammaQ(Series,Double) | Calcuates the incomplete Gamma function Q(a, x).
GammaQ(SeriesCollection,Double) | Calcuates the incomplete Gamma function Q(a, x).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
GammaQ


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaQ Method : GammaQ(String,Series,Double) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
GammaQ(String,Series,Double) Method
Calcuates the incomplete Gamma function Q(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaQ( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal a As Double _
) As Series
'Usage

Dim elementName As String
Dim s As Series
Dim a As Double
Dim value As Series

value = ForecastEngine.Advanced.GammaQ(elementName, s, a)
public static Series GammaQ(
   string elementName,
   Series s,
   double a
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
a
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaQ Method : GammaQ(Series,Double) Method
A statistical series.
GammaQ(Series,Double) Method
Calcuates the incomplete Gamma function Q(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaQ( _
   ByVal s As Series, _
   ByVal a As Double _
) As Series
'Usage

Dim s As Series
Dim a As Double
Dim value As Series

value = ForecastEngine.Advanced.GammaQ(s, a)
public static Series GammaQ(
   Series s,
   double a
)

Parameters

s
A statistical series.
a
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GammaQ Method : GammaQ(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
GammaQ(SeriesCollection,Double) Method
Calcuates the incomplete Gamma function Q(a, x).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GammaQ( _
   ByVal sc As SeriesCollection, _
   ByVal a As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim a As Double
Dim value As SeriesCollection

value = ForecastEngine.Advanced.GammaQ(sc, a)
public static SeriesCollection GammaQ(
   SeriesCollection sc,
   double a
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
a
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : GeneralLinear Method
GeneralLinear Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Overload List
Overload | Description
GeneralLinear(String,Series,Series) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
GeneralLinear(Series,Series) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
GeneralLinear(SeriesCollection,Series) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
GeneralLinear(String,Series,Series,Double,Double,Double) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
GeneralLinear(Series,Series,Double,Double,Double) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
GeneralLinear(SeriesCollection,Series,Double,Double,Double) | Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(String,Series,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
GeneralLinear(String,Series,Series) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal sigma As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim sigma As Series
Dim value As Series

value = ForecastEngine.Advanced.GeneralLinear(seriesName, s, sigma)
public static Series GeneralLinear(
   string seriesName,
   Series s,
   Series sigma
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(Series,Series) Method
A statistical series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
GeneralLinear(Series,Series) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal s As Series, _
   ByVal sigma As Series _
) As Series
'Usage

Dim s As Series
Dim sigma As Series
Dim value As Series

value = ForecastEngine.Advanced.GeneralLinear(s, sigma)
public static Series GeneralLinear(
   Series s,
   Series sigma
)

Parameters

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(SeriesCollection,Series) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
GeneralLinear(SeriesCollection,Series) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal sc As SeriesCollection, _
   ByVal sigma As Series _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim sigma As Series
Dim value As SeriesCollection

value = ForecastEngine.Advanced.GeneralLinear(sc, sigma)
public static SeriesCollection GeneralLinear(
   SeriesCollection sc,
   Series sigma
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(String,Series,Series,Double,Double,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
The XValue of the starting point of the evaluation of best fitting curve.
The XValue of the ending point of the evaluation of best fitting curve.
The distance between two points.
GeneralLinear(String,Series,Series,Double,Double,Double) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim sigma As Series
Dim xMin As Double
Dim xMax As Double
Dim interval As Double
Dim value As Series

value = ForecastEngine.Advanced.GeneralLinear(seriesName, s, sigma, xMin, xMax, interval)
public static Series GeneralLinear(
   string seriesName,
   Series s,
   Series sigma,
   double xMin,
   double xMax,
   double interval
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(Series,Series,Double,Double,Double) Method
A statistical series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
The XValue of the starting point of the evaluation of best fitting curve.
The XValue of the ending point of the evaluation of best fitting curve.
The distance between two points.
GeneralLinear(Series,Series,Double,Double,Double) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal s As Series, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As Series
'Usage

Dim s As Series
Dim sigma As Series
Dim xMin As Double
Dim xMax As Double
Dim interval As Double
Dim value As Series

value = ForecastEngine.Advanced.GeneralLinear(s, sigma, xMin, xMax, interval)
public static Series GeneralLinear(
   Series s,
   Series sigma,
   double xMin,
   double xMax,
   double interval
)

Parameters

s
A statistical series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > GeneralLinear Method : GeneralLinear(SeriesCollection,Series,Double,Double,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
The XValue of the starting point of the evaluation of best fitting curve.
The XValue of the ending point of the evaluation of best fitting curve.
The distance between two points.
GeneralLinear(SeriesCollection,Series,Double,Double,Double) Method
Evaluates the greatest likelyhood coefficients of the function of best fit in accordance with the least squares approach for the function basis given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeneralLinear( _
   ByVal sc As SeriesCollection, _
   ByVal sigma As Series, _
   ByVal xMin As Double, _
   ByVal xMax As Double, _
   ByVal interval As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim sigma As Series
Dim xMin As Double
Dim xMax As Double
Dim interval As Double
Dim value As SeriesCollection

value = ForecastEngine.Advanced.GeneralLinear(sc, sigma, xMin, xMax, interval)
public static SeriesCollection GeneralLinear(
   SeriesCollection sc,
   Series sigma,
   double xMin,
   double xMax,
   double interval
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
sigma
An array where the k-th term depending on your point of view to one of the following:
  1. Measure Error View: is the standard deviation of the value in the y-axis of the k-th data point.
  2. Weighted Fitting View: is inverse of the weight given to the k-th data point.
.
xMin
The XValue of the starting point of the evaluation of best fitting curve.
xMax
The XValue of the ending point of the evaluation of best fitting curve.
interval
The distance between two points.

Return Value

Returns an array of doubles where the k-th term corresponds to the value of the k-th coefficient within the function of best fit.
Remarks

Further Details

In its simplest case this method given a data set (x_i, y_i), for i=0, ..., m, are are able to find the coefficients a_1, ..., a_n such that the function:

f(x) = a_1 * f_1(x) + a_2 * f_2 + ... + x_n * f_n(x)

where f_1,...f_n are the function basis set using SetFunctionBasis method, and the function f(x), is best fit in accordance with the least square approach. That is, coefficients are selected such the points (x_i, f(x_i)), for i=1,...,m; are a best fit for the given data set (x_i, y_i), i=1,...,m.

Fixing some Coefficients

Please note that within this implementation we reserve the right to fix some of the coefficients before the function is fitted. In such instances the above described fitting is performed with some of the coefficients fixed to the initial value which they are given. The fit parameter is used in order to determine which (if any) of the coefficient are kept fixed during the fitting.

Measure Errors or Weighted Best Fit

In addition as mentioned within the overview of this class you are able to incorporate one of the following features when determining the greatest likelyhood coefficients:

  1. Measure Error: You are able to find the greatest likelyhood coefficients when the measure error (i.e. the standard deviations of the errors of the observation so the y_i's). In order to fit the function taking into account the measurment error you are required to provide the k-th term of the parameter sigma as the measurement error of the y_k (i.e. the value of the y-axis corrdinate of the k-th data point which in used within the fitting of the function.
  2. Weighted Best Fit: If you wish you are also able to apply this class with the view of finding the best weighted fit where the sigma_i corresponds the weight applied to the i-th data point.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class : NonLinearModel Method
NonLinearModel Method
Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Overload List
Overload | Description
NonLinearModel(String,Series,Series,Double[],Boolean[]) | Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
NonLinearModel(Series,Series,Double[],Boolean[]) | Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
NonLinearModel(SeriesCollection,Series,Double[],Boolean[]) | Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
NonLinearPolynomial


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > NonLinearModel Method : NonLinearModel(String,Series,Series,Double[],Boolean[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
The parameters/state of the model.
False to indicate the corresponding modelParameters[k] is to be held fixed.
NonLinearModel(String,Series,Series,Double[],Boolean[]) Method
Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NonLinearModel( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim deviations As Series
Dim a() As Double
Dim vary() As Boolean
Dim value As Series

value = ForecastEngine.Advanced.NonLinearModel(seriesName, s, deviations, a, vary)
public static Series NonLinearModel(
   string seriesName,
   Series s,
   Series deviations,
   double[] a,
   bool[] vary
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > NonLinearModel Method : NonLinearModel(Series,Series,Double[],Boolean[]) Method
A statistical series.
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
The parameters/state of the model.
False to indicate the corresponding modelParameters[k] is to be held fixed.
NonLinearModel(Series,Series,Double[],Boolean[]) Method
Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NonLinearModel( _
   ByVal s As Series, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As Series
'Usage

Dim s As Series
Dim deviations As Series
Dim a() As Double
Dim vary() As Boolean
Dim value As Series

value = ForecastEngine.Advanced.NonLinearModel(s, deviations, a, vary)
public static Series NonLinearModel(
   Series s,
   Series deviations,
   double[] a,
   bool[] vary
)

Parameters

s
A statistical series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


dotnetCHARTING Namespace > ForecastEngine.Advanced Class > NonLinearModel Method : NonLinearModel(SeriesCollection,Series,Double[],Boolean[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
The parameters/state of the model.
False to indicate the corresponding modelParameters[k] is to be held fixed.
NonLinearModel(SeriesCollection,Series,Double[],Boolean[]) Method
Here we offer the Levenberg - Marquardt algorithm which fits a given non-linear function set in accordance with the least squares approach.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NonLinearModel( _
   ByVal sc As SeriesCollection, _
   ByVal deviations As Series, _
   ByVal a() As Double, _
   ByVal vary() As Boolean _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim deviations As Series
Dim a() As Double
Dim vary() As Boolean
Dim value As SeriesCollection

value = ForecastEngine.Advanced.NonLinearModel(sc, deviations, a, vary)
public static SeriesCollection NonLinearModel(
   SeriesCollection sc,
   Series deviations,
   double[] a,
   bool[] vary
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
deviations
An array of doubles where the k-th terms corresponding to the weighting given to the model errors associated within the k-th data point.
a
The parameters/state of the model.
vary
False to indicate the corresponding modelParameters[k] is to be held fixed.
Remarks

This examlpe finds the real valued function of best fit, of the type considered in accordance with the least squares approach. That is, for the functon f, which depends on the parameters (or variables a[]), we find the variables such that:

E = sum_k {(y[k] - f(x[k],a)) / s[k]}^2

is minimal, where:

  1. x[] - are the domain points, i.e. the points at which the values of the real valued function are evaluated.
  2. y[] - are the values of the data points at the domain values.
  3. a[] - the models parameters, that is the variables which the function which is being fitted depends on.
  4. s[] - the scale (or weight) which is applied to each error. That is, s[k] is the scale applied the error for the k-th data set point.

Remark: The implemention of the function interface, implements two methods which return the value and the gradient of the function f(x,a), and not the functional E given above.

Features of the Algorithm

The algorithm for the non-linear framework finds the local minimum in accordance with the least squares approach. This mean that the initial point given from which the minimum is sort lies within the same basin of attraction of the global minimum. In practice, this means in particularly when a non-linear function with many terms is considered that the initial starting point is very carefully chosen. This is not a consequence of our implementation but the nature of the algorithm and problem at hand. The algorithms is of greedy type and essentially uses an abstraction of calculus based methods in which the best point in a neighbourhood of a point a chosen at each step.

Remark: As a side note, the reason why the linear algorithm work so well is that it is based on a simplex algorithm which is combinatorial in nature.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Advanced Class
ForecastEngine.Advanced Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ForecastEngine.Options Class
ForecastEngine.Options Class
Defines a set of static options used with FinancialEngine calculations.
Object Model
ForecastEngine.Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class ForecastEngine.Options
'Usage

Dim instance As ForecastEngine.Options
public sealed class ForecastEngine.Options
Inheritance Hierarchy

System.Object
dotnetCHARTING.ForecastEngine.Options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ForecastEngine.Options Class
ForecastEngine.Options Class Members

The following tables list the members exposed by ForecastEngine.Options.

Public Constructors
 | Name | Description
Public Constructor | ForecastEngine.Options Constructor |
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | FormatString | This property sets and gets a format string used in the equation which is display on to the chart through a token.
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | ModelFunction | This attribute allows the basis of functions which describes a factor model.
static (Shared in Visual Basic) | NonLinearModelFunction | This attribute holds the basis of functions which describes a factor model.
static (Shared in Visual Basic) | NumberPrecision | This property sets and gets the number of decimal for the numbers used in the equations which can be display on to the chart through a token. [C#] ForecastEngine.Options.NumberPrecision = 2 ; [Visual Basic] ForecastEngine.Options.NumberPrecision = 2
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddAbsoluteSum | Adds a sum of absolute functions to be used as basis element.
static (Shared in Visual Basic) | AddConstantTerm | Adds a constant function on one real variable to the function basis.
static (Shared in Visual Basic) | AddCosineSum | Adds a sum a Cosine functions to an elements of the function basis.
static (Shared in Visual Basic) | AddExponentialSum | Adds a sum of exponential functions to be used as basis elements.
static (Shared in Visual Basic) | AddLogarithmicSum | Adds a sum of (natural) log functions to be used as basis elements.
static (Shared in Visual Basic) | AddNonLinearCosineSum | Adds a sum a Cosine functions as an element of the function basis.
static (Shared in Visual Basic) | AddNonLinearExponentialSum | Adds a sum of exponential functions to be used as non-linear basis elements.
static (Shared in Visual Basic) | AddNonLinearLogarithmicSum | Adds a sum of (natural) log functions to be used as non-linear basis elements.
static (Shared in Visual Basic) | AddNonLinearSineSum | Adds a sum of Sine functions to the used as non-linear basis elements.
static (Shared in Visual Basic) | AddPowerTerm | Add a power term as an element of the function basis.
static (Shared in Visual Basic) | AddRationalSumOfPowerTerms | Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.
static (Shared in Visual Basic) | AddSineSum | Adds a sum of Sine functions to the used as basis elements.
static (Shared in Visual Basic) | AddStepSum | Adds a sum of step functions to be used as a basis element.
static (Shared in Visual Basic) | AddSumOfNonLinearPowerTerms | Adds a sum of power terms as an element of the function basis.
static (Shared in Visual Basic) | AddSumOfPowerTerms | Adds a sum of power terms as an element of the function basis.
static (Shared in Visual Basic) | AddTangentSum | Adds a sum of Tangent functions to the used as basis elements.
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

ForecastEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%%

dotnetCHARTING Namespace > ForecastEngine.Options Class : ForecastEngine.Options Constructor
ForecastEngine.Options Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ForecastEngine.Options()
public ForecastEngine.Options()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ForecastEngine.Options Class
ForecastEngine.Options Class Methods

For a list of all members of this type, see ForecastEngine.Options members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddAbsoluteSum | Adds a sum of absolute functions to be used as basis element.
static (Shared in Visual Basic) | AddConstantTerm | Adds a constant function on one real variable to the function basis.
static (Shared in Visual Basic) | AddCosineSum | Adds a sum a Cosine functions to an elements of the function basis.
static (Shared in Visual Basic) | AddExponentialSum | Adds a sum of exponential functions to be used as basis elements.
static (Shared in Visual Basic) | AddLogarithmicSum | Adds a sum of (natural) log functions to be used as basis elements.
static (Shared in Visual Basic) | AddNonLinearCosineSum | Adds a sum a Cosine functions as an element of the function basis.
static (Shared in Visual Basic) | AddNonLinearExponentialSum | Adds a sum of exponential functions to be used as non-linear basis elements.
static (Shared in Visual Basic) | AddNonLinearLogarithmicSum | Adds a sum of (natural) log functions to be used as non-linear basis elements.
static (Shared in Visual Basic) | AddNonLinearSineSum | Adds a sum of Sine functions to the used as non-linear basis elements.
static (Shared in Visual Basic) | AddPowerTerm | Add a power term as an element of the function basis.
static (Shared in Visual Basic) | AddRationalSumOfPowerTerms | Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.
static (Shared in Visual Basic) | AddSineSum | Adds a sum of Sine functions to the used as basis elements.
static (Shared in Visual Basic) | AddStepSum | Adds a sum of step functions to be used as a basis element.
static (Shared in Visual Basic) | AddSumOfNonLinearPowerTerms | Adds a sum of power terms as an element of the function basis.
static (Shared in Visual Basic) | AddSumOfPowerTerms | Adds a sum of power terms as an element of the function basis.
static (Shared in Visual Basic) | AddTangentSum | Adds a sum of Tangent functions to the used as basis elements.
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

ForecastEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddAbsoluteSum Method
An array where the k-th term is the coefficient of the whole k-th absolute function term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th absolute function term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the absolute function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the absolute function term within the k-th element of the sum (i.e. n as shown above).
AddAbsoluteSum Method
Adds a sum of absolute functions to be used as basis element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddAbsoluteSum( _
   ByVal absCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim absCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddAbsoluteSum(absCoeff, coefficient, constant, exponent)
public static void AddAbsoluteSum(
   double[] absCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

absCoeff
An array where the k-th term is the coefficient of the whole k-th absolute function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th absolute function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the absolute function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the absolute function term within the k-th element of the sum (i.e. n as shown above).
Remarks
Where each of the elements of this sum takes the following form:

absCoeff * Absn(coefficient * x + constant)

where the Abs is the absolute functions given by:

  1. Abs(x) = x, if x > 0
  2. Abs(x) = -x, if x < 0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddConstantTerm Method
The constant value taken by the constant function.
AddConstantTerm Method
Adds a constant function on one real variable to the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddConstantTerm( _
   ByVal constant As Double _
)
'Usage

Dim constant As Double

ForecastEngine.Options.AddConstantTerm(constant)
public static void AddConstantTerm(
   double constant
)

Parameters

constant
The constant value taken by the constant function.
Remarks
The constant function takes the form:

f(x) = constant

where x is the variable and constant is a real number.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddCosineSum Method
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
AddCosineSum Method
Adds a sum a Cosine functions to an elements of the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddCosineSum( _
   ByVal cosCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim cosCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddCosineSum(cosCoeff, coefficient, constant, exponent)
public static void AddCosineSum(
   double[] cosCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
Remarks
Please note that the k-th term of the sum which makes up the basis function will take to form:

k-th Term = a_k * (Cosn_k (b_k * x + c_k)),

where the Cosine function is in terms of radians, and a_k, n_k, b_k, c_k are real numbers. Please, in order to construct the sum you just sum over k starting at 0.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddExponentialSum Method
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
AddExponentialSum Method
Adds a sum of exponential functions to be used as basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddExponentialSum( _
   ByVal expCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim expCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddExponentialSum(expCoeff, coefficient, constant, exponent)
public static void AddExponentialSum(
   double[] expCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
Remarks
Where each of the elements of the sum given will take the following form:

expCoeff * expn (coefficient * x + constant))

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddLogarithmicSum Method
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
AddLogarithmicSum Method
Adds a sum of (natural) log functions to be used as basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddLogarithmicSum( _
   ByVal logCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim logCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddLogarithmicSum(logCoeff, coefficient, constant, exponent)
public static void AddLogarithmicSum(
   double[] logCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
Remarks
Where each of the elements of the sum given will take the following form:

logCoeff * logn (coefficient * x + constant))

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddNonLinearCosineSum Method
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
AddNonLinearCosineSum Method
Adds a sum a Cosine functions as an element of the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddNonLinearCosineSum( _
   ByVal cosCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim cosCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddNonLinearCosineSum(cosCoeff, coefficient, constant, exponent)
public static void AddNonLinearCosineSum(
   double[] cosCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

cosCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of Cosine terms (i.e. a_k).
coefficient
An array where the k-th term is the coefficient of the Cosine term of the (k+1)-th term of the sum of the Cosine terms (i.e. b_k).
constant
An array where the k-th term is the constant shift in the x-axis of the Cosine term of the (k+1)-th term of the sum of Cosine terms (i.e. c_k).
exponent
An array where the k-th term is the exponent of the Cosine term within the (k+1)-th term of the sum of the Cosine terms (i.e. n_k).
Remarks
Please note that the k-th term of the sum which makes up the basis function will take to form:

k-th Term = r_k * a_(4k) * (Cosn_k + a_(4k+1) (b_k * a_(4k+2) * x + c_k + a_(4k+3))), (*)

where the Cosine function is in terms of radians, and r_k, n_k, b_k, c_k are real numbers which are given by the parameters and a_(4k), a_(4k+1), a_(4k+2), a_(4k+3), a_(4k+4), are the variables which are to be fitted. In order to construct the sum you just sum over k starting at 0. That is, the term from which the basis elements will be constructed is:

f(x, a_0, ..., a_4, ...., a_(4n+3)) = (sum of k of n-terms given by (*) above),

where a_0,....., a_(4n+3) are the variables of the function which are to be fitted, and x is the variable which will not be fitted.

Example

In order to clarify the above explanation we provide an explicit example. In particular, in order to represent the following sum of cosine terms:

f(x, a_0, a_1, ..., a_7) = a_0 * Cos2 * a_1 (b_0 * a_2 * x + a_3) + a_4 * Cos(1 * a_5) (b_1 * a_6 * x + 2 + a_7),

you are required to pass the following parameters:

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddNonLinearExponentialSum Method
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
AddNonLinearExponentialSum Method
Adds a sum of exponential functions to be used as non-linear basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddNonLinearExponentialSum( _
   ByVal expCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim expCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddNonLinearExponentialSum(expCoeff, coefficient, constant, exponent)
public static void AddNonLinearExponentialSum(
   double[] expCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

expCoeff
An array where the k-th term is the coefficient of the whole k-th exponential term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th exponential term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the exponential function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the exponential term within the k-th element of the sum (i.e. n as shown above).
Remarks
Where each of the elements of the sum given will take the following form:

expCoeff * expn (coefficient * x + constant))

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddNonLinearLogarithmicSum Method
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
AddNonLinearLogarithmicSum Method
Adds a sum of (natural) log functions to be used as non-linear basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddNonLinearLogarithmicSum( _
   ByVal logCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim logCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddNonLinearLogarithmicSum(logCoeff, coefficient, constant, exponent)
public static void AddNonLinearLogarithmicSum(
   double[] logCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

logCoeff
An array where the k-th term is the coefficient of the whole k-th logarithm term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th logarithm term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the logarithm function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the logarithm term within the k-th element of the sum (i.e. n as shown above).
Remarks
Where each of the elements of the sum given will take the following form:

logCoeff * logn (coefficient * x + constant))

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddNonLinearSineSum Method
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
AddNonLinearSineSum Method
Adds a sum of Sine functions to the used as non-linear basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddNonLinearSineSum( _
   ByVal sinCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim sinCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddNonLinearSineSum(sinCoeff, coefficient, constant, exponent)
public static void AddNonLinearSineSum(
   double[] sinCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
Remarks
Please note that each term of the sum which makes up the basis function will take to form:

sinCoeff * (sinn (coefficient * x + constant)),

where the Sine function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddPowerTerm Method
A double which is the coefficient of the term (i.e. a_1 above).
A double which is the exponent of the variable of the term (i.e. n above).
AddPowerTerm Method
Add a power term as an element of the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddPowerTerm( _
   ByVal coefficient As Double, _
   ByVal exponent As Double _
)
'Usage

Dim coefficient As Double
Dim exponent As Double

ForecastEngine.Options.AddPowerTerm(coefficient, exponent)
public static void AddPowerTerm(
   double coefficient,
   double exponent
)

Parameters

coefficient
A double which is the coefficient of the term (i.e. a_1 above).
exponent
A double which is the exponent of the variable of the term (i.e. n above).
Remarks
This elements will take the follow form:

a_1 * x^n,

where a_1, n are arbitrary real numbers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddRationalSumOfPowerTerms Method
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k) which make up the numerator.
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k) which make up the numerator.
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. b_k) which make up the denominator.
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. m_k) which make up the denominator.
AddRationalSumOfPowerTerms Method
Adds a rational expression where the numerator and denominator are both themselves a sum of power terms as defined within AddSumOfPowerTerms to the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddRationalSumOfPowerTerms( _
   ByVal upperRationalCoeff() As Double, _
   ByVal upperRationalExp() As Double, _
   ByVal lowerRationalCoeff() As Double, _
   ByVal lowerRationalExp() As Double _
)
'Usage

Dim upperRationalCoeff() As Double
Dim upperRationalExp() As Double
Dim lowerRationalCoeff() As Double
Dim lowerRationalExp() As Double

ForecastEngine.Options.AddRationalSumOfPowerTerms(upperRationalCoeff, upperRationalExp, lowerRationalCoeff, lowerRationalExp)
public static void AddRationalSumOfPowerTerms(
   double[] upperRationalCoeff,
   double[] upperRationalExp,
   double[] lowerRationalCoeff,
   double[] lowerRationalExp
)

Parameters

upperRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k) which make up the numerator.
upperRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k) which make up the numerator.
lowerRationalCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. b_k) which make up the denominator.
lowerRationalExp
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. m_k) which make up the denominator.
Remarks
That is, the rational sum of the power terms takes the form:

( (a_1 * x^n_1) + ... + (a_p * x^n_p) ) / ( (b_1 * x^m_1) + ... + (b_q * x^m_q) ),

where a_1,..., a_n, n_1,..., n_p, b_1,..., b_q are real numbers and x is the real variable.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddSineSum Method
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
AddSineSum Method
Adds a sum of Sine functions to the used as basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddSineSum( _
   ByVal sinCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim sinCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddSineSum(sinCoeff, coefficient, constant, exponent)
public static void AddSineSum(
   double[] sinCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

sinCoeff
An array where the k-th term is the coefficient of the whole k-th cosine term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th sine term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the sine function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the sine term within the k-th element of the sum (i.e. n as shown above).
Remarks
Please note that each term of the sum which makes up the basis function will take to form:

sinCoeff * (sinn (coefficient * x + constant)),

where the Sine function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddStepSum Method
An array where the k-th term is the coefficient of the whole k-th step function term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th step function term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the step function of the k-th term within the sum (i.e. the constant term as shown above).
AddStepSum Method
Adds a sum of step functions to be used as a basis element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddStepSum( _
   ByVal stepCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double _
)
'Usage

Dim stepCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double

ForecastEngine.Options.AddStepSum(stepCoeff, coefficient, constant)
public static void AddStepSum(
   double[] stepCoeff,
   double[] coefficient,
   double[] constant
)

Parameters

stepCoeff
An array where the k-th term is the coefficient of the whole k-th step function term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th step function term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the step function of the k-th term within the sum (i.e. the constant term as shown above).
Remarks
Where each of the elements of the sum takes the following form:

stepCoeff * Step(coefficient * x + constant),

where the Step(x) is given by:

  1. Step(x) = 0, if x lequ; 0
  2. Step(x) = 1, if x > 0

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddSumOfNonLinearPowerTerms Method
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. rk+1).
An array where the k-th term is the coefficient of the (space) variable of the argument of the power term (i.e. bk).
An array where the k-th term is the constant shift in the x-axis of the power term of the (k+1)-th term of the sum of power terms (i.e. ck).
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. pk+1).
AddSumOfNonLinearPowerTerms Method
Adds a sum of power terms as an element of the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddSumOfNonLinearPowerTerms( _
   ByVal powerCoefficients() As Double, _
   ByVal coefficients() As Double, _
   ByVal constants() As Double, _
   ByVal exponents() As Double _
)
'Usage

Dim powerCoefficients() As Double
Dim coefficients() As Double
Dim constants() As Double
Dim exponents() As Double

ForecastEngine.Options.AddSumOfNonLinearPowerTerms(powerCoefficients, coefficients, constants, exponents)
public static void AddSumOfNonLinearPowerTerms(
   double[] powerCoefficients,
   double[] coefficients,
   double[] constants,
   double[] exponents
)

Parameters

powerCoefficients
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. rk+1).
coefficients
An array where the k-th term is the coefficient of the (space) variable of the argument of the power term (i.e. bk).
constants
An array where the k-th term is the constant shift in the x-axis of the power term of the (k+1)-th term of the sum of power terms (i.e. ck).
exponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. pk+1).
Remarks
The sum of power terms will take the follow form:

f(x, a0, a1, a2,..., a3n+2) = (r0 * a0 * (a1 * b0 * x + c0 + a2)p0) + ... + (rn * a3n * (a3n+1 * bb * x + cn + a3n+2)pn),

where r0,..., rn, b0,..., bn, c0,..., cn, p0,..., pn are arbitrary real numbers, a0,..., a3n+2 are real numbers corresponding to values of the model parameters and x is a real variable.

Remark: The sum of power terms for the non-linear factor model is a direct generalization of the sum of power terms contained within the General Linear Factor model (see dotnetCHARTING.Forecasting.GeneralLinearFactorModel).

Example

In order to clarify the use of this method we provide the following explicit example. In order to set the following term to an instance of the non-linear factor model:

f(x, a0, a1, a2) = 2 * a0 * (a1 * 1 * x + a2 + 0)3,

you must make a call to this method with the parameters:

  1. powerCoefficients = {2}
  2. coefficients = {1}
  3. constants = {0}
  4. exponents = {3}

Using this method to represent a constant function term

You are able to represent the constant function term:

f(x, a0) = a0 * constant,

by calling this method with the parameters constant, coefficients being an array of length 1, where the elements can take any (non-zero) value and powerCoefficients = {constant}, exponents = {0}. However in such an instance care must be taken to observe that in fact you are representing the constant functions using the sum of power terms convension in which:

f(x, a0, a1, a2) = constant * a1 (a1 * x + a2)0 = constant * a1

In particular, you will need to keep track of the model parameters a1 and a2 above when calling methods such as GetValueAt, in which you will need to provide (in fact any) values for a1 and a2.

Worked Example

We considered the function:

f(x, a0, a1,..., a8) = a0(a1x + a2) + a3(a4x + a5)2 + (2.5)a6(a7a0 + a8)0,

which can be set to an instance of this class by calling this method with the parameters:

  1. logCoeffs = { 1.0, 1.0, 2.5 }
  2. coefficients = { 1.0, 1.0, 1.0 }
  3. constants = { 0.0, 0.0, 1.0 }
  4. exponents = { 1.0, 2.0, 0.0 }

Therefore, for example when { a0, a1, ..., a8 } = { 1, 1, 1, 1, 1, 1, 1, 1 }, and evaluate the derivative and function itself using GetValueAt we find that:

 | x = 0 | x = 1 | x = 2
∂f/∂a0 = a0x + a1 | 1 | 2 | 3
∂f/∂a1 = a0x | 0 | 1 | 2
∂f/∂a2 = a0 | 1 | 1 | 1
∂f/∂a3 = (a4x + a5)2 | 1 | 4 | 9
∂f/∂a4 = 2 a3(a4x + a5)x | 0 | 4 | 12
∂f/∂a5 = 2a3(a4x + a5) | 2 | 4 | 6
∂f/∂a6 = 2.5 | 2.5 | 2.5 | 2.5
∂f/∂a7 = 0 | 0 | 0 | 0
∂f/∂a8 = 0 | 0 | 0 | 0
f | 4.5 | 8.5 | 14.5

Source Code Implementation: You can find the source code implementation of this example within the QAExample's within the Client/QAClients/ directory. In particular, this worked example corresponds to the example within the CurveFitting/NonLinearFunctionModel directory of the QAExamples. Note that within this implementation we construct the function described above by calling this method twice where the 1st method call defines to the sub-function which depends on (x, a0, ..., a5), and the 2-nd method call defines the constant function which depends on (x, a6, a7, a8).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddSumOfPowerTerms Method
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).
AddSumOfPowerTerms Method
Adds a sum of power terms as an element of the function basis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddSumOfPowerTerms( _
   ByVal powerTermCoeff() As Double, _
   ByVal powerTermExponents() As Double _
)
'Usage

Dim powerTermCoeff() As Double
Dim powerTermExponents() As Double

ForecastEngine.Options.AddSumOfPowerTerms(powerTermCoeff, powerTermExponents)
public static void AddSumOfPowerTerms(
   double[] powerTermCoeff,
   double[] powerTermExponents
)

Parameters

powerTermCoeff
An array where the k-th term is the coefficient of the (k+1)-th term of the sum of power terms (i.e. a_k).
powerTermExponents
An array where the k-th term is the exponent and the variable of the (k+1)-th power term (i.e. n_k).
Remarks
The sum of power terms will take the follow form:

(a_1 * x^n_1) + ... + (a_m * x^n_p),

where a_1,..., a_n, n_1,..., n_p are arbitrary real numbers.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : AddTangentSum Method
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).
AddTangentSum Method
Adds a sum of Tangent functions to the used as basis elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub AddTangentSum( _
   ByVal tanCoeff() As Double, _
   ByVal coefficient() As Double, _
   ByVal constant() As Double, _
   ByVal exponent() As Double _
)
'Usage

Dim tanCoeff() As Double
Dim coefficient() As Double
Dim constant() As Double
Dim exponent() As Double

ForecastEngine.Options.AddTangentSum(tanCoeff, coefficient, constant, exponent)
public static void AddTangentSum(
   double[] tanCoeff,
   double[] coefficient,
   double[] constant,
   double[] exponent
)

Parameters

tanCoeff
An array where the k-th term is the coefficient of the whole k-th tangent term within the sum.
coefficient
An array where the k-th term is the coefficient of the variable within the k-th tangent term within the sum (i.e. coefficient as shown above).
constant
An array where the k-th term is the constant shift of the tangent function of the k-th term within the sum (i.e. the constant term as shown above).
exponent
An array where the k-th term is the exponent of the tangent term within the k-th element of the sum (i.e. n as shown above).
Remarks
Please note that each term of the cum which makes up the basis function will take to form:

tanCoeff * (tann (coefficient * x + constant)),

where the Tangent function is in terms of radians.

Notes on the Radian measure

Radians are a means by which to describe the angle and are related to the more commonly used degrees as follows:

360 degrees = 2 * Pi * radians

therefore, 1 radian = 180 / Pi degrees = 57.295... degrees.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : Reset Method
Reset Method (ForecastEngine.Options)
Resets the options to default settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub Reset()
'Usage

ForecastEngine.Options.Reset()
public static void Reset()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ForecastEngine.Options Class
ForecastEngine.Options Class Properties

For a list of all members of this type, see ForecastEngine.Options members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | FormatString | This property sets and gets a format string used in the equation which is display on to the chart through a token.
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | ModelFunction | This attribute allows the basis of functions which describes a factor model.
static (Shared in Visual Basic) | NonLinearModelFunction | This attribute holds the basis of functions which describes a factor model.
static (Shared in Visual Basic) | NumberPrecision | This property sets and gets the number of decimal for the numbers used in the equations which can be display on to the chart through a token. [C#] ForecastEngine.Options.NumberPrecision = 2 ; [Visual Basic] ForecastEngine.Options.NumberPrecision = 2
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
See Also

Reference

ForecastEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > ForecastEngine.Options Class : FormatString Property
FormatString Property (ForecastEngine.Options)
This property sets and gets a format string used in the equation which is display on to the chart through a token.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property FormatString As String
'Usage

Dim value As String

value = ForecastEngine.Options.FormatString
public static string FormatString {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : MatchColors Property
MatchColors Property (ForecastEngine.Options)
Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property MatchColors As Boolean
'Usage

Dim value As Boolean

ForecastEngine.Options.MatchColors = value

value = ForecastEngine.Options.MatchColors
public static bool MatchColors {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : ModelFunction Property
ModelFunction Property
This attribute allows the basis of functions which describes a factor model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property ModelFunction As FactorModel
'Usage

Dim value As FactorModel

ForecastEngine.Options.ModelFunction = value

value = ForecastEngine.Options.ModelFunction
public static FactorModel ModelFunction {get; set;}
Remarks
A factor model is a real vector space of functions from which a function will be selected in accordance with some criteria. That is, we allow the basis of functions f_1(x), f_2(x) , ..., f_n(x), which span the factor model, i.e. any element of the factor model can be represented as:

a_1 * f_1(x) + a_2 * f_2(x) + ... + a_n * f_n(x)

where a_1, ..., a_n are real numbers. Note that the above representation is unique.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : NonLinearModelFunction Property
NonLinearModelFunction Property
This attribute holds the basis of functions which describes a factor model.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property NonLinearModelFunction As NonLinearFactorModel
'Usage

Dim value As NonLinearFactorModel

ForecastEngine.Options.NonLinearModelFunction = value

value = ForecastEngine.Options.NonLinearModelFunction
public static NonLinearFactorModel NonLinearModelFunction {get; set;}
Remarks
A factor model is a real vector space of functions from which a function will be selected in accordance with some criteria. That is, we allow the basis of functions f_1, f_2,..., f_n, which span the factor model, i.e. any element of the factor model can be represented as:

f_1(x, a_1, ...., a_n) + f_2(x, a'_1,...., a'_n) + ... + f_n(x, a''_1, ....., a''_n)

where x and a_1,..., a_n, a'_1,..., a'_n,..., a''_1,..., a''_n are real variables. For example the term f_1(x, a_1, a_2, a_3), could correspond to:

f_1(x, a_1, a_2, a_3) = a_1 Sin(a_2 x + a_3)

where a_1, a_2, a_3, are the variables which are to be fitted using the fitting algorithm.

Ordering of the Variables

Once the non-linear factor has been built (using this class) and fitted using the the non linear model algorithm, the values of the a_k which generate the best fitted curve in accordance with the least squares approach will be returned within an array.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : NumberPrecision Property
NumberPrecision Property (ForecastEngine.Options)
This property sets and gets the number of decimal for the numbers used in the equations which can be display on to the chart through a token.

[C#] ForecastEngine.Options.NumberPrecision = 2 ;

[Visual Basic] ForecastEngine.Options.NumberPrecision = 2

Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property NumberPrecision As Integer
'Usage

Dim value As Integer

ForecastEngine.Options.NumberPrecision = value

value = ForecastEngine.Options.NumberPrecision
public static int NumberPrecision {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


dotnetCHARTING Namespace > ForecastEngine.Options Class : PopulateSubValues Property
PopulateSubValues Property (ForecastEngine.Options)
Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property PopulateSubValues As Boolean
'Usage

Dim value As Boolean

ForecastEngine.Options.PopulateSubValues = value

value = ForecastEngine.Options.PopulateSubValues
public static bool PopulateSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ForecastEngine.Options Class
ForecastEngine.Options Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : GridColumn Class
GridColumn Class
Encompasses options for JS GridColumn.
Object Model
GridColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GridColumn
'Usage

Dim instance As GridColumn
public class GridColumn
Inheritance Hierarchy

System.Object
dotnetCHARTING.GridColumn

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : GridColumn Class
GridColumn Class Members

The following tables list the members exposed by GridColumn.

Public Constructors
 | Name | Description
Public Constructor | GridColumn Constructor | Creates a new instance of GridColumn
Top
Public Properties
 | Name | Description
Public Property | Header | The header text of the data column.
Public Property | Style | CSS style for the column.
Public Property | Value | Cell value that can be used to specify the data, format, or expression for the column.
Top
See Also

Reference

GridColumn Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > GridColumn Class : GridColumn Constructor
GridColumn Constructor
Creates a new instance of GridColumn
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New GridColumn()
public GridColumn()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : GridColumn Class
GridColumn Class Properties

For a list of all members of this type, see GridColumn members.

Public Properties
 | Name | Description
Public Property | Header | The header text of the data column.
Public Property | Style | CSS style for the column.
Public Property | Value | Cell value that can be used to specify the data, format, or expression for the column.
Top
See Also

Reference

GridColumn Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > GridColumn Class : Header Property
Header Property (GridColumn)
The header text of the data column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Header As String
'Usage

Dim instance As GridColumn
Dim value As String

instance.Header = value

value = instance.Header
public string Header {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


dotnetCHARTING Namespace > GridColumn Class : Style Property
Style Property
CSS style for the column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Style As String
'Usage

Dim instance As GridColumn
Dim value As String

instance.Style = value

value = instance.Style
public string Style {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


dotnetCHARTING Namespace > GridColumn Class : Value Property
Value Property (GridColumn)
Cell value that can be used to specify the data, format, or expression for the column.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As String
'Usage

Dim instance As GridColumn
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumn Class
GridColumn Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : GridColumnCollection Class
GridColumnCollection Class
Contains a collection of GridColumn objects.
Object Model
GridColumnCollection ClassGridColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GridColumnCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As GridColumnCollection
public class GridColumnCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.GridColumnCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : GridColumnCollection Class
GridColumnCollection Class Members

The following tables list the members exposed by GridColumnCollection.

Public Constructors
 | Name | Description
Public Constructor | GridColumnCollection Constructor | Creates a new instance of GridColumnCollection with the specified list of GridColumn objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified GridColumn object to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified GridColumn.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified GridColumn in this collection.
Public Method | Insert | Inserts a GridColumn into this collection at a specified index.
Public Method | Remove | Removes a specified GridColumn from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

GridColumnCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > GridColumnCollection Class : GridColumnCollection Constructor
GridColumnCollection Constructor
Creates a new instance of GridColumnCollection with the specified list of GridColumn objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray gridColumnList() As GridColumn _
)
'Usage

Dim gridColumnList() As GridColumn

Dim instance As New GridColumnCollection(gridColumnList)
public GridColumnCollection(
   params GridColumn[] gridColumnList
)

Parameters

gridColumnList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : GridColumnCollection Class
GridColumnCollection Class Methods

For a list of all members of this type, see GridColumnCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified GridColumn object to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified GridColumn.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified GridColumn in this collection.
Public Method | Insert | Inserts a GridColumn into this collection at a specified index.
Public Method | Remove | Removes a specified GridColumn from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

GridColumnCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > GridColumnCollection Class : Add Method
Add Method (GridColumnCollection)
Adds the specified GridColumn object to this collection.
Overload List
Overload | Description
Add(String,String,String) | Adds the specified GridColumn object to this collection.
Add(GridColumn) |
Add(GridColumnCollection) | Adds a specified GridColumnCollection to this collection.
Add(GridColumn[]) | Adds the specified GridColumn objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


dotnetCHARTING Namespace > GridColumnCollection Class > Add Method : Add(String,String,String) Method
The header label of the new column..
CSS style for the column.
Add(String,String,String) Method
Adds the specified GridColumn object to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal header As String, _
   ByVal value As String, _
   ByVal style As String _
) As Integer
'Usage

Dim instance As GridColumnCollection
Dim header As String
Dim value As String
Dim style As String
Dim value As Integer

value = instance.Add(header, value, style)
public int Add(
   string header,
   string value,
   string style
)

Parameters

header
The header label of the new column..
value
style
CSS style for the column.

Return Value

The zero-based index of the added GridColumn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members
Overload List


dotnetCHARTING Namespace > GridColumnCollection Class > Add Method : Add(GridColumn) Method
Add(GridColumn) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal gridColumn As GridColumn _
) As Integer
'Usage

Dim instance As GridColumnCollection
Dim gridColumn As GridColumn
Dim value As Integer

value = instance.Add(gridColumn)
public int Add(
   GridColumn gridColumn
)

Parameters

gridColumn
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members
Overload List


dotnetCHARTING Namespace > GridColumnCollection Class > Add Method : Add(GridColumnCollection) Method
The GridColumnCollection to add.
Add(GridColumnCollection) Method
Adds a specified GridColumnCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal gridColumnCollection As GridColumnCollection _
)
'Usage

Dim instance As GridColumnCollection
Dim gridColumnCollection As GridColumnCollection

instance.Add(gridColumnCollection)
public void Add(
   GridColumnCollection gridColumnCollection
)

Parameters

gridColumnCollection
The GridColumnCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members
Overload List


dotnetCHARTING Namespace > GridColumnCollection Class > Add Method : Add(GridColumn[]) Method
A list of GridColumn objects to add.
Add(GridColumn[]) Method
Adds the specified GridColumn objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray gridColumnList() As GridColumn _
)
'Usage

Dim instance As GridColumnCollection
Dim gridColumnList() As GridColumn

instance.Add(gridColumnList)
public void Add(
   params GridColumn[] gridColumnList
)

Parameters

gridColumnList
A list of GridColumn objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members
Overload List


dotnetCHARTING Namespace > GridColumnCollection Class : Contains Method
The GridColumn to find.
Contains Method (GridColumnCollection)
Determines whether this collection contains a specified GridColumn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal gridColumn As GridColumn _
) As Boolean
'Usage

Dim instance As GridColumnCollection
Dim gridColumn As GridColumn
Dim value As Boolean

value = instance.Contains(gridColumn)
public bool Contains(
   GridColumn gridColumn
)

Parameters

gridColumn
The GridColumn to find.

Return Value

true if the specified GridColumn belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


dotnetCHARTING Namespace > GridColumnCollection Class : IndexOf Method
The GridColumn to find.
IndexOf Method (GridColumnCollection)
Determines the index of a specified GridColumn in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal gridColumn As GridColumn _
) As Integer
'Usage

Dim instance As GridColumnCollection
Dim gridColumn As GridColumn
Dim value As Integer

value = instance.IndexOf(gridColumn)
public int IndexOf(
   GridColumn gridColumn
)

Parameters

gridColumn
The GridColumn to find.

Return Value

The zero-based index of the specified GridColumn.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


dotnetCHARTING Namespace > GridColumnCollection Class : Insert Method
The zero-based index into the collection at which to insert the GridColumn.
The GridColumn to insert into this collection.
Insert Method (GridColumnCollection)
Inserts a GridColumn into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal gridColumn As GridColumn _
)
'Usage

Dim instance As GridColumnCollection
Dim index As Integer
Dim gridColumn As GridColumn

instance.Insert(index, gridColumn)
public void Insert(
   int index,
   GridColumn gridColumn
)

Parameters

index
The zero-based index into the collection at which to insert the GridColumn.
gridColumn
The GridColumn to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


dotnetCHARTING Namespace > GridColumnCollection Class : Remove Method
The GridColumn to remove.
Remove Method (GridColumnCollection)
Removes a specified GridColumn from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal gridColumn As GridColumn _
)
'Usage

Dim instance As GridColumnCollection
Dim gridColumn As GridColumn

instance.Remove(gridColumn)
public void Remove(
   GridColumn gridColumn
)

Parameters

gridColumn
The GridColumn to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : GridColumnCollection Class
GridColumnCollection Class Properties

For a list of all members of this type, see GridColumnCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

GridColumnCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > GridColumnCollection Class : Item Property
Item Property (GridColumnCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As GridColumn
'Usage

Dim instance As GridColumnCollection
Dim index As Integer
Dim value As GridColumn

instance.Item(index) = value

value = instance.Item(index)
public GridColumn this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GridColumnCollection Class
GridColumnCollection Members


%%PageItemTitle%%

Members Example

dotnetCHARTING Namespace : Hotspot Class
Hotspot Class
Represents a hotspot on the image and provides events such as tool tips and redirect URL when clicked.
Object Model
Hotspot ClassHotspot.HtmlAttributes Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Hotspot
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As Hotspot
public class Hotspot : dotnetCHARTING.Mapping.Drawing.Property
Remarks
For more information, see tutorial:
Getting Started > General Tutorials > Interactivity - Hotspots
Example
This sample demonstrates how to use hotspots.
  • Visual Basic

This sample demonstrates how to use hotspots.

  • C#
    •

Inheritance Hierarchy
System.Object
      dotnetCHARTING.Hotspot

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Hotspot Members

dotnetCHARTING Namespace

Tutorials
Interactivity


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Hotspot Class
Hotspot Class Members

The following tables list the members exposed by Hotspot.

Public Constructors
 | Name | Description
Public Constructor | Hotspot Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Attributes | Gets the HtmlAttributes of this Hotspot.
Public Property | ToolTip | Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents. This property also supports label markup tags and microcharts.
Public Property | URL | Gets or sets the URL redirected to when the object this Hotspot represents is clicked.
Public Property | URLTarget | Gets or sets the URL target of the URL property.
Top
See Also

Reference

Hotspot Class
dotnetCHARTING Namespace

Tutorials

Interactivity


%%PageItemTitle%%

dotnetCHARTING Namespace > Hotspot Class : Hotspot Constructor
Hotspot Constructor
Overload List
Overload | Description
Hotspot Constructor() | Creates an instance of the HotSpot object.
Hotspot Constructor(String,String) | Creates an instance of the HotSpot object with the specified url and tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Hotspot Class > Hotspot Constructor : Hotspot Constructor()
Hotspot Constructor()
Creates an instance of the HotSpot object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Hotspot()
public Hotspot()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Hotspot Class > Hotspot Constructor : Hotspot Constructor(String,String)
The hotspot's url.
The hotspot's tooltip.
Hotspot Constructor(String,String)
Creates an instance of the HotSpot object with the specified url and tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal url As String, _
   ByVal tooltip As String _
)
'Usage

Dim url As String
Dim tooltip As String

Dim instance As New Hotspot(url, tooltip)
public Hotspot(
   string url,
   string tooltip
)

Parameters

url
The hotspot's url.
tooltip
The hotspot's tooltip.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Hotspot Class
Hotspot Class Properties

For a list of all members of this type, see Hotspot members.

Public Properties
 | Name | Description
Public Property | Attributes | Gets the HtmlAttributes of this Hotspot.
Public Property | ToolTip | Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents. This property also supports label markup tags and microcharts.
Public Property | URL | Gets or sets the URL redirected to when the object this Hotspot represents is clicked.
Public Property | URLTarget | Gets or sets the URL target of the URL property.
Top
See Also

Reference

Hotspot Class
dotnetCHARTING Namespace

Tutorials

Interactivity


dotnetCHARTING Namespace > Hotspot Class : Attributes Property
Attributes Property
Gets the HtmlAttributes of this Hotspot.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Attributes As Hotspot.HtmlAttributes
'Usage

Dim instance As Hotspot
Dim value As Hotspot.HtmlAttributes

instance.Attributes = value

value = instance.Attributes
public Hotspot.HtmlAttributes Attributes {get; set;}
Example
JavaScriptToolTips
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members


dotnetCHARTING Namespace > Hotspot Class : ToolTip Property
ToolTip Property (Hotspot)
Gets or sets the tool tip text shown when mouse pointer is over the object this Hotspot represents. This property also supports label markup tags and microcharts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As Hotspot
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members


dotnetCHARTING Namespace > Hotspot Class : URL Property
URL Property (Hotspot)
Gets or sets the URL redirected to when the object this Hotspot represents is clicked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As Hotspot
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members


dotnetCHARTING Namespace > Hotspot Class : URLTarget Property
URLTarget Property (Hotspot)
Gets or sets the URL target of the URL property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As Hotspot
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot Class
Hotspot Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Class
Encapsulates a number of pre-defined javascript actions and their values.
Object Model
Hotspot.HtmlAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Hotspot.HtmlAttribute
'Usage

Dim instance As Hotspot.HtmlAttribute
public class Hotspot.HtmlAttribute
Inheritance Hierarchy

System.Object
dotnetCHARTING.Hotspot.HtmlAttribute

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Members
dotnetCHARTING Namespace
Interactivity


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Class Members

The following tables list the members exposed by Hotspot.HtmlAttribute.

Public Constructors
 | Name | Description
Public Constructor | Hotspot.HtmlAttribute Constructor |
Top
Public Properties
 | Name | Description
Public Property | Alert | Gets or sets the text of a javascript alert pop-up.
Public Property | Redirect | Gets or sets the url the browser redirects to.
Public Property | RedirectFrame | Gets or sets the url the current frame redirects to.
Public Property | StatusBarMessage | Gets or sets the status bar text message of the browser window.
Top
See Also

Reference

Hotspot.HtmlAttribute Class
dotnetCHARTING Namespace
Interactivity


%%PageItemTitle%%

dotnetCHARTING Namespace > Hotspot.HtmlAttribute Class : Hotspot.HtmlAttribute Constructor
Hotspot.HtmlAttribute Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Hotspot.HtmlAttribute()
public Hotspot.HtmlAttribute()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Class Properties

For a list of all members of this type, see Hotspot.HtmlAttribute members.

Public Properties
 | Name | Description
Public Property | Alert | Gets or sets the text of a javascript alert pop-up.
Public Property | Redirect | Gets or sets the url the browser redirects to.
Public Property | RedirectFrame | Gets or sets the url the current frame redirects to.
Public Property | StatusBarMessage | Gets or sets the status bar text message of the browser window.
Top
See Also

Reference

Hotspot.HtmlAttribute Class
dotnetCHARTING Namespace
Interactivity


dotnetCHARTING Namespace > Hotspot.HtmlAttribute Class : Alert Property
Alert Property
Gets or sets the text of a javascript alert pop-up.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alert As String
'Usage

Dim instance As Hotspot.HtmlAttribute
Dim value As String

instance.Alert = value

value = instance.Alert
public string Alert {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Members


dotnetCHARTING Namespace > Hotspot.HtmlAttribute Class : Redirect Property
Redirect Property
Gets or sets the url the browser redirects to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Redirect As String
'Usage

Dim instance As Hotspot.HtmlAttribute
Dim value As String

instance.Redirect = value

value = instance.Redirect
public string Redirect {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Members


dotnetCHARTING Namespace > Hotspot.HtmlAttribute Class : RedirectFrame Property
RedirectFrame Property
Gets or sets the url the current frame redirects to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RedirectFrame As String
'Usage

Dim instance As Hotspot.HtmlAttribute
Dim value As String

instance.RedirectFrame = value

value = instance.RedirectFrame
public string RedirectFrame {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Members


dotnetCHARTING Namespace > Hotspot.HtmlAttribute Class : StatusBarMessage Property
StatusBarMessage Property
Gets or sets the status bar text message of the browser window.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StatusBarMessage As String
'Usage

Dim instance As Hotspot.HtmlAttribute
Dim value As String

instance.StatusBarMessage = value

value = instance.StatusBarMessage
public string StatusBarMessage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttribute Class
Hotspot.HtmlAttribute Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Class
Encapsulates a set of html event attributes and their values.
Object Model
Hotspot.HtmlAttributes ClassListCollection ClassHotspot.HtmlAttribute ClassHotspot.HtmlAttribute ClassHotspot.HtmlAttribute Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Hotspot.HtmlAttributes
'Usage

Dim instance As Hotspot.HtmlAttributes
public class Hotspot.HtmlAttributes
Inheritance Hierarchy

System.Object
dotnetCHARTING.Hotspot.HtmlAttributes

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Members
dotnetCHARTING Namespace
Interactivity


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Class Members

The following tables list the members exposed by Hotspot.HtmlAttributes.

Public Constructors
 | Name | Description
Public Constructor | Hotspot.HtmlAttributes Constructor |
Top
Public Properties
 | Name | Description
Public Property | Custom | Gets or sets a ListCollection of custom html attributes.
Public Property | OnClick | Gets or sets the html OnClick attribute.
Public Property | OnDoubleClick | Gets or sets the html OnDoubleClick attribute.
Public Property | OnMouseOver | Gets or sets the html OnMouseOver attribute.
Top
See Also

Reference

Hotspot.HtmlAttributes Class
dotnetCHARTING Namespace
Interactivity


%%PageItemTitle%%

dotnetCHARTING Namespace > Hotspot.HtmlAttributes Class : Hotspot.HtmlAttributes Constructor
Hotspot.HtmlAttributes Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Hotspot.HtmlAttributes()
public Hotspot.HtmlAttributes()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Class Properties

For a list of all members of this type, see Hotspot.HtmlAttributes members.

Public Properties
 | Name | Description
Public Property | Custom | Gets or sets a ListCollection of custom html attributes.
Public Property | OnClick | Gets or sets the html OnClick attribute.
Public Property | OnDoubleClick | Gets or sets the html OnDoubleClick attribute.
Public Property | OnMouseOver | Gets or sets the html OnMouseOver attribute.
Top
See Also

Reference

Hotspot.HtmlAttributes Class
dotnetCHARTING Namespace
Interactivity


dotnetCHARTING Namespace > Hotspot.HtmlAttributes Class : Custom Property
Custom Property (Hotspot.HtmlAttributes)
Gets or sets a ListCollection of custom html attributes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Custom As ListCollection
'Usage

Dim instance As Hotspot.HtmlAttributes
Dim value As ListCollection

instance.Custom = value

value = instance.Custom
public ListCollection Custom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Members


dotnetCHARTING Namespace > Hotspot.HtmlAttributes Class : OnClick Property
OnClick Property
Gets or sets the html OnClick attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OnClick As Hotspot.HtmlAttribute
'Usage

Dim instance As Hotspot.HtmlAttributes
Dim value As Hotspot.HtmlAttribute

instance.OnClick = value

value = instance.OnClick
public Hotspot.HtmlAttribute OnClick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Members


dotnetCHARTING Namespace > Hotspot.HtmlAttributes Class : OnDoubleClick Property
OnDoubleClick Property
Gets or sets the html OnDoubleClick attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OnDoubleClick As Hotspot.HtmlAttribute
'Usage

Dim instance As Hotspot.HtmlAttributes
Dim value As Hotspot.HtmlAttribute

instance.OnDoubleClick = value

value = instance.OnDoubleClick
public Hotspot.HtmlAttribute OnDoubleClick {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Members


dotnetCHARTING Namespace > Hotspot.HtmlAttributes Class : OnMouseOver Property
OnMouseOver Property
Gets or sets the html OnMouseOver attribute.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OnMouseOver As Hotspot.HtmlAttribute
'Usage

Dim instance As Hotspot.HtmlAttributes
Dim value As Hotspot.HtmlAttribute

instance.OnMouseOver = value

value = instance.OnMouseOver
public Hotspot.HtmlAttribute OnMouseOver {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Hotspot.HtmlAttributes Class
Hotspot.HtmlAttributes Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : HotspotCollection Class
HotspotCollection Class
Contains a collection of Hotspot objects.
Object Model
HotspotCollection ClassHotspot Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class HotspotCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As HotspotCollection
public class HotspotCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.HotspotCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : HotspotCollection Class
HotspotCollection Class Members

The following tables list the members exposed by HotspotCollection.

Public Constructors
 | Name | Description
Public Constructor | HotspotCollection Constructor | Creates a new instance of HotspotCollection with the specified list of Hotspot objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified HotspotCollection to this collection.
Public Method | Clear | Clears this collection.
Public Method | Contains | Determines whether this collection contains a specified Hotspot.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified Hotspot in this collection.
Public Method | Insert | Inserts a Hotspot into this collection at a specified index.
Public Method | Remove | Removes a specified Hotspot from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

HotspotCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > HotspotCollection Class : HotspotCollection Constructor
HotspotCollection Constructor
Creates a new instance of HotspotCollection with the specified list of Hotspot objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray hotspotList() As Hotspot _
)
'Usage

Dim hotspotList() As Hotspot

Dim instance As New HotspotCollection(hotspotList)
public HotspotCollection(
   params Hotspot[] hotspotList
)

Parameters

hotspotList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : HotspotCollection Class
HotspotCollection Class Methods

For a list of all members of this type, see HotspotCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified HotspotCollection to this collection.
Public Method | Clear | Clears this collection.
Public Method | Contains | Determines whether this collection contains a specified Hotspot.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified Hotspot in this collection.
Public Method | Insert | Inserts a Hotspot into this collection at a specified index.
Public Method | Remove | Removes a specified Hotspot from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

HotspotCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > HotspotCollection Class : Add Method
Add Method (HotspotCollection)
Adds a specified HotspotCollection to this collection.
Overload List
Overload | Description
Add(Hotspot) |
Add(HotspotCollection) | Adds a specified HotspotCollection to this collection.
Add(Hotspot[]) | Adds the specified Hotspot objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


dotnetCHARTING Namespace > HotspotCollection Class > Add Method : Add(Hotspot) Method
Add(Hotspot) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal hotspot As Hotspot _
) As Integer
'Usage

Dim instance As HotspotCollection
Dim hotspot As Hotspot
Dim value As Integer

value = instance.Add(hotspot)
public int Add(
   Hotspot hotspot
)

Parameters

hotspot
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members
Overload List


dotnetCHARTING Namespace > HotspotCollection Class > Add Method : Add(HotspotCollection) Method
The HotspotCollection to add.
Add(HotspotCollection) Method
Adds a specified HotspotCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal hotspotCollection As HotspotCollection _
)
'Usage

Dim instance As HotspotCollection
Dim hotspotCollection As HotspotCollection

instance.Add(hotspotCollection)
public void Add(
   HotspotCollection hotspotCollection
)

Parameters

hotspotCollection
The HotspotCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members
Overload List


dotnetCHARTING Namespace > HotspotCollection Class > Add Method : Add(Hotspot[]) Method
A list of Hotspot objects to add.
Add(Hotspot[]) Method
Adds the specified Hotspot objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray hotspotList() As Hotspot _
)
'Usage

Dim instance As HotspotCollection
Dim hotspotList() As Hotspot

instance.Add(hotspotList)
public void Add(
   params Hotspot[] hotspotList
)

Parameters

hotspotList
A list of Hotspot objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members
Overload List


dotnetCHARTING Namespace > HotspotCollection Class : Clear Method
Clear Method (HotspotCollection)
Clears this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Sub Clear()
'Usage

Dim instance As HotspotCollection

instance.Clear()
public new void Clear()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


dotnetCHARTING Namespace > HotspotCollection Class : Contains Method
The Hotspot to find.
Contains Method (HotspotCollection)
Determines whether this collection contains a specified Hotspot.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal hotspot As Hotspot _
) As Boolean
'Usage

Dim instance As HotspotCollection
Dim hotspot As Hotspot
Dim value As Boolean

value = instance.Contains(hotspot)
public bool Contains(
   Hotspot hotspot
)

Parameters

hotspot
The Hotspot to find.

Return Value

true if the specified Hotspot belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


dotnetCHARTING Namespace > HotspotCollection Class : IndexOf Method
The Hotspot to find.
IndexOf Method (HotspotCollection)
Determines index of a specified Hotspot in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal hotspot As Hotspot _
) As Integer
'Usage

Dim instance As HotspotCollection
Dim hotspot As Hotspot
Dim value As Integer

value = instance.IndexOf(hotspot)
public int IndexOf(
   Hotspot hotspot
)

Parameters

hotspot
The Hotspot to find.

Return Value

The zero-based index of the specified Hotspot.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


dotnetCHARTING Namespace > HotspotCollection Class : Insert Method
The zero-based index into the collection at which to insert the Hotspot.
The Hotspot to insert into this collection.
Insert Method (HotspotCollection)
Inserts a Hotspot into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal hotspot As Hotspot _
)
'Usage

Dim instance As HotspotCollection
Dim index As Integer
Dim hotspot As Hotspot

instance.Insert(index, hotspot)
public void Insert(
   int index,
   Hotspot hotspot
)

Parameters

index
The zero-based index into the collection at which to insert the Hotspot.
hotspot
The Hotspot to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


dotnetCHARTING Namespace > HotspotCollection Class : Remove Method
The Hotspot to remove.
Remove Method (HotspotCollection)
Removes a specified Hotspot from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal hotspot As Hotspot _
)
'Usage

Dim instance As HotspotCollection
Dim hotspot As Hotspot

instance.Remove(hotspot)
public void Remove(
   Hotspot hotspot
)

Parameters

hotspot
The Hotspot to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : HotspotCollection Class
HotspotCollection Class Properties

For a list of all members of this type, see HotspotCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

HotspotCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > HotspotCollection Class : Item Property
Item Property (HotspotCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Hotspot
'Usage

Dim instance As HotspotCollection
Dim index As Integer
Dim value As Hotspot

instance.Item(index) = value

value = instance.Item(index)
public Hotspot this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

HotspotCollection Class
HotspotCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JSDataGrid Class
JSDataGrid Class
Encompasses options for JS DataGrid.
Object Model
JSDataGrid ClassGridColumnCollection ClassGridColumn Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JSDataGrid
'Usage

Dim instance As JSDataGrid
public class JSDataGrid
Inheritance Hierarchy

System.Object
dotnetCHARTING.JSDataGrid

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JSDataGrid Class
JSDataGrid Class Members

The following tables list the members exposed by JSDataGrid.

Public Constructors
 | Name | Description
Public Constructor | JSDataGrid Constructor | Creates an instance of the JSDataGrid object.
Top
Public Properties
 | Name | Description
Public Property | ClassName | Gets or sets the name of the CSS class used for this data grid.
Public Property | Columns | Defines columns and their options shown in the grid.
Public Property | Enabled | Gets or sets the bool which indicates whether the datagrid is enabled for this chart. Internally it injects a reference to the datagrid.js module.
Public Property | EnableExportButton | Gets or sets the export to CSV button.
Public Property | StandAlone | Gets or sets a value that determines whether the data grid is shown by itself without a chart.
Top
See Also

Reference

JSDataGrid Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JSDataGrid Class : JSDataGrid Constructor
JSDataGrid Constructor
Creates an instance of the JSDataGrid object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JSDataGrid()
public JSDataGrid()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JSDataGrid Class
JSDataGrid Class Properties

For a list of all members of this type, see JSDataGrid members.

Public Properties
 | Name | Description
Public Property | ClassName | Gets or sets the name of the CSS class used for this data grid.
Public Property | Columns | Defines columns and their options shown in the grid.
Public Property | Enabled | Gets or sets the bool which indicates whether the datagrid is enabled for this chart. Internally it injects a reference to the datagrid.js module.
Public Property | EnableExportButton | Gets or sets the export to CSV button.
Public Property | StandAlone | Gets or sets a value that determines whether the data grid is shown by itself without a chart.
Top
See Also

Reference

JSDataGrid Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JSDataGrid Class : ClassName Property
ClassName Property
Gets or sets the name of the CSS class used for this data grid.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ClassName As String
'Usage

Dim instance As JSDataGrid
Dim value As String

instance.ClassName = value

value = instance.ClassName
public string ClassName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


dotnetCHARTING Namespace > JSDataGrid Class : Columns Property
Columns Property
Defines columns and their options shown in the grid.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Columns As GridColumnCollection
'Usage

Dim instance As JSDataGrid
Dim value As GridColumnCollection

instance.Columns = value

value = instance.Columns
public GridColumnCollection Columns {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


dotnetCHARTING Namespace > JSDataGrid Class : Enabled Property
Enabled Property (JSDataGrid)
Gets or sets the bool which indicates whether the datagrid is enabled for this chart. Internally it injects a reference to the datagrid.js module.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As JSDataGrid
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


dotnetCHARTING Namespace > JSDataGrid Class : EnableExportButton Property
EnableExportButton Property (JSDataGrid)
Gets or sets the export to CSV button.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableExportButton As Boolean
'Usage

Dim instance As JSDataGrid
Dim value As Boolean

instance.EnableExportButton = value

value = instance.EnableExportButton
public bool EnableExportButton {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


dotnetCHARTING Namespace > JSDataGrid Class : StandAlone Property
StandAlone Property
Gets or sets a value that determines whether the data grid is shown by itself without a chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StandAlone As Boolean
'Usage

Dim instance As JSDataGrid
Dim value As Boolean

instance.StandAlone = value

value = instance.StandAlone
public bool StandAlone {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSDataGrid Class
JSDataGrid Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JSMapping Class
JSMapping Class
Encompasses options for JS Mapping.
Object Model
JSMapping ClassSeries Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JSMapping
'Usage

Dim instance As JSMapping
public class JSMapping
Inheritance Hierarchy

System.Object
dotnetCHARTING.JSMapping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JSMapping Class
JSMapping Class Members

The following tables list the members exposed by JSMapping.

Public Constructors
 | Name | Description
Public Constructor | JSMapping Constructor | Creates an instance of the JSMapping object.
Top
Public Properties
 | Name | Description
Public Property | BaseLayers | A list of comma delimited map codes or geoJSON/topoJSON files. Map property filters can also be used if a reference layer is defined.
Public Property | BaseLayersSeries | The series styling for base map layers.
Public Property | Project | When true (default), the standard mercator projection is applied to the map.
Public Property | ReferenceLayers | A list of comma delimited map codes or geoJSON/topoJSON files that are loaded into memory but not shown on the chart by default. This is useful when a series is built based on map features in memory.
Top
See Also

Reference

JSMapping Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JSMapping Class : JSMapping Constructor
JSMapping Constructor
Creates an instance of the JSMapping object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JSMapping()
public JSMapping()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Class
JSMapping Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JSMapping Class
JSMapping Class Properties

For a list of all members of this type, see JSMapping members.

Public Properties
 | Name | Description
Public Property | BaseLayers | A list of comma delimited map codes or geoJSON/topoJSON files. Map property filters can also be used if a reference layer is defined.
Public Property | BaseLayersSeries | The series styling for base map layers.
Public Property | Project | When true (default), the standard mercator projection is applied to the map.
Public Property | ReferenceLayers | A list of comma delimited map codes or geoJSON/topoJSON files that are loaded into memory but not shown on the chart by default. This is useful when a series is built based on map features in memory.
Top
See Also

Reference

JSMapping Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JSMapping Class : BaseLayers Property
BaseLayers Property
A list of comma delimited map codes or geoJSON/topoJSON files. Map property filters can also be used if a reference layer is defined.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BaseLayers As String
'Usage

Dim instance As JSMapping
Dim value As String

instance.BaseLayers = value

value = instance.BaseLayers
public string BaseLayers {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Class
JSMapping Members


dotnetCHARTING Namespace > JSMapping Class : BaseLayersSeries Property
BaseLayersSeries Property
The series styling for base map layers.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property BaseLayersSeries As Series
'Usage

Dim instance As JSMapping
Dim value As Series

instance.BaseLayersSeries = value

value = instance.BaseLayersSeries
public Series BaseLayersSeries {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Class
JSMapping Members


dotnetCHARTING Namespace > JSMapping Class : Project Property
Project Property
When true (default), the standard mercator projection is applied to the map.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Project As Boolean
'Usage

Dim instance As JSMapping
Dim value As Boolean

instance.Project = value

value = instance.Project
public bool Project {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Class
JSMapping Members


dotnetCHARTING Namespace > JSMapping Class : ReferenceLayers Property
ReferenceLayers Property
A list of comma delimited map codes or geoJSON/topoJSON files that are loaded into memory but not shown on the chart by default. This is useful when a series is built based on map features in memory.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReferenceLayers As String
'Usage

Dim instance As JSMapping
Dim value As String

instance.ReferenceLayers = value

value = instance.ReferenceLayers
public string ReferenceLayers {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JSMapping Class
JSMapping Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions Class
JsOptions Class
Contains the public API definitions for options that control JavaScript chart features and behavior.
Object Model
JsOptions ClassJsOptions.JsButtons ClassJsOptions.JsCalendar ClassJSDataGrid ClassJsOptions.LanguageStringSettings ClassJSMapping Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions
'Usage

Dim instance As JsOptions
public class JsOptions
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions Class
JsOptions Class Members

The following tables list the members exposed by JsOptions.

Public Constructors
 | Name | Description
Public Constructor | JsOptions Constructor | Creates an instance of the JsOptions object.
Top
Public Properties
 | Name | Description
Public Property | AxisToZoom |
Public Property | Buttons | Gets or sets the export and print button options.
Public Property | Calendar | Gets or sets the calendar options.
Public Property | ControlID | Gets or sets the ID of the JavaScript chart plugin tag generated on the HTML page. Setting this property provides a reference to the chart plugin from within the page using JavaScript.
Public Property | Data |
Public Property | DataGrid | Gets or sets JavaScript DataGrid options.
Public Property | Enabled | Gets or sets a value that determines whether the JavaScript chart is enabled.
Public Property | EnableElementSelection | Gets or sets a value that determines whether elements can be selected by clicking on them.
Public Property | EnableMouseTracking | Gets or sets a value that determines whether the mouse tracking is enabled for all series.
Public Property | ExportServer | Gets or sets the export server.
Public Property | Highlights | Gets or sets the calendar highlight options.
Public Property | InitialAnimationDuration | Gets or sets the initial animation duration in milliseconds. This applies to the initial animations when a chart is loaded.
Public Property | JQuery | Gets or sets the JQuery URL. Defaults to https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js
Public Property | LanguageStrings | Gets or sets the language string options.
Public Property | Mapping | Exposes options for use with mapping.
Public Property | RenderCallback | Gets or sets the name of a javascript function defined within the page. This function is called after the javascript chart renders.
Public Property | ScriptReference | Gets the required script references after calling Chart.GetChartJS
Public Property | Settings | Gets or sets a dictionary containing additional JSChart properties and values to set before the JS chart renders. The string based key and value pair consists of a property path and value.
Top
See Also

Reference

JsOptions Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions Class : JsOptions Constructor
JsOptions Constructor
Creates an instance of the JsOptions object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions()
public JsOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions Class
JsOptions Class Properties

For a list of all members of this type, see JsOptions members.

Public Properties
 | Name | Description
Public Property | AxisToZoom |
Public Property | Buttons | Gets or sets the export and print button options.
Public Property | Calendar | Gets or sets the calendar options.
Public Property | ControlID | Gets or sets the ID of the JavaScript chart plugin tag generated on the HTML page. Setting this property provides a reference to the chart plugin from within the page using JavaScript.
Public Property | Data |
Public Property | DataGrid | Gets or sets JavaScript DataGrid options.
Public Property | Enabled | Gets or sets a value that determines whether the JavaScript chart is enabled.
Public Property | EnableElementSelection | Gets or sets a value that determines whether elements can be selected by clicking on them.
Public Property | EnableMouseTracking | Gets or sets a value that determines whether the mouse tracking is enabled for all series.
Public Property | ExportServer | Gets or sets the export server.
Public Property | Highlights | Gets or sets the calendar highlight options.
Public Property | InitialAnimationDuration | Gets or sets the initial animation duration in milliseconds. This applies to the initial animations when a chart is loaded.
Public Property | JQuery | Gets or sets the JQuery URL. Defaults to https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js
Public Property | LanguageStrings | Gets or sets the language string options.
Public Property | Mapping | Exposes options for use with mapping.
Public Property | RenderCallback | Gets or sets the name of a javascript function defined within the page. This function is called after the javascript chart renders.
Public Property | ScriptReference | Gets the required script references after calling Chart.GetChartJS
Public Property | Settings | Gets or sets a dictionary containing additional JSChart properties and values to set before the JS chart renders. The string based key and value pair consists of a property path and value.
Top
See Also

Reference

JsOptions Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions Class : AxisToZoom Property
AxisToZoom Property (JsOptions)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisToZoom As String
'Usage

Dim instance As JsOptions
Dim value As String

instance.AxisToZoom = value

value = instance.AxisToZoom
public string AxisToZoom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Buttons Property
Buttons Property
Gets or sets the export and print button options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Buttons As JsOptions.JsButtons
'Usage

Dim instance As JsOptions
Dim value As JsOptions.JsButtons

instance.Buttons = value

value = instance.Buttons
public JsOptions.JsButtons Buttons {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Calendar Property
Calendar Property
Gets or sets the calendar options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Calendar As JsOptions.JsCalendar
'Usage

Dim instance As JsOptions
Dim value As JsOptions.JsCalendar

instance.Calendar = value

value = instance.Calendar
public JsOptions.JsCalendar Calendar {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : ControlID Property
ControlID Property (JsOptions)
Gets or sets the ID of the JavaScript chart plugin tag generated on the HTML page. Setting this property provides a reference to the chart plugin from within the page using JavaScript.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ControlID As String
'Usage

Dim instance As JsOptions
Dim value As String

instance.ControlID = value

value = instance.ControlID
public string ControlID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Data Property
Data Property (JsOptions)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As Object
'Usage

Dim instance As JsOptions
Dim value As Object

instance.Data = value

value = instance.Data
public object Data {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : DataGrid Property
DataGrid Property (JsOptions)
Gets or sets JavaScript DataGrid options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataGrid As JSDataGrid
'Usage

Dim instance As JsOptions
Dim value As JSDataGrid

instance.DataGrid = value

value = instance.DataGrid
public JSDataGrid DataGrid {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Enabled Property
Enabled Property (JsOptions)
Gets or sets a value that determines whether the JavaScript chart is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As JsOptions
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : EnableElementSelection Property
EnableElementSelection Property
Gets or sets a value that determines whether elements can be selected by clicking on them.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableElementSelection As Boolean
'Usage

Dim instance As JsOptions
Dim value As Boolean

instance.EnableElementSelection = value

value = instance.EnableElementSelection
public bool EnableElementSelection {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : EnableMouseTracking Property
EnableMouseTracking Property (JsOptions)
Gets or sets a value that determines whether the mouse tracking is enabled for all series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableMouseTracking As Boolean
'Usage

Dim instance As JsOptions
Dim value As Boolean

instance.EnableMouseTracking = value

value = instance.EnableMouseTracking
public bool EnableMouseTracking {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : ExportServer Property
ExportServer Property
Gets or sets the export server.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExportServer As String
'Usage

Dim instance As JsOptions
Dim value As String

instance.ExportServer = value

value = instance.ExportServer
public string ExportServer {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Highlights Property
Highlights Property
Gets or sets the calendar highlight options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Highlights As List(Of JsOptions.JsHighlight)
'Usage

Dim instance As JsOptions
Dim value As List(Of JsOptions.JsHighlight)

instance.Highlights = value

value = instance.Highlights
public List<JsOptions.JsHighlight> Highlights {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : InitialAnimationDuration Property
InitialAnimationDuration Property
Gets or sets the initial animation duration in milliseconds. This applies to the initial animations when a chart is loaded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InitialAnimationDuration As Integer
'Usage

Dim instance As JsOptions
Dim value As Integer

instance.InitialAnimationDuration = value

value = instance.InitialAnimationDuration
public int InitialAnimationDuration {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : JQuery Property
JQuery Property
Gets or sets the JQuery URL. Defaults to https://ajax.googleapis.com/ajax/libs/jquery/1.10.2/jquery.min.js
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JQuery As String
'Usage

Dim instance As JsOptions
Dim value As String

instance.JQuery = value

value = instance.JQuery
public string JQuery {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : LanguageStrings Property
LanguageStrings Property (JsOptions)
Gets or sets the language string options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LanguageStrings As JsOptions.LanguageStringSettings
'Usage

Dim instance As JsOptions
Dim value As JsOptions.LanguageStringSettings

instance.LanguageStrings = value

value = instance.LanguageStrings
public JsOptions.LanguageStringSettings LanguageStrings {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Mapping Property
Mapping Property (JsOptions)
Exposes options for use with mapping.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mapping As JSMapping
'Usage

Dim instance As JsOptions
Dim value As JSMapping

instance.Mapping = value

value = instance.Mapping
public JSMapping Mapping {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : RenderCallback Property
RenderCallback Property
Gets or sets the name of a javascript function defined within the page. This function is called after the javascript chart renders.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RenderCallback As String
'Usage

Dim instance As JsOptions
Dim value As String

instance.RenderCallback = value

value = instance.RenderCallback
public string RenderCallback {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : ScriptReference Property
ScriptReference Property
Gets the required script references after calling Chart.GetChartJS
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ScriptReference As String
'Usage

Dim instance As JsOptions
Dim value As String

value = instance.ScriptReference
public string ScriptReference {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


dotnetCHARTING Namespace > JsOptions Class : Settings Property
Settings Property
Gets or sets a dictionary containing additional JSChart properties and values to set before the JS chart renders. The string based key and value pair consists of a property path and value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Settings As Dictionary(Of String,String)
'Usage

Dim instance As JsOptions
Dim value As Dictionary(Of String,String)

instance.Settings = value

value = instance.Settings
public Dictionary<string,string> Settings {get; set;}
Remarks
This method takes only strings values, however, any type can be specified. If a value of "true" is passed, it will be a boolean in JS. To use a string with that value, use "'true'" with single quotes. The same applies to numbers. If a JS variable that holds the value in JS must be referenced, prefix the string with "js:". This will prevent quote wrapping and will be used in JS as is. For example, if in JS there is a variable defined as var colorRed = 'red'; to refer to this variable in a string setting server side, use "js:colorRed". This allows passing functions as well for cases like label callbacks. For example: "js:function(txt){return 'text:'+txt}"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions Class
JsOptions Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions.JsButtons Class
JsOptions.JsButtons Class
Defines the export and print button options for JavaScript charts.
Object Model
JsOptions.JsButtons ClassBackground ClassBackground ClassBackground ClassLine ClassLine ClassLine ClassLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions.JsButtons
'Usage

Dim instance As JsOptions.JsButtons
public class JsOptions.JsButtons
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions.JsButtons

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions.JsButtons Class
JsOptions.JsButtons Class Members

The following tables list the members exposed by JsOptions.JsButtons.

Public Constructors
 | Name | Description
Public Constructor | JsOptions.JsButtons Constructor | Creates an instance of the JsOptions.jsButton object.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that defines the background fill of the buttons.
Public Property | EnableExportButton | Gets or sets a value that determines whether the export button is enabled.
Public Property | EnablePrintButton | Gets or sets a value that determines whether the print button is enabled.
Public Property | Foreground | Gets or sets a Background object that defines the icon fill within the buttons.
Public Property | ForegroundHover | Gets or sets a Background object that defines the icon fill within the buttons when the mouse is hovering over them.
Public Property | IconStrokeLine | Gets or sets a Line object that defines outline of the icons within the buttons.
Public Property | IconStrokeLineHover | Gets or sets a Line object that defines outline of the icons within the buttons when the mouse is hovering over them.
Public Property | Offset | Gets or sets a Point object by which the buttons are offset in pixels.
Public Property | Orientation | Gets or sets a value that determines the orientation of the buttons on the chart.
Public Property | Outline | Gets or sets a Line object that defines outline of the buttons.
Public Property | OutlineHover | Gets or sets a Line object that defines outline of the buttons when the mouse is hovering over them.
Top
See Also

Reference

JsOptions.JsButtons Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions.JsButtons Class : JsOptions.JsButtons Constructor
JsOptions.JsButtons Constructor
Creates an instance of the JsOptions.jsButton object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions.JsButtons()
public JsOptions.JsButtons()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions.JsButtons Class
JsOptions.JsButtons Class Properties

For a list of all members of this type, see JsOptions.JsButtons members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that defines the background fill of the buttons.
Public Property | EnableExportButton | Gets or sets a value that determines whether the export button is enabled.
Public Property | EnablePrintButton | Gets or sets a value that determines whether the print button is enabled.
Public Property | Foreground | Gets or sets a Background object that defines the icon fill within the buttons.
Public Property | ForegroundHover | Gets or sets a Background object that defines the icon fill within the buttons when the mouse is hovering over them.
Public Property | IconStrokeLine | Gets or sets a Line object that defines outline of the icons within the buttons.
Public Property | IconStrokeLineHover | Gets or sets a Line object that defines outline of the icons within the buttons when the mouse is hovering over them.
Public Property | Offset | Gets or sets a Point object by which the buttons are offset in pixels.
Public Property | Orientation | Gets or sets a value that determines the orientation of the buttons on the chart.
Public Property | Outline | Gets or sets a Line object that defines outline of the buttons.
Public Property | OutlineHover | Gets or sets a Line object that defines outline of the buttons when the mouse is hovering over them.
Top
See Also

Reference

JsOptions.JsButtons Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions.JsButtons Class : Background Property
Background Property (JsOptions.JsButtons)
Gets or sets a Background object that defines the background fill of the buttons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : EnableExportButton Property
EnableExportButton Property (JsOptions.JsButtons)
Gets or sets a value that determines whether the export button is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableExportButton As Boolean
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Boolean

instance.EnableExportButton = value

value = instance.EnableExportButton
public bool EnableExportButton {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : EnablePrintButton Property
EnablePrintButton Property
Gets or sets a value that determines whether the print button is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnablePrintButton As Boolean
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Boolean

instance.EnablePrintButton = value

value = instance.EnablePrintButton
public bool EnablePrintButton {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : Foreground Property
Foreground Property
Gets or sets a Background object that defines the icon fill within the buttons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Foreground As Background
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Background

instance.Foreground = value

value = instance.Foreground
public Background Foreground {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : ForegroundHover Property
ForegroundHover Property
Gets or sets a Background object that defines the icon fill within the buttons when the mouse is hovering over them.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForegroundHover As Background
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Background

instance.ForegroundHover = value

value = instance.ForegroundHover
public Background ForegroundHover {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : IconStrokeLine Property
IconStrokeLine Property
Gets or sets a Line object that defines outline of the icons within the buttons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IconStrokeLine As Line
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Line

instance.IconStrokeLine = value

value = instance.IconStrokeLine
public Line IconStrokeLine {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : IconStrokeLineHover Property
IconStrokeLineHover Property
Gets or sets a Line object that defines outline of the icons within the buttons when the mouse is hovering over them.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IconStrokeLineHover As Line
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Line

instance.IconStrokeLineHover = value

value = instance.IconStrokeLineHover
public Line IconStrokeLineHover {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : Offset Property
Offset Property (JsOptions.JsButtons)
Gets or sets a Point object by which the buttons are offset in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Offset As Point
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Point

instance.Offset = value

value = instance.Offset
public Point Offset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : Orientation Property
Orientation Property (JsOptions.JsButtons)
Gets or sets a value that determines the orientation of the buttons on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Orientation As Orientation
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Orientation

instance.Orientation = value

value = instance.Orientation
public Orientation Orientation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : Outline Property
Outline Property (JsOptions.JsButtons)
Gets or sets a Line object that defines outline of the buttons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Outline As Line
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Line

instance.Outline = value

value = instance.Outline
public Line Outline {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


dotnetCHARTING Namespace > JsOptions.JsButtons Class : OutlineHover Property
OutlineHover Property
Gets or sets a Line object that defines outline of the buttons when the mouse is hovering over them.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutlineHover As Line
'Usage

Dim instance As JsOptions.JsButtons
Dim value As Line

instance.OutlineHover = value

value = instance.OutlineHover
public Line OutlineHover {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsButtons Class
JsOptions.JsButtons Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions.JsCalendar Class
JsOptions.JsCalendar Class
Encompasses options for the JS calendar chart type.
Object Model
JsOptions.JsCalendar ClassElement ClassElement Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions.JsCalendar
'Usage

Dim instance As JsOptions.JsCalendar
public class JsOptions.JsCalendar
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions.JsCalendar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions.JsCalendar Class
JsOptions.JsCalendar Class Members

The following tables list the members exposed by JsOptions.JsCalendar.

Public Constructors
 | Name | Description
Public Constructor | JsOptions.JsCalendar Constructor | Creates an instance of the JsOptions.Calendar object.
Top
Public Properties
 | Name | Description
Public Property | Calculation | Gets or sets the calculation used when grouping date value pairs into cells and subvalues.
Public Property | DefaultEdgeElement | Gets or sets the default element options for peripheral calendar cells that are not part of the series date range but included for completeness. For example when using month view, some cells representing days of adjacent months are included to fill in the gaps of the grid.
Public Property | DefaultEmptyElement | Gets or sets the default element options for cells that do not contain any heatmap data.
Public Property | ElementFormat | Gets or sets the date format string used when creating element names. These labels are accessible through the element %name token in labels.
Public Property | EndDate | Gets or sets the end date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Public Property | Horizontal | Gets or sets a value determines whether the calendar chart is horizontal or vertical.
Public Property | Initial | Gets or sets the date of the series that should be displayed first when the calendar chart renders.
Public Property | InterpolateSubvalues | Gets or sets whether subvalue interpolation mode is enabled. Subvalues are grouped into predefined intervals but may result in spikes if data does not provide sufficient values for each sub grouping. Setting this to true will create interpolated values for missing data points.
Public Property | SeriesFormat | Gets or sets the date format string used when creating series names. These labels appear in the legend name columns.
Public Property | StartDate | Gets or sets the start date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Public Property | Type | Gets or sets the calendar view used with JS calendar charts.
Public Property | WeekStart | Gets or sets the starting day of the week used when the calendar view arranges the grid by weekdays.
Top
See Also

Reference

JsOptions.JsCalendar Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions.JsCalendar Class : JsOptions.JsCalendar Constructor
JsOptions.JsCalendar Constructor
Creates an instance of the JsOptions.Calendar object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions.JsCalendar()
public JsOptions.JsCalendar()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions.JsCalendar Class
JsOptions.JsCalendar Class Properties

For a list of all members of this type, see JsOptions.JsCalendar members.

Public Properties
 | Name | Description
Public Property | Calculation | Gets or sets the calculation used when grouping date value pairs into cells and subvalues.
Public Property | DefaultEdgeElement | Gets or sets the default element options for peripheral calendar cells that are not part of the series date range but included for completeness. For example when using month view, some cells representing days of adjacent months are included to fill in the gaps of the grid.
Public Property | DefaultEmptyElement | Gets or sets the default element options for cells that do not contain any heatmap data.
Public Property | ElementFormat | Gets or sets the date format string used when creating element names. These labels are accessible through the element %name token in labels.
Public Property | EndDate | Gets or sets the end date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Public Property | Horizontal | Gets or sets a value determines whether the calendar chart is horizontal or vertical.
Public Property | Initial | Gets or sets the date of the series that should be displayed first when the calendar chart renders.
Public Property | InterpolateSubvalues | Gets or sets whether subvalue interpolation mode is enabled. Subvalues are grouped into predefined intervals but may result in spikes if data does not provide sufficient values for each sub grouping. Setting this to true will create interpolated values for missing data points.
Public Property | SeriesFormat | Gets or sets the date format string used when creating series names. These labels appear in the legend name columns.
Public Property | StartDate | Gets or sets the start date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Public Property | Type | Gets or sets the calendar view used with JS calendar charts.
Public Property | WeekStart | Gets or sets the starting day of the week used when the calendar view arranges the grid by weekdays.
Top
See Also

Reference

JsOptions.JsCalendar Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : Calculation Property
Calculation Property
Gets or sets the calculation used when grouping date value pairs into cells and subvalues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public WriteOnly Property Calculation As Calculation
'Usage

Dim instance As JsOptions.JsCalendar

instance.Calculation = value
public Calculation Calculation {set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : DefaultEdgeElement Property
DefaultEdgeElement Property
Gets or sets the default element options for peripheral calendar cells that are not part of the series date range but included for completeness. For example when using month view, some cells representing days of adjacent months are included to fill in the gaps of the grid.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultEdgeElement As Element
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Element

value = instance.DefaultEdgeElement
public Element DefaultEdgeElement {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : DefaultEmptyElement Property
DefaultEmptyElement Property
Gets or sets the default element options for cells that do not contain any heatmap data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property DefaultEmptyElement As Element
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Element

value = instance.DefaultEmptyElement
public Element DefaultEmptyElement {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : ElementFormat Property
ElementFormat Property
Gets or sets the date format string used when creating element names. These labels are accessible through the element %name token in labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ElementFormat As String
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As String

instance.ElementFormat = value

value = instance.ElementFormat
public string ElementFormat {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : EndDate Property
EndDate Property (JsOptions.JsCalendar)
Gets or sets the end date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndDate As Date
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Date

instance.EndDate = value

value = instance.EndDate
public DateTime EndDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : Horizontal Property
Horizontal Property
Gets or sets a value determines whether the calendar chart is horizontal or vertical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Horizontal As Boolean
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Boolean

instance.Horizontal = value

value = instance.Horizontal
public bool Horizontal {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : Initial Property
Initial Property
Gets or sets the date of the series that should be displayed first when the calendar chart renders.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Initial As Date
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Date

instance.Initial = value

value = instance.Initial
public DateTime Initial {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : InterpolateSubvalues Property
InterpolateSubvalues Property
Gets or sets whether subvalue interpolation mode is enabled. Subvalues are grouped into predefined intervals but may result in spikes if data does not provide sufficient values for each sub grouping. Setting this to true will create interpolated values for missing data points.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InterpolateSubvalues As Boolean
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Boolean

instance.InterpolateSubvalues = value

value = instance.InterpolateSubvalues
public bool InterpolateSubvalues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : SeriesFormat Property
SeriesFormat Property
Gets or sets the date format string used when creating series names. These labels appear in the legend name columns.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SeriesFormat As String
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As String

instance.SeriesFormat = value

value = instance.SeriesFormat
public string SeriesFormat {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : StartDate Property
StartDate Property (JsOptions.JsCalendar)
Gets or sets the start date of the date range the calendar chart encompasses. It is required when the calendar chart is not populated with any data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDate As Date
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As Date

instance.StartDate = value

value = instance.StartDate
public DateTime StartDate {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : Type Property
Type Property (JsOptions.JsCalendar)
Gets or sets the calendar view used with JS calendar charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As JsOptions.CalendarView
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As JsOptions.CalendarView

instance.Type = value

value = instance.Type
public JsOptions.CalendarView Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


dotnetCHARTING Namespace > JsOptions.JsCalendar Class : WeekStart Property
WeekStart Property
Gets or sets the starting day of the week used when the calendar view arranges the grid by weekdays.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property WeekStart As DayOfWeek
'Usage

Dim instance As JsOptions.JsCalendar
Dim value As DayOfWeek

instance.WeekStart = value

value = instance.WeekStart
public DayOfWeek WeekStart {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendar Class
JsOptions.JsCalendar Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Class
Represents a JS calendar filter used to define rules such as weekends, or more complicated rules similar to how dates of national holidays are determined. Calendar filters can also represent complex time intervals such as first weekend of every month. Setting filter property value to "*" indicates an interval at that time span. For example month="*" means every month. Only one property can have an asterisk. To represent every 3 months this configuration can be used: month="*"; every=3; When using options such as year="1/1/2020" the year value is evaluated using the same function applied to dates being tested and is equivalent to year="2020"
Object Model
JsOptions.JsCalendarFilter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions.JsCalendarFilter
'Usage

Dim instance As JsOptions.JsCalendarFilter
public class JsOptions.JsCalendarFilter
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions.JsCalendarFilter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Class Members

The following tables list the members exposed by JsOptions.JsCalendarFilter.

Public Constructors
 | Name | Description
Public Constructor | JsOptions.JsCalendarFilter Constructor | Creates an instance of the JsOptions.CalendarFilter object.
Top
Public Properties
 | Name | Description
Public Property | Date | The specific date or dates to match.
Public Property | Day | The day of month to match (1-31).
Public Property | DayOfYear | The day of year to match.
Public Property | Every | When used with an interval filter such as {month="*",every=3}, it provides a way to specify "every 3 months"
Public Property | Hour | The hour of day to match.
Public Property | Inclusive | When multiple filters are specified and this this option is true, all filters must be met for a date value to match this pattern.
Public Property | Minute | The minute of hour to match (0-59).
Public Property | MinuteOfDay | The minute of day to match.
Public Property | Month | The month value to match (1-12).
Public Property | Quarter | The quarter number to match.
Public Property | Second | The second of minute to match (0-59).
Public Property | Weekday | The weekday number to match (0-6).
Public Property | Year | The year value to match.
Top
See Also

Reference

JsOptions.JsCalendarFilter Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : JsOptions.JsCalendarFilter Constructor
JsOptions.JsCalendarFilter Constructor
Creates an instance of the JsOptions.CalendarFilter object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions.JsCalendarFilter()
public JsOptions.JsCalendarFilter()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Class Properties

For a list of all members of this type, see JsOptions.JsCalendarFilter members.

Public Properties
 | Name | Description
Public Property | Date | The specific date or dates to match.
Public Property | Day | The day of month to match (1-31).
Public Property | DayOfYear | The day of year to match.
Public Property | Every | When used with an interval filter such as {month="*",every=3}, it provides a way to specify "every 3 months"
Public Property | Hour | The hour of day to match.
Public Property | Inclusive | When multiple filters are specified and this this option is true, all filters must be met for a date value to match this pattern.
Public Property | Minute | The minute of hour to match (0-59).
Public Property | MinuteOfDay | The minute of day to match.
Public Property | Month | The month value to match (1-12).
Public Property | Quarter | The quarter number to match.
Public Property | Second | The second of minute to match (0-59).
Public Property | Weekday | The weekday number to match (0-6).
Public Property | Year | The year value to match.
Top
See Also

Reference

JsOptions.JsCalendarFilter Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Date Property
Date Property
The specific date or dates to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Date As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Date = value

value = instance.Date
public string Date {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Day Property
Day Property (JsOptions.JsCalendarFilter)
The day of month to match (1-31).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Day As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Day = value

value = instance.Day
public string Day {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : DayOfYear Property
DayOfYear Property
The day of year to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DayOfYear As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.DayOfYear = value

value = instance.DayOfYear
public string DayOfYear {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Every Property
Every Property
When used with an interval filter such as {month="*",every=3}, it provides a way to specify "every 3 months"
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Every As Integer
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As Integer

instance.Every = value

value = instance.Every
public int Every {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Hour Property
Hour Property (JsOptions.JsCalendarFilter)
The hour of day to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hour As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Hour = value

value = instance.Hour
public string Hour {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Inclusive Property
Inclusive Property
When multiple filters are specified and this this option is true, all filters must be met for a date value to match this pattern.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Inclusive As Boolean
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As Boolean

instance.Inclusive = value

value = instance.Inclusive
public bool Inclusive {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Minute Property
Minute Property
The minute of hour to match (0-59).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Minute As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Minute = value

value = instance.Minute
public string Minute {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : MinuteOfDay Property
MinuteOfDay Property
The minute of day to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MinuteOfDay As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.MinuteOfDay = value

value = instance.MinuteOfDay
public string MinuteOfDay {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Month Property
Month Property (JsOptions.JsCalendarFilter)
The month value to match (1-12).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Month As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Month = value

value = instance.Month
public string Month {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Quarter Property
Quarter Property (JsOptions.JsCalendarFilter)
The quarter number to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Quarter As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Quarter = value

value = instance.Quarter
public string Quarter {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Second Property
Second Property
The second of minute to match (0-59).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Second As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Second = value

value = instance.Second
public string Second {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Weekday Property
Weekday Property
The weekday number to match (0-6).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Weekday As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Weekday = value

value = instance.Weekday
public string Weekday {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


dotnetCHARTING Namespace > JsOptions.JsCalendarFilter Class : Year Property
Year Property (JsOptions.JsCalendarFilter)
The year value to match.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Year As String
'Usage

Dim instance As JsOptions.JsCalendarFilter
Dim value As String

instance.Year = value

value = instance.Year
public string Year {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsCalendarFilter Class
JsOptions.JsCalendarFilter Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions.JsHighlight Class
JsOptions.JsHighlight Class
Options that define a calendar filter and styling used to highlight a grouping of points.
Object Model
JsOptions.JsHighlight ClassJsOptions.JsCalendarFilter ClassBackground ClassLine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions.JsHighlight
'Usage

Dim instance As JsOptions.JsHighlight
public class JsOptions.JsHighlight
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions.JsHighlight

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions.JsHighlight Class
JsOptions.JsHighlight Class Members

The following tables list the members exposed by JsOptions.JsHighlight.

Public Constructors
 | Name | Description
Public Constructor | JsOptions.JsHighlight Constructor | Instantiates a JsHighlight object.
Top
Public Properties
 | Name | Description
Public Property | CalendarFilter | Gets or sets the calendar filter used by this highlight
Public Property | Fill | Gets or sets the background fill of this highlight
Public Property | ID | Gets or sets the ID of the highlight
Public Property | Outline | Gets or sets the outline styling of this highlight.
Public Property | Transparency | Gets or sets the Transparency of this highlight.
Top
See Also

Reference

JsOptions.JsHighlight Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions.JsHighlight Class : JsOptions.JsHighlight Constructor
JsOptions.JsHighlight Constructor
Instantiates a JsHighlight object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions.JsHighlight()
public JsOptions.JsHighlight()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions.JsHighlight Class
JsOptions.JsHighlight Class Properties

For a list of all members of this type, see JsOptions.JsHighlight members.

Public Properties
 | Name | Description
Public Property | CalendarFilter | Gets or sets the calendar filter used by this highlight
Public Property | Fill | Gets or sets the background fill of this highlight
Public Property | ID | Gets or sets the ID of the highlight
Public Property | Outline | Gets or sets the outline styling of this highlight.
Public Property | Transparency | Gets or sets the Transparency of this highlight.
Top
See Also

Reference

JsOptions.JsHighlight Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions.JsHighlight Class : CalendarFilter Property
CalendarFilter Property
Gets or sets the calendar filter used by this highlight
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CalendarFilter As JsOptions.JsCalendarFilter
'Usage

Dim instance As JsOptions.JsHighlight
Dim value As JsOptions.JsCalendarFilter

instance.CalendarFilter = value

value = instance.CalendarFilter
public JsOptions.JsCalendarFilter CalendarFilter {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


dotnetCHARTING Namespace > JsOptions.JsHighlight Class : Fill Property
Fill Property
Gets or sets the background fill of this highlight
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Fill As Background
'Usage

Dim instance As JsOptions.JsHighlight
Dim value As Background

instance.Fill = value

value = instance.Fill
public Background Fill {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


dotnetCHARTING Namespace > JsOptions.JsHighlight Class : ID Property
ID Property
Gets or sets the ID of the highlight
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ID As String
'Usage

Dim instance As JsOptions.JsHighlight
Dim value As String

instance.ID = value

value = instance.ID
public string ID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


dotnetCHARTING Namespace > JsOptions.JsHighlight Class : Outline Property
Outline Property (JsOptions.JsHighlight)
Gets or sets the outline styling of this highlight.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Outline As Line
'Usage

Dim instance As JsOptions.JsHighlight
Dim value As Line

instance.Outline = value

value = instance.Outline
public Line Outline {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


dotnetCHARTING Namespace > JsOptions.JsHighlight Class : Transparency Property
Transparency Property (JsOptions.JsHighlight)
Gets or sets the Transparency of this highlight.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transparency As Integer
'Usage

Dim instance As JsOptions.JsHighlight
Dim value As Integer

instance.Transparency = value

value = instance.Transparency
public int Transparency {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.JsHighlight Class
JsOptions.JsHighlight Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Class
Defines the language string options for JavaScript charts.
Object Model
JsOptions.LanguageStringSettings Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class JsOptions.LanguageStringSettings
'Usage

Dim instance As JsOptions.LanguageStringSettings
public class JsOptions.LanguageStringSettings
Inheritance Hierarchy

System.Object
dotnetCHARTING.JsOptions.LanguageStringSettings

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Class Members

The following tables list the members exposed by JsOptions.LanguageStringSettings.

Public Constructors
 | Name | Description
Public Constructor | JsOptions.LanguageStringSettings Constructor | Creates an instance of the JsOptions.LanguageStringSettings object.
Top
Public Properties
 | Name | Description
Public Property | DownloadJpg | Gets or sets the string that is used for the export button item that downloads a Jpg image.
Public Property | DownloadPdf | Gets or sets the string that is used for the export button item that downloads a Pdf image.
Public Property | DownloadPng | Gets or sets the string that is used for the export button item that downloads a Png image.
Public Property | DownloadSvg | Gets or sets the string that is used for the export button item that downloads a Svg image.
Public Property | ExportButtonTooltip | Gets or sets the string that is used for the export button tooltip.
Public Property | Loading | Gets or sets the string that is used when the chart is loading.
Public Property | PrintButtonTooltip | Gets or sets the string that is used for the print button tooltip.
Public Property | ResetZoom | Gets or sets the string that is used for the link that resets the chart zoom level.
Public Property | ResetZoomTooltip | Gets or sets the string that is used as a tooltip for the link that resets the chart zoom level.
Top
See Also

Reference

JsOptions.LanguageStringSettings Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : JsOptions.LanguageStringSettings Constructor
JsOptions.LanguageStringSettings Constructor
Creates an instance of the JsOptions.LanguageStringSettings object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New JsOptions.LanguageStringSettings()
public JsOptions.LanguageStringSettings()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Class Properties

For a list of all members of this type, see JsOptions.LanguageStringSettings members.

Public Properties
 | Name | Description
Public Property | DownloadJpg | Gets or sets the string that is used for the export button item that downloads a Jpg image.
Public Property | DownloadPdf | Gets or sets the string that is used for the export button item that downloads a Pdf image.
Public Property | DownloadPng | Gets or sets the string that is used for the export button item that downloads a Png image.
Public Property | DownloadSvg | Gets or sets the string that is used for the export button item that downloads a Svg image.
Public Property | ExportButtonTooltip | Gets or sets the string that is used for the export button tooltip.
Public Property | Loading | Gets or sets the string that is used when the chart is loading.
Public Property | PrintButtonTooltip | Gets or sets the string that is used for the print button tooltip.
Public Property | ResetZoom | Gets or sets the string that is used for the link that resets the chart zoom level.
Public Property | ResetZoomTooltip | Gets or sets the string that is used as a tooltip for the link that resets the chart zoom level.
Top
See Also

Reference

JsOptions.LanguageStringSettings Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : DownloadJpg Property
DownloadJpg Property
Gets or sets the string that is used for the export button item that downloads a Jpg image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DownloadJpg As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.DownloadJpg = value

value = instance.DownloadJpg
public string DownloadJpg {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : DownloadPdf Property
DownloadPdf Property
Gets or sets the string that is used for the export button item that downloads a Pdf image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DownloadPdf As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.DownloadPdf = value

value = instance.DownloadPdf
public string DownloadPdf {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : DownloadPng Property
DownloadPng Property
Gets or sets the string that is used for the export button item that downloads a Png image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DownloadPng As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.DownloadPng = value

value = instance.DownloadPng
public string DownloadPng {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : DownloadSvg Property
DownloadSvg Property
Gets or sets the string that is used for the export button item that downloads a Svg image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DownloadSvg As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.DownloadSvg = value

value = instance.DownloadSvg
public string DownloadSvg {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : ExportButtonTooltip Property
ExportButtonTooltip Property
Gets or sets the string that is used for the export button tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExportButtonTooltip As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.ExportButtonTooltip = value

value = instance.ExportButtonTooltip
public string ExportButtonTooltip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : Loading Property
Loading Property
Gets or sets the string that is used when the chart is loading.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Loading As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.Loading = value

value = instance.Loading
public string Loading {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : PrintButtonTooltip Property
PrintButtonTooltip Property
Gets or sets the string that is used for the print button tooltip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PrintButtonTooltip As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.PrintButtonTooltip = value

value = instance.PrintButtonTooltip
public string PrintButtonTooltip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : ResetZoom Property
ResetZoom Property
Gets or sets the string that is used for the link that resets the chart zoom level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResetZoom As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.ResetZoom = value

value = instance.ResetZoom
public string ResetZoom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


dotnetCHARTING Namespace > JsOptions.LanguageStringSettings Class : ResetZoomTooltip Property
ResetZoomTooltip Property
Gets or sets the string that is used as a tooltip for the link that resets the chart zoom level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ResetZoomTooltip As String
'Usage

Dim instance As JsOptions.LanguageStringSettings
Dim value As String

instance.ResetZoomTooltip = value

value = instance.ResetZoomTooltip
public string ResetZoomTooltip {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

JsOptions.LanguageStringSettings Class
JsOptions.LanguageStringSettings Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Label Class
Label Class
Represents a label containing text, a font, color, and other options.
Object Model
Label ClassHotspot ClassShadow ClassTruncation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Label
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As Label
public class Label : dotnetCHARTING.Mapping.Drawing.Property
Inheritance Hierarchy

System.Object
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Members
dotnetCHARTING Namespace

Samples

Element Template
LineLabelAlignment

Tutorials

Using Labels
Label Alignment and Control
Label Reference
Token Reference


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Label Class
Label Class Members

The following tables list the members exposed by Label.

Public Constructors
 | Name | Description
Public Constructor | Label Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of this label.
Public Property | AutoWrap | Gets or sets a value that specifies whether this label will automatically wrap if it gets too long. This feature allows the chart to maintain the largest possible area for chart data.
Public Property | Color | Gets or sets the color of this label.
Public Property | Font | Gets or sets the font for this label.
Public Property | GlowColor | Gets or sets a Color used to create a glow effect around the drawn text.
Public Property | Hotspot | Gets or sets the Hotspot of this Label.
Public Property | LineAlignment | Gets or sets the line alignment of this label.
Public Property | MaxWidth | (JS Charts Only) Specifies the maximum width of a label. If the label is wider than this width it will attempt to wrap.
Public Property | Offset | (JS Chart Only) Gets or sets a label offset in pixels when used with JS charts.
Public Property | OutlineColor | Gets or sets to color used to outline this label's text.
Public Property | Placement | (JS Charts Only) Specifies if a label should be drawn inside or outside an object. Used with Series.ShapeLabels and with Element.SmartLabel.
Public Property | Shadow | Gets or sets a Shadow object used to cast a shadow for this label's text.
Public Property | Text | Gets or sets the text for this label.
Public Property | Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.
Public Property | Type | Gets or sets a LabelType enumeration member which specifies the type of font used.
Public Property | Width | (JS Chart Only) Gets or sets the width of this label when used with JS charts.
Top
Public Methods
 | Name | Description
Public Method | Dispose |
Public Method | ToString |
Top
See Also

Reference

Label Class
dotnetCHARTING Namespace

Samples

Element Template
LineLabelAlignment

Tutorials

Using Labels
Label Alignment and Control
Label Reference
Token Reference


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class : Label Constructor
Label Constructor
Overload List
Overload | Description
Label Constructor() | Initializes a new instance of the Label class.
Label Constructor(String) | Initializes a new instance of the Label class with text.
Label Constructor(String,Font) | Initializes a new instance of the Label class with text, and a font.
Label Constructor(String,Font,Color) | Initializes a new instance of the Label class with text, font, and a color.
Label Constructor(String,Font,Color,Color) | Initializes a new instance of the Label class with text, font, color, and an outline color.
Label Constructor(Font) | Initializes a new instance of the Label class with a font.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor()
Label Constructor()
Initializes a new instance of the Label class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Label()
public Label()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor(String)
Text of this label.
Label Constructor(String)
Initializes a new instance of the Label class with text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String _
)
'Usage

Dim text As String

Dim instance As New Label(text)
public Label(
   string text
)

Parameters

text
Text of this label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor(String,Font)
Text of this label.
Font of this label.
Label Constructor(String,Font)
Initializes a new instance of the Label class with text, and a font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal font As Font _
)
'Usage

Dim text As String
Dim font As Font

Dim instance As New Label(text, font)
public Label(
   string text,
   Font font
)

Parameters

text
Text of this label.
font
Font of this label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor(String,Font,Color)
Text of this label.
Font of this label.
Color of this label.
Label Constructor(String,Font,Color)
Initializes a new instance of the Label class with text, font, and a color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Color _
)
'Usage

Dim text As String
Dim font As Font
Dim color As Color

Dim instance As New Label(text, font, color)
public Label(
   string text,
   Font font,
   Color color
)

Parameters

text
Text of this label.
font
Font of this label.
color
Color of this label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor(String,Font,Color,Color)
Text of this label.
Font of this label.
Color of this label.
Outline Color of this label.
Label Constructor(String,Font,Color,Color)
Initializes a new instance of the Label class with text, font, color, and an outline color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal text As String, _
   ByVal font As Font, _
   ByVal color As Color, _
   ByVal outlineColor As Color _
)
'Usage

Dim text As String
Dim font As Font
Dim color As Color
Dim outlineColor As Color

Dim instance As New Label(text, font, color, outlineColor)
public Label(
   string text,
   Font font,
   Color color,
   Color outlineColor
)

Parameters

text
Text of this label.
font
Font of this label.
color
Color of this label.
outlineColor
Outline Color of this label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Label Class > Label Constructor : Label Constructor(Font)
Font of this label.
Label Constructor(Font)
Initializes a new instance of the Label class with a font.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal font As Font _
)
'Usage

Dim font As Font

Dim instance As New Label(font)
public Label(
   Font font
)

Parameters

font
Font of this label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Label Class
Label Class Methods

For a list of all members of this type, see Label members.

Public Methods
 | Name | Description
Public Method | Dispose |
Public Method | ToString |
Top
See Also

Reference

Label Class
dotnetCHARTING Namespace

Samples

Element Template
LineLabelAlignment

Tutorials

Using Labels
Label Alignment and Control
Label Reference
Token Reference


dotnetCHARTING Namespace > Label Class : Dispose() Method
Dispose() Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Dispose()
'Usage

Dim instance As Label

instance.Dispose()
public void Dispose()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : ToString Method
ToString Method (Label)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As Label
Dim value As String

value = instance.ToString()
public override string ToString()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members
Base Implementation in ToString


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Label Class
Label Class Properties

For a list of all members of this type, see Label members.

Public Properties
 | Name | Description
Public Property | Alignment | Gets or sets the alignment of this label.
Public Property | AutoWrap | Gets or sets a value that specifies whether this label will automatically wrap if it gets too long. This feature allows the chart to maintain the largest possible area for chart data.
Public Property | Color | Gets or sets the color of this label.
Public Property | Font | Gets or sets the font for this label.
Public Property | GlowColor | Gets or sets a Color used to create a glow effect around the drawn text.
Public Property | Hotspot | Gets or sets the Hotspot of this Label.
Public Property | LineAlignment | Gets or sets the line alignment of this label.
Public Property | MaxWidth | (JS Charts Only) Specifies the maximum width of a label. If the label is wider than this width it will attempt to wrap.
Public Property | Offset | (JS Chart Only) Gets or sets a label offset in pixels when used with JS charts.
Public Property | OutlineColor | Gets or sets to color used to outline this label's text.
Public Property | Placement | (JS Charts Only) Specifies if a label should be drawn inside or outside an object. Used with Series.ShapeLabels and with Element.SmartLabel.
Public Property | Shadow | Gets or sets a Shadow object used to cast a shadow for this label's text.
Public Property | Text | Gets or sets the text for this label.
Public Property | Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.
Public Property | Type | Gets or sets a LabelType enumeration member which specifies the type of font used.
Public Property | Width | (JS Chart Only) Gets or sets the width of this label when used with JS charts.
Top
See Also

Reference

Label Class
dotnetCHARTING Namespace

Samples

Element Template
LineLabelAlignment

Tutorials

Using Labels
Label Alignment and Control
Label Reference
Token Reference


dotnetCHARTING Namespace > Label Class : Alignment Property
Alignment Property (Label)
Gets or sets the alignment of this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Alignment As StringAlignment
'Usage

Dim instance As Label
Dim value As StringAlignment

instance.Alignment = value

value = instance.Alignment
public StringAlignment Alignment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : AutoWrap Property
AutoWrap Property
Gets or sets a value that specifies whether this label will automatically wrap if it gets too long. This feature allows the chart to maintain the largest possible area for chart data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AutoWrap As Boolean
'Usage

Dim instance As Label
Dim value As Boolean

instance.AutoWrap = value

value = instance.AutoWrap
public bool AutoWrap {get; set;}
Remarks
This property does not affect AxisTick labels. %Axis.TickLabelMode:Axis.TickLabelMode% should be used instead in those cases.
Example
AutoWrapLabels
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Color Property
Color Property (Label)
Gets or sets the color of this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As Label
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Font Property
Font Property
Gets or sets the font for this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Font As Font
'Usage

Dim instance As Label
Dim value As Font

instance.Font = value

value = instance.Font
public Font Font {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : GlowColor Property
GlowColor Property
Gets or sets a Color used to create a glow effect around the drawn text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GlowColor As Color
'Usage

Dim instance As Label
Dim value As Color

instance.GlowColor = value

value = instance.GlowColor
public Color GlowColor {get; set;}
Example
LabelStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Hotspot Property
Hotspot Property (Label)
Gets or sets the Hotspot of this Label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As Label
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : LineAlignment Property
LineAlignment Property
Gets or sets the line alignment of this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LineAlignment As StringAlignment
'Usage

Dim instance As Label
Dim value As StringAlignment

instance.LineAlignment = value

value = instance.LineAlignment
public StringAlignment LineAlignment {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : MaxWidth Property
MaxWidth Property
(JS Charts Only) Specifies the maximum width of a label. If the label is wider than this width it will attempt to wrap.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property MaxWidth As Integer
'Usage

Dim instance As Label
Dim value As Integer

instance.MaxWidth = value

value = instance.MaxWidth
public int MaxWidth {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Offset Property
Offset Property (Label)
(JS Chart Only) Gets or sets a label offset in pixels when used with JS charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Offset As Point
'Usage

Dim instance As Label
Dim value As Point

instance.Offset = value

value = instance.Offset
public Point Offset {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : OutlineColor Property
OutlineColor Property
Gets or sets to color used to outline this label's text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OutlineColor As Color
'Usage

Dim instance As Label
Dim value As Color

instance.OutlineColor = value

value = instance.OutlineColor
public Color OutlineColor {get; set;}
Example
LabelStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Placement Property
Placement Property
(JS Charts Only) Specifies if a label should be drawn inside or outside an object. Used with Series.ShapeLabels and with Element.SmartLabel.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Placement As Placement
'Usage

Dim instance As Label
Dim value As Placement

instance.Placement = value

value = instance.Placement
public Placement Placement {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Shadow Property
Shadow Property (Label)
Gets or sets a Shadow object used to cast a shadow for this label's text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Shadow As Shadow
'Usage

Dim instance As Label
Dim value As Shadow

instance.Shadow = value

value = instance.Shadow
public Shadow Shadow {get; set;}
Example
LabelStyling
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Text Property
Text Property (Label)
Gets or sets the text for this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As String
'Usage

Dim instance As Label
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Truncation Property
Truncation Property
Gets or sets properties used to dynamically shorten this label when it reaches a maximum length.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Truncation As Truncation
'Usage

Dim instance As Label
Dim value As Truncation

instance.Truncation = value

value = instance.Truncation
public Truncation Truncation {get; set;}
Example
LabelTruncation
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Type Property
Type Property (Label)
Gets or sets a LabelType enumeration member which specifies the type of font used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As LabelType
'Usage

Dim instance As Label
Dim value As LabelType

instance.Type = value

value = instance.Type
public LabelType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


dotnetCHARTING Namespace > Label Class : Width Property
Width Property (Label)
(JS Chart Only) Gets or sets the width of this label when used with JS charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Integer
'Usage

Dim instance As Label
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LabelAlignmentCollection Class
LabelAlignmentCollection Class
Contains a collection of LabelAlignment objects.
Object Model
LabelAlignmentCollection ClassLabelAlignment Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LabelAlignmentCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As LabelAlignmentCollection
public class LabelAlignmentCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LabelAlignmentCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : LabelAlignmentCollection Class
LabelAlignmentCollection Class Members

The following tables list the members exposed by LabelAlignmentCollection.

Public Constructors
 | Name | Description
Public Constructor | LabelAlignmentCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a specified LabelAlignment enumeration to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LabelAlignment.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a LabelAlignment enumeration into this collection at a specified index.
Public Method | Remove | Removes a specified label alignment from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LabelAlignmentCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > LabelAlignmentCollection Class : LabelAlignmentCollection Constructor
LabelAlignmentCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New LabelAlignmentCollection()
public LabelAlignmentCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : LabelAlignmentCollection Class
LabelAlignmentCollection Class Methods

For a list of all members of this type, see LabelAlignmentCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a specified LabelAlignment enumeration to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LabelAlignment.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a LabelAlignment enumeration into this collection at a specified index.
Public Method | Remove | Removes a specified label alignment from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LabelAlignmentCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LabelAlignmentCollection Class : Add Method
The LabelAlignment to add.
Add Method (LabelAlignmentCollection)
Adds a specified LabelAlignment enumeration to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal _LabelAlignment As LabelAlignment _
) As Integer
'Usage

Dim instance As LabelAlignmentCollection
Dim _LabelAlignment As LabelAlignment
Dim value As Integer

value = instance.Add(_LabelAlignment)
public int Add(
   LabelAlignment _LabelAlignment
)

Parameters

_LabelAlignment
The LabelAlignment to add.

Return Value

The zero-based index of the added LabelAlignment.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


dotnetCHARTING Namespace > LabelAlignmentCollection Class : Contains Method
The LabelAlignment to find.
Contains Method (LabelAlignmentCollection)
Determines whether this collection contains a specified LabelAlignment.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal _LabelAlignment As LabelAlignment _
) As Boolean
'Usage

Dim instance As LabelAlignmentCollection
Dim _LabelAlignment As LabelAlignment
Dim value As Boolean

value = instance.Contains(_LabelAlignment)
public bool Contains(
   LabelAlignment _LabelAlignment
)

Parameters

_LabelAlignment
The LabelAlignment to find.

Return Value

true if the specified LabelAlignment belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


dotnetCHARTING Namespace > LabelAlignmentCollection Class : Insert Method
The zero-based index into the collection at which to insert the label alignment.
The label alignment to insert into this collection.
Insert Method (LabelAlignmentCollection)
Inserts a LabelAlignment enumeration into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _LabelAlignment As LabelAlignment _
)
'Usage

Dim instance As LabelAlignmentCollection
Dim index As Integer
Dim _LabelAlignment As LabelAlignment

instance.Insert(index, _LabelAlignment)
public void Insert(
   int index,
   LabelAlignment _LabelAlignment
)

Parameters

index
The zero-based index into the collection at which to insert the label alignment.
_LabelAlignment
The label alignment to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


dotnetCHARTING Namespace > LabelAlignmentCollection Class : Remove Method
The label alignment to remove.
Remove Method (LabelAlignmentCollection)
Removes a specified label alignment from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal _LabelAlignment As LabelAlignment _
)
'Usage

Dim instance As LabelAlignmentCollection
Dim _LabelAlignment As LabelAlignment

instance.Remove(_LabelAlignment)
public void Remove(
   LabelAlignment _LabelAlignment
)

Parameters

_LabelAlignment
The label alignment to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LabelAlignmentCollection Class
LabelAlignmentCollection Class Properties

For a list of all members of this type, see LabelAlignmentCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

LabelAlignmentCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LabelAlignmentCollection Class : Item Property
Item Property (LabelAlignmentCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As LabelAlignment
'Usage

Dim instance As LabelAlignmentCollection
Dim index As Integer
Dim value As LabelAlignment

instance.Item(index) = value

value = instance.Item(index)
public LabelAlignment this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelAlignmentCollection Class
LabelAlignmentCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LabelOverrideCollection Class
LabelOverrideCollection Class
Contains a collection of LabelOverride objects.
Object Model
LabelOverrideCollection ClassLabelOverride Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LabelOverrideCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As LabelOverrideCollection
public class LabelOverrideCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LabelOverrideCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : LabelOverrideCollection Class
LabelOverrideCollection Class Members

The following tables list the members exposed by LabelOverrideCollection.

Public Constructors
 | Name | Description
Public Constructor | LabelOverrideCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a specified LabelOverride class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LabelOverride.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a label override into this collection at a specified index.
Public Method | Remove | Removes a specified label override from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LabelOverrideCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > LabelOverrideCollection Class : LabelOverrideCollection Constructor
LabelOverrideCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New LabelOverrideCollection()
public LabelOverrideCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : LabelOverrideCollection Class
LabelOverrideCollection Class Methods

For a list of all members of this type, see LabelOverrideCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a specified LabelOverride class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LabelOverride.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a label override into this collection at a specified index.
Public Method | Remove | Removes a specified label override from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LabelOverrideCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LabelOverrideCollection Class : Add Method
The LabelOverride to add.
Add Method (LabelOverrideCollection)
Adds a specified LabelOverride class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Add( _
   ByVal labelOverride As LabelOverride _
) As Integer
'Usage

Dim instance As LabelOverrideCollection
Dim labelOverride As LabelOverride
Dim value As Integer

value = instance.Add(labelOverride)
public int Add(
   LabelOverride labelOverride
)

Parameters

labelOverride
The LabelOverride to add.

Return Value

The zero-based index of the added LabelOverride.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


dotnetCHARTING Namespace > LabelOverrideCollection Class : Contains Method
The LabelOverride to find.
Contains Method (LabelOverrideCollection)
Determines whether this collection contains a specified LabelOverride.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal labelOverride As LabelOverride _
) As Boolean
'Usage

Dim instance As LabelOverrideCollection
Dim labelOverride As LabelOverride
Dim value As Boolean

value = instance.Contains(labelOverride)
public bool Contains(
   LabelOverride labelOverride
)

Parameters

labelOverride
The LabelOverride to find.

Return Value

true if the specified LabelOverride belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


dotnetCHARTING Namespace > LabelOverrideCollection Class : Insert Method
The zero-based index into the collection at which to insert the label override.
The label override to insert into this collection.
Insert Method (LabelOverrideCollection)
Inserts a label override into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal labelOverride As LabelOverride _
)
'Usage

Dim instance As LabelOverrideCollection
Dim index As Integer
Dim labelOverride As LabelOverride

instance.Insert(index, labelOverride)
public void Insert(
   int index,
   LabelOverride labelOverride
)

Parameters

index
The zero-based index into the collection at which to insert the label override.
labelOverride
The label override to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


dotnetCHARTING Namespace > LabelOverrideCollection Class : Remove Method
The label override marker to remove.
Remove Method (LabelOverrideCollection)
Removes a specified label override from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal labelOverride As LabelOverride _
)
'Usage

Dim instance As LabelOverrideCollection
Dim labelOverride As LabelOverride

instance.Remove(labelOverride)
public void Remove(
   LabelOverride labelOverride
)

Parameters

labelOverride
The label override marker to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LabelOverrideCollection Class
LabelOverrideCollection Class Properties

For a list of all members of this type, see LabelOverrideCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

LabelOverrideCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LabelOverrideCollection Class : Item Property
Item Property (LabelOverrideCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As LabelOverride
'Usage

Dim instance As LabelOverrideCollection
Dim index As Integer
Dim value As LabelOverride

instance.Item(index) = value

value = instance.Item(index)
public LabelOverride this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverrideCollection Class
LabelOverrideCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LegendBox Class
LegendBox Class
Encapsulates a collection of LegendEntry objects.
Object Model
LegendBox ClassBackground ClassDataSource ClassLegendEntry ClassLegendEntryCollection ClassLegendEntry ClassBoxHeaderOptions ClassLegendEntry ClassLine ClassLabel ClassLine ClassShadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LegendBox
   Inherits Box
'Usage

Dim instance As LegendBox
public class LegendBox : Box
Remarks
The legend box has many options such as positioning, source of entries and more. See legend box tutorial for more info.
Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.LegendBox

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Members
dotnetCHARTING Namespace

Tutorials

Legendbox Basics
Legendbox Advanced
Box Tutorial


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : LegendBox Class
LegendBox Class Members

The following tables list the members exposed by LegendBox.

Public Constructors
 | Name | Description
Public Constructor | LegendBox Constructor | Initializes a new instance of the LegendBox class.
Top
Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | ColumnAlignments | Gets or sets an array of StringAlignment enumeration members that specify the alignment of each column respectively. This setting applies for all legend entries in this legend box.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DataSource | Source of objects to populate the legend with.
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DefaultEntry | Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.
Public Property | ExtraEntries | Gets a collection of additional LegendEntry objects that are added to this LegendBox.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | HeaderEntry | Gets or sets a LegendEntry that is used as a header of this LegendBox.
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | LabelStyle | Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | ListTopToBottom | Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea. (Inherited from dotnetCHARTING.Box)
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object. (Inherited from dotnetCHARTING.Box)
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Template | Gets or sets the legend entry column layout of this legend box.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

LegendBox Class
dotnetCHARTING Namespace

Tutorials

Legendbox Basics
Legendbox Advanced
Box Tutorial


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendBox Class : LegendBox Constructor
LegendBox Constructor
Initializes a new instance of the LegendBox class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New LegendBox()
public LegendBox()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LegendBox Class
LegendBox Class Properties

For a list of all members of this type, see LegendBox members.

Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | ColumnAlignments | Gets or sets an array of StringAlignment enumeration members that specify the alignment of each column respectively. This setting applies for all legend entries in this legend box.
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DataSource | Source of objects to populate the legend with.
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DefaultEntry | Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.
Public Property | ExtraEntries | Gets a collection of additional LegendEntry objects that are added to this LegendBox.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | HeaderEntry | Gets or sets a LegendEntry that is used as a header of this LegendBox.
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | LabelStyle | Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | ListTopToBottom | Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea. (Inherited from dotnetCHARTING.Box)
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object. (Inherited from dotnetCHARTING.Box)
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Template | Gets or sets the legend entry column layout of this legend box.
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

LegendBox Class
dotnetCHARTING Namespace

Tutorials

Legendbox Basics
Legendbox Advanced
Box Tutorial


dotnetCHARTING Namespace > LegendBox Class : ColumnAlignments Property
ColumnAlignments Property
Gets or sets an array of StringAlignment enumeration members that specify the alignment of each column respectively. This setting applies for all legend entries in this legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColumnAlignments As StringAlignment()
'Usage

Dim instance As LegendBox
Dim value() As StringAlignment

instance.ColumnAlignments = value

value = instance.ColumnAlignments
public StringAlignment[] ColumnAlignments {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members
LegendColumnAlignment


dotnetCHARTING Namespace > LegendBox Class : DataSource Property
DataSource Property (LegendBox)
Source of objects to populate the legend with.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As DataSource
'Usage

Dim instance As LegendBox
Dim value As DataSource

instance.DataSource = value

value = instance.DataSource
public DataSource DataSource {get; set;}
Remarks
This DataSource is used with custom legend boxes added to Chart.ExtraLegendBoxes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members
LegendBoxDataSource


dotnetCHARTING Namespace > LegendBox Class : DefaultEntry Property
DefaultEntry Property
Gets or sets a LegendEntry that behaves as a vehicle for property settings that will propagate to all entries in this LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultEntry As LegendEntry
'Usage

Dim instance As LegendBox
Dim value As LegendEntry

instance.DefaultEntry = value

value = instance.DefaultEntry
public LegendEntry DefaultEntry {get; set;}
Remarks
The property settings of this object will not overwrite properties explicitly set for any given LegendEntry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members


dotnetCHARTING Namespace > LegendBox Class : ExtraEntries Property
ExtraEntries Property
Gets a collection of additional LegendEntry objects that are added to this LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ExtraEntries As LegendEntryCollection
'Usage

Dim instance As LegendBox
Dim value As LegendEntryCollection

value = instance.ExtraEntries
public LegendEntryCollection ExtraEntries {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members
LegendBoxElement

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendBox Class : HeaderEntry Property
HeaderEntry Property
Gets or sets a LegendEntry that is used as a header of this LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeaderEntry As LegendEntry
'Usage

Dim instance As LegendBox
Dim value As LegendEntry

instance.HeaderEntry = value

value = instance.HeaderEntry
public LegendEntry HeaderEntry {get; set;}
Remarks
This entry is not visible by default. To use it, set HeaderEntry.Visible = true. By default this object has different style settings that accentuate the fact that it is a header. Additional headers can be added to the ExtraEntries collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendBox Class : LabelStyle Property
LabelStyle Property (LegendBox)
Gets or sets a Label object that encapsulates default label style properties applied to legend entries drawn in this LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelStyle As Label
'Usage

Dim instance As LegendBox
Dim value As Label

instance.LabelStyle = value

value = instance.LabelStyle
public Label LabelStyle {get; set;}
Remarks
This property is the equivalent of LegendBox.DefaultEntry.LabelStyle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendBox Class : ListTopToBottom Property
ListTopToBottom Property
Gets or sets a value that indicates whether legend entries are listed top to bottom in multi-column legend boxes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ListTopToBottom As Boolean
'Usage

Dim instance As LegendBox
Dim value As Boolean

instance.ListTopToBottom = value

value = instance.ListTopToBottom
public bool ListTopToBottom {get; set;}
Remarks
When false, entries are listed left to right across columns in multi-column legend boxes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendBox Class : Template Property
Template Property
Gets or sets the legend entry column layout of this legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Template As String
'Usage

Dim instance As LegendBox
Dim value As String

instance.Template = value

value = instance.Template
public string Template {get; set;}
Remarks

Three tokens native to the legend box are:

  • %Icon - Draws a LegendEntry object's icon (LegendEntry.Marker).
  • %Name - Writes the legend entry's name (LegendEntry.Name).
  • %Value - Writes the legend entry's value (LegendEntry.Value).

NOTE: Legend entry properties like LegendEntry.Name can contain tokens used with the object the legend entry represents.

Some examples of properly formed templates are:

LegendBox.Template = "%Icon%Name%Value"

LegendBox.Template = "%Name%Icon"

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBox Class
LegendBox Members

Tutorials

LegendBox Advanced


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LegendBoxCollection Class
LegendBoxCollection Class
Contains a collection of LegendBox objects.
Object Model
LegendBoxCollection ClassLegendBox Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LegendBoxCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As LegendBoxCollection
public class LegendBoxCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LegendBoxCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : LegendBoxCollection Class
LegendBoxCollection Class Members

The following tables list the members exposed by LegendBoxCollection.

Public Constructors
 | Name | Description
Public Constructor | LegendBoxCollection Constructor | Creates a new instance of LegendBoxCollection with the specified list of LegendBox objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified LegendBoxCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LegendBox.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified LegendBox in this collection.
Public Method | Insert | Inserts a LegendBox into this collection at a specified index.
Public Method | Remove | Removes a specified LegendBox from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendBoxCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendBoxCollection Class : LegendBoxCollection Constructor
LegendBoxCollection Constructor
Creates a new instance of LegendBoxCollection with the specified list of LegendBox objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray legendBoxList() As LegendBox _
)
'Usage

Dim legendBoxList() As LegendBox

Dim instance As New LegendBoxCollection(legendBoxList)
public LegendBoxCollection(
   params LegendBox[] legendBoxList
)

Parameters

legendBoxList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : LegendBoxCollection Class
LegendBoxCollection Class Methods

For a list of all members of this type, see LegendBoxCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified LegendBoxCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LegendBox.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified LegendBox in this collection.
Public Method | Insert | Inserts a LegendBox into this collection at a specified index.
Public Method | Remove | Removes a specified LegendBox from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendBoxCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LegendBoxCollection Class : Add Method
Add Method (LegendBoxCollection)
Adds a specified LegendBoxCollection to this collection.
Overload List
Overload | Description
Add(LegendBox) |
Add(LegendBoxCollection) | Adds a specified LegendBoxCollection to this collection.
Add(LegendBox[]) | Adds the specified LegendBox objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


dotnetCHARTING Namespace > LegendBoxCollection Class > Add Method : Add(LegendBox) Method
Add(LegendBox) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal legendBox As LegendBox _
) As Integer
'Usage

Dim instance As LegendBoxCollection
Dim legendBox As LegendBox
Dim value As Integer

value = instance.Add(legendBox)
public int Add(
   LegendBox legendBox
)

Parameters

legendBox
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members
Overload List


dotnetCHARTING Namespace > LegendBoxCollection Class > Add Method : Add(LegendBoxCollection) Method
The LegendBoxCollection to add.
Add(LegendBoxCollection) Method
Adds a specified LegendBoxCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal legendBoxCollection As LegendBoxCollection _
)
'Usage

Dim instance As LegendBoxCollection
Dim legendBoxCollection As LegendBoxCollection

instance.Add(legendBoxCollection)
public void Add(
   LegendBoxCollection legendBoxCollection
)

Parameters

legendBoxCollection
The LegendBoxCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members
Overload List


dotnetCHARTING Namespace > LegendBoxCollection Class > Add Method : Add(LegendBox[]) Method
A list of LegendBox objects to add.
Add(LegendBox[]) Method
Adds the specified LegendBox objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray legendBoxList() As LegendBox _
)
'Usage

Dim instance As LegendBoxCollection
Dim legendBoxList() As LegendBox

instance.Add(legendBoxList)
public void Add(
   params LegendBox[] legendBoxList
)

Parameters

legendBoxList
A list of LegendBox objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members
Overload List


dotnetCHARTING Namespace > LegendBoxCollection Class : Contains Method
The LegendBox to find.
Contains Method (LegendBoxCollection)
Determines whether this collection contains a specified LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal legendBox As LegendBox _
) As Boolean
'Usage

Dim instance As LegendBoxCollection
Dim legendBox As LegendBox
Dim value As Boolean

value = instance.Contains(legendBox)
public bool Contains(
   LegendBox legendBox
)

Parameters

legendBox
The LegendBox to find.

Return Value

true if the specified LegendBox belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


dotnetCHARTING Namespace > LegendBoxCollection Class : IndexOf Method
The LegendBox to find.
IndexOf Method (LegendBoxCollection)
Determines the index of a specified LegendBox in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal legendBox As LegendBox _
) As Integer
'Usage

Dim instance As LegendBoxCollection
Dim legendBox As LegendBox
Dim value As Integer

value = instance.IndexOf(legendBox)
public int IndexOf(
   LegendBox legendBox
)

Parameters

legendBox
The LegendBox to find.

Return Value

The zero-based index of the specified LegendBox.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


dotnetCHARTING Namespace > LegendBoxCollection Class : Insert Method
The zero-based index into the collection at which to insert the LegendBox.
The LegendBox to insert into this collection.
Insert Method (LegendBoxCollection)
Inserts a LegendBox into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal legendBox As LegendBox _
)
'Usage

Dim instance As LegendBoxCollection
Dim index As Integer
Dim legendBox As LegendBox

instance.Insert(index, legendBox)
public void Insert(
   int index,
   LegendBox legendBox
)

Parameters

index
The zero-based index into the collection at which to insert the LegendBox.
legendBox
The LegendBox to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


dotnetCHARTING Namespace > LegendBoxCollection Class : Remove Method
The LegendBox to remove.
Remove Method (LegendBoxCollection)
Removes a specified LegendBox from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal legendBox As LegendBox _
)
'Usage

Dim instance As LegendBoxCollection
Dim legendBox As LegendBox

instance.Remove(legendBox)
public void Remove(
   LegendBox legendBox
)

Parameters

legendBox
The LegendBox to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LegendBoxCollection Class
LegendBoxCollection Class Properties

For a list of all members of this type, see LegendBoxCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

LegendBoxCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LegendBoxCollection Class : Item Property
Item Property (LegendBoxCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As LegendBox
'Usage

Dim instance As LegendBoxCollection
Dim index As Integer
Dim value As LegendBox

instance.Item(index) = value

value = instance.Item(index)
public LegendBox this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendBoxCollection Class
LegendBoxCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LegendEntry Class
LegendEntry Class
Represents an entry in the legend box.
Object Model
LegendEntry ClassBackground ClassListCollection ClassDataSource ClassLine ClassHotspot ClassLabel ClassElementMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LegendEntry
'Usage

Dim instance As LegendEntry
public class LegendEntry
Inheritance Hierarchy

System.Object
dotnetCHARTING.LegendEntry

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Members
dotnetCHARTING Namespace

Tutorials

LegendBox Basics
LegendBox Advanced


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : LegendEntry Class
LegendEntry Class Members

The following tables list the members exposed by LegendEntry.

Public Constructors
 | Name | Description
Public Constructor | LegendEntry Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that influences how the entry's icon is drawn.
Public Property | CustomAttributes | Gets or sets a ListCollection that represents additional entry attributes.
Public Property | DashStyle | Gets or sets a line System.Drawing.Drawing2D.DashStyle that influences how the entry's icon is drawn.
Public Property | DataSource | Gets or sets a DataSource object used to replace tokens.
Public Property | DividerLine | Gets or sets a Line that is drawn under the LegendEntry.
Public Property | HeaderMode | Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.
Public Property | Hotspot | Gets or sets the Hotspot of this LegendEntry.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action setting when the mouse hovers the legend entry.
Public Property | LabelStyle | Gets or sets a Label object that defines the font and color of this LegendEntry object's text.
Public Property | Marker | Gets or sets an ElementMarker that influences how the entry's icon is drawn.
Public Property | Name | Gets or sets the name of this legend entry.
Public Property | PaddingTop | Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.
Public Property | SeriesType | Gets or sets a SeriesType that influences how the entry's icon is drawn.
Public Property | ShapeType | Gets or sets the shape type of this legend entry icon when LegendEntry.SeriesType = SeriesType.BubbleShape.
Public Property | SortOrder | Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.
Public Property | ToolTip | Gets or sets this legend entry's tool tip.
Public Property | URL | Gets or sets the URL of this legend entry.
Public Property | URLTarget | Gets or sets the URL target of this legend entry's link.
Public Property | Use3D | Gets or sets a value that specifies whether icons represent 2D or 3D series.
Public Property | Value | Gets or sets the value of this legend entry.
Public Property | Visible | Gets or sets a value which specifies whether the legend entry is visible.
Top
See Also

Reference

LegendEntry Class
dotnetCHARTING Namespace

Tutorials

LegendBox Basics
LegendBox Advanced


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class : LegendEntry Constructor
LegendEntry Constructor
Overload List
Overload | Description
LegendEntry Constructor() | Initializes a new instance of the LegendEntry class.
LegendEntry Constructor(String,String) | Initializes a new instance of the LegendEntry class with a Name and Value.
LegendEntry Constructor(String,String,Color) | Initializes a new instance of the LegendEntry class with a Name, Value and icon color.
LegendEntry Constructor(String,String,Background) | Initializes a new instance of the LegendEntry class with a Name, Value and icon background.
LegendEntry Constructor(String,String,String) | Initializes a new instance of the LegendEntry class with a Name, Value and icon background.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class > LegendEntry Constructor : LegendEntry Constructor()
LegendEntry Constructor()
Initializes a new instance of the LegendEntry class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New LegendEntry()
public LegendEntry()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class > LegendEntry Constructor : LegendEntry Constructor(String,String)
Sets the LegendEntry.Name property.
Sets the LegendEntry.Value property.
LegendEntry Constructor(String,String)
Initializes a new instance of the LegendEntry class with a Name and Value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String _
)
'Usage

Dim nameString As String
Dim valueString As String

Dim instance As New LegendEntry(nameString, valueString)
public LegendEntry(
   string nameString,
   string valueString
)

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class > LegendEntry Constructor : LegendEntry Constructor(String,String,Color)
Sets the LegendEntry.Name property.
Sets the LegendEntry.Value property.
Sets the LegendEntry.Background.Color property.
LegendEntry Constructor(String,String,Color)
Initializes a new instance of the LegendEntry class with a Name, Value and icon color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconBackgroundColor As Color _
)
'Usage

Dim nameString As String
Dim valueString As String
Dim iconBackgroundColor As Color

Dim instance As New LegendEntry(nameString, valueString, iconBackgroundColor)
public LegendEntry(
   string nameString,
   string valueString,
   Color iconBackgroundColor
)

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackgroundColor
Sets the LegendEntry.Background.Color property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class > LegendEntry Constructor : LegendEntry Constructor(String,String,Background)
Sets the LegendEntry.Name property.
Sets the LegendEntry.Value property.
Sets the LegendEntry.Background.Color property.
LegendEntry Constructor(String,String,Background)
Initializes a new instance of the LegendEntry class with a Name, Value and icon background.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconBackground As Background _
)
'Usage

Dim nameString As String
Dim valueString As String
Dim iconBackground As Background

Dim instance As New LegendEntry(nameString, valueString, iconBackground)
public LegendEntry(
   string nameString,
   string valueString,
   Background iconBackground
)

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconBackground
Sets the LegendEntry.Background.Color property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntry Class > LegendEntry Constructor : LegendEntry Constructor(String,String,String)
Sets the LegendEntry.Name property.
Sets the LegendEntry.Value property.
Sets the string representation of the icon.
LegendEntry Constructor(String,String,String)
Initializes a new instance of the LegendEntry class with a Name, Value and icon background.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal nameString As String, _
   ByVal valueString As String, _
   ByVal iconString As String _
)
'Usage

Dim nameString As String
Dim valueString As String
Dim iconString As String

Dim instance As New LegendEntry(nameString, valueString, iconString)
public LegendEntry(
   string nameString,
   string valueString,
   string iconString
)

Parameters

nameString
Sets the LegendEntry.Name property.
valueString
Sets the LegendEntry.Value property.
iconString
Sets the string representation of the icon.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LegendEntry Class
LegendEntry Class Properties

For a list of all members of this type, see LegendEntry members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets a Background object that influences how the entry's icon is drawn.
Public Property | CustomAttributes | Gets or sets a ListCollection that represents additional entry attributes.
Public Property | DashStyle | Gets or sets a line System.Drawing.Drawing2D.DashStyle that influences how the entry's icon is drawn.
Public Property | DataSource | Gets or sets a DataSource object used to replace tokens.
Public Property | DividerLine | Gets or sets a Line that is drawn under the LegendEntry.
Public Property | HeaderMode | Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.
Public Property | Hotspot | Gets or sets the Hotspot of this LegendEntry.
Public Property | HoverAction | (JS Chart Only) Gets or sets the hover action setting when the mouse hovers the legend entry.
Public Property | LabelStyle | Gets or sets a Label object that defines the font and color of this LegendEntry object's text.
Public Property | Marker | Gets or sets an ElementMarker that influences how the entry's icon is drawn.
Public Property | Name | Gets or sets the name of this legend entry.
Public Property | PaddingTop | Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.
Public Property | SeriesType | Gets or sets a SeriesType that influences how the entry's icon is drawn.
Public Property | ShapeType | Gets or sets the shape type of this legend entry icon when LegendEntry.SeriesType = SeriesType.BubbleShape.
Public Property | SortOrder | Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.
Public Property | ToolTip | Gets or sets this legend entry's tool tip.
Public Property | URL | Gets or sets the URL of this legend entry.
Public Property | URLTarget | Gets or sets the URL target of this legend entry's link.
Public Property | Use3D | Gets or sets a value that specifies whether icons represent 2D or 3D series.
Public Property | Value | Gets or sets the value of this legend entry.
Public Property | Visible | Gets or sets a value which specifies whether the legend entry is visible.
Top
See Also

Reference

LegendEntry Class
dotnetCHARTING Namespace

Tutorials

LegendBox Basics
LegendBox Advanced


dotnetCHARTING Namespace > LegendEntry Class : Background Property
Background Property (LegendEntry)
Gets or sets a Background object that influences how the entry's icon is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As LegendEntry
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Remarks
This object is used with the following settings
LegendEntry.SeriesType = SeriesType.Column
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : CustomAttributes Property
CustomAttributes Property (LegendEntry)
Gets or sets a ListCollection that represents additional entry attributes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CustomAttributes As ListCollection
'Usage

Dim instance As LegendEntry
Dim value As ListCollection

instance.CustomAttributes = value

value = instance.CustomAttributes
public ListCollection CustomAttributes {get; set;}
Remarks
In addition to name, value, and icon, the legend entry can contain further information such as descriptions or comments. These attributes will appear in a legend box when the LegendBox.Template string contains the custom attribute key prefixed with a '%'.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Samples

LegendBoxDataSource

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendEntry Class : DashStyle Property
DashStyle Property (LegendEntry)
Gets or sets a line System.Drawing.Drawing2D.DashStyle that influences how the entry's icon is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DashStyle As DashStyle
'Usage

Dim instance As LegendEntry
Dim value As DashStyle

instance.DashStyle = value

value = instance.DashStyle
public DashStyle DashStyle {get; set;}
Remarks
This object is used with the following settings
LegendEntry.SeriesType = SeriesType.Marker
LegendEntry.In3D = false
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : DataSource Property
DataSource Property (LegendEntry)
Gets or sets a DataSource object used to replace tokens.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataSource As DataSource
'Usage

Dim instance As LegendEntry
Dim value As DataSource

instance.DataSource = value

value = instance.DataSource
public DataSource DataSource {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : DividerLine Property
DividerLine Property
Gets or sets a Line that is drawn under the LegendEntry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DividerLine As Line
'Usage

Dim instance As LegendEntry
Dim value As Line

instance.DividerLine = value

value = instance.DividerLine
public Line DividerLine {get; set;}
Remarks
This line doesn't appear automatically because it's color (LegendEntry.Line.Color) is Color.Empty. To activate it, specify a color for the line. When active, it will add more space between the this entry and the one below it.
Example
LegendBoxCustomHeader
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : HeaderMode Property
HeaderMode Property
Gets or sets an a LegendEntryHeaderMode enumeration that specifies a how this LegendEntry behaves.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HeaderMode As LegendEntryHeaderMode
'Usage

Dim instance As LegendEntry
Dim value As LegendEntryHeaderMode

instance.HeaderMode = value

value = instance.HeaderMode
public LegendEntryHeaderMode HeaderMode {get; set;}
Example
LegendBoxCustomHeader
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : Hotspot Property
Hotspot Property (LegendEntry)
Gets or sets the Hotspot of this LegendEntry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As LegendEntry
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Example
Hide Series
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

Hotspots


dotnetCHARTING Namespace > LegendEntry Class : HoverAction Property
HoverAction Property (LegendEntry)
(JS Chart Only) Gets or sets the hover action setting when the mouse hovers the legend entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HoverAction As HoverAction
'Usage

Dim instance As LegendEntry
Dim value As HoverAction

instance.HoverAction = value

value = instance.HoverAction
public HoverAction HoverAction {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : LabelStyle Property
LabelStyle Property (LegendEntry)
Gets or sets a Label object that defines the font and color of this LegendEntry object's text.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelStyle As Label
'Usage

Dim instance As LegendEntry
Dim value As Label

instance.LabelStyle = value

value = instance.LabelStyle
public Label LabelStyle {get; set;}
Example
Legend Box
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : Marker Property
Marker Property (LegendEntry)
Gets or sets an ElementMarker that influences how the entry's icon is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As LegendEntry
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Remarks
To draw only this marker as the icon, set LegendEntry.SeriesType = SeriesType.Marker.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : Name Property
Name Property (LegendEntry)
Gets or sets the name of this legend entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As LegendEntry
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Remarks
Tokens may be used to describe the object represented by this legend entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendEntry Class : PaddingTop Property
PaddingTop Property
Gets or sets a value (in pixels) that specifies additional padding above this LegendEntry object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaddingTop As Integer
'Usage

Dim instance As LegendEntry
Dim value As Integer

instance.PaddingTop = value

value = instance.PaddingTop
public int PaddingTop {get; set;}
Remarks
This property is useful when the LegendEntry is a header and starts a new group of entries. Additional spacing may be required between the groups to accentuate the separation between groups.
Example
LegendBoxCustomHeader
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : SeriesType Property
SeriesType Property
Gets or sets a SeriesType that influences how the entry's icon is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SeriesType As SeriesType
'Usage

Dim instance As LegendEntry
Dim value As SeriesType

instance.SeriesType = value

value = instance.SeriesType
public SeriesType SeriesType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : ShapeType Property
ShapeType Property (LegendEntry)
Gets or sets the shape type of this legend entry icon when LegendEntry.SeriesType = SeriesType.BubbleShape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShapeType As ShapeType
'Usage

Dim instance As LegendEntry
Dim value As ShapeType

instance.ShapeType = value

value = instance.ShapeType
public ShapeType ShapeType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : SortOrder Property
SortOrder Property
Gets or sets a value that represents the sort position of this LegenEntry when sorted with other entries in a LegendBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SortOrder As Integer
'Usage

Dim instance As LegendEntry
Dim value As Integer

instance.SortOrder = value

value = instance.SortOrder
public int SortOrder {get; set;}
Remarks
The default sort value of all legend entries is zero (0). To indicate that an entry is first in a legend box, set this property to -1.
Example
LegendBoxDataSource
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : ToolTip Property
ToolTip Property (LegendEntry)
Gets or sets this legend entry's tool tip.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTip As String
'Usage

Dim instance As LegendEntry
Dim value As String

instance.ToolTip = value

value = instance.ToolTip
public string ToolTip {get; set;}

Property Value

A string representing the tool tip of this legend entry.
Remarks
Tokens may be used to describe the object represented by this legend entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

Hotspots


dotnetCHARTING Namespace > LegendEntry Class : URL Property
URL Property (LegendEntry)
Gets or sets the URL of this legend entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URL As String
'Usage

Dim instance As LegendEntry
Dim value As String

instance.URL = value

value = instance.URL
public string URL {get; set;}

Property Value

A string representing the url of this legend entry.
Remarks
Tokens may be used to describe the object represented by this legend entry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

Hotspots


dotnetCHARTING Namespace > LegendEntry Class : URLTarget Property
URLTarget Property (LegendEntry)
Gets or sets the URL target of this legend entry's link.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property URLTarget As String
'Usage

Dim instance As LegendEntry
Dim value As String

instance.URLTarget = value

value = instance.URLTarget
public string URLTarget {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

Hotspots


dotnetCHARTING Namespace > LegendEntry Class : Use3D Property
Use3D Property (LegendEntry)
Gets or sets a value that specifies whether icons represent 2D or 3D series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use3D As Boolean
'Usage

Dim instance As LegendEntry
Dim value As Boolean

instance.Use3D = value

value = instance.Use3D
public bool Use3D {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


dotnetCHARTING Namespace > LegendEntry Class : Value Property
Value Property (LegendEntry)
Gets or sets the value of this legend entry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As String
'Usage

Dim instance As LegendEntry
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
Remarks
This string specified in the legend box column Template by the token '%Value'.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members

Tutorials

LegendBox Advanced


dotnetCHARTING Namespace > LegendEntry Class : Visible Property
Visible Property (LegendEntry)
Gets or sets a value which specifies whether the legend entry is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As LegendEntry
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntry Class
LegendEntry Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LegendEntryCollection Class
LegendEntryCollection Class
Contains a collection of LegendEntry objects.
Object Model
LegendEntryCollection ClassLegendEntry Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class LegendEntryCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As LegendEntryCollection
public class LegendEntryCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.LegendEntryCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : LegendEntryCollection Class
LegendEntryCollection Class Members

The following tables list the members exposed by LegendEntryCollection.

Public Constructors
 | Name | Description
Public Constructor | LegendEntryCollection Constructor | Creates a new instance of LegendEntryCollection with the specified list of LegendEntry objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified LegendEntry class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LegendEntry.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified LegendEntry in this collection.
Public Method | Insert | Inserts a legend entry into this collection at a specified index.
Public Method | Remove | Removes a specified legend entry from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendEntryCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > LegendEntryCollection Class : LegendEntryCollection Constructor
LegendEntryCollection Constructor
Creates a new instance of LegendEntryCollection with the specified list of LegendEntry objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray legendEntryList() As LegendEntry _
)
'Usage

Dim legendEntryList() As LegendEntry

Dim instance As New LegendEntryCollection(legendEntryList)
public LegendEntryCollection(
   params LegendEntry[] legendEntryList
)

Parameters

legendEntryList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : LegendEntryCollection Class
LegendEntryCollection Class Methods

For a list of all members of this type, see LegendEntryCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified LegendEntry class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified LegendEntry.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified LegendEntry in this collection.
Public Method | Insert | Inserts a legend entry into this collection at a specified index.
Public Method | Remove | Removes a specified legend entry from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

LegendEntryCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LegendEntryCollection Class : Add Method
Add Method (LegendEntryCollection)
Adds a specified LegendEntry class to this collection.
Overload List
Overload | Description
Add(LegendEntry) | Adds a specified LegendEntry class to this collection.
Add(LegendEntryCollection) | Adds a specified LegendEntryCollection to this collection.
Add(LegendEntry[]) | Adds the specified LegendEntry objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


dotnetCHARTING Namespace > LegendEntryCollection Class > Add Method : Add(LegendEntry) Method
The LegendEntry to add.
Add(LegendEntry) Method
Adds a specified LegendEntry class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal legendEntry As LegendEntry _
) As Integer
'Usage

Dim instance As LegendEntryCollection
Dim legendEntry As LegendEntry
Dim value As Integer

value = instance.Add(legendEntry)
public int Add(
   LegendEntry legendEntry
)

Parameters

legendEntry
The LegendEntry to add.

Return Value

The zero-based index of the added LegendEntry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members
Overload List


dotnetCHARTING Namespace > LegendEntryCollection Class > Add Method : Add(LegendEntryCollection) Method
The LegendEntryCollection to add.
Add(LegendEntryCollection) Method
Adds a specified LegendEntryCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal legendEntryCollection As LegendEntryCollection _
)
'Usage

Dim instance As LegendEntryCollection
Dim legendEntryCollection As LegendEntryCollection

instance.Add(legendEntryCollection)
public void Add(
   LegendEntryCollection legendEntryCollection
)

Parameters

legendEntryCollection
The LegendEntryCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members
Overload List


dotnetCHARTING Namespace > LegendEntryCollection Class > Add Method : Add(LegendEntry[]) Method
A list of LegendEntry objects to add.
Add(LegendEntry[]) Method
Adds the specified LegendEntry objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray legendEntryList() As LegendEntry _
)
'Usage

Dim instance As LegendEntryCollection
Dim legendEntryList() As LegendEntry

instance.Add(legendEntryList)
public void Add(
   params LegendEntry[] legendEntryList
)

Parameters

legendEntryList
A list of LegendEntry objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members
Overload List


dotnetCHARTING Namespace > LegendEntryCollection Class : Contains Method
The LegendEntry to find.
Contains Method (LegendEntryCollection)
Determines whether this collection contains a specified LegendEntry.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal legendEntry As LegendEntry _
) As Boolean
'Usage

Dim instance As LegendEntryCollection
Dim legendEntry As LegendEntry
Dim value As Boolean

value = instance.Contains(legendEntry)
public bool Contains(
   LegendEntry legendEntry
)

Parameters

legendEntry
The LegendEntry to find.

Return Value

true if the specified LegendEntry belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


dotnetCHARTING Namespace > LegendEntryCollection Class : IndexOf Method
The LegendEntry to find.
IndexOf Method (LegendEntryCollection)
Determines the index of a specified LegendEntry in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal legendEntry As LegendEntry _
) As Integer
'Usage

Dim instance As LegendEntryCollection
Dim legendEntry As LegendEntry
Dim value As Integer

value = instance.IndexOf(legendEntry)
public int IndexOf(
   LegendEntry legendEntry
)

Parameters

legendEntry
The LegendEntry to find.

Return Value

The zero-based index of the specified LegendEntry.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


dotnetCHARTING Namespace > LegendEntryCollection Class : Insert Method
The zero-based index into the collection at which to insert the legend entry.
The legend entry to insert into this collection.
Insert Method (LegendEntryCollection)
Inserts a legend entry into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal legendEntry As LegendEntry _
)
'Usage

Dim instance As LegendEntryCollection
Dim index As Integer
Dim legendEntry As LegendEntry

instance.Insert(index, legendEntry)
public void Insert(
   int index,
   LegendEntry legendEntry
)

Parameters

index
The zero-based index into the collection at which to insert the legend entry.
legendEntry
The legend entry to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


dotnetCHARTING Namespace > LegendEntryCollection Class : Remove Method
The legend element to remove.
Remove Method (LegendEntryCollection)
Removes a specified legend entry from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal legendEntry As LegendEntry _
)
'Usage

Dim instance As LegendEntryCollection
Dim legendEntry As LegendEntry

instance.Remove(legendEntry)
public void Remove(
   LegendEntry legendEntry
)

Parameters

legendEntry
The legend element to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : LegendEntryCollection Class
LegendEntryCollection Class Properties

For a list of all members of this type, see LegendEntryCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

LegendEntryCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LegendEntryCollection Class : Item Property
Item Property (LegendEntryCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As LegendEntry
'Usage

Dim instance As LegendEntryCollection
Dim index As Integer
Dim value As LegendEntry

instance.Item(index) = value

value = instance.Item(index)
public LegendEntry this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LegendEntryCollection Class
LegendEntryCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Line Class
Line Class
Object Model
Line Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Line
   Inherits dotnetCHARTING.Mapping.Drawing.Property
'Usage

Dim instance As Line
public class Line : dotnetCHARTING.Mapping.Drawing.Property
Inheritance Hierarchy

System.Object
dotnetCHARTING.Line

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Members
dotnetCHARTING Namespace

Tutorials

Line Reference


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Line Class
Line Class Members

The following tables list the members exposed by Line.

Public Constructors
 | Name | Description
Public Constructor | Line Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AnchorCapScale | Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.
Public Property | Color | Gets or sets the color of this line.
Public Property | DashStyle | Gets or sets the System.Drawing.Drawing2D.DashStyle of this line.
Public Property | EndCap | Gets or sets the System.Drawing.Drawing2D.LineCap that ends this line.
Public Property | Length | Gets or sets the length of this line.
Public Property | StartCap | Gets or sets the System.Drawing.Drawing2D.LineCap that starts this line.
Public Property | Transparency | Gets or sets the transparency percentage of this line (0-100) where 0 = transparent, 100 = solid.
Public Property | Visible | Gets or sets a value that indicates whether this line is visible.
Public Property | Width | Gets or sets the width of this line.
Top
See Also

Reference

Line Class
dotnetCHARTING Namespace

Tutorials

Line Reference


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class : Line Constructor
Line Constructor
Overload List
Overload | Description
Line Constructor() | Initialize a new instance of the Line.
Line Constructor(Color) | Initialize a new instance of the Line class with a color.
Line Constructor(Color,Int32) | Initialize a new instance of the Line class with a color and line width.
Line Constructor(Color,Int32,DashStyle) | Initialize a new instance of the Line class with a color, line width, and .
Line Constructor(Color,DashStyle) | Initialize a new instance of the Line class with a color and System.Drawing.Drawing2D.DashStyle.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class > Line Constructor : Line Constructor()
Line Constructor()
Initialize a new instance of the Line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Line()
public Line()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class > Line Constructor : Line Constructor(Color)
Color of the line.
Line Constructor(Color)
Initialize a new instance of the Line class with a color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal c As Color _
)
'Usage

Dim c As Color

Dim instance As New Line(c)
public Line(
   Color c
)

Parameters

c
Color of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32)
Color of the line.
Width of the line.
Line Constructor(Color,Int32)
Initialize a new instance of the Line class with a color and line width.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal c As Color, _
   ByVal width As Integer _
)
'Usage

Dim c As Color
Dim width As Integer

Dim instance As New Line(c, width)
public Line(
   Color c,
   int width
)

Parameters

c
Color of the line.
width
Width of the line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class > Line Constructor : Line Constructor(Color,Int32,DashStyle)
Line Constructor(Color,Int32,DashStyle)
Initialize a new instance of the Line class with a color, line width, and .
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal c As Color, _
   ByVal width As Integer, _
   ByVal ds As DashStyle _
)
'Usage

Dim c As Color
Dim width As Integer
Dim ds As DashStyle

Dim instance As New Line(c, width, ds)
public Line(
   Color c,
   int width,
   DashStyle ds
)

Parameters

c
width
ds
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle
System.Drawing.Drawing2D.DashStyle


%%PageItemTitle%%

dotnetCHARTING Namespace > Line Class > Line Constructor : Line Constructor(Color,DashStyle)
Color of the line.
System.Drawing.Drawing2D.DashStyle of this line.
Line Constructor(Color,DashStyle)
Initialize a new instance of the Line class with a color and System.Drawing.Drawing2D.DashStyle.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal c As Color, _
   ByVal ds As DashStyle _
)
'Usage

Dim c As Color
Dim ds As DashStyle

Dim instance As New Line(c, ds)
public Line(
   Color c,
   DashStyle ds
)

Parameters

c
Color of the line.
ds
System.Drawing.Drawing2D.DashStyle of this line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Line Class
Line Class Properties

For a list of all members of this type, see Line members.

Public Properties
 | Name | Description
Public Property | AnchorCapScale | Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.
Public Property | Color | Gets or sets the color of this line.
Public Property | DashStyle | Gets or sets the System.Drawing.Drawing2D.DashStyle of this line.
Public Property | EndCap | Gets or sets the System.Drawing.Drawing2D.LineCap that ends this line.
Public Property | Length | Gets or sets the length of this line.
Public Property | StartCap | Gets or sets the System.Drawing.Drawing2D.LineCap that starts this line.
Public Property | Transparency | Gets or sets the transparency percentage of this line (0-100) where 0 = transparent, 100 = solid.
Public Property | Visible | Gets or sets a value that indicates whether this line is visible.
Public Property | Width | Gets or sets the width of this line.
Top
See Also

Reference

Line Class
dotnetCHARTING Namespace

Tutorials

Line Reference


dotnetCHARTING Namespace > Line Class : AnchorCapScale Property
AnchorCapScale Property
Gets or sets the amount by which to scale the line caps with respect to the width of the line. This feature only works with anchor LineCap members.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnchorCapScale As Integer
'Usage

Dim instance As Line
Dim value As Integer

instance.AnchorCapScale = value

value = instance.AnchorCapScale
public int AnchorCapScale {get; set;}
Example
AxisCaps
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : Color Property
Color Property (Line)
Gets or sets the color of this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As Line
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : DashStyle Property
DashStyle Property (Line)
Gets or sets the System.Drawing.Drawing2D.DashStyle of this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DashStyle As DashStyle
'Usage

Dim instance As Line
Dim value As DashStyle

instance.DashStyle = value

value = instance.DashStyle
public DashStyle DashStyle {get; set;}
Example
Gallery/a43
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : EndCap Property
EndCap Property (Line)
Gets or sets the System.Drawing.Drawing2D.LineCap that ends this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndCap As LineCap
'Usage

Dim instance As Line
Dim value As LineCap

instance.EndCap = value

value = instance.EndCap
public LineCap EndCap {get; set;}
Example
AxisCaps
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : Length Property
Length Property (Line)
Gets or sets the length of this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Length As Integer
'Usage

Dim instance As Line
Dim value As Integer

instance.Length = value

value = instance.Length
public int Length {get; set;}
Remarks
Only used with the Axis.TickLine property and represents the tick line length.
Example
AxisTickOverrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : StartCap Property
StartCap Property (Line)
Gets or sets the System.Drawing.Drawing2D.LineCap that starts this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartCap As LineCap
'Usage

Dim instance As Line
Dim value As LineCap

instance.StartCap = value

value = instance.StartCap
public LineCap StartCap {get; set;}
Example
AxisCaps
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : Transparency Property
Transparency Property (Line)
Gets or sets the transparency percentage of this line (0-100) where 0 = transparent, 100 = solid.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Transparency As Integer
'Usage

Dim instance As Line
Dim value As Integer

instance.Transparency = value

value = instance.Transparency
public int Transparency {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : Visible Property
Visible Property (Line)
Gets or sets a value that indicates whether this line is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Line
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


dotnetCHARTING Namespace > Line Class : Width Property
Width Property (Line)
Gets or sets the width of this line.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Width As Integer
'Usage

Dim instance As Line
Dim value As Integer

instance.Width = value

value = instance.Width
public int Width {get; set;}
Example
AxisTickOverrides
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Line Class
Line Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ListCollection Class
ListCollection Class
A list dictionary variation that allows adding items of the string type using a string.
Object Model
ListCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ListCollection
   Inherits System.Collections.Specialized.ListDictionary
'Usage

Dim instance As ListCollection
public class ListCollection : System.Collections.Specialized.ListDictionary
Remarks

Strings used to add items use the following syntax:

"Key1=Value2,Key2=Value2"

Inheritance Hierarchy

System.Object
System.Collections.Specialized.ListDictionary
dotnetCHARTING.ListCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ListCollection Class
ListCollection Class Members

The following tables list the members exposed by ListCollection.

Public Constructors
 | Name | Description
Public Constructor | ListCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsFixedSize | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsReadOnly | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsSynchronized | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Item | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Keys | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | SyncRoot | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Values | (Inherited from System.Collections.Specialized.ListDictionary)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a single or multiple items using a string.
Public Method | Clear | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | Contains | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | CopyTo | (Inherited from System.Collections.Specialized.ListDictionary)
static (Shared in Visual Basic) | FromDictionary | Creates a ListCollection object from a ListDictionary.
Public Method | GetEnumerator | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | Remove | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | ToString |
Top
Public Operators
public Operator Implicit Type Conversion Overloaded.
Top
See Also

Reference

ListCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > ListCollection Class : ListCollection Constructor
ListCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ListCollection()
public ListCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ListCollection Class
ListCollection Class Methods

For a list of all members of this type, see ListCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a single or multiple items using a string.
Public Method | Clear | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | Contains | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | CopyTo | (Inherited from System.Collections.Specialized.ListDictionary)
static (Shared in Visual Basic) | FromDictionary | Creates a ListCollection object from a ListDictionary.
Public Method | GetEnumerator | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | Remove | (Inherited from System.Collections.Specialized.ListDictionary)
Public Method | ToString |
Top
See Also

Reference

ListCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ListCollection Class : Add Method
Add Method (ListCollection)
Adds a single or multiple items using a string.
Overload List
Overload | Description
Add(String) | Adds a single or multiple items using a string.
Add(Object,Object) | (Inherited from System.Collections.Specialized.ListDictionary)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members


dotnetCHARTING Namespace > ListCollection Class > Add Method : Add(String) Method
Add(String) Method
Adds a single or multiple items using a string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal str As String _
)
'Usage

Dim instance As ListCollection
Dim str As String

instance.Add(str)
public void Add(
   string str
)

Parameters

str
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members
Overload List


dotnetCHARTING Namespace > ListCollection Class : FromDictionary Method
ListDictionary to instantiate with.
FromDictionary Method
Creates a ListCollection object from a ListDictionary.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromDictionary( _
   ByVal ld As ListDictionary _
) As ListCollection
'Usage

Dim ld As ListDictionary
Dim value As ListCollection

value = ListCollection.FromDictionary(ld)
public static ListCollection FromDictionary(
   ListDictionary ld
)

Parameters

ld
ListDictionary to instantiate with.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members


dotnetCHARTING Namespace > ListCollection Class : ToString Method
ToString Method (ListCollection)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ListCollection
Dim value As String

value = instance.ToString()
public override string ToString()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members
Base Implementation in ToString


dotnetCHARTING Namespace > ListCollection Class : Implicit Type Conversion Operator
Implicit Type Conversion Operator (ListCollection)
Overload List
Overload | Description
Implicit Type Conversion(ListCollection,String) |
Implicit Type Conversion(String,ListCollection) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ListCollection Class
ListCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : NavigatorOptions Class
NavigatorOptions Class
Contains the definition for options that control the navigator features and behavior.
Object Model
NavigatorOptions ClassNavigatorOptions.NavigationBarOptions Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class NavigatorOptions
'Usage

Dim instance As NavigatorOptions
public class NavigatorOptions
Inheritance Hierarchy

System.Object
dotnetCHARTING.NavigatorOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : NavigatorOptions Class
NavigatorOptions Class Members

The following tables list the members exposed by NavigatorOptions.

Public Constructors
 | Name | Description
Public Constructor | NavigatorOptions Constructor |
Top
Public Properties
 | Name | Description
Public Property | AnimationDuration | Gets or sets the global animation duration in milliseconds. This applies to all animations between ranges on the x axis.
Public Property | ControlID | Gets or sets the ID of the silverlight plugin tag generated on the HTML page. Setting this property provides a reference to the silverlight plugin from within the page using JavaScript.
Public Property | DownlevelUrl | Redirect to the provided URL the end user does not have Silverlight installed. This property works with SilverlightInstall.
Public Property | EnableBrowserStatusHelp | Gets or sets a value that indicates whether the status bar displays a help messages.
Public Property | EnableCellVisualCues | Gets or sets a value that determines whether cells smaller than the axis ticks are used in the chart area axis.
Public Property | Enabled | Gets or sets a value that determines whether the navigator is enabled.
Public Property | EnableMouseTracking | Gets or sets a value that indicates whether the mouse is tracked.
Public Property | EnablePreviewAreaChart | Gets or sets a value that indicates whether an image of the first chart area shown in the preview area.
Public Property | EnableWindowlessMode | Gets or sets a value that determines whether the Navigator displays as a windowless plug-in.
Public Property | EnableXScrollbar | Gets or sets a value that determines if the horizontal scrollbar is enabled.
Public Property | GenerateImagePreview | Gets or sets a value that determines whether an image of the chart is generated on the server to display while the Navigator chart is loading.
Public Property | LoadingAnimation | Gets or sets the LoadingAnimation type that displays while the client-side chart is loading.
Public Property | LoadingTextOverride | Gets or sets single string which can have three different strings separated by a '|' character. The downloading string can contain the token "Percentage" which will be replaced with the percent downloaded when the chart is loading. The default setting isPercentage)|Loading"
Public Property | NavigationBar | Gets or sets the navigation bar settings and options.
Public Property | PreviewAreaHeight | Gets or sets a value that determines the height of the preview area in pixels.
Public Property | PreviewAreaNavigationOptons | Gets or sets the PreviewAreaNavigationOption enum flags that specify navigation options for the preview area.
Public Property | SilverlightInstall | Gets or sets the SilverlightInstall behavior when the end user does not have Silverlight installed.
Public Property | SilverlightInstallMessage | Gets or sets a message used when suggesting the Silverlight plugin installation.
Public Property | SilverlightInstallWarning | Gets or sets a message shown when the Silverlight plugin is not installed and a static chart image is used.
Public Property | ZoomLimit | Gets or sets an object that determines the zoom limit. The object can be a TimeSpan, TimeInterval, or TimeIntervalAdvanced for time scales and Number for numeric and category scales.
Top
See Also

Reference

NavigatorOptions Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > NavigatorOptions Class : NavigatorOptions Constructor
NavigatorOptions Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New NavigatorOptions()
public NavigatorOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : NavigatorOptions Class
NavigatorOptions Class Properties

For a list of all members of this type, see NavigatorOptions members.

Public Properties
 | Name | Description
Public Property | AnimationDuration | Gets or sets the global animation duration in milliseconds. This applies to all animations between ranges on the x axis.
Public Property | ControlID | Gets or sets the ID of the silverlight plugin tag generated on the HTML page. Setting this property provides a reference to the silverlight plugin from within the page using JavaScript.
Public Property | DownlevelUrl | Redirect to the provided URL the end user does not have Silverlight installed. This property works with SilverlightInstall.
Public Property | EnableBrowserStatusHelp | Gets or sets a value that indicates whether the status bar displays a help messages.
Public Property | EnableCellVisualCues | Gets or sets a value that determines whether cells smaller than the axis ticks are used in the chart area axis.
Public Property | Enabled | Gets or sets a value that determines whether the navigator is enabled.
Public Property | EnableMouseTracking | Gets or sets a value that indicates whether the mouse is tracked.
Public Property | EnablePreviewAreaChart | Gets or sets a value that indicates whether an image of the first chart area shown in the preview area.
Public Property | EnableWindowlessMode | Gets or sets a value that determines whether the Navigator displays as a windowless plug-in.
Public Property | EnableXScrollbar | Gets or sets a value that determines if the horizontal scrollbar is enabled.
Public Property | GenerateImagePreview | Gets or sets a value that determines whether an image of the chart is generated on the server to display while the Navigator chart is loading.
Public Property | LoadingAnimation | Gets or sets the LoadingAnimation type that displays while the client-side chart is loading.
Public Property | LoadingTextOverride | Gets or sets single string which can have three different strings separated by a '|' character. The downloading string can contain the token "Percentage" which will be replaced with the percent downloaded when the chart is loading. The default setting isPercentage)|Loading"
Public Property | NavigationBar | Gets or sets the navigation bar settings and options.
Public Property | PreviewAreaHeight | Gets or sets a value that determines the height of the preview area in pixels.
Public Property | PreviewAreaNavigationOptons | Gets or sets the PreviewAreaNavigationOption enum flags that specify navigation options for the preview area.
Public Property | SilverlightInstall | Gets or sets the SilverlightInstall behavior when the end user does not have Silverlight installed.
Public Property | SilverlightInstallMessage | Gets or sets a message used when suggesting the Silverlight plugin installation.
Public Property | SilverlightInstallWarning | Gets or sets a message shown when the Silverlight plugin is not installed and a static chart image is used.
Public Property | ZoomLimit | Gets or sets an object that determines the zoom limit. The object can be a TimeSpan, TimeInterval, or TimeIntervalAdvanced for time scales and Number for numeric and category scales.
Top
See Also

Reference

NavigatorOptions Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > NavigatorOptions Class : AnimationDuration Property
AnimationDuration Property
Gets or sets the global animation duration in milliseconds. This applies to all animations between ranges on the x axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AnimationDuration As Integer
'Usage

Dim instance As NavigatorOptions
Dim value As Integer

instance.AnimationDuration = value

value = instance.AnimationDuration
public int AnimationDuration {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : ControlID Property
ControlID Property (NavigatorOptions)
Gets or sets the ID of the silverlight plugin tag generated on the HTML page. Setting this property provides a reference to the silverlight plugin from within the page using JavaScript.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ControlID As String
'Usage

Dim instance As NavigatorOptions
Dim value As String

instance.ControlID = value

value = instance.ControlID
public string ControlID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : DownlevelUrl Property
DownlevelUrl Property
Redirect to the provided URL the end user does not have Silverlight installed. This property works with SilverlightInstall.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DownlevelUrl As String
'Usage

Dim instance As NavigatorOptions
Dim value As String

instance.DownlevelUrl = value

value = instance.DownlevelUrl
public string DownlevelUrl {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnableBrowserStatusHelp Property
EnableBrowserStatusHelp Property
Gets or sets a value that indicates whether the status bar displays a help messages.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableBrowserStatusHelp As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnableBrowserStatusHelp = value

value = instance.EnableBrowserStatusHelp
public bool EnableBrowserStatusHelp {get; set;}
Remarks
This may not work for some browsers by default.
For example, to enable it in IE 8, choose Internet Options > Security tab > custom level > Under Scripting > Allow status bar updates via script, choose the Enable radio button. Using the SetHelpMessageHost javascript property of the client side chart, a text box or other element can be associated with this message.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnableCellVisualCues Property
EnableCellVisualCues Property
Gets or sets a value that determines whether cells smaller than the axis ticks are used in the chart area axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableCellVisualCues As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnableCellVisualCues = value

value = instance.EnableCellVisualCues
public bool EnableCellVisualCues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : Enabled Property
Enabled Property (NavigatorOptions)
Gets or sets a value that determines whether the navigator is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnableMouseTracking Property
EnableMouseTracking Property (NavigatorOptions)
Gets or sets a value that indicates whether the mouse is tracked.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableMouseTracking As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnableMouseTracking = value

value = instance.EnableMouseTracking
public bool EnableMouseTracking {get; set;}
Remarks
The chart can track the mouse position to determine the values of data at those positions. The mouse is tracked across the chart area and preview area and the values are reported in the respective chart area legends. When hovering cells on axes, the legends will reflect calculations based on the ranges of those cells.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnablePreviewAreaChart Property
EnablePreviewAreaChart Property
Gets or sets a value that indicates whether an image of the first chart area shown in the preview area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnablePreviewAreaChart As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnablePreviewAreaChart = value

value = instance.EnablePreviewAreaChart
public bool EnablePreviewAreaChart {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnableWindowlessMode Property
EnableWindowlessMode Property
Gets or sets a value that determines whether the Navigator displays as a windowless plug-in.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableWindowlessMode As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnableWindowlessMode = value

value = instance.EnableWindowlessMode
public bool EnableWindowlessMode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : EnableXScrollbar Property
EnableXScrollbar Property
Gets or sets a value that determines if the horizontal scrollbar is enabled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableXScrollbar As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.EnableXScrollbar = value

value = instance.EnableXScrollbar
public bool EnableXScrollbar {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : GenerateImagePreview Property
GenerateImagePreview Property
Gets or sets a value that determines whether an image of the chart is generated on the server to display while the Navigator chart is loading.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GenerateImagePreview As Boolean
'Usage

Dim instance As NavigatorOptions
Dim value As Boolean

instance.GenerateImagePreview = value

value = instance.GenerateImagePreview
public bool GenerateImagePreview {get; set;}
Remarks
Generating the preview image may impact performance on the server side slightly. However, this may not be a problem for most cases unless the chart shows many elements in its initial view. Showing a preview chart while loading the Navigator will help provide a more seamless experience to the end user.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : LoadingAnimation Property
LoadingAnimation Property
Gets or sets the LoadingAnimation type that displays while the client-side chart is loading.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LoadingAnimation As LoadingAnimation
'Usage

Dim instance As NavigatorOptions
Dim value As LoadingAnimation

instance.LoadingAnimation = value

value = instance.LoadingAnimation
public LoadingAnimation LoadingAnimation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : LoadingTextOverride Property
LoadingTextOverride Property
Gets or sets single string which can have three different strings separated by a '|' character. The downloading string can contain the token "Percentage" which will be replaced with the percent downloaded when the chart is loading. The default setting isPercentage)|Loading"
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LoadingTextOverride As String
'Usage

Dim instance As NavigatorOptions
Dim value As String

instance.LoadingTextOverride = value

value = instance.LoadingTextOverride
public string LoadingTextOverride {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : NavigationBar Property
NavigationBar Property
Gets or sets the navigation bar settings and options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NavigationBar As NavigatorOptions.NavigationBarOptions
'Usage

Dim instance As NavigatorOptions
Dim value As NavigatorOptions.NavigationBarOptions

instance.NavigationBar = value

value = instance.NavigationBar
public NavigatorOptions.NavigationBarOptions NavigationBar {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : PreviewAreaHeight Property
PreviewAreaHeight Property
Gets or sets a value that determines the height of the preview area in pixels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreviewAreaHeight As Double
'Usage

Dim instance As NavigatorOptions
Dim value As Double

instance.PreviewAreaHeight = value

value = instance.PreviewAreaHeight
public double PreviewAreaHeight {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : PreviewAreaNavigationOptons Property
PreviewAreaNavigationOptons Property
Gets or sets the PreviewAreaNavigationOption enum flags that specify navigation options for the preview area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreviewAreaNavigationOptons As PreviewAreaNavigationOptions
'Usage

Dim instance As NavigatorOptions
Dim value As PreviewAreaNavigationOptions

instance.PreviewAreaNavigationOptons = value

value = instance.PreviewAreaNavigationOptons
public PreviewAreaNavigationOptions PreviewAreaNavigationOptons {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : SilverlightInstall Property
SilverlightInstall Property
Gets or sets the SilverlightInstall behavior when the end user does not have Silverlight installed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SilverlightInstall As SilverlightInstall
'Usage

Dim instance As NavigatorOptions
Dim value As SilverlightInstall

instance.SilverlightInstall = value

value = instance.SilverlightInstall
public SilverlightInstall SilverlightInstall {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : SilverlightInstallMessage Property
SilverlightInstallMessage Property
Gets or sets a message used when suggesting the Silverlight plugin installation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SilverlightInstallMessage As String
'Usage

Dim instance As NavigatorOptions
Dim value As String

instance.SilverlightInstallMessage = value

value = instance.SilverlightInstallMessage
public string SilverlightInstallMessage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : SilverlightInstallWarning Property
SilverlightInstallWarning Property
Gets or sets a message shown when the Silverlight plugin is not installed and a static chart image is used.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SilverlightInstallWarning As String
'Usage

Dim instance As NavigatorOptions
Dim value As String

instance.SilverlightInstallWarning = value

value = instance.SilverlightInstallWarning
public string SilverlightInstallWarning {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


dotnetCHARTING Namespace > NavigatorOptions Class : ZoomLimit Property
ZoomLimit Property
Gets or sets an object that determines the zoom limit. The object can be a TimeSpan, TimeInterval, or TimeIntervalAdvanced for time scales and Number for numeric and category scales.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZoomLimit As Object
'Usage

Dim instance As NavigatorOptions
Dim value As Object

instance.ZoomLimit = value

value = instance.ZoomLimit
public object ZoomLimit {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions Class
NavigatorOptions Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Class
Defines the navigation bar at the top of a navigator chart.
Object Model
NavigatorOptions.NavigationBarOptions ClassBackground ClassBoxHeaderOptions ClassLine ClassLabel ClassLine ClassShadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class NavigatorOptions.NavigationBarOptions
   Inherits Box
'Usage

Dim instance As NavigatorOptions.NavigationBarOptions
public class NavigatorOptions.NavigationBarOptions : Box
Inheritance Hierarchy

System.Object
dotnetCHARTING.Box
dotnetCHARTING.NavigatorOptions.NavigationBarOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions.NavigationBarOptions Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Class Members

The following tables list the members exposed by NavigatorOptions.NavigationBarOptions.

Public Constructors
 | Name | Description
Public Constructor | NavigatorOptions.NavigationBarOptions Constructor |
Top
Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | EnableHistory | Gets or sets a value that indicates whether the history buttons are shown.
Public Property | EnableRangeSelectors | Gets or sets a value that indicates whether the range selectors are shown.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | Label | Gets or sets the Label of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea. (Inherited from dotnetCHARTING.Box)
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object. (Inherited from dotnetCHARTING.Box)
Public Property | QuickZoomIntervals | Gets or sets a string that determines the quick zoom intervals. A value of "Auto" will make the chart generate them automatically.
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

NavigatorOptions.NavigationBarOptions Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > NavigatorOptions.NavigationBarOptions Class : NavigatorOptions.NavigationBarOptions Constructor
NavigatorOptions.NavigationBarOptions Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New NavigatorOptions.NavigationBarOptions()
public NavigatorOptions.NavigationBarOptions()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Class Properties

For a list of all members of this type, see NavigatorOptions.NavigationBarOptions members.

Public Properties
Name | Description
Public Property | Background | Gets or sets a background object used to fill the interior of this box. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomLeft | Gets or sets the bottom left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerBottomRight | Gets or sets the bottom right corner style. (Inherited from dotnetCHARTING.Box)
Public Property CornerSize

Gets or sets a value that indicates the corner size in pixels. This size is used with BoxCorner settings. This setting is limited to 0-8 pixels.

This property can also affect box header alignment behavior. Values larger than 8 will be used by headers.

(Inherited from dotnetCHARTING.Box)
Public Property | CornerTopLeft | Gets or sets the top left corner style. (Inherited from dotnetCHARTING.Box)
Public Property | CornerTopRight | Gets or sets the top right corner style. (Inherited from dotnetCHARTING.Box)
Public Property | DefaultCorner | Gets or sets the default box corner style. (Inherited from dotnetCHARTING.Box)
Public Property | EnableHistory | Gets or sets a value that indicates whether the history buttons are shown.
Public Property | EnableRangeSelectors | Gets or sets a value that indicates whether the range selectors are shown.
Public Property | Header | Gets or sets a BoxHeaderOptions object describing this boxes header options and content. (Inherited from dotnetCHARTING.Box)
Public Property | IconPath | Gets or sets the icon path of this title box. (Inherited from dotnetCHARTING.Box)
Public Property | InteriorLine | Gets or sets the interior line of this legend box. (Inherited from dotnetCHARTING.Box)
Public Property | Label | Gets or sets the Label of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Line | Gets or sets the exterior line of this box. (Inherited from dotnetCHARTING.Box)
Public Property | Orientation | Gets or sets this object's orientation around a ChartArea. (Inherited from dotnetCHARTING.Box)
Public Property | Padding | Gets or sets a value in pixels that represents the padding between objects within the box and the box walls. (Inherited from dotnetCHARTING.Box)
Public Property | Position | Gets or sets the position of this box. When using with Series.Box.Position, this property can take a Size or Rectangle object. (Inherited from dotnetCHARTING.Box)
Public Property | QuickZoomIntervals | Gets or sets a string that determines the quick zoom intervals. A value of "Auto" will make the chart generate them automatically.
Public Property | Shadow | Gets or sets the Shadow cast under this box. (Inherited from dotnetCHARTING.Box)
Public Property | Visible | Gets or sets a value that indicates whether this box is visible. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

NavigatorOptions.NavigationBarOptions Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > NavigatorOptions.NavigationBarOptions Class : EnableHistory Property
EnableHistory Property
Gets or sets a value that indicates whether the history buttons are shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableHistory As Boolean
'Usage

Dim instance As NavigatorOptions.NavigationBarOptions
Dim value As Boolean

instance.EnableHistory = value

value = instance.EnableHistory
public bool EnableHistory {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Members


dotnetCHARTING Namespace > NavigatorOptions.NavigationBarOptions Class : EnableRangeSelectors Property
EnableRangeSelectors Property
Gets or sets a value that indicates whether the range selectors are shown.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableRangeSelectors As Boolean
'Usage

Dim instance As NavigatorOptions.NavigationBarOptions
Dim value As Boolean

instance.EnableRangeSelectors = value

value = instance.EnableRangeSelectors
public bool EnableRangeSelectors {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Members


dotnetCHARTING Namespace > NavigatorOptions.NavigationBarOptions Class : QuickZoomIntervals Property
QuickZoomIntervals Property
Gets or sets a string that determines the quick zoom intervals. A value of "Auto" will make the chart generate them automatically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property QuickZoomIntervals As String
'Usage

Dim instance As NavigatorOptions.NavigationBarOptions
Dim value As String

instance.QuickZoomIntervals = value

value = instance.QuickZoomIntervals
public string QuickZoomIntervals {get; set;}
Remarks

The Quick Zoom intervals are controled by a single string which can disable the buttons, make them determined automatically, specify what intervals to use, and optionally the label text of the buttons. The buttons support localization so users in different cultures will see the appropriate day/month abbreviations.

The string takes a comma delimited list of intervals and supports custom label specification with an equal sign. Setting it to "Auto" will let the chart determine what the best buttons are.

Syntax

"[Multiplier][TimeInterval]=[Label],..."

Intervals that are larger than the axis range or smaller than the zoomLimit will be omitted.

Example

Examples

Setting | Result
"" | No buttons
"1min,30min,5h,5d" | [1min][30min][5h][5d]
"Auto" | Automatically determined based on scale range
"1d,5d=FiveDays" | [1d][FiveDays]
"1d,1m,1y,YTD=Year To Date,Max" | [1d][1m][1y][Year To Date][Max]

 Time Interval specifiers
Specifier | Meaning
ms | millisecond
s | second
min | minute
h | hour
d | day
m | month
y | year
YTD | year to date
Max | maximum
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Parameter Class
Parameter Class
Represents an SQL parameter to use with a StoredProcedure.
Object Model
Parameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Parameter
'Usage

Dim instance As Parameter
public class Parameter
Inheritance Hierarchy

System.Object
dotnetCHARTING.Parameter

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Members
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Parameter Class
Parameter Class Members

The following tables list the members exposed by Parameter.

Public Constructors
 | Name | Description
Public Constructor | Parameter Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Name | Gets or sets the parameter name.
Public Property | Type | Gets or sets the parameter's FieldType.
Public Property | Value | Gets or sets the parameter's value.
Top
See Also

Reference

Parameter Class
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property


%%PageItemTitle%%

dotnetCHARTING Namespace > Parameter Class : Parameter Constructor
Parameter Constructor
Overload List
Overload | Description
Parameter Constructor() | Initializes a new instance of the Parameter class.
Parameter Constructor(String,String,FieldType) | Initializes a new instance of the Parameter class with a name, value, and FieldType.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Parameter Class > Parameter Constructor : Parameter Constructor()
Parameter Constructor()
Initializes a new instance of the Parameter class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Parameter()
public Parameter()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Parameter Class > Parameter Constructor : Parameter Constructor(String,String,FieldType)
Name of the parameter.
Value of the parameter.
FieldType of the parameter.
Parameter Constructor(String,String,FieldType)
Initializes a new instance of the Parameter class with a name, value, and FieldType.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal pName As String, _
   ByVal pValue As String, _
   ByVal pType As FieldType _
)
'Usage

Dim pName As String
Dim pValue As String
Dim pType As FieldType

Dim instance As New Parameter(pName, pValue, pType)
public Parameter(
   string pName,
   string pValue,
   FieldType pType
)

Parameters

pName
Name of the parameter.
pValue
Value of the parameter.
pType
FieldType of the parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Parameter Class
Parameter Class Properties

For a list of all members of this type, see Parameter members.

Public Properties
 | Name | Description
Public Property | Name | Gets or sets the parameter name.
Public Property | Type | Gets or sets the parameter's FieldType.
Public Property | Value | Gets or sets the parameter's value.
Top
See Also

Reference

Parameter Class
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property
DataEngine Class
ParameterCollection Property
StoredProcedure Property


dotnetCHARTING Namespace > Parameter Class : Name Property
Name Property (Parameter)
Gets or sets the parameter name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As Parameter
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


dotnetCHARTING Namespace > Parameter Class : Type Property
Type Property (Parameter)
Gets or sets the parameter's FieldType.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As FieldType
'Usage

Dim instance As Parameter
Dim value As FieldType

instance.Type = value

value = instance.Type
public FieldType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


dotnetCHARTING Namespace > Parameter Class : Value Property
Value Property (Parameter)
Gets or sets the parameter's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Value As String
'Usage

Dim instance As Parameter
Dim value As String

instance.Value = value

value = instance.Value
public string Value {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Parameter Class
Parameter Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ParameterCollection Class
ParameterCollection Class
Contains a collection of Parameter objects.
Object Model
ParameterCollection ClassParameter Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ParameterCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ParameterCollection
public class ParameterCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ParameterCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Members
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ParameterCollection Class
ParameterCollection Class Members

The following tables list the members exposed by ParameterCollection.

Public Constructors
 | Name | Description
Public Constructor | ParameterCollection Constructor |
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified Parameter class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Parameter.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a Parameter into this collection at a specified index.
Public Method | Remove | Removes a specified Parameter from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property


%%PageItemTitle%%

dotnetCHARTING Namespace > ParameterCollection Class : ParameterCollection Constructor
ParameterCollection Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ParameterCollection()
public ParameterCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ParameterCollection Class
ParameterCollection Class Methods

For a list of all members of this type, see ParameterCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified Parameter class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Parameter.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a Parameter into this collection at a specified index.
Public Method | Remove | Removes a specified Parameter from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ParameterCollection Class
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property


dotnetCHARTING Namespace > ParameterCollection Class : Add Method
Add Method (ParameterCollection)
Adds a specified Parameter class to this collection.
Overload List
Overload | Description
Add(Parameter) | Adds a specified Parameter class to this collection.
Add(ParameterCollection) | Adds a specified ParameterCollection to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


dotnetCHARTING Namespace > ParameterCollection Class > Add Method : Add(Parameter) Method
The Parameter to add.
Add(Parameter) Method
Adds a specified Parameter class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal _Parameter As Parameter _
) As Integer
'Usage

Dim instance As ParameterCollection
Dim _Parameter As Parameter
Dim value As Integer

value = instance.Add(_Parameter)
public int Add(
   Parameter _Parameter
)

Parameters

_Parameter
The Parameter to add.

Return Value

The zero-based index of the added Parameter.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


dotnetCHARTING Namespace > ParameterCollection Class > Add Method : Add(ParameterCollection) Method
ParameterCollection to add.
Add(ParameterCollection) Method
Adds a specified ParameterCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal paramCollection As ParameterCollection _
) As Integer
'Usage

Dim instance As ParameterCollection
Dim paramCollection As ParameterCollection
Dim value As Integer

value = instance.Add(paramCollection)
public int Add(
   ParameterCollection paramCollection
)

Parameters

paramCollection
ParameterCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members
Overload List


dotnetCHARTING Namespace > ParameterCollection Class : Contains Method
The Parameter to find.
Contains Method (ParameterCollection)
Determines whether this collection contains a specified Parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal _Parameter As Parameter _
) As Boolean
'Usage

Dim instance As ParameterCollection
Dim _Parameter As Parameter
Dim value As Boolean

value = instance.Contains(_Parameter)
public bool Contains(
   Parameter _Parameter
)

Parameters

_Parameter
The Parameter to find.

Return Value

true if the specified Parameter belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


dotnetCHARTING Namespace > ParameterCollection Class : Insert Method
The zero-based index into the collection at which to insert the Parameter.
The Parameter to insert into this collection.
Insert Method (ParameterCollection)
Inserts a Parameter into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _Parameter As Parameter _
)
'Usage

Dim instance As ParameterCollection
Dim index As Integer
Dim _Parameter As Parameter

instance.Insert(index, _Parameter)
public void Insert(
   int index,
   Parameter _Parameter
)

Parameters

index
The zero-based index into the collection at which to insert the Parameter.
_Parameter
The Parameter to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


dotnetCHARTING Namespace > ParameterCollection Class : Remove Method
The Parameter to remove.
Remove Method (ParameterCollection)
Removes a specified Parameter from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal _Parameter As Parameter _
)
'Usage

Dim instance As ParameterCollection
Dim _Parameter As Parameter

instance.Remove(_Parameter)
public void Remove(
   Parameter _Parameter
)

Parameters

_Parameter
The Parameter to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ParameterCollection Class
ParameterCollection Class Properties

For a list of all members of this type, see ParameterCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

ParameterCollection Class
dotnetCHARTING Namespace
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property
DataEngine Class
ParameterCollection Property


dotnetCHARTING Namespace > ParameterCollection Class : Item Property
Item Property (ParameterCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Parameter
'Usage

Dim instance As ParameterCollection
Dim index As Integer
Dim value As Parameter

instance.Item(index) = value

value = instance.Item(index)
public Parameter this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ParameterCollection Class
ParameterCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ScaleRange Class
ScaleRange Class
Represents a value or range of values on an axis scale. Values can be numeric, DateTime, and string types.
Object Model
ScaleRange Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ScaleRange
'Usage

Dim instance As ScaleRange
public class ScaleRange
Inheritance Hierarchy

System.Object
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisMarker
dotnetCHARTING.AxisTick

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Members
dotnetCHARTING Namespace

Tutorials

Axis Scales


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ScaleRange Class
ScaleRange Class Members

The following tables list the members exposed by ScaleRange.

Public Constructors
 | Name | Description
Public Constructor | ScaleRange Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property | Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property | ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property | ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range.
Top
Public Methods
 | Name | Description
Public Method | ToString |
Top
See Also

Reference

ScaleRange Class
dotnetCHARTING Namespace

Tutorials

Axis Scales


%%PageItemTitle%%

dotnetCHARTING Namespace > ScaleRange Class : ScaleRange Constructor
ScaleRange Constructor
Overload List
Overload | Description
ScaleRange Constructor() |
ScaleRange Constructor(Object,Object) | Instantiates a ScaleRange class with a low and high value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members


%%PageItemTitle%%

dotnetCHARTING Namespace > ScaleRange Class > ScaleRange Constructor : ScaleRange Constructor()
ScaleRange Constructor()
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ScaleRange()
public ScaleRange()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > ScaleRange Class > ScaleRange Constructor : ScaleRange Constructor(Object,Object)
Low value.
High value.
ScaleRange Constructor(Object,Object)
Instantiates a ScaleRange class with a low and high value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal lowValue As Object, _
   ByVal highValue As Object _
)
'Usage

Dim lowValue As Object
Dim highValue As Object

Dim instance As New ScaleRange(lowValue, highValue)
public ScaleRange(
   object lowValue,
   object highValue
)

Parameters

lowValue
Low value.
highValue
High value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ScaleRange Class
ScaleRange Class Methods

For a list of all members of this type, see ScaleRange members.

Public Methods
 | Name | Description
Public Method | ToString |
Top
See Also

Reference

ScaleRange Class
dotnetCHARTING Namespace

Tutorials

Axis Scales


dotnetCHARTING Namespace > ScaleRange Class : ToString Method
ToString Method (ScaleRange)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As ScaleRange
Dim value As String

value = instance.ToString()
public override string ToString()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members
Base Implementation in ToString


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ScaleRange Class
ScaleRange Class Properties

For a list of all members of this type, see ScaleRange members.

Public Properties
 | Name | Description
Public Property | IncludeInAxisScale | Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Public Property | Value | Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Public Property | ValueHigh | Gets or sets the upper bounds of a numeric, DateTime, or text range.
Public Property | ValueLow | Gets or sets the lower bounds of a numeric, DateTime, or text range.
Top
See Also

Reference

ScaleRange Class
dotnetCHARTING Namespace

Tutorials

Axis Scales


dotnetCHARTING Namespace > ScaleRange Class : IncludeInAxisScale Property
IncludeInAxisScale Property
Gets or sets a value indicating whether an AxisTick or AxisMarker object using this ScaleRange will force the axis to expand it's scale to show it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property IncludeInAxisScale As Boolean
'Usage

Dim instance As ScaleRange
Dim value As Boolean

instance.IncludeInAxisScale = value

value = instance.IncludeInAxisScale
public bool IncludeInAxisScale {get; set;}
Remarks
When this option is used with a range instead of a single value. The axis maximum or minimum will snap to the outer edge of this range.
Example
AffectingRanges
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > ScaleRange Class : Value Property
Value Property (ScaleRange)
Gets or sets the numeric, DateTime, or text value of this ScaleRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property Value As Object
'Usage

Dim instance As ScaleRange
Dim value As Object

instance.Value = value

value = instance.Value
public virtual object Value {get; set;}
Remarks
When Value is specified, ValueLow and ValueHigh are both set to this value. When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members


dotnetCHARTING Namespace > ScaleRange Class : ValueHigh Property
ValueHigh Property (ScaleRange)
Gets or sets the upper bounds of a numeric, DateTime, or text range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ValueHigh As Object
'Usage

Dim instance As ScaleRange
Dim value As Object

instance.ValueHigh = value

value = instance.ValueHigh
public virtual object ValueHigh {get; set;}
Remarks
When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members


dotnetCHARTING Namespace > ScaleRange Class : ValueLow Property
ValueLow Property (ScaleRange)
Gets or sets the lower bounds of a numeric, DateTime, or text range.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overridable Property ValueLow As Object
'Usage

Dim instance As ScaleRange
Dim value As Object

instance.ValueLow = value

value = instance.ValueLow
public virtual object ValueLow {get; set;}
Remarks
When ValueLow and ValueHigh are equivalent, this AxisMarker is represented by the Line object, otherwise, Background fills the range between ValueLow and ValueHigh.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRange Class
ScaleRange Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ScaleRangeCollection Class
ScaleRangeCollection Class
Contains a collection of ScaleRange objects.
Object Model
ScaleRangeCollection ClassScaleRange Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ScaleRangeCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ScaleRangeCollection
public class ScaleRangeCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ScaleRangeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ScaleRangeCollection Class
ScaleRangeCollection Class Members

The following tables list the members exposed by ScaleRangeCollection.

Public Constructors
 | Name | Description
Public Constructor | ScaleRangeCollection Constructor | Creates a new instance of ScaleRangeCollection with the specified list of ScaleRange objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ScaleRangeCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified ScaleRange.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a ScaleRange into this collection at a specified index.
Public Method | Remove | Removes a specified ScaleRange from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ScaleRangeCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > ScaleRangeCollection Class : ScaleRangeCollection Constructor
ScaleRangeCollection Constructor
Creates a new instance of ScaleRangeCollection with the specified list of ScaleRange objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray scaleRangeList() As ScaleRange _
)
'Usage

Dim scaleRangeList() As ScaleRange

Dim instance As New ScaleRangeCollection(scaleRangeList)
public ScaleRangeCollection(
   params ScaleRange[] scaleRangeList
)

Parameters

scaleRangeList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ScaleRangeCollection Class
ScaleRangeCollection Class Methods

For a list of all members of this type, see ScaleRangeCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ScaleRangeCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified ScaleRange.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | Insert | Inserts a ScaleRange into this collection at a specified index.
Public Method | Remove | Removes a specified ScaleRange from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ScaleRangeCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ScaleRangeCollection Class : Add Method
Add Method (ScaleRangeCollection)
Adds a specified ScaleRangeCollection to this collection.
Overload List
Overload | Description
Add(ScaleRangeCollection) | Adds a specified ScaleRangeCollection to this collection.
Add(ScaleRange[]) | Adds the specified ScaleRange objects to this collection.
Add(ScaleRange) | Adds a specified ScaleRange class to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


dotnetCHARTING Namespace > ScaleRangeCollection Class > Add Method : Add(ScaleRangeCollection) Method
The ScaleRangeCollection to add.
Add(ScaleRangeCollection) Method
Adds a specified ScaleRangeCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal scaleRangeCollection As ScaleRangeCollection _
)
'Usage

Dim instance As ScaleRangeCollection
Dim scaleRangeCollection As ScaleRangeCollection

instance.Add(scaleRangeCollection)
public void Add(
   ScaleRangeCollection scaleRangeCollection
)

Parameters

scaleRangeCollection
The ScaleRangeCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members
Overload List


dotnetCHARTING Namespace > ScaleRangeCollection Class > Add Method : Add(ScaleRange[]) Method
A list of ScaleRange objects to add.
Add(ScaleRange[]) Method
Adds the specified ScaleRange objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray scaleRangeList() As ScaleRange _
)
'Usage

Dim instance As ScaleRangeCollection
Dim scaleRangeList() As ScaleRange

instance.Add(scaleRangeList)
public void Add(
   params ScaleRange[] scaleRangeList
)

Parameters

scaleRangeList
A list of ScaleRange objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members
Overload List


dotnetCHARTING Namespace > ScaleRangeCollection Class > Add Method : Add(ScaleRange) Method
The ScaleRange to add.
Add(ScaleRange) Method
Adds a specified ScaleRange class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal _ScaleRange As ScaleRange _
) As Integer
'Usage

Dim instance As ScaleRangeCollection
Dim _ScaleRange As ScaleRange
Dim value As Integer

value = instance.Add(_ScaleRange)
public int Add(
   ScaleRange _ScaleRange
)

Parameters

_ScaleRange
The ScaleRange to add.

Return Value

The zero-based index of the added ScaleRange.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members
Overload List


dotnetCHARTING Namespace > ScaleRangeCollection Class : Contains Method
The ScaleRange to find.
Contains Method (ScaleRangeCollection)
Determines whether this collection contains a specified ScaleRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal _ScaleRange As ScaleRange _
) As Boolean
'Usage

Dim instance As ScaleRangeCollection
Dim _ScaleRange As ScaleRange
Dim value As Boolean

value = instance.Contains(_ScaleRange)
public bool Contains(
   ScaleRange _ScaleRange
)

Parameters

_ScaleRange
The ScaleRange to find.

Return Value

true if the specified ScaleRange belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


dotnetCHARTING Namespace > ScaleRangeCollection Class : Insert Method
The zero-based index into the collection at which to insert the ScaleRange.
The ScaleRange to insert into this collection.
Insert Method (ScaleRangeCollection)
Inserts a ScaleRange into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal _ScaleRange As ScaleRange _
)
'Usage

Dim instance As ScaleRangeCollection
Dim index As Integer
Dim _ScaleRange As ScaleRange

instance.Insert(index, _ScaleRange)
public void Insert(
   int index,
   ScaleRange _ScaleRange
)

Parameters

index
The zero-based index into the collection at which to insert the ScaleRange.
_ScaleRange
The ScaleRange to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


dotnetCHARTING Namespace > ScaleRangeCollection Class : Remove Method
The ScaleRange to remove.
Remove Method (ScaleRangeCollection)
Removes a specified ScaleRange from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal _ScaleRange As ScaleRange _
)
'Usage

Dim instance As ScaleRangeCollection
Dim _ScaleRange As ScaleRange

instance.Remove(_ScaleRange)
public void Remove(
   ScaleRange _ScaleRange
)

Parameters

_ScaleRange
The ScaleRange to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ScaleRangeCollection Class
ScaleRangeCollection Class Properties

For a list of all members of this type, see ScaleRangeCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

ScaleRangeCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ScaleRangeCollection Class : Item Property
Item Property (ScaleRangeCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As ScaleRange
'Usage

Dim instance As ScaleRangeCollection
Dim index As Integer
Dim value As ScaleRange

instance.Item(index) = value

value = instance.Item(index)
public ScaleRange this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ScaleRangeCollection Class
ScaleRangeCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Series Class
Series Class
Encapsulates a group of elements.
Object Model
Series ClassBackground ClassBox ClassElement ClassElement ClassElement ClassElementCollection ClassElement ClassEmptyElement ClassElement ClassBox ClassElement ClassElement ClassLegendEntry ClassLine ClassParameterCollection ClassParameter ClassShapeLabelCollection ClassLabel ClassAxis ClassAxis ClassAxis Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Series
'Usage

Dim instance As Series
public class Series
Remarks
The series represents a group of elements and also:
  • Provides a mechanism for setting default properties of all elements within it.
  • Controls all series specific properties such as it's LegendEntry or 2D line dash style (if applicable).
  • Derives an element based on a Calculation performed on the elements within it.
  • Provides data manipulation methods such as sorting and trimming of it's elements.

See also: Data Model Tutorial
Inheritance Hierarchy

System.Object
dotnetCHARTING.Series

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Members
dotnetCHARTING Namespace

Tutorials

Data Model
Data Tutorials


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : Series Class
Series Class Members

The following tables list the members exposed by Series.

Public Constructors
 | Name | Description
Public Constructor | Series Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Background | Gets or sets the background object used to fill a gauge face or radar associated with this series.
Public Property | Box | Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox or ChartType.TreeMap.
Public Property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property | ConnectionString | Sets the database connection string used when dynamically obtaining charting data from a SQL statement.
Public Property | ContourCount | Gets or sets the number of contours to draw on a SeriesType.Surface.Contour series.
Public Property | Data | Gets or sets a DataTable, DataSet, DataView, XML file name, XML string, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property | DataFields | Gets or sets a value that specifies the 'database column' to 'chart data' relationship.
Public Property | DataProviderType | Specifies a database type. Defaults to OleDb (Access database).
Public Property | DefaultElement | Gets or sets the an Element object whose properties will trickle to all elements within this series.
Public Property | DefaultLeafElement | (JS Chart Only) Gets or sets element properties applied to all hierarchical leaf element in this series.
Public Property | Element | Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.
Public Property | Elements | Gets or sets a collection of Element objects associated with this series.
Public Property | EmptyElement | Gets or sets an EmptyElement object associated with this series.
Public Property | EndDate | The ending date used with SqlStatement to query filtered data from a database.
Public Property | ExcludeFromAxisRange | Gets or sets a value that indicates whether the element values of this series will affect the value axis they are plotted against.
Public Property | FirstElement | (JS Chart Only) Gets or sets element properties applied to the first element in this series.
Public Property | GaugeBorderBox | Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox.
Public Property | GaugeBorderShape | Gets or sets the GaugeBorderShape of this series used with gauges.
Public Property | GaugeLinearStyle | Gets or sets the GaugeLinearStyle used with GaugeType.Horizontal and GaugeType.Vertical.
Public Property | GaugeType | Get or sets the GaugeType used with ChartType.Gauges.
Public Property | HatchStylePalette | Gets or sets the hatch style palette used be the Elements of this series.
Public Property | HatchStylePaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property | ImageBarSyncToValue | Gets or sets a value that indicates whether repeating ImageBar templates will sync the number of times they repeat with the element's value.
Public Property | ImageBarTemplate | Gets or sets the path and file name of the image bar template used when drawing elements of this series.
Public Property | InterpolationFillFactor | Gets or sets the factor by which a surface element tile is interpolated. This property is used with SeriesTypeSurface.Surface series.
Public Property | Item | Gets or sets an Element of this Series at a specified index.
Public Property | JsID | Gets or sets the ID of this series used in JavaScript charts. By specifying this ID, the series can be referenced in JS.
Public Property | JsMap |
Public Property | LastElement | (JS Chart Only) Gets or sets element properties applied to the last element in this series.
Public Property | LegendEntry | Gets or sets the legend entry properties of this series.
Public Property | Limit | Gets or sets the limit number of elements returned for this series when data is generated.
Public Property | LimitMode | Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.
Public Property | Line | Gets or sets the line properties of this series.
Public Property | Name | Gets or sets the name of this series.
Public Property | OtherElementText | Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property | Palette | Gets or sets the palette which will be used by the Elements of this series. Note If used, legend behavior will be different.
Public Property | PaletteName | Gets or sets a Palette enumeration which indicates which static palette will be used by the Elements of this series. Note If used, legend behavior will be different.
Public Property | ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure
Public Property | Position | Gets or sets the position of this series in relation to other series when the chart is drawn.
Public Property | ShapeLabels | (JS Chart Only) A collection of labels used with gauge charts.
Public Property | ShowOther | This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.
Public Property | SplineTensionPercent | Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.
Public Property | SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property | SqlStatement | The SQL statement used to obtain the charting data.
Public Property | StartDate | The starting date used with SqlStatement to query filtered data from a database.
Public Property | StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property | TotalElements | Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.
Public Property | Type | Gets or sets the type of this series.
Public Property | Use3D | Gets or sets a value that indicates whether this surface series is drawn in 3D.
Public Property | Visible | Gets or sets a value which indicates whether the series is visible.
Public Property | XAxis | Gets or sets the x axis for this series.
Public Property | YAxis | Gets or sets the y axis for this series.
Public Property | ZAxis | Gets or sets the Z axis of this series when used with surface charts.
Top
Public Methods
Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two Series objects together.
Public Method | AddElements | Overloaded. Adds the elements of the specified series to this series.
Public Method | AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method | Calculate | Overloaded. Performs a Calculation on the current instance of this series.
Public Method | Clone
static (Shared in Visual Basic) | Divide | Overloaded. Divides the element values of the series on the left by the element values of the series on the right.
static (Shared in Visual Basic) | FromSurfaceData | Constructs a series containing surface data created from the specified value arrays.
static (Shared in Visual Basic) | FromYValues | Overloaded. Creates a named series of element with the specified y values.
Public Method | GetActiveElements | Returns a collection of active elements.
Public Method | GetDataSource | Gets a DataSource object representing this Series.
Public Method | GetElementBreadcrumbs | Overloaded.
Public Method | GetInterpolatedXValue | Calculates the interpolated X value of this series given the Y value.
Public Method | GetInterpolatedYValue | Calculates the interpolated Y value of this series given the X value.
Public Method | GetSmartPalette | Overloaded. Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration. Each element gets a different color from the specified palette.
Public Method | GetSurfaceData | Groups the time based elements by the specified time interval and returns a series with surface data. This method also populates a list of dates when can be mapped to the x axis of the chart.
Public Method | GetValueList | Gets a string containing a comma delimited list of the specified values for each element.
Public Method | GetYValueList | Gets a string containing a comma delimited list of Y values.
static (Shared in Visual Basic) | Multiply | Overloaded. Multiplies two Series objects together.
Public Method | SelectiveElementDefaults | Overloaded. Applies property settings of the specified default element to elements in this series that are outside a specified CalendarPattern and corresponding DateTime element property.
Public Method | Sort | Overloaded. Sorts the Elements based on an element value property and sort order.
Public Method | Split | Splits the elements into individual series per the specified TimeIntervalAdvanced.
Public Method | SplitByName | Overloaded. Splits a series to multiple series based on element subvalue's name.
Public Method SplitRegroup

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Public Method SplitRegroupCalculate Overloaded.

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

static (Shared in Visual Basic) | Subtract | Overloaded. Subtracts the element values of series on the right from the series on the left.
Public Method | Trim | Overloaded. Trims this series of elements leaving only the specified number of levels from the root element.
Top
Public Operators
public Operator Addition | Overloaded. Adds two Series objects together.
public Operator Division | Overloaded. Divides the element values of the series on the left by the element values of the series on the right.
public Operator Multiplication | Overloaded. Multiplies two Series objects together.
public Operator Subtraction | Overloaded. Subtracts the element values of series on the right from the series on the left.
Top
See Also

Reference

Series Class
dotnetCHARTING Namespace

Tutorials

Data Model
Data Tutorials


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class : Series Constructor
Series Constructor
Overload List
Overload | Description
Series Constructor(String,Element[]) | Initializes a new instance of the Series class with a name and the specified Elements.
Series Constructor(String,ElementCollection) | Initializes a new instance of the Series class with a name and the specified elementCollection.
Series Constructor() | Initializes a new instance of the Series class.
Series Constructor(String) | Initializes a new instance of the Series class with a name.
Series Constructor(String,SeriesType) | Initializes a new instance of the Series class with a name and SeriesType.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class > Series Constructor : Series Constructor(String,Element[])
Name of the series.
List of Element objects added to the series.
Series Constructor(String,Element[])
Initializes a new instance of the Series class with a name and the specified Elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal ParamArray elementList() As Element _
)
'Usage

Dim name As String
Dim elementList() As Element

Dim instance As New Series(name, elementList)
public Series(
   string name,
   params Element[] elementList
)

Parameters

name
Name of the series.
elementList
List of Element objects added to the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class > Series Constructor : Series Constructor(String,ElementCollection)
Name of the new series.
Collection of elements assigned to this series.
Series Constructor(String,ElementCollection)
Initializes a new instance of the Series class with a name and the specified elementCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal elementCollection As ElementCollection _
)
'Usage

Dim name As String
Dim elementCollection As ElementCollection

Dim instance As New Series(name, elementCollection)
public Series(
   string name,
   ElementCollection elementCollection
)

Parameters

name
Name of the new series.
elementCollection
Collection of elements assigned to this series.
Remarks
The ElementCollection object itself is not used by the series. The elements are copied to this series' ElementCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class > Series Constructor : Series Constructor()
Series Constructor()
Initializes a new instance of the Series class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Series()
public Series()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class > Series Constructor : Series Constructor(String)
Name of the series.
Series Constructor(String)
Initializes a new instance of the Series class with a name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String _
)
'Usage

Dim name As String

Dim instance As New Series(name)
public Series(
   string name
)

Parameters

name
Name of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > Series Class > Series Constructor : Series Constructor(String,SeriesType)
Name of the series.
Series type of the series.
Series Constructor(String,SeriesType)
Initializes a new instance of the Series class with a name and SeriesType.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal name As String, _
   ByVal seriesType As SeriesType _
)
'Usage

Dim name As String
Dim seriesType As SeriesType

Dim instance As New Series(name, seriesType)
public Series(
   string name,
   SeriesType seriesType
)

Parameters

name
Name of the series.
seriesType
Series type of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Series Class
Series Class Methods

For a list of all members of this type, see Series members.

Public Methods
Name | Description
static (Shared in Visual Basic) | Add | Overloaded. Adds two Series objects together.
Public Method | AddElements | Overloaded. Adds the elements of the specified series to this series.
Public Method | AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Public Method | Calculate | Overloaded. Performs a Calculation on the current instance of this series.
Public Method | Clone
static (Shared in Visual Basic) | Divide | Overloaded. Divides the element values of the series on the left by the element values of the series on the right.
static (Shared in Visual Basic) | FromSurfaceData | Constructs a series containing surface data created from the specified value arrays.
static (Shared in Visual Basic) | FromYValues | Overloaded. Creates a named series of element with the specified y values.
Public Method | GetActiveElements | Returns a collection of active elements.
Public Method | GetDataSource | Gets a DataSource object representing this Series.
Public Method | GetElementBreadcrumbs | Overloaded.
Public Method | GetInterpolatedXValue | Calculates the interpolated X value of this series given the Y value.
Public Method | GetInterpolatedYValue | Calculates the interpolated Y value of this series given the X value.
Public Method | GetSmartPalette | Overloaded. Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration. Each element gets a different color from the specified palette.
Public Method | GetSurfaceData | Groups the time based elements by the specified time interval and returns a series with surface data. This method also populates a list of dates when can be mapped to the x axis of the chart.
Public Method | GetValueList | Gets a string containing a comma delimited list of the specified values for each element.
Public Method | GetYValueList | Gets a string containing a comma delimited list of Y values.
static (Shared in Visual Basic) | Multiply | Overloaded. Multiplies two Series objects together.
Public Method | SelectiveElementDefaults | Overloaded. Applies property settings of the specified default element to elements in this series that are outside a specified CalendarPattern and corresponding DateTime element property.
Public Method | Sort | Overloaded. Sorts the Elements based on an element value property and sort order.
Public Method | Split | Splits the elements into individual series per the specified TimeIntervalAdvanced.
Public Method | SplitByName | Overloaded. Splits a series to multiple series based on element subvalue's name.
Public Method SplitRegroup

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Public Method SplitRegroupCalculate Overloaded.

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

static (Shared in Visual Basic) | Subtract | Overloaded. Subtracts the element values of series on the right from the series on the left.
Public Method | Trim | Overloaded. Trims this series of elements leaving only the specified number of levels from the root element.
Top
See Also

Reference

Series Class
dotnetCHARTING Namespace

Tutorials

Data Model
Data Tutorials


dotnetCHARTING Namespace > Series Class : Add Method
Add Method (Series)
Adds two Series objects together.
Overload List
Overload | Description
Add(Series,Series) | Adds two Series objects together.
Add(Double,Series) | Adds a value to all elements in the rhs series.
Add(Series,Double) | Adds a value to all elements in the rhs series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > Add Method : Add(Series,Series) Method
Left hand side Series.
Right hand side Series.
Add(Series,Series) Method
Adds two Series objects together.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Series
Dim value As Series

value = Series.Add(lhs, rhs)
public static Series Add(
   Series lhs,
   Series rhs
)

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.
Remarks
All element values such as YValue, XValue etc. are added based on element names. This means that only elements with the same name will be computed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Add Method : Add(Double,Series) Method
A double value.
A series.
Add(Double,Series) Method
Adds a value to all elements in the rhs series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Double
Dim rhs As Series
Dim value As Series

value = Series.Add(lhs, rhs)
public static Series Add(
   double lhs,
   Series rhs
)

Parameters

lhs
A double value.
rhs
A series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Add Method : Add(Series,Double) Method
A series.
A double value.
Add(Series,Double) Method
Adds a value to all elements in the rhs series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Add( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Double
Dim value As Series

value = Series.Add(lhs, rhs)
public static Series Add(
   Series lhs,
   double rhs
)

Parameters

lhs
A series.
rhs
A double value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : AddElements Method
AddElements Method
Adds the elements of the specified series to this series.
Overload List
Overload | Description
AddElements(Series) | Adds the elements of the specified series to this series.
AddElements(Element[]) | Adds the specified elements to this series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > AddElements Method : AddElements(Series) Method
Series whose elements will be added.
AddElements(Series) Method
Adds the elements of the specified series to this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddElements( _
   ByVal fromSeries As Series _
)
'Usage

Dim instance As Series
Dim fromSeries As Series

instance.AddElements(fromSeries)
public void AddElements(
   Series fromSeries
)

Parameters

fromSeries
Series whose elements will be added.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > AddElements Method : AddElements(Element[]) Method
A list of elements to add
AddElements(Element[]) Method
Adds the specified elements to this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddElements( _
   ByVal ParamArray elementList() As Element _
)
'Usage

Dim instance As Series
Dim elementList() As Element

instance.AddElements(elementList)
public void AddElements(
   params Element[] elementList
)

Parameters

elementList
A list of elements to add
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : AddParameter Method
AddParameter Method (Series)
Adds a stored procedure when to use in conjunction with StoredProcedure.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddParameter( _
   ByVal paramName As String, _
   ByVal paramValue As String, _
   ByVal paramType As FieldType _
)
'Usage

Dim instance As Series
Dim paramName As String
Dim paramValue As String
Dim paramType As FieldType

instance.AddParameter(paramName, paramValue, paramType)
public void AddParameter(
   string paramName,
   string paramValue,
   FieldType paramType
)

Parameters

paramName
paramValue
paramType
Remarks
This method is optionally used in conjunction with the StoredProcedure property to specify any number of parameters for the stored proc. A number of field types are supported. de.AddParameter("MyParameter","MyValue",FieldType.Text)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class


dotnetCHARTING Namespace > Series Class : Calculate Method
Calculate Method (Series)
Performs a Calculation on the current instance of this series.
Overload List
Overload | Description
Calculate(String,Calculation) | Performs a calculation on the current instance of this series.
Calculate(String,Calculation,ElementValue) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > Calculate Method : Calculate(String,Calculation) Method
Name of the returned element.
The calculation to perform.
Calculate(String,Calculation) Method
Performs a calculation on the current instance of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal calculation As Calculation _
) As Element
'Usage

Dim instance As Series
Dim name As String
Dim calculation As Calculation
Dim value As Element

value = instance.Calculate(name, calculation)
public Element Calculate(
   string name,
   Calculation calculation
)

Parameters

name
Name of the returned element.
calculation
The calculation to perform.

Return Value

Returns an Element object based on the specified Calculation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Calculate Method : Calculate(String,Calculation,ElementValue) Method
Name of the returned element.
Calculation to perform.
The ElementValue to store in the resulting element's SubValue collection.
Calculate(String,Calculation,ElementValue) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal name As String, _
   ByVal calculation As Calculation, _
   ByVal subValueSource As ElementValue _
) As Element
'Usage

Dim instance As Series
Dim name As String
Dim calculation As Calculation
Dim subValueSource As ElementValue
Dim value As Element

value = instance.Calculate(name, calculation, subValueSource)
public Element Calculate(
   string name,
   Calculation calculation,
   ElementValue subValueSource
)

Parameters

name
Name of the returned element.
calculation
Calculation to perform.
subValueSource
The ElementValue to store in the resulting element's SubValue collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : Clone Method
Clone Method (Series)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As Series
'Usage

Dim instance As Series
Dim value As Series

value = instance.Clone()
public Series Clone()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Divide Method
Divide Method (Series)
Divides the element values of the series on the left by the element values of the series on the right.
Overload List
Overload | Description
Divide(Series,Series) | Divides the element values of the series on the left by the element values of the series on the right.
Divide(Double,Series) | Divides the value on the left by the series on the right.
Divide(Series,Double) | Divides the series on the left by the value on the right.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > Divide Method : Divide(Series,Series) Method
Dividend series.
Divisor series.
Divide(Series,Series) Method
Divides the element values of the series on the left by the element values of the series on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Series
Dim value As Series

value = Series.Divide(lhs, rhs)
public static Series Divide(
   Series lhs,
   Series rhs
)

Parameters

lhs
Dividend series.
rhs
Divisor series.
Remarks
All element values such as YValue, XValue etc. are divided based on element names. This means that only elements with the same name will be computed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Divide Method : Divide(Double,Series) Method
Dividend number.
Divisor series.
Divide(Double,Series) Method
Divides the value on the left by the series on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Double
Dim rhs As Series
Dim value As Series

value = Series.Divide(lhs, rhs)
public static Series Divide(
   double lhs,
   Series rhs
)

Parameters

lhs
Dividend number.
rhs
Divisor series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Divide Method : Divide(Series,Double) Method
Dividend series.
Divisor number.
Divide(Series,Double) Method
Divides the series on the left by the value on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Divide( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Double
Dim value As Series

value = Series.Divide(lhs, rhs)
public static Series Divide(
   Series lhs,
   double rhs
)

Parameters

lhs
Dividend series.
rhs
Divisor number.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : FromSurfaceData Method
Series Name
X Values
Y Values
Z Values
FromSurfaceData Method
Constructs a series containing surface data created from the specified value arrays.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromSurfaceData( _
   ByVal name As String, _
   ByVal xValues() As Double, _
   ByVal yValues() As Double, _
   ByVal zValues() As Double _
) As Series
'Usage

Dim name As String
Dim xValues() As Double
Dim yValues() As Double
Dim zValues() As Double
Dim value As Series

value = Series.FromSurfaceData(name, xValues, yValues, zValues)
public static Series FromSurfaceData(
   string name,
   double[] xValues,
   double[] yValues,
   double[] zValues
)

Parameters

name
Series Name
xValues
X Values
yValues
Y Values
zValues
Z Values

Return Value

A Series that can be used on surface charts.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : FromYValues Method
FromYValues Method
Creates a named series of element with the specified y values.
Overload List
Overload | Description
FromYValues(String,Double[]) | Creates a named series of element with the specified y values.
FromYValues(Double[]) | Creates a series of element with the specified y values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Shortcuts and Efficient Code


dotnetCHARTING Namespace > Series Class > FromYValues Method : FromYValues(String,Double[]) Method
Name of resulting Series.
YValues of resulting elements.
FromYValues(String,Double[]) Method
Creates a named series of element with the specified y values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromYValues( _
   ByVal name As String, _
   ByVal ParamArray yValues() As Double _
) As Series
'Usage

Dim name As String
Dim yValues() As Double
Dim value As Series

value = Series.FromYValues(name, yValues)
public static Series FromYValues(
   string name,
   params double[] yValues
)

Parameters

name
Name of resulting Series.
yValues
YValues of resulting elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > FromYValues Method : FromYValues(Double[]) Method
YValues of resulting elements.
FromYValues(Double[]) Method
Creates a series of element with the specified y values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromYValues( _
   ByVal ParamArray yValues() As Double _
) As Series
'Usage

Dim yValues() As Double
Dim value As Series

value = Series.FromYValues(yValues)
public static Series FromYValues(
   params double[] yValues
)

Parameters

yValues
YValues of resulting elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : GetActiveElements Method
GetActiveElements Method
Returns a collection of active elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetActiveElements() As ElementCollection
'Usage

Dim instance As Series
Dim value As ElementCollection

value = instance.GetActiveElements()
public ElementCollection GetActiveElements()
Remarks
This is useful when there is some extra elements in a series like when using Splitby feature.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GetDataSource Method
GetDataSource Method (Series)
Gets a DataSource object representing this Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDataSource() As DataSource
'Usage

Dim instance As Series
Dim value As DataSource

value = instance.GetDataSource()
public DataSource GetDataSource()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GetElementBreadcrumbs Method
GetElementBreadcrumbs Method (Series)
Overload List
Overload | Description
GetElementBreadcrumbs(Int32,String,String) |
GetElementBreadcrumbs(Int32,String,String,String) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > GetElementBreadcrumbs Method : GetElementBreadcrumbs(Int32,String,String) Method
ID of the end node of the organizational chain.
Template used for each element from the root to the element with with specified ID.
Separator inserted into the resulting string between each element.
GetElementBreadcrumbs(Int32,String,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElementBreadcrumbs( _
   ByVal parentID As Integer, _
   ByVal elementTemplate As String, _
   ByVal separator As String _
) As String
'Usage

Dim instance As Series
Dim parentID As Integer
Dim elementTemplate As String
Dim separator As String
Dim value As String

value = instance.GetElementBreadcrumbs(parentID, elementTemplate, separator)
public string GetElementBreadcrumbs(
   int parentID,
   string elementTemplate,
   string separator
)

Parameters

parentID
ID of the end node of the organizational chain.
elementTemplate
Template used for each element from the root to the element with with specified ID.
separator
Separator inserted into the resulting string between each element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > GetElementBreadcrumbs Method : GetElementBreadcrumbs(Int32,String,String,String) Method
ID of the end node of the organizational chain.
Template used for each element from the root to the element with with specified ID.
Template used for the last breadcrumb. This is provided so the last element doesnt have to be linked.
Separator inserted into the resulting string between each element.
GetElementBreadcrumbs(Int32,String,String,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElementBreadcrumbs( _
   ByVal parentID As Integer, _
   ByVal elementTemplate As String, _
   ByVal lastElementTemplate As String, _
   ByVal separator As String _
) As String
'Usage

Dim instance As Series
Dim parentID As Integer
Dim elementTemplate As String
Dim lastElementTemplate As String
Dim separator As String
Dim value As String

value = instance.GetElementBreadcrumbs(parentID, elementTemplate, lastElementTemplate, separator)
public string GetElementBreadcrumbs(
   int parentID,
   string elementTemplate,
   string lastElementTemplate,
   string separator
)

Parameters

parentID
ID of the end node of the organizational chain.
elementTemplate
Template used for each element from the root to the element with with specified ID.
lastElementTemplate
Template used for the last breadcrumb. This is provided so the last element doesnt have to be linked.
separator
Separator inserted into the resulting string between each element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : GetInterpolatedXValue Method
Specified Y value. This can be either a numeric or DateTime value.
GetInterpolatedXValue Method
Calculates the interpolated X value of this series given the Y value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetInterpolatedXValue( _
   ByVal yValue As Object _
) As Object
'Usage

Dim instance As Series
Dim yValue As Object
Dim value As Object

value = instance.GetInterpolatedXValue(yValue)
public object GetInterpolatedXValue(
   object yValue
)

Parameters

yValue
Specified Y value. This can be either a numeric or DateTime value.

Return Value

Returns either a numeric or DateTime value when the provided y value is within the series range. Returns null otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class : GetInterpolatedYValue Method
Specified X value. This can be either a numeric or DateTime value.
GetInterpolatedYValue Method
Calculates the interpolated Y value of this series given the X value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetInterpolatedYValue( _
   ByVal xValue As Object _
) As Object
'Usage

Dim instance As Series
Dim xValue As Object
Dim value As Object

value = instance.GetInterpolatedYValue(xValue)
public object GetInterpolatedYValue(
   object xValue
)

Parameters

xValue
Specified X value. This can be either a numeric or DateTime value.

Return Value

Returns either a numeric or DateTime value when the provided x value is within the series range. Returns null otherwise.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class : GetSmartPalette Method
GetSmartPalette Method (Series)
Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration. Each element gets a different color from the specified palette.
Overload List
Overload | Description
GetSmartPalette(Palette) | Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration. Each element gets a different color from the specified palette.
GetSmartPalette(Color[]) | Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified array of Color objects. Each element gets a different color from the specified color array.
GetSmartPalette(ElementValue,Palette) | Generates a SmartPalette object with range colors based on the series data and specified colors. The resulting smartPalette will work on series with the same name as this series.
GetSmartPalette(ElementValue,Color[]) | Generates a SmartPalette object with range colors based on the series data and specified colors. The resulting smartPalette will work on series with the same name as this series.
Example
SmartPaletteSaving
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > GetSmartPalette Method : GetSmartPalette(Palette) Method
GetSmartPalette(Palette) Method
Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified Palette enumeration. Each element gets a different color from the specified palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal palette As Palette _
) As SmartPalette
'Usage

Dim instance As Series
Dim palette As Palette
Dim value As SmartPalette

value = instance.GetSmartPalette(palette)
public SmartPalette GetSmartPalette(
   Palette palette
)

Parameters

palette
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > GetSmartPalette Method : GetSmartPalette(Color[]) Method
GetSmartPalette(Color[]) Method
Generates a SmartPalette object that contains the names of the elements in this Series matched with the specified array of Color objects. Each element gets a different color from the specified color array.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal colors() As Color _
) As SmartPalette
'Usage

Dim instance As Series
Dim colors() As Color
Dim value As SmartPalette

value = instance.GetSmartPalette(colors)
public SmartPalette GetSmartPalette(
   Color[] colors
)

Parameters

colors
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > GetSmartPalette Method : GetSmartPalette(ElementValue,Palette) Method
ElementValue of elements in this series to base the SmartColor value ranges on.
The colors on which the smart palette will be based.
GetSmartPalette(ElementValue,Palette) Method
Generates a SmartPalette object with range colors based on the series data and specified colors. The resulting smartPalette will work on series with the same name as this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal ev As ElementValue, _
   ByVal palette As Palette _
) As SmartPalette
'Usage

Dim instance As Series
Dim ev As ElementValue
Dim palette As Palette
Dim value As SmartPalette

value = instance.GetSmartPalette(ev, palette)
public SmartPalette GetSmartPalette(
   ElementValue ev,
   Palette palette
)

Parameters

ev
ElementValue of elements in this series to base the SmartColor value ranges on.
palette
The colors on which the smart palette will be based.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > GetSmartPalette Method : GetSmartPalette(ElementValue,Color[]) Method
ElementValue of elements in this series to base the SmartColor value ranges on.
The colors on which the smart palette will be based.
GetSmartPalette(ElementValue,Color[]) Method
Generates a SmartPalette object with range colors based on the series data and specified colors. The resulting smartPalette will work on series with the same name as this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal ev As ElementValue, _
   ByVal ParamArray colors() As Color _
) As SmartPalette
'Usage

Dim instance As Series
Dim ev As ElementValue
Dim colors() As Color
Dim value As SmartPalette

value = instance.GetSmartPalette(ev, colors)
public SmartPalette GetSmartPalette(
   ElementValue ev,
   params Color[] colors
)

Parameters

ev
ElementValue of elements in this series to base the SmartColor value ranges on.
colors
The colors on which the smart palette will be based.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : GetSurfaceData Method
Date grouping for the x axis of the resulting data.
A DateTime list representing the x axis dates. The index of the array corresponds to the x axis values.
GetSurfaceData Method (Series)
Groups the time based elements by the specified time interval and returns a series with surface data. This method also populates a list of dates when can be mapped to the x axis of the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSurfaceData( _
   ByVal xGrouping As TimeIntervalAdvanced, _
   ByRef xDates As List(Of Date) _
) As Series
'Usage

Dim instance As Series
Dim xGrouping As TimeIntervalAdvanced
Dim xDates As List(Of Date)
Dim value As Series

value = instance.GetSurfaceData(xGrouping, xDates)
public Series GetSurfaceData(
   TimeIntervalAdvanced xGrouping,
   out List<DateTime> xDates
)

Parameters

xGrouping
Date grouping for the x axis of the resulting data.
xDates
A DateTime list representing the x axis dates. The index of the array corresponds to the x axis values.

Return Value

A series with surface data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GetValueList Method
The element value to get a list of.
GetValueList Method
Gets a string containing a comma delimited list of the specified values for each element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValueList( _
   ByVal ev As ElementValue _
) As String
'Usage

Dim instance As Series
Dim ev As ElementValue
Dim value As String

value = instance.GetValueList(ev)
public string GetValueList(
   ElementValue ev
)

Parameters

ev
The element value to get a list of.

Return Value

A comma delimited list of the specified values for each element.
Remarks
This method can be useful when constructing InfoGrids.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GetYValueList Method
GetYValueList Method
Gets a string containing a comma delimited list of Y values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetYValueList() As String
'Usage

Dim instance As Series
Dim value As String

value = instance.GetYValueList()
public string GetYValueList()

Return Value

A comma delimited list of Y values.
Remarks
This method can be useful when constructing InfoGrids.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Multiply Method
Multiply Method (Series)
Multiplies two Series objects together.
Overload List
Overload | Description
Multiply(Series,Series) | Multiplies two Series objects together.
Multiply(Double,Series) | Multiplies a series by a value.
Multiply(Series,Double) | Multiplies a series by a value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > Multiply Method : Multiply(Series,Series) Method
Left hand side Series.
Right hand side Series.
Multiply(Series,Series) Method
Multiplies two Series objects together.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Series
Dim value As Series

value = Series.Multiply(lhs, rhs)
public static Series Multiply(
   Series lhs,
   Series rhs
)

Parameters

lhs
Left hand side Series.
rhs
Right hand side Series.
Remarks
All element values such as YValue, XValue etc. are multiplied based on element names. This means that only elements with the same name will be computed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Multiply Method : Multiply(Double,Series) Method
Number multiplied by.
Series multiplied by.
Multiply(Double,Series) Method
Multiplies a series by a value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Double
Dim rhs As Series
Dim value As Series

value = Series.Multiply(lhs, rhs)
public static Series Multiply(
   double lhs,
   Series rhs
)

Parameters

lhs
Number multiplied by.
rhs
Series multiplied by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Multiply Method : Multiply(Series,Double) Method
Series multiplied by.
Series multiplied by.
Multiply(Series,Double) Method
Multiplies a series by a value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Multiply( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Double
Dim value As Series

value = Series.Multiply(lhs, rhs)
public static Series Multiply(
   Series lhs,
   double rhs
)

Parameters

lhs
Series multiplied by.
rhs
Series multiplied by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : SelectiveElementDefaults Method
SelectiveElementDefaults Method (Series)
Applies property settings of the specified default element to elements in this series that are outside a specified CalendarPattern and corresponding DateTime element property.
Overload List
Overload | Description
SelectiveElementDefaults(CalendarPattern,ElementValue,Element) | Applies property settings of the specified default element to elements in this series that are outside a specified CalendarPattern and corresponding DateTime element property.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series that are either outside or inside the specified CalendarPattern and corresponding DateTime element property.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) | Applies property settings of the specified default element to elements in this series that are outside the specified DateTime range and corresponding DateTime element property.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series that are either inside or outside the specified DateTime range and corresponding DateTime element property.
SelectiveElementDefaults(ScaleRange,ElementValue,Element) | Applies property settings of the specified default element to elements in this series that are either inside or outside the specified ScaleRange and corresponding DateTime element property.
SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series that are outside the specified ScaleRange and corresponding DateTime element property.
SelectiveElementDefaults(Double,Double,ElementValue,Element) | Applies property settings of the specified default element to elements in this series that are outside the specified numeric range and corresponding numeric element property.
SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series that are outside the specified numeric range and corresponding numeric element property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(CalendarPattern,ElementValue,Element) Method
CalendarPatternused to determine whether the default elements properties should be applied.
DateTime Element value property to compare against the CalendarPattern.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series that are outside a specified CalendarPattern and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As Series
Dim cp As CalendarPattern
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(cp, ev, defaultElement)
public void SelectiveElementDefaults(
   CalendarPattern cp,
   ElementValue ev,
   Element defaultElement
)

Parameters

cp
CalendarPatternused to determine whether the default elements properties should be applied.
ev
DateTime Element value property to compare against the CalendarPattern.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) Method
CalendarPattern used to determine whether the default elements properties should be applied.
DateTime Element value property to compare against the CalendarPattern.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the calendar pattern.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series that are either outside or inside the specified CalendarPattern and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim cp As CalendarPattern
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(cp, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   CalendarPattern cp,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

cp
CalendarPattern used to determine whether the default elements properties should be applied.
ev
DateTime Element value property to compare against the CalendarPattern.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the calendar pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) Method
Low value of the DateTime range.
High value of the DateTime range.
A DateTime element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series that are outside the specified DateTime range and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As Series
Dim Low As Date
Dim High As Date
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(Low, High, ev, defaultElement)
public void SelectiveElementDefaults(
   DateTime Low,
   DateTime High,
   ElementValue ev,
   Element defaultElement
)

Parameters

Low
Low value of the DateTime range.
High
High value of the DateTime range.
ev
A DateTime element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) Method
Low value of the DateTime range.
High value of the DateTime range.
A DateTime element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the DateTime range.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series that are either inside or outside the specified DateTime range and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim Low As Date
Dim High As Date
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(Low, High, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   DateTime Low,
   DateTime High,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

Low
Low value of the DateTime range.
High
High value of the DateTime range.
ev
A DateTime element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the DateTime range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(ScaleRange,ElementValue,Element) Method
Range of element values.
Element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
SelectiveElementDefaults(ScaleRange,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series that are either inside or outside the specified ScaleRange and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As Series
Dim range As ScaleRange
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(range, ev, defaultElement)
public void SelectiveElementDefaults(
   ScaleRange range,
   ElementValue ev,
   Element defaultElement
)

Parameters

range
Range of element values.
ev
Element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) Method
A scale range to compare ele
An element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series that are outside the specified ScaleRange and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim range As ScaleRange
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(range, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   ScaleRange range,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

range
A scale range to compare ele
ev
An element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(Double,Double,ElementValue,Element) Method
Low value of the numeric range.
High value of the numeric range.
A numeric element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
SelectiveElementDefaults(Double,Double,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series that are outside the specified numeric range and corresponding numeric element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As Series
Dim Low As Double
Dim High As Double
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(Low, High, ev, defaultElement)
public void SelectiveElementDefaults(
   double Low,
   double High,
   ElementValue ev,
   Element defaultElement
)

Parameters

Low
Low value of the numeric range.
High
High value of the numeric range.
ev
A numeric element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SelectiveElementDefaults Method : SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) Method
Low value of the numeric range.
High value of the numeric range.
A numeric element value property.
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series that are outside the specified numeric range and corresponding numeric element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim Low As Double
Dim High As Double
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(Low, High, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   double Low,
   double High,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

Low
Low value of the numeric range.
High
High value of the numeric range.
ev
A numeric element value property.
defaultElement
An Element object whose properties will be applied to elements in this series that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : Sort Method
Sort Method (Series)
Sorts the Elements based on an element value property and sort order.
Overload List
Overload | Description
Sort(ElementValue,String) | Sorts the Elements based on an element value property and sort order.
Sort(ElementValue,String,Int32,Int32) | Sorts the Elements based on an element property and order from the start index to the end index.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > Sort Method : Sort(ElementValue,String) Method
ElementValue to sort by.
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
Sort(ElementValue,String) Method
Sorts the Elements based on an element value property and sort order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String _
)
'Usage

Dim instance As Series
Dim ev As ElementValue
Dim order As String

instance.Sort(ev, order)
public void Sort(
   ElementValue ev,
   string order
)

Parameters

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Sort Method : Sort(ElementValue,String,Int32,Int32) Method
ElementValue to sort by.
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
Index at which sorting starts.
Index at which sorting stops.
Sort(ElementValue,String,Int32,Int32) Method
Sorts the Elements based on an element property and order from the start index to the end index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String, _
   ByVal startIndex As Integer, _
   ByVal endIndex As Integer _
)
'Usage

Dim instance As Series
Dim ev As ElementValue
Dim order As String
Dim startIndex As Integer
Dim endIndex As Integer

instance.Sort(ev, order, startIndex, endIndex)
public void Sort(
   ElementValue ev,
   string order,
   int startIndex,
   int endIndex
)

Parameters

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
startIndex
Index at which sorting starts.
endIndex
Index at which sorting stops.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : Split(TimeIntervalAdvanced) Method
The TimeIntervalAdvanced that specifies the split intervals.
Split(TimeIntervalAdvanced) Method
Splits the elements into individual series per the specified TimeIntervalAdvanced.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Split( _
   ByVal tia As TimeIntervalAdvanced _
) As SeriesCollection
'Usage

Dim instance As Series
Dim tia As TimeIntervalAdvanced
Dim value As SeriesCollection

value = instance.Split(tia)
public SeriesCollection Split(
   TimeIntervalAdvanced tia
)

Parameters

tia
The TimeIntervalAdvanced that specifies the split intervals.
Remarks
The splitting is based on the element's XDateTime property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : SplitByName Method
SplitByName Method
Splits a series to multiple series based on element subvalue's name.
Overload List
Overload | Description
SplitByName(String) | Splits a series to multiple series based on element subvalue's name.
SplitByName(String,LimitMode) | Splits a series to multiple series based on element subvalue's name.
SplitByName(String,LimitMode,Boolean) | Splits a series to multiple series based on element subvalue's name.
SplitByName(String,LimitMode,Boolean,String) | Splits a series to multiple series based on element subvalue's name.
SplitByName() | Splits a series to multiple series based on element subvalue's name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > SplitByName Method : SplitByName(String) Method
Determine the number of series created.SplitByLimit Property
SplitByName(String) Method
Splits a series to multiple series based on element subvalue's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitByName( _
   ByVal splitByLimit As String _
) As SeriesCollection
'Usage

Dim instance As Series
Dim splitByLimit As String
Dim value As SeriesCollection

value = instance.SplitByName(splitByLimit)
public SeriesCollection SplitByName(
   string splitByLimit
)

Parameters

splitByLimit
Determine the number of series created.SplitByLimit Property
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property
SplitByLimit Property


dotnetCHARTING Namespace > Series Class > SplitByName Method : SplitByName(String,LimitMode) Method
Determine the number of series created.SplitByLimit Property
Determine the type of limitation. Default is Top.LimitMode Property
SplitByName(String,LimitMode) Method
Splits a series to multiple series based on element subvalue's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitByName( _
   ByVal splitByLimit As String, _
   ByVal limitMode As LimitMode _
) As SeriesCollection
'Usage

Dim instance As Series
Dim splitByLimit As String
Dim limitMode As LimitMode
Dim value As SeriesCollection

value = instance.SplitByName(splitByLimit, limitMode)
public SeriesCollection SplitByName(
   string splitByLimit,
   LimitMode limitMode
)

Parameters

splitByLimit
Determine the number of series created.SplitByLimit Property
limitMode
Determine the type of limitation. Default is Top.LimitMode Property
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property
SplitByLimit Property
LimitMode Property


dotnetCHARTING Namespace > Series Class > SplitByName Method : SplitByName(String,LimitMode,Boolean) Method
Determine the number of series created.SplitByLimit Property
Determine the type of limitation. Default is Top.LimitMode Property
Determine whether the additional series are aggregated into a single series or not.ShowOther Property
SplitByName(String,LimitMode,Boolean) Method
Splits a series to multiple series based on element subvalue's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitByName( _
   ByVal splitByLimit As String, _
   ByVal limitMode As LimitMode, _
   ByVal showOther As Boolean _
) As SeriesCollection
'Usage

Dim instance As Series
Dim splitByLimit As String
Dim limitMode As LimitMode
Dim showOther As Boolean
Dim value As SeriesCollection

value = instance.SplitByName(splitByLimit, limitMode, showOther)
public SeriesCollection SplitByName(
   string splitByLimit,
   LimitMode limitMode,
   bool showOther
)

Parameters

splitByLimit
Determine the number of series created.SplitByLimit Property
limitMode
Determine the type of limitation. Default is Top.LimitMode Property
showOther
Determine whether the additional series are aggregated into a single series or not.ShowOther Property
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property
SplitByLimit Property
LimitMode Property
ShowOther Property


dotnetCHARTING Namespace > Series Class > SplitByName Method : SplitByName(String,LimitMode,Boolean,String) Method
Determine the number of series created.SplitByLimit Property
Determine the type of limitation. Default is Top.LimitMode Property
Determine whether the additional series are aggregated into a single series or not.ShowOther Property
Set the label used for the series created.OtherElementLabel Property
SplitByName(String,LimitMode,Boolean,String) Method
Splits a series to multiple series based on element subvalue's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitByName( _
   ByVal splitByLimit As String, _
   ByVal limitMode As LimitMode, _
   ByVal showOther As Boolean, _
   ByVal otherLable As String _
) As SeriesCollection
'Usage

Dim instance As Series
Dim splitByLimit As String
Dim limitMode As LimitMode
Dim showOther As Boolean
Dim otherLable As String
Dim value As SeriesCollection

value = instance.SplitByName(splitByLimit, limitMode, showOther, otherLable)
public SeriesCollection SplitByName(
   string splitByLimit,
   LimitMode limitMode,
   bool showOther,
   string otherLable
)

Parameters

splitByLimit
Determine the number of series created.SplitByLimit Property
limitMode
Determine the type of limitation. Default is Top.LimitMode Property
showOther
Determine whether the additional series are aggregated into a single series or not.ShowOther Property
otherLable
Set the label used for the series created.OtherElementLabel Property
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property
SplitByLimit Property
LimitMode Property
ShowOther Property
OtherElementLabel Property


dotnetCHARTING Namespace > Series Class > SplitByName Method : SplitByName() Method
SplitByName() Method
Splits a series to multiple series based on element subvalue's name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitByName() As SeriesCollection
'Usage

Dim instance As Series
Dim value As SeriesCollection

value = instance.SplitByName()
public SeriesCollection SplitByName()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : SplitRegroup(TimeIntervalAdvanced,TimeIntervalAdvanced) Method
SplitRegroup(TimeIntervalAdvanced,TimeIntervalAdvanced) Method

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Function SplitRegroup( _
   ByVal firstSplit As TimeIntervalAdvanced, _
   ByVal secondSplit As TimeIntervalAdvanced _
) As SeriesCollection
'Usage

Dim instance As Series
Dim firstSplit As TimeIntervalAdvanced
Dim secondSplit As TimeIntervalAdvanced
Dim value As SeriesCollection

value = instance.SplitRegroup(firstSplit, secondSplit)
public SeriesCollection SplitRegroup(
   TimeIntervalAdvanced firstSplit,
   TimeIntervalAdvanced secondSplit
)

Parameters

firstSplit
secondSplit
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : SplitRegroupCalculate Method
SplitRegroupCalculate Method

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Overload List
Overload Description
SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation)

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,Boolean)

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,TimeIntervalAdvanced)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > SplitRegroupCalculate Method : SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation) Method
First split of the data.
Second split used to group results from the first split.
Calculation performed on elements when grouped by the second split into a single element.
SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation) Method

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitRegroupCalculate( _
   ByVal firstSplit As TimeIntervalAdvanced, _
   ByVal secondSplit As TimeIntervalAdvanced, _
   ByVal calculation As Calculation _
) As Series
'Usage

Dim instance As Series
Dim firstSplit As TimeIntervalAdvanced
Dim secondSplit As TimeIntervalAdvanced
Dim calculation As Calculation
Dim value As Series

value = instance.SplitRegroupCalculate(firstSplit, secondSplit, calculation)
public Series SplitRegroupCalculate(
   TimeIntervalAdvanced firstSplit,
   TimeIntervalAdvanced secondSplit,
   Calculation calculation
)

Parameters

firstSplit
First split of the data.
secondSplit
Second split used to group results from the first split.
calculation
Calculation performed on elements when grouped by the second split into a single element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SplitRegroupCalculate Method : SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,Boolean) Method
First split of the data.
Second split used to group results from the first split.
Calculation performed on elements when grouped by the second split into a single element.
Providing a format string will evaluate the grouped element's xDateTime based on this format string and it will become the resulting element's name.
If true, the values from the elements that are grouped into a single element will propagate into the new element as subvalues.
SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,Boolean) Method

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitRegroupCalculate( _
   ByVal firstSplit As TimeIntervalAdvanced, _
   ByVal secondSplit As TimeIntervalAdvanced, _
   ByVal calculation As Calculation, _
   ByVal elementNameFormatString As String, _
   ByVal popuulateSubValues As Boolean _
) As Series
'Usage

Dim instance As Series
Dim firstSplit As TimeIntervalAdvanced
Dim secondSplit As TimeIntervalAdvanced
Dim calculation As Calculation
Dim elementNameFormatString As String
Dim popuulateSubValues As Boolean
Dim value As Series

value = instance.SplitRegroupCalculate(firstSplit, secondSplit, calculation, elementNameFormatString, popuulateSubValues)
public Series SplitRegroupCalculate(
   TimeIntervalAdvanced firstSplit,
   TimeIntervalAdvanced secondSplit,
   Calculation calculation,
   string elementNameFormatString,
   bool popuulateSubValues
)

Parameters

firstSplit
First split of the data.
secondSplit
Second split used to group results from the first split.
calculation
Calculation performed on elements when grouped by the second split into a single element.
elementNameFormatString
Providing a format string will evaluate the grouped element's xDateTime based on this format string and it will become the resulting element's name.
popuulateSubValues
If true, the values from the elements that are grouped into a single element will propagate into the new element as subvalues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > SplitRegroupCalculate Method : SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,TimeIntervalAdvanced) Method
First split of the data.
Second split used to group results from the first split.
Calculation performed on elements when grouped by the second split into a single element.
Providing a format string will evaluate the grouped element's xDateTime based on this format string and it will become the resulting element's name.
The elements that are grouped to make up the resulting elements can be grouped by a time interval and added as subValues for each resulting element.
SplitRegroupCalculate(TimeIntervalAdvanced,TimeIntervalAdvanced,Calculation,String,TimeIntervalAdvanced) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SplitRegroupCalculate( _
   ByVal firstSplit As TimeIntervalAdvanced, _
   ByVal secondSplit As TimeIntervalAdvanced, _
   ByVal calculation As Calculation, _
   ByVal elementNameFormatString As String, _
   ByVal subValuesDateGrouping As TimeIntervalAdvanced _
) As Series
'Usage

Dim instance As Series
Dim firstSplit As TimeIntervalAdvanced
Dim secondSplit As TimeIntervalAdvanced
Dim calculation As Calculation
Dim elementNameFormatString As String
Dim subValuesDateGrouping As TimeIntervalAdvanced
Dim value As Series

value = instance.SplitRegroupCalculate(firstSplit, secondSplit, calculation, elementNameFormatString, subValuesDateGrouping)
public Series SplitRegroupCalculate(
   TimeIntervalAdvanced firstSplit,
   TimeIntervalAdvanced secondSplit,
   Calculation calculation,
   string elementNameFormatString,
   TimeIntervalAdvanced subValuesDateGrouping
)

Parameters

firstSplit
First split of the data.
secondSplit
Second split used to group results from the first split.
calculation
Calculation performed on elements when grouped by the second split into a single element.
elementNameFormatString
Providing a format string will evaluate the grouped element's xDateTime based on this format string and it will become the resulting element's name.
subValuesDateGrouping
The elements that are grouped to make up the resulting elements can be grouped by a time interval and added as subValues for each resulting element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : Subtract Method
Subtract Method (Series)
Subtracts the element values of series on the right from the series on the left.
Overload List
Overload | Description
Subtract(Series,Series) | Subtracts the element values of series on the right from the series on the left.
Subtract(Double,Series) | Subtracts all element values from the left hand side number.
Subtract(Series,Double) | Subtracts the number on the right hand side from the element values of the series on the left.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class > Subtract Method : Subtract(Series,Series) Method
Series subtracted from.
Series subtracted by.
Subtract(Series,Series) Method
Subtracts the element values of series on the right from the series on the left.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Series
Dim value As Series

value = Series.Subtract(lhs, rhs)
public static Series Subtract(
   Series lhs,
   Series rhs
)

Parameters

lhs
Series subtracted from.
rhs
Series subtracted by.
Remarks
All element values such as YValue, XValue etc. are subtracted based on element names. This means that only elements with the same name will be computed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Subtract Method : Subtract(Double,Series) Method
Number subtracted from.
Series subtracted by.
Subtract(Double,Series) Method
Subtracts all element values from the left hand side number.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series
'Usage

Dim lhs As Double
Dim rhs As Series
Dim value As Series

value = Series.Subtract(lhs, rhs)
public static Series Subtract(
   double lhs,
   Series rhs
)

Parameters

lhs
Number subtracted from.
rhs
Series subtracted by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Subtract Method : Subtract(Series,Double) Method
Series subtracted from.
Number subtracted by.
Subtract(Series,Double) Method
Subtracts the number on the right hand side from the element values of the series on the left.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Subtract( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series
'Usage

Dim lhs As Series
Dim rhs As Double
Dim value As Series

value = Series.Subtract(lhs, rhs)
public static Series Subtract(
   Series lhs,
   double rhs
)

Parameters

lhs
Series subtracted from.
rhs
Number subtracted by.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class : Trim Method
Trim Method (Series)
Trims this series of elements leaving only the specified number of levels from the root element.
Overload List
Overload | Description
Trim(String,Boolean) |
Trim(Int32) | Trims this series of elements leaving only the specified number of levels from the root element.
Trim(Int32,Int32) |
Trim(Int32,Int32,Boolean) |
Trim(Element,Int32) |
Trim(Element,Int32,Boolean) |
Trim(Double,Double,ElementValue,Boolean) | Trims elements out of this series either within or ourside the specified numeric range and element property.
Trim(Double,Double,ElementValue) | Trims the elements ourside the specified numeric range and element property. dotnetCHARTING.ScaleRange.
Trim(ScaleRange,ElementValue,Boolean) | Trims the elements either within or ourside the specified values. dotnetCHARTING.ScaleRange.
Trim(ScaleRange,ElementValue) | Trims elements out of this series based on a specified CalendarPattern and element property.
Trim(DateTime,DateTime,ElementValue,Boolean) | Trims elements out of this series either within or ourside the specified time range and element property.
Trim(DateTime,DateTime,ElementValue) | Trims elements out of this series based on a specified CalendarPattern and element property.
Trim(CalendarPattern,ElementValue,Boolean) | Trims elements out of this series either within or ourside the specified CalendarPattern and element property.
Trim(CalendarPattern,ElementValue) | Trims elements out of this series outside a specified CalendarPattern and element property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(String,Boolean) Method
A comma delimited list of node IDs that are expanded.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(String,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentIDList As String, _
   ByVal addAttributes As Boolean _
) As Series
'Usage

Dim instance As Series
Dim parentIDList As String
Dim addAttributes As Boolean
Dim value As Series

value = instance.Trim(parentIDList, addAttributes)
public Series Trim(
   string parentIDList,
   bool addAttributes
)

Parameters

parentIDList
A comma delimited list of node IDs that are expanded.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Int32) Method
Number of levels of children from the root element to return in the resulting series.
Trim(Int32) Method
Trims this series of elements leaving only the specified number of levels from the root element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal visibleLevels As Integer _
) As Series
'Usage

Dim instance As Series
Dim visibleLevels As Integer
Dim value As Series

value = instance.Trim(visibleLevels)
public Series Trim(
   int visibleLevels
)

Parameters

visibleLevels
Number of levels of children from the root element to return in the resulting series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Int32,Int32) Method
ID of the root element in the resulting series.
Number of levels of children from the root element to return in the resulting series.
Trim(Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentID As Integer, _
   ByVal visibleLevels As Integer _
) As Series
'Usage

Dim instance As Series
Dim parentID As Integer
Dim visibleLevels As Integer
Dim value As Series

value = instance.Trim(parentID, visibleLevels)
public Series Trim(
   int parentID,
   int visibleLevels
)

Parameters

parentID
ID of the root element in the resulting series.
visibleLevels
Number of levels of children from the root element to return in the resulting series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Int32,Int32,Boolean) Method
ID of the root element in the resulting series.
Number of levels of children from the root element to return in the resulting series.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(Int32,Int32,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentID As Integer, _
   ByVal visibleLevels As Integer, _
   ByVal addAttributes As Boolean _
) As Series
'Usage

Dim instance As Series
Dim parentID As Integer
Dim visibleLevels As Integer
Dim addAttributes As Boolean
Dim value As Series

value = instance.Trim(parentID, visibleLevels, addAttributes)
public Series Trim(
   int parentID,
   int visibleLevels,
   bool addAttributes
)

Parameters

parentID
ID of the root element in the resulting series.
visibleLevels
Number of levels of children from the root element to return in the resulting series.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Element,Int32) Method
The root element of the resulting series.
Number of levels of children from the root element to return in the resulting series.
Trim(Element,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parent As Element, _
   ByVal visibleLevels As Integer _
) As Series
'Usage

Dim instance As Series
Dim parent As Element
Dim visibleLevels As Integer
Dim value As Series

value = instance.Trim(parent, visibleLevels)
public Series Trim(
   Element parent,
   int visibleLevels
)

Parameters

parent
The root element of the resulting series.
visibleLevels
Number of levels of children from the root element to return in the resulting series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Element,Int32,Boolean) Method
The root element of the resulting series.
Number of levels of children from the root element to return in the resulting series.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(Element,Int32,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parent As Element, _
   ByVal visibleLevels As Integer, _
   ByVal addAttributes As Boolean _
) As Series
'Usage

Dim instance As Series
Dim parent As Element
Dim visibleLevels As Integer
Dim addAttributes As Boolean
Dim value As Series

value = instance.Trim(parent, visibleLevels, addAttributes)
public Series Trim(
   Element parent,
   int visibleLevels,
   bool addAttributes
)

Parameters

parent
The root element of the resulting series.
visibleLevels
Number of levels of children from the root element to return in the resulting series.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Double,Double,ElementValue,Boolean) Method
Numeric minimum of the range.
Numeric maximum of the range.
The ElementValue the range is compared to.
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Trim(Double,Double,ElementValue,Boolean) Method
Trims elements out of this series either within or ourside the specified numeric range and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim Low As Double
Dim High As Double
Dim ev As ElementValue
Dim inclusive As Boolean

instance.Trim(Low, High, ev, inclusive)
public void Trim(
   double Low,
   double High,
   ElementValue ev,
   bool inclusive
)

Parameters

Low
Numeric minimum of the range.
High
Numeric maximum of the range.
ev
The ElementValue the range is compared to.
inclusive
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Remarks
The ElementValue specified must be a numeric value property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(Double,Double,ElementValue) Method
Numeric minimum of the range.
Numeric maximum of the range.
The ElementValue the range is compared to.
Trim(Double,Double,ElementValue) Method
Trims the elements ourside the specified numeric range and element property. dotnetCHARTING.ScaleRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue _
)
'Usage

Dim instance As Series
Dim Low As Double
Dim High As Double
Dim ev As ElementValue

instance.Trim(Low, High, ev)
public void Trim(
   double Low,
   double High,
   ElementValue ev
)

Parameters

Low
Numeric minimum of the range.
High
Numeric maximum of the range.
ev
The ElementValue the range is compared to.
Remarks
The ElementValue specified must be a numeric value property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(ScaleRange,ElementValue,Boolean) Method
Range of element values to trim.
The ElementValue the range is compared to.
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Trim(ScaleRange,ElementValue,Boolean) Method
Trims the elements either within or ourside the specified values. dotnetCHARTING.ScaleRange.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim range As ScaleRange
Dim ev As ElementValue
Dim inclusive As Boolean

instance.Trim(range, ev, inclusive)
public void Trim(
   ScaleRange range,
   ElementValue ev,
   bool inclusive
)

Parameters

range
Range of element values to trim.
ev
The ElementValue the range is compared to.
inclusive
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(ScaleRange,ElementValue) Method
Range of element values to trim.
ElementValue to match against the calendar pattern.
Trim(ScaleRange,ElementValue) Method
Trims elements out of this series based on a specified CalendarPattern and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue _
)
'Usage

Dim instance As Series
Dim range As ScaleRange
Dim ev As ElementValue

instance.Trim(range, ev)
public void Trim(
   ScaleRange range,
   ElementValue ev
)

Parameters

range
Range of element values to trim.
ev
ElementValue to match against the calendar pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(DateTime,DateTime,ElementValue,Boolean) Method
System.DateTime minimum of the range.
System.DateTime maximum of the range.
The ElementValue the range is compared to.
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Trim(DateTime,DateTime,ElementValue,Boolean) Method
Trims elements out of this series either within or ourside the specified time range and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim Low As Date
Dim High As Date
Dim ev As ElementValue
Dim inclusive As Boolean

instance.Trim(Low, High, ev, inclusive)
public void Trim(
   DateTime Low,
   DateTime High,
   ElementValue ev,
   bool inclusive
)

Parameters

Low
System.DateTime minimum of the range.
High
System.DateTime maximum of the range.
ev
The ElementValue the range is compared to.
inclusive
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Remarks
The ElementValue specified must be a System.DateTime property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(DateTime,DateTime,ElementValue) Method
System.DateTime minimum of the range.
System.DateTime maximum of the range.
The ElementValue the date range is compared to.
Trim(DateTime,DateTime,ElementValue) Method
Trims elements out of this series based on a specified CalendarPattern and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue _
)
'Usage

Dim instance As Series
Dim Low As Date
Dim High As Date
Dim ev As ElementValue

instance.Trim(Low, High, ev)
public void Trim(
   DateTime Low,
   DateTime High,
   ElementValue ev
)

Parameters

Low
System.DateTime minimum of the range.
High
System.DateTime maximum of the range.
ev
The ElementValue the date range is compared to.
Remarks
The ElementValue specified must be a DateTime value property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(CalendarPattern,ElementValue,Boolean) Method
CalendarPattern used to trim the series.
ElementValue to match against the calendar pattern.
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Trim(CalendarPattern,ElementValue,Boolean) Method
Trims elements out of this series either within or ourside the specified CalendarPattern and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As Series
Dim cp As CalendarPattern
Dim ev As ElementValue
Dim inclusive As Boolean

instance.Trim(cp, ev, inclusive)
public void Trim(
   CalendarPattern cp,
   ElementValue ev,
   bool inclusive
)

Parameters

cp
CalendarPattern used to trim the series.
ev
ElementValue to match against the calendar pattern.
inclusive
Whether to trim elements within or outside the specified range. False by default (trims outside the range when calling the method without the inclusive parameter or when set to false.
Remarks
The ElementValue specified must be a System.DateTime property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


dotnetCHARTING Namespace > Series Class > Trim Method : Trim(CalendarPattern,ElementValue) Method
CalendarPattern used to trim the series.
ElementValue to match against the calendar pattern.
Trim(CalendarPattern,ElementValue) Method
Trims elements out of this series outside a specified CalendarPattern and element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Trim( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue _
)
'Usage

Dim instance As Series
Dim cp As CalendarPattern
Dim ev As ElementValue

instance.Trim(cp, ev)
public void Trim(
   CalendarPattern cp,
   ElementValue ev
)

Parameters

cp
CalendarPattern used to trim the series.
ev
ElementValue to match against the calendar pattern.
Remarks
The ElementValue specified must be a System.DateTime property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Series Class
Series Class Properties

For a list of all members of this type, see Series members.

Public Properties
 | Name | Description
Public Property | Background | Gets or sets the background object used to fill a gauge face or radar associated with this series.
Public Property | Box | Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox or ChartType.TreeMap.
Public Property | CommandTimeout | Gets or sets the wait time before terminating the attempt to execute a command and generating an error.
Public Property | ConnectionString | Sets the database connection string used when dynamically obtaining charting data from a SQL statement.
Public Property | ContourCount | Gets or sets the number of contours to draw on a SeriesType.Surface.Contour series.
Public Property | Data | Gets or sets a DataTable, DataSet, DataView, XML file name, XML string, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Public Property | DataFields | Gets or sets a value that specifies the 'database column' to 'chart data' relationship.
Public Property | DataProviderType | Specifies a database type. Defaults to OleDb (Access database).
Public Property | DefaultElement | Gets or sets the an Element object whose properties will trickle to all elements within this series.
Public Property | DefaultLeafElement | (JS Chart Only) Gets or sets element properties applied to all hierarchical leaf element in this series.
Public Property | Element | Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.
Public Property | Elements | Gets or sets a collection of Element objects associated with this series.
Public Property | EmptyElement | Gets or sets an EmptyElement object associated with this series.
Public Property | EndDate | The ending date used with SqlStatement to query filtered data from a database.
Public Property | ExcludeFromAxisRange | Gets or sets a value that indicates whether the element values of this series will affect the value axis they are plotted against.
Public Property | FirstElement | (JS Chart Only) Gets or sets element properties applied to the first element in this series.
Public Property | GaugeBorderBox | Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox.
Public Property | GaugeBorderShape | Gets or sets the GaugeBorderShape of this series used with gauges.
Public Property | GaugeLinearStyle | Gets or sets the GaugeLinearStyle used with GaugeType.Horizontal and GaugeType.Vertical.
Public Property | GaugeType | Get or sets the GaugeType used with ChartType.Gauges.
Public Property | HatchStylePalette | Gets or sets the hatch style palette used be the Elements of this series.
Public Property | HatchStylePaletteName | Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series. Note If used, legend behavior will be different.
Public Property | ImageBarSyncToValue | Gets or sets a value that indicates whether repeating ImageBar templates will sync the number of times they repeat with the element's value.
Public Property | ImageBarTemplate | Gets or sets the path and file name of the image bar template used when drawing elements of this series.
Public Property | InterpolationFillFactor | Gets or sets the factor by which a surface element tile is interpolated. This property is used with SeriesTypeSurface.Surface series.
Public Property | Item | Gets or sets an Element of this Series at a specified index.
Public Property | JsID | Gets or sets the ID of this series used in JavaScript charts. By specifying this ID, the series can be referenced in JS.
Public Property | JsMap |
Public Property | LastElement | (JS Chart Only) Gets or sets element properties applied to the last element in this series.
Public Property | LegendEntry | Gets or sets the legend entry properties of this series.
Public Property | Limit | Gets or sets the limit number of elements returned for this series when data is generated.
Public Property | LimitMode | Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.
Public Property | Line | Gets or sets the line properties of this series.
Public Property | Name | Gets or sets the name of this series.
Public Property | OtherElementText | Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.
Public Property | Palette | Gets or sets the palette which will be used by the Elements of this series. Note If used, legend behavior will be different.
Public Property | PaletteName | Gets or sets a Palette enumeration which indicates which static palette will be used by the Elements of this series. Note If used, legend behavior will be different.
Public Property | ParameterCollection | Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure
Public Property | Position | Gets or sets the position of this series in relation to other series when the chart is drawn.
Public Property | ShapeLabels | (JS Chart Only) A collection of labels used with gauge charts.
Public Property | ShowOther | This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.
Public Property | SplineTensionPercent | Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.
Public Property | SplitByLimit | Gets or sets the number of series created using SplitBy.
Public Property | SqlStatement | The SQL statement used to obtain the charting data.
Public Property | StartDate | The starting date used with SqlStatement to query filtered data from a database.
Public Property | StoredProcedure | This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Public Property | TotalElements | Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.
Public Property | Type | Gets or sets the type of this series.
Public Property | Use3D | Gets or sets a value that indicates whether this surface series is drawn in 3D.
Public Property | Visible | Gets or sets a value which indicates whether the series is visible.
Public Property | XAxis | Gets or sets the x axis for this series.
Public Property | YAxis | Gets or sets the y axis for this series.
Public Property | ZAxis | Gets or sets the Z axis of this series when used with surface charts.
Top
See Also

Reference

Series Class
dotnetCHARTING Namespace

Tutorials

Data Model
Data Tutorials


dotnetCHARTING Namespace > Series Class : Background Property
Background Property (Series)
Gets or sets the background object used to fill a gauge face or radar associated with this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As Series
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Remarks
When using ChartType.Radar (single radar) use Chart.DefaultSeries.Background to control the radar background.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Box Property
Box Property (Series)
Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox or ChartType.TreeMap.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Box As Box
'Usage

Dim instance As Series
Dim value As Box

instance.Box = value

value = instance.Box
public Box Box {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : CommandTimeout Property
CommandTimeout Property (Series)

Gets or sets the wait time before terminating the attempt to execute a command and generating an error.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property CommandTimeout As Integer
'Usage

Dim instance As Series
Dim value As Integer

instance.CommandTimeout = value

value = instance.CommandTimeout
public int CommandTimeout {get; set;}
Example
The follwoing example set the command timeout to 45 seconds.
  • C#
Chart.Series.CommandTimeout=45;
  • Visual Basic
Chart.Series.CommandTimeout=45
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
CommandTimeout Property


Example

dotnetCHARTING Namespace > Series Class : ConnectionString Property
ConnectionString Property (Series)
Sets the database connection string used when dynamically obtaining charting data from a SQL statement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ConnectionString As String
'Usage

Dim instance As Series
Dim value As String

instance.ConnectionString = value

value = instance.ConnectionString
public string ConnectionString {get; set;}
Remarks
This can be overridden or used in combination with the series level connectionstring. Access, Excel and SQL server are supported and automatically detected based on the connection string specified. See Getting Started > Tutorials > Connecting to data.
Example
  • C#
// This will set the Access connection string default for all series.
Chart.DefaultSeries.ConnectionString = @"c:\chartsample.mdb";

//This will set the SQL server connection string default to all series:
Chart.DefaultSeries.ConnectionString ="server=server name or IP;uid=username;pwd=password;database=database name";
  • Visual Basic
'This will Set the Access connection String Default For all series.
Chart.DefaultSeries.ConnectionString = "c:\chartsample.mdb"

'This will Set the SQL server connection String Default To all series:
Chart.DefaultSeries.ConnectionString ="server=server name or IP;uid=username;pwd=password;database=database name"
Example
Items 1
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
ConnectionString Property


dotnetCHARTING Namespace > Series Class : ContourCount Property
ContourCount Property
Gets or sets the number of contours to draw on a SeriesType.Surface.Contour series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ContourCount As Integer
'Usage

Dim instance As Series
Dim value As Integer

instance.ContourCount = value

value = instance.ContourCount
public int ContourCount {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : Data Property
Data Property (Series)
Gets or sets a DataTable, DataSet, DataView, XML file name, XML string, or an object that implement IEnumerable, ArrayList or HashTable used to generate a SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Data As Object
'Usage

Dim instance As Series
Dim value As Object

instance.Data = value

value = instance.Data
public object Data {get; set;}
Remarks
When not connecting to a database directly using ConnectionString and SqlStatement, this property can be used to supply objects with data.
Example
Adds data based on the myDataTable .
  • C#
Chart.Series.Data = myDataTable;
Chart.Series.DataFields = "XAxis=FirstCol,YAxis=SecondCol";
Chart.SeriesCollection.Add();
  • Visual Basic
Chart.Series.Data = myDataTable
Chart.Series.DataFields = "FirstCol=XAxis,SecondCol=YAxis"
Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
Data Property


Example

dotnetCHARTING Namespace > Series Class : DataFields Property
DataFields Property (Series)
Gets or sets a value that specifies the 'database column' to 'chart data' relationship.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataFields As String
'Usage

Dim instance As Series
Dim value As String

instance.DataFields = value

value = instance.DataFields
public string DataFields {get; set;}
Remarks
When programmatically setting a datatable or dataset, certain columns are expected with specific names. This property allows you to control the expected names.

See Getting Started > Tutorials > Data Fields for more info.
Example
  • C#
Chart.Series.DataFields="xAxis=field1,yAxis=field2,splitby=field3";
  • Visual Basic
Chart.Series.DataFields="xAxis=field1,yAxis=field2,splitby=field3"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataFields Property


dotnetCHARTING Namespace > Series Class : DataProviderType Property
DataProviderType Property (Series)
Specifies a database type. Defaults to OleDb (Access database).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DataProviderType As DataProviderType
'Usage

Dim instance As Series
Dim value As DataProviderType

instance.DataProviderType = value

value = instance.DataProviderType
public DataProviderType DataProviderType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataProviderType Property


dotnetCHARTING Namespace > Series Class : DefaultElement Property
DefaultElement Property (Series)
Gets or sets the an Element object whose properties will trickle to all elements within this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultElement As Element
'Usage

Dim instance As Series
Dim value As Element

instance.DefaultElement = value

value = instance.DefaultElement
public Element DefaultElement {get; set;}
Remarks
The properties of this element instance will trickle down to all elements within this series unless explicitly set for any particular element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : DefaultLeafElement Property
DefaultLeafElement Property
(JS Chart Only) Gets or sets element properties applied to all hierarchical leaf element in this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultLeafElement As Element
'Usage

Dim instance As Series
Dim value As Element

instance.DefaultLeafElement = value

value = instance.DefaultLeafElement
public Element DefaultLeafElement {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : Element Property
Element Property (Series)
Gets or sets an Element object which facilitates a shortcut for adding elements to the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Element As Element
'Usage

Dim instance As Series
Dim value As Element

instance.Element = value

value = instance.Element
public Element Element {get; set;}
Example
Add a single element to the chart collection.
  • C#
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();
  • Visual Basic
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Elements Property
Elements Property
Gets or sets a collection of Element objects associated with this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Elements As ElementCollection
'Usage

Dim instance As Series
Dim value As ElementCollection

value = instance.Elements
public ElementCollection Elements {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : EmptyElement Property
EmptyElement Property
Gets or sets an EmptyElement object associated with this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EmptyElement As EmptyElement
'Usage

Dim instance As Series
Dim value As EmptyElement

instance.EmptyElement = value

value = instance.EmptyElement
public EmptyElement EmptyElement {get; set;}
Remarks
The properties of this empty element apply to all elements in the Elements collection.
Example
EmptyElements1
EmptyElements2
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : EndDate Property
EndDate Property (Series)
The ending date used with SqlStatement to query filtered data from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EndDate As Date
'Usage

Dim instance As Series
Dim value As Date

instance.EndDate = value

value = instance.EndDate
public DateTime EndDate {get; set;}
Remarks
This property affects the date listed in the title when Chart.ShowDateInTitle is used, it is also used for the SqlStatement property where the #EndDate# token is replaced with the value set to this property.
Example
  • C#
Chart.Series.StartDate = new DateTime(2004,12,10);
  • Visual Basic
Chart.Series.StartDate = New DateTime(2004,12,10)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
EndDate Property


dotnetCHARTING Namespace > Series Class : ExcludeFromAxisRange Property
ExcludeFromAxisRange Property
Gets or sets a value that indicates whether the element values of this series will affect the value axis they are plotted against.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExcludeFromAxisRange As Boolean
'Usage

Dim instance As Series
Dim value As Boolean

instance.ExcludeFromAxisRange = value

value = instance.ExcludeFromAxisRange
public bool ExcludeFromAxisRange {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Axis Scales


dotnetCHARTING Namespace > Series Class : FirstElement Property
FirstElement Property
(JS Chart Only) Gets or sets element properties applied to the first element in this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property FirstElement As Element
'Usage

Dim instance As Series
Dim value As Element

instance.FirstElement = value

value = instance.FirstElement
public Element FirstElement {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GaugeBorderBox Property
GaugeBorderBox Property
Gets or sets a box object that determines the box style and colors used with GaugeBorderShape.UseBox.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeBorderBox As Box
'Usage

Dim instance As Series
Dim value As Box

instance.GaugeBorderBox = value

value = instance.GaugeBorderBox
public Box GaugeBorderBox {get; set;}
Example
GaugeHRangeTick
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GaugeBorderShape Property
GaugeBorderShape Property
Gets or sets the GaugeBorderShape of this series used with gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeBorderShape As GaugeBorderShape
'Usage

Dim instance As Series
Dim value As GaugeBorderShape

instance.GaugeBorderShape = value

value = instance.GaugeBorderShape
public GaugeBorderShape GaugeBorderShape {get; set;}
Example
GaugeThermometerStyled
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GaugeLinearStyle Property
GaugeLinearStyle Property
Gets or sets the GaugeLinearStyle used with GaugeType.Horizontal and GaugeType.Vertical.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeLinearStyle As GaugeLinearStyle
'Usage

Dim instance As Series
Dim value As GaugeLinearStyle

instance.GaugeLinearStyle = value

value = instance.GaugeLinearStyle
public GaugeLinearStyle GaugeLinearStyle {get; set;}
Example
GaugeThermometerStyled
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : GaugeType Property
GaugeType Property
Get or sets the GaugeType used with ChartType.Gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property GaugeType As GaugeType
'Usage

Dim instance As Series
Dim value As GaugeType

instance.GaugeType = value

value = instance.GaugeType
public GaugeType GaugeType {get; set;}
Example
GaugeAbsolutePosition
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : HatchStylePalette Property
HatchStylePalette Property (Series)
Gets or sets the hatch style palette used be the Elements of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStylePalette As HatchStyle()
'Usage

Dim instance As Series
Dim value() As HatchStyle

instance.HatchStylePalette = value

value = instance.HatchStylePalette
public HatchStyle[] HatchStylePalette {get; set;}
Example
HatchStylePalette
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : HatchStylePaletteName Property
HatchStylePaletteName Property (Series)
Gets or sets a Palette boolean which indicates which static palette will be used be the Elements of this series.
Note If used, legend behavior will be different.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HatchStylePaletteName As HatchStylePalette
'Usage

Dim instance As Series
Dim value As HatchStylePalette

instance.HatchStylePaletteName = value

value = instance.HatchStylePaletteName
public HatchStylePalette HatchStylePaletteName {get; set;}
Example
HatchStylePalette
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : ImageBarSyncToValue Property
ImageBarSyncToValue Property
Gets or sets a value that indicates whether repeating ImageBar templates will sync the number of times they repeat with the element's value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageBarSyncToValue As Boolean
'Usage

Dim instance As Series
Dim value As Boolean

instance.ImageBarSyncToValue = value

value = instance.ImageBarSyncToValue
public bool ImageBarSyncToValue {get; set;}
Example
ImageBarOneToOne4
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : ImageBarTemplate Property
ImageBarTemplate Property
Gets or sets the path and file name of the image bar template used when drawing elements of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ImageBarTemplate As String
'Usage

Dim instance As Series
Dim value As String

instance.ImageBarTemplate = value

value = instance.ImageBarTemplate
public string ImageBarTemplate {get; set;}
Example
Image Bars
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : InterpolationFillFactor Property
InterpolationFillFactor Property
Gets or sets the factor by which a surface element tile is interpolated. This property is used with SeriesTypeSurface.Surface series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property InterpolationFillFactor As Integer
'Usage

Dim instance As Series
Dim value As Integer

instance.InterpolationFillFactor = value

value = instance.InterpolationFillFactor
public int InterpolationFillFactor {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Item Property
Item Property (Series)
Gets or sets an Element of this Series at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Element
'Usage

Dim instance As Series
Dim index As Integer
Dim value As Element

instance.Item(index) = value

value = instance.Item(index)
public Element this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : JsID Property
JsID Property (Series)
Gets or sets the ID of this series used in JavaScript charts. By specifying this ID, the series can be referenced in JS.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsID As String
'Usage

Dim instance As Series
Dim value As String

instance.JsID = value

value = instance.JsID
public string JsID {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : JsMap Property
JsMap Property (Series)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property JsMap As String
'Usage

Dim instance As Series
Dim value As String

instance.JsMap = value

value = instance.JsMap
public string JsMap {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : LastElement Property
LastElement Property
(JS Chart Only) Gets or sets element properties applied to the last element in this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LastElement As Element
'Usage

Dim instance As Series
Dim value As Element

instance.LastElement = value

value = instance.LastElement
public Element LastElement {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : LegendEntry Property
LegendEntry Property (Series)
Gets or sets the legend entry properties of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendEntry As LegendEntry
'Usage

Dim instance As Series
Dim value As LegendEntry

instance.LegendEntry = value

value = instance.LegendEntry
public LegendEntry LegendEntry {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : Limit Property
Limit Property (Series)
Gets or sets the limit number of elements returned for this series when data is generated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Limit As String
'Usage

Dim instance As Series
Dim value As String

instance.Limit = value

value = instance.Limit
public string Limit {get; set;}
Remarks

This property determines the number of elements to include in the limited return in conjuction with LimitMode property. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum elements.

Note: If DateGrouping is used limit has no effect, you can limit the return with the StartDate and EndDate in such a case.

See also: Getting Started > Tutorials > Data Engine.

Example
  • C#
Series.Limit = "10";
Series.Limit = "2x10";
  • Visual Basic
Series.Limit = "10"
Series.Limit = "2x10"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Limit Property
Limit Property


Example

dotnetCHARTING Namespace > Series Class : LimitMode Property
LimitMode Property (Series)
Determine the type of limitation for Limit and SplitByLimit properties. Default is Top.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LimitMode As LimitMode
'Usage

Dim instance As Series
Dim value As LimitMode

instance.LimitMode = value

value = instance.LimitMode
public LimitMode LimitMode {get; set;}
Remarks
This property works in conjunction with Limit or SplitByLimit to determine which elements or series should be included or excluded.
Example
The following setting returns the number of minimum elements or series.
  • C#
series.LimitMode = LimitMode.Bottom;
  • Visual Basic
series.LimitMode = LimitMode.Bottom
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
LimitMode
LimitMode Property


dotnetCHARTING Namespace > Series Class : Line Property
Line Property (Series)
Gets or sets the line properties of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As Series
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Remarks
This line object is used when the SeriesType of this series is Line, Spline, or AreaLine and Use3D is false.
Example
Gallery/a441
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
Line Class


dotnetCHARTING Namespace > Series Class : Name Property
Name Property (Series)
Gets or sets the name of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As Series
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : OtherElementText Property
OtherElementText Property
Controls the label used for the aggregated datapoint / series created when using Limit or SplitByLimit and setting ShowOther to true.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property OtherElementText As String
'Usage

Dim instance As Series
Dim value As String

instance.OtherElementText = value

value = instance.OtherElementText
public string OtherElementText {get; set;}
Remarks
See Getting Started > Tutorials > Data Engine for more info.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
OtherElementLabel Property


dotnetCHARTING Namespace > Series Class : Palette Property
Palette Property (Series)
Gets or sets the palette which will be used by the Elements of this series.

Note If used, legend behavior will be different.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Palette As Color()
'Usage

Dim instance As Series
Dim value() As Color

instance.Palette = value

value = instance.Palette
public Color[] Palette {get; set;}
Remarks
When setting this property, each element will get it's own color. Whereas by default, all elements within a series take their color from Series.DefaultElement.Color. When the chart detects that the elements have been individually colored, each element's LegendEntry will replace the single legend entry of the series in the legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : PaletteName Property
PaletteName Property (Series)
Gets or sets a Palette enumeration which indicates which static palette will be used by the Elements of this series.

Note If used, legend behavior will be different.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaletteName As Palette
'Usage

Dim instance As Series
Dim value As Palette

instance.PaletteName = value

value = instance.PaletteName
public Palette PaletteName {get; set;}
Remarks
When setting this property, each element will get it's own color. Whereas by default, all elements within a series take their color from Series.DefaultElement.Color. When the chart detects that the elements have been individually colored, each element's LegendEntry will replace the single legend entry of the series in the legend box.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : ParameterCollection Property
ParameterCollection Property (Series)
Gets or sets a collection of Parameter objects used in conjunction with StoredProcedure
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property ParameterCollection As ParameterCollection
'Usage

Dim instance As Series
Dim value As ParameterCollection

value = instance.ParameterCollection
public ParameterCollection ParameterCollection {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
DataEngine Class
AddParameter Method
ParameterCollection Property


dotnetCHARTING Namespace > Series Class : Position Property
Position Property (Series)
Gets or sets the position of this series in relation to other series when the chart is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Position As Integer
'Usage

Dim instance As Series
Dim value As Integer

instance.Position = value

value = instance.Position
public int Position {get; set;}
Remarks
Series with lower position values will be drawn closer to the front.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : ShapeLabels Property
ShapeLabels Property
(JS Chart Only) A collection of labels used with gauge charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShapeLabels As ShapeLabelCollection
'Usage

Dim instance As Series
Dim value As ShapeLabelCollection

instance.ShapeLabels = value

value = instance.ShapeLabels
public ShapeLabelCollection ShapeLabels {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : ShowOther Property
ShowOther Property (Series)
This property controls if the additional series not shown due to the use of SplitByLimit, or the additional elements not shown due to the use of Limit are aggregated into a single series / element and graphed alongside the top x series / elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ShowOther As Boolean
'Usage

Dim instance As Series
Dim value As Boolean

instance.ShowOther = value

value = instance.ShowOther
public bool ShowOther {get; set;}
Remarks
See Gettings Started > Tutorials > Data Engine for more info.
The default is false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property
ShowOther Property


dotnetCHARTING Namespace > Series Class : SplineTensionPercent Property
SplineTensionPercent Property
Gets or sets a value between 0 and 100 that specifies the tension of a spline curve.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplineTensionPercent As Integer
'Usage

Dim instance As Series
Dim value As Integer

instance.SplineTensionPercent = value

value = instance.SplineTensionPercent
public int SplineTensionPercent {get; set;}
Example
SplineTension
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


Example

dotnetCHARTING Namespace > Series Class : SplitByLimit Property
SplitByLimit Property (Series)
Gets or sets the number of series created using SplitBy.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SplitByLimit As String
'Usage

Dim instance As Series
Dim value As String

instance.SplitByLimit = value

value = instance.SplitByLimit
public string SplitByLimit {get; set;}
Remarks

This property works with conjunction of LimitMode property and determines the number of series to include in the return. The limit string can be a number "3" or "2x3". In the second format, the first number determines the group positon and the second number is the limit. By setting "2x3" with top limit mode, it only return the second "3" maximum series.

Example
  • C#
de.SplitByLimit="3";
de.SplitByLimit="2x3";
  • Visual Basic
de.SplitByLimit="3"
de.SplitByLimit="2x3"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
LimitMode Property
DataEngine Class
SplitByLimit Property


Example

dotnetCHARTING Namespace > Series Class : SqlStatement Property
SqlStatement Property (Series)
The SQL statement used to obtain the charting data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SqlStatement As String
'Usage

Dim instance As Series
Dim value As String

instance.SqlStatement = value

value = instance.SqlStatement
public string SqlStatement {get; set;}
Remarks
The first column returned is used for the X values, and the second for the Y values. The first also has special handling if dates are returned as the DateGrouping property can be used for intelligent date handling and grouping. The third column is optional and is used only for SplitBy. When a third column is set it is used automatically to create a unique series based on each unique value in this column.

NOTE: All date values in your SQL statements should be wrapped with the pound symbol: #10/25/2002#, regardless if Access or SQL server is used. Also the #StartDate# and #EndDate# tokens can be used in which case the dates set for these properties will be set in place of the tokens before the SqlStatement is executed.
Example
  • C#
series.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders";

//If you are doing a SplitBy you would need another field to correspond to your SplitBy value i.e.
series.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders" ;
  • Visual Basic
series.Series.SqlStatement = "SELECT OrderDate,Total FROM Orders"

'If you are doing a SplitBy you would need another field To correspond To your SplitBy value i.e.
series.Series.SqlStatement = "SELECT OrderDate,Total,Customer FROM Orders"
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
DataEngine Class
SqlStatement Property
SqlStatement Property


Example

dotnetCHARTING Namespace > Series Class : StartDate Property
StartDate Property (Series)
The starting date used with SqlStatement to query filtered data from a database.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDate As Date
'Usage

Dim instance As Series
Dim value As Date

instance.StartDate = value

value = instance.StartDate
public DateTime StartDate {get; set;}
Remarks

This property affects the date listed in the title when Chart.ShowDateInTitle is used, it is also used for the SqlStatement property where the #StartDate# token is replaced with the value set to this property.

Example
  • C#
Chart.Series.StartDate = new DateTime(2004,12,10);
  • Visual Basic
Chart.Series.StartDate = New DateTime(2004,12,10)
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
StartDate Property


dotnetCHARTING Namespace > Series Class : StoredProcedure Property
StoredProcedure Property (Series)
This property accepts the name of a stored procedure to be used in place of the SqlStatement property in order to obtain data for the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StoredProcedure As String
'Usage

Dim instance As Series
Dim value As String

instance.StoredProcedure = value

value = instance.StoredProcedure
public string StoredProcedure {get; set;}
Remarks
See the SqlStatement property for details on how the return columns are expected. Stored Procedures also work with parameters, see the AddParameter method.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
DataEngine Class
StoredProcedure Property


Example

dotnetCHARTING Namespace > Series Class : TotalElements Property
TotalElements Property
Return the total number of elements in the elements collection. This property usually used in conjunction with Limit.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property TotalElements As Integer
'Usage

Dim instance As Series
Dim value As Integer

value = instance.TotalElements
public int TotalElements {get;}
Example
  • C#
int pageSize=3;
int totalPage = Chart.Total%pageSize==0?Chart.Total/pageSize:(Chart.Total/pageSize)+1;
if(totalPage>currentPage)
{
//Display "Next" button.
}
  • Visual Basic
Dim pageSize As Integer = 3
Dim totalPage As Integer = Chart.Total / pageSize;
If Chart.Total Mod pageSize > 0 Then
totalPage = totalPage + 1)
End If
If totalPage > currentPage Then
'Display "Next" button.
End If
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Type Property
Type Property (Series)
Gets or sets the type of this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As Object
'Usage

Dim instance As Series
Dim value As Object

instance.Type = value

value = instance.Type
public object Type {get; set;}
Remarks
This property accepts string, SeriesType, or enumeration.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members
ChartType Enumeration

Tutorials

Chart Type Anatomy


dotnetCHARTING Namespace > Series Class : Use3D Property
Use3D Property (Series)
Gets or sets a value that indicates whether this surface series is drawn in 3D.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Use3D As Boolean
'Usage

Dim instance As Series
Dim value As Boolean

instance.Use3D = value

value = instance.Use3D
public bool Use3D {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Visible Property
Visible Property (Series)
Gets or sets a value which indicates whether the series is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Series
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Remarks
This property is only valid when set through Chart.Series.Visible. Setting this property on a lone Series object would have no effect.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : XAxis Property
XAxis Property (Series)
Gets or sets the x axis for this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property XAxis As Axis
'Usage

Dim instance As Series
Dim value As Axis

instance.XAxis = value

value = instance.XAxis
public Axis XAxis {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Multiple Axes


dotnetCHARTING Namespace > Series Class : YAxis Property
YAxis Property (Series)
Gets or sets the y axis for this series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property YAxis As Axis
'Usage

Dim instance As Series
Dim value As Axis

instance.YAxis = value

value = instance.YAxis
public Axis YAxis {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Multiple Axes


dotnetCHARTING Namespace > Series Class : ZAxis Property
ZAxis Property (Series)
Gets or sets the Z axis of this series when used with surface charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZAxis As Axis
'Usage

Dim instance As Series
Dim value As Axis

instance.ZAxis = value

value = instance.ZAxis
public Axis ZAxis {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : Addition Operator
Addition Operator (Series)
Adds two Series objects together.
Overload List
Overload | Description
Addition(Series,Series) | Adds two Series objects together.
Addition(Double,Series) | Adds a value to all elements in the rhs series.
Addition(Series,Double) | Adds a value to all elements in the rhs series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class : Division Operator
Division Operator (Series)
Divides the element values of the series on the left by the element values of the series on the right.
Overload List
Overload | Description
Division(Series,Series) | Divides the element values of the series on the left by the element values of the series on the right.
Division(Double,Series) | Divides the value on the left by the series on the right.
Division(Series,Double) | Divides the series on the left by the value on the right.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class : Multiplication Operator
Multiplication Operator (Series)
Multiplies two Series objects together.
Overload List
Overload | Description
Multiplication(Series,Series) | Multiplies two Series objects together.
Multiplication(Double,Series) | Multiplies a series by a value.
Multiplication(Series,Double) | Multiplies a series by a value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class : Subtraction Operator
Subtraction Operator (Series)
Subtracts the element values of series on the right from the series on the left.
Overload List
Overload | Description
Subtraction(Series,Series) | Subtracts the element values of series on the right from the series on the left.
Subtraction(Double,Series) | Subtracts all element values from the left hand side number.
Subtraction(Series,Double) | Subtracts the number on the right hand side from the element values of the series on the left.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SeriesCollection Class
SeriesCollection Class
Contains a collection of Series objects.
Object Model
SeriesCollection ClassSeries Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SeriesCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As SeriesCollection
public class SeriesCollection : System.Collections.CollectionBase
Remarks

This class can also perform calculations and data manipulation on the series it contains.

See also: Data Model Tutorial

Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.SeriesCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Members
dotnetCHARTING Namespace

Tutorials

Data Tutorials


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : SeriesCollection Class
SeriesCollection Class Members

The following tables list the members exposed by SeriesCollection.

Public Constructors
 | Name | Description
Public Constructor | SeriesCollection Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the Series at a specified index.
Public Property | SmartGrouping | Gets or sets a value that indicates whether smart element grouping is used or the traditional element name grouping is used where the elements of the first series determines the order.
Public Property | SmartPalette | Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.
Public Method | Calculate | Overloaded. Performs a Calculation on this collection and stores the specified source element values in the resulting element's SubValue collections.
Public Method | CalculateElement | Performs a calculation on this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Clone |
Public Method | Contains | Determines whether this collection contains a specified Series.
Public Method | GetAxisSeries | Gets a collection of series associated with the specified axis.
Public Method | GetDataSource | Gets a DataSource object representing this SeriesCollection.
Public Method | GetElement | Overloaded. Gets an Element at the specified series and element index.
Public Method | GetElementBreadcrumbs | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetProcessedDataTable | Overloaded. Returns a DataTable of processed data.
Public Method | GetSeries | Retrieves the named Series.
Public Method | GetSmartPalette | Overloaded. Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.
Public Method | GetSurfaceData | Overloaded. Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values.
Public Method | GroupByElements | Groups series into even element groups where every element will have a matching element in all other series.
Public Method | IndexOf | Overloaded. Determines the index of a specified Series in this collection.
Public Method | Insert | Inserts a series into this collection at a specified index.
Public Method | Remove | Removes a specified series from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Public Method | SelectiveElementDefaults | Overloaded. Applies property settings of the specified default element to elements in this series collection that are outside a specified CalendarPattern and corresponding DateTime element property.
Public Method | Sort | Sorts the Series based on an element property and order.
Public Method | SortElementGroups | Sorts element groups by their cummulative values. Element groups are defined as elements in different series which share the same names.
Public Method | ToString |
Public Method | Transpose | Overloaded. Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.
Public Method | Trim | Overloaded. Trims this SeriesCollection of elements leaving only the specified number of levels from the root element.
Top
See Also

Reference

SeriesCollection Class
dotnetCHARTING Namespace

Tutorials

Data Tutorials


%%PageItemTitle%%

dotnetCHARTING Namespace > SeriesCollection Class : SeriesCollection Constructor
SeriesCollection Constructor
Overload List
Overload | Description
SeriesCollection Constructor() | Initializes a new instance of the SeriesCollection class.
SeriesCollection Constructor(Series[]) | Initializes a new instance of the SeriesCollection class and adds the specified series to it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


%%PageItemTitle%%

dotnetCHARTING Namespace > SeriesCollection Class > SeriesCollection Constructor : SeriesCollection Constructor()
SeriesCollection Constructor()
Initializes a new instance of the SeriesCollection class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New SeriesCollection()
public SeriesCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SeriesCollection Class > SeriesCollection Constructor : SeriesCollection Constructor(Series[])
List of Series to add to the collection.
SeriesCollection Constructor(Series[])
Initializes a new instance of the SeriesCollection class and adds the specified series to it.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray seriesList() As Series _
)
'Usage

Dim seriesList() As Series

Dim instance As New SeriesCollection(seriesList)
public SeriesCollection(
   params Series[] seriesList
)

Parameters

seriesList
List of Series to add to the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : SeriesCollection Class
SeriesCollection Class Methods

For a list of all members of this type, see SeriesCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.
Public Method | Calculate | Overloaded. Performs a Calculation on this collection and stores the specified source element values in the resulting element's SubValue collections.
Public Method | CalculateElement | Performs a calculation on this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Clone |
Public Method | Contains | Determines whether this collection contains a specified Series.
Public Method | GetAxisSeries | Gets a collection of series associated with the specified axis.
Public Method | GetDataSource | Gets a DataSource object representing this SeriesCollection.
Public Method | GetElement | Overloaded. Gets an Element at the specified series and element index.
Public Method | GetElementBreadcrumbs | Overloaded.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetProcessedDataTable | Overloaded. Returns a DataTable of processed data.
Public Method | GetSeries | Retrieves the named Series.
Public Method | GetSmartPalette | Overloaded. Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.
Public Method | GetSurfaceData | Overloaded. Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values.
Public Method | GroupByElements | Groups series into even element groups where every element will have a matching element in all other series.
Public Method | IndexOf | Overloaded. Determines the index of a specified Series in this collection.
Public Method | Insert | Inserts a series into this collection at a specified index.
Public Method | Remove | Removes a specified series from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Public Method | SelectiveElementDefaults | Overloaded. Applies property settings of the specified default element to elements in this series collection that are outside a specified CalendarPattern and corresponding DateTime element property.
Public Method | Sort | Sorts the Series based on an element property and order.
Public Method | SortElementGroups | Sorts element groups by their cummulative values. Element groups are defined as elements in different series which share the same names.
Public Method | ToString |
Public Method | Transpose | Overloaded. Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.
Public Method | Trim | Overloaded. Trims this SeriesCollection of elements leaving only the specified number of levels from the root element.
Top
See Also

Reference

SeriesCollection Class
dotnetCHARTING Namespace

Tutorials

Data Tutorials


dotnetCHARTING Namespace > SeriesCollection Class : Add Method
Add Method (SeriesCollection)
Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.
Overload List
Overload | Description
Add() | Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.
Add(Calculation) | Adds a series to the collection based on the specified calculation.
Add(Calculation,String) | Adds a series calculated from a specified series.
Add(Series) | Adds a specified Series class to this collection.
Add(SeriesCollection) | Adds a specified SeriesCollection to this collection.
Add(Series[]) | Adds the specified Series objects to this collection.
Add(SeriesCollection[]) | Adds Series of the specified SeriesCollection objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Example

dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add() Method
Add() Method
Provided as a shortcut for adding elements, series, and series collections the chart SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add() As Integer
'Usage

Dim instance As SeriesCollection
Dim value As Integer

value = instance.Add()
public int Add()
Example
Adds an element using the shortcut.
  • C#
[C#]
Chart.Series.Element.YValue = 10;
Chart.Series.Element.Name = "Element 1";
Chart.Series.Elements.Add();
Chart.SeriesCollection.Add();
  • C#
[Visual Basic]
Chart.Series.Element.YValue = 10
Chart.Series.Element.Name = "Element 1"
Chart.Series.Elements.Add()
Chart.SeriesCollection.Add()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(Calculation) Method
Calculation to perform on the collection.
Add(Calculation) Method
Adds a series to the collection based on the specified calculation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal calc As Calculation _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim calc As Calculation
Dim value As Integer

value = instance.Add(calc)
public int Add(
   Calculation calc
)

Parameters

calc
Calculation to perform on the collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(Calculation,String) Method
Calculation to perform
Name of the series to derrive a series from.
Add(Calculation,String) Method
Adds a series calculated from a specified series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal calc As Calculation, _
   ByVal fromSeries As String _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim calc As Calculation
Dim fromSeries As String
Dim value As Integer

value = instance.Add(calc, fromSeries)
public int Add(
   Calculation calc,
   string fromSeries
)

Parameters

calc
Calculation to perform
fromSeries
Name of the series to derrive a series from.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(Series) Method
The Series to add.
Add(Series) Method
Adds a specified Series class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal series As Series _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim series As Series
Dim value As Integer

value = instance.Add(series)
public int Add(
   Series series
)

Parameters

series
The Series to add.

Return Value

The zero-based index of the added Series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(SeriesCollection) Method
The SeriesCollection to add.
Add(SeriesCollection) Method
Adds a specified SeriesCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal seriesCollection As SeriesCollection _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim seriesCollection As SeriesCollection
Dim value As Integer

value = instance.Add(seriesCollection)
public int Add(
   SeriesCollection seriesCollection
)

Parameters

seriesCollection
The SeriesCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(Series[]) Method
A list of Series objects to add.
Add(Series[]) Method
Adds the specified Series objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray seriesList() As Series _
)
'Usage

Dim instance As SeriesCollection
Dim seriesList() As Series

instance.Add(seriesList)
public void Add(
   params Series[] seriesList
)

Parameters

seriesList
A list of Series objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Add Method : Add(SeriesCollection[]) Method
A list of SeriesCollection objects to add.
Add(SeriesCollection[]) Method
Adds Series of the specified SeriesCollection objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray seriesCollectionList() As SeriesCollection _
)
'Usage

Dim instance As SeriesCollection
Dim seriesCollectionList() As SeriesCollection

instance.Add(seriesCollectionList)
public void Add(
   params SeriesCollection[] seriesCollectionList
)

Parameters

seriesCollectionList
A list of SeriesCollection objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : Calculate Method
Calculate Method (SeriesCollection)
Performs a Calculation on this collection and stores the specified source element values in the resulting element's SubValue collections.
Overload List
Overload | Description
Calculate(String,Calculation,ElementValue) | Performs a Calculation on this collection and stores the specified source element values in the resulting element's SubValue collections.
Calculate(String,Calculation) | Performs a calculation on this collection.
Calculate(String,Calculation,Int32) | Performs a Calculation on this collection with an extra parameter.
Calculate(String,Calculation,Axis) | Performs a calculation on series in this collection that are bound to the specified axis.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > SeriesCollection Class > Calculate Method : Calculate(String,Calculation,ElementValue) Method
Name of the returned series.
Calculation to perform on this collection.
The ElementValue to store in the resulting element's SubValue collection.
Calculate(String,Calculation,ElementValue) Method
Performs a Calculation on this collection and stores the specified source element values in the resulting element's SubValue collections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation, _
   ByVal subValueSource As ElementValue _
) As Series
'Usage

Dim instance As SeriesCollection
Dim label As String
Dim calc As Calculation
Dim subValueSource As ElementValue
Dim value As Series

value = instance.Calculate(label, calc, subValueSource)
public Series Calculate(
   string label,
   Calculation calc,
   ElementValue subValueSource
)

Parameters

label
Name of the returned series.
calc
Calculation to perform on this collection.
subValueSource
The ElementValue to store in the resulting element's SubValue collection.

Return Value

Returns a series based on the specified calculation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Calculate Method : Calculate(String,Calculation) Method
Name of the returned series.
The calculation to perform on this collection.
Calculate(String,Calculation) Method
Performs a calculation on this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation _
) As Series
'Usage

Dim instance As SeriesCollection
Dim label As String
Dim calc As Calculation
Dim value As Series

value = instance.Calculate(label, calc)
public Series Calculate(
   string label,
   Calculation calc
)

Parameters

label
Name of the returned series.
calc
The calculation to perform on this collection.

Return Value

Returns a series based on the specified calculation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Calculate Method : Calculate(String,Calculation,Int32) Method
Name of the returned series.
Calculation to perform on this collection.
Extra parameter.
Calculate(String,Calculation,Int32) Method
Performs a Calculation on this collection with an extra parameter.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation, _
   ByVal ExtraParam As Integer _
) As Series
'Usage

Dim instance As SeriesCollection
Dim label As String
Dim calc As Calculation
Dim ExtraParam As Integer
Dim value As Series

value = instance.Calculate(label, calc, ExtraParam)
public Series Calculate(
   string label,
   Calculation calc,
   int ExtraParam
)

Parameters

label
Name of the returned series.
calc
Calculation to perform on this collection.
ExtraParam
Extra parameter.

Return Value

Returns a series based on the specified calculation.
Remarks
Calculation.TrendLineLinear and Calculation.TrendLineLinearScatter will yield a result with extra elements which simulate the continuance of a trend. Supplying the ExtraParam parameter denotes the number of extra elements to create.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Calculate Method : Calculate(String,Calculation,Axis) Method
Name of the returned series.
Calculation to perform.
The axis bound to data on which the calculation is performed.
Calculate(String,Calculation,Axis) Method
Performs a calculation on series in this collection that are bound to the specified axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Calculate( _
   ByVal label As String, _
   ByVal calc As Calculation, _
   ByVal xAxis As Axis _
) As Series
'Usage

Dim instance As SeriesCollection
Dim label As String
Dim calc As Calculation
Dim xAxis As Axis
Dim value As Series

value = instance.Calculate(label, calc, xAxis)
public Series Calculate(
   string label,
   Calculation calc,
   Axis xAxis
)

Parameters

label
Name of the returned series.
calc
Calculation to perform.
xAxis
The axis bound to data on which the calculation is performed.

Return Value

Returns a series based on the specified calculation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : CalculateElement(String,Calculation) Method
Name of the returned element.
The calculation to perform on this collection.
CalculateElement(String,Calculation) Method
Performs a calculation on this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function CalculateElement( _
   ByVal label As String, _
   ByVal calc As Calculation _
) As Element
'Usage

Dim instance As SeriesCollection
Dim label As String
Dim calc As Calculation
Dim value As Element

value = instance.CalculateElement(label, calc)
public Element CalculateElement(
   string label,
   Calculation calc
)

Parameters

label
Name of the returned element.
calc
The calculation to perform on this collection.

Return Value

Returns an element based on the specified calculation.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : Clone Method
Clone Method (SeriesCollection)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Clone() As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim value As SeriesCollection

value = instance.Clone()
public SeriesCollection Clone()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : Contains Method
The Series to find.
Contains Method (SeriesCollection)
Determines whether this collection contains a specified Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal series As Series _
) As Boolean
'Usage

Dim instance As SeriesCollection
Dim series As Series
Dim value As Boolean

value = instance.Contains(series)
public bool Contains(
   Series series
)

Parameters

series
The Series to find.

Return Value

true if the specified Series belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : GetAxisSeries Method
The axis bound to data which will be returned in a series collection.
GetAxisSeries Method
Gets a collection of series associated with the specified axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetAxisSeries( _
   ByVal a As Axis _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim a As Axis
Dim value As SeriesCollection

value = instance.GetAxisSeries(a)
public SeriesCollection GetAxisSeries(
   Axis a
)

Parameters

a
The axis bound to data which will be returned in a series collection.

Return Value

Returns a series collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : GetDataSource Method
GetDataSource Method (SeriesCollection)
Gets a DataSource object representing this SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetDataSource() As DataSource
'Usage

Dim instance As SeriesCollection
Dim value As DataSource

value = instance.GetDataSource()
public DataSource GetDataSource()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : GetElement Method
GetElement Method
Gets an Element at the specified series and element index.
Overload List
Overload | Description
GetElement(Int32,Int32) | Gets an Element at the specified series and element index.
GetElement(String,String) | Gets an Element with the specified name from a named series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > GetElement Method : GetElement(Int32,Int32) Method
Index of the series.
Indes of the element.
GetElement(Int32,Int32) Method
Gets an Element at the specified series and element index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElement( _
   ByVal seriesIndex As Integer, _
   ByVal elementIndex As Integer _
) As Element
'Usage

Dim instance As SeriesCollection
Dim seriesIndex As Integer
Dim elementIndex As Integer
Dim value As Element

value = instance.GetElement(seriesIndex, elementIndex)
public Element GetElement(
   int seriesIndex,
   int elementIndex
)

Parameters

seriesIndex
Index of the series.
elementIndex
Indes of the element.

Return Value

Returns an Element at the specified series and element index.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > GetElement Method : GetElement(String,String) Method
Series name.
Element name.
GetElement(String,String) Method
Gets an Element with the specified name from a named series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElement( _
   ByVal seriesName As String, _
   ByVal elementName As String _
) As Element
'Usage

Dim instance As SeriesCollection
Dim seriesName As String
Dim elementName As String
Dim value As Element

value = instance.GetElement(seriesName, elementName)
public Element GetElement(
   string seriesName,
   string elementName
)

Parameters

seriesName
Series name.
elementName
Element name.

Return Value

Returns an Element with a specified name from a named series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : GetElementBreadcrumbs Method
GetElementBreadcrumbs Method (SeriesCollection)
Overload List
Overload | Description
GetElementBreadcrumbs(Int32,String,String) |
GetElementBreadcrumbs(Int32,String,String,String) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > GetElementBreadcrumbs Method : GetElementBreadcrumbs(Int32,String,String) Method
ID of the end node of the organizational chain.
Template used for each element from the root to the element with with specified ID.
Separator inserted into the resulting string between each element.
GetElementBreadcrumbs(Int32,String,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElementBreadcrumbs( _
   ByVal parentID As Integer, _
   ByVal elementTemplate As String, _
   ByVal separator As String _
) As String
'Usage

Dim instance As SeriesCollection
Dim parentID As Integer
Dim elementTemplate As String
Dim separator As String
Dim value As String

value = instance.GetElementBreadcrumbs(parentID, elementTemplate, separator)
public string GetElementBreadcrumbs(
   int parentID,
   string elementTemplate,
   string separator
)

Parameters

parentID
ID of the end node of the organizational chain.
elementTemplate
Template used for each element from the root to the element with with specified ID.
separator
Separator inserted into the resulting string between each element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > GetElementBreadcrumbs Method : GetElementBreadcrumbs(Int32,String,String,String) Method
ID of the end node of the organizational chain.
Template used for each element from the root to the element with with specified ID.
Template used for the last breadcrumb. This is provided so the last element doesnt have to be linked.
Separator inserted into the resulting string between each element.
GetElementBreadcrumbs(Int32,String,String,String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetElementBreadcrumbs( _
   ByVal parentID As Integer, _
   ByVal elementTemplate As String, _
   ByVal lastElementTemplate As String, _
   ByVal separator As String _
) As String
'Usage

Dim instance As SeriesCollection
Dim parentID As Integer
Dim elementTemplate As String
Dim lastElementTemplate As String
Dim separator As String
Dim value As String

value = instance.GetElementBreadcrumbs(parentID, elementTemplate, lastElementTemplate, separator)
public string GetElementBreadcrumbs(
   int parentID,
   string elementTemplate,
   string lastElementTemplate,
   string separator
)

Parameters

parentID
ID of the end node of the organizational chain.
elementTemplate
Template used for each element from the root to the element with with specified ID.
lastElementTemplate
Template used for the last breadcrumb. This is provided so the last element doesnt have to be linked.
separator
Separator inserted into the resulting string between each element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : GetProcessedDataTable Method
GetProcessedDataTable Method
Returns a DataTable of processed data.
Overload List
Overload | Description
GetProcessedDataTable(String) | Returns a DataTable of processed data.
GetProcessedDataTable(String,Boolean) | Returns a DataTable of processed data.
GetProcessedDataTable(String,Boolean,Boolean) | Returns a DataTable of processed data.
GetProcessedDataTable(String,Boolean,Boolean,String) | Returns a DataTable of processed data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


Example

dotnetCHARTING Namespace > SeriesCollection Class > GetProcessedDataTable Method : GetProcessedDataTable(String) Method
GetProcessedDataTable(String) Method
Returns a DataTable of processed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProcessedDataTable( _
   ByVal tokenTemplate As String _
) As DataTable
'Usage

Dim instance As SeriesCollection
Dim tokenTemplate As String
Dim value As DataTable

value = instance.GetProcessedDataTable(tokenTemplate)
public DataTable GetProcessedDataTable(
   string tokenTemplate
)

Parameters

tokenTemplate

Return Value

Returns a data table of the processed data.Returns a data table of the processed data.
Remarks
This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.
Example
The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx
  • C#
//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}
  • Visual Basic
'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


Example

dotnetCHARTING Namespace > SeriesCollection Class > GetProcessedDataTable Method : GetProcessedDataTable(String,Boolean) Method
GetProcessedDataTable(String,Boolean) Method
Returns a DataTable of processed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean _
) As DataTable
'Usage

Dim instance As SeriesCollection
Dim tokenTemplate As String
Dim transposeData As Boolean
Dim value As DataTable

value = instance.GetProcessedDataTable(tokenTemplate, transposeData)
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData
)

Parameters

tokenTemplate
transposeData

Return Value

Returns a data table of the processed data.Returns a data table of the processed data.
Remarks
This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.
Example
The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx
  • C#
//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true);
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}
  • Visual Basic
'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True)
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


Example

dotnetCHARTING Namespace > SeriesCollection Class > GetProcessedDataTable Method : GetProcessedDataTable(String,Boolean,Boolean) Method
GetProcessedDataTable(String,Boolean,Boolean) Method
Returns a DataTable of processed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean, _
   ByVal addSeriesName As Boolean _
) As DataTable
'Usage

Dim instance As SeriesCollection
Dim tokenTemplate As String
Dim transposeData As Boolean
Dim addSeriesName As Boolean
Dim value As DataTable

value = instance.GetProcessedDataTable(tokenTemplate, transposeData, addSeriesName)
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData,
   bool addSeriesName
)

Parameters

tokenTemplate
transposeData
addSeriesName

Return Value

Returns a data table of the processed data.Returns a data table of the processed data.
Remarks
This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.
Example
The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx
  • C#
//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true,true);
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}
  • Visual Basic
'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True, True)
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


Example

dotnetCHARTING Namespace > SeriesCollection Class > GetProcessedDataTable Method : GetProcessedDataTable(String,Boolean,Boolean,String) Method
GetProcessedDataTable(String,Boolean,Boolean,String) Method
Returns a DataTable of processed data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetProcessedDataTable( _
   ByVal tokenTemplate As String, _
   ByVal transposeData As Boolean, _
   ByVal addSeriesName As Boolean, _
   ByVal header As String _
) As DataTable
'Usage

Dim instance As SeriesCollection
Dim tokenTemplate As String
Dim transposeData As Boolean
Dim addSeriesName As Boolean
Dim header As String
Dim value As DataTable

value = instance.GetProcessedDataTable(tokenTemplate, transposeData, addSeriesName, header)
public DataTable GetProcessedDataTable(
   string tokenTemplate,
   bool transposeData,
   bool addSeriesName,
   string header
)

Parameters

tokenTemplate
transposeData
addSeriesName
header

Return Value

Returns a data table of the processed data.
Remarks
This method usually called in PostDataProcessing event handler method when data generated dynamically from a database. Then, the datatable can be displayed with dataGrid or other controls.
Example
The follwoing sample, get a data table and displays with a datagrid. For complete sample see features/PostDataProcessing.aspx
  • C#
//This line should add in Page_Load method
Chart.PostDataProcessing +=new PostDataProcessingEventHandler(OnPostDataProcessing);

//The method handling the PostDataProcessing event
void OnPostDataProcessing(Object sender)
{
    DataTable dt = Chart.SeriesCollection.GetProcessedDataTable("%YValue",true,true,"Sales");
    chartdatagrid.DataSource = new DataView(dt);
    chartdatagrid.DataBind();

}
  • Visual Basic
'This line should add in Page_Load method
AddHandler Chart.PostDataProcessing, AddressOf OnPostDataProcessing

'The method handling the PostDataProcessing event
Sub OnPostDataProcessing(sender As [Object])
   Dim dt As DataTable = Chart.SeriesCollection.GetProcessedDataTable("%YValue", True, True, "Sales")
   chartdatagrid.DataSource = New DataView(dt)
   chartdatagrid.DataBind()
End Sub 'OnPostDataProcessing
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : GetSeries Method
Name of the series to get
GetSeries Method (SeriesCollection)
Retrieves the named Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetSeries( _
   ByVal seriesName As String _
) As Series
'Usage

Dim instance As SeriesCollection
Dim seriesName As String
Dim value As Series

value = instance.GetSeries(seriesName)
public Series GetSeries(
   string seriesName
)

Parameters

seriesName
Name of the series to get

Return Value

The named series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : GetSmartPalette Method
GetSmartPalette Method (SeriesCollection)
Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.
Overload List
Overload | Description
GetSmartPalette(Palette) | Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.
GetSmartPalette(Color[]) | Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified array of color objects.
Example
SmartPaletteSaving
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > GetSmartPalette Method : GetSmartPalette(Palette) Method
Palette used to generate the SmartPalette object.
GetSmartPalette(Palette) Method
Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified Palette enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal palette As Palette _
) As SmartPalette
'Usage

Dim instance As SeriesCollection
Dim palette As Palette
Dim value As SmartPalette

value = instance.GetSmartPalette(palette)
public SmartPalette GetSmartPalette(
   Palette palette
)

Parameters

palette
Palette used to generate the SmartPalette object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > GetSmartPalette Method : GetSmartPalette(Color[]) Method
Array of colors used to generate the SmartPalette.
GetSmartPalette(Color[]) Method
Generates a SmartPalette object that contains the names of series in this SeriesCollection matched with the specified array of color objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSmartPalette( _
   ByVal colors() As Color _
) As SmartPalette
'Usage

Dim instance As SeriesCollection
Dim colors() As Color
Dim value As SmartPalette

value = instance.GetSmartPalette(colors)
public SmartPalette GetSmartPalette(
   Color[] colors
)

Parameters

colors
Array of colors used to generate the SmartPalette.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : GetSurfaceData Method
GetSurfaceData Method (SeriesCollection)
Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values.
Overload List
Overload | Description
GetSurfaceData(List<String>,List<String>) | Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values.
GetSurfaceData(Axis,Axis) | Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values and populates the specified axes with string labels.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > GetSurfaceData Method : GetSurfaceData(List<String>,List<String>) Method
A string list representing the x axis Element names that can be mapped to the x axis on the surface chart. The index of the array corresponds to the x axis values.
A string list representing the y axis Series names that can be mapped to the y axis on the surface chart. The index of the array corresponds to the y axis values.
GetSurfaceData(List<String>,List<String>) Method
Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSurfaceData( _
   ByRef xLabels As List(Of String), _
   ByRef yLabels As List(Of String) _
) As Series
'Usage

Dim instance As SeriesCollection
Dim xLabels As List(Of String)
Dim yLabels As List(Of String)
Dim value As Series

value = instance.GetSurfaceData(xLabels, yLabels)
public Series GetSurfaceData(
   out List<string> xLabels,
   out List<string> yLabels
)

Parameters

xLabels
A string list representing the x axis Element names that can be mapped to the x axis on the surface chart. The index of the array corresponds to the x axis values.
yLabels
A string list representing the y axis Series names that can be mapped to the y axis on the surface chart. The index of the array corresponds to the y axis values.

Return Value

A series with surface data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > GetSurfaceData Method : GetSurfaceData(Axis,Axis) Method
The X axis of the surface chart. This method will setup the axis to display element names instead of numbers.
The Y axis of the surface chart. This method will setup the axis to display series names instead of numbers.
GetSurfaceData(Axis,Axis) Method
Returns a series with surface data for this SeriesCollection when the elements in this series use names for x axis values and populates the specified axes with string labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetSurfaceData( _
   ByVal xAxis As Axis, _
   ByVal yAxis As Axis _
) As Series
'Usage

Dim instance As SeriesCollection
Dim xAxis As Axis
Dim yAxis As Axis
Dim value As Series

value = instance.GetSurfaceData(xAxis, yAxis)
public Series GetSurfaceData(
   Axis xAxis,
   Axis yAxis
)

Parameters

xAxis
The X axis of the surface chart. This method will setup the axis to display element names instead of numbers.
yAxis
The Y axis of the surface chart. This method will setup the axis to display series names instead of numbers.

Return Value

A series with surface data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : GroupByElements Method
GroupByElements Method
Groups series into even element groups where every element will have a matching element in all other series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub GroupByElements()
'Usage

Dim instance As SeriesCollection

instance.GroupByElements()
public void GroupByElements()
Remarks
The result will be series of even number of elements with the same names.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : IndexOf Method
IndexOf Method (SeriesCollection)
Determines the index of a specified Series in this collection.
Overload List
Overload | Description
IndexOf(Series) | Determines the index of a specified Series in this collection.
IndexOf(String) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > IndexOf Method : IndexOf(Series) Method
IndexOf(Series) Method
Determines the index of a specified Series in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal s As Series _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim s As Series
Dim value As Integer

value = instance.IndexOf(s)
public int IndexOf(
   Series s
)

Parameters

s
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > IndexOf Method : IndexOf(String) Method
IndexOf(String) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function IndexOf( _
   ByVal name As String _
) As Integer
'Usage

Dim instance As SeriesCollection
Dim name As String
Dim value As Integer

value = instance.IndexOf(name)
public int IndexOf(
   string name
)

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : Insert Method
The zero-based index into the collection at which to insert the series.
The series to insert into this collection.
Insert Method (SeriesCollection)
Inserts a series into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal series As Series _
)
'Usage

Dim instance As SeriesCollection
Dim index As Integer
Dim series As Series

instance.Insert(index, series)
public void Insert(
   int index,
   Series series
)

Parameters

index
The zero-based index into the collection at which to insert the series.
series
The series to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : Remove Method
The series to remove.
Remove Method (SeriesCollection)
Removes a specified series from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal series As Series _
)
'Usage

Dim instance As SeriesCollection
Dim series As Series

instance.Remove(series)
public void Remove(
   Series series
)

Parameters

series
The series to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class : SelectiveElementDefaults Method
SelectiveElementDefaults Method (SeriesCollection)
Applies property settings of the specified default element to elements in this series collection that are outside a specified CalendarPattern and corresponding DateTime element property.
Overload List
Overload | Description
SelectiveElementDefaults(CalendarPattern,ElementValue,Element) | Applies property settings of the specified default element to elements in this series collection that are outside a specified CalendarPattern and corresponding DateTime element property.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series collection that are either outside or inside the specified CalendarPattern and corresponding DateTime element property.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) | Applies property settings of the specified default element to elements in this series collection that are outside the specified DateTime range and corresponding DateTime element property.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series collection that are either inside or outside the specified DateTime range and corresponding DateTime element property.
SelectiveElementDefaults(ScaleRange,ElementValue,Element) | Applies property settings of the specified default element to elements in this series collection that are either inside or outside the specified ScaleRange and corresponding DateTime element property.
SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series collection that are outside the specified ScaleRange and corresponding DateTime element property.
SelectiveElementDefaults(Double,Double,ElementValue,Element) | Applies property settings of the specified default element to elements in this series collection that are outside the specified numeric range and corresponding numeric element property.
SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) | Applies property settings of the specified default element to elements in this series collection that are outside the specified numeric range and corresponding numeric element property.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(CalendarPattern,ElementValue,Element) Method
CalendarPatternused to determine whether the default elements properties should be applied.
DateTime Element value property to compare against the CalendarPattern.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series collection that are outside a specified CalendarPattern and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As SeriesCollection
Dim cp As CalendarPattern
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(cp, ev, defaultElement)
public void SelectiveElementDefaults(
   CalendarPattern cp,
   ElementValue ev,
   Element defaultElement
)

Parameters

cp
CalendarPatternused to determine whether the default elements properties should be applied.
ev
DateTime Element value property to compare against the CalendarPattern.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) Method
CalendarPattern used to determine whether the default elements properties should be applied.
DateTime Element value property to compare against the CalendarPattern.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the calendar pattern.
SelectiveElementDefaults(CalendarPattern,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series collection that are either outside or inside the specified CalendarPattern and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal cp As CalendarPattern, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As SeriesCollection
Dim cp As CalendarPattern
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(cp, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   CalendarPattern cp,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

cp
CalendarPattern used to determine whether the default elements properties should be applied.
ev
DateTime Element value property to compare against the CalendarPattern.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the calendar pattern.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) Method
Low value of the DateTime range.
High value of the DateTime range.
A DateTime element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series collection that are outside the specified DateTime range and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As SeriesCollection
Dim Low As Date
Dim High As Date
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(Low, High, ev, defaultElement)
public void SelectiveElementDefaults(
   DateTime Low,
   DateTime High,
   ElementValue ev,
   Element defaultElement
)

Parameters

Low
Low value of the DateTime range.
High
High value of the DateTime range.
ev
A DateTime element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) Method
Low value of the DateTime range.
High value of the DateTime range.
A DateTime element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the DateTime range.
SelectiveElementDefaults(DateTime,DateTime,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series collection that are either inside or outside the specified DateTime range and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Date, _
   ByVal High As Date, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As SeriesCollection
Dim Low As Date
Dim High As Date
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(Low, High, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   DateTime Low,
   DateTime High,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

Low
Low value of the DateTime range.
High
High value of the DateTime range.
ev
A DateTime element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the DateTime range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(ScaleRange,ElementValue,Element) Method
Range of element values.
Element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
SelectiveElementDefaults(ScaleRange,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series collection that are either inside or outside the specified ScaleRange and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As SeriesCollection
Dim range As ScaleRange
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(range, ev, defaultElement)
public void SelectiveElementDefaults(
   ScaleRange range,
   ElementValue ev,
   Element defaultElement
)

Parameters

range
Range of element values.
ev
Element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) Method
A scale range to compare ele
An element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
SelectiveElementDefaults(ScaleRange,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series collection that are outside the specified ScaleRange and corresponding DateTime element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal range As ScaleRange, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As SeriesCollection
Dim range As ScaleRange
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(range, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   ScaleRange range,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

range
A scale range to compare ele
ev
An element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(Double,Double,ElementValue,Element) Method
Low value of the numeric range.
High value of the numeric range.
A numeric element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
SelectiveElementDefaults(Double,Double,ElementValue,Element) Method
Applies property settings of the specified default element to elements in this series collection that are outside the specified numeric range and corresponding numeric element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element _
)
'Usage

Dim instance As SeriesCollection
Dim Low As Double
Dim High As Double
Dim ev As ElementValue
Dim defaultElement As Element

instance.SelectiveElementDefaults(Low, High, ev, defaultElement)
public void SelectiveElementDefaults(
   double Low,
   double High,
   ElementValue ev,
   Element defaultElement
)

Parameters

Low
Low value of the numeric range.
High
High value of the numeric range.
ev
A numeric element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > SelectiveElementDefaults Method : SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) Method
Low value of the numeric range.
High value of the numeric range.
A numeric element value property.
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
SelectiveElementDefaults(Double,Double,ElementValue,Element,Boolean) Method
Applies property settings of the specified default element to elements in this series collection that are outside the specified numeric range and corresponding numeric element property.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SelectiveElementDefaults( _
   ByVal Low As Double, _
   ByVal High As Double, _
   ByVal ev As ElementValue, _
   ByVal defaultElement As Element, _
   ByVal inclusive As Boolean _
)
'Usage

Dim instance As SeriesCollection
Dim Low As Double
Dim High As Double
Dim ev As ElementValue
Dim defaultElement As Element
Dim inclusive As Boolean

instance.SelectiveElementDefaults(Low, High, ev, defaultElement, inclusive)
public void SelectiveElementDefaults(
   double Low,
   double High,
   ElementValue ev,
   Element defaultElement,
   bool inclusive
)

Parameters

Low
Low value of the numeric range.
High
High value of the numeric range.
ev
A numeric element value property.
defaultElement
An Element object whose properties will be applied to elements in this series collection that meet the comparison criteria.
inclusive
Specifies whether to apply the provided element's properties to elements inside or outside the given range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : Sort Method
ElementValue to sort by.
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
Sort Method (SeriesCollection)
Sorts the Series based on an element property and order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Sort( _
   ByVal ev As ElementValue, _
   ByVal order As String _
)
'Usage

Dim instance As SeriesCollection
Dim ev As ElementValue
Dim order As String

instance.Sort(ev, order)
public void Sort(
   ElementValue ev,
   string order
)

Parameters

ev
ElementValue to sort by.
order
Takes "Desc" or "Asc" as inputs. If the string is not recognized "Asc" will be used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > SeriesCollection Class : SortElementGroups Method
SortElementGroups Method

Sorts element groups by their cummulative values. Element groups are defined as elements in different series which share the same names.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub SortElementGroups( _
   ByVal ev As ElementValue, _
   ByVal order As String _
)
'Usage

Dim instance As SeriesCollection
Dim ev As ElementValue
Dim order As String

instance.SortElementGroups(ev, order)
public void SortElementGroups(
   ElementValue ev,
   string order
)

Parameters

ev
order
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > SeriesCollection Class : ToString Method
ToString Method (SeriesCollection)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overrides Function ToString() As String
'Usage

Dim instance As SeriesCollection
Dim value As String

value = instance.ToString()
public override string ToString()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Base Implementation in ToString


dotnetCHARTING Namespace > SeriesCollection Class : Transpose Method
Transpose Method
Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.
Overload List
Overload | Description
Transpose() | Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.
Transpose(Axis) | Transposes the data bound to a specified axis. Data is transposed by converting the series in this collection to elements and the element groups into series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > SeriesCollection Class > Transpose Method : Transpose() Method
Transpose() Method
Transposes the data of this series collection. Data is transposed by converting the series in this collection to elements and the element groups into series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Transpose()
'Usage

Dim instance As SeriesCollection

instance.Transpose()
public void Transpose()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Transpose Method : Transpose(Axis) Method
The axis bound to data that is to be transposed.
Transpose(Axis) Method
Transposes the data bound to a specified axis. Data is transposed by converting the series in this collection to elements and the element groups into series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Transpose( _
   ByVal xAxis As Axis _
)
'Usage

Dim instance As SeriesCollection
Dim xAxis As Axis

instance.Transpose(xAxis)
public void Transpose(
   Axis xAxis
)

Parameters

xAxis
The axis bound to data that is to be transposed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : Trim Method
Trim Method (SeriesCollection)
Trims this SeriesCollection of elements leaving only the specified number of levels from the root element.
Overload List
Overload | Description
Trim(String,Boolean) |
Trim(Int32) | Trims this SeriesCollection of elements leaving only the specified number of levels from the root element.
Trim(Int32,Int32) |
Trim(Int32,Int32,Boolean) |
Trim(Element,Int32) |
Trim(Element,Int32,Boolean) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(String,Boolean) Method
A comma delimited list of node IDs that are expanded.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(String,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentIDList As String, _
   ByVal addAttributes As Boolean _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim parentIDList As String
Dim addAttributes As Boolean
Dim value As SeriesCollection

value = instance.Trim(parentIDList, addAttributes)
public SeriesCollection Trim(
   string parentIDList,
   bool addAttributes
)

Parameters

parentIDList
A comma delimited list of node IDs that are expanded.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(Int32) Method
Number of levels of children from the root element to return in the resulting SeriesCollection.
Trim(Int32) Method
Trims this SeriesCollection of elements leaving only the specified number of levels from the root element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal visibleLevels As Integer _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim visibleLevels As Integer
Dim value As SeriesCollection

value = instance.Trim(visibleLevels)
public SeriesCollection Trim(
   int visibleLevels
)

Parameters

visibleLevels
Number of levels of children from the root element to return in the resulting SeriesCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(Int32,Int32) Method
ID of the root element in the resulting SeriesCollection.
Number of levels of children from the root element to return in the resulting SeriesCollection.
Trim(Int32,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentID As Integer, _
   ByVal visibleLevels As Integer _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim parentID As Integer
Dim visibleLevels As Integer
Dim value As SeriesCollection

value = instance.Trim(parentID, visibleLevels)
public SeriesCollection Trim(
   int parentID,
   int visibleLevels
)

Parameters

parentID
ID of the root element in the resulting SeriesCollection.
visibleLevels
Number of levels of children from the root element to return in the resulting SeriesCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(Int32,Int32,Boolean) Method
ID of the root element in the resulting SeriesCollection.
Number of levels of children from the root element to return in the resulting SeriesCollection.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(Int32,Int32,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parentID As Integer, _
   ByVal visibleLevels As Integer, _
   ByVal addAttributes As Boolean _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim parentID As Integer
Dim visibleLevels As Integer
Dim addAttributes As Boolean
Dim value As SeriesCollection

value = instance.Trim(parentID, visibleLevels, addAttributes)
public SeriesCollection Trim(
   int parentID,
   int visibleLevels,
   bool addAttributes
)

Parameters

parentID
ID of the root element in the resulting SeriesCollection.
visibleLevels
Number of levels of children from the root element to return in the resulting SeriesCollection.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(Element,Int32) Method
The root element of the resulting SeriesCollection.
Number of levels of children from the root element to return in the resulting SeriesCollection.
Trim(Element,Int32) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parent As Element, _
   ByVal visibleLevels As Integer _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim parent As Element
Dim visibleLevels As Integer
Dim value As SeriesCollection

value = instance.Trim(parent, visibleLevels)
public SeriesCollection Trim(
   Element parent,
   int visibleLevels
)

Parameters

parent
The root element of the resulting SeriesCollection.
visibleLevels
Number of levels of children from the root element to return in the resulting SeriesCollection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Trim Method : Trim(Element,Int32,Boolean) Method
The root element of the resulting series.
Number of levels of children from the root element to return in the resulting series.
A bool value indicating whether custom attributes are added to describe the nodes.
Trim(Element,Int32,Boolean) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Trim( _
   ByVal parent As Element, _
   ByVal visibleLevels As Integer, _
   ByVal addAttributes As Boolean _
) As SeriesCollection
'Usage

Dim instance As SeriesCollection
Dim parent As Element
Dim visibleLevels As Integer
Dim addAttributes As Boolean
Dim value As SeriesCollection

value = instance.Trim(parent, visibleLevels, addAttributes)
public SeriesCollection Trim(
   Element parent,
   int visibleLevels,
   bool addAttributes
)

Parameters

parent
The root element of the resulting series.
visibleLevels
Number of levels of children from the root element to return in the resulting series.
addAttributes
A bool value indicating whether custom attributes are added to describe the nodes.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SeriesCollection Class
SeriesCollection Class Properties

For a list of all members of this type, see SeriesCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the Series at a specified index.
Public Property | SmartGrouping | Gets or sets a value that indicates whether smart element grouping is used or the traditional element name grouping is used where the elements of the first series determines the order.
Public Property | SmartPalette | Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.
Top
See Also

Reference

SeriesCollection Class
dotnetCHARTING Namespace

Tutorials

Data Tutorials


dotnetCHARTING Namespace > SeriesCollection Class : Item Property
Item Property (SeriesCollection)
Gets or sets the Series at a specified index.
Overload List
Overload | Description
Item(Int32) | Gets or sets the Series at a specified index.
Item(String) | Gets or sets the Series with the specified name.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


dotnetCHARTING Namespace > SeriesCollection Class > Item Property : Item(Int32) Property
Item(Int32) Property
Gets or sets the Series at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As Integer _
) As Series
'Usage

Dim instance As SeriesCollection
Dim index As Integer
Dim value As Series

instance.Item(index) = value

value = instance.Item(index)
public Series Item(
   int index
) {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class > Item Property : Item(String) Property
Item(String) Property
Gets or sets the Series with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal name As String _
) As Series
'Usage

Dim instance As SeriesCollection
Dim name As String
Dim value As Series

instance.Item(name) = value

value = instance.Item(name)
public Series Item(
   string name
) {get; set;}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members
Overload List


dotnetCHARTING Namespace > SeriesCollection Class : SmartGrouping Property
SmartGrouping Property
Gets or sets a value that indicates whether smart element grouping is used or the traditional element name grouping is used where the elements of the first series determines the order.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartGrouping As Boolean
'Usage

Dim instance As SeriesCollection
Dim value As Boolean

instance.SmartGrouping = value

value = instance.SmartGrouping
public bool SmartGrouping {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Sorting


dotnetCHARTING Namespace > SeriesCollection Class : SmartPalette Property
SmartPalette Property (SeriesCollection)
Gets or sets a SmartPalette object that will determine the colors of series in this SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SmartPalette As SmartPalette
'Usage

Dim instance As SeriesCollection
Dim value As SmartPalette

instance.SmartPalette = value

value = instance.SmartPalette
public SmartPalette SmartPalette {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Shadow Class
Shadow Class
Represents a shadow cast by chart objects such as a Box, Annotation, and others.
Object Model
Shadow Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Shadow
'Usage

Dim instance As Shadow
public class Shadow
Inheritance Hierarchy

System.Object
dotnetCHARTING.Shadow

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Members
dotnetCHARTING Namespace

Tutorials

Box Tutorial


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Shadow Class
Shadow Class Members

The following tables list the members exposed by Shadow.

Public Constructors
 | Name | Description
Public Constructor | Shadow Constructor |
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this shadow.
Public Property | Depth | Gets or sets the shadow's depth.
Public Property | ExpandBy | Gets or sets a numeric value that represents the number of pixels by which the shadow is expanded.
Public Property | Soft | Gets or sets a value which indicates whether this shadow is soft or solid.
Public Property | Visible | Gets or sets a value indicating whether this shadow is visible.
Top
See Also

Reference

Shadow Class
dotnetCHARTING Namespace

Tutorials

Box Tutorial


%%PageItemTitle%%

dotnetCHARTING Namespace > Shadow Class : Shadow Constructor
Shadow Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Shadow()
public Shadow()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Shadow Class
Shadow Class Properties

For a list of all members of this type, see Shadow members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the color of this shadow.
Public Property | Depth | Gets or sets the shadow's depth.
Public Property | ExpandBy | Gets or sets a numeric value that represents the number of pixels by which the shadow is expanded.
Public Property | Soft | Gets or sets a value which indicates whether this shadow is soft or solid.
Public Property | Visible | Gets or sets a value indicating whether this shadow is visible.
Top
See Also

Reference

Shadow Class
dotnetCHARTING Namespace

Tutorials

Box Tutorial


dotnetCHARTING Namespace > Shadow Class : Color Property
Color Property (Shadow)
Gets or sets the color of this shadow.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As Shadow
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Remarks
Making this color partially transparent will give the shadow a more realistic look.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members


dotnetCHARTING Namespace > Shadow Class : Depth Property
Depth Property (Shadow)
Gets or sets the shadow's depth.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Depth As Integer
'Usage

Dim instance As Shadow
Dim value As Integer

instance.Depth = value

value = instance.Depth
public int Depth {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members

Samples

orders3


dotnetCHARTING Namespace > Shadow Class : ExpandBy Property
ExpandBy Property
Gets or sets a numeric value that represents the number of pixels by which the shadow is expanded.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ExpandBy As Single
'Usage

Dim instance As Shadow
Dim value As Single

instance.ExpandBy = value

value = instance.ExpandBy
public float ExpandBy {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members


dotnetCHARTING Namespace > Shadow Class : Soft Property
Soft Property
Gets or sets a value which indicates whether this shadow is soft or solid.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Soft As Boolean
'Usage

Dim instance As Shadow
Dim value As Boolean

instance.Soft = value

value = instance.Soft
public bool Soft {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members


dotnetCHARTING Namespace > Shadow Class : Visible Property
Visible Property (Shadow)
Gets or sets a value indicating whether this shadow is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As Shadow
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shadow Class
Shadow Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : ShapeLabelCollection Class
ShapeLabelCollection Class
Contains a collection of Label objects.
Object Model
ShapeLabelCollection ClassLabel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ShapeLabelCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As ShapeLabelCollection
public class ShapeLabelCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.ShapeLabelCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : ShapeLabelCollection Class
ShapeLabelCollection Class Members

The following tables list the members exposed by ShapeLabelCollection.

Public Constructors
 | Name | Description
Public Constructor | ShapeLabelCollection Constructor | Creates a new instance of ShapeLabelCollection with the specified list of Label objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ShapeLabelCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Label.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Label in this collection.
Public Method | Insert | Inserts a Label into this collection at a specified index.
Public Method | Remove | Removes a specified Label from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ShapeLabelCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > ShapeLabelCollection Class : ShapeLabelCollection Constructor
ShapeLabelCollection Constructor
Creates a new instance of ShapeLabelCollection with the specified list of Label objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray labelList() As Label _
)
'Usage

Dim labelList() As Label

Dim instance As New ShapeLabelCollection(labelList)
public ShapeLabelCollection(
   params Label[] labelList
)

Parameters

labelList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : ShapeLabelCollection Class
ShapeLabelCollection Class Methods

For a list of all members of this type, see ShapeLabelCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified ShapeLabelCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Label.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Label in this collection.
Public Method | Insert | Inserts a Label into this collection at a specified index.
Public Method | Remove | Removes a specified Label from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

ShapeLabelCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ShapeLabelCollection Class : Add Method
Add Method (ShapeLabelCollection)
Adds a specified ShapeLabelCollection to this collection.
Overload List
Overload | Description
Add(Label) |
Add(ShapeLabelCollection) | Adds a specified ShapeLabelCollection to this collection.
Add(Label[]) | Adds the specified Label objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


dotnetCHARTING Namespace > ShapeLabelCollection Class > Add Method : Add(Label) Method
Add(Label) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal label As Label _
) As Integer
'Usage

Dim instance As ShapeLabelCollection
Dim label As Label
Dim value As Integer

value = instance.Add(label)
public int Add(
   Label label
)

Parameters

label
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members
Overload List


dotnetCHARTING Namespace > ShapeLabelCollection Class > Add Method : Add(ShapeLabelCollection) Method
The ShapeLabelCollection to add.
Add(ShapeLabelCollection) Method
Adds a specified ShapeLabelCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal shapeLabelCollection As ShapeLabelCollection _
)
'Usage

Dim instance As ShapeLabelCollection
Dim shapeLabelCollection As ShapeLabelCollection

instance.Add(shapeLabelCollection)
public void Add(
   ShapeLabelCollection shapeLabelCollection
)

Parameters

shapeLabelCollection
The ShapeLabelCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members
Overload List


dotnetCHARTING Namespace > ShapeLabelCollection Class > Add Method : Add(Label[]) Method
A list of Label objects to add.
Add(Label[]) Method
Adds the specified Label objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray labelList() As Label _
)
'Usage

Dim instance As ShapeLabelCollection
Dim labelList() As Label

instance.Add(labelList)
public void Add(
   params Label[] labelList
)

Parameters

labelList
A list of Label objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members
Overload List


dotnetCHARTING Namespace > ShapeLabelCollection Class : Contains Method
The Label to find.
Contains Method (ShapeLabelCollection)
Determines whether this collection contains a specified Label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal label As Label _
) As Boolean
'Usage

Dim instance As ShapeLabelCollection
Dim label As Label
Dim value As Boolean

value = instance.Contains(label)
public bool Contains(
   Label label
)

Parameters

label
The Label to find.

Return Value

true if the specified Label belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


dotnetCHARTING Namespace > ShapeLabelCollection Class : IndexOf Method
The Label to find.
IndexOf Method (ShapeLabelCollection)
Determines the index of a specified Label in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal label As Label _
) As Integer
'Usage

Dim instance As ShapeLabelCollection
Dim label As Label
Dim value As Integer

value = instance.IndexOf(label)
public int IndexOf(
   Label label
)

Parameters

label
The Label to find.

Return Value

The zero-based index of the specified Label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


dotnetCHARTING Namespace > ShapeLabelCollection Class : Insert Method
The zero-based index into the collection at which to insert the Label.
The Label to insert into this collection.
Insert Method (ShapeLabelCollection)
Inserts a Label into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal label As Label _
)
'Usage

Dim instance As ShapeLabelCollection
Dim index As Integer
Dim label As Label

instance.Insert(index, label)
public void Insert(
   int index,
   Label label
)

Parameters

index
The zero-based index into the collection at which to insert the Label.
label
The Label to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


dotnetCHARTING Namespace > ShapeLabelCollection Class : Remove Method
The Label to remove.
Remove Method (ShapeLabelCollection)
Removes a specified Label from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal label As Label _
)
'Usage

Dim instance As ShapeLabelCollection
Dim label As Label

instance.Remove(label)
public void Remove(
   Label label
)

Parameters

label
The Label to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ShapeLabelCollection Class
ShapeLabelCollection Class Properties

For a list of all members of this type, see ShapeLabelCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

ShapeLabelCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ShapeLabelCollection Class : Item Property
Item Property (ShapeLabelCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As Label
'Usage

Dim instance As ShapeLabelCollection
Dim index As Integer
Dim value As Label

instance.Item(index) = value

value = instance.Item(index)
public Label this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeLabelCollection Class
ShapeLabelCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SmartColor Class
SmartColor Class
Defines a SmartColor object that can be used applied to elements or series conditionally based on specific names or elements with values which fall within a specified range.
Object Model
SmartColor ClassLegendEntry ClassScaleRange Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SmartColor
'Usage

Dim instance As SmartColor
public class SmartColor
Example
SmartColorGradient
MapSmartPalette
SmartPaletteRange
Inheritance Hierarchy

System.Object
dotnetCHARTING.SmartColor

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Members
dotnetCHARTING Namespace

Tutorials

Coloring Elements


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : SmartColor Class
SmartColor Class Members

The following tables list the members exposed by SmartColor.

Public Constructors
 | Name | Description
Public Constructor | SmartColor Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Color | Gets or sets the Color of this SmartColor object.
Public Property | ColorSecondary | Gets or sets a secondary Color object. When set, it will represent the high range of the specified ScaleRange coloring elements based on a gradient from ScaleRange.Low/SmartColor.Color to ScaleRange.High/SmartColor.SecondaryColor.
Public Property | ElementValue | Gets or sets the ElementValue that is used with this.ScaleRange to determine if elements use this color.
Public Property | LegendEntry | Gets or sets a LegendEntry that describes this object's color in the legend box.
Public Property | ScaleRange | Gets or sets the ScaleRange used with this.ElementValue to determine if elements use this color.
Top
See Also

Reference

SmartColor Class
dotnetCHARTING Namespace

Tutorials

Coloring Elements


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class : SmartColor Constructor
SmartColor Constructor
Overload List
Overload | Description
SmartColor Constructor() | Initializes a new instance of the SmartColor object.
SmartColor Constructor(Color,ScaleRange) | Initializes a new instance of the SmartColor object with a color and scale range. By default this will check element's YValue to determine whether they inherit this color.
SmartColor Constructor(Color,ScaleRange,ElementValue) | Initializes a new instance of the SmartColor object with a color and scale range. This will check element's specified attribute to determine whether it inherits this color.
SmartColor Constructor(Color,Color,ScaleRange) | Initializes a new instance of the SmartColor object with a gradient consisting of two colors and scale range. By default this will check element's YValue to determine whether the element is colored based on this SmartColor.
SmartColor Constructor(Color,Color,ScaleRange,ElementValue) | Initializes a new instance of the SmartColor object with a gradient consisting of two colors and scale range. By default this will check element's YValue to determine whether the element is colored based on this SmartColor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class > SmartColor Constructor : SmartColor Constructor()
SmartColor Constructor()
Initializes a new instance of the SmartColor object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New SmartColor()
public SmartColor()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class > SmartColor Constructor : SmartColor Constructor(Color,ScaleRange)
SmartColor's main color.
Y value range criteria for elements.
SmartColor Constructor(Color,ScaleRange)
Initializes a new instance of the SmartColor object with a color and scale range. By default this will check element's YValue to determine whether they inherit this color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal range As ScaleRange _
)
'Usage

Dim color As Color
Dim range As ScaleRange

Dim instance As New SmartColor(color, range)
public SmartColor(
   Color color,
   ScaleRange range
)

Parameters

color
SmartColor's main color.
range
Y value range criteria for elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class > SmartColor Constructor : SmartColor Constructor(Color,ScaleRange,ElementValue)
SmartColor's main color.
Value range criteria for elements matching the elementValue of each element.
Element value used to compare against the scale range to determine if an element uses this SmartColor.
SmartColor Constructor(Color,ScaleRange,ElementValue)
Initializes a new instance of the SmartColor object with a color and scale range. This will check element's specified attribute to determine whether it inherits this color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal range As ScaleRange, _
   ByVal elementValue As ElementValue _
)
'Usage

Dim color As Color
Dim range As ScaleRange
Dim elementValue As ElementValue

Dim instance As New SmartColor(color, range, elementValue)
public SmartColor(
   Color color,
   ScaleRange range,
   ElementValue elementValue
)

Parameters

color
SmartColor's main color.
range
Value range criteria for elements matching the elementValue of each element.
elementValue
Element value used to compare against the scale range to determine if an element uses this SmartColor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class > SmartColor Constructor : SmartColor Constructor(Color,Color,ScaleRange)
SmartColor's main color.
Secondary color. When used, this is a gradient SmartColor and elements are colored with colors ranging from the main to the secondary color depending on the element values.
Value range criteria for elements matching the elementValue of each element.
SmartColor Constructor(Color,Color,ScaleRange)
Initializes a new instance of the SmartColor object with a gradient consisting of two colors and scale range. By default this will check element's YValue to determine whether the element is colored based on this SmartColor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal colorSecondary As Color, _
   ByVal range As ScaleRange _
)
'Usage

Dim color As Color
Dim colorSecondary As Color
Dim range As ScaleRange

Dim instance As New SmartColor(color, colorSecondary, range)
public SmartColor(
   Color color,
   Color colorSecondary,
   ScaleRange range
)

Parameters

color
SmartColor's main color.
colorSecondary
Secondary color. When used, this is a gradient SmartColor and elements are colored with colors ranging from the main to the secondary color depending on the element values.
range
Value range criteria for elements matching the elementValue of each element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartColor Class > SmartColor Constructor : SmartColor Constructor(Color,Color,ScaleRange,ElementValue)
SmartColor's main color.
Secondary color. When used, this is a gradient SmartColor and elements are colored with colors ranging from the main to the secondary color depending on the element values.
Value range criteria for elements matching the elementValue of each element.
Element value used to compare against the scale range to determine if an element uses this SmartColor.
SmartColor Constructor(Color,Color,ScaleRange,ElementValue)
Initializes a new instance of the SmartColor object with a gradient consisting of two colors and scale range. By default this will check element's YValue to determine whether the element is colored based on this SmartColor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal color As Color, _
   ByVal colorSecondary As Color, _
   ByVal range As ScaleRange, _
   ByVal elementValue As ElementValue _
)
'Usage

Dim color As Color
Dim colorSecondary As Color
Dim range As ScaleRange
Dim elementValue As ElementValue

Dim instance As New SmartColor(color, colorSecondary, range, elementValue)
public SmartColor(
   Color color,
   Color colorSecondary,
   ScaleRange range,
   ElementValue elementValue
)

Parameters

color
SmartColor's main color.
colorSecondary
Secondary color. When used, this is a gradient SmartColor and elements are colored with colors ranging from the main to the secondary color depending on the element values.
range
Value range criteria for elements matching the elementValue of each element.
elementValue
Element value used to compare against the scale range to determine if an element uses this SmartColor.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SmartColor Class
SmartColor Class Properties

For a list of all members of this type, see SmartColor members.

Public Properties
 | Name | Description
Public Property | Color | Gets or sets the Color of this SmartColor object.
Public Property | ColorSecondary | Gets or sets a secondary Color object. When set, it will represent the high range of the specified ScaleRange coloring elements based on a gradient from ScaleRange.Low/SmartColor.Color to ScaleRange.High/SmartColor.SecondaryColor.
Public Property | ElementValue | Gets or sets the ElementValue that is used with this.ScaleRange to determine if elements use this color.
Public Property | LegendEntry | Gets or sets a LegendEntry that describes this object's color in the legend box.
Public Property | ScaleRange | Gets or sets the ScaleRange used with this.ElementValue to determine if elements use this color.
Top
See Also

Reference

SmartColor Class
dotnetCHARTING Namespace

Tutorials

Coloring Elements


dotnetCHARTING Namespace > SmartColor Class : Color Property
Color Property (SmartColor)
Gets or sets the Color of this SmartColor object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Color As Color
'Usage

Dim instance As SmartColor
Dim value As Color

instance.Color = value

value = instance.Color
public Color Color {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


dotnetCHARTING Namespace > SmartColor Class : ColorSecondary Property
ColorSecondary Property
Gets or sets a secondary Color object. When set, it will represent the high range of the specified ScaleRange coloring elements based on a gradient from ScaleRange.Low/SmartColor.Color to ScaleRange.High/SmartColor.SecondaryColor.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ColorSecondary As Color
'Usage

Dim instance As SmartColor
Dim value As Color

instance.ColorSecondary = value

value = instance.ColorSecondary
public Color ColorSecondary {get; set;}
Example
SmartColorGradient
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


dotnetCHARTING Namespace > SmartColor Class : ElementValue Property
ElementValue Property
Gets or sets the ElementValue that is used with this.ScaleRange to determine if elements use this color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ElementValue As ElementValue
'Usage

Dim instance As SmartColor
Dim value As ElementValue

instance.ElementValue = value

value = instance.ElementValue
public ElementValue ElementValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


dotnetCHARTING Namespace > SmartColor Class : LegendEntry Property
LegendEntry Property (SmartColor)
Gets or sets a LegendEntry that describes this object's color in the legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendEntry As LegendEntry
'Usage

Dim instance As SmartColor
Dim value As LegendEntry

instance.LegendEntry = value

value = instance.LegendEntry
public LegendEntry LegendEntry {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


dotnetCHARTING Namespace > SmartColor Class : ScaleRange Property
ScaleRange Property (SmartColor)
Gets or sets the ScaleRange used with this.ElementValue to determine if elements use this color.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleRange As ScaleRange
'Usage

Dim instance As SmartColor
Dim value As ScaleRange

instance.ScaleRange = value

value = instance.ScaleRange
public ScaleRange ScaleRange {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartColor Class
SmartColor Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SmartLabel Class
SmartLabel Class
Encapsulates a Label object with advanced alignment and collision detection options.
Object Model
SmartLabel ClassLabelAlignmentCollection ClassLabelAlignment EnumerationHotspot ClassLine ClassShadow ClassTruncation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SmartLabel
   Inherits Label
'Usage

Dim instance As SmartLabel
public class SmartLabel : Label
Inheritance Hierarchy

System.Object
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Members
dotnetCHARTING Namespace
Using Labels

Reference

Token Reference

Tutorials

Label Alignment and Control
Formatting Values
Formatting Advanced


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : SmartLabel Class
SmartLabel Class Members

The following tables list the members exposed by SmartLabel.

Public Constructors
 | Name | Description
Public Constructor | SmartLabel Constructor | Initializes a new instance of the SmartLabel class.
Top
Public Properties
 | Name | Description
Public Property | AbsolutePosition | Gets or sets the absolute position of the smart label specified by a Point object.
Public Property | Alignment | Gets or sets the primary label alignment.
Public Property | AlignmentSecondary | Gets or sets a collection of secondary label alignment options.
Public Property | AllowMarkerOverlap | Gets or sets a value that indicates whether smart labels are allowed to be positioned on top of element markers. This property should be set at the Chart.DefaultElement.SmartLabel property level.
Public Property | AutoWrap | Gets or sets a value that specifies whether this label will automatically wrap if it gets too long. This feature allows the chart to maintain the largest possible area for chart data. (Inherited from dotnetCHARTING.Label)
Public Property | Color | Gets or sets the color of this label. (Inherited from dotnetCHARTING.Label)
Public Property | DistanceMaximum | Gets or sets the maximum distance a label is allowed to be moved by DynaicPosition away from the element it is labeling.
Public Property | DynamicDisplay | Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.
Public Property | DynamicPosition | Gets or sets a value that indicates whether the label will be positioned using collision detection.
Public Property | Font | Gets or sets the font for this label. (Inherited from dotnetCHARTING.Label)
Public Property | ForceVertical | Gets or sets a value that indicates whether the label is forced to be drawn vertically.
Public Property | GlowColor | Gets or sets a Color used to create a glow effect around the drawn text. (Inherited from dotnetCHARTING.Label)
Public Property | Hotspot | Gets or sets the Hotspot of this Label. (Inherited from dotnetCHARTING.Label)
Public Property | Line | Gets or sets a Line object that facilitates the DynamicPosition functionality.
Public Property | LineAlignment | Gets or sets the line alignment of this label. (Inherited from dotnetCHARTING.Label)
Public Property | MaxWidth | (JS Charts Only) Specifies the maximum width of a label. If the label is wider than this width it will attempt to wrap. (Inherited from dotnetCHARTING.Label)
Public Property | Offset | (JS Chart Only) Gets or sets a label offset in pixels when used with JS charts. (Inherited from dotnetCHARTING.Label)
Public Property | OutlineColor | Gets or sets to color used to outline this label's text. (Inherited from dotnetCHARTING.Label)
Public Property | Padding | Gets or sets the minimum amount of space between this label, other labels, and the element the label represents.
Public Property | PieLabelMode | Gets or sets a PieLabelMode enumeration for pie and donut charts.
Public Property | Placement | (JS Charts Only) Specifies if a label should be drawn inside or outside an object. Used with Series.ShapeLabels and with Element.SmartLabel. (Inherited from dotnetCHARTING.Label)
Public Property | RadarLabelMode | Gets or sets a RadarLabelMode enumeration for radar charts.
Public Property | Shadow | Gets or sets a Shadow object used to cast a shadow for this label's text. (Inherited from dotnetCHARTING.Label)
Public Property | Text | Gets or sets the text for this label. (Inherited from dotnetCHARTING.Label)
Public Property | Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length. (Inherited from dotnetCHARTING.Label)
Public Property | Type | Gets or sets a LabelType enumeration member which specifies the type of font used. (Inherited from dotnetCHARTING.Label)
Public Property | Width | (JS Chart Only) Gets or sets the width of this label when used with JS charts. (Inherited from dotnetCHARTING.Label)
Top
Public Methods
 | Name | Description
Public Method | Dispose | (Inherited from dotnetCHARTING.Label)
Public Method | ToString | (Inherited from dotnetCHARTING.Label)
Top
See Also

Reference

SmartLabel Class
dotnetCHARTING Namespace
Using Labels

Reference

Token Reference

Tutorials

Label Alignment and Control
Formatting Values
Formatting Advanced


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartLabel Class : SmartLabel Constructor
SmartLabel Constructor
Initializes a new instance of the SmartLabel class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New SmartLabel()
public SmartLabel()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SmartLabel Class
SmartLabel Class Properties

For a list of all members of this type, see SmartLabel members.

Public Properties
 | Name | Description
Public Property | AbsolutePosition | Gets or sets the absolute position of the smart label specified by a Point object.
Public Property | Alignment | Gets or sets the primary label alignment.
Public Property | AlignmentSecondary | Gets or sets a collection of secondary label alignment options.
Public Property | AllowMarkerOverlap | Gets or sets a value that indicates whether smart labels are allowed to be positioned on top of element markers. This property should be set at the Chart.DefaultElement.SmartLabel property level.
Public Property | AutoWrap | Gets or sets a value that specifies whether this label will automatically wrap if it gets too long. This feature allows the chart to maintain the largest possible area for chart data. (Inherited from dotnetCHARTING.Label)
Public Property | Color | Gets or sets the color of this label. (Inherited from dotnetCHARTING.Label)
Public Property | DistanceMaximum | Gets or sets the maximum distance a label is allowed to be moved by DynaicPosition away from the element it is labeling.
Public Property | DynamicDisplay | Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.
Public Property | DynamicPosition | Gets or sets a value that indicates whether the label will be positioned using collision detection.
Public Property | Font | Gets or sets the font for this label. (Inherited from dotnetCHARTING.Label)
Public Property | ForceVertical | Gets or sets a value that indicates whether the label is forced to be drawn vertically.
Public Property | GlowColor | Gets or sets a Color used to create a glow effect around the drawn text. (Inherited from dotnetCHARTING.Label)
Public Property | Hotspot | Gets or sets the Hotspot of this Label. (Inherited from dotnetCHARTING.Label)
Public Property | Line | Gets or sets a Line object that facilitates the DynamicPosition functionality.
Public Property | LineAlignment | Gets or sets the line alignment of this label. (Inherited from dotnetCHARTING.Label)
Public Property | MaxWidth | (JS Charts Only) Specifies the maximum width of a label. If the label is wider than this width it will attempt to wrap. (Inherited from dotnetCHARTING.Label)
Public Property | Offset | (JS Chart Only) Gets or sets a label offset in pixels when used with JS charts. (Inherited from dotnetCHARTING.Label)
Public Property | OutlineColor | Gets or sets to color used to outline this label's text. (Inherited from dotnetCHARTING.Label)
Public Property | Padding | Gets or sets the minimum amount of space between this label, other labels, and the element the label represents.
Public Property | PieLabelMode | Gets or sets a PieLabelMode enumeration for pie and donut charts.
Public Property | Placement | (JS Charts Only) Specifies if a label should be drawn inside or outside an object. Used with Series.ShapeLabels and with Element.SmartLabel. (Inherited from dotnetCHARTING.Label)
Public Property | RadarLabelMode | Gets or sets a RadarLabelMode enumeration for radar charts.
Public Property | Shadow | Gets or sets a Shadow object used to cast a shadow for this label's text. (Inherited from dotnetCHARTING.Label)
Public Property | Text | Gets or sets the text for this label. (Inherited from dotnetCHARTING.Label)
Public Property | Truncation | Gets or sets properties used to dynamically shorten this label when it reaches a maximum length. (Inherited from dotnetCHARTING.Label)
Public Property | Type | Gets or sets a LabelType enumeration member which specifies the type of font used. (Inherited from dotnetCHARTING.Label)
Public Property | Width | (JS Chart Only) Gets or sets the width of this label when used with JS charts. (Inherited from dotnetCHARTING.Label)
Top
See Also

Reference

SmartLabel Class
dotnetCHARTING Namespace
Using Labels

Reference

Token Reference

Tutorials

Label Alignment and Control
Formatting Values
Formatting Advanced


dotnetCHARTING Namespace > SmartLabel Class : AbsolutePosition Property
AbsolutePosition Property
Gets or sets the absolute position of the smart label specified by a Point object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AbsolutePosition As Point
'Usage

Dim instance As SmartLabel
Dim value As Point

instance.AbsolutePosition = value

value = instance.AbsolutePosition
public Point AbsolutePosition {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members

Tutorials

Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : Alignment Property
Alignment Property (SmartLabel)
Gets or sets the primary label alignment.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Alignment As LabelAlignment
'Usage

Dim instance As SmartLabel
Dim value As LabelAlignment

instance.Alignment = value

value = instance.Alignment
public new LabelAlignment Alignment {get; set;}
Remarks
If the labels doesn't fit well given this alignment, alignments in the AlighmentSecondary collection are iterated (when DynamicDisplay is true) to find the first position that fits correctly.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members

Tutorials

Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : AlignmentSecondary Property
AlignmentSecondary Property
Gets or sets a collection of secondary label alignment options.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AlignmentSecondary As LabelAlignmentCollection
'Usage

Dim instance As SmartLabel
Dim value As LabelAlignmentCollection

value = instance.AlignmentSecondary
public LabelAlignmentCollection AlignmentSecondary {get;}
Remarks
When the primary Alignment option does not permit the room necessary to draw this label, the alignment options in this collection are iterated to find one that fits.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members
Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : AllowMarkerOverlap Property
AllowMarkerOverlap Property
Gets or sets a value that indicates whether smart labels are allowed to be positioned on top of element markers. This property should be set at the Chart.DefaultElement.SmartLabel property level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AllowMarkerOverlap As Boolean
'Usage

Dim instance As SmartLabel
Dim value As Boolean

instance.AllowMarkerOverlap = value

value = instance.AllowMarkerOverlap
public bool AllowMarkerOverlap {get; set;}
Remarks
Note: This feature incures a performance cost when many markers and labels are present. Setting this property to true may improve performance in some instances. When this feature is not used, the labels will still try to avoid markers, however, overlap may occur.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members

Tutorials

Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : DistanceMaximum Property
DistanceMaximum Property
Gets or sets the maximum distance a label is allowed to be moved by DynaicPosition away from the element it is labeling.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DistanceMaximum As Integer
'Usage

Dim instance As SmartLabel
Dim value As Integer

instance.DistanceMaximum = value

value = instance.DistanceMaximum
public int DistanceMaximum {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members
Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : DynamicDisplay Property
DynamicDisplay Property
Gets or sets a value that indicates whether the label is forced to be drawn even when there is no room. False means labels are always drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicDisplay As Boolean
'Usage

Dim instance As SmartLabel
Dim value As Boolean

instance.DynamicDisplay = value

value = instance.DynamicDisplay
public bool DynamicDisplay {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members
Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : DynamicPosition Property
DynamicPosition Property
Gets or sets a value that indicates whether the label will be positioned using collision detection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DynamicPosition As Boolean
'Usage

Dim instance As SmartLabel
Dim value As Boolean

instance.DynamicPosition = value

value = instance.DynamicPosition
public bool DynamicPosition {get; set;}
Remarks
This causes the labels to be conscious of each other and does not permit them to overlap. When a label is positioned away from the data point it represents, the SmartLabel.Line is drawn from the label's new position to the data point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members
Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : ForceVertical Property
ForceVertical Property
Gets or sets a value that indicates whether the label is forced to be drawn vertically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ForceVertical As Boolean
'Usage

Dim instance As SmartLabel
Dim value As Boolean

instance.ForceVertical = value

value = instance.ForceVertical
public bool ForceVertical {get; set;}
Remarks
When false, labels will be drawn vertically only on columns and cylinders that are not wide enough to fit the label horizontally. Otherwise, all labels will be vertical.
Example
InteractiveUnitConversion
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members


dotnetCHARTING Namespace > SmartLabel Class : Line Property
Line Property (SmartLabel)
Gets or sets a Line object that facilitates the DynamicPosition functionality.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As SmartLabel
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Remarks
Lines are used to point to an element when a label can not be placed directly beside it.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members


dotnetCHARTING Namespace > SmartLabel Class : Padding Property
Padding Property (SmartLabel)
Gets or sets the minimum amount of space between this label, other labels, and the element the label represents.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Padding As Integer
'Usage

Dim instance As SmartLabel
Dim value As Integer

instance.Padding = value

value = instance.Padding
public int Padding {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members
Label Alignment and Control


dotnetCHARTING Namespace > SmartLabel Class : PieLabelMode Property
PieLabelMode Property (SmartLabel)
Gets or sets a PieLabelMode enumeration for pie and donut charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PieLabelMode As PieLabelMode
'Usage

Dim instance As SmartLabel
Dim value As PieLabelMode

instance.PieLabelMode = value

value = instance.PieLabelMode
public PieLabelMode PieLabelMode {get; set;}
Remarks
This setting will only apply when set through the Chart.DefaultSeries.DefaultElement.SmartLabel instance.
Example
PieLabelSmartWraping
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members


dotnetCHARTING Namespace > SmartLabel Class : RadarLabelMode Property
RadarLabelMode Property (SmartLabel)
Gets or sets a RadarLabelMode enumeration for radar charts.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property RadarLabelMode As RadarLabelMode
'Usage

Dim instance As SmartLabel
Dim value As RadarLabelMode

instance.RadarLabelMode = value

value = instance.RadarLabelMode
public RadarLabelMode RadarLabelMode {get; set;}
Remarks
This setting will only apply when set through the Chart.DefaultSeries.DefaultElement.SmartLabel instance.
Example
Gallery/d04
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartLabel Class
SmartLabel Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SmartPalette Class
SmartPalette Class
Contains collection of SmartPalette objects or dictionary like items of string and color pairs where strings refer to series or element names and colors that are assigned to series or elements with those names.
Object Model
SmartPalette Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SmartPalette
   Inherits System.Collections.Specialized.NameObjectCollectionBase
'Usage

Dim instance As SmartPalette
public class SmartPalette : System.Collections.Specialized.NameObjectCollectionBase
Remarks
This object can be saved as XML and loaded for any other charts to use. To use a SmartPalette with a given chart, it to the Chart.SmartPalette property.
Example
SmartPalette
SmartPaletteAutoSync
SmartPaletteRange
MapSmartPalette
Inheritance Hierarchy

System.Object
System.Collections.Specialized.NameObjectCollectionBase
dotnetCHARTING.SmartPalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Members
dotnetCHARTING Namespace

Tutorial

Element Colors and Palettes


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : SmartPalette Class
SmartPalette Class Members

The following tables list the members exposed by SmartPalette.

Public Constructors
 | Name | Description
Public Constructor | SmartPalette Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | AllKeys | Gets a String array containing all the keys (series or element names) in the SmartPalette.
Public Property | AllValues | Gets a Color array containing all the values (series / element colors) in the SmartPalette.
Public Property | Count | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | HasKeys | Gets a value indicating whether the SmartPalette has entries.
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key.
Public Property | Keys | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified key and color item to this palette.
Public Method | Clear | Clears the SmartPalette.
static (Shared in Visual Basic) | FromColors | Creates a SmartPalette with range colors based on the specified element value and colors.
static (Shared in Visual Basic) | FromColorsRange | Overloaded. Generates a SmartPalette based on the specified element value, element value range, and colors.
Public Method | GetEnumerator | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetObjectData | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetScaleRange | Get a ScaleRange object representing the union of all value ranges defined by colors that match the specified key.
Public Method | GetValueColor | Get the thematic color based on the key and values of smartPalettes..
Public Method | LoadState | Imports a SmartPalette object from the specified xml file.
Public Method | OnDeserialization | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Overloaded. Removes an entry with the specified key from the collection.
Public Method | SaveState | Overloaded. Saves the SmartPalette instance to an xml file.
Top
See Also

Reference

SmartPalette Class
dotnetCHARTING Namespace

Tutorial

Element Colors and Palettes


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartPalette Class : SmartPalette Constructor
SmartPalette Constructor
Overload List
Overload | Description
SmartPalette Constructor() | Initializes a new instance of the SmartPalette object.
SmartPalette Constructor(String) | Initializes a new instance of the SmartPalette object from xml data or filename.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartPalette Class > SmartPalette Constructor : SmartPalette Constructor()
SmartPalette Constructor()
Initializes a new instance of the SmartPalette object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New SmartPalette()
public SmartPalette()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > SmartPalette Class > SmartPalette Constructor : SmartPalette Constructor(String)
Xml data or filename of the stored smart palette.
SmartPalette Constructor(String)
Initializes a new instance of the SmartPalette object from xml data or filename.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xmlDataOrFileName As String _
)
'Usage

Dim xmlDataOrFileName As String

Dim instance As New SmartPalette(xmlDataOrFileName)
public SmartPalette(
   string xmlDataOrFileName
)

Parameters

xmlDataOrFileName
Xml data or filename of the stored smart palette.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : SmartPalette Class
SmartPalette Class Methods

For a list of all members of this type, see SmartPalette members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds the specified key and color item to this palette.
Public Method | Clear | Clears the SmartPalette.
static (Shared in Visual Basic) | FromColors | Creates a SmartPalette with range colors based on the specified element value and colors.
static (Shared in Visual Basic) | FromColorsRange | Overloaded. Generates a SmartPalette based on the specified element value, element value range, and colors.
Public Method | GetEnumerator | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetObjectData | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | GetScaleRange | Get a ScaleRange object representing the union of all value ranges defined by colors that match the specified key.
Public Method | GetValueColor | Get the thematic color based on the key and values of smartPalettes..
Public Method | LoadState | Imports a SmartPalette object from the specified xml file.
Public Method | OnDeserialization | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Method | Remove | Overloaded. Removes an entry with the specified key from the collection.
Public Method | SaveState | Overloaded. Saves the SmartPalette instance to an xml file.
Top
See Also

Reference

SmartPalette Class
dotnetCHARTING Namespace

Tutorial

Element Colors and Palettes


dotnetCHARTING Namespace > SmartPalette Class : Add Method
Add Method (SmartPalette)
Adds the specified key and color item to this palette.
Overload List
Overload | Description
Add(String,Color) | Adds the specified key and color item to this palette.
Add(String,SmartColor) | Adds the specified key and smart color item to this palette.
Add(SmartPalette) | Adds the items in the specified palette to this palette.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class > Add Method : Add(String,Color) Method
Name of series this palette will affect. A '*' wildcard can be used to affect all series regardless of their name.
Color
Add(String,Color) Method
Adds the specified key and color item to this palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal key As String, _
   ByVal value As Color _
)
'Usage

Dim instance As SmartPalette
Dim key As String
Dim value As Color

instance.Add(key, value)
public void Add(
   string key,
   Color value
)

Parameters

key
Name of series this palette will affect. A '*' wildcard can be used to affect all series regardless of their name.
value
Color
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > Add Method : Add(String,SmartColor) Method
Name of series this palette will affect. A '*' wildcard can be used to affect all series regardless of their name.
Smart color used.
Add(String,SmartColor) Method
Adds the specified key and smart color item to this palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal key As String, _
   ByVal value As SmartColor _
)
'Usage

Dim instance As SmartPalette
Dim key As String
Dim value As SmartColor

instance.Add(key, value)
public void Add(
   string key,
   SmartColor value
)

Parameters

key
Name of series this palette will affect. A '*' wildcard can be used to affect all series regardless of their name.
value
Smart color used.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > Add Method : Add(SmartPalette) Method
Source palette.
Add(SmartPalette) Method
Adds the items in the specified palette to this palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal palette As SmartPalette _
)
'Usage

Dim instance As SmartPalette
Dim palette As SmartPalette

instance.Add(palette)
public void Add(
   SmartPalette palette
)

Parameters

palette
Source palette.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class : Clear Method
Clear Method (SmartPalette)
Clears the SmartPalette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Clear()
'Usage

Dim instance As SmartPalette

instance.Clear()
public void Clear()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : FromColors(ElementValue,Color[]) Method
Element value on which element coloring is based.
Colors to base SmartColors on.
FromColors(ElementValue,Color[]) Method
Creates a SmartPalette with range colors based on the specified element value and colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromColors( _
   ByVal ev As ElementValue, _
   ByVal ParamArray colors() As Color _
) As SmartPalette
'Usage

Dim ev As ElementValue
Dim colors() As Color
Dim value As SmartPalette

value = SmartPalette.FromColors(ev, colors)
public static SmartPalette FromColors(
   ElementValue ev,
   params Color[] colors
)

Parameters

ev
Element value on which element coloring is based.
colors
Colors to base SmartColors on.

Return Value

The resulting smartPalette will be empty. The value ranges for the individual SmartColors will be evaluated at run-time.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : FromColorsRange Method
FromColorsRange Method
Generates a SmartPalette based on the specified element value, element value range, and colors.
Overload List
Overload | Description
FromColorsRange(ElementValue,ScaleRange,Color[]) | Generates a SmartPalette based on the specified element value, element value range, and colors.
FromColorsRange(String,ElementValue,ScaleRange,Color[]) | Generates a SmartPalette with range colors for series or elements with a specific name. It is based on the specified element value, element value range, and colors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class > FromColorsRange Method : FromColorsRange(ElementValue,ScaleRange,Color[]) Method
Element value on which element coloring is based.
ScaleRange that specifies the minimum and maximum range of the element value to include in the palette.
Colors to base SmartColors on.
FromColorsRange(ElementValue,ScaleRange,Color[]) Method
Generates a SmartPalette based on the specified element value, element value range, and colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromColorsRange( _
   ByVal ev As ElementValue, _
   ByVal sr As ScaleRange, _
   ByVal ParamArray colors() As Color _
) As SmartPalette
'Usage

Dim ev As ElementValue
Dim sr As ScaleRange
Dim colors() As Color
Dim value As SmartPalette

value = SmartPalette.FromColorsRange(ev, sr, colors)
public static SmartPalette FromColorsRange(
   ElementValue ev,
   ScaleRange sr,
   params Color[] colors
)

Parameters

ev
Element value on which element coloring is based.
sr
ScaleRange that specifies the minimum and maximum range of the element value to include in the palette.
colors
Colors to base SmartColors on.

Return Value

A SmartPalette with generated smart colors.
Remarks
The resulting smartPalette will apply to all series and elements.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > FromColorsRange Method : FromColorsRange(String,ElementValue,ScaleRange,Color[]) Method
The name of a series or element. Use "*" as a wildcard.
Element value on which element coloring is based.
ScaleRange that specifies the minimum and maximum range of the element value to include in the palette.
Colors to base SmartColors on.
FromColorsRange(String,ElementValue,ScaleRange,Color[]) Method
Generates a SmartPalette with range colors for series or elements with a specific name. It is based on the specified element value, element value range, and colors.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromColorsRange( _
   ByVal key As String, _
   ByVal ev As ElementValue, _
   ByVal sr As ScaleRange, _
   ByVal ParamArray colors() As Color _
) As SmartPalette
'Usage

Dim key As String
Dim ev As ElementValue
Dim sr As ScaleRange
Dim colors() As Color
Dim value As SmartPalette

value = SmartPalette.FromColorsRange(key, ev, sr, colors)
public static SmartPalette FromColorsRange(
   string key,
   ElementValue ev,
   ScaleRange sr,
   params Color[] colors
)

Parameters

key
The name of a series or element. Use "*" as a wildcard.
ev
Element value on which element coloring is based.
sr
ScaleRange that specifies the minimum and maximum range of the element value to include in the palette.
colors
Colors to base SmartColors on.

Return Value

A SmartPalette with generated smart colors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class : GetScaleRange Method
GetScaleRange Method
Get a ScaleRange object representing the union of all value ranges defined by colors that match the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetScaleRange( _
   ByVal key As String _
) As ScaleRange
'Usage

Dim instance As SmartPalette
Dim key As String
Dim value As ScaleRange

value = instance.GetScaleRange(key)
public ScaleRange GetScaleRange(
   string key
)

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : GetValueColor Method
The name of a series or element, or "*" for all.
Value to match with a scale range.
GetValueColor Method
Get the thematic color based on the key and values of smartPalettes..
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValueColor( _
   ByVal key As String, _
   ByVal value As Double _
) As Color
'Usage

Dim instance As SmartPalette
Dim key As String
Dim value As Double
Dim value As Color

value = instance.GetValueColor(key, value)
public Color GetValueColor(
   string key,
   double value
)

Parameters

key
The name of a series or element, or "*" for all.
value
Value to match with a scale range.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : LoadState Method
Path of XML file or XML data to load.
LoadState Method (SmartPalette)
Imports a SmartPalette object from the specified xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub LoadState( _
   ByVal xmlDataOrFileName As String _
)
'Usage

Dim instance As SmartPalette
Dim xmlDataOrFileName As String

instance.LoadState(xmlDataOrFileName)
public void LoadState(
   string xmlDataOrFileName
)

Parameters

xmlDataOrFileName
Path of XML file or XML data to load.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : Remove Method
Remove Method (SmartPalette)
Removes an entry with the specified key from the collection.
Overload List
Overload | Description
Remove(String) | Removes an entry with the specified key from the collection.
Remove(Int32) | Removes an item at the specified index from this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class > Remove Method : Remove(String) Method
Key of entry to remove.
Remove(String) Method
Removes an entry with the specified key from the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal key As String _
)
'Usage

Dim instance As SmartPalette
Dim key As String

instance.Remove(key)
public void Remove(
   string key
)

Parameters

key
Key of entry to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > Remove Method : Remove(Int32) Method
The AxisTick to remove.
Remove(Int32) Method
Removes an item at the specified index from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal index As Integer _
)
'Usage

Dim instance As SmartPalette
Dim index As Integer

instance.Remove(index)
public void Remove(
   int index
)

Parameters

index
The AxisTick to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class : SaveState Method
SaveState Method (SmartPalette)
Saves the SmartPalette instance to an xml file.
Overload List
Overload | Description
SaveState() | Saves the SmartPalette instance to an xml file.
SaveState(String) | Saves the SmartPalette instance to an xml file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class > SaveState Method : SaveState() Method
SaveState() Method
Saves the SmartPalette instance to an xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function SaveState() As String
'Usage

Dim instance As SmartPalette
Dim value As String

value = instance.SaveState()
public string SaveState()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > SaveState Method : SaveState(String) Method
SaveState(String) Method
Saves the SmartPalette instance to an xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub SaveState( _
   ByVal xmlFilePath As String _
)
'Usage

Dim instance As SmartPalette
Dim xmlFilePath As String

instance.SaveState(xmlFilePath)
public void SaveState(
   string xmlFilePath
)

Parameters

xmlFilePath
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SmartPalette Class
SmartPalette Class Properties

For a list of all members of this type, see SmartPalette members.

Public Properties
 | Name | Description
Public Property | AllKeys | Gets a String array containing all the keys (series or element names) in the SmartPalette.
Public Property | AllValues | Gets a Color array containing all the values (series / element colors) in the SmartPalette.
Public Property | Count | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Public Property | HasKeys | Gets a value indicating whether the SmartPalette has entries.
Public Property | Item | Overloaded. Gets or sets the value associated with the specified key.
Public Property | Keys | (Inherited from System.Collections.Specialized.NameObjectCollectionBase)
Top
See Also

Reference

SmartPalette Class
dotnetCHARTING Namespace

Tutorial

Element Colors and Palettes


dotnetCHARTING Namespace > SmartPalette Class : AllKeys Property
AllKeys Property
Gets a String array containing all the keys (series or element names) in the SmartPalette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AllKeys As String()
'Usage

Dim instance As SmartPalette
Dim value() As String

value = instance.AllKeys
public string[] AllKeys {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : AllValues Property
AllValues Property
Gets a Color array containing all the values (series / element colors) in the SmartPalette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AllValues As Array
'Usage

Dim instance As SmartPalette
Dim value As Array

value = instance.AllValues
public Array AllValues {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : HasKeys Property
HasKeys Property
Gets a value indicating whether the SmartPalette has entries.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property HasKeys As Boolean
'Usage

Dim instance As SmartPalette
Dim value As Boolean

value = instance.HasKeys
public bool HasKeys {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class : Item Property
Item Property (SmartPalette)
Gets or sets the value associated with the specified key.
Overload List
Overload | Description
Item(Int32) | Gets or sets the value associated with the specified key.
Item(String) | Gets or sets the Color with the specified key.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > SmartPalette Class > Item Property : Item(Int32) Property
Item(Int32) Property
Gets or sets the value associated with the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As DictionaryEntry
'Usage

Dim instance As SmartPalette
Dim index As Integer
Dim value As DictionaryEntry

value = instance.Item(index)
public DictionaryEntry Item(
   int index
) {get;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


dotnetCHARTING Namespace > SmartPalette Class > Item Property : Item(String) Property
Item(String) Property
Gets or sets the Color with the specified key.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal key As String _
) As Color
'Usage

Dim instance As SmartPalette
Dim key As String
Dim value As Color

instance.Item(key) = value

value = instance.Item(key)
public Color Item(
   string key
) {get; set;}

Parameters

key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : StatisticalEngine Class
StatisticalEngine Class
Provides a set of methods that perform statistical analysis of series and series collections.
Object Model
StatisticalEngine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StatisticalEngine
'Usage

Dim instance As StatisticalEngine
public sealed class StatisticalEngine
Inheritance Hierarchy

System.Object
dotnetCHARTING.StatisticalEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Methods

dotnetCHARTING Namespace : StatisticalEngine Class
StatisticalEngine Class Members

The following tables list the members exposed by StatisticalEngine.

Public Constructors
 | Name | Description
Public Constructor | StatisticalEngine Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | BollingerBands | Overloaded. Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
static (Shared in Visual Basic) | CFrequencyTableAOL | Overloaded.
static (Shared in Visual Basic) | CFrequencyTableAOR | Overloaded. Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | CFrequencyTableBOL | Overloaded. Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
static (Shared in Visual Basic) | CFrequencyTableBOR | Overloaded. Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | CorrelationCoefDeterminantion | Overloaded. Calculates the coefficient of determination for the YValues of the series.
static (Shared in Visual Basic) | DataDistribution | Overloaded. Calculates some quality control features like median, mean and percentile and integrate them within an element.
static (Shared in Visual Basic) | DataDistributionChart | Overloaded. Calculates some quality control features like median, mean and percentile and integrate them within an element.
static (Shared in Visual Basic) | EstimateX | Overloaded. Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
static (Shared in Visual Basic) | EstimateY | Overloaded. Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
static (Shared in Visual Basic) | ExponentialDistribution | Overloaded. Calculates the Exponential Probability Density function for a given series.
static (Shared in Visual Basic) | ExponentiallyWeightedMovingAverage | Overloaded. Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | FrequencyTableOL | Overloaded. Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
static (Shared in Visual Basic) | FrequencyTableOR | Overloaded. Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
static (Shared in Visual Basic) | GeometricMean | Overloaded. Calculates the geometric mean of the series's elements YValues.
static (Shared in Visual Basic) | GeometricMovingAverage | Overloaded. Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | IQR | Overloaded. Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
static (Shared in Visual Basic) | Kairi | Overloaded. Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
static (Shared in Visual Basic) | KendallCorrelationCoef | Overloaded. Calculates Kendall's correlation coefficient for the YValues of the series.
static (Shared in Visual Basic) | Kurtosis | Overloaded. Calculates the kurtosis of the currently registered data set.
static (Shared in Visual Basic) | LeastSquaresEstimateX | Overloaded. Constructs the regression line of X on Y using the method of least squares.
static (Shared in Visual Basic) | LeastSquaresEstimateY | Overloaded. Constructs the regression line of Y on X using the method of least squares.
static (Shared in Visual Basic) | LinearlyWeightedMovingAverage | Overloaded. Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
static (Shared in Visual Basic) | LognormalDistribution | Overloaded. Calculates the Lognormal Probability Density function for a given series.
static (Shared in Visual Basic) | LowerBollingerBands | Overloaded. Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Mean | Overloaded. Calculates the arithmetic mean of the elements YValues of the series.
static (Shared in Visual Basic) | MeanDeviation | Overloaded. Calculates the mean deviation of the series's element YValues.
static (Shared in Visual Basic) | Median | Overloaded. Calculates the median of the series's elements YValues.
static (Shared in Visual Basic) | MedianMovingAverage | Overloaded. Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
static (Shared in Visual Basic) | NormalDistribution | Overloaded. Calculates the Normal Probability Density function for a given series.
static (Shared in Visual Basic) | ParetoDistribution | Overloaded. Calculates the Pareto Probability Density function for a given series.
static (Shared in Visual Basic) | PearsonCorrelationCoef | Overloaded. Calculates Pearson's correlation coefficient for the YValues of the series.
static (Shared in Visual Basic) | Percentile | Overloaded. Calculates the n-th percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile25 | Overloaded. Calculates the first percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile50 | Overloaded. Calculates the second percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile75 | Overloaded. Calculates the third percentile of the series's elements YValues.
static (Shared in Visual Basic) | Range | Overloaded. Calculates the range of the series's elements YValues.
static (Shared in Visual Basic) | RChart | Overloaded. Create the R Chart chart for a given SeriesCollection object.
static (Shared in Visual Basic) | Residuals | Overloaded. Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
static (Shared in Visual Basic) | ResidualsAverage | Overloaded. Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
static (Shared in Visual Basic) | RFrequencyTableOL | Overloaded. Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
static (Shared in Visual Basic) | RFrequencyTableOR | Overloaded. Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | RunChart | Overloaded. Create the run chart for a given series.
static (Shared in Visual Basic) | RXBARChart | Overloaded. Create the XBAR Chart based on R Chart results for a given SeriesCollection object.
static (Shared in Visual Basic) | SChart | Overloaded. Create the S Chart chart for a given SeriesCollection object.
static (Shared in Visual Basic) | SimpleMovingAverage | Overloaded. Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | Skewness | Overloaded. Calculates the skewness of the currently registered data set.
static (Shared in Visual Basic) | SpearmanRankCorrelationTest | Overloaded. Calculates Spearson's Rank correlation coefficient for the current data set.
static (Shared in Visual Basic) | StandardDeviation | Overloaded. Calculates the sample standard variance of the series's elements YValues.
static (Shared in Visual Basic) | SXBARChart | Overloaded. Create the XBAR Chart based on S Chart results for a given SeriesCollection object.
static (Shared in Visual Basic) | TriangularMovingAverage | Overloaded. Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | UpperBollingerBands | Overloaded. Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Variance | Overloaded. Calculates the sample variance of the series's elements YValues.
static (Shared in Visual Basic) | WeightedMovingAverage | Overloaded. Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
static (Shared in Visual Basic) | ZScore | Overloaded. Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Top
See Also

Reference

StatisticalEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%%

dotnetCHARTING Namespace > StatisticalEngine Class : StatisticalEngine Constructor
StatisticalEngine Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New StatisticalEngine()
public StatisticalEngine()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : StatisticalEngine Class
StatisticalEngine Class Methods

For a list of all members of this type, see StatisticalEngine members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | BollingerBands | Overloaded. Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
static (Shared in Visual Basic) | CFrequencyTableAOL | Overloaded.
static (Shared in Visual Basic) | CFrequencyTableAOR | Overloaded. Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | CFrequencyTableBOL | Overloaded. Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
static (Shared in Visual Basic) | CFrequencyTableBOR | Overloaded. Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | CorrelationCoefDeterminantion | Overloaded. Calculates the coefficient of determination for the YValues of the series.
static (Shared in Visual Basic) | DataDistribution | Overloaded. Calculates some quality control features like median, mean and percentile and integrate them within an element.
static (Shared in Visual Basic) | DataDistributionChart | Overloaded. Calculates some quality control features like median, mean and percentile and integrate them within an element.
static (Shared in Visual Basic) | EstimateX | Overloaded. Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
static (Shared in Visual Basic) | EstimateY | Overloaded. Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
static (Shared in Visual Basic) | ExponentialDistribution | Overloaded. Calculates the Exponential Probability Density function for a given series.
static (Shared in Visual Basic) | ExponentiallyWeightedMovingAverage | Overloaded. Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | FrequencyTableOL | Overloaded. Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
static (Shared in Visual Basic) | FrequencyTableOR | Overloaded. Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
static (Shared in Visual Basic) | GeometricMean | Overloaded. Calculates the geometric mean of the series's elements YValues.
static (Shared in Visual Basic) | GeometricMovingAverage | Overloaded. Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | IQR | Overloaded. Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
static (Shared in Visual Basic) | Kairi | Overloaded. Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
static (Shared in Visual Basic) | KendallCorrelationCoef | Overloaded. Calculates Kendall's correlation coefficient for the YValues of the series.
static (Shared in Visual Basic) | Kurtosis | Overloaded. Calculates the kurtosis of the currently registered data set.
static (Shared in Visual Basic) | LeastSquaresEstimateX | Overloaded. Constructs the regression line of X on Y using the method of least squares.
static (Shared in Visual Basic) | LeastSquaresEstimateY | Overloaded. Constructs the regression line of Y on X using the method of least squares.
static (Shared in Visual Basic) | LinearlyWeightedMovingAverage | Overloaded. Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
static (Shared in Visual Basic) | LognormalDistribution | Overloaded. Calculates the Lognormal Probability Density function for a given series.
static (Shared in Visual Basic) | LowerBollingerBands | Overloaded. Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Mean | Overloaded. Calculates the arithmetic mean of the elements YValues of the series.
static (Shared in Visual Basic) | MeanDeviation | Overloaded. Calculates the mean deviation of the series's element YValues.
static (Shared in Visual Basic) | Median | Overloaded. Calculates the median of the series's elements YValues.
static (Shared in Visual Basic) | MedianMovingAverage | Overloaded. Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
static (Shared in Visual Basic) | NormalDistribution | Overloaded. Calculates the Normal Probability Density function for a given series.
static (Shared in Visual Basic) | ParetoDistribution | Overloaded. Calculates the Pareto Probability Density function for a given series.
static (Shared in Visual Basic) | PearsonCorrelationCoef | Overloaded. Calculates Pearson's correlation coefficient for the YValues of the series.
static (Shared in Visual Basic) | Percentile | Overloaded. Calculates the n-th percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile25 | Overloaded. Calculates the first percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile50 | Overloaded. Calculates the second percentile of the series's elements YValues.
static (Shared in Visual Basic) | Percentile75 | Overloaded. Calculates the third percentile of the series's elements YValues.
static (Shared in Visual Basic) | Range | Overloaded. Calculates the range of the series's elements YValues.
static (Shared in Visual Basic) | RChart | Overloaded. Create the R Chart chart for a given SeriesCollection object.
static (Shared in Visual Basic) | Residuals | Overloaded. Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
static (Shared in Visual Basic) | ResidualsAverage | Overloaded. Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
static (Shared in Visual Basic) | RFrequencyTableOL | Overloaded. Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
static (Shared in Visual Basic) | RFrequencyTableOR | Overloaded. Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
static (Shared in Visual Basic) | RunChart | Overloaded. Create the run chart for a given series.
static (Shared in Visual Basic) | RXBARChart | Overloaded. Create the XBAR Chart based on R Chart results for a given SeriesCollection object.
static (Shared in Visual Basic) | SChart | Overloaded. Create the S Chart chart for a given SeriesCollection object.
static (Shared in Visual Basic) | SimpleMovingAverage | Overloaded. Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
static (Shared in Visual Basic) | Skewness | Overloaded. Calculates the skewness of the currently registered data set.
static (Shared in Visual Basic) | SpearmanRankCorrelationTest | Overloaded. Calculates Spearson's Rank correlation coefficient for the current data set.
static (Shared in Visual Basic) | StandardDeviation | Overloaded. Calculates the sample standard variance of the series's elements YValues.
static (Shared in Visual Basic) | SXBARChart | Overloaded. Create the XBAR Chart based on S Chart results for a given SeriesCollection object.
static (Shared in Visual Basic) | TriangularMovingAverage | Overloaded. Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
static (Shared in Visual Basic) | UpperBollingerBands | Overloaded. Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
static (Shared in Visual Basic) | Variance | Overloaded. Calculates the sample variance of the series's elements YValues.
static (Shared in Visual Basic) | WeightedMovingAverage | Overloaded. Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
static (Shared in Visual Basic) | ZScore | Overloaded. Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Top
See Also

Reference

StatisticalEngine Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > StatisticalEngine Class : BollingerBands Method
BollingerBands Method (StatisticalEngine)
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Overload List
Overload | Description
BollingerBands(Series,Double,Int32) | Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
BollingerBands(SeriesCollection,Double,Int32) | Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > BollingerBands Method : BollingerBands(Series,Double,Int32) Method
A statistical series.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
BollingerBands(Series,Double,Int32) Method
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim s As Series
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.BollingerBands(s, standardDeviationLevel, lengthOfMA)
public static SeriesCollection BollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
A statistical series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > BollingerBands Method : BollingerBands(SeriesCollection,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
BollingerBands(SeriesCollection,Double,Int32) Method
Within this class we offer procedures which evaluate the upper and lower Bollinger Bands.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function BollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.BollingerBands(sc, standardDeviationLevel, lengthOfMA)
public static SeriesCollection BollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
Remarks

Further Details

Bollinger Bands are a type of envelope that are plotted at standard deviation levels above and below the corresponding (simple) moving average. This produces an effect of having the bands widen during periods of higher volatility and contract during less volatile periods. Bollinger Bands indicate the relative supply and demand for a given asset. If the asset to move close to the top of the envelope then it indicates that there is strong demand for the asset, conversely if the asset hugs the bottom of the trading range then it indicates that there is oversupply of the asset.

Since the Bollinger Bands will nearly always be combined with other indicators when forming a trading system the number of periods used in the evaluation of the standard deviation of the stocks and the moving average will vary. For those without design restrictions a popular choice of the number of time periods is around 20-23.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : CFrequencyTableAOL Method
CFrequencyTableAOL Method
Overload List
Overload | Description
CFrequencyTableAOL(String,Series,Double[]) |
CFrequencyTableAOL(Series,Double[]) | Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.
CFrequencyTableAOL(SeriesCollection,Double[]) | Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOL Method : CFrequencyTableAOL(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOL(String,Series,Double[]) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableAOL(seriesName, s, boundaries)
public static Series CFrequencyTableAOL(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
 | Thrown if data set or boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOL Method : CFrequencyTableAOL(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOL(Series,Double[]) Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableAOL(s, boundaries)
public static Series CFrequencyTableAOL(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if data set or boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOL Method : CFrequencyTableAOL(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOL(SeriesCollection,Double[]) Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.CFrequencyTableAOL(sc, boundaries)
public static SeriesCollection CFrequencyTableAOL(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if data set or boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 1 + 3 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 1 + 3 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 1 + 3 + 1 = 5
  • Cumulative frequency table above 3 is: 1 + 3 + 1 = 5
  • Cumulative frequency table above 4 is: 3 + 1 = 4
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 4, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : CFrequencyTableAOR Method
CFrequencyTableAOR Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
Overload List
Overload | Description
CFrequencyTableAOR(String,Series,Double[]) | Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
CFrequencyTableAOR(Series,Double[]) | Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
CFrequencyTableAOR(SeriesCollection,Double[]) | Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOR Method : CFrequencyTableAOR(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOR(String,Series,Double[]) Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableAOR(seriesName, s, boundaries)
public static Series CFrequencyTableAOR(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if data set or boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOR Method : CFrequencyTableAOR(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOR(Series,Double[]) Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableAOR(s, boundaries)
public static Series CFrequencyTableAOR(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the input data are not given.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableAOR Method : CFrequencyTableAOR(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableAOR(SeriesCollection,Double[]) Method
Calculates the cumulative frequency table from above for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableAOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.CFrequencyTableAOR(sc, boundaries)
public static SeriesCollection CFrequencyTableAOR(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the input data are not given.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set above the lowest value of that interval of the frequency table constructed in accordance with the open right boundary.

Example

Within this example we work through an illustration in which the cumulative frequency table from above using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1,2), [2,3), [3,4), [4,5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, and if we assign this data set in accordance with the Open Right Boundary (ORB) convention then we will have:

  • Within the interval (-infinity, 1), we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3, and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table above -infinity is: 1 + 1 + 0 + 2 + 2 + 1 = 7
  • Cumulative frequency table above 1 is: 1 + 0 + 2 + 2 + 1 = 6
  • Cumulative frequency table above 2 is: 0 + 2 + 2 + 1 = 5
  • Cumulative frequency table above 3 is: 2 + 2 + 1 = 5
  • Cumulative frequency table above 4 is: 2 + 1 = 3
  • Cumulative frequency table above 5 is: 1

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {7, 6, 5, 5, 3, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : CFrequencyTableBOL Method
CFrequencyTableBOL Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
Overload List
Overload | Description
CFrequencyTableBOL(String,Series,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
CFrequencyTableBOL(Series,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
CFrequencyTableBOL(SeriesCollection,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOL Method : CFrequencyTableBOL(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOL(String,Series,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableBOL(seriesName, s, boundaries)
public static Series CFrequencyTableBOL(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the input data are not given.
System.ArgumentException | Thrown if data set or the boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOL Method : CFrequencyTableBOL(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOL(Series,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableBOL(s, boundaries)
public static Series CFrequencyTableBOL(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the input data are not given.
System.ArgumentException | Thrown if data set or the boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOL Method : CFrequencyTableBOL(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOL(SeriesCollection,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.CFrequencyTableBOL(sc, boundaries)
public static SeriesCollection CFrequencyTableBOL(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Exceptions
Exception | Description
System.ArgumentException | Thrown if data set or the boundaries intervals are null.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open left boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open left boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 4
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 4, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : CFrequencyTableBOR Method
CFrequencyTableBOR Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
Overload List
Overload | Description
CFrequencyTableBOR(String,Series,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
CFrequencyTableBOR(Series,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
CFrequencyTableBOR(SeriesCollection,Double[]) | Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOR Method : CFrequencyTableBOR(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOR(String,Series,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableBOR(seriesName, s, boundaries)
public static Series CFrequencyTableBOR(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOR Method : CFrequencyTableBOR(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOR(Series,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.CFrequencyTableBOR(s, boundaries)
public static Series CFrequencyTableBOR(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CFrequencyTableBOR Method : CFrequencyTableBOR(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
CFrequencyTableBOR(SeriesCollection,Double[]) Method
Calculates the cumulative frequency table from below for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CFrequencyTableBOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.CFrequencyTableBOR(sc, boundaries)
public static SeriesCollection CFrequencyTableBOR(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The value of the cumulative frequency table values at a given point is the number of elements within the data set below the highest value of that interval of the frequency table constructed in accordance with the open right boundary convention.

Example

Within this example we work through an illustration in which the cumulative frequency table from below using the open right boundary convention is evaluated.

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Now in follows that the associated values of the cumulative frequency table are given by:

  • Cumulative frequency table up to 1 is: 1
  • Cumulative frequency table up to 2 is: 3
  • Cumulative frequency table up to 3 is: 5
  • Cumulative frequency table up to 4 is: 5
  • Cumulative frequency table up to 5 is: 6
  • Cumulative frequency table up to 5 is: 7

Hence, for this case the series returned by this methods to represent the cumulative frequency table would be: {1, 3, 5, 5, 6, 7}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : CorrelationCoefDeterminantion Method
CorrelationCoefDeterminantion Method
Calculates the coefficient of determination for the YValues of the series.
Overload List
Overload | Description
CorrelationCoefDeterminantion(String,Series) | Calculates the coefficient of determination for the YValues of the series.
CorrelationCoefDeterminantion(Series) | Calculates the coefficient of determination for the YValues of the series.
CorrelationCoefDeterminantion(String,SeriesCollection) | Calculates the coefficient of determination for the YValues of the series.
CorrelationCoefDeterminantion(SeriesCollection) | Calculates the coefficient of determination for the YValues of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > CorrelationCoefDeterminantion Method : CorrelationCoefDeterminantion(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
CorrelationCoefDeterminantion(String,Series) Method
Calculates the coefficient of determination for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CorrelationCoefDeterminantion( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.CorrelationCoefDeterminantion(elementName, s)
public static Element CorrelationCoefDeterminantion(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

The coefficient of determination of the series
Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY(String,Series)), divided by the total amount of variation of the second variable (i.e. Y).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CorrelationCoefDeterminantion Method : CorrelationCoefDeterminantion(Series) Method
A statistical series.
CorrelationCoefDeterminantion(Series) Method
Calculates the coefficient of determination for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CorrelationCoefDeterminantion( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.CorrelationCoefDeterminantion(s)
public static Element CorrelationCoefDeterminantion(
   Series s
)

Parameters

s
A statistical series.

Return Value

The coefficient of determination of the series
Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY(String,Series)), divided by the total amount of variation of the second variable (i.e. Y).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CorrelationCoefDeterminantion Method : CorrelationCoefDeterminantion(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
CorrelationCoefDeterminantion(String,SeriesCollection) Method
Calculates the coefficient of determination for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CorrelationCoefDeterminantion( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.CorrelationCoefDeterminantion(seriesName, sc)
public static Series CorrelationCoefDeterminantion(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY(String,Series)), divided by the total amount of variation of the second variable (i.e. Y).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > CorrelationCoefDeterminantion Method : CorrelationCoefDeterminantion(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
CorrelationCoefDeterminantion(SeriesCollection) Method
Calculates the coefficient of determination for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function CorrelationCoefDeterminantion( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.CorrelationCoefDeterminantion(sc)
public static Series CorrelationCoefDeterminantion(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Explanation of the Coefficient of Determination

The coefficient of determination is the amount of variation in the second variable (i.e. Y) which is explained by the regression line of the second variable Y on the first variable X (see LeastSquaresEstimateY(String,Series)), divided by the total amount of variation of the second variable (i.e. Y).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : DataDistribution Method
DataDistribution Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Overload List
Overload | Description
DataDistribution(String,Series) | Calculates some quality control features like median, mean and percentile and integrate them within an element.
DataDistribution(Series) | Calculates some quality control features like median, mean and percentile and integrate them within an element.
DataDistribution(SeriesCollection) | Calculates some quality control features like median, mean and percentile and integrate them within an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > DataDistribution Method : DataDistribution(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
DataDistribution(String,Series) Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DataDistribution( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.DataDistribution(seriesName, s)
public static Series DataDistribution(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > DataDistribution Method : DataDistribution(Series) Method
A statistical series.
DataDistribution(Series) Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DataDistribution( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.DataDistribution(s)
public static Series DataDistribution(
   Series s
)

Parameters

s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > DataDistribution Method : DataDistribution(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
DataDistribution(SeriesCollection) Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DataDistribution( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.DataDistribution(sc)
public static SeriesCollection DataDistribution(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : DataDistributionChart Method
DataDistributionChart Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Overload List
Overload | Description
DataDistributionChart(Series) | Calculates some quality control features like median, mean and percentile and integrate them within an element.
DataDistributionChart(SeriesCollection) | Calculates some quality control features like median, mean and percentile and integrate them within an element.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > DataDistributionChart Method : DataDistributionChart(Series) Method
A statistical series.
DataDistributionChart(Series) Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DataDistributionChart( _
   ByVal s As Series _
) As ChartArea
'Usage

Dim s As Series
Dim value As ChartArea

value = StatisticalEngine.DataDistributionChart(s)
public static ChartArea DataDistributionChart(
   Series s
)

Parameters

s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > DataDistributionChart Method : DataDistributionChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
DataDistributionChart(SeriesCollection) Method
Calculates some quality control features like median, mean and percentile and integrate them within an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function DataDistributionChart( _
   ByVal sc As SeriesCollection _
) As ChartAreaCollection
'Usage

Dim sc As SeriesCollection
Dim value As ChartAreaCollection

value = StatisticalEngine.DataDistributionChart(sc)
public static ChartAreaCollection DataDistributionChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : EstimateX Method
EstimateX Method
Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Overload List
Overload | Description
EstimateX(String,Series,Double) | Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
EstimateX(Series,Double) | Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
EstimateX(String,SeriesCollection,Double) | Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
EstimateX(SeriesCollection,Double) | Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateX Method : EstimateX(String,Series,Double) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the linear regression line is evaluated.
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
EstimateX(String,Series,Double) Method
Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateX( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim estPoint As Double
Dim value As Element

value = StatisticalEngine.EstimateX(elementName, s, estPoint)
public static Element EstimateX(
   string elementName,
   Series s,
   double estPoint
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateX Method : EstimateX(Series,Double) Method
A statistical series containing the elements for which the linear regression line is evaluated.
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
EstimateX(Series,Double) Method
Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateX( _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
'Usage

Dim s As Series
Dim estPoint As Double
Dim value As Element

value = StatisticalEngine.EstimateX(s, estPoint)
public static Element EstimateX(
   Series s,
   double estPoint
)

Parameters

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateX Method : EstimateX(String,SeriesCollection,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
EstimateX(String,SeriesCollection,Double) Method
Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateX( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim estPoint As Double
Dim value As Series

value = StatisticalEngine.EstimateX(seriesName, sc, estPoint)
public static Series EstimateX(
   string seriesName,
   SeriesCollection sc,
   double estPoint
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateX Method : EstimateX(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
EstimateX(SeriesCollection,Double) Method
Estimates the value of the X variable when the Y variable is known using the regression line of X on Y, which can be evaluated using LeastSquaresEstimateX(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateX( _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
'Usage

Dim sc As SeriesCollection
Dim estPoint As Double
Dim value As Series

value = StatisticalEngine.EstimateX(sc, estPoint)
public static Series EstimateX(
   SeriesCollection sc,
   double estPoint
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the Y coordinate for which the corresponding X coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : EstimateY Method
EstimateY Method
Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Overload List
Overload | Description
EstimateY(String,Series,Double) | Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
EstimateY(Series,Double) | Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
EstimateY(String,SeriesCollection,Double) | Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
EstimateY(SeriesCollection,Double) | Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateY Method : EstimateY(String,Series,Double) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the linear regression line is evaluated.
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
EstimateY(String,Series,Double) Method
Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateY( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim estPoint As Double
Dim value As Element

value = StatisticalEngine.EstimateY(elementName, s, estPoint)
public static Element EstimateY(
   string elementName,
   Series s,
   double estPoint
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateY Method : EstimateY(Series,Double) Method
A statistical series containing the elements for which the linear regression line is evaluated.
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
EstimateY(Series,Double) Method
Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateY( _
   ByVal s As Series, _
   ByVal estPoint As Double _
) As Element
'Usage

Dim s As Series
Dim estPoint As Double
Dim value As Element

value = StatisticalEngine.EstimateY(s, estPoint)
public static Element EstimateY(
   Series s,
   double estPoint
)

Parameters

s
A statistical series containing the elements for which the linear regression line is evaluated.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateY Method : EstimateY(String,SeriesCollection,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
EstimateY(String,SeriesCollection,Double) Method
Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateY( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim estPoint As Double
Dim value As Series

value = StatisticalEngine.EstimateY(seriesName, sc, estPoint)
public static Series EstimateY(
   string seriesName,
   SeriesCollection sc,
   double estPoint
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > EstimateY Method : EstimateY(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
EstimateY(SeriesCollection,Double) Method
Estimates the value of the Y variable when the X variable is known using the regression line of Y on X, which can be evaluated using LeastSquaresEstimateY(String,Series).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function EstimateY( _
   ByVal sc As SeriesCollection, _
   ByVal estPoint As Double _
) As Series
'Usage

Dim sc As SeriesCollection
Dim estPoint As Double
Dim value As Series

value = StatisticalEngine.EstimateY(sc, estPoint)
public static Series EstimateY(
   SeriesCollection sc,
   double estPoint
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
estPoint
the values of the X coordinate for which the corresponding Y coordinate in estimated in accordance with the linear regression line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : ExponentialDistribution Method
ExponentialDistribution Method
Calculates the Exponential Probability Density function for a given series.
Overload List
Overload | Description
ExponentialDistribution(String,Series,Double) | Calculates the Exponential Probability Density function for a given series.
ExponentialDistribution(Series,Double) | Calculates the Exponential Probability Density function for a given series.
ExponentialDistribution(SeriesCollection,Double) | Calculates the Exponential Probability Density function for a given collection of series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentialDistribution Method : ExponentialDistribution(String,Series,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The scale parameter value.
ExponentialDistribution(String,Series,Double) Method
Calculates the Exponential Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentialDistribution( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lambda As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lambda As Double
Dim value As Series

value = StatisticalEngine.ExponentialDistribution(seriesName, s, lambda)
public static Series ExponentialDistribution(
   string seriesName,
   Series s,
   double lambda
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
lambda
The scale parameter value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentialDistribution Method : ExponentialDistribution(Series,Double) Method
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The scale parameter value.
ExponentialDistribution(Series,Double) Method
Calculates the Exponential Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentialDistribution( _
   ByVal s As Series, _
   ByVal lambda As Double _
) As Series
'Usage

Dim s As Series
Dim lambda As Double
Dim value As Series

value = StatisticalEngine.ExponentialDistribution(s, lambda)
public static Series ExponentialDistribution(
   Series s,
   double lambda
)

Parameters

s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
lambda
The scale parameter value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentialDistribution Method : ExponentialDistribution(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The scale parameter value.
ExponentialDistribution(SeriesCollection,Double) Method
Calculates the Exponential Probability Density function for a given collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentialDistribution( _
   ByVal sc As SeriesCollection, _
   ByVal lambda As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lambda As Double
Dim value As SeriesCollection

value = StatisticalEngine.ExponentialDistribution(sc, lambda)
public static SeriesCollection ExponentialDistribution(
   SeriesCollection sc,
   double lambda
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lambda
The scale parameter value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : ExponentiallyWeightedMovingAverage Method
ExponentiallyWeightedMovingAverage Method (StatisticalEngine)
Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Overload List
Overload | Description
ExponentiallyWeightedMovingAverage(String,Series,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
ExponentiallyWeightedMovingAverage(Series,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Int32) | Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(String,Series,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(String,Series,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.ExponentiallyWeightedMovingAverage(seriesName, s, smoothingFactor, lengthOfMA)
public static Series ExponentiallyWeightedMovingAverage(
   string seriesName,
   Series s,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(Series,Double,Int32) Method
A statistical series.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(Series,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.ExponentiallyWeightedMovingAverage(s, smoothingFactor, lengthOfMA)
public static Series ExponentiallyWeightedMovingAverage(
   Series s,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

s
A statistical series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ExponentiallyWeightedMovingAverage Method : ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
The number of periods over which the moving average is evaluated for each period.
ExponentiallyWeightedMovingAverage(SeriesCollection,Double,Int32) Method
Evaluates the (x-day) Exponentially Weighted Moving Average (EWMA) of a time series provided where x is the length of the time series array which is provided as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ExponentiallyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal smoothingFactor As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim smoothingFactor As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.ExponentiallyWeightedMovingAverage(sc, smoothingFactor, lengthOfMA)
public static SeriesCollection ExponentiallyWeightedMovingAverage(
   SeriesCollection sc,
   double smoothingFactor,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
smoothingFactor
The number between 0 and 1 which is known as a smoothing factor. The closer the value is to zero the more influence more resent measurements will have on the EWMA.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the EWMA for the most recent period, the second term is the EWMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the Series is empty or if the value given for the smoothing factor lies outside the closed range [0,1].
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : FrequencyTableOL Method
FrequencyTableOL Method
Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
Overload List
Overload | Description
FrequencyTableOL(String,Series,Double[]) | Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
FrequencyTableOL(Series,Double[]) | Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
FrequencyTableOL(SeriesCollection,Double[]) | Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOL Method : FrequencyTableOL(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOL(String,Series,Double[]) Method
Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.FrequencyTableOL(seriesName, s, boundaries)
public static Series FrequencyTableOL(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOL Method : FrequencyTableOL(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOL(Series,Double[]) Method
Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.FrequencyTableOL(s, boundaries)
public static Series FrequencyTableOL(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOL Method : FrequencyTableOL(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOL(SeriesCollection,Double[]) Method
Calculates the frequency table with respect to the open left boundary convention for YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.FrequencyTableOL(sc, boundaries)
public static SeriesCollection FrequencyTableOL(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1], (1,2], (2,3], (3,4], (4,5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if the assign this data set in accordance with the above the conventions then we will have: using Open Left Boundary (OLB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval (1, 2], we assign the data element 1.4, 1.3, 2.0; and hence the frequency of this interval (wrt OLB convention) is 3.
  • Within the interval (2, 3], we assign the data element 2.3, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (3, 4], we assign no data elements, and hence the frequency of this interval (wrt OLB convention) is 0.
  • Within the interval (4, 5], we assign the data element 4.5, and hence the frequency of this interval (wrt OLB convention) is 1.
  • Within the interval (5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt OLB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 3, 1, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : FrequencyTableOR Method
FrequencyTableOR Method
Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
Overload List
Overload | Description
FrequencyTableOR(String,Series,Double[]) | Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
FrequencyTableOR(Series,Double[]) | Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
FrequencyTableOR(SeriesCollection,Double[]) | Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOR Method : FrequencyTableOR(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOR(String,Series,Double[]) Method
Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.FrequencyTableOR(seriesName, s, boundaries)
public static Series FrequencyTableOR(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOR Method : FrequencyTableOR(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOR(Series,Double[]) Method
Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.FrequencyTableOR(s, boundaries)
public static Series FrequencyTableOR(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > FrequencyTableOR Method : FrequencyTableOR(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
FrequencyTableOR(SeriesCollection,Double[]) Method
Calculates the frequency table with respect to the open right boundary convention for a discrete data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FrequencyTableOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.FrequencyTableOR(sc, boundaries)
public static SeriesCollection FrequencyTableOR(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
Say for example the boundary points used are {b_1, b_2, ..., b_n}, now the first term of the array returned which represents the frequency table, is the number of elements from the data set within the interval (-infinity, b_1), the second term of the array returned is the number of elements from the data set within the interval [b_1, b_2), and so on...

Example

Consider the set of boundaries { 1, 2, 3, 4, 5 }, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, 1), [1, 2), [2, 3), [3, 4), [4, 5), [5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Therefore, if we consider the data set { 0.5, 1.4, 1.3, 2.0, 2.3, 4.5, 5.5}, if you assign this data set in accordance with the above the conventions then we will have using Open Right Boundary (ORB) convention:

  • Within the interval (-infinity, 1], we assign the data element 0.5; and hence the frequency of this interval is 1.
  • Within the interval [1, 2), we assign the data element 1.4, 1.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [2, 3), we assign the data element 2.0, 2.3; and hence the frequency of this interval (wrt ORB convention) is 2.
  • Within the interval [3, 4), we assign no data elements, and hence the frequency of this interval (wrt ORB convention) is 0.
  • Within the interval [4, 5), we assign the data element 4.5, and hence the frequency of this interval (wrt ORB convention) is 1.
  • Within the interval [5, infinity), we assign the data element 5.5, and hence the frequency of this interval (wrt ORB convention) is 1.

Hence, in this case the series returned corresponding to the frequency table will be {1, 2, 2, 0, 1, 1}.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : GeometricMean Method
GeometricMean Method (StatisticalEngine)
Calculates the geometric mean of the series's elements YValues.
Overload List
Overload | Description
GeometricMean(String,Series) | Calculates the geometric mean of the series's elements YValues.
GeometricMean(Series) | Calculates the geometric mean of the series's elements YValues.
GeometricMean(String,SeriesCollection) | Calculates the geometric mean of the series's elements YValues.
GeometricMean(SeriesCollection) | Calculates the geometric mean of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMean Method : GeometricMean(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
GeometricMean(String,Series) Method
Calculates the geometric mean of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.GeometricMean(elementName, s)
public static Element GeometricMean(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
GeometricMean(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMean Method : GeometricMean(Series) Method
A statistical series.
GeometricMean(Series) Method
Calculates the geometric mean of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.GeometricMean(s)
public static Element GeometricMean(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
GeometricMean(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMean Method : GeometricMean(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
GeometricMean(String,SeriesCollection) Method
Calculates the geometric mean of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.GeometricMean(seriesName, sc)
public static Series GeometricMean(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
GeometricMean(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMean Method : GeometricMean(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
GeometricMean(SeriesCollection) Method
Calculates the geometric mean of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMean( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.GeometricMean(sc)
public static Series GeometricMean(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
GeometricMean(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : GeometricMovingAverage Method
GeometricMovingAverage Method (StatisticalEngine)
Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Overload List
Overload | Description
GeometricMovingAverage(String,Series,Int32) | Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
GeometricMovingAverage(Series,Int32) | Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
GeometricMovingAverage(SeriesCollection,Int32) | Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The number of periods over which the moving average is evaluated for each period.
GeometricMovingAverage(String,Series,Int32) Method
Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.GeometricMovingAverage(seriesName, s, lengthOfMA)
public static Series GeometricMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Simple Moving Average (MA)


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(Series,Int32) Method
A statistical series.
The number of periods over which the moving average is evaluated for each period.
GeometricMovingAverage(Series,Int32) Method
Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.GeometricMovingAverage(s, lengthOfMA)
public static Series GeometricMovingAverage(
   Series s,
   int lengthOfMA
)

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > GeometricMovingAverage Method : GeometricMovingAverage(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of periods over which the moving average is evaluated for each period.
GeometricMovingAverage(SeriesCollection,Int32) Method
Calculates the Geometric Moving Average (GMA) for a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function GeometricMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.GeometricMovingAverage(sc, lengthOfMA)
public static SeriesCollection GeometricMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : IQR Method
IQR Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Overload List
Overload | Description
IQR(String,Series) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
IQR(Series) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
IQR(String,SeriesCollection) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
IQR(SeriesCollection) | Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > IQR Method : IQR(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
IQR(String,Series) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function IQR( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.IQR(elementName, s)
public static Element IQR(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
IQR(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > IQR Method : IQR(Series) Method
A statistical series.
IQR(Series) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function IQR( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.IQR(s)
public static Element IQR(
   Series s
)

Parameters

s
A statistical series.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
IQR(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > IQR Method : IQR(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
IQR(String,SeriesCollection) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function IQR( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.IQR(seriesName, sc)
public static Series IQR(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
IQR(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > IQR Method : IQR(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
IQR(SeriesCollection) Method
Calculates the Inter-Quartile Range(IQR) of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function IQR( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.IQR(sc)
public static Series IQR(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the IQR is the difference between the 1-st quartile (i.e. 25-th percentile) and the 2-nd quartile (i.e. the 75-th percentile).
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
IQR(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Kairi Method
Kairi Method (StatisticalEngine)
Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Overload List
Overload | Description
Kairi(String,Series,Series) | Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Kairi(Series,Series) | Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Kairi(Series,SeriesCollection) | Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Kairi Method : Kairi(String,Series,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
Kairi(String,Series,Series) Method
Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal movingAverageSeries As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim movingAverageSeries As Series
Dim value As Series

value = StatisticalEngine.Kairi(seriesName, s, movingAverageSeries)
public static Series Kairi(
   string seriesName,
   Series s,
   Series movingAverageSeries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
movingAverageSeries
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > Kairi Method : Kairi(Series,Series) Method
A statistical series.
A series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
Kairi(Series,Series) Method
Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal s As Series, _
   ByVal movingAverageSeries As Series _
) As Series
'Usage

Dim s As Series
Dim movingAverageSeries As Series
Dim value As Series

value = StatisticalEngine.Kairi(s, movingAverageSeries)
public static Series Kairi(
   Series s,
   Series movingAverageSeries
)

Parameters

s
A statistical series.
movingAverageSeries
A series where the first term corresponds to the most recent value of the moving average (generally the simple moving average) of the underlying asset, the second term to the previous value and so on.
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > Kairi Method : Kairi(Series,SeriesCollection) Method
A statistical series.
A collection of series.
Kairi(Series,SeriesCollection) Method
Calculates the Kairi Indicator measure as a percentage of the element value, the divergence between the a moving average (generally the simple moving average) of the value and the value itself for each period for which there is sufficient historical values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kairi( _
   ByVal s As Series, _
   ByVal movingAverages As SeriesCollection _
) As SeriesCollection
'Usage

Dim s As Series
Dim movingAverages As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.Kairi(s, movingAverages)
public static SeriesCollection Kairi(
   Series s,
   SeriesCollection movingAverages
)

Parameters

s
A statistical series.
movingAverages
A collection of series.
Remarks

Remark: The Kairi Indicator is often used with conjunction with other moving averages within trading systems.

Evaluation

The formulae for the Kairi Indicator is as follows:

Kairi Indicator = (MA - price) / price

where MA is the moving average being considered and price is the present price of the underlying asset.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : KendallCorrelationCoef Method
KendallCorrelationCoef Method
Calculates Kendall's correlation coefficient for the YValues of the series.
Overload List
Overload | Description
KendallCorrelationCoef(String,Series) | Calculates Kendall's correlation coefficient for the YValues of the series.
KendallCorrelationCoef(Series) | Calculates Kendall's correlation coefficient for the YValues of the series.
KendallCorrelationCoef(String,SeriesCollection) | Calculates Kendall's correlation coefficient for the YValues of the series.
KendallCorrelationCoef(SeriesCollection) | Calculates Kendall's correlation coefficient for the YValues of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > KendallCorrelationCoef Method : KendallCorrelationCoef(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
KendallCorrelationCoef(String,Series) Method
Calculates Kendall's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KendallCorrelationCoef( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.KendallCorrelationCoef(elementName, s)
public static Element KendallCorrelationCoef(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > KendallCorrelationCoef Method : KendallCorrelationCoef(Series) Method
A statistical series.
KendallCorrelationCoef(Series) Method
Calculates Kendall's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KendallCorrelationCoef( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.KendallCorrelationCoef(s)
public static Element KendallCorrelationCoef(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > KendallCorrelationCoef Method : KendallCorrelationCoef(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
KendallCorrelationCoef(String,SeriesCollection) Method
Calculates Kendall's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KendallCorrelationCoef( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.KendallCorrelationCoef(seriesName, sc)
public static Series KendallCorrelationCoef(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > KendallCorrelationCoef Method : KendallCorrelationCoef(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
KendallCorrelationCoef(SeriesCollection) Method
Calculates Kendall's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function KendallCorrelationCoef( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.KendallCorrelationCoef(sc)
public static Series KendallCorrelationCoef(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : Kurtosis Method
Kurtosis Method (StatisticalEngine)
Calculates the kurtosis of the currently registered data set.
Overload List
Overload | Description
Kurtosis(String,Series) | Calculates the kurtosis of the currently registered data set.
Kurtosis(Series) | Calculates the kurtosis of the currently registered data set.
Kurtosis(String,SeriesCollection) | Calculates the kurtosis of the currently registered data set.
Kurtosis(SeriesCollection) | Calculates the kurtosis of the currently registered data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Kurtosis Method : Kurtosis(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Kurtosis(String,Series) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Kurtosis(elementName, s)
public static Element Kurtosis(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Kurtosis(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Kurtosis Method : Kurtosis(Series) Method
A statistical series.
Kurtosis(Series) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Kurtosis(s)
public static Element Kurtosis(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Kurtosis(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Kurtosis Method : Kurtosis(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Kurtosis(String,SeriesCollection) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Kurtosis(seriesName, sc)
public static Series Kurtosis(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Kurtosis(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Kurtosis Method : Kurtosis(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Kurtosis(SeriesCollection) Method
Calculates the kurtosis of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Kurtosis( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Kurtosis(sc)
public static Series Kurtosis(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Kurtosis(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : LeastSquaresEstimateX Method
LeastSquaresEstimateX Method
Constructs the regression line of X on Y using the method of least squares.
Overload List
Overload | Description
LeastSquaresEstimateX(String,Series) | Constructs the regression line of X on Y using the method of least squares.
LeastSquaresEstimateX(Series) | Constructs the regression line of X on Y using the method of least squares.
LeastSquaresEstimateX(SeriesCollection) | Constructs the regression line of X on Y using the method of least squares.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateX Method : LeastSquaresEstimateX(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
LeastSquaresEstimateX(String,Series) Method
Constructs the regression line of X on Y using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateX( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.LeastSquaresEstimateX(seriesName, s)
public static Series LeastSquaresEstimateX(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of Y on X, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateX Method : LeastSquaresEstimateX(Series) Method
A statistical series.
LeastSquaresEstimateX(Series) Method
Constructs the regression line of X on Y using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateX( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.LeastSquaresEstimateX(s)
public static Series LeastSquaresEstimateX(
   Series s
)

Parameters

s
A statistical series.
Remarks
That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of Y on X, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateX Method : LeastSquaresEstimateX(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
LeastSquaresEstimateX(SeriesCollection) Method
Constructs the regression line of X on Y using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateX( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.LeastSquaresEstimateX(sc)
public static SeriesCollection LeastSquaresEstimateX(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
That is, the regression line using the least squares method is constructed when the first element of the pairs from which the data set of constructed is plot against the second elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of Y on X, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class : LeastSquaresEstimateY Method
LeastSquaresEstimateY Method
Constructs the regression line of Y on X using the method of least squares.
Overload List
Overload | Description
LeastSquaresEstimateY(String,Series) | Constructs the regression line of Y on X using the method of least squares.
LeastSquaresEstimateY(Series) | Constructs the regression line of Y on X using the method of least squares.
LeastSquaresEstimateY(SeriesCollection) | Constructs the regression line of Y on X using the method of least squares.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateY Method : LeastSquaresEstimateY(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
LeastSquaresEstimateY(String,Series) Method
Constructs the regression line of Y on X using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateY( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.LeastSquaresEstimateY(seriesName, s)
public static Series LeastSquaresEstimateY(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of X on Y, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateY Method : LeastSquaresEstimateY(Series) Method
A statistical series.
LeastSquaresEstimateY(Series) Method
Constructs the regression line of Y on X using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateY( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.LeastSquaresEstimateY(s)
public static Series LeastSquaresEstimateY(
   Series s
)

Parameters

s
A statistical series.
Remarks
That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of X on Y, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class > LeastSquaresEstimateY Method : LeastSquaresEstimateY(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
LeastSquaresEstimateY(SeriesCollection) Method
Constructs the regression line of Y on X using the method of least squares.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LeastSquaresEstimateY( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.LeastSquaresEstimateY(sc)
public static SeriesCollection LeastSquaresEstimateY(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
That is, the regression line using the least squares method is constructed when the second element of the pairs from which the data set of constructed is plot against the first elements of the pairs.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Calculates the regression line of X on Y, using the method of least squares.


dotnetCHARTING Namespace > StatisticalEngine Class : LinearlyWeightedMovingAverage Method
LinearlyWeightedMovingAverage Method
Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
Overload List
Overload | Description
LinearlyWeightedMovingAverage(String,Series,Int32) | Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
LinearlyWeightedMovingAverage(Series,Int32) | Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
LinearlyWeightedMovingAverage(SeriesCollection,Int32) | Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > LinearlyWeightedMovingAverage Method : LinearlyWeightedMovingAverage(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The number of periods over which the moving average is evaluated for each period.
LinearlyWeightedMovingAverage(String,Series,Int32) Method
Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearlyWeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.LinearlyWeightedMovingAverage(seriesName, s, lengthOfMA)
public static Series LinearlyWeightedMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LinearlyWeightedMovingAverage Method : LinearlyWeightedMovingAverage(Series,Int32) Method
A statistical series.
The number of periods over which the moving average is evaluated for each period.
LinearlyWeightedMovingAverage(Series,Int32) Method
Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearlyWeightedMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.LinearlyWeightedMovingAverage(s, lengthOfMA)
public static Series LinearlyWeightedMovingAverage(
   Series s,
   int lengthOfMA
)

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LinearlyWeightedMovingAverage Method : LinearlyWeightedMovingAverage(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of periods over which the moving average is evaluated for each period.
LinearlyWeightedMovingAverage(SeriesCollection,Int32) Method
Returns the value of the Linearly Weighted Moving Average (LWMA) for all periods for which sufficient historical data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LinearlyWeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.LinearlyWeightedMovingAverage(sc, lengthOfMA)
public static SeriesCollection LinearlyWeightedMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.

Return Value

A series where the first term is the LWMA of length lengthOfMA for the latest period, the second term is the LWMA of length lengthOfMA for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty or if its length is less than the lengthofMA.
Remarks
The Linearly Weighted Moving Average (LWMA) weights the time series by assigning a weight of 1, to the oldest price and a weight of 2, to the second oldest price and so on... Until the weight of the most recent value is assigned to be the parameter lengthOfMA, after which the LWMA is given by the sum of the weighted prices divided by the sum of the weights. This indicator then shifts the window (one place back) over which the MA is evaluated and the indicator is then re-evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : LognormalDistribution Method
LognormalDistribution Method
Calculates the Lognormal Probability Density function for a given series.
Overload List
Overload | Description
LognormalDistribution(String,Series,Double) | Calculates the Lognormal Probability Density function for a given series.
LognormalDistribution(Series,Double) | Calculates the Lognormal Probability Density function for a given series.
LognormalDistribution(SeriesCollection,Double) | Calculates the Lognormal Probability Density function for a given collection of series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > LognormalDistribution Method : LognormalDistribution(String,Series,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The standard deviation of the distribution.
LognormalDistribution(String,Series,Double) Method
Calculates the Lognormal Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LognormalDistribution( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal variance As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim variance As Double
Dim value As Series

value = StatisticalEngine.LognormalDistribution(seriesName, s, variance)
public static Series LognormalDistribution(
   string seriesName,
   Series s,
   double variance
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LognormalDistribution Method : LognormalDistribution(Series,Double) Method
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The standard deviation of the distribution.
LognormalDistribution(Series,Double) Method
Calculates the Lognormal Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LognormalDistribution( _
   ByVal s As Series, _
   ByVal variance As Double _
) As Series
'Usage

Dim s As Series
Dim variance As Double
Dim value As Series

value = StatisticalEngine.LognormalDistribution(s, variance)
public static Series LognormalDistribution(
   Series s,
   double variance
)

Parameters

s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LognormalDistribution Method : LognormalDistribution(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The standard deviation of the distribution.
LognormalDistribution(SeriesCollection,Double) Method
Calculates the Lognormal Probability Density function for a given collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LognormalDistribution( _
   ByVal sc As SeriesCollection, _
   ByVal variance As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim variance As Double
Dim value As SeriesCollection

value = StatisticalEngine.LognormalDistribution(sc, variance)
public static SeriesCollection LognormalDistribution(
   SeriesCollection sc,
   double variance
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : LowerBollingerBands Method
LowerBollingerBands Method (StatisticalEngine)
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Overload List
Overload | Description
LowerBollingerBands(String,Series,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
LowerBollingerBands(Series,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
LowerBollingerBands(SeriesCollection,Double,Int32) | Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > LowerBollingerBands Method : LowerBollingerBands(String,Series,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(String,Series,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.LowerBollingerBands(seriesName, s, standardDeviationLevel, lengthOfMA)
public static Series LowerBollingerBands(
   string seriesName,
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LowerBollingerBands Method : LowerBollingerBands(Series,Double,Int32) Method
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(Series,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.LowerBollingerBands(s, standardDeviationLevel, lengthOfMA)
public static Series LowerBollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
A series where the first term correspond the latest periods values and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation and the moving average.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > LowerBollingerBands Method : LowerBollingerBands(SeriesCollection,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of standard deviation which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
LowerBollingerBands(SeriesCollection,Double,Int32) Method
Evaluates the position of the Lower Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LowerBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.LowerBollingerBands(sc, standardDeviationLevel, lengthOfMA)
public static SeriesCollection LowerBollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The number of standard deviation which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown when the series in empty or the number of standard deviations considered (i.e. the parameters standardDeviationLevel) is not positive number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Lower Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : Mean Method
Mean Method (StatisticalEngine)
Calculates the arithmetic mean of the elements YValues of the series.
Overload List
Overload | Description
Mean(String,Series) | Calculates the arithmetic mean of the elements YValues of the series.
Mean(Series) | Calculates the arithmetic mean of the elements YValues of the series.
Mean(String,SeriesCollection) | Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.
Mean(SeriesCollection) | Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Mean Method : Mean(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Mean(String,Series) Method
Calculates the arithmetic mean of the elements YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Mean(elementName, s)
public static Element Mean(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

An element with his YValue representing the arithmetic mean of the elements YValues of the series
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the geometric mean of the series.
Mean(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Mean Method : Mean(Series) Method
A statistical series.
Mean(Series) Method
Calculates the arithmetic mean of the elements YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Mean(s)
public static Element Mean(
   Series s
)

Parameters

s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the geometric mean of the series.
Mean(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Mean Method : Mean(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Mean(String,SeriesCollection) Method
Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Mean(seriesName, sc)
public static Series Mean(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the geometric mean of the series.
Mean(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Mean Method : Mean(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Mean(SeriesCollection) Method
Calculates the arithmetic mean of the elements YValues of each of the series within the collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Mean( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Mean(sc)
public static Series Mean(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the geometric mean of the series.
Mean(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class : MeanDeviation Method
MeanDeviation Method (StatisticalEngine)
Calculates the mean deviation of the series's element YValues.
Overload List
Overload | Description
MeanDeviation(String,Series) | Calculates the mean deviation of the series's element YValues.
MeanDeviation(Series) | Calculates the mean deviation of the series's element YValues.
MeanDeviation(String,SeriesCollection) | Calculates the mean deviation of the series's element YValues.
MeanDeviation(SeriesCollection) | Calculates the mean deviation of the series's element YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > MeanDeviation Method : MeanDeviation(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
MeanDeviation(String,Series) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.MeanDeviation(elementName, s)
public static Element MeanDeviation(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation - a measure of the deviation of the elements of the data set considered.
MeanDeviation(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > MeanDeviation Method : MeanDeviation(Series) Method
A statistical series.
MeanDeviation(Series) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.MeanDeviation(s)
public static Element MeanDeviation(
   Series s
)

Parameters

s
A statistical series.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation - a measure of the deviation of the elements of the data set considered.
MeanDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > MeanDeviation Method : MeanDeviation(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
MeanDeviation(String,SeriesCollection) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.MeanDeviation(seriesName, sc)
public static Series MeanDeviation(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation - a measure of the deviation of the elements of the data set considered.
MeanDeviation(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > MeanDeviation Method : MeanDeviation(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
MeanDeviation(SeriesCollection) Method
Calculates the mean deviation of the series's element YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MeanDeviation( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.MeanDeviation(sc)
public static Series MeanDeviation(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The mean deviation is exactly what the name implies, that is, it is the arithmetic average of the differences from each of the elements of the series to the mean of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation - a measure of the deviation of the elements of the data set considered.
MeanDeviation(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Median Method
Median Method (StatisticalEngine)
Calculates the median of the series's elements YValues.
Overload List
Overload | Description
Median(String,Series) | Calculates the median of the series's elements YValues.
Median(Series) | Calculates the median of the series's elements YValues.
Median(String,SeriesCollection) | Calculates the median of the series's elements YValues.
Median(SeriesCollection) | Calculates the median of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Median Method : Median(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Median(String,Series) Method
Calculates the median of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Median(elementName, s)
public static Element Median(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
Median(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Median Method : Median(Series) Method
A statistical series.
Median(Series) Method
Calculates the median of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Median(s)
public static Element Median(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.


dotnetCHARTING Namespace > StatisticalEngine Class > Median Method : Median(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Median(String,SeriesCollection) Method
Calculates the median of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Median(seriesName, sc)
public static Series Median(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
Median(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Median Method : Median(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Median(SeriesCollection) Method
Calculates the median of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Median( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Median(sc)
public static Series Median(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the arithmetic mean of the series.
Median(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : MedianMovingAverage Method
MedianMovingAverage Method (StatisticalEngine)
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Overload List
Overload | Description
MedianMovingAverage(String,Series,Series,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
MedianMovingAverage(Series,Series,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
MedianMovingAverage(SeriesCollection,Int32) | Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > MedianMovingAverage Method : MedianMovingAverage(String,Series,Series,Int32) Method
The name of the series.
A series where the elements corresponds to the highest recorded values.
A series where the elements corresponds to the lowest recorded values.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(String,Series,Series,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal seriesName As String, _
   ByVal highSeries As Series, _
   ByVal lowSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim highSeries As Series
Dim lowSeries As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.MedianMovingAverage(seriesName, highSeries, lowSeries, lengthOfMA)
public static Series MedianMovingAverage(
   string seriesName,
   Series highSeries,
   Series lowSeries,
   int lengthOfMA
)

Parameters

seriesName
The name of the series.
highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > MedianMovingAverage Method : MedianMovingAverage(Series,Series,Int32) Method
A series where the elements corresponds to the highest recorded values.
A series where the elements corresponds to the lowest recorded values.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(Series,Series,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal highSeries As Series, _
   ByVal lowSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim highSeries As Series
Dim lowSeries As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.MedianMovingAverage(highSeries, lowSeries, lengthOfMA)
public static Series MedianMovingAverage(
   Series highSeries,
   Series lowSeries,
   int lengthOfMA
)

Parameters

highSeries
A series where the elements corresponds to the highest recorded values.
lowSeries
A series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > MedianMovingAverage Method : MedianMovingAverage(SeriesCollection,Int32) Method
A colection of two series: a series where the elements corresponds to the highest recorded values and a series where the elements corresponds to the lowest recorded values.
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.
MedianMovingAverage(SeriesCollection,Int32) Method
Returns the Median Moving Average of a given period of the data series provided for all possible periods for the data given.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function MedianMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.MedianMovingAverage(sc, lengthOfMA)
public static Series MedianMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
)

Parameters

sc
A colection of two series: a series where the elements corresponds to the highest recorded values and a series where the elements corresponds to the lowest recorded values.
lengthOfMA
The number of periods considered within the evaluation of the moving average of each of the days on which it can be evaluated.

Return Value

A series where the first term is the value of the Median Moving Average for the most recent period, the second term is the value of the Median Moving Average for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series highSeries and lowSeries are of different lengths or if one of these arrays is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : NormalDistribution Method
NormalDistribution Method
Calculates the Normal Probability Density function for a given series.
Overload List
Overload | Description
NormalDistribution(String,Series,Double) | Calculates the Normal Probability Density function for a given series.
NormalDistribution(Series,Double) | Calculates the Normal Probability Density function for a given series.
NormalDistribution(SeriesCollection,Double) | Calculates the Normal Probability Density function for a given collection of series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > NormalDistribution Method : NormalDistribution(String,Series,Double) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The standard deviation of the distribution.
NormalDistribution(String,Series,Double) Method
Calculates the Normal Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NormalDistribution( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal variance As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim variance As Double
Dim value As Series

value = StatisticalEngine.NormalDistribution(seriesName, s, variance)
public static Series NormalDistribution(
   string seriesName,
   Series s,
   double variance
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > NormalDistribution Method : NormalDistribution(Series,Double) Method
A statistical series containing the elements for which the normal probability distribution function is evaluated.
The standard deviation of the distribution.
NormalDistribution(Series,Double) Method
Calculates the Normal Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NormalDistribution( _
   ByVal s As Series, _
   ByVal variance As Double _
) As Series
'Usage

Dim s As Series
Dim variance As Double
Dim value As Series

value = StatisticalEngine.NormalDistribution(s, variance)
public static Series NormalDistribution(
   Series s,
   double variance
)

Parameters

s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > NormalDistribution Method : NormalDistribution(SeriesCollection,Double) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The standard deviation of the distribution.
NormalDistribution(SeriesCollection,Double) Method
Calculates the Normal Probability Density function for a given collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function NormalDistribution( _
   ByVal sc As SeriesCollection, _
   ByVal variance As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim variance As Double
Dim value As SeriesCollection

value = StatisticalEngine.NormalDistribution(sc, variance)
public static SeriesCollection NormalDistribution(
   SeriesCollection sc,
   double variance
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
variance
The standard deviation of the distribution.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : ParetoDistribution Method
ParetoDistribution Method
Calculates the Pareto Probability Density function for a given series.
Overload List
Overload | Description
ParetoDistribution(String,Series) | Calculates the Pareto Probability Density function for a given series.
ParetoDistribution(Series) | Calculates the Pareto Probability Density function for a given series.
ParetoDistribution(SeriesCollection) | Calculates the Pareto Probability Density function for a given collection of series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > ParetoDistribution Method : ParetoDistribution(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series containing the elements for which the normal probability distribution function is evaluated.
ParetoDistribution(String,Series) Method
Calculates the Pareto Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ParetoDistribution( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.ParetoDistribution(seriesName, s)
public static Series ParetoDistribution(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ParetoDistribution Method : ParetoDistribution(Series) Method
A statistical series containing the elements for which the normal probability distribution function is evaluated.
ParetoDistribution(Series) Method
Calculates the Pareto Probability Density function for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ParetoDistribution( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.ParetoDistribution(s)
public static Series ParetoDistribution(
   Series s
)

Parameters

s
A statistical series containing the elements for which the normal probability distribution function is evaluated.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ParetoDistribution Method : ParetoDistribution(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ParetoDistribution(SeriesCollection) Method
Calculates the Pareto Probability Density function for a given collection of series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ParetoDistribution( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.ParetoDistribution(sc)
public static SeriesCollection ParetoDistribution(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : PearsonCorrelationCoef Method
PearsonCorrelationCoef Method
Calculates Pearson's correlation coefficient for the YValues of the series.
Overload List
Overload | Description
PearsonCorrelationCoef(String,Series) | Calculates Pearson's correlation coefficient for the YValues of the series.
PearsonCorrelationCoef(Series) | Calculates Pearson's correlation coefficient for the YValues of the series.
PearsonCorrelationCoef(String,SeriesCollection) | Calculates Pearson's correlation coefficient for the YValues of the series.
PearsonCorrelationCoef(SeriesCollection) | Calculates Pearson's correlation coefficient for the YValues of the series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > PearsonCorrelationCoef Method : PearsonCorrelationCoef(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
PearsonCorrelationCoef(String,Series) Method
Calculates Pearson's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PearsonCorrelationCoef( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.PearsonCorrelationCoef(elementName, s)
public static Element PearsonCorrelationCoef(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

Pearson's correlation coefficient of the series
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > PearsonCorrelationCoef Method : PearsonCorrelationCoef(Series) Method
A statistical series.
PearsonCorrelationCoef(Series) Method
Calculates Pearson's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PearsonCorrelationCoef( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.PearsonCorrelationCoef(s)
public static Element PearsonCorrelationCoef(
   Series s
)

Parameters

s
A statistical series.

Return Value

Pearson's correlation coefficient of the series
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > PearsonCorrelationCoef Method : PearsonCorrelationCoef(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
PearsonCorrelationCoef(String,SeriesCollection) Method
Calculates Pearson's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PearsonCorrelationCoef( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.PearsonCorrelationCoef(seriesName, sc)
public static Series PearsonCorrelationCoef(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > PearsonCorrelationCoef Method : PearsonCorrelationCoef(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
PearsonCorrelationCoef(SeriesCollection) Method
Calculates Pearson's correlation coefficient for the YValues of the series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function PearsonCorrelationCoef( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.PearsonCorrelationCoef(sc)
public static Series PearsonCorrelationCoef(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : Percentile Method
Percentile Method (StatisticalEngine)
Calculates the n-th percentile of the series's elements YValues.
Overload List
Overload | Description
Percentile(String,Series,Int32) | Calculates the n-th percentile of the series's elements YValues.
Percentile(Series,Int32) | Calculates the n-th percentile of the series's elements YValues.
Percentile(String,SeriesCollection,Int32) | Calculates the n-th percentile of the series's elements YValues.
Percentile(SeriesCollection,Int32) | Calculates the n-th percentile of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile Method : Percentile(String,Series,Int32) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
A value between 1 and 100 which reprezent the value of the percetile.
Percentile(String,Series,Int32) Method
Calculates the n-th percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal elementName As String, _
   ByVal s As Series, _
   ByVal percentile As Integer _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim percentile As Integer
Dim value As Element

value = StatisticalEngine.Percentile(elementName, s, percentile)
public static Element Percentile(
   string elementName,
   Series s,
   int percentile
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
percentile
A value between 1 and 100 which reprezent the value of the percetile.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
The third percentile.


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile Method : Percentile(Series,Int32) Method
A statistical series.
A value between 1 and 100 which reprezent the value of the percetile.
Percentile(Series,Int32) Method
Calculates the n-th percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal s As Series, _
   ByVal percentile As Integer _
) As Element
'Usage

Dim s As Series
Dim percentile As Integer
Dim value As Element

value = StatisticalEngine.Percentile(s, percentile)
public static Element Percentile(
   Series s,
   int percentile
)

Parameters

s
A statistical series.
percentile
A value between 1 and 100 which reprezent the value of the percetile.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile Method : Percentile(String,SeriesCollection,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A value between 1 and 100 which reprezent the value of the percetile.
Percentile(String,SeriesCollection,Int32) Method
Calculates the n-th percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection, _
   ByVal percentile As Integer _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim percentile As Integer
Dim value As Series

value = StatisticalEngine.Percentile(seriesName, sc, percentile)
public static Series Percentile(
   string seriesName,
   SeriesCollection sc,
   int percentile
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
percentile
A value between 1 and 100 which reprezent the value of the percetile.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile Method : Percentile(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A value between 1 and 100 which reprezent the value of the percetile.
Percentile(SeriesCollection,Int32) Method
Calculates the n-th percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile( _
   ByVal sc As SeriesCollection, _
   ByVal percentile As Integer _
) As Series
'Usage

Dim sc As SeriesCollection
Dim percentile As Integer
Dim value As Series

value = StatisticalEngine.Percentile(sc, percentile)
public static Series Percentile(
   SeriesCollection sc,
   int percentile
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
percentile
A value between 1 and 100 which reprezent the value of the percetile.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Percentile25 Method
Percentile25 Method (StatisticalEngine)
Calculates the first percentile of the series's elements YValues.
Overload List
Overload | Description
Percentile25(String,Series) | Calculates the first percentile of the series's elements YValues.
Percentile25(Series) | Calculates the first percentile of the series's elements YValues.
Percentile25(String,SeriesCollection) | Calculates the first percentile of the series's elements YValues.
Percentile25(SeriesCollection) | Calculates the first percentile of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile25 Method : Percentile25(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Percentile25(String,Series) Method
Calculates the first percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile25(elementName, s)
public static Element Percentile25(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The second percentile.
The third percentile.
Percentile25(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile25 Method : Percentile25(Series) Method
A statistical series.
Percentile25(Series) Method
Calculates the first percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile25(s)
public static Element Percentile25(
   Series s
)

Parameters

s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The second percentile.
The third percentile.
Percentile25(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile25 Method : Percentile25(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile25(String,SeriesCollection) Method
Calculates the first percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile25(seriesName, sc)
public static Series Percentile25(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The second percentile.
The third percentile.
Percentile25(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile25 Method : Percentile25(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile25(SeriesCollection) Method
Calculates the first percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile25( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile25(sc)
public static Series Percentile25(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The second percentile.
The third percentile.
Percentile25(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Percentile50 Method
Percentile50 Method (StatisticalEngine)
Calculates the second percentile of the series's elements YValues.
Overload List
Overload | Description
Percentile50(String,Series) | Calculates the second percentile of the series's elements YValues.
Percentile50(Series) | Calculates the second percentile of the series's elements YValues.
Percentile50(String,SeriesCollection) | Calculates the second percentile of the series's elements YValues.
Percentile50(SeriesCollection) | Calculates the second percentile of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile50 Method : Percentile50(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Percentile50(String,Series) Method
Calculates the second percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile50(elementName, s)
public static Element Percentile50(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The third percentile.
Percentile50(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile50 Method : Percentile50(Series) Method
A statistical series.
Percentile50(Series) Method
Calculates the second percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile50(s)
public static Element Percentile50(
   Series s
)

Parameters

s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The third percentile.
Percentile50(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile50 Method : Percentile50(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile50(String,SeriesCollection) Method
Calculates the second percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile50(seriesName, sc)
public static Series Percentile50(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The third percentile.
Percentile50(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile50 Method : Percentile50(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile50(SeriesCollection) Method
Calculates the second percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile50( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile50(sc)
public static Series Percentile50(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The third percentile.
Percentile50(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Percentile75 Method
Percentile75 Method (StatisticalEngine)
Calculates the third percentile of the series's elements YValues.
Overload List
Overload | Description
Percentile75(String,Series) | Calculates the third percentile of the series's elements YValues.
Percentile75(Series) | Calculates the third percentile of the series's elements YValues.
Percentile75(String,SeriesCollection) | Calculates the third percentile of the series's elements YValues.
Percentile75(SeriesCollection) | Calculates the third percentile of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile75 Method : Percentile75(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Percentile75(String,Series) Method
Calculates the third percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile75(elementName, s)
public static Element Percentile75(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using Median(String,Series,ElementValue).
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile75 Method : Percentile75(Series) Method
A statistical series.
Percentile75(Series) Method
Calculates the third percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Percentile75(s)
public static Element Percentile75(
   Series s
)

Parameters

s
A statistical series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile75 Method : Percentile75(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile75(String,SeriesCollection) Method
Calculates the third percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile75(seriesName, sc)
public static Series Percentile75(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Percentile75 Method : Percentile75(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Percentile75(SeriesCollection) Method
Calculates the third percentile of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Percentile75( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Percentile75(sc)
public static Series Percentile75(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
Recall that the percentile is the value such that at least interest-percent of the data set items are less than or equal to this value, or equivalently if at least (100-interest) percent of the items are greater than or equal to this value.

Remarks:

  1. The 50-th percentile is the measure of centrality of a data set known as the median. The median can also be evaluated using dotnetCHARTING.AnalysisEngine.Implementation.FinancialMedian.
  2. The 25-th, 50-th, 75-th percentiles are often referred to as the 1-st, 2-nd (median) and 3-rd quartile respectively. The term quartile refers to the fact that these three values will roughly divide the data set considered into four equal parts.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
The first percentile.
The second percentile.
Percentile75(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Range Method
Range Method (StatisticalEngine)
Calculates the range of the series's elements YValues.
Overload List
Overload | Description
Range(String,Series) | Calculates the range of the series's elements YValues.
Range(Series) | Calculates the range of the series's elements YValues.
Range(String,SeriesCollection) | Calculates the range of the series's elements YValues.
Range(SeriesCollection) | Calculates the range of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Range Method : Range(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Range(String,Series) Method
Calculates the range of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Range(elementName, s)
public static Element Range(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Range(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Range Method : Range(Series) Method
A statistical series.
Range(Series) Method
Calculates the range of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Range(s)
public static Element Range(
   Series s
)

Parameters

s
A statistical series.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Range(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Range Method : Range(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Range(String,SeriesCollection) Method
Calculates the range of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Range(seriesName, sc)
public static Series Range(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Range(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Range Method : Range(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Range(SeriesCollection) Method
Calculates the range of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Range( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Range(sc)
public static Series Range(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The range is the difference of a discrete data set is the difference between the largest and smallest members of the data set considered.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Range(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : RChart Method
RChart Method
Create the R Chart chart for a given SeriesCollection object.
Overload List
Overload | Description
RChart(String,SeriesCollection) | Create the R Chart chart for a given SeriesCollection object.
RChart(SeriesCollection) | Create the R Chart chart for a given SeriesCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > RChart Method : RChart(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
RChart(String,SeriesCollection) Method
Create the R Chart chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RChart( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.RChart(seriesName, sc)
public static Series RChart(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RChart Method : RChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
RChart(SeriesCollection) Method
Create the R Chart chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RChart( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.RChart(sc)
public static Series RChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : Residuals Method
Residuals Method
Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Overload List
Overload | Description
Residuals(String,Series) | Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Residuals(Series) | Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Residuals(SeriesCollection) | Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Residuals Method : Residuals(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
Residuals(String,Series) Method
Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Residuals( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.Residuals(seriesName, s)
public static Series Residuals(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > Residuals Method : Residuals(Series) Method
A statistical series.
Residuals(Series) Method
Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Residuals( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.Residuals(s)
public static Series Residuals(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > Residuals Method : Residuals(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Residuals(SeriesCollection) Method
Determines the residual for the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Residuals( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.Residuals(sc)
public static SeriesCollection Residuals(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : ResidualsAverage Method
ResidualsAverage Method
Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Overload List
Overload | Description
ResidualsAverage(String,Series) | Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
ResidualsAverage(Series) | Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
ResidualsAverage(String,SeriesCollection) | Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
ResidualsAverage(SeriesCollection) | Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > ResidualsAverage Method : ResidualsAverage(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
ResidualsAverage(String,Series) Method
Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ResidualsAverage( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.ResidualsAverage(elementName, s)
public static Element ResidualsAverage(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ResidualsAverage Method : ResidualsAverage(Series) Method
A statistical series.
ResidualsAverage(Series) Method
Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ResidualsAverage( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.ResidualsAverage(s)
public static Element ResidualsAverage(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ResidualsAverage Method : ResidualsAverage(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ResidualsAverage(String,SeriesCollection) Method
Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ResidualsAverage( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.ResidualsAverage(seriesName, sc)
public static Series ResidualsAverage(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ResidualsAverage Method : ResidualsAverage(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ResidualsAverage(SeriesCollection) Method
Determines the arithmetic average of the residuals for all pairs of points within the current statistical series in accordance with the regression line constructed using LeastSquaresRegressionLineX.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ResidualsAverage( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.ResidualsAverage(sc)
public static Series ResidualsAverage(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : RFrequencyTableOL Method
RFrequencyTableOL Method
Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
Overload List
Overload | Description
RFrequencyTableOL(String,Series,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
RFrequencyTableOL(Series,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
RFrequencyTableOL(SeriesCollection,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOL Method : RFrequencyTableOL(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOL(String,Series,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOL( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.RFrequencyTableOL(seriesName, s, boundaries)
public static Series RFrequencyTableOL(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOL Method : RFrequencyTableOL(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOL(Series,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOL( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.RFrequencyTableOL(s, boundaries)
public static Series RFrequencyTableOL(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOL Method : RFrequencyTableOL(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOL(SeriesCollection,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open left boundary (OLB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOL( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.RFrequencyTableOL(sc, boundaries)
public static SeriesCollection RFrequencyTableOL(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open left boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open left boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Left Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open left boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1], (b_1,b_2], (b_2,b_3], (b_3,b_4], (b_4,b_5], (5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : RFrequencyTableOR Method
RFrequencyTableOR Method
Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
Overload List
Overload | Description
RFrequencyTableOR(String,Series,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
RFrequencyTableOR(Series,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
RFrequencyTableOR(SeriesCollection,Double[]) | Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOR Method : RFrequencyTableOR(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOR(String,Series,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOR( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.RFrequencyTableOR(seriesName, s, boundaries)
public static Series RFrequencyTableOR(
   string seriesName,
   Series s,
   double[] boundaries
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOR Method : RFrequencyTableOR(Series,Double[]) Method
A statistical series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOR(Series,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOR( _
   ByVal s As Series, _
   ByVal boundaries() As Double _
) As Series
'Usage

Dim s As Series
Dim boundaries() As Double
Dim value As Series

value = StatisticalEngine.RFrequencyTableOR(s, boundaries)
public static Series RFrequencyTableOR(
   Series s,
   double[] boundaries
)

Parameters

s
A statistical series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RFrequencyTableOR Method : RFrequencyTableOR(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
RFrequencyTableOR(SeriesCollection,Double[]) Method
Calculates the relative frequency table for a discrete data set in accordance with the open right boundary (ORB) convention.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RFrequencyTableOR( _
   ByVal sc As SeriesCollection, _
   ByVal boundaries() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim boundaries() As Double
Dim value As SeriesCollection

value = StatisticalEngine.RFrequencyTableOR(sc, boundaries)
public static SeriesCollection RFrequencyTableOR(
   SeriesCollection sc,
   double[] boundaries
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
boundaries
A strictly increasing sequence of boundaries of the intervals over the real line in which the data sets point will be assigned.
Remarks
The relative frequency table normalized the data with regard to the size of the data set before evaluating the frequency table is exactly the same fashion as dotnetCHARTING.AnalysisEngine.Implementation.StatisticalFrequencyTableOL.

Further Explanation

If we are comparing two or more data sets then the frequencies should be normalized to reflect the possible different sizes of the data sets themselves. To normalize a data set we much first divide the data set into a collection of classes into which the elements are assigned. Here we assign the data set in accordance with the open right boundary convention where the class frequencies are just the number of elements within each of the sub-intervals of the real line in accordance with the open right boundary convention (see example below).

To evaluate the relative frequency we apply the following formula to each class:

Relative frequency = (class frequency) / (total frequency)

where the class frequency is the number of data points within a given sub-interval of the real line, and the total frequency is the total number of elements within the data set considered.

Example Illustration the Open Right Boundary Convention

Consider the set of boundaries { b_1, b_2, b_3, b_4, b_5 }, where b_1 < b_2 < b_3 < b_4 < b_5, which divide the real line into six sub-intervals. Now if we use the open right boundary convention then the real line will be divided into the sub-intervals:

(-infinity, b_1), [b_1,b_2), [b_2,b_3), [b_3,b_4), [b_4,b_5), [b_5, infinity)

Note that, each point on the real line can be assigned to one of these sub-intervals and therefore when assigning a data point to one of these intervals there will only be one sub-interval in which it belongs.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : RunChart Method
RunChart Method
Create the run chart for a given series.
Overload List
Overload | Description
RunChart(String,Series) | Create the run chart for a given series.
RunChart(Series) | Create the run chart for a given series.
RunChart(SeriesCollection) | Create the run chart for a given SeriesCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > RunChart Method : RunChart(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
RunChart(String,Series) Method
Create the run chart for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RunChart( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.RunChart(seriesName, s)
public static Series RunChart(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.

Return Value

An element with his YValue representing the arithmetic mean of the elements YValues of the series
Exceptions
Exception | Description
 | Thrown if the series s is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RunChart Method : RunChart(Series) Method
A statistical series.
RunChart(Series) Method
Create the run chart for a given series.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RunChart( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.RunChart(s)
public static Series RunChart(
   Series s
)

Parameters

s
A statistical series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series s is empty
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RunChart Method : RunChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
RunChart(SeriesCollection) Method
Create the run chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RunChart( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.RunChart(sc)
public static SeriesCollection RunChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : RXBARChart Method
RXBARChart Method
Create the XBAR Chart based on R Chart results for a given SeriesCollection object.
Overload List
Overload | Description
RXBARChart(String,SeriesCollection) | Create the XBAR Chart based on R Chart results for a given SeriesCollection object.
RXBARChart(SeriesCollection) | Create the XBAR Chart based on R Chart for a given SeriesCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > RXBARChart Method : RXBARChart(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
RXBARChart(String,SeriesCollection) Method
Create the XBAR Chart based on R Chart results for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RXBARChart( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.RXBARChart(seriesName, sc)
public static Series RXBARChart(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > RXBARChart Method : RXBARChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
RXBARChart(SeriesCollection) Method
Create the XBAR Chart based on R Chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function RXBARChart( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.RXBARChart(sc)
public static Series RXBARChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : SChart Method
SChart Method
Create the S Chart chart for a given SeriesCollection object.
Overload List
Overload | Description
SChart(String,SeriesCollection) | Create the S Chart chart for a given SeriesCollection object.
SChart(SeriesCollection) | Create the S Chart chart for a given SeriesCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > SChart Method : SChart(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SChart(String,SeriesCollection) Method
Create the S Chart chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SChart( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SChart(seriesName, sc)
public static Series SChart(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > SChart Method : SChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SChart(SeriesCollection) Method
Create the S Chart chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SChart( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SChart(sc)
public static Series SChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : SimpleMovingAverage Method
SimpleMovingAverage Method (StatisticalEngine)
Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Overload List
Overload | Description
SimpleMovingAverage(String,Series,Int32) | Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
SimpleMovingAverage(Series,Int32) | Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
SimpleMovingAverage(SeriesCollection,Int32) | Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(String,Series,Int32) Method
Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.SimpleMovingAverage(seriesName, s, lengthOfMA)
public static Series SimpleMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Geometric Moving Average (GMA)
SimpleMovingAverage(Series,Int32) Method
SimpleMovingAverage(SeriesCollection,Int32) Method


dotnetCHARTING Namespace > StatisticalEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(Series,Int32) Method
A statistical series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(Series,Int32) Method
Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.SimpleMovingAverage(s, lengthOfMA)
public static Series SimpleMovingAverage(
   Series s,
   int lengthOfMA
)

Parameters

s
A statistical series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Geometric Moving Average (GMA)
SimpleMovingAverage(String,Series,Int32) Method
SimpleMovingAverage(SeriesCollection,Int32) Method


dotnetCHARTING Namespace > StatisticalEngine Class > SimpleMovingAverage Method : SimpleMovingAverage(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.
SimpleMovingAverage(SeriesCollection,Int32) Method
Calculates the arithmetic(or simple) Moving Average (MA) of a given period for all possible data points (i.e. periods) for which there is sufficient historical data provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SimpleMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.SimpleMovingAverage(sc, lengthOfMA)
public static SeriesCollection SimpleMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods considered within the evaluation of the moving average for each of the periods on which it can be evaluated.

Return Value

A series where the first term corresponds to the Moving Average on the last period and the previous value is the value of the Moving average on the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the series is empty.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Geometric Moving Average (GMA)
SimpleMovingAverage(String,Series,Int32) Method
SimpleMovingAverage(Series,Int32) Method


dotnetCHARTING Namespace > StatisticalEngine Class : Skewness Method
Skewness Method (StatisticalEngine)
Calculates the skewness of the currently registered data set.
Overload List
Overload | Description
Skewness(String,Series) | Calculates the skewness of the currently registered data set.
Skewness(Series) | Calculates the skewness of the currently registered data set.
Skewness(String,SeriesCollection) | Calculates the skewness of the currently registered data set.
Skewness(SeriesCollection) | Calculates the skewness of the currently registered data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Skewness Method : Skewness(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Skewness(String,Series) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Skewness(elementName, s)
public static Element Skewness(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Skewness(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Skewness Method : Skewness(Series) Method
A statistical series.
Skewness(Series) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Skewness(s)
public static Element Skewness(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Skewness(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Skewness Method : Skewness(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Skewness(String,SeriesCollection) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Skewness(seriesName, sc)
public static Series Skewness(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Skewness(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Skewness Method : Skewness(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Skewness(SeriesCollection) Method
Calculates the skewness of the currently registered data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Skewness( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Skewness(sc)
public static Series Skewness(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Evaluates the range of the series's elements YValues.
Skewness(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : SpearmanRankCorrelationTest Method
SpearmanRankCorrelationTest Method
Calculates Spearson's Rank correlation coefficient for the current data set.
Overload List
Overload | Description
SpearmanRankCorrelationTest(String,Series) | Calculates Spearson's Rank correlation coefficient for the current data set.
SpearmanRankCorrelationTest(Series) | Calculates Spearson's Rank correlation coefficient for the current data set.
SpearmanRankCorrelationTest(String,SeriesCollection) | Calculates Spearson's Rank correlation coefficient for the current data set.
SpearmanRankCorrelationTest(SeriesCollection) | Calculates Spearson's Rank correlation coefficient for the current data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > SpearmanRankCorrelationTest Method : SpearmanRankCorrelationTest(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
SpearmanRankCorrelationTest(String,Series) Method
Calculates Spearson's Rank correlation coefficient for the current data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SpearmanRankCorrelationTest( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.SpearmanRankCorrelationTest(elementName, s)
public static Element SpearmanRankCorrelationTest(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > SpearmanRankCorrelationTest Method : SpearmanRankCorrelationTest(Series) Method
A statistical series.
SpearmanRankCorrelationTest(Series) Method
Calculates Spearson's Rank correlation coefficient for the current data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SpearmanRankCorrelationTest( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.SpearmanRankCorrelationTest(s)
public static Element SpearmanRankCorrelationTest(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > SpearmanRankCorrelationTest Method : SpearmanRankCorrelationTest(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SpearmanRankCorrelationTest(String,SeriesCollection) Method
Calculates Spearson's Rank correlation coefficient for the current data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SpearmanRankCorrelationTest( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SpearmanRankCorrelationTest(seriesName, sc)
public static Series SpearmanRankCorrelationTest(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > SpearmanRankCorrelationTest Method : SpearmanRankCorrelationTest(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SpearmanRankCorrelationTest(SeriesCollection) Method
Calculates Spearson's Rank correlation coefficient for the current data set.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SpearmanRankCorrelationTest( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SpearmanRankCorrelationTest(sc)
public static Series SpearmanRankCorrelationTest(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : StandardDeviation Method
StandardDeviation Method (StatisticalEngine)
Calculates the sample standard variance of the series's elements YValues.
Overload List
Overload | Description
StandardDeviation(String,Series) | Calculates the sample standard variance of the series's elements YValues.
StandardDeviation(Series) | Calculates the sample standard variance of the series's elements YValues.
StandardDeviation(String,SeriesCollection) | Calculates the sample standard variance of the series's elements YValues.
StandardDeviation(SeriesCollection) | Calculates the sample standard variance of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > StandardDeviation Method : StandardDeviation(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
StandardDeviation(String,Series) Method
Calculates the sample standard variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.StandardDeviation(elementName, s)
public static Element StandardDeviation(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(String,Series) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.
StandardDeviation(Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > StandardDeviation Method : StandardDeviation(Series) Method
A statistical series.
StandardDeviation(Series) Method
Calculates the sample standard variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.StandardDeviation(s)
public static Element StandardDeviation(
   Series s
)

Parameters

s
A statistical series.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(Series) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.
StandardDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > StandardDeviation Method : StandardDeviation(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
StandardDeviation(String,SeriesCollection) Method
Calculates the sample standard variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.StandardDeviation(seriesName, sc)
public static Series StandardDeviation(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(Series) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.
StandardDeviation(SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class > StandardDeviation Method : StandardDeviation(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
StandardDeviation(SeriesCollection) Method
Calculates the sample standard variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function StandardDeviation( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.StandardDeviation(sc)
public static Series StandardDeviation(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks

Remark: The units of the Sample Standard Deviation will correspond to the units used by the observations (i.e. the units of the members of the data set). In many instances it is convenient that the units used for the observations corresponds to the units used for a measure of the sets deviations. This differs from the Variance(Series) in which the deviation is measured in units which are the squares of the units of the observations.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
Another measure of the deviation of the elements of the data set considered.
StandardDeviation(String,SeriesCollection) Method


dotnetCHARTING Namespace > StatisticalEngine Class : SXBARChart Method
SXBARChart Method
Create the XBAR Chart based on S Chart results for a given SeriesCollection object.
Overload List
Overload | Description
SXBARChart(String,SeriesCollection) | Create the XBAR Chart based on S Chart results for a given SeriesCollection object.
SXBARChart(SeriesCollection) | Create the XBAR Chart based on S Chart for a given SeriesCollection object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > SXBARChart Method : SXBARChart(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SXBARChart(String,SeriesCollection) Method
Create the XBAR Chart based on S Chart results for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SXBARChart( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SXBARChart(seriesName, sc)
public static Series SXBARChart(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > SXBARChart Method : SXBARChart(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
SXBARChart(SeriesCollection) Method
Create the XBAR Chart based on S Chart for a given SeriesCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function SXBARChart( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.SXBARChart(sc)
public static Series SXBARChart(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the sc does not contain any series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : TriangularMovingAverage Method
TriangularMovingAverage Method (StatisticalEngine)
Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Overload List
Overload | Description
TriangularMovingAverage(String,Series,Int32) | Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
TriangularMovingAverage(Series,Int32) | Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
TriangularMovingAverage(SeriesCollection,Int32) | Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(String,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(String,Series,Int32) Method
Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.TriangularMovingAverage(seriesName, s, lengthOfMA)
public static Series TriangularMovingAverage(
   string seriesName,
   Series s,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(Series,Int32) Method
A statistical series.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(Series,Int32) Method
Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal s As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.TriangularMovingAverage(s, lengthOfMA)
public static Series TriangularMovingAverage(
   Series s,
   int lengthOfMA
)

Parameters

s
A statistical series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > TriangularMovingAverage Method : TriangularMovingAverage(SeriesCollection,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The number of periods over which the moving average is evaluated for each period.
TriangularMovingAverage(SeriesCollection,Int32) Method
Evaluates the x-period Triangular Moving Average (TMA) where x corresponds to the length of the time series array given as a parameter, for all periods for which sufficient data is provided.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function TriangularMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.TriangularMovingAverage(sc, lengthOfMA)
public static SeriesCollection TriangularMovingAverage(
   SeriesCollection sc,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
lengthOfMA
The number of periods over which the moving average is evaluated for each period.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : UpperBollingerBands Method
UpperBollingerBands Method (StatisticalEngine)
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Overload List
Overload | Description
UpperBollingerBands(String,Series,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
UpperBollingerBands(Series,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
UpperBollingerBands(SeriesCollection,Double,Int32) | Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > UpperBollingerBands Method : UpperBollingerBands(String,Series,Double,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(String,Series,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.UpperBollingerBands(seriesName, s, standardDeviationLevel, lengthOfMA)
public static Series UpperBollingerBands(
   string seriesName,
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > UpperBollingerBands Method : UpperBollingerBands(Series,Double,Int32) Method
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(Series,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal s As Series, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.UpperBollingerBands(s, standardDeviationLevel, lengthOfMA)
public static Series UpperBollingerBands(
   Series s,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

s
An series where the first term correspond the latest periods value and the previous element is the value of the element before that and so on... The length of this series is equal to the number of periods used in the evaluation of the standard deviation.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > UpperBollingerBands Method : UpperBollingerBands(SeriesCollection,Double,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
The (positive) number of standard deviations which the lower band in shifted from the moving average.
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.
UpperBollingerBands(SeriesCollection,Double,Int32) Method
Evaluates the position of the Upper Bollinger Band for a given standard deviation level.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function UpperBollingerBands( _
   ByVal sc As SeriesCollection, _
   ByVal standardDeviationLevel As Double, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim standardDeviationLevel As Double
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.UpperBollingerBands(sc, standardDeviationLevel, lengthOfMA)
public static SeriesCollection UpperBollingerBands(
   SeriesCollection sc,
   double standardDeviationLevel,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
standardDeviationLevel
The (positive) number of standard deviations which the lower band in shifted from the moving average.
lengthOfMA
The length of the moving average used within the evaluation of the Bollinger Bands. Note that this also corresponds to the length of the period over which the standard deviation is evaluated.

Return Value

A series where the first term corresponds to the value of the Upper Bollinger Band for the latest periods, the second terms to the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Throw if the series historicalPrices is empty or if the number of standard deviations given (i.e. the parameter standardDeviationsLevel)is a negative number.
Remarks
Please note that by standard deviation level we not only refer to the number of standard deviations shifts away from the moving average at which the Higher Bollinger Band is drawn but also the number of time series points which are used in the evaluation of the standard deviation and the moving average.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : Variance Method
Variance Method (StatisticalEngine)
Calculates the sample variance of the series's elements YValues.
Overload List
Overload | Description
Variance(String,Series) | Calculates the sample variance of the series's elements YValues.
Variance(Series) | Calculates the sample variance of the series's elements YValues.
Variance(String,SeriesCollection) | Calculates the sample variance of the series's elements YValues.
Variance(SeriesCollection) | Calculates the sample variance of the series's elements YValues.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > Variance Method : Variance(String,Series) Method
The name of the element which will be displayed on the chart, i.e. its label.
A statistical series.
Variance(String,Series) Method
Calculates the sample variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal elementName As String, _
   ByVal s As Series _
) As Element
'Usage

Dim elementName As String
Dim s As Series
Dim value As Element

value = StatisticalEngine.Variance(elementName, s)
public static Element Variance(
   string elementName,
   Series s
)

Parameters

elementName
The name of the element which will be displayed on the chart, i.e. its label.
s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation(String,Series) Method
StatndardDeviation - a measure of the deviation of the elements
            of the data set considered.
Variance(Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Variance Method : Variance(Series) Method
A statistical series.
Variance(Series) Method
Calculates the sample variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal s As Series _
) As Element
'Usage

Dim s As Series
Dim value As Element

value = StatisticalEngine.Variance(s)
public static Element Variance(
   Series s
)

Parameters

s
A statistical series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation(String,Series) Method
A measure of the deviation of the elements of the
            data set considered.
Variance(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Variance Method : Variance(String,SeriesCollection) Method
The name of the series which will be displayed on the chart, i.e. its label.
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Variance(String,SeriesCollection) Method
Calculates the sample variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal seriesName As String, _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim seriesName As String
Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Variance(seriesName, sc)
public static Series Variance(
   string seriesName,
   SeriesCollection sc
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation(String,Series) Method
A measure of the deviation of
            the elements of the data set considered.
Variance(SeriesCollection) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class > Variance Method : Variance(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Variance(SeriesCollection) Method
Calculates the sample variance of the series's elements YValues.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function Variance( _
   ByVal sc As SeriesCollection _
) As Series
'Usage

Dim sc As SeriesCollection
Dim value As Series

value = StatisticalEngine.Variance(sc)
public static Series Variance(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List
StandardDeviation(String,Series) Method
A measure of the deviation of the
            elements of the data set considered.
Variance(String,SeriesCollection) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method
StandardDeviation(String,Series) Method


dotnetCHARTING Namespace > StatisticalEngine Class : WeightedMovingAverage Method
WeightedMovingAverage Method (StatisticalEngine)
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Overload List
Overload | Description
WeightedMovingAverage(String,Series,Series,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(Series,Series,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(SeriesCollection,Series,Int32) | Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
WeightedMovingAverage(String,Series,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
WeightedMovingAverage(Series,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
WeightedMovingAverage(SeriesCollection,Double[]) | Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(String,Series,Series,Int32) Method
The name of the series which will be displayed on the chart, i.e. its label.
An statistical series
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(String,Series,Series,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim weightSeries As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.WeightedMovingAverage(seriesName, s, weightSeries, lengthOfMA)
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   Series weightSeries,
   int lengthOfMA
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(Series,Series,Int32) Method
An statistical series
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(Series,Series,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As Series
'Usage

Dim s As Series
Dim weightSeries As Series
Dim lengthOfMA As Integer
Dim value As Series

value = StatisticalEngine.WeightedMovingAverage(s, weightSeries, lengthOfMA)
public static Series WeightedMovingAverage(
   Series s,
   Series weightSeries,
   int lengthOfMA
)

Parameters

s
An statistical series
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(SeriesCollection,Series,Int32) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
The number of periods over which the weighted moving average is evaluated.
WeightedMovingAverage(SeriesCollection,Series,Int32) Method
Evaluate the Weighted Moving Average(WMA) where the weights associated to all the elements of the historical values are given and the WMA is evaluated for all periods for which there is sufficient historical data.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal weightSeries As Series, _
   ByVal lengthOfMA As Integer _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim weightSeries As Series
Dim lengthOfMA As Integer
Dim value As SeriesCollection

value = StatisticalEngine.WeightedMovingAverage(sc, weightSeries, lengthOfMA)
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   Series weightSeries,
   int lengthOfMA
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weightSeries
A series of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
lengthOfMA
The number of periods over which the weighted moving average is evaluated.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weightsSeries and s differ or if either series is empty.
Remarks
That is, the weights are fixed for all given historical values and the window of length lengthOfMA over which the GMA is evaluated is shifted along the series.

Application

Generally speaking the WMA where the weights are all set and the window over which GMA is evaluated is shifted is used when you wish to give emphasis to particular dates.

Note: The length of the weights array must equal or be greater than the length of the historicalPrices series. If it's greater than we ignore the supplementary values.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(String,Series,Double[]) Method
The name of the series which will be displayed on the chart, i.e. its label.
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(String,Series,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal seriesName As String, _
   ByVal s As Series, _
   ByVal weights() As Double _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim weights() As Double
Dim value As Series

value = StatisticalEngine.WeightedMovingAverage(seriesName, s, weights)
public static Series WeightedMovingAverage(
   string seriesName,
   Series s,
   double[] weights
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to (historicalPrices, weights, lengthOfMovingAverage).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(Series,Double[]) Method
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(Series,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal s As Series, _
   ByVal weights() As Double _
) As Series
'Usage

Dim s As Series
Dim weights() As Double
Dim value As Series

value = StatisticalEngine.WeightedMovingAverage(s, weights)
public static Series WeightedMovingAverage(
   Series s,
   double[] weights
)

Parameters

s
An series of historical values, where the first element corresponds to the market on the last period, the second term to the value on previous period and so on.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to (historicalPrices, weights, lengthOfMovingAverage).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > WeightedMovingAverage Method : WeightedMovingAverage(SeriesCollection,Double[]) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.
WeightedMovingAverage(SeriesCollection,Double[]) Method
Here we evaluate the Weighted Moving Average(WMA) where for each period for which the WMA is evaluated the historical terms are weighted in accordance with the same set of weights.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function WeightedMovingAverage( _
   ByVal sc As SeriesCollection, _
   ByVal weights() As Double _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim weights() As Double
Dim value As SeriesCollection

value = StatisticalEngine.WeightedMovingAverage(sc, weights)
public static SeriesCollection WeightedMovingAverage(
   SeriesCollection sc,
   double[] weights
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
weights
Array of doubles which assigns weights to the k-th previous historical values for the given period on which the moving average is being evaluated. Here k is just the length of the weights array given.

Return Value

A series where the first term is the value of the moving average corresponding of the latest period, the second term is the value for the previous period and so on.
Exceptions
Exception | Description
System.ArgumentException | Thrown if the length of the weights and series differ or if either array is empty.
Remarks
I.e. The weights shift with the window of the historical values.

Application

Generally speaking the WMA is used in order to allow more weight to be assigned to more resent price dynamics. Here the length of the weights array is used as the length of the period over which the moving average is calculated. If you wish to control the number of periods used within the moving average then we refer you to (historicalPrices, weights, lengthOfMovingAverage).

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class : ZScore Method
ZScore Method (StatisticalEngine)
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Overload List
Overload | Description
ZScore(String,Series) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
ZScore(Series) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
ZScore(SeriesCollection) | Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members


dotnetCHARTING Namespace > StatisticalEngine Class > ZScore Method : ZScore(String,Series) Method
The name of the series which will be displayed on the chart, i.e. its label.
A statistical series.
ZScore(String,Series) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal seriesName As String, _
   ByVal s As Series _
) As Series
'Usage

Dim seriesName As String
Dim s As Series
Dim value As Series

value = StatisticalEngine.ZScore(seriesName, s)
public static Series ZScore(
   string seriesName,
   Series s
)

Parameters

seriesName
The name of the series which will be displayed on the chart, i.e. its label.
s
A statistical series.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ZScore Method : ZScore(Series) Method
A statistical series.
ZScore(Series) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal s As Series _
) As Series
'Usage

Dim s As Series
Dim value As Series

value = StatisticalEngine.ZScore(s)
public static Series ZScore(
   Series s
)

Parameters

s
A statistical series.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


dotnetCHARTING Namespace > StatisticalEngine Class > ZScore Method : ZScore(SeriesCollection) Method
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
ZScore(SeriesCollection) Method
Evaluates the z-score (often referred to as the standardized value) of an element series's element values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function ZScore( _
   ByVal sc As SeriesCollection _
) As SeriesCollection
'Usage

Dim sc As SeriesCollection
Dim value As SeriesCollection

value = StatisticalEngine.ZScore(sc)
public static SeriesCollection ZScore(
   SeriesCollection sc
)

Parameters

sc
A collection of series objects. For example, to evaluate this indicator for two series you will need to pass a series collection containing this two series.
Remarks
The z-score denotes the number of standard deviations of a given element of the data set is from the mean of the data set.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine Class
StatisticalEngine Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : StatisticalEngine.Options Class
StatisticalEngine.Options Class
Defines a set of static options used with StatisticalEngine calculations.
Object Model
StatisticalEngine.Options Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public NotInheritable Class StatisticalEngine.Options
'Usage

Dim instance As StatisticalEngine.Options
public sealed class StatisticalEngine.Options
Inheritance Hierarchy

System.Object
dotnetCHARTING.StatisticalEngine.Options

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine.Options Members
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : StatisticalEngine.Options Class
StatisticalEngine.Options Class Members

The following tables list the members exposed by StatisticalEngine.Options.

Public Constructors
 | Name | Description
Public Constructor | StatisticalEngine.Options Constructor |
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

StatisticalEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


%%PageItemTitle%%

dotnetCHARTING Namespace > StatisticalEngine.Options Class : StatisticalEngine.Options Constructor
StatisticalEngine.Options Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New StatisticalEngine.Options()
public StatisticalEngine.Options()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine.Options Class
StatisticalEngine.Options Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : StatisticalEngine.Options Class
StatisticalEngine.Options Class Methods

For a list of all members of this type, see StatisticalEngine.Options members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | Reset | Resets the options to default settings.
Top
See Also

Reference

StatisticalEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > StatisticalEngine.Options Class : Reset Method
Reset Method (StatisticalEngine.Options)
Resets the options to default settings.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Sub Reset()
'Usage

StatisticalEngine.Options.Reset()
public static void Reset()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine.Options Class
StatisticalEngine.Options Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : StatisticalEngine.Options Class
StatisticalEngine.Options Class Properties

For a list of all members of this type, see StatisticalEngine.Options members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | MatchColors | Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
static (Shared in Visual Basic) | PopulateSubValues | Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Top
See Also

Reference

StatisticalEngine.Options Class
dotnetCHARTING Namespace

Tutorials

Analysis Engine


dotnetCHARTING Namespace > StatisticalEngine.Options Class : MatchColors Property
MatchColors Property (StatisticalEngine.Options)
Gets or sets a value that indicates whether calculated elements will use the same colors that are assigned to original series. Both, the original and derived data objects must be placed on the same chart to enable this feature.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property MatchColors As Boolean
'Usage

Dim value As Boolean

StatisticalEngine.Options.MatchColors = value

value = StatisticalEngine.Options.MatchColors
public static bool MatchColors {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine.Options Class
StatisticalEngine.Options Members


dotnetCHARTING Namespace > StatisticalEngine.Options Class : PopulateSubValues Property
PopulateSubValues Property (StatisticalEngine.Options)
Gets or sets a static value that determines whether elements derived from series will contain values of the original elements as SubValue objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Property PopulateSubValues As Boolean
'Usage

Dim value As Boolean

StatisticalEngine.Options.PopulateSubValues = value

value = StatisticalEngine.Options.PopulateSubValues
public static bool PopulateSubValues {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

StatisticalEngine.Options Class
StatisticalEngine.Options Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SubValue Class
SubValue Class
Represents a value relative to or independent of the parent element's value.
Object Model
SubValue ClassLine ClassElementMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SubValue
'Usage

Dim instance As SubValue
public class SubValue
Inheritance Hierarchy

System.Object
dotnetCHARTING.SubValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : SubValue Class
SubValue Class Members

The following tables list the members exposed by SubValue.

Public Constructors
 | Name | Description
Public Constructor | SubValue Constructor |
Top
Public Properties
 | Name | Description
Public Property | ErrorHigh |
Public Property | ErrorHighValue |
Public Property | ErrorLow |
Public Property | ErrorLowValue |
Public Property | ErrorPercentageHigh |
Public Property | ErrorPercentageLow |
Public Property | Line | Gets or sets a Line object used to draw the lines of this SubValue.
Public Property | Marker | Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..
Public Property | Name |
Public Property | Type | Gets or sets a SubValueType that determines how this sub value is drawn.
Public Property | Visible | Gets or sets a value that indicates whether this sub value is visible.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromHighLowValue | Creates a new instance of a SubValue object with an independent range based on the specified low and high values.
static (Shared in Visual Basic) | FromOffset | Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.
static (Shared in Visual Basic) | FromPercent | Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.
static (Shared in Visual Basic) | FromPlusMinusOffset | Overloaded. Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.
static (Shared in Visual Basic) | FromPlusMinusPercent | Overloaded. Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
static (Shared in Visual Basic) | FromValue | Overloaded. Creates a new instance of a SubValue class with a single independent value.
static (Shared in Visual Basic) | FromValues | Returns a SubValueCollection with a SubValue object for each of the specified values.
static (Shared in Visual Basic) | FromValuesList |
Top
See Also

Reference

SubValue Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > SubValue Class : SubValue Constructor
SubValue Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New SubValue()
public SubValue()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : SubValue Class
SubValue Class Methods

For a list of all members of this type, see SubValue members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | FromHighLowValue | Creates a new instance of a SubValue object with an independent range based on the specified low and high values.
static (Shared in Visual Basic) | FromOffset | Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.
static (Shared in Visual Basic) | FromPercent | Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.
static (Shared in Visual Basic) | FromPlusMinusOffset | Overloaded. Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.
static (Shared in Visual Basic) | FromPlusMinusPercent | Overloaded. Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
static (Shared in Visual Basic) | FromValue | Overloaded. Creates a new instance of a SubValue class with a single independent value.
static (Shared in Visual Basic) | FromValues | Returns a SubValueCollection with a SubValue object for each of the specified values.
static (Shared in Visual Basic) | FromValuesList |
Top
See Also

Reference

SubValue Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > SubValue Class : FromHighLowValue Method
FromHighLowValue Method
Creates a new instance of a SubValue object with an independent range based on the specified low and high values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromHighLowValue( _
   ByVal high As Double, _
   ByVal low As Double _
) As SubValue
'Usage

Dim high As Double
Dim low As Double
Dim value As SubValue

value = SubValue.FromHighLowValue(high, low)
public static SubValue FromHighLowValue(
   double high,
   double low
)

Parameters

high
low
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : FromOffset Method
FromOffset Method
Creates a new instance of a SubValue class with a single value offset from an element's Yvalue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromOffset( _
   ByVal offset As Double _
) As SubValue
'Usage

Dim offset As Double
Dim value As SubValue

value = SubValue.FromOffset(offset)
public static SubValue FromOffset(
   double offset
)

Parameters

offset
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : FromPercent Method
FromPercent Method
Creates a new instance of a SubValue class with a single value based on the specified percentage of the related element's Yvalue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromPercent( _
   ByVal percent As Double _
) As SubValue
'Usage

Dim percent As Double
Dim value As SubValue

value = SubValue.FromPercent(percent)
public static SubValue FromPercent(
   double percent
)

Parameters

percent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : FromPlusMinusOffset Method
FromPlusMinusOffset Method
Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.
Overload List
Overload | Description
FromPlusMinusOffset(Double,Double) | Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.
FromPlusMinusOffset(Double) | Creates a new instance of a SubValue class with a range offset from an element's Yvalue in both directions. Hence, the resulting range will be twice the specified offset value.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class > FromPlusMinusOffset Method : FromPlusMinusOffset(Double,Double) Method
FromPlusMinusOffset(Double,Double) Method
Creates a new instance of a SubValue class with a different range offset from an element's Yvalue in both directions. Hence, the resulting range will be the sum of the high and low offset values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromPlusMinusOffset( _
   ByVal plus As Double, _
   ByVal minus As Double _
) As SubValue
'Usage

Dim plus As Double
Dim minus As Double
Dim value As SubValue

value = SubValue.FromPlusMinusOffset(plus, minus)
public static SubValue FromPlusMinusOffset(
   double plus,
   double minus
)

Parameters

plus
minus
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class > FromPlusMinusOffset Method : FromPlusMinusOffset(Double) Method
FromPlusMinusOffset(Double) Method
Creates a new instance of a SubValue class with a range offset from an element's Yvalue in both directions. Hence, the resulting range will be twice the specified offset value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromPlusMinusOffset( _
   ByVal offset As Double _
) As SubValue
'Usage

Dim offset As Double
Dim value As SubValue

value = SubValue.FromPlusMinusOffset(offset)
public static SubValue FromPlusMinusOffset(
   double offset
)

Parameters

offset
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class : FromPlusMinusPercent Method
FromPlusMinusPercent Method
Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
Overload List
Overload | Description
FromPlusMinusPercent(Double) | Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
FromPlusMinusPercent(Double,Double) | Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class > FromPlusMinusPercent Method : FromPlusMinusPercent(Double) Method
FromPlusMinusPercent(Double) Method
Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromPlusMinusPercent( _
   ByVal percent As Double _
) As SubValue
'Usage

Dim percent As Double
Dim value As SubValue

value = SubValue.FromPlusMinusPercent(percent)
public static SubValue FromPlusMinusPercent(
   double percent
)

Parameters

percent
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class > FromPlusMinusPercent Method : FromPlusMinusPercent(Double,Double) Method
FromPlusMinusPercent(Double,Double) Method
Creates a new instance of a SubValue class with a range based on the specified percentage of the related element's Yvalue in both directions. Hence, the resulting range will be twice the specified percentage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromPlusMinusPercent( _
   ByVal minus As Double, _
   ByVal plus As Double _
) As SubValue
'Usage

Dim minus As Double
Dim plus As Double
Dim value As SubValue

value = SubValue.FromPlusMinusPercent(minus, plus)
public static SubValue FromPlusMinusPercent(
   double minus,
   double plus
)

Parameters

minus
plus
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class : FromValue Method
FromValue Method
Creates a new instance of a SubValue class with a single independent value.
Overload List
Overload | Description
FromValue(Double) | Creates a new instance of a SubValue class with a single independent value.
FromValue(Double,SubValueType) | Creates a new instance of a SubValue class with a single independent value and of the specified type.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class > FromValue Method : FromValue(Double) Method
FromValue(Double) Method
Creates a new instance of a SubValue class with a single independent value.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromValue( _
   ByVal val As Double _
) As SubValue
'Usage

Dim val As Double
Dim value As SubValue

value = SubValue.FromValue(val)
public static SubValue FromValue(
   double val
)

Parameters

val
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class > FromValue Method : FromValue(Double,SubValueType) Method
FromValue(Double,SubValueType) Method
Creates a new instance of a SubValue class with a single independent value and of the specified type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function FromValue( _
   ByVal val As Double, _
   ByVal svType As SubValueType _
) As SubValue
'Usage

Dim val As Double
Dim svType As SubValueType
Dim value As SubValue

value = SubValue.FromValue(val, svType)
public static SubValue FromValue(
   double val,
   SubValueType svType
)

Parameters

val
svType
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members
Overload List


dotnetCHARTING Namespace > SubValue Class : FromValues Method
FromValues Method (SubValue)
Returns a SubValueCollection with a SubValue object for each of the specified values.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromValues( _
   ByVal vals() As Double _
) As SubValueCollection
'Usage

Dim vals() As Double
Dim value As SubValueCollection

value = SubValue.FromValues(vals)
public static SubValueCollection FromValues(
   double[] vals
)

Parameters

vals
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : FromValuesList Method
A comma delimited list of values.
FromValuesList Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function FromValuesList( _
   ByVal vals As String _
) As SubValueCollection
'Usage

Dim vals As String
Dim value As SubValueCollection

value = SubValue.FromValuesList(vals)
public static SubValueCollection FromValuesList(
   string vals
)

Parameters

vals
A comma delimited list of values.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SubValue Class
SubValue Class Properties

For a list of all members of this type, see SubValue members.

Public Properties
 | Name | Description
Public Property | ErrorHigh |
Public Property | ErrorHighValue |
Public Property | ErrorLow |
Public Property | ErrorLowValue |
Public Property | ErrorPercentageHigh |
Public Property | ErrorPercentageLow |
Public Property | Line | Gets or sets a Line object used to draw the lines of this SubValue.
Public Property | Marker | Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..
Public Property | Name |
Public Property | Type | Gets or sets a SubValueType that determines how this sub value is drawn.
Public Property | Visible | Gets or sets a value that indicates whether this sub value is visible.
Top
See Also

Reference

SubValue Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > SubValue Class : ErrorHigh Property
ErrorHigh Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorHigh As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorHigh = value

value = instance.ErrorHigh
public double ErrorHigh {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : ErrorHighValue Property
ErrorHighValue Property (SubValue)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorHighValue As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorHighValue = value

value = instance.ErrorHighValue
public double ErrorHighValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : ErrorLow Property
ErrorLow Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorLow As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorLow = value

value = instance.ErrorLow
public double ErrorLow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : ErrorLowValue Property
ErrorLowValue Property (SubValue)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorLowValue As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorLowValue = value

value = instance.ErrorLowValue
public double ErrorLowValue {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : ErrorPercentageHigh Property
ErrorPercentageHigh Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorPercentageHigh As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorPercentageHigh = value

value = instance.ErrorPercentageHigh
public double ErrorPercentageHigh {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : ErrorPercentageLow Property
ErrorPercentageLow Property
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ErrorPercentageLow As Double
'Usage

Dim instance As SubValue
Dim value As Double

instance.ErrorPercentageLow = value

value = instance.ErrorPercentageLow
public double ErrorPercentageLow {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : Line Property
Line Property (SubValue)
Gets or sets a Line object used to draw the lines of this SubValue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As SubValue
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : Marker Property
Marker Property (SubValue)
Gets or sets an ElementMarker object drawn when the SubValue's type is set to SubValueType.Marker..
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As SubValue
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : Name Property
Name Property (SubValue)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As SubValue
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : Type Property
Type Property (SubValue)
Gets or sets a SubValueType that determines how this sub value is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As SubValueType
'Usage

Dim instance As SubValue
Dim value As SubValueType

instance.Type = value

value = instance.Type
public SubValueType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


dotnetCHARTING Namespace > SubValue Class : Visible Property
Visible Property (SubValue)
Gets or sets a value that indicates whether this sub value is visible.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Visible As Boolean
'Usage

Dim instance As SubValue
Dim value As Boolean

instance.Visible = value

value = instance.Visible
public bool Visible {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValue Class
SubValue Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : SubValueCollection Class
SubValueCollection Class
Contains a collection of SubValue objects.
Object Model
SubValueCollection ClassSubValue Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class SubValueCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As SubValueCollection
public class SubValueCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.SubValueCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : SubValueCollection Class
SubValueCollection Class Members

The following tables list the members exposed by SubValueCollection.

Public Constructors
 | Name | Description
Public Constructor | SubValueCollection Constructor | Creates a new instance of SubValueCollection with the specified list of SubValue objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified SubValue class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified SubValue.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetValues | Gets a comma delimited list of values in this SubValueCollection.
Public Method | IndexOf | Determines index of a specified SubValue in this collection.
Public Method | Insert | Inserts a SubValue into this collection at a specified index.
Public Method | Remove | Removes a specified SubValue from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SubValueCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > SubValueCollection Class : SubValueCollection Constructor
SubValueCollection Constructor
Creates a new instance of SubValueCollection with the specified list of SubValue objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray subValueList() As SubValue _
)
'Usage

Dim subValueList() As SubValue

Dim instance As New SubValueCollection(subValueList)
public SubValueCollection(
   params SubValue[] subValueList
)

Parameters

subValueList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : SubValueCollection Class
SubValueCollection Class Methods

For a list of all members of this type, see SubValueCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified SubValue class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified SubValue.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | GetValues | Gets a comma delimited list of values in this SubValueCollection.
Public Method | IndexOf | Determines index of a specified SubValue in this collection.
Public Method | Insert | Inserts a SubValue into this collection at a specified index.
Public Method | Remove | Removes a specified SubValue from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

SubValueCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > SubValueCollection Class : Add Method
Add Method (SubValueCollection)
Adds a specified SubValue class to this collection.
Overload List
Overload | Description
Add(SubValue) | Adds a specified SubValue class to this collection.
Add(SubValueCollection) | Adds a specified SubValueCollection to this collection.
Add(SubValue[]) | Adds the specified SubValue objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


dotnetCHARTING Namespace > SubValueCollection Class > Add Method : Add(SubValue) Method
The SubValue to add.
Add(SubValue) Method
Adds a specified SubValue class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal subValue As SubValue _
) As Integer
'Usage

Dim instance As SubValueCollection
Dim subValue As SubValue
Dim value As Integer

value = instance.Add(subValue)
public int Add(
   SubValue subValue
)

Parameters

subValue
The SubValue to add.

Return Value

The zero-based index of the added SubValue.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members
Overload List


dotnetCHARTING Namespace > SubValueCollection Class > Add Method : Add(SubValueCollection) Method
The SubValueCollection to add.
Add(SubValueCollection) Method
Adds a specified SubValueCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal subValueCollection As SubValueCollection _
)
'Usage

Dim instance As SubValueCollection
Dim subValueCollection As SubValueCollection

instance.Add(subValueCollection)
public void Add(
   SubValueCollection subValueCollection
)

Parameters

subValueCollection
The SubValueCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members
Overload List


dotnetCHARTING Namespace > SubValueCollection Class > Add Method : Add(SubValue[]) Method
A list of SubValue objects to add.
Add(SubValue[]) Method
Adds the specified SubValue objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray subValueList() As SubValue _
)
'Usage

Dim instance As SubValueCollection
Dim subValueList() As SubValue

instance.Add(subValueList)
public void Add(
   params SubValue[] subValueList
)

Parameters

subValueList
A list of SubValue objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members
Overload List


dotnetCHARTING Namespace > SubValueCollection Class : Contains Method
The SubValue to find.
Contains Method (SubValueCollection)
Determines whether this collection contains a specified SubValue.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal subValue As SubValue _
) As Boolean
'Usage

Dim instance As SubValueCollection
Dim subValue As SubValue
Dim value As Boolean

value = instance.Contains(subValue)
public bool Contains(
   SubValue subValue
)

Parameters

subValue
The SubValue to find.

Return Value

true if the specified SubValue belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


dotnetCHARTING Namespace > SubValueCollection Class : GetValues Method
GetValues Method
Gets a comma delimited list of values in this SubValueCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetValues() As String
'Usage

Dim instance As SubValueCollection
Dim value As String

value = instance.GetValues()
public string GetValues()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


dotnetCHARTING Namespace > SubValueCollection Class : IndexOf Method
The SubValue to find.
IndexOf Method (SubValueCollection)
Determines index of a specified SubValue in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal subValue As SubValue _
) As Integer
'Usage

Dim instance As SubValueCollection
Dim subValue As SubValue
Dim value As Integer

value = instance.IndexOf(subValue)
public int IndexOf(
   SubValue subValue
)

Parameters

subValue
The SubValue to find.

Return Value

The zero-based index of the specified SubValue.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


dotnetCHARTING Namespace > SubValueCollection Class : Insert Method
The zero-based index into the collection at which to insert the SubValue.
The SubValue to insert into this collection.
Insert Method (SubValueCollection)
Inserts a SubValue into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal subValue As SubValue _
)
'Usage

Dim instance As SubValueCollection
Dim index As Integer
Dim subValue As SubValue

instance.Insert(index, subValue)
public void Insert(
   int index,
   SubValue subValue
)

Parameters

index
The zero-based index into the collection at which to insert the SubValue.
subValue
The SubValue to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


dotnetCHARTING Namespace > SubValueCollection Class : Remove Method
The SubValue to remove.
Remove Method (SubValueCollection)
Removes a specified SubValue from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal subValue As SubValue _
)
'Usage

Dim instance As SubValueCollection
Dim subValue As SubValue

instance.Remove(subValue)
public void Remove(
   SubValue subValue
)

Parameters

subValue
The SubValue to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : SubValueCollection Class
SubValueCollection Class Properties

For a list of all members of this type, see SubValueCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

SubValueCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > SubValueCollection Class : Item Property
Item Property (SubValueCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As SubValue
'Usage

Dim instance As SubValueCollection
Dim index As Integer
Dim value As SubValue

instance.Item(index) = value

value = instance.Item(index)
public SubValue this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SubValueCollection Class
SubValueCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : TimeIntervalAdvanced Class
TimeIntervalAdvanced Class
Represents a time interval and instant at which it occurs.
Object Model
TimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced ClassTimeIntervalAdvanced Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TimeIntervalAdvanced
'Usage

Dim instance As TimeIntervalAdvanced
public class TimeIntervalAdvanced
Remarks
This time is specific down to the millisecond.
Inheritance Hierarchy

System.Object
dotnetCHARTING.TimeIntervalAdvanced

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : TimeIntervalAdvanced Class
TimeIntervalAdvanced Class Members

The following tables list the members exposed by TimeIntervalAdvanced.

Public Constructors
 | Name | Description
Public Constructor | TimeIntervalAdvanced Constructor | Overloaded.
Top
Public Properties
 | Name | Description
static (Shared in Visual Basic) | Day | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Days | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Hour | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Hours | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Milliseconds | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Minutes | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Month | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Months | Gets a system-defined TimeIntervalAdvanced object.
Public Property | Multiplier | Gets or sets the factor by which this time interval is multiplied.
static (Shared in Visual Basic) | None | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Quarter | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Quarters | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Seconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property | Start | Gets or sets a DateTime object representing the time instant at which this interval initially occurs.
Public Property | StartDayOfWeek | Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
Public Property | StartMonth | Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
Public Property | TimeSpan | Gets or sets a custom time span between each time instant occurrence.
Public Property | Unit | Gets or sets a TimeInterval which is the based interval for this TimeIntervalAdvanced.
static (Shared in Visual Basic) | Week | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Weeks | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Year | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Years | Gets a system-defined TimeIntervalAdvanced object.
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddTimeInterval | Adds a TimeInterval to the specified DateTime.
static (Shared in Visual Basic) | SubtractTimeInterval | Subtracts a TimeInterval from the specified DateTime.
Top
Public Operators
public Operator Addition | Overloaded. Adds a TimeIntervalAdvanced to a DateTime object.
public Operator Equality | Overloaded. Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.
public Operator Inequality | Overloaded. Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.
public Operator Subtraction | Subtracts a TimeIntervalAdvanced from a DateTime object.
Top
See Also

Reference

TimeIntervalAdvanced Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > TimeIntervalAdvanced Class : TimeIntervalAdvanced Constructor
TimeIntervalAdvanced Constructor
Overload List
Overload | Description
TimeIntervalAdvanced Constructor() |
TimeIntervalAdvanced Constructor(TimeSpan) | Creates a new instance of TimeIntervalAdvanced with a custom time span.
TimeIntervalAdvanced Constructor(TimeInterval,Int32) | Creates a new instance of TimeIntervalAdvanced with a TimeInterval and a factor by which the interval is multiplied.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


%%PageItemTitle%%

dotnetCHARTING Namespace > TimeIntervalAdvanced Class > TimeIntervalAdvanced Constructor : TimeIntervalAdvanced Constructor()
TimeIntervalAdvanced Constructor()
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New TimeIntervalAdvanced()
public TimeIntervalAdvanced()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > TimeIntervalAdvanced Class > TimeIntervalAdvanced Constructor : TimeIntervalAdvanced Constructor(TimeSpan)
TimeIntervalAdvanced Constructor(TimeSpan)
Creates a new instance of TimeIntervalAdvanced with a custom time span.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal span As TimeSpan _
)
'Usage

Dim span As TimeSpan

Dim instance As New TimeIntervalAdvanced(span)
public TimeIntervalAdvanced(
   TimeSpan span
)

Parameters

span
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > TimeIntervalAdvanced Class > TimeIntervalAdvanced Constructor : TimeIntervalAdvanced Constructor(TimeInterval,Int32)
A base TimeInterval enumeration.
Factor by which the to multiple the TimeInterval.
TimeIntervalAdvanced Constructor(TimeInterval,Int32)
Creates a new instance of TimeIntervalAdvanced with a TimeInterval and a factor by which the interval is multiplied.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal interval As TimeInterval, _
   ByVal factor As Integer _
)
'Usage

Dim interval As TimeInterval
Dim factor As Integer

Dim instance As New TimeIntervalAdvanced(interval, factor)
public TimeIntervalAdvanced(
   TimeInterval interval,
   int factor
)

Parameters

interval
A base TimeInterval enumeration.
factor
Factor by which the to multiple the TimeInterval.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members
Overload List


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : TimeIntervalAdvanced Class
TimeIntervalAdvanced Class Methods

For a list of all members of this type, see TimeIntervalAdvanced members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | AddTimeInterval | Adds a TimeInterval to the specified DateTime.
static (Shared in Visual Basic) | SubtractTimeInterval | Subtracts a TimeInterval from the specified DateTime.
Top
See Also

Reference

TimeIntervalAdvanced Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : AddTimeInterval Method
The date to add to.
The TimeInterval to add.
AddTimeInterval Method
Adds a TimeInterval to the specified DateTime.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function AddTimeInterval( _
   ByVal lhs As Date, _
   ByVal rhs As TimeInterval _
) As Date
'Usage

Dim lhs As Date
Dim rhs As TimeInterval
Dim value As Date

value = TimeIntervalAdvanced.AddTimeInterval(lhs, rhs)
public static DateTime AddTimeInterval(
   DateTime lhs,
   TimeInterval rhs
)

Parameters

lhs
The date to add to.
rhs
The TimeInterval to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : SubtractTimeInterval Method
The date to subtract from.
The TimeInterval to add.
SubtractTimeInterval Method
Subtracts a TimeInterval from the specified DateTime.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function SubtractTimeInterval( _
   ByVal lhs As Date, _
   ByVal rhs As TimeInterval _
) As Date
'Usage

Dim lhs As Date
Dim rhs As TimeInterval
Dim value As Date

value = TimeIntervalAdvanced.SubtractTimeInterval(lhs, rhs)
public static DateTime SubtractTimeInterval(
   DateTime lhs,
   TimeInterval rhs
)

Parameters

lhs
The date to subtract from.
rhs
The TimeInterval to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : TimeIntervalAdvanced Class
TimeIntervalAdvanced Class Properties

For a list of all members of this type, see TimeIntervalAdvanced members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Day | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Days | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Hour | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Hours | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Milliseconds | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Minutes | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Month | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Months | Gets a system-defined TimeIntervalAdvanced object.
Public Property | Multiplier | Gets or sets the factor by which this time interval is multiplied.
static (Shared in Visual Basic) | None | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Quarter | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Quarters | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Seconds | Gets a system-defined TimeIntervalAdvanced object.
Public Property | Start | Gets or sets a DateTime object representing the time instant at which this interval initially occurs.
Public Property | StartDayOfWeek | Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
Public Property | StartMonth | Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
Public Property | TimeSpan | Gets or sets a custom time span between each time instant occurrence.
Public Property | Unit | Gets or sets a TimeInterval which is the based interval for this TimeIntervalAdvanced.
static (Shared in Visual Basic) | Week | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Weeks | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Year | Gets a system-defined TimeIntervalAdvanced object.
static (Shared in Visual Basic) | Years | Gets a system-defined TimeIntervalAdvanced object.
Top
See Also

Reference

TimeIntervalAdvanced Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Day Property
Day Property (TimeIntervalAdvanced)
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Day As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Day
public static TimeIntervalAdvanced Day {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Days Property
Days Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Days As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Days
public static TimeIntervalAdvanced Days {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Hour Property
Hour Property (TimeIntervalAdvanced)
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Hour As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Hour
public static TimeIntervalAdvanced Hour {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Hours Property
Hours Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Hours As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Hours
public static TimeIntervalAdvanced Hours {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Milliseconds Property
Milliseconds Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Milliseconds As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Milliseconds
public static TimeIntervalAdvanced Milliseconds {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Minutes Property
Minutes Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Minutes As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Minutes
public static TimeIntervalAdvanced Minutes {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Month Property
Month Property (TimeIntervalAdvanced)
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Month As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Month
public static TimeIntervalAdvanced Month {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Months Property
Months Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Months As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Months
public static TimeIntervalAdvanced Months {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Multiplier Property
Multiplier Property
Gets or sets the factor by which this time interval is multiplied.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Multiplier As Integer
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As Integer

instance.Multiplier = value

value = instance.Multiplier
public int Multiplier {get; set;}
Remarks
If TimeSpan is specified, this property will not have any effect.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : None Property
None Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property None As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.None
public static TimeIntervalAdvanced None {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Quarter Property
Quarter Property (TimeIntervalAdvanced)
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Quarter As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Quarter
public static TimeIntervalAdvanced Quarter {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Quarters Property
Quarters Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Quarters As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Quarters
public static TimeIntervalAdvanced Quarters {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Seconds Property
Seconds Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Seconds As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Seconds
public static TimeIntervalAdvanced Seconds {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Start Property
Start Property
Gets or sets a DateTime object representing the time instant at which this interval initially occurs.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Start As Date
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As Date

instance.Start = value

value = instance.Start
public DateTime Start {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : StartDayOfWeek Property
StartDayOfWeek Property (TimeIntervalAdvanced)
Gets or sets the day of the week at which this interval initially occurs. Value ranges from zero indicating Sunday, to six, indicating Saturday.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartDayOfWeek As Integer
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As Integer

instance.StartDayOfWeek = value

value = instance.StartDayOfWeek
public int StartDayOfWeek {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : StartMonth Property
StartMonth Property
Gets or sets the month of year at which this interval initially occurs. Value ranges from zero indicating January, to eleven, indicating December.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property StartMonth As Integer
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As Integer

instance.StartMonth = value

value = instance.StartMonth
public int StartMonth {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : TimeSpan Property
TimeSpan Property
Gets or sets a custom time span between each time instant occurrence.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimeSpan As TimeSpan
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As TimeSpan

instance.TimeSpan = value

value = instance.TimeSpan
public TimeSpan TimeSpan {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Unit Property
Unit Property
Gets or sets a TimeInterval which is the based interval for this TimeIntervalAdvanced.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Unit As TimeInterval
'Usage

Dim instance As TimeIntervalAdvanced
Dim value As TimeInterval

instance.Unit = value

value = instance.Unit
public TimeInterval Unit {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Week Property
Week Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Week As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Week
public static TimeIntervalAdvanced Week {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Weeks Property
Weeks Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Weeks As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Weeks
public static TimeIntervalAdvanced Weeks {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Year Property
Year Property (TimeIntervalAdvanced)
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Year As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Year
public static TimeIntervalAdvanced Year {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Years Property
Years Property
Gets a system-defined TimeIntervalAdvanced object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Years As TimeIntervalAdvanced
'Usage

Dim value As TimeIntervalAdvanced

value = TimeIntervalAdvanced.Years
public static TimeIntervalAdvanced Years {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Addition Operator
Addition Operator (TimeIntervalAdvanced)
Adds a TimeIntervalAdvanced to a DateTime object.
Overload List
Overload | Description
Addition(TimeIntervalAdvanced,DateTime) | Adds a TimeIntervalAdvanced to a DateTime object.
Addition(DateTime,TimeIntervalAdvanced) | Adds a TimeIntervalAdvanced to a DateTime object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Equality Operator
Equality Operator
Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.
Overload List
Overload | Description
Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) | Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.
Equality(TimeIntervalAdvanced,TimeInterval) | Indicates whether a specified TimeIntervalAdvanced is equal to a specified TimeInterval enumeration.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Inequality Operator
Inequality Operator
Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.
Overload List
Overload | Description
Inequality(TimeIntervalAdvanced,TimeInterval) | Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.
Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) | Indicates whether two TimeIntervalAdvanced instances are not equal.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalAdvanced Class
TimeIntervalAdvanced Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class : Subtraction Operator
DateTime to subtract from.
TimeIntervalAdvanced to subtract.
Subtraction Operator (TimeIntervalAdvanced)
Subtracts a TimeIntervalAdvanced from a DateTime object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator -( _
   ByVal lhs As Date, _
   ByVal rhs As TimeIntervalAdvanced _
) As Date

public DateTime operator -(
   DateTime lhs,
   TimeIntervalAdvanced rhs
)

Parameters
lhs

DateTime to subtract from.
rhs

TimeIntervalAdvanced to subtract.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : TimeIntervalCollection Class
TimeIntervalCollection Class
Contains a collection of TimeInterval objects.
Object Model
TimeIntervalCollection ClassTimeInterval Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class TimeIntervalCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As TimeIntervalCollection
public class TimeIntervalCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.TimeIntervalCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING Namespace : TimeIntervalCollection Class
TimeIntervalCollection Class Members

The following tables list the members exposed by TimeIntervalCollection.

Public Constructors
 | Name | Description
Public Constructor | TimeIntervalCollection Constructor | Creates a new instance of TimeIntervalCollection with the specified list of TimeInterval objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified TimeIntervalCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified TimeInterval.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified TimeInterval in this collection.
Public Method | Insert | Inserts a TimeInterval into this collection at a specified index.
Public Method | Remove | Removes a specified TimeInterval from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
Public Operators
public Operator Implicit Type Conversion
Top
See Also

Reference

TimeIntervalCollection Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > TimeIntervalCollection Class : TimeIntervalCollection Constructor
TimeIntervalCollection Constructor
Creates a new instance of TimeIntervalCollection with the specified list of TimeInterval objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray timeIntervalList() As TimeInterval _
)
'Usage

Dim timeIntervalList() As TimeInterval

Dim instance As New TimeIntervalCollection(timeIntervalList)
public TimeIntervalCollection(
   params TimeInterval[] timeIntervalList
)

Parameters

timeIntervalList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : TimeIntervalCollection Class
TimeIntervalCollection Class Methods

For a list of all members of this type, see TimeIntervalCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified TimeIntervalCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified TimeInterval.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified TimeInterval in this collection.
Public Method | Insert | Inserts a TimeInterval into this collection at a specified index.
Public Method | Remove | Removes a specified TimeInterval from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

TimeIntervalCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > TimeIntervalCollection Class : Add Method
Add Method (TimeIntervalCollection)
Adds a specified TimeIntervalCollection to this collection.
Overload List
Overload | Description
Add(TimeInterval) |
Add(TimeIntervalCollection) | Adds a specified TimeIntervalCollection to this collection.
Add(TimeInterval[]) | Adds the specified TimeInterval objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


dotnetCHARTING Namespace > TimeIntervalCollection Class > Add Method : Add(TimeInterval) Method
Add(TimeInterval) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal timeInterval As TimeInterval _
) As Integer
'Usage

Dim instance As TimeIntervalCollection
Dim timeInterval As TimeInterval
Dim value As Integer

value = instance.Add(timeInterval)
public int Add(
   TimeInterval timeInterval
)

Parameters

timeInterval
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members
Overload List


dotnetCHARTING Namespace > TimeIntervalCollection Class > Add Method : Add(TimeIntervalCollection) Method
The TimeIntervalCollection to add.
Add(TimeIntervalCollection) Method
Adds a specified TimeIntervalCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal timeIntervalCollection As TimeIntervalCollection _
)
'Usage

Dim instance As TimeIntervalCollection
Dim timeIntervalCollection As TimeIntervalCollection

instance.Add(timeIntervalCollection)
public void Add(
   TimeIntervalCollection timeIntervalCollection
)

Parameters

timeIntervalCollection
The TimeIntervalCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members
Overload List


dotnetCHARTING Namespace > TimeIntervalCollection Class > Add Method : Add(TimeInterval[]) Method
A list of TimeInterval objects to add.
Add(TimeInterval[]) Method
Adds the specified TimeInterval objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray timeIntervalList() As TimeInterval _
)
'Usage

Dim instance As TimeIntervalCollection
Dim timeIntervalList() As TimeInterval

instance.Add(timeIntervalList)
public void Add(
   params TimeInterval[] timeIntervalList
)

Parameters

timeIntervalList
A list of TimeInterval objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members
Overload List


dotnetCHARTING Namespace > TimeIntervalCollection Class : Contains Method
The TimeInterval to find.
Contains Method (TimeIntervalCollection)
Determines whether this collection contains a specified TimeInterval.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal timeInterval As TimeInterval _
) As Boolean
'Usage

Dim instance As TimeIntervalCollection
Dim timeInterval As TimeInterval
Dim value As Boolean

value = instance.Contains(timeInterval)
public bool Contains(
   TimeInterval timeInterval
)

Parameters

timeInterval
The TimeInterval to find.

Return Value

true if the specified TimeInterval belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


dotnetCHARTING Namespace > TimeIntervalCollection Class : IndexOf Method
The TimeInterval to find.
IndexOf Method (TimeIntervalCollection)
Determines index of a specified TimeInterval in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal timeInterval As TimeInterval _
) As Integer
'Usage

Dim instance As TimeIntervalCollection
Dim timeInterval As TimeInterval
Dim value As Integer

value = instance.IndexOf(timeInterval)
public int IndexOf(
   TimeInterval timeInterval
)

Parameters

timeInterval
The TimeInterval to find.

Return Value

The zero-based index of the specified TimeInterval.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


dotnetCHARTING Namespace > TimeIntervalCollection Class : Insert Method
The zero-based index into the collection at which to insert the TimeInterval.
The TimeInterval to insert into this collection.
Insert Method (TimeIntervalCollection)
Inserts a TimeInterval into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal timeInterval As TimeInterval _
)
'Usage

Dim instance As TimeIntervalCollection
Dim index As Integer
Dim timeInterval As TimeInterval

instance.Insert(index, timeInterval)
public void Insert(
   int index,
   TimeInterval timeInterval
)

Parameters

index
The zero-based index into the collection at which to insert the TimeInterval.
timeInterval
The TimeInterval to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


dotnetCHARTING Namespace > TimeIntervalCollection Class : Remove Method
The TimeInterval to remove.
Remove Method (TimeIntervalCollection)
Removes a specified TimeInterval from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal timeInterval As TimeInterval _
)
'Usage

Dim instance As TimeIntervalCollection
Dim timeInterval As TimeInterval

instance.Remove(timeInterval)
public void Remove(
   TimeInterval timeInterval
)

Parameters

timeInterval
The TimeInterval to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : TimeIntervalCollection Class
TimeIntervalCollection Class Properties

For a list of all members of this type, see TimeIntervalCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

TimeIntervalCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > TimeIntervalCollection Class : Item Property
Item Property (TimeIntervalCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As TimeInterval
'Usage

Dim instance As TimeIntervalCollection
Dim index As Integer
Dim value As TimeInterval

instance.Item(index) = value

value = instance.Item(index)
public TimeInterval this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

TimeIntervalCollection Class
TimeIntervalCollection Members


dotnetCHARTING Namespace > TimeIntervalCollection Class : Implicit Type Conversion Operator
Implicit Type Conversion Operator (TimeIntervalCollection)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Operator Widening CType( _
   ByVal tic As TimeIntervalCollection _
) As ArrayList

public ArrayList operator implicit(
   TimeIntervalCollection tic
)

Parameters
tic

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalCollection Class

TimeIntervalCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Truncation Class
Truncation Class
Defines properties used to shorten long labels.
Object Model
Truncation Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Truncation
'Usage

Dim instance As Truncation
public class Truncation
Inheritance Hierarchy

System.Object
dotnetCHARTING.Truncation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Truncation Members
dotnetCHARTING Namespace

Sample

LabelTruncation


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Truncation Class
Truncation Class Members

The following tables list the members exposed by Truncation.

Public Constructors
 | Name | Description
Public Constructor | Truncation Constructor | Initializes a new instance of the Truncation class.
Top
Public Properties
 | Name | Description
Public Property | Length | Gets or sets the maximum number of characters a label is shortened to.
Public Property | Mode | Gets or sets the TruncationMode used to shorten this label.
Public Property | Text | Gets or sets a string that defines text inserted into a string at the position it was trimmed. Default is '...'
Top
See Also

Reference

Truncation Class
dotnetCHARTING Namespace

Sample

LabelTruncation


%%PageItemTitle%%

dotnetCHARTING Namespace > Truncation Class : Truncation Constructor
Truncation Constructor
Initializes a new instance of the Truncation class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Truncation()
public Truncation()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Truncation Class
Truncation Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Truncation Class
Truncation Class Properties

For a list of all members of this type, see Truncation members.

Public Properties
 | Name | Description
Public Property | Length | Gets or sets the maximum number of characters a label is shortened to.
Public Property | Mode | Gets or sets the TruncationMode used to shorten this label.
Public Property | Text | Gets or sets a string that defines text inserted into a string at the position it was trimmed. Default is '...'
Top
See Also

Reference

Truncation Class
dotnetCHARTING Namespace

Sample

LabelTruncation


dotnetCHARTING Namespace > Truncation Class : Length Property
Length Property (Truncation)
Gets or sets the maximum number of characters a label is shortened to.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Length As Integer
'Usage

Dim instance As Truncation
Dim value As Integer

instance.Length = value

value = instance.Length
public int Length {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Truncation Class
Truncation Members
LabelTruncation


dotnetCHARTING Namespace > Truncation Class : Mode Property
Mode Property (Truncation)
Gets or sets the TruncationMode used to shorten this label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Mode As TruncationMode
'Usage

Dim instance As Truncation
Dim value As TruncationMode

instance.Mode = value

value = instance.Mode
public TruncationMode Mode {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Truncation Class
Truncation Members
LabelTruncation


dotnetCHARTING Namespace > Truncation Class : Text Property
Text Property (Truncation)
Gets or sets a string that defines text inserted into a string at the position it was trimmed.

Default is '...'
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Text As String
'Usage

Dim instance As Truncation
Dim value As String

instance.Text = value

value = instance.Text
public string Text {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Truncation Class
Truncation Members
LabelTruncation


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : View3D Class
View3D Class
Contains properties that control the 3D view angles and options when used with surface charts.
Object Model
View3D Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class View3D
'Usage

Dim instance As View3D
public class View3D
Inheritance Hierarchy

System.Object
dotnetCHARTING.View3D

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

View3D Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : View3D Class
View3D Class Members

The following tables list the members exposed by View3D.

Public Constructors
 | Name | Description
Public Constructor | View3D Constructor |
Top
Public Properties
 | Name | Description
Public Property | AngleOfRotation | Gets or sets the camera horizontal rotation angle in degrees (0-180).
Public Property | AngleOfTilt | Gets or sets the camera vertical tilt angle in degrees (0-90).
Public Property | EnableLighting | Gets or sets a value that determines whether lighting is rendered on 3D object.
Top
See Also

Reference

View3D Class
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > View3D Class : View3D Constructor
View3D Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New View3D()
public View3D()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

View3D Class
View3D Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : View3D Class
View3D Class Properties

For a list of all members of this type, see View3D members.

Public Properties
 | Name | Description
Public Property | AngleOfRotation | Gets or sets the camera horizontal rotation angle in degrees (0-180).
Public Property | AngleOfTilt | Gets or sets the camera vertical tilt angle in degrees (0-90).
Public Property | EnableLighting | Gets or sets a value that determines whether lighting is rendered on 3D object.
Top
See Also

Reference

View3D Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > View3D Class : AngleOfRotation Property
AngleOfRotation Property
Gets or sets the camera horizontal rotation angle in degrees (0-180).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AngleOfRotation As Double
'Usage

Dim instance As View3D
Dim value As Double

instance.AngleOfRotation = value

value = instance.AngleOfRotation
public double AngleOfRotation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

View3D Class
View3D Members


dotnetCHARTING Namespace > View3D Class : AngleOfTilt Property
AngleOfTilt Property
Gets or sets the camera vertical tilt angle in degrees (0-90).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AngleOfTilt As Double
'Usage

Dim instance As View3D
Dim value As Double

instance.AngleOfTilt = value

value = instance.AngleOfTilt
public double AngleOfTilt {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

View3D Class
View3D Members


dotnetCHARTING Namespace > View3D Class : EnableLighting Property
EnableLighting Property
Gets or sets a value that determines whether lighting is rendered on 3D object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property EnableLighting As Boolean
'Usage

Dim instance As View3D
Dim value As Boolean

instance.EnableLighting = value

value = instance.EnableLighting
public bool EnableLighting {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

View3D Class
View3D Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Viewport Class
Viewport Class
An extension to the Axis.ViewRange property. Defines the visible scale range or zoom range when using AJAX scrolling. Setting the properties of this class allows zooming the chart programatically.
Object Model
Viewport ClassScaleRange ClassTimeIntervalAdvanced Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Viewport
'Usage

Dim instance As Viewport
public class Viewport
Inheritance Hierarchy

System.Object
dotnetCHARTING.Viewport

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewport Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING Namespace : Viewport Class
Viewport Class Members

The following tables list the members exposed by Viewport.

Public Properties
 | Name | Description
Public Property | ElementCount | Gets or sets the number of element groups visible within the chart area. Element groups can be synonymous with a category axis tick count.
Public Property | NumericRange | Gets or sets the visible numeric range of a numeric axis.
Public Property | ScaleRange | Gets or sets a scale range that indicates the range of an axis to show at a time as well as a starting position.
Public Property | TimeInterval | Gets or sets the a time span of an axis that is visible in the chart area.
Top
See Also

Reference

Viewport Class
dotnetCHARTING Namespace


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : Viewport Class
Viewport Class Properties

For a list of all members of this type, see Viewport members.

Public Properties
 | Name | Description
Public Property | ElementCount | Gets or sets the number of element groups visible within the chart area. Element groups can be synonymous with a category axis tick count.
Public Property | NumericRange | Gets or sets the visible numeric range of a numeric axis.
Public Property | ScaleRange | Gets or sets a scale range that indicates the range of an axis to show at a time as well as a starting position.
Public Property | TimeInterval | Gets or sets the a time span of an axis that is visible in the chart area.
Top
See Also

Reference

Viewport Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > Viewport Class : ElementCount Property
ElementCount Property
Gets or sets the number of element groups visible within the chart area. Element groups can be synonymous with a category axis tick count.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ElementCount As Integer
'Usage

Dim instance As Viewport
Dim value As Integer

instance.ElementCount = value

value = instance.ElementCount
public int ElementCount {get; set;}
Remarks
To specify a starting position with a category axis, use the ScaleRange Property property with indexes of each element group.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewport Class
Viewport Members


dotnetCHARTING Namespace > Viewport Class : NumericRange Property
NumericRange Property
Gets or sets the visible numeric range of a numeric axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property NumericRange As Double
'Usage

Dim instance As Viewport
Dim value As Double

instance.NumericRange = value

value = instance.NumericRange
public double NumericRange {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewport Class
Viewport Members


dotnetCHARTING Namespace > Viewport Class : ScaleRange Property
ScaleRange Property (Viewport)
Gets or sets a scale range that indicates the range of an axis to show at a time as well as a starting position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScaleRange As ScaleRange
'Usage

Dim instance As Viewport
Dim value As ScaleRange

instance.ScaleRange = value

value = instance.ScaleRange
public ScaleRange ScaleRange {get; set;}
Remarks
When the viewport is used with a category axis (string values like element names), the min and max values of the scale range must be integers and they refer to the index of the axis ticks.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewport Class
Viewport Members


dotnetCHARTING Namespace > Viewport Class : TimeInterval Property
TimeInterval Property (Viewport)
Gets or sets the a time span of an axis that is visible in the chart area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property TimeInterval As TimeIntervalAdvanced
'Usage

Dim instance As Viewport
Dim value As TimeIntervalAdvanced

instance.TimeInterval = value

value = instance.TimeInterval
public TimeIntervalAdvanced TimeInterval {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Viewport Class
Viewport Members


%%PageItemTitle%%

dotnetCHARTING Namespace : AbsorbedDose Enumeration
AbsorbedDose Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AbsorbedDose
   Inherits System.Enum
'Usage

Dim instance As AbsorbedDose
public enum AbsorbedDose : System.Enum
Members
Member | Description
Attogray |
Centigray |
Decigray |
Dekagray |
Exagray |
Femtogray |
Gigagray |
Gray |
Hectogray |
JoulePerCentigram |
JoulePerGram |
JoulePerKilogram |
JoulePerMilligram |
Kilogray |
Megagray |
Microgray |
Milligray |
Nanogray |
Petagray |
Picogray |
Rad |
Teragray |
Yoctogray |
Yottagray |
Zeptogray |
Zettagray |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.AbsorbedDose

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Acceleration Enumeration
Acceleration Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Acceleration
   Inherits System.Enum
'Usage

Dim instance As Acceleration
public enum Acceleration : System.Enum
Members
Member | Description
AttometresPerSecondSquared |
CentimetresPerSecondSquared |
DecimetresPerSecondSquared |
DekametresPerSecondSquared |
ExametresPerSecondSquared |
FeetPerSecondSquared |
FemtometresPerSecondSquared |
Galileo |
GigametresPerSecondSquared |
Gravity |
HectmetresPerSecondSquared |
InchesPerSecondSquared |
KilometresPerSecondSquared |
MegametresPerSecondSquared |
MetersPerSecondSquared |
MicrometresPerSecondSquared |
MilesPerSecondSquared |
MillimetresPerSecondSquared |
NanometresPerSecondSquared |
PetametresPerSecondSquared |
PicometresPerSecondSquared |
TerametresPerSecondSquared |
YardsPerSecondSquared |
YoctometresPerSecondSquared |
YottametresPerSecondSquared |
ZeptometresPerSecondSquared |
ZettametresPerSecondSquared |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Acceleration

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Angle Enumeration
Angle Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Angle
   Inherits System.Enum
'Usage

Dim instance As Angle
public enum Angle : System.Enum
Members
Member | Description
Degrees |
Gradians |
Mil |
Minute |
Radians |
Revolution |
Second |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Angle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : AngularVelocity Enumeration
AngularVelocity Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AngularVelocity
   Inherits System.Enum
'Usage

Dim instance As AngularVelocity
public enum AngularVelocity : System.Enum
Members
Member | Description
DegreesPerDay |
DegreesPerHour |
DegreesPerMinute |
DegreesPerSecond |
RadiansPerDay |
RadiansPerHour |
RadiansPerMinute |
RadiansPerSecond |
RevolutionsPerDay |
RevolutionsPerHour |
RevolutionsPerMinute |
RevolutionsPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.AngularVelocity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Area Enumeration
Area Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Area
   Inherits System.Enum
'Usage

Dim instance As Area
public enum Area : System.Enum
Members
Member | Description
Acre |
Are |
Barn |
Cuerda |
Hectares |
Plaza |
Rood |
Section |
SquareCentimetre |
SquareChain |
SquareDecametre |
SquareDecimetre |
SquareFoot |
SquareHectometre |
SquareInch |
SquareKilometre |
SquareMeters |
SquareMicrometre |
SquareMile |
SquareMillimetre |
SquareNanometre |
SquarePerch |
SquarePole |
SquareRod |
SquareYard |
Township |
VarasCastellanasCuad |
VarasConuquerasCuad |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Area

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : BackgroundMode Enumeration
BackgroundMode Enumeration
Specifies a background drawing mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BackgroundMode
   Inherits System.Enum
'Usage

Dim instance As BackgroundMode
public enum BackgroundMode : System.Enum
Members
Member | Description
Brush | Uses the Background.Brush object to fill the surface.
Color | Draws a solid color.
Gradient | Draws a 2 color gradient.
Image | Draws a centered image on the background surface.
ImageStretch | Stretches an image across the background surface.
ImageTile | Tiles an image on a background surface.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.BackgroundMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : BoxCapStyle Enumeration
BoxCapStyle Enumeration
Specifies the available box cap styles. These caps can be used with box header StartCap and EndCap properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BoxCapStyle
   Inherits System.Enum
'Usage

Dim instance As BoxCapStyle
public enum BoxCapStyle : System.Enum
Members
Member | Description
Arrow | Specifies an arrow cap.
Box | Specifies a box cap.
CutDown | Specifies a downward cut cap.
CutUp | Specifies an upward cut cap.
RibbonDown | Specifies a Ribbon cap that extends down behind the parent box.
RibbonUp | Specifies a Ribbon cap that extends up behind the parent box.
Round | Specifies a rounded cap.
RoundDown | Specifies a cap rounded down.
RoundInverted | Specifies an inverted rounded cap.
RoundUp | Specifies a cap rounded up.
Torn | Specifies a torn cap.
Triangle | Specifies a triangle cap.
TriangleInverted | Specifies an inverted triangle cap.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.BoxCapStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : BoxCorner Enumeration
BoxCorner Enumeration
Specifies a box edge style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum BoxCorner
   Inherits System.Enum
'Usage

Dim instance As BoxCorner
public enum BoxCorner : System.Enum
Members
Member | Description
Cut | The edge is cut.
Round | The edge is rounded.
Square | The edge is a corner.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.BoxCorner

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Calculation Enumeration
Calculation Enumeration
Specifies a calculation to be performed on a series or series collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Calculation
   Inherits System.Enum
'Usage

Dim instance As Calculation
public enum Calculation : System.Enum
Members
Member | Description
Average | Calculates the average of a series or series collection.
Maximum | Calculates the maximum of a series or series collection.
Mean | Calculates the mean of a series or series collection.
Median | Calculates the median of a series or series collection.
Minimum | Calculates the minimum of a series or series collection.
Mode | Calculates the mode of a series or series collection.
RunningAverage | Calculates a running average of a series or series collection.
RunningMaximum | Calculates a running maximum of a series or series collection.
RunningMean | Calculates a running mean of a series or series collection.
RunningMedian | Calculates a running median of a series or series collection.
RunningMinimum | Calculates a running minimum of a series or series collection.
RunningMode | Calculates a running mode of a series or series collection.
RunningSum | Calculates a running sum of a series or series collection.
Sum | Calculates the sum of a series or series collection.
TrendLineLinear | Calculates the linear regression of y values within a series collection.
TrendLineLinearScatter | Calculates the linear regression of x and y values within a series collection.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Calculation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Capacitance Enumeration
Capacitance Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Capacitance
   Inherits System.Enum
'Usage

Dim instance As Capacitance
public enum Capacitance : System.Enum
Members
Member | Description
Attofarad |
Centifarad |
Decifarad |
Dekafarad |
Exafarad |
Farad |
Femtofarad |
Gigafarad |
Hectofarad |
Kilofarad |
Megafarad |
Microfarad |
Millifarad |
Nanofarad |
Petafarad |
Picofarad |
Terafarad |
Yoctofarad |
Yottafarad |
Zeptofarad |
Zettafarad |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Capacitance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Charge Enumeration
Charge Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Charge
   Inherits System.Enum
'Usage

Dim instance As Charge
public enum Charge : System.Enum
Members
Member | Description
Abcoulomb |
AFaradayCarbon12Based |
AMicrofaradayCarbon12Based |
AMillifaradayCarbon12Based |
AmpereHour |
AmpereMinute |
AmpereSecond |
ANanofaradayCarbon12Based |
APicofaradayCarbon12Based |
Attocoulomb |
Coulomb |
Exacoulomb |
Femtocoulomb |
Franklin |
Gigacoulomb |
Kilocoulomb |
Megacoulomb |
Microcoulomb |
Millicoulomb |
Nanocoulomb |
Petacoulomb |
Picocoulomb |
Statcoulomb |
Teracoulomb |
Yoctocoulomb |
Yottacoulomb |
Zeptocoulomb |
Zettacoulomb |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Charge

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ChartAreaLayoutMode Enumeration
ChartAreaLayoutMode Enumeration
Specifies the positioning behavior of multiple chart areas on a single chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartAreaLayoutMode
   Inherits System.Enum
'Usage

Dim instance As ChartAreaLayoutMode
public enum ChartAreaLayoutMode : System.Enum
Members
Member | Description
Custom | Specifies that chart areas will be laid out in a grid matrix based on ChartArea.GridPosition.
Horizontal | Specifies that chart areas will be laid out horizontally in a single row in the order they were added.
HorizontalPriority | Specifies that chart areas layout will be based on axis relationships where y axes will be matched before chart areas are added based on x axis relationships. ChartAreaLayoutRules.EnforceOppositeAxisAlignment affects this setting.
HorizontalSmart | Specifies that chart areas will be laid out horizontally in a single row and arranged based on x axis relationships.
Vertical | Specifies that chart areas will be laid out vertically in a single column in the order they were added.
VerticalPriority | Specifies that chart areas layout will be based on axis relationships where x axes will be matched before chart areas are added based on y axis relationships. ChartAreaLayoutRules.EnforceOppositeAxisAlignment affects this setting.
VerticalSmart | Specifies that chart areas will be laid out vertically in a single column and arranged based on x axis relationships.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ChartAreaLayoutMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ChartAreaNavigationOptions Enumeration
ChartAreaNavigationOptions Enumeration
Specifies the navigation options of chart areas in the navigator.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartAreaNavigationOptions
   Inherits System.Enum
'Usage

Dim instance As ChartAreaNavigationOptions
public enum ChartAreaNavigationOptions : System.Enum
Members
Member | Description
ArbitrarySelection | Enables arbitrary selection in the chart area. Meaning, a new area can be selected to zoom into.
DragScrolling | Enables drag scrolling of the chart area
ScrollWheel | Enables zooming with the scrollwheel.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ChartAreaNavigationOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ChartType Enumeration
ChartType Enumeration
Represents the chart type of a chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ChartType
   Inherits System.Enum
'Usage

Dim instance As ChartType
public enum ChartType : System.Enum
Members
Member | Description
Bubble | Draws scattered data. Markers, lines, and splines are supported. Data Used: YValue, YDateTime, XValue, XDateTime
Calendar | (JS Output Only) Draws a Calendar chart.
Combo | The combo chart supports virtually every feature. This chart is capable of being every chart you want it to be based on settings of other objects like series and axes. The x axis is a label axis and the y axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
ComboHorizontal | This chart supports the bar and cylinder series types. The y axis is a label axis and the x axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
ComboSideBySide | Each series is drawn side by side. This chart doesn't support stacked axis scales and unclustered columns. The x axis is a label axis and the y axis is a value axis. Element values used YValue, YValueStart, YDateTime, YDateTimeStart, Complete
Donut | See Pie.
Donuts | See Pies.
Financial | Only 3 axes exist for this chart, price, volume and x axis. No more axes can be bound to series but you can calculate as many axes as you would like. HLC Charts can be achieved by providing a high, low, and close but leaving open equal double.NaN. Element values used Open, High, Low, Close, Volume
Gantt | See ComboHorizontal.
Gauges | Draws a gauge for each series. Each element represents a needle. Element values used YValue
Heatmap | (JS Output Only) Draws a heatmap chart.
Map | Draws a map from a shapefile or ecw image.
Multiple | Draws multiple type series that are laid out on the chart similar to gauges or radars.
MultipleGrouped | Draws multiple type series that are laid out on the chart similar to Pie.
Organizational | Draws an organization chart.
Pie | The pie chart draws a single pie where each slice represents a series. Most applications would use Pies rather than Pie Element values used YValue
Pies | Multiple pies where each pie is a series and each slice is an element (suitable for most applications). Pies may also be drawn as donuts. Most applications would use Pies rather than Pie. Pies does not support Series.Palette. Element values used YValue
PiesNested | Draws pies that are nested or stacked.
Radar | Draws a single radar. The time scale is not supported by the radar graph. Element values used YValue
Radars | Draws multiple radars where each radar is a series. The time scale is not supported by radar graph. Element values used YValue
Scatter | Draws scattered data. Markers, lines, and splines are supported. Element values used YValue, YDateTime, XValue, XDateTime
Surface | Draws a 2D or 3D surface chart.
TreeMap | Draws a TreeMap chart.
Variwide | (JS Output Only) Draws a Variwide (Mekko) chart.
Venn | (JS Output Only) Draws a Venn chart.
VennColorByPoint | (JS Output Only) Draws a Venn chart where each data point has its own unique color from the palette.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ChartType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ConcentrationMolar Enumeration
ConcentrationMolar Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ConcentrationMolar
   Inherits System.Enum
'Usage

Dim instance As ConcentrationMolar
public enum ConcentrationMolar : System.Enum
Members
Member | Description
KilomolesPerCentimetreCubed |
KilomolesPerLitre |
KilomolesPerMetreCubed |
KilomolesPerMilimetreCubed |
MillimolesPerCentimetreCubed |
MillimolesPerLitre |
MillimolesPerMetreCubed |
MillimolesPerMilimetreCubed |
MolesPerCentimetreCubed |
MolesPerLitre |
MolesPerMetreCubed |
MolesPerMilimetreCubed |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ConcentrationMolar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Current Enumeration
Current Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Current
   Inherits System.Enum
'Usage

Dim instance As Current
public enum Current : System.Enum
Members
Member | Description
Abampere |
Ampere |
Biot |
EMUOfCurrentAbampere |
ESUOfCurrentStatampere |
Gilbert |
Kiloampere |
Miliampere |
Statampere |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Current

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Data Enumeration
Data Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Data
   Inherits System.Enum
'Usage

Dim instance As Data
public enum Data : System.Enum
Members
Member | Description
Bit |
Block |
Byte |
DoubleWord |
Gigabit |
GigabitBySIDef |
Gigabyte |
GigabyteBySIDef |
Kilobit |
KilobitBySIDef |
Kilobyte |
KilobyteBySIDef |
Megabit |
MegabitBySIDef |
Megabyte |
MegabyteBySIDef |
Nibble |
Terabit |
TerabitBySIDef |
Terabyte |
TerabyteBySIDef |
Word |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Data

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : DataProviderType Enumeration
DataProviderType Enumeration
Specifies a database type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataProviderType
   Inherits System.Enum
'Usage

Dim instance As DataProviderType
public enum DataProviderType : System.Enum
Members
Member | Description
MsAccess | Microsoft Access database.
MsSql | MS SQL database.
OleDb | OleDb database.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.DataProviderType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : DataSourceType Enumeration
DataSourceType Enumeration
Specifies a DataSource type to split the parent DataSource into.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataSourceType
   Inherits System.Enum
'Usage

Dim instance As DataSourceType
public enum DataSourceType : System.Enum
Members
Member | Description
AxisMarker | Specifies an AxisMarker data source type.
Element | Specifies an Element data source type.
ElementGroup | Specifies an Element Group data source type. Element groups are elements in the same SeriesCollection that share a name.
None | Specifies no type
ScaleRange | Specifies a ScaleRange data source type.
Series | Specifies a Series data source type.
SeriesCollection | Specifies an SeriesCollection data source type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.DataSourceType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : DataTransfer Enumeration
DataTransfer Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DataTransfer
   Inherits System.Enum
'Usage

Dim instance As DataTransfer
public enum DataTransfer : System.Enum
Members
Member | Description
BitsPerSecond |
BytesPerSecond |
GigabitsPerSecond |
GigabitsPerSecondBySIDef |
GigabytesPerSecond |
GigabytesPerSecondBySIDef |
KilobitsPerSecond |
KilobitsPerSecondBySIDef |
KilobytesPerSecond |
KilobytesPerSecondBySIDef |
MegabitsPerSecond |
MegabitsPerSecondBySIDef |
MegabytesPerSecond |
MegabytesPerSecondBySIDef |
TerabitsPerSecond |
TerabitsPerSecondBySIDef |
TerabytesPerSecond |
TerabytesPerSecondBySIDef |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.DataTransfer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Density Enumeration
Density Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Density
   Inherits System.Enum
'Usage

Dim instance As Density
public enum Density : System.Enum
Members
Member | Description
AttogramsPerLitre |
CentigramsPerLitre |
DecigramsPerLitre |
DekagramsPerLitre |
ExagramsPerLitre |
FemtogramsPerLitre |
GigagramsPerLitre |
GramsPerCentimetreCubed |
GramsPerLitre |
GramsPerMetreCubed |
GramsPerMilimetreCubed |
HectogramsPerLitre |
KilogramsPerCentimetreCubed |
KilogramsPerLitre |
KilogramsPerMetreCubed |
KilogramsPerMillimetreCubed |
MegagramsPerLitre |
MicrogramsPerLitre |
MilligramsPerCentimetreCubed |
MilligramsPerLitre |
MilligramsPerMetreCubed |
MilligramsPerMilimetreCubed |
NanogramsPerLitre |
OuncesUSPerGallonUS |
PetagramsPerLitre |
PicogramsPerLitre |
PoundsPerFootCubed |
PoundsPerInchCubed |
TeragramsPerLitre |
TonsPerYardCubed |
YoctogramsPerLitre |
YottagramsPerLitre |
ZeptogramsPerLitre |
ZettagramsPerLitre |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Density

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : DigitalImageResolution Enumeration
DigitalImageResolution Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum DigitalImageResolution
   Inherits System.Enum
'Usage

Dim instance As DigitalImageResolution
public enum DigitalImageResolution : System.Enum
Members
Member | Description
DotsPerInch |
DotsPerMetre |
DotsPerMilimetre |
PixelsPerInch |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.DigitalImageResolution

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : EdgeAlignment Enumeration
EdgeAlignment Enumeration
Specifies the alignment of an object in relation to an objects side.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum EdgeAlignment
   Inherits System.Enum
'Usage

Dim instance As EdgeAlignment
public enum EdgeAlignment : System.Enum
Members
Member | Description
Edge | Specifies placement in the middle of the edge.
Inside | Specifies inside placement.
Outside | Specifies inside placement.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.EdgeAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ElementMarkerType Enumeration
ElementMarkerType Enumeration
Built in element marker icons.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ElementMarkerType
   Inherits System.Enum
'Usage

Dim instance As ElementMarkerType
public enum ElementMarkerType : System.Enum
Members
Member | Description
ArrowDown | Marker is drawn as an arrow pointing down.
ArrowUp | Marker is drawn as an arrow pointing up.
Circle | Markers is drawn as a circle.
Diamond | Markers is drawn as a diamond.
Dividend | Markers is drawn as a financial dividend paid indicator.
FivePointStar | Markers is drawn as a five point star.
FourPointStar | Markers is drawn as a four point star.
Merger | Markers is drawn as a financial merger.
None | Does not draw a marker
Rectangle | Markers is drawn as a square.
ReverseSplit | Markers is drawn as a financial reverse split.
SevenPointStar | Markers is drawn as a seven point star.
SixPointStar | Markers is drawn as a six point star.
Spinoff | Markers is drawn as a financial spinoff.
Split | Markers is drawn as a financial split.
Square | Markers is drawn as a square.
Triangle | Markers is drawn as a triangle.
TriangleUpsideDown | Marker is drawn as a triangle pointing down.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ElementMarkerType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ElementValue Enumeration
ElementValue Enumeration
Specifies a value of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ElementValue
   Inherits System.Enum
'Usage

Dim instance As ElementValue
public enum ElementValue : System.Enum
Members
Member | Description
BubbleSize | Bubble size value of an element.
Close | Financial close price value of an element.
Complete | Percent completed value of an element.
Height | Element's height, refers to a pie slice's height.
High | Financial high price value of an element.
Length | Element's length, refers to a pie slice's length.
Low | Financial low price value of an element.
Name | The name of an element.
Open | Financial open price value of an element.
Volume | Financial trade volumn value of an element.
XDateTime | X DateTime value of an element.
XDateTimeStart | Initial x DateTime value of an element.
XValue | X value of an element.
XValueStart | Initial x value of an element.
YDateTime | Y DateTime value of an element.
YDateTimeStart | Initial y DateTime value of an element.
YValue | Y value of an element.
YValueStart | Initial y value of an element.
ZValue | The Z Value, used with surface charts.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ElementValue

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : EmptyElementMode Enumeration
EmptyElementMode Enumeration
Specifies how empty elements are handled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum EmptyElementMode
   Inherits System.Enum
'Usage

Dim instance As EmptyElementMode
public enum EmptyElementMode : System.Enum
Members
Member | Description
Fill | Fills the empty area with EmptyElement properties of a series.
Ignore | Completes empty areas by filling the line, or area. Columns will behave the same as EmptyElementMode.None.
None | Empty elements are not shown or marked leaving gaps.
TreatAsZero | Empty elements will have the value of 0 and not be marked as empty.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.EmptyElementMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Energy Enumeration
Energy Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Energy
   Inherits System.Enum
'Usage

Dim instance As Energy
public enum Energy : System.Enum
Members
Member | Description
AAQuad1015BTU |
Attojoule |
BritishThermalUnit |
Calorie |
CalorieMean |
Centijoule |
Decijoule |
Dekajoule |
DyneCentimetre |
ElectronVolt |
Erg |
Exajoule |
Femtojoule |
FootPoundal |
FootPoundFource |
Gigajoule |
GigawattHour |
Hectojoule |
HorsepowerHour |
Joule |
Kilojoule |
KilowattHour |
KilowattSecond |
Megajoule |
Microjoule |
Millijoule |
Nanojoule |
OunceForceInch |
Petajoule |
Picojoule |
PoundForceInch |
Terajoule |
ThermEC |
ThermUS |
TonOfTNTEnergyEquivalent |
WattHour |
WattSecond |
Yoctojoule |
Yottajoule |
Zeptojoule |
Zettajoule |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Energy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : EUCurrency Enumeration
EUCurrency Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum EUCurrency
   Inherits System.Enum
'Usage

Dim instance As EUCurrency
public enum EUCurrency : System.Enum
Members
Member | Description
AustrianSchillings |
BelgianFranc |
DeutschMark |
DutchGuilders |
Euro |
FinnishMarks |
FrenchFrancs |
GreekDrachma |
IrishPounds |
ItalianLire |
LuxembourgFrancs |
PortugueseEscudos |
SpanishPesetas |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.EUCurrency

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FieldType Enumeration
FieldType Enumeration
Specifies a database field data type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FieldType
   Inherits System.Enum
'Usage

Dim instance As FieldType
public enum FieldType : System.Enum
Members
Member | Description
BigInt | BigInt data type.
Bool | Bool data type.
Currency | Currency data type.
Date | Date data type.
Double | Double data type.
LongNumber | LongNumber data type.
Number | Number data type.
Text | String data type.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FieldType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FlowMass Enumeration
FlowMass Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FlowMass
   Inherits System.Enum
'Usage

Dim instance As FlowMass
public enum FlowMass : System.Enum
Members
Member | Description
AttogramPerSecond |
CentigramPerSecond |
DecigramPerSecond |
DekagramPerSecond |
ExagramPerSecond |
FemtogramPerSecond |
GigagramPerSecond |
GramsPerDay |
GramsPerHour |
GramsPerMinute |
GramsPerSecond |
HectogramPerSecond |
KilogramPerSecond |
KilogramsPerDay |
KilogramsPerHour |
KilogramsPerMinute |
MegagramPerSecond |
MicrogramPerSecond |
MilligramPerSecond |
MilligramsPerDay |
MilligramsPerHour |
MilligramsPerMinute |
NanogramPerSecond |
PetagramPerSecond |
PicogramPerSecond |
PoundsPerDay |
PoundsPerHour |
PoundsPerMinute |
PoundsPerSecond |
TeragramPerSecond |
YoctogramPerSecond |
YottagramPerSecond |
ZeptogramPerSecond |
ZettagramPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FlowMass

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FlowMolar Enumeration
FlowMolar Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FlowMolar
   Inherits System.Enum
'Usage

Dim instance As FlowMolar
public enum FlowMolar : System.Enum
Members
Member | Description
AttomolesPerSecond |
CentimolesPerSecond |
DecimolesPerSecond |
DekamolesPerSecond |
ExamolesPerSecond |
FemtomolesPerSecond |
GigamolesPerSecond |
HectomolesPerSecond |
KilomolesPerDay |
KilomolesPerHour |
KilomolesPerMinute |
KilomolesPerSecond |
MegamolesPerSecond |
MicromolesPerSecond |
MillimolesPerDay |
MillimolesPerHour |
MillimolesPerMinute |
MillimolesPerSecond |
MolesPerDay |
MolesPerHour |
MolesPerMinute |
MolesPerSecond |
NanomolesPerSecond |
PetamolesPerSecond |
PicomolesPerSecond |
TeramolesPerSecond |
YoctomolesPerSecond |
YottamolesPerSecond |
ZeptomolesPerSecond |
ZettamolesPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FlowMolar

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FlowVolumetric Enumeration
FlowVolumetric Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FlowVolumetric
   Inherits System.Enum
'Usage

Dim instance As FlowVolumetric
public enum FlowVolumetric : System.Enum
Members
Member | Description
AAKilogramsPerDayGasolineAt155C |
AAKilogramsPerHourGasolineAt155C |
AAKilogramsPerMinuteGasolineAt155C |
AAKilogramsPerSecondGasolineAt155C |
AAPoundsPerDayGasolineAt155C |
AAPoundsPerHourGasolineAt155C |
AAPoundsPerMinuteGasolineAt155C |
AAPoundsPerSecondGasolineAt155C |
BarrelsPerDay |
BarrelsPerHour |
BarrelsPerMinute |
BarrelsPerSecond |
CubicCentimetrePerDay |
CubicCentimetrePerHour |
CubicCentimetrePerMinute |
CubicCentimetrePerSecond |
CubicFeetPerHour |
CubicFeetPerMinute |
CubicFeetPerSecond |
CubicInchesPerDay |
CubicInchesPerHour |
CubicInchesPerMinute |
CubicInchesPerSecond |
CubicMetrePerDay |
CubicMetrePerHour |
CubicMetrePerMinute |
CubicMetresPerSecond |
CubicYardsPerHour |
CubicYardsPerMinute |
CubicYardsPerSecond |
GallonsPerDay |
GallonsPerHour |
GallonsPerMinute |
GallonsPerSecond |
GallonsUKPerDay |
GallonsUKPerHour |
GallonsUKPerMinute |
GallonsUKPerSecond |
KilolitresPerDay |
KilolitresPerHour |
KilolitresPerMinute |
LitresPerDay |
LitresPerHour |
LitresPerMinute |
LitresPerSecond |
MillilitresPerDay |
MillilitresPerHour |
MillilitresPerMinute |
MillilitresPerSecond |
OuncesPerHour |
OuncesPerMinute |
OuncesPerSecond |
OuncesUKPerHour |
OuncesUKPerMinute |
OuncesUKPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FlowVolumetric

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Force Enumeration
Force Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Force
   Inherits System.Enum
'Usage

Dim instance As Force
public enum Force : System.Enum
Members
Member | Description
Attonewton |
Centinewton |
Decinewton |
Dekanewton |
Dyne |
Exanewton |
Femtonewton |
Giganewton |
GramForce |
Hectonewton |
JouleCentimetre |
JouleMetre |
KilogramForce |
Kilonewton |
KipForce |
Meganewton |
Micronewton |
Millinewton |
Nanonewton |
Newton |
OunceForce |
Petanewton |
Piconewton |
Poundal |
PoundForce |
Teranewton |
Yoctonewton |
Yottanewton |
Zeptonewton |
Zettanewton |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Force

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FrequencyWavelength Enumeration
FrequencyWavelength Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FrequencyWavelength
   Inherits System.Enum
'Usage

Dim instance As FrequencyWavelength
public enum FrequencyWavelength : System.Enum
Members
Member | Description
Attohertz |
Centihertz |
CyclesPerSecond |
Decihertz |
Dekahertz |
Exahertz |
Femtohertz |
Gigahertz |
Hectohertz |
Hertz |
Kilohertz |
Megahertz |
Microhertz |
Millihertz |
Nanohertz |
Petahertz |
Picohertz |
Terahertz |
WavelengthInCentimetres |
WavelengthInDecametres |
WavelengthInDecimetres |
WavelengthInExametres |
WavelengthInGigametres |
WavelengthInHectometres |
WavelengthInKilometres |
WavelengthInMegametres |
WavelengthInMetres |
WavelengthInMicrometres |
WavelengthInMillimetres |
WavelengthInPetametres |
WavelengthInTerametres |
Yoctohertz |
Yottahertz |
Zeptohertz |
Zettahertz |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FrequencyWavelength

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : FuelConsumption Enumeration
FuelConsumption Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum FuelConsumption
   Inherits System.Enum
'Usage

Dim instance As FuelConsumption
public enum FuelConsumption : System.Enum
Members
Member | Description
AGallonsUKPer100mi |
AGallonsUSPer100mi |
ALitresPer100Km |
AttometrePerLitre |
CentimetrePerLitre |
DecimetrePerLitre |
DekametrePerLitre |
ExametrePerLitre |
FemtometrePerLitre |
GallonsUKPerMile |
GallonsUSPerMile |
GigametrePerLitre |
HectometrePerLitre |
KilometrePerLitre |
KilometresPerGallonUS |
LitresPerMetre |
MegametrePerLitre |
MetresPerCubicCentimetre |
MetresPerCubicFeet |
MetresPerCubicInches |
MetresPerCubicMetres |
MetresPerCubicYards |
MetresPerCup |
MetresPerCupUK |
MetresPerFluidOunces |
MetresPerFluidOuncesUK |
MetresPerGallon |
MetresPerGallonUK |
MetresPerGallonUS |
MetresPerLitre |
MetresPerPint |
MetresPerPintUK |
MetresPerQuart |
MetresPerQuartUK |
MicrometrePerLitre |
MilesPerGallonUK |
MilesPerGallonUS |
MileUSPerLitre |
MillimetrePerLitre |
NanometrePerLitre |
NauticalMilePerGallonUS |
NauticalMilePerLitre |
PetametrePerLitre |
PicometrePerLitre |
TerametrePerLitre |
YoctometrePerLitre |
YottametrePerLitre |
ZeptometrePerLitre |
ZettametrePerLitre |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.FuelConsumption

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : GaugeBorderShape Enumeration
GaugeBorderShape Enumeration
Specifies the gauge border shape used on gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GaugeBorderShape
   Inherits System.Enum
'Usage

Dim instance As GaugeBorderShape
public enum GaugeBorderShape : System.Enum
Members
Member | Description
Default | The border shape is determined automatically.
UseBox | The Series.GaugeBorderBox is used as the shape of the gauge border.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.GaugeBorderShape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : GaugeLabelMode Enumeration
GaugeLabelMode Enumeration
Specifies the circular gauge axis labeling mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GaugeLabelMode
   Inherits System.Enum
'Usage

Dim instance As GaugeLabelMode
public enum GaugeLabelMode : System.Enum
Members
Member | Description
Default | Default labeling.
Radial | Labels are drawn radially around the axis.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.GaugeLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : GaugeLinearStyle Enumeration
GaugeLinearStyle Enumeration
Specifies the linear gauge type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GaugeLinearStyle
   Inherits System.Enum
'Usage

Dim instance As GaugeLinearStyle
public enum GaugeLinearStyle : System.Enum
Members
Member | Description
Normal | Default linear gauge style.
Thermometer | Thermometer style.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.GaugeLinearStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : GaugeNeedleType Enumeration
GaugeNeedleType Enumeration
Specifies the gauge needle type used on circular gauges.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GaugeNeedleType
   Inherits System.Enum
'Usage

Dim instance As GaugeNeedleType
public enum GaugeNeedleType : System.Enum
Members
Member | Description
One | Type 1.
Three | Type 3.
Two | Type 2.
UseMarker | A custom image is used as the marker needle.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.GaugeNeedleType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : GaugeType Enumeration
GaugeType Enumeration
Specifies the gauge type when using ChartType.Gauges or ChartType.Multiple with SeriesTypeMultiple.Gauge.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum GaugeType
   Inherits System.Enum
'Usage

Dim instance As GaugeType
public enum GaugeType : System.Enum
Members
Member | Description
Bars | Linear horizontal bars.
Circular | Circular gauges.
CircularBars | (JS Chart Only) Circular bars gauge.
DigitalReadout | Digital readout gauge.
Horizontal | Linear horizontal gauge
IndicatorLight | Indicator light gauge.
Vertical | Linear vertical gauge.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.GaugeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : HatchStylePalette Enumeration
HatchStylePalette Enumeration
Specifies a pre-defined hatch style palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HatchStylePalette
   Inherits System.Enum
'Usage

Dim instance As HatchStylePalette
public enum HatchStylePalette : System.Enum
Members
Member | Description
None | No hatch style palette is specified.
One | Palette one.
Random | A random palette.
Three | Palette three.
Two | Palette two.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.HatchStylePalette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : HoverAction Enumeration
HoverAction Enumeration
(JS Charts Only) Specifies the action caused by hovering the mouse over an item.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum HoverAction
   Inherits System.Enum
'Usage

Dim instance As HoverAction
public enum HoverAction : System.Enum
Members
Member | Description
HighlightElement | Highlights the specific element when the item is hovered.
HighlightElementGroup | Highlights the associated element group (elements across all series that share the same x value or name) when the item is hovered.
HighlightSeries | Highlights the associated series when the item is hovered.
None | No action occurs when the item is hovered.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.HoverAction

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Illumination Enumeration
Illumination Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Illumination
   Inherits System.Enum
'Usage

Dim instance As Illumination
public enum Illumination : System.Enum
Members
Member | Description
CentimetreCandle |
Flame |
FootCandle |
LumenPerCentimetreSquared |
LumenPerFootSquared |
LumenPerMetreSquared |
Lux |
MetreCandle |
Nox |
Phot |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Illumination

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ImageFormat Enumeration
ImageFormat Enumeration
Specifies file save format.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ImageFormat
   Inherits System.Enum
'Usage

Dim instance As ImageFormat
public enum ImageFormat : System.Enum
Members
Member | Description
Bmp | Saves an image as a bitmap (BMP).
Emf | Saves an image using the enhanced Windows metafile (EMF) image format.
Jpg | Saves an image using the Joint Photographic Experts Group (JPEG) image format.
Pdf | Saves an image as a Pdf file.
Png | Saves an image using the W3C Portable Network Graphics (PNG) image format.
Svg | Saves an image as an Svg file.
Svgz | Saves an image as a compressed Svg file.
Swf | Saves an image as an Swf flash movie.
Tif | Saves an image using the Tag Image File Format (TIFF) image format.
Wmf | Saves an image using the Windows metafile (WMF) image format.
Xaml | Saves an image as an Xaml file.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ImageFormat

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Inductance Enumeration
Inductance Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Inductance
   Inherits System.Enum
'Usage

Dim instance As Inductance
public enum Inductance : System.Enum
Members
Member | Description
Abhenry |
Attohenry |
Centihenry |
Decihenry |
Dekahenry |
EMUOfInductanceAbhenry |
ESUOfInductanceStathenry |
Exahenry |
Femtohenry |
Gigahenry |
Hectohenry |
Henry |
Kilohenry |
Megahenry |
Microhenry |
Millihenry |
Nanohenry |
Petahenry |
Picohenry |
Stathenry |
Terahenry |
Yoctohenry |
Yottahenry |
Zeptohenry |
Zettahenry |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Inductance

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : JsOptions.CalendarView Enumeration
JsOptions.CalendarView Enumeration
Specifies a JS calendar chart type view.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum JsOptions.CalendarView
   Inherits System.Enum
'Usage

Dim instance As JsOptions.CalendarView
public enum JsOptions.CalendarView : System.Enum
Members
Member | Description
Auto | Attempts to choose a calendar view automatically based on input data.
Day15Min | Groups data into a grid of 15 minute intervals by 3 hour intervals. Subvalues are grouped into minutes.
Day30Min | Groups data into a grid of 30 minute intervals by 3 hour intervals. Subvalues are grouped into minutes.
Day5Min | Groups data into a grid of 5 minute intervals by hour. Subvalues are grouped into minutes.
DayHours | Groups data into a grid of 6 hour intervals by hour. Subvalues are grouped into minutes.
DayMinutes | Groups data into a grid of hours by minute. Subvalues are grouped into seconds.
Decade | Groups data into a grid of 10 year intervals by year(10).
Hour10Sec | Groups data into a grid of 10 second intervals by 5 minute intervals. Subvalues are grouped into 50 millisecond intervals.
Hour30Sec | Groups data into a grid of 30 second intervals by 5 minute intervals. Subvalues are grouped into 50 millisecond intervals.
HourMinutes | Groups data into a grid of 10 minute intervals by minute. Subvalues are grouped into 50 millisecond intervals.
HourSeconds | Groups data into a grid hours by minute. Subvalues are grouped into milliseconds.
Minute | Groups data into a grid of seconds by milliseconds.
Month | Groups data into a grid of weekdays by week spanning 1 month. Subvalues are grouped into hours.
Quarter | Groups data into a grid of weeks by weekday spanning 3 months. Subvalues are grouped into hours.
Week | Groups data into a grid of hours by weekday. Subvalues are grouped into minutes.
Week30Min | Groups data into a grid of 30 minutes intervals by weekday. Subvalues are grouped into minutes.
Year | Groups data into a grid of weeks by weekdays. Subvalues are grouped into hours.
Years | Groups data into a grid of years by months. Subvalues are grouped into days.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.JsOptions.CalendarView

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LabelAlignment Enumeration
LabelAlignment Enumeration
Specifies alignment of a label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LabelAlignment
   Inherits System.Enum
'Usage

Dim instance As LabelAlignment
public enum LabelAlignment : System.Enum
Members
Member | Description
Automatic | Label is aligned automatically.
Bottom | Label is bottom aligned.
Center | Label is center aligned.
OutsideBottom | Label is below an object such as a column.
OutsideTop | Label is above an object such as a column.
Top | Label is top aligned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LabelAlignment

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LabelType Enumeration
LabelType Enumeration
Specifies the label type used with labels.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LabelType
   Inherits System.Enum
'Usage

Dim instance As LabelType
public enum LabelType : System.Enum
Members
Member | Description
Digital | A digital readout font is used. The Label.Font properties such as size and font style are used as well except the font name is ignored.
UseFont | The default label behavior where the Label.Font font is used.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LabelType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LegendBoxPosition Enumeration
LegendBoxPosition Enumeration
Specifies the position of the legend box.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendBoxPosition
   Inherits System.Enum
'Usage

Dim instance As LegendBoxPosition
public enum LegendBoxPosition : System.Enum
Members
Member | Description
Bottom | The legend box is rendered at the bottom right side of the graph.
BottomMiddle | The legend box is rendered at the bottom middle side of the graph.
ChartArea | Legendbox is drawn inside the chart area.
Middle | The legend box is rendered at the middle right side of the graph.
None | The legend box is now visible.
Top | The legend box is rendered at the top right side of the graph.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LegendBoxPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LegendEntryHeaderMode Enumeration
LegendEntryHeaderMode Enumeration
Specifies a header mode for element entries.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LegendEntryHeaderMode
   Inherits System.Enum
'Usage

Dim instance As LegendEntryHeaderMode
public enum LegendEntryHeaderMode : System.Enum
Members
Member | Description
None | No effect.
RepeatOnEachColumn | Forces the LegendEntry to be repeated at the top of each column in multi-column legend boxes.
StartNewColumn | Causes the LegendEntry to start a new column.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LegendEntryHeaderMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Length Enumeration
Length Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Length
   Inherits System.Enum
'Usage

Dim instance As Length
public enum Length : System.Enum
Members
Member | Description
Aln |
Angstroms |
Arpentlin |
AstronomicalUnit |
Attometre |
Barleycorn |
Caliber |
Centimetre |
Chain |
ClothNail |
ClothSpan |
CubitBiblical |
CubitGreek |
Decimetre |
Dekametre |
Exametre |
Famn |
Fathom |
Femtometre |
Fermi |
Foot |
Furlong |
Gigametre |
Hectometre |
Inch |
Ken |
Kilometre |
Kiloparsec |
League |
LightYear |
Link |
Megametre |
Megaparsec |
Metre |
Micrometre |
Mil |
MIL |
MileRoman |
MileUS |
MileUSSurveyFoot |
Millimetre |
Nanometre |
NauticalMile |
Parsec |
Perch |
Petametre |
Picometre |
Pole |
Rod |
RomanActus |
RussianArchin |
Terametre |
VaraCastellana |
VaraConuquera |
VaraDeTarea |
Yard |
Yoctometre |
Yottametre |
Zeptometre |
Zettametre |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Length

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LimitMode Enumeration
LimitMode Enumeration
Controls the type of limitation in Limit or SplitByLimit properties.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LimitMode
   Inherits System.Enum
'Usage

Dim instance As LimitMode
public enum LimitMode : System.Enum
Members
Member | Description
Bottom | Keep only bottom Limit values.
ExcludeBottom | Remove Bottom Limit values.
ExcludeTop | Remove top Limit values.
Top | Keep only top Limit values.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LimitMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LoadingAnimation Enumeration
LoadingAnimation Enumeration
Specifies a predefined loading animation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LoadingAnimation
   Inherits System.Enum
'Usage

Dim instance As LoadingAnimation
public enum LoadingAnimation : System.Enum
Members
Member | Description
CircleSegmented | Segmented circle animation.
None | No animation.
Snake | Rotating snake animation.
SnakeDouble | Double snakes animation.
SnakeSegmented | Segmented Snake animation.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LoadingAnimation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : LumberVolume Enumeration
LumberVolume Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum LumberVolume
   Inherits System.Enum
'Usage

Dim instance As LumberVolume
public enum LumberVolume : System.Enum
Members
Member | Description
A1000BoardFeet |
BoardFeetAprox |
CordOfHardwoodAprox |
CordOfSoftwoodAprox |
CrossTie |
CubicFeet |
CubicMetres |
CubicYards |
Cunit |
HandleBlankAprox |
Mine |
Pallet |
Pole |
SkidsAprox |
SolidContantCord |
StandardCord |
SwitchTiesAprox |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.LumberVolume

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Mass Enumeration
Mass Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Mass
   Inherits System.Enum
'Usage

Dim instance As Mass
public enum Mass : System.Enum
Members
Member | Description
Attogram |
Carat |
Centigram |
Dalton |
Decigram |
Dekagram |
Exagram |
Femtogram |
Gigagram |
Grain |
Gram |
Hectogram |
HunderdweightUK |
Hundredweight |
Kilogram |
Kip |
LongTon |
Megagram |
MetricTonne |
Microgram |
Milligram |
Nanogram |
Ounce |
Pennyweight |
Petagram |
Picogram |
Poundal |
PoundMass |
Scruple |
Slug |
Stone |
StoneUK |
Teragram |
Ton |
TroyOunce |
TroyPound |
Yoctogram |
Yottagram |
Zeptogram |
Zettagram |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Mass

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : OrganizationalConnectorType Enumeration
OrganizationalConnectorType Enumeration
(JS Charts Only) Specifies whether organizational connector lines are drawn straight between nodes or only using right angles.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum OrganizationalConnectorType
   Inherits System.Enum
'Usage

Dim instance As OrganizationalConnectorType
public enum OrganizationalConnectorType : System.Enum
Members
Member | Description
RightAngle | Draws right-angle connector lines.
Straight | Draws straight connector lines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.OrganizationalConnectorType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Orientation Enumeration
Orientation Enumeration
Specifies the orientation of an object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Orientation
   Inherits System.Enum
'Usage

Dim instance As Orientation
public enum Orientation : System.Enum
Members
Member | Description
Bottom | The object is on bottom.
BottomLeft | The object ( Usually an annotation) on the bottom left hand side.
BottomRight | The object ( Usually an annotation) on the bottom right hand side.
Left | The object is on the left.
None | No orientation is specified.
Right | The object is on the right.
Top | The object is on top.
TopLeft | The object ( Usually an annotation) on the upper left hand side.
TopRight | The object ( Usually an annotation) on the upper right hand side.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Orientation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Palette Enumeration
Palette Enumeration
Specifies a pre-defined palette.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Palette
   Inherits System.Enum
'Usage

Dim instance As Palette
public enum Palette : System.Enum
Members
Member | Description
Autumn | Autumn palette.
Bright | Bright palette.
DarkRainbow | Dark rainbow palette. (Optimized for ShadingEffectMode.Four)
Default | A new default palette introduced with version 10.0
Default7 | A new default palette introduced with version 7.0.
Five | Palette five.
FiveColor1 | Five color palette 1.
FiveColor10 | Five color palette 10.
FiveColor11 | Five color palette 11.
FiveColor12 | Five color palette 12.
FiveColor13 | Five color palette 13.
FiveColor14 | Five color palette 14.
FiveColor15 | Five color palette 15.
FiveColor16 | Five color palette 16.
FiveColor17 | Five color palette 17.
FiveColor18 | Five color palette 18.
FiveColor19 | Five color palette 19.
FiveColor2 | Five color palette 2.
FiveColor20 | Five color palette 20.
FiveColor21 | Five color palette 21.
FiveColor22 | Five color palette 22.
FiveColor23 | Five color palette 23.
FiveColor24 | Five color palette 24.
FiveColor25 | Five color palette 25.
FiveColor26 | Five color palette 26.
FiveColor27 | Five color palette 27.
FiveColor28 | Five color palette 28.
FiveColor29 | Five color palette 29.
FiveColor3 | Five color palette 3.
FiveColor30 | Five color palette 30.
FiveColor31 | Five color palette 31.
FiveColor32 | Five color palette 32.
FiveColor33 | Five color palette 33.
FiveColor34 | Five color palette 34.
FiveColor35 | Five color palette 35.
FiveColor36 | Five color palette 36.
FiveColor37 | Five color palette 37.
FiveColor38 | Five color palette 38.
FiveColor39 | Five color palette 39.
FiveColor4 | Five color palette 4.
FiveColor40 | Five color palette 40.
FiveColor41 | Five color palette 41.
FiveColor42 | Five color palette 42.
FiveColor43 | Five color palette 43.
FiveColor44 | Five color palette 44.
FiveColor45 | Five color palette 45.
FiveColor46 | Five color palette 46.
FiveColor5 | Five color palette 5.
FiveColor6 | Five color palette 6.
FiveColor7 | Five color palette 7.
FiveColor8 | Five color palette 8.
FiveColor9 | Five color palette 9.
Four | Palette four.
Lavender | Lavender palette.
MidRange | Mid range colors. (Optimized for ShadingEffectMode.Four)
MidTones | Mid tones palette.
Mixed | Mixed palette.
None | No Palette
One | Palette one.
Pastel | Pastel palette.
Poppies | Poppies palette.
Random | A random palette.
Spring | Spring palette.
Three | Palette three.
Two | Palette two.
VividDark | Vivid dark palette. (Optimized for ShadingEffectMode.Four)
WarmEarth | Warm earth palette.
WaterMeadow | Water meadow palette.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Palette

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Permeability Enumeration
Permeability Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Permeability
   Inherits System.Enum
'Usage

Dim instance As Permeability
public enum Permeability : System.Enum
Members
Member | Description
APermeability0C |
APermeability23C |
APermeabilityInches0C |
APermeabilityInches23C |
KilogramPerPascalSecondSquareMeter |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Permeability

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : PieLabelMode Enumeration
PieLabelMode Enumeration
Specifies pie label behavior.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PieLabelMode
   Inherits System.Enum
'Usage

Dim instance As PieLabelMode
public enum PieLabelMode : System.Enum
Members
Member | Description
Automatic | If labels fit inside a slice they are drawn there otherwise they are drawn outside with a line pointing to the slice it represents.
Inside | Labels must be inside the pie, if they dont fit they will not be visible.
Outside | Labels are drawn outside the pie with a line pointing to the slice it represents.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.PieLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Placement Enumeration
Placement Enumeration
(JS Charts Only) Used with labels to specify inside or outside placement.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Placement
   Inherits System.Enum
'Usage

Dim instance As Placement
public enum Placement : System.Enum
Members
Member | Description
Auto | Determined by the chart automatically.
Inside | Label is drawn inside the object.
Outside | Label is drawn outside the object.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Placement

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Power Enumeration
Power Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Power
   Inherits System.Enum
'Usage

Dim instance As Power
public enum Power : System.Enum
Members
Member | Description
AHorsepower550FtLbfS |
AttojoulePerSecond |
Attowatt |
BTUPerHour |
BTUPerMinute |
BTUPerSecond |
CaloriesPerHour |
CaloriesPerMinute |
CaloriesPerSecond |
CentijoulePerSecond |
Centiwatt |
DecijoulePerSecond |
Deciwatt |
DekajoulePerSecond |
Dekawatt |
ErgPerSecond |
ExajoulePerSecond |
Exawatt |
FemtojoulePerSecond |
Femtowatt |
GigajoulePerSecond |
Gigawatt |
HectojoulePerSecond |
Hectowatt |
HorsepowerBioler |
HorsepowerBoiler |
HorsepowerElectric |
HorsepowerMetric |
HorsepowerUK |
HorsepowerWater |
JoulePerHour |
JoulePerMinute |
JoulePerSecond |
KilocaloriePerHour |
KilocaloriePerMinute |
KilocaloriePerSecond |
KilojoulePerHour |
KilojoulePerMinute |
KilojoulePerSecond |
Kilowatt |
MegajoulePerSecond |
Megawatt |
MicrojoulePerSecond |
Microwatt |
MillijoulePerSecond |
Milliwatt |
NanojoulePerSecond |
Nanowatt |
PetajoulePerSecond |
Petawatt |
Pherdeste |
PicojoulePerSecond |
Picowatt |
PoundFootPerHour |
PoundFootPerMinute |
PoundFootPerSecond |
RefrigerativeTon |
TerajoulePerSecond |
Terawatt |
Watt |
YoctojoulePerSecond |
Yoctowatt |
YottajoulePerSecond |
Yottawatt |
ZeptajoulePerSecond |
ZeptojoulePerSecond |
Zeptowatt |
Zettawatt |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Power

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Pressure Enumeration
Pressure Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Pressure
   Inherits System.Enum
'Usage

Dim instance As Pressure
public enum Pressure : System.Enum
Members
Member | Description
AAFootOfWater155C |
AAInchOfMercury155C |
AAInchOfWater155C |
AAMillimetreOfWater155C |
ACentimeterOfMercury0C |
AFootOfWater4C |
AInchOfMercury0C |
AInchOfWater4C |
AMillimetreOfWater4C |
AMillimetresOfMercury0C |
Atmosphere |
Attopascal |
Bar |
CentimeterOfMercuryConventional |
Centipascal |
Decipascal |
Dekapascal |
DynesPerCentemetreSquared |
Exapascal |
Femtopascal |
FootOfWaterConventional |
Gigapascal |
GramsPerMetreSquared |
Hectopascal |
InchOfMercuryConventional |
InchOfWaterConventional |
KilogramsPerCentimetreSquared |
KilogramsPerMetreSquared |
KilogramsPerSquareInch |
Kilopascal |
Megapascal |
Microbar |
Micropascal |
Milibar |
MillimetreOfWaterConventional |
Millipascal |
MilllimeterOfMercuryConventional |
Nanopascal |
NewtonsPerMetreSquared |
Pascal |
Petapascal |
Picopascal |
PoundsPerSquareFoot |
PoundsPerSquareInch |
Terapascal |
TonsPerSquareFoot |
TonsPerSquareInch |
Torr |
Yoctopascal |
Yottapascal |
Zeptopascal |
Zettapascal |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Pressure

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : PreviewAreaNavigationOptions Enumeration
PreviewAreaNavigationOptions Enumeration
Specifies the navigation options of the navigators preview area.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum PreviewAreaNavigationOptions
   Inherits System.Enum
'Usage

Dim instance As PreviewAreaNavigationOptions
public enum PreviewAreaNavigationOptions : System.Enum
Members
Member | Description
ArbitrarySelection | Enables selection at any arbitrary position
Cells | Enables Cell selection.
ScrollWheel | Enables scroll wheel zooming.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.PreviewAreaNavigationOptions

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : RadarLabelMode Enumeration
RadarLabelMode Enumeration
Specifies how tick labels behave on a radar graph.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RadarLabelMode
   Inherits System.Enum
'Usage

Dim instance As RadarLabelMode
public enum RadarLabelMode : System.Enum
Members
Member | Description
Angled | The labels are angled based on the tick mark angle.
Inside | The label is on the right side of the tick mark and angled to touch the top of the grid. The label will be within the radar grid.
None | The labels are not visible.
Normal | The labels are drawn horizontally next to the tick mark.
Outside | The label is on the right side of the tick mark and angled to lie on top of the grid. The label will be outside the radar grid.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.RadarLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : RadarMode Enumeration
RadarMode Enumeration
Specifies the behavior of the x axis on a circular graph such as radar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum RadarMode
   Inherits System.Enum
'Usage

Dim instance As RadarMode
public enum RadarMode : System.Enum
Members
Member | Description
Polar | The x axis ticks marks are connected by arcs completing a circle around the chart. Connected data points such as lines will have data points interpolated around the arc.
Spider | The x axis tick marks are connected by straight lines resembling a spider web.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.RadarMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Radiation Enumeration
Radiation Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Radiation
   Inherits System.Enum
'Usage

Dim instance As Radiation
public enum Radiation : System.Enum
Members
Member | Description
AttograyPerSecond |
CentigrayPerSecond |
DecigrayPerSecond |
DekagrayPerSecond |
ExagrayPerSecond |
FemtograyPerSecond |
GigagrayPerSecond |
GrayPerSecond |
HectograyPerSecond |
JoulePerKilogramPerSecond |
KilograyPerSecond |
MegagrayPerSecond |
MicrograyPerSecond |
MilligrayPerSecond |
NanograyPerSecond |
PetagrayPerSecond |
PicograyPerSecond |
RadPerSecond |
TeragrayPerSecond |
YoctograyPerSecond |
YottagrayPerSecond |
ZeptograyPerSecond |
ZettagrayPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Radiation

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Scale Enumeration
Scale Enumeration
Indicates the scale of an axis.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Scale
   Inherits System.Enum
'Usage

Dim instance As Scale
public enum Scale : System.Enum
Members
Member | Description
FullStacked | Elements are stacked and each stack is equal to 100%.
Logarithmic | Logarithmic axis scale.
LogarithmicStacked | Similar to Logarithmic but elements are stacked on top of each other.
Normal | The normal scale will always show 0 on the chart.
Range | The axis will start and end shortly outside the range of element values.
Stacked | Similar to Normal but elements are stacked on top of each other.
Time | Time axis scale.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Scale

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ScaleBreakStyle Enumeration
ScaleBreakStyle Enumeration
Specifies how a scale break is drawn on a chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ScaleBreakStyle
   Inherits System.Enum
'Usage

Dim instance As ScaleBreakStyle
public enum ScaleBreakStyle : System.Enum
Members
Member | Description
Gap | A gap is drawn at the scale break position.
Line | A line is drawn at the scale break position.
None | The scale break is not accentuated in any way.
ZigZag | A gap with a zig zag is drawn at the scale break position.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ScaleBreakStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SeriesType Enumeration
SeriesType Enumeration
Specifies how a series will be shown on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SeriesType
   Inherits System.Enum
'Usage

Dim instance As SeriesType
public enum SeriesType : System.Enum
Members
Member | Description
AreaLine | Draws the series as an area line.
AreaSpline | Draws the series as an area spline.
Bar | See Column.
BarSegmented | Draws the series as a segmented bar.
Bubble | Draws the series elements as bubbles.
BubbleShape | Draws the series as a shape, based on the element's ShapeType property.
Column | Draws the series as a bar.
Cone | Draws the series as a cone.
Cylinder | Draws the series as a cylinder.
Line | Draws the series as a line.
Marker | Draws elements as element markers.
Pyramid | Draws the series as a four point pyramid.
Spline | Draws the series as a spline.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SeriesType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SeriesTypeFinancial Enumeration
SeriesTypeFinancial Enumeration
Specifies how a financial series will be shown on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SeriesTypeFinancial
   Inherits System.Enum
'Usage

Dim instance As SeriesTypeFinancial
public enum SeriesTypeFinancial : System.Enum
Members
Member | Description
Bar | Draws the series with bars.
CandleStick | Draws the series with candle sticks.
Close | Draws the closing price as a line.
High | Draws the high price as a line.
HighLowArea | Draws a range area of highs and lows.
Low | Draws the low price as a line.
Open | Draws the opening price as a line.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SeriesTypeFinancial

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SeriesTypeMultiple Enumeration
SeriesTypeMultiple Enumeration
Specifies how a multiple chart type series will be shown on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SeriesTypeMultiple
   Inherits System.Enum
'Usage

Dim instance As SeriesTypeMultiple
public enum SeriesTypeMultiple : System.Enum
Members
Member | Description
Cone | Draws the series as a cone.
Donut | Draws the series as a donut.
FunnelCone | Draws the series as a funnel cone.
FunnelPyramid | Draws the series as a funnel pyramid.
Gauge | Draws the series as a gauge.
Pie | Draws the series as a pie.
Pyramid | Draws the series as a pyramid.
StackedBubble | Draws the series as a stacked bubble.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SeriesTypeMultiple

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SeriesTypeSurface Enumeration
SeriesTypeSurface Enumeration
Specifies how a surface series type will be shown on the chart.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SeriesTypeSurface
   Inherits System.Enum
'Usage

Dim instance As SeriesTypeSurface
public enum SeriesTypeSurface : System.Enum
Members
Member | Description
Contour | Fills the surface with contour lines and fills the gaps.
Surface | Draws the surface using tiles.
SurfaceX | Similar to surface but with only x axis lines.
SurfaceY | Similar to surface but with only y axis lines.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SeriesTypeSurface

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ShadingEffectMode Enumeration
ShadingEffectMode Enumeration
Specifies a shading mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ShadingEffectMode
   Inherits System.Enum
'Usage

Dim instance As ShadingEffectMode
public enum ShadingEffectMode : System.Enum
Members
Member | Description
Background1 | Background Shading style 1. Used for box backgrounds.
Background2 | Background Shading style 2. Used for box backgrounds.
Default | A default shading used with background of objects such as AxisMarkers, AlternateGridBackground, Box, BoxHeader, ChartArea.
Eight | Shading style Eight.
Five | Shading style Five.
Four | Shading style Four.
None | No shading is applied.
One | Shading style One.
Seven | Shading style Seven.
Six | Shading style Six.
SubtleGradient | A subtle shading effect for bars and columns
Three | Shading style Three.
Two | Shading style Two.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ShadingEffectMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ShapeType Enumeration
ShapeType Enumeration
Specifies how a shape bubble will be drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ShapeType
   Inherits System.Enum
'Usage

Dim instance As ShapeType
public enum ShapeType : System.Enum
Members
Member | Description
ArrowDown | Arrow down shape.
ArrowLeft | Arrow left shape.
ArrowRight | Arrow right shape.
ArrowUp | Arrow up shape.
Bell | Bell shape.
Candle | Candle shape.
Chat | Chat bubbles shape.
Check | Check shape.
Clover | Clover shape.
Cube | Cube shape.
Decagon | Decagon shape.
Drop | Drop shape.
EightPointStar | Eight Point Star shape.
FivePointStar | Five Point Star shape.
Flag | Flag shape.
Flake | Flake shape.
Folder | Folder shape.
Hand | Hand shape.
Heart | Hear shape.
Heptagon | Heptagon shape.
Hexagon | Hexagon shape.
Hourglass | Hourglass shape.
Mouse | Mouse shape.
Nonagon | Nonagon shape.
None | No shape.
Octagon | Octagon shape.
Peace | Peace shape.
Pentagon | Pentagon shape.
Plane | Plane shape.
PointDown | Point down shape.
PointLeft | Point left shape.
PointRight | Point right shape.
PointUp | Point up shape.
Quote | Quote shape.
Refresh | Refresh shape.
Ribbon | Ribbon shape.
SevenPointStar | Seven Point Star shape.
SixPointStar | Six Point Star shape.
ThumbsDown | Thumbs down shape.
ThumbsUp | Thumbs up shape.
Triangle | Triangle shape.
Trophy | Trophy shape.
X | X shape.
Zap | Zap shape.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ShapeType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SilverlightInstall Enumeration
SilverlightInstall Enumeration
Defines options used to handle Silverlight plugin installation.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SilverlightInstall
   Inherits System.Enum
'Usage

Dim instance As SilverlightInstall
public enum SilverlightInstall : System.Enum
Members
Member | Description
Automatic | Provides Silverlight plugin installation only (default)
None | Displays a static chart image if the plugin is not already installed but shows no warning.
Prompt | Prompts the user to select between the Silverlight plugin installation or displaying a static chart image
Warning | Displays a static chart image automatically if the plugin is not already installed, but also displays a warning notification that the chart experience is not as rich as possible and links to the plugin install.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SilverlightInstall

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SubValueType Enumeration
SubValueType Enumeration
Specifies the how a sub value is drawn.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SubValueType
   Inherits System.Enum
'Usage

Dim instance As SubValueType
public enum SubValueType : System.Enum
Members
Member | Description
ErrorBar | Draws a traditional error bar. The width of the cap line is determined by SubValue.Line.Length. If not specified it is dynamically determined based on the element size.
Line | Same as the error bar except only the cap lines are drawn.
Marker | Draws a marker at the value position of the SubValue. Two markers are drawn then the SubValue represents a range.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SubValueType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SyncDimention Enumeration
SyncDimention Enumeration
(JS Charts Only) Specifies whether organizational chart nodes should sync a dimension like width or height with other all nodes, nodes on the same level, or none.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SyncDimention
   Inherits System.Enum
'Usage

Dim instance As SyncDimention
public enum SyncDimention : System.Enum
Members
Member | Description
All | Synchronize width or height with all other nodes on the organizational chart.
Level | Synchronize width or height with all other nodes on the same organizational level.
None | Do not synchronize width or height with other nodes on the organizational chart.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SyncDimention

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : SynchronizeScaleMode Enumeration
SynchronizeScaleMode Enumeration
Specifies an axis scale synchronization mode between two or more axes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SynchronizeScaleMode
   Inherits System.Enum
'Usage

Dim instance As SynchronizeScaleMode
public enum SynchronizeScaleMode : System.Enum
Members
Member | Description
Full | Synchronizes the complete axis scale (high, and low).
High | Synchronizes the high range values of multiple axes.
Low | Synchronizes the low range values of multiple axes.
Origin | Synchronizes axes to match the axis origins. The origin is the position on a numeric axis where the value is zero (0). This mode does not apply to time axes.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.SynchronizeScaleMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace
Axis Class
ScaleSync Class


%%PageItemTitle%%

dotnetCHARTING Namespace : Telecommunications Enumeration
Telecommunications Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Telecommunications
   Inherits System.Enum
'Usage

Dim instance As Telecommunications
public enum Telecommunications : System.Enum
Members
Member | Description
AASTM16SynchronousTransportModule16Signal |
AASTM1SynchronousTransportModule1Signal |
AASTM4SynchronousTransportModule4Signal |
AASTM64SynchronousTransportModule64Signal |
AE1EPTASignal1Payload |
AE1EPTASignal1Signal |
AE2EPTASignal2Payload |
AE2EPTASignal2Signal |
AE3EPTASignal3Payload |
AE3EPTASignal3Signal |
AOC12OpticalCarrier12Signal |
AOC192OpticalCarrier192Signal |
AOC1OpticalCarrier1Signal |
AOC24OpticalCarrier24Signal |
AOC3OpticalCarrier3Signal |
AOC48OpticalCarrier48Signal |
AOC768OpticalCarrier768Signal |
ASTS12SynchronousTransmissionSignal12Signal |
ASTS192SynchronousTransmissionSignal192Signal |
ASTS1SynchronousTransmissionSignalLevel1Payload |
ASTS1SynchronousTransmissionSignalLevel1Signal |
ASTS24SynchronousTransmissionSignal24Signal |
ASTS3cConcatenatedSynchronousTransmissionSignalLevel2Payload |
ASTS3cConcatenatedSynchronousTransmissionSignalLevel2Signal |
ASTS3SynchronousTransmissionSignalLevel2Payload |
ASTS3SynchronousTransmissionSignalLevel2Signal |
ASTS48SynchronousTransmissionSignal48Signal |
AT1CDigitalSignal1CPayload |
AT1CDigitalSignal1CSignal |
AT1DigitalSignal1Payload |
AT1DigitalSignal1Signal |
AT1ZB8ZSDigitalSignal1Payload |
AT2DigitalSignal2Signal |
AT3DigitalSignal3Payload |
AT3DigitalSignal3Signal |
AT3ZB8ZSDigitalSignal3Payload |
AT4DigitalSignal4Signal |
AVirtualTributary1Payload |
AVirtualTributary1Signal |
AVirtualTributary2Payload |
AVirtualTributary2Signal |
AVirtualTributary3Payload |
AVirtualTributary3Signal |
AVirtualTributary6Payload |
AVirtualTributary6Signal |
BitsPerSecond |
BytesPerSecond |
GigabitsPerSecond |
GigabitsPerSecondBySIDef |
GigabytesPerSecond |
GigabytesPerSecondBySIDef |
H0DigitalBroadbandChannel |
H11DigitalBroadbandChannel |
H12DigitalBroadbandChannel |
H4DigitalBroadbandChannel |
KilobitsPerSecond |
KilobitsPerSecondBySIDef |
KilobytesPerSecond |
KilobytesPerSecondBySIDef |
MegabitsPerSecond |
MegabitsPerSecondBySIDef |
MegabytesPerSecond |
MegabytesPerSecondBySIDef |
T0DigitalSignalZeroB8ZSPayload |
T0DigitalSignalZeroPayload |
TerabitsPerSecond |
TerabitsPerSecondBySIDef |
TerabytesPerSecond |
TerabytesPerSecondBySIDef |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Telecommunications

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Temperature Enumeration
Temperature Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Temperature
   Inherits System.Enum
'Usage

Dim instance As Temperature
public enum Temperature : System.Enum
Members
Member | Description
Celsius |
Fahrenheit |
Kelvin |
Rankine |
Reaumur |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Temperature

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : TickLabelMode Enumeration
TickLabelMode Enumeration
Specifies how tick labels are laid out.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TickLabelMode
   Inherits System.Enum
'Usage

Dim instance As TickLabelMode
public enum TickLabelMode : System.Enum
Members
Member | Description
Angled | Specifies that labels are angled. Only applies to x axes.
Automatic | Specifies that the best mode is automatically determined.
Normal | Specifies that labels are drawn horizontally on a single line. If labels will overlap with this setting, they will automatically switch to angled.
Wrapped | Specifies that labels are drawn wrapping horizontally. If labels will overlap with this setting, they will automatically switch to angled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TickLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Time Enumeration
Time Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Time
   Inherits System.Enum
'Usage

Dim instance As Time
public enum Time : System.Enum
Members
Member | Description
Century |
Day |
Fortnight |
Hour |
LeapYear |
Minute |
Month |
Novennial |
Octennial |
Quindecennial |
Quinquennial |
Second |
Septennial |
Shake |
SiderealDay |
SiderealHour |
SiderealYear |
SynodicMonth |
Week |
Year |
YearMean |
YearTropical |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Time

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : TimeInterval Enumeration
TimeInterval Enumeration
Specifies a time interval.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TimeInterval
   Inherits System.Enum
'Usage

Dim instance As TimeInterval
public enum TimeInterval : System.Enum
Members
Member | Description
Day | Specifies day by hour.
Days | Specifies days.
Hour | Specifies hour by minute.
Hours | Specifies hours.
Milliseconds | Specified one millisecond.
Minute | Specifies minute by seconds.
Minutes | Specifies minutes.
Month | Specifies month by day.
Months | Specifies months.
None | Specifies no time interval.
Quarter | Specifies year by quarter (3 months).
Quarters | Specifies quarters (3 months).
Second | Specifies second.
Seconds | Specifies seconds.
Week | Specifies week by day.
Weeks | Specifies weeks.
Year | Specifies year by months.
Years | Specifies years.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TimeInterval

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : TimeScaleLabelMode Enumeration
TimeScaleLabelMode Enumeration
Specifies the single value time label automation mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TimeScaleLabelMode
   Inherits System.Enum
'Usage

Dim instance As TimeScaleLabelMode
public enum TimeScaleLabelMode : System.Enum
Members
Member | Description
Default | Specifies no time label automation. Only the Axis.DefaultTick and Axis.FormatString will be used.
Dynamic | Specifies time instance specific label automation mode. Axis ticks will use a format string and axis tick relevant to the instance in time they represent.
Hidden | Specifies hidden time label mode. Single value time labels will not be shown.
Smart | Specifies smart time label automation. Similar to specific except the first tick will indicate the instance in time and take it's default value from the axis default tick.
Remarks

This feature automates choosing different format strings and axis ticks for particular instances in time. These time instance attributes can be modified through the Axis.TimeLabelAutomationMode property.

(Tutorial) See:
Getting Started / General Tutorials / Axis Tutorials / Axis Ticks / Axis Time Label Automation

Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TimeScaleLabelMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace
TimeLabelAutomationInfo Class
TimeLabelAutomation Property (dotnetCHARTING.Axis)


%%PageItemTitle%%

dotnetCHARTING Namespace : TimeScaleLabelRangeMode Enumeration
TimeScaleLabelRangeMode Enumeration
Specifies the range value time label automation mode.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TimeScaleLabelRangeMode
   Inherits System.Enum
'Usage

Dim instance As TimeScaleLabelRangeMode
public enum TimeScaleLabelRangeMode : System.Enum
Members
Member | Description
Default | Range time ticks will not be generated unless the time intervals are specified in TimeScaleLabelInfo.RangeIntervals.
Dynamic | Range time ticks are generated based on dynamically determined intervals. If time intervals are specified in TimeScaleLabelInfo.RangeIntervals this mode will behave like Default mode.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TimeScaleLabelRangeMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : TitleBoxPosition Enumeration
TitleBoxPosition Enumeration
Specifies the title box position.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TitleBoxPosition
   Inherits System.Enum
'Usage

Dim instance As TitleBoxPosition
public enum TitleBoxPosition : System.Enum
Members
Member | Description
Center | Title box is centered.
Full | Title box is stretched across the graph area ( Text is centered ).
FullWithLegend | Title box is stretched across the graph area ( Text is left aligned, legend right aligned ).
Left | Title box is left aligned.
None | Title box not drawn.
Right | Title box is right aligned.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TitleBoxPosition

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Torque Enumeration
Torque Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Torque
   Inherits System.Enum
'Usage

Dim instance As Torque
public enum Torque : System.Enum
Members
Member | Description
DyneCentemetre |
DyneMetre |
DyneMillimetre |
GramForceCentimetre |
GramForceMetre |
GramForceMillimetre |
KilogramForceCentimetre |
KilogramForceMetre |
KilogramForceMillimetre |
KilonewtonMetres |
NetwonCentimetre |
NetwonMelimetre |
NewtonMetre |
OunceForceInchAvoirdupois |
OunceFourceFootAvoirdupois |
PoundForceFoot |
PoundForceInch |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Torque

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : TruncationMode Enumeration
TruncationMode Enumeration
Specifies how to trim characters from a string that exceeds a maximum number of characters.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum TruncationMode
   Inherits System.Enum
'Usage

Dim instance As TruncationMode
public enum TruncationMode : System.Enum
Members
Member | Description
End | The start of a string is removed until the specified number of characters remains. (..IJKL)
Middle | The start and end of a string is removed until the specified number of characters remains. (..EFGH..)
None | No trimming is performed.
Start | The end of a string is removed until the specified number of characters remains. (ABCD..)
StartEnd | The middle of a string is removed until the specified number of characters remains (ABCD..IJKL)
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.TruncationMode

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Typography Enumeration
Typography Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Typography
   Inherits System.Enum
'Usage

Dim instance As Typography
public enum Typography : System.Enum
Members
Member | Description
AAPicaComputer16 |
Centimetres |
Ceros |
En |
Inches |
Millimetres |
PicaPrinterS |
PostScriptPoints |
PrinterPoints |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Typography

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Velocity Enumeration
Velocity Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Velocity
   Inherits System.Enum
'Usage

Dim instance As Velocity
public enum Velocity : System.Enum
Members
Member | Description
AAMach10000Ft |
AAMach20000Ft |
AAMach30000Ft |
AAMach36089Ft |
CentimetrePerHour |
CentimetrePerMinute |
CentimetrePerSecond |
FootPerHour |
FootPerMinute |
FootPerSecond |
KilometerPerHour |
KilometerPerMinute |
KilometerPerSecond |
Knots |
LightSpeed |
MachSeaLevel |
MetersPerSecond |
MetrePerHour |
MetrePerMinute |
MilePerHour |
MilePerMinute |
MilePerSecond |
YardPerHour |
YardPerMinute |
YardPerSecond |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Velocity

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ViscosityDynamic Enumeration
ViscosityDynamic Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ViscosityDynamic
   Inherits System.Enum
'Usage

Dim instance As ViscosityDynamic
public enum ViscosityDynamic : System.Enum
Members
Member | Description
Attopoise |
Centipoise |
Decipoise |
Dekapoise |
Exapoise |
Femtopoise |
Gigapoise |
Hectopoise |
Kilopoise |
Megapoise |
Micropoise |
Millipoise |
Nanopoise |
PascalSecond |
Petapoise |
Picopoise |
Poise |
PoundalSecondPerSquareFoot |
PoundForceSecondPerSquareFoot |
PoundForceSecondPerSquareInch |
PoundPerFootHour |
PoundPerFootSecond |
SlugPerFootSecond |
Terapoise |
Yoctopoise |
Yottapoise |
Zeptopoise |
Zettapoise |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ViscosityDynamic

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ViscosityKinematic Enumeration
ViscosityKinematic Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ViscosityKinematic
   Inherits System.Enum
'Usage

Dim instance As ViscosityKinematic
public enum ViscosityKinematic : System.Enum
Members
Member | Description
Attostokes |
Centistokes |
Decistokes |
Dekastokes |
Exastokes |
Femtostokes |
Gigastokes |
Hectostokes |
Kilostokes |
Megastokes |
MetreSquaredPerSecond |
Microstokes |
Millistokes |
Nanostokes |
Petastokes |
Picostokes |
SquareFootPerSecond |
Stokes |
Terastokes |
Yoctostokes |
Yottastokes |
Zeptostokes |
Zettastokes |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.ViscosityKinematic

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : Volume Enumeration
Volume Enumeration
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum Volume
   Inherits System.Enum
'Usage

Dim instance As Volume
public enum Volume : System.Enum
Members
Member | Description
AcreFoot |
Attolitre |
BarrelPetroleum |
BarrelUSDry |
BushelUK |
BushelUS |
Centilitre |
CubicCentimetre |
CubicFeet |
CubicInches |
CubicMetres |
CubicYards |
CupUK |
CupUS |
Dash |
Decilitre |
Dekalitre |
Dram |
DryPint |
DryQuart |
Exalitre |
Femtolitre |
FluidOuncesUK |
FluidOuncesUS |
GallonUK |
GallonUS |
Gigalitre |
GillUK |
GillUS |
Hectolitre |
Hogshead |
Kilolitre |
Litre |
Megalitre |
MetricTablespoon |
MetricTeaspoon |
Microlitre |
Millilitre |
MinimUK |
MinimUS |
Nanolitre |
PeckUK |
PeckUS |
Petalitre |
Picolitre |
Pinch |
PintUK |
PintUS |
QuartUK |
QuartUS |
Smidgen |
Tablespoon |
TablespoonAustralia |
TazaEspa |
Teaspoon |
Teralitre |
Yoctolitre |
Yottalitre |
Zeptolitre |
Zettalitre |
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Volume

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING Namespace


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : LabelOverride Structure
LabelOverride Structure
Defines a string find and replace pair used by Axis objects to manipulate tick labels.
Object Model
LabelOverride Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure LabelOverride
   Inherits System.ValueType
'Usage

Dim instance As LabelOverride
public struct LabelOverride : System.ValueType
Remarks
The key must match the whole label string not just a part of it.
Inheritance Hierarchy

System.Object
System.ValueType
dotnetCHARTING.LabelOverride

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Fields

dotnetCHARTING Namespace : LabelOverride Structure
LabelOverride Structure Members

The following tables list the members exposed by LabelOverride.

Public Constructors
 | Name | Description
Public Constructor | LabelOverride Constructor | Overloaded.
Top
Public Fields
 | Name | Description
Public Field | IgnoreCase | Specifies whether the key is case sensitive.
Public Field | Key | String to override.
Public Field | Value | String to override the key with.
Top
See Also

Reference

LabelOverride Structure
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > LabelOverride Structure : LabelOverride Constructor
LabelOverride Constructor
Overload List
Overload | Description
LabelOverride Constructor(String,String) | Initialize a new case insensitive instance of the LabelOverride class.
LabelOverride Constructor(String,String,Boolean) | Initialize a new instance of the LabelOverride class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members


%%PageItemTitle%%

dotnetCHARTING Namespace > LabelOverride Structure > LabelOverride Constructor : LabelOverride Constructor(String,String)
String to override.
String to override the key with.
LabelOverride Constructor(String,String)
Initialize a new case insensitive instance of the LabelOverride class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As String, _
   ByVal val As String _
)
'Usage

Dim key As String
Dim val As String

Dim instance As New LabelOverride(key, val)
public LabelOverride(
   string key,
   string val
)

Parameters

key
String to override.
val
String to override the key with.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members
Overload List


%%PageItemTitle%%

dotnetCHARTING Namespace > LabelOverride Structure > LabelOverride Constructor : LabelOverride Constructor(String,String,Boolean)
String to override.
String to override the key with.
Specifies whether the key is case sensitive.
LabelOverride Constructor(String,String,Boolean)
Initialize a new instance of the LabelOverride class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal key As String, _
   ByVal val As String, _
   ByVal ignoreCase As Boolean _
)
'Usage

Dim key As String
Dim val As String
Dim ignoreCase As Boolean

Dim instance As New LabelOverride(key, val, ignoreCase)
public LabelOverride(
   string key,
   string val,
   bool ignoreCase
)

Parameters

key
String to override.
val
String to override the key with.
ignoreCase
Specifies whether the key is case sensitive.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members
Overload List


%%PageItemTitle%% $$Fields$$

dotnetCHARTING Namespace : LabelOverride Structure
LabelOverride Structure Fields

For a list of all members of this type, see LabelOverride members.

Public Fields
 | Name | Description
Public Field | IgnoreCase | Specifies whether the key is case sensitive.
Public Field | Key | String to override.
Public Field | Value | String to override the key with.
Top
See Also

Reference

LabelOverride Structure
dotnetCHARTING Namespace


dotnetCHARTING Namespace > LabelOverride Structure : IgnoreCase Field
IgnoreCase Field
Specifies whether the key is case sensitive.
Syntax
  • Visual Basic
  • C#
'Declaration

Public IgnoreCase As Boolean
'Usage

Dim instance As LabelOverride
Dim value As Boolean

value = instance.IgnoreCase

instance.IgnoreCase = value
public bool IgnoreCase
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members


dotnetCHARTING Namespace > LabelOverride Structure : Key Field
Key Field
String to override.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Key As String
'Usage

Dim instance As LabelOverride
Dim value As String

value = instance.Key

instance.Key = value
public string Key
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members


dotnetCHARTING Namespace > LabelOverride Structure : Value Field
Value Field
String to override the key with.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Value As String
'Usage

Dim instance As LabelOverride
Dim value As String

value = instance.Value

instance.Value = value
public string Value
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

LabelOverride Structure
LabelOverride Members


%%PageItemTitle%%

Members

dotnetCHARTING Namespace : Vector Structure
Vector Structure
Object Model
Vector Structure
Syntax
  • Visual Basic
  • C#
'Declaration

Public Structure Vector
   Inherits System.ValueType
'Usage

Dim instance As Vector
public struct Vector : System.ValueType
Inheritance Hierarchy

System.Object
System.ValueType
dotnetCHARTING.Vector

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Members
dotnetCHARTING Namespace


%%PageItemTitle%% $$Members$$

Fields Methods

dotnetCHARTING Namespace : Vector Structure
Vector Structure Members

The following tables list the members exposed by Vector.

Public Constructors
 | Name | Description
Public Constructor | Vector Constructor |
Top
Public Fields
 | Name | Description
Public Field | x |
Public Field | y |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | invertedDirection |
Public Method | isOpposite |
Top
See Also

Reference

Vector Structure
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace > Vector Structure : Vector Constructor
Vector Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal xVal As Integer, _
   ByVal yVal As Integer _
)
'Usage

Dim xVal As Integer
Dim yVal As Integer

Dim instance As New Vector(xVal, yVal)
public Vector(
   int xVal,
   int yVal
)

Parameters

xVal
yVal
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Structure
Vector Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Vector Structure
Vector Structure Methods

For a list of all members of this type, see Vector members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | invertedDirection |
Public Method | isOpposite |
Top
See Also

Reference

Vector Structure
dotnetCHARTING Namespace


dotnetCHARTING Namespace > Vector Structure : invertedDirection Method
invertedDirection Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function invertedDirection( _
   ByVal lhs As Vector, _
   ByVal rhs As Vector _
) As Vector
'Usage

Dim lhs As Vector
Dim rhs As Vector
Dim value As Vector

value = Vector.invertedDirection(lhs, rhs)
public static Vector invertedDirection(
   Vector lhs,
   Vector rhs
)

Parameters

lhs
rhs
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Structure
Vector Members


dotnetCHARTING Namespace > Vector Structure : isOpposite Method
isOpposite Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function isOpposite( _
   ByVal vect As Vector _
) As Boolean
'Usage

Dim instance As Vector
Dim vect As Vector
Dim value As Boolean

value = instance.isOpposite(vect)
public bool isOpposite(
   Vector vect
)

Parameters

vect
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Structure
Vector Members


%%PageItemTitle%% $$Fields$$

dotnetCHARTING Namespace : Vector Structure
Vector Structure Fields

For a list of all members of this type, see Vector members.

Public Fields
 | Name | Description
Public Field | x |
Public Field | y |
Top
See Also

Reference

Vector Structure
dotnetCHARTING Namespace


dotnetCHARTING Namespace > Vector Structure : x Field
x Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public x As Integer
'Usage

Dim instance As Vector
Dim value As Integer

value = instance.x

instance.x = value
public int x
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Structure
Vector Members


dotnetCHARTING Namespace > Vector Structure : y Field
y Field
Syntax
  • Visual Basic
  • C#
'Declaration

Public y As Integer
'Usage

Dim instance As Vector
Dim value As Integer

value = instance.y

instance.y = value
public int y
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Vector Structure
Vector Members


%%PageItemTitle%%

dotnetCHARTING Namespace : ChangeValueDelegate Delegate
ChangeValueDelegate Delegate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Function ChangeValueDelegate( _
   ByVal s As String _
) As String
'Usage

Dim instance As New ChangeValueDelegate(AddressOf HandlerMethod)
public delegate string ChangeValueDelegate(
   string s
)

Parameters

s
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChangeValueDelegate Members
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : ErrorProcessingEventHandler Delegate
ErrorProcessingEventHandler Delegate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ErrorProcessingEventHandler( _
   ByVal sender As Object _
)
'Usage

Dim instance As New ErrorProcessingEventHandler(AddressOf HandlerMethod)
public delegate void ErrorProcessingEventHandler(
   object sender
)

Parameters

sender
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ErrorProcessingEventHandler Members
dotnetCHARTING Namespace


%%PageItemTitle%%

dotnetCHARTING Namespace : PostDataProcessingEventHandler Delegate
PostDataProcessingEventHandler Delegate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub PostDataProcessingEventHandler( _
   ByVal sender As Object _
)
'Usage

Dim instance As New PostDataProcessingEventHandler(AddressOf HandlerMethod)
public delegate void PostDataProcessingEventHandler(
   object sender
)

Parameters

sender
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

PostDataProcessingEventHandler Members
dotnetCHARTING Namespace


Inheritance Hierarchy
dotnetCHARTING.Mapping Namespace
Classes
 | Class | Description
Class | Group | Represents a single or multiple conditions that are used to group shapes within a map layer. This object is used with MapLayer.Groups.
Class | GroupCollection | Contains a collection of Group objects.
Class | GroupConditionCollection | Contains a collection of conditions.
Class | MapDataEngine | Acquires a MapLayer from a file.
Class | MapLayer | Represents a layer on the map. Either an ecw file (.ecw) image, or a shape file (.shp) collection of shapes including data the shape file contains.
Class | MapLayerCollection | Contains a collection of MapLayer objects.
Class | Mapping | Encapsulates properties associated with mapping. These properties are used only when using a map chart: (Chart.Type = ChartType.Map).
Class | Projection | Represents a Projection type used for projected rendering of maps.
Class | Shape | Represents a shape within a MapLayer. Shapes are automatically generated using shapefiles.
Class | ShapeCollection | Contains a collection of Shape objects.
Enumerations
 | Enumeration | Description
Enumeration | ProjectionType | Defines a type of projection used for rendering maps.
See Also

Reference

dotnetCHARTING Assembly


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : Group Class
Group Class
Represents a single or multiple conditions that are used to group shapes within a map layer. This object is used with MapLayer.Groups.
Object Model
Group ClassGroupConditionCollection ClassShape ClassLabel Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Group
'Usage

Dim instance As Group
public class Group
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.Group

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING.Mapping Namespace : Group Class
Group Class Members

The following tables list the members exposed by Group.

Public Constructors
 | Name | Description
Public Constructor | Group Constructor | Overloaded.
Top
Public Properties
 | Name | Description
Public Property | Conditions | Gets a collection of conditions that shapes within this group must meet.
Public Property | DefaultShape | Gets or sets a shape object that holds the default settings for shapes in this group.
Public Property | Label | Gets or sets a single dotnetCHARTING.Label object used for this entire group of shapes.
Public Property | Name | Gets or sets the name of this group.
Top
See Also

Reference

Group Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Group Class : Group Constructor
Group Constructor
Overload List
Overload | Description
Group Constructor(String) | Initializes a new instance of the Group object with the specified name.
Group Constructor(String,String) | Initializes a new instance of the Group object with a specified condition.
Group Constructor() | Initializes a new instance of the Group object.
Group Constructor(Label) | Initializes a new instance of the Group object with a specified label.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Group Class > Group Constructor : Group Constructor(String)
Name of this group
Group Constructor(String)
Initializes a new instance of the Group object with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal groupName As String _
)
'Usage

Dim groupName As String

Dim instance As New Group(groupName)
public Group(
   string groupName
)

Parameters

groupName
Name of this group
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members
Overload List


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Group Class > Group Constructor : Group Constructor(String,String)
Attribute to compare
Value that must me matched.
Group Constructor(String,String)
Initializes a new instance of the Group object with a specified condition.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal attribute As String, _
   ByVal attributeValue As String _
)
'Usage

Dim attribute As String
Dim attributeValue As String

Dim instance As New Group(attribute, attributeValue)
public Group(
   string attribute,
   string attributeValue
)

Parameters

attribute
Attribute to compare
attributeValue
Value that must me matched.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members
Overload List


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Group Class > Group Constructor : Group Constructor()
Group Constructor()
Initializes a new instance of the Group object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Group()
public Group()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members
Overload List


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Group Class > Group Constructor : Group Constructor(Label)
Group Constructor(Label)
Initializes a new instance of the Group object with a specified label.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal label As Label _
)
'Usage

Dim label As Label

Dim instance As New Group(label)
public Group(
   Label label
)

Parameters

label
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : Group Class
Group Class Properties

For a list of all members of this type, see Group members.

Public Properties
 | Name | Description
Public Property | Conditions | Gets a collection of conditions that shapes within this group must meet.
Public Property | DefaultShape | Gets or sets a shape object that holds the default settings for shapes in this group.
Public Property | Label | Gets or sets a single dotnetCHARTING.Label object used for this entire group of shapes.
Public Property | Name | Gets or sets the name of this group.
Top
See Also

Reference

Group Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Group Class : Conditions Property
Conditions Property
Gets a collection of conditions that shapes within this group must meet.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Conditions As GroupConditionCollection
'Usage

Dim instance As Group
Dim value As GroupConditionCollection

value = instance.Conditions
public GroupConditionCollection Conditions {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


dotnetCHARTING.Mapping Namespace > Group Class : DefaultShape Property
DefaultShape Property (Group)
Gets or sets a shape object that holds the default settings for shapes in this group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultShape As Shape
'Usage

Dim instance As Group
Dim value As Shape

instance.DefaultShape = value

value = instance.DefaultShape
public Shape DefaultShape {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


dotnetCHARTING.Mapping Namespace > Group Class : Label Property
Label Property (Group)
Gets or sets a single dotnetCHARTING.Label object used for this entire group of shapes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As Group
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


dotnetCHARTING.Mapping Namespace > Group Class : Name Property
Name Property (Group)
Gets or sets the name of this group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Name As String
'Usage

Dim instance As Group
Dim value As String

instance.Name = value

value = instance.Name
public string Name {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Group Class
Group Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : GroupCollection Class
GroupCollection Class
Contains a collection of Group objects.
Object Model
GroupCollection ClassGroup Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GroupCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As GroupCollection
public class GroupCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.Mapping.GroupCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : GroupCollection Class
GroupCollection Class Members

The following tables list the members exposed by GroupCollection.

Public Constructors
 | Name | Description
Public Constructor | GroupCollection Constructor | Creates a new instance of GropuCollection with the specified list of Group objects.
Top
Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the object with the specified name.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified GroupCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Determines whether this collection contains a Group with the specified name.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified Group in this collection.
Public Method | Insert | Inserts a Group into this collection at a specified index.
Public Method | Remove | Overloaded. Removes a specified Group from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

GroupCollection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > GroupCollection Class : GroupCollection Constructor
GroupCollection Constructor
Creates a new instance of GropuCollection with the specified list of Group objects.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New( _
   ByVal ParamArray groupList() As Group _
)
'Usage

Dim groupList() As Group

Dim instance As New GroupCollection(groupList)
public GroupCollection(
   params Group[] groupList
)

Parameters

groupList
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : GroupCollection Class
GroupCollection Class Methods

For a list of all members of this type, see GroupCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified GroupCollection to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Overloaded. Determines whether this collection contains a Group with the specified name.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified Group in this collection.
Public Method | Insert | Inserts a Group into this collection at a specified index.
Public Method | Remove | Overloaded. Removes a specified Group from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

GroupCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > GroupCollection Class : Add Method
Add Method (GroupCollection)
Adds a specified GroupCollection to this collection.
Overload List
Overload | Description
Add(Group) |
Add(GroupCollection) | Adds a specified GroupCollection to this collection.
Add(Group[]) | Adds the specified Group objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Add Method : Add(Group) Method
Add(Group) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal group As Group _
) As Integer
'Usage

Dim instance As GroupCollection
Dim group As Group
Dim value As Integer

value = instance.Add(group)
public int Add(
   Group group
)

Parameters

group
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Add Method : Add(GroupCollection) Method
The GropuCollection to add.
Add(GroupCollection) Method
Adds a specified GroupCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal groupCollection As GroupCollection _
)
'Usage

Dim instance As GroupCollection
Dim groupCollection As GroupCollection

instance.Add(groupCollection)
public void Add(
   GroupCollection groupCollection
)

Parameters

groupCollection
The GropuCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Add Method : Add(Group[]) Method
A list of Group objects to add.
Add(Group[]) Method
Adds the specified Group objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray groupList() As Group _
)
'Usage

Dim instance As GroupCollection
Dim groupList() As Group

instance.Add(groupList)
public void Add(
   params Group[] groupList
)

Parameters

groupList
A list of Group objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class : Contains Method
Contains Method (GroupCollection)
Determines whether this collection contains a Group with the specified name.
Overload List
Overload | Description
Contains(String) | Determines whether this collection contains a Group with the specified name.
Contains(Group) | Determines whether this collection contains a specified Group.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Contains Method : Contains(String) Method
Name of the Group to find.
Contains(String) Method
Determines whether this collection contains a Group with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal groupName As String _
) As Boolean
'Usage

Dim instance As GroupCollection
Dim groupName As String
Dim value As Boolean

value = instance.Contains(groupName)
public bool Contains(
   string groupName
)

Parameters

groupName
Name of the Group to find.

Return Value

true if the specified Group belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Contains Method : Contains(Group) Method
The Group to find.
Contains(Group) Method
Determines whether this collection contains a specified Group.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Contains( _
   ByVal group As Group _
) As Boolean
'Usage

Dim instance As GroupCollection
Dim group As Group
Dim value As Boolean

value = instance.Contains(group)
public bool Contains(
   Group group
)

Parameters

group
The Group to find.

Return Value

true if the specified Group belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class : IndexOf Method
The Group to find.
IndexOf Method (GroupCollection)
Determines index of a specified Group in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal group As Group _
) As Integer
'Usage

Dim instance As GroupCollection
Dim group As Group
Dim value As Integer

value = instance.IndexOf(group)
public int IndexOf(
   Group group
)

Parameters

group
The Group to find.

Return Value

The zero-based index of the specified Group.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class : Insert Method
The zero-based index into the collection at which to insert the Group.
The Group to insert into this collection.
Insert Method (GroupCollection)
Inserts a Group into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal group As Group _
)
'Usage

Dim instance As GroupCollection
Dim index As Integer
Dim group As Group

instance.Insert(index, group)
public void Insert(
   int index,
   Group group
)

Parameters

index
The zero-based index into the collection at which to insert the Group.
group
The Group to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class : Remove Method
Remove Method (GroupCollection)
Removes a specified Group from this collection.
Overload List
Overload | Description
Remove(Group) | Removes a specified Group from this collection.
Remove(String) | Removes a Group with the specified name from this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Remove Method : Remove(Group) Method
The Group to remove.
Remove(Group) Method
Removes a specified Group from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal group As Group _
)
'Usage

Dim instance As GroupCollection
Dim group As Group

instance.Remove(group)
public void Remove(
   Group group
)

Parameters

group
The Group to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Remove Method : Remove(String) Method
Remove(String) Method
Removes a Group with the specified name from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Remove( _
   ByVal groupName As String _
)
'Usage

Dim instance As GroupCollection
Dim groupName As String

instance.Remove(groupName)
public void Remove(
   string groupName
)

Parameters

groupName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : GroupCollection Class
GroupCollection Class Properties

For a list of all members of this type, see GroupCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Overloaded. Gets or sets the object with the specified name.
Top
See Also

Reference

GroupCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > GroupCollection Class : Item Property
Item Property (GroupCollection)
Gets or sets the object with the specified name.
Overload List
Overload | Description
Item(String) | Gets or sets the object with the specified name.
Item(Int32) | Gets or sets the object at a specified index.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Item Property : Item(String) Property
Item(String) Property
Gets or sets the object with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal groupName As String _
) As Group
'Usage

Dim instance As GroupCollection
Dim groupName As String
Dim value As Group

value = instance.Item(groupName)
public Group Item(
   string groupName
) {get;}

Parameters

groupName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > GroupCollection Class > Item Property : Item(Int32) Property
Item(Int32) Property
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Property Item( _
   ByVal index As Integer _
) As Group
'Usage

Dim instance As GroupCollection
Dim index As Integer
Dim value As Group

instance.Item(index) = value

value = instance.Item(index)
public Group Item(
   int index
) {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupCollection Class
GroupCollection Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : GroupConditionCollection Class
GroupConditionCollection Class
Contains a collection of conditions.
Object Model
GroupConditionCollection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class GroupConditionCollection
   Inherits System.Collections.DictionaryBase
'Usage

Dim instance As GroupConditionCollection
public class GroupConditionCollection : System.Collections.DictionaryBase
Inheritance Hierarchy

System.Object
System.Collections.DictionaryBase
dotnetCHARTING.Mapping.GroupConditionCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupConditionCollection Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : GroupConditionCollection Class
GroupConditionCollection Class Members

The following tables list the members exposed by GroupConditionCollection.

Public Constructors
 | Name | Description
Public Constructor | GroupConditionCollection Constructor | Initializes a new instance of the GroupConditionCollection object.
Top
Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Top
Public Methods
 | Name | Description
Public Method | Add | Adds a condition to this collection.
Public Method | Clear | Clears the contents of the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Public Method | CopyTo | Copies the System.Collections.DictionaryBase elements to a one-dimensional System.Array at the specified index. (Inherited from System.Collections.DictionaryBase)
Public Method | GetEnumerator | Returns an System.Collections.IDictionaryEnumerator that iterates through the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Top
See Also

Reference

GroupConditionCollection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > GroupConditionCollection Class : GroupConditionCollection Constructor
GroupConditionCollection Constructor
Initializes a new instance of the GroupConditionCollection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New GroupConditionCollection()
public GroupConditionCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupConditionCollection Class
GroupConditionCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : GroupConditionCollection Class
GroupConditionCollection Class Methods

For a list of all members of this type, see GroupConditionCollection members.

Public Methods
 | Name | Description
Public Method | Add | Adds a condition to this collection.
Public Method | Clear | Clears the contents of the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Public Method | CopyTo | Copies the System.Collections.DictionaryBase elements to a one-dimensional System.Array at the specified index. (Inherited from System.Collections.DictionaryBase)
Public Method | GetEnumerator | Returns an System.Collections.IDictionaryEnumerator that iterates through the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Top
See Also

Reference

GroupConditionCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > GroupConditionCollection Class : Add Method
Name of the attribute.
Value the attribute must have in order to meet this condition.
Add Method (GroupConditionCollection)
Adds a condition to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal shapeParam As String, _
   ByVal paramValue As String _
)
'Usage

Dim instance As GroupConditionCollection
Dim shapeParam As String
Dim paramValue As String

instance.Add(shapeParam, paramValue)
public void Add(
   string shapeParam,
   string paramValue
)

Parameters

shapeParam
Name of the attribute.
paramValue
Value the attribute must have in order to meet this condition.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

GroupConditionCollection Class
GroupConditionCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : MapDataEngine Class
MapDataEngine Class
Acquires a MapLayer from a file.
Object Model
MapDataEngine Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapDataEngine
'Usage

Dim instance As MapDataEngine
public class MapDataEngine
Remarks
Supported file types include ShapeFile (.shp) Ecw File (.ecw).
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.MapDataEngine

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataEngine Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Methods

dotnetCHARTING.Mapping Namespace : MapDataEngine Class
MapDataEngine Class Members

The following tables list the members exposed by MapDataEngine.

Public Constructors
 | Name | Description
Public Constructor | MapDataEngine Constructor |
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadLayer | Overloaded. Extracts data into a MapLayer from the specified file.
Top
See Also

Reference

MapDataEngine Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > MapDataEngine Class : MapDataEngine Constructor
MapDataEngine Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New MapDataEngine()
public MapDataEngine()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataEngine Class
MapDataEngine Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : MapDataEngine Class
MapDataEngine Class Methods

For a list of all members of this type, see MapDataEngine members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | LoadLayer | Overloaded. Extracts data into a MapLayer from the specified file.
Top
See Also

Reference

MapDataEngine Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > MapDataEngine Class : LoadLayer Method
LoadLayer Method
Extracts data into a MapLayer from the specified file.
Overload List
Overload | Description
LoadLayer(String) | Extracts data into a MapLayer from the specified file.
LoadLayer(String,String) | Extracts map data from the specified ecw file into a MapLayer and caches the generated image. Caching ecw files is recommended when used with projections.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataEngine Class
MapDataEngine Members


dotnetCHARTING.Mapping Namespace > MapDataEngine Class > LoadLayer Method : LoadLayer(String) Method
Filename of the file used to populate the MapLayer.
LoadLayer(String) Method
Extracts data into a MapLayer from the specified file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LoadLayer( _
   ByVal fileName As String _
) As MapLayer
'Usage

Dim fileName As String
Dim value As MapLayer

value = MapDataEngine.LoadLayer(fileName)
public static MapLayer LoadLayer(
   string fileName
)

Parameters

fileName
Filename of the file used to populate the MapLayer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataEngine Class
MapDataEngine Members
Overload List


dotnetCHARTING.Mapping Namespace > MapDataEngine Class > LoadLayer Method : LoadLayer(String,String) Method
Path and file name of the ecw file.
Path and file name of the cached jpg file.
LoadLayer(String,String) Method
Extracts map data from the specified ecw file into a MapLayer and caches the generated image. Caching ecw files is recommended when used with projections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Shared Function LoadLayer( _
   ByVal fileName As String, _
   ByVal cFileName As String _
) As MapLayer
'Usage

Dim fileName As String
Dim cFileName As String
Dim value As MapLayer

value = MapDataEngine.LoadLayer(fileName, cFileName)
public static MapLayer LoadLayer(
   string fileName,
   string cFileName
)

Parameters

fileName
Path and file name of the ecw file.
cFileName
Path and file name of the cached jpg file.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapDataEngine Class
MapDataEngine Members
Overload List


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : MapLayer Class
MapLayer Class
Represents a layer on the map. Either an ecw file (.ecw) image, or a shape file (.shp) collection of shapes including data the shape file contains.
Object Model
MapLayer ClassShape ClassGroupCollection ClassGroup ClassShapeCollection ClassShape Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapLayer
'Usage

Dim instance As MapLayer
public class MapLayer
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.MapLayer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : MapLayer Class
MapLayer Class Members

The following tables list the members exposed by MapLayer.

Public Constructors
 | Name | Description
Public Constructor | MapLayer Constructor | Initializes a new instance of the MapLayer object.
Top
Public Properties
 | Name | Description
Public Property | AttributeNames | Gets a string array of attribute names associated with the loaded shape file.
Public Property | DefaultShape | Gets or sets a Shape object that specifies the default properties of all subsequent shapes in this MapLayer.
Public Property | Groups | Gets a GroupCollection object which holds Group objects used to modify similar shapes automatically.
Public Property | LabelOnce | Gets or sets a boolean value that indicates whether single shapes with multiple parts are labeled only once. An example is a multiple island country which would use only one label provided this property is set to true, otherwise each island may be labeled.
Public Property | Palette | Gets or sets an array of colors that defines the colors that will be used by the shapes of this MapLayer.
Public Property | PaletteName | Gets or sets a Palette enumeration that indicates which static palette will be used by the shapes of this MapLayer.
Public Property | Shapes | Gets a collection of Shape objects generated by the source shape file (.shp).
Public Property | SourceFileName | Gets or sets the name of the file used to populate this MapLayer.
Top
Public Methods
 | Name | Description
Public Method | AddLatLongLine |
Public Method | AddLatLongPoint | Overloaded. Adds a point to this map layer.
Public Method | AddLine |
Public Method | AddPoint | Overloaded.
Public Method | ImportData | Imports and merges a DataTable with this MapLayer.
Top
See Also

Reference

MapLayer Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > MapLayer Class : MapLayer Constructor
MapLayer Constructor
Initializes a new instance of the MapLayer object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New MapLayer()
public MapLayer()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : MapLayer Class
MapLayer Class Methods

For a list of all members of this type, see MapLayer members.

Public Methods
 | Name | Description
Public Method | AddLatLongLine |
Public Method | AddLatLongPoint | Overloaded. Adds a point to this map layer.
Public Method | AddLine |
Public Method | AddPoint | Overloaded.
Public Method | ImportData | Imports and merges a DataTable with this MapLayer.
Top
See Also

Reference

MapLayer Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > MapLayer Class : AddLatLongLine Method
First coordinate in Latitude, Longitude format.
Second coordinate in Latitude, Longitude format.
The line style used to draw this line.
AddLatLongLine Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddLatLongLine( _
   ByVal p1 As PointF, _
   ByVal p2 As PointF, _
   ByVal line As Line _
)
'Usage

Dim instance As MapLayer
Dim p1 As PointF
Dim p2 As PointF
Dim line As Line

instance.AddLatLongLine(p1, p2, line)
public void AddLatLongLine(
   PointF p1,
   PointF p2,
   Line line
)

Parameters

p1
First coordinate in Latitude, Longitude format.
p2
Second coordinate in Latitude, Longitude format.
line
The line style used to draw this line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : AddLatLongPoint Method
AddLatLongPoint Method
Adds a point to this map layer.
Overload List
Overload | Description
AddLatLongPoint(PointF,ElementMarker) | Adds a point to this map layer.
AddLatLongPoint(PointF,ElementMarker,Hotspot,Annotation) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class > AddLatLongPoint Method : AddLatLongPoint(PointF,ElementMarker) Method
The coordinates in Latitude, Longitude format.
A marker drawn in place of this point.
AddLatLongPoint(PointF,ElementMarker) Method
Adds a point to this map layer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLatLongPoint( _
   ByVal p As PointF, _
   ByVal marker As ElementMarker _
)
'Usage

Dim instance As MapLayer
Dim p As PointF
Dim marker As ElementMarker

instance.AddLatLongPoint(p, marker)
public void AddLatLongPoint(
   PointF p,
   ElementMarker marker
)

Parameters

p
The coordinates in Latitude, Longitude format.
marker
A marker drawn in place of this point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayer Class > AddLatLongPoint Method : AddLatLongPoint(PointF,ElementMarker,Hotspot,Annotation) Method
A PointF in the form of (latitude,longitude)
A marker drawn in place of this point. If null, a default marker is drawn.
The hotspot info like URL and tooltip for this point. Use null if no hotspot is needed.
An annotation for this point. Use null if no annotation is needed.
AddLatLongPoint(PointF,ElementMarker,Hotspot,Annotation) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddLatLongPoint( _
   ByVal p As PointF, _
   ByVal marker As ElementMarker, _
   ByVal hotspot As Hotspot, _
   ByVal annotation As Annotation _
)
'Usage

Dim instance As MapLayer
Dim p As PointF
Dim marker As ElementMarker
Dim hotspot As Hotspot
Dim annotation As Annotation

instance.AddLatLongPoint(p, marker, hotspot, annotation)
public void AddLatLongPoint(
   PointF p,
   ElementMarker marker,
   Hotspot hotspot,
   Annotation annotation
)

Parameters

p
A PointF in the form of (latitude,longitude)
marker
A marker drawn in place of this point. If null, a default marker is drawn.
hotspot
The hotspot info like URL and tooltip for this point. Use null if no hotspot is needed.
annotation
An annotation for this point. Use null if no annotation is needed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayer Class : AddLine Method
First coordinate in Longitude, Latitude format.
Second coordinate in Longitude, Latitude format.
The line style used to draw this line.
AddLine Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub AddLine( _
   ByVal p1 As PointF, _
   ByVal p2 As PointF, _
   ByVal line As Line _
)
'Usage

Dim instance As MapLayer
Dim p1 As PointF
Dim p2 As PointF
Dim line As Line

instance.AddLine(p1, p2, line)
public void AddLine(
   PointF p1,
   PointF p2,
   Line line
)

Parameters

p1
First coordinate in Longitude, Latitude format.
p2
Second coordinate in Longitude, Latitude format.
line
The line style used to draw this line.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : AddPoint Method
AddPoint Method
Overload List
Overload | Description
AddPoint(PointF,ElementMarker) |
AddPoint(PointF,ElementMarker,Hotspot,Annotation) |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class > AddPoint Method : AddPoint(PointF,ElementMarker) Method
The coordinates in Longitude, Latitude format.
A marker drawn in place of this point.
AddPoint(PointF,ElementMarker) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddPoint( _
   ByVal p As PointF, _
   ByVal marker As ElementMarker _
)
'Usage

Dim instance As MapLayer
Dim p As PointF
Dim marker As ElementMarker

instance.AddPoint(p, marker)
public void AddPoint(
   PointF p,
   ElementMarker marker
)

Parameters

p
The coordinates in Longitude, Latitude format.
marker
A marker drawn in place of this point.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayer Class > AddPoint Method : AddPoint(PointF,ElementMarker,Hotspot,Annotation) Method
The coordinates in Longitude, Latitude format.
A marker drawn in place of this point.
The hotspot info like URL and tooltip for this point. Use null if no hotspot is needed.
An annotation for this point. Use null if no annotation is needed.
AddPoint(PointF,ElementMarker,Hotspot,Annotation) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub AddPoint( _
   ByVal p As PointF, _
   ByVal marker As ElementMarker, _
   ByVal hotspot As Hotspot, _
   ByVal annotation As Annotation _
)
'Usage

Dim instance As MapLayer
Dim p As PointF
Dim marker As ElementMarker
Dim hotspot As Hotspot
Dim annotation As Annotation

instance.AddPoint(p, marker, hotspot, annotation)
public void AddPoint(
   PointF p,
   ElementMarker marker,
   Hotspot hotspot,
   Annotation annotation
)

Parameters

p
The coordinates in Longitude, Latitude format.
marker
A marker drawn in place of this point.
hotspot
The hotspot info like URL and tooltip for this point. Use null if no hotspot is needed.
annotation
An annotation for this point. Use null if no annotation is needed.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayer Class : ImportData Method
ImportData Method
Imports and merges a DataTable with this MapLayer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub ImportData( _
   ByVal extTable As DataTable, _
   ByVal nativeField As String, _
   ByVal extField As String _
)
'Usage

Dim instance As MapLayer
Dim extTable As DataTable
Dim nativeField As String
Dim extField As String

instance.ImportData(extTable, nativeField, extField)
public void ImportData(
   DataTable extTable,
   string nativeField,
   string extField
)

Parameters

extTable
nativeField
extField
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : MapLayer Class
MapLayer Class Properties

For a list of all members of this type, see MapLayer members.

Public Properties
 | Name | Description
Public Property | AttributeNames | Gets a string array of attribute names associated with the loaded shape file.
Public Property | DefaultShape | Gets or sets a Shape object that specifies the default properties of all subsequent shapes in this MapLayer.
Public Property | Groups | Gets a GroupCollection object which holds Group objects used to modify similar shapes automatically.
Public Property | LabelOnce | Gets or sets a boolean value that indicates whether single shapes with multiple parts are labeled only once. An example is a multiple island country which would use only one label provided this property is set to true, otherwise each island may be labeled.
Public Property | Palette | Gets or sets an array of colors that defines the colors that will be used by the shapes of this MapLayer.
Public Property | PaletteName | Gets or sets a Palette enumeration that indicates which static palette will be used by the shapes of this MapLayer.
Public Property | Shapes | Gets a collection of Shape objects generated by the source shape file (.shp).
Public Property | SourceFileName | Gets or sets the name of the file used to populate this MapLayer.
Top
See Also

Reference

MapLayer Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > MapLayer Class : AttributeNames Property
AttributeNames Property
Gets a string array of attribute names associated with the loaded shape file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property AttributeNames As String()
'Usage

Dim instance As MapLayer
Dim value() As String

value = instance.AttributeNames
public string[] AttributeNames {get;}
Remarks
When ImportData() is used, the newly added columns will be in this array.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : DefaultShape Property
DefaultShape Property (MapLayer)
Gets or sets a Shape object that specifies the default properties of all subsequent shapes in this MapLayer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultShape As Shape
'Usage

Dim instance As MapLayer
Dim value As Shape

instance.DefaultShape = value

value = instance.DefaultShape
public Shape DefaultShape {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : Groups Property
Groups Property
Gets a GroupCollection object which holds Group objects used to modify similar shapes automatically.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Groups As GroupCollection
'Usage

Dim instance As MapLayer
Dim value As GroupCollection

value = instance.Groups
public GroupCollection Groups {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : LabelOnce Property
LabelOnce Property
Gets or sets a boolean value that indicates whether single shapes with multiple parts are labeled only once. An example is a multiple island country which would use only one label provided this property is set to true, otherwise each island may be labeled.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LabelOnce As Boolean
'Usage

Dim instance As MapLayer
Dim value As Boolean

instance.LabelOnce = value

value = instance.LabelOnce
public bool LabelOnce {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : Palette Property
Palette Property (MapLayer)
Gets or sets an array of colors that defines the colors that will be used by the shapes of this MapLayer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Palette As Color()
'Usage

Dim instance As MapLayer
Dim value() As Color

instance.Palette = value

value = instance.Palette
public Color[] Palette {get; set;}
Remarks
When setting this property, each shape will get it's own color. Whereas by default, all shapes within a mapLayer take their color from MapLayer.DefaultShape.Background.Color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : PaletteName Property
PaletteName Property (MapLayer)
Gets or sets a Palette enumeration that indicates which static palette will be used by the shapes of this MapLayer.

Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PaletteName As Palette
'Usage

Dim instance As MapLayer
Dim value As Palette

instance.PaletteName = value

value = instance.PaletteName
public Palette PaletteName {get; set;}
Remarks
When setting this property, each shape will get it's own color. Whereas by default, all shapes within a mapLayer take their color from MapLayer.DefaultShape.Background.Color.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : Shapes Property
Shapes Property
Gets a collection of Shape objects generated by the source shape file (.shp).
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property Shapes As ShapeCollection
'Usage

Dim instance As MapLayer
Dim value As ShapeCollection

value = instance.Shapes
public ShapeCollection Shapes {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


dotnetCHARTING.Mapping Namespace > MapLayer Class : SourceFileName Property
SourceFileName Property
Gets or sets the name of the file used to populate this MapLayer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SourceFileName As String
'Usage

Dim instance As MapLayer
Dim value As String

instance.SourceFileName = value

value = instance.SourceFileName
public string SourceFileName {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : MapLayerCollection Class
MapLayerCollection Class
Contains a collection of MapLayer objects.
Object Model
MapLayerCollection ClassMapLayer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class MapLayerCollection
   Inherits System.Collections.CollectionBase
'Usage

Dim instance As MapLayerCollection
public class MapLayerCollection : System.Collections.CollectionBase
Inheritance Hierarchy

System.Object
System.Collections.CollectionBase
dotnetCHARTING.Mapping.MapLayerCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : MapLayerCollection Class
MapLayerCollection Class Members

The following tables list the members exposed by MapLayerCollection.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified MapLayer class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified MapLayer.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified MapLayer in this collection.
Public Method | Insert | Inserts a MapLayer into this collection at a specified index.
Public Method | Remove | Removes a specified MapLayer from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MapLayerCollection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : MapLayerCollection Class
MapLayerCollection Class Methods

For a list of all members of this type, see MapLayerCollection members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified MapLayer class to this collection.
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified MapLayer.
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines index of a specified MapLayer in this collection.
Public Method | Insert | Inserts a MapLayer into this collection at a specified index.
Public Method | Remove | Removes a specified MapLayer from this collection.
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

MapLayerCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : Add Method
Add Method (MapLayerCollection)
Adds a specified MapLayer class to this collection.
Overload List
Overload | Description
Add(String) | Adds a specified MapLayer class to this collection.
Add(MapLayer) |
Add(MapLayerCollection) | Adds a specified LayerCollection to this collection.
Add(MapLayer[]) | Adds the specified MapLayer objects to this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class > Add Method : Add(String) Method
Name of the file containing the map data to add.
Add(String) Method
Adds a specified MapLayer class to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal fileName As String _
) As MapLayer
'Usage

Dim instance As MapLayerCollection
Dim fileName As String
Dim value As MapLayer

value = instance.Add(fileName)
public MapLayer Add(
   string fileName
)

Parameters

fileName
Name of the file containing the map data to add.

Return Value

The zero-based index of the added MapLayer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class > Add Method : Add(MapLayer) Method
Add(MapLayer) Method
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function Add( _
   ByVal mapLayer As MapLayer _
) As Integer
'Usage

Dim instance As MapLayerCollection
Dim mapLayer As MapLayer
Dim value As Integer

value = instance.Add(mapLayer)
public int Add(
   MapLayer mapLayer
)

Parameters

mapLayer
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class > Add Method : Add(MapLayerCollection) Method
The LayerCollection to add.
Add(MapLayerCollection) Method
Adds a specified LayerCollection to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal mapLayerCollection As MapLayerCollection _
)
'Usage

Dim instance As MapLayerCollection
Dim mapLayerCollection As MapLayerCollection

instance.Add(mapLayerCollection)
public void Add(
   MapLayerCollection mapLayerCollection
)

Parameters

mapLayerCollection
The LayerCollection to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class > Add Method : Add(MapLayer[]) Method
A list of MapLayer objects to add.
Add(MapLayer[]) Method
Adds the specified MapLayer objects to this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Sub Add( _
   ByVal ParamArray mapLayerList() As MapLayer _
)
'Usage

Dim instance As MapLayerCollection
Dim mapLayerList() As MapLayer

instance.Add(mapLayerList)
public void Add(
   params MapLayer[] mapLayerList
)

Parameters

mapLayerList
A list of MapLayer objects to add.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members
Overload List


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : Contains Method
The MapLayer to find.
Contains Method (MapLayerCollection)
Determines whether this collection contains a specified MapLayer.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function Contains( _
   ByVal mapLayer As MapLayer _
) As Boolean
'Usage

Dim instance As MapLayerCollection
Dim mapLayer As MapLayer
Dim value As Boolean

value = instance.Contains(mapLayer)
public bool Contains(
   MapLayer mapLayer
)

Parameters

mapLayer
The MapLayer to find.

Return Value

true if the specified MapLayer belongs to this collection; otherwise, false.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : IndexOf Method
The MapLayer to find.
IndexOf Method (MapLayerCollection)
Determines index of a specified MapLayer in this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function IndexOf( _
   ByVal mapLayer As MapLayer _
) As Integer
'Usage

Dim instance As MapLayerCollection
Dim mapLayer As MapLayer
Dim value As Integer

value = instance.IndexOf(mapLayer)
public int IndexOf(
   MapLayer mapLayer
)

Parameters

mapLayer
The MapLayer to find.

Return Value

The zero-based index of the specified MapLayer.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : Insert Method
The zero-based index into the collection at which to insert the MapLayer.
The MapLayer to insert into this collection.
Insert Method (MapLayerCollection)
Inserts a MapLayer into this collection at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Insert( _
   ByVal index As Integer, _
   ByVal mapLayer As MapLayer _
)
'Usage

Dim instance As MapLayerCollection
Dim index As Integer
Dim mapLayer As MapLayer

instance.Insert(index, mapLayer)
public void Insert(
   int index,
   MapLayer mapLayer
)

Parameters

index
The zero-based index into the collection at which to insert the MapLayer.
mapLayer
The MapLayer to insert into this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : Remove Method
The MapLayer to remove.
Remove Method (MapLayerCollection)
Removes a specified MapLayer from this collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Remove( _
   ByVal mapLayer As MapLayer _
)
'Usage

Dim instance As MapLayerCollection
Dim mapLayer As MapLayer

instance.Remove(mapLayer)
public void Remove(
   MapLayer mapLayer
)

Parameters

mapLayer
The MapLayer to remove.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : MapLayerCollection Class
MapLayerCollection Class Properties

For a list of all members of this type, see MapLayerCollection members.

Public Properties
 | Name | Description
Public Property | Capacity | Gets or sets the number of elements that the System.Collections.CollectionBase can contain. (Inherited from System.Collections.CollectionBase)
Public Property | Count | Gets the number of elements contained in the System.Collections.CollectionBase instance. This property cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Property | Item | Gets or sets the object at a specified index.
Top
See Also

Reference

MapLayerCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > MapLayerCollection Class : Item Property
Item Property (MapLayerCollection)
Gets or sets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Default Property Item( _
   ByVal index As Integer _
) As MapLayer
'Usage

Dim instance As MapLayerCollection
Dim index As Integer
Dim value As MapLayer

instance.Item(index) = value

value = instance.Item(index)
public MapLayer this[
   int index
]; {get; set;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayerCollection Class
MapLayerCollection Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : Mapping Class
Mapping Class
Encapsulates properties associated with mapping. These properties are used only when using a map chart: (Chart.Type = ChartType.Map).
Object Model
Mapping ClassChartArea ClassShape ClassMapLayerCollection ClassMapLayer ClassProjection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Mapping
'Usage

Dim instance As Mapping
public class Mapping
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.Mapping

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : Mapping Class
Mapping Class Members

The following tables list the members exposed by Mapping.

Public Constructors
 | Name | Description
Public Constructor | Mapping Constructor | Initializes a new instance of the Mapping class.
Top
Public Properties
 | Name | Description
Public Property | ChartArea | Gets or sets the chart area on which the map is drawn. It accesses the same chart area instance as Chart.ChartArea
Public Property | DefaultShape | Gets or sets a shape object that contains default properties for all shapes on this map.
Public Property | MapLayerCollection | Gets a collection of MapLayer objects used to render the map.
Public Property | Projection | Gets or sets an advanced projection the map rendering will be based on. This includes either LambertConicProjection() or MercatorProjection() methods.
Public Property | ZoomCenterPoint | Gets or sets a point that anchors the map to center when used with ZoomPercentage.
Public Property | ZoomPercentage | Gets or sets a percent value that indicates the new zoomed size of the map.
Top
Public Methods
 | Name | Description
Public Method | GetLatLongCoordinates | Overloaded. Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Public Method | GetShapesAtPoint | Overloaded. Gets an arraylist of shapes beneath the specified pixel coorinates.
Top
See Also

Reference

Mapping Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Mapping Class : Mapping Constructor
Mapping Constructor
Initializes a new instance of the Mapping class.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Mapping()
public Mapping()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : Mapping Class
Mapping Class Methods

For a list of all members of this type, see Mapping members.

Public Methods
 | Name | Description
Public Method | GetLatLongCoordinates | Overloaded. Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Public Method | GetShapesAtPoint | Overloaded. Gets an arraylist of shapes beneath the specified pixel coorinates.
Top
See Also

Reference

Mapping Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Mapping Class : GetLatLongCoordinates Method
GetLatLongCoordinates Method
Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Overload List
Overload | Description
GetLatLongCoordinates(String) | Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
GetLatLongCoordinates(Point) | Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class > GetLatLongCoordinates Method : GetLatLongCoordinates(String) Method
Pixel coordinates in the form of: "x,y".
GetLatLongCoordinates(String) Method
Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetLatLongCoordinates( _
   ByVal pixelCoordinate As String _
) As PointF
'Usage

Dim instance As Mapping
Dim pixelCoordinate As String
Dim value As PointF

value = instance.GetLatLongCoordinates(pixelCoordinate)
public PointF GetLatLongCoordinates(
   string pixelCoordinate
)

Parameters

pixelCoordinate
Pixel coordinates in the form of: "x,y".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members
Overload List


dotnetCHARTING.Mapping Namespace > Mapping Class > GetLatLongCoordinates Method : GetLatLongCoordinates(Point) Method
Pixel position to convert.
GetLatLongCoordinates(Point) Method
Computes the Latitude, Longitude coordinates based on the specified pixel coordinates of the chart image.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetLatLongCoordinates( _
   ByVal pixelCoordinate As Point _
) As PointF
'Usage

Dim instance As Mapping
Dim pixelCoordinate As Point
Dim value As PointF

value = instance.GetLatLongCoordinates(pixelCoordinate)
public PointF GetLatLongCoordinates(
   Point pixelCoordinate
)

Parameters

pixelCoordinate
Pixel position to convert.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members
Overload List


dotnetCHARTING.Mapping Namespace > Mapping Class : GetShapesAtPoint Method
GetShapesAtPoint Method
Gets an arraylist of shapes beneath the specified pixel coorinates.
Overload List
Overload | Description
GetShapesAtPoint(Point) | Gets an arraylist of shapes beneath the specified pixel coorinates.
GetShapesAtPoint(String) | Gets an arraylist of shapes beneath the specified pixel coorinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class > GetShapesAtPoint Method : GetShapesAtPoint(Point) Method
Pixel coordinates.
GetShapesAtPoint(Point) Method
Gets an arraylist of shapes beneath the specified pixel coorinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetShapesAtPoint( _
   ByVal p As Point _
) As ArrayList
'Usage

Dim instance As Mapping
Dim p As Point
Dim value As ArrayList

value = instance.GetShapesAtPoint(p)
public ArrayList GetShapesAtPoint(
   Point p
)

Parameters

p
Pixel coordinates.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members
Overload List


dotnetCHARTING.Mapping Namespace > Mapping Class > GetShapesAtPoint Method : GetShapesAtPoint(String) Method
Pixel coordinates in the form of: "x,y".
GetShapesAtPoint(String) Method
Gets an arraylist of shapes beneath the specified pixel coorinates.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads Function GetShapesAtPoint( _
   ByVal pixelCoordinate As String _
) As ArrayList
'Usage

Dim instance As Mapping
Dim pixelCoordinate As String
Dim value As ArrayList

value = instance.GetShapesAtPoint(pixelCoordinate)
public ArrayList GetShapesAtPoint(
   string pixelCoordinate
)

Parameters

pixelCoordinate
Pixel coordinates in the form of: "x,y".
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members
Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : Mapping Class
Mapping Class Properties

For a list of all members of this type, see Mapping members.

Public Properties
 | Name | Description
Public Property | ChartArea | Gets or sets the chart area on which the map is drawn. It accesses the same chart area instance as Chart.ChartArea
Public Property | DefaultShape | Gets or sets a shape object that contains default properties for all shapes on this map.
Public Property | MapLayerCollection | Gets a collection of MapLayer objects used to render the map.
Public Property | Projection | Gets or sets an advanced projection the map rendering will be based on. This includes either LambertConicProjection() or MercatorProjection() methods.
Public Property | ZoomCenterPoint | Gets or sets a point that anchors the map to center when used with ZoomPercentage.
Public Property | ZoomPercentage | Gets or sets a percent value that indicates the new zoomed size of the map.
Top
See Also

Reference

Mapping Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Mapping Class : ChartArea Property
ChartArea Property (Mapping)
Gets or sets the chart area on which the map is drawn. It accesses the same chart area instance as Chart.ChartArea
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ChartArea As ChartArea
'Usage

Dim instance As Mapping
Dim value As ChartArea

instance.ChartArea = value

value = instance.ChartArea
public ChartArea ChartArea {get; set;}
Remarks
This property is equivalent to Chart.ChartArea
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class : DefaultShape Property
DefaultShape Property (Mapping)
Gets or sets a shape object that contains default properties for all shapes on this map.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DefaultShape As Shape
'Usage

Dim instance As Mapping
Dim value As Shape

instance.DefaultShape = value

value = instance.DefaultShape
public Shape DefaultShape {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class : MapLayerCollection Property
MapLayerCollection Property
Gets a collection of MapLayer objects used to render the map.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property MapLayerCollection As MapLayerCollection
'Usage

Dim instance As Mapping
Dim value As MapLayerCollection

value = instance.MapLayerCollection
public MapLayerCollection MapLayerCollection {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class : Projection Property
Projection Property
Gets or sets an advanced projection the map rendering will be based on. This includes either LambertConicProjection() or MercatorProjection() methods.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Projection As Projection
'Usage

Dim instance As Mapping
Dim value As Projection

instance.Projection = value

value = instance.Projection
public Projection Projection {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class : ZoomCenterPoint Property
ZoomCenterPoint Property
Gets or sets a point that anchors the map to center when used with ZoomPercentage.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZoomCenterPoint As PointF
'Usage

Dim instance As Mapping
Dim value As PointF

instance.ZoomCenterPoint = value

value = instance.ZoomCenterPoint
public PointF ZoomCenterPoint {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


dotnetCHARTING.Mapping Namespace > Mapping Class : ZoomPercentage Property
ZoomPercentage Property
Gets or sets a percent value that indicates the new zoomed size of the map.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ZoomPercentage As Integer
'Usage

Dim instance As Mapping
Dim value As Integer

instance.ZoomPercentage = value

value = instance.ZoomPercentage
public int ZoomPercentage {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : Projection Class
Projection Class
Represents a Projection type used for projected rendering of maps.
Object Model
Projection Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Projection
'Usage

Dim instance As Projection
public class Projection
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.Projection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties

dotnetCHARTING.Mapping Namespace : Projection Class
Projection Class Members

The following tables list the members exposed by Projection.

Public Constructors
 | Name | Description
Public Constructor | Projection Constructor | Initializes a new instance of the Projection object.
Top
Public Properties
 | Name | Description
Public Property | Parameters | Gets or sets the projection parameters as a comma delimited string.
Public Property | Type | Gets or sets the projection type.
Top
See Also

Reference

Projection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Projection Class : Projection Constructor
Projection Constructor
Initializes a new instance of the Projection object.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New Projection()
public Projection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : Projection Class
Projection Class Properties

For a list of all members of this type, see Projection members.

Public Properties
 | Name | Description
Public Property | Parameters | Gets or sets the projection parameters as a comma delimited string.
Public Property | Type | Gets or sets the projection type.
Top
See Also

Reference

Projection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Projection Class : Parameters Property
Parameters Property
Gets or sets the projection parameters as a comma delimited string.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Parameters As String
'Usage

Dim instance As Projection
Dim value As String

instance.Parameters = value

value = instance.Parameters
public string Parameters {get; set;}
Remarks

The following table defines the projection parameters based on the specific projection type.

Projection Type | Parameters | Example
Mercator | Latitude in degrees | "-50"
Lambert Conic | Azimuthal coordinate on the surface of a sphere, The latitude (projection latitude) in degrees, The projection standard first parallel in degrees, The projection standard second parallel in degrees. | "-96, 38, 32, 42"
Unprojected | N/A | ""

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


dotnetCHARTING.Mapping Namespace > Projection Class : Type Property
Type Property (Projection)
Gets or sets the projection type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ProjectionType
'Usage

Dim instance As Projection
Dim value As ProjectionType

instance.Type = value

value = instance.Type
public ProjectionType Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Projection Class
Projection Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : Shape Class
Shape Class
Represents a shape within a MapLayer. Shapes are automatically generated using shapefiles.
Object Model
Shape ClassAnnotation ClassBackground ClassHotspot ClassLabel ClassLegendEntry ClassLine ClassElementMarker Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class Shape
'Usage

Dim instance As Shape
public class Shape
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.Shape

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : Shape Class
Shape Class Members

The following tables list the members exposed by Shape.

Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets an annotation for this shape.
Public Property | Background | Gets or sets the dotnetCHARTING.Background object for this shape.
Public Property | Hotspot | Gets or sets the Hotspot of this shape.
Public Property | Item | Overloaded. Gets a shape file attribute with the specified name.
Public Property | Label | Gets or sets the dotnetCHARTING.Label for this shape.
Public Property | LegendEntry | Gets or sets the LegendEntry of this Shape.
Public Property | Line | Gets or sets the dotnetCHARTING.Line object used to outline this shape.
Public Property | Marker | Gets or sets the Marker object drawn on this shape.
Public Property | Type |
Top
Public Methods
 | Name | Description
Public Method | GetBounds | Gets the bounding box for this shape.
Top
See Also

Reference

Shape Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : Shape Class
Shape Class Methods

For a list of all members of this type, see Shape members.

Public Methods
 | Name | Description
Public Method | GetBounds | Gets the bounding box for this shape.
Top
See Also

Reference

Shape Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Shape Class : GetBounds Method
GetBounds Method
Gets the bounding box for this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetBounds() As RectangleF
'Usage

Dim instance As Shape
Dim value As RectangleF

value = instance.GetBounds()
public RectangleF GetBounds()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : Shape Class
Shape Class Properties

For a list of all members of this type, see Shape members.

Public Properties
 | Name | Description
Public Property | Annotation | Gets or sets an annotation for this shape.
Public Property | Background | Gets or sets the dotnetCHARTING.Background object for this shape.
Public Property | Hotspot | Gets or sets the Hotspot of this shape.
Public Property | Item | Overloaded. Gets a shape file attribute with the specified name.
Public Property | Label | Gets or sets the dotnetCHARTING.Label for this shape.
Public Property | LegendEntry | Gets or sets the LegendEntry of this Shape.
Public Property | Line | Gets or sets the dotnetCHARTING.Line object used to outline this shape.
Public Property | Marker | Gets or sets the Marker object drawn on this shape.
Public Property | Type |
Top
See Also

Reference

Shape Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > Shape Class : Annotation Property
Annotation Property (Shape)
Gets or sets an annotation for this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Annotation As Annotation
'Usage

Dim instance As Shape
Dim value As Annotation

instance.Annotation = value

value = instance.Annotation
public Annotation Annotation {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Background Property
Background Property (Shape)
Gets or sets the dotnetCHARTING.Background object for this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Background As Background
'Usage

Dim instance As Shape
Dim value As Background

instance.Background = value

value = instance.Background
public Background Background {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Hotspot Property
Hotspot Property (Shape)
Gets or sets the Hotspot of this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Hotspot As Hotspot
'Usage

Dim instance As Shape
Dim value As Hotspot

instance.Hotspot = value

value = instance.Hotspot
public Hotspot Hotspot {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Item Property
Item Property (Shape)
Gets a shape file attribute with the specified name.
Overload List
Overload | Description
Item(String) | Gets a shape file attribute with the specified name.
Item(Int32) | Gets a shape file attribute at the specified index.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class > Item Property : Item(String) Property
Item(String) Property
Gets a shape file attribute with the specified name.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal name As String _
) As Object
'Usage

Dim instance As Shape
Dim name As String
Dim value As Object

value = instance.Item(name)
public object Item(
   string name
) {get;}

Parameters

name
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members
Overload List


dotnetCHARTING.Mapping Namespace > Shape Class > Item Property : Item(Int32) Property
Item(Int32) Property
Gets a shape file attribute at the specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Overloads ReadOnly Property Item( _
   ByVal index As Integer _
) As Object
'Usage

Dim instance As Shape
Dim index As Integer
Dim value As Object

value = instance.Item(index)
public object Item(
   int index
) {get;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members
Overload List


dotnetCHARTING.Mapping Namespace > Shape Class : Label Property
Label Property (Shape)
Gets or sets the dotnetCHARTING.Label for this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Label As Label
'Usage

Dim instance As Shape
Dim value As Label

instance.Label = value

value = instance.Label
public Label Label {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : LegendEntry Property
LegendEntry Property (Shape)
Gets or sets the LegendEntry of this Shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LegendEntry As LegendEntry
'Usage

Dim instance As Shape
Dim value As LegendEntry

instance.LegendEntry = value

value = instance.LegendEntry
public LegendEntry LegendEntry {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Line Property
Line Property (Shape)
Gets or sets the dotnetCHARTING.Line object used to outline this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Line As Line
'Usage

Dim instance As Shape
Dim value As Line

instance.Line = value

value = instance.Line
public Line Line {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Marker Property
Marker Property (Shape)
Gets or sets the Marker object drawn on this shape.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Marker As ElementMarker
'Usage

Dim instance As Shape
Dim value As ElementMarker

instance.Marker = value

value = instance.Marker
public ElementMarker Marker {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


dotnetCHARTING.Mapping Namespace > Shape Class : Type Property
Type Property (Shape)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Type As ShapeTypes
'Usage

Dim instance As Shape
Dim value As ShapeTypes

instance.Type = value

value = instance.Type
public ShapeTypes Type {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Shape Class
Shape Members


%%PageItemTitle%%

Members

dotnetCHARTING.Mapping Namespace : ShapeCollection Class
ShapeCollection Class
Contains a collection of Shape objects.
Object Model
ShapeCollection ClassShape Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ShapeCollection
'Usage

Dim instance As ShapeCollection
public class ShapeCollection
Inheritance Hierarchy

System.Object
dotnetCHARTING.Mapping.ShapeCollection

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Members
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Mapping Namespace : ShapeCollection Class
ShapeCollection Class Members

The following tables list the members exposed by ShapeCollection.

Public Constructors
 | Name | Description
Public Constructor | ShapeCollection Constructor | Initializes a new instance of ShapeCollection
Top
Public Properties
 | Name | Description
Public Property | Item | Gets the object at a specified index.
Top
Public Methods
 | Name | Description
Public Method | Add |
Public Method | GetEnumerator | Returns an IEnumerator for the collection.
Top
See Also

Reference

ShapeCollection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > ShapeCollection Class : ShapeCollection Constructor
ShapeCollection Constructor
Initializes a new instance of ShapeCollection
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ShapeCollection()
public ShapeCollection()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Class
ShapeCollection Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Mapping Namespace : ShapeCollection Class
ShapeCollection Class Methods

For a list of all members of this type, see ShapeCollection members.

Public Methods
 | Name | Description
Public Method | Add |
Public Method | GetEnumerator | Returns an IEnumerator for the collection.
Top
See Also

Reference

ShapeCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > ShapeCollection Class : Add Method
Add Method (ShapeCollection)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub Add( _
   ByVal shape As Shape _
)
'Usage

Dim instance As ShapeCollection
Dim shape As Shape

instance.Add(shape)
public void Add(
   Shape shape
)

Parameters

shape
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Class
ShapeCollection Members


dotnetCHARTING.Mapping Namespace > ShapeCollection Class : GetEnumerator Method
GetEnumerator Method
Returns an IEnumerator for the collection.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetEnumerator() As IEnumerator
'Usage

Dim instance As ShapeCollection
Dim value As IEnumerator

value = instance.GetEnumerator()
public IEnumerator GetEnumerator()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Class
ShapeCollection Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : ShapeCollection Class
ShapeCollection Class Properties

For a list of all members of this type, see ShapeCollection members.

Public Properties
 | Name | Description
Public Property | Item | Gets the object at a specified index.
Top
See Also

Reference

ShapeCollection Class
dotnetCHARTING.Mapping Namespace


dotnetCHARTING.Mapping Namespace > ShapeCollection Class : Item Property
Item Property (ShapeCollection)
Gets the object at a specified index.
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Default Property Item( _
   ByVal index As Integer _
) As Shape
'Usage

Dim instance As ShapeCollection
Dim index As Integer
Dim value As Shape

value = instance.Item(index)
public Shape this[
   int index
]; {get;}

Parameters

index
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Class
ShapeCollection Members


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace : ProjectionType Enumeration
ProjectionType Enumeration
Defines a type of projection used for rendering maps.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ProjectionType
   Inherits System.Enum
'Usage

Dim instance As ProjectionType
public enum ProjectionType : System.Enum
Members
Member | Description
LambertConic | Specified the Lambert Conic projection type.
Mercator | Specified the Mercator projection type.
Unprojected | Specifies an unprojected map view.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Mapping.ProjectionType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING.Mapping Namespace


Inheritance Hierarchy
dotnetCHARTING.Zoomer Namespace
Classes
 | Class | Description
Class | ChartControl |
Class | ClientScriptProxy | This is a proxy object for the Page.ClientScript and MS Ajax ScriptManager object that can operate when MS Ajax is not present. Because MS Ajax may not be available accessing the methods directly is not possible and we are required to indirectly reference client script methods through this class. This class should be invoked at the Control's start up and be used to replace all calls Page.ClientScript. Scriptmanager calls are made through Reflection
Class | ImageZoomer | Provides AJAX zooming and scrolling feature settings.
Delegates
 | Delegate | Description
Delegate | ReloadChartHandler |
Enumerations
 | Enumeration | Description
Enumeration | AxisToZoom | Specifies the axes to zoom.
Enumeration | ScrollType | Specifies the scrolling type.
Enumeration | SelectionStyle | Specifies the selection style.
See Also

Reference

dotnetCHARTING Assembly


%%PageItemTitle%%

Members

dotnetCHARTING.Zoomer Namespace : ChartControl Class
ChartControl Class
Object Model
ChartControl ClassAnnotationCollection ClassAnnotation ClassAxisCollection ClassAxis ClassBackground ClassAnnotation ClassChartArea ClassChartAreaLayout ClassAxis ClassBox ClassChartArea ClassElement ClassLegendBox ClassSeries ClassShadow ClassBox ClassChartAreaCollection ClassChartArea ClassLegendBoxCollection ClassLegendBox ClassFileManager ClassHotspot ClassJsOptions ClassLegendBox ClassMapping ClassNavigatorOptions ClassLabel ClassSeries ClassSeriesCollection ClassSeries ClassTimeIntervalAdvanced ClassSmartPalette ClassBox ClassView3D ClassAxis ClassAxis ClassAxis ClassImageZoomer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ChartControl
   Inherits dotnetCHARTING.Chart
'Usage

Dim instance As ChartControl
public class ChartControl : dotnetCHARTING.Chart
Inheritance Hierarchy

System.Object
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart
dotnetCHARTING.Zoomer.ChartControl

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Members
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Members$$

Properties Methods Events

dotnetCHARTING.Zoomer Namespace : ChartControl Class
ChartControl Class Members

The following tables list the members exposed by ChartControl.

Public Constructors
 | Name | Description
Public Constructor | ChartControl Constructor |
Top
Public Properties
Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature. (Inherited from dotnetCHARTING.Chart)
Public Property | Annotations | A collection of dotnetCHARTING.Annotation objects drawn on the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided. (Inherited from dotnetCHARTING.Chart)
Public Property | AxisCollection | Contains a collection of calculated Axis objects. (Inherited from dotnetCHARTING.Chart)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Background | Gets or sets the dotnetCHARTING.Background of this chart. (Inherited from dotnetCHARTING.Chart)
Public Property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from System.Web.UI.Control)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Box

Gets or sets an Annotation object that is drawn as the background for this chart.

(Inherited from dotnetCHARTING.Chart)
Public Property | BubbleCenterStack | Gets or sets a boolean value to control bubble center stack. (Inherited from dotnetCHARTING.Chart)
Public Property | BubbleStackShadeAsOne | Gets or sets a boolean value to control bubble stack shade. (Inherited from dotnetCHARTING.Chart)
Public Property | CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated. (Inherited from dotnetCHARTING.Chart)
Public Property | CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartArea | Gets or sets the main dotnetCHARTING.Chart.ChartArea of the image. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartAreaLayout | Gets or sets chart area layout options. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends. (Inherited from dotnetCHARTING.Chart)
Public Property | CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the dotnetCHARTING.Chart.TempDirectory before they are deleted. (Inherited from dotnetCHARTING.Chart)
Public Property | CleanupPeriod | Gets or sets the number of minutes images are stored in the dotnetCHARTING.Chart.TempDirectory folder before they are deleted. (Inherited from dotnetCHARTING.Chart)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area. (Inherited from dotnetCHARTING.Chart)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGrid | Gets or sets the control object or ID of a datagrid control that will be populated with the charted data. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the dotnetCHARTING.Chart.DataGrid property. (Inherited from dotnetCHARTING.Chart)
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

(Inherited from dotnetCHARTING.Chart)
Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the dotnetCHARTING.Chart.DataGrid property. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified dotnetCHARTING.Chart.DataGrid control is populated will be transposed. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGrouping | Gets or sets a dotnetCHARTING.TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided. (Inherited from dotnetCHARTING.Chart)
Public Property | Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultAxis | Gets or sets an dotnetCHARTING.Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultChartArea | Gets a dotnetCHARTING.ChartArea object whose property settings will propagate to all other dotnetCHARTING.ChartArea objects on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultCultureName | Gets or sets the default culture name which determines number and date formatting. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultElement | Gets or sets an dotnetCHARTING.Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property. (Inherited from dotnetCHARTING.Chart)
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.dotnetCHARTING.Chart.DefaultAxis.FormatString. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultLegendBox | Gets a dotnetCHARTING.LegendBox object whose property settings will propagate to all other dotnetCHARTING.LegendBox objects on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultSeries | Gets or sets a dotnetCHARTING.Series object whose properties will trickle to all other series on the chart unless otherwise specified. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultTitleBox | Gets a dotnetCHARTING.Box object whose property settings will propagate to all title boxes on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | Depth | Gets or sets depth of the chart when dotnetCHARTING.Chart.Use3D is true. (Inherited from dotnetCHARTING.Chart)
Public Property | DisableBrowserCache | Gets or sets a value indicating whether disable browser cache. (Inherited from dotnetCHARTING.Chart)
Public Property | DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used. (Inherited from dotnetCHARTING.Chart)
Public Property | Dpi | Gets or sets the resolution, in dots per inch, of the chart Bitmap. (Inherited from dotnetCHARTING.Chart)
Public Property DrillDownChain

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

(Inherited from dotnetCHARTING.Chart)
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series. (Inherited from dotnetCHARTING.Chart)
Public Property | EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel (Inherited from dotnetCHARTING.Chart)
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut. (Inherited from dotnetCHARTING.Chart)
Public Property | ExtraChartAreas | Gets a collection of additional dotnetCHARTING.ChartArea objects added to the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | ExtraLegendBoxes | Gets a collection of additional dotnetCHARTING.LegendBox objects added to the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | FileManager | Gets or sets the chart's instance of the dotnetCHARTING.FileManager which facilitates saving images. (Inherited from dotnetCHARTING.Chart)
Public Property | FileName | See Chart.FileManager.FileName. (Inherited from dotnetCHARTING.Chart)
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality) (Inherited from dotnetCHARTING.Chart)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FunnelNozzlePercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel height that comprises the funnel's nozzle. (Inherited from dotnetCHARTING.Chart)
Public Property | FunnelNozzleWidthPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel width that comprises the funnel's nozzle. (Inherited from dotnetCHARTING.Chart)
Public Property | FunnelSpacingPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the funnel's spacing. (Inherited from dotnetCHARTING.Chart)
Public Property | GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's dotnetCHARTING.Element.Complete value is set. (Inherited from dotnetCHARTING.Chart)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property. (Inherited from dotnetCHARTING.Chart)
Public Property | HatchStylePaletteName | Gets or sets a predefined dotnetCHARTING.HatchStylePalette that defines element and series hatch style. (Inherited from dotnetCHARTING.Chart)
Public Property | Height | Gets or sets the height of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | Hotspot | Gets or sets the dotnetCHARTING.Hotspot property of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | HotspotMinimumSize | Gets or sets a value that indicates the minimum size in pixels a hotspot must be in order for it to be generated. (Inherited from dotnetCHARTING.Chart)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageFormat | Gets or sets an dotnetCHARTING.ImageFormat enumeration specifying the generated image's file type. (Inherited from dotnetCHARTING.Chart)
Public Property | ImageMapName | Returns a string for the image map name generated for the current chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | ImageMapText | Returns a string for the image map generated for the current chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | JS | Provides JavaScript chart functionality. (Inherited from dotnetCHARTING.Chart)
Public Property | LegacyMode | Gets or sets a value that indicates whether original chart defaults are used instead of new defaults introduced with version 10. (Inherited from dotnetCHARTING.Chart)
Public Property | LegendBox | Gets or sets a LegendBox object that represents the legend box. (Inherited from dotnetCHARTING.Chart)
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | Mapping | This property is used only when using a map chart: (Chart.Type = ChartType.Map). (Inherited from dotnetCHARTING.Chart)
Public Property | Margin | Gets or sets a string which automatically sets multiple margins as a shortcut. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginBottom | Gets or sets the bottom margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginLeft | Gets or sets the left margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginRight | Gets or sets the right margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginTop | Gets or sets the top margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used. (Inherited from dotnetCHARTING.Chart)
Public Property | MaximumBubbleSizeValue | Gets or sets the maximum value the bubble size will be based on where a bubble size value of MaximumBubbleSizeValue equals a bubble of size MaximumBubbleSize. (Inherited from dotnetCHARTING.Chart)
Public Property | Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true. (Inherited from dotnetCHARTING.Chart)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Navigator | Provides SliverLight functionality. (Inherited from dotnetCHARTING.Chart)
Public Property | NoDataLabel | Gets or sets a label shown on the chart when no data is available. (Inherited from dotnetCHARTING.Chart)
Public Property | ObjectChart | Gets or sets an object that will be drawn instead of the chart and will dynamically resize the chart image to fit the object's size. The supported objects are Label and Annotation. (Inherited from dotnetCHARTING.Chart)
Public Property | OrganizationalConnectorType | (JS Chart Only) Specifies the connector type (straight or right-angle) for organizatioal charts. (Inherited from dotnetCHARTING.Chart)
Public Property | OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up. (Inherited from dotnetCHARTING.Chart)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Palette | Gets or sets an array of colors that define element and series colors. (Inherited from dotnetCHARTING.Chart)
Public Property | PaletteName | Gets or sets a predefined dotnetCHARTING.Palette that defines element and series colors. (Inherited from dotnetCHARTING.Chart)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode. (Inherited from dotnetCHARTING.Chart)
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues. (Inherited from dotnetCHARTING.Chart)
Public Property | PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing. (Inherited from dotnetCHARTING.Chart)
Public Property | RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode. (Inherited from dotnetCHARTING.Chart)
Public Property | ReloadPeriod | Gets or sets a System.TimeSpan object that determines how often the page containing this chart will automatically reload. (Inherited from dotnetCHARTING.Chart)
Public Property | Series | Gets or sets a series which is added to the chart's main dotnetCHARTING.Chart.SeriesCollection when the Chart.SeriesCollection.Add() method is invoked. (Inherited from dotnetCHARTING.Chart)
Public Property | SeriesCollection | Gets a dotnetCHARTING.SeriesCollection object which represents the data this chart will render. (Inherited from dotnetCHARTING.Chart)
Public Property | ShadingEffectMode | Gets or sets a dotnetCHARTING.Chart.ShadingEffectMode enumeration indicating how elements on the chart are shaded. (Inherited from dotnetCHARTING.Chart)
Public Property | ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title. The formatting of the shown dates can be controlled with Chart.DefaultCultureName. (Inherited from dotnetCHARTING.Chart)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | Size | Sets a string that automatically sets the dotnetCHARTING.Chart.Height and dotnetCHARTING.Chart.Width of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmallChartMode | Gets or sets a value that indicates whether this chart uses the SmallChartMode. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartForecast | Gets or sets a TimeIntervalAdvanced object that specifies a time span shown on the chart. The span shown is an interval which encompasses the time the chart is rendered. A trend line is also added for the entire span shown and uses values not shown in it's calculation to improve accuracy. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization. (Inherited from dotnetCHARTING.Chart)
Public Property | SpacingPercentage | Gets or sets the spacing percentage of pyramids, cones, and funnels with ChartType.Multiple . (Inherited from dotnetCHARTING.Chart)
Public Property | SpacingPercentageNested | Gets or sets a value that indicates the spacing percentage of nested pies. (Inherited from dotnetCHARTING.Chart)
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used. (Inherited from dotnetCHARTING.Chart)
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when dotnetCHARTING.Chart.DateGrouping is used. (Inherited from dotnetCHARTING.Chart)
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SubValueDateGrouping | Gets or sets a dotnetCHARTING.TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database. (Inherited from dotnetCHARTING.Chart)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored. (Inherited from dotnetCHARTING.Chart)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text. (Inherited from dotnetCHARTING.Chart)
Public Property | TitleBox | Gets or sets a dotnetCHARTING.Chart.Box object that represents the title box. (Inherited from dotnetCHARTING.Chart)
Public Property | ToolTip | Gets or sets the Tooltip of the entinre chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit. (Inherited from dotnetCHARTING.Chart)
Public Property | Transpose | Gets or sets a value indicating whether data added to this chart's dotnetCHARTING.Chart.SeriesCollection property is automatically transposed. (Inherited from dotnetCHARTING.Chart)
Public Property | Type | Gets or sets the dotnetCHARTING.ChartType of this dotnetCHARTING.Chart. (Inherited from dotnetCHARTING.Chart)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | URL | Gets or sets the URL of the entinre chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | URLTarget | Gets or sets the target of the dotnetCHARTING.Chart.URL link. (Inherited from dotnetCHARTING.Chart)
Public Property | Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D. (Inherited from dotnetCHARTING.Chart)
Public Property | UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the dotnetCHARTING.Chart.TempDirectory folder or streamed directly to the browser. (Inherited from dotnetCHARTING.Chart)
Public Property UseSession

Gets or sets a value indicating whether the generated image is saved
temporarily in a session variable for subsequent streaming from a helper aspx page. This option may only be used when UseFile = false.

(Inherited from dotnetCHARTING.Chart)
Public Property | View3D | Gets or sets the View3D class that contains properties to control the rendering of 3D surface charts. (Inherited from dotnetCHARTING.Chart)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property XAxis

Gets or Sets the main XAxis which all series inherit by default.

(Inherited from dotnetCHARTING.Chart)
Public Property YAxis

Gets or Sets the main YAxis which all series inherit by default.

(Inherited from dotnetCHARTING.Chart)
Public Property ZAxis

Gets or Sets the main ZAxis which all series inherit by default. The ZAxis is used with surface charts.

(Inherited from dotnetCHARTING.Chart)
Public Property | Zoomer
Top
Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetChartBitmap | Obtains a System.Drawing.Bitmap of the generated chart. (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartJS | Returns a string contains the Javascript chart configuration. (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed). (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartStream | Returns the memory stream of the image. (Inherited from dotnetCHARTING.Chart)
Public Method | GetLegendBitmap | Obtains a System.Drawing.Bitmap of the legend generated by the chart. (Inherited from dotnetCHARTING.Chart)
Public Method | GetLegendMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed). (Inherited from dotnetCHARTING.Chart)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | HitTest | (Inherited from dotnetCHARTING.Chart)
Public Method | LoadState | Overloaded. Imports a chart object from the specified xml file. (Inherited from dotnetCHARTING.Chart)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | PaletteAdd | Overloaded. Adds the colors of a predefined palette to the existing palette colors stored in dotnetCHARTING.Chart.Palette. (Inherited from dotnetCHARTING.Chart)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Outputs chart server control content to a provided HtmlTextWriter object. (Inherited from dotnetCHARTING.Chart)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SaveState | Overloaded. Saves this chart instance to an xml file. (Inherited from dotnetCHARTING.Chart)
Public Method | SaveStateJSON | Overloaded. (Inherited from dotnetCHARTING.Chart)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | ErrorProcessing | (Inherited from dotnetCHARTING.Chart)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PostDataProcessing | Occurs when the the chart is completed the data processing. (Inherited from dotnetCHARTING.Chart)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ChartControl Class
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%%

dotnetCHARTING.Zoomer Namespace > ChartControl Class : ChartControl Constructor
ChartControl Constructor
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function New()
'Usage

Dim instance As New ChartControl()
public ChartControl()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Zoomer Namespace : ChartControl Class
ChartControl Class Properties

For a list of all members of this type, see ChartControl members.

Public Properties
Name | Description
Public Property | AccessKey | Gets or sets the access key that allows you to quickly navigate to the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AlternateText | Gets or sets text displayed in place of a chart when images can't be viewed. This property can also be used as a tooltip for the chart in browsers that support this feature. (Inherited from dotnetCHARTING.Chart)
Public Property | Annotations | A collection of dotnetCHARTING.Annotation objects drawn on the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl object that contains this control. (Inherited from System.Web.UI.Control)
Public Property | Attributes | Gets the collection of arbitrary attributes (for rendering only) that do not correspond to properties on the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | AutoNameLabels | Gets or sets a value which indicates whether elements and series are automatically named when no names are provided. (Inherited from dotnetCHARTING.Chart)
Public Property | AxisCollection | Contains a collection of calculated Axis objects. (Inherited from dotnetCHARTING.Chart)
Public Property | BackColor | Gets or sets the background color of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | Background | Gets or sets the dotnetCHARTING.Background of this chart. (Inherited from dotnetCHARTING.Chart)
Public Property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from System.Web.UI.Control)
Public Property | BorderColor | Gets or sets the border color of the Web control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderStyle | Gets or sets the border style of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | BorderWidth | Gets or sets the border width of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property Box

Gets or sets an Annotation object that is drawn as the background for this chart.

(Inherited from dotnetCHARTING.Chart)
Public Property | BubbleCenterStack | Gets or sets a boolean value to control bubble center stack. (Inherited from dotnetCHARTING.Chart)
Public Property | BubbleStackShadeAsOne | Gets or sets a boolean value to control bubble stack shade. (Inherited from dotnetCHARTING.Chart)
Public Property | CacheDuration | Gets or sets the number of minutes an image is cached and displayed on a page before a new one is generated. (Inherited from dotnetCHARTING.Chart)
Public Property | CalculateEmptyElement | Gets or sets a value indicating whether the values of empty elements are percieved as 0 or omitted in calculations performed with the Chart.SeriesCollection.Add(Calculation calc) shortcut. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartArea | Gets or sets the main dotnetCHARTING.Chart.ChartArea of the image. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartAreaLayout | Gets or sets chart area layout options. (Inherited from dotnetCHARTING.Chart)
Public Property | ChartAreaSpacing | Gets or sets a value in pixels that defines the spacing between boxes like chart areas and legends. (Inherited from dotnetCHARTING.Chart)
Public Property | CleanupMinimumAge | Gets or sets the minimum number of minutes images are stored in the dotnetCHARTING.Chart.TempDirectory before they are deleted. (Inherited from dotnetCHARTING.Chart)
Public Property | CleanupPeriod | Gets or sets the number of minutes images are stored in the dotnetCHARTING.Chart.TempDirectory folder before they are deleted. (Inherited from dotnetCHARTING.Chart)
Public Property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from System.Web.UI.Control)
Public Property | ClipGauges | Gets or sets a value which determines if gauges should be clipped (cut) to display only the active area. (Inherited from dotnetCHARTING.Chart)
Public Property | Controls | Gets a System.Web.UI.ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from System.Web.UI.Control)
Public Property | ControlStyle | Gets the style of the Web server control. This property is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ControlStyleCreated | Gets a value indicating whether a System.Web.UI.WebControls.Style object has been created for the System.Web.UI.WebControls.WebControl.ControlStyle property. This property is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | CssClass | Gets or sets the Cascading Style Sheet (CSS) class rendered by the Web server control on the client. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | DatabaseCultureName | Gets or sets the culture name used when StartDate and EndDate insert to the sql statement. This property only necessary to set if the web server and database server having different culture setting. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGrid | Gets or sets the control object or ID of a datagrid control that will be populated with the charted data. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGridCustomAttributes | Adds element's custom attributes to the DataGrid control specified by the dotnetCHARTING.Chart.DataGrid property. (Inherited from dotnetCHARTING.Chart)
Public Property DataGridFormatString Gets or sets the format string which determines number formatting in the datagrid.

(Inherited from dotnetCHARTING.Chart)
Public Property | DataGridSeriesHeader | Gets or sets the header label of the DataGrid control specified by the dotnetCHARTING.Chart.DataGrid property. (Inherited from dotnetCHARTING.Chart)
Public Property | DataGridTranspose | Gets or sets a value indicating whether the data with which the specified dotnetCHARTING.Chart.DataGrid control is populated will be transposed. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGrouping | Gets or sets a dotnetCHARTING.TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGroupingCalculation | Gets or sets an enum which determines how values are grouped to create a single element value. (Inherited from dotnetCHARTING.Chart)
Public Property | DateGroupingSort | Gets or sets a value indicating whether to maintain the sort order of the data as it is provided. (Inherited from dotnetCHARTING.Chart)
Public Property | Debug | Gets or sets a value that indicates whether debug messages are displayed below the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultAxis | Gets or sets an dotnetCHARTING.Axis object whose properties will trickle down to all other axes on the chart unless otherwise specified. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultBox | Gets a base box object that is used as a vehicle for property settings which will become the defaults settings of all elements on the chart that derive from box. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultChartArea | Gets a dotnetCHARTING.ChartArea object whose property settings will propagate to all other dotnetCHARTING.ChartArea objects on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultCultureName | Gets or sets the default culture name which determines number and date formatting. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultElement | Gets or sets an dotnetCHARTING.Element object whose properties will trickle to all other elements on the chart unless otherwise specified. This is a shortcut to the DefaultSeries.DefaultElement property. (Inherited from dotnetCHARTING.Chart)
Public Property DefaultFormatString Gets or sets the default format string which determines number and date formatting.

See Chart.dotnetCHARTING.Chart.DefaultAxis.FormatString. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultLegendBox | Gets a dotnetCHARTING.LegendBox object whose property settings will propagate to all other dotnetCHARTING.LegendBox objects on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultSeries | Gets or sets a dotnetCHARTING.Series object whose properties will trickle to all other series on the chart unless otherwise specified. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultShadow | Gets or sets a shadow object whose properties will trickle to all other objects with shadows. (Inherited from dotnetCHARTING.Chart)
Public Property | DefaultTitleBox | Gets a dotnetCHARTING.Box object whose property settings will propagate to all title boxes on the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | Depth | Gets or sets depth of the chart when dotnetCHARTING.Chart.Use3D is true. (Inherited from dotnetCHARTING.Chart)
Public Property | DisableBrowserCache | Gets or sets a value indicating whether disable browser cache. (Inherited from dotnetCHARTING.Chart)
Public Property | DonutHoleSize | Gets or sets a percentage value which determines the relative thickness of the donut ring when ChartType.Donut is used. (Inherited from dotnetCHARTING.Chart)
Public Property | Dpi | Gets or sets the resolution, in dots per inch, of the chart Bitmap. (Inherited from dotnetCHARTING.Chart)
Public Property DrillDownChain

Gets or sets the drill down chain which activates automatic time based drill down if date grouping used.

If Limit or SplitByLimit used with ShowOther option, setting drill down chain to "Other" or "OtherAll" activates automatic drill down to other elements or series.

"OtherAll" shows all other elements or series in the second level.
"Other" shows the next number of elements or series has been set in limit or splitByLimit propertes.

(Inherited from dotnetCHARTING.Chart)
Public Property | DrillDownIntoSeries | When using automated drill down in conjunction with date grouping and multiple series, this property determines if drill down will occur into a single series or multiple series. (Inherited from dotnetCHARTING.Chart)
Public Property | EmptyElementText | Gets or sets the default text of empty element labels. See Chart.DefaultSeries.DefaultElement.SmartLabel (Inherited from dotnetCHARTING.Chart)
Public Property | Enabled | Gets or sets a value indicating whether the Web server control is enabled. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableTheming | Gets or sets a value indicating whether themes apply to this control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | EnableViewState | Gets or sets a value indicating whether the server control persists its view state, and the view state of any child controls it contains, to the requesting client. (Inherited from System.Web.UI.Control)
Public Property | ExplodedSliceAmount | Gets or sets the relative percentage an exploded slice should be pulled out from the pie or donut. (Inherited from dotnetCHARTING.Chart)
Public Property | ExtraChartAreas | Gets a collection of additional dotnetCHARTING.ChartArea objects added to the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | ExtraLegendBoxes | Gets a collection of additional dotnetCHARTING.LegendBox objects added to the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | FileManager | Gets or sets the chart's instance of the dotnetCHARTING.FileManager which facilitates saving images. (Inherited from dotnetCHARTING.Chart)
Public Property | FileName | See Chart.FileManager.FileName. (Inherited from dotnetCHARTING.Chart)
Public Property | FileQuality | Gets or sets Jpg file quality. (Worse quality) 0 - 100 (Best quality) (Inherited from dotnetCHARTING.Chart)
Public Property | Font | Gets the font properties associated with the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | ForeColor | Gets or sets the foreground color (typically the color of the text) of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | FunnelNozzlePercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel height that comprises the funnel's nozzle. (Inherited from dotnetCHARTING.Chart)
Public Property | FunnelNozzleWidthPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the full funnel width that comprises the funnel's nozzle. (Inherited from dotnetCHARTING.Chart)
Public Property | FunnelSpacingPercentage | Gets or sets a numeric value between 0 and 100 that indicates the percentage of the funnel's spacing. (Inherited from dotnetCHARTING.Chart)
Public Property | GanttCompleteHatchStyle | Gets or sets the hatch style drawn on columns and cylinders when an element's dotnetCHARTING.Element.Complete value is set. (Inherited from dotnetCHARTING.Chart)
Public Property | HasAttributes | Gets a value indicating whether the control has attributes set. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | HatchStylePalette | Gets or sets a hatch style palette that will trickle to all series on the chart. The hatch patterns will not show on chart elements if a hatch color is not specified. The default hatch color can be specified with the Chart.DefaultSeries.DefaultElement.HatchColor property. (Inherited from dotnetCHARTING.Chart)
Public Property | HatchStylePaletteName | Gets or sets a predefined dotnetCHARTING.HatchStylePalette that defines element and series hatch style. (Inherited from dotnetCHARTING.Chart)
Public Property | Height | Gets or sets the height of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | Hotspot | Gets or sets the dotnetCHARTING.Hotspot property of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | HotspotMinimumSize | Gets or sets a value that indicates the minimum size in pixels a hotspot must be in order for it to be generated. (Inherited from dotnetCHARTING.Chart)
Public Property | ID | Gets or sets the programmatic identifier assigned to the server control. (Inherited from System.Web.UI.Control)
Public Property | ImageFormat | Gets or sets an dotnetCHARTING.ImageFormat enumeration specifying the generated image's file type. (Inherited from dotnetCHARTING.Chart)
Public Property | ImageMapName | Returns a string for the image map name generated for the current chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | ImageMapText | Returns a string for the image map generated for the current chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | JS | Provides JavaScript chart functionality. (Inherited from dotnetCHARTING.Chart)
Public Property | LegacyMode | Gets or sets a value that indicates whether original chart defaults are used instead of new defaults introduced with version 10. (Inherited from dotnetCHARTING.Chart)
Public Property | LegendBox | Gets or sets a LegendBox object that represents the legend box. (Inherited from dotnetCHARTING.Chart)
Public Property | LimitPrimarySeries | In a multiple series chart, this property controls the primary series used for the Limit operation. Other series' elements will be matched with the primary series elements and that order will be maintained regardless of the values of the other series. For example, if you limit to the top 5 values and set the LimitPrimarySeries to the sales series other series such as dollar amount or quantity would not affect which elements were ultimately selected for the chart. (Inherited from dotnetCHARTING.Chart)
Public Property | Mapping | This property is used only when using a map chart: (Chart.Type = ChartType.Map). (Inherited from dotnetCHARTING.Chart)
Public Property | Margin | Gets or sets a string which automatically sets multiple margins as a shortcut. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginBottom | Gets or sets the bottom margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginLeft | Gets or sets the left margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginRight | Gets or sets the right margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MarginTop | Gets or sets the top margin of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | MaximumBubbleSize | Gets or sets a value which controls the maximum size of bubbles when ChartType.Bubble is used. (Inherited from dotnetCHARTING.Chart)
Public Property | MaximumBubbleSizeValue | Gets or sets the maximum value the bubble size will be based on where a bubble size value of MaximumBubbleSizeValue equals a bubble of size MaximumBubbleSize. (Inherited from dotnetCHARTING.Chart)
Public Property | Mentor | Gets or sets a value that indicates whether the mentor is shown under the chart control. The mentor also requires that Chart.Debug is set to true. (Inherited from dotnetCHARTING.Chart)
Public Property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same System.Web.UI.Control.ID property value. (Inherited from System.Web.UI.Control)
Public Property | Navigator | Provides SliverLight functionality. (Inherited from dotnetCHARTING.Chart)
Public Property | NoDataLabel | Gets or sets a label shown on the chart when no data is available. (Inherited from dotnetCHARTING.Chart)
Public Property | ObjectChart | Gets or sets an object that will be drawn instead of the chart and will dynamically resize the chart image to fit the object's size. The supported objects are Label and Annotation. (Inherited from dotnetCHARTING.Chart)
Public Property | OrganizationalConnectorType | (JS Chart Only) Specifies the connector type (straight or right-angle) for organizatioal charts. (Inherited from dotnetCHARTING.Chart)
Public Property | OverlapFooter | Gets or sets a value indicating whether the 'unlicensed chart' footer overlaps the chart or moves it up. (Inherited from dotnetCHARTING.Chart)
Public Property | Page | Gets a reference to the System.Web.UI.Page instance that contains the server control. (Inherited from System.Web.UI.Control)
Public Property | Palette | Gets or sets an array of colors that define element and series colors. (Inherited from dotnetCHARTING.Chart)
Public Property | PaletteName | Gets or sets a predefined dotnetCHARTING.Palette that defines element and series colors. (Inherited from dotnetCHARTING.Chart)
Public Property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from System.Web.UI.Control)
Public Property | PieLabelMode | See DefaultSeries.DefaultElement.SmartLabel.PieLabelMode. (Inherited from dotnetCHARTING.Chart)
Public Property | PopulateDateGroupingSubValues | When using date grouping the main value in the element is derived from the actual values in the database or data provided to .netCHARTING. This property controls whether these subvalues used in the calculation to determine the element value are added to SubValues or not. By default, such values are not added to the element subvalues. (Inherited from dotnetCHARTING.Chart)
Public Property | PrinterOptimizedText | Gets or sets a value that indicates whether text rendered on the chart optimized for printing. (Inherited from dotnetCHARTING.Chart)
Public Property | RadarLabelMode | See DefaultSeries.DefaultElement.SmartLabel.RadarLabelMode. (Inherited from dotnetCHARTING.Chart)
Public Property | ReloadPeriod | Gets or sets a System.TimeSpan object that determines how often the page containing this chart will automatically reload. (Inherited from dotnetCHARTING.Chart)
Public Property | Series | Gets or sets a series which is added to the chart's main dotnetCHARTING.Chart.SeriesCollection when the Chart.SeriesCollection.Add() method is invoked. (Inherited from dotnetCHARTING.Chart)
Public Property | SeriesCollection | Gets a dotnetCHARTING.SeriesCollection object which represents the data this chart will render. (Inherited from dotnetCHARTING.Chart)
Public Property | ShadingEffectMode | Gets or sets a dotnetCHARTING.Chart.ShadingEffectMode enumeration indicating how elements on the chart are shaded. (Inherited from dotnetCHARTING.Chart)
Public Property | ShowDateInTitle | Gets or sets a value which indicates whether specified dates are shown in the title. The formatting of the shown dates can be controlled with Chart.DefaultCultureName. (Inherited from dotnetCHARTING.Chart)
Public Property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from System.Web.UI.Control)
Public Property | Size | Sets a string that automatically sets the dotnetCHARTING.Chart.Height and dotnetCHARTING.Chart.Width of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | SkinID | Gets or sets the skin to apply to the control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SmallChartMode | Gets or sets a value that indicates whether this chart uses the SmallChartMode. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartForecast | Gets or sets a TimeIntervalAdvanced object that specifies a time span shown on the chart. The span shown is an interval which encompasses the time the chart is rendered. A trend line is also added for the entire span shown and uses values not shown in it's calculation to improve accuracy. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartPalette | Gets or sets a NameColorCollection object that specifies the colors of elements and series with specific names. (Inherited from dotnetCHARTING.Chart)
Public Property | SmartPaletteAutoSync | Gets or sets a boolean which controls smart palette synchronization. (Inherited from dotnetCHARTING.Chart)
Public Property | SpacingPercentage | Gets or sets the spacing percentage of pyramids, cones, and funnels with ChartType.Multiple . (Inherited from dotnetCHARTING.Chart)
Public Property | SpacingPercentageNested | Gets or sets a value that indicates the spacing percentage of nested pies. (Inherited from dotnetCHARTING.Chart)
Public Property | StartDateOfYear | Gets or sets a DateTime object to determine the start month of the year when DateGrouping is used. (Inherited from dotnetCHARTING.Chart)
Public Property | StartDayOfWeek | Gets or sets a System.DayOfWeek enumeration that indicates the starting day of the week when dotnetCHARTING.Chart.DateGrouping is used. (Inherited from dotnetCHARTING.Chart)
Public Property | Style | Gets a collection of text attributes that will be rendered as a style attribute on the outer tag of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | SubValueDateGrouping | Gets or sets a dotnetCHARTING.TimeInterval enumeration which determines how the values of a given series are aggregated by date when retrieved from a database. (Inherited from dotnetCHARTING.Chart)
Public Property | TabIndex | Gets or sets the tab index of the Web server control. (Inherited from System.Web.UI.WebControls.WebControl)
Public Property | TempDirectory | Gets or sets the directory where images generated by the control are temporarily stored. (Inherited from dotnetCHARTING.Chart)
Public Property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from System.Web.UI.Control)
Public Property | TemplateSourceDirectory | Gets the virtual directory of the System.Web.UI.Page or System.Web.UI.UserControl that contains the current server control. (Inherited from System.Web.UI.Control)
Public Property Title Gets or sets the chart title.

Equivalent to Chart.TitleBox.Label.Text. (Inherited from dotnetCHARTING.Chart)
Public Property | TitleBox | Gets or sets a dotnetCHARTING.Chart.Box object that represents the title box. (Inherited from dotnetCHARTING.Chart)
Public Property | ToolTip | Gets or sets the Tooltip of the entinre chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | TotalSeries | Return the total number of series in the seriesCollection. This property usually used in conjunction with SplitByLimit. (Inherited from dotnetCHARTING.Chart)
Public Property | Transpose | Gets or sets a value indicating whether data added to this chart's dotnetCHARTING.Chart.SeriesCollection property is automatically transposed. (Inherited from dotnetCHARTING.Chart)
Public Property | Type | Gets or sets the dotnetCHARTING.ChartType of this dotnetCHARTING.Chart. (Inherited from dotnetCHARTING.Chart)
Public Property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from System.Web.UI.Control)
Public Property | URL | Gets or sets the URL of the entinre chart image. (Inherited from dotnetCHARTING.Chart)
Public Property | URLTarget | Gets or sets the target of the dotnetCHARTING.Chart.URL link. (Inherited from dotnetCHARTING.Chart)
Public Property | Use3D | Gets or sets a value indicating whether chart elements are rendered in 3D. (Inherited from dotnetCHARTING.Chart)
Public Property | UseFile | Gets or sets a value indicating whether the generated image is saved as a file in the dotnetCHARTING.Chart.TempDirectory folder or streamed directly to the browser. (Inherited from dotnetCHARTING.Chart)
Public Property UseSession

Gets or sets a value indicating whether the generated image is saved
temporarily in a session variable for subsequent streaming from a helper aspx page. This option may only be used when UseFile = false.

(Inherited from dotnetCHARTING.Chart)
Public Property | View3D | Gets or sets the View3D class that contains properties to control the rendering of 3D surface charts. (Inherited from dotnetCHARTING.Chart)
Public Property | Visible | Gets or sets a value that indicates whether a server control is rendered as UI on the page. (Inherited from System.Web.UI.Control)
Public Property | Width | Gets or sets the width of the chart image. (Inherited from dotnetCHARTING.Chart)
Public Property XAxis

Gets or Sets the main XAxis which all series inherit by default.

(Inherited from dotnetCHARTING.Chart)
Public Property YAxis

Gets or Sets the main YAxis which all series inherit by default.

(Inherited from dotnetCHARTING.Chart)
Public Property ZAxis

Gets or Sets the main ZAxis which all series inherit by default. The ZAxis is used with surface charts.

(Inherited from dotnetCHARTING.Chart)
Public Property | Zoomer
Top
See Also

Reference

ChartControl Class
dotnetCHARTING.Zoomer Namespace


dotnetCHARTING.Zoomer Namespace > ChartControl Class : Zoomer Property
Zoomer Property (ChartControl)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shadows Property Zoomer As ImageZoomer
'Usage

Dim instance As ChartControl
Dim value As ImageZoomer

instance.Zoomer = value

value = instance.Zoomer
public new ImageZoomer Zoomer {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartControl Class
ChartControl Members


%%PageItemTitle%%

Members

dotnetCHARTING.Zoomer Namespace : ClientScriptProxy Class
ClientScriptProxy Class
This is a proxy object for the Page.ClientScript and MS Ajax ScriptManager object that can operate when MS Ajax is not present. Because MS Ajax may not be available accessing the methods directly is not possible and we are required to indirectly reference client script methods through this class. This class should be invoked at the Control's start up and be used to replace all calls Page.ClientScript. Scriptmanager calls are made through Reflection
Object Model
ClientScriptProxy ClassClientScriptProxy Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ClientScriptProxy
'Usage

Dim instance As ClientScriptProxy
public class ClientScriptProxy
Inheritance Hierarchy

System.Object
dotnetCHARTING.Zoomer.ClientScriptProxy

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Members
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Members$$

Properties Methods

dotnetCHARTING.Zoomer Namespace : ClientScriptProxy Class
ClientScriptProxy Class Members

The following tables list the members exposed by ClientScriptProxy.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Current | Current instance of this class which should always be used to access this object. There are no public constructors to ensure the reference is used as a Singleton to further ensure that all scripts are written to the same clientscript manager.
Public Property | IsMsAjax | Determines if MsAjax is available in this Web application
Top
Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckForMsAjax | Checks to see if MS Ajax is registered with the current Web application.
Public Method | GetWebResourceUrl | Returns a WebResource URL for non script resources
Public Method | RegisterClientScriptBlock | Registers a client script block in the page.
Public Method | RegisterClientScriptInclude | Registers a script include tag into the page for an external script url
Public Method | RegisterClientScriptResource | Returns a WebResource or ScriptResource URL for script resources that are to be embedded as script includes.
Public Method | RegisterHiddenField | Injects a hidden field into the page
Public Method | RegisterStartupScript | Registers a startup code snippet that gets placed at the bottom of the page
Top
See Also

Reference

ClientScriptProxy Class
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Zoomer Namespace : ClientScriptProxy Class
ClientScriptProxy Class Methods

For a list of all members of this type, see ClientScriptProxy members.

Public Methods
 | Name | Description
static (Shared in Visual Basic) | CheckForMsAjax | Checks to see if MS Ajax is registered with the current Web application.
Public Method | GetWebResourceUrl | Returns a WebResource URL for non script resources
Public Method | RegisterClientScriptBlock | Registers a client script block in the page.
Public Method | RegisterClientScriptInclude | Registers a script include tag into the page for an external script url
Public Method | RegisterClientScriptResource | Returns a WebResource or ScriptResource URL for script resources that are to be embedded as script includes.
Public Method | RegisterHiddenField | Injects a hidden field into the page
Public Method | RegisterStartupScript | Registers a startup code snippet that gets placed at the bottom of the page
Top
See Also

Reference

ClientScriptProxy Class
dotnetCHARTING.Zoomer Namespace


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : CheckForMsAjax Method
CheckForMsAjax Method
Checks to see if MS Ajax is registered with the current Web application.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared Function CheckForMsAjax() As Boolean
'Usage

Dim value As Boolean

value = ClientScriptProxy.CheckForMsAjax()
public static bool CheckForMsAjax()
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : GetWebResourceUrl Method
GetWebResourceUrl Method
Returns a WebResource URL for non script resources
Syntax
  • Visual Basic
  • C#
'Declaration

Public Function GetWebResourceUrl( _
   ByVal control As Control, _
   ByVal type As Type, _
   ByVal resourceName As String _
) As String
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim type As Type
Dim resourceName As String
Dim value As String

value = instance.GetWebResourceUrl(control, type, resourceName)
public string GetWebResourceUrl(
   Control control,
   Type type,
   string resourceName
)

Parameters

control
type
resourceName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : RegisterClientScriptBlock Method
RegisterClientScriptBlock Method
Registers a client script block in the page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterClientScriptBlock( _
   ByVal control As Control, _
   ByVal type As Type, _
   ByVal key As String, _
   ByVal script As String, _
   ByVal addScriptTags As Boolean _
)
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim type As Type
Dim key As String
Dim script As String
Dim addScriptTags As Boolean

instance.RegisterClientScriptBlock(control, type, key, script, addScriptTags)
public void RegisterClientScriptBlock(
   Control control,
   Type type,
   string key,
   string script,
   bool addScriptTags
)

Parameters

control
type
key
script
addScriptTags
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : RegisterClientScriptInclude Method
RegisterClientScriptInclude Method
Registers a script include tag into the page for an external script url
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterClientScriptInclude( _
   ByVal control As Control, _
   ByVal type As Type, _
   ByVal key As String, _
   ByVal url As String _
)
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim type As Type
Dim key As String
Dim url As String

instance.RegisterClientScriptInclude(control, type, key, url)
public void RegisterClientScriptInclude(
   Control control,
   Type type,
   string key,
   string url
)

Parameters

control
type
key
url
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : RegisterClientScriptResource Method
RegisterClientScriptResource Method
Returns a WebResource or ScriptResource URL for script resources that are to be embedded as script includes.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterClientScriptResource( _
   ByVal control As Control, _
   ByVal type As Type, _
   ByVal resourceName As String _
)
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim type As Type
Dim resourceName As String

instance.RegisterClientScriptResource(control, type, resourceName)
public void RegisterClientScriptResource(
   Control control,
   Type type,
   string resourceName
)

Parameters

control
type
resourceName
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : RegisterHiddenField Method
RegisterHiddenField Method
Injects a hidden field into the page
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterHiddenField( _
   ByVal control As Control, _
   ByVal hiddenFieldName As String, _
   ByVal hiddenFieldInitialValue As String _
)
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim hiddenFieldName As String
Dim hiddenFieldInitialValue As String

instance.RegisterHiddenField(control, hiddenFieldName, hiddenFieldInitialValue)
public void RegisterHiddenField(
   Control control,
   string hiddenFieldName,
   string hiddenFieldInitialValue
)

Parameters

control
hiddenFieldName
hiddenFieldInitialValue
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : RegisterStartupScript Method
RegisterStartupScript Method
Registers a startup code snippet that gets placed at the bottom of the page
Syntax
  • Visual Basic
  • C#
'Declaration

Public Sub RegisterStartupScript( _
   ByVal control As Control, _
   ByVal type As Type, _
   ByVal key As String, _
   ByVal script As String, _
   ByVal addStartupTags As Boolean _
)
'Usage

Dim instance As ClientScriptProxy
Dim control As Control
Dim type As Type
Dim key As String
Dim script As String
Dim addStartupTags As Boolean

instance.RegisterStartupScript(control, type, key, script, addStartupTags)
public void RegisterStartupScript(
   Control control,
   Type type,
   string key,
   string script,
   bool addStartupTags
)

Parameters

control
type
key
script
addStartupTags
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Zoomer Namespace : ClientScriptProxy Class
ClientScriptProxy Class Properties

For a list of all members of this type, see ClientScriptProxy members.

Public Properties
 | Name | Description
static (Shared in Visual Basic) | Current | Current instance of this class which should always be used to access this object. There are no public constructors to ensure the reference is used as a Singleton to further ensure that all scripts are written to the same clientscript manager.
Public Property | IsMsAjax | Determines if MsAjax is available in this Web application
Top
See Also

Reference

ClientScriptProxy Class
dotnetCHARTING.Zoomer Namespace


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : Current Property
Current Property
Current instance of this class which should always be used to access this object. There are no public constructors to ensure the reference is used as a Singleton to further ensure that all scripts are written to the same clientscript manager.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Shared ReadOnly Property Current As ClientScriptProxy
'Usage

Dim value As ClientScriptProxy

value = ClientScriptProxy.Current
public static ClientScriptProxy Current {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


dotnetCHARTING.Zoomer Namespace > ClientScriptProxy Class : IsMsAjax Property
IsMsAjax Property
Determines if MsAjax is available in this Web application
Syntax
  • Visual Basic
  • C#
'Declaration

Public ReadOnly Property IsMsAjax As Boolean
'Usage

Dim instance As ClientScriptProxy
Dim value As Boolean

value = instance.IsMsAjax
public bool IsMsAjax {get;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ClientScriptProxy Class
ClientScriptProxy Members


%%PageItemTitle%%

Members

dotnetCHARTING.Zoomer Namespace : ImageZoomer Class
ImageZoomer Class
Provides AJAX zooming and scrolling feature settings.
Object Model
ImageZoomer Class
Syntax
  • Visual Basic
  • C#
'Declaration

Public Class ImageZoomer
'Usage

Dim instance As ImageZoomer
public class ImageZoomer
Inheritance Hierarchy

System.Object
dotnetCHARTING.Zoomer.ImageZoomer

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Members
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Members$$

Properties Events

dotnetCHARTING.Zoomer Namespace : ImageZoomer Class
ImageZoomer Class Members

The following tables list the members exposed by ImageZoomer.

Public Properties
 | Name | Description
Public Property | AjaxHandlerEnabled | Gets or sets a value that indicates whether the charts handle all ajax calls. If this boolean is true, a dedicated handler (ashx) page is used instead of the calling page.
Public Property | AspnetAjax | Controls whether the ASP.net AJAX is used or not.
Public Property | AxisToZoom | Gets or sets a value that indicates the zooming direction. Options include Both (can select any arbitrary bounding box to zoom to), XAxis (select a specific x axis region only, y axis is fixed to the maximum extent) , YAxis (select a specific y axis region only, x axis is fixed to the maximum extent)
Public Property | DragAfterZoom | Gets or sets a value that indicates whether the default operation after zooming is reset to drag. This allows the user to to drag or navigate the newly zoomed view before zooming again.
Public Property | Enabled | Gets or sets a value that indicates whether the Ajax zooming interface is activated.
Public Property | HelpButtonPosition | Controls the position of the ? icon on the chart when there is no scroll bar.
Public Property | HelpEnabled | Gets or sets a value that determines if the help button is enabled. This button displays in between the scroll bars and pops up a window showing the help text when pressed.
Public Property | HelpText | Gets or sets a string that overrides the default help text which displays when hitting the help icon.
Public Property | LanguageStrings | Gets or sets a language file name that overrides the default en.xml file.
Public Property | PreloadedSections | Gets or sets a value that determines the number of sections (rows / columns) outside of the viewing portal to render in advance. This can provide a better experience for the user at the cost of performance and bandwidth (loading images that may never be viewed).
Public Property | ReloadPeriod | Gets or sets the update interval for the chart in seconds. If data is changing on the server side this interval will refresh the chart image seamlessly based on this time period.
Public Property | ScrollType | Gets or sets a value that determines the scrolling type with options including drag (click / drag), scroll (using scroll bars / arrows) or both.
Public Property | SelectionStyle | Determines the visual style when selecting a zoomed region. Options include box and cross hair. Box is more aesthetically pleasing and allows for rough selections. Cross hair is more accurate and shows the cross hair lines extending ot the axis to select a more accurate region for the zoom.
Public Property | ToolTipDelay | Gets or sets a value that determines the amount time in seconds before the tooltip displays (if a tooltip exists for the area hovered over).
Public Property | UseContextMenu | Controls whether the context menu is displayed is displayed or not.
Public Property | UseSections | Gets or sets a value that determines if the chart image is rendered as a single image or in sections.
Top
Public Events
 | Name | Description
Public Event | ReloadChart |
Top
See Also

Reference

ImageZoomer Class
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Zoomer Namespace : ImageZoomer Class
ImageZoomer Class Properties

For a list of all members of this type, see ImageZoomer members.

Public Properties
 | Name | Description
Public Property | AjaxHandlerEnabled | Gets or sets a value that indicates whether the charts handle all ajax calls. If this boolean is true, a dedicated handler (ashx) page is used instead of the calling page.
Public Property | AspnetAjax | Controls whether the ASP.net AJAX is used or not.
Public Property | AxisToZoom | Gets or sets a value that indicates the zooming direction. Options include Both (can select any arbitrary bounding box to zoom to), XAxis (select a specific x axis region only, y axis is fixed to the maximum extent) , YAxis (select a specific y axis region only, x axis is fixed to the maximum extent)
Public Property | DragAfterZoom | Gets or sets a value that indicates whether the default operation after zooming is reset to drag. This allows the user to to drag or navigate the newly zoomed view before zooming again.
Public Property | Enabled | Gets or sets a value that indicates whether the Ajax zooming interface is activated.
Public Property | HelpButtonPosition | Controls the position of the ? icon on the chart when there is no scroll bar.
Public Property | HelpEnabled | Gets or sets a value that determines if the help button is enabled. This button displays in between the scroll bars and pops up a window showing the help text when pressed.
Public Property | HelpText | Gets or sets a string that overrides the default help text which displays when hitting the help icon.
Public Property | LanguageStrings | Gets or sets a language file name that overrides the default en.xml file.
Public Property | PreloadedSections | Gets or sets a value that determines the number of sections (rows / columns) outside of the viewing portal to render in advance. This can provide a better experience for the user at the cost of performance and bandwidth (loading images that may never be viewed).
Public Property | ReloadPeriod | Gets or sets the update interval for the chart in seconds. If data is changing on the server side this interval will refresh the chart image seamlessly based on this time period.
Public Property | ScrollType | Gets or sets a value that determines the scrolling type with options including drag (click / drag), scroll (using scroll bars / arrows) or both.
Public Property | SelectionStyle | Determines the visual style when selecting a zoomed region. Options include box and cross hair. Box is more aesthetically pleasing and allows for rough selections. Cross hair is more accurate and shows the cross hair lines extending ot the axis to select a more accurate region for the zoom.
Public Property | ToolTipDelay | Gets or sets a value that determines the amount time in seconds before the tooltip displays (if a tooltip exists for the area hovered over).
Public Property | UseContextMenu | Controls whether the context menu is displayed is displayed or not.
Public Property | UseSections | Gets or sets a value that determines if the chart image is rendered as a single image or in sections.
Top
See Also

Reference

ImageZoomer Class
dotnetCHARTING.Zoomer Namespace


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : AjaxHandlerEnabled Property
AjaxHandlerEnabled Property
Gets or sets a value that indicates whether the charts handle all ajax calls. If this boolean is true, a dedicated handler (ashx) page is used instead of the calling page.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AjaxHandlerEnabled As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.AjaxHandlerEnabled = value

value = instance.AjaxHandlerEnabled
public bool AjaxHandlerEnabled {get; set;}
Remarks
This option would typically only be used if the application was very performance sensitive and is disabled by default.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : AspnetAjax Property
AspnetAjax Property
Controls whether the ASP.net AJAX is used or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AspnetAjax As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.AspnetAjax = value

value = instance.AspnetAjax
public bool AspnetAjax {get; set;}
Remarks
It should be set to true when using the chart control inside the asp UpdatePanel.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : AxisToZoom Property
AxisToZoom Property (ImageZoomer)
Gets or sets a value that indicates the zooming direction. Options include Both (can select any arbitrary bounding box to zoom to), XAxis (select a specific x axis region only, y axis is fixed to the maximum extent) , YAxis (select a specific y axis region only, x axis is fixed to the maximum extent)
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property AxisToZoom As AxisToZoom
'Usage

Dim instance As ImageZoomer
Dim value As AxisToZoom

instance.AxisToZoom = value

value = instance.AxisToZoom
public AxisToZoom AxisToZoom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : DragAfterZoom Property
DragAfterZoom Property
Gets or sets a value that indicates whether the default operation after zooming is reset to drag. This allows the user to to drag or navigate the newly zoomed view before zooming again.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property DragAfterZoom As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.DragAfterZoom = value

value = instance.DragAfterZoom
public bool DragAfterZoom {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : Enabled Property
Enabled Property (ImageZoomer)
Gets or sets a value that indicates whether the Ajax zooming interface is activated.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property Enabled As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.Enabled = value

value = instance.Enabled
public bool Enabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : HelpButtonPosition Property
HelpButtonPosition Property
Controls the position of the ? icon on the chart when there is no scroll bar.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HelpButtonPosition As Point
'Usage

Dim instance As ImageZoomer
Dim value As Point

instance.HelpButtonPosition = value

value = instance.HelpButtonPosition
public Point HelpButtonPosition {get; set;}
Remarks
If there is a scroll bar on the chart, the ? icon is displayed before or between the scroll bars.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : HelpEnabled Property
HelpEnabled Property
Gets or sets a value that determines if the help button is enabled. This button displays in between the scroll bars and pops up a window showing the help text when pressed.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HelpEnabled As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.HelpEnabled = value

value = instance.HelpEnabled
public bool HelpEnabled {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : HelpText Property
HelpText Property
Gets or sets a string that overrides the default help text which displays when hitting the help icon.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property HelpText As String
'Usage

Dim instance As ImageZoomer
Dim value As String

instance.HelpText = value

value = instance.HelpText
public string HelpText {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : LanguageStrings Property
LanguageStrings Property (ImageZoomer)
Gets or sets a language file name that overrides the default en.xml file.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property LanguageStrings As String
'Usage

Dim instance As ImageZoomer
Dim value As String

instance.LanguageStrings = value

value = instance.LanguageStrings
public string LanguageStrings {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : PreloadedSections Property
PreloadedSections Property
Gets or sets a value that determines the number of sections (rows / columns) outside of the viewing portal to render in advance. This can provide a better experience for the user at the cost of performance and bandwidth (loading images that may never be viewed).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property PreloadedSections As Integer
'Usage

Dim instance As ImageZoomer
Dim value As Integer

instance.PreloadedSections = value

value = instance.PreloadedSections
public int PreloadedSections {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : ReloadPeriod Property
ReloadPeriod Property (ImageZoomer)
Gets or sets the update interval for the chart in seconds. If data is changing on the server side this interval will refresh the chart image seamlessly based on this time period.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ReloadPeriod As TimeSpan
'Usage

Dim instance As ImageZoomer
Dim value As TimeSpan

instance.ReloadPeriod = value

value = instance.ReloadPeriod
public TimeSpan ReloadPeriod {get; set;}
Remarks
This operation is resource intensive and should only be used if it the data for the chart is frequently changing and it is important that the viewer have the latest result immediately.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : ScrollType Property
ScrollType Property
Gets or sets a value that determines the scrolling type with options including drag (click / drag), scroll (using scroll bars / arrows) or both.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ScrollType As ScrollType
'Usage

Dim instance As ImageZoomer
Dim value As ScrollType

instance.ScrollType = value

value = instance.ScrollType
public ScrollType ScrollType {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : SelectionStyle Property
SelectionStyle Property
Determines the visual style when selecting a zoomed region. Options include box and cross hair. Box is more aesthetically pleasing and allows for rough selections. Cross hair is more accurate and shows the cross hair lines extending ot the axis to select a more accurate region for the zoom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property SelectionStyle As SelectionStyle
'Usage

Dim instance As ImageZoomer
Dim value As SelectionStyle

instance.SelectionStyle = value

value = instance.SelectionStyle
public SelectionStyle SelectionStyle {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : ToolTipDelay Property
ToolTipDelay Property
Gets or sets a value that determines the amount time in seconds before the tooltip displays (if a tooltip exists for the area hovered over).
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ToolTipDelay As Integer
'Usage

Dim instance As ImageZoomer
Dim value As Integer

instance.ToolTipDelay = value

value = instance.ToolTipDelay
public int ToolTipDelay {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : UseContextMenu Property
UseContextMenu Property
Controls whether the context menu is displayed is displayed or not.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseContextMenu As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.UseContextMenu = value

value = instance.UseContextMenu
public bool UseContextMenu {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : UseSections Property
UseSections Property
Gets or sets a value that determines if the chart image is rendered as a single image or in sections.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property UseSections As Boolean
'Usage

Dim instance As ImageZoomer
Dim value As Boolean

instance.UseSections = value

value = instance.UseSections
public bool UseSections {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


%%PageItemTitle%% $$Events$$

dotnetCHARTING.Zoomer Namespace : ImageZoomer Class
ImageZoomer Class Events

For a list of all members of this type, see ImageZoomer members.

Public Events
 | Name | Description
Public Event | ReloadChart |
Top
See Also

Reference

ImageZoomer Class
dotnetCHARTING.Zoomer Namespace


dotnetCHARTING.Zoomer Namespace > ImageZoomer Class : ReloadChart Event
ReloadChart Event
Syntax
  • Visual Basic
  • C#
'Declaration

Public Event ReloadChart As ReloadChartHandler
'Usage

Dim instance As ImageZoomer
Dim handler As ReloadChartHandler

AddHandler instance.ReloadChart, handler
public event ReloadChartHandler ReloadChart
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ImageZoomer Class
ImageZoomer Members


%%PageItemTitle%%

dotnetCHARTING.Zoomer Namespace : AxisToZoom Enumeration
AxisToZoom Enumeration
Specifies the axes to zoom.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum AxisToZoom
   Inherits System.Enum
'Usage

Dim instance As AxisToZoom
public enum AxisToZoom : System.Enum
Members
Member | Description
Both | Can select any arbitrary bounding box to zoom to.
XAxis | Select a specific x axis region only, y axis is fixed to the maximum extent
YAxis | Select a specific y axis region only, x axis is fixed to the maximum extent
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Zoomer.AxisToZoom

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%%

dotnetCHARTING.Zoomer Namespace : ScrollType Enumeration
ScrollType Enumeration
Specifies the scrolling type.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum ScrollType
   Inherits System.Enum
'Usage

Dim instance As ScrollType
public enum ScrollType : System.Enum
Members
Member | Description
Both | Scrolling and Drag are enabled.
Drag | The chart area can be dragged.
Scroll | Only scrolling is enabled.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Zoomer.ScrollType

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%%

dotnetCHARTING.Zoomer Namespace : SelectionStyle Enumeration
SelectionStyle Enumeration
Specifies the selection style.
Syntax
  • Visual Basic
  • C#
'Declaration

Public Enum SelectionStyle
   Inherits System.Enum
'Usage

Dim instance As SelectionStyle
public enum SelectionStyle : System.Enum
Members
Member | Description
Box | Box is more aesthetically pleasing and allows for rough selections.
CrossHair | Cross hair shows the cross hair lines extending ot the axis to select a more accurate region to zoom.
Inheritance Hierarchy

System.Object
System.ValueType
System.Enum
dotnetCHARTING.Zoomer.SelectionStyle

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%%

dotnetCHARTING.Zoomer Namespace : ReloadChartHandler Delegate
ReloadChartHandler Delegate
Syntax
  • Visual Basic
  • C#
'Declaration

Public Delegate Sub ReloadChartHandler( _
   ByVal chart As Chart _
)
'Usage

Dim instance As New ReloadChartHandler(AddressOf HandlerMethod)
public delegate void ReloadChartHandler(
   Chart chart
)

Parameters

chart
Remarks
This event is very useful for updating chart data.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ReloadChartHandler Members
dotnetCHARTING.Zoomer Namespace


Support Index

Support

  • Online Support
    Online support and resources.
  • Knowledge Base
    Common issues / tips / and answers to user questions.
  • FAQ
    Frequently asked questions.
Send comments on this topic.


FAQ
Can .netCHARTING be used from traditional ASP scripts?
No, .netCHARTING requires ASP.NET, please see system requirements for more details. You can still make use of the images generated by .netCHARTING in any language however as they are not specific to any platform.

Do I need to be a developer in order to use .netCHARTING?
No, .netCHARTING includes an easy to use control, if you are familiar with HTML or ASP scripting you should have no trouble producing dynamic charts within minutes of downloading the product! .netCHARTING is unique because in addition to performing charting it also performs the required database operations and groups the data for you automatically.

Can I use .netCHARTING at my ISP in a shared hosting environment?
Yes, it was specifically designed to support xcopy deployment. If your web host supports ASP.NET you will be able to use .netCHARTING. We recommend that you test with the trial version in your hosted environment to confirm the product will work for you.

There is a specific charting type or feature I am interested in, will .netCHARTING support this?
We are continually enhancing .netCHARTING based on client feedback. If you have any feature requests please feel free to email info@dotnetcharting.com, as your suggestions could end up in the next version of .netCHARTING!

Access to "c:\inetpub\wwwroot\dotnetcharting\web\csharp\temp" is denied (where the value in quotes is a path on your system): Write permissions are required on the directory .netCHARTING is configured to create the charts in. See the install section of this document for instructions on granting write permissions.

CreateControl: A generic error occurred in GDI+: This is a similar case to the previous question. You should ensure that the temp directory is set to a valid path and that the directory has permissions set correctly.

Server Error in '/' Application. File or assembly name dotnetCHARTING, or one of its dependencies, was not found: This error indicates that an application is not created on the directory that contains your /bin directory which in turn contains dotnetCHARTING.dll. If you follow the instructions for installation via virtual directory an application is created by default. You can also create an application on the directory see here for instructions.

How do I map my database fields onto the x, y axis and other fields?
Use Series.DataFields or if using the DataEngine DataEngine.DataFields properties. Examples:
Simple Chart: Chart.Series.DataFields = "yAxis=myValueField,xAxis=myNameField";
Financial Chart: Chart.Series.DataFields = "Open=myOpenField, Close=myCloseField, High=myHighField.....";

Can I upgrade a web site license to a server license at a later date?
Yes, for the difference in price between what you paid for the web site license and the current cost of the server license. In this case the server license would replace your web site license.

I installed my license but the chart is still branded 'not for production use' why?

Your license key must be deployed as per your license purchase instructions and be used with a matching DLL version. Website licenses are fully qualified domain specific and will not function on alternate subdomains. If file level (NTFS) permissions are restricted on the license key deployed, it will not be loaded. Please see the illustrated quickstart under setup permissions for more details.

  • The key must be the bin folder of your application along with the dotnetcharting.dll.
  • For web site licenses, the license takes effect when the charts are viewed through the licensed domain in the web browser.
  • The license purchased for a particular domain is specific to YourDomain.com and www.YourDomain.com.
  • The license will not work on sub domains such as 'server1.YourDomain.com' unless a specific key is purchased for such a URL.
  • If you still have troubles after verifying these steps, please contact orders@dotnetcharting.com for further assistance.
Send comments on this topic.


Trademark And Copyright

.netCHARTING documentation, logo, design and application is copyright 2023 Corporate Web Solutions Ltd.

All trademarks of products, services, company or organizational names, logos, phrases, service marks, service logos, and/or slogans are trademark(s) or registered trademark(s) and/or service mark(s) of the respective holder(s), where applicable.

Send comments on this topic.


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Annotation Class
Annotation Class Methods

For a list of all members of this type, see Annotation members.

Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

Annotation Class
dotnetCHARTING Namespace

Tutorials

Box Tutorial


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : Axis.ScaleSync Class
Axis.ScaleSync Class Methods

For a list of all members of this type, see Axis.ScaleSync members.

Public Methods
 | Name | Description
Public Method | Add | Overloaded. Adds a specified AxisCollection to this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Clear | Removes all objects from the System.Collections.CollectionBase instance. This method cannot be overridden. (Inherited from System.Collections.CollectionBase)
Public Method | Contains | Determines whether this collection contains a specified Axis. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | GetEnumerator | Returns an enumerator that iterates through the System.Collections.CollectionBase instance. (Inherited from System.Collections.CollectionBase)
Public Method | IndexOf | Determines the index of a specified Axis in this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Insert | Inserts a Axis into this collection at a specified index. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | Remove | Removes a specified Axis from this collection. (Inherited from dotnetCHARTING.AxisCollection)
Public Method | RemoveAt | Removes the element at the specified index of the System.Collections.CollectionBase instance. This method is not overridable. (Inherited from System.Collections.CollectionBase)
Top
See Also

Reference

Axis.ScaleSync Class
dotnetCHARTING Namespace
SynchronizeScale Property


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : AxisMarker Class
AxisMarker Class Methods

For a list of all members of this type, see AxisMarker members.

Public Methods
 | Name | Description
Public Method | ToString | (Inherited from dotnetCHARTING.ScaleRange)
Top
See Also

Reference

AxisMarker Class
dotnetCHARTING Namespace

Tutorials

Axis Marker


dotnetCHARTING Namespace > AxisTick Class : Dispose Method
Dispose Method (AxisTick)
Releases all resources used by this AxisTick.
Overload List
Overload | Description
Dispose | Releases all resources used by this AxisTick.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

AxisTick Class
AxisTick Members


dotnetCHARTING Namespace > ChartArea Class : ValueLabel Property
ValueLabel Property
Gets or sets a label that specifies the font and color of element labels drawn on the chart.
Equivalent to: Chart.DefaultSeries.DefaultElement.SmartLabel
Syntax
  • Visual Basic
  • C#
'Declaration

Public Property ValueLabel As Label
'Usage

Dim instance As ChartArea
Dim value As Label

instance.ValueLabel = value

value = instance.ValueLabel
public Label ValueLabel {get; set;}
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ChartArea Class
ChartArea Members


dotnetCHARTING Namespace > Chart Class : RenderControl Method
RenderControl Method
Outputs chart server control content to a provided HtmlTextWriter object.
Overload List
Overload | Description
RenderControl | Outputs chart server control content to a provided HtmlTextWriter object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Chart Class
Chart Members
Base Implementation in RenderControl


dotnetCHARTING Namespace > DataEngine Class : AddParameter Method
AddParameter Method (DataEngine)
Adds a stored procedure when to use in conjunction with StoredProcedure.
Overload List
Overload | Description
AddParameter | Adds a stored procedure when to use in conjunction with StoredProcedure.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

DataEngine Class
DataEngine Members


dotnetCHARTING Namespace > DataSource Class > Implicit Type Conversion Operator : Implicit Type Conversion(DataSource,AxisMarker) Operator
AxisMarker that is used as the as the DataSource.
Implicit Type Conversion(DataSource,AxisMarker) Operator
Creates a DataSource from the specified AxisMarker.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal am As AxisMarker _
) As DataSource

public DataSource operator implicit(
   AxisMarker am
)

Parameters
am

AxisMarker that is used as the as the DataSource.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
DataSource Class

DataSource Members

Overload List


dotnetCHARTING Namespace > DataSource Class > Implicit Type Conversion Operator : Implicit Type Conversion(DataSource,Element) Operator
Element that is used as the as the DataSource.
Implicit Type Conversion(DataSource,Element) Operator
Creates a DataSource from the specified Element.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal e As Element _
) As DataSource

public DataSource operator implicit(
   Element e
)

Parameters
e

Element that is used as the as the DataSource.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
DataSource Class

DataSource Members

Overload List


dotnetCHARTING Namespace > DataSource Class > Implicit Type Conversion Operator : Implicit Type Conversion(DataSource,Series) Operator
Series that is used as the as the DataSource.
Implicit Type Conversion(DataSource,Series) Operator
Creates a DataSource from the specified Series.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal s As Series _
) As DataSource

public DataSource operator implicit(
   Series s
)

Parameters
s

Series that is used as the as the DataSource.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
DataSource Class

DataSource Members

Overload List


dotnetCHARTING Namespace > DataSource Class > Implicit Type Conversion Operator : Implicit Type Conversion(DataSource,SeriesCollection) Operator
SeriesCollection that is used as the as the DataSource.
Implicit Type Conversion(DataSource,SeriesCollection) Operator
Creates a DataSource from the specified SeriesCollection.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal sc As SeriesCollection _
) As DataSource

public DataSource operator implicit(
   SeriesCollection sc
)

Parameters
sc

SeriesCollection that is used as the as the DataSource.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
DataSource Class

DataSource Members

Overload List


dotnetCHARTING Namespace > ElementCollection Class : Item Property
Item Property (ElementCollection)
Gets or sets the Element at a specified index.
Overload List
Overload | Description
Item | Gets or sets the Element at a specified index.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ElementCollection Class
ElementCollection Members


dotnetCHARTING Namespace > Element Class > Addition Operator : Addition(Double,Element) Operator
A value.
An element.
Addition(Double,Element) Operator
Adds a value to all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element

public Element operator +(
   double lhs,
   Element rhs
)

Parameters
lhs

A value.
rhs

An element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Addition Operator : Addition(Element,Double) Operator
An element.
A value.
Addition(Element,Double) Operator
Adds a value to all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element

public Element operator +(
   Element lhs,
   double rhs
)

Parameters
lhs

An element.
rhs

A value.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Addition Operator : Addition(Element,Element) Operator
An element.
An element.
Addition(Element,Element) Operator
Adds the values of two elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element

public Element operator +(
   Element lhs,
   Element rhs
)

Parameters
lhs

An element.
rhs

An element.

Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Division Operator : Division(Double,Element) Operator
A numeric value.
An element.
Division(Double,Element) Operator
Divider a number by an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element

public Element operator /(
   double lhs,
   Element rhs
)

Parameters
lhs

A numeric value.
rhs

An element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Division Operator : Division(Element,Double) Operator
An element.
A numeric value.
Division(Element,Double) Operator
Divides an element by a number.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element

public Element operator /(
   Element lhs,
   double rhs
)

Parameters
lhs

An element.
rhs

A numeric value.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Division Operator : Division(Element,Element) Operator
An element.
An element.
Division(Element,Element) Operator
Divides an element by another.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element

public Element operator /(
   Element lhs,
   Element rhs
)

Parameters
lhs

An element.
rhs

An element.

Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Multiplication Operator : Multiplication(Double,Element) Operator
A numeric value.
An element.
Multiplication(Double,Element) Operator
Multiplies an element by a specified numeric value.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element

public Element operator *(
   double lhs,
   Element rhs
)

Parameters
lhs

A numeric value.
rhs

An element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Multiplication Operator : Multiplication(Element,Double) Operator
An element.
A numeric value.
Multiplication(Element,Double) Operator
Multiplies an element by a specified numeric value.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element

public Element operator *(
   Element lhs,
   double rhs
)

Parameters
lhs

An element.
rhs

A numeric value.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Multiplication Operator : Multiplication(Element,Element) Operator
An element.
An element.
Multiplication(Element,Element) Operator
Multiplies two elements.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element

public Element operator *(
   Element lhs,
   Element rhs
)

Parameters
lhs

An element.
rhs

An element.

Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Subtraction Operator : Subtraction(Double,Element) Operator
A value.
An element
Subtraction(Double,Element) Operator
Subtracts all values of an element from specified value.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Double, _
   ByVal rhs As Element _
) As Element

public Element operator -(
   double lhs,
   Element rhs
)

Parameters
lhs

A value.
rhs

An element

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Subtraction Operator : Subtraction(Element,Double) Operator
An element.
A value.
Subtraction(Element,Double) Operator
Subtracts a value from all values of an element.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Element, _
   ByVal rhs As Double _
) As Element

public Element operator -(
   Element lhs,
   double rhs
)

Parameters
lhs

An element.
rhs

A value.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Element Class > Subtraction Operator : Subtraction(Element,Element) Operator
An element.
An element.
Subtraction(Element,Element) Operator
Subtracts an element from another.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Element, _
   ByVal rhs As Element _
) As Element

public Element operator -(
   Element lhs,
   Element rhs
)

Parameters
lhs

An element.
rhs

An element.

Remarks
All properties of lsh are copied to the resulting element, then rhs properties are trickled to the resulting element.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Element Class

Element Members

Overload List


dotnetCHARTING Namespace > Label Class : Dispose Method
Dispose Method (Label)
Overload List
Overload | Description
Dispose |
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Label Class
Label Members


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : LegendBox Class
LegendBox Class Methods

For a list of all members of this type, see LegendBox members.

Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

LegendBox Class
dotnetCHARTING Namespace

Tutorials

Legendbox Basics
Legendbox Advanced
Box Tutorial


%%PageItemTitle%% $$Properties$$

dotnetCHARTING Namespace : ListCollection Class
ListCollection Class Properties

For a list of all members of this type, see ListCollection members.

Public Properties
 | Name | Description
Public Property | Count | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsFixedSize | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsReadOnly | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | IsSynchronized | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Item | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Keys | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | SyncRoot | (Inherited from System.Collections.Specialized.ListDictionary)
Public Property | Values | (Inherited from System.Collections.Specialized.ListDictionary)
Top
See Also

Reference

ListCollection Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > ListCollection Class > Implicit Type Conversion Operator : Implicit Type Conversion(ListCollection,String) Operator
Implicit Type Conversion(ListCollection,String) Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal str As String _
) As ListCollection

public ListCollection operator implicit(
   string str
)

Parameters
str

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
ListCollection Class

ListCollection Members

Overload List


dotnetCHARTING Namespace > ListCollection Class > Implicit Type Conversion Operator : Implicit Type Conversion(String,ListCollection) Operator
Implicit Type Conversion(String,ListCollection) Operator
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator Widening CType( _
   ByVal lc As ListCollection _
) As String

public string operator implicit(
   ListCollection lc
)

Parameters
lc

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
ListCollection Class

ListCollection Members

Overload List


%%PageItemTitle%% $$Properties$$

dotnetCHARTING.Mapping Namespace : GroupConditionCollection Class
GroupConditionCollection Class Properties

For a list of all members of this type, see GroupConditionCollection members.

Public Properties
 | Name | Description
Public Property | Count | Gets the number of elements contained in the System.Collections.DictionaryBase instance. (Inherited from System.Collections.DictionaryBase)
Top
See Also

Reference

GroupConditionCollection Class
dotnetCHARTING.Mapping Namespace


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > MapLayer Class : MapLayer Constructor
MapLayer Constructor
Overload List
Overload | Description
MapLayer Constructor | Initializes a new instance of the MapLayer object.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

MapLayer Class
MapLayer Members


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > Mapping Class : Mapping Constructor
Mapping Constructor
Overload List
Overload | Description
Mapping Constructor | Initializes a new instance of the Mapping class.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Mapping Class
Mapping Members


%%PageItemTitle%%

dotnetCHARTING.Mapping Namespace > ShapeCollection Class : ShapeCollection Constructor
ShapeCollection Constructor
Overload List
Overload | Description
ShapeCollection Constructor | Initializes a new instance of ShapeCollection
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

ShapeCollection Class
ShapeCollection Members


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

dotnetCHARTING.Mapping Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
dotnetCHARTING.Mapping.Group
dotnetCHARTING.Mapping.MapDataEngine
dotnetCHARTING.Mapping.MapLayer
dotnetCHARTING.Mapping.Mapping
dotnetCHARTING.Mapping.Projection
dotnetCHARTING.Mapping.Shape
dotnetCHARTING.Mapping.ShapeCollection
System.Collections.CollectionBase
dotnetCHARTING.Mapping.GroupCollection
dotnetCHARTING.Mapping.MapLayerCollection
System.Collections.DictionaryBase
dotnetCHARTING.Mapping.GroupConditionCollection
See Also

Reference

dotnetCHARTING Assembly


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : NavigatorOptions.NavigationBarOptions Class
NavigatorOptions.NavigationBarOptions Class Methods

For a list of all members of this type, see NavigatorOptions.NavigationBarOptions members.

Public Methods
 | Name | Description
Public Method | ClearColors | Serves as a shortcut to make this box invisible. (Inherited from dotnetCHARTING.Box)
Public Method | GetCoordinates | Gets the coordinates of this box after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Public Method | GetRectangle | Gets a Rectangle object indicating this boxes position and size after the chart is rendered. (Inherited from dotnetCHARTING.Box)
Top
See Also

Reference

NavigatorOptions.NavigationBarOptions Class
dotnetCHARTING Namespace


dotnetCHARTING Namespace > SeriesCollection Class : CalculateElement Method
CalculateElement Method
Performs a calculation on this collection.
Overload List
Overload | Description
CalculateElement | Performs a calculation on this collection.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SeriesCollection Class
SeriesCollection Members

Tutorials

Data Manipulation


dotnetCHARTING Namespace > Series Class > Addition Operator : Addition(Double,Series) Operator
A double value.
A series.
Addition(Double,Series) Operator
Adds a value to all elements in the rhs series.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series

public Series operator +(
   double lhs,
   Series rhs
)

Parameters
lhs

A double value.
rhs

A series.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Addition Operator : Addition(Series,Double) Operator
A series.
A double value.
Addition(Series,Double) Operator
Adds a value to all elements in the rhs series.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series

public Series operator +(
   Series lhs,
   double rhs
)

Parameters
lhs

A series.
rhs

A double value.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Addition Operator : Addition(Series,Series) Operator
Left hand side Series.
Right hand side Series.
Addition(Series,Series) Operator
Adds two Series objects together.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series

public Series operator +(
   Series lhs,
   Series rhs
)

Parameters
lhs

Left hand side Series.
rhs

Right hand side Series.

Remarks
All element values such as YValue, XValue etc. are added based on element names. This means that only elements with the same name will be computed.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Division Operator : Division(Double,Series) Operator
Dividend number.
Divisor series.
Division(Double,Series) Operator
Divides the value on the left by the series on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series

public Series operator /(
   double lhs,
   Series rhs
)

Parameters
lhs

Dividend number.
rhs

Divisor series.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Division Operator : Division(Series,Double) Operator
Dividend series.
Divisor number.
Division(Series,Double) Operator
Divides the series on the left by the value on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series

public Series operator /(
   Series lhs,
   double rhs
)

Parameters
lhs

Dividend series.
rhs

Divisor number.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Division Operator : Division(Series,Series) Operator
Dividend series.
Divisor series.
Division(Series,Series) Operator
Divides the element values of the series on the left by the element values of the series on the right.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator /( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series

public Series operator /(
   Series lhs,
   Series rhs
)

Parameters
lhs

Dividend series.
rhs

Divisor series.

Remarks
All element values such as YValue, XValue etc. are divided based on element names. This means that only elements with the same name will be computed.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Multiplication Operator : Multiplication(Double,Series) Operator
Number multiplied by.
Series multiplied by.
Multiplication(Double,Series) Operator
Multiplies a series by a value.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series

public Series operator *(
   double lhs,
   Series rhs
)

Parameters
lhs

Number multiplied by.
rhs

Series multiplied by.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Multiplication Operator : Multiplication(Series,Double) Operator
Series multiplied by.
Series multiplied by.
Multiplication(Series,Double) Operator
Multiplies a series by a value.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series

public Series operator *(
   Series lhs,
   double rhs
)

Parameters
lhs

Series multiplied by.
rhs

Series multiplied by.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Multiplication Operator : Multiplication(Series,Series) Operator
Left hand side Series.
Right hand side Series.
Multiplication(Series,Series) Operator
Multiplies two Series objects together.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator *( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series

public Series operator *(
   Series lhs,
   Series rhs
)

Parameters
lhs

Left hand side Series.
rhs

Right hand side Series.

Remarks
All element values such as YValue, XValue etc. are multiplied based on element names. This means that only elements with the same name will be computed.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Subtraction Operator : Subtraction(Double,Series) Operator
Number subtracted from.
Series subtracted by.
Subtraction(Double,Series) Operator
Subtracts all element values from the left hand side number.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Double, _
   ByVal rhs As Series _
) As Series

public Series operator -(
   double lhs,
   Series rhs
)

Parameters
lhs

Number subtracted from.
rhs

Series subtracted by.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Subtraction Operator : Subtraction(Series,Double) Operator
Series subtracted from.
Number subtracted by.
Subtraction(Series,Double) Operator
Subtracts the number on the right hand side from the element values of the series on the left.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Series, _
   ByVal rhs As Double _
) As Series

public Series operator -(
   Series lhs,
   double rhs
)

Parameters
lhs

Series subtracted from.
rhs

Number subtracted by.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class > Subtraction Operator : Subtraction(Series,Series) Operator
Series subtracted from.
Series subtracted by.
Subtraction(Series,Series) Operator
Subtracts the element values of series on the right from the series on the left.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator -( _
   ByVal lhs As Series, _
   ByVal rhs As Series _
) As Series

public Series operator -(
   Series lhs,
   Series rhs
)

Parameters
lhs

Series subtracted from.
rhs

Series subtracted by.

Remarks
All element values such as YValue, XValue etc. are subtracted based on element names. This means that only elements with the same name will be computed.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
Series Class

Series Members

Overload List


dotnetCHARTING Namespace > Series Class : Split Method
Split Method
Splits the elements into individual series per the specified TimeIntervalAdvanced.
Overload List
Overload | Description
Split | Splits the elements into individual series per the specified TimeIntervalAdvanced.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members


dotnetCHARTING Namespace > Series Class : SplitRegroup Method
SplitRegroup Method

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Overload List
Overload Description
SplitRegroup

Splits the elements based on the first split, then the resulting series are grouped based on the second split. A simple analogy is a stretch of measuring tape representing a timeline. The tape is cut into sections based on (first split), then the pieces are stacked on top of each other and cut again based on the second split. The resulting stacks are evaluated down to an element based on the specified calculation.

As a real world example, consider you have a series with web site traffic represented by an element for each time the website was visited including a date and time. This method can parse the data in a way that allows determining the traffic for each day of the week throughout the entire span of time. This means all the traffic going through the website on any monday would be calculated down to a single element, same for tuesday and so on.

This illustration shows how the data is arranged.

Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

Series Class
Series Members

Tutorials

Data Manipulation


%%PageItemTitle%% $$Methods$$

dotnetCHARTING Namespace : SmartLabel Class
SmartLabel Class Methods

For a list of all members of this type, see SmartLabel members.

Public Methods
 | Name | Description
Public Method | Dispose | (Inherited from dotnetCHARTING.Label)
Public Method | ToString | (Inherited from dotnetCHARTING.Label)
Top
See Also

Reference

SmartLabel Class
dotnetCHARTING Namespace
Using Labels

Reference

Token Reference

Tutorials

Label Alignment and Control
Formatting Values
Formatting Advanced


dotnetCHARTING Namespace > SmartPalette Class : FromColors Method
FromColors Method
Creates a SmartPalette with range colors based on the specified element value and colors.
Overload List
Overload | Description
FromColors | Creates a SmartPalette with range colors based on the specified element value and colors.
Requirements

Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also

Reference

SmartPalette Class
SmartPalette Members


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Addition Operator : Addition(DateTime,TimeIntervalAdvanced) Operator
Added to DateTime.
TimeIntervalAdvanced to add.
Addition(DateTime,TimeIntervalAdvanced) Operator
Adds a TimeIntervalAdvanced to a DateTime object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As Date, _
   ByVal rhs As TimeIntervalAdvanced _
) As Date

public DateTime operator +(
   DateTime lhs,
   TimeIntervalAdvanced rhs
)

Parameters
lhs

Added to DateTime.
rhs

TimeIntervalAdvanced to add.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Addition Operator : Addition(TimeIntervalAdvanced,DateTime) Operator
TimeIntervalAdvanced to add.
Added to DateTime.
Addition(TimeIntervalAdvanced,DateTime) Operator
Adds a TimeIntervalAdvanced to a DateTime object.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator +( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As Date _
) As Date

public DateTime operator +(
   TimeIntervalAdvanced lhs,
   DateTime rhs
)

Parameters
lhs

TimeIntervalAdvanced to add.
rhs

Added to DateTime.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Equality Operator : Equality(TimeIntervalAdvanced,TimeInterval) Operator
TimeIntervalAdvanced to compare.
TimeInterval to compare.
Equality(TimeIntervalAdvanced,TimeInterval) Operator
Indicates whether a specified TimeIntervalAdvanced is equal to a specified TimeInterval enumeration.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator =( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeInterval _
) As Boolean

public bool operator ==(
   TimeIntervalAdvanced lhs,
   TimeInterval rhs
)

Parameters
lhs

TimeIntervalAdvanced to compare.
rhs

TimeInterval to compare.

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Equality Operator : Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) Operator
left TimeIntervalAdvanced
right TimeIntervalAdvanced
Equality(TimeIntervalAdvanced,TimeIntervalAdvanced) Operator
Indicates whether a specified TimeIntervalAdvanced is equal to another TimeIntervalAdvanced.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator =( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeIntervalAdvanced _
) As Boolean

public bool operator ==(
   TimeIntervalAdvanced lhs,
   TimeIntervalAdvanced rhs
)

Parameters
lhs

left TimeIntervalAdvanced
rhs

right TimeIntervalAdvanced

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Inequality Operator : Inequality(TimeIntervalAdvanced,TimeInterval) Operator
Inequality(TimeIntervalAdvanced,TimeInterval) Operator
Indicates whether a TimeInterval and TimeIntervalAdvanced are not equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator <>( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeInterval _
) As Boolean

public bool operator !=(
   TimeIntervalAdvanced lhs,
   TimeInterval rhs
)

Parameters
lhs

rhs

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


dotnetCHARTING Namespace > TimeIntervalAdvanced Class > Inequality Operator : Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) Operator
Inequality(TimeIntervalAdvanced,TimeIntervalAdvanced) Operator
Indicates whether two TimeIntervalAdvanced instances are not equal.
Syntax
  • Visual Basic
  • C#
'Declaration

Overloads Public Operator <>( _
   ByVal lhs As TimeIntervalAdvanced, _
   ByVal rhs As TimeIntervalAdvanced _
) As Boolean

public bool operator !=(
   TimeIntervalAdvanced lhs,
   TimeIntervalAdvanced rhs
)

Parameters
lhs

rhs

Requirements
Target Platforms: Windows 7, Windows Vista SP1 or later, Windows XP SP3, Windows Server 2008 (Server Core not supported), Windows Server 2008 R2 (Server Core supported with SP1 or later), Windows Server 2003 SP2

See Also
Reference
TimeIntervalAdvanced Class

TimeIntervalAdvanced Members

Overload List


%%PageItemTitle%% $$Events$$

dotnetCHARTING.Zoomer Namespace : ChartControl Class
ChartControl Class Events

For a list of all members of this type, see ChartControl members.

Public Events
 | Name | Description
Public Event | DataBinding | Occurs when the server control binds to a data source. (Inherited from System.Web.UI.Control)
Public Event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from System.Web.UI.Control)
Public Event | ErrorProcessing | (Inherited from dotnetCHARTING.Chart)
Public Event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from System.Web.UI.Control)
Public Event | Load | Occurs when the server control is loaded into the System.Web.UI.Page object. (Inherited from System.Web.UI.Control)
Public Event | PostDataProcessing | Occurs when the the chart is completed the data processing. (Inherited from dotnetCHARTING.Chart)
Public Event | PreRender | Occurs after the System.Web.UI.Control object is loaded but prior to rendering. (Inherited from System.Web.UI.Control)
Public Event | Unload | Occurs when the server control is unloaded from memory. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ChartControl Class
dotnetCHARTING.Zoomer Namespace


%%PageItemTitle%% $$Methods$$

dotnetCHARTING.Zoomer Namespace : ChartControl Class
ChartControl Class Methods

For a list of all members of this type, see ChartControl members.

Public Methods
 | Name | Description
Public Method | ApplyStyle | Copies any nonblank elements of the specified style to the Web control, overwriting any existing style elements of the control. This method is primarily used by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from System.Web.UI.Control)
Public Method | CopyBaseAttributes | Copies the properties not encapsulated by the System.Web.UI.WebControls.WebControl.Style object from the specified Web server control to the Web server control that this method is called from. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from System.Web.UI.Control)
Public Method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from System.Web.UI.Control)
Public Method | FindControl | (Inherited from System.Web.UI.Control)
Public Method | Focus | Sets input focus to a control. (Inherited from System.Web.UI.Control)
Public Method | GetChartBitmap | Obtains a System.Drawing.Bitmap of the generated chart. (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartJS | Returns a string contains the Javascript chart configuration. (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed). (Inherited from dotnetCHARTING.Chart)
Public Method | GetChartStream | Returns the memory stream of the image. (Inherited from dotnetCHARTING.Chart)
Public Method | GetLegendBitmap | Obtains a System.Drawing.Bitmap of the legend generated by the chart. (Inherited from dotnetCHARTING.Chart)
Public Method | GetLegendMetafile | Returns the metafile contains records that describe a sequence of graphics operations that can be recorded (constructed) and played back (displayed). (Inherited from dotnetCHARTING.Chart)
Public Method | HasControls | Determines if the server control contains any child controls. (Inherited from System.Web.UI.Control)
Public Method | HitTest | (Inherited from dotnetCHARTING.Chart)
Public Method | LoadState | Overloaded. Imports a chart object from the specified xml file. (Inherited from dotnetCHARTING.Chart)
Public Method | MergeStyle | Copies any nonblank elements of the specified style to the Web control, but will not overwrite any existing style elements of the control. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | PaletteAdd | Overloaded. Adds the colors of a predefined palette to the existing palette colors stored in dotnetCHARTING.Chart.Palette. (Inherited from dotnetCHARTING.Chart)
Public Method | RenderBeginTag | Renders the HTML opening tag of the control to the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | RenderControl | Outputs chart server control content to a provided HtmlTextWriter object. (Inherited from dotnetCHARTING.Chart)
Public Method | RenderEndTag | Renders the HTML closing tag of the control into the specified writer. This method is used primarily by control developers. (Inherited from System.Web.UI.WebControls.WebControl)
Public Method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from System.Web.UI.Control)
Public Method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from System.Web.UI.Control)
Public Method | SaveState | Overloaded. Saves this chart instance to an xml file. (Inherited from dotnetCHARTING.Chart)
Public Method | SaveStateJSON | Overloaded. (Inherited from dotnetCHARTING.Chart)
Public Method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from System.Web.UI.Control)
Top
See Also

Reference

ChartControl Class
dotnetCHARTING.Zoomer Namespace


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

dotnetCHARTING.Zoomer Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
dotnetCHARTING.Zoomer.ClientScriptProxy
dotnetCHARTING.Zoomer.ImageZoomer
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart
dotnetCHARTING.Zoomer.ChartControl
See Also

Reference

dotnetCHARTING Assembly


%%ItemTitle%% $$INHERITANCE_HIERARCHY$$

dotnetCHARTING Namespace Inheritance Hierarchy
Inheritance Hierarchy
System.Object
dotnetCHARTING.Axis
dotnetCHARTING.Axis.TimeScaleLabelInfo
dotnetCHARTING.AxisLineBreaks
dotnetCHARTING.BoxHeaderOptions
dotnetCHARTING.CalendarPattern
dotnetCHARTING.ChartArea
dotnetCHARTING.ChartAreaLayout
dotnetCHARTING.DataEngine
dotnetCHARTING.DataSource
dotnetCHARTING.Element
dotnetCHARTING.EmptyElement
dotnetCHARTING.FileManager
dotnetCHARTING.FinancialEngine
dotnetCHARTING.FinancialEngine.Options
dotnetCHARTING.ForecastEngine
dotnetCHARTING.ForecastEngine.Advanced
dotnetCHARTING.ForecastEngine.Options
dotnetCHARTING.GridColumn
dotnetCHARTING.Hotspot.HtmlAttribute
dotnetCHARTING.Hotspot.HtmlAttributes
dotnetCHARTING.JSDataGrid
dotnetCHARTING.JSMapping
dotnetCHARTING.JsOptions
dotnetCHARTING.JsOptions.JsButtons
dotnetCHARTING.JsOptions.JsCalendar
dotnetCHARTING.JsOptions.JsCalendarFilter
dotnetCHARTING.JsOptions.JsHighlight
dotnetCHARTING.JsOptions.LanguageStringSettings
dotnetCHARTING.LegendEntry
dotnetCHARTING.Mapping.Drawing.Property
dotnetCHARTING.Background
dotnetCHARTING.Box
dotnetCHARTING.Annotation
dotnetCHARTING.LegendBox
dotnetCHARTING.NavigatorOptions.NavigationBarOptions
dotnetCHARTING.ElementMarker
dotnetCHARTING.Hotspot
dotnetCHARTING.Label
dotnetCHARTING.SmartLabel
dotnetCHARTING.Line
dotnetCHARTING.NavigatorOptions
dotnetCHARTING.Parameter
dotnetCHARTING.ScaleRange
dotnetCHARTING.AxisMarker
dotnetCHARTING.AxisTick
dotnetCHARTING.Series
dotnetCHARTING.Shadow
dotnetCHARTING.SmartColor
dotnetCHARTING.StatisticalEngine
dotnetCHARTING.StatisticalEngine.Options
dotnetCHARTING.SubValue
dotnetCHARTING.TimeIntervalAdvanced
dotnetCHARTING.Truncation
dotnetCHARTING.View3D
dotnetCHARTING.Viewport
System.Collections.CollectionBase
dotnetCHARTING.AnnotationCollection
dotnetCHARTING.AxisCollection
dotnetCHARTING.Axis.ScaleSync
dotnetCHARTING.AxisMarkerCollection
dotnetCHARTING.AxisTickCollection
dotnetCHARTING.ChartAreaCollection
dotnetCHARTING.ElementCollection
dotnetCHARTING.GridColumnCollection
dotnetCHARTING.HotspotCollection
dotnetCHARTING.LabelAlignmentCollection
dotnetCHARTING.LabelOverrideCollection
dotnetCHARTING.LegendBoxCollection
dotnetCHARTING.LegendEntryCollection
dotnetCHARTING.ParameterCollection
dotnetCHARTING.ScaleRangeCollection
dotnetCHARTING.SeriesCollection
dotnetCHARTING.ShapeLabelCollection
dotnetCHARTING.SubValueCollection
dotnetCHARTING.TimeIntervalCollection
System.Collections.Specialized.ListDictionary
dotnetCHARTING.ListCollection
System.Collections.Specialized.NameObjectCollectionBase
dotnetCHARTING.SmartPalette
System.ValueType
dotnetCHARTING.LabelOverride
dotnetCHARTING.Vector
System.Web.UI.Control
System.Web.UI.WebControls.WebControl
dotnetCHARTING.Chart
dotnetCHARTING.Zoomer.ChartControl
See Also

Reference

dotnetCHARTING Assembly


%%Phrase%%

Glossary
A | B | C | D | E | F | G | H | I | J | K | L | M | N | O | P | Q | R | S | T | U | V | W | X | Y | Z

A

Axis Marker
Used to mark a line of area of a chart and must be attached to an axis. It can also be attached to an element. The element will in turn carry it onto the axis it's on.

C

Category Axis
An axis with evenly spaced text tick values.

D

Data Fields
A dictionary list that facilitates .netCHARTING data acquisition engine (DataEngine). It defines which database columns map to which element properties.

E

Element
A data single data point plotted on a chart.

Element Group
A group of elements that have the same name. Elements that share names are usually grouped and shown on the same axis tick.

S

Series
A collection of data elements plotted on a chart.

Shadow Axis
An axis that shadows another axis but can manipulate it's ticks to represent the information in a different way.

Smart Category Axis
An axis with evenly spaced text tick values. If the ticks represents numeric or time values they will be ordered sequentially but not spaced based on the actual values.

T

Tokens
A term prefixed with a percent sign that refers to a property of objects such as series and elements. It can be used in labels and will be replaced with the correct information at runtime. Example: '%YValue' - This specifies the y value of an element.

V

Value Axis
An axis with a numeric or time scale. This scale has tick marks that reflect the actual distance between the values.

Virtual Directory
Directory that references one or more physical directories and, optionally, other virtual directories.

Send comments on this topic.


ImageBar SDK

Introduction

.netCHARTING introduced ImageBars with the release of version 4.0 in 2006. There are nearly 100 highly tuned and optimized image bars available with the bundle today. As the popularity of ImageBars grows, the need for an ImageBar SDK became evident. This tutorial will describe how to construct imageBars manually.

The elements that make up .netCHARTING image bars consist of a descriptive XML file and repeating or static SVG images. The provided compiler can then be used to generate *.cache files which .netCHARTING can consume.

.netCHARTING image bar graphics can be designed manually by using a vector graphics authoring application such as Illustrator to create SVG images.

The SVG format has a number of limitations that full-blown illustrator format files dont. It's recommended to use only supported features when exporting to SVG.

The XML ImageBar definition

The XML file defines the what SVG images to use and how they are used. This is a sample xml definition for an ImageBar.

Banana ImageBar XML definition.
Copy Code
<?xml version="1.0" encoding="utf-8" ?>
<template repeaterstyle="scaley" basecapstyle="lowercut">
  <repeater filename="banana_repeater.svg"/>
  <base filename ="banana_base.svg" include_into_value="true"/>
  <cap filename="banana_cap.svg" include_into_value="true"/>
</template>

The Template Tag

The template tag encompasses the options for an image bar. It offers RepeaterStyle, RepeaterDrawOrder,and BaseCapStyle properties.

RepeaterStyle - Defines options for drawing the repeater section of the bar.

Options

  • ScaleY - The repeater will be scaled vertically.
  • ScaleXY - The repeater will be scaled in both x and y directions.
  • RepeatFixed
  • RepeatFromCap - The repeater is drawn and repeated after the cap down.
  • RepeatFromBase - The repeater is drawn and repeated after the base up.

RepeaterDrawOrder - Defines the starting point for drawing repeater(s) tiles.

Options

  • FromTopToBottom - Indicates that rendering starts from top of the bar.
  • FromBottomToTop - Indicates that rendering starts from the bottom of the bar.

BaseCapStyle - Defines options that specify how cap and base section are rendered.

Options

  • ScaleY - When the bar gets shorter, the base cap will scale down in the y direction.
  • ScaleXY - When the bar gets shorter, the base cap will scale down in the x and y direction.
  • Cut - When the bar gets shorter, the cap will be cropped from both sides.
  • UpperCut - When the bar gets shorter, the top of the bar will be removed but cap remains similar to the tape_measure ImageBar.
  • LowerCut - When the bar gets shorter, the bottom of the cap will be removed.

The Repeater/Base/Cap Tags

The repeater represents a repeating sections of the imageBar. Base and Cap tags represent the top and bottoms of the ImageBar. They include parameters such as fileName MinHeight, Overlap, Offset and others described here:

  • FileName - File name of the SVG image that should repeat.
  • MinHeight - The minimum size of the repeater.
  • Overlap - The size in pixels that the repeater should overlap.
  • Offset - distance in pixels the repeater is offset.
  • Include_into_value - With the Series.ImageBarSyncToValue option, it indicates whether the repeater should be repeated to represent the value of the bar.

Compiling ImageBars

The provided command line compiler can be used to compile the image bars into *.cache files.

Usage:

...

Send comments on this topic.


Manual Installation

Installation is fully automated with the MSI however if you wish to manually install or xcopy deploy to a remote server you don’t have permissions to run the MSI on you can follow the manual installation steps:

Procedure
1. Run the MSI installer
2. Specify manual installation.
3. Ensure that dotnetCHARTING.dll and your purchase key are located in the /bin directory and that the /bin directory is in the root (top level) of your web site or, if not, that you have created an application for the subdirectory which contains your /bin directory. Note: a key is not required for the trial.
Ensure the temp directories have appropriate permissions set. See below.

4. You may now use the .netCHARTING samples

Using a Virtual Directory
1. Run the MSI installer with manual installation option
2. Place files in any directory you wish.
3. Using the IIS administration (MMC), create a virtual directory under your web site pointing to the /web directory that contains the .netCHARTING samples. Click here for more information on virtual directory creation.
4. Ensure that your purchase key is located in the /bin directory along with dotnetCHARTING.dll. Note: a key is not required for the trial.
5. You may now use .netCHARTING samples

Setting Directory Permissions:

.netCHARTING creates image files dynamically to display charting data. By default, these temporary images are written to the same directory of the calling script, alternatively, the TempDirectory property can be set to a path of your choice. Either way, the ASP.NET worker process must have permissions to write to this directory. If your permissions are not already configured to allow write access, right click on the directory in question and select properties, select security, permissions and add the "IIS AppPool\DefaultAppPool" user with write permissions.

See Image

Troubleshooting

  • If you are missing a security tab, see this article.

If you are remotely hosting contact your web host and ask for write permissions on the directory of your choice. These are the same permissions required to add any data to a database or modify a text or XML file. Your host may also have created a special directory for this case such as /data. In this case you can set the TempDirectory to this directory and make no permissions changes.

Working with Visual Studio:
A step by step guide is provided for working with .netCHARTING in visual studio along with common errors and resolutions you may encounter in this environment. View Guide
See Also
{Using With Visual Studio.net}
{Upgrading}
{Using with WinForms}
Send comments on this topic.


Knowledge Base

.netCHARTING offers an extensive Knowledge Base supporting full text search with detailed articles available to address your support and sales questions 24/7.

If you have any technical questions that the KB does not yet have an entry for please contact support@dotnetcharting.com Customer service is available Monday to Friday, 9am to 5pm Pacific.

Send comments on this topic.


License Agreement
Send comments on this topic.


Licensing And Pricing

Send comments on this topic.


Licensing and Pricing Index

Licensing and Pricing

  • Licensing and Pricing
    Licensing and pricing options.
  • License Agreement
    License agreement.
Send comments on this topic.


.NET 9, .NET 8, .NET 7, .NET 6 & .NET 5

System Requirements: .netCHARTING .NET 9, .NET 8 and .NET 7 can be run on Windows, Linux and macOS by installing the appropriate runtime from https://dotnet.microsoft.com/download/dotnet/9.0 or .NET 8.0 or .NET 7.0. For development, Visual Studio users require Visual Studio 16.8 or later to use .NET 5.0 on Windows or Visual Studio 2022 to use .NET 8.0 and .NET 9 and the latest version of Visual Studio for Mac on macOS. The C# extension for Visual Studio Code already supports .NET 7.0, .NET 8.0, .NET 9.0 and C#9, C# 10, and C# 11.

NuGet Package for .netCHARTING .NET 9: You can download from https://www.nuget.org/packages/dotnetCHARTING.NET9 and generate different chart types with Razor C# or Razor VB syntax, for use in both MVC views as well as in Razor Pages.

.NET 8 Sample bundle: You can download the .NET 8 bundle for use in Visual Studio 2022 or later or Visual Studio Code Important folders/files in the Sample bundle:

DNC.cs: An open source helper wrapper for .netCHARTING to provide the following:

  • Extends the html helper to set .netCHARTING properties quickly in the Razor page.
  • Populates HttpContext and HostingEnvironment and uses them when creating Chart object.
  • Loads database setting from appsettings.json or appsettings.Development.json and formats the connection string. .netCHARTING .NET 9 supports SQLite, SQL server, mySql and Oracle. OleDb/MsAccess is also supported but only when running on Windows.

Pages: Bundle organizer files and Sample files

wwwroot/data: sample data in different formats including: SQLite, XML, Excel and CSV files.

Visual Studio 2022: Open dotnetCHARTINGNET8.cspro in VS 2022, and run the samples using IIS Express Visual Studio Code: .NET Sample bundle can be run with Visual Studio Code using the following steps:
  • Open a new terminal through Terminal menu
  • Navigate to the directory of dotnetCHARTINGNET9.csproj
  • Build the project by entering this command: dotnet build -dotnetCHARTINGNET9.csproj
  • Run the project by entering this command: dotnet run -dotnetCHARTINGNET9.csproj
  • Open a browser to run http://localhost:58260/

NuGet Package for .netCHARTING .NET 8: You can download from https://www.nuget.org/packages/dotnetCHARTING.NET8 and generate different chart types with Razor C# or Razor VB syntax, for use in both MVC views as well as in Razor Pages.

.NET 8 Sample bundle: You can download the .NET 8 bundle for use in Visual Studio 2022 or later or Visual Studio Code Important folders/files in the Sample bundle:

DNC.cs: An open source helper wrapper for .netCHARTING to provide the following:

  • Extends the html helper to set .netCHARTING properties quickly in the Razor page.
  • Populates HttpContext and HostingEnvironment and uses them when creating Chart object.
  • Loads database setting from appsettings.json or appsettings.Development.json and formats the connection string. .netCHARTING .NET 8 supports SQLite, SQL server, mySql and Oracle. OleDb/MsAccess is also supported but only when running on Windows.

Pages: Bundle organizer files and Sample files

wwwroot/data: sample data in different formats including: SQLite, XML, Excel and CSV files.

Visual Studio 2022: Open dotnetCHARTINGNET8.cspro in VS 2022, and run the samples using IIS Express Visual Studio Code: .NET Sample bundle can be run with Visual Studio Code using the following steps:
  • Open a new terminal through Terminal menu
  • Navigate to the directory of dotnetCHARTINGNET8.csproj
  • Build the project by entering this command: dotnet build -dotnetCHARTINGNET8.csproj
  • Run the project by entering this command: dotnet run -dotnetCHARTINGNET8.csproj
  • Open a browser to run http://localhost:58260/

NuGet Package for .netCHARTING .NET 7: You can download from https://www.nuget.org/packages/dotnetCHARTING.NET7 and generate different chart types with Razor C# or Razor VB syntax, for use in both MVC views as well as in Razor Pages.

.NET 7 Sample bundle: You can download the .NET 7 bundle for use in Visual Studio 2022 or later or Visual Studio Code Important folders/files in the Sample bundle:

DNC.cs: An open source helper wrapper for .netCHARTING to provide the following:

  • Extends the html helper to set .netCHARTING properties quickly in the Razor page.
  • Populates HttpContext and HostingEnvironment and uses them when creating Chart object.
  • Loads database setting from appsettings.json or appsettings.Development.json and formats the connection string. .netCHARTING .NET 7 supports SQLite, SQL server, mySql and Oracle. OleDb/MsAccess is also supported but only when running on Windows.

Pages: Bundle organizer files and Sample files

wwwroot/data: sample data in different formats including: SQLite, XML, Excel and CSV files.

Visual Studio 2022: Open dotnetCHARTINGNET7.cspro in VS 2022, and run the samples using IIS Express Visual Studio Code: .NET Sample bundle can be run with Visual Studio Code using the following steps:
  • Open a new terminal through Terminal menu
  • Navigate to the directory of dotnetCHARTINGNET7.csproj
  • Build the project by entering this command: dotnet build -dotnetCHARTINGNET7.csproj
  • Run the project by entering this command: dotnet run -dotnetCHARTINGNET7.csproj
  • Open a browser to run http://localhost:58260/

.NET 6 Sample bundle: You can download the .NET 6 bundle for use in Visual Studio 2022 or later or Visual Studio Code Important folders/files in the Sample bundle:

DNC.cs: An open source helper wrapper for .netCHARTING to provide the following:

  • Extends the html helper to set .netCHARTING properties quickly in the Razor page.
  • Populates HttpContext and HostingEnvironment and uses them when creating Chart object.
  • Loads database setting from appsettings.json or appsettings.Development.json and formats the connection string. .netCHARTING .NET 6 supports SQLite, SQL server, mySql and Oracle. OleDb/MsAccess is also supported but only when running on Windows.

Pages: Bundle organizer files and Sample files

wwwroot/data: sample data in different formats including: SQLite, XML, Excel and CSV files.

Visual Studio 2022: Open dotnetCHARTINGNET6.cspro in VS 2022, and run the samples using IIS Express Visual Studio Code: .NET Sample bundle can be run with Visual Studio Code using the following steps:
  • Open a new terminal through Terminal menu
  • Navigate to the directory of dotnetCHARTINGNET6.csproj
  • Build the project by entering this command: dotnet build -dotnetCHARTINGNET6.csproj
  • Run the project by entering this command: dotnet run -dotnetCHARTINGNET6.csproj
  • Open a browser to run https://localhost:5001 or http://localhost:5000

NuGet Package for .netCHARTING .NET 6: You can download from https://www.nuget.org/packages/dotnetCHARTING.NET6 and generate different chart types with Razor C# or Razor VB syntax, for use in both MVC views as well as in Razor Pages.

Important folders/files in the .NET 5 Sample bundle:

.NET 5 Sample bundle: You can download the .NET 5 bundle for use in Visual Studio 16.8 or later or Visual Studio Code Important folders/files in the Sample bundle:

DNC.cs: An open source helper wrapper for .netCHARTING to provide the following:

  • Extends the html helper to set .netCHARTING properties quickly in the Razor page.
  • Populates HttpContext and HostingEnvironment and uses them when creating Chart object.
  • Loads database setting from appsettings.json or appsettings.Development.json and formats the connection string. .netCHARTING .NET 5 supports SQLite, SQL server, mySql and Oracle. OleDb/MsAccess is also supported but only when running on Windows.

Pages: Bundle organizer files and Sample files

wwwroot/data: sample data in different formats including: SQLite, XML, Excel and CSV files.

Visual Studio 2019: Open dotnetCHARTINGNET5.cspro in VS 2019, and run the samples using IIS Express Visual Studio Code: .NET Sample bundle can be run with Visual Studio Code using the following steps:
  • Open a new terminal through Terminal menu
  • Navigate to the directory of dotnetCHARTINGNET5.csproj
  • Build the project by entering this command: dotnet build -dotnetCHARTINGNET5.csproj
  • Run the project by entering this command: dotnet run -dotnetCHARTINGNET5.csproj
  • Open a browser to run https://localhost:5001 or http://localhost:5000

Send comments on this topic.


Quick Start

Quick Start (Recommended Read)

Thank you for downloading .netCHARTING. As you explore the features and functionality of this component you will find it is extremely powerful and capable to creating any charts you need. This software has been developed to be much more flexible than any component you may have worked with before. This will enable you to push the envelope beyond the features you may have seen explored or imagined.

This section with give a general overview of how everything works and is designed to get you started quickly. So without further ado, let's get to it.

Step 1. Installation

Please see the instructions in the installation help topic to get the component installed and to be able to view the accompanying samples.

After the component is installed, take a look at the samples to get a grasp on some of the features available. You may see some interesting ideas that will let your subconscious start working on your project while you get up to speed.

Step 2. Getting/Using Data

.netCHARTING has a simple yet powerful interface for data acquisition and manipulation. Chart data is represented by SeriesCollection, Series, and Element classes. For more information on this model see this topic. When you are familiar with the general data model, you can explore the connecting to data sources and using query strings sections to find out how to populate these classes automatically.

Advanced
At this point you will be able to generate simple charts, however, this is only scratches the surface of what you can do in the data acquisition phase. You can also manipulate, group by dates, limit top x results, and do many other things with your data. When you are ready to explore the more advanced data features, take a look at the other tutorials available in the Data Tutorials section.

Step 3. Chart Type

An important point to remember is that the data model is independent from the chart engine itself. This means that whatever data you get, you can show any type chart with it. Mechanism behind the chart types is quite flexible and a tutorial is available here.

Step 4. Exploring other features

You will now be able to generate basic charts and have a general idea of how to change the chart type. Most of the time, this is not enough to create the exact chart you need. Fortunately, we have covered only about 5% of the functionality available. Moving forward, there are many tutorials at your disposal. You may also visit the support section of our website to download printable PDF versions of some tutorials so that you can review them at your leasure.

Happy Coding!

Send comments on this topic.


Samples

An extensive suite of example scripts is included with the bundle which demonstrate how easy it is to use .netCHARTING. These samples use hard coded data in addition to an access database which includes 4000+ sample order records for the year of 2022/2023. The concept of a store was used for this demonstration, however, .netCHARTING can be used to chart any type of data, from any scenario, quickly and easily. With as few as 6 simple lines of script, you can have a complete, dynamic, multiple series chart pulled from your own database! Samples are also included that use a datatable directly, XML, and Excel. SQL server is also supported natively and any other databases can be used with the system by passing your datatable / dataset.

Samples are included with the .netCHARTING bundle and can be located in the /csharp and /vbnet directories in the following categories:

Classic
Samples from previous versions of .netCHARTING designed to work with the latest version

Features
Feature specific samples, showing specific functionality in use.

Samples & Getting Data
The classic samples show a shortcut method of getting data. The features samples mostly generate dynamic data which simulates getting data using the dataEngine class. For more information on the DataEngine see this topic, and sample: dataEngine.aspx.

Gallery
Gallery specific samples, showing different charting types with randomly generated data.

If you would like to see a specific sample added please email your request to info@dotnetcharting.com.

All the samples including code in c# and vb.net are also available at http://www.dotnetcharting.com/gallery/.
Send comments on this topic.


Support

Support

Customer satisfaction is of the utmost importance to the .netCHARTING team. It drives development to create the richest possible solutions and compels customer service to pass on their knowledge and experience in the clearest, most effective way.

If you have any sales questions please contact info@dotnetcharting.com

If you have any order or licensing questions please contact orders@dotnetcharting.com

At .netCHARTING we stand behind the quality of our products and support with a total customer satisfaction program including:

  • Fully functional free trial versions prior to purchase
  • 30 days of priority email support after purchase
  • Lifetime "as available" product support
  • Free minor version upgrades
  • No nonsense licensing

If you have any technical questions please contact support@dotnetcharting.com

Before contacting support

In order to provide the best support possible please review the following information before contacting support.

License installation support:
Please review the license installation trouble shooter.

Clients:
Please include your order number (also known as your orderid) within the subject of the email.

If no chart is rendered on your page:
Set Chart.Debug = true to see the specific error or reason your chart was not generated.

Help resources:
There are several help resources available with the downloadable bundle.

  • Dotnetcharting.chm help file included in the download bundle.
  • C# & VB.NET samples covering many scenarios.
  • Complete .netCHARTING gallery including code in C# and VB.NET.
Send comments on this topic.


System Requirements

.netCHARTING is designed to be used in a web server environment.

Supported Operating Systems

  • Windows *
  • Windows 10
  • Wndows Server

Additional Requirements
  • ASP.NET
Downloads and Links
  • If you are running a supported Operating system but are not yet running ASP.NET you can enabled ASP.NET through “Turn Windows Features on or off”. The steps are:
    • Open Control Panel
    • Click Programs and Features
    • Click Turn Windows features on or off
    • Check .NET Framework
Send comments on this topic.


Upgrading

Website Version

Upgrading a website dll is a simple process.

  1. Copy the new dll into your bin folder overriding the previous version.

Server Version

  1. Delete the previous installation
  2. Follow the steps in the bin/readme.txt file to re-install the new dll.

In Visual Studio

  1. Delete the dotnetCHARTING reference in your visual studio project.
  2. Add a new reference pointing to the new dll.
  3. If you have the component in the toolbox.
    1. Remove it by right-clicking > Delete
    2. Add it again, right click on the toolbox > Add/Remove Items > .net Framework Components tab > Browse > find the new dll.
    3. Click OK.
  4. Recompile project.
    For troubleshooting issues, please see the Knowledge Base.
See Also

Upgrade Terms

Upgrades KB Article
Send comments on this topic.