Untitled Document ComponentOne Chart for .NET Untitled Document E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Welcome to ComponentOne Chart 3D for .Net

Welcome to ComponentOne Chart™ 3D for .Net, a .Net control designed to allow developers to create a number of eye-catching 3D charts, chart cached or streaming data, or display complex data sets in a visual format. Using the latest technologies built into Visual Studio.Net, C1Chart for .Net completely manages the underlying complexities of a component chart, allowing developers to concentrate on important application-specific tasks.

C1Chart for .Net was designed to be a powerful, versatile, and easy-to-use chart creation tool. Developers can use C1Chart to create a fully functional Chart that can be fully interacted with by the user. Additionally, developers can use the many different chart types to accurately display complex sets of data and create user-friendly charting applications.

C1Chart for .Net is a charting control for Microsoft Visual Studio.Net developed by ComponentOne LLC.

ComponentOne has a user-friendly distribution policy. We want every programmer to obtain a copy of Chart 3D for .Net to try for as long as they wish. Those who like the product and find it useful may buy a license for a reasonable price. The only restriction is that unlicensed copies of Chart 3D for .Net will display a ComponentOne banner every time they are loaded to remind developers to license the product.

We are confident that you will like ComponentOne Chart 3D for .NET. If you have any suggestions or ideas for new features that you'd like to see included in a future version, or ideas for new controls, please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 • USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

What's New in ComponentOne 3D Chart for .NET

Installing C1Chart3D for .NET

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

Licensing FAQs

Technical Support

Redistributable Files

Namespaces

Creating a .NET Project

Adding the ComponentOne Chart 3D Component to Visual Studio

Overview

Untitled Document
Send feedback to ComponentOne
Copyright © 1987-2005 ComponentOne LLC. All rights reserved.


What's New in ComponentOne 3D Chart for .NET

This documentation was last revised on August 19, 2005. There are no new features in ComponentOne Chart 3D for .NET at this time.


Installing C1Chart3D for .NET

This section describes the setup files and system requirements for ComponentOne Chart 3D for .NET. It also explains how to install demonstration versions of ComponentOne products and uninstall ComponentOne Chart 3D for .NET.

ComponentOne Chart 3D For .NET Setup Files

System Requirements

Installing Demonstration Versions

Uninstalling C1Chart 3D for .NET


ComponentOne Chart 3D For .NET Setup Files

The installation program will create the directory C:\Program Files\ComponentOne Studio.NET, which contains the following subdirectories:

bin | Contains copies of all binaries (DLLs, EXEs) in the ComponentOne Visual Studio.NET package.
Common | Contains support and data files that are used by many of the demo programs.
Help | Contains online documentation for all Studio components.
C1Chart | Contains samples and tutorials for the C1Chart3D component.


System Requirements

· Operating Systems:

-Windows 2000

-Windows 2003 Server

-Windows NT 4

-Windows XP, sp1, sp2

· Environments:

-.NET Framework 1.0

-.NET Framework1.1

-C# .NET

-Delphi

-Visual Basic .NET

· Hard Disk Space: 29 mb hard disk space for storage of the software

· Disc Drive: CD or DVD-ROM drive if installing from CD


Installing Demonstration Versions

If you wish to try ComponentOne Chart 3D for .Net or any of our other products and do not have a registration key, follow the steps through the installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that registered versions will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.


Uninstalling C1Chart 3D for .NET

To uninstall C1Chart 3D for .NET, open the Control Panel application, select the "Add or Remove Programs" option, select C1Chart 3D for .Net and click the "Remove" button.


END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

IMPORTANT-READ CAREFULLY: This End User License Agreement (this "EULA") contains the terms and conditions regarding your use of the SOFTWARE (as defined below). This EULA contains material limitations to your rights in that regard. You should read this EULA carefully and treat it as valuable property.

I. THIS EULA.

1. Software Covered by this EULA. This EULA governs your use of the ComponentOne, LLC ("C1") software product(s) enclosed or otherwise accompanied herewith (individually and collectively, the "SOFTWARE"). The term "SOFTWARE" includes, to the extent provided by C1: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and on-line) and printed materials (the "Documentation").

2. This EULA is a Legally Binding Agreement Between You and C1. If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of federal and State laws, such as copyright infringement.

This EULA is a legally binding agreement between you and C1. You intend to be legally bound to this EULA to the same extent as if C1 and you physically signed this EULA. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms and conditions contained in this EULA. If you do not agree to all of the terms and conditions contained in this EULA, you may not install or use the SOFTWARE. If, for whatever reason, installation has begun or has been completed, you should cancel installation or un-install the SOFTWARE, as the case may be. (You may click on the "exit" button or its equivalent to immediately abort installation.) If you do not agree to all of these terms and conditions, then you must promptly return the SOFTWARE to the place of business from which you obtained it in accordance with any return policies of such place of business. Return policies may vary between or among resellers, and you must comply with your particular reseller's return policies as agreed at the point of purchase. If the place of business from which you purchased the SOFTWARE does not honor a complete refund for a period of thirty (30) days from the date of proof of purchase, then you may return the SOFTWARE directly to C1 for a period of thirty (30) days from the date of your purchase. To return the product directly to C1, you must obtain a C1 Return Authorization Number by contacting C1, and you must forward all items purchased, including the proof of purchase, directly to C1. The return must be postage-prepaid, and post-marked within thirty (30) days from the proof of purchase, time being of the essence. The return option to C1 is only available to the original purchaser of an unopened factory packaged item.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

As provided in more detail below, this EULA grants you two licenses: 1) a license to use the SOFTWARE to develop other software products (the "Development License"); and 2) a license to use and/or distribute the Developed Software (the "Distribution License"). Both of these licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. The following terms have the respective meanings as used in this EULA:

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet. "Web Server" means a type of Network Server that serves other computers more particularly connected to it over an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE. "Developed Web Server Software" means those Developed Software products that reside logically or physically on at least one Web Server and are operated (meaning the computer software instruction set is carried out) by the Web Server's central processing unit(s) (CPU). "Developed Legacy Software" means those Developed Software products that are not Developed Web Server Software, including, for example, stand-alone applications and applications accessed by a file server only. "Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by C1 and are identified as such in the Documentation for distribution by you with the Developed Software. "Developer" means a human being or any other automated device using the SOFTWARE in accordance with the terms and conditions of this EULA.

"Developer Seat License" means that each Developer using or otherwise accessing the programmatic interface or the SOFTWARE must obtain the right to do so by purchasing a separate End User License.

“Source Code” shall mean computer software code or programs in human readable format, such as a printed listing of such a program written in a high-level computer language. The term "Source Code" includes, but is not limited to, documents and materials in support of the development effort of the SOFTWARE, such as flow charts, pseudo code and program notes.

2. Your Development License. You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this EULA.

The SOFTWARE is licensed to you on a Developer Seat License basis.

The Developer Seat License means that you may perform an installation of the SOFTWARE for use in designing, testing and creating Developed Software by a single Developer on one or more computers, each with a single set of input devices, so long as such computer/computers is/are used only by one single Developer at any given time and not concurrently. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional Development License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats, whether the additional developers are accessing the SOFTWARE in a stand-alone environment or on a computer network.

In all cases, you may not use C1's name, logo, or trademarks to market your Developed Software without the express written consent of C1; (b) you must include the following C1 copyright notice in your Developed Software documentation and/or in the "About Box" of your Developed Software, and wherever the copyright/rights notice is located in the Developed Software (“Portions Copyright © ComponentOne, LLC 1991-2002. All Rights Reserved.”); (c) agree to indemnify, hold harmless, and defend C1, its suppliers and resellers, from and against any claims or lawsuits, including attorney's fees that may arise from the use or distribution of your Developed Software; (d) you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Distribution License.

License to Distribute Developed Software. Subject to the terms and conditions in this EULA, you are granted the license to use and to distribute Developed Software on a royalty-free basis, provided that the Developed Software incorporates the SOFTWARE as an integral part of the Developed Software in machine-language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "designtime" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Software only.

4. Specific Product Limitations. Notwithstanding anything in this EULA to the contrary, if the license you have purchased is for any of the following products, then the following additional limitations will apply:

a. ComponentOne Reports for .NET Designer Edition. ComponentOne Reports for .NET Designer Edition includes at least: 1) one dynamic link library (c1.win.c1reportdesigner.dll) file known as C1ReportDesigner Component, 2) one executable (ReportDesigner.exe) file known as C1ReportDesigner Application and, 3) the Source Code of the C1ReportDesigner Application. The C1ReportDesigner Component is subject to the general terms and restrictions set forth in this EULA. The C1ReportDesigner Application is an executable file used to design and prepare reports; the C1ReportDesigner Application may be distributed, free of royalties, only in conjunction with the Developed Software.

Subject to the terms and conditions in this EULA, C1 hereby grants you the right to use the C1ReportDesigner Application Source Code. You are hereby also granted the right to modify such Source Code and to create derivative works that are based on the licensed Source Code. You may distribute the derivative works that you develop, solely in object code format and exclusively in conjunction with and/or as a part of the Developed Software. You are expressly not granted the right to distribute, disclose or otherwise make available to any third party the licensed Source Code, any modified version, derivative work, or any portion thereof, in source code format.

C1 shall retain all right, title and interest in and to the licensed Source Code, and all C1 updates, modifications or enhancements thereof. Nothing herein shall be deemed to transfer any ownership or title rights in and to the licensed Source Code from C1 to you.

SOURCE CODE IS LICENSED TO YOU AS IS. C1 DOES NOT AND SHALL NOT PROVIDE YOU WITH ANY TECHNICAL SUPPORT FOR YOUR SOURCE CODE LICENSE.

b. VSView Reporting Edition. VSView Reporting Edition includes at least one executable file listed as “VSRptX.exe” (where X indicates the version number i.e.7,8, etc.), known as “Designer.” The file "VSRptX.exe”, or any upgrade or future versions of the Designer, are subject to the restrictions set forth in this EULA and may not be distributed with your Developed Software or in any other way.

c. Doc-to-Help and ComponentOne Natural Search. You may use Doc-To-Help to create online help, manuals or other documentation in electronic or printed format (the "Output Documents"). You may distribute and incorporate in such Output Documents those files identified in the documentation as Redistributable Files. Except for those specific Redistributable Files, you MAY NOT distribute the SOFTWARE, in any format, to others.

d. Studio Products. You may not share the component parts of the Studio Products licensed to you with other Developers, nor may you allow the use and/or installation of such components by other Developers.

e. ComponentOne Response and SOAP Channel. ComponentOne Response is intended to be installed on a Network Server. C1 grants to you the following rights to the SOFTWARE: a) Installation: You may install one copy of the SOFTWARE on a single Network Server; b) Use: When installed and initialized, the SOFTWARE creates a database file which contains the embodiment of a solution knowledge base (the database hereinafter referred to as the "Knowledge Base").

You may use the SOFTWARE to create Knowledge Bases on one Network Server only. To create or to operate Knowledge Bases in more than one Network Server, you must purchase one additional SOFTWARE license for each additional Network Server.

5. Updates/Upgrades; Studio Subscription. Subject to the terms and conditions of this EULA, the Licenses are perpetual. Updates and upgrades to the SOFTWARE may be provided by C1 from time-to-time, and, if so provided by C1, are provided upon the terms and conditions offered at that time by C1 in its sole discretion. C1 may provide updates and upgrades to the SOFTWARE for free or for any charge, at any time or never, and through its chosen manner of access and distribution, all in C1's sole and complete discretion.

C1 licenses certain of its separately-licensed products bundled together in a product suite, called the C1 "Studio" product line (the "Studio Products"). The exact separately-licensed products that are bundled into the Studio Products may change from time-to-time in C1's sole discretion. If the SOFTWARE is identified as a C1 "Studio" product, then the SOFTWARE is one of the Studio Products. The SOFTWARE and the Studio Products are revised from time-to-time (meaning, for example, revised with updates, upgrades and, in the case of Studio products, possibly changes to which specific products are included in the bundle). For you to be entitled to receive any such revisions to the SOFTWARE or the Studio Products, as the case may be, you must have a valid SOFTWARE license or a valid Studio subscription. The original purchaser of the SOFTWARE or of a Studio product receives a one-year subscription from the date of purchase of the SOFTWARE. After one year, the Studio subscription and/or the SOFTWARE license must be renewed to continue to be entitled to receive the SOFTWARE and/or the Studio Products revisions as the case may be.

6. Serial Number. Within the packaging of the SOFTWARE, a unique serial number (the "Serial Number") is included, which allows for the registration of the SOFTWARE. The Serial Number is subject to the restrictions set forth in this EULA and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number shall constitute a breach of this EULA, the effect of which shall be the automatic termination and revocation of all the rights granted herein.

7. Evaluation Copy. If you are using an "evaluation copy" or similar version, specifically designated as such by C1 on its website or otherwise, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) contact C1 or one of its authorized dealers to purchase a license of the SOFTWARE, which is subject to the terms and limitations contained herein; and c) any Developed Software may not be distributed or used for any commercial purpose.

III. INTELLECTUAL PROPERTY.

1. Copyright. You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, animations, video, audio, music, text, and “applets” incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by C1, except to the limited extent that C1 may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. C1 reserves all rights not otherwise expressly and specifically granted to you in this EULA.

2. Backups. You may either: (a) copy the SOFTWARE solely for backup or archival purposes; or (b) install the SOFTWARE on a single computer, provided you keep the original solely for backup or archival purposes. Notwithstanding the foregoing, you may not copy the Documentation.

3. General Limitations. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that applicable law expressly permits such activity notwithstanding this limitation.

4. Software Transfers. You may not rent or lease the SOFTWARE. You may transfer the SOFTWARE to another computer, provided that it is completely removed from the computer from which it was transferred. You may permanently transfer all of your rights under the EULA, provided that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any dates, upgrades, this EULA and, if applicable, the Certificate of Authenticity), and that the recipient agrees to the terms and conditions of this EULA as provided herein. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination. Without prejudice to any other rights it may have, C1 may terminate this EULA and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. Export Restrictions. You acknowledge that the SOFTWARE is of U.S. origin. You acknowledge that the license and distribution of the SOFTWARE is subject to the export control laws and regulations of the United States of America, and any amendments thereof, which restrict exports and re-exports of software, technical data, and direct products of technical data, including services and Developed Software. You agree that you will not export or re-export the SOFTWARE or any Developed Software, or any information, documentation and/or printed materials related thereto, directly or indirectly, without first obtaining permission to do so as required from the United States of America Department of Commerce's Bureau of Export Administration ("BXA"), or other appropriate governmental agencies, to any countries, end-users, or for any end-uses that are restricted by U.S. export laws and regulations, and any amendments thereof, which include, but are not limited to, the following:

Restricted Countries: Restricted Countries currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, Montenegro, North Korea, Serbia, Sudan, and Syria.

Restricted End-Users: Any End-User whom you know or have reason to know will use SOFTWARE or Developed Software in the design, development, or production of missiles and missile technology, nuclear weapons and weapons technology, or chemical and biological weapons. Any national of any of the Restricted Countries, wherever located, who intends to transmit or transport the SOFTWARE or Developed Software to one of the Restricted Countries.

Restricted End-Uses: Any use of SOFTWARE and Developed Software related to the design, development, or production of missiles and missile technology, nuclear weapons and weapons technology, or chemical and biological weapons.

These restrictions change from time to time. You represent and warrant that neither the BXA nor any other United States federal agency has suspended, revoked or denied your export privileges. C1 acknowledges that it shall use reasonable efforts to supply you with all reasonably necessary information regarding the SOFTWARE and its business to enable you to fully comply with the provisions of this Section. If you have any questions regarding your obligations under United States of America export regulations, you should contact the Bureau of Export Administration, United States Department of Commerce, Exporter Counseling Division, Washington DC. U.S.A. (202) 482-4811, http://www.bxa.doc.gov.

7. U.S. Government Restricted Rights. The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. For solicitations issued before December 1, 1995, by the United States of America, its agencies and/or instrumentalities (the "Government"), other than the Department of Defense, the use, duplication or disclosure of the software and documentation provided to the Government under this EULA shall be subject to the RESTRICTED RIGHTS as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights clause at 48 CFR ch.1 52.227-19. For solicitations issued before September 29, 1995, by the Department of Defense, the use, duplication or disclosure of the software and documentation provided under this EULA shall be subject to the RESTRICTED RIGHTS as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 48 CFR ch.2 252.227-7013. You will comply with any requirements of the Government to obtain such RESTRICTED RIGHTS protection, including without limitation, the placement of any restrictive legends on the SOFTWARE, and any license agreement used in connection with the distribution of the SOFTWARE. Manufacturer is ComponentOne, LLC, 201 South Highland Avenue, 3rd Floor, Pittsburgh, Pennsylvania 15206 USA. For solicitations issued by the Government on or after December 1, 1995 and the Department of Defense on or after September 29, 1995, the only rights provided in the software and documentation provided herein shall be those contained in this EULA. Under no circumstances shall C1 be obligated to comply with any Governmental requirements regarding the submission of or the request for exemption from submission of cost or pricing data or cost accounting requirements. For any distribution of the SOFTWARE that would require compliance by C1 with the Government's requirements relating to cost or pricing data or cost accounting requirements, you must obtain an appropriate waiver or exemption from such requirements for the benefit of C1 from the appropriate Government authority before the distribution and/or license of the SOFTWARE to the Government.

IV. WARRANTIES AND REMEDIES.

1. Limited Warranty. C1 warrants that the original media, if any, are free from defects for ninety (90) days from the date of delivery of the SOFTWARE. EXCEPT AS OTHERWISE PROVIDED IN THE PRECEDING SENTENCE, AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, C1 EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE, DOCUMENTATION AND ANYTHING ELSE PROVIDED BY C1 HEREBY AND C1 PROVIDES THE SAME IN “AS IS” CONDITION WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH YOU. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

2. Limited Remedy. C1's entire liability and your exclusive remedy under this EULA shall be, at C1's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online or otherwise in C1's discretion; or (c) replace the SOFTWARE with SOFTWARE that substantially performs as described in the SOFTWARE documentation, provided that you return the SOFTWARE in the same manner as provided in Section I.2 for return of the SOFTWARE for non-acceptance of this EULA. Any media for any repaired or replacement SOFTWARE will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. THESE REMEDIES ARE NOT AVAILABLE OUTSIDE OF THE UNITED STATES OF AMERICA. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL C1 BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, EVEN IF C1 HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES IN CERTAIN CASES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

V. MISCELLANEOUS.

1. This is the Entire Agreement. This EULA (including any addendum or amendment to this EULA included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and C1 relating to the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this EULA, whether oral or written. No terms or conditions, other than those contained in this EULA, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, "clicking-through" a questionnaire, etc.) Employees, agents and other representatives of C1 are not permitted to orally modify this EULA.

2. You Indemnify C1. You agree to indemnify, hold harmless, and defend C1 and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, which arise out of or result from your breach of any of the terms and conditions of this EULA.

3. Interpretation of this EULA. If for any reason a court of competent jurisdiction finds any provision of this EULA, or any portion thereof, to be unenforceable, that provision of this EULA will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this EULA will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this EULA will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this EULA is governed by the laws of the Commonwealth of Pennsylvania, without regard to its conflict of laws principles. The parties consent to the personal jurisdiction and venue of the Commonwealth of Pennsylvania, in the County of Allegheny, and agree that any legal proceedings arising out of this EULA shall be conducted solely in such Commonwealth. If the SOFTWARE was acquired outside the United States, then local law may apply.


Licensing FAQs

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting


What is Licensing?

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.


How does Licensing Work?

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

NOTE: The Compact Framework components use a slightly different mechanism for licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the "License" button on the About Box of any ComponentOne product.)

When a licensed component is added to a form or web page, Visual Studio asks the newly created component for licensing information. The component looks for licensing information stored in the system and generates a key, which Visual Studio saves in two files:

1. a "<projectName>.licenses" resource file which contains the actual key and

2. a "licenses.licx" file that contains references to those resources.

These files are automatically added to the project.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the "Show All Files" button in the Solution Explorer's toolbox, or select "Project | Show All Files" from Visual Studio's main menu.

Later, when the component is created at run time, it gets passed the key that was created at design time and can decide whether to simply accept the key, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.


Common Scenarios

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications


Creating components at design time

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.


Creating components at run time

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate key for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).


Inheriting from licensed components

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

1. Add a LicenseProvider attribute to the component.

This will mark the component as licensed. When a component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

[LicenseProvider(typeof(LicenseProvider))]

class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid

{

// ...

}

2. Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.


Using licensed components in console applications

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licensex.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the property window, set the "Build Action" property to "Embedded Resource".


Using licensed components in Visual C++ applications

It seems there is a bug in VC++ 2003. The licenses.licx is ignored during the build process, therefore the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an exe file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the app directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed dlls to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

5. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select properties, and go to the Linker/Command Line option. Enter the following:

/ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

6. Rebuild the executable to include the licensing information in the application.


Troubleshooting

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

If this happens, there must be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild ("Rebuild All" from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the "Show All Files" button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the "Rebuild All" option (not just "Rebuild").


I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (exe or dll) when the project is built. After that, the application can be deployed on any machine, including web servers.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Make sure that the license key is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 - Renew your subscription to get a new license key.

If you choose this option, you will receive a new key that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com/.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.


Technical Support

C1Chart for .Net is developed and supported by ComponentOne LLC, a company formed by the merger of APEX Software Corporation and VideoSoft. Technical support can be obtained using any of the following methods:

ComponentOne Web Site

ComponentOne HelpCentral

Internet E-mail

Peer-to-Peer Newsgroup

Documentation


ComponentOne Web Site

The ComponentOne Web site at www.componentone.com provides a wealth of information and software downloads for C1Chart users:

· Descriptions of the various support options available through the ComponentOne Service Team.

· Answers to frequently asked questions (FAQ's) about C1Chart, organized by functionality. Please consult the FAQ's before contacting us directly, as this can save time and also provide an introduction to other useful information pertaining to C1Chart.

· Free product updates, which provide bug fixes and new features.


ComponentOne HelpCentral

ComponentOne HelpCentral is the new online resource for Visual Studio developers and Help authors. Visit HelpCentral to get information on ComponentOne products, view online demos, get Tech Tips and answers to frequently asked questions (FAQ's), search the ComponentOne knowledgebase and more!


Internet E-mail

For technical support through the Internet, e-mail us at:

support.chart.net@componentone.com

To help us provide the best support, please include the following information when contacting ComponentOne:

· Your ComponentOne product serial number.

· The version and name of your operating system.

· Your development environment and its version.

For more information on technical support, browse to:

www.componentone.com/support


Peer-to-Peer Newsgroup

ComponentOne also sponsors a peer-to-peer newsgroup for C1Chart users. ComponentOne does not offer formal technical support in this newsgroup, but instead sponsors it as a forum for users to post and answer each other's questions regarding C1Chart. However, ComponentOne may monitor the newsgroup to ensure accuracy of information and provide comments when necessary. You can access the newsgroup from the ComponentOne Web site at http://helpcentral.componentone.com/Newsgroups.aspx.


Documentation

ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (.NET, ASP.NET and Mobile Device products only), and PDF format. All of the PDFs are also available on our Web site. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.


Redistributable Files

ComponentOne Chart for .NET is developed and published by ComponentOne LLC. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

· C1.Common.dll

· C1.Win.C1Chart.dll

· C1.Win.C1Chart3D.dll

Site licenses are available for groups of multiple developers. Please contact Sales@ComponentOne.com for details.


Namespaces

Namespaces organize the objects defined in an assembly. Assemblies can contain multiple namespaces, which can in turn contain other namespaces. Namespaces prevent ambiguity and simplify references when using large groups of objects such as class libraries.

The general namespace for ComponentOne Windows products is C1.Win. The namespace for the C1Chart 3D control is C1.Win.C1Chart3D. The following code fragment shows how to declare a C1Chart 3D control using the fully qualified name for this class:

· Visual Basic

· C#

· Delphi

Namespaces address a problem sometimes known as namespace pollution, in which the developer of a class library is hampered by the use of similar names in another library. These conflicts with existing components are sometimes called name collisions.

For example, if a new class named BarColor is created, it can be used inside the project without qualification. However, the C1Chart assembly also implements a class called BarColor. So, if the C1Chart class will be used in the same project, a fully qualified reference must be used to make the reference unique. If the reference is not unique, Visual Studio .NET produces an error stating that the name is ambiguous.

Fully qualified names are object references that are prefixed with the name of the namespace where the object is defined. Objects defined in other projects can be used if a reference to the class is created (by choosing Add Reference from the Project menu) and then using the fully qualified name for the object in the code.

Fully qualified names prevent naming conflicts because the compiler can always determine which object is being used. However, the names themselves can get long and cumbersome. To get around this, use the Imports statement (import in C#) to define an alias — an abbreviated name used in place of a fully qualified name. For example, the following code snippet creates aliases for two fully qualified names, and uses these aliases to define two objects:

· Visual Basic

· C#

· Delphi

If Imports statement are used without an alias, use all the names in that namespace without qualification provided they are unique to the project.

As a warning, unless specified explicitly in the code, it is taken for granted that the

· Visual Basic

· C#

· Delphi

statement has been specified. This applies only to small code samples. Tutorials and other longer samples will specify complete qualifiers.


Creating a .NET Project

This topic demonstrates how to create a new .NET project.

1. From the File menu in Microsoft Visual Studio .NET, select New and click Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic Projects or Visual C# Projects, and select Windows Application from the list of Templates in the right pane.

Enter a name for your new application in the Name field or you can use the default name, WindowsApplication1. Click on the Browse button to the right of the Location field to specify the location of your new project and click OK.

A new Microsoft Visual Studio .NET project is created in the specified location. In addition, a new Form1 is displayed in the Designer view.

3. Double-click the desired C1Chart components from the Toolbox to add them to Form1. For information on adding a component to the toolbox, see Adding the ComponentOne Chart 3D Component to Visual Studio.


Adding the ComponentOne Chart 3D Component to Visual Studio

After installing Chart 3D for .NET on your computer, you need to add its components to the Visual Studio Toolbox. To do this, follow these steps:

1. Open the Visual Studio IDE (Microsoft Development Environment.). Make sure the Toolbox is visible (select Toolbox in the View menu if necessary). Right-click the Toolbox to open its context menu.

If you want the Chart 3D for .NET components to appear on their own tab in the Toolbox, Right-click in the gray Toolbox area and select Add Tab from the context menu and type in the tab name, for example, “C1Chart3D”.

2. Right-click that tab or one of the existing tabs and select Customize Toolbox… from the context menu.The Customize Toolbox dialog box will open.

NOTE: In Visual Studio 2003 you would select the Add/Remove Items option from the context menu.

3. In the Customize Toolbox dialog box, go to the .NET Framework Components tab. Sort the list by Namespace (click the Namespace column header).

4. Select the Browse button to find C1.Win.C1Chart and C1.Win.C1Chart3D.dll namespaces and open them. The .Net component for C1Chart3D will be highlighted in blue. Here you can check the check boxes for the C1Chart and C1Chart3D components that will be installed on your toolbox

5. Double-click the desired C1Chart 3D component from the Toolbox to add it to Form1.


Overview

ComponentOne 3D Chart is a three dimensional charting control that can be used in Windows applications to provide users with professional information display and manipulation capabilities.

3D Chart Control

Use the 3D Chart to create 3D Surface, Contour, or Bar charts that enables end-users with the ability to easily rotate, scale, or zoom interactively. 3D Chart can display 3D data in fifteen basic surface or bar appearances and automatically generate contours and zones from the data.

C1Chart3D for .Net Features

· 100% managed code.

· Surface, Bar and Scatter charts provide various ways to display data.

· Automatically generates contours and zones from the data.

· Interactive viewing allows both the programmer and the end user to utilize chart rotation, shift and zoom.

· Transparent data plotting.

· 4D charts capability.

· Mouse tracking capabilities keep track of the region, series, or data point under the mouse pointer.

· Image generation: Charts can be saved to any number of image formats (metafile, bmp, jpg, and more).

· Interactive wizard.


Using the 3DChart

Using the 3D Chart covers the basics of 3D charting, creation of 3D charts, and modification of chart properties.


3D Chart Basics

Successful charting requires familiarity with basic chart processes and vocabulary, specifically as they relate to the 3D Chart control. The following topics cover basic information that anyone who uses the 3D Chart should be familiar with.

3D Chart Terminology

Choosing the 3D Chart Type

Meshed and Shaded Charts

Contour and Zoned Charts

2D Projection View

Understanding 3D Data Layout

Using the Chart 3D Wizard and Chart Properties


3D Chart Terminology

The following shows the terms used to describe chart elements.


Choosing the 3D Chart Type

The 3D Chart displays data as a 3D Surface chart, a 3D Bar chart, or 3D Scatter Plot. Use the ChartType property to specify whether to display data as a Surface chart, Bar chart, or Scatter Plot. The ChartType property is located in the ChartGroupCollection Editor, which can be accessed through the Chart3DGroups property in the .Net Properties Window.

Chart3DTypeEnum.Scatter

Chart3DTypeEnum.Bar

Chart3DTypeEnum.Surface

For more information on 3D Bar charts, see Special 3D Bar Chart Properties. For more information on 3D Scatter plots, see Special Scatter Plot Properties.


Meshed and Shaded Charts

The basic appearance of the Surface and Bar chart types is controlled by the combination of two properties: IsMeshed and IsShaded.

Using IsMeshed

Surfaces: The chart displays the X-Y grid projected onto the 3D surface in a 3D view with a Z-axis. The chart honors rotation and perspective control.

Bars: The chart draws the outline of all bars.

Using IsShaded

Surfaces: The chart displays the data as a flat shaded surface in a 3D view with a Z-axis. Top and bottom shading colors may be set. The chart honors rotation and perspective control.

Bars: The chart draws the bars as a flat shade.

To Change the Basic Appearance

Use a combination of the IsMeshed and IsShaded properties to set the chart’s basic appearance. These properties are located in the Chart3DGroup Collection Editor (IsMeshed and IsShaded under the Elevation node) that can be accessed through the ChartGroups property in the .Net Properties Window.


Mesh

Surface Example | Bar Example

Note: The chart’s top and bottom mesh color and other mesh properties can be customized.


Shaded

Surface Example | Bar Example

Note: The chart’s top and bottom surface color and other surface properties can be customized.


Shaded+Meshed

Surface Example | Bar Example

Notes:

· The chart’s top and bottom mesh color and other mesh properties can be customized.

· The chart’s top and bottom surface color and other surface properties can be customized.


Contour and Zoned Charts

Using IsContoured

Surfaces: The chart examines the distribution of the data and draws contour lines demarcating each of the contour levels.

Bars: The chart draws contour lines around the bars, demarcating each contour level.

Using IsZoned

Surfaces: The chart examines the distribution of the data and fills each level with a solid color.

Bars: The chart fills each level within each bar with a solid color.

Scatter: The points are colored according to their z-value.

To Change the Basic Appearance

Use a combination of the IsContoured and IsZoned properties to set the chart’s basic appearance. These properties are located in the Chart3DGroup Collection Editor (IsContoured and IsZoned are under the Contour node) that can be accessed through the ChartGroups property in the .Net Properties Window.


Contours

Surface Example | Bar Example

Note: The chart’s contour levels, ContourStyles, and other contour properties can be customized.


Zones

Surface Example | Bar Example
Scatter Example |

Note: The chart’s contour levels, ContourStyles, and other zoning properties can be customized.


Contours, Zones

Surface Example | Bar Example

Note: The chart’s contour levels, ContourStyles, and other contour and zoning properties can be customized.


2D Projection View

It is possible to quickly look at any chart from all side of plotting cube using View3D property of Chart3DView object. It can be set with any number of the View3DEnum constant values.

The View3DEnum constant values are:

View3DEnum.Default | Default 3D view.
View3DEnum.XY_2D_Pos | View X-Y plane from positive direction of Z-axis.
View3DEnum.XY_2D_Neg | View X-Y plane from negative direction of Z-axis.
View3DEnum.XZ_2D_Pos | View X-Z plane from positive direction of Y-axis.
View3DEnum.XZ_2D_Neg | View X-Z plane from negative direction of Y-axis.
View3DEnum.YZ_2D_Pos | View Y-Z plane from positive direction of X-axis.
View3DEnum.YZ_2D_Neg | View Y-Z plane from negative direction of X-axis.

Default view | XY_2D_Pos(Top view)
XZ_2D_Neg | YZ_2D_Neg


Understanding 3D Data Layout

The 3D chart displays three-dimensional data. Each data point consists of an X/Y Cartesian coordinate and a Z elevation value. It charts surfaces that are increasing in X and Y and cannot chart surfaces that fold back in X or Y (such as a sphere).

The data must be supplied in one of three basic layouts, Grid, Irregular Grid, or Point. Data can come from many different sources, such as data files or the results of mathematical formulae. Data files can be loaded and saved, and data itself can be customized using the .Net Properties Window.

Grid Layout

Irregular Grid Layout

Point Layout

Holes in the Data

To Edit Grid and Irregular Grid Data

To Edit Point Data


Grid Layout

Use Grid layout when the X-coordinates of each point and the Y-coordinates of each point are always the same distance apart. The following diagram illustrates the characteristics of Grid layout.

The important Grid layout characteristics are:

· The number of rows and columns, the origins, and the single row and column delta value defines the X/Y grid.

· The grid spacing for all rows is set by the RowDelta property. The grid spacing for all columns is set by the ColumnDelta property.


Irregular Grid Layout

Use Irregular Grid layout when the X-coordinates of each point or the Y-coordinates of each point are not the same distance apart. The following diagram illustrates the characteristics of Irregular Grid layout.

The important Irregular Grid layout characteristics are:

· The number of rows and columns, the origins, and the irregular grid spacing deltas defines the X/Y grid.

· Each row and column has its own RowDelta/ColumnDelta value that sets the grid spacing between that row/column and the previous one.


Point Layout

Use Point Layout for scatter plots when charting multiple series of points. The following diagram illustrates the characteristics of Point layout.

The important Point layout characteristics are:

· The points are grouped into one or more series.

· Its X, Y, and Z Cartesian coordinates specify each individual point.


Holes in the Data

Use the HoleValue property to set the data value that represents a hole in the data. When the chart sees values in the data grid that are the same as the hole value it displays as a hole in the chart.


To Edit Grid and Irregular Grid Data

Use the Layout, RowCount, and ColumnCount properties to set the format and size of the data. Use the Hole, RowOrigin, ColumnOrigin, RowDelta, ColumnDelta, and Item properties to define the data itself. These properties are located under the ChartData Node in the Chart3DGroup Collection Editor.

For more information, see the 3D Data topic.


To Edit Point Data

Use the Layout property to set the chart type. Use the SeriesCollection property to add or remove series in the scatter plot, which creates a Chart3DPoint collection for each series of data. Use the Points property of Chart3DPointSeries class to set an array of data points for an individual series.

For more information, see the 3D Data topic.


Using the Chart 3D Wizard and Chart Properties

Chart3D Wizard and Chart Properties provide an easy and interactive way to create and modify chart properties.

To start Wizard or access Chart Properties in design time:

· Right-click on the C1Chart3D control. Select Chart3D Wizard from context menu.

· Right-click on the C1Chart3D control. Select Chart Properties from context menu.


Step1. Gallery

Choose desired Chart type and Chart sub-type from Gallery.


Step2. Data

Select proper data layout and edit data. To find more information on the properties in this data tab, see the 3D Data topic.


Step3. View

The 3D-View tab allows modification of the 3D appearance of the chart.


Creating 3D Charts

In this section, the aspects of 3D chart creation are broken down into four constituent parts, and then described in detail. The 3D Axes section covers the axes of the chart. The 3D Data section details how data is configured in the 3D Chart and how it is loaded and saved. The Customizing 3D Chart Elements section provides information on how to customize the various visual aspects of the chart. Finally, the 3D User Interaction section provides information on interactions the user can have with the chart at run-time.

3D Axes

3D Data

Adding Rows and Columns

Drawing 4D Charts

Point Data

The PointSeries Collection

Data Points

Loading Data From a File

Loading the Data

Charting Data Directly From The Program

Displaying 4D Data

Customizing 3D Chart Elements

Zoning Method

Formatting the Chart3DLegend

Legend Type and Orientation

Formatting the Mesh

Modifying Borders

Modifying Fonts

Modifying Colors

Positioning 3D Chart Elements

Using Chart3DLabels

Using ContourStyles

Customizing the Distribution Table

Creating a Custom Distribution Table

Special 3D Bar Chart Properties

Special Scatter Plot Properties

The Chart3D Styles Collection

Formatting Drop Lines

Formatting Symbols

Transparency

3D User Interaction

Returning Coordinate Values


3D Axes

Annotating the Axes

3D Values Annotation

3D ValueLabels Annotation

DataLabels Annotation (X- and Y-axes only)

Axis Labeling Programming Considerations

Setting Chart3DAxis Bounds

Titling Axes


Annotating the Axes

The annotation along each axis is an extremely important part of any chart. The 3D chart can annotate any axis with numbers based on the data (Values) or with text displayed at axis coordinates (ValueLabels). The X- and Y-axes can also be annotated with text for each point in the data (DataLabels).


3D Values Annotation

Values annotation automatically generates numeric annotation based on the data itself. Values annotation can be used for any axis.

Use the axis AnnoMethod property to specify Values annotation for an axis. The AnnoMethod property can be set through the Chart3D Axis Collection Editor. This editor can be accessed by:

· Expanding the ChartArea node in the Visual Studio Properties Window.

· Clicking on the ellipsis adjacent to the Axis property.


3D ValueLabels Annotation

A very flexible type of annotation, ValueLabels displays text defined at a specific axis coordinate. This is useful to label only specific coordinates, or to produce annotation in a form that the chart does not provide. ValueLabels annotation can be used for any axis.

Every label displayed on the axis is one ValueLabel. Each ValueLabel has a Value property and a Text property.

Use the Value property to set the axis coordinate to display the label. Use the Text property to specify the text to display. All ValueLabels properties are located on the Chart3DLabel Collection Editor, which can be accessed by:

· Expanding the Labels node in the Chart3Daxis Collection Editor window.

· Clicking on the ellipsis adjacent to the Labels property.

Set AnnoMethod to ValueLabels for an axis and use this editor to define the labels.


DataLabels Annotation (X- and Y-axes only)

DataLabels are a collection of labels that display text defined at each point along the X- or Y-axes. DataLabels annotation cannot be used for the Z-axis.

Use the RowLabels and ColumnLabels ChartGroups properties to define and edit DataLabels. These properties can be accessed through the Chart3DDataLabel Collection Editor. The respective editors for RowLabels and ColumnLabels can be accessed by:

· Expanding the ChartGroups node in the Visual Studio Properties Window.

· Clicking on the ellipsis adjacent to the ColumnLabels or RowLabels properties.

Set AnnoMethod to DataLabels for an axis and use this tab to define the labels.

DataLabels annotation can be used only for regular and irregular grid data.


Axis Labeling Programming Considerations

There are three distinct ways to label axes when using the 3D Chart control:

· The axis can be automatically labeled based on the range of data.

· Surface lines or bar row/columns can be individually labeled.

· Labels can be placed at explicit locations along an axis.

The axis labeling method in use for a particular axis is specified by the AnnoMethod property. The AnnotationMethodEnum specifies valid values for this property.

If the AnnoMethod property is set to AnnotationMethodEnum.Values, C1Chart3D will automatically annotate the axis based on the range of the data. This is most suitable for the Z-axis, and for surface charts.

If the AnnoMethod property is set to AnnotationMethodEnum.DataLabels, C1Chart3D uses a list of strings to annotate each grid line or bar. This labeling method can only be used on the X- and Y-axes. For the X-axis, the labels are supplied by setting the RowLabels property of the Chart3DGroups object for the chart. For example, the following code specifies three data labels for each of the three rows of a chart:

· Visual Basic

· C#

· Delphi

Similarly, labels for the Y-axis are supplied by setting the ColumnLabels property of the Chart3DGroups object.

If the AnnoMethod property is set to AnnotationMethodEnum.ValueLabels, C1Chart3D places labels at explicit locations along an axis. The ValueLabels property, which is a ValueLabels collection, supplies this list of strings and their locations. For example, the following code sets chart labels at the locations 10, 20 and 30:

· Visual Basic

· C#

· Delphi


Setting Chart3DAxis Bounds

The chart usually recalculates and redraws the axes whenever data changes. The bounds of any axis can be fixed so that it is not recalculated when data changes. For the X- and Y-axes, a portion of data can be framed by setting axis bounds inside the data bounds.

To Set the Axis Minimum and Maximum:

Use the Axes Min and Max properties to fix the minimum or maximum axis extent at a particular value. AutoMax and Automin properties allow the chart to automatically determine axis bounds based on the data bounds. These properties are located on the Chart3DAxis Collection Editor. This editor can be accessed by:

· Expanding the ChartArea node in the Visual Studio Properties Window.

· Clicking on the ellipsis button adjacent to the Axes property.

Z-axis Notes

The Z-axis minimum/maximum cannot be set inside the Z-range of the data. If a fixed extent exists for the Z-axis and a subsequent data change puts the range outside of the axis, the chart sets the Z-axis AutoMax and AutoMin properties so that its extent is recalculated.

X- and Y-axis Notes

The X- and Y-axis minimum/maximum cannot be set to a location that does not coincide with a line of data. The values are always adjusted upwards to coincide.


Titling Axes

Adding a title to an axis clarifies what is charted along that axis. A title with a specified font can be added to any axis.

To Add an Axis Title:

Use the axis Title property to add a title to an axis. To remove the title, delete the text.

Title Font

Use AxisTitleFont property of Axes collection to specify font for the axis titles. All axes titles use the same font. See Modifying Fonts for more information on using Fonts.

Note: The axis title font size is measured in hundredths of the unit cube size.


3D Data

The following topics explain how to plot, setup, copy and configure data for use with C1Chart3D.

Data Organization

Handling Missing Data

Grid and Irregular Grid Data

Changing Data Values


Data Organization

Data in a chart is organized into ChartGroups. In 3D Chart, a ChartGroup is represented by a ChartGroup object. At present, only one ChartGroup can be stored in a Chart Group Collection.

Within a Chart Group, the three-dimensional data to be displayed is assumed to come either from a grid surface, or from one or more series of points. This data is represented by the Set property of Chart3DData class, which is of Chart3DDataSet type. Chart3DDataSet class is a base abstract class for all data types. The data displayed can be in one of three formats:

· Regularly-grid data, in which the X- and Y-grid lines are evenly spaced (Chart3DDataSetGrid).

· Irregularly-grid data, in which the X- and Y-grid lines are not evenly spaced (Chart3DDataSetIrGrid).

· Point data, in which the X, Y and Z-coordinates can be specified without restrictions (Chart3DDataSetPoint).

To set the data format, create one from three datasets and assign it to the Set property of Chart3DData or set the Layout:Chart3DData property to the appropriate data layout constant. The second way is useful in design-time.


Handling Missing Data

If one coordinate for a data point is set to a special value known as the hole value, the chart treats the data point as a missing value, and does not display it on the chart. This hole value is specified by the Hole property of the Chart3DDataSet object.

For example, the following code treats the point in the third row and first column as a missing value:

· Visual Basic

· C#

· Delphi


Grid and Irregular Grid Data

For grid and irregular grid data, the Chart3DdataSetGrid and Chart3DDataSetIrGrid objects define the following properties that control the data to be displayed in the chart:

· The RowCount and ColumnCount properties define the number of rows and columns of data.

· The RowOrigin and ColumnOrigin properties specify the origins of the X-axis and Y-axis respectively.

· Regular grid: RowDelta and ColumnDelta are properties that specify the space between neighboring rows and columns.

· Irregular grid: RowDeltaArray and ColumnDeltaArray are indexed properties that specify the space between neighboring rows and columns.

· The Item property specifies the Z-coordinate of a particular data point. This property is indexed by row and column. For example, the statement

· Visual Basic

· C#

· Delphi

assigns the Z-coordinate of the point in the first row and third column to Zval.


Changing Data Values

To change a data value displayed in the chart, set its Item property. For example, the following statement changes the value of the point in the third row and second column to 3.14159:

· Visual Basic

· C#

· Delphi


Adding Rows and Columns

To add rows to a chart group, do the following:

· Set the RowCount property to the new number of rows.

· If the data is irregularly-grid, set the RowDeltaArray property for the space between a new row and its predecessor.

· Set the Item property for each of the new points.

For example, the following code adds a fourth row of three points to a ChartGroup:

· Visual Basic

· C#

· Delphi

New columns can be added in much the same way:

· Set the ColumnCount property to the new number of columns.

· If the data is irregularly-grid, set the ColumnDeltaArray property for the space between a new column and its predecessor.

· Set the Item property for each of the new points.


Drawing 4D Charts

3D Chart enables developers to represent four-dimensional plots and Bar charts using color as the fourth dimension. For details, see Displaying 4D Data.


Point Data

The data for the point data format is accessed by series. A series can be added or removed using the Collection Editor in design-time or do it programmatically using AddSeries and RemoveSeries method of Chart3DDataSetPoint class.


The PointSeries Collection

Individual series are accessed via the SeriesCollection property of the Chart3DDataSetPoint object. The number of points in the series can be determined via the read-only Count property.

The Points property of Chart3DPointSeries class gives access to the points array of the series. It returns array of Chart3DPoint that represent coordinates of data points. To set new data points for the series, assign Points property to the new array of Chart3Dpoint.

Examples

The following creates point dataset and adds two series to it:

· Visual Basic

· C#

· Delphi

The following sets up a new array of data points to the first series:

· Visual Basic

· C#

· Delphi


Data Points

The coordinates of specific points are accessible via the properties of their respective Chart3DPoint structure. To retrieve the Chart3DPoint for a coordinate, use the Item method of the Chart3DpointSeries. The following code sets the coordinates of the third point of the second series to (1, 1, 1):

· Visual Basic

· C#

· Delphi


Loading Data From a File

A common task in any C1Chart3D program is to load the chart data (called a dataset) from a file into a format that the chart can use.

In order for C1Chart3D to allocate and load the data from a file, it must be in one of three basic layouts: Grid, Irregular Grid, or Point. Use the Grid format for Surface and Bar charts when the X-coordinates of each point and the Y-coordinates of each point are always the same distance apart. Use the Irregular Grid format for Surface and Bar charts when the X-coordinates of each point or the Y-coordinates of each point are not the same distance apart. Use the Point format for multiple series of points in scatter plots.

See Understanding 3D Data Layout for more information on Grid, Irregular Grid, and Point layout.

The following examples illustrate the Grid, Irregular Grid, and Point file formats.


Grid File Format

! Grid has 50 by 30 points

! Holes have a value of 100.0

! Grid increases in X steps of 1.0 and Y steps of 2.0

! Origin of grid is at X = -20, Y = 50

GRID 50 30

100.0 1.0 2.0 -20.0 50.0

! 1500 data values follow, one for each grid point

49.875000 43.765625 38.500000 33.984375 30.12400

26.828125 24.000000 21.235610 48.877940 17.39770

. . .

Line 5 indicates that the file format is Grid, and the file contains 50 by 30 data points. Line 6 indicates the hole value (100.0), the X and Y increments (1.0 and 2.0), and the coordinates for the origin.

Lines beginning with a "!" are comments and are ignored by the control.


Irregular Grid Format

! Irregular grid has 10 by 5 points

! Holes have a value of 100.0

! Ten X values are given, and then five Y values

IRGRID 10 5

100.0

20 21.1 23.4 24.4 25.0 27.8 29.9 31.0 32.6 33.2

50.3 51.3 52.6 54.8 59.6

! 50 data points follow

23.34563 12.89239 11.99423 15.781212 18.81988

. . .

Line 4 indicates that the file is in the Irregular Grid format, and has 10 by 5 points. Line 5 shows the hole value (100.0). Line 6 contains the 10 X values, and line 7 contains the 5 Y values.

Lines beginning with a "!" are comments and are ignored by the control.


Point File Format

! Point has 2 series.

! Holes have a value of 100.0

POINT 2

100.0

! The first series has 5 points

5

! X Y Z

5.65 6.24 1.78

7.41 7.26 4.21

5.45 5.44 1.43

0.97 9.66 3.41

3.86 1.42 0.20

! The second series has 3 points

3

8.49 -1.28 8.76

8.14 0.42 6.06

7.17 -3.80 4.11

Line 3 indicates that the file Is in Point format, and has 2 series. Line 6 shows the hole value (100.0). Line 8 indicates that the first series has 5 points. Lines 10–14 contain the X, Y, and Z-coordinates of the 5 points in the first series. Line 16 indicates that the second series has 3 points, and the three following lines specify the coordinates of the 3 points.

Lines beginning with a "!" are comments and are ignored by the control.


Loading the Data

The Chart3DData's LoadDataFromFile method can be used to allocate and load data from a file:

· Visual Basic

· C#

· Delphi


Charting Data Directly From The Program

Often it may not be convenient to load chart data from a file. For example, if the data is created from within the program using a mathematical calculation, it makes more sense to read it into the chart directly instead of saving it to a file and then reading it again. Not only can this method be quicker, it can also be quite easy to program.

The following example creates a regular grid dataset using a precalculated two-dimensional array and then transfers it to the chart:

Note: Delphi users can use the GetJaggedGridData and SetJaggedGridData methods instead of the GridData property.

· Visual Basic

· C#

· Delphi


Displaying 4D Data

A 4D chart uses color to display a fourth dimension of data on a 3D Surface or Bar chart. The colors come from a second set of data that the chart uses for the zoning and contouring colors. 4D charts are useful for visualizing two sets of identically sized data in one chart.


Creating 4D Charts

Use the following steps and conditions to create a 4D chart:

1. Add the grid dataset (regular or irregular) data to the chart. See Understanding 3D Data Layout for information on adding data to a chart.

2. Add the contour data to the chart. This data will be used to derive the zoning and contouring colors for the fourth dimension of chart information. The contour data is defines by ContourData property of Chart3DData object.

3. Set the IsShaded or/and IsZoned Contour object properties of Chart3DGroup.

Note: Delphi users can use the GetJaggedGridData and SetJaggedGridData methods instead of the GridData property. Similarly, you can use the GetJaggedContourData and SetJaggedContourData methods instead of the ContourData property.

· Visual Basic

· C#

· Delphi

In Bar charts, each bar is displayed as a single solid color according to the zoned height of the bar:

In Surface charts, the fourth dimension is displayed as zoning and contouring colors.

Note: The grid dataset and contour data array must have the same dimensions. If these conditions are not met, a 4D chart is not displayed.


4D Bars Charts Notes

· When a set of contour data is added to a Bar chart and the IsZoned Contour property is set, each bar is drawn with one color (determined by the zoned height of the bar) instead of being drawn as separate colored segments.

· Contours are never drawn when contour data is added.


Customizing 3D Chart Elements

When the chart data and axes are formatted properly, its elements can be customized to make it look clearer and more professional. The following topics cover tasks that customize the appearance of a chart:

Creating Header and Footer Titles

Title Text and Alignment

Title Positioning

Title Border

Title Colors

Title Font

Modifying the Surface Appearance

Surface Colors


Creating Header and Footer Titles

A chart can have two titles, one called the Header and one called the Footer. A title consists of one or more lines of text with an optional border. Both the title and border can be customized. Because each title can be positioned above, below, and to the right or left of the chart, they do not adhere to the traditional concept of Header and Footer at the top and bottom of an object. In addition, the text alignment, positioning, colors, and font used for the Header or Footer can be modified.


Title Text and Alignment

Use the Text property of the Title class to add, change, or remove text for a title. Text is located in the property editor under corresponding title node (Footer and Header).

Use the HorizontalAlignment and VerticalAlignment of the Title’s Style property to specify whether to center, left-justify, or right-justify. These properties can be accessed through the Style node in either the Header or Footer node in the Visual Studio property editor.


Title Positioning

Use the Compass property of the Title class to specify where to position the Titles relative to the ChartArea. Select from four compass points around the ChartArea.

Use the X and Y location properties to customize the location of the title. To restore auto location auto-selection set left or top to -1.

Use the Width and Height properties to customize the size of the title. To restore auto size selection set width or height to -1. These properties can be accessed through the Size node in either the Header or Footer node in the Visual Studio property editor.

See Positioning 3D Chart Elements for more information.


Title Border

Use the Type and Width border properties to customize the title’s border. These properties can be accessed through the Style node in either the Header or Footer node in the Visual Studio property editor. See Modifying Borders for more information.


Title Colors

Use the ForeColor and BackColor properties to customize background and text colors of a title. These are located under Style node of the property editor. See Modifying Colors for more information.


Title Font

Use the font properties to customize the font used for a title. These are located on the Style node of property editor. See Modifying Fonts for more information.


Modifying the Surface Appearance

The shaded surface (drawn when the IsShaded property of the Chart3DElevation class is used) has color and appearance properties that can be customized. The zoning method (drawn when the IsZoned property of the Chart3DContour class is used) can also be customized.


Surface Colors

Use the ShadedBottomColor and ShadedTopColor properties of the Chart3DElevation class to set the shading colors. These properties can be accessed at design-time under the Elevation node, which is located in the ChartGroup Collection Editor in the Visual Studio Properties Window.


Zoning Method

Use the ZoneMethod property of the Chart3DContour object to specify how to determine each zone region. Contour zoning uses the contour intervals for each zone region, while cell zoning uses the rectangular block formed by the X/Y grid. Cell zoning produces a coarser-looking surface but redraws significantly faster than contour zoning. ZoneMethod can be accessed at design-time through the Contour node, which is located in the ChartGroup Collection Editor in the Visual Studio Properties Window.


Formatting the Chart3DLegend

The chart automatically generates a Legend whenever contours or zones are drawn. When using contours only, the Legend shows the value represented by each contour line. When using zones, the Legend shows the value represented by each zone level. The layout, positioning, border, colors and font used for the Legend can be customized.


Legend Type and Orientation

Use the Type property of the Chart3DLegend class to specify whether to draw the legend in a continuous or stepped style. Continuous legends take less space on the screen than stepped. The Type property can be accessed through the Legend node of the Visual Studio Properties Window.

Continuous Legend

Stepped Legend

Legend Positioning

Legend Title

Legend Border

Legend Colors

Legend Font


Legend Positioning

Use the legend’s Compass property to specify where to position the legend relative to the ChartArea. Select from four compass points around the ChartArea. Compass can be accessed under the Legend node of the Visual Studio Properties Window.

By default the chart automatically positions the legend. Use the X and Y location properties to fine-tune the positioning. These properties can be accessed through the Location node that is under the Legend node of the Visual Studio Properties Window.

By default the chart automatically calculates size of the legend. Use the Width and Height size properties to fine-tune the size of legend. These properties can be accessed under the Size node that is under the Legend node of the Visual Studio Properties Window.

See Positioning 3D Chart Elements for more information.


Legend Title

Use the Text property to specify the legend title. The legend title appears centered at the top of the Legend. The Text property can be accessed at design-time under the Legend node in the Visual Studio Properties Window.


Legend Border

Use the Type and Width border properties to customize the title’s border. These properties can be accessed under the LegendStyle node that is under the Legend node of the Visual Studio Properties Window. See Modifying Borders for more information.


Legend Colors

Use the BackColor and ForeColor properties to customize background and text colors of the Legend. These can be accessed through the LegendStyle node of the Visual Studio Properties Window. See Modifying Colors for more information.


Legend Font

Use the font properties to customize the font used for the Legend. These can be accessed through the LegendStyle node of the Visual Studio Properties Window. See Modifying Fonts for more information.


Formatting the Mesh

The mesh (drawn when the IsMeshed property of the Chart3Delevation class is used) has display, color, and filtering properties that can be customized. Mesh filtering is particularly useful when displaying a large amount of data in a small space.


Mesh Filtering

Use the ColumnMeshFilter and RowMeshFilter properties of the Chart3DSurface class to define how to filter the display of mesh lines. The chart can automatically determine the best filter, or specify a positive integer to use.

· When set to 0, the chart automatically determines the best filter based on the density of the mesh. As the chart data increases or the size of the chart control decreases, the chart performs more mesh filtering.

· When greater than 0, the chart provides fixed mesh filtering. Higher values cause fewer mesh lines to be drawn. For example, a value of 5 filters the mesh so that every fifth mesh line is drawn.

The ColumnMeshFilter and RowMeshFilter properties can be accessed at design-time under the Surface node of ChartGroup Collection Editor.


Mesh Display

Use the IsColumnMeshShowing and IsRowMeshShowing properties to display or hide the mesh lines. These properties can be accessed under Surface node of the ChartGroup Collection Editor.


Mesh Colors

Use the MeshBottomColor and MeshTopColor properties of the Chart3DElevation class to set the mesh colors. These properties can be accessed under the Elevation node of the ChartGroup Collection Editor.


Modifying Borders

Adding a border to part of the chart can help highlight important information, or simply make the chart look more attractive. Customize the border type and width of the following chart elements:

· Header and Footer titles;

· Legend;

· ChartArea;

· The entire chart.

The valid border types are shown below, though it can also be specified that no border be used:


To Change a Border

Use the border Type property to set the type of border and the Width property to set its thickness. These properties are located under the Style nodes, which can be found on the Control: ChartArea, Titles, Legend, and ChartLabels objects in the Visual Studio Properties Window.


Modifying Fonts

A chart can have more impact when customized fonts are used for different chart elements. The font size can be adjusted to make an element better fit the overall size of the chart. The chart uses two kinds of fonts sizing: non-scalable fonts and scalable fonts. Non-scalable fonts are always the same size. The scalable fonts is scaling when PlotCube size is changing. The following table lists the type of font used by each chart element:

Uses Non-Scalable Font | Uses Scalable Font
Header title | Axis annotation
Footer title | Axis title
Legend |


To Change Fonts

Use the standard .Net Font Property editor to set the font, style, and size attributes. Font properties are located under the Style nodes of the Visual Studio Properties Window.


Axis Annotation, Axis Title, or ChartLabel Fonts

For scalable fonts the Size property is measured in hundredths of the PlotCube length, for example, a value of 8 means the characters are 8% of the length of the PlotCube height.


Modifying Colors

Color can powerfully enhance a chart’s visual impact. Colors can be customized using color names, RGB values, or interactively using a color chooser. Each of the following visual elements in the chart has a background and foreground color that can be customized:

· The entire chart;

· Header and Footer titles;

· Legend;

· ChartArea;

· PlotCube (background only);

· Each ChartLabel added to the chart.

The mesh, contour lines, surface shading, and zone fills also have color properties that can be customized.

Choosing Colors Interactively

Specifying RGB Colors

Using Transparent Colors

To Change a Color


Choosing Colors Interactively

Choose colors interactively using a color dialog that works just like the standard Windows color dialog. Select from Windows basic colors, custom colors, or interactively choose from a full color spectrum.


Specifying RGB Colors

Alternately, a color can be specified by its RGB components, useful for matching another RGB color. RGB color values combine hexadecimal values for the red, green, and blue components of a color. “00” is the smallest value a component can have; “ff” is the largest value. For example, “#ff00ff” specifies magenta (the maximum value of red and blue combined with no green).


Using Transparent Colors

The background and foreground of all elements except the chart itself can be “Transparent”.

When a background or foreground is transparent, the chart uses the color of the element outside it for the background. For example, the Header would have the background of the chart itself when its background is set to Transparent.

In other words, if the background color of the element is transparent then its background is not drawn. If the foreground color of the element is transparent, then the foreground (for example the text of a title) is not drawn.

The transparent color options are on the Web tab of the .Net color dialog.


To Change a Color

Use the BackgroundColor and ForegroundColor properties to set background and foreground colors. These properties are located under Style node, found on the Control, Titles, Legend, ChartArea, PlotCube, and ChartLabels nodes of the Visual Studio Properties Window.


Positioning 3D Chart Elements

Each of the main chart elements (Header, Footer, Legend, ChartArea, and ChartLabels) has properties that control its position and size. While the chart can automatically control these properties, the following can also be customized:

· Positioning of any element except ChartLabels.

· Size of any elements.

When the chart controls positioning, it first allows space for the Header, Footer, and Legend, if they exist (size is determined by contents, border, and font). The ChartArea is sized and positioned to fit into the largest remaining rectangular area. Positioning adjusts when other chart properties change.


To Change or View Location

Use the X location property to specify the number of pixels from the edge of the chart to the left edge of the chart element. Use the Y location property to specify the number of pixels from the edge of the chart to the top of the chart element. Set X and Y to –1 to allow the chart to automatically position the element.

These properties are located on the Location node, found on the ChartArea, Titles, Legend, and ChartLabels nodes of the Visual Studio Properties Window.


To Change Width and Height

Use the Width and Height location properties to specify the width and height of the chart elements. Set these properties to –1 to allow the chart to automatically size the chart elements.

These properties are located and enabled under the Location nodes of the Visual Studio Properties Window.


Using Chart3DLabels

A Chart3DLabel is an independent label that can be displayed inside or outside the PlotCube. ChartLabels are used to highlight an important data point, but can also be used generally to provide information on data or on the chart.

There is no limit to the number of ChartLabels a chart can contain. Each Chart3DLabel has label, foreground and background color, border, fonts, and attachment attributes that can be customized.

Attaching and Positioning ChartLabels

Connecting Line and Offset

Chart3DLabel Text and Alignment

Chart3DLabel View3D

Chart3DLabel Border

Chart3DLabel Colors

Chart3DLabel Fonts

DefaultStyle

ChartLabels Programming Considerations

Defining the ChartLabel


Attaching and Positioning ChartLabels

When defining a ChartLabel, specify how and where to attach it to the chart.

The attachment method determines the basic appearance of the ChartLabel. The best method depends on what ChartLabel is used for. The following illustrates and describes the attachment methods:

· Coordinates attaches the label outside the PlotCube and it can appear anywhere on the chart. The number of pixels from the top-left corner of the chart to the center of the Chart3DLabel can be specified. When attached this way, customizing the facing plane and cube font has no effect.

· DataCoordinates attaches the label inside the PlotCube to any point in 3D space within the data range. Specify the data X, Y, and Z-coordinates. The ChartLabels must fall within the maximum and minimum data coordinates for the axes, otherwise the label is not drawn.

· DataIndex attaches the label inside the PlotCube to a specific data point on the chart. Specify the row and column indices.

Use the AttachMethod of the Chart3DLabel property to set the attachment method, and the properties of AttachMethodData class to set the attachment point. These properties are located under AttachMethodData node in Chart3DLabel Collection Editor.


Connecting Line and Offset

Use the Connected property to draw a line connecting the Chart3DLabel to its attachment point. Connected is located in the Chart3DLabel Collection Editor. Use the Offset property to set the distance between the ChartLabel and its attachment point. This property is located in the Chart3DLabel Collection Editor.


Chart3DLabel Text and Alignment

Use the Text property of the Chart3DLabel class to set or change a Chart3DLabel’s text. The Text property can be accessed at design-time through the Chart3DLabel Collection Editor.

Use the LabelCompass property to specify label position relative to the attachment point. For instance, if the label is to be to the left of the point specified, setting this property to East will deliver the desired effect. LabelCompass can be accessed at design-time in the Chart3DLabel Collection Editor.


Chart3DLabel View3D

When attached by DataCoordinates or DataIndex, use the View3D property to set which plane – None, XZ, or YZ -- to face the Chart3DLabel. View3D is located in the Chart3DLabel Collection Editor.


Chart3DLabel Border

When View3D is set to XZ or YZ, the border is a fixed thin line and cannot be customized. WhenView3D is set to none, use the Type and Width border properties to customize the Chart3DLabel’s border. These properties can be accessed under the Style node of the Chart3DLabel Collection Editor. See Modifying Borders for more information.


Chart3DLabel Colors

Use the ForeColor and BackColor properties to customize background and text colors of a Chart3DLabel. These properties can be accessed under the Style node in Chart3DLabel Collection Editor. See Modifying Colors for more information.


Chart3DLabel Fonts

When View3D is set to XZ or YZ, the label font is scalable and its size is changing with size of PlotCube. When View3D is set to none, the label font is non-scalable and its size is fixed. The font properties can be accessed under the Style node in Chart3DLabel Collection Editor. See Modifying Fonts for more information.


DefaultStyle

The Chart3DLabels object has a DefaultLabelStyle that controls attributes of all labels (font, colors, border). Each of the labels also has its own individual Style inherited from this Default style. Setting attributes of the individual style overrides the attributes of the DefaultLabelStyle.

For instance, the background color of the default style can be set to gray:

· Visual Basic

· C#

· Delphi

All existing labels will have a gray background (if not deliberately set otherwise), and all new labels created will also adopt a gray background.


ChartLabels Programming Considerations

Also, see Using Chart3DLabels.

A Chart3DLabel object defines an independent rectangular region that can be attached to a chart. The Chart3DLabels collection contains all the chart labels defined for a particular chart.

Specify the index number in the Chart3DLabels collection in order to access a ChartLabel individually:

· Visual Basic

· C#

· Delphi

To create a Chart3DLabel object, call the AddNewLabel method:

· Visual Basic

· C#

· Delphi

The Remove method removes a Chart3DLabel from the collection:

· Visual Basic

· C#

· Delphi


Defining the ChartLabel

The Chart3DLabel object provides a number of properties that help define and position the chart label. The most important of these properties are the following:

· The Text property specifies the text to appear in the chart label, and is of type Label.

· The View3D property specifies the position of the chart label in 3D space. The position is specified as LabelView3DEnum.

· The Connected property is a Boolean that specifies whether a line is to be drawn from the chart label to its attached location. If True, the line is drawn.

The following code sets the above properties:

· Visual Basic

· C#

· Delphi


Using ContourStyles

The attributes that define how contour lines and zoning colors look in the chart are called a ContourStyle. The chart has a built-in set of one hundred styles. A subset of these styles is used for the chart display, based on the number of contour levels in the chart. Individual styles can be customized.

Every ContourStyle has a FillColor and a LineStyle. FillColors are used for zoning colors. LineStyles are used for contour lines. Most charts will not need to customize ContourStyles. Situations where customization is needed include:

· To control the precise ContourStyle for any particular level;

· To display more than one hundred levels; or

· To uniquely identify contour lines. (The built-in styles use the same LineStyle for every ContourStyle.)

Customizing ContourStyles

Contour Styles and Distribution Levels

Contour Styles Fill Colors

Finding and Changing Contour Styles

Contour and Zone Projection


Customizing ContourStyles

By default, the chart defines an array of contour styles for each chart group. These contour styles are specified as a Chart3DContourStyles collection of objects.

Each Chart3DContourStyle object in this collection defines two properties that specify the appearance of a particular contour line or zone in a chart:

· The FillColor property specifies the color of the zone associated with this contour style. The FillColor property can be accessed at design-time in the Styles Collection Editor of the ContourStyles node. The ContourStyles node can be accessed through the ChartGroups node in the Visual Studio Properties Window.

· The LineStyle property is a LineStyle object, and specifies the width and color of the contour line associated with this contour style. By default, each line is one pixel wide and is a solid black line. The LineStyle property can be accessed at design-time in the Styles Collection Editor of the ContourStyles node. The ContourStyles node can be accessed through the ChartGroups node in the Visual Studio Properties Window.

A total of one hundred contour styles are defined by default. To add additional contour styles, use the Add method.


Contour Styles and Distribution Levels

The nth contour line or zone in a chart is normally not associated with the nth contour style in the Chart3DContourStyles collection. The relationship between distribution levels (contour lines/zones) and the Chart3DContourStyles collection is as follows: if nstyles contour styles are provided, and the number of distribution levels is nlevels, the index of the contour style associated with the nth distribution level is the largest integer less than or equal to the following:

(n * (nstyles - 1) / nlevels) + 1

For example, if one hundred contour styles and six distribution levels are defined, the distribution levels use the 1st, 21st, 41st, 60th, 80th and 100th elements of the Chart3DContourStyles collection, respectively. (The number of distribution levels is specified by the NumLevels property of the Chart3DContour object.)

To force a one-to-one match up between contour styles and distribution levels create an array of contour styles with the same number of elements as there are distribution levels. (If it is specified that zone regions be drawn, the array of contour styles must contain one more element than the number of distribution levels. Setting the IsZoned:Chart3DContour property of the Chart3DContour object to True specifies zone regions. The extra contour style is used to specify the last zone's fill color.)


Contour Styles Fill Colors

The Chart3DContourStyles object has two properties that allow for easy manipulation of the contour styles fill color: the Colors property, and the ColorSet property. When the ColorSet property is set to Custom the fill colors for all contour styles is generated automatically using smooth transitions through colors defined in the Colors collection property. When the ColorSet property is set to one of the predefined values (Rainbow, RevRainbow, BlackWhite, WhiteBlack) the fill colors are generated using one of these predefined colors collections.

ColorSet is Rainbow

ColorSet is BlackWhite


Finding and Changing Contour Styles

To access the ContourStyle object associated with a particular contour line or zone, use the Style property of Chart3DContourLevel object. For example, the following retrieves the Chart3DContourStyle object for the third contour line:

· Visual Basic

· C#

· Delphi

Use this approach to change the attributes of individual zones or contour lines. For example, to change the color for a particular zone, change the FillColor property of the Chart3DContourStyle object. The following statements change the first zone color to green:

· Visual Basic

· C#

· Delphi

To change the line thickness or color for a contour line, change the Thickness and Color properties of the LineStyle object. For example, the following statements change the second contour line to a green line:

· Visual Basic

· C#

· Delphi

To revert to the default contour style behavior, invoke the Reset method. All contour styles will be reset to their default values.


Contour and Zone Projection

The contours and zones determined for the chart can be displayed on the ceiling or the floor of the PlotCube. To do this, set the IsContoured and/or the IsZoned property for the ceiling or the floor.

For example, the following statement projects zones onto the ceiling of the PlotCube:

· Visual Basic

· C#

· Delphi

The Chart3DContour object defined for that chart group sets the contour and zone settings used in these projections.

Contour and zone projection are ignored in two-dimensional charts, Scatter, and Bar charts.


Customizing the Distribution Table

The chart’s ContourLevels determine how many contour lines and zoning colors are used in the chart, and the Z-values that mark each level. The number of levels or the distribution table itself can be customized.

Overview

To generate contours and zones, the chart analyzes the data and based on the number of levels specified, creates the following:

· A linear distribution table that contains the Z-value that marks each level.

· An assignment of ContourStyles from the chart’s one hundred built-in styles. The chart determines which styles to use by evenly distributing its one hundred styles through the number of levels.


Customizing the Number of Levels

Use the NumLevels Contour property to set the number of contour levels to use. This has no effect when the chart is using a custom distribution table. Specify up to one hundred levels. The more levels used, the finer the distribution table. NumLevels is located under Contour node in the ChartGroup Collection Editor.


Creating a Custom Distribution Table

When a linear distribution table does not suit the needs of the chart, create a custom table that sets the number of levels and the value used to mark each level. To use custom distribution table, set the AutoDistribution property of Contour object to False.


Resetting to Linear Distribution Table

Use the AutoDistribution Contour property to use linear distribution. Set it to True and any customized levels are removed. AutoDistribution is located under Contour node in the ChartGroup Collection Editor.


Distribution Table Programming Considerations

Also, see Customizing the Distribution Table.

The Chart3DContourLevel object controls the behavior of the distribution levels used to create contour levels and zones for a chart. One Chart3DContourLevel object is defined for each chart group

The NumLevels property of the Chart3DContour object specifies the number of distribution levels to use in the chart. Any number between 2 and 100 is valid. If two are specified, no contour levels are drawn, and the entire chart is displayed as one zone.

By default, distribution levels are evenly spaced. To define distribution levels and spacing, use the Add method of the Chart3DContourLevel to create them. For example, the following code defines distribution levels at 1000, 2500 and 4200:

· Visual Basic

· C#

· Delphi

To remove a distribution level, use the Remove method:

· Visual Basic

· C#

· Delphi

At any time, revert to evenly spaced distribution levels by setting the AutoDistribution property to True. If this is done, the number of distribution levels in the chart will not change.


Special 3D Bar Chart Properties

In a 3D Bar chart, each data point is displayed as a single bar drawn from the Z-value to the origin. Spacing between adjacent bars is honored when using either grid or irregular grid data layout. Customize several properties unique to Bar charts, including origin, spacing, and colors.


Bar Z Origin

Use the axis Origin property to set the origin of the Z-axis. It is only used with Bar charts. Origin is located in the Bar node of Chart3DGroup Collection Editor.


Bar Width

Use the bar RowWidth and ColumnWidth properties to set the space used by each bar. The value represents the percentage of available space, with valid values between 0 and 100. When 100, the bars touch one another. These properties are located in the Bar node of Chart3DGroup Collection Editor.


Bar Shading Colors

When a Bar chart is shaded but not zoned, bars drawn above the Z-origin use the surface top color and bars drawn below the Z-origin use the surface bottom color. The color of one bar or entire rows and columns of bars can be arbitrarily set. Create a 4D chart to define colors that appear in the Legend; see Displaying 4D Data for more information.


Special Scatter Plot Properties

A scatter plot consists of one or more series of individual points. Customize the presence of drop lines as well as the appearance of the symbol and drop lines for each series.


Adding Drop Lines

Use the Chart3DElevation object’s DropLines property to specify whether or not drop lines appear between the plotted points and the origin. Each point in a scatter plot has a drop line that connects it to the Z = Zmin plane. The DropLines property can be accessed at design-time under the Elevation node of Chart3DGroup Collection Editor.

The following example specifies that drop lines appear:

· Visual Basic

· C#

· Delphi


Adding Depth Cue

Use the DepthCue property of Chart3DElevation object to make emphasis on depth effect. When DepthCue is set to True, symbol size is dependent on its distance from the eye.

DepthCue = False

DepthCue = True


Changing ChartStyles

The attributes that define how a series of data looks in the scatter plot are called a Chart3DStyle. Each series has its own Chart3DStyle, which can be customized. The Chart3DStyle object allows the following properties of a series to be changed programmatically:

· The LineStyle property, which defines the line style for the object. This specifies the color, pattern, and thickness of drop lines.

· The SymbolStyle property, which defines the symbol style for the object. This specifies the color, size and shape of points.

The following sets the line pattern for the second series to a dotted line:

· Visual Basic

· C#

· Delphi

And the following statement sets the symbol style for the third series to an unfilled circle:

· Visual Basic

· C#

· Delphi


The Chart3D Styles Collection

The Chart3DStylesCollection contains the Chart3DStyle objects defined for each series. The following methods are defined for the Chart3DStylesCollection:

AddNewStyle() | Add a new ChartStyle object to the collection.
Remove(index) | Remove a ChartStyle object from the collection.

Normally, manual adding or removing of Chart3DStyle objects from the collection is not needed. If a Chart3DStyle object already exists when its corresponding series is created, the previously created Chart3DStyle object is used to display the data in this series.

Looping through the Chart3DstylesCollection can quickly change the behavior of all of the lines or points in a chart. For example, the following code lightens all of the points in a chart whenever the mouse is clicked:

· Visual Basic

· C#

· Delphi


Formatting Drop Lines

Use the Line Pattern property to set the line drawing pattern, the Width property to set its width, and the Color properties to set the line color for a Chart3DStyle. The valid patterns are shown below:

Solid

Dash

Dot

DashDot

DashDotDot

These properties are available at design-time under the LineStyle node in the Chart3DStyle Collection Editor.


Formatting Symbols

Use the Symbol Shape property to set the symbol type, the Size property to set its size, and the Color properties to set the symbol color for a ChartStyle. The valid symbols are shown below:

None | Vertical Line
Dot | Horizontal Line
Box | Cross
Triangle | Circle
Diamond | Square
Star | Inverted Triangle
Diagonal Cross | Open Triangle
Open Diamond | Open Inverted Triangle

These properties are available at design-time under the LineStyle node in the Chart3DStyle Collection Editor.


Transparency

Use the Chart3DElevation Transparency property to set transparency of data drawing. Valid values of Transparency are 0 through 255. 0 – transparent, 255 – opaque.

Note: The transparency is not applied to Zoned and Contour charts.


3D User Interaction

Interacting with the Chart at Run-Time


Interacting with the Chart at Run-Time

Interact with the chart as it is running to examine data more closely or visually isolate a part of the chart. The interactions described here affect the chart displayed inside the ChartArea; other chart elements like the Header are not affected.

The interactivity of the chart is controlled at runtime by the IsInteractive property. The default setting for this property is True.

Special Notes

The keyboard/mouse combinations that perform the different interactions can be changed or removed. The interactions described here may not be enabled.

Rotation

Hold down both left mouse button.

To rotate freely, move mouse in the desired direction.

Or, to constrain rotation along an axis, press the “x”, “y”, or “z” key and move mouse perpendicular to axis.

Translation

Press SHIFT, hold down the left mouse button.

Move mouse to change the positioning of the chart inside the ChartArea.

Scaling

Press CTRL, hold down left mouse button.

Move mouse down to increase chart size, or up to decrease chart size.

Zooming

Press ALT, hold down left mouse button.

Drag mouse to select zoom area and release mouse button.

Reset to Automatic Scale and Position

Press the “r” key to remove all scaling, translation, and zooming effects. Rotation is not removed.


Returning Coordinate Values

The Chart3DData object provides methods that enable the following:

· Determine the pixel coordinates of a given data point, or the closest point to a given set of pixel coordinates.

· Convert from data coordinates to screen pixel coordinates and vice versa.

Determining Coordinate Values

Converting Data Coordinates to Pixel Coordinates

Converting Pixel Coordinates to Data Coordinates

Picking Data Points


Determining Coordinate Values

To determine the pixel coordinates of a given data point, call the DataIndexToCoord method. For example, the following code obtains the pixel coordinates of the point in the second row and third column:

· Visual Basic

· C#

· Delphi


Converting Data Coordinates to Pixel Coordinates

To convert from data coordinates to screen pixel coordinates, call the DataCoordToCoord method. For example, the following code obtains the pixel coordinates corresponding to the data coordinates (5.1, 10.2, 8.4):

· Visual Basic

· C#

· Delphi

If the data coordinate is out of the visible range of the chart, this method returns false.


Converting Pixel Coordinates to Data Coordinates

To convert from pixel coordinates to data coordinates, call the CoordToDataCoord method. For example, the following converts the pixel coordinates (225, 92) to their equivalent data coordinates:

· Visual Basic

· C#

· Delphi

CoordToDataCoord returns false if there is no data corresponding these pixel coordinates.


Picking Data Points

To determine the closest data point to a set of pixel coordinates, call CoordToDataIndex:

· Visual Basic

· C#

· Delphi


C1Chart Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


Visual Basic and C# Samples

Chart4D

Shows a 4 dimensional chart using Chart3D and color. This sample uses the C1Chart3D control.

ChartLoader

Shows various load and save operations for both 2D and 3D charts using XML and allows editing using the Chart Properties Dialog, the Chart Wizard Dialog, or a basic Property Grid. After editing, the chart can be saved as XML to files or clipboard, or chart images can be generated and saved.

This sample is also a useful utility for manipulating chart XML files at runtime and storing the chart state.

CoordMapping3D

Shows each available chart type and a variety of 3D chart options. This sample uses the C1Chart3D control.

Demo3D

Shows various 3D charts and explores their properties. This sample uses the C1Chart3D control.

Function3D

Shows a 3D surface chart based on various analytical functions. This sample uses the C1Chart3D control.

PrintIt2D

Loads both 2D and 3D persisted from and generates images or prints them. This sample uses the C1Chart and C1Chart3D controls.

Scatter3D

Show a 3D scatter chart and demonstrates various effects. This sample uses the C1Chart3D control.


C1Chart for Mobile Components Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


Visual Basic and C# Samples

Alarmz | Shows a 2D Scatter chart with AlarmZones. This sample uses the C1Chart control.
Box | Shows a Box-and-Whisker chart. This sample uses the C1Chart control.
Bubbles | Shows a Bubble chart. This sample uses the C1Chart control.
Chlabels | Shows a horizontal bar chart with mouse tracking. This sample uses the C1Chart control.
DataStyle | Shows various 2D charts and allows interactive variance of style. This sample uses the C1Chart control.
FloatBar | Shows a floating bar chart. This sample uses the C1Chart control.
HLCandle | Show various price/stock charts. This sample uses the C1Chart control.
MemStatus | This sample uses the C1Chart control.
Pie | Show a pie chart with labels and effects. This sample uses the C1Chart control.
Radar | Shows a radar chart and demonstrates stacked and filled radar options. This sample uses the C1Chart control.
Scatter | Shows a scatter chart and demonstrates mouse tracking with a game. This sample uses the C1Chart control.


Task-Based Help

Using 3D Chart Properties

3D Chart Frequently Asked Questions


Using 3D Chart Properties

Accessing Axis Properties

Accessing ChartGroups

Modifying Header and Footer Titles

Modifying the Legend

Modifying ChartArea

Modifying ChartLabels

Modifying Levels

Modifying ChartStyle


Accessing Axis Properties

Using Properties


Using Properties

1. In the Properties dialog, expand the ChartArea node.

2. Press the ellipsis next to the Axes node to display the ChartAxesCollectionEditor.

3. Modify the properties as desired. For more information, see 3D Axes.


Accessing ChartGroups

ChartGroups are organized into the ChartGroupsCollection, which is accessed through the ChartGroups object.


Using Code

· Visual Basic

· C#

· Delphi

Also, as with the 2D chart, the access path can be shortened.

· Visual Basic

· C#

· Delphi

Properties can be accessed directly from the group as with 2D chart.


Using Properties

1. In the Properties dialog, expand the ChartGroups node.

2. Press the ellipsis next to ChartGroupsCollection to display the ChartGroupReadOnlyCollectionEditor.

3. Modify properties as desired. For more information, see Customizing 3D Chart Elements.


Modifying Header and Footer Titles

A chart can have two titles, one called the Header and one called the Footer. Because each title can be positioned above, below, and to the right or left of the chart, it is not necessary to adhere to the traditional concept of Header and Footer at the top and bottom of an object.


Using Code

· Visual Basic

· C#

· Delphi


Using Properties

1. In the Properties dialog, expand the Footer and Header nodes.

2. Modify properties as desired. For more information, see Customizing 3D Chart Elements.


Modifying the Legend

Whenever data exists in the chart, a Legend is automatically generated. The chart assigns the name specified in the ChartDataSeries object for the series as the series identifier. LineStyle and SymbolStyle determine the symbols that accompany the series name in the Legend. The positioning, border, colors and font used for the Legend can be customized.


Using Code

Sample property settings are listed below:

· Visual Basic

· C#

· Delphi

Note: In VB.Net, it is still possible to use the With and End With statement which may make it easier to show repeated use of the same object. The code above would look as follows using this method:

· Visual Basic

· C#

· Delphi


Using Properties

1. In the Properties dialog, expand the Legend node.

2. Modify Properties as desired. For more information, see Formatting the Chart3DLegend.


Modifying ChartArea

ChartArea contains properties that control position, appearance, and size of the chart.


Using Properties

1. In the Properties dialog, expand ChartArea node.

2. Modify properties as desired. For more information, see 3D Axes.


Modifying ChartLabels

ChartLabels are used to highlight an important data point, but can also be used generally to provide information on data or on the chart.


Using Code

The Chart3DLabel object provides a number of properties that help define and position the chart label. The most important of these properties are the following:

· The Text property specifies the text to appear in the chart label, and is of type Label.

· The View3D property specifies the position of the chart label in 3D space. The position is specified as LabelView3DEnum.

· The Connected property is a Boolean that specifies whether a line is to be drawn from the chart label to its attached location. If True, the line is drawn.

The following code sets the above properties:

· Visual Basic

· C#

· Delphi


Using Properties

1. In the Properties dialog, expand the ChartLabels node.

2. Modify properties as desired. For more information, see Using Chart3DLabels.


Modifying Levels

The relationship between distribution levels (contour lines/zones) and the Chart3DContourStyles collection is as follows: if nstyles contour styles are provided, and the number of distribution levels is nlevels, the index of the contour style associated with the nth distribution level is the largest integer less than or equal to the following:

(n * (nstyles - 1) / nlevels) + 1


Using Properties

1. In the Properties dialog, expand the ChartGroups node.

2. Press the ellipsis next to ChartGroupsCollection to display the Chart3DGroupCollectionEditor.

3. Expand the Contour node.

4. Press the ellipsis next to Levels to display the Chart3DContourLevelCollectionEditor.

5. Add, remove, or modify levels as desired. For more information, see Customizing ContourStyles.


Modifying ChartStyle

Using Code

Using Properties


Using Code

The attributes that define how a series of data looks in the scatter plot are called a Chart3DStyle. Each series has its own Chart3DStyle, which can be customized. The Chart3DStyle object allows the following properties of a series to be changed programmatically:

· The LineStyle property, which defines the line style for the object. This specifies the color, pattern, and thickness of drop lines.

· The SymbolStyle property, which defines the symbol style for the object. This specifies the color, size and shape of points.

The following sets the line pattern for the second series to a dotted line:

· Visual Basic

· C#

· Delphi

And the following statement sets the symbol style for the third series to an unfilled circle:

· Visual Basic

· C#

· Delphi

The Chart3DStylesCollection contains the Chart3DStyle objects defined for each series. The following methods are defined for the Chart3DStylesCollection:

AddNewStyle() | Add a new ChartStyle object to the collection.
Remove(index) | Remove a ChartStyle object from the collection.


Using Properties

1. In the Property dialog, expand the ChartGroups node.

2. Press the ellipsis next to ChartStyles to display the Chart3DstyleCollectionEditor.

3. Modify the LineStyle and SymbolStyle properties as desired. For more information, see Changing ChartStyles in Special Scatter Plot Properties.


3D Chart Frequently Asked Questions

How do I change chart type?

How do I change the way chart data is plotted?

How do I change colors displayed in the chart?

How do I change placement of the Legend?

How do I add or modify a Border?


How do I change chart type?

1. In the Properties dialog, expand the ChartGroups node.

2. Press the ellipsis button next to the ChartGroupsCollection to display the ChartGroupsCollectionEditor.

3. Select the desired chart type from the ChartType property drop-down menu.

Note: When using 3D Chart, the following chart types will be available:

· Scatter

· Bar

· Surface

For more information about chart types, see Choosing the 3D Chart Type.


How do I change the way chart data is plotted?

1. In the Properties dialog, expand the ChartArea node in Properties.

2. Expand the node of appropriate axis.

3. In Grid Minor, set Max and Min (maximum and minimum interval to display on axis) and set UnitMajor (numerical interval on axis).

For example: If Max is set to 20, Min is set to 0, and UnitMajor is set to 5, every fifth number will display 0, 5, 10, 15, and 20 on the axis.

For more information, see Setting Chart3DAxis Bounds.


How do I change colors displayed in the chart?

To change series color

1. Right-click on the chart control.

2. Select Chart Properties.

3. Choose Data.

4. Expand SymbolStyle node.

5. Select desired color from Color drop-down menu.

To change chart area color

1. In the properties dialog, expand the ChartArea node.

2. Expand Style node.

3. Select desired color from BackColor drop-down menu.

To change axis color

1. In the Properties dialog, expand the ChartArea node.

2. Expand Style node.

3. Expand Font node.

4. Select desired color from ForeColor drop-down menu.


How do I change placement of the Legend?

1. In the Properties dialog, expand the Legend node.

2. Select East, West, North, or South from Compass drop-down menu. For more information, see Formatting the Chart3DLegend.


How do I add or modify a Border?

1. In the Properties dialog, expand the ChartArea node.

2. Expand Style node.

3. Expand Border node.

4. Select style type from the BorderStyle drop-down menu.

5. Select desired color from the Color drop-down menu.

6. Increase number of Thickness property to make border more prominent or decrease number to make border less prominent.

For more information, see Modifying Borders.


C1Chart 3D Reference

BarColor Class

BarColorCollection Class

Border Class

C1Chart3D Class

Chart3DArea Class

Chart3DAttachMethodData Class

Chart3DAxis Class

Chart3DAxisCollection Class

Chart3DAxisLabel Class

Chart3DAxisLabelsCollection Class

Chart3DBar Class

Chart3DColorsCollection Class

Chart3DContour Class

Chart3DContourLevel Class

Chart3DContourLevelsCollection Class

Chart3DContourStyle Class

Chart3DContourStyles Class

Chart3DContourStylesCollection Class

Chart3DData Class

Chart3DDataLabel Class

Chart3DDataLabelsCollection Class

Chart3DDataSet Class

Chart3DDataSetIrGrid Class

Chart3DDataSetGrid Class

Chart3DDataSetPoint Class

Chart3DElevation Class

Chart3DGridLines Class

Chart3DGroup Class

Chart3DGroups Class

Chart3DGroupsCollection Class

Chart3DLabel Class

Chart3DLabels Class

Chart3DLabelsCollection Class

Chart3DLegend Class

Chart3DLineStyle Class

Chart3DPoint Struct

Chart3DPointSeries Class

Chart3DPointSeriesCollection Class

Chart3DProjection Class

Chart3DStyle Class

Chart3DStylesCollection Class

Chart3DSurface Class

Chart3DSymbolStyle Class

Chart3DView Class

Chart3DViewState Class

RotateEventArgs Class

Rounding Class

Style Class

Title Class

C1Chart 3D Enumeration Reference


BarColor Class

Syntax

C1.Win.C1Chart3D.BarColor

Remarks

The BarColor class and its properties are used for setting individual bar colors.


BarColor All Members

BarColor Properties

Color | Gets or sets bar color.
Column | Gets or sets bar column.
Row | Gets or sets bar row.


BarColor Properties

Color Property

Column Property

Row Property


Color Property

Color Property

Gets or sets bar color.

Syntax

[VB]

Public Property Color As Color

[C#]

public Color Color { get; set; }

[Delphi]

property Color: Color;

See Also

BarColor Class


Column Property

Column Property

Gets or sets bar column.

Syntax

[VB]

Public Property Column As Integer

[C#]

public int Column { get; set; }

[Delphi]

property Column: Integer;

See Also

BarColor Class


Row Property

Row Property

Gets or sets bar row.

Syntax

[VB]

Public Property Row As Integer

[C#]

public int Row { get; set; }

[Delphi]

property Row: Integer;

See Also

BarColor Class


BarColorCollection Class

Syntax

C1.Win.C1Chart3D.BarColorCollection


BarColorCollection All Members

BarColorCollection Properties

Count | Gets the number of elements in the collection.
Item | Gets the specified BarColor from the collection by numeric index.

BarColorCollection Methods

Add | Adds a BarColor object to the collection.
Contains | Determines whether the specified BarColor exists in the collection.
CopyTo | Copies the collection of BarColor objects beginning with the specified index to an array of BarColor objects.
IndexOf | Gets the index of the specified BarColor in the collection.
Insert | Adds a BarColor object to the collection at the specified index.
Remove | Removes the specified BarColor object from the collection.


BarColorCollection Properties

Count Property (BarColorCollection)

Item Property (BarColorCollection)


Count Property (BarColorCollection)

Count Property (BarColorCollection)

Gets the number of elements in the collection.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

BarColorCollection Class


Item Property (BarColorCollection)

Item Property (BarColorCollection)

Gets the specified BarColor from the collection by numeric index.

Syntax

[VB]

Default Public ReadOnly Property Item(index As Integer) As BarColor

[C#]

public BarColor this[int index]{ get; }

[Delphi]

property Item(index: Integer): BarColor;

See Also

BarColorCollection Class


BarColorCollection Methods

Add Method (BarColorCollection)

Contains Method (BarColorCollection)

CopyTo Method (BarColorCollection)

IndexOf Method (BarColorCollection)

Insert Method (BarColorCollection)

Remove Method (BarColorCollection)


Add Method (BarColorCollection)

Add Method (BarColorCollection)

Adds a BarColor object to the collection.

Syntax

[VB]

Public Function Add (bc As BarColor) As Integer

[C#]

public int Add(BarColor bc);

[Delphi]

function Add(bc: BarColor): Integer;

Return Value

An integer indicating the index of the added BarColor.

See Also

BarColorCollection Class


Contains Method (BarColorCollection)

Contains Method (BarColorCollection)

Determines whether the specified BarColor exists in the collection.

Syntax

[VB]

Public Function Contains (bc As BarColor) As Boolean

[C#]

public bool Contains (BarColor bc)

[Delphi]

function Contains(bc: BarColor): Boolean;

Return Value

A boolean value indicating whether the BarColor is a member of the collection.

See Also

BarColorCollection Class


CopyTo Method (BarColorCollection)

CopyTo Method (BarColorCollection)

Copies the collection BarColor elements beginning with the specified index to an array of BarColor objects.

Syntax

[VB]

Public Sub CopyTo(array As BarColor (), index As Integer)

[C#]

public void CopyTo (BarColor [] array, int Index)

[Delphi]

procedure CopyTo(array: BarColor; index: Integer);

See Also

BarColorCollection Class


IndexOf Method (BarColorCollection)

IndexOf Method (BarColorCollection)

Gets the index of the specified BarColor in the collection.

Syntax

[VB]

Public Function IndexOf (bc As BarColor) As Integer

[C#]

public int IndexOf (BarColor bc)

[Delphi]

function IndexOf(bc: BarColor): Integer;

Return Value

An integer indicating the index of the specified BarColor.

See Also

BarColorCollection Class


Insert Method (BarColorCollection)

Insert Method (BarColorCollection)

Adds a BarColor object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, bc As BarColor)

[C#]

public void Insert (int Index, BarColor bc)

[Delphi]

procedure Insert (index: Integer; bc: BarColor;);

See Also

BarColorCollection Class


Remove Method (BarColorCollection)

Remove Method (BarColorCollection)

Removes a BarColor object from the collection.

Syntax

[VB]

Public Sub Remove(bc As BarColor)

[C#]

public void Remove (BarColor bc)

[Delphi]

procedure Remove (bc: BarColor;);

See Also

BarColorCollection Class


Border Class

Syntax

C1.Win.C1Chart3D.Border

Remarks

The Border class is used to describe the border appearance of various elements of the chart, include the chart itself, the ChartArea, the Legend, the Header, the Footer and Labels.


Border All Members

Border Properties

BorderStyle | Gets or sets the border style.
Color | Gets or sets the border color.
Rounding | Gets the Rounding object that controls rounding of corners.
Thickness | Gets or sets the border thickness.

Border Methods

ShouldSerializeColor

Returns true if the Border Color property is not in the default state.


Border Properties

BorderStyle Property

Color Property (Border)

Rounding Property

Thickness Property (Border)


BorderStyle Property

BorderStyle Property

Gets or sets the border style.

Syntax

[VB]

Public Property BorderStyle As BorderStyleEnum

[C#]

public BorderStyleEnum BorderStyle { get; set; }

[Delphi]

property BorderStyle: BorderStyleEnum;

See Also

Border Class


Color Property (Border)

Color Property (Border)

Gets or sets the border color.

Syntax

[VB]

Public Property Color As Color

[C#]

public Color Color { get; set; }

[Delphi]

property Color: Color;

See Also

Border Class


Rounding Property

Rounding Property

Gets the Rounding object that controls the rounding of corners.

Syntax

[VB]

Public ReadOnly Property Rounding As Rounding

[C#]

public Rounding Rounding { get; }

[Delphi]

property Rounding: Rounding;

See Also

Border Class


Thickness Property (Border)

Thickness Property (Border)

Gets or sets the border thickness.

Syntax

[VB]

Public Property Thickness As Int32

[C#]

public int Thickness { get; set; }

[Delphi]

property Thickness: Integer;

See Also

Border Class


Border Methods

ShouldSerializeColor Method


ShouldSerializeColor Method

ShouldSerializeColor Method

Returns true if the Border Color property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeColor() As Boolean

[C#]

public bool ShouldSerializeColor ( )

[Delphi]

function ShouldSerializeColor: Boolean;

Remarks

The default state is to use Color.Transparent and use the BackColor of the parent Style as the basis for the border color.

See Also

Border Class


C1Chart3D Class

Syntax

C1.Win.C1Chart3D.C1Chart3D

Remarks

The main chart control class.

C1Chart3D All Members

C1Chart3D Properties

C1Chart3D Methods

C1Chart3D Events


C1Chart3D All Members

C1Chart3D Properties

AreaStyle | Gets the ChartArea style.
AssemblyFileVersionString | Gets the control’s assembly file version as a string.
AssemblyVersionString | Gets the control’s assembly version as a string.
BackColor | The background color used to display text and graphics in the control.
BackgroundImage | The background image used for the control.
ChartArea | Gets the control chart area object.
ChartGroups | Gets the control chart groups object.
ChartLabels | Gets the control chart labels object.
DefaultLabelStyle | Gets the ChartLabels DefaultLabelStyle.
Font | The font used to display text in the control.
Footer | Gets the control footer object.
FooterStyle | Gets the Footer style.
ForeColor | The foreground color used to display text and graphics in the control.
Header | Gets the control header object.
HeaderStyle | Gets the Header style
Legend | Gets the control legend object.
LegendStyle | Get the Legend style.
Location | The position of the top-left corner of the control with respect to its container.
PrintDialogUsage | Gets or sets whether a print dialog is used when printing.
Repaint | Determines whether the chart is repainted when its properties change.
Size | The size of the control in pixels.
Style | Gets the chart style
UseAntiAlias | Gets or sets a value indicating whether to use anti-aliasing when displaying the chart.
UseDoubleBuffer | Gets or sets a value indicating whether to use double buffering methods when repainting the chart.
Visible | Determines whether the control is visible or hidden.

C1Chart3D Methods

Dispose | Readies the chart object for garbage collection.
Draw | Draw the chart on the specified drawing surface.
GetImage | Obtains an image of the current chart display.
LoadChartFromFile | Load chart description from the file.
LoadChartFromString | Load chart description from the string.
PageSetup | Raises the PageSetup dialog to manage the page settings
PrintChart | Prints the control using default scaling within the margins of the printer page.
PrintSetup | Raises the PrintSetup dialog to manage the printer settings.
Reset | Clears the chart of all data and settings.
SaveChartToFile | Save chart description to the file.
SaveChartToString | Save chart description to the string.
SaveImage | Saves an image of the chart.
ShowProperties | Raises the chart properties dialog at runtime.
ShowWizard | Raises the chart wizard dialog at runtime.

C1Chart3D Events

LayoutLabels

Fires before rendering labels and allows repositioning of labels relative to positions of other chart elements or using data mapping methods.


C1Chart3D Properties

AreaStyle Property

AssemblyFileVersionString Property

AssemblyVersionString Property

BackColor Property (C1Chart3D)

BackgroundImage Property

ChartArea Property

ChartGroups Property

ChartLabels Property

DefaultLabelStyle Property

Font Property (C1Chart3D)

Footer Property

FooterStyle Property

ForeColor Property (C1Chart3D)

Header Property

HeaderStyle Property

Legend Property

LegendStyle Property

Location Property (C1Chart3D)

PrintDialogUsage Property

Repaint Property

Size Property (C1Chart3D)

Style Property

UseAntiAlias Property

UseDoubleBuffer Property

Visible Property (C1Chart3D)


AreaStyle Property

AreaStyle Property

Gets the ChartArea style.

Syntax

[VB]

Public ReadOnly AreaStyle As Style

[C#]

public Style AreaStyle { get; }

[Delphi]

property AreaStyle: Style;

Remarks

The property provides a convenient shortcut to the ChartArea.Style.

See Also

C1Chart3D Class


AssemblyFileVersionString Property

AssemblyFileVersionString Property

Gets the control’s AssemblyFileVersion as a string. The AssemblyFileVersion is also viewable from the properties dialog of the control assembly dll.

Syntax

[VB]

Public ReadOnly Property AssemblyFileVersionString As String

[C#]

public String AssemblyFileVersionString { get; }

[Delphi]

property AssemblyFileVersionString: string;

Remarks

The AssemblyFileVersion is different from the AssemblyVersion. The AssemblyFileVersion is viewable from the properties dialog of the control assembly dll. The AssemblyVersion is also listed in the properties dialog, but only in the “other version information” section. When viewing the Global Assembly Cache (GAC) in Windows Explorer, the AssemblyVersion is shown as a standard column.

The AssemblyFileVersion will always change with each separate release of the Chart control, including internal changes. The AssemblyVersion will only change when the object model has been changed.

See Also

C1Chart3D Class


AssemblyVersionString Property

AssemblyVersionString Property

Gets the control’s AssemblyVersion as a string. The AssemblyVersion is also viewable from the properties dialog of the control assembly dll, but only in the “other version information” section.

Syntax

[VB]

Public ReadOnly Property AssemblyVersionString As String

[C#]

public String AssemblyVersionString { get; }

[Delphi]

property AssemblyVersionString: string;

Remarks

The AssemblyFileVersion is different from the AssemblyVersion. The AssemblyFileVersion is viewable from the properties dialog of the control assembly dll. The AssemblyVersion is also listed in the properties dialog, but only in the “other version information” section. When viewing the Global Assembly Cache (GAC) in Windows Explorer, the AssemblyVersion is shown as a standard column.

The AssemblyFileVersion will always change with each separate release of the Chart control, including internal changes. The AssemblyVersion will only change when the object model has been changed.

See Also

C1Chart3D Class


BackColor Property (C1Chart3D)

BackColor Property (C1Chart3D)

The background color used to display text and graphics in the control.

Syntax

[VB]

Public Property BackColor As Color

[C#]

public BackColor { get; set; }

[Delphi]

property BackColor: Color;

Remarks

Changing the BackColor also changes the BackColor of the chart’s style object, and visa versa.

See Also

C1Chart3D Class


BackgroundImage Property

BackgroundImage Property

The background image used for the control.

Syntax

[VB]

Public Property BackgroundImage As Image

[C#]

public Image BackgroundImage { get; set; }

[Delphi]

property BackgroundImage: Image;

See Also

C1Chart3D Class


ChartArea Property

ChartArea Property

Gets the control chart area object.

Syntax

[VB]

Public ReadOnly Property ChartArea As Chart3DArea

[C#]

public Chart3DArea ChartArea { get; }

[Delphi]

property ChartArea: Chart3DArea;

Remarks

The ChartArea is that region of the chart that contains plot cube, axes and charted data. Its Style inherits directly from the parent C1Chart3D.

See Also

C1Chart3D Class


ChartGroups Property

ChartGroups Property

Gets the control chart groups object

Syntax

[VB]

Public ReadOnly Property ChartGroups As Chart3DGroups

[C#]

public Chart3DGroups ChartGroups { get; }

[Delphi]

property ChartGroups: Chart3DGroups;

Remarks

ChartGroup contains information related to data values and related appearance.

See Also

C1Chart3D Class


ChartLabels Property

ChartLabels Property

Gets the control chart labels object.

Syntax

[VB]

Public ReadOnly Property ChartLabels As Chart3DLabels

[C#]

public Chart3DLabels ChartLabels { get; }

[Delphi]

property ChartLabels: Chart3DLabels;

Remarks

The ChartLabels contain all Chart3DLabel objects.

See Also

C1Chart3D Class


DefaultLabelStyle Property

DefaultLabelStyle Property

Gets the ChartLabels default style.

Syntax

[VB]

Public ReadOnly DefaultLabelStyle As Style

[C#]

public Style DefaultLabelStyle { get; }

[Delphi]

property DefaultLabelStyle: Style;

Remarks

The property provides a convenient shortcut to the ChartLabels.DefaultLabelStyle.

See Also

C1Chart3D Class


Font Property (C1Chart3D)

Font Property (C1Chart3D)

The font used to display text in the control.

Syntax

[VB]

Public Property Font As Font

[C#]

public Font Font { get; set; }

[Delphi]

property Font: Font;

See Also

C1Chart3D Class


Footer Property

Footer Property

Gets the control footer object.

Syntax

[VB]

Public ReadOnly Property Footer As Title

[C#]

public Title Footer { get; }

[Delphi]

property Footer: Title;

See Also

C1Chart3D Class


FooterStyle Property

FooterStyle Property

Gets the Footer style.

Syntax

[VB]

Public ReadOnly FooterStyle As Style

[C#]

public Style FooterStyle { get; }

[Delphi]

property FooterStyle: Style;

Remarks

This property provides a convenient shortcut to the Footer.Style.

See Also

C1Chart3D Class


ForeColor Property (C1Chart3D)

ForeColor Property (C1Chart3D)

The foreground color used to display text and graphics in the control.

Syntax

[VB]

Public Property ForeColor As Color

[C#]

public Color ForeColor { get; set; }

[Delphi]

property ForeColor: Color;

Remarks

Changing the ForeColor also changes the ForeColor of the chart’s style object, and visa versa.

See Also

C1Chart3D Class


Header Property

Header Property

Gets the control header object.

Syntax

[VB]

Public ReadOnly Property Header As Title

[C#]

public Title Header { get; }

[Delphi]

property Header: Title;

See Also

C1Chart3D Class


HeaderStyle Property

HeaderStyle Property

Gets the Header style.

Syntax

[VB]

Public ReadOnly HeaderStyle As Style

[C#]

public Style HeaderStyle { get; }

[Delphi]

property HeaderStyle: Style;

Remarks

The property provides a convenient shortcut to the Header.Style.

See Also

C1Chart3D Class


Legend Property

Legend Property

Gets the control legend object.

Syntax

[VB]

Public ReadOnly Property Legend As Chart3DLegend

[C#]

public Chart3DLegend Legend { get; }

[Delphi]

property Legend: Chart3DLegend;

See Also

C1Chart3D Class


LegendStyle Property

LegendStyle Property

Gets the Legend style.

Syntax

[VB]

Public ReadOnly LegendStyle As Style

[C#]

public Style LegendStyle { get; }

[Delphi]

property LegendStyle: Style;

Remarks

This property provides a convenient shortcut to the Legend.Style.

See Also

C1Chart3D Class


Location Property (C1Chart3D)

Location Property (C1Chart3D)

With respect to its container, location is the position of the top-left corner of the control.

Syntax

[VB]

Public Location As Point

[C#]

public Point Location { get; set; }

[Delphi]

property Location: Point;

See Also

C1Chart3D Class


PrintDialogUsage Property

PrintDialogUsage Property

Gets or sets whether a print dialog is used when printing.

Syntax

[VB]

Public PrintDialogUsage As Boolean

[C#]

public bool PrintDialogUsage { get; set; }

[Delphi]

property PrintDialogUsage: Boolean;

See Also

C1Chart3D Class


Repaint Property

Repaint Property

Gets or sets a value indicating whether the chart is automatically repainted when its properties are modified.

Syntax

[VB]

Public Property Repaint As Boolean

[C#]

public bool Repaint { get; set; }

[Delphi]

property Repaint: Boolean;

Remarks

When the Repaint property is false, chart repaints are minimized as chart properties are changed. This is useful when multiple chart properties will be changed in an event, and it is desired to reduce the flicker associated with repeated repaints.

Note that it is very important to set Repaint to true when property changes have been completed. Failure to do so can result in a chart that never repaints.

See Also

C1Chart3D Class


Size Property (C1Chart3D)

Size Property (C1Chart3D)

The size of the control displayed in pixels.

Syntax

[VB]

Public Size As Size

[C#]

public Size Size { get; set; }

[Delphi]

property Size: Size;

See Also

C1Chart3D Class


Style Property

Style Property

Gets the chart style.

Syntax

[VB]

Public ReadOnly Style As Style

[C#]

public Style Style { get; }

[Delphi]

property Style: Style;

See Also

C1Chart3D Class


UseAntiAlias Property

UseAntiAlias Property

Gets or sets a value indicating whether to use anti-aliasing when displaying the chart.

Syntax

[VB]

Public Property UseAntiAlias As Boolean

[C#]

public bool UseAntiAlias { get; set; }

[Delphi]

property UseAntoAlias: Boolean;

See Also

C1Chart3D Class


UseDoubleBuffer Property

UseDoubleBuffer Property

Gets or sets a value indicating whether to use double buffering methods when repainting the chart..

Syntax

[VB]

Public Property UseDoubleBuffer As Boolean

[C#]

public bool UseDoubleBuffer { get; set; }

[Delphi]

property UseDoubleBuffer: Boolean;

See Also

C1Chart3D Class


Visible Property (C1Chart3D)

Visible Property (C1Chart3D)

Determines whether the control is visible or hidden.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

See Also

C1Chart3D Class


C1Chart3D Methods

Dispose Method (C1Chart3D)

Draw Method (C1Chart3D)

GetImage Method (C1Chart3D)

LoadChartFromFile Method

LoadChartFromString Method

PageSetup Method (C1Chart3D)

PrintChart Method (C1Chart3D)

PrintSetup Method (C1Chart3D)

Reset Method (C1Chart3D)

SaveChartToFile Method

SaveChartToString Method

SaveImage Method (C1Chart3D)

ShowProperties Method

ShowWizard Method


Dispose Method (C1Chart3D)

Dispose Method (C1Chart3D)

Syntax

[VB]

Public Sub Dispose()

[C#]

public void Dispose();

[Delphi]

procedure Dispose;

Remarks

Readies the chart object for garbage collection. The chart should not be referenced after calling the Dispose method.

See Also

C1Chart3D Class


Draw Method (C1Chart3D)

Draw Method (C1Chart3D)

Draw the chart on the specified drawing surface.

Syntax

[VB]

Public Sub Draw( g As Graphics, r As Rectangle)

[C#]

public void Draw( Graphics g, Rectangle r);

[Delphi]

procedure Draw(g: Graphics; r: Rectangle);

See Also

C1Chart3D Class


GetImage Method (C1Chart3D)

GetImage Method (C1Chart3D)

Obtains an image of the current chart display.

Syntax

[VB]

Public Function GetImage () As Image

Public Function GetImage (Sz As Size) As Image

Public Function GetImage (ImgFmt As ImageFormat) As Image

Public Function GetImage (ImgFmt As ImageFormat, Sz As Size) As Image

[C#]

public Image GetImage ();

public Image GetImage (Size Sz);

public Image GetImage (ImageFormat ImgFmt);

public Image GetImage(ImageFormat ImgFmt, Size Sz);

[Delphi]

function GetImage: Image

function GetImage(sz: Size): Image;

function GetImage(ImgFmt: ImageFormat): Image;

function GetImage(ImgFmt: ImageFormat; sz: Size): Image;

Return Value

Image created by an enhanced metafile of the chart.

Remarks

This method creates an image of the current chart display an returns an Image object. The Image is created with the specified ImageFormat, or if not specified an enhanced metafile, so the image is scalable. When the GetImage overload with the Size parameter is used, the Sz parameter specifies the size of the bitmap in pixels. If the GetImage overload without the size parameter is called, the size of the current display, in pixels, is assumed. If an error occurs during the file creation, chart drawing and writing, an appropriate exception is thrown indicating the cause of error.

See Also

C1Chart3D Class


LoadChartFromFile Method

LoadChartFromFile Method

Load chart description from the file.

Syntax

[VB]

Public Sub LoadChartFromFile(filename As String)

[C#]

public void LoadChartFromFile(string filename);

[Delphi]

procedure LoadChartFromFile(filename: string);

See Also

C1Chart3D Class


LoadChartFromString Method

LoadChartFromString Method

Loads chart description from a string

Syntax

[VB]

Public Sub LoadChartFromString(s As String)

[C#]

public void LoadChartFromString(string s);

[Delphi]

procedure LoadChartFromString(s: string);

Remarks

When a chart is saved to xml, the chart loads all the set properties into an xml file. With the SaveChartToString method the chart can also write these properties to a string value. This method then loads the chart from this string value.

See Also

C1Chart3D Class


PageSetup Method (C1Chart3D)

PageSetup Method (C1Chart3D)

Raises the PageSetup dialog to manage the page settings.

Syntax

[VB]

Public Sub PageSetup ()

[C#]

public void PageSetup ();

[Delphi]

procedure PageSetup;

See Also

C1Chart3D Class


PrintChart Method (C1Chart3D)

PrintChart Method (C1Chart3D)

Prints the control using default scaling within the margins of the printer page.

Syntax

[VB]

Public Sub PrintChart ()

Public Sub PrintChart (scaling As PrintScaleEnum)

Public Sub PrintChart (scaling As PrintScaleEnum, r As Rectangle)

[C#]

public void PrintChart ();

public void PrintChart (PrintScaleEnum scaling);

public void PrintChart (PrintScaleEnum scaling, Rectangle r);

[Delphi]

procedure PrintChart;

procedure PrintChart(scaling: PrintScaleEnum);

procedure PrintChart( scaling: PrintScaleEnum; r: Rectangle);

See Also

C1Chart3D Class


PrintSetup Method (C1Chart3D)

PrintSetup Method (C1Chart3D)

Raises the PrintSetup dialog to manage the printer settings.

Syntax

[VB]

Public Sub PrintSetup ()

[C#]

public void PrintSetup ();

[Delphi]

procedure PrintSetup;

See Also

C1Chart3D Class


Reset Method (C1Chart3D)

Reset Method (C1Chart3D)

Clears the chart of all data and settings.

Syntax

[VB]

Public Sub Reset ()

[C#]

public void Reset ();

[Delphi]

procedure Reset;

See Also

C1Chart3D Class


SaveChartToFile Method

SaveChartToFile Method

Save chart description to the file.

Syntax

[VB]

Public Sub SaveChartToFile(filename As String)

[C#]

public void SaveChartToFile(string filename);

[Delphi]

procedure SaveChartToFile(filename: string);

See Also

C1Chart3D Class


SaveChartToString Method

SaveChartToString Method

Save chart description to the string.

Syntax

[VB]

Public Function SaveChartToString() As String

[C#]

public string SaveChartToString();

[Delphi]

function SaveChartToString: string;

Remarks

When a chart is saved to xml, the chart loads all the set properties into an xml file. With the SaveChartToString method the chart can also write these properties to a string value. The chart can also be loaded from this string.

See Also

C1Chart3D Class


SaveImage Method (C1Chart3D)

SaveImage Method (C1Chart3D)

Saves an image of the specified format to the specified target.

Syntax

[VB]

Public Sub SaveImage (ImgFmt As ImageFormat)

Public Sub SaveImage (ImgFmt As ImageFormat, Size sz)

Public Sub SaveImage (Filename As String, ImgFmt As ImageFormat)

Public Sub SaveImage (Filename As String, ImgFmt As ImageFormat, Size sz)

Public Sub SaveImage (stream As Stream, ImgFmt As ImageFormat)

Public Sub SaveImage (stream As Stream, ImgFmt As ImageFormat, Size sz)

Public Sub SaveImage (ByRef byteArray As Byte(), ImgFmt As ImageFormat)

Public Sub SaveImage (ByRef byteArray As Byte(), ImgFmt As ImageFormat, Size sz)

[C#]

public void SaveImage (ImageFormat ImgFmt);

public void SaveImage (ImageFormat ImgFmt, Size sz);

public void SaveImage (string Filename, ImageFormat ImgFmt);

public void SaveImage (string Filename, ImageFormat ImgFmt, Size sz);

public void SaveImage (Stream stream, ImageFormat ImgFmt);

public void SaveImage (Stream stream, ImageFormat ImgFmt, Size sz);

public void SaveImage (ref Byte[] byteArray, ImageFormat ImgFmt);

public void SaveImage (ref Byte[] byteArray, ImageFormat ImgFmt, Size sz);

[Delphi]

procedure SaveImage(ImgFmt: ImageFormat);

procedure SaveImage(ImgFmt: ImageFormat; sz: Size);

procedure SaveImage(Filename: string; ImgFmt: ImageFormat);

procedure SaveImage(Filename: string; ImgFmt: ImageFormat; sz: Size);

procedure SaveImage(stream: Stream; ImgFmt: ImageFormat);

procedure SaveImage(stream: Stream; ImgFmt: ImageFormat; sz: Size);

procedure SaveImage(byteArray: ref Byte[]; ImgFmt: ImageFormat);

procedure SaveImage(byteArray: ref Byte[]; ImgFmt: ImageFormat; sz: Size);

Remarks

This method creates an image of the specified format of the current chart display and saves the results to the specified target. The first two overloads, which not specify a target object, copy the image to the clipboard in emf or bmp format. When the Size parameter is used, the Sz parameter specifies the size of a bitmap in pixels. If the Size parameter is not used, the size of the current display, in pixels, is assumed. If an error occurs, an appropriate exception is thrown indicating the cause of error.

See Also

C1Chart3D Class


ShowProperties Method

ShowProperties Method

Raises the properties dialog at runtime using specified dialog version.

Syntax

[VB]

Public Sub ShowProperties () As DialogResult

[C#]

public DialogResult ShowProperties ();

[Delphi]

function ShowProperties: DialogResult;

Return Value

DialogResult

See Also

C1Chart3D Class


ShowWizard Method

ShowWizard Method

Raises the wizard dialog at runtime using specified dialog version.

Syntax

[VB]

Public Sub ShowWizard () As DialogResult

[C#]

public DialogResult ShowWizard ();

[Delphi]

function ShowWizard: DialogResult;

Return Value

DialogResult

See Also

C1Chart3D Class


C1Chart3D Events

LayoutLabels Event


LayoutLabels Event

LayoutLabels Event

Fires before rendering labels and allows repositioning labels relative to positions of other chart elements or using data mapping methods.

Syntax

[VB]

Public Event LayoutLabels As EventHandler

[C#]

public event EventHandler LayoutLabels;

[Delphi]

property LayoutLabels : EventHandler;

See Also

C1Chart3D Class


Chart3DArea Class

Syntax

C1.Win.C1Chart3D.Chart3DArea

Remarks

The Chart3DArea class describes the ChartArea of the chart. This area includes plotcube, all axes and the charted data.


Chart3DArea All Members

Chart3DArea Properties

Axes | Gets the axes collection object.
AxisX | Gets the X-axis object.
AxisY | Gets the Y-axis object.
AxisZ | Gets the Z-axis object.
Location | Gets or sets the location of the ChartArea in chart control client coordinates.
LocationDefault | Gets or sets the default location of the ChartArea.
Size | Gets or sets the size of the ChartArea in chart control client coordinates.
SizeDefault | Gets or sets the default size of the ChartArea.
Style | Gets the chart area style.
View | Gets the 3d-view object.
Visible | Gets or sets the Chart3DArea visibility.


Chart3DArea Properties

Axes Property

AxisX Property

AxisY Property

AxisZ Property

Location Property (Chart3DArea)

LocationDefault Property (Chart3DArea)

Size Property (Chart3DArea)

SizeDefault Property (Chart3DArea)

Style Property (Chart3DArea)

View Property

Visible Property (Chart3DArea)


Axes Property

Axes Property

Gets the axes collection object.

Syntax

[VB]

Public ReadOnly Property Axes As Chart3DAxisCollection

[C#]

public Chart3DAxisCollection Axes { get; }

[Delphi]

property Axes: Chart3DAxisCollection;

Remarks

The Axes collection is a collection of three Chart3DAxis objects (AxisX, AxisY and AxisZ).

See Also

Chart3DArea Class


AxisX Property

AxisX Property

Gets the X-axis object.

Syntax

[VB]

Public ReadOnly Property AxisX As Chart3DAxis

[C#]

public Chart3DAxis AxisX { get; }

[Delphi]

property AxisX: Chart3DAxis;

See Also

Chart3DArea Class


AxisY Property

AxisY Property

Gets the Y-axis object

Syntax

[VB]

Public ReadOnly Property AxisY As Chart3DAxis

[C#]

public Chart3DAxis AxisY { get; }

[Delphi]

property AxisX: Chart3DAxis;

See Also

Chart3DArea Class


AxisZ Property

AxisZ Property

Gets the Z-axis object

Syntax

[VB]

Public ReadOnly Property AxisZ As Chart3DAxis

[C#]

public Chart3DAxis AxisZ { get; }

[Delphi]

property AxisZ: Chart3DAxis;

See Also

Chart3DArea Class


Location Property (Chart3DArea)

Location Property (Chart3DArea)

Gets or sets the location of the ChartArea in chart control client coordinates.

Syntax

[VB]

Public Property Location As Point

[C#]

public Point Location { get; set; }

[Delphi]

property Location: Point;

Remarks

The Location property always returns the actual location of the upper, left corner of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change LocationDefault.

See Also

Chart3DArea Class


LocationDefault Property (Chart3DArea)

LocationDefault Property (Chart3DArea)

Gets or sets the default location of the ChartArea.

Syntax

[VB]

Public Property LocationDefault As Point

[C#]

public Point LocationDefault { get; set; }

[Delphi]

property LocationDefault: Point;

Remarks

The LocationDefault property specifies the location of the upper, left corner of the chart element it describes. Non-negative values indicate the explicit position in chart client coordinates to place the chart element. Negative values will allow auto-positioning.

See Also

Chart3DArea Class


Size Property (Chart3DArea)

Size Property (Chart3DArea)

Gets or sets the size of the ChartArea in chart control client coordinates.

Syntax

[VB]

Public Property Size As Size

[C#]

public Size Size { get; set; }

[Delphi]

property Size: Size;

Remarks

The Size property always returns the actual size of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change SizeDefault.

See Also

Chart3DArea Class


SizeDefault Property (Chart3DArea)

SizeDefault Property (Chart3DArea)

Gets or sets the default size of the ChartArea.

Syntax

[VB]

Public SizeDefault As Size

[C#]

public Size SizeDefault { get; set; }

[Delphi]

property SizeDefault: Size;

Remarks

The SizeDefault property specifies the size of the chart element it describes. Non-negative values indicate the explicit width and height in chart client coordinates to place the chart element.Negative values will allow auto-positioning.

See Also

Chart3DArea Class


Style Property (Chart3DArea)

Style Property (Chart3DArea)

Gets the chart area style

Syntax

[VB]

Public ReadOnly Property Style As Style

[C#]

public Style Style { get; }

[Delphi]

property Style: Style;

See Also

Chart3DArea Class


View Property

View Property

Gets the 3d-view object.

Syntax

[VB]

Public ReadOnly Property View As Chart3DView

[C#]

public Chart3DView View { get; }

[Delphi]

property View: Chart3DView;

Remarks

View object controls appearance of plot cube in 3d-space.

See Also

Chart3DArea Class


Visible Property (Chart3DArea)

Visible Property (Chart3DArea)

Gets or sets the Chart3DArea visibility.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

Remarks

If this property is false, the ChartArea and all objects composing the ChartArea, including Axes and plot cube are not visible.

See Also

Chart3DArea Class


Chart3DAttachMethodData Class

Syntax

C1.Win.C1Chart3D.Chart3DAttachMethodData

Remarks

The Chart3DAttachMethodData Class is used by chart Label objects in conjunction with the Label object AttachMethod property to identify how the Label is placed or attached to the chart. Each of the Chart3DAttachMethodData object properties are meaning only in the context of the AttachMethod value.


Chart3DAttachMethodData All Members

Chart3DAttachMethodData Properties

Column | Gets or sets the Column of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is regular or irregular grid.
Row | Gets or sets the Row of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is regular or irregular grid.
PointIndex | Gets or sets the point index of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is point.
SeriesIndex | Gets or sets the series index of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is point.
X | Gets or sets the X coordinate (data or client) when the label AttachMethod property specifies Coordinate or DataCoordinate attachment.
Y | Gets or sets the Y coordinate (data or client) when the label AttachMethod property specifies Coordinate or DataCoordinate attachment.
Z | Gets or sets the X coordinate (data or client) when the label AttachMethod property specifies DataCoordinate attachment.


Chart3DAttachMethodData Properties

Column Property

Row Property

PointIndex Property

SeriesIndex Property

X Property (Chart3DAttachMethodData)

Y Property (Chart3DAttachMethodData)

Z Property


Column Property

Column Property

Gets or sets column of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is regular or irregular grid.

Syntax

[VB]

Public Property Column As Integer

[C#]

public int Column { get; set; }

[Delphi]

property Column: Integer;

See Also

Chart3DAttachMethodData Class


Row Property

Row Property

Gets or sets row of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout is regular or irregular grid.

Syntax

[VB]

Public Property Row As Integer

[C#]

public int Row { get; set; }

[Delphi]

property Row: Integer;

See Also

Chart3DAttachMethodData Class


PointIndex Property

PointIndex Property

Gets or sets the point index of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout specified is point layout.

Syntax

[VB]

Public Property PointIndex As Integer

[C#]

public int PointIndex { get; set; }

[Delphi]

property PointIndex: Integer;

See Also

Chart3DAttachMethodData Class


SeriesIndex Property

SeriesIndex Property

Gets or sets the series index of the data point to attach a label when the label AttachMethod property specifies DataIndex attachment and data layout specified is point layout.

Syntax

[VB]

Public Property SeriesIndex As Integer

[C#]

public int SeriesIndex { get; set; }

[Delphi]

property SeriesIndex: Integer;

See Also

Chart3DAttachMethodData Class


X Property (Chart3DAttachMethodData)

X Property (Chart3DAttachMethodData)

Gets or sets the X coordinate (data or client) when the label AttachMethod property specifies Coordinate or DataCoordinate attachment.

Syntax

[VB]

Public Property X As Single

[C#]

public float X { get; set; }

[Delphi]

property X: single;

See Also

Chart3DAttachMethodData Class


Y Property (Chart3DAttachMethodData)

Y Property (Chart3DAttachMethodData)

Gets or sets the Y coordinate (data or client) when the label AttachMethod property specifies Coordinate or DataCoordinate attachment.

Syntax

[VB]

Public Property Y As Single

[C#]

public float Y { get; set; }

[Delphi]

property Y: single;

See Also

Chart3DAttachMethodData Class


Z Property

Z Property

Gets or sets the X coordinate (data or client) when the label AttachMethod property specifies DataCoordinate attachment.

Syntax

[VB]

Public Property Z As Single

[C#]

public float Z { get; set; }

[Delphi]

property Z: single;

See Also

Chart3DAttachMethodData Class


Chart3DAxis Class

Syntax

C1.Win.C1Chart3D.Chart3DAxis

Remarks

Represents one axis of the chart.


Chart3DAxis All Members

Chart3DAxis Properties

AnnoFormat | Gets or sets the annotation format.
AnnoFormatString | Gets or sets the annotation format string used with manual formats.
AnnoMethod | Gets or sets annotation method of the axis.
AnnoPosition | Gets or sets the position of the axis annotation and text.
AnnoRotated | Gets or sets whether annotation rotated.
AutoMajor | Gets or sets whether major tick mark values are calculated automatically.
AutoMax | Gets or sets whether the axis maximum value is calculated automatically.
AutoMin | Gets or sets whether the axis minimum value is calculated automatically.
AutoMinor | Gets or sets whether minor tick mark values are calculated automatically.
MajorGrid | Gets or sets the major grid lines object.
Max | Gets or sets whether the axis maximum value is calculated automatically.
Min | Gets or sets whether the axis minimum value is calculated automatically.
Title | Gets or sets the title of the axis.
UnitMajor | Gets or sets the units between major tick marks.
UnitMinor | Gets or sets the units between minor tick marks.
ValueLabels | Gets the axis value labels.
Visible | Gets or sets the axis visibility.

Chart3DAxis Methods

ShouldSerializeMax | Returns true if the Axis Max property is not in the default state.
ShouldSerializeMin | Returns true if the Axis Min property is not in the default state.
ShouldSerializeUnitMajor | Returns true if the Axis UnitMajor property is not in the default state.
ShouldSerializeUnitMinor | Returns true if the Axis UnitMinor property is not in the default state.


Chart3DAxis Properties

AnnoFormat Property

AnnoFormatString Property (Chart3DAxis)

AnnoMethod Property

AnnoPosition Property

AnnoRotated Property

AutoMajor Property (Chart3DAxis)

AutoMax Property (Chart3DAxis)

AutoMin Property (Chart3DAxis)

AutoMinor Property (Chart3DAxis)

MajorGrid Property

Max Property (Chart3DAxis)

Min Property (Chart3DAxis)

Title Property (Chart3DAxis)

UnitMajor Property (Chart3DAxis)

UnitMinor Property (Chart3DAxis)

ValueLabels Property

Visible Property (Chart3DAxis)


AnnoFormat Property

AnnoFormat Property

Gets or sets the annotation format.

Syntax

[VB]

Public Property AnnoFormat As FormatEnum

[C#]

public FormatEnum AnnoFormat { get; set; }

[Delphi]

property AnnoFormat: FormatEnum;

Remarks

The AnnoFormat property allow specification of numeric and time formats using enumerated values.

For numeric values, each of the enumerations specify formatting similar to that specified by the .Net NumberFormatInfo class, including Currency, General, Exponential, Percentage, Roundtrip and Hexadecimal. NumericManual is used in conjunction with the AnnoFormatString property to specify a custom format string.

For date/time values, each of the enumerations specify formatting similar to that specified by the .Net DateTimeFormatInfo class, including combinations of long and short dates and times, and universional time representations. DateManual is used in conjunction with the AnnoFormatString property to specify a custom format string.

See Also

Chart3DAxis Class


AnnoFormatString Property (Chart3DAxis)

AnnoFormatString Property (Chart3DAxis)

Gets or set the annotation format string used with manual formats.

Syntax

[VB]

Public Property AnnoFormatString As String

[C#]

public string AnnoFormatString { get; set; }

[Delphi]

property AnnoFormatString: string;

Remarks

Only used when AnnoFormat property is NumericManual or DateManual. The AnnoFormatString property specifies a custom string for formatting the annotations along the axis.

When the AnnoFormat property is NumericManual, the AnnoFormatString property can be set to format strings as described by the .Net double.ToString(AnnoFormatString) method call. Custom numeric format strings are described in detail by the .Net documentation under “Custom Numeric Format Strings”. If the AnnoFormatString property is empty, then “g” or General is used.

When the AnnoFormat property is DateManual, the AnnoFormatString property can be set to format string as described by the .Net DateTime.ToString(AnnoFormatSTring) method call. Custom DateTime format strings are described in detail by the .Net documentation under “Date and Time Format Strings”. If the AnnoFormatString property is empty, then C1Chart selects a format string appropriate for the time span defined by the axis maximum and minimum values.

See Also

Chart3DAxis Class


AnnoMethod Property

AnnoMethod Property

Gets or sets annotation method of the axis.

Syntax

[VB]

Public Property AnnoMethod As AnnotationMethodEnum

[C#]

public AnnotationMethodEnum AnnoMethod { get; set; }

[Delphi]

property AnnoMethod: AnnotationMethodEnum;

See Also

Chart3DAxis Class


AnnoPosition Property

AnnoPosition Property

Gets or sets the position of the axis annotation and text.

Syntax

[VB]

Public Property AnnoPosition As AnnoPositionEnum

[C#]

public AnnoPositionEnum AnnoPosition {get; set;}

[Delphi]

property AnnoPosition: AnnoPositionEnum;

See Also

Chart3DAxis Class


AnnoRotated Property

AnnoRotated Property

Gets or sets whether annotation rotated.

Syntax

[VB]

Public Property AnnoRotated As Boolean

[C#]

public bool AnnoRotated { get; set; }

[Delphi]

property AnnoRotated: Boolean;

See Also

Chart3DAxis Class


AutoMajor Property (Chart3DAxis)

AutoMajor Property (Chart3DAxis)

Gets or sets whether major tick mark values are calculated automatically.

Syntax

[VB]

Public Property AutoMajor As Boolean

[C#]

public bool AutoMajor { get; set; }

[Delphi]

property AutoMajor: Boolean;

Remarks

Setting the UnitMajor property automatically sets AutoMajor to false.

See Also

Chart3DAxis Class


AutoMax Property (Chart3DAxis)

AutoMax Property (Chart3DAxis)

Gets or sets whether the axis maximum value is calculated automatically.

Syntax

[VB]

Public Property AutoMax As Boolean

[C#]

public bool AutoMax { get; set; }

[Delphi]

property AutoMax: Boolean;

Remarks

Setting the Max property automatically sets AutoMax to false.

See Also

Chart3DAxis Class


AutoMin Property (Chart3DAxis)

AutoMin Property (Chart3DAxis)

Gets or sets whether the axis minimum value is calculated automatically.

Syntax

[VB]

Public Property AutoMin As Boolean

[C#]

public bool AutoMin { get; set; }

[Delphi]

property AutoMin: Boolean;

Remarks

Setting the Min property automatically sets AutoMin to false.

See Also

Chart3DAxis Class


AutoMinor Property (Chart3DAxis)

AutoMinor Property (Chart3DAxis)

Gets or sets whether minor tick mark values are calculated automatically.

Syntax

[VB]

Public Property AutoMinor As Boolean

[C#]

public bool AutoMinor { get; set; }

[Delphi]

property AutoMinor: Boolean;

Remarks

Setting the UnitMinor property automatically sets AutoMinor to false.

See Also

Chart3DAxis Class


MajorGrid Property

MajorGrid Property

Gets or sets the major grid lines object.

Syntax

[VB]

Public Property MajorGrid As Chart3DGridLines

[C#]

public Chart3DGridLines MajorGrid { get; }

[Delphi]

property MajorGrid: Chart3DGridLines;

Remarks

Major grids are placed coincident with major tickmarks at UnitMajor intervals. The MajorGrid property is used to set the grid line appearance.

See Also

Chart3DAxis Class


Max Property (Chart3DAxis)

Max Property (Chart3DAxis)

Gets or sets the maximum value of the axis.

Syntax

[VB]

Public Property Max As Double

[C#]

public double Max { get; set; }

[Delphi]

property Max: Double;

See Also

Chart3DAxis Class


Min Property (Chart3DAxis)

Min Property (Chart3DAxis)

Gets or sets the minimum value of the axis.

Syntax

[VB]

Public Property Min As Double

[C#]

public double Min { get; set; }

[Delphi]

property Min: Double;

See Also

Chart3DAxis Class


Title Property (Chart3DAxis)

Title Property (Chart3DAxis)

Gets or sets the title of the axis.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Chart3DAxis Class


UnitMajor Property (Chart3DAxis)

UnitMajor Property (Chart3DAxis)

Gets or sets the units between major tickmarks.

Syntax

[VB]

Public Property UnitMajor As Double

[C#]

public double UnitMajor { get; set; }

[Delphi]

property UnitMajor: Double;

Remarks

Setting this value turns off AutoMajor.

See Also

Chart3DAxis Class


UnitMinor Property (Chart3DAxis)

UnitMinor Property (Chart3DAxis)

Gets or sets the units between minor tickmarks.

Syntax

[VB]

Public Property UnitMinor As Double

[C#]

public double UnitMinor { get; set; }

[Delphi]

property UnitMinor: Double;

Remarks

Setting this value turns off AutoMinor.

See Also

Chart3DAxis Class


ValueLabels Property

ValueLabels Property

Gets the axis value labels.

Syntax

[VB]

Public ReadOnly Property ValueLabels As Chart3DAxisLabelsCollection

[C#]

public Chart3DAxisLabelsCollection ValueLabels { get;}

[Delphi]

property ValueLabels: Chart3DAxisLabelsCollection;

See Also

Chart3DAxis Class


Visible Property (Chart3DAxis)

Visible Property (Chart3DAxis)

Gets or sets the axis visibility.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

See Also

Chart3DAxis Class


Chart3DAxis Methods

ShouldSerializeMax Method

ShouldSerializeMin Method

ShouldSerializeUnitMajor Method

ShouldSerializeUnitMinor Method


ShouldSerializeMax Method

ShouldSerializeMax Method

Returns true if the Axis Max property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeMax() As Boolean

[C#]

public bool ShouldSerializeMax ( )

[Delphi]

function ShouldSerializeMax: Boolean;

Remarks

The default state is to automatically calculate the Max property value by setting the AutoMax property to true.

See Also

Chart3DAxis Class


ShouldSerializeMin Method

ShouldSerializeMin Method

Returns true if the Axis Min property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeMin() As Boolean

[C#]

public bool ShouldSerializeMin ( )

[Delphi]

function ShouldSerializeMin: Boolean;

Remarks

The default state is to automatically calculate the Min property value by setting the AutoMin property to true.

See Also

Chart3DAxis Class


ShouldSerializeUnitMajor Method

ShouldSerializeUnitMajor Method

Returns true if the Axis UnitMajor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeUnitMajor() As Boolean

[C#]

public bool ShouldSerializeUnitMajor ( )

[Delphi]

function ShouldSerializeUnitMajor: Boolean;

Remarks

The default state is to automatically calculate the UnitMajor property value by setting the AutoMajor property to true.

See Also

Chart3DAxis Class


ShouldSerializeUnitMinor Method

ShouldSerializeUnitMinor Method

Returns true if the Axis UnitMinor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeUnitMinor() As Boolean

[C#]

public bool ShouldSerializeUnitMinor ( )

[Delphi]

function ShouldSerializeUnitMinor: Boolean;

Remarks

The default state is to automatically calculate the MUnitMinor property value by setting the AutoMinor property to true.

See Also

Chart3DAxis Class


Chart3DAxisCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DaxisCollection

Remarks

The collection of three Chart3DAxis objects named “X”, “Y” and “Z”.


Chart3DAxisCollection All Members

Chart3DAxisCollection Properties

AxisFont | Gets or sets the axis annotation font.
AxisTitleFont | Gets or sets the axis title font.
Count | Gets the number of elements in the collection.
Item | Gets the specified Axis from the collection by numeric index or string.

Chart3DAxisCollection Methods

CopyTo

Copies the collection of the Chart3DAxis objects beginning with the specified index to an array of Chart3DAxis objects.


Chart3DAxisCollection Properties

AxisFont Property (Chart3DAxisCollection)

AxisTitleFont Property (Chart3DAxisCollection)

Count Property (Chart3DAxisCollection)

Item Property (Chart3DAxisCollection)


AxisFont Property (Chart3DAxisCollection)

AxisFont Property (Chart3DAxisCollection)

Gets or sets the axis annotation font.

Syntax

[VB]

Public Property AxisFont As Font

[C#]

public Font AxisFont { get; set; }

[Delphi]

property AxisFont: Font;

Remarks

The axis font size is measured in hundredths of the unit cube size. All axes have the same axis font.

See Also

Chart3DAxisCollection Class


AxisTitleFont Property (Chart3DAxisCollection)

AxisTitleFont Property (Chart3DAxisCollection)

Gets or sets the axis title font.

Syntax

[VB]

Public Property AxisTitleFont As Font

[C#]

public Font AxisTitleFont { get; set; }

[Delphi]

property AxisTitleFont: Font;

Remarks

The axis title font size is measured in hundredths of the unit cube size. All axes have the same axis title font.

See Also

Chart3DAxisCollection Class


Count Property (Chart3DAxisCollection)

Count Property (Chart3DAxisCollection)

Gets the number of elements in the collection.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DAxisCollection Class


Item Property (Chart3DAxisCollection)

Item Property (Chart3DAxisCollection)

Gets the specified Axis from the collection by numeric index or string.

Syntax

[VB]

Public ReadOnly Property Item(index As Integer) As Chart3DAxis

Public ReadOnly Property Item(name As String) As Chart3DAxis

[C#]

public Chart3DAxis this[int index]{ get; }

public Chart3DAxis this[string name]{ get; }

[Delphi]

property Item(index: Integer): Chart3DAxis;

property Item(name: string): Chart3DAxis;

See Also

Chart3DAxisCollection Class


Chart3DAxisCollection Methods

CopyTo Method (Chart3DAxisCollection)


CopyTo Method (Chart3DAxisCollection)

CopyTo Method (Chart3DAxisCollection)

Copies the collection Chart3DAxis elements beginning with the specified index to an array of Chart3DAxis objects.

Syntax

[VB]

Public Sub CopyTo (array As Chart3DAxis (), Index As Integer)

[C#]

public void CopyTo (Chart3DAxis [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DAxis; index: Integer);

See Also

Chart3DAxisCollection Class


Chart3DAxisLabel Class

Syntax

C1.Win.C1Chart3D.Chart3DAxisLabel


Chart3DAxisLabel All Members

Chart3DAxisLabel Properties

Text | Gets or sets label text.
Value | Gets or sets label value.


Chart3DAxisLabel Properties

Text Property (Chart3DAxisLabel)

Value Property (Chart3DAxisLabel)


Text Property (Chart3DAxisLabel)

Text Property (Chart3DAxisLabel)

Gets or sets label text.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Chart3DAxisLabel Class


Value Property (Chart3DAxisLabel)

Value Property (Chart3DAxisLabel)

Gets or sets label value.

Syntax

[VB]

Public Property Value As Double

[C#]

public double Value { get; set; }

[Delphi]

property Value: Double;

See Also

Chart3DAxisLabel Class


Chart3DAxisLabelsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DAxisLabelsCollection


Chart3DAxisLabelsCollection All Members

Chart3DAxisLabelsCollection Properties

Count | Gets the number of elements in the collection.
Item | Gets or sets the specified label from the collection by numeric index, or gets a label by its text value.

Chart3DAxisLabelsCollection Methods

Add | Creates a new label with specified value and text and appends it to the collection.
AddNewLabel | Creates a new label and appends it to the collection.
Contains | Determines whether the specified label exists in the collection.
CopyTo | Copies the collection of labels objects beginning with the specified index to an array of labels.
IndexOf | Determines the index of the specified label in the collection.
Insert | Inserts a label at the specified location in the collection.
Remove | Removes the specified label from the collection.


Chart3DAxisLabelsCollection Properties

Count Property (Chart3DAxisLabelsCollection)

Item Property (Chart3DAxisLabelsCollection)


Count Property (Chart3DAxisLabelsCollection)

Count Property (Chart3DAxisLabelsCollection)

Gets the number of elements in the collection.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DAxisLabelsCollection Class


Item Property (Chart3DAxisLabelsCollection)

Item Property (Chart3DAxisLabelsCollection)

Gets or sets the specified label from the collection by numeric index, or gets a label by its text value.

Syntax

[VB]

Public Property Item[index As Integer] As Chart3DAxisLabel

Public ReadOnly Property Item[text As string] As Chart3DAxisLabel

[C#]

public Chart3DAxisLabel this[int index]{ get; set;}

public Chart3DAxisLabel this[string text]{get;}

[Delphi]

property Item(index: Integer): Chart3DAxisLabel;

property Item(text: String): Chart3DAxisLabel;

See Also

Chart3DAxisLabelsCollection Class


Chart3DAxisLabelsCollection Methods

Add Method

AddNewLabel Method (Chart3DAxisLabelsCollection)

Contains Method (Chart3DAxisLabelsCollection)

CopyTo Method (Chart3DAxisLabelsCollection)

IndexOf Method

Insert Method

Remove Method


Add Method

Add Method

Creates a new label with specified value and text and appends it to the collection. If an existing label is specified, it is appended to the collection.

Syntax

[VB]

Public Function Add(value as Double, text As String) As Integer

Public Function Add(label as Chart3DAxisLabel) As Integer

[C#]

public int Add(double value, string text);

public int Add(Chart3DAxisLabel label);

[Delphi]

function Add(value: Double, text: string): Integer

function Add(label: Chart3DAxisLabel): Integer

Return Value

Integer

Remarks

The new label index is returned.

See Also

Chart3DAxisLabelsCollection Class


AddNewLabel Method (Chart3DAxisLabelsCollection)

AddNewLabel Method (Chart3DAxisLabelsCollection)

Creates a new label and appends it to the collection.

Syntax

[VB]

Public Function AddNewLabel() As Chart3DAxisLabel

[C#]

public Chart3DAxisLabel AddNewLabel();

[Delphi]

function AddNewLabel: Chart3DAxisLabel

Return Value

Chart3DAxisLabel Class

Remarks

The reference to the new label is returned.

See Also

Chart3DAxisLabelsCollection Class


Contains Method (Chart3DAxisLabelsCollection)

Contains Method (Chart3DAxisLabelsCollection)

Determines whether the specified label exists in the collection.

Syntax

[VB]

Public Function Contains (lbl As Chart3DAxisLabel) As Boolean

[C#]

public bool Contains (Chart3DAxisLabel lbl)

[Delphi]

function Contains(lbl: Chart3DAxisLabel): Boolean;

See Also

Chart3DAxisLabelsCollection Class


CopyTo Method (Chart3DAxisLabelsCollection)

CopyTo Method (Chart3DAxisLabelsCollection)

Copies the collection of labels objects beginning with the specified index to an array of labels.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DAxisLabel (), index As Integer)

[C#]

public void CopyTo (Chart3DAxisLabel [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DAxisLabel; index: Integer);

See Also

Chart3DAxisLabelsCollection Class


IndexOf Method

IndexOf Method

Determines the index of the specified label of the collection.

Syntax

[VB]

Public Function IndexOf(label As Chart3DAxisLabel) As Integer

[C#]

public int IndexOf(Chart3DAxisLabel label);

[Delphi]

function IndexOf(label: Chart3DAxisLabel): Integer;

Return Value

The index of the label is represented by an Integer.

See Also

Chart3DAxisLabelsCollection Class


Insert Method

Insert Method

Inserts the specified label at the specified index of the collection.

Syntax

[VB]

Public Sub Insert(ByVal index As Integer, ByVal lbl As Chart3DAxisLabel)

[C#]

public void Insert ( System.Int32 index , Chart3DAxisLabel lbl )

[Delphi]

procedure Insert(index: Integer; lbl: Chart3DAxisLabel);

See Also

Chart3DAxisLabelsCollection Class


Remove Method

Remove Method

Removes the specified label from the collection.

Syntax

[VB]

Public Sub Remove(label As Chart3DAxisLabel)

[C#]

public void Remove(Chart3DAxisLabel label);

[Delphi]

procedure Remove(label: Chart3DAxisLabel);

See Also

Chart3DAxisLabelsCollection Class


Chart3DBar Class

Syntax

C1.Win.C1Chart3D.Chart3DBar

Remarks

The Bar class and its properties are only used for bar charts. It is returned by the Bar property of a ChartGroup.


Chart3DBar All Members

Chart3DBar Properties

Colors | Gets the collection of BarColor objects.
ColumnFormat | Gets or sets column format.
ColumnWidth | Gets or sets column width.
Origin | Gets or sets origin of Z-axis for the bar chart.
RowFormat | Gets or sets row format.
RowWidth | Gets or sets row width.

Chart3DBar Methods

GetBarColor | Gets individual bar color.
SetBarColor | Sets individual bar color.


Chart3DBar Properties

Colors Property

ColumnFormat Property

ColumnWidth Property

Origin Property

RowFormat Property

RowWidth Property


Colors Property

Colors Property

Gets the collection of BarColor objects.

Syntax

[VB]

Public ReadOnly Property Colors As BarColorCollection

[C#]

public BarColorCollection Colors { get; }

[Delphi]

property Colors: BarColorCollection;

See Also

Chart3DBar Class


ColumnFormat Property

ColumnFormat Property

Gets or sets column format.

Syntax

[VB]

Public Property ColumnFormat As BarFormatEnum

[C#]

public BarFormatEnum ColumnFormat { get; set; }

[Delphi]

property ColumnFormat: BarFormatEnum;

See Also

Chart3DBar Class


ColumnWidth Property

ColumnWidth Property

Gets or sets column width.

Syntax

[VB]

Public Property ColumnWidth As Single

[C#]

public float ColumnWidth { get; set; }

[Delphi]

property ColumnWidth: single;

Remarks

Width is measured as a percentage of the total amount of space available.

See Also

Chart3DBar Class


Origin Property

Origin Property

Gets or sets origin of Z-axis for the bar chart.

Syntax

[VB]

Public Property Origin As Double

[C#]

public double Origin { get; set; }

[Delphi]

property Origin: Double;

Remarks

Defines the Z-value from which bars are filled.

See Also

Chart3DBar Class


RowFormat Property

RowFormat Property

Gets or sets row format.

Syntax

[VB]

Public Property RowFormat As BarFormatEnum

[C#]

public BarFormatEnum RowFormat { get; set; }

[Delphi]

property RowFormat: BarFormatEnum;

See Also

Chart3DBar Class


RowWidth Property

RowWidth Property

Gets or sets row width.

Syntax

[VB]

Public Property RowWidth As Single

[C#]

public float RowWidth { get; set; }

[Delphi]

property RowWidth: single;

Remarks

Width is measured as a percentage of the total amount of space available.

See Also

Chart3DBar Class


Chart3DBar Methods

GetBarColor Method

SetBarColor Method


GetBarColor Method

GetBarColor Method

Gets an individual bar color.

Syntax

[VB]

Public Function GetBarColor (column As Integer, row As Integer)

[C#]

public Color GetBarColor (int column, int row)

[Delphi]

function GetBarColor(column: Integer; row: Integer);

Return Value

Color

Remarks

If the row is equal to –1, then this method applies to the entire row. If the column is equal to -1, then this method applies to entire column.

Applies To

Chart3DBar Class


SetBarColor Method

SetBarColor Method

Sets individual bar color.

Syntax

[VB]

Public Sub SetBarColor (column As Integer, row As Integer, color As Color)

[C#]

public void SetBarColor (int column, int row, Color color)

[Delphi]

procedure SetBarColor(column: Integer; row: Integer; color: Color);

Remarks

If the row is equal to –1, then this method applies to the entire row. If the column is equal to -1, then this method applies to entire column.

See Also

Chart3DBar Class


Chart3DColorsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DColorsCollection


Chart3DColorsCollection All Members

Chart3DColorsCollection Properties

Count | Gets number of collection elements.
Item | Gets or sets the specified Color by numeric index.

Chart3DColorsCollection Methods

Add | Adds new Color to the collection.
Contains | Determines if the specified Color is in the collection.
CopyTo | Copies the collection of Color objects beginning with the specified index to an array of Color objects.
IndexOf | Gets the index of the specified Color in the collection.
Insert | Inserts the specified Color in the collection at the specified index.
Remove | Removes the specified Color from the collection.


Chart3DColorsCollection Properties

Count Property (Chart3DColorsCollection)

Item Property (Chart3DColorsCollection)


Count Property (Chart3DColorsCollection)

Count Property (Chart3DColorsCollection)

Gets number of collection elements.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DColorsCollection Class


Item Property (Chart3DColorsCollection)

Item Property (Chart3DColorsCollection)

Gets or sets the specified Color by numeric index.

Syntax

[VB]

Public Property Item(Index As Integer) As Color

[C#]

public Color this[int index]{ get; set; }

[Delphi]

property Item(index: Integer): Color;

See Also

Chart3DColorsCollection Class


Chart3DColorsCollection Methods

Add Method (Chart3DColorsCollection)

Contains Method (Chart3DColorsCollection)

CopyTo Method (Chart3DColorsCollection)

IndexOf Method (Chart3DColorsCollection)

Insert Method (Chart3DColorsCollection)

Remove Method (Chart3DColorsCollection)


Add Method (Chart3DColorsCollection)

Add Method (Chart3DColorsCollection)

Add new Color to the collection.

Syntax

[VB]

Public Function Add( Clr As Color) As Integer

[C#]

public int Add( Color clr);

[Delphi]

function Add(Clr: Color): Integer;

Return Value

An integer indicating the index of the collection to which the Color was added.

See Also

Chart3DColorsCollection Class


Contains Method (Chart3DColorsCollection)

Contains Method (Chart3DColorsCollection)

Determines if the specified Color is in the collection.

Syntax

[VB]

Public Function Contains(Clr As Color) As Boolean

[C#]

public bool Contains(Color clr);

[Delphi]

function Contains(Clr: Color): Boolean;

Return Value

A boolean indicating if the Color is in the collection.

See Also

Chart3DColorsCollection Class


CopyTo Method (Chart3DColorsCollection)

CopyTo Method (Chart3DColorsCollection)

Copies the collection Color elements beginning with the specified index to an array of Color.

Syntax

[VB]

Public Sub CopyTo(array As Color(), index As Integer)

[C#]

public void CopyTo(color[] array, int Index)

[Delphi]

procedure CopyTo(array: Color; index: Integer);

See Also

Chart3DColorsCollection Class


IndexOf Method (Chart3DColorsCollection)

IndexOf Method (Chart3DColorsCollection)

Gets the index of the specified Color in the collection.

Syntax

[VB]

Public Function IndexOf(Clr As Color) As Integer

[C#]

public int IndexOf(Color clr);

[Delphi]

function IndexOf(Clr: Color): Integer;

Return Value

The index of the color is represented by an Integer.

See Also

Chart3DColorsCollection Class


Insert Method (Chart3DColorsCollection)

Insert Method (Chart3DColorsCollection)

Inserts the specified Color at the specified index of the collection.

Syntax

[VB]

Public Sub Insert(index As Integer, Clr As Color)

[C#]

public void Insert(int Index, Color clr);

[Delphi]

procedure Insert(index: Integer; Clr: Color);

See Also

Chart3DColorsCollection Class


Remove Method (Chart3DColorsCollection)

Remove Method (Chart3DColorsCollection)

Removes the specified Color from the collection.

Syntax

[VB]

Public Sub Remove(Clr As Color)

[C#]

public void Remove(Color clr);

[Delphi]

procedure Remove(clr: Clear);

See Also

Chart3DColorsCollection Class


Chart3DContour Class

Syntax

C1.Win.C1Chart3D.Chart3DContour

Remarks

The Chart3DContour class and its properties are used for contour and zone charts. It is returned by the Contour property of a ChartGroup.


Chart3DContour All Members

Chart3DContour Properties

AutoDistribution | Whether to use a linear distribution table to determine the spacing of contour levels.
Distribution | Gets or sets array labels for contour calculations.
IsContoured | Gets or sets whether chart contoured.
IsShaded | If True, displays the surface or bars as a flat shade of color.
IsZoned | Gets or sets whether chart zoned.
Item | Gets the specified Chart3DContourLevel by numeric index.
Levels | Gets collection of Chart3DContourLevel objects.
NumLevels | Gets or sets number of contour levels.
ZoneMethod | Gets or sets zone method.


Chart3DContour Properties

AutoDistribution Property

Distribution Property

IsContoured Property (Chart3DContour)

IsShaded Property (Chart3DContour)

IsZoned Property (Chart3DContour)

Item Property (Chart3DContour)

Levels Property

NumLevels Property

ZoneMethod Property


AutoDistribution Property

AutoDistribution Property

Whether to use a linear distribution table to determine the spacing of contour levels.

Syntax

[VB]

Public Property AutoDistribution As Boolean

[C#]

public bool AutoDistribution { get; set; }

[Delphi]

property AutoDistribution: Boolean;

Remarks

When AutoDistribution is true the chart automatically generates linear distribution table using NumLevels property.

See Also

Chart3DContour Class


Distribution Property

Distribution Property

Gets or sets array labels for contour calculations.

Syntax

[VB]

Public Property Distribution As Double()

[C#]

public double[] Distribution { get; set; }

[Delphi]

property Distribution: Double;

See Also

Chart3DContour Class


IsContoured Property (Chart3DContour)

IsContoured Property (Chart3DContour)

Gets or sets whether chart contoured.

Syntax

[VB]

Public Property IsContoured As Boolean

[C#]

public bool IsContoured { get; set; }

[Delphi]

property IsContoured: Boolean;

See Also

Chart3DContour Class


IsShaded Property (Chart3DContour)

IsShaded Property (Chart3DContour)

If True, displays the surface or bars as a flat shade of color.

Syntax

[VB]

Public Property IsShaded As Boolean

[C#]

public bool IsShaded { get; set; }

[Delphi]

property IsShaded: Boolean;

Remarks

Is used only for bar and surface charts.

See Also

Chart3DContour Class


IsZoned Property (Chart3DContour)

IsZoned Property (Chart3DContour)

Gets or sets whether chart zoned.

Syntax

[VB]

Public Property IsZoned As Boolean

[C#]

public bool IsZoned { get; set; }

[Delphi]

property IsZoned: Boolean;

See Also

Chart3DContour Class


Item Property (Chart3DContour)

Item Property (Chart3DContour)

Gets the specified Chart3DContourLevel by numeric index.

Syntax

[VB]

Default Public ReadOnly Property Item(index As Integer) As Chart3DContourLevel

[C#]

public Chart3DContourLevel this[int index]{ get; }

[Delphi]

property Item(index: Integer): Chart3DContourLevel;

See Also

Chart3DContour Class


Levels Property

Levels Property

Gets collection of contour levels.

Syntax

[VB]

Public ReadOnly Property Levels As Chart3DContourLevelsCollection

[C#]

public Chart3DContourLevelsCollection Levels { get; }

[Delphi]

property Levels: Chart3DContourLevelsCollection;

See Also

Chart3DContour Class


NumLevels Property

NumLevels Property

Gets or sets number of contour levels.

Syntax

[VB]

Public Property NumLevels As Integer

[C#]

public int NumLevels { get; set; }

[Delphi]

property NumLevels: Integer;

Remarks

This has no effect when the chart is using a custom distribution table(AutoDistribution property is false).

See Also

Chart3DContour Class


ZoneMethod Property

ZoneMethod Property

Gets or sets zone method.

Syntax

[VB]

Public Property ZoneMethod As ZoneMethodEnum

[C#]

public ZoneMethodEnum ZoneMethod { get; set; }

[Delphi]

property ZoneMethod: ZoneMethodEnum;

See Also

Chart3DContour Class


Chart3DContourLevel Class

Syntax

C1.Win.C1Chart3D.Chart3DContourLevel

Remarks

Represents level of contour or zone chart.


Chart3DContourLevel All Members

Chart3DContourLevel Properties

Level | Gets or sets level value.
Style | Gets or sets contour style corresponding to this level.


Chart3DContourLevel Properties

Level Property

Style Property (Chart3DContourLevel)


Level Property

Level Property

Gets or sets level value.

Syntax

[VB]

Public Property Level As Double

[C#]

public double Level { get; set; }

[Delphi]

property Level: Double;

See Also

Chart3DContourLevel Class


Style Property (Chart3DContourLevel)

Style Property (Chart3DContourLevel)

Gets or sets contour style corresponding to this level.

Syntax

[VB]

Public Property Style As Chart3DContourStyle

[C#]

public Chart3DContourStyle Style { get; }

[Delphi]

property Style: Chart3DContourStyle;

See Also

Chart3DContourLevel Class


Chart3DContourLevelsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DContourLevelsCollection


Chart3DContourLevelsCollection All Members

Chart3DContourLevelsCollection Properties

Count | Gets number of collection elements.
Item | Gets the specified Chart3DContourLevel by numeric index.

Chart3DContourLevelsCollection Methods

Add | Add new Chart3DContourLevel to the collection.
Contains | Determines whether the specified Chart3DcontourLevel exists in the collection.
CopyTo | Copies the collection of Chart3DcontourLevel objects beginning with the specified index to an array of Chart3DcontourLevel objects.
IndexOf | Determines the index of the specified Chart3DcontourLevel object in the collection.
Insert | Inserts a Chart3DcontourLevel object at the specified location in the collection.
Remove | Remove Chart3DContourLevel with specified value from the collection.


Chart3DContourLevelsCollection Properties

Count Property (Chart3DContourLevelsCollection)

Item Property (Chart3DContourLevelsCollection)


Count Property (Chart3DContourLevelsCollection)

Count Property (Chart3DContourLevelsCollection)

Gets number of collection elements.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DContourLevelsCollection Class


Item Property (Chart3DContourLevelsCollection)

Item Property (Chart3DContourLevelsCollection)

Gets the specified Chart3DContourLevel by numeric index.

Syntax

[VB]

Public ReadOnly Property Item(Index As Integer) As Chart3DContourLevel

[C#]

public Chart3DContourLevel this[int index]{ get;}

[Delphi]

property Item(index: Integer): Chart3DContourLevel;

See Also

Chart3DContourLevelsCollection Class


Chart3DContourLevelsCollection Methods

Add Method (Chart3DContourLevelsCollection)

Contains Method (Chart3DContourLevelsCollection)

CopyTo Method (Chart3DContourLevelsCollection)

IndexOf Method (Chart3DContourLevelsCollection)

Insert Method (Chart3DContourLevelsCollection)

Remove Method (Chart3DContourLevelsCollection)


Add Method (Chart3DContourLevelsCollection)

Add Method (Chart3DContourLevelsCollection)

Add new contour level with specified value to the collection.

Syntax

[VB]

Public Function Add (val As Chart3DContourLevel) As Integer

Public Function Add (val As Single) As Integer

Public Function Add (val As Double) As Integer

[C#]

public int Add (Chart3DcontourLevel val);

public int Add (float val);

public int Add (double val);

[Delphi]

function Add(val: Chart3DcontourLevel): Integer;

function Add(val: Single): Integer;

function Add(val: Double): Integer;

Return Value

An integer indicating the index of the collection to which the contour level was added.

See Also

Chart3DContourLevelsCollection Class


Contains Method (Chart3DContourLevelsCollection)

Contains Method (Chart3DContourLevelsCollection)

Determines whether the specified Chart3DContourLevel exists in the collection.

Syntax

[VB]

Public Function Contains (lvl As Chart3DContourLevel) As Boolean

[C#]

public bool Contains (Chart3DcontourLevel lvl)

[Delphi]

function Contains(lvl: Chart3DContourLevel): Boolean;

Return Value

A boolean value that indicates whether the Chart3DContourLevel is a member of the collection.

See Also

Chart3DContourLevelsCollection Class


CopyTo Method (Chart3DContourLevelsCollection)

CopyTo Method (Chart3DContourLevelsCollection)

Copies the collection BarColor elements beginning with the specified index to an array of BarColor objects.

Syntax

[VB]

Public Sub CopyTo (array As Chart3DContourLevel(), Index As Integer)

[C#]

public void CopyTo (Chart3DContourLevel [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DContourLevel; index: Integer);

See Also

Chart3DContourLevelsCollection Class


IndexOf Method (Chart3DContourLevelsCollection)

IndexOf Method (Chart3DContourLevelsCollection)

Gets the index of the specified Chart3DContourLevel in the collection.

Syntax

[VB]

Public Function IndexOf(lvl As Chart3DContourLevel) As Integer

[C#]

public int IndexOf (Chart3DContourLevel lvl)

[Delphi]

function IndexOf(lvl: Chart3DContourLevel): Integer;

Return Value

The index of the specified Chart3DContourLevel is indicated by an Integer.

See Also

Chart3DContourLevelsCollection Class


Insert Method (Chart3DContourLevelsCollection)

Insert Method (Chart3DContourLevelsCollection)

Adds a Chart3DContourLevel object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert (index As Integer, level As Chart3DContourLevel)

[C#]

public void Insert (int Index, Chart3DContourLevel level);

[Delphi]

procedure Insert(index: Integer; level: Chart3DContourLevel);

See Also

Chart3DContourLevelsCollection Class


Remove Method (Chart3DContourLevelsCollection)

Remove Method (Chart3DContourLevelsCollection)

Remove contour level with specified value from the collection.

Syntax

[VB]

Public Sub Remove (val As Chart3DContourLevel)

Public Sub Remove(val As Double)

[C#]

public void Remove (double Chart3DContourLevel);

public void Remove(double val);

[Delphi]

function Remove(val: Chart3DContourLevel);

function Remove(val: Double);

See Also

Chart3DContourLevelsCollection Class


Chart3DContourStyle Class

Syntax

C1.Win.C1Chart3D.Chart3DContourStyle

Remarks

Represents appearance of one level of contour and zone charts.


Chart3DContourStyle All Members

Chart3DContourStyle Properties

FillColor | Gets or sets zone fill color.
LineStyle | Gets or sets line style for drawing contours.


Chart3DContourStyle Properties

FillColor Property

LineStyle Property


FillColor Property

FillColor Property

Gets or sets zone fill color.

Syntax

[VB]

Public Property FillColor As Color

[C#]

public Color FillColor { get; set; }

[Delphi]

property FillColor: Color;

See Also

Chart3DContourStyle Class


LineStyle Property

LineStyle Property

Gets or sets line style for drawing contours.

Syntax

[VB]

Public Property LineStyle As Chart3DLineStyle

[C#]

public Chart3DLineStyle LineStyle { get; set; }

[Delphi]

property LineStyle: Chart3DLineStyle;

See Also

Chart3DContourStyle Class


Chart3DContourStyles Class

Syntax

C1.Win.C1Chart3D.Chart3DContourStyles

Remarks


Chart3DContourStyles All Members

Chart3DContourStyles Properties

Colors | Gets color collection for contour styles.
ColorSet | Gets or sets predefined color collections for contour styles.
Item | Gets the specified Chart3DStyle by numeric index.
Styles | Gets the collection of Chart3DStyle objects.

Chart3DContourStyles Methods

Reset | Resets the Chart3DContourStyles to the default state.
ShouldSerializeColors | Returns true if the Chart3DContourStyles Colors property is not in the default state.
ShouldSerializeStyles | Returns true if the Chart3DContourStyles Styles property is not in the default state.


Chart3DContourStyles Properties

Colors Property

ColorSet Property

Item Property (Chart3DContourStyles)

Styles Property (Chart3DContourStyles)


Colors Property

Colors Property

Gets color collection for contour styles.

Syntax

[VB]

Public ReadOnly Property Colors As Chart3DColorsCollection

[C#]

public Chart3DColorsCollection Colors { get; }

[Delphi]

property Colors: Chart3DColorsCollection;

See Also

Chart3DContourStyles Class


ColorSet Property

ColorSet Property

Gets or sets predefined color collections for contour styles.

Syntax

[VB]

Public Property ColorSet As ColorSetEnum

[C#]

public ColorSetEnum ColorSet { get; set;}

[Delphi]

property ColorSet: ColorSetEnum;

See Also

Chart3DContourStyles Class


Item Property (Chart3DContourStyles)

Item Property (Chart3DContourStyles)

Gets the specified Chart3DStyle by numeric index.

Syntax

[VB]

Public Item(index as Integer) As Chart3DContourStyle

[C#]

public Chart3DContourStyle this[int index]{ get; }

[Delphi]

property Item(index: Integer): Chart3DContourStyle;

See Also

Chart3DContourStyles Class


Styles Property (Chart3DContourStyles)

Styles Property (Chart3DContourStyles)

Gets the collection of contour styles.

Syntax

[VB]

Public ReadOnly Property Styles As Chart3DContourStylesCollection

[C#]

public Chart3DContourStylesCollection Styles { get; }

[Delphi]

property Styles: Chart3DContourStylesCollection;

See Also

Chart3DContourStyles Class


Chart3DContourStyles Methods

Reset Method

ShouldSerializeColors Method

ShouldSerializeStyles Method


Reset Method

Reset Method

Resets the Chart3DContourStyles to the default state.

Syntax

[VB]

Public Sub Reset()

[C#]

public void Reset ( )

[Delphi]

procedure Reset;

See Also

Chart3DContourStyles Class


ShouldSerializeColors Method

ShouldSerializeColors Method

Returns true if the Chart3DContourStyles Colors property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeColors() As Boolean

[C#]

public bool ShouldSerializeColors ( )

[Delphi]

function ShouldSerializeColors: Boolean;

See Also

Chart3DContourStyles Class


ShouldSerializeStyles Method

ShouldSerializeStyles Method

Returns true if the Chart3DContourStyles Styles property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeStyles() As Boolean

[C#]

public bool ShouldSerializeStyles ( )

[Delphi]

function ShouldSerializeStyles: Boolean;

See Also

Chart3DContourStyles Class


Chart3DContourStylesCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DContourStylesCollection


Chart3DContourStylesCollection All Members

Chart3DContourStylesCollection Properties

Count | Gets number of collection elements.
Item | Gets the specified Chart3DStyle by numeric index.

Chart3DContourStylesCollection Methods

Add | Adds a contour style to the collection.
Contains | Determines whether the specified Chart3DContourStyle exists in the collection.
CopyTo | Copies the collection of Chart3DContourStyle elements beginning with the specified index to an array of Chart3DContourStyle objects.
IndexOf | Gets the index of the specified Chart3DContourStyle in the collection.
Insert | Adds a Chart3DContourStyle object to the collection at the specified index.
Remove | Removes a Chart3DContourStyle object from the collection.


Chart3DContourStylesCollection Properties

Count Property (Chart3DContourStylesCollection)

Item Property (Chart3DContourStylesCollection)


Count Property (Chart3DContourStylesCollection)

Count Property (Chart3DContourStylesCollection)

Gets number of collection elements.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DContourStylesCollection Class


Item Property (Chart3DContourStylesCollection)

Item Property (Chart3DContourStylesCollection)

Gets the specified Chart3DStyle by numeric index.

Syntax

[VB]

Public ReadOnly Property Item[index as Integer] As Chart3DContourStyle

[C#]

public Chart3DContourStyle this[int index]{ get; }

[Delphi]

property Item(index: Integer): Chart3DContourStyle;

See Also

Chart3DContourStylesCollection Class


Chart3DContourStylesCollection Methods

Add Method (Chart3DContourStylesCollection)

Contains Method (Chart3DContourStylesCollection)

CopyTo Method (Chart3DContourStylesCollection)

IndexOf Method (Chart3DContourStylesCollection)

Insert Method (Chart3DContourStylesCollection)

Remove Method (Chart3DContourStylesCollection)


Add Method (Chart3DContourStylesCollection)

Add Method (Chart3DContourStylesCollection)

Add specified contour style to the collection.

Syntax

[VB]

Public Function Add (style As Chart3DContourStyle) As Integer

[C#]

public int Add(Chart3DContourStyle);

[Delphi]

function Add(style: Chart3DContourStyle): Integer;

Return Value

An integer indicating the index of the collection to which the contour style was added.

See Also

Chart3DContourStylesCollection Class


Contains Method (Chart3DContourStylesCollection)

Contains Method (Chart3DContourStylesCollection)

Determines whether the specified Chart3DContourStyle exists in the collection.

Syntax

[VB]

Public Function Contains (style As Chart3DContourStyle) As Boolean

[C#]

public bool Contains (Chart3DContourStyle style)

[Delphi]

function Contains(style: Chart3DContourStyle): Boolean;

Return Value

A boolean value that indicates whether the Chart3DContourStyle is a member of the collection.

See Also

Chart3DContourStylesCollection Class


CopyTo Method (Chart3DContourStylesCollection)

CopyTo Method (Chart3DContourStylesCollection)

Copies the collection Chart3DContourStyle elements beginning with the specified index to an array of Chart3DContourStyle objects.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DContourStyle(), index As Integer)

[C#]

public void CopyTo (Chart3DContourStyle [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DContourStyle; index: Integer);

See Also

Chart3DContourStylesCollection Class


IndexOf Method (Chart3DContourStylesCollection)

IndexOf Method (Chart3DContourStylesCollection)

Gets the index of the specified Chart3DContourStyle in the collection.

Syntax

[VB]

Public Function IndexOf (style As Chart3DContourStyle) As Integer

[C#]

public int IndexOf (Chart3DContourStyle style)

[Delphi]

function IndexOf(style: Chart3DContourStyle): Integer;

Return Value

The index of the specified Chart3DContourStyle indicated by an Integer.

See Also

Chart3DContourStylesCollection Class


Insert Method (Chart3DContourStylesCollection)

Insert Method (Chart3DContourStylesCollection)

Adds a Chart3DContourStyle object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, style As Chart3DContourStyle)

[C#]

public void Insert (int Index, Chart3DContourStyle style)

[Delphi]

procedure Insert (index: Integer; style: Chart3DContourStyle;);

See Also

Chart3DContourStylesCollection Class


Remove Method (Chart3DContourStylesCollection)

Remove Method (Chart3DContourStylesCollection)

Removes a Chart3DContourStyle object from the collection.

Syntax

[VB]

Public Sub Remove(style As Chart3DContourStyle)

[C#]

public void Remove (Chart3DContourStyle style)

[Delphi]

procedure Remove (style: Chart3DContourStyle;);

See Also

Chart3DContourStylesCollection Class


Chart3DData Class

Syntax

C1.Win.C1Chart3D.Chart3DData


Chart3DData All Members

Chart3DData Properties

ContourData | Gets or sets contour data.
Layout | Gets or sets the chart data type.
Set | Gets or sets dataset.
SetGrid | Gets or sets regular grid dataset.
SetIrGrid | Gets or sets irregular grid dataset.
SetPoint | Gets or sets point dataset.

Chart3DData Methods

CoordToDataCoord | Maps a pixel coordinate to a data coordinate.
CoordToDataIndex | Picks the displayed data closest to the given pixel coordinate.
DataCoordToCoord | Maps a data coordinate to a pixel coordinate.
DataIndexToCoord | Determines a pixel coordinate by given a data row and column..
GetJaggedContourData | Returns an object containing contour data in a jagged double array.
GetMax | Gets the maximum data value for the coordinate indicated by the specified axis.
GetMin | Gets the minimum data value for the coordinate indicated by the specified axis.
LoadDataFromFile | Loads from the current Chart3DData object to the specified file in XML or ComponentOne Chart 7 format.
ResetContourData | Clears all contour data.
SaveDataToFile | Saves the contents of the current Chart3DData object to the specified file in XML or ComponentOne Chart 7 format (.dat).
SetJaggedContourData | Sets the contour with a two-dimensional integer array, or a jagged integer, jagged float or jagged double array.


Chart3DData Properties

ContourData Property

Layout Property

Set Property

SetGrid Property

SetIrGrid Property

SetPoint Property


ContourData Property

ContourData Property

Gets or sets contour data.

Syntax

[VB]

Public Property ContourData As Double(,)

[C#]

public double[,] ContourData { get; set; }

[Delphi]

property ContourData: Double;

Remarks

Used when drawing 4D charts. Can be used only for bar and surface charts, as well as grid and irregular grid data layout.

See Also

Chart3DData Class


Layout Property

Layout Property

Gets or sets the chart data layout type.

Syntax

[VB]

Public Property Layout As DataLayoutEnum

[C#]

public DataLayoutEnum Layout { get; set; }

[Delphi]

property Layout: DataLayoutEnum;

See Also

Chart3DData Class


Set Property

Set Property

Gets or sets dataset.

Syntax

[VB]

Public Property Set As Chart3DDataSet

[C#]

public Chart3DDataSet Set { get; set; }

[Delphi]

property Set: Chart3DDataSet;

Remarks

See Chart3DDataSet for details.

See Also

Chart3DData Class


SetGrid Property

SetGrid Property

Gets or sets regular grid dataset.

Syntax

[VB]

Public Property SetGrid As Chart3DDataSetGrid

[C#]

public Chart3DDataSetGrid SetGrid { get; set; }

[Delphi]

property SetGrid: Chart3DDataSetGrid;

Remarks

Applied only if DataLayout is GridData. See Chart3DDataSetGrid for details.

See Also

Chart3DData Class


SetIrGrid Property

SetIrGrid Property

Gets or sets irregular grid dataset.

Syntax

[VB]

Public Property SetIrGrid As Chart3DDataSetIrGrid

[C#]

public Chart3DDataSetIrGrid SetIrGrid { get; set; }

[Delphi]

property SetlrGrid: Chart3DDataSetIrGrid;

Remarks

Applied only if DataLayout is IrGridData. See Chart3DDataSetIrGrid for details.

See Also

Chart3DData Class


SetPoint Property

SetPoint Property

Gets or sets point dataset.

Syntax

[VB]

Public Property SetPoint As Chart3DDataSetPoint

[C#]

public Chart3DDataSetPoint SetPoint { get; set; }

[Delphi]

property SetPoint: Chart3DDataSetPoint;

Remarks

Applied only if DataLayout is PointData. See Chart3DDataSetPoint for details.

See Also

Chart3DData Class


Chart3DData Methods

CoordToDataCoord Method (Chart3DData)

CoordToDataIndex Method (Chart3DData)

DataCoordToCoord Method (Chart3DData)

DataIndexToCoord Method (Chart3DData)

GetJaggedContourData Method

GetMax Method (Chart3DData)

GetMin Method (Chart3DData)

LoadDataFromFile Method (Chart3DData)

ResetContourData Method (Chart3DData)

SaveDataToFile Method (Chart3DData)

SetJaggedContourData Method


CoordToDataCoord Method (Chart3DData)

CoordToDataCoord Method (Chart3DData)

Maps a pixel coordinate to a data coordinate.

Syntax

[VB]

Public Function CoordToDataCoord(PixelX As Integer, PixelY As Integer, ByRef X As Single, ByRef Y As Single, ByRef Z As Single) As Boolean

[C#]

public bool CoordToDataCoord( int PixelX, int PixelY, ref float X, ref float Y, ref float Z);

[Delphi]

function CoordToDataCoord(PixelX: Integer; PixelY: Integer; X: single; Y: single; Z: single): Boolean;

Return Value

Boolean result of coordinate conversion.

See Also

Chart3DData Class


CoordToDataIndex Method (Chart3DData)

CoordToDataIndex Method (Chart3DData)

Picks the displayed data closest to the given pixel coordinate.

Syntax

[VB]

Public Function CoordToDataIndex(PixelX As Integer, PixelY As Integer, ByRef Column As Integer, ByRef Row As Integer) As Boolean

[C#]

public bool CoordToDataIndex( int PixelX, int PixelY, ref int Column, ref int Row);

[Delphi]

function CoordToDataIndex(PixelX: Integer; PixelY: Integer; Column: Integer; Row: Integer): Boolean;

Remarks

For point data layout the column parameter relates to series index and the row parameter relates to point index.

Return Value

Boolean result of coordinate conversion.

See Also

Chart3DData Class


DataCoordToCoord Method (Chart3DData)

DataCoordToCoord Method (Chart3DData)

Maps a data coordinate to a pixel coordinate.

Syntax

[VB]

Public Function DataCoordToCoord(X As Single, Y As Single, Z As Single, ByRef PixelX As Integer, ByRef PixelY As Integer) As Boolean

[C#]

public bool DataCoordToCoord(float X, float Y, float Z, ref int PixelX, ref int PixelY);

[Delphi]

function DataCoordToCoord(X: single; Y: single; Z: single; PixelX: Integer; PixelY: Integer): Boolean;

Return Value

Boolean result of coordinate conversion.

See Also

Chart3DData Class


DataIndexToCoord Method (Chart3DData)

DataIndexToCoord Method (Chart3DData)

Determines a pixel coordinate by given a data row and column.

Syntax

[VB]

Public Function DataIndexToCoord(Column As Integer, Row As Integer, ByRef PixelX As Integer, ByRef PixelY As Integer) As Boolean

[C#]

public bool DataIndexToCoord(int Column, int Row, ref int PixelX, ref int PixelY);

[Delphi]

function DataIndexToCoord(Column: Integer; Row: Integer; PixelX: Integer; PixelY: Integer): Boolean;

Remarks

For point data layout the column parameter relates to series index and the row parameter relates to point index.

Return Value

Boolean result of coordinate conversion.

See Also

Chart3DData Class


GetJaggedContourData Method

GetJaggedContourData Method

Returns an object containing contour data in a jagged double array.

Syntax

[VB]

Public Function GetJaggedContourData() As Object

[C#]

public object GetJaggedContourData()

[Delphi]

function GetJaggedContourData (): Object;

Remarks

Jagged arrays are useful in certain instances for manipulating data. In Delphi, multiply dimensioned arrays are jagged. Delphi users should use the GetJaggedContourData method instead of the ContourData property.

See Also

Chart3DData Class


GetMax Method (Chart3DData)

GetMax Method (Chart3DData)

Gets the maximum data value for the coordinate indicated by the specified index.

Syntax

[VB]

Public Function GetMax (AxisType as AxisTypeEnum) As Double

[C#]

public double GetMax (AxisType As AxisTypeEnum);

[Delphi]

function GetMax(AxisType: AxisTypeEnum): Double;

Remarks

This method returns the data coordinate with the maximum value along the specified axis. For example, specifying AxisTypeEnum.AxisX as a calling parameter, will return the X coordinate value with the largest X value.

Return Value

Double value equal to the largest coordinate value.

See Also

Chart3DData Class


GetMin Method (Chart3DData)

GetMin Method (Chart3DData)

Gets the minimum data value for the coordinate indicated by the specified index.

Syntax

[VB]

Public Function GetMin (AxisType as AxisTypeEnum) As Double

[C#]

public double GetMin (AxisType As AxisTypeEnum);

[Delphi]

function GetMin(AxisType: AxisTypeEnum): Double;

Remarks

This method returns the data coordinate with the minimum value along the specified axis. For example, specifying AxisTypeEnum.AxisX as a calling parameter, will return the X coordinate value with the smallest X value.

Return Value

Double value equal to the smallest coordinate value.

See Also

Chart3DData Class


LoadDataFromFile Method (Chart3DData)

LoadDataFromFile Method (Chart3DData)

Saves the contents of the current Chart3DData object to the specified file in XML or ComponentOne Chart 7 format.

Syntax

[VB]

Public Sub LoadDataFromFile (Filename As String)

Public Sub LoadDataFromFile (Filename As String, Datafomat As DataFormatEnum)

[C#]

public void LoadDataFromFile (string Filename);

public void LoadDataFromFile (string Filename, DataFormatEnum Dataformat);

[Delphi]

procedure LoadDataFromFile(Filename: string);

procedure LoadDataFromFile(Filename: string; Dataformat: DataFormatEnum);

Remarks

This method loads the current Chart3DData object with the contents to the specified file in specified data format. If data format is not specified, the data format is defined by file extension. If file extension is “dat” then ComponentOne Chart 7 data format is used for loading data. Using any other extension leads to reading data in xml format. If an error occurs during the file reading, an appropriate exception is thrown indicating the cause of error.

See Also

Chart3DData Class


ResetContourData Method (Chart3DData)

ResetContourData Method (Chart3DData)

Clears all contour data.

Syntax

[VB]

Public Sub ResetContourData()

[C#]

public void ResetContourData();

[Delphi]

procedure ResetContourData;

Remarks

This method clears all contour data from the chart.

See Also

Chart3DData Class


SaveDataToFile Method (Chart3DData)

SaveDataToFile Method (Chart3DData)

Saves the contents of the current Chart3DData object to the specified file in XML or ComponentOne Chart 7 format (.dat).

Syntax

[VB]

Public Sub SaveDataToFile (Filename As String)

Public Sub SaveDataToFile (Filename As String, Dataformat As DataFormatEnum))

[C#]

public void SaveDataToFile (string Filename);

public void SaveDataToFile (string Filename, DataFormatEnum Dataformat);

[Delphi]

procedure SaveDataToFile(Filename: string);

procedure SaveDataToFile(Filename: string; DataFormat: DataFormatEnum);

Remarks

This method saves the Chart3DData object contents to the specified file in specified data format. If data format is not specified, the data format is defined by file extension. If file extension is “dat” then ComponentOne Chart 7 data format is used. Using any other extension leads to saving data in xml format. If an error occurs during the file creation or writing, an appropriate exception is thrown indicating the cause of error.

See Also

Chart3DData Class


SetJaggedContourData Method

SetJaggedContourData Method

Sets the contour data with a two-dimensional integer array, or a jagged integer, jagged float or jagged double array.

Syntax

[VB]

Public Sub SetJaggedContourData ( ContourData As Object)

[C#]

public void SetJaggedContourData ( object ContourData )

[Delphi]

procedure SetJaggedContourData ( ContourData: Object );

Remarks

Jagged arrays are useful in certain instances for manipulating data. In Delphi, multiply dimensioned arrays are jagged. This method will also conveniently accept a two-dimensional integer array. Delphi users should use the SetJaggedContourData method instead of the ContourData property.

For non-jagged arrays, set the ContourData property instead.

See Also

Chart3DData Class


Chart3DDataLabel Class

Syntax

C1.Win.C1Chart3D.Chart3DDataLabel


Chart3DDataLabel All Members

Chart3DDataLabel Properties

Index | Gets or sets index for label.
Text | Gets or sets label text.


Chart3DDataLabel Properties

Index Property

Text Property (Chart3DDataLabel)


Index Property

Index Property

Gets or sets index for label.

Syntax

[VB]

Public Property Index As Integer

[C#]

public int Index { get; set; }

[Delphi]

property Index: Integer;

Remarks

Represents row (RowLabels) or column (ColumnLabels) number.

See Also

Chart3DDataLabel Class


Text Property (Chart3DDataLabel)

Text Property (Chart3DDataLabel)

Gets or sets label text.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Chart3DDataLabel Class


Chart3DDataLabelsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DDataLabelsCollection


Chart3DDataLabelsCollection All Members

Chart3DDataLabelsCollection Properties

Count | Gets number of collection elements.
Item | Gets or sets the specified Chart3DDataLabel by numeric index, or gets a Chart3DDataLabel by its text value.

Chart3DDataLabelsCollection Methods

Add | Creates a new label with specified index and text and appends it to the collection.
AddNewLabel | Creates a new Chart3DDataLabel and appends it to the collection.
Contains | Determines whether the specified Chart3DDataLabel exists in the collection.
CopyTo | Copies the collection of Chart3DDataLabel objects beginning with the specified index to an array of Chart3DDataLabel objects.
IndexOf | Gets the index of the specified Chart3DDataLabel in the collection.
Insert | Adds a Chart3DDataLabel object to the collection at the specified index.
Remove | Removes a Chart3DDataLabel object from the collection.


Chart3DDataLabelsCollection Properties

Count Property (Chart3DDataLabelsCollection)

Item Property (Chart3DDataLabelsCollection)


Count Property (Chart3DDataLabelsCollection)

Count Property (Chart3DDataLabelsCollection)

Gets number of collection elements.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DDataLabelsCollection Class


Item Property (Chart3DDataLabelsCollection)

Item Property (Chart3DDataLabelsCollection)

Gets or sets the specified Chart3DDataLabel by numeric index, or gets a Chart3DDataLabel by its text value.

Syntax

[VB]

Public Property Item(Index As Integer) As Chart3DDataLabel

Public ReadOnly Property Item(text As string) As Chart3DDataLabel

[C#]

public Chart3DDataLabel this[int index]{ get; set; }

public Chart3DDataLabel this[string text]{get;}

[Delphi]

property Item(index: Integer): Chart3DDataLabel;

property Item(text: String): Chart3DDataLabel;

See Also

Chart3DDataLabelsCollection Class


Chart3DDataLabelsCollection Methods

Add Method (Chart3DDataLabelsCollection)

AddNewLabel Method (Chart3DDataLabelsCollection)

Contains Method (Chart3DDataLabelsCollection)

CopyTo Method (Chart3DDataLabelsCollection)

IndexOf Method (Chart3DDataLabelsCollection)

Insert Method (Chart3DDataLabelsCollection)

Remove Method (Chart3DDataLabelsCollection)


Add Method (Chart3DDataLabelsCollection)

Add Method (Chart3DDataLabelsCollection)

Creates a new label with specified index and text and appends it to the collection.

Syntax

[VB]

Public Function Add(label As Chart3DDataLabel) As Integer

Public Function Add(Index As Integer, Text As String) As Integer

[C#]

public int Add(Chart3DDataLabel label)

public int Add( int Index, string Text)

[Delphi]

function Add(label: As Chart3DDataLabel): Integer;

function Add(index: Integer; Text: string): Integer;

Return Value

An integer indicating the index of the collection to which the Chart3DDataLabel was added.

See Also

Chart3DDataLabelsCollection Class


AddNewLabel Method (Chart3DDataLabelsCollection)

AddNewLabel Method (Chart3DDataLabelsCollection)

Creates a new Chart3DDataLabel and appends it to the collection.

Syntax

[VB]

Public Function AddNewLabel () As Chart3DDataLabel

[C#]

public Chart3DDataLabel AddNewLabel();

[Delphi]

function AddNewLabel: Chart3DDataLabel;

Return Value

A reference to the newly created Chart3DDataLabel.

See Also

Chart3DDataLabelsCollection Class


Contains Method (Chart3DDataLabelsCollection)

Contains Method (Chart3DDataLabelsCollection)

Determines whether the specified Chart3DDataLabel exists in the collection.

Syntax

[VB]

Public Function Contains (lbl As Chart3DDataLabel) As Boolean

[C#]

public bool Contains (Chart3DDataLabel lbl)

[Delphi]

function Contains(lbl: Chart3DDataLabel): Boolean;

Return Value

A boolean value indicating whether the Chart3DDataLabel is a member of the collection.

See Also

Chart3DDataLabelsCollection Class


CopyTo Method (Chart3DDataLabelsCollection)

CopyTo Method (Chart3DDataLabelsCollection)

Copies the collection Chart3DDataLabel elements beginning with the specified index to an array of Chart3DDataLabel objects.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DDataLabel (), index As Integer)

[C#]

public void CopyTo (Chart3DDataLabel [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DDataLabel; index: Integer);

See Also

Chart3DDataLabelsCollection Class


IndexOf Method (Chart3DDataLabelsCollection)

IndexOf Method (Chart3DDataLabelsCollection)

Gets the index of the specified Chart3DDataLabel in the collection.

Syntax

[VB]

Public Function IndexOf (lbl As Chart3DDataLabel) As Integer

[C#]

public int IndexOf (Chart3DDataLabel lbl)

[Delphi]

function IndexOf(lbl: Chart3DDataLabel): Integer;

Return Value

An integer indicating the index of the specified Chart3DDataLabel.

See Also

Chart3DDataLabelsCollection Class


Insert Method (Chart3DDataLabelsCollection)

Insert Method (Chart3DDataLabelsCollection)

Adds a Chart3DDataLabel object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, lbl As Chart3DDataLabel)

[C#]

public void Insert (int Index, Chart3DDataLabel lbl)

[Delphi]

procedure Insert (index: Integer; lbl: Chart3DDataLabel;);

See Also

Chart3DDataLabelsCollection Class


Remove Method (Chart3DDataLabelsCollection)

Remove Method (Chart3DDataLabelsCollection)

Removes a Chart3DDataLabel object from the collection.

Syntax

[VB]

Public Sub Remove(lbl As Chart3DDataLabel)

[C#]

public void Remove (Chart3DDataLabel lbl)

[Delphi]

procedure Remove (lbl: Chart3DDataLabel;);

See Also

Chart3DDataLabelsCollection Class


Chart3DDataSet Class

Syntax

C1.Win.C1Chart3D.Chart3DDataSet

Remarks

Abstract base class for all types of data sets (regular grid, irregular grid and point).


Chart3DDataSet All Members

Chart3DDataSet Properties

Item | Gets or sets the specified Chart3DPoint in the Chart3DDataSet by column and row indices.
Hole | Gets or sets hole value.
MaxX | Gets the maximum X value of the chart data.
MaxY | Gets the maximum Y value of the chart data.
MaxZ | Gets the maximum Z value of the chart data.
MinX | Gets the minimum X value of the chart data.
MinY | Gets the minimum Y value of the chart data.
MinZ | Gets the minimum Z value of the chart data.

Chart3DDataSet Methods

IsHole

Determines if the passed value is a data hole.


Chart3DDataSet Properties

Item Property (Chart3DDataSet)

Hole Property (Chart3DDataSet)

MaxX Property (Chart3DDataSet)

MaxY Property (Chart3DDataSet)

MaxZ Property (Chart3DDataSet)

MinX Property (Chart3DDataSet)

MinY Property (Chart3DDataSet)

MinZ Property (Chart3DDataSet)


Item Property (Chart3DDataSet)

Item Property (Chart3DDataSet)

Gets or sets the specified Chart3DPoint in the Chart3DDataSet by column and row indices.

Syntax

[VB]

Public Property Item(col As Integer, row As Integer) As Chart3DPoint

[C#]

public Chart3DPoint this [int col, int row] {get; set;}

[Delphi]

property Item(col: Integer; row: Integer): Chart3DPoint;

See Also

Chart3DDataSet Class


Hole Property (Chart3DDataSet)

Hole Property (Chart3DDataSet)

Gets or sets hole value.

Syntax

[VB]

Public Property Hole As Double

[C#]

public double Hole { get; set; }

[Delphi]

property Hole: Double;

Remarks

The value representing a missing data value (a hole in the chart).

See Also

Chart3DDataSet Class


MaxX Property (Chart3DDataSet)

MaxX Property (Chart3DDataSet)

Gets the maximum X value of the chart data.

Syntax

[VB]

Public ReadOnly Property MaxX As Double

[C#]

public double MaxX { get;}

[Delphi]

property MaxX: Double;

See Also

Chart3DDataSet Class


MaxY Property (Chart3DDataSet)

MaxY Property (Chart3DDataSet)

Gets the maximum Y value of the chart data.

Syntax

[VB]

Public ReadOnly Property MaxY As Double

[C#]

public double MaxY { get;}

[Delphi]

property MaxY: Double;

See Also

Chart3DDataSet Class


MaxZ Property (Chart3DDataSet)

MaxZ Property (Chart3DDataSet)

Gets the maximum Z value of the chart data.

Syntax

[VB]

Public ReadOnly Property MaxZ As Double

[C#]

public double MaxZ { get;}

[Delphi]

property MaxZ: Double;

See Also

Chart3DDataSet Class


MinX Property (Chart3DDataSet)

MinX Property (Chart3DDataSet)

Gets the minimum X value of the chart data.

Syntax

[VB]

Public ReadOnly Property MinX As Double

[C#]

public double MinX { get;}

[Delphi]

property MinX: Double;

See Also

Chart3DDataSet Class


MinY Property (Chart3DDataSet)

MinY Property (Chart3DDataSet)

Gets the minimum Y value of the chart data.

Syntax

[VB]

Public ReadOnly Property MinY As Double

[C#]

public double MinY { get;}

[Delphi]

property MinY: Double;

See Also

Chart3DDataSet Class


MinZ Property (Chart3DDataSet)

MinZ Property (Chart3DDataSet)

Gets the minimum Z value of the chart data.

Syntax

[VB]

Public ReadOnly Property MinZ As Double

[C#]

public double MinZ { get;}

[Delphi]

property MinZ: Double;

See Also

Chart3DDataSet Class


Chart3DDataSet Methods

IsHole Method (Chart3DDataSet)


IsHole Method (Chart3DDataSet)

IsHole Method (Chart3DDataSet)

Determines if the passed value is a data hole.

Syntax

[VB]

Public Function IsHole (value As Double) As Boolean

[C#]

public bool IsHole (double value);

[Delphi]

function IsHole(value: Double): Boolean;

Return Value

A boolean value indicating whether the value passed is the equivalent of a data hole.

See Also

Chart3DDataSet Class


Chart3DDataSetIrGrid Class

Syntax

C1.Win.C1Chart3D.Chart3DDataSetIrGrid

Remarks

Represents irregular grid data layout.


Chart3DDataSetIrGrid All Members

Chart3DDataSetIrGrid Properties

ColumnDeltaArray | Indicates the amount of space between a data value and its neighboring column in grid.
Hole (inherited from Chart3DDataSet) | Gets or sets hole value.
MaxX (inherited from Chart3DDataSet) | Gets the maximum X value of the chart data.
MaxY (inherited from Chart3DDataSet) | Gets the maximum Y value of the chart data.
MaxZ (inherited from Chart3DDataSet) | Gets the maximum Z value of the chart data.
MinX (inherited from Chart3DDataSet) | Gets the minimum X value of the chart data.
MinY (inherited from Chart3DDataSet) | Gets the minimum Y value of the chart data.
MinZ (inherited from Chart3DDataSet) | Gets the minimum Z value of the chart data.
RowDeltaArray | Indicates the amount of space between a data value and its neighboring row in grid dataset.

Chart3DDataSetIrGrid Methods

GetColumnValue | Returns the X value associated with the specified indexed column.
GetRowValue | Returns the Y value associated with the specified indexed row.
IsHole (inherited from Chart3DDataSet) | Determines if the passed value is a data hole.


Chart3DDataSetIrGrid Properties

Chart3DDataSetIrGrid Constructor

ColumnDeltaArray Property

Hole Property (Chart3DDataSetIrGrid)

MaxX Property (Chart3DDataSetIrGrid)

MaxY Property (Chart3DDataSetIrGrid)

MaxZ Property (Chart3DDataSetIrGrid)

MinX Property (Chart3DDataSetIrGrid)

MinY Property (Chart3DDataSetIrGrid)

MinZ Property (Chart3DDataSetIrGrid)

RowDeltaArray Property


Chart3DDataSetIrGrid Constructor

Chart3DDataSetIrGrid Constructor

Creates instance of irregular grid dataset.

Syntax

[VB]

Public Sub New( XValues() As Single, YValues() As Single, ZValues(,) As Single)

Public Sub New( XValues() As Double, YValues() As Double, ZValues(,) As Double)

Public Sub New( XValues() As Double, YValues() As Double, ZValues As Object)

[C#]

public Chart3DDataSetIrGrid( float[] XValues, float[] YValues, float[,] ZValues);

public Chart3DDataSetIrGrid( double[] XValues, double[] YValues, double[,] ZValues);

public Chart3DDataSetIrGrid( double[] XValues, double[] YValues, object ZValues);

[Delphi]

constructor Chart3DDataSetIrGrid.Create(Xvalues: array of Single; Yvalues: array of Single; Zvalues:…); // Not available

constructor Chart3DDataSetIrGrid.Create(Xvalues: array of Double; Yvalues: array of Double; Zvalues:…); // Not available

Chart3DDataSetIrGrid.Create(Xvalues: array of Double; Yvalues: array of Double; Zvalues: object);

Remarks

All values in XValues array must be different. All values in YValues array must be different. The size of the first dimension of ZValues must be equal to the XValues array length, the size of the second dimension of ZValues must be equal to the YValues array length. In case of errors it throws an exception.

The third constructor can be used to pass an integer array, jagged integer, jagged float or jagged double arrays. For jagged arrays, the length of the outer array must be equal to the XValues array length, and the longest inner array must be equal to the YValues array length. Note that short inner arrays assume hole values for missing entries.

For Delphi, only the third constructor specified above is appropriate, as Delphi assumes jagged arrays will be passed to the constructor. The first and second constructors will fail in Delphi.

See Also

Chart3DDataSetIrGrid Class


ColumnDeltaArray Property

ColumnDeltaArray Property

Indicates the amount of space between a data value and its neighboring column in grid dataset.

Syntax

[VB]

Public Property ColumnDeltaArray As Double()

[C#]

public double[] ColumnDeltaArray { get; set;}

[Delphi]

property ColumnDeltaArray: Double;

See Also

Chart3DDataSetIrGrid Class


Hole Property (Chart3DDataSetIrGrid)

Hole Property (Chart3DDataSetIrGrid)

See Hole Property (Chart3DDataSet)


MaxX Property (Chart3DDataSetIrGrid)

MaxX Property (Chart3DDataSetIrGrid)

See MaxX Property (Chart3DDataSet)


MaxY Property (Chart3DDataSetIrGrid)

MaxY Property (Chart3DDataSetIrGrid)

See MaxY Property (Chart3DDataSet)


MaxZ Property (Chart3DDataSetIrGrid)

MaxZ Property (Chart3DDataSetIrGrid)

See MaxZ Property (Chart3DDataSet)


MinX Property (Chart3DDataSetIrGrid)

MinX Property (Chart3DDataSetIrGrid)

See MinX Property (Chart3DDataSet)


MinY Property (Chart3DDataSetIrGrid)

MinY Property (Chart3DDataSetIrGrid)

See MinY Property (Chart3DDataSet)


MinZ Property (Chart3DDataSetIrGrid)

MinZ Property (Chart3DDataSetIrGrid)

See MinZ Property (Chart3DDataSet)


RowDeltaArray Property

RowDeltaArray Property

Indicates the amount of space between a data value and its neighboring row in grid dataset.

Syntax

[VB]

Public Property RowDeltaArray As Double()

[C#]

public double[] RowDeltaArray { get; set;}

[Delphi]

property RowDeltaArray: Double;

See Also

Chart3DDataSetIrGrid Class


Chart3DDataSetIrGrid Methods

GetColumnValue Method

GetRowValue Method

IsHole Method (Chart3DDataSetIrGrid)


GetColumnValue Method

GetColumnValue Method

Returns the X value associated with the specified indexed column.

Syntax

[VB]

Public Function GetColumnValue(col As Integer) As Double

[C#]

public double GetColumnValue ( int col )

[Delphi]

function GetColumnValue(col: Integer): Double;

See Also

Chart3DDataSetIrGrid Class


GetRowValue Method

GetRowValue Method

Syntax

[VB]

Public Function GetRowValue(row As Integer) As Double

[C#]

public double GetRowValue ( int row )

[Delphi]

function GetRowValue(row: Integer): Double;

See Also

Chart3DDataSetIrGrid Class


IsHole Method (Chart3DDataSetIrGrid)

IsHole Method (Chart3DDataSetIrGrid)

See IsHole Method (Chart3DDataSet)


Chart3DDataSetGrid Class

Syntax

C1.Win.C1Chart3D.Chart3DDataSetGrid

Remarks

Represents regular grid data layout.


Chart3DDataSetGrid All Members

Chart3DDataSetGrid Properties

ColumnCount | Gets or sets the number of columns in grid dataset.
ColumnDelta | Indicates the amount of space between a data value and its neighboring column in grid.
ColumnOrigin | The X-coordinate of the grid origin.
GridData | Gets or sets two-dimensional array of Z-values.
Hole (inherited from Chart3DDataSet) | Gets or sets hole value.
Item | Gets or sets z-value of data by specified row and column.
MaxX (inherited from Chart3DDataSet) | Gets the maximum X value of the chart data.
MaxY (inherited from Chart3DDataSet) | Gets the maximum Y value of the chart data.
MaxZ (inherited from Chart3DDataSet) | Gets the maximum Z value of the chart data.
MinX (inherited from Chart3DDataSet) | Gets the minimum X value of the chart data.
MinY (inherited from Chart3DDataSet) | Gets the minimum Y value of the chart data.
MinZ (inherited from Chart3DDataSet) | Gets the minimum Z value of the chart data.
RowCount | Gets or sets the number of rows in grid dataset.
RowDelta | Indicates the amount of space between a data value and its neighboring column in grid.
RowOrigin | The Y-coordinate of the grid origin.

Chart3DDataSetGrid Methods

GetJaggedGridData | Returns an object containing Z-values in a jagged double array.
GetValue | Returns the elevation value of the grid point specified by the column and row indicies.
IsHole (inherited from Chart3DDataSet) | Determines if the passed value is a data hole.
SetJaggedGridData | Sets the Z-values with a two-dimensional integer array, or a jagged integer, jagged float or jagged double array.
SetValue | Sets the elevation value of the grid point specified by the column and row indices.


Chart3DDataSetGrid Properties

Chart3DDataSetGrid Constructor

ColumnCount Property

ColumnDelta Property

ColumnOrigin Property

GridData Property

Hole Property (Chart3DDataSetGrid)

Item Property (Chart3DDataSetGrid)

MaxX Property (Chart3DDataSetGrid)

MaxY Property (Chart3DDataSetGrid)

MaxZ Property (Chart3DDataSetGrid)

MinX Property (Chart3DDataSetGrid)

MinY Property (Chart3DDataSetGrid)

MinZ Property (Chart3DDataSetGrid)

RowCount Property

RowDelta Property

RowOrigin Property


Chart3DDataSetGrid Constructor

Chart3DDataSetGrid Constructor

Create instance of grid dataset.

Syntax

[VB]

Public Sub New(ColumnOrigin As Single, RowOrigin As Single, ColumnDelta As Single, RowDelta As Single, ZValues(,) As Single)

Public Sub New(ColumnOrigin As Double, RowOrigin As Double, ColumnDelta As Double, RowDelta As Double, ZValues(,) As Double)

Public Sub New(ColumnOrigin As Double, RowOrigin As Double, ColumnDelta As Double, RowDelta As Double, ZValues As Object)

[C#]

public Chart3DDataSetGrid(float ColumnOrigin, float RowOrigin, float ColumnDelta, float RowDelta, float[,] ZValues);

public Chart3DDataSetGrid(double ColumnOrigin, double RowOrigin, double ColumnDelta, double RowDelta, double[,] ZValues);

public Chart3DDataSetGrid(double ColumnOrigin, double RowOrigin, double ColumnDelta, double RowDelta, object ZValues);

[Delphi]

constructor Chart3DDataSetGrid.Create(ColumnOrigin: Single; RowOrigin: Single; ColumnDelta: Single; RowDelta: Single; Zalues: …); // Not available

constructor Chart3DDataSetGrid.Create(ColumnOrigin: Double; RowOrigin: Double; ColumnDelta: Double; RowDelta: Double; Zalues: …); // Not available

constructor Chart3DDataSetGrid.Create(ColumnOrigin: Double; RowOrigin: Double; ColumnDelta: Double; RowDelta: Double; ZValues: Object);

Remarks

Each of the constructor values with the exception of Zvalues, specifies the initial value of the object property with the corresponding name. The size of the first dimension of ZValues must be equal to the desired ColumnCount, the size of the second dimension of ZValues must be equal to the desired RowCount. In case of errors it throws an exception.

The third constructor can be used to pass an integer array, jagged integer, jagged float or jagged double arrays. For jagged arrays, the length of the outer array must be equal to the desired ColumnCount, and the longest inner array must be equal to the desired RowCount. Note that short inner arrays assume hole values for missing entries.

For Delphi, only the third constructor specified above is appropriate, as Delphi assumes jagged arrays will be passed to the constructor. The first and second constructors will fail in Delphi.

See Also

Chart3DDataSetGrid Class


ColumnCount Property

ColumnCount Property

Gets or sets the number of columns in grid dataset.

Syntax

[VB]

Public Property ColumnCount As Integer

[C#]

public int ColumnCount { get; set;}

[Delphi]

property ColumnCount: Integer;

See Also

Chart3DDataSetGrid Class


ColumnDelta Property

ColumnDelta Property

Indicates the amount of space between a data value and its neighboring column in grid dataset.

Syntax

[VB]

Public Property ColumnDelta As Double

[C#]

public double ColumnDelta { get; set;}

[Delphi]

property ColumnDelta: Double;

See Also

Chart3DDataSetGrid Class


ColumnOrigin Property

ColumnOrigin Property

The X-coordinate of the grid origin.

Syntax

[VB]

Public Property ColumnOrigin As Double

[C#]

public double ColumnOrigin { get; set;}

[Delphi]

property ColumnOrigin: Double;

See Also

Chart3DDataSetGrid Class


GridData Property

GridData Property

Gets or sets two-dimensional array of Z-values.

Syntax

[VB]

Public Property GridData As Double(,)

[C#]

public double[,] GridData { get; set;}

[Delphi]

property GridDate: Double;

See Also

Chart3DDataSetGrid Class


Hole Property (Chart3DDataSetGrid)

Hole Property (Chart3DDataSetGrid)

See Hole Property (Chart3DDataSet)


Item Property (Chart3DDataSetGrid)

Item Property (Chart3DDataSetGrid)

Gets or sets z-value of data by specified row and column.

Syntax

[VB]

Public Property Item(column As Integer, row As Integer) As Double

[C#]

public double this[int column, int row]{ get; set; }

[Delphi]

property Item(column: Integer; row: Integer): Double;

See Also

Chart3DDataSetGrid Class


MaxX Property (Chart3DDataSetGrid)

MaxX Property (Chart3DDataSetGrid)

See MaxX Property (Chart3DDataSet)


MaxY Property (Chart3DDataSetGrid)

MaxY Property (Chart3DDataSetGrid)

See MaxY Property (Chart3DDataSet)


MaxZ Property (Chart3DDataSetGrid)

MaxZ Property (Chart3DDataSetGrid)

See MaxZ Property (Chart3DDataSet)


MinX Property (Chart3DDataSetGrid)

MinX Property (Chart3DDataSetGrid)

See MinX Property (Chart3DDataSet)


MinY Property (Chart3DDataSetGrid)

MinY Property (Chart3DDataSetGrid)

See MinY Property (Chart3DDataSet)


MinZ Property (Chart3DDataSetGrid)

MinZ Property (Chart3DDataSetGrid)

See MinZ Property (Chart3DDataSet)


RowCount Property

RowCount Property

Gets or sets the number of rows in grid dataset.

Syntax

[VB]

Public RowCount As Integer

[C#]

public int RowCount { get; set;}

[Delphi]

property RowCount: Integer;

See Also

Chart3DDataSetGrid Class


RowDelta Property

RowDelta Property

Indicates the amount of space between a data value and its neighboring column in grid dataset.

Syntax

[VB]

Public Property RowDelta As Double

[C#]

public double RowDelta { get; set;}

[Delphi]

property RowDelta: Double;

See Also

Chart3DDataSetGrid Class


RowOrigin Property

RowOrigin Property

The Y-coordinate of the grid origin.

Syntax

[VB]

Public Property RowOrigin As Double

[C#]

public double RowOrigin { get; set;}

[Delphi]

property RowOrigin: Double;

See Also

Chart3DDataSetGrid Class


Chart3DDataSetGrid Methods

GetJaggedGridData Method

GetValue Method

IsHole Method (Chart3DDataSetGrid)

SetJaggedGridData Method

SetValue Method


GetJaggedGridData Method

GetJaggedGridData Method

Returns an object containing Z-values in a jagged double array.

Syntax

[VB]

Public Function GetJaggedGridData() As Object

[C#]

public object GetJaggedGridData()

[Delphi]

function GetJaggedGridData (): Object;

Remarks

Jagged arrays are useful in certain instances for manipulating data. In Delphi, multiply dimensioned arrays are jagged. Delphi users should use GetJaggedGridData() instead of the GridData property.

See Also

Chart3DDataSetGrid Class


GetValue Method

GetValue Method

Returns the elevation value of the grid point specified by the column and row indices.

Syntax

[VB]

Public Function GetValue(column As Integer, row As Integer) As Double

[C#]

public double GetValue ( int column , int row )

[Delphi]

function GetValue(column: Integer; row: Integer): Double;

See Also

Chart3DDataSetGrid Class


IsHole Method (Chart3DDataSetGrid)

IsHole Method (Chart3DDataSetGrid)

See IsHole Method (Chart3DDataSet)


SetJaggedGridData Method

SetJaggedGridData Method

Sets the Z-values with a two-dimensional integer array, or a jagged integer, jagged float or jagged double array.

Syntax

[VB]

Public Sub SetJaggedGridData ( ZValues As Object)

[C#]

public void SetJaggedGridData ( object ZValues )

[Delphi]

procedure SetJaggedGridData ( ZValues: Object );

Remarks

Jagged arrays are useful in certain instances for manipulating data. In Delphi, multiply dimensioned arrays are jagged. This method will also conveniently accept a two-dimensional integer array. Delphi users should use SetJaggedGridData() instead of the GridData property.

See Also

Chart3DDataSetGrid Class


SetValue Method

SetValue Method

Sets the elevation value of the grid point specified by the column and row indices.

Syntax

[VB]

Public Sub SetValue(column As Integer, row As Integer, value As Double)

[C#]

public void SetValue ( int column , int row , double value )

[Delphi]

procedure SetValue(column: Integer; row: Integer; value: Double);

See Also

Chart3DDataSetGrid Class


Chart3DDataSetPoint Class

Syntax

C1.Win.C1Chart3D.Chart3DDataSetPoint

Remarks

Represents point data layout.


Chart3DDataSetPoint All Members

Chart3DDataSetPoint Properties

Item | Gets or sets data point coordinates by specified series and index.
Hole (inherited from Chart3DDataSet) | Gets or sets hole value.
MaxX (inherited from Chart3DDataSet) | Gets the maximum X value of the chart data.
MaxY (inherited from Chart3DDataSet) | Gets the maximum Y value of the chart data.
MaxZ (inherited from Chart3DDataSet) | Gets the maximum Z value of the chart data.
MinX (inherited from Chart3DDataSet) | Gets the minimum X value of the chart data.
MinY (inherited from Chart3DDataSet) | Gets the minimum Y value of the chart data.
MinZ (inherited from Chart3DDataSet) | Gets the minimum Z value of the chart data.
SeriesCollection | Gets the collection of series.

Chart3DDataSetPoint Methods

AddSeries | Add new series to the data set.
IsHole | Determines if the passed value is a data hole.
RemoveSeries | Remove series with given index from the data set.


Chart3DDataSetPoint Properties

Chart3DDataSetPoint Constructor

Item Property (Chart3DDataSetPoint)

Hole Property (Chart3DDataSetPoint)

MaxX Property (Chart3DDataSetPoint)

MaxY Property (Chart3DDataSetPoint)

MaxZ Property (Chart3DDataSetPoint)

MinX Property (Chart3DDataSetPoint)

MinY Property (Chart3DDataSetPoint)

MinZ Property (Chart3DDataSetPoint)

SeriesCollection Property


Chart3DDataSetPoint Constructor

Chart3DDataSetPoint Constructor

Create instance of point dataset.

Syntax

[VB]

Public Sub New()

[C#]

public Chart3DDataSetGrid();

[Delphi]

constructor Chart3DDataSetGrid.Create;

See Also

Chart3DDataSetPoint Class


Item Property (Chart3DDataSetPoint)

Item Property (Chart3DDataSetPoint)

Gets or sets data point coordinates by specified series and index.

Syntax

[VB]

Public Property Item(series As Integer, index As Integer) As Chart3DPoint

[C#]

public Chart3DPoint this[int series, int index]{ get; set; }

[Delphi]

property Item(series: Integer, index: Integer): Chart3DPoint

See Also

Chart3DDataSetPoint Class


Hole Property (Chart3DDataSetPoint)

Hole Property (Chart3DDataSetPoint)

See Hole Property (Chart3DDataSet)


MaxX Property (Chart3DDataSetPoint)

MaxX Property (Chart3DDataSetPoint)

See MaxX Property (Chart3DDataSet)


MaxY Property (Chart3DDataSetPoint)

MaxY Property (Chart3DDataSetPoint)

See MaxY Property (Chart3DDataSet)


MaxZ Property (Chart3DDataSetPoint)

MaxZ Property (Chart3DDataSetPoint)

See MaxZ Property (Chart3DDataSet)


MinX Property (Chart3DDataSetPoint)

MinX Property (Chart3DDataSetPoint)

See MinX Property (Chart3DDataSet)


MinY Property (Chart3DDataSetPoint)

MinY Property (Chart3DDataSetPoint)

See MinY Property (Chart3DDataSet)


MinZ Property (Chart3DDataSetPoint)

MinZ Property (Chart3DDataSetPoint)

See MinZ Property (Chart3DDataSet)


SeriesCollection Property

SeriesCollection Property

Gets the collection of series.

Syntax

[VB]

Public ReadOnly Property SeriesCollection As Chart3DPointSeriesCollection

[C#]

public Chart3DPointSeriesCollection SeriesCollection { get; }

[Delphi]

property SeriesCollection: Chart3DPointSeriesCollection;

See Also

Chart3DDataSetPoint Class


Chart3DDataSetPoint Methods

AddSeries Method

IsHole Method (Chart3DDataSetPoint)

RemoveSeries Method


AddSeries Method

AddSeries Method

Add new series to the data set.

Syntax

[VB]

Public Sub AddSeries(ByVal points As Chart3DPoint( ))

[C#]

public void AddSeries (Chart3DPoint[] points )

[Delphi]

procedure AddSeries(points: Chart3DPoint);

Return value

An integer indicating the index of the collection to which the series was added.

See Also

Chart3DDataSetPoint Class


IsHole Method (Chart3DDataSetPoint)

IsHole Method (Chart3DDataSetPoint)

See IsHole Method (Chart3DDataSet)


RemoveSeries Method

RemoveSeries Method

Remove series with given index from the data set.

Syntax

[VB]

Public Sub RemoveSeries(Index As Integer)

[C#]

public void RemoveSeries( int Index);

[Delphi]

procedure RemoveSeries(Index: Integer);

See Also

Chart3DDataSetPoint Class


Chart3DElevation Class

Syntax

C1.Win.C1Chart3D.Chart3DElevation

Remarks

The Chart3DElevation class and its properties are used for control over the appearance of different chart types. It is returned by the Elevation property of a ChartGroup.


Chart3DElevation All Members

Chart3DElevation Properties

DepthCue | Determines whether scatter chart point sizes are dependant upon their distance from the eye.
DropLines | Determines whether scatter chart points have droplines.
IsMeshed | Determines whether surface charts are meshed, or whether bars in bar charts are outlined.
IsShaded | Determines whether surface or bar charts use shading.
MeshBottomColor | The bottom color of the mesh.
MeshTopColor | The top color of the mesh.
ShadedBottomColor | The bottom color of the shaded surface.
ShadedTopColor | The top color of the shaded surface.
Transparency | Transparency of drawing chart data.


Chart3DElevation Properties

DepthCue Property

DropLines Property

IsMeshed Property

IsShaded Property

MeshBottomColor Property

MeshTopColor Property

ShadedBottomColor Property

ShadedTopColor Property

Transparency Property


DepthCue Property

DepthCue Property

Determines whether scatter chart point sizes are dependant upon their distance from the eye. Set this property to true if the point sizes should be dependant upon distance from the eye.

Syntax

[VB]

Public Property DepthCue As Boolean

[C#]

public bool DepthCue { get; set; }

[Delphi]

property DepthCue: Boolean;

Remarks

Only for scatter chart.

See Also

Chart3DElevation Class


DropLines Property

DropLines Property

Determines whether scatter chart points have droplines. Set this property to true if points should have drop lines.

Syntax

[VB]

Public Property DropLines As Boolean

[C#]

public bool DropLines { get; set; }

[Delphi]

property DropLines: Boolean;

Remarks

Only for scatter chart.

See Also

Chart3DElevation Class


IsMeshed Property

IsMeshed Property

Determines whether surface charts are meshed, or whether bars in bar charts are outlined. Set this property to true to display a surface as a mesh, or to display bars in outline format.

Syntax

[VB]

Public Property IsMeshed As Boolean

[C#]

public bool IsMeshed { get; set; }

[Delphi]

property IsMeshed: Boolean;

Remarks

Only for bar and surface charts. The IsColumnMeshShowing and IsRowMeshShowing properties of the Chart3DSurface object control allow mesh lines in either the X or the Y direction to be turned off.

See Also

Chart3DElevation Class


IsShaded Property

IsShaded Property

Determines whether surface or bar charts use shading. Set this property to true to display surfaces and bars as a flat shade of color.

Syntax

[VB]

Public Property IsShaded As Boolean

[C#]

public bool IsShaded { get; set; }

[Delphi]

property IsShaded: Boolean;

Remarks

Only for bar and surface charts.

See Also

Chart3DElevation Class


MeshBottomColor Property

MeshBottomColor Property

The bottom color of the mesh.

Syntax

[VB]

Public Property MeshBottomColor As Color

[C#]

public Color MeshBottomColor { get; set; }

[Delphi]

property MeshBottomColor: Color;

Remarks

For bar charts, this color is used for bars with a value less than that specified by the Chart3DBar Origin property.

See Also

Chart3DElevation Class


MeshTopColor Property

MeshTopColor Property

The top color of the mesh.

Syntax

[VB]

Public Property MeshTopColor As Color

[C#]

public Color MeshTopColor { get; set; }

[Delphi]

property MeshTopColor: Color;

Remarks

For bar charts, this color is used for bars with a value greater than that specified by the Chart3DBar Origin property.

See Also

Chart3DElevation Class


ShadedBottomColor Property

ShadedBottomColor Property

The bottom color of the shaded surface.

Syntax

[VB]

Public Property ShadedBottomColor As Color

[C#]

public Color ShadedBottomColor { get; set; }

[Delphi]

property ShadedBottomColor: Color;

Remarks

For bar charts, this color is used for bars with a value less than that specified by the Chart3DBar Origin property.

See Also

Chart3DElevation Class


ShadedTopColor Property

ShadedTopColor Property

The top color of the shaded surface.

Syntax

[VB]

Public Property ShadedTopColor As Color

[C#]

public Color ShadedTopColor { get; set; }

[Delphi]

property ShadedTopColor: Color;

Remarks

For bar charts, this color is used for bars with a value greater than that specified by the Chart3DBar Origin property.

See Also

Chart3DElevation Class


Transparency Property

Transparency Property

Transparency of drawing chart data.

Syntax

[VB]

Public Property Transparency As Byte

[C#]

public Byte Transparency { get; set; }

[Delphi]

property Transparency: Byte;

Remarks

0 – transparent, 255 – opaque. Applied only for non-contoured and non-zoned chart.

See Also

Chart3DElevation Class


Chart3DGridLines Class

Syntax

C1.Win.C1Chart3D.Chart3DGridLines

Remarks

The Chart3DGridLines class and its properties are used for control appearance of grid. It is returned by the MajorGrid property of a Chart3DAxis.


Chart3DGridLines All Members

Chart3DGridLines Properties

IsOnXYPlane | Set to True if grid lines are to appear on the XY-plane.
IsOnXZPlane | Set to True if grid lines are to appear on the XZ-plane.
IsOnYZPlane | Set to True if grid lines are to appear on the YZ-plane.
Style | Gets or sets line style for drawing grid.


Chart3DGridLines Properties

IsOnXYPlane Property

IsOnXZPlane Property

IsOnYZPlane Property

Style Property (Chart3DGridLines)


IsOnXYPlane Property

IsOnXYPlane Property

Set to True if grid lines are to appear on the XY-plane.

Syntax

[VB]

Public Property IsOnXYPlane As Boolean

[C#]

public bool IsOnXYPlane { get; set; }

[Delphi]

property IsOnXYPlane: Boolean;

Remarks

In 2D projections, grid lines are drawn perpendicular to the axis.

See Also

Chart3DGridLines Class


IsOnXZPlane Property

IsOnXZPlane Property

Set to True if grid lines are to appear on the XZ-plane.

Syntax

[VB]

Public Property IsOnXZPlane As Boolean

[C#]

public bool IsOnXZPlane { get; set; }

[Delphi]

property IsOnXZPlane: Boolean;

Remarks

In 2D projections, grid lines are drawn perpendicular to the axis.

See Also

Chart3DGridLines Class


IsOnYZPlane Property

IsOnYZPlane Property

Set to True if grid lines are to appear on the YZ-plane.

Syntax

[VB]

Public Property IsOnYZPlane As Boolean

[C#]

public bool IsOnYZPlane { get; set; }

[Delphi]

property IsOnYZPlane: Boolean;

Remarks

In 2D projections, grid lines are drawn perpendicular to the axis.

See Also

Chart3DGridLines Class


Style Property (Chart3DGridLines)

Style Property (Chart3DGridLines)

Gets or sets line style for drawing grid.

Syntax

[VB]

Public Property Style As Chart3DLineStyle

[C#]

public Chart3DLineStyle Style { get; set; }

[Delphi]

property Style: Chart3DLineStyle;

See Also

Chart3DGridLines Class


Chart3DGroup Class

Syntax

C1.Win.C1Chart3D.Chart3DGroup

Remarks

Chart3DGroup contains chart data and classes that control chart appearance.


Chart3DGroup All Members

Chart3DGroup Properties

Bar | Controls the appearance of a bar chart.
ChartData | Data for the chart.
ChartType | The type of chart to be displayed.
Contour | The type of contouring to be used.
Elevation | Controls the three-dimensional appearance of the chart.
Surface | Controls the appearance of a surface format chart.

Chart3DGroup Methods

ShouldSerializeBar | Returns true if the Chart3DGroup Bar property is not in the default state.
ShouldSerializeContour | Returns true if the Chart3DGroup Contour property is not in the default state.
ShouldSerializeElevation | Returns true if the Chart3DGroup Elevation property is not in the default state.
ShouldSerializeSurface | Returns true if the Chart3DGroup Surface property is not in the default state.


Chart3DGroup Properties

Bar Property (Chart3DGroup)

ChartData Property (Chart3DGroup)

ChartType Property

Contour Property

Elevation Property

Surface Property


Bar Property (Chart3DGroup)

Bar Property (Chart3DGroup)

Controls the appearance of a bar chart.

Syntax

[VB]

Public ReadOnly Property Bar As Chart3DBar

[C#]

public Chart3DBar Bar { get; }

[Delphi]

property Bar: Chart3DBar;

Remarks

See Chart3DBar for details.

See Also

Chart3DGroup Class


ChartData Property (Chart3DGroup)

ChartData Property (Chart3DGroup)

Data for the chart.

Syntax

[VB]

Public ReadOnly Property ChartData As Chart3DData

[C#]

public Chart3DData ChartData { get; }

[Delphi]

property ChartData: Chart3DData;

Remarks

See Chart3DData for details.

See Also

Chart3DGroup Class


ChartType Property

ChartType Property

The type of chart to be displayed.

Syntax

[VB]

Public ChartType As Chart3DTypeEnum

[C#]

public Chart3DTypeEnum ChartType { get; set;}

[Delphi]

property ChartType: Chart3DTypeEnum;

See Also

Chart3DGroup Class


Contour Property

Contour Property

The type of contouring to be used.

Syntax

[VB]

Public ReadOnly Property Contour As Chart3DContour

[C#]

public Chart3DContour Contour { get; }

[Delphi]

property Contour: Chart3DContour;

Remarks

See Chart3DContour for details.

See Also

Chart3DGroup Class


Elevation Property

Elevation Property

Controls the three-dimensional appearance of the chart.

Syntax

[VB]

Public ReadOnly Property Elevation As Chart3DElevation

[C#]

public Chart3DElevation Elevation { get; }

[Delphi]

property Elevation: Chart3DElevation;

Remarks

See Chart3DElevation for details.

See Also

Chart3DGroup Class


Surface Property

Surface Property

Controls the appearance of a surface format chart.

Syntax

[VB]

Public ReadOnly Property Surface As Chart3DSurface

[C#]

public Chart3DSurface Surface { get; }

[Delphi]

property Surface: Chart3DSurface;

Remarks

See Chart3DSurface for details.

See Also

Chart3DGroup Class


Chart3DGroup Methods

ShouldSerializeBar Method

ShouldSerializeContour Method

ShouldSerializeElevation Method

ShouldSerializeSurface Method


ShouldSerializeBar Method

ShouldSerializeBar Method

Returns true if the Chart3DGroup Bar property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeBar() As Boolean

[C#]

public bool ShouldSerializeBar ( )

[Delphi]

function ShouldSerializeBar: Boolean;

See Also

Chart3DGroup Class


ShouldSerializeContour Method

ShouldSerializeContour Method

Returns true if the Chart3DGroup Contour property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeContour() As Boolean

[C#]

public bool ShouldSerializeContour ( )

[Delphi]

function ShouldSerializeContour: Boolean;

See Also

Chart3DGroup Class


ShouldSerializeElevation Method

ShouldSerializeElevation Method

Returns true if the Chart3DGroup Elevation property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeElevation() As Boolean

[C#]

public bool ShouldSerializeElevation ( )

[Delphi]

function ShouldSerializeElevation: Boolean;

See Also

Chart3DGroup Class


ShouldSerializeSurface Method

ShouldSerializeSurface Method

Returns true if the Chart3DGroup Surface property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeSurface() As Boolean

[C#]

public bool ShouldSerializeSurface ( )

[Delphi]

function ShouldSerializeSurface: Boolean;

See Also

Chart3DGroup Class


Chart3DGroups Class

Syntax

C1.Win.C1Chart3D.Chart3DGroups

Remarks

Chart3DGroups class contains collection of ChartGroup, data labels, chart and contour styles.


Chart3DGroups All Members

Chart3DGroups Properties

ChartGroupsCollection | Gets chart groups collection.
ChartStyles | Gets contour styles collection.
ColumnLabels | Gets column labels collection.
ContourStyles | Gets contour styles collection.
Group0 | Gets chart group.
Item | Gets the specified ChartGroup by numeric index.
RowLabels | Gets row labels collection.


Chart3DGroups Properties

ChartGroupsCollection Property

ChartStyles Property

ColumnLabels Property

ContourStyles Property

Group0 Property

Item Property (Chart3DGroups)

RowLabels Property


ChartGroupsCollection Property

ChartGroupsCollection Property

Gets chart groups collection.

Syntax

[VB]

Public ReadOnly Property ChartGroupsCollection As Chart3DGroupsCollection

[C#]

public Chart3DGroupsCollection ChartGroupsCollection { get; }

[Delphi]

property ChartGroupsCollection: Chart3DGroupsCollection;

See Also

Chart3DGroups Class


ChartStyles Property

ChartStyles Property

Gets contour styles collection.

Syntax

[VB]

Public ReadOnly Property ChartStyles As Chart3DStylesCollection

[C#]

public Chart3DStylesCollection ChartStyles { get; }

[Delphi]

property ChartStyles: Chart3DStylesCollection;

See Also

Chart3DGroups Class


ColumnLabels Property

ColumnLabels Property

Gets column labels collection.

Syntax

[VB]

Public ReadOnly Property ColumnLabels As Chart3DDataLabelsCollection

[C#]

public Chart3DDataLabelsCollection ColumnLabels { get; }

[Delphi]

property ColumnLabel: Chart3DDataLabelsCollection;

Remarks

The labels for the columns (X-axis) in the chart, used when the X-axis has its AnnoMethod property set to DataLabels.

See Also

Chart3DGroups Class


ContourStyles Property

ContourStyles Property

Gets contour styles collection.

Syntax

[VB]

Public ReadOnly Property ContourStyles As Chart3DContourStyles

[C#]

public Chart3DContourStyles ContourStyles { get; }

[Delphi]

property ContourStyles: Chart3DContourStyles;

See Also

Chart3DGroups Class


Group0 Property

Group0 Property

Gets chart group.

Syntax

[VB]

Public ReadOnly Property Group0 As Chart3DGroup

[C#]

public Chart3DGroup Group0 { get; }

[Delphi]

property Group0: Chart3DGroup;

See Also

Chart3DGroups Class


Item Property (Chart3DGroups)

Item Property (Chart3DGroups)

Gets the specified ChartGroup by numeric index.

Syntax

[VB]

Public ReadOnly Property Item(Index As Integer) As Chart3DGroup

[C#]

public Chart3DGroup this[int Index] { get; set; }

[Delphi]

property Item(Index: Integer): Chart3DGroup;

Remarks

Now there is only one chart group now.

See Also

Chart3DGroups Class


RowLabels Property

RowLabels Property

Gets row labels collection.

Syntax

[VB]

Public ReadOnly Property RowLabels As Chart3DDataLabelsCollection

[C#]

public Chart3DDataLabelsCollection RowLabels { get; }

[Delphi]

property RowLabels: Chart3DDataLabelsCollection;

Remarks

The labels for the rows (Y-axis) in the chart, used when the Y-axis has its AnnoMethod property set to DataLabels.

See Also

Chart3DGroups Class


Chart3DGroupsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DGroupsCollection

Remarks

The ChartGroupsCollection contains one ChartGroup object.


Chart3DGroupsCollection All Members

Chart3DGroupsCollection Properties

Count | Gets the collection count.
Item | Gets the specified Chart3DGroup by numeric index.

Chart3DGroupsCollection Methods

Contains | Determines whether the specified Chart3DGroup object exists in the collection.
CopyTo | Copies the collection of Chart3DGroup objects beginning with the specified index to an array of Chart3DGroup objects.
IndexOf | Gets the index of the specified Chart3DGroup in the collection.


Chart3DGroupsCollection Properties

Count Property (Chart3DGroupsCollection)

Item Property (Chart3DGroupsCollection)


Count Property (Chart3DGroupsCollection)

Count Property (Chart3DGroupsCollection)

Gets the collection count.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DGroupsCollection Class


Item Property (Chart3DGroupsCollection)

Item Property (Chart3DGroupsCollection)

Gets the specified Chart3DGroup by numeric index.

Syntax

[VB]

Public ReadOnly Property Item( Index As Integer) As Chart3DGroup

[C#]

public Chart3DGroup this[int Index] { get;}

[Delphi]

property Item(Index: Integer): Chart3DGroup;

See Also

Chart3DGroupsCollection Class


Chart3DGroupsCollection Methods

Contains Method (Chart3DGroupsCollection)

CopyTo Method (Chart3DGroupsCollection)

IndexOf Method (Chart3DGroupsCollection)


Contains Method (Chart3DGroupsCollection)

Contains Method (Chart3DGroupsCollection)

Determines whether the specified Chart3DGroup exists in the collection.

Syntax

[VB]

Public Function Contains (grp As Chart3DGroup) As Boolean

[C#]

public bool Contains (Chart3DGroup grp)

[Delphi]

function Contains(grp: Chart3DGroup): Boolean;

Return Value

A boolean value indicating whether the Chart3DGroup is a member of the collection.

See Also

Chart3DGroupsCollection Class


CopyTo Method (Chart3DGroupsCollection)

CopyTo Method (Chart3DGroupsCollection)

Copies the collection Chart3DGroup elements beginning with the specified index to an array of Chart3DGroup objects.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DGroup (), index As Integer)

[C#]

public void CopyTo (Chart3DGroup [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DGroup; index: Integer);

See Also

Chart3DGroupsCollection Class


IndexOf Method (Chart3DGroupsCollection)

IndexOf Method (Chart3DGroupsCollection)

Gets the index of the specified Chart3DGroup in the collection.

Syntax

[VB]

Public Function IndexOf (grp As Chart3DGroup) As Integer

[C#]

public int IndexOf (Chart3DGroup grp)

[Delphi]

function IndexOf(grp: Chart3DGroup): Integer;

Return Value

An integer indicating the index of the specified Chart3DGroup.

See Also

Chart3DGroupsCollection Class


Chart3DLabel Class

Syntax

C1.Win.C1Chart3D.Chart3DLabel

Remarks

A Chart3DLabel object is an independent text annotation that can be attached to the chart.


Chart3DLabel All Members

Chart3DLabel Properties

AttachMethod | Gets or sets the label attachment method.
AttachMethodData | Gets or sets the attachment data for the label.
Connected | Gets or sets whether a connecting line is drawn to an associated data point.
LabelCompass | Gets or sets the position of the label relative its specified location.
Name | Gets or sets the label name.
Offset | Gets or sets the offset distance from an associated data point.
Style | Gets the Style object of the label.
Text | Gets or sets the text of the label.
View3D | Gets or sets the 3D-view plane of the label.
Visible | Gets or sets label visibility.


Chart3DLabel Properties

AttachMethod Property

AttachMethodData Property

Connected Property

LabelCompass Property

Name Property

Offset Property

Style Property (Chart3DLabel)

Text Property (Chart3DLabel)

View3D Property

Visible Property (Chart3DLabel)


AttachMethod Property

AttachMethod Property

Gets or sets the label attachment method.

Syntax

[VB]

Public Property AttachMethod As AttachMethodEnum

[C#]

public AttachMethodEnum AttachMethod { get; set; }

[Delphi]

property AttachMethod: AttachMethodEnum;

See Also

Chart3DLabel Class


AttachMethodData Property

AttachMethodData Property

Gets or sets the attachment data for the label.

Syntax

[VB]

Public Property AttachMethodData As Chart3DAttachMethodData

[C#]

public Chart3DAttachMethodData AttachMethodData { get; set; }

[Delphi]

property AttachMethodData: Chart3DAttachMethodData;

See Also

Chart3DLabel Class


Connected Property

Connected Property

Gets or sets whether a connecting line is drawn to an associated data point.

Syntax

[VB]

Public Property Connected As Boolean

[C#]

public bool Connected { get; set; }

[Delphi]

property Connected: Boolean;

Remarks

If drawn, this connecting line is one pixel wide, and is drawn in the foreground color.

See Also

Chart3DLabel Class


LabelCompass Property

LabelCompass Property

Gets or sets the position of the label relative its specified location.

Syntax

[VB]

Public Property LabelCompass As LabelCompassEnum

[C#]

public LabelCompassEnum LabelCompass { get; set; }

[Delphi]

property LabelCompass: LabelCompassEnum;

See Also

Chart3DLabel Class


Name Property

Name Property

Gets or sets the label name.

Syntax

[VB]

Public Property Name As String

[C#]

public string Name { get; set; }

[Delphi]

property Name: string;

See Also

Chart3DLabel Class


Offset Property

Offset Property

Gets or sets the offset distance from an associated data point.

Syntax

[VB]

Public Property Offset As Integer

[C#]

public int Offset { get; set; }

[Delphi]

property Offset: Integer;

Remarks

Offset is measured in pixels.

See Also

Chart3DLabel Class


Style Property (Chart3DLabel)

Style Property (Chart3DLabel)

Gets the Style object of the label.

Syntax

[VB]

Public ReadOnly Property Style As Style

[C#]

public Style Style { get; }

[Delphi]

property Style: Style;

Remarks

Inherits from the ChartLabels.DefaultLabelStyle property.

See Also

Chart3DLabel Class


Text Property (Chart3DLabel)

Text Property (Chart3DLabel)

Gets or sets the text of the label.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Chart3DLabel Class


View3D Property

View3D Property

Gets or sets the 3D-view plane of the label.

Syntax

[VB]

Public Property View3D As LabelView3DEnum

[C#]

public LabelView3DEnum View3D { get; set; }

[Delphi]

property View3D: LabelView3DEnum;

See Also

Chart3DLabel Class


Visible Property (Chart3DLabel)

Visible Property (Chart3DLabel)

Gets or sets label visibility.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

See Also

Chart3DLabel Class


Chart3DLabels Class

Syntax

C1.Win.C1Chart3D.Chart3DLabels

Remarks

The Chart3DLabels contains all chart labels.


Chart3DLabels All Members

Chart3DLabels Properties

DefaultLabelStyle | Gets the default label style.
Item | Gets the specified label from the collection by numerical index.
LabelsCollection | Gets the labels collection.

Chart3DLabels Methods

AddNewLabel | Creates a new label and appends it to the LabelsCollection.
LabelFromCoord | Gets the label index at the specified coordinate.
Remove | Removes the specified label from the collection.


Chart3DLabels Properties

DefaultLabelStyle Property (Chart3DLabels)

Item Property (Chart3DLabels)

LabelsCollection Property


DefaultLabelStyle Property (Chart3DLabels)

DefaultLabelStyle Property (Chart3DLabels)

Gets the default label style.

Syntax

[VB]

Public ReadOnly Property DefaultLabelStyle As Style

[C#]

public Style DefaultLabelStyle { get;}

[Delphi]

property DefaultLabelStyle: Style;

Remarks

All labels inherit from this Style.

See Also

Chart3DLabels Class


Item Property (Chart3DLabels)

Item Property (Chart3DLabels)

Gets the specified label from the collection by numerical index.

Syntax

[VB]

Public ReadOnly Property Item(Index As Integer) As Chart3DLabel

[C#]

public Chart3DLabel this[int Index]{ get; }

[Delphi]

property Item(Index: Integer): Chart3DLabel;

See Also

Chart3DLabels Class


LabelsCollection Property

LabelsCollection Property

Gets the labels collection.

Syntax

[VB]

Public ReadOnly Property LabelsCollection As Chart3DLabelsCollection

[C#]

public Chart3DLabelsCollection LabelsCollection { get;}

[Delphi]

property LabelsCollection: Chart3DLabelsCollection;

See Also

Chart3DLabels Class


Chart3DLabels Methods

AddNewLabel Method (Chart3DLabels)

LabelFromCoord Method (Chart3DLabels)

Remove Method (Chart3DLabels)


AddNewLabel Method (Chart3DLabels)

AddNewLabel Method (Chart3DLabels)

Creates a new label and appends it to the collection.

Syntax

[VB]

Public Function AddNewLabel() As Chart3DLabel

[C#]

public Chart3DLabel AddNewLabel();

[Delphi]

function AddNewLabel: Chart3DLabel;

Return Value

This method returns a reference to the newly added label.

See Also

Chart3DLabels Class


LabelFromCoord Method (Chart3DLabels)

LabelFromCoord Method (Chart3DLabels)

Gets the label index at the specified location.

Syntax

[VB]

Public Function LabelFromCoord(X As Integer, Y As Integer, ref LabelIndex As Integer) As Boolean

[C#]

public bool LabelFromCoord(int X, int Y, ref int LabelIndex);

[Delphi]

function LabelFromCoord(X: Integer; Y: Integer; LabelIndex: Integer): Boolean;

Return Value

This method returns true when a label exists at the specified coordinate. The LabelIndex is set as it is passed by reference.

See Also

Chart3DLabels Class


Remove Method (Chart3DLabels)

Remove Method (Chart3DLabels)

Removes the specified label from the collection.

Syntax

[VB]

Public Sub Remove(label As Chart3DLabel)

[C#]

public void Remove(Chart3DLabel label);

[Delphi]

procedure Remove(label: Chart3DLabel);

See Also

Chart3DLabels Class


Chart3DLabelsCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DLabelsCollection

Remarks

Represents collection of Chart3DLabels.


Chart3DLabelsCollection All Members

Chart3DLabelsCollection Properties

Count | Gets the collection count.
Item | Gets or sets the specified Chart3DLabel from the collection by numerical index, or gets a label by name.

Chart3DLabelsCollection Methods

Add | Adds a new Chart3DLabel object to the collection.
AddNewLabel | Creates a new Chart3DLabel and appends it to the collection.
Contains | Determines whether the specified Chart3DLabel exists in the collection.
CopyTo | Copies the collection of Chart3DLabel objects beginning with the specified index to an array of labels.
IndexOf | Gets the index of the specified Chart3DLabel in the collection.
Insert | Adds a Chart3DLabel object to the collection at the specified index.
InsertNewLabel | Creates a new Chart3DLabel and inserts it into the collection at the specified index.
Remove | Removes the specified Chart3DLabel from the collection.


Chart3DLabelsCollection Properties

Count Property (Chart3DLabelsCollection)

Item Property (Chart3DLabelsCollection)


Count Property (Chart3DLabelsCollection)

Count Property (Chart3DLabelsCollection)

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DLabelsCollection Class


Item Property (Chart3DLabelsCollection)

Item Property (Chart3DLabelsCollection)

Gets or sets the specified label from the collection by numerical index, or gets the first occurence of the label with the specified name.

Syntax

[VB]

Public Property Item(Index As Integer) As Chart3DLabel

Public ReadOnly Property Item(name As String) As Chart3DLabel

[C#]

public Chart3DLabel this[int Index]{get; set;}

public Chart3DLabel this[string name]{ get; }

[Delphi]

property Item(Index: Integer): Chart3DLabel;

property Item(name: String): Chart3DLabel;

See Also

Chart3DLabelsCollection Class


Chart3DLabelsCollection Methods

Add Method (Chart3DLabelsCollection)

AddNewLabel Method (Chart3DLabelsCollection)

Contains Method (Chart3DLabelsCollection)

CopyTo Method (Chart3DLabelsCollection)

IndexOf Method (Chart3DLabelsCollection)

Insert Method (Chart3DLabelsCollection)

InsertNewLabel Method

Remove Method


Add Method (Chart3DLabelsCollection)

Add Method (Chart3DLabelsCollection)

Adds a Chart3DLabel object to the collection.

Syntax

[VB]

Public Function Add(lbl As Chart3DLabel) As Integer

[C#]

public int Add(Chart3DLabel lbl)

[Delphi]

function Add(lbl: Chart3DLabel): Integer;

Return Value

An integer indicating the index of the added Chart3DLabel.

See Also

Chart3DLabelsCollection Class


AddNewLabel Method (Chart3DLabelsCollection)

AddNewLabel Method (Chart3DLabelsCollection)

Creates a new label and appends it to the collection.

Syntax

[VB]

Public Function AddNewLabel () As Chart3Dlabel

[C#]

public Chart3DLabel AddNewLabel();

[Delphi]

function AddNewLabel: Chart3DLabel;

Return Value

A reference to the newly created Chart3DLabel.

See Also

Chart3DLabelsCollection Class


Contains Method (Chart3DLabelsCollection)

Contains Method (Chart3DLabelsCollection)

Determines whether the specified Chart3DLabel exists in the collection.

Syntax

[VB]

Public Function Contains (lbl As Chart3DLabel) As Boolean

[C#]

public bool Contains (Chart3DLabel lbl)

[Delphi]

function Contains(lbl: Chart3DLabel): Boolean;

Return Value

A boolean value indicating whether the Chart3DLabel is a member of the collection.

See Also

Chart3DLabelsCollection Class


CopyTo Method (Chart3DLabelsCollection)

CopyTo Method (Chart3DLabelsCollection)

Copies the collection Chart3DLabel elements beginning with the specified index to an array of Chart3DLabel objects.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DLabel (), index As Integer)

[C#]

public void CopyTo (Chart3DLabel [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DLabel; index: Integer);

See Also

Chart3DLabelsCollection Class


IndexOf Method (Chart3DLabelsCollection)

IndexOf Method (Chart3DLabelsCollection)

Gets the index of the specified Chart3DLabel in the collection.

Syntax

[VB]

Public Function IndexOf (lbl As Chart3DLabel) As Integer

[C#]

public int IndexOf (Chart3DLabel lbl)

[Delphi]

function IndexOf(lbl: Chart3DLabel): Integer;

Return Value

An integer indicating the index of the specified Chart3DLabel.

See Also

Chart3DLabelsCollection Class


Insert Method (Chart3DLabelsCollection)

Insert Method (Chart3DLabelsCollection)

Adds a Chart3DLabel object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, lbl As Chart3DLabel)

[C#]

public void Insert (int Index, Chart3DLabel lbl)

[Delphi]

procedure Insert (index: Integer; lbl: Chart3DLabel;);

See Also

Chart3DLabelsCollection Class


InsertNewLabel Method

InsertNewLabel Method

Creates a new label and inserts it into the collection at the specified index.

Syntax

[VB]

Public Function InsertNewLabel (Index As Integer) As Chart3DLabel

[C#]

public Chart3DLabel InsertNewLabel( int Index);

[Delphi]

function InsertNewLabel(Index: Integer): Chart3DLabel;

Return Value

A reference to the newly created Chart3DLabel.

See Also

Chart3DLabelsCollection Class


Remove Method

Remove Method

Removes the specified Chart3DLabel from the collection.

Syntax

[VB]

Public Sub Remove(label As Chart3DLabel)

[C#]

public void Remove(Chart3DLabel label);

[Delphi]

procedure Remove(label: Chart3DLabel);

See Also

Chart3DLabelsCollection Class


Chart3DLegend Class

Syntax

C1.Win.C1Chart3D.Chart3DLegend

Remarks

Represents the legend of the chart.


Chart3DLegend All Members

Chart3DLegend Properties

Compass | Gets or sets the general positioning of the legend.
Location | Gets or sets the location of the legend in chart control client coordinates.
LocationDefault | Gets or sets the location of the legend in chart control client coordinates.
Orientation | Gets or sets the orientation of the legend entries.
Size | Gets or sets the size of the legend in chart control client coordinates.
SizeDefault | Gets or sets the default size of the legend.
Style | Gets the legend style.
Text | Gets or sets the title of the legend.
Type | Gets or sets legend type.
Visible | Gets or sets legend visibility.

Chart3DLegend Methods

RectFromSeries | Gets the minimal Rectangle that circumscribes the specified series entry in the legend.
SeriesFromCoord | Gets the index of the series entry closest to the specified coordinates.


Chart3DLegend Properties

Compass Property (Chart3DLegend)

Location Property (Chart3DLegend)

LocationDefault Property (Chart3DLegend)

Orientation Property

Size Property (Chart3DLegend)

SizeDefault Property (Chart3DLegend)

Style Property (Chart3DLegend)

Text Property (Chart3DLegend)

Type Property (Chart3DLegend)

Visible Property (Chart3DLegend)


Compass Property (Chart3DLegend)

Compass Property (Chart3DLegend)

Gets or sets the general positioning of the legend.

Syntax

[VB]

Public Property Compass As CompassEnum

[C#]

public CompassEnum Compass { get; set; }

[Delphi]

property Compass: CompassEnum;

See Also

Chart3DLegend Class


Location Property (Chart3DLegend)

Location Property (Chart3DLegend)

Gets or sets the location of the legend in chart control client coordinates.

Syntax

[VB]

Public Property Location As Point

[C#]

public Point Location { get; set; }

[Delphi]

property Location: Point;

Remarks

The Location property always returns the actual location of the upper, left corner of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change LocationDefault.

See Also

Chart3DLegend Class


LocationDefault Property (Chart3DLegend)

LocationDefault Property (Chart3DLegend)

Gets or sets the location of the legend in chart control client coordinates.

Syntax

[VB]

Public Property LocationDefault As Point

[C#]

public Point LocationDefault { get; set; }

[Delphi]

property LocationDefault: Point;

Remarks

The LocationDefault property specifies the location of the upper, left corner of the chart element it describes. Non-negative values indicate the explicit position in chart client coordinates to place the chart element. Negative values will allow auto-positioning.

See Also

Chart3DLegend Class


Orientation Property

Orientation Property

Gets or sets the orientation of the legend entries.

Syntax

[VB]

Public Orientation As LegendOrientationEnum

[C#]

public LegendOrientationEnum Orientation { get; set; }

[Delphi]

property Orientation: LegendOrientationEnum;

Remarks

The legend entries can be oriented in a vertical or horizontal fashion.

Vertical orientation indicates that legend entries will stack vertically as the legend height permits. If the legend height cannot contain all of the entries and the legend is allowed to size itself, then additional columns of stacked entries will be added to the legend.

Horizontal orientation indicates that legend entries will be created side by side as legend width permits. If the legend width cannot contain all of the entries and the legend is allowed to size itself, then additional rows of entries will be added to the legend.

Auto orientation automatically selects an appropriate orientation based upon the legend Compass property. For east and west Compass values, Vertical orientation is used. For north and south Compass values, Horizontal orientation is used.

See Also

Chart3DLegend Class


Size Property (Chart3DLegend)

Size Property (Chart3DLegend)

Gets or sets the size of the legend in chart control client coordinates.

Syntax

[VB]

Public Property Size As Size

[C#]

public Size Size { get; set; }

[Delphi]

property Size: Size;

Remarks

The Size property always returns the actual size of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change SizeDefault.

See Also

Chart3DLegend Class


SizeDefault Property (Chart3DLegend)

SizeDefault Property (Chart3DLegend)

Gets or sets the default size of the legend.

Syntax

[VB]

Public Property SizeDefault As Size

[C#]

public Size SizeDefault { get; set; }

[Delphi]

property SizeDefault: Size;

Remarks

The SizeDefault property specifies the size of the chart element it describes. Non-negative values indicate the explicit width and height in chart client coordinates to place the chart element.Negative values will allow auto-positioning.

See Also

Chart3DLegend Class


Style Property (Chart3DLegend)

Style Property (Chart3DLegend)

Gets the legend style

Syntax

[VB]

Public ReadOnly Property Style As Style

[C#]

public Style Style { get; }

[Delphi]

property Style: Style;

See Also

Chart3DLegend Class


Text Property (Chart3DLegend)

Text Property (Chart3DLegend)

Gets or sets the title of the legend.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Chart3DLegend Class


Type Property (Chart3DLegend)

Type Property (Chart3DLegend)

Gets or sets legend type.

Syntax

[VB]

Public Property Type As LegendTypeEnum

[C#]

public LegendTypeEnum Type { get; set; }

[Delphi]

property Type: LegendTypeEnum;

See Also

Chart3DLegend Class


Visible Property (Chart3DLegend)

Visible Property (Chart3DLegend)

Gets or sets legend visibility.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

See Also

Chart3DLegend Class


Chart3DLegend Methods

RectFromSeries Method (Chart3DLegend)

SeriesFromCoord Method (Chart3DLegend)


RectFromSeries Method (Chart3DLegend)

RectFromSeries Method (Chart3DLegend)

Gets the minimal Rectangle that circumscribes the specified series entry in the legend.

Syntax

[VB]

Public Function RectFromSeries(seriesIndex As Integer) As Rectangle

[C#]

public Rectangle RectFromSeries(int seriesIndex);

[Delphi]

function RectFromSeries(seriesIndex: Integer): Rectangle;

See Also

Chart3DLegend Class


SeriesFromCoord Method (Chart3DLegend)

SeriesFromCoord Method (Chart3DLegend)

Gets the index of the legend series entry closest to the specified coordinates.

Syntax

[VB]

Public Function SeriesFromCoord(X As Integer, Y As Integer, ref seriesIndex As Integer) As Boolean

[C#]

public bool SeriesFromCoord(int X, int Y, ref int seriesIndex);

[Delphi]

function SeriesFromCoord(X: Integer; Y: Integer; seriesIndex: Integer): Boolean;

Return Value

This method returns true when a legend series entry exists at the specified coordinate. The seriesIndex is set as it is passed by reference.

See Also

Chart3DLegend Class


Chart3DLineStyle Class

Syntax

C1.Win.C1Chart3D.Chart3DLineStyle

Remarks

Represents style of the plotting line.


Chart3DLineStyle All Members

Chart3DLineStyle Properties

Color | Gets or sets the color of a plotted line.
Pattern | Gets or sets the pattern of a plotted line.
Thickness | Gets or sets the thickness of a plotted line.


Chart3DLineStyle Properties

Color Property (Chart3DLineStyle)

Pattern Property

Thickness Property (Chart3DLineStyle)


Color Property (Chart3DLineStyle)

Color Property (Chart3DLineStyle)

Gets or sets the color of a plotted line.

Syntax

[VB]

Public Property Color As Color

[C#]

public Color Color { get; set; }

[Delphi]

property Color: Color;

See Also

Chart3DLineStyle Class


Pattern Property

Pattern Property

Gets or sets the pattern of a plotted line.

Syntax

[VB]

Public Property Pattern As LinePatternEnum

[C#]

public LinePatternEnum Pattern { get; set; }

[Delphi]

property Pattern: LinePatternEnum;

See Also

Chart3DLineStyle Class


Thickness Property (Chart3DLineStyle)

Thickness Property (Chart3DLineStyle)

Gets or sets the thickness of a plotted line.

Syntax

[VB]

Public Property Thickness As Single

[C#]

public float Thickness { get; set; }

[Delphi]

property Thickness: single;

See Also

Chart3DLineStyle Class


Chart3DPoint Struct

Syntax

C1.Win.C1Chart3D.Chart3DPoint


Chart3DPoint All Members

Chart3DPoint Properties

X | Gets or sets X-coordinate of the point.
Y | Gets or sets Y-coordinate of the point.
Z | Gets or sets Z-coordinate of the point.


Chart3DPoint Properties

X Property (Chart3DPoint)

Y Property (Chart3DPoint)

Z Property (Chart3DPoint)


X Property (Chart3DPoint)

X Property (Chart3DPoint)

Gets or sets X-coordinate of the point.

Syntax

[VB]

Public Property X As Double

[C#]

public double X { get; set; }

[Delphi]

property X: Double;

See Also

Chart3DPoint Struct


Y Property (Chart3DPoint)

Y Property (Chart3DPoint)

Gets or sets Y-coordinate of the point.

Syntax

[VB]

Public Property Y As Double

[C#]

public double Y { get; set; }

[Delphi]

property Y: Double;

See Also

Chart3DPoint Struct


Z Property (Chart3DPoint)

Z Property (Chart3DPoint)

Gets or sets Z-coordinate of the point.

Syntax

[VB]

Public Property Z As Double

[C#]

public double Z { get; set; }

[Delphi]

property Z: Double;

See Also

Chart3DPoint Struct


Chart3DPointSeries Class

Syntax

C1.Win.C1Chart3D.Chart3DPointSeries

Remarks

Represents one series of data for point data layout (Chart3DDataSetPoint class).


Chart3DPointSeries All Members

Chart3DPointSeries Properties

Connected | Gets or sets whether the series points are connected with lines.
Count | Gets the number of points in the series.
Item | Gets or sets data point coordinates by specified index.
Label | Gets or sets the text label of the series.
Points | Gets or sets the array of points in the series.
Style | Gets the style of point drawing.
Visible | Gets or sets visibility of the series.


Chart3DPointSeries Properties

Connected Property (Chart3DPointSeries)

Count Property (Chart3DPointSeries)

Item Property (Chart3DPointSeries)

Label Property (Chart3DPointSeries)

Points Property (Chart3DPointSeries)

Style Property (Chart3DPointSeries)

Visible Property (Chart3DPointSeries)


Connected Property (Chart3DPointSeries)

Connected Property (Chart3DPointSeries)

Gets or sets whether the series points are connected with lines.

Syntax

[VB]

Public Property Connected As Boolean

[C#]

public bool Connected { get; set; }

[Delphi]

property Connected: Boolean;

Remarks

The line style is defined by the LineStyle property of Chart3DPointSeries Style object.

See Also

Chart3DPointSeries Class


Count Property (Chart3DPointSeries)

Count Property (Chart3DPointSeries)

Gets the number of points in series.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DPointSeries Class


Item Property (Chart3DPointSeries)

Item Property (Chart3DPointSeries)

Gets or sets data point coordinates by specified index.

Syntax

[VB]

Public Property Item(index As Integer) As Chart3DPoint

[C#]

public Chart3DPoint this[int index]{ get; set; }

[Delphi]

property Item(index: Integer): Chart3DPoint;

See Also

Chart3DPointSeries Class


Label Property (Chart3DPointSeries)

Label Property (Chart3DPointSeries)

Gets or sets the text label of series.

Syntax

[VB]

Public Property Label As String

[C#]

public string Label { get; set;}

[Delphi]

property Label: string;

See Also

Chart3DPointSeries Class


Points Property (Chart3DPointSeries)

Points Property (Chart3DPointSeries)

Gets or sets the array of points in the series .

Syntax

[VB]

Public Property Points As Chart3DPoint()

[C#]

public Chart3DPoint[] Points { get; set;}

[Delphi]

property Point: Chart3DPoint;

See Also

Chart3DPointSeries Class


Style Property (Chart3DPointSeries)

Style Property (Chart3DPointSeries)

Gets the style of point drawing.

Syntax

[VB]

Public ReadOnly Property Style As Chart3DStyle

[C#]

public Chart3DStyle Style { get;}

[Delphi]

property Style: Chart3DStyle;

See Also

Chart3DPointSeries Class


Visible Property (Chart3DPointSeries)

Visible Property (Chart3DPointSeries)

Gets or sets visibility of series.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set;}

[Delphi]

property Visible: Boolean;

See Also

Chart3DPointSeries Class


Chart3DPointSeriesCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DPointSeriesCollection

Remarks

Represents collection of point series.


Chart3DPointSeriesCollection All Members

Chart3DPointSeriesCollection Properties

Count | Gets the item count of the collection.
Item | Gets the specified series from the collection by numeric index.

Chart3DPointSeriesCollection Methods

Add | Adds a Chart3DPointSeries object to the collection.
Contains | Determines whether the specified Chart3DPointSeries exists in the collection.
CopyTo | Copies the collection Chart3DPointSeries beginning with the specified index to an array of Chart3DPointSeries objects.
IndexOf | Gets the index of the specified Chart3DPointSeries in the collection.
Insert | Adds a Chart3DPointSeries object to the collection at the specified index.
Remove | Removes a Chart3DPointSeries object from the collection.


Chart3DPointSeriesCollection Properties

Count Property (Chart3DPointSeriesCollection)

Item Property (Chart3DPointSeriesCollection)


Count Property (Chart3DPointSeriesCollection)

Count Property (Chart3DPointSeriesCollection)

Gets the item count of the collection.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count {get;}

[Delphi]

property Count: Integer;

See Also

Chart3DPointSeriesCollection Class


Item Property (Chart3DPointSeriesCollection)

Item Property (Chart3DPointSeriesCollection)

Gets the specified series from the collection by numeric index.

Syntax

[VB]

Public ReadOnly Item( Index As Integer) As Chart3DPointSeries

[C#]

public Chart3DPointSeries this[ int index] { get; }

[Delphi]

property Item(Index: Integer): Chart3DPointSeries;

See Also

Chart3DPointSeriesCollection Class


Chart3DPointSeriesCollection Methods

Add Method (Chart3DPointSeriesCollection)

Contains Method (Chart3DPointSeriesCollection)

CopyTo Method (Chart3DPointSeriesCollection)

IndexOf Method (Chart3DPointSeriesCollection)

Insert Method (Chart3DPointSeriesCollection)

Remove Method (Chart3DPointSeriesCollection)


Add Method (Chart3DPointSeriesCollection)

Add Method (Chart3DPointSeriesCollection)

Adds a Chart3DpointSeries object to the collection.

Syntax

[VB]

Public Function Add(pointSeries As Chart3DPointSeries) As Integer

[C#]

public int Add(Chart3DPointSeries pointSeries)

[Delphi]

function Add(pointSeries: Chart3DPointSeries): Integer;

Return Value

An integer indicating the index of the added Chart3DPointSeries.

See Also

Chart3DPointSeriesCollection Class


Contains Method (Chart3DPointSeriesCollection)

Contains Method (Chart3DPointSeriesCollection)

Determines whether the specified Chart3DPointSeries exists in the collection.

Syntax

[VB]

Public Function Contains (pointSeries As Chart3DPointSeries) As Boolean

[C#]

public bool Contains (Chart3DPointSeries pointSeries)

[Delphi]

function Contains(pointSeries: Chart3DPointSeries): Boolean;

Return Value

A boolean return indicating whether the Chart3DPointSeries is a member of the collection.

See Also

Chart3DPointSeriesCollection Class


CopyTo Method (Chart3DPointSeriesCollection)

CopyTo Method (Chart3DPointSeriesCollection)

Copies the collection Chart3DPointSeries elements beginning with the specified index to an array of Chart3DPointSeries objects.

Syntax

[VB]

Public Sub CopyTo (array As Chart3DPointSeries(), Index As Integer)

[C#]

public void CopyTo (Chart3DPointSeries[] array, int index)

[Delphi]

procedure CopyTo(array: Chart3DPointSeries; index: Integer);

See Also

Chart3DPointSeriesCollection Class


IndexOf Method (Chart3DPointSeriesCollection)

IndexOf Method (Chart3DPointSeriesCollection)

Gets the index of the specified Chart3DPointSeries in the collection.

Syntax

[VB]

Public Function IndexOf (series As Chart3DPointSeries) As Integer

[C#]

public int IndexOf (Chart3DPointSeries series)

[Delphi]

function IndexOf(series: Chart3DPointSeries): Integer;

Return Value

An integer indicating the index of the specified Chart3DPointSeries.

See Also

Chart3DPointSeriesCollection Class


Insert Method (Chart3DPointSeriesCollection)

Insert Method (Chart3DPointSeriesCollection)

Adds a Chart3DPointSeries object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, pointSeries As Chart3DPointSeries)

[C#]

public void Insert(int index, Chart3DPointSeries pointSeries);

[Delphi]

procedure Insert(index: Integer; pointSeries: Chart3DPointSeries);

See Also

Chart3DPointSeriesCollection Class


Remove Method (Chart3DPointSeriesCollection)

Remove Method (Chart3DPointSeriesCollection)

Removes a Chart3PointSeries object from the collection.

Syntax

[VB]

Public Sub Remove (series As Chart3DPointSeries)

[C#]

public void Remove (Chart3DPointSeries series)

[Delphi]

procedure Remove(series: Chart3DPointSeries);

See Also

Chart3DPointSeriesCollection Class


Chart3DProjection Class

Syntax

C1.Win.C1Chart3D.Chart3DProjection

Remarks

Represents projection(floor or ceiling) for contour and zones charts.


Chart3DProjection All Members

Chart3DProjection Properties

IsContoured | Specifies whether projected contours are to be drawn.
IsZoned | Specifies whether zones are to be drawn.


Chart3DProjection Properties

IsContoured Property (Chart3DProjection)

IsZoned Property (Chart3DProjection)


IsContoured Property (Chart3DProjection)

IsContoured Property (Chart3DProjection)

Specifies whether projected contours are to be drawn.

Syntax

[VB]

Public Property IsContoured As Boolean

[C#]

public bool IsContoured { get; set; }

[Delphi]

property IsContoured: Boolean;

Remarks

If True, projected contours are drawn regardless of the value of the IsContoured property of the Contour object.

See Also

Chart3DProjection Class


IsZoned Property (Chart3DProjection)

IsZoned Property (Chart3DProjection)

Specifies whether zones are to be drawn.

Syntax

[VB]

Public Property IsZoned As Boolean

[C#]

public bool IsZoned { get; set; }

[Delphi]

property IsZoned: Boolean;

Remarks

If True, projected contours are drawn regardless of the value of the IsZoned property of the Contour object.

See Also

Chart3DProjection Class


Chart3DStyle Class

Syntax

C1.Win.C1Chart3D.Chart3DStyle

Remarks

Represents style for drawing scatter charts.


Chart3DStyle All Members

Chart3DStyle Properties

LineStyle | The color, pattern, and thickness of drop lines in scatter plots.
SymbolStyle | The color, size, and shape of points in scatter plots.


Chart3DStyle Properties

LineStyle Property (Chart3DStyle)

SymbolStyle Property


LineStyle Property (Chart3DStyle)

LineStyle Property (Chart3DStyle)

The color, pattern, and thickness of drop lines in scatter plots.

Syntax

[VB]

Public ReadOnly Property LineStyle As Chart3DLineStyle

[C#]

public Chart3DLineStyle LineStyle { get; }

[Delphi]

property LineStyle: Chart3DLineStyle;

See Also

Chart3DStyle Class


SymbolStyle Property

SymbolStyle Property

The color, size, and shape of points in scatter plots.

Syntax

[VB]

Public ReadOnly Property SymbolStyle As Chart3DSymbolStyle

[C#]

public Chart3DSymbolStyle SymbolStyle { get; }

[Delphi]

property SymbolStyle: Chart3DSymbolStyle;

See Also

Chart3DStyle Class


Chart3DStylesCollection Class

Syntax

C1.Win.C1Chart3D.Chart3DStylesCollection

Remarks

Represents collection of Chart3DStyle objects used for scatter charts


Chart3DStylesCollection All Members

Chart3DStylesCollection Properties

Count | Gets the number of styles in the collection.
Item | Gets or sets the specified style from the collection by numeric index.

Chart3DStylesCollection Methods

Add | Adds the specified Chart3DStyle to the collection.
AddNewStyle | Creates a new Chart3DStyle and appends it to the collection.
Contains | Determines whether the specified Chart3DStyle exists in the collection.
CopyTo | Copies the collection of Chart3DStyle objects beginning with the specified index to an array of Chart3DStyle objects.
IndexOf | Gets the index of the specified Chart3DStyle in the collection.
Insert | Adds a Chart3DStyle object to the collection at the specified index.
Remove | Removes a Chart3DStyle object from the collection.


Chart3DStylesCollection Properties

Count Property (Chart3DStylesCollection)

Item Property (Chart3DStylesCollection)


Count Property (Chart3DStylesCollection)

Count Property (Chart3DStylesCollection)

Gets the number of styles in the collection.

Syntax

[VB]

Public ReadOnly Property Count As Integer

[C#]

public int Count { get; }

[Delphi]

property Count: Integer;

See Also

Chart3DStylesCollection Class


Item Property (Chart3DStylesCollection)

Item Property (Chart3DStylesCollection)

Gets or sets the specified style from the collection by numeric index.

Syntax

[VB]

Public Property Item(Index as Integer) As Chart3DStyle

[C#]

public Chart3DStyle this[int index]{ get; set;}

[Delphi]

property Item(Index: Integer): Chart3DStyle;

See Also

Chart3DStylesCollection Class


Chart3DStylesCollection Methods

Add Method (Chart3DStylesCollection)

AddNewStyle Method (Chart3DStylesCollection)

Contains Method (Chart3DStylesCollection)

CopyTo Method (Chart3DStylesCollection)

IndexOf Method (Chart3DStylesCollection)

Insert Method (Chart3DStylesCollection)

Remove Method (Chart3DStylesCollection)


Add Method (Chart3DStylesCollection)

Add Method (Chart3DStylesCollection)

Adds the specified Chart3DStyle to the collection.

Syntax

[VB]

Public Function Add (style As Chart3DStyle) As Integer

[C#]

public int Add(Chart3DStyle style);

[Delphi]

function Add(style: Chart3DStyle): Integer;

Return Value

An integer indicating the index of the collection to which the Chart3DStyle was added.

See Also

Chart3DStylesCollection Class


AddNewStyle Method (Chart3DStylesCollection)

AddNewStyle Method (Chart3DStylesCollection)

Creates a new Chart3DStyle and appends it to the collection.

Syntax

[VB]

Public Function AddNewStyle () As Chart3DStyle

[C#]

public Chart3DStyle AddNewStyle();

[Delphi]

function AddNewStyle: Chart3DStyle;

Return Value

A reference to the newly created Chart3DStyle

See Also

Chart3DStylesCollection Class


Contains Method (Chart3DStylesCollection)

Contains Method (Chart3DStylesCollection)

Determines whether the specified Chart3DStyle exists in the collection.

Syntax

[VB]

Public Function Contains (style As Chart3DStyle) As Boolean

[C#]

public bool Contains (Chart3DStyle style)

[Delphi]

function Contains(style: Chart3DStyle): Boolean;

Return Value

A boolean value indicating whether the Chart3DStyle is a member of the collection.

See Also

Chart3DStylesCollection Class


CopyTo Method (Chart3DStylesCollection)

CopyTo Method (Chart3DStylesCollection)

Copies the collection Chart3DStyle elements beginning with the specified index to an array of BarColor objects.

Syntax

[VB]

Public Sub CopyTo(array As Chart3DStyle (), index As Integer)

[C#]

public void CopyTo (Chart3DStyle [] array, int Index)

[Delphi]

procedure CopyTo(array: Chart3DStyle; index: Integer);

See Also

Chart3DStylesCollection Class


IndexOf Method (Chart3DStylesCollection)

IndexOf Method (Chart3DStylesCollection)

Gets the index of the specified Chart3DStyle in the collection.

Syntax

[VB]

Public Function IndexOf (lbl As Chart3DStyle) As Integer

[C#]

public int IndexOf (Chart3DStyle lbl)

[Delphi]

function IndexOf(lbl: Chart3DStyle): Integer;

Return Value

An integer indicating the index of the specified Chart3DStyle.

See Also

Chart3DStylesCollection Class


Insert Method (Chart3DStylesCollection)

Insert Method (Chart3DStylesCollection)

Adds a Chart3DStyle object to the collection at the specified index.

Syntax

[VB]

Public Sub Insert(index As Integer, style As Chart3DStyle)

[C#]

public void Insert (int Index, Chart3DStyle style)

[Delphi]

procedure Insert (index: Integer; style: Chart3DStyle;);

See Also

Chart3DStylesCollection Class


Remove Method (Chart3DStylesCollection)

Remove Method (Chart3DStylesCollection)

Removes a Chart3DStyle object from the collection.

Syntax

[VB]

Public Sub Remove(style As Chart3DStyle)

[C#]

public void Remove (Chart3DStyle style)

[Delphi]

procedure Remove (style: Chart3DStyle;);

See Also

Chart3DStylesCollection Class


Chart3DSurface Class

Syntax

C1.Win.C1Chart3D.Chart3DSurface

Remarks

The Chart3DSurfce class and its properties are only used for surface charts. It is returned by the Surface property of a ChartGroup.


Chart3DSurface All Members

Chart3DSurface Properties

ColumnMeshFilter | Column mesh filter.
IsColumnMeshShowing | Specifies whether the column mesh lines are to appear.
IsRowMeshShowing | Specifies whether the row mesh lines are to appear.
RowMeshFilter | Row mesh filter.


Chart3DSurface Properties

ColumnMeshFilter Property

IsColumnMeshShowing Property

IsRowMeshShowing Property

RowMeshFilter Property


ColumnMeshFilter Property

ColumnMeshFilter Property

Column mesh filter.

Syntax

[VB]

Public Property ColumnMeshFilter As Integer

[C#]

public int ColumnMeshFilter { get; set; }

[Delphi]

property ColumnMeshFilter: Integer;

Remarks

When this property has the value n, every nth mesh line is drawn. This mesh filter applies to both regular and irregular grids. When this property is set to 0, the chart automatically chooses a mesh filter.

See Also

Chart3DSurface Class


IsColumnMeshShowing Property

IsColumnMeshShowing Property

Specifies whether the column mesh lines are to appear.

Syntax

[VB]

Public Property IsColumnMeshShowing As Boolean

[C#]

public bool IsColumnMeshShowing { get; set; }

[Delphi]

property IsColumnMeshShowing: Boolean;

See Also

Chart3DSurface Class


IsRowMeshShowing Property

IsRowMeshShowing Property

Specifies whether the row mesh lines are to appear.

Syntax

[VB]

Public Property IsRowMeshShowing As Boolean

[C#]

public bool IsRowMeshShowing { get; set; }

[Delphi]

property IsRowMeshShowing: Boolean;

See Also

Chart3DSurface Class


RowMeshFilter Property

RowMeshFilter Property

Row mesh filter.

Syntax

[VB]

Public Property RowMeshFilter As Integer

[C#]

public int RowMeshFilter { get; set; }

[Delphi]

property RowMeshFilter: Integer;

Remarks

When this property has the value n, every nth mesh line is drawn. This mesh filter applies to both regular and irregular grids. When this property is set to 0, the chart automatically chooses a mesh filter.

See Also

Chart3DSurface Class


Chart3DSymbolStyle Class

Syntax

C1.Win.C1Chart3D.Chart3DSymbolStyle

Remarks

Represents symbol properties used in scatter plots for the points in a series.


Chart3DSymbolStyle All Members

Chart3DSymbolStyle Properties

Color | Gets or sets the color of a data point symbol.
OutlineColor | Gets or sets the outline color of the data point symbol.
OutlineWidth | Gets or sets the outline width of the data point symbol.
Shape | Gets or sets the shape of a data point symbol.
Size | Gets or sets the size of a data point symbol


Chart3DSymbolStyle Properties

Color Property (Chart3DSymbolStyle)

OutlineColor Property (Chart3DSymbolStyle)

OutlineWidth Property (Chart3DSymbolStyle)

Shape Property

Size Property (Chart3DSymbolStyle)


Color Property (Chart3DSymbolStyle)

Color Property (Chart3DSymbolStyle)

Gets or sets the color of a data point symbol.

Syntax

[VB]

Public Property Color As Color

[C#]

public Color Color { get; set; }

[Delphi]

property Color: Color;

See Also

Chart3DSymbolStyle Class


OutlineColor Property (Chart3DSymbolStyle)

OutlineColor Property (Chart3DSymbolStyle)

Gets or sets the outline color of the data point symbol.

Syntax

[VB]

Public Property OutlineColor As Color

[C#]

public Color OutlineColor {get; set;}

[Delphi]

property OutlineColor: Color;

See Also

Chart3DSymbolStyle Class


OutlineWidth Property (Chart3DSymbolStyle)

OutlineWidth Property (Chart3DSymbolStyle)

Gets or sets the outline width of the data point symbol.

Syntax

[VB]

Public Property OutlineWidth As Integer

[C#]

public int OutlineWidth {get; set;}

[Delphi]

property OutlineWidth: Integer;

Remarks

OutlineWidth should not exceed symbol size. If the outline width is greater than the symbol size, the symbol size is used as the outline width when drawing the symbol.

See Also

Chart3DSymbolStyle Class


Shape Property

Shape Property

Gets or sets the shape of a data point symbol.

Syntax

[VB]

Public Property Shape As SymbolShapeEnum

[C#]

public SymbolShapeEnum Shape { get; set; }

[Delphi]

property Shape: SymbolShapeEnum;

See Also

Chart3DSymbolStyle Class


Size Property (Chart3DSymbolStyle)

Size Property (Chart3DSymbolStyle)

Gets or sets the size of a data point symbol.

Syntax

[VB]

Public Property Size As Integer

[C#]

public int Size { get; set; }

[Delphi]

property Size: Integer;

See Also

Chart3DSymbolStyle Class


Chart3DView Class

Syntax

C1.Win.C1Chart3D.Chart3DView

Remarks

The Chart3DView defines the three-dimensional features of a chart. It is returned by the View property of a Chart3DArea.

Chart3DView All Members

Chart3DView Properties

Chart3DView Methods

Chart3DView Events

Chart3DView Event Handlers


Chart3DView All Members

Chart3DView Properties

BackColor | Background color of plot cube.
Boxed | Gets or sets whether all plotting cube edges are rendered.
Ceiling | Gets the ceiling object.
Floor | Gets the floor object.
ForeColor | Foreground color of plot cube.
IsInteractive | Is chart view interactive.
Perspective | Perspective of 3-D view.
PreviewMethod | Gets or sets preview method.
RotationX | Rotation about X-axis.
RotationY | Rotation about Y-axis.
RotationZ | Rotation about Z-axis.
View3D | Gets or sets predefined view.
ViewportScale | Gets or sets scale of chart viewport.
ViewportHorizontalShift | Gets or sets horizontal shift of chart viewport.
ViewportVerticalShift | Gets or sets vertical shift of chart viewport.
TextRotation | Gets or sets text rotation for axis titles and axis annotations.
XScale | Gets or sets scaling of the plot cube along X-axis.
YScale | Gets or sets scaling of the plot cube along Y-axis.

Chart3DView Methods

ResetTransformation | Resets all transformation parameters to their default values.
Restore | Restore to view state to the represented by a Chart3DViewState object.
Save | Save current view state to the Chart3DViewState object.
ShouldSerializeBackColor | Returns true if the Chart3DView BackColor property is not in the default state.
ShouldSerializeForeColor | Returns true if the Chart3DView ForeColor property is not in the default state.

Chart3DView Events

AfterRotate | Occurs after chart rotates.
BeforeRotate | Occurs before chart rotates.

Chart3DView Delegates

RotateEventHandler

Represents the method that will handle BeforeRotate and AfterRotate event of Chart3DView.


Chart3DView Properties

BackColor Property (Chart3DView)

Boxed Property

Ceiling Property

Floor Property

ForeColor Property (Chart3DView)

IsInteractive Property

Perspective Property

PreviewMethod Property

RotationX Property

RotationY Property

RotationZ Property

View3D Property

ViewportScale Property

ViewportHorizontalShift Property

ViewportVerticalShift Property

TextRotation Property

XScale Property

YScale Property


BackColor Property (Chart3DView)

BackColor Property (Chart3DView)

Background color of plot cube.

Syntax

[VB]

Public Property BackColor As Color

[C#]

public Color BackColor { get; set; }

[Delphi]

property BackColor: Color;

Remarks

Inherits from Chart3Darea.Style.BackColor.

See Also

Chart3DView Class


Boxed Property

Boxed Property

Gets or sets whether all plotting cube edges are rendered.

Syntax

[VB]

Public Property Boxed As Boolean

[C#]

public bool Boxed { get; set; }

[Delphi]

property Boxed: Boolean;

See Also

Chart3DView Class


Ceiling Property

Ceiling Property

Gets the ceiling object.

Syntax

[VB]

Public ReadOnly Property Ceiling As Chart3DProjection

[C#]

public Chart3DProjection Ceiling { get; }

[Delphi]

property Ceiling: Chart3DProjection;

Remarks

The projection of contours and zones onto the z=zmax plane. This property is used only in surface charts.

See Also

Chart3DView Class


Floor Property

Floor Property

Gets the floor object.

Syntax

[VB]

Public ReadOnly Property Floor As Chart3DProjection

[C#]

public Chart3DProjection Floor { get; }

[Delphi]

property Floor: Chart3DProjection;

Remarks

The projection of contours and zones onto the z=zmin plane. This property is used only in surface charts.

See Also

Chart3DView Class


ForeColor Property (Chart3DView)

ForeColor Property (Chart3DView)

Foreground color of plot cube.

Syntax

[VB]

Public Property ForeColor As Color

[C#]

public Color ForeColor { get; set; }

[Delphi]

property ForeColor: Color;

Remarks

Inherits from Chart3Darea.Style.ForeColor.

See Also

Chart3DView Class


IsInteractive Property

IsInteractive Property

Is chart view interactive.

Syntax

[VB]

Public Property IsInteractive As Boolean

[C#]

public bool IsInteractive { get; set; }

[Delphi]

property IsInteractive: Boolean;

See Also

Chart3DView Class


Perspective Property

Perspective Property

Perspective of 3-D view.

Syntax

[VB]

Public Property Perspective As Single

[C#]

public float Perspective { get; set; }

[Delphi]

property Perspective: Single;

Remarks

Must be a value greater than 1. Higher values reduce the perspective effect and approach a parallel projection.

See Also

Chart3DView Class


PreviewMethod Property

PreviewMethod Property

Gets or sets preview method.

Syntax

[VB]

Public Property PreviewMethod As PreviewMethodEnum

[C#]

public PreviewMethodEnum PreviewMethod { get; set; }

[Delphi]

property PreviewMethod: PreviewMethodEnum;

Remarks

Specifies how interactive manipulations are to be presented to the user.

See Also

Chart3DView Class


RotationX Property

RotationX Property

Rotation about X-axis.

Syntax

[VB]

Public Property RotationX As Integer

[C#]

public int RotationX { get; set; }

[Delphi]

property RotationX: Integer;

Remarks

Specifies the number of degrees of rotation of the plot cube, in a counter-clockwise direction about the X-axis.

See Also

Chart3DView Class


RotationY Property

RotationY Property

Rotation about Y-axis.

Syntax

[VB]

Public Property RotationY As Integer

[C#]

public int RotationY { get; set; }

[Delphi]

property RotationY: Integer;

Remarks

Specifies the number of degrees of rotation of the plot cube, in a counter-clockwise direction about the Y-axis.

See Also

Chart3DView Class


RotationZ Property

RotationZ Property

Rotation about Z-axis.

Syntax

[VB]

Public Property RotationZ As Integer

[C#]

public int RotationZ { get; set; }

[Delphi]

property RotationZ: Integer;

Remarks

Specifies the number of degrees of rotation of the plot cube, in a counter-clockwise direction about the Y-axis.

See Also

Chart3DView Class


View3D Property

View3D Property

Gets or sets predefined view.

Syntax

[VB]

Public Property View3D As View3DEnum

[C#]

public View3DEnum View3D { get; set; }

[Delphi]

property View3D: View3DEnum;

See Also

Chart3DView Class


ViewportScale Property

ViewportScale Property

Gets or sets scale of chart viewport.

Syntax

[VB]

Public Property ViewportScale As Single

[C#]

public float ViewportScale { get; set; }

[Delphi]

property ViewportScale: single;

Remarks

Specifies the degree of scaling (zooming) up or down from a full (maximal, non-clipped) view. This property is updated if the user dynamically scales or zooms the view.

See Also

Chart3DView Class


ViewportHorizontalShift Property

ViewportHorizontalShift Property

Gets or sets horizontal shift of chart viewport.

Syntax

[VB]

Public Property ViewportHorizontalShift As Single

[C#]

public float ViewportHorizontalShift { get; set; }

[Delphi]

property ViewportHorizontalShift: single;

Remarks

Specifies the degree of horizontal view translation from a full view (a maximal, non-clipped view). Translation is relative to a normalized box with origin in the bottom left corner. Translation of more than a full unit (more than 1.0 or -1.0) causes the view to translate “out of view” when ViewPortScale=1. This property is updated if the user dynamically translates the view.

See Also

Chart3DView Class


ViewportVerticalShift Property

ViewportVerticalShift Property

Gets or sets vertical shift of chart viewport.

Syntax

[VB]

Public Property ViewportVerticalShift As Single

[C#]

public float ViewportVerticalShift { get; set; }

[Delphi]

property ViewportVerticalShift: single;

Remarks

Specifies the degree of vertical view translation from a full view. Translation is relative to a normalized box with origin in the bottom left corner. Translation of more than a full unit (more than 1.0 or -1.0) causes the view to translate “out of view” when ViewPortScale=1. This property is updated if the user dynamically translates the view.

See Also

Chart3DView Class


TextRotation Property

TextRotation Property

Gets or sets text rotation for axis titles and axis annotations.

Syntax

[VB]

Public Property TextRotation As TextRotationEnum

[C#]

public TextRotationEnum TextRotation { get; set;}

[Delphi]

property TextRotation: TextRotationEnum;

Remarks

See Also

Chart3DView Class


XScale Property

XScale Property

Gets or sets scaling of the plot cube along X-axis.

Syntax

[VB]

Public Property XScale As Single

[C#]

public float XScale { get; set; }

[Delphi]

property Xscale: single;

Remarks

The amount of scaling in the X-axis direction, measured as relation to the height (Z-axis) of the cube.

See Also

Chart3DView Class


YScale Property

YScale Property

Gets or sets scaling of the plot cube along Y-axis.

Syntax

[VB]

Public Property YScale As Single

[C#]

public float YScale { get; set; }

[Delphi]

property Yscale: single;

Remarks

The amount of scaling in the Y-axis direction, measured as relation to the height (Z-axis) of the cube.

See Also

Chart3DView Class


Chart3DView Methods

ResetTransformation Method (Chart3DView)

Restore Method (Chart3DView)

Save Method (Chart3DView)

ShouldSerializeBackColor Method (Chart3DView)

ShouldSerializeForeColor Method (Chart3DView)


ResetTransformation Method (Chart3DView)

ResetTransformation Method (Chart3DView)

Resets all transformation parameters to their default values.

Syntax

[VB]

Public Sub ResetTransformation()

[C#]

public void ResetTransformation ();

[Delphi]

procedure ResetTransformation;

Remarks

The transformation parameters that are reset include Xscale, Yscale, RotationX, RotationY, RotationZ, Perspective, ViewportScale, ViewPortHorizontalShift, and ViewportVerticalShift.

See Also

Chart3DView Class


Restore Method (Chart3DView)

Restore Method (Chart3DView)

Restore to view state to the represented by a Chart3DViewState object.

Syntax

[VB]

Public Sub Restore( state as Chart3DViewState)

[C#]

public void Restore(Chart3DViewState state);

[Delphi]

procedure Restore(state: Chart3DViewState);

Remarks

State must be previously saved using Save method.

See Also

Chart3DView Class


Save Method (Chart3DView)

Save Method (Chart3DView)

Save current view state to the Chart3DViewState object.

Syntax

[VB]

Public Function Save() As Chart3DViewState

[C#]

public Chart3DViewState Save();

[Delphi]

function Save: Chart3DViewState;

Return Value

C1.Win.Chart3D.Chart3DViewState

Remarks

Use Restore method to return view to the saved state.

See Also

Chart3DView Class


ShouldSerializeBackColor Method (Chart3DView)

ShouldSerializeBackColor Method (Chart3DView)

Returns true if the Chart3DView BackColor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeBackColor() As Boolean

[C#]

public bool ShouldSerializeBackColor ( )

[Delphi]

function ShouldSerializeBackColor: Boolean;

Remarks

The default state is to inherit the BackColor from the Chart3DArea object.

See Also

Chart3DView Class


ShouldSerializeForeColor Method (Chart3DView)

ShouldSerializeForeColor Method (Chart3DView)

Returns true if the Chart3DView ForeColor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeForeColor() As Boolean

[C#]

public bool ShouldSerializeForeColor ( )

[Delphi]

function ShouldSerializeForeColor: Boolean;

Remarks

The default state is to inherit the ForeColor from the Chart3DArea object.

See Also

Chart3DView Class


Chart3DView Events

AfterRotate Event

BeforeRotate Event


AfterRotate Event

AfterRotate Event

Occurs after chart rotates.

Syntax

[VB]

Public Event AfterRotate As RotateEventHandler

[C#]

public event RotateEventHandler AfterRotate;

[Delphi]

property AfterRotate: RotateEventHandler;

Event Data

The event handler receives an argument of type RotateEventArgs containing data related to this event.

See Also

Chart3DView Class


BeforeRotate Event

BeforeRotate Event

Occurs before chart rotates.

Syntax

[VB]

Public Event BeforeRotate As RotateEventHandler

[C#]

public event RotateEventHandler BeforeRotate;

[Delphi]

property BeforeRotate: RotateEventHandler;

Event Data

The event handler receives an argument of type RotateEventArgs containing data related to this event.

See Also

Chart3DView Class


Chart3DView Event Handlers

RotateEventHandler Delegate


RotateEventHandler Delegate

RotateEventHandler Delegate

Represents the method that will handle BeforeRotate and AfterRotate event of Chart3DView.

Syntax

[VB]

Public Delegate Sub RotateEventHandler( sender As Object, e As RotateEventArgs)

[C#]

public delegate void RotateEventHandler( object sender, RotateEventArgs e);

[Delphi]

type RotateEventHandler = procedure(sender: System.Object, e: RotateEventArgs) of object;


Chart3DViewState Class

Syntax

C1.Win.C1Chart3D.Chart3DViewState

Remarks

Represents the state of Chart3DView object. This object, which has no properties or methods, is returned by a call to the Save method.

· Visual Basic

· C#

· Delphi


RotateEventArgs Class

Syntax

[VB]

Public Class RotateEventArgs

[C#]

public class RotateEventArgs : EventArgs

[Delphi]

type RotateEventArgs: class(EventArgs);

Remarks

Provides data for the BeforeRotate and AfterRotate events.


RotateEventArgs All Members

RotateEventArgs Properties

RotationX | Gets or sets rotation about X-axis measured in radians.
RotationY | Gets or sets rotation about Y-axis measured in radians.
RotationZ | Gets or sets rotation about Z-axis measured in radians.


RotateEventArgs Properties

RotationX Property (RotateEventArgs)

RotationY Property (RotateEventArgs)

RotationZ Property (RotateEventArgs)


RotationX Property (RotateEventArgs)

RotationX Property (RotateEventArgs)

Gets or sets rotation about X-axis measured in radians.

Syntax

[VB]

Public Property RotationX As Single

[C#]

public float RotationX { get; set;}

[Delphi]

property RotationX: single;

See Also

RotateEventArgs Class


RotationY Property (RotateEventArgs)

RotationY Property (RotateEventArgs)

Gets or sets rotation about Y-axis measured in radians.

Syntax

[VB]

Public Property RotationY As Single

[C#]

public float RotationY { get; set;}

[Delphi]

property RotationY: single;

See Also

RotateEventArgs Class


RotationZ Property (RotateEventArgs)

RotationZ Property (RotateEventArgs)

Gets or sets rotation about Z-axis measured in radians.

Syntax

[VB]

Public Property RotationZ As Single

[C#]

public float RotationZ { get; set;}

[Delphi]

property RotationZ: single;

See Also

RotateEventArgs Class


Rounding Class

Syntax

C1.Win.C1Chart3D.Rounding

Remarks

Provides the properties set that describes the rounding of border corners.


Rounding All Members

Rounding Properties

All | Gets or sets the radius of rounding for all corners of the rectangle.
LeftBottom | Gets or sets the radius of rounding for the left bottom corner of the rectangle.
LeftTop | Gets or sets the radius of rounding for the left top corner of the rectangle.
RightBottom | Gets or sets the radius of rounding for the right bottom corner of the rectangle.
RightTop | Gets or sets the radius of rounding for the right top corner of the rectangle.


Rounding Properties

All Property

LeftBottom Property

LeftTop Property

RightBottom Property

RightTop Property


All Property

All Property

Gets or sets the radius of rounding for all corners of the rectangle.

Syntax

[VB]

Public Property All as Integer

[C#]

public int All { get; set; }

[Delphi]

property All: Integer;

Remarks

Setting this property changes all of the corners by changing the values of the LeftTop, LeftBottom, RightTop, and RightBottom properties. If these properties are re-set after setting the All property, then each corner may have a different radius.

See Also

Rounding Class


LeftBottom Property

LeftBottom Property

Gets or sets the radius of rounding for the left bottom corner of the rectangle.

Syntax

[VB]

Public Property LeftBottom as Integer

[C#]

public int LeftBottom { get; set; }

[Delphi]

property LeftBottom: Integer;

Remarks

Setting this property will override the All property value for the LeftBottom region of the border.

See Also

Rounding Class


LeftTop Property

LeftTop Property

Gets or sets the radius of rounding for the left top corner of the rectangle.

Syntax

[VB]

Public Property LeftTop as Integer

[C#]

public int LeftTop { get; set; }

[Delphi]

property LeftTop: Integer;

Remarks

Setting this property will override the All property value for the LeftTop region of the border.

See Also

Rounding Class


RightBottom Property

RightBottom Property

Gets or sets the radius of rounding for the right bottom corner of the rectangle.

Syntax

[VB]

Public Property RightBottom as Integer

[C#]

public int RightBottom { get; set; }

[Delphi]

property RightBottom: Integer;

Remarks

Setting this property will override the All property value for the RightBottom region of the border.

See Also

Rounding Class


RightTop Property

RightTop Property

Gets or sets the radius of rounding for the right top corner of the rectangle.

Syntax

[VB]

Public Property RightTop as Integer

[C#]

public int RightTop { get; set; }

[Delphi]

property RightTop: Integer;

Remarks

Setting this property will override the All property value for the RightTop region of the border.

See Also

Rounding Class


Style Class

Syntax

C1.Win.C1Chart3D.Style

Remarks

The Style class is used to describe the appearance of various elements of the chart, include the chart itself, the ChartArea, the Legend, the Header, the Footer and Labels. Typically, an object’s style and one or more of its properties are inherited the object’s parent.


Style All Members

Style Properties

Autowrap | Gets or sets whether the text is automatically wrapped.
BackColor | Gets or sets the background color.
BackColor2 | Gets or sets the gradient or hatch background.
Border | Gets the border object.
Font | Gets or sets the font object.
ForeColor | Gets or sets the foreground color.
GradientStyle | Defines the style of the background gradient filling.
HatchStyle | Defines the style of the background hatch filling.
HorizontalAlignment | Gets or sets the text horizontal alignment.
ImageAlignment | Gets or sets the image alignment.
Opaque | Gets or sets the whether the background is opaque.
Rotation | Gets or sets the text rotational orientation.
VerticalAlignment | Gets or sets the text vertical alignment.

Style Methods

ShouldSerializeAutowrap | Returns true if the Style Autowrap property is not in the default state.
ShouldSerializeBackColor | Returns true if the Style BackColor property is not in the default state.
ShouldSerializeBackColor2 | Returns true if the Style BackColor2 property is not in the default state.
ShouldSerializeFont | Returns true if the Style Font property is not in the default state.
ShouldSerializeForeColor | Returns true if the Style ForeColor property is not in the default state.


Style Properties

Autowrap Property (Style)

BackColor Property (Style)

BackColor2 Property

Border Property

Font Property (Style)

ForeColor Property (Style)

GradientStyle Property

HatchStyle Property

HorizontalAlignment Property

ImageAlignment Property

Opaque Property

Rotation Property

VerticalAlignment Property


Autowrap Property (Style)

Autowrap Property (Style)

Gets or sets whether the text is automatically wrapped.

Syntax

[VB]

Public Property Autowrap As Boolean

[C#]

public bool Autowrap { get; set; }

[Delphi]

property Autowrap: Boolean;

Remarks

Most text containing objects within C1Chart3D can automatically wrap text within them, including header, footer, axes titles, labels and the legend (title only, not series names). However, all of these objects can be sized automatically. Automatic sizing is always based upon a single line of text whenever possible.

See Also

Style Class


BackColor Property (Style)

BackColor Property (Style)

Gets or sets the background color.

Syntax

[VB]

Public Property BackColor As Color

[C#]

public Color BackColor { get; set; }

[Delphi]

property BackColor: Color;

See Also

Style Class


BackColor2 Property

BackColor2 Property

Gets or sets the gradient or hatch background.

Syntax

[VB]

Public Property BackColor2 As Color

[C#]

public Color BackColor2 { get; set; }

[Delphi]

property BackColor2: Color;

See Also

Style Class


Border Property

Border Property

Gets the border object.

Syntax

[VB]

Public ReadOnly Property Border As Border

[C#]

public Border Border { get; }

[Delphi]

property Border: Border;

See Also

Style Class


Font Property (Style)

Font Property (Style)

Gets or sets the font object.

Syntax

[VB]

Public Property Font As Font

[C#]

public Font Font { get; set; }

[Delphi]

property Font: Font;

See Also

Style Class


ForeColor Property (Style)

ForeColor Property (Style)

Gets or sets the foreground color.

Syntax

[VB]

Public Property ForeColor As Color

[C#]

public Color ForeColor { get; set; }

[Delphi]

property ForeColor: Color;

See Also

Style Class


GradientStyle Property

GradientStyle Property

Defines the style of the background gradient filling.

Syntax

[VB]

Public Property GradientStyle As GradientStyleEnum

[C#]

public GradientStyleEnum GradientStyle {get; set;}

[Delphi]

property GradientStyle: GradientStyleEnum;

See Also

Style Class


HatchStyle Property

HatchStyle Property

Defines the style of the background hatch filling.

Syntax

[VB]

Public Property HatchStyle As HatchStyleEnum

[C#]

public HatchStyleEnum HatchStyle {get; set;}

[Delphi]

property HatchStyle: HatchStyleEnum;

See Also

Style Class


HorizontalAlignment Property

HorizontalAlignment Property

Gets or sets the text horizontal alignment.

Syntax

[VB]

Public Property HorizontalAlignment As AlignHorzEnum

[C#]

public AlignHorzEnum HorizontalAlignment { get; set; }

[Delphi]

property HorizontalAlignment: AlignHorzEnum;

See Also

Style Class


ImageAlignment Property

ImageAlignment Property

Gets or sets the image alignment.

Syntax

[VB]

Public Property ImageAlignment As AlignImageEnum

[C#]

public AlignImageEnum ImageAlignment { get; set; }

[Delphi]

property ImageAlignment: AlignImageEnum;

See Also

Style Class


Opaque Property

Opaque Property

Gets or sets the whether the background is opaque.

Syntax

[VB]

Public Property Opaque As Boolean

[C#]

public bool Opaque { get; set; }

[Delphi]

property Opaque: Boolean;

Remarks

If an object’s Opaque property is true, then the object’s background is brushed in the backcolor before the foreground is drawn. If an object’s Opaque property is false, the background is not brushed and only the object’s foreground is drawn.

See Also

Style Class


Rotation Property

Rotation Property

Gets or sets the text rotational orientation.

Syntax

[VB]

Public Property Rotation As RotationEnum

[C#]

public RotationEnum Rotation { get; set; }

[Delphi]

property Rotation: RotationEnum;

See Also

Style Class


VerticalAlignment Property

VerticalAlignment Property

Gets or sets the text vertical alignment.

Syntax

[VB]

Public Property VerticalAlignment As AlignVertEnum

[C#]

public AlignVertEnum VerticalAlignment { get; set; }

[Delphi]

property VerticalAlignment: AlignVertEnum;

See Also

Style Class


Style Methods

ShouldSerializeAutowrap Method

ShouldSerializeBackColor Method (Style)

ShouldSerializeBackColor2 Method

ShouldSerializeFont Method

ShouldSerializeForeColor Method (Style)


ShouldSerializeAutowrap Method

ShouldSerializeAutowrap Method

Returns true if the Style Autowrap property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeAutowrap() As Boolean

[C#]

public bool ShouldSerializeAutowrap ( )

[Delphi]

function ShouldSerializeAutowrap: Boolean;

Remarks

The default state is to inherit the Autowrap from the style of the parent object.

See Also

Style Class


ShouldSerializeBackColor Method (Style)

ShouldSerializeBackColor Method (Style)

Returns true if the Style BackColor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeBackColor() As Boolean

[C#]

public bool ShouldSerializeBackColor ( )

[Delphi]

function ShouldSerializeBackColor: Boolean;

Remarks

The default state is to inherit the BackColor from the style of the parent object.

See Also

Style Class


ShouldSerializeBackColor2 Method

ShouldSerializeBackColor2 Method

Returns true if the Style BackColor2 property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeBackColor2() As Boolean

[C#]

public bool ShouldSerializeBackColor2 ( )

[Delphi]

function ShouldSerializeBackColor2: Boolean;

Remarks

The default state is to inherit the BackColor2 from the style of the parent object.

See Also

Style Class


ShouldSerializeFont Method

ShouldSerializeFont Method

Returns true if the Style Font property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeFont() As Boolean

[C#]

public bool ShouldSerializeFont ( )

[Delphi]

function ShouldSerializeFont: Boolean;

Remarks

The default state is to inherit the Font from the style of the parent object.

See Also

Style Class


ShouldSerializeForeColor Method (Style)

ShouldSerializeForeColor Method (Style)

Returns true if the Style ForeColor property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeForeColor() As Boolean

[C#]

public bool ShouldSerializeForeColor ( )

[Delphi]

function ShouldSerializeForeColor: Boolean;

Remarks

The default state is to inherit the ForeColor from the style of the parent object.

See Also

Style Class


Title Class

Syntax

C1.Win.C1Chart3D.Title

Remarks

The Title class is used to describe the appearance of the Header and the Footer.


Title All Members

Title Properties

Compass | Gets or sets the general positioning of the title.
Location | Gets or sets the location of the title in chart control client coordinates.
LocationDefault | Gets or sets the default location of the title.
Size | Gets or sets the size of the title in chart control client coordinates.
SizeDefault | Gets or sets the default size of the title.
Style | Gets the title style.
Text | Gets or sets title text.
Visible | Gets or sets the title visibility.

Title Methods

ResetStyle | Resets the style to its default state.
ShouldSerializeLocationDefault | Returns true if the Title LocationDefault property is not in the default state.
ShouldSerializeSizeDefault | Returns true if the Title SizeDefault property is not in the default state.
ShouldSerializeStyle | Returns true if the Title Style property is not in the default state.


Title Properties

Compass Property (Title)

Location Property (Title)

LocationDefault Property (Title)

Size Property (Title)

SizeDefault Property (Title)

Style Property (Title)

Text Property (Title)

Visible Property (Title)


Compass Property (Title)

Compass Property (Title)

Gets or sets the general positioning of the title.

Syntax

[VB]

Public Property Compass As CompassEnum

[C#]

public CompassEnum Compass { get; set; }

[Delphi]

property Compass: CompassEnum;

See Also

Title Class


Location Property (Title)

Location Property (Title)

Gets or sets the location of the title in chart control client coordinates.

Syntax

[VB]

Public Property Location As Point

[C#]

public Point Location { get; set; }

[Delphi]

property Location: Point;

Remarks

The Location property always returns the actual location of the upper, left corner of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change LocationDefault.

See Also

Title Class


LocationDefault Property (Title)

LocationDefault Property (Title)

Gets or sets the default location of the title.

Syntax

[VB]

Public Property LocationDefault As Point

[C#]

public Point LocationDefault { get; set; }

[Delphi]

property LocationDefault: Point;

Remarks

The LocationDefault property specifies the location of the upper, left corner of the chart element it describes. Non-negative values indicate the explicit position in chart client coordinates to place the chart element. Negative values will allow auto-positioning.

See Also

Title Class


Size Property (Title)

Size Property (Title)

Gets or sets the size of the title in chart control client coordinates.

Syntax

[VB]

Public Property Size As Size

[C#]

public Size Size { get; set; }

[Delphi]

property Size: Size;

Remarks

The Size property always returns the actual size of the chart element it describes whether or not the element placement is manual or automatic. Modifying this value will change SizeDefault.

See Also

Title Class


SizeDefault Property (Title)

SizeDefault Property (Title)

Gets or sets the default size of the title.

Syntax

[VB]

Public Property SizeDefault As Size

[C#]

public Size SizeDefault { get; set; }

[Delphi]

property SizeDefault: Size;

Remarks

The SizeDefault property specifies the size of the chart element it describes. Non-negative values indicate the explicit width and height in chart client coordinates to place the chart element.Negative values will allow auto-positioning.

See Also

Title Class


Style Property (Title)

Style Property (Title)

Gets the title style.

Syntax

[VB]

Public ReadOnly Property Style As Style

[C#]

public Style Style { get; }

[Delphi]

property Style: Style;

Remarks

Inherits from the C1Chart3D style.

See Also

Title Class


Text Property (Title)

Text Property (Title)

Gets or set title text.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text { get; set; }

[Delphi]

property Text: string;

See Also

Title Class


Visible Property (Title)

Visible Property (Title)

Gets or sets the title visibility.

Syntax

[VB]

Public Property Visible As Boolean

[C#]

public bool Visible { get; set; }

[Delphi]

property Visible: Boolean;

See Also

Title Class


Title Methods

ResetStyle Method (Title)

ShouldSerializeLocationDefault Method

ShouldSerializeSizeDefault Method

ShouldSerializeStyle Method


ResetStyle Method (Title)

ResetStyle Method (Title)

Resets the style to its default state.

Syntax

[VB]

Public Sub ResetStyle()

[C#]

public void ResetStyle()

[Delphi]

procedure ResetStyle;

See Also

Title Class


ShouldSerializeLocationDefault Method

ShouldSerializeLocationDefault Method

Returns true if the Title LocationDefault property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeLocationDefault() As Boolean

[C#]

public bool ShouldSerializeLocationDefault ( )

[Delphi]

function ShouldSerializeLocationDefault: Boolean

Remarks

The default state is LocationDefault.Width = -1, LocationDefault.Height = -1, which results in automatic location of the Title based upon the Compass property.

See Also

Title Class


ShouldSerializeSizeDefault Method

ShouldSerializeSizeDefault Method

Returns true if the Title SizeDefault property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeSizeDefault() As Boolean

[C#]

public bool ShouldSerializeSizeDefault ( )

[Delphi]

function ShouldSerializeSizeDefault: Boolean;

Remarks

The default state is SizeDefault.Width = -1, SizeDefault.Height = -1, which results in automatic sizing of the Title.

See Also

Title Class


ShouldSerializeStyle Method

ShouldSerializeStyle Method

Returns true if the Title Style property is not in the default state.

Syntax

[VB]

Public Function ShouldSerializeStyle() As Boolean

[C#]

public bool ShouldSerializeStyle ( )

[Delphi]

function ShouldSerializeStyle: Boolean;

Remarks

The default state is to inherit the Style from the C1Chart3D Style property.

See Also

Title Class


C1Chart 3D Enumeration Reference

AlignHorzEnum Enumeration (C1Chart3D)

AlignImageEnum Enumeration (C1Chart3D)

AlignVertEnum Enumeration (C1Chart3D)

AnnoPositionEnum Enumeration (C1Chart3D)

AnnotationMethodEnum Enumeration (C1Chart3D)

AttachMethodEnum Enumeration (C1Chart3D)

AxisTypeEnum Enumeration

BarFormatEnum Enumeration

BorderStyleEnum Enumeration (C1Chart3D)

Chart3DTypeEnum Enumeration

ColorSetEnum Enumeration

CompassEnum Enumeration

DataFormatEnum Enumeration

DataLayoutEnum Enumeration

FormatEnum Enumeration

GradientStyleEnum Enumeration

HatchStyleEnum Enumeration

LabelCompassEnum Enumeration (C1Chart3D)

LabelView3DEnum Enumeration

LegendOrientationEnum Enumeration

LegendTypeEnum Enumeration

LinePatternEnum Enumeration (C1Chart3D)

PreviewMethodEnum Enumeration

PrintScaleEnum Enumeration

RotationEnum Enumeration (C1Chart3D)

SymbolShapeEnum Enumeration

TextRotationEnum Enumeration

View3DEnum Enumeration

ZoneMethodEnum Enumeration


AlignHorzEnum Enumeration (C1Chart3D)

AlignHorzEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AlignHorzEnum

[C#]

public sealed enum AlignHorzEnum : System.Enum

[Delphi]

type AlignHorzEnum = (General, Near, Center, Far, Justify);

Remarks

Use the members of this enumeration to set the value of the HorizontalAlignment property in the Style class.

Member Name | Description
General | Sets text to be left aligned and numbers to be right aligned.
Near | Aligns text to the near side (left side in left-to-right mode).
Center | Aligns text to the center.
Far | Aligns cell text to the far side (right side in left-to-right mode).
Justify | Spreads text throughout.


AlignImageEnum Enumeration (C1Chart3D)

AlignImageEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AlignImageEnum

[C#]

public sealed enum AlignImageEnum : System.Enum

[Delphi]

type AlignImageEnum = (Hide, Left, Right, Top, Bottom, Center, Scale, Stretch, Tile);

Remarks

Use the members of this enumeration to set the value of the ImageAlignment property in the Style class.

Member Name | Description
Hide | Image is hidden
Left | Image is aligned to the left
Right | Image is aligned to the right
Top | Image is aligned to the Top
Bottom | Image is aligned to the bottom
Center | Image is center-aligned
Scale | Image is scaled to fit the image area
Stretch | Image is stretched to fit image area
Tile | Image is tiled throughout the image area


AlignVertEnum Enumeration (C1Chart3D)

AlignVertEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AlignVertEnum

[C#]

public sealed enum AlignVertEnum : System.Enum

[Delphi]

type AlignVertEnum = (Top, Center, Bottom);

Remarks

Use the members of this enumeration to set the value of the VerticalAlignment property in the Style class.

Member Name | Description
Top | Aligns text to the top.
Center | Aligns text to the center.
Bottom | Aligns text to the bottom.


AnnoPositionEnum Enumeration (C1Chart3D)

AnnoPositionEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AnnoPositionEnum

[C#]

public sealed enum AnnoPositionEnum : System.Enum

[Delphi]

type AnnoPositionEnum = (Both, Far, Near, None);

Remarks

Use the members of this enumeration to determine which axes edges of the plot cube will have annotations.

Member Name | Description
Both | The axis on both sides of the plot cube will be annotated.
Far | The axis on the far side of the plot cube will be annotated.
Near | The axis on the near side of the plot cube will be annotated.
None | The axis is not annotated.


AnnotationMethodEnum Enumeration (C1Chart3D)

AnnotationMethodEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AnnotationMethodEnum

[C#]

public sealed enum AnnotationMethodEnum : System.Enum

[Delphi]

type AnnotationMethodEnum = (DataLabels, ValueLabels, Values);

Remarks

Use the members of this enumeration to set the value of the AnnotationMethod property in the Chart3DAxis class.

Member Name | Description
DataLabels | Annotate using data labels.
ValueLabels | Annotate using ValueLabels property.
Values | Annotate using chart's values.


AttachMethodEnum Enumeration (C1Chart3D)

AttachMethodEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum AttachMethodEnum

[C#]

public sealed enum AttachMethodEnum : System.Enum

[Delphi]

type AttachMethodEnum = (Coordinate, DataCoordinate, DataIndex);

Remarks

Use the members of this enumeration to set the value of the AttachMethod property in the Chart3DLabel class.

Member Name | Description
Coordinate | Label is attached at specified pixel coordinate.
DataCoordinate | Label is attached to specified data coordinates.
DataIndex | Label is attached to specified data indices.


AxisTypeEnum Enumeration

AxisTypeEnum Enumeration

Syntax

[VB]

Public enum AxisTypeEnum

[C#]

public sealed enum AxisTypeEnum : System.Enum

[Delphi]

type AxisTypeEnum = (AxisX, AxisY, AxisZ, None);

Remarks

Use the members of this enumeration to specify a specific Axis where appropriate.

Member Name | Description
AxisX | Specifies the X axis.
AxisY | Specifies the Y axis.
AxisZ | Specifies the Z axis.
None | Indicates that no axis is specified.


BarFormatEnum Enumeration

BarFormatEnum Enumeration

Syntax

[VB]

Public enum BarFormatEnum

[C#]

public sealed enum BarFormatEnum : System.Enum

[Delphi]

type BarFormatEnum = (Fixed, Histogram);

Remarks

Use the members of this enumeration to set the value of the ColumnFormat and RowFormat property in the Chart3DBar class.

Member Name | Description
Fixed | Fixed format (bars are fixed width and centered about their X or Y values) .
Histogram | Histogram format (each bar fills the space up to its adjoining bar).


BorderStyleEnum Enumeration (C1Chart3D)

BorderStyleEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum BorderStyleEnum

[C#]

public sealed enum BorderStyleEnum : System.Enum

[Delphi]

type BorderStyleEnum = (NotSet, None, Empty, Solid, Raised, Inset, RaisedBevel, InsetBevel, Groove, Fillet, Double, Dashed);

Remarks

Use the members of this enumeration to set the value of the BorderStyle property in the Border class.

Member Name | Description
NotSet | Border style is not set and is inherited from C1Chart class.
None | No border.
Empty | Empty Border.
Solid | Solid line border.
Raised | Raised 3D border, drawn using system colors.
Inset | Inset 3D border, drawn using system colors.
RaisedBevel | Raised 3D border with bevel.
InsetBevel | Inset 3D border with bevel.
Groove | Compound border (inset+raised).
Fillet | Compound border (raised+inset).
Double | Double solid line border.
Dashed | Dashed line border.


Chart3DTypeEnum Enumeration

Chart3DTypeEnum Enumeration

Syntax

[VB]

Public enum Chart3DTypeEnum

[C#]

public sealed enum Chart3DTypeEnum : System.Enum

[Delphi]

type Chart3DTypeEnum = (Bar, Scatter, Surface);

Remarks

Use the members of this enumeration to set the value of the ChartType property in the Chart3DGroup class.

Member Name | Description
Bar | Bar chart
Scatter | Scatter chart
Surface | Surface chart


ColorSetEnum Enumeration

ColorSetEnum Enumeration

Syntax

[VB]

Public enum ColorSetEnum

[C#]

public sealed enum ColorSetEnum : System.Enum

[Delphi]

type ColorSetEnum = (Custom, Rainbow, RevRainbow, BlackWhite, WhiteBlack, GreenBlue, RedWhite, BluePink, BlueWhiteRed, BlackRedYellow, GreenPurpleYellow);

Remarks

Use the members of this enumeration to set the value of the ColorSet property in the Chart3DContourStyles class.

Member Name | Description
Custom | Custom color set
Rainbow | Rainbow colors
RevRainbow | Rainbow colors in the reverse order
BlackWhite | Grayscale colors
WhiteBlack | Grayscale colors in the reverse order
GreenBlue | Colors from green to blue
RedWhite | Colors from red to white
BluePink | Colors from blue to pink
BlueWhiteRed | Colors blue -> white ->red
BlackRedYellow | Colors black -> red -> yellow
GreenPurpleYellow | Colors green -> purple -> yellow


CompassEnum Enumeration

CompassEnum Enumeration

Syntax

[VB]

Public enum CompassEnum

[C#]

public sealed enum CompassEnum : System.Enum

[Delphi]

type CompassEnum = (North, South, East, West);

Remarks

Use the members of this enumeration to set the value of the Compass property of the Title and Chart3DLegend classes.

Member Name | Description
North | Object is positioned north or above.
South | Object is positioned south or below.
East | Object is positioned east or to the right side.
West | Object is positioned west or to the left side.


DataFormatEnum Enumeration

DataFormatEnum Enumeration

Syntax

[VB]

Public enum DataFormatEnum

[C#]

public sealed enum DataFormatEnum : System.Enum

[Delphi]

type DataFormatEnum = (XML, Chart7);

Remarks

Use the members of this enumeration to specify data format when loading or saving data.

Member Name | Description
Xml | XML format
Chart7 | ComponentOne Chart 7 format


DataLayoutEnum Enumeration

DataLayoutEnum Enumeration

Syntax

[VB]

Public enum DataLayoutEnum

[C#]

public sealed enum DataLayoutEnum : System.Enum

[Delphi]

type DataLayoutEnum = (GridData, lrGridData, PointData);

Remarks

Use the members of this enumeration to set the value of the Layout property in the Chart3DData class.

Member Name | Description
GridData | Regular grid data
IrGridData | Irregular grid data
PointData | Point data


FormatEnum Enumeration

FormatEnum Enumeration

Syntax

[VB]

Public enum FormatEnum

[C#]

public sealed enum FormatEnum : System.Enum

[Delphi]

type FormatEnum = (NumericManual, NumericCurrency, NumericGeneral, NumericExponential, NumericPercentage, NumericRoundtrip, NumericHexadecimal, DateManual, DateShort, DateLong, DateFullShortTime, DateFull, DateGeneralShortTime, DateGeneral, DateMonth, DateRFC1123, DateSortable, DateShortTime, DateLongTime, DateUniversalSortable, DateUniversal, DateYear);

Remarks

Use the members of this enumeration to set the value of the AnnoFormat property in the Chart3DAxis class.

See .Net date and time format strings and standard numeric format strings for more information

Member Name | Description
NumericManual | Used in conjunction with the Axis AnnoFormatString property to specify a .Net custom numeric format. (See custom numeric format strings in the .Net documentation).
NumericCurrency | A currency amount format.
NumericGeneral | A general number format. Formatted into the most compact decimal form using fixed or scientific notation.
NumericExponential | A scientific or exponential format in the form "-d.ddd…E+ddd" or "-d.ddd…e+ddd".
NumericPercentage | A percentage amount format.
NumericRoundtrip | A format that guarantees that a numeric value after being converted will be returned as the same numeric value.
NumericHexadecimal | A hexadecimal format.
DateManual | Used in conjunction with the Axis AnnoFormatString property to specify a .Net custom date/datetime format. (See custom date and time format strings in the .Net documentation).
DateShort | A short date format.
DateLong | A long date format.
DateFullShortTime | A full format for both short date and time.
DateFull | A full date format.
DateGeneralShortTime | A general date format with short time format.
DateGeneral | A general date format.
DateMonth | A month format.
DateRFC1123 | A date format based on the IETF RFC 1123 specification.
DateSortable | A sortable date format.
DateShortTime | A short time format.
DateLongTime | A long time format.
DateUniversalSortable | A universally sortable date format.
DateUniversal | A universal date format.
DateYear | A year format.


GradientStyleEnum Enumeration

GradientStyleEnum Enumeration

Syntax

[VB]

Public enum GradientStyleEnum

[C#]

public sealed enum GradientStyleEnum : System.Enum

[Delphi]

type GradientStyleEnum = (None, Horizontal, HorizontalCenter, Vertical, VerticalCenter, Diagonal, DiagonalCenter, DiagonalBack, DiagonalBackCenter, Radial, FromCenter);

Remarks

Use the members of this enumeration to set the value of the GradientStyle property in the Style class.

Member Name | Description
None | No gradient filling.
Horizontal | From left (BackColor) to right (BackColor2).
HorizontalCenter | From center (BackColor) to left and right (BackColor2).
Vertical | From top (BackColor) to bottom (BackColor2).
VerticalCenter | From center (BackColor) to top and bottom (BackColor2).
Diagonal | From left-bottom (BackColor) to right-top (BackColor2).
DiagonalCenter | From center (BackColor) to left-bottom and right-top (BackColor2).
DiagonalBack | From left-top (BackColor) to right-bottom (BackColor2).
DiagonalBackCenter | From center (BackColor) to left-top and right-bottom (BackColor2).
Radial | From center (BackColor) to corners (BackColor2) in radial direction.
FromCenter | From center (BackColor) to corners (BackColor2).


HatchStyleEnum Enumeration

HatchStyleEnum Enumeration

Syntax

[VB]

Public enum HatchStyleEnum

[C#]

public sealed enum HatchStyleEnum : System.Enum

[Delphi]

type HatchStyleEnum = (BackwardDiagonal, Corss, DarkDownwardDiagonal, DarkHorizontal, DarkUpwardHorizontal, DarkVertical, DashedDownwardDiagonal, DashedHorizontal, DashedUpwardDiagonal, DashedVertical, DiagonalBrick, DiagonalCross, Divot, DottedDiamond, DottedGrid, ForwardDiagonal, Horizontal, HorizontalBrick, LargeCheckerBoard, LargeConfetti, LightDownwardDiagonal, LightHorizontal, LightUpwardDiagonal, LightVertical, NarrowHorizontal, NarrowVertical, None, OutlinedDiamond, Percent05, Percent10, Percent20, Percent25, Percent30, Percent40, Percent50, Percent60, Percent70, Percent75, Percent80, Percent90, Plaid, Shingle, SmallCheckerBoard, SmallConfetti, SmallGrid, SolidDiamond, Sphere, Trellis, Vertical, Wave, Weave, WideDownwardDiagonal, WideUpwardDiagonal, ZigZag);

Remarks

Use the members of this enumeration to set the value of the HatchStyle property in the Style class.

Member Name | Description
None | No pattern.
Horizontal | A pattern of horizontal lines.
Vertical | A pattern of vertical lines.
ForwardDiagonal | A pattern of lines on a diagonal from upper left to lower right.
BackwardDiagonal | A pattern of lines on a diagonal from upper right to lower left.
Cross | Specifies horizontal and vertical lines that cross.
DiagonalCross | Specifies forward diagonal and backward diagonal lines that cross. The lines are antialiased.
Percent05 | Specifies a 5-percent hatch. The ratio of foreground color to background color is 5:100.
Percent10 | Specifies a 10-percent hatch. The ratio of foreground color to background color is 10:100.
Percent20 | Specifies a 20-percent hatch. The ratio of foreground color to background color is 20:100.
Percent25 | Specifies a 25-percent hatch. The ratio of foreground color to background color is 25:100.
Percent30 | Specifies a 30-percent hatch. The ratio of foreground color to background color is 30:100.
Percent40 | Specifies a 40-percent hatch. The ratio of foreground color to background color is 40:100.
Percent50 | Specifies a 50-percent hatch. The ratio of foreground color to background color is 50:100.
Percent60 | Specifies a 60-percent hatch. The ratio of foreground color to background color is 60:100.
Percent70 | Specifies a 70-percent hatch. The ratio of foreground color to background color is 70:100.
Percent75 | Specifies a 75-percent hatch. The ratio of foreground color to background color is 75:100.
Percent80 | Specifies a 80-percent hatch. The ratio of foreground color to background color is 80:100.
Percent90 | Specifies a 90-percent hatch. The ratio of foreground color to background color is 90:100.
LightDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points.
LightUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points and are spaced 50 percent closer together than BackwardDiagonal, but they are not antialiased.
DarkDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, are spaced 50 percent closer together than, and are twice the width of ForwardDiagonal. This hatch pattern is not antialiased.
DarkUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, are spaced 50 percent closer together than BackwardDiagonal, and are twice its width, but the lines are not antialiased.
WideDownwardDiagonal | Specifies diagonal lines that slant to the right from top points to bottom points, have the same spacing as hatch style ForwardDiagonal, and are triple its width, but are not antialiased.
WideUpwardDiagonal | Specifies diagonal lines that slant to the left from top points to bottom points, have the same spacing as hatch style BackwardDiagonal, and are triple its width, but are not antialiased.
LightVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical.
LightHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal.
NarrowVertical | Specifies vertical lines that are spaced 75 percent closer together than hatch style Vertical (or 25 percent closer together than LightVertical).
NarrowHorizontal | Specifies horizontal lines that are spaced 75 percent closer together than hatch style Horizontal (or 25 percent closer together than LightHorizontal).
DarkVertical | Specifies vertical lines that are spaced 50 percent closer together than Vertical and are twice its width.
DarkHorizontal | Specifies horizontal lines that are spaced 50 percent closer together than Horizontal and are twice the width of HatchStyleHorizontal.
DashedDownwardDiagonal | Specifies dashed diagonal lines that slant to the right from top points to bottom points.
DashedUpwardDiagonal | Specifies dashed diagonal lines that slant to the left from top points to bottom points.
DashedHorizontal | Specifies dashed horizontal lines.
DashedVertical | Specifies dashed vertical lines.
SmallConfetti | Specifies a hatch that has the appearance of confetti.
LargeConfetti | Specifies a hatch that has the appearance of confetti, and is composed of larger pieces than SmallConfetti.
ZigZag | Specifies horizontal lines that are composed of zigzags.
Wave | Specifies horizontal lines that are composed of tildes.
DiagonalBrick | Specifies a hatch that has the appearance of layered bricks that slant to the left from top points to bottom points.
HorizontalBrick | Specifies a hatch that has the appearance of horizontally layered bricks.
Weave | Specifies a hatch that has the appearance of a woven material.
Plaid | Specifies a hatch that has the appearance of a plaid material.
Divot | Specifies a hatch that has the appearance of divots.
DottedGrid | Specifies horizontal and vertical lines, each of which is composed of dots that cross.
DottedDiamond | Specifies forward diagonal and backward diagonal lines, each of which is composed of dots, that cross.
Shingle | Specifies a hatch that has the appearance of diagonally-layered shingles that slant to the right from top points to bottom points.
Trellis | Specifies a hatch that has the appearance of a trellis.
Sphere | Specifies a hatch that has the appearance of spheres laid adjacent to one another.
SmallGrid | Specifies horizontal and vertical lines that cross and are spaced 50 percent closer together than hatch style Cross.
SmallCheckerBoard | Specifies a hatch that has the appearance of a checkerboard.
LargeCheckerBoard | Specifies a hatch that has the appearance of a checkerboard with squares that are twice the size of SmallCheckerBoard.
OutlinedDiamond | Specifies forward diagonal and backward diagonal lines that cross but are not antialiased.
SolidDiamond | Specifies a hatch that has the appearance of a checkerboard placed diagonally.


LabelCompassEnum Enumeration (C1Chart3D)

LabelCompassEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum LabelCompassEnum

[C#]

public sealed enum LabelCompassEnum : System.Enum

[Delphi]

type LabelCompassEnum = (North, NorthEast, East, SouthEast, South, SouthWest, West, NorthWest);

Remarks

Use the members of this enumeration to set the value of the LabelCompass property in the Chart3DLabel class.

Member Name | Description
North | Places label to the north or above the data point.
NorthEast | Places label to the NorthEast or above and right of the data point.
East | Places label to the East or to the right of the data point.
SouthEast | Places label to the SouthEast or blow and right of the data point.
South | Places label to the South or below the data point.
SouthWest | Places label to the SouthWest or below and left of the data point.
West | Places label to the West or left of the data point.
NorthWest | Places label to the NorthWest or above and left of the data point.


LabelView3DEnum Enumeration

LabelView3DEnum Enumeration

Syntax

[VB]

Public enum LabelView3Denum

[C#]

public sealed enum LabelView3DEnum : System.Enum

[Delphi]

type LabelView3DEnum = (None, XZ, YZ);

Remarks

Use the members of this enumeration to set the value of the View3D property in the Chart3DLabel class.

Member Name | Description
None | Label is drawn in 2D plane of screen.
XZ | Label is drawn in 3D plane parallel to XZ plane.
YZ | Label is drawn in 3D plane parallel to YZ plane.


LegendOrientationEnum Enumeration

LegendOrientationEnum Enumeration

Syntax

[VB]

Public enum LegendOrientationEnum

[C#]

public sealed enum LegendOrientationEnum : System.Enum

[Delphi]

type LegendOrientationEnum = (Auto, Horizontal, Vertical);

Remarks

Use the members of this enumeration to set the value of the Orientation in the Legend classes.

Member Name | Description
Auto | Horizontal for legends with north and south Compass values, and Vertical for legends with east and west Compass values.
Horizontal | Legend entries are added side by side as (horizontally) as legend width permits. If sufficient width is not available, additional legend rows are created.
Vertical | Legend entries are stacked vertically as legend height permits. If sufficient height is not available, additional legend columns are created.


LegendTypeEnum Enumeration

LegendTypeEnum Enumeration

Syntax

[VB]

Public enum LegendTypeEnum

[C#]

public sealed enum LegendTypeEnum : System.Enum

[Delphi]

type LegendTypeEnum = (Continuous, Stepped);

Remarks

Use the members of this enumeration to set the value of the Type property in the Chart3DLegend class.

Member Name | Description
Continuous | Level printed at the division between two adjacent zones.
Stepped | Range printed for each zone.


LinePatternEnum Enumeration (C1Chart3D)

LinePatternEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum LinePatternEnum

[C#]

public sealed enum LinePatternEnum : System.Enum

[Delphi]

type LinePatternEnum = (Solid, Dash, Dot, DashDot, DashDotDot);

Remarks

Use the members of this enumeration to set the value of the Pattern property in the Chart3DLineStyle class.

Member Name | Description
Solid | A solid line.
Dash | A dashed line.
Dot | A dotted line.
DashDot | A line with alternating dashes and dots.
DashDotDot | A line with series consisting of a dash followed by two dots.


PreviewMethodEnum Enumeration

PreviewMethodEnum Enumeration

Syntax

[VB]

Public enum PreviewMethodEnum

[C#]

public sealed enum PreviewMethodEnum : System.Enum

[Delphi]

type PreviewMethodEnum = (PreviewAxes, PreviewFull);

Remarks

Use the members of this enumeration to set the value of the PreviewMethod property in the Chart3DView class.

Member Name | Description
PreviewAxes | During rotating, scaling, or zooming action only the axes of the chart will be redrawn.
PreviewFull | During rotating, scaling, or zooming action the entire chart will be redrawn.


PrintScaleEnum Enumeration

PrintScaleEnum Enumeration

Syntax

[VB]

Public enum PrintScaleEnum

[C#]

public sealed enum PrintScaleEnum : System.Enum

[Delphi]

type PrintScaleEnum = (ScaleNone, ScaleToFit, ScaleToHeight, ScaleToMax, ScaleToWidth);

Remarks

Use the members of this enumeration to set the value of the scaling property in the PrintChart method.

Member Name | Description
ScaleNone | Same size as actual chart.
ScaleToFit | Scale to existing window (minimum of height and width), preserving aspect ratio.
ScaleToHeight | Scale to specified height, preserving aspect ratio.
ScaleToMax | Enlarge to size of page.
ScaleToWidth | Scale to specified width, preserving aspect ratio.


RotationEnum Enumeration (C1Chart3D)

RotationEnum Enumeration (C1Chart3D)

Syntax

[VB]

Public enum RotationEnum

[C#]

public sealed enum RotationEnum : System.Enum

[Delphi]

type RotationEnum =(Rotate0, Rotate90, Rotate180, Rotate270);

Remarks

Use the members of this enumeration to set the value of the Rotation property in the Style class.

Member Name | Description
Rotate0 | No rotation.
Rotate90 | Object is rotated 90 degrees.
Rotate180 | Object is rotated 180 degrees, or inverted.
Rotate270 | Object is rotated 270 degrees.


SymbolShapeEnum Enumeration

SymbolShapeEnum Enumeration

Syntax

[VB]

Public enum SymbolShapeEnum

[C#]

public sealed enum SymbolShapeEnum : System.Enum

[Delphi]

type SymbolShapeEnum = (None, Box, Dot, Tri, Diamond, InvertedTri, Star, VerticalLine, HorizontalLine, Cross, DiagCross, Circle, Square, OpenTri, OpenDiamond, OpenInvertedTri);

Remarks

Use the members of this enumeration to set the value of the Shape property in the Chart3DSymbolStyle class.

Member Name | Description
None | No symbol represents data point.
Box | Data point represented by small solid square.
Dot | Data point represented by small solid circle.
Tri | Data point represented by solid triangle.
Diamond | Data point represented by solid diamond.
InvertedTri | Data point represented by solid inverted triangle.
Star | Data point represented by solid star.
VerticalLine | Data point represented by short vertical line.
HorizontalLine | Data point represented by short horizontal line.
Cross | Data point represented by crossed horizontal and vertical lines.
DiagCross | Data point represented by diagonal crossed lines.
Circle | Data point represented by large solid circle.
Square | Data point represented by large solid square.
OpenTri | Data point represented by the outline of a small triangle.
OpenDiamond | Data point represented by the outline of a diamond.
OpenInvertedTri | Data point represented by the outline of an inverted triangle.


TextRotationEnum Enumeration

TextRotationEnum Enumeration

Syntax

[VB]

Public enum TextRotationEnum

[C#]

public sealed enum TextRotationEnum : System.Enum

[Delphi]

type TextRotationEnum = (RotNo, Rot2D, Rot3D);

Remarks

Use the members of this enumeration to set the value of the TextRotation property in the Chart3DView class.

Member Name | Description
RotNo | No rotation.
Rot2D | Rotate in the plane of screen.
Rot3D | Rotate in 3D space.


View3DEnum Enumeration

View3DEnum Enumeration

Syntax

[VB]

Public enum View3DEnum

[C#]

public sealed enum View3DEnum : System.Enum

[Delphi]

type View3DEnum = (Default, XY_2D_Neg, XY_2D_Pos, XZ_2D_Neg, XZ_2D_Pos, YZ_2D_Neg, YZ_2D_Pos, Custom);

Remarks

Use the members of this enumeration to set the value of the View property in the Chart3DView class.

Member Name | Description
Default | Default view.
XY_2D_Neg | View XY-plane from negative edge of Z-axis.
XY_2D_Pos | View XY-plane from positive edge of Z-axis.
XZ_2D_Neg | View XZ-plane from negative edge of Y-axis.
XZ_2D_Pos | View XZ-plane from positive edge of Y-axis.
YZ_2D_Neg | View YZ-plane from negative edge of X-axis.
YZ_2D_Pos | View YZ-plane from positive edge of X-axis.
Custom | Custom view.


ZoneMethodEnum Enumeration

ZoneMethodEnum Enumeration

Syntax

[VB]

Public enum ZoneMethodEnum

[C#]

public sealed enum ZoneMethodEnum : System.Enum

[Delphi]

type ZoneMethodEnum = (Cells, Contours);

Remarks

Use the members of this enumeration to set the value of the ZoneMethod property in the Chart3DContour class.

Member Name | Description
Cells | Cell zoning.
Contours | Contour zoning.


AbsoluteExpiration Property (C1WebChart3D)

AbsoluteExpiration Property (C1WebChart3D)

Specifies the absolute expiration time when the image expires from the session, cache, or file object.

Syntax

[VB]

Public Property AbsoluteExpiration As DateTime

[C#]

public DateTime AbsoluteExpiration { get; set; }

[Delphi]

property AbsoluteExpiration: DateTime;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


Adding C1WebChart to the Visual Studio Toolbox

Before you can use C1WebChart, you must add it to the Visual Studio toolbox.

· Open Visual Studio and make sure the toolbox window is visible.

· Right-click on the toolbox and select “Customize Toolbox”.

· Select the .Net Components tab.

· Check the C1WebChart and C1WebChart3D controls. If you can’t find the controls on the list, click the Browse button and select the C1WebChart.dll and C1WebChart3D.dll files, which should be in the “c:\Program Files\ComponentOne Studio.NET\bin” directory.

These steps will add the components to the toolbox, where it will be available to all your web applications.

At this point, you should also decide whether you want C1WebChart to run from the GAC (Global Assembly Cache) or locally. If the installation program (or you) places a copy of the component in the GAC, that copy will be used by all applications that use the component. If the component is not installed in the GAC, Visual Studio will make a local copy of the required dlls into your application’s bin directory.

Using the GAC can save some disk space, but it also complicates deployment, because you will have to remember to install the components in the GAC on the server as well. In most cases, it is better to remove the component from the GAC and later use XCOPY deployment (the application folder will contain all the dlls needed to run it). To remove the component from the GAC, open the “system\assembly” folder and delete the C1WebChart, C1Chart and C1Chart3D from it. For more details on the GAC, see the .NET documentation. Also, keep in mind that C1Chart and C1Chart3D have a dependency upon C1.Common.dll, and require it to run, so be sure that it is copied during deployment as well.


Adding Charts to your Web Applications

Once the C1WebChart control has been added to the Visual Studio toolbox, you can drag it onto your web forms. When you add a C1WebChart control to the form, you will see a default chart with four data series and some random data.

Before you run the application, you need to configure it by performing these steps:

· Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”

· In the Solution Explorer, double-click the “Web.Config” file

· Place the cursor below <system.web> and select “Paste”. The Web.Config file should look like this:

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.web>

<httpHandlers>

<add verb="*" path="c1chartimage.aspx"

type="C1.Web.C1WebChart.ImageHttpHandler,C1.Web.C1WebChart"/>

</httpHandlers>

…

This step allows C1WebChart to use its internal HttpHandler to transfer chart images directly to the client without any temporary files. It is not strictly required (you can use temporary files if you prefer), but for most applications this is the most efficient method.

If you are using C1WebChart3D, the process is identical, except that the <add> tag entry applies to C1WebChart3D and its internal HttpHandler. If you are using both C1WebChart and C1WebChart3D on the same form, then perform the operation given above for one of them, then again for the other, but this time selecting “HttpHandler string to clipboard”. This will place only the <add> tag for the control on the clipboard, which should be pasted into the web.config file inside the existing <httpHandlers>.

The result should look as follows:

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.web>

<httpHandlers>

<add verb="*" path="c1chartimage.aspx"

type="C1.Web.C1WebChart.ImageHttpHandler,C1.Web.C1WebChart"/>

<add verb="*" path="c1chart3dimage.aspx"

type="C1.Web.C1WebChart3D.ImageHttpHandler,C1.Web.C1WebChart3D"/>

</httpHandlers>

…

At this point, you may run your application and see the chart on your web page.

Note that you only have to perform this step once per application. If you later add more charts to the form, or add new forms, there’s no need to modify the Web.Config file again.

This topic is discussed in detail in a later section (see “How C1WebChart Handles Images”)


Adding Data to the Chart

The final step is to add the data you want to show to your chart. This step requires you to write some code.

In most applications, the data will come from an ADO.NET DataSet, often with some transformations such as filtering, sorting, or summarizing. It is also possible to chart data from other sources, such as arrays or custom data structures. Regardless of where the data comes from, you can add it to the chart using methods provided by the ChartDataSeries class.

For example, the C# code below populates a chart using data from a DataTable:

private void Page_Load(object sender, EventArgs e)

{

// get dataset (from db or cache)

DataSet ds = GetDataSet();

// filter the data

DataView dv = new DataView(ds.Tables["Sales"]);

dv.RowFilter = "ProductSales >= 40000";

dv.Sort = "ProductSales";

// create an array of data points

PointF[] data = new PointF[dv.Count]

for (int i = 0; i < data.Length; i++)

{

float y = float.Parse(dv[i]["ProductSales"].ToString());

data[i] = new PointF(i, y);

}

// populate chart data points

ChartDataSeries series =

_c1webChart.ChartGroups[0].ChartData.SeriesList[0];

series.PointData.CopyDataIn(data);

}

For more details on how to add data to charts, see Understanding 3D Data Layout. Note: C1Chart and C1Chart3D are the WinForms control used by C1WebChart and C1WebChart3D, respectively, to generate the charts.


AddingDropLines - C#

C#

C1Chart3D1.ChartGroups[0].Elevation.DropLines = true;


AddingDropLines - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].Elevation.DropLines := True;

end;


AddingDropLines - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(0).Elevation.DropLines = True


AddingRowsColumns - C#

C#

C1Chart3D1.ChartGroups[0].ChartData.SetGrid.RowCount = 4;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[0,3] = 5.17f;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[1,3] = 5.84f;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[2,3] = 6.33f;


AddingRowsColumns - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].ChartData.SetGrid.RowCount := 4;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[0,3] := 5.17;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[1,3] := 5.84;

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[2,3] := 6.33;

end;


AddingRowsColumns - Visual Basic

Visual Basic

With C1Chart3D1.ChartGroups(0).ChartData.SetGrid

.RowCount = 4

.Item(0, 3) = 5.17

.Item(1, 3) = 5.84

.Item(2, 3) = 6.33

End With


Adding User Interaction With ImageAreas

C1WebChart and C1WebChart3D allow you to associate tooltips and links with chart elements, so the chart responds to mouse events. This is done using an HTML image map, which is handled on the client.

The image map is defined by the ImageAreas property, a collection of chart elements with associated dynamic tooltips and HRefs. The tooltips allow you to specify the text that is displayed to the user when he moves the mouse over chart elements. The HRefs allow you to specify actions to be taken when the user clicks on a chart element.

You can edit the ImageAreas collection using the property window. Click the button to bring up an editor with a list of 11 chart elements, including ChartArea, PlotArea, Axes, ChartData, Legend, etc.

For example, if you select “ChartData” and set its Tooltip property to “{#YVAL:c}”, then the control will display the value for a point (or bar) when the user moves the mouse over the point. Note that you can use several keywords to refer to chart properties and create dynamic toolbars with no code. You can also specify the format to be used to displaying the information (the example formats the data as currency values).

This topic is discussed in detail in a later section (see “User Interaction with C1WebChart”).


Add Method (MapAreaCollection)

Add Method (MapAreaCollection)

Adds the specified MapArea to the collection.

Syntax

[VB]

Public Function Add(chartMap As MapArea) As Integer

[C#]

public int Add(MapArea chartMap);

[Delphi]

function Add(chartMap: MapArea): Integer;

Remarks

This property applies to C1WebChart3D.

Return Value

This method returns an integer indicating the index of the added MapArea.

See Also

MapAreaCollection Class


All Members

Properties

AbsoluteExpiration | Specifies the absolute expiration time when the image expires from the session, cache, or file object.
AssemblyFileVersionString | Gets the control’s assembly file version as a string.
AssemblyVersionString | Gets the control’s assembly version as a string.
BackColor | Gets or sets the control’s back color.
BackgroundImageUrl | Gets or sets the location of the background image through a URL.
ChartArea | Gets the internal C1Chart control ChartArea object.
ChartGroups | Gets the internal C1Chart control ChartGroups object.
ChartLabels | Gets the internal C1Chart control ChartLabels object.
ChartStyle | Gets the internal C1Chart control ChartStyle object.
Footer | Gets the internal C1Chart control footer object.
ForeColor | Gets or sets the control's fore color.
Header | Gets the internal C1Chart control header object.
ImageAreas | Gets the MapAreaCollection object used to generate client side image maps.
ImageFormat | Gets or sets the Image format to be used for the client side image.
ImageIdGeneration | Gets or sets the level of uniqueness of the ID transfer object.
ImageQuality | Specifies the image quality created when the ImageFormat is set to jpeg
ImageRenderMethod | Indicates the method by which the HTML image tag source URL is rendered
ImageTransferMethod | Indicates the method by which image data is transferred to the source page.
ImageUri | Specifies a path for various render methods.
Legend | Gets the internal C1Chart control Legend object.
SlidingExpiration | Gets or sets the interval between the time the image was last accessed and the time when the image expires from the session, cache, or file object.
UseAntiAlias | Gets or sets whether the chart is rendered using anti-aliasing methods.

Methods

Dispose | Prepares the control for garbage collection.
LoadChartFromFile | Loads the chart properties and data from the specified file.
LoadChartFromString | Loads the chart properties and data from the specified string.
Reset | Clears the internal C1Chart or C1Chart3D of all data and settings.
SaveChartToFile | Saves the internal C1Chart properties and data to the specified file.
SaveChartToString | Saves the internal C1Chart properties and data to the specified string.

Events

Click

Occurs when the chart image is clicked.


AreaShapeEnum Enumeration

AreaShapeEnum Enumeration

Syntax

[VB]

Public Enum AreaShapeEnum

[C#]

public enum AreaShapeEnum

[Delphi]

type AreaShapeEnum = (Circle, Polygon, Rectangle)

Remarks

This enumeration applies to C1WebChart3D.

Use the members of this enumeration to set the value of the Shape property in the MapArea class.


ASP Page-based Rendering Tutorials

The ASPPage based tutorials show how you can replace the built-in HttpHandler with custom ASP pages, thereby gaining extra control over the chart rendering mechanism. This method allows you to customize, for example, the behavior of the client and server caches, and IIS logging.

Both tutorials use the following ASP page to replace the HttpHandler mechanism, and differ only in the way they store the chart data. The code below can handle both Session and Cache transfers. It performs the exact same functions as the built-in HttpHandler, and should be useful as a starting point for your custom pages.

· Visual Basic

· C#

· Delphi


ASP Page-based Rendering Tutorials - C#

C#

using System;

using System.Web;

using System.Web.SessionState;

namespace AspPageSample

{

public class StreamResponse : System.Web.UI.Page

{

private void Page_Load(object sender,

System.EventArgs e)

{

// determine how the image is

// transferred to this page

string ses = Request["SessionID"];

// non null if session transfer

string cac = Request["CacheID"];

// non null if cache transfer

string del = Request["Delete"];

// non null if delete request

bool doDelete = false;

// check the delete request status

if(del != null)

{

del = del.ToLower();

doDelete = (del == "t" || del == "true");

}

byte [] image = null;

string imgtype = string.Empty;

string img = string.Empty;

string hsh = string.Empty;

if (ses != null)

{

// get image info from Session object

img = ses + "_ImageBytes";

hsh = ses + "_Hash";

image = (byte[])Session[img];

imgtype = (string)Session[hsh];

if(doDelete)

{

Session.Remove(img);

Session.Remove(hsh);

}

}

else if (cac != null)

{

// get image info from Application cache

img = cac + "_ImageBytes";

hsh = cac + "_Hash";

image = (byte[])Cache[img];

imgtype = (string)Cache[hsh];

if (doDelete)

{

Cache.Remove(img);

Cache.Remove(hsh);

}

}

// return image to the client

if (image != null && imgtype != null)

{

int iext = imgtype.LastIndexOf('.')+1;

imgtype = "image/" +

imgtype.Substring(iext);

Response.Clear();

Response.Cache.SetExpires(DateTime.MinValue);

// clear client cache

Response.ContentType = imgtype;

Response.BinaryWrite(image);

Response.Flush();

}

}

}

}


ASP Page-based Rendering Tutorials - Delphi

Delphi

procedure StreamResponse.Page_Load(sender: System.Object; e: System.EventArgs);

var

hsh: string;

img: string;

imgtype: string;

image: array of System.Byte;

doDelete: Boolean;

del: string;

cac: string;

ses: string;

begin

ses := Request['SessionID'];

cac := Request['CacheID'];

del := Request['Delete'];

doDelete := False;

if (del <> nil) then

begin

del := del.ToLower;

doDelete := ((del = 't') or (del = 'true'));

end;

image := nil;

imgtype := Empty;

img := Empty;

hsh := Empty;

if (ses <> nil) then

begin

img := (ses + '_ImageBytes');

hsh := (ses + '_Hash');

image := (array of System.Byte(Session[img]));

imgtype := (string(Session[hsh]));

if doDelete then

begin

Session.Remove(img);

Session.Remove(hsh);

end;

end

else

if (cac <> nil) then

begin

img := (cac + '_ImageBytes');

hsh := (cac + '_Hash');

image := (array of System.Byte(Cache[img]));

imgtype := (string(Cache[hsh]));

if doDelete then

begin

Cache.Remove(img);

Cache.Remove(hsh);

end;

end;

if ((image <> nil) and (imgtype <> nil)) then

begin

imgtype := ('image/' + imgtype.Substring((imgtype.LastIndexOf('.') + 1)));

Response.Clear;

Response.Cache.SetExpires(DateTime.MinValue);

Response.ContentType := imgtype;

Response.BinaryWrite(image);

Response.Flush;

end;

end;


ASP Page-based Rendering Tutorials - Visual Basic

Visual Basic

Imports System

Imports System.Web

Imports System.Web.SessionState

Namespace AspPageSample

_

Public Class StreamResponse

Inherits System.Web.UI.Page

Private Sub Page_Load(sender As Object, e As System.EventArgs)

' Determine how the image is transferred to this page

Dim ses As String = Request("SessionID") ' non null if session transfer

Dim cac As String = Request("CacheID") ' non null if cache transfer

Dim del As String = Request("Delete") ' non null if delete request

Dim doDelete As Boolean = False

' Check the delete request status

If Not (del Is Nothing) Then

del = del.ToLower()

doDelete = del = "t" Or del = "true"

End If

Dim image As Byte() = Nothing

Dim imgtype As String = String.Empty

Dim img As String = String.Empty

Dim hsh As String = String.Empty

If Not (ses Is Nothing) Then

' extract the image info from the session object

img = ses + "_ImageBytes"

hsh = ses + "_Hash"

image = CType(Session(img), Byte())

imgtype = CStr(Session(hsh))

If doDelete Then

Session.Remove(img)

Session.Remove(hsh)

End If

Else

If Not (cac Is Nothing) Then

' extract the image info from the Application cache

img = cac + "_ImageBytes"

hsh = cac + "_Hash"

image = CType(Cache(img), Byte())

imgtype = CStr(Cache(hsh))

If doDelete Then

Cache.Remove(img)

Cache.Remove(hsh)

End If

End If

End If

If Not (image Is Nothing) And Not (imgtype Is Nothing) Then

' return the binary image to the client

imgtype = "image/" + imgtype.Substring((imgtype.LastIndexOf("."c) + 1))

Response.Clear()

Response.Cache.SetExpires(DateTime.MinValue) ' clear client cache

Response.ContentType = imgtype

Response.BinaryWrite(image)

Response.Flush()

End If

End Sub 'Page_Load

End Class 'StreamResponse

End Namespace 'AspPageSample


AssemblyFileVersionString Property (C1WebChart3D)

AssemblyFileVersionString Property (C1WebChart3D)

Gets the control’s AssemblyFileVersion as a string. The AssemblyFileVersion is also viewable from the properties dialog of the control assembly dll.

Syntax

[VB]

Public ReadOnly Property AssemblyFileVersionString As String

[C#]

public string AssemblyFileVersionString { get; }

[Delphi]

property AssemblyFileVersionString: string;

Remarks

This property applies to C1WebChart3D.

The AssemblyFileVersion is different from the AssemblyVersion. The AssemblyFileVersion is viewable from the properties dialog of the control assembly dll. The AssemblyVersion is also listed in the properties dialog, but only in the “other version information” section. When viewing the Global Assembly Cache (GAC) in Windows Explorer, the AssemblyVersion is shown as a standard column.

The AssemblyFileVersion will always change with each separate release of the Chart control, including internal changes. The AssemblyVersion will only change when the object model has been changed.

See Also

C1WebChart3D Class


AssemblyVersionString Property (C1WebChart3D)

AssemblyVersionString Property (C1WebChart3D)

Gets the control’s AssemblyVersion as a string. The AssemblyVersion is also viewable from the properties dialog of the control assembly dll, but only in the “other version information” section.

Syntax

[VB]

Public ReadOnly Property AssemblyVersionString As String

[C#]

public String AssemblyVersionString { get; }

[Delphi]

property AssemblyVersionString: string;

Remarks

This property applies to C1WebChart3D.

The AssemblyFileVersion is different from the AssemblyVersion. The AssemblyFileVersion is viewable from the properties dialog of the control assembly dll. The AssemblyVersion is also listed in the properties dialog, but only in the “other version information” section. When viewing the Global Assembly Cache (GAC) in Windows Explorer, the AssemblyVersion is shown as a standard column.

The AssemblyFileVersion will always change with each separate release of the Chart control, including internal changes. The AssemblyVersion will only change when the object model has been changed.

See Also

C1WebChart3D Class


Attributes Property (MapArea)

Attributes Property (MapArea)

Specifies a set of attributes to be added to the <AREA> tag.

Syntax

[VB]

Public Property Attributes As String

[C#]

public string Attributes { get; set; }

[Delphi]

property Attributes: string;

Remarks

This property applies to C1WebChart3D.

Each MapArea can have additional attributes set as appropriate for <AREA> tags. For more information on <AREA> tags see the Microsoft documentation.

Setting this property causes the specified string to appear as a set of attributes for the MapArea. Note that the attribute value is added to the <AREA> tag as a literal string, so any encoding necessary must be performed to the property value.

See Also

MapArea Class


BackColor Property (C1WebChart3D)

BackColor Property (C1WebChart3D)

Gets or sets the control back color.

Syntax

[VB]

Public Property BackColor As Color

[C#]

public Color BackColor { get; set; }

[Delphi]

property BackColor: Color;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


BackgroundImageUrl Property (C1WebChart3D)

BackgroundImageUrl Property (C1WebChart3D)

Gets or sets the location of the background image through a URL.

Syntax

[VB]

Public Property BackgroundImageUrl As String

[C#]

public string BackgroundImageUrl { get; set; }

[Delphi]

property BackgroundImageUrl: String;

Remarks

At present, only relative URLs are supported. Absolute URLs are currently not supported. The position of the image can be adjusted using the ChartStyle.ImageAlignment property.

See Also

C1WebChart3D Class


C1WebChart3D Class

Syntax

C1.Web.C1WebChart3D

All Members

Properties

Methods

Events


C1WebChart3D Enumeration Reference

AreaShapeEnum Enumeration

ImageIdGenerationEnum Enumeration

ImageRenderMethodEnum Enumeration

ImageTransferMethodEnum Enumeration


C1WebChart3D Reference

This reference section pertains only to ComponentOne WebChart for ASP.NET. All properties apply to C1WebChart3D.

C1WebChart3D Class

MapArea Class

MapAreaCollection Class

C1WebChart3D Enumeration Reference


C1WebChart Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product’s features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://helpcentral.componentone.com/ProductResources.aspx.


C1WebChart Task-Based Help

The task-based help assumes that you are familiar with programming in ASP.NET, have a basic knowledge of charts, and know how to use controls in general. By following the steps outlined in the help, you will be able to create projects demonstrating a variety of C1WebChart features, and get a good sense of what the C1WebChart can do.

Using ASP.NET

File-based Rendering Tutorials

HTTPHandler-based Rendering Tutorials

ASP Page-based Rendering Tutorials


ChangingChartStyles1 - C#

C#

C1Chart3D1.ChartGroups.ChartStyles[1].LineStyle.Pattern = LinePatternEnum.Dot;


ChangingChartStyles1 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups.ChartStyles[1].LineStyle.Pattern := LinePatternEnum.Dot;

end;


ChangingChartStyles1 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.ChartStyles(1).LineStyle.Pattern = LinePatternEnum.Dot


ChangingChartStyles2 - C#

C#

C1Chart3D1.ChartGroups.ChartStyles[2].SymbolStyle.Shape = SymbolShapeEnum.Circle;


ChangingChartStyles2 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups.ChartStyles[2].SymbolStyle.Shape :=
SymbolShapeEnum.Circle;

end;


ChangingChartStyles2 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.ChartStyles(2).SymbolStyle.Shape = SymbolShapeEnum.Circle


ChangingContourStyles1 - C#

C#

Chart3DContourStyle sty = C1Chart3D1.ChartGroups[0].Contour.Levels[2].Style;


ChangingContourStyles1 - Delphi

Delphi

var

sty: Chart3DContourStyle;

begin

sty := C1Chart3D1.ChartGroups[0].Contour.Levels[2].Style;

end;


ChangingContourStyles1 - Visual Basic

Visual Basic

Dim Style As Chart3DContourStyle

Style = C1Chart3D1.ChartGroups(0).Contour.Levels(2).Style


ChangingContourStyles2 - C#

C#

C1Chart3D1.ChartGroups[0].Contour.Levels[0].Style.FillColor = Color.Green;


ChangingContourStyles2 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].Contour.Levels[0].Style.FillColor := Color.Green;

end;


ChangingContourStyles2 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(0).Contour.Levels(0).Style.FillColor = Color.Green


ChangingContourStyles3 - C#

C#

C1Chart3D1.ChartGroups[0].Contour.Levels[1].Style.LineStyle.Color = Color.Green;


ChangingContourStyles3 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].Contour.Levels[1].Style.LineStyle.Color := Color.Green;

end;


ChangingContourStyles3 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(0).Contour.Levels(1).Style.LineStyle.Color = Color.Green


ChangingDataValues - C#

C#

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[1, 2] = 3.14159;


ChangingDataValues - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].ChartData.SetGrid[1, 2] := 3.14159;

end;


ChangingDataValues - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(0).ChartData.SetGrid(1, 2) = 3.14159


Chart 3D MSHelp Annoformat property - NumberFormatInfo class

AnnoFormat Property

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

NumberFormatInfo class

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for NumberFormatInfo class in Microsoft's Help search box.


Chart 3D MSHelp AnnoFormatString - Custom DateTime Format Strings

AnnoFormatString Property

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

Custom DateTime format strings

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for date and time format strings in Microsoft's Help search box.


Chart 3D MSHelp AnnoFormatString -Custom Numeric Format Strings

AnnoFormatString Property

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

Custom numeric format strings

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for numeric format strings in Microsoft's Help search box.


Chart 3D MSHelp DateTimeFormatInfo - DateTimeFormatInfo class

AnnoFormat Property

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

DateTimeFormatInfo class

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for DateTimeFormatInfo class in Microsoft's Help search box.


Chart 3D MSHelp FormatEnum - Date and Time Format Strings

FormatEnum

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

date and time format strings

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for date and time format strings in Microsoft's Help search box.


Chart 3D MSHelp FormatEnum - Standard Numeric Format Strings

FormatEnum

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

standard numeric format strings

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for standard numeric format strings in Microsoft's Help search box.


Chart 3D MSHelp TBH Tutorial 2 IHttpHandler - IHttpHandler Interface

IhttpHandler Interface

NOTE: If you have Visual Studio .NET 2002 you can click here to access this link:

IHttpHandler Help

If you have Visual Studio .NET 2003 Or higher you can access this link by searching for IhttpHandler Interface in Microsoft's Help search box.


Chart3DStylesCollection - C#

C#

private void c1Chart3D1_Click(object sender, System.EventArgs e)

{

foreach(Chart3DStyle sty in c1Chart3D1.ChartGroups.ChartStyles)

sty.SymbolStyle.Color = Color.White;

}


Chart3DStylesCollection - Delphi

Delphi

procedure C1Chart3D1_Click(sender: System.Object; e: System.EventArgs);

var

stys: Chart3DStylesCOllection;

sty: Chart3DStyle;

s: Integer;

begin

stys := C1Chart3D1.ChartGroups.ChartStyles;

for s := 0 to stys.Count -1 do

begin

sty := stys[s];

sty.SymbolStyle.Color := Color.White;

end;

end;


Chart3DStylesCollection - Visual Basic

Visual Basic

Private Sub C1Chart3D1_Click(ByVal sender As Object, _
ByVal e As System.EventArgs) Handles C1Chart3D1.Click

Dim Style As Chart3DStyle

For Each Style in Chart3D1.ChartGroups.ChartStyles

Style.SymbolStyle.Color = Color.White

Next Style

End Sub


Chart3DviewStateClass - C#

C#

// Save all info about view(rotation, scaling etc.)

Chart3DViewState vs = C1Chart3D1.ChartArea.View.Save();

// Restore saved view

C1Chart3D1.ChartArea.View.Restore(vs);


Chart3DviewStateClass - Delphi

Delphi

var

vs: Chart3DViewState;

begin

// Save all info about view(rotation, scaling etc.)

vs := C1Chart3D1.ChartArea.View.Save();

// Restore saved view

C1Chart3D1.ChartArea.View.Restore(vs);

end;


Chart3DviewStateClass - Visual Basic

Visual Basic

' Save all info about view(rotation, scaling etc.)

Dim vs As Chart3DViewState = C1Chart3D1.ChartArea.View.Save()

' Restore saved view

C1Chart3D1.ChartArea.View.Restore( vs);


ChartArea Property (C1WebChart3D)

ChartArea Property (C1WebChart3D)

Gets the internal C1Chart control ChartArea object.

Syntax

[VB]

Public ReadOnly Property ChartArea() As C1.Win.C1Chart3D.Chart3DArea

[C#]

public C1.Win.C1Chart3D.Chart3DArea ChartArea { get; }

[Delphi]

property ChartArea: C1.Win.C1Chart3D.Chart3DArea;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


ChartDataDirect - C#

C#

//Calculate array

Random rnd = new Random();

double[,] z = new double[21, 31];

for( int m = 0; m<31; m++)

for( int n = 0; n<21; n++)

{

if(m%2==0)

z[n,m]= m * 5 * rnd.NextDouble() + Math.Sqrt(2 * m * m * n);

else

z[n,m]= m * -5 * rnd.NextDouble() + Math.Sqrt(2 * m * n);

}

//create dataset and put it to the chart

Chart3DDataSetGrid gridset=new Chart3DDataSetGrid(0,0,1,1,z);

C1Chart3D1.ChartGroups[0].ChartData.Set = gridset;


ChartDataDirect - Delphi

Delphi

//Calculate array

var

gridset: Chart3DDataSetGrid;

z: array of array of double;

n: Integer;

m: Integer;

rnd: System.Random;

begin

rnd := System.Random.Create;

SetLength(z, 21, 31);

for m := 0 to 30 do

begin

for n := 0 to 20 do

if ((m mod 2) = 0) then

z[n,m] := m * 5 * rnd.NextDouble() + Math.Sqrt(2 * m * m * n)

else

z[n,m] := m * -5 * rnd.NextDouble() + Math.Sqrt(2 * m * m * n);

begin

end;

gridSet := Chart3DDataSetGrid.Create(0.0, 0.0, 1.0, 1.0, z);

C1Chart3D1.ChartGroups[0].ChartData.SetGrid := gridSet;

end;

end;


ChartDataDirect - Visual Basic

Visual Basic

'Calculate array

Dim Rnd As Random = New Random()

Dim m,n As Integer

Dim z(20,30) As Double

For m = 0 To 30

For n = 0 To 20

If m Mod 2 = 0 Then

Z(n, m) = m * 5 * Rnd.NextDouble() + Math.Sqrt(2 * m * m * n)

Else

Z(n, m) = m * -5 * Rnd.NextDouble() + Math.Sqrt(2 * m * n)

End If

Next n

Next m

'create dataset and put it to the chart

Dim gridset As Chart3DDataSetGrid

gridset=New Chart3DDataSetGrid( 0, 0, 1, 1, z)

C1Chart3D1.ChartGroups(0).ChartData.Set = gridset


ChartGroups Property (C1WebChart3D)

ChartGroups Property (C1WebChart3D)

Gets the internal C1Chart control ChartGroups object.

Syntax

[VB]

Public ReadOnly Property ChartGroups() As C1.Win.C1Chart3D.Chart3DGroups

[C#]

public C1.Win.C1Chart3D.Chart3DGroups ChartGroups { get; }

[Delphi]

property ChartGroups: C1.Win.C1Chart3D.Chart3DGroups;

Remarks

This property applies to C1WebChart3D.

Each ChartGroup contains information related to data values and related appearance.

See Also

C1WebChart3D Class


ChartGroupsUsingCode1 - C#

C#

C1Chart3D1.ChartGroups.ChartGroupsCollection[0];


ChartGroupsUsingCode1 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups.ChartGroupsCollection[0];

end;


ChartGroupsUsingCode1 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.ChartGroupsCollection(0)


ChartGroupsUsingCode2 - C#

C#

C1Chart3D1.ChartGroups.Group0;


ChartGroupsUsingCode2 - Delphi

Delphi

C1Chart3D1.ChartGroups.Group0;


ChartGroupsUsingCode2 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.Group0


ChartLabelsProgramming1 - C#

C#

C1Chart3D1.ChartLabels[0].Text = "This is the first label in the collection";


ChartLabelsProgramming1 - Delphi

Delphi

begin

C1Chart3D1.ChartLabels[0].Text := 'This is the first label in the collection';

end;


ChartLabelsProgramming1 - Visual Basic

Visual Basic

C1Chart3D1.ChartLabels(0).Text = "This is the first label in the collection"


ChartLabelsProgramming2 - C#

C#

Chart3DLabel label;

label = C1Chart3D1.ChartLabels.AddNewLabel();


ChartLabelsProgramming2 - Delphi

Delphi

var

label: Chart3DLabel;

begin

label := C1Chart3D1.ChartLabels.AddNewLabel();

end;


ChartLabelsProgramming2 - Visual Basic

Visual Basic

Dim label As Chart3DLabel

label = C1Chart3D1.ChartLabels.AddNewLabel()


ChartLabelsProgramming3 - C#

C#

C1Chart3D1.ChartLabels.Remove(label);


ChartLabelsProgramming3 - Delphi

Delphi

begin

C1Chart3D1.ChartLabels.Remove(label);

end;


ChartLabelsProgramming3 - Visual Basic

Visual Basic

C1Chart3D1.ChartLabels.Remove(label)


ChartLabels Property (C1WebChart3D)

ChartLabels Property (C1WebChart3D)

Gets the internal C1Chart control Labels object.

Syntax

[VB]

Public ReadOnly Property ChartLabels() As C1.Win.C1Chart3D.Chart3DLabels

[C#]

public C1.Win.C1Chart3D.Chart3DLabels ChartLabels { get; }

[Delphi]

property ChartLabels: C1.Win.C1Chart3D.Chart3DLabels;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


ChartLabelsUsingCode - C#

C#

C1.Win.Chart3D.Chart3DLabel lab = C1Chart3D1.ChartLabels[1];

lab.Text = "Here is my chart label";

lab.View3D = LabelView3DEnum.XY;

lab.IsConnect = True;


ChartLabelsUsingCode - Delphi

Delphi

var

lab: C1.Win.Chart3D.Chart3DLabel;

begin

lab := C1Chart3D1.ChartLabels[1];

lab.Text = 'Here is my chart label';

lab.View3D = LabelView3DEnum.XY;

lab.IsConnect = True;

end;


ChartLabelsUsingCode - Visual Basic

Visual Basic

With C1Chart3D1.ChartLabels(1)

.Text = "Here is my chart label"

.View3D = LabelView3DEnum.XY

.IsConnected = True

End With


ChartStyle Property (C1WebChart3D)

ChartStyle Property (C1WebChart3D)

Gets the internal C1Chart control ChartStyle object.

Syntax

[VB]

Public ReadOnly Property ChartStyle() As C1.Win.C1Chart3D.Style

[C#]

public C1.Win.C1Chart3D.Style: ChartStyle { get; }

[Delphi]

property ChartStyle: C1.Win.C1Chart3D.Style;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


ChartStyleUsingCode1 - C#

C#

C1Chart3D1.ChartGroups.ChartStyles[1].LineStyle.Pattern = LinePatternEnum.Dot;


ChartStyleUsingCode1 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups.ChartStyles[1].LineStyle.Pattern := LinePatternEnum.Dot;

end;


ChartStyleUsingCode1 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.ChartStyles(1).LineStyle.Pattern = LinePatternEnum.Dot


ChartStyleUsingCode2 - C#

C#

C1Chart3D1.ChartGroups.ChartStyles[2].SymbolStyle.Shape = SymbolShapeEnum.Circle;


ChartStyleUsingCode2 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups.ChartStyles[2].SymbolStyle.Shape :=
SymbolShapeEnum.Circle;

end;


ChartStyleUsingCode2 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups.ChartStyles(2).SymbolStyle.Shape = SymbolShapeEnum.Circle


Click Event (C1WebChart3D)

Click Event (C1WebChart3D)

Fires when the chart image is clicked.

Syntax

[VB]

Public Event Click As ImageClickEventHandler

[C#]

public event ImageClickEventHandler Click;

[Delphi]

property Click: ImageClickEventHandler;

Event Data

The event handler receives an argument of type ImageClickEventArgs containing coordinate data of the mouse click relative to the chart image. The sender object of the event is the instance of the C1WebChart3D.

This property applies to C1WebChart3D.

Remarks

When an event hander is attached, the chart is rendered as an input tag and image map generation is suppressed.

See Also

C1WebChart3D Class


Configuring the Chart

Once the chart is on the page, the next step is to use the built-in Wizard to customize its appearance. To do so, right-click the chart and select “Chart Wizard”. This will bring up the wizard so you can select the chart type you want, the number of series and their appearance, the axes, titles, and so on.

You can also use the property window to set properties such as the chart’s BackColor and ChartStyle.

The Wizard and property window are powerful enough to customize virtually every aspect of the chart without writing any code at all. You can even use the Wizard to populate the chart with data, but that is rarely practical except to play with ranges and number of points and get a feel for the final look of the data.

After the chart is configured, you can save it to a file. This is useful so you can reuse this layout later in other charts. To do so, right-click the chart and select “Save Chart”. To re-use the layout later, right-click another chart and select “Load Chart”. You can define as many of these chart layouts as you want, and use them as templates to achieve a consistent look for all charts throughout your applications. You can even load chart layouts at run time using the LoadChartFromFile method.

For more details on how to configure charts and use the Chart Wizard, see 3D Chart Basics, Note: C1Chart and C1Chart3D are the WinForms control used by C1WebChart and C1WebChart3D, respectively, to generate the charts.


ContourZoneProjection - C#

C#

C1Chart3D1.ChartArea.View.Ceiling.IsZoned = true;


ContourZoneProjection - Delphi

Delphi

begin

C1Chart3D1.ChartArea.View.Ceiling.IsZoned := True;

end;


ContourZoneProjection - Visual Basic

Visual Basic

C1Chart3D1.ChartArea.View.Ceiling.IsZoned = True


ConvertDataToPixel - C#

C#

int PixelX=0, PixelY=0;

C1Chart3D1.ChartGroups[0].ChartData.

DataCoordToCoord(5.1, 10.2, 8.4, ref PixelX, ref PixelY);

//PixelX and PixelY now contain the pixel coordinate value.


ConvertDataToPixel - Delphi

Delphi

var

PixelX, PixelY: Integer;

begin

C1Chart3D1.ChartGroups[0].ChartData.

DataCoordToCoord(5.1, 10.2, 8.4, PixelX, PixelY);

//PixelX and PixelY now contain the pixel coordinate value.

end;


ConvertDataToPixel - Visual Basic

Visual Basic

Dim PixelX, PixelY As Integer

C1Chart3D1.ChartGroups(0).ChartData. _
DataCoordToCoord(5.1, 10.2, 8.4, PixelX, PixelY)

'PixelX and PixelY now contain the pixel coordinate value.


ConvertPixelToData - C#

C#

double DataX=0, DataY=0, DataZ=0;

C1Chart3D1.ChartGroups[0].ChartData.

CoordToDataCoord(225, 92, ref DataX, ref DataY, ref DataZ);

//DataX, DataY and DataZ now contain the data coordinate value.


ConvertPixelToData - Delphi

Delphi

var

DataX, DataY, DataZ: Double;

begin

C1Chart3D1.ChartGroups[0].ChartData.

CoordToDataCoord(225, 92, DataX, DataY, DataZ);

//DataX, DataY and DataZ now contain the data coordinate value.

end;


ConvertPixelToData - Visual Basic

Visual Basic

Dim DataX As Double

Dim DataY As Double

Dim DataZ As Double

C1Chart3D1.ChartGroups(0).ChartData._
CoordToDataCoord(225, 92, DataX, DataY, DataZ)

'DataX, DataY and DataZ now contain the data coordinate value.


Creating4Dcharts - C#

C#

// 1 step

// Create dataset with sample data

Random rnd = new Random();

int i, j;

double[,] z = new double[21, 21];

for( i=0; i<z.GetLength(0); i++)

{

for( j=0; j<z.GetLength(1); j++)

{

z[ i, j] = 200 - (( i-10)*(i-10) + (j-10)*(j-10));

}

}

Chart3DDataSetGrid gridset=new Chart3DDataSetGrid(0,0,1,1,z);

C1Chart3D1.ChartGroups[0].ChartData.Set = gridset;

// 2 step

// Create 4-dimension values array and put it to the chart

double[,] contour = new double[21, 21];

for( i=0; i<contour.GetLength(0); i++)

{

for( j=0; j<contour.GetLength(1); j++)

{

contour[ i, j] = rnd.NextDouble();

}

}

C1Chart3D1.ChartGroups[0].ChartData.ContourData = contour;

// 3 step

// Set zoned chart

C1Chart3D1.ChartGroups[0].Contour.IsZoned = true;

C1Chart3D1.ChartGroups[0].Contour.NumLevels = 20;

C1Chart3D1.ChartGroups.ContourStyles.ColorSet = ColorSetEnum.RevRainbow;


Creating4Dcharts - Delphi

Delphi

var

rnd: System.Random;

i, j: Integer;

z: array of array of double;

contour: array of array of double;

gridset: Chart3DDataSetGrid;

begin

rnd := System.Random.Create;

SetLength(z, 21, 21);

// 1 step

// Change the dataset with sample data

for i := 0 to 20 do

begin

for j := 0 to 20 do

begin

z[i, j] := 200 - ((i-10)*(i-10) + (j-10)*(j-10));

end;

end;

gridset := Chart3DDataSetGrid.Create(0.0, 0.0, 1.0, 1.0, z);

C1Chart3D1.ChartGroups[0].ChartData.SetGrid := gridset;

// 2 step

// Create 4-dimension values array and put it to the chart

SetLength(contour, 21, 21);

for i := 0 to 20 do

begin

for j := 0 to 20 do

begin

contour[i,j] := rnd.NextDouble();

end;

end;

C1Chart3D1.ChartGroups[0].ChartData.ContourData := contour;

// 3 step

// Set zoned chart

C1Chart3D1.ChartGroups[0].Contour.IsZoned := True;

C1Chart3D1.ChartGroups[0].Contour.NumLevels := 20;

C1Chart3D1.ChartGroups.ContourStyles.ColorSet := ColorSetEnum.RevRainbow;

end;


Creating4Dcharts - Visual Basic

Visual Basic

'1 step

'Create dataset with sample data

Dim rnd As Random = New Random()

Dim i, j As Integer

Dim z(20, 20) As Double

For i = 0 To 20

For j = 0 To 20

z(i,j) = 200 - ((i - 10) * (i - 10) + (j - 10) * (j - 10))

Next j

Next i

Dim gridset As Chart3DDataSetGrid = New Chart3DDataSetGrid(0, 0, 1, 1, z)

C1Chart3D1.ChartGroups(0).ChartData.Set = gridset

'2 step

'Create 4-dimension values array and put it to the chart

Dim contour(20, 20) As Double

For i = 0 To 20

For j = 0 To 20

contour(i, j) = rnd.NextDouble()

Next j

Next i

C1Chart3D1.ChartGroups(0).ChartData.ContourData = contour

'3 step

'Set zoned chart

C1Chart3D1.ChartGroups(0).Contour.IsZoned = True

C1Chart3D1.ChartGroups(0).Contour.NumLevels = 20

C1Chart3D1.ChartGroups.ContourStyles.ColorSet = ColorSetEnum.RevRainbow


Creating an ASP.NET Project

1. From the File menu in .NET, select New and click Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic Projects or Visual C# Projects, and select ASP.NET Web Application from the list of Templates in the right pane.

3. Enter a URL for your application in the Location field and click OK.

Note: The Web server must have IIS version 5 or later and the .NET Framework installed on it. If you have IIS on your computer, you can specify http://localhost for the server.

A new Web Forms project is created at the root of the Web server you specified. In addition, a new Web Forms page called WebForm1.aspx is displayed in the Web Forms Designer in Design view.

4. Add a C1WebChart control to WebForm1.aspx.

After a chart has been configured at design-time in the ASP.Net IDE, and upon compilation, C1WebChart creates an <IMG> tag in the resulting HTML page. The <IMG> tag will be created where the C1WebChart control is placed on the main .aspx page. The source attribute of this <IMG> tag is where the chart image data gets referenced or placed. How this attribute gets filled with data is the concern of the ImageRenderMethod property, and how the actual data actually gets streamed back to the source attribute is the concern of the ImageTransferMethod property. For more information, see ImageRenderMethod Property (C1WebChart3D) and ImageTransferMethod Property (C1WebChart3D).

The below table lists what the effect of an intersection between a transfer method and render method produces:


DataPoints - C#

C#

C1Chart3D1.ChartGroups[0].ChartData.SetPoint[1,2] = new Chart3DPoint(1,1,1);


DataPoints - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[0].ChartData.SetPoint[1,2] :=

Chart3DPoint.Create(1, 1, 1);

end;


DataPoints - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(0).ChartData.SetPoint(1,2) = New Chart3DPoint(1,1,1)


DefaultStyle - C#

C#

C1Chart3D1.ChartLabels.DefaultStyle.BackColor = Drawing.Color.Gray;


DefaultStyle - Delphi

Delphi

begin

C1Chart3D1.ChartLabels.DefaultStyle.BackColor := Drawing.Color.Gray;

end;


DefaultStyle - Visual Basic

Visual Basic

C1Chart3D1.ChartLabels.DefaultStyle.BackColor = Drawing.Color.Gray


DefiningChartLabel - C#

C#

Chart3DLabel lab = C1Chart3D1.ChartLabels[1];

lab.Text = "Here is my chart label";

lab.View3D = LabelView3DEnum.YZ;

lab.Connected = true;


DefiningChartLabel - Delphi

Delphi

var

lab: Chart3DLabel;

begin

lab := C1Chart3D1.ChartLabels[1];

lab.Text := 'Here is my chart label';

lab.View3D := LabelView3DEnum.YZ;

lab.Connected := True;

end;


DefiningChartLabel - Visual Basic

Visual Basic

With C1Chart3D1.ChartLabels(1)

.Text = "Here is my chart label"

.View3D = LabelView3DEnum.YZ

.Connected = True

End With


DetermineCoordValues - C#

C#

int PixelX=0, PixelY=0;

C1Chart3D1.ChartGroups[0].ChartData.DataIndexToCoord(2,1,ref PixelX,ref PixelY);

//PixelX and PixelY now contain the pixel coordinate value.


DetermineCoordValues - Delphi

Delphi

var

PixelX, PixelY: Integer

begin

C1Chart3D1.ChartGroups[0].ChartData.DataIndexToCoord(2, 1, PixelX, PixelY);

//PixelX and PixelY now contain the pixel coordinate value.

end;


DetermineCoordValues - Visual Basic

Visual Basic

Dim PixelX, PixelY As Integer

C1Chart3D1.ChartGroups(0).ChartData.DataIndexToCoord(2, 1, PixelX, PixelY)

'PixelX and PixelY now contain the pixel coordinate value.


Dispose Method (C1WebChart3D)

Dispose Method (C1WebChart3D)

Prepares the control for garbage collection by freeing disposable objects.

Syntax

[VB]

Public Sub Dispose()

[C#]

public void Dispose();

[Delphi]

procedure Dispose;

Remarks

This property applies to C1WebChart3D.

The control should not be referenced after calling Dispose().

See Also

C1WebChart3D Class


Distribution1 - C#

C#

Chart3DContourLevelsCollection levs;

levs = C1Chart3D1.ChartGroups[0].Contour.Levels;

levs.Add(1000);

levs.Add(2500);

levs.Add(4200);


Distribution1 - Delphi

Delphi

Chart3DContourLevelsCollection levs;

levs := C1Chart3D1.ChartGroups[0].Contour.Levels;

levs.Add(1000);

levs.Add(2500);

levs.Add(4200);


Distribution1 - Visual Basic

Visual Basic

With C1Chart3D1.ChartGroups(0).Contour.Levels

.Add( 1000)

.Add( 2500)

.Add( 4200)

End With


Distribution2 - C#

C#

C1Chart3D1.ChartGroups[1].Contour.Levels.Remove( 1000);


Distribution2 - Delphi

Delphi

begin

C1Chart3D1.ChartGroups[1].Contour.Levels.Remove(1000);

end;


Distribution2 - Visual Basic

Visual Basic

C1Chart3D1.ChartGroups(1).Contour.Levels.Remove( 1000)


Events

Click Event (C1WebChart3D)


File-based Rendering Tutorials

The File-based tutorials transfer charts to the client using temporary files. Repeated requests for the same chart use the same file, reducing load on the server. New requests create new files as needed. Files are not cleaned up automatically. This method is indicated when charts are complex (expensive to generate) or when you expect a large number of requests for a relatively small number of different charts.


Footer Property (C1WebChart3D)

Footer Property (C1WebChart3D)

Gets the internal C1Chart control Title object object.

Syntax

[VB]

Public ReadOnly Property Footer As C1.Win.C1Chart3D.Title

[C#]

public C1.Win.C1Chart3D.Title Footer { get; }

[Delphi]

property Footer: C1.Win.C1Chart3D.Title;

Remarks

This property applies to C1WebChart3D.

The Title class for the 2D (C1.Win.C1Chart.Title) and 3D (C1.Win.C1Chart3D.Title) chart contain similar properties.

See Also

C1WebChart3D Class


ForeColor Property (C1WebChart3D)

ForeColor Property (C1WebChart3D)

Gets or sets the control fore color.

Syntax

[VB]

Public Property ForeColor As Color

[C#]

public Color ForeColor { get; set; }

[Delphi]

property ForeColor: Color;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


GetByName Method (MapAreaCollection)

GetByName Method (MapAreaCollection)

Gets the MapArea with the specified name from the collection.

Syntax

[VB]

Public Function GetByName(name As String) As MapArea

[C#]

public MapArea GetByName(string name);

[Delphi]

function GetByName(name: String): MapArea;

Remarks

This property applies to C1WebChart3D.

Return Value

This method returns the MapArea from the collection with the specified name. If such a MapArea is not found, the method returns null.

See Also

MapAreaCollection Class


GetHtmlMap Method (MapAreaCollection)

GetHtmlMap Method (MapAreaCollection)

Gets the content of an Html map tag appropriate for the C1WebChart3D image as a string.

Syntax

[VB]

Public Function GetHtmlMap() As String

Public Function GetHtmlMap(name As String) As String

[C#]

public string GetHtmlMap();

public string GetHtmlMap(string name);

[Delphi]

function GetHtmlMap: MapArea;

function GetHtmlMap(name: string): string;

Remarks

This property applies to C1WebChart3D.

Return Value

This method returns a string with map tag content appropriate for the C1WebChart3D image. If a string is passed, the string will be used as the name of the map element. Note that the content of the string does not include the <map> and </map> tag and end tag marker.

See Also

MapAreaCollection Class


Getting Started With C1WebChart

Adding C1WebChart to the Visual Studio Toolbox

Adding Charts to your Web Applications

Configuring the Chart

Adding User Interaction With ImageAreas

Adding Data to the Chart


HandlingMissingData - C#

C#

Chart3DDataSetGrid gridset =
C1Chart3D1.ChartGroups[0].ChartData.SetGrid;

gridset.Hole = 999.1f;

gridset[0,2] = 999.1f;


HandlingMissingData - Delphi

Delphi

var

gridset: Chart3DDataSetGrid;

begin

gridset := C1Chart3D1.ChartGroups[0].ChartData.SetGrid;

gridset.Hole := 999.1;

gridset[0,2] := 999.1;

end;


HandlingMissingData - Visual Basic

Visual Basic

Dim gridset As Chart3DDataSetGrid

gridset = C1Chart3D1.ChartGroups(0).ChartData.SetGrid

With gridset

.Hole = 999.1

.Item(0, 2) = 999.1

End With


HeaderFooterUsingCode - C#

C#

C1Chart3D1.Header.Text = "Sample Header Text";

C1Chart3D1.Header.Compass = C1.Win.C1ChartBase.CompassEnum.East;

C1Chart3D1.Header.Location = new Point(20, -1);

C1Chart3D1.Footer.Text = "Sample Footer Text";

C1Chart3D1.Footer.Compass = C1.Win.C1ChartBase.CompassEnum.South;

C1Chart3D1.Footer.Location = new Point((C1Chart3D1.Size.Width - 120), -1);


HeaderFooterUsingCode - Delphi

Delphi

begin

C1Chart3D1.Header.Text := 'Sample Header Text';

C1Chart3D1.Header.Compass := C1.Win.C1ChartBase.CompassEnum.East;

C1Chart3D1.Header.Location := Point.Create(20, -1);

C1Chart3D1.Footer.Text := 'Sample Footer Text';

C1Chart3D1.Footer.Compass := C1.Win.C1ChartBase.CompassEnum.South;

C1Chart3D1.Footer.Location := Point.Create((C1Chart3D1.Size.Width - 120), -1);

end;


HeaderFooterUsingCode - Visual Basic

Visual Basic

C1Chart3D1.Header.Text = "Sample Header Text"

C1Chart3D1.Header.Compass = C1.Win.C1ChartBase.CompassEnum.East

C1Chart3D1.Header.Location = New Point(20, -1)

C1Chart3D1.Footer.Text = "Sample Footer Text"

C1Chart3D1.Footer.Compass = C1.Win.C1ChartBase.CompassEnum.South

C1Chart3D1.Footer.Location = New Point((C1Chart3D1.Size.Width - 120), -1)


Header Property (C1WebChart3D)

Header Property (C1WebChart3D)

Gets the internal C1Chart control Title object.

Syntax

[VB]

Public ReadOnly Property Header As C1.Win.C1Chart3D.Title

[C#]

public C1.Win.C1Chart3D.Title Header { get; }

[Delphi]

property Header: C1.Win.C1Chart3D.Title;

Remarks

This property applies to C1WebChart3D.

The Title class for the 2D (C1.Win.C1Chart.Title) and 3D (C1.Win.C1Chart3D.Title) chart contain similar properties.

See Also

C1WebChart3D Class


How C1WebChart Handles Images

When you add a chart to a web page, C1WebChart inserts an image in the HTML stream. This image is represented by an <img> tag and contains a reference to a second URL that provides the actual image. C1WebChart is responsible for creating this URL and providing its content. The diagram below illustrates this process:

The diagram shows a browser on the left, displaying an ASP page. To display this page, the browser requests the page content from the server (myWebPage.aspx) and receives an HTML stream. The HTML contains a chart, represented by an <img> tag. The source for this tag is a second URL (c1ChartImage.aspx) that the server translates into an image stream that is rendered in the browser.

The source attribute for the tag can be a temporary image file, an HttpHandler, or a second .aspx page. This is determined by the value of the ImageRenderMethod property.

The source attribute also contains parameters that specify where the chart data is stored so the URL can create the chart image. This data can be stored in a temporary file, in the Session variable, or in the Cache. This is determined by the value of the ImageTransferMethod property.

By default, C1WebChart stores the chart data in the Session variable. In some cases, you may prefer to use the Cache or temporary files instead. Each option has its advantages and drawbacks, depending on how the server is set up and on the nature of the application. For details on the operation of the Session and Cache objects, please refer to the .NET documentation.

The ImageRenderMethod property has settings that range from completely automatic (HttpHandler, File) to manual (Manual). These settings are described below, and demonstrated in the tutorials that follow.

The best combination for the ImageRenderMethod and ImageTransferMethod properties will depend on the complexity and variety of the charts being delivered, the expected site traffic, and server configuration. This is not a trivial task, but the good news is you can test different configurations easily, just by changing those two properties.


Href Property (MapArea)

Href Property (MapArea)

Specifies an Href for the MapArea.

Syntax

[VB]

Public Property Href As String

[C#]

public string Href { get; set; }

[Delphi]

property Href: string;

Remarks

This property applies to C1WebChart3D.

Each MapArea in the resulting ImageMap can link to another URL. If this property is set to a valid address, clicking on the MapArea will link users to the specified page.

Note

The Href is automatically HTML encoded as appropriate (unless it is a JavaScript url).

See Also

MapArea Class


HTTPHandler-based Rendering Tutorials

The HttpHandler based tutorials transfer charts to the client using C1WebChart’s built-in http handler. This method doesn’t use temporary image files, reducing the load on the server’s file system. This method is indicated when charts are simple (easy to generate) or when you expect requests for a large number of different charts.

Tutorial 2 - Using HTTPHandler with a Session-based Transfer Method and a Unique Image ID

Tutorial 3 - Using HTTPHandler with a Cache-based Transfer Method and a Unique Image ID

Tutorial 4 - Using the HTTPHandler with a File-based Transfer Method and a Unique Image ID

Tutorial 5 - Using the HTTPHandler with a Session-based Transfer Method and a per-Application Image ID

Tutorial 6 - Using the HTTPHandler with a Cache-based Transfer Method and a per-Application Image ID

Tutorial 7 - Using the HTTPHandler with a File-based Transfer Method and a per-Application Image ID


ImageAreas Property (C1WebChart3D)

ImageAreas Property (C1WebChart3D)

Gets the MapAreaCollection object used to generate client side image maps.

Syntax

[VB]

Public ReadOnly Property ImageAreas As MapAreaCollection

[C#]

public MapAreaCollection ImageAreas { get; }

[Delphi]

property ImageAreas: MapAreaCollection;

Remarks

This property applies to C1WebChart3D.

The ImageAreas property exposes a collection of MapArea objects. This collection defines the properties of the generated image map to be used for end-user interaction. Each MapArea object in turn specifies the behaviors of the image map.

See Also

C1WebChart3D Class


ImageFormat Property (C1WebChart3D)

ImageFormat Property (C1WebChart3D)

Gets or sets the Image format to be used for the client side image.

Syntax

[VB]

Public Property ImageFormat As System.Drawing.Imaging.ImageFormat

[C#]

public System.Drawing.Imaging.ImageFormat ImageFormat { get; set; }

[Delphi]

property ImageFormat: System.Drawing.Imaging.ImageFormat;

Remarks

This property applies to C1WebChart3D.

Note that while this property accepts a .Net ImageFormat value, the only image formats available to the C1WebChart3D programmer are .gif, .jpeg, and .png.

See Also

C1WebChart3D Class


ImageIdGenerationEnum Enumeration

ImageIdGenerationEnum Enumeration

Syntax

[VB]

Public Enum ImageIdGenerationEnum

[C#]

public enum ImageIdGenerationEnum

[Delphi]

type ImageIdGenerationEnum = (Application, Unique);

Remarks

This enumeration applies to C1WebChart3D.

Use the members of this enumeration to set the value of the ImageIDGeneration property in the C1WebChart3D class.


ImageIdGeneration Property (C1WebChart3D)

ImageIdGeneration Property (C1WebChart3D)

Gets or sets the level of uniqueness of the ID transfer object.

Syntax

[VB]

Public Property ImageIDGeneration As ImageIdGenerationEnum

[C#]

public ImageIdGenerationEnum ImageIDGeneration { get; set; }

[Delphi]

property ImageIDGeneration: ImageIdGenerationEnum;

Remarks

This property applies to C1WebChart3D.

When chart data is transferred from one page to another, IDs are created for the Session or Cache variables or for a filename in order to render a chart image. This property determines whether a unique ID is created each time the chart image is accessed (i.e. when the chart image is accessed by a single user), or if the same ID is to be used for the duration of the application life (i.e. when the identical chart image is accessed by multiple users or accessed repeatedly by a single user).

Note

The ImageIdGeneration property has no effect with the ImageRenderMethodEnum.File or ImageRenderMethodEnum.BinaryWrite. For more information, see ImageRenderMethod Property.

See Also

C1WebChart3D Class


ImageQuality Property (C1WebChart3D)

ImageQuality Property (C1WebChart3D)

Specifies the image quality created when the ImageFormat is set to jpeg.

Syntax

[VB]

Public Property ImageQuality As Integer

[C#]

public int ImageQuality { get; set; }

[Delphi]

property ImageQuality: Integer;

Remarks

This property applies to C1WebChart3D.

This property accepts an integer from 0 to 100 which specifies the quality of the jpeg image file.

See Also

C1WebChart3D Class


ImageRenderMethodEnum Enumeration

ImageRenderMethodEnum Enumeration

Syntax

[VB]

Public Enum ImageRenderMethodEnum

[C#]

public enum ImageRenderMethodEnum

[Delphi]

type ImageRenderMethodEnum = (ASPPage, BinaryWrite, File, HTTPHandler, Manual);

Remarks

This enumeration applies to C1WebChart3D.

Use the members of this enumeration to set the value of the ImageRenderMethod property in the C1WebChart3D class.

Member Name | Description
ASPPage | C1WebChart3D will utilize a secondary asp(x) page to stream the image data back to an imbedded <IMG> tag on the primary page. If this option is selected, the chart will generate an appropriately placed <IMG> tag within the page that hosts the chart. The positioning of the <IMG> tag will be in the same location as shown on the Visual Studio design page, and <IMG> tag src attribute will reference the specified asp(x) page. The path to the page will be that specified by the ImageUri property.
BinaryWrite | C1WebChart3D will perform a binary write to its host page response stream directly, without transferring data to another page. However, the binary image data will be the only data returned.
File | C1WebChart3D will generate image files that can be referenced directly by an <IMG> tag. The <IMG> tag will be generated and will reference the file specified by the ImageUri property. If the ImageUri property is not specified, then a name for the temporary file will be generated and the URL will reference the temporary file.
HTTPHandler | C1WebChart3D supports the IHTTPHandler interface and will generate an appropriately placed <IMG> tag within the page that references its internal HTTPHandler to stream the image to the client.
Manual | C1WebChart3D does nothing to render itself at runtime. All operations required for generating and placing the chart image within the page are the responsibility of the programmer.


ImageRenderMethod Property

The ImageRenderMethod Property is the main property in C1WebChart which determines how the <IMG> tag and its arguments get created, as well as who renders or streams the chart image back to the client (source attribute of the <IMG> tag). The different render methods vary from the more automated methods (HTTPHandler, File) to the less automated (Manual).

In addition, for each of the render methods except Binary Write, the ImageUri property specifies a path necessary for correct image creation. Since this property has different functions for different methods, the details of render methods and the function of the ImageUri property for that method are listed below.

ImageRenderMethodEnum.File

This setting creates temporary image files on the server. It is recommended in situations where you expect a lot of requests for a relatively small number of charts, or in situations where charts are complex and expensive to generate and do not change often.

By default, C1WebChart creates image file names automatically, based on a hash code obtained from the chart data itself. If the specified file is found on the server, the chart doesn’t have to be re-created, which makes this mechanism efficient. However, if the chart data changes often, a large number of image files will be created on the server. Depending upon other property settings the may or may not delete these files automatically.

Because it relies on the file system, this method enables the implementation of security settings to control which usernames may render and view the chart.

The ImageUri property specifies the path and filename of the image file to be generated. If you leave ImageUri empty, these names are automatically manufactured by the C1WebChart control. For both C1WebChart and C1WebChart3D, the default temporary file directory is “C1WebChartTemp”.

The following example shows the type of <img> tag that this method creates:

<img id='c1wc' src='C1WebChartTemp/c1c_105….png' />

The ‘src’ attribute specifies the location of the temporary image file on the server, and the file name contains a hash code that is unique for the chart data. Since this method doesn’t require transferring image data, the ImageTransferMethod property is not relevant.

Note: This render method not only allows the use of file security, it also requires it. The directory where the image files are created must have write permission for all usernames running the application.

ImageRenderMethodEnum.HTTPHandler

This is the default setting. It provides a fast and efficient way to render the chart images. Instead of image files, C1WebChart uses its internal HttpHandler to resolve the image URL and stream the image data directly to the client.

This method requires that you to add an appropriate HttpHandler entry to the Web.Config file in the project. C1WebChart makes this process easy by providing an option in its context menu that copies the required entry to the clipboard. These are the steps required to add the HttpHandler entry to your Web.Config file:

· Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”

· In the Solution Explorer, double-click the “Web.Config” file

· Place the cursor below <system.web> and select “Paste”. The Web.Config file should look like this:

<?xml version="1.0" encoding="utf-8" ?>

<configuration>

<system.web>

<httpHandlers>

<add verb="*" path="c1chartimage.aspx"

type="C1.Web.C1WebChart.ImageHttpHandler,C1.Web.C1WebChart"/>

</httpHandlers>

…

If your Web.Config file already contains other HttpHandlers, select the non-tagged option instead (“HttpHandler string to clipboard”) or edit the xml file directly. For example multiple HttpHandlers are used when you include both C1WebChart and C1WebChart3D in the same application.

Note that the xml entry contains a value that reflects the setting of the ImageUri property. If you change the value of that property and forget to update the Web.Config file, ASP.NET will at best, throw an exception, and at worst use the wrong HttpHandler. Fortunately, the error message points clearly to the HttpHandler. The easiest way to fix this problem is to repeat the steps above whenever you change the ImageUri property.

The ImageUri property allows you to specify a virtual directory and file name. The virtual directory is used to store chart data when the ImageTransferMethod is set to File. The file name identifies which HttpHandler to use and should match the corresponding entry in the Web.Config file. If you leave ImageUri empty, these names are automatically manufactured by the C1WebChart and C1WebChart3D controls and are c1webchartimage.aspx and c1webchart3dimage.asp, respectively.

The following example shows the type of <img> tag that this method creates:

<img id='c1wc' src='c1webchartimage.aspx?SessionID=87987…' />

The ‘src’ attribute specifies the filename associated with the HttpHandler and also a parameter that describes where the handler can find the data it needs in order to create the chart. In this case the parameter is a SessionID, but could also be a CacheID or temporary file, depending on the setting of the ImageTransferMethod property.

ImageRenderMethodEnum.ASPPage

This setting requires you to create a second ASP page that is responsible streaming the chart data back to the first page through a call to the Response.Write method.

This method is useful for gaining greater control of the binary response stream returning the chart image to the page. By authoring a separate ASP page for the response, it is possible to customize management of the response, including the client cache, server cache, and IIS logging. Other positive attributes are that the <img> tag is automatically generated and properly placed, image maps are available, and data transfer to the second ASP page is managed automatically.

The ImageUri property specifies the path to the second ASP page.

The following example shows the type of <img> tag that this method creates:

<img id='c1wc' src='mySecondPage.aspx?CacheID=87987…' />

The ‘src’ attribute specifies the location of the second ASP page and also a parameter that describes where the page can find the information required to create the chart. In this case the parameter is a CacheID, but could also be a SessionID entry or temporary file, depending on the setting of the ImageTransferMethod property.

ImageRenderMethodEnum.Manual

This setting requires you to render the image and send it to the page. Because you have to do most of the work yourself, you get the most flexibility.

C1WebChart still stores the image data in the Session, Cache, or temporary file, depending on the setting of the ImageTransferMethod property. This information can be used to create the chart image that will be returned to the client.

ImageRenderMethodEnum.BinaryWrite

This setting requires you to create a second ASP page that is responsible streaming the raw chart data (a byte array).

This method is useful when it is not necessary to include the chart in the context of an ASP page at design time, and sufficient information can be passed to the control to render the proper image through other means. For example, you may want to load the chart layout from a file and configure only a few display elements.

The main difference between this method and the others is that here the chart creation parameters are embedded in the <img> tag itself, rather than stored in the Session, Cache, or temporary files. This process is more streamlined than all others and reduces server resource requirements, since no data transfer from one page to another is required. One drawback is that image maps and the resulting end-user interaction are not available.

The following example shows the type of <img> tag that this method creates:

<img id='c1wc' src='renderSalesChart.aspx?Color=Red&Type=XYPlot' />

Notice that all the information required to create the chart is available in the ‘src’ attribute itself. No information is stored in the cache, session, or temporary files, so the ImageTransferMethod property is not relevant.


ImageRenderMethod Property (C1WebChart3D)

ImageRenderMethod Property (C1WebChart3D)

Indicates the method by which the HTML image tag source URL is rendered.

Syntax

[VB]

Public Property ImageRenderMethod As ImageRenderMethodEnum

[C#]

public ImageRenderMethodEnum ImageRenderMethod { get; set; }

[Delphi]

property ImageRenderMethod: ImageRenderMethodEnum;

Remarks

This property applies to C1WebChart3D.

For more information, see the ImageRenderMethod Property topic.

See Also

C1WebChart3D Class


ImageTransferMethod

The ImageTransferMethod property lists how the chart data is transferred to the source attribute of the <IMG> tag. ImageTransferEnum.Session places the chart data (byte array) into a Session variable, while ImageTransferEnum.Cache places the chart data into a Cache variable. ImageTransferEnum.File writes chart data to a temporary file.

This property only applies to the Manual, HTTPHandler, and ASP Page rendering methods. The below table lists what the effect of an intersection between a transfer method and render method produces:


ImageTransferMethodEnum Enumeration

ImageTransferMethodEnum Enumeration

Syntax

[VB]

Public Enum ImageTransferMethodEnum

[C#]

public enum ImageTransferMethodEnum

[Delphi]

type ImageTransferMethodEnum = (Cache, File, None, Session);

Remarks

This enumeration applies to C1WebChart3D.

Use the members of this enumeration to set the value of the ImageTransferMethod property in the C1WebChart3D class.


ImageTransferMethod Property (C1WebChart3D)

ImageTransferMethod Property (C1WebChart3D)

Indicates the method by which image data is transferred to the source page.

Syntax

[VB]

Public Property ImageTransferMethod As ImageTransferMethodEnum

[C#]

public ImageTransferMethodEnum ImageTransferMethod { get; set; }

[Delphi]

property ImageTransferMethod: ImageTransferMethodEnum;

Remarks

This property applies to C1WebChart3D.

When a secondary URL is used to stream image data back to an <IMG> tag on the primary page, it is necessary to transfer the chart data through either a session object, cache object, or a file. For more information see the ImageTransferMethod Property topic.

See Also

C1WebChart3D Class


ImageUri Property (C1WebChart3D)

ImageUri Property (C1WebChart3D)

Specifies a path for various render methods.

Syntax

[VB]

Public Property ImageUri As String

[C#]

public string ImageUri { get; set; }

[Delphi]

property ImageUri: string;

Remarks

This property applies to C1WebChart3D.

This property specifies a pathname. It has different applications for different properties and settings. For more information, see ImageRenderMethod Property. Also refer to File-based Rendering Tutorials, HTTPHandler-based Rendering Tutorials, and ASP Page-based Rendering Tutorials.

See Also

C1WebChart3D Class


IrregularGridData - C#

C#

Zval = C1Chart3D1.ChartGroups(0).ChartData.SetGrid[2, 0];


IrregularGridData - Delphi

Delphi

begin

Zval := C1Chart3D1.ChartGroups(0).ChartData.SetGrid[2, 0];

end;


IrregularGridData - Visual Basic

Visual Basic

Zval = C1Chart3D1.ChartGroups(0).ChartData.SetGrid(2, 0)


Item Property (MapAreaCollection)

Item Property (MapAreaCollection)

Gets the specified MapArea of the collection by index.

Syntax

[VB]

Public ReadOnly Property Item(index As Integer) As MapArea

[C#]

public MapArea this[int index] { get; }

[Delphi]

property Item(index: Integer): MapArea;

Remarks

This property applies to C1WebChart3D.

See Also

MapAreaCollection Class


Legend Property (C1WebChart3D)

Legend Property (C1WebChart3D)

Gets the internal C1Chart control Legend object.

Syntax

[VB]

Public ReadOnly Property Legend() As C1.Win.C1Chart3D.Chart3DLegend

[C#]

public C1.Win.C1Chart3D.Chart3DLegend Legend { get; }

[Delphi]

property Legend: C1.Win.C1Chart3D.Chart3DLegend;

Remarks

This property applies to C1WebChart3D.

See Also

C1WebChart3D Class


LegendUsingCode1 - C#

C#

C1Chart3D1.Legend.Compass = CompassEnum.East;

C1Chart3D1.Legend.Style.Border.BorderStyle = BorderStyleEnum.Solid;

C1Chart3D1.Legend.Style.Border.Thickness = 3;

C1Chart3D1.Legend.Style.Border.Color = Color.Black;

C1Chart3D1.Legend.Style.BackColor = Color.Gray;

C1Chart3D1.Legend.Text = "Legend Text";


LegendUsingCode1 - Delphi

Delphi

begin

C1Chart3D1.Legend.Compass := CompassEnum.East;

C1Chart3D1.Legend.Style.Border.BorderStyle := BorderStyleEnum.Solid;

C1Chart3D1.Legend.Style.Border.Thickness := 3;

C1Chart3D1.Legend.Style.Border.Color := Color.Black;

C1Chart3D1.Legend.Style.BackColor := Color.Gray;

C1Chart3D1.Legend.Text := 'Legend Text';

end;


LegendUsingCode1 - Visual Basic

Visual Basic

C1Chart3D1.Legend.Compass = CompassEnum.East

C1Chart3D1.Legend.Style.Border.BorderStyle = BorderStyleEnum.Solid

C1Chart3D1.Legend.Style.Border.Thickness = 3

C1Chart3D1.Legend.Style.Border.Color = Color.Black

C1Chart3D1.Legend.Style.BackColor = Color.Gray

C1Chart3D1.Legend.Text = "Legend Text"


LegendUsingCode2 - C#

C#

C1.Win.C1Chart3D.Legend legend = C1Chart3D1.Legend;

C1.Win.C1Chart3D.Style style = legend.Style;

C1.Win.C1Chart3D.Border border = style.Border;

legend.Compass = CompassEnum.East;

border.BorderStyle = BorderStyleEnum.Solid;

border.Thickness = 3;

border.Color = Color.Black;

style.BackColor = Color.Grey;

legend.Text = "Legend Text";


LegendUsingCode2 - Delphi

Delphi

C1.Win.C1Chart3D.Legend legend = C1Chart3D1.Legend;

C1.Win.C1Chart3D.Style style = legend.Style;

C1.Win.C1Chart3D.Border border = style.Border;

legend.Compass = CompassEnum.East;

border.BorderStyle = BorderStyleEnum.Solid;

border.Thickness = 3;

border.Color = Color.Black;

style.BackColor = Color.Grey;

legend.Text = "Legend Text";


LegendUsingCode2 - Visual Basic

Visual Basic

With C1Chart3D1.Legend

.Compass = CompassEnum.East

With .Style

With.Border

.BorderStyle = BorderStyleEnum.Solid

.Thickness = 3

.Color = Color.Black

End With

.BackColor = Color.Gray

End With

.Text = "Legend Text"

End With


LoadChartFromFile Method (C1WebChart3D)

LoadChartFromFile Method (C1WebChart3D)

Loads the chart properties and data from the specified file.

Syntax

[VB]

Public Sub LoadChartFromFile(filename As String)

[C#]

public void LoadChartFromFile(string filename);

[Delphi]

procedure LoadChartFromFile(filename: string);

Remarks

This property applies to C1WebChart3D.

Note that only the C1.Win.C1Chart properties and data are loaded by this method. C1WebChart3D properties are not loaded by this method.

See Also

C1WebChart3D Class


LoadChartFromString Method (C1WebChart3D)

LoadChartFromString Method (C1WebChart3D)

Loads the chart properties and data from the specified string.

Syntax

[VB]

Public Sub LoadChartFromString(strChart As String)

[C#]

public void LoadChartFromString(string strChart);

[Delphi]

procedure LoadChartFromString(strChart: string);

Remarks

This property applies to C1WebChart3D.

Note that only the C1.Win.C1Chart and C1.Win.C1Chart3D properties and data are loaded by this method. C1WebChart3D properties are not loaded by this method.

See Also

C1WebChart3D Class


LoadData - C#

C#

//Load the data from a file MMF95.DAT

C1Chart3D1.ChartGroups[0].ChartData.LoadDataFromFile("mmf95.dat")


LoadData - Delphi

Delphi

// Load the data from a file MMF95.DAT

begin

C1Chart3D1.ChartGroups[0].ChartData.LoadDataFromFile('mmf95.dat');

end;


LoadData - Visual Basic

Visual Basic

'Load the data from a file MMF95.DAT

C1Chart3D1.ChartGroups(0).ChartData.LoadDataFromFile("mmf95.dat")


MapArea All Members

MapArea Properties

Attributes | Specifies a set of attributes to be added to the <AREA> tag.
Href | Specifies an Href for the MapArea.
Shape | Gets or sets a shape for the MapArea.
Tooltip | Specifies a tooltip for the MapArea.


MapArea Class

Syntax

MapArea


MapAreaCollection All Members

MapAreaCollection Properties

Item

Gets the specified element of the MapArea collection.

MapAreaCollection Methods

Add | Adds the specified MapArea to the collection.
GetByName | Gets the MapArea with the specified name from the collection.
GetHtmlMap | Gets html map tag content as a string.


MapAreaCollection Class

Syntax

MapAreaCollection


MapAreaCollection Methods

Add Method (MapAreaCollection)

GetByName Method (MapAreaCollection)

GetHtmlMap Method (MapAreaCollection)


MapAreaCollection Properties

Item Property (MapAreaCollection)


MapArea Properties

Attributes Property (MapArea)

Href Property (MapArea)

Shape Property (MapArea)

Tooltip Property (MapArea)


MapArea Properties and Keywords

Each MapArea object contains the following properties that define how the image map will respond to end-user interaction.

Attributes | Specifies additional attributes for the <area> tag in the image map.
Href | Specifies the URL to link when the corresponding chart object is clicked.
Shape | Gets or sets a shape for the MapArea.
Tooltip | Specifies the text to show when mouse pointer is over the element.

If none of these properties are set, then the MapArea will be excluded from the resulting image map.

The following example creates a new area and sets its Tooltip and an Href property, turning the area into a hyperlink:

map.Tooltip = "Go to C1 home page";

map.HRef = "http://componentone.com";

You can also use the Attributes property to attach JavaScript event handler to areas:

map.Attributes = "onclick=window.open('url.com')";

In fact, the Attributes property can be used to add any attributes to the map <area> of a chart element, including an ID, TITLE, TARGET or anything else you wish. The enter string specified by the Attributes property is embedded within the <area> tag for the chart element.

If all of the ImageAreas elements are empty, then at runtime, the ImageAreas collection will appear empty, i.e. – the Count will be zero. However, build in map areas can still be accessed and automatically added to the collection by retrieving them by name. For example, to retrieve the header element,

MapArea map = C1WebChart1.ImageAreas.GetByName("Header");

map.Attributes = "onclick=window.open('url.com')";


Methods

Dispose Method (C1WebChart3D)

LoadChartFromFile Method (C1WebChart3D)

LoadChartFromString Method (C1WebChart3D)

Reset Method (C1WebChart3D)

SaveChartToFile Method (C1WebChart3D)

SaveChartToString Method (C1WebChart3D)


Namespace1 - C#

C#

C1.Win.C1Chart3D.C1Chart3D chart;


Namespace1 - Delphi

Delphi

chart: C1.Win.C1Chart3D.C1Chart3D;


Namespace1 - Visual Basic

Visual Basic

Dim chart As C1.Win.C1Chart3D.C1Chart3D


Namespace2 - C#

C#

using MyChart = C1.Win.C1Chart3D;

MyChart chart;


Namespace2 - Delphi

Delphi

Var

chart: MyChart;

begin

uses MyChart := C1.Win.C1Chart3D;

end;


Namespace2 - Visual Basic

Visual Basic

Imports MyChart = C1.Win.C1Chart3D
Dim chart As MyChart


Namespace3 - C#

C#

using C1.Win.C1Chart3D;


Namespace3 - Delphi

Delphi

uses C1.Win.C1Chart3D;


Namespace3 - Visual Basic

Visual Basic

Imports C1.Win.C1Chart3D


PickingDataPoints - C#

C#

int Row=0, Column=0;

C1Chart3D1.ChartGroups[0].ChartData.

CoordToDataIndex(225, 92, ref Column, ref Row);

//CoordToDataIndex returns the row and column of the closest data point.


PickingDataPoints - Delphi

Delphi

var

Row, Column: Integer;

begin

C1Chart3D1.ChartGroups[0].ChartData.CoordToDataIndex(225, 92, Column, Row);

//CoordToDataIndex returns the row and column of the closest data point.

end;


PickingDataPoints - Visual Basic

Visual Basic

Dim Row, Column As Integer

C1Chart3D1.ChartGroups(0).ChartData.CoordToDataIndex( 225, 92, Column, Row)

'CoordToDataIndex returns the row and column of the closest data point.


PointSeriesCollection1 - C#

C#

Chart3DDataSetPoint pointset = new Chart3DDataSetPoint();

int len =21;

Chart3DPoint[] points1 = new Chart3DPoint[len];

Chart3DPoint[] points2 = new Chart3DPoint[len];

double c, s;

for( int i=0; i<len; i++)

{

c = Math.Cos( i * Math.PI*2 / len);

s = Math.Sin( i * Math.PI*2 / len);

points1[i]=new Chart3DPoint(s, c, 0);

points2[i]=new Chart3DPoint(s, 0, c);

}

pointset.AddSeries( points1);

pointset.AddSeries( points2);

// transfer dataset to the chart and select scatter

C1Chart3D1.ChartGroups[0].ChartData.Set = pointset;

C1Chart3D1.ChartGroups[0].ChartType = Chart3DTypeEnum.Scatter;


PointSeriesCollection1 - Delphi

Delphi

var

i: Integer;

s: Double;

c: Double;

points2: array of Chart3DPoint;

points1: array of Chart3DPoint;

len: Integer;

pointset: Chart3DDataSetPoint;

begin

pointset.Create;

len := 21;

SetLen(points1, len);

SetLen(points2, len);

for i := 0 to len – 1 do

begin

c := Math.Cos((i * (Math.PI * (2 / len))));

s := Math.Sin((i * (Math.PI * (2 / len))));

points1[i] := Chart3DPoint.Create(s, c, 0);

points2[i] := Chart3DPoint.Create(s, 0, c);

end;

pointset.AddSeries(points1);

pointset.AddSeries(points2);

// transfer dataset to the chart and select scatter

C1Chart3D1.ChartGroups[0].ChartData.Set := pointset;

C1Chart3D1.ChartGroups[0].ChartType := Chart3DTypeEnum.Scatter;

end;


PointSeriesCollection1 - Visual Basic

Visual Basic

Dim pointset As Chart3DDataSetPoint

pointset = new Chart3DDataSetPoint()

Dim len As Integer = 20

Dim i As Integer

Dim points1(len) As Chart3DPoint

Dim points2(len) As Chart3DPoint

Dim c, s As Double

For i = 0 To 20

c = Math.Cos(i * Math.PI * 2 / len)

s = Math.Sin(i * Math.PI * 2 / len)

points1(i) = New Chart3DPoint(s, c, 0)

points2(i) = New Chart3DPoint(s, 0, c)

Next

pointset.AddSeries( points1)

pointset.AddSeries( points2)

'transfer dataset to the chart and select

scatterC1Chart3D1.ChartGroups(0).ChartData.Set = pointset

C1Chart3D1.ChartGroups(0).ChartType = Chart3DTypeEnum.Scatter


PointSeriesCollection2 - C#

C#

Chart3DPoint[] pts = new Chart3DPoint[2];

pts[0] = new Chart3DPoint( 0, 0, -1);

pts[1] = new Chart3DPoint( 0, 0, 1);

pointset.SeriesCollection[0].Points = pts;


PointSeriesCollection2 - Delphi

Delphi

var

pts: array of Chart3DPoint;

begin

SetLen(pts, 2);

pts[0] := Chart3DPoint.Create(0, 0, -1);

pts[1] := Chart3DPoint.Create(0, 0, 1);

pointset.SeriesCollection[0].Points := pts;

end;


PointSeriesCollection2 - Visual Basic

Visual Basic

Dim pts(1) As Chart3DPoint

pts(0) = New Chart3DPoint( 0, 0, -1)

pts(1) = New Chart3DPoint( 0, 0, 1)

pointset.SeriesCollection(0).Points = pts


ProgrammingConsiderations1 - C#

C#

C1.Win.C1Chart3D.ChartGroups cgs = C1Chart3D1.ChartGroups;

C1Chart3D1.ChartArea.Axes["X"].AnnoMethod = AnnotationMethodEnum.DataLabels;

cgs.Add(0, "Row 1");

cgs.Add(1, "Row 2");

cgs.Add(2, "Row 3");


ProgrammingConsiderations1 - Delphi

Delphi

var

cgs: C1.Win.C1Chart3D.ChartGroups cgs;

begin

C1Chart3D1.ChartArea.Axes["X"].AnnoMethod := AnnotationMethodEnum.DataLabels;

cgs := C1Chart3D1.ChartGroups;

cgs.Add(0,"Row 1");

cgs.Add(1,"Row 2");

cgs.Add(2,"Row 3");

end;


ProgrammingConsiderations1 - Visual Basic

Visual Basic

With C1Chart3D1

'assume three rows in chart

.ChartArea.Axes("X").AnnoMethod = AnnotationMethodEnum.DataLabels

With .ChartGroups.RowLabels

.Add(0, "Row 1")

.Add(1, "Row 2")

.Add(2, "Row 3")

End With

End With


ProgrammingConsiderations2 - C#

C#

C1.Win.C1Chart3D.Chart3DAxis axis = C1Chart3D1.ChartArea.Axes["X"];

C1.Win.C1Chart3D.Chart3DAxisLabelsCollection valueLabels = axis.ValueLabels;

axis.AnnoMethod = AnnotationMethodEnum.ValueLabels;

valueLabels.Add(10#, "Label 1");

valueLabels.Add(20#, "Label 2");

valueLabels.Add(30#, "Label 3");


ProgrammingConsiderations2 - Delphi

Delphi

var

axis: C1.Win.C1Chart3D.Chart3DAxis;

valueLabels: C1.Win.C1Chart3D.Chart3DAxisLabelsCollection;

begin

axis := C1Chart3D1.ChartArea.Axes["X"];

axis.AnnoMethod := AnnotationMethodEnum.ValueLabels;

valueLabels := axis.ValueLabels;

valueLabels.Add(10#, "Label 1");

valueLabels.Add(20#, "Label 2");

valueLabels.Add(30#, "Label 3");

end;


ProgrammingConsiderations2 - Visual Basic

Visual Basic

With C1Chart3D1.ChartArea.Axes("X")

.AnnoMethod = AnnotationMethodEnum.ValueLabels

With .ValueLabels

.Add(10#, "Label 1")

.Add(20#, "Label 2")

.Add(30#, "Label 3")

End With

End With


Properties

AbsoluteExpiration Property (C1WebChart3D)

AssemblyFileVersionString Property (C1WebChart3D)

AssemblyVersionString Property (C1WebChart3D)

BackColor Property (C1WebChart3D)

BackgroundImageUrl Property (C1WebChart3D)

ChartArea Property (C1WebChart3D)

ChartGroups Property (C1WebChart3D)

ChartLabels Property (C1WebChart3D)

ChartStyle Property (C1WebChart3D)

Footer Property (C1WebChart3D)

ForeColor Property (C1WebChart3D)

Header Property (C1WebChart3D)

ImageAreas Property (C1WebChart3D)

ImageFormat Property (C1WebChart3D)

ImageIdGeneration Property (C1WebChart3D)

ImageQuality Property (C1WebChart3D)

ImageRenderMethod Property (C1WebChart3D)

ImageTransferMethod Property (C1WebChart3D)

ImageUri Property (C1WebChart3D)

Legend Property (C1WebChart3D)

SlidingExpiration Property (C1WebChart3D)

UseAntiAlias Property (C1WebChart3D)


Reset Method (C1WebChart3D)

Reset Method (C1WebChart3D)

Clears the internal C1Chart of all data and settings.

Syntax

[VB]

Public Sub Reset ()

[C#]

public void Reset ();

[Delphi]

procedure Reset;

Remarks

This property applies to C1WebChart3D.

Note that only the C1.Win.C1Chart and C1.Win.C1Chart3D data and properties are cleared by this method. C1WebChart3D properties are not modified. The unmodified properties are the properties listed in this section.

See Also

C1WebChart3D Class


SaveChartToFile Method (C1WebChart3D)

SaveChartToFile Method (C1WebChart3D)

Saves the chart properties and data to the specified file.

Syntax

[VB]

Public Sub SaveChartToFile(filename As String)

[C#]

public void SaveChartToFile(string filename);

[Delphi]

procedure SaveChartToFile(filename: string);

Remarks

This property applies to C1WebChart3D.

Note that only the C1.Win.C1Chart properties and data are saved by this method. C1WebChart3D properties are not saved by this method.

See Also

C1WebChart3D Class


SaveChartToString Method (C1WebChart3D)

SaveChartToString Method (C1WebChart3D)

Saves the chart properties and data to the specified string.

Syntax

[VB]

Public Function SaveChartToString as String

[C#]

public string SaveChartToString;

[Delphi]

procedure SaveChartToString:string;

Remarks

This property applies to C1WebChart3D.

Note that only the C1.Win.C1Chart properties and data are saved by this method. C1WebChart3D properties are not saved by this method.

See Also

C1WebChart3D Class


Shape Property (MapArea)

Shape Property (MapArea)

Gets or sets a shape for the MapArea.

Syntax

[VB]

Public Property Shape() As C1WebChart3D.AreaShapeEnum

[C#]

public C1WebChart3D.AreaShapeEnum Shape { get; set; }

[Delphi]

property Shape: C1WebChart3D.AreaShapeEnum;

Remarks

This property applies to C1WebChart3D.

See Also

MapArea Class


SlidingExpiration Property (C1WebChart3D)

SlidingExpiration Property (C1WebChart3D)

Gets or sets the interval between the time the image was last accessed and the time when the image expires from the session, cache, or file object.

Syntax

[VB]

Public Property SlidingExpiration As TimeSpan

[C#]

public TimeSpan SlidingExpiration { get; set; }

[Delphi]

property SlidingExpiration: TimeSpan;

Remarks

This property applies to C1WebChart3D.

If this value is the equivalent of 5 minutes, the image expires and is removed from the transfer object 5 minutes after it was last accessed.

See Also

C1WebChart3D Class


Special Keywords

You can embed special keywords in the MapArea properties to access chart data such as the coordinates of a data point. The chart below lists the keywords available:

Keyword | Chart Element | Chart Type | Description
#TEXT | All | 2D, 3D | Text property value of chart element.
#XVAL | ChartData, ChartLabel | 2D, 3D | X data coordinate.
#YVAL | ChartData, ChartLabel | 2D, 3D | Y data coordinate.
#Y1VAL | ChartData | 2D only | Y1 data coordinate.
#Y2VAL | ChartData | 2D only | Y2 data coordinate.
#Y3VAL | ChartData | 2D only | Y3 data coordinate.
#ISERIES | ChartData, ChartLabel | 2D only | Data series index.
#IPOINT | ChartData, ChartLabel | 2D only | Data point index.
#ZVAL | ChartData, ChartLabel | 3D only | Z data coordinate.
#IROW | ChartData, ChartLabel | 3D only | Data row index.
#ICOL | ChartData, ChartLabel | 3D only | Data column index.

The keywords are case-sensitive and should be placed in curly brackets. You may include a colon and a .NET format string after the keyword. For example:

map.Tooltip = "X={#XVAL}, Y={#YVAL:c}";


The ImageAreas Property

The ImageAreas property is a collection of MapArea objects. Each MapArea object has properties that specify a tooltip to be displayed when the user moves the mouse over the area, and an action to be performed when the area is clicked.

The ImageAreas property has a set of built-in areas, created automatically by the control:

· ChartArea, PlotArea

· AxisX, AxisY, AxisY2

· ChartData (one <area> tag per data point or series)

· ChartLabel (one <area> tag per label)

· Header, Footer

· Legend, LegendItem (one <area> tag per item)

You can add your own MapArea objects using the collection’s Add method. When you create new MapArea objects, specify their shape (circle, rectangle or polygon) and the coordinates of the area to be created. You can do this at design time, using the collection editor, or using code. For example:

MapArea a = new MapArea();

a.Shape = AreaShapeEnum.Rectangle;

a.Coords = new int[] { 169,225,175,240 };

a.Tooltip = "My Custom Area";

_c1wc.ImageAreas.Add(a);

The coordinates are specified as an array of integers. This array corresponds to the ‘coords’ attribute of the <area> tag. The meaning of the array elements depends on the shape of the area:

Shape | Coords | Description
Circle | "x1,y1,r" | x1,y2 are the coordinates of the center of the circle, and r is the radius of the circle.
Polygon | "x1,y1,x2,y2...xn,yn" | Each x,y pair contains the coordinates of one vertex of the polygon.
Rectangle | "x1,y1,x2,y2" | x1,y1 are the coordinates of the upper-left corner of the rectangle and x2,y2 are the coordinates of the lower-right coordinates of the rectangle.

You can obtain coordinate values for the various chart elements using methods and properties exposed by C1WebChart.


Tooltip Property (MapArea)

Tooltip Property (MapArea)

Specifies a tooltip for the MapArea.

Syntax

[VB]

Public Property Tooltip As String

[C#]

public string Tooltip { get; set; }

[Delphi]

property Tooltip: string;

Remarks

This property applies to C1WebChart3D.

Each MapArea can have a tooltip string specified. The tooltip appears when the end-user scrolls over the appointed MapArea. The string is automatically HTML encoded as appropriate and appears as the value of the <AREA> tag Title attribute. There are special entries for Tooltip entries that will be translated by the chart.

Keyword | Chart element | Note | Description
#TEXT | All |  | Represents text property value of chart element.
#XVAL | ChartData, ChartLabel |  | Represents X data coordinate.
#YVAL | ChartData, ChartLabel |  | Represents Y data coordinate.
#Y1VAL | ChartData | 2D only | Represents Y1 data coordinate.
#Y2VAL | ChartData | 2D only | Represents Y2 data coordinate.
#Y3VAL | ChartData | 2D only | Represents Y3 data coordinate.
#ISERIES | ChartData, ChartLabel, LegendItem | 2D only | Represents data series index.
#IPOINT | ChartData, ChartLabel | 2D only | Represents data point index.
#ZVAL | ChartData, ChartLabel | 3D only | Represents Z data coordinate.
#IROW | ChartData, ChartLabel | 3D only | Represents data row index.
#ICOL | ChartData, ChartLabel | 3D only | Represents data column index.

The keywords should be placed in braces with optional formatting. Formatting rules are same as for .Net framework string.Format() method.

For example:

map.Tooltip = "X={#XVAL}, Y={#YVAL}";

map.Tooltip = "{#XVAL:d} {#YVAL:c}";

During image map generation special keywords will be replaced by corresponding values with the specified formatting.

See Also

MapArea Class


Tutorial 1 - Using a File-based Rendering Method

Tutorial 1 – Using a File-based Rendering Method

1. Place a WebChart control on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to ImageRenderMethodEnum.File.

4. Ensure the ImageUri property is blank.

Run the program and notice the following:

The image tag created should look similar to the following:

<img id=_c1wc
src=C1WebChartTemp/c1c_105_f1_d814d8cf.png>

The “C1WebChartTemp” directory is always assumed if a virtual path is not specified. File security settings must allow writing here for the anonymous web user.

Because the ImageUri property is blank, the control manufactures a name for the temporary file. The manufactured name is a hash code of the chart properties, and is virtually unique for each different chart.


Tutorial 2 - Using HTTPHandler with a Session-based Transfer Method and a Unique Image ID

Tutorial 2 – Using HTTPHandler with a Session-based Transfer Method and a Unique Image ID

1. Place a C1WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “Session”.

5. Set the ImageIDGeneration property to “Unique”.

6. Set the ImageUri property to an empty string.

7. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”,
In the Solution Explorer, double-click the “Web.Config” file,
Place the cursor below <system.web> and select “Paste”.

The last step configures the application to enable the C1WebChart’s built-in HttpHandler. The Web.Config file in your project should contain this entry:

<configuration>

<system.web>

<httpHandlers>

<add verb="*" path="c1webchartimage.aspx"

type="C1.Web.C1WebChart.ImageHttpHandler,C1.Web.C1WebChart"/>

</httpHandlers>

</system.web>

<configuration>

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc src='c1webchartimage.aspx?SessionID=91…93&Delete=T'/>

Because the ImageIDGeneration property is set to “Unique”, the “SessionID” attribute is unique for each rendering of the chart. It provides access to the following Session variables:

91…93_ImageBytes (image)

91…93_Hash (hash code and image type)

The “Delete=T” attribute causes the session variables to be deleted after the data is received by the HTTPHandler. This attribute is always invoked for Unique IDs.

The “httpHandler” entry in the Web.Config file contains the page alias for the class within C1WebChart that handles the http request. In this case, the alias it set to the default value “c1webchartimage.aspx”. For more details on this, see IHttpHandler Help in the .NET documentation.


Tutorial 3 - Using HTTPHandler with a Cache-based Transfer Method and a Unique Image ID

Tutorial 3 – Using HTTPHandler with a Cache-based Transfer Method and a Unique Image ID

1. Place a C1WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “Cache”.

5. Set the ImageIDGeneration property to “Unique”.

6. Set the ImageUri property to an empty string.

7. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”
In the Solution Explorer, double-click the “Web.Config” file
Place the cursor below <system.web> and select “Paste”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc src='c1webchartimage.aspx?CacheID=91…93&Delete=T'/>

Because the ImageIDGeneration property is set to “Unique”, the “CacheID” attribute is unique for each rendering of the chart. It provides access to the following Cache entries:

91…93_ImageBytes (image)

91…93_Hash (hash code and image type)

The “Delete=T” attribute causes the cache entries to be deleted after the data is received by the HTTPHandler. This attribute is always invoked for Unique IDs.


Tutorial 4 - Using the HTTPHandler with a File-based Transfer Method and a Unique Image ID

Tutorial 4 – Using the HTTPHandler with a File-based Transfer Method and a Unique Image ID

1. Place a C1WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “File”.

5. Set the ImageIDGeneration property to “Unique”.

6. Set the ImageUri property a viable folder on the server. To use the C1WebChart’s sample folder, for example, use:

/C1WebChartApps/Sample/c1webchartimage.aspx

7. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”
In the Solution Explorer, double-click the “Web.Config” file
Place the cursor below <system.web> and select “Paste”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc

src='c1webchartimage.aspx?FileID=/C1WebChartApps/Sample/91…93.png&Delete=T'/>

Because the ImageIDGeneration property is set to “Unique”, the FileID is unique for each rendering of the chart. It contains the virtual path to the temporary file used for the transfer. The virtual path consists of the virtual directory specified by the ImageUri property and a file name manufactured from the image type and the unique ID string. The file part of the ImageUri property is used to specify the HTTPHandler page.

If the ImageUri property is blank, default values are used.

The “Delete=T” attribute causes the temporary file to be deleted after the data is received by the HTTPHandler. This attribute is always invoked for Unique IDs.


Tutorial 5 - Using the HTTPHandler with a Session-based Transfer Method and a per-Application Image ID

Tutorial 5 – Using the HTTPHandler with a Session-based Transfer Method and a per-Application Image ID

1. Place a C1WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “Session”.

5. Set the ImageIDGeneration property to “Application”.

6. Set the ImageUri property to an empty string.

7. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”
In the Solution Explorer, double-click the “Web.Config” file
Place the cursor below <system.web> and select “Paste”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc

src='c1webchartimage.aspx?SessionID=WebForm1.aspx_C1WebChart1_9F0D3D0E'/>

The “SessionID” attribute is common for each rendering of the chart. This allows existing images to be reused if no changes occur. Since the session object is distinct for each browser session, data is secure for each client. The “SessionID” attribute provides access to the following Session variables:

WebForm1…9F0D3D0E_ImageBytes (image)

WebForm1…9F0D3D0E_Hash (hash code and image type)

In this case, the _Hash variable contains the following string:

"c1c_104_f1_c69d1f91.png"

This string is uniquely generated from the contents of the chart properties. Each time C1WebChart renders itself, it checks the value of the current hash with the existing hash in the Session object. If there has been no change, then the chart image need not be recreated. This behavior is built into the internal HTTPHandler in C1WebChart to help reduce server load.

The Session object variables names do not change from one render to the next (only the values change), so it is not necessary to delete the session variables with each rendering.


Tutorial 6 - Using the HTTPHandler with a Cache-based Transfer Method and a per-Application Image ID

Tutorial 6 – Using the HTTPHandler with a Cache-based Transfer Method and a per-Application Image ID

1. Place a C1WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “Cache”.

5. Set the ImageIDGeneration property to “Application”.

6. Set the ImageUri property to an empty string.

7. Set the Page.ID property

8. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”
In the Solution Explorer, double-click the “Web.Config” file
Place the cursor below <system.web> and select “Paste”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc

src='c1webchartimage.aspx?SessionID=WebForm1.aspx_C1WebChart1_9F0D3D0E'/>

The “SessionID” attribute is common for each rendering of the chart. This allows existing images to be reused if no changes occur. Since the session object is distinct for each browser session, data is secure for each client. The “SessionID” attribute provides access to the following Session variables:

WebForm1…9F0D3D0E_ImageBytes (image)

WebForm1…9F0D3D0E_Hash (hash code and image type)

In this case, the _Hash variable contains the following string:

"c1c_104_f1_c69d1f91.png"

This string is uniquely generated from the contents of the chart properties. Each time C1WebChart renders itself, it checks the value of the current hash with the existing hash in the Session object. If there has been no change, then the chart image need not be recreated. This behavior is built into the internal HTTPHandler in C1WebChart to help reduce server load.

The Session object variables names do not change from one render to the next (only the values change), so it is not necessary to delete the session variables with each rendering.


Tutorial 7 - Using the HTTPHandler with a File-based Transfer Method and a per-Application Image ID

Tutorial 7 – Using the HTTPHandler with a File-based Transfer Method and a per-Application Image ID

1. Place a C1WebChart control on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “HttpHandler”.

4. Set the ImageTransferMethod property to “File”.

5. Set the ImageIDGeneration property to “Application”.

6. Set the ImageUri property a viable folder on the server. To use the C1WebChart’s sample folder, for example, use:

/C1WebChartApps/Sample/c1webchartimage.aspx

7. Right-click the C1WebChart control and select “HttpHandler string to clipboard (tagged)”
In the Solution Explorer, double-click the “Web.Config” file
Place the cursor below <system.web> and select “Paste”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc

rc='c1webchartimage.aspx?FileID=C1WebChartTemp/WebForm1.aspx_C1WebChart1.png'/>

Because the ImageIDGeneration property is set to “Application”, the FileID is common for each rendering of the chart and contains a virtual path to the temporary file used for the transfer. The virtual path consists of the virtual directory specified by the ImageUri property, and the file manufactured from the image type and the ID string. The file part of the ImageUri property is used to specify the HttpHandler page (it must match the “httpHandler” entry in the Web.Config file).

Image files created in this manner are set to expire based upon Absolute and Sliding expiration. The files are actually deleted during the next render, or by rendering of other C1WebChart files in the same directory.


Tutorial 8 - Using an ASP Page-based Rendering Method with a Session-based Transfer Method

Tutorial 8 – Using an ASP Page-based Rendering Method with a Session-based Transfer Method

1. Place a WebChart on a form.

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “ASPPage”.

4. Set the ImageTransferMethod property to “Session”.

5. Set the ImageIDGeneration property to “Unique”.

6. Set the ImageUri to the above ASP Page ( “StreamResponse.aspx”).

(ImageUri = C:\…StreamResponse.aspx).

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc src='StreamResponse.aspx?SessionID=3b…a5&Delete=T'/>

Because the ImageIDGeneration property is set to “Unique”, the SessionID is unique for each rendering of the chart.

The Session object variables are:

3b…a5_ImageBytes (image)

3b…a5_Hash (hash code and image type)

The “Delete=T” attribute means the ASP Page is expected to remove the session variables after the data is received by the page. Delete is always requested for Unique Ids, and is handled by the “SreamResponse.aspx” code above.

Using an ASP Page instead of the internal HttpHandler allows full control of the stream to be sent to the client. The code given above provides exactly the same function as used by the internal HttpHandler.

ImageUri specifies the full path to the ASP Page used to handle the image. Note that the file part of the Uri must not be the same as any HttpHandlers added to Web.Config. If the same name is used, ASP.NET will use the HttpHandlers instead of the page.

If the ImageTransferMethod were changed to “Cache”, the generated image tag would be identical in format, except that a “CacheID” would be specified instead of the “SessionID”, and the data would be added to the application cache instead of the session object.


Tutorial 9 - Using an ASP Page-based Rendering Method with a Cache-based Transfer Method

Tutorial 9 – Using an ASP Page-based Rendering Method with a Cache-based Transfer Method

1. Place a WebChart on a form

2. Configure the data and appearance elements as desired.

3. Set the ImageRenderMethod property to “ASPPage”.

4. Set the ImageTransferMethod property to “Cache”.

5. Set the ImageIDGeneration property to “Application”.

6. Set the ImageUri to the above ASP Page (“StreamResponse.aspx”).

(ImageUri = C:\…StreamResponse.aspx)

7. Set the SlidingExpiration property to “00:00:30”.

Run the program and notice the following:

The image tag created should look similar to:

<img id=_c1wc src='StreamResponse.aspx?CacheID=WebForm1.aspx_C1WebChart1_9F0D3D0E'/>

Because the ImageIDGeneration property is set to “Unique”, the CacheID is unique for each rendering of the chart.

The Cache object variables are:

WebForm…3D0E_ImageBytes (image)

WebForm…3D0E_Hash (hash code and image type)

Because the SlidingExpiration property is set to 30 seconds, the lifetime of the cache variables is 30 seconds from the last access.

Using an ASP Page instead of the internal HttpHandler allows full control of the stream to be sent to the client. The code given above provides exactly the same function as used by the internal HttpHandler.

ImageUri specifies the full path to the ASP Page used to handle the image. Note that the file part of the Uri must not be the same as any HttpHandlers added to Web.Config. If the same name is used, ASP.NET will use the HttpHandlers instead of the page.

If the ImageTransferMethod were changed to “Session”, the generated image tag would be identical in format, except that a “SessionID” would be specified instead of the “CacheID”, and the data would be added to the Application Cache instead of the Session object.


UseAntiAlias Property (C1WebChart3D)

UseAntiAlias Property (C1WebChart3D)

Sets the interval between the time the image was last accessed and the time when the image expires from the session, cache, or file object.

Syntax

[VB]

Public Property UseAntiAlias As String

[C#]

public string UseAntiAlias { get; set; }

[Delphi]

property UseAntiAlias: string;

Remarks

This property applies to C1WebChart3D.

If this value is the equivalent of 5 minutes, the image expires and is removed from the transfer object 5 minutes after it was last accessed.

See Also

C1WebChart3D Class


User Interaction with C1WebChart

C1WebChart allows you to associate tooltips and links with chart elements, so the chart responds to mouse events. This is done using an HTML image map, which is handled on the client.

The image map is defined by the ImageAreas property, a collection of chart elements with associated dynamic tooltips and HRefs. The tooltips allow you to specify the text that is displayed to the user when he moves the mouse over chart elements. The HRefs allow you to specify actions to be taken when the user clicks a chart element.

When the ImageAreas contains non-empty elements, C1WebChart automatically generates <map> and <area> tags, and associates the map with the chart by adding a “usemap” attribute to the chart’s image tag.

Note that the automatic creation of image maps does not work when the ImageRenderMethod property is set to BinaryWrite. The workaround is to create a web chart with image maps on a web page other than the one that contains the resulting image.


Using ASP.NET

Creating an ASP.NET Project


Using C1WebChart for ASP.Net

This section starts with a walkthrough of C1WebChart, covering the main aspects of its usage. Later sections drill down into the details involved in each step and provide in-depth knowledge of the control.


Visual Basic and C# Samples

Bar3D | Demonstrates the use of a 3D bar chart in the web environment. This sample uses a C1WebChart3D control.
BinaryRender | Demonstrates the use of the BinaryRender option of C1WebChart. This sample uses a C1WebChart control.
NorthWindCharts | Demonstrates the use of a database with a 2D chart in the Web environment. This sample uses a C1WebChart control.
Simple2D | Demonstrates the use of a 2D chart in the Web environment. This sample uses a C1WebChart control.
Simple3D | Demonstrates the use of a 3D chart in the web environment. This sample uses a C1WebChart3D control.


WebChart3D Namespace1 - C#

C#

C1.Web.C1WebChart3D.C1WebChart3D webchart3d;


WebChart3D Namespace1 - Delphi

Delphi

Webchart3d: C1.Web.C1WebChart3D.C1WebChart3D;


WebChart3D Namespace1 - Visual Basic

Visual Basic

Dim webchart3d As C1.Web.C1WebChart3D.C1WebChart3D


WebChart3D Namespace2 - C#

C#

using MyGroup = C1.Win.C1Chart.ChartGroup;

MyGroup Gp;


WebChart3D Namespace2 - Delphi

Delphi

MyGroup : C1.Win.C1Chart.ChartGroup;

Gp: MyGroup;


WebChart3D Namespace2 - Visual Basic

Visual Basic

Imports MyGroup = C1.Win.C1Chart.ChartGroup

Dim Gp As MyGroup


WebChart3D Namespace3 - C#

C#

using C1.Win.C1Chart3D;

using C1.Web.C1WebChart3D;


WebChart3D Namespace3 - Delphi

Delphi

uses C1.Win.C1Chart3D;

uses C1.Web.C1WebChart3D;


WebChart3D Namespace3 - Visual Basic

Visual Basic

Imports C1.Win.C1Chart3D

Imports C1.Web.C1WebChart3D


Working with Two URLs

To have a chart image appear in a client’s browser, C1WebChart (or the developer, if in Manual mode) will have to handle at least two URL’s. The page specified by the first URL (the main page) is where the <IMG> tag will be created, and it can be used to gather information via input controls, layout the resulting display of the chart image amid text, and include other controls.

A second URL will be necessary to retrieve the actual chart image (jpeg, png, gif) to be displayed as the source attribute of the original page <IMG> tag.

The .aspx page identified by the first URL will result in HTML that contains:

<img src='second-url' />

Except for the Manual render method, the second URL accesses the chart image data, so conceptually the <IMG> tag is really:

<img src='second URL handles a request for an image' />

This handle is either a path to an image file, an HTTPHandler, or a path to another .aspx page that will complete the stream. The ImageRenderMethod determines what form the <IMG> tag will take.


Untitled Document

Send feedback to ComponentOne
Copyright © 1987-2005 ComponentOne LLC. All rights reserved.


Untitled Document

 E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.