Untitled Document ComponentOne Menus and Toolbars for .NET Untitled Document E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.

Welcome to ComponentOne Menus and Toolbars for .NET

ComponentOne Menus and Toolbars™ for .NET is a suite of .NET Windows Forms components providing closely integrated menus and toolbars with the Microsoft Visual Studio .NET look and feel.

If you like Menus and Toolbars for .NET, you can check out our other products by visiting our web site at www.componentone.com.

ComponentOne has a user-friendly distribution policy. We want every programmer to get copies of our products and try them for as long as they want. Those who like the tools and find them useful can buy licenses at reasonable prices. The only restriction is that unlicensed copies of the software will display a ComponentOne banner when they are loaded, as a friendly reminder that we do expect people to pay for the software if they use it on a regular basis.

We are confident that you'll like Menus and Toolbars for .NET. If you have any suggestions or ideas for new features or tools that you'd like to see included in a future version please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 • USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

Overview

What's New in ComponentOne Menus and Toolbars for .NET

Installing Menus and Toolbars for .NET

END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

Licensing FAQs

Technical Support

Redistributable Files

Namespaces

Creating a .NET Project

Adding ComponentOne Menus and Toolbars Components to Visual Studio

Terminology

Untitled Document
Send feedback to ComponentOne
Copyright © 1987-2005 ComponentOne LLC. All rights reserved.


Overview

The Menus and Toolbars for .NET suite of components allows you to add nice-looking menus and docking/floating toolbars to your Windows Forms applications. Useful features of the suite go beyond just looks though. Some highlights include:

· Microsoft Visual Studio .NET/Office XP look and feel.

· Close integration between menus and toolbars; the same command item (text, image, event handling code) can be used in several menus and/or toolbars at the same time.

· Full design-time support integrated into the Visual Studio forms designer.

· Docking/floating behavior, with layout that can be easily made end user-customizable.

· Global key shortcuts, usable also for commands not present in any menus or toolbars.

· Special support for MDI applications, including built-in MDI child windows list and hierarchical shortcut key processing.

· Idle-time automatic update of menu/toolbar items’ state.

· Context menus that can be attached to arbitrary controls on the form.

· and more.


What's New in ComponentOne Menus and Toolbars for .NET

This documentation was last revised on July 19, 2005.

Overview of What's New in Menus and Toolbars for .NET

There is a new class, C1SideCaption, and a few new members that have been added to Menus and Toolbars for .NET to allow the user more flexibility.

With the addition of the new class and members, Menus and Toolbars for .NET now provides the following:

· New sequence of menus and toolbar items.

· Ability to use stream files for SaveLayout and RestoreLayout methods of the C1DockingTab.

· Enhanced C1CommandMenus.


Feature Overview

New sequence of menu/toolbar items

The sequence of menu/toolbar items specified in the base form is now preserved in the inherited form.

New overload for SaveLayout and RestoreLayout

Ability to use a stream file instead of a file for the SaveLayout and RestoreLayout method of the C1DockingTab.

New technique for adding a delimiter

In dropdown menus, a command link without a command and with text surrounded by "-" is shown as a delimiter with centered text. If you would like to see how to create the delimiter using this technique, please see the following topic: Displaying the Delimiter in Drop-Down Menus.

C1CommandMenu now contains a side caption for its menus

A new property, SideCaption, has been added to C1CommandMenu. The SideCaption property allows to specify a caption (text and/or image) to be shown alongside the left edge of the menu. If you would like to see how to create a side caption for your C1CommandMenu, please see the following topic: Creating a SideCaption for a Command Menu.


Class Members

Here are the three most recent members added to the C1.Win.C1Command component:

C1CommandLink Class | Description
SortOrder Property | Gets or sets a value determining the relative position of the item.

C1CommandMenu Class | Description
SideCaption Property | Allows to specify a caption (text and/or image) to be shown alongside the left edge of the menu.
SideCaptionChanged Event | Fires when the SideCaption property of C1CommandMenu is changed.


New Classes

Here is the new class added to the C1.Win.C1Command component:

C1SideCaption Class | Description
BarGradientBegin Property | Gets or sets the beginning color of the gradient for the SideCaption.
BarGradientEnd Property | Gets or sets the ending color of the gradient for the SideCaption.
CaptionLayout Property | Gets or sets the text layout for the SideCaption. The default layout is TextAbove.
Font Property (C1SideCaption) | Gets or sets the font of the SideCaption.
ForeColor Property (C1SideCaption) | Gets or sets the text color of the SideCaption.
GradientDirection Property | Gets or sets the gradient direction (horizontal, vertical, forward diagonal, or backward diagonal) of the SideCaption.
Icon Property (C1SideCaption) | Gets or sets the SideCaption icon.
Image Property (C1SideCaption) | Gets or sets the SideCaption image.
ImageIndex Property (C1SideCaption) | Gets or sets the index of the C1CommandMenu image for the SideCaption (in C1CommandHolder.ImageList).
Text Property (C1SideCaption) | Gets or sets the text shown in the SideCaption.
TextAlignment Property (C1SideCaption) | Gets or sets the text alignment (near, far, or center) from an object in the SideCaption.
TextDirection Property (C1SideCaption) | Gets or sets the direction of the text in the SideCaption.
Width Property (C1SideCaption) | Gets or sets the width of the SideCaption.


Installing Menus and Toolbars for .NET

This section describes the setup files and system requirements for Menus and Toolbars for .NET. It also explains how to install demonstration versions of ComponentOne products and uninstall Menus and Toolbars for .NET.


C1Menus and ToolBars for .NET Setup Files

The installation program will create the directory C:\Program Files\ComponentOne Studio.NET, which contains the following subdirectories:

bin | Contains copies of all binaries (DLLs, EXEs) in the ComponentOne Visual Studio.NET package.
Common | Contains support and data files that are used by many of the demo programs.
Help | Contains online documentation for all Studio components.
C1Command | Contains samples and tutorials for Menus and Toolbars for .NET.

To install the Menus and Toolbars for .NET, run the .msi installation file provided in the distribution CD (or downloaded from the web). If the installation is being performed from the distribution CD, a menu should appear when it is placed in the computer. From the menu, click the "Install Software" link for the Reporting Components, and follow the instructions. It is important to note that selecting the "Typical" installation type will install all of the ComponentOne controls and components within the msi and their supporting files. If it is the wish of the developer to install only the Menus and Toolbars, select the "Custom" installation type and remove those features that are not desired.


System Requirements

· Operating Systems:

-Windows 2000

-Windows 2003 Server

-Windows NT 4

-Windows XP, sp1, sp2

· Environments:

-.NET Framework 1.0

-.NET Framework1.1

-C# .NET

-Delphi

-Visual Basic .NET

· Hard Disk Space: 6 mb hard disk space for storage of the software

· Disc Drive: CD or DVD-ROM drive if installing from CD


Installing Demonstration Versions

If you wish to try Menus and Toolbars for .NET or any of our other products and do not have a registration key, follow the steps through the installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that registered versions will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.


END-USER LICENSE AGREEMENT FOR COMPONENTONE SOFTWARE

IMPORTANT-READ CAREFULLY: This End User License Agreement (this "EULA") contains the terms and conditions regarding your use of the SOFTWARE (as defined below). This EULA contains material limitations to your rights in that regard. You should read this EULA carefully and treat it as valuable property.

I. THIS EULA.

1. Software Covered by this EULA. This EULA governs your use of the ComponentOne, LLC ("C1") software product(s) enclosed or otherwise accompanied herewith (individually and collectively, the "SOFTWARE"). The term "SOFTWARE" includes, to the extent provided by C1: 1) any revisions, updates and/or upgrades thereto; 2) any data, image or executable files, databases, data engines, computer software, or similar items customarily used or distributed with computer software products; 3) anything in any form whatsoever intended to be used with or in conjunction with the SOFTWARE; and 4) any associated media, documentation (including physical, electronic and on-line) and printed materials (the "Documentation").

2. This EULA is a Legally Binding Agreement Between You and C1. If you are acting as an agent of a company or another legal person, such as an officer or other employee acting for your employer, then "you" and "your" mean your principal, the entity or other legal person for whom you are acting. However, importantly, even if you are acting as an agent for another, you may still be personally liable for violation of federal and State laws, such as copyright infringement.

This EULA is a legally binding agreement between you and C1. You intend to be legally bound to this EULA to the same extent as if C1 and you physically signed this EULA. By installing, copying, or otherwise using the SOFTWARE, you agree to be bound by the terms and conditions contained in this EULA. If you do not agree to all of the terms and conditions contained in this EULA, you may not install or use the SOFTWARE. If, for whatever reason, installation has begun or has been completed, you should cancel installation or un-install the SOFTWARE, as the case may be. (You may click on the "exit" button or its equivalent to immediately abort installation.) If you do not agree to all of these terms and conditions, then you must promptly return the SOFTWARE to the place of business from which you obtained it in accordance with any return policies of such place of business. Return policies may vary between or among resellers, and you must comply with your particular reseller's return policies as agreed at the point of purchase. If the place of business from which you purchased the SOFTWARE does not honor a complete refund for a period of thirty (30) days from the date of proof of purchase, then you may return the SOFTWARE directly to C1 for a period of thirty (30) days from the date of your purchase. To return the product directly to C1, you must obtain a C1 Return Authorization Number by contacting C1, and you must forward all items purchased, including the proof of purchase, directly to C1. The return must be postage-prepaid, and post-marked within thirty (30) days from the proof of purchase, time being of the essence. The return option to C1 is only available to the original purchaser of an unopened factory packaged item.

II. YOUR LICENSE TO DEVELOP AND TO DISTRIBUTE.

As provided in more detail below, this EULA grants you two licenses: 1) a license to use the SOFTWARE to develop other software products (the "Development License"); and 2) a license to use and/or distribute the Developed Software (the "Distribution License"). Both of these licenses (individually and collectively, the "Licenses") are explained and defined in more detail below.

1. Definitions. The following terms have the respective meanings as used in this EULA:

"Network Server" means a computer with one or more computer central processing units (CPU's) that operates for the purpose of serving other computers logically or physically connected to it, including, but not limited to, other computers connected to it on an internal network, intranet or the Internet. "Web Server" means a type of Network Server that serves other computers more particularly connected to it over an intranet or the Internet.

"Developed Software" means those computer software products that are developed by or through the use of the SOFTWARE. "Developed Web Server Software" means those Developed Software products that reside logically or physically on at least one Web Server and are operated (meaning the computer software instruction set is carried out) by the Web Server's central processing unit(s) (CPU). "Developed Legacy Software" means those Developed Software products that are not Developed Web Server Software, including, for example, stand-alone applications and applications accessed by a file server only. "Redistributable Files" means the SOFTWARE files or other portions of the SOFTWARE that are provided by C1 and are identified as such in the Documentation for distribution by you with the Developed Software. "Developer" means a human being or any other automated device using the SOFTWARE in accordance with the terms and conditions of this EULA.

"Developer Seat License" means that each Developer using or otherwise accessing the programmatic interface or the SOFTWARE must obtain the right to do so by purchasing a separate End User License.

“Source Code” shall mean computer software code or programs in human readable format, such as a printed listing of such a program written in a high-level computer language. The term "Source Code" includes, but is not limited to, documents and materials in support of the development effort of the SOFTWARE, such as flow charts, pseudo code and program notes.

2. Your Development License. You are hereby granted a limited, royalty-free, non-exclusive right to use the SOFTWARE to design, develop, and test Developed Software, on the express condition that, and only for so long as, you fully comply with all terms and conditions of this EULA.

The SOFTWARE is licensed to you on a Developer Seat License basis.

The Developer Seat License means that you may perform an installation of the SOFTWARE for use in designing, testing and creating Developed Software by a single Developer on one or more computers, each with a single set of input devices, so long as such computer/computers is/are used only by one single Developer at any given time and not concurrently. Conversely, you may not install or use the SOFTWARE on a computer that is a network server or a computer at which the SOFTWARE is used by more than one Developer. You may not network the SOFTWARE or any component part of it, where it is or may be used by more than one Developer unless you purchase an additional Development License for each Developer. You must purchase another separate license to the SOFTWARE in order to add additional developer seats, whether the additional developers are accessing the SOFTWARE in a stand-alone environment or on a computer network.

In all cases, you may not use C1's name, logo, or trademarks to market your Developed Software without the express written consent of C1; (b) you must include the following C1 copyright notice in your Developed Software documentation and/or in the "About Box" of your Developed Software, and wherever the copyright/rights notice is located in the Developed Software (“Portions Copyright © ComponentOne, LLC 1991-2002. All Rights Reserved.”); (c) agree to indemnify, hold harmless, and defend C1, its suppliers and resellers, from and against any claims or lawsuits, including attorney's fees that may arise from the use or distribution of your Developed Software; (d) you may use the SOFTWARE only to create Developed Software that is significantly different than the SOFTWARE.

3. Your Distribution License.

License to Distribute Developed Software. Subject to the terms and conditions in this EULA, you are granted the license to use and to distribute Developed Software on a royalty-free basis, provided that the Developed Software incorporates the SOFTWARE as an integral part of the Developed Software in machine-language compiled format (customarily an ".exe", or ".dll", etc.). You may not distribute, bundle, wrap or subclass the SOFTWARE as Developed Software which, when used in a "designtime" development environment, exposes the programmatic interface of the SOFTWARE. You may distribute, on a royalty-free basis, Redistributable Files with Developed Software only.

4. Specific Product Limitations. Notwithstanding anything in this EULA to the contrary, if the license you have purchased is for any of the following products, then the following additional limitations will apply:

a. ComponentOne Reports for .NET Designer Edition. ComponentOne Reports for .NET Designer Edition includes at least: 1) one dynamic link library (c1.win.c1reportdesigner.dll) file known as C1ReportDesigner Component, 2) one executable (ReportDesigner.exe) file known as C1ReportDesigner Application and, 3) the Source Code of the C1ReportDesigner Application. The C1ReportDesigner Component is subject to the general terms and restrictions set forth in this EULA. The C1ReportDesigner Application is an executable file used to design and prepare reports; the C1ReportDesigner Application may be distributed, free of royalties, only in conjunction with the Developed Software.

Subject to the terms and conditions in this EULA, C1 hereby grants you the right to use the C1ReportDesigner Application Source Code. You are hereby also granted the right to modify such Source Code and to create derivative works that are based on the licensed Source Code. You may distribute the derivative works that you develop, solely in object code format and exclusively in conjunction with and/or as a part of the Developed Software. You are expressly not granted the right to distribute, disclose or otherwise make available to any third party the licensed Source Code, any modified version, derivative work, or any portion thereof, in source code format.

C1 shall retain all right, title and interest in and to the licensed Source Code, and all C1 updates, modifications or enhancements thereof. Nothing herein shall be deemed to transfer any ownership or title rights in and to the licensed Source Code from C1 to you.

SOURCE CODE IS LICENSED TO YOU AS IS. C1 DOES NOT AND SHALL NOT PROVIDE YOU WITH ANY TECHNICAL SUPPORT FOR YOUR SOURCE CODE LICENSE.

b. VSView Reporting Edition. VSView Reporting Edition includes at least one executable file listed as “VSRptX.exe” (where X indicates the version number i.e.7,8, etc.), known as “Designer.” The file "VSRptX.exe”, or any upgrade or future versions of the Designer, are subject to the restrictions set forth in this EULA and may not be distributed with your Developed Software or in any other way.

c. Doc-to-Help and ComponentOne Natural Search. You may use Doc-To-Help to create online help, manuals or other documentation in electronic or printed format (the "Output Documents"). You may distribute and incorporate in such Output Documents those files identified in the documentation as Redistributable Files. Except for those specific Redistributable Files, you MAY NOT distribute the SOFTWARE, in any format, to others.

d. Studio Products. You may not share the component parts of the Studio Products licensed to you with other Developers, nor may you allow the use and/or installation of such components by other Developers.

e. ComponentOne Response and SOAP Channel. ComponentOne Response is intended to be installed on a Network Server. C1 grants to you the following rights to the SOFTWARE: a) Installation: You may install one copy of the SOFTWARE on a single Network Server; b) Use: When installed and initialized, the SOFTWARE creates a database file which contains the embodiment of a solution knowledge base (the database hereinafter referred to as the "Knowledge Base").

You may use the SOFTWARE to create Knowledge Bases on one Network Server only. To create or to operate Knowledge Bases in more than one Network Server, you must purchase one additional SOFTWARE license for each additional Network Server.

5. Updates/Upgrades; Studio Subscription. Subject to the terms and conditions of this EULA, the Licenses are perpetual. Updates and upgrades to the SOFTWARE may be provided by C1 from time-to-time, and, if so provided by C1, are provided upon the terms and conditions offered at that time by C1 in its sole discretion. C1 may provide updates and upgrades to the SOFTWARE for free or for any charge, at any time or never, and through its chosen manner of access and distribution, all in C1's sole and complete discretion.

C1 licenses certain of its separately-licensed products bundled together in a product suite, called the C1 "Studio" product line (the "Studio Products"). The exact separately-licensed products that are bundled into the Studio Products may change from time-to-time in C1's sole discretion. If the SOFTWARE is identified as a C1 "Studio" product, then the SOFTWARE is one of the Studio Products. The SOFTWARE and the Studio Products are revised from time-to-time (meaning, for example, revised with updates, upgrades and, in the case of Studio products, possibly changes to which specific products are included in the bundle). For you to be entitled to receive any such revisions to the SOFTWARE or the Studio Products, as the case may be, you must have a valid SOFTWARE license or a valid Studio subscription. The original purchaser of the SOFTWARE or of a Studio product receives a one-year subscription from the date of purchase of the SOFTWARE. After one year, the Studio subscription and/or the SOFTWARE license must be renewed to continue to be entitled to receive the SOFTWARE and/or the Studio Products revisions as the case may be.

6. Serial Number. Within the packaging of the SOFTWARE, a unique serial number (the "Serial Number") is included, which allows for the registration of the SOFTWARE. The Serial Number is subject to the restrictions set forth in this EULA and may not be disclosed or distributed either with your Developed Software or in any other way. The disclosure or distribution of the Serial Number shall constitute a breach of this EULA, the effect of which shall be the automatic termination and revocation of all the rights granted herein.

7. Evaluation Copy. If you are using an "evaluation copy" or similar version, specifically designated as such by C1 on its website or otherwise, then the Licenses are limited as follows: a) you are granted a license to use the SOFTWARE for a period of thirty (30) days counted from the day of installation (the "Evaluation Period"); b) upon completion of the Evaluation Period, you shall either i) delete the SOFTWARE from the computer containing the installation, or you may ii) contact C1 or one of its authorized dealers to purchase a license of the SOFTWARE, which is subject to the terms and limitations contained herein; and c) any Developed Software may not be distributed or used for any commercial purpose.

III. INTELLECTUAL PROPERTY.

1. Copyright. You agree that all right, title, and interest in and to the SOFTWARE (including, but not limited to, any images, photographs, animations, video, audio, music, text, and “applets” incorporated into the SOFTWARE), and any copies of the SOFTWARE, and any copyrights and other intellectual properties therein or related thereto are owned exclusively by C1, except to the limited extent that C1 may be the rightful license holder of certain third-party technologies incorporated into the SOFTWARE. The SOFTWARE is protected by copyright laws and international treaty provisions. The SOFTWARE is licensed to you, not sold to you. C1 reserves all rights not otherwise expressly and specifically granted to you in this EULA.

2. Backups. You may either: (a) copy the SOFTWARE solely for backup or archival purposes; or (b) install the SOFTWARE on a single computer, provided you keep the original solely for backup or archival purposes. Notwithstanding the foregoing, you may not copy the Documentation.

3. General Limitations. You may not reverse engineer, decompile, or disassemble the SOFTWARE, except and only to the extent that applicable law expressly permits such activity notwithstanding this limitation.

4. Software Transfers. You may not rent or lease the SOFTWARE. You may transfer the SOFTWARE to another computer, provided that it is completely removed from the computer from which it was transferred. You may permanently transfer all of your rights under the EULA, provided that you retain no copies, that you transfer all the SOFTWARE (including all component parts, the media and printed materials, any dates, upgrades, this EULA and, if applicable, the Certificate of Authenticity), and that the recipient agrees to the terms and conditions of this EULA as provided herein. If the SOFTWARE is an update or upgrade, any transfer must include all prior versions of the SOFTWARE.

5. Termination. Without prejudice to any other rights it may have, C1 may terminate this EULA and the Licenses if you fail to comply with the terms and conditions contained herein. In such an event, you must destroy all copies of the SOFTWARE and all of its component parts.

6. Export Restrictions. You acknowledge that the SOFTWARE is of U.S. origin. You acknowledge that the license and distribution of the SOFTWARE is subject to the export control laws and regulations of the United States of America, and any amendments thereof, which restrict exports and re-exports of software, technical data, and direct products of technical data, including services and Developed Software. You agree that you will not export or re-export the SOFTWARE or any Developed Software, or any information, documentation and/or printed materials related thereto, directly or indirectly, without first obtaining permission to do so as required from the United States of America Department of Commerce's Bureau of Export Administration ("BXA"), or other appropriate governmental agencies, to any countries, end-users, or for any end-uses that are restricted by U.S. export laws and regulations, and any amendments thereof, which include, but are not limited to, the following:

Restricted Countries: Restricted Countries currently include, but are not necessarily limited to Cuba, Iran, Iraq, Libya, Montenegro, North Korea, Serbia, Sudan, and Syria.

Restricted End-Users: Any End-User whom you know or have reason to know will use SOFTWARE or Developed Software in the design, development, or production of missiles and missile technology, nuclear weapons and weapons technology, or chemical and biological weapons. Any national of any of the Restricted Countries, wherever located, who intends to transmit or transport the SOFTWARE or Developed Software to one of the Restricted Countries.

Restricted End-Uses: Any use of SOFTWARE and Developed Software related to the design, development, or production of missiles and missile technology, nuclear weapons and weapons technology, or chemical and biological weapons.

These restrictions change from time to time. You represent and warrant that neither the BXA nor any other United States federal agency has suspended, revoked or denied your export privileges. C1 acknowledges that it shall use reasonable efforts to supply you with all reasonably necessary information regarding the SOFTWARE and its business to enable you to fully comply with the provisions of this Section. If you have any questions regarding your obligations under United States of America export regulations, you should contact the Bureau of Export Administration, United States Department of Commerce, Exporter Counseling Division, Washington DC. U.S.A. (202) 482-4811, http://www.bxa.doc.gov.

7. U.S. Government Restricted Rights. The SOFTWARE and documentation are provided with RESTRICTED RIGHTS. For solicitations issued before December 1, 1995, by the United States of America, its agencies and/or instrumentalities (the "Government"), other than the Department of Defense, the use, duplication or disclosure of the software and documentation provided to the Government under this EULA shall be subject to the RESTRICTED RIGHTS as set forth in subparagraphs (c)(1) and (2) of the Commercial Computer Software - Restricted Rights clause at 48 CFR ch.1 52.227-19. For solicitations issued before September 29, 1995, by the Department of Defense, the use, duplication or disclosure of the software and documentation provided under this EULA shall be subject to the RESTRICTED RIGHTS as set forth in subparagraph (c)(1)(ii) of the Rights in Technical Data and Computer Software clause at 48 CFR ch.2 252.227-7013. You will comply with any requirements of the Government to obtain such RESTRICTED RIGHTS protection, including without limitation, the placement of any restrictive legends on the SOFTWARE, and any license agreement used in connection with the distribution of the SOFTWARE. Manufacturer is ComponentOne, LLC, 201 South Highland Avenue, 3rd Floor, Pittsburgh, Pennsylvania 15206 USA. For solicitations issued by the Government on or after December 1, 1995 and the Department of Defense on or after September 29, 1995, the only rights provided in the software and documentation provided herein shall be those contained in this EULA. Under no circumstances shall C1 be obligated to comply with any Governmental requirements regarding the submission of or the request for exemption from submission of cost or pricing data or cost accounting requirements. For any distribution of the SOFTWARE that would require compliance by C1 with the Government's requirements relating to cost or pricing data or cost accounting requirements, you must obtain an appropriate waiver or exemption from such requirements for the benefit of C1 from the appropriate Government authority before the distribution and/or license of the SOFTWARE to the Government.

IV. WARRANTIES AND REMEDIES.

1. Limited Warranty. C1 warrants that the original media, if any, are free from defects for ninety (90) days from the date of delivery of the SOFTWARE. EXCEPT AS OTHERWISE PROVIDED IN THE PRECEDING SENTENCE, AND TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, C1 EXPRESSLY DISCLAIMS ANY WARRANTY FOR THE SOFTWARE, DOCUMENTATION AND ANYTHING ELSE PROVIDED BY C1 HEREBY AND C1 PROVIDES THE SAME IN “AS IS” CONDITION WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, WITHOUT LIMITATION, THE IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. THE ENTIRE RISK ARISING OUT OF USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH YOU. THIS LIMITED WARRANTY GIVES YOU SPECIFIC LEGAL RIGHTS. YOU MAY HAVE OTHERS WHICH VARY FROM STATE TO STATE.

2. Limited Remedy. C1's entire liability and your exclusive remedy under this EULA shall be, at C1's sole option, either (a) return of the price paid for the SOFTWARE; (b) repair the SOFTWARE through updates distributed online or otherwise in C1's discretion; or (c) replace the SOFTWARE with SOFTWARE that substantially performs as described in the SOFTWARE documentation, provided that you return the SOFTWARE in the same manner as provided in Section I.2 for return of the SOFTWARE for non-acceptance of this EULA. Any media for any repaired or replacement SOFTWARE will be warranted for the remainder of the original warranty period or thirty (30) days, whichever is longer. THESE REMEDIES ARE NOT AVAILABLE OUTSIDE OF THE UNITED STATES OF AMERICA. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL C1 BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF BUSINESS PROFIT, BUSINESS INTERRUPTION, LOSS OF BUSINESS INFORMATION, OR ANY OTHER PECUNIARY LOSS) ARISING OUT OF THE USE OR INABILITY TO USE THE SOFTWARE, EVEN IF C1 HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES. BECAUSE SOME STATES/JURISDICTIONS DO NOT ALLOW THE EXCLUSION OR LIMITATION OF LIABILITY FOR CONSEQUENTIAL OR INCIDENTAL DAMAGES IN CERTAIN CASES, THE ABOVE LIMITATION MAY NOT APPLY TO YOU.

V. MISCELLANEOUS.

1. This is the Entire Agreement. This EULA (including any addendum or amendment to this EULA included with the SOFTWARE) is the final, complete and exclusive statement of the entire agreement between you and C1 relating to the SOFTWARE. This EULA supersedes any prior and contemporaneous proposals, purchase orders, advertisements, and all other communications in relation to the subject matter of this EULA, whether oral or written. No terms or conditions, other than those contained in this EULA, and no other understanding or agreement which in any way modifies these terms and conditions, shall be binding upon the parties unless entered into in writing executed between the parties, or by other non-oral manner of agreement whereby the parties objectively and definitively act in a manner to be bound (such as by continuing with an installation of the SOFTWARE, "clicking-through" a questionnaire, etc.) Employees, agents and other representatives of C1 are not permitted to orally modify this EULA.

2. You Indemnify C1. . You agree to indemnify, hold harmless, and defend C1 and its suppliers and resellers from and against any and all claims or lawsuits, including attorney's fees, which arise out of or result from your breach of any of the terms and conditions of this EULA.

3. Interpretation of this EULA. If for any reason a court of competent jurisdiction finds any provision of this EULA, or any portion thereof, to be unenforceable, that provision of this EULA will be enforced to the maximum extent permissible so as to effect the intent of the parties, and the remainder of this EULA will continue in full force and effect. Formatives of defined terms shall have the same meaning of the defined term. Failure by either party to enforce any provision of this EULA will not be deemed a waiver of future enforcement of that or any other provision. Except as otherwise required or superseded by law, this EULA is governed by the laws of the Commonwealth of Pennsylvania, without regard to its conflict of laws principles. The parties consent to the personal jurisdiction and venue of the Commonwealth of Pennsylvania, in the County of Allegheny, and agree that any legal proceedings arising out of this EULA shall be conducted solely in such Commonwealth. If the SOFTWARE was acquired outside the United States, then local law may apply.


Licensing FAQs

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting


What is Licensing?

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.


How does Licensing Work?

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

NOTE: The Compact Framework components use a slightly different mechanism for licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the "License" button on the About Box of any ComponentOne product.)

When a licensed component is added to a form or web page, Visual Studio asks the newly created component for licensing information. The component looks for licensing information stored in the system and generates a key, which Visual Studio saves in two files:

1. a "<projectName>.licenses" resource file which contains the actual key and

2. a "licenses.licx" file that contains references to those resources.

These files are automatically added to the project.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the "Show All Files" button in the Solution Explorer's toolbox, or select "Project | Show All Files" from Visual Studio's main menu.

Later, when the component is created at run time, it gets passed the key that was created at design time and can decide whether to simply accept the key, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.


Common Scenarios

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications


Creating components at design time

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.


Creating components at run time

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate key for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).


Inheriting from licensed components

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

1. Add a LicenseProvider attribute to the component.

This will mark the component as licensed. When a component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

[LicenseProvider(typeof(LicenseProvider))]

class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid

{

// ...

}

2. Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.


Using licensed components in console applications

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licensex.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the property window, set the "Build Action" property to "Embedded Resource".


Using licensed components in Visual C++ applications

It seems there is a bug in VC++ 2003. The licenses.licx is ignored during the build process, therefore the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an exe file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the app directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed dlls to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

5. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select properties, and go to the Linker/Command Line option. Enter the following:

/ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

6. Rebuild the executable to include the licensing information in the application.


Troubleshooting

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

If this happens, there must be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild ("Rebuild All" from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the "Show All Files" button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the "Rebuild All" option (not just "Rebuild").


I have a licensed version of a ComponentOne product on my web server but the components still behave as unlicensed.

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (exe or dll) when the project is built. After that, the application can be deployed on any machine, including web servers.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Make sure that the license key is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 - Renew your subscription to get a new license key.

If you choose this option, you will receive a new key that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com/.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.


Technical Support

ComponentOne Menus and Toolbars for .NET is developed and supported by ComponentOne LLC, a company formed by the merger of APEX Software Corporation and VideoSoft. You can obtain technical support using any of the following methods:

ComponentOne Web site

ComponentOne HelpCentral

Internet E-mail

Peer-to-Peer Newsgroup

Documentation


ComponentOne Web site

The ComponentOne Web site at www.componentone.com provides a wealth of information and software downloads for Menus and Toolbars for .NET users, including:

· Descriptions of the various support options available through the ComponentOne Service Team.

· Answers to frequently asked questions (FAQ's) about our products, organized by functionality. Please consult the FAQ's before contacting us directly, as this can save you time and also introduce you to other useful information pertaining to our products.

· Free product updates, which provide you with bug fixes and new features.


ComponentOne HelpCentral

ComponentOne HelpCentral is the new online resource for Visual Studio developers and Help authors. Visit HelpCentral to get information on ComponentOne products, view online demos, get Tech Tips and answers to frequently asked questions (FAQ's), search the ComponentOne knowledgebase and more!


Internet E-mail

For technical support through the Internet, e-mail us at:

support.c1command.net@componentone.com

To help us provide you with the best support, please include the following information when contacting ComponentOne:

· Your ComponentOne product serial number.

· The version and name of your operating system.

· Your development environment and its version.

For more information on technical support, go to:

www.componentone.com/support


Peer-to-Peer Newsgroup

ComponentOne also sponsors peer-to-peer newsgroups for C1Command users. ComponentOne does not offer formal technical support in this newsgroup, but instead sponsors it as a forum for users to post and answer each other's questions regarding C1Command. However, ComponentOne may monitor the newsgroups to ensure accuracy of information and provide comments when necessary. You can access the newsgroup from the ComponentOne Web site at http://helpcentral.componentone.com/Newsgroups.aspx.


Documentation

ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (.NET, ASP.NET and Mobile Device products only), and PDF format. All of the PDFs are also available on http://helpcentral.componentone.com/Documentation.aspx. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.


Redistributable Files

ComponentOne Menus and Toolbars for .NET is developed and published by ComponentOne LLC. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

· C1.Win.C1Command.dll

· C1.Common.dll

Site licenses are available for groups of multiple developers. Please contact Sales@ComponentOne.com for details.


Namespaces

Namespaces organize the objects defined in an assembly. Assemblies can contain multiple namespaces, which can in turn contain other namespaces. Namespaces prevent ambiguity and simplify references when using large groups of objects such as class libraries.

The general namespace for ComponentOne Windows's products is C1.Win. The namespace for the Menus and Toolbars suite is C1.Win.C1Command (note also that in this manual, the name C1Command is used sometimes to designate the Menus and Toolbars product – the two names in this document mean exactly the same thing). The following code fragment shows how to declare a C1MainMenu (which is one of the components included in the Menus and Toolbars suite) using the fully qualified name for this class:

· Visual Basic

· C#

· Delphi

Namespaces address a problem sometimes known as namespace pollution, in which the developer of a class library is hampered by the use of similar names in another library. These conflicts with existing components are sometimes called name collisions.

For example, if you create a new class named C1ToolBar, you can use it inside your project without qualification. However, the C1Command assembly also implements a class called C1ToolBar. So, if you want to use the C1ToolBar class in the same project, you must use a fully qualified reference to make the reference unique. If the reference is not unique, Visual Studio .NET produces an error stating that the name is ambiguous. The following code snippet demonstrates how to declare these objects:

· Visual Basic

· C#

· Delphi

Fully qualified names are object references that are prefixed with the name of the namespace where the object is defined. You can use objects defined in other projects if you create a reference to the class (by choosing Add Reference from the Project menu) and then use the fully qualified name for the object in your code.

Fully qualified names prevent naming conflicts because the compiler can always determine which object is being used. However, the names themselves can get long and cumbersome. To get around this, you can use the Imports statement (using in C#) to define an alias — an abbreviated name you can use in place of a fully qualified name. For example, the following code snippet creates aliases for two fully qualified names, and uses these aliases to define two objects:

· Visual Basic

· C#

· Delphi

If you use the Imports statement without an alias, you can use all the names in that namespace without qualification provided they are unique to the project.


Creating a .NET Project

This topic demonstrates how to create a new NET project.

1. From the File menu in .NET, select New and click Project. The New Project dialog box opens.

2. Under Project Types, choose either Visual Basic Projects or Visual C# Projects, and select.NET Windows Application from the list of Templates in the right pane.

3. Enter a name for your new application in the Name field or you can use the default name, WindowsApplication1. Click on the Browse button to the right of the Location field to specify the location of your new project and click OK.


Adding ComponentOne Menus and Toolbars Components to Visual Studio

After installing Menus and Toolbars for .NET on your computer, you need to add its components to the Visual Studio Toolbox. To do this, follow these steps:

1. Open the Visual Studio IDE (Microsoft Development Environment.)

2. Make sure the Toolbox is visible (select Toolbox in the View menu if necessary). Right-click the Toolbox to open its context menu.

If you want the Menus and Toolbars for .NET components to appear on their own tab in the Toolbox, Right-click in the gray Toolbox area and select Add Tab from the context menu and type in the tab name, for example, “C1Command”.

3. Select the tab where you want the components to appear.

4. Right-click that tab or one of the existing tabs and select Customize Toolbox… from the context menu. The Customize Toolbox dialog box will open.

5. In the Customize Toolbox dialog box, go to the .NET Framework Components tab.

6. Sort the list by Namespace (click the Namespace column header).

7. Select the Browse button and find C1.Win.C1Command.dll and open it. All of the .Net components for C1Command will be highlighted in blue.

8. Here you can check which Menus and Toolbars for .NET components will be installed on your toolbox.

We recommend that you install all C1.Win.C1Command components, which include the following:

· C1CommandDock

C1CommandDock is a container control which provides docking and floating behavior to toolbars (objects of class C1ToolBar). You can drop a C1CommandDock anywhere on your form, adjust its size and position, and then put your toolbars in it. At runtime, toolbars contained in a C1CommandDock will show a drag area on their left (horizontal toolbars) or top (vertical toolbars) side, and the user will be able to drag them around, dock to other sides of the form and/or to other C1CommandDock objects, or make them floating. C1CommandDock also has a set of properties which allows you to control the available behavior options. For details, see the C1CommandDock class.

· C1ContextMenu

C1ContextMenu is a command with one or more sub-items (i.e., a command with a submenu) which can be used as a context menu for an arbitrary control on your form. Objects of type C1ContextMenu appear in the component tray. To make a C1ContextMenu the context menu for a control, you should set the C1ContextMenu property provided to all controls on the form containing a C1ContextMenu.

· C1MainMenu

This is a control which provides the main menu for a form. When you place this object on your form, it will show across the whole form at the top, as regular Windows main menus do. Only one C1MainMenu control can be added to a form. To add items to a C1MainMenu, right-click on it and select the “Append Item…”item from the context menu. Alternatively, you can edit the CommandLinks collection of the C1MainMenu using the collection editor.

· C1ToolBar

This is the toolbar control of the suite. When you place it on a form, you can add buttons to it by right-clicking and selecting appropriate items from the context menu. At design time, items in C1ToolBar can be dragged to different positions and/or to another toolbar. To make a toolbar that end users will be able to move around the form, dock to its sides or make it float, put your C1ToolBar controls inside the C1CommandDock containers.

· C1DockingTab

This is a control that displays multiple tabs, like dividers in a notebook or labels in a set of folders in a filing cabinet. The C1DockingTab control contains a collection of the C1DockingTabPage controls. Each of those pages can contain arbitrary controls. In addition to the standard tab control features, the C1DockingTab provides docking and floating behavior: the whole control or any of its pages individually, can be torn off and docked to another side of the form, to another C1DockingTab control, or it can be made to float. (Note: to enable the docking and floating features, a C1DockingTab must be placed inside a C1CommandDock initially.)

· C1DockingTabPage

This is a container control which represents a single tab page in a C1DockingTab control.

· C1OutBar

An outbar control which manages a related set of pages. It provides an Outlook-style tab container.


Terminology

In this text, the following words are used to designate specific classes or groups of classes of components provided by the ComponentOne Menus and Toolbars for .NET product:

· C1Command (two meanings): used as a short name to designate the whole ComponentOne Menus and Toolbars for .NET product, and used to designate the key class in the product.

· Command: used to designate objects of the type C1Command and of derived types, which represent the actual executable commands invoked from menu items and toolbar buttons.

· Command link: used to designate objects of the type C1CommandLink.

· Command holder: used to designate objects of the type C1CommandHolder.


Commands and Command Links

The C1Command suite integrates menus and toolbars into a single system, allowing you to reuse the same objects and code for menu items and toolbar buttons. The following model provides this integration:

The functionality of a menu item or a toolbar button (which are very closely related in C1Command) is split between two components: a command and a command link. The command (an object of type C1Command or derived types, see Class Hierarchy below for a list) is used to hold properties and event handlers related to the actual action which the command represents. Commands themselves are not contained in C1Command’s menus and toolbars. Instead, all commands on a form are stored as a single collection in a component of type C1CommandHolder, a single instance of which is automatically created on the form when you add the first C1Command’s menu or toolbar to it. To represent commands in menus and toolbars, command links (components of type C1CommandLink) are used. A command link is a small and quite simple component. Its most important property is Command, which points to the actual command object associated with this command link. Aside from this, a command link allows you to override some of the properties of the linked command, such as text. The visual representation of a command link depends on two factors: the command it links to, and whether the link is contained in a main menu, a popup menu, or a toolbar. Properties used to show the command link are taken from the command (e.g., text or image), whereas the way they are shown is determined by the container (in a main menu, only the command’s text is shown, in a popup menu, also the image and the shortcut are shown, and so on). And of course, multiple command links can point to the same command, which is one of the main reasons why commands and command links are separate items.

To sum it up, the following relationships exist between commands, command links, menus and toolbars, and the command holder on a form:

· Commands (class C1Command and derived classes) are automatically stored in the form’s command holder (object of type C1CommandHolder).

· Menus and toolbars (objects of type C1MainMenu, C1CommandMenu, C1ContextMenu, C1ToolBar) contain command links (type C1CommandLink) which represent menu items or toolbar buttons. Each command link points to the actual command in the command holder. Command links are stored in the CommandLinks collection of a menu or a toolbar. Command links can be edited via this collection or using the designer.

· Multiple command links can point to the same command. And command links pointing to the same command can be inside different containers. For example, a link from the File menu and another from the File Operations toolbar can point to the same file open command.

· Most properties of a command link visible to the user (text, image, etc.) are normally taken from the linked command. The shown state of the command link (enabled/disabled, checked/unchecked etc.) is also determined by the corresponding state of the linked command (command links do not have state properties).

· Most importantly, event handlers that actually perform user-defined actions (e.g., opening a file or copying to the clipboard) are associated only with commands and never with command links. When a menu item is selected or a toolbar button is clicked by the user, the click event handler of the linked command is invoked.

· To enumerate all commands defined on a form, use the Commands collection of the command holder (which shows up in the component tray of the form). You can also use the collection editor to add or remove commands (although an easier approach is probably to use the menu or toolbar designer, accessing commands via their links).


Class Hierarchy

This section summarizes the class relationships between the more important of the components included in the C1Command suite.


Commands

· C1Command : System.ComponentModel.Component

Basic executable command. Base class for all other command classes.

· C1CommandMenu : C1Command

Command which can contain a submenu.

· C1ContextMenu : C1CommandMenu

Command with a submenu that can be attached to another control as a context menu.

· C1CommandMdiList : C1CommandMenu

Command which at runtime expands to the list of existing MDI child windows.

· C1CommandControl : C1CommandMenu

Command which can be associated with an arbitrary control. The control is displayed inside the command link connected to the command (this command allows at most one command link to be connected to it).


Other Components

· C1CommandHolder : System.ComponentModel.Component

Container for all commands on a form. Only one object per form is allowed, and is always automatically created when a menu or toolbar is added to the form.

· C1MainMenu : System.Windows.Forms.Control

Control representing the main menu of a form.

· C1ToolBar : System.Windows.Forms.Control

Control representing a toolbar. Must be put in a C1CommandDock to have docking and floating behavior.

· C1CommandDock : System.Windows.Forms.Panel

A container providing docking and floating behavior to toolbars.

· C1DockingTab : System.Windows.Forms.Control

A tab control which manages a related set of pages.

· C1OutBar : System.Windows.Forms.Control

An outbar control which manages a related set of pages. It provides an Outlook-style tab container.


Designing Menus and Toolbars

This section briefly outlines how to create and edit a main menu, a toolbar and a context menu using C1Command components.

Designing a Menu System

Designing a Toolbar

Designing a Context Menu

Using C1Command In Visual Studio Design Time


Designing a Menu System

1. To start creating a main menu, select the C1MainMenu component from the toolbox and drop it on your form. The main menu will appear at the top of the form.

The menu will have a single item with the text “New Command”. This item (which is an “empty” item – not pointing to any command) is added automatically. Because this command link does not point to any command (there are none defined yet), it will have a disabled appearance. Note also that a new object of the type C1CommandHolder will appear in the component tray of your form like the picture shown below:

2. Select the New Command link in the C1mainmenu. The command link will be highlighted, and its properties will be shown in the properties window of the forms designer.

If you click on the (selected) command link again, a small dialog box will pop up below the link (note that this behavior – popping up that dialog box on second click – is present for empty command links only; for command links that already have a command linked, the same dialog box can be shown by selecting the “Edit…” item from the link’s context menu).

The picture below shows what the dialog box looks like when you click on New Command twice in the form:

As a shortcut, you can select the menu and right click which will cause the context menu to appear. This dialog box is used to create new commands, edit existing ones, or link command links to commands. The same dialog box is used to edit command links in dropdown menus and toolbars. The dialog box has the following fields:

· Command Text

Here you can type the text of the command, which will show up in the menu.

· Command Name

This is the name of the command component which can be used to access this command in the code.

· Create New Command

This checkbox allows you to toggle between creating a new command and linking to an existing one.

· Link to Existing Command

This list shows commands already created on the form. When you select an item from this list, the Create New Command checkbox is automatically unchecked.

· Command Type

This list shows the available command types. For existing commands, the actual command type is shown. When you select an item from this list, a command of the corresponding type will be created (the Create New Command checkbox is automatically checked in this case).

· Just below the Command Type list, a brief description of the currently selected command type is shown.

Note that the command type selected is C1CommandMenu. This creates a menu with a submenu, which is what is normally desired in the main menu of a form.

3. Type the desired text for the new command, enter an appropriate command name, and press OK to close the dialog box and create the new command. The command link will now point to that new command.

The picture below shows the new command. The name of the new command is Tools.

When a new C1CommandMenu is created, an empty command link is automatically added to it in the same way as an empty command link was automatically added to the new main menu. When you close the edit dialog box, that new command link will be selected in the dropdown menu (like the picture above).

Again, clicking on the C1CommandMenuwill pop up the command creation/edit dialog box. Repeating the process, you will be able to create the whole menu system.

NOTE: Just do not forget to select the C1CommandMenu type from the Command Type field in the dialog box for new commands when you want them to contain a submenu.

As was already noted, the edit dialog box appears when you click twice (not double-click though – double-clicking creates a command click handler instead) on an empty command link in a menu (or toolbar). This dialog box is also available from the context menu of a main menu, a dropdown menu or a toolbar.

A picture of C1MainMenu's context menu appears below:

Below is a brief description of the custom items added by C1Command components to their context menus:

· Edit…

Brings up the command edit dialog box for the currently selected command link. You can edit the currently linked command, or link to another (new or existing) command. This item is disabled when there is no currently selected command link.

· Insert Item…

Inserts a new command link before the current one, and brings up the command edit dialog box. This item is disabled when there is no currently selected command link.

The new item appears before the previous item in the picture below:

· Append Item…

Adds a new command link after the last one in the current menu or toolbar, and brings up the command edit dialog box for the new link.

The appended item appears after the previous item in the picture below:

· Add Child Item…

Adds a new command link to the menu (C1CommandMenu or C1ContextMenu) linked by the currently selected command link. This item is disabled unless the current command link is linked to a C1CommandMenu or C1ContextMenu type command.

The child item appears in the picture below:

· Link Properties

Selects the command link and shows its properties in the forms designer’s Properties window.

· Command Properties

Selects the command and shows its properties in the forms designer’s Properties window. Note that for non-empty links, clicking a link toggles between link’s own and linked command’s properties.

· About…

Shows the C1Command About box.

Note that all menu-editing actions are fully undoable using the Visual Studio’s Undo facility.


Designing a Toolbar

To design a toolbar, select the C1ToolBar component from the Visual Studio toolbox, and drop it on your form. As with main menus and submenus, the newly created toolbar will contain a single empty command link. Clicking on it twice, or right-clicking and selecting Edit from the context menu will bring up the already familiar command edit dialog box. There you can either create a new command, or link to an existing command from the list. Designing a toolbar is not really different from designing a menu. Note that you can add submenus (commands of type C1CommandMenu or C1ContextMenu) to toolbars in the same way as to menus. You can even link to existing menus.

As with menus, all toolbar editing actions are fully undoable using the Visual Studio’s Undo facility.


Designing a Context Menu

To create a context menu, select the C1ContextMenu in the Visual Studio’s toolbox, and drop it onto your form. The new context menu (with an empty command link automatically added in the same way it is done for new menus and toolbars) will appear in your form’s component tray. You can right-click on the C1ContextMenu control and select “Edit…” from the context menu. The menu will be shown in the top left corner of the form, and you can edit it in the same way as you can edit main menu or its submenus.

Note that you can use C1ContextMenu objects anywhere a C1CommandMenu object is required. Thus, if you want to reuse the same menu as a submenu of the main menu and as a context menu for a control, you can create the submenu of the main menu as a C1ContextMenu, and then attach it as a context menu (extended property C1ContextMenu) to a control on the form.

The picture below shows the submenu of a main menu with a submenu of the main menu as a context menu:


Using C1Command In Visual Studio Design Time

C1Command Menus and Toolbars rely on installing a message filter (implementing the IMessageFilter interface) to implement main menu and some other functionality. In some cases (e.g. when C1Command is used in a component’s designer, and is run in Visual Studio’s design time), installing a message filter does not work. In such cases, C1Command can still be used. The code fragment below illustrates how to show a dialog form when a message filter could not be installed. You can use this approach for example if you want to show a dialog form in your component’s designer.

· Visual Basic

· C#

· Delphi


Converting Standard .NET Menus and Toolbars

C1Command comes with a Visual Studio add-in utility (converter) that can convert the standard .NET menus and toolbars defined on a form to C1Command-style menus and toolbars. After installation you can access the add-in via the Tools | Convert to C1Command... command of the Visual Studio’s menu.

To use the converter, open an existing project that has standard menus and toolbars defined on its forms. Make sure all designer windows are closed (the add-in cannot run with open designer windows). Select the Tools | Convert to C1Command... menu item. The converter start dialog box will pop up. Here you can specify which forms of your project to convert (by default, the converter will attempt to convert all forms), whether to create backups and whether to automatically save files after conversion. Set up the options as desired and press the Start button. That’s it, the converter will convert all your menus and toolbars to use C1Command. Some technical details follow:

· The converter can convert forms written in VB.NET or C# languages.

· The converter converts the following classes into corresponding C1Command classes:

System.Windows.Forms.MainMenu

System.Windows.Forms.MenuItem

System.Windows.Forms.ContextMenu

System.Windows.Forms.ToolBar

System.Windows.Forms.ToolBarButton

· The converter converts all relevant properties of the menus and toolbars, and also the Click event handlers of menu items.

· Because of the different handling of toolbar buttons in the standard .NET toolbars (individual buttons cannot have event handlers attached, all buttons of a toolbar must be handled by a single event handler), toolbar ButtonClick event handlers are not converted; such conversions should be done manually by the user.


C1Command Samples

Please be advised that this ComponentOne software title is accompanied by various sample projects and/or demos, which may or not make use of other ComponentOne development tools. While the sample projects and/or demos included with the software are used to demonstrate and highlight the product's features, and how the control may be integrated with the rest of the ComponentOne product line, some of the controls used in the demo/sample project may not be included with the purchase of certain individual products.

The ComponentOne Samples are also available at http://www.componentone.com/samples.


Visual Basic Samples

ProgramOutBar | This sample starts with a form containing a C1OutBar with two empty pages (created at design time). The form also contains an empty command holder. In the form load handler, several commands are created on the command holder. Two toolbars are also created and filled with links to the commands. The toolbars are placed on the outbar pages.
SimpleTextEditor | Shows the basic usage of C1Command menus and toolbars. Builds a rich text box-based text editor, with C1Command menus and floating toolbars. The toolbars are end user-customizable. Their layout and customizations are automatically saved by C1Command in the application config file. This sample uses C1ToolBar, C1ContextMenu, C1CommandMenu, C1Command, C1MainMenu, C1CommandLink, C1CommandDock, and C1CommandHolder controls.
SimpleTextEditor2 | Shows how to add an arbitrary control to a toolbar item. This sample is similar to SimpleTextEditor, but additionally includes a combo box nested in a movable and dockable C1ToolBar, implementing a simple text search. This sample uses C1Toolbar, C1CommandMenu, C1CommandControl, C1CommandDock, C1CommandHolder, C1CommandLink, C1MainMenu, C1Command, and C1ContextMenu controls.


C# Samples

CreateMenusInCode | Shows how to create and wire up context menus in code. Creates a C1ContextMenu for a text box completely in code, on a form that does not have any other C1Command elements. Wires up click event handlers for the menu items. Also sets up state query handlers for the commands so that their state (enabled etc.) is kept up to date automatically by C1Command. This sample calls the C1.Win.C1Command namespace.
MdiTab | This sample shows how to use C1DockingTab to create a Visual Studio-like multiple window environment.
NonMdiMenuMerge | Shows how to merge menus using methods provided by C1Command. This sample contains two forms, both with C1MainMenu's on them. One form is created at application startup, and it is the main form of the app. It has a command to create the other form. When that form is created, its main menu is merged programmatically into the main menu of the first form, in the same way as MDI child menus are merged in Windows. This sample uses C1CommandLink, C1MainMenu, C1Command, C1CommandMenu, and C1CommandHolder controls.
SelectMdiChildForm | This sample shows how to provide a customized MDI child form selector window. The sample project contains an inherited form, which is based on C1SelectMdiChildForm. The custom selector form overrides the default colors, and in addition to the two default buttons (ok and cancel), provides a new button close, which allows the selected window to close. This sample also shows how to invoke the selector form from code.
SimpleMenusInCode | This sample shows how to create menus and toolbars by customizing their appearance and attaching event handlers to them in code. The sample app is a form with a rich text editor control. The form load event handler creates C1Command commands to load a text file, create a new form, or exit the application. It also creates a main menu and a toolbar that allow the user to invoke those commands.


Task-Based Help

The task-based help assumes that you are familiar with programming in Visual Basic.NET. By following the steps outlined in the help, you will be able to utilize the features of ComponentOne Menus and ToolBars for .NET.

C1MainMenu Tasks

C1ToolBar Tasks

C1ContextMenu Tasks

C1DockingTab Tasks

C1OutBar Tasks


C1MainMenu Tasks

Adding a C1MainMenu

Inserting a Menu Item

Appending a Menu Item

Adding a Child Item

Adding Multiple SubMenus

Deleting Menu Items

Modifying the Appearance of the Menus

Displaying the Delimiter in Drop-Down Menus

Creating a SideCaption for a Command Menu

Displaying ToolTips for Menus and Toolbars

Applying ShortCut Keys to C1Menus


Adding a C1MainMenu

This topic demonstrates how to add a C1MainMenu and a C1CommandMenu control to your form.

C1MainMenu is a control that represents the main menu. It contains a collection of command links that represent items of the menu. Only one main menu can be added to the form.

C1CommandMenu is a command that is a menu.

You can add a C1MainMenu at design-time following the steps listed below:

1. Start a new Visual Basic .NET Windows Application project and add the C1Command component to the toolbox.

2. Place a C1MainMenu on the form by dragging and dropping the C1MainMenu onto the form. A C1CommandHolder will automatically appear at the bottom of the form such as the picture below:

3. Select the text, New Command, and right-click on it. The context menu will appear. Select Edit from the context menu.

4. After selecting Edit from the context menu, the Dialog Box appears. It will look like this:

5. In the Dialog Box, select the Command Text field and type menu 1. Select OK, in the Dialog Box. The new C1MainMenu called menu1 will appear. It will look like this on your form:

The exact same menu, menu1, can be created at run-time with a few simple steps:

1. Add the C1.Win.C1Command namespace to your references in your project.

2. Declare the namespace in your source file.

· Visual Basic

· C#

· Delphi

3. Add a C1CommandHolder to hold the menu.

· Visual Basic

· C#

· Delphi

4. Create a new main menu.

· Visual Basic

· C#

· Delphi

5. Add the main menu control to your form.

· Visual Basic

· C#

· Delphi

6. Create a sub-menu to hold commands.

· Visual Basic

· C#

· Delphi

7. Set the text property for the new menu.

· Visual Basic

· C#

· Delphi

8. Add the command link to the new sub-menu.

· Visual Basic

· C#

· Delphi

9. Save and run your application. Your new menu will appear like this at run-time:


Inserting a Menu Item

The purpose of this topic is to show you how to insert a menu item at design time by selecting the option, Insert Item, from C1MainMenu's context menu. The command, Insert Item, will insert a new menu item before the current one.

1. Drag and drop the C1MainMenu control on your form.

2. Right-click on C1MainMenu and select, Insert Item from the context menu.

3. The Edit, dialog box will appear like the picture below:

4. Type Menu 1 in the Command Text field and select OK. The menu will appear like the one below:


Appending a Menu Item

This topic demonstrates how to add a new menu item at design time after the last one in the current menu.

1. Drag and drop the C1MainMenu control on your form.

2. Right-click on C1MainMenu. Select Append Item from the context menu. The Edit dialog box will appear like the picture below:

3. Type Menu 2 in the Command Text field and select OK. The menu will appear like the one below on your form at design time:


Adding a Child Item

This topic demonstrates how to add a new command link to the menu (C1CommandMenu or C1ContextMenu) linked by the currently selected command link. This item is disabled unless the current command link is linked to a C1CommandMenu or C1ContextMenu type command.

1. Right-click on an item in the C1MainMenu. Select Add Child Item from the context menu. The Edit dialog box will appear like the picture below:

2. Type submenu 1 in the Command Text field and select OK. The menu will appear like the one below:

The exact same menu, menu1, and submenu,submenu1, can be created at run-time with a few simple steps:

1. Add the C1.Win.C1Command namespace to your references in your project.

2. Declare the namespace in your source file.

· Visual Basic

· C#

· Delphi

3. Add a C1CommandHolder to hold the menu.

· Visual Basic

· C#

· Delphi

4. Create a new main menu.

· Visual Basic

· C#

· Delphi

5. Add the main menu control to your form.

· Visual Basic

· C#

· Delphi

6. Create the main menu to hold commands.

· Visual Basic

· C#

· Delphi

7. Set the text property for the new menu.

· Visual Basic

· C#

· Delphi

8. Add the commandlink to the new main menu.

· Visual Basic

· C#

· Delphi

9. Create and set up a menu item under the menu, menu 1. Fill the menu with a command.

· Visual Basic

· C#

· Delphi

10. Add text to the new sub menu item and add a new c1commandlink to the submenu item.

· Visual Basic

· C#

· Delphi

11. Your menu should appear exactly like the menu below.


Adding Multiple SubMenus

This topic demonstrates how to add a submenu and another menu within the submenu at design-time.

1. Drag and drop the C1MainMenu control on your form.

2. Right-click on the C1MainMenu and select Edit from its context menu.

3. The Edit dialog box will appear. In the Command Text field box type, menu 1, and select ok.

4. The menu will appear like this on your form:

5. Click on the New Command and select Edit from its context menu. In the Command Text field box type, Menu Item 1, and select ok.

6. When you click on menu 1 at design time on your form the menu will appear like this:

7. Select Menu Item 1, on the form and select Append Item from its context menu.

8. The Edit dialog box will appear. In the Command Text field box type, Menu Item 2, and select ok. The menu will appear like this on your form at design time:

9. Select Menu Item 2 on your form and select Edit from its context menu. The Edit dialog box will appear. In the Command Type box select C1CommandMenu and then select OK.

10. The Menu Item 2 will now be a C1CommandMenu that can hold multiple menus inside it.

11. Select the New Command menu item and select Edit from its context menu. In the Command Text field box type, Submenu1, and select ok. The menu will appear like this on your form at design time:

This topic demonstrates how to add a submenu and another menu within the submenu at run time.

1. Add the C1.Win.C1Command namespace to your references in your project.

2. Declare the namespace in your source file.

· Visual Basic

· C#

· Delphi

3. Add a C1CommandHolder to hold the menu.

· Visual Basic

· C#

· Delphi

4. Create a new main menu.

· Visual Basic

· C#

· Delphi

5. Add the main menu control to your form.

· Visual Basic

· C#

· Delphi

6. Create the main menu to hold commands.

· Visual Basic

· C#

· Delphi

7. Set the text property for the new menu.

· Visual Basic

· C#

· Delphi

8. Add the commandlink to the new main menu.

· Visual Basic

· C#

· Delphi

9. Create and set up a menu item under the menu, menu 1. Fill the menu with a command.

· Visual Basic

· C#

· Delphi

10. Add text to the new menu item and add a new c1commandlink to menuitem1.

· Visual Basic

· C#

· Delphi

11. Create a new command menu for the second menu item below the menu, menu1, and call it menuitem2. Menuitem2 is going to be a menu that contains submenus.

· Visual Basic

· C#

· Delphi

12. Add a new commandlink for the new menuitem2 menu.

· Visual Basic

· C#

· Delphi

13. Create a submenu for the new menuitem2 menu and call it Submenu 1.

· Visual Basic

· C#

· Delphi

14. Add a new commandlink for the new submenu1.

· Visual Basic

· C#

· Delphi

15. Save and run your application. Your menus will look like this at run-time:


Deleting Menu Items

When a menu item is highlighted, and you press the Del key or select delete from the context menu, either the command link or the command (simple or menu) linked by that link can be deleted, depending on which one is currently selected. (To check what is currently selected, look at the properties window of the Visual Studio designer.)

To delete the command link (this will leave the command, so that you can link to it from another command link):

1. Click once on the menu item you want to delete. Make sure that the properties window shows the properties of the command link and not the command.

2. Right-click on the item to open the context menu and select delete, or simply press the Del key.

To delete the command itself (this will remove the command but leave the command link so that you’ll be able to link it to another command or menu):

1. Click on the menu item you want to delete. Then click on it again, that will select the command rather than the command link. Make sure that the properties window shows the properties of the command and not the command link.

2. Right-click on the item to open the context menu and select delete, or simply press the Del key. The command will be deleted, the now empty command link will be left. You can re-link it to another command by right-clicking on it and selecting edit from the context menu.

At Run-Time:

You can delete the menu by using the Dispose Method. For example, if you want to delete the menu or menu item you would write the following code:

· Visual Basic

· C#

· Delphi


Modifying the Appearance of the Menus

This topic demonstrates how to modify C1MainMenu's properties by using the property editor at design time.

By using the associated properties, you can customize each menu item.

1. Right-click on the C1MainMenu control. Select the Menu Properties in the context menu or you can view C1MainMenu's properties in the properties toolbox.

2. Select C1MainMenu1 from the properties drop-down box and set the related Font properties to:

· Font – Verdana

· Font Style – Regular

· Font Size – 8pt

3. Select C1MainMenu1 control from the properties drop-down box and set the properties to:

· BackColor – Select the Web tab and select Alice Blue.

· BackHiColor – #66CCFF

· ForeColor – Select the Web tab and select Navy.

· ForeHiColor – Black.

4. Build and run the web application and note:

· Unless otherwise modified, the sub-menu items inherit formatting from the parent Menu.

· You can modify the individual items as necessary.

The appearance of the C1MainMenu will look like the picture below:

NOTE: The picture displayed below illustrates the appearance of the C1MainMenu after following the tutorial, but it does not illustrate how the content will appear since we did not add any content in the tutorial above.


Displaying the Delimiter in Drop-Down Menus

This topic demonstrates how to display a delimiter in the drop-down menu by creating a command link without a command and with text surrounded by "-".

1. Right-click a command from an existing drop-down menu and select Append Item from its context menu.

2. A new command will appear. In the New Command's Edit dialog box, delete the name in the Command Name field so its blank. In the Command Text field change it to a hyphen. The properties, Command Text, and Command Name should appear like the Edit dialog box shown below.

3. Select OK and your command link will appear as a delimiter like the one shown below.


Creating a SideCaption for a Command Menu

This topic shows how to use the C1CommandMenu.SideCaption property at design-time to display a side caption along the commands.

1. Select a C1CommandMenu from the Properties drop-down box.

2. Locate and expand the SideCaption node.

3. Select the BarGradientBegin property and select Powder Blue from its Web tab.

4. Select the BarGradientEnd property and select Teal from its Web tab.

5. Set SideCaption.Text property to "Physics 101".

6. The side caption will appear along side of the menus. The appearance of the side caption will look similar to the image below:

Note: The text displayed in the side caption represents the name of the class that participated in the field trips.


Displaying ToolTips for Menus and Toolbars

This topic demonstrates how to customize the tool tips by creating your own tool tips for menus and toolbars. Both the menus and toolbars have the property called ToolTips that provides users the ability to display tool tips when the user mouses over a menu or a toolbar.

Displaying ToolTips for Menu Items

1. Select the C1CommandMenu.

2. The command link's properties for the C1CommandMenu will appear in the properties toolbox on the right-pane. In the C1CommandMenu properties expand the Command properties.

3. Set the ShowToolTips property under the Command's properties to true. This will enable the text of the ToolTipText's property to appear when the user mouses over the menus.

4. Select a C1Command menu item on the form that you want the tool tips to appear. Set the ShowTextAsToolTip to False. Setting the ShowTextAsToolTip to False will not make the command's text appear for the selected menu item in the C1CommandMenu when the user mouses over the menus. Select the ToolTipText property and enter the information in the textbox that you want to appear when the user mouses over the menu item.

5. Save and run your application. Below is what the ToolTipText will look like at run-time:

Displaying ToolTips for Buttons on the Toolbar

1. Select the toolbar button from the C1Toolbar control on your form.

2. The command link's properties for the C1Toolbar will appear in the properties toolbox on the right-pane. In the C1CommandLinks properties expand the Command properties.

3. Set the ShowTextAsToolTip to False. Select the ToolTipText property and enter the information in the textbox that you want to appear when the user mouses over the toolbar button.

4. Save and run your application. Here is what the tool tip text will look like for the toolbar button when you mouse over the volcano:

NOTE: If you leave the ShowTextAsToolTip property to its default value, true, then the toolbar button's text will be displayed when the user mouses over the toolbar button rather than the Tooltips text. Also, delete the information that you entered for the ToolTipsText property in the toolbox. The picture below illustrates this example:

Displaying ToolTips Text for Buttons on the Outbar

You can follow the same procedure listed above to display Tooltips for buttons on the outbar.


Applying ShortCut Keys to C1Menus

This topic demonstrates how to use shortcut and mnemonic keys to access a menu by the keyboard instead of the mouse.

At Design-time:

1. Add a C1MainMenu control to your form.

2. Right-click the c1MainMenu control and select Edit from the context menu.

3. Choose OK in the Edit dialog box.

4. The default name for the menu is New Command.

5. Select the 'New Command' item on your form. The properties for C1Command's menu will appear on the right-pane in the properties toolbox.

6. Select the short-cut key that you want to use for the command menu in the drop down of C1Command's ShortCut key property.

NOTE: The remaining steps are listed below for you to try and see how the short cut key functions.

7. Add a picturebox to your form.

8. Double-click on the New Command menu on your form.

9. The following line of code will appear after double clicking on the menu in your source file:

private void c1CommandMenu1_Click(object sender, C1.Win.C1Command.ClickEventArgs e){ }.

10. Type the following code in between the brackets, { }:

· Visual Basic

· C#

· Delphi

11. Run the application and press the F6 key once the form appears. The picturebox should appear on your form.

At Run-time:

1. In your source file locate the item in the menu where you want the shortcut key to exist.

2. Create a shortcut key for the C1CommmandMenu1 by entering the following code:

· Visual Basic

· C#

· Delphi


C1ToolBar Tasks

Adding a C1ToolBar

Modifying the Appearance of the Toolbar

Adding an Image to Your Toolbar button in Code

Making the C1Toolbar Appear Like the Default Toolbar in Internet Explorer(IE)

Docking a Toolbar at Run-Time

Specifying a Docking/Floating Position (Top, Bottom, Left, or Right) For Your C1Toolbar

Adding Separators Between the Buttons

Changing the Position of the Toolbar from Horizontal to Vertical

Adding a C1CommandControl and an arbitrary control to your Toolbar


Adding a C1ToolBar

This topic demonstrates how to define a C1ToolBar toolbar.

1. Start a new Visual Basic .NET Windows Application project, and add the C1Command component to the toolbox.

2. Place a C1Toolbar component on the form. The C1Toolbar will appear on your form like this:

3. Right-click the C1Toolbar control and select Edit from the context menu. This will bring up the Edit dialog box for the selected toolbar item.

4. Type the text, File, in the Text property field.

5. Click on the drop down arrow in the ButtonLook property field. Select, Text, from the drop-down menu and then press the OK button.

6. Right-click on the C1Toolbar control and select Append Item from the context menu. The new command link will be added after the current one. The Edit dialog box will appear.

7. Type the text, Edit, in the Command Text field and press the OK button.

8. Select the new command link, Edit, in the form. The new commandlinks properties will appear on the right pane. Select the new commandlink's property, ButtonLook, from Default to Text. Press the OK button.

9. Right-click on the C1Toolbar control and select Insert Item from the context menu. The new command link will be added before the current one. The Edit dialog box will appear.

10. Type the text, View, in the Command Text field and press the OK button.

11. Select the new command link, Edit, in the form. The new commandlinks properties will appear on the right pane. Select the new commandlink's property, ButtonLook, from Default to Text. Press the OK button.

12. Build and run the windows application.

Your toolbar at run-time should look like the toolbar below:

The same toolbar above can be made in code.

1. Add the C1.Win.C1Command namespace to your references in your project.

2. Declare the namespace in your source file.

· Visual Basic

· C#

· Delphi

3. Add a C1CommandHolder to hold the toolbar.

· Visual Basic

· C#

· Delphi

4. Create a new C1Toolbar.

· Visual Basic

· C#

· Delphi

5. Add the toolbar to your control on your form.

· Visual Basic

· C#

· Delphi

6. Assign the C1CommandHolder to the C1Toolbar.

· Visual Basic

· C#

· Delphi

7. Create a new command for the toolbar. The name for the new command will be called File.

· Visual Basic

· C#

· Delphi

8. Create a new commandlink for the new command in the toolbar.

· Visual Basic

· C#

· Delphi

9. Add the new commandlink to the toolbar.

· Visual Basic

· C#

· Delphi

10. Make the commandlink appear as text.

· Visual Basic

· C#

· Delphi

11. Create another command for the toolbar and call it View.

· Visual Basic

· C#

· Delphi

12. Create a new commandlink for the new command, view, in the toolbar.

· Visual Basic

· C#

· Delphi

13. Add the new commandlink to the toolbar.

· Visual Basic

· C#

· Delphi

14. Make the commandlink for view appear as text.

· Visual Basic

· C#

· Delphi

15. Create another command for the toolbar and call it Edit.

· Visual Basic

· C#

· Delphi

16. Create a new commandlink for the new command, Edit, in the toolbar.

· Visual Basic

· C#

· Delphi

17. Add the new commandlink to the toolbar.

· Visual Basic

· C#

· Delphi

18. Make the command link for the edit toolbar button to appear as text.

· Visual Basic

· C#

· Delphi

19. Save and run your application. Your toolbar will appear like this at run-time:


Modifying the Appearance of the Toolbar

This topic demonstrates how to modify the appearance of the toolbar.

1. Select the drop down arrow in the properties toolbox and select C1Toolbar.

2. Expand the Font properties of the C1Toolbar Component. Set the following Font properties:

Font.Name property to "Arial".

Font.Size property to "9".

3. Set BackColor to "#0066CC".

4. Set BackHiColor to "Pale Turquoise".

5. Set ForeColor to "White".

6. Set ForeHicolor to "#003399".

7. Expand the Border properties of the C1Toolbar Component. Set the following Border properties:

Border.Light Color to "Pale Turquoise".

Border.Style to "Outset".

Border.Width to "3".

Your toolbar at run-time should look like the toolbar below:


Adding an Image to Your Toolbar button in Code

This topic demonstrates how to add an image to your toolbar button in code. This topic assumes you have a toolbar button created.

1. Locate the command in your source file that you want to add an image to.

2. Type the following code to add an image to your toolbar button:

· Visual Basic

· C#

· Delphi


Making the C1Toolbar Appear Like the Default Toolbar in Internet Explorer(IE)

This topic demonstrates how to make the C1Toolbar appear like the default toolbar in IE by using the ButtonLookFlags enumeration. The ButtonLookFlags enumeration contains the parameters: Text, TextAndImage, Image, and Default. These parameters give you the ability to modify your toolbar button to show text, text and an image, or just an image.

The following code demonstrates how you can make the C1Toolbar appear like the default toolbar in IE. In this example I use all of the parameters(TextAndImage, Image, Default, and Text)contained in the ButtonLookFlags enumeration to make the C1Toolbar appear similar to the IE toolbar.

1. Create the first toolbar button and make it appear as an image. The code below shows you how to use the ButtonLookFlags enumeration to make the toolbar button appear as an image.

· Visual Basic

· C#

· Delphi

2. Create a second toolbar button and make it appear as text and image. The code below shows you how to use the ButtonLookFlags enumeration to make the toolbar button appear as text and an image.

· Visual Basic

· C#

· Delphi

3. Create a third toolbar button and make it appear as the default appearance. The code below shows you how to use the ButtonLookFlags enumeration to make the toolbar button appear as the default appearance.

· Visual Basic

· C#

· Delphi

4. Create a fourth toolbar button and make it appear as the default appearance. The code below shows you how to use the ButtonLookFlags enumeration to make the toolbar button appear as the default appearance.

· Visual Basic

· C#

· Delphi

5. Save and run your application. Your C1Toolbar will appear similar to the toolbar below:

NOTE: Your images in your toolbar will appear different from the images in the toolbar below. The first, second, third, and fourth toolbar button are shown as an image, text and image, default, and text, respectively.


Docking a Toolbar at Run-Time

This topic demonstrates how to make a C1Toolbar dockable by using the C1CommandDock class. This topic assumes you have a C1Toolbar created in code.

1. Create a new C1CommandDock and call it dock.

· Visual Basic

· C#

· Delphi

2. Add the C1CommandDock to your control so it will appear on the form.

· Visual Basic

· C#

· Delphi


Specifying a Docking/Floating Position (Top, Bottom, Left, or Right) For Your C1Toolbar

This topic demonstrates how to specify a position for your C1CommandDock in code.

Dock your toolbar to the top

The code below docks the toolbar to the top.

· Visual Basic

· C#

· Delphi

NOTE: If you want to dock your toolbar to the bottom, left, or right, change the Top parameter to its desired position: bottom, left, or right.


Adding Separators Between the Buttons

This topic demonstrates how to add separators between the buttons.

1. Select the second toolbar button from the C1Toolbar control on your form.

2. The commandlinks properties for the toolbar button will appear in the properties toolbox on the right-pane.

3. Locate the appearance properties and set the Delimiter property to True.

4. Save and run your application. Here is what the button separator will look like:


Changing the Position of the Toolbar from Horizontal to Vertical

This topic uses the Horizontal property to demonstrate how to change the position of the toolbars from horizontal to vertical.

1. Create a toolbar.

2. Use the code below to make the toolbar appear vertical.

· Visual Basic

· C#

· Delphi


Adding a C1CommandControl and an arbitrary control to your Toolbar

This topic demonstrates how arbitrary controls can be contained in the toolbar by using the C1CommandControl object. It also demonstrates how to use the C1CommandDock.

1. Start a new Visual Basic .NET Windows Application project, and add the C1Command component to the toolbox.

2. Select the C1CommandDock control and drag and drop it on the top of your form.

3. Select the C1Toolbar control and drag and drop it onto the C1CommandDock, located at the top of your form. It will appear like this on your form:

4. Right-click on the C1Toolbar located on your form. Select Edit from the context menu. The Edit dialog box will appear:

Set the following properties in the Edit dialog box:

· Command Text to "Find text:".

· Command Name to "C1CommandControl1".

· Command Type to "C1CommandControl".

Press the OK button in the Edit dialog box.

5. Select the drop-down arrow in the ButtonLook property field in C1CommandLink1's properties toolbox. Select "Text" from the ButtonLook property. The "Find Text" will automatically appear in the Toolbar.

6. Select the Windows Form tab and drag and drop the combo box control to the right side of the c1toolbar. The Combo Box will appear like this on your form:

7. Locate the Text property in the properties toolbox for Combo Box and delete the text, ComboBox1.

8. Select the C1Toolbar control and select the ellipses button in the Command Links property field. The C1CommandLinkCollection Editor will appear. Expand the Command property field.

9. Select the Control property field and select ComboBox1 from the drop-down box.

10. Click on the OK button in the C1CommandLinkCollection Editor.

11. Run and build the application. Your toolbar will appear like this at run-time:


C1ContextMenu Tasks

Creating a ContextMenu

Creating a Context Menu and Associating it with a Control at Run-Time


Creating a ContextMenu

This topic demonstrates how to create a context menu and associate it with a menu item. In this particular example, I use the C1MainMenu control and associate a context menu with the menu item in the C1MainMenu.

At design-time:

1. Start a new Visual Basic .NET Windows Application project and add the C1Command component to the toolbox.

2. Place a C1MainMenu on the form by dragging and dropping it onto the form.

3. Select the text, New Command, and right-click on it. The context menu will appear. Select Edit from the context menu. The Edit dialog box will appear.

4. In the Edit dialog box, change the following field properties:

· Command Text to "File".

· Command Name to "MenuFile".

· Command Type to "C1Context Menu". This will create a command with a sub-menu which can be used as a context menu. Select OK, in the Edit dialog box. The new C1MainMenu, File will appear.

5. Press the OK button in the Edit dialog box.

6. Right-click on the File menu and select Edit from the context menu. The Edit dialog box will paper. Set the following properties in the Edit dialog box:

· Command Text to "New".

· Command Name to "cmdFileNew".

· CommandType to "C1Command".

7. Press the Ok button in the Edit dialog box.

8. Select the 'New' menu and right-click it.

9. Select Append Item from the context menu. This will add a new command link below the current one.

10. The Edit dialog box will appear. Set the following properties in the dialog box:

· Command Text to "Open".

· CommandName to "cmdFileOpen".

· CommandType to "C1Command".

11. Press the OK button in the Edit dialog box.

12. Select the Windows Form tab from the Toolbox and drag and drop the RichTextBox control onto your form.

13. Select the RichTextBox control on your form. In the RichTextBox1 properties, delete the text, RichTextBox1, from the Text property field.

14. Select the drop-down arrow in the RichTextBox.Dock property field and select the middle rectangle.

15. Select the MenuFile from the properties' s drop-down box.

16. Select the Category property and type the text, File in the field.

17. Select the drop-down arrow in the C1ContextMenu on C1CommandHolder property and select MenuFile.

18. Run and build the application. Your context menu at run-time should look like the context menu below:


Creating a Context Menu and Associating it with a Control at Run-Time

This topic demonstrates how to create a context menu for a text box in code, on a form that does not have any other c1command elements. This topic also demonstrates how to use click event handlers for the menu items and query event handlers for the commands so their state is kept up to date automatically by C1Command.

1. Drag and drop the button control and text box onto your form.

2. Double-click on the button control. The source file will appear.

3. Attach the C1.Win.C1Command to your reference project located in the solution explorer.

4. Add the C1.Win.C1Command namespace to your source file.

5. Create a C1CommandHolder so it will hold the command. The following code below will create a CommandHolder:

NOTE: Use the try and catch method if you want to create more than one command holder for a form. This will catch and ignore the exception when the second attempt to create another commandholder fails.

· Visual Basic

· C#

· Delphi

6. Create and set up a copy command. The following code below will create a copy command to copy text into the TextBox control:

· Visual Basic

· C#

· Delphi

7. Use the click event to enable the user to call the copy command when the user clicks on the menu item. Also set up state query handlers for the commands so their command is kept up to date automatically by c1command. Use the code below:

· Visual Basic

· C#

· Delphi

8. Create a context menu to hold the copy command. In order to create a context menu you must create a command in the C1CommandHolder and assign it to the context menu. Use the CreateCommand method from the C1CommandHolder class. Use the code below:

· Visual Basic

· C#

· Delphi

9. Assign the context menu to the text box control. Use the SetC1ContextMenu method from the C1CommandHolder class to set the new context menu within the C1CommandHolder. The following code below shows how to assign the new context menu to the text box:

· Visual Basic

· C#

· Delphi

10. Invoke the clickCopy method to handle the copy command action. Use the queryCopy method to provide the current state of the copy command. When you click the copy command from the context menu, the current text will be copied into the textbox.. You can achieve this by using the following code:

· Visual Basic

· C#

· Delphi

Save and run the application. Here is what the context menu will appear like:


C1DockingTab Tasks

Adding a DockingTab

Moving TabPages at Run-Time


Adding a DockingTab

This topic demonstrates how to add a C1DockingTab to your form.

1. Drag and drop the C1CommandDock control onto your form.

2. The C1CommandDock will dock to the left side of the form. Select the drop-down arrow in the Dock property field for C1CommandDock's properties. Select the top rectangle. This will dock the C1CommandDock control to the top of the form.

3. Drag and drop the C1DockingTab control inside the C1CommandDock control. It will appear like this on your form:

4. Build and run the application. Your dockingtab at run-time should look like the dockingtab below:


Moving TabPages at Run-Time

This topic demonstrates how to move tabs in different positions by using the CanMoveTabs property.

· In the properties toolbox set the C1DockingTab.CanMoveTabs to true.


C1OutBar Tasks

Adding a C1OutBar

Adding a C1OutPage to the C1OutBar at Run-Time

Adding Multiple C1OutPages to C1OutBar at Design-Time

Modifying the Appearance of the C1OutBar


Adding a C1OutBar

This topic demonstrates how to add a C1OutBar at design-time.

1. Start a new Visual Basic .NET Windows Application project and add the C1Command component to the toolbox.

2. Select the C1OutBar component from the toolbox and drag and drop in onto the form. The newly created C1OutBar will initially contain a single page with a C1ToolBar control on it (C1OutBar pages can contain either C1ToolBar controls which are specially treated in that case, or arbitrary other controls, as e.g. pages of a tab control). Also, a C1CommandHolder will be automatically created and placed on the components tray Here is what the C1OutBar will look like on your form:

3. Select C1OutPage1 and locate C1OutPage1's properties in the properties window. Select the text property and change it from 'Page1' to 'File'.

4. Right-click on the (only) item in the C1ToolBar. Select Append Item… from the context menu. The Edit dialog box will appear like the picture below:

5. In the Edit dialog box set the following properties:

· Command Text to "New".

· Command Name to "cmdFileNew".

· Command Type to "C1Command".

6. Select the OK button in the Edit dialog box.

7. Select the C1CommandLink1 and select the ButtonLook property field to "TextAndImage”.

8. Select the cmdFileNew and locate its image property. Click on the ellipsis button and locate the desired image. Select the image and click on the Open button in the File Open dialog box. The new image will appear above C1CommandLink1's text. Your C1CommandLink1 should look similar to the picture below:

9. Run and Build the application. It will look similar to this image at run-time:


Adding a C1OutPage to the C1OutBar at Run-Time

This topic demonstrates how to add a new C1OutPage to the C1OutBar at run-time.

1. Start a new Visual Basic .NET Windows Application project and add the C1OutBar control to the form.

2. Import the C1.Win.C1Command namespace. The code below imports the C1.Win.C1Command namespace.

· Visual Basic

· C#

· Delphi

3. Add a new C1OutPage to the C1OutBar. The last line of code uses the Add method to add the new outpage1 to the C1OutBar1.

· Visual Basic

· C#

· Delphi

4. Run and build the new page you created for C1OutBar. It appears like the image below at run-time:


Adding Multiple C1OutPages to C1OutBar at Design-Time

This topic demonstrates how to add a new C1OutPage to a new C1OutBar at design time.

1. Start a new Visual Basic .NET Windows Application project and add the C1Command component to the toolbox.

2. Select the C1OutBar component from the toolbox and drag and drop in onto the form. The C1OutBar will consist of a C1OutPage and a C1Toolbar.

3. Select the C1OutPage1 and right-click it. Select Add Toolbar from the context menu.

4. The new C1OutPage2 appears similar to the picture below:

5. You can create several C1OutPages by right-clicking on the C1OutPage and selecting Add Toolbar from its context menu.


Modifying the Appearance of the C1OutBar

This topic demonstrates how to modify the appearance of the C1OutBar at design-time.

1. Start a new Visual Basic .NET Windows Application project and add the C1Command component to the toolbox.

2. Select the C1OutBar component from the toolbox and drag and drop in onto the form. The C1OutBar will consist of a C1OutPage and a C1Toolbar.

3. Right-click on Page1 and locate C1OutPage1's properties in its toolbox. Select the text property field and change it from 'Page1' to 'Going Places'.

4. Right-click in the C1Toolbar on the form and select Append Item from the context menu. A new command and an Edit dialog box appears.

5. In the Edit dialog box set the following properties:

· Command Text to "Air Tickets"

· Command Name to "cmdGPAirTicket"

· Command Type to "C1Command"

6. Select the OK button in the Edit dialog box.

7. Select the C1CommandLink1 from the Properties window drop-down box and set its ButtonLook property to "TextAndImage".

8. In the C1CommandLink1's properties window, expand the Command properties node and click on the three ellipses button in the image properties field. The Open dialog box appears. Browse for an image to add to the Air tickets command link. The new image appears in the Air tickets command link.

9. Select the Air tickets commandlink on the toolbar and select Append Item from its context menu. A new commandlink appears in the toolbar.

10. In the Edit dialog box set the following properties:

· Command Text to "City Guides"

· Command Name to "cmdGPCityGuides"

· Command Type to "C1Command"

11. Select the OK button in the Edit dialog box.

12. Select the C1CommandLink2, City Guides, on the toolbar and set its ButtonLook property field to "TextAndImage".

13. Expand the Command properties node in CommandLink2's properties window and click on the three ellipses button in the image properties field. Select the desired image and click on the Open button in the Open dialog box. The new image will appear above C1CommandLink2's text.

14. Select C1OutPage1 from the Properties drop-down list box and modify its properties to the following:

· Expand the Font Property and set Bold to True.

· Select the BorderStyle property and select FixedSingle from its drop-down box.

15. Select the C1Toolbar1 on the form and go to its properties toolbox and set its following properties:

· BackColor to "White"

· BackHiColor to "SkyBlue"

16. Select C1OutBar1from the properties drop-down list box and set its properties to the following:

· BackColor to "#CC99FF"

· Font.Size to "9"

· Bold to "True"

17. Right-click on Going Places and select Add Toolbar from the context menu. A new C1OutPage2 appears below the C1OutPage1, Going Places.

18. Select C1OutPage2 from the drop-down list in the Properties window and set its Text property to Browse.

19. Right-click in the C1Toolbar2 on the form and select Append Item from the context menu. The Edit dialog box appears below the new command.

20. In the Edit dialog box set the following properties:

· Command Text to "Electronics"

· Command Name to "cmdBrowseElectronics".

· Command Type to "C1Command"

21. Select the OK button in the Edit dialog box.

22. Select the C1CommandLink3, Electronics, on the toolbar and set its ButtonLook property to "Text".

23. Select C1Toolbar2 from the Properties window drop-down list box and set its properties to the following:

· BackColor to "Teal"

· BackHiColor to "MediumAquamarine"

· ButtonAlign to "Near"

· ForeColor to "White"

24. Build and the run the application.

The C1OutBar 's Going Places out page appears like the image below:

Note: The images will differ depending on what type of image you selected for C1ComandLink1 and C1CommandLink2.

The C1OutBar's Browse out page at run-time appears like picture below:


C1Command Reference

C1Border class

C1Command class

C1CommandControl class

C1CommandMenu class

C1ContextMenu class

C1CommandMdiList class

C1CommandLink class

C1CommandLinks class

C1CommandHolder class

C1MainMenu class

C1OutBar class

C1OutPage class

C1OutPages class

C1SideCaption class

C1ToolBar class

C1CommandDock class

C1DockingTab class

C1DockingTabPage class

C1DockingTabPageControlCollection class

C1DockingTabPages Class

Event Handler Delegates

Helper classes

Event Argument Classes

Enumerations


C1Border class

This class allows you to add borders to a C1ToolBar object.


C1Border Members

C1Border Public Properties

BottomEdge | Determines whether the border has a bottom edge.
DarkColor | Gets or sets the dark color of the border.
LeftEdge | Determines whether the border has a left edge.
LightColor | Gets or sets the light color of the border.
RightEdge | Determines whether the border has a right edge.
Style | Gets or sets the border style.
TopEdge | Determines whether the border has a top edge.
Width | Gets or sets the width of the border.

C1Border Public Methods

FrameIt | Sets or removes all borders.
IsFrameOff | Returns true if the border is completely invisible.
IsFrameOn | Returns true if the border is visible on all four sides.


C1Border Properties

BottomEdge Property

DarkColor Property

LeftEdge Property

LightColor Property

RightEdge Property

Style Property

TopEdge Property

Width Property (C1Border)


BottomEdge Property

BottomEdge Property

Determines whether the border has a bottom edge.

Syntax

[VB]

Public Property BottomEdge As Boolean

[C#]

public bool BottomEdge {get; set;}

[Delphi]

property BottomEdge: Boolean;

See Also

C1Border class


DarkColor Property

DarkColor Property

Gets or sets the color of the border.

Syntax

[VB]

Public Property DarkColor As Color

[C#]

public Color DarkColor {get; set;}

[Delphi]

property DarkColor: Color;

See Also

C1Border class


LeftEdge Property

LeftEdge Property

Determines whether the border has a left edge.

Syntax

[VB]

Public Property LeftEdge As Boolean

[C#]

public bool LeftEdge {get; set;}

[Delphi]

property LeftEdge: Boolean;

See Also

C1Border class


LightColor Property

LightColor Property

Gets or sets the color of the border.

Syntax

[VB]

Public Property LightColor As Color

[C#]

public Color LightColor {get; set;}

[Delphi]

property LightColor: Color;

See Also

C1Border class


RightEdge Property

RightEdge Property

Determines whether the border has a right edge.

Syntax

[VB]

Public Property RightEdge As Boolean

[C#]

public bool RightEdge {get; set;}

[Delphi]

property RightEdge: Boolean;

See Also

C1Border class


Style Property

Style Property

Gets or sets the border style.

Syntax

[VB]

Public Property Style As BorderStyleEnum

[C#]

public BorderStyleEnum Style {get; set;}

[Delphi]

property Style: BorderStyleEnum;

Remarks

Possible values of this property are:

Member Name | Description
Flat | Flat border.
Groove | Grooved border.
Inset | Inset border.
None | No border.
Outset | Outset border.
Ridge | Ridged border.

See Also

C1Border class


TopEdge Property

TopEdge Property

Determines whether the border has a top edge.

Syntax

[VB]

Public Property TopEdge As Boolean

[C#]

public bool TopEdge {get; set;}

[Delphi]

property TopEdge: Boolean;

See Also

C1Border class


Width Property (C1Border)

Width Property (C1Border)

Gets or sets the width of the border.

Syntax

[VB]

Public Property Width As Integer

[C#]

public int Width {get; set;}

[Delphi]

property Width: Integer;

See Also

C1Border class


C1Border Methods

FrameIt Method

IsFrameOff Method

IsFrameOn Method


FrameIt Method

FrameIt Method

Sets or removes all borders.

Syntax

[VB]

public sub FrameIt(ByVal framed As Boolean)

[C#]

public void FrameIt(bool framed)

[Delphi]

procedure FrameIt (framed: Boolean);

See Also

C1Border class


IsFrameOff Method

IsFrameOff Method

Returns true if the border is completely invisible.

Syntax

[VB]

public function IsFrameOff() As Boolean

[C#]

public bool IsFrameOff()

[Delphi]

function IsFrameOff: Boolean;

See Also

C1Border class


IsFrameOn Method

IsFrameOn Method

Returns true if the border is visible on all four sides.

Syntax

[VB]

public function IsFrameOn() As Boolean

[C#]

public bool IsFrameOn()

[Delphi]

function IsFrameOn: Boolean;

See Also

C1Border class


C1Command class

This class represents a basic executable command. An event handler can be attached to its Click event to execute the command. Most command-related properties such as text, shortcut, image, etc. are contained in this class. This class is also the base class for all other commands (e.g., menus).

Objects of this type are always stored in the C1CommandHolder object (a single instance that is created automatically per each form in the project containing commands). Either the C1CommandHolder or menus or toolbars created on the form can be used to access commands at design time. Commands themselves are not shown in the component tray (except for C1ContextMenu items).

At runtime, commands can be selected via command links (see the C1CommandLink class), or invoked directly by pressing a shortcut key.

C1Command Members

C1Command Properties

C1Command Methods

C1Command Events


C1Command Members

C1Command Public Properties

Category | Specifies the category of the command.
CheckAutoToggle | Determines whether the Checked property value is toggled automatically.
Checked | Determines whether the command is checked.
DropDown | Determines whether the command has a dropdown arrow when it is in a toolbar.
Enabled | Determines whether the command is enabled.
Icon | Gets or sets the command icon.
Image | Gets or sets the command image.
ImageIndex | Gets or sets the index of the command image.
IsParent | Determines whether this command is a non-empty submenu. Always False for C1Command objects (but may be True for an object of a derived class).
Mnemonic | Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.
Name | Gets or sets the name of the command. It is used for saving/restoring layout data in application config file
Owner | Specifies the C1CommandHolder containing this command.
Pressed | Gets or sets the value indicating whether the command is pressed.
Shortcut | Gets or sets the keyboard shortcut associated with the command.
ShowShortcut | Gets or sets the value indicating whether the shortcut for this command will be shown.
ShowTextAsToolTip | Gets or sets the value indicating whether this command's text will be shown as a tool tip in toolbars.
Text | Gets or sets the command text.
ToolTipText | Gets or sets the tool tip text.
UserData | Arbitrary data that can be associated with the command.
Visible | Determines whether the command is visible.

C1Command Public Methods

Invoke | Invokes the command.
PerformClick | Generates a click event for the C1Command. Same as Invoke.
PerformSelect | Selects the command.
StateQuery | Fires the CommandStateQuery event, updates any changed properties.

C1Command Public Events

CategoryChanged | Fires when the Category property of command is changed.
CheckedChanged | Fires when the Checked property has changed.
Click | Fires when the command is invoked by the user.
CommandLinkAdded | Fires after a command link is linked to this command.
CommandLinkRemoved | Fires after a command link is unlinked from this command.
CommandStateQuery | Fires when the command state has to be verified.
DropDownClicked | Event fired when the dropdown arrow is clicked on the toolbar button.
EnabledChanged | Event fired when the Enabled property of C1Command is changed.
ImageChanged | Event fired when the Image or ImageIndex or Icon property of C1Command is changed.
Select | Fires when the command is selected by the user.
ShowShortcutChanged | Event fired when the ShowShortcut property of C1Command is changed.
ShowTextAsToolTipChanged | Event fired when the ShowTextAsToolTip property of C1Command is changed.
TextChanged | Fires when the Text property of command is changed.
ToolTipChanged | Fires when the ToolTipText property of command is changed.
VisibleChanged | Event fired when the Visible property of C1Command is changed.


C1Command Properties

Category Property (C1Command)

CheckAutoToggle Property (C1Command)

Checked Property (C1Command)

DropDown Property (C1Command)

Enabled Property (C1Command)

Icon Property

Image Property (C1Command)

ImageIndex Property (C1Command)

IsParent Property (C1Command)

Mnemonic Property (C1Command)

Name Property (C1Command)

Owner Property (C1Command)

Pressed Property (C1Command)

Shortcut Property (C1Command)

ShowShortcut Property (C1Command)

ShowTextAsToolTip Property (C1Command)

Text Property (C1Command)

ToolTipText Property (C1Command)

UserData Property (C1Command)

Visible Property (C1Command)


Category Property (C1Command)

Category Property (C1Command)

Specifies the category of the command.

Syntax

[VB]

Public Property Category As String

[C#]

public string Category {get; set;}

[Delphi]

property Category: string;

See Also

C1Command class


CheckAutoToggle Property (C1Command)

CheckAutoToggle Property (C1Command)

Determines whether the Checked property value is toggled automatically.

Syntax

[VB]

Public Property CheckAutoToggle As Boolean

[C#]

public bool CheckAutoToggle {get; set}

[Delphi]

property CheckAutoToggle: Boolean;

Remarks

If True, the Checked property value is toggled automatically when this command is invoked.

See Also

C1Command class


Checked Property (C1Command)

Checked Property (C1Command)

Determines whether the command is checked.

Syntax

[VB]

Public Property Checked As Boolean

[C#]

public bool Checked {get; set;}

[Delphi]

property Checked: Boolean;

See Also

C1Command class


DropDown Property (C1Command)

DropDown Property (C1Command)

Determines whether the command has a dropdown arrow when it is in a toolbar.

Syntax

[VB]

Public Property DropDown As Boolean

[C#]

public bool DropDown {get; set;}

[Delphi]

property DropDown: Boolean;

Remarks

This property allows showing a drop-down arrow (such as displayed automatically for menus) near a non-menu command in a toolbar.

See Also

C1Command class


Enabled Property (C1Command)

Enabled Property (C1Command)

Determines whether the command is enabled.

Syntax

[VB]

Public Property Enabled As Boolean

[C#]

public bool Enabled {get; set;}

[Delphi]

property Enabled: Boolean;

See Also

C1Command class


Icon Property

Icon Property

Gets or sets the command icon.

Syntax

[VB]

Public Property Icon As System.Drawing.Icon

[C#]

public System.Drawing.Icon Icon {get; set;}

[Delphi]

property Icon: System.Drawing.Icon;

Remarks

The default value for this property is None. If the value is specified, it overrides the Image and ImageIndex properties.

Icons preserve transparency/alpha channels. No additional processing is done when drawing icons.

NOTE: This is different from images - e.g., In OfficeXP look and feel, an automatic shadow is drawn for images, images can be "smoothed", etc.; none of this occurs for icons.

See Also

C1Command class


Image Property (C1Command)

Image Property (C1Command)

Gets or sets the command image.

Syntax

[VB]

Public Property Image As Image

[C#]

public Image Image {get; set;}

[Delphi]

property Image: Image;

Remarks

An image can be attached to a command either directly via this property, or by specifying an image index [see the ImageIndex Property (C1Command)] into the image list attached to the command holder (see the C1CommandHolder class). Note that if a valid image can be found, the Image property will return it in both cases, but setting this property will overwrite the current ImageIndex if one is specified.

See Also

C1Command class


ImageIndex Property (C1Command)

ImageIndex Property (C1Command)

Gets or sets the index of the command image.

Syntax

[VB]

Public Property ImageIndex As Integer

[C#]

public int ImageIndex {get; set;}

[Delphi]

property ImageIndex: Integer;

Remarks

Specifies the index of the image in the image list attached to the command holder containing this command.

See Also

C1Command class

C1CommandHolder class

Image Property (C1Command)

ImageList Property


IsParent Property (C1Command)

IsParent Property (C1Command)

Determines whether this command is a non-empty submenu. Always False for C1Command objects (but may be True for an object of a derived class).

Syntax

[VB]

Public Overridable ReadOnly Property IsParent As Boolean

[C#]

public bool IsParent {get;}

[Delphi]

property IsParent: Boolean;

Remarks

This property is always False for C1Command objects. To create a submenu, C1CommandMenu (which is derived from C1Command) should be used.

See Also

C1Command class

C1CommandMenu class


Mnemonic Property (C1Command)

Mnemonic Property (C1Command)

Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.

Syntax

[VB]

Public ReadOnly Property Mnemonic As Char

[C#]

public char Mnemonic {get;}

[Delphi]

property Mnemonic: Char;

See Also

C1Command class


Name Property (C1Command)

Name Property (C1Command)

Gets or sets the name of the command. It is used for saving/restoring layout data in application config file

Syntax

[VB]

Public Property Name As String

[C#]

public string Name {get;set;}

[Delphi]

property Name: string;

See Also

C1Command class


Owner Property (C1Command)

Owner Property (C1Command)

Returns the C1CommandHolder containing this command.

Syntax

[VB]

Public ReadOnly Property Owner As C1CommandHolder

[C#]

public C1CommandHolder Owner {get;}

[Delphi]

property Owner: C1CommandHolder;

Remarks

Each C1Command (or a derived type) object is contained in a C1CommandHolder object (an instance of which is always created for any form containing C1Command objects). That class can be used to enumerate commands existing on a form.

See Also

C1Command class


Pressed Property (C1Command)

Pressed Property (C1Command)

Gets or sets the value indicating whether the command should be displayed as pressed.

Syntax

[VB]

Public Property Pressed As Boolean

[C#]

public bool Pressed {get; set;}

[Delphi]

property Pressed: Boolean;

See Also

C1Command class


Shortcut Property (C1Command)

Shortcut Property (C1Command)

Gets or sets the keyboard shortcut associated with the command.

Syntax

[VB]

Public Property Shortcut As Shortcut

[C#]

public Shortcut Shortcut {get; set;}

[Delphi]

property Shortcut: Shortcut;

See Also

C1Command class


ShowShortcut Property (C1Command)

ShowShortcut Property (C1Command)

Indicates whether the shortcut for this command will be shown.

Syntax

[VB]

Public ShowShortcut As Boolean

[C#]

public bool ShowShortcut {get; set;}

[Delphi]

property ShowShortcut: Boolean;

See Also

C1Command class


ShowTextAsToolTip Property (C1Command)

ShowTextAsToolTip Property (C1Command)

Indicates whether this command's text will be shown as a tool tip.

Syntax

[VB]

Public ShowTextToolTip As Boolean

[C#]

public bool ShowTextToolTip {get; set;}

[Delphi]

property ShowTextToolTip: Boolean;

Remarks

If this property is True, and no ToolTipText is specified for the command, the Text property will be shown as tooltip when appropriate (e.g., in a tool bar).

See Also

C1Command class


Text Property (C1Command)

Text Property (C1Command)

Specifies the command text.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: String;

See Also

C1Command class


ToolTipText Property (C1Command)

ToolTipText Property (C1Command)

Gets or sets the text for the tool tip.

Syntax

[VB]

Public ToolTipText As String

[C#]

public string ToolTipText {get; set;}

[Delphi]

property ToolTipText: string;

See Also

C1Command class


UserData Property (C1Command)

UserData Property (C1Command)

Arbitrary data that can be associated with the command.

Syntax

[VB]

Public UserData As Object

[C#]

public object UserData {get; set;}

[Delphi]

property UserData: Object;

See Also

C1Command class


Visible Property (C1Command)

Visible Property (C1Command)

Determines whether the command is visible.

Syntax

[VB]

Public Visible as Boolean

[C#]

public bool Visible {get; set;}

[Delphi]

property Visible: Boolean;

See Also

C1Command class


C1Command Methods

Invoke Method (C1Command)

PerformClick Method (C1Command)

PerformSelect Method (C1Command)

StateQuery Method (C1Command)


Invoke Method (C1Command)

Invoke Method (C1Command)

Invokes the command.

Syntax

[VB]

Public Overridable Sub Invoke()

[C#]

public virtual void Invoke (ClickEventArgs e )

[Delphi]

procedure Invoke(e: ClickEventArgs); virtual;

See Also

C1Command class


PerformClick Method (C1Command)

PerformClick Method (C1Command)

Generates a click event for the C1Command.

Syntax

[VB]

Public Sub PerformClick()

[C#]

public void PerformClick ( )

[Delphi]

procedure PerformClick;

See Also

C1Command class


PerformSelect Method (C1Command)

PerformSelect Method (C1Command)

Raises the Select event for the C1Command.

Syntax

[VB]

Public Sub PerformSelect()

[C#]

public void PerformSelect ( )

[Delphi]

procedure PerformSelect;

See Also

C1Command class


StateQuery Method (C1Command)

StateQuery Method (C1Command)

Fires the CommandStateQuery event, updates any changed properties.

Syntax

[VB]

Public Sub StateQuery()

[C#]

public void StateQuery ( )

[Delphi]

procedure StateQuery;

See Also

C1Command class


C1Command Events

CategoryChanged Event

CheckedChanged Event (C1Command)

Click Event (C1Command)

CommandLinkAdded Event (C1Command)

CommandLinkRemoved Event (C1Command)

CommandStateQuery Event (C1Command)

DropDownClicked Event

EnabledChanged Event

ImageChanged Event

Select Event (C1Command)

ShowShortcutChanged Event

ShowTextAsToolTipChanged Event

TextChanged Event (C1Command)

ToolTipChanged Event (C1Command)

VisibleChanged Event


CategoryChanged Event

CategoryChanged Event

Fires when the Category property of command is changed.

Syntax

[VB]

Public Event CategoryChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public EventHandler CategoryChanged

[Delphi]

property CategoryChanged: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event.

See Also

C1Command class


CheckedChanged Event (C1Command)

CheckedChanged Event (C1Command)

Fires when the Checked property has changed.

Syntax

[VB]

Public Event CheckedChanged(sender As Object, e As CheckedChangedEventArgs) As CheckedChangedEventHandler

[C#]

public event CheckedChangedEventHandler CheckedChanged

[Delphi]

property CheckedChanged: CheckedChangedEventHandler;

Event Data

The event handler receives an argument of type CheckedChangedEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
NewValue | The new value of the Checked property.

See Also

C1Command class


Click Event (C1Command)

Click Event (C1Command)

Fires when the command is invoked by the user.

Syntax

[VB]

Public Event Click(ByVal sender As Object, ByVal e As ClickEventArgs) As ClickEventHandler

[C#]

public event ClickEventHandler Click

[Delphi]

property Click: ClickEventHandler;

Event Data

The event handler receives an argument of type ClickEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
ClickSource | Determines what caused the click event to occur.
CallerLink | Gets the command link which was clicked by the user.
ContextInfo | Gets the context info for events fired from a context menu.

Remarks

Some members of the event data object can be null in certain cases. For example, the CallerLink is null for commands fired by the user pressing a shortcut key, and ContextInfo is null unless the command was invoked from a context menu.

See Also

C1Command class


CommandLinkAdded Event (C1Command)

CommandLinkAdded Event (C1Command)

Fires after a command link is linked to this command.

Syntax

[VB]

Public Event CommandLinkAdded(sender As Object, e As CommandLinkEventArgs) As CommandLinkEventHandler

[C#]

public event CommandLinkEventHandler CommandLinkAdded

[Delphi]

property CommandLinkAdded: CommandLinkEventHandler;

Event Data

The event handler receives an argument of type CommandLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
CommandLink | The command link that has been added.

See Also

C1Command class


CommandLinkRemoved Event (C1Command)

CommandLinkRemoved Event (C1Command)

Fires after a command link is unlinked from this command.

Syntax

[VB]

Public Event CommandLinkRemoved(sender As Object, e As CommandLinkEventArgs) As CommandLinkEventHandler

[C#]

public event CommandLinkEventHandler CommandLinkRemoved

[Delphi]

property CommandLinkRemoved: CommandLinkEventHandler;

Event Data

The event handler receives an argument of type CommandLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
CommandLink | The command link that has been removed.

See Also

C1Command class


CommandStateQuery Event (C1Command)

CommandStateQuery Event (C1Command)

Fires when the command state has to be verified.

Syntax

[VB]

Public Event CommandStateQuery(sender As Object, e As CommandStateQueryEventArgs) As CommandStateQueryEventHandler

[C#]

public event CommandStateQueryEventHandler CommandStateQuery

[Delphi]

property CommandStateQuery: CommandStateQueryEventHandler;

Event Data

The event handler receives an argument of type CommandStateQueryEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Checked | Determines whether the command is checked.
Enabled | Determines whether the command is enabled.
Pressed | Determines whether the command is pressed.
Visible | Determines whether the command is visible.

Remarks

For the command state to be correctly updated, you should handle this event and set the values passed in the event args to the desired values.

See Also

C1Command class


DropDownClicked Event

DropDownClicked Event

Event fired when the dropdown arrow is clicked on the toolbar button.

Syntax

[VB]

Public Event DropDownClicked(sender As Object, e As DropDownEventArgs) As DropDownEventHandler

[C#]

public event DropDownEventHandler DropDownClicked

[Delphi]

property DropDownClicked: DropDownEventHandler;

See Also

C1Command class


EnabledChanged Event

EnabledChanged Event

Event fired when the Enabled property of command is changed.

Syntax

[VB]

Public Event EnabledChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler EnabledChanged

[Delphi]

property EnabledChanged: EventHandler;

See Also

C1Command class


ImageChanged Event

ImageChanged Event

Event fired when the Image or ImageIndex or Icon property of command is changed.

Syntax

[VB]

Public Event ImageChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ImageChanged

[Delphi]

property ImageChanged: EventHandler;

See Also

C1Command class


Select Event (C1Command)

Select Event (C1Command)

Fires when the command is selected by the user.

Syntax

[VB]

Public Event Select(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler Select

[Delphi]

property Select: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event.

See Also

C1Command class


ShowShortcutChanged Event

ShowShortcutChanged Event

Event fired when the ShowShortcut property of command is changed.

Syntax

[VB]

Public Event ShowShortcutChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ShowShortcutChanged

[Delphi]

property ShowShortcutChanged: EventHandler;

See Also

C1Command class


ShowTextAsToolTipChanged Event

ShowTextAsToolTipChanged Event

Event fired when the ShowTextAsToolTip property of command is changed.

Syntax

[VB]

Public Event ShowTextAsToolTipChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ShowTextAsToolTipChanged

[Delphi]

property ShowTextAsToolTipChanged: EventHandler;

See Also

C1Command class


TextChanged Event (C1Command)

TextChanged Event (C1Command)

Fires when the Text property of command is changed.

Syntax

[VB]

Public Event TextChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler TextChanged

[Delphi]

property TextChanged: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event.

See Also

C1Command class


ToolTipChanged Event (C1Command)

ToolTipChanged Event (C1Command)

Fires when the ToolTipText property of command is changed.

Syntax

[VB]

Public Event ToolTipChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler ToolTipChanged

[Delphi]

property ToolTipChanged: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event.

See Also

C1Command class


VisibleChanged Event

VisibleChanged Event

Event fired when the Visible property of command is changed.

Syntax

[VB]

Public Event VisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler VisibleChanged

[Delphi]

property VisibleChanged: EventHandler;

See Also

C1Command class


C1CommandControl class

Arbitrary controls can be contained in toolbars. This functionality is provided by the class C1CommandControl, derived from C1Command. Controls can be dragged from the VS toolbox and dropped onto a C1ToolBar. This automatically creates a C1CommandControl, connects it to the dropped control, and adds a link to the new command to the toolbar.

C1CommandControl Members

C1CommandControl Properties

C1CommandControl Methods

C1CommandControl Events


C1CommandControl Members

C1CommandControl Public Properties

AcceptsReturn | Gets or sets the value indicating whether the embedded control receives the Return key.
Category (Inherited from C1Command) | Specifies the category of the command.
CheckAutoToggle (Inherited from C1Command) | Determines whether the Checked property value is toggled automatically.
Checked (Inherited from C1Command) | Determines whether the command is checked.
CommandActive | Gets or sets the value indicating whether the command link can be clicked.
Control | Gets or sets the control attached to this C1CommandControl.
Enabled | Determines whether the command is enabled.
HotFrame | Gets or sets the value indicating how the hot frame around the link is drawn. The default is HotFrameEnum.Full.
Image (Inherited from C1Command) | Gets or sets the command image.
ImageIndex (Inherited from C1Command) | Gets or sets the index of the command image.
IsParent (overridden) | Gets the value indicating whether this menu contains at least one item.
Mnemonic (Inherited from C1Command) | Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.
Owner (Inherited from C1Command) | Specifies the C1CommandHolder containing this command.
Pressed (Inherited from C1Command) | Determines whether the command is pressed.
Shortcut (Inherited from C1Command) | Specifies the keyboard shortcut associated with the command.
ShowShortcut (Inherited from C1Command) | Indicates whether the shortcut for this command will be shown.
ShowTextAsToolTip (Inherited from C1Command) | Indicates whether this command's text will be shown as a tool tip.
Text (Inherited from C1Command) | Specifies the command text.
ToolTipText (Inherited from C1Command) | Gets or sets the text for the tool tip.
UserData (Inherited from C1Command) | Arbitrary data that can be associated with the command.
Visible (Inherited from C1Command) | Determines whether the command is visible.

C1CommandControl Public Methods

Invoke (Inherited from C1Command) | Invokes the command.
PerformClick (Inherited from C1Command) | Generates a click event for the C1Command.
PerformSelect (Inherited from C1Command) | Selects the command.
StateQuery (Inherited from C1Command) | Fires the CommandStateQuery event, updates any changed properties.

C1CommandControl Public Events

CheckedChanged (Inherited from C1Command) | Fires when the Checked property has changed.
Click (Inherited from C1Command) | Fires when the command is invoked by the user.
CommandActiveChanged | Fires when the CommandActive property of C1CommandControl is changed.
CommandLinkAdded (Inherited from C1Command) | Fires after a command link is linked to this command.
CommandLinkRemoved (Inherited from C1Command) | Fires after a command link is unlinked from this command.
CommandStateQuery (Inherited from C1Command) | Fires when the command state has to be verified.
ControlChanged | Fires when the Control property of C1CommandControl is changed.
Select (Inherited from C1Command) | Fires when the command is selected by the user.


C1CommandControl Properties

AcceptsReturn Property

Category Property (C1CommandControl)

CheckAutoToggle Property (C1CommandControl)

Checked Property (C1CommandControl)

Control Property

CommandActive Property

DropDown Property (C1CommandControl)

Enabled Property (C1CommandControl)

HotFrame Property (C1CommandControl)

Image Property (C1CommandControl)

ImageIndex Property (C1CommandControl)

IsParent Property (C1CommandControl)

Mnemonic Property (C1CommandControl)

Owner Property (C1CommandControl)

Pressed Property (C1CommandControl)

Shortcut Property (C1CommandControl)

ShowShortcut Property (C1CommandControl)

ShowTextAsToolTip Property (C1CommandControl)

Text Property (C1CommandControl)

ToolTipText Property (C1CommandControl)

UserData Property (C1CommandControl)

Visible Property (C1CommandControl)


AcceptsReturn Property

AcceptsReturn Property

Gets or sets the value indicating whether the embedded control receives the Return key.

Syntax

[VB]

Public Property AcceptsReturn As Boolean

[C#]

public bool AcceptsReturn {get; set;}

[Delphi]

property AcceptsReturn: Boolean;

Remarks

The default is false, which means that the Return key is processed by the command link and is not passed to the embedded control. Setting this value to true results in the Return key being passed to the control for processing.

See Also

C1CommandControl class


Category Property (C1CommandControl)

Category Property (C1CommandControl)

See Category Property (C1Command).


CheckAutoToggle Property (C1CommandControl)

CheckAutoToggle Property (C1CommandControl)

See CheckAutoToggle Property (C1Command).


Checked Property (C1CommandControl)

Checked Property (C1CommandControl)

See Checked Property (C1Command).


Control Property

Control Property

Gets or sets the control attached to this C1CommandControl.

Syntax

[VB]

Public Property Control As Control

[C#]

public Control Control {get; set;}

[Delphi]

property Control: Control;

See Also

C1CommandControl class


CommandActive Property

CommandActive Property

Gets or sets the value indicating whether the command link can be clicked.

Syntax

[VB]

Public Property CommandActive As Boolean

[C#]

public bool CommandActive {get; set;}

[Delphi]

property CommandActive: Boolean;

See Also

C1CommandControl class


DropDown Property (C1CommandControl)

DropDown Property (C1CommandControl)

See DropDown Property (C1Command).


Enabled Property (C1CommandControl)

Enabled Property (C1CommandControl)

Determines whether the command is enabled.

Syntax

[VB]

Public Overridable Property Enabled As Boolean

[C#]

public bool Enabled {get; set;}

[Delphi]

property Enabled: Boolean;

Remarks

When this property is set, both the command and the related control are affected (enabled or disabled).

See Also

C1CommandControl class


HotFrame Property (C1CommandControl)

HotFrame Property (C1CommandControl)

Gets or sets the value indicating how the hot frame around the link is drawn.

Syntax

[VB]

Public Property HotFrame As C1.Win.C1Command.HotFrameEnum

[C#]

public C1.Win.C1Command.HotFrameEnum HotFrame {get; set;}

[Delphi]

property HotFrame: C1.Win.C1Command.HotFrameEnum;

Remarks

The default is HotFrameEnum.Full.

Possible values of this property are:

Member Name | Description
Full | The frame encloses the whole link.
Control | The frame encloses just the control.
None | Hot frame is not drawn.

See Also

C1CommandControl class


Image Property (C1CommandControl)

Image Property (C1CommandControl)

See Image Property (C1Command).


ImageIndex Property (C1CommandControl)

ImageIndex Property (C1CommandControl)

See ImageIndex Property (C1Command).


IsParent Property (C1CommandControl)

IsParent Property (C1CommandControl)

See IsParent Property (C1Command).


Mnemonic Property (C1CommandControl)

Mnemonic Property (C1CommandControl)

See Mnemonic Property (C1Command).


Owner Property (C1CommandControl)

Owner Property (C1CommandControl)

See Owner Property (C1Command).


Pressed Property (C1CommandControl)

Pressed Property (C1CommandControl)

See Pressed Property (C1Command).


Shortcut Property (C1CommandControl)

Shortcut Property (C1CommandControl)

See Shortcut Property (C1Command).


ShowShortcut Property (C1CommandControl)

ShowShortcut Property (C1CommandControl)

See ShowShortcut Property (C1Command).


ShowTextAsToolTip Property (C1CommandControl)

ShowTextAsToolTip Property (C1CommandControl)

See ShowTextAsToolTip Property (C1Command).


Text Property (C1CommandControl)

Text Property (C1CommandControl)

See Text Property (C1Command).


ToolTipText Property (C1CommandControl)

ToolTipText Property (C1CommandControl)

See ToolTipText Property (C1Command).


UserData Property (C1CommandControl)

UserData Property (C1CommandControl)

See UserData Property (C1Command).


Visible Property (C1CommandControl)

Visible Property (C1CommandControl)

See Visible Property (C1Command).


C1CommandControl Methods

Invoke Method (C1CommandControl)

PerformClick Method (C1CommandControl)

PerformSelect Method (C1CommandControl)

StateQuery Method (C1CommandControl)


Invoke Method (C1CommandControl)

Invoke Method (C1CommandControl)

See Invoke Method (C1Command).


PerformClick Method (C1CommandControl)

PerformClick Method (C1CommandControl)

See PerformClick Method (C1Command).


PerformSelect Method (C1CommandControl)

PerformSelect Method (C1CommandControl)

See PerformSelect Method (C1Command).


StateQuery Method (C1CommandControl)

StateQuery Method (C1CommandControl)

See StateQuery Method (C1Command).


C1CommandControl Events

CheckedChanged Event (C1CommandControl)

Click Event (C1CommandControl)

CommandActiveChanged Event

CommandLinkAdded Event (C1CommandControl)

CommandLinkRemoved Event (C1CommandControl)

CommandStateQuery Event (C1CommandControl)

ControlChanged Event

Select Event (C1CommandControl)


CheckedChanged Event (C1CommandControl)

CheckedChanged Event (C1CommandControl)

See CheckedChanged Event (C1Command).


Click Event (C1CommandControl)

Click Event (C1CommandControl)

See Click Event (C1Command).


CommandActiveChanged Event

CommandActiveChanged Event

Fires when the CommandActive property of C1CommandControl is changed.

Syntax

[VB]

Public Event CommandActiveChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler CommandActiveChanged

[Delphi]

property CommandActiveChanged: EventHandler;

See Also

C1CommandControl class


CommandLinkAdded Event (C1CommandControl)

CommandLinkAdded Event (C1CommandControl)

See CommandLinkAdded Event (C1Command).


CommandLinkRemoved Event (C1CommandControl)

CommandLinkRemoved Event (C1CommandControl)

See CommandLinkRemoved Event (C1Command).


CommandStateQuery Event (C1CommandControl)

CommandStateQuery Event (C1CommandControl)

See CommandStateQuery Event (C1Command).


ControlChanged Event

ControlChanged Event

Fires when the Control property of C1CommandControl is changed.

Syntax

[VB]

Public Event ControlChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ControlChanged

[Delphi]

property ControlChanged: EventHandler;

See Also

C1CommandControl class


Select Event (C1CommandControl)

Select Event (C1CommandControl)

See Select Event (C1Command).


C1CommandMenu class

The C1CommandMenu component is a command (derives from the C1Command base class) that is a menu. In addition to other C1Command properties, it contains a collection of command links which are the menu items of this menu. C1CommandMenu can be included in another menu as a sub-menu.

Inherits from C1Command.

C1CommandMenu Members

C1CommandMenu Properties

C1CommandMenu Methods

C1CommandMenu Events


C1CommandMenu Members

C1CommandMenu Public Properties

BackColor | Gets or sets the base background color of the menu.
BackgroundImage | Gets or sets the background image displayed in the menu.
BackHiColor | Gets or sets the base background color of the highlighted item.
Category (Inherited from C1Command) | Specifies the category of the command.
CheckAutoToggle (Inherited from C1Command) | Determines whether the Checked property value is toggled automatically.
Checked (Inherited from C1Command) | Determines whether the command is checked.
CommandLinks | Returns a collection of C1CommandLinks objects.
DropDown (overridden) | Determines whether the command has a dropdown arrow when it is in a toolbar.
Enabled (Inherited from C1Command) | Determines whether the command is enabled.
Font | Gets or sets the selected font.
ForeColor | Gets or sets the text color of the menu.
ForeHiColor | Gets or sets the text color of the highlighted item.
HideNonRecentLinks | Gets or sets the value indicating whether to hide rarely used menu items.
Image (Inherited from C1Command) | Gets or sets the command image.
ImageBarWidth | Gets or sets the width of the image/checkmarks bar. The default is 0 which means that the width is selected automatically.
ImageIndex (Inherited from C1Command) | Gets or sets the index of the command image.
IsParent (overridden) | Gets the value indicating whether this menu contains at least one item.
LargeMenuDisplay | Determines the way large menus are displayed when all items cannot fit in one column.
Mnemonic (Inherited from C1Command) | Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.
Owner (Inherited from C1Command) | Specifies the C1CommandHolder containing this command.
Pressed (Inherited from C1Command) | Determines whether the command is pressed.
SeparateCheckBar | Gets or sets the value indicating whether to show check marks instead of images or in a separate bar. The default is false.
Shortcut (Inherited from C1Command) | Specifies the keyboard shortcut associated with the command.
ShowShortcut (Inherited from C1Command) | Indicates whether the shortcut for this command will be shown.
ShowTextAsToolTip (Inherited from C1Command) | Indicates whether this command's text will be shown as a tool tip.
ShowToolTips | Gets or sets the value indicating whether to show tooltip texts when the mouse cursor is over the toolbutton.
SideCaption | Allows to specify a caption (text and/or image) to be shown alongside the left edge of the menu.
Text (Inherited from C1Command) | Specifies the command text.
ToolTipText (Inherited from C1Command) | Gets or sets the text for the tool tip.
UserData (Inherited from C1Command) | Arbitrary data that can be associated with the command.
Visible (Inherited from C1Command) | Determines whether the command is visible.
Width | Gets or sets the minimum width of the menu (may be used to make menus wider than the default determined by the menu's content).

C1CommandMenu Public Methods

Invoke (Inherited from C1Command) | Invokes the command.
PerformClick (Inherited from C1Command) | Generates a click event for the C1Command.
PerformSelect (Inherited from C1Command) | Selects the command.
StateQuery (Inherited from C1Command) | Fires the CommandStateQuery event, updates any changed properties.

C1CommandMenu Public Events

BackColorChanged | Occurs when the value of the BackColor property changes.
BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes.
BackHiColorChanged | Occurs when the value of the BackHiColor property changes.
CheckedChanged (Inherited from C1Command) | Fires when the Checked property has changed.
Click (Inherited from C1Command) | Fires when the command is invoked by the user.
Closed | Occurs after the command's submenu is closed.
CommandLinkAdded (Inherited from C1Command) | Fires after a command link is linked to this command.
CommandLinkRemoved (Inherited from C1Command) | Fires after a command link is unlinked from this command.
CurrentLinkChanged | Occurs when the current command link changes.
CommandStateQuery (Inherited from C1Command) | Fires when the command state has to be verified.
DrawBar | Occurs when the owner-drawn C1CommandMenu should be redrawn.
DrawLink | Occurs when the owner-drawn C1CommandLink should be redrawn.
FontChanged | Fires when the Font property of C1CommandMenu is changed.
ForeColorChanged | Occurs when the value of the ForeColor property changes.
ForeHiColorChanged | Occurs when the value of the ForeHiColor property changes.
HideNonRecentLinksChanged | Occurs when the value of HideNonRecentLinks property changes.
LargeMenuDisplayChanged | Fires when the LargeMenuDisplay property of C1CommandMenu is changed.
LayoutLink | Occurs when an OwnerDraw command link needs to layout its text, image and control within the link bounds.
MeasureLink | Occurs when it is necessary to measure the owner-drawn link.
Popup | Fires before the command's submenu is displayed.
Select (Inherited from C1Command) | Fires when the command is selected by the user.
ShowToolTipsChanged | Fires when the ShowToolTips property of C1CommandMenu is changed.
SideCaptionChanged | Fires when the SideCaption property of C1CommandMenu is changed.
WidthChanged | Fires when the Width property of menu is changed.


C1CommandMenu Properties

BackColor Property

BackgroundImage Property

BackHiColor Property (C1CommandMenu)

Category Property (C1CommandMenu)

CheckAutoToggle Property (C1CommandMenu)

Checked Property (C1CommandMenu)

CommandLinks Property (C1CommandMenu)

DropDown Property (C1CommandMenu)

Enabled Property (C1CommandMenu)

Font Property

ForeColor Property

ForeHiColor Property (C1CommandMenu)

HideNonRecentLinks Property (C1CommandMenu)

Image Property (C1CommandMenu)

ImageBarWidth Property

ImageIndex Property (C1CommandMenu)

IsParent Property (C1CommandMenu)

LargeMenuDisplay Property

Mnemonic Property (C1CommandMenu)

Owner Property (C1CommandMenu)

Pressed Property (C1CommandMenu)

SeparateCheckBar Property

SideCaption Property

Shortcut Property (C1CommandMenu)

ShowShortcut Property (C1CommandMenu)

ShowTextAsToolTip Property (C1CommandMenu)

ShowToolTips Property (C1CommandMenu)

Text Property (C1CommandMenu)

ToolTipText Property (C1CommandMenu)

UserData Property (C1CommandMenu)

Visible Property (C1CommandMenu)

Width Property (C1CommandMenu)


BackColor Property

BackColor Property

Gets or sets the base background color of the menu.

Syntax

[VB]

Public Property BackColor As System.Drawing.Color

[C#]

public System.Drawing.Color BackColor {get; set;}

[Delphi]

property BackColor: System.Drawing.Color;

See Also

C1CommandMenu class


BackgroundImage Property

BackgroundImage Property

Gets or sets the background image displayed in the menu.

Syntax

[VB]

Public Property BackgroundImage As System.Drawing.Image

[C#]

public System.Drawing.Image BackgroundImage {get; set;}

[Delphi]

property BackgroundImage: System.Drawing.Image;

See Also

C1CommandMenu class


BackHiColor Property (C1CommandMenu)

BackHiColor Property (C1CommandMenu)

Gets or sets the base background color of the highlighted item.

Syntax

[VB]

Public Property BackHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color BackHiColor {get; set;}

[Delphi]

property BackHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


Category Property (C1CommandMenu)

Category Property (C1CommandMenu)

See Category Property (C1Command).


CheckAutoToggle Property (C1CommandMenu)

CheckAutoToggle Property (C1CommandMenu)

See CheckAutoToggle Property (C1Command).


Checked Property (C1CommandMenu)

Checked Property (C1CommandMenu)

See Checked Property (C1Command).


CommandLinks Property (C1CommandMenu)

CommandLinks Property (C1CommandMenu)

Returns a collection of C1CommandLink objects.

Syntax

[VB]

Public ReadOnly Property CommandLinks As C1CommandLinks

[C#]

public C1CommandLinks CommandLinks {get;}

[Delphi]

property CommandLinks: C1CommandLinks;

Remarks

This collection determines which items the menu defined by this command will contain. You can edit this collection or enumerate it to access items in the menu.

See Also

C1CommandMenu class


DropDown Property (C1CommandMenu)

DropDown Property (C1CommandMenu)

See DropDown Property (C1Command).


Enabled Property (C1CommandMenu)

Enabled Property (C1CommandMenu)

See Enabled Property (C1Command).


Font Property

Font Property

Gets or sets the selected font.

Syntax

[VB]

Public Overridable Property Font As Font

[C#]

public Font Font {get; set;}

[Delphi]

property Font: Font;

See Also

C1CommandMenu class


ForeColor Property

ForeColor Property

Gets or sets the text color of the menu.

Syntax

[VB]

Public Property ForeColor As System.Drawing.Color

[C#]

public System.Drawing.Color ForeColor {get; set;}

[Delphi]

property ForeColor: System.Drawing.Color;

See Also

C1CommandMenu class


ForeHiColor Property (C1CommandMenu)

ForeHiColor Property (C1CommandMenu)

Gets or sets the text color of the highlighted item.

Syntax

[VB]

Public Property ForeHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color ForeHiColor {get; set;}

[Delphi]

property ForeHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


HideNonRecentLinks Property (C1CommandMenu)

HideNonRecentLinks Property (C1CommandMenu)

Gets or sets the value indicating whether to hide rarely used menu items.

Syntax

[VB]

Public Property HideNonRecentLinks As Boolean

[C#]

public bool HideNonRecentLinks {get; set;}

[Delphi]

property HideNonRecentLinks: Boolean;

See Also

C1CommandMenu class


Image Property (C1CommandMenu)

Image Property (C1CommandMenu)

See Image Property (C1Command).


ImageBarWidth Property

ImageBarWidth Property

Gets or sets the width of the image/checkmarks bar.

Syntax

[VB]

Public Property ImageBarWidth As Integer

[C#]

public int ImageBarWidth {get; set;}

[Delphi]

property ImageBarWidth: Integer;

Remarks

The default is 0 which means that the width is selected automatically.

See Also

C1CommandMenu class


ImageIndex Property (C1CommandMenu)

ImageIndex Property (C1CommandMenu)

See ImageIndex Property (C1Command).


IsParent Property (C1CommandMenu)

IsParent Property (C1CommandMenu)

Returns True if there is at least one item in the menu.

Syntax

[VB]

Public ReadOnly Property IsParent As Boolean

[C#]

public bool IsParent {get;}

[Delphi]

property IsParent: Boolean;

Remarks

The value of this property is equivalent to the condition that the CommandLinks collection has at least one item.

See Also

C1CommandMenu class


LargeMenuDisplay Property

LargeMenuDisplay Property

Determines the way large menus are displayed when all items cannot fit in one column.

Syntax

[VB]

Public Property LargeMenuDisplay As LargeMenuDisplayEnum

[C#]

public LargeMenuDisplayEnum LargeMenuDisplay {get; set;}

[Delphi]

property LargeMenuDisplay: LargeMenuDisplayEnum;

Remarks

Possible values of this property are:

Member Name | Description
Scroll | When a menu does not fit on the screen, it is scrolled.
Wrap | When a menu does not fit on the screen, it is wrapped.

The default value is Wrap.

See Also

C1CommandMenu class


Mnemonic Property (C1CommandMenu)

Mnemonic Property (C1CommandMenu)

See Mnemonic Property (C1Command).


Owner Property (C1CommandMenu)

Owner Property (C1CommandMenu)

See Owner Property (C1Command).


Pressed Property (C1CommandMenu)

Pressed Property (C1CommandMenu)

See Pressed Property (C1Command).


SeparateCheckBar Property

SeparateCheckBar Property

Gets or sets the value indicating whether to show check marks instead of images or in a separate bar.

Syntax

[VB]

Public Property SeparateCheckBar As Boolean

[C#]

public bool SeparateCheckBar {get;}

[Delphi]

property SeparateCheckBar: Boolean;

Remarks

The default value is false.

See Also

C1CommandMenu class


SideCaption Property

SideCaption Property

Allows to specify a caption (text and/or image) to be shown alongside the left edge of the menu.

Syntax

[VB]

Public Property SideCaption As C1SideCaption

[C#]

public C1SideCaption SideCaption {get;set; }

[Delphi]

property SideCaption: C1SideCaption;

See Also

C1CommandMenu class


Shortcut Property (C1CommandMenu)

Shortcut Property (C1CommandMenu)

See Shortcut Property (C1Command).


ShowShortcut Property (C1CommandMenu)

ShowShortcut Property (C1CommandMenu)

See ShowShortcut Property (C1Command).


ShowTextAsToolTip Property (C1CommandMenu)

ShowTextAsToolTip Property (C1CommandMenu)

See ShowTextAsToolTip Property (C1Command).


ShowToolTips Property (C1CommandMenu)

ShowToolTips Property (C1CommandMenu)

Gets or sets the value indicating whether to show tooltip texts when mouse cursor is over toolbutton.

Syntax

[VB]

Public NotOverridable Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get; set}

[Delphi]

property ShowToolTips: Boolean;

See Also

C1CommandMenu class


Text Property (C1CommandMenu)

Text Property (C1CommandMenu)

See Text Property (C1Command).


ToolTipText Property (C1CommandMenu)

ToolTipText Property (C1CommandMenu)

See ToolTipText Property (C1Command).


UserData Property (C1CommandMenu)

UserData Property (C1CommandMenu)

See UserData Property (C1Command).


Visible Property (C1CommandMenu)

Visible Property (C1CommandMenu)

See Visible Property (C1Command).


Width Property (C1CommandMenu)

Width Property (C1CommandMenu)

Gets or sets the minimum width of the menu (may be used to make menus wider than the default determined by the menu's content).

Syntax

[VB]

Public Property Width As Integer

[C#]

public int Width {get; set;}

[Delphi]

property Width: Integer;

Remarks

The default value of this property is 0 (the menu width is determined automatically).

See Also

C1CommandMenu class


C1CommandMenu Methods

Invoke Method (C1CommandMenu)

PerformClick Method (C1CommandMenu)

PerformSelect Method (C1CommandMenu)

StateQuery Method (C1CommandMenu)


Invoke Method (C1CommandMenu)

Invoke Method (C1CommandMenu)

See Invoke Method (C1Command).


PerformClick Method (C1CommandMenu)

PerformClick Method (C1CommandMenu)

See PerformClick Method (C1Command).


PerformSelect Method (C1CommandMenu)

PerformSelect Method (C1CommandMenu)

See PerformSelect Method (C1Command).


StateQuery Method (C1CommandMenu)

StateQuery Method (C1CommandMenu)

See StateQuery Method (C1Command).


C1CommandMenu Events

BackColorChanged Event

BackgroundImageChanged Event

BackHiColorChanged Event (C1CommandMenu)

CheckedChanged Event (C1CommandMenu)

Click Event (C1CommandMenu)

Closed Event

CommandLinkAdded Event (C1CommandMenu)

CommandLinkRemoved Event (C1CommandMenu)

CommandStateQuery Event (C1CommandMenu)

CurrentLinkChanged Event

DrawBar Event

DrawLink Event

FontChanged Event

ForeColorChanged Event

ForeHiColorChanged Event (C1CommandMenu)

HideNonRecentLinksChanged Event (C1CommandMenu)

LargeMenuDisplayChanged Event

LayoutLink Event (C1CommandMenu)

MeasureLink Event

Popup Event (C1CommandMenu)

Select Event (C1CommandMenu)

ShowToolTipsChanged Event (C1CommandMenu)

SideCaptionChanged Event

WidthChanged Event


BackColorChanged Event

BackColorChanged Event

Occurs when the value of the BackColor property changes.

Syntax

[VB]

Public Event BackColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BackColorChanged

[Delphi]

property BackColorChanged: EventHandler;

See Also

C1CommandMenu class


BackgroundImageChanged Event

BackgroundImageChanged Event

Occurs when the value of the BackgroundImage property changes.

Syntax

[VB]

Public Event BackgroundImageChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BackgroundImageChanged

[Delphi]

property BackgroundImageChanged: EventHandler;

See Also

C1CommandMenu class


BackHiColorChanged Event (C1CommandMenu)

BackHiColorChanged Event (C1CommandMenu)

Occurs when the value of the BackHiColor property changes.

Syntax

[VB]

Public Event BackHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BackHiColorChanged

[Delphi]

property BackHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


CheckedChanged Event (C1CommandMenu)

CheckedChanged Event (C1CommandMenu)

See CheckedChanged Event (C1Command).


Click Event (C1CommandMenu)

Click Event (C1CommandMenu)

See Click Event (C1Command).


Closed Event

Closed Event

Occurs after the command's submenu is closed.

Syntax

[VB]

Public Event Closed(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler Closed

[Delphi]

property Closed: EventHandler;

See Also

C1CommandMenu class


CommandLinkAdded Event (C1CommandMenu)

CommandLinkAdded Event (C1CommandMenu)

See CommandLinkAdded Event (C1Command).


CommandLinkRemoved Event (C1CommandMenu)

CommandLinkRemoved Event (C1CommandMenu)

See CommandLinkRemoved Event (C1Command).


CommandStateQuery Event (C1CommandMenu)

CommandStateQuery Event (C1CommandMenu)

See CommandStateQuery Event (C1Command).


CurrentLinkChanged Event

CurrentLinkChanged Event

Occurs when the current command link changes.

Syntax

[VB]

Public Event CurrentLinkChanged(ByVal sender As Object, ByVal e As C1.Win.C1Command.CommandLinkEventArgs) As C1.Win.C1Command.CommandLinkEventHandler

[C#]

public event EventHandler CurrentLinkChanged

[Delphi]

property CurrentLinkChanged: EventHandler;

Remarks

If a handler is attached to this event of a menu or toolbar, and that menu or toolbar opens a sub-menu which does not have its own handler for this event, the parent's handler is invoked. This event can be used to keep track of which command link is currently selected (e.g. to set context-sensitive status help messages).

See Also

C1CommandMenu class


DrawBar Event

DrawBar Event

Occurs when the owner-drawn C1CommandMenu should be redrawn.

Syntax

[VB]

Public Event DrawBar(ByVal sender As Object, ByVal e As DrawBarEventArgs) As DrawBarEventHandler

[C#]

public event DrawBarEventHandler DrawBar

[Delphi]

property DrawBar: DrawBarEventHandler;

Event Data

The event handler receives an argument of type DrawBarEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the menu.
Path | The graphcs path bounding the menu.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1CommandMenu class


DrawLink Event

DrawLink Event

Occurs when the owner-drawn C1CommandLink should be redrawn.

Syntax

[VB]

Public Event DrawLink(ByVal sender As Object, ByVal e As DrawLinkEventArgs) As DrawLinkEventHandler

[C#]

public event DrawLinkEventHandler DrawLink

[Delphi]

property DrawLink: DrawLinkEventHandler;

Event Data

The event handler receives an argument of type DrawLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the link.
Link | C1CommandLink to draw
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1CommandMenu class


FontChanged Event

FontChanged Event

Fires when the Font property of C1CommandMenu is changed.

Syntax

[VB]

Public Event FontChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler FontChanged

[Delphi]

property FontChanged: EventHandler;

See Also

C1CommandMenu class


ForeColorChanged Event

ForeColorChanged Event

Occurs when the value of the ForeColor property changes.

Syntax

[VB]

Public Event ForeColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ForeColorChanged

[Delphi]

property ForeColorChanged: EventHandler;

See Also

C1CommandMenu class


ForeHiColorChanged Event (C1CommandMenu)

ForeHiColorChanged Event (C1CommandMenu)

Occurs when the value of the ForeHiColor property changes.

Syntax

[VB]

Public Event ForeHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ForeHiColorChanged

[Delphi]

property ForeHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


HideNonRecentLinksChanged Event (C1CommandMenu)

HideNonRecentLinksChanged Event (C1CommandMenu)

Occurs when the value of the HideNonRecentLinks property changes.

Syntax

[VB]

Public Event HideNonRecentLinksChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler HideNonRecentLinksChanged

[Delphi]

property HideNonRecentLinksChanged: EventHandler;

See Also

C1CommandMenu class


LargeMenuDisplayChanged Event

LargeMenuDisplayChanged Event

Fires when the LargeMenuDisplay property of C1CommandMenu is changed.

Syntax

[VB]

Public Event LargeMenuDisplayChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler LargeMenuDisplayChanged

[Delphi]

property LargeMenuDisplayChanged: EventHandler;

See Also

C1CommandMenu class


LayoutLink Event (C1CommandMenu)

LayoutLink Event (C1CommandMenu)

See LayoutLink Event (C1MainMenu).


MeasureLink Event

MeasureLink Event

Occurs when it is necessary to measure the owner-drawn link.

Syntax

[VB]

Public Event MeasureLink(ByVal sender As Object, ByVal e As MeasureLinkEventArgs) As MeasureLinkEventHandler

[C#]

public event MeasureLinkEventHandler MeasureLink

[Delphi]

property MeasureLink: MeasureLinkEventHandler;

Event Data

The event handler receives an argument of type MeasureLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | Specifies the Graphics object to use for measuring.
Link | Specifies the link that needs to be measured.
Width | Specifies the width of the link.
Height | Specifies the height of the link.

See Also

C1CommandMenu class


Popup Event (C1CommandMenu)

Popup Event (C1CommandMenu)

Fires before the command's submenu is displayed.

Syntax

[VB]

Public Event Popup(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler Popup

[Delphi]

property PopUp: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event. The following properties provide information specific to this event.

See Also

C1CommandMenu class


Select Event (C1CommandMenu)

Select Event (C1CommandMenu)

See Select Event (C1Command).


ShowToolTipsChanged Event (C1CommandMenu)

ShowToolTipsChanged Event (C1CommandMenu)

Fires when the ShowToolTips property of C1CommandMenu is changed.

Syntax

[VB]

Public Event ShowToolTipsChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ShowToolTipsChanged

[Delphi]

property ShowToolTipsChanged: EventHandler;

See Also

C1CommandMenu class


SideCaptionChanged Event

SideCaptionChanged Event

Fires when the SideCaption property of C1CommandMenu is changed.

Syntax

[VB]

Public Event SideCaptionChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler SideCaptionChanged

[Delphi]

property SideCaptionChanged: EventHandler;

See Also

C1CommandMenu class


WidthChanged Event

WidthChanged Event

Fires when the Width property of menu is changed.

Syntax

[VB]

Public Event WidthChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler WidthChanged

[Delphi]

property WidthChanged: EventHandler;

See Also

C1CommandMenu class


C1ContextMenu class

The C1ContextMenu component is a menu (it derives from the C1CommandMenu base class) that can be attached to an arbitrary control as a context menu. To facilitate this, the C1CommandHolder (which always exists on a form using C1 menus) is an IExtenderProvider providing a C1ContextMenu property of the type C1ContextMenu to all controls on the form.

Note that a C1ContextMenu can be used in other menus in exactly the same way as its base class C1CommandMenu. Thus if you want to use the same menu as a submenu in the main menu system and as a context menu, just link (see C1CommandLink) to the same C1ContextMenu in both places.

C1ContextMenu Members

C1ContextMenu Properties

C1ContextMenu Methods

C1ContextMenu Events


C1ContextMenu Members

C1ContextMenu Public Properties

Category (Inherited from C1CommandMenu) | Specifies the category of the command.
CheckAutoToggle (Inherited from C1CommandMenu) | Determines whether the Checked property value is toggled automatically.
Checked (Inherited from C1CommandMenu) | Determines whether the command is checked.
CommandLinks (Inherited from C1CommandMenu) | Returns a collection of C1CommandLinks objects.
DropDown (Inherited from C1CommandMenu) | Determines whether the command has a dropdown arrow when it is in a toolbar.
Enabled (Inherited from C1CommandMenu) | Determines whether the command is enabled.
Image (Inherited from C1CommandMenu) | Gets or sets the command image.
ImageIndex (Inherited from C1CommandMenu) | Gets or sets the index of the command image.
IsParent (inherited from C1CommandMenu) | Determines if the parent control is a C1Command component.
Mnemonic (Inherited from C1CommandMenu) | Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.
Owner (Inherited from C1CommandMenu) | Specifies the C1CommandHolder containing this command.
Pressed (Inherited from C1CommandMenu) | Determines whether the command is pressed.
Shortcut (Inherited from C1CommandMenu) | Specifies the keyboard shortcut associated with the command.
ShowShortcut (Inherited from C1CommandMenu) | Indicates whether the shortcut for this command will be shown.
ShowTextAsToolTip (Inherited from C1CommandMenu) | Indicates whether this command's text will be shown as a tool tip.
Text (Inherited from C1CommandMenu) | Specifies the command text.
ToolTipText (Inherited from C1CommandMenu) | Gets or sets the text for the tool tip.
UserData (Inherited from C1CommandMenu) | Arbitrary data that can be associated with the command.
Visible (Inherited from C1CommandMenu) | Determines whether the command is visible.

C1ContextMenu Public Methods

Invoke | Invokes the command.
PerformClick (Inherited from C1Command) | Generates a click event for the C1Command.
PerformSelect (Inherited from C1Command) | Selects the command.
ShowContextMenu | Shows the context menu at the specified position.
StateQuery (Inherited from C1Command) | Fires the CommandStateQuery event, updates any changed properties.

C1ContextMenu Public Events

CheckedChanged (Inherited from C1CommandMenu) | Fires when the Checked property has changed.
Click (Inherited from C1CommandMenu) | Fires when the command is invoked by the user.
CommandLinkAdded (Inherited from C1CommandMenu) | Fires after a command link is linked to this command.
CommandLinkRemoved (Inherited from C1CommandMenu) | Fires after a command link is unlinked from this command.
CommandStateQuery (Inherited from C1CommandMenu) | Fires when the command state has to be verified.
Popup (Inherited from C1CommandMenu) | Fires before the command's submenu is displayed.
Select (Inherited from C1CommandMenu) | Fires when the command is selected by the user.


C1ContextMenu Properties

Category Property (C1ContextMenu)

CheckAutoToggle Property (C1ContextMenu)

Checked Property (C1ContextMenu)

CommandLinks Property (C1ContextMenu)

DropDown Property (C1ContextMenu)

Enabled Property (C1ContextMenu)

Image Property (C1ContextMenu)

ImageIndex Property (C1ContextMenu)

IsParent Property (C1ContextMenu)

Mnemonic Property (C1ContextMenu)

Owner Property (C1ContextMenu)

Pressed Property (C1ContextMenu)

Shortcut Property (C1ContextMenu)

ShowShortcut Property (C1ContextMenu)

ShowTextAsToolTip Property (C1ContextMenu)

Text Property (C1ContextMenu)

ToolTipText Property (C1ContextMenu)

UserData Property (C1ContextMenu)

Visible Property (C1ContextMenu)


Category Property (C1ContextMenu)

Category Property (C1ContextMenu)

See Category Property (C1CommandMenu).


CheckAutoToggle Property (C1ContextMenu)

CheckAutoToggle Property (C1ContextMenu)

See CheckAutoToggle Property (C1CommandMenu).


Checked Property (C1ContextMenu)

Checked Property (C1ContextMenu)

See Checked Property (C1CommandMenu).


CommandLinks Property (C1ContextMenu)

CommandLinks Property (C1ContextMenu)

See CommandLinks Property (C1CommandMenu).


DropDown Property (C1ContextMenu)

DropDown Property (C1ContextMenu)

See DropDown Property (C1CommandMenu).


Enabled Property (C1ContextMenu)

Enabled Property (C1ContextMenu)

See Enabled Property (C1CommandMenu).


Image Property (C1ContextMenu)

Image Property (C1ContextMenu)

See Image Property (C1CommandMenu).


ImageIndex Property (C1ContextMenu)

ImageIndex Property (C1ContextMenu)

See ImageIndex Property (C1CommandMenu).


IsParent Property (C1ContextMenu)

IsParent Property (C1ContextMenu)

See IsParent Property (C1CommandMenu).


Mnemonic Property (C1ContextMenu)

Mnemonic Property (C1ContextMenu)

See Mnemonic Property (C1CommandMenu).


Owner Property (C1ContextMenu)

Owner Property (C1ContextMenu)

See Owner Property (C1CommandMenu).


Pressed Property (C1ContextMenu)

Pressed Property (C1ContextMenu)

See Pressed Property (C1CommandMenu).


Shortcut Property (C1ContextMenu)

Shortcut Property (C1ContextMenu)

See Shortcut Property (C1CommandMenu).


ShowShortcut Property (C1ContextMenu)

ShowShortcut Property (C1ContextMenu)

See ShowShortcut Property (C1CommandMenu).


ShowTextAsToolTip Property (C1ContextMenu)

ShowTextAsToolTip Property (C1ContextMenu)

See ShowTextAsToolTip Property (C1CommandMenu).


Text Property (C1ContextMenu)

Text Property (C1ContextMenu)

See Text Property (C1CommandMenu).


ToolTipText Property (C1ContextMenu)

ToolTipText Property (C1ContextMenu)

See ToolTipText Property (C1CommandMenu).


UserData Property (C1ContextMenu)

UserData Property (C1ContextMenu)

See UserData Property (C1CommandMenu).


Visible Property (C1ContextMenu)

Visible Property (C1ContextMenu)

See Visible Property (C1CommandMenu).


C1ContextMenu Methods

Invoke Method (C1ContextMenu)

PerformClick Method (C1ContextMenu)

PerformSelect Method (C1ContextMenu)

ShowContextMenu Method

StateQuery Method (C1ContextMenu)


Invoke Method (C1ContextMenu)

Invoke Method (C1ContextMenu)

See Invoke Method (C1CommandMenu).


PerformClick Method (C1ContextMenu)

PerformClick Method (C1ContextMenu)

See PerformClick Method (C1CommandMenu).


PerformSelect Method (C1ContextMenu)

PerformSelect Method (C1ContextMenu)

See PerformSelect Method (C1CommandMenu).


ShowContextMenu Method

ShowContextMenu Method

Shows the menu at the specified location.

Syntax

[VB]

Public Sub ShowContextMenu(control As Control, pt As Point)

[C#]

public void ShowContextMenu (Control control , Point pt )

[Delphi]

procedure ShowContextMenu(control: Control; pt: Point);

Remarks

Parameter | Description
control | The control where the context menu is to be shown.
pt | The point in the control client area where the context menu is to be shown.

See Also

C1ContextMenu class


StateQuery Method (C1ContextMenu)

StateQuery Method (C1ContextMenu)

See StateQuery Method (C1CommandMenu).


C1ContextMenu Events

CheckedChanged Event (C1ContextMenu)

Click Event (C1ContextMenu)

CommandLinkAdded Event (C1ContextMenu)

CommandLinkRemoved Event (C1ContextMenu)

CommandStateQuery Event (C1ContextMenu)

Popup Event (C1ContextMenu)

Select Event (C1ContextMenu)


CheckedChanged Event (C1ContextMenu)

CheckedChanged Event (C1ContextMenu)

See CheckedChanged Event (C1CommandMenu).


Click Event (C1ContextMenu)

Click Event (C1ContextMenu)

See Click Event (C1CommandMenu).


CommandLinkAdded Event (C1ContextMenu)

CommandLinkAdded Event (C1ContextMenu)

See CommandLinkAdded Event (C1CommandMenu).


CommandLinkRemoved Event (C1ContextMenu)

CommandLinkRemoved Event (C1ContextMenu)

See CommandLinkRemoved Event (C1CommandMenu).


CommandStateQuery Event (C1ContextMenu)

CommandStateQuery Event (C1ContextMenu)

See CommandStateQuery Event (C1CommandMenu).


Popup Event (C1ContextMenu)

Popup Event (C1ContextMenu)

See Popup Event (C1CommandMenu).


Select Event (C1ContextMenu)

Select Event (C1ContextMenu)

See Select Event (C1Command).


C1CommandMdiList class

The C1CommandMdiList component is a command which at runtime expands to a list of items corresponding to the MDI child windows of the current window. Note that this is not a submenu. You can either put this command in a submenu all by itself, or add other menu items before or after it.

Inherits from C1Command.

C1CommandMdiList Members

C1CommandMdiList Properties

C1CommandMdiList Methods

C1CommandMdiList Events


C1CommandMdiList Members

C1CommandMdiList Public Properties

Category (Inherited from C1Command) | Specifies the category of the command.
CheckAutoToggle (Inherited from C1Command) | Determines whether the Checked property value is toggled automatically.
Checked (Inherited from C1Command) | Determines whether the command is checked.
DropDown (Inherited from C1Command) | Determines whether the command has a dropdown arrow when it is in a toolbar.
Enabled (Inherited from C1Command) | Determines whether the command is enabled.
Image (Inherited from C1Command) | Gets or sets the command image.
ImageIndex (Inherited from C1Command) | Gets or sets the index of the command image.
IsParent (Inherited from C1Command) | Determines if the parent control is a C1Command component.
ListHidden | Gets or sets the value indicating whether to list hidden windows.
MaxItems | Sets or returns the maximum number of menu items which can be created.
Mnemonic (Inherited from C1Command) | Returns the value of the mnemonic character, or the character following the ampersand (&), to be used as an access key.
Owner (Inherited from C1Command) | Specifies the C1CommandHolder containing this command.
Pressed (Inherited from C1Command) | Determines whether the command is pressed.
Shortcut (Inherited from C1Command) | Specifies the keyboard shortcut associated with the command.
ShowShortcut (Inherited from C1Command) | Indicates whether the shortcut for this command will be shown.
ShowTextAsToolTip (Inherited from C1Command) | Indicates whether this command's text will be shown as a tool tip.
Text | Specifies the command text.
ToolTipText (Inherited from C1Command) | Gets or sets the text for the tool tip.
UserData (Inherited from C1Command) | Arbitrary data that can be associated with the command.
Visible (Inherited from C1Command) | Determines whether the command is visible.

C1CommandMdiList Public Methods

Invoke | Fires the Click event and selects the specified MDI child window.
IsEmpty | Returns true if there are currently no items in the list.
PerformClick (Inherited from C1Command) | Generates a click event for the C1Command.
PerformSelect (Inherited from C1Command) | Selects the command.
ShowSelectorWindow | Shows a popup window with the list of MDI child windows.
StateQuery (Inherited from C1Command) | Fires the CommandStateQuery event, updates any changed properties.

C1CommandMdiList Public Events

BeforeSelectWindow | Fires before the Select MDI child window dialog box is shown.
CheckedChanged (Inherited from C1Command) | Fires when the Checked property has changed.
Click (Inherited from C1Command) | Fires when the command is invoked by the user.
CommandLinkAdded (Inherited from C1Command) | Fires after a command link is linked to this command.
CommandLinkRemoved (Inherited from C1Command) | Fires after a command link is unlinked from this command.
CommandStateQuery (Inherited from C1Command) | Fires when the command state has to be verified.
Select (Inherited from C1Command) | Fires when the command is selected by the user.


C1CommandMdiList Properties

Category Property (C1CommandMdiList)

CheckAutoToggle Property (C1CommandMdiList)

Checked Property (C1CommandMdiList)

DropDown Property (C1CommandMdiList)

Enabled Property (C1CommandMdiList)

Image Property (C1CommandMdiList)

ImageIndex Property (C1CommandMdiList)

IsParent Property (C1CommandMdiList)

ListHidden Property

MaxItems Property

Mnemonic Property (C1CommandMdiList)

Owner Property (C1CommandMdiList)

Pressed Property (C1CommandMdiList)

Shortcut Property (C1CommandMdiList)

ShowShortcut Property (C1CommandMdiList)

ShowTextAsToolTip Property (C1CommandMdiList)

Text Property (C1CommandMdiList)

ToolTipText Property (C1CommandMdiList)

UserData Property (C1CommandMdiList)

Visible Property (C1CommandMdiList)


Category Property (C1CommandMdiList)

Category Property (C1CommandMdiList)

See Category Property (C1Command).


CheckAutoToggle Property (C1CommandMdiList)

CheckAutoToggle Property (C1CommandMdiList)

See CheckAutoToggle Property (C1Command).


Checked Property (C1CommandMdiList)

Checked Property (C1CommandMdiList)

See Checked Property (C1Command).


DropDown Property (C1CommandMdiList)

DropDown Property (C1CommandMdiList)

See DropDown Property (C1Command).


Enabled Property (C1CommandMdiList)

Enabled Property (C1CommandMdiList)

See Enabled Property (C1Command).


Image Property (C1CommandMdiList)

Image Property (C1CommandMdiList)

See Image Property (C1Command).


ImageIndex Property (C1CommandMdiList)

ImageIndex Property (C1CommandMdiList)

See ImageIndex Property (C1Command).


IsParent Property (C1CommandMdiList)

IsParent Property (C1CommandMdiList)

See IsParent Property (C1Command).


ListHidden Property

ListHidden Property

Gets or sets the value indicating whether to list hidden windows.

Syntax

[VB]

Public Property ListHidden As String

[C#]

public string ListHidden {get; set;}

[Delphi]

property ListHidden: string;

See Also

C1CommandMdiList class


MaxItems Property

MaxItems Property

Sets or returns the maximum number of menu items created.

Syntax

[VB]

Public Property MaxItems As Integer

[C#]

public int MaxItems {get; set;}

[Delphi]

property MaxItems: Integer;

Remarks

By default, not more than 10 MDI child windows are displayed in the menu. I.e. the C1CommandMdiList command expands to up to 10 menu items corresponding to child windows, and if there are more, an item with the text “More…” is added after the tenth item, which if selected pops up a separate window with the whole list. Using this property, the maximum number of windows can be adjusted.

See Also

C1CommandMdiList class


Mnemonic Property (C1CommandMdiList)

Mnemonic Property (C1CommandMdiList)

See Mnemonic Property (C1Command).


Owner Property (C1CommandMdiList)

Owner Property (C1CommandMdiList)

See Owner Property (C1Command).


Pressed Property (C1CommandMdiList)

Pressed Property (C1CommandMdiList)

See Pressed Property (C1Command).


Shortcut Property (C1CommandMdiList)

Shortcut Property (C1CommandMdiList)

See Shortcut Property (C1Command).


ShowShortcut Property (C1CommandMdiList)

ShowShortcut Property (C1CommandMdiList)

See ShowShortcut Property (C1Command).


ShowTextAsToolTip Property (C1CommandMdiList)

ShowTextAsToolTip Property (C1CommandMdiList)

See ShowTextAsToolTip Property (C1Command).


Text Property (C1CommandMdiList)

Text Property (C1CommandMdiList)

See Text Property (C1Command).


ToolTipText Property (C1CommandMdiList)

ToolTipText Property (C1CommandMdiList)

See ToolTipText Property (C1Command).


UserData Property (C1CommandMdiList)

UserData Property (C1CommandMdiList)

See UserData Property (C1Command).


Visible Property (C1CommandMdiList)

Visible Property (C1CommandMdiList)

See Visible Property (C1Command).


C1CommandMdiList Methods

Invoke Method (C1CommandMdiList)

IsEmpty Method (C1CommandMdiList)

PerformClick Method (C1CommandMdiList)

PerformSelect Method (C1CommandMdiList)

ShowSelectorWindow Method

StateQuery Method (C1CommandMdiList)


Invoke Method (C1CommandMdiList)

Invoke Method (C1CommandMdiList)

This method should not be called directly, as there is no clear meaning in invoking a command which is actually a placeholder for commands created on the fly.


IsEmpty Method (C1CommandMdiList)

IsEmpty Method (C1CommandMdiList)

Returns true if there are currently no items in the list.

Syntax

[VB]

Public Function IsEmpty() As Boolean

[C#]

public bool IsEmpty()

[Delphi]

function IsEmpty: Boolean;

See Also

C1CommandMdiList class


PerformClick Method (C1CommandMdiList)

PerformClick Method (C1CommandMdiList)

See PerformClick Method (C1Command).


PerformSelect Method (C1CommandMdiList)

PerformSelect Method (C1CommandMdiList)

See PerformSelect Method (C1Command).


ShowSelectorWindow Method

ShowSelectorWindow Method

Populates and shows the popup window with the list of all currently available MDI child windows.

Syntax

[VB]

Public Sub ShowSelectorWindow()

[C#]

public void ShowSelectorWindow ( )

[Delphi]

procedure ShowSelectorWindow;

Remarks

The form shown by this method can be customized by handling the BeforeSelectWindow event of the C1CommandMdiList object.

See Also

C1CommandMdiList class

BeforeSelectWindow Event

BeforeSelectWindowEventHandler Delegate

BeforeSelectWindowEventArgs class


StateQuery Method (C1CommandMdiList)

StateQuery Method (C1CommandMdiList)

See StateQuery Method (C1Command).


C1CommandMdiList Events

BeforeSelectWindow Event

CheckedChanged Event (C1CommandMdiList)

Click Event (C1CommandMdiList)

CommandLinkAdded Event (C1CommandMdiList)

CommandLinkRemoved Event (C1CommandMdiList)

CommandStateQuery Event (C1CommandMdiList)

Select Event (C1CommandMdiList)


BeforeSelectWindow Event

BeforeSelectWindow Event

Fires before the Select Window dialog box is shown.

Syntax

[VB]

Public Event BeforeSelectWindow(sender As Object, e As BeforeSelectWindowEventArgs) As BeforeSelectWindowEventHandler

[C#]

public event BeforeSelectWindowEventHandler BeforeSelectWindow

[Delphi]

property BeforeSelectWindow: BeforeSelectWindowEventHandler;

Event Data

The event handler receives an argument of type BeforeSelectWindowEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
SelectWindowForm | The window or dialog box selected.

Remarks

This event can be used to customize the form used to show the list of available MDI child windows.

See Also

C1CommandMdiList class


CheckedChanged Event (C1CommandMdiList)

CheckedChanged Event (C1CommandMdiList)

See CheckedChanged Event (C1Command).


Click Event (C1CommandMdiList)

Click Event (C1CommandMdiList)

See Click Event (C1Command).


CommandLinkAdded Event (C1CommandMdiList)

CommandLinkAdded Event (C1CommandMdiList)

See CommandLinkAdded Event (C1Command).


CommandLinkRemoved Event (C1CommandMdiList)

CommandLinkRemoved Event (C1CommandMdiList)

See CommandLinkRemoved Event (C1Command).


CommandStateQuery Event (C1CommandMdiList)

CommandStateQuery Event (C1CommandMdiList)

See CommandStateQuery Event (C1Command).


Select Event (C1CommandMdiList)

Select Event (C1CommandMdiList)

See Select Event (C1Command).


C1CommandLink class

C1CommandLink is a component that represents a C1Command in a specific menu or toolbar. A command link always lives inside either a menu (main or popup) or a toolbar. Depending on its host (menu or toolbar), a command link can have visible appearance of either a main menu item, a popup menu item or a toolbar button. A command link must point to a specific command object (of the type C1Command or a derived type) to actually do something when selected by the user.

Command links serve several important purposes. First of all, they allow several items (e.g., a menu item and a toolbar button) to point to the same command, thus saving time and effort in defining the command’s behavior and actions. They provide for better consistency in menus and toolbars, as a command’s state is automatically updated across all links pointing to the command. They also allow overriding the command’s text in certain places (e.g., have an “Open” command read “File open” in a context menu). Finally, a command link can draw a delimiter before itself in a menu or toolbar.

Command links are not shown in the component tray. To access them, use their hosting component (main menu, popup menu or toolbar).


C1CommandLink Members

C1CommandLink Public Properties

AlwaysRecent | Gets or sets the value indicating whether the item is always recent (is never hidden when hiding non-recent links is on).
Bounds | Returns the bounding rectangle of the command link.
ButtonLook | Gets or sets the value used to determine how this link should look in a toolbar.
CheckRect | Returns the check mark rectangle.
Command | Gets or sets the command this command link points to.
DefaultItem | Gets or sets a value indicating whether this item is default in a dropdown or context menu.
Delimiter | Gets or sets a value indicating whether a delimiter should be drawn before this item.
Enabled | Shortcut to the linked command's Enabled property.
ImageRect | Returns the image rectangle of the command link.
Index | Gets the index of the link in the containing CommandLinks collection.
IsEnabledParent | Returns True if the linked command is enabled and contains a submenu.
IsMoreLink | Returns True if the link points to the "More..." command.
IsServiceLink | Indicated if this link is a “service” link (such as more, customize, scroll button).
MergeOrder | Gets or sets a value indicating the relative position of the menu item when it is merged with another.
MergeType | Gets or sets a value indicating the behavior of this menu item when its menu is merged with another.
NewColumn | Gets or sets the value indicating whether this link starts a new column in the menu.
Owner | Gets the object (menu, toolbar, etc.) containing this command link.
OwnerDraw | Gets or sets a value indicating whether this item is drawn by DrawLink handle.
SortOrder | Gets or sets a value determining the relative position of the item.
State | Gets the current state of the command link (normal, hot, pressed, open).
Text | Gets or sets the text associated with the command link. Allows to override the linked command’s text.
TextRect | Returns the text rectangle of the command link.
ToolTipText | If set, overrides the Command tooltip text.
Visible | Shortcut to the linked command's Visible property.

C1CommandLink Public Events

AlwaysRecentChanged | Fires when the AlwaysRecent property of C1CommandLink is changed.
ButtonLookChanged | Fires when the ButtonLook property of C1CommandLink is changed.
DelimiterChanged | Fires when the Delimiter property of C1CommandLink is changed.
MergeOrderChanged | Fires when the MergeOrder property of C1CommandLink is changed.
MergeTypeChanged | Fires when the MergeType property of C1CommandLink is changed.
NewColumnChanged | Fires when the NewColumn property of C1CommandLink is changed.
TextChanged | Fires when the Text property of C1CommandLink is changed.
ToolTipChanged | Fires when the ToolTip property of C1CommandLink is changed.


C1CommandLink Properties

AlwaysRecent Property

Bounds Property

ButtonLook Property

CheckRect Property

Command Property

DefaultItem Property

Delimiter Property

Enabled Property (C1CommandLink)

ImageRect Property

Index Property (C1CommandLink)

IsEnabledParent Property

IsMoreLink Property

IsServiceLink Property

MergeOrder Property

MergeType Property

NewColumn Property

Owner Property (C1CommandLink)

OwnerDraw Property (C1CommandLink)

SortOrder Property

State Property

Text Property (C1CommandLink)

TextRect Property

ToolTipText Property (C1CommandLink)

Visible Property (C1CommandLink)


AlwaysRecent Property

AlwaysRecent Property

Gets or sets the value indicating whether the item is always recent (is never hidden when hiding non-recent links is on).

Syntax

[VB]

Public Property AlwaysRecent As Boolean

[C#]

public bool AlwaysRecent {get; set;}

[Delphi]

property AlwaysRecent: Boolean;

Remarks

Set this to true for items you want to be shown always, regardless of how often or rarely they are clicked.

See Also

C1CommandLink class


Bounds Property

Bounds Property

Returns the bounding rectangle of the command link.

Syntax

[VB]

Public ReadOnly Property Bounds As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle Bounds {get;}

[Delphi]

property Bounds: System.Drawing.Rectangle;

See Also

C1CommandLink class


ButtonLook Property

ButtonLook Property

Gets or sets the value used to determine how this link should look in a toolbar.

Syntax

[VB]

Public Property ButtonLook As ButtonLookFlags

[C#]

public ButtonLookFlags ButtonLook {get; set;}

[Delphi]

property ButtonLook: ButtonLookFlags;

Remarks

This property is relevant only for command links in a toolbar. By default this property has the ButtonLookFlags.Default value which essentially leaves the way the link looks up to the container toolbar. Adjusting this property allows to specify the preferred look (but it is still up to the toolbar to respect or override it).

See Also

C1CommandLink class

ButtonLayoutHorz property

ButtonLayoutVert property

ButtonLookEnforceHorz property

ButtonLookEnforceVert property

ButtonLookHorz property

ButtonLookVert property


CheckRect Property

CheckRect Property

Returns the check mark rectangle.

Syntax

[VB]

Public ReadOnly Property CheckRect As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle CheckRect {get;}

[Delphi]

property CheckRect: System.Drawing.Rectangle;

See Also

C1CommandLink class


Command Property

Command Property

Gets or sets a command in the CommandLinks collection.

Syntax

[VB]

Public Property Command As C1Command

[C#]

public C1Command Command {get; set;}

[Delphi]

property Command: C1Command;

Remarks

When a new command link is created, its Command property is set to point to the C1Command.Empty static member of the C1Command class (this property never has the null value). In order to actually perform some useful action, this property must be set to point to a user-defined command.

See Also

C1CommandLink class


DefaultItem Property

DefaultItem Property

Gets or sets a value indicating whether this item is default in a dropdown or context menu.

Syntax

[VB]

Public Property DefaultItem As Boolean

[C#]

public Boolean DefaultItem {get;}

[Delphi]

property DefaultItem: Boolean;

Remarks

Default is false. If true, the item in dropdown or context menus is drawn using bold font.

See Also

C1CommandLink class


Delimiter Property

Delimiter Property

Gets or sets a value indicating whether a delimiter should be drawn before this item.

Syntax

[VB]

Public Property Delimiter As Boolean

[C#]

public bool Delimiter {get; set;}

[Delphi]

property Delimiter: Boolean;

See Also

C1CommandLink class


Enabled Property (C1CommandLink)

Enabled Property (C1CommandLink)

Shortcut to linked command's Enabled property.

Syntax

[VB]

Public ReadOnly Property Enabled As Boolean

[C#]

public bool Enabled {get;}

[Delphi]

property Enabled: Boolean;

Remarks

This property is only a shortcut to the linked command’s Enabled property.

See Also

C1CommandLink class


ImageRect Property

ImageRect Property

Returns the image rectangle of the command link.

Syntax

[VB]

Public ReadOnly Property ImageRect As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle ImageRect {get;}

[Delphi]

property ImageRect: System.Drawing.Rectangle;

See Also

C1CommandLink class


Index Property (C1CommandLink)

Index Property (C1CommandLink)

Gets the index of the link in the containing CommandLinks collection.

Syntax

[VB]

Public ReadOnly Property Index As Integer

[C#]

public int Index {get;}

[Delphi]

property Index: Integer;

See Also

C1CommandLink class


IsEnabledParent Property

IsEnabledParent Property

Returns True if the linked command is enabled and contains a submenu.

Syntax

[VB]

Public ReadOnly Property IsEnabledParent As Boolean

[C#]

public bool IsEnabledParent {get;}

[Delphi]

property IsEnabledParent: Boolean;

See Also

C1CommandLink class


IsMoreLink Property

IsMoreLink Property

Returns True if the link points to the "More..." command.

Syntax

[VB]

Public ReadOnly Property IsMoreLink As Boolean

[C#]

public bool IsMoreLink {get;}

[Delphi]

property IsMoreLink: Boolean;

See Also

C1CommandLink class


IsServiceLink Property

IsServiceLink Property

Indicated if this link is a “service” link (such as more, customize, scroll button.").

Syntax

[VB]

Public ReadOnly Property IsServiceLink As Boolean

[C#]

public bool IsServiceLink {get;}

[Delphi]

property IsServiceLink: Boolean;

See Also

C1CommandLink class


MergeOrder Property

MergeOrder Property

Gets or sets a value indicating the relative position of the menu item when it is merged with another.

Syntax

[VB]

Public Property MergeOrder As Integer

[C#]

public bool MergeOrder {get; set;}

[Delphi]

property MergeOrder: Integer;

Remarks

This property behaves in the same manner as the standard .NET Framework’s MenuItem.MergeOrder.

See Also

C1CommandLink class

MergeType property


MergeType Property

MergeType Property

Gets or sets a value indicating the behavior of this menu item when its menu is merged with another.

Syntax

[VB]

Public Property MergeType As MenuMerge

[C#]

public MenuMerge MergeType {get; set;}

[Delphi]

property MergeType: MenuMerge;

Remarks

This property behaves in the same manner as the standard .NET Framework’s MenuItem.MergeType.

See Also

C1CommandLink class

MergeOrder property


NewColumn Property

NewColumn Property

Gets or sets the value indicating whether this link starts a new column in the menu.

Syntax

[VB]

Public Property NewColumn As Boolean

[C#]

public bool NewColumn {get; set;}

[Delphi]

property NewColumn: Boolean;

See Also

C1CommandLink class


Owner Property (C1CommandLink)

Owner Property (C1CommandLink)

Gets the object (menu, toolbar, etc.) containing this command link.

Syntax

[VB]

Public ReadOnly Property Owner As Object

[C#]

public object Owner {get;}

[Delphi]

property Owner: Object;

See Also

C1CommandLink class


OwnerDraw Property (C1CommandLink)

OwnerDraw Property (C1CommandLink)

Gets or sets a value indicating whether this item is drawn by DrawLink handle.

Syntax

[VB]

Public Property OwnerDraw As Boolean

[C#]

public bool OwnerDraw {get; set;}

[Delphi]

property OwnerDraw: Boolean;

See Also

C1CommandLink class


SortOrder Property

SortOrder Property

Gets or sets a value determining the relative position of the item.

Syntax

[VB]

Public Property SortOrder As Integer

[C#]

public int SortOrder {get; set; }

[Delphi]

property SortOrder: Integer;

Remarks

Please note, for menus/toolbars in inherited forms to work correctly, the following sequence of actions must be performed:

· The parent form will need to be recreated. In particular, all menus, toolbars and commands must be created on that form, and must be declared either public or protected. Also, the command holder (typically called c1CommandHolder1) must be declared public or protected.

· The form must be compiled. Only after that, the inherited form may be designed.

Failing to observe the above sequence will result in errors.

See Also

C1CommandLink class


State Property

State Property

Gets the current state of the command link (normal, hot, pressed, open).

Syntax

[VB]

Public ReadOnly Property State As ItemStateEnum

[C#]

public ItemStateEnum State {get;}

[Delphi]

property State: ItemStateEnum;

See Also

C1CommandLink class


Text Property (C1CommandLink)

Text Property (C1CommandLink)

Specifies the command text.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: String;

Remarks

Initially, this property is set up to return the value of the linked command’s Text property. Setting this property to any non-null and non-empty string overrides the default value breaks this dependency. You can always reset it to the default behavior by setting this property to a null or to an empty string.

Note

Command links with the Text property equal to “-“ are interpreted as pure delimiters.

See Also

C1CommandLink class


TextRect Property

TextRect Property

Returns the text rectangle of the command link.

Syntax

[VB]

Public ReadOnly Property TextRect As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle TextRect {get;}

[Delphi]

property TextRect: System.Drawing.Rectangle;

See Also

C1CommandLink class


ToolTipText Property (C1CommandLink)

ToolTipText Property (C1CommandLink)

If set, overrides the Command tooltip text.

Syntax

[VB]

Public Property ToolTipText As String

[C#]

public string ToolTipText {get; set;}

[Delphi]

property ToolTipText: string;

See Also

C1CommandLink class


Visible Property (C1CommandLink)

Visible Property (C1CommandLink)

Shortcut to the linked command's Visible property.

Syntax

[VB]

Public ReadOnly Property Visible As Boolean

[C#]

public bool Visible {get;}

[Delphi]

property Visible: Boolean;

Remarks

This property is only a shortcut to the linked command’s Visible property.

See Also

C1CommandLink class


C1CommandLink Events

AlwaysRecentChanged Event (C1CommandLink)

ButtonLookChanged Event (C1CommandLink)

DelimiterChanged Event

MergeOrderChanged Event

MergeTypeChanged Event

NewColumnChanged Event

TextChanged Event (C1CommandLink)

ToolTipChanged Event (C1CommandLink)


AlwaysRecentChanged Event (C1CommandLink)

AlwaysRecentChanged Event (C1CommandLink)

Event fired when the AlwaysRecent property of C1CommandLink is changed.

Syntax

[VB]

Public Event AlwaysRecentChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler AlwaysRecentChanged

[Delphi]

property AlwaysRecentChanged: EventHandler;

See Also

C1CommandLink class


ButtonLookChanged Event (C1CommandLink)

ButtonLookChanged Event (C1CommandLink)

Event fired when the ButtonLook property of C1CommandLink is changed.

Syntax

[VB]

Public Event ButtonLookChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLookChanged

[Delphi]

property ButtonLookChanged: EventHandler;

See Also

C1CommandLink class


DelimiterChanged Event

DelimiterChanged Event

Event fired when the Delimiter property of C1CommandLink is changed.

Syntax

[VB]

Public Event DelimiterChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler DelimiterChanged

[Delphi]

property DelimiterChanged: EventHandler;

See Also

C1CommandLink class


MergeOrderChanged Event

MergeOrderChanged Event

Event fired when the MergeOrder property of C1CommandLink is changed.

Syntax

[VB]

Public Event MergeOrderChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler MergeOrderChanged

[Delphi]

property MergeOrderChanged: EventHandler;

See Also

C1CommandLink class


MergeTypeChanged Event

MergeTypeChanged Event

Event fired when the MergeType property of C1CommandLink is changed.

Syntax

[VB]

Public Event MergeTypeChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler MergeTypeChanged

[Delphi]

property MergeTypeChanged: EventHandler;

See Also

C1CommandLink class


NewColumnChanged Event

NewColumnChanged Event

Event fired when the NewColumn property of C1CommandLink is changed.

Syntax

[VB]

Public Event NewColumnChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler NewColumnChanged

[Delphi]

property NewColumnChanged: EventHandler;

See Also

C1CommandLink class


TextChanged Event (C1CommandLink)

TextChanged Event (C1CommandLink)

Event fired when the Text property of C1CommandLink is changed.

Syntax

[VB]

Public Event TextChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler TextChanged

[Delphi]

property TextChanged: EventHandler;

See Also

C1CommandLink class


ToolTipChanged Event (C1CommandLink)

ToolTipChanged Event (C1CommandLink)

Event fired when the ToolTipText property of C1CommandLink is changed.

Syntax

[VB]

Public Event ToolTipChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ToolTipChanged

[Delphi]

property ToolTipChanged: EventHandler;

See Also

C1CommandLink class


C1CommandLinks class

The C1CommandLinks class is a collection of C1Commandlink objects. It inherits from Systems.Collection.ArrayList.


C1CommandLinks Members

C1CommandLinks Public Property

Item

Indicates the command link at the specified indexed location in the collection.

C1CommandLinks Public Methods

BeginUpdate | Begins an update block. Suspends updates to the containing menu or toolbar until a call to EndUpdate.
EndUpdate | Ends an update block. Updates the containing menu or toolbar if necessary.
MoveTo | Moves the specified link (which must belong to the collection) to the new position.
ResetLinksUsage | Resets usage statistics for the command links.


C1CommandLinks Property

Item Property


Item Property

Item Property

Indicates the command link at the specified indexed location in the collection.

Syntax

[VB]

Default Public Property Item(ByVal index As Integer) As C1.Win.C1Command.C1CommandLink

[C#]

public C1.Win.C1Command.C1CommandLink this[] {get; set;}

[Delphi]

property Item: (index: Integer): C1.Win.C1Command.C1CommandLink;

See Also

C1CommandHolder class


C1CommandLinks Methods

BeginUpdate Method

EndUpdate Method (C1CommandLinks)

MoveTo Method

ResetLinksUsage Method


BeginUpdate Method

BeginUpdate Method

Begins an update block. Suspends updates to the containing menu or toolbar until a call to EndUpdate.

Syntax

[VB]

Public Sub BeginUpdate()

[C#]

public void BeginUpdate ( )

[Delphi]

procedure BeginUpdate;

See Also

C1CommandLinks class


EndUpdate Method (C1CommandLinks)

EndUpdate Method (C1CommandLinks)

Ends an update block. Updates the containing menu or toolbar if necessary.

Syntax

[VB]

Public Sub EndUpdate()

[C#]

public void EndUpdate ( )

[Delphi]

procedure EndUpdate;

See Also

C1CommandLinks class


MoveTo Method

MoveTo Method

Moves the specified link (which must belong to the collection) to the new position.

Syntax

[VB]

Public Sub MoveTo(ByVal cl As C1.Win.C1Command.C1CommandLink, ByVal newindex As Integer)

[C#]

public void MoveTo (C1.Win.C1Command.C1CommandLink cl , System.Int32 newindex)

[Delphi]

procedure MoveTo(cl: C1.Win.C1Command.C1CommandLink; newindex: Integer);

See Also

C1CommandLInks class


ResetLinksUsage Method

ResetLinksUsage Method

Resets usage statistics for the command links.

Syntax

[VB]

Public Sub ResetLinksUsage()

[C#]

public void ResetLinksUsage()

[Delphi]

procedure ResetLinksUsage;

See Also

C1CommandLInks class


C1CommandHolder class

The C1CommandHolder component provides a centralized location for all C1Command components on a form. When a new C1Command is created, a C1CommandHolder instance is automatically added to the form if one does not exist already. And, a form cannot contain more than one command holder (if you attempt to create a second instance, an error will occur).

C1CommandHolder Members

C1CommandHolder Properties

C1CommandHolder Methods

C1CommandHolder Events


C1CommandHolder Members

C1CommandHolder Public Properties

AutoSaveLayout | Gets or sets the value indicating whether to automatically save the toolbars layout (for this to work, Layout must be added to dynamic properties).
Commands | Returns the list of commands in the C1Command collection.
CustomizerFormClassName | Gets or sets the class name of the Customizer form.
ImageList | Gets or sets the image list for command images.
ImageTransparentColor | Gets or sets the transparent color for images not in the image list.
Layout | Gets or sets the toolbars layout. To enable automatic layout persistence, add this property to dynamic properties.
LayoutKeyName | Gets or sets a name of the layout dynamic key in the application config file
LookAndFeel | Gets or sets the look and feel of the menus and toolbars.
MainMenu | Returns the main menu contained in the C1CommandHolder.
NewToolbarFormClassName | Gets or sets the class name of the Customizer's new toolbar dialog form.
Owner | Gets or sets the control which is the owner of this command holder. Normally this property is set automatically and should not be changed.
RecentLinksRunCount | Gets or sets the value indicating how many times the app must be run before rarely used menu items start hiding.
RecentLinksThreshold | Gets or sets the threshold (in percent) for an item to be considered rarely used. The higher the value, the more items are hidden.
SelectMdiChildFormClassName | Gets or sets the class name of the MDI child selection dialog form.
ShowNonRecentLinksHoverDelay | Gets or sets the delay (in seconds) for the mouse to hover over the parent menu item in order to show all rarely used item.
SmoothImages | Draw smooth images for currently unselected items.
StateUpdateOnIdle | Gets or sets the value indicating whether to update the commands' state when the form is idle.
UIStrings | Gets the array of user interface strings.

C1CommandHolder Public Methods

CommandHolderByForm | Returns to command holder for the form, if any.
CreateCommand | Creates a new command and adds it to the Commands collection.
CreateCommandHolder | Creates a command holder for the specified form and does all the necessary initializations.
Customize | Invokes toolbar customizer.
FindCommand | Gets the C1Command associated with the shortcut.
GetC1ContextMenu | Gets a context menu contained within the C1CommandHolder.
HandleMessage | Passes the message to the holder for handling.
InstallMessageFilter | Installs the message filter for the application. This is normally done automatically when the application starts.
LayoutLoadFromAppConfig | Loads layout data from the application config file.
LayoutReset | Resets layout.
LayoutSaveInAppConfig | Saves the layout data into the application config file.
MergeCommandLinks | Merges command links from links1 and links2 into result, using merge rules specified with links, similar to MDI merge.
SaveDefaultLayout | Sets the current layout to be the default( the one the customizer's reset button reverts to).
SetC1ContextMenu | Sets a context menu contained within the C1CommandHolder.
UninstallMessageFilter | Uninstalls the message filter.
UnmergeCommandLinks | Unmerges the two collections of links merged previously by MergeCommandLinks

C1CommandHolder Public Events

CommandClick | Fires when the user invokes a command.
CustomizationFinished | Occurs when customization mode finishes.
CustomizationStarted | Occurs when customization mode starts.
CustomizeLinkAdded | Occurs when a new command link is added to an existing toolbar during customization.
CustomizeLinkRemoved | Occurs when a command link is removed from a toolbar during customization.
CustomizeToolBarAdded | Occurs when a new toolbar is added or a hidden toolbar becomes visible during customization.
CustomizeToolBarRemoved | Occurs when a visible toolbar is hidden during customization.
LayoutLoad | Fires when layout data is loaded.
LayoutSave | Fires when layout data is saved.
LookAndFeelChanged | Occurs when the LookAndFeel property value changes.
RecentLinksRunCountChanged | Occurs when the RecentLinksRunCount property value changes
RecentLinksThresholdChanged | Occurs when the RecentLinksThreshold property value changes
ShowNonRecentLinksHoverDelayChanged | Occurs when the ShowNonRecentLinksHoverDelay property value changes


C1CommandHolder Properties

AutoSaveLayout Property

Commands Property

CustomizerFormClassName Property

ImageList Property

ImageTransparentColor Property

Layout Property

LayoutKeyName Property

LookAndFeel Property (C1CommandHolder)

MainMenu Property

NewToolbarFormClassName Property

Owner Property

RecentLinksRunCount Property

RecentLinksThreshold Property

SelectMdiChildFormClassName Property

ShowNonRecentLinksHoverDelay Property

SmoothImages Property

StateUpdateOnIdle Property

UIStrings Property


AutoSaveLayout Property

AutoSaveLayout Property

Gets or sets the value indicating whether to automatically save the toolbars layout (for this to work, Layout must be added to dynamic properties).

Syntax

[VB]

Public Property AutoSaveLayout As Boolean

[C#]

public bool AutoSaveLayout {get; set;}

[Delphi]

property AutoSaveLayout: Boolean;

See Also

C1CommandHolder class


Commands Property

Commands Property

Returns the list of commands in the C1Command collection.

Syntax

[VB]

Public ReadOnly Property Commands As C1Commands

[C#]

public C1Commands Commands {get;}

[Delphi]

property Commands: C1Commands;

Remarks

This property can be used to enumerate all commands which exist on a form.

See Also

C1CommandHolder class


CustomizerFormClassName Property

CustomizerFormClassName Property

Gets or sets the class name of the Customizer form.

Syntax

[VB]

Public Property CustomizerFormClassName As String

[C#]

public string CustomizerFormClassName {get; set;}

[Delphi]

property CustomizerFormClassName: string;

Remarks

This property can be used to provide a custom form for the customizer. By default, the value of this property is C1.Win.C1Command.C1CustomizerForm (that class is defined in the C1Command dll). To provide your own custom customizer form, add a new inherited form to your project, specify C1.Win.C1Command.C1CustomizerForm as the base class for your form, and adjust its appearance and/or behavior to suit your needs.

See Also

C1CommandHolder class


ImageList Property

ImageList Property

Gets or sets the image list for command images.

Syntax

[VB]

Public Property ImageList As ImageList

[C#]

public ImageList ImageList {get; set;}

[Delphi]

property ImageList: ImageList;

Remarks

A command can have its image specified in one of two ways: either by an index into the image list specified by this property, or directly by an image. These two ways are not mutually exclusive, although using the image list is probably preferable from the performance point of view.

See Also

C1CommandHolder class


ImageTransparentColor Property

ImageTransparentColor Property

Gets or sets the transparent color for images not in an image list.

Syntax

[VB]

Public Property ImageTransparentColor As Color

[C#]

public Color ImageTransparentColor {get; set}

[Delphi]

property ImageTransparentColor: Color;

Remarks

For command images specified directly, this property determines the transparent color. For images from the image list, image list’s own transparent color is used.

See Also

C1CommandHolder class


Layout Property

Layout Property

Gets or sets the toolbars layout. To enable automatic layout persistence, add this property to dynamic properties.

Syntax

[VB]

Public Property Layout As String

[C#]

public string Layout {get; set;}

[Delphi]

property Layout: string;

Remarks

If the form has customizable toolbars (see CustomizeButton property), you can enable automatic persistence of end user toolbar customizations in the application config file by adding this property to the list of dynamic properties. Alternatively, you can persist end user customizations elsewhere by saving/restoring this property programmatically.

See Also

C1CommandHolder class

CustomizeButton property


LayoutKeyName Property

LayoutKeyName Property

Gets or sets a name of the layout dynamic key in the application config file.

Syntax

[VB]

Public Property LayoutKeyName As String

[C#]

public string LayoutKeyName {get; set;}

[Delphi]

property LayoutKeyName: string;

See Also

C1CommandHolder class


LookAndFeel Property (C1CommandHolder)

LookAndFeel Property (C1CommandHolder)

Gets or sets the look and feel of the menus and toolbars.

Syntax

[VB]

Public Property LookAndFeel As LookAndFeelEnum

[C#]

public LookAndFeelEnum LookAndFeel {get; set;}

[Delphi]

property LookAndFeel: LookAndFeelEnum;

See Also

C1CommandHolder class


MainMenu Property

MainMenu Property

Returns the main menu for the form.

Syntax

[VB]

Public ReadOnly Property MainMenu As C1MainMenu

[C#]

public C1MainMenu MainMenu {get;}

[Delphi]

property MainMenu: C1MainMenu;

See Also

C1CommandHolder class


NewToolbarFormClassName Property

NewToolbarFormClassName Property

Gets or sets the class name of the Customizer's new toolbar dialog form.

Syntax

[VB]

Public Property NewToolbarFormClassName As String

[C#]

public string NewToolbarFormClassName {get; set;}

[Delphi]

property NewToolbarFormClassName: string;

Remarks

This property can be used to provide a custom form for the “create new toolbar” runtime dialog (shown by the customizer). By default, the value of this property is C1.Win.C1Command.C1NewToolbarForm (that class is defined in the C1Command dll). To provide your own custom form, add a new inherited form to your project, specify C1.Win.C1Command.C1NewToolbarForm as the base class for your form, and adjust its appearance and/or behavior to suit your needs.

See Also

C1CommandHolder class


Owner Property

Owner Property

Gets or sets the control which is the owner of this command holder. Normally this property is set automatically and should not be changed.

Syntax

[VB]

Public Property Owner As Control

[C#]

public Control Owner {get; set;}

[Delphi]

property Owner: Control;

Remarks

This property is for internal use, and should not normally be used by user code.

See Also

C1CommandHolder class


RecentLinksRunCount Property

RecentLinksRunCount Property

Gets or sets the value indicating how many times the app must be run before rarely used menu items start hiding.

Syntax

[VB]

Public Property RecentLinksRunCount As Integer

[C#]

public int RecentLinksRunCount {get; set;}

[Delphi]

property RecentLinksRunCount: Integer;

Remarks

The default is 5,which means that a particular application must be run at least 5 times before hiding rarely used items starts. Till then, only statistics is collected. Set this to 0 to turn the feature on immediately.

See Also

C1CommandHolder class


RecentLinksThreshold Property

RecentLinksThreshold Property

Gets or sets the threshold (in percent) for an item to be considered rarely used. The higher the value, the more items are hidden.

Syntax

[VB]

Public Property RecentLinksThreshold As Integer

[C#]

public int RecentLinksThreshold {get; set;}

[Delphi]

property RecentLinksThreshold: Integer;

Remarks

The default is 0, which effectively turns the whole feature (hiding menu items that have not been used for a long time) off (i.e. all items are considered "recently used"). Setting this property to a value between 0 and 100 turns the feature on. A good starting point is 50.

See Also

C1CommandHolder class


SelectMdiChildFormClassName Property

SelectMdiChildFormClassName Property

Gets or sets the class name of the MDI child selection dialog form.

Syntax

[VB]

Public Property SelectMdiChildFormClassName As String

[C#]

public string SelectMdiChildFormClassName {get; set;}

[Delphi]

property SelectMdiChildFormClassName: String;

Remarks

This property can be used to provide a custom form for the runtime dialog shown by the C1CommandMdiList command when the number of MDI children is too large to show them all in the menu. By default, the value of this property is C1.Win.C1Command.C1SelectMdiChildForm (that class is defined in the C1Command dll). To provide your own custom form, add a new inherited form to your project, specify C1.Win.C1Command.C1SelectMdiChildForm as the base class for your form, and adjust its appearance and/or behavior to suit your needs.

See Also

C1CommandHolder class


ShowNonRecentLinksHoverDelay Property

ShowNonRecentLinksHoverDelay Property

Gets or sets the delay (in seconds) for the mouse to hover over the parent menu item in order to show all rarely used item.

Syntax

[VB]

Public Property ShowNonRecentLinksHoverDelay As Integer

[C#]

public int ShowNonRecentLinksHoverDelay {get; set;}

[Delphi]

property ShowNonRecentLinksHoverDelay: Integer;

Remarks

A menu will also be expanded (all items shown) if the mouse hovers without clicking over the expansion arrow at the bottom of the menu.

See Also

C1CommandHolder class


SmoothImages Property

SmoothImages Property

Draw smooth images for currently unselected items.

Syntax

[VB]

Public Property SmoothImages As Boolean

[C#]

public bool SmoothImages {get; set;}

[Delphi]

property SmoothImages: Boolean;

Remarks

If True, images (except for the currently selected item's image) are "smoothed," i.e., drawn with less contrast. Setting this property to False disables this feature.

See Also

C1CommandHolder class


StateUpdateOnIdle Property

StateUpdateOnIdle Property

Gets or sets the value indicating whether to update commands' status when idle.

Syntax

[VB]

Public Property StateUpdateOnIdle As Boolean

[C#]

public bool StateUpdateOnIdle {get; set;}

[Delphi]

property StateUpdateOnIdle: Boolean;

Remarks

Commands’ state can be queried (via the CommandStateQuery event) and updated automatically when your application is idle. To enable this behavior, this property must be set to True (which is the default). Set this property to False to disable this behavior.

See Also

C1CommandHolder class


UIStrings Property

UIStrings Property

Customize and/or localize specified end user visible strings

Syntax

[VB]

Public ReadOnly Property UIStrings As UIStrings

[C#]

public UIStrings UIStrings {get;}

[Delphi]

property UIStrings: UIStrings;

Remarks

The UIStrings array is indexed by UIStringsEnum enumeration, which determines the valid values for customizable user interface strings.

See Also

C1CommandHolder class

UIStringsEnum enumeration


C1CommandHolder Methods

CommandHolderByForm Method

CreateCommand Method

CreateCommandHolder Method

Customize Method

FindCommand Method

GetC1ContextMenu Method

HandleMessage Method

InstallMessageFilter Method

LayoutLoadFromAppConfig Method

LayoutReset Method

LayoutSaveInAppConfig Method

MergeCommandLinks Method

SaveDefaultLayout Method

SetC1ContextMenu Method

UnInstallMessageFilter Method

UnMergeCommandLinks Method


CommandHolderByForm Method

CommandHolderByForm Method

Returns the command holder for the form, if any.

Syntax

[VB]

Public Shared Function CommandHolderByForm(form As Form) As C1CommandHolder

[C#]

public static C1CommandHolder CommandHolderByForm (Form form )

[Delphi]

function CommandHolderByForm(form: Form): C1CommandHolder; static;

See Also

C1CommandHolder class


CreateCommand Method

CreateCommand Method

Creates a new command and adds it to the Commands collection.

Syntax

[VB]

Public Function CreateCommand() As C1Command

Public Function CreateCommand(ByVal commandType as System.Type) As C1Command

[C#]

public C1Command CreateCommand()

public C1Command CreateCommand(SystemType commandType)

[Delphi]

function CreateCommand: C1Command;

function CreateCommand(commandType: System.Type): C1Command;

See Also

C1CommandHolder class


CreateCommandHolder Method

CreateCommandHolder Method

Creates a command holder for the specified form and does all the necessary initializations.

Syntax

[VB]

Public Shared Function CreateCommandHolder(form As Form) As C1CommandHolder

[C#]

public static C1CommandHolder CreateCommandHolder (Form form )

[Delphi]

function CreateCommandHolder(form: Form): C1CommandHolder; static;

Remarks

This is the preferred method for creating a command holder for a form at runtime.

See Also

C1CommandHolder class


Customize Method

Customize Method

Invokes toolbar customizer.

Syntax

[VB]

Public Sub Customize()

[C#]

public void Customize ( )

[Delphi]

procedure Customize;

See Also

C1CommandHolder class


FindCommand Method

FindCommand Method

Gets the C1Command associated with the shortcut.

Syntax

[VB]

Public Function FindCommand(shortcut As Shortcut) As C1Command

[C#]

public C1Command FindCommand (Shortcut shortcut )

[Delphi]

function FindCommand(shortcut: Shortcut): C1Command;

Parameter | Description
shortcut | The shortcut keys associated with the command.

See Also

C1CommandHolder class


GetC1ContextMenu Method

GetC1ContextMenu Method

Gets a context menu contained within the C1CommandHolder.

Syntax

[VB]

Public Function GetC1ContextMenu(control As Control) As C1ContextMenu

[C#]

public C1ContextMenu GetC1ContextMenu (Control control )

[Delphi]

function GetC1ContextMenu(control: Control);

Parameter | Description
control | The control for which to retrieve the context menu.

See Also

C1CommandHolder class


HandleMessage Method

HandleMessage Method

Passes the message to the holder for handling.

Syntax

[VB]

Public Shared Function HandleMessage(m As Message) As Boolean

[C#]

public static bool HandleMessage(Message m)

[Delphi]

function HandleMessage(m: Message): Boolean; static;

See Also

C1CommandHolder class


InstallMessageFilter Method

InstallMessageFilter Method

Installs the message filter for the application. This is normally done automatically when the application starts.

Syntax

[VB]

Public Shared Sub InstallMessageFilter()

[C#]

public static void InstallMessageFilter()

[Delphi]

procedure InstallMessageFilter; static;

See Also

C1CommandHolder class


LayoutLoadFromAppConfig Method

LayoutLoadFromAppConfig Method

Loads layout data from the application config file.

Syntax

[VB]

Public Sub LayoutLoadFromAppConfig()

[C#]

public void LayoutLoadFromAppConfig()

[Delphi]

procedure LayoutLoadFromAppConfig;

See Also

C1CommandHolder class


LayoutReset Method

LayoutReset Method

Reset layout.

Syntax

[VB]

Public Sub LayoutReset()

[C#]

public void LayoutReset()

[Delphi]

procedure LayoutReset;

See Also

C1CommandHolder class


LayoutSaveInAppConfig Method

LayoutSaveInAppConfig Method

Saves the layout data into the application config file.

Syntax

[VB]

Public Sub LayoutSaveInAppConfig()

[C#]

public void LayoutSaveInAppConfig()

[Delphi]

procedure LayoutSaveInAppConfig;

See Also

C1CommandHolder class


MergeCommandLinks Method

MergeCommandLinks Method

Merges command links from links1 and links2 into result, using merge rules specified with links, similar to MDI merge.

Syntax

[VB]

Public Sub MergeCommandLinks(result As C1CommandLinks, links1 As C1CommandLinks, links2 As C1CommandLinks)

Public Sub MergeCommandLinks(result As C1CommandLinks, links1 As C1CommandLinks, links2 As C1CommandLinks, restore As Boolean)

[C#]

public void MergeCommandLinks (C1CommandLinks result , C1CommandLinks links1 , C1CommandLinks links2)

public static void MergeCommandLinks(C1CommandLinks result,C1CommandLinks links1, C1CommandLinks links2, bool restore);

[Delphi]

procedure MergeCommandLinks(result: C1CommandLinks; links1: C1CommandLinks; links2: C1CommandLinks);

procedure MergeCommandLinks(result: C1CommandLinks; links1: C1CommandLinks; links2: C1CommandLinks; restore: Boolean);

Remarks

If the "restore" parameter is true, the resulting command links collection ("result") is restored before merging, otherwise it is merged as is.

See Also

C1CommandHolder class


SaveDefaultLayout Method

SaveDefaultLayout Method

Sets the current layout to be the default (the one the customizer's reset button reverts to).

Syntax

[VB]

Protected Sub SaveDefaultLayout( )

[C#]

public void SaveDefaultLayout ( )

[Delphi]

procedure SaveDefaultLayout;

Remarks

The SaveDefaultLayout Method maybe used if the developer would like to make changes made to the layout programmatically more permanent. In particular, if the developer adds items to a toolbar programmatically, those items will show in the items list available via the customization button only if the SaveDefaultLayout was called after their creation.

See Also

C1CommandHolder class


SetC1ContextMenu Method

SetC1ContextMenu Method

Sets a context menu contained within the C1CommandHolder.

Syntax

[VB]

Public Sub SetC1ContextMenu(control As Control, value As C1ContextMenu)

[C#]

public void SetC1ContextMenu (Control control , C1ContextMenu value )

[Delphi]

procedure SetC1ContextMenu(control: Control; value: C1ContextMenu);

Parameter | Description
control | The control for which to set the context menu.
value | The context menu to attach to the control.

See Also

C1CommandHolder class


UnInstallMessageFilter Method

UnInstallMessageFilter Method

Uninstalls the message filter.

Syntax

[VB]

Public Shared Sub UnInstallMessageFilter()

[C#]

public static void UnInstallMessageFilter()

[Delphi]

procedure UnInstallMessageFilter; static;

See Also

C1CommandHolder class


UnMergeCommandLinks Method

UnMergeCommandLinks Method

Unmerges the two collections of links merged previously by MergeCommandLinks.

Syntax

[VB]

Public Sub UnMergeCommandLinks(result As C1CommandLinks)

Public Sub UnMergeCommandLinks(result As C1CommandLinks, links1 As C1CommandLinks, links2 As C1CommandLinks)

[C#]

public void UnMergeCommandLinks (C1CommandLinks result)

public void UnMergeCommandLinks (C1CommandLinks result , C1CommandLinks links1 , C1CommandLinks links2)

[Delphi]

procedure UnMergeCommandLinks(result: C1CommandLinks; links1: C1CommandLinks; links2: C1CommandLinks);

procedure UnMergeCommandLinks(result: C1CommandLinks);

See Also

C1CommandHolder class


C1CommandHolder Events

CommandClick Event

CustomizationFinished Event

CustomizationStarted Event

CustomizeLinkAdded Event

CustomizeLinkRemoved Event

CustomizeToolBarAdded Event

CustomizeToolBarRemoved Event

LayoutLoad Event

LayoutSave Event

LookAndFeelChanged Event

RecentLinksRunCountChanged Event

RecentLinksThresholdChanged Event

ShowNonRecentLinksHoverDelayChanged Event


CommandClick Event

CommandClick Event

Fires when the user invokes a command.

Syntax

[VB]

Public Event CommandClick(sender As Object, e As CommandClickEventArgs) As CommandClickEventHandler

[C#]

public event CommandClickEventHandler CommandClick

[Delphi]

property CommandClick: CommandClickEventHandler;

Event Data

The event handler receives an argument of type CommandClickEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
ClickSource | Determines what caused the click event to occur.
CallerLink | Gets the command link which was clicked by the user.
ContextInfo | Gets the context info for events fired from a context menu.
Command | Gets the command which was invoked.

Remarks

This event allows having a single handler method for all commands, with a switch or a series of if-else clauses selecting the command to handle. The alternative is attaching a separate click event handler to each command.

See Also

C1CommandHolder class

Click Event (C1Command)


CustomizationFinished Event

CustomizationFinished Event

Occurs when customization mode finishes.

Syntax

[VB]

Public Event CustomizationFinished(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizationFinished

[Delphi]

property CustomizationFinished: EventHandler;

See Also

C1CommandHolder class


CustomizationStarted Event

CustomizationStarted Event

Occurs when customization mode starts.

Syntax

[VB]

Public Event CustomizationStarted(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizationStarted

[Delphi]

property CustomizationStarted: EventHandler;

See Also

C1CommandHolder class


CustomizeLinkAdded Event

CustomizeLinkAdded Event

Occurs when a new command link is added to an existing toolbar during customization.

Syntax

[VB]

Public Event CustomizeLinkAdded(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizeLinkAdded

[Delphi]

property CustomizeLinkAdded: EventHandler;

See Also

C1CommandHolder class


CustomizeLinkRemoved Event

CustomizeLinkRemoved Event

Occurs when a command link is removed from a toolbar during customization.

Syntax

[VB]

Public Event CustomizeLinkRemoved(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizeLinkRemoved

[Delphi]

property CustomizeLinkRemoved: EventHandler;

See Also

C1CommandHolder class


CustomizeToolBarAdded Event

CustomizeToolBarAdded Event

Occurs when a new toolbar is added or a hidden toolbar becomes visible during customization.

Syntax

[VB]

Public Event CustomizeToolBarAdded(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizeToolBarAdded

[Delphi]

property CustomizeToolBarAdded: EventHandler;

See Also

C1CommandHolder class


CustomizeToolBarRemoved Event

CustomizeToolBarRemoved Event

Occurs when a visible toolbar is hidden during customization.

Syntax

[VB]

Public Event CustomizeToolBarRemoved(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler CustomizeToolBarRemoved

[Delphi]

property CustomizeToolBarRemoved: EventHandler;

See Also

C1CommandHolder class


LayoutLoad Event

LayoutLoad Event

Fires when layout data is loaded.

Syntax

[VB]

Public Event LayoutLoad(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler LayoutLoad

[Delphi]

property LayoutLoad: EventHandler;

See Also

C1CommandHolder class


LayoutSave Event

LayoutSave Event

Fires when layout data is saved.

Syntax

[VB]

Public Event LayoutSave(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler LayoutSave

[Delphi]

property LayoutSave: EventHandler;

See Also

C1CommandHolder class


LookAndFeelChanged Event

LookAndFeelChanged Event

Occurs when the LookAndFeel property value changes.

Syntax

[VB]

Public Event LookAndFeelChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler LookAndFeelChanged

[Delphi]

property LookAndFeelChanged: EventHandler;

See Also

C1CommandHolder class


RecentLinksRunCountChanged Event

RecentLinksRunCountChanged Event

Occurs when the RecentLinksRunCoun t property value changes.

Syntax

[VB]

Public Event RecentLinksRunCountChanged (sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler RecentLinksRunCountChanged

[Delphi]

property RecentLinksRunCountChanged: EventHandler;

See Also

C1CommandHolder class


RecentLinksThresholdChanged Event

RecentLinksThresholdChanged Event

Occurs when the RecentLinksThreshold property value changes.

Syntax

[VB]

Public Event RecentLinksThresholdChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler RecentLinksThresholdChanged

[Delphi]

property RecentLinksThresholdChanged: EventHandler;

See Also

C1CommandHolder class


ShowNonRecentLinksHoverDelayChanged Event

ShowNonRecentLinksHoverDelayChanged Event

Occurs when the ShowNonRecentLinksHoverDelay property value changes.

Syntax

[VB]

Public Event ShowNonRecentLinksHoverDelayChanged(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler ShowNonRecentLinksHoverDelayChanged

[Delphi]

property ShowNonRecentLinksHoverDelayChanged: EventHandler;

See Also

C1CommandHolder class


C1MainMenu class

C1MainMenu is a control which represents the main menu. It contains a collection of command links that represent items of the menu. Only one main menu can be added to the form.


C1MainMenu Members

C1MainMenu Public Properties

BackHiColor | Gets or sets the base background color of the highlighted item.
BackImageInImageBar | Gets or sets the value indicating whether to draw background image in the image bar of dropdown menus.
CanMerge | Gets or sets the value indicating whether to merge MDI child menu with MDI parent menu.
CommandHolder | Gets or sets the command holder.
CommandLinks | Gets the collection of command links representing items of this menu.
ForeHiColor | Gets or sets the text color of the highlighted item.
ShowToolTips | Gets or sets the value indicating whether to show tooltip texts when mouse cursor is over toolbutton.
Wrap | Gets or sets the value indicating whether to wrap the menu or to add More item at the end of the menu, if the window is not wide enough for all items to show in one line.

C1MainMenu Public Events

BackHiColorChanged | Occurs when the value of the BackHiColor property changes.
CurrentLinkChanged | Occurs when the current command link changes.
DrawBar | Occurs when the owner-drawn menu should be redrawn.
DrawLink | Occurs when the owner-drawn C1CommandLink should be redrawn.
CanMergeChanged | Occurs when the value of the CanMerge property changes.
ForeHiColorChanged | Occurs when the value of the ForeHiColor property changes.
LayoutLink | Occurs when an OwnerDraw command link needs to layout its text, image and control within the link bounds.
MeasureLink | Occurs when it is necessary to measure the owner-drawn link.
ShowToolTipsChanged | Occurs when the value of the ShowToolTips property changes.
WrapChanged | Occurs when the value of the Wrap property changes.


C1MainMenu Properties

BackHiColor Property (C1MainMenu)

BackImageInImageBar Property (C1MainMenu)

CanMerge Property

CommandHolder Property (C1MainMenu)

CommandLinks Property (C1MainMenu)

ForeHiColor Property (C1MainMenu)

ShowToolTips Property (C1MainMenu)

Wrap Property


BackHiColor Property (C1MainMenu)

BackHiColor Property (C1MainMenu)

Gets or sets the base background color of the highlighted item.

Syntax

[VB]

Public Property BackHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color BackHiColor {get; set;}

[Delphi]

property BackHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


BackImageInImageBar Property (C1MainMenu)

BackImageInImageBar Property (C1MainMenu)

Gets or sets the value indicating whether to draw background image in the image bar of dropdown menus.

Syntax

[VB]

Public Property BackImageInImageBar As Boolean

[C#]

public bool BackImageInImageBar {get; set;}

[Delphi]

property BackImageInImageBar: Boolean;

See Also

C1MainMenu class

C1ToolBar class


CanMerge Property

CanMerge Property

Gets or sets the value indicating whether to merge MDI child menu with MDI parent menu.

Syntax

[VB]

Public Property CanMerge As Boolean

[C#]

public bool CanMerge {get; set;}

[Delphi]

property CanMerge: Boolean;

See Also

C1MainMenu class


CommandHolder Property (C1MainMenu)

CommandHolder Property (C1MainMenu)

Gets or sets the command holder.

Syntax

[VB]

Public Property CommandHolder As C1CommandHolder

[C#]

public C1CommandHolder CommandHolder {get; set;}

[Delphi]

property CommandHolder: C1CommandHolder;

See Also

C1MainMenu class


CommandLinks Property (C1MainMenu)

CommandLinks Property (C1MainMenu)

Gets the collection of command links representing items of this menu.

Syntax

[VB]

Public Property CommandLinks As C1CommandLinks

[C#]

public C1CommandLinks CommandLinks {get;}

[Delphi]

property CommandLinks: C1CommandLinks;

See Also

C1MainMenu class


ForeHiColor Property (C1MainMenu)

ForeHiColor Property (C1MainMenu)

Gets or sets the text color of the highlighted item.

Syntax

[VB]

Public Property ForeHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color ForeHiColor {get; set;}

[Delphi]

property ForeHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


ShowToolTips Property (C1MainMenu)

ShowToolTips Property (C1MainMenu)

Gets or sets the value indicating whether to show tooltip texts when mouse cursor is over toolbutton.

Syntax

[VB]

Public Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get; set;}

[Delphi]

property ShowToolTips: Boolean;

See Also

C1MainMenu class


Wrap Property

Wrap Property

Gets or sets the value indicating whether to wrap the menu or to add More item at the end of the menu, if the window is not wide enough for all items to show in one line.

Syntax

[VB]

Public Property Wrap As Boolean

[C#]

public bool Wrap {get; set;}

[Delphi]

property Wrap: Boolean;

Remarks

If True (default), menu is wrapped when the window is not wide enough. If False, the menu is not wrapped, and the extension menu is instead added at the end as in toolbars.

See Also

C1MainMenu class


C1MainMenu Events

BackHiColorChanged Event (C1MainMenu)

CanMergeChanged Event

CurrentLinkChanged Event

DrawBar Event

DrawLink Event

ForeHiColorChanged Event (C1MainMenu)

LayoutLink Event (C1MainMenu)

MeasureLink Event (C1MainMenu)

ShowToolTipsChanged Event (C1MainMenu)

WrapChanged Event


BackHiColorChanged Event (C1MainMenu)

BackHiColorChanged Event (C1MainMenu)

Occurs when the value of the BackHiColor property changes.

Syntax

[VB]

Public Event BackHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BackHiColorChanged

[Delphi]

property BackHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


CanMergeChanged Event

CanMergeChanged Event

Occurs when the value of the CanMerge property changes.

Syntax

[VB]

Public Event CanMergeChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler CanMergeChanged

[Delphi]

property CanMergeChanged: EventHandler;

See Also

C1MainMenu class


CurrentLinkChanged Event

CurrentLinkChanged Event

Occurs when the current command link changes.

Syntax

[VB]

Public Event CurrentLinkChanged(ByVal sender As Object, ByVal e As C1.Win.C1Command.CommandLinkEventArgs) As C1.Win.C1Command.CommandLinkEventHandler

[C#]

public event EventHandler CurrentLinkChanged;

[Delphi]

property CurrentLinkChanged: EventHandler;

Remarks

If a handler is attached to this event of a menu or toolbar, and that menu or toolbar opens a sub-menu which does not have its own handler for this event, the parent's handler is invoked. This event can be used to keep track of which command link is currently selected (e.g. to set context-sensitive status help messages).

See Also

C1MainMenu class


DrawBar Event

DrawBar Event

Occurs when the owner-drawn menu should be redrawn.

Syntax

[VB]

Public Event DrawBar(ByVal sender As Object, ByVal e As DrawBarEventArgs) As DrawBarEventHandler

[C#]

public event DrawBarEventHandler DrawBar

[Delphi]

property DrawBar: DrawBarEventHandler;

Event Data

The event handler receives an argument of type DrawBarEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the menu.
Path | The graphics path bounding the menu.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1MainMenu class


DrawLink Event

DrawLink Event

Occurs when the owner-drawn C1CommandLink should be redrawn.

Syntax

[VB]

Public Event DrawLink(ByVal sender As Object, ByVal e As DrawLinkEventArgs) As DrawLinkEventHandler

[C#]

public event DrawLinkEventHandler DrawLink

[Delphi]

property DrawLink: DrawLinkEventHandler;

Event Data

The event handler receives an argument of type DrawLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the link.
Link | C1CommandLink to draw
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1MainMenu class


ForeHiColorChanged Event (C1MainMenu)

ForeHiColorChanged Event (C1MainMenu)

Occurs when the value of the ForeHiColor property changes.

Syntax

[VB]

Public Event ForeHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ForeHiColorChanged

[Delphi]

property ForeHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


LayoutLink Event (C1MainMenu)

LayoutLink Event (C1MainMenu)

Occurs when an OwnerDraw command link needs to layout its text, image and control within the link bounds.

Syntax

[VB]

Public Event LayoutLink(ByVal sender As Object, ByVal e As LayoutLinkEventArgs) As LayoutLinkEventHandler

[C#]

public event C1.Win.C1Command.LayoutLinkEventHandler LayoutLink

[Delphi]

property LayoutLink: LayoutLinkEventHandler;

Remarks

This event allows the developer to change the default layout of elements in the link. For example, the developer can put the nested control on the right of the link's text.

Event Data

The event handler receives an argument of type LayoutLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Member | Description
Bounds | The bounding rectangle of the command link.
ControlLocation | The location of the nested control (valid only if the command is a C1CommandControl).
ImageRect | Image rectangle layout.
LInk | Specifies the command link for the layout.

See Also

C1MainMenu class


MeasureLink Event (C1MainMenu)

MeasureLink Event (C1MainMenu)

Occurs when it is necessary to measure the owner-drawn link.

Syntax

[VB]

Public Event MeasureLink(ByVal sender As Object, ByVal e As MeasureLinkEventArgs) As MeasureLinkEventHandler

[C#]

public event MeasureLinkEventHandler MeasureLink

[Delphi]

property MeasureLink: MeasureLinkEventHandler;

Event Data

The event handler receives an argument of type MeasureLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | Specifies the Graphics object to use for measuring.
Link | Specifies the link that needs to be measured.
Width | Specifies the width of the link.
Height | Specifies the height of the link.

See Also

C1MainMenu class


ShowToolTipsChanged Event (C1MainMenu)

ShowToolTipsChanged Event (C1MainMenu)

Occurs when the value of the ShowToolTips property changes.

Syntax

[VB]

Public Event ShowToolTipsChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ShowToolTipsChanged

[Delphi]

property ShowToolTipsChanged: EventHandler;

See Also

C1MainMenu class


WrapChanged Event

WrapChanged Event

Occurs when the value of the Wrap property changes.

Syntax

[VB]

Public Event WrapChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler WrapChanged

[Delphi]

property WrapChanged: EventHandler;

See Also

C1MainMenu class


C1OutBar class

Outlook-style container/tab control. Provides a set of "pages" (of the type C1OutPage) which may be opened by clicking on their titles organized in a vertical stack. Pages may be used to store arbitrary controls, but special processing (such as smart scrolling etc.) is provided when storing a single C1ToolBar per page.

C1OutBar Members

C1OutBar Public Properties

C1OutBar Public Methods

C1OutBar Public Events


C1OutBar Members

C1OutBar Public Properties

Align | Gets or sets the alignment of text and image on pages' title bars.
Animate | Indicates whether C1OutBar selected page changing is animated.
BackHiColor | Gets or sets the background color of the highlighted item.
CaptionFormat | Gets text format of caption string
ForeHiColor | Gets or sets the text color of the highlighted item.
ImageList | Gets or sets the image list used to provide images shown on pages' title bars.
LookAndFeel | Gets or sets the look and feel style of this outbar.
Pages | Gets the array of outbar pages.
PageTitleHeight | Gets or sets the height of the page title bar.
SelectedIndex | Gets or sets the index of the currently selected page.
SelectedPage | Gets or sets the currently selected page.
ShowToolTips | Gets or sets a value indicating whether the tool tip is shown when the mouse is over the page caption.
TitleBrush | Gets the brush used to draw the title.

C1OutBar Public Methods

FindPage | Returns the index of the page with the specified text, or -1 if such a page does not exist.
IsPressed | Returns true if the specified page caption is in the pressed state, or false otherwise.
ScrollDown | Scrolls the embedded toolbar down
ScrollUp | Scrolls the embedded toolbar up

C1OutBar Public Events

BackHiColorChanged | Occurs when the value of the BackHiColor property changes.
DrawArrow | Allows owner-draw of the page scrolling arrows in an C1OutBar.
DrawPage | Occurs when the owner-drawn C1OutPage should be redrawn.
ForeHiColorChanged | Occurs when the value of the ForeHiColor property changes.
LookAndFeelChanged | Fires when the LookAndFeel property of C1Outbar is changed.
MeasurePage | Fires when it is necessary to measure the page caption in the owner-drawn C1OutBar.
PageTitleHeightChanged | Fires when the PageTitleHeight property of C1Outbar is changed.
SelectedIndexChanging | Event fired when the index of the currently selected page is about to change. Allows to cancel the change.
SelectedPageChanged | Fires when the SelectedPage property of C1Outbar is changed.


C1OutBar Public Properties

Align Property

Animate Property

BackHiColor Property (C1OutBar)

CaptionFormat Property

ForeHiColor Property (C1OutBar)

ImageList Property (C1OutBar)

LookAndFeel Property (C1OutBar)

Pages Property

PageLayout Property

PageTitleHeight Property

SelectedIndex Property

SelectedPage Property

ShowToolTips Property (C1OutBar)

TitleBrush Property


Align Property

Align Property

Gets or sets the alignment of text and image on pages' title bars.

Syntax

[VB]

Public Property Align As System.Windows.Forms.HorizontalAlignment

[C#]

public System.Windows.Forms.HorizontalAlignment Align {get; set;}

[Delphi]

property Align: System.Windows.Forms.HorizontalAlignment;

See Also

C1OutBar class


Animate Property

Animate Property

Indicates whether C1OutBar selected page changing is animated.

Syntax

[VB]

Public Property Animate As Boolean

[C#]

public bool Animate {get; set;}

[Delphi]

property Animate: Boolean;

See Also

C1OutBar class


BackHiColor Property (C1OutBar)

BackHiColor Property (C1OutBar)

Gets or sets the background color of the highlighted item.

Syntax

[VB]

Public Property BackHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color BackHiColor {get; set;}

[Delphi]

property BackHiColor: System.Drawing.Color;

See Also

C1OutBar class


CaptionFormat Property

CaptionFormat Property

Gets text format of caption string.

Syntax

[VB]

Public ReadOnly Property CaptionFormat As String

[C#]

public string CaptionFormat {get;}

[Delphi]

property CaptionFormat: string;

See Also

C1OutBar class


ForeHiColor Property (C1OutBar)

ForeHiColor Property (C1OutBar)

Gets or sets the text color of the highlighted item.

Syntax

[VB]

Public Property ForeHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color ForeHiColor {get;}

[Delphi]

property ForeHiColor: System.Drawing.Color;

See Also

C1OutBar class


ImageList Property (C1OutBar)

ImageList Property (C1OutBar)

Gets or sets the image list used to provide images shown on pages' title bars.

Syntax

[VB]

Public Property ImageList As System.Windows.Forms.ImageList

[C#]

public System.Windows.Forms.ImageList ImageList {get; set;}

[Delphi]

property ImageList: System.Windows.Forms.ImageList;

See Also

C1OutBar class


LookAndFeel Property (C1OutBar)

LookAndFeel Property (C1OutBar)

Gets or sets the look and feel style of this outbar.

Syntax

[VB]

Public Property LookAndFeel As LookAndFeelEnum

[C#]

public LookAndFeelEnum LookAndFeel {get; set;}

[Delphi]

property LookAndFeel: LookAndFeelEnum;

Remarks

Default is LookAndFeelEnum.OfficeXP.

See Also

C1OutBar class


Pages Property

Pages Property

Gets the array of outbar pages.

Syntax

[VB]

Public ReadOnly Property Pages As C1OutPages

[C#]

public C1OutPages Pages {get;}

[Delphi]

property Pages: C1OutPages;

See Also

C1OutBar class


PageLayout Property

PageLayout Property

Gets or sets the layout of text and image on pages' title bars.

Syntax

[VB]

Public Property PageLayout As C1.Win.C1Command.ButtonLayoutEnum

[C#]

public C1.Win.C1Command.ButtonLayoutEnum PageLayout {get;}

[Delphi]

property PageLayout: C1.Win.C1Command.ButtonLayoutEnum;

See Also

C1OutBar class


PageTitleHeight Property

PageTitleHeight Property

Gets or sets the height of the page title bar.

Syntax

[VB]

Public Property PageTitleText As Integer

[C#]

public int PageTitleText {get; set;}

[Delphi]

property PageTitleText: Integer;

See Also

C1OutBar class


SelectedIndex Property

SelectedIndex Property

Gets or sets the index of the currently selected page.

Syntax

[VB]

Public Property SelectedIndex As Integer

[C#]

public int SelectedIndex {get; set;}

[Delphi]

property SelectedIndex: Integer;

See Also

C1OutBar class


SelectedPage Property

SelectedPage Property

Gets or sets the currently selected page.

Syntax

[VB]

Public Property SelectedPage As C1OutPage

[C#]

public C1OutPage SelectedPage {get; set;}

[Delphi]

property SelectedPage: C1OutPage;

See Also

C1OutBar class


ShowToolTips Property (C1OutBar)

ShowToolTips Property (C1OutBar)

Gets or sets a value indicating whether the tool tip is shown when the mouse is over the page caption.

Syntax

[VB]

Public Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get; set;}

[Delphi]

property ShowToolTips: Boolean;

See Also

C1OutBar class


TitleBrush Property

TitleBrush Property

Gets the brush used to draw the title.

Syntax

[VB]

Public ReadOnly Property TitleBrush As Brush

[C#]

public Brush TitleBrush {get;}

[Delphi]

property TitleBrush: Brush;

See Also

C1OutBar class


C1OutBar Public Methods

FindPage Method

IsPressed Method

ScrollDown Method

ScrollUp Method


FindPage Method

FindPage Method

Returns the index of the page with the specified text, or -1 if such a page does not exist.

Syntax

[VB]

Public Function FindPage(text as System.String) as Integer

[C#]

public System.Int32 FindPage(System.String text)

[Delphi]

function FindPage(text: System.String): Integer;

Parameter | Description
text | The text of the page to search for.

See Also

C1OutBar class


IsPressed Method

IsPressed Method

Returns true if the specified page caption is in the pressed state, or false otherwise.

Syntax

[VB]

Public Function IsPressed(page as C1OutPage) as Boolean

[C#]

public bool IsPressed(C1OutPage page)

[Delphi]

function IsPressed(page: C1OutPage): Boolean;

See Also

C1OutBar class


ScrollDown Method

ScrollDown Method

Scrolls embedded toolbar down

Syntax

[VB]

Public Sub ScrollDown(delta as integer)

[C#]

public void ScrollDown(int delta)

[Delphi]

procedure ScrollDown(delta: integer);

See Also

C1OutBar class


ScrollUp Method

ScrollUp Method

Scrolls embedded toolbar up.

Syntax

[VB]

Public Sub ScrollUp(delta as integer)

[C#]

public void ScrollUp(int delta)

[Delphi]

procedure ScrollUp(delta: integer);

See Also

C1OutBar class


C1OutBar Public Events

BackHiColorChanged Event

DrawArrow Event

DrawPage Event

ForeHiColorChanged Event

LookAndFeelChanged Event (C1OutBar)

MeasurePage Event

PageTitleHeightChanged Event

SelectedIndexChanging Event (C1OutBar)

SelectedPageChanged Event


BackHiColorChanged Event

BackHiColorChanged Event

Occurs when the value of the BackHiColor property changes.

Syntax

[VB]

Public Event BackHiColorChanged(ByVal sender As Object, e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler BackHiColorChanged

[Delphi]

property BackHiColorChanged: System.EventHandler;

See Also

C1OutBar class


DrawArrow Event

DrawArrow Event

Allows owner-draw of the page scrolling arrows in an C1OutBar.

Syntax

[VB]

Public Event DrawArrow(ByVal sender As Object, e As DrawArrowEventArgs) As DrawArrowEventHandler

[C#]

public event DrawArrowEventHandler DrawArrow

[Delphi]

property DrawArrow: DrawArrowEventHandler;

See Also

C1OutBar class


DrawPage Event

DrawPage Event

Occurs when the owner-drawn C1OutPage should be redrawn.

Syntax

[VB]

Public Event DrawPage(ByVal sender As Object, ByVal e As DrawPageEventArgs) As DrawPageEventHandler

[C#]

public event DrawPageEventHandler DrawPage

[Delphi]

property DrawPage: DrawPageEventHandler;

Event Data

The event handler receives an argument of type DrawPageEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the page.
Page | Specifes the C1OutPage object to draw.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1OutBar class


ForeHiColorChanged Event

ForeHiColorChanged Event

Occurs when the value of the BackHiColor property changes.

Syntax

[VB]

Public Event ForeHiColorChanged(ByVal sender As Object, e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ForeHiColorChanged

[Delphi]

property ForHiColorChanged: System.EventHandler;

See Also

C1OutBar class


LookAndFeelChanged Event (C1OutBar)

LookAndFeelChanged Event (C1OutBar)

Fires when the LookAndFeel property of C1Outbar is changed.

Syntax

[VB]

Public Event LookAndFeelChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler LookAndFeelChanged

[Delphi]

property LookAndFeelChanged: EventHandler;

See Also

C1OutBar class


MeasurePage Event

MeasurePage Event

Fires when it is necessary to measure the link in the menu.

Syntax

[VB]

Public Event MeasurePage(ByVal sender As Object, ByVal e As MeasurePageEventArgs) As MeasurePageEventHandler

[C#]

public event MeasurePageEventHandler MeasurePage

[Delphi]

property MeasurePage: MeasurePageEventHandler;

Event Data

The event handler receives an argument of type MeasurePageEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | Specifies the Graphics object to use for measuring.
Page | Specifes the C1OutPage object to measure.
Height | Specifies the height of the page caption.

See Also

C1MainMenu class


PageTitleHeightChanged Event

PageTitleHeightChanged Event

Fires when the PageTitleHeight property of C1Outbar is changed.

Syntax

[VB]

Public Event PageTitleHeightChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler PageTitleHeightChanged

[Delphi]

property PageTitleHeightChanged: EventHandler;

See Also

C1OutBar class


SelectedIndexChanging Event (C1OutBar)

SelectedIndexChanging Event (C1OutBar)

Event fired when the index of the currently selected page is about to change. Allows to cancel the change.

Syntax

[VB]

Public Event SelectedIndexChanging(ByVal sender As Object, ByVal e As C1.Win.C1Command.SelectedIndexChangingEventArgs) As C1.Win.C1Command.SelectedIndexChangingEventHandler

[C#]

public event C1.Win.C1Command.SelectedIndexChangingEventHandler SelectedIndexChanging

[Delphi]

property SelectedIndexChanging: C1.Win.C1Command.SelectedIndexChangingEventHandler;

Event Data

The event handler receives an argument of type SelectedIndexChangingEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
NewIndex | Indicates the new index of the selected tab page.
CanCancel | indicates whether the change of the selected index can be cancelled by the event handler. In some situations, this is not allowed - e.g. when the C1DockingTab control is in the "sliding out" mode, there is a selected page, and the control is being resized (in that case, the selected page is hidden, so the selected index is changed to -1).

See Also

C1OutBar class


SelectedPageChanged Event

SelectedPageChanged Event

Fires when the SelectedPage property of C1Outbar is changed.

Syntax

[VB]

Public Event SelectedPageChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler SelectedPageChanged

[Delphi]

property SelectedPageChanged: EventHandler;

See Also

C1OutBar class


C1OutPage class

C1OutPage Members

C1OutPage Public Properties

C1OutPage Public Events


C1OutPage Members

C1OutPage Public Properties

CaptionBounds | Returns the caption bounds of the page.
Image | Gets or sets the page image.
ImageIndex | Gets or sets the index of the page image in the outbar's ImageList.
IsSelected | Returns true if the page is currently selected.
OwnerDraw | Gets or sets the value indicating whether the title of this page is owner-drawn.
PageVisible | Gets or sets the value indicating whether the page is visible or not.
Pressed | Gets the pressed state of the page caption.
Text | Gets or sets the caption of the page.
ToolTipText | Gets or sets the tooltip text for the page.

C1OutPage Public Events

PageVisibleChanged

Fired when the PageVisible property is changed.


C1OutPage Public Properties

CaptionBounds Property

Image Property

ImageIndex Property

IsSelected Property

OwnerDraw Property

PageVisible Property

Pressed Property

Text Property

ToolTipText Property


CaptionBounds Property

CaptionBounds Property

Returns the caption bounds of the page.

Syntax

[VB]

Public ReadOnly Property CaptionBounds As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle CaptionBounds {get;}

[Delphi]

property CaptionBounds: System.Drawing.Rectangle;

See Also

C1OutPage class


Image Property

Image Property

Gets or sets the page image.

Syntax

[VB]

Public Property Image As System.Drawing.Image

[C#]

public System.Drawing.Image Image {get; set;}

[Delphi]

property Image: System.Drawing.Image;

See Also

C1OutPage class


ImageIndex Property

ImageIndex Property

Gets or sets the index of the page image in the outbar's ImageList.

Syntax

[VB]

Public Property ImageIndex As Integer

[C#]

public int ImageIndex {get; set;}

[Delphi]

property ImageIndex: Integer;

See Also

C1OutPage class


IsSelected Property

IsSelected Property

Returns true if the page is currently selected.

Syntax

[VB]

Public ReadOnly Property IsSelected As Boolean

[C#]

public bool IsSelected {get;}

[Delphi]

property IsSelected: Boolean;

See Also

C1OutPage class


OwnerDraw Property

OwnerDraw Property

Gets or sets the value indicating whether the title of this page is owner-drawn.

Syntax

[VB]

Public Property OwnerDraw As Boolean

[C#]

public bool OwnerDraw {get; set;}

[Delphi]

property OwnerDraw: Boolean;

See Also

C1OutPage class


PageVisible Property

PageVisible Property

Gets or sets the value indicating whether the page is visible or not.

Syntax

[VB]

Public Property PageVisible As Boolean

[C#]

public bool PageVisible {get; set;}

[Delphi]

property PageVisible: Boolean;

Remarks

This property allows to hide a page (including the caption) without removing it from the pages collection altogether.

See Also

C1OutPage class


Pressed Property

Pressed Property

Gets the pressed state of the page caption.

Syntax

[VB]

Public ReadOnly Property Pressed As Boolean

[C#]

public bool Pressed {get;}

[Delphi]

property Pressed: Boolean;

See Also

C1OutPage class


Text Property

Text Property

Gets or sets the caption of the page.

Syntax

[VB]

Public Overridable Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: string;

See Also

C1OutPage class


ToolTipText Property

ToolTipText Property

Gets or sets the tooltip text for the page.

Syntax

[VB]

Public Property ToolTipText As String

[C#]

public string ToolTipText {get; set;}

[Delphi]

property ToolTipText: string;

See Also

C1OutPage class


C1OutPage Public Events

PageVisibleChanged Event


PageVisibleChanged Event

PageVisibleChanged Event

Fired when the PageVisible property is changed.

Syntax

[VB]

Public Event PageVisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler PageVisibleChanged

[Delphi]

property PageVisibleChanged: EventHandler;

See Also

C1OutPage class


C1OutPages class

C1OutPages Members

C1OutPages Public Properties


C1OutPages Members

C1OutPages Public Properties

Item

Gets or sets the item with the specified index.


C1OutPages Public Properties

Item Property (C1OutPages)


Item Property (C1OutPages)

Item Property (C1OutPages)

Gets or sets the item with the specified index.

Syntax

[VB]

Default Public Property Item(ByVal index As Integer) As C1OutPage

[C#]

public C1OutPage this[int index] { get; set;}

[Delphi]

property Item(index: Integer): C1OutPage;

See Also

C1OutPages class


C1SideCaption class

C1SideCaption Members

C1SideCaption Public Properties


C1SideCaption Members

C1SideCaption Public Properties

BarGradientBegin | Gets or sets the beginning color of the gradient for the SideCaption.
BarGradientEnd | Gets or sets the ending color of the gradient for the SideCaption.
CaptionLayout | Gets or sets the text layout for the SideCaption. The default layout is TextAbove.
Font | Gets or sets the font of the SideCaption.
ForeColor | Gets or sets the text color of the SideCaption.
GradientDirection | Gets or sets the gradient direction (horizontal, vertical, forward diagonal, or backward diagonal) of the SideCaption.
Icon | Gets or sets the SideCaption icon.
Image | Gets or sets the SideCaption image.
ImageIndex | Gets or sets the index of the C1CommandMenu image for the SideCaption (in C1CommandHolder.ImageList).
Text | Gets or sets the text shown on the SideCaption.
TextAlignment | Gets or sets the text alignment (near, far, or center) from an object in the SideCaption.
TextDirection | Gets or sets the direction of the text in the SideCaption.
Width | Gets or sets the width of the SideCaption.


C1SideCaption Public Properties

BarGradientBegin Property

BarGradientEnd Property

CaptionLayout Property

Font Property (C1SideCaption)

ForeColor Property (C1SideCaption)

GradientDirection Property

Icon Property (C1SideCaption)

Image Property (C1SideCaption)

ImageIndex Property (C1SideCaption)

Text Property (C1SideCaption)

TextAlignment Property (C1SideCaption)

TextDirection Property (C1SideCaption)

Width Property (C1SideCaption)


BarGradientBegin Property

BarGradientBegin Property

Gets or sets the beginning color of the gradient for the SideCaption.

Syntax

[VB]

Public Property BarGradientBegin As System.Drawing.Color

[C#]

public System.Drawing.Color BarGradientBegin {get; set; }

[Delphi]

property BarGradientBegin: System.Drawing.Color;

See Also

C1SideCaption class


BarGradientEnd Property

BarGradientEnd Property

Gets or sets the ending color of the gradient for the SideCaption.

Syntax

[VB]

Public Property BarGradientEnd As System.Drawing.Color

[C#]

public System.Drawing.Color BarGradientEnd {get; set; }

[Delphi]

property BarGradientEnd: System.Drawing.Color;

See Also

C1SideCaption class


CaptionLayout Property

CaptionLayout Property

Gets or sets the text layout for the SideCaption.

Syntax

[VB]

Public Property CaptionLayout As C1.Win.C1Command.ButtonLayoutEnum

[C#]

public C1.Win.C1Command.ButtonLayoutEnum CaptionLayout {get; set; }

[Delphi]

property CaptionLayout: C1.Win.C1Command.ButtonLayoutEnum;

Remarks

The default layout is TextAbove.

See Also

C1SideCaption class


Font Property (C1SideCaption)

Font Property (C1SideCaption)

Gets or sets the font of the SideCaption.

Syntax

[VB]

Public Property Font As System.Drawing.Font

[C#]

public System.Drawing.Font Font {get; set;}

[Delphi]

property Font: System.Drawing.Font;

See Also

C1SideCaption class


ForeColor Property (C1SideCaption)

ForeColor Property (C1SideCaption)

Gets or sets the text color of the SideCaption.

Syntax

[VB]

Public Property ForeColor As System.Drawing.Font

[C#]

public System.Drawing.Font ForeColor {get; set;}

[Delphi]

property ForeColor: System.Drawing.Font;

See Also

C1SideCaption class


GradientDirection Property

GradientDirection Property

Gets or sets the gradient direction (horizontal, vertical, forward diagonal, or backward diagonal) of the SideCaption.

Syntax

[VB]

Public Property GradientDirection As System.Drawing.Drawing2D.LinearGradientMode

[C#]

public System.Drawing.Drawing2D.LinearGradientMode GradientDirection {get; set; }

[Delphi]

property GradientDirection: System.Drawing.Drawing2D.LinearGradientMode;

See Also

C1SideCaption class


Icon Property (C1SideCaption)

Icon Property (C1SideCaption)

Gets or sets the SideCaption icon.

Syntax

[VB]

Public Property Icon As System.Drawing.Icon

[C#]

public System.Drawing.Icon Icon {get; set;}

[Delphi]

property Icon: System.Drawing.Icon;

See Also

C1SideCaption class


Image Property (C1SideCaption)

Image Property (C1SideCaption)

Gets or sets the SideCaption image.

Syntax

[VB]

Public Property Image As Integer

[C#]

public System.Drawing.Image Image {get; set;}

[Delphi]

property Image: System.Drawing.Image;

See Also

C1SideCaption class


ImageIndex Property (C1SideCaption)

ImageIndex Property (C1SideCaption)

Gets or sets the index of the C1CommandMenu image for the SideCaption (in C1CommandHolder.ImageList).

Syntax

[VB]

Public Property ImageIndex As Integer

[C#]

public int ImageIndex {get; set;}

[Delphi]

property ImageIndex: Integer;

See Also

C1SideCaption class


Text Property (C1SideCaption)

Text Property (C1SideCaption)

Gets or sets the text shown in the SideCaption.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: String;

See Also

C1SideCaption class


TextAlignment Property (C1SideCaption)

TextAlignment Property (C1SideCaption)

Gets or sets the text alignment (near, far, or center) from an object in the SideCaption.

Syntax

[VB]

Public Property TextAlignment As System.Drawing.StringAlignment

[C#]

public System.Drawing.StringAlignment TextAlignment {get; set;}

[Delphi]

property TextAlignment: System.Drawing.StringAlignment;

See Also

C1SideCaption class


TextDirection Property (C1SideCaption)

TextDirection Property (C1SideCaption)

Gets or sets the direction of the text in the SideCaption.

Syntax

[VB]

Public Property TextDirection As TabTextDirectionEnum

[C#]

public TabTextDirectionEnum TextDirection {get; set;}

[Delphi]

property TextDirection: TabTextDirectionEnum;

See Also

C1SideCaption class


Width Property (C1SideCaption)

Width Property (C1SideCaption)

Gets or sets the width of the SideCaption.

Syntax

[VB]

Public Property Width As Integer

[C#]

public int Width {get; set;}

[Delphi]

property Width: Integer;

See Also

C1SideCaption class


C1ToolBar class

C1ToolBar is a control which represents a toolbar. It contains a collection of command links which represent buttons on the toolbar.


C1ToolBar Members

C1ToolBar Public Properties

AutoSize | Gets or sets the value indicating whether the toolbar automatically adjusts its size to fit all items.
BackHiColor | Gets or sets the base background color of the highlighted item.
BackImageInImageBar | Gets or sets the value indicating whether to draw background image in the image bar of dropdown menus.
Border | Gets or sets the appearance of the toolbar’s border.
ButtonAlign | Controls text and image alignment when the toolbar is oriented vertically.
ButtonLayoutCurrent | Gets the current layout of the buttons.
ButtonLayoutHorz | Gets or sets the layout of the buttons when the toolbar is horizontal.
ButtonLayoutVert | Gets or sets the layout of the buttons when the toolbar is vertical.
ButtonLookCurrent | Gets the default look of the buttons in the current toolbar orientation.
ButtonLookEnforceCurrent | Gets the value indicating whether to force all buttons to comply with ButtonLookCurrent.
ButtonLookEnforceHorz | Gets or sets the value indicating whether to force all buttons to comply with ButtonLookHorz when the toolbar is horizontal.
ButtonLookEnforceVert | Gets or sets the value indicating whether to force all buttons to comply with ButtonLookVert when the toolbar is vertical.
ButtonLookHorz | Gets or sets the default look of the buttons when the toolbar is horizontal.
ButtonLookVert | Gets or sets the default look of the buttons when the toolbar is vertical.
ButtonWidth | Gets or sets the width for all buttons (applies to horizontal toolbars only if 0 buttons are individually sized).
CommandHolder | Gets or sets the command holder.
CommandLinks | Gets the collection of command links representing buttons on this toolbar.
CustomizeButton | Gets or sets the value indicating whether the customize button will appear as the last button in the toolbar.
CustomizeMode | Indicates whether the toolbar is currently in customize mode.
CustomizeOptions | Gets or sets the value indicating what can be customized in this toolbar.
Floating | Indicates whether the toolbar is floating.
ForeHiColor | Gets or sets the text color of the highlighted item.
Horizontal | Gets or sets the orientation of the toolbar.
MinButtonSize | Sets or gets the minimum size (width and height) of buttons in the toolbar.
Movable | Indicates whether the user can move the toolbar.
ShowToolTips | Gets or sets the value indicating whether to show tooltip texts when mouse cursor is over toolbutton.
ToolBarStyle | Allows specification of the dropdown menu look for the toolbar.
WrapText | If ButtonWidth > 0, and WrapText is true, links texts’ wrap if their length exceeds ButtonWidth.

C1ToolBar Public Events

BackHiColorChanged | Occurs when the value of the BackHiColor property changes.
BorderChanged | Occurs when the value of the Border property changes.
ButtonAlignChanged | Occurs when the value of the ButtonAlign property changes.
ButtonLayoutHorzChanged | Occurs when the value of the ButtonLayoutHorz property changes.
ButtonLayoutVertChanged | Occurs when the value of the ButtonLayoutVert property changes.
ButtonLookHorzChanged | Occurs when the value of the ButtonLookHorz property changes.
ButtonLookVertChanged | Occurs when the value of the ButtonLookVert property changes.
ButtonLookEnforceHorzChanged | Occurs when the value of the ButtonLookEnforceHorz property changes
ButtonLookEnforceVertChanged | Occurs when the value of the ButtonLookEnforceVert property changes.
ButtonWidthChanged | Occurs when the value of the ButtonWidth property changes.
CurrentLinkChanged | Occurs when the current command link changes.
CustomizeButtonChanged | Occurs when the value of the CustomizeButton property changes.
DrawBar | Occurs when the owner-drawn C1ToolBar should be redrawn.
DrawFloatingCaption | Allows owner-draw of the caption of the window containing the toolbar when the toolbar is floating.
DrawLink | Occurs when the owner-drawn C1CommandLink should be redrawn.
ForeHiColorChanged | Occurs when the value of the ForeHiColor property changes.
HorizontalChanged | Occurs when the value of the Horizontal property changes.
LayoutLink | Occurs when an OwnerDraw command link needs to layout its text, image and control within the link bounds.
MeasureFloatingCaption | Allows owner-draw of the caption of the window containing the toolbar when the toolbar is floating.
MeasureLink | Occurs when it is necessary to measure the owner-drawn link.
MinButtonSizeChanged | Occurs when the value of the MinButtonSize property changes.
Reset | Fires when the Reset command from the Customize dialog box is clicked.
ShowToolTipsChanged | Occurs when the value of the ShowToolTips property changes.
ToolBarStyleChanged | Occurs when the value of the ToolBarStyle property changes.
WrapTextChanged | Occurs when the value of the WrapText property changes.


C1ToolBar Properties

AutoSize Property

BackHiColor Property (C1ToolBar)

BackImageInImageBar Property (C1ToolBar)

Border Property

ButtonAlign Property

ButtonLayoutCurrent Property

ButtonLayoutHorz Property

ButtonLayoutVert Property

ButtonLookCurrent Property

ButtonLookEnforceCurrent Property

ButtonLookEnforceHorz Property

ButtonLookEnforceVert Property

ButtonLookHorz Property

ButtonLookVert Property

ButtonWidth Property

CommandHolder Property (C1ToolBar)

CommandLinks Property (C1ToolBar)

CustomizeButton Property

CustomizeMode Property

CustomizeOptions Property

Floating Property

ForeHiColor Property (C1ToolBar)

Horizontal Property

MinButtonSize Property

Movable Property

ShowToolTips Property (C1ToolBar)

ToolBarStyle Property

WrapText Property


AutoSize Property

AutoSize Property

Gets or sets the value indicating whether the toolbar automatically adjusts its size to fit all items.

Syntax

[VB]

Public Property AutoSize As Boolean

[C#]

public bool AutoSize {get; set;}

[Delphi]

property AutoSize: Boolean;

Remarks

If set to True (default), the toolbar always automatically resizes to fit all items (space permitting). If set to False, the toolbar can be resized arbitrarily.

See Also

C1ToolBar class


BackHiColor Property (C1ToolBar)

BackHiColor Property (C1ToolBar)

Gets or sets the base background color of the highlighted item.

Syntax

[VB]

Public Property BackHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color BackHiColor {get; set;}

[Delphi]

property BackHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


BackImageInImageBar Property (C1ToolBar)

BackImageInImageBar Property (C1ToolBar)

Gets or sets the value indicating whether to draw background image in the image bar of dropdown menus.

Syntax

[VB]

Public Property BackImageInImageBar As Boolean

[C#]

public bool BackImageInImageBar {get; set;}

[Delphi]

property BackImageInImageBar: Boolean;

Remarks

If background image is not null, show image bar background in menus as one-color or as background image.

See Also

C1ToolBar class

C1MainMenu class


Border Property

Border Property

Gets or sets the appearance of the toolbar’s border.

Syntax

[VB]

Public Property Border As C1Border

[C#]

public C1Border Border {get; set;}

[Delphi]

property Border: C1Border;

See Also

C1ToolBar class

C1Border class


ButtonAlign Property

ButtonAlign Property

Controls text and image alignment when the toolbar is oriented vertically.

Syntax

[VB]

Public Property ButtonAlign As ButtonLayoutEnum

[C#]

public ButtonLayoutEnum ButtonAlign {get; set;}

[Delphi]

property ButtonAlign: ButtonLayoutEnum;

Remarks

The default behavior is to center button texts and images (StringAlignment.Center).

See Also

C1ToolBar class


ButtonLayoutCurrent Property

ButtonLayoutCurrent Property

Gets the current layout of the buttons.

Syntax

[VB]

Public ReadOnly Property ButtonLayoutCurrent As ButtonLayoutEnum

[C#]

public ButtonLayoutEnum ButtonLayoutCurrent {get;}

[Delphi]

property ButtonLayoutCurrent: ButtonLayoutEnum;

See Also

C1ToolBar class


ButtonLayoutHorz Property

ButtonLayoutHorz Property

Gets or sets the layout of the buttons when the toolbar is horizontal.

Syntax

[VB]

Public Property ButtonLayoutHorz As ButtonLayoutEnum

[C#]

public ButtonLayoutEnum ButtonLayoutHorz {get; set;}

[Delphi]

property ButtonLayoutHorz: ButtonLayoutEnum;

Remarks

This property determines the relative placement of texts and images on the toolbar’s buttons when the toolbar is horizontal. Whether each particular button will have both text and image shown is determined by a combination of button’s own ButtonLook property and toolbar’s ButtonLookHorz and ButtonLookEnforceHorz properties. Note that all of these toolbar properties have analogs for when the toolbar is vertical.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutVert property

ButtonLookEnforceHorz property

ButtonLookEnforceVert property

ButtonLookHorz property

ButtonLookVert property


ButtonLayoutVert Property

ButtonLayoutVert Property

Gets or sets the layout of the buttons when the toolbar is vertical.

Syntax

[VB]

Public Property ButtonLayoutVert As ButtonLayoutEnum

[C#]

public ButtonLayoutEnum ButtonLayoutVert {get; set;}

[Delphi]

property ButtonLayoutVert: ButtonLayoutEnum;

Remarks

Please see the remarks on the ButtonLayoutHorz property.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutHorz property

ButtonLookEnforceHorz property

ButtonLookEnforceVert property

ButtonLookHorz property

ButtonLookVert property


ButtonLookCurrent Property

ButtonLookCurrent Property

Gets the default look of the buttons in the current toolbar orientation.

Syntax

[VB]

Public ReadOnly Property ButtonLookCurrent As ButtonLookFlags

[C#]

public ButtonLookFlags ButtonLookCurrent {get;}

[Delphi]

property ButtonLookCurrent: ButtonLookFlags;

See Also

C1ToolBar class


ButtonLookEnforceCurrent Property

ButtonLookEnforceCurrent Property

Gets the value indicating whether to force all buttons to comply with ButtonLookCurrent.

Syntax

[VB]

Public ReadOnly Property ButtonLookEnforceCurrent As Boolean

[C#]

public bool ButtonLookEnforceCurrent {get;}

[Delphi]

property ButtonLookEnforceCurrent: Boolean;

Remarks

Please see the remarks on the ButtonLayoutHorz property.

See Also

C1ToolBar class


ButtonLookEnforceHorz Property

ButtonLookEnforceHorz Property

Gets or sets the value indicating whether to force all buttons to comply with ButtonLookHorz when the toolbar is horizontal.

Syntax

[VB]

Public Property ButtonLookEnforceHorz As Boolean

[C#]

public bool ButtonLookEnforceHorz {get; set;}

[Delphi]

property ButtonLookEnforceHorz: Boolean;

Remarks

Please see the remarks on the ButtonLayoutHorz property.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutHorz property

ButtonLayoutVert property

ButtonLookEnforceVert property

ButtonLookHorz property

ButtonLookVert property


ButtonLookEnforceVert Property

ButtonLookEnforceVert Property

Gets or sets the value indicating whether to force all buttons to comply with ButtonLookVert.

Syntax

[VB]

Public Property ButtonLookEnforceVert As Boolean

[C#]

public bool ButtonLookEnforceVert {get; set;}

[Delphi]

property ButtonLookEnforceVert: Boolean;

Remarks

Please see the remarks on the ButtonLayoutVert property.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutHorz property

ButtonLayoutVert property

ButtonLookEnforceHorz property

ButtonLookHorz property

ButtonLookVert property


ButtonLookHorz Property

ButtonLookHorz Property

Gets or sets the default look of the buttons when the toolbar is horizontal.

Syntax

[VB]

Public Property ButtonLookHorz As ButtonLookFlags

[C#]

public ButtonLookFlags ButtonLookHorz {get; set;}

[Delphi]

property ButtonLookHorz: ButtonLookFlags;

Remarks

This property is used to determine whether to show text and image for buttons (command links) which have their own ButtonLook property set to ButtonLookFlags.Default. Please also see the remarks on the ButtonLayoutHorz property.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutHorz property

ButtonLookEnforceHorz property

ButtonLookEnforceVert property

ButtonLayoutVert property

ButtonLookVert property


ButtonLookVert Property

ButtonLookVert Property

Gets or sets the default look of the buttons when the toolbar is vertical.

Syntax

[VB]

Public Property ButtonLookVert As ButtonLookFlags

[C#]

public ButtonLookFlags ButtonLookVert {get; set;}

[Delphi]

property ButtonLookVert: ButtonLookFlags;

Remarks

This property is used to determine whether to show text and image for buttons (command links) which have their own ButtonLook property set to ButtonLookFlags.Default. Please also see the remarks on the ButtonLayoutHorz property.

See Also

C1ToolBar class

ButtonLook property

ButtonLayoutHorz property

ButtonLookEnforceHorz property

ButtonLookEnforceVert property

ButtonLayoutVert property

ButtonLookHorz property


ButtonWidth Property

ButtonWidth Property

Gets or sets the width for all buttons (applies to horizontal toolbars only if 0 buttons are individually sized).

Syntax

[VB]

Public Property ButtonWidth As Integer

[C#]

public int ButtonWidth {get; set;}

[Delphi]

property ButtonWidth: Integer;

See Also

C1ToolBar class


CommandHolder Property (C1ToolBar)

CommandHolder Property (C1ToolBar)

Gets or sets the command holder.

Syntax

[VB]

Public Property CommandHolder As C1CommandHolder

[C#]

public C1CommandHolder CommandHolder {get; set;}

[Delphi]

property CommandHolder: C1CommandHolder;

See Also

C1ToolBar class


CommandLinks Property (C1ToolBar)

CommandLinks Property (C1ToolBar)

Gets the collection of command links representing buttons on this toolbar.

Syntax

[VB]

Public ReadOnly Property CommandLinks As C1CommandLinks

[C#]

public C1CommandLinks CommandLinks {get;}

[Delphi]

property CommandLinks: C1CommandLinks;

See Also

C1ToolBar class


CustomizeButton Property

CustomizeButton Property

Gets or sets the value indicating whether the customize button will appear as the last button in the toolbar.

Syntax

[VB]

Public Property CustomizeButton As Boolean

[C#]

public bool CustomizeButton {get;set;}

[Delphi]

property CustomizeButton: Boolean;

See Also

C1ToolBar class


CustomizeMode Property

CustomizeMode Property

Indicates whether the toolbar is currently in customize mode.

Syntax

[VB]

Public ReadOnly Property CustomizeMode As Boolean

[C#]

public bool CustomizeMode {get;set;}

[Delphi]

property CustomizeMode: Boolean;

See Also

C1ToolBar class


CustomizeOptions Property

CustomizeOptions Property

Gets or sets the value indicating what can be customized in this toolbar.

Syntax

[VB]

Public Property CustomizeOptions As CustomizeOptionsFlags

[C#]

public CustomizeOptionsFlags CustomizeOptions {get;set;}

[Delphi]

property CustomizeOptions: CustomizeOptionsFlags;

See Also

C1ToolBar class


Floating Property

Floating Property

Indicates whether the toolbar is floating.

Syntax

[VB]

Public ReadOnly Property Floating As Boolean

[C#]

public bool Floating {get;}

[Delphi]

property Floating: Boolean;

See Also

C1ToolBar class


ForeHiColor Property (C1ToolBar)

ForeHiColor Property (C1ToolBar)

Gets or sets the text color of the highlighted item.

Syntax

[VB]

Public Property ForeHiColor As System.Drawing.Color

[C#]

public System.Drawing.Color ForeHiColor {get; set;}

[Delphi]

property ForeHiColor: System.Drawing.Color;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


Horizontal Property

Horizontal Property

Gets or sets the orientation of the toolbar.

Syntax

[VB]

Public Property Horizontal As Boolean

[C#]

public bool Horizontal {get; set;}

[Delphi]

property Horizontal: Boolean;

Remarks

Can be set to false to force the vertical orientation of the toolbar.

See Also

C1ToolBar class


MinButtonSize Property

MinButtonSize Property

Sets or gets the minimum size (width and height) of buttons in the toolbar.

Syntax

[VB]

Public Property MinButtonSize As Integer

[C#]

public int MinButtonSize {get; set;}

[Delphi]

property MinButtonSize: Integer;

See Also

C1ToolBar class


Movable Property

Movable Property

Indicates whether the toolbar can be moved by the user.

Syntax

[VB]

Public ReadWrite Property Movable As Boolean

[C#]

public bool Movable {get; set;}

[Delphi]

property Movable: Boolean;

Remarks

Can be set to False to prevent the end user from moving the toolbar even if it is placed in a C1CommandDock.

See Also

C1ToolBar class


ShowToolTips Property (C1ToolBar)

ShowToolTips Property (C1ToolBar)

Gets or sets the value indicating whether to show tooltip texts when mouse cursor is over toolbutton.

Syntax

[VB]

Public NotOverridable Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get; set;}

[Delphi]

property ShowToolTips: Boolean;

See Also

C1ToolBar class


ToolBarStyle Property

ToolBarStyle Property

Allows specification of the dropdown menu look for the toolbar.

Syntax

[VB]

Public Property ToolBarStyle As ToolBarStyleEnum

[C#]

public ToolBarStyleEnum ToolBarStyle {get; set;}

[Delphi]

property ToolBarStyle: ToolBarStyleEnum;

Remarks

Most useful with toolbars that are not moveable/dockable.

See Also

C1ToolBar class

ToolBarStyleEnum Enumeration


WrapText Property

WrapText Property

If ButtonWidth > 0, and WrapText is true, links text's wrap if their length exceeds ButtonWidth.

Syntax

[VB]

Public Property WrapText As Boolean

[C#]

public bool WrapText {get; set;}

[Delphi]

property WrapText: Boolean;

See Also

C1ToolBar class


C1ToolBar Events

BackHiColorChanged Event (C1ToolBar)

BorderChanged Event

ButtonAlignChanged Event

ButtonLayoutHorzChanged Event

ButtonLayoutVertChanged Event

ButtonLookHorzChanged Event

ButtonLookVertChanged Event

ButtonLookEnforceHorzChanged Event

ButtonLookEnforceVertChanged Event

ButtonWidthChanged Event

CurrentLinkChanged Event

CustomizeButtonChanged Event

DrawBar Event

DrawFloatingCaption Event

DrawLink Event

ForeHiColorChanged Event (C1ToolBar)

HorizontalChanged Event

LayoutLink Event (C1ToolBar)

MeasureFloatingCaption Event

MeasureLink Event (C1ToolBar)

MinButtonSizeChanged Event

Reset Event

ShowToolTipsChanged Event (C1ToolBar)

ToolBarStyleChanged Event

WrapTextChanged Event


BackHiColorChanged Event (C1ToolBar)

BackHiColorChanged Event (C1ToolBar)

Occurs when the value of the BackHiColor property changes.

Syntax

[VB]

Public Event BackHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BackHiColorChanged

[Delphi]

property BackHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


BorderChanged Event

BorderChanged Event

Occurs when the value of the Border property changes.

Syntax

[VB]

Public Event BorderChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler BorderChanged

[Delphi]

property BorderChanged: EventHandler;

See Also

C1ToolBar class


ButtonAlignChanged Event

ButtonAlignChanged Event

Occurs when the value of the ButtonAlign property changes.

Syntax

[VB]

Public Event ButtonAlignChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonAlignChanged

[Delphi]

property ButtonAlignChanged: EventHandler;

See Also

C1ToolBar class


ButtonLayoutHorzChanged Event

ButtonLayoutHorzChanged Event

Occurs when the value of the ButtonLayoutHorz property changes.

Syntax

[VB]

Public Event ButtonLayoutHorzChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLayoutHorzChanged

[Delphi]

property ButtonLayoutHorzChanged: EventHandler;

See Also

C1ToolBar class


ButtonLayoutVertChanged Event

ButtonLayoutVertChanged Event

Occurs when the value of the ButtonLayoutVert property changes.

Syntax

[VB]

Public Event ButtonLayoutVertChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLayoutVertChanged

[Delphi]

property ButtonLayoutVertChanged: EventHandler;

See Also

C1ToolBar class


ButtonLookHorzChanged Event

ButtonLookHorzChanged Event

Occurs when the value of the ButtonLookHorz property changes.

Syntax

[VB]

Public Event ButtonLookHorzChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLookHorzChanged

[Delphi]

property ButtonLookHorzChanged: EventHandler;

See Also

C1ToolBar class


ButtonLookVertChanged Event

ButtonLookVertChanged Event

Occurs when the value of the ButtonLookVert property changes.

Syntax

[VB]

Public Event ButtonLookVertChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLookVertChanged

[Delphi]

property ButtonLookVertChanged: EventHandler;

See Also

C1ToolBar class


ButtonLookEnforceHorzChanged Event

ButtonLookEnforceHorzChanged Event

Occurs when the value of the ButtonLookEnforceHorz property changes.

Syntax

[VB]

Public Event ButtonLookEnforceHorzChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLookEnforceHorzChanged

[Delphi]

property ButtonLookEnforceHorzChanged: EventHandler;

See Also

C1ToolBar class


ButtonLookEnforceVertChanged Event

ButtonLookEnforceVertChanged Event

Occurs when the value of the ButtonLookEnforceVert property changes.

Syntax

[VB]

Public Event ButtonLookEnforceVertChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonLookEnforceVertChanged

[Delphi]

property ButtonLookEnforceVertChanged: EventHandler;

See Also

C1ToolBar class


ButtonWidthChanged Event

ButtonWidthChanged Event

Occurs when the value of the ButtonWidth property changes.

Syntax

[VB]

Public Event ButtonWidthChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ButtonWidthChanged

[Delphi]

property ButtonWidthChanged: EventHandler;

See Also

C1ToolBar class


CurrentLinkChanged Event

CurrentLinkChanged Event

Occurs when the current command link changes.

Syntax

[VB]

Public Event CurrentLinkChanged(ByVal sender As Object, ByVal e As C1.Win.C1Command.CommandLinkEventArgs) As C1.Win.C1Command.CommandLinkEventHandler

[C#]

public event EventHandler CurrentLinkChanged

[Delphi]

property CurrentLinkChanged: EventHandler;

Remarks

If a handler is attached to this event of a menu or toolbar, and that menu or toolbar opens a sub-menu which does not have its own handler for this event, the parent's handler is invoked. This event can be used to keep track of which command link is currently selected (e.g. to set context-sensitive status help messages).

See Also

C1ToolBar class


CustomizeButtonChanged Event

CustomizeButtonChanged Event

Occurs when the value of the CustomizeButton property changes.

Syntax

[VB]

Public Event CustomizeButtonChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler CustomizeButtonChanged

[Delphi]

property CustomizeButtonChanged: EventHandler;

See Also

C1ToolBar class


DrawBar Event

DrawBar Event

Occurs when the owner-drawn C1ToolBar should be redrawn.

Syntax

[VB]

Public Event DrawBar(ByVal sender As Object, ByVal e As DrawBarEventArgs) As DrawBarEventHandler

[C#]

public event DrawBarEventHandler DrawBar

[Delphi]

property DrawBar: DrawBarEventHandler;

Event Data

The event handler receives an argument of type DrawBarEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the toolbar.
Path | The graphcs path bounding the bar.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1ToolBar class


DrawFloatingCaption Event

DrawFloatingCaption Event

Allows owner-draw of the caption of the window containing the toolbar when the toolbar is floating.

Syntax

[VB]

Public Event DrawFloatingCaption(sender As Object, e As DrawFloatingCaptionEventArgs) As DrawFloatingCaptionEventHandler

[C#]

public event DrawFloatingCaptionEventHandler DrawFloatingCaption

[Delphi]

property DrawFloatingCaption: DrawFloatingCaptionEventHandler;

See Also

C1ToolBar class


DrawLink Event

DrawLink Event

Occurs when the owner-drawn C1CommandLink should be redrawn.

Syntax

[VB]

Public Event DrawLink(ByVal sender As Object, ByVal e As DrawLinkEventArgs) As DrawLinkEventHandler

[C#]

public event DrawLinkEventHandler DrawLink

[Delphi]

property DrawLink: DrawLinkEventHandler;

Event Data

The event handler receives an argument of type DrawLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the link.
Link | C1CommandLink to draw
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

C1ToolBar class


ForeHiColorChanged Event (C1ToolBar)

ForeHiColorChanged Event (C1ToolBar)

Occurs when the value of the ForeHiColor property changes.

Syntax

[VB]

Public Event ForeHiColorChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ForeHiColorChanged

[Delphi]

property ForeHiColorChanged: EventHandler;

See Also

C1MainMenu class

C1ToolBar class

C1CommandMenu class


HorizontalChanged Event

HorizontalChanged Event

Occurs when the value of the Horizontal property changes.

Syntax

[VB]

Public Event HorizontalChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler HorizontalChanged

[Delphi]

property HorizontalChanged: EventHandler;

See Also

C1ToolBar class


LayoutLink Event (C1ToolBar)

LayoutLink Event (C1ToolBar)

See LayoutLink Event (C1MainMenu).


MeasureFloatingCaption Event

MeasureFloatingCaption Event

Allows owner-draw of the caption of the window containing the toolbar when the toolbar is floating.

Syntax

[VB]

Public Event MeasureFloatingCaption(sender As Object, e As MeasureFloatingCaptionEventArgs) As MeasureFloatingCaptionEventHandler

[C#]

public event MeasureFloatingCaptionEventHandler MeasureFloatingCaption

[Delphi]

property MeasureFloatingCaption: MeasureFloatingCaptionEventHandler;

See Also

C1ToolBar class


MeasureLink Event (C1ToolBar)

MeasureLink Event (C1ToolBar)

Occurs when it is necessary to measure the owner-drawn link.

Syntax

[VB]

Public Event MeasureLink(ByVal sender As Object, ByVal e As MeasureLinkEventArgs) As MeasureLinkEventHandler

[C#]

public event MeasureLinkEventHandler MeasureLink

[Delphi]

property MeasureLink: MeasureLinkEventHandler;

Event Data

The event handler receives an argument of type MeasureLinkEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
Graphics | Specifies the Graphics object to use for measuring.
Link | Specifies the link that needs to be measured.
Width | Specifies the width of the link.
Height | Specifies the height of the link.

See Also

C1ToolBar class


MinButtonSizeChanged Event

MinButtonSizeChanged Event

Occurs when the value of the MinButtonSize property changes.

Syntax

[VB]

Public Event MinButtonSizeChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler MinButtonSizeChanged

[Delphi]

property MinButtonSizeChanged: EventHandler;

See Also

C1ToolBar class


Reset Event

Reset Event

Fires when the Reset command from the Customize dialog box is clicked.

Syntax

[VB]

Public Event Reset(sender As Object, e As EventArgs) As EventHandler

[C#]

public event EventHandler Reset

[Delphi]

property Reset: EventHandler;

Event Data

The event handler receives an argument of type EventArgs containing data related to this event.

See Also

C1ToolBar class


ShowToolTipsChanged Event (C1ToolBar)

ShowToolTipsChanged Event (C1ToolBar)

Occurs when the value of the ShowToolTips property changes.

Syntax

[VB]

Public Event ShowToolTipsChanged (ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ShowToolTipsChanged

[Delphi]

property ShowToolTipsChanged: EventHandler;

See Also

C1ToolBar class


ToolBarStyleChanged Event

ToolBarStyleChanged Event

Occurs when the value of the ToolBarStyle property changes.

Syntax

[VB]

Public Event ToolBarStyleChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event EventHandler ToolBarStyleChanged

[Delphi]

property ToolBarStyleChanged: EventHandler;

See Also

C1ToolBar class


WrapTextChanged Event

WrapTextChanged Event

Occurs when the value of the WrapText property changes.

Syntax

[VB]

Public Event WrapTextChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler WrapTextChanged

[Delphi]

procedure WrapTextChanged: System.EventHandler;

See Also

C1ToolBar class


C1CommandDock class

The C1CommandDock control provides docking and floating capabilities to C1Command toolbars (class C1ToolBar) and tab controls (class C1DockingTab). Objects placed inside a C1CommandDock can be torn off at runtime, and either docked to one of the other sides of the containing form, or dropped into an arbitrary location on screen to become floating. Of course, all of these features can be turned off if necessary. If you need more control over the docking behavior, you can provide additional C1CommandDock objects at design time and limit runtime docking to those predefined docks.


C1CommandDock Members

C1CommandDock Public Properties

AllowFloat | Gets or sets the value indicating whether to allow floating toolbars.
AutoCreated | Indicates whether a dock area is created automatically.
AutoDockBottom | Gets or sets the value indicating whether to automatically create a dock area at the bottom.
AutoDockLeft | Gets or sets the value indicating whether to automatically create a dock area on the left.
AutoDockRight | Gets or sets the value indicating whether to automatically create a dock area on the right.
AutoDockTop | Gets or sets the value indicating whether to automatically create a dock area at the top.
AutoSize | Sets or returns whether the dock automatically adjusts its size.
Horizontal | Indicates whether the dock is horizontal.
MinimumHeight | Sets or returns the minimum height of the control.
MinimumWidth | Sets or returns the minimum width of the control.

C1CommandDock Public Methods

DockOrFloatChild

Docs or floats the specified control.


C1CommandDock Properties

AllowFloat Property

AutoCreated Property

AutoDockBottom Property

AutoDockLeft Property

AutoDockRight Property

AutoDockTop Property

AutoSize Property

Horizontal Property

MinimumHeight Property

MinimumWidth Property


AllowFloat Property

AllowFloat Property

Indicates whether to allow floating toolbars.

Syntax

[VB]

Public Property AllowFloat As Boolean

[C#]

public bool AllowFloat {get; set;}

[Delphi]

property AllowFloat: Boolean;

See Also

C1CommandDock class


AutoCreated Property

AutoCreated Property

Indicates whether a dock area is created automatically.

Syntax

[VB]

Public ReadOnly Property AutoCreated As Boolean

[C#]

public bool AutoCreated {get;}

[Delphi]

property AutoCreated: Boolean;

See Also

C1CommandDock class


AutoDockBottom Property

AutoDockBottom Property

Gets or sets the value indicating whether to automatically create a dock area at the bottom.

Syntax

[VB]

Public Property AutoDockBottom As Boolean

[C#]

public bool AutoDockBottom {get; set;}

[Delphi]

property AutoDockBottom: Boolean;

See Also

C1CommandDock class


AutoDockLeft Property

AutoDockLeft Property

Gets or sets the value indicating whether to automatically create a dock area on the left.

Syntax

[VB]

Public Property AutoDockLeft As Boolean

[C#]

public bool AutoDockLeft {get; set;}

[Delphi]

property AutoDockLeft: Boolean;

See Also

C1CommandDock class


AutoDockRight Property

AutoDockRight Property

Gets or sets the value indicating whether to automatically create a dock area on the right.

Syntax

[VB]

Public Property AutoDockRight As Boolean

[C#]

public bool AutoDockRight {get; set;}

[Delphi]

property AutoDockRight: Boolean;

See Also

C1CommandDock class


AutoDockTop Property

AutoDockTop Property

Gets or sets the value indicating whether to automatically create a dock area at the top.

Syntax

[VB]

Public Property AutoDockTop As Boolean

[C#]

public bool AutoDockTop {get; set;}

[Delphi]

property AutoDockTop: Boolean;

See Also

C1CommandDock class


AutoSize Property

AutoSize Property

Sets or returns whether the dock automatically adjusts its size.

Syntax

[VB]

Public Property AutoSize As Boolean

[C#]

public bool AutoSize {get; set;}

[Delphi]

property AutoSize: Boolean;

Remarks

Replaces the (now obsolete) AutoExpand and AutoShrink properties. At design time, the AutoSize property is respected unless there are no nested controls in the dock.

See Also

C1CommandDock class


Horizontal Property

Horizontal Property

Indicates whether the dock is horizontal.

Syntax

[VB]

Public Property Horizontal As Boolean

[C#]

public bool Horizontal {get;}

[Delphi]

property Horizontal: Boolean;

Remarks

Can be set to False to force vertical orientation of the toolbar.

See Also

C1CommandDock class


MinimumHeight Property

MinimumHeight Property

Sets or returns the minimum height of the control.

Syntax

[VB]

Public Property MinimumHeight As Integer

[C#]

public int MinimumHeight {get; set;}

[Delphi]

property MinimumHeight: Integer;

See Also

C1CommandDock class


MinimumWidth Property

MinimumWidth Property

Sets or returns the minimum width of the control.

Syntax

[VB]

Public Property MinimumWidth As Integer

[C#]

public int MinimumWidth {get; set;}

[Delphi]

property MinimumWidth: Integer;

See Also

C1CommandDock class


C1CommandDock Methods

DockOrFloatChild Method


DockOrFloatChild Method

DockOrFloatChild Method

Docs or floats the specified control.

Syntax

[VB]

Public Sub DockOrFloatChild(child As Control, screenPt As Point)

[C#]

public void DockOrFloatChild (Control child , Point screenPt )

[Delphi]

procedure DockOrFloatChild(child: Control; screenPt: Point);

Parameter | Description
child | The child command.
screenPt | The x- and y-coordinates of the point where the child command will be moved.

See Also

C1CommandDock class


C1DockingTab class

This class implements the familiar tab control interface: several overlaying pages (each of which can contain arbitrary controls) accessible via tabs at the side of the control. In addition to this standard behavior, the C1DockingTab also provides docking and floating behavior: the whole control, or individual pages (tabs) can be torn off and automatically docked to one of the other sides of the form, to another C1DockingTab control, or made floating. Please note that to enable the docking and floating behavior of the C1DockingTab control, it must be placed inside a C1CommandDock (which is also included in the C1Command product).

C1DockingTab Members

C1DockingTab Properties

C1DockingTab Methods

C1DockingTab Events


C1DockingTab Members

C1DockingTab Public Properties

AcceptsCtrlTab | Gets or sets a value indicating whether the control handles Ctrl-Tab and Ctrl-Shift-Tab keys. The default value is true.
Alignment | Gets or sets the area of the control (top, bottom, left or right) where the tabs are aligned.
Animate | Gets or sets a value indicating whether to use animation when showing or hiding the control. The default is true.
AutoHiding | Gets or sets the value indicating whether the pages of the C1DockingTab control are in auto-hiding mode (runtime-only).
CanAutoHide | Gets or sets a value indicating whether the pages can auto-hide (if both CanAutoHide and ShowCaption are true, a pin icon appears in the caption area).
CanCloseTabs | Gets or sets a value indicating whether individual tab pages can be closed by the end user. If CanCloseTabs is true, a close icon appears either in the caption area (if ShowCaption is true), or in the tabs area otherwise.
CanMoveTabs | Gets or sets a value indicating whether the end user can rearrange tabs by dragging them around at runtime.
CreatorDockingTab | Gets the C1DockingTab which automatically created this instance in response to user actions.
Dock | Gets or sets the docking of the control in the parent container. Can be specified only for controls not parented in a C1CommandDock.
Floating | Gets the value indicating whether the C1DockingTab is currently floating (runtime - only).
HotTrack | Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.
ImageList | Gets or sets the image list used to provide images to show on the control’s tabs.
Indent | Gets or sets the indentation of the first tab from the side of the control.
ItemSize | Gets or sets the size of the tabs (if empty, the size is calculated automatically based on content).
Multiline | Gets or sets a value indicating whether more than one row of tabs can be displayed.
OutlineMode | Gets or sets the way window outlines are drawn when the C1DockingTab control or its individual pages are moved at runtime by the user.
Padding | Gets or sets the amount of space around each item on the control's tab pages.
RowCount | Gets the number of tab rows (runtime-only).
ScrollActive | Gets the value indicating whether tabs scrolling arrows are currently shown (runtime-only).
SelectedIndex | Gets or sets the index of the currently selected page.
SelectedTab | Gets or sets the currently selected page.
ShowCaption | Gets or sets a value indicating whether caption is shown on the pages.
ShowSingleTab | Gets or sets a value indicating whether a tab will be shown when there is only one page in the control.
ShowToolTips | Gets or sets a value indicating whether the tool tip is shown when the mouse passes over the tab.
SplitterWidth | Gets or sets the width of automatic splitters drawn between pages of the control when page docking is enabled.
TabAreaBackColor | Gets or sets the background color of the tab area.
TabsCanFocus | Gets or sets a value indicating whether tabs can receive focus on mouse click. The default is true.
TabCount | Gets the number of pages in the control.
TabLayout | Gets or sets the layout of text and images on the tabs.
TabLook | Gets or sets the look of the tabs (whether to show text, image or both).
TabPages | Gets the collection of tab pages in this control.
TabSizeMode | Gets or sets the way in which the tabs are sized.
Text | Gets the text of the currently selected tab (runtime-only).
TextDirection | Gets or sets the direction of the text drawn on the tabs.
UIStrings | Gets the array of the user interface strings and allows to customize and/or localize the end user visible strings.

C1DockingTab Public Methods

BeginUpdate | Temporarily suspends the layout logic for the control.
Close | Closes the tab page specified.
EndUpdate | Resumes normal layout logic.
GetTabRowCol | Returns the row and column of the specified tab in the tabs of the C1DockingTab.
Refresh (inherited from Control) | Forces the control to invalidate its client area and immediately redraw itself and any child controls.
RestoreLayout | Restores the previously saved layout of the tabs on the form from the specified file.
SaveLayout | Saves the current layout of the tabs on the form to the specified file.
SlideHidePage | Hides the page by sliding it to the side.
SlideShowPage | Shows the page by sliding it out.
FindPage | Returns the page with the specified tab text.
ScrollToSelectedTab | Scrolls the tabs if necessary so that the tab of the currently selected page is visible.

C1DockingTab Public Events

AlignmentChanged | Occurs when the Alignment property is changed.
AutoCreatedDockingTab | Fired when a new C1DockingTab is automatically created in response to user actions (e.g. tearing off a tab and dropping it elsewhere).
CanAutoHideChanged | Occurs when the CanAutoHide property is changed.
CanCloseTabsChanged | Occurs when the CanCloseTabs property is changed.
CanMoveTabsChanged | Occurs when the CanMove property is changed.
DrawTab | Allows to override the standard drawing of the tabs with custom drawing.
HotTrackChanged | Occurs when the HotTrack property is changed.
ItemSizeChanged | Occurs when the ItemSize property is changed.
IndentChanged | Occurs when the Indent property is changed.
MeasureTab | Allows to arbitrarily change the size of the tabs.
MultiLineChanged | Occurs when the MultiLine property is changed.
PaddingChanged | Occurs when the Padding property is changed.
SelectedIndexChanging | Event fired when the index of the currently selected page is about to change. Allows to cancel the change.
SelectedIndexChanged | Occurs when the SelectedIndex property is changed.
ShowCaptionChanged | Occurs when the ShowCaption property is changed.
ShowSingleTabChanged | Occurs when the ShowSingleTab property is changed.
ShowToolTipsChanged | Occurs when the ShowToolTips property is changed.
TabSizeModeChanged | Occurs when the TabSizeMode property is changed.
TabLayoutChanged | Occurs when the TabLayout property is changed.
TabLookChanged | Occurs when the TabLook property is changed.
TabPageClosing | Event fired when the currently selected page is about to be closed by the user. Allows to cancel closing the page.
TabPageClosed | Event fired after a page has been closed.


C1DockingTab Properties

AcceptsCtrlTab Property

Alignment Property

Animate Property

AutoHiding Property

CanAutoHide Property

CanCloseTabs Property

CanMoveTabs Property

CreatorDockingTab Property

Dock Property

Floating Property

HotTrack Property

ImageList Property

Indent Property

ItemSize Property

Multiline Property

OutlineMode Property

Padding Property

RowCount Property

ScrollActive Property

SelectedIndex Property

SelectedTab Property

ShowCaption Property

ShowSingleTab Property

ShowToolTips Property

SplitterWidth Property

TabAreaBackColor Property

TabsCanFocus Property

TabCount Property

TabLayout Property

TabLook Property

TabPages Property

TabSizeMode Property

Text Property

TextDirection Property

UIStrings Property


AcceptsCtrlTab Property

AcceptsCtrlTab Property

Gets or sets a value indicating whether the control handles Ctrl-Tab and Ctrl-Shift-Tab keys.

Syntax

[VB]

Public Property AcceptsCtrlTab As Boolean

[C#]

public bool AcceptsCtrlTab {get; set;}

[Delphi]

property AcceptsCtrlTab: Boolean;

Remarks

The default value is true.

See Also

C1DockingTab class


Alignment Property

Alignment Property

Gets or sets the area of the control (top, bottom, left or right) where the tabs are aligned.

Syntax

[VB]

Public Property Alignment As System.Windows.Forms.TabAlignment

[C#]

public System.Windows.Forms.TabAlignment Alignment {get; set;}

[Delphi]

property Alignment: System.Windows.Forms.TabAlignment;

See Also

C1DockingTab class


Animate Property

Animate Property

Gets or sets a value indicating whether to use animation when showing or hiding the control.

Syntax

[VB]

Public Property Animate As Boolean

[C#]

public bool Animate {get; set;}

[Delphi]

property Animate: Boolean;

Remarks

The default is true.

See Also

C1DockingTab class


AutoHiding Property

AutoHiding Property

Gets or sets the value indicating whether the pages of the DockingTab control are in auto-hiding mode (runtime-only).

Syntax

[VB]

Public Property AutoHiding As Boolean

[C#]

public bool AutoHiding {get; set;}

[Delphi]

property AutoHiding: Boolean;

See Also

C1DockingTab class


CanAutoHide Property

CanAutoHide Property

Gets or sets a value indicating whether the pages can auto-hide (if both CanAutoHide and ShowCaption are true, a pin icon appears in the caption area).

Syntax

[VB]

Public Property CanAutoHide As Boolean

[C#]

public bool CanAutoHide {get; set;}

[Delphi]

property CanAutoHide: Boolean;

See Also

C1DockingTab class


CanCloseTabs Property

CanCloseTabs Property

Gets or sets a value indicating whether individual tab pages can be closed by the end user. If CanCloseTabs is true, a close icon appears either in the caption area (if ShowCaption is true), or in the tabs area otherwise.

Syntax

[VB]

Public Property CanCloseTabs As Boolean

[C#]

public bool CanCloseTabs {get; set;}

[Delphi]

property CanCloseTabs: Boolean;

See Also

C1DockingTab class


CanMoveTabs Property

CanMoveTabs Property

Gets or sets a value indicating whether the end user can rearrange tabs by dragging them around at runtime.

Syntax

[VB]

Public Property CanMoveTabs As Boolean

[C#]

public bool CanMoveTabs {get; set;}

[Delphi]

property CanMoveTabs: Boolean;

See Also

C1DockingTab class


CreatorDockingTab Property

CreatorDockingTab Property

Gets the C1DockingTab which automatically created this instance in response to user actions.

Syntax

[VB]

Public ReadOnly Property CreatorDockingTab As C1.Win.C1Command.C1DockingTab

[C#]

public C1.Win.C1Command.C1DockingTab CreatorDockingTab {get; }

[Delphi]

property CanMoveTabs: C1.Win.C1Command.C1DockingTab;

See Also

C1DockingTab class


Dock Property

Dock Property

Gets or sets the docking of the control in the parent container. Can be specified only for controls not parented in a C1CommandDock.

Syntax

[VB]

Public Property Dock As Systems.Windows.Forms.DocStyle

[C#]

public Systems.Windows.Forms.DocStyle. Dock {get; set;}

[Delphi]

property Dock: Systems.Windows.Forms.DocStyle;

See Also

C1DockingTab class


Floating Property

Floating Property

Gets the value indicating whether the C1DockingTab is currently floating (runtime – only).

Syntax

[VB]

Public ReadOnly Property Floating As Boolean

[C#]

public bool Floating {get;}

[Delphi]

property Floating: Boolean;

See Also

C1DockingTab class


HotTrack Property

HotTrack Property

Gets or sets a value indicating whether the control's tabs change in appearance when the mouse passes over them.

Syntax

[VB]

Public Property HotTrack As Boolean

[C#]

public bool HotTrack {get; set;}

[Delphi]

property HotTrack: Boolean;

See Also

C1DockingTab class


ImageList Property

ImageList Property

Gets or sets the image list used to provide images to show on the control’s tabs.

Syntax

[VB]

Public Property ImageList As Systems.Windows.Forms.ImageList

[C#]

public Systems.Windows.Forms.ImageList ImageList {get; set;}

[Delphi]

property ImageList: Systems.Windows.Forms.ImageList;

See Also

C1DockingTab class


Indent Property

Indent Property

Gets or sets the indentation of the first tab from the side of the control.

Syntax

[VB]

Public Property Indent As Integer

[C#]

public int Indent {get; set;}

[Delphi]

property Indent: Integer;

See Also

C1DockingTab class


ItemSize Property

ItemSize Property

Gets or sets the size of the tabs (if empty, the size is calculated automatically based on content)

Syntax

[VB]

Public Property ItemSize As System.Drawing.Size

[C#]

public System.Drawing.Size ItemSize {get; set;}

[Delphi]

property ItemSize: System.Drawing.Size;

See Also

C1DockingTab class


Multiline Property

Multiline Property

Gets or sets a value indicating whether more than one row of tabs can be displayed.

Syntax

[VB]

Public Property Multiline As Boolean

[C#]

public bool Multiline {get; set;}

[Delphi]

property Multiline: Boolean;

See Also

C1DockingTab class


OutlineMode Property

OutlineMode Property

Gets or sets the way window outlines are drawn when the C1DockingTab control or its individual pages are moved at runtime by the user.

Syntax

[VB]

Public Shared Property OutlineMode As OutlineModeEnum

[C#]

public static OutlineModeEnum OutlineMode {get;set;}

[Delphi]

property OutlineMode: OutlineModeEnum; static;

Remarks

The default for this property is Reversible mode, which is faster (so works better on slower machines) and produces more consistent results across different video hardware. Transparent mode may produce better-looking results on faster systems, but is generally slower. Note that this is a static property and controls the behavior of all C1DockingTab controls in the application.

See Also

C1DockingTab class


Padding Property

Padding Property

Gets or sets the amount of space around each item on the control's tab pages.

Syntax

[VB]

Public Property Padding As System.Drawing.Point

[C#]

public System.Drawing.Point Padding {get; set;}

[Delphi]

property Padding: System.Drawing.Point;

See Also

C1DockingTab class


RowCount Property

RowCount Property

Gets the number of tab rows (runtime-only).

Syntax

[VB]

Public Property RowCount As Integer

[C#]

public int RowCount {get;}

[Delphi]

property RowCount: Integer;

See Also

C1DockingTab class


ScrollActive Property

ScrollActive Property

Gets the value indicating whether tabs scrolling arrows are currently shown (runtime-only).

Syntax

[VB]

Public Property ScrollActive As Boolean

[C#]

public bool ScrollActive {get;}

[Delphi]

property ScrollActive: Boolean;

See Also

C1DockingTab class


SelectedIndex Property

SelectedIndex Property

Gets or sets the index of the currently selected page.

Syntax

[VB]

Public Property SelectedIndex As Integer

[C#]

public int SelectedIndex {get; set;}

[Delphi]

property SelectedIndex: Integer;

See Also

C1DockingTab class


SelectedTab Property

SelectedTab Property

Gets or sets the currently selected page.

Syntax

[VB]

Public Property SelectedTab As C1.Win.C1Command.C1DockingTabPage

[C#]

public C1.Win.C1Command.C1DockingTabPage SelectedTab {get; set;}

[Delphi]

property SelectedTab: C1.Win.C1Command.C1DockingTabPage;

See Also

C1DockingTab class


ShowCaption Property

ShowCaption Property

Gets or sets a value indicating whether caption is shown on the pages.

Syntax

[VB]

Public Property ShowCaption As Boolean

[C#]

public bool ShowCaption {get; set;}

[Delphi]

property ShowCaption: Boolean;

See Also

C1DockingTab class


ShowSingleTab Property

ShowSingleTab Property

Gets or sets a value indicating whether a tab will be shown when there is only one page in the control.

Syntax

[VB]

Public Property ShowSingleTab As Boolean

[C#]

public bool ShowSingleTab {get; set;}

[Delphi]

property ShowSingleTab: Boolean;

See Also

C1DockingTab class


ShowToolTips Property

ShowToolTips Property

Gets or sets a value indicating whether the tool tip is shown when the mouse passes over the tab.

Syntax

[VB]

Public Property ShowToolTips As Boolean

[C#]

public bool ShowToolTips {get; set;}

[Delphi]

property ShowToolTips: Boolean;

See Also

C1DockingTab class


SplitterWidth Property

SplitterWidth Property

Gets or sets the width of automatic splitters drawn between pages of the control when page docking is enabled.

Syntax

[VB]

Public Property SplitterWidth As Integer

[C#]

public int SplitterWidth {get; set;}

[Delphi]

property SplitterWidth: Integer;

See Also

C1DockingTab class


TabAreaBackColor Property

TabAreaBackColor Property

Gets or sets the background color of the tab area.

Syntax

[VB]

Public Property TabAreaBackColor As System.Drawing.Color

[C#]

public System.Drawing.Color TabAreaBackColor {get; set;}

[Delphi]

property TabAreaBackColor: System.Drawing.Color;

See Also

C1DockingTab class


TabsCanFocus Property

TabsCanFocus Property

Gets or sets a value indicating whether tabs can receive focus on mouse click.

Syntax

[VB]

Public Property TabsCanFocus As Boolean

[C#]

public bool TabsCanFocus {get; set;}

[Delphi]

property TabsCanFocus: Boolean;

Remarks

The default is true.

See Also

C1DockingTab class


TabCount Property

TabCount Property

Gets the number of pages in the control.

Syntax

[VB]

Public Property TabCount As Integer

[C#]

public int TabCount {get;}

[Delphi]

property TabCount: Integer;

See Also

C1DockingTab class


TabLayout Property

TabLayout Property

Gets or sets the layout of text and images on the tabs.

Syntax

[VB]

Public Property TabLayout As C1.Win.C1Command.ButtonLayoutEnum

[C#]

public C1.Win.C1Command.ButtonLayoutEnum TabLayout {get; set;}

[Delphi]

property TabLayout: C1.Win.C1Command.ButtonLayoutEnum;

See Also

C1DockingTab class


TabLook Property

TabLook Property

Gets or sets the look of the tabs (whether to show text, image or both).

Syntax

[VB]

Public Property TabLook As C1.Win.C1Command.ButtonLookFlags

[C#]

public C1.Win.C1Command.ButtonLookFlags TabLook {get; set;}

[Delphi]

property TabLook: C1.Win.C1Command.ButtonLookFlags;

See Also

C1DockingTab class


TabPages Property

TabPages Property

Gets the collection of tab pages in this control.

Syntax

[VB]

Public Property TabPages As C1.Win.C1Command.TabPages

[C#]

public C1.Win.C1Command.TabPages TabPages {get;}

[Delphi]

property TabPages: C1.Win.C1Command.TabPages;

See Also

C1DockingTab class


TabSizeMode Property

TabSizeMode Property

Gets or sets the way in which the tabs are sized.

Syntax

[VB]

Public Property TabSizeMode As C1.Win.C1Command.TabSizeModeEnum

[C#]

public C1.Win.C1Command.TabSizeModeEnum TabSizeMode {get; set;}

[Delphi]

property TabSizeMode: C1.Win.C1Command.TabSizeModeEnum;

See Also

C1DockingTab class


Text Property

Text Property

Gets the text of the currently selected tab (runtime-only).

Syntax

[VB]

Public Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: String;

See Also

C1DockingTab class


TextDirection Property

TextDirection Property

Gets or sets the direction of the text drawn on the tabs.

Syntax

[VB]

Public Property TextDirection As C1.Win.C1Command.TabTextDirectionEnum

[C#]

public C1.Win.C1Command.TabTextDirectionEnum TextDirection {get; set;}

[Delphi]

property TextDirection: C1.Win.C1Command.TabTextDirectionEnum;

See Also

C1DockingTab class


UIStrings Property

UIStrings Property

Gets the array of the user interface strings and allows to customize and/or localize the end user visible strings.

Syntax

[VB]

Public ReadOnly Property UIStrings As C1.Util.UIStrings

[C#]

public C1.Util.UIStrings UIStrings {get; }

[Delphi]

property UIStrings: C1.Util.UIStrings;

See Also

C1DockingTab class

Remarks

The C1DockingTab tooltip strings can be set on the C1DockingTab itself. But, if your form contains a C1CommandHolder, the tooltips can be set on that instead (via its UIStrings property), then they will affect all C1DockingTab controls found on the form unless they were changed there.


C1DockingTab Methods

BeginUpdate Method (C1DockingTab)

Close Method

EndUpdate Method

FindPage Method

GetTabRowCol Method

Refresh Method

RestoreLayout Method

SaveLayout Method

ScrollToSelectedTab Method

SlideHidePage Method

SlideShowPage Method


BeginUpdate Method (C1DockingTab)

BeginUpdate Method (C1DockingTab)

Temporarily suspends the layout logic for the control.

Syntax

[VB]

Public Sub BeginUpdate()

[C#]

public void BeginUpdate()

[Delphi]

procedure BeginUpdate;

See Also

C1DockingTab class


Close Method

Close Method

Closes the tab page specified.

Syntax

[VB]

Public Sub Close()

[C#]

public void Close()

[Delphi]

procedure Close;

See Also

C1DockingTab class


EndUpdate Method

EndUpdate Method

Resumes normal layout logic.

Syntax

[VB]

Public Sub EndUpdate()

[C#]

public void EndUpdate()

[Delphi]

procedure EndUpdate;

See Also

C1DockingTab class


FindPage Method

FindPage Method

Returns the page with the specified tab text.

Syntax

[VB]

Public Function FindPage(ByVal text As String) As Integer

[C#]

public System.Int32 FindPage ( System.String text)

[Delphi]

procedure FindPage(text: String): Integer;

See Also

C1DockingTab class


GetTabRowCol Method

GetTabRowCol Method

Returns the row and column of the specified tab in the tabs of the C1DockingTab.

Syntax

[VB]

Public Sub GetTabRowCol(ByVal tabIdx As Integer, ByRef row As Integer, ByRef col As Integer)

[C#]

public void GetTabRowCol (System.Int32 tabIdx, System.Int32 row, System.Int32 col )

[Delphi]

procedure GetTabRowCol(tabIdx: Integer; row: Integer; col: Integer);

See Also

C1DockingTab class


Refresh Method

Refresh Method

Forces the control to invalidate its client area and immediately redraw itself and any child controls.

Syntax

[VB]

Public Overridable Sub Refresh()

[C#]

public virtual void Refresh()

[Delphi]

procedure Refresh; virtual;

See Also

C1DockingTab class


RestoreLayout Method

RestoreLayout Method

Restores the previously saved layout of the tabs on the form from the specified file.

Syntax

[VB]

Public Shared Sub RestoreLayout(ByVal form As System.Windows.Forms.Form, ByVal filename As String)

Public Shared Sub RestoreLayout(ByVal form As System.Windows.Forms.Form, ByVal string As System.IO.Stream)

[C#]

public static void RestoreLayout ( System.Windows.Forms.Form form , System.String filename)

public static void RestoreLayout ( System.Windows.Forms.Form form, System.IO.Stream stream)

[Delphi]

procedure RestoreLayout( form: System.Windows.Forms.Form; filename: String);

procedure RestoreLayout( form: System.Windows.Forms.Form; stream: System.IO.Stream);

See Also

C1DockingTab class


SaveLayout Method

SaveLayout Method

Saves the current layout of the tabs on the form to the specified file.

Syntax

[VB]

Public Shared Sub SaveLayout(ByVal form As System.Windows.Forms.Form, ByVal filename As String)

Public Shared Sub SaveLayout(ByVal form As System.Windows.Forms.Form, ByVal string As System.IO.Stream)

[C#]

public static void SaveLayout (System.Windows.Forms.Form form , System.String filename)

public static void SaveLayout(System.Windows.Forms.Form form, System.IO.Stream stream);

[Delphi]

procedure SaveLayout(form: System.Windows.Forms.Form; filename: String);

procedure SaveLayout(form: System.Windows.Forms.Form; stream: System.IO.Stream);

See Also

C1DockingTab class


ScrollToSelectedTab Method

ScrollToSelectedTab Method

Scrolls the tabs if necessary so that the tab of the currently selected page is visible.

Syntax

[VB]

Public Sub ScrollToSelectedTab()

[C#]

public void ScrollToSelectedTab()

[Delphi]

procedure ScrollToSelectedTab;

See Also

C1DockingTab class


SlideHidePage Method

SlideHidePage Method

Hides the page by sliding it to the side.

Syntax

[VB]

Public Sub SlideHidePage()

[C#]

public void SlideHidePage()

[Delphi]

procedure SlideHidePage;

See Also

C1DockingTab class


SlideShowPage Method

SlideShowPage Method

Shows the page by sliding it out.

Syntax

[VB]

Public Sub SlideShowPage(ByVal pageIndex As Integer)

Public Sub SlideShowPage (ByVal page As C1.Win.C1Command.C1.TabPage)

[C#]

public void SlideShowPage (int pageIndex )

public void SlideShowPage (C1.Win.C1Command.C1.TabPage page)

[Delphi]

procedure SlideShowPage(pageIndex: Integer);

procedure SlideShowPage (page: C1.Win.C1Command.C1.TabPage);

See Also

C1DockingTab class


C1DockingTab Events

AlignmentChanged Event

AutoCreatedDockingTab Event

CanAutoHideChanged Event

CanCloseTabsChanged Event

CanMoveTabsChanged Event

DrawTab Event

HotTrackChanged Event

IndentChanged Event

ItemSizeChanged Event

MeasureTab Event

MultiLineChanged Event

PaddingChanged Event

SelectedIndexChanged Event

SelectedIndexChanging Event

ShowCaptionChanged Event

ShowSingleTabChanged Event

ShowToolTipsChanged Event

TabLayoutChanged Event

TabLookChanged Event

TabPageClosed Event

TabPageClosing Event

TabSizeModeChanged Event


AlignmentChanged Event

AlignmentChanged Event

Occurs when the Alignment property is changed.

Syntax

[VB]

Public Event AlignmentChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler AlignmentChanged

[Delphi]

property AlignmentChanged: EventHandler;

See Also

C1DockingTab class


AutoCreatedDockingTab Event

AutoCreatedDockingTab Event

Fired when a new C1DockingTab is automatically created in response to user actions (e.g. tearing off a tab and dropping it elsewhere).

Syntax

[VB]

Public Event AutoCreatedDockingTab(ByVal sender As Object, ByVal e As C1.Win.C1Command.AutoCreatedDockingTabEventArgs) As C1.Win.C1Command.AutoCreatedDockingTabHandler

[C#]

public event C1.Win.C1Command.AutoCreatedDockingTabHandler AutoCreatedDockingTab

[Delphi]

property AutoCreatedDockingTab: C1.Win.C1Command.AutoCreatedDockingTabHandler;

See Also

C1DockingTab class


CanAutoHideChanged Event

CanAutoHideChanged Event

Occurs when the CanAutoHide property is changed.

Syntax

[VB]

Public Event CanAutoHideChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler CanAutoHideChanged

[Delphi]

property CanAutoHideChanged: EventHandler;

See Also

C1DockingTab class


CanCloseTabsChanged Event

CanCloseTabsChanged Event

Occurs when the CanCloseTabs property is changed.

Syntax

[VB]

Public Event CanCloseTabsChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler CanCloseTabsChanged

[Delphi]

property CanCloseTabsChanged: EventHandler;

See Also

C1DockingTab class


CanMoveTabsChanged Event

CanMoveTabsChanged Event

Occurs when the CanMove property is changed.

Syntax

[VB]

Public Event CanMoveTabsChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler CanMoveTabsChanged

[Delphi]

property CanMoveTabsChanged: EventHandler;

See Also

C1DockingTab class


DrawTab Event

DrawTab Event

Allows to override the standard drawing of the tabs with custom drawing.

Syntax

[VB]

Public Event DrawTab(ByVal sender As Object, ByVal e As C1.Win.C1Command.DrawTabEventArgs) As C1.Win.C1Command.DrawTabEventHandler

[C#]

public event C1.Win.C1Command.DrawTabEventHandler DrawTab

[Delphi]

property DrawTab: EventHandler;

See Also

C1DockingTab class


HotTrackChanged Event

HotTrackChanged Event

Occurs when the HotTrack property is changed.

Syntax

[VB]

Public Event HotTrackChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler HotTrackChanged

[Delphi]

property HotTrackChanged: EventHandler;

See Also

C1DockingTab class


IndentChanged Event

IndentChanged Event

Occurs when the Indent property is changed.

Syntax

[VB]

Public Event IndentChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler IndentChanged

[Delphi]

property IndentChanged: EventHandler;

See Also

C1DockingTab class


ItemSizeChanged Event

ItemSizeChanged Event

Occurs when the ItemSize property is changed.

Syntax

[VB]

Public Event ItemSizeChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ItemSizeChanged

[Delphi]

property ItemSizeChanged: EventHandler;

See Also

C1DockingTab class


MeasureTab Event

MeasureTab Event

Allows to arbitrarily change the size of the tabs.

Syntax

[VB]

Public Event MeasureTab(ByVal sender As Object, ByVal e As C1. Win.C1Command.MeasureTab.EventArgs) As C1.Win.C1Command .MeasureTab.EventHandler

[C#]

public event C1.Win.C1Command.MeasureTabEventHandler MeasureTab

[Delphi]

property MeasureTab: EventHandler;

See Also

C1DockingTab class


MultiLineChanged Event

MultiLineChanged Event

Occurs when the MultiLine property is changed.

Syntax

[VB]

Public Event MultiLineChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler MultiLineChanged

[Delphi]

property MultiLineChanged: EventHandler;

See Also

C1DockingTab class


PaddingChanged Event

PaddingChanged Event

Occurs when the Padding property is changed.

Syntax

[VB]

Public Event PaddingChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler PaddingChanged

[Delphi]

property PaddingChanged: EventHandler;

See Also

C1DockingTab class


SelectedIndexChanged Event

SelectedIndexChanged Event

Occurs when the SelectedIndex property is changed.

Syntax

[VB]

Public Event SelectedIndexChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler SelectedIndexChanged

[Delphi]

property SelectedIndexChanged: EventHandler;

See Also

C1DockingTab class


SelectedIndexChanging Event

SelectedIndexChanging Event

Event fired when the index of the currently selected page is about to change. Allows to cancel the change.

Syntax

[VB]

Public Event SelectedIndexChanging(ByVal sender As Object, ByVal e As C1.Win.C1Command.SelectedIndexChangingEventArgs) As C1.Win.C1Command.SelectedIndexChangingEventHandler

[C#]

public event C1.Win.C1Command.SelectedIndexChangingEventHandler SelectedIndexChanging

[Delphi]

property SelectedIndexChanging: C1.Win.C1Command.SelectedIndexChangingEventHandler;

Event Data

The event handler receives an argument of type SelectedIndexChangingEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
NewIndex | Indicates the new index of the selected tab page.
CanCancel | indicates whether the change of the selected index can be cancelled by the event handler. In some situations, this is not allowed - e.g. when the C1DockingTab control is in the "sliding out" mode, there is a selected page, and the control is being resized (in that case, the selected page is hidden, so the selected index is changed to -1).

See Also

C1DockingTab class


ShowCaptionChanged Event

ShowCaptionChanged Event

Occurs when the ShowCaption property is changed.

Syntax

[VB]

Public Event ShowCaptionChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ShowCaptionChanged

[Delphi]

property ShowCaptionChanged: EventHandler;

See Also

C1DockingTab class


ShowSingleTabChanged Event

ShowSingleTabChanged Event

Occurs when the ShowSingleTab property is changed.

Syntax

[VB]

Public Event ShowSingleTabChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ShowSingleTabChanged

[Delphi]

property ShowSingleTabChanged: EventHandler;

See Also

C1DockingTab class


ShowToolTipsChanged Event

ShowToolTipsChanged Event

Occurs when the ShowToolTips property is changed.

Syntax

[VB]

Public Event ShowToolTipsChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ShowToolTipsChanged

[Delphi]

property ShowToolTipsChanged: EventHandler;

See Also

C1DockingTab class


TabLayoutChanged Event

TabLayoutChanged Event

Occurs when the TabLayout property is changed.

Syntax

[VB]

Public Event TabLayoutChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler TabLayoutChanged

[Delphi]

property TabLayoutChanged: EventHandler;

See Also

C1DockingTab class


TabLookChanged Event

TabLookChanged Event

Occurs when the TabLook property is changed.

Syntax

[VB]

Public Event TabLookChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler TabLookChanged

[Delphi]

property TabLookChanged: EventHandler;

See Also

C1DockingTab class


TabPageClosed Event

TabPageClosed Event

Event fired after a page has been closed.

Syntax

[VB]

Public Event TabPageClosed (ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event C1.Win.C1Command.TabPage EventHandler TabPageClosed

[Delphi]

property TabPageClosed: EventHandler;

Event Data

The event handler receives an argument of type TabPageCancelEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
TabPage | Indicates the tab page.

See Also

C1DockingTab class


TabPageClosing Event

TabPageClosing Event

Event fired when the currently selected page is about to be closed by the user. Allows to cancel closing the page.

Syntax

[VB]

Public Event TabPageClosing (ByVal sender As Object, ByVal e As System.ComponentModel.CancelEventArgs) As System.ComponentModel.CancelEventHandler

[C#]

public event System.ComponentModel.CancelEventHandler TabPageClosing

[Delphi]

property TabPageClosing: EventHandler;

Event Data

The event handler receives an argument of type TabPageCancelEventArgs containing data related to this event. The following properties provide information specific to this event.

Argument | Description
TabPage | Indicates the tab page.

See Also

C1DockingTab class


TabSizeModeChanged Event

TabSizeModeChanged Event

Occurs when the TabSizeMode property is changed.

Syntax

[VB]

Public Event TabSizeModeChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler TabSizeModeChanged

[Delphi]

property TabSizeModeChanged: EventHandler;

See Also

C1DockingTab class


C1DockingTabPage class

Represents a single tab page in a C1DockingTab.

C1DockingTabPage Members

C1DockingTabPage Constructors

C1DockingTabPage Properties

C1DockingTabPage Events


C1DockingTabPage Members

Public Constructor

C1DockingTabPage

Initializes a new instance of the the C1DockingTabPage class.

C1DockingTabPage Public Properties

CaptionText | Gets or sets the text in the caption area of the page. If not specified, defaults to the value of the Text property.
DisplayRectangle | Overridden. Gets or sets the Rectangle representing the display area of the tab page.
Image | Gets or sets the tab image.
ImageIndex | Gets or sets the index of the tab image in the tab control's ImageList.
IsSelected | Gets the value indicating whether this page is currently selected
TabBounds | Gets the tab bounds of the page.
TabBackColor | Gets or sets a background color for the non-selected tab.
TabBackColorSelected | Gets or sets the selected background color of the tab.
TabVisible | Gets or sets the value indicating whether the tab is visible or not. Allows to hide the tab page without removing it from the C1DockingTab control.
Text | Overridden. Gets or sets the text shown on the tab.
ToolTipText | Gets or sets the ToolTip text for the tab.

C1DockingTabPage Public Events

CaptionTextChanged | Occurs when the value of CaptionText property changes.
TabVisibleChanged | Occurs when the TabVisible property changes
ToolTipTextChanged | Occurs when the value of ToolTipText property changes.


C1DockingTabPage Constructors

C1DockingTabPage Constructor


C1DockingTabPage Constructor

C1DockingTabPage Constructor

Initializes a new instance of the the C1DockingTabPage class.

Syntax

[VB]

Public Sub New()

[C#]

public C1DockingTabPage( );

[Delphi]

constructor Create;

See Also

C1DockingTabPage class


C1DockingTabPage Properties

CaptionText Property

DisplayRectangle Property

Image Property

ImageIndex Property

IsSelected Property

TabBounds Property

TabBackColor Property

TabBackColorSelected Property

TabVisible Property

Text Property (C1DockingTabPage)

ToolTipText Property (C1DockingTabPage)


CaptionText Property

CaptionText Property

Gets or sets the text in the caption area of the page.

Syntax

[VB]

Public Property CaptionText As String

[C#]

public string CaptionText {get; set;}

[Delphi]

property CaptionText: String;

Remarks

If the value is not specified for the CaptionText property it defaults to the value of the C1DockingTabPage.Text property.

See Also

C1DockingTabPage class


DisplayRectangle Property

DisplayRectangle Property

Overridden. Gets or sets the Rectangle representing the display area of the tab page.

Syntax

[VB]

Public Property DisplayRectangle As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle DisplayRectangle {get;}

[Delphi]

property DisplayRectangle: System.Drawing.Rectangle;

See Also

C1DockingTabPage class


Image Property

Image Property

Gets or sets the tab image.

Syntax

[VB]

Public Property Image As String

[C#]

public System.Drawing.Image Image {get; set;}

[Delphi]

property Image: System.Drawing.Image;

See Also

C1DockingTabPage class


ImageIndex Property

ImageIndex Property

Gets or sets the index of the tab image in the tab control's ImageList.

Syntax

[VB]

Public Property ImageIndex As Integer

[C#]

public int ImageIndex {get; set;}

[Delphi]

property ImageIndex: Integer;

See Also

C1DockingTabPage class


IsSelected Property

IsSelected Property

Gets the value indicating whether this page is currently selected.

Syntax

[VB]

Public ReadOnly Property IsSelected As Boolean

[C#]

public bool IsSelected {get;}

[Delphi]

property IsSelected: Boolean;

See Also

C1DockingTabPage class


TabBounds Property

TabBounds Property

Returns the tab bounds of the page.

Syntax

[VB]

Public ReadOnly Property TabBounds As System.Drawing.Rectangle

[C#]

public System.Drawing.Rectangle TabBounds {get;}

[Delphi]

property TabBounds: System.Drawing.Rectangle;

See Also

C1DockingTabPage class


TabBackColor Property

TabBackColor Property

Gets or sets a background color for the non-selected tab.

Syntax

[VB]

Public Property TabBackColor As System.Drawing.Color

[C#]

public System.Drawing.Color TabBackColor {get; set;}

[Delphi]

property TabBackColor: System.Drawing.Color;

See Also

C1DockingTabPage class


TabBackColorSelected Property

TabBackColorSelected Property

Gets or sets the selected background color of the tab.

Syntax

[VB]

Public Property TabBackColorSelected As System.Drawing.Color

[C#]

public System.Drawing.Color TabBackColorSelected {get; set;}

[Delphi]

property TabBackColorSelected: System.Drawing.Color;

See Also

C1DockingTabPage class


TabVisible Property

TabVisible Property

Gets or sets the value indicating whether the tab is visible or not. Allows to hide the tab page without removing it from the C1DockingTab control.

Syntax

[VB]

Public Property TabVisible As Boolean

[C#]

public bool TabVisible {get; set;}

[Delphi]

property TabVisible: Boolean;

See Also

C1DockingTabPage class


Text Property (C1DockingTabPage)

Text Property (C1DockingTabPage)

Overridden. Gets or sets the text shown on the tab.

Syntax

[VB]

Public Property Text As String

[C#]

public string Text {get; set;}

[Delphi]

property Text: String;

See Also

C1DockingTabPage class


ToolTipText Property (C1DockingTabPage)

ToolTipText Property (C1DockingTabPage)

Gets or sets the ToolTip text for the tab.

Syntax

[VB]

Public Property ToolTipText As String

[C#]

public string ToolTipText {get; set;}

[Delphi]

property ToolTipText: String;

See Also

C1DockingTabPage class


C1DockingTabPage Events

CaptionTextChanged Event

TabVisibleChanged Event

ToolTipTextChanged Event


CaptionTextChanged Event

CaptionTextChanged Event

Occurs when the value of CaptionText property changes.

Syntax

[VB]

Public Event CaptionTextChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler CaptionTextChanged

[Delphi]

property CaptionTextChanged: EventHandler;

See Also

C1DockingTabPage class


TabVisibleChanged Event

TabVisibleChanged Event

Occurs when the TabVisible property changes.

Syntax

[VB]

Public Event TabVisibleChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler TabVisibleChanged {get; set;}

[Delphi]

property TabVisibleChanged: System.EventHandler;

See Also

C1DockingTabPage class


ToolTipTextChanged Event

ToolTipTextChanged Event

Occurs when the value of ToolTipText property changes.

Syntax

[VB]

Public Event ToolTipTextChanged(ByVal sender As Object, ByVal e As System.EventArgs) As System.EventHandler

[C#]

public event System.EventHandler ToolTipTextChanged

[Delphi]

property ToolTipTextChanged: EventHandler;

See Also

C1DockingTabPage class


C1DockingTabPageControlCollection class

Represents a collection of Control objects on a page of a C1DockingTab.


C1DockingTabPage.C1DockingTabPageControlCollection Members

Public Constructor

C1DockingTabpageControlCollection

Initializes a new instance of the the C1DockingTabPageControlCollection class.

Public Methods

Add

Overridden. Adds a C1DockingTabPage to the collection.


C1DockingTabPageControlCollection Constructors

C1DockingTabPageControlCollection Constructor


C1DockingTabPageControlCollection Constructor

C1DockingTabPageControlCollection Constructor

Initializes a new instance of the C1DockingTabPageControlCollection class

Syntax

[VB]

Public Sub New()

[C#]

public C1DockingTabPageControlCollection( );

[Delphi]

constructor C1DockingTabPageControlCollection.Create;

See Also

C1DockingTabPageControlCollection class


C1DockingTabPageControlCollection Methods

Add Method


Add Method

Add Method

Overridden. Adds a C1DockingTabPage to the collection.

Syntax

[VB]

Public Overridable Sub Add(ByVal value As System.Windows.Forms.Control)

[C#]

public virtual void Add (System.Windows.Forms.Control value )

[Delphi]

procedure Add(value: System.Windows.Forms.Control); virtual;

See Also

C1DockingTabPageControlCollection class


C1DockingTabPages Class

Contains a collection of C1DockingTabPage objects.


C1DockingTabPages Members

Public Properties

Item

Gets or sets a C1DockingTabPage in the collection.In C#, this property is the indexer for the C1DockingTabPages class.

Public Methods

Add | Adds a C1DockingTabPage object to the collection
AddRange | Copies the elements of the specified collection of C1DockingTabPage objects to the end of the collection.
Clear | Removes all elements from the collection.
Insert | Inserts a C1DockingTabPage object into the collection at the specified index.
InsertRange | Inserts the elements of the specified collection of C1DockingTabPage objects into the collection at the specified index.
RemoveAt | Removes the C1DockingTabPage object at the specified index from the collection.
RemoveRange | Removes the specified range of elements from the collection.


C1DockingTabPages Properties

Item Property (C1DockingTabPages)


Item Property (C1DockingTabPages)

Item Property (C1DockingTabPages)

Gets or sets a C1DockingTabPage in the collection.

Syntax

[VB]

Default Public Property Item(ByVal index As Integer)

[C#]

public C1.Win.C1Command.C1DockingTabPage this {get; set;}

[Delphi]

property Item(index: Integer);

Remarks

In C#, this property is the indexer for the C1DockingTabPages class.

See Also

C1DockingTabPages class


C1DockingTabPages Methods

Add Method (C1DockingTabPages)

AddRange Method

Clear Method

Insert Method

InsertRange Method

RemoveAt Method

RemoveRange Method


Add Method (C1DockingTabPages)

Add Method (C1DockingTabPages)

Adds a C1DockingTabPage object to the collection.

Syntax

[VB]

Public Overridable Function Add(ByVal o As Object) As Integer

[C#]

public virtual System.Int32 Add (System.Object o )

[Delphi]

function Add(o: Object): Integer; virtual;

See Also

C1DockingTabPages class


AddRange Method

AddRange Method

Copies the elements of the specified collection of C1DockingTabPage objects to the end of the collection.

Syntax

[VB]

Public Overridable Sub AddRange(ByVal c As System.Collections.ICollection)

[C#]

public virtual void AddRange ( System.Collections.Icollection c )

[Delphi]

procedure AddRange(c: System.Collections.Icollection); virtual;

See Also

C1DockingTabPages class


Clear Method

Clear Method

Removes all elements from the collection.

Syntax

[VB]

Public Overridable Sub Clear()

[C#]

public virtual void Clear ( )

[Delphi]

procedure Clear; virtual;

See Also

C1DockingTabPages class


Insert Method

Insert Method

Inserts a C1DockingTabPage object into the collection at the specified index.

Syntax

[VB]

Public Overridable Sub Insert(ByVal index As Integer, ByVal o As Object)

[C#]

public virtual void Insert ( System.Int32 index, System.Object o )

[Delphi]

procedure Insert(index: Integer; o: Object); virtual;

See Also

C1DockingTabPages class


InsertRange Method

InsertRange Method

Inserts the elements of the specified collection of C1DockingTabPage objects into the collection at the specified index.

Syntax

[VB]

Public Overridable Sub InsertRange(ByVal index As Integer, ByVal c As System.Collections.ICollection)

[C#]

public virtual void InsertRange ( System.Int32 index, System.Collections.ICollection c )

[Delphi]

procedure InsertRange(index: Integer; c: System.Collections.ICollection); virtual;

See Also

C1DockingTabPages class


RemoveAt Method

RemoveAt Method

Removes the C1DockingTabPage object at the specified index from the collection.

Syntax

[VB]

Public Overridable Sub RemoveAt(ByVal index As Integer)

[C#]

public virtual void RemoveAt ( System.Int32 index )

[Delphi]

procedure RemoveAt(index: Integer); virtual;

See Also

C1DockingTabPages class


RemoveRange Method

RemoveRange Method

Removes the specified range of elements from the collection.

Syntax

[VB]

Public Overridable Sub RemoveRange(ByVal index As Integer, ByVal count As Integer)

[C#]

public virtual void RemoveRange ( System.Int32 index, System.Int32 count )

[Delphi]

procedure RemoveAt(index: Integer; count: Integer); virtual;

See Also

C1DockingTabPages class


Event Handler Delegates

AutoCreatedDockingTabEventHandler Delegate

BeforeSelectWindowEventHandler Delegate

CheckedChangedEventHandler Delegate

CommandClickEventHandler Delegate

CommandLinkEventHandler Delegate

CommandStateQueryEventHandler Delegate

CustomizeLinkEventHandler Delegate

CustomizeToolBarEventHandler Delegate

DrawArrowEventHandler Delegate

DrawBarEventHandler Delegate

DrawFloatingCaptionEventHandler Delegate

DrawLinkEventHandler Delegate

DrawPageEventHandler Delegate

DrawTabEventHandler Delegate

DropDownEventHandler Delegate

LayoutLinkEventHandler Delegate

MeasureFloatingCaptionEventHandler Delegate

MeasureLinkEventHandler Delegate

MeasurePageEventHandler Delegate

MeasureTabEventHandler Delegate

SelectedIndexChangingEventHandler Delegate

TabPageCancelEventHandler Delegate

TabPageEventHandler Delegate


AutoCreatedDockingTabEventHandler Delegate

AutoCreatedDockingTabEventHandler Delegate

Syntax

[VB]

Public Delegate Sub AutoCreatedDockingTabEventHandler (object sender, AutoCreatedTabEventArgs e)

[C#]

public sealed delegate AutoCreatedDockingTabEventHandler : System.MulticastDelegate

[Delphi]

type AutoCreatedDockingTabEventHandler = procedure(sender: Object, e: AutoCreatedTabEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A AutoCreatedDockingTabEventArgs object that contains the event data.

See Also

AutoCreatedDockingTab Event


BeforeSelectWindowEventHandler Delegate

BeforeSelectWindowEventHandler Delegate

Syntax

[VB]

Public Delegate Sub BeforeSelectWindowEventHandler (object sender, BeforeSelectWindowEventArgs e)

[C#]

public sealed delegate BeforeSelectWindowEventHandler : System.MulticastDelegate

[Delphi]

type BeforeSelectWindowEventHandler = procedure(sender: Object, e: BeforeSelectWindowEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A BeforeSelectWindowEventArgs object that contains the event data.

See Also

BeforeSelectWindow Event


CheckedChangedEventHandler Delegate

CheckedChangedEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CheckedChangedEventHandler (object sender, CheckedChangedEventArgs e)

[C#]

public sealed delegate CheckedChangedEventHandler : System.MulticastDelegate

[Delphi]

type CheckedChangedEventHandler = procedure(sender: Object, e: CheckedChangedEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CheckedChangedEventArgs object that contains the event data.

See Also

CheckedChanged Event (C1Command)


CommandClickEventHandler Delegate

CommandClickEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CommandClickEventHandler (object sender, CommandClickEventArgs e)

[C#]

public sealed delegate CommandClickEventHandler : System.MulticastDelegate

[Delphi]

type CommandClickEventHandler = procedure(sender: Object, e: CommandClickEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CommandClickEventArgs object that contains the event data.

See Also

CommandClick Event


CommandLinkEventHandler Delegate

CommandLinkEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CommandLinkEventHandler (object sender, CommandLinkEventArgs e)

[C#]

public sealed delegate CommandLinkEventHandler : System.MulticastDelegate

[Delphi]

type CommandLinkEventHandler = procedure(sender: Object, e: CommandLinkEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CommandLinkEventArgs object that contains the event data.

See Also

CommandLinkAdded Event (C1Command)

CommandLinkRemoved Event (C1Command)


CommandStateQueryEventHandler Delegate

CommandStateQueryEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CommandStateQueryEventHandler (object sender, CommandStateQueryEventArgs e)

[C#]

public sealed delegate CommandStateQueryEventHandler : System.MulticastDelegate

[Delphi]

type CommandStateQueryEventHandler = procedure(sender: Object, e: CommandStateQueryEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CommandStateQueryEventArgs object that contains the event data.

See Also

CommandStateQuery Event (C1Command)


CustomizeLinkEventHandler Delegate

CustomizeLinkEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CustomizeLinkEventHandler (object sender, CommandStateQueryEventArgs e)

[C#]

public sealed delegate CustomizeLinkEventHandler : System.MulticastDelegate

[Delphi]

type CustomizeLinkEventHandler = procedure(sender: Object, e: CommandStateQueryEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CustomizeLinkEventArgs object that contains the event data.

See Also

CustomizeLinkAdded Event


CustomizeToolBarEventHandler Delegate

CustomizeToolBarEventHandler Delegate

Syntax

[VB]

Public Delegate Sub CustomizeToolBarEventHandler (object sender, CommandStateQueryEventArgs e)

[C#]

public sealed delegate CustomizeToolBarEventHandler : System.MulticastDelegate

[Delphi]

type CustomizeToolBarEventHandler = procedure(sender: Object, e: CommandStateQueryEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A CustomizeToolBarEventArgs object that contains the event data.

See Also

CustomizeToolBarAdded Event


DrawArrowEventHandler Delegate

DrawArrowEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawArrowEventHandler (object sender, DrawArrowEventArgs e)

[C#]

public sealed delegate DrawArrowEventHandler: System.MulticastDelegate

[Delphi]

type DrawArrowEventHandler = procedure(sender: Object, e: DrawArrowEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawArrowEventArgs object that contains the event data.

See Also

DrawArrow Event


DrawBarEventHandler Delegate

DrawBarEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawBarEventHandler (object sender, DrawBarEventArgs e)

[C#]

public sealed delegate DrawBarEventHandler: System.MulticastDelegate

[Delphi]

type DrawBarEventHandler = procedure(sender: Object, e: DrawBarEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawBarEventArgs object that contains the event data.

See Also

DrawBar Event


DrawFloatingCaptionEventHandler Delegate

DrawFloatingCaptionEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawFloatingCaptionEventHandler (object sender, DrawFloatingCaptionEventArgs e)

[C#]

public sealed delegate DrawFloatingCaptionEventHandler: System.MulticastDelegate

[Delphi]

type DrawFloatingCaptionEventHandler = procedure(sender: Object, e: DrawFloatingCaptionEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawFloatingCaptionEventArgs object that contains the event data.

See Also

DrawFloatingCaption Event


DrawLinkEventHandler Delegate

DrawLinkEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawLinkEventHandler (object sender, DrawLinkEventArgs e)

[C#]

public sealed delegate DrawLinkEventHandler: System.MulticastDelegate

[Delphi]

type DrawLinkEventHandler = procedure(sender: Object, e: DrawLinkEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawLinkEventArgs object that contains the event data.

See Also

DrawLink Event


DrawPageEventHandler Delegate

DrawPageEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawPageEventHandler (object sender, DrawPageEventArgs e)

[C#]

public sealed delegate DrawPageEventHandler: System.MulticastDelegate

[Delphi]

type DrawPageEventHandler = procedure(sender: Object, e: DrawPageEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawPageEventArgs object that contains the event data.

See Also

DrawPage Event


DrawTabEventHandler Delegate

DrawTabEventHandler Delegate

Syntax

[VB]

Public Delegate Sub DrawTabEventHandler (object sender, DrawTabEventArgs e)

[C#]

public sealed delegate DrawTabEventHandler: System.MulticastDelegate

[Delphi]

type DrawTabEventHandler = procedure(sender: Object, e: DrawTabEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A DrawTabEventArgs object that contains the event data.

See Also

DrawTab Event


DropDownEventHandler Delegate

DropDownEventHandler Delegate

Syntax

[VB]

Public NotInheritable Delegate DropDownEventHandler

[C#]

public sealed delegate DropDownEventHandler : System.MulticastDelegate

[Delphi]

type DropDownEventHandler = procedure(sender: Object, e: NotInheritable) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A NonInheritable object.


LayoutLinkEventHandler Delegate

LayoutLinkEventHandler Delegate

Syntax

[VB]

Public Delegate Sub LayoutLinkEventHandler (object sender, LayoutLinkEventArgs e)

[C#]

public sealed delegate LayoutLinkEventHandler: System.MulticastDelegate

[Delphi]

type LayoutLinkEventHandler = procedure(sender: Object, e: LayoutLinkEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A LayoutLinkEventArgs object that contains the event data.


MeasureFloatingCaptionEventHandler Delegate

MeasureFloatingCaptionEventHandler Delegate

Syntax

[VB]

Public Delegate Sub MeasureFloatingCaptionEventHandler (object sender, MeasureFloatingCaptionEventArgs e)

[C#]

public sealed delegate MeasureFloatingCaptionEventHandler: System.MulticastDelegate

[Delphi]

type MeasureFloatingCaptionEventHandler = procedure(sender: Object, e: MeasureFloatingCaptionEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A MeasureFloatingCaptionEventArgs object that contains the event data.

See Also

MeasureFloatingCaption Event


MeasureLinkEventHandler Delegate

MeasureLinkEventHandler Delegate

Syntax

[VB]

Public Delegate Sub MeasureLinkEventHandler (object sender, MeasureLinkEventArgs e)

[C#]

public sealed delegate MeasureLinkEventHandler: System.MulticastDelegate

[Delphi]

type MeasureLinkEventHandler = procedure(sender: Object, e: MeasureLinkEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A MeasureLinkEventArgs object that contains the event data.

See Also

MeasureLink Event


MeasurePageEventHandler Delegate

MeasurePageEventHandler Delegate

Syntax

[VB]

Public Delegate Sub MeasurePageEventHandler (object sender, MeasurePageEventArgs e)

[C#]

public sealed delegate MeasurePageEventHandler: System.MulticastDelegate

[Delphi]

type MeasurePageEventHandler = procedure(sender: Object, e: MeasurePageEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A MeasurePageEventArgs object that contains the event data.

See Also

MeasurePage Event


MeasureTabEventHandler Delegate

MeasureTabEventHandler Delegate

Syntax

[VB]

Public Delegate Sub MeasureTabEventHandler (object sender, MeasureTabEventArgs e)

[C#]

public sealed delegate MeasureTabEventHandler: System.MulticastDelegate

[Delphi]

type MeasureTabEventHandler = procedure(sender: Object, e: MeasureTabEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A MeasureTabEventArgs object that contains the event data.

See Also

MeasureTab Event


SelectedIndexChangingEventHandler Delegate

SelectedIndexChangingEventHandler Delegate

Syntax

[VB]

Public Delegate Sub SelectedIndexChangingEventHandler (object sender, SelectedIndexChangingEventArgs e)

[C#]

public sealed delegate SelectedIndexChangingEventHandler: System.MulticastDelegate

[Delphi]

type SelectedIndexChangingEventHandler = procedure(sender: Object, e: SelectedIndexChangingEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A SelectedIndexChangingEventArgs object that contains the event data.

See Also

SelectedIndexChanging Event (C1OutBar).


TabPageCancelEventHandler Delegate

TabPageCancelEventHandler Delegate

Syntax

[VB]

Public Delegate Sub TabPageCancelEventHandler (object sender, TabPageCancelEventArgs e)

[C#]

public sealed delegate TabPageCancelEventHandler: System.MulticastDelegate

[Delphi]

type TabPageCancelEventHandler = procedure(sender: Object, e: TabPageCancelEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A TabPageCancelEventArgs object that contains the event data.


TabPageEventHandler Delegate

TabPageEventHandler Delegate

Syntax

[VB]

Public Delegate Sub TabPageEventHandler (object sender, TabPageEventArgs e)

[C#]

public sealed delegate TabPageEventHandler: System.MulticastDelegate

[Delphi]

type TabPageEventHandler = procedure(sender: Object, e: TabPageEventArgs) of object;

Arguments

Argument | Description
sender | The source of the event.
e | A TabPageEventArgs object that contains the event data.


Helper classes

ContextInfo Class


ContextInfo Class

This class is passed as a member of the click event arguments for clicks originating in a context menu. It contains information about the context when the menu was shown.

Syntax

[VB]

Public Class ContextInfo

[C#]

public class ContextInfo : System.Object

[Delphi]

type ContextInfo: class;

Members

Public Dim Source As System.Windows.Forms.Control

Public Dim Location As System.Drawing.Point

Member | Description
Source | Returns the control where the context menu was shown.
Location | Return the location inside the Source control where the context menu was shown.


Event Argument Classes

AutoCreatedDockingTabEventArgs class

BeforeSelectWindowEventArgs class

CheckedChangedEventArgs class

ClickEventArgs class

CommandClickEventArgs class

CommandLinkEventArgs class

CommandStateQueryEventArgs class

CustomizeLinkEventArgs class

CustomizeToolBarEventArgs class

DrawBarEventArgs class

DrawFloatingCaptionEventArgs class

DrawLinkEventArgs

DrawPageEventArgs class

DrawTabEventArgs class

DropDownEventArgs class

LayoutLinkEventArgs class

MeasureFloatingCaptionEventArgs class

MeasureLinkEventArgs class

MeasurePageEventArgs class

MeasureTabEventArgs class

SelectedIndexChangingEventArgs class

TabPageCancelEventArgs class

TabPageEventArgs class


AutoCreatedDockingTabEventArgs class

AutoCreatedDockingTabEventArgs class

Syntax

[VB]

Public Class AutoCreatedDockingTabEventArgs

[C#]

public class AutoCreatedDockingTabEventArgs : EventArgs

[Delphi]

type AutoCreatedDockingTabEventArgs: class(EventArgs);

Members

Public Const NewDockingTab As C1.Win.C1Command.C1DockingTab

Member | Description
NewDockingTab | Gets the new DockingTab.

See Also

AutoCreatedDockingTabEventHandler Delegate


BeforeSelectWindowEventArgs class

BeforeSelectWindowEventArgs class

Syntax

[VB]

Public Class BeforeSelectWindowEventArgs

[C#]

public class BeforeSelectWindowEventArgs : EventArgs

[Delphi]

type BeforeSelectWindowEventArgs: class(EventArgs);

Members

Public Const SelectWindowForm As System.Windows.Forms.Form

Member | Description
SelectWindowForm | The window or dialog box selected.

See Also

BeforeSelectWindowEventHandler Delegate


CheckedChangedEventArgs class

CheckedChangedEventArgs class

Syntax

[VB]

Public Class CheckedChangedEventArgs

[C#]

public class CheckedChangedEventArgs : EventArgs

[Delphi]

type CheckedChangedEventArgs: class(EventArgs);

Members

Public Const NewValue As Boolean

Member | Description
NewValue | Boolean

See Also

CheckedChangedEventHandler Delegate


ClickEventArgs class

ClickEventArgs class

Syntax

[VB]

Public Class ClickEventArgs

[C#]

public class ClickEventArgs : EventArgs

[Delphi]

type ClickEventArgs: class(EventArgs);

Members

Public Dim ClickSource As C1.Win.C1Command.ClickSourceEnum

Public Dim CommandLink As C1.Win.C1Command.C1CommandLink

Public Dim ContextInfo As C1.Win.C1Command.ContextInfo

Member | Description
ClickSource | Determines whether the click event was caused by a menu selection, shortcut key, or other means.
CommandLink | Gets the command link which caused the click event to occur. May be null in some cases (e.g., if the click was caused by a shortcut key).
ContextInfo | Gets the context info for clicks which originated in a context menu. Null otherwise.

See Also

BeforeSelectWindowEventHandler Delegate


CommandClickEventArgs class

CommandClickEventArgs class

Syntax

[VB]

Public Class CommandClickEventArgs

[C#]

public class CommandClickEventArgs : ClickEventArgs

[Delphi]

type CommandClickEventArgs: class(EventArgs);

Members

Public Const Command As C1.Win.C1Command.C1Command

Public Const Empty As C1.Win.C1Command.CommandClickEventArgs

Member | Description
ClickSource | Determines what caused the click event to occur.
CallerLink | Gets the command link which was clicked by the user.
ContextInfo | Gets the context info for events fired from a context menu.
Command | The command invoked by the user.

See Also

CommandClickEventHandler Delegate


CommandLinkEventArgs class

CommandLinkEventArgs class

Syntax

[VB]

Public Class CommandLinkEventArgs

[C#]

public class CommandLinkEventArgs : EventArgs

[Delphi]

type CommandLinkEventArgs: class(EventArgs);

Members

Public Dim CommandLink As C1.Win.C1Command.C1CommandLink

Member | Description
CommandLink | Gets the command link.

See Also

CommandLinkEventHandler Delegate


CommandStateQueryEventArgs class

CommandStateQueryEventArgs class

Syntax

[VB]

Public Class CommandStateQueryEventArgs

[C#]

public class CommandStateQueryEventArgs : EventArgs

[Delphi]

type CommandStateQueryEventArgs: class(EventArgs);

Members

Public Dim Checked As Boolean

Public Dim Enabled As Boolean

Public Dim Pressed As Boolean

Public Dim Visible As Boolean

Member | Description
Checked | Determines whether the command is checked.
Enabled | Determines whether the command is enabled.
Pressed | Determines whether the command is pressed.
Visible | Determines whether the command is visible.

See Also

CommandStateQueryEventHandler Delegate


CustomizeLinkEventArgs class

CustomizeLinkEventArgs class

Syntax

[VB]

Public Class CustomizeLinkEventArgs

[C#]

public class CustomizeLinkEventArgs : EventArgs

[Delphi]

type CustomizeLinkEventArgs: class(EventArgs);

Members

Public Const CommandLink As C1.Win.C1Command.C1CommandLink

Public Const ToolBar As C1.Win.C1Command.C1ToolBar

Member | Description
CommandLink | Gets the command link.
ToolBar | Gets the tool bar for the command link.

See Also

CustomizeToolBarEventHandler Delegate


CustomizeToolBarEventArgs class

CustomizeToolBarEventArgs class

Syntax

[VB]

Public Class CustomizeToolBarEventArgs

[C#]

public class CustomizeToolBarEventArgs : EventArgs

[Delphi]

type CustomizeToolBarEventArgs: class(EventArgs);

Members

Public Const ToolBar As C1.Win.C1Command.C1ToolBar

Member | Description
ToolBar | Gets the tool bar.

See Also

CustomizeToolBarEventHandler Delegate


DrawBarEventArgs class

DrawBarEventArgs class

Syntax

[VB]

Public Class DrawBarEventArgs

[C#]

public class DrawBarEventArgs : EventArgs

[Delphi]

type DrawBarEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Bounds As Rectangle

Public Dim Path As GraphicPath

Public Dim Done As Boolean

Member | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the bar (menu or toolbar).
Path | The graphcs path bounding the bar (menu or toolbar).
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

DrawBarEventHandler Delegate


DrawFloatingCaptionEventArgs class

DrawFloatingCaptionEventArgs class

Syntax

[VB]

Public Class DrawFloatingCaptionEventArgs

[C#]

public class DrawFloatingCaptionEventArgs : EventArgs

[Delphi]

type DrawFloatingCaptionEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Bounds As Rectangle

Public Dim Done As Boolean

Member | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the floating caption.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

DrawFloatingCaptionEventHandler Delegate


DrawLinkEventArgs

DrawLinkEventArgs

Syntax

[VB]

Public Class DrawLinkEventArgs

[C#]

public class DrawLinkEventArgs : EventArgs

[Delphi]

type DrawLinkEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Bounds As Rectangle

Public Dim Link As C1CommandLink

Public Dim Done As Boolean

Member | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the link.
Link | The command link to draw.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

DrawLinkEventHandler Delegate


DrawPageEventArgs class

DrawPageEventArgs class

Syntax

[VB]

Public Class DrawPageEventArgs

[C#]

public class DrawPageEventArgs : EventArgs

[Delphi]

type DrawPageEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Bounds As Rectangle

Public Dim Page As C1OutPage

Public Dim Done As Boolean

Member | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the page.
Page | The page to draw.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

DrawPageEventHandler Delegate


DrawTabEventArgs class

DrawTabEventArgs class

Syntax

[VB]

Public Class DrawTabEventArgs

[C#]

public class DrawTabEventArgs : EventArgs

[Delphi]

type DrawTabEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Bounds As Rectangle

Public Dim Page As C1DockingTabPage

Public Dim Done As Boolean

Member | Description
Graphics | The Graphics object to draw on.
Bounds | The bounding rectangle of the tab.
Page | The tab page to draw.
Done | Flag indicating whether the user completed the drawing. If set to true, no further drawing is performed. Otherwise, the default drawing is done.

See Also

DrawTabEventHandler Delegate


DropDownEventArgs class

DropDownEventArgs class

Syntax

[VB]

Public Class DropDownEventArgs

[C#]

public class DropDownEventArgs : EventArgs

[Delphi]

type DropDownEventArgs: class(EventArgs);

Members

Public Const CallerLink As C1.Win.C1Command.C1CommandLink

Public Const LinkRect As System.Drawing.Rectangle

Member | Description
CallerLink | Gets the command link which was clicked by the user.
LinkRect |

See Also

DropDownEventHandler Delegate


LayoutLinkEventArgs class

LayoutLinkEventArgs class

Syntax

[VB]

Public Class LayoutLinkEventArgs

[C#]

public class LayoutLinkEventArgs: EventArgs

[Delphi]

type LayoutLinkEventArgs: class(EventArgs);

Members

Public Dim Bounds As System.Drawing.Rectangle

Public Dim ControlLocation As System.Drawing.Point

Public Dim ImageRect As System.Drawing.Rectangle

Public Dim Link As C1.Win.C1Command.C1CommandLink

Public Dim TextRect As System.Drawing.Rectangle

Member | Description
Bounds | The bounding rectangle of the command link.
ControlLocation | The location of the nested control (valid only if the command is a C1CommandControl).
ImageRect | Image rectangle layout.
LInk | Specifies the command link for the layout.
TextRect | Text rectangle layout.

See Also

LayoutLinkEventHandler Delegate


MeasureFloatingCaptionEventArgs class

MeasureFloatingCaptionEventArgs class

Syntax

[VB]

Public Class MeasureFloatingCaptionEventArgs

[C#]

public class MeasureFloatingCaptionEventArgs: EventArgs

[Delphi]

type MeasureFloatingCaptionEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Height As Integer

Member | Description
Graphics | The Graphics object to use for measuring.
Height | The height of the floating caption.

See Also

MeasureFloatingCaptionEventHandler Delegate


MeasureLinkEventArgs class

MeasureLinkEventArgs class

Syntax

[VB]

Public Class MeasureLinkEventArgs

[C#]

public class MeasureLinkEventArgs: EventArgs

[Delphi]

type MeasureLinkEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Link As C1CommandLink

Public Dim Width As Integer

Public Dim Height As Integer

Member | Description
Graphics | Specifies the Graphics object to use for measuring.
Link | Specifies the link that needs to be measured.
Width | Specifies the width of the link.
Height | Specifies the height of the link.

See Also

MeasureLinkEventHandler Delegate


MeasurePageEventArgs class

MeasurePageEventArgs class

Syntax

[VB]

Public Class MeasurePageEventArgs

[C#]

public class MeasurePageEventArgs: EventArgs

[Delphi]

type MeasurePageEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Page As C1OutPage

Public Dim Height As Integer

Member | Description
Graphics | Specifies the Graphics object to use for measuring.
Page | The C1OutPage object to measure.
Height | The height of the page caption.

See Also

MeasurePageEventHandler Delegate


MeasureTabEventArgs class

MeasureTabEventArgs class

Syntax

[VB]

Public Class MeasureTabEventArgs

[C#]

public class MeasureTabEventArgs: EventArgs

[Delphi]

type MeasureTabEventArgs: class(EventArgs);

Members

Public Dim Graphics As Graphics

Public Dim Page As C1DockingTabPage

Public Dim Width As Integer

Member | Description
Graphics | Specifies the Graphics object to use for measuring.
Page | The C1OutPage object to measure.
Width | The width of the tab

See Also

MeasureTabEventHandler Delegate


SelectedIndexChangingEventArgs class

SelectedIndexChangingEventArgs class

Syntax

[VB]

Public Class SelectedIndexChangingEventArgs

[C#]

public class SelectedIndexChangingEventArgs: EventArgs

[Delphi]

type SelectedIndexChangingEventArgs: class(EventArgs);

Members

Public Dim NewIndex As Integer

Public Dim CanCancel As Boolean

Member | Description
NewIndex | Indicates the new index of the selected tab page.
CanCancel | Indicates whether the change of the selected index can be cancelled by the event handler. In some situations, this is not allowed - e.g. when the C1DockingTab control is in the "sliding out" mode, there is a selected page, and the control is being resized (in that case, the selected page is hidden, so the selected index is changed to -1).

See Also

SelectedIndexChangingEventHandler Delegate


TabPageCancelEventArgs class

TabPageCancelEventArgs class

Syntax

[VB]

Public Class TabPageCancelEventArgs

[C#]

public class TabPageCancelEventArgs: EventArgs

[Delphi]

type TabPageCancelEventArgs: class(EventArgs);

Members

Public Dim TabPage As C1DockingTabPage

Member | Description
TabPage | Indicates the tab page.

See Also

TabPageCancelEventHandler Delegate


TabPageEventArgs class

TabPageEventArgs class

Syntax

[VB]

Public Class TabPageEventArgs

[C#]

public class TabPageEventArgs: EventArgs

[Delphi]

type TabPageEventArgs: class(EventArgs);

Members

Public Dim TabPage As C1DockingTabPage

Member | Description
TabPage | Indicates the tab page.

See Also

TabPageEventHandler Delegate


Enumerations

BorderStyleEnum Enumeration

ButtonLookFlags Enumeration

ButtonLayoutEnum Enumeration

ClickSourceEnum Enumeration

CustomizeOptionsFlags Enumeration

HotFrameEnum Enumeration

ItemStateEnum Enumeration

LargeMenuDisplayEnum Enumeration

LookAndFeelEnum Enumeration

OutlineModeEnum Enumeration

TabTextDirectionEnum Enumeration

TabSizeModeEnum Enumeration

TabStyleEnum Enumeration

ToolBarStyleEnum Enumeration

UIStringsEnum Enumeration


BorderStyleEnum Enumeration

BorderStyleEnum Enumeration

Syntax

[VB]

Public enum BorderStyleEnum

[C#]

public sealed enum BorderStyleEnum : Enum

[Delphi]

type BorderStyleEnum = (Flat, Groove, Inset, None, Outset, Ridge);

Remarks

Use members of this enumeration to set the value of the Style property of the C1Border class.

Member Name | Description
Flat | Flat border
Groove | Grooved border
Inset | Inset border
None | No border
Outset | Outset border
Ridge | Ridged border


ButtonLookFlags Enumeration

ButtonLookFlags Enumeration

Syntax

[VB]

Public enum ButtonLookFlags

[C#]

public sealed enum ButtonLookFlags : Enum

[Delphi]

type ButtonLookFlags = (Default, Text, Image, TextAndImage);

Remarks

The members of this enumeration can be combined using the bitwise OR operation. Use the members of this enumeration to set the values of ButtonLook, ButtonLookHorz, and ButtonLookVert properties of the C1CommandLink class.

Member Name | Description
Default | Use the default value for the toolbar.
Text | Show button text.
Image | Show button image.
TextAndImage | Show button text and image.


ButtonLayoutEnum Enumeration

ButtonLayoutEnum Enumeration

Syntax

[VB]

Public enum ButtonLayoutEnum

[C#]

public sealed enum ButtonLayoutEnum : Enum

[Delphi]

type ButtonLayoutEnum = (TextOnRight, TextOnLeft, TextBelow, TextAbove);

Remarks

Use members of this enumeration to set the ButtonLayoutHorzand ButtonLayoutVert properties of the C1Toolbar class.

Member Name | Description
TextOnRight | Text is on the right of the image.
TextOnLeft | Text is on the left of the image.
TextBelow | Text is below the image.
TextAbove | Text is above the image.


ClickSourceEnum Enumeration

ClickSourceEnum Enumeration

Syntax

[VB]

Public enum ClickSourceEnum

[C#]

public sealed enum ClickSourceEnum : Enum

[Delphi]

type ClickSourceEnum = (None, Menu, Shortcut, External);

Remarks

Members of this enumeration are used to determine the value of the ClickSource property in the ClickEventArgs class.

Member Name | Description
None | Click source undefined.
Menu | Click source is a menu.
Shortcut | Click source is a shortcut key.
External | Click source is external.


CustomizeOptionsFlags Enumeration

CustomizeOptionsFlags Enumeration

Syntax

[VB]

Public Enum CustomizeOptionsFlags

[C#]

public sealed enum CustomizeOptionsFlags: Enum

[Delphi]

type CustomizeOptionsFlags = (AllowNone, AllowDelete, AllowAddItem, AllowRemoveItem, AllowAll);

Remarks

Use the members of this enumeration to set the value of the CustomizeOptions property in the C1ToolBar class.

Member Name | Description
AllowNone | No options.
AllowDelete | Options can be deleted.
AllowAddItem | Item can be added.
AllowRemoveItem | Item can be removed.
AllowAll | AllowDelete, AllowAddItem, AllowRemoveItem.


HotFrameEnum Enumeration

HotFrameEnum Enumeration

Syntax

[VB]

Public Enum HotFrame

[C#]

public sealed enum HotFrame: Enum

[Delphi]

type HotFrame = (Full, Control, None);

Remarks

Use the members of this enumeration to set the value of the HotFrame property in the C1CommandControl class.

Member Name | Description
Full | The frame encloses the whole link.
Control | The frame encloses just the control.
None | Hot frame/selection is not drawn.


ItemStateEnum Enumeration

ItemStateEnum Enumeration

Syntax

[VB]

public enum ItemStateEnum

[C#]

public sealed enum ItemStateEnum : Enum

[Delphi]

type ItemStateEnum = (Hot, Normal, Open, Pressed);

Remarks

Use the members of this enumeration to set the value of the State property in the C1CommandLink class.

Member Name | Description
Hot | Specifies an item in that is currently under the mouse.
Normal | Specifies an item in the default state.
Open | Specifies an open item (an item with a submenu open).
Pressed | Specifies an item that is currently pressed down.


LargeMenuDisplayEnum Enumeration

LargeMenuDisplayEnum Enumeration

Syntax

[VB]

Public enum LargeMenuDisplayEnum

[C#]

public sealed enum LargeMenuDisplayEnum : Enum

[Delphi]

type LargeMenuDisplayEnum = (Scroll, Wrap);

Remarks

Use the members of this enumeration to set the value of the LargeMenuDisplay property in the C1CommandMenu class.

Member Name | Description
Scroll | When a menu does not fit on the screen, it is scrolled.
Wrap | When a menu does not fit on the screen, it is wrapped.


LookAndFeelEnum Enumeration

LookAndFeelEnum Enumeration

Syntax

[VB]

Public enum LookAndFeelEnum

[C#]

public sealed enum LookAndFeelEnum : Enum

[Delphi]

type LookAndFeelEnum = (OfficeXP, Classic, WindowsXP, Office2003);

Remarks

Use the members of this enumeration to set the value of the LookAndFeel properties in the C1CommandHolder and C1OutBar classes.

Member Name | Description
OfficeXP | Office XP look and feel.
Classic | Classic look and feel.
WindowsXP | Windows XP look and feel.
Office2003 | Office 2003 look and feel.


OutlineModeEnum Enumeration

OutlineModeEnum Enumeration

Syntax

[VB]

Public enum OutlineModeEnum

[C#]

public sealed enum OutlineModeEnum : System.Enum

[Delphi]

type OutlineModeEnum = (Transparent, Reversible);

Remarks

Use the members of this enumeration to set the value of the OutlineMode property in the C1DockingTab class, which determines how the outline is displayed when a C1DockingTab control is moved across the screen.

Member Name | Description
Transparent | Draws the outline with a checkered pattern of black and transparent pixels.
Reversible | Draws a reversible line with a complimentary color.


TabTextDirectionEnum Enumeration

TabTextDirectionEnum Enumeration

Specifies the direction of the text drawn on the tab control’s tabs.

Syntax

[VB]

Public enum TabTextDirectionEnum

[C#]

public sealed enum TabTextDirectionEnum: Enum

[Delphi]

type TabTextDirectionEnum = (Default, Horizontal, VerticalLeft, VerticalRight);

Remarks

Use the members of this enumeration to set the value of the TabTextDirection property in the C1DockingTab class.

Member Name | Description
Default | The default direction: Horizontal for tabs on the top or bottom, VerticalLeft for tabs on the left, VerticalRight for tabs on the right.
Horizontal | Text is drawn horizontally.
VerticalLeft | Text is drawn vertically, turned 90 degrees counter-clockwise.
VerticalRight | Text is drawn vertically, turned 90 degrees clockwise.


TabSizeModeEnum Enumeration

TabSizeModeEnum Enumeration

Specifies the mode used to size the tabs of the tab control.

Syntax

[VB]

Public enum TabSizeModeEnum

[C#]

public sealed enum TabSizeModeEnum: Enum

[Delphi]

type TabSizeModeEnum = (Normal, Fit, FillToEnd, User);

Remarks

Use the members of this enumeration to set the value of the TabSizeMode property in the C1DockingTab class.

Member Name | Description
Normal | The default sizing mode.
Fit | All tabs are squeezed to fit into the width of the tab control.
FillToEnd | Tabs are stretched to take the whole width of the tab control.
User | The user can specify the tab size in the MeasureTab event.


TabStyleEnum Enumeration

TabStyleEnum Enumeration

Specifies the look of the tabs of the tab control.

Syntax

[VB]

Public enum TabStyleEnum

[C#]

public sealed enum TabStyleEnum: Enum

[Delphi]

type TabStyleEnum = (Default, WindowsXP, Classic);

Remarks

Use the members of this enumeration to set the value of the TabStyle property in the C1DockingTab class.

Member Name | Description
Default | The default tab style.
WindowsXP | Windows XP look.
Classic | Classic look.


ToolBarStyleEnum Enumeration

ToolBarStyleEnum Enumeration

Syntax

[VB]

Public Enum ToolBarStyleEnum

[C#]

public sealed enum ToolBarStyleEnum : Enum

[Delphi]

type ToolBarStyleEnum = (Default, DropDownMenu);

Remarks

Use the members of this enumeration to set the value of the ToolBarStyle property in the C1ToolBar class.

Member Name | Description
Default | Specifies an item in the default state.
DropDownMenu | Specifies an item in the DropDownMenu.


UIStringsEnum Enumeration

UIStringsEnum Enumeration

Syntax

[VB]

Public enum UIStringsEnum

[C#]

public sealed enum UIStringsEnum : Enum

[Delphi]

type UIStringsEnum = (CustomizeAddRemoveItems, CustomizeCustomize, CustomizeDeleteToolbarFmt, CustomizeStatusDone, CustomizeStatusResetting, CustomizeReset, CustomizeToolbarOptions, More, MoreMdiChildren);

Remarks

Elements of this enumeration can be used to index individual strings in the UIStrings array of customizable user interface strings. The C1DockingTab tooltip strings can be set of the C1DockingTab ifself. But, if your form contains a CommandHolder, the tooltips can be set on that instead by using its UIStrings property then they will affect all C1DockingTab controls found on the form unless they were changed there. For details, see the UIStrings property of the C1CommandHolder class. Use the members of this enumeration to set the value of the UIStrings in the C1CommandHolder class.

Member Name | Description
More | Text of the "More..." command.
CustomizeToolbarOptions | Text of the "Toolbar Options" command.
CustomizeAddRemoveItems | Text of the "Add or Remove Buttons" command.
CustomizeDeleteToolbarFmt | The default is 'Do you really want to delete toolbar "{0}"?'Allows to translate/customize the "confirm toolbar delete" question in the customizer.
CustomizeReset | Text of the "Reset" command.
CustomizeStatusDone | Allows to translate/customize the status strings in the customizer.
CustomizeStatusResetting | Allows to translate/customize the status strings in the customizer.
CustomizeStatusRestoring | Allows to translate/customize the status strings in the customizer.
CustomizeStatusSaving | Allows to translate/customize the status strings in the customizer.
CustomizeCustomize | Text of the "Customize..." command.
DockingTabCloseTooltip | Tooltip for the close C1DockingTab button.
DockingTabPinTooltip | Tooltip for the auto hide C1DockingTab button.
DockingTabScrollNextTooltip | Tooltip for the scroll right C1DockingTab button.
DockingTabScrollPrevTooltip | Tooltip for the scroll left C1DockingTab button.
MoreMdiChildren | Text of the "More &Windows..." menu item created by C1CommandMdiList.


C1Command Declare Objects - C#

C#

// Define a new object of your C1ToolBar class type.

MyToolBar as C1ToolBar;

// Define a new C1Command.C1ToolBar object.

c1TBar as C1.Win.C1Command.C1ToolBar;


C1Command Declare Objects - Delphi

Delphi

// Define a new object based of C1ToolBar class type.

MyToolBar: C1ToolBar;

// Define a new C1Command.C1ToolBar object.;

c1Tbar: C1.Win.C1Command.C1ToolBar;


C1Command Declare Objects - Visual Basic

Visual Basic

' Define a new object of your C1ToolBar class type.

Dim MyToolBar as C1ToolBar

' Define a new C1Command.C1ToolBar object.

Dim c1TBar as C1.Win.C1Command.C1ToolBar


C1Command Import - C#

C#

using C1ToolBar = C1.Win.C1Command.C1ToolBar;

using MyToolBar = MyProject.Objects.C1ToolBar;

C1ToolBar tb1;

MyToolBar tb2;


C1Command Import - Delphi

Delphi

C1ToolBar := C1.Win.C1Command.C1ToolBar;

MyToolBar := MyProject.Objects.C1ToolBar;

tb1: C1ToolBar;

tb2: MyToolBar;


C1Command Import - Visual Basic

Visual Basic

Imports C1ToolBar = C1.Win.C1Command.C1ToolBar

Imports MyToolBar = MyProject.Objects.C1ToolBar

Dim tb1 As C1ToolBar

Dim tb2 As MyToolBar


C1Command Namespace - C#

C#

C1.Win.C1Command.C1MainMenu mainMenu;


C1Command Namespace - Delphi

Delphi

mainMenu: C1.Win.C1Command.C1MainMenu;


C1Command Namespace - Visual Basic

Visual Basic

Dim mainMenu As C1.Win.C1Command.C1MainMenu


Displaying a Dialog Form - C#

C#

using C1.Win.C1Command;

...

C1CommandHolder.UninstallMessageFilter();

C1CommandMsgHook hook = new C1CommandMsgHook();

hook.Install();

try

{

result = dialog.ShowDialog();

}

finally

{

hook.Uninstall();

}


Displaying a Dialog Form - Delphi

Delphi

uses C1.Win.C1Command;

var

hook: C1CommandMsgHook;

begin

C1CommandHolder.UninstallMessageFilter;

//Create the C1CommandMsgHook

hook := C1CommandMsgHook.Create;

hook.Install;

try

Result := dialog.ShowDialog;

finally

hook.Uninstall;

end;

end;


Displaying a Dialog Form - Visual Basic

Visual Basic

Imports C1.Win.C1Command;

C1CommandHolder.UninstallMessageFilter()

'Create the C1CommandMsgHook

Dim hook As New C1CommandMsgHook()

hook.Install()

Try

result = dialog.ShowDialog()

Finally

Hook.Uninstall();

End Try


Untitled Document

Send feedback to ComponentOne
Copyright © 1987-2005 ComponentOne LLC. All rights reserved.


TBH Adding a C1MainMenu1 Step 1 - C#

C#

using C1.Win.C1Command;


TBH Adding a C1MainMenu1 Step 1 - Delphi

Delphi

uses C1.Win.C1Command;


TBH Adding a C1MainMenu1 Step 1 - Visual Basic

Visual Basic

Imports C1.Win.C1Command


TBH Adding a C1MainMenu1 Step 2 - C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);


TBH Adding a C1MainMenu1 Step 2 - Delphi

Delphi

var

ch: C1CommandHolder;

begin

ch := C1CommandHolder.CreateCommandHolder(Self);

end;


TBH Adding a C1MainMenu1 Step 2 - Visual Basic

Visual Basic

Dim ch As C1CommandHolder = C1CommandHolder.CreateCommandHolder(Me)


TBH Adding a C1MainMenu1 Step 3 - C#

C#

C1MainMenu mm = new C1MainMenu();


TBH Adding a C1MainMenu1 Step 3 - Delphi

Delphi

var

mm: C1MainMenu;

begin

mm := C1MainMenu.Create;

end;


TBH Adding a C1MainMenu1 Step 3 - Visual Basic

Visual Basic

Dim mm As New C1MainMenu


TBH Adding a C1MainMenu1 Step 4 - C#

C#

this.Controls.Add(mm);


TBH Adding a C1MainMenu1 Step 4 - Delphi

Delphi

Self.Controls.Add(mm);


TBH Adding a C1MainMenu1 Step 4 - Visual Basic

Visual Basic

Me.Controls.Add(mm)


TBH Adding a C1MainMenu1 Step 5 - C#

C#

C1CommandMenu mmenu = ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding a C1MainMenu1 Step 5 - Delphi

Delphi

mmenu := ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding a C1MainMenu1 Step 5 - Visual Basic

Visual Basic

Dim mmenu As C1CommandMenu = CType(ch.CreateCommand(GetType(C1CommandMenu)), C1CommandMenu)


TBH Adding a C1MainMenu1 Step 6 - C#

C#

mmenu.Text = "&menu1";


TBH Adding a C1MainMenu1 Step 6 - Delphi

Delphi

mmenu.Text := '&menu1';


TBH Adding a C1MainMenu1 Step 6 - Visual Basic

Visual Basic

mmenu.Text = "&menu1"


TBH Adding a C1MainMenu1 Step 7 - C#

C#

mm.CommandLinks.Add(new C1CommandLink(mmenu));


TBH Adding a C1MainMenu1 Step 7 - Delphi

Delphi

mm.CommandLinks.Add(C1CommandLink.Create(mmenu));


TBH Adding a C1MainMenu1 Step 7 - Visual Basic

Visual Basic

mm.CommandLinks.Add(New C1CommandLink(mmenu))


TBH Adding a C1OutBar Step1 - C#

C#

using C1.Win.C1Command;


TBH Adding a C1OutBar Step1 - Delphi

Delphi

uses C1.Win.C1Command;


TBH Adding a C1OutBar Step1 - Visual Basic

Visual Basic

Imports C1.Win.C1Command


TBH Adding a C1OutBar Step2 - C#

C#

C1.Win.C1Command.C1OutPage outpage1 = new C1.Win.C1Command.C1OutPage();

outpage1.Text = "New Page";

this.c1OutBar1.Pages.Add(outpage1);


TBH Adding a C1OutBar Step2 - Delphi

Delphi

var

outpage1 : C1.Win.C1Command.C1OutPage;

begin

outpage1 := C1OutPage.Create;

outpage1.Text := 'New Page';

Self.c1OutBar1.Pages.Add(outpage1);

end


TBH Adding a C1OutBar Step2 - Visual Basic

Visual Basic

Dim outpage1 As New C1.Win.C1Command.C1OutPage()

Outpage1.Text = "New Page"

Me.c1OutBar1.Pages.Add(outpage1)


TBH Adding a Child Item Step1 - C#

C#

using C1.Win.C1Command;


TBH Adding a Child Item Step1 - Delphi

Delphi

uses C1.Win.C1Command;


TBH Adding a Child Item Step1 - Visual Basic

Visual Basic

Imports C1.Win.C1Command


TBH Adding a Child Item Step2 - C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);


TBH Adding a Child Item Step2 - Delphi

Delphi

var

ch: C1CommandHolder;

begin

ch := C1CommandHolder.CreateCommandHolder(Self);

end;


TBH Adding a Child Item Step2 - Visual Basic

Visual Basic

Dim ch As C1CommandHolder = C1CommandHolder.CreateCommandHolder(Me)


TBH Adding a Child Item Step3 - C#

C#

C1MainMenu mm = new C1MainMenu();


TBH Adding a Child Item Step3 - Delphi

Delphi

var

mm: C1MainMenu;

begin

mm := C1MainMenu.Create;

end;


TBH Adding a Child Item Step3 - Visual Basic

Visual Basic

Dim mm As New C1MainMenu


TBH Adding a Child Item Step4 - C#

C#

this.Controls.Add(mm);


TBH Adding a Child Item Step4 - Delphi

Delphi

Self.Controls.Add(mm);


TBH Adding a Child Item Step4 - Visual Basic

Visual Basic

Me.Controls.Add(mm)


TBH Adding a Child Item Step5 - C#

C#

C1CommandMenu mmenu = ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding a Child Item Step5 - Delphi

Delphi

mmenu := ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding a Child Item Step5 - Visual Basic

Visual Basic

Dim mmenu As C1CommandMenu = CType(ch.CreateCommand(GetType(C1CommandMenu)), C1CommandMenu)


TBH Adding a Child Item Step6 - C#

C#

mmenu.Text = "&Menu 1";


TBH Adding a Child Item Step6 - Delphi

Delphi

mmenu.Text := '&Menu 1';


TBH Adding a Child Item Step6 - Visual Basic

Visual Basic

mmenu.Text = "&Menu 1"


TBH Adding a Child Item Step7 - C#

C#

mm.CommandLinks.Add(new C1CommandLink(mmenu));


TBH Adding a Child Item Step7 - Delphi

Delphi

mm.CommandLinks.Add(C1CommandLink.Create(mmenu));


TBH Adding a Child Item Step7 - Visual Basic

Visual Basic

mm.CommandLinks.Add(New C1CommandLink(mmenu))


TBH Adding a Child Item Step8 - C#

C#

C1Command submenu = ch.CreateCommand();


TBH Adding a Child Item Step8 - Delphi

Delphi

var

submenu := C1Command;

begin

submenu := ch.Createcommand;

end;


TBH Adding a Child Item Step8 - Visual Basic

Visual Basic

Dim submenu As C1Command = ch.CreateCommand()


TBH Adding a Child Item Step9 - C#

C#

submenu.Text = "submenu 1";

//add a new c1commandlink to the submenu item

mmenu.CommandLinks.Add(new C1CommandLink(submenu));


TBH Adding a Child Item Step9 - Delphi

Delphi

submenu.Text := 'submenu 1';

//add a new c1commandlink to the submenu item

mmenu.CommandLinks.Add(C1CommandLink.Create(submenu));


TBH Adding a Child Item Step9 - Visual Basic

Visual Basic

submenu.Text = "submmenu1"

'add a new c1commandlink to the submenu item

mmenu.CommandLinks.Add(New C1CommandLink(submenu))


TBH Adding an Image to your Toolbar Button - C#

C#

cNew.Image = System.Drawing.Image.FromFile("C:\\bitmap\\New.bmp");


TBH Adding an Image to your Toolbar Button - Delphi

Delphi

cNew.Image := System.Drawing.Image.FromFile('C:\bitmap\New.bmp');


TBH Adding an Image to your Toolbar Button - Visual Basic

Visual Basic

cNew.Image = System.Drawing.Image.FromFile("C:\bitmap\New.bmp")


TBH Adding Multiple Submenus Step1 - C#

C#

using C1.Win.C1Command;


TBH Adding Multiple Submenus Step1 - Delphi

Delphi

uses C1.Win.C1Command;


TBH Adding Multiple Submenus Step1 - Visual Basic

Visual Basic

Imports C1.Win.C1Command


TBH Adding Multiple Submenus Step2 - C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);


TBH Adding Multiple Submenus Step2 - Delphi

Delphi

var

ch: C1CommandHolder;

begin

ch := C1CommandHolder.CreateCommandHolder(Self);

end;


TBH Adding Multiple Submenus Step2 - Visual Basic

Visual Basic

Dim ch As C1CommandHolder = C1CommandHolder.CreateCommandHolder(Me)


TBH Adding Multiple Submenus Step3- C#

C#

C1MainMenu mm = new C1MainMenu();


TBH Adding Multiple Submenus Step3 - Delphi

Delphi

var

mm: C1MainMenu;

begin

mm := C1MainMenu.Create;

end;


TBH Adding Multiple Submenus Step3- Visual Basic

Visual Basic

Dim mm As New C1MainMenu


TBH Adding Multiple Submenus Step4 - C#

C#

this.Controls.Add(mm);


TBH Adding Multiple Submenus Step4 - Delphi

Delphi

Self.Controls.Add(mm)


TBH Adding Multiple Submenus Step4 - Visual Basic

Visual Basic

Me.Controls.Add(mm)


TBH Adding Multiple Submenus Step5 - C#

C#

C1CommandMenu mmenu = ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding Multiple Submenus Step5 - Delphi

Delphi

mmenu := ch.CreateCommand(typeof(C1CommandMenu)) as C1CommandMenu;


TBH Adding Multiple Submenus Step5 - Visual Basic

Visual Basic

Dim mmenu As C1CommandMenu = CType(ch.CreateCommand(GetType(C1CommandMenu)), C1CommandMenu)


TBH Adding Multiple Submenus Step6 - C#

C#

mmenu.Text = "&Menu 1";


TBH Adding Multiple Submenus Step6 - Delphi

Delphi

mmenu.Text := '&Menu 1';


TBH Adding Multiple Submenus Step6 - Visual Basic

Visual Basic

mmenu.Text = "&Menu 1"


TBH Adding Multiple Submenus Step7 - C#

C#

mm.CommandLinks.Add(new C1CommandLink(mmenu));


TBH Adding Multiple Submenus Step7 - Delphi

Delphi

mm.CommandLinks.Add(C1CommandLink.Create(mmenu));


TBH Adding Multiple Submenus Step7 - Visual Basic

Visual Basic

mm.CommandLinks.Add(New C1CommandLink(mmenu))


TBH Adding Multiple Submenus Step8 - C#

C#

C1Command menuitem1 = ch.CreateCommand();


TBH Adding Multiple Submenus Step8 - Delphi

Delphi

var

menuitem1: C1Command;

begin

menuitem1 := ch.CreateCommand;

end;


TBH Adding Multiple Submenus Step8 - Visual Basic

Visual Basic

Dim menuitem1 As C1Command = ch.CreateCommand())


TBH Adding Multiple Submenus Step9 - C#

C#

menuitem1.Text = "Menu Item 1";

//add a new c1commandlink to the menuitem1

mmenu.CommandLinks.Add(new C1CommandLink(menuitem1));


TBH Adding Multiple Submenus Step9 - Delphi

Delphi

menuitem1.Text := 'Menu Item 1";

//add a new c1commandlink to the menuitem1

mmenu.CommandLinks.Add(C1Commandlink.Create(menuitem1));


TBH Adding Multiple Submenus Step9 - Visual Basic

Visual Basic

menuitem1.Text = "Menu Item 1"

'add a new c1commandlink to the menumitem1

mmenu.CommandLinks.Add(New C1CommandLink(menuitem1))


TBH Adding Multiple Submenus Step10 - C#

C#

C1CommandMenu menuitem2 = new C1CommandMenu();

menuitem2.Text = "Menu Item 2";


TBH Adding Multiple Submenus Step10 - Delphi

Delphi

var

menuitem2 := C1CommandMenu;

begin

menuitem2 := C1CommandMenu.Create;

menuitem2.Text := 'Menu Item 2';

end;


TBH Adding Multiple Submenus Step10 - Visual Basic

Visual Basic

Dim menuitem2 As C1CommandMenu = New C1CommandMenu()

menuitem2.Text = "Menu Item 2"


TBH Adding Multiple Submenus Step11 - C#

C#

mmenu.CommandLinks.Add(new C1CommandLink(menuitem2));


TBH Adding Multiple Submenus Step11 - Delphi

Delphi

mmenu.CommandLinks.Add(C1CommandLink.Create(menuitem2));


TBH Adding Multiple Submenus Step11 - Visual Basic

Visual Basic

mmenu.CommandLinks.Add(New C1CommandLink(menuitem2))


TBH Adding Multiple Submenus Step12 - C#

C#

C1Command submenu1 = ch.CreateCommand();

submenu1.Text = "Submenu 1";


TBH Adding Multiple Submenus Step12 - Delphi

Delphi

var

submenu1 := C1Command;

begin

submenu1 := ch.CreateCommand;

submenu1.Text := 'Submenu 1';

end;


TBH Adding Multiple Submenus Step12 - Visual Basic

Visual Basic

Dim submenu1 As C1Command = ch.CreateCommand()

submenu1.Text = "Submenu 1"


TBH Adding Multiple Submenus Step13 - C#

C#

menuitem2.CommandLinks.Add(new C1CommandLink(submenu1));


TBH Adding Multiple Submenus Step13 - Delphi

Delphi

menuitem2.CommandLinks.Add(C1CommandLink.Create(submenu1));


TBH Adding Multiple Submenus Step13 - Visual Basic

Visual Basic

menuitem2.CommandLinks.Add(New C1CommandLink(submenu1))


TBH Applying Shortcut Keys - C#

C#

if (sender == c1CommandMenu1)

{

this.pictureBox1.BackColor = Color.Violet;

}


TBH Applying Shortcut Keys - Delphi

Delphi

begin

if (sender = c1commandMenu1) then

Self.pictureBox1.BackColor : = Color.Violet;

end;


TBH Applying Shortcut Keys - Visual Basic

Visual Basic

If (sender = c1CommandMenu1)

Me.pictureBox1.BackColor = Color.Violet

End If


TBH Changing the Position of the Toolbar from Horizontal To Vertical - C#

C#

toolbar.Horizontal = False;


TBH Changing the Position of the Toolbar from Horizontal To Vertical - Delphi

Delphi

toolbar.Horizontal := False;


TBH Changing the Position of the Toolbar from Horizontal To Vertical - Visual Basic

Visual Basic

toolbar.Horizontal = False


TBH Creating a Context Menu Step1 - C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);


TBH Creating a Context Menu Step1 - Delphi

Delphi

var

ch: C1CommandHolder;

begin

ch := C1CommandHolder.CreateCommandHolder.Create(Self);

end;


TBH Creating a Context Menu Step1 - Visual Basic

Visual Basic

Dim ch As C1.Win.C1Command.C1CommandHolder

ch = C1CommandHolder.CreateCommandHolder(Me)


TBH Creating a Context Menu Step2 - C#

C#

// Create and set up the Copy command

C1Command cmdCopy = ch.CreateCommand();

cmdCopy.Text = "&Copy";


TBH Creating a Context Menu Step2 - Delphi

Delphi

var

cmdCopy: C1Command;

begin

cmdCopy := ch.CreateCommand;

cmdCopy.Text := '&Copy';

end;


TBH Creating a Context Menu Step2 - Visual Basic

Visual Basic

' Create and set up the Copy command

Dim cmdCopy as C1Command = ch.CreateCommand()

cmdCopy.Text = "&Copy"


TBH Creating a Context Menu Step3 - C#

C#

cmdCopy.Click += new C1.Win.C1Command.ClickEventHandler(clickCopy);

cmdCopy.CommandStateQuery += new C1.Win.C1Command.CommandStateQueryEventHandler(queryCopy);


TBH Creating a Context Menu Step3 - Delphi

Delphi

var

cmdCopy.Click: C1.Win.C1Command.ClickEventHandler;

cmdCopy.CommandStateQuery: C1.Win.C1Command.CommandStateQueryEventHandler;

begin

cmdCopyClick := C1Win.C1Command.ClickEventHandler(clickCopy).Create;

cmdCopy.CommandStateQuery := C1.Win.C1Command.CommandStateQueryEventHandler(queryCopy).Create;

end;


TBH Creating a Context Menu Step3 - Visual Basic

Visual Basic

AddHandler cmdCopy.Click, AddressOf clickCopy

AddHandler cmdCopy.CommandStateQuery, AddressOf queryCopy


TBH Creating a Context Menu Step4 - C#

C#

C1ContextMenu cm = ch.CreateCommand(typeof(C1ContextMenu)) as C1ContextMenu;

// Fill it with the links to the commands

cm.CommandLinks.Add(new C1CommandLink(cmdCopy));


TBH Creating a Context Menu Step4 - Delphi

Delphi

var

cm: C1ContextMenu;

begin

cm := ch.CreateCommand(typeof(C1ContextMenu)) As C1ContextMenu;

// Fill it with the links to the commands

cm.CommandLinks.Add(C1CommandLink.Create(cmdCopy));

end;


TBH Creating a Context Menu Step4 - Visual Basic

Visual Basic

Dim cm As C1ContextMenu = Ctype(ch.CreateCommand(GetType(C1ContextMenu)), C1ContextMenu)

'Fill it with the links to the commands

cm.CommandLinks.Add(New C1CommandLink (cmdCopy))


TBH Creating a Context Menu Step5 - C#

C#

ch.SetC1ContextMenu(textBox1, cm);

//You'll need to add the closing curly bracket, }, below, before you create a new //procedure in the following step

}


TBH Creating a Context Menu Step5 - Delphi

Delphi

ch.SetC1ContextMenu(textBox1, cm);


TBH Creating a Context Menu Step5 - Visual Basic

Visual Basic

ch.SetC1ContextMenu(textBox1, cm)

'You'll need to add the End Sub below before you create a Private Sub in the 'following step

End Sub


TBH Creating a Context Menu Step6 - C#

C#

private void clickCopy(object sender, C1.Win.C1Command.ClickEventArgs e)

{

this.textBox1.Copy();

}

//provides the current state of the copy command

private void queryCopy(object sender, C1.Win.C1Command.CommandStateQueryEventArgs e)

{

e.Enabled = this.textBox1.SelectionLength > 0;

}


TBH Creating a Context Menu Step6 - Delphi

Delphi

procedure MainForm clickCopy(sender: System.Object; e: System.EventArgs);

begin

self.textBox1.Copy();

end;

procedure MainForm queryCopy(sender: System.Object; e: System.EventArgs);

begin

e.Enabled := self.textBox1.SelectionLength > 0;

end;


TBH Creating a Context Menu Step6 - Visual Basic

Visual Basic

Private Sub clickCopy(ByVal sender As Object, ByVal e As C1.Win.C1Command.ClickEventArgs)

Me.textBox1.Copy()

End Sub

'provides the current state of the copy command

Private Sub queryCopy(ByVal sender As Object, ByVal e As C1.Win.C1Command.CommandStateQueryEventArgs)

e.Enabled = Me.textBox1.SelectionLength > 0

End Sub


TBH Creating a Toolbar Step1- C#

C#

using C1.Win.C1Command;


TBH Creating a Toolbar Step1- Delphi

Delphi

uses C1.Win.C1Command;


TBH Creating a Toolbar Step1 - Visual Basic

Visual Basic

Imports C1.Win.C1Command


TBH Creating a Toolbar Step2 - C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);


TBH Creating a Toolbar Step2 - Delphi

Delphi

var

ch: C1CommandHolder;

begin

ch := C1CommandHolder.CreateCommandHolder(Self);


TBH Creating a Toolbar Step2 - Visual Basic

Visual Basic

Dim ch As C1CommandHolder = C1CommandHolder.CreateCommandHolder(Me)


TBH Creating a Toolbar Step3 - C#

C#

C1ToolBar tb = new C1ToolBar();


TBH Creating a Toolbar Step3 - Delphi

Delphi

var

tb := C1ToolBar;

begin

tb := Create.C1ToolBar;

end;


TBH Creating a Toolbar Step3 - Visual Basic

Visual Basic

Dim tb As New C1ToolBar()


TBH Creating a Toolbar Step4 - C#

C#

this.Controls.Add(tb);


TBH Creating a Toolbar Step4 - Delphi

Delphi

Self.Controls.Add(tb);


TBH Creating a Toolbar Step4 - Visual Basic

Visual Basic

Me.Controls.Add(tb)


TBH Creating a Toolbar Step5 - C#

C#

tb.CommandHolder = ch;


TBH Creating a Toolbar Step5 - Delphi

Delphi

tb.CommandHolder := ch.Create;


TBH Creating a Toolbar Step5 - Visual Basic

Visual Basic

tb.CommandHolder = ch


TBH Creating a Toolbar Step6 - C#

C#

C1Command cFile = new C1Command();

cFile.Text = "File";


TBH Creating a Toolbar Step6 - Delphi

Delphi

var

cFile: C1Command;

begin

cFile := Create.C1Command;

cFile.Text : = 'File';


TBH Creating a Toolbar Step6 - Visual Basic

Visual Basic

Dim cFile As New C1Command()

cFile.Text = "File"


TBH Creating a Toolbar Step7 - C#

C#

C1CommandLink cl = new C1CommandLink(cFile);


TBH Creating a Toolbar Step7 - Delphi

Delphi

var

cl: C1CommandLink;

begin

cl := C1CommandLink.Create(cFile);

end;


TBH Creating a Toolbar Step7 - Visual Basic

Visual Basic

Dim cl As C1CommandLink

cl = New C1CommandLink(cFile)


TBH Creating a Toolbar Step8 - C#

C#

tb.CommandLinks.Add(cl);


TBH Creating a Toolbar Step8 - Delphi

Delphi

tb.CommandLinks.Add(c1);


TBH Creating a Toolbar Step8 - Visual Basic

Visual Basic

tb.CommandLinks.Add(cl)


TBH Creating a Toolbar Step9 - C#

C#

cl.ButtonLook = ButtonLookFlags.Text;


TBH Creating a Toolbar Step9 - Delphi

Delphi

cl.ButtonLook : = ButtonLookFlags.Text;


TBH Creating a Toolbar Step9 - Visual Basic

Visual Basic

cl.ButtonLook = ButtonLookFlags.Text


TBH Creating a Toolbar Step10 - C#

C#

C1Command cView = new C1Command();

cView.Text = "View";


TBH Creating a Toolbar Step10 - Delphi

Delphi

var

cView: C1Command;

begin

cView := Create.C1Command();

end;


TBH Creating a Toolbar Step10 - Visual Basic

Visual Basic

Dim cView As New C1Command()

cView.Text = "View"


TBH Creating a Toolbar Step11 - C#

C#

cl = new C1CommandLink(cView);


TBH Creating a Toolbar Step11 - Delphi

Delphi

cl : = C1CommandLink.Create(cView);


TBH Creating a Toolbar Step11 - Visual Basic

Visual Basic

cl = New C1CommandLink(cView)


TBH Creating a Toolbar Step12 - C#

C#

tb.CommandLinks.Add(cl);


TBH Creating a Toolbar Step12 - Delphi

Delphi

tb.CommandLinks.Add(cl);


TBH Creating a Toolbar Step12 - Visual Basic

Visual Basic

tb.CommandLinks.Add(cl)


TBH Creating a Toolbar Step13 - C#

C#

cl.ButtonLook = ButtonLookFlags.Text;


TBH Creating a Toolbar Step13 - Delphi

Delphi

cl.ButtonLook : = ButtonLookFlags.Text;


TBH Creating a Toolbar Step13 - Visual Basic

Visual Basic

cl.ButtonLook = ButtonLookFlags.Text


TBH Creating a Toolbar Step14 - C#

C#

C1Command mEdit = new C1Command();

mEdit.Text = "Edit";


TBH Creating a Toolbar Step14 - Delphi

Delphi

var

mEdit: C1Command;

begin

mEdit := Create.C1Command;

mEdit.Text = 'Edit';

end;


TBH Creating a Toolbar Step14 - Visual Basic

Visual Basic

Dim mEdit As New C1Command()

mEdit.Text = "Edit"


TBH Creating a Toolbar Step15 - C#

C#

cl = new C1CommandLink(mEdit);


TBH Creating a Toolbar Step15 - Delphi

Delphi

cl : = C1CommandLink.Create(mEdit);


TBH Creating a Toolbar Step15 - Visual Basic

Visual Basic

cl = New C1CommandLink(mEdit)


TBH Creating a Toolbar Step16 - C#

C#

tb.CommandLinks.Add(cl);


TBH Creating a Toolbar Step16 - Delphi

Delphi

tb.CommandLinks.Add(cl);


TBH Creating a Toolbar Step16 - Visual Basic

Visual Basic

tb.CommandLinks.Add(cl)


TBH Creating a Toolbar Step17 - C#

C#

cl.ButtonLook = ButtonLookFlags.Text;


TBH Creating a Toolbar Step17 - Delphi

Delphi

cl.ButtonLook : = ButtonLookFlags.Text;


TBH Creating a Toolbar Step17 - Visual Basic

Visual Basic

cl.ButtonLook = ButtonLookFlags.Text


TBH Creating Shortcut Keys - C#

C#

this.C1CommandMenu1.Shortcut = System.Windows.Forms.Shortcut.F6;


TBH Creating Shortcut Keys - Delphi

Delphi

Self.C1CommandMenu1.Shortcut := System.Windows.Forms.Shortcut.F6;


TBH Creating Shortcut Keys - Visual Basic

Visual Basic

Me.C1CommandMenu1.Shortcut = System.Windows.Forms.Shortcut.F


TBH Deleting Menu Items - C#

C#

//The variable name for the menu is called menu

//This deletes the menu

menu.Dispose();

//The variable name for the menu item is called menuitem1

//This deletes the menu item

menuitem1.Dispose();


TBH Deleting Menu Items - Delphi

Delphi

//The variable name for the menu is called menu

//This deletes the menu

menu.Dispose;

//The variable name for the menu item is called menuitem1

//This deletes the menu item

menuitem1.Dispose;


TBH Deleting Menu Items- Visual Basic

Visual Basic

'The variable name for the menu is called menu

'This deletes the menu

menu.Dispose()

'The variable name for the menu item is called menuitem1

'This deletes the menu item

menuitem1.Dispose()


TBH Docking a Toolbar at RunTime Step1 - C#

C#

C1CommandDock dock = new C1ComandDock();


TBH Docking a Toolbar at RunTime Step1 - Delphi

Delphi

var

dock: C1CommandDock;

begin

dock := C1CommandDock.Create;


TBH Docking a Toolbar at RunTime Step1 - Visual Basic

Visual Basic

Dim dock As New C1CommandDock()


TBH Docking a Toolbar at RunTime Step2 - C#

C#

this.Controls.Add(dock);


TBH Docking a Toolbar at RunTime Step2 - Delphi

Delphi

Self.Controls.Add(dock);


TBH Docking a Toolbar at RunTime Step2 - Visual Basic

Visual Basic

Me.Controls.Add(dock)


TBH Docking Your Toolbar to the top - C#

C#

dock.Dock = DockStyle.Top;


TBH Docking Your Toolbar to the top - Delphi

Delphi

dock.Dock := DockStyle.Top;


TBH Docking Your Toolbar to the top - Visual Basic

Visual Basic

dock.Dock = DockStyle.Top


TBH Making the Toolbar Appear Like IE Step1- C#

C#

C1CommandHolder ch = C1CommandHolder.CreateCommandHolder(this);

C1ToolBar tb = new C1ToolBar();

this.Controls.Add(tb);

tb.CommandHolder = ch;

C1Command cNew = new C1Command();

cNew.Text = " New ";

cl = new C1CommandLink(cNew);

tb.Commandlinks.Add(cl);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as an image

cl.ButtonLook = ButtonLookFlags.Image;


TBH Making the Toolbar Appear Like IE Step1 - Delphi

Delphi

var

ch: C1CommandHolder;

tb: C1ToolBar;

cNew: C1Command;

cl: C1CommandLink;

begin

ch := C1CommandHolder.CreateCommandHolder(Self);

tb := Create.C1ToolBar;

Self.Controls.Add(tb);

tb.CommandHolder := ch.Create;

cNew := Create.C1Command;

cNew.Text := ' New ';

cl := C1CommandLink.Create(cNew);

tb.CommandLinks.Add(c1);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as an image

cl.ButtonLook := ButtonLookFlags.Image;

end;


TBH Making the Toolbar Appear Like IE Step1 - Visual Basic

Visual Basic

Dim ch As C1CommandHolder = C1CommandHolder.CreateCommandHolder(Me)

Dim tb As New C1ToolBar()

Me.Controls.Add(tb)

tb.CommandHolder = ch

Dim cNew As New C1Command()

Dim cl As C1CommandLink

cNew.Text = "New"

cNew.Image = System.Drawing.Image.FromFile("C:\Images\New.bmp")

cl = New C1CommandLink(cNew)

tb.CommandLinks.Add(cl)

'Use the ButtonLookFlags enumeration to make the toolbar button appear as an image

cl.ButtonLook = ButtonLookFlags.Image


TBH Making the Toolbar Appear Like IE Step2- C#

C#

C1Command cOpen = new C1Command();

cOpen.Text = "Open";

cl = new C1CommandLink(cOpen);

cOpen.Image = System.Drawing.Image.FromFile("C:\Images\FileOpen.bmp");

tb.CommandLinks.Add(cl);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as text and an image

cl.ButtonLook = ButtonLookFlags.TextAndImage;


TBH Making the Toolbar Appear Like IE Step2 - Delphi

Delphi

var

cOpen: C1Command;

begin

cOpen := Create.C1Command;

cOpen.Text := ' Open ';

cl := C1CommandLink.Create(cOpen);

cOpen.Image := System.Drawing.Image.FromFile('C:\Images\FileOpen.bmp')

tb.CommandLinks.Add(c1);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as text and an image

cl.ButtonLook := ButtonLookFlags.TextAndImage;

end;


TBH Making the Toolbar Appear Like IE Step2 - Visual Basic

Visual Basic

Dim cOpen As New C1Command()

cOpen.Text = "Open"

cl = New C1CommandLink(cOpen)

cOpen.Image = System.Drawing.Image.FromFile("C:\Images\FileOpen.bmp")

tb.CommandLinks.Add(cl)

'Use the ButtonLookFlags enumeration to make the toolbar button appear as text and an image

cl.ButtonLook = ButtonLookFlags.TextAndImage


TBH Making the Toolbar Appear Like IE Step3 - C#

C#

C1Command cSave = new C1Command();

cSave.Text = "View";

cl = new C1CommandLink(cSave);

tb.CommandLinks.Add(cl);

cSave.Image = System.Drawing.Image.FromFile("C:\Images\FileSave.bmp")

//Use the ButtonLookFlags enumeration to make the toolbar button appear as default

cl.ButtonLook = ButtonLookFlags.Default;


TBH Making the Toolbar Appear Like IE Step3 - Delphi

Delphi

var

cSave: C1Command;

begin

cSave := Create.C1Command;

cSave.Text := ' Save ';

cl := C1CommandLink.Create(cSave);

tb.CommandLinks.Add(c1);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as default

cl.ButtonLook := ButtonLookFlags.Default;

end;


TBH Making the Toolbar Appear Like IE Step3 - Visual Basic

Visual Basic

Dim cSave As New C1Command()

cSave.Text = "Save"

cl = New C1CommandLink(cSave)

tb.CommandLinks.Add(cl)

cSave.Image = System.Drawing.Image.FromFile("C:\Images\FileSave.bmp")

'Use the ButtonLookFlags enumeration to make the toolbar button appear as default

cl.ButtonLook = ButtonLookFlags.Default


TBH Making the Toolbar Appear Like IE Step4 - C#

C#

C1Command cFavorites = new C1Command();

cFavorites.Text = "Favorites";

cl = new C1CommandLink(cFavorites);

tb.CommandLinks.Add(cl);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as text

cl.ButtonLook = ButtonLookFlags.Text;


TBH Making the Toolbar Appear Like IE Step4 - Delphi

Delphi

var

cFavorites: C1Command;

begin

cFavorites := Create.C1Command;

cFavorites.Text := ' Favorites ';

cl := C1CommandLink.Create(cFavorites);

tb.CommandLinks.Add(c1);

//Use the ButtonLookFlags enumeration to make the toolbar button appear as text

cl.ButtonLook := ButtonLookFlags.Text;

end;


TBH Making the Toolbar Appear Like IE Step4 - Visual Basic

Visual Basic

Dim cFavorites As New C1Command()

cFavorites.Text = "Favorites"

cl = New C1CommandLink(cFavorites)

tb.CommandLinks.Add(cl)

'Use the ButtonLookFlags enumeration to make the toolbar button appear as text

cl.ButtonLook = ButtonLookFlags.Text


Untitled Document

 E-mail sent to documentation@componentone.com is for documentation feedback only. We welcome any suggestions to help improve our documentation.