ComponentOne Studio for Silverlight Overview

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview | Search Helpcentral Search HelpCentral

ComponentOne Studio for Silverlight Overview

Previous Next

The future of Web development tools is here. ComponentOne Studio® for Silverlight is the most complete set of enterprise-quality components in the Silverlight market with over 30 innovative Silverlight controls. Advance your Web development with animation, vector graphics, custom layouts, and enhanced performance.

Studio for Silverlight complements the designer and developer workflow by supporting both XAML and code. Our Silverlight components allow designers to create the ultimate user experience and provide developers a familiar, full-featured set of properties and methods. Studio for Silverlight delivers exactly what developers and designers need to create brilliant experiences for the Web.

This document describes the controls in the ComponentOne Studio for Silverlight library. All the controls in the library target the Silverlight 2.0 library, and take full advantage of all the new technologies Microsoft has built into the Silverlight platform.

The ComponentOne Studio for Silverlight library is included in the ComponentOne Studio Enterprise product, which also includes control libraries for WinForms, ASP.NET, WPF, and Mobile platforms and is the most complete control suite available today.

Installing ComponentOne Studio for Silverlight

Licensing FAQs

Technical Support

Redistributable Files

About This Documentation

Running the Samples

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Installing ComponentOne Studio for Silverlight

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight | Search Helpcentral Search HelpCentral

Installing ComponentOne Studio for Silverlight

Previous Next

The following sections provide helpful information on installing ComponentOne Studio for Silverlight.

Studio for Silverlight Setup Files

System Requirements

Installing Demonstration Versions

Uninstalling Studio for Silverlight

Deploying your Application in a Medium Trust Environment

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Studio for Silverlight Setup Files

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Studio for Silverlight Setup Files | Search Helpcentral Search HelpCentral

Studio for Silverlight Setup Files

Previous Next

The ComponentOne Studio for Silverlight installation program will create the following directory: C:\Program Files\ComponentOne\Studio for Silverlight. This directory contains the following subdirectories:

bin | Contains copies of all ComponentOne binaries (DLLs, Exes).
Help | Contains documentation for all Studio components.
Samples | Contains several sample projects.
Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


System Requirements

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > System Requirements | Search Helpcentral Search HelpCentral

System Requirements

Previous Next

System requirements for ComponentOne Studio for Silverlight include the following:

· Microsoft Silverlight 2.0 RTW (2.0.31005.0)

· Microsoft Visual Studio 2008 (9.0.30729.1 SP or later)

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Installing Demonstration Versions

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Installing Demonstration Versions | Search Helpcentral Search HelpCentral

Installing Demonstration Versions

Previous Next

If you wish to try ComponentOne Studio for Silverlight and do not have a serial number, follow the steps through the installation wizard and use the default serial number.

The only difference between unregistered (demonstration) and registered (purchased) versions of our products is that the registered version will stamp every application you compile so a ComponentOne banner will not appear when your users run the applications.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Uninstalling Studio for Silverlight

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Uninstalling Studio for Silverlight | Search Helpcentral Search HelpCentral

Uninstalling Studio for Silverlight

Previous Next

To uninstall ComponentOne Studio for Silverlight:

1. Open the Control Panel and select the Add or Remove Programs.

2. Select ComponentOne Studio for Silverlight and click the Remove button.

3. Click Yes to remove the program.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Deploying your Application in a Medium Trust Environment

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Deploying your Application in a Medium Trust Environment | Search Helpcentral Search HelpCentral

Deploying your Application in a Medium Trust Environment

Previous Next

Depending on your hosting choice, you may need to deploy your Web site or application in a medium trust environment. Often in a shared hosting environment, medium trust is required. In a medium trust environment several permissions are unavailable or limited, including OleDbPermission, ReflectionPermission,and FileIOPermission. You can configure your Web.config file to enable these permissions.

Note: ComponentOne controls will not work in an environment where reflection is not allowed.

ComponentOne ASP.NET controls include the AllowPartiallyTrustedCallers() assembly attribute and will work under the medium trust level with some changes to the Web.config file. Since this requires some control over the Web.config file, please check with your particular host to determine if they can provide the rights to override these security settings.

Modifying or Editing the Config File

Allowing Deserialization

Adding Permissions

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Modifying or Editing the Config File

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Deploying your Application in a Medium Trust Environment > Modifying or Editing the Config File | Search Helpcentral Search HelpCentral

Modifying or Editing the Config File

Previous Next

In order to add permissions, you can edit the exiting web_mediumtrust.config file or create a custom policy file based on the medium trust policy. If you modify the existing web_mediumtrust.config file, all Web applications will have the same permissions with the permissions you have added. If you want applications to have different permissions, you can instead create a custom policy based on medium trust.

Edit the Config File

In order to add permissions, you can edit the exiting web_mediumtrust.config file. To edit the exiting web_mediumtrust.config file, complete the following steps:

1. Locate the medium trust policy file web_mediumtrust.config located by default in the %windir%\Microsoft.NET\Framework\{Version}\CONFIG directory.

2. Open the web_mediumtrust.config file.

3. Add the permissions that you want to grant. For examples, see Adding Permissions.

Create a Custom Policy Based on Medium Trust

In order to add permissions, you can create a custom policy file based on the medium trust policy. To create a custom policy file, complete the following steps:

1. Locate the medium trust policy file web_mediumtrust.config located by default in the %windir%\Microsoft.NET\Framework\{Version}\CONFIG directory.

2. Copy the web_mediumtrust.config file and create a new policy file in the same directory.

Give the new a name that indicates that it is your variation of medium trust; for example, AllowReflection_Web_MediumTrust.config.

3. Add the permissions that you want to grant. For examples, see Adding Permissions.

4. Enable the custom policy file on your application by modifying the following lines in your web.config file under the <system.web> node:

<system.web>

<trust level="CustomMedium" originUrl=""/>

<securityPolicy>

<trustLevel name="CustomMedium" policyFile="AllowReflection_Web_MediumTrust.config"/>

</securityPolicy>

...

</system.web>

Note: Your host may not allow trust level overrides. Please check with your host to see if you have these rights.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Allowing Deserialization

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Installing ComponentOne Studio for Silverlight > Deploying your Application in a Medium Trust Environment > Allowing Deserialization | Search Helpcentral Search HelpCentral

Allowing Deserialization

Previous Next

To allow the deserialization of the license added to App_Licenses.dll by the Microsoft IDE, you should add the SerializationFormatter flag to security permission to the Web.config file. Complete the steps in the Modifying or Editing the Config File topic to create or modify a policy file before completing the following.

Add the SerializationFormatter flag to the <IPermission class="SecurityPermission"> tag so that it appears similar to the following:

<NamedPermissionSets>

<PermissionSet

class="NamedPermissionSet"

version="1"

Name="ASP.Net">

<IPermission

class="SecurityPermission"

version="1"

Flags="Assertion, Execution, ControlThread, ControlPrincipal, RemotingConfiguration, SerializationFormatter"/>

...

</PermissionSet>

</NamedPermissionSets>

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Adding Permissions

You can add permission, including ReflectionPermission, OleDbPermission, and FileIOPermission to the web.config file. Note that ComponentOne controls will not work in an environment where reflection is not allowed. Complete the steps in the Modifying or Editing the Config File topic to create or modify a policy file before completing the following.

ReflectionPermission

By default ReflectionPermission is not available in a medium trust environment. ComponentOne ASP.NET controls require reflection permission because LicenseManager.Validate() causes a link demand for full trust.

To add reflection permission, complete the following:

1. Open the web_mediumtrust.config file or a file created based on the web_mediumtrust.config file.

2. Add the following <SecurityClass> tag after the <SecurityClasses> tag so that it appears similar to the following:

<SecurityClasses>

    <SecurityClass
Name="ReflectionPermission"
Description="System.Security.Permissions.ReflectionPermission, mscorlib,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

...

</SecurityClasses>

3. Add the following <IPermission> tag after the <NamedPermissionSets> tag so it appears similar to the following:

<NamedPermissionSets>

<PermissionSet class="NamedPermissionSet" version="1" Name="ASP.Net">

<IPermission

class="ReflectionPermission"

version="1"

Flags="ReflectionEmit,MemberAccess" />

...

</PermissionSet>

</NamedPermissionSets>

4. Save and close the web_mediumtrust.config file.

OleDbPermission

By default OleDbPermission is not available in a medium trust environment. This means you cannot use the ADO.NET managed OLE DB data provider to access databases. If you wish to use the ADO.NET managed OLE DB data provider to access databases, you must modify the web_mediumtrust.config file.

To add OleDbPermission, complete the following steps:

1. Open the web_mediumtrust.config file or a file created based on the web_mediumtrust.config file.

2. Add the following <SecurityClass> tag after the <SecurityClasses> tag so that it appears similar to the following:

<SecurityClasses>

<SecurityClass Name="OleDbPermission" Description="System.Data.OleDb.OleDbPermission, System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

...

</SecurityClasses>

3. Add the following <IPermission> tag after the <NamedPermissionSets> tag so it appears similar to the following:

<NamedPermissionSets>

<PermissionSet class="NamedPermissionSet" version="1" Name="ASP.Net">

<IPermission class="OleDbPermission" version="1" Unrestricted="true"/>

...

</PermissionSet>

</NamedPermissionSets>

4. Save and close the web_mediumtrust.config file.

FileIOPermission

By default, FileIOPermission is not available in a medium trust environment. This means no file access is permitted outside of the application's virtual directory hierarchy. If you wish to allow additional file permissions, you must modify the web_mediumtrust.config file.

To modify FileIOPermission to allow read access to a specific directory outside of the application's virtual directory hierarchy, complete the following steps:

1. Open the web_mediumtrust.config file or a file created based on the web_mediumtrust.config file.

2. Add the following <SecurityClass> tag after the <SecurityClasses> tag so that it appears similar to the following:

<SecurityClasses>

    <SecurityClass
Name="FileIOPermission"
Description="System.Security.Permissions.FileIOPermission, mscorlib,
Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>

...

</SecurityClasses>

3. Add the following <IPermission> tag after the <NamedPermissionSets> tag so it appears similar to the following:

<NamedPermissionSets>

<PermissionSet class="NamedPermissionSet" version="1" Name="ASP.Net">

...

<IPermission class="FileIOPermission" version="1" Read="C:\SomeDir;$AppDir$" Write="$AppDir$" Append="$AppDir$" PathDiscovery="$AppDir$" />

...

</PermissionSet>

</NamedPermissionSets>

4. Save and close the web_mediumtrust.config file.


Licensing FAQs

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs | Search Helpcentral Search HelpCentral

Licensing FAQs

Previous Next

This section describes the main technical aspects of licensing. It may help the user to understand and resolve licensing problems he may experience when using ComponentOne .NET and ASP.NET products.

What is Licensing?

How does Licensing Work?

Common Scenarios

Troubleshooting

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


What is Licensing?

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > What is Licensing? | Search Helpcentral Search HelpCentral

What is Licensing?

Previous Next

Licensing is a mechanism used to protect intellectual property by ensuring that users are authorized to use software products.

Licensing is not only used to prevent illegal distribution of software products. Many software vendors, including ComponentOne, use licensing to allow potential users to test products before they decide to purchase them.

Without licensing, this type of distribution would not be practical for the vendor or convenient for the user. Vendors would either have to distribute evaluation software with limited functionality, or shift the burden of managing software licenses to customers, who could easily forget that the software being used is an evaluation version and has not been purchased.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


How does Licensing Work?

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > How does Licensing Work? | Search Helpcentral Search HelpCentral

How does Licensing Work?

Previous Next

ComponentOne uses a licensing model based on the standard set by Microsoft, which works with all types of components.

Note: The Compact Framework components use a slightly different mechanism for run-time licensing than the other ComponentOne components due to platform differences.

When a user decides to purchase a product, he receives an installation program and a Serial Number. During the installation process, the user is prompted for the serial number that is saved on the system. (Users can also enter the serial number by clicking the License button on the About Box of any ComponentOne product, if available, or by rerunning the installation and entering the serial number in the licensing dialog box.)

When a licensed component is added to a form or Web page, Visual Studio obtains version and licensing information from the newly created component. When queried by Visual Studio, the component looks for licensing information stored in the system and generates a run-time license and version information, which Visual Studio saves in the following two files:

· An assembly resource file which contains the actual run-time license

· A "licenses.licx" file that contains the licensed component strong name and version information

These files are automatically added to the project.

In WinForms and ASP.Net 1.x applications, the run-time license is stored as an embedded resource in the assembly hosting the component or control by Visual Studio. In ASP.Net 2.x applications, the run-time license may also be stored as an embedded resource in the App_Licenses.dll assembly, which is used to store all run-time licenses for all components directly hosted by WebForms in the application. Thus, the App_licenses.dll must always be deployed with the application.

The licenses.licx file is a simple text file that contains strong names and version information for each of the licensed components used in the application. Whenever Visual Studio is called upon to rebuild the application resources, this file is read and used as a list of components to query for run-time licenses to be embedded in the appropriate assembly resource. Note that editing or adding an appropriate line to this file can force Visual Studio to add run-time licenses of other controls as well.

Note that the licenses.licx file is usually not shown in the Solution Explorer; it appears if you press the Show All Files button in the Solution Explorer's Toolbox, or from Visual Studio's main menu, select Show All Files on the Project menu.

Later, when the component is created at run time, it obtains the run-time license from the appropriate assembly resource that was created at design time and can decide whether to simply accept the run-time license, to throw an exception and fail altogether, or to display some information reminding the user that the software has not been licensed.

All ComponentOne products are designed to display licensing information if the product is not licensed. None will throw licensing exceptions and prevent applications from running.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Common Scenarios

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios | Search Helpcentral Search HelpCentral

Common Scenarios

Previous Next

The following topics describe some of the licensing scenarios you may encounter.

Creating components at design time

Creating components at run time

Inheriting from licensed components

Using licensed components in console applications

Using licensed components in Visual C++ applications

Using licensed components with automated testing products

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Creating components at design time

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Creating components at design time | Search Helpcentral Search HelpCentral

Creating components at design time

Previous Next

This is the most common scenario and also the simplest: the user adds one or more controls to the form, the licensing information is stored in the licenses.licx file, and the component works.

Note that the mechanism is exactly the same for Windows Forms and Web Forms (ASP.NET) projects.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Creating components at run time

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Creating components at run time | Search Helpcentral Search HelpCentral

Creating components at run time

Previous Next

This is also a fairly common scenario. You do not need an instance of the component on the form, but would like to create one or more instances at run time.

In this case, the project will not contain a licenses.licx file (or the file will not contain an appropriate run-time license for the component) and therefore licensing will fail.

To fix this problem, add an instance of the component to a form in the project. This will create the licenses.licx file and things will then work as expected. (The component can be removed from the form after the licenses.licx file has been created).

Adding an instance of the component to a form, then removing that component, is just a simple way of adding a line with the component strong name to the licenses.licx file. If desired, you can do this manually using notepad or Visual Studio itself by opening the file and adding the text. When Visual Studio recreates the application resources, the component will be queried and its run-time license added to the appropriate assembly resource.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Inheriting from licensed components

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Inheriting from licensed components | Search Helpcentral Search HelpCentral

Inheriting from licensed components

Previous Next

If a component that inherits from a licensed component is created, the licensing information to be stored in the form is still needed. This can be done in two ways:

· Add a LicenseProvider attribute to the component.

This will mark the derived component class as licensed. When the component is added to a form, Visual Studio will create and manage the licenses.licx file, and the base class will handle the licensing process as usual. No additional work is needed. For example:

    [LicenseProvider(typeof(LicenseProvider))]
    class MyGrid: C1.Win.C1FlexGrid.C1FlexGrid
    {
               // ...
    }

· Add an instance of the base component to the form.

This will embed the licensing information into the licenses.licx file as in the previous scenario, and the base component will find it and use it. As before, the extra instance can be deleted after the licenses.licx file has been created.

Please note, that C1 licensing will not accept a run-time license for a derived control if the run-time license is embedded in the same assembly as the derived class definition, and the assembly is a DLL. This restriction is necessary to prevent a derived control class assembly from being used in other applications without a design-time license. If you create such an assembly, you will need to take one of the actions previously described create a component at run time.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Using licensed components in console applications

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Using licensed components in console applications | Search Helpcentral Search HelpCentral

Using licensed components in console applications

Previous Next

When building console applications, there are no forms to add components to, and therefore Visual Studio won't create a licenses.licx file.

In these cases, create a temporary Windows Forms application and add all the desired licensed components to a form. Then close the Windows Forms application and copy the licenses.licx file into the console application project.

Make sure the licenses.licx file is configured as an embedded resource. To do this, right-click the licenses.licx file in the Solution Explorer window and select Properties. In the Properties window, set the Build Action property to Embedded Resource.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Using licensed components in Visual C++ applications

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Using licensed components in Visual C++ applications | Search Helpcentral Search HelpCentral

Using licensed components in Visual C++ applications

Previous Next

There is an issue in VC++ 2003 where the licenses.licx is ignored during the build process; therefore, the licensing information is not included in VC++ applications.

To fix this problem, extra steps must be taken to compile the licensing resources and link them to the project. Note the following:

1. Build the C++ project as usual. This should create an EXE file and also a licenses.licx file with licensing information in it.

2. Copy the licenses.licx file from the application directory to the target folder (Debug or Release).

3. Copy the C1Lc.exe utility and the licensed DLLs to the target folder. (Don't use the standard lc.exe, it has bugs.)

4. Use C1Lc.exe to compile the licenses.licx file. The command line should look like this:

c1lc /target:MyApp.exe /complist:licenses.licx /i:C1.Win.C1FlexGrid.dll

5. Link the licenses into the project. To do this, go back to Visual Studio, right-click the project, select Properties, and go to the Linker/Command Line option. Enter the following:

/ASSEMBLYRESOURCE:Debug\MyApp.exe.licenses

6. Rebuild the executable to include the licensing information in the application.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Using licensed components with automated testing products

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Common Scenarios > Using licensed components with automated testing products | Search Helpcentral Search HelpCentral

Using licensed components with automated testing products

Previous Next

Automated testing products that load assemblies dynamically may cause them to display license dialog boxes. This is the expected behavior since the test application typically does not contain the necessary licensing information, and there is no easy way to add it.

This can be avoided by adding the string "C1CheckForDesignLicenseAtRuntime" to the AssemblyConfiguration attribute of the assembly that contains or derives from ComponentOne controls. This attribute value directs the ComponentOne controls to use design-time licenses at run time.

For example:

#if AUTOMATED_TESTING
       [AssemblyConfiguration("C1CheckForDesignLicenseAtRuntime")]
#endif
       public class MyDerivedControl : C1LicensedControl
       {
              // ...
       }

Note that the AssemblyConfiguration string may contain additional text before or after the given string, so the AssemblyConfiguration attribute can be used for other purposes as well. For example:

       [AssemblyConfiguration("C1CheckForDesignLicenseAtRuntime,BetaVersion")]

THIS METHOD SHOULD ONLY BE USED UNDER THE SCENARIO DESCRIBED. It requires a design-time license to be installed on the testing machine. Distributing or installing the license on other computers is a violation of the EULA.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Troubleshooting

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Troubleshooting | Search Helpcentral Search HelpCentral

Troubleshooting

Previous Next

We try very hard to make the licensing mechanism as unobtrusive as possible, but problems may occur for a number of reasons.

Below is a description of the most common problems and their solutions.

I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

I have a licensed version of a ComponentOne product on my Web server but the components still behave as unlicensed.

I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Troubleshooting > I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project. | Search Helpcentral Search HelpCentral

I have a licensed version of a ComponentOne product but I still get the splash screen when I run my project.

Previous Next

If this happens, there may be a problem with the licenses.licx file in the project. It either doesn't exist, contains wrong information, or is not configured correctly.

First, try a full rebuild (Rebuild All from the Visual Studio Build menu). This will usually rebuild the correct licensing resources.

If that fails follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the Show All Files button on the top of the window.

3. Find the licenses.licx file and open it. If prompted, continue to open the file.

4. Change the version number of each component to the appropriate value. If the component does not appear in the file, obtain the appropriate data from another licenses.licx file or follow the alternate procedure following.

5. Save the file, then close the licenses.licx tab.

6. Rebuild the project using the Rebuild All option (not just Rebuild).

Alternatively, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Click the Show All Files button on the top of the window.

3. Find the licenses.licx file and delete it.

4. Close the project and reopen it.

5. Open the main form and add an instance of each licensed control.

6. Check the Solution Explorer window, there should be a licenses.licx file there.

7. Rebuild the project using the Rebuild All option (not just Rebuild).

For ASP.Net 2.x applications, follow these steps:

1. Open the project and go to the Solution Explorer window.

2. Find the licenses.licx file and right-click it.

3. Select the Rebuild Licenses option (this will rebuild the App_Licenses.licx file).

4. Rebuild the project using the Rebuild All option (not just Rebuild).

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


I have a licensed version of a ComponentOne product on my Web server but the components still behave as unlicensed.

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Troubleshooting > I have a licensed version of a ComponentOne product on my Web server but the components still behave as unlicensed. | Search Helpcentral Search HelpCentral

I have a licensed version of a ComponentOne product on my Web server but the components still behave as unlicensed.

Previous Next

There is no need to install any licenses on machines used as servers and not used for development.

The components must be licensed on the development machine, therefore the licensing information will be saved into the executable (EXE or DLL) when the project is built. After that, the application can be deployed on any machine, including Web servers.

For ASP.Net 2.x applications, be sure that the App_Licenses.dll assembly created during development of the application is deployed to the bin application bin directory on the Web server.

If your ASP.Net application uses WinForms user controls with constituent licensed controls, the run-time license is embedded in the WinForms user control assembly. In this case, you must be sure to rebuild and update the user control whenever the licensed embedded controls are updated.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Licensing FAQs > Troubleshooting > I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects. | Search Helpcentral Search HelpCentral

I downloaded a new build of a component that I have purchased, and now I'm getting the splash screen when I build my projects.

Previous Next

Make sure that the serial number is still valid. If you licensed the component over a year ago, your subscription may have expired. In this case, you have two options:

Option 1 – Renew your subscription to get a new serial number.

If you choose this option, you will receive a new serial number that you can use to license the new components (from the installation utility or directly from the About Box).

The new subscription will entitle you to a full year of upgrades and to download the latest maintenance builds directly from http://prerelease.componentone.com/.

Option 2 – Continue to use the components you have.

Subscriptions expire, products do not. You can continue to use the components you received or downloaded while your subscription was valid.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Technical Support

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Technical Support | Search Helpcentral Search HelpCentral

Technical Support

Previous Next

ComponentOne offers various support options. For a complete list and a description of each, visit the ComponentOne Web site at http://www.componentone.com/Support.

Some methods for obtaining technical support include:

· Online Support via HelpCentral
ComponentOne HelpCentral provides customers with a comprehensive set of technical resources in the form of FAQs, samples, Version Release History, Articles, searchable Knowledge Base, searchable Online Help and more. We recommend this as the first place to look for answers to your technical questions.

· Online Support via our Incident Submission Form
This online support service provides you with direct access to our Technical Support staff via an online incident submission form. When you submit an incident, you'll immediately receive a response via e-mail confirming that you've successfully created an incident. This email will provide you with an Issue Reference ID and will provide you with a set of possible answers to your question from our Knowledgebase. You will receive a response from one of the ComponentOne staff members via e-mail in 2 business days or less.

· Peer-to-Peer Product Forums and Newsgroups
ComponentOne peer-to-peer product forums and newsgroups are available to exchange information, tips, and techniques regarding ComponentOne products. ComponentOne sponsors these areas as a forum for users to share information. While ComponentOne does not provide direct support in the forums and newsgroups, we periodically monitor them to ensure accuracy of information and provide comments when appropriate. Please note that a ComponentOne User Account is required to participate in the ComponentOne Product Forums.

· Installation Issues
Registered users can obtain help with problems installing ComponentOne products. Contact technical support by using the online incident submission form or by phone (412.681.4738). Please note that this does not include issues related to distributing a product to end-users in an application.

· Documentation
ComponentOne documentation is available with each of our products in HTML Help, Microsoft Help 2.0 (WPF, .NET, ASP.NET and Mobile Device products only), and NetHelp format. The NetHelp version of the documentation is also available on HelpCentral. If you have suggestions on how we can improve our documentation, please email the Documentation team. Please note that e-mail sent to the Documentation team is for documentation feedback only. Technical Support and Sales issues should be sent directly to their respective departments.

Note: You must create a ComponentOne Account and register your product with a valid serial number to obtain support using some of the above methods.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Redistributable Files

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Redistributable Files | Search Helpcentral Search HelpCentral

Redistributable Files

Previous Next

ComponentOne Studio for Silverlight is developed and published by ComponentOne LLC. You may use it to develop applications in conjunction with Microsoft Visual Studio or any other programming environment that enables the user to use and integrate the control(s). You may also distribute, free of royalties, the following Redistributable Files with any such application you develop to the extent that they are used separately on a single CPU on the client/workstation side of the network:

· C1.Silverlight.dll

· C1.Silverlight.Chart.dll

· C1.Silverlight.Data.dll

· C1.Silverlight.DataGrid.dll

· C1.Silverlight.Extended.dll

· C1.Silverlight.Gauge.dll

· C1.Silverlight.Maps.dll

· C1.Silverlight.RichTextBox.dll

· C1.Silverlight.RichTextBox.Toolbar.dll

· C1.Silverlight.Uploader.dll

· C1.Silverlight.Zip.dll

Site licenses are available for groups of multiple developers. Please contact Sales@ComponentOne.com for details.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


About This Documentation

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > About This Documentation | Search Helpcentral Search HelpCentral

About This Documentation

Previous Next

Acknowledgements

Microsoft, Windows, Windows Vista, and Visual Studio, are either registered trademarks or trademarks of Microsoft Corporation in the United States and/or other countries. Firefox is a registered trademark of the Mozilla Foundation. Safari is a trademark of Apple Inc., registered in the U.S. and other countries.

ComponentOne

If you have any suggestions or ideas for new features or controls, please call us or write:

Corporate Headquarters

ComponentOne LLC
201 South Highland Avenue
3rd Floor
Pittsburgh, PA 15206 • USA
412.681.4343
412.681.4384 (Fax)

http://www.componentone.com

ComponentOne Doc-To-Help

This documentation was produced using ComponentOne Doc-To-Help® Enterprise.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Running the Samples

ComponentOne Studio for Silverlight: ComponentOne Studio for Silverlight Overview > Running the Samples | Search Helpcentral Search HelpCentral

Running the Samples

Previous Next

If you just installed Studio for Silverlight, open Visual Studio 2008 and load the Samples.sln solution located in the Program Files\ComponentOne\Studio for Silverlight\Samples folder. This solution contains all the samples that ship with this release. Each sample has a readme.txt file that describes it and two projects named as follows:

· <SampleName> Silverlight project (client part)

· <SampleName>Web ASP.NET project that hosts the Silverlight project (server part)

To run a sample, right-click the <SampleName>Web project in the solution explorer, select Set as Startup Project, and press F5.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Assembly Summary

ComponentOne Studio for Silverlight: Assembly Summary | Search Helpcentral Search HelpCentral

Assembly Summary

Previous Next

ComponentOne Studio for Silverlight includes several assemblies. This increases the granularity of the studio and helps to decrease the size of applications that do not use all the controls available in the studio.

The table below lists the assemblies in ComponentOne Studio for Silverlight. The XAP Size column shows the size of the compressed file that has to be deployed with the applications that use the assembly. The Dependencies column shows only the ComponentOne dependencies (Silverlight DLLs are not listed).

# | Assembly | Size (kb) | XAP Size (kb) | Dependencies
1 | C1.Silverlight | 396 | 113 |
2 | C1.Silverlight.Extended | 303 | 61 | C1.Silverlight
3 | C1.Silverlight.Data | 51 | 23 |
4 | C1.Silverlight.Zip | 78 | 31 |
5 | C1.Silverlight.Chart | 225 | 78 |
6 | C1.Silverlight.DataGrid | 334 | 84 | C1.Silverlight
7 | C1.Silverlight.RichTextBox | 157 | 66 | C1.Silverlight
8 | C1.Silverlight.RichTextBox.Toolbar | 224 | 29 | C1.Silverlight.RichTextBox
9 | C1.Silverlight.Uploader | 34 | 14 |
10 | C1.Silverlight.Maps | 76 | 23 | C1.Silverlight
11 | C1.Silverlight.Gauge | 70 | 23 | C1.Silverlight

ComponentOne Silverlight Assemblies (build 2.0.20083.6, October 20, 2008)

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Control Summary

ComponentOne Studio for Silverlight: Control Summary | Search Helpcentral Search HelpCentral

Control Summary

Previous Next

The following topics list the main controls in each assembly.

C1.Silverlight.dll

C1.Silverlight.Extended.dll

C1.Silverlight.Chart.dll

C1.Silverlight.Gauge.dll

C1.Silverlight.Maps.dll

C1.Silverlight.RichTextBox.dll

C1.Silverlight.RichTextBox.Toolbar.dll

C1.Silverlight.DataGrid.dll

C1.Silverlight.Uploader.dll

C1.Silverlight.Zip.dll

C1.Silverlight.Data.dll

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.dll

ComponentOne Studio for Silverlight: Control Summary > C1.Silverlight.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.dll

Previous Next

This is the main assembly. It contains several basic controls and utility classes that can be used by themselves and are often used by other controls in the Studio.

Main Classes

The following main classes are included in the C1.Silverlight.dll assembly:

· C1ComboBox: Combines a textbox with an auto-searchable drop-down list, similar to the ComboBox controls in WPF and WinForms.

· C1DropDown: Provides a generic dropdown control (like a ComboBox or a DateTimePicker). The control has a Header property that determines what the user sees when the drop-down part of the control is closed, and a Content property that determines what goes into the drop-down part.

· C1FilePicker: A control that shows a file name and allows the user to show a file picker dialog box to browse the file system and select one or more files.

· C1MaskedTextBox: Provides a text box with a mask that automatically validates the input, similar to the MaskedTextBox control in WinForms.

· C1NumericBox: Provides a text box for displaying and editing formatted numeric values. Includes up/down buttons to increment or decrement the value, and allows you to display a fixed or variable number of decimal places and thousand separators.

· C1TreeView: Provides a hierarchical view of data items, similar to the TreeView control in WPF and WinForms. The control contains C1TreeViewItem objects, which may contain any type of UI element (text, images, checkboxes, and so on), and supports drag-and-drop operations.

· C1Menu: Provides a hierarchical list of elements associated with event handlers, similar to the Menu control in WPF.

· C1Window: Shows content in a window inside the Silverlight plug-in, similar to the Window class in WPF.

· C1MessageBox: Provides an easy way to show messages and ask simple questions to the user.

· C1PromptBox: Provides an easy way to get simple input from the user.

· C1RangeSlider: Lets users select a range by moving two thumbs along a track. Similar to the Slider control in WPF and Silverlight, but provides a range (UpperValue and LowerValue) instead of a single value.

· C1HyperPanel: A StackPanel that applies a dynamic zoom effect to items near the mouse, similar to the Doc (system toolbar) seen in the Apple Macintosh. You can place any elements in a C1HyperPanel to achieve carousel-like effects and display a large number of elements in a relatively small container, without using scrollbars.

· C1DockPanel: Panel that allows you to dock other panels horizontally and vertically, similar to the DockPanel class available in WPF.

· C1UniformGrid: Grid panel where all cells have the same width and height, similar to the UniformGrid class in WPF.

· C1WrapPanel: A panel that wraps its contents vertically or horizontally, similar to the WrapPanel class in WPF. In addition to the automatic wrapping, the C1WrapPanel supports custom breaks so you can customize the layout as needed.

· C1DragDropManager: Provides support for drag-and-drop operations in Silverlight applications. It also provides methods for registering UIElement objects to act as drag sources and drop targets automatically, and fires events that allow you to customize the drag-and-drop behavior.

· C1MouseHelper: Provides additional mouse support for FrameworkElement objects, including mouse wheel support, double-click events, and element dragging.

· C1PasswordBox: This control was present in pre-release versions of the studio but has been removed since Microsoft added a PasswordBox control to the Silverlight core.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Extended.dll

ComponentOne Studio for Silverlight: Control Summary > C1.Silverlight.Extended.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Extended.dll

Previous Next

C1.Silverlight.Extended.dll provides controls that are more specialized and less commonly used than the ones in the main C1.Silverlight.dll assembly. Most of the controls in the C1.Silverlight.Extended.dll are visually rich controls not available in WinForms or in WPF.

Main Classes

The following main classes are included in the C1.Silverlight.Extended.dll assembly:

· C1Accordion: An ItemsControl where each item is shown inside a C1Expander control and only one is allowed to be expanded at a time. This is similar to the Microsoft Outlook navigation bar.

· C1Book: Presents UIElement objects as if they were pages in a book. You can see two elements at a time, and turn pages with the mouse, just as you would turn pages in a regular paper book. The control provides page-turning effects and shadows that make the experience visually interesting and yet familiar.

· C1ColorPicker: Enables users to browse colors using a palette or to create colors using the RGB and HSB color models.

· C1Cube: Presents UIElement objects as faces on a rotating cube. The control provides methods for rotating the cube in order to display specific elements. This is a visually attractive and innovative way to present information using a 3D metaphor.

· C1HeaderedContentControl: Provides the base implementation for all controls that contain single content and have a header, similar to the HeaderedContentControl in WPF.

· C1Expander: A C1HeaderedContentControl whose content can be collapsed and expanded by clicking on the header.

· C1HtmlHost: Provides a frame that can host arbitrary HTML content. The control can display content from arbitrary URIs (SourceUri property), or it can display HTML documents (SourceHtml property). Note: the C1HtmlHost control requires that the host Silverlight plug-in have its Windowless property set to True.

· C1ImageMagnifier: Similar to an Image element with a 'magnifying glass' over it. The portion of the image under the magnifying glass is zoomed. The user can move the magnifying glass over the image to easily zoom in on any part of the image, and he can use the keyboard to change the zoom factor.

· C1ImageRotator: Provides a pseudo-3D rotating effect for images, similar to the cover-flow view used in Apple's iTunes application. The control can rotate images vertically or horizontally, and it can display a reflection below the image.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Chart.dll

ComponentOne Studio for Silverlight: Control Summary > C1.Silverlight.Chart.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Chart.dll

Previous Next

Contains the C1Chart control and its auxiliary classes.

Main Classes

The following main classes are included in the C1.Silverlight.Chart.dll assembly:

· C1Chart: A full-featured charting tool that supports several chart types, built-in color palettes, and special effects including animations, zooming, and panning.

· C1ChartLegend: A companion control used to display legends that describe the data series in a C1Chart control.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Gauge.dll

ComponentOne Studio for Silverlight: Control Summary > C1.Silverlight.Gauge.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Gauge.dll

Previous Next

C1.Silverlight.Gauge.dll contains gauge controls that provide an intuitive and attractive way to display information graphically. These controls are often used in dashboard applications that display information summaries.

Main Classes

The following main classes are included in the C1.Silverlight.Gauge.dll assembly:

· C1RadialGauge: Provides a pointer that sweeps along an arc to indicate the current value. You can use the object model to add tickmarks, labels, and ranges to indicate special intervals (or customize the built-in XAML definition to create completely customized gauges).

· C1LinearGauge: Provides a linear indicator that moves along a straight path to indicate the current value. You can modify the appearance of the control using the object model or by modifying the built-in XAML definition.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Maps.dll

ComponentOne Studio for Silverlight: Control Summary > C1.Silverlight.Maps.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Maps.dll

Previous Next

C1.Silverlight.Maps.dll contains the C1Maps control which displays rich geographical information from various sources, including Microsoft Live MapsTM and Google MapsTM.

Main Classes

The following main class is included in the C1.Silverlight.Maps.dll assembly:

· C1Maps: Shows maps with rich geographical information. The control supports zooming, panning, and mapping between screen and geographical coordinates. It also supports layers that allow you to superimpose elements to the maps. The layers support item virtualization and allow you to display static elements as well as elements that are attached to geographical locations.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.RichTextBox.dll

Previous Next

C1.Silverlight.RichTextBox.dll contains the C1RichTextBox control, a full-fledged editor with a document-based architecture similar to the one used in WPF.

Main Classes

The following main classes are included in the C1.Silverlight.RichTextBox.dll assembly:

· C1RichTextBox: Control used to view and edit C1Document documents. The control can import and export Html, and supports rich formatting including fonts, foreground and background colors, borders, paragraph alignment, images, hyperlinks, lists, arbitrary UIElement objects, and more.

· C1Document: Class that represents documents as a hierarchical list of elements that represent document components such as paragraphs, lists, images, and so on. The object model exposed by the C1Document object is similar to the one used in the WPF FixedDocument class and in the Html DOM.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.RichTextBox.Toolbar.dll

Previous Next

C1.Silverlight.RichTextBox.Toolbar.dll contains the C1RichTextBoxToolbar control, a toolbar that attaches to a C1RichTextBox control and provides common formatting commands. The toolbar is packaged in a separate dll because many applications may choose to implement their own custom toolbars (or no toolbars at all) for the C1RichTextBox. These applications don’t have to deploy de standard toolbar.

Main Classes

The following main classes are included in the C1.Silverlight.RichTextBox.Toolbar.dll assembly:

· C1RichTextBoxToolbar: Toolbar control that attaches to a C1RichTextBox control and provides common formatting commands such as bold, italics, underline, font size, alignment, and so on.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.DataGrid.dll

Previous Next

C1.Silverlight.DataGrid.dll contains the C1DataGrid control, a drop-in replacement for the Microsoft DataGrid control with many additional features and integration with the controls in the C1.Silverlight.dll assembly.

Main Classes

The following main classes are included in the C1.Silverlight.DataGrid.dll assembly:

· C1DataGrid: Grid control with an object model similar to the Microsoft DataGrid, but with additional features including (1) an Excel-like filtering feature and (2) built-in specialized editors for entering and editing numeric data.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Uploader.dll

Previous Next

C1.Silverlight.Uploader.dll contains the C1Uploader class, an object that allows uploading files and streams from Silverlight applications to the server.

Main Classes

The following main classes are included in the C1.Silverlight.Uploader.dll assembly:

· C1Uploader: Allows uploading files and streams from Silverlight applications to the server. C1Uploader provides a lot of flexibility over how files are uploaded. You can upload one file per request, split large files into multiple requests, or group many small files into a single request.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Zip.dll

Previous Next

C1.Silverlight.Zip.dll contains classes that provide data compression services. In Silverlight applications, data compression is especially useful when transferring between client and server, and also when storing application data in isolated storage (which is limited to 100kb by default).

Main Classes

The following main classes are included in the C1.Silverlight.Zip.dll assembly:

· C1ZipFile: Allows you to create, edit, and manage zip files and streams. The zip format is an open standard widely used in all kinds of applications. It provides a convenient way to package any number of files and streams into a single unit that can be easily and efficiently transmitted or stored.

· C1ZStreamWriter: Writes data into a stream compressing it while writing. You can later decompress the data by reading it with a C1ZStreamReader. This class is useful in situations where you don't need a full-fledged zip file, only a single compressed stream.

· C1ZStreamReader: Reads data from a compressed stream de-compressing it while reading. The compressed stream is usually created with a C1ZStreamWriter.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Data.dll

Previous Next

C1.Silverlight.Data.dll contains classes that implement lightweight versions of the familiar classes in the System.Data namespace (DataSet, DataTable, and so on). These classes allow you to build data-centric Silverlight application using the same logic you have been using in ASP.NET and WinForms applications. In many cases, you will be able to reuse most of the server side code.

Main Classes

The following main classes are included in the C1.Silverlight.Data.dll assembly:

· DataSet: Analogous to the System.Data.DataSet class. This class represents an in-memory cache of data, and provides methods for persisting the data as XML so it can be exchanged between client and server. The actual data is stored in DataTable objects, accessible through the Tables property.

· DataTable: Analogous to the System.Data.DataTable class. This class contains columns that represent database fields and rows that represent the data items.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Quick Start

ComponentOne Studio for Silverlight: Quick Start | Search Helpcentral Search HelpCentral

Quick Start

Previous Next

This section will help you get started quickly with the controls in ComponentOne Studio for Silverlight. We will walk you through the process of creating a Silverlight application and then adding ComponentOne Studio controls to it.

The application is called QuickStart. When finished, it will show several panels, each one demonstrating one control in the C1.Silverlight assembly. (The finished application is included in the Samples folder.)

In order to follow the tutorial, you will need Visual Studio 2008 and the latest Silverlight 2.0 SDK, which you can download from http://silverlight.net/GetStarted/.

This section focuses on the ComponentOne controls only. For general help on getting started with Silverlight, we recommend the following resources:

1) http://www.silverlight.net
The official Silverlight site, with many links to downloads, samples, tutorials, and more.

2) http://silverlight.net/learn/tutorials.aspx
Silverlight tutorials by Jesse Liberty. Topics covered include:
Tutorial 0: The Roadmap
Tutorial 1: Controls
Tutorial 2: Data-binding
Tutorial 3: Styles and Templates
Tutorial 4: Accessing data from a SQL database
Tutorial 5: User Controls

3) http://weblogs.asp.net/scottgu/pages/silverlight-posts.aspx
Scott Guthrie's Silverlight Tips, Tricks, Tutorials and Links Page

4) http://weblogs.asp.net/scottgu/archive/2008/02/22/first-look-at-silverlight-2.aspx
An excellent eight-part tutorial by Scott Guthrie, covering the following topics:
Part 1: Creating "Hello World" with Silverlight 2 and VS 2008
Part 2: Using Layout Management
Part 3: Using Networking to Retrieve Data and Populate a DataGrid
Part 4: Using Style Elements to Better Encapsulate Look and Feel
Part 5: Using the ListBox and DataBinding to Display List Data
Part 6: Using User Controls to Implement Master/Details Scenarios
Part 7: Using Templates to Customize Control Look and Feel
Part 8: Creating a Digg Desktop Version of our Application using WPF

5) http://blogs.msdn.com/corrinab/archive/2008/03/11/silverlight-2-control-skins.aspx
A practical discussion of skinning Silverlight controls and applications by Corrina Barber.

Create a Project that Uses the C1.Silverlight Controls

C1.Silverlight.dll

C1.Silverlight.Extended.dll

C1.Silverlight.RichTextBox.dll

C1.Silverlight.Uploader.dll

C1.Silverlight.Gauge.dll

C1.Silverlight.Maps.dll

C1.Silverlight.Chart.dll

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create a Project that Uses the C1.Silverlight Controls

ComponentOne Studio for Silverlight: Quick Start > Create a Project that Uses the C1.Silverlight Controls | Search Helpcentral Search HelpCentral

Create a Project that Uses the C1.Silverlight Controls

Previous Next

In this first project, we will create an empty Silverlight solution that references the C1.Silverlight controls and provides a scrollable area that we will later populate with controls.

Sample Available

The complete QuickStart project is included in the samples that ship with ComponentOne Studio for Silverlight.

The purpose of this application is to show how to instantiate the controls in ComponentOne Studio for Silverlight and how to use their basic functionality. The application does not demonstrate the advanced features in the controls. Those features are demonstrated in the other samples included with the package.

Create a New Silverlight Project

Add References to the C1.Silverlight Assemblies

Create the Initial Page Layout

Create Styles

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create a New Silverlight Project

ComponentOne Studio for Silverlight: Quick Start > Create a Project that Uses the C1.Silverlight Controls > Create a New Silverlight Project | Search Helpcentral Search HelpCentral

Create a New Silverlight Project

Previous Next

To get started with ComponentOne Studio for Silverlight, start by opening Visual Studio 2008 and creating a new Silverlight project named "QuickStart":

5. Select File | New | Project to open the New Project dialog box in Visual Studio 2008.

6. In the Project types pane, expand either the Visual Basic or Visual C# node and select Silverlight.

7. Choose Silverlight Application in the Templates pane.

8. Name the project "QuickStart", specify a location for the project, and click OK.

Next, Visual Studio will prompt you for the type of hosting you want to use for the new project.

9. In the Add Silverlight Application dialog box, select Web Application Project from the Project Type drop-down box. Select OK to accept the default name ("QuickStartWeb") and create the project.

The solution you just created will contain two projects, QuickStart and QuickStartWeb:

· QuickStart: This is the Silverlight application proper. It will produce a XAP file that gets downloaded to the client and runs inside the Silverlight plug-in.

· QuickStartWeb: This is the host application. It runs on the server and provides support for the Silverlight application.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Add References to the C1.Silverlight Assemblies

ComponentOne Studio for Silverlight: Quick Start > Create a Project that Uses the C1.Silverlight Controls > Add References to the C1.Silverlight Assemblies | Search Helpcentral Search HelpCentral

Add References to the C1.Silverlight Assemblies

Previous Next

In this topic you'll add references to the ComponentOne Studio for Silverlight assemblies which will allow you to add the ComponentOne controls to the page. Complete the following steps to add references to the ComponentOne Silverlight assemblies:

1. Right-click the QuickStart project in the Solution Explorer and select Add Reference.

2. In the Add Reference dialog box, locate and select the following assemblies and click OK to add references to your project:

· C1.Silverlight.dll

· C1.Silverlight.Extended.dll

· C1.Silverlight.RichTextBox.dll

· C1.Silverlight.Uploader.dll

· C1.Silverlight.Gauge.dll

· C1.Silverlight.Chart.dll

· C1.Silverlight.Maps.dll

Note: The default install location for the ComponentOne assemblies is
C:\Program Files\ComponentOne\Studio for Silverlight\bin\

The QuickStart application will demonstrate all the ComponentOne controls, so we will add references to all C1.Silverlight assemblies. Most applications will use only a few of the controls and should reference only the DLLs required.

After adding references, the solution should look like this:

After adding the references, you can create ComponentOne Silverlight controls in C# code and also in Microsoft Expression Blend.

In Blend

If you create the controls in Blend, it will add a namespace statement to the XAML, similar to this:

xmlns:C1_Silverlight="clr-namespace:C1.Silverlight;assembly=C1.Silverlight"

In most applications, you would let Blend create the namespace statements for you as needed. To simplify later steps of our QuickStart application, we will add all the namespaces at once (and use namespaces that are shorter than the default ones created by Blend):

<UserControl x:Class="QuickStart.Page"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:c1="clr-namespace:C1.Silverlight;assembly=C1.Silverlight"

xmlns:c1x="clr-namespace:C1.Silverlight.Extended;assembly=C1.Silverlight.Extended"

xmlns:c1t="clr-namespace:C1.Silverlight.RichTextBox;assembly=C1.Silverlight.RichTextBox"

xmlns:c1g="clr-namespace:C1.Silverlight.Gauge;assembly=C1.Silverlight.Gauge"

xmlns:c1m="clr-namespace:C1.Silverlight.Maps;assembly=C1.Silverlight.Maps"

xmlns:c1c="clr-namespace:C1.Silverlight.Chart;assembly=C1.Silverlight.Chart"

>

Once these statements are added to the page, you can use the specified prefixes to create the objects in each assembly. For example:

<StackPanel>
  <c1:C1ComboBox />   <!-- C1.Silverlight.dll -->
  <c1x:C1Book />      <!-- C1.Silverlight.Extended.dll -->
  <c1m:C1Maps />      <!-- C1.Silverlight.Maps.dll -->
</StackPanel>
Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create the Initial Page Layout

ComponentOne Studio for Silverlight: Quick Start > Create a Project that Uses the C1.Silverlight Controls > Create the Initial Page Layout | Search Helpcentral Search HelpCentral

Create the Initial Page Layout

Previous Next

Now we have an application that consists of a blank page. To start adding content to the page, we have three options:

· Code: Open the Page.xaml.cs file and create the application using code. This is an easy way to quickly create test applications, but is not normally used for real Silverlight development.

· Visual Studio: Use the Visual Studio designer to edit the Page.xaml file by typing some XAML code and seeing the results in the preview window. This is possible but not practical. The Visual Studio designer is slow and limited, and is suited only for minor modifications to the XAML code.

· Expression Blend: Create the page using Microsoft Expression Blend. This is the preferred way of creating Silverlight and WPF applications.

We will choose the third option, Expression Blend. Complete the following to open and setup the project in Blend:

1. In Visual Studio, right-click the Page.xaml file in the Solution Explorer and select Open in Expression Blend. This will bring up the project in Blend.

Because the project contains references to the ComponentOne Silverlight assemblies, the ComponentOne controls will be available from within Blend. You can design the page, adding controls and setting their properties. When you are happy with the design, closing Blend will take you back to Visual Studio where you can add code and debug the application.

2. In Blend, add the following XAML to your project:

<Grid x:Name="LayoutRoot" Background="White">

<ScrollViewer>

<StackPanel x:Name="_mainPanel" Margin="6" >

<TextBlock Text="Content will go here" />

</StackPanel>

</ScrollViewer>

</Grid>

We want to create a scrollable area where we will later add several C1.Silverlight controls to experiment with. If you are familiar with Blend, you can instead use the control palette to add a ScrollViewer to the page and then a StackPanel within the ScrollViewer. This is much easier to do than to describe step by step, so we'll take a shortcut here and provide the XAML code (you can paste the above into the Blend XAML editor).

3. Close Blend and run the application from within Visual Studio.

It's not very interesting at this point, but if you do run it, notice how the Silverlight plug-in automatically resizes to fill the page. As the plug-in resizes, the content within it also resizes to fill it. This is the default behavior when you don't specify the panel dimensions explicitly.

In step 2 above, you may have noticed that we assigned a name to the StackPanel element. Any element that is given a name can be referred to from code, if desired. Otherwise the elements are usually left unnamed.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create Styles

ComponentOne Studio for Silverlight: Quick Start > Create a Project that Uses the C1.Silverlight Controls > Create Styles | Search Helpcentral Search HelpCentral

Create Styles

Previous Next

In this tutorial you'll create many similar elements, one for each control type. Instead of formatting each one independently, you can create some styles that can be applied to all elements. This will save some work and, more importantly, will make it easier to modify the appearance of the application later.

Add the following XAML to define the styles that you'll use:

<UserControl x:Class="QuickStart.Page"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

...>

<UserControl.Resources>

<Style x:Key="ControlBorder" TargetType="Border">

<Setter Property="BorderThickness" Value="3" />

<Setter Property="Background" Value="#FFC2F5CB" />

<Setter Property="BorderBrush" Value="#FF257004" />

<Setter Property="CornerRadius" Value="6" />

<Setter Property="Margin" Value="5" />

<Setter Property="Padding" Value="5" />

</Style>

<Style x:Key="ControlTitle" TargetType="TextBlock">

<Setter Property="FontSize" Value="14" />

<Setter Property="HorizontalAlignment" Value="Center" />

<Setter Property="FontFamily" Value="Courier New" />

<Setter Property="FontWeight" Value="Bold" />

<Setter Property="Foreground" Value="#FF1F6900" />

</Style>

</UserControl.Resources>

<Grid x:Name="LayoutRoot" Background="White">

...

Note that Silverlight (and WPF) Styles are just collections of property names and values. Each member of the collection specifies a value to be applied to a property. They don't necessarily have to be visual properties at all.

To see what the styles we just created look like, modify the content of the _mainPanel element so it appears as follows:

<StackPanel x:Name="_mainPanel" Margin="6" >
<Border Style="{StaticResource ControlBorder}" >
<StackPanel>
<TextBlock Text="Control Name" Style="{StaticResource ControlTitle}" />
<TextBox Width="200"/>
</StackPanel>
</Border>
</StackPanel>

You can see the effect of the changes right in Visual Studio:

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.dll

Previous Next

The C1.Silverlight.dll is the core assembly in the ComponentOne Studio for Silverlight. It implements all the basic controls that are necessary in most applications but are not part of Silverlight itself.

C1ComboBox

C1MaskedTextBox

C1NumericBox

C1Menu

C1Window

C1MessageBox

C1TreeView

C1HyperPanel

C1DragDropManager

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1ComboBox

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1ComboBox | Search Helpcentral Search HelpCentral

C1ComboBox

Previous Next

In this step, we will add some C1ComboBox controls to the application. To do so, complete the following steps:

1. In Visual Studio's Solution Explorer, right-click the Page.xaml file and select Open in Expression Blend.

2. In Blend, click the Asset Library button [image] (the double chevron button that appears last in the toolbar). The Asset Library dialog box will open.

3. In the Asset Library dialog box, select the Custom Controls tab. Notice that the C1.Silverlight controls appear on the list. That happens because the project has a reference to the C1.Silverlight.dll assembly.

4. Click the C1ComboBox control in the Asset Library dialog box. This will add the C1ComboBox to the toolbox, right above the Asset Library button.

5. Double-click the _mainPanel item in the Objects and Timeline pane to make it the default container.

6. Double-click the C1ComboBox in the toolbox. This will add a new C1ComboBox to the page, as a child of the _mainPanel.

Rather than repeat these steps for the other elements we want to add to the page, in the next step we'll just give you the revised section of XAML that you can paste directly into Blend.

7. Update the XAML within mainPanel so it appears like the following:

<StackPanel x:Name="_mainPanel" Margin="6" >

<!-- C1ComboBox -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1ComboBox" Style="{StaticResource ControlTitle}" />

<c1:C1ComboBox x:Name="_cmb1" Width="200" />

<c1:C1ComboBox x:Name="_cmb2" Width="200" />

</StackPanel>

</Border>

</StackPanel>

We added a TextBlock element to work as a header and two C1ComboBox elements named _cmb1 and _cmb2. The names are important because we will reference these controls from code.

8. Close Blend and return to Visual Studio. We will now add some code to populate the combo boxes.

9. In Visual Studio, double-click the Page.xaml.cs file and add the following using statements:

using System.Diagnostics;

using System.Reflection;

using C1.Silverlight;

using C1.Silverlight.RichTextBox;

using C1.Silverlight.Extended;

using C1.Silverlight.Uploader;

using C1.Silverlight.Maps;

using C1.Silverlight.Chart;

using QuickStart;

10. Add the following code to the page constructor to initialize the C1ComboBox controls:

public Page()

{

InitializeComponent();

// Initialize the C1ComboBoxes

_cmb1.IsEditable = false;

_cmb1.SelectedItemChanged += _cmb_SelectedItemChanged;

PopulateCombo(_cmb1);

_cmb2.IsEditable = true;

_cmb2.SelectedItemChanged += _cmb_SelectedItemChanged;

PopulateCombo(_cmb2);

}

11. Add the following code right below the constructor to add the SelectedItemChanged event handler and the PopulateCombo method:

void _cmb_SelectedItemChanged(object sender, PropertyChangedEventArgs<object> e)

{

C1ComboBox cmb = sender as C1ComboBox;

Debug.WriteLine("SelectedItemChanged on {0}: new value is '{1}'", cmb.Name, cmb.Text);

}

void PopulateCombo(C1ComboBox cmb)

{

foreach (PropertyInfo pi in cmb.GetType().GetProperties())cmb.Items.Add(pi.Name);

}

The code is straightforward. For each combo, it simply adds some strings to the Items collection and attaches a handler to the SelectedItemChanged event.

12. Run the project to see the C1ComboBox in action.

Notice how both combos provide auto-completion, but only the bottom one allows you to enter items that are not on the list. Check the Visual Studio output window to see when the SelectedItemChanged event fires.

This is the simplest way to populate and use C1ComboBox controls. But you can do a lot more with the C1ComboBox by using data templates and binding. We will cover these more advanced topics in later sections.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1MaskedTextBox

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1MaskedTextBox | Search Helpcentral Search HelpCentral

C1MaskedTextBox

Previous Next

In this step, we will add some C1MaskedTextBox controls to the application. The C1MaskedTextBox allows you to display and edit formatted string values. The Mask property is used to specify which type of character is allowed at each position.

To add the new controls, add the following code to the Page.xaml file, right after the last Border element:

<!-- C1MaskedTextBox -->

<Border Style="{StaticResource ControlBorder}">

<StackPanel>

<TextBlock Text="C1MaskedTextBox" Style="{StaticResource ControlTitle}" />

<c1:C1MaskedTextBox Width="200"

Watermark="Phone Number" Mask="(999) 000-0000"/>

<c1:C1MaskedTextBox Width="200"

Watermark="Short Date" Mask="00/00/0000"/>

<c1:C1MaskedTextBox Width="200"

Watermark="Social Security Number" Mask="000-00-0000"/>

</StackPanel>

</Border>

That's all we need to demonstrate the C1MaskedTextBox. Notice the following:

· The C1MaskedTextBox supports a Watermark property. This makes it easy to prompt the user for the type of information that is expected.

· The Mask property uses the same syntax as the MaskedTextBox control in WinForms. This makes it easier to re-use masks across applications and platforms.

· Formatting this new block was easy; we simply re-used the styles defined earlier. A designer could take this XAML file and modify the styles very easily, without touching the controls themselves.

If you run the application now and type into the C1MaskedTextBox controls, you will notice that only valid characters are accepted at each position.

The Text property of the C1MaskedTextBox exposes the control's full content. The Value property exposes only the values typed by the user, excluding template characters specified in the Mask. For example, if the Mask property is set to "99-99" and the control contains the string "55-55", the Text property would return "55-55" and the Value property would return "5555".

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1NumericBox

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1NumericBox | Search Helpcentral Search HelpCentral

C1NumericBox

Previous Next

In this step, we will add some C1NumericBox controls to the application. The C1NumericBox allows you to display and edit formatted numeric values.

To add the new controls, add the following code to the Page.xaml file, right after the last Border element:

<!-- C1NumericBox -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1NumericBox" Style="{StaticResource ControlTitle}" />

<c1:C1NumericBox Width="200"

Format="F2" Value="3.1416" />

<c1:C1NumericBox Width="200"

Format="#,##0.00" Increment="100"

Value="3.1416" />

<c1:C1NumericBox Width="200"

Format="F2" Value="3.1416" ShowButtons="False"

AllowNull="True" Watermark="No value specified" />

</StackPanel>

</Border>

The main properties in the C1NumericBox control are Value and Format.

The Value property contains the value being edited represented as a double. The control fires the ValueChanged event when the value of this property changes.

The Format property is used to format the value for display in the control. It specifies the number of decimal places and whether thousand separators should be used. The Format property is specified using the same format strings used by the .NET framework. For example, "F2" displays the value as a floating point number with two decimals, and "#,##0.0000" displays the value with a thousand separator and four decimal places. Note that not all formats are supported (for example, percentages, hexadecimals, scientific notation and multi-part formats). If you try to use an unsupported format, the control will throw an exception.

Other useful properties include:

· Increment: Determines the amount added or removed from the value when the user clicks the up/down buttons in the control or when the up/down keys are pressed.

· MaximumValue/MinimumValue: Constrains the value to a specified range.

· ShowButtons: Determines whether the up/down buttons should be displayed.

· AllowNull: Determines whether the control should allow the user to clear the entire content of the control. In this case, the Value property is set to double.NaN, which indicates the value is null.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Menu

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1Menu | Search Helpcentral Search HelpCentral

C1Menu

Previous Next

The C1Menu is a control that allows hierarchical organization of elements associated with event handlers. The C1Menu control is similar to the Menu control in WPF. You can create and populate it entirely in XAML, and that is how we will get started.

1. Add the following code to the Page.xaml file, right after the last Border element:

<!-- C1Menu -->

<Border Style="{StaticResource ControlBorder}">

<StackPanel>

<TextBlock Text="C1Menu" Style="{StaticResource ControlTitle}" />

<c1:C1Menu x:Name="_menu" Width="Auto" Height="40" >

<c1:C1MenuItem Header="File" >

<c1:C1MenuItem Header="New" >

<c1:C1MenuItem Header="Project" />

<c1:C1MenuItem Header="File" />

</c1:C1MenuItem>

<c1:C1MenuItem Header="Open" />

</c1:C1MenuItem>

<c1:C1MenuItem Header="Edit" >

<c1:C1MenuItem Header="Cut" />

<c1:C1MenuItem Header="Copy" />

<c1:C1MenuItem Header="Test" />

</c1:C1MenuItem>

<c1:C1MenuItem Header="Window" >

<c1:C1MenuItem Header="Floating" IsCheckable="True" />

<c1:C1MenuItem Header="Dockable" IsCheckable="True" />

</c1:C1MenuItem>

</c1:C1Menu>

</StackPanel>

</Border>

We just added a new C1Menu control to the page, with three first-level menu items and some submenus.

If you run the sample now, you will notice that the new control only shows the top-level menu items and allows you to open its associated submenus by clicking on them. It also supports keyboard navigation.

There are some practical applications where you won't be able to create the whole C1Menu at design time. For example, many applications have a "Recent Files" submenu, where the files that were recently open are listed; that data is not available at design time.

2. To populate a C1Menu using code, open the Page.xaml.cs file and add the following code to the page constructor:

public Page()

{

InitializeComponent();

// No changes here.

// ...

// Initialize the C1Menu

InitializeMenu();

}

3. Add the following code to implement the InitializeMenu method:

private void InitializeMenu()

{

// Remove items that were added at design time.

_menu.Items.Clear();

// Create File menu.

C1MenuItem fileMenu = new C1MenuItem();

fileMenu.Header = "File";

CreateSubMenu("New", fileMenu);

CreateSubMenu("Open", fileMenu);

CreateSubMenu("Add", fileMenu);

CreateSubMenu("Close", fileMenu);

CreateSubMenu("Save", fileMenu);

CreateSubMenu("Save As", fileMenu);

CreateSubMenu("Save All", fileMenu);

// Create Window menu when the page loads.

C1MenuItem windowMenu = new C1MenuItem();

windowMenu.Header = "Window";

windowMenu.Loaded += windowMenuLoaded;

// Populate main menu.

_menu.Items.Add(fileMenu);

_menu.Items.Add(windowMenu);

}

private void CreateSubMenu(string header, C1MenuItem parent)

{

C1MenuItem menuItem = new C1MenuItem();

menuItem.Header = header;

parent.Items.Add(menuItem);

}

These methods create two first-level menus: File and Window, then add some submenus to the File menu through its Items collection.

Instead of populating the Window menu directly, the code above hooks up a handler to the Loaded event. The code in the next step illustrates how you can populate menus in response to events (such as when a file is opened for example).

4. Add the following code to illustrate populating menus in response to events:

void windowMenuLoaded(object sender, RoutedEventArgs e)

{

C1MenuItem windowMenu = sender as C1MenuItem;

windowMenu.ItemsSource = GetSubmenus();

}

private IList<object> GetSubmenus()

{

List<object> menuList = new List<object>(10);

for (int i = 0; i < 10; i++)

{

C1MenuItem menuItem = new C1MenuItem();

menuItem.Header = "Submenu " + i;

menuList.Add(menuItem);

}

return menuList;

}

This implementation creates some dummy submenus in a for loop. In a real application, the GetSubmenus method would retrieve a list of recently used files from isolated storage or from the server.

5. Now run the application to see the C1Menu in action.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Window

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1Window | Search Helpcentral Search HelpCentral

C1Window

Previous Next

The C1Window control shows content in a floating window within the Silverlight plug-in.

C1Window objects are not children of any elements on the page. Because of this, they are defined in separate XAML files whose root element is a C1Window object.

To create a new C1Window object, complete the following:

1. Right-click the project in the Visual Studio Project Explorer and select the Add | New Item option.

2. Pick the Silverlight User Control option and name the new control "MyWindow".

3. Open the MyWindow.xaml file and make sure it contains this XAML:

<c1:C1Window x:Class="QuickStart.MyWindow"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:c1="clr-namespace:C1.Silverlight;assembly=C1.Silverlight"

Width="400" Height="300">

<Grid x:Name="LayoutRoot" Background="White">

<TextBlock Text="We can put any control inside the window" />

</Grid>

</c1:C1Window>

This is a simple window; it contains only a Grid and a TextBlock. But you can edit this file in Blend and add any elements you want. Creating and maintaining C1Window objects is very easy.

4. In the Solution Explorer, double-click the MyWindow.xaml.cs file to open it and add the following using statement to the top of the page:

using C1.Silverlight;

5. Modify the MyWindow.xaml.cs file to make the MyWindow class inherit from C1Window:

public partial class MyWindow : C1Window

{

public MyWindow()

{

InitializeComponent();

}

}

6. Return to the main Page.xaml file.

Now that the C1Window object is ready, we will go back to the main project and add two buttons to the main page. Clicking the buttons will show the C1Window, either as a modeless window or as a dialog window.

7. Add the following to the Page.xaml file, just below the last Border element:

<!-- C1Window -->

<Border Style="{StaticResource ControlBorder}">

<StackPanel>

<TextBlock Text="C1Window" Style="{StaticResource ControlTitle}" />

<Button Click="OpenWindow" Width="300" Content="Open window (modeless)" />

<Button Click="ShowDialog" Width="300" Content="Open window (modal)" />

</StackPanel>

</Border>

Note that the XAML above specifies event handlers for the Click event of each button; in the next step you'll add the event handlers.

8. Open the Page.xaml.cs file and add the following event handlers:

void OpenWindow(object sender, RoutedEventArgs e)

{

var window = new MyWindow();

window.CenterOnScreen();

window.Show();

}

void ShowDialog(object sender, RoutedEventArgs e)

{

var window = new MyWindow();

window.CenterOnScreen();

window.ShowModal();

}

9. Run the project and click the buttons to see the C1Windows.

You can drag the window by its caption bar as well as maximize, restore, and close it using the system buttons.

You can open as many modeless windows as you want, but only one modal window at a time.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1MessageBox

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1MessageBox | Search Helpcentral Search HelpCentral

C1MessageBox

Previous Next

The C1MessageBox class is similar to the MessageBox classes in WPF and WinForms. It provides an easy way to display a message to the user and optionally ask a simple question.

The C1MessageBox class is a handy time-saver so you don't have to create C1Window objects for performing this simple task.

To see how it works, complete the following:

1. Add the following XAML below the last Border element in the Page.xaml file:

<!-- C1MessageBox -->

<Border Style="{StaticResource ControlBorder}">

<StackPanel>

<TextBlock Text="C1MessageBox" Style="{StaticResource ControlTitle}" />

<Button Click="ShowMessageBox" Width="300" Content="Show C1MessageBox" />

</StackPanel>

</Border>

2. And add the following code to the Page.xaml.cs file:

void ShowMessageBox(object sender, RoutedEventArgs e)

{

C1MessageBox.Show("To be, or not to be?", "The question",

C1MessageBoxButton.YesNoCancel,

C1MessageBoxIcon.Question,

MessageBoxResult);

}

void MessageBoxResult(C1MessageBoxResult result)

{

switch (result)

{

case C1MessageBoxResult.Yes:

C1MessageBox.Show("You are!");

break;

case C1MessageBoxResult.No:

C1MessageBox.Show("You are not!");

break;

case C1MessageBoxResult.Cancel:

C1MessageBox.Show("OK, I won't ask again ;-)");

break;

}

}

3. Run your project and click the button.

Notice that the first call to C1MessageBox uses all the available parameters. It's possible to customize the message, title, buttons, and the icon to be displayed. There are overloads available that allow you to omit most of these parameters.

Notice also that the Show method is asynchronous. Instead of waiting until the message box is dismissed and then returning a value, the method calls a delegate that is supposed to handle the result. In this example, the delegate is the MessageBoxResult method listed above.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1TreeView

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1TreeView | Search Helpcentral Search HelpCentral

C1TreeView

Previous Next

We will now add a C1TreeView control to the application. The C1TreeView control is similar to the TreeView control in WPF.

You can create and populate it entirely in XAML, and that is how we will get started. Complete the following steps:

1. Add the following XAML to the Page.xaml file, right after the last Border element:

<!-- C1TreeView -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1TreeView" Style="{StaticResource ControlTitle}" />

<c1:C1TreeView x:Name="_tv" Width="400" Height="300" >

<c1:C1TreeViewItem Header="Item 1" >

<c1:C1TreeViewItem Header="Item 1.1" />

<c1:C1TreeViewItem Header="Item 1.2" />

</c1:C1TreeViewItem>

<c1:C1TreeViewItem Header="Item 2" >

<c1:C1TreeViewItem Header="Item 2.1" />

<c1:C1TreeViewItem Header="Item 2.2" />

<c1:C1TreeViewItem Header="Last Item" />

</c1:C1TreeViewItem>

</c1:C1TreeView>

</StackPanel>

</Border>

This is all it takes to add a new C1TreeView control to the page, complete with two top-level nodes and some child nodes.

If you run the sample now, you will notice that the new control allows you to collapse and expand nodes by clicking on them as you would expect. It also supports the keyboard for navigation, expanding and collapsing nodes, and auto-searching.

2. Open the Page.xaml.cs file and add the following to the page constructor to populate a C1TreeView using code:

public Page()

{

InitializeComponent();

// No changes here.

// ...

// Initialize the C1TreeView

InitializeTreeView();

}

In most practical applications, you won't be able to populate the C1TreeView at design time. The control is normally used to display hierarchical data that is not available at design time.

3. Now add the implementation of the InitializeTreeView method:

void InitializeTreeView()

{

// Remove items that were added at design time

_tv.Items.Clear();

// Scan every type in the assembly

foreach (Type t in _tv.GetType().Assembly.GetTypes())

{

if (t.IsPublic && !t.IsSpecialName && !t.IsAbstract)

{

// Add node for this type

C1TreeViewItem node = new C1TreeViewItem();

node.Header = t.Name;

node.FontWeight = FontWeights.Bold;

_tv.Items.Add(node);

// Add subnodes for properties, events, and methods

node.Items.Add(CreateMemberNode("Properties", t, MemberTypes.Property));

node.Items.Add(CreateMemberNode("Events", t, MemberTypes.Event));

node.Items.Add(CreateMemberNode("Methods", t, MemberTypes.Method));

}

}

}

C1TreeViewItem CreateMemberNode(string header, Type type, MemberTypes memberTypes)

{

C1TreeViewItem node = new C1TreeViewItem();

node.Header = header;

return node;

}

This first version of the code enumerates the types in the C1.Silverlight.dll assembly and adds one node for each type. Each of these nodes has three child nodes that will contain the properties, events, and methods declared by the type.

The code does not fill the sub-nodes yet, so if you run the sample you will see all the types but none of their members. Instead of fully populating each node when the application starts, we will implement a technique called "delayed loading", where nodes are populated on demand, when the user expands them. This allows the application to load faster and use resources more efficiently (maybe the user is interested in one type only, so we will never even load the information for the types the user is not interested in).

4. To implement the delayed loading nodes, replace the CreateMemberNode code above with this implementation:

C1TreeViewItem CreateMemberNode(string header, MemberTypes memberTypes)

{

// Create the node

C1TreeViewItem node = new C1TreeViewItem();

node.Header = header;

node.Foreground = new SolidColorBrush(Colors.DarkGray);

// Hook up event hander to populate the node before expanding it

node.Expanding += node_Expanding;

// Save information needed to populate the node

node.Tag = memberTypes;

// Add a dummy node so this node can be expanded

node.Items.Add(new C1TreeViewItem());

node.IsExpanded = false;

// Finish

return node;

}

This implementation hooks up an event hander for the Expanding event, so we can populate the node when the user tries to expand it. We also save the information we will need to populate the node in the Tag property. Finally, we add a dummy child node so the user will be able to expand this node and trigger the Expanding event that will populate the node.

Note that instead of using the Tag property, we could also have derived a custom class from C1TreeViewNode and built all the delay-load logic into that class. This would be a more elegant approach, but unfortunately Silverlight doesn't support template inheritance. If you derive a class from a class that has a template (such as Button or C1TreeViewNode), the template is not inherited, and you have to provide a template yourself or your derived class will be just an empty control. This seems to be a bug in Silverlight; hopefully it will be corrected before the final release.

5. Finally, add the following code to actually populate the node. The code below only gets called once for each node, when the user expands the node for the first time:

void node_Expanding(object sender, RoutedEventArgs e)

{

// Get the node that fired the event

C1TreeViewItem node = sender as C1TreeViewItem;

// Unhook event handler (we'll populate the node and be done with it)

node.Expanding -= node_Expanding;

// Remove dummy node

node.Items.Clear();

// Populate the node

Type type = (Type)node.Parent.Tag;

MemberTypes memberTypes = (MemberTypes)node.Tag;

BindingFlags bf = BindingFlags.Public | BindingFlags.Instance;

foreach (MemberInfo mi in type.GetMembers(bf))

{

if (mi.MemberType == memberTypes)

{

if (!mi.Name.StartsWith("get_") && !mi.Name.StartsWith("set_"))

{

C1TreeViewItem item = new C1TreeViewItem();

item.Header = mi.Name;

item.FontSize = 12;

node.Items.Add(item);

}

}

}

}

6. Run the application to see the C1TreeView in action.

You will notice that it loads quickly, since the child nodes are not created until you expand an object node to see its properties, methods, or events. When each node is expanded the first time, you may notice a short delay as the node is populated. Expanding and collapsing the node after that happens instantaneously.

Notice that you can use the keyboard to navigate the tree and to search for items. You can also use the AllowDragDrop property to enable automatic drag-and-drop support within the tree, so users can drag items into new positions. The image below shows the C1TreeView control during a drag-and-drop operation. The item being dragged is shown in its selected state, and the exact drop location is highlighted with a horizontal bar.

This sample barely scratches the surface of the C1TreeView control. The distribution package includes more specific samples that show advanced features.

Every node header is a ContentControl, which means you can easily add elements such as images and checkboxes to the node headers.

You can use the ItemsSource property to bind the control to your data. You can use DataTemplates to define the visual representation of each item. And you can use template selectors to create different visuals for each type of element on the tree. For example, you could have parent nodes display product categories with images and complete descriptions, and subnodes that display products with prices and stock availability.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1HyperPanel

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1HyperPanel | Search Helpcentral Search HelpCentral

C1HyperPanel

Previous Next

The C1HyperPanel is a similar to a StackPanel, except it applies a dynamic zoom effect to elements that are closer to the mouse.

To demonstrate the C1HyperPanel, we will define two instances of it in the Page.xaml file. Complete the following steps:

1. Add the following code just below the last Border element:

<!-- C1HyperPanel -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1HyperPanel" Style="{StaticResource ControlTitle}" />

<c1:C1HyperPanel x:Name="_hp1" Orientation="Horizontal"

HorizontalAlignment="Center" Margin="8"

Distribution="0.4" />

<c1:C1HyperPanel x:Name="_hp2" Orientation="Horizontal"

HorizontalAlignment="Center" Margin="8"

Distribution="0.1" MinElementScale="0.2" ApplyOpacity="False" />

</StackPanel>

</Border>

This code creates two empty panels named _hp1 and _hp2, and initializes their main properties:

· Distribution is a value between zero and one that determines how much zooming should be applied when the mouse moves over the panel. Smaller values cause a more pronounced zoom factor.

· MinElementScale determines the minimum scale factor that is applied to elements that are far from the mouse. When Distribution is set to a small value, you may want to set this property to a value greater than zero to prevent elements from being scaled down to zero.

· ApplyOpacity determines whether elements away from the mouse should also be made semi-transparent, adding to the distance effect.

The values used here cause the top panel to apply a moderate zoom factor. The second panel applies a more pronounced zoom factor, and prevents elements from becoming too small by setting the MinElementScale property.

2. Open the Page.xaml.cs file and add this code to the page constructor:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

// ...

// Initialize the C1HyperPanels

FillHyperPanel(_hp1);

FillHyperPanel(_hp2);

}

Instead of populating the panels in the XAML file, we will do it in code.

3. Next, add the FillHyperPanel method below the page constructor:

void FillHyperPanel(C1HyperPanel hp)

{

for (double p = 0; p <= 1; p+= 0.05)

{

// Create Color

byte red = (byte)(255 * p);

byte green = (byte)((red + 255/3) % 255);

byte blue = (byte)((green + 255 / 3) % 255);

Color c = Color.FromArgb(255, red, green, blue);

// Create Rectangle element

Rectangle r = new Rectangle();

r.Fill = new SolidColorBrush(c);

r.Width = r.Height = 30;

r.Margin = new Thickness(2);

r.RadiusX = r.RadiusY = 4;

r.Stroke = new SolidColorBrush(Colors.Black);

r.StrokeThickness = 1;

r.VerticalAlignment = VerticalAlignment.Bottom;

// Add rectangle to C1HyperPanel

hp.Children.Add(r);

}

}

4. Run the project and scroll to the bottom of the main panel.

Move the mouse over the two C1HyperPanels to see the dynamic zooming effect. Note that the rectangles are aligned along the bottom of the panels, honoring the setting of their VerticalAlignment property. The effect is similar to the one seen in the Apple Macintosh toolbar.

You can achieve interesting variations by modifying the value of the Distribution and MinElementScale properties.

Note that you can add any UIElement object to a C1HyperPanel, including any type of control. You can use the C1HyperPanel as a toolbar for example, or as a stack panel that can display a large number of elements without resorting to scrollbars.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1DragDropManager

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.dll > C1DragDropManager | Search Helpcentral Search HelpCentral

C1DragDropManager

Previous Next

The C1DragDropManager is a class that provides drag- drop services on behalf of other elements. It is not a control and has no visual representation at design time.

The C1DragDropManager class follows the patterns found in the WinForms drag-and-drop implementation. It provides a DoDragDrop method that is called to initiate the drag-and-drop operations, and fires events that allow you to customize the whole process (DragStart, DragEnter, DragOver, DragLeave, DragDrop).

The event parameters provide information on what item is being dragged (e.DragSource) and where it is about to be dropped (e.DropTarget). The event handlers are responsible for checking this information and setting the value of the e.Effect parameter to indicate whether the operation is valid or not. The handler for the DragDrop event is responsible for actually moving or copying the source element to the target location.

The C1DragDropManager class also provides two helper methods that simplify the whole process. The methods are called RegisterDragSource and RegisterDropTarget. They provide a simple generic implementation that handles most common drag-and-drop scenarios with very little code. Once you have registered elements as sources and targets with these methods, the C1DragDropManager will monitor the mouse to automatically initiate and manage the drag-and-drop operation. In this case, all you have to do is handle the DragDrop event to perform the move or copy operation.

To demonstrate the C1DragDropManager, we will add a Grid with some child elements to the page. Later, we will use a C1DragDropManager to allow users to drag elements from one grid cell to another. Complete the following steps:

1. Add the following XAML to the Page.xaml file, below the last Border element:

<!-- C1DragDropManager (new in M3) -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1DragDropManager (NEW)"
Style="{StaticResource ControlTitle}" />

<Grid x:Name="_ddGrid" Background="LightGray" ShowGridLines="True"
Width="400" Height="300">

<Grid.RowDefinitions>

<RowDefinition/><RowDefinition/>

<RowDefinition/><RowDefinition/>

<RowDefinition/><RowDefinition/>

</Grid.RowDefinitions>

<Grid.ColumnDefinitions>

<ColumnDefinition/><ColumnDefinition/>

<ColumnDefinition/><ColumnDefinition/>

<ColumnDefinition/><ColumnDefinition/>

</Grid.ColumnDefinitions>

<TextBlock Text="Drag Me" Grid.Row="1" Grid.Column="2" />

<TextBlock Text="Or Me" Grid.Row="3" Grid.Column="4" />

<Rectangle Fill="Red" Grid.Row="2" Grid.Column="0"/>

<Rectangle Fill="Blue" Grid.Row="0" Grid.Column="4"/>

</Grid>

</StackPanel>

</Border>

2. Open the Page.xaml.cs file and add the following code to the page constructor:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

//...

// Initialize the C1DragDropManager

C1DragDropManager dd = new C1DragDropManager();

dd.RegisterDropTarget(_ddGrid, true);

foreach (UIElement e in _ddGrid.Children)

{

dd.RegisterDragSource(e, DragDropEffect.Move, ModifierKeys.None);

}

dd.DragDrop += dd_DragDrop;

}

The code starts by instantiating a new instance of a C1DragDropManager. Then it calls the RegisterDropTarget method to indicate that the grid should act as a drop target by default. It also calls the RegisterDragSource method to indicate that users should be allowed to drag the elements in the grid. Finally, the code attaches an event handler to the DragDrop event so the application can receive a notification and move the element being dragged into its new position.

3. Add the following code to create the DragDrop event handler:

void dd_DragDrop(object source, DragDropEventArgs e)

{

// Get mouse position

Point pMouse = e.GetPosition(_ddGrid);

// Translate into grid row/col coordinates

int row, col;

Point pGrid = new Point(0, 0);

for (row = 0; row < _ddGrid.RowDefinitions.Count; row++)

{

pGrid.Y += _ddGrid.RowDefinitions[row].ActualHeight;

if (pGrid.Y > pMouse.Y)

break;

}

for (col = 0; col < _ddGrid.ColumnDefinitions.Count; col++)

{

pGrid.X += _ddGrid.ColumnDefinitions[col].ActualWidth;

if (pGrid.X > pMouse.X)

break;

}

// Move the element to the new position

e.DragSource.SetValue(Grid.RowProperty, row);

e.DragSource.SetValue(Grid.ColumnProperty, col);

}

The event handler starts by converting the mouse coordinates into row/column values. Then it uses the SetValue method to update the Grid.RowProperty and Grid.ColumnProperty values on the element that was dragged. Similar logic could be used to drag elements within other types of panel or list-type controls, or from one panel to another.

4. Run the project.

You should be able to drag the Rectangle and TextBlock objects from one grid cell to another. The image below shows the drag process in action. The extra border around the first TextBlock shows that it is the element being dragged, and the transparent rectangle follows the mouse and shows where the element will be dropped.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Extended.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Extended.dll

Previous Next

The C1.Silverlight.Extended.dll provides additional controls that leverage Silverlight to display information in visually appealing, unusual ways. The controls are less common than the ones found in the core assembly (C1.Silverlight.dll).

C1Expander

C1Accordion

C1ImageRotator

C1ImageMagnifier

C1HtmlHost

C1Book

C1Cube

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Expander

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1Expander | Search Helpcentral Search HelpCentral

C1Expander

Previous Next

The C1Expander control has a header and a single content. The content can be expanded and collapsed by clicking on the header. The C1Expander control is similar to the WPF Expander class.

To view an example, add the following XAML to the Page.xaml file below the last Border element:

<!-- C1Expander -->
<Border Style="{StaticResource ControlBorder}">
  <StackPanel>
    <TextBlock Text="C1Expander" Style="{StaticResource ControlTitle}" />

    <!-- Simplest expander, show content below header -->
    <c1x:C1Expander Margin="2"
      HeaderFontWeight="Bold"
      Header="Click me"
      Content="Collapsible Content" />

    <!-- Show content to the right of the header -->
    <c1x:C1Expander Margin="2"
      ExpandDirection="Right"
      HeaderFontWeight="Bold"
      Header="Click me"
      Content="Collapsible Content" />

    <!-- Show content above header, add red border around the header -->
    <c1x:C1Expander Margin="2"
      ExpandDirection="Up"
      Content="Collapsible content">
      <c1x:C1Expander.Header>
        <Border BorderThickness="2" BorderBrush="Red">
          <TextBlock Text="Click Me!"/>
        </Border>
      </c1x:C1Expander.Header>
    </c1x:C1Expander>

    <!-- Show content to the left of the header -->
    <c1x:C1Expander Margin="2"
      ExpandDirection="Left"
      HeaderFontWeight="Bold"
      Header="Click Me!"
      Content="Collapsible Content" />

  </StackPanel>
</Border>

The C1Expander can be configured to expand in four directions using the ExpandDirection property. The default ExpandDirection is Down, so we don't need to specify it in the first C1Expander.

C1Expander is a C1HeaderedContentControl, so its Font and Content properties work exactly like their counterparts in a ContentControl.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Accordion

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1Accordion | Search Helpcentral Search HelpCentral

C1Accordion

Previous Next

The C1Accordion is an ItemsControl where each item is shown inside a C1Expander control and only one is allowed to be expanded at a time.

To see a C1Accordion in action, complete the following steps:

1. Add the following XAML to the Page.xaml file, below the last Border element:

<!-- C1Accordion -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Accordion" Style="{StaticResource ControlTitle}" />

<StackPanel Orientation="Horizontal">

<!-- Traditional accordion (items expand below headers) -->

<c1x:C1Accordion Height="200" Fill="True" Margin="10"

AllowCollapseAll="False">

<c1x:C1Expander

Header="Beverages"

Content="Tea, Coffee, Milk"/>

<c1x:C1Expander

Header="Dairy"

Content="Milk, Cheese, Cream"/>

<c1x:C1Expander

Header="Desserts"

Content="Pies, Fruit, Ice-cream"/>

</c1x:C1Accordion>

<!-- Horizontal data-bound accordion -->

<c1x:C1Accordion x:Name="templatedAccordion" Margin="10"

ExpandDirection="Right">

<c1x:C1Accordion.ItemTemplate>

<DataTemplate>

<!-- Root must be a C1Expander -->

<c1x:C1Expander Header="{Binding Key}" Content="{Binding Value}" />

</DataTemplate>

</c1x:C1Accordion.ItemTemplate>

</c1x:C1Accordion>

</StackPanel>

</StackPanel>

</Border>

The first C1Accordion in the code shows how items can be added to the C1Accordion in XAML. Notice how AllowCollapseAll is set to False. This means that one C1Expander will be expanded at all times. If we didn't set that property, the user would be able to collapse all items.

Also notice that we set the Fill property set to True. This causes the C1Accordion to fill all the space available. If we didn't set this property, the C1Accordion would automatically resize to fit its content.

The second C1Accordion demonstrates two additional properties, ExpandDirection and ItemTemplate.

ExpandDirection indicates the direction where the C1Expander items expand. The default is Down, which causes content to be displayed below each header. Other options are the same as in the C1Expander control. In this case, we set the property to Right, causing items to expand in the horizontal direction.

Because C1Accordion inherits from ItemsControl, you can add objects of any data type to its Items collection and use a DataTemplate to create a visual representation of the items (in this case, the root of the DataTemplate must be a C1Expander object). The XAML above creates C1Expander objects and binds the Header and Content properties of each element to properties called Key and Value.

2. In order to populate the second C1Accordion, add the following code to the page's constructor in the Page.xaml.cs file:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

// ...

// Initialize the C1Accordion

PopulateAccordion();

}

void PopulateAccordion()

{

for (int i = 1; i <= 4; i++)

{

string key = string.Format("Key {0}", i);

string value = string.Format("This is value {0}", i);

templatedAccordion.Items.Add(

new KeyValuePair<string, string>(key, value));

}

}

3. Run the project.

If you run the project now, you will see the second accordion populated by KeyValuePair instances.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1ImageRotator

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1ImageRotator | Search Helpcentral Search HelpCentral

C1ImageRotator

Previous Next

The C1ImageRotator control provides a pseudo 3D effect used for displaying images with a perspective transformation and optional image reflection, similar to the effect seen in Apple's iTunes application.

Note that the C1ImageRotator control can only display images, not arbitrary UIElement objects. This limitation is imposed by the lack of a VisualBrush class in Silverlight (like the one in WPF).

Also note that the C1ImageRotator will size itself automatically to fit the image and angle it is displaying. As you rotate a 200 pixel-wide image from zero to 60 degrees, the control width will decrease from 200 to 100 pixels. If you rotate it to 90 degrees, the width will become zero. This makes it easy to fill a StackPanel with C1ImageRotators set to arbitrary angles and have them fill up the stack with no empty gaps between them. Setting the control's Width and Height properties to explicit values disables this auto-sizing behavior.

To demonstrate the C1ImageRotator, start by adding some images to the application. Complete the following steps:

1. Right-click the QuickStart project node in the project explorer and select the Add | Existing Item option.

2. Select five images and add them to the project. Name the images "cover1.jpg", "cover2.jpg", and so on until "cover5.jpg".

3. Select the newly added images and make sure the BuildAction property is set to Resource. The image below shows what the project should look like after you add the images:

4. Once you've added the images to the project, add the following XAML snippet to the Page.xaml file, below the last Border element:

<!-- C1ImageRotator -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1ImageRotator" Style="{StaticResource ControlTitle}" />

<StackPanel x:Name="_spRotator" Orientation="Horizontal"

HorizontalAlignment="Center" Margin="0,30,0,30">

<c1x:C1ImageRotator Source="cover1.jpg" Angle="-70" />

<c1x:C1ImageRotator Source="cover2.jpg" Angle="-45" />

<c1x:C1ImageRotator Source="cover3.jpg" Angle="0" />

<c1x:C1ImageRotator Source="cover4.jpg" Angle="45" />

<c1x:C1ImageRotator Source="cover5.jpg" Angle="70" />

</StackPanel>

</StackPanel>

</Border>

This XAML is enough to show the five images in a layout similar to the one in iTunes. The next step is to add code that will allow users to select an item by clicking on it. The selected item should be displayed flat, and the ones around it should be more rotated the further they are from the selected one.

Open the Page.xaml.cs file and add the code below to the Page constructor:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

//...

// Initialize the C1ImageRotators

InitializeImageRotators();

UpdateImageRotation(2);

}

The InitializeImageRotators method adds a few extra images to the panel (just to make the sample more visually appealing), then attaches an event handler to each C1ImageRotator in order to select it when the user clicks it with the mouse. Here is the implementation:

void InitializeImageRotators(StackPanel sp)

{

// Add a few extra image rotators

StackPanel sp = _spRotator;

int cnt = sp.Children.Count;

for (int i = 0; i < cnt; i++)

{

C1ImageRotator ir = new C1ImageRotator();

ir.UriSource = ((C1ImageRotator)sp.Children[i]).UriSource;

sp.Children.Add(ir);

}

// Attach event handlers to all image rotators

foreach (C1ImageRotator ir in sp.Children)

{

ir.ShowReflection = true;

ir.MouseLeftButtonDown += ir_MouseLeftButtonDown;

}

}

void ir_MouseLeftButtonDown(object sender, MouseButtonEventArgs e)

{

// Update rotations around the item that was clicked

C1ImageRotator ir = sender as C1ImageRotator;

int index = _spRotator.Children.IndexOf(ir);

UpdateImageRotation(index);

}

The only piece still missing is the code that will rotate all the covers when the user clicks one:

void UpdateImageRotation(int selectedIndex)

{

// Rotate all images in the stack panel

for (int i = 0; i < _spRotator.Children.Count; i++)

{

int delta = i - selectedIndex;

C1ImageRotator ir = _spRotator.Children[i] as C1ImageRotator;

double angle = Math.Sqrt(Math.Abs(delta)) * 45 * Math.Sign(delta);

ir.Angle = Math.Max(-90, Math.Min(90, angle));

ScaleTransform st = new ScaleTransform();

st.CenterX = st.CenterY = 0.5;

st.ScaleX = st.ScaleY = 1 + 0.15 / (1.0 + Math.Abs(delta));

ir.RenderTransform = st;

ir.SetValue(Canvas.ZIndexProperty, 1000 - Math.Abs(delta));

}

}

The code loops through the C1ImageRotator objects in the panel and applies a rotation and scale that are proportional to the difference between the element's index and the currently selected index.

If you run the application now, you will see that the effect is pretty similar to the one seen in iTunes. The main difference is that the rotations happen instantly, instead of with a smooth animation effect. To improve the application, you could create a Storyboard and use it to modify the Angle and Scale property on each element instead of changing the values directly. That is left as an exercise for the reader (or check out the SilverTunes sample).

Notice how the reflections "spill out" of the control boundaries. That is by design; they are intended to look like real reflections, not as part of the main image. Any UIElement can do this simply by setting its Clip property to null.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1ImageMagnifier

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1ImageMagnifier | Search Helpcentral Search HelpCentral

C1ImageMagnifier

Previous Next

The C1ImageMagnifier control is similar to an Image element with a 'magnifying glass' over it. The portion of the image under the magnifying glass is zoomed. The user can move the magnifying glass over the image to easily zoom in on any part of the image, and he can use the keyboard to change the zoom factor.

C1ImageMagnifier is useful in situations where you have a high-resolution image and want to allow users to zero-in on important details. It is a simple alternative to a deep zoom image.

Fo an example of C1ImageMagnifier, add the following XAML to the Page.xaml file below the last Border element:

<!-- C1ImageMagnifier (new in M4) -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock
Text="C1ImageMagnifier (C1.Silverlight.Extended)"
Style="{StaticResource ControlTitle}" />

<c1x:C1ImageMagnifier
Width="400"
Height="200" Source="cover2.jpg"
Zoom="2"
/>

</StackPanel>

</Border>

If you run the project now, the C1ImageMagnifier will look like the image below. You can drag the magnifying glass with the mouse to see the details of the album cover. You can also use the arrow keys to move the magnifier over the image, and the plus/minus keys to change the zoom factor.

You can customize the appearance of the magnifying glass using the Zoom property, which gets or sets the current zoom factor, and the Magnifier property, which returns a reference to the Border element that holds the zoomed image.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1HtmlHost

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1HtmlHost | Search Helpcentral Search HelpCentral

C1HtmlHost

Previous Next

The C1HtmlHost control behaves like an HMTL iFrame tag, and allows you to show HTML content within your Silverlight pages. This is a reversal of the typical scenario, where Silverlight plug-ins are islands in the HTML that makes up the page. The C1HtmlHost control allows you to create HTML islands in your Silverlight pages.

This concept is useful because in many cases your Silverlight applications may want to display existing HTML content within the Silverlight plug-in itself (as opposed to controlling elements in the host page's DOM, which Silverlight also allows).

For an example, add the following XAML to the Page.xaml file below the last Border element:

<!-- C1HtmlHost -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1HtmlHost" Style="{StaticResource ControlTitle}" />

<c1x:C1HtmlHost Width="400" Height="20"

SourceHtml="This is &lt;b&gt;HTML&lt;/b&gt; hosted in a Browser!"/>

<c1x:C1HtmlHost Width="400" Height="200"

SourceUri="http://www.componentone.com" />

</StackPanel>

</Border>

Populating C1HtmlHost

The C1HtmlHost can be populated in two ways:

· Use the SourceHtml property to specify an HMTL string that should be displayed in the control. This option is useful if your application builds or loads the HTML content.

· Use the SourceUri property to specify the URL that will be displayed in the control. This option is useful if your application needs to display content that is already available at a given URL.

The C1HtmlHost control has an important requirement. In order to display the HTML content within the Silverlight plug-in, the plug-in must have its Windowless property set to True. If you run the application now, you will see an error message that explains this:

Note: To use this control the Silverlight plug-in must have its Windowless parameter set to True.

The control cannot modify the properties of the plug-in, the page author must do that instead. To make the necessary change, open the page that creates the plug-in (in our case QuickStartTextPage.aspx, which is part of the QuickStartWeb project) and add a line to set the Windowless property to True:

<%@ Page Language="C#" AutoEventWireup="true" %>

<%@ Register
Assembly="System.Web.Silverlight"
Namespace="System.Web.UI.SilverlightControls"
TagPrefix="asp" %>

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

<html xmlns="http://www.w3.org/1999/xhtml" style="height:100%;">

<head runat="server">

<title>ComponentOne Studio for Silverlight QuickStart</title>

</head>

<body style="height:100%;margin:0;">

<form id="form1" runat="server" style="height:100%;">

<asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>

<div style="height:100%;">

<asp:Silverlight

ID="Xaml1"

runat="server"

Windowless="true"

Source="~/ClientBin/QuickStart.xap"

Version="2.0" Width="100%" Height="100%" />

</div>

</form>

</body>

</html>

If you run the project now, you should see the HTML content hosted within the Silverlight page:

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Book

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1Book | Search Helpcentral Search HelpCentral

C1Book

Previous Next

The C1Book control presents UIElement objects as if they were pages in a book. You can see two elements at a time and turn the pages with the mouse, just as you would turn pages in a regular paper book.

The C1Book is an ItemsControl, so you can define it entirely in XAML, including its contents.

To see an example of C1Book, following XAML to the Page.xaml file, right after the last Border element on the page:

<!-- C1Book (new in M3) -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Book (NEW, C1.Silverlight.Extended)"
Style="{StaticResource ControlTitle}" />

<c1x:C1Book x:Name="_book" Width="500" Height="300" >

<!-- Template for left pages -->

<c1x:C1Book.LeftPageTemplate>

<ControlTemplate>

<Border BorderThickness="1,1,2,2"
BorderBrush="Gray"
Background="WhiteSmoke">

<StackPanel Margin="10,10,25,10">

  <TextBlock Text="C1Book Sample"
FontSize="9"
Margin="0,0,0,10" HorizontalAlignment="Left"
/>

<ContentPresenter /> <!-- content goes here -->

</StackPanel>

</Border>

</ControlTemplate>

</c1x:C1Book.LeftPageTemplate>

<!-- Template for right pages -->

<c1x:C1Book.RightPageTemplate>

<ControlTemplate>

  <Border BorderThickness="1,1,2,2"
BorderBrush="Gray"
Background="White">

<StackPanel Margin="25,10,15,10">

  <TextBlock Text="C1.Silverlight.Extended.dll"
FontSize="9"
HorizontalAlignment="Right" Margin="0,0,0,10" />

<ContentPresenter /> <!-- Content goes here -->

</StackPanel>

</Border>

</ControlTemplate>

</c1x:C1Book.RightPageTemplate>

<!-- book content: each element is a page -->

<TextBlock Text="This is Page 1"/>

<TextBlock Text="This is Page 2"/>

<TextBox Text="This is Page 3 (type here)" AcceptsReturn="True"/>

<Button Content="This is Page 4 (click it)"/>

<Image Source="cover1.jpg" />

<Image Source="cover2.jpg" />

<Image Source="cover3.jpg" />

<Image Source="cover4.jpg" />

<TextBlock Text="This is the last page..."/>

</c1x:C1Book>

</StackPanel>

</Border>

This is a fair amount of XAML, but the C1Book control itself only required one line.

After declaring the C1Book, the XAML defines two templates (LeftPageTemplate and RightPageTemplate). These templates are optional. If present, they are used to determine how the content should be laid out within each page, and should contain a ContentPresenter element that determines where the actual content will be displayed.

In this sample, we use the templates to apply a border, margins, and a simple header to each page.

After the templates comes the content of each page in the book. These are just regular elements, which may include controls, images, videos, even other C1Book elements.

If you run the application now, you should be able to browse through the pages by flipping them with the mouse.

The C1Book control has a CurrentPage property that gets or sets the index of the page that is currently being displayed. Setting this property displays the selected page immediately, without any animations. To turn pages with animation, use the TurnPage method.

The C1Book control also has properties that determine whether it should show shadows on each page (ShowInnerShadows, ShowOuterShadows) and on the page corners when the mouse passes over them (ShowFold).

By default, the first page is displayed on the left side, the second on the right, and so on. This prevents the control from being half empty when showing the first page. You can change this behavior by setting the IsFirstPageOnTheRight property to true. In this case, the first page is displayed on the right side of the control, as the cover of a closed book.

C1Book is an ItemsControl, which allows you to bind it to data sources. As usual, each item in the data source can be a UIElement or a generic object that gets converted into a UIElement using templates.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Cube

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Extended.dll > C1Cube | Search Helpcentral Search HelpCentral

C1Cube

Previous Next

The C1Cube control allows you to attach UIElement objects to faces on a rotating cube. The control provides methods for rotating the cube in order to display specific elements, or you can allow users to spin the cube with the mouse.

C1Cube is an ItemsControl, so you can define it entirely in XAML, including its contents. Complete the following steps:

1. Add the following XAML to the Page.xaml file, right after the last Border element on the page:

<!-- C1Cube (new in M3) -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Cube" Style="{StaticResource ControlTitle}" />

<c1x:C1Cube x:Name="_cube" Margin="5" Width="200" Height="200" >

<Image Source="cover1.jpg" c1x:C1Cube.Face="Front" />

<Image Source="cover2.jpg" c1x:C1Cube.Face="Back" />

<Image Source="cover3.jpg" c1x:C1Cube.Face="Left" />

<Image Source="cover4.jpg" c1x:C1Cube.Face="Right" />

<Image Source="cover5.jpg" c1x:C1Cube.Face="Top" />

<Button Content="Click Me ;-)" c1x:C1Cube.Face="Bottom" />

</c1x:C1Cube>

<Button Content="Next Face..." Click="Button_Click" Width="200"/>

</StackPanel>

</Border>

This XAML creates and populates the C1Cube and adds a button below it with an event handler that turns the cube to show the next face.

2. Open the Page.xaml.cs file and add the following code to implement the event handler:

int _currentFace = 0;

private void Button_Click(object sender, RoutedEventArgs e)

{

_cube.ShowFace((CubeFace)(++_currentFace % 6));

}

The code defines a variable to keep track of the face currently being displayed and calls the ShowFace method to show the next face each time the button is clicked.

This sample uses the cube as container for other controls, somewhat similar to a tab or a wizard. Each tab or wizard page corresponds to a cube face, and the cube rotates only to switch from one face to another.

If you set the IsDraggable property to True, users can rotate the cube with the mouse. However, in this case the content presented on the cube faces will no longer receive the mouse events.

Finally, you can take complete control over the cube rotation in code, using the RotationX, RotationY, and RotationZ properties. For example, you could use these properties to create a cube that spins continuously, displaying your company logo.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.RichTextBox.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.RichTextBox.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.RichTextBox.dll

Previous Next

C1.Silverlight.RichTextBox.dll contains a single control, the C1RichTextBox.

The C1RichTextBox provides rich editing including multiple fonts and colors, images, lists, hyperlinks, per-paragraph alignment, HTML import and export.

In addition to rich formatting, the C1RichTextBox provides automatic line wrapping and several types of HTML export (with CSS style sheets, inline styles, or simple tags only).

The latest version of the C1RichTextBox control has a document-oriented architecture similar to the one found in WPF. The control has a Document property that gets or sets the C1Document object displayed in the control. C1Document objects can be persisted as HTML documents, and can also be created and manipulated in code using a rich object model.

C1RichTextBox

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1RichTextBox

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.RichTextBox.dll > C1RichTextBox | Search Helpcentral Search HelpCentral

C1RichTextBox

Previous Next

In this step, we will add a C1RichTextBox control to the application. In order to demonstrate the control, we will also add a small toolbar so users can change the style of the selected text.

To keep the sample short and simple, we will expose only the bold, italic, and underline properties of the selected text (the control supports many other styles and attributes). Complete the following steps:

1. Add the following XAML to the Page.xaml file, right after the last Border element on the page:

<!-- C1RichTextBox -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1RichTextBox" Style="{StaticResource ControlTitle}" />

<StackPanel Orientation="Horizontal" Width="400" >

<ToggleButton x:Name="_btnBold" Padding="4,0,4,0"

Content="B" FontWeight="Bold"/>

<ToggleButton x:Name="_btnItalics" Padding="4,0,4,0"

Content="I" FontStyle="Italic"/>

<ToggleButton x:Name="_btnUnderline" Padding="4,0,4,0"

Content="U" TextDecorations="Underline"/>

</StackPanel>

<c1t:C1RichTextBox x:Name="_rtb"

Width="400" Height="100" TextWrapping="Wrap"

Html="This is a &lt;b&gt;C1RichTextBox&lt;/b&gt; control."/>

</StackPanel>

</Border>

Note that the content of the C1RichTextBox can be specified in two ways. The Text property is used to assign and retrieve the control content as plain text. The Html property is used to assign and retrieve formatted text as HTML. The HTML text needs to be encoded in the XAML file, so instead of <b> for bold, tags are encoded as &lt;b&gt;.

The C1RichTextBox exposes a TextWrapping property that specifies whether the control should wrap long lines or whether it should keep the lines together and provide a horizontal scrollbar instead.

Now that the controls have been defined, we need to add some code to handle the buttons.

2. Open the Page.xaml.cs file in Visual Studio and add the following code to the page constructor to handle the buttons:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

//...

// Initialize the C1RichTextBox

_btnBold.Click += _btnBold_Click;

_btnItalics.Click += _btnItalics_Click;

_btnUnderline.Click += _btnUnderline_Click;

_rtb.SelectionChanged += _rtb_SelectionChanged;

}

The new code attaches event handlers to each button in the toolbar (so the styles can be applied to the C1RichTextBox) and to the SelectionChanged event on the C1RichTextBox (so we can toggle the buttons to reflect the formatting of the current selection).

3. Open the Page.xaml.cs file and add the following code to add the event handlers to the Page class:

void _btnBold_Click(object sender, RoutedEventArgs e)

{

if (_btnBold.IsChecked.HasValue)

{

_rtb.Selection.FontWeight = _btnBold.IsChecked.Value

? FontWeights.Bold

: FontWeights.Normal;

}

}

void _btnItalics_Click(object sender, RoutedEventArgs e)

{

if (_btnItalics.IsChecked.HasValue)

{

_rtb.Selection.FontStyle = _btnItalics.IsChecked.Value

? FontStyles.Italic

: FontStyles.Normal;

}

}

void _btnUnderline_Click(object sender, RoutedEventArgs e)

{

if (_btnUnderline.IsChecked.HasValue)

{

_rtb.Selection.TextDecorations = _btnUnderline.IsChecked.Value

? TextDecorations.Underline

: null;

}

}

These event handlers execute when the user clicks one of the Bold, Italic, or Underline buttons. They all start by checking whether the button's IsChecked property has a value (it may be in a mixed state). If the button has a value, it is applied to the corresponding property of the editor's Selection. Selection is a property of the C1RichTextBox control that allows you to modify the content and style of the current selection.

These handlers take care of button clicks. But we also want to change the state of the buttons as the user changes the selection. For example, if he selects some text that is bold, we would like the Bold button to appear pressed automatically.

4. Add the following event handler:

void _rtb_SelectionChanged(object sender, EventArgs e)

{

// Get current selection

var sel = _rtb.Selection;

// Update state of bold button

FontWeight? fw = sel.FontWeight;

if (fw.HasValue)

_btnBold.IsChecked = fw.Value == FontWeights.Bold;

else

_btnBold.IsChecked = null;

// Update state of italics button

FontStyle? fs = sel.FontStyle;

if (fs.HasValue)

_btnItalics.IsChecked = fs.Value == FontStyles.Italic;

else

_btnItalics.IsChecked = null;

// Update state of underline button

TextDecorationCollection td = sel.TextDecorations;

_btnUnderline.IsChecked = td != null;

}

The code starts by getting a reference to the Selection object. It then checks the value of the style properties that correspond to each button and updates their state to reflect the state of the current selection.

Note that the Bold and Italic buttons can be in three states (if the selection contains mixed states, the button is put is an undefined state). This is accomplished easily because the corresponding properties in the selection (FontWeight and FontStyle) return nullable values. The Underline button, however, is never put in an undefined state. This is because the TextDecorations property returns an object, and there is no way to differentiate between a "null" that indicates there are no decorations and a "null" that indicates the selection is in a mixed state. It would be easy to work around this small limitation in a real application, but the behavior described is good enough for this sample.

5. Run the sample again to see the C1RichTextBox in action, along with its fully functional (albeit simple) toolbar:

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Uploader.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Uploader.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Uploader.dll

Previous Next

C1.Silverlight.Uploader.dll contains a single component, the C1Uploader.

The C1Uploader component uploads files and streams from Silverlight applications running on the client to the server.

C1Uploader

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Uploader

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Uploader.dll > C1Uploader | Search Helpcentral Search HelpCentral

C1Uploader

Previous Next

To see the C1Uploader in action, complete the following steps:

1. Add the following XAML below the last Border element in the Page.xaml file:

<!-- C1Uploader -->

<Border Style="{StaticResource ControlBorder}">

<StackPanel>

<TextBlock Text="C1Uploader" Style="{StaticResource ControlTitle}" />

<StackPanel Orientation="Horizontal" Height="250">

<Button Content="Upload Photos..." Height="30"

VerticalAlignment="Top" Margin="5"

Click="Upload_Click" />

<ScrollViewer Width="400" Margin="5" Background="White">

<StackPanel x:Name="_spPictures" />

</ScrollViewer>

</StackPanel>

</StackPanel>

</Border>

This creates a button that the user will click in order to upload image files to the server, and a panel where the images will be displayed.

2. Add the event handler below to the Page.xaml.cs file, below all the other methods in the Page class:

private void Upload_Click(object sender, RoutedEventArgs e)

{

// Configure OpenFileDialog

OpenFileDialog dlg = new OpenFileDialog();

dlg.Filter = "All|*.*|Images|*.jpg;*.png;*.gif";

dlg.FilterIndex = 2;

dlg.Multiselect = true;

// Show OpenFileDialog

if ((bool)dlg.ShowDialog())

{

try

{

// Check that the files really are images

foreach (FileDialogFileInfo fdi in dlg.SelectedFiles)

{

System.Windows.Media.Imaging.BitmapImage img =

new System.Windows.Media.Imaging.BitmapImage();

img.SetSource(fdi.OpenRead());

}

}

catch

{

C1MessageBox.Show(

"Sorry, at least one of these files doesn't look like an image...",

"Upload Canceled",

C1MessageBoxButton.OK, C1MessageBoxIcon.Warning);

return;

}

// Create and configure uploader

Uri uri = BuildAbsoluteUri("photoUpload.ashx");

C1Uploader uploader = new C1UploaderPost(uri);

uploader.UploadProgressChanged += uploader_UploadProgressChanged;

uploader.UploadCompleted += uploader_UploadCompleted;

// Upload selected files

uploader.AddFiles(dlg.SelectedFiles);

uploader.BeginUploadFiles();

}

}

The event handler starts by showing an OpenFileDialog to the user so he can select the files that will be uploaded. Silverlight runs in a secure sandbox environment, and you can't get direct access to the file system. But the OpenFileDialog class grants access to specific files explicitly selected by the user. You can also get access to files in the IsolatedStorage area.

Once the files have been selected, the code checks that the files really are images. It does this by creating BitmapImage objects and loading the files into the objects. If the file does not contain an image, then an exception is thrown and the process is aborted. This check prevents users from uploading files of the wrong type, either by mistake or with malicious intent. Later, we will also perform a similar security check on the server.

After the files have been validated, the code creates a new C1UploaderPost object. There are two types of C1Uploader object, the C1UploaderPost and C1UploaderWebService. The difference between the two is how files are received on the server. C1UploaderPost uses a multipart POST protocol that is very easy to use, as you will see below.

3. Add the following code to your project:

public static Uri BuildAbsoluteUri(string relativeUri)

{

// Get current absolute Uri; this depends on where the app is deployed

Uri uri = System.Windows.Browser.HtmlPage.Document.DocumentUri;

string uriString = uri.AbsoluteUri;

// Replace page name with relative service Uri

int ls = uriString.LastIndexOf('/');

uriString = uriString.Substring(0, ls + 1) + relativeUri;

// Return new Uri

return new Uri(uriString, UriKind.Absolute);

}

The C1UploaderPost constructor requires a parameter that specifies the Uri of the handler that will process the files on the server. Silverlight requires an absolute Uri, so the code uses a helper method called BuildAbsoluteUri that works whether the application is running on a development machine or on a production server.

The code also attaches event handlers to the UploadProgressChanged and UploadCompleted events of the new C1UploaderPost. We will use the first to check the progress of the upload process, and the second to display the files that were uploaded.

4. Add the following code to your project:

void uploader_UploadProgressChanged(object sender,

C1.Silverlight.Uploader.UploadProgressChangedEventArgs e)

{

Debug.WriteLine("uploaded {0} of {1} bytes, {2}%",

e.BytesUploaded,

e.TotalBytesToUpload,

e.ProgressPercentage);

}

void uploader_UploadCompleted(object sender, UploadCompletedEventArgs e)

{

if (e.Success)

{

foreach (string fileName in e.Files)

{

// Holder for picture and title

StackPanel picHolder = new StackPanel();

picHolder.Background = new SolidColorBrush(Colors.LightGray);

picHolder.Margin = new Thickness(10);

picHolder.Width = 200;

// Create Image to show the picture

System.Windows.Media.Imaging.BitmapImage bmp =

new System.Windows.Media.Imaging.BitmapImage();

bmp.UriSource = BuildAbsoluteUri("Pictures/" + fileName);

Image img = new Image();

img.Source = bmp;

img.Margin = new Thickness(10, 10, 10, 0);

picHolder.Children.Add(img);

// Create image title

TextBlock tb = new TextBlock();

tb.Text = fileName;

tb.FontSize = 12;

tb.HorizontalAlignment = HorizontalAlignment.Center;

tb.Margin = new Thickness(10, 0, 10, 10);

picHolder.Children.Add(tb);

// Add picture holder to panel

_spPictures.Children.Add(picHolder);

}

}

else

{

Debug.WriteLine("Upload failed: {0}",

e.Error != null ? e.Error.Message : "??");

}

}

The code checks that the upload was successful, and then loops through the files to create a new Image element for each one. The Image elements are configured to show the images, assuming they are stored under a "Pictures" folder on the server.

If you run the project now and try to upload some pictures, you will get an error. That is because the C1Uploader is sending files to the server, but we haven't implemented the server code yet.

5. To implement the server part of the code, right-click the QuickStartWeb solution in the Visual Studio Solution Explorer and select the Add | New Item option.

6. In the Add New Item dialog box, select the Generic Handler template and name the new class "photoUpload.ashx" (this is the Uri we used when creating the C1Uploader object earlier).

7. Click Add to add the file to your project and close the Add New Item dialog box.

8. Open the photoUpload.ashx file and replace the default implementation of the ProcessRequest method with the following code:

public void ProcessRequest(HttpContext context)

{

const int MAXFILES = 30;

// Clean up

string path = context.Request.MapPath("Pictures");

string[] files = System.IO.Directory.GetFiles(path);

if (files.Length >= MAXFILES)

{

foreach (string fileName in files)

System.IO.File.Delete(fileName);

}

// Get files being uploaded

for (int i = 0; i < context.Request.Files.Count && i < MAXFILES; i++)

{

HttpPostedFile file = context.Request.Files[i];

try

{

// Check that it really is an image by loading it into an Image object

System.Drawing.Image img =

System.Drawing.Image.FromStream(file.InputStream);

// Save file to the Pictures folder

string fileName = context.Request.MapPath("Pictures/" + file.FileName);

file.SaveAs(fileName);

}

catch

{

// Doesn't look like a valid image, skip request

break;

}

}

}

The code starts by cleaning up the images folder in case there are more than 30 images in it. A real application would do this differently, possibly by compressing old images or enforcing a per-user storage limit.

After the clean-up, the code loops through the files in the context.Request.Files collection and checks that they really are image files. We already added a similar check when implementing the server part of the code, but it is important to protect both ends of the application.

Finally, the code saves each image into the "Pictures" folder. This is a good time to create the Pictures folder under the QuickStartWeb application's main folder.

9. To create the Pictures folder, right-click the QuickStartWeb application in the Solution Explorer and select New Folder. Name the folder "Pictures".

After you create the Pictures folder, you have to set up its permissions so the application can save the pictures into the folder.

10. To se the permissions for the Pictures folder, complete the following:

1. Right-click the Pictures folder and select Properties.

2. Click the Security tab.

3. Make sure NETWORK SERVICE has Read and Write permissions checked.

4. If not then click Edit.

5. Select NETWORK SERVICE and check the boxes next to Read and Write.

6. Click Apply, then OK.

11. Run the sample now and try uploading some pictures.

Notice that you can select many pictures at a time. They will be uploaded to the server, saved in the Pictures folder, then downloaded back to the client by the Image elements that we are creating in response to the UploadCompleted event. The result is a simple picture album that looks like this:

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Gauge.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Gauge.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Gauge.dll

Previous Next

The C1.Silverlight.Gauge.dll assembly contains the C1Gauge, C1RadialGauge, and C1LinearGauge controls (C1Gauge is an abstract class that serves as a base for the other two).

Gauge controls provide an intuitive and attractive way to display information graphically. They are often used in dashboard applications that display information summaries.

The C1RadialGauge and C1LinearGauge controls have properties that provide extensive customization without requiring any changes to the XAML template.

C1RadialGauge and C1LinearGauge

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1RadialGauge and C1LinearGauge

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Gauge.dll > C1RadialGauge and C1LinearGauge | Search Helpcentral Search HelpCentral

C1RadialGauge and C1LinearGauge

Previous Next

To see the C1RadialGauge and C1LinearGauge controls in action, comeplet the following steps:

1. Add the following XAML below the last Border element in the Page.xaml file:

<!-- C1RadialGauge and C1LinearGauge -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Gauge (NEW, C1.Silverlight.Gauge)"
Style="{StaticResource ControlTitle}" />

<!-- Simple RadialGauge -->

<c1g:C1RadialGauge x:Name="_gauge1" Width="300" Height="250"

StartAngle="0" SweepAngle="270" Radius="0.9" Minimum="0" Maximum="270" Value="50">

<c1g:C1RadialGauge.Decorators>

<c1g:C1GaugeMark From="0" To="270" Interval="30"

ShowLabels="True" ShowMarks="True" MarkLocation="0.8"

LabelLocation="0.9" />

<c1g:C1GaugeMark From="0" To="270" Interval="5"

ShowLabels="False" ShowMarks="True" MarkLocation="0.75" />

<c1g:C1GaugeRange From="0" To="60" Location="0.4"

      StrokeThickness="0.3"
Background="#A000F000" />
<c1g:C1GaugeRange From="60" To="120" Location="0.4"

      StrokeThickness="0.3"
Background="#A0F0F000" />
<c1g:C1GaugeRange From="120" To="180" Location="0.4"

StrokeThickness="0.3" Background="#A0F0A000" />

<c1g:C1GaugeRange From="180" To="270" Location="0.4"

StrokeThickness="0.3" Background="#A0F00000" /> </c1g:C1RadialGauge.Decorators>

</c1g:C1RadialGauge>

<!-- Simple LinearGauge -->

<c1g:C1LinearGauge x:Name="_gauge2" Width="300" Height="20"
Minimum="0" Maximum="270" Value="50"/>

<!-- Slider used to set Gauge values -->

<StackPanel Orientation="Horizontal" HorizontalAlignment="Center">

<TextBlock Width="80" />

      <Slider
x:Name="_slider" Width="300" Minimum="0"
Maximum="270"
Value="50" ValueChanged="_slider_ValueChanged" />

<TextBlock x:Name="_txtGaugeValue" Width="80" Text="50"
TextAlignment="Center"/>

</StackPanel>

</StackPanel>

</Border>

This XAML adds two gauges to the page. Below the gauges, it adds a Slider used to modify the value displayed in the gauges, and and a TextBlock used to display the current value.

The first gauge is a RadialGauge, and it includes several "Decorators" that customize its appearance. The first two decorators are GaugeMark objects used to show tick marks and scale values. The remaining decorators are GaugeRange objects used to highlight ranges of values.

2. Open the Page.xaml.cs file and add the code below to implement the event hander that will be called when the user modifies the value of the Slider:

private void _slider_ValueChanged(object sender,

RoutedPropertyChangedEventArgs<double> e)

{

double value = ((Slider)sender).Value;

if (_gauge1 != null && _gauge2 != null)

{

_gauge1.Value = _gauge2.Value = value;

}

if (_txtGaugeValue != null)

{

_txtGaugeValue.Text = value.ToString("n0");

}

}

The code starts by retrieving the current value of the Slider control, then applies the value to both gauges and to the TextBlock element.

3. Run the application.

You will an image like the one below. Move the Slider to change the value and see how the gauges change also.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Maps.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Maps.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Maps.dll

Previous Next

The C1.Silverlight.Maps.dll assembly contains the C1Maps control.

The C1Maps control displays rich geographical information from various sources, including Microsoft Live MapsTM and Google MapsTM. It supports zooming, panning, and mapping between screen and geographical coordinates. It also supports layers that allow you to superimpose elements to the maps.

C1Maps

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Maps

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Maps.dll > C1Maps | Search Helpcentral Search HelpCentral

C1Maps

Previous Next

To see C1Maps in action, complete the following steps:

1. Add the following XAML to the Page.xaml file, just below the last Border element:

<!-- C1Maps -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Maps" Style="{StaticResource ControlTitle}" />

<c1m:C1Maps Width="500" Height="350"

Center="-79.924706, 40.458833"

Zoom="3"

MouseMove="C1Maps_MouseMove">

<c1m:C1MapItemsLayer>

<Ellipse Width="15" Height="15" Fill="Yellow" Opacity="0.5"

c1m:C1MapCanvas.LatLong="-79.924706, 40.458833"/>

</c1m:C1MapItemsLayer>

</c1m:C1Maps>

<TextBlock x:Name="_tbMapCoords" Width="500" Text="" />

</StackPanel>

</Border>

This XAML creates the C1Maps control and initializes its Center and Zoom properties to show the ComponentOne head office in Pittsburgh, PA. It also adds a yellow Ellipse to the C1MapsItemsLayer and positions it at the same geographical position used as the center. The ellipse is attached to that geographical position and will move with the map as the user zooms and pans with the mouse.

Finally, the code specifies a handler for the MouseMove event so we can show the coordinates under the mouse.

2. Add the following event handler to the Page.xaml.cs file:

private void C1Maps_MouseMove(object sender, MouseEventArgs e)

{

C1Maps map = sender as C1Maps;

Point p = map.ScreenToGeographic(e.GetPosition(map));

_tbMapCoords.Text = string.Format("{0:f6},{1:f6}", p.X, p.Y);

}

The code converts the mouse (screen) coordinates into geographical coordinates and shows them below the map.

3. Run your application.

You should see a display similar to the image below. You can use the mouse to drag the map to a new position and the mouse wheel to zoom in and out. As you move the mouse over the map, the current geographical coordinates are displayed below.

You can now zoom in using the mouse wheel or the zoom bar on the left. Get close enough and you will see the ComponentOne building and the new Borders store across the freeway.

C1Maps can display geographical information from several sources. By default it uses Microsoft LiveMapsTM as the source, but you can change that using the Source property, which takes an object of type MultiScaleTileSource. The following sources are included:

map1.Source = new VirtualEarthAerialSource(); // Virtual Earth Aerial

map2.Source = new VirtualEarthRoadSource(); // Virtual Earth Road

map3.Source = new VirtualEarthHybridSource(); // Virtual Earth Hybrid

map4.Source = new
GoogleMapsMapSource();
// Google Maps Road

map5.Source = new GoogleMapsSatelliteSource(); // Google Maps Satellite

The portion of the map that is currently visible is determined by the Center and Zoom properties, and by the size of the control.

The Center property is of type Point but it actually represents a geographic coordinate, in which the X property is longitude and the Y property is latitude. The user can change the value of the Center property by dragging the map with the mouse, or by using the navigator control shown on the left top corner.

The Zoom property indicates the current resolution of the map. A zoom value of 0 has the map totally zoomed out, and each increment of 1 doubles the map resolution. The user can change the value of the Zoom property using the mouse wheel, or the zoom control on the left side of the control.

C1Maps uses three coordinate systems:

· Geographic coordinates mark points in the world using latitude and longitude. This coordinate system is not Cartesian, which means the scale of the map may change as you pan.

· Logical coordinates go from 0 to 1 on each axis for the whole extent of the map, and they are easier to work with because they are Cartesian coordinates.

· Screen coordinates are the pixel coordinates of the Control relative to the top-left corner. These are useful for positioning items within the control and for handling mouse events.

C1Maps provides four methods for converting between these coordinate systems: ScreenToGeographic, ScreenToLogic, GeographicToScreen, and LogicToScreen.

In addition to the geographical information provided by the source, you can add layers of information to the map. C1Maps includes four layers by default:

· C1MapItemsLayer is the layer used to display arbitrary items, positioned geographically on the map. This layer is an ItemsControl, so it supports directly adding UIElement objects or generic data objects with a DataTemplate that can convert them into visual items.

· C1MapVirtualLayer displays items that are virtualized, so they are only present in the visual tree when they need to be displayed on the map.

· C1MapToolsLayer is the next layer, used to display tools for panning and zooming, and a scale.

· C1MapTilesLayer is the background layer where the map tiles are displayed. You normally don't have to use this layer because it is managed by C1Maps automatically.

Note: C1Maps only works in solutions that include a web site or web application project. If you use it in a standalone, single-project Silverlight solution, it will not display anything.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.Silverlight.Chart.dll

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Chart.dll | Search Helpcentral Search HelpCentral

C1.Silverlight.Chart.dll

Previous Next

The C1.Silverlight.Chart.dll assembly contains the C1Chart control.

The C1Chart control is a full-featured charting tool that supports several chart types, built-in color palettes, and special effects including animations, zooming, and panning.

C1Chart

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1Chart

ComponentOne Studio for Silverlight: Quick Start > C1.Silverlight.Chart.dll > C1Chart | Search Helpcentral Search HelpCentral

C1Chart

Previous Next

To see C1Chart in action, complete the following steps:

1. Add the XAML below to the Page.xaml file, below the last Border element:

<!-- C1Chart -->

<Border Style="{StaticResource ControlBorder}" >

<StackPanel>

<TextBlock Text="C1Chart (C1.Silverlight.Chart)"
Style="{StaticResource ControlTitle}" />

<!-- Controls to customize the chart -->

<StackPanel Orientation="Horizontal" HorizontalAlignment="Center">

<TextBlock Text="Chart Type: " FontSize="11" VerticalAlignment="Center" />

      <c1:C1ComboBox
x:Name="_cbChartType" FontSize="11" Width="120"
SelectedItemChanged="_cbChartType_SelectedItemChanged"
SelectedIndex="0" >

<c1:C1ComboBoxItem Content="Line"/>

<c1:C1ComboBoxItem Content="Area"/>

<c1:C1ComboBoxItem Content="Column"/>

</c1:C1ComboBox>

      <TextBlock
Text="Palette: " FontSize="11"
VerticalAlignment="Center"
Margin="20,0,0,0"/>

      <c1:C1ComboBox
x:Name="_cbPalette" FontSize="11" Width="120"
SelectedItemChanged="_cbPalette_SelectedItemChanged"
SelectedIndex="0" >

<c1:C1ComboBoxItem Content="Default"/>

<c1:C1ComboBoxItem Content="Standard"/>

<c1:C1ComboBoxItem Content="Office"/>

<c1:C1ComboBoxItem Content="GrayScale"/>

<c1:C1ComboBoxItem Content="Apex"/>

<c1:C1ComboBoxItem Content="Aspect"/>

<c1:C1ComboBoxItem Content="Civic"/>

<!-- actual sample includes over 20 color schemes… -->

</c1:C1ComboBox>

<Button x:Name="_btnChart" Content="Generate"
Margin="20,0,0,0" Padding="5,0,5,0" Click="_btnChart_Click" />

</StackPanel>

<!-- Chart and legend -->

<StackPanel Orientation="Horizontal" HorizontalAlignment="Center">

<c1c:C1Chart x:Name="_chart" Width="500" Height="350" />

      <Border
CornerRadius="5" BorderThickness="2"
BorderBrush="DarkGray"
Background="WhiteSmoke" Padding="5" VerticalAlignment="Center" >

<c1c:C1ChartLegend x:Name="_legend" />

</Border>

</StackPanel>

</StackPanel>

</Border>

This XAML starts by creating a C1Chart and a C1ChartLegend. C1Chart does not display the legend within the control. Instead, you must create a separate C1ChartLegend control and connect it to the chart using the legend's Chart property. This design provides maximum flexibility when styling and positioning the legend.

Below the chart and legend, the XAML adds some controls that will be used to select the chart type, color scheme, and to generate some random data.

Now that the controls have been defined, we need to add some code to handle the buttons.

2. Open the Page.xaml.cs file in Visual Studio and add the following code to the page constructor to handle the buttons:

public Page()

{

InitializeComponent();

// Initialize other controls

// No changes here

//...

// Initialize the chart

_legend.Chart = _chart; // Connect legend to chart

GenerateChart(); // Show the chart

}

The code starts by connecting the legend to the C1Chart, then calls the GenerateChart method to populate the chart.

3. Add the following code for the GenerateChart method to the Page.xaml.cs file:

// Populate chart with some random series

void GenerateChart()

{

// Don't repaint while creating the chart

_chart.BeginUpdate();

// Clear existing content if any

_chart.Data.Children.Clear();

// Configure X axis

_chart.View.AxisX.IsTime = true;

_chart.View.AxisX.AnnoFormat = "MMM dd";

// Configure Y axis

_chart.View.AxisY.AnnoFormat = "0 ";

// Add a few data series

foreach (string seriesName in

"North;East;South;West;Center;Overseas".Split(';'))

{

AddSeries(_chart, seriesName + " Region");

}

// Finish

_chart.EndUpdate();

}

The code sets up the chart, then calls the AddSeries method a few times to populate the chart.

Add the following code for the AddSeries method:

// Add a series with some random data

Random _rnd = new Random(0);

void AddSeries(C1Chart chart, string name)

{

// Create some random data to plot

int len = 50;

DateTime[] x = new DateTime[len];

double[] y = new double[len];

double lastY = 0;

for (int i = 0; i < len; i++)

{

x[i] = DateTime.Today.AddDays(i);

y[i] = Math.Max(0, lastY + (_rnd.NextDouble() - 0.45) * 10);

lastY = y[i];

}

// Create the series

XYDataSeries ds = new XYDataSeries();

ds.XValuesSource = x;

ds.ValuesSource = y;

ds.Label = name;

ds.ConnectionStrokeThickness = 3;

// Add series to chart

chart.Data.Children.Add(ds);

}

The code generates two arrays with data for the X and Y axis, then creates a new data series and populates is using the ValuesSource and XValuesSource properties. Finally, it adds the new series to the chart.

The only parts still missing are the event handlers for the controls that determine the chart appearance.

4. Add the following event handlers that determine the chart appearance:

// Change chart type

void _cbChartType_SelectedItemChanged(object sender,

C1.Silverlight.PropertyChangedEventArgs<object> e)

{

switch (_cbChartType.SelectedIndex)

{

case 0:

_chart.ChartType = ChartType.LineSymbols;

break;

case 1:

_chart.ChartType = ChartType.AreaStacked;

break;

case 2:

_chart.ChartType = ChartType.ColumnStacked;

break;

}

}

// Change chart palette

void _cbPalette_SelectedItemChanged(object sender,

C1.Silverlight.PropertyChangedEventArgs<object> e)

{

_chart.Palette = (Palette)_cbPalette.SelectedIndex;

}

// Re-generate chart

void _btnChart_Click(object sender, RoutedEventArgs e)

{

GenerateChart();

}

5. Run the application.

If you scroll all the way to the bottom of the screen, you should see this:

Use the combo boxes to change the chart type and palette, or click the Generate button to generate a new set of random data.

This concludes the quick start guide.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


DataTemplates

ComponentOne Studio for Silverlight: DataTemplates | Search Helpcentral Search HelpCentral

DataTemplates

Previous Next

The previous sections focused on the ComponentOne Silverlight controls. This section focuses on DataTemplates, and how they are applied to Silverlight controls in general (including the ones provided by Microsoft). If you are an experienced Silverlight developer, this information may be of no interest to you.

DataTemplates are a powerful feature in Silverlight 2.0. They are virtually identical to the DataTemplates in WPF, so if you know WPF there's nothing really new about them.

On the other hand, if you have never used WPF and have seen pieces of XAML that contain styles and templates, you may be confused by the concepts and notation. The good news is DataTemplates are very powerful and are not overly complicated. Once you start using them, the concept will make sense in a couple of minutes and you will be on your way. Remember, just reading the tutorial probably won't be enough to fully grasp the concept. After reading, you should play with the projects.

Create the "Templates" Solution

Populate the controls

Defining and using Data Templates

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create the "Templates" Solution

ComponentOne Studio for Silverlight: DataTemplates > Create the "Templates" Solution | Search Helpcentral Search HelpCentral

Create the "Templates" Solution

Previous Next

To illustrate the power of DataTemplates, let us create a new Silverlight solution. Call it "Templates".

1. Select File | New | Project to open the New Project dialog box in Visual Studio 2008.

2. In the Project types pane, expand either the Visual Basic or Visual C# node and select Silverlight.

3. Choose Silverlight Application in the Templates pane.

4. Name the project "Templates", specify a location for the project, and click OK.

Next, Visual Studio will prompt you for the type of hosting you want to use for the new project.

5. In the Add Silverlight Application dialog box, select Web Application Project from the Project Type drop-down box. Select OK to accept the default name ("TemplatesWeb") and create the project.

6. Right-click the Templates project in the Solution Explorer and select Add Reference.

7. In the Add Reference dialog box locate and select the C1.Silverlight.dll assembly and click OK to add a reference to your project.

This is required since we will be adding C1.Silverlight controls to the page.

8. Now, open the Page.xaml file in the Templates project and paste in the XAML below:

<UserControl x:Class="Templates.Page"

xmlns="http://schemas.microsoft.com/client/2007"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:C1_Silverlight="clr-namespace:C1.Silverlight;assembly=C1.Silverlight">

<Grid x:Name="LayoutRoot" >

<Grid.Background>

<LinearGradientBrush EndPoint="0.5,1" StartPoint="0.5,0">

<GradientStop Color="#FF7EB9F0"/>

<GradientStop Color="#FF284259" Offset="1"/>

</LinearGradientBrush>

</Grid.Background>

<!-- Grid layout -->

<Grid.RowDefinitions>

<RowDefinition Height="30" />

<RowDefinition Height="*" />

</Grid.RowDefinitions>

<Grid.ColumnDefinitions>

<ColumnDefinition Width="*"/>

<ColumnDefinition Width="*"/>

</Grid.ColumnDefinitions>

<!-- Page title -->

<TextBlock Text="Silverlight Templates" Grid.Column="0" Grid.ColumnSpan="2"

TextAlignment="Center" FontSize="18" FontWeight="Bold" />

<!-- ListBox on the left -->

<StackPanel Grid.Row="1" Margin="5" >

<TextBlock Text="ListBox Control" />

<ListBox x:Name="_listBox" />

</StackPanel>

<!-- C1ComboBoxes on the right -->

<StackPanel Grid.Column="2" Grid.Row="1" Margin="5" >

<TextBlock Text="C1ComboBox Controls" />

<C1_Silverlight:C1ComboBox x:Name="_cmb1" Margin="0,0,0,5" />

<C1_Silverlight:C1ComboBox x:Name="_cmb2" Margin="0,0,0,5" />

</StackPanel>

</Grid>

</UserControl>

This creates a page with two columns. The left column has a standard ListBox control and the right has two C1ComboBoxes. These are the controls we will populate and style in the following steps.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Populate the controls

ComponentOne Studio for Silverlight: DataTemplates > Populate the controls | Search Helpcentral Search HelpCentral

Populate the controls

Previous Next

Before we start using templates and styles, let us populate the controls first. To do that, complete the following:

1. Open the Page.xaml.cs file and paste the following code into the page constructor:

public Page()

{

InitializeComponent();

// Get list of items

IEnumerable list = GetItems();

// Add items to ListBox and in C1ComboBox

_listBox.ItemsSource = list;

_cmb1.ItemsSource = list;

// Show fonts in the other C1ComboBox

FontFamily[] ff = new FontFamily[]

{

new FontFamily("Default font"),

new FontFamily("Arial"),

new FontFamily("Courier New"),

new FontFamily("Times New Roman"),

new FontFamily("Trebuchet MS"),

new FontFamily("Verdana")

};

_cmb2.ItemsSource = ff;

}

The code populates the ListBox and both C1ComboBoxes by setting their ItemsSource property. ItemsSource is a standard property present in most controls that support lists of items (ListBox, DataGrid, C1ComboBox, and so on).

2. Add the following code to implement the GetItems() method in the Page class:

List<DataItem> GetItems()

{

List<DataItem> members = new List<DataItem>();

foreach (MemberInfo mi in this.GetType().GetMembers())

{

members.Add(new DataItem(mi));

}

return members;

}

3. Add the definition of the DataItem class. to the Page.xaml.cs file, below the Page class definition:

public class DataItem

{

public string ItemName { get; set; }

public MemberTypes ItemType { get; set; }

public DataItem(MemberInfo mi)

{

ItemName = mi.Name;

ItemType = mi.MemberType;

}

}

If you run the project now, you will see that the controls are being populated. However, they don't do a very good job of showing the items:

The controls simply convert the DataItem objects into strings using their ToString() method, which we didn't override and by default returns a string representation of the object type ("Templates.DataItem").

The bottom C1ComboBox displays the font family names correctly. That's because the FontFamily class implements the ToString() method and returns the font family name.

It is easy to provide a ToString() implementation that would return a more useful string, containing one of more properties. For example:

public override string ToString()

{

return string.Format("{0} {1}", ItemType, ItemName);

}

If you add this method to the DataItem class and run the project again, you will see a slightly more satisfying result. But there's only so much you can do with plain strings. To represent complex objects effectively, we need something more. Enter Data Templates!

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Defining and using Data Templates

ComponentOne Studio for Silverlight: DataTemplates > Defining and using Data Templates | Search Helpcentral Search HelpCentral

Defining and using Data Templates

Previous Next

Data Templates are objects that map regular .NET objects into UIElement objects. They are used by controls that contain lists of regular .NET objects to convert these objects into UIElement objects that can be displayed to the user.

For example, the Data Template below can be used to map our DataItem objects into a StackPanel with two TextBlock elements that display the ItemName and ItemType properties of the DataItem. This is what the template definition looks like in XAML:

<UserControl x:Class="Templates.Page"

xmlns="http://schemas.microsoft.com/client/2007"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:C1_Silverlight="clr-namespace:C1.Silverlight;assembly=C1.Silverlight">

<!-- Data template used to convert DataItem objects into UIElement objects -->

<UserControl.Resources>

<DataTemplate x:Key="DataItemTemplate" >

<StackPanel Orientation="Horizontal" Height="30" >

<TextBlock Text="{Binding ItemType}"

Margin="5" VerticalAlignment="Bottom" Foreground="Red" FontSize="10" />

<TextBlock Text="{Binding ItemName}"

Margin="5" VerticalAlignment="Bottom" />

</StackPanel>

</DataTemplate>

</UserControl.Resources>

<!-- Page content (same as before)… -->

This template tells Silverlight (or WPF) that in order to represent a source data object, it should do this:

4. Create a StackPanel with two TextBlocks in it,

5. Bind the Text property of the first TextBlock to the ItemType property of the source data object, and

6. Bind the Text property of the second TextBlock object to the ItemName property of the source object.

That's it. The template does not specify what type of control can use it (any control can, we will use it with the ListBox and also with the C1ComboBox), and it does not specify the type of object it should expect (any object will do, as long as it has public properties named ItemType and ItemName).

To use the template, add an ItemTemplate attribute to the controls where you want the template to be applied. In our example, we will apply it to the ListBox declaration in the Page.xaml file:

<!-- ListBox on the left -->

<StackPanel Grid.Row="1" Margin="5" >

<TextBlock Text="ListBox Control" />

<ListBox x:Name="_listBox"

ItemTemplate="{StaticResource DataItemTemplate}" />

</StackPanel>

And also to the top C1ComboBox:

<!-- C1ComboBox on the right -->

<StackPanel Grid.Column="2" Grid.Row="1" Margin="5" >

<TextBlock Text="C1ComboBox Controls" />

<!-- C1ComboBox 1 -->

<C1_Silverlight:C1ComboBox x:Name="_cmb1" Margin="0,0,0,5"

ItemTemplate="{StaticResource DataItemTemplate}" />

Note that we can now change the appearance of the DataItem objects by modifying the template in one place. Any changes will automatically be applied to all objects that use that template, making application maintenance much easier.

Before you run the application again, let's add a template to the second C1ComboBox as well. This control contains a list of font families. We can use templates to display each item using the actual font they represent.

This time, we will not define the template as a resource. It will only be used in one place, so we can insert it inline, as shown below:

<!-- C1ComboBox 2 -->

<C1_Silverlight:C1ComboBox x:Name="_cmb2" FontSize="12" Margin="0,0,0,5" >

<C1_Silverlight:C1ComboBox.ItemTemplate>

<DataTemplate>

<TextBlock Text="{Binding}" FontFamily="{Binding}" Margin="4" />

</DataTemplate>

</C1_Silverlight:C1ComboBox.ItemTemplate>

</C1_Silverlight:C1ComboBox>

Don't let the XAML syntax confuse you. This specifies that in order to create items from data, the control should use a DataTemplate that consists of a single TextBlock element. The TextBlock element should have two of its properties (Text and FontFamily) bound to the data object itself (as opposed to properties of that object).

In this case, the data object is a FontFamily object. Because the template assigns this object to the Text property and also to the FontFamily property, the TextBlock will display the font name and will use the actual font.

If you run the project now, you should see this result:

Note that if you assign a DataTemplate to the C1ComboBox, it will no longer be able to perform text-related tasks such as auto-search and editing. If you want to re-enable those features, you should provide your own ItemConverter that is a standard TypeConverter.

Styles and Templates are extremely powerful concepts. We encourage you to play and experiment with this sample. Try modifying the templates to show the data in different ways. The more you experiment, the more comfortable you will feel with these concepts and with the Silverlight/WPF application architecture.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Control Templates

ComponentOne Studio for Silverlight: Control Templates | Search Helpcentral Search HelpCentral

Control Templates

Previous Next

Data Templates allow you to specify how to convert arbitrary data objects into UIElement objects that can be displayed to the user. But that's not the only use of templates in Silverlight and WPF. You can also use templates to modify the visual structure of existing UIElement objects such as controls.

Most controls have their visual appearance defined by a native XAML resource (typically contained within the assembly that defines the control). This resource specifies a Style which assigns values to most of the control's properties, including its Template property (which defines the control's internal "visual tree").

For example:

<Style TargetType="HyperlinkButton">

<Setter Property="IsEnabled" Value="true" />

<Setter Property="IsTabStop" Value="true" />

<Setter Property="Foreground" Value="#FF417DA5" />

<Setter Property="Cursor" Value="Hand" />

<Setter Property="Template">

<Setter.Value>

<ControlTemplate TargetType="HyperlinkButton">

<Grid x:Name="RootElement" Cursor="{TemplateBinding Cursor}">

<!-- Focus indicator -->

<Rectangle x:Name="FocusVisualElement" StrokeDashCap="Round" ...=""/>

<!-- HyperlinkButton content -->

<ContentPresenter x:Name="Normal"

Background="{TemplateBinding Background}"

Content="{TemplateBinding Content}"

ContentTemplate="{TemplateBinding ContentTemplate}"...=""/>

</Grid>

</ControlTemplate>

</Setter.Value>

</Setter>

</Style>

This is a very simplified version of the XAML resource used to specify the HyperlinkButton control. It consists of a Style that begins by setting the default value of several simple properties, and then assigns a value of type ControlTemplate to the control's Template property.

The ControlTemplate in this case consists of a Grid (RootElement) that contains a Rectangle (FocusVisualElement) used to indicate the focused state, and a ContentPresenter (Normal) that represents the content portion of the control (and itself contains another ContentTemplate property).

Note the TemplateBinding attributes in the XAML. These constructs are used to map properties exposed by the control to properties of the template elements. For example, the Background property of the hyperlink control is mapped to the Background property of the Normal element specified in the template.

Specifying controls this way has some advantages. The complete visual appearance is defined in XAML and can be modified by a professional designer using Expression Blend, without touching the code behind it. In practice, this is not as easy as it sounds, because there are logical relationships between the template and the control implementation.

Recognizing this problem, Silverlight introduced a TemplatePart attribute that allows control classes to specify the names and types it expects its templates to contain. In the future, this attribute will be added to WPF as well, and used by designer applications such as Blend to validate templates and ensure they are valid for the target control.

For example, the Microsoft Button control contains the following TemplatePart attributes:

/// <summary>

/// Represents a button control, which reacts to the Click event.

/// </summary>

[TemplatePart(Name = Button.ElementRootName, Type = typeof(FrameworkElement))]

[TemplatePart(Name = Button.ElementFocusVisualName, Type = typeof(UIElement))]

[TemplatePart(Name = Button.StateNormalName, Type = typeof(Storyboard))]

[TemplatePart(Name = Button.StateMouseOverName, Type = typeof(Storyboard))]

[TemplatePart(Name = Button.StatePressedName, Type = typeof(Storyboard))]

[TemplatePart(Name = Button.StateDisabledName, Type = typeof(Storyboard))]

public partial class Button : ButtonBase

These six template parts constitute a contract between the control implementation and the design specification. They tell the designer that the control implementation expects to find certain elements in the template (defined by their name and type).

Well-behaved controls should degrade gracefully, not crashing if some non-essential elements are missing from the template. For example, if the control can't find a Storyboard named Button.StateMouseOverName in the template, it should not do anything when the mouse hovers over it.

Well-implemented templates should fulfill the contract and provide all the elements that the control logic supports. Designer applications such as Blend can enforce the contract and warn designers if they try to apply invalid templates to controls.

For the time being, the easiest way to create new templates for existing controls is to start with the original XAML and customize it.

We will not show any actual examples of how to create and use custom control templates here. Instead, we suggest you download the examples developed by Corrina Barber:

http://blogs.msdn.com/corrinab/archive/2008/03/11/silverlight-2-control-skins.aspx

The link contains previews and downloads for three 'skins' (bubbly, red, and flat). Each skin consists of a set of Style specifications, similar to the one shown above, which are added to the application's global XAML file (App.xaml). The format is similar to this:

<Application xmlns="http://schemas.microsoft.com/client/2007"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

x:Class="Styles_Red.App"

<Application.Resources>

<!-- Button -->

<Style x:Key="buttonStyle" TargetType="Button">

<Setter Property="IsEnabled" Value="true" />

<Setter Property="IsTabStop" Value="true" />

<Setter Property="Foreground" Value="#FF1E2B33" />

<Setter Property="Cursor" Value="Hand" />

<Setter Property="TextAlignment" Value="Center" />

<!-- A lot more XAML follows… -->

Once these styles are defined in the App.xaml file, they can be assigned to any controls in the application:

<Button Content="Button" Style="{StaticResource buttonStyle}"/>

If you are curious, this is what the Button control looks like after applying each of the skins defined in the reference above:

Default

Bubbly

Red

Flat

This mechanism is extremely powerful. You can change what the controls look like and even the parts used internally to build them.

Unlike data templates, however, control templates are not trivial to create and modify. Creating or changing a control template requires not only design talent but also some understanding of how the control works.

It is also a labor-intensive proposition. In addition to their normal appearance, most controls have Storyboards that are applied to change their appearance when the mouse hovers over them, when they gain focus, get pressed, get disabled, and so on (see the C1ComboBox example above).

Furthermore, all controls in an application should have a consistent look. You probably wouldn't want to mix bubbly buttons with regular scrollbars on the same page for example. So each 'skin' will contain styles for many controls.

It is likely that professionally designed skin packages will become commercially available as soon as Silverlight 2.0 ships.

Some controls are designed with custom templates in mind. For example, the C1ComboBox has an ItemsPanel property of type ItemsPanelTemplate. You can use this property to replace the default drop-down ListBox element with any other UIElement you like.

We will not demonstrate the ItemsPanel property here. Instead, we suggest you check the ControlExplorer sample distributed with the ComponentOne Studio for Silverlight.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


ComponentOne Data for Silverlight (C1.Silverlight.Data)

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) | Search Helpcentral Search HelpCentral

ComponentOne Data for Silverlight (C1.Silverlight.Data)

Previous Next

This document describes how you can use the C1.Silverlight.Data assembly to implement data-centric Silverlight applications. Because the classes in the C1.Silverlight.Data assembly are a subset of those in the System.Data namespace, we will not describe them here. Instead, this document assumes you know how to create and manage DataSet and DataTable objects. If you are not familiar with these classes, please check the descriptions of the System.Data.DataSet and System.Data.DataTable classes on MSDN.

Silverlight can be used to build line-of-business and other data-centric applications. This type of application typically involves the following steps:

1. Get the data from the server.

2. Display and edit the data on the client.

3. Submit the changes back to the server.

Steps 1 and 3 typically rely on Web services to transfer the data and traditional data access strategies to query and update a database. Step 2 typically involves Silverlight data-bound controls.

Microsoft offers many tools that can be used to perform the server-side part of the job. The latest such tool is ADO.NET Data Services, which provides web-accessible endpoints for data models and integrates with Silverlight through the ADO.NET Data Services for Silverlight library (System.Data.Services.Client.dll). A lot has been written lately about this new technology (see for example "Data Services" in MSDN vol. 23, no. 10, September 2008).

ADO.NET Data Services is a powerful new technology that is likely to become a standard for many types of data-centric applications. However, it is not the only option. The traditional data ADO.NET classes (DataSet, DataTable, DataAdapters, and so on) can also be used to retrieve and update data on the server. These classes have been used by developers since .NET 1.0. They are solid, powerful, and easy to use. Furthermore, many developers already have a considerable investment in the form of code that has been used and tested for a long time.

C1Data for Silverlight is a set of classes that can be used by Silverlight clients to exchange data with servers using traditional ADO.NET. The typical steps are as follows:

1. Get the data from the server.

a. Server populates a DataSet object the traditional way (typically using DataAdapter objects to retrieve the data from a SqlServer database).

b. Server calls DataSet.WriteXml to serialize the DataSet into a stream and sends the stream to the client.

c. Client uses the DataSet.ReadXml method to de-serialize the stream.

2. Display and edit the data on the client.

a. Client binds the tables in the DataSet to controls (possibly using LINQ queries).

b. User interacts with the controls to view, edit, add, and delete data items.

3. Submit the changes back to the server.

a. Client calls DataSet.GetChanges and DataSet.WriteXml to serialize the changes into a stream and sends the stream to the server.

b. Server calls DataSet.ReadXml to de-serialize the changes, then uses DataAdapter objects to persist the changes into the database.

The role of C1Data in this scenario is twofold. First, it provides a symmetric serialization mechanism that makes it easy to transfer data between DataSet objects on the client and on the server. Second, it provides a familiar object model to manipulate the data on the client.

Note: C1Data does not compete against ADO.NET Data Services. It allows you to leverage your knowledge of ADO.NET and assets you may already have. You can transfer all that to Silverlight with minimal effort, and migrate to ADO.NET Data Services gradually, if such a migration is desired.

C1Data is not a legacy technology. You can use it with LINQ, for example. In fact, C1Data enables LINQ features that are available on desktop but not in Silverlight applications (partial anonymous classes).

The next sections describe the implementation of a simple application that performs the steps described above. Despite its simplicity, the application shows how to perform the four CRUD operations (Create, Read, Update, Delete) that are required of most data-centric applications.

The Sample Application

Conclusion

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


The Sample Application

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application | Search Helpcentral Search HelpCentral

The Sample Application

Previous Next

The sample application will consist of two grids, arranged to show a master-detail view of the Northwind Categories and Products tables. The data will be retrieved from the server when the application starts, using a web service. It will then populate the tables so the user can browse and edit the data. Finally, it will submit any changes back to the server so the database can be updated.

Create the Application

Add the References

Create the UI

Implement the Server Side

Implement the Client Side

Optimize the Data Transfers

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create the Application

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Create the Application | Search Helpcentral Search HelpCentral

Create the Application

Previous Next

Let us start by creating a new Silverlight application called "MasterDetail". Complete the following steps:

1. Select File | New | Project to open the New Project dialog box in Visual Studio 2008.

2. In the Project types pane, expand either the Visual Basic or Visual C# node and select Silverlight.

3. Choose Silverlight Application in the Templates pane.

4. Name the project "MasterDetail", specify a location for the project, and click OK.

Next, Visual Studio will prompt you for the type of hosting you want to use for the new project.

5. In the Add Silverlight Application dialog box, select Web Application Project from the Project Type drop-down box. Select OK to accept the default name ("MasterDetailtWeb") and create the project.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Add the References

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Add the References | Search Helpcentral Search HelpCentral

Add the References

Previous Next

Our project will use two additional assemblies, C1.Silverlight.Data.dll (contains the C1Data classes) and System.Windows.Controls.Data.dll (contains Microsoft's DataGrid control). We chose to use the Microsoft grid instead of ComponentOne's to show that the C1Data classes are not tied in any way to other ComponentOne controls; they can be used against any Silverlight control.

To add the assemblies, complete the following:

6. Right-click the MasterDetail project in the Solution Explorer and select Add Reference.

7. In the Add Reference dialog box locate and select the following assemblies and click OK to add references to your project:

· C1.Silverlight.Data.dll

· System.Windows.Controls.Data.dll

After adding references, the solution should look like this:

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Create the UI

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Create the UI | Search Helpcentral Search HelpCentral

Create the UI

Previous Next

The user interface will consist of two data grids (Categories and Products), and a few buttons used to add and delete items, and to commit the changes.

To create the user interface, open the Page.xaml file and in Source view copy the following XAML onto the page:

<UserControl x:Class="MasterDetail.Page"

xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"

xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"

xmlns:swc=
"clr-namespace:System.Windows.Controls;assembly=System.Windows.Controls.Data" >

<Grid x:Name="LayoutRoot" Background="White" >

<!-- Main grid layout -->

<Grid.RowDefinitions>

<RowDefinition Height="Auto" />

<RowDefinition Height="Auto" />

<RowDefinition Height="*" />

<RowDefinition Height="Auto" />

<RowDefinition Height="2*" />

<RowDefinition Height="Auto" />

</Grid.RowDefinitions>

<!-- Page title -->

    <TextBlock Text="Master-Detail
Sample in Silverlight" Margin="5"
FontSize="20" FontWeight="Bold" />

<!-- Master data grid -->

    <TextBlock Text="Categories"
Margin="5" Grid.Row="1"
FontSize="16"
FontWeight="Bold" Foreground="Blue" />

<swc:DataGrid x:Name="_gridCategories" Margin="5" Grid.Row="2" />

<!-- Detail data grid -->

    <TextBlock Text="Products"
Margin="5" Grid.Row="3"
FontSize="16"
FontWeight="Bold" Foreground="Blue" />

<swc:DataGrid x:Name="_gridProducts" Margin="5" Grid.Row="4" />

<!-- Control panel -->

<StackPanel Margin="5" Orientation="Horizontal" Grid.Row="5" >

<Button x:Name="_btnAdd" Content=" Add Item "
Margin="0,0,20,0" FontSize="14" VerticalAlignment="Center" />

<Button x:Name="_btnRemove" Content=" Remove Item "
Margin="0,0,20,0" FontSize="14" VerticalAlignment="Center" />

<Button x:Name="_btnCommit" Content=" Commit Changes "
Margin="0,0,20,0" FontSize="14" VerticalAlignment="Center" />

<TextBlock x:Name="_tbStatus" Text="Ready"
VerticalAlignment="Center" FontSize="12" Foreground="Gray" />

</StackPanel>

</Grid>

</UserControl>

Try running the application now to make sure everything is OK so far. You should see two empty grids.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Implement the Server Side

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Server Side | Search Helpcentral Search HelpCentral

Implement the Server Side

Previous Next

In this step, we will implement the server side of the application. It consists of a web service with two methods: GetData gets the data from the Northwind database and returns it to the client. UpdateData saves the changes made by the client back into the database.

Add the Database Access Infrastructure

Implement the Web Service

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Add the Database Access Infrastructure

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Server Side > Add the Database Access Infrastructure | Search Helpcentral Search HelpCentral

Add the Database Access Infrastructure

Previous Next

Before implementing the web services, let's add the database itself to the project. This step is optional. We will use a connection string to specify where the database is located, so we could use any existing copy of the MDB file already in the system. We will create a local copy here to facilitate deployment and to avoid making changes to the original database.

To add the database to the project, right-click the App_Data node in the MasterDetailWeb project and select Add Existing Item. Then locate the NWIND.MDB file and add it to the project. Make sure the Build Action property in the property window is set to None. The image below shows the Solution Explorer window after this step is completed:

In addition to the database file, we need a mechanism to transfer data from and to the database. In this sample, we will accomplish this using a utility class called SmartDataSet. SmartDataSet extends the regular ADO.NET DataSet class and adds the following:

· A ConnectionString property that specifies the database type and location.

· A Load method that loads data from selected tables.

· An Update method that saves changes back into the database.

The SmartDataSet is convenient but not necessary. It knows how to create and configure DataAdapter objects used to load and save data, but you could also write standard ADO.NET code to accomplish the same thing. Because it only uses standard ADO.NET techniques, we will not list it here.

To add the SmartDataSet.cs file to the project, right-click the MasterDetailWeb node in the Solution Explorer, select "Add Existing Item", then locate the SmartDataSet.cs file in the C1.Silverlight distribution package.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Implement the Web Service

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Server Side > Implement the Web Service | Search Helpcentral Search HelpCentral

Implement the Web Service

Previous Next

The server side of the application consists of web services that load the data from the database and return it to the server, or receive a list of changes from the client and applies it to the database.

We could implement the server side as a generic handler class (ashx), as a Web Service (asmx), or as a Silverlight-enabled WCF service (svc). For this sample, any of the choices would do. We will choose a classic Web Service.

Follow these steps to create the service:

1. Right-click the MasterDetailWeb project.

2. Select Add New Item

3. Pick the Web Service template.

4. Name the new service "DataService.asmx".

The dialog box should look like the image below. Click the Add button to create the new web service.

After you click the Add button, Visual Studio will open the newly created DataService.asmx.cs file. The file contains a single HelloWorld method.

Edit the file as follows:

1. Add the following statement to the "using" statement block at the start of the file:
using System.IO;

2. Uncomment the line below so the service can be called from Silverlight:
[System.Web.Script.Services.ScriptService]

3. Delete the HelloWorld method that Visual Studio created and replace it with the following code:

[WebMethod]

public byte[] GetData(string tables)

{

// Create DataSet with connection string

var ds = GetDataSet();

// Load data into DataSet

ds.Fill(tables.Split(','));

// Persist to stream

var ms = new System.IO.MemoryStream();

ds.WriteXml(ms, XmlWriteMode.WriteSchema);

// Return stream data

return ms.ToArray();

}

The method starts by creating a SmartDataSet, then fills it with the tables specified by the "tables" parameter. Finally, it uses the WriteXml method to persist the DataSet into a stream, converts the stream into a byte array, and returns the result.

Remember this code will run on the server. We could use a data compression library such as C1.Zip to compress the stream and reduce its size significantly before returning it to the client. We did not bother to do this here to keep the example as simple as possible.

Next, let's add the method that saves the changes back into the database. Here is the code:

[WebMethod]

public string UpdateData(byte[] dtAdded, byte[] dtModified, byte[] dtDeleted)

{

try

{

UpdateData(dtAdded, DataRowState.Added);

UpdateData(dtModified, DataRowState.Modified);

UpdateData(dtDeleted, DataRowState.Deleted);

return null;

}

catch (Exception x)

{

return x.Message;

}

}

The method takes three parameters, each corresponding to a different type of change to be applied to the database: records that were added, modified, and deleted. It calls the UpdateData helper method to apply each set of changes, and returns null if all changes were applied successfully. If there are any errors, the method returns the a message that describes the exception.

Here is the code for the UpdateData helper method:

void UpdateData(byte[] data, DataRowState state)

{

// No changes, no work

if (data == null)

return;

// Load data into dataset

var ds = GetDataSet();

var ms = new MemoryStream(data);

ds.ReadXml(ms);

ds.AcceptChanges();

// Update row states with changes

foreach (DataTable dt in ds.Tables)

{

foreach (DataRow dr in dt.Rows)

{

switch (state)

{

case DataRowState.Added:

dr.SetAdded();

break;

case DataRowState.Modified:

dr.SetModified();

break;

case DataRowState.Deleted:

dr.Delete();

break;

}

}

}

// Update the database

ds.Update();

}

The method starts by creating a SmartDataSet and loading all the changes into it. It then changes the RowState property on each row to identify the type of change that has been applied to the row (added, modified, or deleted). Finally, it calls the SmartDataSet.Update method to write the changes to the database.

The server-side code is almost ready. The only part still missing is the method that creates and configures the SmartDataSet. Here is the implementation:

SmartDataSet GetDataSet()

{

// Get physical location of the mdb file

string mdb = Path.Combine(

Context.Request.PhysicalApplicationPath, @"App_Data\nwind.mdb");

// Check that the file exists

if (!File.Exists(mdb))

{

string msg = string.Format("Cannot find database file {0}.", mdb);

throw new FileNotFoundException(msg);

}

// Make sure file is not read-only (source control often does this...)

FileAttributes att = File.GetAttributes(mdb);

if ((att & FileAttributes.ReadOnly) != 0)

{

att &= ~FileAttributes.ReadOnly;

File.SetAttributes(mdb, att);

}

// Create and initialize the SmartDataSet

var dataSet = new SmartDataSet();

dataSet.ConnectionString =

"provider=microsoft.jet.oledb.4.0;data source=" + mdb;

return dataSet;

}

The method starts by locating the database file, making sure it exists, and checking that it is not read-only (or the updates would fail). Once that is done, it creates a new SmartDataSet, initializes its ConnectionString property, and returns the newly created SmartDataSet to the caller.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Implement the Client Side

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side | Search Helpcentral Search HelpCentral

Implement the Client Side

Previous Next

Now let's return to the client side of the application.

Add a Reference to the Web Service

Use the Web Service to Get the Data

Bind the Data to Controls on the Page

Synchronize the Views

Add and Remove Items

Commit Changes to the Server

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Add a Reference to the Web Service

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Add a Reference to the Web Service | Search Helpcentral Search HelpCentral

Add a Reference to the Web Service

Previous Next

The first thing we will do is add a reference to the web service we just created, so we can invoke it from the client.

Right-click the References node in the MasterDetail project and select Add Service Reference. In the dialog box that follows, click the Discover button. Visual Studio will locate the service we just added in the previous step. In the Namespace field, type "DataService".

The dialog box should look like this:

Click OK to add the reference.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Use the Web Service to Get the Data

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Use the Web Service to Get the Data | Search Helpcentral Search HelpCentral

Use the Web Service to Get the Data

Previous Next

We are finally ready to get the data and show it to the users.

Open the Page.xaml.cs file and add the following using statements to the block at the top of the file:

using System.IO;

using C1.Silverlight.Data;

using MasterDetail.DataService;

Next, edit the page constructor as follows:

public Page()

{

InitializeComponent();

LoadData();

}

The LoadData method will invoke the web service to retrieve the data into a DataSet object, which we will then bind to the controls on the page. Here is the code:

DataSet _ds = null;

void LoadData()

{

// Invoke web service

var svc = new GetDataService();

svc.GetDataCompleted += svc_GetDataCompleted;

svc.GetDataAsync("Categories,Products");

}

void svc_GetDataCompleted(object sender, GetDataCompletedEventArgs e)

{

// Handle errors

if (e.Error != null)

{

_tbStatus.Text = "Error downloading data...";

return;

}

// Parse data stream from server (DataSet as XML)

_tbStatus.Text = string.Format(

"Got data, {0:n0} kBytes", e.Result.Length / 1024);

var ms = new MemoryStream(e.Result);

_ds = new DataSet();

_ds.ReadXml(ms);

// Got the data, bind controls to it

BindData();

}

The GetDataService method instantiates and returns a new DataServiceSoapClient object. We don’t use the default constructor because that would refer to the development environment (http://localhost and so on). It would work correctly on the development machine, but would break when the application is deployed. Also, the default constructor uses a 65k buffer that might be too small for our data transfers. Here is the GetDataService method implementation that takes care of both issues:

// Get data service relative to current host/domain

DataServiceSoapClient GetDataService()

{

// Increase buffer size

var binding = new System.ServiceModel.BasicHttpBinding();

binding.MaxReceivedMessageSize = 2147483647; // int.MaxValue

binding.MaxBufferSize = 2147483647; // int.MaxValue

// Get absolute service addres

Uri uri = GetAbsoluteUri("DataService.asmx");

var address = new System.ServiceModel.EndpointAddress(uri);

// Return new service client

return new DataServiceSoapClient(binding, address);

}

public static Uri GetAbsoluteUri(string relativeUri)

{

Uri uri = System.Windows.Browser.HtmlPage.Document.DocumentUri;

string uriString = uri.AbsoluteUri;

int ls = uriString.LastIndexOf('/');

return new Uri(uriString.Substring(0, ls + 1) + relativeUri);

}

The LoadData method above instantiates the service and invokes the GetDataAsync method. When the method finishes executing, it invokes the svc_DataCompleted delegate. The delegate instantiates a DataSet object, uses the ReadXml method to de-serialize the data provided by the server, then calls BindData to bind the data to the controls on the page.

Note: This is one of the most important features of the C1.Silverlight.Data DataSet class. It uses the same Xml schema that ADO.NET DataSet objects use. This allows applications to serialize data on the client and de-serialize it on the server, or vice-versa. The fact that the object models are very similar also makes things substantially easier for the developer.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Bind the Data to Controls on the Page

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Bind the Data to Controls on the Page | Search Helpcentral Search HelpCentral

Bind the Data to Controls on the Page

Previous Next

After the data has been retrieved, we have to bind it to the controls on the page. Here is the implementation of the BindData method that handles that task:

void BindData()

{

// Get the tables we want

DataTable dtCategories = _ds.Tables["Categories"];

DataTable dtProducts = _ds.Tables["Products"];

// Populate categories grid

_gridCategories.ItemsSource =

new DataView(dtCategories,

"CategoryID", "CategoryName", "Description");

// Populate products categories grid

_gridProducts.ItemsSource = dtProducts.DefaultView;

}

Note: If you have ever written WinForms or ASP.NET applications, this code should look familiar. This is one of the strengths of C1.Silverlight.Data. It allows you to leverage your knowledge of ADO.NET in Silverlight applications. You can use the DataSet object model to inspect and modify the tables available for data-binding, including their schemas and data, as well as the data relations, keys, and so on.

The only slightly unusual statement is the one that creates a DataView object and specifies which columns should be included in the view. This is an extension provided by the C1.Silverlight.Data implementation that is not present in the original ADO.NET DataView class.

If you run the project now, you should see the data retrieved from the server:

Before we continue with the sample, a few comments are in order.

Although the code that binds the data to the controls looks familiar, what happens under the covers is quite different from the traditional WinForms and ASP.NET scenarios. All data binding in WPF and Silverlight is done through reflection. But the DataRowView objects exposed by DataView collections do not have properties that match the columns in the underlying DataTable ("CategoryID", "CategoryName", "Description", and so on).

Note: The binding is possible because the DataView class dynamically creates anonymous types that derive from DataRowView and expose additional properties that correspond to the table columns. Controls can then use reflection to find these properties and bind to them.

The DataRow class also leverages this mechanism through its GetRowView method. This method builds a wrapper object that exposes selected properties of the DataRow and can be used for data binding. You can use this method to in your LINQ queries.

For example, code below builds a LINQ query that selects all categories that start with "C" and exposes their name and description:

_gridCategories.ItemsSource =

from dr

in dtCategories.Rows

where ((string)dr["CategoryName"]).StartsWith("C")

select dr.GetRowView("CategoryName", "Description");

If you call GetRowView with no parameters, all columns are exposed.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Synchronize the Views

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Synchronize the Views | Search Helpcentral Search HelpCentral

Synchronize the Views

Previous Next

Our master-detail view is not synchronized yet. All products are displayed on the bottom grid, regardless of the category selected on the top grid.

To synchronize the views, we need to handle the SelectionChanged event on the categories grid and filter the products to display only those that belong to the selected category.

To do this, we start by adding an event handler to the page constructor:

public Page()

{

InitializeComponent();

LoadData();

_gridCategories.SelectionChanged += _gridCategories_SelectionChanged;

}

The event handler is implemented as follows:

void _gridCategories_SelectionChanged(object sender, EventArgs e)

{

var drv = _gridCategories.SelectedItem as DataRowView;

if (drv != null)

{

var dv = _ds.Tables["Products"].DefaultView;

dv.RowFilter = string.Format("CategoryID = {0}", drv.GetData("CategoryID"));

}

}

The code gets the selected category as a DataRowView object, gets the default view for the "Products" table (used as a data source for the second grid), and applies the filter. Again, the code should look familiar to WinForms and ASP.NET developers.

If you run the application again, you will notice that the views are now synchronized.

Note that instead of applying a filter to the DataView, we could have used a LINQ query to update the products table. For example:

void _gridCategories_SelectionChanged(object sender, EventArgs e)

{

var drv = _gridCategories.SelectedItem as DataRowView;

if (drv != null)

{

int id = (int)drv.GetData("CategoryID");

_gridProducts.ItemsSource =

from dr

in _ds.Tables["Products"].Rows

where (int)dr["CategoryID"] == id

select dr.GetRowView();

}

}

This also achieves the goal of synchronizing the master and detail views. The main difference is that the previous method would affect any other controls bound to the same view, while this method affects only the products grid.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Add and Remove Items

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Add and Remove Items | Search Helpcentral Search HelpCentral

Add and Remove Items

Previous Next

Unlike most WinForms grids, the Silverlight DataGrid control does not allow users to add or remove items from the grid. We will use the buttons already on the page for that. The first thing to do is connect the event handlers on the page constructor:

// Load data, hook up event handlers

public Page()

{

InitializeComponent();

LoadData();

_gridCategories.SelectionChanged += _gridCategories_SelectionChanged;

_btnAdd.Click += _btnAdd_Click;

_btnRemove.Click += _btnRemove_Click;

}

The event handlers are simple, they look like regular ADO.NET code you would write on a WinForms application:

// Add a new row

private void _btnAdd_Click(object sender, RoutedEventArgs e)

{

DataTable dt = _ds.Tables["Categories"];

DataRow newRow = dt.NewRow();

newRow["CategoryName"] = "New category";

newRow["Description"] = "This is a new category...";

dt.Rows.Add(newRow);

}

// Delete a row

private void _btnRemove_Click(object sender, RoutedEventArgs e)

{

DataRowView drv = _gridCategories.SelectedItem as DataRowView;

if (drv != null)

{

DataRow dr = drv.GetRow();

dr.Delete();

}

}

If you run the application now, you will be able to add, remove, and modify the items displayed on the grids.

Note: The DataSet we are using contains not only the tables you see, but also the DataRelation that connects the two tables. That relation came from the MDB file and was downloaded from the server along with the data. The relation has a ChildKeyConstraint property that specifies, among other things, that delete operations should cascade through the tables. In other words, if you delete a category, all products that belong to that category will also be automatically deleted.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Commit Changes to the Server

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Implement the Client Side > Commit Changes to the Server | Search Helpcentral Search HelpCentral

Commit Changes to the Server

Previous Next

We are almost done now. The only piece still missing is the code that submits the changes made by the user back to the server, so they can be applied to the database.

The first step is to modify the page constructor once again and connect the event handler for the "Commit Changes" button:

// Load data, hook up event handlers

public Page()

{

InitializeComponent();

LoadData();

_gridCategories.SelectionChanged += _gridCategories_SelectionChanged;

_btnAdd.Click += _btnAdd_Click;

_btnRemove.Click += _btnRemove_Click;

_btnCommit.Click += _btnCommit_Click;

}

And here is the implementation for the event handler:

// Commit changes to server

private void _btnCommit_Click(object sender, RoutedEventArgs e)

{

SaveData();

}

And here is the implementation for the SaveData method, which does the real work:

// Save data back into the database

void SaveData()

{

if (_ds != null)

{

// get changes of each type

byte[] dtAdded = GetChanges(DataRowState.Added);

byte[] dtModified = GetChanges(DataRowState.Modified);

byte[] dtDeleted = GetChanges(DataRowState.Deleted);

// Invoke service

var svc = new GetDataService();

svc.UpdateDataCompleted += svc_UpdateDataCompleted;

svc.UpdateDataAsync(dtAdded, dtModified, dtDeleted);

}

}

void svc_UpdateDataCompleted(object sender, UpdateDataCompletedEventArgs e)

{

if (!string.IsNullOrEmpty(e.Result))

{

throw new Exception("Error updating data on the server: " + e.Result);

}

_tbStatus.Text = "Changes accepted by server.";

_ds.AcceptChanges();

}

The method starts by calling the GetChanges method to build three byte arrays. Each one represents a DataSet with the rows that have been added, modified, or deleted since the data was downloaded from the server. Then the method invokes the web service we implemented earlier and listens for the result. If any errors were detected while updating the server, we throw an exception (real applications would deal with the error in a more elegant way).

The only piece still missing is the GetChanges method. Here it is:

byte[] GetChanges(DataRowState state)

{

DataSet ds = _ds.GetChanges(state);

if (ds != null)

{

MemoryStream ms = new MemoryStream();

ds.WriteXml(ms);

return ms.ToArray();

}

return null;

}

The method uses the DataSet.GetChanges method to obtain a new DataSet object containing only the rows that have the DataRowState specified by the caller. This is the same method available on the ADO.NET DataSet class.

The method then serializes the DataSet containing the changes into a MemoryStream, and returns the stream contents as a byte array.

Try running the application now. Make some changes, then click the "Commit Changes" button to send the changes to the server. If you stop the application and start it again, you should see that the changes were indeed persisted to the database.

Note: The update may fail depending on the changes you make. For example, if you delete one of the existing categories, all products that belong to that category will also be removed from the DataSet on the client. When you try to apply these changes to the server, the transaction will likely fail because the database may contain tables that still refer to the products you are trying to delete (the Orders table in this case). To test the delete/commit action, try creating a category, committing the changes, then deleting the new category and committing again. This will succeed because the new category won't have any products associated with it in the database.

A real application would have to deal with this type of problem more intelligently. For example, we could have loaded the Orders table as well, inspect the DataSet to detect whether the user is trying to delete an item that he should not, and issue a warning. That is left as an exercise for the reader.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Optimize the Data Transfers

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Optimize the Data Transfers | Search Helpcentral Search HelpCentral

Optimize the Data Transfers

Previous Next

Now that our sample application is ready, we could easily go a step further and optimize its performance by compressing the data streams between client and server. This would require two small modifications to our project:

Compress the Data on the Server

Decompress the Data on the Client

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Compress the Data on the Server

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Optimize the Data Transfers > Compress the Data on the Server | Search Helpcentral Search HelpCentral

Compress the Data on the Server

Previous Next

Before sending the data to the client, we would compress the stream using the C1.Zip library (the desktop version included with ComponentOne Studio, not the Silverlight version). To do this, we would modify the MasterDetailWeb project by adding a reference to the C1.Zip library, then changing the GetData method in the DataService.asmx.cs web service as follows:

[WebMethod]

public byte[] GetData(string tables)

{

// Create DataSet with connection string

var ds = GetDataSet();

// Load data into DataSet

ds.Fill(tables.Split(','));

// Persist to stream

var ms = new MemoryStream();

using (var sw = new C1.C1Zip.C1ZStreamWriter(ms))

ds.WriteXml(sw, XmlWriteMode.WriteSchema);

//ds.WriteXml(ms, XmlWriteMode.WriteSchema);

// Return stream data

return ms.ToArray();

}

This small change is all that's required to compress the data on the server before sending it to the client. Instead of persisting the DataSet directly to the stream, we are now persisting it through a C1ZStreamWriter that compresses the data before writing it to the stream. Because the data is encoded as XML, compression rates will be very good.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Decompress the Data on the Client

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > The Sample Application > Optimize the Data Transfers > Decompress the Data on the Client | Search Helpcentral Search HelpCentral

Decompress the Data on the Client

Previous Next

To decompress the data on the client, we would modify the MasterDetail project by adding a reference to the C1.Zip library (Silverlight version), then change the svc_GetDataCompleted method in the Page.xaml.cs file as follows:

void svc_GetDataCompleted(object sender, GetDataCompletedEventArgs e)

{

// Handle errors

if (e.Error != null)

{

_tbStatus.Text = "Error downloading data...";

return;

}

// Parse data stream from server (DataSet as XML)

_tbStatus.Text = string.Format(

"Got data, {0:n0} kBytes", e.Result.Length / 1024);

var ms = new MemoryStream(e.Result);

_ds = new DataSet();

using (var zr = new C1.C1Zip.C1ZStreamReader(ms))

_ds.ReadXml(zr);

//_ds.ReadXml(ms);

// Got the data, bind controls to it

BindData();

}

Instead of reading the DataSet directly from the compressed stream, we are now reading it through a C1ZStreamReader that decompresses it automatically.

Note: Without compression, the application transfers about 150k bytes of data on startup. After making these small changes, the initial data transfer is reduced to less than 50k. The two small changes reduce the amount of data transferred by about two-thirds. This reduces network traffic and the time it takes for the application to initialize and show the data.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Conclusion

ComponentOne Studio for Silverlight: ComponentOne Data for Silverlight (C1.Silverlight.Data) > Conclusion | Search Helpcentral Search HelpCentral

Conclusion

Previous Next

It is possible to build data-centric Silverlight applications today, using familiar tools and techniques. The introduction of new data technologies does not mean ADO.NET developers have to throw out all their knowledge, tools, and existing code. In most cases, these new technologies extend rather than replace the existing tools and patterns.

C1.Silverlight.Data provides a Silverlight implementation of a substantial subset of the ADO.NET classes. This allows developers to:

· Leverage their knowledge of ADO.NET and the rich object model it provides, while at the same time enjoying the benefits of new technologies such as LINQ, WCF, and so on.

· Exchange relational data between client and server in a simple and efficient way;

· Write code that uses similar classes and object models on client and server. Server and client use the same language, similar classes, and similar object models.

Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


C1.C1Zip Namespace

[image]

.NET Framework Class Library
C1.C1Zip Namespace

Classes

Class | Description
C1ZipEntry | Represents an entry in a zip file, and exposes information including the entry name, compressed and uncompressed sizes, date, checksum, etc.
C1ZipEntryCollection | A collection of C1ZipEntry objects that represent the contents of a zip file.
C1ZipFile | Used for creating, opening, and managing zip files.
C1ZStreamReader | Decompresses data from .NET streams.
C1ZStreamWriter | Compresses data into .NET Streams.
ZipFileException | Exception thrown when trying to open an invalid Zip file.
ZipProgressEventArgs | Provides data for the Progress event of a C1ZipFile.

Delegates

Delegate | Description
ZipProgressEventHandler | Represents the method that will handle the Progress event of a C1ZipFile.

Enumerations

Enumeration | Description
CompressionLevelEnum | Specifies the level of compression to be applied when adding entries to a C1ZipFile.


C1ZipEntry Class

[image]

.NET Framework Class Library
C1ZipEntry Class
Members See Also
Represents an entry in a zip file, and exposes information including the entry name, compressed and uncompressed sizes, date, checksum, etc.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class C1ZipEntry
Visual Basic (Declaration)
Public Class C1ZipEntry

Inheritance Hierarchy

System..::.Object
C1.C1Zip..::.C1ZipEntry

See Also

C1ZipEntry Members
C1.C1Zip Namespace


C1ZipEntry Members

[image] [image]

.NET Framework Class Library
C1ZipEntry Members
C1ZipEntry Class Methods Properties See Also

The C1ZipEntry type exposes the following members.

Methods

Name | Description
CheckCRC32 | Calculates a checksum value for the entry and compares it to the checksum that was stored when the entry was created.
CheckPassword | Checks whether this C1ZipEntry can be read with the currently set password.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenReader | Returns a Stream that can be used to read the content of the entry without extracting it to a disk file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Attributes | Gets the file attributes associated with the entry.
Comment | Gets or sets a comment associated with the entry.
CRC32 | Gets the checksum calculated when the entry was compressed.
Date | Gets the date and time when the file used to create the entry was last modified.
FileName | Gets the entry name. This is usually a file name, optionally including a path.
IsEncrypted | Gets a value that determines whether the entry is encrypted.
SizeCompressed | Gets the compressed size of the entry, in bytes.
SizeUncompressed | Gets the original (uncompressed) size of the entry, in bytes.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


C1ZipEntry Methods

[image] [image]

.NET Framework Class Library
C1ZipEntry Methods
C1ZipEntry Class See Also

The C1ZipEntry type exposes the following members.

Methods

Name | Description
CheckCRC32 | Calculates a checksum value for the entry and compares it to the checksum that was stored when the entry was created.
CheckPassword | Checks whether this C1ZipEntry can be read with the currently set password.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenReader | Returns a Stream that can be used to read the content of the entry without extracting it to a disk file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ZipEntry Class
C1.C1Zip Namespace


CheckCRC32 Method

[image]

.NET Framework Class Library
C1ZipEntry..::.CheckCRC32 Method
C1ZipEntry Class See Also
Calculates a checksum value for the entry and compares it to the checksum that was stored when the entry was created.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool CheckCRC32()
Visual Basic (Declaration)
Public Function CheckCRC32 As Boolean

Return Value

True if the checksum values match, false otherwise.

Remarks

This method is used to check the integrity of the entries in the zip file. If the calculated checksum does not match the stored checksum, then either the zip file is corrupted or the program used to create the zip file is incompatible with C1Zip.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


CheckPassword Method

[image]

.NET Framework Class Library
C1ZipEntry..::.CheckPassword Method
C1ZipEntry Class See Also
Checks whether this C1ZipEntry can be read with the currently set password.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool CheckPassword()
Visual Basic (Declaration)
Public Function CheckPassword As Boolean

Return Value

True if the entry can be read with the current password, or if the entry is not encrypted.

Remarks

This method is more efficient than using a try/catch block and trying to open the entry to determine whether the current password is valid for the entry.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


OpenReader Method

[image]

.NET Framework Class Library
C1ZipEntry..::.OpenReader Method
C1ZipEntry Class See Also
Returns a Stream that can be used to read the content of the entry without extracting it to a disk file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public Stream OpenReader()
Visual Basic (Declaration)
Public Function OpenReader As Stream

Return Value

A Stream that can be used to read the data in the entry.

Remarks

The Stream returned is a C1ZStreamReader, which decompresses the data as it is read from the entry.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


C1ZipEntry Properties

[image] [image]

.NET Framework Class Library
C1ZipEntry Properties
C1ZipEntry Class See Also

The C1ZipEntry type exposes the following members.

Properties

Name | Description
Attributes | Gets the file attributes associated with the entry.
Comment | Gets or sets a comment associated with the entry.
CRC32 | Gets the checksum calculated when the entry was compressed.
Date | Gets the date and time when the file used to create the entry was last modified.
FileName | Gets the entry name. This is usually a file name, optionally including a path.
IsEncrypted | Gets a value that determines whether the entry is encrypted.
SizeCompressed | Gets the compressed size of the entry, in bytes.
SizeUncompressed | Gets the original (uncompressed) size of the entry, in bytes.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


Attributes Property

[image]

.NET Framework Class Library
C1ZipEntry..::.Attributes Property
C1ZipEntry Class See Also
Gets the file attributes associated with the entry.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public FileAttributes Attributes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Attributes As FileAttributes

See Also

C1ZipEntry Class
C1.C1Zip Namespace


Comment Property

[image]

.NET Framework Class Library
C1ZipEntry..::.Comment Property
C1ZipEntry Class See Also
Gets or sets a comment associated with the entry.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String

See Also

C1ZipEntry Class
C1.C1Zip Namespace


CRC32 Property

[image]

.NET Framework Class Library
C1ZipEntry..::.CRC32 Property
C1ZipEntry Class See Also
Gets the checksum calculated when the entry was compressed.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int CRC32 { get; }
Visual Basic (Declaration)
Public ReadOnly Property CRC32 As Integer

Remarks

This value can be used to check the integrity of the entry when it is decompressed.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


Date Property

[image]

.NET Framework Class Library
C1ZipEntry..::.Date Property
C1ZipEntry Class See Also
Gets the date and time when the file used to create the entry was last modified.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public DateTime Date { get; }
Visual Basic (Declaration)
Public ReadOnly Property Date As DateTime

Remarks

This value can be used to check whether an entry needs to be updated because the source file was modified since it was last compressed.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


FileName Property

[image]

.NET Framework Class Library
C1ZipEntry..::.FileName Property
C1ZipEntry Class See Also
Gets the entry name. This is usually a file name, optionally including a path.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String

See Also

C1ZipEntry Class
C1.C1Zip Namespace


IsEncrypted Property

[image]

.NET Framework Class Library
C1ZipEntry..::.IsEncrypted Property
C1ZipEntry Class See Also
Gets a value that determines whether the entry is encrypted.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool IsEncrypted { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEncrypted As Boolean

Remarks

Encrypted entries can only be extracted if the Password property on the containing C1ZipFile object is set to the password that was used when the file was added to the zip file.

See Also

C1ZipEntry Class
C1.C1Zip Namespace


SizeCompressed Property

[image]

.NET Framework Class Library
C1ZipEntry..::.SizeCompressed Property
C1ZipEntry Class See Also
Gets the compressed size of the entry, in bytes.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeCompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeCompressed As Integer

See Also

C1ZipEntry Class
C1.C1Zip Namespace


SizeUncompressed Property

[image]

.NET Framework Class Library
C1ZipEntry..::.SizeUncompressed Property
C1ZipEntry Class See Also
Gets the original (uncompressed) size of the entry, in bytes.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeUncompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeUncompressed As Integer

See Also

C1ZipEntry Class
C1.C1Zip Namespace


C1ZipEntryCollection Class

[image]

.NET Framework Class Library
C1ZipEntryCollection Class
Members See Also
A collection of C1ZipEntry objects that represent the contents of a zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class C1ZipEntryCollection : ICollection,
    IEnumerable
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class C1ZipEntryCollection _
    Implements ICollection, IEnumerable

Remarks

Use the C1ZipEntryCollection to programmatically manage the contents of zip files. You can add, remove, extract, or insert items into the C1ZipEntryCollection.

Inheritance Hierarchy

System..::.Object
C1.C1Zip..::.C1ZipEntryCollection

See Also

C1ZipEntryCollection Members
C1.C1Zip Namespace


C1ZipEntryCollection Members

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection Members
C1ZipEntryCollection Class Methods Properties See Also

The C1ZipEntryCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddFolder | Overloaded.
Contains | Determines whether the collection contains an entry with a given name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Extract | Overloaded.
ExtractFolder | Extracts the contents of the zip file into a specified path.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Gets the index of the entry with the specified name.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenWriter | Opens a stream for writing an entry into the zip file.
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of entries in the current zip file.
Item | Overloaded.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


C1ZipEntryCollection Methods

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection Methods
C1ZipEntryCollection Class See Also

The C1ZipEntryCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
AddFolder | Overloaded.
Contains | Determines whether the collection contains an entry with a given name.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Extract | Overloaded.
ExtractFolder | Extracts the contents of the zip file into a specified path.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Gets the index of the entry with the specified name.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OpenWriter | Opens a stream for writing an entry into the zip file.
Remove | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


Add Method

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method
C1ZipEntryCollection Class See Also

Overload List

Name | Description
Add(String) | Adds an entry to the current zip file.
Add(array<String>[]()[]) | Adds a list of entries to the current zip file.
Add(Stream, String) | Adds a stream to the current zip file.
Add(String, Int32) | Adds an entry to the current zip file.
Add(String, String) | Adds an entry to the current zip file.

See Also

C1ZipEntryCollection Class
C1ZipEntryCollection Members
C1.C1Zip Namespace


Add Method (String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method (String)
C1ZipEntryCollection Class See Also
Adds an entry to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Add(
    string fileName
)
Visual Basic (Declaration)
Public Sub Add ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
Name of the file to add to the zip file.

Remarks

By default, the directory name is not stored in the zip file. To store a specific part of the directory name in the zip file, use the overloaded version of the Add method with a pathLevels parameter.

See Also

C1ZipEntryCollection Class
Add Overload
C1.C1Zip Namespace


Add Method (String[])

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method (array<String>[]()[])
C1ZipEntryCollection Class See Also
Adds a list of entries to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Add(
    string[] fileNames
)
Visual Basic (Declaration)
Public Sub Add ( _
    fileNames As String() _
)

Parameters

fileNames
Type: array< System..::.String >[]()[]
Array containing the file names of the entries to be added to the zip file.

See Also

C1ZipEntryCollection Class
Add Overload
C1.C1Zip Namespace


Add Method (Stream, String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method (Stream, String)
C1ZipEntryCollection Class See Also
Adds a stream to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Add(
    Stream stream,
    string entryName
)
Visual Basic (Declaration)
Public Sub Add ( _
    stream As Stream, _
    entryName As String _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that contains data for the new entry.
entryName
Type: System..::.String
Name to be used for the new entry.

See Also

C1ZipEntryCollection Class
Add Overload
C1.C1Zip Namespace


Add Method (String, Int32)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method (String, Int32)
C1ZipEntryCollection Class See Also
Adds an entry to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Add(
    string fileName,
    int pathLevels
)
Visual Basic (Declaration)
Public Sub Add ( _
    fileName As String, _
    pathLevels As Integer _
)

Parameters

fileName
Type: System..::.String
Name of the file to add to the zip file.
pathLevels
Type: System..::.Int32
The number of path levels to be stored as the entry name.

Remarks

By default, path names are not stored in the zip file. For example, adding the file "c:\temp\samples\readme.txt" to the zip file will create an entry called "readme.txt".

The pathLevels parameter allows you to store one or more levels of the path in the entry name. For example, adding the file "c:\temp\samples\readme.txt" to the zip file with pathLevels=1 will create an entry called "samples\readme.txt".

See Also

C1ZipEntryCollection Class
Add Overload
C1.C1Zip Namespace


Add Method (String, String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Add Method (String, String)
C1ZipEntryCollection Class See Also
Adds an entry to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Add(
    string fileName,
    string entryName
)
Visual Basic (Declaration)
Public Sub Add ( _
    fileName As String, _
    entryName As String _
)

Parameters

fileName
Type: System..::.String
Name of the file to add to the zip file.
entryName
Type: System..::.String
Name of the new entry as stored in the zip file.

Remarks

By default, entries in the zip file have the same name as the original (uncompressed) file. This method allows you to specify a different name, including a path for example.

See Also

C1ZipEntryCollection Class
Add Overload
C1.C1Zip Namespace


AddFolder Method

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection..::.AddFolder Method
C1ZipEntryCollection Class See Also

Overload List

Name | Description
AddFolder(String) | Adds the content of a folder to the current zip file.
AddFolder(String, String) | Adds the content of a folder to the current zip file.
AddFolder(String, String, Boolean) | Adds the content of a folder to the current zip file.

See Also

C1ZipEntryCollection Class
C1ZipEntryCollection Members
C1.C1Zip Namespace


AddFolder Method (String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.AddFolder Method (String)
C1ZipEntryCollection Class See Also
Adds the content of a folder to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void AddFolder(
    string path
)
Visual Basic (Declaration)
Public Sub AddFolder ( _
    path As String _
)

Parameters

path
Type: System..::.String
The full path of the folder to be added to the zip file.

Remarks

This method adds all files and sub folders to the zip file.

See Also

C1ZipEntryCollection Class
AddFolder Overload
C1.C1Zip Namespace


AddFolder Method (String, String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.AddFolder Method (String, String)
C1ZipEntryCollection Class See Also
Adds the content of a folder to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void AddFolder(
    string path,
    string searchPattern
)
Visual Basic (Declaration)
Public Sub AddFolder ( _
    path As String, _
    searchPattern As String _
)

Parameters

path
Type: System..::.String
The full path of the folder to be added to the zip file.
searchPattern
Type: System..::.String
A mask that specifies which files to add.

Remarks

If the folder contains sub folders, those are also added to the zip file.

See Also

C1ZipEntryCollection Class
AddFolder Overload
C1.C1Zip Namespace


AddFolder Method (String, String, Boolean)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.AddFolder Method (String, String, Boolean)
C1ZipEntryCollection Class See Also
Adds the content of a folder to the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void AddFolder(
    string path,
    string searchPattern,
    bool includeSubfolders
)
Visual Basic (Declaration)
Public Sub AddFolder ( _
    path As String, _
    searchPattern As String, _
    includeSubfolders As Boolean _
)

Parameters

path
Type: System..::.String
The full path of the folder to be added to the zip file.
searchPattern
Type: System..::.String
A mask that specifies which files to add.
includeSubfolders
Type: System..::.Boolean
True to include sub folders, false to include only files at the root level.

See Also

C1ZipEntryCollection Class
AddFolder Overload
C1.C1Zip Namespace


Contains Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Contains Method
C1ZipEntryCollection Class See Also
Determines whether the collection contains an entry with a given name.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Name of the entry to look for.

Return Value

True if the collection contains an entry with the given name, false otherwise.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


Extract Method

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection..::.Extract Method
C1ZipEntryCollection Class See Also

Overload List

Name | Description
Extract(Int32) | Extracts a file from the current zip file.
Extract(String) | Extracts a file from the current zip file.
Extract(Int32, String) | Extracts a file from the current zip file.
Extract(String, String) | Extracts a file from the current zip file.

See Also

C1ZipEntryCollection Class
C1ZipEntryCollection Members
C1.C1Zip Namespace


Extract Method (Int32)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Extract Method (Int32)
C1ZipEntryCollection Class See Also
Extracts a file from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Extract(
    int index
)
Visual Basic (Declaration)
Public Sub Extract ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Index of the entry to extract.

Remarks

The entry is extracted to a file in the same folder as the current zip file, with the same name as the entry.

See Also

C1ZipEntryCollection Class
Extract Overload
C1.C1Zip Namespace


Extract Method (String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Extract Method (String)
C1ZipEntryCollection Class See Also
Extracts a file from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Extract(
    string entryName
)
Visual Basic (Declaration)
Public Sub Extract ( _
    entryName As String _
)

Parameters

entryName
Type: System..::.String
Name of the entry to extract.

Remarks

The entry is extracted to a file in the same folder as the current zip file, with the same name as the entry.

See Also

C1ZipEntryCollection Class
Extract Overload
C1.C1Zip Namespace


Extract Method (Int32, String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Extract Method (Int32, String)
C1ZipEntryCollection Class See Also
Extracts a file from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Extract(
    int index,
    string destFileName
)
Visual Basic (Declaration)
Public Sub Extract ( _
    index As Integer, _
    destFileName As String _
)

Parameters

index
Type: System..::.Int32
Index of the entry to extract.
destFileName
Type: System..::.String
Name and location of the extracted file.

See Also

C1ZipEntryCollection Class
Extract Overload
C1.C1Zip Namespace


Extract Method (String, String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Extract Method (String, String)
C1ZipEntryCollection Class See Also
Extracts a file from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Extract(
    string entryName,
    string destFileName
)
Visual Basic (Declaration)
Public Sub Extract ( _
    entryName As String, _
    destFileName As String _
)

Parameters

entryName
Type: System..::.String
Name of the entry to extract.
destFileName
Type: System..::.String
Name and location of the extracted file.

See Also

C1ZipEntryCollection Class
Extract Overload
C1.C1Zip Namespace


ExtractFolder Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.ExtractFolder Method
C1ZipEntryCollection Class See Also
Extracts the contents of the zip file into a specified path.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void ExtractFolder(
    string path
)
Visual Basic (Declaration)
Public Sub ExtractFolder ( _
    path As String _
)

Parameters

path
Type: System..::.String
Destination path for the unzipped files.

Remarks

If the zip file contains compressed folders, new folders will be created under the destination path to preserve the hierarchical structure of the archive.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


IndexOf Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.IndexOf Method
C1ZipEntryCollection Class See Also
Gets the index of the entry with the specified name.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int IndexOf(
    string name
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    name As String _
) As Integer

Parameters

name
Type: System..::.String
Name of the entry to look for.

Return Value

The index of the entry in the collection or -1 if the entry was not found.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


OpenWriter Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.OpenWriter Method
C1ZipEntryCollection Class See Also
Opens a stream for writing an entry into the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public Stream OpenWriter(
    string entryName,
    bool useMemory
)
Visual Basic (Declaration)
Public Function OpenWriter ( _
    entryName As String, _
    useMemory As Boolean _
) As Stream

Parameters

entryName
Type: System..::.String
The name of the new entry.
useMemory
Type: System..::.Boolean
Whether to use a memory stream or temporary file.

Return Value

A stream that can be used to write data into the zip file. The entry is not added until the stream is closed.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection..::.Remove Method
C1ZipEntryCollection Class See Also

Overload List

Name | Description
Remove(Int32) | Removes an entry from the current zip file.
Remove(array<Int32>[]()[]) | Removes several entries from the current zip file.
Remove(String) | Removes an entry from the current zip file.
Remove(array<String>[]()[]) | Removes several entries from the current zip file.

See Also

C1ZipEntryCollection Class
C1ZipEntryCollection Members
C1.C1Zip Namespace


Remove Method (Int32)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Remove Method (Int32)
C1ZipEntryCollection Class See Also
Removes an entry from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Remove(
    int index
)
Visual Basic (Declaration)
Public Sub Remove ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Index of the entry to remove.

See Also

C1ZipEntryCollection Class
Remove Overload
C1.C1Zip Namespace


Remove Method (Int32[])

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Remove Method (array<Int32>[]()[])
C1ZipEntryCollection Class See Also
Removes several entries from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Remove(
    int[] indices
)
Visual Basic (Declaration)
Public Sub Remove ( _
    indices As Integer() _
)

Parameters

indices
Type: array< System..::.Int32 >[]()[]
Array containing the indices of the entries to remove.

See Also

C1ZipEntryCollection Class
Remove Overload
C1.C1Zip Namespace


Remove Method (String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Remove Method (String)
C1ZipEntryCollection Class See Also
Removes an entry from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Remove(
    string fileName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
Name of the entry to remove (case-insensitive).

See Also

C1ZipEntryCollection Class
Remove Overload
C1.C1Zip Namespace


Remove Method (String[])

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Remove Method (array<String>[]()[])
C1ZipEntryCollection Class See Also
Removes several entries from the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Remove(
    string[] entryNames
)
Visual Basic (Declaration)
Public Sub Remove ( _
    entryNames As String() _
)

Parameters

entryNames
Type: array< System..::.String >[]()[]
Array containing the names of the entries to remove.

See Also

C1ZipEntryCollection Class
Remove Overload
C1.C1Zip Namespace


C1ZipEntryCollection Properties

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection Properties
C1ZipEntryCollection Class See Also

The C1ZipEntryCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of entries in the current zip file.
Item | Overloaded.

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


Count Property

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Count Property
C1ZipEntryCollection Class See Also
Gets the number of entries in the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

Implements

ICollection..::.Count

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


Item Property

[image] [image]

.NET Framework Class Library
C1ZipEntryCollection..::.Item Property
C1ZipEntryCollection Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the C1ZipEntry at the specified index.
Item[([(String])]) | Gets the C1ZipEntry with the given name (returns null if the entry cannot be found).

See Also

C1ZipEntryCollection Class
C1ZipEntryCollection Members
C1.C1Zip Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Item Property (Int32)
C1ZipEntryCollection Class See Also
Gets the C1ZipEntry at the specified index.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipEntry this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As C1ZipEntry

Parameters

index
Type: System..::.Int32

See Also

C1ZipEntryCollection Class
Item Overload
C1.C1Zip Namespace


Item Property (String)

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.Item Property (String)
C1ZipEntryCollection Class See Also
Gets the C1ZipEntry with the given name (returns null if the entry cannot be found).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipEntry this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As C1ZipEntry

Parameters

name
Type: System..::.String

See Also

C1ZipEntryCollection Class
Item Overload
C1.C1Zip Namespace


C1ZipFile Class

[image]

.NET Framework Class Library
C1ZipFile Class
Members Example See Also
Used for creating, opening, and managing zip files.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class C1ZipFile : IDisposable
Visual Basic (Declaration)
Public Class C1ZipFile _
    Implements IDisposable

Remarks

Use the Open(String) or Create(String) methods to associate the C1Zip file object with a zip file on disk. Then use the Entries property to add, remove, retrieve, or inspect individual entries in the zip file.

C1ZipFile can only be used with standard zip files. The component does not support other similar formats such as gzip, zip2, tar, or rar.

The standard zip file imposes some limitations on the size of each entry. You cannot use it to compress files larger than 4 gigabytes (uint.MaxValue).

Examples

The code below creates a zip file called sources.zip and adds all files with a "cs" extension to the zip file:
Copy CodeC#
// get path for zip file and files to compress
string path = Application.ExecutablePath;
int pos = path.IndexOf(@"\bin");
path = path.Substring(0, pos + 1);

// create a zip file
C1ZipFile zip = new C1ZipFile();
zip.Create(path + "source.zip");

// add all files with extension cs to the zip file
foreach (string fileName in Directory.GetFiles(path, "*.cs"))
    zip.Entries.Add(fileName);

// show result
foreach (C1ZipEntry ze in zip.Entries)
{
    Console.WriteLine("{0} {1:#,##0} {2:#,##0}",
        ze.FileName, ze.SizeUncompressed, ze.SizeCompressed);
}

Inheritance Hierarchy

System..::.Object
C1.C1Zip..::.C1ZipFile

See Also

C1ZipFile Members
C1.C1Zip Namespace


C1ZipFile Members

[image] [image]

.NET Framework Class Library
C1ZipFile Members
C1ZipFile Class Constructors Methods Properties Events See Also

The C1ZipFile type exposes the following members.

Constructors

Name | Description
C1ZipFile | Overloaded.

Methods

Name | Description
Close | Resets all data members of the C1ZipFile object.
CloseBatch | Closes a zip file after it was opened with a call to the OpenBatch()()() method.
Create | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsZipFile | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Overloaded.
OpenBatch | Opens the zip file for multiple operations.
Refresh | Refreshes all data members by re-opening the current zip file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comment | Gets or sets a comment associated with the current zip file.
CompressionLevel | Gets or sets the compression level to use when adding entries to the zip file.
Entries | Gets a C1ZipEntryCollection that contains the entries in the zip file.
FileName | Gets the name of the current zip file.
MemoryThreshold | Gets or sets the size of the largest stream to be compressed in memory.
OverwriteHidden | Determines whether the component should overwrite hidden files when extracting entries from the zip file.
OverwriteReadOnly | Determines whether the component should overwrite read-only files when extracting entries from the zip file.
OverwriteSystem | Determines whether the component should overwrite system files when extracting entries from the zip file.
Password | Gets or sets the password to use when adding or retrieving entries from the zip file.
TempFileName | Gets or sets the name of the temporary file to use when adding entries to the zip file.

Events

Name | Description
Progress | Fired while data is being read from or written into a zip file.

See Also

C1ZipFile Class
C1.C1Zip Namespace


C1ZipFile Constructor

[image] [image]

.NET Framework Class Library
C1ZipFile Constructor
C1ZipFile Class See Also

Overload List

Name | Description
C1ZipFile()()() | Initializes a new instance of the C1ZipFile class.
C1ZipFile(Stream) | Initializes a new instance of the C1ZipFile class and opens a zip stream associated with this new instance.
C1ZipFile(String) | Initializes a new instance of the C1ZipFile class and opens a zip file associated with this new instance.
C1ZipFile(Stream, Boolean) | Initializes a new instance of the C1ZipFile class and opens a zip stream associated with this new instance.
C1ZipFile(String, Boolean) | Initializes a new instance of the C1ZipFile class and creates or opens a zip file associated with this new instance.

See Also

C1ZipFile Class
C1ZipFile Members
C1.C1Zip Namespace


C1ZipFile Constructor

[image]

.NET Framework Class Library
C1ZipFile Constructor
C1ZipFile Class See Also
Initializes a new instance of the C1ZipFile class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipFile()
Visual Basic (Declaration)
Public Sub New

See Also

C1ZipFile Class
C1ZipFile Overload
C1.C1Zip Namespace


C1ZipFile Constructor (Stream)

[image]

.NET Framework Class Library
C1ZipFile Constructor (Stream)
C1ZipFile Class See Also
Initializes a new instance of the C1ZipFile class and opens a zip stream associated with this new instance.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipFile(
    Stream stream
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that contains the zip data.

See Also

C1ZipFile Class
C1ZipFile Overload
C1.C1Zip Namespace


C1ZipFile Constructor (String)

[image]

.NET Framework Class Library
C1ZipFile Constructor (String)
C1ZipFile Class See Also
Initializes a new instance of the C1ZipFile class and opens a zip file associated with this new instance.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipFile(
    string fileName
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
The name of the zip file to open.

Remarks

If the file does not exist, a new empty file is created.

See Also

C1ZipFile Class
C1ZipFile Overload
C1.C1Zip Namespace


C1ZipFile Constructor (Stream, Boolean)

[image]

.NET Framework Class Library
C1ZipFile Constructor (Stream, Boolean)
C1ZipFile Class See Also
Initializes a new instance of the C1ZipFile class and opens a zip stream associated with this new instance.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipFile(
    Stream stream,
    bool create
)
Visual Basic (Declaration)
Public Sub New ( _
    stream As Stream, _
    create As Boolean _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that contains the zip data.
create
Type: System..::.Boolean
Whether to initialize the stream with an empty zip header or open an existing zip file in the stream.

See Also

C1ZipFile Class
C1ZipFile Overload
C1.C1Zip Namespace


C1ZipFile Constructor (String, Boolean)

[image]

.NET Framework Class Library
C1ZipFile Constructor (String, Boolean)
C1ZipFile Class See Also
Initializes a new instance of the C1ZipFile class and creates or opens a zip file associated with this new instance.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipFile(
    string fileName,
    bool create
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String, _
    create As Boolean _
)

Parameters

fileName
Type: System..::.String
The name of the zip file to open or create.
create
Type: System..::.Boolean
True to create a new zip file, false to open an existing file.

Remarks

If create is true and the zip file already exists, it is overwritten with a new empty file.

If create is false and the zip file already exists, the existing file is opened.

See Also

C1ZipFile Class
C1ZipFile Overload
C1.C1Zip Namespace


C1ZipFile Methods

[image] [image]

.NET Framework Class Library
C1ZipFile Methods
C1ZipFile Class See Also

The C1ZipFile type exposes the following members.

Methods

Name | Description
Close | Resets all data members of the C1ZipFile object.
CloseBatch | Closes a zip file after it was opened with a call to the OpenBatch()()() method.
Create | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IsZipFile | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Open | Overloaded.
OpenBatch | Opens the zip file for multiple operations.
Refresh | Refreshes all data members by re-opening the current zip file.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ZipFile Class
C1.C1Zip Namespace


Close Method

[image]

.NET Framework Class Library
C1ZipFile..::.Close Method
C1ZipFile Class See Also
Resets all data members of the C1ZipFile object.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close

Remarks

Disk files are automatically closed by C1Zip. You only need to use this method if you want to break the connection between a C1ZipFile class and a physical zip file.

See Also

C1ZipFile Class
C1.C1Zip Namespace


CloseBatch Method

[image]

.NET Framework Class Library
C1ZipFile..::.CloseBatch Method
C1ZipFile Class See Also
Closes a zip file after it was opened with a call to the OpenBatch()()() method.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void CloseBatch()
Visual Basic (Declaration)
Public Sub CloseBatch

Remarks

See the OpenBatch()()() method for a complete description and a sample.

See Also

C1ZipFile Class
C1.C1Zip Namespace


Create Method

[image] [image]

.NET Framework Class Library
C1ZipFile..::.Create Method
C1ZipFile Class See Also

Overload List

Name | Description
Create(Stream) | Creates a new zip file in a stream.
Create(String) | Creates an empty zip file on disk.

See Also

C1ZipFile Class
C1ZipFile Members
C1.C1Zip Namespace


Create Method (Stream)

[image]

.NET Framework Class Library
C1ZipFile..::.Create Method (Stream)
C1ZipFile Class Example See Also
Creates a new zip file in a stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Create(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Create ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that will contain the new zip file.

Examples

The code below creates a new C1ZipFile on a memory stream, then adds several files to it. Finally, the code gets the zipped data out as an array of bytes, which, for example, could be stored in a database.
Copy CodeC#
// create zip on a stream
MemoryStream msZip = new MemoryStream();
C1ZipFile zip = new C1ZipFile(msZip, true);

// add some entries to it
foreach (string f in Directory.GetFiles(@"c:\WINDOWS\Web\Wallpaper"))
{
  zip.Entries.Add(f);
}

// get zipped data out as a byte array
byte[] zipData = msZip.ToArray();

See Also

C1ZipFile Class
Create Overload
C1.C1Zip Namespace


Create Method (String)

[image]

.NET Framework Class Library
C1ZipFile..::.Create Method (String)
C1ZipFile Class See Also
Creates an empty zip file on disk.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Create(
    string fileName
)
Visual Basic (Declaration)
Public Sub Create ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
The name of the zip file to create, including the path.

Remarks

If a file by the same name already exists, it is deleted before the new one is created.

See Also

C1ZipFile Class
Create Overload
C1.C1Zip Namespace


IsZipFile Method

[image] [image]

.NET Framework Class Library
C1ZipFile..::.IsZipFile Method
C1ZipFile Class See Also

Overload List

Name | Description
IsZipFile(Stream) | Tests whether a stream contains a valid zip file.
IsZipFile(String) | Tests whether a file is a valid zip file.

See Also

C1ZipFile Class
C1ZipFile Members
C1.C1Zip Namespace


IsZipFile Method (Stream)

[image]

.NET Framework Class Library
C1ZipFile..::.IsZipFile Method (Stream)
C1ZipFile Class See Also
Tests whether a stream contains a valid zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public static bool IsZipFile(
    Stream stream
)
Visual Basic (Declaration)
Public Shared Function IsZipFile ( _
    stream As Stream _
) As Boolean

Parameters

stream
Type: System.IO..::.Stream
Stream to test.

Return Value

True if stream contains a valid zip file, false otherwise.

See Also

C1ZipFile Class
IsZipFile Overload
C1.C1Zip Namespace


IsZipFile Method (String)

[image]

.NET Framework Class Library
C1ZipFile..::.IsZipFile Method (String)
C1ZipFile Class See Also
Tests whether a file is a valid zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public static bool IsZipFile(
    string fileName
)
Visual Basic (Declaration)
Public Shared Function IsZipFile ( _
    fileName As String _
) As Boolean

Parameters

fileName
Type: System..::.String
Name of the file to test.

Return Value

True if the file exists and is a valid zip file, false otherwise.

See Also

C1ZipFile Class
IsZipFile Overload
C1.C1Zip Namespace


Open Method

[image] [image]

.NET Framework Class Library
C1ZipFile..::.Open Method
C1ZipFile Class See Also

Overload List

Name | Description
Open(Stream) | Opens an existing zip file stored in a stream.
Open(String) | Opens an existing zip file.

See Also

C1ZipFile Class
C1ZipFile Members
C1.C1Zip Namespace


Open Method (Stream)

[image]

.NET Framework Class Library
C1ZipFile..::.Open Method (Stream)
C1ZipFile Class Example See Also
Opens an existing zip file stored in a stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Open(
    Stream stream
)
Visual Basic (Declaration)
Public Sub Open ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that contains a zip file.

Remarks

This method allows you to open and work with a zip file stored in a stream instead of in an actual file.

Typical usage scenarios for this are zip files stored as application resources or in binary database fields.

Examples

The example below loads information from a zip file stored in an embedded resource. To embed a zip file in an application, follow these steps:

1) Right-click the project node in Visual Studio, select the Add | Add Existing Item... menu option.

2) Select a zip file to add to the project as an embedded resource.

3) Select the newly added file and make sure the Build Action property is set to "Embedded Resource".

Copy CodeC#
// get Stream from application resources
System.Reflection.Assembly a = this.GetType().Assembly;
using (Stream stream = a.GetManifestResourceStream("MyApp.test.zip"))
{
  // open C1ZipFile on the stream
  zip.Open(stream);

  // enumerate the entries in the zip file,
  foreach (C1ZipEntry ze in zip.Entries)
  {
    // show entries that have a 'txt' extension.
    if (ze.FileName.ToLower().EndsWith(".txt"))
    {
      using (StreamReader sr = new StreamReader(ze.OpenReader()))
      {
        MessageBox.Show(sr.ReadToEnd(), ze.FileName);
      }
    }
  }
}

See Also

C1ZipFile Class
Open Overload
C1.C1Zip Namespace


Open Method (String)

[image]

.NET Framework Class Library
C1ZipFile..::.Open Method (String)
C1ZipFile Class See Also
Opens an existing zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Open(
    string fileName
)
Visual Basic (Declaration)
Public Sub Open ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
The name of an existing zip file, including the path.

Remarks

This method checks that the zip file exists and is a valid zip file, then reads the zip file directory into the Entries collection. The zip file is then closed, and can be used by other applications. There is no need to close the zip file explicitly.

See Also

C1ZipFile Class
Open Overload
C1.C1Zip Namespace


OpenBatch Method

[image]

.NET Framework Class Library
C1ZipFile..::.OpenBatch Method
C1ZipFile Class Example See Also
Opens the zip file for multiple operations.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void OpenBatch()
Visual Basic (Declaration)
Public Sub OpenBatch

Remarks

By default, C1ZipFile opens and closes the zip file automatically whenever entries are added or removed.

This can cause delays in systems that have certain types of anti-virus software installed, or in situations where you want to add a large number of relatively small entries. In these cases, use the OpenBatch()()() and CloseBatch()()() methods to keep the zip file open until the entire operation is concluded.

Use a finally clause to ensure that the CloseBatch()()() method is called even if an exception occurs.

Examples

The code below opens a zip file, adds several entries to it, then closes the file:
Copy CodeC#
C1ZipFile zip = new C1ZipFile();
zip.Open(myzipfile);
try
{
    zip.OpenBatch();
    foreach (string fileName in Directory.GetFiles(path, "*.*"))
        zip.Entries.Add(fileName);
}
finally
{
    zip.CloseBatch();
}

See Also

C1ZipFile Class
C1.C1Zip Namespace


Refresh Method

[image]

.NET Framework Class Library
C1ZipFile..::.Refresh Method
C1ZipFile Class See Also
Refreshes all data members by re-opening the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh

Remarks

This method is useful in instances where other applications may have changed the zip file and you want to make sure the information in the Entries collection is up to date.

See Also

C1ZipFile Class
C1.C1Zip Namespace


C1ZipFile Properties

[image] [image]

.NET Framework Class Library
C1ZipFile Properties
C1ZipFile Class See Also

The C1ZipFile type exposes the following members.

Properties

Name | Description
Comment | Gets or sets a comment associated with the current zip file.
CompressionLevel | Gets or sets the compression level to use when adding entries to the zip file.
Entries | Gets a C1ZipEntryCollection that contains the entries in the zip file.
FileName | Gets the name of the current zip file.
MemoryThreshold | Gets or sets the size of the largest stream to be compressed in memory.
OverwriteHidden | Determines whether the component should overwrite hidden files when extracting entries from the zip file.
OverwriteReadOnly | Determines whether the component should overwrite read-only files when extracting entries from the zip file.
OverwriteSystem | Determines whether the component should overwrite system files when extracting entries from the zip file.
Password | Gets or sets the password to use when adding or retrieving entries from the zip file.
TempFileName | Gets or sets the name of the temporary file to use when adding entries to the zip file.

See Also

C1ZipFile Class
C1.C1Zip Namespace


Comment Property

[image]

.NET Framework Class Library
C1ZipFile..::.Comment Property
C1ZipFile Class See Also
Gets or sets a comment associated with the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string Comment { get; set; }
Visual Basic (Declaration)
Public Property Comment As String

See Also

C1ZipFile Class
C1.C1Zip Namespace


CompressionLevel Property

[image]

.NET Framework Class Library
C1ZipFile..::.CompressionLevel Property
C1ZipFile Class See Also
Gets or sets the compression level to use when adding entries to the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public CompressionLevelEnum CompressionLevel { get; set; }
Visual Basic (Declaration)
Public Property CompressionLevel As CompressionLevelEnum

Remarks

Higher compression settings create smaller files, but take longer to process. The default setting (DefaultCompression) provides a good trade-off between compression and speed.

See Also

C1ZipFile Class
C1.C1Zip Namespace


Entries Property

[image]

.NET Framework Class Library
C1ZipFile..::.Entries Property
C1ZipFile Class See Also
Gets a C1ZipEntryCollection that contains the entries in the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZipEntryCollection Entries { get; }
Visual Basic (Declaration)
Public ReadOnly Property Entries As C1ZipEntryCollection

Remarks

The Entries collection is used to enumerate the entries in the zip file, and also to add, remove, and expand entries.

See Also

C1ZipFile Class
C1.C1Zip Namespace


FileName Property

[image]

.NET Framework Class Library
C1ZipFile..::.FileName Property
C1ZipFile Class See Also
Gets the name of the current zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string FileName { get; }
Visual Basic (Declaration)
Public ReadOnly Property FileName As String

See Also

C1ZipFile Class
C1.C1Zip Namespace


MemoryThreshold Property

[image]

.NET Framework Class Library
C1ZipFile..::.MemoryThreshold Property
C1ZipFile Class See Also
Gets or sets the size of the largest stream to be compressed in memory.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int MemoryThreshold { get; set; }
Visual Basic (Declaration)
Public Property MemoryThreshold As Integer

Remarks

C1ZipFile compresses entries into temporary streams before adding them to the zip file.

Entries with fewer than MemoryThreshold bytes are compressed using a temporary memory stream.

Entries with more than MemoryThreshold bytes are compressed using a temporary file. You can control the location of the temporary file using the TempFileName property.

See Also

C1ZipFile Class
C1.C1Zip Namespace


OverwriteHidden Property

[image]

.NET Framework Class Library
C1ZipFile..::.OverwriteHidden Property
C1ZipFile Class See Also
Determines whether the component should overwrite hidden files when extracting entries from the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool OverwriteHidden { get; set; }
Visual Basic (Declaration)
Public Property OverwriteHidden As Boolean

See Also

C1ZipFile Class
C1.C1Zip Namespace


OverwriteReadOnly Property

[image]

.NET Framework Class Library
C1ZipFile..::.OverwriteReadOnly Property
C1ZipFile Class See Also
Determines whether the component should overwrite read-only files when extracting entries from the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool OverwriteReadOnly { get; set; }
Visual Basic (Declaration)
Public Property OverwriteReadOnly As Boolean

See Also

C1ZipFile Class
C1.C1Zip Namespace


OverwriteSystem Property

[image]

.NET Framework Class Library
C1ZipFile..::.OverwriteSystem Property
C1ZipFile Class See Also
Determines whether the component should overwrite system files when extracting entries from the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool OverwriteSystem { get; set; }
Visual Basic (Declaration)
Public Property OverwriteSystem As Boolean

See Also

C1ZipFile Class
C1.C1Zip Namespace


Password Property

[image]

.NET Framework Class Library
C1ZipFile..::.Password Property
C1ZipFile Class See Also
Gets or sets the password to use when adding or retrieving entries from the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string Password { get; set; }
Visual Basic (Declaration)
Public Property Password As String

Remarks

If the Password property is set to a non-empty string, any entries added to the zip file will be encrypted and protected by the password. To extract these entries later, the same password must be used.

The password applies to all entries from the moment it is set. If you set the password to a non-empty string and then add several entries to the zip file, all entries will use the same password.

Although C1Zip supports Unicode characters in passwords, several popular zip utilities do not. To ensure your encrypted zip files can be opened with third-party utilities, use passwords that consist of ASCII characters only.

See Also

C1ZipFile Class
C1.C1Zip Namespace


TempFileName Property

[image]

.NET Framework Class Library
C1ZipFile..::.TempFileName Property
C1ZipFile Class See Also
Gets or sets the name of the temporary file to use when adding entries to the zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string TempFileName { get; set; }
Visual Basic (Declaration)
Public Property TempFileName As String

Remarks

C1ZipFile creates temporary streams while adding entries to a zip file. These temporary streams can be memory-based or disk-based, depending on the size of the entry and on the setting of the MemoryThreshold property.

If a temporary file is used, C1ZipFile you can control its location by setting the TempFileName property. If you don't select a path for the temporary file, C1ZipFile will create one automatically using the GetTempFileName()()() method.

See Also

C1ZipFile Class
C1.C1Zip Namespace


C1ZipFile Events

[image] [image]

.NET Framework Class Library
C1ZipFile Events
C1ZipFile Class See Also

The C1ZipFile type exposes the following members.

Events

Name | Description
Progress | Fired while data is being read from or written into a zip file.

See Also

C1ZipFile Class
C1.C1Zip Namespace


Progress Event

[image]

.NET Framework Class Library
C1ZipFile..::.Progress Event
C1ZipFile Class Example See Also
Fired while data is being read from or written into a zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public event ZipProgressEventHandler Progress
Visual Basic (Declaration)
Public Event Progress As ZipProgressEventHandler

Remarks

This event is typically used to update the application UI during lengthy operations. It can also be used to cancel the operations.

Examples

The code below writes messages to the output window while the application compresses files.
Copy CodeC#
private void Compress()
{
       // create zip file
       C1Zip zip = new C1Zip();
       zip.Create(zipFileName);

       // connect event handler
       zip.Progress += new ZipProgressEventHandler(zip_Progress);

       // add files
       foreach (string fileName in Directory.GetFiles(path, "*.*"))
           zip.Entries.Add(fileName);
   }

// print messages while files are compressed
private void zip_Progress(object sender, ZipProgressEventArgs e)
{
       Console.WriteLine("Compressing {0}, {1:p0} done",
           e.FileName, e.Position/(float)e.FileLength);
   }

See Also

C1ZipFile Class
C1.C1Zip Namespace


C1ZStreamReader Class

[image]

.NET Framework Class Library
C1ZStreamReader Class
Members Example See Also
Decompresses data from .NET streams.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class C1ZStreamReader : Stream
Visual Basic (Declaration)
Public Class C1ZStreamReader _
    Inherits Stream

Remarks

To decompress data from a compressed stream, create a C1ZStreamReader object passing the compressed stream to the C1ZStreamReader constructor.

Then read the data from the C1ZStreamReader using the Read(array<Byte>[]()[], Int32, Int32) method, or create a StreamReader on the C1ZStreamReader. The second option is indicated when you want to read formatted data.

Examples

The code below decompresses a string that was stored into a memory stream object:
Copy CodeC#
public string ExpandString(byte[] buffer)
{
    // turn buffer into a memory stream
    MemoryStream ms = new MemoryStream(buffer);

    // attach decompressor stream to memory stream
    C1ZStreamReader sr = new C1ZStreamReader(ms);

    // read uncompressed data
    StreamReader reader = new StreamReader(sr);
    return reader.ReadToEnd();
}

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.IO..::.Stream
C1.C1Zip..::.C1ZStreamReader

See Also

C1ZStreamReader Members
C1.C1Zip Namespace


C1ZStreamReader Members

[image] [image]

.NET Framework Class Library
C1ZStreamReader Members
C1ZStreamReader Class Constructors Methods Properties See Also

The C1ZStreamReader type exposes the following members.

Constructors

Name | Description
C1ZStreamReader | Overloaded.

Methods

Name | Description
BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Close | Closes the current stream compressor and flushed any pending data into the base stream. If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it. (Overrides Stream..::.Close()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose | Overloaded.
EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying stream. (Overrides Stream..::.Flush()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Read | Reads a sequence of bytes from the underlying compressed stream, decompressing them into a buffer, then advances the position within the stream by the number of bytes read. (Overrides Stream..::.Read(array<Byte>[]()[], Int32, Int32).)
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Overrides Stream..::.ReadByte()()().)
Seek | Not supported. (Overrides Stream..::.Seek(Int64, SeekOrigin).)
SetLength | Sets the number of compressed bytes to read from the underlying stream. (Overrides Stream..::.SetLength(Int64).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | This method is overridden and is not supported by the C1ZStreamReader class. (Overrides Stream..::.Write(array<Byte>[]()[], Int32, Int32).)
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

Properties

Name | Description
BaseStream | Gets the underlying stream that contains the compressed data.
CanRead | Always returns True. (Overrides Stream..::.CanRead.)
CanSeek | Always returns False. (Overrides Stream..::.CanSeek.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Always returns False. (Overrides Stream..::.CanWrite.)
Length | Gets the length of the compressed stream if it is known (or -1 if the length of the compressed stream is unknown). (Overrides Stream..::.Length.)
OwnsBaseStream | Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).
Position | Gets the position within the stream (read-only). (Overrides Stream..::.Position.)
ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
SizeCompressed | Gets the number of bytes in the stream (compressed bytes).
SizeUncompressed | Gets the number of bytes that were compressed into the stream (uncompressed bytes).
WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
ZStream | Gets the ZStream instance wrapped by this C1ZStreamWriter.

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


C1ZStreamReader Constructor

[image] [image]

.NET Framework Class Library
C1ZStreamReader Constructor
C1ZStreamReader Class See Also

Overload List

Name | Description
C1ZStreamReader(Stream) | Initializes a new instance of the C1ZStreamReader class.
C1ZStreamReader(Stream, Boolean) | Initializes a new instance of the C1ZStreamReader class.
C1ZStreamReader(Stream, Boolean, Boolean) | Initializes a new instance of the C1ZStreamReader class.
C1ZStreamReader(Stream, Boolean, Int32) | Initializes a new instance of the C1ZStreamReader class.
C1ZStreamReader(Stream, Boolean, Int32, Int32) | Initializes a new instance of the C1ZStreamReader class.

See Also

C1ZStreamReader Class
C1ZStreamReader Members
C1.C1Zip Namespace


C1ZStreamReader Constructor (Stream)

[image]

.NET Framework Class Library
C1ZStreamReader Constructor (Stream)
C1ZStreamReader Class See Also
Initializes a new instance of the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamReader(
    Stream baseStream
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream _
)

Parameters

baseStream
Type: System.IO..::.Stream
Input stream that contains the compressed data.

See Also

C1ZStreamReader Class
C1ZStreamReader Overload
C1.C1Zip Namespace


C1ZStreamReader Constructor (Stream, Boolean)

[image]

.NET Framework Class Library
C1ZStreamReader Constructor (Stream, Boolean)
C1ZStreamReader Class See Also
Initializes a new instance of the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamReader(
    Stream baseStream,
    bool zip
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    zip As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Input stream that contains the compressed data.
zip
Type: System..::.Boolean
Specifies whether the compressed stream was created in zip format.

See Also

C1ZStreamReader Class
C1ZStreamReader Overload
C1.C1Zip Namespace


C1ZStreamReader Constructor (Stream, Boolean, Boolean)

[image]

.NET Framework Class Library
C1ZStreamReader Constructor (Stream, Boolean, Boolean)
C1ZStreamReader Class See Also
Initializes a new instance of the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamReader(
    Stream baseStream,
    bool header,
    bool crc32
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    header As Boolean, _
    crc32 As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Input stream that contains the compressed data.
header
Type: System..::.Boolean
Specifies whether the compressed stream contains header information (should be False for streams in zip files).
crc32
Type: System..::.Boolean
Specifies whether the compressed stream contains a CRC32 checksum (should be True for streams in zip files).

See Also

C1ZStreamReader Class
C1ZStreamReader Overload
C1.C1Zip Namespace


C1ZStreamReader Constructor (Stream, Boolean, Int32)

[image]

.NET Framework Class Library
C1ZStreamReader Constructor (Stream, Boolean, Int32)
C1ZStreamReader Class See Also
Initializes a new instance of the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamReader(
    Stream baseStream,
    bool zip,
    int sizeCompressed
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    zip As Boolean, _
    sizeCompressed As Integer _
)

Parameters

baseStream
Type: System.IO..::.Stream
Input stream that contains the compressed data.
zip
Type: System..::.Boolean
Specifies whether the compressed stream was created in zip format.
sizeCompressed
Type: System..::.Int32
Specifies the number of compressed bytes to read from the stream.

Remarks

The sizeCompressed parameter is needed only when a single stream contains several compressed streams (in zip files for example). If this parameter is not specified, it is assumed that the stream contains a single stream of compressed data.

See Also

C1ZStreamReader Class
C1ZStreamReader Overload
C1.C1Zip Namespace


C1ZStreamReader Constructor (Stream, Boolean, Int32, Int32)

[image]

.NET Framework Class Library
C1ZStreamReader Constructor (Stream, Boolean, Int32, Int32)
C1ZStreamReader Class See Also
Initializes a new instance of the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamReader(
    Stream baseStream,
    bool zip,
    int sizeCompressed,
    int method
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    zip As Boolean, _
    sizeCompressed As Integer, _
    method As Integer _
)

Parameters

baseStream
Type: System.IO..::.Stream
Input stream that contains the compressed data.
zip
Type: System..::.Boolean
Specifies whether the compressed stream was created in zip format.
sizeCompressed
Type: System..::.Int32
Specifies the number of compressed bytes to read from the stream.
method
Type: System..::.Int32
Specifies the method that was used to compress the stream.

See Also

C1ZStreamReader Class
C1ZStreamReader Overload
C1.C1Zip Namespace


C1ZStreamReader Methods

[image] [image]

.NET Framework Class Library
C1ZStreamReader Methods
C1ZStreamReader Class See Also

The C1ZStreamReader type exposes the following members.

Methods

Name | Description
BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Close | Closes the current stream compressor and flushed any pending data into the base stream. If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it. (Overrides Stream..::.Close()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose | Overloaded.
EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying stream. (Overrides Stream..::.Flush()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Read | Reads a sequence of bytes from the underlying compressed stream, decompressing them into a buffer, then advances the position within the stream by the number of bytes read. (Overrides Stream..::.Read(array<Byte>[]()[], Int32, Int32).)
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Overrides Stream..::.ReadByte()()().)
Seek | Not supported. (Overrides Stream..::.Seek(Int64, SeekOrigin).)
SetLength | Sets the number of compressed bytes to read from the underlying stream. (Overrides Stream..::.SetLength(Int64).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | This method is overridden and is not supported by the C1ZStreamReader class. (Overrides Stream..::.Write(array<Byte>[]()[], Int32, Int32).)
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Close Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.Close Method
C1ZStreamReader Class See Also

Closes the current stream compressor and flushed any pending data into the base stream.

If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Close()
Visual Basic (Declaration)
Public Overrides Sub Close

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
C1ZStreamReader..::.Dispose Method
C1ZStreamReader Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)

See Also

C1ZStreamReader Class
C1ZStreamReader Members
C1.C1Zip Namespace


Flush Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.Flush Method
C1ZStreamReader Class See Also
Clears all buffers for this stream and causes any buffered data to be written to the underlying stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Flush()
Visual Basic (Declaration)
Public Overrides Sub Flush

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
C1ZStreamReader..::.MemberwiseClone Method
C1ZStreamReader Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

C1ZStreamReader Class
C1ZStreamReader Members
C1.C1Zip Namespace


Read Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.Read Method
C1ZStreamReader Class See Also
Reads a sequence of bytes from the underlying compressed stream, decompressing them into a buffer, then advances the position within the stream by the number of bytes read.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override int Read(
    byte[] buf,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Overrides Function Read ( _
    buf As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer

Parameters

buf
Type: array< System..::.Byte >[]()[]
An array of bytes. When this method returns, buff contains the specified byte array with the values between offsetand (offset + count) replaced by the uncompressed data read from the stream.
offset
Type: System..::.Int32
The zero-based byte offset in buff at which to begin storing the data read from the current stream.
count
Type: System..::.Int32
The maximum number of (decompressed) bytes to be read from the current stream.

Return Value

The total number of bytes read into the buffer. This may be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


ReadByte Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.ReadByte Method
C1ZStreamReader Class See Also
Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override int ReadByte()
Visual Basic (Declaration)
Public Overrides Function ReadByte As Integer

Return Value

The unsigned byte cast to an Int32, or -1 if at the end of the stream.

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Seek Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.Seek Method
C1ZStreamReader Class See Also
Not supported.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long

Parameters

offset
Type: System..::.Int64
origin
Type: System.IO..::.SeekOrigin

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


SetLength Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.SetLength Method
C1ZStreamReader Class See Also
Sets the number of compressed bytes to read from the underlying stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void SetLength(
    long value
)
Visual Basic (Declaration)
Public Overrides Sub SetLength ( _
    value As Long _
)

Parameters

value
Type: System..::.Int64

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Write Method

[image]

.NET Framework Class Library
C1ZStreamReader..::.Write Method
C1ZStreamReader Class See Also
This method is overridden and is not supported by the C1ZStreamReader class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Write(
    byte[] buf,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Overrides Sub Write ( _
    buf As Byte(), _
    offset As Integer, _
    count As Integer _
)

Parameters

buf
Type: array< System..::.Byte >[]()[]
offset
Type: System..::.Int32
count
Type: System..::.Int32

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


C1ZStreamReader Properties

[image] [image]

.NET Framework Class Library
C1ZStreamReader Properties
C1ZStreamReader Class See Also

The C1ZStreamReader type exposes the following members.

Properties

Name | Description
BaseStream | Gets the underlying stream that contains the compressed data.
CanRead | Always returns True. (Overrides Stream..::.CanRead.)
CanSeek | Always returns False. (Overrides Stream..::.CanSeek.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Always returns False. (Overrides Stream..::.CanWrite.)
Length | Gets the length of the compressed stream if it is known (or -1 if the length of the compressed stream is unknown). (Overrides Stream..::.Length.)
OwnsBaseStream | Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).
Position | Gets the position within the stream (read-only). (Overrides Stream..::.Position.)
ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
SizeCompressed | Gets the number of bytes in the stream (compressed bytes).
SizeUncompressed | Gets the number of bytes that were compressed into the stream (uncompressed bytes).
WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
ZStream | Gets the ZStream instance wrapped by this C1ZStreamWriter.

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


BaseStream Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.BaseStream Property
C1ZStreamReader Class See Also
Gets the underlying stream that contains the compressed data.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public Stream BaseStream { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseStream As Stream

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


CanRead Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.CanRead Property
C1ZStreamReader Class See Also
Always returns True.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanRead { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


CanSeek Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.CanSeek Property
C1ZStreamReader Class See Also
Always returns False.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanSeek { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


CanWrite Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.CanWrite Property
C1ZStreamReader Class See Also
Always returns False.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanWrite { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Length Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.Length Property
C1ZStreamReader Class See Also
Gets the length of the compressed stream if it is known (or -1 if the length of the compressed stream is unknown).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Length { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


OwnsBaseStream Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.OwnsBaseStream Property
C1ZStreamReader Class See Also
Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool OwnsBaseStream { get; set; }
Visual Basic (Declaration)
Public Property OwnsBaseStream As Boolean

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


Position Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.Position Property
C1ZStreamReader Class See Also
Gets the position within the stream (read-only).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Position { get; set; }
Visual Basic (Declaration)
Public Overrides Property Position As Long

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


SizeCompressed Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.SizeCompressed Property
C1ZStreamReader Class See Also
Gets the number of bytes in the stream (compressed bytes).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeCompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeCompressed As Integer

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


SizeUncompressed Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.SizeUncompressed Property
C1ZStreamReader Class See Also
Gets the number of bytes that were compressed into the stream (uncompressed bytes).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeUncompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeUncompressed As Integer

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


ZStream Property

[image]

.NET Framework Class Library
C1ZStreamReader..::.ZStream Property
C1ZStreamReader Class See Also
Gets the ZStream instance wrapped by this C1ZStreamWriter.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStream ZStream { get; }
Visual Basic (Declaration)
Public ReadOnly Property ZStream As ZStream

Remarks

This property is useful only in advanced applications that need to customize the low-level behavior of the compressor. It is not needed in common applications.

See Also

C1ZStreamReader Class
C1.C1Zip Namespace


C1ZStreamWriter Class

[image]

.NET Framework Class Library
C1ZStreamWriter Class
Members Example See Also
Compresses data into .NET Streams.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class C1ZStreamWriter : Stream
Visual Basic (Declaration)
Public Class C1ZStreamWriter _
    Inherits Stream

Remarks

To compress data into a stream, create a C1ZStreamWriter object passing the stream to the C1ZStreamWriter constructor.

Then write the data into the C1ZStreamWriter using the Write(array<Byte>[]()[], Int32, Int32) method, or create a StreamWriter on the C1ZStreamWriter. The second option is indicated when you want to write formatted data.

When you are done writing the data, call the Close()()() method to flush the data and close the underlying stream.

Examples

The code below compresses a string into a memory stream:
Copy CodeC#
public byte[] CompressString(string str)
{
    // open memory stream
    MemoryStream ms = new MemoryStream();

    // attach compressor stream to memory stream
    C1ZStreamWriter sw = new C1ZStreamWriter(ms);

    // write data into compressor stream
    StreamWriter writer = new StreamWriter(sw);
    writer.Write(str);

    // flush any pending data
    writer.Flush();

    // return the memory buffer
    return ms.ToArray();
}

Inheritance Hierarchy

System..::.Object
System..::.MarshalByRefObject
System.IO..::.Stream
C1.C1Zip..::.C1ZStreamWriter

See Also

C1ZStreamWriter Members
C1.C1Zip Namespace


C1ZStreamWriter Members

[image] [image]

.NET Framework Class Library
C1ZStreamWriter Members
C1ZStreamWriter Class Constructors Methods Properties See Also

The C1ZStreamWriter type exposes the following members.

Constructors

Name | Description
C1ZStreamWriter | Overloaded.

Methods

Name | Description
BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Close | Closes the current stream compressor and flushed any pending data into the base stream. If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it. (Overrides Stream..::.Close()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose | Overloaded.
EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying stream. (Overrides Stream..::.Flush()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Read | Not supported. (Overrides Stream..::.Read(array<Byte>[]()[], Int32, Int32).)
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Seek | Not supported. (Overrides Stream..::.Seek(Int64, SeekOrigin).)
SetLength | Not supported. (Overrides Stream..::.SetLength(Int64).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::.Write(array<Byte>[]()[], Int32, Int32).)
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Overrides Stream..::.WriteByte(Byte).)

Properties

Name | Description
BaseStream | Gets the underlying stream that receives the compressed data.
CanRead | Always returns False. (Overrides Stream..::.CanRead.)
CanSeek | Always returns False. (Overrides Stream..::.CanSeek.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Always returns True. (Overrides Stream..::.CanWrite.)
Checksum | Gets the checksum value used to check the integrity of the stream.
Length | Returns the length of the underlying stream, in bytes. (Overrides Stream..::.Length.)
OwnsBaseStream | Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).
Position | Gets the position within the stream (read-only). (Overrides Stream..::.Position.)
ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
SizeCompressed | Gets the number of bytes in the stream (compressed bytes).
SizeUncompressed | Gets the number of bytes that were compressed into the stream (uncompressed bytes).
WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
ZStream | Gets the ZStream instance wrapped by this C1ZStreamWriter.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


C1ZStreamWriter Constructor

[image] [image]

.NET Framework Class Library
C1ZStreamWriter Constructor
C1ZStreamWriter Class See Also

Overload List

Name | Description
C1ZStreamWriter(Stream) | Initializes a new instance of the C1ZStreamWriter class.
C1ZStreamWriter(Stream, CompressionLevelEnum) | Initializes a new instance of the C1ZStreamWriter class.
C1ZStreamWriter(Stream, Boolean) | Initializes a new instance of the C1ZStreamWriter class.
C1ZStreamWriter(Stream, CompressionLevelEnum, Boolean) | Initializes a new instance of the C1ZStreamWriter class.
C1ZStreamWriter(Stream, Boolean, Boolean) | Initializes a new instance of the C1ZStreamWriter class.
C1ZStreamWriter(Stream, CompressionLevelEnum, Boolean, Boolean) | Initializes a new instance of the C1ZStreamWriter class.

See Also

C1ZStreamWriter Class
C1ZStreamWriter Members
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream, CompressionLevelEnum)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream, CompressionLevelEnum)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream,
    CompressionLevelEnum level
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    level As CompressionLevelEnum _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.
level
Type: C1.C1Zip..::.CompressionLevelEnum
Compression level to use when compressing data.

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream, Boolean)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream, Boolean)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream,
    bool zip
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    zip As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.
zip
Type: System..::.Boolean
Specifies whether the compressed stream should be compatible with zip files.

Remarks

Streams in zip files are different from regular zlib streams in two aspects:

(1) zip streams do not contain any local header information (the information is stored in the zip file headers instead) and

(2) zip streams use a CRC32 checksum instead of the adler32 checksum used by zlib streams.

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream, CompressionLevelEnum, Boolean)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream, CompressionLevelEnum, Boolean)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream,
    CompressionLevelEnum level,
    bool zip
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    level As CompressionLevelEnum, _
    zip As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.
level
Type: C1.C1Zip..::.CompressionLevelEnum
Compression level to use when compressing data.
zip
Type: System..::.Boolean
Specifies whether the compressed stream should be compatible with zip files.

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream, Boolean, Boolean)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream, Boolean, Boolean)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream,
    bool header,
    bool crc32
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    header As Boolean, _
    crc32 As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.
header
Type: System..::.Boolean
Include header information in compressed stream (should be False for streams in zip files).
crc32
Type: System..::.Boolean
Include CRC32 checksum in compressed stream (should be True for streams in zip files).

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Constructor (Stream, CompressionLevelEnum, Boolean, Boolean)

[image]

.NET Framework Class Library
C1ZStreamWriter Constructor (Stream, CompressionLevelEnum, Boolean, Boolean)
C1ZStreamWriter Class See Also
Initializes a new instance of the C1ZStreamWriter class.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public C1ZStreamWriter(
    Stream baseStream,
    CompressionLevelEnum level,
    bool header,
    bool crc32
)
Visual Basic (Declaration)
Public Sub New ( _
    baseStream As Stream, _
    level As CompressionLevelEnum, _
    header As Boolean, _
    crc32 As Boolean _
)

Parameters

baseStream
Type: System.IO..::.Stream
Output stream that will contain the compressed data.
level
Type: C1.C1Zip..::.CompressionLevelEnum
Compression level to use when compressing data.
header
Type: System..::.Boolean
Include header information in compressed stream (should be False for streams in zip files).
crc32
Type: System..::.Boolean
Include CRC32 checksum in compressed stream (should be True for streams in zip files).

See Also

C1ZStreamWriter Class
C1ZStreamWriter Overload
C1.C1Zip Namespace


C1ZStreamWriter Methods

[image] [image]

.NET Framework Class Library
C1ZStreamWriter Methods
C1ZStreamWriter Class See Also

The C1ZStreamWriter type exposes the following members.

Methods

Name | Description
BeginRead | Begins an asynchronous read operation. (Inherited from Stream.)
BeginWrite | Begins an asynchronous write operation. (Inherited from Stream.)
Close | Closes the current stream compressor and flushed any pending data into the base stream. If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it. (Overrides Stream..::.Close()()().)
CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Dispose | Overloaded.
EndRead | Waits for the pending asynchronous read to complete. (Inherited from Stream.)
EndWrite | Ends an asynchronous write operation. (Inherited from Stream.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying stream. (Overrides Stream..::.Flush()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
MemberwiseClone | Overloaded.
Read | Not supported. (Overrides Stream..::.Read(array<Byte>[]()[], Int32, Int32).)
ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Seek | Not supported. (Overrides Stream..::.Seek(Int64, SeekOrigin).)
SetLength | Not supported. (Overrides Stream..::.SetLength(Int64).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Write | Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides Stream..::.Write(array<Byte>[]()[], Int32, Int32).)
WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Overrides Stream..::.WriteByte(Byte).)

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Close Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Close Method
C1ZStreamWriter Class See Also

Closes the current stream compressor and flushed any pending data into the base stream.

If the OwnsBaseStream property is set to True (the default value), then this method also closes the base stream and releases any resources (such as sockets and file handles) associated with it.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Close()
Visual Basic (Declaration)
Public Overrides Sub Close

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Dispose Method

[image] [image]

.NET Framework Class Library
C1ZStreamWriter..::.Dispose Method
C1ZStreamWriter Class See Also

Overload List

Name | Description
Dispose()()() | Releases all resources used by the Stream. (Inherited from Stream.)
Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)

See Also

C1ZStreamWriter Class
C1ZStreamWriter Members
C1.C1Zip Namespace


Flush Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Flush Method
C1ZStreamWriter Class See Also
Clears all buffers for this stream and causes any buffered data to be written to the underlying stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Flush()
Visual Basic (Declaration)
Public Overrides Sub Flush

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


MemberwiseClone Method

[image] [image]

.NET Framework Class Library
C1ZStreamWriter..::.MemberwiseClone Method
C1ZStreamWriter Class See Also

Overload List

Name | Description
MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)

See Also

C1ZStreamWriter Class
C1ZStreamWriter Members
C1.C1Zip Namespace


Read Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Read Method
C1ZStreamWriter Class See Also
Not supported.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override int Read(
    byte[] buf,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Overrides Function Read ( _
    buf As Byte(), _
    offset As Integer, _
    count As Integer _
) As Integer

Parameters

buf
Type: array< System..::.Byte >[]()[]
offset
Type: System..::.Int32
count
Type: System..::.Int32

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Seek Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Seek Method
C1ZStreamWriter Class See Also
Not supported.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Seek(
    long offset,
    SeekOrigin origin
)
Visual Basic (Declaration)
Public Overrides Function Seek ( _
    offset As Long, _
    origin As SeekOrigin _
) As Long

Parameters

offset
Type: System..::.Int64
origin
Type: System.IO..::.SeekOrigin

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


SetLength Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.SetLength Method
C1ZStreamWriter Class See Also
Not supported.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void SetLength(
    long value
)
Visual Basic (Declaration)
Public Overrides Sub SetLength ( _
    value As Long _
)

Parameters

value
Type: System..::.Int64

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Write Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Write Method
C1ZStreamWriter Class See Also
Writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void Write(
    byte[] buf,
    int offset,
    int count
)
Visual Basic (Declaration)
Public Overrides Sub Write ( _
    buf As Byte(), _
    offset As Integer, _
    count As Integer _
)

Parameters

buf
Type: array< System..::.Byte >[]()[]
An array of bytes. This method copies count bytes from buf to the current stream.
offset
Type: System..::.Int32
The zero-based byte offset in buf at which to begin copying bytes to the current stream.
count
Type: System..::.Int32
The number of bytes to be written to the current stream.

Remarks

The data is compressed as it is written into the stream. Writing count bytes into the stream will usually advance the position by a number smaller than count.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


WriteByte Method

[image]

.NET Framework Class Library
C1ZStreamWriter..::.WriteByte Method
C1ZStreamWriter Class See Also
Writes a byte to the current position in the stream and advances the position within the stream by one byte.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override void WriteByte(
    byte value
)
Visual Basic (Declaration)
Public Overrides Sub WriteByte ( _
    value As Byte _
)

Parameters

value
Type: System..::.Byte
Value to be written to the stream.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


C1ZStreamWriter Properties

[image] [image]

.NET Framework Class Library
C1ZStreamWriter Properties
C1ZStreamWriter Class See Also

The C1ZStreamWriter type exposes the following members.

Properties

Name | Description
BaseStream | Gets the underlying stream that receives the compressed data.
CanRead | Always returns False. (Overrides Stream..::.CanRead.)
CanSeek | Always returns False. (Overrides Stream..::.CanSeek.)
CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
CanWrite | Always returns True. (Overrides Stream..::.CanWrite.)
Checksum | Gets the checksum value used to check the integrity of the stream.
Length | Returns the length of the underlying stream, in bytes. (Overrides Stream..::.Length.)
OwnsBaseStream | Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).
Position | Gets the position within the stream (read-only). (Overrides Stream..::.Position.)
ReadTimeout | Gets or sets a value that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
SizeCompressed | Gets the number of bytes in the stream (compressed bytes).
SizeUncompressed | Gets the number of bytes that were compressed into the stream (uncompressed bytes).
WriteTimeout | Gets or sets a value that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
ZStream | Gets the ZStream instance wrapped by this C1ZStreamWriter.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


BaseStream Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.BaseStream Property
C1ZStreamWriter Class See Also
Gets the underlying stream that receives the compressed data.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public Stream BaseStream { get; }
Visual Basic (Declaration)
Public ReadOnly Property BaseStream As Stream

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


CanRead Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.CanRead Property
C1ZStreamWriter Class See Also
Always returns False.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanRead { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanRead As Boolean

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


CanSeek Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.CanSeek Property
C1ZStreamWriter Class See Also
Always returns False.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanSeek { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanSeek As Boolean

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


CanWrite Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.CanWrite Property
C1ZStreamWriter Class See Also
Always returns True.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override bool CanWrite { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property CanWrite As Boolean

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Checksum Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Checksum Property
C1ZStreamWriter Class See Also
Gets the checksum value used to check the integrity of the stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int Checksum { get; }
Visual Basic (Declaration)
Public ReadOnly Property Checksum As Integer

Remarks

The checksum used may be an Adler or crc32 value depending on how the C1ZStreamWriter was created.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Length Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Length Property
C1ZStreamWriter Class See Also
Returns the length of the underlying stream, in bytes.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Length { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Length As Long

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


OwnsBaseStream Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.OwnsBaseStream Property
C1ZStreamWriter Class See Also
Gets or sets whether calling the Close()()() method will also close the underlying stream (see BaseStream).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool OwnsBaseStream { get; set; }
Visual Basic (Declaration)
Public Property OwnsBaseStream As Boolean

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


Position Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.Position Property
C1ZStreamWriter Class See Also
Gets the position within the stream (read-only).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public override long Position { get; set; }
Visual Basic (Declaration)
Public Overrides Property Position As Long

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


SizeCompressed Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.SizeCompressed Property
C1ZStreamWriter Class See Also
Gets the number of bytes in the stream (compressed bytes).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeCompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeCompressed As Integer

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


SizeUncompressed Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.SizeUncompressed Property
C1ZStreamWriter Class See Also
Gets the number of bytes that were compressed into the stream (uncompressed bytes).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int SizeUncompressed { get; }
Visual Basic (Declaration)
Public ReadOnly Property SizeUncompressed As Integer

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


ZStream Property

[image]

.NET Framework Class Library
C1ZStreamWriter..::.ZStream Property
C1ZStreamWriter Class See Also
Gets the ZStream instance wrapped by this C1ZStreamWriter.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStream ZStream { get; }
Visual Basic (Declaration)
Public ReadOnly Property ZStream As ZStream

Remarks

This property is useful only in advanced applications that need to customize the low-level behavior of the compressor. It is not needed in common applications.

See Also

C1ZStreamWriter Class
C1.C1Zip Namespace


CompressionLevelEnum Enumeration

[image]

.NET Framework Class Library
CompressionLevelEnum Enumeration
See Also
Specifies the level of compression to be applied when adding entries to a C1ZipFile.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public enum CompressionLevelEnum
Visual Basic (Declaration)
Public Enumeration CompressionLevelEnum

Members

Member name | Description
NoCompression | No Compression.
BestSpeed | Low compression, highest speed.
BestCompression | Highest compression, low speed.
DefaultCompression | High compression, high speed.

See Also

C1.C1Zip Namespace


ZipFileException Class

[image]

.NET Framework Class Library
ZipFileException Class
Members See Also
Exception thrown when trying to open an invalid Zip file.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class ZipFileException : IOException
Visual Basic (Declaration)
Public Class ZipFileException _
    Inherits IOException

Inheritance Hierarchy

System..::.Object
System..::.Exception
System..::.SystemException
System.IO..::.IOException
C1.C1Zip..::.ZipFileException

See Also

ZipFileException Members
C1.C1Zip Namespace


ZipFileException Members

[image] [image]

.NET Framework Class Library
ZipFileException Members
ZipFileException Class Constructors Methods Properties See Also

The ZipFileException type exposes the following members.

Constructors

Name | Description
ZipFileException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ZipFileException Class
C1.C1Zip Namespace


ZipFileException Constructor

[image] [image]

.NET Framework Class Library
ZipFileException Constructor
ZipFileException Class See Also

Overload List

Name | Description
ZipFileException(String) | Initializes a new instance of a FileLoadException.
ZipFileException(String, String) | Initializes a new instance of a FileLoadException.
ZipFileException(String, String, Exception) | Initializes a new instance of a FileLoadException.

See Also

ZipFileException Class
ZipFileException Members
C1.C1Zip Namespace


ZipFileException Constructor (String)

[image]

.NET Framework Class Library
ZipFileException Constructor (String)
ZipFileException Class See Also
Initializes a new instance of a FileLoadException.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZipFileException(
    string msg
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As String _
)

Parameters

msg
Type: System..::.String
Message that describes the exception.

See Also

ZipFileException Class
ZipFileException Overload
C1.C1Zip Namespace


ZipFileException Constructor (String, String)

[image]

.NET Framework Class Library
ZipFileException Constructor (String, String)
ZipFileException Class See Also
Initializes a new instance of a FileLoadException.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZipFileException(
    string msg,
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As String, _
    filename As String _
)

Parameters

msg
Type: System..::.String
Message that describes the exception.
filename
Type: System..::.String
Name of the file that caused the exception.

See Also

ZipFileException Class
ZipFileException Overload
C1.C1Zip Namespace


ZipFileException Constructor (String, String, Exception)

[image]

.NET Framework Class Library
ZipFileException Constructor (String, String, Exception)
ZipFileException Class See Also
Initializes a new instance of a FileLoadException.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZipFileException(
    string msg,
    string filename,
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As String, _
    filename As String, _
    innerException As Exception _
)

Parameters

msg
Type: System..::.String
Message that describes the exception.
filename
Type: System..::.String
Name of the file that caused the exception.
innerException
Type: System..::.Exception
Inner exception.

See Also

ZipFileException Class
ZipFileException Overload
C1.C1Zip Namespace


ZipFileException Methods

[image] [image]

.NET Framework Class Library
ZipFileException Methods
ZipFileException Class See Also

The ZipFileException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ZipFileException Class
C1.C1Zip Namespace


ZipFileException Properties

[image] [image]

.NET Framework Class Library
ZipFileException Properties
ZipFileException Class See Also

The ZipFileException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ZipFileException Class
C1.C1Zip Namespace


ZipProgressEventArgs Class

[image]

.NET Framework Class Library
ZipProgressEventArgs Class
Members See Also
Provides data for the Progress event of a C1ZipFile.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class ZipProgressEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ZipProgressEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.C1Zip..::.ZipProgressEventArgs

See Also

ZipProgressEventArgs Members
C1.C1Zip Namespace


ZipProgressEventArgs Members

[image] [image]

.NET Framework Class Library
ZipProgressEventArgs Members
ZipProgressEventArgs Class Methods Fields Properties See Also

The ZipProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
Cancel | Set to true to cancel the current operation.
FileLength | Gets the length of the file being compressed or expanded.
FileName | Gets the name of the file being compressed or expanded.

Properties

Name | Description
Position | Gets the current position into the stream.

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


ZipProgressEventArgs Fields

[image] [image]

.NET Framework Class Library
ZipProgressEventArgs Fields
ZipProgressEventArgs Class See Also

The ZipProgressEventArgs type exposes the following members.

Fields

Name | Description
Cancel | Set to true to cancel the current operation.
FileLength | Gets the length of the file being compressed or expanded.
FileName | Gets the name of the file being compressed or expanded.

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


Cancel Field

[image]

.NET Framework Class Library
ZipProgressEventArgs..::.Cancel Field
ZipProgressEventArgs Class See Also
Set to true to cancel the current operation.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public bool Cancel
Visual Basic (Declaration)
Public Cancel As Boolean

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


FileLength Field

[image]

.NET Framework Class Library
ZipProgressEventArgs..::.FileLength Field
ZipProgressEventArgs Class See Also
Gets the length of the file being compressed or expanded.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public readonly int FileLength
Visual Basic (Declaration)
Public ReadOnly FileLength As Integer

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


FileName Field

[image]

.NET Framework Class Library
ZipProgressEventArgs..::.FileName Field
ZipProgressEventArgs Class See Also
Gets the name of the file being compressed or expanded.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public readonly string FileName
Visual Basic (Declaration)
Public ReadOnly FileName As String

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


ZipProgressEventArgs Methods

[image] [image]

.NET Framework Class Library
ZipProgressEventArgs Methods
ZipProgressEventArgs Class See Also

The ZipProgressEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


ZipProgressEventArgs Properties

[image] [image]

.NET Framework Class Library
ZipProgressEventArgs Properties
ZipProgressEventArgs Class See Also

The ZipProgressEventArgs type exposes the following members.

Properties

Name | Description
Position | Gets the current position into the stream.

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


Position Property

[image]

.NET Framework Class Library
ZipProgressEventArgs..::.Position Property
ZipProgressEventArgs Class See Also
Gets the current position into the stream.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int Position { get; }
Visual Basic (Declaration)
Public ReadOnly Property Position As Integer

See Also

ZipProgressEventArgs Class
C1.C1Zip Namespace


ZipProgressEventHandler Delegate

[image]

.NET Framework Class Library
ZipProgressEventHandler Delegate
See Also
Represents the method that will handle the Progress event of a C1ZipFile.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public delegate void ZipProgressEventHandler(
    Object sender,
    ZipProgressEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub ZipProgressEventHandler ( _
    sender As Object, _
    e As ZipProgressEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: C1.C1Zip..::.ZipProgressEventArgs

See Also

C1.C1Zip Namespace


C1.C1Zip.ZLib Namespace

[image]

.NET Framework Class Library
C1.C1Zip.ZLib Namespace

Classes

Class | Description
ZStream | ZStream is the most flexible and hardest to use class in the C1.C1Zip assembly. It contains a C# implementation of ZLIB's zstream object, which is a general purpose compressor and decompressor.
ZStreamException | The exception that is thrown when reading or writing to a compressed stream fails.


ZStream Class

[image]

.NET Framework Class Library
ZStream Class
Members See Also
ZStream is the most flexible and hardest to use class in the C1.C1Zip assembly. It contains a C# implementation of ZLIB's zstream object, which is a general purpose compressor and decompressor.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class ZStream
Visual Basic (Declaration)
Public Class ZStream

Remarks

In most cases, you should be able to use the C1ZStreamReader and C1ZStreamWriter classes instead of ZStream. These classes provide friendly and easy-to-use wrappers that hide the ZLIB complexity.

Use ZStream only if you are familiar with ZLIB and need control over the low-level aspects of the data compression or decompression process (for example, to provide your own buffers or compression dictionaries).

If you choose to use ZStream directly and need technical support, please check out the detailed documentation, sample, and articles available at http://www.info-zip.org/ or http://www.gzip.org/, the official zlib sites.

ZLIB is an open-source, patent-free library created by Jean-Loup Gailly and Mark Adler.

Inheritance Hierarchy

System..::.Object
C1.C1Zip.ZLib..::.ZStream

See Also

ZStream Members
C1.C1Zip.ZLib Namespace


ZStream Members

[image] [image]

.NET Framework Class Library
ZStream Members
ZStream Class Constructors Methods Fields See Also

The ZStream type exposes the following members.

Constructors

Name | Description
ZStream | Overloaded.

Methods

Name | Description
deflate | Compresses as much data as possible, and stops when the input buffer becomes empty or the output buffer becomes full.
deflateEnd | Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.
deflateInit | Overloaded.
deflateParams | Dynamically updates the compression level and compression strategy.
deflateSetDictionary | Initializes the compression dictionary from the given byte sequence without producing any compressed output.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
inflate | Decompresses as much data as possible until the input buffer is exhausted or the output buffer is full.
inflateEnd | Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.
inflateInit | Overloaded.
inflateSetDictionary | Initializes the decompression dictionary from the given uncompressed byte sequence.
inflateSync | Skips invalid compressed data until a full flush point is found, or until all available input is skipped. No output is provided.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
adler | Current checksum value (Adler or CRC32).
avail_in | Number of bytes available in the input buffer.
avail_out | Number of free bytes remaining in output buffer.
msg | Description of the last error (null if no errors).
next_in | Input buffer.
next_in_index | Position of cursor into input buffer.
next_out | Output buffer.
next_out_index | Position of cursor into the output buffer.
total_in | Total number of input bytes read so far.
total_out | Total number of bytes output so far.
Z_BUF_ERROR | No progress possible or no room in output buffer.
Z_DATA_ERROR | Input data is corrupted (wrong format or checksum).
Z_ERRNO | File error.
Z_MEM_ERROR | Not enough memory.
Z_NEED_DICT | A preset dictionary is needed at this point.
Z_OK | No error.
Z_STREAM_END | End of stream detected.
Z_STREAM_ERROR | Stream structure is inconsistent (input/output buffers are null for example).
Z_VERSION_ERROR | Incompatible ZLIB version.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


ZStream Constructor

[image] [image]

.NET Framework Class Library
ZStream Constructor
ZStream Class See Also

Overload List

Name | Description
ZStream()()() | Initializes a new instance of the ZStream class using an Adler checksum.
ZStream(Boolean) | Initializes a new instance of the ZStream class.

See Also

ZStream Class
ZStream Members
C1.C1Zip.ZLib Namespace


ZStream Constructor

[image]

.NET Framework Class Library
ZStream Constructor
ZStream Class See Also
Initializes a new instance of the ZStream class using an Adler checksum.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStream()
Visual Basic (Declaration)
Public Sub New

See Also

ZStream Class
ZStream Overload
C1.C1Zip.ZLib Namespace


ZStream Constructor (Boolean)

[image]

.NET Framework Class Library
ZStream Constructor (Boolean)
ZStream Class See Also
Initializes a new instance of the ZStream class.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStream(
    bool crc32
)
Visual Basic (Declaration)
Public Sub New ( _
    crc32 As Boolean _
)

Parameters

crc32
Type: System..::.Boolean
True to use a CRC32 checksum, False to use an Adler checksum.

Remarks

CRC32 checksums are the standard used in zip files. Adler checksums are the default used by ZLIB. Adler checksums are faster to calculate, but are not compatible with the zip format.

See Also

ZStream Class
ZStream Overload
C1.C1Zip.ZLib Namespace


ZStream Fields

[image] [image]

.NET Framework Class Library
ZStream Fields
ZStream Class See Also

The ZStream type exposes the following members.

Fields

Name | Description
adler | Current checksum value (Adler or CRC32).
avail_in | Number of bytes available in the input buffer.
avail_out | Number of free bytes remaining in output buffer.
msg | Description of the last error (null if no errors).
next_in | Input buffer.
next_in_index | Position of cursor into input buffer.
next_out | Output buffer.
next_out_index | Position of cursor into the output buffer.
total_in | Total number of input bytes read so far.
total_out | Total number of bytes output so far.
Z_BUF_ERROR | No progress possible or no room in output buffer.
Z_DATA_ERROR | Input data is corrupted (wrong format or checksum).
Z_ERRNO | File error.
Z_MEM_ERROR | Not enough memory.
Z_NEED_DICT | A preset dictionary is needed at this point.
Z_OK | No error.
Z_STREAM_END | End of stream detected.
Z_STREAM_ERROR | Stream structure is inconsistent (input/output buffers are null for example).
Z_VERSION_ERROR | Incompatible ZLIB version.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


adler Field

[image]

.NET Framework Class Library
ZStream..::.adler Field
ZStream Class See Also
Current checksum value (Adler or CRC32).

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public long adler
Visual Basic (Declaration)
Public adler As Long

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


avail_in Field

[image]

.NET Framework Class Library
ZStream..::.avail_in Field
ZStream Class See Also
Number of bytes available in the input buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int avail_in
Visual Basic (Declaration)
Public avail_in As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


avail_out Field

[image]

.NET Framework Class Library
ZStream..::.avail_out Field
ZStream Class See Also
Number of free bytes remaining in output buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int avail_out
Visual Basic (Declaration)
Public avail_out As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


msg Field

[image]

.NET Framework Class Library
ZStream..::.msg Field
ZStream Class See Also
Description of the last error (null if no errors).

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public string msg
Visual Basic (Declaration)
Public msg As String

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


next_in Field

[image]

.NET Framework Class Library
ZStream..::.next_in Field
ZStream Class See Also
Input buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public byte[] next_in
Visual Basic (Declaration)
Public next_in As Byte()

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


next_in_index Field

[image]

.NET Framework Class Library
ZStream..::.next_in_index Field
ZStream Class See Also
Position of cursor into input buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int next_in_index
Visual Basic (Declaration)
Public next_in_index As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


next_out Field

[image]

.NET Framework Class Library
ZStream..::.next_out Field
ZStream Class See Also
Output buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public byte[] next_out
Visual Basic (Declaration)
Public next_out As Byte()

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


next_out_index Field

[image]

.NET Framework Class Library
ZStream..::.next_out_index Field
ZStream Class See Also
Position of cursor into the output buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int next_out_index
Visual Basic (Declaration)
Public next_out_index As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


total_in Field

[image]

.NET Framework Class Library
ZStream..::.total_in Field
ZStream Class See Also
Total number of input bytes read so far.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public long total_in
Visual Basic (Declaration)
Public total_in As Long

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


total_out Field

[image]

.NET Framework Class Library
ZStream..::.total_out Field
ZStream Class See Also
Total number of bytes output so far.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public long total_out
Visual Basic (Declaration)
Public total_out As Long

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_BUF_ERROR Field

[image]

.NET Framework Class Library
ZStream..::.Z_BUF_ERROR Field
ZStream Class See Also
No progress possible or no room in output buffer.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_BUF_ERROR
Visual Basic (Declaration)
Public Const Z_BUF_ERROR As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_DATA_ERROR Field

[image]

.NET Framework Class Library
ZStream..::.Z_DATA_ERROR Field
ZStream Class See Also
Input data is corrupted (wrong format or checksum).

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_DATA_ERROR
Visual Basic (Declaration)
Public Const Z_DATA_ERROR As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_ERRNO Field

[image]

.NET Framework Class Library
ZStream..::.Z_ERRNO Field
ZStream Class See Also
File error.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_ERRNO
Visual Basic (Declaration)
Public Const Z_ERRNO As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_MEM_ERROR Field

[image]

.NET Framework Class Library
ZStream..::.Z_MEM_ERROR Field
ZStream Class See Also
Not enough memory.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_MEM_ERROR
Visual Basic (Declaration)
Public Const Z_MEM_ERROR As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_NEED_DICT Field

[image]

.NET Framework Class Library
ZStream..::.Z_NEED_DICT Field
ZStream Class See Also
A preset dictionary is needed at this point.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_NEED_DICT
Visual Basic (Declaration)
Public Const Z_NEED_DICT As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_OK Field

[image]

.NET Framework Class Library
ZStream..::.Z_OK Field
ZStream Class See Also
No error.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_OK
Visual Basic (Declaration)
Public Const Z_OK As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_STREAM_END Field

[image]

.NET Framework Class Library
ZStream..::.Z_STREAM_END Field
ZStream Class See Also
End of stream detected.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_STREAM_END
Visual Basic (Declaration)
Public Const Z_STREAM_END As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_STREAM_ERROR Field

[image]

.NET Framework Class Library
ZStream..::.Z_STREAM_ERROR Field
ZStream Class See Also
Stream structure is inconsistent (input/output buffers are null for example).

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_STREAM_ERROR
Visual Basic (Declaration)
Public Const Z_STREAM_ERROR As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


Z_VERSION_ERROR Field

[image]

.NET Framework Class Library
ZStream..::.Z_VERSION_ERROR Field
ZStream Class See Also
Incompatible ZLIB version.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public const int Z_VERSION_ERROR
Visual Basic (Declaration)
Public Const Z_VERSION_ERROR As Integer

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


ZStream Methods

[image] [image]

.NET Framework Class Library
ZStream Methods
ZStream Class See Also

The ZStream type exposes the following members.

Methods

Name | Description
deflate | Compresses as much data as possible, and stops when the input buffer becomes empty or the output buffer becomes full.
deflateEnd | Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.
deflateInit | Overloaded.
deflateParams | Dynamically updates the compression level and compression strategy.
deflateSetDictionary | Initializes the compression dictionary from the given byte sequence without producing any compressed output.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
inflate | Decompresses as much data as possible until the input buffer is exhausted or the output buffer is full.
inflateEnd | Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.
inflateInit | Overloaded.
inflateSetDictionary | Initializes the decompression dictionary from the given uncompressed byte sequence.
inflateSync | Skips invalid compressed data until a full flush point is found, or until all available input is skipped. No output is provided.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


deflate Method

[image]

.NET Framework Class Library
ZStream..::.deflate Method
ZStream Class See Also
Compresses as much data as possible, and stops when the input buffer becomes empty or the output buffer becomes full.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflate(
    int flush
)
Visual Basic (Declaration)
Public Function deflate ( _
    flush As Integer _
) As Integer

Parameters

flush
Type: System..::.Int32
Non-zero to force some data to be flushed into the output buffer.

Return Value

Zero on success, an error code on failure.

Remarks

deflate performs one or both of the following actions:

1. Compress more input starting at next_in and update next_in and avail_in accordingly. If not all input can be processed (because there is not enough room in the output buffer), next_in and avail_in are updated and processing will resume at this point for the next call to deflate.

2. Provide more output starting at next_out and update next_out and avail_out accordingly. This action is forced if the parameter flush is non zero. Forcing flush frequently degrades the compression ratio, so this parameter should be set only when necessary (in interactive applications). Some output may be provided even if flush is not set

This method may introduce some output latency (reading input without producing any output) except when forced to flush.

If deflate returns with avail_out == 0, this method must be called again with the same value of the flush parameter and more output space until the flush is complete (deflate returns with avail_out != 0).

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


deflateEnd Method

[image]

.NET Framework Class Library
ZStream..::.deflateEnd Method
ZStream Class See Also
Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflateEnd()
Visual Basic (Declaration)
Public Function deflateEnd As Integer

Return Value

Zero on success, an error code on failure.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


deflateInit Method

[image] [image]

.NET Framework Class Library
ZStream..::.deflateInit Method
ZStream Class See Also

Overload List

Name | Description
deflateInit(Int32) | Initializes the internal stream state for compression.
deflateInit(Int32, Int32) | Initializes the internal stream state for compression.

See Also

ZStream Class
ZStream Members
C1.C1Zip.ZLib Namespace


deflateInit Method (Int32)

[image]

.NET Framework Class Library
ZStream..::.deflateInit Method (Int32)
ZStream Class See Also
Initializes the internal stream state for compression.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflateInit(
    int level
)
Visual Basic (Declaration)
Public Function deflateInit ( _
    level As Integer _
) As Integer

Parameters

level
Type: System..::.Int32
Compression level between zero and nine (0-9).

Return Value

Zero on success, an error code on failure.

Remarks

Compression level 1 gives best speed, 9 gives best compression.

Compression level zero gives no compression at all (the input data is simply copied a block at a time).

The default compression level is 6, which provides a compromise between speed and compression.

See Also

ZStream Class
deflateInit Overload
C1.C1Zip.ZLib Namespace


deflateInit Method (Int32, Int32)

[image]

.NET Framework Class Library
ZStream..::.deflateInit Method (Int32, Int32)
ZStream Class See Also
Initializes the internal stream state for compression.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflateInit(
    int level,
    int bits
)
Visual Basic (Declaration)
Public Function deflateInit ( _
    level As Integer, _
    bits As Integer _
) As Integer

Parameters

level
Type: System..::.Int32
Compression level between zero and nine (0-9).
bits
Type: System..::.Int32
Size of the LZ77 sliding compression window in bits (the default value is 15 bits).

Return Value

Zero on success, an error code on failure.

Remarks

Compression level 1 gives best speed, 9 gives best compression.

Compression level zero gives no compression at all (the input data is simply copied a block at a time).

The default compression level is 6, which provides a compromise between speed and compression.

See Also

ZStream Class
deflateInit Overload
C1.C1Zip.ZLib Namespace


deflateParams Method

[image]

.NET Framework Class Library
ZStream..::.deflateParams Method
ZStream Class See Also
Dynamically updates the compression level and compression strategy.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflateParams(
    int level,
    int strategy
)
Visual Basic (Declaration)
Public Function deflateParams ( _
    level As Integer, _
    strategy As Integer _
) As Integer

Parameters

level
Type: System..::.Int32
Compression level between zero and nine (0-9).
strategy
Type: System..::.Int32
Compression strategy (0-2).

Return Value

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


deflateSetDictionary Method

[image]

.NET Framework Class Library
ZStream..::.deflateSetDictionary Method
ZStream Class See Also
Initializes the compression dictionary from the given byte sequence without producing any compressed output.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int deflateSetDictionary(
    byte[] dictionary,
    int dictLength
)
Visual Basic (Declaration)
Public Function deflateSetDictionary ( _
    dictionary As Byte(), _
    dictLength As Integer _
) As Integer

Parameters

dictionary
Type: array< System..::.Byte >[]()[]
Data in the dictionary.
dictLength
Type: System..::.Int32
Number of bytes in the dictionary.

Return Value

Zero on success, an error code on failure.

Remarks

This method must be called immediately after deflateInit(Int32), before any call to deflate(Int32).

The compressor and decompressor must use exactly the same dictionary (see inflateSetDictionary(array<Byte>[]()[], Int32)).

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


inflate Method

[image]

.NET Framework Class Library
ZStream..::.inflate Method
ZStream Class See Also
Decompresses as much data as possible until the input buffer is exhausted or the output buffer is full.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflate(
    int flush
)
Visual Basic (Declaration)
Public Function inflate ( _
    flush As Integer _
) As Integer

Parameters

flush
Type: System..::.Int32
How to flush data into the output buffer (default value is 2).

Return Value

Z_OK if some progress has been made (more input processed or more output produced), Z_STREAM_END if the end of the compressed data has been reached and all uncompressed output has been produced, Z_NEED_DICT if a preset dictionary is needed at this point, Z_DATA_ERROR if the input data was corrupted (input stream not conforming to the zlib format or incorrect checksum), Z_STREAM_ERROR if the stream structure was inconsistent (for example if next_in or next_out was null), Z_MEM_ERROR if there was not enough memory, Z_BUF_ERROR if no progress is possible or if there was not enough room in the output buffer when Z_FINISH is used.

Remarks

inflate performs one or both of the following actions:

1. Decompress more input starting at next_in and update next_in and avail_in accordingly. If not all input can be processed (because there is not enough room in the output buffer), next_in is updated and processing will resume at this point for the next call to inflate.

2. Provide more output starting at next_out and update next_out and avail_out accordingly. inflate provides as much output as possible, until there is no more input data or no more space in the output buffer.

Before the call to inflate, the application should ensure that at least one of the actions is possible, by providing more input and/or consuming more output, and updating the next_* and avail_* values accordingly.

If inflate returns Zero and avail_out == 0, it must be called again after making room in the output buffer because there might be more output pending.

The application can consume the uncompressed output when it wants, for example when the output buffer is full (avail_out == 0), or after each call of inflate.

This method may introduce some output latency (reading input without producing any output) except when forced to flush.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


inflateEnd Method

[image]

.NET Framework Class Library
ZStream..::.inflateEnd Method
ZStream Class See Also
Frees all dynamically allocated data structures for this stream, discards any unprocessed input, and does not flush any pending output.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflateEnd()
Visual Basic (Declaration)
Public Function inflateEnd As Integer

Return Value

Zero on success, an error code on failure.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


inflateInit Method

[image] [image]

.NET Framework Class Library
ZStream..::.inflateInit Method
ZStream Class See Also

Overload List

Name | Description
inflateInit()()() | Initializes the internal stream state for decompression.
inflateInit(Int32) | Initializes the internal stream state for decompression.

See Also

ZStream Class
ZStream Members
C1.C1Zip.ZLib Namespace


inflateInit Method

[image]

.NET Framework Class Library
ZStream..::.inflateInit Method
ZStream Class See Also
Initializes the internal stream state for decompression.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflateInit()
Visual Basic (Declaration)
Public Function inflateInit As Integer

Return Value

Zero on success, an error code on failure.

Remarks

The fields next_in and avail_in must be initialized before by the caller.

inflateInit does not perform any decompression apart from reading the zlib header if present: data decompression is done by the inflate(Int32) method. Therefore, the next_in and avail_in may be modified, but next_out and avail_out are unchanged.

See Also

ZStream Class
inflateInit Overload
C1.C1Zip.ZLib Namespace


inflateInit Method (Int32)

[image]

.NET Framework Class Library
ZStream..::.inflateInit Method (Int32)
ZStream Class See Also
Initializes the internal stream state for decompression.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflateInit(
    int bits
)
Visual Basic (Declaration)
Public Function inflateInit ( _
    bits As Integer _
) As Integer

Parameters

bits
Type: System..::.Int32
Size of the LZ77 sliding compression window in bits (the default value is 15 bits).

Return Value

Zero on success, an error code on failure.

See Also

ZStream Class
inflateInit Overload
C1.C1Zip.ZLib Namespace


inflateSetDictionary Method

[image]

.NET Framework Class Library
ZStream..::.inflateSetDictionary Method
ZStream Class See Also
Initializes the decompression dictionary from the given uncompressed byte sequence.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflateSetDictionary(
    byte[] dictionary,
    int dictLength
)
Visual Basic (Declaration)
Public Function inflateSetDictionary ( _
    dictionary As Byte(), _
    dictLength As Integer _
) As Integer

Parameters

dictionary
Type: array< System..::.Byte >[]()[]
Data in the dictionary.
dictLength
Type: System..::.Int32
Number of bytes in the dictionary.

Return Value

Zero on success, an error code on failure.

Remarks

This method must be called immediately after a call of inflate(Int32) if this call returned Z_NEED_DICT. The dictionary chosen by the compressor can be determined from the Adler32 value returned by this call to inflate.

The compressor and decompressor must use exactly the same dictionary (see the deflateSetDictionary(array<Byte>[]()[], Int32) method).

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


inflateSync Method

[image]

.NET Framework Class Library
ZStream..::.inflateSync Method
ZStream Class See Also
Skips invalid compressed data until a full flush point is found, or until all available input is skipped. No output is provided.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public int inflateSync()
Visual Basic (Declaration)
Public Function inflateSync As Integer

Return Value

Zero on success, an error code on failure.

See Also

ZStream Class
C1.C1Zip.ZLib Namespace


ZStreamException Class

[image]

.NET Framework Class Library
ZStreamException Class
Members See Also
The exception that is thrown when reading or writing to a compressed stream fails.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public class ZStreamException : Exception
Visual Basic (Declaration)
Public Class ZStreamException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
C1.C1Zip.ZLib..::.ZStreamException

See Also

ZStreamException Members
C1.C1Zip.ZLib Namespace


ZStreamException Members

[image] [image]

.NET Framework Class Library
ZStreamException Members
ZStreamException Class Constructors Methods Properties See Also

The ZStreamException type exposes the following members.

Constructors

Name | Description
ZStreamException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ZStreamException Class
C1.C1Zip.ZLib Namespace


ZStreamException Constructor

[image] [image]

.NET Framework Class Library
ZStreamException Constructor
ZStreamException Class See Also

Overload List

Name | Description
ZStreamException()()() | Initializes a new instance of a ZStreamException.
ZStreamException(String) | Initializes a new instance of a ZStreamException.
ZStreamException(String, Exception) | Initializes a new instance of a ZStreamException.

See Also

ZStreamException Class
ZStreamException Members
C1.C1Zip.ZLib Namespace


ZStreamException Constructor

[image]

.NET Framework Class Library
ZStreamException Constructor
ZStreamException Class See Also
Initializes a new instance of a ZStreamException.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStreamException()
Visual Basic (Declaration)
Public Sub New

See Also

ZStreamException Class
ZStreamException Overload
C1.C1Zip.ZLib Namespace


ZStreamException Constructor (String)

[image]

.NET Framework Class Library
ZStreamException Constructor (String)
ZStreamException Class See Also
Initializes a new instance of a ZStreamException.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStreamException(
    string msg
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As String _
)

Parameters

msg
Type: System..::.String
Message that describes the exception.

See Also

ZStreamException Class
ZStreamException Overload
C1.C1Zip.ZLib Namespace


ZStreamException Constructor (String, Exception)

[image]

.NET Framework Class Library
ZStreamException Constructor (String, Exception)
ZStreamException Class See Also
Initializes a new instance of a ZStreamException.

Namespace: C1.C1Zip.ZLib
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
public ZStreamException(
    string msg,
    Exception x
)
Visual Basic (Declaration)
Public Sub New ( _
    msg As String, _
    x As Exception _
)

Parameters

msg
Type: System..::.String
Message that describes the exception.
x
Type: System..::.Exception
Inner exception.

See Also

ZStreamException Class
ZStreamException Overload
C1.C1Zip.ZLib Namespace


ZStreamException Methods

[image] [image]

.NET Framework Class Library
ZStreamException Methods
ZStreamException Class See Also

The ZStreamException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

ZStreamException Class
C1.C1Zip.ZLib Namespace


ZStreamException Properties

[image] [image]

.NET Framework Class Library
ZStreamException Properties
ZStreamException Class See Also

The ZStreamException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

ZStreamException Class
C1.C1Zip.ZLib Namespace


C1.Silverlight Namespace

[image]

.NET Framework Class Library
C1.Silverlight Namespace

Classes

Class | Description
C1ComboBox | Represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.
C1ComboBoxItem | Implements a selectable item inside a C1ComboBox.
C1DataTemplateSelector | Provides a way to apply data templates based on custom logic.
C1DockPanel | Defines an area where you can arrange child elements either horizontally or vertically, relative to each other.
C1DragDropManager | Provides methods for drag-and-drop operations in Silverlight applications.
C1DropDown | C1HeaderedContentControl that presents the Content in a dropdown popup.
C1EditableContentControl | ContenControl that supports edit mode.
C1FilePicker | Editor that allows selecting one or more files
C1HeaderedContentControl | Provides the base implementation for all controls that contain single content and have a header.
C1HierarchicalDataTemplate | Represents a DataTemplate that supports C1HierarchicalPresenter, such as TreeViewItem.
C1HierarchicalPresenter | Represents a control that contains multiple items and has a header.
C1HyperPanel | Arranges child elements in a stack and applies a dynamic zoom effect to the elements near the mouse.
C1ItemContainerGenerator | Provides some helper methods related to the items and containers of a C1ItemsControl.
C1ItemsControl | Represents a control that can be used to present a collection of items.
C1MaskedTextBox | Represents a control that uses a mask to prevent users from entering invalid data.
C1Menu | Represents a menu control that enables you to hierarchically organize elements associated with event handlers.
C1MenuItem | Represents a selectable item inside a C1Menu control.
C1MessageBox | Displays a message box.
C1MessageBoxContent | Control that displays the content of a message box. It's meant to be used inside a C1Window.
C1MouseHelper | Provides extra mouse events not provided by UIElement
C1NumericBox | Editor that allows entering numbers in many formats.
C1PromptBox | Displays a message box.
C1PromptBoxContent | Control that displays the content of a prompt box. It's meant to be used inside a C1Window.
C1RangeSlider | Represents a control that lets the user select two values from a range by moving two Thumb controls along a track.
C1SelectionManager<(Of <(T>)>) | Provides basic logic to handle item selection using different selection modes.
C1Separator | Control that is used to separate items in menus.
C1StyleSelector | Provides a way to apply styles based on custom logic.
C1TextBoxBase | Base class for all ComponentOne text box controls.
C1TextEditableContentControl | Dual control that provides a TextBox on edit mode, and a ContentControl on readonly mode.
C1TreeView | Represents a control that displays hierarchical data in a tree structure that has items that can expand and collapse.
C1TreeViewItem | Implements a selectable item in a C1TreeView control.
C1UniformGrid | Provides a way to arrange content in a grid where all the cells in the grid have the same size.
C1Window | Shows content in a window inside Silverlight.
C1WrapPanel | Positions child elements sequentially from top to bottom or from right to left, depending on the value of the Orientation property.
CancelEventArgs | Provides data for a cancelable event.
DragDropEventArgs | Class that contains data for drag-and-drop events.
Extensions | Class that provides static extension methods for several other classes.
LatLongConverter | Converts from a string to a Point representing a geographic coordinate and back.
MouseDragEventArgs | Provides data for mouse drag related events.
MouseWheelEventArgs | Provides data for mouse wheel related events.
PopupUtil | Utility methods for popups.
PrepareDropDownEventArgs | Argument of the event fired before the drop-down box is opened.
PropertyChangedEventArgs<(Of <(T>)>) | Provides event data for OnPropertyChanged events.
SourcedEventArgs | Contains data for events with a source different from the object firing the event.
TextEditedEventArgs | AutoComplete event details.
ValidateInputEventArgs | Arguments for the event fired to validate the input.

Structures

Structure | Description
AnchorMatching | Specifies an anchor matching between two elements.

Delegates

Delegate | Description
C1SelectionManager<(Of <(T>)>)..::.GetSelection | Retrieves all the items that are comprised between the startItem and the endItem. Used when making a consecutive selection.
C1SelectionManager<(Of <(T>)>)..::.IsSelected | Used to get the current state of an item (selected/unselected).
C1SelectionManager<(Of <(T>)>)..::.Select | Used to set an item as selected/unselected.
CancelEventHandler | Represents the method that handles a cancelable event.
DragDropEventHandler | Method used to handle drag drop events.

Enumerations

Enumeration | Description
Anchor | Specifies an anchor point in a visual element.
BreakLine | Specifies hard line breaks before and/or after elements in a C1WrapPanel.
C1MessageBoxButton | Specifies the buttons that are displayed on a message box.
C1MessageBoxIcon | Specifies the icon that is displayed by a message box.
C1MessageBoxResult | Specifies which message box button that a user clicks.
C1SelectionMode | Defines the selection behavior for a control which supports the SelectionMode property like C1treeView.
Dock | Specifies how controls are sized and aligned within C1DockPanel controls.
DragDropEffect | Specifies the action that will be performed when the user drops a drag source into a drop target element.
DropDownDirection | Provides the supported expand directions for the C1ComboBox.
LatLongFormat | Defines different string representations of geographic coordinates.
MaskFormat | Defines how to format the value inside of a [!:MaskedTextBox].


Anchor Enumeration

[image]

.NET Framework Class Library
Anchor Enumeration
See Also
Specifies an anchor point in a visual element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum Anchor
Visual Basic (Declaration)
Public Enumeration Anchor

Members

Member name | Description
TopLeft | The top left corner of the visual element.
TopRight | The top right corner of the visual element.
BottomLeft | The bottom left corner of the visual element.
BottomRight | The bottom right corner of the visual element.
Center | The center of the visual element.

See Also

C1.Silverlight Namespace


AnchorMatching Structure

[image]

.NET Framework Class Library
AnchorMatching Structure
Members See Also
Specifies an anchor matching between two elements.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public struct AnchorMatching
Visual Basic (Declaration)
Public Structure AnchorMatching

See Also

AnchorMatching Members
C1.Silverlight Namespace


AnchorMatching Members

[image] [image]

.NET Framework Class Library
AnchorMatching Members
AnchorMatching Structure Methods Properties See Also

The AnchorMatching type exposes the following members.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

Properties

Name | Description
FixedElementAnchor | Anchor of the fixed element.
MoveableElementAnchor | Anchor of the element that will be located.

See Also

AnchorMatching Structure
C1.Silverlight Namespace


AnchorMatching Methods

[image] [image]

.NET Framework Class Library
AnchorMatching Methods
AnchorMatching Structure See Also

The AnchorMatching type exposes the following members.

Methods

Name | Description
Equals | (Overrides ValueType..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

See Also

AnchorMatching Structure
C1.Silverlight Namespace


Equality Operator

[image]

.NET Framework Class Library
AnchorMatching..::.Equality Operator
AnchorMatching Structure See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static bool operator ==(
    AnchorMatching am1,
    AnchorMatching am2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    am1 As AnchorMatching, _
    am2 As AnchorMatching _
) As Boolean

Parameters

am1
Type: C1.Silverlight..::.AnchorMatching
am2
Type: C1.Silverlight..::.AnchorMatching

See Also

AnchorMatching Structure
C1.Silverlight Namespace


Equals Method

[image]

.NET Framework Class Library
AnchorMatching..::.Equals Method
AnchorMatching Structure See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

AnchorMatching Structure
C1.Silverlight Namespace


GetHashCode Method

[image]

.NET Framework Class Library
AnchorMatching..::.GetHashCode Method
AnchorMatching Structure See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

AnchorMatching Structure
C1.Silverlight Namespace


Inequality Operator

[image]

.NET Framework Class Library
AnchorMatching..::.Inequality Operator
AnchorMatching Structure See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static bool operator !=(
    AnchorMatching am1,
    AnchorMatching am2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    am1 As AnchorMatching, _
    am2 As AnchorMatching _
) As Boolean

Parameters

am1
Type: C1.Silverlight..::.AnchorMatching
am2
Type: C1.Silverlight..::.AnchorMatching

See Also

AnchorMatching Structure
C1.Silverlight Namespace


AnchorMatching Properties

[image] [image]

.NET Framework Class Library
AnchorMatching Properties
AnchorMatching Structure See Also

The AnchorMatching type exposes the following members.

Properties

Name | Description
FixedElementAnchor | Anchor of the fixed element.
MoveableElementAnchor | Anchor of the element that will be located.

See Also

AnchorMatching Structure
C1.Silverlight Namespace


FixedElementAnchor Property

[image]

.NET Framework Class Library
AnchorMatching..::.FixedElementAnchor Property
AnchorMatching Structure See Also
Anchor of the fixed element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Anchor FixedElementAnchor { get; set; }
Visual Basic (Declaration)
Public Property FixedElementAnchor As Anchor

See Also

AnchorMatching Structure
C1.Silverlight Namespace


MoveableElementAnchor Property

[image]

.NET Framework Class Library
AnchorMatching..::.MoveableElementAnchor Property
AnchorMatching Structure See Also
Anchor of the element that will be located.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Anchor MoveableElementAnchor { get; set; }
Visual Basic (Declaration)
Public Property MoveableElementAnchor As Anchor

See Also

AnchorMatching Structure
C1.Silverlight Namespace


BreakLine Enumeration

[image]

.NET Framework Class Library
BreakLine Enumeration
See Also
Specifies hard line breaks before and/or after elements in a C1WrapPanel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum BreakLine
Visual Basic (Declaration)
Public Enumeration BreakLine

Members

Member name | Description
None | No hard breaks. The next element will be positioned in the same line if there is enough room.
After | Add a hard break after this element. The next element will be positioned in the next line.
Before | Add a hard break before this element.
AfterAndBefore | Add hard breaks before and after this element. It will be positioned by itself on a line.

See Also

C1.Silverlight Namespace


C1ComboBox Class

[image]

.NET Framework Class Library
C1ComboBox Class
Members See Also
Represents a selection control with a drop-down list that can be shown or hidden by clicking the arrow on the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "DropDown", Type = typeof(C1DropDown))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Open", GroupName = "DropDownOpenStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplatePartAttribute(Name = "Root", Type = typeof(Panel))]
[TemplateVisualStateAttribute(Name = "Closed", GroupName = "DropDownOpenStates")]
[TemplatePartAttribute(Name = "ScrollViewer", Type = typeof(ScrollViewer))]
[TemplatePartAttribute(Name = "ComboHeader", Type = typeof(C1TextEditableContentControl))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
public class C1ComboBox : ItemsControl
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "DropDown", Type := GetType(C1DropDown))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Open", GroupName := "DropDownOpenStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplatePartAttribute(Name := "Root", Type := GetType(Panel))> _
<TemplateVisualStateAttribute(Name := "Closed", GroupName := "DropDownOpenStates")> _
<TemplatePartAttribute(Name := "ScrollViewer", Type := GetType(ScrollViewer))> _
<TemplatePartAttribute(Name := "ComboHeader", Type := GetType(C1TextEditableContentControl))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
Public Class C1ComboBox _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ComboBox

See Also

C1ComboBox Members
C1.Silverlight Namespace


C1ComboBox Members

[image] [image]

.NET Framework Class Library
C1ComboBox Members
C1ComboBox Class Constructors Methods Fields Properties Events See Also

The C1ComboBox type exposes the following members.

Constructors

Name | Description
C1ComboBox | Initializes a new instance of a C1ComboBox.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginEdit | Begins the edit.
CalculateDropDownSize | Estimates the drop down size using taking the MaxDropDownItems value into account You might need to override this method when providing different panel layouts to the C1ComboBox.
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateDropDownOpen |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
IsOpenKey | Return true if that key should open the combo box. Override to handle you own keyboard selection strategy.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveListBox | Get the next item in the ListBox when a key is pressed. You may override this to implement your own keyboard selection strategy.
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCompleted | Fires the EditCompleted event.
OnItemsChanged | (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AutoCompleteProperty | Identifies the AutoComplete dependency property.
DefaultItemHeightProperty | Identifies the DefaultItemHeight dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemConverterProperty | Identifies the ItemConverter dependency property.
MaxDropDownItemsProperty | Identifies the MaxDropDownItems dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
SelectedValueProperty | Identifies the SelectedValue dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextProperty | Identifies the Text dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AutoComplete | Gets or sets whether the control should try to automatically complete entries using the list items as an item source.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultItemHeight | Default height used for each item when it cannot be calculated automatically.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownDirection | Specifies the expand direction of the C1ComboBox drop down.
DropDownHeight | Gets or sets the height of the dropdown (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the drop-down box (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the C1ComboBox popup.
IsEditable | Get/Set if the user can select a value not contained in the C1ComboBox' Items collection.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
ItemContainerStyle | Gets or sets the style used for the inner C1ComboBox's items.
ItemConverter | Item converter used to convert the items to string and vice versa.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxDropDownItems | Gets or sets the maximum number of items that should appear on the drop-down box (set to zero to size automatically).
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | Gets or sets the current selected index or returns -1 if there is no selection, or the selection doesn't belong to the Items collection.
SelectedItem | Gets or sets the current selected item or returns null if there is no selection.
SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.
SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text in the C1ComboBox. The behavior depends on the AutoComplete and IsEditable properties.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content displayed when the control is empty.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCompleted | Handle this event to know when the user has completed the edits.
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyDownInPopup | Handle this event to provide your own custom navigation when the popup is opened. Receives the key that was pressed and the current index, and returns the new index that should be selected.
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedIndexChanged | Event raised when the SelectedIndex property has changed.
SelectedItemChanged | Event raised when the SelectedItem property has changed.
SelectedValueChanged | Event raised when the SelectedValue property has changed.
SizeChanged | (Inherited from FrameworkElement.)
ValidateInput | Event fired when new text is added to an editable C1ComboBox. Catch this event to validate the new input.

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBox Constructor

[image]

.NET Framework Class Library
C1ComboBox Constructor
C1ComboBox Class See Also
Initializes a new instance of a C1ComboBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1ComboBox()
Visual Basic (Declaration)
Public Sub New

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBox Fields

[image] [image]

.NET Framework Class Library
C1ComboBox Fields
C1ComboBox Class See Also

The C1ComboBox type exposes the following members.

Fields

Name | Description
AutoCompleteProperty | Identifies the AutoComplete dependency property.
DefaultItemHeightProperty | Identifies the DefaultItemHeight dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemConverterProperty | Identifies the ItemConverter dependency property.
MaxDropDownItemsProperty | Identifies the MaxDropDownItems dependency property.
SelectedIndexProperty | Identifies the SelectedIndex dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedValuePathProperty | Identifies the SelectedValuePath dependency property.
SelectedValueProperty | Identifies the SelectedValue dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextProperty | Identifies the Text dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

See Also

C1ComboBox Class
C1.Silverlight Namespace


AutoCompleteProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.AutoCompleteProperty Field
C1ComboBox Class See Also
Identifies the AutoComplete dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AutoCompleteProperty
Visual Basic (Declaration)
Public Shared ReadOnly AutoCompleteProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


DefaultItemHeightProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.DefaultItemHeightProperty Field
C1ComboBox Class See Also
Identifies the DefaultItemHeight dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DefaultItemHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly DefaultItemHeightProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.DisabledStyleProperty Field
C1ComboBox Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownDirectionProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownDirectionProperty Field
C1ComboBox Class See Also
Identifies the DropDownDirection dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownDirectionProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownHeightProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownHeightProperty Field
C1ComboBox Class See Also
Identifies the DropDownHeight dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownHeightProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownWidthProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownWidthProperty Field
C1ComboBox Class See Also
Identifies the DropDownWidth dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownWidthProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.FocusStyleProperty Field
C1ComboBox Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsDropDownOpenProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.IsDropDownOpenProperty Field
C1ComboBox Class See Also
Identifies the IsDropDownOpen dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsEditableProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.IsEditableProperty Field
C1ComboBox Class See Also
Identifies the IsEditable dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsEditableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsEditableProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.IsFocusedProperty Field
C1ComboBox Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.IsMouseOverProperty Field
C1ComboBox Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


ItemContainerStyleProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.ItemContainerStyleProperty Field
C1ComboBox Class See Also
Identifies the ItemContainerStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


ItemConverterProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.ItemConverterProperty Field
C1ComboBox Class See Also
Identifies the ItemConverter dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemConverterProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemConverterProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


MaxDropDownItemsProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.MaxDropDownItemsProperty Field
C1ComboBox Class See Also
Identifies the MaxDropDownItems dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MaxDropDownItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaxDropDownItemsProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedIndexProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedIndexProperty Field
C1ComboBox Class See Also
Identifies the SelectedIndex dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedIndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedItemProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedItemProperty Field
C1ComboBox Class See Also
Identifies the SelectedItem dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedValuePathProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedValuePathProperty Field
C1ComboBox Class See Also
Identifies the SelectedValuePath dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedValuePathProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedValuePathProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedValueProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedValueProperty Field
C1ComboBox Class See Also
Identifies the SelectedValue dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedValueProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.TextAlignmentProperty Field
C1ComboBox Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


TextProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.TextProperty Field
C1ComboBox Class See Also
Identifies the Text dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


WatermarkProperty Field

[image]

.NET Framework Class Library
C1ComboBox..::.WatermarkProperty Field
C1ComboBox Class See Also
Identifies the Watermark dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty WatermarkProperty
Visual Basic (Declaration)
Public Shared ReadOnly WatermarkProperty As DependencyProperty

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBox Methods

[image] [image]

.NET Framework Class Library
C1ComboBox Methods
C1ComboBox Class See Also

The C1ComboBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginEdit | Begins the edit.
CalculateDropDownSize | Estimates the drop down size using taking the MaxDropDownItems value into account You might need to override this method when providing different panel layouts to the C1ComboBox.
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateDropDownOpen |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
IsOpenKey | Return true if that key should open the combo box. Override to handle you own keyboard selection strategy.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveListBox | Get the next item in the ListBox when a key is pressed. You may override this to implement your own keyboard selection strategy.
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCompleted | Fires the EditCompleted event.
OnItemsChanged | (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ComboBox Class
C1.Silverlight Namespace


BeginEdit Method

[image]

.NET Framework Class Library
C1ComboBox..::.BeginEdit Method
C1ComboBox Class See Also
Begins the edit.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void BeginEdit(
    string text
)
Visual Basic (Declaration)
Public Sub BeginEdit ( _
    text As String _
)

Parameters

text
Type: System..::.String
The text.

See Also

C1ComboBox Class
C1.Silverlight Namespace


CalculateDropDownSize Method

[image]

.NET Framework Class Library
C1ComboBox..::.CalculateDropDownSize Method
C1ComboBox Class See Also
Estimates the drop down size using taking the MaxDropDownItems value into account You might need to override this method when providing different panel layouts to the C1ComboBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual Size CalculateDropDownSize()
Visual Basic (Declaration)
Protected Overridable Function CalculateDropDownSize As Size

See Also

C1ComboBox Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ComboBox..::.ChangeVisualStateCommon Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


ChangeVisualStateDropDownOpen Method

[image]

.NET Framework Class Library
C1ComboBox..::.ChangeVisualStateDropDownOpen Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateDropDownOpen(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateDropDownOpen ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1ComboBox..::.ChangeVisualStateFocus Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ComboBox..::.ClearContainerForItemOverride Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ComboBox..::.GetContainerForItemOverride Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1ComboBox Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ComboBox..::.HitTest Method
C1ComboBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ComboBox Class
C1ComboBox Members
C1.Silverlight Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1ComboBox..::.IsItemItsOwnContainerOverride Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsOpenKey Method

[image]

.NET Framework Class Library
C1ComboBox..::.IsOpenKey Method
C1ComboBox Class See Also
Return true if that key should open the combo box. Override to handle you own keyboard selection strategy.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual bool IsOpenKey(
    Key key
)
Visual Basic (Declaration)
Protected Overridable Function IsOpenKey ( _
    key As Key _
) As Boolean

Parameters

key
Type: System.Windows.Input..::.Key
The key that was pressed.

Return Value

True if the key pressed should open the combo box.

See Also

C1ComboBox Class
C1.Silverlight Namespace


MoveListBox Method

[image]

.NET Framework Class Library
C1ComboBox..::.MoveListBox Method
C1ComboBox Class See Also
Get the next item in the ListBox when a key is pressed. You may override this to implement your own keyboard selection strategy.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual bool MoveListBox(
    Key key,
    out int newIndex
)
Visual Basic (Declaration)
Protected Overridable Function MoveListBox ( _
    key As Key, _
    <OutAttribute> ByRef newIndex As Integer _
) As Boolean

Parameters

key
Type: System.Windows.Input..::.Key
Key that was pressed.
newIndex
Type: System..::.Int32 %
The new selected index.

Return Value

True if it is a handled key.

See Also

C1ComboBox Class
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ComboBox..::.OnApplyTemplate Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ComboBox Class
C1.Silverlight Namespace


OnEditCompleted Method

[image]

.NET Framework Class Library
C1ComboBox..::.OnEditCompleted Method
C1ComboBox Class See Also
Fires the EditCompleted event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnEditCompleted()
Visual Basic (Declaration)
Protected Overridable Sub OnEditCompleted

See Also

C1ComboBox Class
C1.Silverlight Namespace


OnItemsChanged Method

[image]

.NET Framework Class Library
C1ComboBox..::.OnItemsChanged Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs

See Also

C1ComboBox Class
C1.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ComboBox..::.PrepareContainerForItemOverride Method
C1ComboBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBox Properties

[image] [image]

.NET Framework Class Library
C1ComboBox Properties
C1ComboBox Class See Also

The C1ComboBox type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AutoComplete | Gets or sets whether the control should try to automatically complete entries using the list items as an item source.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultItemHeight | Default height used for each item when it cannot be calculated automatically.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
DropDownDirection | Specifies the expand direction of the C1ComboBox drop down.
DropDownHeight | Gets or sets the height of the dropdown (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the drop-down box (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the C1ComboBox popup.
IsEditable | Get/Set if the user can select a value not contained in the C1ComboBox' Items collection.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
ItemContainerStyle | Gets or sets the style used for the inner C1ComboBox's items.
ItemConverter | Item converter used to convert the items to string and vice versa.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxDropDownItems | Gets or sets the maximum number of items that should appear on the drop-down box (set to zero to size automatically).
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedIndex | Gets or sets the current selected index or returns -1 if there is no selection, or the selection doesn't belong to the Items collection.
SelectedItem | Gets or sets the current selected item or returns null if there is no selection.
SelectedValue | Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.
SelectedValuePath | Gets or sets the path that is used to get the SelectedValue from the SelectedItem.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text in the C1ComboBox. The behavior depends on the AutoComplete and IsEditable properties.
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content displayed when the control is empty.
Width | (Inherited from FrameworkElement.)

See Also

C1ComboBox Class
C1.Silverlight Namespace


AutoComplete Property

[image]

.NET Framework Class Library
C1ComboBox..::.AutoComplete Property
C1ComboBox Class See Also
Gets or sets whether the control should try to automatically complete entries using the list items as an item source.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AutoComplete { get; set; }
Visual Basic (Declaration)
Public Property AutoComplete As Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


DefaultItemHeight Property

[image]

.NET Framework Class Library
C1ComboBox..::.DefaultItemHeight Property
C1ComboBox Class See Also
Default height used for each item when it cannot be calculated automatically.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DefaultItemHeight { get; set; }
Visual Basic (Declaration)
Public Property DefaultItemHeight As Double

See Also

C1ComboBox Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1ComboBox..::.DisabledStyle Property
C1ComboBox Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownDirection Property

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownDirection Property
C1ComboBox Class See Also
Specifies the expand direction of the C1ComboBox drop down.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DropDownDirection DropDownDirection { get; set; }
Visual Basic (Declaration)
Public Property DropDownDirection As DropDownDirection

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownHeight Property

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownHeight Property
C1ComboBox Class See Also
Gets or sets the height of the dropdown (set to zero to size automatically).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double

See Also

C1ComboBox Class
C1.Silverlight Namespace


DropDownWidth Property

[image]

.NET Framework Class Library
C1ComboBox..::.DropDownWidth Property
C1ComboBox Class See Also
Gets or sets the width of the drop-down box (set to zero to size automatically).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double

See Also

C1ComboBox Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1ComboBox..::.FocusStyle Property
C1ComboBox Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsDropDownOpen Property

[image]

.NET Framework Class Library
C1ComboBox..::.IsDropDownOpen Property
C1ComboBox Class See Also
Open or close the C1ComboBox popup.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsEditable Property

[image]

.NET Framework Class Library
C1ComboBox..::.IsEditable Property
C1ComboBox Class See Also
Get/Set if the user can select a value not contained in the C1ComboBox' Items collection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1ComboBox..::.IsFocused Property
C1ComboBox Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ComboBox..::.IsMouseOver Property
C1ComboBox Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ComboBox Class
C1.Silverlight Namespace


ItemContainerStyle Property

[image]

.NET Framework Class Library
C1ComboBox..::.ItemContainerStyle Property
C1ComboBox Class See Also
Gets or sets the style used for the inner C1ComboBox's items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style ItemContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ItemContainerStyle As Style

See Also

C1ComboBox Class
C1.Silverlight Namespace


ItemConverter Property

[image]

.NET Framework Class Library
C1ComboBox..::.ItemConverter Property
C1ComboBox Class See Also
Item converter used to convert the items to string and vice versa.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TypeConverter ItemConverter { get; set; }
Visual Basic (Declaration)
Public Property ItemConverter As TypeConverter

Remarks

Use in conjunction with ItemTemplate to support AutoComplete and editing when providing custom item visualization.

See Also

C1ComboBox Class
C1.Silverlight Namespace


MaxDropDownItems Property

[image]

.NET Framework Class Library
C1ComboBox..::.MaxDropDownItems Property
C1ComboBox Class See Also
Gets or sets the maximum number of items that should appear on the drop-down box (set to zero to size automatically).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int MaxDropDownItems { get; set; }
Visual Basic (Declaration)
Public Property MaxDropDownItems As Integer

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedIndex Property

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedIndex Property
C1ComboBox Class See Also
Gets or sets the current selected index or returns -1 if there is no selection, or the selection doesn't belong to the Items collection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedItem Property

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedItem Property
C1ComboBox Class See Also
Gets or sets the current selected item or returns null if there is no selection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedValue Property

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedValue Property
C1ComboBox Class See Also
Gets or sets the value of the SelectedItem, obtained by using SelectedValuePath.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object SelectedValue { get; set; }
Visual Basic (Declaration)
Public Property SelectedValue As Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedValuePath Property

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedValuePath Property
C1ComboBox Class See Also
Gets or sets the path that is used to get the SelectedValue from the SelectedItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string SelectedValuePath { get; set; }
Visual Basic (Declaration)
Public Property SelectedValuePath As String

Remarks

Returns the path used to get the SelectedValue. The default is an empty string.

See Also

C1ComboBox Class
C1.Silverlight Namespace


Text Property

[image]

.NET Framework Class Library
C1ComboBox..::.Text Property
C1ComboBox Class See Also
Gets or sets the text in the C1ComboBox. The behavior depends on the AutoComplete and IsEditable properties.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

C1ComboBox Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1ComboBox..::.TextAlignment Property
C1ComboBox Class See Also
Gets or sets a value that indicates the horizontal alignment of text content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1ComboBox Class
C1.Silverlight Namespace


Watermark Property

[image]

.NET Framework Class Library
C1ComboBox..::.Watermark Property
C1ComboBox Class See Also
Gets or sets the watermark content displayed when the control is empty.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Watermark { get; set; }
Visual Basic (Declaration)
Public Property Watermark As Object

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBox Events

[image] [image]

.NET Framework Class Library
C1ComboBox Events
C1ComboBox Class See Also

The C1ComboBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCompleted | Handle this event to know when the user has completed the edits.
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyDownInPopup | Handle this event to provide your own custom navigation when the popup is opened. Receives the key that was pressed and the current index, and returns the new index that should be selected.
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedIndexChanged | Event raised when the SelectedIndex property has changed.
SelectedItemChanged | Event raised when the SelectedItem property has changed.
SelectedValueChanged | Event raised when the SelectedValue property has changed.
SizeChanged | (Inherited from FrameworkElement.)
ValidateInput | Event fired when new text is added to an editable C1ComboBox. Catch this event to validate the new input.

See Also

C1ComboBox Class
C1.Silverlight Namespace


EditCompleted Event

[image]

.NET Framework Class Library
C1ComboBox..::.EditCompleted Event
C1ComboBox Class See Also
Handle this event to know when the user has completed the edits.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler EditCompleted
Visual Basic (Declaration)
Public Event EditCompleted As EventHandler

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsDropDownOpenChanged Event

[image]

.NET Framework Class Library
C1ComboBox..::.IsDropDownOpenChanged Event
C1ComboBox Class See Also
Event raised when the IsDropDownOpen property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsDropDownOpenChanged
Visual Basic (Declaration)
Public Event IsDropDownOpenChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ComboBox Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ComboBox..::.IsMouseOverChanged Event
C1ComboBox Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ComboBox Class
C1.Silverlight Namespace


KeyDownInPopup Event

[image]

.NET Framework Class Library
C1ComboBox..::.KeyDownInPopup Event
C1ComboBox Class See Also
Handle this event to provide your own custom navigation when the popup is opened. Receives the key that was pressed and the current index, and returns the new index that should be selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event Func<Key, int, int> KeyDownInPopup
Visual Basic (Declaration)
Public Event KeyDownInPopup As Func(Of Key, Integer, Integer)

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedIndexChanged Event

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedIndexChanged Event
C1ComboBox Class See Also
Event raised when the SelectedIndex property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<int>> SelectedIndexChanged
Visual Basic (Declaration)
Public Event SelectedIndexChanged As EventHandler(Of PropertyChangedEventArgs(Of Integer))

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedItemChanged Event

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedItemChanged Event
C1ComboBox Class See Also
Event raised when the SelectedItem property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Object>> SelectedItemChanged
Visual Basic (Declaration)
Public Event SelectedItemChanged As EventHandler(Of PropertyChangedEventArgs(Of Object))

See Also

C1ComboBox Class
C1.Silverlight Namespace


SelectedValueChanged Event

[image]

.NET Framework Class Library
C1ComboBox..::.SelectedValueChanged Event
C1ComboBox Class See Also
Event raised when the SelectedValue property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Object>> SelectedValueChanged
Visual Basic (Declaration)
Public Event SelectedValueChanged As EventHandler(Of PropertyChangedEventArgs(Of Object))

See Also

C1ComboBox Class
C1.Silverlight Namespace


ValidateInput Event

[image]

.NET Framework Class Library
C1ComboBox..::.ValidateInput Event
C1ComboBox Class See Also
Event fired when new text is added to an editable C1ComboBox. Catch this event to validate the new input.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<ValidateInputEventArgs> ValidateInput
Visual Basic (Declaration)
Public Event ValidateInput As EventHandler(Of ValidateInputEventArgs)

See Also

C1ComboBox Class
C1.Silverlight Namespace


C1ComboBoxItem Class

[image]

.NET Framework Class Library
C1ComboBoxItem Class
Members See Also
Implements a selectable item inside a C1ComboBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1ComboBoxItem : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1ComboBoxItem _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1ComboBoxItem

See Also

C1ComboBoxItem Members
C1.Silverlight Namespace


C1ComboBoxItem Members

[image] [image]

.NET Framework Class Library
C1ComboBoxItem Members
C1ComboBoxItem Class Constructors Methods Fields Properties Events See Also

The C1ComboBoxItem type exposes the following members.

Constructors

Name | Description
C1ComboBoxItem | Initializes a new instance of a C1ComboBoxItem.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsSelected | Gets or sets a Boolean value indicating that this C1ComboBoxItem is selected.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1ComboBoxItem Constructor

[image]

.NET Framework Class Library
C1ComboBoxItem Constructor
C1ComboBoxItem Class See Also
Initializes a new instance of a C1ComboBoxItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1ComboBoxItem()
Visual Basic (Declaration)
Public Sub New

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1ComboBoxItem Fields

[image] [image]

.NET Framework Class Library
C1ComboBoxItem Fields
C1ComboBoxItem Class See Also

The C1ComboBoxItem type exposes the following members.

Fields

Name | Description
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsFocusedProperty Field
C1ComboBoxItem Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsMouseOverProperty Field
C1ComboBoxItem Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsSelectedProperty Field
C1ComboBoxItem Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1ComboBoxItem Methods

[image] [image]

.NET Framework Class Library
C1ComboBoxItem Methods
C1ComboBoxItem Class See Also

The C1ComboBoxItem type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ComboBoxItem..::.ChangeVisualStateCommon Method
C1ComboBoxItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1ComboBoxItem..::.ChangeVisualStateFocus Method
C1ComboBoxItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


ChangeVisualStateSelection Method

[image]

.NET Framework Class Library
C1ComboBoxItem..::.ChangeVisualStateSelection Method
C1ComboBoxItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateSelection(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateSelection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ComboBoxItem..::.HitTest Method
C1ComboBoxItem Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ComboBoxItem Class
C1ComboBoxItem Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ComboBoxItem..::.OnApplyTemplate Method
C1ComboBoxItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1ComboBoxItem Properties

[image] [image]

.NET Framework Class Library
C1ComboBoxItem Properties
C1ComboBoxItem Class See Also

The C1ComboBoxItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsSelected | Gets or sets a Boolean value indicating that this C1ComboBoxItem is selected.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsFocused Property
C1ComboBoxItem Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsMouseOver Property
C1ComboBoxItem Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsSelected Property

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsSelected Property
C1ComboBoxItem Class See Also
Gets or sets a Boolean value indicating that this C1ComboBoxItem is selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1ComboBoxItem Events

[image] [image]

.NET Framework Class Library
C1ComboBoxItem Events
C1ComboBoxItem Class See Also

The C1ComboBoxItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ComboBoxItem..::.IsMouseOverChanged Event
C1ComboBoxItem Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ComboBoxItem Class
C1.Silverlight Namespace


C1DataTemplateSelector Class

[image]

.NET Framework Class Library
C1DataTemplateSelector Class
Members See Also
Provides a way to apply data templates based on custom logic.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1DataTemplateSelector
Visual Basic (Declaration)
Public Class C1DataTemplateSelector

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1DataTemplateSelector

See Also

C1DataTemplateSelector Members
C1.Silverlight Namespace


C1DataTemplateSelector Members

[image] [image]

.NET Framework Class Library
C1DataTemplateSelector Members
C1DataTemplateSelector Class Constructors Methods See Also

The C1DataTemplateSelector type exposes the following members.

Constructors

Name | Description
C1DataTemplateSelector |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1DataTemplateSelector Class
C1.Silverlight Namespace


C1DataTemplateSelector Constructor

[image]

.NET Framework Class Library
C1DataTemplateSelector Constructor
C1DataTemplateSelector Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1DataTemplateSelector()
Visual Basic (Declaration)
Public Sub New

See Also

C1DataTemplateSelector Class
C1.Silverlight Namespace


C1DataTemplateSelector Methods

[image] [image]

.NET Framework Class Library
C1DataTemplateSelector Methods
C1DataTemplateSelector Class See Also

The C1DataTemplateSelector type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectTemplate | When overridden in a derived class, returns a DataTemplate based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1DataTemplateSelector Class
C1.Silverlight Namespace


SelectTemplate Method

[image]

.NET Framework Class Library
C1DataTemplateSelector..::.SelectTemplate Method
C1DataTemplateSelector Class See Also
When overridden in a derived class, returns a DataTemplate based on custom logic.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public virtual DataTemplate SelectTemplate(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overridable Function SelectTemplate ( _
    item As Object, _
    container As DependencyObject _
) As DataTemplate

Parameters

item
Type: System..::.Object
The data object for which to select the template.
container
Type: System.Windows..::.DependencyObject
The data-bound object.

Return Value

Returns a DataTemplate or nullNothingnullptra null reference.

See Also

C1DataTemplateSelector Class
C1.Silverlight Namespace


C1DockPanel Class

[image]

.NET Framework Class Library
C1DockPanel Class
Members See Also
Defines an area where you can arrange child elements either horizontally or vertically, relative to each other.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1DockPanel : Panel
Visual Basic (Declaration)
Public Class C1DockPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight..::.C1DockPanel

See Also

C1DockPanel Members
C1.Silverlight Namespace


C1DockPanel Members

[image] [image]

.NET Framework Class Library
C1DockPanel Members
C1DockPanel Class Constructors Methods Fields Properties Events See Also

The C1DockPanel type exposes the following members.

Constructors

Name | Description
C1DockPanel | Initializes a new instance of a C1DockPanel.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDock | Gets the value of the Dock attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetDock | Sets the value of the Dock attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DockProperty | Identifies the Dock attached property.
LastChildFillProperty | Identifies the LastChildFill dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LastChildFill | Gets or sets a value indicating whether last child of the panel fills the remaining space. If this property is set to True then the dock property of the last child element will be ignored and the panel will try to fill the empty space.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DockPanel Constructor

[image]

.NET Framework Class Library
C1DockPanel Constructor
C1DockPanel Class See Also
Initializes a new instance of a C1DockPanel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1DockPanel()
Visual Basic (Declaration)
Public Sub New

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DockPanel Fields

[image] [image]

.NET Framework Class Library
C1DockPanel Fields
C1DockPanel Class See Also

The C1DockPanel type exposes the following members.

Fields

Name | Description
DockProperty | Identifies the Dock attached property.
LastChildFillProperty | Identifies the LastChildFill dependency property.

See Also

C1DockPanel Class
C1.Silverlight Namespace


DockProperty Field

[image]

.NET Framework Class Library
C1DockPanel..::.DockProperty Field
C1DockPanel Class See Also
Identifies the Dock attached property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DockProperty
Visual Basic (Declaration)
Public Shared ReadOnly DockProperty As DependencyProperty

See Also

C1DockPanel Class
C1.Silverlight Namespace


LastChildFillProperty Field

[image]

.NET Framework Class Library
C1DockPanel..::.LastChildFillProperty Field
C1DockPanel Class See Also
Identifies the LastChildFill dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty LastChildFillProperty
Visual Basic (Declaration)
Public Shared ReadOnly LastChildFillProperty As DependencyProperty

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DockPanel Methods

[image] [image]

.NET Framework Class Library
C1DockPanel Methods
C1DockPanel Class See Also

The C1DockPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDock | Gets the value of the Dock attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetDock | Sets the value of the Dock attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1DockPanel Class
C1.Silverlight Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1DockPanel..::.ArrangeOverride Method
C1DockPanel Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1DockPanel Class
C1.Silverlight Namespace


GetDock Method

[image]

.NET Framework Class Library
C1DockPanel..::.GetDock Method
C1DockPanel Class See Also
Gets the value of the Dock attached property for the specified element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Dock GetDock(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetDock ( _
    element As DependencyObject _
) As Dock

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the Dock property.

See Also

C1DockPanel Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1DockPanel..::.HitTest Method
C1DockPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1DockPanel Class
C1DockPanel Members
C1.Silverlight Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1DockPanel..::.MeasureOverride Method
C1DockPanel Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1DockPanel Class
C1.Silverlight Namespace


SetDock Method

[image]

.NET Framework Class Library
C1DockPanel..::.SetDock Method
C1DockPanel Class See Also
Sets the value of the Dock attached property for the specified element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void SetDock(
    DependencyObject element,
    Dock value
)
Visual Basic (Declaration)
Public Shared Sub SetDock ( _
    element As DependencyObject, _
    value As Dock _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: C1.Silverlight..::.Dock
The property value to set.

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DockPanel Properties

[image] [image]

.NET Framework Class Library
C1DockPanel Properties
C1DockPanel Class See Also

The C1DockPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
LastChildFill | Gets or sets a value indicating whether last child of the panel fills the remaining space. If this property is set to True then the dock property of the last child element will be ignored and the panel will try to fill the empty space.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1DockPanel Class
C1.Silverlight Namespace


LastChildFill Property

[image]

.NET Framework Class Library
C1DockPanel..::.LastChildFill Property
C1DockPanel Class See Also
Gets or sets a value indicating whether last child of the panel fills the remaining space. If this property is set to True then the dock property of the last child element will be ignored and the panel will try to fill the empty space.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool LastChildFill { get; set; }
Visual Basic (Declaration)
Public Property LastChildFill As Boolean

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DockPanel Events

[image] [image]

.NET Framework Class Library
C1DockPanel Events
C1DockPanel Class See Also

The C1DockPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1DockPanel Class
C1.Silverlight Namespace


C1DragDropManager Class

[image]

.NET Framework Class Library
C1DragDropManager Class
Members See Also
Provides methods for drag-and-drop operations in Silverlight applications.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1DragDropManager
Visual Basic (Declaration)
Public Class C1DragDropManager

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1DragDropManager

See Also

C1DragDropManager Members
C1.Silverlight Namespace


C1DragDropManager Members

[image] [image]

.NET Framework Class Library
C1DragDropManager Members
C1DragDropManager Class Constructors Methods Properties Events See Also

The C1DragDropManager type exposes the following members.

Constructors

Name | Description
C1DragDropManager |

Methods

Name | Description
ClearSources | Removes all the registered sources
ClearTargets | Removes all the registered targets
DoDragDrop | Initiates a drag drop operation using a UIElement as a source, supporting a specified DragDropEffect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDragAutoScroll | Raises the DragAutoScroll event.
OnDragDrop | Raises the DragDrop event.
OnDragEnter | Raises the DragEnter event.
OnDragLeave | Raises the DragLeave event.
OnDragOver | Raises the DragOver event.
OnDragStart | Raises the DragStart event.
RegisterDragSource | Registers a UIElement to act as a drag source.
RegisterDropTarget | Registers (or unregisters) an element as a drop target.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AutoScroll | Gets or sets whether the C1DragDropManager should automatically scroll the ScrollViewer that contains the drop target.
AutoScrollDelay | Gets or sets the number of milliseconds between auto scroll steps.
AutoScrollEdge | Gets or sets the distance between the mouse and the edges of a drag target element that triggers the auto scroll process.
AutoScrollStep | Gets or sets the number of pixels to scroll in each auto scroll step.
Canvas | Gets a reference to the Canvas being used to show the drag-and-drop process.
DragThreshold | Gets or sets the distance in pixels that the mouse must move before a drag operation starts.
SourceMarker | Gets a reference to the Border used to highlight the drag source.
TargetMarker | Gets or sets the Border used to indicate the drop location.

Events

Name | Description
DragAutoScroll | Fires after the C1DragDropManager automatically scrolls a ScrollViewer in order to keep the drop location within view.
DragDrop | Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.
DragEnter | Fires during a drag drop process, when the cursor enters a registered drop target.
DragLeave | Fires during a drag drop process, when the cursor leaves a registered drop target.
DragOver | Fires during a drag drop process, when the cursor moves over a registered drop target.
DragStart | Fires when a drag drop process starts.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


C1DragDropManager Constructor

[image]

.NET Framework Class Library
C1DragDropManager Constructor
C1DragDropManager Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1DragDropManager()
Visual Basic (Declaration)
Public Sub New

See Also

C1DragDropManager Class
C1.Silverlight Namespace


C1DragDropManager Methods

[image] [image]

.NET Framework Class Library
C1DragDropManager Methods
C1DragDropManager Class See Also

The C1DragDropManager type exposes the following members.

Methods

Name | Description
ClearSources | Removes all the registered sources
ClearTargets | Removes all the registered targets
DoDragDrop | Initiates a drag drop operation using a UIElement as a source, supporting a specified DragDropEffect.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnDragAutoScroll | Raises the DragAutoScroll event.
OnDragDrop | Raises the DragDrop event.
OnDragEnter | Raises the DragEnter event.
OnDragLeave | Raises the DragLeave event.
OnDragOver | Raises the DragOver event.
OnDragStart | Raises the DragStart event.
RegisterDragSource | Registers a UIElement to act as a drag source.
RegisterDropTarget | Registers (or unregisters) an element as a drop target.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1DragDropManager Class
C1.Silverlight Namespace


ClearSources Method

[image]

.NET Framework Class Library
C1DragDropManager..::.ClearSources Method
C1DragDropManager Class See Also
Removes all the registered sources

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void ClearSources()
Visual Basic (Declaration)
Public Sub ClearSources

See Also

C1DragDropManager Class
C1.Silverlight Namespace


ClearTargets Method

[image]

.NET Framework Class Library
C1DragDropManager..::.ClearTargets Method
C1DragDropManager Class See Also
Removes all the registered targets

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void ClearTargets()
Visual Basic (Declaration)
Public Sub ClearTargets

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DoDragDrop Method

[image]

.NET Framework Class Library
C1DragDropManager..::.DoDragDrop Method
C1DragDropManager Class See Also
Initiates a drag drop operation using a UIElement as a source, supporting a specified DragDropEffect.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void DoDragDrop(
    UIElement source,
    MouseEventArgs e,
    DragDropEffect effect
)
Visual Basic (Declaration)
Public Sub DoDragDrop ( _
    source As UIElement, _
    e As MouseEventArgs, _
    effect As DragDropEffect _
)

Parameters

source
Type: System.Windows..::.UIElement
UIElement that will be dragged.
e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the mouse position when the drag operation starts.
effect
Type: C1.Silverlight..::.DragDropEffect
DragDropEffect supported by the operation.

Remarks

The e is not strictly required, but is usually available since drag drop operations are initiated by mouse actions. If you don't have a MouseEventArgs to provide, pass null instead.

The method causes the drag operation to start, then returns immediately. The caller is responsible for monitoring and completing the operation using the DragStart, DragEnter, DragOver, and DragDrop events.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragAutoScroll Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragAutoScroll Method
C1DragDropManager Class See Also
Raises the DragAutoScroll event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragAutoScroll(
    DragDropEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragAutoScroll ( _
    e As DragDropEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.DragDropEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragDrop Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragDrop Method
C1DragDropManager Class See Also
Raises the DragDrop event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragDrop(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragDrop ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragEnter Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragEnter Method
C1DragDropManager Class See Also
Raises the DragEnter event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragEnter(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragEnter ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragLeave Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragLeave Method
C1DragDropManager Class See Also
Raises the DragLeave event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragLeave(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragLeave ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragOver Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragOver Method
C1DragDropManager Class See Also
Raises the DragOver event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragOver(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragOver ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


OnDragStart Method

[image]

.NET Framework Class Library
C1DragDropManager..::.OnDragStart Method
C1DragDropManager Class See Also
Raises the DragStart event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragStart(
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragStart ( _
    e As MouseEventArgs _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains the event data.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


RegisterDragSource Method

[image]

.NET Framework Class Library
C1DragDropManager..::.RegisterDragSource Method
C1DragDropManager Class See Also
Registers a UIElement to act as a drag source.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void RegisterDragSource(
    UIElement source,
    DragDropEffect effect,
    ModifierKeys keys
)
Visual Basic (Declaration)
Public Sub RegisterDragSource ( _
    source As UIElement, _
    effect As DragDropEffect, _
    keys As ModifierKeys _
)

Parameters

source
Type: System.Windows..::.UIElement
UIElement that will act as a drag source.
effect
Type: C1.Silverlight..::.DragDropEffect
DragDropEffect that will be supported by the source object.
keys
Type: System.Windows.Input..::.ModifierKeys
ModifierKeys that should be pressed in order for the drag operation to start.

Remarks

When a UIElement is registered as a drag source, the C1DragDropManager monitors the mouse events for that element and starts drag-drop operations automatically when the user presses the mouse over the element and moves it for a few pixels.

This is a convenience method, it is not strictly required; you could handle the mouse events for the objects you want to use as drag sources and call the DoDragDrop(UIElement, MouseEventArgs, DragDropEffect) method explicitly.

Note that only elements that raise mouse events may be used as automatic drag sources. For example, the Button and TextBox controls consume mouse events internally, so the C1DragDropManager does not receive any mouse events for these controls. Therefore, they cannot be used as automatic drag sources.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


RegisterDropTarget Method

[image]

.NET Framework Class Library
C1DragDropManager..::.RegisterDropTarget Method
C1DragDropManager Class See Also
Registers (or unregisters) an element as a drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void RegisterDropTarget(
    UIElement target,
    bool register
)
Visual Basic (Declaration)
Public Sub RegisterDropTarget ( _
    target As UIElement, _
    register As Boolean _
)

Parameters

target
Type: System.Windows..::.UIElement
UIElement that will act as a drop target.
register
Type: System..::.Boolean
True to register the element, false to unregister.

Remarks

The target element should not be transparent, or it will not receive any mouse events and thus won't be able to act as a drop target.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


C1DragDropManager Properties

[image] [image]

.NET Framework Class Library
C1DragDropManager Properties
C1DragDropManager Class See Also

The C1DragDropManager type exposes the following members.

Properties

Name | Description
AutoScroll | Gets or sets whether the C1DragDropManager should automatically scroll the ScrollViewer that contains the drop target.
AutoScrollDelay | Gets or sets the number of milliseconds between auto scroll steps.
AutoScrollEdge | Gets or sets the distance between the mouse and the edges of a drag target element that triggers the auto scroll process.
AutoScrollStep | Gets or sets the number of pixels to scroll in each auto scroll step.
Canvas | Gets a reference to the Canvas being used to show the drag-and-drop process.
DragThreshold | Gets or sets the distance in pixels that the mouse must move before a drag operation starts.
SourceMarker | Gets a reference to the Border used to highlight the drag source.
TargetMarker | Gets or sets the Border used to indicate the drop location.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


AutoScroll Property

[image]

.NET Framework Class Library
C1DragDropManager..::.AutoScroll Property
C1DragDropManager Class See Also
Gets or sets whether the C1DragDropManager should automatically scroll the ScrollViewer that contains the drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[DefaultValueAttribute(true)]
public bool AutoScroll { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute(True)> _
Public Property AutoScroll As Boolean

See Also

C1DragDropManager Class
C1.Silverlight Namespace


AutoScrollDelay Property

[image]

.NET Framework Class Library
C1DragDropManager..::.AutoScrollDelay Property
C1DragDropManager Class See Also
Gets or sets the number of milliseconds between auto scroll steps.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[DefaultValueAttribute()]
public int AutoScrollDelay { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property AutoScrollDelay As Integer

Remarks

This property is applicable only when AutoScroll is set to true.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


AutoScrollEdge Property

[image]

.NET Framework Class Library
C1DragDropManager..::.AutoScrollEdge Property
C1DragDropManager Class See Also
Gets or sets the distance between the mouse and the edges of a drag target element that triggers the auto scroll process.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[DefaultValueAttribute()]
public int AutoScrollEdge { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property AutoScrollEdge As Integer

Remarks

This property is applicable only when AutoScroll is set to true.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


AutoScrollStep Property

[image]

.NET Framework Class Library
C1DragDropManager..::.AutoScrollStep Property
C1DragDropManager Class See Also
Gets or sets the number of pixels to scroll in each auto scroll step.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[DefaultValueAttribute()]
public int AutoScrollStep { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property AutoScrollStep As Integer

Remarks

This property is applicable only when AutoScroll is set to true.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


Canvas Property

[image]

.NET Framework Class Library
C1DragDropManager..::.Canvas Property
C1DragDropManager Class See Also
Gets a reference to the Canvas being used to show the drag-and-drop process.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Canvas Canvas { get; }
Visual Basic (Declaration)
Public ReadOnly Property Canvas As Canvas

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragThreshold Property

[image]

.NET Framework Class Library
C1DragDropManager..::.DragThreshold Property
C1DragDropManager Class See Also
Gets or sets the distance in pixels that the mouse must move before a drag operation starts.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[DefaultValueAttribute()]
public int DragThreshold { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property DragThreshold As Integer

Remarks

This property affects the drag behavior of objects registered as drag sources using the RegisterDragSource(UIElement, DragDropEffect, ModifierKeys) method.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


SourceMarker Property

[image]

.NET Framework Class Library
C1DragDropManager..::.SourceMarker Property
C1DragDropManager Class See Also
Gets a reference to the Border used to highlight the drag source.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Border SourceMarker { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceMarker As Border

See Also

C1DragDropManager Class
C1.Silverlight Namespace


TargetMarker Property

[image]

.NET Framework Class Library
C1DragDropManager..::.TargetMarker Property
C1DragDropManager Class See Also
Gets or sets the Border used to indicate the drop location.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Border TargetMarker { get; }
Visual Basic (Declaration)
Public ReadOnly Property TargetMarker As Border

See Also

C1DragDropManager Class
C1.Silverlight Namespace


C1DragDropManager Events

[image] [image]

.NET Framework Class Library
C1DragDropManager Events
C1DragDropManager Class See Also

The C1DragDropManager type exposes the following members.

Events

Name | Description
DragAutoScroll | Fires after the C1DragDropManager automatically scrolls a ScrollViewer in order to keep the drop location within view.
DragDrop | Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.
DragEnter | Fires during a drag drop process, when the cursor enters a registered drop target.
DragLeave | Fires during a drag drop process, when the cursor leaves a registered drop target.
DragOver | Fires during a drag drop process, when the cursor moves over a registered drop target.
DragStart | Fires when a drag drop process starts.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragAutoScroll Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragAutoScroll Event
C1DragDropManager Class See Also
Fires after the C1DragDropManager automatically scrolls a ScrollViewer in order to keep the drop location within view.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragAutoScroll
Visual Basic (Declaration)
Public Event DragAutoScroll As DragDropEventHandler

Remarks

The ScrollViewer property of the DragDropEventArgs contains a reference to the ScrollViewer that was updated.

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragDrop Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragDrop Event
C1DragDropManager Class See Also
Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragDrop
Visual Basic (Declaration)
Public Event DragDrop As DragDropEventHandler

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragEnter Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragEnter Event
C1DragDropManager Class See Also
Fires during a drag drop process, when the cursor enters a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragEnter
Visual Basic (Declaration)
Public Event DragEnter As DragDropEventHandler

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragLeave Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragLeave Event
C1DragDropManager Class See Also
Fires during a drag drop process, when the cursor leaves a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragLeave
Visual Basic (Declaration)
Public Event DragLeave As DragDropEventHandler

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragOver Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragOver Event
C1DragDropManager Class See Also
Fires during a drag drop process, when the cursor moves over a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragOver
Visual Basic (Declaration)
Public Event DragOver As DragDropEventHandler

See Also

C1DragDropManager Class
C1.Silverlight Namespace


DragStart Event

[image]

.NET Framework Class Library
C1DragDropManager..::.DragStart Event
C1DragDropManager Class See Also
Fires when a drag drop process starts.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragStart
Visual Basic (Declaration)
Public Event DragStart As DragDropEventHandler

See Also

C1DragDropManager Class
C1.Silverlight Namespace


C1DropDown Class

[image]

.NET Framework Class Library
C1DropDown Class
Members See Also
C1HeaderedContentControl that presents the Content in a dropdown popup.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "DropDownPopup", Type = typeof(Popup))]
[TemplateVisualStateAttribute(Name = "Opened", GroupName = "DropDownOpenStates")]
[TemplateVisualStateAttribute(Name = "Closed", GroupName = "DropDownOpenStates")]
[TemplatePartAttribute(Name = "ArrowToggle", Type = typeof(ToggleButton))]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
public class C1DropDown : C1HeaderedContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "DropDownPopup", Type := GetType(Popup))> _
<TemplateVisualStateAttribute(Name := "Opened", GroupName := "DropDownOpenStates")> _
<TemplateVisualStateAttribute(Name := "Closed", GroupName := "DropDownOpenStates")> _
<TemplatePartAttribute(Name := "ArrowToggle", Type := GetType(ToggleButton))> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
Public Class C1DropDown _
    Inherits C1HeaderedContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1HeaderedContentControl
C1.Silverlight..::.C1DropDown

See Also

C1DropDown Members
C1.Silverlight Namespace


C1DropDown Members

[image] [image]

.NET Framework Class Library
C1DropDown Members
C1DropDown Class Constructors Methods Fields Properties Events See Also

The C1DropDown type exposes the following members.

Constructors

Name | Description
C1DropDown | Initializes a new instance of a C1DropDown.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateDropDownOpen |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPreferedLocations | Get the locations where the dropdown will try to locate the Popup once it's opened.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
OnPreparePopupContent | Prepare the drop-down content before being opened.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AutoCloseProperty | Identifies the AutoClose dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ShowButtonProperty | Identifies the ShowButton dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AutoClose | Auto closes the dropdown when the user clicks outside it.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DropDownDirection | Specifies the expand direction of the control drop-down box.
DropDownHeight | Gets or sets the height of the drop-down box (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the drop-down box (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the control drop-down box.
IsEnabled | (Inherited from ContentControl.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowButton | Gets/sets if the aToggleButton is shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PrepareDropDown | Handle this event to set the dropdown size before it's being opened
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1DropDown Class
C1.Silverlight Namespace


C1DropDown Constructor

[image]

.NET Framework Class Library
C1DropDown Constructor
C1DropDown Class See Also
Initializes a new instance of a C1DropDown.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1DropDown()
Visual Basic (Declaration)
Public Sub New

See Also

C1DropDown Class
C1.Silverlight Namespace


C1DropDown Fields

[image] [image]

.NET Framework Class Library
C1DropDown Fields
C1DropDown Class See Also

The C1DropDown type exposes the following members.

Fields

Name | Description
AutoCloseProperty | Identifies the AutoClose dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ShowButtonProperty | Identifies the ShowButton dependency property.

See Also

C1DropDown Class
C1.Silverlight Namespace


AutoCloseProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.AutoCloseProperty Field
C1DropDown Class See Also
Identifies the AutoClose dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AutoCloseProperty
Visual Basic (Declaration)
Public Shared ReadOnly AutoCloseProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.DisabledStyleProperty Field
C1DropDown Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownDirectionProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.DropDownDirectionProperty Field
C1DropDown Class See Also
Identifies the DropDownDirection dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownDirectionProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownHeightProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.DropDownHeightProperty Field
C1DropDown Class See Also
Identifies the DropDownHeight dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownHeightProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownWidthProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.DropDownWidthProperty Field
C1DropDown Class See Also
Identifies the DropDownWidth dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DropDownWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownWidthProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.FocusStyleProperty Field
C1DropDown Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


IsDropDownOpenProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.IsDropDownOpenProperty Field
C1DropDown Class See Also
Identifies the IsDropDownOpen dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.IsFocusedProperty Field
C1DropDown Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.IsMouseOverProperty Field
C1DropDown Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


ShowButtonProperty Field

[image]

.NET Framework Class Library
C1DropDown..::.ShowButtonProperty Field
C1DropDown Class See Also
Identifies the ShowButton dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ShowButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowButtonProperty As DependencyProperty

See Also

C1DropDown Class
C1.Silverlight Namespace


C1DropDown Methods

[image] [image]

.NET Framework Class Library
C1DropDown Methods
C1DropDown Class See Also

The C1DropDown type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateDropDownOpen |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPreferedLocations | Get the locations where the dropdown will try to locate the Popup once it's opened.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
OnPreparePopupContent | Prepare the drop-down content before being opened.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1DropDown Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1DropDown..::.ChangeVisualStateCommon Method
C1DropDown Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


ChangeVisualStateDropDownOpen Method

[image]

.NET Framework Class Library
C1DropDown..::.ChangeVisualStateDropDownOpen Method
C1DropDown Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateDropDownOpen(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateDropDownOpen ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1DropDown..::.ChangeVisualStateFocus Method
C1DropDown Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


GetPreferedLocations Method

[image]

.NET Framework Class Library
C1DropDown..::.GetPreferedLocations Method
C1DropDown Class See Also
Get the locations where the dropdown will try to locate the Popup once it's opened.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual List<AnchorMatching> GetPreferedLocations()
Visual Basic (Declaration)
Protected Overridable Function GetPreferedLocations As List(Of AnchorMatching)

Return Value

Ordered list of AnchorMatching to try.

See Also

C1DropDown Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1DropDown..::.HitTest Method
C1DropDown Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1DropDown Class
C1DropDown Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1DropDown..::.OnApplyTemplate Method
C1DropDown Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1DropDown Class
C1.Silverlight Namespace


OnPreparePopupContent Method

[image]

.NET Framework Class Library
C1DropDown..::.OnPreparePopupContent Method
C1DropDown Class See Also
Prepare the drop-down content before being opened.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual Size OnPreparePopupContent()
Visual Basic (Declaration)
Protected Overridable Function OnPreparePopupContent As Size

See Also

C1DropDown Class
C1.Silverlight Namespace


C1DropDown Properties

[image] [image]

.NET Framework Class Library
C1DropDown Properties
C1DropDown Class See Also

The C1DropDown type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AutoClose | Auto closes the dropdown when the user clicks outside it.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DropDownDirection | Specifies the expand direction of the control drop-down box.
DropDownHeight | Gets or sets the height of the drop-down box (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the drop-down box (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the control drop-down box.
IsEnabled | (Inherited from ContentControl.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowButton | Gets/sets if the aToggleButton is shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1DropDown Class
C1.Silverlight Namespace


AutoClose Property

[image]

.NET Framework Class Library
C1DropDown..::.AutoClose Property
C1DropDown Class See Also
Auto closes the dropdown when the user clicks outside it.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AutoClose { get; set; }
Visual Basic (Declaration)
Public Property AutoClose As Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1DropDown..::.DisabledStyle Property
C1DropDown Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownDirection Property

[image]

.NET Framework Class Library
C1DropDown..::.DropDownDirection Property
C1DropDown Class See Also
Specifies the expand direction of the control drop-down box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DropDownDirection DropDownDirection { get; set; }
Visual Basic (Declaration)
Public Property DropDownDirection As DropDownDirection

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownHeight Property

[image]

.NET Framework Class Library
C1DropDown..::.DropDownHeight Property
C1DropDown Class See Also
Gets or sets the height of the drop-down box (set to zero to size automatically).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double

See Also

C1DropDown Class
C1.Silverlight Namespace


DropDownWidth Property

[image]

.NET Framework Class Library
C1DropDown..::.DropDownWidth Property
C1DropDown Class See Also
Gets or sets the width of the drop-down box (set to zero to size automatically).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double

See Also

C1DropDown Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1DropDown..::.FocusStyle Property
C1DropDown Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1DropDown Class
C1.Silverlight Namespace


IsDropDownOpen Property

[image]

.NET Framework Class Library
C1DropDown..::.IsDropDownOpen Property
C1DropDown Class See Also
Open or close the control drop-down box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1DropDown..::.IsFocused Property
C1DropDown Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1DropDown..::.IsMouseOver Property
C1DropDown Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


ShowButton Property

[image]

.NET Framework Class Library
C1DropDown..::.ShowButton Property
C1DropDown Class See Also
Gets/sets if the aToggleButton is shown.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool ShowButton { get; set; }
Visual Basic (Declaration)
Public Property ShowButton As Boolean

See Also

C1DropDown Class
C1.Silverlight Namespace


C1DropDown Events

[image] [image]

.NET Framework Class Library
C1DropDown Events
C1DropDown Class See Also

The C1DropDown type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PrepareDropDown | Handle this event to set the dropdown size before it's being opened
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1DropDown Class
C1.Silverlight Namespace


IsDropDownOpenChanged Event

[image]

.NET Framework Class Library
C1DropDown..::.IsDropDownOpenChanged Event
C1DropDown Class See Also
Event raised when the IsDropDownOpen property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsDropDownOpenChanged
Visual Basic (Declaration)
Public Event IsDropDownOpenChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1DropDown Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1DropDown..::.IsMouseOverChanged Event
C1DropDown Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1DropDown Class
C1.Silverlight Namespace


PrepareDropDown Event

[image]

.NET Framework Class Library
C1DropDown..::.PrepareDropDown Event
C1DropDown Class See Also
Handle this event to set the dropdown size before it's being opened

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PrepareDropDownEventArgs> PrepareDropDown
Visual Basic (Declaration)
Public Event PrepareDropDown As EventHandler(Of PrepareDropDownEventArgs)

See Also

C1DropDown Class
C1.Silverlight Namespace


C1EditableContentControl Class

[image]

.NET Framework Class Library
C1EditableContentControl Class
Members See Also
ContenControl that supports edit mode.
ContenControl that supports edit mode using a TextBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public abstract class C1EditableContentControl : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public MustInherit Class C1EditableContentControl _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1EditableContentControl
C1.Silverlight..::.C1TextEditableContentControl

See Also

C1EditableContentControl Members
C1.Silverlight Namespace


C1EditableContentControl Members

[image] [image]

.NET Framework Class Library
C1EditableContentControl Members
C1EditableContentControl Class Constructors Methods Fields Properties Events See Also

The C1EditableContentControl type exposes the following members.

Constructors

Name | Description
C1EditableContentControl | Initializes a new instance of a C1EditableContentControl.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCanceled | Fires the EditCanceled event.
OnEditCompleted | Fires the EditCompleted event.
OnEditStarted | Fires the EditStarted event.
OnIsEditableChanged | The IsEditable value has changed.
OnIsEnabledChanged | (Inherited from ContentControl.)
OnIsInEditModeChanged | The control has changed the mode.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldEnterEditModeOnKeyDown | Called to define if the control has to enter edit mode when a particular key is pressed. For example: arrow keys might not change to edit mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateVisualState | Update the visual state of this control

Fields

Name | Description
ContentControlProperty | Identifies the ContentControl dependency property.
ContentConverterProperty | Identifies the ContentConverter dependency property.
EditControlProperty | Identifies the EditControl dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
IsInEditModeProperty | Identifies the IsInEditMode dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentControl | Control visible when it is not in edit mode.
ContentConverter | Used to create the control content from the edited content.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
EditControl | Control visible when it is in edit mode.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirty | Get or sets whether the element was edited during edit mode.
IsEditable | Gets/set if the control can be edited.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets/sets when the control enters in edit mode.
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCanceled | Fired when the user exits edit mode without changes.
EditCompleted | Fired when the user has completed the edits.
EditStarted | Fired when the control enters edit mode.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1EditableContentControl Constructor

[image]

.NET Framework Class Library
C1EditableContentControl Constructor
C1EditableContentControl Class See Also
Initializes a new instance of a C1EditableContentControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1EditableContentControl()
Visual Basic (Declaration)
Public Sub New

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1EditableContentControl Fields

[image] [image]

.NET Framework Class Library
C1EditableContentControl Fields
C1EditableContentControl Class See Also

The C1EditableContentControl type exposes the following members.

Fields

Name | Description
ContentControlProperty | Identifies the ContentControl dependency property.
ContentConverterProperty | Identifies the ContentConverter dependency property.
EditControlProperty | Identifies the EditControl dependency property.
IsEditableProperty | Identifies the IsEditable dependency property.
IsInEditModeProperty | Identifies the IsInEditMode dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ContentControlProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.ContentControlProperty Field
C1EditableContentControl Class See Also
Identifies the ContentControl dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ContentControlProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentControlProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ContentConverterProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.ContentConverterProperty Field
C1EditableContentControl Class See Also
Identifies the ContentConverter dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ContentConverterProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentConverterProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


EditControlProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.EditControlProperty Field
C1EditableContentControl Class See Also
Identifies the EditControl dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected static readonly DependencyProperty EditControlProperty
Visual Basic (Declaration)
Protected Shared ReadOnly EditControlProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsEditableProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsEditableProperty Field
C1EditableContentControl Class See Also
Identifies the IsEditable dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsEditableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsEditableProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsInEditModeProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsInEditModeProperty Field
C1EditableContentControl Class See Also
Identifies the IsInEditMode dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsInEditModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsInEditModeProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsMouseOverProperty Field
C1EditableContentControl Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1EditableContentControl Methods

[image] [image]

.NET Framework Class Library
C1EditableContentControl Methods
C1EditableContentControl Class See Also

The C1EditableContentControl type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCanceled | Fires the EditCanceled event.
OnEditCompleted | Fires the EditCompleted event.
OnEditStarted | Fires the EditStarted event.
OnIsEditableChanged | The IsEditable value has changed.
OnIsEnabledChanged | (Inherited from ContentControl.)
OnIsInEditModeChanged | The control has changed the mode.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldEnterEditModeOnKeyDown | Called to define if the control has to enter edit mode when a particular key is pressed. For example: arrow keys might not change to edit mode.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateVisualState | Update the visual state of this control

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.ChangeVisualStateCommon Method
C1EditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1EditableContentControl..::.HitTest Method
C1EditableContentControl Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1EditableContentControl Class
C1EditableContentControl Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnApplyTemplate Method
C1EditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


OnEditCanceled Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnEditCanceled Method
C1EditableContentControl Class See Also
Fires the EditCanceled event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnEditCanceled()
Visual Basic (Declaration)
Protected Overridable Sub OnEditCanceled

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


OnEditCompleted Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnEditCompleted Method
C1EditableContentControl Class See Also
Fires the EditCompleted event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnEditCompleted()
Visual Basic (Declaration)
Protected Overridable Sub OnEditCompleted

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


OnEditStarted Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnEditStarted Method
C1EditableContentControl Class See Also
Fires the EditStarted event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnEditStarted()
Visual Basic (Declaration)
Protected Overridable Sub OnEditStarted

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


OnIsEditableChanged Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnIsEditableChanged Method
C1EditableContentControl Class See Also
The IsEditable value has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnIsEditableChanged(
    bool oldValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsEditableChanged ( _
    oldValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean
Old IsEditable value

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


OnIsInEditModeChanged Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.OnIsInEditModeChanged Method
C1EditableContentControl Class See Also
The control has changed the mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnIsInEditModeChanged(
    bool oldValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsInEditModeChanged ( _
    oldValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean
Old IsInEditMode value

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ShouldEnterEditModeOnKeyDown Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.ShouldEnterEditModeOnKeyDown Method
C1EditableContentControl Class See Also
Called to define if the control has to enter edit mode when a particular key is pressed. For example: arrow keys might not change to edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual bool ShouldEnterEditModeOnKeyDown(
    Key key
)
Visual Basic (Declaration)
Protected Overridable Function ShouldEnterEditModeOnKeyDown ( _
    key As Key _
) As Boolean

Parameters

key
Type: System.Windows.Input..::.Key
Key that was pressed.

Return Value

True if the control has enter edit mode.

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


UpdateVisualState Method

[image]

.NET Framework Class Library
C1EditableContentControl..::.UpdateVisualState Method
C1EditableContentControl Class See Also
Update the visual state of this control

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal void UpdateVisualState()
Visual Basic (Declaration)
Protected Friend Sub UpdateVisualState

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1EditableContentControl Properties

[image] [image]

.NET Framework Class Library
C1EditableContentControl Properties
C1EditableContentControl Class See Also

The C1EditableContentControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentControl | Control visible when it is not in edit mode.
ContentConverter | Used to create the control content from the edited content.
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
EditControl | Control visible when it is in edit mode.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirty | Get or sets whether the element was edited during edit mode.
IsEditable | Gets/set if the control can be edited.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets/sets when the control enters in edit mode.
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ContentControl Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.ContentControl Property
C1EditableContentControl Class See Also
Control visible when it is not in edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public ContentPresenter ContentControl { get; set; }
Visual Basic (Declaration)
Public Property ContentControl As ContentPresenter

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


ContentConverter Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.ContentConverter Property
C1EditableContentControl Class See Also
Used to create the control content from the edited content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TypeConverter ContentConverter { get; set; }
Visual Basic (Declaration)
Public Property ContentConverter As TypeConverter

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


EditControl Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.EditControl Property
C1EditableContentControl Class See Also
Control visible when it is in edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected Control EditControl { get; set; }
Visual Basic (Declaration)
Protected Property EditControl As Control

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsDirty Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsDirty Property
C1EditableContentControl Class See Also
Get or sets whether the element was edited during edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public virtual bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overridable Property IsDirty As Boolean

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsEditable Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsEditable Property
C1EditableContentControl Class See Also
Gets/set if the control can be edited.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsEditable { get; set; }
Visual Basic (Declaration)
Public Property IsEditable As Boolean

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsInEditMode Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsInEditMode Property
C1EditableContentControl Class See Also
Gets/sets when the control enters in edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsInEditMode { get; set; }
Visual Basic (Declaration)
Public Property IsInEditMode As Boolean

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsMouseOver Property
C1EditableContentControl Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1EditableContentControl Events

[image] [image]

.NET Framework Class Library
C1EditableContentControl Events
C1EditableContentControl Class See Also

The C1EditableContentControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCanceled | Fired when the user exits edit mode without changes.
EditCompleted | Fired when the user has completed the edits.
EditStarted | Fired when the control enters edit mode.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


EditCanceled Event

[image]

.NET Framework Class Library
C1EditableContentControl..::.EditCanceled Event
C1EditableContentControl Class See Also
Fired when the user exits edit mode without changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler EditCanceled
Visual Basic (Declaration)
Public Event EditCanceled As EventHandler

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


EditCompleted Event

[image]

.NET Framework Class Library
C1EditableContentControl..::.EditCompleted Event
C1EditableContentControl Class See Also
Fired when the user has completed the edits.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler EditCompleted
Visual Basic (Declaration)
Public Event EditCompleted As EventHandler

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


EditStarted Event

[image]

.NET Framework Class Library
C1EditableContentControl..::.EditStarted Event
C1EditableContentControl Class See Also
Fired when the control enters edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler EditStarted
Visual Basic (Declaration)
Public Event EditStarted As EventHandler

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1EditableContentControl..::.IsMouseOverChanged Event
C1EditableContentControl Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1EditableContentControl Class
C1.Silverlight Namespace


C1FilePicker Class

[image]

.NET Framework Class Library
C1FilePicker Class
Members See Also
Editor that allows selecting one or more files

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Text", Type = typeof(C1TextBoxBase))]
[TemplatePartAttribute(Name = "Browse", Type = typeof(Button))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
public class C1FilePicker : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Text", Type := GetType(C1TextBoxBase))> _
<TemplatePartAttribute(Name := "Browse", Type := GetType(Button))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
Public Class C1FilePicker _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1FilePicker

See Also

C1FilePicker Members
C1.Silverlight Namespace


C1FilePicker Members

[image] [image]

.NET Framework Class Library
C1FilePicker Members
C1FilePicker Class Constructors Methods Fields Properties Events See Also

The C1FilePicker type exposes the following members.

Constructors

Name | Description
C1FilePicker | Initializes a new instance of a C1FilePicker.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearSelection | Removes the selected files.
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnSelectedFilesChanged | Raises the SelectedFilesChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
BrowseContentProperty | Identifies the BrowseContent dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FilterIndexProperty | Identifies the FilterIndex dependency property.
FilterProperty | Identifies the Filter dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MultiselectProperty | Identifies the Multiselect dependency property.
SelectedFileProperty | Identifies the SelectedFile dependency property.
SelectedFilesProperty | Identifies the SelectedFiles dependency property.
SelectionBackgroundProperty | Identifies the SelectionBackground dependency property.
SelectionForegroundProperty | Identifies the SelectionForeground dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
BrowseContent | Gets or sets the content of the Browse button.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
Filter | Gets or sets the filter that will be applied to the OpenFileDialog.
FilterIndex | Gets or sets the filter index that will be applied to the OpenFileDialog.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasSelectedFiles | True, if files were selected.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Gets true if the control is focused, otherwise false.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Multiselect | Gets or sets whether it's possible to select more than one file.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedFile | Gets the file that the user has selected.
SelectedFiles | Gets the files that the user has selected.
SelectionBackground | Gets or sets the brush that fills the background of the selected text.
SelectionForeground | Gets or sets the brush used for the selected text in the C1FilePicker.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1FilePicker.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedFilesChanged | Fires when the SelectedFiles property changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1FilePicker Constructor

[image]

.NET Framework Class Library
C1FilePicker Constructor
C1FilePicker Class See Also
Initializes a new instance of a C1FilePicker.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1FilePicker()
Visual Basic (Declaration)
Public Sub New

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1FilePicker Fields

[image] [image]

.NET Framework Class Library
C1FilePicker Fields
C1FilePicker Class See Also

The C1FilePicker type exposes the following members.

Fields

Name | Description
BrowseContentProperty | Identifies the BrowseContent dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FilterIndexProperty | Identifies the FilterIndex dependency property.
FilterProperty | Identifies the Filter dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MultiselectProperty | Identifies the Multiselect dependency property.
SelectedFileProperty | Identifies the SelectedFile dependency property.
SelectedFilesProperty | Identifies the SelectedFiles dependency property.
SelectionBackgroundProperty | Identifies the SelectionBackground dependency property.
SelectionForegroundProperty | Identifies the SelectionForeground dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

See Also

C1FilePicker Class
C1.Silverlight Namespace


BrowseContentProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.BrowseContentProperty Field
C1FilePicker Class See Also
Identifies the BrowseContent dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty BrowseContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly BrowseContentProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.DisabledStyleProperty Field
C1FilePicker Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


FilterIndexProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.FilterIndexProperty Field
C1FilePicker Class See Also
Identifies the FilterIndex dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FilterIndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly FilterIndexProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


FilterProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.FilterProperty Field
C1FilePicker Class See Also
Identifies the Filter dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FilterProperty
Visual Basic (Declaration)
Public Shared ReadOnly FilterProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.FocusStyleProperty Field
C1FilePicker Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.IsFocusedProperty Field
C1FilePicker Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.IsMouseOverProperty Field
C1FilePicker Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


MultiselectProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.MultiselectProperty Field
C1FilePicker Class See Also
Identifies the Multiselect dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MultiselectProperty
Visual Basic (Declaration)
Public Shared ReadOnly MultiselectProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectedFileProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.SelectedFileProperty Field
C1FilePicker Class See Also
Identifies the SelectedFile dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedFileProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedFileProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectedFilesProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.SelectedFilesProperty Field
C1FilePicker Class See Also
Identifies the SelectedFiles dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedFilesProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedFilesProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectionBackgroundProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.SelectionBackgroundProperty Field
C1FilePicker Class See Also
Identifies the SelectionBackground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionBackgroundProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectionForegroundProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.SelectionForegroundProperty Field
C1FilePicker Class See Also
Identifies the SelectionForeground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionForegroundProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.TextAlignmentProperty Field
C1FilePicker Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


WatermarkProperty Field

[image]

.NET Framework Class Library
C1FilePicker..::.WatermarkProperty Field
C1FilePicker Class See Also
Identifies the Watermark dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty WatermarkProperty
Visual Basic (Declaration)
Public Shared ReadOnly WatermarkProperty As DependencyProperty

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1FilePicker Methods

[image] [image]

.NET Framework Class Library
C1FilePicker Methods
C1FilePicker Class See Also

The C1FilePicker type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearSelection | Removes the selected files.
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnSelectedFilesChanged | Raises the SelectedFilesChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1FilePicker Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1FilePicker..::.ChangeVisualStateCommon Method
C1FilePicker Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1FilePicker..::.ChangeVisualStateFocus Method
C1FilePicker Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


ClearSelection Method

[image]

.NET Framework Class Library
C1FilePicker..::.ClearSelection Method
C1FilePicker Class See Also
Removes the selected files.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void ClearSelection()
Visual Basic (Declaration)
Public Sub ClearSelection

See Also

C1FilePicker Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1FilePicker..::.HitTest Method
C1FilePicker Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1FilePicker Class
C1FilePicker Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1FilePicker..::.OnApplyTemplate Method
C1FilePicker Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1FilePicker Class
C1.Silverlight Namespace


OnSelectedFilesChanged Method

[image]

.NET Framework Class Library
C1FilePicker..::.OnSelectedFilesChanged Method
C1FilePicker Class See Also
Raises the SelectedFilesChanged event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnSelectedFilesChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnSelectedFilesChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1FilePicker Properties

[image] [image]

.NET Framework Class Library
C1FilePicker Properties
C1FilePicker Class See Also

The C1FilePicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
BrowseContent | Gets or sets the content of the Browse button.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
Filter | Gets or sets the filter that will be applied to the OpenFileDialog.
FilterIndex | Gets or sets the filter index that will be applied to the OpenFileDialog.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasSelectedFiles | True, if files were selected.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Gets true if the control is focused, otherwise false.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Multiselect | Gets or sets whether it's possible to select more than one file.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedFile | Gets the file that the user has selected.
SelectedFiles | Gets the files that the user has selected.
SelectionBackground | Gets or sets the brush that fills the background of the selected text.
SelectionForeground | Gets or sets the brush used for the selected text in the C1FilePicker.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1FilePicker.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content.
Width | (Inherited from FrameworkElement.)

See Also

C1FilePicker Class
C1.Silverlight Namespace


BrowseContent Property

[image]

.NET Framework Class Library
C1FilePicker..::.BrowseContent Property
C1FilePicker Class See Also
Gets or sets the content of the Browse button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object BrowseContent { get; set; }
Visual Basic (Declaration)
Public Property BrowseContent As Object

See Also

C1FilePicker Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1FilePicker..::.DisabledStyle Property
C1FilePicker Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1FilePicker Class
C1.Silverlight Namespace


Filter Property

[image]

.NET Framework Class Library
C1FilePicker..::.Filter Property
C1FilePicker Class See Also
Gets or sets the filter that will be applied to the OpenFileDialog.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As String

See Also

C1FilePicker Class
C1.Silverlight Namespace


FilterIndex Property

[image]

.NET Framework Class Library
C1FilePicker..::.FilterIndex Property
C1FilePicker Class See Also
Gets or sets the filter index that will be applied to the OpenFileDialog.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int FilterIndex { get; set; }
Visual Basic (Declaration)
Public Property FilterIndex As Integer

See Also

C1FilePicker Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1FilePicker..::.FocusStyle Property
C1FilePicker Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1FilePicker Class
C1.Silverlight Namespace


HasSelectedFiles Property

[image]

.NET Framework Class Library
C1FilePicker..::.HasSelectedFiles Property
C1FilePicker Class See Also
True, if files were selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool HasSelectedFiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasSelectedFiles As Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1FilePicker..::.IsFocused Property
C1FilePicker Class See Also
Gets true if the control is focused, otherwise false.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; private set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1FilePicker..::.IsMouseOver Property
C1FilePicker Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


Multiselect Property

[image]

.NET Framework Class Library
C1FilePicker..::.Multiselect Property
C1FilePicker Class See Also
Gets or sets whether it's possible to select more than one file.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool Multiselect { get; set; }
Visual Basic (Declaration)
Public Property Multiselect As Boolean

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectedFile Property

[image]

.NET Framework Class Library
C1FilePicker..::.SelectedFile Property
C1FilePicker Class See Also
Gets the file that the user has selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public FileInfo SelectedFile { get; set; }
Visual Basic (Declaration)
Public Property SelectedFile As FileInfo

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectedFiles Property

[image]

.NET Framework Class Library
C1FilePicker..::.SelectedFiles Property
C1FilePicker Class See Also
Gets the files that the user has selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IEnumerable<FileInfo> SelectedFiles { get; set; }
Visual Basic (Declaration)
Public Property SelectedFiles As IEnumerable(Of FileInfo)

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectionBackground Property

[image]

.NET Framework Class Library
C1FilePicker..::.SelectionBackground Property
C1FilePicker Class See Also
Gets or sets the brush that fills the background of the selected text.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush SelectionBackground { get; set; }
Visual Basic (Declaration)
Public Property SelectionBackground As Brush

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectionForeground Property

[image]

.NET Framework Class Library
C1FilePicker..::.SelectionForeground Property
C1FilePicker Class See Also
Gets or sets the brush used for the selected text in the C1FilePicker.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush SelectionForeground { get; set; }
Visual Basic (Declaration)
Public Property SelectionForeground As Brush

See Also

C1FilePicker Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1FilePicker..::.TextAlignment Property
C1FilePicker Class See Also
Gets or sets how the text should be aligned in the C1FilePicker.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1FilePicker Class
C1.Silverlight Namespace


Watermark Property

[image]

.NET Framework Class Library
C1FilePicker..::.Watermark Property
C1FilePicker Class See Also
Gets or sets the watermark content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Watermark { get; set; }
Visual Basic (Declaration)
Public Property Watermark As Object

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1FilePicker Events

[image] [image]

.NET Framework Class Library
C1FilePicker Events
C1FilePicker Class See Also

The C1FilePicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedFilesChanged | Fires when the SelectedFiles property changes.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1FilePicker Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1FilePicker..::.IsMouseOverChanged Event
C1FilePicker Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1FilePicker Class
C1.Silverlight Namespace


SelectedFilesChanged Event

[image]

.NET Framework Class Library
C1FilePicker..::.SelectedFilesChanged Event
C1FilePicker Class See Also
Fires when the SelectedFiles property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler SelectedFilesChanged
Visual Basic (Declaration)
Public Event SelectedFilesChanged As EventHandler

See Also

C1FilePicker Class
C1.Silverlight Namespace


C1HeaderedContentControl Class

[image]

.NET Framework Class Library
C1HeaderedContentControl Class
Members See Also
Provides the base implementation for all controls that contain single content and have a header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1HeaderedContentControl : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1HeaderedContentControl _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1HeaderedContentControl
C1.Silverlight..::.C1DropDown
C1.Silverlight..::.C1Window
C1.Silverlight.Extended..::.C1Expander

See Also

C1HeaderedContentControl Members
C1.Silverlight Namespace


C1HeaderedContentControl Members

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl Members
C1HeaderedContentControl Class Constructors Methods Fields Properties Events See Also

The C1HeaderedContentControl type exposes the following members.

Constructors

Name | Description
C1HeaderedContentControl | Initializes a new instance of a C1HeaderedContentControl.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderFontFamilyProperty | Identifies the HeaderFontFamily dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderFontStretchProperty | Identifies the HeaderFontStretch dependency property.
HeaderFontStyleProperty | Identifies the HeaderFontStyle dependency property.
HeaderFontWeightProperty | Identifies the HeaderFontWeight dependency property.
HeaderForegroundProperty | Identifies the HeaderForeground dependency property.
HeaderHorizontalContentAlignmentProperty | Identifies the HeaderHorizontalContentAlignment dependency property.
HeaderPaddingProperty | Identifies the HeaderPadding dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HeaderTextAlignmentProperty | Identifies the HeaderTextAlignment dependency property.
HeaderTextDecorationsProperty | Identifies the HeaderTextDecorations dependency property.
HeaderTextWrappingProperty | Identifies the HeaderTextWrapping dependency property.
HeaderVerticalContentAlignmentProperty | Identifies the HeaderVerticalContentAlignment dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control.
HeaderBackground | Gets or sets the background brush of the header.
HeaderFontFamily | Gets or sets the font family of the header.
HeaderFontSize | Gets or sets the font size of the header.
HeaderFontStretch | Gets or sets the font stretch of the header.
HeaderFontStyle | Gets or sets the font style of the header.
HeaderFontWeight | Gets or sets the font weight of the header.
HeaderForeground | Gets or sets the foreground brush of the header.
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header.
HeaderPadding | Gets or sets the padding of the header.
HeaderTemplate | Gets or sets the data template used to display the header.
HeaderTextAlignment | Gets or sets the text alignment of the header.
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text.
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped.
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HeaderedContentControl Constructor

[image]

.NET Framework Class Library
C1HeaderedContentControl Constructor
C1HeaderedContentControl Class See Also
Initializes a new instance of a C1HeaderedContentControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1HeaderedContentControl()
Visual Basic (Declaration)
Public Sub New

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HeaderedContentControl Fields

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl Fields
C1HeaderedContentControl Class See Also

The C1HeaderedContentControl type exposes the following members.

Fields

Name | Description
HeaderBackgroundProperty | Identifies the HeaderBackground dependency property.
HeaderFontFamilyProperty | Identifies the HeaderFontFamily dependency property.
HeaderFontSizeProperty | Identifies the HeaderFontSize dependency property.
HeaderFontStretchProperty | Identifies the HeaderFontStretch dependency property.
HeaderFontStyleProperty | Identifies the HeaderFontStyle dependency property.
HeaderFontWeightProperty | Identifies the HeaderFontWeight dependency property.
HeaderForegroundProperty | Identifies the HeaderForeground dependency property.
HeaderHorizontalContentAlignmentProperty | Identifies the HeaderHorizontalContentAlignment dependency property.
HeaderPaddingProperty | Identifies the HeaderPadding dependency property.
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.
HeaderTextAlignmentProperty | Identifies the HeaderTextAlignment dependency property.
HeaderTextDecorationsProperty | Identifies the HeaderTextDecorations dependency property.
HeaderTextWrappingProperty | Identifies the HeaderTextWrapping dependency property.
HeaderVerticalContentAlignmentProperty | Identifies the HeaderVerticalContentAlignment dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderBackgroundProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderBackgroundProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderBackground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderBackgroundProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontFamilyProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontFamilyProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderFontFamily dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderFontFamilyProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderFontFamilyProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontSizeProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontSizeProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderFontSize dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderFontSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderFontSizeProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontStretchProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontStretchProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderFontStretch dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderFontStretchProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderFontStretchProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontStyleProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontStyleProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderFontStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderFontStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderFontStyleProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontWeightProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontWeightProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderFontWeight dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderFontWeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderFontWeightProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderForegroundProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderForegroundProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderForeground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderForegroundProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderHorizontalContentAlignmentProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderHorizontalContentAlignmentProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderHorizontalContentAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderHorizontalContentAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderHorizontalContentAlignmentProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderPaddingProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderPaddingProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderPadding dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderPaddingProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderPaddingProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderProperty Field
C1HeaderedContentControl Class See Also
Identifies the Header dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTemplateProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTemplateProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderTemplate dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextAlignmentProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextAlignmentProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderTextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderTextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTextAlignmentProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextDecorationsProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextDecorationsProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderTextDecorations dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderTextDecorationsProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTextDecorationsProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextWrappingProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextWrappingProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderTextWrapping dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderTextWrappingProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTextWrappingProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderVerticalContentAlignmentProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderVerticalContentAlignmentProperty Field
C1HeaderedContentControl Class See Also
Identifies the HeaderVerticalContentAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderVerticalContentAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderVerticalContentAlignmentProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.IsMouseOverProperty Field
C1HeaderedContentControl Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HeaderedContentControl Methods

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl Methods
C1HeaderedContentControl Class See Also

The C1HeaderedContentControl type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.ChangeVisualStateCommon Method
C1HeaderedContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl..::.HitTest Method
C1HeaderedContentControl Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1HeaderedContentControl Class
C1HeaderedContentControl Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.OnApplyTemplate Method
C1HeaderedContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HeaderedContentControl Properties

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl Properties
C1HeaderedContentControl Class See Also

The C1HeaderedContentControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control.
HeaderBackground | Gets or sets the background brush of the header.
HeaderFontFamily | Gets or sets the font family of the header.
HeaderFontSize | Gets or sets the font size of the header.
HeaderFontStretch | Gets or sets the font stretch of the header.
HeaderFontStyle | Gets or sets the font style of the header.
HeaderFontWeight | Gets or sets the font weight of the header.
HeaderForeground | Gets or sets the foreground brush of the header.
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header.
HeaderPadding | Gets or sets the padding of the header.
HeaderTemplate | Gets or sets the data template used to display the header.
HeaderTextAlignment | Gets or sets the text alignment of the header.
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text.
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped.
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


Header Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.Header Property
C1HeaderedContentControl Class See Also
Gets or sets the header of this control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Header { get; set; }
Visual Basic (Declaration)
Public Property Header As Object

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderBackground Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderBackground Property
C1HeaderedContentControl Class See Also
Gets or sets the background brush of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush HeaderBackground { get; set; }
Visual Basic (Declaration)
Public Property HeaderBackground As Brush

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontFamily Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontFamily Property
C1HeaderedContentControl Class See Also
Gets or sets the font family of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public FontFamily HeaderFontFamily { get; set; }
Visual Basic (Declaration)
Public Property HeaderFontFamily As FontFamily

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontSize Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontSize Property
C1HeaderedContentControl Class See Also
Gets or sets the font size of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double HeaderFontSize { get; set; }
Visual Basic (Declaration)
Public Property HeaderFontSize As Double

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontStretch Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontStretch Property
C1HeaderedContentControl Class See Also
Gets or sets the font stretch of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public FontStretch HeaderFontStretch { get; set; }
Visual Basic (Declaration)
Public Property HeaderFontStretch As FontStretch

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontStyle Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontStyle Property
C1HeaderedContentControl Class See Also
Gets or sets the font style of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public FontStyle HeaderFontStyle { get; set; }
Visual Basic (Declaration)
Public Property HeaderFontStyle As FontStyle

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderFontWeight Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderFontWeight Property
C1HeaderedContentControl Class See Also
Gets or sets the font weight of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public FontWeight HeaderFontWeight { get; set; }
Visual Basic (Declaration)
Public Property HeaderFontWeight As FontWeight

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderForeground Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderForeground Property
C1HeaderedContentControl Class See Also
Gets or sets the foreground brush of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush HeaderForeground { get; set; }
Visual Basic (Declaration)
Public Property HeaderForeground As Brush

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderHorizontalContentAlignment Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderHorizontalContentAlignment Property
C1HeaderedContentControl Class See Also
Gets or sets the HorizontalContentAlignment of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public HorizontalAlignment HeaderHorizontalContentAlignment { get; set; }
Visual Basic (Declaration)
Public Property HeaderHorizontalContentAlignment As HorizontalAlignment

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderPadding Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderPadding Property
C1HeaderedContentControl Class See Also
Gets or sets the padding of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Thickness HeaderPadding { get; set; }
Visual Basic (Declaration)
Public Property HeaderPadding As Thickness

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTemplate Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTemplate Property
C1HeaderedContentControl Class See Also
Gets or sets the data template used to display the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DataTemplate HeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property HeaderTemplate As DataTemplate

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextAlignment Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextAlignment Property
C1HeaderedContentControl Class See Also
Gets or sets the text alignment of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment HeaderTextAlignment { get; set; }
Visual Basic (Declaration)
Public Property HeaderTextAlignment As TextAlignment

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextDecorations Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextDecorations Property
C1HeaderedContentControl Class See Also
Gets or sets a TextDecorationCollection that contains the effects to apply to the header text.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextDecorationCollection HeaderTextDecorations { get; set; }
Visual Basic (Declaration)
Public Property HeaderTextDecorations As TextDecorationCollection

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderTextWrapping Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderTextWrapping Property
C1HeaderedContentControl Class See Also
Gets or sets a value that indicates how any header text should be wrapped.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextWrapping HeaderTextWrapping { get; set; }
Visual Basic (Declaration)
Public Property HeaderTextWrapping As TextWrapping

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


HeaderVerticalContentAlignment Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.HeaderVerticalContentAlignment Property
C1HeaderedContentControl Class See Also
Gets or sets the VerticalContentAlignment of the header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public VerticalAlignment HeaderVerticalContentAlignment { get; set; }
Visual Basic (Declaration)
Public Property HeaderVerticalContentAlignment As VerticalAlignment

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.IsMouseOver Property
C1HeaderedContentControl Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HeaderedContentControl Events

[image] [image]

.NET Framework Class Library
C1HeaderedContentControl Events
C1HeaderedContentControl Class See Also

The C1HeaderedContentControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1HeaderedContentControl..::.IsMouseOverChanged Event
C1HeaderedContentControl Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1HeaderedContentControl Class
C1.Silverlight Namespace


C1HierarchicalDataTemplate Class

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate Class
Members See Also
Represents a DataTemplate that supports C1HierarchicalPresenter, such as TreeViewItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1HierarchicalDataTemplate : DataTemplate
Visual Basic (Declaration)
Public Class C1HierarchicalDataTemplate _
    Inherits DataTemplate

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.FrameworkTemplate
System.Windows..::.DataTemplate
C1.Silverlight..::.C1HierarchicalDataTemplate

See Also

C1HierarchicalDataTemplate Members
C1.Silverlight Namespace


C1HierarchicalDataTemplate Members

[image] [image]

.NET Framework Class Library
C1HierarchicalDataTemplate Members
C1HierarchicalDataTemplate Class Constructors Methods Fields Properties See Also

The C1HierarchicalDataTemplate type exposes the following members.

Constructors

Name | Description
C1HierarchicalDataTemplate |

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
LoadContent | (Inherited from DataTemplate.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ItemsSourceProperty | Identifies the ItemsSource dependency property.
ItemTemplateProperty | Identifies the ItemTemplate dependency property.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
ItemsSource | Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.
ItemTemplate | Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated C1HierarchicalPresenter (such as a TreeViewItem), to indicate how to display items from the next level in the data hierarchy.

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


C1HierarchicalDataTemplate Constructor

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate Constructor
C1HierarchicalDataTemplate Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1HierarchicalDataTemplate()
Visual Basic (Declaration)
Public Sub New

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


C1HierarchicalDataTemplate Fields

[image] [image]

.NET Framework Class Library
C1HierarchicalDataTemplate Fields
C1HierarchicalDataTemplate Class See Also

The C1HierarchicalDataTemplate type exposes the following members.

Fields

Name | Description
ItemsSourceProperty | Identifies the ItemsSource dependency property.
ItemTemplateProperty | Identifies the ItemTemplate dependency property.

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


ItemsSourceProperty Field

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate..::.ItemsSourceProperty Field
C1HierarchicalDataTemplate Class See Also
Identifies the ItemsSource dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


ItemTemplateProperty Field

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate..::.ItemTemplateProperty Field
C1HierarchicalDataTemplate Class See Also
Identifies the ItemTemplate dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


C1HierarchicalDataTemplate Methods

[image] [image]

.NET Framework Class Library
C1HierarchicalDataTemplate Methods
C1HierarchicalDataTemplate Class See Also

The C1HierarchicalDataTemplate type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
LoadContent | (Inherited from DataTemplate.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


C1HierarchicalDataTemplate Properties

[image] [image]

.NET Framework Class Library
C1HierarchicalDataTemplate Properties
C1HierarchicalDataTemplate Class See Also

The C1HierarchicalDataTemplate type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
ItemsSource | Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.
ItemTemplate | Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated C1HierarchicalPresenter (such as a TreeViewItem), to indicate how to display items from the next level in the data hierarchy.

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


ItemsSource Property

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate..::.ItemsSource Property
C1HierarchicalDataTemplate Class See Also
Gets or sets the binding for this data template, which indicates where to find the collection that represents the next level in the data hierarchy.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Binding ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As Binding

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


ItemTemplate Property

[image]

.NET Framework Class Library
C1HierarchicalDataTemplate..::.ItemTemplate Property
C1HierarchicalDataTemplate Class See Also
Gets or sets the DataTemplate to apply to the ItemTemplate property on a generated C1HierarchicalPresenter (such as a TreeViewItem), to indicate how to display items from the next level in the data hierarchy.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DataTemplate ItemTemplate { get; set; }
Visual Basic (Declaration)
Public Property ItemTemplate As DataTemplate

See Also

C1HierarchicalDataTemplate Class
C1.Silverlight Namespace


C1HierarchicalPresenter Class

[image]

.NET Framework Class Library
C1HierarchicalPresenter Class
Members See Also
Represents a control that contains multiple items and has a header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1HierarchicalPresenter : C1ItemsControl
Visual Basic (Declaration)
Public Class C1HierarchicalPresenter _
    Inherits C1ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1HierarchicalPresenter
C1.Silverlight..::.C1TreeView
C1.Silverlight..::.C1TreeViewItem

See Also

C1HierarchicalPresenter Members
C1.Silverlight Namespace


C1HierarchicalPresenter Members

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter Members
C1HierarchicalPresenter Class Constructors Methods Fields Properties Events See Also

The C1HierarchicalPresenter type exposes the following members.

Constructors

Name | Description
C1HierarchicalPresenter | Initializes a new instance of a C1HierarchicalPresenter.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element.
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from C1ItemsControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Inherited from C1ItemsControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control.
HeaderTemplate | Gets or sets the template used to display the contents of the control's header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentCollection | Gets the items collection of this element's parent.
ParentItemsSource | Returns this element's parent ItemsSource Property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HierarchicalPresenter Constructor

[image]

.NET Framework Class Library
C1HierarchicalPresenter Constructor
C1HierarchicalPresenter Class See Also
Initializes a new instance of a C1HierarchicalPresenter.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1HierarchicalPresenter()
Visual Basic (Declaration)
Public Sub New

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HierarchicalPresenter Fields

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter Fields
C1HierarchicalPresenter Class See Also

The C1HierarchicalPresenter type exposes the following members.

Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
HeaderTemplateProperty | Identifies the HeaderTemplate dependency property.

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


HeaderProperty Field

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.HeaderProperty Field
C1HierarchicalPresenter Class See Also
Identifies the Header dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


HeaderTemplateProperty Field

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.HeaderTemplateProperty Field
C1HierarchicalPresenter Class See Also
Identifies the HeaderTemplate dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderTemplateProperty As DependencyProperty

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HierarchicalPresenter Methods

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter Methods
C1HierarchicalPresenter Class See Also

The C1HierarchicalPresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element.
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from C1ItemsControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Inherited from C1ItemsControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.GetContainerForItemOverride Method
C1HierarchicalPresenter Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter..::.HitTest Method
C1HierarchicalPresenter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1HierarchicalPresenter Class
C1HierarchicalPresenter Members
C1.Silverlight Namespace


InitializeItem Method

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.InitializeItem Method
C1HierarchicalPresenter Class See Also
Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void InitializeItem(
    C1HierarchicalPresenter rootPresenter
)
Visual Basic (Declaration)
Public Sub InitializeItem ( _
    rootPresenter As C1HierarchicalPresenter _
)

Parameters

rootPresenter
Type: C1.Silverlight..::.C1HierarchicalPresenter
The C1HierarchicalPresenter whose this item belongs to.

Remarks

This method should be invoked only when we want to force the initialization of an item before it gets visible. Otherwise the item will be initialized automatically before becoming visible.

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


IsAncestorOf Method

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.IsAncestorOf Method
C1HierarchicalPresenter Class See Also
Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsAncestorOf(
    C1HierarchicalPresenter descendant
)
Visual Basic (Declaration)
Public Function IsAncestorOf ( _
    descendant As C1HierarchicalPresenter _
) As Boolean

Parameters

descendant
Type: C1.Silverlight..::.C1HierarchicalPresenter
The descendant C1HierarchicalPresenter.

Return Value

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.IsItemItsOwnContainerOverride Method
C1HierarchicalPresenter Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HierarchicalPresenter Properties

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter Properties
C1HierarchicalPresenter Class See Also

The C1HierarchicalPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control.
HeaderTemplate | Gets or sets the template used to display the contents of the control's header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentCollection | Gets the items collection of this element's parent.
ParentItemsSource | Returns this element's parent ItemsSource Property.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


Header Property

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.Header Property
C1HierarchicalPresenter Class See Also
Gets or sets the item that labels the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Header { get; set; }
Visual Basic (Declaration)
Public Property Header As Object

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


HeaderTemplate Property

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.HeaderTemplate Property
C1HierarchicalPresenter Class See Also
Gets or sets the template used to display the contents of the control's header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DataTemplate HeaderTemplate { get; set; }
Visual Basic (Declaration)
Public Property HeaderTemplate As DataTemplate

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


ItemConverter Property

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.ItemConverter Property
C1HierarchicalPresenter Class See Also
The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TypeConverter ItemConverter { internal get; set; }
Visual Basic (Declaration)
Public Property ItemConverter As TypeConverter

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


ParentCollection Property

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.ParentCollection Property
C1HierarchicalPresenter Class See Also
Gets the items collection of this element's parent.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IList ParentCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentCollection As IList

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


ParentItemsSource Property

[image]

.NET Framework Class Library
C1HierarchicalPresenter..::.ParentItemsSource Property
C1HierarchicalPresenter Class See Also
Returns this element's parent ItemsSource Property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IEnumerable ParentItemsSource { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentItemsSource As IEnumerable

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HierarchicalPresenter Events

[image] [image]

.NET Framework Class Library
C1HierarchicalPresenter Events
C1HierarchicalPresenter Class See Also

The C1HierarchicalPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HierarchicalPresenter Class
C1.Silverlight Namespace


C1HyperPanel Class

[image]

.NET Framework Class Library
C1HyperPanel Class
Members See Also
Arranges child elements in a stack and applies a dynamic zoom effect to the elements near the mouse.
Arranges child elements in a stack and applies a dynamic zoom effect to the elements near the mouse.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1HyperPanel : Panel
Visual Basic (Declaration)
Public Class C1HyperPanel _
    Inherits Panel

Remarks

The C1HyperPanel is similar to a StackPanel, except is applies a dynamic zoom effect as the user moves the mouse over the panel. Child elements near the mouse appear in their normal size, and elements away from the mouse are scaled down and appear smaller.

Use the Distribution and MinElementScale properties to control the intensity of the zoom effect.

Use the ApplyOpacity property to make elements far from the mouse appear faded.

Use VerticalAlignment and HorizontalAlignment properties on the child elements to determine how they should be aligned within the C1HyperPanel.

In order to apply the zooming effect efficiently, the C1HyperPanel takes over the RenderTransform property of its child elements. If you want to apply your own transforms to the child elements, place them in another panel before adding them to the C1HyperPanel.

Note that some native Silverlight elements (such as the Button control) do not always auto-size correctly. You should set the width and height of these elements explicitly before adding them to the C1HyperPanel.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight..::.C1HyperPanel

See Also

C1HyperPanel Members
C1.Silverlight Namespace


C1HyperPanel Members

[image] [image]

.NET Framework Class Library
C1HyperPanel Members
C1HyperPanel Class Constructors Methods Fields Properties Events See Also

The C1HyperPanel type exposes the following members.

Constructors

Name | Description
C1HyperPanel | Initializes a new instance of a C1HyperPanel.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | Positions child elements and determines a size for the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size in layout required for child elements and determines a size for the element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ApplyOpacityProperty | Identifies the ApplyOpacity dependency property.
CenterProperty | Identifies the Center dependency property.
DistributionProperty | Identifies the Distribution dependency property.
HorizontalContentAlignmentProperty | Identifies the HorizontalContentAlignment dependency property.
MinElementScaleProperty | Identifies the MinElementScale dependency property.
OrientationProperty | Identifies the Orientation dependency property.
VerticalContentAlignmentProperty | Identifies the VerticalContentAlignment dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
ApplyOpacity | Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.
Background | (Inherited from Panel.)
Center | Gets or sets the center of the C1HyperPanel as a percentage of the control size.
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Distribution | Gets or sets a value between 0.1 and 1.0 that controls how much zooming should be applied to elements near the center.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | Gets or sets the horizontal alignment of the panel's content.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinElementScale | Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | Gets or sets the vertical alignment of the panel's content.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1HyperPanel Constructor

[image]

.NET Framework Class Library
C1HyperPanel Constructor
C1HyperPanel Class See Also
Initializes a new instance of a C1HyperPanel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1HyperPanel()
Visual Basic (Declaration)
Public Sub New

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1HyperPanel Fields

[image] [image]

.NET Framework Class Library
C1HyperPanel Fields
C1HyperPanel Class See Also

The C1HyperPanel type exposes the following members.

Fields

Name | Description
ApplyOpacityProperty | Identifies the ApplyOpacity dependency property.
CenterProperty | Identifies the Center dependency property.
DistributionProperty | Identifies the Distribution dependency property.
HorizontalContentAlignmentProperty | Identifies the HorizontalContentAlignment dependency property.
MinElementScaleProperty | Identifies the MinElementScale dependency property.
OrientationProperty | Identifies the Orientation dependency property.
VerticalContentAlignmentProperty | Identifies the VerticalContentAlignment dependency property.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


ApplyOpacityProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.ApplyOpacityProperty Field
C1HyperPanel Class See Also
Identifies the ApplyOpacity dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ApplyOpacityProperty
Visual Basic (Declaration)
Public Shared ReadOnly ApplyOpacityProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


CenterProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.CenterProperty Field
C1HyperPanel Class See Also
Identifies the Center dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty CenterProperty
Visual Basic (Declaration)
Public Shared ReadOnly CenterProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


DistributionProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.DistributionProperty Field
C1HyperPanel Class See Also
Identifies the Distribution dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DistributionProperty
Visual Basic (Declaration)
Public Shared ReadOnly DistributionProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


HorizontalContentAlignmentProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.HorizontalContentAlignmentProperty Field
C1HyperPanel Class See Also
Identifies the HorizontalContentAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HorizontalContentAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalContentAlignmentProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


MinElementScaleProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.MinElementScaleProperty Field
C1HyperPanel Class See Also
Identifies the MinElementScale dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MinElementScaleProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinElementScaleProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


OrientationProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.OrientationProperty Field
C1HyperPanel Class See Also
Identifies the Orientation dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


VerticalContentAlignmentProperty Field

[image]

.NET Framework Class Library
C1HyperPanel..::.VerticalContentAlignmentProperty Field
C1HyperPanel Class See Also
Identifies the VerticalContentAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty VerticalContentAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalContentAlignmentProperty As DependencyProperty

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1HyperPanel Methods

[image] [image]

.NET Framework Class Library
C1HyperPanel Methods
C1HyperPanel Class See Also

The C1HyperPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | Positions child elements and determines a size for the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size in layout required for child elements and determines a size for the element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1HyperPanel Class
C1.Silverlight Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1HyperPanel..::.ArrangeOverride Method
C1HyperPanel Class See Also
Positions child elements and determines a size for the element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1HyperPanel..::.HitTest Method
C1HyperPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1HyperPanel Class
C1HyperPanel Members
C1.Silverlight Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1HyperPanel..::.MeasureOverride Method
C1HyperPanel Class See Also
Measures the size in layout required for child elements and determines a size for the element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1HyperPanel Properties

[image] [image]

.NET Framework Class Library
C1HyperPanel Properties
C1HyperPanel Class See Also

The C1HyperPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
ApplyOpacity | Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.
Background | (Inherited from Panel.)
Center | Gets or sets the center of the C1HyperPanel as a percentage of the control size.
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Distribution | Gets or sets a value between 0.1 and 1.0 that controls how much zooming should be applied to elements near the center.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | Gets or sets the horizontal alignment of the panel's content.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinElementScale | Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | Gets or sets the vertical alignment of the panel's content.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1HyperPanel Class
C1.Silverlight Namespace


ApplyOpacity Property

[image]

.NET Framework Class Library
C1HyperPanel..::.ApplyOpacity Property
C1HyperPanel Class See Also
Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool ApplyOpacity { get; set; }
Visual Basic (Declaration)
Public Property ApplyOpacity As Boolean

See Also

C1HyperPanel Class
C1.Silverlight Namespace


Center Property

[image]

.NET Framework Class Library
C1HyperPanel..::.Center Property
C1HyperPanel Class See Also
Gets or sets the center of the C1HyperPanel as a percentage of the control size.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Double

Remarks

Elements near the center appear larger than the others.

This value is updated automatically as the mouse moves.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


Distribution Property

[image]

.NET Framework Class Library
C1HyperPanel..::.Distribution Property
C1HyperPanel Class See Also
Gets or sets a value between 0.1 and 1.0 that controls how much zooming should be applied to elements near the center.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Distribution { get; set; }
Visual Basic (Declaration)
Public Property Distribution As Double

Remarks

Small values increase the zoom effect. Elements far from the mouse appear much smaller than elements near the mouse.

Large values decrease the zoom effect. Elements far from the mouse appear only slightly smaller than elements near the mouse.

You can limit the amount by which elements far from the mouse are zoomed out by setting the MinElementScale.For example, setting MinElementScale to 0.5 prevents any child elements from being reduced to less than half their original size.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


HorizontalContentAlignment Property

[image]

.NET Framework Class Library
C1HyperPanel..::.HorizontalContentAlignment Property
C1HyperPanel Class See Also
Gets or sets the horizontal alignment of the panel's content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; set; }
Visual Basic (Declaration)
Public Property HorizontalContentAlignment As HorizontalAlignment

See Also

C1HyperPanel Class
C1.Silverlight Namespace


MinElementScale Property

[image]

.NET Framework Class Library
C1HyperPanel..::.MinElementScale Property
C1HyperPanel Class See Also
Gets or sets a value between zero and one that determines the minimum scale to be applied to elements when they are away from the center.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double MinElementScale { get; set; }
Visual Basic (Declaration)
Public Property MinElementScale As Double

Remarks

This property is useful when the Distribution property is set to small values, and you want to prevent child elements from becoming too small when they are away from the mouse.

For example, setting this property to 0.5 prevents any child elements from being reduced to less than half their original size.

See Also

C1HyperPanel Class
C1.Silverlight Namespace


Orientation Property

[image]

.NET Framework Class Library
C1HyperPanel..::.Orientation Property
C1HyperPanel Class See Also
Gets or sets a value that indicates the dimension by which child elements are stacked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation

See Also

C1HyperPanel Class
C1.Silverlight Namespace


VerticalContentAlignment Property

[image]

.NET Framework Class Library
C1HyperPanel..::.VerticalContentAlignment Property
C1HyperPanel Class See Also
Gets or sets the vertical alignment of the panel's content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public VerticalAlignment VerticalContentAlignment { get; set; }
Visual Basic (Declaration)
Public Property VerticalContentAlignment As VerticalAlignment

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1HyperPanel Events

[image] [image]

.NET Framework Class Library
C1HyperPanel Events
C1HyperPanel Class See Also

The C1HyperPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1HyperPanel Class
C1.Silverlight Namespace


C1ItemContainerGenerator Class

[image]

.NET Framework Class Library
C1ItemContainerGenerator Class
Members See Also
Provides some helper methods related to the items and containers of a C1ItemsControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1ItemContainerGenerator
Visual Basic (Declaration)
Public Class C1ItemContainerGenerator

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1ItemContainerGenerator

See Also

C1ItemContainerGenerator Members
C1.Silverlight Namespace


C1ItemContainerGenerator Members

[image] [image]

.NET Framework Class Library
C1ItemContainerGenerator Members
C1ItemContainerGenerator Class Constructors Methods See Also

The C1ItemContainerGenerator type exposes the following members.

Constructors

Name | Description
C1ItemContainerGenerator | Constructor

Methods

Name | Description
ContainerFromIndex | Returns the container element corresponding to the item at the given index within the ItemCollection.
ContainerFromItem | Returns the container element corresponding to the given item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexFromContainer | Returns the index to an item that corresponds to the specified, generated container element.
ItemFromContainer | Returns the item that corresponds to the specified, generated container element.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


C1ItemContainerGenerator Constructor

[image]

.NET Framework Class Library
C1ItemContainerGenerator Constructor
C1ItemContainerGenerator Class See Also
Constructor

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1ItemContainerGenerator(
    C1ItemsControl itemsControl
)
Visual Basic (Declaration)
Public Sub New ( _
    itemsControl As C1ItemsControl _
)

Parameters

itemsControl
Type: C1.Silverlight..::.C1ItemsControl
The C1ItemsControl this C1ItemContainerGenerator will be associated to.

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


C1ItemContainerGenerator Methods

[image] [image]

.NET Framework Class Library
C1ItemContainerGenerator Methods
C1ItemContainerGenerator Class See Also

The C1ItemContainerGenerator type exposes the following members.

Methods

Name | Description
ContainerFromIndex | Returns the container element corresponding to the item at the given index within the ItemCollection.
ContainerFromItem | Returns the container element corresponding to the given item.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexFromContainer | Returns the index to an item that corresponds to the specified, generated container element.
ItemFromContainer | Returns the item that corresponds to the specified, generated container element.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


ContainerFromIndex Method

[image]

.NET Framework Class Library
C1ItemContainerGenerator..::.ContainerFromIndex Method
C1ItemContainerGenerator Class See Also
Returns the container element corresponding to the item at the given index within the ItemCollection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DependencyObject ContainerFromIndex(
    int index
)
Visual Basic (Declaration)
Public Function ContainerFromIndex ( _
    index As Integer _
) As DependencyObject

Parameters

index
Type: System..::.Int32
The index of the desired item.

Return Value

Returns the element corresponding to the item at the given index within the ItemCollection or returns a null reference if the item is not realized.

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


ContainerFromItem Method

[image]

.NET Framework Class Library
C1ItemContainerGenerator..::.ContainerFromItem Method
C1ItemContainerGenerator Class See Also
Returns the container element corresponding to the given item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DependencyObject ContainerFromItem(
    Object item
)
Visual Basic (Declaration)
Public Function ContainerFromItem ( _
    item As Object _
) As DependencyObject

Parameters

item
Type: System..::.Object
The Object item to find the container for.

Return Value

A container element that corresponds to the given item. Returns a null reference if the item does not belong to the item collection, or if a container element has not been generated for it.

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


IndexFromContainer Method

[image]

.NET Framework Class Library
C1ItemContainerGenerator..::.IndexFromContainer Method
C1ItemContainerGenerator Class See Also
Returns the index to an item that corresponds to the specified, generated container element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int IndexFromContainer(
    DependencyObject container
)
Visual Basic (Declaration)
Public Function IndexFromContainer ( _
    container As DependencyObject _
) As Integer

Parameters

container
Type: System.Windows..::.DependencyObject
The container that corresponds to the item to the index to be returned.

Return Value

An index to an item that corresponds to the specified, generated container element.

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


ItemFromContainer Method

[image]

.NET Framework Class Library
C1ItemContainerGenerator..::.ItemFromContainer Method
C1ItemContainerGenerator Class See Also
Returns the item that corresponds to the specified, generated container element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object ItemFromContainer(
    DependencyObject container
)
Visual Basic (Declaration)
Public Function ItemFromContainer ( _
    container As DependencyObject _
) As Object

Parameters

container
Type: System.Windows..::.DependencyObject
The container that corresponds to the item to be returned.

Return Value

The item which corresponds to the specified, generated container element.

See Also

C1ItemContainerGenerator Class
C1.Silverlight Namespace


C1ItemsControl Class

[image]

.NET Framework Class Library
C1ItemsControl Class
Members See Also
Represents a control that can be used to present a collection of items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1ItemsControl : ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1ItemsControl _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1HierarchicalPresenter
C1.Silverlight..::.C1Menu
C1.Silverlight..::.C1MenuItem

See Also

C1ItemsControl Members
C1.Silverlight Namespace


C1ItemsControl Members

[image] [image]

.NET Framework Class Library
C1ItemsControl Members
C1ItemsControl Class Constructors Methods Fields Properties Events See Also

The C1ItemsControl type exposes the following members.

Constructors

Name | Description
C1ItemsControl | Initializes a new instance of a C1ItemsControl.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control.
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item.
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1ItemsControl Constructor

[image]

.NET Framework Class Library
C1ItemsControl Constructor
C1ItemsControl Class See Also
Initializes a new instance of a C1ItemsControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1ItemsControl()
Visual Basic (Declaration)
Public Sub New

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1ItemsControl Fields

[image] [image]

.NET Framework Class Library
C1ItemsControl Fields
C1ItemsControl Class See Also

The C1ItemsControl type exposes the following members.

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ItemContainerStyleProperty | Identifies the ItemContainerStyle dependency property.
ItemContainerStyleSelectorProperty | Identifies the ItemContainerStyleSelector dependency property.
ItemTemplateSelectorProperty | Identifies the ItemTemplateSelector dependency property.

See Also

C1ItemsControl Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ItemsControl..::.IsMouseOverProperty Field
C1ItemsControl Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemContainerStyleProperty Field

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemContainerStyleProperty Field
C1ItemsControl Class See Also
Identifies the ItemContainerStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleProperty As DependencyProperty

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemContainerStyleSelectorProperty Field

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemContainerStyleSelectorProperty Field
C1ItemsControl Class See Also
Identifies the ItemContainerStyleSelector dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemContainerStyleSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemContainerStyleSelectorProperty As DependencyProperty

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemTemplateSelectorProperty Field

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemTemplateSelectorProperty Field
C1ItemsControl Class See Also
Identifies the ItemTemplateSelector dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateSelectorProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateSelectorProperty As DependencyProperty

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1ItemsControl Methods

[image] [image]

.NET Framework Class Library
C1ItemsControl Methods
C1ItemsControl Class See Also

The C1ItemsControl type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ItemsControl..::.ChangeVisualStateCommon Method
C1ItemsControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ItemsControl..::.ClearContainerForItemOverride Method
C1ItemsControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1ItemsControl Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ItemsControl..::.HitTest Method
C1ItemsControl Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ItemsControl Class
C1ItemsControl Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ItemsControl..::.OnApplyTemplate Method
C1ItemsControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ItemsControl Class
C1.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ItemsControl..::.PrepareContainerForItemOverride Method
C1ItemsControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1ItemsControl Properties

[image] [image]

.NET Framework Class Library
C1ItemsControl Properties
C1ItemsControl Class See Also

The C1ItemsControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control.
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item.
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element.
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ItemsControl Class
C1.Silverlight Namespace


HasItems Property

[image]

.NET Framework Class Library
C1ItemsControl..::.HasItems Property
C1ItemsControl Class See Also
Gets a value that indicates whether the ItemsControl contains items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool HasItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasItems As Boolean

See Also

C1ItemsControl Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ItemsControl..::.IsMouseOver Property
C1ItemsControl Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemContainerGenerator Property

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemContainerGenerator Property
C1ItemsControl Class See Also
Gets the C1ItemContainerGenerator that is associated with the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1ItemContainerGenerator ItemContainerGenerator { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemContainerGenerator As C1ItemContainerGenerator

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemContainerStyle Property

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemContainerStyle Property
C1ItemsControl Class See Also
Gets or sets the Style that is applied to the container element generated for each item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style ItemContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ItemContainerStyle As Style

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemContainerStyleSelector Property

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemContainerStyleSelector Property
C1ItemsControl Class See Also
Gets or sets custom style-selection logic for a style that can be applied to each generated container element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1StyleSelector ItemContainerStyleSelector { get; set; }
Visual Basic (Declaration)
Public Property ItemContainerStyleSelector As C1StyleSelector

See Also

C1ItemsControl Class
C1.Silverlight Namespace


ItemTemplateSelector Property

[image]

.NET Framework Class Library
C1ItemsControl..::.ItemTemplateSelector Property
C1ItemsControl Class See Also
Provides a way to choose a DataTemplate based on the data object and the data-bound element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1DataTemplateSelector ItemTemplateSelector { get; set; }
Visual Basic (Declaration)
Public Property ItemTemplateSelector As C1DataTemplateSelector

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1ItemsControl Events

[image] [image]

.NET Framework Class Library
C1ItemsControl Events
C1ItemsControl Class See Also

The C1ItemsControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ItemsControl Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ItemsControl..::.IsMouseOverChanged Event
C1ItemsControl Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ItemsControl Class
C1.Silverlight Namespace


C1MaskedTextBox Class

[image]

.NET Framework Class Library
C1MaskedTextBox Class
Members See Also
Represents a control that uses a mask to prevent users from entering invalid data.
Represents a control that uses a mask to prevent users from entering invalid data.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1MaskedTextBox : C1TextBoxBase
Visual Basic (Declaration)
Public Class C1MaskedTextBox _
    Inherits C1TextBoxBase

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.TextBox
C1.Silverlight..::.C1TextBoxBase
C1.Silverlight..::.C1MaskedTextBox

See Also

C1MaskedTextBox Members
C1.Silverlight Namespace


C1MaskedTextBox Members

[image] [image]

.NET Framework Class Library
C1MaskedTextBox Members
C1MaskedTextBox Class Constructors Methods Fields Properties Events See Also

The C1MaskedTextBox type exposes the following members.

Constructors

Name | Description
C1MaskedTextBox | Initializes a new instance of a C1MaskedTextBox.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from TextBox.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateWatermark | (Inherited from C1TextBoxBase.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from C1TextBoxBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsFocusedChanged | (Overrides C1TextBoxBase..::.OnIsFocusedChanged(Boolean).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
MaskProperty | Identifies the Mask dependency property
PromptCharProperty | Identifies the PromptChar dependency property

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element. (Inherited from C1TextBoxBase.)
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element. (Inherited from C1TextBoxBase.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsFocused | Returns true if the control has the focus. (Inherited from C1TextBoxBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
IsValid | Gets a value that determines whether the control contains a valid entry.
IsWatermarked | Get or sets if the watermark is shown. (Inherited from C1TextBoxBase.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
Mask | Gets or sets the input mask.
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PromptChar | Gets or sets the character used to show spaces where user is supposed to type.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextMaskFormat | Gets or sets a value that determines whether literals and prompt characters are included in the Value property.
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
Value | Gets the formatted content of the control as specified by the TextMaskFormat property.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the content of the watermark. (Inherited from C1TextBoxBase.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1MaskedTextBox Constructor

[image]

.NET Framework Class Library
C1MaskedTextBox Constructor
C1MaskedTextBox Class See Also
Initializes a new instance of a C1MaskedTextBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MaskedTextBox()
Visual Basic (Declaration)
Public Sub New

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1MaskedTextBox Fields

[image] [image]

.NET Framework Class Library
C1MaskedTextBox Fields
C1MaskedTextBox Class See Also

The C1MaskedTextBox type exposes the following members.

Fields

Name | Description
MaskProperty | Identifies the Mask dependency property
PromptCharProperty | Identifies the PromptChar dependency property

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


MaskProperty Field

[image]

.NET Framework Class Library
C1MaskedTextBox..::.MaskProperty Field
C1MaskedTextBox Class See Also
Identifies the Mask dependency property

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MaskProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaskProperty As DependencyProperty

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


PromptCharProperty Field

[image]

.NET Framework Class Library
C1MaskedTextBox..::.PromptCharProperty Field
C1MaskedTextBox Class See Also
Identifies the PromptChar dependency property

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty PromptCharProperty
Visual Basic (Declaration)
Public Shared ReadOnly PromptCharProperty As DependencyProperty

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1MaskedTextBox Methods

[image] [image]

.NET Framework Class Library
C1MaskedTextBox Methods
C1MaskedTextBox Class See Also

The C1MaskedTextBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from TextBox.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateWatermark | (Inherited from C1TextBoxBase.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from C1TextBoxBase.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsFocusedChanged | (Overrides C1TextBoxBase..::.OnIsFocusedChanged(Boolean).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MaskedTextBox..::.HitTest Method
C1MaskedTextBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MaskedTextBox Class
C1MaskedTextBox Members
C1.Silverlight Namespace


OnIsFocusedChanged Method

[image]

.NET Framework Class Library
C1MaskedTextBox..::.OnIsFocusedChanged Method
C1MaskedTextBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnIsFocusedChanged(
    bool oldValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnIsFocusedChanged ( _
    oldValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1MaskedTextBox Properties

[image] [image]

.NET Framework Class Library
C1MaskedTextBox Properties
C1MaskedTextBox Class See Also

The C1MaskedTextBox type exposes the following members.

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element. (Inherited from C1TextBoxBase.)
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element. (Inherited from C1TextBoxBase.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsFocused | Returns true if the control has the focus. (Inherited from C1TextBoxBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
IsValid | Gets a value that determines whether the control contains a valid entry.
IsWatermarked | Get or sets if the watermark is shown. (Inherited from C1TextBoxBase.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
Mask | Gets or sets the input mask.
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PromptChar | Gets or sets the character used to show spaces where user is supposed to type.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextMaskFormat | Gets or sets a value that determines whether literals and prompt characters are included in the Value property.
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
Value | Gets the formatted content of the control as specified by the TextMaskFormat property.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the content of the watermark. (Inherited from C1TextBoxBase.)
Width | (Inherited from FrameworkElement.)

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


IsValid Property

[image]

.NET Framework Class Library
C1MaskedTextBox..::.IsValid Property
C1MaskedTextBox Class See Also
Gets a value that determines whether the control contains a valid entry.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsValid { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsValid As Boolean

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


Mask Property

[image]

.NET Framework Class Library
C1MaskedTextBox..::.Mask Property
C1MaskedTextBox Class See Also
Gets or sets the input mask.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Mask { get; set; }
Visual Basic (Declaration)
Public Property Mask As String

Remarks

The mask consists of a string that determines what class of character is acceptable at each input position.

Valid mask characters are:

0 Digit (0-9)

9 Digit or space

# Digit, space, or sign (+/-)

L Letter

? Letter or space

A Letter or digit

a Letter, digit, or space

& Any character

. Localized decimal symbol

, Localized thousand separator

: Localized time separator

/ Localized date separator

Other characters are treated as literals. They are displayed in the control but cannot be edited.

For example, the mask "000-0000" causes the control to accept only digits at every position except the third, which always contains a dash.

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


PromptChar Property

[image]

.NET Framework Class Library
C1MaskedTextBox..::.PromptChar Property
C1MaskedTextBox Class See Also
Gets or sets the character used to show spaces where user is supposed to type.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public char PromptChar { get; set; }
Visual Basic (Declaration)
Public Property PromptChar As Char

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


TextMaskFormat Property

[image]

.NET Framework Class Library
C1MaskedTextBox..::.TextMaskFormat Property
C1MaskedTextBox Class See Also
Gets or sets a value that determines whether literals and prompt characters are included in the Value property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public MaskFormat TextMaskFormat { get; set; }
Visual Basic (Declaration)
Public Property TextMaskFormat As MaskFormat

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


Value Property

[image]

.NET Framework Class Library
C1MaskedTextBox..::.Value Property
C1MaskedTextBox Class See Also
Gets the formatted content of the control as specified by the TextMaskFormat property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As String

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1MaskedTextBox Events

[image] [image]

.NET Framework Class Library
C1MaskedTextBox Events
C1MaskedTextBox Class See Also

The C1MaskedTextBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

C1MaskedTextBox Class
C1.Silverlight Namespace


C1Menu Class

[image]

.NET Framework Class Library
C1Menu Class
Members See Also
Represents a menu control that enables you to hierarchically organize elements associated with event handlers.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplatePartAttribute(Name = "Root", Type = typeof(Border))]
public class C1Menu : C1ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplatePartAttribute(Name := "Root", Type := GetType(Border))> _
Public Class C1Menu _
    Inherits C1ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1Menu

See Also

C1Menu Members
C1.Silverlight Namespace


C1Menu Members

[image] [image]

.NET Framework Class Library
C1Menu Members
C1Menu Class Constructors Methods Fields Properties Events See Also

The C1Menu type exposes the following members.

Constructors

Name | Description
C1Menu | Initializes a new instance of a C1Menu.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemClicked | Responds to a C1MenuItem clieck action by raising a ItemClicked event.
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
FirstLevelTemplateProperty | Identifies the FirstLevelTemplate dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
MenuOpenDelayProperty | Identifies the MenuOpenDelay dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FirstLevelTemplate | Represents the template to apply to all menu items of the first level.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MenuOpenDelay | Gets or Sets a value (in milliseconds) for the delay used when opening a submenu.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
ItemClicked | Occurs when a C1MenuItem is clicked.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Menu Class
C1.Silverlight Namespace


C1Menu Constructor

[image]

.NET Framework Class Library
C1Menu Constructor
C1Menu Class See Also
Initializes a new instance of a C1Menu.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1Menu()
Visual Basic (Declaration)
Public Sub New

See Also

C1Menu Class
C1.Silverlight Namespace


C1Menu Fields

[image] [image]

.NET Framework Class Library
C1Menu Fields
C1Menu Class See Also

The C1Menu type exposes the following members.

Fields

Name | Description
FirstLevelTemplateProperty | Identifies the FirstLevelTemplate dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
MenuOpenDelayProperty | Identifies the MenuOpenDelay dependency property.

See Also

C1Menu Class
C1.Silverlight Namespace


FirstLevelTemplateProperty Field

[image]

.NET Framework Class Library
C1Menu..::.FirstLevelTemplateProperty Field
C1Menu Class See Also
Identifies the FirstLevelTemplate dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FirstLevelTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly FirstLevelTemplateProperty As DependencyProperty

See Also

C1Menu Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1Menu..::.IsFocusedProperty Field
C1Menu Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1Menu Class
C1.Silverlight Namespace


MenuOpenDelayProperty Field

[image]

.NET Framework Class Library
C1Menu..::.MenuOpenDelayProperty Field
C1Menu Class See Also
Identifies the MenuOpenDelay dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MenuOpenDelayProperty
Visual Basic (Declaration)
Public Shared ReadOnly MenuOpenDelayProperty As DependencyProperty

See Also

C1Menu Class
C1.Silverlight Namespace


C1Menu Methods

[image] [image]

.NET Framework Class Library
C1Menu Methods
C1Menu Class See Also

The C1Menu type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemClicked | Responds to a C1MenuItem clieck action by raising a ItemClicked event.
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Menu Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1Menu..::.ChangeVisualStateFocus Method
C1Menu Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Menu Class
C1.Silverlight Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Menu..::.GetContainerForItemOverride Method
C1Menu Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1Menu Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Menu..::.HitTest Method
C1Menu Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Menu Class
C1Menu Members
C1.Silverlight Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1Menu..::.IsItemItsOwnContainerOverride Method
C1Menu Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1Menu Class
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Menu..::.OnApplyTemplate Method
C1Menu Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Menu Class
C1.Silverlight Namespace


OnItemClicked Method

[image]

.NET Framework Class Library
C1Menu..::.OnItemClicked Method
C1Menu Class See Also
Responds to a C1MenuItem clieck action by raising a ItemClicked event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnItemClicked(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnItemClicked ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for SourcedEventArgs.

See Also

C1Menu Class
C1.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Menu..::.PrepareContainerForItemOverride Method
C1Menu Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1Menu Class
C1.Silverlight Namespace


C1Menu Properties

[image] [image]

.NET Framework Class Library
C1Menu Properties
C1Menu Class See Also

The C1Menu type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FirstLevelTemplate | Represents the template to apply to all menu items of the first level.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MenuOpenDelay | Gets or Sets a value (in milliseconds) for the delay used when opening a submenu.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Menu Class
C1.Silverlight Namespace


FirstLevelTemplate Property

[image]

.NET Framework Class Library
C1Menu..::.FirstLevelTemplate Property
C1Menu Class See Also
Represents the template to apply to all menu items of the first level.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public ControlTemplate FirstLevelTemplate { get; set; }
Visual Basic (Declaration)
Public Property FirstLevelTemplate As ControlTemplate

See Also

C1Menu Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1Menu..::.IsFocused Property
C1Menu Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1Menu Class
C1.Silverlight Namespace


MenuOpenDelay Property

[image]

.NET Framework Class Library
C1Menu..::.MenuOpenDelay Property
C1Menu Class See Also
Gets or Sets a value (in milliseconds) for the delay used when opening a submenu.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int MenuOpenDelay { get; set; }
Visual Basic (Declaration)
Public Property MenuOpenDelay As Integer

See Also

C1Menu Class
C1.Silverlight Namespace


C1Menu Events

[image] [image]

.NET Framework Class Library
C1Menu Events
C1Menu Class See Also

The C1Menu type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
ItemClicked | Occurs when a C1MenuItem is clicked.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Menu Class
C1.Silverlight Namespace


ItemClicked Event

[image]

.NET Framework Class Library
C1Menu..::.ItemClicked Event
C1Menu Class See Also
Occurs when a C1MenuItem is clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> ItemClicked
Visual Basic (Declaration)
Public Event ItemClicked As EventHandler(Of SourcedEventArgs)

See Also

C1Menu Class
C1.Silverlight Namespace


C1MenuItem Class

[image]

.NET Framework Class Library
C1MenuItem Class
Members See Also
Represents a selectable item inside a C1Menu control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Closed", GroupName = "OpenStates")]
[TemplatePartAttribute(Name = "ExpandIcon", Type = typeof(Path))]
[TemplatePartAttribute(Name = "MenuIcon", Type = typeof(ContentControl))]
[TemplatePartAttribute(Name = "CheckIcon", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "SubItemsPopup", Type = typeof(Popup))]
[TemplatePartAttribute(Name = "SubItemsPresenter", Type = typeof(ItemsPresenter))]
[TemplateVisualStateAttribute(Name = "Open", GroupName = "OpenStates")]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Highlighted", GroupName = "HighlightedStates")]
[TemplateVisualStateAttribute(Name = "NonHighlighted", GroupName = "HighlightedStates")]
[TemplatePartAttribute(Name = "HeaderPanel", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "Header", Type = typeof(ContentControl))]
public class C1MenuItem : C1ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Closed", GroupName := "OpenStates")> _
<TemplatePartAttribute(Name := "ExpandIcon", Type := GetType(Path))> _
<TemplatePartAttribute(Name := "MenuIcon", Type := GetType(ContentControl))> _
<TemplatePartAttribute(Name := "CheckIcon", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "SubItemsPopup", Type := GetType(Popup))> _
<TemplatePartAttribute(Name := "SubItemsPresenter", Type := GetType(ItemsPresenter))> _
<TemplateVisualStateAttribute(Name := "Open", GroupName := "OpenStates")> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Highlighted", GroupName := "HighlightedStates")> _
<TemplateVisualStateAttribute(Name := "NonHighlighted", GroupName := "HighlightedStates")> _
<TemplatePartAttribute(Name := "HeaderPanel", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "Header", Type := GetType(ContentControl))> _
Public Class C1MenuItem _
    Inherits C1ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1MenuItem

See Also

C1MenuItem Members
C1.Silverlight Namespace


C1MenuItem Members

[image] [image]

.NET Framework Class Library
C1MenuItem Members
C1MenuItem Class Constructors Methods Fields Properties Events See Also

The C1MenuItem type exposes the following members.

Constructors

Name | Description
C1MenuItem | Initializes a new instance of a C1MenuItem.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateHighlighted |
ChangeVisualStateOpen |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnClick | Responds to a click action by raising a Clicked event.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
OnMouseEnter | Called when the mouse pointer enters the bounds of the header element.
OnMouseLeave | Called when the mouse pointer leaves the bounds of the header element.
OnMouseLeftButtonDown | Called when the user presses the left mouse button over the item.
OnSubmenuClosed | Responds to a closed item action by raising a SubmenuClosed event.
OnSubmenuOpened | Responds to an open item action by raising a SubmenuOpened event.
PrepareContainerForItemOverride | (Inherited from C1ItemsControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
IconProperty | Identifies the Icon dependency property.
IsCheckableProperty | Identifies the IsCheckable dependency property.
IsCheckedProperty | Identifies the IsChecked dependency property.
IsHighlightedProperty | Identifies the IsHighlighted dependency property.
IsSubmenuOpenProperty | Identifies the IsSubmenuOpen dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the C1MenuItem control.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets the icon that appears in a C1MenuItem.
Index | Gets the index of this C1MenuItem in its parent items collection.
IsCheckable | Gets a value that indicates whether a C1MenuItem can be checked.
IsChecked | Gets or sets a value that indicates whether the C1MenuItem is checked.
IsHighlighted | Gets a value that indicates whether a C1MenuItem is highlighted.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsSubmenuOpen | Gets a value that indicates whether the submenu of the C1MenuItem is open.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Menu | Identifies the parent C1Menu of this item.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | Gets the C1MenuItem that is the parent of this item.
ParentCollection | Gets the items collection of the C1MenuItem that is the parent of this item.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content in the Header.
TextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.
TextWrapping | Gets or sets a value that indicates how any text should be wrapped in the Header.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Occurs when the C1MenuItem is clicked.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false.
SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true.

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MenuItem Constructor

[image]

.NET Framework Class Library
C1MenuItem Constructor
C1MenuItem Class See Also
Initializes a new instance of a C1MenuItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MenuItem()
Visual Basic (Declaration)
Public Sub New

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MenuItem Fields

[image] [image]

.NET Framework Class Library
C1MenuItem Fields
C1MenuItem Class See Also

The C1MenuItem type exposes the following members.

Fields

Name | Description
HeaderProperty | Identifies the Header dependency property.
IconProperty | Identifies the Icon dependency property.
IsCheckableProperty | Identifies the IsCheckable dependency property.
IsCheckedProperty | Identifies the IsChecked dependency property.
IsHighlightedProperty | Identifies the IsHighlighted dependency property.
IsSubmenuOpenProperty | Identifies the IsSubmenuOpen dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

See Also

C1MenuItem Class
C1.Silverlight Namespace


HeaderProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.HeaderProperty Field
C1MenuItem Class See Also
Identifies the Header dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


IconProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.IconProperty Field
C1MenuItem Class See Also
Identifies the Icon dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IconProperty
Visual Basic (Declaration)
Public Shared ReadOnly IconProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsCheckableProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.IsCheckableProperty Field
C1MenuItem Class See Also
Identifies the IsCheckable dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsCheckableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsCheckableProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsCheckedProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.IsCheckedProperty Field
C1MenuItem Class See Also
Identifies the IsChecked dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsCheckedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsCheckedProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsHighlightedProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.IsHighlightedProperty Field
C1MenuItem Class See Also
Identifies the IsHighlighted dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsHighlightedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsHighlightedProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsSubmenuOpenProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.IsSubmenuOpenProperty Field
C1MenuItem Class See Also
Identifies the IsSubmenuOpen dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsSubmenuOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSubmenuOpenProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.TextAlignmentProperty Field
C1MenuItem Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextDecorationsProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.TextDecorationsProperty Field
C1MenuItem Class See Also
Identifies the TextDecorations dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextDecorationsProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextDecorationsProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextWrappingProperty Field

[image]

.NET Framework Class Library
C1MenuItem..::.TextWrappingProperty Field
C1MenuItem Class See Also
Identifies the TextWrapping dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextWrappingProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MenuItem Methods

[image] [image]

.NET Framework Class Library
C1MenuItem Methods
C1MenuItem Class See Also

The C1MenuItem type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateHighlighted |
ChangeVisualStateOpen |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from C1ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnClick | Responds to a click action by raising a Clicked event.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
OnMouseEnter | Called when the mouse pointer enters the bounds of the header element.
OnMouseLeave | Called when the mouse pointer leaves the bounds of the header element.
OnMouseLeftButtonDown | Called when the user presses the left mouse button over the item.
OnSubmenuClosed | Responds to a closed item action by raising a SubmenuClosed event.
OnSubmenuOpened | Responds to an open item action by raising a SubmenuOpened event.
PrepareContainerForItemOverride | (Inherited from C1ItemsControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MenuItem Class
C1.Silverlight Namespace


ChangeVisualStateHighlighted Method

[image]

.NET Framework Class Library
C1MenuItem..::.ChangeVisualStateHighlighted Method
C1MenuItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateHighlighted(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateHighlighted ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


ChangeVisualStateOpen Method

[image]

.NET Framework Class Library
C1MenuItem..::.ChangeVisualStateOpen Method
C1MenuItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateOpen(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateOpen ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MenuItem..::.HitTest Method
C1MenuItem Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MenuItem Class
C1MenuItem Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnApplyTemplate Method
C1MenuItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnClick Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnClick Method
C1MenuItem Class See Also
Responds to a click action by raising a Clicked event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnClick(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnClick ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for SourcedEventArgs.

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnMouseEnter Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnMouseEnter Method
C1MenuItem Class See Also
Called when the mouse pointer enters the bounds of the header element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnMouseEnter(
    Object sender,
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnMouseEnter ( _
    sender As Object, _
    e As MouseEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Input..::.MouseEventArgs

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnMouseLeave Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnMouseLeave Method
C1MenuItem Class See Also
Called when the mouse pointer leaves the bounds of the header element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnMouseLeave(
    Object sender,
    MouseEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnMouseLeave ( _
    sender As Object, _
    e As MouseEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Input..::.MouseEventArgs

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnMouseLeftButtonDown Method
C1MenuItem Class See Also
Called when the user presses the left mouse button over the item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnMouseLeftButtonDown(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnMouseLeftButtonDown ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Input..::.MouseButtonEventArgs

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnSubmenuClosed Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnSubmenuClosed Method
C1MenuItem Class See Also
Responds to a closed item action by raising a SubmenuClosed event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnSubmenuClosed(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnSubmenuClosed ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for SourcedEventArgs.

See Also

C1MenuItem Class
C1.Silverlight Namespace


OnSubmenuOpened Method

[image]

.NET Framework Class Library
C1MenuItem..::.OnSubmenuOpened Method
C1MenuItem Class See Also
Responds to an open item action by raising a SubmenuOpened event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnSubmenuOpened(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnSubmenuOpened ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for SourcedEventArgs.

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MenuItem Properties

[image] [image]

.NET Framework Class Library
C1MenuItem Properties
C1MenuItem Class See Also

The C1MenuItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the C1MenuItem control.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets the icon that appears in a C1MenuItem.
Index | Gets the index of this C1MenuItem in its parent items collection.
IsCheckable | Gets a value that indicates whether a C1MenuItem can be checked.
IsChecked | Gets or sets a value that indicates whether the C1MenuItem is checked.
IsHighlighted | Gets a value that indicates whether a C1MenuItem is highlighted.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsSubmenuOpen | Gets a value that indicates whether the submenu of the C1MenuItem is open.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Menu | Identifies the parent C1Menu of this item.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | Gets the C1MenuItem that is the parent of this item.
ParentCollection | Gets the items collection of the C1MenuItem that is the parent of this item.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content in the Header.
TextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.
TextWrapping | Gets or sets a value that indicates how any text should be wrapped in the Header.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MenuItem Class
C1.Silverlight Namespace


Header Property

[image]

.NET Framework Class Library
C1MenuItem..::.Header Property
C1MenuItem Class See Also
Gets or sets the item that labels the C1MenuItem control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Header { get; set; }
Visual Basic (Declaration)
Public Property Header As Object

See Also

C1MenuItem Class
C1.Silverlight Namespace


Icon Property

[image]

.NET Framework Class Library
C1MenuItem..::.Icon Property
C1MenuItem Class See Also
Gets or sets the icon that appears in a C1MenuItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Icon { get; set; }
Visual Basic (Declaration)
Public Property Icon As Object

See Also

C1MenuItem Class
C1.Silverlight Namespace


Index Property

[image]

.NET Framework Class Library
C1MenuItem..::.Index Property
C1MenuItem Class See Also
Gets the index of this C1MenuItem in its parent items collection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsCheckable Property

[image]

.NET Framework Class Library
C1MenuItem..::.IsCheckable Property
C1MenuItem Class See Also
Gets a value that indicates whether a C1MenuItem can be checked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsCheckable { get; set; }
Visual Basic (Declaration)
Public Property IsCheckable As Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsChecked Property

[image]

.NET Framework Class Library
C1MenuItem..::.IsChecked Property
C1MenuItem Class See Also
Gets or sets a value that indicates whether the C1MenuItem is checked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsChecked { get; set; }
Visual Basic (Declaration)
Public Property IsChecked As Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsHighlighted Property

[image]

.NET Framework Class Library
C1MenuItem..::.IsHighlighted Property
C1MenuItem Class See Also
Gets a value that indicates whether a C1MenuItem is highlighted.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsHighlighted { get; set; }
Visual Basic (Declaration)
Public Property IsHighlighted As Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


IsSubmenuOpen Property

[image]

.NET Framework Class Library
C1MenuItem..::.IsSubmenuOpen Property
C1MenuItem Class See Also
Gets a value that indicates whether the submenu of the C1MenuItem is open.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsSubmenuOpen { get; set; }
Visual Basic (Declaration)
Public Property IsSubmenuOpen As Boolean

See Also

C1MenuItem Class
C1.Silverlight Namespace


Menu Property

[image]

.NET Framework Class Library
C1MenuItem..::.Menu Property
C1MenuItem Class See Also
Identifies the parent C1Menu of this item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1Menu Menu { get; internal set; }
Visual Basic (Declaration)
Public Property Menu As C1Menu

See Also

C1MenuItem Class
C1.Silverlight Namespace


Parent Property

[image]

.NET Framework Class Library
C1MenuItem..::.Parent Property
C1MenuItem Class See Also
Gets the C1MenuItem that is the parent of this item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MenuItem Parent { get; set; }
Visual Basic (Declaration)
Public Property Parent As C1MenuItem

See Also

C1MenuItem Class
C1.Silverlight Namespace


ParentCollection Property

[image]

.NET Framework Class Library
C1MenuItem..::.ParentCollection Property
C1MenuItem Class See Also
Gets the items collection of the C1MenuItem that is the parent of this item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IList ParentCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentCollection As IList

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1MenuItem..::.TextAlignment Property
C1MenuItem Class See Also
Gets or sets a value that indicates the horizontal alignment of text content in the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextDecorations Property

[image]

.NET Framework Class Library
C1MenuItem..::.TextDecorations Property
C1MenuItem Class See Also
Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextDecorationCollection TextDecorations { get; set; }
Visual Basic (Declaration)
Public Property TextDecorations As TextDecorationCollection

See Also

C1MenuItem Class
C1.Silverlight Namespace


TextWrapping Property

[image]

.NET Framework Class Library
C1MenuItem..::.TextWrapping Property
C1MenuItem Class See Also
Gets or sets a value that indicates how any text should be wrapped in the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic (Declaration)
Public Property TextWrapping As TextWrapping

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MenuItem Events

[image] [image]

.NET Framework Class Library
C1MenuItem Events
C1MenuItem Class See Also

The C1MenuItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Occurs when the C1MenuItem is clicked.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
SubmenuClosed | Occurs when the state of the IsSubmenuOpen property changes to false.
SubmenuOpened | Occurs when the state of the IsSubmenuOpen property changes to true.

See Also

C1MenuItem Class
C1.Silverlight Namespace


Click Event

[image]

.NET Framework Class Library
C1MenuItem..::.Click Event
C1MenuItem Class See Also
Occurs when the C1MenuItem is clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Click
Visual Basic (Declaration)
Public Event Click As EventHandler(Of SourcedEventArgs)

See Also

C1MenuItem Class
C1.Silverlight Namespace


SubmenuClosed Event

[image]

.NET Framework Class Library
C1MenuItem..::.SubmenuClosed Event
C1MenuItem Class See Also
Occurs when the state of the IsSubmenuOpen property changes to false.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> SubmenuClosed
Visual Basic (Declaration)
Public Event SubmenuClosed As EventHandler(Of SourcedEventArgs)

See Also

C1MenuItem Class
C1.Silverlight Namespace


SubmenuOpened Event

[image]

.NET Framework Class Library
C1MenuItem..::.SubmenuOpened Event
C1MenuItem Class See Also
Occurs when the state of the IsSubmenuOpen property changes to true.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> SubmenuOpened
Visual Basic (Declaration)
Public Event SubmenuOpened As EventHandler(Of SourcedEventArgs)

See Also

C1MenuItem Class
C1.Silverlight Namespace


C1MessageBox Class

[image]

.NET Framework Class Library
C1MessageBox Class
Members See Also
Displays a message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static class C1MessageBox
Visual Basic (Declaration)
Public NotInheritable Class C1MessageBox

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1MessageBox

See Also

C1MessageBox Members
C1.Silverlight Namespace


C1MessageBox Members

[image] [image]

.NET Framework Class Library
C1MessageBox Members
C1MessageBox Class Methods Properties See Also

The C1MessageBox type exposes the following members.

Methods

Name | Description
Show | Overloaded.

Properties

Name | Description
ContentStyle | Gets or sets the Style that defines the appearance of the window's content.
WindowStyle | Gets or sets the Style that defines the appearance of the window.

See Also

C1MessageBox Class
C1.Silverlight Namespace


C1MessageBox Methods

[image] [image]

.NET Framework Class Library
C1MessageBox Methods
C1MessageBox Class See Also

Methods

Name | Description
Show | Overloaded.

See Also

C1MessageBox Class
C1.Silverlight Namespace


Show Method

[image] [image]

.NET Framework Class Library
C1MessageBox..::.Show Method
C1MessageBox Class See Also

Overload List

Name | Description
Show(String) | Displays a message box that has a message.
Show(String, Action<(Of <(C1MessageBoxResult>)>)) | Displays a message box that has a message and calls back with the result.
Show(String, String) | Displays a message box that has a message and title bar caption.
Show(String, String, C1MessageBoxButton) | Displays a message box that has a message, title bar caption and button.
Show(String, String, C1MessageBoxIcon) | Displays a message box that has a message, title bar caption and icon.
Show(String, String, Action<(Of <(C1MessageBoxResult>)>)) | Displays a message box that has a message and title bar caption; and calls back with the result.
Show(String, String, C1MessageBoxButton, C1MessageBoxIcon) | Displays a message box that has a message, title bar caption and icon.
Show(String, String, C1MessageBoxButton, Action<(Of <(C1MessageBoxResult>)>)) | Displays a message box that has a message, title bar caption and button; and calls back with the result.
Show(String, String, C1MessageBoxIcon, Action<(Of <(C1MessageBoxResult>)>)) | Displays a message box that has a message, title bar caption and icon; and calls back with the result.
Show(String, String, C1MessageBoxButton, C1MessageBoxIcon, Action<(Of <(C1MessageBoxResult>)>)) | Displays a message box that has a message, title bar caption, button and icon; and calls back with the result.

See Also

C1MessageBox Class
C1MessageBox Members
C1.Silverlight Namespace


Show Method (String)

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String)
C1MessageBox Class See Also
Displays a message box that has a message.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String _
)

Parameters

message
Type: System..::.String
The text to display as a message.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, Action(C1MessageBoxResult))

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, Action<(Of <(C1MessageBoxResult>)>))
C1MessageBox Class See Also
Displays a message box that has a message and calls back with the result.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    Action<C1MessageBoxResult> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    callback As Action(Of C1MessageBoxResult) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
callback
Type: System..::.Action <(Of <( C1MessageBoxResult >)>)
An Action<(Of <(T>)>) which is called with the result of the message box.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String)

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String)
C1MessageBox Class See Also
Displays a message box that has a message and title bar caption.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxButton)

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxButton)
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption and button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxButton button
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    button As C1MessageBoxButton _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
button
Type: C1.Silverlight..::.C1MessageBoxButton
A C1MessageBoxButton value that specifies which buttons to display.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxIcon)

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxIcon)
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption and icon.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxIcon icon
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    icon As C1MessageBoxIcon _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
icon
Type: C1.Silverlight..::.C1MessageBoxIcon
A C1MessageBoxIcon value that specifies the icon to display.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, Action(C1MessageBoxResult))

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, Action<(Of <(C1MessageBoxResult>)>))
C1MessageBox Class See Also
Displays a message box that has a message and title bar caption; and calls back with the result.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    Action<C1MessageBoxResult> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    callback As Action(Of C1MessageBoxResult) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
callback
Type: System..::.Action <(Of <( C1MessageBoxResult >)>)
An Action<(Of <(T>)>) which is called with the result of the message box.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxButton, C1MessageBoxIcon)

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxButton, C1MessageBoxIcon)
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption and icon.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxButton button,
    C1MessageBoxIcon icon
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    button As C1MessageBoxButton, _
    icon As C1MessageBoxIcon _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
button
Type: C1.Silverlight..::.C1MessageBoxButton
A C1MessageBoxButton value that specifies which buttons to display.
icon
Type: C1.Silverlight..::.C1MessageBoxIcon
A C1MessageBoxIcon value that specifies the icon to display.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxButton, Action(C1MessageBoxResult))

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxButton, Action<(Of <(C1MessageBoxResult>)>))
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption and button; and calls back with the result.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxButton button,
    Action<C1MessageBoxResult> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    button As C1MessageBoxButton, _
    callback As Action(Of C1MessageBoxResult) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
button
Type: C1.Silverlight..::.C1MessageBoxButton
A C1MessageBoxButton value that specifies which buttons to display.
callback
Type: System..::.Action <(Of <( C1MessageBoxResult >)>)
An Action<(Of <(T>)>) which is called with the result of the message box.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxIcon, Action(C1MessageBoxResult))

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxIcon, Action<(Of <(C1MessageBoxResult>)>))
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption and icon; and calls back with the result.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxIcon icon,
    Action<C1MessageBoxResult> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    icon As C1MessageBoxIcon, _
    callback As Action(Of C1MessageBoxResult) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
icon
Type: C1.Silverlight..::.C1MessageBoxIcon
A C1MessageBoxIcon value that specifies the icon to display.
callback
Type: System..::.Action <(Of <( C1MessageBoxResult >)>)
An Action<(Of <(T>)>) which is called with the result of the message box.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


Show Method (String, String, C1MessageBoxButton, C1MessageBoxIcon, Action(C1MessageBoxResult))

[image]

.NET Framework Class Library
C1MessageBox..::.Show Method (String, String, C1MessageBoxButton, C1MessageBoxIcon, Action<(Of <(C1MessageBoxResult>)>))
C1MessageBox Class See Also
Displays a message box that has a message, title bar caption, button and icon; and calls back with the result.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    C1MessageBoxButton button,
    C1MessageBoxIcon icon,
    Action<C1MessageBoxResult> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    button As C1MessageBoxButton, _
    icon As C1MessageBoxIcon, _
    callback As Action(Of C1MessageBoxResult) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
button
Type: C1.Silverlight..::.C1MessageBoxButton
A C1MessageBoxButton value that specifies which buttons to display.
icon
Type: C1.Silverlight..::.C1MessageBoxIcon
A C1MessageBoxIcon value that specifies the icon to display.
callback
Type: System..::.Action <(Of <( C1MessageBoxResult >)>)
An Action<(Of <(T>)>) which is called with the result of the message box.

See Also

C1MessageBox Class
Show Overload
C1.Silverlight Namespace


C1MessageBox Properties

[image] [image]

.NET Framework Class Library
C1MessageBox Properties
C1MessageBox Class See Also

The C1MessageBox type exposes the following members.

Properties

Name | Description
ContentStyle | Gets or sets the Style that defines the appearance of the window's content.
WindowStyle | Gets or sets the Style that defines the appearance of the window.

See Also

C1MessageBox Class
C1.Silverlight Namespace


ContentStyle Property

[image]

.NET Framework Class Library
C1MessageBox..::.ContentStyle Property
C1MessageBox Class See Also
Gets or sets the Style that defines the appearance of the window's content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Style ContentStyle { get; set; }
Visual Basic (Declaration)
Public Shared Property ContentStyle As Style

See Also

C1MessageBox Class
C1.Silverlight Namespace


WindowStyle Property

[image]

.NET Framework Class Library
C1MessageBox..::.WindowStyle Property
C1MessageBox Class See Also
Gets or sets the Style that defines the appearance of the window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Style WindowStyle { get; set; }
Visual Basic (Declaration)
Public Shared Property WindowStyle As Style

See Also

C1MessageBox Class
C1.Silverlight Namespace


C1MessageBoxButton Enumeration

[image]

.NET Framework Class Library
C1MessageBoxButton Enumeration
See Also
Specifies the buttons that are displayed on a message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum C1MessageBoxButton
Visual Basic (Declaration)
Public Enumeration C1MessageBoxButton

Members

Member name | Description
OK | The message box displays an OK button.
OKCancel | The message box displays OK and Cancel buttons.
YesNoCancel | The message box displays OK and Cancel buttons.
YesNo | The message box displays Yes and No buttons.

See Also

C1.Silverlight Namespace


C1MessageBoxContent Class

[image]

.NET Framework Class Library
C1MessageBoxContent Class
Members See Also
Control that displays the content of a message box. It's meant to be used inside a C1Window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Icon", Type = typeof(Image))]
[TemplateVisualStateAttribute(Name = "Error", GroupName = "IconStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Buttons", Type = typeof(Panel))]
[TemplateVisualStateAttribute(Name = "Warning", GroupName = "IconStates")]
[TemplateVisualStateAttribute(Name = "Question", GroupName = "IconStates")]
[TemplateVisualStateAttribute(Name = "Information", GroupName = "IconStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "IconStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
public class C1MessageBoxContent : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Icon", Type := GetType(Image))> _
<TemplateVisualStateAttribute(Name := "Error", GroupName := "IconStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Buttons", Type := GetType(Panel))> _
<TemplateVisualStateAttribute(Name := "Warning", GroupName := "IconStates")> _
<TemplateVisualStateAttribute(Name := "Question", GroupName := "IconStates")> _
<TemplateVisualStateAttribute(Name := "Information", GroupName := "IconStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "IconStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
Public Class C1MessageBoxContent _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1MessageBoxContent

See Also

C1MessageBoxContent Members
C1.Silverlight Namespace


C1MessageBoxContent Members

[image] [image]

.NET Framework Class Library
C1MessageBoxContent Members
C1MessageBoxContent Class Constructors Methods Fields Properties Events See Also

The C1MessageBoxContent type exposes the following members.

Constructors

Name | Description
C1MessageBoxContent | Initializes a new instance of a C1MessageBoxContent.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateIcon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ButtonProperty | Identifies the Button dependency property.
ButtonStyleProperty | Identifies the ButtonStyle dependency property.
CancelTextProperty | Identifies the CancelText dependency property.
IconProperty | Identifies the Icon dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MessageProperty | Identifies the Message dependency property.
NoTextProperty | Identifies the NoText dependency property.
OKTextProperty | Identifies the OKText dependency property.
YesTextProperty | Identifies the YesText dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Button | Gets or sets a C1MessageBoxButton specifying which buttons are displayed in the message box.
ButtonStyle | Gets or sets the style applied to the message box's buttons.
CancelText | Gets or sets the text displayed in the Cancel button.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets a C1MessageBoxIcon specifying which icon is displayed in the message box.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Message | Gets or sets the message text displayed in the message box.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NoText | Gets or sets the text displayed in the No button.
OKText | Gets or sets the text displayed in the OK button.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
YesText | Gets or sets the text displayed in the Yes button.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ButtonClick | Event fired when a button is pressed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxContent Constructor

[image]

.NET Framework Class Library
C1MessageBoxContent Constructor
C1MessageBoxContent Class See Also
Initializes a new instance of a C1MessageBoxContent.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MessageBoxContent()
Visual Basic (Declaration)
Public Sub New

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxContent Fields

[image] [image]

.NET Framework Class Library
C1MessageBoxContent Fields
C1MessageBoxContent Class See Also

The C1MessageBoxContent type exposes the following members.

Fields

Name | Description
ButtonProperty | Identifies the Button dependency property.
ButtonStyleProperty | Identifies the ButtonStyle dependency property.
CancelTextProperty | Identifies the CancelText dependency property.
IconProperty | Identifies the Icon dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MessageProperty | Identifies the Message dependency property.
NoTextProperty | Identifies the NoText dependency property.
OKTextProperty | Identifies the OKText dependency property.
YesTextProperty | Identifies the YesText dependency property.

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ButtonProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ButtonProperty Field
C1MessageBoxContent Class See Also
Identifies the Button dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly ButtonProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ButtonStyleProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ButtonStyleProperty Field
C1MessageBoxContent Class See Also
Identifies the ButtonStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ButtonStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ButtonStyleProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


CancelTextProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.CancelTextProperty Field
C1MessageBoxContent Class See Also
Identifies the CancelText dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty CancelTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly CancelTextProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


IconProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.IconProperty Field
C1MessageBoxContent Class See Also
Identifies the Icon dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IconProperty
Visual Basic (Declaration)
Public Shared ReadOnly IconProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.IsMouseOverProperty Field
C1MessageBoxContent Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


MessageProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.MessageProperty Field
C1MessageBoxContent Class See Also
Identifies the Message dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MessageProperty
Visual Basic (Declaration)
Public Shared ReadOnly MessageProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


NoTextProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.NoTextProperty Field
C1MessageBoxContent Class See Also
Identifies the NoText dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty NoTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly NoTextProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


OKTextProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.OKTextProperty Field
C1MessageBoxContent Class See Also
Identifies the OKText dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty OKTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly OKTextProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


YesTextProperty Field

[image]

.NET Framework Class Library
C1MessageBoxContent..::.YesTextProperty Field
C1MessageBoxContent Class See Also
Identifies the YesText dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty YesTextProperty
Visual Basic (Declaration)
Public Shared ReadOnly YesTextProperty As DependencyProperty

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxContent Methods

[image] [image]

.NET Framework Class Library
C1MessageBoxContent Methods
C1MessageBoxContent Class See Also

The C1MessageBoxContent type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateIcon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ChangeVisualStateCommon Method
C1MessageBoxContent Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ChangeVisualStateIcon Method

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ChangeVisualStateIcon Method
C1MessageBoxContent Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateIcon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateIcon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MessageBoxContent..::.HitTest Method
C1MessageBoxContent Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MessageBoxContent Class
C1MessageBoxContent Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1MessageBoxContent..::.OnApplyTemplate Method
C1MessageBoxContent Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxContent Properties

[image] [image]

.NET Framework Class Library
C1MessageBoxContent Properties
C1MessageBoxContent Class See Also

The C1MessageBoxContent type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Button | Gets or sets a C1MessageBoxButton specifying which buttons are displayed in the message box.
ButtonStyle | Gets or sets the style applied to the message box's buttons.
CancelText | Gets or sets the text displayed in the Cancel button.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets a C1MessageBoxIcon specifying which icon is displayed in the message box.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Message | Gets or sets the message text displayed in the message box.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NoText | Gets or sets the text displayed in the No button.
OKText | Gets or sets the text displayed in the OK button.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
YesText | Gets or sets the text displayed in the Yes button.

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


Button Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.Button Property
C1MessageBoxContent Class See Also
Gets or sets a C1MessageBoxButton specifying which buttons are displayed in the message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MessageBoxButton Button { get; set; }
Visual Basic (Declaration)
Public Property Button As C1MessageBoxButton

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ButtonStyle Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ButtonStyle Property
C1MessageBoxContent Class See Also
Gets or sets the style applied to the message box's buttons.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style ButtonStyle { get; set; }
Visual Basic (Declaration)
Public Property ButtonStyle As Style

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


CancelText Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.CancelText Property
C1MessageBoxContent Class See Also
Gets or sets the text displayed in the Cancel button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string CancelText { get; set; }
Visual Basic (Declaration)
Public Property CancelText As String

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


Icon Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.Icon Property
C1MessageBoxContent Class See Also
Gets or sets a C1MessageBoxIcon specifying which icon is displayed in the message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MessageBoxIcon Icon { get; set; }
Visual Basic (Declaration)
Public Property Icon As C1MessageBoxIcon

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.IsMouseOver Property
C1MessageBoxContent Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


Message Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.Message Property
C1MessageBoxContent Class See Also
Gets or sets the message text displayed in the message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


NoText Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.NoText Property
C1MessageBoxContent Class See Also
Gets or sets the text displayed in the No button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string NoText { get; set; }
Visual Basic (Declaration)
Public Property NoText As String

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


OKText Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.OKText Property
C1MessageBoxContent Class See Also
Gets or sets the text displayed in the OK button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string OKText { get; set; }
Visual Basic (Declaration)
Public Property OKText As String

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


YesText Property

[image]

.NET Framework Class Library
C1MessageBoxContent..::.YesText Property
C1MessageBoxContent Class See Also
Gets or sets the text displayed in the Yes button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string YesText { get; set; }
Visual Basic (Declaration)
Public Property YesText As String

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxContent Events

[image] [image]

.NET Framework Class Library
C1MessageBoxContent Events
C1MessageBoxContent Class See Also

The C1MessageBoxContent type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ButtonClick | Event fired when a button is pressed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


ButtonClick Event

[image]

.NET Framework Class Library
C1MessageBoxContent..::.ButtonClick Event
C1MessageBoxContent Class See Also
Event fired when a button is pressed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event Action<C1MessageBoxResult> ButtonClick
Visual Basic (Declaration)
Public Event ButtonClick As Action(Of C1MessageBoxResult)

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1MessageBoxContent..::.IsMouseOverChanged Event
C1MessageBoxContent Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1MessageBoxContent Class
C1.Silverlight Namespace


C1MessageBoxIcon Enumeration

[image]

.NET Framework Class Library
C1MessageBoxIcon Enumeration
See Also
Specifies the icon that is displayed by a message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum C1MessageBoxIcon
Visual Basic (Declaration)
Public Enumeration C1MessageBoxIcon

Members

Member name | Description
None | No icon is displayed.
Error | The message box displays an error icon.
Warning | The message box displays a warning icon.
Information | The message box displays an information icon.
Question | The message box displays an information icon.

See Also

C1.Silverlight Namespace


C1MessageBoxResult Enumeration

[image]

.NET Framework Class Library
C1MessageBoxResult Enumeration
See Also
Specifies which message box button that a user clicks.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum C1MessageBoxResult
Visual Basic (Declaration)
Public Enumeration C1MessageBoxResult

Members

Member name | Description
Yes | The result value of the message box is Yes.
No | The result value of the message box is No.
OK | The result value of the message box is OK.
Cancel | The result value of the message box is Cancel.

See Also

C1.Silverlight Namespace


C1MouseHelper Class

[image]

.NET Framework Class Library
C1MouseHelper Class
Members See Also
Provides extra mouse events not provided by UIElement

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1MouseHelper
Visual Basic (Declaration)
Public Class C1MouseHelper

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1MouseHelper

See Also

C1MouseHelper Members
C1.Silverlight Namespace


C1MouseHelper Members

[image] [image]

.NET Framework Class Library
C1MouseHelper Members
C1MouseHelper Class Constructors Methods Events See Also

The C1MouseHelper type exposes the following members.

Constructors

Name | Description
C1MouseHelper | Initializes a new C1MouseHelper.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
MouseClick | Fired when the UIElement is clicked.
MouseDoubleClick | Fired when the UIElement is double clicked.
MouseDragEnd | Fires when a drag ends.
MouseDragMove | Fired when the mouse moves dragging the UIElement.
MouseDragStart | Fired when a drag of the UIElement starts.
MouseWheel | Fired when the mouse wheel is triggered over the UIElement.

See Also

C1MouseHelper Class
C1.Silverlight Namespace


C1MouseHelper Constructor

[image]

.NET Framework Class Library
C1MouseHelper Constructor
C1MouseHelper Class See Also
Initializes a new C1MouseHelper.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1MouseHelper(
    UIElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As UIElement _
)

Parameters

element
Type: System.Windows..::.UIElement
A UIElement for which the mouse events will be fired.

See Also

C1MouseHelper Class
C1.Silverlight Namespace


C1MouseHelper Methods

[image] [image]

.NET Framework Class Library
C1MouseHelper Methods
C1MouseHelper Class See Also

The C1MouseHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1MouseHelper Class
C1.Silverlight Namespace


C1MouseHelper Events

[image] [image]

.NET Framework Class Library
C1MouseHelper Events
C1MouseHelper Class See Also

The C1MouseHelper type exposes the following members.

Events

Name | Description
MouseClick | Fired when the UIElement is clicked.
MouseDoubleClick | Fired when the UIElement is double clicked.
MouseDragEnd | Fires when a drag ends.
MouseDragMove | Fired when the mouse moves dragging the UIElement.
MouseDragStart | Fired when a drag of the UIElement starts.
MouseWheel | Fired when the mouse wheel is triggered over the UIElement.

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseClick Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseClick Event
C1MouseHelper Class See Also
Fired when the UIElement is clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event MouseEventHandler MouseClick
Visual Basic (Declaration)
Public Event MouseClick As MouseEventHandler

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseDoubleClick Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseDoubleClick Event
C1MouseHelper Class See Also
Fired when the UIElement is double clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event MouseEventHandler MouseDoubleClick
Visual Basic (Declaration)
Public Event MouseDoubleClick As MouseEventHandler

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseDragEnd Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseDragEnd Event
C1MouseHelper Class See Also
Fires when a drag ends.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> MouseDragEnd
Visual Basic (Declaration)
Public Event MouseDragEnd As EventHandler(Of MouseDragEventArgs)

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseDragMove Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseDragMove Event
C1MouseHelper Class See Also
Fired when the mouse moves dragging the UIElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> MouseDragMove
Visual Basic (Declaration)
Public Event MouseDragMove As EventHandler(Of MouseDragEventArgs)

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseDragStart Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseDragStart Event
C1MouseHelper Class See Also
Fired when a drag of the UIElement starts.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> MouseDragStart
Visual Basic (Declaration)
Public Event MouseDragStart As EventHandler(Of MouseDragEventArgs)

See Also

C1MouseHelper Class
C1.Silverlight Namespace


MouseWheel Event

[image]

.NET Framework Class Library
C1MouseHelper..::.MouseWheel Event
C1MouseHelper Class See Also
Fired when the mouse wheel is triggered over the UIElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<MouseWheelEventArgs> MouseWheel
Visual Basic (Declaration)
Public Event MouseWheel As EventHandler(Of MouseWheelEventArgs)

See Also

C1MouseHelper Class
C1.Silverlight Namespace


C1NumericBox Class

[image]

.NET Framework Class Library
C1NumericBox Class
Members See Also
Editor that allows entering numbers in many formats.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Decrease", Type = typeof(RepeatButton))]
[TemplatePartAttribute(Name = "Text", Type = typeof(TextBox))]
[TemplatePartAttribute(Name = "Increase", Type = typeof(RepeatButton))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "ShowButtons", GroupName = "ButtonsVisibilityStates")]
[TemplateVisualStateAttribute(Name = "HideButtons", GroupName = "ButtonsVisibilityStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
public class C1NumericBox : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Decrease", Type := GetType(RepeatButton))> _
<TemplatePartAttribute(Name := "Text", Type := GetType(TextBox))> _
<TemplatePartAttribute(Name := "Increase", Type := GetType(RepeatButton))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "ShowButtons", GroupName := "ButtonsVisibilityStates")> _
<TemplateVisualStateAttribute(Name := "HideButtons", GroupName := "ButtonsVisibilityStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
Public Class C1NumericBox _
    Inherits Control

Remarks

Format property supports standard and custom formats. Watermark property shows help text when the control is empty. AllowNull property allows binding to and displaying null values. When the control is empty, or bound to a null value, the Value property returns double.NaN.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1NumericBox

See Also

C1NumericBox Members
C1.Silverlight Namespace


C1NumericBox Members

[image] [image]

.NET Framework Class Library
C1NumericBox Members
C1NumericBox Class Constructors Methods Fields Properties Events See Also

The C1NumericBox type exposes the following members.

Constructors

Name | Description
C1NumericBox | Initializes a new instance of a C1NumericBox.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateButtonsVisibility |
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnValueChanged | Raises the ValueChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | Selects the text specified by start and length.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowNullProperty | Identifies the AllowNull dependency property.
DelayProperty | Identifies the Delay dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
FormatProperty | Identifies the Format dependency property.
HandleUpDownKeysProperty | Identifies the HandleUpDownKeys dependency property.
IncrementProperty | Identifies the Increment dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
SelectionBackgroundProperty | Identifies the SelectionBackground dependency property.
SelectionForegroundProperty | Identifies the SelectionForeground dependency property.
SelectionLengthProperty | Identifies the SelectionLength dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
ShowButtonsProperty | Identifies the ShowButtons dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
ValueProperty | Identifies the Value dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowNull | Gets or sets whether the user can enter nulls values.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
Delay | Gets or sets the delay for the Increase and Decrease buttons.
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Format | Gets or sets the value for the Format of the C1NumericBox.
HandleUpDownKeys | Gets or sets If the control handles the Up / Down / PageUp / PageDown keys.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Increment | Gets or sets the increment applied when the user pressed the up/down arrow keys.
Interval | Gets or sets the interval for the Increase and Decrease buttons.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsReadOnly | Gets or sets the value that determines if the C1NumericBox is read-only.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Gets or sets the maximum value allowed for the C1NumericBox.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Gets or sets the minimum value allowed for the C1NumericBox.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectionBackground | Gets or sets the brush that fills the background of the selected text.
SelectionForeground | Gets or sets the brush used for the selected text in the C1NumericBox.
SelectionLength | Gets or sets the number of characters in the current selection in the C1NumericBox.
SelectionStart | Gets or sets the starting position of the text selected in the C1NumericBox.
ShowButtons | Shows or hides the buttons for Increment or Decrement.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1NumericBox.
Triggers | (Inherited from FrameworkElement.)
Value | Gets or sets the numeric value in the C1NumericBox.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content displayed when the control is empty.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Fires when the Value property changes.

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1NumericBox Constructor

[image]

.NET Framework Class Library
C1NumericBox Constructor
C1NumericBox Class See Also
Initializes a new instance of a C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1NumericBox()
Visual Basic (Declaration)
Public Sub New

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1NumericBox Fields

[image] [image]

.NET Framework Class Library
C1NumericBox Fields
C1NumericBox Class See Also

The C1NumericBox type exposes the following members.

Fields

Name | Description
AllowNullProperty | Identifies the AllowNull dependency property.
DelayProperty | Identifies the Delay dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
FormatProperty | Identifies the Format dependency property.
HandleUpDownKeysProperty | Identifies the HandleUpDownKeys dependency property.
IncrementProperty | Identifies the Increment dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
SelectionBackgroundProperty | Identifies the SelectionBackground dependency property.
SelectionForegroundProperty | Identifies the SelectionForeground dependency property.
SelectionLengthProperty | Identifies the SelectionLength dependency property.
SelectionStartProperty | Identifies the SelectionStart dependency property.
ShowButtonsProperty | Identifies the ShowButtons dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
ValueProperty | Identifies the Value dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

See Also

C1NumericBox Class
C1.Silverlight Namespace


AllowNullProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.AllowNullProperty Field
C1NumericBox Class See Also
Identifies the AllowNull dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AllowNullProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowNullProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


DelayProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.DelayProperty Field
C1NumericBox Class See Also
Identifies the Delay dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DelayProperty
Visual Basic (Declaration)
Public Shared ReadOnly DelayProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.DisabledStyleProperty Field
C1NumericBox Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.FocusStyleProperty Field
C1NumericBox Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


FormatProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.FormatProperty Field
C1NumericBox Class See Also
Identifies the Format dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FormatProperty
Visual Basic (Declaration)
Public Shared ReadOnly FormatProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


HandleUpDownKeysProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.HandleUpDownKeysProperty Field
C1NumericBox Class See Also
Identifies the HandleUpDownKeys dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty HandleUpDownKeysProperty
Visual Basic (Declaration)
Public Shared ReadOnly HandleUpDownKeysProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


IncrementProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.IncrementProperty Field
C1NumericBox Class See Also
Identifies the Increment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IncrementProperty
Visual Basic (Declaration)
Public Shared ReadOnly IncrementProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


IntervalProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.IntervalProperty Field
C1NumericBox Class See Also
Identifies the Interval dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.IsFocusedProperty Field
C1NumericBox Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.IsMouseOverProperty Field
C1NumericBox Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsReadOnlyProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.IsReadOnlyProperty Field
C1NumericBox Class See Also
Identifies the IsReadOnly dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


MaximumProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.MaximumProperty Field
C1NumericBox Class See Also
Identifies the Maximum dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MaximumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


MinimumProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.MinimumProperty Field
C1NumericBox Class See Also
Identifies the Minimum dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MinimumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionBackgroundProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionBackgroundProperty Field
C1NumericBox Class See Also
Identifies the SelectionBackground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionBackgroundProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionForegroundProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionForegroundProperty Field
C1NumericBox Class See Also
Identifies the SelectionForeground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionForegroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionForegroundProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionLengthProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionLengthProperty Field
C1NumericBox Class See Also
Identifies the SelectionLength dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionLengthProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionLengthProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionStartProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionStartProperty Field
C1NumericBox Class See Also
Identifies the SelectionStart dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionStartProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionStartProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


ShowButtonsProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.ShowButtonsProperty Field
C1NumericBox Class See Also
Identifies the ShowButtons dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ShowButtonsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowButtonsProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.TextAlignmentProperty Field
C1NumericBox Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


ValueProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.ValueProperty Field
C1NumericBox Class See Also
Identifies the Value dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


WatermarkProperty Field

[image]

.NET Framework Class Library
C1NumericBox..::.WatermarkProperty Field
C1NumericBox Class See Also
Identifies the Watermark dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty WatermarkProperty
Visual Basic (Declaration)
Public Shared ReadOnly WatermarkProperty As DependencyProperty

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1NumericBox Methods

[image] [image]

.NET Framework Class Library
C1NumericBox Methods
C1NumericBox Class See Also

The C1NumericBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateButtonsVisibility |
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnValueChanged | Raises the ValueChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | Selects the text specified by start and length.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1NumericBox Class
C1.Silverlight Namespace


ChangeVisualStateButtonsVisibility Method

[image]

.NET Framework Class Library
C1NumericBox..::.ChangeVisualStateButtonsVisibility Method
C1NumericBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateButtonsVisibility(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateButtonsVisibility ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1NumericBox..::.ChangeVisualStateCommon Method
C1NumericBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1NumericBox..::.ChangeVisualStateFocus Method
C1NumericBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1NumericBox..::.HitTest Method
C1NumericBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1NumericBox Class
C1NumericBox Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1NumericBox..::.OnApplyTemplate Method
C1NumericBox Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1NumericBox Class
C1.Silverlight Namespace


OnValueChanged Method

[image]

.NET Framework Class Library
C1NumericBox..::.OnValueChanged Method
C1NumericBox Class See Also
Raises the ValueChanged event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnValueChanged(
    PropertyChangedEventArgs<double> e
)
Visual Basic (Declaration)
Protected Overridable Sub OnValueChanged ( _
    e As PropertyChangedEventArgs(Of Double) _
)

Parameters

e
Type: C1.Silverlight..::.PropertyChangedEventArgs <(Of <( Double >)>)

See Also

C1NumericBox Class
C1.Silverlight Namespace


Select Method

[image]

.NET Framework Class Library
C1NumericBox..::.Select Method
C1NumericBox Class See Also
Selects the text specified by start and length.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Select(
    int start,
    int length
)
Visual Basic (Declaration)
Public Sub Select ( _
    start As Integer, _
    length As Integer _
)

Parameters

start
Type: System..::.Int32
Start of the selection.
length
Type: System..::.Int32
Length of the selection.

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1NumericBox Properties

[image] [image]

.NET Framework Class Library
C1NumericBox Properties
C1NumericBox Class See Also

The C1NumericBox type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowNull | Gets or sets whether the user can enter nulls values.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
Delay | Gets or sets the delay for the Increase and Decrease buttons.
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Format | Gets or sets the value for the Format of the C1NumericBox.
HandleUpDownKeys | Gets or sets If the control handles the Up / Down / PageUp / PageDown keys.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Increment | Gets or sets the increment applied when the user pressed the up/down arrow keys.
Interval | Gets or sets the interval for the Increase and Decrease buttons.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsReadOnly | Gets or sets the value that determines if the C1NumericBox is read-only.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Gets or sets the maximum value allowed for the C1NumericBox.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Gets or sets the minimum value allowed for the C1NumericBox.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectionBackground | Gets or sets the brush that fills the background of the selected text.
SelectionForeground | Gets or sets the brush used for the selected text in the C1NumericBox.
SelectionLength | Gets or sets the number of characters in the current selection in the C1NumericBox.
SelectionStart | Gets or sets the starting position of the text selected in the C1NumericBox.
ShowButtons | Shows or hides the buttons for Increment or Decrement.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1NumericBox.
Triggers | (Inherited from FrameworkElement.)
Value | Gets or sets the numeric value in the C1NumericBox.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the watermark content displayed when the control is empty.
Width | (Inherited from FrameworkElement.)

See Also

C1NumericBox Class
C1.Silverlight Namespace


AllowNull Property

[image]

.NET Framework Class Library
C1NumericBox..::.AllowNull Property
C1NumericBox Class See Also
Gets or sets whether the user can enter nulls values.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AllowNull { get; set; }
Visual Basic (Declaration)
Public Property AllowNull As Boolean

Remarks

Null values are encoded in the Value property as double.NaN.

See Also

C1NumericBox Class
C1.Silverlight Namespace


Delay Property

[image]

.NET Framework Class Library
C1NumericBox..::.Delay Property
C1NumericBox Class See Also
Gets or sets the delay for the Increase and Decrease buttons.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Delay { get; set; }
Visual Basic (Declaration)
Public Property Delay As Integer

See Also

C1NumericBox Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1NumericBox..::.DisabledStyle Property
C1NumericBox Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1NumericBox Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1NumericBox..::.FocusStyle Property
C1NumericBox Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1NumericBox Class
C1.Silverlight Namespace


Format Property

[image]

.NET Framework Class Library
C1NumericBox..::.Format Property
C1NumericBox Class See Also
Gets or sets the value for the Format of the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String

Remarks

The possible values are: N, C, F, N0, C0, F0, N1, C1, etc. Default Value is : F0

See Also

C1NumericBox Class
C1.Silverlight Namespace


HandleUpDownKeys Property

[image]

.NET Framework Class Library
C1NumericBox..::.HandleUpDownKeys Property
C1NumericBox Class See Also
Gets or sets If the control handles the Up / Down / PageUp / PageDown keys.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool HandleUpDownKeys { get; set; }
Visual Basic (Declaration)
Public Property HandleUpDownKeys As Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


Increment Property

[image]

.NET Framework Class Library
C1NumericBox..::.Increment Property
C1NumericBox Class See Also
Gets or sets the increment applied when the user pressed the up/down arrow keys.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Increment { get; set; }
Visual Basic (Declaration)
Public Property Increment As Double

See Also

C1NumericBox Class
C1.Silverlight Namespace


Interval Property

[image]

.NET Framework Class Library
C1NumericBox..::.Interval Property
C1NumericBox Class See Also
Gets or sets the interval for the Increase and Decrease buttons.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Integer

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1NumericBox..::.IsFocused Property
C1NumericBox Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1NumericBox..::.IsMouseOver Property
C1NumericBox Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
C1NumericBox..::.IsReadOnly Property
C1NumericBox Class See Also
Gets or sets the value that determines if the C1NumericBox is read-only.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


Maximum Property

[image]

.NET Framework Class Library
C1NumericBox..::.Maximum Property
C1NumericBox Class See Also
Gets or sets the maximum value allowed for the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double

See Also

C1NumericBox Class
C1.Silverlight Namespace


Minimum Property

[image]

.NET Framework Class Library
C1NumericBox..::.Minimum Property
C1NumericBox Class See Also
Gets or sets the minimum value allowed for the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionBackground Property

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionBackground Property
C1NumericBox Class See Also
Gets or sets the brush that fills the background of the selected text.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush SelectionBackground { get; set; }
Visual Basic (Declaration)
Public Property SelectionBackground As Brush

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionForeground Property

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionForeground Property
C1NumericBox Class See Also
Gets or sets the brush used for the selected text in the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush SelectionForeground { get; set; }
Visual Basic (Declaration)
Public Property SelectionForeground As Brush

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionLength Property

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionLength Property
C1NumericBox Class See Also
Gets or sets the number of characters in the current selection in the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int SelectionLength { get; set; }
Visual Basic (Declaration)
Public Property SelectionLength As Integer

See Also

C1NumericBox Class
C1.Silverlight Namespace


SelectionStart Property

[image]

.NET Framework Class Library
C1NumericBox..::.SelectionStart Property
C1NumericBox Class See Also
Gets or sets the starting position of the text selected in the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int SelectionStart { get; set; }
Visual Basic (Declaration)
Public Property SelectionStart As Integer

See Also

C1NumericBox Class
C1.Silverlight Namespace


ShowButtons Property

[image]

.NET Framework Class Library
C1NumericBox..::.ShowButtons Property
C1NumericBox Class See Also
Shows or hides the buttons for Increment or Decrement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool ShowButtons { get; set; }
Visual Basic (Declaration)
Public Property ShowButtons As Boolean

See Also

C1NumericBox Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1NumericBox..::.TextAlignment Property
C1NumericBox Class See Also
Gets or sets how the text should be aligned in the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1NumericBox Class
C1.Silverlight Namespace


Value Property

[image]

.NET Framework Class Library
C1NumericBox..::.Value Property
C1NumericBox Class See Also
Gets or sets the numeric value in the C1NumericBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double

Remarks

Null values are represented by the Value property as double.NaN. See also the AllowNull property.

See Also

C1NumericBox Class
C1.Silverlight Namespace


Watermark Property

[image]

.NET Framework Class Library
C1NumericBox..::.Watermark Property
C1NumericBox Class See Also
Gets or sets the watermark content displayed when the control is empty.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Watermark { get; set; }
Visual Basic (Declaration)
Public Property Watermark As Object

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1NumericBox Events

[image] [image]

.NET Framework Class Library
C1NumericBox Events
C1NumericBox Class See Also

The C1NumericBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Fires when the Value property changes.

See Also

C1NumericBox Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1NumericBox..::.IsMouseOverChanged Event
C1NumericBox Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1NumericBox Class
C1.Silverlight Namespace


ValueChanged Event

[image]

.NET Framework Class Library
C1NumericBox..::.ValueChanged Event
C1NumericBox Class See Also
Fires when the Value property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1NumericBox Class
C1.Silverlight Namespace


C1PromptBox Class

[image]

.NET Framework Class Library
C1PromptBox Class
Members See Also
Displays a message box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static class C1PromptBox
Visual Basic (Declaration)
Public NotInheritable Class C1PromptBox

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1PromptBox

See Also

C1PromptBox Members
C1.Silverlight Namespace


C1PromptBox Members

[image] [image]

.NET Framework Class Library
C1PromptBox Members
C1PromptBox Class Methods Properties See Also

The C1PromptBox type exposes the following members.

Methods

Name | Description
Show | Displays a prompt box that has a message, title bar caption, and calls back with the user input.

Properties

Name | Description
ContentStyle | Gets or sets the Style that defines the appearance of the window's content.
WindowStyle | Gets or sets the Style that defines the appearance of the window.

See Also

C1PromptBox Class
C1.Silverlight Namespace


C1PromptBox Methods

[image] [image]

.NET Framework Class Library
C1PromptBox Methods
C1PromptBox Class See Also

The C1PromptBox type exposes the following members.

Methods

Name | Description
Show | Displays a prompt box that has a message, title bar caption, and calls back with the user input.

See Also

C1PromptBox Class
C1.Silverlight Namespace


Show Method

[image]

.NET Framework Class Library
C1PromptBox..::.Show Method
C1PromptBox Class See Also
Displays a prompt box that has a message, title bar caption, and calls back with the user input.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Show(
    string message,
    string caption,
    Action<string> callback
)
Visual Basic (Declaration)
Public Shared Sub Show ( _
    message As String, _
    caption As String, _
    callback As Action(Of String) _
)

Parameters

message
Type: System..::.String
The text to display as a message.
caption
Type: System..::.String
The title bar caption.
callback
Type: System..::.Action <(Of <( String >)>)
An Action<(Of <(T>)>) which is called with the user input.

See Also

C1PromptBox Class
C1.Silverlight Namespace


C1PromptBox Properties

[image] [image]

.NET Framework Class Library
C1PromptBox Properties
C1PromptBox Class See Also

The C1PromptBox type exposes the following members.

Properties

Name | Description
ContentStyle | Gets or sets the Style that defines the appearance of the window's content.
WindowStyle | Gets or sets the Style that defines the appearance of the window.

See Also

C1PromptBox Class
C1.Silverlight Namespace


ContentStyle Property

[image]

.NET Framework Class Library
C1PromptBox..::.ContentStyle Property
C1PromptBox Class See Also
Gets or sets the Style that defines the appearance of the window's content.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Style ContentStyle { get; set; }
Visual Basic (Declaration)
Public Shared Property ContentStyle As Style

See Also

C1PromptBox Class
C1.Silverlight Namespace


WindowStyle Property

[image]

.NET Framework Class Library
C1PromptBox..::.WindowStyle Property
C1PromptBox Class See Also
Gets or sets the Style that defines the appearance of the window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Style WindowStyle { get; set; }
Visual Basic (Declaration)
Public Shared Property WindowStyle As Style

See Also

C1PromptBox Class
C1.Silverlight Namespace


C1PromptBoxContent Class

[image]

.NET Framework Class Library
C1PromptBoxContent Class
Members See Also
Control that displays the content of a prompt box. It's meant to be used inside a C1Window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "OKButton", Type = typeof(Button))]
[TemplatePartAttribute(Name = "TextBox", Type = typeof(TextBox))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
public class C1PromptBoxContent : Control
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "OKButton", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "TextBox", Type := GetType(TextBox))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
Public Class C1PromptBoxContent _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1PromptBoxContent

See Also

C1PromptBoxContent Members
C1.Silverlight Namespace


C1PromptBoxContent Members

[image] [image]

.NET Framework Class Library
C1PromptBoxContent Members
C1PromptBoxContent Class Constructors Methods Fields Properties Events See Also

The C1PromptBoxContent type exposes the following members.

Constructors

Name | Description
C1PromptBoxContent | Initializes a new instance of a C1PromptBoxContent.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MessageProperty | Identifies the Message dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Message | Gets or sets the message text displayed in the prompt box.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets the text input.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ButtonClick | Event fired when a button is pressed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1PromptBoxContent Constructor

[image]

.NET Framework Class Library
C1PromptBoxContent Constructor
C1PromptBoxContent Class See Also
Initializes a new instance of a C1PromptBoxContent.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1PromptBoxContent()
Visual Basic (Declaration)
Public Sub New

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1PromptBoxContent Fields

[image] [image]

.NET Framework Class Library
C1PromptBoxContent Fields
C1PromptBoxContent Class See Also

The C1PromptBoxContent type exposes the following members.

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MessageProperty | Identifies the Message dependency property.

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1PromptBoxContent..::.IsMouseOverProperty Field
C1PromptBoxContent Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


MessageProperty Field

[image]

.NET Framework Class Library
C1PromptBoxContent..::.MessageProperty Field
C1PromptBoxContent Class See Also
Identifies the Message dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MessageProperty
Visual Basic (Declaration)
Public Shared ReadOnly MessageProperty As DependencyProperty

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1PromptBoxContent Methods

[image] [image]

.NET Framework Class Library
C1PromptBoxContent Methods
C1PromptBoxContent Class See Also

The C1PromptBoxContent type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1PromptBoxContent..::.ChangeVisualStateCommon Method
C1PromptBoxContent Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1PromptBoxContent..::.HitTest Method
C1PromptBoxContent Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1PromptBoxContent Class
C1PromptBoxContent Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1PromptBoxContent..::.OnApplyTemplate Method
C1PromptBoxContent Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1PromptBoxContent Properties

[image] [image]

.NET Framework Class Library
C1PromptBoxContent Properties
C1PromptBoxContent Class See Also

The C1PromptBoxContent type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
Message | Gets or sets the message text displayed in the prompt box.
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets the text input.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1PromptBoxContent..::.IsMouseOver Property
C1PromptBoxContent Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


Message Property

[image]

.NET Framework Class Library
C1PromptBoxContent..::.Message Property
C1PromptBoxContent Class See Also
Gets or sets the message text displayed in the prompt box.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Message { get; set; }
Visual Basic (Declaration)
Public Property Message As String

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


Text Property

[image]

.NET Framework Class Library
C1PromptBoxContent..::.Text Property
C1PromptBoxContent Class See Also
Gets the text input.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Text { get; }
Visual Basic (Declaration)
Public ReadOnly Property Text As String

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1PromptBoxContent Events

[image] [image]

.NET Framework Class Library
C1PromptBoxContent Events
C1PromptBoxContent Class See Also

The C1PromptBoxContent type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ButtonClick | Event fired when a button is pressed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


ButtonClick Event

[image]

.NET Framework Class Library
C1PromptBoxContent..::.ButtonClick Event
C1PromptBoxContent Class See Also
Event fired when a button is pressed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler ButtonClick
Visual Basic (Declaration)
Public Event ButtonClick As EventHandler

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1PromptBoxContent..::.IsMouseOverChanged Event
C1PromptBoxContent Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1PromptBoxContent Class
C1.Silverlight Namespace


C1RangeSlider Class

[image]

.NET Framework Class Library
C1RangeSlider Class
Members See Also
Represents a control that lets the user select two values from a range by moving two Thumb controls along a track.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Root", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "MiddleThumb", Type = typeof(Thumb))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "LowerThumb", Type = typeof(Thumb))]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "DecreaseRepeatButton", Type = typeof(RepeatButton))]
[TemplatePartAttribute(Name = "IncreaseRepeatButton", Type = typeof(RepeatButton))]
[TemplatePartAttribute(Name = "UpperThumb", Type = typeof(Thumb))]
public class C1RangeSlider : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Root", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "MiddleThumb", Type := GetType(Thumb))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "LowerThumb", Type := GetType(Thumb))> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "DecreaseRepeatButton", Type := GetType(RepeatButton))> _
<TemplatePartAttribute(Name := "IncreaseRepeatButton", Type := GetType(RepeatButton))> _
<TemplatePartAttribute(Name := "UpperThumb", Type := GetType(Thumb))> _
Public Class C1RangeSlider _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1RangeSlider

See Also

C1RangeSlider Members
C1.Silverlight Namespace


C1RangeSlider Members

[image] [image]

.NET Framework Class Library
C1RangeSlider Members
C1RangeSlider Class Constructors Methods Fields Properties Events See Also

The C1RangeSlider type exposes the following members.

Constructors

Name | Description
C1RangeSlider | Initializes a new instance of a C1RangeSlider.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnLowerValueChanged | Raises the LowerValueChanged event.
OnUpperValueChanged | Raises the UpperValueChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateTrackLayout | This method will take the current min, max, and value to calculate and layout the current control measurements.

Fields

Name | Description
DelayProperty | Identifies the Delay dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
LowerValueProperty | Identifies the LowerValue dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
UpperValueProperty | Identifies the UpperValue dependency property.
ValueChangeProperty | Identifies the ValueChange dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
Delay | Gets or sets the time, in milliseconds, the RepeatButtons (at the left of the LowerThumb and at the right of the UpperThumb) wait when they are pressed before they start repeating the click action.
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Interval | Gets or sets the time, in milliseconds, between repetitions of the click action, as soon as repeating starts (for the RepeatButtons at the left of the LowerThumb and at the right of the UpperThumb).
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LowerValue | Gets or sets the current lower magnitude of the range control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Gets or sets the maximum possible value of the range element.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Gets or sets the minimum possible value of the range element.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UpperValue | Gets or sets the current upper magnitude of the range control.
ValueChange | Gets or sets a value to be added to or subtracted from the Upper/LowerValue of a RangeBase control.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LowerValueChanged | Fires when the LowerValue property changes.
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
UpperValueChanged | Fires when the UpperValue property changes.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1RangeSlider Constructor

[image]

.NET Framework Class Library
C1RangeSlider Constructor
C1RangeSlider Class See Also
Initializes a new instance of a C1RangeSlider.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1RangeSlider()
Visual Basic (Declaration)
Public Sub New

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1RangeSlider Fields

[image] [image]

.NET Framework Class Library
C1RangeSlider Fields
C1RangeSlider Class See Also

The C1RangeSlider type exposes the following members.

Fields

Name | Description
DelayProperty | Identifies the Delay dependency property.
IntervalProperty | Identifies the Interval dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
LowerValueProperty | Identifies the LowerValue dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
UpperValueProperty | Identifies the UpperValue dependency property.
ValueChangeProperty | Identifies the ValueChange dependency property.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


DelayProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.DelayProperty Field
C1RangeSlider Class See Also
Identifies the Delay dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DelayProperty
Visual Basic (Declaration)
Public Shared ReadOnly DelayProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IntervalProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.IntervalProperty Field
C1RangeSlider Class See Also
Identifies the Interval dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.IsFocusedProperty Field
C1RangeSlider Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.IsMouseOverProperty Field
C1RangeSlider Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


LowerValueProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.LowerValueProperty Field
C1RangeSlider Class See Also
Identifies the LowerValue dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty LowerValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly LowerValueProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


MaximumProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.MaximumProperty Field
C1RangeSlider Class See Also
Identifies the Maximum dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MaximumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


MinimumProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.MinimumProperty Field
C1RangeSlider Class See Also
Identifies the Minimum dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty MinimumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


UpperValueProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.UpperValueProperty Field
C1RangeSlider Class See Also
Identifies the UpperValue dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty UpperValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly UpperValueProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


ValueChangeProperty Field

[image]

.NET Framework Class Library
C1RangeSlider..::.ValueChangeProperty Field
C1RangeSlider Class See Also
Identifies the ValueChange dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ValueChangeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValueChangeProperty As DependencyProperty

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1RangeSlider Methods

[image] [image]

.NET Framework Class Library
C1RangeSlider Methods
C1RangeSlider Class See Also

The C1RangeSlider type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnLowerValueChanged | Raises the LowerValueChanged event.
OnUpperValueChanged | Raises the UpperValueChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateTrackLayout | This method will take the current min, max, and value to calculate and layout the current control measurements.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1RangeSlider..::.ChangeVisualStateCommon Method
C1RangeSlider Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RangeSlider Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1RangeSlider..::.ChangeVisualStateFocus Method
C1RangeSlider Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RangeSlider Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1RangeSlider..::.HitTest Method
C1RangeSlider Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1RangeSlider Class
C1RangeSlider Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1RangeSlider..::.OnApplyTemplate Method
C1RangeSlider Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1RangeSlider Class
C1.Silverlight Namespace


OnLowerValueChanged Method

[image]

.NET Framework Class Library
C1RangeSlider..::.OnLowerValueChanged Method
C1RangeSlider Class See Also
Raises the LowerValueChanged event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnLowerValueChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnLowerValueChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
EventArgs that contains the event data.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


OnUpperValueChanged Method

[image]

.NET Framework Class Library
C1RangeSlider..::.OnUpperValueChanged Method
C1RangeSlider Class See Also
Raises the UpperValueChanged event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnUpperValueChanged(
    EventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnUpperValueChanged ( _
    e As EventArgs _
)

Parameters

e
Type: System..::.EventArgs
EventArgs that contains the event data.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


UpdateTrackLayout Method

[image]

.NET Framework Class Library
C1RangeSlider..::.UpdateTrackLayout Method
C1RangeSlider Class See Also
This method will take the current min, max, and value to calculate and layout the current control measurements.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void UpdateTrackLayout()
Visual Basic (Declaration)
Protected Overridable Sub UpdateTrackLayout

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1RangeSlider Properties

[image] [image]

.NET Framework Class Library
C1RangeSlider Properties
C1RangeSlider Class See Also

The C1RangeSlider type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
Delay | Gets or sets the time, in milliseconds, the RepeatButtons (at the left of the LowerThumb and at the right of the UpperThumb) wait when they are pressed before they start repeating the click action.
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Interval | Gets or sets the time, in milliseconds, between repetitions of the click action, as soon as repeating starts (for the RepeatButtons at the left of the LowerThumb and at the right of the UpperThumb).
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LowerValue | Gets or sets the current lower magnitude of the range control.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Gets or sets the maximum possible value of the range element.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Gets or sets the minimum possible value of the range element.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UpperValue | Gets or sets the current upper magnitude of the range control.
ValueChange | Gets or sets a value to be added to or subtracted from the Upper/LowerValue of a RangeBase control.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1RangeSlider Class
C1.Silverlight Namespace


Delay Property

[image]

.NET Framework Class Library
C1RangeSlider..::.Delay Property
C1RangeSlider Class See Also
Gets or sets the time, in milliseconds, the RepeatButtons (at the left of the LowerThumb and at the right of the UpperThumb) wait when they are pressed before they start repeating the click action.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Delay { get; set; }
Visual Basic (Declaration)
Public Property Delay As Integer

See Also

C1RangeSlider Class
C1.Silverlight Namespace


Interval Property

[image]

.NET Framework Class Library
C1RangeSlider..::.Interval Property
C1RangeSlider Class See Also
Gets or sets the time, in milliseconds, between repetitions of the click action, as soon as repeating starts (for the RepeatButtons at the left of the LowerThumb and at the right of the UpperThumb).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Integer

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1RangeSlider..::.IsFocused Property
C1RangeSlider Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1RangeSlider..::.IsMouseOver Property
C1RangeSlider Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1RangeSlider Class
C1.Silverlight Namespace


LowerValue Property

[image]

.NET Framework Class Library
C1RangeSlider..::.LowerValue Property
C1RangeSlider Class See Also
Gets or sets the current lower magnitude of the range control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double LowerValue { get; set; }
Visual Basic (Declaration)
Public Property LowerValue As Double

See Also

C1RangeSlider Class
C1.Silverlight Namespace


Maximum Property

[image]

.NET Framework Class Library
C1RangeSlider..::.Maximum Property
C1RangeSlider Class See Also
Gets or sets the maximum possible value of the range element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double

See Also

C1RangeSlider Class
C1.Silverlight Namespace


Minimum Property

[image]

.NET Framework Class Library
C1RangeSlider..::.Minimum Property
C1RangeSlider Class See Also
Gets or sets the minimum possible value of the range element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double

See Also

C1RangeSlider Class
C1.Silverlight Namespace


UpperValue Property

[image]

.NET Framework Class Library
C1RangeSlider..::.UpperValue Property
C1RangeSlider Class See Also
Gets or sets the current upper magnitude of the range control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double UpperValue { get; set; }
Visual Basic (Declaration)
Public Property UpperValue As Double

See Also

C1RangeSlider Class
C1.Silverlight Namespace


ValueChange Property

[image]

.NET Framework Class Library
C1RangeSlider..::.ValueChange Property
C1RangeSlider Class See Also
Gets or sets a value to be added to or subtracted from the Upper/LowerValue of a RangeBase control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double ValueChange { get; set; }
Visual Basic (Declaration)
Public Property ValueChange As Double

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1RangeSlider Events

[image] [image]

.NET Framework Class Library
C1RangeSlider Events
C1RangeSlider Class See Also

The C1RangeSlider type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
LowerValueChanged | Fires when the LowerValue property changes.
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
UpperValueChanged | Fires when the UpperValue property changes.

See Also

C1RangeSlider Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1RangeSlider..::.IsMouseOverChanged Event
C1RangeSlider Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1RangeSlider Class
C1.Silverlight Namespace


LowerValueChanged Event

[image]

.NET Framework Class Library
C1RangeSlider..::.LowerValueChanged Event
C1RangeSlider Class See Also
Fires when the LowerValue property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler LowerValueChanged
Visual Basic (Declaration)
Public Event LowerValueChanged As EventHandler

See Also

C1RangeSlider Class
C1.Silverlight Namespace


UpperValueChanged Event

[image]

.NET Framework Class Library
C1RangeSlider..::.UpperValueChanged Event
C1RangeSlider Class See Also
Fires when the UpperValue property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler UpperValueChanged
Visual Basic (Declaration)
Public Event UpperValueChanged As EventHandler

See Also

C1RangeSlider Class
C1.Silverlight Namespace


C1SelectionManager(T) Class

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Class
Members See Also
Provides basic logic to handle item selection using different selection modes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1SelectionManager<T>
Visual Basic (Declaration)
Public Class C1SelectionManager(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1SelectionManager<(Of <(T>)>)

See Also

C1SelectionManager<(Of <(T>)>) Members
C1.Silverlight Namespace


C1SelectionManager(T) Members

[image] [image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Members
C1SelectionManager<(Of <(T>)>) Class Constructors Methods Properties Events See Also

The C1SelectionManager<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
C1SelectionManager<(Of <(T>)>) | Creates an instance of C1SelectionManager.

Methods

Name | Description
ClearSelection | Clears the current selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleSelectionChange | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowMultiRangeSelection | Gets or sets a value indicating if the selection of multiple ranges at the same time are allowed.
SelectedItem | Gets the current selected item (if not in single selection mode returns the last of the SelectedItems.
SelectedItems | Gets the list of current selected items.
SelectionMode | Gets or sets the selection mode used by the C1SelectionManager.

Events

Name | Description
SelectionChanged | Fired when the selection changes.

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


C1SelectionManager(T) Constructor

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Constructor
C1SelectionManager<(Of <(T>)>) Class See Also
Creates an instance of C1SelectionManager.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1SelectionManager(
    C1SelectionManager<(Of <(T>)>)..::.Select setSelected,
    C1SelectionManager<(Of <(T>)>)..::.IsSelected getSelected,
    C1SelectionManager<(Of <(T>)>)..::.GetSelection getSelection
)
Visual Basic (Declaration)
Public Sub New ( _
    setSelected As C1SelectionManager<(Of <(T>)>)..::.Select, _
    getSelected As C1SelectionManager<(Of <(T>)>)..::.IsSelected, _
    getSelection As C1SelectionManager<(Of <(T>)>)..::.GetSelection _
)

Parameters

setSelected
Type: C1.Silverlight..::.C1SelectionManager<(Of <(T>)>)..::.Select
SetIsSelected delegate
getSelected
Type: C1.Silverlight..::.C1SelectionManager<(Of <(T>)>)..::.IsSelected
GetIsSelected delegate
getSelection
Type: C1.Silverlight..::.C1SelectionManager<(Of <(T>)>)..::.GetSelection
GetSelection delegate

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


C1SelectionManager(T) Methods

[image] [image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Methods
C1SelectionManager<(Of <(T>)>) Class See Also

The C1SelectionManager<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
ClearSelection | Clears the current selection.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
HandleSelectionChange | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


ClearSelection Method

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.ClearSelection Method
C1SelectionManager<(Of <(T>)>) Class See Also
Clears the current selection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void ClearSelection()
Visual Basic (Declaration)
Public Sub ClearSelection

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


HandleSelectionChange Method

[image] [image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.HandleSelectionChange Method
C1SelectionManager<(Of <(T>)>) Class See Also

Overload List

Name | Description
HandleSelectionChange(T, Boolean) | Handles the items selection, checks the item current status and updates the selected items.
HandleSelectionChange(T, Boolean, Boolean) | Handles the items selection, checks the item current status and updates the selected items.

See Also

C1SelectionManager<(Of <(T>)>) Class
C1SelectionManager<(Of <(T>)>) Members
C1.Silverlight Namespace


HandleSelectionChange Method (T, Boolean)

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.HandleSelectionChange Method (T, Boolean)
C1SelectionManager<(Of <(T>)>) Class See Also
Handles the items selection, checks the item current status and updates the selected items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void HandleSelectionChange(
    T item,
    bool statusChanged
)
Visual Basic (Declaration)
Public Sub HandleSelectionChange ( _
    item As T, _
    statusChanged As Boolean _
)

Parameters

item
Type: T
The item to handle its selection
statusChanged
Type: System..::.Boolean
A value indicating if the item status (selected/unselected) was already changed outside the C1SelectionManager

See Also

C1SelectionManager<(Of <(T>)>) Class
HandleSelectionChange Overload
C1.Silverlight Namespace


HandleSelectionChange Method (T, Boolean, Boolean)

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.HandleSelectionChange Method (T, Boolean, Boolean)
C1SelectionManager<(Of <(T>)>) Class See Also
Handles the items selection, checks the item current status and updates the selected items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void HandleSelectionChange(
    T item,
    bool statusChanged,
    bool ignoreKeyboard
)
Visual Basic (Declaration)
Public Sub HandleSelectionChange ( _
    item As T, _
    statusChanged As Boolean, _
    ignoreKeyboard As Boolean _
)

Parameters

item
Type: T
The item to handle its selection.
statusChanged
Type: System..::.Boolean
A value indicating if the item status (selected/unselected) was already changed outside the C1SelectionManager.
ignoreKeyboard
Type: System..::.Boolean
If true, the pressed key will be ignored.

See Also

C1SelectionManager<(Of <(T>)>) Class
HandleSelectionChange Overload
C1.Silverlight Namespace


C1SelectionManager(T) Properties

[image] [image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Properties
C1SelectionManager<(Of <(T>)>) Class See Also

The C1SelectionManager<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
AllowMultiRangeSelection | Gets or sets a value indicating if the selection of multiple ranges at the same time are allowed.
SelectedItem | Gets the current selected item (if not in single selection mode returns the last of the SelectedItems.
SelectedItems | Gets the list of current selected items.
SelectionMode | Gets or sets the selection mode used by the C1SelectionManager.

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


AllowMultiRangeSelection Property

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.AllowMultiRangeSelection Property
C1SelectionManager<(Of <(T>)>) Class See Also
Gets or sets a value indicating if the selection of multiple ranges at the same time are allowed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AllowMultiRangeSelection { get; set; }
Visual Basic (Declaration)
Public Property AllowMultiRangeSelection As Boolean

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


SelectedItem Property

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.SelectedItem Property
C1SelectionManager<(Of <(T>)>) Class See Also
Gets the current selected item (if not in single selection mode returns the last of the SelectedItems.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public T SelectedItem { get; private set; }
Visual Basic (Declaration)
Public Property SelectedItem As T

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


SelectedItems Property

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.SelectedItems Property
C1SelectionManager<(Of <(T>)>) Class See Also
Gets the list of current selected items.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IList<T> SelectedItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property SelectedItems As IList(Of T)

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


SelectionMode Property

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.SelectionMode Property
C1SelectionManager<(Of <(T>)>) Class See Also
Gets or sets the selection mode used by the C1SelectionManager.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As C1SelectionMode

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


C1SelectionManager(T) Events

[image] [image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>) Events
C1SelectionManager<(Of <(T>)>) Class See Also

The C1SelectionManager<(Of <(T>)>) type exposes the following members.

Events

Name | Description
SelectionChanged | Fired when the selection changes.

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


SelectionChanged Event

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.SelectionChanged Event
C1SelectionManager<(Of <(T>)>) Class See Also
Fired when the selection changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event SelectionChangedEventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler

See Also

C1SelectionManager<(Of <(T>)>) Class
C1.Silverlight Namespace


C1SelectionManager(T).GetSelection Delegate

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.GetSelection Delegate
C1SelectionManager<(Of <(T>)>) Class See Also
Retrieves all the items that are comprised between the startItem and the endItem. Used when making a consecutive selection.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public delegate IList<T> GetSelection(
    T startItem,
    T endItem
)
Visual Basic (Declaration)
Public Delegate Function GetSelection ( _
    startItem As T, _
    endItem As T _
) As IList(Of T)

Parameters

startItem
Type: T
The first item in the selection
endItem
Type: T
The last item in the selection

Return Value

A list of items that are comprised between the start and end items

See Also

C1.Silverlight Namespace


C1SelectionManager(T).IsSelected Delegate

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.IsSelected Delegate
C1SelectionManager<(Of <(T>)>) Class See Also
Used to get the current state of an item (selected/unselected).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public delegate bool IsSelected(
    T item
)
Visual Basic (Declaration)
Public Delegate Function IsSelected ( _
    item As T _
) As Boolean

Parameters

item
Type: T
The item to get the state

Return Value

True if the item is selected, False otherwise

See Also

C1.Silverlight Namespace


C1SelectionManager(T).Select Delegate

[image]

.NET Framework Class Library
C1SelectionManager<(Of <(T>)>)..::.Select Delegate
C1SelectionManager<(Of <(T>)>) Class See Also
Used to set an item as selected/unselected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public delegate void Select(
    T item,
    bool value
)
Visual Basic (Declaration)
Public Delegate Sub Select ( _
    item As T, _
    value As Boolean _
)

Parameters

item
Type: T
The item to mark as selected/unselected
value
Type: System..::.Boolean
The value to set

See Also

C1.Silverlight Namespace


C1SelectionMode Enumeration

[image]

.NET Framework Class Library
C1SelectionMode Enumeration
See Also
Defines the selection behavior for a control which supports the SelectionMode property like C1treeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum C1SelectionMode
Visual Basic (Declaration)
Public Enumeration C1SelectionMode

Members

Member name | Description
None | The user can not select any item.
Single | The user can select only one item at a time.
Multiple | The user can select multiple items without holding down a modifier key.
Extended | The user can select multiple consecutive items while holding down the corresponding modifier key.

See Also

C1.Silverlight Namespace


C1Separator Class

[image]

.NET Framework Class Library
C1Separator Class
Members See Also
Control that is used to separate items in menus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
public class C1Separator : Control
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
Public Class C1Separator _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight..::.C1Separator

See Also

C1Separator Members
C1.Silverlight Namespace


C1Separator Members

[image] [image]

.NET Framework Class Library
C1Separator Members
C1Separator Class Constructors Methods Fields Properties Events See Also

The C1Separator type exposes the following members.

Constructors

Name | Description
C1Separator | Initializes a new instance of a C1Separator.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
FirstLevelTemplateProperty | Identifies the FirstLevelTemplate dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FirstLevelTemplate | Represents the template to apply to all separator items used in the first level of the menu.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Separator Class
C1.Silverlight Namespace


C1Separator Constructor

[image]

.NET Framework Class Library
C1Separator Constructor
C1Separator Class See Also
Initializes a new instance of a C1Separator.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1Separator()
Visual Basic (Declaration)
Public Sub New

See Also

C1Separator Class
C1.Silverlight Namespace


C1Separator Fields

[image] [image]

.NET Framework Class Library
C1Separator Fields
C1Separator Class See Also

The C1Separator type exposes the following members.

Fields

Name | Description
FirstLevelTemplateProperty | Identifies the FirstLevelTemplate dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1Separator Class
C1.Silverlight Namespace


FirstLevelTemplateProperty Field

[image]

.NET Framework Class Library
C1Separator..::.FirstLevelTemplateProperty Field
C1Separator Class See Also
Identifies the FirstLevelTemplate dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FirstLevelTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly FirstLevelTemplateProperty As DependencyProperty

See Also

C1Separator Class
C1.Silverlight Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Separator..::.IsMouseOverProperty Field
C1Separator Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Separator Class
C1.Silverlight Namespace


C1Separator Methods

[image] [image]

.NET Framework Class Library
C1Separator Methods
C1Separator Class See Also

The C1Separator type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Separator Class
C1.Silverlight Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Separator..::.ChangeVisualStateCommon Method
C1Separator Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Separator Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Separator..::.HitTest Method
C1Separator Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Separator Class
C1Separator Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Separator..::.OnApplyTemplate Method
C1Separator Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Separator Class
C1.Silverlight Namespace


C1Separator Properties

[image] [image]

.NET Framework Class Library
C1Separator Properties
C1Separator Class See Also

The C1Separator type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FirstLevelTemplate | Represents the template to apply to all separator items used in the first level of the menu.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Separator Class
C1.Silverlight Namespace


FirstLevelTemplate Property

[image]

.NET Framework Class Library
C1Separator..::.FirstLevelTemplate Property
C1Separator Class See Also
Represents the template to apply to all separator items used in the first level of the menu.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public ControlTemplate FirstLevelTemplate { get; set; }
Visual Basic (Declaration)
Public Property FirstLevelTemplate As ControlTemplate

See Also

C1Separator Class
C1.Silverlight Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Separator..::.IsMouseOver Property
C1Separator Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Separator Class
C1.Silverlight Namespace


C1Separator Events

[image] [image]

.NET Framework Class Library
C1Separator Events
C1Separator Class See Also

The C1Separator type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Separator Class
C1.Silverlight Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Separator..::.IsMouseOverChanged Event
C1Separator Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Separator Class
C1.Silverlight Namespace


C1StyleSelector Class

[image]

.NET Framework Class Library
C1StyleSelector Class
Members See Also
Provides a way to apply styles based on custom logic.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1StyleSelector
Visual Basic (Declaration)
Public Class C1StyleSelector

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.C1StyleSelector

See Also

C1StyleSelector Members
C1.Silverlight Namespace


C1StyleSelector Members

[image] [image]

.NET Framework Class Library
C1StyleSelector Members
C1StyleSelector Class Constructors Methods See Also

The C1StyleSelector type exposes the following members.

Constructors

Name | Description
C1StyleSelector |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectStyle | When overridden in a derived class, returns a Style based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1StyleSelector Class
C1.Silverlight Namespace


C1StyleSelector Constructor

[image]

.NET Framework Class Library
C1StyleSelector Constructor
C1StyleSelector Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1StyleSelector()
Visual Basic (Declaration)
Public Sub New

See Also

C1StyleSelector Class
C1.Silverlight Namespace


C1StyleSelector Methods

[image] [image]

.NET Framework Class Library
C1StyleSelector Methods
C1StyleSelector Class See Also

The C1StyleSelector type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SelectStyle | When overridden in a derived class, returns a Style based on custom logic.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1StyleSelector Class
C1.Silverlight Namespace


SelectStyle Method

[image]

.NET Framework Class Library
C1StyleSelector..::.SelectStyle Method
C1StyleSelector Class See Also
When overridden in a derived class, returns a Style based on custom logic.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public virtual Style SelectStyle(
    Object item,
    DependencyObject container
)
Visual Basic (Declaration)
Public Overridable Function SelectStyle ( _
    item As Object, _
    container As DependencyObject _
) As Style

Parameters

item
Type: System..::.Object
The content.
container
Type: System.Windows..::.DependencyObject
The element to which the style will be applied.

Return Value

Returns an application-specific style to apply; otherwise, null.

See Also

C1StyleSelector Class
C1.Silverlight Namespace


C1TextBoxBase Class

[image]

.NET Framework Class Library
C1TextBoxBase Class
Members See Also
Base class for all ComponentOne text box controls.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Watermark", Type = typeof(ContentControl))]
[TemplatePartAttribute(Name = "ContentElement", Type = typeof(ScrollViewer))]
[TemplatePartAttribute(Name = "FocusVisual", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Unwatermarked", GroupName = "WatermarkStates")]
[TemplateVisualStateAttribute(Name = "Watermarked", GroupName = "WatermarkStates")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class C1TextBoxBase : TextBox
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Watermark", Type := GetType(ContentControl))> _
<TemplatePartAttribute(Name := "ContentElement", Type := GetType(ScrollViewer))> _
<TemplatePartAttribute(Name := "FocusVisual", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Unwatermarked", GroupName := "WatermarkStates")> _
<TemplateVisualStateAttribute(Name := "Watermarked", GroupName := "WatermarkStates")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Class C1TextBoxBase _
    Inherits TextBox

Remarks

Adds Watermark and IsEnabled()()() properties, as well as styles for mouse over and focus.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.TextBox
C1.Silverlight..::.C1TextBoxBase
C1.Silverlight..::.C1MaskedTextBox

See Also

C1TextBoxBase Members
C1.Silverlight Namespace


C1TextBoxBase Members

[image] [image]

.NET Framework Class Library
C1TextBoxBase Members
C1TextBoxBase Class Constructors Methods Fields Properties Events See Also

The C1TextBoxBase type exposes the following members.

Constructors

Name | Description
C1TextBoxBase | Initializes a new instance of a C1TextBoxBase.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from TextBox.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateWatermark |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsFocusedChanged | Callback called when the IsFocused property changes.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsWatermarkedProperty | Identifies the IsWatermarked dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
IsWatermarked | Get or sets if the watermark is shown.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the content of the watermark.
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextBoxBase Constructor

[image]

.NET Framework Class Library
C1TextBoxBase Constructor
C1TextBoxBase Class See Also
Initializes a new instance of a C1TextBoxBase.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TextBoxBase()
Visual Basic (Declaration)
Public Sub New

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextBoxBase Fields

[image] [image]

.NET Framework Class Library
C1TextBoxBase Fields
C1TextBoxBase Class See Also

The C1TextBoxBase type exposes the following members.

Fields

Name | Description
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsWatermarkedProperty | Identifies the IsWatermarked dependency property.
WatermarkProperty | Identifies the Watermark dependency property.

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1TextBoxBase..::.DisabledStyleProperty Field
C1TextBoxBase Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1TextBoxBase..::.FocusStyleProperty Field
C1TextBoxBase Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1TextBoxBase..::.IsFocusedProperty Field
C1TextBoxBase Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


IsWatermarkedProperty Field

[image]

.NET Framework Class Library
C1TextBoxBase..::.IsWatermarkedProperty Field
C1TextBoxBase Class See Also
Identifies the IsWatermarked dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsWatermarkedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsWatermarkedProperty As DependencyProperty

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


WatermarkProperty Field

[image]

.NET Framework Class Library
C1TextBoxBase..::.WatermarkProperty Field
C1TextBoxBase Class See Also
Identifies the Watermark dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty WatermarkProperty
Visual Basic (Declaration)
Public Shared ReadOnly WatermarkProperty As DependencyProperty

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextBoxBase Methods

[image] [image]

.NET Framework Class Library
C1TextBoxBase Methods
C1TextBoxBase Class See Also

The C1TextBoxBase type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from TextBox.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateWatermark |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsFocusedChanged | Callback called when the IsFocused property changes.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Select | (Inherited from TextBox.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


ChangeVisualStateWatermark Method

[image]

.NET Framework Class Library
C1TextBoxBase..::.ChangeVisualStateWatermark Method
C1TextBoxBase Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateWatermark(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateWatermark ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1TextBoxBase..::.HitTest Method
C1TextBoxBase Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1TextBoxBase Class
C1TextBoxBase Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1TextBoxBase..::.OnApplyTemplate Method
C1TextBoxBase Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


OnIsFocusedChanged Method

[image]

.NET Framework Class Library
C1TextBoxBase..::.OnIsFocusedChanged Method
C1TextBoxBase Class See Also
Callback called when the IsFocused property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnIsFocusedChanged(
    bool oldValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnIsFocusedChanged ( _
    oldValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean
The previous value of IsFocused.

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextBoxBase Properties

[image] [image]

.NET Framework Class Library
C1TextBoxBase Properties
C1TextBoxBase Class See Also

The C1TextBoxBase type exposes the following members.

Properties

Name | Description
AcceptsReturn | (Inherited from TextBox.)
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontSource | (Inherited from TextBox.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | (Inherited from TextBox.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsReadOnly | (Inherited from TextBox.)
IsTabStop | (Inherited from Control.)
IsWatermarked | Get or sets if the watermark is shown.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxLength | (Inherited from TextBox.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedText | (Inherited from TextBox.)
SelectionBackground | (Inherited from TextBox.)
SelectionForeground | (Inherited from TextBox.)
SelectionLength | (Inherited from TextBox.)
SelectionStart | (Inherited from TextBox.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | (Inherited from TextBox.)
TextAlignment | (Inherited from TextBox.)
TextWrapping | (Inherited from TextBox.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | (Inherited from TextBox.)
Visibility | (Inherited from UIElement.)
Watermark | Gets or sets the content of the watermark.
Width | (Inherited from FrameworkElement.)

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1TextBoxBase..::.DisabledStyle Property
C1TextBoxBase Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1TextBoxBase..::.FocusStyle Property
C1TextBoxBase Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1TextBoxBase..::.IsFocused Property
C1TextBoxBase Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; private set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


IsWatermarked Property

[image]

.NET Framework Class Library
C1TextBoxBase..::.IsWatermarked Property
C1TextBoxBase Class See Also
Get or sets if the watermark is shown.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsWatermarked { get; internal set; }
Visual Basic (Declaration)
Public Property IsWatermarked As Boolean

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


Watermark Property

[image]

.NET Framework Class Library
C1TextBoxBase..::.Watermark Property
C1TextBoxBase Class See Also
Gets or sets the content of the watermark.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Watermark { get; set; }
Visual Basic (Declaration)
Public Property Watermark As Object

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextBoxBase Events

[image] [image]

.NET Framework Class Library
C1TextBoxBase Events
C1TextBoxBase Class See Also

The C1TextBoxBase type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | (Inherited from TextBox.)
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | (Inherited from TextBox.)

See Also

C1TextBoxBase Class
C1.Silverlight Namespace


C1TextEditableContentControl Class

[image]

.NET Framework Class Library
C1TextEditableContentControl Class
Members See Also
Dual control that provides a TextBox on edit mode, and a ContentControl on readonly mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "EditControl", Type = typeof(C1TextBoxBase))]
[TemplatePartAttribute(Name = "ContentControl", Type = typeof(ContentPresenter))]
public class C1TextEditableContentControl : C1EditableContentControl
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "EditControl", Type := GetType(C1TextBoxBase))> _
<TemplatePartAttribute(Name := "ContentControl", Type := GetType(ContentPresenter))> _
Public Class C1TextEditableContentControl _
    Inherits C1EditableContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1EditableContentControl
C1.Silverlight..::.C1TextEditableContentControl

See Also

C1TextEditableContentControl Members
C1.Silverlight Namespace


C1TextEditableContentControl Members

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl Members
C1TextEditableContentControl Class Constructors Methods Fields Properties Events See Also

The C1TextEditableContentControl type exposes the following members.

Constructors

Name | Description
C1TextEditableContentControl | Initializes a new instance of a C1TextEditableContentControl.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1EditableContentControl.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1EditableContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCanceled | (Overrides C1EditableContentControl..::.OnEditCanceled()()().)
OnEditCompleted | Fires the EditCompleted event. (Inherited from C1EditableContentControl.)
OnEditStarted | Fires the EditStarted event. (Inherited from C1EditableContentControl.)
OnIsEditableChanged | The IsEditable value has changed. (Inherited from C1EditableContentControl.)
OnIsEnabledChanged | (Inherited from ContentControl.)
OnIsInEditModeChanged | (Overrides C1EditableContentControl..::.OnIsInEditModeChanged(Boolean).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldEnterEditModeOnKeyDown | (Overrides C1EditableContentControl..::.ShouldEnterEditModeOnKeyDown(Key).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateVisualState | Update the visual state of this control (Inherited from C1EditableContentControl.)

Fields

Name | Description
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentControl | Control visible when it is not in edit mode. (Inherited from C1EditableContentControl.)
ContentConverter | Used to create the control content from the edited content. (Inherited from C1EditableContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
EditControl | Control visible when it is in edit mode. (Inherited from C1EditableContentControl.)
EditTextBox | C1TextBoxBase used during the edit mode.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirty | (Overrides C1EditableContentControl..::.IsDirty.)
IsEditable | Gets/set if the control can be edited. (Inherited from C1EditableContentControl.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets/sets when the control enters in edit mode. (Inherited from C1EditableContentControl.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1EditableContentControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1TextEditableContentControl.
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCanceled | Fired when the user exits edit mode without changes. (Inherited from C1EditableContentControl.)
EditCompleted | Fired when the user has completed the edits. (Inherited from C1EditableContentControl.)
EditStarted | Fired when the control enters edit mode. (Inherited from C1EditableContentControl.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1EditableContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
TextBoxKeyDown | Event fired when a key is pressed in the EditableTextBox.
TextBoxKeyUp | Event fired when a key is released in the EditableTextBox.
TextEdited | Event fired to do when the text is edited in the EditableTextBox.
ValidateInput | Event fired when the editing is completed. Handle this event to validate the new input.

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TextEditableContentControl Constructor

[image]

.NET Framework Class Library
C1TextEditableContentControl Constructor
C1TextEditableContentControl Class See Also
Initializes a new instance of a C1TextEditableContentControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TextEditableContentControl()
Visual Basic (Declaration)
Public Sub New

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TextEditableContentControl Fields

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl Fields
C1TextEditableContentControl Class See Also

The C1TextEditableContentControl type exposes the following members.

Fields

Name | Description
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.DisabledStyleProperty Field
C1TextEditableContentControl Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.FocusStyleProperty Field
C1TextEditableContentControl Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.TextAlignmentProperty Field
C1TextEditableContentControl Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TextEditableContentControl Methods

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl Methods
C1TextEditableContentControl Class See Also

The C1TextEditableContentControl type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1EditableContentControl.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1EditableContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Overrides ContentControl..::.OnContentChanged(Object, Object).)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnEditCanceled | (Overrides C1EditableContentControl..::.OnEditCanceled()()().)
OnEditCompleted | Fires the EditCompleted event. (Inherited from C1EditableContentControl.)
OnEditStarted | Fires the EditStarted event. (Inherited from C1EditableContentControl.)
OnIsEditableChanged | The IsEditable value has changed. (Inherited from C1EditableContentControl.)
OnIsEnabledChanged | (Inherited from ContentControl.)
OnIsInEditModeChanged | (Overrides C1EditableContentControl..::.OnIsInEditModeChanged(Boolean).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldEnterEditModeOnKeyDown | (Overrides C1EditableContentControl..::.ShouldEnterEditModeOnKeyDown(Key).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)
UpdateVisualState | Update the visual state of this control (Inherited from C1EditableContentControl.)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl..::.HitTest Method
C1TextEditableContentControl Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1TextEditableContentControl Class
C1TextEditableContentControl Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.OnApplyTemplate Method
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


OnContentChanged Method

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.OnContentChanged Method
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnContentChanged(
    Object oldContent,
    Object newContent
)
Visual Basic (Declaration)
Protected Overrides Sub OnContentChanged ( _
    oldContent As Object, _
    newContent As Object _
)

Parameters

oldContent
Type: System..::.Object
newContent
Type: System..::.Object

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


OnEditCanceled Method

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.OnEditCanceled Method
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnEditCanceled()
Visual Basic (Declaration)
Protected Overrides Sub OnEditCanceled

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


OnIsInEditModeChanged Method

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.OnIsInEditModeChanged Method
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnIsInEditModeChanged(
    bool oldValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnIsInEditModeChanged ( _
    oldValue As Boolean _
)

Parameters

oldValue
Type: System..::.Boolean

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


ShouldEnterEditModeOnKeyDown Method

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.ShouldEnterEditModeOnKeyDown Method
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool ShouldEnterEditModeOnKeyDown(
    Key key
)
Visual Basic (Declaration)
Protected Overrides Function ShouldEnterEditModeOnKeyDown ( _
    key As Key _
) As Boolean

Parameters

key
Type: System.Windows.Input..::.Key

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TextEditableContentControl Properties

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl Properties
C1TextEditableContentControl Class See Also

The C1TextEditableContentControl type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentControl | Control visible when it is not in edit mode. (Inherited from C1EditableContentControl.)
ContentConverter | Used to create the control content from the edited content. (Inherited from C1EditableContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
EditControl | Control visible when it is in edit mode. (Inherited from C1EditableContentControl.)
EditTextBox | C1TextBoxBase used during the edit mode.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDirty | (Overrides C1EditableContentControl..::.IsDirty.)
IsEditable | Gets/set if the control can be edited. (Inherited from C1EditableContentControl.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsInEditMode | Gets/sets when the control enters in edit mode. (Inherited from C1EditableContentControl.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1EditableContentControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets how the text should be aligned in the C1TextEditableContentControl.
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.DisabledStyle Property
C1TextEditableContentControl Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


EditTextBox Property

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.EditTextBox Property
C1TextEditableContentControl Class See Also
C1TextBoxBase used during the edit mode.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TextBoxBase EditTextBox { get; }
Visual Basic (Declaration)
Public ReadOnly Property EditTextBox As C1TextBoxBase

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.FocusStyle Property
C1TextEditableContentControl Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


IsDirty Property

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.IsDirty Property
C1TextEditableContentControl Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsDirty As Boolean

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.TextAlignment Property
C1TextEditableContentControl Class See Also
Gets or sets how the text should be aligned in the C1TextEditableContentControl.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TextEditableContentControl Events

[image] [image]

.NET Framework Class Library
C1TextEditableContentControl Events
C1TextEditableContentControl Class See Also

The C1TextEditableContentControl type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
EditCanceled | Fired when the user exits edit mode without changes. (Inherited from C1EditableContentControl.)
EditCompleted | Fired when the user has completed the edits. (Inherited from C1EditableContentControl.)
EditStarted | Fired when the control enters edit mode. (Inherited from C1EditableContentControl.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1EditableContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
TextBoxKeyDown | Event fired when a key is pressed in the EditableTextBox.
TextBoxKeyUp | Event fired when a key is released in the EditableTextBox.
TextEdited | Event fired to do when the text is edited in the EditableTextBox.
ValidateInput | Event fired when the editing is completed. Handle this event to validate the new input.

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


TextBoxKeyDown Event

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.TextBoxKeyDown Event
C1TextEditableContentControl Class See Also
Event fired when a key is pressed in the EditableTextBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<KeyEventArgs> TextBoxKeyDown
Visual Basic (Declaration)
Public Event TextBoxKeyDown As EventHandler(Of KeyEventArgs)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


TextBoxKeyUp Event

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.TextBoxKeyUp Event
C1TextEditableContentControl Class See Also
Event fired when a key is released in the EditableTextBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<KeyEventArgs> TextBoxKeyUp
Visual Basic (Declaration)
Public Event TextBoxKeyUp As EventHandler(Of KeyEventArgs)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


TextEdited Event

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.TextEdited Event
C1TextEditableContentControl Class See Also
Event fired to do when the text is edited in the EditableTextBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<TextEditedEventArgs> TextEdited
Visual Basic (Declaration)
Public Event TextEdited As EventHandler(Of TextEditedEventArgs)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


ValidateInput Event

[image]

.NET Framework Class Library
C1TextEditableContentControl..::.ValidateInput Event
C1TextEditableContentControl Class See Also
Event fired when the editing is completed. Handle this event to validate the new input.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<ValidateInputEventArgs> ValidateInput
Visual Basic (Declaration)
Public Event ValidateInput As EventHandler(Of ValidateInputEventArgs)

See Also

C1TextEditableContentControl Class
C1.Silverlight Namespace


C1TreeView Class

[image]

.NET Framework Class Library
C1TreeView Class
Members See Also
Represents a control that displays hierarchical data in a tree structure that has items that can expand and collapse.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Scroll", Type = typeof(ScrollViewer))]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
public class C1TreeView : C1HierarchicalPresenter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Scroll", Type := GetType(ScrollViewer))> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
Public Class C1TreeView _
    Inherits C1HierarchicalPresenter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1HierarchicalPresenter
C1.Silverlight..::.C1TreeView

See Also

C1TreeView Members
C1.Silverlight Namespace


C1TreeView Members

[image] [image]

.NET Framework Class Library
C1TreeView Members
C1TreeView Class Constructors Methods Fields Properties Events See Also

The C1TreeView type exposes the following members.

Constructors

Name | Description
C1TreeView | Initializes a new instance of a C1TreeView.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides C1ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Returns the first item that matches exactly with the text used as search parameter
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides C1HierarchicalPresenter..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNode | Gets the nearest C1TreeViewItem to the specified location.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy. (Inherited from C1HierarchicalPresenter.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element. (Inherited from C1HierarchicalPresenter.)
IsItemItsOwnContainerOverride | (Overrides C1HierarchicalPresenter..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDragDrop | Raises the DragDrop event.
OnDragOver | Raises the DragOver event.
OnDragStart | Raises the DragStart event.
OnItemClicked | Raises the ItemClicked event.
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowDragDropProperty | Identifies the AllowDragDrop dependency property.
AutoSearchProperty | Identifies the AutoSearch dependency property.
AutoSearchResetDelayProperty | Identifies the AutoSearchResetDelay dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
KeyboardNavigationProperty | Identifies the KeyboardNavigation dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedItemsProperty | Identifies the SelectedItems dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDragDrop | Gets or sets a value indicating whether this C1TreeView allows drag-and-drop operations.
AutoSearch | Enables or disables the AutoSearch functionality of the C1TreeView.
AutoSearchResetDelay | Gets or Sets a value for the delay (in milliseconds) used in the keyboard search.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control. (Inherited from C1HierarchicalPresenter.)
HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from C1HierarchicalPresenter.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used. (Inherited from C1HierarchicalPresenter.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
KeyboardNavigation | Enables or disables the Keyboard navigation functionality of the C1TreeView.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentCollection | Gets the items collection of this element's parent. (Inherited from C1HierarchicalPresenter.)
ParentItemsSource | Returns this element's parent ItemsSource Property. (Inherited from C1HierarchicalPresenter.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedItem | Gets the selected item in a C1TreeView.
SelectedItems | Gets the selected items in a C1TreeView (when in Multiple Selection mode).
SelectionMode | Gets or sets the selection behavior for a C1TreeView.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragDrop | Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.
DragOver | Fires during a drag drop process, when the cursor moves over a registered drop target.
DragStart | Fires when a drag drop process starts.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
ItemClicked | Occurs when a C1TreeViewItem is clicked.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | Occurs when the current selection changes.
SelectionModeChanged | Event raised when the SelectionMode property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeView Constructor

[image]

.NET Framework Class Library
C1TreeView Constructor
C1TreeView Class See Also
Initializes a new instance of a C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeView()
Visual Basic (Declaration)
Public Sub New

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeView Fields

[image] [image]

.NET Framework Class Library
C1TreeView Fields
C1TreeView Class See Also

The C1TreeView type exposes the following members.

Fields

Name | Description
AllowDragDropProperty | Identifies the AllowDragDrop dependency property.
AutoSearchProperty | Identifies the AutoSearch dependency property.
AutoSearchResetDelayProperty | Identifies the AutoSearchResetDelay dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
KeyboardNavigationProperty | Identifies the KeyboardNavigation dependency property.
SelectedItemProperty | Identifies the SelectedItem dependency property.
SelectedItemsProperty | Identifies the SelectedItems dependency property.
SelectionModeProperty | Identifies the SelectionMode dependency property.

See Also

C1TreeView Class
C1.Silverlight Namespace


AllowDragDropProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.AllowDragDropProperty Field
C1TreeView Class See Also
Identifies the AllowDragDrop dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AllowDragDropProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowDragDropProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


AutoSearchProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.AutoSearchProperty Field
C1TreeView Class See Also
Identifies the AutoSearch dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AutoSearchProperty
Visual Basic (Declaration)
Public Shared ReadOnly AutoSearchProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


AutoSearchResetDelayProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.AutoSearchResetDelayProperty Field
C1TreeView Class See Also
Identifies the AutoSearchResetDelay dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty AutoSearchResetDelayProperty
Visual Basic (Declaration)
Public Shared ReadOnly AutoSearchResetDelayProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.DisabledStyleProperty Field
C1TreeView Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.FocusStyleProperty Field
C1TreeView Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.IsFocusedProperty Field
C1TreeView Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


KeyboardNavigationProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.KeyboardNavigationProperty Field
C1TreeView Class See Also
Identifies the KeyboardNavigation dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty KeyboardNavigationProperty
Visual Basic (Declaration)
Public Shared ReadOnly KeyboardNavigationProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectedItemProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.SelectedItemProperty Field
C1TreeView Class See Also
Identifies the SelectedItem dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectedItemsProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.SelectedItemsProperty Field
C1TreeView Class See Also
Identifies the SelectedItems dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemsProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectionModeProperty Field

[image]

.NET Framework Class Library
C1TreeView..::.SelectionModeProperty Field
C1TreeView Class See Also
Identifies the SelectionMode dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeView Methods

[image] [image]

.NET Framework Class Library
C1TreeView Methods
C1TreeView Class See Also

The C1TreeView type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides C1ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindItem | Returns the first item that matches exactly with the text used as search parameter
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides C1HierarchicalPresenter..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetNode | Gets the nearest C1TreeViewItem to the specified location.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy. (Inherited from C1HierarchicalPresenter.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element. (Inherited from C1HierarchicalPresenter.)
IsItemItsOwnContainerOverride | (Overrides C1HierarchicalPresenter..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnDragDrop | Raises the DragDrop event.
OnDragOver | Raises the DragOver event.
OnDragStart | Raises the DragStart event.
OnItemClicked | Raises the ItemClicked event.
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1TreeView Class
C1.Silverlight Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1TreeView..::.ChangeVisualStateFocus Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1TreeView Class
C1.Silverlight Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeView..::.ClearContainerForItemOverride Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1TreeView Class
C1.Silverlight Namespace


FindItem Method

[image]

.NET Framework Class Library
C1TreeView..::.FindItem Method
C1TreeView Class See Also
Returns the first item that matches exactly with the text used as search parameter

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem FindItem(
    string text
)
Visual Basic (Declaration)
Public Function FindItem ( _
    text As String _
) As C1TreeViewItem

Parameters

text
Type: System..::.String
The text to search for

Return Value

The item that matched the search parameter, null otherwise

See Also

C1TreeView Class
C1.Silverlight Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeView..::.GetContainerForItemOverride Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1TreeView Class
C1.Silverlight Namespace


GetNode Method

[image]

.NET Framework Class Library
C1TreeView..::.GetNode Method
C1TreeView Class See Also
Gets the nearest C1TreeViewItem to the specified location.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem GetNode(
    Point position
)
Visual Basic (Declaration)
Public Function GetNode ( _
    position As Point _
) As C1TreeViewItem

Parameters

position
Type: System.Windows..::.Point
The location.

Return Value

The nearest C1TreeViewItem.

See Also

C1TreeView Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1TreeView..::.HitTest Method
C1TreeView Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1TreeView Class
C1TreeView Members
C1.Silverlight Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1TreeView..::.IsItemItsOwnContainerOverride Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1TreeView Class
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1TreeView..::.OnApplyTemplate Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1TreeView Class
C1.Silverlight Namespace


OnDragDrop Method

[image]

.NET Framework Class Library
C1TreeView..::.OnDragDrop Method
C1TreeView Class See Also
Raises the DragDrop event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragDrop(
    Object source,
    DragDropEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragDrop ( _
    source As Object, _
    e As DragDropEventArgs _
)

Parameters

source
Type: System..::.Object
Used to set the source of the event.
e
Type: C1.Silverlight..::.DragDropEventArgs
DragDropEventArgs that contains the event data.

See Also

C1TreeView Class
C1.Silverlight Namespace


OnDragOver Method

[image]

.NET Framework Class Library
C1TreeView..::.OnDragOver Method
C1TreeView Class See Also
Raises the DragOver event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragOver(
    Object source,
    DragDropEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragOver ( _
    source As Object, _
    e As DragDropEventArgs _
)

Parameters

source
Type: System..::.Object
Used to set the source of the event.
e
Type: C1.Silverlight..::.DragDropEventArgs
DragDropEventArgs that contains the event data.

See Also

C1TreeView Class
C1.Silverlight Namespace


OnDragStart Method

[image]

.NET Framework Class Library
C1TreeView..::.OnDragStart Method
C1TreeView Class See Also
Raises the DragStart event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnDragStart(
    Object source,
    DragDropEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnDragStart ( _
    source As Object, _
    e As DragDropEventArgs _
)

Parameters

source
Type: System..::.Object
Used to set the source of the event.
e
Type: C1.Silverlight..::.DragDropEventArgs
DragDropEventArgs that contains the event data.

See Also

C1TreeView Class
C1.Silverlight Namespace


OnItemClicked Method

[image]

.NET Framework Class Library
C1TreeView..::.OnItemClicked Method
C1TreeView Class See Also
Raises the ItemClicked event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnItemClicked(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnItemClicked ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeView Class
C1.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeView..::.PrepareContainerForItemOverride Method
C1TreeView Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeView Properties

[image] [image]

.NET Framework Class Library
C1TreeView Properties
C1TreeView Class See Also

The C1TreeView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowDragDrop | Gets or sets a value indicating whether this C1TreeView allows drag-and-drop operations.
AutoSearch | Enables or disables the AutoSearch functionality of the C1TreeView.
AutoSearchResetDelay | Gets or Sets a value for the delay (in milliseconds) used in the keyboard search.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control. (Inherited from C1HierarchicalPresenter.)
HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from C1HierarchicalPresenter.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used. (Inherited from C1HierarchicalPresenter.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
KeyboardNavigation | Enables or disables the Keyboard navigation functionality of the C1TreeView.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentCollection | Gets the items collection of this element's parent. (Inherited from C1HierarchicalPresenter.)
ParentItemsSource | Returns this element's parent ItemsSource Property. (Inherited from C1HierarchicalPresenter.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedItem | Gets the selected item in a C1TreeView.
SelectedItems | Gets the selected items in a C1TreeView (when in Multiple Selection mode).
SelectionMode | Gets or sets the selection behavior for a C1TreeView.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1TreeView Class
C1.Silverlight Namespace


AllowDragDrop Property

[image]

.NET Framework Class Library
C1TreeView..::.AllowDragDrop Property
C1TreeView Class See Also
Gets or sets a value indicating whether this C1TreeView allows drag-and-drop operations.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AllowDragDrop { get; set; }
Visual Basic (Declaration)
Public Property AllowDragDrop As Boolean

See Also

C1TreeView Class
C1.Silverlight Namespace


AutoSearch Property

[image]

.NET Framework Class Library
C1TreeView..::.AutoSearch Property
C1TreeView Class See Also
Enables or disables the AutoSearch functionality of the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool AutoSearch { get; set; }
Visual Basic (Declaration)
Public Property AutoSearch As Boolean

See Also

C1TreeView Class
C1.Silverlight Namespace


AutoSearchResetDelay Property

[image]

.NET Framework Class Library
C1TreeView..::.AutoSearchResetDelay Property
C1TreeView Class See Also
Gets or Sets a value for the delay (in milliseconds) used in the keyboard search.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int AutoSearchResetDelay { get; set; }
Visual Basic (Declaration)
Public Property AutoSearchResetDelay As Integer

See Also

C1TreeView Class
C1.Silverlight Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1TreeView..::.DisabledStyle Property
C1TreeView Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1TreeView Class
C1.Silverlight Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1TreeView..::.FocusStyle Property
C1TreeView Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1TreeView Class
C1.Silverlight Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1TreeView..::.IsFocused Property
C1TreeView Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1TreeView Class
C1.Silverlight Namespace


KeyboardNavigation Property

[image]

.NET Framework Class Library
C1TreeView..::.KeyboardNavigation Property
C1TreeView Class See Also
Enables or disables the Keyboard navigation functionality of the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool KeyboardNavigation { get; set; }
Visual Basic (Declaration)
Public Property KeyboardNavigation As Boolean

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectedItem Property

[image]

.NET Framework Class Library
C1TreeView..::.SelectedItem Property
C1TreeView Class See Also
Gets the selected item in a C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem SelectedItem { get; private set; }
Visual Basic (Declaration)
Public Property SelectedItem As C1TreeViewItem

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectedItems Property

[image]

.NET Framework Class Library
C1TreeView..::.SelectedItems Property
C1TreeView Class See Also
Gets the selected items in a C1TreeView (when in Multiple Selection mode).

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public IList<C1TreeViewItem> SelectedItems { get; private set; }
Visual Basic (Declaration)
Public Property SelectedItems As IList(Of C1TreeViewItem)

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectionMode Property

[image]

.NET Framework Class Library
C1TreeView..::.SelectionMode Property
C1TreeView Class See Also
Gets or sets the selection behavior for a C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As C1SelectionMode

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeView Events

[image] [image]

.NET Framework Class Library
C1TreeView Events
C1TreeView Class See Also

The C1TreeView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
DragDrop | Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.
DragOver | Fires during a drag drop process, when the cursor moves over a registered drop target.
DragStart | Fires when a drag drop process starts.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
ItemClicked | Occurs when a C1TreeViewItem is clicked.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectionChanged | Occurs when the current selection changes.
SelectionModeChanged | Event raised when the SelectionMode property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1TreeView Class
C1.Silverlight Namespace


DragDrop Event

[image]

.NET Framework Class Library
C1TreeView..::.DragDrop Event
C1TreeView Class See Also
Fires at the end of a drag drop process, when the user releases the mouse button over a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragDrop
Visual Basic (Declaration)
Public Event DragDrop As DragDropEventHandler

See Also

C1TreeView Class
C1.Silverlight Namespace


DragOver Event

[image]

.NET Framework Class Library
C1TreeView..::.DragOver Event
C1TreeView Class See Also
Fires during a drag drop process, when the cursor moves over a registered drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragOver
Visual Basic (Declaration)
Public Event DragOver As DragDropEventHandler

See Also

C1TreeView Class
C1.Silverlight Namespace


DragStart Event

[image]

.NET Framework Class Library
C1TreeView..::.DragStart Event
C1TreeView Class See Also
Fires when a drag drop process starts.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event DragDropEventHandler DragStart
Visual Basic (Declaration)
Public Event DragStart As DragDropEventHandler

See Also

C1TreeView Class
C1.Silverlight Namespace


ItemClicked Event

[image]

.NET Framework Class Library
C1TreeView..::.ItemClicked Event
C1TreeView Class See Also
Occurs when a C1TreeViewItem is clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> ItemClicked
Visual Basic (Declaration)
Public Event ItemClicked As EventHandler(Of SourcedEventArgs)

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectionChanged Event

[image]

.NET Framework Class Library
C1TreeView..::.SelectionChanged Event
C1TreeView Class See Also
Occurs when the current selection changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event SelectionChangedEventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As SelectionChangedEventHandler

See Also

C1TreeView Class
C1.Silverlight Namespace


SelectionModeChanged Event

[image]

.NET Framework Class Library
C1TreeView..::.SelectionModeChanged Event
C1TreeView Class See Also
Event raised when the SelectionMode property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<C1SelectionMode>> SelectionModeChanged
Visual Basic (Declaration)
Public Event SelectionModeChanged As EventHandler(Of PropertyChangedEventArgs(Of C1SelectionMode))

See Also

C1TreeView Class
C1.Silverlight Namespace


C1TreeViewItem Class

[image]

.NET Framework Class Library
C1TreeViewItem Class
Members See Also
Implements a selectable item in a C1TreeView control.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "ExpandButton", Type = typeof(ToggleButton))]
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
[TemplatePartAttribute(Name = "HeaderPanel", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "Header", Type = typeof(ContentControl))]
[TemplatePartAttribute(Name = "ChildrenPanel", Type = typeof(ItemsPresenter))]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
public class C1TreeViewItem : C1HierarchicalPresenter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "ExpandButton", Type := GetType(ToggleButton))> _
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
<TemplatePartAttribute(Name := "HeaderPanel", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "Header", Type := GetType(ContentControl))> _
<TemplatePartAttribute(Name := "ChildrenPanel", Type := GetType(ItemsPresenter))> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
Public Class C1TreeViewItem _
    Inherits C1HierarchicalPresenter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight..::.C1ItemsControl
C1.Silverlight..::.C1HierarchicalPresenter
C1.Silverlight..::.C1TreeViewItem

See Also

C1TreeViewItem Members
C1.Silverlight Namespace


C1TreeViewItem Members

[image] [image]

.NET Framework Class Library
C1TreeViewItem Members
C1TreeViewItem Class Constructors Methods Fields Properties Events See Also

The C1TreeViewItem type exposes the following members.

Constructors

Name | Description
C1TreeViewItem | Initializes a new instance of a C1TreeViewItem.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides C1ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Collapse | Collapses the C1TreeViewItem.
EnsureVisible | Scrolls the C1TreeViewItem into view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the C1TreeViewItem.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides C1HierarchicalPresenter..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy. (Inherited from C1HierarchicalPresenter.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element. (Inherited from C1HierarchicalPresenter.)
IsItemItsOwnContainerOverride | (Overrides C1HierarchicalPresenter..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnClick | Raises the Click event.
OnCollapsed | Raises the Collapsed event.
OnCollapsing | Raises the Collapsing event.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnExpandButtonClick | Called when the user clicks the expand/collapse button.
OnExpanded | Raises the Expanded event.
OnExpanding | Raises the Expanding event.
OnItemsChanged | Called when the Items property changes. (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | Called when the user presses a key, performs keyboard auto-search and node navigation.
OnMouseLeftButtonDown | Called when the user presses the left mouse button over the item.
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FirstNode | Gets this node's first child.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control. (Inherited from C1HierarchicalPresenter.)
HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from C1HierarchicalPresenter.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Index | Gets the index of this C1TreeViewItem in its parent items collection
IsExpanded | Gets or sets a value that indicates whether a C1TreeViewItem is expanded.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsSelected | Gets or sets whether a C1TreeViewItem control is selected.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used. (Inherited from C1HierarchicalPresenter.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
LastNode | Gets this node's last child.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextNode | Gets the next node to this one on the C1TreeView.
NextVisibleNode | Gets the next visible node to this one on the C1TreeView.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | Gets the C1TreeViewItem that is the parent of this item.
ParentCollection | Gets the items collection of this element's parent. (Inherited from C1HierarchicalPresenter.)
ParentItemsSource | Returns this element's parent ItemsSource Property. (Inherited from C1HierarchicalPresenter.)
PrevNode | Gets the previous node to this one on the C1TreeView.
PrevVisibleNode | Gets the previous visible node to this one on the C1TreeView.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content in the Header.
TextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.
TextWrapping | Gets or sets a value that indicates how any text should be wrapped in the Header.
TreeView | Identifies the parent C1TreeView of this item.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Occurs when the C1TreeViewItem is clicked.
Collapsed | Occurs after the C1TreeViewItem is collapsed.
Collapsing | Occurs before the C1TreeViewItem is collapsed.
Expanded | Occurs after the C1TreeViewItem is expanded.
Expanding | Occurs before the C1TreeViewItem is expanded.
GotFocus | (Inherited from UIElement.)
IsExpandedChanged | Event raised when the IsExpanded property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1TreeViewItem Constructor

[image]

.NET Framework Class Library
C1TreeViewItem Constructor
C1TreeViewItem Class See Also
Initializes a new instance of a C1TreeViewItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem()
Visual Basic (Declaration)
Public Sub New

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1TreeViewItem Fields

[image] [image]

.NET Framework Class Library
C1TreeViewItem Fields
C1TreeViewItem Class See Also

The C1TreeViewItem type exposes the following members.

Fields

Name | Description
IsExpandedProperty | Identifies the IsExpanded dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.
TextAlignmentProperty | Identifies the TextAlignment dependency property.
TextDecorationsProperty | Identifies the TextDecorations dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


IsExpandedProperty Field

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsExpandedProperty Field
C1TreeViewItem Class See Also
Identifies the IsExpanded dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsSelectedProperty Field
C1TreeViewItem Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextAlignmentProperty Field

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextAlignmentProperty Field
C1TreeViewItem Class See Also
Identifies the TextAlignment dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextAlignmentProperty As DependencyProperty

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextDecorationsProperty Field

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextDecorationsProperty Field
C1TreeViewItem Class See Also
Identifies the TextDecorations dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextDecorationsProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextDecorationsProperty As DependencyProperty

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextWrappingProperty Field

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextWrappingProperty Field
C1TreeViewItem Class See Also
Identifies the TextWrapping dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TextWrappingProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1TreeViewItem Methods

[image] [image]

.NET Framework Class Library
C1TreeViewItem Methods
C1TreeViewItem Class See Also

The C1TreeViewItem type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1ItemsControl.)
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides C1ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Collapse | Collapses the C1TreeViewItem.
EnsureVisible | Scrolls the C1TreeViewItem into view.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Expand | Expands the C1TreeViewItem.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides C1HierarchicalPresenter..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InitializeItem | Initializes a C1HierarchicalPresenter by setting its parent and root elements in the hierarchy. (Inherited from C1HierarchicalPresenter.)
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsAncestorOf | Determines whether the C1HierarchicalPresenter is an ancestor of the descendant element. (Inherited from C1HierarchicalPresenter.)
IsItemItsOwnContainerOverride | (Overrides C1HierarchicalPresenter..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1ItemsControl..::.OnApplyTemplate()()().)
OnClick | Raises the Click event.
OnCollapsed | Raises the Collapsed event.
OnCollapsing | Raises the Collapsing event.
OnCreateAutomationPeer | (Inherited from UIElement.)
OnExpandButtonClick | Called when the user clicks the expand/collapse button.
OnExpanded | Raises the Expanded event.
OnExpanding | Raises the Expanding event.
OnItemsChanged | Called when the Items property changes. (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
OnKeyDown | Called when the user presses a key, performs keyboard auto-search and node navigation.
OnMouseLeftButtonDown | Called when the user presses the left mouse button over the item.
PrepareContainerForItemOverride | (Overrides C1ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


ChangeVisualStateSelection Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.ChangeVisualStateSelection Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateSelection(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateSelection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.ClearContainerForItemOverride Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Collapse Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.Collapse Method
C1TreeViewItem Class See Also
Collapses the C1TreeViewItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Collapse()
Visual Basic (Declaration)
Public Sub Collapse

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


EnsureVisible Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.EnsureVisible Method
C1TreeViewItem Class See Also
Scrolls the C1TreeViewItem into view.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void EnsureVisible()
Visual Basic (Declaration)
Public Sub EnsureVisible

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Expand Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.Expand Method
C1TreeViewItem Class See Also
Expands the C1TreeViewItem.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Expand()
Visual Basic (Declaration)
Public Sub Expand

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.GetContainerForItemOverride Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1TreeViewItem..::.HitTest Method
C1TreeViewItem Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1TreeViewItem Class
C1TreeViewItem Members
C1.Silverlight Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsItemItsOwnContainerOverride Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnApplyTemplate Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnClick Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnClick Method
C1TreeViewItem Class See Also
Raises the Click event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnClick(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnClick ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnCollapsed Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnCollapsed Method
C1TreeViewItem Class See Also
Raises the Collapsed event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnCollapsed(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCollapsed ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnCollapsing Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnCollapsing Method
C1TreeViewItem Class See Also
Raises the Collapsing event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnCollapsing(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnCollapsing ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnExpandButtonClick Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnExpandButtonClick Method
C1TreeViewItem Class See Also
Called when the user clicks the expand/collapse button.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnExpandButtonClick()
Visual Basic (Declaration)
Protected Overridable Sub OnExpandButtonClick

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnExpanded Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnExpanded Method
C1TreeViewItem Class See Also
Raises the Expanded event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnExpanded(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnExpanded ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnExpanding Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnExpanding Method
C1TreeViewItem Class See Also
Raises the Expanding event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnExpanding(
    SourcedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnExpanding ( _
    e As SourcedEventArgs _
)

Parameters

e
Type: C1.Silverlight..::.SourcedEventArgs
Provides data for the event.

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnItemsChanged Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnItemsChanged Method
C1TreeViewItem Class See Also
Called when the Items property changes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnKeyDown Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnKeyDown Method
C1TreeViewItem Class See Also
Called when the user presses a key, performs keyboard auto-search and node navigation.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected virtual void OnKeyDown(
    Object sender,
    KeyEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnKeyDown ( _
    sender As Object, _
    e As KeyEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Input..::.KeyEventArgs

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


OnMouseLeftButtonDown Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.OnMouseLeftButtonDown Method
C1TreeViewItem Class See Also
Called when the user presses the left mouse button over the item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected internal virtual void OnMouseLeftButtonDown(
    Object sender,
    MouseButtonEventArgs e
)
Visual Basic (Declaration)
Protected Friend Overridable Sub OnMouseLeftButtonDown ( _
    sender As Object, _
    e As MouseButtonEventArgs _
)

Parameters

sender
Type: System..::.Object
e
Type: System.Windows.Input..::.MouseButtonEventArgs

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1TreeViewItem..::.PrepareContainerForItemOverride Method
C1TreeViewItem Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1TreeViewItem Properties

[image] [image]

.NET Framework Class Library
C1TreeViewItem Properties
C1TreeViewItem Class See Also

The C1TreeViewItem type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FirstNode | Gets this node's first child.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HasItems | Gets a value that indicates whether the ItemsControl contains items. (Inherited from C1ItemsControl.)
Header | Gets or sets the item that labels the control. (Inherited from C1HierarchicalPresenter.)
HeaderTemplate | Gets or sets the template used to display the contents of the control's header. (Inherited from C1HierarchicalPresenter.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Index | Gets the index of this C1TreeViewItem in its parent items collection
IsExpanded | Gets or sets a value that indicates whether a C1TreeViewItem is expanded.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1ItemsControl.)
IsSelected | Gets or sets whether a C1TreeViewItem control is selected.
IsTabStop | (Inherited from Control.)
ItemContainerGenerator | Gets the C1ItemContainerGenerator that is associated with the control. (Inherited from C1ItemsControl.)
ItemContainerStyle | Gets or sets the Style that is applied to the container element generated for each item. (Inherited from C1ItemsControl.)
ItemContainerStyleSelector | Gets or sets custom style-selection logic for a style that can be applied to each generated container element. (Inherited from C1ItemsControl.)
ItemConverter | The ItemConverter performs the conversion from a C1HierarchicalPresenter instance to its String representation. If not set by the user, the default converter will be used. (Inherited from C1HierarchicalPresenter.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
ItemTemplateSelector | Provides a way to choose a DataTemplate based on the data object and the data-bound element. (Inherited from C1ItemsControl.)
Language | (Inherited from FrameworkElement.)
LastNode | Gets this node's last child.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NextNode | Gets the next node to this one on the C1TreeView.
NextVisibleNode | Gets the next visible node to this one on the C1TreeView.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | Gets the C1TreeViewItem that is the parent of this item.
ParentCollection | Gets the items collection of this element's parent. (Inherited from C1HierarchicalPresenter.)
ParentItemsSource | Returns this element's parent ItemsSource Property. (Inherited from C1HierarchicalPresenter.)
PrevNode | Gets the previous node to this one on the C1TreeView.
PrevVisibleNode | Gets the previous visible node to this one on the C1TreeView.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | Gets or sets a value that indicates the horizontal alignment of text content in the Header.
TextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.
TextWrapping | Gets or sets a value that indicates how any text should be wrapped in the Header.
TreeView | Identifies the parent C1TreeView of this item.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


FirstNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.FirstNode Property
C1TreeViewItem Class See Also
Gets this node's first child.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem FirstNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property FirstNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Index Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.Index Property
C1TreeViewItem Class See Also
Gets the index of this C1TreeViewItem in its parent items collection

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Index { get; }
Visual Basic (Declaration)
Public ReadOnly Property Index As Integer

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


IsExpanded Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsExpanded Property
C1TreeViewItem Class See Also
Gets or sets a value that indicates whether a C1TreeViewItem is expanded.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


IsSelected Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsSelected Property
C1TreeViewItem Class See Also
Gets or sets whether a C1TreeViewItem control is selected.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


LastNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.LastNode Property
C1TreeViewItem Class See Also
Gets this node's last child.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem LastNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property LastNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


NextNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.NextNode Property
C1TreeViewItem Class See Also
Gets the next node to this one on the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem NextNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


NextVisibleNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.NextVisibleNode Property
C1TreeViewItem Class See Also
Gets the next visible node to this one on the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem NextVisibleNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property NextVisibleNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Parent Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.Parent Property
C1TreeViewItem Class See Also
Gets the C1TreeViewItem that is the parent of this item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem Parent { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parent As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


PrevNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.PrevNode Property
C1TreeViewItem Class See Also
Gets the previous node to this one on the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem PrevNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrevNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


PrevVisibleNode Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.PrevVisibleNode Property
C1TreeViewItem Class See Also
Gets the previous visible node to this one on the C1TreeView.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeViewItem PrevVisibleNode { get; }
Visual Basic (Declaration)
Public ReadOnly Property PrevVisibleNode As C1TreeViewItem

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextAlignment Property
C1TreeViewItem Class See Also
Gets or sets a value that indicates the horizontal alignment of text content in the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextDecorations Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextDecorations Property
C1TreeViewItem Class See Also
Gets or sets a TextDecorationCollection that contains the effects to apply to the text of the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextDecorationCollection TextDecorations { get; set; }
Visual Basic (Declaration)
Public Property TextDecorations As TextDecorationCollection

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TextWrapping Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.TextWrapping Property
C1TreeViewItem Class See Also
Gets or sets a value that indicates how any text should be wrapped in the Header.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic (Declaration)
Public Property TextWrapping As TextWrapping

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


TreeView Property

[image]

.NET Framework Class Library
C1TreeViewItem..::.TreeView Property
C1TreeViewItem Class See Also
Identifies the parent C1TreeView of this item.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1TreeView TreeView { get; }
Visual Basic (Declaration)
Public ReadOnly Property TreeView As C1TreeView

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1TreeViewItem Events

[image] [image]

.NET Framework Class Library
C1TreeViewItem Events
C1TreeViewItem Class See Also

The C1TreeViewItem type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Occurs when the C1TreeViewItem is clicked.
Collapsed | Occurs after the C1TreeViewItem is collapsed.
Collapsing | Occurs before the C1TreeViewItem is collapsed.
Expanded | Occurs after the C1TreeViewItem is expanded.
Expanding | Occurs before the C1TreeViewItem is expanded.
GotFocus | (Inherited from UIElement.)
IsExpandedChanged | Event raised when the IsExpanded property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1ItemsControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Click Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.Click Event
C1TreeViewItem Class See Also
Occurs when the C1TreeViewItem is clicked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Click
Visual Basic (Declaration)
Public Event Click As EventHandler(Of SourcedEventArgs)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Collapsed Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.Collapsed Event
C1TreeViewItem Class See Also
Occurs after the C1TreeViewItem is collapsed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Collapsed
Visual Basic (Declaration)
Public Event Collapsed As EventHandler(Of SourcedEventArgs)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Collapsing Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.Collapsing Event
C1TreeViewItem Class See Also
Occurs before the C1TreeViewItem is collapsed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Collapsing
Visual Basic (Declaration)
Public Event Collapsing As EventHandler(Of SourcedEventArgs)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Expanded Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.Expanded Event
C1TreeViewItem Class See Also
Occurs after the C1TreeViewItem is expanded.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Expanded
Visual Basic (Declaration)
Public Event Expanded As EventHandler(Of SourcedEventArgs)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


Expanding Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.Expanding Event
C1TreeViewItem Class See Also
Occurs before the C1TreeViewItem is expanded.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<SourcedEventArgs> Expanding
Visual Basic (Declaration)
Public Event Expanding As EventHandler(Of SourcedEventArgs)

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


IsExpandedChanged Event

[image]

.NET Framework Class Library
C1TreeViewItem..::.IsExpandedChanged Event
C1TreeViewItem Class See Also
Event raised when the IsExpanded property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsExpandedChanged
Visual Basic (Declaration)
Public Event IsExpandedChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1TreeViewItem Class
C1.Silverlight Namespace


C1UniformGrid Class

[image]

.NET Framework Class Library
C1UniformGrid Class
Members See Also
Provides a way to arrange content in a grid where all the cells in the grid have the same size.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1UniformGrid : Panel
Visual Basic (Declaration)
Public Class C1UniformGrid _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight..::.C1UniformGrid

See Also

C1UniformGrid Members
C1.Silverlight Namespace


C1UniformGrid Members

[image] [image]

.NET Framework Class Library
C1UniformGrid Members
C1UniformGrid Class Constructors Methods Fields Properties Events See Also

The C1UniformGrid type exposes the following members.

Constructors

Name | Description
C1UniformGrid | Initializes a new instance of a C1UniformGrid.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColumnsProperty | Identifies the Columns dependency property.
RowsProperty | Identifies the Rows dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the number of columns for this panel.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Rows | Gets or sets the number of rows for this panel.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1UniformGrid Constructor

[image]

.NET Framework Class Library
C1UniformGrid Constructor
C1UniformGrid Class See Also
Initializes a new instance of a C1UniformGrid.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1UniformGrid()
Visual Basic (Declaration)
Public Sub New

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1UniformGrid Fields

[image] [image]

.NET Framework Class Library
C1UniformGrid Fields
C1UniformGrid Class See Also

The C1UniformGrid type exposes the following members.

Fields

Name | Description
ColumnsProperty | Identifies the Columns dependency property.
RowsProperty | Identifies the Rows dependency property.

See Also

C1UniformGrid Class
C1.Silverlight Namespace


ColumnsProperty Field

[image]

.NET Framework Class Library
C1UniformGrid..::.ColumnsProperty Field
C1UniformGrid Class See Also
Identifies the Columns dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty

See Also

C1UniformGrid Class
C1.Silverlight Namespace


RowsProperty Field

[image]

.NET Framework Class Library
C1UniformGrid..::.RowsProperty Field
C1UniformGrid Class See Also
Identifies the Rows dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty RowsProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowsProperty As DependencyProperty

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1UniformGrid Methods

[image] [image]

.NET Framework Class Library
C1UniformGrid Methods
C1UniformGrid Class See Also

The C1UniformGrid type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1UniformGrid Class
C1.Silverlight Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1UniformGrid..::.ArrangeOverride Method
C1UniformGrid Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1UniformGrid Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1UniformGrid..::.HitTest Method
C1UniformGrid Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1UniformGrid Class
C1UniformGrid Members
C1.Silverlight Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1UniformGrid..::.MeasureOverride Method
C1UniformGrid Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1UniformGrid Properties

[image] [image]

.NET Framework Class Library
C1UniformGrid Properties
C1UniformGrid Class See Also

The C1UniformGrid type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Columns | Gets or sets the number of columns for this panel.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Rows | Gets or sets the number of rows for this panel.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1UniformGrid Class
C1.Silverlight Namespace


Columns Property

[image]

.NET Framework Class Library
C1UniformGrid..::.Columns Property
C1UniformGrid Class See Also
Gets or sets the number of columns for this panel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Columns { get; set; }
Visual Basic (Declaration)
Public Property Columns As Integer

See Also

C1UniformGrid Class
C1.Silverlight Namespace


Rows Property

[image]

.NET Framework Class Library
C1UniformGrid..::.Rows Property
C1UniformGrid Class See Also
Gets or sets the number of rows for this panel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int Rows { get; set; }
Visual Basic (Declaration)
Public Property Rows As Integer

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1UniformGrid Events

[image] [image]

.NET Framework Class Library
C1UniformGrid Events
C1UniformGrid Class See Also

The C1UniformGrid type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1UniformGrid Class
C1.Silverlight Namespace


C1Window Class

[image]

.NET Framework Class Library
C1Window Class
Members See Also
Shows content in a window inside Silverlight.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Maximize", Type = typeof(Button))]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "MaximizedStates")]
[TemplatePartAttribute(Name = "Resize", Type = typeof(Border))]
[TemplateVisualStateAttribute(Name = "Maximized", GroupName = "MaximizedStates")]
[TemplatePartAttribute(Name = "Drag", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Close", Type = typeof(Button))]
[TemplatePartAttribute(Name = "Content", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Active", GroupName = "ActiveStates")]
[TemplateVisualStateAttribute(Name = "Inactive", GroupName = "ActiveStates")]
public class C1Window : C1HeaderedContentControl
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Maximize", Type := GetType(Button))> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "MaximizedStates")> _
<TemplatePartAttribute(Name := "Resize", Type := GetType(Border))> _
<TemplateVisualStateAttribute(Name := "Maximized", GroupName := "MaximizedStates")> _
<TemplatePartAttribute(Name := "Drag", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Close", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "Content", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Active", GroupName := "ActiveStates")> _
<TemplateVisualStateAttribute(Name := "Inactive", GroupName := "ActiveStates")> _
Public Class C1Window _
    Inherits C1HeaderedContentControl

Remarks

This control is a Popup with the added ability to resize and drag. It cannot be added as a child of another control. To open a C1Window, create a C1Window object and call its Show method.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1HeaderedContentControl
C1.Silverlight..::.C1Window

See Also

C1Window Members
C1.Silverlight Namespace


C1Window Members

[image] [image]

.NET Framework Class Library
C1Window Members
C1Window Class Constructors Methods Fields Properties Events See Also

The C1Window type exposes the following members.

Constructors

Name | Description
C1Window | Initializes a new instance of a C1Window.

Methods

Name | Description
AddDefaultPopupToVisualTree | Call this method when initializing the application to workaround the Popup TransformToVisual bug.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BringToFront | Puts the window in front of all windows.
CaptureMouse | (Inherited from UIElement.)
CenterOnScreen | Centers the window in the Silverlight plug-in.
ChangeVisualStateActive |
ChangeVisualStateCommon | (Inherited from C1HeaderedContentControl.)
ChangeVisualStateMaximized |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | Closes the window.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
Hide | Hides the window without closing it.
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
Position | Positions the window so that the specified point in the window matches the specified point of a FrameworkElement.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | Opens the window.
ShowModal | Opens the window as modal.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsActiveProperty | Identifies the IsActive dependency property.
IsMaximizedProperty | Identifies the IsMaximized dependency property.
IsResizableProperty | Identifies the IsResizable dependency property.
LeftProperty | Identifies the Left dependency property.
ModalBackgroundProperty | Identifies the ModalBackground dependency property.
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.
ShowMaximizeButtonProperty | Identifies the ShowMaximizeButton dependency property.
TopProperty | Identifies the Top dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Canvas | Gets or sets the Canvas used to display the window.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsActive | Gets or sets whether the window is the active window.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMaximized | Gets or sets whether the window is maximized.
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1HeaderedContentControl.)
IsResizable | Gets or sets whether the window can be resized and maximized.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Left | Gets or sets the distance from the left side of the window to the left side of the screen.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
ModalBackground | Gets or sets the brushed used on the background when showing a modal window.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowCloseButton | Gets or sets whether the maximize button of this window is shown.
ShowMaximizeButton | Gets or sets whether the maximize button of this window is shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Top | Gets or sets the distance from the top side of the window to the top side of the screen.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | Event fired when the window is closed by the user or the Close()()() method.
Closing | Event fired when the window is about to close, allows the handler to stop the window from being closed.
GotFocus | (Inherited from UIElement.)
IsActiveChanged | Event raised when the IsActive property has changed.
IsMaximizedChanged | Event raised when the IsMaximized property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1HeaderedContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Window Class
C1.Silverlight Namespace


C1Window Constructor

[image]

.NET Framework Class Library
C1Window Constructor
C1Window Class See Also
Initializes a new instance of a C1Window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1Window()
Visual Basic (Declaration)
Public Sub New

See Also

C1Window Class
C1.Silverlight Namespace


C1Window Fields

[image] [image]

.NET Framework Class Library
C1Window Fields
C1Window Class See Also

The C1Window type exposes the following members.

Fields

Name | Description
IsActiveProperty | Identifies the IsActive dependency property.
IsMaximizedProperty | Identifies the IsMaximized dependency property.
IsResizableProperty | Identifies the IsResizable dependency property.
LeftProperty | Identifies the Left dependency property.
ModalBackgroundProperty | Identifies the ModalBackground dependency property.
ShowCloseButtonProperty | Identifies the ShowCloseButton dependency property.
ShowMaximizeButtonProperty | Identifies the ShowMaximizeButton dependency property.
TopProperty | Identifies the Top dependency property.

See Also

C1Window Class
C1.Silverlight Namespace


IsActiveProperty Field

[image]

.NET Framework Class Library
C1Window..::.IsActiveProperty Field
C1Window Class See Also
Identifies the IsActive dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsActiveProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsActiveProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


IsMaximizedProperty Field

[image]

.NET Framework Class Library
C1Window..::.IsMaximizedProperty Field
C1Window Class See Also
Identifies the IsMaximized dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsMaximizedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMaximizedProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


IsResizableProperty Field

[image]

.NET Framework Class Library
C1Window..::.IsResizableProperty Field
C1Window Class See Also
Identifies the IsResizable dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty IsResizableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsResizableProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


LeftProperty Field

[image]

.NET Framework Class Library
C1Window..::.LeftProperty Field
C1Window Class See Also
Identifies the Left dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty LeftProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeftProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


ModalBackgroundProperty Field

[image]

.NET Framework Class Library
C1Window..::.ModalBackgroundProperty Field
C1Window Class See Also
Identifies the ModalBackground dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ModalBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly ModalBackgroundProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


ShowCloseButtonProperty Field

[image]

.NET Framework Class Library
C1Window..::.ShowCloseButtonProperty Field
C1Window Class See Also
Identifies the ShowCloseButton dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ShowCloseButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowCloseButtonProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


ShowMaximizeButtonProperty Field

[image]

.NET Framework Class Library
C1Window..::.ShowMaximizeButtonProperty Field
C1Window Class See Also
Identifies the ShowMaximizeButton dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ShowMaximizeButtonProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowMaximizeButtonProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


TopProperty Field

[image]

.NET Framework Class Library
C1Window..::.TopProperty Field
C1Window Class See Also
Identifies the Top dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty TopProperty
Visual Basic (Declaration)
Public Shared ReadOnly TopProperty As DependencyProperty

See Also

C1Window Class
C1.Silverlight Namespace


C1Window Methods

[image] [image]

.NET Framework Class Library
C1Window Methods
C1Window Class See Also

The C1Window type exposes the following members.

Methods

Name | Description
AddDefaultPopupToVisualTree | Call this method when initializing the application to workaround the Popup TransformToVisual bug.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BringToFront | Puts the window in front of all windows.
CaptureMouse | (Inherited from UIElement.)
CenterOnScreen | Centers the window in the Silverlight plug-in.
ChangeVisualStateActive |
ChangeVisualStateCommon | (Inherited from C1HeaderedContentControl.)
ChangeVisualStateMaximized |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Close | Closes the window.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
Hide | Hides the window without closing it.
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
Position | Positions the window so that the specified point in the window matches the specified point of a FrameworkElement.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
Show | Opens the window.
ShowModal | Opens the window as modal.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Window Class
C1.Silverlight Namespace


AddDefaultPopupToVisualTree Method

[image]

.NET Framework Class Library
C1Window..::.AddDefaultPopupToVisualTree Method
C1Window Class See Also
Call this method when initializing the application to workaround the Popup TransformToVisual bug.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void AddDefaultPopupToVisualTree(
    Panel panel
)
Visual Basic (Declaration)
Public Shared Sub AddDefaultPopupToVisualTree ( _
    panel As Panel _
)

Parameters

panel
Type: System.Windows.Controls..::.Panel

See Also

C1Window Class
C1.Silverlight Namespace


BringToFront Method

[image]

.NET Framework Class Library
C1Window..::.BringToFront Method
C1Window Class See Also
Puts the window in front of all windows.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void BringToFront()
Visual Basic (Declaration)
Public Sub BringToFront

See Also

C1Window Class
C1.Silverlight Namespace


CenterOnScreen Method

[image]

.NET Framework Class Library
C1Window..::.CenterOnScreen Method
C1Window Class See Also
Centers the window in the Silverlight plug-in.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void CenterOnScreen()
Visual Basic (Declaration)
Public Sub CenterOnScreen

Remarks

If the window is not yet loaded the positioning is delayed until it's loaded.

See Also

C1Window Class
C1.Silverlight Namespace


ChangeVisualStateActive Method

[image]

.NET Framework Class Library
C1Window..::.ChangeVisualStateActive Method
C1Window Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateActive(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateActive ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Window Class
C1.Silverlight Namespace


ChangeVisualStateMaximized Method

[image]

.NET Framework Class Library
C1Window..::.ChangeVisualStateMaximized Method
C1Window Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected void ChangeVisualStateMaximized(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateMaximized ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Window Class
C1.Silverlight Namespace


Close Method

[image]

.NET Framework Class Library
C1Window..::.Close Method
C1Window Class See Also
Closes the window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close

Remarks

A window cannot be reopened after it has been closed.

See Also

C1Window Class
C1.Silverlight Namespace


Hide Method

[image]

.NET Framework Class Library
C1Window..::.Hide Method
C1Window Class See Also
Hides the window without closing it.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Hide()
Visual Basic (Declaration)
Public Sub Hide

See Also

C1Window Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Window..::.HitTest Method
C1Window Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Window Class
C1Window Members
C1.Silverlight Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Window..::.OnApplyTemplate Method
C1Window Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Window Class
C1.Silverlight Namespace


Position Method

[image]

.NET Framework Class Library
C1Window..::.Position Method
C1Window Class See Also
Positions the window so that the specified point in the window matches the specified point of a FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Position(
    Anchor windowAnchor,
    FrameworkElement reference,
    Anchor referenceAnchor
)
Visual Basic (Declaration)
Public Sub Position ( _
    windowAnchor As Anchor, _
    reference As FrameworkElement, _
    referenceAnchor As Anchor _
)

Parameters

windowAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the window.
reference
Type: System.Windows..::.FrameworkElement
The FrameworkElement to use as reference.
referenceAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the FrameworkElement.

Remarks

If the window is not yet loaded the positioning is delayed until it's loaded.

See Also

C1Window Class
C1.Silverlight Namespace


Show Method

[image]

.NET Framework Class Library
C1Window..::.Show Method
C1Window Class See Also
Opens the window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void Show()
Visual Basic (Declaration)
Public Sub Show

Remarks

Calling Show makes the window visible, active and in front of other windows. A window cannot be reopened after it has been closed. It's possible to hide the window without closing it using Hide()()() or the Visibility property.

See Also

C1Window Class
C1.Silverlight Namespace


ShowModal Method

[image]

.NET Framework Class Library
C1Window..::.ShowModal Method
C1Window Class See Also
Opens the window as modal.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public void ShowModal()
Visual Basic (Declaration)
Public Sub ShowModal

Remarks

Opens the window over a grayed out layer preventing the user from interacting with anything else until the window is closed.

See Also

C1Window Class
C1.Silverlight Namespace


C1Window Properties

[image] [image]

.NET Framework Class Library
C1Window Properties
C1Window Class See Also

The C1Window type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Canvas | Gets or sets the Canvas used to display the window.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsActive | Gets or sets whether the window is the active window.
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMaximized | Gets or sets whether the window is maximized.
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1HeaderedContentControl.)
IsResizable | Gets or sets whether the window can be resized and maximized.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Left | Gets or sets the distance from the left side of the window to the left side of the screen.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
ModalBackground | Gets or sets the brushed used on the background when showing a modal window.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowCloseButton | Gets or sets whether the maximize button of this window is shown.
ShowMaximizeButton | Gets or sets whether the maximize button of this window is shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Top | Gets or sets the distance from the top side of the window to the top side of the screen.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Window Class
C1.Silverlight Namespace


Canvas Property

[image]

.NET Framework Class Library
C1Window..::.Canvas Property
C1Window Class See Also
Gets or sets the Canvas used to display the window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Canvas Canvas { get; set; }
Visual Basic (Declaration)
Public Property Canvas As Canvas

See Also

C1Window Class
C1.Silverlight Namespace


IsActive Property

[image]

.NET Framework Class Library
C1Window..::.IsActive Property
C1Window Class See Also
Gets or sets whether the window is the active window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsActive { get; set; }
Visual Basic (Declaration)
Public Property IsActive As Boolean

See Also

C1Window Class
C1.Silverlight Namespace


IsMaximized Property

[image]

.NET Framework Class Library
C1Window..::.IsMaximized Property
C1Window Class See Also
Gets or sets whether the window is maximized.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsMaximized { get; set; }
Visual Basic (Declaration)
Public Property IsMaximized As Boolean

See Also

C1Window Class
C1.Silverlight Namespace


IsResizable Property

[image]

.NET Framework Class Library
C1Window..::.IsResizable Property
C1Window Class See Also
Gets or sets whether the window can be resized and maximized.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsResizable { get; set; }
Visual Basic (Declaration)
Public Property IsResizable As Boolean

See Also

C1Window Class
C1.Silverlight Namespace


Left Property

[image]

.NET Framework Class Library
C1Window..::.Left Property
C1Window Class See Also
Gets or sets the distance from the left side of the window to the left side of the screen.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Left { get; set; }
Visual Basic (Declaration)
Public Property Left As Double

See Also

C1Window Class
C1.Silverlight Namespace


ModalBackground Property

[image]

.NET Framework Class Library
C1Window..::.ModalBackground Property
C1Window Class See Also
Gets or sets the brushed used on the background when showing a modal window.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Brush ModalBackground { get; set; }
Visual Basic (Declaration)
Public Property ModalBackground As Brush

See Also

C1Window Class
C1.Silverlight Namespace


ShowCloseButton Property

[image]

.NET Framework Class Library
C1Window..::.ShowCloseButton Property
C1Window Class See Also
Gets or sets whether the maximize button of this window is shown.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool ShowCloseButton { get; set; }
Visual Basic (Declaration)
Public Property ShowCloseButton As Boolean

See Also

C1Window Class
C1.Silverlight Namespace


ShowMaximizeButton Property

[image]

.NET Framework Class Library
C1Window..::.ShowMaximizeButton Property
C1Window Class See Also
Gets or sets whether the maximize button of this window is shown.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool ShowMaximizeButton { get; set; }
Visual Basic (Declaration)
Public Property ShowMaximizeButton As Boolean

See Also

C1Window Class
C1.Silverlight Namespace


Top Property

[image]

.NET Framework Class Library
C1Window..::.Top Property
C1Window Class See Also
Gets or sets the distance from the top side of the window to the top side of the screen.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Top { get; set; }
Visual Basic (Declaration)
Public Property Top As Double

See Also

C1Window Class
C1.Silverlight Namespace


C1Window Events

[image] [image]

.NET Framework Class Library
C1Window Events
C1Window Class See Also

The C1Window type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Closed | Event fired when the window is closed by the user or the Close()()() method.
Closing | Event fired when the window is about to close, allows the handler to stop the window from being closed.
GotFocus | (Inherited from UIElement.)
IsActiveChanged | Event raised when the IsActive property has changed.
IsMaximizedChanged | Event raised when the IsMaximized property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1HeaderedContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Window Class
C1.Silverlight Namespace


Closed Event

[image]

.NET Framework Class Library
C1Window..::.Closed Event
C1Window Class See Also
Event fired when the window is closed by the user or the Close()()() method.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler Closed
Visual Basic (Declaration)
Public Event Closed As EventHandler

See Also

C1Window Class
C1.Silverlight Namespace


Closing Event

[image]

.NET Framework Class Library
C1Window..::.Closing Event
C1Window Class See Also
Event fired when the window is about to close, allows the handler to stop the window from being closed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event CancelEventHandler Closing
Visual Basic (Declaration)
Public Event Closing As CancelEventHandler

See Also

C1Window Class
C1.Silverlight Namespace


IsActiveChanged Event

[image]

.NET Framework Class Library
C1Window..::.IsActiveChanged Event
C1Window Class See Also
Event raised when the IsActive property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsActiveChanged
Visual Basic (Declaration)
Public Event IsActiveChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Window Class
C1.Silverlight Namespace


IsMaximizedChanged Event

[image]

.NET Framework Class Library
C1Window..::.IsMaximizedChanged Event
C1Window Class See Also
Event raised when the IsMaximized property has changed.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMaximizedChanged
Visual Basic (Declaration)
Public Event IsMaximizedChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Window Class
C1.Silverlight Namespace


C1WrapPanel Class

[image]

.NET Framework Class Library
C1WrapPanel Class
Members See Also
Positions child elements sequentially from top to bottom or from right to left, depending on the value of the Orientation property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class C1WrapPanel : Panel
Visual Basic (Declaration)
Public Class C1WrapPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight..::.C1WrapPanel

See Also

C1WrapPanel Members
C1.Silverlight Namespace


C1WrapPanel Members

[image] [image]

.NET Framework Class Library
C1WrapPanel Members
C1WrapPanel Class Constructors Methods Fields Properties Events See Also

The C1WrapPanel type exposes the following members.

Constructors

Name | Description
C1WrapPanel | Initializes a new instance of a C1WrapPanel.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBreakLine | Gets the value of the BreakLine attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetBreakLine | Sets the value of the BreakLine attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
BreakLineProperty | Identifies the BreakLine attached property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ItemWidthProperty | Identifies the ItemWidth dependency property.
OrientationProperty | Identifies the Orientation dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
ItemHeight | Gets or sets a value that specifies the height of all items that are contained within the panel.
ItemWidth | Gets or sets a value that specifies the width of all items that are contained within the panel.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1WrapPanel Class
C1.Silverlight Namespace


C1WrapPanel Constructor

[image]

.NET Framework Class Library
C1WrapPanel Constructor
C1WrapPanel Class See Also
Initializes a new instance of a C1WrapPanel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public C1WrapPanel()
Visual Basic (Declaration)
Public Sub New

See Also

C1WrapPanel Class
C1.Silverlight Namespace


C1WrapPanel Fields

[image] [image]

.NET Framework Class Library
C1WrapPanel Fields
C1WrapPanel Class See Also

The C1WrapPanel type exposes the following members.

Fields

Name | Description
BreakLineProperty | Identifies the BreakLine attached property.
ItemHeightProperty | Identifies the ItemHeight dependency property.
ItemWidthProperty | Identifies the ItemWidth dependency property.
OrientationProperty | Identifies the Orientation dependency property.

See Also

C1WrapPanel Class
C1.Silverlight Namespace


BreakLineProperty Field

[image]

.NET Framework Class Library
C1WrapPanel..::.BreakLineProperty Field
C1WrapPanel Class See Also
Identifies the BreakLine attached property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty BreakLineProperty
Visual Basic (Declaration)
Public Shared ReadOnly BreakLineProperty As DependencyProperty

See Also

C1WrapPanel Class
C1.Silverlight Namespace


ItemHeightProperty Field

[image]

.NET Framework Class Library
C1WrapPanel..::.ItemHeightProperty Field
C1WrapPanel Class See Also
Identifies the ItemHeight dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemHeightProperty As DependencyProperty

See Also

C1WrapPanel Class
C1.Silverlight Namespace


ItemWidthProperty Field

[image]

.NET Framework Class Library
C1WrapPanel..::.ItemWidthProperty Field
C1WrapPanel Class See Also
Identifies the ItemWidth dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty ItemWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemWidthProperty As DependencyProperty

See Also

C1WrapPanel Class
C1.Silverlight Namespace


OrientationProperty Field

[image]

.NET Framework Class Library
C1WrapPanel..::.OrientationProperty Field
C1WrapPanel Class See Also
Identifies the Orientation dependency property.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

C1WrapPanel Class
C1.Silverlight Namespace


C1WrapPanel Methods

[image] [image]

.NET Framework Class Library
C1WrapPanel Methods
C1WrapPanel Class See Also

The C1WrapPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBreakLine | Gets the value of the BreakLine attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetBreakLine | Sets the value of the BreakLine attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1WrapPanel Class
C1.Silverlight Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1WrapPanel..::.ArrangeOverride Method
C1WrapPanel Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1WrapPanel Class
C1.Silverlight Namespace


GetBreakLine Method

[image]

.NET Framework Class Library
C1WrapPanel..::.GetBreakLine Method
C1WrapPanel Class See Also
Gets the value of the BreakLine attached property for the specified element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static BreakLine GetBreakLine(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetBreakLine ( _
    element As DependencyObject _
) As BreakLine

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the BreakLine property.

See Also

C1WrapPanel Class
C1.Silverlight Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1WrapPanel..::.HitTest Method
C1WrapPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1WrapPanel Class
C1WrapPanel Members
C1.Silverlight Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1WrapPanel..::.MeasureOverride Method
C1WrapPanel Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::.Size

See Also

C1WrapPanel Class
C1.Silverlight Namespace


SetBreakLine Method

[image]

.NET Framework Class Library
C1WrapPanel..::.SetBreakLine Method
C1WrapPanel Class See Also
Sets the value of the BreakLine attached property for the specified element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void SetBreakLine(
    DependencyObject element,
    BreakLine value
)
Visual Basic (Declaration)
Public Shared Sub SetBreakLine ( _
    element As DependencyObject, _
    value As BreakLine _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: C1.Silverlight..::.BreakLine
The property value to set.

See Also

C1WrapPanel Class
C1.Silverlight Namespace


C1WrapPanel Properties

[image] [image]

.NET Framework Class Library
C1WrapPanel Properties
C1WrapPanel Class See Also

The C1WrapPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
ItemHeight | Gets or sets a value that specifies the height of all items that are contained within the panel.
ItemWidth | Gets or sets a value that specifies the width of all items that are contained within the panel.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets a value that indicates the dimension by which child elements are stacked.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1WrapPanel Class
C1.Silverlight Namespace


ItemHeight Property

[image]

.NET Framework Class Library
C1WrapPanel..::.ItemHeight Property
C1WrapPanel Class See Also
Gets or sets a value that specifies the height of all items that are contained within the panel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double ItemHeight { get; set; }
Visual Basic (Declaration)
Public Property ItemHeight As Double

See Also

C1WrapPanel Class
C1.Silverlight Namespace


ItemWidth Property

[image]

.NET Framework Class Library
C1WrapPanel..::.ItemWidth Property
C1WrapPanel Class See Also
Gets or sets a value that specifies the width of all items that are contained within the panel.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double ItemWidth { get; set; }
Visual Basic (Declaration)
Public Property ItemWidth As Double

See Also

C1WrapPanel Class
C1.Silverlight Namespace


Orientation Property

[image]

.NET Framework Class Library
C1WrapPanel..::.Orientation Property
C1WrapPanel Class See Also
Gets or sets a value that indicates the dimension by which child elements are stacked.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation

See Also

C1WrapPanel Class
C1.Silverlight Namespace


C1WrapPanel Events

[image] [image]

.NET Framework Class Library
C1WrapPanel Events
C1WrapPanel Class See Also

The C1WrapPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1WrapPanel Class
C1.Silverlight Namespace


CancelEventArgs Class

[image]

.NET Framework Class Library
CancelEventArgs Class
Members See Also
Provides data for a cancelable event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class CancelEventArgs : EventArgs
Visual Basic (Declaration)
Public Class CancelEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.CancelEventArgs

See Also

CancelEventArgs Members
C1.Silverlight Namespace


CancelEventArgs Members

[image] [image]

.NET Framework Class Library
CancelEventArgs Members
CancelEventArgs Class Constructors Methods Properties See Also

The CancelEventArgs type exposes the following members.

Constructors

Name | Description
CancelEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

See Also

CancelEventArgs Class
C1.Silverlight Namespace


CancelEventArgs Constructor

[image]

.NET Framework Class Library
CancelEventArgs Constructor
CancelEventArgs Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public CancelEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

CancelEventArgs Class
C1.Silverlight Namespace


CancelEventArgs Methods

[image] [image]

.NET Framework Class Library
CancelEventArgs Methods
CancelEventArgs Class See Also

The CancelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CancelEventArgs Class
C1.Silverlight Namespace


CancelEventArgs Properties

[image] [image]

.NET Framework Class Library
CancelEventArgs Properties
CancelEventArgs Class See Also

The CancelEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Gets or sets a value indicating whether the event should be canceled.

See Also

CancelEventArgs Class
C1.Silverlight Namespace


Cancel Property

[image]

.NET Framework Class Library
CancelEventArgs..::.Cancel Property
CancelEventArgs Class See Also
Gets or sets a value indicating whether the event should be canceled.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

CancelEventArgs Class
C1.Silverlight Namespace


CancelEventHandler Delegate

[image]

.NET Framework Class Library
CancelEventHandler Delegate
See Also
Represents the method that handles a cancelable event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public delegate void CancelEventHandler(
    Object sender,
    CancelEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub CancelEventHandler ( _
    sender As Object, _
    e As CancelEventArgs _
)

Parameters

sender
Type: System..::.Object
The source of the event.
e
Type: C1.Silverlight..::.CancelEventArgs
A CancelEventArgs that contains the event data.

See Also

C1.Silverlight Namespace


Dock Enumeration

[image]

.NET Framework Class Library
Dock Enumeration
See Also
Specifies how controls are sized and aligned within C1DockPanel controls.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum Dock
Visual Basic (Declaration)
Public Enumeration Dock

Members

Member name | Description
Left | The control's left edge is docked to the left edge of its containing control.
Right | The control's right edge is docked to the right edge of its containing control.
Top | The control's top edge is docked to the top of its containing control.
Bottom | The control's bottom edge is docked to the bottom of its containing control.

See Also

C1.Silverlight Namespace


DragDropEffect Enumeration

[image]

.NET Framework Class Library
DragDropEffect Enumeration
See Also
Specifies the action that will be performed when the user drops a drag source into a drop target element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum DragDropEffect
Visual Basic (Declaration)
Public Enumeration DragDropEffect

Members

Member name | Description
None | No action.
Move | Move the source element into the target element.
Copy | Copy the source element into the target element.

See Also

C1.Silverlight Namespace


DragDropEventArgs Class

[image]

.NET Framework Class Library
DragDropEventArgs Class
Members See Also
Class that contains data for drag-and-drop events.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class DragDropEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DragDropEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.DragDropEventArgs

See Also

DragDropEventArgs Members
C1.Silverlight Namespace


DragDropEventArgs Members

[image] [image]

.NET Framework Class Library
DragDropEventArgs Members
DragDropEventArgs Class Constructors Methods Properties See Also

The DragDropEventArgs type exposes the following members.

Constructors

Name | Description
DragDropEventArgs | Initializes a new instance of a DragDropEventArgs.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPosition | Gets the mouse coordinates relative to a given UIElement.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DragSource | Gets the UIElement that is acting as a drag source.
DropTarget | Gets the UIElement that is acting as a drop target.
Effect | Gets or sets the DragDropEffect that will be applied when the user drops the DragSource element into the DropTarget element.
ScrollViewer | Gets or sets the ScrollViewer that will scroll automatically during the drag drop operation when the mouse is near its edge.

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DragDropEventArgs Constructor

[image]

.NET Framework Class Library
DragDropEventArgs Constructor
DragDropEventArgs Class See Also
Initializes a new instance of a DragDropEventArgs.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DragDropEventArgs(
    MouseEventArgs e,
    UIElement source,
    UIElement target,
    DragDropEffect effect,
    ScrollViewer scrollViewer
)
Visual Basic (Declaration)
Public Sub New ( _
    e As MouseEventArgs, _
    source As UIElement, _
    target As UIElement, _
    effect As DragDropEffect, _
    scrollViewer As ScrollViewer _
)

Parameters

e
Type: System.Windows.Input..::.MouseEventArgs
MouseEventArgs that contains mouse state information.
source
Type: System.Windows..::.UIElement
UIElement acting as a drag source.
target
Type: System.Windows..::.UIElement
UIElement acting as a drop target.
effect
Type: C1.Silverlight..::.DragDropEffect
DragDropEffect that specifies the action to be performed when the drag and drop process is completed.
scrollViewer
Type: System.Windows.Controls..::.ScrollViewer
ScrollViewer that scrolls to show the target location.

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DragDropEventArgs Methods

[image] [image]

.NET Framework Class Library
DragDropEventArgs Methods
DragDropEventArgs Class See Also

The DragDropEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPosition | Gets the mouse coordinates relative to a given UIElement.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


GetPosition Method

[image]

.NET Framework Class Library
DragDropEventArgs..::.GetPosition Method
DragDropEventArgs Class See Also
Gets the mouse coordinates relative to a given UIElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point GetPosition(
    UIElement relativeTo
)
Visual Basic (Declaration)
Public Function GetPosition ( _
    relativeTo As UIElement _
) As Point

Parameters

relativeTo
Type: System.Windows..::.UIElement
UIElement that determines the coordinate system of the return value.

Return Value

A Point that contains the mouse coordinates relative to the UIElement specified by the relativeTo parameter.

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DragDropEventArgs Properties

[image] [image]

.NET Framework Class Library
DragDropEventArgs Properties
DragDropEventArgs Class See Also

The DragDropEventArgs type exposes the following members.

Properties

Name | Description
DragSource | Gets the UIElement that is acting as a drag source.
DropTarget | Gets the UIElement that is acting as a drop target.
Effect | Gets or sets the DragDropEffect that will be applied when the user drops the DragSource element into the DropTarget element.
ScrollViewer | Gets or sets the ScrollViewer that will scroll automatically during the drag drop operation when the mouse is near its edge.

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DragSource Property

[image]

.NET Framework Class Library
DragDropEventArgs..::.DragSource Property
DragDropEventArgs Class See Also
Gets the UIElement that is acting as a drag source.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public UIElement DragSource { get; set; }
Visual Basic (Declaration)
Public Property DragSource As UIElement

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DropTarget Property

[image]

.NET Framework Class Library
DragDropEventArgs..::.DropTarget Property
DragDropEventArgs Class See Also
Gets the UIElement that is acting as a drop target.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public UIElement DropTarget { get; set; }
Visual Basic (Declaration)
Public Property DropTarget As UIElement

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


Effect Property

[image]

.NET Framework Class Library
DragDropEventArgs..::.Effect Property
DragDropEventArgs Class See Also
Gets or sets the DragDropEffect that will be applied when the user drops the DragSource element into the DropTarget element.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public DragDropEffect Effect { get; set; }
Visual Basic (Declaration)
Public Property Effect As DragDropEffect

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


ScrollViewer Property

[image]

.NET Framework Class Library
DragDropEventArgs..::.ScrollViewer Property
DragDropEventArgs Class See Also
Gets or sets the ScrollViewer that will scroll automatically during the drag drop operation when the mouse is near its edge.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public ScrollViewer ScrollViewer { get; set; }
Visual Basic (Declaration)
Public Property ScrollViewer As ScrollViewer

Remarks

The C1DragDropManager selects the ScrollViewer by default. If there are several nested scroll viewers, the innermost is selected by default. If that is not the desired behavior, callers may modify this behavior by setting this property to a reference to the desired ScrollViewer.

See Also

DragDropEventArgs Class
C1.Silverlight Namespace


DragDropEventHandler Delegate

[image]

.NET Framework Class Library
DragDropEventHandler Delegate
See Also
Method used to handle drag drop events.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public delegate void DragDropEventHandler(
    Object source,
    DragDropEventArgs e
)
Visual Basic (Declaration)
Public Delegate Sub DragDropEventHandler ( _
    source As Object, _
    e As DragDropEventArgs _
)

Parameters

source
Type: System..::.Object
Object that raised the event.
e
Type: C1.Silverlight..::.DragDropEventArgs
DragDropEventArgs that contains the event data.

See Also

C1.Silverlight Namespace


DropDownDirection Enumeration

[image]

.NET Framework Class Library
DropDownDirection Enumeration
See Also
Provides the supported expand directions for the C1ComboBox.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum DropDownDirection
Visual Basic (Declaration)
Public Enumeration DropDownDirection

Members

Member name | Description
BelowOrAbove | Tries to open the drop-down C1ComboBox below the header. If it is not possible tries to open above it.
AboveOrBelow | Tries to open the drop-down C1ComboBox above the header. If it is not possible tries to open below it.
ForceBelow | Forces the drop-down C1ComboBox to open below the header.
ForceAbove | Forces the C1ComboBox content to open above the header.

See Also

C1.Silverlight Namespace


Extensions Class

[image]

.NET Framework Class Library
Extensions Class
Members See Also
Class that provides static extension methods for several other classes.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static class Extensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class Extensions

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.Extensions

See Also

Extensions Members
C1.Silverlight Namespace


Extensions Members

[image] [image]

.NET Framework Class Library
Extensions Members
Extensions Class Methods See Also

The Extensions type exposes the following members.

Methods

Name | Description
C1TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object.
MakeRelative | Makes the popup relative to another FrameworkElement.

See Also

Extensions Class
C1.Silverlight Namespace


Extensions Methods

[image] [image]

.NET Framework Class Library
Extensions Methods
Extensions Class See Also

The Extensions type exposes the following members.

Methods

Name | Description
C1TransformToVisual | Returns a transform object that can be used to transform coordinates from the UIElement to the specified object.
MakeRelative | Makes the popup relative to another FrameworkElement.

See Also

Extensions Class
C1.Silverlight Namespace


C1TransformToVisual Method

[image]

.NET Framework Class Library
Extensions..::.C1TransformToVisual Method
Extensions Class See Also
Returns a transform object that can be used to transform coordinates from the UIElement to the specified object.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static GeneralTransform C1TransformToVisual(
    this UIElement element,
    UIElement visual
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function C1TransformToVisual ( _
    element As UIElement, _
    visual As UIElement _
) As GeneralTransform

Parameters

element
Type: System.Windows..::.UIElement
The UIElement that defines the source coordinates.
visual
Type: System.Windows..::.UIElement
The UIElement that defines the target coordinates.

Return Value

A transform object that can be used to transform coordinates from the UIElement to the specified object.

Remarks

This is an improved version of TransformToVisual(UIElement). It works in cases that TransformToVisual doesn't, like with UIElements inside Popups.

See Also

Extensions Class
C1.Silverlight Namespace


MakeRelative Method

[image]

.NET Framework Class Library
Extensions..::.MakeRelative Method
Extensions Class See Also
Makes the popup relative to another FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void MakeRelative(
    this Popup popup,
    FrameworkElement relativeElement,
    Func<List<AnchorMatching>> getLocations
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub MakeRelative ( _
    popup As Popup, _
    relativeElement As FrameworkElement, _
    getLocations As Func(Of List(Of AnchorMatching)) _
)

Parameters

popup
Type: System.Windows.Controls.Primitives..::.Popup
Popup to handle.
relativeElement
Type: System.Windows..::.FrameworkElement
Element used to locate the popup.
getLocations
Type: System..::.Func <(Of <( List <(Of <( AnchorMatching >)>)>)>)
Function that provides the ordered list of AnchorMatching defining the corners to bound of both elements.

See Also

Extensions Class
C1.Silverlight Namespace


LatLongConverter Class

[image]

.NET Framework Class Library
LatLongConverter Class
Members See Also
Converts from a string to a Point representing a geographic coordinate and back.

Namespace: C1.Silverlight
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class LatLongConverter : TypeConverter
Visual Basic (Declaration)
Public Class LatLongConverter _
    Inherits TypeConverter

Remarks

When converting from a string, LatLongConverter accepts any of the formats defined by LatLongFormat.

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
C1.Silverlight..::.LatLongConverter

See Also

LatLongConverter Members
C1.Silverlight Namespace


LatLongConverter Members

[image] [image]

.NET Framework Class Library
LatLongConverter Members
LatLongConverter Class Methods See Also

The LatLongConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertTo | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
ConvertFrom | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertTo | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatLongConverter Class
C1.Silverlight Namespace


LatLongConverter Methods

[image] [image]

.NET Framework Class Library
LatLongConverter Methods
LatLongConverter Class See Also

The LatLongConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertTo | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
ConvertFrom | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertTo | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LatLongConverter Class
C1.Silverlight Namespace


LatLongFormat Enumeration

[image]

.NET Framework Class Library
LatLongFormat Enumeration
See Also
Defines different string representations of geographic coordinates.

Namespace: C1.Silverlight
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public enum LatLongFormat
Visual Basic (Declaration)
Public Enumeration LatLongFormat

Members

Member name | Description
SignedDegrees | Represents a geographic coordinate as a comma separated pair of signed numbers.
DegreesMinutes | Represents a geographic coordinate as pair of values in degrees, minutes and hemisphere. Example: 18°35.438'N 14°15.314'W
DegreesMinutesSeconds | Represents a geographic coordinate as pair of values in degrees, minutes, seconds and hemisphere. Example: 18°35'20.07"N 14°15'48.77"W

See Also

C1.Silverlight Namespace


MaskFormat Enumeration

[image]

.NET Framework Class Library
MaskFormat Enumeration
See Also
Defines how to format the value inside of a [!:MaskedTextBox].

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public enum MaskFormat
Visual Basic (Declaration)
Public Enumeration MaskFormat

Members

Member name | Description
IncludePrompt | Return text input by the user as well as any instances of the prompt character.
IncludeLiterals | Return text input by the user as well as any literal characters defined in the mask.
IncludePromptAndLiterals | Return text input by the user as well as any literal characters defined in the mask and any instances of the prompt character.
ExcludePromptAndLiterals | Return only text input by the user.

See Also

C1.Silverlight Namespace


MouseDragEventArgs Class

[image]

.NET Framework Class Library
MouseDragEventArgs Class
Members See Also
Provides data for mouse drag related events.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class MouseDragEventArgs : EventArgs
Visual Basic (Declaration)
Public Class MouseDragEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.MouseDragEventArgs

See Also

MouseDragEventArgs Members
C1.Silverlight Namespace


MouseDragEventArgs Members

[image] [image]

.NET Framework Class Library
MouseDragEventArgs Members
MouseDragEventArgs Class Constructors Methods Properties See Also

The MouseDragEventArgs type exposes the following members.

Constructors

Name | Description
MouseDragEventArgs | Initializes a MouseDragEventArgs object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CurrentPoint | Gets the current mouse position, relative to the application root.
DeltaX | Gets the variation of X between the previous mouse position and the current one.
DeltaY | Gets the variation of Y between the previous mouse position and the current one.
PreviousPoint | Gets the mouse position from the previous drag event, relative to the application root.
StartPoint | Gets the mouse position where the drag started, relative to the application root.
TotalDeltaX | Gets the variation of X between the mouse position where the drag started and the current one.
TotalDeltaY | Gets the variation of Y between the mouse position where the drag started and the current one.

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


MouseDragEventArgs Constructor

[image]

.NET Framework Class Library
MouseDragEventArgs Constructor
MouseDragEventArgs Class See Also
Initializes a MouseDragEventArgs object.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public MouseDragEventArgs(
    Point startPoint,
    Point previousPoint,
    Point currentPoint
)
Visual Basic (Declaration)
Public Sub New ( _
    startPoint As Point, _
    previousPoint As Point, _
    currentPoint As Point _
)

Parameters

startPoint
Type: System.Windows..::.Point
The mouse position where the drag started, relative to the application root.
previousPoint
Type: System.Windows..::.Point
The mouse position from the previous drag event, relative to the application root.
currentPoint
Type: System.Windows..::.Point
The current mouse position, relative to the application root.

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


MouseDragEventArgs Methods

[image] [image]

.NET Framework Class Library
MouseDragEventArgs Methods
MouseDragEventArgs Class See Also

The MouseDragEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPosition | Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


GetPosition Method

[image]

.NET Framework Class Library
MouseDragEventArgs..::.GetPosition Method
MouseDragEventArgs Class See Also
Returns the x- and y-coordinates of the mouse pointer position, optionally evaluated against a coordinate origin of a supplied UIElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point GetPosition(
    UIElement relativeTo
)
Visual Basic (Declaration)
Public Function GetPosition ( _
    relativeTo As UIElement _
) As Point

Parameters

relativeTo
Type: System.Windows..::.UIElement
Any UIElement-derived object that is contained by the Silverlight plug-in and connected to the object tree. To specify the object relative to the overall Silverlight coordinate system, set the relativeTo parameter to null.

Return Value

A Point that represents the current x- and y-coordinates of the mouse pointer position. If null was passed as relativeTo, this coordinate is for the overall Silverlight plug-in content area. If a non-null relativeTo was passed, this coordinate is relative to the object referenced by relativeTo.

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


MouseDragEventArgs Properties

[image] [image]

.NET Framework Class Library
MouseDragEventArgs Properties
MouseDragEventArgs Class See Also

The MouseDragEventArgs type exposes the following members.

Properties

Name | Description
CurrentPoint | Gets the current mouse position, relative to the application root.
DeltaX | Gets the variation of X between the previous mouse position and the current one.
DeltaY | Gets the variation of Y between the previous mouse position and the current one.
PreviousPoint | Gets the mouse position from the previous drag event, relative to the application root.
StartPoint | Gets the mouse position where the drag started, relative to the application root.
TotalDeltaX | Gets the variation of X between the mouse position where the drag started and the current one.
TotalDeltaY | Gets the variation of Y between the mouse position where the drag started and the current one.

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


CurrentPoint Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.CurrentPoint Property
MouseDragEventArgs Class See Also
Gets the current mouse position, relative to the application root.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point CurrentPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentPoint As Point

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


DeltaX Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.DeltaX Property
MouseDragEventArgs Class See Also
Gets the variation of X between the previous mouse position and the current one.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DeltaX { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaX As Double

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


DeltaY Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.DeltaY Property
MouseDragEventArgs Class See Also
Gets the variation of Y between the previous mouse position and the current one.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DeltaY { get; }
Visual Basic (Declaration)
Public ReadOnly Property DeltaY As Double

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


PreviousPoint Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.PreviousPoint Property
MouseDragEventArgs Class See Also
Gets the mouse position from the previous drag event, relative to the application root.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point PreviousPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousPoint As Point

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


StartPoint Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.StartPoint Property
MouseDragEventArgs Class See Also
Gets the mouse position where the drag started, relative to the application root.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point StartPoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property StartPoint As Point

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


TotalDeltaX Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.TotalDeltaX Property
MouseDragEventArgs Class See Also
Gets the variation of X between the mouse position where the drag started and the current one.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double TotalDeltaX { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalDeltaX As Double

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


TotalDeltaY Property

[image]

.NET Framework Class Library
MouseDragEventArgs..::.TotalDeltaY Property
MouseDragEventArgs Class See Also
Gets the variation of Y between the mouse position where the drag started and the current one.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double TotalDeltaY { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalDeltaY As Double

See Also

MouseDragEventArgs Class
C1.Silverlight Namespace


MouseWheelEventArgs Class

[image]

.NET Framework Class Library
MouseWheelEventArgs Class
Members See Also
Provides data for mouse wheel related events.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class MouseWheelEventArgs : EventArgs
Visual Basic (Declaration)
Public Class MouseWheelEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.MouseWheelEventArgs

See Also

MouseWheelEventArgs Members
C1.Silverlight Namespace


MouseWheelEventArgs Members

[image] [image]

.NET Framework Class Library
MouseWheelEventArgs Members
MouseWheelEventArgs Class Constructors Methods Properties See Also

The MouseWheelEventArgs type exposes the following members.

Constructors

Name | Description
MouseWheelEventArgs | Initializes a MouseWheelEventArgs object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Delta | Gets the number of wheel movements.
Handled | Gets or sets a value that marks the event as handled, and prevents the browser from performing the default action.
Point | Gets the mouse position, relative to the application root, where the wheel was moved.

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


MouseWheelEventArgs Constructor

[image]

.NET Framework Class Library
MouseWheelEventArgs Constructor
MouseWheelEventArgs Class See Also
Initializes a MouseWheelEventArgs object.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public MouseWheelEventArgs(
    double delta,
    Point position
)
Visual Basic (Declaration)
Public Sub New ( _
    delta As Double, _
    position As Point _
)

Parameters

delta
Type: System..::.Double
The number of wheel movements.
position
Type: System.Windows..::.Point
The mouse position, relative to the application root, where the wheel was moved.

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


MouseWheelEventArgs Methods

[image] [image]

.NET Framework Class Library
MouseWheelEventArgs Methods
MouseWheelEventArgs Class See Also

The MouseWheelEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


MouseWheelEventArgs Properties

[image] [image]

.NET Framework Class Library
MouseWheelEventArgs Properties
MouseWheelEventArgs Class See Also

The MouseWheelEventArgs type exposes the following members.

Properties

Name | Description
Delta | Gets the number of wheel movements.
Handled | Gets or sets a value that marks the event as handled, and prevents the browser from performing the default action.
Point | Gets the mouse position, relative to the application root, where the wheel was moved.

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


Delta Property

[image]

.NET Framework Class Library
MouseWheelEventArgs..::.Delta Property
MouseWheelEventArgs Class See Also
Gets the number of wheel movements.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double Delta { get; }
Visual Basic (Declaration)
Public ReadOnly Property Delta As Double

Remarks

A positive value indicates a forward movement, and a negative value indicates a backward movement.

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


Handled Property

[image]

.NET Framework Class Library
MouseWheelEventArgs..::.Handled Property
MouseWheelEventArgs Class See Also
Gets or sets a value that marks the event as handled, and prevents the browser from performing the default action.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool Handled { get; set; }
Visual Basic (Declaration)
Public Property Handled As Boolean

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


Point Property

[image]

.NET Framework Class Library
MouseWheelEventArgs..::.Point Property
MouseWheelEventArgs Class See Also
Gets the mouse position, relative to the application root, where the wheel was moved.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Point Point { get; }
Visual Basic (Declaration)
Public ReadOnly Property Point As Point

See Also

MouseWheelEventArgs Class
C1.Silverlight Namespace


PopupUtil Class

[image]

.NET Framework Class Library
PopupUtil Class
Members See Also
Utility methods for popups.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static class PopupUtil
Visual Basic (Declaration)
Public NotInheritable Class PopupUtil

Inheritance Hierarchy

System..::.Object
C1.Silverlight..::.PopupUtil

See Also

PopupUtil Members
C1.Silverlight Namespace


PopupUtil Members

[image] [image]

.NET Framework Class Library
PopupUtil Members
PopupUtil Class Methods See Also

Methods

Name | Description
Position | Overloaded.
TestPosition | Overloaded.

See Also

PopupUtil Class
C1.Silverlight Namespace


PopupUtil Methods

[image] [image]

.NET Framework Class Library
PopupUtil Methods
PopupUtil Class See Also

Methods

Name | Description
Position | Overloaded.
TestPosition | Overloaded.

See Also

PopupUtil Class
C1.Silverlight Namespace


Position Method

[image] [image]

.NET Framework Class Library
PopupUtil..::.Position Method
PopupUtil Class See Also

Overload List

Name | Description
Position(Popup, Point) | Positions a Popup in a specified absolute point.
Position(Popup, Anchor, FrameworkElement, Anchor) | Positions a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.

See Also

PopupUtil Class
PopupUtil Members
C1.Silverlight Namespace


Position Method (Popup, Point)

[image]

.NET Framework Class Library
PopupUtil..::.Position Method (Popup, Point)
PopupUtil Class See Also
Positions a Popup in a specified absolute point.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Position(
    Popup popup,
    Point point
)
Visual Basic (Declaration)
Public Shared Sub Position ( _
    popup As Popup, _
    point As Point _
)

Parameters

popup
Type: System.Windows.Controls.Primitives..::.Popup
The popup to position.
point
Type: System.Windows..::.Point
The popup position.

See Also

PopupUtil Class
Position Overload
C1.Silverlight Namespace


Position Method (Popup, Anchor, FrameworkElement, Anchor)

[image]

.NET Framework Class Library
PopupUtil..::.Position Method (Popup, Anchor, FrameworkElement, Anchor)
PopupUtil Class See Also
Positions a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static void Position(
    Popup popup,
    Anchor popupAnchor,
    FrameworkElement element,
    Anchor elementAnchor
)
Visual Basic (Declaration)
Public Shared Sub Position ( _
    popup As Popup, _
    popupAnchor As Anchor, _
    element As FrameworkElement, _
    elementAnchor As Anchor _
)

Parameters

popup
Type: System.Windows.Controls.Primitives..::.Popup
The popup to position.
popupAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the Popup.
element
Type: System.Windows..::.FrameworkElement
The FrameworkElement to use as reference.
elementAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the FrameworkElement.

See Also

PopupUtil Class
Position Overload
C1.Silverlight Namespace


TestPosition Method

[image] [image]

.NET Framework Class Library
PopupUtil..::.TestPosition Method
PopupUtil Class See Also

Overload List

Name | Description
TestPosition(Popup, Anchor, FrameworkElement, Anchor) | Calculates the position of a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.
TestPosition(Popup, Anchor, FrameworkElement, Anchor, Double, Double) | Calculates the position of a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.
TestPosition(FrameworkElement, Anchor, FrameworkElement, Anchor, Double, Double) | Calculates the position of a FrameworkElement so that the specified point in the FrameworkElement matches the specified point of another FrameworkElement.

See Also

PopupUtil Class
PopupUtil Members
C1.Silverlight Namespace


TestPosition Method (Popup, Anchor, FrameworkElement, Anchor)

[image]

.NET Framework Class Library
PopupUtil..::.TestPosition Method (Popup, Anchor, FrameworkElement, Anchor)
PopupUtil Class See Also
Calculates the position of a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Point TestPosition(
    Popup popup,
    Anchor popupAnchor,
    FrameworkElement element,
    Anchor elementAnchor
)
Visual Basic (Declaration)
Public Shared Function TestPosition ( _
    popup As Popup, _
    popupAnchor As Anchor, _
    element As FrameworkElement, _
    elementAnchor As Anchor _
) As Point

Parameters

popup
Type: System.Windows.Controls.Primitives..::.Popup
The popup to position.
popupAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the Popup.
element
Type: System.Windows..::.FrameworkElement
The FrameworkElement to use as reference.
elementAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the FrameworkElement.

Return Value

The absolute point where the popup would be located

See Also

PopupUtil Class
TestPosition Overload
C1.Silverlight Namespace


TestPosition Method (Popup, Anchor, FrameworkElement, Anchor, Double, Double)

[image]

.NET Framework Class Library
PopupUtil..::.TestPosition Method (Popup, Anchor, FrameworkElement, Anchor, Double, Double)
PopupUtil Class See Also
Calculates the position of a Popup so that the specified point in the Popup matches the specified point of a FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Point TestPosition(
    Popup popup,
    Anchor popupAnchor,
    FrameworkElement element,
    Anchor elementAnchor,
    double overlapHorizontal,
    double overlapVertical
)
Visual Basic (Declaration)
Public Shared Function TestPosition ( _
    popup As Popup, _
    popupAnchor As Anchor, _
    element As FrameworkElement, _
    elementAnchor As Anchor, _
    overlapHorizontal As Double, _
    overlapVertical As Double _
) As Point

Parameters

popup
Type: System.Windows.Controls.Primitives..::.Popup
The popup to position.
popupAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the Popup.
element
Type: System.Windows..::.FrameworkElement
The FrameworkElement to use as reference.
elementAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the FrameworkElement.
overlapHorizontal
Type: System..::.Double
The horizontal overlap between the elements (used for corner matching's).
overlapVertical
Type: System..::.Double
The vertical overlap between the elements (used for corner matching's).

Return Value

The absolute point where the popup would be located

See Also

PopupUtil Class
TestPosition Overload
C1.Silverlight Namespace


TestPosition Method (FrameworkElement, Anchor, FrameworkElement, Anchor, Double, Double)

[image]

.NET Framework Class Library
PopupUtil..::.TestPosition Method (FrameworkElement, Anchor, FrameworkElement, Anchor, Double, Double)
PopupUtil Class See Also
Calculates the position of a FrameworkElement so that the specified point in the FrameworkElement matches the specified point of another FrameworkElement.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public static Point TestPosition(
    FrameworkElement positionElement,
    Anchor positionAnchor,
    FrameworkElement element,
    Anchor elementAnchor,
    double overlapHorizontal,
    double overlapVertical
)
Visual Basic (Declaration)
Public Shared Function TestPosition ( _
    positionElement As FrameworkElement, _
    positionAnchor As Anchor, _
    element As FrameworkElement, _
    elementAnchor As Anchor, _
    overlapHorizontal As Double, _
    overlapVertical As Double _
) As Point

Parameters

positionElement
Type: System.Windows..::.FrameworkElement
The element to position.
positionAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the element to position.
element
Type: System.Windows..::.FrameworkElement
The FrameworkElement to use as reference.
elementAnchor
Type: C1.Silverlight..::.Anchor
An Anchor value specifying the point in the FrameworkElement used as reference.
overlapHorizontal
Type: System..::.Double
The horizontal overlap between the elements (used for corner matching's).
overlapVertical
Type: System..::.Double
The vertical overlap between the elements (used for corner matching's).

Return Value

The absolute point where the FrameworkElement would be located.

See Also

PopupUtil Class
TestPosition Overload
C1.Silverlight Namespace


PrepareDropDownEventArgs Class

[image]

.NET Framework Class Library
PrepareDropDownEventArgs Class
Members See Also
Argument of the event fired before the drop-down box is opened.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class PrepareDropDownEventArgs : EventArgs
Visual Basic (Declaration)
Public Class PrepareDropDownEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.PrepareDropDownEventArgs

See Also

PrepareDropDownEventArgs Members
C1.Silverlight Namespace


PrepareDropDownEventArgs Members

[image] [image]

.NET Framework Class Library
PrepareDropDownEventArgs Members
PrepareDropDownEventArgs Class Constructors Methods Properties See Also

The PrepareDropDownEventArgs type exposes the following members.

Constructors

Name | Description
PrepareDropDownEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DropDownHeight | Height of the DropDown, modify to set a custom size, set double.NaN to use default.
DropDownWidth | Width of the DropDown, modify to set a custom size, set double.NaN to use default.

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


PrepareDropDownEventArgs Constructor

[image]

.NET Framework Class Library
PrepareDropDownEventArgs Constructor
PrepareDropDownEventArgs Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public PrepareDropDownEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


PrepareDropDownEventArgs Methods

[image] [image]

.NET Framework Class Library
PrepareDropDownEventArgs Methods
PrepareDropDownEventArgs Class See Also

The PrepareDropDownEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


PrepareDropDownEventArgs Properties

[image] [image]

.NET Framework Class Library
PrepareDropDownEventArgs Properties
PrepareDropDownEventArgs Class See Also

The PrepareDropDownEventArgs type exposes the following members.

Properties

Name | Description
DropDownHeight | Height of the DropDown, modify to set a custom size, set double.NaN to use default.
DropDownWidth | Width of the DropDown, modify to set a custom size, set double.NaN to use default.

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


DropDownHeight Property

[image]

.NET Framework Class Library
PrepareDropDownEventArgs..::.DropDownHeight Property
PrepareDropDownEventArgs Class See Also
Height of the DropDown, modify to set a custom size, set double.NaN to use default.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


DropDownWidth Property

[image]

.NET Framework Class Library
PrepareDropDownEventArgs..::.DropDownWidth Property
PrepareDropDownEventArgs Class See Also
Width of the DropDown, modify to set a custom size, set double.NaN to use default.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double

See Also

PrepareDropDownEventArgs Class
C1.Silverlight Namespace


PropertyChangedEventArgs(T) Class

[image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>) Class
Members See Also
Provides event data for OnPropertyChanged events.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class PropertyChangedEventArgs<T> : EventArgs
Visual Basic (Declaration)
Public Class PropertyChangedEventArgs(Of T) _
    Inherits EventArgs

Type Parameters

T

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.PropertyChangedEventArgs<(Of <(T>)>)

See Also

PropertyChangedEventArgs<(Of <(T>)>) Members
C1.Silverlight Namespace


PropertyChangedEventArgs(T) Members

[image] [image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>) Members
PropertyChangedEventArgs<(Of <(T>)>) Class Constructors Methods Properties See Also

The PropertyChangedEventArgs<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
PropertyChangedEventArgs<(Of <(T>)>) |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NewValue | The value of the property after the change.
OldValue | The value of the property before the change.

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


PropertyChangedEventArgs(T) Constructor

[image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>) Constructor
PropertyChangedEventArgs<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public PropertyChangedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


PropertyChangedEventArgs(T) Methods

[image] [image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>) Methods
PropertyChangedEventArgs<(Of <(T>)>) Class See Also

The PropertyChangedEventArgs<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


PropertyChangedEventArgs(T) Properties

[image] [image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>) Properties
PropertyChangedEventArgs<(Of <(T>)>) Class See Also

The PropertyChangedEventArgs<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
NewValue | The value of the property after the change.
OldValue | The value of the property before the change.

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


NewValue Property

[image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>)..::.NewValue Property
PropertyChangedEventArgs<(Of <(T>)>) Class See Also
The value of the property after the change.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public T NewValue { get; set; }
Visual Basic (Declaration)
Public Property NewValue As T

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


OldValue Property

[image]

.NET Framework Class Library
PropertyChangedEventArgs<(Of <(T>)>)..::.OldValue Property
PropertyChangedEventArgs<(Of <(T>)>) Class See Also
The value of the property before the change.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public T OldValue { get; set; }
Visual Basic (Declaration)
Public Property OldValue As T

See Also

PropertyChangedEventArgs<(Of <(T>)>) Class
C1.Silverlight Namespace


SourcedEventArgs Class

[image]

.NET Framework Class Library
SourcedEventArgs Class
Members See Also
Contains data for events with a source different from the object firing the event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class SourcedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class SourcedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.SourcedEventArgs

See Also

SourcedEventArgs Members
C1.Silverlight Namespace


SourcedEventArgs Members

[image] [image]

.NET Framework Class Library
SourcedEventArgs Members
SourcedEventArgs Class Constructors Methods Properties See Also

The SourcedEventArgs type exposes the following members.

Constructors

Name | Description
SourcedEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Source | Gets or sets the source of the event.

See Also

SourcedEventArgs Class
C1.Silverlight Namespace


SourcedEventArgs Constructor

[image]

.NET Framework Class Library
SourcedEventArgs Constructor
SourcedEventArgs Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public SourcedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

SourcedEventArgs Class
C1.Silverlight Namespace


SourcedEventArgs Methods

[image] [image]

.NET Framework Class Library
SourcedEventArgs Methods
SourcedEventArgs Class See Also

The SourcedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SourcedEventArgs Class
C1.Silverlight Namespace


SourcedEventArgs Properties

[image] [image]

.NET Framework Class Library
SourcedEventArgs Properties
SourcedEventArgs Class See Also

The SourcedEventArgs type exposes the following members.

Properties

Name | Description
Source | Gets or sets the source of the event.

See Also

SourcedEventArgs Class
C1.Silverlight Namespace


Source Property

[image]

.NET Framework Class Library
SourcedEventArgs..::.Source Property
SourcedEventArgs Class See Also
Gets or sets the source of the event.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public Object Source { get; set; }
Visual Basic (Declaration)
Public Property Source As Object

See Also

SourcedEventArgs Class
C1.Silverlight Namespace


TextEditedEventArgs Class

[image]

.NET Framework Class Library
TextEditedEventArgs Class
Members See Also
AutoComplete event details.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class TextEditedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class TextEditedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.TextEditedEventArgs

See Also

TextEditedEventArgs Members
C1.Silverlight Namespace


TextEditedEventArgs Members

[image] [image]

.NET Framework Class Library
TextEditedEventArgs Members
TextEditedEventArgs Class Constructors Methods Properties See Also

The TextEditedEventArgs type exposes the following members.

Constructors

Name | Description
TextEditedEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel | Cancel the input of the new text.
CurrentSelectionStart | Current selection start.
CurrentText | Current text.
NewSelectionStart | Index where the selection will start after the AutoComplete.
NewText | Text that will be put in the control after the AutoComplete.

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


TextEditedEventArgs Constructor

[image]

.NET Framework Class Library
TextEditedEventArgs Constructor
TextEditedEventArgs Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public TextEditedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


TextEditedEventArgs Methods

[image] [image]

.NET Framework Class Library
TextEditedEventArgs Methods
TextEditedEventArgs Class See Also

The TextEditedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


TextEditedEventArgs Properties

[image] [image]

.NET Framework Class Library
TextEditedEventArgs Properties
TextEditedEventArgs Class See Also

The TextEditedEventArgs type exposes the following members.

Properties

Name | Description
Cancel | Cancel the input of the new text.
CurrentSelectionStart | Current selection start.
CurrentText | Current text.
NewSelectionStart | Index where the selection will start after the AutoComplete.
NewText | Text that will be put in the control after the AutoComplete.

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


Cancel Property

[image]

.NET Framework Class Library
TextEditedEventArgs..::.Cancel Property
TextEditedEventArgs Class See Also
Cancel the input of the new text.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


CurrentSelectionStart Property

[image]

.NET Framework Class Library
TextEditedEventArgs..::.CurrentSelectionStart Property
TextEditedEventArgs Class See Also
Current selection start.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int CurrentSelectionStart { get; set; }
Visual Basic (Declaration)
Public Property CurrentSelectionStart As Integer

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


CurrentText Property

[image]

.NET Framework Class Library
TextEditedEventArgs..::.CurrentText Property
TextEditedEventArgs Class See Also
Current text.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string CurrentText { get; set; }
Visual Basic (Declaration)
Public Property CurrentText As String

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


NewSelectionStart Property

[image]

.NET Framework Class Library
TextEditedEventArgs..::.NewSelectionStart Property
TextEditedEventArgs Class See Also
Index where the selection will start after the AutoComplete.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public int NewSelectionStart { get; set; }
Visual Basic (Declaration)
Public Property NewSelectionStart As Integer

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


NewText Property

[image]

.NET Framework Class Library
TextEditedEventArgs..::.NewText Property
TextEditedEventArgs Class See Also
Text that will be put in the control after the AutoComplete.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string NewText { get; set; }
Visual Basic (Declaration)
Public Property NewText As String

See Also

TextEditedEventArgs Class
C1.Silverlight Namespace


ValidateInputEventArgs Class

[image]

.NET Framework Class Library
ValidateInputEventArgs Class
Members See Also
Arguments for the event fired to validate the input.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public class ValidateInputEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ValidateInputEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight..::.ValidateInputEventArgs

See Also

ValidateInputEventArgs Members
C1.Silverlight Namespace


ValidateInputEventArgs Members

[image] [image]

.NET Framework Class Library
ValidateInputEventArgs Members
ValidateInputEventArgs Class Constructors Methods Properties See Also

The ValidateInputEventArgs type exposes the following members.

Constructors

Name | Description
ValidateInputEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Input | New text input
IsValidInput | Set this flag to undo the edits if the input is not valid.

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


ValidateInputEventArgs Constructor

[image]

.NET Framework Class Library
ValidateInputEventArgs Constructor
ValidateInputEventArgs Class See Also

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public ValidateInputEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


ValidateInputEventArgs Methods

[image] [image]

.NET Framework Class Library
ValidateInputEventArgs Methods
ValidateInputEventArgs Class See Also

The ValidateInputEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


ValidateInputEventArgs Properties

[image] [image]

.NET Framework Class Library
ValidateInputEventArgs Properties
ValidateInputEventArgs Class See Also

The ValidateInputEventArgs type exposes the following members.

Properties

Name | Description
Input | New text input
IsValidInput | Set this flag to undo the edits if the input is not valid.

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


Input Property

[image]

.NET Framework Class Library
ValidateInputEventArgs..::.Input Property
ValidateInputEventArgs Class See Also
New text input

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public string Input { get; internal set; }
Visual Basic (Declaration)
Public Property Input As String

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


IsValidInput Property

[image]

.NET Framework Class Library
ValidateInputEventArgs..::.IsValidInput Property
ValidateInputEventArgs Class See Also
Set this flag to undo the edits if the input is not valid.

Namespace: C1.Silverlight
Assembly: C1.Silverlight (in C1.Silverlight.dll)

Syntax

C#
public bool IsValidInput { get; set; }
Visual Basic (Declaration)
Public Property IsValidInput As Boolean

See Also

ValidateInputEventArgs Class
C1.Silverlight Namespace


C1.Silverlight.Chart Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Chart Namespace

Classes

Class | Description
Action | Represents action object such as
ActionCollection | Represents a collection of Action objects that describe the interactive behavior of a C1Chart at runtime.
Area | Represents the area plot elements that fills the area between data point and base line.
Axis | Represents axis on the plot.
AxisCollection | Represents collection of axes.
Bar | Represents bar plot element.
BarColumnOptions | Bar/column chart options.
BasePieRenderer | Base class for pie renderers.
BaseRenderer | Presents base renderer class. The renderer class performs data visualization.
BoxSymbol | Represents box symbol.
BubbleOptions | Bubble chart options.
BubbleSeries | BubbleSeries can contains values that specify size of the symbol for each data point. Use BubbleSeries to create bubble charts.
C1Chart | Represents a C1Chart control.
C1ChartLegend | Represents the chart legend.
ChartData | Main class of data handling, contains collection of data series.
ChartSubtype | Represents chart type in the gallery.
ChartTypeInfo | Represents the chart type. The type contains from the collection of subtypes that describe different variations of the chart type.
ChartView | Represents class view object that contains all visual plot elements: axes, visualized data.
Converters | Contains static instances of built-in converters.
DataPoint | Represent the single data point that may have several data values.
DataPointConverter | Performs conversion from DataPoint to string based on the specified format string.
DataSeries | Represents data series which contains a group of data values.
DataSeriesCollection | Represents collection of data series.
DotSymbol | Represents a dot symbol.
Extensions | Class that provides static extension methods for several other classes.
FormatConverter | Performs conversion to string based on the specified format string.
HighLowOpenCloseSeries | Represents data series with x, y, high, low, open, close data arrays.
HighLowSeries | Represents data series with X, Y, High and Low values.
HLOC | Represents element of financial chart (high-low-open-close).
Legend | Obsolete. Represents the chart legend.
LegendItem | Represents the item in the chart legend.
LegendItemCollection | Represents the collection of legend items.
Lines | Represents plot element that connects the data points.
Pie | Represents the element of pie chart.
PieRenderContext | Provides information about the render context for pie visualization.
PieRenderer | Performs 2D pie visualization.
PlotElement | Generic plot element.
RadarRenderer | Renders radar charts.
RenderContext | Represents the render context.
Renderer2D | Renderer which creates plot in Cartesian coordinates.
RPolygon | Represents regular polygon.
ScaleAction | Represents the scale action.
ShapeStyle | Describes shape appearance.
Star | Represents star symbol.
Symbol | Represents base class for 2D plot symbols.
TranslateAction | Represents translate action.
XYDataSeries | Represents data series with X- and Y-values.
ZoomAction | Represents zoom action.

Structures

Structure | Description
PieInfo | Represents parameters of pie slice.

Interfaces

Interface | Description
ICoordConverter | Represents coordinate converter
IDataSeriesInfo | Generic data series.
IPlotElement | Represents generic plot element.
IRenderer | Generic renderer interface.

Enumerations

Enumeration | Description
AnnoPosition | Specifies position of axis labels
AxisPosition | Specifies position of axis.
AxisType | Specifies axis type.
BubbleScale | Specifies how to calculate the size of symbols for Bubble chart.
ChartTheme | Specifies available chart themes
ChartType | Specifies the chart type.
ColorScheme | Specifies how color scheme is generated.
GradientMethod | Specifies how to handle gradient brushes in themes and custom palettes.
HLOCAppearance | Defines the appearance of HLOC (high-low-open-close) plot element.
LabelAlignment | Specifies the position of data label relatively to the corresponding plot element.
LegendPosition | Specifies legend position.
Marker | Specifies data point marker.
MeasureOption | Specifies how the distance between points is calculated.
Palette | This enumeration specifies color themes used to generate colors for data series. Named color themes other than Custom are similar to those in Microsoft Office.
SeriesDisplay | Specifies various display options for data series.
StackedOptions | Specifies options of stacked chart.
TransformMode | Specifies transformation mode for plot elements.
ValueCoordinate | Specifies which coordinate corresponds to the data values.


Action Class

[image]

.NET Framework Class Library
Action Class
Members See Also
Represents action object such as

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public abstract class Action : DependencyObject
Visual Basic (Declaration)
Public MustInherit Class Action _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.Action
C1.Silverlight.Chart..::.ScaleAction
C1.Silverlight.Chart..::.TranslateAction
C1.Silverlight.Chart..::.ZoomAction

See Also

Action Members
C1.Silverlight.Chart Namespace


Action Members

[image] [image]

.NET Framework Class Library
Action Members
Action Class Methods Properties See Also

The Action type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action.

See Also

Action Class
C1.Silverlight.Chart Namespace


Action Methods

[image] [image]

.NET Framework Class Library
Action Methods
Action Class See Also

The Action type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Action Class
C1.Silverlight.Chart Namespace


Action Properties

[image] [image]

.NET Framework Class Library
Action Properties
Action Class See Also

The Action type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action.

See Also

Action Class
C1.Silverlight.Chart Namespace


Modifiers Property

[image]

.NET Framework Class Library
Action..::.Modifiers Property
Action Class See Also
Gets or sets the state of modifier keys that starts the action.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ModifierKeys Modifiers { get; set; }
Visual Basic (Declaration)
Public Property Modifiers As ModifierKeys

See Also

Action Class
C1.Silverlight.Chart Namespace


ActionCollection Class

[image]

.NET Framework Class Library
ActionCollection Class
Members See Also
Represents a collection of Action objects that describe the interactive behavior of a C1Chart at runtime.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class ActionCollection : ObservableCollection<Action>
Visual Basic (Declaration)
Public Class ActionCollection _
    Inherits ObservableCollection(Of Action)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Action >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( Action >)>)
C1.Silverlight.Chart..::.ActionCollection

See Also

ActionCollection Members
C1.Silverlight.Chart Namespace


ActionCollection Members

[image] [image]

.NET Framework Class Library
ActionCollection Members
ActionCollection Class Methods Properties Events See Also

The ActionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Action >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Action >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Action >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Action >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)

See Also

ActionCollection Class
C1.Silverlight.Chart Namespace


ActionCollection Methods

[image] [image]

.NET Framework Class Library
ActionCollection Methods
ActionCollection Class See Also

The ActionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Action >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Action >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Action >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( Action >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ActionCollection Class
C1.Silverlight.Chart Namespace


ActionCollection Properties

[image] [image]

.NET Framework Class Library
ActionCollection Properties
ActionCollection Class See Also

The ActionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Action >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Action >)>).)

See Also

ActionCollection Class
C1.Silverlight.Chart Namespace


ActionCollection Events

[image] [image]

.NET Framework Class Library
ActionCollection Events
ActionCollection Class See Also

The ActionCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Action >)>).)

See Also

ActionCollection Class
C1.Silverlight.Chart Namespace


AnnoPosition Enumeration

[image]

.NET Framework Class Library
AnnoPosition Enumeration
See Also
Specifies position of axis labels

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum AnnoPosition
Visual Basic (Declaration)
Public Enumeration AnnoPosition

Members

Member name | Description
Auto | Automatic selection.
Near | Near position.
Far | Far position.

See Also

C1.Silverlight.Chart Namespace


Area Class

[image]

.NET Framework Class Library
Area Class
Members See Also
Represents the area plot elements that fills the area between data point and base line.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Area : Lines
Visual Basic (Declaration)
Public Class Area _
    Inherits Lines

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Lines
C1.Silverlight.Chart..::.Area

See Also

Area Members
C1.Silverlight.Chart Namespace


Area Members

[image] [image]

.NET Framework Class Library
Area Members
Area Class Constructors Methods Fields Properties Events See Also

The Area type exposes the following members.

Constructors

Name | Description
Area | Initializes a new instance of the Area class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Overrides Lines..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitPointsWithHoles | Returns list of point arrays splitted by NaN values. (Inherited from Lines.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Stores the geometry of the plot element. (Inherited from Lines.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape that represents the appearance of plot element in the legend. (Overrides Lines..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Smoothed | Gets or sets whether the points are connected with smoothed lines. (Inherited from Lines.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Area Class
C1.Silverlight.Chart Namespace


Area Constructor

[image]

.NET Framework Class Library
Area Constructor
Area Class See Also
Initializes a new instance of the Area class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Area()
Visual Basic (Declaration)
Public Sub New

See Also

Area Class
C1.Silverlight.Chart Namespace


Area Fields

[image] [image]

.NET Framework Class Library
Area Fields
Area Class See Also

The Area type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Stores the geometry of the plot element. (Inherited from Lines.)

See Also

Area Class
C1.Silverlight.Chart Namespace


Area Methods

[image] [image]

.NET Framework Class Library
Area Methods
Area Class See Also

The Area type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Overrides Lines..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitPointsWithHoles | Returns list of point arrays splitted by NaN values. (Inherited from Lines.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Area Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Area..::.HitTest Method
Area Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Area Class
Area Members
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
Area..::.Render Method
Area Class See Also
Renders the element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext
Render context.

Return Value

Whether the rendering was successful.

See Also

Area Class
C1.Silverlight.Chart Namespace


Area Properties

[image] [image]

.NET Framework Class Library
Area Properties
Area Class See Also

The Area type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape that represents the appearance of plot element in the legend. (Overrides Lines..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Smoothed | Gets or sets whether the points are connected with smoothed lines. (Inherited from Lines.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Area Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
Area..::.LegendShape Property
Area Class See Also
Gets the shape that represents the appearance of plot element in the legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

Area Class
C1.Silverlight.Chart Namespace


Area Events

[image] [image]

.NET Framework Class Library
Area Events
Area Class See Also

The Area type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Area Class
C1.Silverlight.Chart Namespace


Axis Class

[image]

.NET Framework Class Library
Axis Class
Members See Also
Represents axis on the plot.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Axis
Visual Basic (Declaration)
Public Class Axis

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.Axis

See Also

Axis Members
C1.Silverlight.Chart Namespace


Axis Members

[image] [image]

.NET Framework Class Library
Axis Members
Axis Class Constructors Methods Properties See Also

The Axis type exposes the following members.

Constructors

Name | Description
Axis | Initializes an instance of the Axis class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnnoAngle | Gets or sets the rotation angle of axis annotation.
AnnoFormat | Gets or sets the format of the axis annotation.
AnnoPosition | Gets or sets annotation position.
AnnoTemplate | Gets or sets the template for axis annotation.
AutoMax | Gets or sets whether axis maximum is set automatically.
AutoMin | Gets or sets whether the axis minimum is set automatically.
AxisLine | Gets or sets the axis line.
AxisType | Gets or sets axis type for auxiliary axis.
Foreground | Gets or sets the foreground brush of the axis.
IsTime | Gets or sets whether the axis represents time values.
ItemsSource | Gets or sets the source for axis annotations.
MajorGridFill | Gets or sets the fill based of the major grid. The MajorGridFill allows to create striped plot appearance.
MajorGridStroke | Gets or sets the brush of major grid lines.
MajorGridStrokeDashes | Gets or sets the dash pattern of major grid lines.
MajorGridStrokeThickness | Gets or sets the thickness of major grid lines.
MajorTickHeight | Gets or sets the major tick height.
MajorTickStroke | Gets or sets the major tick stroke.
MajorTickThickness | Gets or sets the major tick thickness.
MajorUnit | Gets or sets the major unit (distance between labels).
Max | Gets or sets the axis maximum.
Min | Gets or sets the axis minimum.
MinorGridStroke | Gets or sets the brush of minor grid lines.
MinorGridStrokeDashes | Gets or sets the dash pattern of minor grid lines.
MinorGridStrokeThickness | Gets or sets the thickness of minor grid lines.
MinorTickHeight | Gets or sets the minor tick height.
MinorTickStroke | Gets or sets the minor tick stroke.
MinorTickThickness | Gets or sets the minor tick thickness.
MinorUnit | Gets or sets the minor unit (distance between minor ticks).
MinScale | Gets or set the minimal scale of axis.
Name | Gets or sets the axis name.
Position | Gets or sets the position of axis.
Reversed | Gets or sets whether the axis is reversed.
Scale | Gets or set the scale of axis.
Title | Gets or sets the axis title.
Value | Gets or sets the current scrolling position of the axis.
Visible | Gets or sets axis visibility.

See Also

Axis Class
C1.Silverlight.Chart Namespace


Axis Constructor

[image]

.NET Framework Class Library
Axis Constructor
Axis Class See Also
Initializes an instance of the Axis class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Axis()
Visual Basic (Declaration)
Public Sub New

See Also

Axis Class
C1.Silverlight.Chart Namespace


Axis Methods

[image] [image]

.NET Framework Class Library
Axis Methods
Axis Class See Also

The Axis type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Axis Class
C1.Silverlight.Chart Namespace


Axis Properties

[image] [image]

.NET Framework Class Library
Axis Properties
Axis Class See Also

The Axis type exposes the following members.

Properties

Name | Description
AnnoAngle | Gets or sets the rotation angle of axis annotation.
AnnoFormat | Gets or sets the format of the axis annotation.
AnnoPosition | Gets or sets annotation position.
AnnoTemplate | Gets or sets the template for axis annotation.
AutoMax | Gets or sets whether axis maximum is set automatically.
AutoMin | Gets or sets whether the axis minimum is set automatically.
AxisLine | Gets or sets the axis line.
AxisType | Gets or sets axis type for auxiliary axis.
Foreground | Gets or sets the foreground brush of the axis.
IsTime | Gets or sets whether the axis represents time values.
ItemsSource | Gets or sets the source for axis annotations.
MajorGridFill | Gets or sets the fill based of the major grid. The MajorGridFill allows to create striped plot appearance.
MajorGridStroke | Gets or sets the brush of major grid lines.
MajorGridStrokeDashes | Gets or sets the dash pattern of major grid lines.
MajorGridStrokeThickness | Gets or sets the thickness of major grid lines.
MajorTickHeight | Gets or sets the major tick height.
MajorTickStroke | Gets or sets the major tick stroke.
MajorTickThickness | Gets or sets the major tick thickness.
MajorUnit | Gets or sets the major unit (distance between labels).
Max | Gets or sets the axis maximum.
Min | Gets or sets the axis minimum.
MinorGridStroke | Gets or sets the brush of minor grid lines.
MinorGridStrokeDashes | Gets or sets the dash pattern of minor grid lines.
MinorGridStrokeThickness | Gets or sets the thickness of minor grid lines.
MinorTickHeight | Gets or sets the minor tick height.
MinorTickStroke | Gets or sets the minor tick stroke.
MinorTickThickness | Gets or sets the minor tick thickness.
MinorUnit | Gets or sets the minor unit (distance between minor ticks).
MinScale | Gets or set the minimal scale of axis.
Name | Gets or sets the axis name.
Position | Gets or sets the position of axis.
Reversed | Gets or sets whether the axis is reversed.
Scale | Gets or set the scale of axis.
Title | Gets or sets the axis title.
Value | Gets or sets the current scrolling position of the axis.
Visible | Gets or sets axis visibility.

See Also

Axis Class
C1.Silverlight.Chart Namespace


AnnoAngle Property

[image]

.NET Framework Class Library
Axis..::.AnnoAngle Property
Axis Class See Also
Gets or sets the rotation angle of axis annotation.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double AnnoAngle { get; set; }
Visual Basic (Declaration)
Public Property AnnoAngle As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


AnnoFormat Property

[image]

.NET Framework Class Library
Axis..::.AnnoFormat Property
Axis Class See Also
Gets or sets the format of the axis annotation.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string AnnoFormat { get; set; }
Visual Basic (Declaration)
Public Property AnnoFormat As String

Remarks

The format conforms to the standard .Net formatting.

See Also

Axis Class
C1.Silverlight.Chart Namespace


AnnoPosition Property

[image]

.NET Framework Class Library
Axis..::.AnnoPosition Property
Axis Class See Also
Gets or sets annotation position.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public AnnoPosition AnnoPosition { get; set; }
Visual Basic (Declaration)
Public Property AnnoPosition As AnnoPosition

Remarks

The position is relative to the value on the axis which corresponds to the axis annotation.

See Also

Axis Class
C1.Silverlight.Chart Namespace


AnnoTemplate Property

[image]

.NET Framework Class Library
Axis..::.AnnoTemplate Property
Axis Class See Also
Gets or sets the template for axis annotation.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object AnnoTemplate { get; set; }
Visual Basic (Declaration)
Public Property AnnoTemplate As Object

Remarks

The template is used for generation of axis labels.

See Also

Axis Class
C1.Silverlight.Chart Namespace


AutoMax Property

[image]

.NET Framework Class Library
Axis..::.AutoMax Property
Axis Class See Also
Gets or sets whether axis maximum is set automatically.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool AutoMax { get; set; }
Visual Basic (Declaration)
Public Property AutoMax As Boolean

See Also

Axis Class
C1.Silverlight.Chart Namespace


AutoMin Property

[image]

.NET Framework Class Library
Axis..::.AutoMin Property
Axis Class See Also
Gets or sets whether the axis minimum is set automatically.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool AutoMin { get; set; }
Visual Basic (Declaration)
Public Property AutoMin As Boolean

See Also

Axis Class
C1.Silverlight.Chart Namespace


AxisLine Property

[image]

.NET Framework Class Library
Axis..::.AxisLine Property
Axis Class See Also
Gets or sets the axis line.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Line AxisLine { get; set; }
Visual Basic (Declaration)
Public Property AxisLine As Line

Remarks

The axis line connects the points on plot which correspond to the Min and Max of the axis.

See Also

Axis Class
C1.Silverlight.Chart Namespace


AxisType Property

[image]

.NET Framework Class Library
Axis..::.AxisType Property
Axis Class See Also
Gets or sets axis type for auxiliary axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public AxisType AxisType { get; set; }
Visual Basic (Declaration)
Public Property AxisType As AxisType

See Also

Axis Class
C1.Silverlight.Chart Namespace


Foreground Property

[image]

.NET Framework Class Library
Axis..::.Foreground Property
Axis Class See Also
Gets or sets the foreground brush of the axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic (Declaration)
Public Property Foreground As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


IsTime Property

[image]

.NET Framework Class Library
Axis..::.IsTime Property
Axis Class See Also
Gets or sets whether the axis represents time values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool IsTime { get; set; }
Visual Basic (Declaration)
Public Property IsTime As Boolean

See Also

Axis Class
C1.Silverlight.Chart Namespace


ItemsSource Property

[image]

.NET Framework Class Library
Axis..::.ItemsSource Property
Axis Class See Also
Gets or sets the source for axis annotations.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IEnumerable

Remarks

The ItemsSource provides the data that is used for display in axis labels instead of automatic annotation with numeric or DataTime values.

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorGridFill Property

[image]

.NET Framework Class Library
Axis..::.MajorGridFill Property
Axis Class See Also
Gets or sets the fill based of the major grid. The MajorGridFill allows to create striped plot appearance.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush MajorGridFill { get; set; }
Visual Basic (Declaration)
Public Property MajorGridFill As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorGridStroke Property

[image]

.NET Framework Class Library
Axis..::.MajorGridStroke Property
Axis Class See Also
Gets or sets the brush of major grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush MajorGridStroke { get; set; }
Visual Basic (Declaration)
Public Property MajorGridStroke As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorGridStrokeDashes Property

[image]

.NET Framework Class Library
Axis..::.MajorGridStrokeDashes Property
Axis Class See Also
Gets or sets the dash pattern of major grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection MajorGridStrokeDashes { get; set; }
Visual Basic (Declaration)
Public Property MajorGridStrokeDashes As DoubleCollection

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorGridStrokeThickness Property

[image]

.NET Framework Class Library
Axis..::.MajorGridStrokeThickness Property
Axis Class See Also
Gets or sets the thickness of major grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MajorGridStrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property MajorGridStrokeThickness As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorTickHeight Property

[image]

.NET Framework Class Library
Axis..::.MajorTickHeight Property
Axis Class See Also
Gets or sets the major tick height.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MajorTickHeight { get; set; }
Visual Basic (Declaration)
Public Property MajorTickHeight As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorTickStroke Property

[image]

.NET Framework Class Library
Axis..::.MajorTickStroke Property
Axis Class See Also
Gets or sets the major tick stroke.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush MajorTickStroke { get; set; }
Visual Basic (Declaration)
Public Property MajorTickStroke As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorTickThickness Property

[image]

.NET Framework Class Library
Axis..::.MajorTickThickness Property
Axis Class See Also
Gets or sets the major tick thickness.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MajorTickThickness { get; set; }
Visual Basic (Declaration)
Public Property MajorTickThickness As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MajorUnit Property

[image]

.NET Framework Class Library
Axis..::.MajorUnit Property
Axis Class See Also
Gets or sets the major unit (distance between labels).

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object MajorUnit { get; set; }
Visual Basic (Declaration)
Public Property MajorUnit As Object

See Also

Axis Class
C1.Silverlight.Chart Namespace


Max Property

[image]

.NET Framework Class Library
Axis..::.Max Property
Axis Class See Also
Gets or sets the axis maximum.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Max { get; set; }
Visual Basic (Declaration)
Public Property Max As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


Min Property

[image]

.NET Framework Class Library
Axis..::.Min Property
Axis Class See Also
Gets or sets the axis minimum.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Min { get; set; }
Visual Basic (Declaration)
Public Property Min As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorGridStroke Property

[image]

.NET Framework Class Library
Axis..::.MinorGridStroke Property
Axis Class See Also
Gets or sets the brush of minor grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush MinorGridStroke { get; set; }
Visual Basic (Declaration)
Public Property MinorGridStroke As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorGridStrokeDashes Property

[image]

.NET Framework Class Library
Axis..::.MinorGridStrokeDashes Property
Axis Class See Also
Gets or sets the dash pattern of minor grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection MinorGridStrokeDashes { get; set; }
Visual Basic (Declaration)
Public Property MinorGridStrokeDashes As DoubleCollection

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorGridStrokeThickness Property

[image]

.NET Framework Class Library
Axis..::.MinorGridStrokeThickness Property
Axis Class See Also
Gets or sets the thickness of minor grid lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MinorGridStrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property MinorGridStrokeThickness As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorTickHeight Property

[image]

.NET Framework Class Library
Axis..::.MinorTickHeight Property
Axis Class See Also
Gets or sets the minor tick height.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MinorTickHeight { get; set; }
Visual Basic (Declaration)
Public Property MinorTickHeight As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorTickStroke Property

[image]

.NET Framework Class Library
Axis..::.MinorTickStroke Property
Axis Class See Also
Gets or sets the minor tick stroke.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush MinorTickStroke { get; set; }
Visual Basic (Declaration)
Public Property MinorTickStroke As Brush

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorTickThickness Property

[image]

.NET Framework Class Library
Axis..::.MinorTickThickness Property
Axis Class See Also
Gets or sets the minor tick thickness.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double MinorTickThickness { get; set; }
Visual Basic (Declaration)
Public Property MinorTickThickness As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinorUnit Property

[image]

.NET Framework Class Library
Axis..::.MinorUnit Property
Axis Class See Also
Gets or sets the minor unit (distance between minor ticks).

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object MinorUnit { get; set; }
Visual Basic (Declaration)
Public Property MinorUnit As Object

See Also

Axis Class
C1.Silverlight.Chart Namespace


MinScale Property

[image]

.NET Framework Class Library
Axis..::.MinScale Property
Axis Class See Also
Gets or set the minimal scale of axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute()]
public double MinScale { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property MinScale As Double

See Also

Axis Class
C1.Silverlight.Chart Namespace


Name Property

[image]

.NET Framework Class Library
Axis..::.Name Property
Axis Class See Also
Gets or sets the axis name.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

Axis Class
C1.Silverlight.Chart Namespace


Position Property

[image]

.NET Framework Class Library
Axis..::.Position Property
Axis Class See Also
Gets or sets the position of axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public AxisPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As AxisPosition

Remarks

For vertical axis AxisPosition.Near corresponds to the left and AxisPosition.Far corresponds to the right. For horizontal axis AxisPosition.Near corresponds to bottom and AxisPosition.Far corresponds to the top.

See Also

Axis Class
C1.Silverlight.Chart Namespace


Reversed Property

[image]

.NET Framework Class Library
Axis..::.Reversed Property
Axis Class See Also
Gets or sets whether the axis is reversed.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool Reversed { get; set; }
Visual Basic (Declaration)
Public Property Reversed As Boolean

See Also

Axis Class
C1.Silverlight.Chart Namespace


Scale Property

[image]

.NET Framework Class Library
Axis..::.Scale Property
Axis Class See Also
Gets or set the scale of axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Scale { get; set; }
Visual Basic (Declaration)
Public Property Scale As Double

Remarks

The scale should be more than 0 and less or equal to 1. The scale specifies which part of the range between Min and Max is shown. When scale is 1 (default value) the whole axis range is visible.

See Also

Axis Class
C1.Silverlight.Chart Namespace


Title Property

[image]

.NET Framework Class Library
Axis..::.Title Property
Axis Class See Also
Gets or sets the axis title.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public UIElement Title { get; set; }
Visual Basic (Declaration)
Public Property Title As UIElement

See Also

Axis Class
C1.Silverlight.Chart Namespace


Value Property

[image]

.NET Framework Class Library
Axis..::.Value Property
Axis Class See Also
Gets or sets the current scrolling position of the axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double

Remarks

The Value represents scrolling position on the axis when the Scale is less than 1 otherwise the Value has no effect. The Value should be from 0 to 1.

See Also

Axis Class
C1.Silverlight.Chart Namespace


Visible Property

[image]

.NET Framework Class Library
Axis..::.Visible Property
Axis Class See Also
Gets or sets axis visibility.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool Visible { get; set; }
Visual Basic (Declaration)
Public Property Visible As Boolean

See Also

Axis Class
C1.Silverlight.Chart Namespace


AxisCollection Class

[image]

.NET Framework Class Library
AxisCollection Class
Members See Also
Represents collection of axes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class AxisCollection : Collection<Axis>
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class AxisCollection _
    Inherits Collection(Of Axis)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Axis >)>)
C1.Silverlight.Chart..::.AxisCollection

See Also

AxisCollection Members
C1.Silverlight.Chart Namespace


AxisCollection Members

[image] [image]

.NET Framework Class Library
AxisCollection Members
AxisCollection Class Constructors Methods Properties See Also

The AxisCollection type exposes the following members.

Constructors

Name | Description
AxisCollection | Initializes a new instance of AxisCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
ClearItems | Removes items from the collection. (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Axis >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Axis >)>).)
InsertItem | Inserts an element into the collection at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
RemoveItem | Removes the item at the specified index of the collection. (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( Axis >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


AxisCollection Constructor

[image]

.NET Framework Class Library
AxisCollection Constructor
AxisCollection Class See Also
Initializes a new instance of AxisCollection class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public AxisCollection()
Visual Basic (Declaration)
Public Sub New

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


AxisCollection Methods

[image] [image]

.NET Framework Class Library
AxisCollection Methods
AxisCollection Class See Also

The AxisCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
ClearItems | Removes items from the collection. (Overrides Collection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Axis >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Axis >)>).)
InsertItem | Inserts an element into the collection at the specified index. (Overrides Collection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
RemoveItem | Removes the item at the specified index of the collection. (Overrides Collection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the element at the specified index. (Inherited from Collection <(Of <( Axis >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


ClearItems Method

[image]

.NET Framework Class Library
AxisCollection..::.ClearItems Method
AxisCollection Class See Also
Removes items from the collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


InsertItem Method

[image]

.NET Framework Class Library
AxisCollection..::.InsertItem Method
AxisCollection Class See Also
Inserts an element into the collection at the specified index.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    Axis item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As Axis _
)

Parameters

index
Type: System..::.Int32
Index at which the element is inserted.
item
Type: C1.Silverlight.Chart..::.Axis
Element to insert

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


RemoveItem Method

[image]

.NET Framework Class Library
AxisCollection..::.RemoveItem Method
AxisCollection Class See Also
Removes the item at the specified index of the collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Index of the element to remove.

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


AxisCollection Properties

[image] [image]

.NET Framework Class Library
AxisCollection Properties
AxisCollection Class See Also

The AxisCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Axis >)>).)

See Also

AxisCollection Class
C1.Silverlight.Chart Namespace


Item Property

[image] [image]

.NET Framework Class Library
AxisCollection..::.Item Property
AxisCollection Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Axis >)>).)
Item[([(String])]) | Gets the axis by its name.

See Also

AxisCollection Class
AxisCollection Members
C1.Silverlight.Chart Namespace


Item Property (String)

[image]

.NET Framework Class Library
AxisCollection..::.Item Property (String)
AxisCollection Class See Also
Gets the axis by its name.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Axis this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Axis

Parameters

name
Type: System..::.String
The name of the axis.

Return Value

Axis with the specified name. Null if there is no axis with the specified name.

See Also

AxisCollection Class
Item Overload
C1.Silverlight.Chart Namespace


AxisPosition Enumeration

[image]

.NET Framework Class Library
AxisPosition Enumeration
See Also
Specifies position of axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum AxisPosition
Visual Basic (Declaration)
Public Enumeration AxisPosition

Members

Member name | Description
Near | Left for vertical, bottom for horizontal.
Far | Right for vertical, top for horizontal.

See Also

C1.Silverlight.Chart Namespace


AxisType Enumeration

[image]

.NET Framework Class Library
AxisType Enumeration
See Also
Specifies axis type.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum AxisType
Visual Basic (Declaration)
Public Enumeration AxisType

Members

Member name | Description
X | X-axis.
Y | Y-axis.
Z | Z-axis.

See Also

C1.Silverlight.Chart Namespace


Bar Class

[image]

.NET Framework Class Library
Bar Class
Members See Also
Represents bar plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Bar : PlotElement
Visual Basic (Declaration)
Public Class Bar _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Bar

See Also

Bar Members
C1.Silverlight.Chart Namespace


Bar Members

[image] [image]

.NET Framework Class Library
Bar Members
Bar Class Constructors Methods Fields Properties Events See Also

The Bar type exposes the following members.

Constructors

Name | Description
Bar | Initializes an new instance of the Bar class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Specifies whether the plot element can be clustered. (Overrides PlotElement..::.IsClustered.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RadiusX | Gets or sets the x radius.
RadiusY | Gets or sets the y radius.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Bar Class
C1.Silverlight.Chart Namespace


Bar Constructor

[image]

.NET Framework Class Library
Bar Constructor
Bar Class See Also
Initializes an new instance of the Bar class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Bar()
Visual Basic (Declaration)
Public Sub New

See Also

Bar Class
C1.Silverlight.Chart Namespace


Bar Fields

[image] [image]

.NET Framework Class Library
Bar Fields
Bar Class See Also

The Bar type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

See Also

Bar Class
C1.Silverlight.Chart Namespace


Bar Methods

[image] [image]

.NET Framework Class Library
Bar Methods
Bar Class See Also

The Bar type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Bar Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Bar..::.HitTest Method
Bar Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Bar Class
Bar Members
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
Bar..::.Render Method
Bar Class See Also
Renders the plot element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

Bar Class
C1.Silverlight.Chart Namespace


Bar Properties

[image] [image]

.NET Framework Class Library
Bar Properties
Bar Class See Also

The Bar type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Specifies whether the plot element can be clustered. (Overrides PlotElement..::.IsClustered.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RadiusX | Gets or sets the x radius.
RadiusY | Gets or sets the y radius.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Bar Class
C1.Silverlight.Chart Namespace


IsClustered Property

[image]

.NET Framework Class Library
Bar..::.IsClustered Property
Bar Class See Also
Specifies whether the plot element can be clustered.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool IsClustered { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property IsClustered As Boolean

See Also

Bar Class
C1.Silverlight.Chart Namespace


RadiusX Property

[image]

.NET Framework Class Library
Bar..::.RadiusX Property
Bar Class See Also
Gets or sets the x radius.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double RadiusX { get; set; }
Visual Basic (Declaration)
Public Property RadiusX As Double

See Also

Bar Class
C1.Silverlight.Chart Namespace


RadiusY Property

[image]

.NET Framework Class Library
Bar..::.RadiusY Property
Bar Class See Also
Gets or sets the y radius.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double RadiusY { get; set; }
Visual Basic (Declaration)
Public Property RadiusY As Double

See Also

Bar Class
C1.Silverlight.Chart Namespace


Bar Events

[image] [image]

.NET Framework Class Library
Bar Events
Bar Class See Also

The Bar type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Bar Class
C1.Silverlight.Chart Namespace


BarColumnOptions Class

[image]

.NET Framework Class Library
BarColumnOptions Class
Members See Also
Bar/column chart options.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class BarColumnOptions : DependencyObject
Visual Basic (Declaration)
Public Class BarColumnOptions _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.BarColumnOptions

See Also

BarColumnOptions Members
C1.Silverlight.Chart Namespace


BarColumnOptions Members

[image] [image]

.NET Framework Class Library
BarColumnOptions Members
BarColumnOptions Class Constructors Methods Fields Properties See Also

The BarColumnOptions type exposes the following members.

Constructors

Name | Description
BarColumnOptions |

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOrigin | Returns the value of the OriginProperty attached property for a specified chart.
GetSize | Returns the value of the SizeProperty attached property for a specified chart. The BarColumnOptions.Size property specifies the size(column width or bar height) of elements for bar and column charts. The value of the property is relative to the available space e.g. when BarColumnOptions.Size the elements fill all available space on the plot.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetOrigin | Sets the value of the OriginProperty attached property for a specified chart.
SetSize | Sets the value of the SizeProperty attached property for a specified chart.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
OriginProperty | Identifies the Origin dependency property.
SizeProperty |

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


BarColumnOptions Constructor

[image]

.NET Framework Class Library
BarColumnOptions Constructor
BarColumnOptions Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public BarColumnOptions()
Visual Basic (Declaration)
Public Sub New

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


BarColumnOptions Fields

[image] [image]

.NET Framework Class Library
BarColumnOptions Fields
BarColumnOptions Class See Also

The BarColumnOptions type exposes the following members.

Fields

Name | Description
OriginProperty | Identifies the Origin dependency property.
SizeProperty |

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


OriginProperty Field

[image]

.NET Framework Class Library
BarColumnOptions..::.OriginProperty Field
BarColumnOptions Class See Also
Identifies the Origin dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty OriginProperty
Visual Basic (Declaration)
Public Shared OriginProperty As DependencyProperty

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


SizeProperty Field

[image]

.NET Framework Class Library
BarColumnOptions..::.SizeProperty Field
BarColumnOptions Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty SizeProperty
Visual Basic (Declaration)
Public Shared SizeProperty As DependencyProperty

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


BarColumnOptions Methods

[image] [image]

.NET Framework Class Library
BarColumnOptions Methods
BarColumnOptions Class See Also

The BarColumnOptions type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetOrigin | Returns the value of the OriginProperty attached property for a specified chart.
GetSize | Returns the value of the SizeProperty attached property for a specified chart. The BarColumnOptions.Size property specifies the size(column width or bar height) of elements for bar and column charts. The value of the property is relative to the available space e.g. when BarColumnOptions.Size the elements fill all available space on the plot.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetOrigin | Sets the value of the OriginProperty attached property for a specified chart.
SetSize | Sets the value of the SizeProperty attached property for a specified chart.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


GetOrigin Method

[image]

.NET Framework Class Library
BarColumnOptions..::.GetOrigin Method
BarColumnOptions Class See Also
Returns the value of the OriginProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static double GetOrigin(
    C1Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetOrigin ( _
    chart As C1Chart _
) As Double

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart

Return Value

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


GetSize Method

[image]

.NET Framework Class Library
BarColumnOptions..::.GetSize Method
BarColumnOptions Class See Also
Returns the value of the SizeProperty attached property for a specified chart. The BarColumnOptions.Size property specifies the size(column width or bar height) of elements for bar and column charts. The value of the property is relative to the available space e.g. when BarColumnOptions.Size the elements fill all available space on the plot.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static double GetSize(
    C1Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetSize ( _
    chart As C1Chart _
) As Double

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart

Return Value

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


SetOrigin Method

[image]

.NET Framework Class Library
BarColumnOptions..::.SetOrigin Method
BarColumnOptions Class See Also
Sets the value of the OriginProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetOrigin(
    C1Chart chart,
    double value
)
Visual Basic (Declaration)
Public Shared Sub SetOrigin ( _
    chart As C1Chart, _
    value As Double _
)

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart
value
Type: System..::.Double

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


SetSize Method

[image]

.NET Framework Class Library
BarColumnOptions..::.SetSize Method
BarColumnOptions Class See Also
Sets the value of the SizeProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetSize(
    C1Chart chart,
    double value
)
Visual Basic (Declaration)
Public Shared Sub SetSize ( _
    chart As C1Chart, _
    value As Double _
)

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart
value
Type: System..::.Double

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


BarColumnOptions Properties

[image] [image]

.NET Framework Class Library
BarColumnOptions Properties
BarColumnOptions Class See Also

The BarColumnOptions type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

BarColumnOptions Class
C1.Silverlight.Chart Namespace


BasePieRenderer Class

[image]

.NET Framework Class Library
BasePieRenderer Class
Members See Also
Base class for pie renderers.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class BasePieRenderer : BaseRenderer
Visual Basic (Declaration)
Public Class BasePieRenderer _
    Inherits BaseRenderer

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.BaseRenderer
C1.Silverlight.Chart..::.BasePieRenderer
C1.Silverlight.Chart..::.PieRenderer

See Also

BasePieRenderer Members
C1.Silverlight.Chart Namespace


BasePieRenderer Members

[image] [image]

.NET Framework Class Library
BasePieRenderer Members
BasePieRenderer Class Methods Properties See Also

The BasePieRenderer type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Adds the options set to the bag. (Overrides BaseRenderer..::.InitOptions()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
InnerRadius | Gets or sets the inner radius of pie.
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
Offset | Gets or sets the offset of slices.
Radius | Gets or sets the radius of pie.
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


BasePieRenderer Methods

[image] [image]

.NET Framework Class Library
BasePieRenderer Methods
BasePieRenderer Class See Also

The BasePieRenderer type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Adds the options set to the bag. (Overrides BaseRenderer..::.InitOptions()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


CreateSymbolShape Method

[image] [image]

.NET Framework Class Library
BasePieRenderer..::.CreateSymbolShape Method
BasePieRenderer Class See Also

Overload List

Name | Description
CreateSymbolShape(DataSeries) | Create symbol shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape(ShapeStyle) | Create symbol shape based on the specified shape style. (Inherited from BaseRenderer.)

See Also

BasePieRenderer Class
BasePieRenderer Members
C1.Silverlight.Chart Namespace


InitOptions Method

[image]

.NET Framework Class Library
BasePieRenderer..::.InitOptions Method
BasePieRenderer Class See Also
Adds the options set to the bag.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void InitOptions()
Visual Basic (Declaration)
Protected Overrides Sub InitOptions

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


BasePieRenderer Properties

[image] [image]

.NET Framework Class Library
BasePieRenderer Properties
BasePieRenderer Class See Also

The BasePieRenderer type exposes the following members.

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
InnerRadius | Gets or sets the inner radius of pie.
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
Offset | Gets or sets the offset of slices.
Radius | Gets or sets the radius of pie.
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


InnerRadius Property

[image]

.NET Framework Class Library
BasePieRenderer..::.InnerRadius Property
BasePieRenderer Class See Also
Gets or sets the inner radius of pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double InnerRadius { get; set; }
Visual Basic (Declaration)
Public Property InnerRadius As Double

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


Offset Property

[image]

.NET Framework Class Library
BasePieRenderer..::.Offset Property
BasePieRenderer Class See Also
Gets or sets the offset of slices.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Double

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


Radius Property

[image]

.NET Framework Class Library
BasePieRenderer..::.Radius Property
BasePieRenderer Class See Also
Gets or sets the radius of pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double

See Also

BasePieRenderer Class
C1.Silverlight.Chart Namespace


BaseRenderer Class

[image]

.NET Framework Class Library
BaseRenderer Class
Members See Also
Presents base renderer class. The renderer class performs data visualization.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public abstract class BaseRenderer : IRenderer
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)> _
Public MustInherit Class BaseRenderer _
    Implements IRenderer

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.BaseRenderer
C1.Silverlight.Chart..::.BasePieRenderer
C1.Silverlight.Chart..::.RadarRenderer
C1.Silverlight.Chart..::.Renderer2D

See Also

BaseRenderer Members
C1.Silverlight.Chart Namespace


BaseRenderer Members

[image] [image]

.NET Framework Class Library
BaseRenderer Members
BaseRenderer Class Constructors Methods Properties See Also

The BaseRenderer type exposes the following members.

Constructors

Name | Description
BaseRenderer |

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits.
CreateElement | Create plot element based on specified template and style.
CreateLineShape | Create line shape based on the specified data series.
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element.
RenderElement | Renders the element and add it to the specified list.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements.
Connection | Gets or sets the data template that is used for visualization of all data points of the series.
CoordConverter | Gets or sets coordinate mapping engine.
Inverted | Gets or sets whether the direction of plotting is inverted.
SizeX | Gets or sets the size of data element along x-axis.
SizeY | Gets or sets the size of data element along y-axis.
Stacked | Gets or sets the stacked options of the plot.
Symbol | Gets or sets the data template that is used for data point visualization.

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


BaseRenderer Constructor

[image]

.NET Framework Class Library
BaseRenderer Constructor
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected BaseRenderer()
Visual Basic (Declaration)
Protected Sub New

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


BaseRenderer Methods

[image] [image]

.NET Framework Class Library
BaseRenderer Methods
BaseRenderer Class See Also

The BaseRenderer type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits.
CreateElement | Create plot element based on specified template and style.
CreateLineShape | Create line shape based on the specified data series.
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element.
RenderElement | Renders the element and add it to the specified list.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


AnalyzeData Method

[image]

.NET Framework Class Library
BaseRenderer..::.AnalyzeData Method
BaseRenderer Class See Also
Analyses data values, finds data limits.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void AnalyzeData(
    bool isStacked
)
Visual Basic (Declaration)
Protected Sub AnalyzeData ( _
    isStacked As Boolean _
)

Parameters

isStacked
Type: System..::.Boolean

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


CreateElement Method

[image]

.NET Framework Class Library
BaseRenderer..::.CreateElement Method
BaseRenderer Class See Also
Create plot element based on specified template and style.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected IPlotElement CreateElement(
    Object element,
    Style style
)
Visual Basic (Declaration)
Protected Function CreateElement ( _
    element As Object, _
    style As Style _
) As IPlotElement

Parameters

element
Type: System..::.Object
style
Type: System.Windows..::.Style

Return Value

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


CreateLineShape Method

[image]

.NET Framework Class Library
BaseRenderer..::.CreateLineShape Method
BaseRenderer Class See Also
Create line shape based on the specified data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual Shape CreateLineShape(
    DataSeries ds
)
Visual Basic (Declaration)
Protected Overridable Function CreateLineShape ( _
    ds As DataSeries _
) As Shape

Parameters

ds
Type: C1.Silverlight.Chart..::.DataSeries

Return Value

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


CreateSymbolShape Method

[image] [image]

.NET Framework Class Library
BaseRenderer..::.CreateSymbolShape Method
BaseRenderer Class See Also

Overload List

Name | Description
CreateSymbolShape(DataSeries) | Create symbol shape based on the specified data series.
CreateSymbolShape(ShapeStyle) | Create symbol shape based on the specified shape style.

See Also

BaseRenderer Class
BaseRenderer Members
C1.Silverlight.Chart Namespace


CreateSymbolShape Method (DataSeries)

[image]

.NET Framework Class Library
BaseRenderer..::.CreateSymbolShape Method (DataSeries)
BaseRenderer Class See Also
Create symbol shape based on the specified data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual Shape CreateSymbolShape(
    DataSeries ds
)
Visual Basic (Declaration)
Protected Overridable Function CreateSymbolShape ( _
    ds As DataSeries _
) As Shape

Parameters

ds
Type: C1.Silverlight.Chart..::.DataSeries

Return Value

See Also

BaseRenderer Class
CreateSymbolShape Overload
C1.Silverlight.Chart Namespace


CreateSymbolShape Method (ShapeStyle)

[image]

.NET Framework Class Library
BaseRenderer..::.CreateSymbolShape Method (ShapeStyle)
BaseRenderer Class See Also
Create symbol shape based on the specified shape style.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual Shape CreateSymbolShape(
    ShapeStyle shapeStyle
)
Visual Basic (Declaration)
Protected Overridable Function CreateSymbolShape ( _
    shapeStyle As ShapeStyle _
) As Shape

Parameters

shapeStyle
Type: C1.Silverlight.Chart..::.ShapeStyle

Return Value

See Also

BaseRenderer Class
CreateSymbolShape Overload
C1.Silverlight.Chart Namespace


InitOptions Method

[image]

.NET Framework Class Library
BaseRenderer..::.InitOptions Method
BaseRenderer Class See Also
Add options to the bag.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual void InitOptions()
Visual Basic (Declaration)
Protected Overridable Sub InitOptions

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


RenderConnection Method

[image]

.NET Framework Class Library
BaseRenderer..::.RenderConnection Method
BaseRenderer Class See Also
Renders connection and returns the created element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected PlotElement RenderConnection(
    DataSeries ds,
    RenderContext rc,
    int i
)
Visual Basic (Declaration)
Protected Function RenderConnection ( _
    ds As DataSeries, _
    rc As RenderContext, _
    i As Integer _
) As PlotElement

Parameters

ds
Type: C1.Silverlight.Chart..::.DataSeries
rc
Type: C1.Silverlight.Chart..::.RenderContext
i
Type: System..::.Int32

Return Value

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


RenderElement Method

[image]

.NET Framework Class Library
BaseRenderer..::.RenderElement Method
BaseRenderer Class See Also
Renders the element and add it to the specified list.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void RenderElement(
    List<UIElement> objects,
    IPlotElement pe,
    DataSeries ds,
    RenderContext rc,
    ShapeStyle shapeStyle,
    DataPoint dp
)
Visual Basic (Declaration)
Protected Sub RenderElement ( _
    objects As List(Of UIElement), _
    pe As IPlotElement, _
    ds As DataSeries, _
    rc As RenderContext, _
    shapeStyle As ShapeStyle, _
    dp As DataPoint _
)

Parameters

objects
Type: System.Collections.Generic..::.List <(Of <( UIElement >)>)
pe
Type: C1.Silverlight.Chart..::.IPlotElement
ds
Type: C1.Silverlight.Chart..::.DataSeries
rc
Type: C1.Silverlight.Chart..::.RenderContext
shapeStyle
Type: C1.Silverlight.Chart..::.ShapeStyle
dp
Type: C1.Silverlight.Chart..::.DataPoint

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


BaseRenderer Properties

[image] [image]

.NET Framework Class Library
BaseRenderer Properties
BaseRenderer Class See Also

The BaseRenderer type exposes the following members.

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements.
Connection | Gets or sets the data template that is used for visualization of all data points of the series.
CoordConverter | Gets or sets coordinate mapping engine.
Inverted | Gets or sets whether the direction of plotting is inverted.
SizeX | Gets or sets the size of data element along x-axis.
SizeY | Gets or sets the size of data element along y-axis.
Stacked | Gets or sets the stacked options of the plot.
Symbol | Gets or sets the data template that is used for data point visualization.

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


ColorScheme Property

[image]

.NET Framework Class Library
BaseRenderer..::.ColorScheme Property
BaseRenderer Class See Also
Gets or sets how the colors are assigned to the plot elements.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ColorScheme ColorScheme { get; set; }
Visual Basic (Declaration)
Public Property ColorScheme As ColorScheme

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


Connection Property

[image]

.NET Framework Class Library
BaseRenderer..::.Connection Property
BaseRenderer Class See Also
Gets or sets the data template that is used for visualization of all data points of the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Connection { get; set; }
Visual Basic (Declaration)
Public Property Connection As Object

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


CoordConverter Property

[image]

.NET Framework Class Library
BaseRenderer..::.CoordConverter Property
BaseRenderer Class See Also
Gets or sets coordinate mapping engine.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public virtual ICoordConverter CoordConverter { get; set; }
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overridable Property CoordConverter As ICoordConverter

Implements

IRenderer..::.CoordConverter

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


Inverted Property

[image]

.NET Framework Class Library
BaseRenderer..::.Inverted Property
BaseRenderer Class See Also
Gets or sets whether the direction of plotting is inverted.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool Inverted { get; set; }
Visual Basic (Declaration)
Public Property Inverted As Boolean

Remarks

By default (Inverted=false) the direction of plotting is horizontal. When the Inverted property is set to true the direction becomes vertical.

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


SizeX Property

[image]

.NET Framework Class Library
BaseRenderer..::.SizeX Property
BaseRenderer Class See Also
Gets or sets the size of data element along x-axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double SizeX { get; set; }
Visual Basic (Declaration)
Public Property SizeX As Double

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


SizeY Property

[image]

.NET Framework Class Library
BaseRenderer..::.SizeY Property
BaseRenderer Class See Also
Gets or sets the size of data element along y-axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double SizeY { get; set; }
Visual Basic (Declaration)
Public Property SizeY As Double

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


Stacked Property

[image]

.NET Framework Class Library
BaseRenderer..::.Stacked Property
BaseRenderer Class See Also
Gets or sets the stacked options of the plot.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public StackedOptions Stacked { get; set; }
Visual Basic (Declaration)
Public Property Stacked As StackedOptions

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


Symbol Property

[image]

.NET Framework Class Library
BaseRenderer..::.Symbol Property
BaseRenderer Class See Also
Gets or sets the data template that is used for data point visualization.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As Object

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


BoxSymbol Class

[image]

.NET Framework Class Library
BoxSymbol Class
Members See Also
Represents box symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class BoxSymbol : PlotElement
Visual Basic (Declaration)
Public Class BoxSymbol _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.BoxSymbol

See Also

BoxSymbol Members
C1.Silverlight.Chart Namespace


BoxSymbol Members

[image] [image]

.NET Framework Class Library
BoxSymbol Members
BoxSymbol Class Constructors Methods Fields Properties Events See Also

The BoxSymbol type exposes the following members.

Constructors

Name | Description
BoxSymbol | Initializes a new instance of the BoxSymbol class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Inherited from PlotElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


BoxSymbol Constructor

[image]

.NET Framework Class Library
BoxSymbol Constructor
BoxSymbol Class See Also
Initializes a new instance of the BoxSymbol class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public BoxSymbol()
Visual Basic (Declaration)
Public Sub New

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


BoxSymbol Fields

[image] [image]

.NET Framework Class Library
BoxSymbol Fields
BoxSymbol Class See Also

The BoxSymbol type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


BoxSymbol Methods

[image] [image]

.NET Framework Class Library
BoxSymbol Methods
BoxSymbol Class See Also

The BoxSymbol type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Inherited from PlotElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
BoxSymbol..::.HitTest Method
BoxSymbol Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

BoxSymbol Class
BoxSymbol Members
C1.Silverlight.Chart Namespace


BoxSymbol Properties

[image] [image]

.NET Framework Class Library
BoxSymbol Properties
BoxSymbol Class See Also

The BoxSymbol type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
BoxSymbol..::.LegendShape Property
BoxSymbol Class See Also
Gets the legend shape for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


BoxSymbol Events

[image] [image]

.NET Framework Class Library
BoxSymbol Events
BoxSymbol Class See Also

The BoxSymbol type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

BoxSymbol Class
C1.Silverlight.Chart Namespace


BubbleOptions Class

[image]

.NET Framework Class Library
BubbleOptions Class
Members See Also
Bubble chart options.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class BubbleOptions : DependencyObject
Visual Basic (Declaration)
Public Class BubbleOptions _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.BubbleOptions

See Also

BubbleOptions Members
C1.Silverlight.Chart Namespace


BubbleOptions Members

[image] [image]

.NET Framework Class Library
BubbleOptions Members
BubbleOptions Class Constructors Methods Fields Properties See Also

The BubbleOptions type exposes the following members.

Constructors

Name | Description
BubbleOptions |

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSize | Returns the value of the MaxSizeProperty attached property for a specified chart.
GetMinSize | Returns the value of the MinSizeProperty attached property for a specified chart.
GetScale | Returns the value of the ScaleProperty attached property for a specified chart.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetMaxSize | Sets the value of the MinSizeProperty attached property for a specified chart.
SetMinSize | Sets the value of the MinSizeProperty attached property for a specified chart.
SetScale | Sets the value of the ScaleProperty attached property for a specified chart.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
MaxSizeProperty | Identifies the MaxSize dependency property.
MinSizeProperty | Identifies the MinSize dependency property.
ScaleProperty |

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


BubbleOptions Constructor

[image]

.NET Framework Class Library
BubbleOptions Constructor
BubbleOptions Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public BubbleOptions()
Visual Basic (Declaration)
Public Sub New

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


BubbleOptions Fields

[image] [image]

.NET Framework Class Library
BubbleOptions Fields
BubbleOptions Class See Also

The BubbleOptions type exposes the following members.

Fields

Name | Description
MaxSizeProperty | Identifies the MaxSize dependency property.
MinSizeProperty | Identifies the MinSize dependency property.
ScaleProperty |

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


MaxSizeProperty Field

[image]

.NET Framework Class Library
BubbleOptions..::.MaxSizeProperty Field
BubbleOptions Class See Also
Identifies the MaxSize dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty MaxSizeProperty
Visual Basic (Declaration)
Public Shared MaxSizeProperty As DependencyProperty

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


MinSizeProperty Field

[image]

.NET Framework Class Library
BubbleOptions..::.MinSizeProperty Field
BubbleOptions Class See Also
Identifies the MinSize dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty MinSizeProperty
Visual Basic (Declaration)
Public Shared MinSizeProperty As DependencyProperty

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


ScaleProperty Field

[image]

.NET Framework Class Library
BubbleOptions..::.ScaleProperty Field
BubbleOptions Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty ScaleProperty
Visual Basic (Declaration)
Public Shared ScaleProperty As DependencyProperty

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


BubbleOptions Methods

[image] [image]

.NET Framework Class Library
BubbleOptions Methods
BubbleOptions Class See Also

The BubbleOptions type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSize | Returns the value of the MaxSizeProperty attached property for a specified chart.
GetMinSize | Returns the value of the MinSizeProperty attached property for a specified chart.
GetScale | Returns the value of the ScaleProperty attached property for a specified chart.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetMaxSize | Sets the value of the MinSizeProperty attached property for a specified chart.
SetMinSize | Sets the value of the MinSizeProperty attached property for a specified chart.
SetScale | Sets the value of the ScaleProperty attached property for a specified chart.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


GetMaxSize Method

[image]

.NET Framework Class Library
BubbleOptions..::.GetMaxSize Method
BubbleOptions Class See Also
Returns the value of the MaxSizeProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static Size GetMaxSize(
    C1Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetMaxSize ( _
    chart As C1Chart _
) As Size

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart

Return Value

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


GetMinSize Method

[image]

.NET Framework Class Library
BubbleOptions..::.GetMinSize Method
BubbleOptions Class See Also
Returns the value of the MinSizeProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static Size GetMinSize(
    C1Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetMinSize ( _
    chart As C1Chart _
) As Size

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart

Return Value

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


GetScale Method

[image]

.NET Framework Class Library
BubbleOptions..::.GetScale Method
BubbleOptions Class See Also
Returns the value of the ScaleProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static BubbleScale GetScale(
    C1Chart chart
)
Visual Basic (Declaration)
Public Shared Function GetScale ( _
    chart As C1Chart _
) As BubbleScale

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart

Return Value

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


SetMaxSize Method

[image]

.NET Framework Class Library
BubbleOptions..::.SetMaxSize Method
BubbleOptions Class See Also
Sets the value of the MinSizeProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetMaxSize(
    C1Chart chart,
    Size value
)
Visual Basic (Declaration)
Public Shared Sub SetMaxSize ( _
    chart As C1Chart, _
    value As Size _
)

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart
value
Type: System.Windows..::.Size

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


SetMinSize Method

[image]

.NET Framework Class Library
BubbleOptions..::.SetMinSize Method
BubbleOptions Class See Also
Sets the value of the MinSizeProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetMinSize(
    C1Chart chart,
    Size value
)
Visual Basic (Declaration)
Public Shared Sub SetMinSize ( _
    chart As C1Chart, _
    value As Size _
)

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart
value
Type: System.Windows..::.Size

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


SetScale Method

[image]

.NET Framework Class Library
BubbleOptions..::.SetScale Method
BubbleOptions Class See Also
Sets the value of the ScaleProperty attached property for a specified chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetScale(
    C1Chart chart,
    BubbleScale value
)
Visual Basic (Declaration)
Public Shared Sub SetScale ( _
    chart As C1Chart, _
    value As BubbleScale _
)

Parameters

chart
Type: C1.Silverlight.Chart..::.C1Chart
value
Type: C1.Silverlight.Chart..::.BubbleScale

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


BubbleOptions Properties

[image] [image]

.NET Framework Class Library
BubbleOptions Properties
BubbleOptions Class See Also

The BubbleOptions type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

BubbleOptions Class
C1.Silverlight.Chart Namespace


BubbleScale Enumeration

[image]

.NET Framework Class Library
BubbleScale Enumeration
See Also
Specifies how to calculate the size of symbols for Bubble chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum BubbleScale
Visual Basic (Declaration)
Public Enumeration BubbleScale

Members

Member name | Description
Diameter | Scales the symbols according to diameter(linear size).
Area | Scales the symbols according to area(quadratic size).

See Also

C1.Silverlight.Chart Namespace


BubbleSeries Class

[image]

.NET Framework Class Library
BubbleSeries Class
Members See Also
BubbleSeries can contains values that specify size of the symbol for each data point. Use BubbleSeries to create bubble charts.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class BubbleSeries : XYDataSeries
Visual Basic (Declaration)
Public Class BubbleSeries _
    Inherits XYDataSeries

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.DataSeries
C1.Silverlight.Chart..::.XYDataSeries
C1.Silverlight.Chart..::.BubbleSeries

See Also

BubbleSeries Members
C1.Silverlight.Chart Namespace


BubbleSeries Members

[image] [image]

.NET Framework Class Library
BubbleSeries Members
BubbleSeries Class Constructors Methods Fields Properties Events See Also

The BubbleSeries type exposes the following members.

Constructors

Name | Description
BubbleSeries | Creates an instance of BubbleSeries class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

Fields

Name | Description
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listSize | Temporary list for x-values.
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
SizeValuesSourceProperty | Identifies the SizeValuesSource dependency property.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides XYDataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
SizeValueBinding | Gets or sets binding for size data values.
SizeValues | Gets or set the size data values collection.
SizeValuesSource | Gets or sets the x-data values source.
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


BubbleSeries Constructor

[image]

.NET Framework Class Library
BubbleSeries Constructor
BubbleSeries Class See Also
Creates an instance of BubbleSeries class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public BubbleSeries()
Visual Basic (Declaration)
Public Sub New

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


BubbleSeries Fields

[image] [image]

.NET Framework Class Library
BubbleSeries Fields
BubbleSeries Class See Also

The BubbleSeries type exposes the following members.

Fields

Name | Description
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listSize | Temporary list for x-values.
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
SizeValuesSourceProperty | Identifies the SizeValuesSource dependency property.

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


_listSize Field

[image]

.NET Framework Class Library
BubbleSeries..::._listSize Field
BubbleSeries Class See Also
Temporary list for x-values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _listSize
Visual Basic (Declaration)
Protected _listSize As List(Of Object)

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


SizeValuesSourceProperty Field

[image]

.NET Framework Class Library
BubbleSeries..::.SizeValuesSourceProperty Field
BubbleSeries Class See Also
Identifies the SizeValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SizeValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly SizeValuesSourceProperty As DependencyProperty

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


BubbleSeries Methods

[image] [image]

.NET Framework Class Library
BubbleSeries Methods
BubbleSeries Class See Also

The BubbleSeries type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


BubbleSeries Properties

[image] [image]

.NET Framework Class Library
BubbleSeries Properties
BubbleSeries Class See Also

The BubbleSeries type exposes the following members.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides XYDataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
SizeValueBinding | Gets or sets binding for size data values.
SizeValues | Gets or set the size data values collection.
SizeValuesSource | Gets or sets the x-data values source.
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
BubbleSeries..::.MemberPaths Property
BubbleSeries Class See Also
Gets the array of member bindings for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override Binding[] MemberPaths { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberPaths As Binding()

Implements

IDataSeriesInfo..::.MemberPaths

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


SizeValueBinding Property

[image]

.NET Framework Class Library
BubbleSeries..::.SizeValueBinding Property
BubbleSeries Class See Also
Gets or sets binding for size data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding SizeValueBinding { get; set; }
Visual Basic (Declaration)
Public Property SizeValueBinding As Binding

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


SizeValues Property

[image]

.NET Framework Class Library
BubbleSeries..::.SizeValues Property
BubbleSeries Class See Also
Gets or set the size data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection SizeValues { get; set; }
Visual Basic (Declaration)
Public Property SizeValues As DoubleCollection

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


SizeValuesSource Property

[image]

.NET Framework Class Library
BubbleSeries..::.SizeValuesSource Property
BubbleSeries Class See Also
Gets or sets the x-data values source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable SizeValuesSource { get; set; }
Visual Basic (Declaration)
Public Property SizeValuesSource As IEnumerable

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


BubbleSeries Events

[image] [image]

.NET Framework Class Library
BubbleSeries Events
BubbleSeries Class See Also

The BubbleSeries type exposes the following members.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

BubbleSeries Class
C1.Silverlight.Chart Namespace


C1Chart Class

[image]

.NET Framework Class Library
C1Chart Class
Members See Also
Represents a C1Chart control.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[ContentPropertyAttribute("Children")]
public class C1Chart : ContentControl, INotifyPropertyChanged
Visual Basic (Declaration)
<ContentPropertyAttribute("Children")> _
Public Class C1Chart _
    Inherits ContentControl _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight.Chart..::.C1Chart

See Also

C1Chart Members
C1.Silverlight.Chart Namespace


C1Chart Members

[image] [image]

.NET Framework Class Library
C1Chart Members
C1Chart Class Constructors Methods Fields Properties Events See Also

The C1Chart type exposes the following members.

Constructors

Name | Description
C1Chart | Initializes a new instance of the C1Chart class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginUpdate | Starts batch updating.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EndUpdate | Ends batch updating.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
FindPlotElement | Find the plot element by its name.
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Invoked when control template was applied. (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ResetData | Resets the data to the default value.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldSerializeData | Whether the data should be serialized
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ChartTypeProperty | Identifies the ChartType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
CustomPaletteProperty | Identifies the CustomPalette dependency property.
CustomThemeProperty | Identifies the CustomeTheme dependency property.
DataProperty | Identifies the Data dependency property.
ThemeProperty | Identifies the Theme dependency property.
ViewProperty | Identifies the View dependency property.

Properties

Name | Description
Actions | Stores the Action objects that control interactive features at runtime.
ActionUpdateDelay | Gets or sets chart update delay in milliseconds after interactive action.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ChartType | Gets or sets the chart type.
Children | Gets collection of child elements.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
CornerRadius | Gets or sets corner radius of the chart.
Cursor | (Inherited from FrameworkElement.)
CustomPalette | Gets ot sets the custom brushes array for the plot elements.
CustomTheme | Gets or sets user-defined theme.
Data | Gets or sets the chart data.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
GradientMethod | Specifies how to handle gradient brushes in themes and custom palettes.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendItems | Gets the collection of legend items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets color palette.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Theme | Gets or sets chart theme.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets the chart view.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
ActionEnter | Fires when interactive action is started.
ActionLeave | Fires when interactive action is finished.
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
LegendChanged | Fires when the chart legend was updated.
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PropertyChanged | Fires when property was changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1Chart Constructor

[image]

.NET Framework Class Library
C1Chart Constructor
C1Chart Class See Also
Initializes a new instance of the C1Chart class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public C1Chart()
Visual Basic (Declaration)
Public Sub New

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1Chart Fields

[image] [image]

.NET Framework Class Library
C1Chart Fields
C1Chart Class See Also

The C1Chart type exposes the following members.

Fields

Name | Description
ChartTypeProperty | Identifies the ChartType dependency property.
CornerRadiusProperty | Identifies the CornerRadius dependency property.
CustomPaletteProperty | Identifies the CustomPalette dependency property.
CustomThemeProperty | Identifies the CustomeTheme dependency property.
DataProperty | Identifies the Data dependency property.
ThemeProperty | Identifies the Theme dependency property.
ViewProperty | Identifies the View dependency property.

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ChartTypeProperty Field

[image]

.NET Framework Class Library
C1Chart..::.ChartTypeProperty Field
C1Chart Class See Also
Identifies the ChartType dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ChartTypeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ChartTypeProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CornerRadiusProperty Field

[image]

.NET Framework Class Library
C1Chart..::.CornerRadiusProperty Field
C1Chart Class See Also
Identifies the CornerRadius dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty CornerRadiusProperty
Visual Basic (Declaration)
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CustomPaletteProperty Field

[image]

.NET Framework Class Library
C1Chart..::.CustomPaletteProperty Field
C1Chart Class See Also
Identifies the CustomPalette dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty CustomPaletteProperty
Visual Basic (Declaration)
Public Shared ReadOnly CustomPaletteProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CustomThemeProperty Field

[image]

.NET Framework Class Library
C1Chart..::.CustomThemeProperty Field
C1Chart Class See Also
Identifies the CustomeTheme dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty CustomThemeProperty
Visual Basic (Declaration)
Public Shared CustomThemeProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


DataProperty Field

[image]

.NET Framework Class Library
C1Chart..::.DataProperty Field
C1Chart Class See Also
Identifies the Data dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty DataProperty
Visual Basic (Declaration)
Public Shared ReadOnly DataProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ThemeProperty Field

[image]

.NET Framework Class Library
C1Chart..::.ThemeProperty Field
C1Chart Class See Also
Identifies the Theme dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DependencyProperty ThemeProperty
Visual Basic (Declaration)
Public Shared ThemeProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ViewProperty Field

[image]

.NET Framework Class Library
C1Chart..::.ViewProperty Field
C1Chart Class See Also
Identifies the View dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ViewProperty
Visual Basic (Declaration)
Public Shared ReadOnly ViewProperty As DependencyProperty

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1Chart Methods

[image] [image]

.NET Framework Class Library
C1Chart Methods
C1Chart Class See Also

The C1Chart type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginUpdate | Starts batch updating.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EndUpdate | Ends batch updating.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
FindPlotElement | Find the plot element by its name.
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | Invoked when control template was applied. (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ResetData | Resets the data to the default value.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ShouldSerializeData | Whether the data should be serialized
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


BeginUpdate Method

[image]

.NET Framework Class Library
C1Chart..::.BeginUpdate Method
C1Chart Class See Also
Starts batch updating.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public void BeginUpdate()
Visual Basic (Declaration)
Public Sub BeginUpdate

Remarks

Prevents updating of the control until the EndUpdate()()() method is called.

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


EndUpdate Method

[image]

.NET Framework Class Library
C1Chart..::.EndUpdate Method
C1Chart Class See Also
Ends batch updating.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public void EndUpdate()
Visual Basic (Declaration)
Public Sub EndUpdate

Remarks

Updates the controls with changes made after the previous call of BeginUpdate()()() method.

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


FindPlotElement Method

[image]

.NET Framework Class Library
C1Chart..::.FindPlotElement Method
C1Chart Class See Also
Find the plot element by its name.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object FindPlotElement(
    string name
)
Visual Basic (Declaration)
Public Function FindPlotElement ( _
    name As String _
) As Object

Parameters

name
Type: System..::.String
The name of element to find.

Return Value

The plot element with the specified name.

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Chart..::.HitTest Method
C1Chart Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Chart Class
C1Chart Members
C1.Silverlight.Chart Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Chart..::.OnApplyTemplate Method
C1Chart Class See Also
Invoked when control template was applied.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ResetData Method

[image]

.NET Framework Class Library
C1Chart..::.ResetData Method
C1Chart Class See Also
Resets the data to the default value.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void ResetData()
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub ResetData

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ShouldSerializeData Method

[image]

.NET Framework Class Library
C1Chart..::.ShouldSerializeData Method
C1Chart Class See Also
Whether the data should be serialized

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeData()
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Function ShouldSerializeData As Boolean

Return Value

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1Chart Properties

[image] [image]

.NET Framework Class Library
C1Chart Properties
C1Chart Class See Also

The C1Chart type exposes the following members.

Properties

Name | Description
Actions | Stores the Action objects that control interactive features at runtime.
ActionUpdateDelay | Gets or sets chart update delay in milliseconds after interactive action.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ChartType | Gets or sets the chart type.
Children | Gets collection of child elements.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
CornerRadius | Gets or sets corner radius of the chart.
Cursor | (Inherited from FrameworkElement.)
CustomPalette | Gets ot sets the custom brushes array for the plot elements.
CustomTheme | Gets or sets user-defined theme.
Data | Gets or sets the chart data.
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
GradientMethod | Specifies how to handle gradient brushes in themes and custom palettes.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendItems | Gets the collection of legend items.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets or sets color palette.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Theme | Gets or sets chart theme.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
View | Gets or sets the chart view.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


Actions Property

[image]

.NET Framework Class Library
C1Chart..::.Actions Property
C1Chart Class See Also
Stores the Action objects that control interactive features at runtime.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ActionCollection Actions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Actions As ActionCollection

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ActionUpdateDelay Property

[image]

.NET Framework Class Library
C1Chart..::.ActionUpdateDelay Property
C1Chart Class See Also
Gets or sets chart update delay in milliseconds after interactive action.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute()]
public double ActionUpdateDelay { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute()> _
Public Property ActionUpdateDelay As Double

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ChartType Property

[image]

.NET Framework Class Library
C1Chart..::.ChartType Property
C1Chart Class See Also
Gets or sets the chart type.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[CategoryAttribute("Appearance")]
public ChartType ChartType { get; set; }
Visual Basic (Declaration)
<CategoryAttribute("Appearance")> _
Public Property ChartType As ChartType

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


Children Property

[image]

.NET Framework Class Library
C1Chart..::.Children Property
C1Chart Class See Also
Gets collection of child elements.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ObservableCollection<UIElement> Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As ObservableCollection(Of UIElement)

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CornerRadius Property

[image]

.NET Framework Class Library
C1Chart..::.CornerRadius Property
C1Chart Class See Also
Gets or sets corner radius of the chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public CornerRadius CornerRadius { get; set; }
Visual Basic (Declaration)
Public Property CornerRadius As CornerRadius

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CustomPalette Property

[image]

.NET Framework Class Library
C1Chart..::.CustomPalette Property
C1Chart Class See Also
Gets ot sets the custom brushes array for the plot elements.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable CustomPalette { get; set; }
Visual Basic (Declaration)
Public Property CustomPalette As IEnumerable

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


CustomTheme Property

[image]

.NET Framework Class Library
C1Chart..::.CustomTheme Property
C1Chart Class See Also
Gets or sets user-defined theme.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ResourceDictionary CustomTheme { get; set; }
Visual Basic (Declaration)
Public Property CustomTheme As ResourceDictionary

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


Data Property

[image]

.NET Framework Class Library
C1Chart..::.Data Property
C1Chart Class See Also
Gets or sets the chart data.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public ChartData Data { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute(Nothing)> _
Public Property Data As ChartData

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


GradientMethod Property

[image]

.NET Framework Class Library
C1Chart..::.GradientMethod Property
C1Chart Class See Also
Specifies how to handle gradient brushes in themes and custom palettes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public GradientMethod GradientMethod { get; set; }
Visual Basic (Declaration)
Public Property GradientMethod As GradientMethod

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


LegendItems Property

[image]

.NET Framework Class Library
C1Chart..::.LegendItems Property
C1Chart Class See Also
Gets the collection of legend items.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public LegendItemCollection LegendItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property LegendItems As LegendItemCollection

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


Palette Property

[image]

.NET Framework Class Library
C1Chart..::.Palette Property
C1Chart Class See Also
Gets or sets color palette.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[CategoryAttribute("Appearance")]
[DefaultValueAttribute(Palette.Default)]
public Palette Palette { get; set; }
Visual Basic (Declaration)
<CategoryAttribute("Appearance")> _
<DefaultValueAttribute(Palette.Default)> _
Public Property Palette As Palette

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


Theme Property

[image]

.NET Framework Class Library
C1Chart..::.Theme Property
C1Chart Class See Also
Gets or sets chart theme.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[CategoryAttribute("Appearance")]
public ChartTheme Theme { get; set; }
Visual Basic (Declaration)
<CategoryAttribute("Appearance")> _
Public Property Theme As ChartTheme

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


View Property

[image]

.NET Framework Class Library
C1Chart..::.View Property
C1Chart Class See Also
Gets or sets the chart view.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartView View { get; set; }
Visual Basic (Declaration)
Public Property View As ChartView

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1Chart Events

[image] [image]

.NET Framework Class Library
C1Chart Events
C1Chart Class See Also

The C1Chart type exposes the following members.

Events

Name | Description
ActionEnter | Fires when interactive action is started.
ActionLeave | Fires when interactive action is finished.
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
LegendChanged | Fires when the chart legend was updated.
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
PropertyChanged | Fires when property was changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ActionEnter Event

[image]

.NET Framework Class Library
C1Chart..::.ActionEnter Event
C1Chart Class See Also
Fires when interactive action is started.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event EventHandler ActionEnter
Visual Basic (Declaration)
Public Event ActionEnter As EventHandler

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


ActionLeave Event

[image]

.NET Framework Class Library
C1Chart..::.ActionLeave Event
C1Chart Class See Also
Fires when interactive action is finished.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event EventHandler ActionLeave
Visual Basic (Declaration)
Public Event ActionLeave As EventHandler

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


LegendChanged Event

[image]

.NET Framework Class Library
C1Chart..::.LegendChanged Event
C1Chart Class See Also
Fires when the chart legend was updated.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public event EventHandler LegendChanged
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Event LegendChanged As EventHandler

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
C1Chart..::.PropertyChanged Event
C1Chart Class See Also
Fires when property was changed.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

C1Chart Class
C1.Silverlight.Chart Namespace


C1ChartLegend Class

[image]

.NET Framework Class Library
C1ChartLegend Class
Members See Also
Represents the chart legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class C1ChartLegend : ItemsControl
Visual Basic (Declaration)
Public Class C1ChartLegend _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Chart..::.C1ChartLegend
C1.Silverlight.Chart..::.Legend

See Also

C1ChartLegend Members
C1.Silverlight.Chart Namespace


C1ChartLegend Members

[image] [image]

.NET Framework Class Library
C1ChartLegend Members
C1ChartLegend Class Constructors Methods Fields Properties Events See Also

The C1ChartLegend type exposes the following members.

Constructors

Name | Description
C1ChartLegend | Initializes a new instance of Legend class.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
OrientationProperty | Identifies the Orientation dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Chart | Gets or sets the instance of Chart that corresponds to the Legend.
Clip | (Inherited from UIElement.)
CornerRadius | Gets or sets corner radius of the legend.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the layout orientation for the legend.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Position | Gets or sets legend position.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


C1ChartLegend Constructor

[image]

.NET Framework Class Library
C1ChartLegend Constructor
C1ChartLegend Class See Also
Initializes a new instance of Legend class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public C1ChartLegend()
Visual Basic (Declaration)
Public Sub New

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


C1ChartLegend Fields

[image] [image]

.NET Framework Class Library
C1ChartLegend Fields
C1ChartLegend Class See Also

The C1ChartLegend type exposes the following members.

Fields

Name | Description
CornerRadiusProperty | Identifies the CornerRadius dependency property.
OrientationProperty | Identifies the Orientation dependency property.

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


CornerRadiusProperty Field

[image]

.NET Framework Class Library
C1ChartLegend..::.CornerRadiusProperty Field
C1ChartLegend Class See Also
Identifies the CornerRadius dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty CornerRadiusProperty
Visual Basic (Declaration)
Public Shared ReadOnly CornerRadiusProperty As DependencyProperty

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


OrientationProperty Field

[image]

.NET Framework Class Library
C1ChartLegend..::.OrientationProperty Field
C1ChartLegend Class See Also
Identifies the Orientation dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


C1ChartLegend Methods

[image] [image]

.NET Framework Class Library
C1ChartLegend Methods
C1ChartLegend Class See Also

The C1ChartLegend type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ChartLegend..::.HitTest Method
C1ChartLegend Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ChartLegend Class
C1ChartLegend Members
C1.Silverlight.Chart Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1ChartLegend..::.PrepareContainerForItemOverride Method
C1ChartLegend Class See Also
Prepares the specified element to display the specified item.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


C1ChartLegend Properties

[image] [image]

.NET Framework Class Library
C1ChartLegend Properties
C1ChartLegend Class See Also

The C1ChartLegend type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Chart | Gets or sets the instance of Chart that corresponds to the Legend.
Clip | (Inherited from UIElement.)
CornerRadius | Gets or sets corner radius of the legend.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the layout orientation for the legend.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Position | Gets or sets legend position.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


Chart Property

[image]

.NET Framework Class Library
C1ChartLegend..::.Chart Property
C1ChartLegend Class See Also
Gets or sets the instance of Chart that corresponds to the Legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public C1Chart Chart { get; set; }
Visual Basic (Declaration)
Public Property Chart As C1Chart

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


CornerRadius Property

[image]

.NET Framework Class Library
C1ChartLegend..::.CornerRadius Property
C1ChartLegend Class See Also
Gets or sets corner radius of the legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public CornerRadius CornerRadius { get; set; }
Visual Basic (Declaration)
Public Property CornerRadius As CornerRadius

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


Orientation Property

[image]

.NET Framework Class Library
C1ChartLegend..::.Orientation Property
C1ChartLegend Class See Also
Gets or sets the layout orientation for the legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


Position Property

[image]

.NET Framework Class Library
C1ChartLegend..::.Position Property
C1ChartLegend Class See Also
Gets or sets legend position.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public LegendPosition Position { get; set; }
Visual Basic (Declaration)
Public Property Position As LegendPosition

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


C1ChartLegend Events

[image] [image]

.NET Framework Class Library
C1ChartLegend Events
C1ChartLegend Class See Also

The C1ChartLegend type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ChartLegend Class
C1.Silverlight.Chart Namespace


ChartData Class

[image]

.NET Framework Class Library
ChartData Class
Members See Also
Main class of data handling, contains collection of data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[ContentPropertyAttribute("Children")]
public class ChartData : DependencyObject
Visual Basic (Declaration)
<ContentPropertyAttribute("Children")> _
Public Class ChartData _
    Inherits DependencyObject

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.ChartData

See Also

ChartData Members
C1.Silverlight.Chart Namespace


ChartData Members

[image] [image]

.NET Framework Class Library
ChartData Members
ChartData Class Constructors Methods Fields Properties Events See Also

The ChartData type exposes the following members.

Constructors

Name | Description
ChartData |

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateDesignTimeData | Creates set of design-time default data values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ShouldSerializeChildren | Determines whether the Children collection should be serialized.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
ItemNamesProperty | Identifies the ItemNames dependency property.
ItemsSourceProperty | Identifies the ItemsSource dependency property.
RendererProperty | Identifies the Renderer dependency property.

Properties

Name | Description
Children | Gets the collection of data series.
Dispatcher | (Inherited from DependencyObject.)
ItemNameBinding | Gets or sets the item name binding.
ItemNames | Gets or sets the item names.
ItemsSource | Gets or sets the items source.
Renderer | Gets or sets renderer which is responsible for data visualization.

Events

Name | Description
DataChanged | Fires when data was changed.
PropertyChanged | Fires when a property value changes.

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartData Constructor

[image]

.NET Framework Class Library
ChartData Constructor
ChartData Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartData()
Visual Basic (Declaration)
Public Sub New

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartData Fields

[image] [image]

.NET Framework Class Library
ChartData Fields
ChartData Class See Also

The ChartData type exposes the following members.

Fields

Name | Description
ItemNamesProperty | Identifies the ItemNames dependency property.
ItemsSourceProperty | Identifies the ItemsSource dependency property.
RendererProperty | Identifies the Renderer dependency property.

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ItemNamesProperty Field

[image]

.NET Framework Class Library
ChartData..::.ItemNamesProperty Field
ChartData Class See Also
Identifies the ItemNames dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ItemNamesProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemNamesProperty As DependencyProperty

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ItemsSourceProperty Field

[image]

.NET Framework Class Library
ChartData..::.ItemsSourceProperty Field
ChartData Class See Also
Identifies the ItemsSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

ChartData Class
C1.Silverlight.Chart Namespace


RendererProperty Field

[image]

.NET Framework Class Library
ChartData..::.RendererProperty Field
ChartData Class See Also
Identifies the Renderer dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty RendererProperty
Visual Basic (Declaration)
Public Shared ReadOnly RendererProperty As DependencyProperty

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartData Methods

[image] [image]

.NET Framework Class Library
ChartData Methods
ChartData Class See Also

The ChartData type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateDesignTimeData | Creates set of design-time default data values.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ShouldSerializeChildren | Determines whether the Children collection should be serialized.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartData Class
C1.Silverlight.Chart Namespace


CreateDesignTimeData Method

[image]

.NET Framework Class Library
ChartData..::.CreateDesignTimeData Method
ChartData Class See Also
Creates set of design-time default data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void CreateDesignTimeData()
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Sub CreateDesignTimeData

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ShouldSerializeChildren Method

[image]

.NET Framework Class Library
ChartData..::.ShouldSerializeChildren Method
ChartData Class See Also
Determines whether the Children collection should be serialized.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool ShouldSerializeChildren()
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Function ShouldSerializeChildren As Boolean

Return Value

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartData Properties

[image] [image]

.NET Framework Class Library
ChartData Properties
ChartData Class See Also

The ChartData type exposes the following members.

Properties

Name | Description
Children | Gets the collection of data series.
Dispatcher | (Inherited from DependencyObject.)
ItemNameBinding | Gets or sets the item name binding.
ItemNames | Gets or sets the item names.
ItemsSource | Gets or sets the items source.
Renderer | Gets or sets renderer which is responsible for data visualization.

See Also

ChartData Class
C1.Silverlight.Chart Namespace


Children Property

[image]

.NET Framework Class Library
ChartData..::.Children Property
ChartData Class See Also
Gets the collection of data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataSeriesCollection Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As DataSeriesCollection

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ItemNameBinding Property

[image]

.NET Framework Class Library
ChartData..::.ItemNameBinding Property
ChartData Class See Also
Gets or sets the item name binding.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Binding ItemNameBinding { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute(Nothing)> _
Public Property ItemNameBinding As Binding

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ItemNames Property

[image]

.NET Framework Class Library
ChartData..::.ItemNames Property
ChartData Class See Also
Gets or sets the item names.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable ItemNames { get; set; }
Visual Basic (Declaration)
Public Property ItemNames As IEnumerable

Remarks

The item names are common for all data series.

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ItemsSource Property

[image]

.NET Framework Class Library
ChartData..::.ItemsSource Property
ChartData Class See Also
Gets or sets the items source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IEnumerable

See Also

ChartData Class
C1.Silverlight.Chart Namespace


Renderer Property

[image]

.NET Framework Class Library
ChartData..::.Renderer Property
ChartData Class See Also
Gets or sets renderer which is responsible for data visualization.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IRenderer Renderer { get; set; }
Visual Basic (Declaration)
Public Property Renderer As IRenderer

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartData Events

[image] [image]

.NET Framework Class Library
ChartData Events
ChartData Class See Also

The ChartData type exposes the following members.

Events

Name | Description
DataChanged | Fires when data was changed.
PropertyChanged | Fires when a property value changes.

See Also

ChartData Class
C1.Silverlight.Chart Namespace


DataChanged Event

[image]

.NET Framework Class Library
ChartData..::.DataChanged Event
ChartData Class See Also
Fires when data was changed.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event EventHandler DataChanged
Visual Basic (Declaration)
Public Event DataChanged As EventHandler

See Also

ChartData Class
C1.Silverlight.Chart Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ChartData..::.PropertyChanged Event
ChartData Class See Also
Fires when a property value changes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Event PropertyChanged As PropertyChangedEventHandler

See Also

ChartData Class
C1.Silverlight.Chart Namespace


ChartSubtype Class

[image]

.NET Framework Class Library
ChartSubtype Class
Members See Also
Represents chart type in the gallery.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ChartSubtype
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Class ChartSubtype

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.ChartSubtype

See Also

ChartSubtype Members
C1.Silverlight.Chart Namespace


ChartSubtype Members

[image] [image]

.NET Framework Class Library
ChartSubtype Members
ChartSubtype Class Constructors Methods Properties See Also

The ChartSubtype type exposes the following members.

Constructors

Name | Description
ChartSubtype | Initialize an instance of the ChartSubtype class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Connection | Gets or sets the
Name | Gets or sets the name of subtype.
Renderer | Gets or sets the name of renderer.
RendererOptions | Gets or sets the options of the renderer.
Symbol | Gets or sets the template of symbol.

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


ChartSubtype Constructor

[image]

.NET Framework Class Library
ChartSubtype Constructor
ChartSubtype Class See Also
Initialize an instance of the ChartSubtype class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartSubtype()
Visual Basic (Declaration)
Public Sub New

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


ChartSubtype Methods

[image] [image]

.NET Framework Class Library
ChartSubtype Methods
ChartSubtype Class See Also

The ChartSubtype type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


ChartSubtype Properties

[image] [image]

.NET Framework Class Library
ChartSubtype Properties
ChartSubtype Class See Also

The ChartSubtype type exposes the following members.

Properties

Name | Description
Connection | Gets or sets the
Name | Gets or sets the name of subtype.
Renderer | Gets or sets the name of renderer.
RendererOptions | Gets or sets the options of the renderer.
Symbol | Gets or sets the template of symbol.

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


Connection Property

[image]

.NET Framework Class Library
ChartSubtype..::.Connection Property
ChartSubtype Class See Also
Gets or sets the

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Connection { get; set; }
Visual Basic (Declaration)
Public Property Connection As Object

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


Name Property

[image]

.NET Framework Class Library
ChartSubtype..::.Name Property
ChartSubtype Class See Also
Gets or sets the name of subtype.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


Renderer Property

[image]

.NET Framework Class Library
ChartSubtype..::.Renderer Property
ChartSubtype Class See Also
Gets or sets the name of renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Renderer { get; set; }
Visual Basic (Declaration)
Public Property Renderer As String

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


RendererOptions Property

[image]

.NET Framework Class Library
ChartSubtype..::.RendererOptions Property
ChartSubtype Class See Also
Gets or sets the options of the renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string RendererOptions { get; set; }
Visual Basic (Declaration)
Public Property RendererOptions As String

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


Symbol Property

[image]

.NET Framework Class Library
ChartSubtype..::.Symbol Property
ChartSubtype Class See Also
Gets or sets the template of symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As Object

See Also

ChartSubtype Class
C1.Silverlight.Chart Namespace


ChartTheme Enumeration

[image]

.NET Framework Class Library
ChartTheme Enumeration
See Also
Specifies available chart themes

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum ChartTheme
Visual Basic (Declaration)
Public Enumeration ChartTheme

Members

Member name | Description
None | Theme is not set.
Custom | User-defined theme is set with CustomTheme property.
DuskBlue | Built-in DuskBlue theme.
DuskGreen | Built-in DuskGreen theme.
MediaPlayer | Built-in MediaPlayer theme.
Office2003Blue | Built-in Office2003Blue theme.
Office2003Classic | Built-in Office2003Classic theme.
Office2003Olive | Built-in Office2003Olive theme.
Office2003Royale | Built-in Office2003Royale theme.
Office2003Silver | Built-in Office2003Silver theme.
Office2007Black | Built-in Office2007Black theme.
Office2007Blue | Built-in Office2007Blue theme.
Office2007Silver | Built-in Office2007Silver theme.
Vista | Built-in Vista theme.

See Also

C1.Silverlight.Chart Namespace


ChartType Enumeration

[image]

.NET Framework Class Library
ChartType Enumeration
See Also
Specifies the chart type.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum ChartType
Visual Basic (Declaration)
Public Enumeration ChartType

Members

Member name | Description
Bar | Default bar chart.
BarStacked | Stacked bar chart.
BarStacked100pc | 100% stacked bar chart.
Column | Default column chart.
ColumnStacked | Stacked column chart.
ColumnStacked100pc | 100% stacked column chart.
Line | Default line chart.
LineSmoothed | Smoothed line chart.
LineStacked | Stacked line chart.
LineStacked100pc | 100% stacked line chart.
LineSymbols | Line chart with symbols.
LineSymbolsStacked | Stacked line chart with symbols.
LineSymbolsStacked100pc | 100% stacked line chart with symbols.
LineSymbolsSmoothed | Smoothed line chart with symbols.
Area | Default area chart
AreaStacked | Stacked area chart.
AreaStacked100pc | 100% stacked area chart.
AreaSmoothed | Smoothed area chart.
Pie | Default pie chart.
PieExploded | Exploded pie chart.
PieDoughnut | Doughnut pie chart.
PieExplodedDoughnut | Exploded doughnut pie chart.
XYPlot | Scatter(point) plot in Cartesian coordinates.
Bubble | Bubble chart. To specify control size of symbols use BubbleSeries and set its SizeValues or SizeValuesource property.
Radar | Radar chart
RadarSymbols | Radar chart with symbols
RadarFilled | Filled(area) radar chart
HighLowOpenClose | High-low-open-close financial chart. Use HighLowOpenCloseSeries to specify data for the chart.
Candle | Candle financial chart. Use HighLowOpenCloseSeries to specify data for the chart.

See Also

C1.Silverlight.Chart Namespace


ChartTypeInfo Class

[image]

.NET Framework Class Library
ChartTypeInfo Class
Members See Also
Represents the chart type. The type contains from the collection of subtypes that describe different variations of the chart type.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
[ContentPropertyAttribute("Subtypes")]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ChartTypeInfo
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
<ContentPropertyAttribute("Subtypes")> _
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Class ChartTypeInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.ChartTypeInfo

See Also

ChartTypeInfo Members
C1.Silverlight.Chart Namespace


ChartTypeInfo Members

[image] [image]

.NET Framework Class Library
ChartTypeInfo Members
ChartTypeInfo Class Constructors Methods Properties See Also

The ChartTypeInfo type exposes the following members.

Constructors

Name | Description
ChartTypeInfo | Initializes an instance of ChartTypeInfo class.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | Gets the chart subtype by its name.
Name | Gets or sets the name of chart type.
Subtypes | Gets the list of subtypes.

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


ChartTypeInfo Constructor

[image]

.NET Framework Class Library
ChartTypeInfo Constructor
ChartTypeInfo Class See Also
Initializes an instance of ChartTypeInfo class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartTypeInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


ChartTypeInfo Methods

[image] [image]

.NET Framework Class Library
ChartTypeInfo Methods
ChartTypeInfo Class See Also

The ChartTypeInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


ChartTypeInfo Properties

[image] [image]

.NET Framework Class Library
ChartTypeInfo Properties
ChartTypeInfo Class See Also

The ChartTypeInfo type exposes the following members.

Properties

Name | Description
Item | Gets the chart subtype by its name.
Name | Gets or sets the name of chart type.
Subtypes | Gets the list of subtypes.

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


Item Property

[image]

.NET Framework Class Library
ChartTypeInfo..::.Item Property
ChartTypeInfo Class See Also
Gets the chart subtype by its name.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartSubtype this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As ChartSubtype

Parameters

name
Type: System..::.String
The name of subtype.

Return Value

Subtype with the specified name.

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


Name Property

[image]

.NET Framework Class Library
ChartTypeInfo..::.Name Property
ChartTypeInfo Class See Also
Gets or sets the name of chart type.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


Subtypes Property

[image]

.NET Framework Class Library
ChartTypeInfo..::.Subtypes Property
ChartTypeInfo Class See Also
Gets the list of subtypes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public List<ChartSubtype> Subtypes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Subtypes As List(Of ChartSubtype)

See Also

ChartTypeInfo Class
C1.Silverlight.Chart Namespace


ChartView Class

[image]

.NET Framework Class Library
ChartView Class
Members See Also
Represents class view object that contains all visual plot elements: axes, visualized data.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[ContentPropertyAttribute("Axes")]
public class ChartView : FrameworkElement
Visual Basic (Declaration)
<ContentPropertyAttribute("Axes")> _
Public Class ChartView _
    Inherits FrameworkElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
C1.Silverlight.Chart..::.ChartView

See Also

ChartView Members
C1.Silverlight.Chart Namespace


ChartView Members

[image] [image]

.NET Framework Class Library
ChartView Members
ChartView Class Constructors Methods Fields Properties Events See Also

The ChartView type exposes the following members.

Constructors

Name | Description
ChartView | Initialize an instance of ChartView class.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
DataIndexFromPoint | Get the index of closest data point that corresponds to the specified point.
DataIndexToPoint | Returns the point that corresponds to the specified data point. The data point is specified by its series and point indices.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataPoint | Gets the data point attached to the specified visual.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
PointFromData | Transforms the point from data coordinates to control coordinates.
PointToData | Transforms the point from control coordinates to data coordinates.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetDataPoint | Attaches the specified visual to the specified data point on the plot.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
PlotBackgroundProperty | Identifies the PlotBackground dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Axes | Gets the axis collection.
AxisX | Gets or sets X axis.
AxisY | Gets or sets Z axis.
Children | Gets the list of the additional visuals that are rendered on the plot.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
PlotBackground | Gets or sets the background brush for plot area.
PlotRect | Gets the plot rectangle (area inside axes).
PlotShape | Gets or sets the shape that should be rendered on the plot background.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ChartView Constructor

[image]

.NET Framework Class Library
ChartView Constructor
ChartView Class See Also
Initialize an instance of ChartView class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ChartView()
Visual Basic (Declaration)
Public Sub New

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ChartView Fields

[image] [image]

.NET Framework Class Library
ChartView Fields
ChartView Class See Also

The ChartView type exposes the following members.

Fields

Name | Description
PlotBackgroundProperty | Identifies the PlotBackground dependency property.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


PlotBackgroundProperty Field

[image]

.NET Framework Class Library
ChartView..::.PlotBackgroundProperty Field
ChartView Class See Also
Identifies the PlotBackground dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty PlotBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly PlotBackgroundProperty As DependencyProperty

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ChartView Methods

[image] [image]

.NET Framework Class Library
ChartView Methods
ChartView Class See Also

The ChartView type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
DataIndexFromPoint | Get the index of closest data point that corresponds to the specified point.
DataIndexToPoint | Returns the point that corresponds to the specified data point. The data point is specified by its series and point indices.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataPoint | Gets the data point attached to the specified visual.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
PointFromData | Transforms the point from data coordinates to control coordinates.
PointToData | Transforms the point from control coordinates to data coordinates.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetDataPoint | Attaches the specified visual to the specified data point on the plot.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ChartView Class
C1.Silverlight.Chart Namespace


DataIndexFromPoint Method

[image]

.NET Framework Class Library
ChartView..::.DataIndexFromPoint Method
ChartView Class See Also
Get the index of closest data point that corresponds to the specified point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public int DataIndexFromPoint(
    Point pt,
    int seriesIndex,
    MeasureOption option,
    out double distance
)
Visual Basic (Declaration)
Public Function DataIndexFromPoint ( _
    pt As Point, _
    seriesIndex As Integer, _
    option As MeasureOption, _
    <OutAttribute> ByRef distance As Double _
) As Integer

Parameters

pt
Type: System.Windows..::.Point
Point in the control coordinates.
seriesIndex
Type: System..::.Int32
Index of series.
option
Type: C1.Silverlight.Chart..::.MeasureOption
Measure option.
distance
Type: System..::.Double %
Distance from the data point to the specified point.

Return Value

The index of the data point that is closest to the specified point.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


DataIndexToPoint Method

[image]

.NET Framework Class Library
ChartView..::.DataIndexToPoint Method
ChartView Class See Also
Returns the point that corresponds to the specified data point. The data point is specified by its series and point indices.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point DataIndexToPoint(
    int seriesIndex,
    int pointIndex
)
Visual Basic (Declaration)
Public Function DataIndexToPoint ( _
    seriesIndex As Integer, _
    pointIndex As Integer _
) As Point

Parameters

seriesIndex
Type: System..::.Int32
Index of data series.
pointIndex
Type: System..::.Int32
Index of the point in the data series.

Return Value

See Also

ChartView Class
C1.Silverlight.Chart Namespace


GetDataPoint Method

[image]

.NET Framework Class Library
ChartView..::.GetDataPoint Method
ChartView Class See Also
Gets the data point attached to the specified visual.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point GetDataPoint(
    UIElement visual
)
Visual Basic (Declaration)
Public Function GetDataPoint ( _
    visual As UIElement _
) As Point

Parameters

visual
Type: System.Windows..::.UIElement
The visual.

Return Value

The data point.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
ChartView..::.HitTest Method
ChartView Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

ChartView Class
ChartView Members
C1.Silverlight.Chart Namespace


PointFromData Method

[image]

.NET Framework Class Library
ChartView..::.PointFromData Method
ChartView Class See Also
Transforms the point from data coordinates to control coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point PointFromData(
    Point pt
)
Visual Basic (Declaration)
Public Function PointFromData ( _
    pt As Point _
) As Point

Parameters

pt
Type: System.Windows..::.Point
Point in data coordinates

Return Value

The corresponding point in control coordinates.

Remarks

Only 2D Cartesian charts.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


PointToData Method

[image]

.NET Framework Class Library
ChartView..::.PointToData Method
ChartView Class See Also
Transforms the point from control coordinates to data coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point PointToData(
    Point pt
)
Visual Basic (Declaration)
Public Function PointToData ( _
    pt As Point _
) As Point

Parameters

pt
Type: System.Windows..::.Point
Point in control coordinates

Return Value

The corresponding point in data coordinates.

Remarks

Only 2D Cartesian charts.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


SetDataPoint Method

[image]

.NET Framework Class Library
ChartView..::.SetDataPoint Method
ChartView Class See Also
Attaches the specified visual to the specified data point on the plot.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public void SetDataPoint(
    UIElement visual,
    Point point
)
Visual Basic (Declaration)
Public Sub SetDataPoint ( _
    visual As UIElement, _
    point As Point _
)

Parameters

visual
Type: System.Windows..::.UIElement
The visual to attach.
point
Type: System.Windows..::.Point
The point in data coordinates.

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ChartView Properties

[image] [image]

.NET Framework Class Library
ChartView Properties
ChartView Class See Also

The ChartView type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Axes | Gets the axis collection.
AxisX | Gets or sets X axis.
AxisY | Gets or sets Z axis.
Children | Gets the list of the additional visuals that are rendered on the plot.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
PlotBackground | Gets or sets the background brush for plot area.
PlotRect | Gets the plot rectangle (area inside axes).
PlotShape | Gets or sets the shape that should be rendered on the plot background.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ChartView Class
C1.Silverlight.Chart Namespace


Axes Property

[image]

.NET Framework Class Library
ChartView..::.Axes Property
ChartView Class See Also
Gets the axis collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public AxisCollection Axes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Axes As AxisCollection

See Also

ChartView Class
C1.Silverlight.Chart Namespace


AxisX Property

[image]

.NET Framework Class Library
ChartView..::.AxisX Property
ChartView Class See Also
Gets or sets X axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Axis AxisX { get; set; }
Visual Basic (Declaration)
Public Property AxisX As Axis

See Also

ChartView Class
C1.Silverlight.Chart Namespace


AxisY Property

[image]

.NET Framework Class Library
ChartView..::.AxisY Property
ChartView Class See Also
Gets or sets Z axis.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Axis AxisY { get; set; }
Visual Basic (Declaration)
Public Property AxisY As Axis

See Also

ChartView Class
C1.Silverlight.Chart Namespace


Children Property

[image]

.NET Framework Class Library
ChartView..::.Children Property
ChartView Class See Also
Gets the list of the additional visuals that are rendered on the plot.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ObservableCollection<UIElement> Children { get; }
Visual Basic (Declaration)
Public ReadOnly Property Children As ObservableCollection(Of UIElement)

See Also

ChartView Class
C1.Silverlight.Chart Namespace


PlotBackground Property

[image]

.NET Framework Class Library
ChartView..::.PlotBackground Property
ChartView Class See Also
Gets or sets the background brush for plot area.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush PlotBackground { get; set; }
Visual Basic (Declaration)
Public Property PlotBackground As Brush

See Also

ChartView Class
C1.Silverlight.Chart Namespace


PlotRect Property

[image]

.NET Framework Class Library
ChartView..::.PlotRect Property
ChartView Class See Also
Gets the plot rectangle (area inside axes).

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Rect PlotRect { get; }
Visual Basic (Declaration)
Public ReadOnly Property PlotRect As Rect

See Also

ChartView Class
C1.Silverlight.Chart Namespace


PlotShape Property

[image]

.NET Framework Class Library
ChartView..::.PlotShape Property
ChartView Class See Also
Gets or sets the shape that should be rendered on the plot background.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Shape PlotShape { get; set; }
Visual Basic (Declaration)
Public Property PlotShape As Shape

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ChartView Events

[image] [image]

.NET Framework Class Library
ChartView Events
ChartView Class See Also

The ChartView type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ChartView Class
C1.Silverlight.Chart Namespace


ColorScheme Enumeration

[image]

.NET Framework Class Library
ColorScheme Enumeration
See Also
Specifies how color scheme is generated.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum ColorScheme
Visual Basic (Declaration)
Public Enumeration ColorScheme

Members

Member name | Description
Auto | Color scheme is generated automatically.
Series | New color scheme is generated for each data series.
Point | New color scheme is generated for each data point.

See Also

C1.Silverlight.Chart Namespace


Converters Class

[image]

.NET Framework Class Library
Converters Class
Members See Also
Contains static instances of built-in converters.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public sealed class Converters
Visual Basic (Declaration)
Public NotInheritable Class Converters

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.Converters

See Also

Converters Members
C1.Silverlight.Chart Namespace


Converters Members

[image] [image]

.NET Framework Class Library
Converters Members
Converters Class Methods Properties See Also

The Converters type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Format | Gets the format converter.

See Also

Converters Class
C1.Silverlight.Chart Namespace


Converters Methods

[image] [image]

.NET Framework Class Library
Converters Methods
Converters Class See Also

The Converters type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Converters Class
C1.Silverlight.Chart Namespace


Converters Properties

[image] [image]

.NET Framework Class Library
Converters Properties
Converters Class See Also

The Converters type exposes the following members.

Properties

Name | Description
Format | Gets the format converter.

See Also

Converters Class
C1.Silverlight.Chart Namespace


Format Property

[image]

.NET Framework Class Library
Converters..::.Format Property
Converters Class See Also
Gets the format converter.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static FormatConverter Format { get; }
Visual Basic (Declaration)
Public Shared ReadOnly Property Format As FormatConverter

See Also

Converters Class
C1.Silverlight.Chart Namespace


DataPoint Class

[image]

.NET Framework Class Library
DataPoint Class
Members See Also
Represent the single data point that may have several data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class DataPoint
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class DataPoint

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.DataPoint

See Also

DataPoint Members
C1.Silverlight.Chart Namespace


DataPoint Members

[image] [image]

.NET Framework Class Library
DataPoint Members
DataPoint Class Methods Properties See Also

The DataPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DataObject | Gets the object which is associated with the data point.
Item | Overloaded.
Name | Gets the name associated with the data point.
PercentagePoint | Gets the percentage value of the point in the all series.
PercentageSeries | Gets the percentage value of the point in the series.
PointIndex | Gets the point index.
Series | Gets the data series related to the data point.
SeriesIndex | Gets index of data series.
Value | Gets the value of the point.

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


DataPoint Methods

[image] [image]

.NET Framework Class Library
DataPoint Methods
DataPoint Class See Also

The DataPoint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


DataPoint Properties

[image] [image]

.NET Framework Class Library
DataPoint Properties
DataPoint Class See Also

The DataPoint type exposes the following members.

Properties

Name | Description
DataObject | Gets the object which is associated with the data point.
Item | Overloaded.
Name | Gets the name associated with the data point.
PercentagePoint | Gets the percentage value of the point in the all series.
PercentageSeries | Gets the percentage value of the point in the series.
PointIndex | Gets the point index.
Series | Gets the data series related to the data point.
SeriesIndex | Gets index of data series.
Value | Gets the value of the point.

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


DataObject Property

[image]

.NET Framework Class Library
DataPoint..::.DataObject Property
DataPoint Class See Also
Gets the object which is associated with the data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object DataObject { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataObject As Object

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataPoint..::.Item Property
DataPoint Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets the indexed value of the point.
Item[([(String])]) | Gets the value of the data point.
Item[([(String, String])]) | Gets the value of the data point formatted with the specified format string.

See Also

DataPoint Class
DataPoint Members
C1.Silverlight.Chart Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
DataPoint..::.Item Property (Int32)
DataPoint Class See Also
Gets the indexed value of the point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32
Index of value.

Return Value

The indexed value.

See Also

DataPoint Class
Item Overload
C1.Silverlight.Chart Namespace


Item Property (String)

[image]

.NET Framework Class Library
DataPoint..::.Item Property (String)
DataPoint Class See Also
Gets the value of the data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Object

Parameters

name
Type: System..::.String
String name of value.

Return Value

The value

See Also

DataPoint Class
Item Overload
C1.Silverlight.Chart Namespace


Item Property (String, String)

[image]

.NET Framework Class Library
DataPoint..::.Item Property (String, String)
DataPoint Class See Also
Gets the value of the data point formatted with the specified format string.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object this[
    string name,
    string format
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String, _
    format As String _
) As Object

Parameters

name
Type: System..::.String
format
Type: System..::.String

Return Value

See Also

DataPoint Class
Item Overload
C1.Silverlight.Chart Namespace


Name Property

[image]

.NET Framework Class Library
DataPoint..::.Name Property
DataPoint Class See Also
Gets the name associated with the data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Name { get; internal set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


PercentagePoint Property

[image]

.NET Framework Class Library
DataPoint..::.PercentagePoint Property
DataPoint Class See Also
Gets the percentage value of the point in the all series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double PercentagePoint { get; }
Visual Basic (Declaration)
Public ReadOnly Property PercentagePoint As Double

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


PercentageSeries Property

[image]

.NET Framework Class Library
DataPoint..::.PercentageSeries Property
DataPoint Class See Also
Gets the percentage value of the point in the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double PercentageSeries { get; }
Visual Basic (Declaration)
Public ReadOnly Property PercentageSeries As Double

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


PointIndex Property

[image]

.NET Framework Class Library
DataPoint..::.PointIndex Property
DataPoint Class See Also
Gets the point index.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public int PointIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointIndex As Integer

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


Series Property

[image]

.NET Framework Class Library
DataPoint..::.Series Property
DataPoint Class See Also
Gets the data series related to the data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataSeries Series { get; }
Visual Basic (Declaration)
Public ReadOnly Property Series As DataSeries

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


SeriesIndex Property

[image]

.NET Framework Class Library
DataPoint..::.SeriesIndex Property
DataPoint Class See Also
Gets index of data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public int SeriesIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property SeriesIndex As Integer

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


Value Property

[image]

.NET Framework Class Library
DataPoint..::.Value Property
DataPoint Class See Also
Gets the value of the point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Value { get; }
Visual Basic (Declaration)
Public ReadOnly Property Value As Double

See Also

DataPoint Class
C1.Silverlight.Chart Namespace


DataPointConverter Class

[image]

.NET Framework Class Library
DataPointConverter Class
Members See Also
Performs conversion from DataPoint to string based on the specified format string.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class DataPointConverter : IValueConverter
Visual Basic (Declaration)
Public Class DataPointConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.DataPointConverter

See Also

DataPointConverter Members
C1.Silverlight.Chart Namespace


DataPointConverter Members

[image] [image]

.NET Framework Class Library
DataPointConverter Members
DataPointConverter Class Constructors Methods See Also

The DataPointConverter type exposes the following members.

Constructors

Name | Description
DataPointConverter |

Methods

Name | Description
Convert | Converts a value when the value is transferred from binding source to target.
ConvertBack | Converts a value when the value is transferred from target to binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPointConverter Class
C1.Silverlight.Chart Namespace


DataPointConverter Constructor

[image]

.NET Framework Class Library
DataPointConverter Constructor
DataPointConverter Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataPointConverter()
Visual Basic (Declaration)
Public Sub New

See Also

DataPointConverter Class
C1.Silverlight.Chart Namespace


DataPointConverter Methods

[image] [image]

.NET Framework Class Library
DataPointConverter Methods
DataPointConverter Class See Also

The DataPointConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value when the value is transferred from binding source to target.
ConvertBack | Converts a value when the value is transferred from target to binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataPointConverter Class
C1.Silverlight.Chart Namespace


Convert Method

[image]

.NET Framework Class Library
DataPointConverter..::.Convert Method
DataPointConverter Class See Also
Converts a value when the value is transferred from binding source to target.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

DataPointConverter Class
C1.Silverlight.Chart Namespace


ConvertBack Method

[image]

.NET Framework Class Library
DataPointConverter..::.ConvertBack Method
DataPointConverter Class See Also
Converts a value when the value is transferred from target to binding source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

DataPointConverter Class
C1.Silverlight.Chart Namespace


DataSeries Class

[image]

.NET Framework Class Library
DataSeries Class
Members See Also
Represents data series which contains a group of data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class DataSeries : DependencyObject, INotifyPropertyChanged,
    IDataSeriesInfo
Visual Basic (Declaration)
Public Class DataSeries _
    Inherits DependencyObject _
    Implements INotifyPropertyChanged, IDataSeriesInfo

Remarks

The DataSeries class has the single set of data values.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.DataSeries
C1.Silverlight.Chart..::.XYDataSeries

See Also

DataSeries Members
C1.Silverlight.Chart Namespace


DataSeries Members

[image] [image]

.NET Framework Class Library
DataSeries Members
DataSeries Class Constructors Methods Fields Properties Events See Also

The DataSeries type exposes the following members.

Constructors

Name | Description
DataSeries | Initializes a new instance of DataSeries class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChangeValues | Handles change values notification.
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Overrides Object..::.ToString()()().)

Fields

Name | Description
_isDefCon | Whether the connection template is default.
_isDefSym | Whether the symbol template is default.
_listY | Temporary list of y-values.
_values | Cached data values.
ConnectionFillProperty | Identifies the ConnectionFill dependency property.
ConnectionProperty | Identifies the Connection dependency property.
ConnectionStrokeDashesProperty | Identifies the ConnectionStrokeDashes dependency property.
ConnectionStrokeProperty | Identifies the ConnectionStroke dependency property.
ConnectionStrokeThicknessProperty | Identifies the ConnectionStrokeThickness dependency property.
ConnectionStyleProperty | Identifies the ConnectionStyle dependency property.
DisplayProperty | Identifies the Display dependency property.
LabelProperty | Identifies the Label dependency property.
OpacityProperty | Identifies the Display dependency property.
PointLabelTemplateProperty | Identifies the PointLabelTemplate dependency property.
PointTooltipTemplateProperty | Identifies the PointTooltipTemplate dependency property.
SymbolFillProperty | Identifies the SymbolFill dependency property.
SymbolMarkerProperty | Identifies the SymbolMarker dependency property.
SymbolProperty | Identifies the Symbol dependency property.
SymbolSizeProperty | Identifies the SymbolSize dependency property.
SymbolStrokeDashesProperty | Identifies the SymbolStrokeDashes dependency property.
SymbolStrokeProperty | Identifies the SymbolStroke dependency property.
SymbolStrokeThicknessProperty | Identifies the SymbolStrokeThickness dependency property.
SymbolStyleProperty | Identifies the SymbolStyle dependency property.
ValuesSourceProperty | Identifies the ValueSource dependency property.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series.
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series.
Connection | Gets or sets the connection template which applies to whole set of data points of series.
ConnectionFill | Gets or sets the connection fill brush.
ConnectionStroke | Gets or sets the connection outline brush.
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke.
ConnectionStrokeThickness | Gets or sets the connection outline thickness.
ConnectionStyle | Gets or sets the style of connection.
Dirty | Gets or sets whether the data values array should be regenerated.
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker.
Label | Gets or sets the text label of data series.
MemberPaths | Gets the array of member bindings for the series.
Opacity | Gets or sets the symbol marker.
PointLabelTemplate | Gets or sets the template for data point label.
PointTooltipTemplate | Gets or sets the template for data point tooltip.
Symbol | Gets or sets the symbol template which applies to the each data point of the series.
SymbolFill | Gets or sets the symbol fill brush.
SymbolMarker | Gets or sets the symbol marker.
SymbolSize | Gets or sets the symbol size in pixels.
SymbolStroke | Gets or sets the symbol outline brush.
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke.
SymbolStrokeThickness | Gets or sets the symbol outline thickness.
SymbolStyle | Gets or sets the style of symbol.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element.
ValueBinding | Gets or sets the value binding.
Values | Gets the data values collection.
ValuesSource | Gets or sets the data values source.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded.
PropertyChanged | Fires when a property value was changed.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeries Constructor

[image]

.NET Framework Class Library
DataSeries Constructor
DataSeries Class See Also
Initializes a new instance of DataSeries class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataSeries()
Visual Basic (Declaration)
Public Sub New

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeries Fields

[image] [image]

.NET Framework Class Library
DataSeries Fields
DataSeries Class See Also

The DataSeries type exposes the following members.

Fields

Name | Description
_isDefCon | Whether the connection template is default.
_isDefSym | Whether the symbol template is default.
_listY | Temporary list of y-values.
_values | Cached data values.
ConnectionFillProperty | Identifies the ConnectionFill dependency property.
ConnectionProperty | Identifies the Connection dependency property.
ConnectionStrokeDashesProperty | Identifies the ConnectionStrokeDashes dependency property.
ConnectionStrokeProperty | Identifies the ConnectionStroke dependency property.
ConnectionStrokeThicknessProperty | Identifies the ConnectionStrokeThickness dependency property.
ConnectionStyleProperty | Identifies the ConnectionStyle dependency property.
DisplayProperty | Identifies the Display dependency property.
LabelProperty | Identifies the Label dependency property.
OpacityProperty | Identifies the Display dependency property.
PointLabelTemplateProperty | Identifies the PointLabelTemplate dependency property.
PointTooltipTemplateProperty | Identifies the PointTooltipTemplate dependency property.
SymbolFillProperty | Identifies the SymbolFill dependency property.
SymbolMarkerProperty | Identifies the SymbolMarker dependency property.
SymbolProperty | Identifies the Symbol dependency property.
SymbolSizeProperty | Identifies the SymbolSize dependency property.
SymbolStrokeDashesProperty | Identifies the SymbolStrokeDashes dependency property.
SymbolStrokeProperty | Identifies the SymbolStroke dependency property.
SymbolStrokeThicknessProperty | Identifies the SymbolStrokeThickness dependency property.
SymbolStyleProperty | Identifies the SymbolStyle dependency property.
ValuesSourceProperty | Identifies the ValueSource dependency property.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


_isDefCon Field

[image]

.NET Framework Class Library
DataSeries..::._isDefCon Field
DataSeries Class See Also
Whether the connection template is default.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected bool _isDefCon
Visual Basic (Declaration)
Protected _isDefCon As Boolean

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


_isDefSym Field

[image]

.NET Framework Class Library
DataSeries..::._isDefSym Field
DataSeries Class See Also
Whether the symbol template is default.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected bool _isDefSym
Visual Basic (Declaration)
Protected _isDefSym As Boolean

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


_listY Field

[image]

.NET Framework Class Library
DataSeries..::._listY Field
DataSeries Class See Also
Temporary list of y-values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _listY
Visual Basic (Declaration)
Protected _listY As List(Of Object)

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


_values Field

[image]

.NET Framework Class Library
DataSeries..::._values Field
DataSeries Class See Also
Cached data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected double[,] _values
Visual Basic (Declaration)
Protected _values As Double(,)

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionFillProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionFillProperty Field
DataSeries Class See Also
Identifies the ConnectionFill dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionFillProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionFillProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionProperty Field
DataSeries Class See Also
Identifies the Connection dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStrokeDashesProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStrokeDashesProperty Field
DataSeries Class See Also
Identifies the ConnectionStrokeDashes dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionStrokeDashesProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionStrokeDashesProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStrokeProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStrokeProperty Field
DataSeries Class See Also
Identifies the ConnectionStroke dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionStrokeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionStrokeProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStrokeThicknessProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStrokeThicknessProperty Field
DataSeries Class See Also
Identifies the ConnectionStrokeThickness dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionStrokeThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionStrokeThicknessProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStyleProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStyleProperty Field
DataSeries Class See Also
Identifies the ConnectionStyle dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ConnectionStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ConnectionStyleProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DisplayProperty Field

[image]

.NET Framework Class Library
DataSeries..::.DisplayProperty Field
DataSeries Class See Also
Identifies the Display dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty DisplayProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisplayProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


LabelProperty Field

[image]

.NET Framework Class Library
DataSeries..::.LabelProperty Field
DataSeries Class See Also
Identifies the Label dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty LabelProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


OpacityProperty Field

[image]

.NET Framework Class Library
DataSeries..::.OpacityProperty Field
DataSeries Class See Also
Identifies the Display dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty OpacityProperty
Visual Basic (Declaration)
Public Shared ReadOnly OpacityProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


PointLabelTemplateProperty Field

[image]

.NET Framework Class Library
DataSeries..::.PointLabelTemplateProperty Field
DataSeries Class See Also
Identifies the PointLabelTemplate dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty PointLabelTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointLabelTemplateProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


PointTooltipTemplateProperty Field

[image]

.NET Framework Class Library
DataSeries..::.PointTooltipTemplateProperty Field
DataSeries Class See Also
Identifies the PointTooltipTemplate dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty PointTooltipTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointTooltipTemplateProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolFillProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolFillProperty Field
DataSeries Class See Also
Identifies the SymbolFill dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolFillProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolFillProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolMarkerProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolMarkerProperty Field
DataSeries Class See Also
Identifies the SymbolMarker dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolMarkerProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolMarkerProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolProperty Field
DataSeries Class See Also
Identifies the Symbol dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolSizeProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolSizeProperty Field
DataSeries Class See Also
Identifies the SymbolSize dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolSizeProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStrokeDashesProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolStrokeDashesProperty Field
DataSeries Class See Also
Identifies the SymbolStrokeDashes dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolStrokeDashesProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolStrokeDashesProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStrokeProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolStrokeProperty Field
DataSeries Class See Also
Identifies the SymbolStroke dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolStrokeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolStrokeProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStrokeThicknessProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolStrokeThicknessProperty Field
DataSeries Class See Also
Identifies the SymbolStrokeThickness dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolStrokeThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolStrokeThicknessProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStyleProperty Field

[image]

.NET Framework Class Library
DataSeries..::.SymbolStyleProperty Field
DataSeries Class See Also
Identifies the SymbolStyle dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty SymbolStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly SymbolStyleProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ValuesSourceProperty Field

[image]

.NET Framework Class Library
DataSeries..::.ValuesSourceProperty Field
DataSeries Class See Also
Identifies the ValueSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty ValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValuesSourceProperty As DependencyProperty

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeries Methods

[image] [image]

.NET Framework Class Library
DataSeries Methods
DataSeries Class See Also

The DataSeries type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnChangeValues | Handles change values notification.
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Overrides Object..::.ToString()()().)

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


GetDataValue Method

[image]

.NET Framework Class Library
DataSeries..::.GetDataValue Method
DataSeries Class See Also
Get data value with specified name at the specified index.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double GetDataValue(
    string name,
    int pointIndex
)
Visual Basic (Declaration)
Public Function GetDataValue ( _
    name As String, _
    pointIndex As Integer _
) As Double

Parameters

name
Type: System..::.String
Name of data array.
pointIndex
Type: System..::.Int32
Index of the value.

Return Value

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


OnChangeValues Method

[image]

.NET Framework Class Library
DataSeries..::.OnChangeValues Method
DataSeries Class See Also
Handles change values notification.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected static void OnChangeValues(
    DependencyObject obj,
    DependencyPropertyChangedEventArgs args
)
Visual Basic (Declaration)
Protected Shared Sub OnChangeValues ( _
    obj As DependencyObject, _
    args As DependencyPropertyChangedEventArgs _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
args
Type: System.Windows..::.DependencyPropertyChangedEventArgs

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ToString Method

[image]

.NET Framework Class Library
DataSeries..::.ToString Method
DataSeries Class See Also
Returns string representation of the data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeries Properties

[image] [image]

.NET Framework Class Library
DataSeries Properties
DataSeries Class See Also

The DataSeries type exposes the following members.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series.
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series.
Connection | Gets or sets the connection template which applies to whole set of data points of series.
ConnectionFill | Gets or sets the connection fill brush.
ConnectionStroke | Gets or sets the connection outline brush.
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke.
ConnectionStrokeThickness | Gets or sets the connection outline thickness.
ConnectionStyle | Gets or sets the style of connection.
Dirty | Gets or sets whether the data values array should be regenerated.
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker.
Label | Gets or sets the text label of data series.
MemberPaths | Gets the array of member bindings for the series.
Opacity | Gets or sets the symbol marker.
PointLabelTemplate | Gets or sets the template for data point label.
PointTooltipTemplate | Gets or sets the template for data point tooltip.
Symbol | Gets or sets the symbol template which applies to the each data point of the series.
SymbolFill | Gets or sets the symbol fill brush.
SymbolMarker | Gets or sets the symbol marker.
SymbolSize | Gets or sets the symbol size in pixels.
SymbolStroke | Gets or sets the symbol outline brush.
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke.
SymbolStrokeThickness | Gets or sets the symbol outline thickness.
SymbolStyle | Gets or sets the style of symbol.
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element.
ValueBinding | Gets or sets the value binding.
Values | Gets the data values collection.
ValuesSource | Gets or sets the data values source.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


AxisX Property

[image]

.NET Framework Class Library
DataSeries..::.AxisX Property
DataSeries Class See Also
Gets or sets the name of auxiliary axis that is used as x-axis for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string AxisX { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute("")> _
Public Property AxisX As String

Remarks

If AxisX is an empty string the default x-axis is used for this series.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


AxisY Property

[image]

.NET Framework Class Library
DataSeries..::.AxisY Property
DataSeries Class See Also
Gets or sets the name of auxiliary axis that is used as y-axis for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute("")]
public string AxisY { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute("")> _
Public Property AxisY As String

Remarks

If AxisY is an empty string the default y-axis is used for this series.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Connection Property

[image]

.NET Framework Class Library
DataSeries..::.Connection Property
DataSeries Class See Also
Gets or sets the connection template which applies to whole set of data points of series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Connection { get; set; }
Visual Basic (Declaration)
Public Property Connection As Object

Implements

IDataSeriesInfo..::.Connection

Remarks

The connection template is used for visualizing the data series as a single visual such as line connecting the data points.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionFill Property

[image]

.NET Framework Class Library
DataSeries..::.ConnectionFill Property
DataSeries Class See Also
Gets or sets the connection fill brush.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush ConnectionFill { get; set; }
Visual Basic (Declaration)
Public Property ConnectionFill As Brush

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStroke Property

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStroke Property
DataSeries Class See Also
Gets or sets the connection outline brush.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush ConnectionStroke { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStroke As Brush

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStrokeDashes Property

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStrokeDashes Property
DataSeries Class See Also
Gets or sets the dash pattern of connection stroke.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection ConnectionStrokeDashes { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStrokeDashes As DoubleCollection

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStrokeThickness Property

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStrokeThickness Property
DataSeries Class See Also
Gets or sets the connection outline thickness.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double ConnectionStrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStrokeThickness As Double

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ConnectionStyle Property

[image]

.NET Framework Class Library
DataSeries..::.ConnectionStyle Property
DataSeries Class See Also
Gets or sets the style of connection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Style ConnectionStyle { get; set; }
Visual Basic (Declaration)
Public Property ConnectionStyle As Style

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Dirty Property

[image]

.NET Framework Class Library
DataSeries..::.Dirty Property
DataSeries Class See Also
Gets or sets whether the data values array should be regenerated.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected internal bool Dirty { get; set; }
Visual Basic (Declaration)
Protected Friend Property Dirty As Boolean

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Display Property

[image]

.NET Framework Class Library
DataSeries..::.Display Property
DataSeries Class See Also
Gets or sets the symbol marker.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public SeriesDisplay Display { get; set; }
Visual Basic (Declaration)
Public Property Display As SeriesDisplay

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Label Property

[image]

.NET Framework Class Library
DataSeries..::.Label Property
DataSeries Class See Also
Gets or sets the text label of data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Label { get; set; }
Visual Basic (Declaration)
Public Property Label As String

Implements

IDataSeriesInfo..::.Label

Remarks

Usually the Label property is used to identify the data series in the chart legend.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
DataSeries..::.MemberPaths Property
DataSeries Class See Also
Gets the array of member bindings for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public virtual Binding[] MemberPaths { get; }
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Overridable ReadOnly Property MemberPaths As Binding()

Implements

IDataSeriesInfo..::.MemberPaths

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Opacity Property

[image]

.NET Framework Class Library
DataSeries..::.Opacity Property
DataSeries Class See Also
Gets or sets the symbol marker.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Opacity { get; set; }
Visual Basic (Declaration)
Public Property Opacity As Double

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


PointLabelTemplate Property

[image]

.NET Framework Class Library
DataSeries..::.PointLabelTemplate Property
DataSeries Class See Also
Gets or sets the template for data point label.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataTemplate PointLabelTemplate { get; set; }
Visual Basic (Declaration)
Public Property PointLabelTemplate As DataTemplate

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


PointTooltipTemplate Property

[image]

.NET Framework Class Library
DataSeries..::.PointTooltipTemplate Property
DataSeries Class See Also
Gets or sets the template for data point tooltip.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataTemplate PointTooltipTemplate { get; set; }
Visual Basic (Declaration)
Public Property PointTooltipTemplate As DataTemplate

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Symbol Property

[image]

.NET Framework Class Library
DataSeries..::.Symbol Property
DataSeries Class See Also
Gets or sets the symbol template which applies to the each data point of the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As Object

Implements

IDataSeriesInfo..::.Symbol

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolFill Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolFill Property
DataSeries Class See Also
Gets or sets the symbol fill brush.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Brush SymbolFill { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute(Nothing)> _
Public Property SymbolFill As Brush

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolMarker Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolMarker Property
DataSeries Class See Also
Gets or sets the symbol marker.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Marker SymbolMarker { get; set; }
Visual Basic (Declaration)
Public Property SymbolMarker As Marker

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolSize Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolSize Property
DataSeries Class See Also
Gets or sets the symbol size in pixels.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Size SymbolSize { get; set; }
Visual Basic (Declaration)
Public Property SymbolSize As Size

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStroke Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolStroke Property
DataSeries Class See Also
Gets or sets the symbol outline brush.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush SymbolStroke { get; set; }
Visual Basic (Declaration)
Public Property SymbolStroke As Brush

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStrokeDashes Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolStrokeDashes Property
DataSeries Class See Also
Gets or sets the dash pattern of symbol stroke.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection SymbolStrokeDashes { get; set; }
Visual Basic (Declaration)
Public Property SymbolStrokeDashes As DoubleCollection

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStrokeThickness Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolStrokeThickness Property
DataSeries Class See Also
Gets or sets the symbol outline thickness.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double SymbolStrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property SymbolStrokeThickness As Double

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


SymbolStyle Property

[image]

.NET Framework Class Library
DataSeries..::.SymbolStyle Property
DataSeries Class See Also
Gets or sets the style of symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Style SymbolStyle { get; set; }
Visual Basic (Declaration)
Public Property SymbolStyle As Style

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Tag Property

[image]

.NET Framework Class Library
DataSeries..::.Tag Property
DataSeries Class See Also
Gets or sets an arbitrary object value that can be used to store custom information about this element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As Object

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ValueBinding Property

[image]

.NET Framework Class Library
DataSeries..::.ValueBinding Property
DataSeries Class See Also
Gets or sets the value binding.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[DefaultValueAttribute(null)]
public Binding ValueBinding { get; set; }
Visual Basic (Declaration)
<DefaultValueAttribute(Nothing)> _
Public Property ValueBinding As Binding

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Values Property

[image]

.NET Framework Class Library
DataSeries..::.Values Property
DataSeries Class See Also
Gets the data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection Values { get; set; }
Visual Basic (Declaration)
Public Property Values As DoubleCollection

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


ValuesSource Property

[image]

.NET Framework Class Library
DataSeries..::.ValuesSource Property
DataSeries Class See Also
Gets or sets the data values source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable ValuesSource { get; set; }
Visual Basic (Declaration)
Public Property ValuesSource As IEnumerable

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeries Events

[image] [image]

.NET Framework Class Library
DataSeries Events
DataSeries Class See Also

The DataSeries type exposes the following members.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded.
PropertyChanged | Fires when a property value was changed.

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


Loaded Event

[image]

.NET Framework Class Library
DataSeries..::.Loaded Event
DataSeries Class See Also
Fires when plot element associated with this data series is loaded.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event EventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As EventHandler

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DataSeries..::.PropertyChanged Event
DataSeries Class See Also
Fires when a property value was changed.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


DataSeriesCollection Class

[image]

.NET Framework Class Library
DataSeriesCollection Class
Members See Also
Represents collection of data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class DataSeriesCollection : ObservableCollection<DataSeries>
Visual Basic (Declaration)
Public Class DataSeriesCollection _
    Inherits ObservableCollection(Of DataSeries)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataSeries >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( DataSeries >)>)
C1.Silverlight.Chart..::.DataSeriesCollection

See Also

DataSeriesCollection Members
C1.Silverlight.Chart Namespace


DataSeriesCollection Members

[image] [image]

.NET Framework Class Library
DataSeriesCollection Members
DataSeriesCollection Class Constructors Methods Properties Events See Also

The DataSeriesCollection type exposes the following members.

Constructors

Name | Description
DataSeriesCollection | Initializes a new instance of DataSeriesCollection class.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
ClearItems | Removes all items from the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataSeries >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataSeries >)>).)
InsertItem | Inserts an element into the Collection at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
RemoveItem | Removes the element at the specified index of the Collection. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the element at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataSeries >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


DataSeriesCollection Constructor

[image]

.NET Framework Class Library
DataSeriesCollection Constructor
DataSeriesCollection Class See Also
Initializes a new instance of DataSeriesCollection class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataSeriesCollection()
Visual Basic (Declaration)
Public Sub New

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


DataSeriesCollection Methods

[image] [image]

.NET Framework Class Library
DataSeriesCollection Methods
DataSeriesCollection Class See Also

The DataSeriesCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
ClearItems | Removes all items from the collection. (Overrides ObservableCollection<(Of <(T>)>)..::.ClearItems()()().)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataSeries >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataSeries >)>).)
InsertItem | Inserts an element into the Collection at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
RemoveItem | Removes the element at the specified index of the Collection. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | Replaces the element at the specified index. (Overrides ObservableCollection<(Of <(T>)>)..::.SetItem(Int32, T).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


ClearItems Method

[image]

.NET Framework Class Library
DataSeriesCollection..::.ClearItems Method
DataSeriesCollection Class See Also
Removes all items from the collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void ClearItems()
Visual Basic (Declaration)
Protected Overrides Sub ClearItems

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


InsertItem Method

[image]

.NET Framework Class Library
DataSeriesCollection..::.InsertItem Method
DataSeriesCollection Class See Also
Inserts an element into the Collection at the specified index.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    DataSeries item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As DataSeries _
)

Parameters

index
Type: System..::.Int32
The index at which element should be inserted.
item
Type: C1.Silverlight.Chart..::.DataSeries
The element to insert.

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


RemoveItem Method

[image]

.NET Framework Class Library
DataSeriesCollection..::.RemoveItem Method
DataSeriesCollection Class See Also
Removes the element at the specified index of the Collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
The index of element to remove.

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


SetItem Method

[image]

.NET Framework Class Library
DataSeriesCollection..::.SetItem Method
DataSeriesCollection Class See Also
Replaces the element at the specified index.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void SetItem(
    int index,
    DataSeries item
)
Visual Basic (Declaration)
Protected Overrides Sub SetItem ( _
    index As Integer, _
    item As DataSeries _
)

Parameters

index
Type: System..::.Int32
The index of element to replace.
item
Type: C1.Silverlight.Chart..::.DataSeries
The new element at the specified index.

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


DataSeriesCollection Properties

[image] [image]

.NET Framework Class Library
DataSeriesCollection Properties
DataSeriesCollection Class See Also

The DataSeriesCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataSeries >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataSeries >)>).)

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


DataSeriesCollection Events

[image] [image]

.NET Framework Class Library
DataSeriesCollection Events
DataSeriesCollection Class See Also

The DataSeriesCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataSeries >)>).)

See Also

DataSeriesCollection Class
C1.Silverlight.Chart Namespace


DotSymbol Class

[image]

.NET Framework Class Library
DotSymbol Class
Members See Also
Represents a dot symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class DotSymbol : PlotElement
Visual Basic (Declaration)
Public Class DotSymbol _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.DotSymbol

See Also

DotSymbol Members
C1.Silverlight.Chart Namespace


DotSymbol Members

[image] [image]

.NET Framework Class Library
DotSymbol Members
DotSymbol Class Constructors Methods Fields Properties Events See Also

The DotSymbol type exposes the following members.

Constructors

Name | Description
DotSymbol | Initializes a new instance of the DotSymbol class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Inherited from PlotElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


DotSymbol Constructor

[image]

.NET Framework Class Library
DotSymbol Constructor
DotSymbol Class See Also
Initializes a new instance of the DotSymbol class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DotSymbol()
Visual Basic (Declaration)
Public Sub New

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


DotSymbol Fields

[image] [image]

.NET Framework Class Library
DotSymbol Fields
DotSymbol Class See Also

The DotSymbol type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


DotSymbol Methods

[image] [image]

.NET Framework Class Library
DotSymbol Methods
DotSymbol Class See Also

The DotSymbol type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context. (Inherited from PlotElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DotSymbol..::.HitTest Method
DotSymbol Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DotSymbol Class
DotSymbol Members
C1.Silverlight.Chart Namespace


DotSymbol Properties

[image] [image]

.NET Framework Class Library
DotSymbol Properties
DotSymbol Class See Also

The DotSymbol type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
DotSymbol..::.LegendShape Property
DotSymbol Class See Also
Gets the legend shape for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


DotSymbol Events

[image] [image]

.NET Framework Class Library
DotSymbol Events
DotSymbol Class See Also

The DotSymbol type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DotSymbol Class
C1.Silverlight.Chart Namespace


Extensions Class

[image]

.NET Framework Class Library
Extensions Class
Members See Also
Class that provides static extension methods for several other classes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static class Extensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class Extensions

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.Extensions

See Also

Extensions Members
C1.Silverlight.Chart Namespace


Extensions Members

[image] [image]

.NET Framework Class Library
Extensions Members
Extensions Class Methods See Also

Methods

Name | Description
ToCollection | Overloaded.

See Also

Extensions Class
C1.Silverlight.Chart Namespace


Extensions Methods

[image] [image]

.NET Framework Class Library
Extensions Methods
Extensions Class See Also

Methods

Name | Description
ToCollection | Overloaded.

See Also

Extensions Class
C1.Silverlight.Chart Namespace


ToCollection Method

[image] [image]

.NET Framework Class Library
Extensions..::.ToCollection Method
Extensions Class See Also

Overload List

Name | Description
ToCollection(array<Double>[]()[]) | Converts the array of doubles into a DoubleCollection
ToCollection(array<Point>[]()[]) | Converts the array of Points into a PointCollection

See Also

Extensions Class
Extensions Members
C1.Silverlight.Chart Namespace


ToCollection Method (Double[])

[image]

.NET Framework Class Library
Extensions..::.ToCollection Method (array<Double>[]()[])
Extensions Class See Also
Converts the array of doubles into a DoubleCollection

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static DoubleCollection ToCollection(
    this double[] thisPointArray
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ToCollection ( _
    thisPointArray As Double() _
) As DoubleCollection

Parameters

thisPointArray
Type: array< System..::.Double >[]()[]

Return Value

See Also

Extensions Class
ToCollection Overload
C1.Silverlight.Chart Namespace


ToCollection Method (Point[])

[image]

.NET Framework Class Library
Extensions..::.ToCollection Method (array<Point>[]()[])
Extensions Class See Also
Converts the array of Points into a PointCollection

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static PointCollection ToCollection(
    this Point[] thisPointArray
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function ToCollection ( _
    thisPointArray As Point() _
) As PointCollection

Parameters

thisPointArray
Type: array< System.Windows..::.Point >[]()[]

Return Value

See Also

Extensions Class
ToCollection Overload
C1.Silverlight.Chart Namespace


FormatConverter Class

[image]

.NET Framework Class Library
FormatConverter Class
Members See Also
Performs conversion to string based on the specified format string.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class FormatConverter : IValueConverter
Visual Basic (Declaration)
Public Class FormatConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.FormatConverter

See Also

FormatConverter Members
C1.Silverlight.Chart Namespace


FormatConverter Members

[image] [image]

.NET Framework Class Library
FormatConverter Members
FormatConverter Class Constructors Methods See Also

The FormatConverter type exposes the following members.

Constructors

Name | Description
FormatConverter |

Methods

Name | Description
Convert | Converts a value when the value is transferred from binding source to target.
ConvertBack | Converts a value when the value is transferred from target to binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatConverter Class
C1.Silverlight.Chart Namespace


FormatConverter Constructor

[image]

.NET Framework Class Library
FormatConverter Constructor
FormatConverter Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public FormatConverter()
Visual Basic (Declaration)
Public Sub New

See Also

FormatConverter Class
C1.Silverlight.Chart Namespace


FormatConverter Methods

[image] [image]

.NET Framework Class Library
FormatConverter Methods
FormatConverter Class See Also

The FormatConverter type exposes the following members.

Methods

Name | Description
Convert | Converts a value when the value is transferred from binding source to target.
ConvertBack | Converts a value when the value is transferred from target to binding source.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FormatConverter Class
C1.Silverlight.Chart Namespace


Convert Method

[image]

.NET Framework Class Library
FormatConverter..::.Convert Method
FormatConverter Class See Also
Converts a value when the value is transferred from binding source to target.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

FormatConverter Class
C1.Silverlight.Chart Namespace


ConvertBack Method

[image]

.NET Framework Class Library
FormatConverter..::.ConvertBack Method
FormatConverter Class See Also
Converts a value when the value is transferred from target to binding source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Return Value

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

FormatConverter Class
C1.Silverlight.Chart Namespace


GradientMethod Enumeration

[image]

.NET Framework Class Library
GradientMethod Enumeration
See Also
Specifies how to handle gradient brushes in themes and custom palettes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum GradientMethod
Visual Basic (Declaration)
Public Enumeration GradientMethod

Members

Member name | Description
Auto | Automatic, chart converts linear brushes to radial if it is appropriate for the current chart type.
None | There is no any conversion for gradient brushes.
Linear | Chart always uses linear gradient.
Radial | Chart always uses radial gradient.

See Also

C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Class

[image]

.NET Framework Class Library
HighLowOpenCloseSeries Class
Members See Also
Represents data series with x, y, high, low, open, close data arrays.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class HighLowOpenCloseSeries : HighLowSeries
Visual Basic (Declaration)
Public Class HighLowOpenCloseSeries _
    Inherits HighLowSeries

Remarks

HighLowOpenCloseSeries class is typically used for financial data. It has six sets of data value (x-coordinates, y-coordinates, high values, low values, open values, close values).

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.DataSeries
C1.Silverlight.Chart..::.XYDataSeries
C1.Silverlight.Chart..::.HighLowSeries
C1.Silverlight.Chart..::.HighLowOpenCloseSeries

See Also

HighLowOpenCloseSeries Members
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Members

[image] [image]

.NET Framework Class Library
HighLowOpenCloseSeries Members
HighLowOpenCloseSeries Class Constructors Methods Fields Properties Events See Also

The HighLowOpenCloseSeries type exposes the following members.

Constructors

Name | Description
HighLowOpenCloseSeries | Initializes an instance of the HighLowOpenCloseSeries class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

Fields

Name | Description
_alCl | Temporary list for close data values.
_alHi | Temporary list for high data values. (Inherited from HighLowSeries.)
_alLo | Temporary list for low data values. (Inherited from HighLowSeries.)
_alOp | Temporary list for open data values.
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
CloseValuesSourceProperty | Identifies the CloseValuesSource dependency property.
OpenValuesSourceProperty | Identifies the OpenValuesSource dependency property.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
CloseValueBinding | Gets or sets binding for close data values.
CloseValues | Gets or set the close data values collection.
CloseValuesSource | Gets or sets the source for close data values.
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
HighValueBinding | Gets or sets binding for high data values. (Inherited from HighLowSeries.)
HighValues | Gets or set the high data values collection. (Inherited from HighLowSeries.)
HighValuesSource | Gets or sets the source for high data values. (Inherited from HighLowSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
LowValueBinding | Gets or sets binding for low data values. (Inherited from HighLowSeries.)
LowValues | Gets or set the high data values collection. (Inherited from HighLowSeries.)
LowValuesSource | Gets or sets the source for low data values. (Inherited from HighLowSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides HighLowSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
OpenValueBinding | Gets or sets binding for open data values.
OpenValues | Gets or set the open data values collection.
OpenValuesSource | Gets or sets the source for open data values.
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Constructor

[image]

.NET Framework Class Library
HighLowOpenCloseSeries Constructor
HighLowOpenCloseSeries Class See Also
Initializes an instance of the HighLowOpenCloseSeries class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public HighLowOpenCloseSeries()
Visual Basic (Declaration)
Public Sub New

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Fields

[image] [image]

.NET Framework Class Library
HighLowOpenCloseSeries Fields
HighLowOpenCloseSeries Class See Also

The HighLowOpenCloseSeries type exposes the following members.

Fields

Name | Description
_alCl | Temporary list for close data values.
_alHi | Temporary list for high data values. (Inherited from HighLowSeries.)
_alLo | Temporary list for low data values. (Inherited from HighLowSeries.)
_alOp | Temporary list for open data values.
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
CloseValuesSourceProperty | Identifies the CloseValuesSource dependency property.
OpenValuesSourceProperty | Identifies the OpenValuesSource dependency property.

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


_alCl Field

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::._alCl Field
HighLowOpenCloseSeries Class See Also
Temporary list for close data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _alCl
Visual Basic (Declaration)
Protected _alCl As List(Of Object)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


_alOp Field

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::._alOp Field
HighLowOpenCloseSeries Class See Also
Temporary list for open data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _alOp
Visual Basic (Declaration)
Protected _alOp As List(Of Object)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


CloseValuesSourceProperty Field

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.CloseValuesSourceProperty Field
HighLowOpenCloseSeries Class See Also
Identifies the CloseValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty CloseValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly CloseValuesSourceProperty As DependencyProperty

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


OpenValuesSourceProperty Field

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.OpenValuesSourceProperty Field
HighLowOpenCloseSeries Class See Also
Identifies the OpenValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty OpenValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly OpenValuesSourceProperty As DependencyProperty

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Methods

[image] [image]

.NET Framework Class Library
HighLowOpenCloseSeries Methods
HighLowOpenCloseSeries Class See Also

The HighLowOpenCloseSeries type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Properties

[image] [image]

.NET Framework Class Library
HighLowOpenCloseSeries Properties
HighLowOpenCloseSeries Class See Also

The HighLowOpenCloseSeries type exposes the following members.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
CloseValueBinding | Gets or sets binding for close data values.
CloseValues | Gets or set the close data values collection.
CloseValuesSource | Gets or sets the source for close data values.
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
HighValueBinding | Gets or sets binding for high data values. (Inherited from HighLowSeries.)
HighValues | Gets or set the high data values collection. (Inherited from HighLowSeries.)
HighValuesSource | Gets or sets the source for high data values. (Inherited from HighLowSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
LowValueBinding | Gets or sets binding for low data values. (Inherited from HighLowSeries.)
LowValues | Gets or set the high data values collection. (Inherited from HighLowSeries.)
LowValuesSource | Gets or sets the source for low data values. (Inherited from HighLowSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides HighLowSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
OpenValueBinding | Gets or sets binding for open data values.
OpenValues | Gets or set the open data values collection.
OpenValuesSource | Gets or sets the source for open data values.
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


CloseValueBinding Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.CloseValueBinding Property
HighLowOpenCloseSeries Class See Also
Gets or sets binding for close data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding CloseValueBinding { get; set; }
Visual Basic (Declaration)
Public Property CloseValueBinding As Binding

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


CloseValues Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.CloseValues Property
HighLowOpenCloseSeries Class See Also
Gets or set the close data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection CloseValues { get; set; }
Visual Basic (Declaration)
Public Property CloseValues As DoubleCollection

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


CloseValuesSource Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.CloseValuesSource Property
HighLowOpenCloseSeries Class See Also
Gets or sets the source for close data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable CloseValuesSource { get; set; }
Visual Basic (Declaration)
Public Property CloseValuesSource As IEnumerable

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.MemberPaths Property
HighLowOpenCloseSeries Class See Also
Gets the array of member bindings for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override Binding[] MemberPaths { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberPaths As Binding()

Implements

IDataSeriesInfo..::.MemberPaths

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


OpenValueBinding Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.OpenValueBinding Property
HighLowOpenCloseSeries Class See Also
Gets or sets binding for open data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding OpenValueBinding { get; set; }
Visual Basic (Declaration)
Public Property OpenValueBinding As Binding

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


OpenValues Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.OpenValues Property
HighLowOpenCloseSeries Class See Also
Gets or set the open data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection OpenValues { get; set; }
Visual Basic (Declaration)
Public Property OpenValues As DoubleCollection

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


OpenValuesSource Property

[image]

.NET Framework Class Library
HighLowOpenCloseSeries..::.OpenValuesSource Property
HighLowOpenCloseSeries Class See Also
Gets or sets the source for open data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable OpenValuesSource { get; set; }
Visual Basic (Declaration)
Public Property OpenValuesSource As IEnumerable

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowOpenCloseSeries Events

[image] [image]

.NET Framework Class Library
HighLowOpenCloseSeries Events
HighLowOpenCloseSeries Class See Also

The HighLowOpenCloseSeries type exposes the following members.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

HighLowOpenCloseSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Class

[image]

.NET Framework Class Library
HighLowSeries Class
Members See Also
Represents data series with X, Y, High and Low values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class HighLowSeries : XYDataSeries
Visual Basic (Declaration)
Public Class HighLowSeries _
    Inherits XYDataSeries

Remarks

The HighLowSeries class has four sets of data values (x-coordinates, y-coordinates, high values, low values).

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.DataSeries
C1.Silverlight.Chart..::.XYDataSeries
C1.Silverlight.Chart..::.HighLowSeries
C1.Silverlight.Chart..::.HighLowOpenCloseSeries

See Also

HighLowSeries Members
C1.Silverlight.Chart Namespace


HighLowSeries Members

[image] [image]

.NET Framework Class Library
HighLowSeries Members
HighLowSeries Class Constructors Methods Fields Properties Events See Also

The HighLowSeries type exposes the following members.

Constructors

Name | Description
HighLowSeries | Initialize a new instance of the HighLowSeries class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

Fields

Name | Description
_alHi | Temporary list for high data values.
_alLo | Temporary list for low data values.
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
HighValuesSourceProperty | Identifies the HighValuesSource dependency property.
LowValuesSourceProperty | Identifies the LowValuesSource dependency property.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
HighValueBinding | Gets or sets binding for high data values.
HighValues | Gets or set the high data values collection.
HighValuesSource | Gets or sets the source for high data values.
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
LowValueBinding | Gets or sets binding for low data values.
LowValues | Gets or set the high data values collection.
LowValuesSource | Gets or sets the source for low data values.
MemberPaths | Gets the array of member bindings for the series. (Overrides XYDataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Constructor

[image]

.NET Framework Class Library
HighLowSeries Constructor
HighLowSeries Class See Also
Initialize a new instance of the HighLowSeries class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public HighLowSeries()
Visual Basic (Declaration)
Public Sub New

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Fields

[image] [image]

.NET Framework Class Library
HighLowSeries Fields
HighLowSeries Class See Also

The HighLowSeries type exposes the following members.

Fields

Name | Description
_alHi | Temporary list for high data values.
_alLo | Temporary list for low data values.
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values. (Inherited from XYDataSeries.)
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
HighValuesSourceProperty | Identifies the HighValuesSource dependency property.
LowValuesSourceProperty | Identifies the LowValuesSource dependency property.

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


_alHi Field

[image]

.NET Framework Class Library
HighLowSeries..::._alHi Field
HighLowSeries Class See Also
Temporary list for high data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _alHi
Visual Basic (Declaration)
Protected _alHi As List(Of Object)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


_alLo Field

[image]

.NET Framework Class Library
HighLowSeries..::._alLo Field
HighLowSeries Class See Also
Temporary list for low data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _alLo
Visual Basic (Declaration)
Protected _alLo As List(Of Object)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighValuesSourceProperty Field

[image]

.NET Framework Class Library
HighLowSeries..::.HighValuesSourceProperty Field
HighLowSeries Class See Also
Identifies the HighValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty HighValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly HighValuesSourceProperty As DependencyProperty

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


LowValuesSourceProperty Field

[image]

.NET Framework Class Library
HighLowSeries..::.LowValuesSourceProperty Field
HighLowSeries Class See Also
Identifies the LowValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty LowValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly LowValuesSourceProperty As DependencyProperty

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Methods

[image] [image]

.NET Framework Class Library
HighLowSeries Methods
HighLowSeries Class See Also

The HighLowSeries type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Properties

[image] [image]

.NET Framework Class Library
HighLowSeries Properties
HighLowSeries Class See Also

The HighLowSeries type exposes the following members.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
HighValueBinding | Gets or sets binding for high data values.
HighValues | Gets or set the high data values collection.
HighValuesSource | Gets or sets the source for high data values.
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
LowValueBinding | Gets or sets binding for low data values.
LowValues | Gets or set the high data values collection.
LowValuesSource | Gets or sets the source for low data values.
MemberPaths | Gets the array of member bindings for the series. (Overrides XYDataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values. (Inherited from XYDataSeries.)
XValues | Gets or set the x-data values collection. (Inherited from XYDataSeries.)
XValuesSource | Gets or sets the x-data values source. (Inherited from XYDataSeries.)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighValueBinding Property

[image]

.NET Framework Class Library
HighLowSeries..::.HighValueBinding Property
HighLowSeries Class See Also
Gets or sets binding for high data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding HighValueBinding { get; set; }
Visual Basic (Declaration)
Public Property HighValueBinding As Binding

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighValues Property

[image]

.NET Framework Class Library
HighLowSeries..::.HighValues Property
HighLowSeries Class See Also
Gets or set the high data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection HighValues { get; set; }
Visual Basic (Declaration)
Public Property HighValues As DoubleCollection

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighValuesSource Property

[image]

.NET Framework Class Library
HighLowSeries..::.HighValuesSource Property
HighLowSeries Class See Also
Gets or sets the source for high data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable HighValuesSource { get; set; }
Visual Basic (Declaration)
Public Property HighValuesSource As IEnumerable

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


LowValueBinding Property

[image]

.NET Framework Class Library
HighLowSeries..::.LowValueBinding Property
HighLowSeries Class See Also
Gets or sets binding for low data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding LowValueBinding { get; set; }
Visual Basic (Declaration)
Public Property LowValueBinding As Binding

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


LowValues Property

[image]

.NET Framework Class Library
HighLowSeries..::.LowValues Property
HighLowSeries Class See Also
Gets or set the high data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection LowValues { get; set; }
Visual Basic (Declaration)
Public Property LowValues As DoubleCollection

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


LowValuesSource Property

[image]

.NET Framework Class Library
HighLowSeries..::.LowValuesSource Property
HighLowSeries Class See Also
Gets or sets the source for low data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable LowValuesSource { get; set; }
Visual Basic (Declaration)
Public Property LowValuesSource As IEnumerable

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
HighLowSeries..::.MemberPaths Property
HighLowSeries Class See Also
Gets the array of member bindings for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override Binding[] MemberPaths { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberPaths As Binding()

Implements

IDataSeriesInfo..::.MemberPaths

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HighLowSeries Events

[image] [image]

.NET Framework Class Library
HighLowSeries Events
HighLowSeries Class See Also

The HighLowSeries type exposes the following members.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

HighLowSeries Class
C1.Silverlight.Chart Namespace


HLOC Class

[image]

.NET Framework Class Library
HLOC Class
Members See Also
Represents element of financial chart (high-low-open-close).

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class HLOC : PlotElement
Visual Basic (Declaration)
Public Class HLOC _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.HLOC

See Also

HLOC Members
C1.Silverlight.Chart Namespace


HLOC Members

[image] [image]

.NET Framework Class Library
HLOC Members
HLOC Class Constructors Methods Fields Properties Events See Also

The HLOC type exposes the following members.

Constructors

Name | Description
HLOC | Initializes a new instance of the HLOC class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
RenderCandle | Renders candle based on the specified context.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_app | Stores the appearance of the symbol.
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Appearance | Gets or sets the appearance of plot element.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOC Constructor

[image]

.NET Framework Class Library
HLOC Constructor
HLOC Class See Also
Initializes a new instance of the HLOC class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public HLOC()
Visual Basic (Declaration)
Public Sub New

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOC Fields

[image] [image]

.NET Framework Class Library
HLOC Fields
HLOC Class See Also

The HLOC type exposes the following members.

Fields

Name | Description
_app | Stores the appearance of the symbol.
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

See Also

HLOC Class
C1.Silverlight.Chart Namespace


_app Field

[image]

.NET Framework Class Library
HLOC..::._app Field
HLOC Class See Also
Stores the appearance of the symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected HLOCAppearance _app
Visual Basic (Declaration)
Protected _app As HLOCAppearance

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOC Methods

[image] [image]

.NET Framework Class Library
HLOC Methods
HLOC Class See Also

The HLOC type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
RenderCandle | Renders candle based on the specified context.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
HLOC..::.HitTest Method
HLOC Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

HLOC Class
HLOC Members
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
HLOC..::.Render Method
HLOC Class See Also
Renders the plot element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

HLOC Class
C1.Silverlight.Chart Namespace


RenderCandle Method

[image]

.NET Framework Class Library
HLOC..::.RenderCandle Method
HLOC Class See Also
Renders candle based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void RenderCandle(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Sub RenderCandle ( _
    rc As RenderContext _
)

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOC Properties

[image] [image]

.NET Framework Class Library
HLOC Properties
HLOC Class See Also

The HLOC type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Appearance | Gets or sets the appearance of plot element.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

HLOC Class
C1.Silverlight.Chart Namespace


Appearance Property

[image]

.NET Framework Class Library
HLOC..::.Appearance Property
HLOC Class See Also
Gets or sets the appearance of plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public HLOCAppearance Appearance { get; set; }
Visual Basic (Declaration)
Public Property Appearance As HLOCAppearance

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOC Events

[image] [image]

.NET Framework Class Library
HLOC Events
HLOC Class See Also

The HLOC type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

HLOC Class
C1.Silverlight.Chart Namespace


HLOCAppearance Enumeration

[image]

.NET Framework Class Library
HLOCAppearance Enumeration
See Also
Defines the appearance of HLOC (high-low-open-close) plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum HLOCAppearance
Visual Basic (Declaration)
Public Enumeration HLOCAppearance

Members

Member name | Description
Default | Default appearance as line segments.
Candle | Candle plot.

See Also

C1.Silverlight.Chart Namespace


ICoordConverter Interface

[image]

.NET Framework Class Library
ICoordConverter Interface
Members See Also
Represents coordinate converter

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface ICoordConverter
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Interface ICoordConverter

See Also

ICoordConverter Members
C1.Silverlight.Chart Namespace


ICoordConverter Members

[image] [image]

.NET Framework Class Library
ICoordConverter Members
ICoordConverter Interface Methods Properties See Also

The ICoordConverter type exposes the following members.

Methods

Name | Description
ConvertPoint | Converts point from data to plot coordinates.
ConvertX | Converts x-value from data to space coordinate.
ConvertY | Converts y-value from data to space coordinate.
ConvertZ | Converts z-value from data to space coordinate.

Properties

Name | Description
DataBounds | Gets the bounds of the plot in data coordinates.
ViewBounds | Gets the bounds of the plot in view coordinates.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ICoordConverter Methods

[image] [image]

.NET Framework Class Library
ICoordConverter Methods
ICoordConverter Interface See Also

The ICoordConverter type exposes the following members.

Methods

Name | Description
ConvertPoint | Converts point from data to plot coordinates.
ConvertX | Converts x-value from data to space coordinate.
ConvertY | Converts y-value from data to space coordinate.
ConvertZ | Converts z-value from data to space coordinate.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ConvertPoint Method

[image]

.NET Framework Class Library
ICoordConverter..::.ConvertPoint Method
ICoordConverter Interface See Also
Converts point from data to plot coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Point ConvertPoint(
    Point point
)
Visual Basic (Declaration)
Function ConvertPoint ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point
Point in data coordinates.

Return Value

The corresponding point in plot coordinates.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ConvertX Method

[image]

.NET Framework Class Library
ICoordConverter..::.ConvertX Method
ICoordConverter Interface See Also
Converts x-value from data to space coordinate.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
double ConvertX(
    double x
)
Visual Basic (Declaration)
Function ConvertX ( _
    x As Double _
) As Double

Parameters

x
Type: System..::.Double
X-data value.

Return Value

View coordinate.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ConvertY Method

[image]

.NET Framework Class Library
ICoordConverter..::.ConvertY Method
ICoordConverter Interface See Also
Converts y-value from data to space coordinate.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
double ConvertY(
    double y
)
Visual Basic (Declaration)
Function ConvertY ( _
    y As Double _
) As Double

Parameters

y
Type: System..::.Double
Y-data value.

Return Value

View coordinate.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ConvertZ Method

[image]

.NET Framework Class Library
ICoordConverter..::.ConvertZ Method
ICoordConverter Interface See Also
Converts z-value from data to space coordinate.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
double ConvertZ(
    double z
)
Visual Basic (Declaration)
Function ConvertZ ( _
    z As Double _
) As Double

Parameters

z
Type: System..::.Double
Z-data value.

Return Value

View coordinate.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ICoordConverter Properties

[image] [image]

.NET Framework Class Library
ICoordConverter Properties
ICoordConverter Interface See Also

The ICoordConverter type exposes the following members.

Properties

Name | Description
DataBounds | Gets the bounds of the plot in data coordinates.
ViewBounds | Gets the bounds of the plot in view coordinates.

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


DataBounds Property

[image]

.NET Framework Class Library
ICoordConverter..::.DataBounds Property
ICoordConverter Interface See Also
Gets the bounds of the plot in data coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Rect DataBounds { get; }
Visual Basic (Declaration)
ReadOnly Property DataBounds As Rect

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


ViewBounds Property

[image]

.NET Framework Class Library
ICoordConverter..::.ViewBounds Property
ICoordConverter Interface See Also
Gets the bounds of the plot in view coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Rect ViewBounds { get; }
Visual Basic (Declaration)
ReadOnly Property ViewBounds As Rect

See Also

ICoordConverter Interface
C1.Silverlight.Chart Namespace


IDataSeriesInfo Interface

[image]

.NET Framework Class Library
IDataSeriesInfo Interface
Members See Also
Generic data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IDataSeriesInfo
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Interface IDataSeriesInfo

See Also

IDataSeriesInfo Members
C1.Silverlight.Chart Namespace


IDataSeriesInfo Members

[image] [image]

.NET Framework Class Library
IDataSeriesInfo Members
IDataSeriesInfo Interface Methods Properties See Also

The IDataSeriesInfo type exposes the following members.

Methods

Name | Description
GetDataNames | Gets data column names.
GetValueCoordinates | Gets coordinates which correspond to the data values.
GetValues | Gets 2D array containing data values.
SetResolvedValues | Setup bounded data values.

Properties

Name | Description
Connection | Gets or sets the connection template for data series.
Label | Gets or sets the text label of data series
MemberPaths | Gets the member bindings for the data series.
Symbol | Gets or sets the symbol template for data series.

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


IDataSeriesInfo Methods

[image] [image]

.NET Framework Class Library
IDataSeriesInfo Methods
IDataSeriesInfo Interface See Also

The IDataSeriesInfo type exposes the following members.

Methods

Name | Description
GetDataNames | Gets data column names.
GetValueCoordinates | Gets coordinates which correspond to the data values.
GetValues | Gets 2D array containing data values.
SetResolvedValues | Setup bounded data values.

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


GetDataNames Method

[image]

.NET Framework Class Library
IDataSeriesInfo..::.GetDataNames Method
IDataSeriesInfo Interface See Also
Gets data column names.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
string[] GetDataNames()
Visual Basic (Declaration)
Function GetDataNames As String()

Return Value

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


GetValueCoordinates Method

[image]

.NET Framework Class Library
IDataSeriesInfo..::.GetValueCoordinates Method
IDataSeriesInfo Interface See Also
Gets coordinates which correspond to the data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
ValueCoordinate[] GetValueCoordinates()
Visual Basic (Declaration)
Function GetValueCoordinates As ValueCoordinate()

Return Value

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


GetValues Method

[image]

.NET Framework Class Library
IDataSeriesInfo..::.GetValues Method
IDataSeriesInfo Interface See Also
Gets 2D array containing data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
double[,] GetValues()
Visual Basic (Declaration)
Function GetValues As Double(,)

Return Value

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


SetResolvedValues Method

[image]

.NET Framework Class Library
IDataSeriesInfo..::.SetResolvedValues Method
IDataSeriesInfo Interface See Also
Setup bounded data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void SetResolvedValues(
    int index,
    Object[] values
)
Visual Basic (Declaration)
Sub SetResolvedValues ( _
    index As Integer, _
    values As Object() _
)

Parameters

index
Type: System..::.Int32
values
Type: array< System..::.Object >[]()[]

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


IDataSeriesInfo Properties

[image] [image]

.NET Framework Class Library
IDataSeriesInfo Properties
IDataSeriesInfo Interface See Also

The IDataSeriesInfo type exposes the following members.

Properties

Name | Description
Connection | Gets or sets the connection template for data series.
Label | Gets or sets the text label of data series
MemberPaths | Gets the member bindings for the data series.
Symbol | Gets or sets the symbol template for data series.

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


Connection Property

[image]

.NET Framework Class Library
IDataSeriesInfo..::.Connection Property
IDataSeriesInfo Interface See Also
Gets or sets the connection template for data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Object Connection { get; set; }
Visual Basic (Declaration)
Property Connection As Object

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


Label Property

[image]

.NET Framework Class Library
IDataSeriesInfo..::.Label Property
IDataSeriesInfo Interface See Also
Gets or sets the text label of data series

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
string Label { get; set; }
Visual Basic (Declaration)
Property Label As String

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
IDataSeriesInfo..::.MemberPaths Property
IDataSeriesInfo Interface See Also
Gets the member bindings for the data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Binding[] MemberPaths { get; }
Visual Basic (Declaration)
ReadOnly Property MemberPaths As Binding()

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


Symbol Property

[image]

.NET Framework Class Library
IDataSeriesInfo..::.Symbol Property
IDataSeriesInfo Interface See Also
Gets or sets the symbol template for data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Object Symbol { get; set; }
Visual Basic (Declaration)
Property Symbol As Object

See Also

IDataSeriesInfo Interface
C1.Silverlight.Chart Namespace


IPlotElement Interface

[image]

.NET Framework Class Library
IPlotElement Interface
Members See Also
Represents generic plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IPlotElement
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Interface IPlotElement

See Also

IPlotElement Members
C1.Silverlight.Chart Namespace


IPlotElement Members

[image] [image]

.NET Framework Class Library
IPlotElement Members
IPlotElement Interface Methods Properties See Also

The IPlotElement type exposes the following members.

Methods

Name | Description
IsCompatible | Whether the plot element is compatible with the specified renderer.
Render | Renders the plot element based on specified context.
SetShape | Sets the shape style of the plot element.

Properties

Name | Description
IsClustered | Whether the plot element can be clustered.
Label | Gets or sets the data label associated with the plot element.
LegendShape | Gets the shape that represents the appearance of plot element in the legend.
Style | Gets or sets the style that should be applied to the plot element.

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


IPlotElement Methods

[image] [image]

.NET Framework Class Library
IPlotElement Methods
IPlotElement Interface See Also

The IPlotElement type exposes the following members.

Methods

Name | Description
IsCompatible | Whether the plot element is compatible with the specified renderer.
Render | Renders the plot element based on specified context.
SetShape | Sets the shape style of the plot element.

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


IsCompatible Method

[image]

.NET Framework Class Library
IPlotElement..::.IsCompatible Method
IPlotElement Interface See Also
Whether the plot element is compatible with the specified renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IsCompatible(
    IRenderer rend
)
Visual Basic (Declaration)
Function IsCompatible ( _
    rend As IRenderer _
) As Boolean

Parameters

rend
Type: C1.Silverlight.Chart..::.IRenderer

Return Value

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
IPlotElement..::.Render Method
IPlotElement Interface See Also
Renders the plot element based on specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


SetShape Method

[image]

.NET Framework Class Library
IPlotElement..::.SetShape Method
IPlotElement Interface See Also
Sets the shape style of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void SetShape(
    ShapeStyle shapeStyle
)
Visual Basic (Declaration)
Sub SetShape ( _
    shapeStyle As ShapeStyle _
)

Parameters

shapeStyle
Type: C1.Silverlight.Chart..::.ShapeStyle

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


IPlotElement Properties

[image] [image]

.NET Framework Class Library
IPlotElement Properties
IPlotElement Interface See Also

The IPlotElement type exposes the following members.

Properties

Name | Description
IsClustered | Whether the plot element can be clustered.
Label | Gets or sets the data label associated with the plot element.
LegendShape | Gets the shape that represents the appearance of plot element in the legend.
Style | Gets or sets the style that should be applied to the plot element.

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


IsClustered Property

[image]

.NET Framework Class Library
IPlotElement..::.IsClustered Property
IPlotElement Interface See Also
Whether the plot element can be clustered.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IsClustered { get; }
Visual Basic (Declaration)
ReadOnly Property IsClustered As Boolean

Remarks

Only for Cartesian plots.

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


Label Property

[image]

.NET Framework Class Library
IPlotElement..::.Label Property
IPlotElement Interface See Also
Gets or sets the data label associated with the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
UIElement Label { get; set; }
Visual Basic (Declaration)
Property Label As UIElement

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
IPlotElement..::.LegendShape Property
IPlotElement Interface See Also
Gets the shape that represents the appearance of plot element in the legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Shape LegendShape { get; }
Visual Basic (Declaration)
ReadOnly Property LegendShape As Shape

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


Style Property

[image]

.NET Framework Class Library
IPlotElement..::.Style Property
IPlotElement Interface See Also
Gets or sets the style that should be applied to the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Style Style { get; set; }
Visual Basic (Declaration)
Property Style As Style

See Also

IPlotElement Interface
C1.Silverlight.Chart Namespace


IRenderer Interface

[image]

.NET Framework Class Library
IRenderer Interface
Members See Also
Generic renderer interface.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public interface IRenderer
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Interface IRenderer

See Also

IRenderer Members
C1.Silverlight.Chart Namespace


IRenderer Members

[image] [image]

.NET Framework Class Library
IRenderer Members
IRenderer Interface Methods Properties Events See Also

The IRenderer type exposes the following members.

Methods

Name | Description
AddSeries | Adds data series.
Clear | Clear data series list.

Properties

Name | Description
CoordConverter | Gets or sets coordinate converter
Dirty | Requires rebuilding.
Options | Gets or sets rendering options.
Visual | Visual element that is used for rendering.

Events

Name | Description
Changed | Occurs when the object was modified.

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


IRenderer Methods

[image] [image]

.NET Framework Class Library
IRenderer Methods
IRenderer Interface See Also

The IRenderer type exposes the following members.

Methods

Name | Description
AddSeries | Adds data series.
Clear | Clear data series list.

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


AddSeries Method

[image]

.NET Framework Class Library
IRenderer..::.AddSeries Method
IRenderer Interface See Also
Adds data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void AddSeries(
    IDataSeriesInfo seriesInfo
)
Visual Basic (Declaration)
Sub AddSeries ( _
    seriesInfo As IDataSeriesInfo _
)

Parameters

seriesInfo
Type: C1.Silverlight.Chart..::.IDataSeriesInfo

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


Clear Method

[image]

.NET Framework Class Library
IRenderer..::.Clear Method
IRenderer Interface See Also
Clear data series list.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


IRenderer Properties

[image] [image]

.NET Framework Class Library
IRenderer Properties
IRenderer Interface See Also

The IRenderer type exposes the following members.

Properties

Name | Description
CoordConverter | Gets or sets coordinate converter
Dirty | Requires rebuilding.
Options | Gets or sets rendering options.
Visual | Visual element that is used for rendering.

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


CoordConverter Property

[image]

.NET Framework Class Library
IRenderer..::.CoordConverter Property
IRenderer Interface See Also
Gets or sets coordinate converter

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
ICoordConverter CoordConverter { get; set; }
Visual Basic (Declaration)
Property CoordConverter As ICoordConverter

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


Dirty Property

[image]

.NET Framework Class Library
IRenderer..::.Dirty Property
IRenderer Interface See Also
Requires rebuilding.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool Dirty { get; set; }
Visual Basic (Declaration)
Property Dirty As Boolean

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


Options Property

[image]

.NET Framework Class Library
IRenderer..::.Options Property
IRenderer Interface See Also
Gets or sets rendering options.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
string Options { get; set; }
Visual Basic (Declaration)
Property Options As String

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


Visual Property

[image]

.NET Framework Class Library
IRenderer..::.Visual Property
IRenderer Interface See Also
Visual element that is used for rendering.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
UIElement Visual { get; set; }
Visual Basic (Declaration)
Property Visual As UIElement

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


IRenderer Events

[image] [image]

.NET Framework Class Library
IRenderer Events
IRenderer Interface See Also

The IRenderer type exposes the following members.

Events

Name | Description
Changed | Occurs when the object was modified.

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


Changed Event

[image]

.NET Framework Class Library
IRenderer..::.Changed Event
IRenderer Interface See Also
Occurs when the object was modified.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
event EventHandler Changed
Visual Basic (Declaration)
Event Changed As EventHandler

See Also

IRenderer Interface
C1.Silverlight.Chart Namespace


LabelAlignment Enumeration

[image]

.NET Framework Class Library
LabelAlignment Enumeration
See Also
Specifies the position of data label relatively to the corresponding plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum LabelAlignment
Visual Basic (Declaration)
Public Enumeration LabelAlignment

Members

Member name | Description
Auto | Automatic label position.
BottomCenter | Bottom center position.
BottomLeft | Bottom left position.
BottomRight | Bottom right position.
MiddleCenter | Middle center position.
MiddleLeft | Middle left position.
MiddleRight | Middle right position.
TopCenter | Top center position.
TopLeft | Top left position.
TopRight | Top right position.

See Also

C1.Silverlight.Chart Namespace


Legend Class

[image]

.NET Framework Class Library
Legend Class
Members See Also
Represents the chart legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[ObsoleteAttribute("Please use C1ChartLegend instead")]
public class Legend : C1ChartLegend
Visual Basic (Declaration)
<ObsoleteAttribute("Please use C1ChartLegend instead")> _
Public Class Legend _
    Inherits C1ChartLegend

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Chart..::.C1ChartLegend
C1.Silverlight.Chart..::.Legend

See Also

Legend Members
C1.Silverlight.Chart Namespace


Legend Members

[image] [image]

.NET Framework Class Library
Legend Members
Legend Class Constructors Methods Properties Events See Also

The Legend type exposes the following members.

Constructors

Name | Description
Legend |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from C1ChartLegend.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Chart | Gets or sets the instance of Chart that corresponds to the Legend. (Inherited from C1ChartLegend.)
Clip | (Inherited from UIElement.)
CornerRadius | Gets or sets corner radius of the legend. (Inherited from C1ChartLegend.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the layout orientation for the legend. (Inherited from C1ChartLegend.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Position | Gets or sets legend position. (Inherited from C1ChartLegend.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Legend Class
C1.Silverlight.Chart Namespace


Legend Constructor

[image]

.NET Framework Class Library
Legend Constructor
Legend Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Legend()
Visual Basic (Declaration)
Public Sub New

See Also

Legend Class
C1.Silverlight.Chart Namespace


Legend Methods

[image] [image]

.NET Framework Class Library
Legend Methods
Legend Class See Also

The Legend type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Inherited from C1ChartLegend.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Legend Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Legend..::.HitTest Method
Legend Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Legend Class
Legend Members
C1.Silverlight.Chart Namespace


Legend Properties

[image] [image]

.NET Framework Class Library
Legend Properties
Legend Class See Also

The Legend type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Chart | Gets or sets the instance of Chart that corresponds to the Legend. (Inherited from C1ChartLegend.)
Clip | (Inherited from UIElement.)
CornerRadius | Gets or sets corner radius of the legend. (Inherited from C1ChartLegend.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the layout orientation for the legend. (Inherited from C1ChartLegend.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Position | Gets or sets legend position. (Inherited from C1ChartLegend.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Legend Class
C1.Silverlight.Chart Namespace


Legend Events

[image] [image]

.NET Framework Class Library
Legend Events
Legend Class See Also

The Legend type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Legend Class
C1.Silverlight.Chart Namespace


LegendItem Class

[image]

.NET Framework Class Library
LegendItem Class
Members See Also
Represents the item in the chart legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class LegendItem
Visual Basic (Declaration)
Public Class LegendItem

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.LegendItem

See Also

LegendItem Members
C1.Silverlight.Chart Namespace


LegendItem Members

[image] [image]

.NET Framework Class Library
LegendItem Members
LegendItem Class Methods Properties See Also

The LegendItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns textual presentation of the object. (Overrides Object..::.ToString()()().)

Properties

Name | Description
Item | Gets the object associated with the plot element.
Label | Gets the text label of the plot element.
Line | Gets the line (connection) shape of the plot element.
Symbol | Gets the symbol shape of the plot element.

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


LegendItem Methods

[image] [image]

.NET Framework Class Library
LegendItem Methods
LegendItem Class See Also

The LegendItem type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns textual presentation of the object. (Overrides Object..::.ToString()()().)

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


ToString Method

[image]

.NET Framework Class Library
LegendItem..::.ToString Method
LegendItem Class See Also
Returns textual presentation of the object.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

Return Value

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


LegendItem Properties

[image] [image]

.NET Framework Class Library
LegendItem Properties
LegendItem Class See Also

The LegendItem type exposes the following members.

Properties

Name | Description
Item | Gets the object associated with the plot element.
Label | Gets the text label of the plot element.
Line | Gets the line (connection) shape of the plot element.
Symbol | Gets the symbol shape of the plot element.

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


Item Property

[image]

.NET Framework Class Library
LegendItem..::.Item Property
LegendItem Class See Also
Gets the object associated with the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Object Item { get; }
Visual Basic (Declaration)
Public ReadOnly Property Item As Object

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


Label Property

[image]

.NET Framework Class Library
LegendItem..::.Label Property
LegendItem Class See Also
Gets the text label of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public string Label { get; }
Visual Basic (Declaration)
Public ReadOnly Property Label As String

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


Line Property

[image]

.NET Framework Class Library
LegendItem..::.Line Property
LegendItem Class See Also
Gets the line (connection) shape of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Shape Line { get; }
Visual Basic (Declaration)
Public ReadOnly Property Line As Shape

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


Symbol Property

[image]

.NET Framework Class Library
LegendItem..::.Symbol Property
LegendItem Class See Also
Gets the symbol shape of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Shape Symbol { get; }
Visual Basic (Declaration)
Public ReadOnly Property Symbol As Shape

See Also

LegendItem Class
C1.Silverlight.Chart Namespace


LegendItemCollection Class

[image]

.NET Framework Class Library
LegendItemCollection Class
Members See Also
Represents the collection of legend items.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class LegendItemCollection : ReadOnlyCollection<LegendItem>,
    INotifyPropertyChanged, INotifyCollectionChanged
Visual Basic (Declaration)
Public Class LegendItemCollection _
    Inherits ReadOnlyCollection(Of LegendItem) _
    Implements INotifyPropertyChanged, INotifyCollectionChanged

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.ReadOnlyCollection <(Of <( LegendItem >)>)
C1.Silverlight.Chart..::.LegendItemCollection

See Also

LegendItemCollection Members
C1.Silverlight.Chart Namespace


LegendItemCollection Members

[image] [image]

.NET Framework Class Library
LegendItemCollection Members
LegendItemCollection Class Methods Properties Events See Also

The LegendItemCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)

Events

Name | Description
CollectionChanged | Occurs when an item in the collection changes, or the entire collection changes.
PropertyChanged | Occurs when a property value changes.

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


LegendItemCollection Methods

[image] [image]

.NET Framework Class Library
LegendItemCollection Methods
LegendItemCollection Class See Also

The LegendItemCollection type exposes the following members.

Methods

Name | Description
Contains | Determines whether an element is in the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
CopyTo | Copies the entire ReadOnlyCollection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ReadOnlyCollection<(Of <(T>)>). (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


LegendItemCollection Properties

[image] [image]

.NET Framework Class Library
LegendItemCollection Properties
LegendItemCollection Class See Also

The LegendItemCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements contained in the ReadOnlyCollection<(Of <(T>)>) instance. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Item | Gets the element at the specified index. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)
Items | Returns the IList<(Of <(T>)>) that the ReadOnlyCollection<(Of <(T>)>) wraps. (Inherited from ReadOnlyCollection <(Of <( LegendItem >)>).)

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


LegendItemCollection Events

[image] [image]

.NET Framework Class Library
LegendItemCollection Events
LegendItemCollection Class See Also

The LegendItemCollection type exposes the following members.

Events

Name | Description
CollectionChanged | Occurs when an item in the collection changes, or the entire collection changes.
PropertyChanged | Occurs when a property value changes.

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


CollectionChanged Event

[image]

.NET Framework Class Library
LegendItemCollection..::.CollectionChanged Event
LegendItemCollection Class See Also
Occurs when an item in the collection changes, or the entire collection changes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Implements

INotifyCollectionChanged..::.CollectionChanged

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
LegendItemCollection..::.PropertyChanged Event
LegendItemCollection Class See Also
Occurs when a property value changes.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Protected Event PropertyChanged As PropertyChangedEventHandler

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


LegendPosition Enumeration

[image]

.NET Framework Class Library
LegendPosition Enumeration
See Also
Specifies legend position.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum LegendPosition
Visual Basic (Declaration)
Public Enumeration LegendPosition

Members

Member name | Description
Left | At left from the chart.
Right | At right from the chart.
Top | At top from the chart.
Bottom | At bottom from the chart.

See Also

C1.Silverlight.Chart Namespace


Lines Class

[image]

.NET Framework Class Library
Lines Class
Members See Also
Represents plot element that connects the data points.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Lines : PlotElement
Visual Basic (Declaration)
Public Class Lines _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Lines
C1.Silverlight.Chart..::.Area

See Also

Lines Members
C1.Silverlight.Chart Namespace


Lines Members

[image] [image]

.NET Framework Class Library
Lines Members
Lines Class Constructors Methods Fields Properties Events See Also

The Lines type exposes the following members.

Constructors

Name | Description
Lines | Initializes a new instance of Lines class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitPointsWithHoles | Returns list of point arrays splitted by NaN values.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Stores the geometry of the plot element.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape that represents the appearance of plot element in the legend. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Smoothed | Gets or sets whether the points are connected with smoothed lines.
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Lines Class
C1.Silverlight.Chart Namespace


Lines Constructor

[image]

.NET Framework Class Library
Lines Constructor
Lines Class See Also
Initializes a new instance of Lines class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Lines()
Visual Basic (Declaration)
Public Sub New

See Also

Lines Class
C1.Silverlight.Chart Namespace


Lines Fields

[image] [image]

.NET Framework Class Library
Lines Fields
Lines Class See Also

The Lines type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Stores the geometry of the plot element.

See Also

Lines Class
C1.Silverlight.Chart Namespace


_geometry Field

[image]

.NET Framework Class Library
Lines..::._geometry Field
Lines Class See Also
Stores the geometry of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected PathGeometry _geometry
Visual Basic (Declaration)
Protected _geometry As PathGeometry

See Also

Lines Class
C1.Silverlight.Chart Namespace


Lines Methods

[image] [image]

.NET Framework Class Library
Lines Methods
Lines Class See Also

The Lines type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
SplitPointsWithHoles | Returns list of point arrays splitted by NaN values.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Lines Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Lines..::.HitTest Method
Lines Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Lines Class
Lines Members
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
Lines..::.Render Method
Lines Class See Also
Renders the plot element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

Lines Class
C1.Silverlight.Chart Namespace


SplitPointsWithHoles Method

[image]

.NET Framework Class Library
Lines..::.SplitPointsWithHoles Method
Lines Class See Also
Returns list of point arrays splitted by NaN values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Point[]> SplitPointsWithHoles(
    Point[] pts
)
Visual Basic (Declaration)
Protected Function SplitPointsWithHoles ( _
    pts As Point() _
) As List(Of Point())

Parameters

pts
Type: array< System.Windows..::.Point >[]()[]

Return Value

See Also

Lines Class
C1.Silverlight.Chart Namespace


Lines Properties

[image] [image]

.NET Framework Class Library
Lines Properties
Lines Class See Also

The Lines type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape that represents the appearance of plot element in the legend. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Smoothed | Gets or sets whether the points are connected with smoothed lines.
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Lines Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
Lines..::.LegendShape Property
Lines Class See Also
Gets the shape that represents the appearance of plot element in the legend.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

Lines Class
C1.Silverlight.Chart Namespace


Smoothed Property

[image]

.NET Framework Class Library
Lines..::.Smoothed Property
Lines Class See Also
Gets or sets whether the points are connected with smoothed lines.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool Smoothed { get; set; }
Visual Basic (Declaration)
Public Property Smoothed As Boolean

See Also

Lines Class
C1.Silverlight.Chart Namespace


Lines Events

[image] [image]

.NET Framework Class Library
Lines Events
Lines Class See Also

The Lines type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Lines Class
C1.Silverlight.Chart Namespace


Marker Enumeration

[image]

.NET Framework Class Library
Marker Enumeration
See Also
Specifies data point marker.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum Marker
Visual Basic (Declaration)
Public Enumeration Marker

Members

Member name | Description
None | None or default marker.
Box | Box marker.
Dot | Dot marker.
Diamond | Diamond marker.
Triangle | Triangle marker.
Star4 | 4-ray star marker.
Star8 | 8-ray star marker.
Cross | Cross marker.
DiagonalCross | Diagonal cross marker.

See Also

C1.Silverlight.Chart Namespace


MeasureOption Enumeration

[image]

.NET Framework Class Library
MeasureOption Enumeration
See Also
Specifies how the distance between points is calculated.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum MeasureOption
Visual Basic (Declaration)
Public Enumeration MeasureOption

Members

Member name | Description
X | Only x-coordinates is used.
Y | Only y-coordinates is used.
XY | Both x- and y-coordinates are used.

See Also

C1.Silverlight.Chart Namespace


Palette Enumeration

[image]

.NET Framework Class Library
Palette Enumeration
See Also
This enumeration specifies color themes used to generate colors for data series. Named color themes other than Custom are similar to those in Microsoft Office.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum Palette
Visual Basic (Declaration)
Public Enumeration Palette

Members

Member name | Description
Default |
Standard |
Office |
GrayScale |
Apex |
Aspect |
Civic |
Concourse |
Equity |
Flow |
Foundry |
Median |
Metro |
Module |
Opulent |
Oriel |
Origin |
Paper |
Solstice |
Technic |
Trek |
Urban |
Verve |

See Also

C1.Silverlight.Chart Namespace


Pie Class

[image]

.NET Framework Class Library
Pie Class
Members See Also
Represents the element of pie chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Pie : PlotElement
Visual Basic (Declaration)
Public Class Pie _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Pie

See Also

Pie Members
C1.Silverlight.Chart Namespace


Pie Members

[image] [image]

.NET Framework Class Library
Pie Members
Pie Class Constructors Methods Fields Properties Events See Also

The Pie type exposes the following members.

Constructors

Name | Description
Pie | Initializes a new instance of of Pie class.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Overrides PlotElement..::.AutoPosition(Size, Point%, Point%).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Overrides PlotElement..::.IsCompatible(IRenderer).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Pie Class
C1.Silverlight.Chart Namespace


Pie Constructor

[image]

.NET Framework Class Library
Pie Constructor
Pie Class See Also
Initializes a new instance of of Pie class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Pie()
Visual Basic (Declaration)
Public Sub New

See Also

Pie Class
C1.Silverlight.Chart Namespace


Pie Fields

[image] [image]

.NET Framework Class Library
Pie Fields
Pie Class See Also

The Pie type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)

See Also

Pie Class
C1.Silverlight.Chart Namespace


Pie Methods

[image] [image]

.NET Framework Class Library
Pie Methods
Pie Class See Also

The Pie type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Overrides PlotElement..::.AutoPosition(Size, Point%, Point%).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Overrides PlotElement..::.IsCompatible(IRenderer).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

Pie Class
C1.Silverlight.Chart Namespace


AutoPosition Method

[image]

.NET Framework Class Library
Pie..::.AutoPosition Method
Pie Class See Also
Calculates automatic position of data label.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override LabelAlignment AutoPosition(
    Size labelSize,
    ref Point hot,
    ref Point offset
)
Visual Basic (Declaration)
Protected Overrides Function AutoPosition ( _
    labelSize As Size, _
    ByRef hot As Point, _
    ByRef offset As Point _
) As LabelAlignment

Parameters

labelSize
Type: System.Windows..::.Size
Size of the label.
hot
Type: System.Windows..::.Point %
Hot point (coordinates of the data point) of l.
offset
Type: System.Windows..::.Point %
Offset of the label from the hot point.

Return Value

The alignment of the label.

See Also

Pie Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Pie..::.HitTest Method
Pie Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Pie Class
Pie Members
C1.Silverlight.Chart Namespace


IsCompatible Method

[image]

.NET Framework Class Library
Pie..::.IsCompatible Method
Pie Class See Also
Whether the plot element is compatible with the specified renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool IsCompatible(
    IRenderer rend
)
Visual Basic (Declaration)
Protected Overrides Function IsCompatible ( _
    rend As IRenderer _
) As Boolean

Parameters

rend
Type: C1.Silverlight.Chart..::.IRenderer

Return Value

See Also

Pie Class
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
Pie..::.Render Method
Pie Class See Also
Renders the plot element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

Pie Class
C1.Silverlight.Chart Namespace


Pie Properties

[image] [image]

.NET Framework Class Library
Pie Properties
Pie Class See Also

The Pie type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation. (Inherited from PlotElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Pie Class
C1.Silverlight.Chart Namespace


Pie Events

[image] [image]

.NET Framework Class Library
Pie Events
Pie Class See Also

The Pie type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Pie Class
C1.Silverlight.Chart Namespace


PieInfo Structure

[image]

.NET Framework Class Library
PieInfo Structure
Members See Also
Represents parameters of pie slice.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public struct PieInfo
Visual Basic (Declaration)
Public Structure PieInfo

See Also

PieInfo Members
C1.Silverlight.Chart Namespace


PieInfo Members

[image] [image]

.NET Framework Class Library
PieInfo Members
PieInfo Structure Constructors Methods Fields See Also

The PieInfo type exposes the following members.

Constructors

Name | Description
PieInfo | Creates a new PieInfo structure with the specified parameters.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

Fields

Name | Description
Angle | Gets or sets the start angle of the pie.
Center | Gets or sets the center of the pie.
Height | Gets or sets the height of the pie.
InnerRadius | Gets or sets the inner radius of the pie.
RadiusX | Gets or sets the x-radius of the pie.
RadiusY | Gets or sets the y-radius of the pie.
Sweep | Gets or sets the sweep of the pie.

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


PieInfo Constructor

[image]

.NET Framework Class Library
PieInfo Constructor
PieInfo Structure See Also
Creates a new PieInfo structure with the specified parameters.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public PieInfo(
    Point center,
    double radiusX,
    double radiusY,
    double inner,
    double angle,
    double sweep,
    double height
)
Visual Basic (Declaration)
Public Sub New ( _
    center As Point, _
    radiusX As Double, _
    radiusY As Double, _
    inner As Double, _
    angle As Double, _
    sweep As Double, _
    height As Double _
)

Parameters

center
Type: System.Windows..::.Point
radiusX
Type: System..::.Double
radiusY
Type: System..::.Double
inner
Type: System..::.Double
angle
Type: System..::.Double
sweep
Type: System..::.Double
height
Type: System..::.Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


PieInfo Fields

[image] [image]

.NET Framework Class Library
PieInfo Fields
PieInfo Structure See Also

The PieInfo type exposes the following members.

Fields

Name | Description
Angle | Gets or sets the start angle of the pie.
Center | Gets or sets the center of the pie.
Height | Gets or sets the height of the pie.
InnerRadius | Gets or sets the inner radius of the pie.
RadiusX | Gets or sets the x-radius of the pie.
RadiusY | Gets or sets the y-radius of the pie.
Sweep | Gets or sets the sweep of the pie.

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Angle Field

[image]

.NET Framework Class Library
PieInfo..::.Angle Field
PieInfo Structure See Also
Gets or sets the start angle of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Angle
Visual Basic (Declaration)
Public Angle As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Center Field

[image]

.NET Framework Class Library
PieInfo..::.Center Field
PieInfo Structure See Also
Gets or sets the center of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point Center
Visual Basic (Declaration)
Public Center As Point

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Height Field

[image]

.NET Framework Class Library
PieInfo..::.Height Field
PieInfo Structure See Also
Gets or sets the height of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Height
Visual Basic (Declaration)
Public Height As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


InnerRadius Field

[image]

.NET Framework Class Library
PieInfo..::.InnerRadius Field
PieInfo Structure See Also
Gets or sets the inner radius of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double InnerRadius
Visual Basic (Declaration)
Public InnerRadius As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


RadiusX Field

[image]

.NET Framework Class Library
PieInfo..::.RadiusX Field
PieInfo Structure See Also
Gets or sets the x-radius of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double RadiusX
Visual Basic (Declaration)
Public RadiusX As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


RadiusY Field

[image]

.NET Framework Class Library
PieInfo..::.RadiusY Field
PieInfo Structure See Also
Gets or sets the y-radius of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double RadiusY
Visual Basic (Declaration)
Public RadiusY As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Sweep Field

[image]

.NET Framework Class Library
PieInfo..::.Sweep Field
PieInfo Structure See Also
Gets or sets the sweep of the pie.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double Sweep
Visual Basic (Declaration)
Public Sweep As Double

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


PieInfo Methods

[image] [image]

.NET Framework Class Library
PieInfo Methods
PieInfo Structure See Also

The PieInfo type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides ValueType..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Operators

Name | Description
Equality |
Inequality |

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Equality Operator

[image]

.NET Framework Class Library
PieInfo..::.Equality Operator
PieInfo Structure See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static bool operator ==(
    PieInfo pie1,
    PieInfo pie2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    pie1 As PieInfo, _
    pie2 As PieInfo _
) As Boolean

Parameters

pie1
Type: C1.Silverlight.Chart..::.PieInfo
pie2
Type: C1.Silverlight.Chart..::.PieInfo

Return Value

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Equals Method

[image] [image]

.NET Framework Class Library
PieInfo..::.Equals Method
PieInfo Structure See Also

Overload List

Name | Description
Equals(PieInfo) |
Equals(Object) | (Overrides ValueType..::.Equals(Object).)

See Also

PieInfo Structure
PieInfo Members
C1.Silverlight.Chart Namespace


Equals Method (PieInfo)

[image]

.NET Framework Class Library
PieInfo..::.Equals Method (PieInfo)
PieInfo Structure See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public bool Equals(
    PieInfo value
)
Visual Basic (Declaration)
Public Function Equals ( _
    value As PieInfo _
) As Boolean

Parameters

value
Type: C1.Silverlight.Chart..::.PieInfo

Return Value

See Also

PieInfo Structure
Equals Overload
C1.Silverlight.Chart Namespace


Equals Method (Object)

[image]

.NET Framework Class Library
PieInfo..::.Equals Method (Object)
PieInfo Structure See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

Return Value

See Also

PieInfo Structure
Equals Overload
C1.Silverlight.Chart Namespace


GetHashCode Method

[image]

.NET Framework Class Library
PieInfo..::.GetHashCode Method
PieInfo Structure See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

Return Value

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


Inequality Operator

[image]

.NET Framework Class Library
PieInfo..::.Inequality Operator
PieInfo Structure See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static bool operator !=(
    PieInfo pie1,
    PieInfo pie2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    pie1 As PieInfo, _
    pie2 As PieInfo _
) As Boolean

Parameters

pie1
Type: C1.Silverlight.Chart..::.PieInfo
pie2
Type: C1.Silverlight.Chart..::.PieInfo

Return Value

See Also

PieInfo Structure
C1.Silverlight.Chart Namespace


PieRenderContext Class

[image]

.NET Framework Class Library
PieRenderContext Class
Members See Also
Provides information about the render context for pie visualization.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class PieRenderContext : RenderContext
Visual Basic (Declaration)
Public Class PieRenderContext _
    Inherits RenderContext

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.RenderContext
C1.Silverlight.Chart..::.PieRenderContext

See Also

PieRenderContext Members
C1.Silverlight.Chart Namespace


PieRenderContext Members

[image] [image]

.NET Framework Class Library
PieRenderContext Members
PieRenderContext Class Methods Fields Properties See Also

The PieRenderContext type exposes the following members.

Methods

Name | Description
ConvertX | Converts x data value to the control coordinate. (Inherited from RenderContext.)
ConvertY | Converts y data value to the control coordinate. (Inherited from RenderContext.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
PieInfo | Contains information about pie slice.

Properties

Name | Description
Bounds | Gets the range of data values. (Inherited from RenderContext.)
Current | Gets the current data point in data coordinates. (Inherited from RenderContext.)
CurrentView | Gets the current data point in control(view) coordinates. (Inherited from RenderContext.)
Data | Gets the array of data values of current series. (Inherited from RenderContext.)
DataSeries | Gets the current data series. (Inherited from RenderContext.)
Item | Gets the value of current data point by its name. (Inherited from RenderContext.)
PointIndex | Gets the current index of data point. (Inherited from RenderContext.)
Points | Gets the array of points for the current data series. (Inherited from RenderContext.)
Previous | Gets the previous data point. (Inherited from RenderContext.)
PreviousValues | Gets the array of value for the previous data series. (Inherited from RenderContext.)
Rect | Gets the rectangle that corresponds to the current data point. (Inherited from RenderContext.)
Renderer | Gets the current renderer. (Inherited from RenderContext.)

See Also

PieRenderContext Class
C1.Silverlight.Chart Namespace


PieRenderContext Fields

[image] [image]

.NET Framework Class Library
PieRenderContext Fields
PieRenderContext Class See Also

The PieRenderContext type exposes the following members.

Fields

Name | Description
PieInfo | Contains information about pie slice.

See Also

PieRenderContext Class
C1.Silverlight.Chart Namespace


PieInfo Field

[image]

.NET Framework Class Library
PieRenderContext..::.PieInfo Field
PieRenderContext Class See Also
Contains information about pie slice.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public PieInfo PieInfo
Visual Basic (Declaration)
Public PieInfo As PieInfo

See Also

PieRenderContext Class
C1.Silverlight.Chart Namespace


PieRenderContext Methods

[image] [image]

.NET Framework Class Library
PieRenderContext Methods
PieRenderContext Class See Also

The PieRenderContext type exposes the following members.

Methods

Name | Description
ConvertX | Converts x data value to the control coordinate. (Inherited from RenderContext.)
ConvertY | Converts y data value to the control coordinate. (Inherited from RenderContext.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PieRenderContext Class
C1.Silverlight.Chart Namespace


PieRenderContext Properties

[image] [image]

.NET Framework Class Library
PieRenderContext Properties
PieRenderContext Class See Also

The PieRenderContext type exposes the following members.

Properties

Name | Description
Bounds | Gets the range of data values. (Inherited from RenderContext.)
Current | Gets the current data point in data coordinates. (Inherited from RenderContext.)
CurrentView | Gets the current data point in control(view) coordinates. (Inherited from RenderContext.)
Data | Gets the array of data values of current series. (Inherited from RenderContext.)
DataSeries | Gets the current data series. (Inherited from RenderContext.)
Item | Gets the value of current data point by its name. (Inherited from RenderContext.)
PointIndex | Gets the current index of data point. (Inherited from RenderContext.)
Points | Gets the array of points for the current data series. (Inherited from RenderContext.)
Previous | Gets the previous data point. (Inherited from RenderContext.)
PreviousValues | Gets the array of value for the previous data series. (Inherited from RenderContext.)
Rect | Gets the rectangle that corresponds to the current data point. (Inherited from RenderContext.)
Renderer | Gets the current renderer. (Inherited from RenderContext.)

See Also

PieRenderContext Class
C1.Silverlight.Chart Namespace


PieRenderer Class

[image]

.NET Framework Class Library
PieRenderer Class
Members See Also
Performs 2D pie visualization.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class PieRenderer : BasePieRenderer,
    IRenderer
Visual Basic (Declaration)
Public Class PieRenderer _
    Inherits BasePieRenderer _
    Implements IRenderer

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.BaseRenderer
C1.Silverlight.Chart..::.BasePieRenderer
C1.Silverlight.Chart..::.PieRenderer

See Also

PieRenderer Members
C1.Silverlight.Chart Namespace


PieRenderer Members

[image] [image]

.NET Framework Class Library
PieRenderer Members
PieRenderer Class Constructors Methods Properties See Also

The PieRenderer type exposes the following members.

Constructors

Name | Description
PieRenderer | Creates an instance of pie renderer.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Adds the options set to the bag. (Inherited from BasePieRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
InnerRadius | Gets or sets the inner radius of pie. (Inherited from BasePieRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
Offset | Gets or sets the offset of slices. (Inherited from BasePieRenderer.)
Radius | Gets or sets the radius of pie. (Inherited from BasePieRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

PieRenderer Class
C1.Silverlight.Chart Namespace


PieRenderer Constructor

[image]

.NET Framework Class Library
PieRenderer Constructor
PieRenderer Class See Also
Creates an instance of pie renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public PieRenderer()
Visual Basic (Declaration)
Public Sub New

See Also

PieRenderer Class
C1.Silverlight.Chart Namespace


PieRenderer Methods

[image] [image]

.NET Framework Class Library
PieRenderer Methods
PieRenderer Class See Also

The PieRenderer type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Adds the options set to the bag. (Inherited from BasePieRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PieRenderer Class
C1.Silverlight.Chart Namespace


CreateSymbolShape Method

[image] [image]

.NET Framework Class Library
PieRenderer..::.CreateSymbolShape Method
PieRenderer Class See Also

Overload List

Name | Description
CreateSymbolShape(DataSeries) | Create symbol shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape(ShapeStyle) | Create symbol shape based on the specified shape style. (Inherited from BaseRenderer.)

See Also

PieRenderer Class
PieRenderer Members
C1.Silverlight.Chart Namespace


PieRenderer Properties

[image] [image]

.NET Framework Class Library
PieRenderer Properties
PieRenderer Class See Also

The PieRenderer type exposes the following members.

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
InnerRadius | Gets or sets the inner radius of pie. (Inherited from BasePieRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
Offset | Gets or sets the offset of slices. (Inherited from BasePieRenderer.)
Radius | Gets or sets the radius of pie. (Inherited from BasePieRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

PieRenderer Class
C1.Silverlight.Chart Namespace


PlotElement Class

[image]

.NET Framework Class Library
PlotElement Class
Members See Also
Generic plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class PlotElement : ContentPresenter,
    IPlotElement
Visual Basic (Declaration)
Public Class PlotElement _
    Inherits ContentPresenter _
    Implements IPlotElement

Remarks

Plot element is a visual presentation of data such as bar on the bar chart or slice of pie on the pie chart.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Bar
C1.Silverlight.Chart..::.BoxSymbol
C1.Silverlight.Chart..::.DotSymbol
C1.Silverlight.Chart..::.HLOC
C1.Silverlight.Chart..::.Lines
C1.Silverlight.Chart..::.Pie
C1.Silverlight.Chart..::.Symbol

See Also

PlotElement Members
C1.Silverlight.Chart Namespace


PlotElement Members

[image] [image]

.NET Framework Class Library
PlotElement Members
PlotElement Class Methods Fields Properties Events See Also

The PlotElement type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLabelAlignment | Gets the label alignment of the element.
GetLabelLine | Sets the line connecting data point and label for the element.
GetLabelOffset | Gets the labels offset for the element.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context.
SetBinding | (Inherited from FrameworkElement.)
SetLabelAlignment | Sets the label alignment of the element.
SetLabelLine | Gets the line connecting data point and label for the element.
SetLabelOffset | Sets the label offset for the element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element.
_fill | Whether the plot element should be filled.
DataPointProperty | Identifies the DataPoint dependency property.
LabelAlignmentProperty | Identifies the PlotElement.LabelAlignment attached dependency property.
LabelLineProperty | Identifies the PlotElement.LabelLine attached dependency property.
LabelOffsetProperty | Identifies the PlotElement.LabelOffset attached dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element.
Size | Gets or sets the size of the plot element.
Stroke | Gets or sets the stroke brush for the plot element.
StrokeLineJoin | Gets or sets the line join type used by the plot element.
StrokeThickness | Gets or sets the stroke thickness for the plot element.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created.
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded.
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element.
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element.
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element.
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element.
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


PlotElement Fields

[image] [image]

.NET Framework Class Library
PlotElement Fields
PlotElement Class See Also

The PlotElement type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element.
_fill | Whether the plot element should be filled.
DataPointProperty | Identifies the DataPoint dependency property.
LabelAlignmentProperty | Identifies the PlotElement.LabelAlignment attached dependency property.
LabelLineProperty | Identifies the PlotElement.LabelLine attached dependency property.
LabelOffsetProperty | Identifies the PlotElement.LabelOffset attached dependency property.

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


_autoStyle Field

[image]

.NET Framework Class Library
PlotElement..::._autoStyle Field
PlotElement Class See Also
Stores automatic shape style that was set to the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected ShapeStyle _autoStyle
Visual Basic (Declaration)
Protected _autoStyle As ShapeStyle

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


_fill Field

[image]

.NET Framework Class Library
PlotElement..::._fill Field
PlotElement Class See Also
Whether the plot element should be filled.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected bool _fill
Visual Basic (Declaration)
Protected _fill As Boolean

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


DataPointProperty Field

[image]

.NET Framework Class Library
PlotElement..::.DataPointProperty Field
PlotElement Class See Also
Identifies the DataPoint dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty DataPointProperty
Visual Basic (Declaration)
Public Shared ReadOnly DataPointProperty As DependencyProperty

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


LabelAlignmentProperty Field

[image]

.NET Framework Class Library
PlotElement..::.LabelAlignmentProperty Field
PlotElement Class See Also
Identifies the PlotElement.LabelAlignment attached dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty LabelAlignmentProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelAlignmentProperty As DependencyProperty

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


LabelLineProperty Field

[image]

.NET Framework Class Library
PlotElement..::.LabelLineProperty Field
PlotElement Class See Also
Identifies the PlotElement.LabelLine attached dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty LabelLineProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelLineProperty As DependencyProperty

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


LabelOffsetProperty Field

[image]

.NET Framework Class Library
PlotElement..::.LabelOffsetProperty Field
PlotElement Class See Also
Identifies the PlotElement.LabelOffset attached dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty LabelOffsetProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelOffsetProperty As DependencyProperty

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


PlotElement Methods

[image] [image]

.NET Framework Class Library
PlotElement Methods
PlotElement Class See Also

The PlotElement type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label.
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLabelAlignment | Gets the label alignment of the element.
GetLabelLine | Sets the line connecting data point and label for the element.
GetLabelOffset | Gets the labels offset for the element.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the element based on the specified context.
SetBinding | (Inherited from FrameworkElement.)
SetLabelAlignment | Sets the label alignment of the element.
SetLabelLine | Gets the line connecting data point and label for the element.
SetLabelOffset | Sets the label offset for the element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


AdjustLegendShape Method

[image]

.NET Framework Class Library
PlotElement..::.AdjustLegendShape Method
PlotElement Class See Also
Adjusts property of legend shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void AdjustLegendShape(
    Shape shape
)
Visual Basic (Declaration)
Protected Sub AdjustLegendShape ( _
    shape As Shape _
)

Parameters

shape
Type: System.Windows.Shapes..::.Shape

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


AutoPosition Method

[image]

.NET Framework Class Library
PlotElement..::.AutoPosition Method
PlotElement Class See Also
Calculates automatic position of data label.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual LabelAlignment AutoPosition(
    Size labelSize,
    ref Point hot,
    ref Point offset
)
Visual Basic (Declaration)
Protected Overridable Function AutoPosition ( _
    labelSize As Size, _
    ByRef hot As Point, _
    ByRef offset As Point _
) As LabelAlignment

Parameters

labelSize
Type: System.Windows..::.Size
Size of the label.
hot
Type: System.Windows..::.Point %
Hot point (coordinates of the data point) of l.
offset
Type: System.Windows..::.Point %
Offset of the label from the hot point.

Return Value

The alignment of the label.

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


CloneAttributes Method

[image]

.NET Framework Class Library
PlotElement..::.CloneAttributes Method
PlotElement Class See Also
Clone the attributes of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void CloneAttributes(
    PlotElement clone
)
Visual Basic (Declaration)
Protected Sub CloneAttributes ( _
    clone As PlotElement _
)

Parameters

clone
Type: C1.Silverlight.Chart..::.PlotElement

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


GetLabelAlignment Method

[image]

.NET Framework Class Library
PlotElement..::.GetLabelAlignment Method
PlotElement Class See Also
Gets the label alignment of the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static LabelAlignment GetLabelAlignment(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetLabelAlignment ( _
    obj As DependencyObject _
) As LabelAlignment

Parameters

obj
Type: System.Windows..::.DependencyObject

Return Value

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


GetLabelLine Method

[image]

.NET Framework Class Library
PlotElement..::.GetLabelLine Method
PlotElement Class See Also
Sets the line connecting data point and label for the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static Line GetLabelLine(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetLabelLine ( _
    obj As DependencyObject _
) As Line

Parameters

obj
Type: System.Windows..::.DependencyObject

Return Value

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


GetLabelOffset Method

[image]

.NET Framework Class Library
PlotElement..::.GetLabelOffset Method
PlotElement Class See Also
Gets the labels offset for the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static Point GetLabelOffset(
    DependencyObject obj
)
Visual Basic (Declaration)
Public Shared Function GetLabelOffset ( _
    obj As DependencyObject _
) As Point

Parameters

obj
Type: System.Windows..::.DependencyObject

Return Value

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
PlotElement..::.HitTest Method
PlotElement Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

PlotElement Class
PlotElement Members
C1.Silverlight.Chart Namespace


IsCompatible Method

[image]

.NET Framework Class Library
PlotElement..::.IsCompatible Method
PlotElement Class See Also
Whether the plot element is compatible with the specified renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual bool IsCompatible(
    IRenderer rend
)
Visual Basic (Declaration)
Protected Overridable Function IsCompatible ( _
    rend As IRenderer _
) As Boolean

Parameters

rend
Type: C1.Silverlight.Chart..::.IRenderer

Return Value

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
PlotElement..::.Render Method
PlotElement Class See Also
Renders the element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overridable Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


SetLabelAlignment Method

[image]

.NET Framework Class Library
PlotElement..::.SetLabelAlignment Method
PlotElement Class See Also
Sets the label alignment of the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetLabelAlignment(
    DependencyObject obj,
    LabelAlignment value
)
Visual Basic (Declaration)
Public Shared Sub SetLabelAlignment ( _
    obj As DependencyObject, _
    value As LabelAlignment _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
value
Type: C1.Silverlight.Chart..::.LabelAlignment

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


SetLabelLine Method

[image]

.NET Framework Class Library
PlotElement..::.SetLabelLine Method
PlotElement Class See Also
Gets the line connecting data point and label for the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetLabelLine(
    DependencyObject obj,
    Line line
)
Visual Basic (Declaration)
Public Shared Sub SetLabelLine ( _
    obj As DependencyObject, _
    line As Line _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
line
Type: System.Windows.Shapes..::.Line

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


SetLabelOffset Method

[image]

.NET Framework Class Library
PlotElement..::.SetLabelOffset Method
PlotElement Class See Also
Sets the label offset for the element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static void SetLabelOffset(
    DependencyObject obj,
    Point offset
)
Visual Basic (Declaration)
Public Shared Sub SetLabelOffset ( _
    obj As DependencyObject, _
    offset As Point _
)

Parameters

obj
Type: System.Windows..::.DependencyObject
offset
Type: System.Windows..::.Point

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


PlotElement Properties

[image] [image]

.NET Framework Class Library
PlotElement Properties
PlotElement Class See Also

The PlotElement type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element.
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element.
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the shape of the element for the legend presentation.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element.
Size | Gets or sets the size of the plot element.
Stroke | Gets or sets the stroke brush for the plot element.
StrokeLineJoin | Gets or sets the line join type used by the plot element.
StrokeThickness | Gets or sets the stroke thickness for the plot element.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Center Property

[image]

.NET Framework Class Library
PlotElement..::.Center Property
PlotElement Class See Also
Gets the center of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point Center { get; internal set; }
Visual Basic (Declaration)
Public Property Center As Point

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


DataPoint Property

[image]

.NET Framework Class Library
PlotElement..::.DataPoint Property
PlotElement Class See Also
Gets the data point associated with the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DataPoint DataPoint { get; internal set; }
Visual Basic (Declaration)
Public Property DataPoint As DataPoint

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Fill Property

[image]

.NET Framework Class Library
PlotElement..::.Fill Property
PlotElement Class See Also
Gets or sets the fill brush for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Brush

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IsClustered Property

[image]

.NET Framework Class Library
PlotElement..::.IsClustered Property
PlotElement Class See Also
Whether the plot element can be clustered.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual bool IsClustered { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property IsClustered As Boolean

Remarks

Only for Cartesian plots.

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
PlotElement..::.LegendShape Property
PlotElement Class See Also
Gets the shape of the element for the legend presentation.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property LegendShape As Shape

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


PlotRect Property

[image]

.NET Framework Class Library
PlotElement..::.PlotRect Property
PlotElement Class See Also
Gets the rectangle that limits the plot area.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Rect PlotRect { get; internal set; }
Visual Basic (Declaration)
Public Property PlotRect As Rect

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Shape Property

[image]

.NET Framework Class Library
PlotElement..::.Shape Property
PlotElement Class See Also
Gets the shape of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Shape Shape { get; internal set; }
Visual Basic (Declaration)
Public Property Shape As Shape

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Size Property

[image]

.NET Framework Class Library
PlotElement..::.Size Property
PlotElement Class See Also
Gets or sets the size of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Size Size { get; set; }
Visual Basic (Declaration)
Public Property Size As Size

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Stroke Property

[image]

.NET Framework Class Library
PlotElement..::.Stroke Property
PlotElement Class See Also
Gets or sets the stroke brush for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Brush

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


StrokeLineJoin Property

[image]

.NET Framework Class Library
PlotElement..::.StrokeLineJoin Property
PlotElement Class See Also
Gets or sets the line join type used by the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public PenLineJoin StrokeLineJoin { get; set; }
Visual Basic (Declaration)
Public Property StrokeLineJoin As PenLineJoin

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


StrokeThickness Property

[image]

.NET Framework Class Library
PlotElement..::.StrokeThickness Property
PlotElement Class See Also
Gets or sets the stroke thickness for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


TransformMode Property

[image]

.NET Framework Class Library
PlotElement..::.TransformMode Property
PlotElement Class See Also
Gets or sets the transformation mode for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public TransformMode TransformMode { get; set; }
Visual Basic (Declaration)
Public Property TransformMode As TransformMode

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


PlotElement Events

[image] [image]

.NET Framework Class Library
PlotElement Events
PlotElement Class See Also

The PlotElement type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created.
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded.
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element.
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element.
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element.
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element.
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Created Event

[image]

.NET Framework Class Library
PlotElement..::.Created Event
PlotElement Class See Also
Fires when the plot element was created.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event EventHandler Created
Visual Basic (Declaration)
Public Event Created As EventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


Loaded Event

[image]

.NET Framework Class Library
PlotElement..::.Loaded Event
PlotElement Class See Also
Fires when the plot element is loaded.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event RoutedEventHandler Loaded
Visual Basic (Declaration)
Public Event Loaded As RoutedEventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


MouseEnter Event

[image]

.NET Framework Class Library
PlotElement..::.MouseEnter Event
PlotElement Class See Also
Fires when the mouse pointer enters the bounds of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event MouseEventHandler MouseEnter
Visual Basic (Declaration)
Public Event MouseEnter As MouseEventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


MouseLeave Event

[image]

.NET Framework Class Library
PlotElement..::.MouseLeave Event
PlotElement Class See Also
Fires when the mouse pointer leaves the bounds of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event MouseEventHandler MouseLeave
Visual Basic (Declaration)
Public Event MouseLeave As MouseEventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


MouseLeftButtonDown Event

[image]

.NET Framework Class Library
PlotElement..::.MouseLeftButtonDown Event
PlotElement Class See Also
Fires when the left mouse button is pressed while the mouse pointer is over this element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event MouseButtonEventHandler MouseLeftButtonDown
Visual Basic (Declaration)
Public Event MouseLeftButtonDown As MouseButtonEventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


MouseLeftButtonUp Event

[image]

.NET Framework Class Library
PlotElement..::.MouseLeftButtonUp Event
PlotElement Class See Also
Fires when the left mouse button is released while the mouse pointer is over this element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public event MouseButtonEventHandler MouseLeftButtonUp
Visual Basic (Declaration)
Public Event MouseLeftButtonUp As MouseButtonEventHandler

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


RadarRenderer Class

[image]

.NET Framework Class Library
RadarRenderer Class
Members See Also
Renders radar charts.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class RadarRenderer : BaseRenderer,
    IRenderer
Visual Basic (Declaration)
Public Class RadarRenderer _
    Inherits BaseRenderer _
    Implements IRenderer

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.BaseRenderer
C1.Silverlight.Chart..::.RadarRenderer

See Also

RadarRenderer Members
C1.Silverlight.Chart Namespace


RadarRenderer Members

[image] [image]

.NET Framework Class Library
RadarRenderer Members
RadarRenderer Class Constructors Methods Properties See Also

The RadarRenderer type exposes the following members.

Constructors

Name | Description
RadarRenderer |

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag. (Inherited from BaseRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

RadarRenderer Class
C1.Silverlight.Chart Namespace


RadarRenderer Constructor

[image]

.NET Framework Class Library
RadarRenderer Constructor
RadarRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public RadarRenderer()
Visual Basic (Declaration)
Public Sub New

See Also

RadarRenderer Class
C1.Silverlight.Chart Namespace


RadarRenderer Methods

[image] [image]

.NET Framework Class Library
RadarRenderer Methods
RadarRenderer Class See Also

The RadarRenderer type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag. (Inherited from BaseRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RadarRenderer Class
C1.Silverlight.Chart Namespace


CreateSymbolShape Method

[image] [image]

.NET Framework Class Library
RadarRenderer..::.CreateSymbolShape Method
RadarRenderer Class See Also

Overload List

Name | Description
CreateSymbolShape(DataSeries) | Create symbol shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape(ShapeStyle) | Create symbol shape based on the specified shape style. (Inherited from BaseRenderer.)

See Also

RadarRenderer Class
RadarRenderer Members
C1.Silverlight.Chart Namespace


RadarRenderer Properties

[image] [image]

.NET Framework Class Library
RadarRenderer Properties
RadarRenderer Class See Also

The RadarRenderer type exposes the following members.

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

RadarRenderer Class
C1.Silverlight.Chart Namespace


RenderContext Class

[image]

.NET Framework Class Library
RenderContext Class
Members See Also
Represents the render context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DefaultMemberAttribute("Item")]
public class RenderContext
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<DefaultMemberAttribute("Item")> _
Public Class RenderContext

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.RenderContext
C1.Silverlight.Chart..::.PieRenderContext

See Also

RenderContext Members
C1.Silverlight.Chart Namespace


RenderContext Members

[image] [image]

.NET Framework Class Library
RenderContext Members
RenderContext Class Methods Properties See Also

The RenderContext type exposes the following members.

Methods

Name | Description
ConvertX | Converts x data value to the control coordinate.
ConvertY | Converts y data value to the control coordinate.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Bounds | Gets the range of data values.
Current | Gets the current data point in data coordinates.
CurrentView | Gets the current data point in control(view) coordinates.
Data | Gets the array of data values of current series.
DataSeries | Gets the current data series.
Item | Gets the value of current data point by its name.
PointIndex | Gets the current index of data point.
Points | Gets the array of points for the current data series.
Previous | Gets the previous data point.
PreviousValues | Gets the array of value for the previous data series.
Rect | Gets the rectangle that corresponds to the current data point.
Renderer | Gets the current renderer.

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


RenderContext Methods

[image] [image]

.NET Framework Class Library
RenderContext Methods
RenderContext Class See Also

The RenderContext type exposes the following members.

Methods

Name | Description
ConvertX | Converts x data value to the control coordinate.
ConvertY | Converts y data value to the control coordinate.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


ConvertX Method

[image]

.NET Framework Class Library
RenderContext..::.ConvertX Method
RenderContext Class See Also
Converts x data value to the control coordinate.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double ConvertX(
    double x
)
Visual Basic (Declaration)
Public Function ConvertX ( _
    x As Double _
) As Double

Parameters

x
Type: System..::.Double
X data value

Return Value

Value in control coordinates corresponding to given data value.

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


ConvertY Method

[image]

.NET Framework Class Library
RenderContext..::.ConvertY Method
RenderContext Class See Also
Converts y data value to the control coordinate.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double ConvertY(
    double y
)
Visual Basic (Declaration)
Public Function ConvertY ( _
    y As Double _
) As Double

Parameters

y
Type: System..::.Double
Y data value.

Return Value

Value in control coordinates corresponding to given data value.

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


RenderContext Properties

[image] [image]

.NET Framework Class Library
RenderContext Properties
RenderContext Class See Also

The RenderContext type exposes the following members.

Properties

Name | Description
Bounds | Gets the range of data values.
Current | Gets the current data point in data coordinates.
CurrentView | Gets the current data point in control(view) coordinates.
Data | Gets the array of data values of current series.
DataSeries | Gets the current data series.
Item | Gets the value of current data point by its name.
PointIndex | Gets the current index of data point.
Points | Gets the array of points for the current data series.
Previous | Gets the previous data point.
PreviousValues | Gets the array of value for the previous data series.
Rect | Gets the rectangle that corresponds to the current data point.
Renderer | Gets the current renderer.

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Bounds Property

[image]

.NET Framework Class Library
RenderContext..::.Bounds Property
RenderContext Class See Also
Gets the range of data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Rect Bounds { get; set; }
Visual Basic (Declaration)
Public Property Bounds As Rect

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Current Property

[image]

.NET Framework Class Library
RenderContext..::.Current Property
RenderContext Class See Also
Gets the current data point in data coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point Current { get; set; }
Visual Basic (Declaration)
Public Property Current As Point

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


CurrentView Property

[image]

.NET Framework Class Library
RenderContext..::.CurrentView Property
RenderContext Class See Also
Gets the current data point in control(view) coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point CurrentView { get; set; }
Visual Basic (Declaration)
Public Property CurrentView As Point

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Data Property

[image]

.NET Framework Class Library
RenderContext..::.Data Property
RenderContext Class See Also
Gets the array of data values of current series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double[] Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As Double()

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


DataSeries Property

[image]

.NET Framework Class Library
RenderContext..::.DataSeries Property
RenderContext Class See Also
Gets the current data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IDataSeriesInfo DataSeries { get; internal set; }
Visual Basic (Declaration)
Public Property DataSeries As IDataSeriesInfo

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Item Property

[image]

.NET Framework Class Library
RenderContext..::.Item Property
RenderContext Class See Also
Gets the value of current data point by its name.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double this[
    string name
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    name As String _
) As Double

Parameters

name
Type: System..::.String
The name of data array.

Return Value

The data value.

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


PointIndex Property

[image]

.NET Framework Class Library
RenderContext..::.PointIndex Property
RenderContext Class See Also
Gets the current index of data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public int PointIndex { get; }
Visual Basic (Declaration)
Public ReadOnly Property PointIndex As Integer

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Points Property

[image]

.NET Framework Class Library
RenderContext..::.Points Property
RenderContext Class See Also
Gets the array of points for the current data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point[] Points { get; }
Visual Basic (Declaration)
Public ReadOnly Property Points As Point()

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Previous Property

[image]

.NET Framework Class Library
RenderContext..::.Previous Property
RenderContext Class See Also
Gets the previous data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Point Previous { get; set; }
Visual Basic (Declaration)
Public Property Previous As Point

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


PreviousValues Property

[image]

.NET Framework Class Library
RenderContext..::.PreviousValues Property
RenderContext Class See Also
Gets the array of value for the previous data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double[] PreviousValues { get; }
Visual Basic (Declaration)
Public ReadOnly Property PreviousValues As Double()

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Rect Property

[image]

.NET Framework Class Library
RenderContext..::.Rect Property
RenderContext Class See Also
Gets the rectangle that corresponds to the current data point.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Rect Rect { get; internal set; }
Visual Basic (Declaration)
Public Property Rect As Rect

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Renderer Property

[image]

.NET Framework Class Library
RenderContext..::.Renderer Property
RenderContext Class See Also
Gets the current renderer.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IRenderer Renderer { get; }
Visual Basic (Declaration)
Public ReadOnly Property Renderer As IRenderer

See Also

RenderContext Class
C1.Silverlight.Chart Namespace


Renderer2D Class

[image]

.NET Framework Class Library
Renderer2D Class
Members See Also
Renderer which creates plot in Cartesian coordinates.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Renderer2D : BaseRenderer, IRenderer
Visual Basic (Declaration)
Public Class Renderer2D _
    Inherits BaseRenderer _
    Implements IRenderer

Remarks

Renderer2D allows creating most of 2D chart types that use Cartesian axes including bar, area, line, scatter charts. The specific presentation of the data values is defined by templates (Symbol and Connection properties). The templates can also be set using corresponding properties of DataSeries class.

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.BaseRenderer
C1.Silverlight.Chart..::.Renderer2D

See Also

Renderer2D Members
C1.Silverlight.Chart Namespace


Renderer2D Members

[image] [image]

.NET Framework Class Library
Renderer2D Members
Renderer2D Class Constructors Methods Properties See Also

The Renderer2D type exposes the following members.

Constructors

Name | Description
Renderer2D | Initializes a new instance of Renderer2D class.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag. (Inherited from BaseRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

Renderer2D Class
C1.Silverlight.Chart Namespace


Renderer2D Constructor

[image]

.NET Framework Class Library
Renderer2D Constructor
Renderer2D Class See Also
Initializes a new instance of Renderer2D class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Renderer2D()
Visual Basic (Declaration)
Public Sub New

See Also

Renderer2D Class
C1.Silverlight.Chart Namespace


Renderer2D Methods

[image] [image]

.NET Framework Class Library
Renderer2D Methods
Renderer2D Class See Also

The Renderer2D type exposes the following members.

Methods

Name | Description
AnalyzeData | Analyses data values, finds data limits. (Inherited from BaseRenderer.)
CreateElement | Create plot element based on specified template and style. (Inherited from BaseRenderer.)
CreateLineShape | Create line shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
InitOptions | Add options to the bag. (Inherited from BaseRenderer.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RenderConnection | Renders connection and returns the created element. (Inherited from BaseRenderer.)
RenderElement | Renders the element and add it to the specified list. (Inherited from BaseRenderer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Renderer2D Class
C1.Silverlight.Chart Namespace


CreateSymbolShape Method

[image] [image]

.NET Framework Class Library
Renderer2D..::.CreateSymbolShape Method
Renderer2D Class See Also

Overload List

Name | Description
CreateSymbolShape(DataSeries) | Create symbol shape based on the specified data series. (Inherited from BaseRenderer.)
CreateSymbolShape(ShapeStyle) | Create symbol shape based on the specified shape style. (Inherited from BaseRenderer.)

See Also

Renderer2D Class
Renderer2D Members
C1.Silverlight.Chart Namespace


Renderer2D Properties

[image] [image]

.NET Framework Class Library
Renderer2D Properties
Renderer2D Class See Also

The Renderer2D type exposes the following members.

Properties

Name | Description
ColorScheme | Gets or sets how the colors are assigned to the plot elements. (Inherited from BaseRenderer.)
Connection | Gets or sets the data template that is used for visualization of all data points of the series. (Inherited from BaseRenderer.)
CoordConverter | Gets or sets coordinate mapping engine. (Inherited from BaseRenderer.)
Inverted | Gets or sets whether the direction of plotting is inverted. (Inherited from BaseRenderer.)
SizeX | Gets or sets the size of data element along x-axis. (Inherited from BaseRenderer.)
SizeY | Gets or sets the size of data element along y-axis. (Inherited from BaseRenderer.)
Stacked | Gets or sets the stacked options of the plot. (Inherited from BaseRenderer.)
Symbol | Gets or sets the data template that is used for data point visualization. (Inherited from BaseRenderer.)

See Also

Renderer2D Class
C1.Silverlight.Chart Namespace


RPolygon Class

[image]

.NET Framework Class Library
RPolygon Class
Members See Also
Represents regular polygon.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class RPolygon : Symbol
Visual Basic (Declaration)
Public Class RPolygon _
    Inherits Symbol

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Symbol
C1.Silverlight.Chart..::.RPolygon
C1.Silverlight.Chart..::.Star

See Also

RPolygon Members
C1.Silverlight.Chart Namespace


RPolygon Members

[image] [image]

.NET Framework Class Library
RPolygon Members
RPolygon Class Constructors Methods Fields Properties Events See Also

The RPolygon type exposes the following members.

Constructors

Name | Description
RPolygon | Initializes a new instance of RPolygon class.

Methods

Name | Description
AddFakeEllipse | Creates and adds ellipse geometry that is used for hit testing.
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Inherited from Symbol.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Inherited from Symbol.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol. (Overrides Symbol..::.UpdateGeometry(PathGeometry, Size).)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol. (Inherited from Symbol.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element. (Inherited from Symbol.)
NumVerticesProperty | Identifies the NumVertices dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape of plot element. (Overrides Symbol..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NumVertices | Gets or sets number of polygon vertices.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


RPolygon Constructor

[image]

.NET Framework Class Library
RPolygon Constructor
RPolygon Class See Also
Initializes a new instance of RPolygon class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public RPolygon()
Visual Basic (Declaration)
Public Sub New

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


RPolygon Fields

[image] [image]

.NET Framework Class Library
RPolygon Fields
RPolygon Class See Also

The RPolygon type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol. (Inherited from Symbol.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element. (Inherited from Symbol.)
NumVerticesProperty | Identifies the NumVertices dependency property.

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


NumVerticesProperty Field

[image]

.NET Framework Class Library
RPolygon..::.NumVerticesProperty Field
RPolygon Class See Also
Identifies the NumVertices dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty NumVerticesProperty
Visual Basic (Declaration)
Public Shared ReadOnly NumVerticesProperty As DependencyProperty

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


RPolygon Methods

[image] [image]

.NET Framework Class Library
RPolygon Methods
RPolygon Class See Also

The RPolygon type exposes the following members.

Methods

Name | Description
AddFakeEllipse | Creates and adds ellipse geometry that is used for hit testing.
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Inherited from Symbol.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Inherited from Symbol.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol. (Overrides Symbol..::.UpdateGeometry(PathGeometry, Size).)
UpdateLayout | (Inherited from UIElement.)

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


AddFakeEllipse Method

[image]

.NET Framework Class Library
RPolygon..::.AddFakeEllipse Method
RPolygon Class See Also
Creates and adds ellipse geometry that is used for hit testing.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected void AddFakeEllipse(
    PathGeometry pg,
    Point center,
    double rx,
    double ry,
    double w2
)
Visual Basic (Declaration)
Protected Sub AddFakeEllipse ( _
    pg As PathGeometry, _
    center As Point, _
    rx As Double, _
    ry As Double, _
    w2 As Double _
)

Parameters

pg
Type: System.Windows.Media..::.PathGeometry
center
Type: System.Windows..::.Point
rx
Type: System..::.Double
ry
Type: System..::.Double
w2
Type: System..::.Double

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
RPolygon..::.HitTest Method
RPolygon Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

RPolygon Class
RPolygon Members
C1.Silverlight.Chart Namespace


UpdateGeometry Method

[image]

.NET Framework Class Library
RPolygon..::.UpdateGeometry Method
RPolygon Class See Also
Recreates the geometry describing the symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void UpdateGeometry(
    PathGeometry pg,
    Size sz
)
Visual Basic (Declaration)
Protected Overrides Sub UpdateGeometry ( _
    pg As PathGeometry, _
    sz As Size _
)

Parameters

pg
Type: System.Windows.Media..::.PathGeometry
sz
Type: System.Windows..::.Size

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


RPolygon Properties

[image] [image]

.NET Framework Class Library
RPolygon Properties
RPolygon Class See Also

The RPolygon type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape of plot element. (Overrides Symbol..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NumVertices | Gets or sets number of polygon vertices.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
RPolygon..::.LegendShape Property
RPolygon Class See Also
Gets the legend shape of plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


NumVertices Property

[image]

.NET Framework Class Library
RPolygon..::.NumVertices Property
RPolygon Class See Also
Gets or sets number of polygon vertices.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public int NumVertices { get; set; }
Visual Basic (Declaration)
Public Property NumVertices As Integer

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


RPolygon Events

[image] [image]

.NET Framework Class Library
RPolygon Events
RPolygon Class See Also

The RPolygon type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

RPolygon Class
C1.Silverlight.Chart Namespace


ScaleAction Class

[image]

.NET Framework Class Library
ScaleAction Class
Members See Also
Represents the scale action.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class ScaleAction : Action
Visual Basic (Declaration)
Public Class ScaleAction _
    Inherits Action

Remarks

The MinScale property of Axis property specifies the minimum scale that can set for the axis. If MinScale is equal to 1 the zoom is not applied to the axis.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.Action
C1.Silverlight.Chart..::.ScaleAction

See Also

ScaleAction Members
C1.Silverlight.Chart Namespace


ScaleAction Members

[image] [image]

.NET Framework Class Library
ScaleAction Members
ScaleAction Class Constructors Methods Properties See Also

The ScaleAction type exposes the following members.

Constructors

Name | Description
ScaleAction | Creates a new instance of the ScaleAction class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)

See Also

ScaleAction Class
C1.Silverlight.Chart Namespace


ScaleAction Constructor

[image]

.NET Framework Class Library
ScaleAction Constructor
ScaleAction Class See Also
Creates a new instance of the ScaleAction class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ScaleAction()
Visual Basic (Declaration)
Public Sub New

See Also

ScaleAction Class
C1.Silverlight.Chart Namespace


ScaleAction Methods

[image] [image]

.NET Framework Class Library
ScaleAction Methods
ScaleAction Class See Also

The ScaleAction type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleAction Class
C1.Silverlight.Chart Namespace


ScaleAction Properties

[image] [image]

.NET Framework Class Library
ScaleAction Properties
ScaleAction Class See Also

The ScaleAction type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)

See Also

ScaleAction Class
C1.Silverlight.Chart Namespace


SeriesDisplay Enumeration

[image]

.NET Framework Class Library
SeriesDisplay Enumeration
See Also
Specifies various display options for data series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum SeriesDisplay
Visual Basic (Declaration)
Public Enumeration SeriesDisplay

Members

Member name | Description
SkipNaN | Skip NaN values(default) behavior.
ShowNaNGap | Gaps are shown if there are NaN values in data.

See Also

C1.Silverlight.Chart Namespace


ShapeStyle Class

[image]

.NET Framework Class Library
ShapeStyle Class
Members See Also
Describes shape appearance.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class ShapeStyle
Visual Basic (Declaration)
Public Class ShapeStyle

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Chart..::.ShapeStyle

See Also

ShapeStyle Members
C1.Silverlight.Chart Namespace


ShapeStyle Members

[image] [image]

.NET Framework Class Library
ShapeStyle Members
ShapeStyle Class Constructors Methods Properties See Also

The ShapeStyle type exposes the following members.

Constructors

Name | Description
ShapeStyle | Creates an instance of shape style.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Fill | Gets or sets the fill brush of the shape.
RenderTransform | Gets or sets the render transform of the shape.
Stroke | Gets or sets the stroke brush of the shape.
StrokeDashArray | Gets or sets the stroke dash array of the shape.
StrokeThickness | Gets or sets the stroke thickness of the shape.

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


ShapeStyle Constructor

[image]

.NET Framework Class Library
ShapeStyle Constructor
ShapeStyle Class See Also
Creates an instance of shape style.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ShapeStyle()
Visual Basic (Declaration)
Public Sub New

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


ShapeStyle Methods

[image] [image]

.NET Framework Class Library
ShapeStyle Methods
ShapeStyle Class See Also

The ShapeStyle type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


ShapeStyle Properties

[image] [image]

.NET Framework Class Library
ShapeStyle Properties
ShapeStyle Class See Also

The ShapeStyle type exposes the following members.

Properties

Name | Description
Fill | Gets or sets the fill brush of the shape.
RenderTransform | Gets or sets the render transform of the shape.
Stroke | Gets or sets the stroke brush of the shape.
StrokeDashArray | Gets or sets the stroke dash array of the shape.
StrokeThickness | Gets or sets the stroke thickness of the shape.

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


Fill Property

[image]

.NET Framework Class Library
ShapeStyle..::.Fill Property
ShapeStyle Class See Also
Gets or sets the fill brush of the shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Brush

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


RenderTransform Property

[image]

.NET Framework Class Library
ShapeStyle..::.RenderTransform Property
ShapeStyle Class See Also
Gets or sets the render transform of the shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Transform RenderTransform { get; set; }
Visual Basic (Declaration)
Public Property RenderTransform As Transform

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


Stroke Property

[image]

.NET Framework Class Library
ShapeStyle..::.Stroke Property
ShapeStyle Class See Also
Gets or sets the stroke brush of the shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Brush

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


StrokeDashArray Property

[image]

.NET Framework Class Library
ShapeStyle..::.StrokeDashArray Property
ShapeStyle Class See Also
Gets or sets the stroke dash array of the shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection StrokeDashArray { get; set; }
Visual Basic (Declaration)
Public Property StrokeDashArray As DoubleCollection

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


StrokeThickness Property

[image]

.NET Framework Class Library
ShapeStyle..::.StrokeThickness Property
ShapeStyle Class See Also
Gets or sets the stroke thickness of the shape.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double

See Also

ShapeStyle Class
C1.Silverlight.Chart Namespace


StackedOptions Enumeration

[image]

.NET Framework Class Library
StackedOptions Enumeration
See Also
Specifies options of stacked chart.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum StackedOptions
Visual Basic (Declaration)
Public Enumeration StackedOptions

Members

Member name | Description
None | Normal (non-stacked) chart.
Stacked | Stacked chart.
Stacked100pc | Stacked 100% chart.

See Also

C1.Silverlight.Chart Namespace


Star Class

[image]

.NET Framework Class Library
Star Class
Members See Also
Represents star symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Star : RPolygon
Visual Basic (Declaration)
Public Class Star _
    Inherits RPolygon

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Symbol
C1.Silverlight.Chart..::.RPolygon
C1.Silverlight.Chart..::.Star

See Also

Star Members
C1.Silverlight.Chart Namespace


Star Members

[image] [image]

.NET Framework Class Library
Star Members
Star Class Constructors Methods Fields Properties Events See Also

The Star type exposes the following members.

Constructors

Name | Description
Star | Creates an instance of Star class.

Methods

Name | Description
AddFakeEllipse | Creates and adds ellipse geometry that is used for hit testing. (Inherited from RPolygon.)
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Inherited from Symbol.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Inherited from Symbol.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol. (Overrides RPolygon..::.UpdateGeometry(PathGeometry, Size).)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol. (Inherited from Symbol.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element. (Inherited from Symbol.)
InnerRadiusProperty | Identifies the InnerRadius dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InnerRadius | Gets or sets the inner radius of symbol.
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape of plot element. (Inherited from RPolygon.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NumVertices | Gets or sets number of polygon vertices. (Inherited from RPolygon.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Star Class
C1.Silverlight.Chart Namespace


Star Constructor

[image]

.NET Framework Class Library
Star Constructor
Star Class See Also
Creates an instance of Star class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Star()
Visual Basic (Declaration)
Public Sub New

See Also

Star Class
C1.Silverlight.Chart Namespace


Star Fields

[image] [image]

.NET Framework Class Library
Star Fields
Star Class See Also

The Star type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol. (Inherited from Symbol.)
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element. (Inherited from Symbol.)
InnerRadiusProperty | Identifies the InnerRadius dependency property.

See Also

Star Class
C1.Silverlight.Chart Namespace


InnerRadiusProperty Field

[image]

.NET Framework Class Library
Star..::.InnerRadiusProperty Field
Star Class See Also
Identifies the InnerRadius dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty InnerRadiusProperty
Visual Basic (Declaration)
Public Shared ReadOnly InnerRadiusProperty As DependencyProperty

See Also

Star Class
C1.Silverlight.Chart Namespace


Star Methods

[image] [image]

.NET Framework Class Library
Star Methods
Star Class See Also

The Star type exposes the following members.

Methods

Name | Description
AddFakeEllipse | Creates and adds ellipse geometry that is used for hit testing. (Inherited from RPolygon.)
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Inherited from Symbol.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Inherited from Symbol.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol. (Overrides RPolygon..::.UpdateGeometry(PathGeometry, Size).)
UpdateLayout | (Inherited from UIElement.)

See Also

Star Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Star..::.HitTest Method
Star Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Star Class
Star Members
C1.Silverlight.Chart Namespace


UpdateGeometry Method

[image]

.NET Framework Class Library
Star..::.UpdateGeometry Method
Star Class See Also
Recreates the geometry describing the symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override void UpdateGeometry(
    PathGeometry pg,
    Size sz
)
Visual Basic (Declaration)
Protected Overrides Sub UpdateGeometry ( _
    pg As PathGeometry, _
    sz As Size _
)

Parameters

pg
Type: System.Windows.Media..::.PathGeometry
sz
Type: System.Windows..::.Size

See Also

Star Class
C1.Silverlight.Chart Namespace


Star Properties

[image] [image]

.NET Framework Class Library
Star Properties
Star Class See Also

The Star type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InnerRadius | Gets or sets the inner radius of symbol.
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape of plot element. (Inherited from RPolygon.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NumVertices | Gets or sets number of polygon vertices. (Inherited from RPolygon.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Star Class
C1.Silverlight.Chart Namespace


InnerRadius Property

[image]

.NET Framework Class Library
Star..::.InnerRadius Property
Star Class See Also
Gets or sets the inner radius of symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public double InnerRadius { get; set; }
Visual Basic (Declaration)
Public Property InnerRadius As Double

See Also

Star Class
C1.Silverlight.Chart Namespace


Star Events

[image] [image]

.NET Framework Class Library
Star Events
Star Class See Also

The Star type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Star Class
C1.Silverlight.Chart Namespace


Symbol Class

[image]

.NET Framework Class Library
Symbol Class
Members See Also
Represents base class for 2D plot symbols.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class Symbol : PlotElement
Visual Basic (Declaration)
Public Class Symbol _
    Inherits PlotElement

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentPresenter
C1.Silverlight.Chart..::.PlotElement
C1.Silverlight.Chart..::.Symbol
C1.Silverlight.Chart..::.RPolygon

See Also

Symbol Members
C1.Silverlight.Chart Namespace


Symbol Members

[image] [image]

.NET Framework Class Library
Symbol Members
Symbol Class Constructors Methods Fields Properties Events See Also

The Symbol type exposes the following members.

Constructors

Name | Description
Symbol |

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol.
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol.
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Symbol Constructor

[image]

.NET Framework Class Library
Symbol Constructor
Symbol Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Symbol()
Visual Basic (Declaration)
Public Sub New

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Symbol Fields

[image] [image]

.NET Framework Class Library
Symbol Fields
Symbol Class See Also

The Symbol type exposes the following members.

Fields

Name | Description
_autoStyle | Stores automatic shape style that was set to the plot element. (Inherited from PlotElement.)
_center | Stores the center point of the symbol.
_fill | Whether the plot element should be filled. (Inherited from PlotElement.)
_geometry | Contains geometry of element.

See Also

Symbol Class
C1.Silverlight.Chart Namespace


_center Field

[image]

.NET Framework Class Library
Symbol..::._center Field
Symbol Class See Also
Stores the center point of the symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected Point _center
Visual Basic (Declaration)
Protected _center As Point

See Also

Symbol Class
C1.Silverlight.Chart Namespace


_geometry Field

[image]

.NET Framework Class Library
Symbol..::._geometry Field
Symbol Class See Also
Contains geometry of element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected Geometry _geometry
Visual Basic (Declaration)
Protected _geometry As Geometry

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Symbol Methods

[image] [image]

.NET Framework Class Library
Symbol Methods
Symbol Class See Also

The Symbol type exposes the following members.

Methods

Name | Description
AdjustLegendShape | Adjusts property of legend shape. (Inherited from PlotElement.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
AutoPosition | Calculates automatic position of data label. (Inherited from PlotElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CloneAttributes | Clone the attributes of the plot element. (Inherited from PlotElement.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsCompatible | Whether the plot element is compatible with the specified renderer. (Inherited from PlotElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size of the plot element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Render | Renders the plot element based on the specified context. (Overrides PlotElement..::.Render(RenderContext).)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateGeometry | Recreates the geometry describing the symbol.
UpdateLayout | (Inherited from UIElement.)

See Also

Symbol Class
C1.Silverlight.Chart Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
Symbol..::.HitTest Method
Symbol Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

Symbol Class
Symbol Members
C1.Silverlight.Chart Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
Symbol..::.MeasureOverride Method
Symbol Class See Also
Measures the size of the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size constraint
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    constraint As Size _
) As Size

Parameters

constraint
Type: System.Windows..::.Size

Return Value

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Render Method

[image]

.NET Framework Class Library
Symbol..::.Render Method
Symbol Class See Also
Renders the plot element based on the specified context.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override bool Render(
    RenderContext rc
)
Visual Basic (Declaration)
Protected Overrides Function Render ( _
    rc As RenderContext _
) As Boolean

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Return Value

See Also

Symbol Class
C1.Silverlight.Chart Namespace


UpdateGeometry Method

[image]

.NET Framework Class Library
Symbol..::.UpdateGeometry Method
Symbol Class See Also
Recreates the geometry describing the symbol.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected virtual void UpdateGeometry(
    PathGeometry pg,
    Size sz
)
Visual Basic (Declaration)
Protected Overridable Sub UpdateGeometry ( _
    pg As PathGeometry, _
    sz As Size _
)

Parameters

pg
Type: System.Windows.Media..::.PathGeometry
sz
Type: System.Windows..::.Size

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Symbol Properties

[image] [image]

.NET Framework Class Library
Symbol Properties
Symbol Class See Also

The Symbol type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets the center of the plot element. (Inherited from PlotElement.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentPresenter.)
ContentTemplate | (Inherited from ContentPresenter.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DataPoint | Gets the data point associated with the plot element. (Inherited from PlotElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush for the plot element. (Inherited from PlotElement.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsClustered | Whether the plot element can be clustered. (Inherited from PlotElement.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
LegendShape | Gets the legend shape for the plot element. (Overrides PlotElement..::.LegendShape.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PlotRect | Gets the rectangle that limits the plot area. (Inherited from PlotElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Shape | Gets the shape of the plot element. (Inherited from PlotElement.)
Size | Gets or sets the size of the plot element. (Inherited from PlotElement.)
Stroke | Gets or sets the stroke brush for the plot element. (Inherited from PlotElement.)
StrokeLineJoin | Gets or sets the line join type used by the plot element. (Inherited from PlotElement.)
StrokeThickness | Gets or sets the stroke thickness for the plot element. (Inherited from PlotElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentPresenter.)
TextDecorations | (Inherited from ContentPresenter.)
TextWrapping | (Inherited from ContentPresenter.)
TransformMode | Gets or sets the transformation mode for the plot element. (Inherited from PlotElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

Symbol Class
C1.Silverlight.Chart Namespace


LegendShape Property

[image]

.NET Framework Class Library
Symbol..::.LegendShape Property
Symbol Class See Also
Gets the legend shape for the plot element.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected override Shape LegendShape { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property LegendShape As Shape

See Also

Symbol Class
C1.Silverlight.Chart Namespace


Symbol Events

[image] [image]

.NET Framework Class Library
Symbol Events
Symbol Class See Also

The Symbol type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Created | Fires when the plot element was created. (Inherited from PlotElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | Fires when the plot element is loaded. (Inherited from PlotElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | Fires when the mouse pointer enters the bounds of the plot element. (Inherited from PlotElement.)
MouseLeave | Fires when the mouse pointer leaves the bounds of the plot element. (Inherited from PlotElement.)
MouseLeftButtonDown | Fires when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseLeftButtonUp | Fires when the left mouse button is released while the mouse pointer is over this element. (Inherited from PlotElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

Symbol Class
C1.Silverlight.Chart Namespace


TransformMode Enumeration

[image]

.NET Framework Class Library
TransformMode Enumeration
See Also
Specifies transformation mode for plot elements.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public enum TransformMode
Visual Basic (Declaration)
Public Enumeration TransformMode

Members

Member name | Description
Relative | Transformation is relative to the center of the plot element.
Absolute | Transformation is applied based on the absolute control coordinates.

See Also

C1.Silverlight.Chart Namespace


TranslateAction Class

[image]

.NET Framework Class Library
TranslateAction Class
Members See Also
Represents translate action.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class TranslateAction : Action
Visual Basic (Declaration)
Public Class TranslateAction _
    Inherits Action

Remarks

The Scale property of Axis should less than 1. Otherwise the translate along the axis is not available.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.Action
C1.Silverlight.Chart..::.TranslateAction

See Also

TranslateAction Members
C1.Silverlight.Chart Namespace


TranslateAction Members

[image] [image]

.NET Framework Class Library
TranslateAction Members
TranslateAction Class Constructors Methods Properties See Also

The TranslateAction type exposes the following members.

Constructors

Name | Description
TranslateAction | Creates a new instance of the TranslateAction class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)

See Also

TranslateAction Class
C1.Silverlight.Chart Namespace


TranslateAction Constructor

[image]

.NET Framework Class Library
TranslateAction Constructor
TranslateAction Class See Also
Creates a new instance of the TranslateAction class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public TranslateAction()
Visual Basic (Declaration)
Public Sub New

See Also

TranslateAction Class
C1.Silverlight.Chart Namespace


TranslateAction Methods

[image] [image]

.NET Framework Class Library
TranslateAction Methods
TranslateAction Class See Also

The TranslateAction type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TranslateAction Class
C1.Silverlight.Chart Namespace


TranslateAction Properties

[image] [image]

.NET Framework Class Library
TranslateAction Properties
TranslateAction Class See Also

The TranslateAction type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)

See Also

TranslateAction Class
C1.Silverlight.Chart Namespace


ValueCoordinate Enumeration

[image]

.NET Framework Class Library
ValueCoordinate Enumeration
See Also
Specifies which coordinate corresponds to the data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public enum ValueCoordinate
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Enumeration ValueCoordinate

Members

Member name | Description
None | None or default.
X | X-coordinate.
Y | Y-coordinate.
Z | Z-coordinate.
Size | Size-coordinate.

See Also

C1.Silverlight.Chart Namespace


XYDataSeries Class

[image]

.NET Framework Class Library
XYDataSeries Class
Members See Also
Represents data series with X- and Y-values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class XYDataSeries : DataSeries
Visual Basic (Declaration)
Public Class XYDataSeries _
    Inherits DataSeries

Remarks

The XYDataSeries class has two sets of data values (for x-coordinates and for y-coordinates).

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.DataSeries
C1.Silverlight.Chart..::.XYDataSeries
C1.Silverlight.Chart..::.BubbleSeries
C1.Silverlight.Chart..::.HighLowSeries

See Also

XYDataSeries Members
C1.Silverlight.Chart Namespace


XYDataSeries Members

[image] [image]

.NET Framework Class Library
XYDataSeries Members
XYDataSeries Class Constructors Methods Fields Properties Events See Also

The XYDataSeries type exposes the following members.

Constructors

Name | Description
XYDataSeries | Creates an instance of XYDataSeries class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

Fields

Name | Description
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values.
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
XValuesSourceProperty | Identifies the XValuesSource dependency property.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides DataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values.
XValues | Gets or set the x-data values collection.
XValuesSource | Gets or sets the x-data values source.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XYDataSeries Constructor

[image]

.NET Framework Class Library
XYDataSeries Constructor
XYDataSeries Class See Also
Creates an instance of XYDataSeries class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public XYDataSeries()
Visual Basic (Declaration)
Public Sub New

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XYDataSeries Fields

[image] [image]

.NET Framework Class Library
XYDataSeries Fields
XYDataSeries Class See Also

The XYDataSeries type exposes the following members.

Fields

Name | Description
_isDefCon | Whether the connection template is default. (Inherited from DataSeries.)
_isDefSym | Whether the symbol template is default. (Inherited from DataSeries.)
_listX | Temporary list for x-values.
_listY | Temporary list of y-values. (Inherited from DataSeries.)
_values | Cached data values. (Inherited from DataSeries.)
XValuesSourceProperty | Identifies the XValuesSource dependency property.

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


_listX Field

[image]

.NET Framework Class Library
XYDataSeries..::._listX Field
XYDataSeries Class See Also
Temporary list for x-values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
protected List<Object> _listX
Visual Basic (Declaration)
Protected _listX As List(Of Object)

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XValuesSourceProperty Field

[image]

.NET Framework Class Library
XYDataSeries..::.XValuesSourceProperty Field
XYDataSeries Class See Also
Identifies the XValuesSource dependency property.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public static readonly DependencyProperty XValuesSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly XValuesSourceProperty As DependencyProperty

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XYDataSeries Methods

[image] [image]

.NET Framework Class Library
XYDataSeries Methods
XYDataSeries Class See Also

The XYDataSeries type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDataValue | Get data value with specified name at the specified index. (Inherited from DataSeries.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns string representation of the data series. (Inherited from DataSeries.)

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XYDataSeries Properties

[image] [image]

.NET Framework Class Library
XYDataSeries Properties
XYDataSeries Class See Also

The XYDataSeries type exposes the following members.

Properties

Name | Description
AxisX | Gets or sets the name of auxiliary axis that is used as x-axis for the series. (Inherited from DataSeries.)
AxisY | Gets or sets the name of auxiliary axis that is used as y-axis for the series. (Inherited from DataSeries.)
Connection | Gets or sets the connection template which applies to whole set of data points of series. (Inherited from DataSeries.)
ConnectionFill | Gets or sets the connection fill brush. (Inherited from DataSeries.)
ConnectionStroke | Gets or sets the connection outline brush. (Inherited from DataSeries.)
ConnectionStrokeDashes | Gets or sets the dash pattern of connection stroke. (Inherited from DataSeries.)
ConnectionStrokeThickness | Gets or sets the connection outline thickness. (Inherited from DataSeries.)
ConnectionStyle | Gets or sets the style of connection. (Inherited from DataSeries.)
Dirty | Gets or sets whether the data values array should be regenerated. (Inherited from DataSeries.)
Dispatcher | (Inherited from DependencyObject.)
Display | Gets or sets the symbol marker. (Inherited from DataSeries.)
Label | Gets or sets the text label of data series. (Inherited from DataSeries.)
MemberPaths | Gets the array of member bindings for the series. (Overrides DataSeries..::.MemberPaths.)
Opacity | Gets or sets the symbol marker. (Inherited from DataSeries.)
PointLabelTemplate | Gets or sets the template for data point label. (Inherited from DataSeries.)
PointTooltipTemplate | Gets or sets the template for data point tooltip. (Inherited from DataSeries.)
Symbol | Gets or sets the symbol template which applies to the each data point of the series. (Inherited from DataSeries.)
SymbolFill | Gets or sets the symbol fill brush. (Inherited from DataSeries.)
SymbolMarker | Gets or sets the symbol marker. (Inherited from DataSeries.)
SymbolSize | Gets or sets the symbol size in pixels. (Inherited from DataSeries.)
SymbolStroke | Gets or sets the symbol outline brush. (Inherited from DataSeries.)
SymbolStrokeDashes | Gets or sets the dash pattern of symbol stroke. (Inherited from DataSeries.)
SymbolStrokeThickness | Gets or sets the symbol outline thickness. (Inherited from DataSeries.)
SymbolStyle | Gets or sets the style of symbol. (Inherited from DataSeries.)
Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from DataSeries.)
ValueBinding | Gets or sets the value binding. (Inherited from DataSeries.)
Values | Gets the data values collection. (Inherited from DataSeries.)
ValuesSource | Gets or sets the data values source. (Inherited from DataSeries.)
XValueBinding | Gets or sets binding for x data values.
XValues | Gets or set the x-data values collection.
XValuesSource | Gets or sets the x-data values source.

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


MemberPaths Property

[image]

.NET Framework Class Library
XYDataSeries..::.MemberPaths Property
XYDataSeries Class See Also
Gets the array of member bindings for the series.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public override Binding[] MemberPaths { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property MemberPaths As Binding()

Implements

IDataSeriesInfo..::.MemberPaths

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XValueBinding Property

[image]

.NET Framework Class Library
XYDataSeries..::.XValueBinding Property
XYDataSeries Class See Also
Gets or sets binding for x data values.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Binding XValueBinding { get; set; }
Visual Basic (Declaration)
Public Property XValueBinding As Binding

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XValues Property

[image]

.NET Framework Class Library
XYDataSeries..::.XValues Property
XYDataSeries Class See Also
Gets or set the x-data values collection.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public DoubleCollection XValues { get; set; }
Visual Basic (Declaration)
Public Property XValues As DoubleCollection

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XValuesSource Property

[image]

.NET Framework Class Library
XYDataSeries..::.XValuesSource Property
XYDataSeries Class See Also
Gets or sets the x-data values source.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public IEnumerable XValuesSource { get; set; }
Visual Basic (Declaration)
Public Property XValuesSource As IEnumerable

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


XYDataSeries Events

[image] [image]

.NET Framework Class Library
XYDataSeries Events
XYDataSeries Class See Also

The XYDataSeries type exposes the following members.

Events

Name | Description
Loaded | Fires when plot element associated with this data series is loaded. (Inherited from DataSeries.)
PropertyChanged | Fires when a property value was changed. (Inherited from DataSeries.)

See Also

XYDataSeries Class
C1.Silverlight.Chart Namespace


ZoomAction Class

[image]

.NET Framework Class Library
ZoomAction Class
Members See Also
Represents zoom action.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public class ZoomAction : Action
Visual Basic (Declaration)
Public Class ZoomAction _
    Inherits Action

Remarks

The MinScale property of Axis property specifies the minimum scale that can set for the axis. If MinScale is equal to 1 the zoom is not applied to the axis.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
C1.Silverlight.Chart..::.Action
C1.Silverlight.Chart..::.ZoomAction

See Also

ZoomAction Members
C1.Silverlight.Chart Namespace


ZoomAction Members

[image] [image]

.NET Framework Class Library
ZoomAction Members
ZoomAction Class Constructors Methods Properties See Also

The ZoomAction type exposes the following members.

Constructors

Name | Description
ZoomAction | Creates a new instance of the ZoomAction class.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush that is used for painting selection area.
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)
Stroke | Gets or sets the stroke brush that is used for painting the selection area.

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


ZoomAction Constructor

[image]

.NET Framework Class Library
ZoomAction Constructor
ZoomAction Class See Also
Creates a new instance of the ZoomAction class.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public ZoomAction()
Visual Basic (Declaration)
Public Sub New

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


ZoomAction Methods

[image] [image]

.NET Framework Class Library
ZoomAction Methods
ZoomAction Class See Also

The ZoomAction type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


ZoomAction Properties

[image] [image]

.NET Framework Class Library
ZoomAction Properties
ZoomAction Class See Also

The ZoomAction type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)
Fill | Gets or sets the fill brush that is used for painting selection area.
Modifiers | Gets or sets the state of modifier keys that starts the action. (Inherited from Action.)
Stroke | Gets or sets the stroke brush that is used for painting the selection area.

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


Fill Property

[image]

.NET Framework Class Library
ZoomAction..::.Fill Property
ZoomAction Class See Also
Gets or sets the fill brush that is used for painting selection area.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Brush

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


Stroke Property

[image]

.NET Framework Class Library
ZoomAction..::.Stroke Property
ZoomAction Class See Also
Gets or sets the stroke brush that is used for painting the selection area.

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Brush

See Also

ZoomAction Class
C1.Silverlight.Chart Namespace


C1.Silverlight.Data Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Data Namespace

Classes

Class | Description
CollectionView | This class is for internal use only.
DataColumn | Subset of the System.Data.DataColumn class.
DataColumnList | List of DataColumn objects.
DataRelation | Represents a parent/child relationship between two DataTable objects.
DataRelationCollection | Collection of DataRelation objects.
DataRow | Subset of the System.Data.DataRow class.
DataRowCollection | Collection of DataRow objects.
DataRowView | Class that wraps a DataRow object, used as a base for dynamically-generated classes that expose the DataRow columns as bindable properties.
DataSet | Subset of the System.Data.DataSet class.
DataTable | Subset of the System.Data.DataTable class.
DataTableCollection | List of DataTable objects.
DataView | Represents a databindable, customized view of a DataTable used for sorting and filtering.
ForeignKeyConstraint | Represents an action restriction enforced on a set of columns when a row is deleted or updated.
NamedObject | Object that has a Name property.
NamedObjectCollection<(Of <(T>)>) | Collection of named objects, provides string indexer to retrieve objects by name.
SortDescriptionCollection | Collection of SortDescription objects.
UpdatableCollection<(Of <(T>)>) | Observable collection similar to the one in System.Collections.ObjectModel but with BeginUpdate/EndUpdate methods used to optionally suppress notifications.

Structures

Structure | Description
SortDescription | Defines the direction and the property name to be used as the criteria for sorting a collection.

Enumerations

Enumeration | Description
AcceptRejectRule | Indicates the action that occurs across this constraint when AcceptChanges()()() is called.
DataRowState | Specifies the state of a DataRow object.
Rule | Indicates the action that occurs across this constraint when rows are updated or deleted.


AcceptRejectRule Enumeration

[image]

.NET Framework Class Library
AcceptRejectRule Enumeration
See Also
Indicates the action that occurs across this constraint when AcceptChanges()()() is called.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public enum AcceptRejectRule
Visual Basic (Declaration)
Public Enumeration AcceptRejectRule

Members

Member name | Description
Cascade | Changes are cascaded across the data relation.
None | No action is taken.

See Also

C1.Silverlight.Data Namespace


CollectionView Class

[image]

.NET Framework Class Library
CollectionView Class
Members See Also
This class is for internal use only.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class CollectionView : UpdatableCollection<Object>,
    IComparer<Object>
Visual Basic (Declaration)
Public Class CollectionView _
    Inherits UpdatableCollection(Of Object) _
    Implements IComparer(Of Object)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Object >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( Object >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( Object >)>)
C1.Silverlight.Data..::.CollectionView
C1.Silverlight.Data..::.DataView

See Also

CollectionView Members
C1.Silverlight.Data Namespace


CollectionView Members

[image] [image]

.NET Framework Class Library
CollectionView Members
CollectionView Class Constructors Methods Properties Events See Also

The CollectionView type exposes the following members.

Constructors

Name | Description
CollectionView |

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Object >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Object >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewObject | Gets a viewable object that wraps a raw source item.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Object >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetFilter | Sets the Predicate that defines how the view is filtered.
SetItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetSortDescriptions | Overloaded.
SetSource | Sets the source collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Object >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


CollectionView Constructor

[image]

.NET Framework Class Library
CollectionView Constructor
CollectionView Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public CollectionView()
Visual Basic (Declaration)
Public Sub New

See Also

CollectionView Class
C1.Silverlight.Data Namespace


CollectionView Methods

[image] [image]

.NET Framework Class Library
CollectionView Methods
CollectionView Class See Also

The CollectionView type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Object >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Object >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewObject | Gets a viewable object that wraps a raw source item.
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Object >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetFilter | Sets the Predicate that defines how the view is filtered.
SetItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetSortDescriptions | Overloaded.
SetSource | Sets the source collection.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


GetViewObject Method

[image]

.NET Framework Class Library
CollectionView..::.GetViewObject Method
CollectionView Class See Also
Gets a viewable object that wraps a raw source item.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected virtual Object GetViewObject(
    Object item
)
Visual Basic (Declaration)
Protected Overridable Function GetViewObject ( _
    item As Object _
) As Object

Parameters

item
Type: System..::.Object
The raw source item.

Return Value

A viewable object that wraps a raw source item

See Also

CollectionView Class
C1.Silverlight.Data Namespace


SetFilter Method

[image]

.NET Framework Class Library
CollectionView..::.SetFilter Method
CollectionView Class See Also
Sets the Predicate that defines how the view is filtered.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected void SetFilter(
    Predicate<Object> filter
)
Visual Basic (Declaration)
Protected Sub SetFilter ( _
    filter As Predicate(Of Object) _
)

Parameters

filter
Type: System..::.Predicate <(Of <( Object >)>)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


SetSortDescriptions Method

[image] [image]

.NET Framework Class Library
CollectionView..::.SetSortDescriptions Method
CollectionView Class See Also

Overload List

Name | Description
SetSortDescriptions(SortDescriptionCollection) | Sets the SortDescriptionCollection that defines how the view is sorted.
SetSortDescriptions(String) | Sets the SortDescriptionCollection that defines how the view is sorted.

See Also

CollectionView Class
CollectionView Members
C1.Silverlight.Data Namespace


SetSortDescriptions Method (SortDescriptionCollection)

[image]

.NET Framework Class Library
CollectionView..::.SetSortDescriptions Method (SortDescriptionCollection)
CollectionView Class See Also
Sets the SortDescriptionCollection that defines how the view is sorted.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected void SetSortDescriptions(
    SortDescriptionCollection sortDescriptions
)
Visual Basic (Declaration)
Protected Sub SetSortDescriptions ( _
    sortDescriptions As SortDescriptionCollection _
)

Parameters

sortDescriptions
Type: C1.Silverlight.Data..::.SortDescriptionCollection

See Also

CollectionView Class
SetSortDescriptions Overload
C1.Silverlight.Data Namespace


SetSortDescriptions Method (String)

[image]

.NET Framework Class Library
CollectionView..::.SetSortDescriptions Method (String)
CollectionView Class See Also
Sets the SortDescriptionCollection that defines how the view is sorted.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected void SetSortDescriptions(
    string sortString
)
Visual Basic (Declaration)
Protected Sub SetSortDescriptions ( _
    sortString As String _
)

Parameters

sortString
Type: System..::.String

See Also

CollectionView Class
SetSortDescriptions Overload
C1.Silverlight.Data Namespace


SetSource Method

[image]

.NET Framework Class Library
CollectionView..::.SetSource Method
CollectionView Class See Also
Sets the source collection.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected void SetSource(
    IEnumerable source
)
Visual Basic (Declaration)
Protected Sub SetSource ( _
    source As IEnumerable _
)

Parameters

source
Type: System.Collections..::.IEnumerable
The source collection.

See Also

CollectionView Class
C1.Silverlight.Data Namespace


CollectionView Properties

[image] [image]

.NET Framework Class Library
CollectionView Properties
CollectionView Class See Also

The CollectionView type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Object >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


CollectionView Events

[image] [image]

.NET Framework Class Library
CollectionView Events
CollectionView Class See Also

The CollectionView type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


DataColumn Class

[image]

.NET Framework Class Library
DataColumn Class
Members See Also
Subset of the System.Data.DataColumn class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataColumn : NamedObject
Visual Basic (Declaration)
Public Class DataColumn _
    Inherits NamedObject

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.NamedObject
C1.Silverlight.Data..::.DataColumn

See Also

DataColumn Members
C1.Silverlight.Data Namespace


DataColumn Members

[image] [image]

.NET Framework Class Library
DataColumn Members
DataColumn Class Constructors Methods Properties See Also

The DataColumn type exposes the following members.

Constructors

Name | Description
DataColumn | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowDBNull | Gets or sets a value that indicated whether null values are allowed in this column.
AutoIncrement | Gets or sets a value that indicates whether the column automatically increments the value of the column for new rows added to the table.
AutoIncrementSeed | Gets or sets the starting value for a column that has its AutoIncrement property set to true.
AutoIncrementStep | Gets or sets the increment used by a column with its AutoIncrement property set to true.
Caption | Gets or sets the caption for the column.
ColumnName | Gets or sets the name of this DataColumn.
DataType | Gets or sets the Type of value stored in this DataColumn.
DefaultValue | Gets or sets the default value stored in this DataColumn when a new DataRow object is created.
Expression | Gets or sets a string that specifies an expression used to calculate values in this DataColumn.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
Ordinal | Gets the position of this DataColumn in the parent table.
ReadOnly | Gets or sets a value that determines whether this DataColumn is read-only.
Table | Gets a reference to the DataTable that contains this DataColumn.

See Also

DataColumn Class
C1.Silverlight.Data Namespace


DataColumn Constructor

[image] [image]

.NET Framework Class Library
DataColumn Constructor
DataColumn Class See Also

Overload List

Name | Description
DataColumn()()() | Initializes a new instance of a DataColumn object.
DataColumn(String) | Initializes a new instance of a DataColumn object.
DataColumn(String, Type) | Initializes a new instance of a DataColumn object.
DataColumn(String, Type, String) | Initializes a new instance of a DataColumn object.

See Also

DataColumn Class
DataColumn Members
C1.Silverlight.Data Namespace


DataColumn Constructor

[image]

.NET Framework Class Library
DataColumn Constructor
DataColumn Class See Also
Initializes a new instance of a DataColumn object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataColumn Class
DataColumn Overload
C1.Silverlight.Data Namespace


DataColumn Constructor (String)

[image]

.NET Framework Class Library
DataColumn Constructor (String)
DataColumn Class See Also
Initializes a new instance of a DataColumn object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn(
    string columnName
)
Visual Basic (Declaration)
Public Sub New ( _
    columnName As String _
)

Parameters

columnName
Type: System..::.String
Name of the new column.

See Also

DataColumn Class
DataColumn Overload
C1.Silverlight.Data Namespace


DataColumn Constructor (String, Type)

[image]

.NET Framework Class Library
DataColumn Constructor (String, Type)
DataColumn Class See Also
Initializes a new instance of a DataColumn object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn(
    string columnName,
    Type dataType
)
Visual Basic (Declaration)
Public Sub New ( _
    columnName As String, _
    dataType As Type _
)

Parameters

columnName
Type: System..::.String
Name of the new column.
dataType
Type: System..::.Type
Type of values stored in the new column.

See Also

DataColumn Class
DataColumn Overload
C1.Silverlight.Data Namespace


DataColumn Constructor (String, Type, String)

[image]

.NET Framework Class Library
DataColumn Constructor (String, Type, String)
DataColumn Class See Also
Initializes a new instance of a DataColumn object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn(
    string columnName,
    Type dataType,
    string expression
)
Visual Basic (Declaration)
Public Sub New ( _
    columnName As String, _
    dataType As Type, _
    expression As String _
)

Parameters

columnName
Type: System..::.String
Name of the new column.
dataType
Type: System..::.Type
Type of values stored in the new column.
expression
Type: System..::.String
Expression used to evaluate items in the new column.

See Also

DataColumn Class
DataColumn Overload
C1.Silverlight.Data Namespace


DataColumn Methods

[image] [image]

.NET Framework Class Library
DataColumn Methods
DataColumn Class See Also

The DataColumn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataColumn Class
C1.Silverlight.Data Namespace


DataColumn Properties

[image] [image]

.NET Framework Class Library
DataColumn Properties
DataColumn Class See Also

The DataColumn type exposes the following members.

Properties

Name | Description
AllowDBNull | Gets or sets a value that indicated whether null values are allowed in this column.
AutoIncrement | Gets or sets a value that indicates whether the column automatically increments the value of the column for new rows added to the table.
AutoIncrementSeed | Gets or sets the starting value for a column that has its AutoIncrement property set to true.
AutoIncrementStep | Gets or sets the increment used by a column with its AutoIncrement property set to true.
Caption | Gets or sets the caption for the column.
ColumnName | Gets or sets the name of this DataColumn.
DataType | Gets or sets the Type of value stored in this DataColumn.
DefaultValue | Gets or sets the default value stored in this DataColumn when a new DataRow object is created.
Expression | Gets or sets a string that specifies an expression used to calculate values in this DataColumn.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
Ordinal | Gets the position of this DataColumn in the parent table.
ReadOnly | Gets or sets a value that determines whether this DataColumn is read-only.
Table | Gets a reference to the DataTable that contains this DataColumn.

See Also

DataColumn Class
C1.Silverlight.Data Namespace


AllowDBNull Property

[image]

.NET Framework Class Library
DataColumn..::.AllowDBNull Property
DataColumn Class See Also
Gets or sets a value that indicated whether null values are allowed in this column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool AllowDBNull { get; set; }
Visual Basic (Declaration)
Public Property AllowDBNull As Boolean

See Also

DataColumn Class
C1.Silverlight.Data Namespace


AutoIncrement Property

[image]

.NET Framework Class Library
DataColumn..::.AutoIncrement Property
DataColumn Class See Also
Gets or sets a value that indicates whether the column automatically increments the value of the column for new rows added to the table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool AutoIncrement { get; set; }
Visual Basic (Declaration)
Public Property AutoIncrement As Boolean

See Also

DataColumn Class
C1.Silverlight.Data Namespace


AutoIncrementSeed Property

[image]

.NET Framework Class Library
DataColumn..::.AutoIncrementSeed Property
DataColumn Class See Also
Gets or sets the starting value for a column that has its AutoIncrement property set to true.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public int AutoIncrementSeed { get; set; }
Visual Basic (Declaration)
Public Property AutoIncrementSeed As Integer

See Also

DataColumn Class
C1.Silverlight.Data Namespace


AutoIncrementStep Property

[image]

.NET Framework Class Library
DataColumn..::.AutoIncrementStep Property
DataColumn Class See Also
Gets or sets the increment used by a column with its AutoIncrement property set to true.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public int AutoIncrementStep { get; set; }
Visual Basic (Declaration)
Public Property AutoIncrementStep As Integer

See Also

DataColumn Class
C1.Silverlight.Data Namespace


Caption Property

[image]

.NET Framework Class Library
DataColumn..::.Caption Property
DataColumn Class See Also
Gets or sets the caption for the column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string Caption { get; set; }
Visual Basic (Declaration)
Public Property Caption As String

See Also

DataColumn Class
C1.Silverlight.Data Namespace


ColumnName Property

[image]

.NET Framework Class Library
DataColumn..::.ColumnName Property
DataColumn Class See Also
Gets or sets the name of this DataColumn.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string ColumnName { get; set; }
Visual Basic (Declaration)
Public Property ColumnName As String

See Also

DataColumn Class
C1.Silverlight.Data Namespace


DataType Property

[image]

.NET Framework Class Library
DataColumn..::.DataType Property
DataColumn Class See Also
Gets or sets the Type of value stored in this DataColumn.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Type DataType { get; set; }
Visual Basic (Declaration)
Public Property DataType As Type

See Also

DataColumn Class
C1.Silverlight.Data Namespace


DefaultValue Property

[image]

.NET Framework Class Library
DataColumn..::.DefaultValue Property
DataColumn Class See Also
Gets or sets the default value stored in this DataColumn when a new DataRow object is created.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object DefaultValue { get; set; }
Visual Basic (Declaration)
Public Property DefaultValue As Object

See Also

DataColumn Class
C1.Silverlight.Data Namespace


Expression Property

[image]

.NET Framework Class Library
DataColumn..::.Expression Property
DataColumn Class See Also
Gets or sets a string that specifies an expression used to calculate values in this DataColumn.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string Expression { get; set; }
Visual Basic (Declaration)
Public Property Expression As String

See Also

DataColumn Class
C1.Silverlight.Data Namespace


Ordinal Property

[image]

.NET Framework Class Library
DataColumn..::.Ordinal Property
DataColumn Class See Also
Gets the position of this DataColumn in the parent table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public int Ordinal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Ordinal As Integer

See Also

DataColumn Class
C1.Silverlight.Data Namespace


ReadOnly Property

[image]

.NET Framework Class Library
DataColumn..::.ReadOnly Property
DataColumn Class See Also
Gets or sets a value that determines whether this DataColumn is read-only.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool ReadOnly { get; set; }
Visual Basic (Declaration)
Public Property ReadOnly As Boolean

See Also

DataColumn Class
C1.Silverlight.Data Namespace


Table Property

[image]

.NET Framework Class Library
DataColumn..::.Table Property
DataColumn Class See Also
Gets a reference to the DataTable that contains this DataColumn.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable Table { get; }
Visual Basic (Declaration)
Public ReadOnly Property Table As DataTable

See Also

DataColumn Class
C1.Silverlight.Data Namespace


DataColumnList Class

[image]

.NET Framework Class Library
DataColumnList Class
Members See Also
List of DataColumn objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataColumnList : NamedObjectCollection<DataColumn>
Visual Basic (Declaration)
Public Class DataColumnList _
    Inherits NamedObjectCollection(Of DataColumn)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataColumn >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( DataColumn >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( DataColumn >)>)
C1.Silverlight.Data..::.NamedObjectCollection <(Of <( DataColumn >)>)
C1.Silverlight.Data..::.DataColumnList

See Also

DataColumnList Members
C1.Silverlight.Data Namespace


DataColumnList Members

[image] [image]

.NET Framework Class Library
DataColumnList Members
DataColumnList Class Methods Properties Events See Also

The DataColumnList type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all items from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataColumn >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataColumn >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides UpdatableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


DataColumnList Methods

[image] [image]

.NET Framework Class Library
DataColumnList Methods
DataColumnList Class See Also

The DataColumnList type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all items from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataColumn >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataColumn >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides UpdatableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


Add Method

[image] [image]

.NET Framework Class Library
DataColumnList..::.Add Method
DataColumnList Class See Also

Overload List

Name | Description
Add()()() | Creates a new DataColumn and appends it to the list.
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Add(String) | Creates an item and appends it to the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)
Add(String, Type) | Creates a new DataColumn and appends it to the list.
Add(String, Type, String) | Creates a new DataColumn and appends it to the list.

See Also

DataColumnList Class
DataColumnList Members
C1.Silverlight.Data Namespace


Add Method

[image]

.NET Framework Class Library
DataColumnList..::.Add Method
DataColumnList Class See Also
Creates a new DataColumn and appends it to the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn Add()
Visual Basic (Declaration)
Public Function Add As DataColumn

Return Value

A reference to the new DataColumn.

See Also

DataColumnList Class
Add Overload
C1.Silverlight.Data Namespace


Add Method (String, Type)

[image]

.NET Framework Class Library
DataColumnList..::.Add Method (String, Type)
DataColumnList Class See Also
Creates a new DataColumn and appends it to the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn Add(
    string columnName,
    Type dataType
)
Visual Basic (Declaration)
Public Function Add ( _
    columnName As String, _
    dataType As Type _
) As DataColumn

Parameters

columnName
Type: System..::.String
Name of the new column.
dataType
Type: System..::.Type
Type of data stored in the new column.

Return Value

A reference to the new DataColumn.

See Also

DataColumnList Class
Add Overload
C1.Silverlight.Data Namespace


Add Method (String, Type, String)

[image]

.NET Framework Class Library
DataColumnList..::.Add Method (String, Type, String)
DataColumnList Class See Also
Creates a new DataColumn and appends it to the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn Add(
    string columnName,
    Type dataType,
    string expression
)
Visual Basic (Declaration)
Public Function Add ( _
    columnName As String, _
    dataType As Type, _
    expression As String _
) As DataColumn

Parameters

columnName
Type: System..::.String
Name of the new column.
dataType
Type: System..::.Type
Type of data stored in the new column.
expression
Type: System..::.String
String that contains an expression used to evaluate values in the new column.

Return Value

A reference to the new DataColumn.

See Also

DataColumnList Class
Add Overload
C1.Silverlight.Data Namespace


Clear Method

[image]

.NET Framework Class Library
DataColumnList..::.Clear Method
DataColumnList Class See Also
Removes all items from the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


Contains Method

[image] [image]

.NET Framework Class Library
DataColumnList..::.Contains Method
DataColumnList Class See Also

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Contains(String) | Gets a value that determines whether an item is a member of the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataColumnList Class
DataColumnList Members
C1.Silverlight.Data Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
DataColumnList..::.IndexOf Method
DataColumnList Class See Also

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
IndexOf(String) | Gets the index of an item in the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataColumnList Class
DataColumnList Members
C1.Silverlight.Data Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
DataColumnList..::.OnCollectionChanged Method
DataColumnList Class See Also
Raises the CollectionChanged event.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
NotifyCollectionChangedEventArgs that contains the event data.

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


DataColumnList Properties

[image] [image]

.NET Framework Class Library
DataColumnList Properties
DataColumnList Class See Also

The DataColumnList type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataColumn >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataColumnList..::.Item Property
DataColumnList Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataColumn >)>).)
Item[([(String])]) | Gets or sets an item in the list by name. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataColumnList Class
DataColumnList Members
C1.Silverlight.Data Namespace


DataColumnList Events

[image] [image]

.NET Framework Class Library
DataColumnList Events
DataColumnList Class See Also

The DataColumnList type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataColumn >)>).)

See Also

DataColumnList Class
C1.Silverlight.Data Namespace


DataRelation Class

[image]

.NET Framework Class Library
DataRelation Class
Members See Also
Represents a parent/child relationship between two DataTable objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataRelation : NamedObject
Visual Basic (Declaration)
Public Class DataRelation _
    Inherits NamedObject

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.NamedObject
C1.Silverlight.Data..::.DataRelation

See Also

DataRelation Members
C1.Silverlight.Data Namespace


DataRelation Members

[image] [image]

.NET Framework Class Library
DataRelation Members
DataRelation Class Constructors Methods Properties See Also

The DataRelation type exposes the following members.

Constructors

Name | Description
DataRelation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChildColumn | Gets a reference to the child DataColumn in this DataRelation.
ChildKeyConstraint | Gets the ForeignKeyConstraint for this DataRelation.
ChildTable | Gets a reference to the child DataTable in this DataRelation.
DataSet | Gets a reference to the DataSet to which this relation belongs.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
ParentColumn | Gets a reference to the parent DataColumn in this DataRelation.
ParentTable | Gets a reference to the parent DataTable in this DataRelation.
RelationName | Gets or sets the name of the DataRelation.

See Also

DataRelation Class
C1.Silverlight.Data Namespace


DataRelation Constructor

[image] [image]

.NET Framework Class Library
DataRelation Constructor
DataRelation Class See Also

Overload List

Name | Description
DataRelation()()() | Initializes a new instance of a DataRelation.
DataRelation(String, DataColumn, DataColumn) | Initializes a new instance of a DataRelation.

See Also

DataRelation Class
DataRelation Members
C1.Silverlight.Data Namespace


DataRelation Constructor

[image]

.NET Framework Class Library
DataRelation Constructor
DataRelation Class See Also
Initializes a new instance of a DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelation()
Visual Basic (Declaration)
Public Sub New

See Also

DataRelation Class
DataRelation Overload
C1.Silverlight.Data Namespace


DataRelation Constructor (String, DataColumn, DataColumn)

[image]

.NET Framework Class Library
DataRelation Constructor (String, DataColumn, DataColumn)
DataRelation Class See Also
Initializes a new instance of a DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelation(
    string name,
    DataColumn parentColumn,
    DataColumn childColumn
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    parentColumn As DataColumn, _
    childColumn As DataColumn _
)

Parameters

name
Type: System..::.String
Name of the new DataRelation.
parentColumn
Type: C1.Silverlight.Data..::.DataColumn
Parent DataColumn in the new relation.
childColumn
Type: C1.Silverlight.Data..::.DataColumn
Child DataColumn in the new relation.

See Also

DataRelation Class
DataRelation Overload
C1.Silverlight.Data Namespace


DataRelation Methods

[image] [image]

.NET Framework Class Library
DataRelation Methods
DataRelation Class See Also

The DataRelation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataRelation Class
C1.Silverlight.Data Namespace


DataRelation Properties

[image] [image]

.NET Framework Class Library
DataRelation Properties
DataRelation Class See Also

The DataRelation type exposes the following members.

Properties

Name | Description
ChildColumn | Gets a reference to the child DataColumn in this DataRelation.
ChildKeyConstraint | Gets the ForeignKeyConstraint for this DataRelation.
ChildTable | Gets a reference to the child DataTable in this DataRelation.
DataSet | Gets a reference to the DataSet to which this relation belongs.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
ParentColumn | Gets a reference to the parent DataColumn in this DataRelation.
ParentTable | Gets a reference to the parent DataTable in this DataRelation.
RelationName | Gets or sets the name of the DataRelation.

See Also

DataRelation Class
C1.Silverlight.Data Namespace


ChildColumn Property

[image]

.NET Framework Class Library
DataRelation..::.ChildColumn Property
DataRelation Class See Also
Gets a reference to the child DataColumn in this DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn ChildColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildColumn As DataColumn

See Also

DataRelation Class
C1.Silverlight.Data Namespace


ChildKeyConstraint Property

[image]

.NET Framework Class Library
DataRelation..::.ChildKeyConstraint Property
DataRelation Class See Also
Gets the ForeignKeyConstraint for this DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public ForeignKeyConstraint ChildKeyConstraint { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildKeyConstraint As ForeignKeyConstraint

See Also

DataRelation Class
C1.Silverlight.Data Namespace


ChildTable Property

[image]

.NET Framework Class Library
DataRelation..::.ChildTable Property
DataRelation Class See Also
Gets a reference to the child DataTable in this DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable ChildTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property ChildTable As DataTable

See Also

DataRelation Class
C1.Silverlight.Data Namespace


DataSet Property

[image]

.NET Framework Class Library
DataRelation..::.DataSet Property
DataRelation Class See Also
Gets a reference to the DataSet to which this relation belongs.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet DataSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSet As DataSet

See Also

DataRelation Class
C1.Silverlight.Data Namespace


ParentColumn Property

[image]

.NET Framework Class Library
DataRelation..::.ParentColumn Property
DataRelation Class See Also
Gets a reference to the parent DataColumn in this DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn ParentColumn { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentColumn As DataColumn

See Also

DataRelation Class
C1.Silverlight.Data Namespace


ParentTable Property

[image]

.NET Framework Class Library
DataRelation..::.ParentTable Property
DataRelation Class See Also
Gets a reference to the parent DataTable in this DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable ParentTable { get; }
Visual Basic (Declaration)
Public ReadOnly Property ParentTable As DataTable

See Also

DataRelation Class
C1.Silverlight.Data Namespace


RelationName Property

[image]

.NET Framework Class Library
DataRelation..::.RelationName Property
DataRelation Class See Also
Gets or sets the name of the DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string RelationName { get; set; }
Visual Basic (Declaration)
Public Property RelationName As String

See Also

DataRelation Class
C1.Silverlight.Data Namespace


DataRelationCollection Class

[image]

.NET Framework Class Library
DataRelationCollection Class
Members See Also
Collection of DataRelation objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataRelationCollection : NamedObjectCollection<DataRelation>
Visual Basic (Declaration)
Public Class DataRelationCollection _
    Inherits NamedObjectCollection(Of DataRelation)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataRelation >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( DataRelation >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( DataRelation >)>)
C1.Silverlight.Data..::.NamedObjectCollection <(Of <( DataRelation >)>)
C1.Silverlight.Data..::.DataRelationCollection

See Also

DataRelationCollection Members
C1.Silverlight.Data Namespace


DataRelationCollection Members

[image] [image]

.NET Framework Class Library
DataRelationCollection Members
DataRelationCollection Class Constructors Methods Properties Events See Also

The DataRelationCollection type exposes the following members.

Constructors

Name | Description
DataRelationCollection |

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataRelation >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataRelation >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)

See Also

DataRelationCollection Class
C1.Silverlight.Data Namespace


DataRelationCollection Constructor

[image]

.NET Framework Class Library
DataRelationCollection Constructor
DataRelationCollection Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelationCollection()
Visual Basic (Declaration)
Public Sub New

See Also

DataRelationCollection Class
C1.Silverlight.Data Namespace


DataRelationCollection Methods

[image] [image]

.NET Framework Class Library
DataRelationCollection Methods
DataRelationCollection Class See Also

The DataRelationCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataRelation >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataRelation >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataRelationCollection Class
C1.Silverlight.Data Namespace


Add Method

[image] [image]

.NET Framework Class Library
DataRelationCollection..::.Add Method
DataRelationCollection Class See Also

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Add(String) | Creates an item and appends it to the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataRelationCollection Class
DataRelationCollection Members
C1.Silverlight.Data Namespace


Contains Method

[image] [image]

.NET Framework Class Library
DataRelationCollection..::.Contains Method
DataRelationCollection Class See Also

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Contains(String) | Gets a value that determines whether an item is a member of the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataRelationCollection Class
DataRelationCollection Members
C1.Silverlight.Data Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
DataRelationCollection..::.IndexOf Method
DataRelationCollection Class See Also

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
IndexOf(String) | Gets the index of an item in the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataRelationCollection Class
DataRelationCollection Members
C1.Silverlight.Data Namespace


DataRelationCollection Properties

[image] [image]

.NET Framework Class Library
DataRelationCollection Properties
DataRelationCollection Class See Also

The DataRelationCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRelation >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

DataRelationCollection Class
C1.Silverlight.Data Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataRelationCollection..::.Item Property
DataRelationCollection Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataRelation >)>).)
Item[([(String])]) | Gets or sets an item in the list by name. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataRelationCollection Class
DataRelationCollection Members
C1.Silverlight.Data Namespace


DataRelationCollection Events

[image] [image]

.NET Framework Class Library
DataRelationCollection Events
DataRelationCollection Class See Also

The DataRelationCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataRelation >)>).)

See Also

DataRelationCollection Class
C1.Silverlight.Data Namespace


DataRow Class

[image]

.NET Framework Class Library
DataRow Class
Members See Also
Subset of the System.Data.DataRow class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class DataRow : INotifyPropertyChanged
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class DataRow _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.DataRow

See Also

DataRow Members
C1.Silverlight.Data Namespace


DataRow Members

[image] [image]

.NET Framework Class Library
DataRow Members
DataRow Class Constructors Methods Properties Events See Also

The DataRow type exposes the following members.

Constructors

Name | Description
DataRow |

Methods

Name | Description
Delete | Removes this row from its parent table.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildRows | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParentRow | Overloaded.
GetRowView | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Item | Overloaded.
ItemArray | Gets or sets an array of objects that represent the data stored in this row.
RowState | Gets a DataRowState value that determines the state of this row.
Table | Gets a reference to the DataTable that contains this row.

Events

Name | Description
PropertyChanged | Fires when a field value changes.

See Also

DataRow Class
C1.Silverlight.Data Namespace


DataRow Constructor

[image]

.NET Framework Class Library
DataRow Constructor
DataRow Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow()
Visual Basic (Declaration)
Public Sub New

See Also

DataRow Class
C1.Silverlight.Data Namespace


DataRow Methods

[image] [image]

.NET Framework Class Library
DataRow Methods
DataRow Class See Also

The DataRow type exposes the following members.

Methods

Name | Description
Delete | Removes this row from its parent table.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChildRows | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParentRow | Overloaded.
GetRowView | Overloaded.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnPropertyChanged | Raises the PropertyChanged event.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataRow Class
C1.Silverlight.Data Namespace


Delete Method

[image]

.NET Framework Class Library
DataRow..::.Delete Method
DataRow Class See Also
Removes this row from its parent table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void Delete()
Visual Basic (Declaration)
Public Sub Delete

See Also

DataRow Class
C1.Silverlight.Data Namespace


GetChildRows Method

[image] [image]

.NET Framework Class Library
DataRow..::.GetChildRows Method
DataRow Class See Also

Overload List

Name | Description
GetChildRows(DataRelation) | Gets the child rows of this DataRow using the specified DataRelation.
GetChildRows(String) | Gets the child rows of this DataRow using the specified DataRelation.

See Also

DataRow Class
DataRow Members
C1.Silverlight.Data Namespace


GetChildRows Method (DataRelation)

[image]

.NET Framework Class Library
DataRow..::.GetChildRows Method (DataRelation)
DataRow Class See Also
Gets the child rows of this DataRow using the specified DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow[] GetChildRows(
    DataRelation relation
)
Visual Basic (Declaration)
Public Function GetChildRows ( _
    relation As DataRelation _
) As DataRow()

Parameters

relation
Type: C1.Silverlight.Data..::.DataRelation
The DataRelation to use.

Return Value

An array containing the child rows of this DataRow using the specified DataRelation.

See Also

DataRow Class
GetChildRows Overload
C1.Silverlight.Data Namespace


GetChildRows Method (String)

[image]

.NET Framework Class Library
DataRow..::.GetChildRows Method (String)
DataRow Class See Also
Gets the child rows of this DataRow using the specified DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow[] GetChildRows(
    string relationName
)
Visual Basic (Declaration)
Public Function GetChildRows ( _
    relationName As String _
) As DataRow()

Parameters

relationName
Type: System..::.String
The name of the DataRelation to use.

Return Value

An array containing the child rows of this DataRow using the specified DataRelation.

See Also

DataRow Class
GetChildRows Overload
C1.Silverlight.Data Namespace


GetParentRow Method

[image] [image]

.NET Framework Class Library
DataRow..::.GetParentRow Method
DataRow Class See Also

Overload List

Name | Description
GetParentRow(DataRelation) | Gets the parent row of this DataRow using the specified DataRelation.
GetParentRow(String) | Gets the parent row of this DataRow using the specified DataRelation.

See Also

DataRow Class
DataRow Members
C1.Silverlight.Data Namespace


GetParentRow Method (DataRelation)

[image]

.NET Framework Class Library
DataRow..::.GetParentRow Method (DataRelation)
DataRow Class See Also
Gets the parent row of this DataRow using the specified DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow GetParentRow(
    DataRelation relation
)
Visual Basic (Declaration)
Public Function GetParentRow ( _
    relation As DataRelation _
) As DataRow

Parameters

relation
Type: C1.Silverlight.Data..::.DataRelation
The DataRelation to use.

Return Value

The parent row of this DataRow using the specified DataRelation.

See Also

DataRow Class
GetParentRow Overload
C1.Silverlight.Data Namespace


GetParentRow Method (String)

[image]

.NET Framework Class Library
DataRow..::.GetParentRow Method (String)
DataRow Class See Also
Gets the parent row of this DataRow using the specified DataRelation.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow GetParentRow(
    string relationName
)
Visual Basic (Declaration)
Public Function GetParentRow ( _
    relationName As String _
) As DataRow

Parameters

relationName
Type: System..::.String
The name of the DataRelation to use.

Return Value

The parent row of this DataRow using the specified DataRelation.

See Also

DataRow Class
GetParentRow Overload
C1.Silverlight.Data Namespace


GetRowView Method

[image] [image]

.NET Framework Class Library
DataRow..::.GetRowView Method
DataRow Class See Also

Overload List

Name | Description
GetRowView()()() | Gets a dynamically-built object suitable for data-binding scenarios.
GetRowView(array<String>[]()[]) | Gets a dynamically-built object suitable for data-binding scenarios.

See Also

DataRow Class
DataRow Members
C1.Silverlight.Data Namespace


GetRowView Method

[image]

.NET Framework Class Library
DataRow..::.GetRowView Method
DataRow Class See Also
Gets a dynamically-built object suitable for data-binding scenarios.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object GetRowView()
Visual Basic (Declaration)
Public Function GetRowView As Object

Return Value

A dynamically built type suitable for data-binding scenarios.

See Also

DataRow Class
GetRowView Overload
C1.Silverlight.Data Namespace


GetRowView Method (String[])

[image]

.NET Framework Class Library
DataRow..::.GetRowView Method (array<String>[]()[])
DataRow Class See Also
Gets a dynamically-built object suitable for data-binding scenarios.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object GetRowView(
    params string[] columnNames
)
Visual Basic (Declaration)
Public Function GetRowView ( _
    ParamArray columnNames As String() _
) As Object

Parameters

columnNames
Type: array< System..::.String >[]()[]

Return Value

A dynamically-built type suitable for data-binding scenarios.

See Also

DataRow Class
GetRowView Overload
C1.Silverlight.Data Namespace


OnPropertyChanged Method

[image]

.NET Framework Class Library
DataRow..::.OnPropertyChanged Method
DataRow Class See Also
Raises the PropertyChanged event.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected virtual void OnPropertyChanged(
    PropertyChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overridable Sub OnPropertyChanged ( _
    e As PropertyChangedEventArgs _
)

Parameters

e
Type: System.ComponentModel..::.PropertyChangedEventArgs
PropertyChangedEventArgs that contains the event data.

See Also

DataRow Class
C1.Silverlight.Data Namespace


DataRow Properties

[image] [image]

.NET Framework Class Library
DataRow Properties
DataRow Class See Also

The DataRow type exposes the following members.

Properties

Name | Description
Item | Overloaded.
ItemArray | Gets or sets an array of objects that represent the data stored in this row.
RowState | Gets a DataRowState value that determines the state of this row.
Table | Gets a reference to the DataTable that contains this row.

See Also

DataRow Class
C1.Silverlight.Data Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataRow..::.Item Property
DataRow Class See Also

Overload List

Name | Description
Item[([(DataColumn])]) | Gets or sets the value stored in this row for a given column.
Item[([(Int32])]) | Gets or sets the value stored in this row for a given column.
Item[([(String])]) | Gets or sets the value stored in this row for a given column.

See Also

DataRow Class
DataRow Members
C1.Silverlight.Data Namespace


Item Property (DataColumn)

[image]

.NET Framework Class Library
DataRow..::.Item Property (DataColumn)
DataRow Class See Also
Gets or sets the value stored in this row for a given column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object this[
    DataColumn column
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    column As DataColumn _
) As Object

Parameters

column
Type: C1.Silverlight.Data..::.DataColumn
Reference to a DataColumn.

Return Value

The value stored in this row for the given column.

See Also

DataRow Class
Item Overload
C1.Silverlight.Data Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
DataRow..::.Item Property (Int32)
DataRow Class See Also
Gets or sets the value stored in this row for a given column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32
Index of the column.

Return Value

The value stored in this row for the given column.

See Also

DataRow Class
Item Overload
C1.Silverlight.Data Namespace


Item Property (String)

[image]

.NET Framework Class Library
DataRow..::.Item Property (String)
DataRow Class See Also
Gets or sets the value stored in this row for a given column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object this[
    string columnName
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    columnName As String _
) As Object

Parameters

columnName
Type: System..::.String
Name of the column.

Return Value

The value stored in this row for the given column.

See Also

DataRow Class
Item Overload
C1.Silverlight.Data Namespace


ItemArray Property

[image]

.NET Framework Class Library
DataRow..::.ItemArray Property
DataRow Class See Also
Gets or sets an array of objects that represent the data stored in this row.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object[] ItemArray { get; set; }
Visual Basic (Declaration)
Public Property ItemArray As Object()

See Also

DataRow Class
C1.Silverlight.Data Namespace


RowState Property

[image]

.NET Framework Class Library
DataRow..::.RowState Property
DataRow Class See Also
Gets a DataRowState value that determines the state of this row.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRowState RowState { get; }
Visual Basic (Declaration)
Public ReadOnly Property RowState As DataRowState

See Also

DataRow Class
C1.Silverlight.Data Namespace


Table Property

[image]

.NET Framework Class Library
DataRow..::.Table Property
DataRow Class See Also
Gets a reference to the DataTable that contains this row.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable Table { get; }
Visual Basic (Declaration)
Public ReadOnly Property Table As DataTable

See Also

DataRow Class
C1.Silverlight.Data Namespace


DataRow Events

[image] [image]

.NET Framework Class Library
DataRow Events
DataRow Class See Also

The DataRow type exposes the following members.

Events

Name | Description
PropertyChanged | Fires when a field value changes.

See Also

DataRow Class
C1.Silverlight.Data Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DataRow..::.PropertyChanged Event
DataRow Class See Also
Fires when a field value changes.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DataRow Class
C1.Silverlight.Data Namespace


DataRowCollection Class

[image]

.NET Framework Class Library
DataRowCollection Class
Members See Also
Collection of DataRow objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataRowCollection : UpdatableCollection<DataRow>
Visual Basic (Declaration)
Public Class DataRowCollection _
    Inherits UpdatableCollection(Of DataRow)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataRow >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( DataRow >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( DataRow >)>)
C1.Silverlight.Data..::.DataRowCollection

See Also

DataRowCollection Members
C1.Silverlight.Data Namespace


DataRowCollection Members

[image] [image]

.NET Framework Class Library
DataRowCollection Members
DataRowCollection Class Methods Properties Events See Also

The DataRowCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all rows from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataRow >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds the DataRow that has the specified key in its PrimaryKey column.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataRow >)>).)
InsertItem | Inserts a DataRow object into the list at a specified position. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
RemoveItem | Removes the DataRow at the specified index from the list. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataRow >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


DataRowCollection Methods

[image] [image]

.NET Framework Class Library
DataRowCollection Methods
DataRowCollection Class See Also

The DataRowCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all rows from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataRow >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Finds the DataRow that has the specified key in its PrimaryKey column.
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataRow >)>).)
InsertItem | Inserts a DataRow object into the list at a specified position. (Overrides ObservableCollection<(Of <(T>)>)..::.InsertItem(Int32, T).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
RemoveItem | Removes the DataRow at the specified index from the list. (Overrides ObservableCollection<(Of <(T>)>)..::.RemoveItem(Int32).)
SetItem | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


Clear Method

[image]

.NET Framework Class Library
DataRowCollection..::.Clear Method
DataRowCollection Class See Also
Removes all rows from the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


Find Method

[image]

.NET Framework Class Library
DataRowCollection..::.Find Method
DataRowCollection Class See Also
Finds the DataRow that has the specified key in its PrimaryKey column.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow Find(
    Object key
)
Visual Basic (Declaration)
Public Function Find ( _
    key As Object _
) As DataRow

Parameters

key
Type: System..::.Object
Value to look for.

Return Value

A DataRow object that has the specified key.

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


InsertItem Method

[image]

.NET Framework Class Library
DataRowCollection..::.InsertItem Method
DataRowCollection Class See Also
Inserts a DataRow object into the list at a specified position.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override void InsertItem(
    int index,
    DataRow item
)
Visual Basic (Declaration)
Protected Overrides Sub InsertItem ( _
    index As Integer, _
    item As DataRow _
)

Parameters

index
Type: System..::.Int32
Position where the row will be inserted.
item
Type: C1.Silverlight.Data..::.DataRow
DataRow that will be inserted into the list.

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


RemoveItem Method

[image]

.NET Framework Class Library
DataRowCollection..::.RemoveItem Method
DataRowCollection Class See Also
Removes the DataRow at the specified index from the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override void RemoveItem(
    int index
)
Visual Basic (Declaration)
Protected Overrides Sub RemoveItem ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32
Index of the DataRow to remove from the list.

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


DataRowCollection Properties

[image] [image]

.NET Framework Class Library
DataRowCollection Properties
DataRowCollection Class See Also

The DataRowCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataRow >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataRow >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


DataRowCollection Events

[image] [image]

.NET Framework Class Library
DataRowCollection Events
DataRowCollection Class See Also

The DataRowCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataRow >)>).)

See Also

DataRowCollection Class
C1.Silverlight.Data Namespace


DataRowState Enumeration

[image]

.NET Framework Class Library
DataRowState Enumeration
See Also
Specifies the state of a DataRow object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1028")]
public enum DataRowState
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Design", "CA1028")> _
Public Enumeration DataRowState

Members

Member name | Description
Unchanged | The row has not changed.
Added | The row has been added to the table.
Deleted | The row has been deleted from the table.
Detached | The row has been created but not yet added to the table.
Modified | The row has been modified since it was created or loaded.

See Also

C1.Silverlight.Data Namespace


DataRowView Class

[image]

.NET Framework Class Library
DataRowView Class
Members See Also
Class that wraps a DataRow object, used as a base for dynamically-generated classes that expose the DataRow columns as bindable properties.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataRowView : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class DataRowView _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.DataRowView

See Also

DataRowView Members
C1.Silverlight.Data Namespace


DataRowView Members

[image] [image]

.NET Framework Class Library
DataRowView Members
DataRowView Class Constructors Methods Events See Also

The DataRowView type exposes the following members.

Constructors

Name | Description
DataRowView | Initializes a new instance of a DataRowView.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetData | Gets the data for a specified column in the underlying DataRow.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a reference to the underlying DataRow object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetData | Gets the data for a specified column in the underlying DataRow.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
PropertyChanged | Fires when one of the fields in the underlying DataRow changes value.

See Also

DataRowView Class
C1.Silverlight.Data Namespace


DataRowView Constructor

[image]

.NET Framework Class Library
DataRowView Constructor
DataRowView Class See Also
Initializes a new instance of a DataRowView.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRowView(
    DataRow dr
)
Visual Basic (Declaration)
Public Sub New ( _
    dr As DataRow _
)

Parameters

dr
Type: C1.Silverlight.Data..::.DataRow
Underlying DataRow object.

See Also

DataRowView Class
C1.Silverlight.Data Namespace


DataRowView Methods

[image] [image]

.NET Framework Class Library
DataRowView Methods
DataRowView Class See Also

The DataRowView type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetData | Gets the data for a specified column in the underlying DataRow.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRow | Gets a reference to the underlying DataRow object.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetData | Gets the data for a specified column in the underlying DataRow.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataRowView Class
C1.Silverlight.Data Namespace


GetData Method

[image]

.NET Framework Class Library
DataRowView..::.GetData Method
DataRowView Class See Also
Gets the data for a specified column in the underlying DataRow.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object GetData(
    string columnName
)
Visual Basic (Declaration)
Public Function GetData ( _
    columnName As String _
) As Object

Parameters

columnName
Type: System..::.String
Name of the column that contains the data.

Return Value

Data at column columnName.

See Also

DataRowView Class
C1.Silverlight.Data Namespace


GetRow Method

[image]

.NET Framework Class Library
DataRowView..::.GetRow Method
DataRowView Class See Also
Gets a reference to the underlying DataRow object.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Design", "CA1024")]
public DataRow GetRow()
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Design", "CA1024")> _
Public Function GetRow As DataRow

Return Value

See Also

DataRowView Class
C1.Silverlight.Data Namespace


SetData Method

[image]

.NET Framework Class Library
DataRowView..::.SetData Method
DataRowView Class See Also
Gets the data for a specified column in the underlying DataRow.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void SetData(
    string columnName,
    Object value
)
Visual Basic (Declaration)
Public Sub SetData ( _
    columnName As String, _
    value As Object _
)

Parameters

columnName
Type: System..::.String
Name of the column that contains the data.
value
Type: System..::.Object
New value for the column.

See Also

DataRowView Class
C1.Silverlight.Data Namespace


DataRowView Events

[image] [image]

.NET Framework Class Library
DataRowView Events
DataRowView Class See Also

The DataRowView type exposes the following members.

Events

Name | Description
PropertyChanged | Fires when one of the fields in the underlying DataRow changes value.

See Also

DataRowView Class
C1.Silverlight.Data Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
DataRowView..::.PropertyChanged Event
DataRowView Class See Also
Fires when one of the fields in the underlying DataRow changes value.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

DataRowView Class
C1.Silverlight.Data Namespace


DataSet Class

[image]

.NET Framework Class Library
DataSet Class
Members See Also
Subset of the System.Data.DataSet class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataSet : NamedObject
Visual Basic (Declaration)
Public Class DataSet _
    Inherits NamedObject

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.NamedObject
C1.Silverlight.Data..::.DataSet

See Also

DataSet Members
C1.Silverlight.Data Namespace


DataSet Members

[image] [image]

.NET Framework Class Library
DataSet Members
DataSet Class Constructors Methods Properties See Also

The DataSet type exposes the following members.

Constructors

Name | Description
DataSet | Overloaded.

Methods

Name | Description
AcceptChanges | Marks all rows on all tables as unchanged.
Clear | Clears all rows in all tables of the DataSet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChanges | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadXml | Overloaded.
Reset | Resets the DataSet.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

Properties

Name | Description
DataSetName | Gets or sets the name of this DataSet.
HasChanges | Gets a value that indicates whether the DataSet has any changes since it was created, loaded, or since the AcceptChanges()()() method was called.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
Relations | Gets a list with all the DataRelation objects in the DataSet.
Tables | Gets a list with all the DataTable objects in the DataSet.

See Also

DataSet Class
C1.Silverlight.Data Namespace


DataSet Constructor

[image] [image]

.NET Framework Class Library
DataSet Constructor
DataSet Class See Also

Overload List

Name | Description
DataSet()()() | Initializes a new instance of a DataSet.
DataSet(String) | Initializes a new instance of a DataSet.

See Also

DataSet Class
DataSet Members
C1.Silverlight.Data Namespace


DataSet Constructor

[image]

.NET Framework Class Library
DataSet Constructor
DataSet Class See Also
Initializes a new instance of a DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet()
Visual Basic (Declaration)
Public Sub New

See Also

DataSet Class
DataSet Overload
C1.Silverlight.Data Namespace


DataSet Constructor (String)

[image]

.NET Framework Class Library
DataSet Constructor (String)
DataSet Class See Also
Initializes a new instance of a DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet(
    string name
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String _
)

Parameters

name
Type: System..::.String

See Also

DataSet Class
DataSet Overload
C1.Silverlight.Data Namespace


DataSet Methods

[image] [image]

.NET Framework Class Library
DataSet Methods
DataSet Class See Also

The DataSet type exposes the following members.

Methods

Name | Description
AcceptChanges | Marks all rows on all tables as unchanged.
Clear | Clears all rows in all tables of the DataSet.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChanges | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadXml | Overloaded.
Reset | Resets the DataSet.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
WriteXml | Overloaded.

See Also

DataSet Class
C1.Silverlight.Data Namespace


AcceptChanges Method

[image]

.NET Framework Class Library
DataSet..::.AcceptChanges Method
DataSet Class See Also
Marks all rows on all tables as unchanged.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void AcceptChanges()
Visual Basic (Declaration)
Public Sub AcceptChanges

See Also

DataSet Class
C1.Silverlight.Data Namespace


Clear Method

[image]

.NET Framework Class Library
DataSet..::.Clear Method
DataSet Class See Also
Clears all rows in all tables of the DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

DataSet Class
C1.Silverlight.Data Namespace


GetChanges Method

[image] [image]

.NET Framework Class Library
DataSet..::.GetChanges Method
DataSet Class See Also

Overload List

Name | Description
GetChanges()()() | Gets a DataSet containing all tables that have changed since the data was loaded or AcceptChanges()()() was called.
GetChanges(DataRowState) | Gets a DataSet containing all tables that have changed since the data was loaded or AcceptChanges()()() was called, or null if there are no changes.

See Also

DataSet Class
DataSet Members
C1.Silverlight.Data Namespace


GetChanges Method

[image]

.NET Framework Class Library
DataSet..::.GetChanges Method
DataSet Class See Also
Gets a DataSet containing all tables that have changed since the data was loaded or AcceptChanges()()() was called.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet GetChanges()
Visual Basic (Declaration)
Public Function GetChanges As DataSet

Return Value

A DataSet containing all modifications on all tables.

See Also

DataSet Class
GetChanges Overload
C1.Silverlight.Data Namespace


GetChanges Method (DataRowState)

[image]

.NET Framework Class Library
DataSet..::.GetChanges Method (DataRowState)
DataSet Class See Also
Gets a DataSet containing all tables that have changed since the data was loaded or AcceptChanges()()() was called, or null if there are no changes.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet GetChanges(
    DataRowState state
)
Visual Basic (Declaration)
Public Function GetChanges ( _
    state As DataRowState _
) As DataSet

Parameters

state
Type: C1.Silverlight.Data..::.DataRowState

Return Value

A DataSet containing all modifications on all tables, or null if there are no changes.

See Also

DataSet Class
GetChanges Overload
C1.Silverlight.Data Namespace


ReadXml Method

[image] [image]

.NET Framework Class Library
DataSet..::.ReadXml Method
DataSet Class See Also

Overload List

Name | Description
ReadXml(Stream) | Loads a DataSet from an Xml stream.
ReadXml(XmlReader) | Loads a DataSet from an XmlReader.

See Also

DataSet Class
DataSet Members
C1.Silverlight.Data Namespace


ReadXml Method (Stream)

[image]

.NET Framework Class Library
DataSet..::.ReadXml Method (Stream)
DataSet Class See Also
Loads a DataSet from an Xml stream.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void ReadXml(
    Stream stream
)
Visual Basic (Declaration)
Public Sub ReadXml ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream
Stream that contains the data.

See Also

DataSet Class
ReadXml Overload
C1.Silverlight.Data Namespace


ReadXml Method (XmlReader)

[image]

.NET Framework Class Library
DataSet..::.ReadXml Method (XmlReader)
DataSet Class See Also
Loads a DataSet from an XmlReader.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void ReadXml(
    XmlReader xr
)
Visual Basic (Declaration)
Public Sub ReadXml ( _
    xr As XmlReader _
)

Parameters

xr
Type: System.Xml..::.XmlReader
XmlReader that contains the data.

See Also

DataSet Class
ReadXml Overload
C1.Silverlight.Data Namespace


Reset Method

[image]

.NET Framework Class Library
DataSet..::.Reset Method
DataSet Class See Also
Resets the DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public virtual void Reset()
Visual Basic (Declaration)
Public Overridable Sub Reset

See Also

DataSet Class
C1.Silverlight.Data Namespace


WriteXml Method

[image] [image]

.NET Framework Class Library
DataSet..::.WriteXml Method
DataSet Class See Also

Overload List

Name | Description
WriteXml(Stream) | Writes a DataSet into an Xml stream.
WriteXml(XmlWriter) | Writes a DataSet into an XmlWriter.

See Also

DataSet Class
DataSet Members
C1.Silverlight.Data Namespace


WriteXml Method (Stream)

[image]

.NET Framework Class Library
DataSet..::.WriteXml Method (Stream)
DataSet Class See Also
Writes a DataSet into an Xml stream.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void WriteXml(
    Stream stream
)
Visual Basic (Declaration)
Public Sub WriteXml ( _
    stream As Stream _
)

Parameters

stream
Type: System.IO..::.Stream

See Also

DataSet Class
WriteXml Overload
C1.Silverlight.Data Namespace


WriteXml Method (XmlWriter)

[image]

.NET Framework Class Library
DataSet..::.WriteXml Method (XmlWriter)
DataSet Class See Also
Writes a DataSet into an XmlWriter.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void WriteXml(
    XmlWriter xw
)
Visual Basic (Declaration)
Public Sub WriteXml ( _
    xw As XmlWriter _
)

Parameters

xw
Type: System.Xml..::.XmlWriter

See Also

DataSet Class
WriteXml Overload
C1.Silverlight.Data Namespace


DataSet Properties

[image] [image]

.NET Framework Class Library
DataSet Properties
DataSet Class See Also

The DataSet type exposes the following members.

Properties

Name | Description
DataSetName | Gets or sets the name of this DataSet.
HasChanges | Gets a value that indicates whether the DataSet has any changes since it was created, loaded, or since the AcceptChanges()()() method was called.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
Relations | Gets a list with all the DataRelation objects in the DataSet.
Tables | Gets a list with all the DataTable objects in the DataSet.

See Also

DataSet Class
C1.Silverlight.Data Namespace


DataSetName Property

[image]

.NET Framework Class Library
DataSet..::.DataSetName Property
DataSet Class See Also
Gets or sets the name of this DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string DataSetName { get; set; }
Visual Basic (Declaration)
Public Property DataSetName As String

See Also

DataSet Class
C1.Silverlight.Data Namespace


HasChanges Property

[image]

.NET Framework Class Library
DataSet..::.HasChanges Property
DataSet Class See Also
Gets a value that indicates whether the DataSet has any changes since it was created, loaded, or since the AcceptChanges()()() method was called.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool HasChanges { get; }
Visual Basic (Declaration)
Public ReadOnly Property HasChanges As Boolean

See Also

DataSet Class
C1.Silverlight.Data Namespace


Relations Property

[image]

.NET Framework Class Library
DataSet..::.Relations Property
DataSet Class See Also
Gets a list with all the DataRelation objects in the DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelationCollection Relations { get; }
Visual Basic (Declaration)
Public ReadOnly Property Relations As DataRelationCollection

See Also

DataSet Class
C1.Silverlight.Data Namespace


Tables Property

[image]

.NET Framework Class Library
DataSet..::.Tables Property
DataSet Class See Also
Gets a list with all the DataTable objects in the DataSet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTableCollection Tables { get; }
Visual Basic (Declaration)
Public ReadOnly Property Tables As DataTableCollection

See Also

DataSet Class
C1.Silverlight.Data Namespace


DataTable Class

[image]

.NET Framework Class Library
DataTable Class
Members See Also
Subset of the System.Data.DataTable class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataTable : NamedObject
Visual Basic (Declaration)
Public Class DataTable _
    Inherits NamedObject

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.NamedObject
C1.Silverlight.Data..::.DataTable

See Also

DataTable Members
C1.Silverlight.Data Namespace


DataTable Members

[image] [image]

.NET Framework Class Library
DataTable Members
DataTable Class Constructors Methods Properties See Also

The DataTable type exposes the following members.

Constructors

Name | Description
DataTable | Overloaded.

Methods

Name | Description
AcceptChanges | Marks all rows as unchanged.
BeginLoadData | Suspends notifications during batch operations.
Compute | Overloaded.
EndLoadData | Resumes notifications suspended by a call to BeginLoadData()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChanges | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewRow | Creates a new DataRow that is compatible with this table.
Select | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ChildRelations | Gets a collection with all DataRelation objects for which this table is the parent table.
Columns | Gets a list of DataColumn columns.
DataSet | Gets the DataSet that owns this table.
DefaultView | Gets the default DataView associated with this DataTable.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
ParentRelations | Gets a collection with all DataRelation objects for which this table is the child table.
PrimaryKey | Gets or sets the DataColumn that is used as a key for this table.
Rows | Gets a list of DataRow objects.
TableName | Gets or sets the name of the table.

See Also

DataTable Class
C1.Silverlight.Data Namespace


DataTable Constructor

[image] [image]

.NET Framework Class Library
DataTable Constructor
DataTable Class See Also

Overload List

Name | Description
DataTable()()() | Initializes a new instance of a DataTable.
DataTable(String) | Initializes a new instance of a DataTable.

See Also

DataTable Class
DataTable Members
C1.Silverlight.Data Namespace


DataTable Constructor

[image]

.NET Framework Class Library
DataTable Constructor
DataTable Class See Also
Initializes a new instance of a DataTable.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable()
Visual Basic (Declaration)
Public Sub New

See Also

DataTable Class
DataTable Overload
C1.Silverlight.Data Namespace


DataTable Constructor (String)

[image]

.NET Framework Class Library
DataTable Constructor (String)
DataTable Class See Also
Initializes a new instance of a DataTable.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable(
    string tableName
)
Visual Basic (Declaration)
Public Sub New ( _
    tableName As String _
)

Parameters

tableName
Type: System..::.String
Name of the new DataTable.

See Also

DataTable Class
DataTable Overload
C1.Silverlight.Data Namespace


DataTable Methods

[image] [image]

.NET Framework Class Library
DataTable Methods
DataTable Class See Also

The DataTable type exposes the following members.

Methods

Name | Description
AcceptChanges | Marks all rows as unchanged.
BeginLoadData | Suspends notifications during batch operations.
Compute | Overloaded.
EndLoadData | Resumes notifications suspended by a call to BeginLoadData()()().
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetChanges | Overloaded.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NewRow | Creates a new DataRow that is compatible with this table.
Select | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTable Class
C1.Silverlight.Data Namespace


AcceptChanges Method

[image]

.NET Framework Class Library
DataTable..::.AcceptChanges Method
DataTable Class See Also
Marks all rows as unchanged.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void AcceptChanges()
Visual Basic (Declaration)
Public Sub AcceptChanges

See Also

DataTable Class
C1.Silverlight.Data Namespace


BeginLoadData Method

[image]

.NET Framework Class Library
DataTable..::.BeginLoadData Method
DataTable Class See Also
Suspends notifications during batch operations.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void BeginLoadData()
Visual Basic (Declaration)
Public Sub BeginLoadData

See Also

DataTable Class
C1.Silverlight.Data Namespace


Compute Method

[image] [image]

.NET Framework Class Library
DataTable..::.Compute Method
DataTable Class See Also

Overload List

Name | Description
Compute(String) | Evaluates an expression assuming no current row. This is mostly useful for computing aggregates, which are not supported yet.
Compute(String, DataRow) | Evaluates an expression using data in a given DataRow.

See Also

DataTable Class
DataTable Members
C1.Silverlight.Data Namespace


Compute Method (String)

[image]

.NET Framework Class Library
DataTable..::.Compute Method (String)
DataTable Class See Also
Evaluates an expression assuming no current row. This is mostly useful for computing aggregates, which are not supported yet.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object Compute(
    string expression
)
Visual Basic (Declaration)
Public Function Compute ( _
    expression As String _
) As Object

Parameters

expression
Type: System..::.String

Return Value

See Also

DataTable Class
Compute Overload
C1.Silverlight.Data Namespace


Compute Method (String, DataRow)

[image]

.NET Framework Class Library
DataTable..::.Compute Method (String, DataRow)
DataTable Class See Also
Evaluates an expression using data in a given DataRow.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Object Compute(
    string expression,
    DataRow row
)
Visual Basic (Declaration)
Public Function Compute ( _
    expression As String, _
    row As DataRow _
) As Object

Parameters

expression
Type: System..::.String
row
Type: C1.Silverlight.Data..::.DataRow

Return Value

See Also

DataTable Class
Compute Overload
C1.Silverlight.Data Namespace


EndLoadData Method

[image]

.NET Framework Class Library
DataTable..::.EndLoadData Method
DataTable Class See Also
Resumes notifications suspended by a call to BeginLoadData()()().

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void EndLoadData()
Visual Basic (Declaration)
Public Sub EndLoadData

See Also

DataTable Class
C1.Silverlight.Data Namespace


GetChanges Method

[image] [image]

.NET Framework Class Library
DataTable..::.GetChanges Method
DataTable Class See Also

Overload List

Name | Description
GetChanges()()() | Gets a DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.
GetChanges(DataRowState) | Gets a DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.

See Also

DataTable Class
DataTable Members
C1.Silverlight.Data Namespace


GetChanges Method

[image]

.NET Framework Class Library
DataTable..::.GetChanges Method
DataTable Class See Also
Gets a DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable GetChanges()
Visual Basic (Declaration)
Public Function GetChanges As DataTable

Return Value

A DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.

See Also

DataTable Class
GetChanges Overload
C1.Silverlight.Data Namespace


GetChanges Method (DataRowState)

[image]

.NET Framework Class Library
DataTable..::.GetChanges Method (DataRowState)
DataTable Class See Also
Gets a DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable GetChanges(
    DataRowState state
)
Visual Basic (Declaration)
Public Function GetChanges ( _
    state As DataRowState _
) As DataTable

Parameters

state
Type: C1.Silverlight.Data..::.DataRowState
DataRowState value used to filter the rows.

Return Value

A DataTable containing all rows that have changed since the table was loaded or AcceptChanges()()() was called, or null if the table contains no changes.

See Also

DataTable Class
GetChanges Overload
C1.Silverlight.Data Namespace


NewRow Method

[image]

.NET Framework Class Library
DataTable..::.NewRow Method
DataTable Class See Also
Creates a new DataRow that is compatible with this table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public virtual DataRow NewRow()
Visual Basic (Declaration)
Public Overridable Function NewRow As DataRow

Return Value

See Also

DataTable Class
C1.Silverlight.Data Namespace


Select Method

[image] [image]

.NET Framework Class Library
DataTable..::.Select Method
DataTable Class See Also

Overload List

Name | Description
Select()()() | Gets an array with all rows in the table.
Select(String) | Gets an array with all rows in the table that match a filter expression.

See Also

DataTable Class
DataTable Members
C1.Silverlight.Data Namespace


Select Method

[image]

.NET Framework Class Library
DataTable..::.Select Method
DataTable Class See Also
Gets an array with all rows in the table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow[] Select()
Visual Basic (Declaration)
Public Function Select As DataRow()

Return Value

See Also

DataTable Class
Select Overload
C1.Silverlight.Data Namespace


Select Method (String)

[image]

.NET Framework Class Library
DataTable..::.Select Method (String)
DataTable Class See Also
Gets an array with all rows in the table that match a filter expression.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRow[] Select(
    string filterExpression
)
Visual Basic (Declaration)
Public Function Select ( _
    filterExpression As String _
) As DataRow()

Parameters

filterExpression
Type: System..::.String

Return Value

See Also

DataTable Class
Select Overload
C1.Silverlight.Data Namespace


DataTable Properties

[image] [image]

.NET Framework Class Library
DataTable Properties
DataTable Class See Also

The DataTable type exposes the following members.

Properties

Name | Description
ChildRelations | Gets a collection with all DataRelation objects for which this table is the parent table.
Columns | Gets a list of DataColumn columns.
DataSet | Gets the DataSet that owns this table.
DefaultView | Gets the default DataView associated with this DataTable.
Name | Gets or sets the object's name. (Inherited from NamedObject.)
ParentRelations | Gets a collection with all DataRelation objects for which this table is the child table.
PrimaryKey | Gets or sets the DataColumn that is used as a key for this table.
Rows | Gets a list of DataRow objects.
TableName | Gets or sets the name of the table.

See Also

DataTable Class
C1.Silverlight.Data Namespace


ChildRelations Property

[image]

.NET Framework Class Library
DataTable..::.ChildRelations Property
DataTable Class See Also
Gets a collection with all DataRelation objects for which this table is the parent table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelationCollection ChildRelations { get; internal set; }
Visual Basic (Declaration)
Public Property ChildRelations As DataRelationCollection

See Also

DataTable Class
C1.Silverlight.Data Namespace


Columns Property

[image]

.NET Framework Class Library
DataTable..::.Columns Property
DataTable Class See Also
Gets a list of DataColumn columns.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumnList Columns { get; }
Visual Basic (Declaration)
Public ReadOnly Property Columns As DataColumnList

See Also

DataTable Class
C1.Silverlight.Data Namespace


DataSet Property

[image]

.NET Framework Class Library
DataTable..::.DataSet Property
DataTable Class See Also
Gets the DataSet that owns this table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataSet DataSet { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSet As DataSet

See Also

DataTable Class
C1.Silverlight.Data Namespace


DefaultView Property

[image]

.NET Framework Class Library
DataTable..::.DefaultView Property
DataTable Class See Also
Gets the default DataView associated with this DataTable.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataView DefaultView { get; }
Visual Basic (Declaration)
Public ReadOnly Property DefaultView As DataView

See Also

DataTable Class
C1.Silverlight.Data Namespace


ParentRelations Property

[image]

.NET Framework Class Library
DataTable..::.ParentRelations Property
DataTable Class See Also
Gets a collection with all DataRelation objects for which this table is the child table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRelationCollection ParentRelations { get; internal set; }
Visual Basic (Declaration)
Public Property ParentRelations As DataRelationCollection

See Also

DataTable Class
C1.Silverlight.Data Namespace


PrimaryKey Property

[image]

.NET Framework Class Library
DataTable..::.PrimaryKey Property
DataTable Class See Also
Gets or sets the DataColumn that is used as a key for this table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataColumn PrimaryKey { get; set; }
Visual Basic (Declaration)
Public Property PrimaryKey As DataColumn

See Also

DataTable Class
C1.Silverlight.Data Namespace


Rows Property

[image]

.NET Framework Class Library
DataTable..::.Rows Property
DataTable Class See Also
Gets a list of DataRow objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataRowCollection Rows { get; }
Visual Basic (Declaration)
Public ReadOnly Property Rows As DataRowCollection

See Also

DataTable Class
C1.Silverlight.Data Namespace


TableName Property

[image]

.NET Framework Class Library
DataTable..::.TableName Property
DataTable Class See Also
Gets or sets the name of the table.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string TableName { get; set; }
Visual Basic (Declaration)
Public Property TableName As String

See Also

DataTable Class
C1.Silverlight.Data Namespace


DataTableCollection Class

[image]

.NET Framework Class Library
DataTableCollection Class
Members See Also
List of DataTable objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataTableCollection : NamedObjectCollection<DataTable>
Visual Basic (Declaration)
Public Class DataTableCollection _
    Inherits NamedObjectCollection(Of DataTable)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( DataTable >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( DataTable >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( DataTable >)>)
C1.Silverlight.Data..::.NamedObjectCollection <(Of <( DataTable >)>)
C1.Silverlight.Data..::.DataTableCollection

See Also

DataTableCollection Members
C1.Silverlight.Data Namespace


DataTableCollection Members

[image] [image]

.NET Framework Class Library
DataTableCollection Members
DataTableCollection Class Methods Properties Events See Also

The DataTableCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all the DataTable items from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataTable >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataTable >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides UpdatableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


DataTableCollection Methods

[image] [image]

.NET Framework Class Library
DataTableCollection Methods
DataTableCollection Class See Also

The DataTableCollection type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all the DataTable items from the list.
ClearItems | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( DataTable >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( DataTable >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides UpdatableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


Add Method

[image] [image]

.NET Framework Class Library
DataTableCollection..::.Add Method
DataTableCollection Class See Also

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Add(String) | Creates an item and appends it to the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataTableCollection Class
DataTableCollection Members
C1.Silverlight.Data Namespace


Clear Method

[image]

.NET Framework Class Library
DataTableCollection..::.Clear Method
DataTableCollection Class See Also
Removes all the DataTable items from the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


Contains Method

[image] [image]

.NET Framework Class Library
DataTableCollection..::.Contains Method
DataTableCollection Class See Also

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Contains(String) | Gets a value that determines whether an item is a member of the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataTableCollection Class
DataTableCollection Members
C1.Silverlight.Data Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
DataTableCollection..::.IndexOf Method
DataTableCollection Class See Also

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
IndexOf(String) | Gets the index of an item in the list. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataTableCollection Class
DataTableCollection Members
C1.Silverlight.Data Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
DataTableCollection..::.OnCollectionChanged Method
DataTableCollection Class See Also
Raises the CollectionChanged event.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
NotifyCollectionChangedEventArgs that contains the event data.

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


DataTableCollection Properties

[image] [image]

.NET Framework Class Library
DataTableCollection Properties
DataTableCollection Class See Also

The DataTableCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( DataTable >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataTableCollection..::.Item Property
DataTableCollection Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( DataTable >)>).)
Item[([(String])]) | Gets or sets an item in the list by name. (Inherited from NamedObjectCollection<(Of <(T>)>).)

See Also

DataTableCollection Class
DataTableCollection Members
C1.Silverlight.Data Namespace


DataTableCollection Events

[image] [image]

.NET Framework Class Library
DataTableCollection Events
DataTableCollection Class See Also

The DataTableCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( DataTable >)>).)

See Also

DataTableCollection Class
C1.Silverlight.Data Namespace


DataView Class

[image]

.NET Framework Class Library
DataView Class
Members See Also
Represents a databindable, customized view of a DataTable used for sorting and filtering.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class DataView : CollectionView
Visual Basic (Declaration)
Public Class DataView _
    Inherits CollectionView

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( Object >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( Object >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( Object >)>)
C1.Silverlight.Data..::.CollectionView
C1.Silverlight.Data..::.DataView

See Also

DataView Members
C1.Silverlight.Data Namespace


DataView Members

[image] [image]

.NET Framework Class Library
DataView Members
DataView Class Constructors Methods Properties Events See Also

The DataView type exposes the following members.

Constructors

Name | Description
DataView | Overloaded.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Object >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Object >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewObject | Gets a DataRowView object that wraps a raw DataRow. (Overrides CollectionView..::.GetViewObject(Object).)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Object >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetFilter | Sets the Predicate that defines how the view is filtered. (Inherited from CollectionView.)
SetItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetSortDescriptions | Overloaded.
SetSource | Sets the source collection. (Inherited from CollectionView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Object >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RowFilter | Gets or sets a string that specifies which rows should be included in this DataView.
Sort | Gets or sets a string that specifies the columns used to sort this DataView.
Table | Gets or sets the DataTable that provides data for this DataView.
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)

See Also

DataView Class
C1.Silverlight.Data Namespace


DataView Constructor

[image] [image]

.NET Framework Class Library
DataView Constructor
DataView Class See Also

Overload List

Name | Description
DataView(DataTable) | Initializes a new instance of a DataView class.
DataView(DataTable, array<String>[]()[]) | Initializes a new instance of a DataView class.

See Also

DataView Class
DataView Members
C1.Silverlight.Data Namespace


DataView Constructor (DataTable)

[image]

.NET Framework Class Library
DataView Constructor (DataTable)
DataView Class See Also
Initializes a new instance of a DataView class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataView(
    DataTable table
)
Visual Basic (Declaration)
Public Sub New ( _
    table As DataTable _
)

Parameters

table
Type: C1.Silverlight.Data..::.DataTable
The DataTable that provides data for this DataView.

See Also

DataView Class
DataView Overload
C1.Silverlight.Data Namespace


DataView Constructor (DataTable, String[])

[image]

.NET Framework Class Library
DataView Constructor (DataTable, array<String>[]()[])
DataView Class See Also
Initializes a new instance of a DataView class.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataView(
    DataTable table,
    params string[] columnNames
)
Visual Basic (Declaration)
Public Sub New ( _
    table As DataTable, _
    ParamArray columnNames As String() _
)

Parameters

table
Type: C1.Silverlight.Data..::.DataTable
The DataTable that provides data for this DataView.
columnNames
Type: array< System..::.String >[]()[]
Array containing the names of the columns exposed by this DataView.

See Also

DataView Class
DataView Overload
C1.Silverlight.Data Namespace


DataView Methods

[image] [image]

.NET Framework Class Library
DataView Methods
DataView Class See Also

The DataView type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( Object >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( Object >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetViewObject | Gets a DataRowView object that wraps a raw DataRow. (Overrides CollectionView..::.GetViewObject(Object).)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( Object >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetFilter | Sets the Predicate that defines how the view is filtered. (Inherited from CollectionView.)
SetItem | (Inherited from ObservableCollection <(Of <( Object >)>).)
SetSortDescriptions | Overloaded.
SetSource | Sets the source collection. (Inherited from CollectionView.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataView Class
C1.Silverlight.Data Namespace


GetViewObject Method

[image]

.NET Framework Class Library
DataView..::.GetViewObject Method
DataView Class See Also
Gets a DataRowView object that wraps a raw DataRow.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override Object GetViewObject(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function GetViewObject ( _
    item As Object _
) As Object

Parameters

item
Type: System..::.Object
The raw DataRow.

Return Value

A DataRowView that wraps a DataRow and makes it bindable.

See Also

DataView Class
C1.Silverlight.Data Namespace


SetSortDescriptions Method

[image] [image]

.NET Framework Class Library
DataView..::.SetSortDescriptions Method
DataView Class See Also

Overload List

Name | Description
SetSortDescriptions(SortDescriptionCollection) | Sets the SortDescriptionCollection that defines how the view is sorted. (Inherited from CollectionView.)
SetSortDescriptions(String) | Sets the SortDescriptionCollection that defines how the view is sorted. (Inherited from CollectionView.)

See Also

DataView Class
DataView Members
C1.Silverlight.Data Namespace


DataView Properties

[image] [image]

.NET Framework Class Library
DataView Properties
DataView Class See Also

The DataView type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( Object >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( Object >)>).)
RowFilter | Gets or sets a string that specifies which rows should be included in this DataView.
Sort | Gets or sets a string that specifies the columns used to sort this DataView.
Table | Gets or sets the DataTable that provides data for this DataView.
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

DataView Class
C1.Silverlight.Data Namespace


RowFilter Property

[image]

.NET Framework Class Library
DataView..::.RowFilter Property
DataView Class See Also
Gets or sets a string that specifies which rows should be included in this DataView.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string RowFilter { get; set; }
Visual Basic (Declaration)
Public Property RowFilter As String

See Also

DataView Class
C1.Silverlight.Data Namespace


Sort Property

[image]

.NET Framework Class Library
DataView..::.Sort Property
DataView Class See Also
Gets or sets a string that specifies the columns used to sort this DataView.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string Sort { get; set; }
Visual Basic (Declaration)
Public Property Sort As String

See Also

DataView Class
C1.Silverlight.Data Namespace


Table Property

[image]

.NET Framework Class Library
DataView..::.Table Property
DataView Class See Also
Gets or sets the DataTable that provides data for this DataView.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public DataTable Table { get; set; }
Visual Basic (Declaration)
Public Property Table As DataTable

See Also

DataView Class
C1.Silverlight.Data Namespace


DataView Events

[image] [image]

.NET Framework Class Library
DataView Events
DataView Class See Also

The DataView type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( Object >)>).)

See Also

DataView Class
C1.Silverlight.Data Namespace


ForeignKeyConstraint Class

[image]

.NET Framework Class Library
ForeignKeyConstraint Class
Members See Also
Represents an action restriction enforced on a set of columns when a row is deleted or updated.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class ForeignKeyConstraint
Visual Basic (Declaration)
Public Class ForeignKeyConstraint

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.ForeignKeyConstraint

See Also

ForeignKeyConstraint Members
C1.Silverlight.Data Namespace


ForeignKeyConstraint Members

[image] [image]

.NET Framework Class Library
ForeignKeyConstraint Members
ForeignKeyConstraint Class Methods Properties See Also

The ForeignKeyConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AcceptRejectRule | Gets or sets the action that occurs across this constraint when changes are accepted.
DeleteRule | Gets or sets the action that occurs across this constraint when a row is deleted.
UpdateRule | Gets or sets the action that occurs across this constraint when a row is updated.

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


ForeignKeyConstraint Methods

[image] [image]

.NET Framework Class Library
ForeignKeyConstraint Methods
ForeignKeyConstraint Class See Also

The ForeignKeyConstraint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


ForeignKeyConstraint Properties

[image] [image]

.NET Framework Class Library
ForeignKeyConstraint Properties
ForeignKeyConstraint Class See Also

The ForeignKeyConstraint type exposes the following members.

Properties

Name | Description
AcceptRejectRule | Gets or sets the action that occurs across this constraint when changes are accepted.
DeleteRule | Gets or sets the action that occurs across this constraint when a row is deleted.
UpdateRule | Gets or sets the action that occurs across this constraint when a row is updated.

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


AcceptRejectRule Property

[image]

.NET Framework Class Library
ForeignKeyConstraint..::.AcceptRejectRule Property
ForeignKeyConstraint Class See Also
Gets or sets the action that occurs across this constraint when changes are accepted.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public AcceptRejectRule AcceptRejectRule { get; set; }
Visual Basic (Declaration)
Public Property AcceptRejectRule As AcceptRejectRule

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


DeleteRule Property

[image]

.NET Framework Class Library
ForeignKeyConstraint..::.DeleteRule Property
ForeignKeyConstraint Class See Also
Gets or sets the action that occurs across this constraint when a row is deleted.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Rule DeleteRule { get; set; }
Visual Basic (Declaration)
Public Property DeleteRule As Rule

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


UpdateRule Property

[image]

.NET Framework Class Library
ForeignKeyConstraint..::.UpdateRule Property
ForeignKeyConstraint Class See Also
Gets or sets the action that occurs across this constraint when a row is updated.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public Rule UpdateRule { get; set; }
Visual Basic (Declaration)
Public Property UpdateRule As Rule

See Also

ForeignKeyConstraint Class
C1.Silverlight.Data Namespace


NamedObject Class

[image]

.NET Framework Class Library
NamedObject Class
Members See Also
Object that has a Name property.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class NamedObject
Visual Basic (Declaration)
Public Class NamedObject

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Data..::.NamedObject
C1.Silverlight.Data..::.DataColumn
C1.Silverlight.Data..::.DataRelation
C1.Silverlight.Data..::.DataSet
C1.Silverlight.Data..::.DataTable

See Also

NamedObject Members
C1.Silverlight.Data Namespace


NamedObject Members

[image] [image]

.NET Framework Class Library
NamedObject Members
NamedObject Class Constructors Methods Properties See Also

The NamedObject type exposes the following members.

Constructors

Name | Description
NamedObject |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name | Gets or sets the object's name.

See Also

NamedObject Class
C1.Silverlight.Data Namespace


NamedObject Constructor

[image]

.NET Framework Class Library
NamedObject Constructor
NamedObject Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public NamedObject()
Visual Basic (Declaration)
Public Sub New

See Also

NamedObject Class
C1.Silverlight.Data Namespace


NamedObject Methods

[image] [image]

.NET Framework Class Library
NamedObject Methods
NamedObject Class See Also

The NamedObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedObject Class
C1.Silverlight.Data Namespace


NamedObject Properties

[image] [image]

.NET Framework Class Library
NamedObject Properties
NamedObject Class See Also

The NamedObject type exposes the following members.

Properties

Name | Description
Name | Gets or sets the object's name.

See Also

NamedObject Class
C1.Silverlight.Data Namespace


Name Property

[image]

.NET Framework Class Library
NamedObject..::.Name Property
NamedObject Class See Also
Gets or sets the object's name.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String

See Also

NamedObject Class
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Class

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Class
Members See Also
Collection of named objects, provides string indexer to retrieve objects by name.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class NamedObjectCollection<T> : UpdatableCollection<T>
where T : new(), NamedObject
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class NamedObjectCollection(Of T As {New, NamedObject}) _
    Inherits UpdatableCollection(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(T>)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <(T>)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <(T>)>)
C1.Silverlight.Data..::.NamedObjectCollection<(Of <(T>)>)
C1.Silverlight.Data..::.DataColumnList
C1.Silverlight.Data..::.DataRelationCollection
C1.Silverlight.Data..::.DataTableCollection

See Also

NamedObjectCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Members

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Members
NamedObjectCollection<(Of <(T>)>) Class Constructors Methods Properties Events See Also

The NamedObjectCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
NamedObjectCollection<(Of <(T>)>) |

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( T >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( T >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( T >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( T >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)

See Also

NamedObjectCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Constructor

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Constructor
NamedObjectCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public NamedObjectCollection()
Visual Basic (Declaration)
Public Sub New

See Also

NamedObjectCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Methods

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Methods
NamedObjectCollection<(Of <(T>)>) Class See Also

The NamedObjectCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( T >)>).)
Contains | Overloaded.
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( T >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( T >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( T >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NamedObjectCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


Add Method

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Add Method
NamedObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Add(T) | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Add(String) | Creates an item and appends it to the list.

See Also

NamedObjectCollection<(Of <(T>)>) Class
NamedObjectCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


Add Method (String)

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Add Method (String)
NamedObjectCollection<(Of <(T>)>) Class See Also
Creates an item and appends it to the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public T Add(
    string name
)
Visual Basic (Declaration)
Public Function Add ( _
    name As String _
) As T

Parameters

name
Type: System..::.String
Name of the new item.

Return Value

A reference to the new item added to the list.

See Also

NamedObjectCollection<(Of <(T>)>) Class
Add Overload
C1.Silverlight.Data Namespace


Contains Method

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Contains Method
NamedObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Contains(T) | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Contains(String) | Gets a value that determines whether an item is a member of the list.

See Also

NamedObjectCollection<(Of <(T>)>) Class
NamedObjectCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


Contains Method (String)

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Contains Method (String)
NamedObjectCollection<(Of <(T>)>) Class See Also
Gets a value that determines whether an item is a member of the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool Contains(
    string name
)
Visual Basic (Declaration)
Public Function Contains ( _
    name As String _
) As Boolean

Parameters

name
Type: System..::.String
Name of the item to search.

Return Value

True if the list contains an item named name, false otherwise.

See Also

NamedObjectCollection<(Of <(T>)>) Class
Contains Overload
C1.Silverlight.Data Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.IndexOf Method
NamedObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
IndexOf(String) | Gets the index of an item in the list.

See Also

NamedObjectCollection<(Of <(T>)>) Class
NamedObjectCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


IndexOf Method (String)

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.IndexOf Method (String)
NamedObjectCollection<(Of <(T>)>) Class See Also
Gets the index of an item in the list.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public int IndexOf(
    string name
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    name As String _
) As Integer

Parameters

name
Type: System..::.String
Name of the item to search.

Return Value

The index of the item in the list, or -1 if the item could not be found.

See Also

NamedObjectCollection<(Of <(T>)>) Class
IndexOf Overload
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Properties

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Properties
NamedObjectCollection<(Of <(T>)>) Class See Also

The NamedObjectCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Item | Overloaded.
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

NamedObjectCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


Item Property

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Item Property
NamedObjectCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Item[([(Int32])]) | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( T >)>).)
Item[([(String])]) | Gets or sets an item in the list by name.

See Also

NamedObjectCollection<(Of <(T>)>) Class
NamedObjectCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


Item Property (String)

[image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>)..::.Item Property (String)
NamedObjectCollection<(Of <(T>)>) Class See Also
Gets or sets an item in the list by name.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public T this[
    string name
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    name As String _
) As T

Parameters

name
Type: System..::.String
Name of the item to get or set.

Return Value

A reference to the item with the given name.

See Also

NamedObjectCollection<(Of <(T>)>) Class
Item Overload
C1.Silverlight.Data Namespace


NamedObjectCollection(T) Events

[image] [image]

.NET Framework Class Library
NamedObjectCollection<(Of <(T>)>) Events
NamedObjectCollection<(Of <(T>)>) Class See Also

The NamedObjectCollection<(Of <(T>)>) type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)

See Also

NamedObjectCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


Rule Enumeration

[image]

.NET Framework Class Library
Rule Enumeration
See Also
Indicates the action that occurs across this constraint when rows are updated or deleted.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public enum Rule
Visual Basic (Declaration)
Public Enumeration Rule

Members

Member name | Description
Cascade | Changes are cascaded across the data relation.
None | No action is taken.
SetDefault | Set values on related rows to the default value.
SetNull | Set values on related rows to null.

See Also

C1.Silverlight.Data Namespace


SortDescription Structure

[image]

.NET Framework Class Library
SortDescription Structure
Members See Also
Defines the direction and the property name to be used as the criteria for sorting a collection.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public struct SortDescription
Visual Basic (Declaration)
Public Structure SortDescription

See Also

SortDescription Members
C1.Silverlight.Data Namespace


SortDescription Members

[image] [image]

.NET Framework Class Library
SortDescription Members
SortDescription Structure Methods Properties See Also

The SortDescription type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

Properties

Name | Description
Descending | Gets or sets whether the sorting should be performed in descending order.
PropertyInfo | Gets or sets a PropertyInfo object that defines the property used for sorting.

See Also

SortDescription Structure
C1.Silverlight.Data Namespace


SortDescription Methods

[image] [image]

.NET Framework Class Library
SortDescription Methods
SortDescription Structure See Also

The SortDescription type exposes the following members.

Methods

Name | Description
Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)

See Also

SortDescription Structure
C1.Silverlight.Data Namespace


SortDescription Properties

[image] [image]

.NET Framework Class Library
SortDescription Properties
SortDescription Structure See Also

The SortDescription type exposes the following members.

Properties

Name | Description
Descending | Gets or sets whether the sorting should be performed in descending order.
PropertyInfo | Gets or sets a PropertyInfo object that defines the property used for sorting.

See Also

SortDescription Structure
C1.Silverlight.Data Namespace


Descending Property

[image]

.NET Framework Class Library
SortDescription..::.Descending Property
SortDescription Structure See Also
Gets or sets whether the sorting should be performed in descending order.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool Descending { get; set; }
Visual Basic (Declaration)
Public Property Descending As Boolean

See Also

SortDescription Structure
C1.Silverlight.Data Namespace


PropertyInfo Property

[image]

.NET Framework Class Library
SortDescription..::.PropertyInfo Property
SortDescription Structure See Also
Gets or sets a PropertyInfo object that defines the property used for sorting.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public PropertyInfo PropertyInfo { get; set; }
Visual Basic (Declaration)
Public Property PropertyInfo As PropertyInfo

See Also

SortDescription Structure
C1.Silverlight.Data Namespace


SortDescriptionCollection Class

[image]

.NET Framework Class Library
SortDescriptionCollection Class
Members See Also
Collection of SortDescription objects.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class SortDescriptionCollection : UpdatableCollection<SortDescription>
Visual Basic (Declaration)
Public Class SortDescriptionCollection _
    Inherits UpdatableCollection(Of SortDescription)

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <( SortDescription >)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <( SortDescription >)>)
C1.Silverlight.Data..::.UpdatableCollection <(Of <( SortDescription >)>)
C1.Silverlight.Data..::.SortDescriptionCollection

See Also

SortDescriptionCollection Members
C1.Silverlight.Data Namespace


SortDescriptionCollection Members

[image] [image]

.NET Framework Class Library
SortDescriptionCollection Members
SortDescriptionCollection Class Constructors Methods Properties Events See Also

The SortDescriptionCollection type exposes the following members.

Constructors

Name | Description
SortDescriptionCollection |

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( SortDescription >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( SortDescription >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( SortDescription >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)

See Also

SortDescriptionCollection Class
C1.Silverlight.Data Namespace


SortDescriptionCollection Constructor

[image]

.NET Framework Class Library
SortDescriptionCollection Constructor
SortDescriptionCollection Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public SortDescriptionCollection()
Visual Basic (Declaration)
Public Sub New

See Also

SortDescriptionCollection Class
C1.Silverlight.Data Namespace


SortDescriptionCollection Methods

[image] [image]

.NET Framework Class Library
SortDescriptionCollection Methods
SortDescriptionCollection Class See Also

The SortDescriptionCollection type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called. (Inherited from UpdatableCollection<(Of <(T>)>).)
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( SortDescription >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( SortDescription >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Inherited from UpdatableCollection<(Of <(T>)>).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortDescriptionCollection Class
C1.Silverlight.Data Namespace


SortDescriptionCollection Properties

[image] [image]

.NET Framework Class Library
SortDescriptionCollection Properties
SortDescriptionCollection Class See Also

The SortDescriptionCollection type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( SortDescription >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( SortDescription >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method. (Inherited from UpdatableCollection<(Of <(T>)>).)

See Also

SortDescriptionCollection Class
C1.Silverlight.Data Namespace


SortDescriptionCollection Events

[image] [image]

.NET Framework Class Library
SortDescriptionCollection Events
SortDescriptionCollection Class See Also

The SortDescriptionCollection type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( SortDescription >)>).)

See Also

SortDescriptionCollection Class
C1.Silverlight.Data Namespace


UpdatableCollection(T) Class

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Class
Members See Also
Observable collection similar to the one in System.Collections.ObjectModel but with BeginUpdate/EndUpdate methods used to optionally suppress notifications.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public class UpdatableCollection<T> : ObservableCollection<T>
Visual Basic (Declaration)
Public Class UpdatableCollection(Of T) _
    Inherits ObservableCollection(Of T)

Type Parameters

T

Inheritance Hierarchy

System..::.Object
System.Collections.ObjectModel..::.Collection <(Of <(T>)>)
System.Collections.ObjectModel..::.ObservableCollection <(Of <(T>)>)
C1.Silverlight.Data..::.UpdatableCollection<(Of <(T>)>)
C1.Silverlight.Data..::.CollectionView
C1.Silverlight.Data..::.DataRowCollection
C1.Silverlight.Data..::.NamedObjectCollection<(Of <(T>)>)
C1.Silverlight.Data..::.SortDescriptionCollection

See Also

UpdatableCollection<(Of <(T>)>) Members
C1.Silverlight.Data Namespace


UpdatableCollection(T) Members

[image] [image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Members
UpdatableCollection<(Of <(T>)>) Class Constructors Methods Properties Events See Also

The UpdatableCollection<(Of <(T>)>) type exposes the following members.

Constructors

Name | Description
UpdatableCollection<(Of <(T>)>) |

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( T >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( T >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( T >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides ObservableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( T >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( T >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


UpdatableCollection(T) Constructor

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Constructor
UpdatableCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public UpdatableCollection()
Visual Basic (Declaration)
Public Sub New

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


UpdatableCollection(T) Methods

[image] [image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Methods
UpdatableCollection<(Of <(T>)>) Class See Also

The UpdatableCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
BeginUpdate | Prevents the list from firing notification events until the EndUpdate()()() method is called.
Clear | Removes all elements from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
ClearItems | (Inherited from ObservableCollection <(Of <( T >)>).)
Contains | Determines whether an element is in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
CopyTo | Copies the entire Collection<(Of <(T>)>) to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection <(Of <( T >)>).)
EndUpdate | Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Insert | Inserts an element into the Collection<(Of <(T>)>) at the specified index. (Inherited from Collection <(Of <( T >)>).)
InsertItem | (Inherited from ObservableCollection <(Of <( T >)>).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCollectionChanged | Raises the CollectionChanged event. (Overrides ObservableCollection<(Of <(T>)>)..::.OnCollectionChanged(NotifyCollectionChangedEventArgs).)
OnPropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
Remove | Removes the first occurrence of a specific object from the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveAt | Removes the element at the specified index of the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
RemoveItem | (Inherited from ObservableCollection <(Of <( T >)>).)
SetItem | (Inherited from ObservableCollection <(Of <( T >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


BeginUpdate Method

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>)..::.BeginUpdate Method
UpdatableCollection<(Of <(T>)>) Class See Also
Prevents the list from firing notification events until the EndUpdate()()() method is called.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public virtual void BeginUpdate()
Visual Basic (Declaration)
Public Overridable Sub BeginUpdate

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


EndUpdate Method

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>)..::.EndUpdate Method
UpdatableCollection<(Of <(T>)>) Class See Also
Resumes event firing after it had been suspended by a call to the BeginUpdate()()() method.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public virtual void EndUpdate()
Visual Basic (Declaration)
Public Overridable Sub EndUpdate

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


OnCollectionChanged Method

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>)..::.OnCollectionChanged Method
UpdatableCollection<(Of <(T>)>) Class See Also
Raises the CollectionChanged event.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
protected override void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnCollectionChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


UpdatableCollection(T) Properties

[image] [image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Properties
UpdatableCollection<(Of <(T>)>) Class See Also

The UpdatableCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count | Gets the number of elements actually contained in the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Item | Gets or sets the element at the specified index. (Inherited from Collection <(Of <( T >)>).)
Items | Gets a List<(Of <(T>)>) wrapper around the Collection<(Of <(T>)>). (Inherited from Collection <(Of <( T >)>).)
Updating | Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method.

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


Updating Property

[image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>)..::.Updating Property
UpdatableCollection<(Of <(T>)>) Class See Also
Gets whether events are temporarily suspended because of calls to the BeginUpdate()()() method.

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
public bool Updating { get; }
Visual Basic (Declaration)
Public ReadOnly Property Updating As Boolean

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


UpdatableCollection(T) Events

[image] [image]

.NET Framework Class Library
UpdatableCollection<(Of <(T>)>) Events
UpdatableCollection<(Of <(T>)>) Class See Also

The UpdatableCollection<(Of <(T>)>) type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from ObservableCollection <(Of <( T >)>).)
PropertyChanged | (Inherited from ObservableCollection <(Of <( T >)>).)

See Also

UpdatableCollection<(Of <(T>)>) Class
C1.Silverlight.Data Namespace


C1.Silverlight.Extended Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Extended Namespace

Classes

Class | Description
C1Accordion | ItemsControl that contains C1Expander and allows only one to be expanded at a time (similar to the NavigationBar in Outlook).
C1Book | ItemsControl that contains elements which are shown as pages of a book. The user can turn the pages like in a real book using the mouse to drag them.
C1ColorButton | Button that represents a color.
C1ColorHslPad | Represents a HSL color selection pad.
C1ColorPicker | Allow to pick a color from a color palette or build an advanced color using RGB or HSL. Keeps a list of the recent used colors.
C1Cube | ItemsControl that provides a 3D rotating cube with different content on each face.
C1Expander | C1Expander is a C1HeaderedContentControl whose content's visibility can be toggled clicking on its header.
C1ExpanderButton | Toggle Button whose ExpandDirection property and states are used to change the appearance of the expand button of the C1Expander.
C1HtmlHost | Control that shows HTML content within a Silverlight page.
C1ImageMagnifier | Customizable magnifier for an image
C1ImageRotator | Control that applies a pseudo-3D effect to rotate images.
ColorPalette | Class that defines named groups of colors.
ColorPaletteEntry | Class that contains information about the color, its name and description.
WebColor | Utility methods for web colors.

Enumerations

Enumeration | Description
ApplyPageTemplate | Specifies when the page template will be taken into account.
C1ColorPickerMode | Pick the mode for the C1ColorPicker.
CubeFace | Specifies a face in a cube.
ExpandDirection | Specifies the direction in which a C1Expander control opens.
Office2007ColorTheme | Specifies a color theme from the standard Office2007 theme collection.


ApplyPageTemplate Enumeration

[image]

.NET Framework Class Library
ApplyPageTemplate Enumeration
See Also
Specifies when the page template will be taken into account.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public enum ApplyPageTemplate
Visual Basic (Declaration)
Public Enumeration ApplyPageTemplate

Members

Member name | Description
True | The page template will be applied to the page.
False | The page template won't be applied to the page

See Also

C1.Silverlight.Extended Namespace


C1Accordion Class

[image]

.NET Framework Class Library
C1Accordion Class
Members See Also
ItemsControl that contains C1Expander and allows only one to be expanded at a time (similar to the NavigationBar in Outlook).

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1Accordion : ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1Accordion _
    Inherits ItemsControl

Remarks

C1Accordion is an ItemsControl so items are added to the Items collection or a collection is set to ItemsSource. Either way, if a UIElement is added that is not a C1Expander it is shown inside a C1Expander as its Content. When using ItemTemplate the behavior is similar. If the template doesn't generate a C1Expander, the generated element from the template is shown inside a C1Expander. C1Accordion uses a Grid as its ItemsPanel. If ItemsPanel is set to a different Panel the layout won't work correctly.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Extended..::.C1Accordion

See Also

C1Accordion Members
C1.Silverlight.Extended Namespace


C1Accordion Members

[image] [image]

.NET Framework Class Library
C1Accordion Members
C1Accordion Class Constructors Methods Fields Properties Events See Also

The C1Accordion type exposes the following members.

Constructors

Name | Description
C1Accordion | Initializes a new instance of a C1Accordion.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AllowCollapseAllProperty | Identifies the AllowCollapseAll dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.
ExpanderStyleProperty | Identifies the ExpanderStyle dependency property.
FillProperty | Identifies the Fill dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowCollapseAll | Gets or sets whether the accordion allows the user to collapse all items.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
ExpandDirection | Gets or sets the direction the contained C1Expanders expands.
ExpanderStyle | Gets or sets the Style that is applied to the expander element of each item.
Fill | Gets or sets whether the expanded item should fill the remaining space in the control.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Accordion Constructor

[image]

.NET Framework Class Library
C1Accordion Constructor
C1Accordion Class See Also
Initializes a new instance of a C1Accordion.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1Accordion()
Visual Basic (Declaration)
Public Sub New

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Accordion Fields

[image] [image]

.NET Framework Class Library
C1Accordion Fields
C1Accordion Class See Also

The C1Accordion type exposes the following members.

Fields

Name | Description
AllowCollapseAllProperty | Identifies the AllowCollapseAll dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.
ExpanderStyleProperty | Identifies the ExpanderStyle dependency property.
FillProperty | Identifies the Fill dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


AllowCollapseAllProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.AllowCollapseAllProperty Field
C1Accordion Class See Also
Identifies the AllowCollapseAll dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty AllowCollapseAllProperty
Visual Basic (Declaration)
Public Shared ReadOnly AllowCollapseAllProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.DisabledStyleProperty Field
C1Accordion Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ExpandDirectionProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.ExpandDirectionProperty Field
C1Accordion Class See Also
Identifies the ExpandDirection dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ExpandDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExpandDirectionProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ExpanderStyleProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.ExpanderStyleProperty Field
C1Accordion Class See Also
Identifies the ExpanderStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ExpanderStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExpanderStyleProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


FillProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.FillProperty Field
C1Accordion Class See Also
Identifies the Fill dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty FillProperty
Visual Basic (Declaration)
Public Shared ReadOnly FillProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.FocusStyleProperty Field
C1Accordion Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Accordion..::.IsMouseOverProperty Field
C1Accordion Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Accordion Methods

[image] [image]

.NET Framework Class Library
C1Accordion Methods
C1Accordion Class See Also

The C1Accordion type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Accordion..::.ChangeVisualStateCommon Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Accordion..::.ClearContainerForItemOverride Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Accordion..::.GetContainerForItemOverride Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Accordion..::.HitTest Method
C1Accordion Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Accordion Class
C1Accordion Members
C1.Silverlight.Extended Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1Accordion..::.IsItemItsOwnContainerOverride Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Accordion..::.OnApplyTemplate Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Accordion..::.PrepareContainerForItemOverride Method
C1Accordion Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Accordion Properties

[image] [image]

.NET Framework Class Library
C1Accordion Properties
C1Accordion Class See Also

The C1Accordion type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AllowCollapseAll | Gets or sets whether the accordion allows the user to collapse all items.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
ExpandDirection | Gets or sets the direction the contained C1Expanders expands.
ExpanderStyle | Gets or sets the Style that is applied to the expander element of each item.
Fill | Gets or sets whether the expanded item should fill the remaining space in the control.
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


AllowCollapseAll Property

[image]

.NET Framework Class Library
C1Accordion..::.AllowCollapseAll Property
C1Accordion Class See Also
Gets or sets whether the accordion allows the user to collapse all items.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool AllowCollapseAll { get; set; }
Visual Basic (Declaration)
Public Property AllowCollapseAll As Boolean

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1Accordion..::.DisabledStyle Property
C1Accordion Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ExpandDirection Property

[image]

.NET Framework Class Library
C1Accordion..::.ExpandDirection Property
C1Accordion Class See Also
Gets or sets the direction the contained C1Expanders expands.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic (Declaration)
Public Property ExpandDirection As ExpandDirection

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


ExpanderStyle Property

[image]

.NET Framework Class Library
C1Accordion..::.ExpanderStyle Property
C1Accordion Class See Also
Gets or sets the Style that is applied to the expander element of each item.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style ExpanderStyle { get; set; }
Visual Basic (Declaration)
Public Property ExpanderStyle As Style

Remarks

If the Item added is a C1Expander then the Style is applied only if the Item doesn't have a Style already applied.

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


Fill Property

[image]

.NET Framework Class Library
C1Accordion..::.Fill Property
C1Accordion Class See Also
Gets or sets whether the expanded item should fill the remaining space in the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool Fill { get; set; }
Visual Basic (Declaration)
Public Property Fill As Boolean

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1Accordion..::.FocusStyle Property
C1Accordion Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Accordion..::.IsMouseOver Property
C1Accordion Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Accordion Events

[image] [image]

.NET Framework Class Library
C1Accordion Events
C1Accordion Class See Also

The C1Accordion type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Accordion..::.IsMouseOverChanged Event
C1Accordion Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Accordion Class
C1.Silverlight.Extended Namespace


C1Book Class

[image]

.NET Framework Class Library
C1Book Class
Members See Also
ItemsControl that contains elements which are shown as pages of a book. The user can turn the pages like in a real book using the mouse to drag them.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Root", Type = typeof(Grid))]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
public class C1Book : ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Root", Type := GetType(Grid))> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
Public Class C1Book _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Extended..::.C1Book

See Also

C1Book Members
C1.Silverlight.Extended Namespace


C1Book Members

[image] [image]

.NET Framework Class Library
C1Book Members
C1Book Class Constructors Methods Fields Properties Events See Also

The C1Book type exposes the following members.

Constructors

Name | Description
C1Book | Initializes a new instance of a C1Book.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetApplyPageTemplate | Gets the value of the ApplyPageTemplate attached property for the specified element.
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | Invoked when the System.Windows.Controls.ItemsControl.Items property changes. (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetApplyPageTemplate | Sets the value of the ApplyPageTemplate attached property for the specified element.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
TurnPage | Turn page with animation.
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ApplyPageTemplateProperty | Identifies the ApplyPageTemplate attached property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
FoldSizeProperty | Identifies the FoldSize dependency property.
IsFirstPageOnTheRightProperty | Identifies the IsFirstPageOnTheRight dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
LeftPageTemplateProperty | Identifies the LeftPageTemplate dependency property.
RightPageTemplateProperty | Identifies the RightPageTemplate dependency property.
ShowFoldProperty | Identifies the ShowFold dependency property.
ShowInnerShadowsProperty | Identifies the ShowInnerShadows dependency property.
ShowOuterShadowsProperty | Identifies the ShowOuterShadows dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
CurrentPage | Gets or sets the current page that is displayed
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FoldSize | Gets or sets the size of the fold (in pixels)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFirstPageOnTheRight | Gets or sets whether the first page of the book is displayed in the right side of the book.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LeftPageTemplate | Gets or sets the template of the page shown in the left side of the book.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RightPageTemplate | Gets or sets the template of the page shown in the right side of the book.
ShowFold | Gets or sets whether the fold is displayed
ShowInnerShadows | Gets or sets whether the inner shadows are shown.
ShowOuterShadows | Gets or sets whether the outer shadows are shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
CurrentPageChanged | Fires when the CurrentPage property changes.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1Book Constructor

[image]

.NET Framework Class Library
C1Book Constructor
C1Book Class See Also
Initializes a new instance of a C1Book.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1Book()
Visual Basic (Declaration)
Public Sub New

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1Book Fields

[image] [image]

.NET Framework Class Library
C1Book Fields
C1Book Class See Also

The C1Book type exposes the following members.

Fields

Name | Description
ApplyPageTemplateProperty | Identifies the ApplyPageTemplate attached property.
CurrentPageProperty | Identifies the CurrentPage dependency property.
FoldSizeProperty | Identifies the FoldSize dependency property.
IsFirstPageOnTheRightProperty | Identifies the IsFirstPageOnTheRight dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
LeftPageTemplateProperty | Identifies the LeftPageTemplate dependency property.
RightPageTemplateProperty | Identifies the RightPageTemplate dependency property.
ShowFoldProperty | Identifies the ShowFold dependency property.
ShowInnerShadowsProperty | Identifies the ShowInnerShadows dependency property.
ShowOuterShadowsProperty | Identifies the ShowOuterShadows dependency property.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ApplyPageTemplateProperty Field

[image]

.NET Framework Class Library
C1Book..::.ApplyPageTemplateProperty Field
C1Book Class See Also
Identifies the ApplyPageTemplate attached property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ApplyPageTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ApplyPageTemplateProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


CurrentPageProperty Field

[image]

.NET Framework Class Library
C1Book..::.CurrentPageProperty Field
C1Book Class See Also
Identifies the CurrentPage dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty CurrentPageProperty
Visual Basic (Declaration)
Public Shared ReadOnly CurrentPageProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


FoldSizeProperty Field

[image]

.NET Framework Class Library
C1Book..::.FoldSizeProperty Field
C1Book Class See Also
Identifies the FoldSize dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty FoldSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly FoldSizeProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


IsFirstPageOnTheRightProperty Field

[image]

.NET Framework Class Library
C1Book..::.IsFirstPageOnTheRightProperty Field
C1Book Class See Also
Identifies the IsFirstPageOnTheRight dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsFirstPageOnTheRightProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFirstPageOnTheRightProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Book..::.IsMouseOverProperty Field
C1Book Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


LeftPageTemplateProperty Field

[image]

.NET Framework Class Library
C1Book..::.LeftPageTemplateProperty Field
C1Book Class See Also
Identifies the LeftPageTemplate dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty LeftPageTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly LeftPageTemplateProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


RightPageTemplateProperty Field

[image]

.NET Framework Class Library
C1Book..::.RightPageTemplateProperty Field
C1Book Class See Also
Identifies the RightPageTemplate dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RightPageTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly RightPageTemplateProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowFoldProperty Field

[image]

.NET Framework Class Library
C1Book..::.ShowFoldProperty Field
C1Book Class See Also
Identifies the ShowFold dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowFoldProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowFoldProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowInnerShadowsProperty Field

[image]

.NET Framework Class Library
C1Book..::.ShowInnerShadowsProperty Field
C1Book Class See Also
Identifies the ShowInnerShadows dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowInnerShadowsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowInnerShadowsProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowOuterShadowsProperty Field

[image]

.NET Framework Class Library
C1Book..::.ShowOuterShadowsProperty Field
C1Book Class See Also
Identifies the ShowOuterShadows dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowOuterShadowsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowOuterShadowsProperty As DependencyProperty

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1Book Methods

[image] [image]

.NET Framework Class Library
C1Book Methods
C1Book Class See Also

The C1Book type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetApplyPageTemplate | Gets the value of the ApplyPageTemplate attached property for the specified element.
GetContainerForItemOverride | Creates or identifies the element that is used to display the given item. (Overrides ItemsControl..::.GetContainerForItemOverride()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | Determines if the specified item is (or is eligible to be) its own container. (Overrides ItemsControl..::.IsItemItsOwnContainerOverride(Object).)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | Invoked when the System.Windows.Controls.ItemsControl.Items property changes. (Overrides ItemsControl..::.OnItemsChanged(NotifyCollectionChangedEventArgs).)
PrepareContainerForItemOverride | Prepares the specified element to display the specified item. (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetApplyPageTemplate | Sets the value of the ApplyPageTemplate attached property for the specified element.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
TurnPage | Turn page with animation.
UpdateLayout | (Inherited from UIElement.)

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Book..::.ChangeVisualStateCommon Method
C1Book Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


GetApplyPageTemplate Method

[image]

.NET Framework Class Library
C1Book..::.GetApplyPageTemplate Method
C1Book Class See Also
Gets the value of the ApplyPageTemplate attached property for the specified element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static ApplyPageTemplate GetApplyPageTemplate(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetApplyPageTemplate ( _
    element As DependencyObject _
) As ApplyPageTemplate

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the ApplyPageTemplate property.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


GetContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Book..::.GetContainerForItemOverride Method
C1Book Class See Also
Creates or identifies the element that is used to display the given item.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override DependencyObject GetContainerForItemOverride()
Visual Basic (Declaration)
Protected Overrides Function GetContainerForItemOverride As DependencyObject

Return Value

See Also

C1Book Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Book..::.HitTest Method
C1Book Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Book Class
C1Book Members
C1.Silverlight.Extended Namespace


IsItemItsOwnContainerOverride Method

[image]

.NET Framework Class Library
C1Book..::.IsItemItsOwnContainerOverride Method
C1Book Class See Also
Determines if the specified item is (or is eligible to be) its own container.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override bool IsItemItsOwnContainerOverride(
    Object item
)
Visual Basic (Declaration)
Protected Overrides Function IsItemItsOwnContainerOverride ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object
The item to check.

Return Value

true if the item is (or is eligible to be) its own container; otherwise,false.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Book..::.OnApplyTemplate Method
C1Book Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Book Class
C1.Silverlight.Extended Namespace


OnItemsChanged Method

[image]

.NET Framework Class Library
C1Book..::.OnItemsChanged Method
C1Book Class See Also
Invoked when the System.Windows.Controls.ItemsControl.Items property changes.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void OnItemsChanged(
    NotifyCollectionChangedEventArgs e
)
Visual Basic (Declaration)
Protected Overrides Sub OnItemsChanged ( _
    e As NotifyCollectionChangedEventArgs _
)

Parameters

e
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs
Information about the change.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Book..::.PrepareContainerForItemOverride Method
C1Book Class See Also
Prepares the specified element to display the specified item.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
Element used to display the specified item.
item
Type: System..::.Object
Specified item.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


SetApplyPageTemplate Method

[image]

.NET Framework Class Library
C1Book..::.SetApplyPageTemplate Method
C1Book Class See Also
Sets the value of the ApplyPageTemplate attached property for the specified element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static void SetApplyPageTemplate(
    DependencyObject element,
    ApplyPageTemplate value
)
Visual Basic (Declaration)
Public Shared Sub SetApplyPageTemplate ( _
    element As DependencyObject, _
    value As ApplyPageTemplate _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: C1.Silverlight.Extended..::.ApplyPageTemplate
The property value to set.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


TurnPage Method

[image]

.NET Framework Class Library
C1Book..::.TurnPage Method
C1Book Class See Also
Turn page with animation.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool TurnPage(
    bool forward
)
Visual Basic (Declaration)
Public Function TurnPage ( _
    forward As Boolean _
) As Boolean

Parameters

forward
Type: System..::.Boolean
True, if the movement is forward.

Return Value

True, if the movement started.

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1Book Properties

[image] [image]

.NET Framework Class Library
C1Book Properties
C1Book Class See Also

The C1Book type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
CurrentPage | Gets or sets the current page that is displayed
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FoldSize | Gets or sets the size of the fold (in pixels)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsFirstPageOnTheRight | Gets or sets whether the first page of the book is displayed in the right side of the book.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
LeftPageTemplate | Gets or sets the template of the page shown in the left side of the book.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RightPageTemplate | Gets or sets the template of the page shown in the right side of the book.
ShowFold | Gets or sets whether the fold is displayed
ShowInnerShadows | Gets or sets whether the inner shadows are shown.
ShowOuterShadows | Gets or sets whether the outer shadows are shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Book Class
C1.Silverlight.Extended Namespace


CurrentPage Property

[image]

.NET Framework Class Library
C1Book..::.CurrentPage Property
C1Book Class See Also
Gets or sets the current page that is displayed

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public int CurrentPage { get; set; }
Visual Basic (Declaration)
Public Property CurrentPage As Integer

See Also

C1Book Class
C1.Silverlight.Extended Namespace


FoldSize Property

[image]

.NET Framework Class Library
C1Book..::.FoldSize Property
C1Book Class See Also
Gets or sets the size of the fold (in pixels)

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double FoldSize { get; set; }
Visual Basic (Declaration)
Public Property FoldSize As Double

See Also

C1Book Class
C1.Silverlight.Extended Namespace


IsFirstPageOnTheRight Property

[image]

.NET Framework Class Library
C1Book..::.IsFirstPageOnTheRight Property
C1Book Class See Also
Gets or sets whether the first page of the book is displayed in the right side of the book.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsFirstPageOnTheRight { get; set; }
Visual Basic (Declaration)
Public Property IsFirstPageOnTheRight As Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Book..::.IsMouseOver Property
C1Book Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


LeftPageTemplate Property

[image]

.NET Framework Class Library
C1Book..::.LeftPageTemplate Property
C1Book Class See Also
Gets or sets the template of the page shown in the left side of the book.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ControlTemplate LeftPageTemplate { get; set; }
Visual Basic (Declaration)
Public Property LeftPageTemplate As ControlTemplate

See Also

C1Book Class
C1.Silverlight.Extended Namespace


RightPageTemplate Property

[image]

.NET Framework Class Library
C1Book..::.RightPageTemplate Property
C1Book Class See Also
Gets or sets the template of the page shown in the right side of the book.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ControlTemplate RightPageTemplate { get; set; }
Visual Basic (Declaration)
Public Property RightPageTemplate As ControlTemplate

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowFold Property

[image]

.NET Framework Class Library
C1Book..::.ShowFold Property
C1Book Class See Also
Gets or sets whether the fold is displayed

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool ShowFold { get; set; }
Visual Basic (Declaration)
Public Property ShowFold As Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowInnerShadows Property

[image]

.NET Framework Class Library
C1Book..::.ShowInnerShadows Property
C1Book Class See Also
Gets or sets whether the inner shadows are shown.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool ShowInnerShadows { get; set; }
Visual Basic (Declaration)
Public Property ShowInnerShadows As Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


ShowOuterShadows Property

[image]

.NET Framework Class Library
C1Book..::.ShowOuterShadows Property
C1Book Class See Also
Gets or sets whether the outer shadows are shown.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool ShowOuterShadows { get; set; }
Visual Basic (Declaration)
Public Property ShowOuterShadows As Boolean

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1Book Events

[image] [image]

.NET Framework Class Library
C1Book Events
C1Book Class See Also

The C1Book type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
CurrentPageChanged | Fires when the CurrentPage property changes.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Book Class
C1.Silverlight.Extended Namespace


CurrentPageChanged Event

[image]

.NET Framework Class Library
C1Book..::.CurrentPageChanged Event
C1Book Class See Also
Fires when the CurrentPage property changes.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<EventArgs> CurrentPageChanged
Visual Basic (Declaration)
Public Event CurrentPageChanged As EventHandler(Of EventArgs)

See Also

C1Book Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Book..::.IsMouseOverChanged Event
C1Book Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Book Class
C1.Silverlight.Extended Namespace


C1ColorButton Class

[image]

.NET Framework Class Library
C1ColorButton Class
Members See Also
Button that represents a color.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
public class C1ColorButton : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
Public Class C1ColorButton _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight.Extended..::.C1ColorButton

See Also

C1ColorButton Members
C1.Silverlight.Extended Namespace


C1ColorButton Members

[image] [image]

.NET Framework Class Library
C1ColorButton Members
C1ColorButton Class Constructors Methods Fields Properties Events See Also

The C1ColorButton type exposes the following members.

Constructors

Name | Description
C1ColorButton | Initializes a new instance of a C1ColorButton.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Gets/sets if the color has the mouse over.
IsSelected | Gets/sets if the color is selected.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Raises the click event.
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorButton Constructor

[image]

.NET Framework Class Library
C1ColorButton Constructor
C1ColorButton Class See Also
Initializes a new instance of a C1ColorButton.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ColorButton()
Visual Basic (Declaration)
Public Sub New

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorButton Fields

[image] [image]

.NET Framework Class Library
C1ColorButton Fields
C1ColorButton Class See Also

The C1ColorButton type exposes the following members.

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsSelectedProperty | Identifies the IsSelected dependency property.

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ColorButton..::.IsMouseOverProperty Field
C1ColorButton Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
C1ColorButton..::.IsSelectedProperty Field
C1ColorButton Class See Also
Identifies the IsSelected dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorButton Methods

[image] [image]

.NET Framework Class Library
C1ColorButton Methods
C1ColorButton Class See Also

The C1ColorButton type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ColorButton..::.ChangeVisualStateCommon Method
C1ColorButton Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ColorButton..::.HitTest Method
C1ColorButton Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ColorButton Class
C1ColorButton Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ColorButton..::.OnApplyTemplate Method
C1ColorButton Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorButton Properties

[image] [image]

.NET Framework Class Library
C1ColorButton Properties
C1ColorButton Class See Also

The C1ColorButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Gets/sets if the color has the mouse over.
IsSelected | Gets/sets if the color is selected.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ColorButton..::.IsMouseOver Property
C1ColorButton Class See Also
Gets/sets if the color has the mouse over.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


IsSelected Property

[image]

.NET Framework Class Library
C1ColorButton..::.IsSelected Property
C1ColorButton Class See Also
Gets/sets if the color is selected.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorButton Events

[image] [image]

.NET Framework Class Library
C1ColorButton Events
C1ColorButton Class See Also

The C1ColorButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Click | Raises the click event.
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


Click Event

[image]

.NET Framework Class Library
C1ColorButton..::.Click Event
C1ColorButton Class See Also
Raises the click event.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event RoutedEventHandler Click
Visual Basic (Declaration)
Public Event Click As RoutedEventHandler

See Also

C1ColorButton Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Class

[image]

.NET Framework Class Library
C1ColorHslPad Class
Members See Also
Represents a HSL color selection pad.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplatePartAttribute(Name = "HueSlider", Type = typeof(Slider))]
[TemplatePartAttribute(Name = "Pad", Type = typeof(ContentControl))]
[TemplatePartAttribute(Name = "Indicator", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1ColorHslPad : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "HueSlider", Type := GetType(Slider))> _
<TemplatePartAttribute(Name := "Pad", Type := GetType(ContentControl))> _
<TemplatePartAttribute(Name := "Indicator", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1ColorHslPad _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Extended..::.C1ColorHslPad

See Also

C1ColorHslPad Members
C1.Silverlight.Extended Namespace


C1ColorHslPad Members

[image] [image]

.NET Framework Class Library
C1ColorHslPad Members
C1ColorHslPad Class Constructors Methods Fields Properties Events See Also

The C1ColorHslPad type exposes the following members.

Constructors

Name | Description
C1ColorHslPad | Initializes a new instance of a C1ColorHslPad.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Color | Gets or sets the current color in the pad.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ColorChanged | Raised when the color is changed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Constructor

[image]

.NET Framework Class Library
C1ColorHslPad Constructor
C1ColorHslPad Class See Also
Initializes a new instance of a C1ColorHslPad.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ColorHslPad()
Visual Basic (Declaration)
Public Sub New

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Fields

[image] [image]

.NET Framework Class Library
C1ColorHslPad Fields
C1ColorHslPad Class See Also

The C1ColorHslPad type exposes the following members.

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ColorHslPad..::.IsMouseOverProperty Field
C1ColorHslPad Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Methods

[image] [image]

.NET Framework Class Library
C1ColorHslPad Methods
C1ColorHslPad Class See Also

The C1ColorHslPad type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ColorHslPad..::.ChangeVisualStateCommon Method
C1ColorHslPad Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ColorHslPad..::.HitTest Method
C1ColorHslPad Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ColorHslPad Class
C1ColorHslPad Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ColorHslPad..::.OnApplyTemplate Method
C1ColorHslPad Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Properties

[image] [image]

.NET Framework Class Library
C1ColorHslPad Properties
C1ColorHslPad Class See Also

The C1ColorHslPad type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Color | Gets or sets the current color in the pad.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


Color Property

[image]

.NET Framework Class Library
C1ColorHslPad..::.Color Property
C1ColorHslPad Class See Also
Gets or sets the current color in the pad.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Color Color { get; set; }
Visual Basic (Declaration)
Public Property Color As Color

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ColorHslPad..::.IsMouseOver Property
C1ColorHslPad Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorHslPad Events

[image] [image]

.NET Framework Class Library
C1ColorHslPad Events
C1ColorHslPad Class See Also

The C1ColorHslPad type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ColorChanged | Raised when the color is changed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


ColorChanged Event

[image]

.NET Framework Class Library
C1ColorHslPad..::.ColorChanged Event
C1ColorHslPad Class See Also
Raised when the color is changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler ColorChanged
Visual Basic (Declaration)
Public Event ColorChanged As EventHandler

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ColorHslPad..::.IsMouseOverChanged Event
C1ColorHslPad Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ColorHslPad Class
C1.Silverlight.Extended Namespace


C1ColorPicker Class

[image]

.NET Framework Class Library
C1ColorPicker Class
Members See Also
Allow to pick a color from a color palette or build an advanced color using RGB or HSL. Keeps a list of the recent used colors.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplatePartAttribute(Name = "InputLuminance", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "OkButton", Type = typeof(Button))]
[TemplatePartAttribute(Name = "InputGreen", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "DropDown", Type = typeof(C1DropDown))]
[TemplatePartAttribute(Name = "StandardColors", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "RecentColors", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "ThemeColorsHeader", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "ThemeColorsValues", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "ButtonBasic", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "ButtonAdvanced", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "Basic", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Advanced", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Preview", Type = typeof(Rectangle))]
[TemplatePartAttribute(Name = "InputRed", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "RecentColorsHeader", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "InputBlue", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "InputHue", Type = typeof(C1NumericBox))]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplatePartAttribute(Name = "InputAlpha", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "InputWeb", Type = typeof(TextBox))]
[TemplatePartAttribute(Name = "HslPad", Type = typeof(C1ColorHslPad))]
[TemplatePartAttribute(Name = "InputSaturation", Type = typeof(C1NumericBox))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
public class C1ColorPicker : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "InputLuminance", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "OkButton", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "InputGreen", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "DropDown", Type := GetType(C1DropDown))> _
<TemplatePartAttribute(Name := "StandardColors", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "RecentColors", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "ThemeColorsHeader", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "ThemeColorsValues", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "ButtonBasic", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "ButtonAdvanced", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "Basic", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Advanced", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Preview", Type := GetType(Rectangle))> _
<TemplatePartAttribute(Name := "InputRed", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "RecentColorsHeader", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "InputBlue", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "InputHue", Type := GetType(C1NumericBox))> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplatePartAttribute(Name := "InputAlpha", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "InputWeb", Type := GetType(TextBox))> _
<TemplatePartAttribute(Name := "HslPad", Type := GetType(C1ColorHslPad))> _
<TemplatePartAttribute(Name := "InputSaturation", Type := GetType(C1NumericBox))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
Public Class C1ColorPicker _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Extended..::.C1ColorPicker

See Also

C1ColorPicker Members
C1.Silverlight.Extended Namespace


C1ColorPicker Members

[image] [image]

.NET Framework Class Library
C1ColorPicker Members
C1ColorPicker Class Constructors Methods Fields Properties Events See Also

The C1ColorPicker type exposes the following members.

Constructors

Name | Description
C1ColorPicker | Initializes a new instance of a C1ColorPicker.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateColorButton | Overloaded.
CreateColorContainer | Override to change the default ItemsControl used.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ColorContainerStyleProperty | Identifies the ColorContainerStyle dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeaderProperty | Identifies the DropDownHeader dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ModeProperty | Identifies the Mode dependency property.
PaletteProperty | Identifies the Palette dependency property.
SelectedBrushProperty | Identifies the SelectedBrush dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.
ShowRecentColorsProperty | Identifies the ShowRecentColors dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
ColorContainerStyle | Sets/gets the style of the ItemsControl used to show a section of colors (that is recent colors).
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DropDownDirection | Specifies the expand direction of the control drop down.
DropDownHeader | UIElement used as header of the C1DropDown,
DropDownHeight | Gets or sets the height of the dropdown (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the dropdown (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the control dropdown.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Mode | Indicates the mode of the color picker.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets/sets the palette to be used.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBrush | Gets the currently selected color as a Brush.
SelectedColor | Gets/sets the currently selected color.
ShowRecentColors | Indicates if the recent colors should be shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedColorChanged | Event raised when the SelectedColor property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPicker Constructor

[image]

.NET Framework Class Library
C1ColorPicker Constructor
C1ColorPicker Class See Also
Initializes a new instance of a C1ColorPicker.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ColorPicker()
Visual Basic (Declaration)
Public Sub New

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPicker Fields

[image] [image]

.NET Framework Class Library
C1ColorPicker Fields
C1ColorPicker Class See Also

The C1ColorPicker type exposes the following members.

Fields

Name | Description
ColorContainerStyleProperty | Identifies the ColorContainerStyle dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
DropDownDirectionProperty | Identifies the DropDownDirection dependency property.
DropDownHeaderProperty | Identifies the DropDownHeader dependency property.
DropDownHeightProperty | Identifies the DropDownHeight dependency property.
DropDownWidthProperty | Identifies the DropDownWidth dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
IsDropDownOpenProperty | Identifies the IsDropDownOpen dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ModeProperty | Identifies the Mode dependency property.
PaletteProperty | Identifies the Palette dependency property.
SelectedBrushProperty | Identifies the SelectedBrush dependency property.
SelectedColorProperty | Identifies the SelectedColor dependency property.
ShowRecentColorsProperty | Identifies the ShowRecentColors dependency property.

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ColorContainerStyleProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.ColorContainerStyleProperty Field
C1ColorPicker Class See Also
Identifies the ColorContainerStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ColorContainerStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColorContainerStyleProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.DisabledStyleProperty Field
C1ColorPicker Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownDirectionProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownDirectionProperty Field
C1ColorPicker Class See Also
Identifies the DropDownDirection dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DropDownDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownDirectionProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownHeaderProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownHeaderProperty Field
C1ColorPicker Class See Also
Identifies the DropDownHeader dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DropDownHeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownHeaderProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownHeightProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownHeightProperty Field
C1ColorPicker Class See Also
Identifies the DropDownHeight dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DropDownHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownHeightProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownWidthProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownWidthProperty Field
C1ColorPicker Class See Also
Identifies the DropDownWidth dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty DropDownWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownWidthProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.FocusStyleProperty Field
C1ColorPicker Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsDropDownOpenProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.IsDropDownOpenProperty Field
C1ColorPicker Class See Also
Identifies the IsDropDownOpen dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsDropDownOpenProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDropDownOpenProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.IsFocusedProperty Field
C1ColorPicker Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.IsMouseOverProperty Field
C1ColorPicker Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ModeProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.ModeProperty Field
C1ColorPicker Class See Also
Identifies the Mode dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ModeProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


PaletteProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.PaletteProperty Field
C1ColorPicker Class See Also
Identifies the Palette dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty PaletteProperty
Visual Basic (Declaration)
Public Shared ReadOnly PaletteProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


SelectedBrushProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.SelectedBrushProperty Field
C1ColorPicker Class See Also
Identifies the SelectedBrush dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SelectedBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedBrushProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


SelectedColorProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.SelectedColorProperty Field
C1ColorPicker Class See Also
Identifies the SelectedColor dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SelectedColorProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedColorProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ShowRecentColorsProperty Field

[image]

.NET Framework Class Library
C1ColorPicker..::.ShowRecentColorsProperty Field
C1ColorPicker Class See Also
Identifies the ShowRecentColors dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowRecentColorsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowRecentColorsProperty As DependencyProperty

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPicker Methods

[image] [image]

.NET Framework Class Library
C1ColorPicker Methods
C1ColorPicker Class See Also

The C1ColorPicker type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CreateColorButton | Overloaded.
CreateColorContainer | Override to change the default ItemsControl used.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ColorPicker..::.ChangeVisualStateCommon Method
C1ColorPicker Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1ColorPicker..::.ChangeVisualStateFocus Method
C1ColorPicker Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


CreateColorButton Method

[image] [image]

.NET Framework Class Library
C1ColorPicker..::.CreateColorButton Method
C1ColorPicker Class See Also

Overload List

Name | Description
CreateColorButton(ColorPaletteEntry) | Override to change the default C1ColorButton used for a ColorPaletteEntry.
CreateColorButton(Color) | Override to change the default C1ColorButton used for a Color.

See Also

C1ColorPicker Class
C1ColorPicker Members
C1.Silverlight.Extended Namespace


CreateColorButton Method (ColorPaletteEntry)

[image]

.NET Framework Class Library
C1ColorPicker..::.CreateColorButton Method (ColorPaletteEntry)
C1ColorPicker Class See Also
Override to change the default C1ColorButton used for a ColorPaletteEntry.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected virtual C1ColorButton CreateColorButton(
    ColorPaletteEntry colorEntry
)
Visual Basic (Declaration)
Protected Overridable Function CreateColorButton ( _
    colorEntry As ColorPaletteEntry _
) As C1ColorButton

Parameters

colorEntry
Type: C1.Silverlight.Extended..::.ColorPaletteEntry
ColorPaletteEntry that should be represented.

Return Value

A C1ColorButton for a specific ColorPaletteEntry.

See Also

C1ColorPicker Class
CreateColorButton Overload
C1.Silverlight.Extended Namespace


CreateColorButton Method (Color)

[image]

.NET Framework Class Library
C1ColorPicker..::.CreateColorButton Method (Color)
C1ColorPicker Class See Also
Override to change the default C1ColorButton used for a Color.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected virtual C1ColorButton CreateColorButton(
    Color color
)
Visual Basic (Declaration)
Protected Overridable Function CreateColorButton ( _
    color As Color _
) As C1ColorButton

Parameters

color
Type: System.Windows.Media..::.Color
Color that should be represented.

Return Value

A C1ColorButton for a specific Color.

See Also

C1ColorPicker Class
CreateColorButton Overload
C1.Silverlight.Extended Namespace


CreateColorContainer Method

[image]

.NET Framework Class Library
C1ColorPicker..::.CreateColorContainer Method
C1ColorPicker Class See Also
Override to change the default ItemsControl used.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected virtual ItemsControl CreateColorContainer()
Visual Basic (Declaration)
Protected Overridable Function CreateColorContainer As ItemsControl

Return Value

An ItemsControl used to put several C1ColorButton.

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ColorPicker..::.HitTest Method
C1ColorPicker Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ColorPicker Class
C1ColorPicker Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ColorPicker..::.OnApplyTemplate Method
C1ColorPicker Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPicker Properties

[image] [image]

.NET Framework Class Library
C1ColorPicker Properties
C1ColorPicker Class See Also

The C1ColorPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
ColorContainerStyle | Sets/gets the style of the ItemsControl used to show a section of colors (that is recent colors).
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
DropDownDirection | Specifies the expand direction of the control drop down.
DropDownHeader | UIElement used as header of the C1DropDown,
DropDownHeight | Gets or sets the height of the dropdown (set to zero to size automatically).
DropDownWidth | Gets or sets the width of the dropdown (set to zero to size automatically).
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDropDownOpen | Open or close the control dropdown.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Mode | Indicates the mode of the color picker.
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Palette | Gets/sets the palette to be used.
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBrush | Gets the currently selected color as a Brush.
SelectedColor | Gets/sets the currently selected color.
ShowRecentColors | Indicates if the recent colors should be shown.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ColorContainerStyle Property

[image]

.NET Framework Class Library
C1ColorPicker..::.ColorContainerStyle Property
C1ColorPicker Class See Also
Sets/gets the style of the ItemsControl used to show a section of colors (that is recent colors).

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style ColorContainerStyle { get; set; }
Visual Basic (Declaration)
Public Property ColorContainerStyle As Style

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1ColorPicker..::.DisabledStyle Property
C1ColorPicker Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownDirection Property

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownDirection Property
C1ColorPicker Class See Also
Specifies the expand direction of the control drop down.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public DropDownDirection DropDownDirection { get; set; }
Visual Basic (Declaration)
Public Property DropDownDirection As DropDownDirection

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownHeader Property

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownHeader Property
C1ColorPicker Class See Also
UIElement used as header of the C1DropDown,

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public UIElement DropDownHeader { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeader As UIElement

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownHeight Property

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownHeight Property
C1ColorPicker Class See Also
Gets or sets the height of the dropdown (set to zero to size automatically).

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


DropDownWidth Property

[image]

.NET Framework Class Library
C1ColorPicker..::.DropDownWidth Property
C1ColorPicker Class See Also
Gets or sets the width of the dropdown (set to zero to size automatically).

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1ColorPicker..::.FocusStyle Property
C1ColorPicker Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsDropDownOpen Property

[image]

.NET Framework Class Library
C1ColorPicker..::.IsDropDownOpen Property
C1ColorPicker Class See Also
Open or close the control dropdown.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsDropDownOpen { get; set; }
Visual Basic (Declaration)
Public Property IsDropDownOpen As Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1ColorPicker..::.IsFocused Property
C1ColorPicker Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ColorPicker..::.IsMouseOver Property
C1ColorPicker Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


Mode Property

[image]

.NET Framework Class Library
C1ColorPicker..::.Mode Property
C1ColorPicker Class See Also
Indicates the mode of the color picker.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ColorPickerMode Mode { get; set; }
Visual Basic (Declaration)
Public Property Mode As C1ColorPickerMode

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


Palette Property

[image]

.NET Framework Class Library
C1ColorPicker..::.Palette Property
C1ColorPicker Class See Also
Gets/sets the palette to be used.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ColorPalette Palette { get; set; }
Visual Basic (Declaration)
Public Property Palette As ColorPalette

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


SelectedBrush Property

[image]

.NET Framework Class Library
C1ColorPicker..::.SelectedBrush Property
C1ColorPicker Class See Also
Gets the currently selected color as a Brush.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Brush SelectedBrush { get; private set; }
Visual Basic (Declaration)
Public Property SelectedBrush As Brush

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


SelectedColor Property

[image]

.NET Framework Class Library
C1ColorPicker..::.SelectedColor Property
C1ColorPicker Class See Also
Gets/sets the currently selected color.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Color SelectedColor { get; set; }
Visual Basic (Declaration)
Public Property SelectedColor As Color

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


ShowRecentColors Property

[image]

.NET Framework Class Library
C1ColorPicker..::.ShowRecentColors Property
C1ColorPicker Class See Also
Indicates if the recent colors should be shown.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool ShowRecentColors { get; set; }
Visual Basic (Declaration)
Public Property ShowRecentColors As Boolean

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPicker Events

[image] [image]

.NET Framework Class Library
C1ColorPicker Events
C1ColorPicker Class See Also

The C1ColorPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsDropDownOpenChanged | Event raised when the IsDropDownOpen property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SelectedColorChanged | Event raised when the SelectedColor property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsDropDownOpenChanged Event

[image]

.NET Framework Class Library
C1ColorPicker..::.IsDropDownOpenChanged Event
C1ColorPicker Class See Also
Event raised when the IsDropDownOpen property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsDropDownOpenChanged
Visual Basic (Declaration)
Public Event IsDropDownOpenChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ColorPicker..::.IsMouseOverChanged Event
C1ColorPicker Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


SelectedColorChanged Event

[image]

.NET Framework Class Library
C1ColorPicker..::.SelectedColorChanged Event
C1ColorPicker Class See Also
Event raised when the SelectedColor property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Color>> SelectedColorChanged
Visual Basic (Declaration)
Public Event SelectedColorChanged As EventHandler(Of PropertyChangedEventArgs(Of Color))

See Also

C1ColorPicker Class
C1.Silverlight.Extended Namespace


C1ColorPickerMode Enumeration

[image]

.NET Framework Class Library
C1ColorPickerMode Enumeration
See Also
Pick the mode for the C1ColorPicker.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public enum C1ColorPickerMode
Visual Basic (Declaration)
Public Enumeration C1ColorPickerMode

Members

Member name | Description
Basic | Shows only the basic tab.
Advanced | Shows only the advanced tab.
Both | Shows both the basic and the advanced tabs.

See Also

C1.Silverlight.Extended Namespace


C1Cube Class

[image]

.NET Framework Class Library
C1Cube Class
Members See Also
ItemsControl that provides a 3D rotating cube with different content on each face.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Drag", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
public class C1Cube : ItemsControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Drag", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
Public Class C1Cube _
    Inherits ItemsControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Extended..::.C1Cube

See Also

C1Cube Members
C1.Silverlight.Extended Namespace


C1Cube Members

[image] [image]

.NET Framework Class Library
C1Cube Members
C1Cube Class Constructors Methods Fields Properties Events See Also

The C1Cube type exposes the following members.

Constructors

Name | Description
C1Cube | Initializes a new instance of a C1Cube.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetFace | Gets the value of the Face attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Rotate | Rotates the cube.
SetBinding | (Inherited from FrameworkElement.)
SetFace | Sets the value of the Face attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ShowFace | Smoothly rotates the cube so that a face faces forward.
ShowItem | Smoothly rotates the cube so that the face an item is in faces forward.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
FaceProperty | Identifies the Face attached property.
IsDraggableProperty | Identifies the IsDraggable dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
RotationXProperty | Identifies the RotationX dependency property.
RotationYProperty | Identifies the RotationY dependency property.
RotationZProperty | Identifies the RotationZ dependency property.
ShowFaceDelayProperty | Identifies the ShowFaceDelay dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDraggable | Gets or sets a value indicating whether the cube can be rotated by dragging with the mouse.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RotationX | Gets or sets the rotation of the cube in the x axis.
RotationY | Gets or sets the rotation of the cube in the y axis.
RotationZ | Gets or sets the rotation of the cube in the z axis.
ShowFaceDelay | Gets or sets the time in seconds that it takes to go to a new face when CurrentFace is set.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RotationXChanged | Event raised when the RotationX property has changed.
RotationYChanged | Event raised when the RotationY property has changed.
RotationZChanged | Event raised when the RotationZ property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Cube Constructor

[image]

.NET Framework Class Library
C1Cube Constructor
C1Cube Class See Also
Initializes a new instance of a C1Cube.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1Cube()
Visual Basic (Declaration)
Public Sub New

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Cube Fields

[image] [image]

.NET Framework Class Library
C1Cube Fields
C1Cube Class See Also

The C1Cube type exposes the following members.

Fields

Name | Description
FaceProperty | Identifies the Face attached property.
IsDraggableProperty | Identifies the IsDraggable dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
RotationXProperty | Identifies the RotationX dependency property.
RotationYProperty | Identifies the RotationY dependency property.
RotationZProperty | Identifies the RotationZ dependency property.
ShowFaceDelayProperty | Identifies the ShowFaceDelay dependency property.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


FaceProperty Field

[image]

.NET Framework Class Library
C1Cube..::.FaceProperty Field
C1Cube Class See Also
Identifies the Face attached property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty FaceProperty
Visual Basic (Declaration)
Public Shared ReadOnly FaceProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


IsDraggableProperty Field

[image]

.NET Framework Class Library
C1Cube..::.IsDraggableProperty Field
C1Cube Class See Also
Identifies the IsDraggable dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsDraggableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDraggableProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Cube..::.IsMouseOverProperty Field
C1Cube Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationXProperty Field

[image]

.NET Framework Class Library
C1Cube..::.RotationXProperty Field
C1Cube Class See Also
Identifies the RotationX dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationXProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationXProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationYProperty Field

[image]

.NET Framework Class Library
C1Cube..::.RotationYProperty Field
C1Cube Class See Also
Identifies the RotationY dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationYProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationYProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationZProperty Field

[image]

.NET Framework Class Library
C1Cube..::.RotationZProperty Field
C1Cube Class See Also
Identifies the RotationZ dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationZProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationZProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ShowFaceDelayProperty Field

[image]

.NET Framework Class Library
C1Cube..::.ShowFaceDelayProperty Field
C1Cube Class See Also
Identifies the ShowFaceDelay dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowFaceDelayProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowFaceDelayProperty As DependencyProperty

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Cube Methods

[image] [image]

.NET Framework Class Library
C1Cube Methods
C1Cube Class See Also

The C1Cube type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Overrides ItemsControl..::.ClearContainerForItemOverride(DependencyObject, Object).)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetFace | Gets the value of the Face attached property for the specified element.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Rotate | Rotates the cube.
SetBinding | (Inherited from FrameworkElement.)
SetFace | Sets the value of the Face attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ShowFace | Smoothly rotates the cube so that a face faces forward.
ShowItem | Smoothly rotates the cube so that the face an item is in faces forward.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Cube..::.ChangeVisualStateCommon Method
C1Cube Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ClearContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Cube..::.ClearContainerForItemOverride Method
C1Cube Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void ClearContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub ClearContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


GetFace Method

[image]

.NET Framework Class Library
C1Cube..::.GetFace Method
C1Cube Class See Also
Gets the value of the Face attached property for the specified element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static CubeFace GetFace(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetFace ( _
    element As DependencyObject _
) As CubeFace

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the Face property.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Cube..::.HitTest Method
C1Cube Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Cube Class
C1Cube Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Cube..::.OnApplyTemplate Method
C1Cube Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1Cube..::.PrepareContainerForItemOverride Method
C1Cube Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


Rotate Method

[image]

.NET Framework Class Library
C1Cube..::.Rotate Method
C1Cube Class See Also
Rotates the cube.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Rotate(
    double rotationX,
    double rotationY,
    double rotationZ
)
Visual Basic (Declaration)
Public Sub Rotate ( _
    rotationX As Double, _
    rotationY As Double, _
    rotationZ As Double _
)

Parameters

rotationX
Type: System..::.Double
Rotation around the X axis.
rotationY
Type: System..::.Double
Rotation around the Y axis.
rotationZ
Type: System..::.Double
Rotation around the Z axis.

Remarks

The rotation is done around the X axis, then around the Y axis and finally around the Z axis.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


SetFace Method

[image]

.NET Framework Class Library
C1Cube..::.SetFace Method
C1Cube Class See Also
Sets the value of the Face attached property for the specified element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static void SetFace(
    DependencyObject element,
    CubeFace value
)
Visual Basic (Declaration)
Public Shared Sub SetFace ( _
    element As DependencyObject, _
    value As CubeFace _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: C1.Silverlight.Extended..::.CubeFace
The property value to set.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ShowFace Method

[image]

.NET Framework Class Library
C1Cube..::.ShowFace Method
C1Cube Class See Also
Smoothly rotates the cube so that a face faces forward.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void ShowFace(
    CubeFace face
)
Visual Basic (Declaration)
Public Sub ShowFace ( _
    face As CubeFace _
)

Parameters

face
Type: C1.Silverlight.Extended..::.CubeFace
The face that will be facing forward.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ShowItem Method

[image]

.NET Framework Class Library
C1Cube..::.ShowItem Method
C1Cube Class See Also
Smoothly rotates the cube so that the face an item is in faces forward.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void ShowItem(
    Object item
)
Visual Basic (Declaration)
Public Sub ShowItem ( _
    item As Object _
)

Parameters

item
Type: System..::.Object
The item whose face will be facing forward.

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Cube Properties

[image] [image]

.NET Framework Class Library
C1Cube Properties
C1Cube Class See Also

The C1Cube type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsDraggable | Gets or sets a value indicating whether the cube can be rotated by dragging with the mouse.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RotationX | Gets or sets the rotation of the cube in the x axis.
RotationY | Gets or sets the rotation of the cube in the y axis.
RotationZ | Gets or sets the rotation of the cube in the z axis.
ShowFaceDelay | Gets or sets the time in seconds that it takes to go to a new face when CurrentFace is set.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


IsDraggable Property

[image]

.NET Framework Class Library
C1Cube..::.IsDraggable Property
C1Cube Class See Also
Gets or sets a value indicating whether the cube can be rotated by dragging with the mouse.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsDraggable { get; set; }
Visual Basic (Declaration)
Public Property IsDraggable As Boolean

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Cube..::.IsMouseOver Property
C1Cube Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationX Property

[image]

.NET Framework Class Library
C1Cube..::.RotationX Property
C1Cube Class See Also
Gets or sets the rotation of the cube in the x axis.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationX { get; set; }
Visual Basic (Declaration)
Public Property RotationX As Double

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationY Property

[image]

.NET Framework Class Library
C1Cube..::.RotationY Property
C1Cube Class See Also
Gets or sets the rotation of the cube in the y axis.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationY { get; set; }
Visual Basic (Declaration)
Public Property RotationY As Double

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationZ Property

[image]

.NET Framework Class Library
C1Cube..::.RotationZ Property
C1Cube Class See Also
Gets or sets the rotation of the cube in the z axis.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationZ { get; set; }
Visual Basic (Declaration)
Public Property RotationZ As Double

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


ShowFaceDelay Property

[image]

.NET Framework Class Library
C1Cube..::.ShowFaceDelay Property
C1Cube Class See Also
Gets or sets the time in seconds that it takes to go to a new face when CurrentFace is set.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double ShowFaceDelay { get; set; }
Visual Basic (Declaration)
Public Property ShowFaceDelay As Double

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Cube Events

[image] [image]

.NET Framework Class Library
C1Cube Events
C1Cube Class See Also

The C1Cube type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RotationXChanged | Event raised when the RotationX property has changed.
RotationYChanged | Event raised when the RotationY property has changed.
RotationZChanged | Event raised when the RotationZ property has changed.
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Cube..::.IsMouseOverChanged Event
C1Cube Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationXChanged Event

[image]

.NET Framework Class Library
C1Cube..::.RotationXChanged Event
C1Cube Class See Also
Event raised when the RotationX property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> RotationXChanged
Visual Basic (Declaration)
Public Event RotationXChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationYChanged Event

[image]

.NET Framework Class Library
C1Cube..::.RotationYChanged Event
C1Cube Class See Also
Event raised when the RotationY property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> RotationYChanged
Visual Basic (Declaration)
Public Event RotationYChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


RotationZChanged Event

[image]

.NET Framework Class Library
C1Cube..::.RotationZChanged Event
C1Cube Class See Also
Event raised when the RotationZ property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> RotationZChanged
Visual Basic (Declaration)
Public Event RotationZChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1Cube Class
C1.Silverlight.Extended Namespace


C1Expander Class

[image]

.NET Framework Class Library
C1Expander Class
Members See Also
C1Expander is a C1HeaderedContentControl whose content's visibility can be toggled clicking on its header.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Collapsed", GroupName = "ExpansionStates")]
[TemplateVisualStateAttribute(Name = "Expanded", GroupName = "ExpansionStates")]
[TemplatePartAttribute(Name = "ExpandButton", Type = typeof(ToggleButton))]
[TemplateVisualStateAttribute(Name = "Up", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Down", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Left", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Right", GroupName = "DirectionStates")]
public class C1Expander : C1HeaderedContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Collapsed", GroupName := "ExpansionStates")> _
<TemplateVisualStateAttribute(Name := "Expanded", GroupName := "ExpansionStates")> _
<TemplatePartAttribute(Name := "ExpandButton", Type := GetType(ToggleButton))> _
<TemplateVisualStateAttribute(Name := "Up", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Down", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Left", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Right", GroupName := "DirectionStates")> _
Public Class C1Expander _
    Inherits C1HeaderedContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight..::.C1HeaderedContentControl
C1.Silverlight.Extended..::.C1Expander

See Also

C1Expander Members
C1.Silverlight.Extended Namespace


C1Expander Members

[image] [image]

.NET Framework Class Library
C1Expander Members
C1Expander Class Constructors Methods Fields Properties Events See Also

The C1Expander type exposes the following members.

Constructors

Name | Description
C1Expander | Initializes a new instance of a C1Expander.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1HeaderedContentControl.)
ChangeVisualStateDirection |
ChangeVisualStateExpansion |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.
IsExpandableProperty | Identifies the IsExpandable dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ExpandDirection | Gets or sets the direction the expander expands.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsExpandable | Gets or sets whether the expander can be expanded and collapsed.
IsExpanded | Gets or sets whether the expander content is visible.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1HeaderedContentControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsExpandedChanged | Event raised when the IsExpanded property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1HeaderedContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1Expander Constructor

[image]

.NET Framework Class Library
C1Expander Constructor
C1Expander Class See Also
Initializes a new instance of a C1Expander.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1Expander()
Visual Basic (Declaration)
Public Sub New

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1Expander Fields

[image] [image]

.NET Framework Class Library
C1Expander Fields
C1Expander Class See Also

The C1Expander type exposes the following members.

Fields

Name | Description
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.
IsExpandableProperty | Identifies the IsExpandable dependency property.
IsExpandedProperty | Identifies the IsExpanded dependency property.

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


ExpandDirectionProperty Field

[image]

.NET Framework Class Library
C1Expander..::.ExpandDirectionProperty Field
C1Expander Class See Also
Identifies the ExpandDirection dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ExpandDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExpandDirectionProperty As DependencyProperty

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


IsExpandableProperty Field

[image]

.NET Framework Class Library
C1Expander..::.IsExpandableProperty Field
C1Expander Class See Also
Identifies the IsExpandable dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandableProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandableProperty As DependencyProperty

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


IsExpandedProperty Field

[image]

.NET Framework Class Library
C1Expander..::.IsExpandedProperty Field
C1Expander Class See Also
Identifies the IsExpanded dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsExpandedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsExpandedProperty As DependencyProperty

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1Expander Methods

[image] [image]

.NET Framework Class Library
C1Expander Methods
C1Expander Class See Also

The C1Expander type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1HeaderedContentControl.)
ChangeVisualStateDirection |
ChangeVisualStateExpansion |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides C1HeaderedContentControl..::.OnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


ChangeVisualStateDirection Method

[image]

.NET Framework Class Library
C1Expander..::.ChangeVisualStateDirection Method
C1Expander Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateDirection(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateDirection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


ChangeVisualStateExpansion Method

[image]

.NET Framework Class Library
C1Expander..::.ChangeVisualStateExpansion Method
C1Expander Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateExpansion(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateExpansion ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Expander..::.HitTest Method
C1Expander Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Expander Class
C1Expander Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Expander..::.OnApplyTemplate Method
C1Expander Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1Expander Properties

[image] [image]

.NET Framework Class Library
C1Expander Properties
C1Expander Class See Also

The C1Expander type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ExpandDirection | Gets or sets the direction the expander expands.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the header of this control. (Inherited from C1HeaderedContentControl.)
HeaderBackground | Gets or sets the background brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontFamily | Gets or sets the font family of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontSize | Gets or sets the font size of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStretch | Gets or sets the font stretch of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontStyle | Gets or sets the font style of the header. (Inherited from C1HeaderedContentControl.)
HeaderFontWeight | Gets or sets the font weight of the header. (Inherited from C1HeaderedContentControl.)
HeaderForeground | Gets or sets the foreground brush of the header. (Inherited from C1HeaderedContentControl.)
HeaderHorizontalContentAlignment | Gets or sets the HorizontalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderPadding | Gets or sets the padding of the header. (Inherited from C1HeaderedContentControl.)
HeaderTemplate | Gets or sets the data template used to display the header. (Inherited from C1HeaderedContentControl.)
HeaderTextAlignment | Gets or sets the text alignment of the header. (Inherited from C1HeaderedContentControl.)
HeaderTextDecorations | Gets or sets a TextDecorationCollection that contains the effects to apply to the header text. (Inherited from C1HeaderedContentControl.)
HeaderTextWrapping | Gets or sets a value that indicates how any header text should be wrapped. (Inherited from C1HeaderedContentControl.)
HeaderVerticalContentAlignment | Gets or sets the VerticalContentAlignment of the header. (Inherited from C1HeaderedContentControl.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsExpandable | Gets or sets whether the expander can be expanded and collapsed.
IsExpanded | Gets or sets whether the expander content is visible.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1HeaderedContentControl.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


ExpandDirection Property

[image]

.NET Framework Class Library
C1Expander..::.ExpandDirection Property
C1Expander Class See Also
Gets or sets the direction the expander expands.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic (Declaration)
Public Property ExpandDirection As ExpandDirection

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


IsExpandable Property

[image]

.NET Framework Class Library
C1Expander..::.IsExpandable Property
C1Expander Class See Also
Gets or sets whether the expander can be expanded and collapsed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsExpandable { get; set; }
Visual Basic (Declaration)
Public Property IsExpandable As Boolean

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


IsExpanded Property

[image]

.NET Framework Class Library
C1Expander..::.IsExpanded Property
C1Expander Class See Also
Gets or sets whether the expander content is visible.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsExpanded { get; set; }
Visual Basic (Declaration)
Public Property IsExpanded As Boolean

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1Expander Events

[image] [image]

.NET Framework Class Library
C1Expander Events
C1Expander Class See Also

The C1Expander type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsExpandedChanged | Event raised when the IsExpanded property has changed.
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1HeaderedContentControl.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


IsExpandedChanged Event

[image]

.NET Framework Class Library
C1Expander..::.IsExpandedChanged Event
C1Expander Class See Also
Event raised when the IsExpanded property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsExpandedChanged
Visual Basic (Declaration)
Public Event IsExpandedChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Expander Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Class

[image]

.NET Framework Class Library
C1ExpanderButton Class
Members See Also
Toggle Button whose ExpandDirection property and states are used to change the appearance of the expand button of the C1Expander.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Right", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Down", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Left", GroupName = "DirectionStates")]
[TemplateVisualStateAttribute(Name = "Up", GroupName = "DirectionStates")]
public class C1ExpanderButton : ToggleButton
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Right", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Down", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Left", GroupName := "DirectionStates")> _
<TemplateVisualStateAttribute(Name := "Up", GroupName := "DirectionStates")> _
Public Class C1ExpanderButton _
    Inherits ToggleButton

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls.Primitives..::.ToggleButton
C1.Silverlight.Extended..::.C1ExpanderButton

See Also

C1ExpanderButton Members
C1.Silverlight.Extended Namespace


C1ExpanderButton Members

[image] [image]

.NET Framework Class Library
C1ExpanderButton Members
C1ExpanderButton Class Constructors Methods Fields Properties Events See Also

The C1ExpanderButton type exposes the following members.

Constructors

Name | Description
C1ExpanderButton | Initializes a new instance of a C1ExpanderButton.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateDirection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ToggleButtonOnApplyTemplate()()().)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsEnabledChanged | (Inherited from ToggleButton.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ExpandDirection | Gets or sets the direction the expander expands.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Constructor

[image]

.NET Framework Class Library
C1ExpanderButton Constructor
C1ExpanderButton Class See Also
Initializes a new instance of a C1ExpanderButton.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ExpanderButton()
Visual Basic (Declaration)
Public Sub New

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Fields

[image] [image]

.NET Framework Class Library
C1ExpanderButton Fields
C1ExpanderButton Class See Also

The C1ExpanderButton type exposes the following members.

Fields

Name | Description
ExpandDirectionProperty | Identifies the ExpandDirection dependency property.

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


ExpandDirectionProperty Field

[image]

.NET Framework Class Library
C1ExpanderButton..::.ExpandDirectionProperty Field
C1ExpanderButton Class See Also
Identifies the ExpandDirection dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ExpandDirectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ExpandDirectionProperty As DependencyProperty

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Methods

[image] [image]

.NET Framework Class Library
C1ExpanderButton Methods
C1ExpanderButton Class See Also

The C1ExpanderButton type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateDirection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ToggleButtonOnApplyTemplate()()().)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsEnabledChanged | (Inherited from ToggleButton.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


ChangeVisualStateDirection Method

[image]

.NET Framework Class Library
C1ExpanderButton..::.ChangeVisualStateDirection Method
C1ExpanderButton Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateDirection(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateDirection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ExpanderButton..::.HitTest Method
C1ExpanderButton Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ExpanderButton Class
C1ExpanderButton Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ExpanderButton..::.OnApplyTemplate Method
C1ExpanderButton Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Properties

[image] [image]

.NET Framework Class Library
C1ExpanderButton Properties
C1ExpanderButton Class See Also

The C1ExpanderButton type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
ExpandDirection | Gets or sets the direction the expander expands.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


ExpandDirection Property

[image]

.NET Framework Class Library
C1ExpanderButton..::.ExpandDirection Property
C1ExpanderButton Class See Also
Gets or sets the direction the expander expands.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ExpandDirection ExpandDirection { get; set; }
Visual Basic (Declaration)
Public Property ExpandDirection As ExpandDirection

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1ExpanderButton Events

[image] [image]

.NET Framework Class Library
C1ExpanderButton Events
C1ExpanderButton Class See Also

The C1ExpanderButton type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

C1ExpanderButton Class
C1.Silverlight.Extended Namespace


C1HtmlHost Class

[image]

.NET Framework Class Library
C1HtmlHost Class
Members See Also
Control that shows HTML content within a Silverlight page.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public class C1HtmlHost : Panel
Visual Basic (Declaration)
Public Class C1HtmlHost _
    Inherits Panel

Remarks

To use this control the Silverlight plugin should have its 'windowless' parameter set to true.

For example, if the Silverlight plugin is declared in an aspx page, it should be edited as follows:

Copy CodeC#
<form id="form1" runat="server" style="height:100%;">
  <asp:ScriptManager ID="ScriptManager1" runat="server"></asp:ScriptManager>
  <div  style="height:100%;">
    <asp:Silverlight
      ID="Xaml1" runat="server"
      Source="~/ClientBin/TestM1.xap"
      Version="2.0" Width="100%" Height="100%"
      <b>Windowless="true" /></b>
  </div>
</form>
 If the plugin is declared in a html page, it should be edited as follows:
Copy CodeC#
<div id="silverlightControlHost">
<object data="data:application/x-silverlight," type="application/x-silverlight-2-b1" width="100%" height="100%" >
    <param name="source" value="ClientBin/TestM1.xap"/>
    <param name="onerror" value="onSilverlightError" />
    <param name="background" value="white" />
    <b><param name="windowless" value="true" /></b>
    <a href="http://go.microsoft.com/fwlink/?LinkID=108182" style="text-decoration: none;">
        <img src="http://go.microsoft.com/fwlink/?LinkId=108181" alt="Get Microsoft Silverlight" style="border-style: none"/>
    </a>
</object>
<iframe style='visibility:hidden;height:0;width:0;border:0px'></iframe>
</div>

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.Extended..::.C1HtmlHost

See Also

C1HtmlHost Members
C1.Silverlight.Extended Namespace


C1HtmlHost Members

[image] [image]

.NET Framework Class Library
C1HtmlHost Members
C1HtmlHost Class Constructors Methods Fields Properties Events See Also

The C1HtmlHost type exposes the following members.

Constructors

Name | Description
C1HtmlHost | Initializes a new instance of a C1HtmlHost.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | C1HtmlHost destructor. (Overrides Object..::.Finalize()()().)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
SourceHtmlProperty | Identifies the SourceHtml dependency property.
SourceUriProperty | Identifies the SourceUri dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HtmlElement | Gets the HtmlElement hosted by this C1HtmlHost control.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SourceHtml | Gets or set the HTML content as a string.
SourceUri | Gets or set a Uri that will provide the content for the control.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
UriLoaded | Fired when the content from a Uri has been loaded.

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1HtmlHost Constructor

[image]

.NET Framework Class Library
C1HtmlHost Constructor
C1HtmlHost Class See Also
Initializes a new instance of a C1HtmlHost.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1HtmlHost()
Visual Basic (Declaration)
Public Sub New

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1HtmlHost Fields

[image] [image]

.NET Framework Class Library
C1HtmlHost Fields
C1HtmlHost Class See Also

The C1HtmlHost type exposes the following members.

Fields

Name | Description
SourceHtmlProperty | Identifies the SourceHtml dependency property.
SourceUriProperty | Identifies the SourceUri dependency property.

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


SourceHtmlProperty Field

[image]

.NET Framework Class Library
C1HtmlHost..::.SourceHtmlProperty Field
C1HtmlHost Class See Also
Identifies the SourceHtml dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SourceHtmlProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceHtmlProperty As DependencyProperty

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


SourceUriProperty Field

[image]

.NET Framework Class Library
C1HtmlHost..::.SourceUriProperty Field
C1HtmlHost Class See Also
Identifies the SourceUri dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SourceUriProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceUriProperty As DependencyProperty

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1HtmlHost Methods

[image] [image]

.NET Framework Class Library
C1HtmlHost Methods
C1HtmlHost Class See Also

The C1HtmlHost type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | C1HtmlHost destructor. (Overrides Object..::.Finalize()()().)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1HtmlHost..::.ArrangeOverride Method
C1HtmlHost Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


Finalize Method

[image]

.NET Framework Class Library
C1HtmlHost..::.Finalize Method
C1HtmlHost Class See Also
C1HtmlHost destructor.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override void Finalize()
Visual Basic (Declaration)
Protected Overrides Sub Finalize

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1HtmlHost..::.HitTest Method
C1HtmlHost Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1HtmlHost Class
C1HtmlHost Members
C1.Silverlight.Extended Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1HtmlHost..::.MeasureOverride Method
C1HtmlHost Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1HtmlHost Properties

[image] [image]

.NET Framework Class Library
C1HtmlHost Properties
C1HtmlHost Class See Also

The C1HtmlHost type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HtmlElement | Gets the HtmlElement hosted by this C1HtmlHost control.
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SourceHtml | Gets or set the HTML content as a string.
SourceUri | Gets or set a Uri that will provide the content for the control.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


HtmlElement Property

[image]

.NET Framework Class Library
C1HtmlHost..::.HtmlElement Property
C1HtmlHost Class See Also
Gets the HtmlElement hosted by this C1HtmlHost control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public HtmlElement HtmlElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property HtmlElement As HtmlElement

Remarks

If the SourceHtml property was set, HtmlElement returned is a div element whose content is the value of the SourceHtml property. Otherwise, if the property was set, the content is an iframe element whose src is the value of the SourceUri property.

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


SourceHtml Property

[image]

.NET Framework Class Library
C1HtmlHost..::.SourceHtml Property
C1HtmlHost Class See Also
Gets or set the HTML content as a string.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public string SourceHtml { get; set; }
Visual Basic (Declaration)
Public Property SourceHtml As String

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


SourceUri Property

[image]

.NET Framework Class Library
C1HtmlHost..::.SourceUri Property
C1HtmlHost Class See Also
Gets or set a Uri that will provide the content for the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TypeConverterAttribute(null)]
public Uri SourceUri { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(Nothing)> _
Public Property SourceUri As Uri

Remarks

When hosting content from a Uri you should set the Width and Height of the control, or it may not be sized properly.

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1HtmlHost Events

[image] [image]

.NET Framework Class Library
C1HtmlHost Events
C1HtmlHost Class See Also

The C1HtmlHost type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
UriLoaded | Fired when the content from a Uri has been loaded.

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


UriLoaded Event

[image]

.NET Framework Class Library
C1HtmlHost..::.UriLoaded Event
C1HtmlHost Class See Also
Fired when the content from a Uri has been loaded.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler UriLoaded
Visual Basic (Declaration)
Public Event UriLoaded As EventHandler

See Also

C1HtmlHost Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Class

[image]

.NET Framework Class Library
C1ImageMagnifier Class
Members See Also
Customizable magnifier for an image

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Magnifier", Type = typeof(Border))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Image", Type = typeof(Image))]
[TemplatePartAttribute(Name = "MagnifierContent", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "MagnifiedImage", Type = typeof(Image))]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
public class C1ImageMagnifier : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Magnifier", Type := GetType(Border))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Image", Type := GetType(Image))> _
<TemplatePartAttribute(Name := "MagnifierContent", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "MagnifiedImage", Type := GetType(Image))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
Public Class C1ImageMagnifier _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Extended..::.C1ImageMagnifier

See Also

C1ImageMagnifier Members
C1.Silverlight.Extended Namespace


C1ImageMagnifier Members

[image] [image]

.NET Framework Class Library
C1ImageMagnifier Members
C1ImageMagnifier Class Constructors Methods Fields Properties Events See Also

The C1ImageMagnifier type exposes the following members.

Constructors

Name | Description
C1ImageMagnifier | Initializes a new instance of a C1ImageMagnifier.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
HandleKeyboardProperty | Identifies the HandleKeyboard dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
PanStepProperty | Identifies the PanStep dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomIncrementProperty | Identifies the ZoomIncrement dependency property.
ZoomMaximumProperty | Identifies the ZoomMaximum dependency property.
ZoomMinimumProperty | Identifies the ZoomMinimum dependency property.
ZoomProperty | Identifies the Zoom dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HandleKeyboard | Determines whether the control should handle the keyboard to provide automatic zooming and panning.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Magnifier | Gets the Border element that represents the magnifying glass over the main image.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PanStep | Gets or sets the distance by which the magnifier moves when the user presses the cursor keys;
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Source | Gets or sets the source for the C1ImageMagnifier.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
Zoom | Gets or sets the zoom factor provided by the magnifying glass.
ZoomIncrement | Gets or sets the zoom increment applied when the user presses the plus and minus keys.
ZoomMaximum | Gets or sets the maximum zoom applied when the user presses the plus and minus keys.
ZoomMinimum | Gets or sets the minimum zoom applied when the user presses the plus and minus keys.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ZoomChanged | Event raised when the Zoom property has changed.

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Constructor

[image]

.NET Framework Class Library
C1ImageMagnifier Constructor
C1ImageMagnifier Class See Also
Initializes a new instance of a C1ImageMagnifier.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ImageMagnifier()
Visual Basic (Declaration)
Public Sub New

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Fields

[image] [image]

.NET Framework Class Library
C1ImageMagnifier Fields
C1ImageMagnifier Class See Also

The C1ImageMagnifier type exposes the following members.

Fields

Name | Description
HandleKeyboardProperty | Identifies the HandleKeyboard dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
PanStepProperty | Identifies the PanStep dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomIncrementProperty | Identifies the ZoomIncrement dependency property.
ZoomMaximumProperty | Identifies the ZoomMaximum dependency property.
ZoomMinimumProperty | Identifies the ZoomMinimum dependency property.
ZoomProperty | Identifies the Zoom dependency property.

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


HandleKeyboardProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.HandleKeyboardProperty Field
C1ImageMagnifier Class See Also
Identifies the HandleKeyboard dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty HandleKeyboardProperty
Visual Basic (Declaration)
Public Shared ReadOnly HandleKeyboardProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.IsMouseOverProperty Field
C1ImageMagnifier Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


PanStepProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.PanStepProperty Field
C1ImageMagnifier Class See Also
Identifies the PanStep dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty PanStepProperty
Visual Basic (Declaration)
Public Shared ReadOnly PanStepProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


SourceProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.SourceProperty Field
C1ImageMagnifier Class See Also
Identifies the Source dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomIncrementProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomIncrementProperty Field
C1ImageMagnifier Class See Also
Identifies the ZoomIncrement dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ZoomIncrementProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomIncrementProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomMaximumProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomMaximumProperty Field
C1ImageMagnifier Class See Also
Identifies the ZoomMaximum dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ZoomMaximumProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomMaximumProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomMinimumProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomMinimumProperty Field
C1ImageMagnifier Class See Also
Identifies the ZoomMinimum dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ZoomMinimumProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomMinimumProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomProperty Field

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomProperty Field
C1ImageMagnifier Class See Also
Identifies the Zoom dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Methods

[image] [image]

.NET Framework Class Library
C1ImageMagnifier Methods
C1ImageMagnifier Class See Also

The C1ImageMagnifier type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ArrangeOverride Method
C1ImageMagnifier Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ChangeVisualStateCommon Method
C1ImageMagnifier Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ImageMagnifier..::.HitTest Method
C1ImageMagnifier Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ImageMagnifier Class
C1ImageMagnifier Members
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ImageMagnifier..::.OnApplyTemplate Method
C1ImageMagnifier Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Properties

[image] [image]

.NET Framework Class Library
C1ImageMagnifier Properties
C1ImageMagnifier Class See Also

The C1ImageMagnifier type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HandleKeyboard | Determines whether the control should handle the keyboard to provide automatic zooming and panning.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Magnifier | Gets the Border element that represents the magnifying glass over the main image.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
PanStep | Gets or sets the distance by which the magnifier moves when the user presses the cursor keys;
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Source | Gets or sets the source for the C1ImageMagnifier.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
Zoom | Gets or sets the zoom factor provided by the magnifying glass.
ZoomIncrement | Gets or sets the zoom increment applied when the user presses the plus and minus keys.
ZoomMaximum | Gets or sets the maximum zoom applied when the user presses the plus and minus keys.
ZoomMinimum | Gets or sets the minimum zoom applied when the user presses the plus and minus keys.

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


HandleKeyboard Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.HandleKeyboard Property
C1ImageMagnifier Class See Also
Determines whether the control should handle the keyboard to provide automatic zooming and panning.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool HandleKeyboard { get; set; }
Visual Basic (Declaration)
Public Property HandleKeyboard As Boolean

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.IsMouseOver Property
C1ImageMagnifier Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


Magnifier Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.Magnifier Property
C1ImageMagnifier Class See Also
Gets the Border element that represents the magnifying glass over the main image.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Border Magnifier { get; }
Visual Basic (Declaration)
Public ReadOnly Property Magnifier As Border

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


PanStep Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.PanStep Property
C1ImageMagnifier Class See Also
Gets or sets the distance by which the magnifier moves when the user presses the cursor keys;

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double PanStep { get; set; }
Visual Basic (Declaration)
Public Property PanStep As Double

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


Source Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.Source Property
C1ImageMagnifier Class See Also
Gets or sets the source for the C1ImageMagnifier.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ImageSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As ImageSource

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


Zoom Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.Zoom Property
C1ImageMagnifier Class See Also
Gets or sets the zoom factor provided by the magnifying glass.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomIncrement Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomIncrement Property
C1ImageMagnifier Class See Also
Gets or sets the zoom increment applied when the user presses the plus and minus keys.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double ZoomIncrement { get; set; }
Visual Basic (Declaration)
Public Property ZoomIncrement As Double

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomMaximum Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomMaximum Property
C1ImageMagnifier Class See Also
Gets or sets the maximum zoom applied when the user presses the plus and minus keys.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double ZoomMaximum { get; set; }
Visual Basic (Declaration)
Public Property ZoomMaximum As Double

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomMinimum Property

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomMinimum Property
C1ImageMagnifier Class See Also
Gets or sets the minimum zoom applied when the user presses the plus and minus keys.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double ZoomMinimum { get; set; }
Visual Basic (Declaration)
Public Property ZoomMinimum As Double

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageMagnifier Events

[image] [image]

.NET Framework Class Library
C1ImageMagnifier Events
C1ImageMagnifier Class See Also

The C1ImageMagnifier type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ZoomChanged | Event raised when the Zoom property has changed.

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ImageMagnifier..::.IsMouseOverChanged Event
C1ImageMagnifier Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


ZoomChanged Event

[image]

.NET Framework Class Library
C1ImageMagnifier..::.ZoomChanged Event
C1ImageMagnifier Class See Also
Event raised when the Zoom property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> ZoomChanged
Visual Basic (Declaration)
Public Event ZoomChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1ImageMagnifier Class
C1.Silverlight.Extended Namespace


C1ImageRotator Class

[image]

.NET Framework Class Library
C1ImageRotator Class
Members See Also
Control that applies a pseudo-3D effect to rotate images.
Represents a control that applies a pseudo-3D rotation effect to images.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Root", Type = typeof(Panel))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1ImageRotator : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Root", Type := GetType(Panel))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1ImageRotator _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Extended..::.C1ImageRotator

See Also

C1ImageRotator Members
C1.Silverlight.Extended Namespace


C1ImageRotator Members

[image] [image]

.NET Framework Class Library
C1ImageRotator Members
C1ImageRotator Class Constructors Methods Fields Properties Events See Also

The C1ImageRotator type exposes the following members.

Constructors

Name | Description
C1ImageRotator | Initializes a new instance of a C1ImageRotator.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Positions child elements and determines a size for the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size in layout required for child elements and determines a size for the element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AngleProperty | Identifies the Angle dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
OrientationProperty | Identifies the Orientation dependency property.
PreserveControlSizeProperty | Identifies the PreserveControlSize dependency property.
ShowReflectionProperty | Identifies the ShowReflection dependency property.
SourceProperty | Identifies the Source dependency property.
UriSourceProperty | Identifies the UriSource dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Angle | Gets or sets the angle by which the image is rotated, in degrees.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the direction of the rotation.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreserveControlSize | Gets or sets whether the control size should be kept constant when the image is rotated.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowReflection | Gets or sets whether the control should display a reflection of the image.
Source | Gets or sets the ImageSource of the image displayed in the control.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UriSource | Gets or sets the Uri of the image displayed in the control.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
AngleChanged | Event raised when the Angle property has changed.
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


C1ImageRotator Constructor

[image]

.NET Framework Class Library
C1ImageRotator Constructor
C1ImageRotator Class See Also
Initializes a new instance of a C1ImageRotator.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1ImageRotator()
Visual Basic (Declaration)
Public Sub New

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


C1ImageRotator Fields

[image] [image]

.NET Framework Class Library
C1ImageRotator Fields
C1ImageRotator Class See Also

The C1ImageRotator type exposes the following members.

Fields

Name | Description
AngleProperty | Identifies the Angle dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
OrientationProperty | Identifies the Orientation dependency property.
PreserveControlSizeProperty | Identifies the PreserveControlSize dependency property.
ShowReflectionProperty | Identifies the ShowReflection dependency property.
SourceProperty | Identifies the Source dependency property.
UriSourceProperty | Identifies the UriSource dependency property.

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


AngleProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.AngleProperty Field
C1ImageRotator Class See Also
Identifies the Angle dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty AngleProperty
Visual Basic (Declaration)
Public Shared ReadOnly AngleProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.IsMouseOverProperty Field
C1ImageRotator Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


OrientationProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.OrientationProperty Field
C1ImageRotator Class See Also
Identifies the Orientation dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


PreserveControlSizeProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.PreserveControlSizeProperty Field
C1ImageRotator Class See Also
Identifies the PreserveControlSize dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty PreserveControlSizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly PreserveControlSizeProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


ShowReflectionProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.ShowReflectionProperty Field
C1ImageRotator Class See Also
Identifies the ShowReflection dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty ShowReflectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowReflectionProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


SourceProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.SourceProperty Field
C1ImageRotator Class See Also
Identifies the Source dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty SourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


UriSourceProperty Field

[image]

.NET Framework Class Library
C1ImageRotator..::.UriSourceProperty Field
C1ImageRotator Class See Also
Identifies the UriSource dependency property.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty UriSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly UriSourceProperty As DependencyProperty

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


C1ImageRotator Methods

[image] [image]

.NET Framework Class Library
C1ImageRotator Methods
C1ImageRotator Class See Also

The C1ImageRotator type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | Positions child elements and determines a size for the element. (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | Measures the size in layout required for child elements and determines a size for the element. (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1ImageRotator..::.ArrangeOverride Method
C1ImageRotator Class See Also
Positions child elements and determines a size for the element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size
The final area within the parent that this element should use to arrange itself and its children.

Return Value

The actual size used.

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ImageRotator..::.ChangeVisualStateCommon Method
C1ImageRotator Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ImageRotator..::.HitTest Method
C1ImageRotator Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ImageRotator Class
C1ImageRotator Members
C1.Silverlight.Extended Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1ImageRotator..::.MeasureOverride Method
C1ImageRotator Class See Also
Measures the size in layout required for child elements and determines a size for the element.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size
The available size that this element can give to child elements. Infinity can be specified as a value to indicate that the element will size to whatever content is available.

Return Value

The size that this element determines it needs during layout, based on its calculations of child element sizes.

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ImageRotator..::.OnApplyTemplate Method
C1ImageRotator Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


C1ImageRotator Properties

[image] [image]

.NET Framework Class Library
C1ImageRotator Properties
C1ImageRotator Class See Also

The C1ImageRotator type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Angle | Gets or sets the angle by which the image is rotated, in degrees.
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Gets or sets the direction of the rotation.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
PreserveControlSize | Gets or sets whether the control size should be kept constant when the image is rotated.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowReflection | Gets or sets whether the control should display a reflection of the image.
Source | Gets or sets the ImageSource of the image displayed in the control.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
UriSource | Gets or sets the Uri of the image displayed in the control.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


Angle Property

[image]

.NET Framework Class Library
C1ImageRotator..::.Angle Property
C1ImageRotator Class See Also
Gets or sets the angle by which the image is rotated, in degrees.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double Angle { get; set; }
Visual Basic (Declaration)
Public Property Angle As Double

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ImageRotator..::.IsMouseOver Property
C1ImageRotator Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


Orientation Property

[image]

.NET Framework Class Library
C1ImageRotator..::.Orientation Property
C1ImageRotator Class See Also
Gets or sets the direction of the rotation.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


PreserveControlSize Property

[image]

.NET Framework Class Library
C1ImageRotator..::.PreserveControlSize Property
C1ImageRotator Class See Also
Gets or sets whether the control size should be kept constant when the image is rotated.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool PreserveControlSize { get; set; }
Visual Basic (Declaration)
Public Property PreserveControlSize As Boolean

Remarks

If this property is set to true and the control dimensions are not explicitly set, then they are automatically adjusted fit the image size and the current angle.

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


ShowReflection Property

[image]

.NET Framework Class Library
C1ImageRotator..::.ShowReflection Property
C1ImageRotator Class See Also
Gets or sets whether the control should display a reflection of the image.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool ShowReflection { get; set; }
Visual Basic (Declaration)
Public Property ShowReflection As Boolean

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


Source Property

[image]

.NET Framework Class Library
C1ImageRotator..::.Source Property
C1ImageRotator Class See Also
Gets or sets the ImageSource of the image displayed in the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ImageSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As ImageSource

Remarks

Only a BitmapImage with a URI as source can be used.

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


UriSource Property

[image]

.NET Framework Class Library
C1ImageRotator..::.UriSource Property
C1ImageRotator Class See Also
Gets or sets the Uri of the image displayed in the control.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[TypeConverterAttribute(null)]
public Uri UriSource { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(Nothing)> _
Public Property UriSource As Uri

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


C1ImageRotator Events

[image] [image]

.NET Framework Class Library
C1ImageRotator Events
C1ImageRotator Class See Also

The C1ImageRotator type exposes the following members.

Events

Name | Description
AngleChanged | Event raised when the Angle property has changed.
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


AngleChanged Event

[image]

.NET Framework Class Library
C1ImageRotator..::.AngleChanged Event
C1ImageRotator Class See Also
Event raised when the Angle property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> AngleChanged
Visual Basic (Declaration)
Public Event AngleChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ImageRotator..::.IsMouseOverChanged Event
C1ImageRotator Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ImageRotator Class
C1.Silverlight.Extended Namespace


ColorPalette Class

[image]

.NET Framework Class Library
ColorPalette Class
Members See Also
Class that defines named groups of colors.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public sealed class ColorPalette : IEnumerable<ColorPaletteEntry>,
    IEnumerable
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public NotInheritable Class ColorPalette _
    Implements IEnumerable(Of ColorPaletteEntry), IEnumerable

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Extended..::.ColorPalette

See Also

ColorPalette Members
C1.Silverlight.Extended Namespace


ColorPalette Members

[image] [image]

.NET Framework Class Library
ColorPalette Members
ColorPalette Class Constructors Methods Properties See Also

The ColorPalette type exposes the following members.

Constructors

Name | Description
ColorPalette | Creates an instance of the color palette with the specified theme name.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all entries from the palette.
Clone | Returns a clone of this palette with the specified theme name.
Contains | Determines whether a color is in the palette.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColorPalette | Returns one of the predefined color palettes.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified color in the palette and returns a zero-based index of the found entry.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Set | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count | Gets the number of palette entries.
Item | Gets the palette entry with the specified index.
ThemeName | Gets or sets the name of the color theme.

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


ColorPalette Constructor

[image]

.NET Framework Class Library
ColorPalette Constructor
ColorPalette Class See Also
Creates an instance of the color palette with the specified theme name.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ColorPalette(
    string themeName
)
Visual Basic (Declaration)
Public Sub New ( _
    themeName As String _
)

Parameters

themeName
Type: System..::.String

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


ColorPalette Methods

[image] [image]

.NET Framework Class Library
ColorPalette Methods
ColorPalette Class See Also

The ColorPalette type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear | Deletes all entries from the palette.
Clone | Returns a clone of this palette with the specified theme name.
Contains | Determines whether a color is in the palette.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetColorPalette | Returns one of the predefined color palettes.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Searches for the specified color in the palette and returns a zero-based index of the found entry.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Set | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Add Method

[image] [image]

.NET Framework Class Library
ColorPalette..::.Add Method
ColorPalette Class See Also

Overload List

Name | Description
Add(Color) | Adds the specified color to the palette.
Add(Color, String) | Adds the color with the specified name.
Add(Color, String, String) | Adds the color with the specified name and description.

See Also

ColorPalette Class
ColorPalette Members
C1.Silverlight.Extended Namespace


Add Method (Color)

[image]

.NET Framework Class Library
ColorPalette..::.Add Method (Color)
ColorPalette Class See Also
Adds the specified color to the palette.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Add(
    Color color
)
Visual Basic (Declaration)
Public Sub Add ( _
    color As Color _
)

Parameters

color
Type: System.Windows.Media..::.Color

See Also

ColorPalette Class
Add Overload
C1.Silverlight.Extended Namespace


Add Method (Color, String)

[image]

.NET Framework Class Library
ColorPalette..::.Add Method (Color, String)
ColorPalette Class See Also
Adds the color with the specified name.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Add(
    Color color,
    string colorName
)
Visual Basic (Declaration)
Public Sub Add ( _
    color As Color, _
    colorName As String _
)

Parameters

color
Type: System.Windows.Media..::.Color
colorName
Type: System..::.String

See Also

ColorPalette Class
Add Overload
C1.Silverlight.Extended Namespace


Add Method (Color, String, String)

[image]

.NET Framework Class Library
ColorPalette..::.Add Method (Color, String, String)
ColorPalette Class See Also
Adds the color with the specified name and description.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Add(
    Color color,
    string colorName,
    string description
)
Visual Basic (Declaration)
Public Sub Add ( _
    color As Color, _
    colorName As String, _
    description As String _
)

Parameters

color
Type: System.Windows.Media..::.Color
colorName
Type: System..::.String
description
Type: System..::.String

See Also

ColorPalette Class
Add Overload
C1.Silverlight.Extended Namespace


Clear Method

[image]

.NET Framework Class Library
ColorPalette..::.Clear Method
ColorPalette Class See Also
Deletes all entries from the palette.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Clone Method

[image]

.NET Framework Class Library
ColorPalette..::.Clone Method
ColorPalette Class See Also
Returns a clone of this palette with the specified theme name.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ColorPalette Clone(
    string themeName
)
Visual Basic (Declaration)
Public Function Clone ( _
    themeName As String _
) As ColorPalette

Parameters

themeName
Type: System..::.String

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Contains Method

[image]

.NET Framework Class Library
ColorPalette..::.Contains Method
ColorPalette Class See Also
Determines whether a color is in the palette.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public bool Contains(
    Color color
)
Visual Basic (Declaration)
Public Function Contains ( _
    color As Color _
) As Boolean

Parameters

color
Type: System.Windows.Media..::.Color

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


GetColorPalette Method

[image]

.NET Framework Class Library
ColorPalette..::.GetColorPalette Method
ColorPalette Class See Also
Returns one of the predefined color palettes.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static ColorPalette GetColorPalette(
    Office2007ColorTheme colorPalette
)
Visual Basic (Declaration)
Public Shared Function GetColorPalette ( _
    colorPalette As Office2007ColorTheme _
) As ColorPalette

Parameters

colorPalette
Type: C1.Silverlight.Extended..::.Office2007ColorTheme

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


IndexOf Method

[image]

.NET Framework Class Library
ColorPalette..::.IndexOf Method
ColorPalette Class See Also
Searches for the specified color in the palette and returns a zero-based index of the found entry.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public int IndexOf(
    Color color
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    color As Color _
) As Integer

Parameters

color
Type: System.Windows.Media..::.Color

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Set Method

[image] [image]

.NET Framework Class Library
ColorPalette..::.Set Method
ColorPalette Class See Also

Overload List

Name | Description
Set(Int32, Color) | Assigns the color to the palette entry with the specified index.
Set(Int32, Color, String) | Assigns the color and color name to the palette entry with the specified index.

See Also

ColorPalette Class
ColorPalette Members
C1.Silverlight.Extended Namespace


Set Method (Int32, Color)

[image]

.NET Framework Class Library
ColorPalette..::.Set Method (Int32, Color)
ColorPalette Class See Also
Assigns the color to the palette entry with the specified index.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Set(
    int index,
    Color color
)
Visual Basic (Declaration)
Public Sub Set ( _
    index As Integer, _
    color As Color _
)

Parameters

index
Type: System..::.Int32
color
Type: System.Windows.Media..::.Color

See Also

ColorPalette Class
Set Overload
C1.Silverlight.Extended Namespace


Set Method (Int32, Color, String)

[image]

.NET Framework Class Library
ColorPalette..::.Set Method (Int32, Color, String)
ColorPalette Class See Also
Assigns the color and color name to the palette entry with the specified index.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Set(
    int index,
    Color color,
    string colorName
)
Visual Basic (Declaration)
Public Sub Set ( _
    index As Integer, _
    color As Color, _
    colorName As String _
)

Parameters

index
Type: System..::.Int32
color
Type: System.Windows.Media..::.Color
colorName
Type: System..::.String

See Also

ColorPalette Class
Set Overload
C1.Silverlight.Extended Namespace


ColorPalette Properties

[image] [image]

.NET Framework Class Library
ColorPalette Properties
ColorPalette Class See Also

The ColorPalette type exposes the following members.

Properties

Name | Description
Count | Gets the number of palette entries.
Item | Gets the palette entry with the specified index.
ThemeName | Gets or sets the name of the color theme.

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Count Property

[image]

.NET Framework Class Library
ColorPalette..::.Count Property
ColorPalette Class See Also
Gets the number of palette entries.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


Item Property

[image]

.NET Framework Class Library
ColorPalette..::.Item Property
ColorPalette Class See Also
Gets the palette entry with the specified index.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public ColorPaletteEntry this[
    int index
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    index As Integer _
) As ColorPaletteEntry

Parameters

index
Type: System..::.Int32

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


ThemeName Property

[image]

.NET Framework Class Library
ColorPalette..::.ThemeName Property
ColorPalette Class See Also
Gets or sets the name of the color theme.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public string ThemeName { get; set; }
Visual Basic (Declaration)
Public Property ThemeName As String

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


ColorPaletteEntry Class

[image]

.NET Framework Class Library
ColorPaletteEntry Class
Members See Also
Class that contains information about the color, its name and description.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public class ColorPaletteEntry
Visual Basic (Declaration)
Public Class ColorPaletteEntry

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Extended..::.ColorPaletteEntry

See Also

ColorPaletteEntry Members
C1.Silverlight.Extended Namespace


ColorPaletteEntry Members

[image] [image]

.NET Framework Class Library
ColorPaletteEntry Members
ColorPaletteEntry Class Methods Properties See Also

The ColorPaletteEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetColor | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Color | Gets the color of this entry.
ColorName | Gets the color name.
Description | Gets or sets the entry description.

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


ColorPaletteEntry Methods

[image] [image]

.NET Framework Class Library
ColorPaletteEntry Methods
ColorPaletteEntry Class See Also

The ColorPaletteEntry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SetColor | Overloaded.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


SetColor Method

[image] [image]

.NET Framework Class Library
ColorPaletteEntry..::.SetColor Method
ColorPaletteEntry Class See Also

Overload List

Name | Description
SetColor(Color) | Assign the color to this entry.
SetColor(Color, String) | Assign the color with the specified name to this entry.

See Also

ColorPaletteEntry Class
ColorPaletteEntry Members
C1.Silverlight.Extended Namespace


SetColor Method (Color)

[image]

.NET Framework Class Library
ColorPaletteEntry..::.SetColor Method (Color)
ColorPaletteEntry Class See Also
Assign the color to this entry.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void SetColor(
    Color color
)
Visual Basic (Declaration)
Public Sub SetColor ( _
    color As Color _
)

Parameters

color
Type: System.Windows.Media..::.Color

See Also

ColorPaletteEntry Class
SetColor Overload
C1.Silverlight.Extended Namespace


SetColor Method (Color, String)

[image]

.NET Framework Class Library
ColorPaletteEntry..::.SetColor Method (Color, String)
ColorPaletteEntry Class See Also
Assign the color with the specified name to this entry.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void SetColor(
    Color color,
    string colorName
)
Visual Basic (Declaration)
Public Sub SetColor ( _
    color As Color, _
    colorName As String _
)

Parameters

color
Type: System.Windows.Media..::.Color
colorName
Type: System..::.String

See Also

ColorPaletteEntry Class
SetColor Overload
C1.Silverlight.Extended Namespace


ColorPaletteEntry Properties

[image] [image]

.NET Framework Class Library
ColorPaletteEntry Properties
ColorPaletteEntry Class See Also

The ColorPaletteEntry type exposes the following members.

Properties

Name | Description
Color | Gets the color of this entry.
ColorName | Gets the color name.
Description | Gets or sets the entry description.

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


Color Property

[image]

.NET Framework Class Library
ColorPaletteEntry..::.Color Property
ColorPaletteEntry Class See Also
Gets the color of this entry.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


ColorName Property

[image]

.NET Framework Class Library
ColorPaletteEntry..::.ColorName Property
ColorPaletteEntry Class See Also
Gets the color name.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public string ColorName { get; }
Visual Basic (Declaration)
Public ReadOnly Property ColorName As String

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


Description Property

[image]

.NET Framework Class Library
ColorPaletteEntry..::.Description Property
ColorPaletteEntry Class See Also
Gets or sets the entry description.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public string Description { get; set; }
Visual Basic (Declaration)
Public Property Description As String

See Also

ColorPaletteEntry Class
C1.Silverlight.Extended Namespace


CubeFace Enumeration

[image]

.NET Framework Class Library
CubeFace Enumeration
See Also
Specifies a face in a cube.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public enum CubeFace
Visual Basic (Declaration)
Public Enumeration CubeFace

Members

Member name | Description
Front | The cube's front face.
Back | The cube's back face.
Left | The cube's left face.
Right | The cube's right face.
Top | The cube's top face.
Bottom | The cube's bottom face.

See Also

C1.Silverlight.Extended Namespace


ExpandDirection Enumeration

[image]

.NET Framework Class Library
ExpandDirection Enumeration
See Also
Specifies the direction in which a C1Expander control opens.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public enum ExpandDirection
Visual Basic (Declaration)
Public Enumeration ExpandDirection

Members

Member name | Description
Down | The C1Expander control opens down.
Up | The C1Expander control opens up.
Left | The C1Expander control opens left.
Right | The C1Expander control opens right.

See Also

C1.Silverlight.Extended Namespace


Office2007ColorTheme Enumeration

[image]

.NET Framework Class Library
Office2007ColorTheme Enumeration
See Also
Specifies a color theme from the standard Office2007 theme collection.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public enum Office2007ColorTheme
Visual Basic (Declaration)
Public Enumeration Office2007ColorTheme

Members

Member name | Description
Standard | Standard color theme.
Highlight | Highlight color theme.
Office | Office color theme.
GrayScale | GrayScale color theme.
Apex | Apex color theme.
Aspect | Aspect color theme.
Civic | Civic color theme.
Concourse | Concourse color theme.
Equity | Equity color theme.
Flow | Flow color theme.
Foundry | Foundry color theme.
Median | Median color theme.
Metro | Metro color theme.
Module | Module color theme.
Opulent | Opulent color theme.
Oriel | Oriel color theme.
Origin | Origin color theme.
Paper | Paper color theme.
Solstice | Solstice color theme.
Technic | Technic color theme.
Trek | Trek color theme.
Urban | Urban color theme.
Verve | Verve color theme.

See Also

C1.Silverlight.Extended Namespace


WebColor Class

[image]

.NET Framework Class Library
WebColor Class
Members See Also
Utility methods for web colors.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static class WebColor
Visual Basic (Declaration)
Public NotInheritable Class WebColor

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Extended..::.WebColor

See Also

WebColor Members
C1.Silverlight.Extended Namespace


WebColor Members

[image] [image]

.NET Framework Class Library
WebColor Members
WebColor Class Methods See Also

The WebColor type exposes the following members.

Methods

Name | Description
ToColor | Convert a hex string to a .NET Color object.

See Also

WebColor Class
C1.Silverlight.Extended Namespace


WebColor Methods

[image] [image]

.NET Framework Class Library
WebColor Methods
WebColor Class See Also

The WebColor type exposes the following members.

Methods

Name | Description
ToColor | Convert a hex string to a .NET Color object.

See Also

WebColor Class
C1.Silverlight.Extended Namespace


ToColor Method

[image]

.NET Framework Class Library
WebColor..::.ToColor Method
WebColor Class See Also
Convert a hex string to a .NET Color object.

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static Color ToColor(
    string hexColor
)
Visual Basic (Declaration)
Public Shared Function ToColor ( _
    hexColor As String _
) As Color

Parameters

hexColor
Type: System..::.String
A hex string: "FFFFFF", "#000000"

See Also

WebColor Class
C1.Silverlight.Extended Namespace


C1.Silverlight.Extended.Primitives Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Extended.Primitives Namespace

Classes

Class | Description
C1CubePanel | Panel that provides a 3D rotating cube with different content on each face.


C1CubePanel Class

[image]

.NET Framework Class Library
C1CubePanel Class
Members See Also
Panel that provides a 3D rotating cube with different content on each face.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public class C1CubePanel : Panel
Visual Basic (Declaration)
Public Class C1CubePanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.Extended.Primitives..::.C1CubePanel

See Also

C1CubePanel Members
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Members

[image] [image]

.NET Framework Class Library
C1CubePanel Members
C1CubePanel Class Constructors Methods Fields Properties Events See Also

The C1CubePanel type exposes the following members.

Constructors

Name | Description
C1CubePanel | Initializes a new instance of a C1CubePanel.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBounds | Returns a rectangles that bounds the rotated cube.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Rotate | Rotates the cube.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
RotationXProperty | Identifies the RotationX dependency property.
RotationYProperty | Identifies the RotationY dependency property.
RotationZProperty | Identifies the RotationZ dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RotationX | Gets or sets the rotation of the cube in the x axis.
RotationY | Gets or sets the rotation of the cube in the y axis.
RotationZ | Gets or sets the rotation of the cube in the z axis.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Constructor

[image]

.NET Framework Class Library
C1CubePanel Constructor
C1CubePanel Class See Also
Initializes a new instance of a C1CubePanel.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public C1CubePanel()
Visual Basic (Declaration)
Public Sub New

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Fields

[image] [image]

.NET Framework Class Library
C1CubePanel Fields
C1CubePanel Class See Also

The C1CubePanel type exposes the following members.

Fields

Name | Description
RotationXProperty | Identifies the RotationX dependency property.
RotationYProperty | Identifies the RotationY dependency property.
RotationZProperty | Identifies the RotationZ dependency property.

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationXProperty Field

[image]

.NET Framework Class Library
C1CubePanel..::.RotationXProperty Field
C1CubePanel Class See Also
Identifies the RotationX dependency property.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationXProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationXProperty As DependencyProperty

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationYProperty Field

[image]

.NET Framework Class Library
C1CubePanel..::.RotationYProperty Field
C1CubePanel Class See Also
Identifies the RotationY dependency property.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationYProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationYProperty As DependencyProperty

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationZProperty Field

[image]

.NET Framework Class Library
C1CubePanel..::.RotationZProperty Field
C1CubePanel Class See Also
Identifies the RotationZ dependency property.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public static readonly DependencyProperty RotationZProperty
Visual Basic (Declaration)
Public Shared ReadOnly RotationZProperty As DependencyProperty

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Methods

[image] [image]

.NET Framework Class Library
C1CubePanel Methods
C1CubePanel Class See Also

The C1CubePanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetBounds | Returns a rectangles that bounds the rotated cube.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
Rotate | Rotates the cube.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1CubePanel..::.ArrangeOverride Method
C1CubePanel Class See Also

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


GetBounds Method

[image]

.NET Framework Class Library
C1CubePanel..::.GetBounds Method
C1CubePanel Class See Also
Returns a rectangles that bounds the rotated cube.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public Rect GetBounds()
Visual Basic (Declaration)
Public Function GetBounds As Rect

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1CubePanel..::.HitTest Method
C1CubePanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1CubePanel Class
C1CubePanel Members
C1.Silverlight.Extended.Primitives Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1CubePanel..::.MeasureOverride Method
C1CubePanel Class See Also

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


Rotate Method

[image]

.NET Framework Class Library
C1CubePanel..::.Rotate Method
C1CubePanel Class See Also
Rotates the cube.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public void Rotate(
    double rotationX,
    double rotationY,
    double rotationZ
)
Visual Basic (Declaration)
Public Sub Rotate ( _
    rotationX As Double, _
    rotationY As Double, _
    rotationZ As Double _
)

Parameters

rotationX
Type: System..::.Double
Rotation around the X axis.
rotationY
Type: System..::.Double
Rotation around the Y axis.
rotationZ
Type: System..::.Double
Rotation around the Z axis.

Remarks

The rotation is done around the X axis, then around the Y axis and finally around the Z axis.

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Properties

[image] [image]

.NET Framework Class Library
C1CubePanel Properties
C1CubePanel Class See Also

The C1CubePanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RotationX | Gets or sets the rotation of the cube in the x axis.
RotationY | Gets or sets the rotation of the cube in the y axis.
RotationZ | Gets or sets the rotation of the cube in the z axis.
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationX Property

[image]

.NET Framework Class Library
C1CubePanel..::.RotationX Property
C1CubePanel Class See Also
Gets or sets the rotation of the cube in the x axis.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationX { get; set; }
Visual Basic (Declaration)
Public Property RotationX As Double

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationY Property

[image]

.NET Framework Class Library
C1CubePanel..::.RotationY Property
C1CubePanel Class See Also
Gets or sets the rotation of the cube in the y axis.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationY { get; set; }
Visual Basic (Declaration)
Public Property RotationY As Double

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


RotationZ Property

[image]

.NET Framework Class Library
C1CubePanel..::.RotationZ Property
C1CubePanel Class See Also
Gets or sets the rotation of the cube in the z axis.

Namespace: C1.Silverlight.Extended.Primitives
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
public double RotationZ { get; set; }
Visual Basic (Declaration)
Public Property RotationZ As Double

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1CubePanel Events

[image] [image]

.NET Framework Class Library
C1CubePanel Events
C1CubePanel Class See Also

The C1CubePanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1CubePanel Class
C1.Silverlight.Extended.Primitives Namespace


C1.Silverlight.Gauge Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Gauge Namespace

Classes

Class | Description
C1Gauge | Base class for gauges controls.
C1GaugeDecorator | Base class for all the C1Gauge decorators.
C1GaugeDecoratorInfo | Base class for C1GaugeDecorator data elements.
C1GaugeMark | C1GaugeDecorator used to place marks within the C1Gauge
C1GaugeMarkInfo | Data element that is set to each instance of a C1GaugeMark as its DataContext.
C1GaugeRange | C1GaugeDecorator used to define a range within the C1Gauge.
C1GaugeRangeInfo | Data element that is set to each instance of a C1GaugeMark as its DataContext.
C1LinearGauge | C1Gauge shown in a linear axis.
C1RadialGauge | C1Gauge shown in a circular or radial axis.
GaugeDrawingContext | Context of the C1Gauge when it's being drawn.
GaugeLayoutChangedEventArgs | Event args of the LayoutChanged of the Gauge context

Enumerations

Enumeration | Description
C1GaugeAxis | Represents the axis of the C1Gauge.
RangeValueBinding | Binding options for the C1GaugeRange.


C1Gauge Class

[image]

.NET Framework Class Library
C1Gauge Class
Members See Also
Base class for gauges controls.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
[TemplatePartAttribute(Name = "PointerLayer", Type = typeof(Panel))]
[TemplatePartAttribute(Name = "PointerBorder", Type = typeof(Border))]
[TemplatePartAttribute(Name = "Root", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "FaceBorder", Type = typeof(Border))]
[TemplatePartAttribute(Name = "DecoratorsLayer", Type = typeof(Canvas))]
[TemplatePartAttribute(Name = "CoverBorder", Type = typeof(Border))]
[ContentPropertyAttribute("Decorators")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "PointerCapBorder", Type = typeof(Border))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public abstract class C1Gauge : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "PointerLayer", Type := GetType(Panel))> _
<TemplatePartAttribute(Name := "PointerBorder", Type := GetType(Border))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "FaceBorder", Type := GetType(Border))> _
<TemplatePartAttribute(Name := "DecoratorsLayer", Type := GetType(Canvas))> _
<TemplatePartAttribute(Name := "CoverBorder", Type := GetType(Border))> _
<ContentPropertyAttribute("Decorators")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "PointerCapBorder", Type := GetType(Border))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public MustInherit Class C1Gauge _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1Gauge
C1.Silverlight.Gauge..::.C1LinearGauge
C1.Silverlight.Gauge..::.C1RadialGauge

See Also

C1Gauge Members
C1.Silverlight.Gauge Namespace


C1Gauge Members

[image] [image]

.NET Framework Class Library
C1Gauge Members
C1Gauge Class Constructors Methods Fields Properties Events See Also

The C1Gauge type exposes the following members.

Constructors

Name | Description
C1Gauge | Initializes a new instance of a C1Gauge.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | Build the default storyboard used to animate this type of C1Gauge.
GetGeometry | Builds the geometry used to represent an element from a starting value to an end one.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIsDefault | Gets the value of the IsDefault attached property for the specified element.
GetTemplateChild | (Inherited from Control.)
GetTransform | Builds transformation required to place an element in a specific value position within the C1Gauge.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | Converts a logical offset value to width in the screen.
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | Override this method to create custom default decorators. This method is called when the used hasn't defined any decorator for the C1Gauge.
OnLayoutChanged | Fires the LayoutChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetIsDefault | Sets the value of the IsDefault attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CoverProperty | Identifies the Cover dependency property.
CoverTemplateProperty | Identifies the CoverTemplate dependency property.
CoverVisibilityProperty | Identifies the CoverVisibility dependency property.
DecoratorsProperty | Identifies the Decorators dependency property.
DecoratorsVisibilityProperty | Identifies the DecoratorsVisibility dependency property.
DefaultLabelTemplateProperty | Identifies the DefaultLabelTemplate dependency property.
DefaultMarkTemplateProperty | Identifies the DefaultMarkTemplate dependency property.
FaceProperty | Identifies the Face dependency property.
FaceTemplateProperty | Identifies the FaceTemplate dependency property.
FaceVisibilityProperty | Identifies the FaceVisibility dependency property.
IsDefaultProperty | Identifies the IsDefault attached property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
PointerAnimationProperty | Identifies the PointerAnimation dependency property.
PointerCapProperty | Identifies the PointerCap dependency property.
PointerCapTemplateProperty | Identifies the PointerCapTemplate dependency property.
PointerProperty | Identifies the Pointer dependency property.
PointerTemplateProperty | Identifies the PointerTemplate dependency property.
PointerVisibilityProperty | Identifies the PointerVisibility dependency property.
ShowDefaultDecoratorsProperty | Identifies the ShowDefaultDecorators dependency property.
ValueProperty | Identifies the Value dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context |
Cover | FrameworkElement in the top layer (over everything).
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property.
CoverVisibility | Show/hide the C1Gauge top layer.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark.
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators.
DefaultLabelTemplate | Default DataTemplate for the Labels.
DefaultMarkTemplate | Default DataTemplate for the Marks.
DefaultSize | Size used by default in the VS designer
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators).
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property.
FaceVisibility | Show/hide the C1Gauge bottom layer.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage.
Pointer | FrameworkElement representing the Pointer.
PointerAnimation | When defined, replace the default pointer animation by this one.
PointerCap | FrameworkElement representing the PointerCap.
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property.
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property.
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1Gauge Constructor

[image]

.NET Framework Class Library
C1Gauge Constructor
C1Gauge Class See Also
Initializes a new instance of a C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1Gauge()
Visual Basic (Declaration)
Public Sub New

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1Gauge Fields

[image] [image]

.NET Framework Class Library
C1Gauge Fields
C1Gauge Class See Also

The C1Gauge type exposes the following members.

Fields

Name | Description
CoverProperty | Identifies the Cover dependency property.
CoverTemplateProperty | Identifies the CoverTemplate dependency property.
CoverVisibilityProperty | Identifies the CoverVisibility dependency property.
DecoratorsProperty | Identifies the Decorators dependency property.
DecoratorsVisibilityProperty | Identifies the DecoratorsVisibility dependency property.
DefaultLabelTemplateProperty | Identifies the DefaultLabelTemplate dependency property.
DefaultMarkTemplateProperty | Identifies the DefaultMarkTemplate dependency property.
FaceProperty | Identifies the Face dependency property.
FaceTemplateProperty | Identifies the FaceTemplate dependency property.
FaceVisibilityProperty | Identifies the FaceVisibility dependency property.
IsDefaultProperty | Identifies the IsDefault attached property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MaximumProperty | Identifies the Maximum dependency property.
MinimumProperty | Identifies the Minimum dependency property.
PointerAnimationProperty | Identifies the PointerAnimation dependency property.
PointerCapProperty | Identifies the PointerCap dependency property.
PointerCapTemplateProperty | Identifies the PointerCapTemplate dependency property.
PointerProperty | Identifies the Pointer dependency property.
PointerTemplateProperty | Identifies the PointerTemplate dependency property.
PointerVisibilityProperty | Identifies the PointerVisibility dependency property.
ShowDefaultDecoratorsProperty | Identifies the ShowDefaultDecorators dependency property.
ValueProperty | Identifies the Value dependency property.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


CoverProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.CoverProperty Field
C1Gauge Class See Also
Identifies the Cover dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty CoverProperty
Visual Basic (Declaration)
Public Shared ReadOnly CoverProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


CoverTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.CoverTemplateProperty Field
C1Gauge Class See Also
Identifies the CoverTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty CoverTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly CoverTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


CoverVisibilityProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.CoverVisibilityProperty Field
C1Gauge Class See Also
Identifies the CoverVisibility dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty CoverVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly CoverVisibilityProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DecoratorsProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.DecoratorsProperty Field
C1Gauge Class See Also
Identifies the Decorators dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty DecoratorsProperty
Visual Basic (Declaration)
Public Shared ReadOnly DecoratorsProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DecoratorsVisibilityProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.DecoratorsVisibilityProperty Field
C1Gauge Class See Also
Identifies the DecoratorsVisibility dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty DecoratorsVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly DecoratorsVisibilityProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DefaultLabelTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.DefaultLabelTemplateProperty Field
C1Gauge Class See Also
Identifies the DefaultLabelTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty DefaultLabelTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly DefaultLabelTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DefaultMarkTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.DefaultMarkTemplateProperty Field
C1Gauge Class See Also
Identifies the DefaultMarkTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty DefaultMarkTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly DefaultMarkTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


FaceProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.FaceProperty Field
C1Gauge Class See Also
Identifies the Face dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty FaceProperty
Visual Basic (Declaration)
Public Shared ReadOnly FaceProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


FaceTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.FaceTemplateProperty Field
C1Gauge Class See Also
Identifies the FaceTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty FaceTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly FaceTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


FaceVisibilityProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.FaceVisibilityProperty Field
C1Gauge Class See Also
Identifies the FaceVisibility dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty FaceVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly FaceVisibilityProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


IsDefaultProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.IsDefaultProperty Field
C1Gauge Class See Also
Identifies the IsDefault attached property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty IsDefaultProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsDefaultProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.IsMouseOverProperty Field
C1Gauge Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


MaximumProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.MaximumProperty Field
C1Gauge Class See Also
Identifies the Maximum dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty MaximumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaximumProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


MinimumProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.MinimumProperty Field
C1Gauge Class See Also
Identifies the Minimum dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty MinimumProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinimumProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerAnimationProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerAnimationProperty Field
C1Gauge Class See Also
Identifies the PointerAnimation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerAnimationProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerAnimationProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerCapProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerCapProperty Field
C1Gauge Class See Also
Identifies the PointerCap dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerCapProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerCapProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerCapTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerCapTemplateProperty Field
C1Gauge Class See Also
Identifies the PointerCapTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerCapTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerCapTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerProperty Field
C1Gauge Class See Also
Identifies the Pointer dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerTemplateProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerTemplateProperty Field
C1Gauge Class See Also
Identifies the PointerTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerTemplateProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerVisibilityProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.PointerVisibilityProperty Field
C1Gauge Class See Also
Identifies the PointerVisibility dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerVisibilityProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ShowDefaultDecoratorsProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.ShowDefaultDecoratorsProperty Field
C1Gauge Class See Also
Identifies the ShowDefaultDecorators dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ShowDefaultDecoratorsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowDefaultDecoratorsProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ValueProperty Field

[image]

.NET Framework Class Library
C1Gauge..::.ValueProperty Field
C1Gauge Class See Also
Identifies the Value dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ValueProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValueProperty As DependencyProperty

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1Gauge Methods

[image] [image]

.NET Framework Class Library
C1Gauge Methods
C1Gauge Class See Also

The C1Gauge type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | Build the default storyboard used to animate this type of C1Gauge.
GetGeometry | Builds the geometry used to represent an element from a starting value to an end one.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetIsDefault | Gets the value of the IsDefault attached property for the specified element.
GetTemplateChild | (Inherited from Control.)
GetTransform | Builds transformation required to place an element in a specific value position within the C1Gauge.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | Converts a logical offset value to width in the screen.
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | Override this method to create custom default decorators. This method is called when the used hasn't defined any decorator for the C1Gauge.
OnLayoutChanged | Fires the LayoutChanged event.
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetIsDefault | Sets the value of the IsDefault attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1Gauge..::.ArrangeOverride Method
C1Gauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Gauge..::.ChangeVisualStateCommon Method
C1Gauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


GetDefaultPointerAnimation Method

[image]

.NET Framework Class Library
C1Gauge..::.GetDefaultPointerAnimation Method
C1Gauge Class See Also
Build the default storyboard used to animate this type of C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected abstract Storyboard GetDefaultPointerAnimation(
    GaugeDrawingContext context
)
Visual Basic (Declaration)
Protected MustOverride Function GetDefaultPointerAnimation ( _
    context As GaugeDrawingContext _
) As Storyboard

Parameters

context
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext
Drawing context for the C1Gauge.

Return Value

Storyboard used to animate the C1Gauge

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


GetGeometry Method

[image]

.NET Framework Class Library
C1Gauge..::.GetGeometry Method
C1Gauge Class See Also
Builds the geometry used to represent an element from a starting value to an end one.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public abstract Geometry GetGeometry(
    double startValue,
    double endValue,
    double yAxisLocation
)
Visual Basic (Declaration)
Public MustOverride Function GetGeometry ( _
    startValue As Double, _
    endValue As Double, _
    yAxisLocation As Double _
) As Geometry

Parameters

startValue
Type: System..::.Double
Value where the geometry has to start.
endValue
Type: System..::.Double
Value where the geometry has to end.
yAxisLocation
Type: System..::.Double
Relative offset of the element in the y-axis.

Return Value

Geometry used to represent the element.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


GetIsDefault Method

[image]

.NET Framework Class Library
C1Gauge..::.GetIsDefault Method
C1Gauge Class See Also
Gets the value of the IsDefault attached property for the specified element.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static bool GetIsDefault(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetIsDefault ( _
    element As DependencyObject _
) As Boolean

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the IsDefault property.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


GetTransform Method

[image]

.NET Framework Class Library
C1Gauge..::.GetTransform Method
C1Gauge Class See Also
Builds transformation required to place an element in a specific value position within the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public abstract Transform GetTransform(
    double value,
    double yAxisLocation,
    bool rotate
)
Visual Basic (Declaration)
Public MustOverride Function GetTransform ( _
    value As Double, _
    yAxisLocation As Double, _
    rotate As Boolean _
) As Transform

Parameters

value
Type: System..::.Double
Value to locate the element.
yAxisLocation
Type: System..::.Double
Relative offset of the element in the y-axis.
rotate
Type: System..::.Boolean
false to avoid rotations (useful for text elements).

Return Value

Transform that should be applied to the element.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Gauge..::.HitTest Method
C1Gauge Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Gauge Class
C1Gauge Members
C1.Silverlight.Gauge Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1Gauge..::.MeasureOverride Method
C1Gauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


OffsetToThickness Method

[image]

.NET Framework Class Library
C1Gauge..::.OffsetToThickness Method
C1Gauge Class See Also
Converts a logical offset value to width in the screen.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public abstract double OffsetToThickness(
    double offset,
    C1GaugeAxis axis
)
Visual Basic (Declaration)
Public MustOverride Function OffsetToThickness ( _
    offset As Double, _
    axis As C1GaugeAxis _
) As Double

Parameters

offset
Type: System..::.Double
Logical offset
axis
Type: C1.Silverlight.Gauge..::.C1GaugeAxis
Axis in which calculate the offset.

Return Value

The value in pixels.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Gauge..::.OnApplyTemplate Method
C1Gauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


OnCreateDefaultDecorators Method

[image]

.NET Framework Class Library
C1Gauge..::.OnCreateDefaultDecorators Method
C1Gauge Class See Also
Override this method to create custom default decorators. This method is called when the used hasn't defined any decorator for the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected virtual void OnCreateDefaultDecorators()
Visual Basic (Declaration)
Protected Overridable Sub OnCreateDefaultDecorators

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


OnLayoutChanged Method

[image]

.NET Framework Class Library
C1Gauge..::.OnLayoutChanged Method
C1Gauge Class See Also
Fires the LayoutChanged event.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected void OnLayoutChanged()
Visual Basic (Declaration)
Protected Sub OnLayoutChanged

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


SetIsDefault Method

[image]

.NET Framework Class Library
C1Gauge..::.SetIsDefault Method
C1Gauge Class See Also
Sets the value of the IsDefault attached property for the specified element.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static void SetIsDefault(
    DependencyObject element,
    bool value
)
Visual Basic (Declaration)
Public Shared Sub SetIsDefault ( _
    element As DependencyObject, _
    value As Boolean _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: System..::.Boolean
The property value to set.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1Gauge Properties

[image] [image]

.NET Framework Class Library
C1Gauge Properties
C1Gauge Class See Also

The C1Gauge type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context |
Cover | FrameworkElement in the top layer (over everything).
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property.
CoverVisibility | Show/hide the C1Gauge top layer.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark.
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators.
DefaultLabelTemplate | Default DataTemplate for the Labels.
DefaultMarkTemplate | Default DataTemplate for the Marks.
DefaultSize | Size used by default in the VS designer
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators).
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property.
FaceVisibility | Show/hide the C1Gauge bottom layer.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge.
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge.
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage.
Pointer | FrameworkElement representing the Pointer.
PointerAnimation | When defined, replace the default pointer animation by this one.
PointerCap | FrameworkElement representing the PointerCap.
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property.
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property.
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Context Property

[image]

.NET Framework Class Library
C1Gauge..::.Context Property
C1Gauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected GaugeDrawingContext Context { get; }
Visual Basic (Declaration)
Protected ReadOnly Property Context As GaugeDrawingContext

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Cover Property

[image]

.NET Framework Class Library
C1Gauge..::.Cover Property
C1Gauge Class See Also
FrameworkElement in the top layer (over everything).

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FrameworkElement Cover { get; set; }
Visual Basic (Declaration)
Public Property Cover As FrameworkElement

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


CoverTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.CoverTemplate Property
C1Gauge Class See Also
DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate CoverTemplate { get; set; }
Visual Basic (Declaration)
Public Property CoverTemplate As DataTemplate

Remarks

Using DataTemplates to be able to insert user UIElements in the C1Gauge visual tree.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


CoverVisibility Property

[image]

.NET Framework Class Library
C1Gauge..::.CoverVisibility Property
C1Gauge Class See Also
Show/hide the C1Gauge top layer.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Visibility CoverVisibility { get; set; }
Visual Basic (Declaration)
Public Property CoverVisibility As Visibility

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Decorators Property

[image]

.NET Framework Class Library
C1Gauge..::.Decorators Property
C1Gauge Class See Also
Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public ObservableCollection<C1GaugeDecorator> Decorators { get; set; }
Visual Basic (Declaration)
Public Property Decorators As ObservableCollection(Of C1GaugeDecorator)

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DecoratorsVisibility Property

[image]

.NET Framework Class Library
C1Gauge..::.DecoratorsVisibility Property
C1Gauge Class See Also
Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Visibility DecoratorsVisibility { get; set; }
Visual Basic (Declaration)
Public Property DecoratorsVisibility As Visibility

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DefaultLabelTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.DefaultLabelTemplate Property
C1Gauge Class See Also
Default DataTemplate for the Labels.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate DefaultLabelTemplate { get; set; }
Visual Basic (Declaration)
Public Property DefaultLabelTemplate As DataTemplate

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DefaultMarkTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.DefaultMarkTemplate Property
C1Gauge Class See Also
Default DataTemplate for the Marks.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate DefaultMarkTemplate { get; set; }
Visual Basic (Declaration)
Public Property DefaultMarkTemplate As DataTemplate

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


DefaultSize Property

[image]

.NET Framework Class Library
C1Gauge..::.DefaultSize Property
C1Gauge Class See Also
Size used by default in the VS designer

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public abstract Size DefaultSize { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property DefaultSize As Size

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Face Property

[image]

.NET Framework Class Library
C1Gauge..::.Face Property
C1Gauge Class See Also
FrameworkElement in the bottom layer (between the background and the decorators).

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FrameworkElement Face { get; set; }
Visual Basic (Declaration)
Public Property Face As FrameworkElement

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


FaceTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.FaceTemplate Property
C1Gauge Class See Also
DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate FaceTemplate { get; set; }
Visual Basic (Declaration)
Public Property FaceTemplate As DataTemplate

Remarks

Using DataTemplates to be able to insert user UIElements in the C1Gauge visual tree.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


FaceVisibility Property

[image]

.NET Framework Class Library
C1Gauge..::.FaceVisibility Property
C1Gauge Class See Also
Show/hide the C1Gauge bottom layer.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Visibility FaceVisibility { get; set; }
Visual Basic (Declaration)
Public Property FaceVisibility As Visibility

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Gauge..::.IsMouseOver Property
C1Gauge Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Maximum Property

[image]

.NET Framework Class Library
C1Gauge..::.Maximum Property
C1Gauge Class See Also
Maximum value for the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Minimum Property

[image]

.NET Framework Class Library
C1Gauge..::.Minimum Property
C1Gauge Class See Also
Minimum value for the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Percentage Property

[image]

.NET Framework Class Library
C1Gauge..::.Percentage Property
C1Gauge Class See Also
Gets or sets the current Value expressed as a percentage.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Percentage { get; set; }
Visual Basic (Declaration)
Public Property Percentage As Double

Remarks

This property returns a value between zero (when Value equals Minimum) and one (when Value equals Maximum).

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Pointer Property

[image]

.NET Framework Class Library
C1Gauge..::.Pointer Property
C1Gauge Class See Also
FrameworkElement representing the Pointer.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FrameworkElement Pointer { get; private set; }
Visual Basic (Declaration)
Public Property Pointer As FrameworkElement

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerAnimation Property

[image]

.NET Framework Class Library
C1Gauge..::.PointerAnimation Property
C1Gauge Class See Also
When defined, replace the default pointer animation by this one.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Storyboard PointerAnimation { get; set; }
Visual Basic (Declaration)
Public Property PointerAnimation As Storyboard

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerCap Property

[image]

.NET Framework Class Library
C1Gauge..::.PointerCap Property
C1Gauge Class See Also
FrameworkElement representing the PointerCap.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FrameworkElement PointerCap { get; private set; }
Visual Basic (Declaration)
Public Property PointerCap As FrameworkElement

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerCapTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.PointerCapTemplate Property
C1Gauge Class See Also
DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate PointerCapTemplate { get; set; }
Visual Basic (Declaration)
Public Property PointerCapTemplate As DataTemplate

Remarks

Using DataTemplates to be able to insert user UIElements in the C1Gauge visual tree. Set a Grid in order make it scale and locate the real PointerCap in the center.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerTemplate Property

[image]

.NET Framework Class Library
C1Gauge..::.PointerTemplate Property
C1Gauge Class See Also
DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate PointerTemplate { get; set; }
Visual Basic (Declaration)
Public Property PointerTemplate As DataTemplate

Remarks

Using DataTemplates to be able to insert user UIElements in the C1Gauge visual tree. Set a Grid in order make it scale and locate the real pointer in the center.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


PointerVisibility Property

[image]

.NET Framework Class Library
C1Gauge..::.PointerVisibility Property
C1Gauge Class See Also
Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Visibility PointerVisibility { get; set; }
Visual Basic (Declaration)
Public Property PointerVisibility As Visibility

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ShowDefaultDecorators Property

[image]

.NET Framework Class Library
C1Gauge..::.ShowDefaultDecorators Property
C1Gauge Class See Also
Create default decorators for an empty gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public bool ShowDefaultDecorators { get; set; }
Visual Basic (Declaration)
Public Property ShowDefaultDecorators As Boolean

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


Value Property

[image]

.NET Framework Class Library
C1Gauge..::.Value Property
C1Gauge Class See Also
Current value of the gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1Gauge Events

[image] [image]

.NET Framework Class Library
C1Gauge Events
C1Gauge Class See Also

The C1Gauge type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed.

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Gauge..::.IsMouseOverChanged Event
C1Gauge Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


ValueChanged Event

[image]

.NET Framework Class Library
C1Gauge..::.ValueChanged Event
C1Gauge Class See Also
Event raised when the Value property has changed.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1Gauge Class
C1.Silverlight.Gauge Namespace


C1GaugeAxis Enumeration

[image]

.NET Framework Class Library
C1GaugeAxis Enumeration
See Also
Represents the axis of the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public enum C1GaugeAxis
Visual Basic (Declaration)
Public Enumeration C1GaugeAxis

Members

Member name | Description
X | Gauge values axis.
Y | Gauge non values axis

See Also

C1.Silverlight.Gauge Namespace


C1GaugeDecorator Class

[image]

.NET Framework Class Library
C1GaugeDecorator Class
Members See Also
Base class for all the C1Gauge decorators.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Always)]
public abstract class C1GaugeDecorator : Control
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Always)> _
Public MustInherit Class C1GaugeDecorator _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1GaugeDecorator
C1.Silverlight.Gauge..::.C1GaugeMark
C1.Silverlight.Gauge..::.C1GaugeRange

See Also

C1GaugeDecorator Members
C1.Silverlight.Gauge Namespace


C1GaugeDecorator Members

[image] [image]

.NET Framework Class Library
C1GaugeDecorator Members
C1GaugeDecorator Class Constructors Methods Properties Events See Also

The C1GaugeDecorator type exposes the following members.

Constructors

Name | Description
C1GaugeDecorator |

Methods

Name | Description
AddElement | Adds an element to the decorators layer.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator.
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | Called after the context has changed
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


C1GaugeDecorator Constructor

[image]

.NET Framework Class Library
C1GaugeDecorator Constructor
C1GaugeDecorator Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected C1GaugeDecorator()
Visual Basic (Declaration)
Protected Sub New

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


C1GaugeDecorator Methods

[image] [image]

.NET Framework Class Library
C1GaugeDecorator Methods
C1GaugeDecorator Class See Also

The C1GaugeDecorator type exposes the following members.

Methods

Name | Description
AddElement | Adds an element to the decorators layer.
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator.
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | Called after the context has changed
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


AddElement Method

[image]

.NET Framework Class Library
C1GaugeDecorator..::.AddElement Method
C1GaugeDecorator Class See Also
Adds an element to the decorators layer.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected void AddElement(
    FrameworkElement element
)
Visual Basic (Declaration)
Protected Sub AddElement ( _
    element As FrameworkElement _
)

Parameters

element
Type: System.Windows..::.FrameworkElement
FrameworkElement to add

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


ClearElements Method

[image]

.NET Framework Class Library
C1GaugeDecorator..::.ClearElements Method
C1GaugeDecorator Class See Also
Clear all the elements added in the decorators layer for this decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected void ClearElements()
Visual Basic (Declaration)
Protected Sub ClearElements

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1GaugeDecorator..::.HitTest Method
C1GaugeDecorator Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1GaugeDecorator Class
C1GaugeDecorator Members
C1.Silverlight.Gauge Namespace


OnContextChanged Method

[image]

.NET Framework Class Library
C1GaugeDecorator..::.OnContextChanged Method
C1GaugeDecorator Class See Also
Called after the context has changed

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected virtual void OnContextChanged(
    GaugeDrawingContext oldValue
)
Visual Basic (Declaration)
Protected Overridable Sub OnContextChanged ( _
    oldValue As GaugeDrawingContext _
)

Parameters

oldValue
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext
Old context value

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


RemoveElement Method

[image]

.NET Framework Class Library
C1GaugeDecorator..::.RemoveElement Method
C1GaugeDecorator Class See Also
Remove an

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected void RemoveElement(
    FrameworkElement element
)
Visual Basic (Declaration)
Protected Sub RemoveElement ( _
    element As FrameworkElement _
)

Parameters

element
Type: System.Windows..::.FrameworkElement
FrameworkElement to remove

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


C1GaugeDecorator Properties

[image] [image]

.NET Framework Class Library
C1GaugeDecorator Properties
C1GaugeDecorator Class See Also

The C1GaugeDecorator type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


MyElements Property

[image]

.NET Framework Class Library
C1GaugeDecorator..::.MyElements Property
C1GaugeDecorator Class See Also
Returns all the framework element added by this decorator

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected IEnumerable<FrameworkElement> MyElements { get; }
Visual Basic (Declaration)
Protected ReadOnly Property MyElements As IEnumerable(Of FrameworkElement)

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


C1GaugeDecorator Events

[image] [image]

.NET Framework Class Library
C1GaugeDecorator Events
C1GaugeDecorator Class See Also

The C1GaugeDecorator type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1GaugeDecorator Class
C1.Silverlight.Gauge Namespace


C1GaugeDecoratorInfo Class

[image]

.NET Framework Class Library
C1GaugeDecoratorInfo Class
Members See Also
Base class for C1GaugeDecorator data elements.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1GaugeDecoratorInfo
Visual Basic (Declaration)
Public Class C1GaugeDecoratorInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Gauge..::.C1GaugeDecoratorInfo
C1.Silverlight.Gauge..::.C1GaugeMarkInfo
C1.Silverlight.Gauge..::.C1GaugeRangeInfo

See Also

C1GaugeDecoratorInfo Members
C1.Silverlight.Gauge Namespace


C1GaugeDecoratorInfo Members

[image] [image]

.NET Framework Class Library
C1GaugeDecoratorInfo Members
C1GaugeDecoratorInfo Class Constructors Methods Properties See Also

The C1GaugeDecoratorInfo type exposes the following members.

Constructors

Name | Description
C1GaugeDecoratorInfo | Public constructor

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Decorator | Decorator reference.
Gauge | C1Gauge that owns this instance.
Visibility | Bridge to the Visibility property of the Decorator.

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeDecoratorInfo Constructor

[image]

.NET Framework Class Library
C1GaugeDecoratorInfo Constructor
C1GaugeDecoratorInfo Class See Also
Public constructor

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeDecoratorInfo(
    C1GaugeDecorator dec
)
Visual Basic (Declaration)
Public Sub New ( _
    dec As C1GaugeDecorator _
)

Parameters

dec
Type: C1.Silverlight.Gauge..::.C1GaugeDecorator

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeDecoratorInfo Methods

[image] [image]

.NET Framework Class Library
C1GaugeDecoratorInfo Methods
C1GaugeDecoratorInfo Class See Also

The C1GaugeDecoratorInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeDecoratorInfo Properties

[image] [image]

.NET Framework Class Library
C1GaugeDecoratorInfo Properties
C1GaugeDecoratorInfo Class See Also

The C1GaugeDecoratorInfo type exposes the following members.

Properties

Name | Description
Decorator | Decorator reference.
Gauge | C1Gauge that owns this instance.
Visibility | Bridge to the Visibility property of the Decorator.

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


Decorator Property

[image]

.NET Framework Class Library
C1GaugeDecoratorInfo..::.Decorator Property
C1GaugeDecoratorInfo Class See Also
Decorator reference.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeDecorator Decorator { get; set; }
Visual Basic (Declaration)
Public Property Decorator As C1GaugeDecorator

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


Gauge Property

[image]

.NET Framework Class Library
C1GaugeDecoratorInfo..::.Gauge Property
C1GaugeDecoratorInfo Class See Also
C1Gauge that owns this instance.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1Gauge Gauge { get; set; }
Visual Basic (Declaration)
Public Property Gauge As C1Gauge

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


Visibility Property

[image]

.NET Framework Class Library
C1GaugeDecoratorInfo..::.Visibility Property
C1GaugeDecoratorInfo Class See Also
Bridge to the Visibility property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Visibility Visibility { get; }
Visual Basic (Declaration)
Public ReadOnly Property Visibility As Visibility

See Also

C1GaugeDecoratorInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Class

[image]

.NET Framework Class Library
C1GaugeMark Class
Members See Also
C1GaugeDecorator used to place marks within the C1Gauge

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1GaugeMark : C1GaugeDecorator
Visual Basic (Declaration)
Public Class C1GaugeMark _
    Inherits C1GaugeDecorator

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1GaugeDecorator
C1.Silverlight.Gauge..::.C1GaugeMark

See Also

C1GaugeMark Members
C1.Silverlight.Gauge Namespace


C1GaugeMark Members

[image] [image]

.NET Framework Class Library
C1GaugeMark Members
C1GaugeMark Class Constructors Methods Fields Properties Events See Also

The C1GaugeMark type exposes the following members.

Constructors

Name | Description
C1GaugeMark | Initializes a new instance of a C1GaugeMark.

Methods

Name | Description
AddElement | Adds an element to the decorators layer. (Inherited from C1GaugeDecorator.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator. (Inherited from C1GaugeDecorator.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | (Overrides C1GaugeDecorator..::.OnContextChanged(GaugeDrawingContext).)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an (Inherited from C1GaugeDecorator.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
FromProperty | Identifies the From dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelLocationProperty | Identifies the LabelLocation dependency property.
LabelTemplateProperty | Identifies the LabelTemplate dependency property.
MarkLocationProperty | Identifies the MarkLocation dependency property.
MarkTemplateProperty | Identifies the MarkTemplate dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMarksProperty | Identifies the ShowMarks dependency property.
ToProperty | Identifies the To dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
From | Start value for decorator to be applied.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Interval | Value interval to draw each mark.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
LabelLocation | Logical position of the labels, where 0 represents the center and 1 represents the axis location.
LabelTemplate | DataTemplate used to generate each Label.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MarkLocation | Logical position of the marks, where 0 represents the center and 1 represents the axis location.
MarkTemplate | DataTemplate used to generate each Mark.
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator (Inherited from C1GaugeDecorator.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowLabels | Turn on/off the labels.
ShowMarks | Turn on/off the marks.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
To | End value for decorator to be applied.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Constructor

[image]

.NET Framework Class Library
C1GaugeMark Constructor
C1GaugeMark Class See Also
Initializes a new instance of a C1GaugeMark.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeMark()
Visual Basic (Declaration)
Public Sub New

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Fields

[image] [image]

.NET Framework Class Library
C1GaugeMark Fields
C1GaugeMark Class See Also

The C1GaugeMark type exposes the following members.

Fields

Name | Description
FromProperty | Identifies the From dependency property.
IntervalProperty | Identifies the Interval dependency property.
LabelLocationProperty | Identifies the LabelLocation dependency property.
LabelTemplateProperty | Identifies the LabelTemplate dependency property.
MarkLocationProperty | Identifies the MarkLocation dependency property.
MarkTemplateProperty | Identifies the MarkTemplate dependency property.
ShowLabelsProperty | Identifies the ShowLabels dependency property.
ShowMarksProperty | Identifies the ShowMarks dependency property.
ToProperty | Identifies the To dependency property.

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


FromProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.FromProperty Field
C1GaugeMark Class See Also
Identifies the From dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty FromProperty
Visual Basic (Declaration)
Public Shared ReadOnly FromProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


IntervalProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.IntervalProperty Field
C1GaugeMark Class See Also
Identifies the Interval dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty IntervalProperty
Visual Basic (Declaration)
Public Shared ReadOnly IntervalProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


LabelLocationProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.LabelLocationProperty Field
C1GaugeMark Class See Also
Identifies the LabelLocation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty LabelLocationProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelLocationProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


LabelTemplateProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.LabelTemplateProperty Field
C1GaugeMark Class See Also
Identifies the LabelTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty LabelTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly LabelTemplateProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


MarkLocationProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.MarkLocationProperty Field
C1GaugeMark Class See Also
Identifies the MarkLocation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty MarkLocationProperty
Visual Basic (Declaration)
Public Shared ReadOnly MarkLocationProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


MarkTemplateProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.MarkTemplateProperty Field
C1GaugeMark Class See Also
Identifies the MarkTemplate dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty MarkTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly MarkTemplateProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


ShowLabelsProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.ShowLabelsProperty Field
C1GaugeMark Class See Also
Identifies the ShowLabels dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ShowLabelsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowLabelsProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


ShowMarksProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.ShowMarksProperty Field
C1GaugeMark Class See Also
Identifies the ShowMarks dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ShowMarksProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowMarksProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


ToProperty Field

[image]

.NET Framework Class Library
C1GaugeMark..::.ToProperty Field
C1GaugeMark Class See Also
Identifies the To dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ToProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToProperty As DependencyProperty

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Methods

[image] [image]

.NET Framework Class Library
C1GaugeMark Methods
C1GaugeMark Class See Also

The C1GaugeMark type exposes the following members.

Methods

Name | Description
AddElement | Adds an element to the decorators layer. (Inherited from C1GaugeDecorator.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator. (Inherited from C1GaugeDecorator.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | (Overrides C1GaugeDecorator..::.OnContextChanged(GaugeDrawingContext).)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an (Inherited from C1GaugeDecorator.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1GaugeMark..::.HitTest Method
C1GaugeMark Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1GaugeMark Class
C1GaugeMark Members
C1.Silverlight.Gauge Namespace


OnContextChanged Method

[image]

.NET Framework Class Library
C1GaugeMark..::.OnContextChanged Method
C1GaugeMark Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override void OnContextChanged(
    GaugeDrawingContext oldValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnContextChanged ( _
    oldValue As GaugeDrawingContext _
)

Parameters

oldValue
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Properties

[image] [image]

.NET Framework Class Library
C1GaugeMark Properties
C1GaugeMark Class See Also

The C1GaugeMark type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
From | Start value for decorator to be applied.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Interval | Value interval to draw each mark.
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
LabelLocation | Logical position of the labels, where 0 represents the center and 1 represents the axis location.
LabelTemplate | DataTemplate used to generate each Label.
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MarkLocation | Logical position of the marks, where 0 represents the center and 1 represents the axis location.
MarkTemplate | DataTemplate used to generate each Mark.
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator (Inherited from C1GaugeDecorator.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowLabels | Turn on/off the labels.
ShowMarks | Turn on/off the marks.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
To | End value for decorator to be applied.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


From Property

[image]

.NET Framework Class Library
C1GaugeMark..::.From Property
C1GaugeMark Class See Also
Start value for decorator to be applied.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double From { get; set; }
Visual Basic (Declaration)
Public Property From As Double

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


Interval Property

[image]

.NET Framework Class Library
C1GaugeMark..::.Interval Property
C1GaugeMark Class See Also
Value interval to draw each mark.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Interval { get; set; }
Visual Basic (Declaration)
Public Property Interval As Double

Remarks

Draw each mark at the current C1Gauge size. It will scale it automatically.

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


LabelLocation Property

[image]

.NET Framework Class Library
C1GaugeMark..::.LabelLocation Property
C1GaugeMark Class See Also
Logical position of the labels, where 0 represents the center and 1 represents the axis location.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double LabelLocation { get; set; }
Visual Basic (Declaration)
Public Property LabelLocation As Double

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


LabelTemplate Property

[image]

.NET Framework Class Library
C1GaugeMark..::.LabelTemplate Property
C1GaugeMark Class See Also
DataTemplate used to generate each Label.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate LabelTemplate { get; set; }
Visual Basic (Declaration)
Public Property LabelTemplate As DataTemplate

Remarks

The DataContext is a C1GaugeMarkInfo element.

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


MarkLocation Property

[image]

.NET Framework Class Library
C1GaugeMark..::.MarkLocation Property
C1GaugeMark Class See Also
Logical position of the marks, where 0 represents the center and 1 represents the axis location.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double MarkLocation { get; set; }
Visual Basic (Declaration)
Public Property MarkLocation As Double

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


MarkTemplate Property

[image]

.NET Framework Class Library
C1GaugeMark..::.MarkTemplate Property
C1GaugeMark Class See Also
DataTemplate used to generate each Mark.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public DataTemplate MarkTemplate { get; set; }
Visual Basic (Declaration)
Public Property MarkTemplate As DataTemplate

Remarks

The DataContext is a C1GaugeMarkInfo element.

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


ShowLabels Property

[image]

.NET Framework Class Library
C1GaugeMark..::.ShowLabels Property
C1GaugeMark Class See Also
Turn on/off the labels.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public bool ShowLabels { get; set; }
Visual Basic (Declaration)
Public Property ShowLabels As Boolean

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


ShowMarks Property

[image]

.NET Framework Class Library
C1GaugeMark..::.ShowMarks Property
C1GaugeMark Class See Also
Turn on/off the marks.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public bool ShowMarks { get; set; }
Visual Basic (Declaration)
Public Property ShowMarks As Boolean

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


To Property

[image]

.NET Framework Class Library
C1GaugeMark..::.To Property
C1GaugeMark Class See Also
End value for decorator to be applied.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double To { get; set; }
Visual Basic (Declaration)
Public Property To As Double

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMark Events

[image] [image]

.NET Framework Class Library
C1GaugeMark Events
C1GaugeMark Class See Also

The C1GaugeMark type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1GaugeMark Class
C1.Silverlight.Gauge Namespace


C1GaugeMarkInfo Class

[image]

.NET Framework Class Library
C1GaugeMarkInfo Class
Members See Also
Data element that is set to each instance of a C1GaugeMark as its DataContext.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1GaugeMarkInfo : C1GaugeDecoratorInfo
Visual Basic (Declaration)
Public Class C1GaugeMarkInfo _
    Inherits C1GaugeDecoratorInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Gauge..::.C1GaugeDecoratorInfo
C1.Silverlight.Gauge..::.C1GaugeMarkInfo

See Also

C1GaugeMarkInfo Members
C1.Silverlight.Gauge Namespace


C1GaugeMarkInfo Members

[image] [image]

.NET Framework Class Library
C1GaugeMarkInfo Members
C1GaugeMarkInfo Class Constructors Methods Properties See Also

The C1GaugeMarkInfo type exposes the following members.

Constructors

Name | Description
C1GaugeMarkInfo | Creates a new instance of C1GaugeMarkInfo

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Bridge to the Background property of the Decorator.
BorderBrush | Bridge to the BorderBrush property of the Decorator.
BorderThickness | Bridge to the BorderThickness property of the Decorator.
Decorator | Decorator reference. (Inherited from C1GaugeDecoratorInfo.)
FontFamily | Bridge to the FontFamily property of the Decorator.
FontSize | Bridge to the FontSize property of the Decorator.
FontStretch | Bridge to the FontStretch property of the Decorator.
FontWeight | Bridge to the FontWeight property of the Decorator.
Foreground | Bridge to the Foreground property of the Decorator.
Gauge | C1Gauge that owns this instance. (Inherited from C1GaugeDecoratorInfo.)
GaugeMark | C1GaugeMark that defines this instance.
Height | Bridge to the Height property of the Decorator.
HorizontalAlignment | Bridge to the HorizontalAlignment property of the Decorator.
HorizontalContentAlignment | Bridge to the HorizontalContentAlignment property of the Decorator.
Margin | Bridge to the Margin property of the Decorator
MaxHeight | Bridge to the MaxHeight property of the Decorator.
MaxWidth | Bridge to the MaxWidth property of the Decorator.
MinHeight | Bridge to the MinHeight property of the Decorator.
MinWidth | Bridge to the MinWidth property of the Decorator.
Value | Corresponding value for this mark instance.
VerticalAlignment | Bridge to the VerticalAlignment property of the Decorator.
Visibility | Bridge to the Visibility property of the Decorator. (Inherited from C1GaugeDecoratorInfo.)
Width | Bridge to the Width property of the Decorator.

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeMarkInfo Constructor

[image]

.NET Framework Class Library
C1GaugeMarkInfo Constructor
C1GaugeMarkInfo Class See Also
Creates a new instance of C1GaugeMarkInfo

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeMarkInfo(
    C1GaugeMark mark
)
Visual Basic (Declaration)
Public Sub New ( _
    mark As C1GaugeMark _
)

Parameters

mark
Type: C1.Silverlight.Gauge..::.C1GaugeMark
The corresponding C1GaugeMark

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeMarkInfo Methods

[image] [image]

.NET Framework Class Library
C1GaugeMarkInfo Methods
C1GaugeMarkInfo Class See Also

The C1GaugeMarkInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeMarkInfo Properties

[image] [image]

.NET Framework Class Library
C1GaugeMarkInfo Properties
C1GaugeMarkInfo Class See Also

The C1GaugeMarkInfo type exposes the following members.

Properties

Name | Description
Background | Bridge to the Background property of the Decorator.
BorderBrush | Bridge to the BorderBrush property of the Decorator.
BorderThickness | Bridge to the BorderThickness property of the Decorator.
Decorator | Decorator reference. (Inherited from C1GaugeDecoratorInfo.)
FontFamily | Bridge to the FontFamily property of the Decorator.
FontSize | Bridge to the FontSize property of the Decorator.
FontStretch | Bridge to the FontStretch property of the Decorator.
FontWeight | Bridge to the FontWeight property of the Decorator.
Foreground | Bridge to the Foreground property of the Decorator.
Gauge | C1Gauge that owns this instance. (Inherited from C1GaugeDecoratorInfo.)
GaugeMark | C1GaugeMark that defines this instance.
Height | Bridge to the Height property of the Decorator.
HorizontalAlignment | Bridge to the HorizontalAlignment property of the Decorator.
HorizontalContentAlignment | Bridge to the HorizontalContentAlignment property of the Decorator.
Margin | Bridge to the Margin property of the Decorator
MaxHeight | Bridge to the MaxHeight property of the Decorator.
MaxWidth | Bridge to the MaxWidth property of the Decorator.
MinHeight | Bridge to the MinHeight property of the Decorator.
MinWidth | Bridge to the MinWidth property of the Decorator.
Value | Corresponding value for this mark instance.
VerticalAlignment | Bridge to the VerticalAlignment property of the Decorator.
Visibility | Bridge to the Visibility property of the Decorator. (Inherited from C1GaugeDecoratorInfo.)
Width | Bridge to the Width property of the Decorator.

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Background Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Background Property
C1GaugeMarkInfo Class See Also
Bridge to the Background property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Brush Background { get; }
Visual Basic (Declaration)
Public ReadOnly Property Background As Brush

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


BorderBrush Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.BorderBrush Property
C1GaugeMarkInfo Class See Also
Bridge to the BorderBrush property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Brush BorderBrush { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderBrush As Brush

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


BorderThickness Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.BorderThickness Property
C1GaugeMarkInfo Class See Also
Bridge to the BorderThickness property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Thickness BorderThickness { get; }
Visual Basic (Declaration)
Public ReadOnly Property BorderThickness As Thickness

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


FontFamily Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.FontFamily Property
C1GaugeMarkInfo Class See Also
Bridge to the FontFamily property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FontFamily FontFamily { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontFamily As FontFamily

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


FontSize Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.FontSize Property
C1GaugeMarkInfo Class See Also
Bridge to the FontSize property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double FontSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontSize As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


FontStretch Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.FontStretch Property
C1GaugeMarkInfo Class See Also
Bridge to the FontStretch property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FontStretch FontStretch { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontStretch As FontStretch

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


FontWeight Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.FontWeight Property
C1GaugeMarkInfo Class See Also
Bridge to the FontWeight property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public FontWeight FontWeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property FontWeight As FontWeight

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Foreground Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Foreground Property
C1GaugeMarkInfo Class See Also
Bridge to the Foreground property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Brush Foreground { get; }
Visual Basic (Declaration)
Public ReadOnly Property Foreground As Brush

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


GaugeMark Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.GaugeMark Property
C1GaugeMarkInfo Class See Also
C1GaugeMark that defines this instance.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeMark GaugeMark { get; }
Visual Basic (Declaration)
Public ReadOnly Property GaugeMark As C1GaugeMark

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Height Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Height Property
C1GaugeMarkInfo Class See Also
Bridge to the Height property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Height { get; }
Visual Basic (Declaration)
Public ReadOnly Property Height As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


HorizontalAlignment Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.HorizontalAlignment Property
C1GaugeMarkInfo Class See Also
Bridge to the HorizontalAlignment property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public HorizontalAlignment HorizontalAlignment { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalAlignment As HorizontalAlignment

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


HorizontalContentAlignment Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.HorizontalContentAlignment Property
C1GaugeMarkInfo Class See Also
Bridge to the HorizontalContentAlignment property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public HorizontalAlignment HorizontalContentAlignment { get; }
Visual Basic (Declaration)
Public ReadOnly Property HorizontalContentAlignment As HorizontalAlignment

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Margin Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Margin Property
C1GaugeMarkInfo Class See Also
Bridge to the Margin property of the Decorator

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Thickness Margin { get; }
Visual Basic (Declaration)
Public ReadOnly Property Margin As Thickness

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


MaxHeight Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.MaxHeight Property
C1GaugeMarkInfo Class See Also
Bridge to the MaxHeight property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double MaxHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxHeight As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


MaxWidth Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.MaxWidth Property
C1GaugeMarkInfo Class See Also
Bridge to the MaxWidth property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double MaxWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxWidth As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


MinHeight Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.MinHeight Property
C1GaugeMarkInfo Class See Also
Bridge to the MinHeight property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double MinHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinHeight As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


MinWidth Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.MinWidth Property
C1GaugeMarkInfo Class See Also
Bridge to the MinWidth property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double MinWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinWidth As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Value Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Value Property
C1GaugeMarkInfo Class See Also
Corresponding value for this mark instance.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


VerticalAlignment Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.VerticalAlignment Property
C1GaugeMarkInfo Class See Also
Bridge to the VerticalAlignment property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public VerticalAlignment VerticalAlignment { get; }
Visual Basic (Declaration)
Public ReadOnly Property VerticalAlignment As VerticalAlignment

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


Width Property

[image]

.NET Framework Class Library
C1GaugeMarkInfo..::.Width Property
C1GaugeMarkInfo Class See Also
Bridge to the Width property of the Decorator.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Width { get; }
Visual Basic (Declaration)
Public ReadOnly Property Width As Double

See Also

C1GaugeMarkInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Class

[image]

.NET Framework Class Library
C1GaugeRange Class
Members See Also
C1GaugeDecorator used to define a range within the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1GaugeRange : C1GaugeDecorator
Visual Basic (Declaration)
Public Class C1GaugeRange _
    Inherits C1GaugeDecorator

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1GaugeDecorator
C1.Silverlight.Gauge..::.C1GaugeRange

See Also

C1GaugeRange Members
C1.Silverlight.Gauge Namespace


C1GaugeRange Members

[image] [image]

.NET Framework Class Library
C1GaugeRange Members
C1GaugeRange Class Constructors Methods Fields Properties Events See Also

The C1GaugeRange type exposes the following members.

Constructors

Name | Description
C1GaugeRange | Initializes a new instance of a C1GaugeRange.

Methods

Name | Description
AddElement | Adds an element to the decorators layer. (Inherited from C1GaugeDecorator.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator. (Inherited from C1GaugeDecorator.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | (Overrides C1GaugeDecorator..::.OnContextChanged(GaugeDrawingContext).)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an (Inherited from C1GaugeDecorator.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
FromProperty | Identifies the From dependency property.
LocationProperty | Identifies the Location dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ToProperty | Identifies the To dependency property.
ValueBindingProperty | Identifies the ValueBinding dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
From | Start value for decorator to be applied.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Location | Logical value representing the starting point of the range, where 0 represents the center, and 1 represents the axis location.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator (Inherited from C1GaugeDecorator.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
StrokeThickness | Sets/gets the thickness of the range.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
To | End value for decorator to be applied.
Triggers | (Inherited from FrameworkElement.)
ValueBinding | Binds the C1Gauge value to any of the end points of this range.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueEnter | Fired when the C1Gauge value enters to this range of values.
ValueLeave | Fired when the C1Gauge value leaves this range of values.

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Constructor

[image]

.NET Framework Class Library
C1GaugeRange Constructor
C1GaugeRange Class See Also
Initializes a new instance of a C1GaugeRange.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeRange()
Visual Basic (Declaration)
Public Sub New

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Fields

[image] [image]

.NET Framework Class Library
C1GaugeRange Fields
C1GaugeRange Class See Also

The C1GaugeRange type exposes the following members.

Fields

Name | Description
FromProperty | Identifies the From dependency property.
LocationProperty | Identifies the Location dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.
ToProperty | Identifies the To dependency property.
ValueBindingProperty | Identifies the ValueBinding dependency property.

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


FromProperty Field

[image]

.NET Framework Class Library
C1GaugeRange..::.FromProperty Field
C1GaugeRange Class See Also
Identifies the From dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty FromProperty
Visual Basic (Declaration)
Public Shared ReadOnly FromProperty As DependencyProperty

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


LocationProperty Field

[image]

.NET Framework Class Library
C1GaugeRange..::.LocationProperty Field
C1GaugeRange Class See Also
Identifies the Location dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty LocationProperty
Visual Basic (Declaration)
Public Shared ReadOnly LocationProperty As DependencyProperty

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


StrokeThicknessProperty Field

[image]

.NET Framework Class Library
C1GaugeRange..::.StrokeThicknessProperty Field
C1GaugeRange Class See Also
Identifies the StrokeThickness dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty StrokeThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


ToProperty Field

[image]

.NET Framework Class Library
C1GaugeRange..::.ToProperty Field
C1GaugeRange Class See Also
Identifies the To dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ToProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToProperty As DependencyProperty

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


ValueBindingProperty Field

[image]

.NET Framework Class Library
C1GaugeRange..::.ValueBindingProperty Field
C1GaugeRange Class See Also
Identifies the ValueBinding dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty ValueBindingProperty
Visual Basic (Declaration)
Public Shared ReadOnly ValueBindingProperty As DependencyProperty

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Methods

[image] [image]

.NET Framework Class Library
C1GaugeRange Methods
C1GaugeRange Class See Also

The C1GaugeRange type exposes the following members.

Methods

Name | Description
AddElement | Adds an element to the decorators layer. (Inherited from C1GaugeDecorator.)
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearElements | Clear all the elements added in the decorators layer for this decorator. (Inherited from C1GaugeDecorator.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnContextChanged | (Overrides C1GaugeDecorator..::.OnContextChanged(GaugeDrawingContext).)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveElement | Remove an (Inherited from C1GaugeDecorator.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1GaugeRange..::.HitTest Method
C1GaugeRange Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1GaugeRange Class
C1GaugeRange Members
C1.Silverlight.Gauge Namespace


OnContextChanged Method

[image]

.NET Framework Class Library
C1GaugeRange..::.OnContextChanged Method
C1GaugeRange Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override void OnContextChanged(
    GaugeDrawingContext oldValue
)
Visual Basic (Declaration)
Protected Overrides Sub OnContextChanged ( _
    oldValue As GaugeDrawingContext _
)

Parameters

oldValue
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Properties

[image] [image]

.NET Framework Class Library
C1GaugeRange Properties
C1GaugeRange Class See Also

The C1GaugeRange type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
From | Start value for decorator to be applied.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Location | Logical value representing the starting point of the range, where 0 represents the center, and 1 represents the axis location.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MyElements | Returns all the framework element added by this decorator (Inherited from C1GaugeDecorator.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
StrokeThickness | Sets/gets the thickness of the range.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
To | End value for decorator to be applied.
Triggers | (Inherited from FrameworkElement.)
ValueBinding | Binds the C1Gauge value to any of the end points of this range.
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


From Property

[image]

.NET Framework Class Library
C1GaugeRange..::.From Property
C1GaugeRange Class See Also
Start value for decorator to be applied.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double From { get; set; }
Visual Basic (Declaration)
Public Property From As Double

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


Location Property

[image]

.NET Framework Class Library
C1GaugeRange..::.Location Property
C1GaugeRange Class See Also
Logical value representing the starting point of the range, where 0 represents the center, and 1 represents the axis location.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Location { get; set; }
Visual Basic (Declaration)
Public Property Location As Double

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


StrokeThickness Property

[image]

.NET Framework Class Library
C1GaugeRange..::.StrokeThickness Property
C1GaugeRange Class See Also
Sets/gets the thickness of the range.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Double

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


To Property

[image]

.NET Framework Class Library
C1GaugeRange..::.To Property
C1GaugeRange Class See Also
End value for decorator to be applied.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double To { get; set; }
Visual Basic (Declaration)
Public Property To As Double

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


ValueBinding Property

[image]

.NET Framework Class Library
C1GaugeRange..::.ValueBinding Property
C1GaugeRange Class See Also
Binds the C1Gauge value to any of the end points of this range.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public RangeValueBinding ValueBinding { get; set; }
Visual Basic (Declaration)
Public Property ValueBinding As RangeValueBinding

Remarks

Used to simulate fill/unfill effects.

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRange Events

[image] [image]

.NET Framework Class Library
C1GaugeRange Events
C1GaugeRange Class See Also

The C1GaugeRange type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueEnter | Fired when the C1Gauge value enters to this range of values.
ValueLeave | Fired when the C1Gauge value leaves this range of values.

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


ValueEnter Event

[image]

.NET Framework Class Library
C1GaugeRange..::.ValueEnter Event
C1GaugeRange Class See Also
Fired when the C1Gauge value enters to this range of values.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public event EventHandler ValueEnter
Visual Basic (Declaration)
Public Event ValueEnter As EventHandler

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


ValueLeave Event

[image]

.NET Framework Class Library
C1GaugeRange..::.ValueLeave Event
C1GaugeRange Class See Also
Fired when the C1Gauge value leaves this range of values.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public event EventHandler ValueLeave
Visual Basic (Declaration)
Public Event ValueLeave As EventHandler

See Also

C1GaugeRange Class
C1.Silverlight.Gauge Namespace


C1GaugeRangeInfo Class

[image]

.NET Framework Class Library
C1GaugeRangeInfo Class
Members See Also
Data element that is set to each instance of a C1GaugeMark as its DataContext.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1GaugeRangeInfo : C1GaugeDecoratorInfo
Visual Basic (Declaration)
Public Class C1GaugeRangeInfo _
    Inherits C1GaugeDecoratorInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Gauge..::.C1GaugeDecoratorInfo
C1.Silverlight.Gauge..::.C1GaugeRangeInfo

See Also

C1GaugeRangeInfo Members
C1.Silverlight.Gauge Namespace


C1GaugeRangeInfo Members

[image] [image]

.NET Framework Class Library
C1GaugeRangeInfo Members
C1GaugeRangeInfo Class Constructors Methods Properties See Also

The C1GaugeRangeInfo type exposes the following members.

Constructors

Name | Description
C1GaugeRangeInfo | Creates a new instance of C1GaugeMarkInfo

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Decorator | Decorator reference. (Inherited from C1GaugeDecoratorInfo.)
Gauge | C1Gauge that owns this instance. (Inherited from C1GaugeDecoratorInfo.)
GaugeRange | C1GaugeRange that defines this instance.
Value | Corresponding value for this mark instance.
Visibility | Bridge to the Visibility property of the Decorator. (Inherited from C1GaugeDecoratorInfo.)

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeRangeInfo Constructor

[image]

.NET Framework Class Library
C1GaugeRangeInfo Constructor
C1GaugeRangeInfo Class See Also
Creates a new instance of C1GaugeMarkInfo

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeRangeInfo(
    C1GaugeRange range
)
Visual Basic (Declaration)
Public Sub New ( _
    range As C1GaugeRange _
)

Parameters

range
Type: C1.Silverlight.Gauge..::.C1GaugeRange
The corresponding C1GaugeMark

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeRangeInfo Methods

[image] [image]

.NET Framework Class Library
C1GaugeRangeInfo Methods
C1GaugeRangeInfo Class See Also

The C1GaugeRangeInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


C1GaugeRangeInfo Properties

[image] [image]

.NET Framework Class Library
C1GaugeRangeInfo Properties
C1GaugeRangeInfo Class See Also

The C1GaugeRangeInfo type exposes the following members.

Properties

Name | Description
Decorator | Decorator reference. (Inherited from C1GaugeDecoratorInfo.)
Gauge | C1Gauge that owns this instance. (Inherited from C1GaugeDecoratorInfo.)
GaugeRange | C1GaugeRange that defines this instance.
Value | Corresponding value for this mark instance.
Visibility | Bridge to the Visibility property of the Decorator. (Inherited from C1GaugeDecoratorInfo.)

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


GaugeRange Property

[image]

.NET Framework Class Library
C1GaugeRangeInfo..::.GaugeRange Property
C1GaugeRangeInfo Class See Also
C1GaugeRange that defines this instance.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1GaugeRange GaugeRange { get; }
Visual Basic (Declaration)
Public ReadOnly Property GaugeRange As C1GaugeRange

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


Value Property

[image]

.NET Framework Class Library
C1GaugeRangeInfo..::.Value Property
C1GaugeRangeInfo Class See Also
Corresponding value for this mark instance.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Double

See Also

C1GaugeRangeInfo Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Class

[image]

.NET Framework Class Library
C1LinearGauge Class
Members See Also
C1Gauge shown in a linear axis.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1LinearGauge : C1Gauge
Visual Basic (Declaration)
Public Class C1LinearGauge _
    Inherits C1Gauge

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1Gauge
C1.Silverlight.Gauge..::.C1LinearGauge

See Also

C1LinearGauge Members
C1.Silverlight.Gauge Namespace


C1LinearGauge Members

[image] [image]

.NET Framework Class Library
C1LinearGauge Members
C1LinearGauge Class Constructors Methods Fields Properties Events See Also

The C1LinearGauge type exposes the following members.

Constructors

Name | Description
C1LinearGauge | Initializes a new instance of a C1LinearGauge.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from C1Gauge.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1Gauge.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | (Overrides C1Gauge..::.GetDefaultPointerAnimation(GaugeDrawingContext).)
GetGeometry | (Overrides C1Gauge..::.GetGeometry(Double, Double, Double).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetTransform | (Overrides C1Gauge..::.GetTransform(Double, Double, Boolean).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from C1Gauge.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | (Overrides C1Gauge..::.OffsetToThickness(Double, C1GaugeAxis).)
OnApplyTemplate | (Inherited from C1Gauge.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | (Overrides C1Gauge..::.OnCreateDefaultDecorators()()().)
OnLayoutChanged | Fires the LayoutChanged event. (Inherited from C1Gauge.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.
XAxisLengthProperty | Identifies the XAxisLength dependency property.
XAxisLocationProperty | Identifies the XAxisLocation dependency property.
YAxisLocationProperty | Identifies the YAxisLocation dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context | (Inherited from C1Gauge.)
Cover | FrameworkElement in the top layer (over everything). (Inherited from C1Gauge.)
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property. (Inherited from C1Gauge.)
CoverVisibility | Show/hide the C1Gauge top layer. (Inherited from C1Gauge.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark. (Inherited from C1Gauge.)
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators. (Inherited from C1Gauge.)
DefaultLabelTemplate | Default DataTemplate for the Labels. (Inherited from C1Gauge.)
DefaultMarkTemplate | Default DataTemplate for the Marks. (Inherited from C1Gauge.)
DefaultSize | (Overrides C1Gauge..::.DefaultSize.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators). (Inherited from C1Gauge.)
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property. (Inherited from C1Gauge.)
FaceVisibility | Show/hide the C1Gauge bottom layer. (Inherited from C1Gauge.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1Gauge.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge. (Inherited from C1Gauge.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge. (Inherited from C1Gauge.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Orientation of the C1LinearGauge.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage. (Inherited from C1Gauge.)
Pointer | FrameworkElement representing the Pointer. (Inherited from C1Gauge.)
PointerAnimation | When defined, replace the default pointer animation by this one. (Inherited from C1Gauge.)
PointerCap | FrameworkElement representing the PointerCap. (Inherited from C1Gauge.)
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property. (Inherited from C1Gauge.)
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property. (Inherited from C1Gauge.)
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap. (Inherited from C1Gauge.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge. (Inherited from C1Gauge.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge. (Inherited from C1Gauge.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
XAxisLength | Logical length of the x-axis.
XAxisLocation | Logical start of the x-axis.
YAxisLocation | Logical offset of the C1LinearGauge.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1Gauge.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed. (Inherited from C1Gauge.)

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Constructor

[image]

.NET Framework Class Library
C1LinearGauge Constructor
C1LinearGauge Class See Also
Initializes a new instance of a C1LinearGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1LinearGauge()
Visual Basic (Declaration)
Public Sub New

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Fields

[image] [image]

.NET Framework Class Library
C1LinearGauge Fields
C1LinearGauge Class See Also

The C1LinearGauge type exposes the following members.

Fields

Name | Description
OrientationProperty | Identifies the Orientation dependency property.
XAxisLengthProperty | Identifies the XAxisLength dependency property.
XAxisLocationProperty | Identifies the XAxisLocation dependency property.
YAxisLocationProperty | Identifies the YAxisLocation dependency property.

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


OrientationProperty Field

[image]

.NET Framework Class Library
C1LinearGauge..::.OrientationProperty Field
C1LinearGauge Class See Also
Identifies the Orientation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty OrientationProperty
Visual Basic (Declaration)
Public Shared ReadOnly OrientationProperty As DependencyProperty

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


XAxisLengthProperty Field

[image]

.NET Framework Class Library
C1LinearGauge..::.XAxisLengthProperty Field
C1LinearGauge Class See Also
Identifies the XAxisLength dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty XAxisLengthProperty
Visual Basic (Declaration)
Public Shared ReadOnly XAxisLengthProperty As DependencyProperty

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


XAxisLocationProperty Field

[image]

.NET Framework Class Library
C1LinearGauge..::.XAxisLocationProperty Field
C1LinearGauge Class See Also
Identifies the XAxisLocation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty XAxisLocationProperty
Visual Basic (Declaration)
Public Shared ReadOnly XAxisLocationProperty As DependencyProperty

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


YAxisLocationProperty Field

[image]

.NET Framework Class Library
C1LinearGauge..::.YAxisLocationProperty Field
C1LinearGauge Class See Also
Identifies the YAxisLocation dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty YAxisLocationProperty
Visual Basic (Declaration)
Public Shared ReadOnly YAxisLocationProperty As DependencyProperty

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Methods

[image] [image]

.NET Framework Class Library
C1LinearGauge Methods
C1LinearGauge Class See Also

The C1LinearGauge type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from C1Gauge.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1Gauge.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | (Overrides C1Gauge..::.GetDefaultPointerAnimation(GaugeDrawingContext).)
GetGeometry | (Overrides C1Gauge..::.GetGeometry(Double, Double, Double).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetTransform | (Overrides C1Gauge..::.GetTransform(Double, Double, Boolean).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from C1Gauge.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | (Overrides C1Gauge..::.OffsetToThickness(Double, C1GaugeAxis).)
OnApplyTemplate | (Inherited from C1Gauge.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | (Overrides C1Gauge..::.OnCreateDefaultDecorators()()().)
OnLayoutChanged | Fires the LayoutChanged event. (Inherited from C1Gauge.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


GetDefaultPointerAnimation Method

[image]

.NET Framework Class Library
C1LinearGauge..::.GetDefaultPointerAnimation Method
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Storyboard GetDefaultPointerAnimation(
    GaugeDrawingContext context
)
Visual Basic (Declaration)
Protected Overrides Function GetDefaultPointerAnimation ( _
    context As GaugeDrawingContext _
) As Storyboard

Parameters

context
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


GetGeometry Method

[image]

.NET Framework Class Library
C1LinearGauge..::.GetGeometry Method
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Geometry GetGeometry(
    double startValue,
    double endValue,
    double yAxisLocation
)
Visual Basic (Declaration)
Public Overrides Function GetGeometry ( _
    startValue As Double, _
    endValue As Double, _
    yAxisLocation As Double _
) As Geometry

Parameters

startValue
Type: System..::.Double
endValue
Type: System..::.Double
yAxisLocation
Type: System..::.Double

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


GetTransform Method

[image]

.NET Framework Class Library
C1LinearGauge..::.GetTransform Method
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Transform GetTransform(
    double value,
    double yAxisLocation,
    bool rotate
)
Visual Basic (Declaration)
Public Overrides Function GetTransform ( _
    value As Double, _
    yAxisLocation As Double, _
    rotate As Boolean _
) As Transform

Parameters

value
Type: System..::.Double
yAxisLocation
Type: System..::.Double
rotate
Type: System..::.Boolean

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1LinearGauge..::.HitTest Method
C1LinearGauge Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1LinearGauge Class
C1LinearGauge Members
C1.Silverlight.Gauge Namespace


OffsetToThickness Method

[image]

.NET Framework Class Library
C1LinearGauge..::.OffsetToThickness Method
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override double OffsetToThickness(
    double offset,
    C1GaugeAxis axis
)
Visual Basic (Declaration)
Public Overrides Function OffsetToThickness ( _
    offset As Double, _
    axis As C1GaugeAxis _
) As Double

Parameters

offset
Type: System..::.Double
axis
Type: C1.Silverlight.Gauge..::.C1GaugeAxis

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


OnCreateDefaultDecorators Method

[image]

.NET Framework Class Library
C1LinearGauge..::.OnCreateDefaultDecorators Method
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override void OnCreateDefaultDecorators()
Visual Basic (Declaration)
Protected Overrides Sub OnCreateDefaultDecorators

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Properties

[image] [image]

.NET Framework Class Library
C1LinearGauge Properties
C1LinearGauge Class See Also

The C1LinearGauge type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context | (Inherited from C1Gauge.)
Cover | FrameworkElement in the top layer (over everything). (Inherited from C1Gauge.)
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property. (Inherited from C1Gauge.)
CoverVisibility | Show/hide the C1Gauge top layer. (Inherited from C1Gauge.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark. (Inherited from C1Gauge.)
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators. (Inherited from C1Gauge.)
DefaultLabelTemplate | Default DataTemplate for the Labels. (Inherited from C1Gauge.)
DefaultMarkTemplate | Default DataTemplate for the Marks. (Inherited from C1Gauge.)
DefaultSize | (Overrides C1Gauge..::.DefaultSize.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators). (Inherited from C1Gauge.)
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property. (Inherited from C1Gauge.)
FaceVisibility | Show/hide the C1Gauge bottom layer. (Inherited from C1Gauge.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1Gauge.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge. (Inherited from C1Gauge.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge. (Inherited from C1Gauge.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Orientation | Orientation of the C1LinearGauge.
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage. (Inherited from C1Gauge.)
Pointer | FrameworkElement representing the Pointer. (Inherited from C1Gauge.)
PointerAnimation | When defined, replace the default pointer animation by this one. (Inherited from C1Gauge.)
PointerCap | FrameworkElement representing the PointerCap. (Inherited from C1Gauge.)
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property. (Inherited from C1Gauge.)
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property. (Inherited from C1Gauge.)
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap. (Inherited from C1Gauge.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge. (Inherited from C1Gauge.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge. (Inherited from C1Gauge.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
XAxisLength | Logical length of the x-axis.
XAxisLocation | Logical start of the x-axis.
YAxisLocation | Logical offset of the C1LinearGauge.

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


DefaultSize Property

[image]

.NET Framework Class Library
C1LinearGauge..::.DefaultSize Property
C1LinearGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Size DefaultSize { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultSize As Size

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


Orientation Property

[image]

.NET Framework Class Library
C1LinearGauge..::.Orientation Property
C1LinearGauge Class See Also
Orientation of the C1LinearGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Orientation Orientation { get; set; }
Visual Basic (Declaration)
Public Property Orientation As Orientation

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


XAxisLength Property

[image]

.NET Framework Class Library
C1LinearGauge..::.XAxisLength Property
C1LinearGauge Class See Also
Logical length of the x-axis.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double XAxisLength { get; set; }
Visual Basic (Declaration)
Public Property XAxisLength As Double

Remarks

0 represents 0, and 1 represents the length of the C1LinearGauge.

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


XAxisLocation Property

[image]

.NET Framework Class Library
C1LinearGauge..::.XAxisLocation Property
C1LinearGauge Class See Also
Logical start of the x-axis.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double XAxisLocation { get; set; }
Visual Basic (Declaration)
Public Property XAxisLocation As Double

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


YAxisLocation Property

[image]

.NET Framework Class Library
C1LinearGauge..::.YAxisLocation Property
C1LinearGauge Class See Also
Logical offset of the C1LinearGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double YAxisLocation { get; set; }
Visual Basic (Declaration)
Public Property YAxisLocation As Double

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1LinearGauge Events

[image] [image]

.NET Framework Class Library
C1LinearGauge Events
C1LinearGauge Class See Also

The C1LinearGauge type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1Gauge.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed. (Inherited from C1Gauge.)

See Also

C1LinearGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Class

[image]

.NET Framework Class Library
C1RadialGauge Class
Members See Also
C1Gauge shown in a circular or radial axis.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class C1RadialGauge : C1Gauge
Visual Basic (Declaration)
Public Class C1RadialGauge _
    Inherits C1Gauge

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge..::.C1Gauge
C1.Silverlight.Gauge..::.C1RadialGauge

See Also

C1RadialGauge Members
C1.Silverlight.Gauge Namespace


C1RadialGauge Members

[image] [image]

.NET Framework Class Library
C1RadialGauge Members
C1RadialGauge Class Constructors Methods Fields Properties Events See Also

The C1RadialGauge type exposes the following members.

Constructors

Name | Description
C1RadialGauge | Initializes a new instance of a C1RadialGauge.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides C1Gauge..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1Gauge.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | (Overrides C1Gauge..::.GetDefaultPointerAnimation(GaugeDrawingContext).)
GetGeometry | (Overrides C1Gauge..::.GetGeometry(Double, Double, Double).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetTransform | (Overrides C1Gauge..::.GetTransform(Double, Double, Boolean).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides C1Gauge..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | (Overrides C1Gauge..::.OffsetToThickness(Double, C1GaugeAxis).)
OnApplyTemplate | (Inherited from C1Gauge.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | (Overrides C1Gauge..::.OnCreateDefaultDecorators()()().)
OnLayoutChanged | Fires the LayoutChanged event. (Inherited from C1Gauge.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
PointerOriginProperty | Identifies the PointerOrigin dependency property.
RadiusProperty | Identifies the Radius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
SweepAngleProperty | Identifies the SweepAngle dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context | (Inherited from C1Gauge.)
Cover | FrameworkElement in the top layer (over everything). (Inherited from C1Gauge.)
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property. (Inherited from C1Gauge.)
CoverVisibility | Show/hide the C1Gauge top layer. (Inherited from C1Gauge.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark. (Inherited from C1Gauge.)
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators. (Inherited from C1Gauge.)
DefaultLabelTemplate | Default DataTemplate for the Labels. (Inherited from C1Gauge.)
DefaultMarkTemplate | Default DataTemplate for the Marks. (Inherited from C1Gauge.)
DefaultSize | (Overrides C1Gauge..::.DefaultSize.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators). (Inherited from C1Gauge.)
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property. (Inherited from C1Gauge.)
FaceVisibility | Show/hide the C1Gauge bottom layer. (Inherited from C1Gauge.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1Gauge.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge. (Inherited from C1Gauge.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge. (Inherited from C1Gauge.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage. (Inherited from C1Gauge.)
Pointer | FrameworkElement representing the Pointer. (Inherited from C1Gauge.)
PointerAnimation | When defined, replace the default pointer animation by this one. (Inherited from C1Gauge.)
PointerCap | FrameworkElement representing the PointerCap. (Inherited from C1Gauge.)
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property. (Inherited from C1Gauge.)
PointerOrigin | Logical coordinates of the pointer origin of the C1RadialGauge.
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property. (Inherited from C1Gauge.)
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap. (Inherited from C1Gauge.)
Radius | Logical radius of the C1RadialGauge.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge. (Inherited from C1Gauge.)
StartAngle | Start angle for the C1RadialGauge axis. 0 is the topmost point of the circumference.
Style | (Inherited from FrameworkElement.)
SweepAngle | Sweep angle for the C1RadialGauge values. The Maximum value will be placed at StartAngle + SweepAngle.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge. (Inherited from C1Gauge.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1Gauge.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed. (Inherited from C1Gauge.)

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Constructor

[image]

.NET Framework Class Library
C1RadialGauge Constructor
C1RadialGauge Class See Also
Initializes a new instance of a C1RadialGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1RadialGauge()
Visual Basic (Declaration)
Public Sub New

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Fields

[image] [image]

.NET Framework Class Library
C1RadialGauge Fields
C1RadialGauge Class See Also

The C1RadialGauge type exposes the following members.

Fields

Name | Description
PointerOriginProperty | Identifies the PointerOrigin dependency property.
RadiusProperty | Identifies the Radius dependency property.
StartAngleProperty | Identifies the StartAngle dependency property.
SweepAngleProperty | Identifies the SweepAngle dependency property.

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


PointerOriginProperty Field

[image]

.NET Framework Class Library
C1RadialGauge..::.PointerOriginProperty Field
C1RadialGauge Class See Also
Identifies the PointerOrigin dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty PointerOriginProperty
Visual Basic (Declaration)
Public Shared ReadOnly PointerOriginProperty As DependencyProperty

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


RadiusProperty Field

[image]

.NET Framework Class Library
C1RadialGauge..::.RadiusProperty Field
C1RadialGauge Class See Also
Identifies the Radius dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty RadiusProperty
Visual Basic (Declaration)
Public Shared ReadOnly RadiusProperty As DependencyProperty

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


StartAngleProperty Field

[image]

.NET Framework Class Library
C1RadialGauge..::.StartAngleProperty Field
C1RadialGauge Class See Also
Identifies the StartAngle dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty StartAngleProperty
Visual Basic (Declaration)
Public Shared ReadOnly StartAngleProperty As DependencyProperty

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


SweepAngleProperty Field

[image]

.NET Framework Class Library
C1RadialGauge..::.SweepAngleProperty Field
C1RadialGauge Class See Also
Identifies the SweepAngle dependency property.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty SweepAngleProperty
Visual Basic (Declaration)
Public Shared ReadOnly SweepAngleProperty As DependencyProperty

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Methods

[image] [image]

.NET Framework Class Library
C1RadialGauge Methods
C1RadialGauge Class See Also

The C1RadialGauge type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides C1Gauge..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon | (Inherited from C1Gauge.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetDefaultPointerAnimation | (Overrides C1Gauge..::.GetDefaultPointerAnimation(GaugeDrawingContext).)
GetGeometry | (Overrides C1Gauge..::.GetGeometry(Double, Double, Double).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetTransform | (Overrides C1Gauge..::.GetTransform(Double, Double, Boolean).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides C1Gauge..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OffsetToThickness | (Overrides C1Gauge..::.OffsetToThickness(Double, C1GaugeAxis).)
OnApplyTemplate | (Inherited from C1Gauge.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnCreateDefaultDecorators | (Overrides C1Gauge..::.OnCreateDefaultDecorators()()().)
OnLayoutChanged | Fires the LayoutChanged event. (Inherited from C1Gauge.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1RadialGauge..::.ArrangeOverride Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


GetDefaultPointerAnimation Method

[image]

.NET Framework Class Library
C1RadialGauge..::.GetDefaultPointerAnimation Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Storyboard GetDefaultPointerAnimation(
    GaugeDrawingContext context
)
Visual Basic (Declaration)
Protected Overrides Function GetDefaultPointerAnimation ( _
    context As GaugeDrawingContext _
) As Storyboard

Parameters

context
Type: C1.Silverlight.Gauge..::.GaugeDrawingContext

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


GetGeometry Method

[image]

.NET Framework Class Library
C1RadialGauge..::.GetGeometry Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Geometry GetGeometry(
    double startValue,
    double endValue,
    double yAxisLocation
)
Visual Basic (Declaration)
Public Overrides Function GetGeometry ( _
    startValue As Double, _
    endValue As Double, _
    yAxisLocation As Double _
) As Geometry

Parameters

startValue
Type: System..::.Double
endValue
Type: System..::.Double
yAxisLocation
Type: System..::.Double

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


GetTransform Method

[image]

.NET Framework Class Library
C1RadialGauge..::.GetTransform Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Transform GetTransform(
    double value,
    double yAxisLocation,
    bool rotate
)
Visual Basic (Declaration)
Public Overrides Function GetTransform ( _
    value As Double, _
    yAxisLocation As Double, _
    rotate As Boolean _
) As Transform

Parameters

value
Type: System..::.Double
yAxisLocation
Type: System..::.Double
rotate
Type: System..::.Boolean

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1RadialGauge..::.HitTest Method
C1RadialGauge Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1RadialGauge Class
C1RadialGauge Members
C1.Silverlight.Gauge Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1RadialGauge..::.MeasureOverride Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


OffsetToThickness Method

[image]

.NET Framework Class Library
C1RadialGauge..::.OffsetToThickness Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override double OffsetToThickness(
    double offset,
    C1GaugeAxis axis
)
Visual Basic (Declaration)
Public Overrides Function OffsetToThickness ( _
    offset As Double, _
    axis As C1GaugeAxis _
) As Double

Parameters

offset
Type: System..::.Double
axis
Type: C1.Silverlight.Gauge..::.C1GaugeAxis

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


OnCreateDefaultDecorators Method

[image]

.NET Framework Class Library
C1RadialGauge..::.OnCreateDefaultDecorators Method
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
protected override void OnCreateDefaultDecorators()
Visual Basic (Declaration)
Protected Overrides Sub OnCreateDefaultDecorators

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Properties

[image] [image]

.NET Framework Class Library
C1RadialGauge Properties
C1RadialGauge Class See Also

The C1RadialGauge type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Context | (Inherited from C1Gauge.)
Cover | FrameworkElement in the top layer (over everything). (Inherited from C1Gauge.)
CoverTemplate | DataTemplate used to generate the element placed on top of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Top property. (Inherited from C1Gauge.)
CoverVisibility | Show/hide the C1Gauge top layer. (Inherited from C1Gauge.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
Decorators | Collection of decorator elements that will be added to the C1Gauge inside the decorators layer. These elements can be any C1GaugeDecorator, for example C1GaugeRange or C1GaugeMark. (Inherited from C1Gauge.)
DecoratorsVisibility | Show/hide the C1Gauge decorators layer, containing all the marks, ranges and custom decorators. (Inherited from C1Gauge.)
DefaultLabelTemplate | Default DataTemplate for the Labels. (Inherited from C1Gauge.)
DefaultMarkTemplate | Default DataTemplate for the Marks. (Inherited from C1Gauge.)
DefaultSize | (Overrides C1Gauge..::.DefaultSize.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Face | FrameworkElement in the bottom layer (between the background and the decorators). (Inherited from C1Gauge.)
FaceTemplate | DataTemplate used to generate the element placed over the C1Gauge background. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Bottom property. (Inherited from C1Gauge.)
FaceVisibility | Show/hide the C1Gauge bottom layer. (Inherited from C1Gauge.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control. (Inherited from C1Gauge.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
Maximum | Maximum value for the C1Gauge. (Inherited from C1Gauge.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
Minimum | Minimum value for the C1Gauge. (Inherited from C1Gauge.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Percentage | Gets or sets the current Value expressed as a percentage. (Inherited from C1Gauge.)
Pointer | FrameworkElement representing the Pointer. (Inherited from C1Gauge.)
PointerAnimation | When defined, replace the default pointer animation by this one. (Inherited from C1Gauge.)
PointerCap | FrameworkElement representing the PointerCap. (Inherited from C1Gauge.)
PointerCapTemplate | DataTemplate used to generate the PointerCap element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the PointerCap property. (Inherited from C1Gauge.)
PointerOrigin | Logical coordinates of the pointer origin of the C1RadialGauge.
PointerTemplate | DataTemplate used to generate the Pointer element of the C1Gauge. After the DataTemplate is loaded, the FrameworkElement can be accessed through the Pointer property. (Inherited from C1Gauge.)
PointerVisibility | Show/hide the C1Gauge pointer layer, containing the Pointer and the PointerCap. (Inherited from C1Gauge.)
Radius | Logical radius of the C1RadialGauge.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowDefaultDecorators | Create default decorators for an empty gauge. (Inherited from C1Gauge.)
StartAngle | Start angle for the C1RadialGauge axis. 0 is the topmost point of the circumference.
Style | (Inherited from FrameworkElement.)
SweepAngle | Sweep angle for the C1RadialGauge values. The Maximum value will be placed at StartAngle + SweepAngle.
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Value | Current value of the gauge. (Inherited from C1Gauge.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


DefaultSize Property

[image]

.NET Framework Class Library
C1RadialGauge..::.DefaultSize Property
C1RadialGauge Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override Size DefaultSize { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property DefaultSize As Size

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


PointerOrigin Property

[image]

.NET Framework Class Library
C1RadialGauge..::.PointerOrigin Property
C1RadialGauge Class See Also
Logical coordinates of the pointer origin of the C1RadialGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Point PointerOrigin { get; set; }
Visual Basic (Declaration)
Public Property PointerOrigin As Point

Remarks

The Point (0, 0) is the top-left corner of the control and the Point (0.5, 0.5) is the center of the control.

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


Radius Property

[image]

.NET Framework Class Library
C1RadialGauge..::.Radius Property
C1RadialGauge Class See Also
Logical radius of the C1RadialGauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double Radius { get; set; }
Visual Basic (Declaration)
Public Property Radius As Double

Remarks

1 represents half of the Min (Width, Height) of the control and 0 represents 0.

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


StartAngle Property

[image]

.NET Framework Class Library
C1RadialGauge..::.StartAngle Property
C1RadialGauge Class See Also
Start angle for the C1RadialGauge axis. 0 is the topmost point of the circumference.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double StartAngle { get; set; }
Visual Basic (Declaration)
Public Property StartAngle As Double

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


SweepAngle Property

[image]

.NET Framework Class Library
C1RadialGauge..::.SweepAngle Property
C1RadialGauge Class See Also
Sweep angle for the C1RadialGauge values. The Maximum value will be placed at StartAngle + SweepAngle.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public double SweepAngle { get; set; }
Visual Basic (Declaration)
Public Property SweepAngle As Double

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


C1RadialGauge Events

[image] [image]

.NET Framework Class Library
C1RadialGauge Events
C1RadialGauge Class See Also

The C1RadialGauge type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed. (Inherited from C1Gauge.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ValueChanged | Event raised when the Value property has changed. (Inherited from C1Gauge.)

See Also

C1RadialGauge Class
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Class

[image]

.NET Framework Class Library
GaugeDrawingContext Class
Members See Also
Context of the C1Gauge when it's being drawn.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class GaugeDrawingContext
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
Public Class GaugeDrawingContext

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Gauge..::.GaugeDrawingContext

See Also

GaugeDrawingContext Members
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Members

[image] [image]

.NET Framework Class Library
GaugeDrawingContext Members
GaugeDrawingContext Class Constructors Methods Properties Events See Also

The GaugeDrawingContext type exposes the following members.

Constructors

Name | Description
GaugeDrawingContext |

Methods

Name | Description
AddCustomData<(Of <(T>)>) | Add a custom data value to the context
ContainsCustomData | Returns true if the key is already defined in the custom data storage in the context.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomData<(Of <(T>)>) | Retrieves custom data from the context
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLayoutChanged | Fires the LayoutChanged event that is listened for the decorators to redraw themselves.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
ActualSize | Gets the real Gauge size.
DesignSize | Get the design time size of the Gauge.
Gauge | Reference to the C1Gauge.
ResizingTransform | Transformation used to scale the elements in the inner layers.

Events

Name | Description
LayoutChanged | Fired when properties provoking layout-change has changed

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Constructor

[image]

.NET Framework Class Library
GaugeDrawingContext Constructor
GaugeDrawingContext Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public GaugeDrawingContext()
Visual Basic (Declaration)
Public Sub New

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Methods

[image] [image]

.NET Framework Class Library
GaugeDrawingContext Methods
GaugeDrawingContext Class See Also

The GaugeDrawingContext type exposes the following members.

Methods

Name | Description
AddCustomData<(Of <(T>)>) | Add a custom data value to the context
ContainsCustomData | Returns true if the key is already defined in the custom data storage in the context.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCustomData<(Of <(T>)>) | Retrieves custom data from the context
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnLayoutChanged | Fires the LayoutChanged event that is listened for the decorators to redraw themselves.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


AddCustomData(T) Method

[image]

.NET Framework Class Library
GaugeDrawingContext..::.AddCustomData<(Of <(T>)>) Method
GaugeDrawingContext Class See Also
Add a custom data value to the context

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public void AddCustomData<T>(
    string key,
    T data
)
Visual Basic (Declaration)
Public Sub AddCustomData(Of T) ( _
    key As String, _
    data As T _
)

Parameters

key
Type: System..::.String
Key for that data
data
Type: T
Object to be saved in the shared storage

Type Parameters

T
Type of the data to be added

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


ContainsCustomData Method

[image]

.NET Framework Class Library
GaugeDrawingContext..::.ContainsCustomData Method
GaugeDrawingContext Class See Also
Returns true if the key is already defined in the custom data storage in the context.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public bool ContainsCustomData(
    string key
)
Visual Basic (Declaration)
Public Function ContainsCustomData ( _
    key As String _
) As Boolean

Parameters

key
Type: System..::.String
Key for that data.

Return Value

true if it's already contained.

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GetCustomData(T) Method

[image]

.NET Framework Class Library
GaugeDrawingContext..::.GetCustomData<(Of <(T>)>) Method
GaugeDrawingContext Class See Also
Retrieves custom data from the context

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public T GetCustomData<T>(
    string key
)
Visual Basic (Declaration)
Public Function GetCustomData(Of T) ( _
    key As String _
) As T

Parameters

key
Type: System..::.String
Key for that data

Type Parameters

T
Type of the data to be retrieved

Return Value

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


OnLayoutChanged Method

[image]

.NET Framework Class Library
GaugeDrawingContext..::.OnLayoutChanged Method
GaugeDrawingContext Class See Also
Fires the LayoutChanged event that is listened for the decorators to redraw themselves.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public void OnLayoutChanged()
Visual Basic (Declaration)
Public Sub OnLayoutChanged

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Properties

[image] [image]

.NET Framework Class Library
GaugeDrawingContext Properties
GaugeDrawingContext Class See Also

The GaugeDrawingContext type exposes the following members.

Properties

Name | Description
ActualSize | Gets the real Gauge size.
DesignSize | Get the design time size of the Gauge.
Gauge | Reference to the C1Gauge.
ResizingTransform | Transformation used to scale the elements in the inner layers.

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


ActualSize Property

[image]

.NET Framework Class Library
GaugeDrawingContext..::.ActualSize Property
GaugeDrawingContext Class See Also
Gets the real Gauge size.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Size ActualSize { get; set; }
Visual Basic (Declaration)
Public Property ActualSize As Size

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


DesignSize Property

[image]

.NET Framework Class Library
GaugeDrawingContext..::.DesignSize Property
GaugeDrawingContext Class See Also
Get the design time size of the Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Size DesignSize { get; set; }
Visual Basic (Declaration)
Public Property DesignSize As Size

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


Gauge Property

[image]

.NET Framework Class Library
GaugeDrawingContext..::.Gauge Property
GaugeDrawingContext Class See Also
Reference to the C1Gauge.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1Gauge Gauge { get; set; }
Visual Basic (Declaration)
Public Property Gauge As C1Gauge

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


ResizingTransform Property

[image]

.NET Framework Class Library
GaugeDrawingContext..::.ResizingTransform Property
GaugeDrawingContext Class See Also
Transformation used to scale the elements in the inner layers.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public ScaleTransform ResizingTransform { get; }
Visual Basic (Declaration)
Public ReadOnly Property ResizingTransform As ScaleTransform

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GaugeDrawingContext Events

[image] [image]

.NET Framework Class Library
GaugeDrawingContext Events
GaugeDrawingContext Class See Also

The GaugeDrawingContext type exposes the following members.

Events

Name | Description
LayoutChanged | Fired when properties provoking layout-change has changed

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


LayoutChanged Event

[image]

.NET Framework Class Library
GaugeDrawingContext..::.LayoutChanged Event
GaugeDrawingContext Class See Also
Fired when properties provoking layout-change has changed

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public event EventHandler<GaugeLayoutChangedEventArgs> LayoutChanged
Visual Basic (Declaration)
Public Event LayoutChanged As EventHandler(Of GaugeLayoutChangedEventArgs)

See Also

GaugeDrawingContext Class
C1.Silverlight.Gauge Namespace


GaugeLayoutChangedEventArgs Class

[image]

.NET Framework Class Library
GaugeLayoutChangedEventArgs Class
Members See Also
Event args of the LayoutChanged of the Gauge context

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public class GaugeLayoutChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class GaugeLayoutChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.Gauge..::.GaugeLayoutChangedEventArgs

See Also

GaugeLayoutChangedEventArgs Members
C1.Silverlight.Gauge Namespace


GaugeLayoutChangedEventArgs Members

[image] [image]

.NET Framework Class Library
GaugeLayoutChangedEventArgs Members
GaugeLayoutChangedEventArgs Class Constructors Methods See Also

The GaugeLayoutChangedEventArgs type exposes the following members.

Constructors

Name | Description
GaugeLayoutChangedEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GaugeLayoutChangedEventArgs Class
C1.Silverlight.Gauge Namespace


GaugeLayoutChangedEventArgs Constructor

[image]

.NET Framework Class Library
GaugeLayoutChangedEventArgs Constructor
GaugeLayoutChangedEventArgs Class See Also

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public GaugeLayoutChangedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

GaugeLayoutChangedEventArgs Class
C1.Silverlight.Gauge Namespace


GaugeLayoutChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
GaugeLayoutChangedEventArgs Methods
GaugeLayoutChangedEventArgs Class See Also

The GaugeLayoutChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GaugeLayoutChangedEventArgs Class
C1.Silverlight.Gauge Namespace


RangeValueBinding Enumeration

[image]

.NET Framework Class Library
RangeValueBinding Enumeration
See Also
Binding options for the C1GaugeRange.

Namespace: C1.Silverlight.Gauge
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public enum RangeValueBinding
Visual Basic (Declaration)
Public Enumeration RangeValueBinding

Members

Member name | Description
None | Do not bind the C1Gauge's value with any property.
From | Bind the C1Gauge's value with the From property of the C1GaugeRange.
To | Bind the C1Gauge's value with the To property of the C1GaugeRange.

See Also

C1.Silverlight.Gauge Namespace


C1.Silverlight.Gauge.Primitives Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Gauge.Primitives Namespace

Classes

Class | Description
C1Ellipse | Used in the C1RadialGauge to be able to bind the BorderThickness of a Control to the StrokeThickness of a Shape.


C1Ellipse Class

[image]

.NET Framework Class Library
C1Ellipse Class
Members See Also
Used in the C1RadialGauge to be able to bind the BorderThickness of a Control to the StrokeThickness of a Shape.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[TemplatePartAttribute(Name = "Ellipse", Type = typeof(Ellipse))]
public class C1Ellipse : Control
Visual Basic (Declaration)
<EditorBrowsableAttribute(EditorBrowsableState.Never)> _
<TemplatePartAttribute(Name := "Ellipse", Type := GetType(Ellipse))> _
Public Class C1Ellipse _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Gauge.Primitives..::.C1Ellipse

See Also

C1Ellipse Members
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Members

[image] [image]

.NET Framework Class Library
C1Ellipse Members
C1Ellipse Class Constructors Methods Fields Properties Events See Also

The C1Ellipse type exposes the following members.

Constructors

Name | Description
C1Ellipse | Initializes a new instance of a C1Ellipse.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Stroke | Represents the inner Ellipse Stroke.
StrokeThickness | Represents the inner Ellipse StrokeThickness.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Constructor

[image]

.NET Framework Class Library
C1Ellipse Constructor
C1Ellipse Class See Also
Initializes a new instance of a C1Ellipse.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public C1Ellipse()
Visual Basic (Declaration)
Public Sub New

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Fields

[image] [image]

.NET Framework Class Library
C1Ellipse Fields
C1Ellipse Class See Also

The C1Ellipse type exposes the following members.

Fields

Name | Description
StrokeProperty | Identifies the Stroke dependency property.
StrokeThicknessProperty | Identifies the StrokeThickness dependency property.

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


StrokeProperty Field

[image]

.NET Framework Class Library
C1Ellipse..::.StrokeProperty Field
C1Ellipse Class See Also
Identifies the Stroke dependency property.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty StrokeProperty
Visual Basic (Declaration)
Public Shared ReadOnly StrokeProperty As DependencyProperty

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


StrokeThicknessProperty Field

[image]

.NET Framework Class Library
C1Ellipse..::.StrokeThicknessProperty Field
C1Ellipse Class See Also
Identifies the StrokeThickness dependency property.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public static readonly DependencyProperty StrokeThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly StrokeThicknessProperty As DependencyProperty

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Methods

[image] [image]

.NET Framework Class Library
C1Ellipse Methods
C1Ellipse Class See Also

The C1Ellipse type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Ellipse..::.HitTest Method
C1Ellipse Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Ellipse Class
C1Ellipse Members
C1.Silverlight.Gauge.Primitives Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Ellipse..::.OnApplyTemplate Method
C1Ellipse Class See Also

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Properties

[image] [image]

.NET Framework Class Library
C1Ellipse Properties
C1Ellipse Class See Also

The C1Ellipse type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Stroke | Represents the inner Ellipse Stroke.
StrokeThickness | Represents the inner Ellipse StrokeThickness.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


Stroke Property

[image]

.NET Framework Class Library
C1Ellipse..::.Stroke Property
C1Ellipse Class See Also
Represents the inner Ellipse Stroke.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Brush Stroke { get; set; }
Visual Basic (Declaration)
Public Property Stroke As Brush

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


StrokeThickness Property

[image]

.NET Framework Class Library
C1Ellipse..::.StrokeThickness Property
C1Ellipse Class See Also
Represents the inner Ellipse StrokeThickness.

Namespace: C1.Silverlight.Gauge.Primitives
Assembly: C1.Silverlight.Gauge (in C1.Silverlight.Gauge.dll)

Syntax

C#
public Thickness StrokeThickness { get; set; }
Visual Basic (Declaration)
Public Property StrokeThickness As Thickness

Remarks

The Left field will be bound.

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1Ellipse Events

[image] [image]

.NET Framework Class Library
C1Ellipse Events
C1Ellipse Class See Also

The C1Ellipse type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1Ellipse Class
C1.Silverlight.Gauge.Primitives Namespace


C1.Silverlight.Maps Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Maps Namespace

Classes

Class | Description
C1MapCanvas | A Panel that positions its elements using geographic coordinates and the current state of an associated C1Maps.
C1MapItemsLayer | An ItemsControl that displays its items positioned geographically inside a C1Maps.
C1Maps | Displays a map with layers of content above it.
C1MapTilesLayer | A IMapLayer that displays map tiles from a MultiScaleTileSource
C1MapToolsLayer | A IMapLayer that displays tools for panning and zooming the map, and a scale.
C1MapVirtualLayer | A IMapLayer that displays its items positioned geographically and only shows the items actually in view.
C1MultiScaleTileSource | Base class for C1's MultiScaleTileSource implementations, used for testing.
GoogleMapsMapSource | A MultiScaleTileSource accessing Google Maps' map tiles.
GoogleMapSource |
GoogleMapsSatelliteSource | A MultiScaleTileSource accessing Google Maps' satellite tiles.
MapSlice | Represents a map slice as used in C1MapVirtualLayer.
MercatorProjection | A MapProjection implementation for the Mercator projection.
QuadTreeTileSource | Base class for MultiScaleTileSource implementation accessing a quad tree of tiles.
VirtualEarthAerialSource | A MultiScaleTileSource accessing Microsoft's Virtual Earth aerial tiles.
VirtualEarthHybridSource | A MultiScaleTileSource accessing Microsoft's Virtual Earth hybrid tiles.
VirtualEarthRoadSource | A MultiScaleTileSource accessing Microsoft's Virtual Earth road tiles.

Interfaces

Interface | Description
IMapLayer | Interface implemented by classes that will be added as layers of a C1Maps.
IMapVirtualSource | Interface implemented by items sources for C1MapVirtualLayer.
MapProjection | Interface for projections between geographic coordinates and logical coordinates.


C1MapCanvas Class

[image]

.NET Framework Class Library
C1MapCanvas Class
Members See Also
A Panel that positions its elements using geographic coordinates and the current state of an associated C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class C1MapCanvas : Panel
Visual Basic (Declaration)
Public Class C1MapCanvas _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.Maps..::.C1MapCanvas

See Also

C1MapCanvas Members
C1.Silverlight.Maps Namespace


C1MapCanvas Members

[image] [image]

.NET Framework Class Library
C1MapCanvas Members
C1MapCanvas Class Constructors Methods Fields Properties Events See Also

The C1MapCanvas type exposes the following members.

Constructors

Name | Description
C1MapCanvas | Initializes a new instance of a C1MapCanvas.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLatLong | Gets the value of the LatLong attached property for the specified element.
GetPinpoint | Gets the value of the Pinpoint attached property for the specified element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetLatLong | Sets the value of the LatLong attached property for the specified element.
SetPinpoint | Sets the value of the Pinpoint attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
LatLongProperty | Identifies the LatLong attached property.
PinpointProperty | Identifies the Pinpoint attached property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Gets or sets the C1Maps to which this C1MapCanvas is associated with.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapCanvas Constructor

[image]

.NET Framework Class Library
C1MapCanvas Constructor
C1MapCanvas Class See Also
Initializes a new instance of a C1MapCanvas.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1MapCanvas()
Visual Basic (Declaration)
Public Sub New

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapCanvas Fields

[image] [image]

.NET Framework Class Library
C1MapCanvas Fields
C1MapCanvas Class See Also

The C1MapCanvas type exposes the following members.

Fields

Name | Description
LatLongProperty | Identifies the LatLong attached property.
PinpointProperty | Identifies the Pinpoint attached property.

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


LatLongProperty Field

[image]

.NET Framework Class Library
C1MapCanvas..::.LatLongProperty Field
C1MapCanvas Class See Also
Identifies the LatLong attached property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty LatLongProperty
Visual Basic (Declaration)
Public Shared ReadOnly LatLongProperty As DependencyProperty

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


PinpointProperty Field

[image]

.NET Framework Class Library
C1MapCanvas..::.PinpointProperty Field
C1MapCanvas Class See Also
Identifies the Pinpoint attached property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty PinpointProperty
Visual Basic (Declaration)
Public Shared ReadOnly PinpointProperty As DependencyProperty

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapCanvas Methods

[image] [image]

.NET Framework Class Library
C1MapCanvas Methods
C1MapCanvas Class See Also

The C1MapCanvas type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetLatLong | Gets the value of the LatLong attached property for the specified element.
GetPinpoint | Gets the value of the Pinpoint attached property for the specified element.
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetLatLong | Sets the value of the LatLong attached property for the specified element.
SetPinpoint | Sets the value of the Pinpoint attached property for the specified element.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
C1MapCanvas..::.ArrangeOverride Method
C1MapCanvas Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


GetLatLong Method

[image]

.NET Framework Class Library
C1MapCanvas..::.GetLatLong Method
C1MapCanvas Class See Also
Gets the value of the LatLong attached property for the specified element.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static Point GetLatLong(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetLatLong ( _
    element As DependencyObject _
) As Point

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the LatLong property.

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


GetPinpoint Method

[image]

.NET Framework Class Library
C1MapCanvas..::.GetPinpoint Method
C1MapCanvas Class See Also
Gets the value of the Pinpoint attached property for the specified element.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static Point GetPinpoint(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetPinpoint ( _
    element As DependencyObject _
) As Point

Parameters

element
Type: System.Windows..::.DependencyObject
The element from which to read the attached property.

Return Value

The value of the Pinpoint property.

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MapCanvas..::.HitTest Method
C1MapCanvas Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MapCanvas Class
C1MapCanvas Members
C1.Silverlight.Maps Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
C1MapCanvas..::.MeasureOverride Method
C1MapCanvas Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


SetLatLong Method

[image]

.NET Framework Class Library
C1MapCanvas..::.SetLatLong Method
C1MapCanvas Class See Also
Sets the value of the LatLong attached property for the specified element.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static void SetLatLong(
    DependencyObject element,
    Point value
)
Visual Basic (Declaration)
Public Shared Sub SetLatLong ( _
    element As DependencyObject, _
    value As Point _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: System.Windows..::.Point
The property value to set.

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


SetPinpoint Method

[image]

.NET Framework Class Library
C1MapCanvas..::.SetPinpoint Method
C1MapCanvas Class See Also
Sets the value of the Pinpoint attached property for the specified element.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static void SetPinpoint(
    DependencyObject element,
    Point value
)
Visual Basic (Declaration)
Public Shared Sub SetPinpoint ( _
    element As DependencyObject, _
    value As Point _
)

Parameters

element
Type: System.Windows..::.DependencyObject
The element to write the attached property to.
value
Type: System.Windows..::.Point
The property value to set.

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapCanvas Properties

[image] [image]

.NET Framework Class Library
C1MapCanvas Properties
C1MapCanvas Class See Also

The C1MapCanvas type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Gets or sets the C1Maps to which this C1MapCanvas is associated with.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
C1MapCanvas..::.ParentMaps Property
C1MapCanvas Class See Also
Gets or sets the C1Maps to which this C1MapCanvas is associated with.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Public Property ParentMaps As C1Maps

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapCanvas Events

[image] [image]

.NET Framework Class Library
C1MapCanvas Events
C1MapCanvas Class See Also

The C1MapCanvas type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapCanvas Class
C1.Silverlight.Maps Namespace


C1MapItemsLayer Class

[image]

.NET Framework Class Library
C1MapItemsLayer Class
Members See Also
An ItemsControl that displays its items positioned geographically inside a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class C1MapItemsLayer : ItemsControl,
    IMapLayer
Visual Basic (Declaration)
Public Class C1MapItemsLayer _
    Inherits ItemsControl _
    Implements IMapLayer

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ItemsControl
C1.Silverlight.Maps..::.C1MapItemsLayer

See Also

C1MapItemsLayer Members
C1.Silverlight.Maps Namespace


C1MapItemsLayer Members

[image] [image]

.NET Framework Class Library
C1MapItemsLayer Members
C1MapItemsLayer Class Constructors Methods Properties Events See Also

The C1MapItemsLayer type exposes the following members.

Constructors

Name | Description
C1MapItemsLayer | Initializes a new instance of a C1MapItemsLayer.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


C1MapItemsLayer Constructor

[image]

.NET Framework Class Library
C1MapItemsLayer Constructor
C1MapItemsLayer Class See Also
Initializes a new instance of a C1MapItemsLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1MapItemsLayer()
Visual Basic (Declaration)
Public Sub New

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


C1MapItemsLayer Methods

[image] [image]

.NET Framework Class Library
C1MapItemsLayer Methods
C1MapItemsLayer Class See Also

The C1MapItemsLayer type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearContainerForItemOverride | (Inherited from ItemsControl.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContainerForItemOverride | (Inherited from ItemsControl.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
IsItemItsOwnContainerOverride | (Inherited from ItemsControl.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnItemsChanged | (Inherited from ItemsControl.)
PrepareContainerForItemOverride | (Overrides ItemsControl..::.PrepareContainerForItemOverride(DependencyObject, Object).)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MapItemsLayer..::.HitTest Method
C1MapItemsLayer Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MapItemsLayer Class
C1MapItemsLayer Members
C1.Silverlight.Maps Namespace


PrepareContainerForItemOverride Method

[image]

.NET Framework Class Library
C1MapItemsLayer..::.PrepareContainerForItemOverride Method
C1MapItemsLayer Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
protected override void PrepareContainerForItemOverride(
    DependencyObject element,
    Object item
)
Visual Basic (Declaration)
Protected Overrides Sub PrepareContainerForItemOverride ( _
    element As DependencyObject, _
    item As Object _
)

Parameters

element
Type: System.Windows..::.DependencyObject
item
Type: System..::.Object

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


C1MapItemsLayer Properties

[image] [image]

.NET Framework Class Library
C1MapItemsLayer Properties
C1MapItemsLayer Class See Also

The C1MapItemsLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DisplayMemberPath | (Inherited from ItemsControl.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Items | (Inherited from ItemsControl.)
ItemsPanel | (Inherited from ItemsControl.)
ItemsSource | (Inherited from ItemsControl.)
ItemTemplate | (Inherited from ItemsControl.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
C1MapItemsLayer..::.ParentMaps Property
C1MapItemsLayer Class See Also
Get or sets the parent C1Maps for this IMapLayer

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Public Property ParentMaps As C1Maps

Implements

IMapLayer..::.ParentMaps

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


C1MapItemsLayer Events

[image] [image]

.NET Framework Class Library
C1MapItemsLayer Events
C1MapItemsLayer Class See Also

The C1MapItemsLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapItemsLayer Class
C1.Silverlight.Maps Namespace


C1Maps Class

[image]

.NET Framework Class Library
C1Maps Class
Members See Also
Displays a map with layers of content above it.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
[ContentPropertyAttribute("Layers")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Layers", Type = typeof(Panel))]
[TemplatePartAttribute(Name = "Tiles", Type = typeof(C1MapTilesLayer))]
[TemplatePartAttribute(Name = "Tools", Type = typeof(C1MapToolsLayer))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
public class C1Maps : Control
Visual Basic (Declaration)
<ContentPropertyAttribute("Layers")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Layers", Type := GetType(Panel))> _
<TemplatePartAttribute(Name := "Tiles", Type := GetType(C1MapTilesLayer))> _
<TemplatePartAttribute(Name := "Tools", Type := GetType(C1MapToolsLayer))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
Public Class C1Maps _
    Inherits Control

Remarks

In order for C1Maps to be able to access tiles over the internet, the Silverlight application must be hosted in a Web server. If the Silverlight application is ran directly from local disk, the Silverlight runtime prevents it from accessing internet resources.

Note that geographic coordinates are represented using Point structures. The X property of Point is the longitude and the Y property is the latitude.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Maps..::.C1Maps

See Also

C1Maps Members
C1.Silverlight.Maps Namespace


C1Maps Members

[image] [image]

.NET Framework Class Library
C1Maps Members
C1Maps Class Constructors Methods Fields Properties Events See Also

The C1Maps type exposes the following members.

Constructors

Name | Description
C1Maps | Initializes a new instance of a C1Maps.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Distance | Returns the distance, in meters, between two geographic coordinates.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GeographicToScreen | Transform a point from geographic coordinates to screen coordinates.
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
LogicToScreen | Transform a point from logic coordinates to screen coordinates.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ScreenToGeographic | Transform a point from screen coordinates to geographic coordinates.
ScreenToLogic | Transform a point from screen coordinates to logic coordinates.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CenterProperty | Identifies the Center dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MaxLat | The maximum latitude of a C1Maps.
MaxLong | The maximum longitude of a C1Maps.
MaxZoom | The maximum zoom of a C1Maps.
MinLat | The minimum zoom of a C1Maps.
MinLong | The minimum zoom of a C1Maps.
MinZoom | The minimum zoom of a C1Maps.
ProjectionProperty | Identifies the Projection dependency property.
ShowToolsProperty | Identifies the ShowTools dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomProperty | Identifies the Zoom dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets or sets the center of this map in geographic coordinates.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Layers | Gets the collection of layers.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | Gets or sets the projection used for this map.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowTools | Gets or sets a value indicating whether the default tools are shown.
Source | Gets or sets the MultiScaleTileSource used as source for the base map tiles.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewportHeight | The visible height of the map in logic coordinates.
ViewportWidth | The visible width of the map in logic coordinates.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
Zoom | Gets or sets the zoom factor of this map.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
CenterChanged | Event raised when the Center property has changed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ZoomChanged | Event raised when the Zoom property has changed.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1Maps Constructor

[image]

.NET Framework Class Library
C1Maps Constructor
C1Maps Class See Also
Initializes a new instance of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps()
Visual Basic (Declaration)
Public Sub New

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1Maps Fields

[image] [image]

.NET Framework Class Library
C1Maps Fields
C1Maps Class See Also

The C1Maps type exposes the following members.

Fields

Name | Description
CenterProperty | Identifies the Center dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
MaxLat | The maximum latitude of a C1Maps.
MaxLong | The maximum longitude of a C1Maps.
MaxZoom | The maximum zoom of a C1Maps.
MinLat | The minimum zoom of a C1Maps.
MinLong | The minimum zoom of a C1Maps.
MinZoom | The minimum zoom of a C1Maps.
ProjectionProperty | Identifies the Projection dependency property.
ShowToolsProperty | Identifies the ShowTools dependency property.
SourceProperty | Identifies the Source dependency property.
ZoomProperty | Identifies the Zoom dependency property.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


CenterProperty Field

[image]

.NET Framework Class Library
C1Maps..::.CenterProperty Field
C1Maps Class See Also
Identifies the Center dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty CenterProperty
Visual Basic (Declaration)
Public Shared ReadOnly CenterProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1Maps..::.IsMouseOverProperty Field
C1Maps Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MaxLat Field

[image]

.NET Framework Class Library
C1Maps..::.MaxLat Field
C1Maps Class See Also
The maximum latitude of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MaxLat
Visual Basic (Declaration)
Public Const MaxLat As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MaxLong Field

[image]

.NET Framework Class Library
C1Maps..::.MaxLong Field
C1Maps Class See Also
The maximum longitude of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MaxLong
Visual Basic (Declaration)
Public Const MaxLong As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MaxZoom Field

[image]

.NET Framework Class Library
C1Maps..::.MaxZoom Field
C1Maps Class See Also
The maximum zoom of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MaxZoom
Visual Basic (Declaration)
Public Const MaxZoom As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MinLat Field

[image]

.NET Framework Class Library
C1Maps..::.MinLat Field
C1Maps Class See Also
The minimum zoom of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MinLat
Visual Basic (Declaration)
Public Const MinLat As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MinLong Field

[image]

.NET Framework Class Library
C1Maps..::.MinLong Field
C1Maps Class See Also
The minimum zoom of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MinLong
Visual Basic (Declaration)
Public Const MinLong As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


MinZoom Field

[image]

.NET Framework Class Library
C1Maps..::.MinZoom Field
C1Maps Class See Also
The minimum zoom of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public const double MinZoom
Visual Basic (Declaration)
Public Const MinZoom As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ProjectionProperty Field

[image]

.NET Framework Class Library
C1Maps..::.ProjectionProperty Field
C1Maps Class See Also
Identifies the Projection dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty ProjectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly ProjectionProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ShowToolsProperty Field

[image]

.NET Framework Class Library
C1Maps..::.ShowToolsProperty Field
C1Maps Class See Also
Identifies the ShowTools dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty ShowToolsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowToolsProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


SourceProperty Field

[image]

.NET Framework Class Library
C1Maps..::.SourceProperty Field
C1Maps Class See Also
Identifies the Source dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty SourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ZoomProperty Field

[image]

.NET Framework Class Library
C1Maps..::.ZoomProperty Field
C1Maps Class See Also
Identifies the Zoom dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty ZoomProperty
Visual Basic (Declaration)
Public Shared ReadOnly ZoomProperty As DependencyProperty

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1Maps Methods

[image] [image]

.NET Framework Class Library
C1Maps Methods
C1Maps Class See Also

The C1Maps type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Distance | Returns the distance, in meters, between two geographic coordinates.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GeographicToScreen | Transform a point from geographic coordinates to screen coordinates.
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
LogicToScreen | Transform a point from logic coordinates to screen coordinates.
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ScreenToGeographic | Transform a point from screen coordinates to geographic coordinates.
ScreenToLogic | Transform a point from screen coordinates to logic coordinates.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1Maps..::.ChangeVisualStateCommon Method
C1Maps Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Distance Method

[image]

.NET Framework Class Library
C1Maps..::.Distance Method
C1Maps Class See Also
Returns the distance, in meters, between two geographic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static double Distance(
    Point latLong1,
    Point latLong2
)
Visual Basic (Declaration)
Public Shared Function Distance ( _
    latLong1 As Point, _
    latLong2 As Point _
) As Double

Parameters

latLong1
Type: System.Windows..::.Point
The first geographic coordinate.
latLong2
Type: System.Windows..::.Point
The second geographic coordinate.

Return Value

The distance, in meters, between the two geographic coordinates.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


GeographicToScreen Method

[image]

.NET Framework Class Library
C1Maps..::.GeographicToScreen Method
C1Maps Class See Also
Transform a point from geographic coordinates to screen coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point GeographicToScreen(
    Point latLong
)
Visual Basic (Declaration)
Public Function GeographicToScreen ( _
    latLong As Point _
) As Point

Parameters

latLong
Type: System.Windows..::.Point
A point in geographic coordinates.

Return Value

The screen coordinates currently mapped to the parameter geographic coordinates.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1Maps..::.HitTest Method
C1Maps Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1Maps Class
C1Maps Members
C1.Silverlight.Maps Namespace


LogicToScreen Method

[image]

.NET Framework Class Library
C1Maps..::.LogicToScreen Method
C1Maps Class See Also
Transform a point from logic coordinates to screen coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point LogicToScreen(
    Point point
)
Visual Basic (Declaration)
Public Function LogicToScreen ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point
A point in logic coordinates.

Return Value

The screen coordinates currently mapped to the parameter logic coordinates.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1Maps..::.OnApplyTemplate Method
C1Maps Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ScreenToGeographic Method

[image]

.NET Framework Class Library
C1Maps..::.ScreenToGeographic Method
C1Maps Class See Also
Transform a point from screen coordinates to geographic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point ScreenToGeographic(
    Point point
)
Visual Basic (Declaration)
Public Function ScreenToGeographic ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point
A point in screen coordinates (pixels from the top left corner of this control).

Return Value

The geographic coordinates currently mapped to the parameter screen coordinates.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ScreenToLogic Method

[image]

.NET Framework Class Library
C1Maps..::.ScreenToLogic Method
C1Maps Class See Also
Transform a point from screen coordinates to logic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point ScreenToLogic(
    Point point
)
Visual Basic (Declaration)
Public Function ScreenToLogic ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point
A point in screen coordinates (pixels from the top left corner of this control).

Return Value

The screen coordinates currently mapped to the parameter screen coordinates.

Remarks

The logic coordinates are the ones used by the MapProjection.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1Maps Properties

[image] [image]

.NET Framework Class Library
C1Maps Properties
C1Maps Class See Also

The C1Maps type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Center | Gets or sets the center of this map in geographic coordinates.
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Layers | Gets the collection of layers.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
Projection | Gets or sets the projection used for this map.
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
ShowTools | Gets or sets a value indicating whether the default tools are shown.
Source | Gets or sets the MultiScaleTileSource used as source for the base map tiles.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
ViewportHeight | The visible height of the map in logic coordinates.
ViewportWidth | The visible width of the map in logic coordinates.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)
Zoom | Gets or sets the zoom factor of this map.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Center Property

[image]

.NET Framework Class Library
C1Maps..::.Center Property
C1Maps Class See Also
Gets or sets the center of this map in geographic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point Center { get; set; }
Visual Basic (Declaration)
Public Property Center As Point

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1Maps..::.IsMouseOver Property
C1Maps Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Layers Property

[image]

.NET Framework Class Library
C1Maps..::.Layers Property
C1Maps Class See Also
Gets the collection of layers.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Collection<IMapLayer> Layers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Layers As Collection(Of IMapLayer)

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Projection Property

[image]

.NET Framework Class Library
C1Maps..::.Projection Property
C1Maps Class See Also
Gets or sets the projection used for this map.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public MapProjection Projection { get; set; }
Visual Basic (Declaration)
Public Property Projection As MapProjection

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ShowTools Property

[image]

.NET Framework Class Library
C1Maps..::.ShowTools Property
C1Maps Class See Also
Gets or sets a value indicating whether the default tools are shown.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public bool ShowTools { get; set; }
Visual Basic (Declaration)
Public Property ShowTools As Boolean

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Source Property

[image]

.NET Framework Class Library
C1Maps..::.Source Property
C1Maps Class See Also
Gets or sets the MultiScaleTileSource used as source for the base map tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public MultiScaleTileSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As MultiScaleTileSource

Remarks

If the source is set to null no map tiles are shown.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ViewportHeight Property

[image]

.NET Framework Class Library
C1Maps..::.ViewportHeight Property
C1Maps Class See Also
The visible height of the map in logic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public double ViewportHeight { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewportHeight As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ViewportWidth Property

[image]

.NET Framework Class Library
C1Maps..::.ViewportWidth Property
C1Maps Class See Also
The visible width of the map in logic coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public double ViewportWidth { get; }
Visual Basic (Declaration)
Public ReadOnly Property ViewportWidth As Double

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


Zoom Property

[image]

.NET Framework Class Library
C1Maps..::.Zoom Property
C1Maps Class See Also
Gets or sets the zoom factor of this map.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public double Zoom { get; set; }
Visual Basic (Declaration)
Public Property Zoom As Double

Remarks

The minimum zoom factor is 0. An increment of 1 in the zoom factor doubles the map resolution.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1Maps Events

[image] [image]

.NET Framework Class Library
C1Maps Events
C1Maps Class See Also

The C1Maps type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
CenterChanged | Event raised when the Center property has changed.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ZoomChanged | Event raised when the Zoom property has changed.

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


CenterChanged Event

[image]

.NET Framework Class Library
C1Maps..::.CenterChanged Event
C1Maps Class See Also
Event raised when the Center property has changed.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Point>> CenterChanged
Visual Basic (Declaration)
Public Event CenterChanged As EventHandler(Of PropertyChangedEventArgs(Of Point))

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1Maps..::.IsMouseOverChanged Event
C1Maps Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


ZoomChanged Event

[image]

.NET Framework Class Library
C1Maps..::.ZoomChanged Event
C1Maps Class See Also
Event raised when the Zoom property has changed.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<double>> ZoomChanged
Visual Basic (Declaration)
Public Event ZoomChanged As EventHandler(Of PropertyChangedEventArgs(Of Double))

See Also

C1Maps Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Class

[image]

.NET Framework Class Library
C1MapTilesLayer Class
Members See Also
A IMapLayer that displays map tiles from a MultiScaleTileSource

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
[TemplatePartAttribute(Name = "MapImage", Type = typeof(MultiScaleImage))]
public class C1MapTilesLayer : Control,
    IMapLayer
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "MapImage", Type := GetType(MultiScaleImage))> _
Public Class C1MapTilesLayer _
    Inherits Control _
    Implements IMapLayer

Remarks

C1Maps comes with a C1MapTilesLayer layer, so that it's not usually necessary to add a layer of this type.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Maps..::.C1MapTilesLayer

See Also

C1MapTilesLayer Members
C1.Silverlight.Maps Namespace


C1MapTilesLayer Members

[image] [image]

.NET Framework Class Library
C1MapTilesLayer Members
C1MapTilesLayer Class Constructors Methods Fields Properties Events See Also

The C1MapTilesLayer type exposes the following members.

Constructors

Name | Description
C1MapTilesLayer | Initializes a new instance of a C1MapTilesLayer.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
SourceProperty | Identifies the Source dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Source | Gets or sets the MultiScaleTileSource used as source for this map tiles.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Constructor

[image]

.NET Framework Class Library
C1MapTilesLayer Constructor
C1MapTilesLayer Class See Also
Initializes a new instance of a C1MapTilesLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1MapTilesLayer()
Visual Basic (Declaration)
Public Sub New

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Fields

[image] [image]

.NET Framework Class Library
C1MapTilesLayer Fields
C1MapTilesLayer Class See Also

The C1MapTilesLayer type exposes the following members.

Fields

Name | Description
SourceProperty | Identifies the Source dependency property.

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


SourceProperty Field

[image]

.NET Framework Class Library
C1MapTilesLayer..::.SourceProperty Field
C1MapTilesLayer Class See Also
Identifies the Source dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty SourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly SourceProperty As DependencyProperty

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Methods

[image] [image]

.NET Framework Class Library
C1MapTilesLayer Methods
C1MapTilesLayer Class See Also

The C1MapTilesLayer type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MapTilesLayer..::.HitTest Method
C1MapTilesLayer Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MapTilesLayer Class
C1MapTilesLayer Members
C1.Silverlight.Maps Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1MapTilesLayer..::.OnApplyTemplate Method
C1MapTilesLayer Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Properties

[image] [image]

.NET Framework Class Library
C1MapTilesLayer Properties
C1MapTilesLayer Class See Also

The C1MapTilesLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Source | Gets or sets the MultiScaleTileSource used as source for this map tiles.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
C1MapTilesLayer..::.ParentMaps Property
C1MapTilesLayer Class See Also
Get or sets the parent C1Maps for this IMapLayer

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Public Property ParentMaps As C1Maps

Implements

IMapLayer..::.ParentMaps

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


Source Property

[image]

.NET Framework Class Library
C1MapTilesLayer..::.Source Property
C1MapTilesLayer Class See Also
Gets or sets the MultiScaleTileSource used as source for this map tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public MultiScaleTileSource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As MultiScaleTileSource

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapTilesLayer Events

[image] [image]

.NET Framework Class Library
C1MapTilesLayer Events
C1MapTilesLayer Class See Also

The C1MapTilesLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapTilesLayer Class
C1.Silverlight.Maps Namespace


C1MapToolsLayer Class

[image]

.NET Framework Class Library
C1MapToolsLayer Class
Members See Also
A IMapLayer that displays tools for panning and zooming the map, and a scale.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
[TemplatePartAttribute(Name = "MilesScale", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Pan", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "MetersLabel", Type = typeof(TextBlock))]
[TemplatePartAttribute(Name = "MilesLabel", Type = typeof(TextBlock))]
[TemplatePartAttribute(Name = "PanMarker", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "MetersScale", Type = typeof(FrameworkElement))]
[TemplatePartAttribute(Name = "Zoom", Type = typeof(RangeBase))]
public class C1MapToolsLayer : Control,
    IMapLayer
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "MilesScale", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Pan", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "MetersLabel", Type := GetType(TextBlock))> _
<TemplatePartAttribute(Name := "MilesLabel", Type := GetType(TextBlock))> _
<TemplatePartAttribute(Name := "PanMarker", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "MetersScale", Type := GetType(FrameworkElement))> _
<TemplatePartAttribute(Name := "Zoom", Type := GetType(RangeBase))> _
Public Class C1MapToolsLayer _
    Inherits Control _
    Implements IMapLayer

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Maps..::.C1MapToolsLayer

See Also

C1MapToolsLayer Members
C1.Silverlight.Maps Namespace


C1MapToolsLayer Members

[image] [image]

.NET Framework Class Library
C1MapToolsLayer Members
C1MapToolsLayer Class Constructors Methods Properties Events See Also

The C1MapToolsLayer type exposes the following members.

Constructors

Name | Description
C1MapToolsLayer | Initializes a new instance of a C1MapToolsLayer.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


C1MapToolsLayer Constructor

[image]

.NET Framework Class Library
C1MapToolsLayer Constructor
C1MapToolsLayer Class See Also
Initializes a new instance of a C1MapToolsLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1MapToolsLayer()
Visual Basic (Declaration)
Public Sub New

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


C1MapToolsLayer Methods

[image] [image]

.NET Framework Class Library
C1MapToolsLayer Methods
C1MapToolsLayer Class See Also

The C1MapToolsLayer type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MapToolsLayer..::.HitTest Method
C1MapToolsLayer Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MapToolsLayer Class
C1MapToolsLayer Members
C1.Silverlight.Maps Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1MapToolsLayer..::.OnApplyTemplate Method
C1MapToolsLayer Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


C1MapToolsLayer Properties

[image] [image]

.NET Framework Class Library
C1MapToolsLayer Properties
C1MapToolsLayer Class See Also

The C1MapToolsLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
C1MapToolsLayer..::.ParentMaps Property
C1MapToolsLayer Class See Also
Get or sets the parent C1Maps for this IMapLayer

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Public Property ParentMaps As C1Maps

Implements

IMapLayer..::.ParentMaps

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


C1MapToolsLayer Events

[image] [image]

.NET Framework Class Library
C1MapToolsLayer Events
C1MapToolsLayer Class See Also

The C1MapToolsLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapToolsLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Class

[image]

.NET Framework Class Library
C1MapVirtualLayer Class
Members See Also
A IMapLayer that displays its items positioned geographically and only shows the items actually in view.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
[TemplatePartAttribute(Name = "ItemsHost", Type = typeof(C1MapItemsLayer))]
public class C1MapVirtualLayer : Control,
    IMapLayer
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "ItemsHost", Type := GetType(C1MapItemsLayer))> _
Public Class C1MapVirtualLayer _
    Inherits Control _
    Implements IMapLayer

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.Maps..::.C1MapVirtualLayer

See Also

C1MapVirtualLayer Members
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Members

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer Members
C1MapVirtualLayer Class Constructors Methods Fields Properties Events See Also

The C1MapVirtualLayer type exposes the following members.

Constructors

Name | Description
C1MapVirtualLayer | Initializes a new instance of a C1MapVirtualLayer.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
ForceRefresh | Forces this C1MapVirtualLayer to request all items again.
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ItemTemplateProperty | Identifies the ItemTemplate dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemTemplate | Gets or sets the DataTemplate used to display each item.
Language | (Inherited from FrameworkElement.)
MapItemsSource | Gets os sets the current IMapVirtualSource for this C1MapVirtualLayer.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Slices | Gets the collection of MapSlice specifying how the map is partitioned for virtualization.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Constructor

[image]

.NET Framework Class Library
C1MapVirtualLayer Constructor
C1MapVirtualLayer Class See Also
Initializes a new instance of a C1MapVirtualLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1MapVirtualLayer()
Visual Basic (Declaration)
Public Sub New

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Fields

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer Fields
C1MapVirtualLayer Class See Also

The C1MapVirtualLayer type exposes the following members.

Fields

Name | Description
ItemTemplateProperty | Identifies the ItemTemplate dependency property.

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


ItemTemplateProperty Field

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.ItemTemplateProperty Field
C1MapVirtualLayer Class See Also
Identifies the ItemTemplate dependency property.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static readonly DependencyProperty ItemTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemTemplateProperty As DependencyProperty

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Methods

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer Methods
C1MapVirtualLayer Class See Also

The C1MapVirtualLayer type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
ForceRefresh | Forces this C1MapVirtualLayer to request all items again.
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


ForceRefresh Method

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.ForceRefresh Method
C1MapVirtualLayer Class See Also
Forces this C1MapVirtualLayer to request all items again.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public void ForceRefresh()
Visual Basic (Declaration)
Public Sub ForceRefresh

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer..::.HitTest Method
C1MapVirtualLayer Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1MapVirtualLayer Class
C1MapVirtualLayer Members
C1.Silverlight.Maps Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.OnApplyTemplate Method
C1MapVirtualLayer Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Properties

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer Properties
C1MapVirtualLayer Class See Also

The C1MapVirtualLayer type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemTemplate | Gets or sets the DataTemplate used to display each item.
Language | (Inherited from FrameworkElement.)
MapItemsSource | Gets os sets the current IMapVirtualSource for this C1MapVirtualLayer.
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
ParentMaps | Get or sets the parent C1Maps for this IMapLayer
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Slices | Gets the collection of MapSlice specifying how the map is partitioned for virtualization.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


ItemTemplate Property

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.ItemTemplate Property
C1MapVirtualLayer Class See Also
Gets or sets the DataTemplate used to display each item.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public DataTemplate ItemTemplate { get; set; }
Visual Basic (Declaration)
Public Property ItemTemplate As DataTemplate

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


MapItemsSource Property

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.MapItemsSource Property
C1MapVirtualLayer Class See Also
Gets os sets the current IMapVirtualSource for this C1MapVirtualLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public IMapVirtualSource MapItemsSource { get; set; }
Visual Basic (Declaration)
Public Property MapItemsSource As IMapVirtualSource

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.ParentMaps Property
C1MapVirtualLayer Class See Also
Get or sets the parent C1Maps for this IMapLayer

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Public Property ParentMaps As C1Maps

Implements

IMapLayer..::.ParentMaps

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


Slices Property

[image]

.NET Framework Class Library
C1MapVirtualLayer..::.Slices Property
C1MapVirtualLayer Class See Also
Gets the collection of MapSlice specifying how the map is partitioned for virtualization.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public ICollection<MapSlice> Slices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Slices As ICollection(Of MapSlice)

Remarks

Each MapSlice defines a set of regions this C1MapVirtualLayer will get items for when needed. The minimum zoom of a MapSlice is the value of its Zoom property, while the maximum zoom is the value from the Zoom property of the next slice. Each slice divides the map in a uniform grid of regions according to the current Projection.

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MapVirtualLayer Events

[image] [image]

.NET Framework Class Library
C1MapVirtualLayer Events
C1MapVirtualLayer Class See Also

The C1MapVirtualLayer type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1MapVirtualLayer Class
C1.Silverlight.Maps Namespace


C1MultiScaleTileSource Class

[image]

.NET Framework Class Library
C1MultiScaleTileSource Class
Members See Also
Base class for C1's MultiScaleTileSource implementations, used for testing.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public abstract class C1MultiScaleTileSource : MultiScaleTileSource
Visual Basic (Declaration)
Public MustInherit Class C1MultiScaleTileSource _
    Inherits MultiScaleTileSource

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.GoogleMapSource
C1.Silverlight.Maps..::.QuadTreeTileSource

See Also

C1MultiScaleTileSource Members
C1.Silverlight.Maps Namespace


C1MultiScaleTileSource Members

[image] [image]

.NET Framework Class Library
C1MultiScaleTileSource Members
C1MultiScaleTileSource Class Methods Properties See Also

The C1MultiScaleTileSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from MultiScaleTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

C1MultiScaleTileSource Class
C1.Silverlight.Maps Namespace


C1MultiScaleTileSource Methods

[image] [image]

.NET Framework Class Library
C1MultiScaleTileSource Methods
C1MultiScaleTileSource Class See Also

The C1MultiScaleTileSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from MultiScaleTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1MultiScaleTileSource Class
C1.Silverlight.Maps Namespace


C1MultiScaleTileSource Properties

[image] [image]

.NET Framework Class Library
C1MultiScaleTileSource Properties
C1MultiScaleTileSource Class See Also

The C1MultiScaleTileSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

C1MultiScaleTileSource Class
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Class

[image]

.NET Framework Class Library
GoogleMapsMapSource Class
Members See Also
A MultiScaleTileSource accessing Google Maps' map tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class GoogleMapsMapSource : GoogleMapSource
Visual Basic (Declaration)
Public Class GoogleMapsMapSource _
    Inherits GoogleMapSource

Remarks

Google may temporarily block tile access if it detects abuse.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.GoogleMapSource
C1.Silverlight.Maps..::.GoogleMapsMapSource

See Also

GoogleMapsMapSource Members
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Members

[image] [image]

.NET Framework Class Library
GoogleMapsMapSource Members
GoogleMapsMapSource Class Constructors Methods Fields Properties See Also

The GoogleMapsMapSource type exposes the following members.

Constructors

Name | Description
GoogleMapsMapSource | Initializes a new GoogleMapsMapSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from GoogleMapSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Constructor

[image]

.NET Framework Class Library
GoogleMapsMapSource Constructor
GoogleMapsMapSource Class See Also
Initializes a new GoogleMapsMapSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public GoogleMapsMapSource()
Visual Basic (Declaration)
Public Sub New

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Fields

[image] [image]

.NET Framework Class Library
GoogleMapsMapSource Fields
GoogleMapsMapSource Class See Also

The GoogleMapsMapSource type exposes the following members.

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


UriFormat Field

[image]

.NET Framework Class Library
GoogleMapsMapSource..::.UriFormat Field
GoogleMapsMapSource Class See Also
The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static string UriFormat
Visual Basic (Declaration)
Public Shared UriFormat As String

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Methods

[image] [image]

.NET Framework Class Library
GoogleMapsMapSource Methods
GoogleMapsMapSource Class See Also

The GoogleMapsMapSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from GoogleMapSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapsMapSource Properties

[image] [image]

.NET Framework Class Library
GoogleMapsMapSource Properties
GoogleMapsMapSource Class See Also

The GoogleMapsMapSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapsMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapSource Class

[image]

.NET Framework Class Library
GoogleMapSource Class
Members See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public abstract class GoogleMapSource : C1MultiScaleTileSource
Visual Basic (Declaration)
Public MustInherit Class GoogleMapSource _
    Inherits C1MultiScaleTileSource

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.GoogleMapSource
C1.Silverlight.Maps..::.GoogleMapsMapSource
C1.Silverlight.Maps..::.GoogleMapsSatelliteSource

See Also

GoogleMapSource Members
C1.Silverlight.Maps Namespace


GoogleMapSource Members

[image] [image]

.NET Framework Class Library
GoogleMapSource Members
GoogleMapSource Class Constructors Methods Properties See Also

The GoogleMapSource type exposes the following members.

Constructors

Name | Description
GoogleMapSource | Initializes a new GoogleMapSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Overrides MultiScaleTileSourceGetTileLayers(Int32, Int32, Int32, IList<(Of <(Object>)>)).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapSource Constructor

[image]

.NET Framework Class Library
GoogleMapSource Constructor
GoogleMapSource Class See Also
Initializes a new GoogleMapSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public GoogleMapSource(
    string uriFormat
)
Visual Basic (Declaration)
Public Sub New ( _
    uriFormat As String _
)

Parameters

uriFormat
Type: System..::.String
Uri format to use.

See Also

GoogleMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapSource Methods

[image] [image]

.NET Framework Class Library
GoogleMapSource Methods
GoogleMapSource Class See Also

The GoogleMapSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Overrides MultiScaleTileSourceGetTileLayers(Int32, Int32, Int32, IList<(Of <(Object>)>)).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GoogleMapSource Class
C1.Silverlight.Maps Namespace


GetTileLayers Method

[image]

.NET Framework Class Library
GoogleMapSource..::.GetTileLayers Method
GoogleMapSource Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
protected override void GetTileLayers(
    int level,
    int x,
    int y,
    IList<Object> sources
)
Visual Basic (Declaration)
Protected Overrides Sub GetTileLayers ( _
    level As Integer, _
    x As Integer, _
    y As Integer, _
    sources As IList(Of Object) _
)

Parameters

level
Type: System..::.Int32
x
Type: System..::.Int32
y
Type: System..::.Int32
sources
Type: System.Collections.Generic..::.IList <(Of <( Object >)>)

See Also

GoogleMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapSource Properties

[image] [image]

.NET Framework Class Library
GoogleMapSource Properties
GoogleMapSource Class See Also

The GoogleMapSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapSource Class
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Class

[image]

.NET Framework Class Library
GoogleMapsSatelliteSource Class
Members See Also
A MultiScaleTileSource accessing Google Maps' satellite tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class GoogleMapsSatelliteSource : GoogleMapSource
Visual Basic (Declaration)
Public Class GoogleMapsSatelliteSource _
    Inherits GoogleMapSource

Remarks

Google may temporarily block tile access if it detects abuse.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.GoogleMapSource
C1.Silverlight.Maps..::.GoogleMapsSatelliteSource

See Also

GoogleMapsSatelliteSource Members
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Members

[image] [image]

.NET Framework Class Library
GoogleMapsSatelliteSource Members
GoogleMapsSatelliteSource Class Constructors Methods Fields Properties See Also

The GoogleMapsSatelliteSource type exposes the following members.

Constructors

Name | Description
GoogleMapsSatelliteSource | Initializes a new GoogleMapsSatelliteSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from GoogleMapSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Constructor

[image]

.NET Framework Class Library
GoogleMapsSatelliteSource Constructor
GoogleMapsSatelliteSource Class See Also
Initializes a new GoogleMapsSatelliteSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public GoogleMapsSatelliteSource()
Visual Basic (Declaration)
Public Sub New

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Fields

[image] [image]

.NET Framework Class Library
GoogleMapsSatelliteSource Fields
GoogleMapsSatelliteSource Class See Also

The GoogleMapsSatelliteSource type exposes the following members.

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


UriFormat Field

[image]

.NET Framework Class Library
GoogleMapsSatelliteSource..::.UriFormat Field
GoogleMapsSatelliteSource Class See Also
The URI format used for accessing the tiles. It might be necessary to change this if Google changes the tiles URLs.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static string UriFormat
Visual Basic (Declaration)
Public Shared UriFormat As String

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Methods

[image] [image]

.NET Framework Class Library
GoogleMapsSatelliteSource Methods
GoogleMapsSatelliteSource Class See Also

The GoogleMapsSatelliteSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from GoogleMapSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


GoogleMapsSatelliteSource Properties

[image] [image]

.NET Framework Class Library
GoogleMapsSatelliteSource Properties
GoogleMapsSatelliteSource Class See Also

The GoogleMapsSatelliteSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

GoogleMapsSatelliteSource Class
C1.Silverlight.Maps Namespace


IMapLayer Interface

[image]

.NET Framework Class Library
IMapLayer Interface
Members See Also
Interface implemented by classes that will be added as layers of a C1Maps.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public interface IMapLayer
Visual Basic (Declaration)
Public Interface IMapLayer

See Also

IMapLayer Members
C1.Silverlight.Maps Namespace


IMapLayer Members

[image] [image]

.NET Framework Class Library
IMapLayer Members
IMapLayer Interface Properties See Also

The IMapLayer type exposes the following members.

Properties

Name | Description
ParentMaps | Get or sets the parent C1Maps for this IMapLayer

See Also

IMapLayer Interface
C1.Silverlight.Maps Namespace


IMapLayer Properties

[image] [image]

.NET Framework Class Library
IMapLayer Properties
IMapLayer Interface See Also

The IMapLayer type exposes the following members.

Properties

Name | Description
ParentMaps | Get or sets the parent C1Maps for this IMapLayer

See Also

IMapLayer Interface
C1.Silverlight.Maps Namespace


ParentMaps Property

[image]

.NET Framework Class Library
IMapLayer..::.ParentMaps Property
IMapLayer Interface See Also
Get or sets the parent C1Maps for this IMapLayer

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
C1Maps ParentMaps { get; set; }
Visual Basic (Declaration)
Property ParentMaps As C1Maps

See Also

IMapLayer Interface
C1.Silverlight.Maps Namespace


IMapVirtualSource Interface

[image]

.NET Framework Class Library
IMapVirtualSource Interface
Members See Also
Interface implemented by items sources for C1MapVirtualLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public interface IMapVirtualSource
Visual Basic (Declaration)
Public Interface IMapVirtualSource

See Also

IMapVirtualSource Members
C1.Silverlight.Maps Namespace


IMapVirtualSource Members

[image] [image]

.NET Framework Class Library
IMapVirtualSource Members
IMapVirtualSource Interface Methods See Also

The IMapVirtualSource type exposes the following members.

Methods

Name | Description
Request | Called from C1MapVirtualLayer when new items are needed for a map region.

See Also

IMapVirtualSource Interface
C1.Silverlight.Maps Namespace


IMapVirtualSource Methods

[image] [image]

.NET Framework Class Library
IMapVirtualSource Methods
IMapVirtualSource Interface See Also

The IMapVirtualSource type exposes the following members.

Methods

Name | Description
Request | Called from C1MapVirtualLayer when new items are needed for a map region.

See Also

IMapVirtualSource Interface
C1.Silverlight.Maps Namespace


Request Method

[image]

.NET Framework Class Library
IMapVirtualSource..::.Request Method
IMapVirtualSource Interface See Also
Called from C1MapVirtualLayer when new items are needed for a map region.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
void Request(
    double minZoom,
    double maxZoom,
    Point lowerLeft,
    Point upperRight,
    Action<ICollection> callback
)
Visual Basic (Declaration)
Sub Request ( _
    minZoom As Double, _
    maxZoom As Double, _
    lowerLeft As Point, _
    upperRight As Point, _
    callback As Action(Of ICollection) _
)

Parameters

minZoom
Type: System..::.Double
The minimum zoom of the region.
maxZoom
Type: System..::.Double
The maximum zoom of the region.
lowerLeft
Type: System.Windows..::.Point
The lower left coordinate of the region, in geographic coordinates.
upperRight
Type: System.Windows..::.Point
The upper right coordinate of the region, in geographic coordinates.
callback
Type: System..::.Action <(Of <( ICollection >)>)
A delegate to call with the elements inside the specified region.

See Also

IMapVirtualSource Interface
C1.Silverlight.Maps Namespace


MapProjection Interface

[image]

.NET Framework Class Library
MapProjection Interface
Members See Also
Interface for projections between geographic coordinates and logical coordinates.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public interface MapProjection
Visual Basic (Declaration)
Public Interface MapProjection

See Also

MapProjection Members
C1.Silverlight.Maps Namespace


MapProjection Members

[image] [image]

.NET Framework Class Library
MapProjection Members
MapProjection Interface Methods See Also

The MapProjection type exposes the following members.

Methods

Name | Description
Project | Projects a geographic coordinate to logical coordinate.
Unproject | Inverse of Project(Point).

See Also

MapProjection Interface
C1.Silverlight.Maps Namespace


MapProjection Methods

[image] [image]

.NET Framework Class Library
MapProjection Methods
MapProjection Interface See Also

The MapProjection type exposes the following members.

Methods

Name | Description
Project | Projects a geographic coordinate to logical coordinate.
Unproject | Inverse of Project(Point).

See Also

MapProjection Interface
C1.Silverlight.Maps Namespace


Project Method

[image]

.NET Framework Class Library
MapProjection..::.Project Method
MapProjection Interface See Also
Projects a geographic coordinate to logical coordinate.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
Point Project(
    Point latLong
)
Visual Basic (Declaration)
Function Project ( _
    latLong As Point _
) As Point

Parameters

latLong
Type: System.Windows..::.Point
The geographic coordinate to project.

Return Value

The logical coordinate corresponding to the geographic coordinate.

See Also

MapProjection Interface
C1.Silverlight.Maps Namespace


Unproject Method

[image]

.NET Framework Class Library
MapProjection..::.Unproject Method
MapProjection Interface See Also
Inverse of Project(Point).

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
Point Unproject(
    Point point
)
Visual Basic (Declaration)
Function Unproject ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point
The logical coordinate to apply the inverse projection.

Return Value

The geographic coordinate corresponding to the logical coordinate.

See Also

MapProjection Interface
C1.Silverlight.Maps Namespace


MapSlice Class

[image]

.NET Framework Class Library
MapSlice Class
Members See Also
Represents a map slice as used in C1MapVirtualLayer.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class MapSlice
Visual Basic (Declaration)
Public Class MapSlice

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Maps..::.MapSlice

See Also

MapSlice Members
C1.Silverlight.Maps Namespace


MapSlice Members

[image] [image]

.NET Framework Class Library
MapSlice Members
MapSlice Class Constructors Methods Properties See Also

The MapSlice type exposes the following members.

Constructors

Name | Description
MapSlice | Initializes a new MapSlice.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
LatSlices | Gets the number of latitude divisions for this slice.
LongSlices | Gets the number of longitude divisions for this slice.
Zoom | Gets the minimum zoom of this slice.

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


MapSlice Constructor

[image]

.NET Framework Class Library
MapSlice Constructor
MapSlice Class See Also
Initializes a new MapSlice.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public MapSlice(
    int latSlices,
    int longSlices,
    double zoom
)
Visual Basic (Declaration)
Public Sub New ( _
    latSlices As Integer, _
    longSlices As Integer, _
    zoom As Double _
)

Parameters

latSlices
Type: System..::.Int32
The number of latitude divisions for this slice.
longSlices
Type: System..::.Int32
The number of longitude divisions for this slice.
zoom
Type: System..::.Double
The minimum zoom of this slice.

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


MapSlice Methods

[image] [image]

.NET Framework Class Library
MapSlice Methods
MapSlice Class See Also

The MapSlice type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


MapSlice Properties

[image] [image]

.NET Framework Class Library
MapSlice Properties
MapSlice Class See Also

The MapSlice type exposes the following members.

Properties

Name | Description
LatSlices | Gets the number of latitude divisions for this slice.
LongSlices | Gets the number of longitude divisions for this slice.
Zoom | Gets the minimum zoom of this slice.

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


LatSlices Property

[image]

.NET Framework Class Library
MapSlice..::.LatSlices Property
MapSlice Class See Also
Gets the number of latitude divisions for this slice.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public int LatSlices { get; }
Visual Basic (Declaration)
Public ReadOnly Property LatSlices As Integer

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


LongSlices Property

[image]

.NET Framework Class Library
MapSlice..::.LongSlices Property
MapSlice Class See Also
Gets the number of longitude divisions for this slice.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public int LongSlices { get; }
Visual Basic (Declaration)
Public ReadOnly Property LongSlices As Integer

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


Zoom Property

[image]

.NET Framework Class Library
MapSlice..::.Zoom Property
MapSlice Class See Also
Gets the minimum zoom of this slice.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public double Zoom { get; }
Visual Basic (Declaration)
Public ReadOnly Property Zoom As Double

See Also

MapSlice Class
C1.Silverlight.Maps Namespace


MercatorProjection Class

[image]

.NET Framework Class Library
MercatorProjection Class
Members See Also
A MapProjection implementation for the Mercator projection.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class MercatorProjection : MapProjection
Visual Basic (Declaration)
Public Class MercatorProjection _
    Implements MapProjection

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Maps..::.MercatorProjection

See Also

MercatorProjection Members
C1.Silverlight.Maps Namespace


MercatorProjection Members

[image] [image]

.NET Framework Class Library
MercatorProjection Members
MercatorProjection Class Constructors Methods See Also

The MercatorProjection type exposes the following members.

Constructors

Name | Description
MercatorProjection | Initializes a new MercatorProjection.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Project |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unproject |

See Also

MercatorProjection Class
C1.Silverlight.Maps Namespace


MercatorProjection Constructor

[image]

.NET Framework Class Library
MercatorProjection Constructor
MercatorProjection Class See Also
Initializes a new MercatorProjection.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public MercatorProjection(
    double scaleX,
    double scaleY,
    double offsetX,
    double offsetY
)
Visual Basic (Declaration)
Public Sub New ( _
    scaleX As Double, _
    scaleY As Double, _
    offsetX As Double, _
    offsetY As Double _
)

Parameters

scaleX
Type: System..::.Double
Scale applied to the x coordinate after the projection.
scaleY
Type: System..::.Double
Scale applied to the y coordinate after the projection.
offsetX
Type: System..::.Double
Offset added to the x coordinate after the projection and after scaling.
offsetY
Type: System..::.Double
Offset added to the y coordinate after the projection and after scaling.

See Also

MercatorProjection Class
C1.Silverlight.Maps Namespace


MercatorProjection Methods

[image] [image]

.NET Framework Class Library
MercatorProjection Methods
MercatorProjection Class See Also

The MercatorProjection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Project |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Unproject |

See Also

MercatorProjection Class
C1.Silverlight.Maps Namespace


Project Method

[image]

.NET Framework Class Library
MercatorProjection..::.Project Method
MercatorProjection Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point Project(
    Point latLong
)
Visual Basic (Declaration)
Public Function Project ( _
    latLong As Point _
) As Point

Parameters

latLong
Type: System.Windows..::.Point

Implements

MapProjection..::.Project(Point)

See Also

MercatorProjection Class
C1.Silverlight.Maps Namespace


Unproject Method

[image]

.NET Framework Class Library
MercatorProjection..::.Unproject Method
MercatorProjection Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public Point Unproject(
    Point point
)
Visual Basic (Declaration)
Public Function Unproject ( _
    point As Point _
) As Point

Parameters

point
Type: System.Windows..::.Point

Implements

MapProjection..::.Unproject(Point)

See Also

MercatorProjection Class
C1.Silverlight.Maps Namespace


QuadTreeTileSource Class

[image]

.NET Framework Class Library
QuadTreeTileSource Class
Members See Also
Base class for MultiScaleTileSource implementation accessing a quad tree of tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public abstract class QuadTreeTileSource : C1MultiScaleTileSource
Visual Basic (Declaration)
Public MustInherit Class QuadTreeTileSource _
    Inherits C1MultiScaleTileSource

Remarks

See http://msdn.microsoft.com/en-us/library/bb545006.aspx for a specific case of the quad tree access pattern.

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.QuadTreeTileSource
C1.Silverlight.Maps..::.VirtualEarthAerialSource
C1.Silverlight.Maps..::.VirtualEarthHybridSource
C1.Silverlight.Maps..::.VirtualEarthRoadSource

See Also

QuadTreeTileSource Members
C1.Silverlight.Maps Namespace


QuadTreeTileSource Members

[image] [image]

.NET Framework Class Library
QuadTreeTileSource Members
QuadTreeTileSource Class Constructors Methods Properties See Also

The QuadTreeTileSource type exposes the following members.

Constructors

Name | Description
QuadTreeTileSource | Initializes a new QuadTreeTileSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Overrides MultiScaleTileSourceGetTileLayers(Int32, Int32, Int32, IList<(Of <(Object>)>)).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

QuadTreeTileSource Class
C1.Silverlight.Maps Namespace


QuadTreeTileSource Constructor

[image]

.NET Framework Class Library
QuadTreeTileSource Constructor
QuadTreeTileSource Class See Also
Initializes a new QuadTreeTileSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public QuadTreeTileSource(
    string uriFormat,
    string code,
    int size,
    int tileSize
)
Visual Basic (Declaration)
Public Sub New ( _
    uriFormat As String, _
    code As String, _
    size As Integer, _
    tileSize As Integer _
)

Parameters

uriFormat
Type: System..::.String
A string with the format of the tile URLs. It must have two string.Format place holder. The first is for the server number (a random number from 0 to 3), the second parameter is the quad tree access string.
code
Type: System..::.String
A four character string containing the characters for the tiles in the following order: upper left, lower left, upper right and lower right.
size
Type: System..::.Int32
The side length in pixels of the source image at the maximum zoom level.
tileSize
Type: System..::.Int32
The side length, in pixels, of a tile.

See Also

QuadTreeTileSource Class
C1.Silverlight.Maps Namespace


QuadTreeTileSource Methods

[image] [image]

.NET Framework Class Library
QuadTreeTileSource Methods
QuadTreeTileSource Class See Also

The QuadTreeTileSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Overrides MultiScaleTileSourceGetTileLayers(Int32, Int32, Int32, IList<(Of <(Object>)>)).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

QuadTreeTileSource Class
C1.Silverlight.Maps Namespace


GetTileLayers Method

[image]

.NET Framework Class Library
QuadTreeTileSource..::.GetTileLayers Method
QuadTreeTileSource Class See Also

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
protected override void GetTileLayers(
    int level,
    int x,
    int y,
    IList<Object> sources
)
Visual Basic (Declaration)
Protected Overrides Sub GetTileLayers ( _
    level As Integer, _
    x As Integer, _
    y As Integer, _
    sources As IList(Of Object) _
)

Parameters

level
Type: System..::.Int32
x
Type: System..::.Int32
y
Type: System..::.Int32
sources
Type: System.Collections.Generic..::.IList <(Of <( Object >)>)

See Also

QuadTreeTileSource Class
C1.Silverlight.Maps Namespace


QuadTreeTileSource Properties

[image] [image]

.NET Framework Class Library
QuadTreeTileSource Properties
QuadTreeTileSource Class See Also

The QuadTreeTileSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

QuadTreeTileSource Class
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Class

[image]

.NET Framework Class Library
VirtualEarthAerialSource Class
Members See Also
A MultiScaleTileSource accessing Microsoft's Virtual Earth aerial tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class VirtualEarthAerialSource : QuadTreeTileSource
Visual Basic (Declaration)
Public Class VirtualEarthAerialSource _
    Inherits QuadTreeTileSource

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.QuadTreeTileSource
C1.Silverlight.Maps..::.VirtualEarthAerialSource

See Also

VirtualEarthAerialSource Members
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Members

[image] [image]

.NET Framework Class Library
VirtualEarthAerialSource Members
VirtualEarthAerialSource Class Constructors Methods Fields Properties See Also

The VirtualEarthAerialSource type exposes the following members.

Constructors

Name | Description
VirtualEarthAerialSource | Initializes a new VirtualEarthAerialSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Constructor

[image]

.NET Framework Class Library
VirtualEarthAerialSource Constructor
VirtualEarthAerialSource Class See Also
Initializes a new VirtualEarthAerialSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public VirtualEarthAerialSource()
Visual Basic (Declaration)
Public Sub New

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Fields

[image] [image]

.NET Framework Class Library
VirtualEarthAerialSource Fields
VirtualEarthAerialSource Class See Also

The VirtualEarthAerialSource type exposes the following members.

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


UriFormat Field

[image]

.NET Framework Class Library
VirtualEarthAerialSource..::.UriFormat Field
VirtualEarthAerialSource Class See Also
The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static string UriFormat
Visual Basic (Declaration)
Public Shared UriFormat As String

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Methods

[image] [image]

.NET Framework Class Library
VirtualEarthAerialSource Methods
VirtualEarthAerialSource Class See Also

The VirtualEarthAerialSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


VirtualEarthAerialSource Properties

[image] [image]

.NET Framework Class Library
VirtualEarthAerialSource Properties
VirtualEarthAerialSource Class See Also

The VirtualEarthAerialSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthAerialSource Class
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Class

[image]

.NET Framework Class Library
VirtualEarthHybridSource Class
Members See Also
A MultiScaleTileSource accessing Microsoft's Virtual Earth hybrid tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class VirtualEarthHybridSource : QuadTreeTileSource
Visual Basic (Declaration)
Public Class VirtualEarthHybridSource _
    Inherits QuadTreeTileSource

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.QuadTreeTileSource
C1.Silverlight.Maps..::.VirtualEarthHybridSource

See Also

VirtualEarthHybridSource Members
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Members

[image] [image]

.NET Framework Class Library
VirtualEarthHybridSource Members
VirtualEarthHybridSource Class Constructors Methods Fields Properties See Also

The VirtualEarthHybridSource type exposes the following members.

Constructors

Name | Description
VirtualEarthHybridSource | Initializes a new VirtualEarthHybridSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Constructor

[image]

.NET Framework Class Library
VirtualEarthHybridSource Constructor
VirtualEarthHybridSource Class See Also
Initializes a new VirtualEarthHybridSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public VirtualEarthHybridSource()
Visual Basic (Declaration)
Public Sub New

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Fields

[image] [image]

.NET Framework Class Library
VirtualEarthHybridSource Fields
VirtualEarthHybridSource Class See Also

The VirtualEarthHybridSource type exposes the following members.

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


UriFormat Field

[image]

.NET Framework Class Library
VirtualEarthHybridSource..::.UriFormat Field
VirtualEarthHybridSource Class See Also
The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static string UriFormat
Visual Basic (Declaration)
Public Shared UriFormat As String

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Methods

[image] [image]

.NET Framework Class Library
VirtualEarthHybridSource Methods
VirtualEarthHybridSource Class See Also

The VirtualEarthHybridSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


VirtualEarthHybridSource Properties

[image] [image]

.NET Framework Class Library
VirtualEarthHybridSource Properties
VirtualEarthHybridSource Class See Also

The VirtualEarthHybridSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthHybridSource Class
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Class

[image]

.NET Framework Class Library
VirtualEarthRoadSource Class
Members See Also
A MultiScaleTileSource accessing Microsoft's Virtual Earth road tiles.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public class VirtualEarthRoadSource : QuadTreeTileSource
Visual Basic (Declaration)
Public Class VirtualEarthRoadSource _
    Inherits QuadTreeTileSource

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
MultiScaleTileSource
C1.Silverlight.Maps..::.C1MultiScaleTileSource
C1.Silverlight.Maps..::.QuadTreeTileSource
C1.Silverlight.Maps..::.VirtualEarthRoadSource

See Also

VirtualEarthRoadSource Members
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Members

[image] [image]

.NET Framework Class Library
VirtualEarthRoadSource Members
VirtualEarthRoadSource Class Constructors Methods Fields Properties See Also

The VirtualEarthRoadSource type exposes the following members.

Constructors

Name | Description
VirtualEarthRoadSource | Initializes a new VirtualEarthRoadSource.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Constructor

[image]

.NET Framework Class Library
VirtualEarthRoadSource Constructor
VirtualEarthRoadSource Class See Also
Initializes a new VirtualEarthRoadSource.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public VirtualEarthRoadSource()
Visual Basic (Declaration)
Public Sub New

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Fields

[image] [image]

.NET Framework Class Library
VirtualEarthRoadSource Fields
VirtualEarthRoadSource Class See Also

The VirtualEarthRoadSource type exposes the following members.

Fields

Name | Description
UriFormat | The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


UriFormat Field

[image]

.NET Framework Class Library
VirtualEarthRoadSource..::.UriFormat Field
VirtualEarthRoadSource Class See Also
The URI format used for accessing the tiles. It might be necessary to change this if Microsoft changes the tiles URLs.

Namespace: C1.Silverlight.Maps
Assembly: C1.Silverlight.Maps (in C1.Silverlight.Maps.dll)

Syntax

C#
public static string UriFormat
Visual Basic (Declaration)
Public Shared UriFormat As String

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Methods

[image] [image]

.NET Framework Class Library
VirtualEarthRoadSource Methods
VirtualEarthRoadSource Class See Also

The VirtualEarthRoadSource type exposes the following members.

Methods

Name | Description
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTileLayers | (Inherited from QuadTreeTileSource.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from DependencyObject.)
InvalidateTileLayer | (Inherited from MultiScaleTileSource.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadLocalValue | (Inherited from DependencyObject.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


VirtualEarthRoadSource Properties

[image] [image]

.NET Framework Class Library
VirtualEarthRoadSource Properties
VirtualEarthRoadSource Class See Also

The VirtualEarthRoadSource type exposes the following members.

Properties

Name | Description
Dispatcher | (Inherited from DependencyObject.)

See Also

VirtualEarthRoadSource Class
C1.Silverlight.Maps Namespace


C1.Silverlight.RichTextBox Namespace

[image]

.NET Framework Class Library
C1.Silverlight.RichTextBox Namespace

Classes

Class | Description
C1RichTextBox | Represents a rich text editing control.
C1RichTextBoxToolbar | Represents a toolbar for a C1RichTextBox.
C1SimpleColorPicker | Color picker used in C1RichTextBoxToolbar
C1TextChangedEventArgs | Provides data for the TextChanged event.
C1ThicknessPicker | Control used to pick a Thickness value.
EditExtensions | Provides extensions methods for editing a C1Document.
RequestNavigateEventArgs | Provides data for the RequestNavigate event.

Enumerations

Enumeration | Description
HtmlEncoding | Defines different encodings for interpreting a TextBlock contents as HTML.
NavigationMode | Defines the mode in which C1RichTextBox fires RequestNavigate events.
TextChangedAction |


C1RichTextBox Class

[image]

.NET Framework Class Library
C1RichTextBox Class
Members See Also
Represents a rich text editing control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[TemplatePartAttribute(Name = "VerticalScrollBar", Type = typeof(ScrollBar))]
[TemplateVisualStateAttribute(Name = "Unfocused", GroupName = "FocusStates")]
[TemplateVisualStateAttribute(Name = "ReadOnly", GroupName = "WritableStates")]
[TemplateVisualStateAttribute(Name = "Focused", GroupName = "FocusStates")]
[TemplatePartAttribute(Name = "Content", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "Root", Type = typeof(Panel))]
[TemplatePartAttribute(Name = "HorizontalScrollBar", Type = typeof(ScrollBar))]
[TemplateVisualStateAttribute(Name = "Writable", GroupName = "WritableStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1RichTextBox : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "VerticalScrollBar", Type := GetType(ScrollBar))> _
<TemplateVisualStateAttribute(Name := "Unfocused", GroupName := "FocusStates")> _
<TemplateVisualStateAttribute(Name := "ReadOnly", GroupName := "WritableStates")> _
<TemplateVisualStateAttribute(Name := "Focused", GroupName := "FocusStates")> _
<TemplatePartAttribute(Name := "Content", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(Panel))> _
<TemplatePartAttribute(Name := "HorizontalScrollBar", Type := GetType(ScrollBar))> _
<TemplateVisualStateAttribute(Name := "Writable", GroupName := "WritableStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1RichTextBox _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.RichTextBox..::.C1RichTextBox

See Also

C1RichTextBox Members
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Members

[image] [image]

.NET Framework Class Library
C1RichTextBox Members
C1RichTextBox Class Constructors Methods Fields Properties Events See Also

The C1RichTextBox type exposes the following members.

Constructors

Name | Description
C1RichTextBox | Initializes a new instance of a C1RichTextBox.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
ChangeVisualStateWritable |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHtml | Get the HTML content with the selected encoding.
GetPositionFromPoint | Returns the closest text position to a given point in the rendered document.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ScrollIntoView | Scrolls the C1RichTextBox to bring a C1TextElement into view.
SelectAll | Selects all the text in the control.
SetBinding | (Inherited from FrameworkElement.)
SetHtml | Sets the HTML content.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AcceptsReturnProperty | Identifies the AcceptsReturn dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
HideSelectionProperty | Identifies the HideSelection dependency property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property.

Properties

Name | Description
AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
Document | Gets or sets the C1Document for the C1RichTextBox
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HideSelection | Gets or sets whether the control should highlight the selection when not in focus.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.
Html | Gets or sets the content of the C1RichTextBox in HTML format.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsReadOnly | Gets or sets whether the user is allowed to modify the text in the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NavigationMode | Indicates when the RequestNavigate event is fired.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Selection | Gets or sets the C1TextRange selected in the C1RichTextBox's document.
SelectionBackground | Gets or sets the brush used to fill the background of the selected text
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text inside the C1Document of the C1RichTextBox.
TextWrapping | Gets or sets whether the control should wrap the text to fit its width.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ElementMouseEnter | Fires when the mouse enters a text element.
ElementMouseLeave | Fires when the mouse leaves a text element.
ElementMouseLeftButtonDown | Fires when the left mouse button is pressed over a text element.
ElementMouseLeftButtonUp | Fires when the left mouse button is released over a text element.
ElementMouseMove | Fires when the mouse moves over a text element.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RequestNavigate | Fires when the user clicks on a C1Hyperlink.
SelectionChanged | Fires when Selection changes.
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | Fired when there is a change in the document.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Constructor

[image]

.NET Framework Class Library
C1RichTextBox Constructor
C1RichTextBox Class See Also
Initializes a new instance of a C1RichTextBox.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1RichTextBox()
Visual Basic (Declaration)
Public Sub New

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Fields

[image] [image]

.NET Framework Class Library
C1RichTextBox Fields
C1RichTextBox Class See Also

The C1RichTextBox type exposes the following members.

Fields

Name | Description
AcceptsReturnProperty | Identifies the AcceptsReturn dependency property.
DisabledStyleProperty | Identifies the DisabledStyle dependency property.
FocusStyleProperty | Identifies the FocusStyle dependency property.
HideSelectionProperty | Identifies the HideSelection dependency property.
HorizontalScrollBarVisibilityProperty | Identifies the HorizontalScrollBarVisibility dependency property.
IsFocusedProperty | Identifies the IsFocused dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
IsReadOnlyProperty | Identifies the IsReadOnly dependency property.
TextWrappingProperty | Identifies the TextWrapping dependency property.
VerticalScrollBarVisibilityProperty | Identifies the VerticalScrollBarVisibility dependency property.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


AcceptsReturnProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.AcceptsReturnProperty Field
C1RichTextBox Class See Also
Identifies the AcceptsReturn dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty AcceptsReturnProperty
Visual Basic (Declaration)
Public Shared ReadOnly AcceptsReturnProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


DisabledStyleProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.DisabledStyleProperty Field
C1RichTextBox Class See Also
Identifies the DisabledStyle dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty DisabledStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DisabledStyleProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.FocusStyleProperty Field
C1RichTextBox Class See Also
Identifies the FocusStyle dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


HideSelectionProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.HideSelectionProperty Field
C1RichTextBox Class See Also
Identifies the HideSelection dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty HideSelectionProperty
Visual Basic (Declaration)
Public Shared ReadOnly HideSelectionProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.HorizontalScrollBarVisibilityProperty Field
C1RichTextBox Class See Also
Identifies the HorizontalScrollBarVisibility dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty HorizontalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalScrollBarVisibilityProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsFocusedProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.IsFocusedProperty Field
C1RichTextBox Class See Also
Identifies the IsFocused dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty IsFocusedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFocusedProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.IsMouseOverProperty Field
C1RichTextBox Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsReadOnlyProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.IsReadOnlyProperty Field
C1RichTextBox Class See Also
Identifies the IsReadOnly dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty IsReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


TextWrappingProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.TextWrappingProperty Field
C1RichTextBox Class See Also
Identifies the TextWrapping dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty TextWrappingProperty
Visual Basic (Declaration)
Public Shared ReadOnly TextWrappingProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


VerticalScrollBarVisibilityProperty Field

[image]

.NET Framework Class Library
C1RichTextBox..::.VerticalScrollBarVisibilityProperty Field
C1RichTextBox Class See Also
Identifies the VerticalScrollBarVisibility dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static readonly DependencyProperty VerticalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalScrollBarVisibilityProperty As DependencyProperty

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Methods

[image] [image]

.NET Framework Class Library
C1RichTextBox Methods
C1RichTextBox Class See Also

The C1RichTextBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateFocus |
ChangeVisualStateWritable |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetHtml | Get the HTML content with the selected encoding.
GetPositionFromPoint | Returns the closest text position to a given point in the rendered document.
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
ScrollIntoView | Scrolls the C1RichTextBox to bring a C1TextElement into view.
SelectAll | Selects all the text in the control.
SetBinding | (Inherited from FrameworkElement.)
SetHtml | Sets the HTML content.
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1RichTextBox..::.ChangeVisualStateCommon Method
C1RichTextBox Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateFocus Method

[image]

.NET Framework Class Library
C1RichTextBox..::.ChangeVisualStateFocus Method
C1RichTextBox Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateFocus(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateFocus ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateWritable Method

[image]

.NET Framework Class Library
C1RichTextBox..::.ChangeVisualStateWritable Method
C1RichTextBox Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateWritable(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateWritable ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


GetHtml Method

[image]

.NET Framework Class Library
C1RichTextBox..::.GetHtml Method
C1RichTextBox Class See Also
Get the HTML content with the selected encoding.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string GetHtml(
    HtmlEncoding encoding
)
Visual Basic (Declaration)
Public Function GetHtml ( _
    encoding As HtmlEncoding _
) As String

Parameters

encoding
Type: C1.Silverlight.RichTextBox..::.HtmlEncoding
The HtmlEncoding to use.

Return Value

A string containing an HTML version of the C1RichTextBox contents.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


GetPositionFromPoint Method

[image]

.NET Framework Class Library
C1RichTextBox..::.GetPositionFromPoint Method
C1RichTextBox Class See Also
Returns the closest text position to a given point in the rendered document.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition GetPositionFromPoint(
    Point point
)
Visual Basic (Declaration)
Public Function GetPositionFromPoint ( _
    point As Point _
) As C1TextPosition

Parameters

point
Type: System.Windows..::.Point
A Point

Return Value

The closest text position to a given point in the rendered document.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1RichTextBox..::.HitTest Method
C1RichTextBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1RichTextBox Class
C1RichTextBox Members
C1.Silverlight.RichTextBox Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1RichTextBox..::.OnApplyTemplate Method
C1RichTextBox Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ScrollIntoView Method

[image]

.NET Framework Class Library
C1RichTextBox..::.ScrollIntoView Method
C1RichTextBox Class See Also
Scrolls the C1RichTextBox to bring a C1TextElement into view.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void ScrollIntoView(
    C1TextElement element
)
Visual Basic (Declaration)
Public Sub ScrollIntoView ( _
    element As C1TextElement _
)

Parameters

element
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextElement

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


SelectAll Method

[image]

.NET Framework Class Library
C1RichTextBox..::.SelectAll Method
C1RichTextBox Class See Also
Selects all the text in the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void SelectAll()
Visual Basic (Declaration)
Public Sub SelectAll

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


SetHtml Method

[image]

.NET Framework Class Library
C1RichTextBox..::.SetHtml Method
C1RichTextBox Class See Also
Sets the HTML content.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void SetHtml(
    string html,
    Uri baseUri
)
Visual Basic (Declaration)
Public Sub SetHtml ( _
    html As String, _
    baseUri As Uri _
)

Parameters

html
Type: System..::.String
A string containing HTML content.
baseUri
Type: System..::.Uri
The base Uri used to resolve links and image sources.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Properties

[image] [image]

.NET Framework Class Library
C1RichTextBox Properties
C1RichTextBox Class See Also

The C1RichTextBox type exposes the following members.

Properties

Name | Description
AcceptsReturn | Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key.
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DisabledStyle | Gets or sets the style of the disabled element.
Dispatcher | (Inherited from DependencyObject.)
Document | Gets or sets the C1Document for the C1RichTextBox
FocusStyle | Gets or sets the style of the focus element.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HideSelection | Gets or sets whether the control should highlight the selection when not in focus.
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.
Html | Gets or sets the content of the C1RichTextBox in HTML format.
IsFocused | Returns true if the control has the focus.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsReadOnly | Gets or sets whether the user is allowed to modify the text in the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
NavigationMode | Indicates when the RequestNavigate event is fired.
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Selection | Gets or sets the C1TextRange selected in the C1RichTextBox's document.
SelectionBackground | Gets or sets the brush used to fill the background of the selected text
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Text | Gets or sets the text inside the C1Document of the C1RichTextBox.
TextWrapping | Gets or sets whether the control should wrap the text to fit its width.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility | Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


AcceptsReturn Property

[image]

.NET Framework Class Library
C1RichTextBox..::.AcceptsReturn Property
C1RichTextBox Class See Also
Gets or sets a value that indicates how the text editing control responds when the user presses the ENTER key.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool AcceptsReturn { get; set; }
Visual Basic (Declaration)
Public Property AcceptsReturn As Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


DisabledStyle Property

[image]

.NET Framework Class Library
C1RichTextBox..::.DisabledStyle Property
C1RichTextBox Class See Also
Gets or sets the style of the disabled element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Style DisabledStyle { get; set; }
Visual Basic (Declaration)
Public Property DisabledStyle As Style

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


Document Property

[image]

.NET Framework Class Library
C1RichTextBox..::.Document Property
C1RichTextBox Class See Also
Gets or sets the C1Document for the C1RichTextBox

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Document Document { get; set; }
Visual Basic (Declaration)
Public Property Document As C1Document

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1RichTextBox..::.FocusStyle Property
C1RichTextBox Class See Also
Gets or sets the style of the focus element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


HideSelection Property

[image]

.NET Framework Class Library
C1RichTextBox..::.HideSelection Property
C1RichTextBox Class See Also
Gets or sets whether the control should highlight the selection when not in focus.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool HideSelection { get; set; }
Visual Basic (Declaration)
Public Property HideSelection As Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


HorizontalScrollBarVisibility Property

[image]

.NET Framework Class Library
C1RichTextBox..::.HorizontalScrollBarVisibility Property
C1RichTextBox Class See Also
Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


Html Property

[image]

.NET Framework Class Library
C1RichTextBox..::.Html Property
C1RichTextBox Class See Also
Gets or sets the content of the C1RichTextBox in HTML format.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1721:PropertyNamesShouldNotMatchGetMethods")]
public string Html { get; set; }
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1721:PropertyNamesShouldNotMatchGetMethods")> _
Public Property Html As String

Remarks

The HTML returned when getting uses StyleSheet encoding.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsFocused Property

[image]

.NET Framework Class Library
C1RichTextBox..::.IsFocused Property
C1RichTextBox Class See Also
Returns true if the control has the focus.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsFocused { get; internal set; }
Visual Basic (Declaration)
Public Property IsFocused As Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1RichTextBox..::.IsMouseOver Property
C1RichTextBox Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
C1RichTextBox..::.IsReadOnly Property
C1RichTextBox Class See Also
Gets or sets whether the user is allowed to modify the text in the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


NavigationMode Property

[image]

.NET Framework Class Library
C1RichTextBox..::.NavigationMode Property
C1RichTextBox Class See Also
Indicates when the RequestNavigate event is fired.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public NavigationMode NavigationMode { get; set; }
Visual Basic (Declaration)
Public Property NavigationMode As NavigationMode

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


Selection Property

[image]

.NET Framework Class Library
C1RichTextBox..::.Selection Property
C1RichTextBox Class See Also
Gets or sets the C1TextRange selected in the C1RichTextBox's document.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextRange Selection { get; set; }
Visual Basic (Declaration)
Public Property Selection As C1TextRange

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


SelectionBackground Property

[image]

.NET Framework Class Library
C1RichTextBox..::.SelectionBackground Property
C1RichTextBox Class See Also
Gets or sets the brush used to fill the background of the selected text

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush SelectionBackground { get; set; }
Visual Basic (Declaration)
Public Property SelectionBackground As Brush

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


Text Property

[image]

.NET Framework Class Library
C1RichTextBox..::.Text Property
C1RichTextBox Class See Also
Gets or sets the text inside the C1Document of the C1RichTextBox.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


TextWrapping Property

[image]

.NET Framework Class Library
C1RichTextBox..::.TextWrapping Property
C1RichTextBox Class See Also
Gets or sets whether the control should wrap the text to fit its width.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextWrapping TextWrapping { get; set; }
Visual Basic (Declaration)
Public Property TextWrapping As TextWrapping

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


VerticalScrollBarVisibility Property

[image]

.NET Framework Class Library
C1RichTextBox..::.VerticalScrollBarVisibility Property
C1RichTextBox Class See Also
Gets or sets a value that indicates whether a horizontal ScrollBar should be displayed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property VerticalScrollBarVisibility As ScrollBarVisibility

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBox Events

[image] [image]

.NET Framework Class Library
C1RichTextBox Events
C1RichTextBox Class See Also

The C1RichTextBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ElementMouseEnter | Fires when the mouse enters a text element.
ElementMouseLeave | Fires when the mouse leaves a text element.
ElementMouseLeftButtonDown | Fires when the left mouse button is pressed over a text element.
ElementMouseLeftButtonUp | Fires when the left mouse button is released over a text element.
ElementMouseMove | Fires when the mouse moves over a text element.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RequestNavigate | Fires when the user clicks on a C1Hyperlink.
SelectionChanged | Fires when Selection changes.
SizeChanged | (Inherited from FrameworkElement.)
TextChanged | Fired when there is a change in the document.

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ElementMouseEnter Event

[image]

.NET Framework Class Library
C1RichTextBox..::.ElementMouseEnter Event
C1RichTextBox Class See Also
Fires when the mouse enters a text element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event MouseEventHandler ElementMouseEnter
Visual Basic (Declaration)
Public Event ElementMouseEnter As MouseEventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ElementMouseLeave Event

[image]

.NET Framework Class Library
C1RichTextBox..::.ElementMouseLeave Event
C1RichTextBox Class See Also
Fires when the mouse leaves a text element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event MouseEventHandler ElementMouseLeave
Visual Basic (Declaration)
Public Event ElementMouseLeave As MouseEventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ElementMouseLeftButtonDown Event

[image]

.NET Framework Class Library
C1RichTextBox..::.ElementMouseLeftButtonDown Event
C1RichTextBox Class See Also
Fires when the left mouse button is pressed over a text element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event MouseButtonEventHandler ElementMouseLeftButtonDown
Visual Basic (Declaration)
Public Event ElementMouseLeftButtonDown As MouseButtonEventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ElementMouseLeftButtonUp Event

[image]

.NET Framework Class Library
C1RichTextBox..::.ElementMouseLeftButtonUp Event
C1RichTextBox Class See Also
Fires when the left mouse button is released over a text element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event MouseButtonEventHandler ElementMouseLeftButtonUp
Visual Basic (Declaration)
Public Event ElementMouseLeftButtonUp As MouseButtonEventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


ElementMouseMove Event

[image]

.NET Framework Class Library
C1RichTextBox..::.ElementMouseMove Event
C1RichTextBox Class See Also
Fires when the mouse moves over a text element.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event MouseEventHandler ElementMouseMove
Visual Basic (Declaration)
Public Event ElementMouseMove As MouseEventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1RichTextBox..::.IsMouseOverChanged Event
C1RichTextBox Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


RequestNavigate Event

[image]

.NET Framework Class Library
C1RichTextBox..::.RequestNavigate Event
C1RichTextBox Class See Also
Fires when the user clicks on a C1Hyperlink.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event EventHandler<RequestNavigateEventArgs> RequestNavigate
Visual Basic (Declaration)
Public Event RequestNavigate As EventHandler(Of RequestNavigateEventArgs)

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


SelectionChanged Event

[image]

.NET Framework Class Library
C1RichTextBox..::.SelectionChanged Event
C1RichTextBox Class See Also
Fires when Selection changes.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event EventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As EventHandler

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


TextChanged Event

[image]

.NET Framework Class Library
C1RichTextBox..::.TextChanged Event
C1RichTextBox Class See Also
Fired when there is a change in the document.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event EventHandler<C1TextChangedEventArgs> TextChanged
Visual Basic (Declaration)
Public Event TextChanged As EventHandler(Of C1TextChangedEventArgs)

See Also

C1RichTextBox Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Class

[image]

.NET Framework Class Library
C1RichTextBoxToolbar Class
Members See Also
Represents a toolbar for a C1RichTextBox.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[TemplatePartAttribute(Name = "DecreaseFontSize", Type = typeof(Button))]
[TemplatePartAttribute(Name = "TextWrapping", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "InsertImage", Type = typeof(Button))]
[TemplatePartAttribute(Name = "InsertHyperlink", Type = typeof(Button))]
[TemplatePartAttribute(Name = "InsertSymbol", Type = typeof(C1ComboBox))]
[TemplatePartAttribute(Name = "UpperCase", Type = typeof(Button))]
[TemplatePartAttribute(Name = "OrderedList", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "CapitalizeWords", Type = typeof(Button))]
[TemplatePartAttribute(Name = "ToggleCase", Type = typeof(Button))]
[TemplatePartAttribute(Name = "RemoveHyperlink", Type = typeof(Button))]
[TemplatePartAttribute(Name = "Foreground", Type = typeof(C1SimpleColorPicker))]
[TemplatePartAttribute(Name = "InlineBackground", Type = typeof(C1SimpleColorPicker))]
[TemplatePartAttribute(Name = "BlockBackground", Type = typeof(C1SimpleColorPicker))]
[TemplatePartAttribute(Name = "BorderBrush", Type = typeof(C1SimpleColorPicker))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", MessageId = "Toolbar")]
[TemplatePartAttribute(Name = "FontSize", Type = typeof(C1ComboBox))]
[TemplatePartAttribute(Name = "Bold", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "IncreaseFontSize", Type = typeof(Button))]
[TemplatePartAttribute(Name = "Italic", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "FontFamily", Type = typeof(C1ComboBox))]
[TemplatePartAttribute(Name = "Margin", Type = typeof(C1ThicknessPicker))]
[TemplatePartAttribute(Name = "Padding", Type = typeof(C1ThicknessPicker))]
[TemplatePartAttribute(Name = "Border", Type = typeof(C1ThicknessPicker))]
[TemplatePartAttribute(Name = "LowerCase", Type = typeof(Button))]
[TemplatePartAttribute(Name = "Underline", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "Superscript", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "Subscript", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "LeftAlign", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "CenterAlign", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "RightAlign", Type = typeof(ToggleButton))]
[TemplatePartAttribute(Name = "UnorderedList", Type = typeof(ToggleButton))]
public class C1RichTextBoxToolbar : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "DecreaseFontSize", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "TextWrapping", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "InsertImage", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "InsertHyperlink", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "InsertSymbol", Type := GetType(C1ComboBox))> _
<TemplatePartAttribute(Name := "UpperCase", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "OrderedList", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "CapitalizeWords", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "ToggleCase", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "RemoveHyperlink", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "Foreground", Type := GetType(C1SimpleColorPicker))> _
<TemplatePartAttribute(Name := "InlineBackground", Type := GetType(C1SimpleColorPicker))> _
<TemplatePartAttribute(Name := "BlockBackground", Type := GetType(C1SimpleColorPicker))> _
<TemplatePartAttribute(Name := "BorderBrush", Type := GetType(C1SimpleColorPicker))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1702:CompoundWordsShouldBeCasedCorrectly", MessageId := "Toolbar")> _
<TemplatePartAttribute(Name := "FontSize", Type := GetType(C1ComboBox))> _
<TemplatePartAttribute(Name := "Bold", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "IncreaseFontSize", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "Italic", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "FontFamily", Type := GetType(C1ComboBox))> _
<TemplatePartAttribute(Name := "Margin", Type := GetType(C1ThicknessPicker))> _
<TemplatePartAttribute(Name := "Padding", Type := GetType(C1ThicknessPicker))> _
<TemplatePartAttribute(Name := "Border", Type := GetType(C1ThicknessPicker))> _
<TemplatePartAttribute(Name := "LowerCase", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "Underline", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "Superscript", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "Subscript", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "LeftAlign", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "CenterAlign", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "RightAlign", Type := GetType(ToggleButton))> _
<TemplatePartAttribute(Name := "UnorderedList", Type := GetType(ToggleButton))> _
Public Class C1RichTextBoxToolbar _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.RichTextBox..::.C1RichTextBoxToolbar

See Also

C1RichTextBoxToolbar Members
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Members

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar Members
C1RichTextBoxToolbar Class Constructors Methods Fields Properties Events See Also

The C1RichTextBoxToolbar type exposes the following members.

Constructors

Name | Description
C1RichTextBoxToolbar | Initializes a new instance of a C1RichTextBoxToolbar.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RichTextBox | Gets or sets the C1RichTextBox associated with this C1RichTextBoxToolbar.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Constructor

[image]

.NET Framework Class Library
C1RichTextBoxToolbar Constructor
C1RichTextBoxToolbar Class See Also
Initializes a new instance of a C1RichTextBoxToolbar.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public C1RichTextBoxToolbar()
Visual Basic (Declaration)
Public Sub New

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Fields

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar Fields
C1RichTextBoxToolbar Class See Also

The C1RichTextBoxToolbar type exposes the following members.

Fields

Name | Description
IsMouseOverProperty | Identifies the IsMouseOver dependency property.

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.IsMouseOverProperty Field
C1RichTextBoxToolbar Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Methods

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar Methods
C1RichTextBoxToolbar Class See Also

The C1RichTextBoxToolbar type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.ChangeVisualStateCommon Method
C1RichTextBoxToolbar Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.HitTest Method
C1RichTextBoxToolbar Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1RichTextBoxToolbar Class
C1RichTextBoxToolbar Members
C1.Silverlight.RichTextBox Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.OnApplyTemplate Method
C1RichTextBoxToolbar Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Properties

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar Properties
C1RichTextBoxToolbar Class See Also

The C1RichTextBoxToolbar type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RichTextBox | Gets or sets the C1RichTextBox associated with this C1RichTextBoxToolbar.
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.IsMouseOver Property
C1RichTextBoxToolbar Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


RichTextBox Property

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.RichTextBox Property
C1RichTextBoxToolbar Class See Also
Gets or sets the C1RichTextBox associated with this C1RichTextBoxToolbar.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public C1RichTextBox RichTextBox { get; set; }
Visual Basic (Declaration)
Public Property RichTextBox As C1RichTextBox

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1RichTextBoxToolbar Events

[image] [image]

.NET Framework Class Library
C1RichTextBoxToolbar Events
C1RichTextBoxToolbar Class See Also

The C1RichTextBoxToolbar type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1RichTextBoxToolbar..::.IsMouseOverChanged Event
C1RichTextBoxToolbar Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1RichTextBoxToolbar Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Class

[image]

.NET Framework Class Library
C1SimpleColorPicker Class
Members See Also
Color picker used in C1RichTextBoxToolbar

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[TemplatePartAttribute(Name = "ApplyButton", Type = typeof(ToggleButton))]
[ContentPropertyAttribute("Icon")]
[TemplatePartAttribute(Name = "Combo", Type = typeof(C1ComboBox))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
public class C1SimpleColorPicker : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "ApplyButton", Type := GetType(ToggleButton))> _
<ContentPropertyAttribute("Icon")> _
<TemplatePartAttribute(Name := "Combo", Type := GetType(C1ComboBox))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
Public Class C1SimpleColorPicker _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.RichTextBox..::.C1SimpleColorPicker

See Also

C1SimpleColorPicker Members
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Members

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker Members
C1SimpleColorPicker Class Constructors Methods Fields Properties Events See Also

The C1SimpleColorPicker type exposes the following members.

Constructors

Name | Description
C1SimpleColorPicker | Initializes a new instance of a C1SimpleColorPicker.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
ComboBoxStyleProperty | Identifies the ComboBoxStyle dependency property.
IconProperty | Identifies the Icon dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ToggleButtonStyleProperty | Identifies the ToggleButtonStyle dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Brush | Gets or sets the selected brush.
Clip | (Inherited from UIElement.)
ComboBoxStyle | Gets or sets the C1ComboBox style for the toggle button used to select the current brush.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets the icon.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToggleButtonStyle | Gets or sets the ToggleButton style for the toggle button used to apply the current brush.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
BrushSelected | Fires when the Brush property changes.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Constructor

[image]

.NET Framework Class Library
C1SimpleColorPicker Constructor
C1SimpleColorPicker Class See Also
Initializes a new instance of a C1SimpleColorPicker.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public C1SimpleColorPicker()
Visual Basic (Declaration)
Public Sub New

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Fields

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker Fields
C1SimpleColorPicker Class See Also

The C1SimpleColorPicker type exposes the following members.

Fields

Name | Description
BrushProperty | Identifies the Brush dependency property.
ComboBoxStyleProperty | Identifies the ComboBoxStyle dependency property.
IconProperty | Identifies the Icon dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ToggleButtonStyleProperty | Identifies the ToggleButtonStyle dependency property.

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


BrushProperty Field

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.BrushProperty Field
C1SimpleColorPicker Class See Also
Identifies the Brush dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty BrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly BrushProperty As DependencyProperty

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


ComboBoxStyleProperty Field

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.ComboBoxStyleProperty Field
C1SimpleColorPicker Class See Also
Identifies the ComboBoxStyle dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty ComboBoxStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ComboBoxStyleProperty As DependencyProperty

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


IconProperty Field

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.IconProperty Field
C1SimpleColorPicker Class See Also
Identifies the Icon dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty IconProperty
Visual Basic (Declaration)
Public Shared ReadOnly IconProperty As DependencyProperty

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.IsMouseOverProperty Field
C1SimpleColorPicker Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


ToggleButtonStyleProperty Field

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.ToggleButtonStyleProperty Field
C1SimpleColorPicker Class See Also
Identifies the ToggleButtonStyle dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty ToggleButtonStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ToggleButtonStyleProperty As DependencyProperty

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Methods

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker Methods
C1SimpleColorPicker Class See Also

The C1SimpleColorPicker type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.ChangeVisualStateCommon Method
C1SimpleColorPicker Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker..::.HitTest Method
C1SimpleColorPicker Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1SimpleColorPicker Class
C1SimpleColorPicker Members
C1.Silverlight.RichTextBox Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.OnApplyTemplate Method
C1SimpleColorPicker Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Properties

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker Properties
C1SimpleColorPicker Class See Also

The C1SimpleColorPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Brush | Gets or sets the selected brush.
Clip | (Inherited from UIElement.)
ComboBoxStyle | Gets or sets the C1ComboBox style for the toggle button used to select the current brush.
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
Icon | Gets or sets the icon.
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
ToggleButtonStyle | Gets or sets the ToggleButton style for the toggle button used to apply the current brush.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


Brush Property

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.Brush Property
C1SimpleColorPicker Class See Also
Gets or sets the selected brush.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Brush Brush { get; set; }
Visual Basic (Declaration)
Public Property Brush As Brush

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


ComboBoxStyle Property

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.ComboBoxStyle Property
C1SimpleColorPicker Class See Also
Gets or sets the C1ComboBox style for the toggle button used to select the current brush.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Style ComboBoxStyle { get; set; }
Visual Basic (Declaration)
Public Property ComboBoxStyle As Style

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


Icon Property

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.Icon Property
C1SimpleColorPicker Class See Also
Gets or sets the icon.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Object Icon { get; set; }
Visual Basic (Declaration)
Public Property Icon As Object

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.IsMouseOver Property
C1SimpleColorPicker Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


ToggleButtonStyle Property

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.ToggleButtonStyle Property
C1SimpleColorPicker Class See Also
Gets or sets the ToggleButton style for the toggle button used to apply the current brush.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Style ToggleButtonStyle { get; set; }
Visual Basic (Declaration)
Public Property ToggleButtonStyle As Style

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1SimpleColorPicker Events

[image] [image]

.NET Framework Class Library
C1SimpleColorPicker Events
C1SimpleColorPicker Class See Also

The C1SimpleColorPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
BrushSelected | Fires when the Brush property changes.
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


BrushSelected Event

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.BrushSelected Event
C1SimpleColorPicker Class See Also
Fires when the Brush property changes.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public event EventHandler BrushSelected
Visual Basic (Declaration)
Public Event BrushSelected As EventHandler

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1SimpleColorPicker..::.IsMouseOverChanged Event
C1SimpleColorPicker Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1SimpleColorPicker Class
C1.Silverlight.RichTextBox Namespace


C1TextChangedEventArgs Class

[image]

.NET Framework Class Library
C1TextChangedEventArgs Class
Members See Also
Provides data for the TextChanged event.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public class C1TextChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class C1TextChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.RichTextBox..::.C1TextChangedEventArgs

See Also

C1TextChangedEventArgs Members
C1.Silverlight.RichTextBox Namespace


C1TextChangedEventArgs Members

[image] [image]

.NET Framework Class Library
C1TextChangedEventArgs Members
C1TextChangedEventArgs Class Constructors Methods Properties See Also

The C1TextChangedEventArgs type exposes the following members.

Constructors

Name | Description
C1TextChangedEventArgs | Initializes a new C1TextChangedEventArgs object.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Change | Indicates how the text was changed.
Source | C1TextElement where the change occurred.

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


C1TextChangedEventArgs Constructor

[image]

.NET Framework Class Library
C1TextChangedEventArgs Constructor
C1TextChangedEventArgs Class See Also
Initializes a new C1TextChangedEventArgs object.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextChangedEventArgs(
    C1TextElement source,
    TextChangedAction change
)
Visual Basic (Declaration)
Public Sub New ( _
    source As C1TextElement, _
    change As TextChangedAction _
)

Parameters

source
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextElement
Value for Source property.
change
Type: C1.Silverlight.RichTextBox..::.TextChangedAction
Value for Change property.

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


C1TextChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
C1TextChangedEventArgs Methods
C1TextChangedEventArgs Class See Also

The C1TextChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


C1TextChangedEventArgs Properties

[image] [image]

.NET Framework Class Library
C1TextChangedEventArgs Properties
C1TextChangedEventArgs Class See Also

The C1TextChangedEventArgs type exposes the following members.

Properties

Name | Description
Change | Indicates how the text was changed.
Source | C1TextElement where the change occurred.

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


Change Property

[image]

.NET Framework Class Library
C1TextChangedEventArgs..::.Change Property
C1TextChangedEventArgs Class See Also
Indicates how the text was changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextChangedAction Change { get; private set; }
Visual Basic (Declaration)
Public Property Change As TextChangedAction

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


Source Property

[image]

.NET Framework Class Library
C1TextChangedEventArgs..::.Source Property
C1TextChangedEventArgs Class See Also
C1TextElement where the change occurred.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement Source { get; private set; }
Visual Basic (Declaration)
Public Property Source As C1TextElement

See Also

C1TextChangedEventArgs Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Class

[image]

.NET Framework Class Library
C1ThicknessPicker Class
Members See Also
Control used to pick a Thickness value.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Right", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "Top", Type = typeof(C1NumericBox))]
[TemplatePartAttribute(Name = "Bottom", Type = typeof(C1NumericBox))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[ContentPropertyAttribute("Header")]
[TemplatePartAttribute(Name = "Left", Type = typeof(C1NumericBox))]
public class C1ThicknessPicker : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Right", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "Top", Type := GetType(C1NumericBox))> _
<TemplatePartAttribute(Name := "Bottom", Type := GetType(C1NumericBox))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<ContentPropertyAttribute("Header")> _
<TemplatePartAttribute(Name := "Left", Type := GetType(C1NumericBox))> _
Public Class C1ThicknessPicker _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.RichTextBox..::.C1ThicknessPicker

See Also

C1ThicknessPicker Members
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Members

[image] [image]

.NET Framework Class Library
C1ThicknessPicker Members
C1ThicknessPicker Class Constructors Methods Fields Properties Events See Also

The C1ThicknessPicker type exposes the following members.

Constructors

Name | Description
C1ThicknessPicker | Initializes a new instance of a C1ThicknessPicker.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
DropDownStyleProperty | Identifies the DropDownStyle dependency property.
HeaderProperty | Identifies the Header dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ThicknessProperty | Identifies the Thickness dependency property.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DropDownStyle | Gets or sets the dropdown style.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the content of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Thickness | Gets or sets the current thickness value.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ThicknessChanged | Event raised when the Thickness property has changed.

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Constructor

[image]

.NET Framework Class Library
C1ThicknessPicker Constructor
C1ThicknessPicker Class See Also
Initializes a new instance of a C1ThicknessPicker.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public C1ThicknessPicker()
Visual Basic (Declaration)
Public Sub New

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Fields

[image] [image]

.NET Framework Class Library
C1ThicknessPicker Fields
C1ThicknessPicker Class See Also

The C1ThicknessPicker type exposes the following members.

Fields

Name | Description
DropDownStyleProperty | Identifies the DropDownStyle dependency property.
HeaderProperty | Identifies the Header dependency property.
IsMouseOverProperty | Identifies the IsMouseOver dependency property.
ThicknessProperty | Identifies the Thickness dependency property.

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


DropDownStyleProperty Field

[image]

.NET Framework Class Library
C1ThicknessPicker..::.DropDownStyleProperty Field
C1ThicknessPicker Class See Also
Identifies the DropDownStyle dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty DropDownStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropDownStyleProperty As DependencyProperty

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


HeaderProperty Field

[image]

.NET Framework Class Library
C1ThicknessPicker..::.HeaderProperty Field
C1ThicknessPicker Class See Also
Identifies the Header dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty HeaderProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeaderProperty As DependencyProperty

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1ThicknessPicker..::.IsMouseOverProperty Field
C1ThicknessPicker Class See Also
Identifies the IsMouseOver dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


ThicknessProperty Field

[image]

.NET Framework Class Library
C1ThicknessPicker..::.ThicknessProperty Field
C1ThicknessPicker Class See Also
Identifies the Thickness dependency property.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public static readonly DependencyProperty ThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly ThicknessProperty As DependencyProperty

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Methods

[image] [image]

.NET Framework Class Library
C1ThicknessPicker Methods
C1ThicknessPicker Class See Also

The C1ThicknessPicker type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1ThicknessPicker..::.ChangeVisualStateCommon Method
C1ThicknessPicker Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")]
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Performance", "CA1820:TestForEmptyStringsUsingStringLength")> _
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1ThicknessPicker..::.HitTest Method
C1ThicknessPicker Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1ThicknessPicker Class
C1ThicknessPicker Members
C1.Silverlight.RichTextBox Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1ThicknessPicker..::.OnApplyTemplate Method
C1ThicknessPicker Class See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Properties

[image] [image]

.NET Framework Class Library
C1ThicknessPicker Properties
C1ThicknessPicker Class See Also

The C1ThicknessPicker type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DropDownStyle | Gets or sets the dropdown style.
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Header | Gets or sets the content of the header.
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | Returns true if the mouse is over the control.
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Thickness | Gets or sets the current thickness value.
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


DropDownStyle Property

[image]

.NET Framework Class Library
C1ThicknessPicker..::.DropDownStyle Property
C1ThicknessPicker Class See Also
Gets or sets the dropdown style.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Style DropDownStyle { get; set; }
Visual Basic (Declaration)
Public Property DropDownStyle As Style

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


Header Property

[image]

.NET Framework Class Library
C1ThicknessPicker..::.Header Property
C1ThicknessPicker Class See Also
Gets or sets the content of the header.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public UIElement Header { get; set; }
Visual Basic (Declaration)
Public Property Header As UIElement

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1ThicknessPicker..::.IsMouseOver Property
C1ThicknessPicker Class See Also
Returns true if the mouse is over the control.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


Thickness Property

[image]

.NET Framework Class Library
C1ThicknessPicker..::.Thickness Property
C1ThicknessPicker Class See Also
Gets or sets the current thickness value.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public Thickness Thickness { get; set; }
Visual Basic (Declaration)
Public Property Thickness As Thickness

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


C1ThicknessPicker Events

[image] [image]

.NET Framework Class Library
C1ThicknessPicker Events
C1ThicknessPicker Class See Also

The C1ThicknessPicker type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged | Event raised when the IsMouseOver property has changed.
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
ThicknessChanged | Event raised when the Thickness property has changed.

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1ThicknessPicker..::.IsMouseOverChanged Event
C1ThicknessPicker Class See Also
Event raised when the IsMouseOver property has changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


ThicknessChanged Event

[image]

.NET Framework Class Library
C1ThicknessPicker..::.ThicknessChanged Event
C1ThicknessPicker Class See Also
Event raised when the Thickness property has changed.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox.Toolbar (in C1.Silverlight.RichTextBox.Toolbar.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Thickness>> ThicknessChanged
Visual Basic (Declaration)
Public Event ThicknessChanged As EventHandler(Of PropertyChangedEventArgs(Of Thickness))

See Also

C1ThicknessPicker Class
C1.Silverlight.RichTextBox Namespace


EditExtensions Class

[image]

.NET Framework Class Library
EditExtensions Class
Members See Also
Provides extensions methods for editing a C1Document.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static class EditExtensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class EditExtensions

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox..::.EditExtensions

See Also

EditExtensions Members
C1.Silverlight.RichTextBox Namespace


EditExtensions Members

[image] [image]

.NET Framework Class Library
EditExtensions Members
EditExtensions Class Methods See Also

The EditExtensions type exposes the following members.

Methods

Name | Description
Delete | Deletes elements and content in a range.
InsertHardLineBreak | Inserts a hard line break in the position.
InsertInline | Inserts an inline element in a text position.
InsertSoftLineBreak | Inserts a soft line break in the position.
MakeHyperlink | Makes a text range into a hyperlink.
MakeList | Makes a list from the blocks in a range.
RemoveHyperlinks | Removes all hyperlinks in a text range.
ReplaceText | Replaces a range with text.
UndoList | Converts all the items of a list in a range to paragraphs.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


EditExtensions Methods

[image] [image]

.NET Framework Class Library
EditExtensions Methods
EditExtensions Class See Also

The EditExtensions type exposes the following members.

Methods

Name | Description
Delete | Deletes elements and content in a range.
InsertHardLineBreak | Inserts a hard line break in the position.
InsertInline | Inserts an inline element in a text position.
InsertSoftLineBreak | Inserts a soft line break in the position.
MakeHyperlink | Makes a text range into a hyperlink.
MakeList | Makes a list from the blocks in a range.
RemoveHyperlinks | Removes all hyperlinks in a text range.
ReplaceText | Replaces a range with text.
UndoList | Converts all the items of a list in a range to paragraphs.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


Delete Method

[image]

.NET Framework Class Library
EditExtensions..::.Delete Method
EditExtensions Class See Also
Deletes elements and content in a range.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static C1TextPosition Delete(
    this C1TextRange range
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Delete ( _
    range As C1TextRange _
) As C1TextPosition

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
A C1TextRange where the content is to be deleted.

Return Value

A position before the deleted range,

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


InsertHardLineBreak Method

[image]

.NET Framework Class Library
EditExtensions..::.InsertHardLineBreak Method
EditExtensions Class See Also
Inserts a hard line break in the position.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static C1TextPosition InsertHardLineBreak(
    this C1TextPosition position
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InsertHardLineBreak ( _
    position As C1TextPosition _
) As C1TextPosition

Parameters

position
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
A C1TextPosition where to insert the hard line break.

Return Value

A position at the start of the new paragraph.

Remarks

A hard line break ends the current block and creates a new C1Paragraph.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


InsertInline Method

[image]

.NET Framework Class Library
EditExtensions..::.InsertInline Method
EditExtensions Class See Also
Inserts an inline element in a text position.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static C1TextPosition InsertInline(
    this C1TextPosition position,
    C1Inline inline
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InsertInline ( _
    position As C1TextPosition, _
    inline As C1Inline _
) As C1TextPosition

Parameters

position
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
inline
Type: C1.Silverlight.RichTextBox.Documents..::.C1Inline

Return Value

A position before the inserted inline element.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


InsertSoftLineBreak Method

[image]

.NET Framework Class Library
EditExtensions..::.InsertSoftLineBreak Method
EditExtensions Class See Also
Inserts a soft line break in the position.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static C1TextPosition InsertSoftLineBreak(
    this C1TextPosition position
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function InsertSoftLineBreak ( _
    position As C1TextPosition _
) As C1TextPosition

Parameters

position
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
A C1TextPosition where to insert the soft line break.

Return Value

A position after the inserted soft line break.

Remarks

A soft line break is an end of line character.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


MakeHyperlink Method

[image]

.NET Framework Class Library
EditExtensions..::.MakeHyperlink Method
EditExtensions Class See Also
Makes a text range into a hyperlink.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static void MakeHyperlink(
    this C1TextRange range,
    Uri uri
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub MakeHyperlink ( _
    range As C1TextRange, _
    uri As Uri _
)

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
A C1TextRange to make into a hyperlink.
uri
Type: System..::.Uri
A Uri for the hyperlink.

Remarks

If the range spans several blocks this method generates a C1Hyperlink element per block.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


MakeList Method

[image]

.NET Framework Class Library
EditExtensions..::.MakeList Method
EditExtensions Class See Also
Makes a list from the blocks in a range.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static void MakeList(
    this C1TextRange range,
    TextMarkerStyle style
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub MakeList ( _
    range As C1TextRange, _
    style As TextMarkerStyle _
)

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
style
Type: C1.Silverlight.RichTextBox.Documents..::.TextMarkerStyle

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


RemoveHyperlinks Method

[image]

.NET Framework Class Library
EditExtensions..::.RemoveHyperlinks Method
EditExtensions Class See Also
Removes all hyperlinks in a text range.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static void RemoveHyperlinks(
    this C1TextRange range
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub RemoveHyperlinks ( _
    range As C1TextRange _
)

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


ReplaceText Method

[image]

.NET Framework Class Library
EditExtensions..::.ReplaceText Method
EditExtensions Class See Also
Replaces a range with text.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static C1TextRange ReplaceText(
    C1TextRange range,
    string text,
    C1Run styledRun
)
Visual Basic (Declaration)
Public Shared Function ReplaceText ( _
    range As C1TextRange, _
    text As String, _
    styledRun As C1Run _
) As C1TextRange

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
A C1TextRange.
text
Type: System..::.String
A string with the text to insert.
styledRun
Type: C1.Silverlight.RichTextBox.Documents..::.C1Run
A pre styled C1Run to use when inserting the text. May be null.

Return Value

A range that bounds the inserted text.

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


UndoList Method

[image]

.NET Framework Class Library
EditExtensions..::.UndoList Method
EditExtensions Class See Also
Converts all the items of a list in a range to paragraphs.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static void UndoList(
    this C1TextRange range
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub UndoList ( _
    range As C1TextRange _
)

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange

See Also

EditExtensions Class
C1.Silverlight.RichTextBox Namespace


HtmlEncoding Enumeration

[image]

.NET Framework Class Library
HtmlEncoding Enumeration
See Also
Defines different encodings for interpreting a TextBlock contents as HTML.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum HtmlEncoding
Visual Basic (Declaration)
Public Enumeration HtmlEncoding

Members

Member name | Description
StyleSheet | Encodes the styles in an embedded stylesheet. Generates classes for every style.
Inline | Encodes the styles as style attributes in each HTML tag.

See Also

C1.Silverlight.RichTextBox Namespace


NavigationMode Enumeration

[image]

.NET Framework Class Library
NavigationMode Enumeration
See Also
Defines the mode in which C1RichTextBox fires RequestNavigate events.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum NavigationMode
Visual Basic (Declaration)
Public Enumeration NavigationMode

Members

Member name | Description
Never | The event is never fired.
Always | The event is fired when the user clicks on a C1Hyperlink. A hand cursor is shown when the mouse hovers a C1Hyperlink.
OnControlKey | The event is fired when the user clicks on a C1Hyperlink and the control key is pressed. A hand cursor is shown when the mouse hovers a C1Hyperlink and the control key is pressed.

See Also

C1.Silverlight.RichTextBox Namespace


RequestNavigateEventArgs Class

[image]

.NET Framework Class Library
RequestNavigateEventArgs Class
Members See Also
Provides data for the RequestNavigate event.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public class RequestNavigateEventArgs : EventArgs
Visual Basic (Declaration)
Public Class RequestNavigateEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.RichTextBox..::.RequestNavigateEventArgs

See Also

RequestNavigateEventArgs Members
C1.Silverlight.RichTextBox Namespace


RequestNavigateEventArgs Members

[image] [image]

.NET Framework Class Library
RequestNavigateEventArgs Members
RequestNavigateEventArgs Class Constructors Methods Properties See Also

The RequestNavigateEventArgs type exposes the following members.

Constructors

Name | Description
RequestNavigateEventArgs | Initializes a new RequestNavigateEventArgs.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Hyperlink | Gets the C1Hyperlink that triggered the event.

See Also

RequestNavigateEventArgs Class
C1.Silverlight.RichTextBox Namespace


RequestNavigateEventArgs Constructor

[image]

.NET Framework Class Library
RequestNavigateEventArgs Constructor
RequestNavigateEventArgs Class See Also
Initializes a new RequestNavigateEventArgs.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public RequestNavigateEventArgs(
    C1Hyperlink hyperlink
)
Visual Basic (Declaration)
Public Sub New ( _
    hyperlink As C1Hyperlink _
)

Parameters

hyperlink
Type: C1.Silverlight.RichTextBox.Documents..::.C1Hyperlink

See Also

RequestNavigateEventArgs Class
C1.Silverlight.RichTextBox Namespace


RequestNavigateEventArgs Methods

[image] [image]

.NET Framework Class Library
RequestNavigateEventArgs Methods
RequestNavigateEventArgs Class See Also

The RequestNavigateEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RequestNavigateEventArgs Class
C1.Silverlight.RichTextBox Namespace


RequestNavigateEventArgs Properties

[image] [image]

.NET Framework Class Library
RequestNavigateEventArgs Properties
RequestNavigateEventArgs Class See Also

The RequestNavigateEventArgs type exposes the following members.

Properties

Name | Description
Hyperlink | Gets the C1Hyperlink that triggered the event.

See Also

RequestNavigateEventArgs Class
C1.Silverlight.RichTextBox Namespace


Hyperlink Property

[image]

.NET Framework Class Library
RequestNavigateEventArgs..::.Hyperlink Property
RequestNavigateEventArgs Class See Also
Gets the C1Hyperlink that triggered the event.

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Hyperlink Hyperlink { get; private set; }
Visual Basic (Declaration)
Public Property Hyperlink As C1Hyperlink

See Also

RequestNavigateEventArgs Class
C1.Silverlight.RichTextBox Namespace


TextChangedAction Enumeration

[image]

.NET Framework Class Library
TextChangedAction Enumeration
See Also

Namespace: C1.Silverlight.RichTextBox
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum TextChangedAction
Visual Basic (Declaration)
Public Enumeration TextChangedAction

Members

Member name | Description
ChildrenAdd |
ChildrenRemove |
ChildrenReplace |
ChildrenReset |
Content |
Style |

See Also

C1.Silverlight.RichTextBox Namespace


C1.Silverlight.RichTextBox.Documents Namespace

[image]

.NET Framework Class Library
C1.Silverlight.RichTextBox.Documents Namespace

Classes

Class | Description
C1Block | An abstract class that provides a base for all block-level flow content elements.
C1BlockUIContainer | A block-level flow content element which enables UIElement elements to be embedded in flow content.
C1Document | Represents a flow document.
C1Hyperlink | An inline-level flow content element that provides facilities for hosting hyperlinks within flow content.
C1Inline | An abstract class that provides a base for all inline flow content elements.
C1InlineUIContainer | An inline-level flow content element which enables UIElement elements to be embedded in flow content.
C1List | A block-level flow content element that provides facilities for presenting content in an ordered or unordered list.
C1ListItem | A flow content element that represents a particular content item in a C1List.
C1Paragraph | A block-level flow content element used to group content into a paragraph.
C1Run | An inline-level flow content element intended to contain a run of formatted or unformatted text.
C1RunTextChangedEventArgs | Provides data for the TextChanged event.
C1Span | Groups other C1Inline flow content elements.
C1TextElement | An abstract class used as the base class for all elements in a C1Document.
C1TextPosition | Represents a position within a C1Document
C1TextRange | Represents a text range in a C1Document.
ProxyCollection<(Of <(T>)>) | Collection class used in C1TextElement inherited classes.

Enumerations

Enumeration | Description
InlineAlignment | Describes how C1Inline elements are vertically aligned in a line.
LogicalDirection | Indicates a direction in a document.
RunTextChangedAction | Indicates an action performed on a C1Run's text.
TextMarkerStyle | Describes the appearance of a C1List item's bullet.


C1Block Class

[image]

.NET Framework Class Library
C1Block Class
Members See Also
An abstract class that provides a base for all block-level flow content elements.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public abstract class C1Block : C1TextElement
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public MustInherit Class C1Block _
    Inherits C1TextElement

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1BlockUIContainer
C1.Silverlight.RichTextBox.Documents..::.C1List
C1.Silverlight.RichTextBox.Documents..::.C1ListItem
C1.Silverlight.RichTextBox.Documents..::.C1Paragraph

See Also

C1Block Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Block Members

[image] [image]

.NET Framework Class Library
C1Block Members
C1Block Class Constructors Methods Properties See Also

The C1Block type exposes the following members.

Constructors

Name | Description
C1Block |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Block Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Block Constructor

[image]

.NET Framework Class Library
C1Block Constructor
C1Block Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
protected C1Block()
Visual Basic (Declaration)
Protected Sub New

See Also

C1Block Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Block Methods

[image] [image]

.NET Framework Class Library
C1Block Methods
C1Block Class See Also

The C1Block type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Block Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Block..::.Remove Method
C1Block Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Block Class
C1Block Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Block Properties

[image] [image]

.NET Framework Class Library
C1Block Properties
C1Block Class See Also

The C1Block type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Block Class
C1.Silverlight.RichTextBox.Documents Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1Block..::.TextAlignment Property
C1Block Class See Also
Gets or sets the horizontal alignment of text content.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextAlignment TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As TextAlignment

See Also

C1Block Class
C1.Silverlight.RichTextBox.Documents Namespace


C1BlockUIContainer Class

[image]

.NET Framework Class Library
C1BlockUIContainer Class
Members See Also
A block-level flow content element which enables UIElement elements to be embedded in flow content.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[ContentPropertyAttribute("Child")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1BlockUIContainer : C1Block
Visual Basic (Declaration)
<ContentPropertyAttribute("Child")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1BlockUIContainer _
    Inherits C1Block

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1BlockUIContainer

See Also

C1BlockUIContainer Members
C1.Silverlight.RichTextBox.Documents Namespace


C1BlockUIContainer Members

[image] [image]

.NET Framework Class Library
C1BlockUIContainer Members
C1BlockUIContainer Class Constructors Methods Properties See Also

The C1BlockUIContainer type exposes the following members.

Constructors

Name | Description
C1BlockUIContainer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
Child | Gets or sets the FrameworkElement hosted by the C1BlockUIContainer.
ContentEnd | (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1BlockUIContainer Constructor

[image]

.NET Framework Class Library
C1BlockUIContainer Constructor
C1BlockUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1BlockUIContainer()
Visual Basic (Declaration)
Public Sub New

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1BlockUIContainer Methods

[image] [image]

.NET Framework Class Library
C1BlockUIContainer Methods
C1BlockUIContainer Class See Also

The C1BlockUIContainer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1BlockUIContainer..::.Remove Method
C1BlockUIContainer Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1BlockUIContainer Class
C1BlockUIContainer Members
C1.Silverlight.RichTextBox.Documents Namespace


C1BlockUIContainer Properties

[image] [image]

.NET Framework Class Library
C1BlockUIContainer Properties
C1BlockUIContainer Class See Also

The C1BlockUIContainer type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
Child | Gets or sets the FrameworkElement hosted by the C1BlockUIContainer.
ContentEnd | (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


Child Property

[image]

.NET Framework Class Library
C1BlockUIContainer..::.Child Property
C1BlockUIContainer Class See Also
Gets or sets the FrameworkElement hosted by the C1BlockUIContainer.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FrameworkElement Child { get; set; }
Visual Basic (Declaration)
Public Property Child As FrameworkElement

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentEnd Property

[image]

.NET Framework Class Library
C1BlockUIContainer..::.ContentEnd Property
C1BlockUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentEnd { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentEnd As C1TextPosition

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentStart Property

[image]

.NET Framework Class Library
C1BlockUIContainer..::.ContentStart Property
C1BlockUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentStart { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentStart As C1TextPosition

See Also

C1BlockUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Document Class

[image]

.NET Framework Class Library
C1Document Class
Members See Also
Represents a flow document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
[ContentPropertyAttribute("Blocks")]
public class C1Document : C1TextElement
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
<ContentPropertyAttribute("Blocks")> _
Public Class C1Document _
    Inherits C1TextElement

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Document

See Also

C1Document Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Document Members

[image] [image]

.NET Framework Class Library
C1Document Members
C1Document Class Constructors Methods Properties See Also

The C1Document type exposes the following members.

Constructors

Name | Description
C1Document |

Methods

Name | Description
Add | Adds a C1Block element to this document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
Blocks | Gets the collection of C1Block elements in the C1Document.
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Document Constructor

[image]

.NET Framework Class Library
C1Document Constructor
C1Document Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Document()
Visual Basic (Declaration)
Public Sub New

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Document Methods

[image] [image]

.NET Framework Class Library
C1Document Methods
C1Document Class See Also

The C1Document type exposes the following members.

Methods

Name | Description
Add | Adds a C1Block element to this document.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image]

.NET Framework Class Library
C1Document..::.Add Method
C1Document Class See Also
Adds a C1Block element to this document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    C1Block block
)
Visual Basic (Declaration)
Public Sub Add ( _
    block As C1Block _
)

Parameters

block
Type: C1.Silverlight.RichTextBox.Documents..::.C1Block

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Document..::.Remove Method
C1Document Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Document Class
C1Document Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Document Properties

[image] [image]

.NET Framework Class Library
C1Document Properties
C1Document Class See Also

The C1Document type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
Blocks | Gets the collection of C1Block elements in the C1Document.
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


Blocks Property

[image]

.NET Framework Class Library
C1Document..::.Blocks Property
C1Document Class See Also
Gets the collection of C1Block elements in the C1Document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ProxyCollection<C1Block> Blocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Blocks As ProxyCollection(Of C1Block)

See Also

C1Document Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Hyperlink Class

[image]

.NET Framework Class Library
C1Hyperlink Class
Members See Also
An inline-level flow content element that provides facilities for hosting hyperlinks within flow content.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1Hyperlink : C1Span
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1Hyperlink _
    Inherits C1Span

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Inline
C1.Silverlight.RichTextBox.Documents..::.C1Span
C1.Silverlight.RichTextBox.Documents..::.C1Hyperlink

See Also

C1Hyperlink Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Hyperlink Members

[image] [image]

.NET Framework Class Library
C1Hyperlink Members
C1Hyperlink Class Constructors Methods Properties See Also

The C1Hyperlink type exposes the following members.

Constructors

Name | Description
C1Hyperlink |

Methods

Name | Description
Add | Adds a C1Inline element to the C1Span. (Inherited from C1Span.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline elements grouped by the C1Span. (Inherited from C1Span.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NavigateUri | Gets or sets a URI to navigate to when the C1Hyperlink is activated.
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TargetName | Gets or sets the name of a target window or frame for the C1Hyperlink.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Hyperlink Constructor

[image]

.NET Framework Class Library
C1Hyperlink Constructor
C1Hyperlink Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Hyperlink()
Visual Basic (Declaration)
Public Sub New

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Hyperlink Methods

[image] [image]

.NET Framework Class Library
C1Hyperlink Methods
C1Hyperlink Class See Also

The C1Hyperlink type exposes the following members.

Methods

Name | Description
Add | Adds a C1Inline element to the C1Span. (Inherited from C1Span.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Hyperlink..::.Remove Method
C1Hyperlink Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Hyperlink Class
C1Hyperlink Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Hyperlink Properties

[image] [image]

.NET Framework Class Library
C1Hyperlink Properties
C1Hyperlink Class See Also

The C1Hyperlink type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline elements grouped by the C1Span. (Inherited from C1Span.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NavigateUri | Gets or sets a URI to navigate to when the C1Hyperlink is activated.
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TargetName | Gets or sets the name of a target window or frame for the C1Hyperlink.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


NavigateUri Property

[image]

.NET Framework Class Library
C1Hyperlink..::.NavigateUri Property
C1Hyperlink Class See Also
Gets or sets a URI to navigate to when the C1Hyperlink is activated.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Uri NavigateUri { get; set; }
Visual Basic (Declaration)
Public Property NavigateUri As Uri

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


TargetName Property

[image]

.NET Framework Class Library
C1Hyperlink..::.TargetName Property
C1Hyperlink Class See Also
Gets or sets the name of a target window or frame for the C1Hyperlink.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string TargetName { get; set; }
Visual Basic (Declaration)
Public Property TargetName As String

See Also

C1Hyperlink Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Inline Class

[image]

.NET Framework Class Library
C1Inline Class
Members See Also
An abstract class that provides a base for all inline flow content elements.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public abstract class C1Inline : C1TextElement
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public MustInherit Class C1Inline _
    Inherits C1TextElement

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Inline
C1.Silverlight.RichTextBox.Documents..::.C1InlineUIContainer
C1.Silverlight.RichTextBox.Documents..::.C1Run
C1.Silverlight.RichTextBox.Documents..::.C1Span

See Also

C1Inline Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Inline Members

[image] [image]

.NET Framework Class Library
C1Inline Members
C1Inline Class Constructors Methods Properties See Also

The C1Inline type exposes the following members.

Constructors

Name | Description
C1Inline |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Inline Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Inline Constructor

[image]

.NET Framework Class Library
C1Inline Constructor
C1Inline Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
protected C1Inline()
Visual Basic (Declaration)
Protected Sub New

See Also

C1Inline Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Inline Methods

[image] [image]

.NET Framework Class Library
C1Inline Methods
C1Inline Class See Also

The C1Inline type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Inline Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Inline..::.Remove Method
C1Inline Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Inline Class
C1Inline Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Inline Properties

[image] [image]

.NET Framework Class Library
C1Inline Properties
C1Inline Class See Also

The C1Inline type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Inline Class
C1.Silverlight.RichTextBox.Documents Namespace


C1InlineUIContainer Class

[image]

.NET Framework Class Library
C1InlineUIContainer Class
Members See Also
An inline-level flow content element which enables UIElement elements to be embedded in flow content.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
[ContentPropertyAttribute("Child")]
public class C1InlineUIContainer : C1Inline
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
<ContentPropertyAttribute("Child")> _
Public Class C1InlineUIContainer _
    Inherits C1Inline

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Inline
C1.Silverlight.RichTextBox.Documents..::.C1InlineUIContainer

See Also

C1InlineUIContainer Members
C1.Silverlight.RichTextBox.Documents Namespace


C1InlineUIContainer Members

[image] [image]

.NET Framework Class Library
C1InlineUIContainer Members
C1InlineUIContainer Class Constructors Methods Properties See Also

The C1InlineUIContainer type exposes the following members.

Constructors

Name | Description
C1InlineUIContainer |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
Child | Gets or sets the FrameworkElement hosted by the C1InlineUIContainer.
ContentEnd | (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1InlineUIContainer Constructor

[image]

.NET Framework Class Library
C1InlineUIContainer Constructor
C1InlineUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1InlineUIContainer()
Visual Basic (Declaration)
Public Sub New

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1InlineUIContainer Methods

[image] [image]

.NET Framework Class Library
C1InlineUIContainer Methods
C1InlineUIContainer Class See Also

The C1InlineUIContainer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1InlineUIContainer..::.Remove Method
C1InlineUIContainer Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1InlineUIContainer Class
C1InlineUIContainer Members
C1.Silverlight.RichTextBox.Documents Namespace


C1InlineUIContainer Properties

[image] [image]

.NET Framework Class Library
C1InlineUIContainer Properties
C1InlineUIContainer Class See Also

The C1InlineUIContainer type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
Child | Gets or sets the FrameworkElement hosted by the C1InlineUIContainer.
ContentEnd | (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


Child Property

[image]

.NET Framework Class Library
C1InlineUIContainer..::.Child Property
C1InlineUIContainer Class See Also
Gets or sets the FrameworkElement hosted by the C1InlineUIContainer.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FrameworkElement Child { get; set; }
Visual Basic (Declaration)
Public Property Child As FrameworkElement

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentEnd Property

[image]

.NET Framework Class Library
C1InlineUIContainer..::.ContentEnd Property
C1InlineUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentEnd { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentEnd As C1TextPosition

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentStart Property

[image]

.NET Framework Class Library
C1InlineUIContainer..::.ContentStart Property
C1InlineUIContainer Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentStart { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentStart As C1TextPosition

See Also

C1InlineUIContainer Class
C1.Silverlight.RichTextBox.Documents Namespace


C1List Class

[image]

.NET Framework Class Library
C1List Class
Members See Also
A block-level flow content element that provides facilities for presenting content in an ordered or unordered list.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[ContentPropertyAttribute("ListItems")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1List : C1Block
Visual Basic (Declaration)
<ContentPropertyAttribute("ListItems")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1List _
    Inherits C1Block

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1List

See Also

C1List Members
C1.Silverlight.RichTextBox.Documents Namespace


C1List Members

[image] [image]

.NET Framework Class Library
C1List Members
C1List Class Constructors Methods Properties See Also

The C1List type exposes the following members.

Constructors

Name | Description
C1List | Initializes a new C1List.

Methods

Name | Description
Add | Adds a C1ListItem to the C1List.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
ListItems | Gets the collection of C1ListItem elements in the C1List.
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
MarkerStyle | Gets or sets the TextMarkerStyle used in the C1List.
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
StartIndex | Gets or sets the starting index to use when the MarkerStyle is for an ordered list.
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


C1List Constructor

[image]

.NET Framework Class Library
C1List Constructor
C1List Class See Also
Initializes a new C1List.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1List()
Visual Basic (Declaration)
Public Sub New

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


C1List Methods

[image] [image]

.NET Framework Class Library
C1List Methods
C1List Class See Also

The C1List type exposes the following members.

Methods

Name | Description
Add | Adds a C1ListItem to the C1List.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image]

.NET Framework Class Library
C1List..::.Add Method
C1List Class See Also
Adds a C1ListItem to the C1List.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    C1ListItem item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As C1ListItem _
)

Parameters

item
Type: C1.Silverlight.RichTextBox.Documents..::.C1ListItem

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1List..::.Remove Method
C1List Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1List Class
C1List Members
C1.Silverlight.RichTextBox.Documents Namespace


C1List Properties

[image] [image]

.NET Framework Class Library
C1List Properties
C1List Class See Also

The C1List type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
ListItems | Gets the collection of C1ListItem elements in the C1List.
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
MarkerStyle | Gets or sets the TextMarkerStyle used in the C1List.
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
StartIndex | Gets or sets the starting index to use when the MarkerStyle is for an ordered list.
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


ListItems Property

[image]

.NET Framework Class Library
C1List..::.ListItems Property
C1List Class See Also
Gets the collection of C1ListItem elements in the C1List.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ProxyCollection<C1ListItem> ListItems { get; }
Visual Basic (Declaration)
Public ReadOnly Property ListItems As ProxyCollection(Of C1ListItem)

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


MarkerStyle Property

[image]

.NET Framework Class Library
C1List..::.MarkerStyle Property
C1List Class See Also
Gets or sets the TextMarkerStyle used in the C1List.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextMarkerStyle MarkerStyle { get; set; }
Visual Basic (Declaration)
Public Property MarkerStyle As TextMarkerStyle

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


StartIndex Property

[image]

.NET Framework Class Library
C1List..::.StartIndex Property
C1List Class See Also
Gets or sets the starting index to use when the MarkerStyle is for an ordered list.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int StartIndex { get; set; }
Visual Basic (Declaration)
Public Property StartIndex As Integer

See Also

C1List Class
C1.Silverlight.RichTextBox.Documents Namespace


C1ListItem Class

[image]

.NET Framework Class Library
C1ListItem Class
Members See Also
A flow content element that represents a particular content item in a C1List.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
[ContentPropertyAttribute("Blocks")]
public class C1ListItem : C1Block
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
<ContentPropertyAttribute("Blocks")> _
Public Class C1ListItem _
    Inherits C1Block

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1ListItem

See Also

C1ListItem Members
C1.Silverlight.RichTextBox.Documents Namespace


C1ListItem Members

[image] [image]

.NET Framework Class Library
C1ListItem Members
C1ListItem Class Constructors Methods Properties See Also

The C1ListItem type exposes the following members.

Constructors

Name | Description
C1ListItem |

Methods

Name | Description
Add | Adds a C1Block element to the C1ListItem.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
Blocks | Gets the collection of C1Block elements contained in the C1ListItem.
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


C1ListItem Constructor

[image]

.NET Framework Class Library
C1ListItem Constructor
C1ListItem Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1ListItem()
Visual Basic (Declaration)
Public Sub New

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


C1ListItem Methods

[image] [image]

.NET Framework Class Library
C1ListItem Methods
C1ListItem Class See Also

The C1ListItem type exposes the following members.

Methods

Name | Description
Add | Adds a C1Block element to the C1ListItem.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image]

.NET Framework Class Library
C1ListItem..::.Add Method
C1ListItem Class See Also
Adds a C1Block element to the C1ListItem.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    C1Block block
)
Visual Basic (Declaration)
Public Sub Add ( _
    block As C1Block _
)

Parameters

block
Type: C1.Silverlight.RichTextBox.Documents..::.C1Block
A C1Block.

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1ListItem..::.Remove Method
C1ListItem Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1ListItem Class
C1ListItem Members
C1.Silverlight.RichTextBox.Documents Namespace


C1ListItem Properties

[image] [image]

.NET Framework Class Library
C1ListItem Properties
C1ListItem Class See Also

The C1ListItem type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
Blocks | Gets the collection of C1Block elements contained in the C1ListItem.
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


Blocks Property

[image]

.NET Framework Class Library
C1ListItem..::.Blocks Property
C1ListItem Class See Also
Gets the collection of C1Block elements contained in the C1ListItem.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ProxyCollection<C1Block> Blocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Blocks As ProxyCollection(Of C1Block)

See Also

C1ListItem Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Paragraph Class

[image]

.NET Framework Class Library
C1Paragraph Class
Members See Also
A block-level flow content element used to group content into a paragraph.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[ContentPropertyAttribute("Inlines")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1Paragraph : C1Block
Visual Basic (Declaration)
<ContentPropertyAttribute("Inlines")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1Paragraph _
    Inherits C1Block

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1Paragraph

See Also

C1Paragraph Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Paragraph Members

[image] [image]

.NET Framework Class Library
C1Paragraph Members
C1Paragraph Class Constructors Methods Properties See Also

The C1Paragraph type exposes the following members.

Constructors

Name | Description
C1Paragraph | Initializes a new C1Paragraph.

Methods

Name | Description
Add | Adds a C1Inline element to the C1Paragraph.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline in the C1Paragraph.
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Paragraph Constructor

[image]

.NET Framework Class Library
C1Paragraph Constructor
C1Paragraph Class See Also
Initializes a new C1Paragraph.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Paragraph()
Visual Basic (Declaration)
Public Sub New

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Paragraph Methods

[image] [image]

.NET Framework Class Library
C1Paragraph Methods
C1Paragraph Class See Also

The C1Paragraph type exposes the following members.

Methods

Name | Description
Add | Adds a C1Inline element to the C1Paragraph.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image]

.NET Framework Class Library
C1Paragraph..::.Add Method
C1Paragraph Class See Also
Adds a C1Inline element to the C1Paragraph.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    C1Inline inline
)
Visual Basic (Declaration)
Public Sub Add ( _
    inline As C1Inline _
)

Parameters

inline
Type: C1.Silverlight.RichTextBox.Documents..::.C1Inline
An C1Inline element.

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Paragraph..::.Remove Method
C1Paragraph Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Paragraph Class
C1Paragraph Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Paragraph Properties

[image] [image]

.NET Framework Class Library
C1Paragraph Properties
C1Paragraph Class See Also

The C1Paragraph type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline in the C1Paragraph.
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextAlignment | Gets or sets the horizontal alignment of text content. (Inherited from C1Block.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


Inlines Property

[image]

.NET Framework Class Library
C1Paragraph..::.Inlines Property
C1Paragraph Class See Also
Gets the collection of C1Inline in the C1Paragraph.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ProxyCollection<C1Inline> Inlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inlines As ProxyCollection(Of C1Inline)

See Also

C1Paragraph Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Class

[image]

.NET Framework Class Library
C1Run Class
Members See Also
An inline-level flow content element intended to contain a run of formatted or unformatted text.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1Run : C1Inline
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1Run _
    Inherits C1Inline

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Inline
C1.Silverlight.RichTextBox.Documents..::.C1Run

See Also

C1Run Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Members

[image] [image]

.NET Framework Class Library
C1Run Members
C1Run Class Constructors Methods Properties Events See Also

The C1Run type exposes the following members.

Constructors

Name | Description
C1Run |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts text in Text's current value.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | (Overrides C1TextElement..::.Split(Int32).)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of the C1Run's text. (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the beginning of the C1Run's text. (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
Text | Gets or sets the unformatted text contents of this text C1Run.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

Events

Name | Description
TextChanged | Fires when the Text property changes.

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Constructor

[image]

.NET Framework Class Library
C1Run Constructor
C1Run Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Run()
Visual Basic (Declaration)
Public Sub New

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Methods

[image] [image]

.NET Framework Class Library
C1Run Methods
C1Run Class See Also

The C1Run type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Insert | Inserts text in Text's current value.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | (Overrides C1TextElement..::.Split(Int32).)
ToString | (Overrides Object..::.ToString()()().)

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


Insert Method

[image]

.NET Framework Class Library
C1Run..::.Insert Method
C1Run Class See Also
Inserts text in Text's current value.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Insert(
    int index,
    string text
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    text As String _
)

Parameters

index
Type: System..::.Int32
The index where to insert the text.
text
Type: System..::.String
The text to insert.

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Run..::.Remove Method
C1Run Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of text from Text's current value. (Overrides C1TextElement..::.Remove(Int32, Int32).)

See Also

C1Run Class
C1Run Members
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method (Int32, Int32)

[image]

.NET Framework Class Library
C1Run..::.Remove Method (Int32, Int32)
C1Run Class See Also
Removes a range of text from Text's current value.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override void Remove(
    int start,
    int count
)
Visual Basic (Declaration)
Public Overrides Sub Remove ( _
    start As Integer, _
    count As Integer _
)

Parameters

start
Type: System..::.Int32
The index where to start removing text.
count
Type: System..::.Int32
The count of characters to remove.

See Also

C1Run Class
Remove Overload
C1.Silverlight.RichTextBox.Documents Namespace


Split Method

[image]

.NET Framework Class Library
C1Run..::.Split Method
C1Run Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition Split(
    int offset
)
Visual Basic (Declaration)
Public Overrides Function Split ( _
    offset As Integer _
) As C1TextPosition

Parameters

offset
Type: System..::.Int32

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


ToString Method

[image]

.NET Framework Class Library
C1Run..::.ToString Method
C1Run Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Properties

[image] [image]

.NET Framework Class Library
C1Run Properties
C1Run Class See Also

The C1Run type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of the C1Run's text. (Overrides C1TextElement..::.ContentEnd.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the beginning of the C1Run's text. (Overrides C1TextElement..::.ContentStart.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
Text | Gets or sets the unformatted text contents of this text C1Run.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentEnd Property

[image]

.NET Framework Class Library
C1Run..::.ContentEnd Property
C1Run Class See Also
Gets the C1TextPosition at the end of the C1Run's text.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentEnd { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentEnd As C1TextPosition

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentStart Property

[image]

.NET Framework Class Library
C1Run..::.ContentStart Property
C1Run Class See Also
Gets the C1TextPosition at the beginning of the C1Run's text.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override C1TextPosition ContentStart { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property ContentStart As C1TextPosition

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


Text Property

[image]

.NET Framework Class Library
C1Run..::.Text Property
C1Run Class See Also
Gets or sets the unformatted text contents of this text C1Run.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

Remarks

Note that it will be much faster to use Insert(Int32, String) or Remove(Int32, Int32) methods when possible.

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Run Events

[image] [image]

.NET Framework Class Library
C1Run Events
C1Run Class See Also

The C1Run type exposes the following members.

Events

Name | Description
TextChanged | Fires when the Text property changes.

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


TextChanged Event

[image]

.NET Framework Class Library
C1Run..::.TextChanged Event
C1Run Class See Also
Fires when the Text property changes.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public event EventHandler<C1RunTextChangedEventArgs> TextChanged
Visual Basic (Declaration)
Public Event TextChanged As EventHandler(Of C1RunTextChangedEventArgs)

See Also

C1Run Class
C1.Silverlight.RichTextBox.Documents Namespace


C1RunTextChangedEventArgs Class

[image]

.NET Framework Class Library
C1RunTextChangedEventArgs Class
Members See Also
Provides data for the TextChanged event.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public class C1RunTextChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class C1RunTextChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.RichTextBox.Documents..::.C1RunTextChangedEventArgs

See Also

C1RunTextChangedEventArgs Members
C1.Silverlight.RichTextBox.Documents Namespace


C1RunTextChangedEventArgs Members

[image] [image]

.NET Framework Class Library
C1RunTextChangedEventArgs Members
C1RunTextChangedEventArgs Class Constructors Methods Properties See Also

The C1RunTextChangedEventArgs type exposes the following members.

Constructors

Name | Description
C1RunTextChangedEventArgs | Initializes a new C1RunTextChangedEventArgs

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Action | Gets the action performed on the text.
Index | Returns the index where the change was made.
Text | Returns the new text when Action is [!:TextAction.Insert], the text removed when Action is [!:TextAction.Remove] or the old text when Action is [!:TextAction.Reset].

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


C1RunTextChangedEventArgs Constructor

[image]

.NET Framework Class Library
C1RunTextChangedEventArgs Constructor
C1RunTextChangedEventArgs Class See Also
Initializes a new C1RunTextChangedEventArgs

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1RunTextChangedEventArgs(
    RunTextChangedAction action,
    int index,
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    action As RunTextChangedAction, _
    index As Integer, _
    text As String _
)

Parameters

action
Type: C1.Silverlight.RichTextBox.Documents..::.RunTextChangedAction
The value of the Action property.
index
Type: System..::.Int32
The value of the Index property.
text
Type: System..::.String
The value of the Text property.

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


C1RunTextChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
C1RunTextChangedEventArgs Methods
C1RunTextChangedEventArgs Class See Also

The C1RunTextChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


C1RunTextChangedEventArgs Properties

[image] [image]

.NET Framework Class Library
C1RunTextChangedEventArgs Properties
C1RunTextChangedEventArgs Class See Also

The C1RunTextChangedEventArgs type exposes the following members.

Properties

Name | Description
Action | Gets the action performed on the text.
Index | Returns the index where the change was made.
Text | Returns the new text when Action is [!:TextAction.Insert], the text removed when Action is [!:TextAction.Remove] or the old text when Action is [!:TextAction.Reset].

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


Action Property

[image]

.NET Framework Class Library
C1RunTextChangedEventArgs..::.Action Property
C1RunTextChangedEventArgs Class See Also
Gets the action performed on the text.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public RunTextChangedAction Action { get; private set; }
Visual Basic (Declaration)
Public Property Action As RunTextChangedAction

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


Index Property

[image]

.NET Framework Class Library
C1RunTextChangedEventArgs..::.Index Property
C1RunTextChangedEventArgs Class See Also
Returns the index where the change was made.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int Index { get; private set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


Text Property

[image]

.NET Framework Class Library
C1RunTextChangedEventArgs..::.Text Property
C1RunTextChangedEventArgs Class See Also
Returns the new text when Action is [!:TextAction.Insert], the text removed when Action is [!:TextAction.Remove] or the old text when Action is [!:TextAction.Reset].

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string Text { get; private set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

C1RunTextChangedEventArgs Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Span Class

[image]

.NET Framework Class Library
C1Span Class
Members See Also
Groups other C1Inline flow content elements.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[ContentPropertyAttribute("Inlines")]
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1Span : C1Inline
Visual Basic (Declaration)
<ContentPropertyAttribute("Inlines")> _
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1Span _
    Inherits C1Inline

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Inline
C1.Silverlight.RichTextBox.Documents..::.C1Span
C1.Silverlight.RichTextBox.Documents..::.C1Hyperlink

See Also

C1Span Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Span Members

[image] [image]

.NET Framework Class Library
C1Span Members
C1Span Class Constructors Methods Properties See Also

The C1Span type exposes the following members.

Constructors

Name | Description
C1Span |

Methods

Name | Description
Add | Adds a C1Inline element to the C1Span.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline elements grouped by the C1Span.
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Span Constructor

[image]

.NET Framework Class Library
C1Span Constructor
C1Span Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1Span()
Visual Basic (Declaration)
Public Sub New

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


C1Span Methods

[image] [image]

.NET Framework Class Library
C1Span Methods
C1Span Class See Also

The C1Span type exposes the following members.

Methods

Name | Description
Add | Adds a C1Inline element to the C1Span.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from C1TextElement.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root. (Inherited from C1TextElement.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties. (Inherited from C1TextElement.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image]

.NET Framework Class Library
C1Span..::.Add Method
C1Span Class See Also
Adds a C1Inline element to the C1Span.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    C1Inline inline
)
Visual Basic (Declaration)
Public Sub Add ( _
    inline As C1Inline _
)

Parameters

inline
Type: C1.Silverlight.RichTextBox.Documents..::.C1Inline
An C1Inline element.

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1Span..::.Remove Method
C1Span Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree. (Inherited from C1TextElement.)
Remove(Int32, Int32) | Removes a range of children in this element. (Inherited from C1TextElement.)

See Also

C1Span Class
C1Span Members
C1.Silverlight.RichTextBox.Documents Namespace


C1Span Properties

[image] [image]

.NET Framework Class Library
C1Span Properties
C1Span Class See Also

The C1Span type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area. (Inherited from C1TextElement.)
BorderBrush | Gets or sets the Brush used to fill the border of a text element. (Inherited from C1TextElement.)
BorderThickness | Gets or sets the border thickness of a text element. (Inherited from C1TextElement.)
ContentEnd | Gets the C1TextPosition at the end of this text element. (Inherited from C1TextElement.)
ContentRange | Gets the C1TextRange of this element's content. (Inherited from C1TextElement.)
ContentStart | Gets the C1TextPosition at the start of this text element. (Inherited from C1TextElement.)
Cursor | Gets or sets the Cursor displayed when the mouse is over this element. (Inherited from C1TextElement.)
FontFamily | Gets or sets the preferred font family for the content of the element. (Inherited from C1TextElement.)
FontSize | Gets or sets the font size for the content of the element. (Inherited from C1TextElement.)
FontStyle | Gets or sets the font style for the content of the element. (Inherited from C1TextElement.)
FontWeight | Gets or sets the font weight for the content of the element. (Inherited from C1TextElement.)
Foreground | Gets or sets the Brush to apply to the content of the element. (Inherited from C1TextElement.)
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line. (Inherited from C1TextElement.)
Inlines | Gets the collection of C1Inline elements grouped by the C1Span.
IsLeaf | Returns whether this element is a leaf in the document tree. (Inherited from C1TextElement.)
IsRoot | Returns whether this element is the root of its tree. (Inherited from C1TextElement.)
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height. (Inherited from C1TextElement.)
Margin | Gets or sets the margin of a text element. (Inherited from C1TextElement.)
NextSibling | Gets the next sibling of this element, or null if this is the last child. (Inherited from C1TextElement.)
Padding | Gets or sets the padding of a text element. (Inherited from C1TextElement.)
Parent | Gets the parent of this element. (Inherited from C1TextElement.)
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child. (Inherited from C1TextElement.)
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element. (Inherited from C1TextElement.)

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


Inlines Property

[image]

.NET Framework Class Library
C1Span..::.Inlines Property
C1Span Class See Also
Gets the collection of C1Inline elements grouped by the C1Span.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public ProxyCollection<C1Inline> Inlines { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inlines As ProxyCollection(Of C1Inline)

See Also

C1Span Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextElement Class

[image]

.NET Framework Class Library
C1TextElement Class
Members See Also
An abstract class used as the base class for all elements in a C1Document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")]
public class C1TextElement : IEnumerable<C1TextElement>,
    IEnumerable
Visual Basic (Declaration)
<SuppressMessageAttribute("Microsoft.Naming", "CA1710:IdentifiersShouldHaveCorrectSuffix")> _
Public Class C1TextElement _
    Implements IEnumerable(Of C1TextElement), IEnumerable

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextElement
C1.Silverlight.RichTextBox.Documents..::.C1Block
C1.Silverlight.RichTextBox.Documents..::.C1Document
C1.Silverlight.RichTextBox.Documents..::.C1Inline

See Also

C1TextElement Members
C1.Silverlight.RichTextBox.Documents Namespace


C1TextElement Members

[image] [image]

.NET Framework Class Library
C1TextElement Members
C1TextElement Class Constructors Methods Properties See Also

The C1TextElement type exposes the following members.

Constructors

Name | Description
C1TextElement | Initializes a new C1TextElement

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area.
BorderBrush | Gets or sets the Brush used to fill the border of a text element.
BorderThickness | Gets or sets the border thickness of a text element.
ContentEnd | Gets the C1TextPosition at the end of this text element.
ContentRange | Gets the C1TextRange of this element's content.
ContentStart | Gets the C1TextPosition at the start of this text element.
Cursor | Gets or sets the Cursor displayed when the mouse is over this element.
FontFamily | Gets or sets the preferred font family for the content of the element.
FontSize | Gets or sets the font size for the content of the element.
FontStyle | Gets or sets the font style for the content of the element.
FontWeight | Gets or sets the font weight for the content of the element.
Foreground | Gets or sets the Brush to apply to the content of the element.
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line.
IsLeaf | Returns whether this element is a leaf in the document tree.
IsRoot | Returns whether this element is the root of its tree.
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height.
Margin | Gets or sets the margin of a text element.
NextSibling | Gets the next sibling of this element, or null if this is the last child.
Padding | Gets or sets the padding of a text element.
Parent | Gets the parent of this element.
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element.

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextElement Constructor

[image]

.NET Framework Class Library
C1TextElement Constructor
C1TextElement Class See Also
Initializes a new C1TextElement

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement()
Visual Basic (Declaration)
Public Sub New

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextElement Methods

[image] [image]

.NET Framework Class Library
C1TextElement Methods
C1TextElement Class See Also

The C1TextElement type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator | Returns an enumerator that iterates through the collection.
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetParents | Returns the list of parents from the root.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
Split | Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
C1TextElement..::.GetEnumerator Method
C1TextElement Class See Also
Returns an enumerator that iterates through the collection.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator

Return Value

A IEnumerator that can be used to iterate through the collection.

Implements

IEnumerable..::.GetEnumerator()()()

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


GetParents Method

[image]

.NET Framework Class Library
C1TextElement..::.GetParents Method
C1TextElement Class See Also
Returns the list of parents from the root.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public List<C1TextElement> GetParents()
Visual Basic (Declaration)
Public Function GetParents As List(Of C1TextElement)

Return Value

The list of parents from the root.

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
C1TextElement..::.Remove Method
C1TextElement Class See Also

Overload List

Name | Description
Remove()()() | Removes the element from the document tree.
Remove(Int32, Int32) | Removes a range of children in this element.

See Also

C1TextElement Class
C1TextElement Members
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image]

.NET Framework Class Library
C1TextElement..::.Remove Method
C1TextElement Class See Also
Removes the element from the document tree.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Remove()
Visual Basic (Declaration)
Public Sub Remove

See Also

C1TextElement Class
Remove Overload
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method (Int32, Int32)

[image]

.NET Framework Class Library
C1TextElement..::.Remove Method (Int32, Int32)
C1TextElement Class See Also
Removes a range of children in this element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public virtual void Remove(
    int start,
    int count
)
Visual Basic (Declaration)
Public Overridable Sub Remove ( _
    start As Integer, _
    count As Integer _
)

Parameters

start
Type: System..::.Int32
The index of the first child to remove.
count
Type: System..::.Int32
The count of children to remove.

See Also

C1TextElement Class
Remove Overload
C1.Silverlight.RichTextBox.Documents Namespace


Split Method

[image]

.NET Framework Class Library
C1TextElement..::.Split Method
C1TextElement Class See Also
Splits this C1TextElement at the specified offset into two elements of the same type with the same style properties.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public virtual C1TextPosition Split(
    int offset
)
Visual Basic (Declaration)
Public Overridable Function Split ( _
    offset As Integer _
) As C1TextPosition

Parameters

offset
Type: System..::.Int32
The offset where to split, elements in positions greater or equal to the offset are added to the second element.

Return Value

Returns the position in the parent element between this element and the new element.

Exceptions

Exception | Condition
System..::.InvalidOperationException | this element has no parent.

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextElement Properties

[image] [image]

.NET Framework Class Library
C1TextElement Properties
C1TextElement Class See Also

The C1TextElement type exposes the following members.

Properties

Name | Description
Background | Gets or sets the Brush used to fill the background of the content area.
BorderBrush | Gets or sets the Brush used to fill the border of a text element.
BorderThickness | Gets or sets the border thickness of a text element.
ContentEnd | Gets the C1TextPosition at the end of this text element.
ContentRange | Gets the C1TextRange of this element's content.
ContentStart | Gets the C1TextPosition at the start of this text element.
Cursor | Gets or sets the Cursor displayed when the mouse is over this element.
FontFamily | Gets or sets the preferred font family for the content of the element.
FontSize | Gets or sets the font size for the content of the element.
FontStyle | Gets or sets the font style for the content of the element.
FontWeight | Gets or sets the font weight for the content of the element.
Foreground | Gets or sets the Brush to apply to the content of the element.
InlineAlignment | Gets or sets a value indicating how elements are aligned in a line.
IsLeaf | Returns whether this element is a leaf in the document tree.
IsRoot | Returns whether this element is the root of its tree.
LineHeight | Gets or sets a number that is multiplied by the computed height of a line to obtain the final height.
Margin | Gets or sets the margin of a text element.
NextSibling | Gets the next sibling of this element, or null if this is the last child.
Padding | Gets or sets the padding of a text element.
Parent | Gets the parent of this element.
PreviousSibling | Gets the previous sibling of this element, or null if this is the first child.
TextDecorations | Gets or sets a collection of text decorations to apply to the content of the element.

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Background Property

[image]

.NET Framework Class Library
C1TextElement..::.Background Property
C1TextElement Class See Also
Gets or sets the Brush used to fill the background of the content area.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush Background { get; set; }
Visual Basic (Declaration)
Public Property Background As Brush

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


BorderBrush Property

[image]

.NET Framework Class Library
C1TextElement..::.BorderBrush Property
C1TextElement Class See Also
Gets or sets the Brush used to fill the border of a text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic (Declaration)
Public Property BorderBrush As Brush

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


BorderThickness Property

[image]

.NET Framework Class Library
C1TextElement..::.BorderThickness Property
C1TextElement Class See Also
Gets or sets the border thickness of a text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic (Declaration)
Public Property BorderThickness As Thickness

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentEnd Property

[image]

.NET Framework Class Library
C1TextElement..::.ContentEnd Property
C1TextElement Class See Also
Gets the C1TextPosition at the end of this text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public virtual C1TextPosition ContentEnd { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ContentEnd As C1TextPosition

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentRange Property

[image]

.NET Framework Class Library
C1TextElement..::.ContentRange Property
C1TextElement Class See Also
Gets the C1TextRange of this element's content.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextRange ContentRange { get; }
Visual Basic (Declaration)
Public ReadOnly Property ContentRange As C1TextRange

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


ContentStart Property

[image]

.NET Framework Class Library
C1TextElement..::.ContentStart Property
C1TextElement Class See Also
Gets the C1TextPosition at the start of this text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public virtual C1TextPosition ContentStart { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property ContentStart As C1TextPosition

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Cursor Property

[image]

.NET Framework Class Library
C1TextElement..::.Cursor Property
C1TextElement Class See Also
Gets or sets the Cursor displayed when the mouse is over this element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Cursor Cursor { get; set; }
Visual Basic (Declaration)
Public Property Cursor As Cursor

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


FontFamily Property

[image]

.NET Framework Class Library
C1TextElement..::.FontFamily Property
C1TextElement Class See Also
Gets or sets the preferred font family for the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic (Declaration)
Public Property FontFamily As FontFamily

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


FontSize Property

[image]

.NET Framework Class Library
C1TextElement..::.FontSize Property
C1TextElement Class See Also
Gets or sets the font size for the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public double FontSize { get; set; }
Visual Basic (Declaration)
Public Property FontSize As Double

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


FontStyle Property

[image]

.NET Framework Class Library
C1TextElement..::.FontStyle Property
C1TextElement Class See Also
Gets or sets the font style for the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FontStyle FontStyle { get; set; }
Visual Basic (Declaration)
Public Property FontStyle As FontStyle

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


FontWeight Property

[image]

.NET Framework Class Library
C1TextElement..::.FontWeight Property
C1TextElement Class See Also
Gets or sets the font weight for the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FontWeight FontWeight { get; set; }
Visual Basic (Declaration)
Public Property FontWeight As FontWeight

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Foreground Property

[image]

.NET Framework Class Library
C1TextElement..::.Foreground Property
C1TextElement Class See Also
Gets or sets the Brush to apply to the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic (Declaration)
Public Property Foreground As Brush

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


InlineAlignment Property

[image]

.NET Framework Class Library
C1TextElement..::.InlineAlignment Property
C1TextElement Class See Also
Gets or sets a value indicating how elements are aligned in a line.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public InlineAlignment InlineAlignment { get; set; }
Visual Basic (Declaration)
Public Property InlineAlignment As InlineAlignment

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


IsLeaf Property

[image]

.NET Framework Class Library
C1TextElement..::.IsLeaf Property
C1TextElement Class See Also
Returns whether this element is a leaf in the document tree.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsLeaf { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsLeaf As Boolean

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


IsRoot Property

[image]

.NET Framework Class Library
C1TextElement..::.IsRoot Property
C1TextElement Class See Also
Returns whether this element is the root of its tree.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsRoot As Boolean

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


LineHeight Property

[image]

.NET Framework Class Library
C1TextElement..::.LineHeight Property
C1TextElement Class See Also
Gets or sets a number that is multiplied by the computed height of a line to obtain the final height.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public double LineHeight { get; set; }
Visual Basic (Declaration)
Public Property LineHeight As Double

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Margin Property

[image]

.NET Framework Class Library
C1TextElement..::.Margin Property
C1TextElement Class See Also
Gets or sets the margin of a text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness Margin { get; set; }
Visual Basic (Declaration)
Public Property Margin As Thickness

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


NextSibling Property

[image]

.NET Framework Class Library
C1TextElement..::.NextSibling Property
C1TextElement Class See Also
Gets the next sibling of this element, or null if this is the last child.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement NextSibling { get; private set; }
Visual Basic (Declaration)
Public Property NextSibling As C1TextElement

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Padding Property

[image]

.NET Framework Class Library
C1TextElement..::.Padding Property
C1TextElement Class See Also
Gets or sets the padding of a text element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Thickness

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


Parent Property

[image]

.NET Framework Class Library
C1TextElement..::.Parent Property
C1TextElement Class See Also
Gets the parent of this element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement Parent { get; internal set; }
Visual Basic (Declaration)
Public Property Parent As C1TextElement

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


PreviousSibling Property

[image]

.NET Framework Class Library
C1TextElement..::.PreviousSibling Property
C1TextElement Class See Also
Gets the previous sibling of this element, or null if this is the first child.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement PreviousSibling { get; private set; }
Visual Basic (Declaration)
Public Property PreviousSibling As C1TextElement

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


TextDecorations Property

[image]

.NET Framework Class Library
C1TextElement..::.TextDecorations Property
C1TextElement Class See Also
Gets or sets a collection of text decorations to apply to the content of the element.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextDecorationCollection TextDecorations { get; set; }
Visual Basic (Declaration)
Public Property TextDecorations As TextDecorationCollection

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Class

[image]

.NET Framework Class Library
C1TextPosition Class
Members See Also
Represents a position within a C1Document

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public class C1TextPosition : IComparable<C1TextPosition>
Visual Basic (Declaration)
Public Class C1TextPosition _
    Implements IComparable(Of C1TextPosition)

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Members
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Members

[image] [image]

.NET Framework Class Library
C1TextPosition Members
C1TextPosition Class Constructors Methods Properties See Also

The C1TextPosition type exposes the following members.

Constructors

Name | Description
C1TextPosition | Overloaded.

Methods

Name | Description
CompareTo | Compares positions of this C1TextPosition with another C1TextPosition.
Enumerate | Enumerates the C1TextPosition in the indicated direction.
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetPositionAtOffset | Returns the position at an offset of the current position.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |

Properties

Name | Description
Element | The C1TextElement where the C1TextPosition is positioned.
IsWordEnd | Returns whether the position is just after a word.
IsWordStart | Returns whether the position is just before a word.
Offset | The offset inside of Element where the C1TextPosition is positioned.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Constructor

[image] [image]

.NET Framework Class Library
C1TextPosition Constructor
C1TextPosition Class See Also

Overload List

Name | Description
C1TextPosition(C1TextPosition) | Initializes a new C1TextPosition.
C1TextPosition(C1TextElement, Int32) | Initializes a new C1TextPosition.

See Also

C1TextPosition Class
C1TextPosition Members
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Constructor (C1TextPosition)

[image]

.NET Framework Class Library
C1TextPosition Constructor (C1TextPosition)
C1TextPosition Class See Also
Initializes a new C1TextPosition.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition(
    C1TextPosition position
)
Visual Basic (Declaration)
Public Sub New ( _
    position As C1TextPosition _
)

Parameters

position
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
A position to initialize this C1TextPosition with.

See Also

C1TextPosition Class
C1TextPosition Overload
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Constructor (C1TextElement, Int32)

[image]

.NET Framework Class Library
C1TextPosition Constructor (C1TextElement, Int32)
C1TextPosition Class See Also
Initializes a new C1TextPosition.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition(
    C1TextElement element,
    int offset
)
Visual Basic (Declaration)
Public Sub New ( _
    element As C1TextElement, _
    offset As Integer _
)

Parameters

element
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextElement
The C1TextElement where to position the C1TextPosition.
offset
Type: System..::.Int32
The offset where to position the C1TextPosition.

See Also

C1TextPosition Class
C1TextPosition Overload
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Methods

[image] [image]

.NET Framework Class Library
C1TextPosition Methods
C1TextPosition Class See Also

The C1TextPosition type exposes the following members.

Methods

Name | Description
CompareTo | Compares positions of this C1TextPosition with another C1TextPosition.
Enumerate | Enumerates the C1TextPosition in the indicated direction.
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetPositionAtOffset | Returns the position at an offset of the current position.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Operators

Name | Description
Equality |
GreaterThan |
GreaterThanOrEqual |
Inequality |
LessThan |
LessThanOrEqual |

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


CompareTo Method

[image]

.NET Framework Class Library
C1TextPosition..::.CompareTo Method
C1TextPosition Class See Also
Compares positions of this C1TextPosition with another C1TextPosition.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int CompareTo(
    C1TextPosition other
)
Visual Basic (Declaration)
Public Function CompareTo ( _
    other As C1TextPosition _
) As Integer

Parameters

other
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
The C1TextPosition to compare with.

Return Value

Less than zero: this C1TextPosition precedes position. Zero: this C1TextPosition is at the same location as position. Greater than zero: this C1TextPosition follows position.

Implements

IComparable<(Of <(T>)>)..::.CompareTo(T)

Exceptions

Exception | Condition
System..::.ArgumentException | Throws ArgumentException if position does not belong to the same text container as this C1TextPosition.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Enumerate Method

[image]

.NET Framework Class Library
C1TextPosition..::.Enumerate Method
C1TextPosition Class See Also
Enumerates the C1TextPosition in the indicated direction.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerable<C1TextPosition> Enumerate(
    LogicalDirection dir
)
Visual Basic (Declaration)
Public Function Enumerate ( _
    dir As LogicalDirection _
) As IEnumerable(Of C1TextPosition)

Parameters

dir
Type: C1.Silverlight.RichTextBox.Documents..::.LogicalDirection
A LogicalDirection.

Return Value

An IEnumerable<C1TextPosition> enumerating the C1TextPosition in the indicated direction.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Equality Operator

[image]

.NET Framework Class Library
C1TextPosition..::.Equality Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator ==(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator = ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Equals Method

[image]

.NET Framework Class Library
C1TextPosition..::.Equals Method
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


GetHashCode Method

[image]

.NET Framework Class Library
C1TextPosition..::.GetHashCode Method
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


GetPositionAtOffset Method

[image]

.NET Framework Class Library
C1TextPosition..::.GetPositionAtOffset Method
C1TextPosition Class See Also
Returns the position at an offset of the current position.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition GetPositionAtOffset(
    int offset
)
Visual Basic (Declaration)
Public Function GetPositionAtOffset ( _
    offset As Integer _
) As C1TextPosition

Parameters

offset
Type: System..::.Int32
The offset.

Return Value

A new position at the offset indicated.

Remarks

This method can be used to linearly traverse a C1Document tree.

Start and end tags in each C1TextElement count as items for the traverse, for instance if the position is in an element with children, a position at offset 1 will be the ContentStart of the C1TextElement where this C1TextPosition is positioned.

If this C1TextPosition is positioned in a C1Run then it traverses the text of the C1Run.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


GreaterThan Operator

[image]

.NET Framework Class Library
C1TextPosition..::.GreaterThan Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator >(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator > ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


GreaterThanOrEqual Operator

[image]

.NET Framework Class Library
C1TextPosition..::.GreaterThanOrEqual Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator >=(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator >= ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Inequality Operator

[image]

.NET Framework Class Library
C1TextPosition..::.Inequality Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator !=(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator <> ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


LessThan Operator

[image]

.NET Framework Class Library
C1TextPosition..::.LessThan Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator <(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator < ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


LessThanOrEqual Operator

[image]

.NET Framework Class Library
C1TextPosition..::.LessThanOrEqual Operator
C1TextPosition Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public static bool operator <=(
    C1TextPosition pointer1,
    C1TextPosition pointer2
)
Visual Basic (Declaration)
Public Shared Operator <= ( _
    pointer1 As C1TextPosition, _
    pointer2 As C1TextPosition _
) As Boolean

Parameters

pointer1
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
pointer2
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextPosition Properties

[image] [image]

.NET Framework Class Library
C1TextPosition Properties
C1TextPosition Class See Also

The C1TextPosition type exposes the following members.

Properties

Name | Description
Element | The C1TextElement where the C1TextPosition is positioned.
IsWordEnd | Returns whether the position is just after a word.
IsWordStart | Returns whether the position is just before a word.
Offset | The offset inside of Element where the C1TextPosition is positioned.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Element Property

[image]

.NET Framework Class Library
C1TextPosition..::.Element Property
C1TextPosition Class See Also
The C1TextElement where the C1TextPosition is positioned.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextElement Element { get; private set; }
Visual Basic (Declaration)
Public Property Element As C1TextElement

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


IsWordEnd Property

[image]

.NET Framework Class Library
C1TextPosition..::.IsWordEnd Property
C1TextPosition Class See Also
Returns whether the position is just after a word.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsWordEnd { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWordEnd As Boolean

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


IsWordStart Property

[image]

.NET Framework Class Library
C1TextPosition..::.IsWordStart Property
C1TextPosition Class See Also
Returns whether the position is just before a word.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsWordStart { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsWordStart As Boolean

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


Offset Property

[image]

.NET Framework Class Library
C1TextPosition..::.Offset Property
C1TextPosition Class See Also
The offset inside of Element where the C1TextPosition is positioned.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int Offset { get; private set; }
Visual Basic (Declaration)
Public Property Offset As Integer

Remarks

If Element has children then the C1TextPosition is positioned before the child whose index equals Offset, or after the last child if Offset equals the number of children.

If Element doesn't have children, then the meaning of Offset depends on the type of Element. For example, in C1Run it indicates a position inside the text.

See Also

C1TextPosition Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextRange Class

[image]

.NET Framework Class Library
C1TextRange Class
Members See Also
Represents a text range in a C1Document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public class C1TextRange
Visual Basic (Declaration)
Public Class C1TextRange

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.C1TextRange

See Also

C1TextRange Members
C1.Silverlight.RichTextBox.Documents Namespace


C1TextRange Members

[image] [image]

.NET Framework Class Library
C1TextRange Members
C1TextRange Class Constructors Methods Properties See Also

The C1TextRange type exposes the following members.

Constructors

Name | Description
C1TextRange | Initializes a C1TextRange.

Methods

Name | Description
CapitalizeWords | Converts all characters that start words to uppercase, and all other characters to lowercase.
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | Returns the intersection with another range.
Intersects | Returns whether this range intersects the parameter range.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToggleCase | Toggles the case of all characters in the range.
ToLowercase | Converts all characters in the range to lower case.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToUppercase | Converts all characters in the range to upper case.
TrimRuns | If the range includes part of a C1Run element, it is split so that there are only whole runs inside of it.

Properties

Name | Description
BlockBackground | Gets or sets the background of the blocks in the range.
Blocks | Gets the highest level C1Block elements inside the range.
BorderBrush | Gets or sets the border brush of the blocks in the range.
BorderThickness | Gets or sets the border thickness of the blocks in the range.
Elements | Gets the list of C1TextElement elements inside the range.
End | Gets the end position of the range.
FontFamily | Gets or sets the font family of the runs in the range.
FontSize | Gets or sets the font size of the runs in the range.
FontStyle | Gets or sets the font style of the runs in the range.
FontWeight | Gets or sets the font weight of the runs in the range.
Foreground | Gets or sets the foreground of the runs in the range.
InlineAlignment | Gets or sets the inline alignment of the runs in the range.
InlineBackground | Gets or sets the background of the runs in the range.
IsEmpty | Returns whether the range is empty.
List | Returns the C1List the range is inside of, or null.
Margin | Gets or sets the margin of the blocks in the range.
Padding | Gets or sets the padding of the blocks in the range.
Runs | Gets the list of C1Run elements inside the range.
Start | Gets the start position of the range.
Text | Gets or sets the text in the range.
TextAlignment | Gets or sets the text alignment of the blocks in the range.
TextDecorations | Gets or sets the text alignment of the blocks in the range.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextRange Constructor

[image]

.NET Framework Class Library
C1TextRange Constructor
C1TextRange Class See Also
Initializes a C1TextRange.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextRange(
    C1TextPosition start,
    C1TextPosition end
)
Visual Basic (Declaration)
Public Sub New ( _
    start As C1TextPosition, _
    end As C1TextPosition _
)

Parameters

start
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
The start position.
end
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextPosition
The end position.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextRange Methods

[image] [image]

.NET Framework Class Library
C1TextRange Methods
C1TextRange Class See Also

The C1TextRange type exposes the following members.

Methods

Name | Description
CapitalizeWords | Converts all characters that start words to uppercase, and all other characters to lowercase.
Equals | (Overrides Object..::.Equals(Object).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | (Overrides Object..::.GetHashCode()()().)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersection | Returns the intersection with another range.
Intersects | Returns whether this range intersects the parameter range.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToggleCase | Toggles the case of all characters in the range.
ToLowercase | Converts all characters in the range to lower case.
ToString | Returns a String that represents the current Object. (Inherited from Object.)
ToUppercase | Converts all characters in the range to upper case.
TrimRuns | If the range includes part of a C1Run element, it is split so that there are only whole runs inside of it.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


CapitalizeWords Method

[image]

.NET Framework Class Library
C1TextRange..::.CapitalizeWords Method
C1TextRange Class See Also
Converts all characters that start words to uppercase, and all other characters to lowercase.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void CapitalizeWords()
Visual Basic (Declaration)
Public Sub CapitalizeWords

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Equals Method

[image]

.NET Framework Class Library
C1TextRange..::.Equals Method
C1TextRange Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override bool Equals(
    Object obj
)
Visual Basic (Declaration)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean

Parameters

obj
Type: System..::.Object

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


GetHashCode Method

[image]

.NET Framework Class Library
C1TextRange..::.GetHashCode Method
C1TextRange Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public override int GetHashCode()
Visual Basic (Declaration)
Public Overrides Function GetHashCode As Integer

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Intersection Method

[image]

.NET Framework Class Library
C1TextRange..::.Intersection Method
C1TextRange Class See Also
Returns the intersection with another range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextRange Intersection(
    C1TextRange range
)
Visual Basic (Declaration)
Public Function Intersection ( _
    range As C1TextRange _
) As C1TextRange

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
The other C1TextRange

Return Value

The intersection with the other range.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Intersects Method

[image]

.NET Framework Class Library
C1TextRange..::.Intersects Method
C1TextRange Class See Also
Returns whether this range intersects the parameter range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool Intersects(
    C1TextRange range
)
Visual Basic (Declaration)
Public Function Intersects ( _
    range As C1TextRange _
) As Boolean

Parameters

range
Type: C1.Silverlight.RichTextBox.Documents..::.C1TextRange
A C1TextRange to intersect with.

Return Value

Whether this range intersects the parameter range.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


ToggleCase Method

[image]

.NET Framework Class Library
C1TextRange..::.ToggleCase Method
C1TextRange Class See Also
Toggles the case of all characters in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void ToggleCase()
Visual Basic (Declaration)
Public Sub ToggleCase

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


ToLowercase Method

[image]

.NET Framework Class Library
C1TextRange..::.ToLowercase Method
C1TextRange Class See Also
Converts all characters in the range to lower case.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void ToLowercase()
Visual Basic (Declaration)
Public Sub ToLowercase

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


ToUppercase Method

[image]

.NET Framework Class Library
C1TextRange..::.ToUppercase Method
C1TextRange Class See Also
Converts all characters in the range to upper case.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void ToUppercase()
Visual Basic (Declaration)
Public Sub ToUppercase

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


TrimRuns Method

[image]

.NET Framework Class Library
C1TextRange..::.TrimRuns Method
C1TextRange Class See Also
If the range includes part of a C1Run element, it is split so that there are only whole runs inside of it.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void TrimRuns()
Visual Basic (Declaration)
Public Sub TrimRuns

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


C1TextRange Properties

[image] [image]

.NET Framework Class Library
C1TextRange Properties
C1TextRange Class See Also

The C1TextRange type exposes the following members.

Properties

Name | Description
BlockBackground | Gets or sets the background of the blocks in the range.
Blocks | Gets the highest level C1Block elements inside the range.
BorderBrush | Gets or sets the border brush of the blocks in the range.
BorderThickness | Gets or sets the border thickness of the blocks in the range.
Elements | Gets the list of C1TextElement elements inside the range.
End | Gets the end position of the range.
FontFamily | Gets or sets the font family of the runs in the range.
FontSize | Gets or sets the font size of the runs in the range.
FontStyle | Gets or sets the font style of the runs in the range.
FontWeight | Gets or sets the font weight of the runs in the range.
Foreground | Gets or sets the foreground of the runs in the range.
InlineAlignment | Gets or sets the inline alignment of the runs in the range.
InlineBackground | Gets or sets the background of the runs in the range.
IsEmpty | Returns whether the range is empty.
List | Returns the C1List the range is inside of, or null.
Margin | Gets or sets the margin of the blocks in the range.
Padding | Gets or sets the padding of the blocks in the range.
Runs | Gets the list of C1Run elements inside the range.
Start | Gets the start position of the range.
Text | Gets or sets the text in the range.
TextAlignment | Gets or sets the text alignment of the blocks in the range.
TextDecorations | Gets or sets the text alignment of the blocks in the range.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


BlockBackground Property

[image]

.NET Framework Class Library
C1TextRange..::.BlockBackground Property
C1TextRange Class See Also
Gets or sets the background of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush BlockBackground { get; set; }
Visual Basic (Declaration)
Public Property BlockBackground As Brush

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Blocks Property

[image]

.NET Framework Class Library
C1TextRange..::.Blocks Property
C1TextRange Class See Also
Gets the highest level C1Block elements inside the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerable<C1Block> Blocks { get; }
Visual Basic (Declaration)
Public ReadOnly Property Blocks As IEnumerable(Of C1Block)

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


BorderBrush Property

[image]

.NET Framework Class Library
C1TextRange..::.BorderBrush Property
C1TextRange Class See Also
Gets or sets the border brush of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush BorderBrush { get; set; }
Visual Basic (Declaration)
Public Property BorderBrush As Brush

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


BorderThickness Property

[image]

.NET Framework Class Library
C1TextRange..::.BorderThickness Property
C1TextRange Class See Also
Gets or sets the border thickness of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness BorderThickness { get; set; }
Visual Basic (Declaration)
Public Property BorderThickness As Thickness

Remarks

When there are several blocks in the range getting this property returns NaN as the width of the sides that have different values in different blocks, setting this property only sets the width of the sides that are not NaN in the assigned Thickness.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Elements Property

[image]

.NET Framework Class Library
C1TextRange..::.Elements Property
C1TextRange Class See Also
Gets the list of C1TextElement elements inside the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerable<C1TextElement> Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As IEnumerable(Of C1TextElement)

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


End Property

[image]

.NET Framework Class Library
C1TextRange..::.End Property
C1TextRange Class See Also
Gets the end position of the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition End { get; private set; }
Visual Basic (Declaration)
Public Property End As C1TextPosition

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


FontFamily Property

[image]

.NET Framework Class Library
C1TextRange..::.FontFamily Property
C1TextRange Class See Also
Gets or sets the font family of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public FontFamily FontFamily { get; set; }
Visual Basic (Declaration)
Public Property FontFamily As FontFamily

Remarks

When the range is empty, setting this property changes the FontFamily of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


FontSize Property

[image]

.NET Framework Class Library
C1TextRange..::.FontSize Property
C1TextRange Class See Also
Gets or sets the font size of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Nullable<double> FontSize { get; set; }
Visual Basic (Declaration)
Public Property FontSize As Nullable(Of Double)

Remarks

When the range is empty, setting this property changes the FontSize of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


FontStyle Property

[image]

.NET Framework Class Library
C1TextRange..::.FontStyle Property
C1TextRange Class See Also
Gets or sets the font style of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Nullable<FontStyle> FontStyle { get; set; }
Visual Basic (Declaration)
Public Property FontStyle As Nullable(Of FontStyle)

Remarks

When the range is empty, setting this property changes the FontStyle of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


FontWeight Property

[image]

.NET Framework Class Library
C1TextRange..::.FontWeight Property
C1TextRange Class See Also
Gets or sets the font weight of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Nullable<FontWeight> FontWeight { get; set; }
Visual Basic (Declaration)
Public Property FontWeight As Nullable(Of FontWeight)

Remarks

When the range is empty, setting this property changes the FontWeight of the text to be written and getting the FontWeight returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Foreground Property

[image]

.NET Framework Class Library
C1TextRange..::.Foreground Property
C1TextRange Class See Also
Gets or sets the foreground of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush Foreground { get; set; }
Visual Basic (Declaration)
Public Property Foreground As Brush

Remarks

When the range is empty, setting this property changes the Foreground of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


InlineAlignment Property

[image]

.NET Framework Class Library
C1TextRange..::.InlineAlignment Property
C1TextRange Class See Also
Gets or sets the inline alignment of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Nullable<InlineAlignment> InlineAlignment { get; set; }
Visual Basic (Declaration)
Public Property InlineAlignment As Nullable(Of InlineAlignment)

Remarks

When the range is empty, setting this property changes the InlineAlignment of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


InlineBackground Property

[image]

.NET Framework Class Library
C1TextRange..::.InlineBackground Property
C1TextRange Class See Also
Gets or sets the background of the runs in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Brush InlineBackground { get; set; }
Visual Basic (Declaration)
Public Property InlineBackground As Brush

Remarks

When the range is empty, setting this property changes the Background of the text to be written and getting this property returns the format of the of the text to be written. When the selection is not empty, getting this property returns the format of the selection, or null if the selection has mixed format.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


IsEmpty Property

[image]

.NET Framework Class Library
C1TextRange..::.IsEmpty Property
C1TextRange Class See Also
Returns whether the range is empty.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


List Property

[image]

.NET Framework Class Library
C1TextRange..::.List Property
C1TextRange Class See Also
Returns the C1List the range is inside of, or null.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1List List { get; }
Visual Basic (Declaration)
Public ReadOnly Property List As C1List

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Margin Property

[image]

.NET Framework Class Library
C1TextRange..::.Margin Property
C1TextRange Class See Also
Gets or sets the margin of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness Margin { get; set; }
Visual Basic (Declaration)
Public Property Margin As Thickness

Remarks

When there are several blocks in the range getting this property returns NaN as the width of the sides that have different values in different blocks, setting this property only sets the width of the sides that are not NaN in the assigned Thickness.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Padding Property

[image]

.NET Framework Class Library
C1TextRange..::.Padding Property
C1TextRange Class See Also
Gets or sets the padding of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Thickness Padding { get; set; }
Visual Basic (Declaration)
Public Property Padding As Thickness

Remarks

When there are several blocks in the range getting this property returns NaN as the width of the sides that have different values in different blocks, setting this property only sets the width of the sides that are not NaN in the assigned Thickness.

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Runs Property

[image]

.NET Framework Class Library
C1TextRange..::.Runs Property
C1TextRange Class See Also
Gets the list of C1Run elements inside the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerable<C1Run> Runs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Runs As IEnumerable(Of C1Run)

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Start Property

[image]

.NET Framework Class Library
C1TextRange..::.Start Property
C1TextRange Class See Also
Gets the start position of the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public C1TextPosition Start { get; private set; }
Visual Basic (Declaration)
Public Property Start As C1TextPosition

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


Text Property

[image]

.NET Framework Class Library
C1TextRange..::.Text Property
C1TextRange Class See Also
Gets or sets the text in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

Remarks

When setting the selected text, all line breaks (\n, \r and \r\n) are converted to a single new line character (\n).

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


TextAlignment Property

[image]

.NET Framework Class Library
C1TextRange..::.TextAlignment Property
C1TextRange Class See Also
Gets or sets the text alignment of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Nullable<TextAlignment> TextAlignment { get; set; }
Visual Basic (Declaration)
Public Property TextAlignment As Nullable(Of TextAlignment)

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


TextDecorations Property

[image]

.NET Framework Class Library
C1TextRange..::.TextDecorations Property
C1TextRange Class See Also
Gets or sets the text alignment of the blocks in the range.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public TextDecorationCollection TextDecorations { get; set; }
Visual Basic (Declaration)
Public Property TextDecorations As TextDecorationCollection

See Also

C1TextRange Class
C1.Silverlight.RichTextBox.Documents Namespace


InlineAlignment Enumeration

[image]

.NET Framework Class Library
InlineAlignment Enumeration
See Also
Describes how C1Inline elements are vertically aligned in a line.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum InlineAlignment
Visual Basic (Declaration)
Public Enumeration InlineAlignment

Members

Member name | Description
Baseline | The baseline of the element is aligned with the baseline of the line.
Top | The top of the element is aligned with the top of the line.
Bottom | The bottom of the element is aligned with the bottom of the line.
Middle | The middle of the element is aligned with the baseline plus half the x-height of the line.
Super | The baseline of the element is aligned with the superscript baseline for its size.
Sub | The baseline of the element is aligned with the subscript baseline for its size.

See Also

C1.Silverlight.RichTextBox.Documents Namespace


LogicalDirection Enumeration

[image]

.NET Framework Class Library
LogicalDirection Enumeration
See Also
Indicates a direction in a document.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum LogicalDirection
Visual Basic (Declaration)
Public Enumeration LogicalDirection

Members

Member name | Description
Backward | Backward direction.
Forward | Forward direction.

See Also

C1.Silverlight.RichTextBox.Documents Namespace


ProxyCollection(T) Class

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>) Class
Members See Also
Collection class used in C1TextElement inherited classes.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class ProxyCollection<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IList, ICollection, IEnumerable
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class ProxyCollection(Of T) _
    Implements IList(Of T), ICollection(Of T),  _
    IEnumerable(Of T), IList, ICollection, IEnumerable

Type Parameters

T
The type of items in the collection.

Inheritance Hierarchy

System..::.Object
C1.Silverlight.RichTextBox.Documents..::.ProxyCollection<(Of <(T>)>)

See Also

ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


ProxyCollection(T) Members

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>) Members
ProxyCollection<(Of <(T>)>) Class Methods Properties See Also

The ProxyCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear |
Contains | Overloaded.
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
IsFixedSize |
IsReadOnly |
IsSynchronized |
Item |
SyncRoot |

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


ProxyCollection(T) Methods

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>) Methods
ProxyCollection<(Of <(T>)>) Class See Also

The ProxyCollection<(Of <(T>)>) type exposes the following members.

Methods

Name | Description
Add | Overloaded.
Clear |
Contains | Overloaded.
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAt |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


Add Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Add Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Add(Object) |
Add(T) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


Add Method (Object)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Add Method (Object)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int Add(
    Object value
)
Visual Basic (Declaration)
Public Function Add ( _
    value As Object _
) As Integer

Parameters

value
Type: System..::.Object

Implements

IList..::.Add(Object)

See Also

ProxyCollection<(Of <(T>)>) Class
Add Overload
C1.Silverlight.RichTextBox.Documents Namespace


Add Method (T)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Add Method (T)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Add(
    T item
)
Visual Basic (Declaration)
Public Sub Add ( _
    item As T _
)

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Add(T)

See Also

ProxyCollection<(Of <(T>)>) Class
Add Overload
C1.Silverlight.RichTextBox.Documents Namespace


Clear Method

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Clear Method
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

Implements

ICollection<(Of <(T>)>)..::.Clear()()()
IList..::.Clear()()()

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


Contains Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Contains Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Contains(Object) |
Contains(T) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


Contains Method (Object)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Contains Method (Object)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool Contains(
    Object value
)
Visual Basic (Declaration)
Public Function Contains ( _
    value As Object _
) As Boolean

Parameters

value
Type: System..::.Object

Implements

IList..::.Contains(Object)

See Also

ProxyCollection<(Of <(T>)>) Class
Contains Overload
C1.Silverlight.RichTextBox.Documents Namespace


Contains Method (T)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Contains Method (T)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool Contains(
    T item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As T _
) As Boolean

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Contains(T)

See Also

ProxyCollection<(Of <(T>)>) Class
Contains Overload
C1.Silverlight.RichTextBox.Documents Namespace


CopyTo Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.CopyTo Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
CopyTo(Array, Int32) |
CopyTo(array<T>[]()[], Int32) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


CopyTo Method (Array, Int32)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.CopyTo Method (Array, Int32)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As Array, _
    index As Integer _
)

Parameters

array
Type: System..::.Array
index
Type: System..::.Int32

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

ProxyCollection<(Of <(T>)>) Class
CopyTo Overload
C1.Silverlight.RichTextBox.Documents Namespace


CopyTo Method (T[], Int32)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.CopyTo Method (array<T>[]()[], Int32)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void CopyTo(
    T[] array,
    int arrayIndex
)
Visual Basic (Declaration)
Public Sub CopyTo ( _
    array As T(), _
    arrayIndex As Integer _
)

Parameters

array
Type: array< T >[]()[]
arrayIndex
Type: System..::.Int32

Implements

ICollection<(Of <(T>)>)..::.CopyTo(array<T>[]()[], Int32)

See Also

ProxyCollection<(Of <(T>)>) Class
CopyTo Overload
C1.Silverlight.RichTextBox.Documents Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.GetEnumerator Method
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public IEnumerator<T> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of T)

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IndexOf Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
IndexOf(Object) |
IndexOf(T) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


IndexOf Method (Object)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IndexOf Method (Object)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int IndexOf(
    Object value
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    value As Object _
) As Integer

Parameters

value
Type: System..::.Object

Implements

IList..::.IndexOf(Object)

See Also

ProxyCollection<(Of <(T>)>) Class
IndexOf Overload
C1.Silverlight.RichTextBox.Documents Namespace


IndexOf Method (T)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IndexOf Method (T)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int IndexOf(
    T item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As T _
) As Integer

Parameters

item
Type: T

Implements

IList<(Of <(T>)>)..::.IndexOf(T)

See Also

ProxyCollection<(Of <(T>)>) Class
IndexOf Overload
C1.Silverlight.RichTextBox.Documents Namespace


Insert Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Insert Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Insert(Int32, Object) |
Insert(Int32, T) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


Insert Method (Int32, Object)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Insert Method (Int32, Object)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Insert(
    int index,
    Object value
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    value As Object _
)

Parameters

index
Type: System..::.Int32
value
Type: System..::.Object

Implements

IList..::.Insert(Int32, Object)

See Also

ProxyCollection<(Of <(T>)>) Class
Insert Overload
C1.Silverlight.RichTextBox.Documents Namespace


Insert Method (Int32, T)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Insert Method (Int32, T)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Insert(
    int index,
    T item
)
Visual Basic (Declaration)
Public Sub Insert ( _
    index As Integer, _
    item As T _
)

Parameters

index
Type: System..::.Int32
item
Type: T

Implements

IList<(Of <(T>)>)..::.Insert(Int32, T)

See Also

ProxyCollection<(Of <(T>)>) Class
Insert Overload
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Remove Method
ProxyCollection<(Of <(T>)>) Class See Also

Overload List

Name | Description
Remove(Object) |
Remove(T) |

See Also

ProxyCollection<(Of <(T>)>) Class
ProxyCollection<(Of <(T>)>) Members
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method (Object)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Remove Method (Object)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void Remove(
    Object value
)
Visual Basic (Declaration)
Public Sub Remove ( _
    value As Object _
)

Parameters

value
Type: System..::.Object

Implements

IList..::.Remove(Object)

See Also

ProxyCollection<(Of <(T>)>) Class
Remove Overload
C1.Silverlight.RichTextBox.Documents Namespace


Remove Method (T)

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Remove Method (T)
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool Remove(
    T item
)
Visual Basic (Declaration)
Public Function Remove ( _
    item As T _
) As Boolean

Parameters

item
Type: T

Implements

ICollection<(Of <(T>)>)..::.Remove(T)

See Also

ProxyCollection<(Of <(T>)>) Class
Remove Overload
C1.Silverlight.RichTextBox.Documents Namespace


RemoveAt Method

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.RemoveAt Method
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.RemoveAt(Int32)
IList..::.RemoveAt(Int32)

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


ProxyCollection(T) Properties

[image] [image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>) Properties
ProxyCollection<(Of <(T>)>) Class See Also

The ProxyCollection<(Of <(T>)>) type exposes the following members.

Properties

Name | Description
Count |
IsFixedSize |
IsReadOnly |
IsSynchronized |
Item |
SyncRoot |

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


Count Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Count Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

Implements

ICollection<(Of <(T>)>)..::.Count
ICollection..::.Count

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


IsFixedSize Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IsFixedSize Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsFixedSize { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsFixedSize As Boolean

Implements

IList..::.IsFixedSize

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IsReadOnly Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsReadOnly { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsReadOnly As Boolean

Implements

ICollection<(Of <(T>)>)..::.IsReadOnly
IList..::.IsReadOnly

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


IsSynchronized Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IsSynchronized Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public bool IsSynchronized { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSynchronized As Boolean

Implements

ICollection..::.IsSynchronized

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


Item Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.Item Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public T this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As T

Parameters

index
Type: System..::.Int32

Implements

IList<(Of <(T>)>)..::.Item[([(Int32])])

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


SyncRoot Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.SyncRoot Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public Object SyncRoot { get; }
Visual Basic (Declaration)
Public ReadOnly Property SyncRoot As Object

Implements

ICollection..::.SyncRoot

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


RunTextChangedAction Enumeration

[image]

.NET Framework Class Library
RunTextChangedAction Enumeration
See Also
Indicates an action performed on a C1Run's text.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum RunTextChangedAction
Visual Basic (Declaration)
Public Enumeration RunTextChangedAction

Members

Member name | Description
Insert | Text was inserted.
Remove | Text was removed.
Reset | Text was reassigned.

See Also

C1.Silverlight.RichTextBox.Documents Namespace


TextMarkerStyle Enumeration

[image]

.NET Framework Class Library
TextMarkerStyle Enumeration
See Also
Describes the appearance of a C1List item's bullet.

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
public enum TextMarkerStyle
Visual Basic (Declaration)
Public Enumeration TextMarkerStyle

Members

Member name | Description
None | No marker is displayed.
Disc | A solid disc circle is displayed.
Circle | A hollow disc circle is displayed.
Square | A hollow square shape is displayed.
Box | A solid square box is displayed.
LowerRoman | A lowercase Roman numeral is displayed.
UpperRoman | An uppercase Roman numeral is displayed.
LowerLatin | A lowercase ASCII character is displayed.
UpperLatin | An uppercase ASCII character is displayed.
Decimal | A decimal is displayed.

See Also

C1.Silverlight.RichTextBox.Documents Namespace


C1.Silverlight.Uploader Namespace

[image]

.NET Framework Class Library
C1.Silverlight.Uploader Namespace

Classes

Class | Description
C1Uploader | Represents an object that uploads files to a server.
C1UploaderPost | Represents a class that uploads files to the server using multipart POST messages.
C1UploaderWebService | Represents a class that uploads files to the server using Web services.
FilePackager | Represents an object that maps files into server requests.
FilePackagerFactory | Static class that creates FilePackager objects.
FilePackagerMultiFile | FilePackager that packages multiple files per request.
FilePackagerPartialFile | FilePackager that breaks up files into multiple requests.
FilePackagerSingleFile | FilePackager that packages one file per request.
InvalidAddressException | This exception is raised if the address of the service to be called is not correct.
MaximumUploadSizeExceededException | This exception is raised when the size needed to do the upload is greater than the size specified by the user.
UploadCompletedEventArgs | Contains data about upload completed event of the upload file
UploadFileInfo | Wraps the information of files that comes from different sources.
UploadFilePartInfo | Represents a file part. It can be a file or a file segment.
UploadFilePartPackage | Contains a sets of UploadFilePartInfo.
UploadManagerPost | Class that packages files into multipart POST requests.
UploadManagerSettings | Contains parameters that specify the behavior of IUploadManager objects.
UploadManagerSettingsPost | Contains parameters that specify the behavior of UploadManagerPost objects.
UploadManagerSettingsWebService | Contains parameters that specify the behavior of UploadManagerWebService objects.
UploadManagerWebService | Class that packages files into Web Service requests.
UploadProgressChangedEventArgs | Contains data about progress changed event of the upload file.

Interfaces

Interface | Description
IUploadManager | Interface implemented by classes that package files into server requests.

Enumerations

Enumeration | Description
FilesPerRequest | Specifies how files are mapped into server requests.
MultipartPostEncoding | Specifies the encoding of the data that will be sent in the post message.


C1Uploader Class

[image]

.NET Framework Class Library
C1Uploader Class
Members See Also
Represents an object that uploads files to a server.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public abstract class C1Uploader
Visual Basic (Declaration)
Public MustInherit Class C1Uploader

Remarks

C1Uploader is the abstract base class of C1UploaderPost, which uploads files using multipart POST requests, and C1UploaderWebService, which uploads files using web services.

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.C1Uploader
C1.Silverlight.Uploader..::.C1UploaderPost
C1.Silverlight.Uploader..::.C1UploaderWebService

See Also

C1Uploader Members
C1.Silverlight.Uploader Namespace


C1Uploader Members

[image] [image]

.NET Framework Class Library
C1Uploader Members
C1Uploader Class Constructors Methods Fields Properties Events See Also

The C1Uploader type exposes the following members.

Constructors

Name | Description
C1Uploader | Initializes a new instance of a C1Uploader.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.
BeginUploadFiles | Begins uploading the files specified in the Files property.
Cancel | Cancels the current upload process.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server.

Properties

Name | Description
Files | Gets the collection of files that will be uploaded.
Headers | Gets the headers that will be sent to the server with each upload.
IsBusy | Gets whether the component is currently uploading files.
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload.
Parameters | Gets the parameters that will be sent to the server with each upload.
Settings | Gets the UploadManagerSettings that will be used to configure the C1Uploader.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events.

Events

Name | Description
UploadCompleted | Event raised when the upload has completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1Uploader Constructor

[image]

.NET Framework Class Library
C1Uploader Constructor
C1Uploader Class See Also
Initializes a new instance of a C1Uploader.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1Uploader(
    UploadManagerSettings settings,
    FilePackager filePackager,
    IUploadManager uploadManager
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As UploadManagerSettings, _
    filePackager As FilePackager, _
    uploadManager As IUploadManager _
)

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettings
UploadManagerSettings that specifies how the upload should be performed.
filePackager
Type: C1.Silverlight.Uploader..::.FilePackager
FilePackager used to map files into server requests.
uploadManager
Type: C1.Silverlight.Uploader..::.IUploadManager
IUploadManager object responsible for performing the upload.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1Uploader Fields

[image] [image]

.NET Framework Class Library
C1Uploader Fields
C1Uploader Class See Also

The C1Uploader type exposes the following members.

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


_manager Field

[image]

.NET Framework Class Library
C1Uploader..::._manager Field
C1Uploader Class See Also
Object responsible for packaging the files into requests and sending them to the server.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
protected IUploadManager _manager
Visual Basic (Declaration)
Protected _manager As IUploadManager

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1Uploader Methods

[image] [image]

.NET Framework Class Library
C1Uploader Methods
C1Uploader Class See Also

The C1Uploader type exposes the following members.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.
BeginUploadFiles | Begins uploading the files specified in the Files property.
Cancel | Cancels the current upload process.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


AddFile Method

[image] [image]

.NET Framework Class Library
C1Uploader..::.AddFile Method
C1Uploader Class See Also

Overload List

Name | Description
AddFile(FileInfo) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.
AddFile(String) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.
AddFile(String, Stream) | Adds a Stream to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.

See Also

C1Uploader Class
C1Uploader Members
C1.Silverlight.Uploader Namespace


AddFile Method (FileInfo)

[image]

.NET Framework Class Library
C1Uploader..::.AddFile Method (FileInfo)
C1Uploader Class See Also
Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void AddFile(
    FileInfo file
)
Visual Basic (Declaration)
Public Sub AddFile ( _
    file As FileInfo _
)

Parameters

file
Type: System.IO..::.FileInfo
FileInfo that identifies the file to be uploaded.

See Also

C1Uploader Class
AddFile Overload
C1.Silverlight.Uploader Namespace


AddFile Method (String)

[image]

.NET Framework Class Library
C1Uploader..::.AddFile Method (String)
C1Uploader Class See Also
Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void AddFile(
    string fileName
)
Visual Basic (Declaration)
Public Sub AddFile ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
Name of the file (in the Silverlight Isolated Storage) to be uploaded.

See Also

C1Uploader Class
AddFile Overload
C1.Silverlight.Uploader Namespace


AddFile Method (String, Stream)

[image]

.NET Framework Class Library
C1Uploader..::.AddFile Method (String, Stream)
C1Uploader Class See Also
Adds a Stream to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void AddFile(
    string name,
    Stream file
)
Visual Basic (Declaration)
Public Sub AddFile ( _
    name As String, _
    file As Stream _
)

Parameters

name
Type: System..::.String
Name of the file as it will be seen by the server.
file
Type: System.IO..::.Stream
Stream that contains the data to be uploaded.

See Also

C1Uploader Class
AddFile Overload
C1.Silverlight.Uploader Namespace


AddFiles Method

[image]

.NET Framework Class Library
C1Uploader..::.AddFiles Method
C1Uploader Class See Also
Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void AddFiles(
    IEnumerable<FileInfo> files
)
Visual Basic (Declaration)
Public Sub AddFiles ( _
    files As IEnumerable(Of FileInfo) _
)

Parameters

files
Type: System.Collections.Generic..::.IEnumerable <(Of <( FileInfo >)>)
Collection of FileInfo objects that specify the files to be uploaded.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


BeginUploadFiles Method

[image]

.NET Framework Class Library
C1Uploader..::.BeginUploadFiles Method
C1Uploader Class See Also
Begins uploading the files specified in the Files property.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool BeginUploadFiles()
Visual Basic (Declaration)
Public Function BeginUploadFiles As Boolean

Return Value

True if the upload started successfully, false if the C1Uploader is busy or if there are no files to upload.

Remarks

You can check the IsBusy property to determine whether the component is currently uploading files, and use the Cancel()()() method to cancel the current upload process.

Exceptions

Exception | Condition
C1.Silverlight.Uploader..::.MaximumUploadSizeExceededException |
C1.Silverlight.Uploader..::.InvalidAddressException |

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


Cancel Method

[image]

.NET Framework Class Library
C1Uploader..::.Cancel Method
C1Uploader Class See Also
Cancels the current upload process.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool Cancel()
Visual Basic (Declaration)
Public Function Cancel As Boolean

Return Value

True if the current upload process has been canceled successfully.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1Uploader Properties

[image] [image]

.NET Framework Class Library
C1Uploader Properties
C1Uploader Class See Also

The C1Uploader type exposes the following members.

Properties

Name | Description
Files | Gets the collection of files that will be uploaded.
Headers | Gets the headers that will be sent to the server with each upload.
IsBusy | Gets whether the component is currently uploading files.
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload.
Parameters | Gets the parameters that will be sent to the server with each upload.
Settings | Gets the UploadManagerSettings that will be used to configure the C1Uploader.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


Files Property

[image]

.NET Framework Class Library
C1Uploader..::.Files Property
C1Uploader Class See Also
Gets the collection of files that will be uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public List<UploadFileInfo> Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Files As List(Of UploadFileInfo)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


Headers Property

[image]

.NET Framework Class Library
C1Uploader..::.Headers Property
C1Uploader Class See Also
Gets the headers that will be sent to the server with each upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Dictionary<HttpRequestHeader, string> Headers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Headers As Dictionary(Of HttpRequestHeader, String)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


IsBusy Property

[image]

.NET Framework Class Library
C1Uploader..::.IsBusy Property
C1Uploader Class See Also
Gets whether the component is currently uploading files.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool IsBusy { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsBusy As Boolean

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


MaximumUploadSize Property

[image]

.NET Framework Class Library
C1Uploader..::.MaximumUploadSize Property
C1Uploader Class See Also
Gets or sets the maximum size in bytes allowed for each upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long MaximumUploadSize { get; set; }
Visual Basic (Declaration)
Public Property MaximumUploadSize As Long

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


Parameters Property

[image]

.NET Framework Class Library
C1Uploader..::.Parameters Property
C1Uploader Class See Also
Gets the parameters that will be sent to the server with each upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Dictionary<string, string> Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As Dictionary(Of String, String)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


Settings Property

[image]

.NET Framework Class Library
C1Uploader..::.Settings Property
C1Uploader Class See Also
Gets the UploadManagerSettings that will be used to configure the C1Uploader.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public virtual UploadManagerSettings Settings { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Settings As UploadManagerSettings

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


UserState Property

[image]

.NET Framework Class Library
C1Uploader..::.UserState Property
C1Uploader Class See Also
Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Object UserState { get; set; }
Visual Basic (Declaration)
Public Property UserState As Object

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1Uploader Events

[image] [image]

.NET Framework Class Library
C1Uploader Events
C1Uploader Class See Also

The C1Uploader type exposes the following members.

Events

Name | Description
UploadCompleted | Event raised when the upload has completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


UploadCompleted Event

[image]

.NET Framework Class Library
C1Uploader..::.UploadCompleted Event
C1Uploader Class See Also
Event raised when the upload has completed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadCompletedEventArgs> UploadCompleted
Visual Basic (Declaration)
Public Event UploadCompleted As EventHandler(Of UploadCompletedEventArgs)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


UploadProgressChanged Event

[image]

.NET Framework Class Library
C1Uploader..::.UploadProgressChanged Event
C1Uploader Class See Also
Event that fires when the upload process makes progress.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadProgressChangedEventArgs> UploadProgressChanged
Visual Basic (Declaration)
Public Event UploadProgressChanged As EventHandler(Of UploadProgressChangedEventArgs)

See Also

C1Uploader Class
C1.Silverlight.Uploader Namespace


C1UploaderPost Class

[image]

.NET Framework Class Library
C1UploaderPost Class
Members See Also
Represents a class that uploads files to the server using multipart POST messages.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class C1UploaderPost : C1Uploader
Visual Basic (Declaration)
Public Class C1UploaderPost _
    Inherits C1Uploader

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.C1Uploader
C1.Silverlight.Uploader..::.C1UploaderPost

See Also

C1UploaderPost Members
C1.Silverlight.Uploader Namespace


C1UploaderPost Members

[image] [image]

.NET Framework Class Library
C1UploaderPost Members
C1UploaderPost Class Constructors Methods Fields Properties Events See Also

The C1UploaderPost type exposes the following members.

Constructors

Name | Description
C1UploaderPost | Overloaded.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
BeginUploadFiles | Begins uploading the files specified in the Files property. (Inherited from C1Uploader.)
Cancel | Cancels the current upload process. (Inherited from C1Uploader.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server. (Inherited from C1Uploader.)

Properties

Name | Description
Files | Gets the collection of files that will be uploaded. (Inherited from C1Uploader.)
Headers | Gets the headers that will be sent to the server with each upload. (Inherited from C1Uploader.)
IsBusy | Gets whether the component is currently uploading files. (Inherited from C1Uploader.)
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload. (Inherited from C1Uploader.)
Parameters | Gets the parameters that will be sent to the server with each upload. (Inherited from C1Uploader.)
Settings | Gets the UploadManagerSettingsPost that specifies how the upload process should be performed.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events. (Inherited from C1Uploader.)

Events

Name | Description
UploadCompleted | Event raised when the upload has completed. (Inherited from C1Uploader.)
UploadProgressChanged | Event that fires when the upload process makes progress. (Inherited from C1Uploader.)

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


C1UploaderPost Constructor

[image] [image]

.NET Framework Class Library
C1UploaderPost Constructor
C1UploaderPost Class See Also

Overload List

Name | Description
C1UploaderPost(FilesPerRequest) | Initializes a new instance of a C1UploaderPost.
C1UploaderPost(UploadManagerSettingsPost) | Initializes a new instance of a C1UploaderPost.
C1UploaderPost(Uri) | Initializes a new instance of a C1UploaderPost.
C1UploaderPost(UploadManagerSettingsPost, FilePackager) | Initializes a new instance of a C1UploaderPost.

See Also

C1UploaderPost Class
C1UploaderPost Members
C1.Silverlight.Uploader Namespace


C1UploaderPost Constructor (FilesPerRequest)

[image]

.NET Framework Class Library
C1UploaderPost Constructor (FilesPerRequest)
C1UploaderPost Class See Also
Initializes a new instance of a C1UploaderPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderPost(
    FilesPerRequest filePackager
)
Visual Basic (Declaration)
Public Sub New ( _
    filePackager As FilesPerRequest _
)

Parameters

filePackager
Type: C1.Silverlight.Uploader..::.FilesPerRequest
FilesPerRequest value that specifies how files should be packaged into requests.

See Also

C1UploaderPost Class
C1UploaderPost Overload
C1.Silverlight.Uploader Namespace


C1UploaderPost Constructor (UploadManagerSettingsPost)

[image]

.NET Framework Class Library
C1UploaderPost Constructor (UploadManagerSettingsPost)
C1UploaderPost Class See Also
Initializes a new instance of a C1UploaderPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderPost(
    UploadManagerSettingsPost settings
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As UploadManagerSettingsPost _
)

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettingsPost
UploadManagerSettingsPost that specifies how the upload process will be performed.

See Also

C1UploaderPost Class
C1UploaderPost Overload
C1.Silverlight.Uploader Namespace


C1UploaderPost Constructor (Uri)

[image]

.NET Framework Class Library
C1UploaderPost Constructor (Uri)
C1UploaderPost Class See Also
Initializes a new instance of a C1UploaderPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderPost(
    Uri address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As Uri _
)

Parameters

address
Type: System..::.Uri
Uri that will receive the upload requests.

See Also

C1UploaderPost Class
C1UploaderPost Overload
C1.Silverlight.Uploader Namespace


C1UploaderPost Constructor (UploadManagerSettingsPost, FilePackager)

[image]

.NET Framework Class Library
C1UploaderPost Constructor (UploadManagerSettingsPost, FilePackager)
C1UploaderPost Class See Also
Initializes a new instance of a C1UploaderPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderPost(
    UploadManagerSettingsPost settings,
    FilePackager filePackager
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As UploadManagerSettingsPost, _
    filePackager As FilePackager _
)

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettingsPost
UploadManagerSettingsPost that specifies how the upload process will be performed.
filePackager
Type: C1.Silverlight.Uploader..::.FilePackager
FilesPerRequest value that specifies how files should be packaged into requests.

See Also

C1UploaderPost Class
C1UploaderPost Overload
C1.Silverlight.Uploader Namespace


C1UploaderPost Fields

[image] [image]

.NET Framework Class Library
C1UploaderPost Fields
C1UploaderPost Class See Also

The C1UploaderPost type exposes the following members.

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server. (Inherited from C1Uploader.)

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


C1UploaderPost Methods

[image] [image]

.NET Framework Class Library
C1UploaderPost Methods
C1UploaderPost Class See Also

The C1UploaderPost type exposes the following members.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
BeginUploadFiles | Begins uploading the files specified in the Files property. (Inherited from C1Uploader.)
Cancel | Cancels the current upload process. (Inherited from C1Uploader.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


AddFile Method

[image] [image]

.NET Framework Class Library
C1UploaderPost..::.AddFile Method
C1UploaderPost Class See Also

Overload List

Name | Description
AddFile(FileInfo) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
AddFile(String) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
AddFile(String, Stream) | Adds a Stream to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)

See Also

C1UploaderPost Class
C1UploaderPost Members
C1.Silverlight.Uploader Namespace


C1UploaderPost Properties

[image] [image]

.NET Framework Class Library
C1UploaderPost Properties
C1UploaderPost Class See Also

The C1UploaderPost type exposes the following members.

Properties

Name | Description
Files | Gets the collection of files that will be uploaded. (Inherited from C1Uploader.)
Headers | Gets the headers that will be sent to the server with each upload. (Inherited from C1Uploader.)
IsBusy | Gets whether the component is currently uploading files. (Inherited from C1Uploader.)
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload. (Inherited from C1Uploader.)
Parameters | Gets the parameters that will be sent to the server with each upload. (Inherited from C1Uploader.)
Settings | Gets the UploadManagerSettingsPost that specifies how the upload process should be performed.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events. (Inherited from C1Uploader.)

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


Settings Property

[image]

.NET Framework Class Library
C1UploaderPost..::.Settings Property
C1UploaderPost Class See Also
Gets the UploadManagerSettingsPost that specifies how the upload process should be performed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsPost Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As UploadManagerSettingsPost

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


C1UploaderPost Events

[image] [image]

.NET Framework Class Library
C1UploaderPost Events
C1UploaderPost Class See Also

The C1UploaderPost type exposes the following members.

Events

Name | Description
UploadCompleted | Event raised when the upload has completed. (Inherited from C1Uploader.)
UploadProgressChanged | Event that fires when the upload process makes progress. (Inherited from C1Uploader.)

See Also

C1UploaderPost Class
C1.Silverlight.Uploader Namespace


C1UploaderWebService Class

[image]

.NET Framework Class Library
C1UploaderWebService Class
Members See Also
Represents a class that uploads files to the server using Web services.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class C1UploaderWebService : C1Uploader
Visual Basic (Declaration)
Public Class C1UploaderWebService _
    Inherits C1Uploader

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.C1Uploader
C1.Silverlight.Uploader..::.C1UploaderWebService

See Also

C1UploaderWebService Members
C1.Silverlight.Uploader Namespace


C1UploaderWebService Members

[image] [image]

.NET Framework Class Library
C1UploaderWebService Members
C1UploaderWebService Class Constructors Methods Fields Properties Events See Also

The C1UploaderWebService type exposes the following members.

Constructors

Name | Description
C1UploaderWebService | Overloaded.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
BeginUploadFiles | Begins uploading the files specified in the Files property. (Inherited from C1Uploader.)
Cancel | Cancels the current upload process. (Inherited from C1Uploader.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server. (Inherited from C1Uploader.)

Properties

Name | Description
Files | Gets the collection of files that will be uploaded. (Inherited from C1Uploader.)
Headers | Gets the headers that will be sent to the server with each upload. (Inherited from C1Uploader.)
IsBusy | Gets whether the component is currently uploading files. (Inherited from C1Uploader.)
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload. (Inherited from C1Uploader.)
Parameters | Gets the parameters that will be sent to the server with each upload. (Inherited from C1Uploader.)
Settings | Gets the settings that will be used by the upload algorithm to do the uploads.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events. (Inherited from C1Uploader.)

Events

Name | Description
UploadCompleted | Event raised when the upload has completed. (Inherited from C1Uploader.)
UploadProgressChanged | Event that fires when the upload process makes progress. (Inherited from C1Uploader.)

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


C1UploaderWebService Constructor

[image] [image]

.NET Framework Class Library
C1UploaderWebService Constructor
C1UploaderWebService Class See Also

Overload List

Name | Description
C1UploaderWebService(FilesPerRequest) | Initializes a new instance of a C1UploaderWebService.
C1UploaderWebService(UploadManagerSettingsWebService) | Initializes a new instance of a C1UploaderWebService.
C1UploaderWebService(Uri) | Initializes a new instance of a C1UploaderWebService.
C1UploaderWebService(UploadManagerSettingsWebService, FilePackager) | Initializes a new instance of a C1UploaderWebService.

See Also

C1UploaderWebService Class
C1UploaderWebService Members
C1.Silverlight.Uploader Namespace


C1UploaderWebService Constructor (FilesPerRequest)

[image]

.NET Framework Class Library
C1UploaderWebService Constructor (FilesPerRequest)
C1UploaderWebService Class See Also
Initializes a new instance of a C1UploaderWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderWebService(
    FilesPerRequest splitter
)
Visual Basic (Declaration)
Public Sub New ( _
    splitter As FilesPerRequest _
)

Parameters

splitter
Type: C1.Silverlight.Uploader..::.FilesPerRequest
Splitter mode used to upload the files

See Also

C1UploaderWebService Class
C1UploaderWebService Overload
C1.Silverlight.Uploader Namespace


C1UploaderWebService Constructor (UploadManagerSettingsWebService)

[image]

.NET Framework Class Library
C1UploaderWebService Constructor (UploadManagerSettingsWebService)
C1UploaderWebService Class See Also
Initializes a new instance of a C1UploaderWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderWebService(
    UploadManagerSettingsWebService settings
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As UploadManagerSettingsWebService _
)

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettingsWebService
Settings that will be used by the upload algorithm to do the uploads

See Also

C1UploaderWebService Class
C1UploaderWebService Overload
C1.Silverlight.Uploader Namespace


C1UploaderWebService Constructor (Uri)

[image]

.NET Framework Class Library
C1UploaderWebService Constructor (Uri)
C1UploaderWebService Class See Also
Initializes a new instance of a C1UploaderWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderWebService(
    Uri address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As Uri _
)

Parameters

address
Type: System..::.Uri
Address of the service that will receive the upload

See Also

C1UploaderWebService Class
C1UploaderWebService Overload
C1.Silverlight.Uploader Namespace


C1UploaderWebService Constructor (UploadManagerSettingsWebService, FilePackager)

[image]

.NET Framework Class Library
C1UploaderWebService Constructor (UploadManagerSettingsWebService, FilePackager)
C1UploaderWebService Class See Also
Initializes a new instance of a C1UploaderWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public C1UploaderWebService(
    UploadManagerSettingsWebService settings,
    FilePackager algorithm
)
Visual Basic (Declaration)
Public Sub New ( _
    settings As UploadManagerSettingsWebService, _
    algorithm As FilePackager _
)

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettingsWebService
Settings that will be used by the upload algorithm to do the uploads
algorithm
Type: C1.Silverlight.Uploader..::.FilePackager

See Also

C1UploaderWebService Class
C1UploaderWebService Overload
C1.Silverlight.Uploader Namespace


C1UploaderWebService Fields

[image] [image]

.NET Framework Class Library
C1UploaderWebService Fields
C1UploaderWebService Class See Also

The C1UploaderWebService type exposes the following members.

Fields

Name | Description
_manager | Object responsible for packaging the files into requests and sending them to the server. (Inherited from C1Uploader.)

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


C1UploaderWebService Methods

[image] [image]

.NET Framework Class Library
C1UploaderWebService Methods
C1UploaderWebService Class See Also

The C1UploaderWebService type exposes the following members.

Methods

Name | Description
AddFile | Overloaded.
AddFiles | Adds a collection of files to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
BeginUploadFiles | Begins uploading the files specified in the Files property. (Inherited from C1Uploader.)
Cancel | Cancels the current upload process. (Inherited from C1Uploader.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


AddFile Method

[image] [image]

.NET Framework Class Library
C1UploaderWebService..::.AddFile Method
C1UploaderWebService Class See Also

Overload List

Name | Description
AddFile(FileInfo) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
AddFile(String) | Adds a file to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)
AddFile(String, Stream) | Adds a Stream to the Files collection that will be sent to the server when the BeginUploadFiles()()() method is invoked. (Inherited from C1Uploader.)

See Also

C1UploaderWebService Class
C1UploaderWebService Members
C1.Silverlight.Uploader Namespace


C1UploaderWebService Properties

[image] [image]

.NET Framework Class Library
C1UploaderWebService Properties
C1UploaderWebService Class See Also

The C1UploaderWebService type exposes the following members.

Properties

Name | Description
Files | Gets the collection of files that will be uploaded. (Inherited from C1Uploader.)
Headers | Gets the headers that will be sent to the server with each upload. (Inherited from C1Uploader.)
IsBusy | Gets whether the component is currently uploading files. (Inherited from C1Uploader.)
MaximumUploadSize | Gets or sets the maximum size in bytes allowed for each upload. (Inherited from C1Uploader.)
Parameters | Gets the parameters that will be sent to the server with each upload. (Inherited from C1Uploader.)
Settings | Gets the settings that will be used by the upload algorithm to do the uploads.
UserState | Gets or sets an arbitrary object that will be passed to the UploadCompleted and UploadProgressChanged events. (Inherited from C1Uploader.)

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


Settings Property

[image]

.NET Framework Class Library
C1UploaderWebService..::.Settings Property
C1UploaderWebService Class See Also
Gets the settings that will be used by the upload algorithm to do the uploads.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsWebService Settings { get; }
Visual Basic (Declaration)
Public ReadOnly Property Settings As UploadManagerSettingsWebService

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


C1UploaderWebService Events

[image] [image]

.NET Framework Class Library
C1UploaderWebService Events
C1UploaderWebService Class See Also

The C1UploaderWebService type exposes the following members.

Events

Name | Description
UploadCompleted | Event raised when the upload has completed. (Inherited from C1Uploader.)
UploadProgressChanged | Event that fires when the upload process makes progress. (Inherited from C1Uploader.)

See Also

C1UploaderWebService Class
C1.Silverlight.Uploader Namespace


FilePackager Class

[image]

.NET Framework Class Library
FilePackager Class
Members See Also
Represents an object that maps files into server requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public abstract class FilePackager
Visual Basic (Declaration)
Public MustInherit Class FilePackager

Remarks

FilePackager is the abstract base class of FilePackagerSingleFile, which uploads one file per request, FilePackagerMultiFile, which uploads multiple files per request, and FilePackagerPartialFile, which uploads partial files in each request.

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.FilePackager
C1.Silverlight.Uploader..::.FilePackagerMultiFile
C1.Silverlight.Uploader..::.FilePackagerPartialFile
C1.Silverlight.Uploader..::.FilePackagerSingleFile

See Also

FilePackager Members
C1.Silverlight.Uploader Namespace


FilePackager Members

[image] [image]

.NET Framework Class Library
FilePackager Members
FilePackager Class Constructors Methods Properties See Also

The FilePackager type exposes the following members.

Constructors

Name | Description
FilePackager | Initializes a new instance of a FilePackager.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum size needed to upload the files.
GetPackages | Gets a set of packages that should be uploaded
GetTotalSize | Gets the total size of all in the Files collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded.
MaximumUploadSize | Gets or sets the maximum size allowed per upload request.

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


FilePackager Constructor

[image]

.NET Framework Class Library
FilePackager Constructor
FilePackager Class See Also
Initializes a new instance of a FilePackager.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public FilePackager()
Visual Basic (Declaration)
Public Sub New

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


FilePackager Methods

[image] [image]

.NET Framework Class Library
FilePackager Methods
FilePackager Class See Also

The FilePackager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum size needed to upload the files.
GetPackages | Gets a set of packages that should be uploaded
GetTotalSize | Gets the total size of all in the Files collection.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


GetMaxSizePerUpload Method

[image]

.NET Framework Class Library
FilePackager..::.GetMaxSizePerUpload Method
FilePackager Class See Also
Gets the maximum size needed to upload the files.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public abstract long GetMaxSizePerUpload()
Visual Basic (Declaration)
Public MustOverride Function GetMaxSizePerUpload As Long

Return Value

Maximum size needed to upload the files

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


GetPackages Method

[image]

.NET Framework Class Library
FilePackager..::.GetPackages Method
FilePackager Class See Also
Gets a set of packages that should be uploaded

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public abstract IEnumerable<UploadFilePartPackage> GetPackages()
Visual Basic (Declaration)
Public MustOverride Function GetPackages As IEnumerable(Of UploadFilePartPackage)

Return Value

Set of packages that should be uploaded

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


GetTotalSize Method

[image]

.NET Framework Class Library
FilePackager..::.GetTotalSize Method
FilePackager Class See Also
Gets the total size of all in the Files collection.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long GetTotalSize()
Visual Basic (Declaration)
Public Function GetTotalSize As Long

Return Value

Amount of size of all files

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


FilePackager Properties

[image] [image]

.NET Framework Class Library
FilePackager Properties
FilePackager Class See Also

The FilePackager type exposes the following members.

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded.
MaximumUploadSize | Gets or sets the maximum size allowed per upload request.

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


Files Property

[image]

.NET Framework Class Library
FilePackager..::.Files Property
FilePackager Class See Also
Gets or sets a list of files to be uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public List<UploadFileInfo> Files { get; set; }
Visual Basic (Declaration)
Public Property Files As List(Of UploadFileInfo)

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


MaximumUploadSize Property

[image]

.NET Framework Class Library
FilePackager..::.MaximumUploadSize Property
FilePackager Class See Also
Gets or sets the maximum size allowed per upload request.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long MaximumUploadSize { get; set; }
Visual Basic (Declaration)
Public Property MaximumUploadSize As Long

See Also

FilePackager Class
C1.Silverlight.Uploader Namespace


FilePackagerFactory Class

[image]

.NET Framework Class Library
FilePackagerFactory Class
Members See Also
Static class that creates FilePackager objects.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public static class FilePackagerFactory
Visual Basic (Declaration)
Public NotInheritable Class FilePackagerFactory

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.FilePackagerFactory

See Also

FilePackagerFactory Members
C1.Silverlight.Uploader Namespace


FilePackagerFactory Members

[image] [image]

.NET Framework Class Library
FilePackagerFactory Members
FilePackagerFactory Class Methods See Also

The FilePackagerFactory type exposes the following members.

Methods

Name | Description
Create | Creates FilePackager objects.

See Also

FilePackagerFactory Class
C1.Silverlight.Uploader Namespace


FilePackagerFactory Methods

[image] [image]

.NET Framework Class Library
FilePackagerFactory Methods
FilePackagerFactory Class See Also

The FilePackagerFactory type exposes the following members.

Methods

Name | Description
Create | Creates FilePackager objects.

See Also

FilePackagerFactory Class
C1.Silverlight.Uploader Namespace


Create Method

[image]

.NET Framework Class Library
FilePackagerFactory..::.Create Method
FilePackagerFactory Class See Also
Creates FilePackager objects.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public static FilePackager Create(
    FilesPerRequest mode
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    mode As FilesPerRequest _
) As FilePackager

Parameters

mode
Type: C1.Silverlight.Uploader..::.FilesPerRequest
FilesPerRequest value that specifies the type of FilePackager to create.

Return Value

A new FilePackager object.

See Also

FilePackagerFactory Class
C1.Silverlight.Uploader Namespace


FilePackagerMultiFile Class

[image]

.NET Framework Class Library
FilePackagerMultiFile Class
Members See Also
FilePackager that packages multiple files per request.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class FilePackagerMultiFile : FilePackager
Visual Basic (Declaration)
Public Class FilePackagerMultiFile _
    Inherits FilePackager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.FilePackager
C1.Silverlight.Uploader..::.FilePackagerMultiFile

See Also

FilePackagerMultiFile Members
C1.Silverlight.Uploader Namespace


FilePackagerMultiFile Members

[image] [image]

.NET Framework Class Library
FilePackagerMultiFile Members
FilePackagerMultiFile Class Constructors Methods Properties See Also

The FilePackagerMultiFile type exposes the following members.

Constructors

Name | Description
FilePackagerMultiFile | Initializes a new instance of a FilePackagerMultiFile.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum amount of size needed to upload the files (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


FilePackagerMultiFile Constructor

[image]

.NET Framework Class Library
FilePackagerMultiFile Constructor
FilePackagerMultiFile Class See Also
Initializes a new instance of a FilePackagerMultiFile.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public FilePackagerMultiFile()
Visual Basic (Declaration)
Public Sub New

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


FilePackagerMultiFile Methods

[image] [image]

.NET Framework Class Library
FilePackagerMultiFile Methods
FilePackagerMultiFile Class See Also

The FilePackagerMultiFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum amount of size needed to upload the files (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


GetMaxSizePerUpload Method

[image]

.NET Framework Class Library
FilePackagerMultiFile..::.GetMaxSizePerUpload Method
FilePackagerMultiFile Class See Also
Gets the maximum amount of size needed to upload the files

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override long GetMaxSizePerUpload()
Visual Basic (Declaration)
Public Overrides Function GetMaxSizePerUpload As Long

Return Value

Maximum amount of size needed to upload the files

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


GetPackages Method

[image]

.NET Framework Class Library
FilePackagerMultiFile..::.GetPackages Method
FilePackagerMultiFile Class See Also
Gets a set of packages that should be uploaded

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override IEnumerable<UploadFilePartPackage> GetPackages()
Visual Basic (Declaration)
Public Overrides Function GetPackages As IEnumerable(Of UploadFilePartPackage)

Return Value

Set of packages that should be uploaded

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


FilePackagerMultiFile Properties

[image] [image]

.NET Framework Class Library
FilePackagerMultiFile Properties
FilePackagerMultiFile Class See Also

The FilePackagerMultiFile type exposes the following members.

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerMultiFile Class
C1.Silverlight.Uploader Namespace


FilePackagerPartialFile Class

[image]

.NET Framework Class Library
FilePackagerPartialFile Class
Members See Also
FilePackager that breaks up files into multiple requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class FilePackagerPartialFile : FilePackager
Visual Basic (Declaration)
Public Class FilePackagerPartialFile _
    Inherits FilePackager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.FilePackager
C1.Silverlight.Uploader..::.FilePackagerPartialFile

See Also

FilePackagerPartialFile Members
C1.Silverlight.Uploader Namespace


FilePackagerPartialFile Members

[image] [image]

.NET Framework Class Library
FilePackagerPartialFile Members
FilePackagerPartialFile Class Constructors Methods Properties See Also

The FilePackagerPartialFile type exposes the following members.

Constructors

Name | Description
FilePackagerPartialFile | Initializes a new instance of a FilePackagerPartialFile.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the size needed to upload the files. (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded. (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


FilePackagerPartialFile Constructor

[image]

.NET Framework Class Library
FilePackagerPartialFile Constructor
FilePackagerPartialFile Class See Also
Initializes a new instance of a FilePackagerPartialFile.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public FilePackagerPartialFile()
Visual Basic (Declaration)
Public Sub New

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


FilePackagerPartialFile Methods

[image] [image]

.NET Framework Class Library
FilePackagerPartialFile Methods
FilePackagerPartialFile Class See Also

The FilePackagerPartialFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the size needed to upload the files. (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded. (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


GetMaxSizePerUpload Method

[image]

.NET Framework Class Library
FilePackagerPartialFile..::.GetMaxSizePerUpload Method
FilePackagerPartialFile Class See Also
Gets the size needed to upload the files.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override long GetMaxSizePerUpload()
Visual Basic (Declaration)
Public Overrides Function GetMaxSizePerUpload As Long

Return Value

Maximum amount of size needed to upload the files

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


GetPackages Method

[image]

.NET Framework Class Library
FilePackagerPartialFile..::.GetPackages Method
FilePackagerPartialFile Class See Also
Gets a set of packages that should be uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override IEnumerable<UploadFilePartPackage> GetPackages()
Visual Basic (Declaration)
Public Overrides Function GetPackages As IEnumerable(Of UploadFilePartPackage)

Return Value

Set of packages that should be uploaded.

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


FilePackagerPartialFile Properties

[image] [image]

.NET Framework Class Library
FilePackagerPartialFile Properties
FilePackagerPartialFile Class See Also

The FilePackagerPartialFile type exposes the following members.

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerPartialFile Class
C1.Silverlight.Uploader Namespace


FilePackagerSingleFile Class

[image]

.NET Framework Class Library
FilePackagerSingleFile Class
Members See Also
FilePackager that packages one file per request.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class FilePackagerSingleFile : FilePackager
Visual Basic (Declaration)
Public Class FilePackagerSingleFile _
    Inherits FilePackager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.FilePackager
C1.Silverlight.Uploader..::.FilePackagerSingleFile

See Also

FilePackagerSingleFile Members
C1.Silverlight.Uploader Namespace


FilePackagerSingleFile Members

[image] [image]

.NET Framework Class Library
FilePackagerSingleFile Members
FilePackagerSingleFile Class Constructors Methods Properties See Also

The FilePackagerSingleFile type exposes the following members.

Constructors

Name | Description
FilePackagerSingleFile | Initializes a new instance of a FilePackagerSingleFile.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum upload size needed to upload the files. (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


FilePackagerSingleFile Constructor

[image]

.NET Framework Class Library
FilePackagerSingleFile Constructor
FilePackagerSingleFile Class See Also
Initializes a new instance of a FilePackagerSingleFile.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public FilePackagerSingleFile()
Visual Basic (Declaration)
Public Sub New

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


FilePackagerSingleFile Methods

[image] [image]

.NET Framework Class Library
FilePackagerSingleFile Methods
FilePackagerSingleFile Class See Also

The FilePackagerSingleFile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetMaxSizePerUpload | Gets the maximum upload size needed to upload the files. (Overrides FilePackager..::.GetMaxSizePerUpload()()().)
GetPackages | Gets a set of packages that should be uploaded (Overrides FilePackager..::.GetPackages()()().)
GetTotalSize | Gets the total size of all in the Files collection. (Inherited from FilePackager.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


GetMaxSizePerUpload Method

[image]

.NET Framework Class Library
FilePackagerSingleFile..::.GetMaxSizePerUpload Method
FilePackagerSingleFile Class See Also
Gets the maximum upload size needed to upload the files.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override long GetMaxSizePerUpload()
Visual Basic (Declaration)
Public Overrides Function GetMaxSizePerUpload As Long

Return Value

Maximum amount of size needed to upload the files

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


GetPackages Method

[image]

.NET Framework Class Library
FilePackagerSingleFile..::.GetPackages Method
FilePackagerSingleFile Class See Also
Gets a set of packages that should be uploaded

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public override IEnumerable<UploadFilePartPackage> GetPackages()
Visual Basic (Declaration)
Public Overrides Function GetPackages As IEnumerable(Of UploadFilePartPackage)

Return Value

Set of packages that should be uploaded

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


FilePackagerSingleFile Properties

[image] [image]

.NET Framework Class Library
FilePackagerSingleFile Properties
FilePackagerSingleFile Class See Also

The FilePackagerSingleFile type exposes the following members.

Properties

Name | Description
Files | Gets or sets a list of files to be uploaded. (Inherited from FilePackager.)
MaximumUploadSize | Gets or sets the maximum size allowed per upload request. (Inherited from FilePackager.)

See Also

FilePackagerSingleFile Class
C1.Silverlight.Uploader Namespace


FilesPerRequest Enumeration

[image]

.NET Framework Class Library
FilesPerRequest Enumeration
See Also
Specifies how files are mapped into server requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public enum FilesPerRequest
Visual Basic (Declaration)
Public Enumeration FilesPerRequest

Members

Member name | Description
OneFilePerRequest | Each request contains one file. This is the default setting.
AllFilesInOneRequest | All files will be uploaded in a single request. This is more efficient when uploading many small files.
SplitFilesIntoMultipleRequests | Each file will be split into multiple requests. Indicated when uploading very large files.

See Also

C1.Silverlight.Uploader Namespace


InvalidAddressException Class

[image]

.NET Framework Class Library
InvalidAddressException Class
Members See Also
This exception is raised if the address of the service to be called is not correct.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class InvalidAddressException : Exception
Visual Basic (Declaration)
Public Class InvalidAddressException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
C1.Silverlight.Uploader..::.InvalidAddressException

See Also

InvalidAddressException Members
C1.Silverlight.Uploader Namespace


InvalidAddressException Members

[image] [image]

.NET Framework Class Library
InvalidAddressException Members
InvalidAddressException Class Constructors Methods Properties See Also

The InvalidAddressException type exposes the following members.

Constructors

Name | Description
InvalidAddressException | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidAddressException Class
C1.Silverlight.Uploader Namespace


InvalidAddressException Constructor

[image] [image]

.NET Framework Class Library
InvalidAddressException Constructor
InvalidAddressException Class See Also

Overload List

Name | Description
InvalidAddressException()()() | Initializes a new instance of a InvalidAddressException.
InvalidAddressException(Exception) | Initializes a new instance of a InvalidAddressException.

See Also

InvalidAddressException Class
InvalidAddressException Members
C1.Silverlight.Uploader Namespace


InvalidAddressException Constructor

[image]

.NET Framework Class Library
InvalidAddressException Constructor
InvalidAddressException Class See Also
Initializes a new instance of a InvalidAddressException.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public InvalidAddressException()
Visual Basic (Declaration)
Public Sub New

See Also

InvalidAddressException Class
InvalidAddressException Overload
C1.Silverlight.Uploader Namespace


InvalidAddressException Constructor (Exception)

[image]

.NET Framework Class Library
InvalidAddressException Constructor (Exception)
InvalidAddressException Class See Also
Initializes a new instance of a InvalidAddressException.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public InvalidAddressException(
    Exception innerException
)
Visual Basic (Declaration)
Public Sub New ( _
    innerException As Exception _
)

Parameters

innerException
Type: System..::.Exception
the exception that is the cause of the current exception

See Also

InvalidAddressException Class
InvalidAddressException Overload
C1.Silverlight.Uploader Namespace


InvalidAddressException Methods

[image] [image]

.NET Framework Class Library
InvalidAddressException Methods
InvalidAddressException Class See Also

The InvalidAddressException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

InvalidAddressException Class
C1.Silverlight.Uploader Namespace


InvalidAddressException Properties

[image] [image]

.NET Framework Class Library
InvalidAddressException Properties
InvalidAddressException Class See Also

The InvalidAddressException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

InvalidAddressException Class
C1.Silverlight.Uploader Namespace


IUploadManager Interface

[image]

.NET Framework Class Library
IUploadManager Interface
Members See Also
Interface implemented by classes that package files into server requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public interface IUploadManager
Visual Basic (Declaration)
Public Interface IUploadManager

See Also

IUploadManager Members
C1.Silverlight.Uploader Namespace


IUploadManager Members

[image] [image]

.NET Framework Class Library
IUploadManager Members
IUploadManager Interface Methods Events See Also

The IUploadManager type exposes the following members.

Methods

Name | Description
BeginUpload | Begins the upload of one UploadFilePartPackage
Cancel | Cancels the current upload process.

Events

Name | Description
UploadCompleted | Event that fires when the upload process has been completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


IUploadManager Methods

[image] [image]

.NET Framework Class Library
IUploadManager Methods
IUploadManager Interface See Also

The IUploadManager type exposes the following members.

Methods

Name | Description
BeginUpload | Begins the upload of one UploadFilePartPackage
Cancel | Cancels the current upload process.

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


BeginUpload Method

[image]

.NET Framework Class Library
IUploadManager..::.BeginUpload Method
IUploadManager Interface See Also
Begins the upload of one UploadFilePartPackage

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
bool BeginUpload(
    UploadManagerSettings settings,
    UploadFilePartPackage package,
    Dictionary<HttpRequestHeader, string> headers,
    Dictionary<string, string> parameters
)
Visual Basic (Declaration)
Function BeginUpload ( _
    settings As UploadManagerSettings, _
    package As UploadFilePartPackage, _
    headers As Dictionary(Of HttpRequestHeader, String), _
    parameters As Dictionary(Of String, String) _
) As Boolean

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettings
UploadManagerSettings that specify how to perform the upload.
package
Type: C1.Silverlight.Uploader..::.UploadFilePartPackage
UploadFilePartPackage that contains file parts to be uploaded.
headers
Type: System.Collections.Generic..::.Dictionary <(Of <( HttpRequestHeader, String >)>)
Headers that will be sent with the upload requests.
parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)
Parameters that will be sent to the server with the upload requests.

Return Value

Returns true if the upload process started successfully.

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


Cancel Method

[image]

.NET Framework Class Library
IUploadManager..::.Cancel Method
IUploadManager Interface See Also
Cancels the current upload process.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
void Cancel()
Visual Basic (Declaration)
Sub Cancel

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


IUploadManager Events

[image] [image]

.NET Framework Class Library
IUploadManager Events
IUploadManager Interface See Also

The IUploadManager type exposes the following members.

Events

Name | Description
UploadCompleted | Event that fires when the upload process has been completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


UploadCompleted Event

[image]

.NET Framework Class Library
IUploadManager..::.UploadCompleted Event
IUploadManager Interface See Also
Event that fires when the upload process has been completed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
event EventHandler<UploadCompletedEventArgs> UploadCompleted
Visual Basic (Declaration)
Event UploadCompleted As EventHandler(Of UploadCompletedEventArgs)

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


UploadProgressChanged Event

[image]

.NET Framework Class Library
IUploadManager..::.UploadProgressChanged Event
IUploadManager Interface See Also
Event that fires when the upload process makes progress.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
event EventHandler<UploadProgressChangedEventArgs> UploadProgressChanged
Visual Basic (Declaration)
Event UploadProgressChanged As EventHandler(Of UploadProgressChangedEventArgs)

See Also

IUploadManager Interface
C1.Silverlight.Uploader Namespace


MaximumUploadSizeExceededException Class

[image]

.NET Framework Class Library
MaximumUploadSizeExceededException Class
Members See Also
This exception is raised when the size needed to do the upload is greater than the size specified by the user.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class MaximumUploadSizeExceededException : Exception
Visual Basic (Declaration)
Public Class MaximumUploadSizeExceededException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
C1.Silverlight.Uploader..::.MaximumUploadSizeExceededException

See Also

MaximumUploadSizeExceededException Members
C1.Silverlight.Uploader Namespace


MaximumUploadSizeExceededException Members

[image] [image]

.NET Framework Class Library
MaximumUploadSizeExceededException Members
MaximumUploadSizeExceededException Class Constructors Methods Properties See Also

The MaximumUploadSizeExceededException type exposes the following members.

Constructors

Name | Description
MaximumUploadSizeExceededException | Initializes a new instance of a MaximumUploadSizeExceededException.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MaximumUploadSizeExceededException Class
C1.Silverlight.Uploader Namespace


MaximumUploadSizeExceededException Constructor

[image]

.NET Framework Class Library
MaximumUploadSizeExceededException Constructor
MaximumUploadSizeExceededException Class See Also
Initializes a new instance of a MaximumUploadSizeExceededException.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public MaximumUploadSizeExceededException()
Visual Basic (Declaration)
Public Sub New

See Also

MaximumUploadSizeExceededException Class
C1.Silverlight.Uploader Namespace


MaximumUploadSizeExceededException Methods

[image] [image]

.NET Framework Class Library
MaximumUploadSizeExceededException Methods
MaximumUploadSizeExceededException Class See Also

The MaximumUploadSizeExceededException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

MaximumUploadSizeExceededException Class
C1.Silverlight.Uploader Namespace


MaximumUploadSizeExceededException Properties

[image] [image]

.NET Framework Class Library
MaximumUploadSizeExceededException Properties
MaximumUploadSizeExceededException Class See Also

The MaximumUploadSizeExceededException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

MaximumUploadSizeExceededException Class
C1.Silverlight.Uploader Namespace


MultipartPostEncoding Enumeration

[image]

.NET Framework Class Library
MultipartPostEncoding Enumeration
See Also
Specifies the encoding of the data that will be sent in the post message.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public enum MultipartPostEncoding
Visual Basic (Declaration)
Public Enumeration MultipartPostEncoding

Members

Member name | Description
Binary | Data encoded in binary format.
Base64 | Data encoded in Base64 format

See Also

C1.Silverlight.Uploader Namespace


UploadCompletedEventArgs Class

[image]

.NET Framework Class Library
UploadCompletedEventArgs Class
Members See Also
Contains data about upload completed event of the upload file

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadCompletedEventArgs : AsyncCompletedEventArgs
Visual Basic (Declaration)
Public Class UploadCompletedEventArgs _
    Inherits AsyncCompletedEventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
System.ComponentModel..::.AsyncCompletedEventArgs
C1.Silverlight.Uploader..::.UploadCompletedEventArgs

See Also

UploadCompletedEventArgs Members
C1.Silverlight.Uploader Namespace


UploadCompletedEventArgs Members

[image] [image]

.NET Framework Class Library
UploadCompletedEventArgs Members
UploadCompletedEventArgs Class Constructors Methods Properties See Also

The UploadCompletedEventArgs type exposes the following members.

Constructors

Name | Description
UploadCompletedEventArgs | Initializes a new instance of a UploadCompletedEventArgs.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Files | Array of names of the files uploaded
Response | Response returned by the server in the message body.
Success | True if all the files were uploaded successfully.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadCompletedEventArgs Constructor

[image]

.NET Framework Class Library
UploadCompletedEventArgs Constructor
UploadCompletedEventArgs Class See Also
Initializes a new instance of a UploadCompletedEventArgs.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadCompletedEventArgs(
    bool success,
    bool cancelled,
    Exception error,
    string[] files,
    Object response,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    success As Boolean, _
    cancelled As Boolean, _
    error As Exception, _
    files As String(), _
    response As Object, _
    userState As Object _
)

Parameters

success
Type: System..::.Boolean
True if all the files were uploaded successfully
cancelled
Type: System..::.Boolean
True if the user cancelled the request
error
Type: System..::.Exception
Exception returned if something was wrong
files
Type: array< System..::.String >[]()[]
Array of names of the files uploaded
response
Type: System..::.Object
Response returned by the server in the message body
userState
Type: System..::.Object
Additional information attached by the user

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadCompletedEventArgs Methods

[image] [image]

.NET Framework Class Library
UploadCompletedEventArgs Methods
UploadCompletedEventArgs Class See Also

The UploadCompletedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
RaiseExceptionIfNecessary | Raises a user-supplied exception if an asynchronous operation failed. (Inherited from AsyncCompletedEventArgs.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadCompletedEventArgs Properties

[image] [image]

.NET Framework Class Library
UploadCompletedEventArgs Properties
UploadCompletedEventArgs Class See Also

The UploadCompletedEventArgs type exposes the following members.

Properties

Name | Description
Cancelled | Gets a value indicating whether an asynchronous operation has been canceled. (Inherited from AsyncCompletedEventArgs.)
Error | Gets a value indicating which error occurred during an asynchronous operation. (Inherited from AsyncCompletedEventArgs.)
Files | Array of names of the files uploaded
Response | Response returned by the server in the message body.
Success | True if all the files were uploaded successfully.
UserState | Gets the unique identifier for the asynchronous task. (Inherited from AsyncCompletedEventArgs.)

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


Files Property

[image]

.NET Framework Class Library
UploadCompletedEventArgs..::.Files Property
UploadCompletedEventArgs Class See Also
Array of names of the files uploaded

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string[] Files { get; }
Visual Basic (Declaration)
Public ReadOnly Property Files As String()

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


Response Property

[image]

.NET Framework Class Library
UploadCompletedEventArgs..::.Response Property
UploadCompletedEventArgs Class See Also
Response returned by the server in the message body.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Object Response { get; }
Visual Basic (Declaration)
Public ReadOnly Property Response As Object

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


Success Property

[image]

.NET Framework Class Library
UploadCompletedEventArgs..::.Success Property
UploadCompletedEventArgs Class See Also
True if all the files were uploaded successfully.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool Success { get; }
Visual Basic (Declaration)
Public ReadOnly Property Success As Boolean

See Also

UploadCompletedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadFileInfo Class

[image]

.NET Framework Class Library
UploadFileInfo Class
Members See Also
Wraps the information of files that comes from different sources.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadFileInfo
Visual Basic (Declaration)
Public Class UploadFileInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadFileInfo

See Also

UploadFileInfo Members
C1.Silverlight.Uploader Namespace


UploadFileInfo Members

[image] [image]

.NET Framework Class Library
UploadFileInfo Members
UploadFileInfo Class Constructors Methods Properties See Also

The UploadFileInfo type exposes the following members.

Constructors

Name | Description
UploadFileInfo | Overloaded.

Methods

Name | Description
Close | Closes the file if it is opened.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSize | Gets the size in bytes of a file.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Opens the file if it is not opened.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
File | Data of the file.
Name | Name of the file.

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


UploadFileInfo Constructor

[image] [image]

.NET Framework Class Library
UploadFileInfo Constructor
UploadFileInfo Class See Also

Overload List

Name | Description
UploadFileInfo(FileInfo) | Initializes a new instance of a UploadFileInfo.
UploadFileInfo(String) | Initializes a new instance of a UploadFileInfo.
UploadFileInfo(String, Stream) | Initializes a new instance of a UploadFileInfo.

See Also

UploadFileInfo Class
UploadFileInfo Members
C1.Silverlight.Uploader Namespace


UploadFileInfo Constructor (FileInfo)

[image]

.NET Framework Class Library
UploadFileInfo Constructor (FileInfo)
UploadFileInfo Class See Also
Initializes a new instance of a UploadFileInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFileInfo(
    FileInfo file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As FileInfo _
)

Parameters

file
Type: System.IO..::.FileInfo
File that comes from OpenFileDialog

See Also

UploadFileInfo Class
UploadFileInfo Overload
C1.Silverlight.Uploader Namespace


UploadFileInfo Constructor (String)

[image]

.NET Framework Class Library
UploadFileInfo Constructor (String)
UploadFileInfo Class See Also
Initializes a new instance of a UploadFileInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFileInfo(
    string fileName
)
Visual Basic (Declaration)
Public Sub New ( _
    fileName As String _
)

Parameters

fileName
Type: System..::.String
Name of the file in the Isolated Storage

See Also

UploadFileInfo Class
UploadFileInfo Overload
C1.Silverlight.Uploader Namespace


UploadFileInfo Constructor (String, Stream)

[image]

.NET Framework Class Library
UploadFileInfo Constructor (String, Stream)
UploadFileInfo Class See Also
Initializes a new instance of a UploadFileInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFileInfo(
    string name,
    Stream file
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    file As Stream _
)

Parameters

name
Type: System..::.String
Name of the file
file
Type: System.IO..::.Stream
Stream that contains the data of the file

See Also

UploadFileInfo Class
UploadFileInfo Overload
C1.Silverlight.Uploader Namespace


UploadFileInfo Methods

[image] [image]

.NET Framework Class Library
UploadFileInfo Methods
UploadFileInfo Class See Also

The UploadFileInfo type exposes the following members.

Methods

Name | Description
Close | Closes the file if it is opened.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSize | Gets the size in bytes of a file.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Prepare | Opens the file if it is not opened.
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


Close Method

[image]

.NET Framework Class Library
UploadFileInfo..::.Close Method
UploadFileInfo Class See Also
Closes the file if it is opened.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void Close()
Visual Basic (Declaration)
Public Sub Close

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


GetSize Method

[image]

.NET Framework Class Library
UploadFileInfo..::.GetSize Method
UploadFileInfo Class See Also
Gets the size in bytes of a file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long GetSize()
Visual Basic (Declaration)
Public Function GetSize As Long

Return Value

Return the size in bytes of a file.

Remarks

If the Prepare()()() method has not been called the size will be 0.

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


Prepare Method

[image]

.NET Framework Class Library
UploadFileInfo..::.Prepare Method
UploadFileInfo Class See Also
Opens the file if it is not opened.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void Prepare()
Visual Basic (Declaration)
Public Sub Prepare

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


UploadFileInfo Properties

[image] [image]

.NET Framework Class Library
UploadFileInfo Properties
UploadFileInfo Class See Also

The UploadFileInfo type exposes the following members.

Properties

Name | Description
File | Data of the file.
Name | Name of the file.

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


File Property

[image]

.NET Framework Class Library
UploadFileInfo..::.File Property
UploadFileInfo Class See Also
Data of the file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Stream File { get; }
Visual Basic (Declaration)
Public ReadOnly Property File As Stream

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


Name Property

[image]

.NET Framework Class Library
UploadFileInfo..::.Name Property
UploadFileInfo Class See Also
Name of the file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

UploadFileInfo Class
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Class

[image]

.NET Framework Class Library
UploadFilePartInfo Class
Members See Also
Represents a file part. It can be a file or a file segment.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadFilePartInfo
Visual Basic (Declaration)
Public Class UploadFilePartInfo

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadFilePartInfo

See Also

UploadFilePartInfo Members
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Members

[image] [image]

.NET Framework Class Library
UploadFilePartInfo Members
UploadFilePartInfo Class Constructors Methods Properties See Also

The UploadFilePartInfo type exposes the following members.

Constructors

Name | Description
UploadFilePartInfo | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSize | Gets the size of a file part.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Data | Gets the data of the file part
Name | Gets the name of the file part.
PartCount | Gets the total number of parts associated with the owner file.
PartNumber | Gets the index of a part within the owner file.

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Constructor

[image] [image]

.NET Framework Class Library
UploadFilePartInfo Constructor
UploadFilePartInfo Class See Also

Overload List

Name | Description
UploadFilePartInfo(UploadFileInfo) | Initializes a new instance of a UploadFilePartInfo.
UploadFilePartInfo(String, array<Byte>[]()[], Int32, Int32) | Initializes a new instance of a UploadFilePartInfo.

See Also

UploadFilePartInfo Class
UploadFilePartInfo Members
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Constructor (UploadFileInfo)

[image]

.NET Framework Class Library
UploadFilePartInfo Constructor (UploadFileInfo)
UploadFilePartInfo Class See Also
Initializes a new instance of a UploadFilePartInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFilePartInfo(
    UploadFileInfo file
)
Visual Basic (Declaration)
Public Sub New ( _
    file As UploadFileInfo _
)

Parameters

file
Type: C1.Silverlight.Uploader..::.UploadFileInfo
File that will be wrapped in a UploadFilePartInfo

See Also

UploadFilePartInfo Class
UploadFilePartInfo Overload
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Constructor (String, Byte[], Int32, Int32)

[image]

.NET Framework Class Library
UploadFilePartInfo Constructor (String, array<Byte>[]()[], Int32, Int32)
UploadFilePartInfo Class See Also
Initializes a new instance of a UploadFilePartInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFilePartInfo(
    string filePartName,
    byte[] filePartData,
    int partNumber,
    int partCount
)
Visual Basic (Declaration)
Public Sub New ( _
    filePartName As String, _
    filePartData As Byte(), _
    partNumber As Integer, _
    partCount As Integer _
)

Parameters

filePartName
Type: System..::.String
Name of the file part
filePartData
Type: array< System..::.Byte >[]()[]
Data of the file part
partNumber
Type: System..::.Int32
Index of the file part in the file
partCount
Type: System..::.Int32
Total number of parts for the file

See Also

UploadFilePartInfo Class
UploadFilePartInfo Overload
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Methods

[image] [image]

.NET Framework Class Library
UploadFilePartInfo Methods
UploadFilePartInfo Class See Also

The UploadFilePartInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetSize | Gets the size of a file part.
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


GetSize Method

[image]

.NET Framework Class Library
UploadFilePartInfo..::.GetSize Method
UploadFilePartInfo Class See Also
Gets the size of a file part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long GetSize()
Visual Basic (Declaration)
Public Function GetSize As Long

Return Value

Size of the file part.

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


UploadFilePartInfo Properties

[image] [image]

.NET Framework Class Library
UploadFilePartInfo Properties
UploadFilePartInfo Class See Also

The UploadFilePartInfo type exposes the following members.

Properties

Name | Description
Data | Gets the data of the file part
Name | Gets the name of the file part.
PartCount | Gets the total number of parts associated with the owner file.
PartNumber | Gets the index of a part within the owner file.

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


Data Property

[image]

.NET Framework Class Library
UploadFilePartInfo..::.Data Property
UploadFilePartInfo Class See Also
Gets the data of the file part

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public byte[] Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As Byte()

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


Name Property

[image]

.NET Framework Class Library
UploadFilePartInfo..::.Name Property
UploadFilePartInfo Class See Also
Gets the name of the file part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


PartCount Property

[image]

.NET Framework Class Library
UploadFilePartInfo..::.PartCount Property
UploadFilePartInfo Class See Also
Gets the total number of parts associated with the owner file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public int PartCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartCount As Integer

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


PartNumber Property

[image]

.NET Framework Class Library
UploadFilePartInfo..::.PartNumber Property
UploadFilePartInfo Class See Also
Gets the index of a part within the owner file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public int PartNumber { get; }
Visual Basic (Declaration)
Public ReadOnly Property PartNumber As Integer

See Also

UploadFilePartInfo Class
C1.Silverlight.Uploader Namespace


UploadFilePartPackage Class

[image]

.NET Framework Class Library
UploadFilePartPackage Class
Members See Also
Contains a sets of UploadFilePartInfo.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadFilePartPackage : List<UploadFilePartInfo>
Visual Basic (Declaration)
Public Class UploadFilePartPackage _
    Inherits List(Of UploadFilePartInfo)

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( UploadFilePartInfo >)>)
C1.Silverlight.Uploader..::.UploadFilePartPackage

See Also

UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


UploadFilePartPackage Members

[image] [image]

.NET Framework Class Library
UploadFilePartPackage Members
UploadFilePartPackage Class Constructors Methods Properties See Also

The UploadFilePartPackage type exposes the following members.

Constructors

Name | Description
UploadFilePartPackage |

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetSize | Gets the size of the package.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ServerWaitForOneFile | Gets or sets whether the package should be uploaded as a one only file package.

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


UploadFilePartPackage Constructor

[image]

.NET Framework Class Library
UploadFilePartPackage Constructor
UploadFilePartPackage Class See Also

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadFilePartPackage()
Visual Basic (Declaration)
Public Sub New

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


UploadFilePartPackage Methods

[image] [image]

.NET Framework Class Library
UploadFilePartPackage Methods
UploadFilePartPackage Class See Also

The UploadFilePartPackage type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindAll | Retrieves the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
GetSize | Gets the size of the package.
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


BinarySearch Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.BinarySearch Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


CopyTo Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.CopyTo Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


FindIndex Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.FindIndex Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


FindLastIndex Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.FindLastIndex Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


GetSize Method

[image]

.NET Framework Class Library
UploadFilePartPackage..::.GetSize Method
UploadFilePartPackage Class See Also
Gets the size of the package.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long GetSize()
Visual Basic (Declaration)
Public Function GetSize As Long

Return Value

Size of the package.

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


IndexOf Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.IndexOf Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


LastIndexOf Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.LastIndexOf Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


Reverse Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.Reverse Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


Sort Method

[image] [image]

.NET Framework Class Library
UploadFilePartPackage..::.Sort Method
UploadFilePartPackage Class See Also

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( UploadFilePartInfo >)>).)

See Also

UploadFilePartPackage Class
UploadFilePartPackage Members
C1.Silverlight.Uploader Namespace


UploadFilePartPackage Properties

[image] [image]

.NET Framework Class Library
UploadFilePartPackage Properties
UploadFilePartPackage Class See Also

The UploadFilePartPackage type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( UploadFilePartInfo >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( UploadFilePartInfo >)>).)
ServerWaitForOneFile | Gets or sets whether the package should be uploaded as a one only file package.

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


ServerWaitForOneFile Property

[image]

.NET Framework Class Library
UploadFilePartPackage..::.ServerWaitForOneFile Property
UploadFilePartPackage Class See Also
Gets or sets whether the package should be uploaded as a one only file package.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool ServerWaitForOneFile { get; set; }
Visual Basic (Declaration)
Public Property ServerWaitForOneFile As Boolean

See Also

UploadFilePartPackage Class
C1.Silverlight.Uploader Namespace


UploadManagerPost Class

[image]

.NET Framework Class Library
UploadManagerPost Class
Members See Also
Class that packages files into multipart POST requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadManagerPost : IUploadManager
Visual Basic (Declaration)
Public Class UploadManagerPost _
    Implements IUploadManager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadManagerPost

See Also

UploadManagerPost Members
C1.Silverlight.Uploader Namespace


UploadManagerPost Members

[image] [image]

.NET Framework Class Library
UploadManagerPost Members
UploadManagerPost Class Constructors Methods Events See Also

The UploadManagerPost type exposes the following members.

Constructors

Name | Description
UploadManagerPost |

Methods

Name | Description
BeginUpload | Begins the upload of a set of parts.
Cancel | Aborts the execution of the upload.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
UploadCompleted | It is raised when the upload has been completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadManagerPost Constructor

[image]

.NET Framework Class Library
UploadManagerPost Constructor
UploadManagerPost Class See Also

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerPost()
Visual Basic (Declaration)
Public Sub New

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadManagerPost Methods

[image] [image]

.NET Framework Class Library
UploadManagerPost Methods
UploadManagerPost Class See Also

The UploadManagerPost type exposes the following members.

Methods

Name | Description
BeginUpload | Begins the upload of a set of parts.
Cancel | Aborts the execution of the upload.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


BeginUpload Method

[image]

.NET Framework Class Library
UploadManagerPost..::.BeginUpload Method
UploadManagerPost Class See Also
Begins the upload of a set of parts.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool BeginUpload(
    UploadManagerSettings settings,
    UploadFilePartPackage package,
    Dictionary<HttpRequestHeader, string> headers,
    Dictionary<string, string> parameters
)
Visual Basic (Declaration)
Public Function BeginUpload ( _
    settings As UploadManagerSettings, _
    package As UploadFilePartPackage, _
    headers As Dictionary(Of HttpRequestHeader, String), _
    parameters As Dictionary(Of String, String) _
) As Boolean

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettings
Settings used to upload the part.
package
Type: C1.Silverlight.Uploader..::.UploadFilePartPackage
Package of file parts to be uploaded.
headers
Type: System.Collections.Generic..::.Dictionary <(Of <( HttpRequestHeader, String >)>)
Headers that will be sent within the upload.
parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)
Parameter that will be sent to the server together with the part.

Return Value

Returns True if the upload has been started correctly.

Implements

IUploadManager..::.BeginUpload(UploadManagerSettings, UploadFilePartPackage, Dictionary<(Of <(HttpRequestHeader, String>)>), Dictionary<(Of <(String, String>)>))

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


Cancel Method

[image]

.NET Framework Class Library
UploadManagerPost..::.Cancel Method
UploadManagerPost Class See Also
Aborts the execution of the upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel

Implements

IUploadManager..::.Cancel()()()

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadManagerPost Events

[image] [image]

.NET Framework Class Library
UploadManagerPost Events
UploadManagerPost Class See Also

The UploadManagerPost type exposes the following members.

Events

Name | Description
UploadCompleted | It is raised when the upload has been completed.
UploadProgressChanged | Event that fires when the upload process makes progress.

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadCompleted Event

[image]

.NET Framework Class Library
UploadManagerPost..::.UploadCompleted Event
UploadManagerPost Class See Also
It is raised when the upload has been completed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadCompletedEventArgs> UploadCompleted
Visual Basic (Declaration)
Public Event UploadCompleted As EventHandler(Of UploadCompletedEventArgs)

Implements

IUploadManager..::.UploadCompleted

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadProgressChanged Event

[image]

.NET Framework Class Library
UploadManagerPost..::.UploadProgressChanged Event
UploadManagerPost Class See Also
Event that fires when the upload process makes progress.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadProgressChangedEventArgs> UploadProgressChanged
Visual Basic (Declaration)
Public Event UploadProgressChanged As EventHandler(Of UploadProgressChangedEventArgs)

Implements

IUploadManager..::.UploadProgressChanged

See Also

UploadManagerPost Class
C1.Silverlight.Uploader Namespace


UploadManagerSettings Class

[image]

.NET Framework Class Library
UploadManagerSettings Class
Members See Also
Contains parameters that specify the behavior of IUploadManager objects.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public abstract class UploadManagerSettings
Visual Basic (Declaration)
Public MustInherit Class UploadManagerSettings

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadManagerSettings
C1.Silverlight.Uploader..::.UploadManagerSettingsPost
C1.Silverlight.Uploader..::.UploadManagerSettingsWebService

See Also

UploadManagerSettings Members
C1.Silverlight.Uploader Namespace


UploadManagerSettings Members

[image] [image]

.NET Framework Class Library
UploadManagerSettings Members
UploadManagerSettings Class Constructors Methods Properties See Also

The UploadManagerSettings type exposes the following members.

Constructors

Name | Description
UploadManagerSettings | Initializes a new instance of a UploadManagerSettings.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload

See Also

UploadManagerSettings Class
C1.Silverlight.Uploader Namespace


UploadManagerSettings Constructor

[image]

.NET Framework Class Library
UploadManagerSettings Constructor
UploadManagerSettings Class See Also
Initializes a new instance of a UploadManagerSettings.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettings(
    Uri address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As Uri _
)

Parameters

address
Type: System..::.Uri
Uri of the service that will receive the upload requests.

See Also

UploadManagerSettings Class
C1.Silverlight.Uploader Namespace


UploadManagerSettings Methods

[image] [image]

.NET Framework Class Library
UploadManagerSettings Methods
UploadManagerSettings Class See Also

The UploadManagerSettings type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadManagerSettings Class
C1.Silverlight.Uploader Namespace


UploadManagerSettings Properties

[image] [image]

.NET Framework Class Library
UploadManagerSettings Properties
UploadManagerSettings Class See Also

The UploadManagerSettings type exposes the following members.

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload

See Also

UploadManagerSettings Class
C1.Silverlight.Uploader Namespace


Address Property

[image]

.NET Framework Class Library
UploadManagerSettings..::.Address Property
UploadManagerSettings Class See Also
Gets or sets the address of the service that will receive the upload

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
[TypeConverterAttribute(typeof(Uri))]
public Uri Address { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(GetType(Uri))> _
Public Property Address As Uri

See Also

UploadManagerSettings Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Class

[image]

.NET Framework Class Library
UploadManagerSettingsPost Class
Members See Also
Contains parameters that specify the behavior of UploadManagerPost objects.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadManagerSettingsPost : UploadManagerSettings
Visual Basic (Declaration)
Public Class UploadManagerSettingsPost _
    Inherits UploadManagerSettings

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadManagerSettings
C1.Silverlight.Uploader..::.UploadManagerSettingsPost

See Also

UploadManagerSettingsPost Members
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Members

[image] [image]

.NET Framework Class Library
UploadManagerSettingsPost Members
UploadManagerSettingsPost Class Constructors Methods Properties See Also

The UploadManagerSettingsPost type exposes the following members.

Constructors

Name | Description
UploadManagerSettingsPost | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload (Inherited from UploadManagerSettings.)
Boundary | Gets or sets the boundary used to create the multipart post.
TransferEncoding | Gets or sets the encoding used to transfer the parts to the server.

See Also

UploadManagerSettingsPost Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Constructor

[image] [image]

.NET Framework Class Library
UploadManagerSettingsPost Constructor
UploadManagerSettingsPost Class See Also

Overload List

Name | Description
UploadManagerSettingsPost()()() | Initializes a new instance of a UploadManagerSettingsPost.
UploadManagerSettingsPost(Uri) | Initializes a new instance of a UploadManagerSettingsPost.

See Also

UploadManagerSettingsPost Class
UploadManagerSettingsPost Members
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Constructor

[image]

.NET Framework Class Library
UploadManagerSettingsPost Constructor
UploadManagerSettingsPost Class See Also
Initializes a new instance of a UploadManagerSettingsPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsPost()
Visual Basic (Declaration)
Public Sub New

See Also

UploadManagerSettingsPost Class
UploadManagerSettingsPost Overload
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Constructor (Uri)

[image]

.NET Framework Class Library
UploadManagerSettingsPost Constructor (Uri)
UploadManagerSettingsPost Class See Also
Initializes a new instance of a UploadManagerSettingsPost.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsPost(
    Uri address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As Uri _
)

Parameters

address
Type: System..::.Uri
Address of the service that will receive the upload

See Also

UploadManagerSettingsPost Class
UploadManagerSettingsPost Overload
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Methods

[image] [image]

.NET Framework Class Library
UploadManagerSettingsPost Methods
UploadManagerSettingsPost Class See Also

The UploadManagerSettingsPost type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadManagerSettingsPost Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsPost Properties

[image] [image]

.NET Framework Class Library
UploadManagerSettingsPost Properties
UploadManagerSettingsPost Class See Also

The UploadManagerSettingsPost type exposes the following members.

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload (Inherited from UploadManagerSettings.)
Boundary | Gets or sets the boundary used to create the multipart post.
TransferEncoding | Gets or sets the encoding used to transfer the parts to the server.

See Also

UploadManagerSettingsPost Class
C1.Silverlight.Uploader Namespace


Boundary Property

[image]

.NET Framework Class Library
UploadManagerSettingsPost..::.Boundary Property
UploadManagerSettingsPost Class See Also
Gets or sets the boundary used to create the multipart post.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string Boundary { get; set; }
Visual Basic (Declaration)
Public Property Boundary As String

Remarks

If no boundary is specified the system will generate one randomly (Recommended).

See Also

UploadManagerSettingsPost Class
C1.Silverlight.Uploader Namespace


TransferEncoding Property

[image]

.NET Framework Class Library
UploadManagerSettingsPost..::.TransferEncoding Property
UploadManagerSettingsPost Class See Also
Gets or sets the encoding used to transfer the parts to the server.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public MultipartPostEncoding TransferEncoding { get; set; }
Visual Basic (Declaration)
Public Property TransferEncoding As MultipartPostEncoding

See Also

UploadManagerSettingsPost Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Class

[image]

.NET Framework Class Library
UploadManagerSettingsWebService Class
Members See Also
Contains parameters that specify the behavior of UploadManagerWebService objects.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadManagerSettingsWebService : UploadManagerSettings
Visual Basic (Declaration)
Public Class UploadManagerSettingsWebService _
    Inherits UploadManagerSettings

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadManagerSettings
C1.Silverlight.Uploader..::.UploadManagerSettingsWebService

See Also

UploadManagerSettingsWebService Members
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Members

[image] [image]

.NET Framework Class Library
UploadManagerSettingsWebService Members
UploadManagerSettingsWebService Class Constructors Methods Properties See Also

The UploadManagerSettingsWebService type exposes the following members.

Constructors

Name | Description
UploadManagerSettingsWebService | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload (Inherited from UploadManagerSettings.)
MethodManyFiles | Gets or sets the name of the WebMethod which receives the upload.
MethodOneFile | Gets or sets the name of the WebMethod which receives the upload.
Namespace | Gets or sets the namespace of the WebService which receive the upload.
ParamFileData | Gets or sets the name of the parameter that receives the data of the part.
ParamFileName | Gets or sets the name of the parameter that receives the name of the part.
ParamFiles | Gets or sets the name of the parameter that receives the list of files.
ParamParameters | Gets or sets the name of the parameter that receives optional parameters specified in the Uploader component.
ParamPartCount | Gets or sets the name of the parameter that receives the number of parts.
ParamPartNumber | Gets or sets the name of the parameter that receives the index of the part.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Constructor

[image] [image]

.NET Framework Class Library
UploadManagerSettingsWebService Constructor
UploadManagerSettingsWebService Class See Also

Overload List

Name | Description
UploadManagerSettingsWebService()()() | Initializes a new instance of a UploadManagerSettingsWebService.
UploadManagerSettingsWebService(Uri) | Initializes a new instance of a UploadManagerSettingsWebService.

See Also

UploadManagerSettingsWebService Class
UploadManagerSettingsWebService Members
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Constructor

[image]

.NET Framework Class Library
UploadManagerSettingsWebService Constructor
UploadManagerSettingsWebService Class See Also
Initializes a new instance of a UploadManagerSettingsWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsWebService()
Visual Basic (Declaration)
Public Sub New

See Also

UploadManagerSettingsWebService Class
UploadManagerSettingsWebService Overload
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Constructor (Uri)

[image]

.NET Framework Class Library
UploadManagerSettingsWebService Constructor (Uri)
UploadManagerSettingsWebService Class See Also
Initializes a new instance of a UploadManagerSettingsWebService.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerSettingsWebService(
    Uri address
)
Visual Basic (Declaration)
Public Sub New ( _
    address As Uri _
)

Parameters

address
Type: System..::.Uri
Uri of the service that will receive the upload requests.

See Also

UploadManagerSettingsWebService Class
UploadManagerSettingsWebService Overload
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Methods

[image] [image]

.NET Framework Class Library
UploadManagerSettingsWebService Methods
UploadManagerSettingsWebService Class See Also

The UploadManagerSettingsWebService type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerSettingsWebService Properties

[image] [image]

.NET Framework Class Library
UploadManagerSettingsWebService Properties
UploadManagerSettingsWebService Class See Also

The UploadManagerSettingsWebService type exposes the following members.

Properties

Name | Description
Address | Gets or sets the address of the service that will receive the upload (Inherited from UploadManagerSettings.)
MethodManyFiles | Gets or sets the name of the WebMethod which receives the upload.
MethodOneFile | Gets or sets the name of the WebMethod which receives the upload.
Namespace | Gets or sets the namespace of the WebService which receive the upload.
ParamFileData | Gets or sets the name of the parameter that receives the data of the part.
ParamFileName | Gets or sets the name of the parameter that receives the name of the part.
ParamFiles | Gets or sets the name of the parameter that receives the list of files.
ParamParameters | Gets or sets the name of the parameter that receives optional parameters specified in the Uploader component.
ParamPartCount | Gets or sets the name of the parameter that receives the number of parts.
ParamPartNumber | Gets or sets the name of the parameter that receives the index of the part.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


MethodManyFiles Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.MethodManyFiles Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the WebMethod which receives the upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string MethodManyFiles { get; set; }
Visual Basic (Declaration)
Public Property MethodManyFiles As String

Remarks

Default value is UploadFiles.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


MethodOneFile Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.MethodOneFile Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the WebMethod which receives the upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string MethodOneFile { get; set; }
Visual Basic (Declaration)
Public Property MethodOneFile As String

Remarks

Default value is UploadFile.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


Namespace Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.Namespace Property
UploadManagerSettingsWebService Class See Also
Gets or sets the namespace of the WebService which receive the upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string Namespace { get; set; }
Visual Basic (Declaration)
Public Property Namespace As String

Remarks

Default value is http://tempuri.org/.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamFileData Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamFileData Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives the data of the part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamFileData { get; set; }
Visual Basic (Declaration)
Public Property ParamFileData As String

Remarks

The data is received as a string formatted in base64.

Remarks

Default value is fileData.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamFileName Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamFileName Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives the name of the part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamFileName { get; set; }
Visual Basic (Declaration)
Public Property ParamFileName As String

Remarks

Default value is filename.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamFiles Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamFiles Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives the list of files.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamFiles { get; set; }
Visual Basic (Declaration)
Public Property ParamFiles As String

Remarks

Default value is files.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamParameters Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamParameters Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives optional parameters specified in the Uploader component.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamParameters { get; set; }
Visual Basic (Declaration)
Public Property ParamParameters As String

Remarks

Default value is parameters.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamPartCount Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamPartCount Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives the number of parts.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamPartCount { get; set; }
Visual Basic (Declaration)
Public Property ParamPartCount As String

Remarks

Default value is partCount.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


ParamPartNumber Property

[image]

.NET Framework Class Library
UploadManagerSettingsWebService..::.ParamPartNumber Property
UploadManagerSettingsWebService Class See Also
Gets or sets the name of the parameter that receives the index of the part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public string ParamPartNumber { get; set; }
Visual Basic (Declaration)
Public Property ParamPartNumber As String

Remarks

Default value is partNumber.

See Also

UploadManagerSettingsWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerWebService Class

[image]

.NET Framework Class Library
UploadManagerWebService Class
Members See Also
Class that packages files into Web Service requests.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadManagerWebService : IUploadManager
Visual Basic (Declaration)
Public Class UploadManagerWebService _
    Implements IUploadManager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.Uploader..::.UploadManagerWebService

See Also

UploadManagerWebService Members
C1.Silverlight.Uploader Namespace


UploadManagerWebService Members

[image] [image]

.NET Framework Class Library
UploadManagerWebService Members
UploadManagerWebService Class Constructors Methods Events See Also

The UploadManagerWebService type exposes the following members.

Constructors

Name | Description
UploadManagerWebService |

Methods

Name | Description
BeginUpload | Begins the upload of one part.
Cancel | Aborts the execution of the upload.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Events

Name | Description
UploadCompleted | It is raised when the upload has been completed.
UploadProgressChanged | It is raised when the progress of the upload has changed.

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerWebService Constructor

[image]

.NET Framework Class Library
UploadManagerWebService Constructor
UploadManagerWebService Class See Also

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadManagerWebService()
Visual Basic (Declaration)
Public Sub New

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerWebService Methods

[image] [image]

.NET Framework Class Library
UploadManagerWebService Methods
UploadManagerWebService Class See Also

The UploadManagerWebService type exposes the following members.

Methods

Name | Description
BeginUpload | Begins the upload of one part.
Cancel | Aborts the execution of the upload.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


BeginUpload Method

[image]

.NET Framework Class Library
UploadManagerWebService..::.BeginUpload Method
UploadManagerWebService Class See Also
Begins the upload of one part.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public bool BeginUpload(
    UploadManagerSettings settings,
    UploadFilePartPackage package,
    Dictionary<HttpRequestHeader, string> headers,
    Dictionary<string, string> parameters
)
Visual Basic (Declaration)
Public Function BeginUpload ( _
    settings As UploadManagerSettings, _
    package As UploadFilePartPackage, _
    headers As Dictionary(Of HttpRequestHeader, String), _
    parameters As Dictionary(Of String, String) _
) As Boolean

Parameters

settings
Type: C1.Silverlight.Uploader..::.UploadManagerSettings
Settings used to upload the part.
package
Type: C1.Silverlight.Uploader..::.UploadFilePartPackage
Package of file parts to be uploaded.
headers
Type: System.Collections.Generic..::.Dictionary <(Of <( HttpRequestHeader, String >)>)
Headers that will be sent within the upload.
parameters
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)
Parameter that will be sent to the server together with the part.

Return Value

Returns True, if the upload has been started correctly.

Implements

IUploadManager..::.BeginUpload(UploadManagerSettings, UploadFilePartPackage, Dictionary<(Of <(HttpRequestHeader, String>)>), Dictionary<(Of <(String, String>)>))

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


Cancel Method

[image]

.NET Framework Class Library
UploadManagerWebService..::.Cancel Method
UploadManagerWebService Class See Also
Aborts the execution of the upload.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public void Cancel()
Visual Basic (Declaration)
Public Sub Cancel

Implements

IUploadManager..::.Cancel()()()

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadManagerWebService Events

[image] [image]

.NET Framework Class Library
UploadManagerWebService Events
UploadManagerWebService Class See Also

The UploadManagerWebService type exposes the following members.

Events

Name | Description
UploadCompleted | It is raised when the upload has been completed.
UploadProgressChanged | It is raised when the progress of the upload has changed.

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadCompleted Event

[image]

.NET Framework Class Library
UploadManagerWebService..::.UploadCompleted Event
UploadManagerWebService Class See Also
It is raised when the upload has been completed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadCompletedEventArgs> UploadCompleted
Visual Basic (Declaration)
Public Event UploadCompleted As EventHandler(Of UploadCompletedEventArgs)

Implements

IUploadManager..::.UploadCompleted

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadProgressChanged Event

[image]

.NET Framework Class Library
UploadManagerWebService..::.UploadProgressChanged Event
UploadManagerWebService Class See Also
It is raised when the progress of the upload has changed.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public event EventHandler<UploadProgressChangedEventArgs> UploadProgressChanged
Visual Basic (Declaration)
Public Event UploadProgressChanged As EventHandler(Of UploadProgressChangedEventArgs)

Implements

IUploadManager..::.UploadProgressChanged

See Also

UploadManagerWebService Class
C1.Silverlight.Uploader Namespace


UploadProgressChangedEventArgs Class

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs Class
Members See Also
Contains data about progress changed event of the upload file.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public class UploadProgressChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class UploadProgressChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.Uploader..::.UploadProgressChangedEventArgs

See Also

UploadProgressChangedEventArgs Members
C1.Silverlight.Uploader Namespace


UploadProgressChangedEventArgs Members

[image] [image]

.NET Framework Class Library
UploadProgressChangedEventArgs Members
UploadProgressChangedEventArgs Class Constructors Methods Properties See Also

The UploadProgressChangedEventArgs type exposes the following members.

Constructors

Name | Description
UploadProgressChangedEventArgs | Initializes a new instance of a UploadProgressChangedEventArgs.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
BytesUploaded | Amount of bytes that were uploaded.
ProgressPercentage | Percentage of bytes that were uploaded.
TotalBytesToUpload | Amount of bytes that must be uploaded.
UserState | Additional information attached by the user.

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadProgressChangedEventArgs Constructor

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs Constructor
UploadProgressChangedEventArgs Class See Also
Initializes a new instance of a UploadProgressChangedEventArgs.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public UploadProgressChangedEventArgs(
    long bytesUploaded,
    long totalBytesToUpload,
    Object userState
)
Visual Basic (Declaration)
Public Sub New ( _
    bytesUploaded As Long, _
    totalBytesToUpload As Long, _
    userState As Object _
)

Parameters

bytesUploaded
Type: System..::.Int64
Amount of bytes that were uploaded
totalBytesToUpload
Type: System..::.Int64
Amount of bytes that must be uploaded
userState
Type: System..::.Object
Additional information attached by the user

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadProgressChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
UploadProgressChangedEventArgs Methods
UploadProgressChangedEventArgs Class See Also

The UploadProgressChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


UploadProgressChangedEventArgs Properties

[image] [image]

.NET Framework Class Library
UploadProgressChangedEventArgs Properties
UploadProgressChangedEventArgs Class See Also

The UploadProgressChangedEventArgs type exposes the following members.

Properties

Name | Description
BytesUploaded | Amount of bytes that were uploaded.
ProgressPercentage | Percentage of bytes that were uploaded.
TotalBytesToUpload | Amount of bytes that must be uploaded.
UserState | Additional information attached by the user.

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


BytesUploaded Property

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs..::.BytesUploaded Property
UploadProgressChangedEventArgs Class See Also
Amount of bytes that were uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long BytesUploaded { get; }
Visual Basic (Declaration)
Public ReadOnly Property BytesUploaded As Long

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


ProgressPercentage Property

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs..::.ProgressPercentage Property
UploadProgressChangedEventArgs Class See Also
Percentage of bytes that were uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public int ProgressPercentage { get; }
Visual Basic (Declaration)
Public ReadOnly Property ProgressPercentage As Integer

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


TotalBytesToUpload Property

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs..::.TotalBytesToUpload Property
UploadProgressChangedEventArgs Class See Also
Amount of bytes that must be uploaded.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public long TotalBytesToUpload { get; }
Visual Basic (Declaration)
Public ReadOnly Property TotalBytesToUpload As Long

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


UserState Property

[image]

.NET Framework Class Library
UploadProgressChangedEventArgs..::.UserState Property
UploadProgressChangedEventArgs Class See Also
Additional information attached by the user.

Namespace: C1.Silverlight.Uploader
Assembly: C1.Silverlight.Uploader (in C1.Silverlight.Uploader.dll)

Syntax

C#
public Object UserState { get; }
Visual Basic (Declaration)
Public ReadOnly Property UserState As Object

See Also

UploadProgressChangedEventArgs Class
C1.Silverlight.Uploader Namespace


C1.Silverlight.DataGrid Namespace

[image]

.NET Framework Class Library
C1.Silverlight.DataGrid Namespace

Classes

Class | Description
BoundConverter |
C1DataGrid |
C1ScrollBarHelper |
ColumnMovedEventArgs |
ComboValueInfo |
DataConnection |
DataGridAutoGeneratingColumnEventArgs |
DataGridBeganEditEventArgs |
DataGridBeginningEditEventArgs |
DataGridBoundColumn |
DataGridCell |
DataGridCellContentPanel |
DataGridCellEventArgs |
DataGridCellPresenter |
DataGridCellsPanel |
DataGridCheckBoxColumn |
DataGridCheckBoxFilter |
DataGridColumn |
DataGridColumnEventArgs |
DataGridColumnHeader |
DataGridColumnReorderingEventArgs |
DataGridColumnsHeaderPanel |
DataGridComboBoxColumn |
DataGridComboBoxFilter |
DataGridDateColumn |
DataGridDateFilter |
DataGridEndingEditEventArgs |
DataGridFilter |
DataGridFilterManager |
DataGridImageColumn |
DataGridMainPanel |
DataGridNumericColumn |
DataGridNumericFilter |
DataGridRow |
DataGridRowCollection |
DataGridRowDetailsEventArgs |
DataGridRowEventArgs |
DataGridRowHeader |
DataGridRowPresenter |
DataGridRowRequestingDetailsEventArgs |
DataGridRowsHeaderPanel |
DataGridSortChangedEventArgs |
DataGridSortingManager |
DataGridTemplateColumn |
DataGridTextColumn |
DataGridTextFilter |
DataSourceView |
EditableCheckBox |
Extensions |
FilterDescription |
FinalizeEditingException |
GridLengthConverter |
GroupDescription |
NumericComparator |
NumericConverter |
PerformanceClock |
ReadOnlyCheckBox |
SortDescription |

Interfaces

Interface | Description
IDataGridFilter |
IDataSourceView |
IEditableObject |

Delegates

Delegate | Description
CancellingCellEditEventHandler |
DataGridColumnHeader..::.SortingStateChangedEventHandler |
LoadingFilterEventHandler |
PreparingCellEditEventHandler |

Enumerations

Enumeration | Description
DataGridCellsContentType |
DataGridEditingUnit |
DataGridHeaders |
DataGridRowDetailsVisibilityMode |
DataGridSortingState |
MergeStrategy |
NumericComparison |


BoundConverter Class

[image]

.NET Framework Class Library
BoundConverter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class BoundConverter : IValueConverter
Visual Basic (Declaration)
Public Class BoundConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.BoundConverter

See Also

BoundConverter Members
C1.Silverlight.DataGrid Namespace


BoundConverter Members

[image] [image]

.NET Framework Class Library
BoundConverter Members
BoundConverter Class Constructors Methods See Also

The BoundConverter type exposes the following members.

Constructors

Name | Description
BoundConverter |

Methods

Name | Description
Convert |
ConvertBack |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundConverter Class
C1.Silverlight.DataGrid Namespace


BoundConverter Constructor

[image]

.NET Framework Class Library
BoundConverter Constructor
BoundConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public BoundConverter()
Visual Basic (Declaration)
Public Sub New

See Also

BoundConverter Class
C1.Silverlight.DataGrid Namespace


BoundConverter Methods

[image] [image]

.NET Framework Class Library
BoundConverter Methods
BoundConverter Class See Also

The BoundConverter type exposes the following members.

Methods

Name | Description
Convert |
ConvertBack |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

BoundConverter Class
C1.Silverlight.DataGrid Namespace


Convert Method

[image]

.NET Framework Class Library
BoundConverter..::.Convert Method
BoundConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

BoundConverter Class
C1.Silverlight.DataGrid Namespace


ConvertBack Method

[image]

.NET Framework Class Library
BoundConverter..::.ConvertBack Method
BoundConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

BoundConverter Class
C1.Silverlight.DataGrid Namespace


C1DataGrid Class

[image]

.NET Framework Class Library
C1DataGrid Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "Body", Type = typeof(DataGridMainPanel))]
[TemplateVisualStateAttribute(Name = "Ready", GroupName = "LoadingStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Loading", GroupName = "LoadingStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "HorizontalScrollBar", Type = typeof(ScrollBar))]
[TemplatePartAttribute(Name = "VerticalScrollBar", Type = typeof(ScrollBar))]
[TemplatePartAttribute(Name = "RowsHeader", Type = typeof(DataGridRowsHeaderPanel))]
[TemplatePartAttribute(Name = "ColumnsHeader", Type = typeof(DataGridColumnsHeaderPanel))]
[TemplatePartAttribute(Name = "Root", Type = typeof(Grid))]
public class C1DataGrid : Control
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "Body", Type := GetType(DataGridMainPanel))> _
<TemplateVisualStateAttribute(Name := "Ready", GroupName := "LoadingStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Loading", GroupName := "LoadingStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "HorizontalScrollBar", Type := GetType(ScrollBar))> _
<TemplatePartAttribute(Name := "VerticalScrollBar", Type := GetType(ScrollBar))> _
<TemplatePartAttribute(Name := "RowsHeader", Type := GetType(DataGridRowsHeaderPanel))> _
<TemplatePartAttribute(Name := "ColumnsHeader", Type := GetType(DataGridColumnsHeaderPanel))> _
<TemplatePartAttribute(Name := "Root", Type := GetType(Grid))> _
Public Class C1DataGrid _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.C1DataGrid

See Also

C1DataGrid Members
C1.Silverlight.DataGrid Namespace


C1DataGrid Members

[image] [image]

.NET Framework Class Library
C1DataGrid Members
C1DataGrid Class Constructors Methods Fields Properties Events See Also

The C1DataGrid type exposes the following members.

Constructors

Name | Description
C1DataGrid |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginEdit | Overloaded.
CancelEdit |
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateLoading |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EndEdit | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetCell |
GetCellFromPoint |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
Refresh |
ReleaseMouseCapture | (Inherited from UIElement.)
Reload |
ScrollIntoView | Overloaded.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
AlternatingRowBackgroundProperty |
AutoGenerateColumnsProperty |
BodyRectProperty |
CanUserFilterProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserResizeRowsProperty |
CanUserSortProperty |
ColumnHeaderHeightProperty |
ColumnHeaderStyleProperty |
ColumnsProperty |
ColumnWidthProperty |
CurrentColumnProperty |
CurrentRowProperty |
DragOverColumnStyleProperty |
DragSourceColumnStyleProperty |
DropIndicatorStyleProperty |
FilterStyleProperty |
FluidMouseOverBrushProperty |
FocusStyleProperty |
HeadersVisibilityProperty |
HorizontalScrollBarVisibilityProperty |
IsLoadingProperty |
IsMouseOverProperty |
IsReadOnlyProperty |
ItemsSourceProperty |
MaxColumnWidthProperty |
MaxRowHeightProperty |
MinColumnWidthProperty |
MinRowHeightProperty |
RowBackgroundProperty |
RowDetailsTemplateProperty |
RowDetailsVisibilityModeProperty |
RowHeaderStyleProperty |
RowHeaderWidthProperty |
RowHeightProperty |
RowStyleProperty |
SelectedIndexProperty |
SelectedItemProperty |
SelectedItemsProperty |
SelectionModeProperty |
ShowFluidMouseOverProperty |
VerticalScrollBarVisibilityProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AlternatingRowBackground |
AutoGenerateColumns |
Background | (Inherited from Control.)
BodyRect |
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserFilter |
CanUserReorderColumns |
CanUserResizeColumns |
CanUserResizeRows |
CanUserSort |
Clip | (Inherited from UIElement.)
ColumnHeaderHeight |
ColumnHeaderStyle |
Columns |
ColumnWidth |
CurrentColumn |
CurrentRow |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DragOverColumnStyle |
DragSourceColumnStyle |
DropIndicatorStyle |
FilterStyle |
FluidMouseOverBrush |
Focused |
FocusStyle |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeadersVisibility |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility |
IsHitTestVisible | (Inherited from UIElement.)
IsLoading |
IsMouseOver |
IsReadOnly |
IsTabStop | (Inherited from Control.)
ItemsSource |
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxColumnWidth |
MaxHeight | (Inherited from FrameworkElement.)
MaxRowHeight |
MaxWidth | (Inherited from FrameworkElement.)
MinColumnWidth |
MinHeight | (Inherited from FrameworkElement.)
MinRowHeight |
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RowBackground |
RowDetailsTemplate |
RowDetailsVisibilityMode |
RowHeaderStyle |
RowHeaderWidth |
RowHeight |
RowStyle |
SelectedIndex |
SelectedItem |
SelectedItems |
SelectionMode |
ShowFluidMouseOver |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility |
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
AutoGeneratingColumn |
BeganEdit |
BeginningEdit |
BindingValidationError | (Inherited from FrameworkElement.)
CancelingEdit |
ColumnHeaderDragCompleted |
ColumnHeaderDragDelta |
ColumnHeaderDragStarted |
ColumnReordered |
ColumnReordering |
CommittingEdit |
CurrentCellChanged |
GotFocus | (Inherited from UIElement.)
IsLoadingChanged |
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LoadingRow |
LoadingRowDetails |
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RowDetailsVisibilityChanged |
SelectionChanged |
SizeChanged | (Inherited from FrameworkElement.)
SortChanged |
UnloadingRow |
UnloadingRowDetails |

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


C1DataGrid Constructor

[image]

.NET Framework Class Library
C1DataGrid Constructor
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public C1DataGrid()
Visual Basic (Declaration)
Public Sub New

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


C1DataGrid Fields

[image] [image]

.NET Framework Class Library
C1DataGrid Fields
C1DataGrid Class See Also

The C1DataGrid type exposes the following members.

Fields

Name | Description
AlternatingRowBackgroundProperty |
AutoGenerateColumnsProperty |
BodyRectProperty |
CanUserFilterProperty |
CanUserReorderColumnsProperty |
CanUserResizeColumnsProperty |
CanUserResizeRowsProperty |
CanUserSortProperty |
ColumnHeaderHeightProperty |
ColumnHeaderStyleProperty |
ColumnsProperty |
ColumnWidthProperty |
CurrentColumnProperty |
CurrentRowProperty |
DragOverColumnStyleProperty |
DragSourceColumnStyleProperty |
DropIndicatorStyleProperty |
FilterStyleProperty |
FluidMouseOverBrushProperty |
FocusStyleProperty |
HeadersVisibilityProperty |
HorizontalScrollBarVisibilityProperty |
IsLoadingProperty |
IsMouseOverProperty |
IsReadOnlyProperty |
ItemsSourceProperty |
MaxColumnWidthProperty |
MaxRowHeightProperty |
MinColumnWidthProperty |
MinRowHeightProperty |
RowBackgroundProperty |
RowDetailsTemplateProperty |
RowDetailsVisibilityModeProperty |
RowHeaderStyleProperty |
RowHeaderWidthProperty |
RowHeightProperty |
RowStyleProperty |
SelectedIndexProperty |
SelectedItemProperty |
SelectedItemsProperty |
SelectionModeProperty |
ShowFluidMouseOverProperty |
VerticalScrollBarVisibilityProperty |

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


AlternatingRowBackgroundProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.AlternatingRowBackgroundProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty AlternatingRowBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly AlternatingRowBackgroundProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


AutoGenerateColumnsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.AutoGenerateColumnsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty AutoGenerateColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly AutoGenerateColumnsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


BodyRectProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.BodyRectProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty BodyRectProperty
Visual Basic (Declaration)
Public Shared ReadOnly BodyRectProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserFilterProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserFilterProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserFilterProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserFilterProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserReorderColumnsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserReorderColumnsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserReorderColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserReorderColumnsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserResizeColumnsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserResizeColumnsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserResizeColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserResizeColumnsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserResizeRowsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserResizeRowsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserResizeRowsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserResizeRowsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserSortProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserSortProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserSortProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserSortProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderHeightProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderHeightProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderHeightProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ColumnHeaderStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnHeaderStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ColumnsProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnWidthProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnWidthProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ColumnWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly ColumnWidthProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CurrentColumnProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CurrentColumnProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CurrentColumnProperty
Visual Basic (Declaration)
Public Shared ReadOnly CurrentColumnProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CurrentRowProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.CurrentRowProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CurrentRowProperty
Visual Basic (Declaration)
Public Shared ReadOnly CurrentRowProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DragOverColumnStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.DragOverColumnStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty DragOverColumnStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DragOverColumnStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DragSourceColumnStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.DragSourceColumnStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty DragSourceColumnStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DragSourceColumnStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DropIndicatorStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.DropIndicatorStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty DropIndicatorStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly DropIndicatorStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FilterStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.FilterStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty FilterStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FilterStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FluidMouseOverBrushProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.FluidMouseOverBrushProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty FluidMouseOverBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly FluidMouseOverBrushProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FocusStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.FocusStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty FocusStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly FocusStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


HeadersVisibilityProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.HeadersVisibilityProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty HeadersVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly HeadersVisibilityProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


HorizontalScrollBarVisibilityProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.HorizontalScrollBarVisibilityProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty HorizontalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly HorizontalScrollBarVisibilityProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsLoadingProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.IsLoadingProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsLoadingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsLoadingProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.IsMouseOverProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsReadOnlyProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.IsReadOnlyProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsReadOnlyProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsReadOnlyProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ItemsSourceProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ItemsSourceProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MaxColumnWidthProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.MaxColumnWidthProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MaxColumnWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaxColumnWidthProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MaxRowHeightProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.MaxRowHeightProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MaxRowHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly MaxRowHeightProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MinColumnWidthProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.MinColumnWidthProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MinColumnWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinColumnWidthProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MinRowHeightProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.MinRowHeightProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MinRowHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly MinRowHeightProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowBackgroundProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowBackgroundProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowBackgroundProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowBackgroundProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowDetailsTemplateProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowDetailsTemplateProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowDetailsTemplateProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowDetailsTemplateProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowDetailsVisibilityModeProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowDetailsVisibilityModeProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowDetailsVisibilityModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowDetailsVisibilityModeProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeaderStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeaderStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowHeaderStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowHeaderStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeaderWidthProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeaderWidthProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowHeaderWidthProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowHeaderWidthProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeightProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeightProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowHeightProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowHeightProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowStyleProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.RowStyleProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty RowStyleProperty
Visual Basic (Declaration)
Public Shared ReadOnly RowStyleProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedIndexProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedIndexProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedIndexProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedIndexProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedItemProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedItemProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedItemsProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedItemsProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedItemsProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedItemsProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectionModeProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.SelectionModeProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectionModeProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectionModeProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ShowFluidMouseOverProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.ShowFluidMouseOverProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ShowFluidMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly ShowFluidMouseOverProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


VerticalScrollBarVisibilityProperty Field

[image]

.NET Framework Class Library
C1DataGrid..::.VerticalScrollBarVisibilityProperty Field
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty VerticalScrollBarVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly VerticalScrollBarVisibilityProperty As DependencyProperty

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


C1DataGrid Methods

[image] [image]

.NET Framework Class Library
C1DataGrid Methods
C1DataGrid Class See Also

The C1DataGrid type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
BeginEdit | Overloaded.
CancelEdit |
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateLoading |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
EndEdit | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetCell |
GetCellFromPoint |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
Refresh |
ReleaseMouseCapture | (Inherited from UIElement.)
Reload |
ScrollIntoView | Overloaded.
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image] [image]

.NET Framework Class Library
C1DataGrid..::.BeginEdit Method
C1DataGrid Class See Also

Overload List

Name | Description
BeginEdit()()() |
BeginEdit(KeyEventArgs) |
BeginEdit(Int32, Int32) |

See Also

C1DataGrid Class
C1DataGrid Members
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
C1DataGrid..::.BeginEdit Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool BeginEdit()
Visual Basic (Declaration)
Public Function BeginEdit As Boolean

See Also

C1DataGrid Class
BeginEdit Overload
C1.Silverlight.DataGrid Namespace


BeginEdit Method (KeyEventArgs)

[image]

.NET Framework Class Library
C1DataGrid..::.BeginEdit Method (KeyEventArgs)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool BeginEdit(
    KeyEventArgs editingEventArgs
)
Visual Basic (Declaration)
Public Function BeginEdit ( _
    editingEventArgs As KeyEventArgs _
) As Boolean

Parameters

editingEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

C1DataGrid Class
BeginEdit Overload
C1.Silverlight.DataGrid Namespace


BeginEdit Method (Int32, Int32)

[image]

.NET Framework Class Library
C1DataGrid..::.BeginEdit Method (Int32, Int32)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool BeginEdit(
    int rowIndex,
    int columnIndex
)
Visual Basic (Declaration)
Public Function BeginEdit ( _
    rowIndex As Integer, _
    columnIndex As Integer _
) As Boolean

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32

See Also

C1DataGrid Class
BeginEdit Overload
C1.Silverlight.DataGrid Namespace


CancelEdit Method

[image]

.NET Framework Class Library
C1DataGrid..::.CancelEdit Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CancelEdit()
Visual Basic (Declaration)
Public Function CancelEdit As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
C1DataGrid..::.ChangeVisualStateCommon Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateLoading Method

[image]

.NET Framework Class Library
C1DataGrid..::.ChangeVisualStateLoading Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateLoading(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateLoading ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


EndEdit Method

[image] [image]

.NET Framework Class Library
C1DataGrid..::.EndEdit Method
C1DataGrid Class See Also

Overload List

Name | Description
EndEdit()()() |
EndEdit(Boolean) |
EndEdit(Boolean, Boolean) |

See Also

C1DataGrid Class
C1DataGrid Members
C1.Silverlight.DataGrid Namespace


EndEdit Method

[image]

.NET Framework Class Library
C1DataGrid..::.EndEdit Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool EndEdit()
Visual Basic (Declaration)
Public Function EndEdit As Boolean

See Also

C1DataGrid Class
EndEdit Overload
C1.Silverlight.DataGrid Namespace


EndEdit Method (Boolean)

[image]

.NET Framework Class Library
C1DataGrid..::.EndEdit Method (Boolean)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool EndEdit(
    bool commitChanges
)
Visual Basic (Declaration)
Public Function EndEdit ( _
    commitChanges As Boolean _
) As Boolean

Parameters

commitChanges
Type: System..::.Boolean

See Also

C1DataGrid Class
EndEdit Overload
C1.Silverlight.DataGrid Namespace


EndEdit Method (Boolean, Boolean)

[image]

.NET Framework Class Library
C1DataGrid..::.EndEdit Method (Boolean, Boolean)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool EndEdit(
    bool commitChanges,
    bool exitEditingMode
)
Visual Basic (Declaration)
Public Function EndEdit ( _
    commitChanges As Boolean, _
    exitEditingMode As Boolean _
) As Boolean

Parameters

commitChanges
Type: System..::.Boolean
exitEditingMode
Type: System..::.Boolean

See Also

C1DataGrid Class
EndEdit Overload
C1.Silverlight.DataGrid Namespace


GetCell Method

[image]

.NET Framework Class Library
C1DataGrid..::.GetCell Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCell GetCell(
    int rowIndex,
    int columnIndex
)
Visual Basic (Declaration)
Public Function GetCell ( _
    rowIndex As Integer, _
    columnIndex As Integer _
) As DataGridCell

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


GetCellFromPoint Method

[image]

.NET Framework Class Library
C1DataGrid..::.GetCellFromPoint Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCell GetCellFromPoint(
    Point point
)
Visual Basic (Declaration)
Public Function GetCellFromPoint ( _
    point As Point _
) As DataGridCell

Parameters

point
Type: System.Windows..::.Point

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
C1DataGrid..::.HitTest Method
C1DataGrid Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

C1DataGrid Class
C1DataGrid Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
C1DataGrid..::.OnApplyTemplate Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


Refresh Method

[image]

.NET Framework Class Library
C1DataGrid..::.Refresh Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Refresh()
Visual Basic (Declaration)
Public Sub Refresh

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


Reload Method

[image]

.NET Framework Class Library
C1DataGrid..::.Reload Method
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Reload(
    bool createColumns
)
Visual Basic (Declaration)
Public Sub Reload ( _
    createColumns As Boolean _
)

Parameters

createColumns
Type: System..::.Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ScrollIntoView Method

[image] [image]

.NET Framework Class Library
C1DataGrid..::.ScrollIntoView Method
C1DataGrid Class See Also

Overload List

Name | Description
ScrollIntoView(Int32, Int32) |
ScrollIntoView(Object, DataGridColumn) |

See Also

C1DataGrid Class
C1DataGrid Members
C1.Silverlight.DataGrid Namespace


ScrollIntoView Method (Int32, Int32)

[image]

.NET Framework Class Library
C1DataGrid..::.ScrollIntoView Method (Int32, Int32)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ScrollIntoView(
    int rowIndex,
    int columnIndex
)
Visual Basic (Declaration)
Public Sub ScrollIntoView ( _
    rowIndex As Integer, _
    columnIndex As Integer _
)

Parameters

rowIndex
Type: System..::.Int32
columnIndex
Type: System..::.Int32

See Also

C1DataGrid Class
ScrollIntoView Overload
C1.Silverlight.DataGrid Namespace


ScrollIntoView Method (Object, DataGridColumn)

[image]

.NET Framework Class Library
C1DataGrid..::.ScrollIntoView Method (Object, DataGridColumn)
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ScrollIntoView(
    Object item,
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub ScrollIntoView ( _
    item As Object, _
    column As DataGridColumn _
)

Parameters

item
Type: System..::.Object
column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

C1DataGrid Class
ScrollIntoView Overload
C1.Silverlight.DataGrid Namespace


C1DataGrid Properties

[image] [image]

.NET Framework Class Library
C1DataGrid Properties
C1DataGrid Class See Also

The C1DataGrid type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
AlternatingRowBackground |
AutoGenerateColumns |
Background | (Inherited from Control.)
BodyRect |
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserFilter |
CanUserReorderColumns |
CanUserResizeColumns |
CanUserResizeRows |
CanUserSort |
Clip | (Inherited from UIElement.)
ColumnHeaderHeight |
ColumnHeaderStyle |
Columns |
ColumnWidth |
CurrentColumn |
CurrentRow |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
DragOverColumnStyle |
DragSourceColumnStyle |
DropIndicatorStyle |
FilterStyle |
FluidMouseOverBrush |
Focused |
FocusStyle |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
HeadersVisibility |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
HorizontalScrollBarVisibility |
IsHitTestVisible | (Inherited from UIElement.)
IsLoading |
IsMouseOver |
IsReadOnly |
IsTabStop | (Inherited from Control.)
ItemsSource |
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxColumnWidth |
MaxHeight | (Inherited from FrameworkElement.)
MaxRowHeight |
MaxWidth | (Inherited from FrameworkElement.)
MinColumnWidth |
MinHeight | (Inherited from FrameworkElement.)
MinRowHeight |
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
RowBackground |
RowDetailsTemplate |
RowDetailsVisibilityMode |
RowHeaderStyle |
RowHeaderWidth |
RowHeight |
RowStyle |
SelectedIndex |
SelectedItem |
SelectedItems |
SelectionMode |
ShowFluidMouseOver |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
VerticalScrollBarVisibility |
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


AlternatingRowBackground Property

[image]

.NET Framework Class Library
C1DataGrid..::.AlternatingRowBackground Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush AlternatingRowBackground { get; set; }
Visual Basic (Declaration)
Public Property AlternatingRowBackground As Brush

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


AutoGenerateColumns Property

[image]

.NET Framework Class Library
C1DataGrid..::.AutoGenerateColumns Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool AutoGenerateColumns { get; set; }
Visual Basic (Declaration)
Public Property AutoGenerateColumns As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


BodyRect Property

[image]

.NET Framework Class Library
C1DataGrid..::.BodyRect Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Rect BodyRect { get; set; }
Visual Basic (Declaration)
Public Property BodyRect As Rect

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserFilter Property

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserFilter Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserFilter { get; set; }
Visual Basic (Declaration)
Public Property CanUserFilter As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserReorderColumns Property

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserReorderColumns Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserReorderColumns { get; set; }
Visual Basic (Declaration)
Public Property CanUserReorderColumns As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserResizeColumns Property

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserResizeColumns Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResizeColumns { get; set; }
Visual Basic (Declaration)
Public Property CanUserResizeColumns As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserResizeRows Property

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserResizeRows Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResizeRows { get; set; }
Visual Basic (Declaration)
Public Property CanUserResizeRows As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CanUserSort Property

[image]

.NET Framework Class Library
C1DataGrid..::.CanUserSort Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserSort { get; set; }
Visual Basic (Declaration)
Public Property CanUserSort As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderHeight Property

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderHeight Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double ColumnHeaderHeight { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderHeight As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style ColumnHeaderStyle { get; set; }
Visual Basic (Declaration)
Public Property ColumnHeaderStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


Columns Property

[image]

.NET Framework Class Library
C1DataGrid..::.Columns Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ObservableCollection<DataGridColumn> Columns { get; set; }
Visual Basic (Declaration)
Public Property Columns As ObservableCollection(Of DataGridColumn)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnWidth Property

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnWidth Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GridLength ColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property ColumnWidth As GridLength

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CurrentColumn Property

[image]

.NET Framework Class Library
C1DataGrid..::.CurrentColumn Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn CurrentColumn { get; set; }
Visual Basic (Declaration)
Public Property CurrentColumn As DataGridColumn

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CurrentRow Property

[image]

.NET Framework Class Library
C1DataGrid..::.CurrentRow Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow CurrentRow { get; set; }
Visual Basic (Declaration)
Public Property CurrentRow As DataGridRow

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DragOverColumnStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.DragOverColumnStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style DragOverColumnStyle { get; set; }
Visual Basic (Declaration)
Public Property DragOverColumnStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DragSourceColumnStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.DragSourceColumnStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style DragSourceColumnStyle { get; set; }
Visual Basic (Declaration)
Public Property DragSourceColumnStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


DropIndicatorStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.DropIndicatorStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style DropIndicatorStyle { get; set; }
Visual Basic (Declaration)
Public Property DropIndicatorStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FilterStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.FilterStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style FilterStyle { get; set; }
Visual Basic (Declaration)
Public Property FilterStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FluidMouseOverBrush Property

[image]

.NET Framework Class Library
C1DataGrid..::.FluidMouseOverBrush Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush FluidMouseOverBrush { get; set; }
Visual Basic (Declaration)
Public Property FluidMouseOverBrush As Brush

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


Focused Property

[image]

.NET Framework Class Library
C1DataGrid..::.Focused Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Focused { get; private set; }
Visual Basic (Declaration)
Public Property Focused As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


FocusStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.FocusStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style FocusStyle { get; set; }
Visual Basic (Declaration)
Public Property FocusStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


HeadersVisibility Property

[image]

.NET Framework Class Library
C1DataGrid..::.HeadersVisibility Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridHeaders HeadersVisibility { get; set; }
Visual Basic (Declaration)
Public Property HeadersVisibility As DataGridHeaders

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


HorizontalScrollBarVisibility Property

[image]

.NET Framework Class Library
C1DataGrid..::.HorizontalScrollBarVisibility Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ScrollBarVisibility HorizontalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property HorizontalScrollBarVisibility As ScrollBarVisibility

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsLoading Property

[image]

.NET Framework Class Library
C1DataGrid..::.IsLoading Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsLoading { get; set; }
Visual Basic (Declaration)
Public Property IsLoading As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
C1DataGrid..::.IsMouseOver Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
C1DataGrid..::.IsReadOnly Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ItemsSource Property

[image]

.NET Framework Class Library
C1DataGrid..::.ItemsSource Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IEnumerable

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MaxColumnWidth Property

[image]

.NET Framework Class Library
C1DataGrid..::.MaxColumnWidth Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MaxColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxColumnWidth As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MaxRowHeight Property

[image]

.NET Framework Class Library
C1DataGrid..::.MaxRowHeight Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MaxRowHeight { get; set; }
Visual Basic (Declaration)
Public Property MaxRowHeight As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MinColumnWidth Property

[image]

.NET Framework Class Library
C1DataGrid..::.MinColumnWidth Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MinColumnWidth { get; set; }
Visual Basic (Declaration)
Public Property MinColumnWidth As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


MinRowHeight Property

[image]

.NET Framework Class Library
C1DataGrid..::.MinRowHeight Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MinRowHeight { get; set; }
Visual Basic (Declaration)
Public Property MinRowHeight As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowBackground Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowBackground Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush RowBackground { get; set; }
Visual Basic (Declaration)
Public Property RowBackground As Brush

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowDetailsTemplate Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowDetailsTemplate Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataTemplate RowDetailsTemplate { get; set; }
Visual Basic (Declaration)
Public Property RowDetailsTemplate As DataTemplate

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowDetailsVisibilityMode Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowDetailsVisibilityMode Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowDetailsVisibilityMode RowDetailsVisibilityMode { get; set; }
Visual Basic (Declaration)
Public Property RowDetailsVisibilityMode As DataGridRowDetailsVisibilityMode

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeaderStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeaderStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style RowHeaderStyle { get; set; }
Visual Basic (Declaration)
Public Property RowHeaderStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeaderWidth Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeaderWidth Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double RowHeaderWidth { get; set; }
Visual Basic (Declaration)
Public Property RowHeaderWidth As Double

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowHeight Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowHeight Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GridLength RowHeight { get; set; }
Visual Basic (Declaration)
Public Property RowHeight As GridLength

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowStyle Property

[image]

.NET Framework Class Library
C1DataGrid..::.RowStyle Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style RowStyle { get; set; }
Visual Basic (Declaration)
Public Property RowStyle As Style

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedIndex Property

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedIndex Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int SelectedIndex { get; set; }
Visual Basic (Declaration)
Public Property SelectedIndex As Integer

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedItem Property

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedItem Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object SelectedItem { get; set; }
Visual Basic (Declaration)
Public Property SelectedItem As Object

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectedItems Property

[image]

.NET Framework Class Library
C1DataGrid..::.SelectedItems Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<Object> SelectedItems { get; set; }
Visual Basic (Declaration)
Public Property SelectedItems As IList(Of Object)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectionMode Property

[image]

.NET Framework Class Library
C1DataGrid..::.SelectionMode Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public C1SelectionMode SelectionMode { get; set; }
Visual Basic (Declaration)
Public Property SelectionMode As C1SelectionMode

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ShowFluidMouseOver Property

[image]

.NET Framework Class Library
C1DataGrid..::.ShowFluidMouseOver Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool ShowFluidMouseOver { get; set; }
Visual Basic (Declaration)
Public Property ShowFluidMouseOver As Boolean

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


VerticalScrollBarVisibility Property

[image]

.NET Framework Class Library
C1DataGrid..::.VerticalScrollBarVisibility Property
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ScrollBarVisibility VerticalScrollBarVisibility { get; set; }
Visual Basic (Declaration)
Public Property VerticalScrollBarVisibility As ScrollBarVisibility

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


C1DataGrid Events

[image] [image]

.NET Framework Class Library
C1DataGrid Events
C1DataGrid Class See Also

The C1DataGrid type exposes the following members.

Events

Name | Description
AutoGeneratingColumn |
BeganEdit |
BeginningEdit |
BindingValidationError | (Inherited from FrameworkElement.)
CancelingEdit |
ColumnHeaderDragCompleted |
ColumnHeaderDragDelta |
ColumnHeaderDragStarted |
ColumnReordered |
ColumnReordering |
CommittingEdit |
CurrentCellChanged |
GotFocus | (Inherited from UIElement.)
IsLoadingChanged |
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LoadingRow |
LoadingRowDetails |
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
RowDetailsVisibilityChanged |
SelectionChanged |
SizeChanged | (Inherited from FrameworkElement.)
SortChanged |
UnloadingRow |
UnloadingRowDetails |

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


AutoGeneratingColumn Event

[image]

.NET Framework Class Library
C1DataGrid..::.AutoGeneratingColumn Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridAutoGeneratingColumnEventArgs> AutoGeneratingColumn
Visual Basic (Declaration)
Public Event AutoGeneratingColumn As EventHandler(Of DataGridAutoGeneratingColumnEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


BeganEdit Event

[image]

.NET Framework Class Library
C1DataGrid..::.BeganEdit Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridBeganEditEventArgs> BeganEdit
Visual Basic (Declaration)
Public Event BeganEdit As EventHandler(Of DataGridBeganEditEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


BeginningEdit Event

[image]

.NET Framework Class Library
C1DataGrid..::.BeginningEdit Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridBeginningEditEventArgs> BeginningEdit
Visual Basic (Declaration)
Public Event BeginningEdit As EventHandler(Of DataGridBeginningEditEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CancelingEdit Event

[image]

.NET Framework Class Library
C1DataGrid..::.CancelingEdit Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridEndingEditEventArgs> CancelingEdit
Visual Basic (Declaration)
Public Event CancelingEdit As EventHandler(Of DataGridEndingEditEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderDragCompleted Event

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderDragCompleted Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> ColumnHeaderDragCompleted
Visual Basic (Declaration)
Public Event ColumnHeaderDragCompleted As EventHandler(Of MouseDragEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderDragDelta Event

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderDragDelta Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> ColumnHeaderDragDelta
Visual Basic (Declaration)
Public Event ColumnHeaderDragDelta As EventHandler(Of MouseDragEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnHeaderDragStarted Event

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnHeaderDragStarted Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<MouseDragEventArgs> ColumnHeaderDragStarted
Visual Basic (Declaration)
Public Event ColumnHeaderDragStarted As EventHandler(Of MouseDragEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnReordered Event

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnReordered Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridColumnEventArgs> ColumnReordered
Visual Basic (Declaration)
Public Event ColumnReordered As EventHandler(Of DataGridColumnEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


ColumnReordering Event

[image]

.NET Framework Class Library
C1DataGrid..::.ColumnReordering Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridColumnReorderingEventArgs> ColumnReordering
Visual Basic (Declaration)
Public Event ColumnReordering As EventHandler(Of DataGridColumnReorderingEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CommittingEdit Event

[image]

.NET Framework Class Library
C1DataGrid..::.CommittingEdit Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridEndingEditEventArgs> CommittingEdit
Visual Basic (Declaration)
Public Event CommittingEdit As EventHandler(Of DataGridEndingEditEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


CurrentCellChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.CurrentCellChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridCellEventArgs> CurrentCellChanged
Visual Basic (Declaration)
Public Event CurrentCellChanged As EventHandler(Of DataGridCellEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsLoadingChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.IsLoadingChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsLoadingChanged
Visual Basic (Declaration)
Public Event IsLoadingChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.IsMouseOverChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


LoadingRow Event

[image]

.NET Framework Class Library
C1DataGrid..::.LoadingRow Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridRowEventArgs> LoadingRow
Visual Basic (Declaration)
Public Event LoadingRow As EventHandler(Of DataGridRowEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


LoadingRowDetails Event

[image]

.NET Framework Class Library
C1DataGrid..::.LoadingRowDetails Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridRowDetailsEventArgs> LoadingRowDetails
Visual Basic (Declaration)
Public Event LoadingRowDetails As EventHandler(Of DataGridRowDetailsEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


RowDetailsVisibilityChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.RowDetailsVisibilityChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridRowDetailsEventArgs> RowDetailsVisibilityChanged
Visual Basic (Declaration)
Public Event RowDetailsVisibilityChanged As EventHandler(Of DataGridRowDetailsEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SelectionChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.SelectionChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler SelectionChanged
Visual Basic (Declaration)
Public Event SelectionChanged As EventHandler

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


SortChanged Event

[image]

.NET Framework Class Library
C1DataGrid..::.SortChanged Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridSortChangedEventArgs> SortChanged
Visual Basic (Declaration)
Public Event SortChanged As EventHandler(Of DataGridSortChangedEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


UnloadingRow Event

[image]

.NET Framework Class Library
C1DataGrid..::.UnloadingRow Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridRowEventArgs> UnloadingRow
Visual Basic (Declaration)
Public Event UnloadingRow As EventHandler(Of DataGridRowEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


UnloadingRowDetails Event

[image]

.NET Framework Class Library
C1DataGrid..::.UnloadingRowDetails Event
C1DataGrid Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<DataGridRowDetailsEventArgs> UnloadingRowDetails
Visual Basic (Declaration)
Public Event UnloadingRowDetails As EventHandler(Of DataGridRowDetailsEventArgs)

See Also

C1DataGrid Class
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Class

[image]

.NET Framework Class Library
C1ScrollBarHelper Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class C1ScrollBarHelper
Visual Basic (Declaration)
Public Class C1ScrollBarHelper

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.C1ScrollBarHelper

See Also

C1ScrollBarHelper Members
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Members

[image] [image]

.NET Framework Class Library
C1ScrollBarHelper Members
C1ScrollBarHelper Class Constructors Methods Properties Events See Also

The C1ScrollBarHelper type exposes the following members.

Constructors

Name | Description
C1ScrollBarHelper |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InnerScrollBar |
TimerInterval |

Events

Name | Description
Scroll |
ValueChanged |

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Constructor

[image]

.NET Framework Class Library
C1ScrollBarHelper Constructor
C1ScrollBarHelper Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public C1ScrollBarHelper(
    ScrollBar innerScrollBar
)
Visual Basic (Declaration)
Public Sub New ( _
    innerScrollBar As ScrollBar _
)

Parameters

innerScrollBar
Type: System.Windows.Controls.Primitives..::.ScrollBar

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Methods

[image] [image]

.NET Framework Class Library
C1ScrollBarHelper Methods
C1ScrollBarHelper Class See Also

The C1ScrollBarHelper type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Properties

[image] [image]

.NET Framework Class Library
C1ScrollBarHelper Properties
C1ScrollBarHelper Class See Also

The C1ScrollBarHelper type exposes the following members.

Properties

Name | Description
InnerScrollBar |
TimerInterval |

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


InnerScrollBar Property

[image]

.NET Framework Class Library
C1ScrollBarHelper..::.InnerScrollBar Property
C1ScrollBarHelper Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ScrollBar InnerScrollBar { get; private set; }
Visual Basic (Declaration)
Public Property InnerScrollBar As ScrollBar

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


TimerInterval Property

[image]

.NET Framework Class Library
C1ScrollBarHelper..::.TimerInterval Property
C1ScrollBarHelper Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int TimerInterval { get; set; }
Visual Basic (Declaration)
Public Property TimerInterval As Integer

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


C1ScrollBarHelper Events

[image] [image]

.NET Framework Class Library
C1ScrollBarHelper Events
C1ScrollBarHelper Class See Also

The C1ScrollBarHelper type exposes the following members.

Events

Name | Description
Scroll |
ValueChanged |

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


Scroll Event

[image]

.NET Framework Class Library
C1ScrollBarHelper..::.Scroll Event
C1ScrollBarHelper Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event ScrollEventHandler Scroll
Visual Basic (Declaration)
Public Event Scroll As ScrollEventHandler

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


ValueChanged Event

[image]

.NET Framework Class Library
C1ScrollBarHelper..::.ValueChanged Event
C1ScrollBarHelper Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event RoutedPropertyChangedEventHandler<double> ValueChanged
Visual Basic (Declaration)
Public Event ValueChanged As RoutedPropertyChangedEventHandler(Of Double)

See Also

C1ScrollBarHelper Class
C1.Silverlight.DataGrid Namespace


CancellingCellEditEventHandler Delegate

[image]

.NET Framework Class Library
CancellingCellEditEventHandler Delegate
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public delegate Object CancellingCellEditEventHandler(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Public Delegate Function CancellingCellEditEventHandler ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

C1.Silverlight.DataGrid Namespace


ColumnMovedEventArgs Class

[image]

.NET Framework Class Library
ColumnMovedEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class ColumnMovedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class ColumnMovedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.ColumnMovedEventArgs

See Also

ColumnMovedEventArgs Members
C1.Silverlight.DataGrid Namespace


ColumnMovedEventArgs Members

[image] [image]

.NET Framework Class Library
ColumnMovedEventArgs Members
ColumnMovedEventArgs Class Constructors Methods Properties See Also

The ColumnMovedEventArgs type exposes the following members.

Constructors

Name | Description
ColumnMovedEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
NewIndex |
OldIndex |

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


ColumnMovedEventArgs Constructor

[image]

.NET Framework Class Library
ColumnMovedEventArgs Constructor
ColumnMovedEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ColumnMovedEventArgs()
Visual Basic (Declaration)
Public Sub New

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


ColumnMovedEventArgs Methods

[image] [image]

.NET Framework Class Library
ColumnMovedEventArgs Methods
ColumnMovedEventArgs Class See Also

The ColumnMovedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


ColumnMovedEventArgs Properties

[image] [image]

.NET Framework Class Library
ColumnMovedEventArgs Properties
ColumnMovedEventArgs Class See Also

The ColumnMovedEventArgs type exposes the following members.

Properties

Name | Description
NewIndex |
OldIndex |

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


NewIndex Property

[image]

.NET Framework Class Library
ColumnMovedEventArgs..::.NewIndex Property
ColumnMovedEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int NewIndex { get; set; }
Visual Basic (Declaration)
Public Property NewIndex As Integer

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


OldIndex Property

[image]

.NET Framework Class Library
ColumnMovedEventArgs..::.OldIndex Property
ColumnMovedEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int OldIndex { get; set; }
Visual Basic (Declaration)
Public Property OldIndex As Integer

See Also

ColumnMovedEventArgs Class
C1.Silverlight.DataGrid Namespace


ComboValueInfo Class

[image]

.NET Framework Class Library
ComboValueInfo Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class ComboValueInfo : INotifyPropertyChanged
Visual Basic (Declaration)
Public Class ComboValueInfo _
    Implements INotifyPropertyChanged

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.ComboValueInfo

See Also

ComboValueInfo Members
C1.Silverlight.DataGrid Namespace


ComboValueInfo Members

[image] [image]

.NET Framework Class Library
ComboValueInfo Members
ComboValueInfo Class Constructors Methods Properties Events See Also

The ComboValueInfo type exposes the following members.

Constructors

Name | Description
ComboValueInfo |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Show |
Text |
Value |

Events

Name | Description
PropertyChanged |

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


ComboValueInfo Constructor

[image]

.NET Framework Class Library
ComboValueInfo Constructor
ComboValueInfo Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ComboValueInfo()
Visual Basic (Declaration)
Public Sub New

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


ComboValueInfo Methods

[image] [image]

.NET Framework Class Library
ComboValueInfo Methods
ComboValueInfo Class See Also

The ComboValueInfo type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


ComboValueInfo Properties

[image] [image]

.NET Framework Class Library
ComboValueInfo Properties
ComboValueInfo Class See Also

The ComboValueInfo type exposes the following members.

Properties

Name | Description
Show |
Text |
Value |

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


Show Property

[image]

.NET Framework Class Library
ComboValueInfo..::.Show Property
ComboValueInfo Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Show { get; set; }
Visual Basic (Declaration)
Public Property Show As Boolean

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


Text Property

[image]

.NET Framework Class Library
ComboValueInfo..::.Text Property
ComboValueInfo Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string Text { get; set; }
Visual Basic (Declaration)
Public Property Text As String

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


Value Property

[image]

.NET Framework Class Library
ComboValueInfo..::.Value Property
ComboValueInfo Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Object

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


ComboValueInfo Events

[image] [image]

.NET Framework Class Library
ComboValueInfo Events
ComboValueInfo Class See Also

The ComboValueInfo type exposes the following members.

Events

Name | Description
PropertyChanged |

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


PropertyChanged Event

[image]

.NET Framework Class Library
ComboValueInfo..::.PropertyChanged Event
ComboValueInfo Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event PropertyChangedEventHandler PropertyChanged
Visual Basic (Declaration)
Public Event PropertyChanged As PropertyChangedEventHandler

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

ComboValueInfo Class
C1.Silverlight.DataGrid Namespace


DataConnection Class

[image]

.NET Framework Class Library
DataConnection Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataConnection
Visual Basic (Declaration)
Public Class DataConnection

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataConnection

See Also

DataConnection Members
C1.Silverlight.DataGrid Namespace


DataConnection Members

[image] [image]

.NET Framework Class Library
DataConnection Members
DataConnection Class Constructors Methods Properties Events See Also

The DataConnection type exposes the following members.

Constructors

Name | Description
DataConnection |

Methods

Name | Description
BeginEdit |
CancelEdit |
EndEdit |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Filter |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataItem |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPropertyIsReadOnly |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowEdit |
AllowFilter |
AllowSort |
Count |
DataIsPrimitive |
DataProperties |
DataSource |
DataSourceView |
DataType |
FilterDescriptions |
List |
SortDescriptions |

Events

Name | Description
CollectionChanged |

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataConnection Constructor

[image]

.NET Framework Class Library
DataConnection Constructor
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataConnection(
    C1DataGrid owner
)
Visual Basic (Declaration)
Public Sub New ( _
    owner As C1DataGrid _
)

Parameters

owner
Type: C1.Silverlight.DataGrid..::.C1DataGrid

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataConnection Methods

[image] [image]

.NET Framework Class Library
DataConnection Methods
DataConnection Class See Also

The DataConnection type exposes the following members.

Methods

Name | Description
BeginEdit |
CancelEdit |
EndEdit |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Filter |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataItem |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetPropertyIsReadOnly |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Sort |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataConnection..::.BeginEdit Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool BeginEdit(
    Object dataItem
)
Visual Basic (Declaration)
Public Function BeginEdit ( _
    dataItem As Object _
) As Boolean

Parameters

dataItem
Type: System..::.Object

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


CancelEdit Method

[image]

.NET Framework Class Library
DataConnection..::.CancelEdit Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CancelEdit(
    Object dataItem
)
Visual Basic (Declaration)
Public Function CancelEdit ( _
    dataItem As Object _
) As Boolean

Parameters

dataItem
Type: System..::.Object

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


EndEdit Method

[image]

.NET Framework Class Library
DataConnection..::.EndEdit Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool EndEdit(
    Object dataItem
)
Visual Basic (Declaration)
Public Function EndEdit ( _
    dataItem As Object _
) As Boolean

Parameters

dataItem
Type: System..::.Object

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


Filter Method

[image]

.NET Framework Class Library
DataConnection..::.Filter Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Filter(
    AsyncCallback FilterComplete
)
Visual Basic (Declaration)
Public Sub Filter ( _
    FilterComplete As AsyncCallback _
)

Parameters

FilterComplete
Type: System..::.AsyncCallback

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


GetDataItem Method

[image]

.NET Framework Class Library
DataConnection..::.GetDataItem Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object GetDataItem(
    int index
)
Visual Basic (Declaration)
Public Function GetDataItem ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


GetPropertyIsReadOnly Method

[image]

.NET Framework Class Library
DataConnection..::.GetPropertyIsReadOnly Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool GetPropertyIsReadOnly(
    string propertyName
)
Visual Basic (Declaration)
Public Function GetPropertyIsReadOnly ( _
    propertyName As String _
) As Boolean

Parameters

propertyName
Type: System..::.String

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


IndexOf Method

[image]

.NET Framework Class Library
DataConnection..::.IndexOf Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int IndexOf(
    Object dataItem
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    dataItem As Object _
) As Integer

Parameters

dataItem
Type: System..::.Object

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


Sort Method

[image]

.NET Framework Class Library
DataConnection..::.Sort Method
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Sort(
    AsyncCallback SortComplete
)
Visual Basic (Declaration)
Public Sub Sort ( _
    SortComplete As AsyncCallback _
)

Parameters

SortComplete
Type: System..::.AsyncCallback

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataConnection Properties

[image] [image]

.NET Framework Class Library
DataConnection Properties
DataConnection Class See Also

The DataConnection type exposes the following members.

Properties

Name | Description
AllowEdit |
AllowFilter |
AllowSort |
Count |
DataIsPrimitive |
DataProperties |
DataSource |
DataSourceView |
DataType |
FilterDescriptions |
List |
SortDescriptions |

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


AllowEdit Property

[image]

.NET Framework Class Library
DataConnection..::.AllowEdit Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool AllowEdit { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowEdit As Boolean

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


AllowFilter Property

[image]

.NET Framework Class Library
DataConnection..::.AllowFilter Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool AllowFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowFilter As Boolean

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


AllowSort Property

[image]

.NET Framework Class Library
DataConnection..::.AllowSort Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool AllowSort { get; }
Visual Basic (Declaration)
Public ReadOnly Property AllowSort As Boolean

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


Count Property

[image]

.NET Framework Class Library
DataConnection..::.Count Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataIsPrimitive Property

[image]

.NET Framework Class Library
DataConnection..::.DataIsPrimitive Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool DataIsPrimitive { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataIsPrimitive As Boolean

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataProperties Property

[image]

.NET Framework Class Library
DataConnection..::.DataProperties Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public PropertyInfo[] DataProperties { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataProperties As PropertyInfo()

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataSource Property

[image]

.NET Framework Class Library
DataConnection..::.DataSource Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable DataSource { get; set; }
Visual Basic (Declaration)
Public Property DataSource As IEnumerable

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataSourceView Property

[image]

.NET Framework Class Library
DataConnection..::.DataSourceView Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IDataSourceView DataSourceView { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataSourceView As IDataSourceView

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataType Property

[image]

.NET Framework Class Library
DataConnection..::.DataType Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Type DataType { get; }
Visual Basic (Declaration)
Public ReadOnly Property DataType As Type

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


FilterDescriptions Property

[image]

.NET Framework Class Library
DataConnection..::.FilterDescriptions Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<FilterDescription> FilterDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property FilterDescriptions As IList(Of FilterDescription)

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


List Property

[image]

.NET Framework Class Library
DataConnection..::.List Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList List { get; }
Visual Basic (Declaration)
Public ReadOnly Property List As IList

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


SortDescriptions Property

[image]

.NET Framework Class Library
DataConnection..::.SortDescriptions Property
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<SortDescription> SortDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property SortDescriptions As IList(Of SortDescription)

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataConnection Events

[image] [image]

.NET Framework Class Library
DataConnection Events
DataConnection Class See Also

The DataConnection type exposes the following members.

Events

Name | Description
CollectionChanged |

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


CollectionChanged Event

[image]

.NET Framework Class Library
DataConnection..::.CollectionChanged Event
DataConnection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

See Also

DataConnection Class
C1.Silverlight.DataGrid Namespace


DataGridAutoGeneratingColumnEventArgs Class

[image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridAutoGeneratingColumnEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridAutoGeneratingColumnEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridAutoGeneratingColumnEventArgs

See Also

DataGridAutoGeneratingColumnEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridAutoGeneratingColumnEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs Members
DataGridAutoGeneratingColumnEventArgs Class Constructors Methods Properties See Also

The DataGridAutoGeneratingColumnEventArgs type exposes the following members.

Constructors

Name | Description
DataGridAutoGeneratingColumnEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel |
Column |
Property |

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridAutoGeneratingColumnEventArgs Constructor

[image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs Constructor
DataGridAutoGeneratingColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridAutoGeneratingColumnEventArgs(
    PropertyInfo property,
    DataGridBoundColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo, _
    column As DataGridBoundColumn _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo
column
Type: C1.Silverlight.DataGrid..::.DataGridBoundColumn

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridAutoGeneratingColumnEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs Methods
DataGridAutoGeneratingColumnEventArgs Class See Also

The DataGridAutoGeneratingColumnEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridAutoGeneratingColumnEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs Properties
DataGridAutoGeneratingColumnEventArgs Class See Also

The DataGridAutoGeneratingColumnEventArgs type exposes the following members.

Properties

Name | Description
Cancel |
Column |
Property |

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


Cancel Property

[image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs..::.Cancel Property
DataGridAutoGeneratingColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs..::.Column Property
DataGridAutoGeneratingColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridBoundColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As DataGridBoundColumn

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


Property Property

[image]

.NET Framework Class Library
DataGridAutoGeneratingColumnEventArgs..::.Property Property
DataGridAutoGeneratingColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public PropertyInfo Property { get; private set; }
Visual Basic (Declaration)
Public Property Property As PropertyInfo

See Also

DataGridAutoGeneratingColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeganEditEventArgs Class

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridBeganEditEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridBeganEditEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridBeganEditEventArgs

See Also

DataGridBeganEditEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridBeganEditEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridBeganEditEventArgs Members
DataGridBeganEditEventArgs Class Constructors Methods Properties See Also

The DataGridBeganEditEventArgs type exposes the following members.

Constructors

Name | Description
DataGridBeganEditEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel |
Column |
EditingElement |
Row |

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeganEditEventArgs Constructor

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs Constructor
DataGridBeganEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridBeganEditEventArgs(
    DataGridRow row,
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    row As DataGridRow, _
    column As DataGridColumn _
)

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow
column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeganEditEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridBeganEditEventArgs Methods
DataGridBeganEditEventArgs Class See Also

The DataGridBeganEditEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeganEditEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridBeganEditEventArgs Properties
DataGridBeganEditEventArgs Class See Also

The DataGridBeganEditEventArgs type exposes the following members.

Properties

Name | Description
Cancel |
Column |
EditingElement |
Row |

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Cancel Property

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs..::.Cancel Property
DataGridBeganEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs..::.Column Property
DataGridBeganEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


EditingElement Property

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs..::.EditingElement Property
DataGridBeganEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FrameworkElement EditingElement { get; internal set; }
Visual Basic (Declaration)
Public Property EditingElement As FrameworkElement

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridBeganEditEventArgs..::.Row Property
DataGridBeganEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridBeganEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeginningEditEventArgs Class

[image]

.NET Framework Class Library
DataGridBeginningEditEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridBeginningEditEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridBeginningEditEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridBeginningEditEventArgs

See Also

DataGridBeginningEditEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridBeginningEditEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridBeginningEditEventArgs Members
DataGridBeginningEditEventArgs Class Constructors Methods Properties See Also

The DataGridBeginningEditEventArgs type exposes the following members.

Constructors

Name | Description
DataGridBeginningEditEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel |
Column |
Row |

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeginningEditEventArgs Constructor

[image]

.NET Framework Class Library
DataGridBeginningEditEventArgs Constructor
DataGridBeginningEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridBeginningEditEventArgs(
    DataGridRow row,
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    row As DataGridRow, _
    column As DataGridColumn _
)

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow
column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeginningEditEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridBeginningEditEventArgs Methods
DataGridBeginningEditEventArgs Class See Also

The DataGridBeginningEditEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBeginningEditEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridBeginningEditEventArgs Properties
DataGridBeginningEditEventArgs Class See Also

The DataGridBeginningEditEventArgs type exposes the following members.

Properties

Name | Description
Cancel |
Column |
Row |

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Cancel Property

[image]

.NET Framework Class Library
DataGridBeginningEditEventArgs..::.Cancel Property
DataGridBeginningEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridBeginningEditEventArgs..::.Column Property
DataGridBeginningEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridBeginningEditEventArgs..::.Row Property
DataGridBeginningEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridBeginningEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Class

[image]

.NET Framework Class Library
DataGridBoundColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridBoundColumn : DataGridColumn
Visual Basic (Declaration)
Public Class DataGridBoundColumn _
    Inherits DataGridColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridCheckBoxColumn
C1.Silverlight.DataGrid..::.DataGridComboBoxColumn
C1.Silverlight.DataGrid..::.DataGridDateColumn
C1.Silverlight.DataGrid..::.DataGridImageColumn
C1.Silverlight.DataGrid..::.DataGridNumericColumn
C1.Silverlight.DataGrid..::.DataGridTextColumn

See Also

DataGridBoundColumn Members
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Members

[image] [image]

.NET Framework Class Library
DataGridBoundColumn Members
DataGridBoundColumn Class Constructors Methods Properties Events See Also

The DataGridBoundColumn type exposes the following members.

Constructors

Name | Description
DataGridBoundColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Overrides DataGridColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText |
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull |
Binding |
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format |
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping |
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridBoundColumn Constructor
DataGridBoundColumn Class See Also

Overload List

Name | Description
DataGridBoundColumn()()() |
DataGridBoundColumn(PropertyInfo) |

See Also

DataGridBoundColumn Class
DataGridBoundColumn Members
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Constructor

[image]

.NET Framework Class Library
DataGridBoundColumn Constructor
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridBoundColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridBoundColumn Class
DataGridBoundColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridBoundColumn Constructor (PropertyInfo)
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridBoundColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridBoundColumn Class
DataGridBoundColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Methods

[image] [image]

.NET Framework Class Library
DataGridBoundColumn Methods
DataGridBoundColumn Class See Also

The DataGridBoundColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText |
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.BeginEdit Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control cellElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    cellElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

cellElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.CancelCellEdit Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


CopyBinding Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.CopyBinding Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected Binding CopyBinding(
    Binding binding
)
Visual Basic (Declaration)
Protected Function CopyBinding ( _
    binding As Binding _
) As Binding

Parameters

binding
Type: System.Windows.Data..::.Binding

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.GetCellContent Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.GetCellEditingContent Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


GetDesignTimeText Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.GetDesignTimeText Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected virtual string GetDesignTimeText(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Overridable Function GetDesignTimeText ( _
    row As DataGridRow _
) As String

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.Initialize Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridBoundColumn..::.PrepareCellForEdit Method
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Properties

[image] [image]

.NET Framework Class Library
DataGridBoundColumn Properties
DataGridBoundColumn Class See Also

The DataGridBoundColumn type exposes the following members.

Properties

Name | Description
AllowNull |
Binding |
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format |
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping |
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


AllowNull Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.AllowNull Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected virtual bool AllowNull { get; set; }
Visual Basic (Declaration)
Protected Overridable Property AllowNull As Boolean

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


Binding Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.Binding Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Binding Binding { get; set; }
Visual Basic (Declaration)
Public Property Binding As Binding

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


DefaultConverter Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.DefaultConverter Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected virtual IValueConverter DefaultConverter { get; }
Visual Basic (Declaration)
Protected Overridable ReadOnly Property DefaultConverter As IValueConverter

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


Format Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.Format Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public virtual string Format { get; set; }
Visual Basic (Declaration)
Public Overridable Property Format As String

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


IsEditable Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.IsEditable Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override bool IsEditable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEditable As Boolean

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


TextWrapping Property

[image]

.NET Framework Class Library
DataGridBoundColumn..::.TextWrapping Property
DataGridBoundColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public virtual TextWrapping TextWrapping { get; set; }
Visual Basic (Declaration)
Public Overridable Property TextWrapping As TextWrapping

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


DataGridBoundColumn Events

[image] [image]

.NET Framework Class Library
DataGridBoundColumn Events
DataGridBoundColumn Class See Also

The DataGridBoundColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridBoundColumn Class
C1.Silverlight.DataGrid Namespace


DataGridCell Class

[image]

.NET Framework Class Library
DataGridCell Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridCell
Visual Basic (Declaration)
Public Class DataGridCell

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridCell

See Also

DataGridCell Members
C1.Silverlight.DataGrid Namespace


DataGridCell Members

[image] [image]

.NET Framework Class Library
DataGridCell Members
DataGridCell Class Methods Properties See Also

The DataGridCell type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column |
Content |
Row |

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


DataGridCell Methods

[image] [image]

.NET Framework Class Library
DataGridCell Methods
DataGridCell Class See Also

The DataGridCell type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


DataGridCell Properties

[image] [image]

.NET Framework Class Library
DataGridCell Properties
DataGridCell Class See Also

The DataGridCell type exposes the following members.

Properties

Name | Description
Column |
Content |
Row |

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridCell..::.Column Property
DataGridCell Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; internal set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


Content Property

[image]

.NET Framework Class Library
DataGridCell..::.Content Property
DataGridCell Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FrameworkElement Content { get; }
Visual Basic (Declaration)
Public ReadOnly Property Content As FrameworkElement

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridCell..::.Row Property
DataGridCell Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; internal set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridCell Class
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Class

[image]

.NET Framework Class Library
DataGridCellContentPanel Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridCellContentPanel : Panel
Visual Basic (Declaration)
Public Class DataGridCellContentPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.DataGrid..::.DataGridCellContentPanel

See Also

DataGridCellContentPanel Members
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Members

[image] [image]

.NET Framework Class Library
DataGridCellContentPanel Members
DataGridCellContentPanel Class Constructors Methods Properties Events See Also

The DataGridCellContentPanel type exposes the following members.

Constructors

Name | Description
DataGridCellContentPanel |

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Content |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Constructor

[image]

.NET Framework Class Library
DataGridCellContentPanel Constructor
DataGridCellContentPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCellContentPanel()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Methods

[image] [image]

.NET Framework Class Library
DataGridCellContentPanel Methods
DataGridCellContentPanel Class See Also

The DataGridCellContentPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridCellContentPanel..::.ArrangeOverride Method
DataGridCellContentPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridCellContentPanel..::.HitTest Method
DataGridCellContentPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridCellContentPanel Class
DataGridCellContentPanel Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridCellContentPanel..::.MeasureOverride Method
DataGridCellContentPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Properties

[image] [image]

.NET Framework Class Library
DataGridCellContentPanel Properties
DataGridCellContentPanel Class See Also

The DataGridCellContentPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Content |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


Content Property

[image]

.NET Framework Class Library
DataGridCellContentPanel..::.Content Property
DataGridCellContentPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public UIElement Content { get; set; }
Visual Basic (Declaration)
Public Property Content As UIElement

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellContentPanel Events

[image] [image]

.NET Framework Class Library
DataGridCellContentPanel Events
DataGridCellContentPanel Class See Also

The DataGridCellContentPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellContentPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellEventArgs Class

[image]

.NET Framework Class Library
DataGridCellEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridCellEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridCellEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridCellEventArgs

See Also

DataGridCellEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridCellEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridCellEventArgs Members
DataGridCellEventArgs Class Constructors Methods Properties See Also

The DataGridCellEventArgs type exposes the following members.

Constructors

Name | Description
DataGridCellEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cell |

See Also

DataGridCellEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridCellEventArgs Constructor

[image]

.NET Framework Class Library
DataGridCellEventArgs Constructor
DataGridCellEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCellEventArgs(
    DataGridCell cell
)
Visual Basic (Declaration)
Public Sub New ( _
    cell As DataGridCell _
)

Parameters

cell
Type: C1.Silverlight.DataGrid..::.DataGridCell

See Also

DataGridCellEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridCellEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridCellEventArgs Methods
DataGridCellEventArgs Class See Also

The DataGridCellEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridCellEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridCellEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridCellEventArgs Properties
DataGridCellEventArgs Class See Also

The DataGridCellEventArgs type exposes the following members.

Properties

Name | Description
Cell |

See Also

DataGridCellEventArgs Class
C1.Silverlight.DataGrid Namespace


Cell Property

[image]

.NET Framework Class Library
DataGridCellEventArgs..::.Cell Property
DataGridCellEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCell Cell { get; set; }
Visual Basic (Declaration)
Public Property Cell As DataGridCell

See Also

DataGridCellEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Class

[image]

.NET Framework Class Library
DataGridCellPresenter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Editing", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
[TemplatePartAttribute(Name = "Content", Type = typeof(Grid))]
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
public class DataGridCellPresenter : Control
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Editing", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
<TemplatePartAttribute(Name := "Content", Type := GetType(Grid))> _
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
Public Class DataGridCellPresenter _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridCellPresenter

See Also

DataGridCellPresenter Members
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Members

[image] [image]

.NET Framework Class Library
DataGridCellPresenter Members
DataGridCellPresenter Class Constructors Methods Fields Properties Events See Also

The DataGridCellPresenter type exposes the following members.

Constructors

Name | Description
DataGridCellPresenter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCustomDefaultValues |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ContentProperty |
IsEditingProperty |
IsSelectedProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsHitTestVisible | (Inherited from UIElement.)
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Constructor

[image]

.NET Framework Class Library
DataGridCellPresenter Constructor
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCellPresenter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Fields

[image] [image]

.NET Framework Class Library
DataGridCellPresenter Fields
DataGridCellPresenter Class See Also

The DataGridCellPresenter type exposes the following members.

Fields

Name | Description
ContentProperty |
IsEditingProperty |
IsSelectedProperty |

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


ContentProperty Field

[image]

.NET Framework Class Library
DataGridCellPresenter..::.ContentProperty Field
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ContentProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentProperty As DependencyProperty

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


IsEditingProperty Field

[image]

.NET Framework Class Library
DataGridCellPresenter..::.IsEditingProperty Field
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsEditingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsEditingProperty As DependencyProperty

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
DataGridCellPresenter..::.IsSelectedProperty Field
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Methods

[image] [image]

.NET Framework Class Library
DataGridCellPresenter Methods
DataGridCellPresenter Class See Also

The DataGridCellPresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetCustomDefaultValues |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateSelection Method

[image]

.NET Framework Class Library
DataGridCellPresenter..::.ChangeVisualStateSelection Method
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateSelection(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateSelection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridCellPresenter..::.HitTest Method
DataGridCellPresenter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridCellPresenter Class
DataGridCellPresenter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridCellPresenter..::.OnApplyTemplate Method
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


SetCustomDefaultValues Method

[image]

.NET Framework Class Library
DataGridCellPresenter..::.SetCustomDefaultValues Method
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void SetCustomDefaultValues()
Visual Basic (Declaration)
Public Sub SetCustomDefaultValues

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Properties

[image] [image]

.NET Framework Class Library
DataGridCellPresenter Properties
DataGridCellPresenter Class See Also

The DataGridCellPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Content |
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsHitTestVisible | (Inherited from UIElement.)
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


Content Property

[image]

.NET Framework Class Library
DataGridCellPresenter..::.Content Property
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FrameworkElement Content { get; set; }
Visual Basic (Declaration)
Public Property Content As FrameworkElement

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


IsEditing Property

[image]

.NET Framework Class Library
DataGridCellPresenter..::.IsEditing Property
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsEditing { get; set; }
Visual Basic (Declaration)
Public Property IsEditing As Boolean

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


IsSelected Property

[image]

.NET Framework Class Library
DataGridCellPresenter..::.IsSelected Property
DataGridCellPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellPresenter Events

[image] [image]

.NET Framework Class Library
DataGridCellPresenter Events
DataGridCellPresenter Class See Also

The DataGridCellPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridCellsContentType Enumeration

[image]

.NET Framework Class Library
DataGridCellsContentType Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum DataGridCellsContentType
Visual Basic (Declaration)
Public Enumeration DataGridCellsContentType

Members

Member name | Description
Cell |
EditingCell |
Selection |

See Also

C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Class

[image]

.NET Framework Class Library
DataGridCellsPanel Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridCellsPanel : Panel
Visual Basic (Declaration)
Public Class DataGridCellsPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.DataGrid..::.DataGridCellsPanel

See Also

DataGridCellsPanel Members
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Members

[image] [image]

.NET Framework Class Library
DataGridCellsPanel Members
DataGridCellsPanel Class Constructors Methods Fields Properties Events See Also

The DataGridCellsPanel type exposes the following members.

Constructors

Name | Description
DataGridCellsPanel |

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContentType |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetContentType |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ContentTypeProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Constructor

[image]

.NET Framework Class Library
DataGridCellsPanel Constructor
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCellsPanel()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Fields

[image] [image]

.NET Framework Class Library
DataGridCellsPanel Fields
DataGridCellsPanel Class See Also

The DataGridCellsPanel type exposes the following members.

Fields

Name | Description
ContentTypeProperty |

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


ContentTypeProperty Field

[image]

.NET Framework Class Library
DataGridCellsPanel..::.ContentTypeProperty Field
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ContentTypeProperty
Visual Basic (Declaration)
Public Shared ReadOnly ContentTypeProperty As DependencyProperty

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Methods

[image] [image]

.NET Framework Class Library
DataGridCellsPanel Methods
DataGridCellsPanel Class See Also

The DataGridCellsPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetContentType |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetContentType |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridCellsPanel..::.ArrangeOverride Method
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


GetContentType Method

[image]

.NET Framework Class Library
DataGridCellsPanel..::.GetContentType Method
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static DataGridCellsContentType GetContentType(
    DependencyObject element
)
Visual Basic (Declaration)
Public Shared Function GetContentType ( _
    element As DependencyObject _
) As DataGridCellsContentType

Parameters

element
Type: System.Windows..::.DependencyObject

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridCellsPanel..::.HitTest Method
DataGridCellsPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridCellsPanel Class
DataGridCellsPanel Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridCellsPanel..::.MeasureOverride Method
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


SetContentType Method

[image]

.NET Framework Class Library
DataGridCellsPanel..::.SetContentType Method
DataGridCellsPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static void SetContentType(
    DependencyObject element,
    DataGridCellsContentType value
)
Visual Basic (Declaration)
Public Shared Sub SetContentType ( _
    element As DependencyObject, _
    value As DataGridCellsContentType _
)

Parameters

element
Type: System.Windows..::.DependencyObject
value
Type: C1.Silverlight.DataGrid..::.DataGridCellsContentType

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Properties

[image] [image]

.NET Framework Class Library
DataGridCellsPanel Properties
DataGridCellsPanel Class See Also

The DataGridCellsPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCellsPanel Events

[image] [image]

.NET Framework Class Library
DataGridCellsPanel Events
DataGridCellsPanel Class See Also

The DataGridCellsPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCellsPanel Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Class

[image]

.NET Framework Class Library
DataGridCheckBoxColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridCheckBoxColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridCheckBoxColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridCheckBoxColumn

See Also

DataGridCheckBoxColumn Members
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Members

[image] [image]

.NET Framework Class Library
DataGridCheckBoxColumn Members
DataGridCheckBoxColumn Class Constructors Methods Properties Events See Also

The DataGridCheckBoxColumn type exposes the following members.

Constructors

Name | Description
DataGridCheckBoxColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridCheckBoxColumn Constructor
DataGridCheckBoxColumn Class See Also

Overload List

Name | Description
DataGridCheckBoxColumn()()() |
DataGridCheckBoxColumn(PropertyInfo) |

See Also

DataGridCheckBoxColumn Class
DataGridCheckBoxColumn Members
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Constructor

[image]

.NET Framework Class Library
DataGridCheckBoxColumn Constructor
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCheckBoxColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridCheckBoxColumn Class
DataGridCheckBoxColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridCheckBoxColumn Constructor (PropertyInfo)
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCheckBoxColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridCheckBoxColumn Class
DataGridCheckBoxColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Methods

[image] [image]

.NET Framework Class Library
DataGridCheckBoxColumn Methods
DataGridCheckBoxColumn Class See Also

The DataGridCheckBoxColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.BeginEdit Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control editingElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    editingElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

editingElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.CancelCellEdit Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.GetCellContent Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.GetCellEditingContent Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.GetFilter Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overrides Function GetFilter As IDataGridFilter

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.Initialize Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridCheckBoxColumn..::.PrepareCellForEdit Method
DataGridCheckBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Properties

[image] [image]

.NET Framework Class Library
DataGridCheckBoxColumn Properties
DataGridCheckBoxColumn Class See Also

The DataGridCheckBoxColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxColumn Events

[image] [image]

.NET Framework Class Library
DataGridCheckBoxColumn Events
DataGridCheckBoxColumn Class See Also

The DataGridCheckBoxColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridCheckBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Class

[image]

.NET Framework Class Library
DataGridCheckBoxFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "FilterCheckBox", Type = typeof(CheckBox))]
public class DataGridCheckBoxFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "FilterCheckBox", Type := GetType(CheckBox))> _
Public Class DataGridCheckBoxFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridCheckBoxFilter

See Also

DataGridCheckBoxFilter Members
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Members

[image] [image]

.NET Framework Class Library
DataGridCheckBoxFilter Members
DataGridCheckBoxFilter Class Constructors Methods Properties Events See Also

The DataGridCheckBoxFilter type exposes the following members.

Constructors

Name | Description
DataGridCheckBoxFilter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Constructor

[image]

.NET Framework Class Library
DataGridCheckBoxFilter Constructor
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridCheckBoxFilter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Methods

[image] [image]

.NET Framework Class Library
DataGridCheckBoxFilter Methods
DataGridCheckBoxFilter Class See Also

The DataGridCheckBoxFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.ClearFilter Method
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ClearFilter()
Visual Basic (Declaration)
Public Sub ClearFilter

Implements

IDataGridFilter..::.ClearFilter()()()

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.CreateFilter Method
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CreateFilter()
Visual Basic (Declaration)
Public Sub CreateFilter

Implements

IDataGridFilter..::.CreateFilter()()()

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.HitTest Method
DataGridCheckBoxFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridCheckBoxFilter Class
DataGridCheckBoxFilter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.OnApplyTemplate Method
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Properties

[image] [image]

.NET Framework Class Library
DataGridCheckBoxFilter Properties
DataGridCheckBoxFilter Class See Also

The DataGridCheckBoxFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.Filter Property
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As FilterDescription

Implements

IDataGridFilter..::.Filter

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridCheckBoxFilter Events

[image] [image]

.NET Framework Class Library
DataGridCheckBoxFilter Events
DataGridCheckBoxFilter Class See Also

The DataGridCheckBoxFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridCheckBoxFilter..::.FilterChanged Event
DataGridCheckBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

Implements

IDataGridFilter..::.FilterChanged

See Also

DataGridCheckBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridColumn Class

[image]

.NET Framework Class Library
DataGridColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public abstract class DataGridColumn
Visual Basic (Declaration)
Public MustInherit Class DataGridColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridTemplateColumn

See Also

DataGridColumn Members
C1.Silverlight.DataGrid Namespace


DataGridColumn Members

[image] [image]

.NET Framework Class Library
DataGridColumn Members
DataGridColumn Class Constructors Methods Properties Events See Also

The DataGridColumn type exposes the following members.

Constructors

Name | Description
DataGridColumn | Overloaded.

Methods

Name | Description
BeginEdit |
CancelCellEdit |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent |
GetCellEditingContent |
GetFilter |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CanUserFilter |
CanUserResize |
CellEditingStyle |
CellStyle |
EditOnSelection |
FilterMemberPath |
Header |
HorizontalAlignment |
Index |
IsEditable |
IsReadOnly |
MaxWidth |
MinWidth |
SortingState |
SortMemberPath |
VerticalAlignment |
Visibility |
Width |

Events

Name | Description
FilterMemberPathChanged |
LoadingFilter |
SortingStateChanged |
SortMemberPathChanged |
VisibilityChanged |
WidthChanged |

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


DataGridColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridColumn Constructor
DataGridColumn Class See Also

Overload List

Name | Description
DataGridColumn()()() |
DataGridColumn(PropertyInfo) |

See Also

DataGridColumn Class
DataGridColumn Members
C1.Silverlight.DataGrid Namespace


DataGridColumn Constructor

[image]

.NET Framework Class Library
DataGridColumn Constructor
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridColumn Class
DataGridColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridColumn Constructor (PropertyInfo)
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridColumn Class
DataGridColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridColumn Methods

[image] [image]

.NET Framework Class Library
DataGridColumn Methods
DataGridColumn Class See Also

The DataGridColumn type exposes the following members.

Methods

Name | Description
BeginEdit |
CancelCellEdit |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent |
GetCellEditingContent |
GetFilter |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridColumn..::.BeginEdit Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal abstract bool BeginEdit(
    Control cellElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend MustOverride Function BeginEdit ( _
    cellElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

cellElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridColumn..::.CancelCellEdit Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal abstract void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend MustOverride Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridColumn..::.GetCellContent Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal abstract FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend MustOverride Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridColumn..::.GetCellEditingContent Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal abstract Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend MustOverride Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridColumn..::.GetFilter Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal virtual IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overridable Function GetFilter As IDataGridFilter

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridColumn..::.Initialize Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected virtual void Initialize()
Visual Basic (Declaration)
Protected Overridable Sub Initialize

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridColumn..::.PrepareCellForEdit Method
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal abstract Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend MustOverride Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


DataGridColumn Properties

[image] [image]

.NET Framework Class Library
DataGridColumn Properties
DataGridColumn Class See Also

The DataGridColumn type exposes the following members.

Properties

Name | Description
CanUserFilter |
CanUserResize |
CellEditingStyle |
CellStyle |
EditOnSelection |
FilterMemberPath |
Header |
HorizontalAlignment |
Index |
IsEditable |
IsReadOnly |
MaxWidth |
MinWidth |
SortingState |
SortMemberPath |
VerticalAlignment |
Visibility |
Width |

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


CanUserFilter Property

[image]

.NET Framework Class Library
DataGridColumn..::.CanUserFilter Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserFilter { get; set; }
Visual Basic (Declaration)
Public Property CanUserFilter As Boolean

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


CanUserResize Property

[image]

.NET Framework Class Library
DataGridColumn..::.CanUserResize Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResize { get; set; }
Visual Basic (Declaration)
Public Property CanUserResize As Boolean

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


CellEditingStyle Property

[image]

.NET Framework Class Library
DataGridColumn..::.CellEditingStyle Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style CellEditingStyle { get; set; }
Visual Basic (Declaration)
Public Property CellEditingStyle As Style

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


CellStyle Property

[image]

.NET Framework Class Library
DataGridColumn..::.CellStyle Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Style CellStyle { get; set; }
Visual Basic (Declaration)
Public Property CellStyle As Style

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


EditOnSelection Property

[image]

.NET Framework Class Library
DataGridColumn..::.EditOnSelection Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool EditOnSelection { get; set; }
Visual Basic (Declaration)
Public Property EditOnSelection As Boolean

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


FilterMemberPath Property

[image]

.NET Framework Class Library
DataGridColumn..::.FilterMemberPath Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string FilterMemberPath { get; set; }
Visual Basic (Declaration)
Public Property FilterMemberPath As String

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


Header Property

[image]

.NET Framework Class Library
DataGridColumn..::.Header Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object Header { get; set; }
Visual Basic (Declaration)
Public Property Header As Object

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


HorizontalAlignment Property

[image]

.NET Framework Class Library
DataGridColumn..::.HorizontalAlignment Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public HorizontalAlignment HorizontalAlignment { get; set; }
Visual Basic (Declaration)
Public Property HorizontalAlignment As HorizontalAlignment

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


Index Property

[image]

.NET Framework Class Library
DataGridColumn..::.Index Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int Index { get; internal set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


IsEditable Property

[image]

.NET Framework Class Library
DataGridColumn..::.IsEditable Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public virtual bool IsEditable { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property IsEditable As Boolean

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


IsReadOnly Property

[image]

.NET Framework Class Library
DataGridColumn..::.IsReadOnly Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsReadOnly { get; set; }
Visual Basic (Declaration)
Public Property IsReadOnly As Boolean

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


MaxWidth Property

[image]

.NET Framework Class Library
DataGridColumn..::.MaxWidth Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MaxWidth { get; set; }
Visual Basic (Declaration)
Public Property MaxWidth As Double

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


MinWidth Property

[image]

.NET Framework Class Library
DataGridColumn..::.MinWidth Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MinWidth { get; set; }
Visual Basic (Declaration)
Public Property MinWidth As Double

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


SortingState Property

[image]

.NET Framework Class Library
DataGridColumn..::.SortingState Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridSortingState SortingState { get; set; }
Visual Basic (Declaration)
Public Property SortingState As DataGridSortingState

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


SortMemberPath Property

[image]

.NET Framework Class Library
DataGridColumn..::.SortMemberPath Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public virtual string SortMemberPath { get; set; }
Visual Basic (Declaration)
Public Overridable Property SortMemberPath As String

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


VerticalAlignment Property

[image]

.NET Framework Class Library
DataGridColumn..::.VerticalAlignment Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public VerticalAlignment VerticalAlignment { get; set; }
Visual Basic (Declaration)
Public Property VerticalAlignment As VerticalAlignment

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


Visibility Property

[image]

.NET Framework Class Library
DataGridColumn..::.Visibility Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Visibility Visibility { get; set; }
Visual Basic (Declaration)
Public Property Visibility As Visibility

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


Width Property

[image]

.NET Framework Class Library
DataGridColumn..::.Width Property
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GridLength Width { get; set; }
Visual Basic (Declaration)
Public Property Width As GridLength

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


DataGridColumn Events

[image] [image]

.NET Framework Class Library
DataGridColumn Events
DataGridColumn Class See Also

The DataGridColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged |
LoadingFilter |
SortingStateChanged |
SortMemberPathChanged |
VisibilityChanged |
WidthChanged |

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


FilterMemberPathChanged Event

[image]

.NET Framework Class Library
DataGridColumn..::.FilterMemberPathChanged Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<string>> FilterMemberPathChanged
Visual Basic (Declaration)
Public Event FilterMemberPathChanged As EventHandler(Of PropertyChangedEventArgs(Of String))

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


LoadingFilter Event

[image]

.NET Framework Class Library
DataGridColumn..::.LoadingFilter Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event LoadingFilterEventHandler LoadingFilter
Visual Basic (Declaration)
Public Event LoadingFilter As LoadingFilterEventHandler

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


SortingStateChanged Event

[image]

.NET Framework Class Library
DataGridColumn..::.SortingStateChanged Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<DataGridSortingState>> SortingStateChanged
Visual Basic (Declaration)
Public Event SortingStateChanged As EventHandler(Of PropertyChangedEventArgs(Of DataGridSortingState))

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


SortMemberPathChanged Event

[image]

.NET Framework Class Library
DataGridColumn..::.SortMemberPathChanged Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<string>> SortMemberPathChanged
Visual Basic (Declaration)
Public Event SortMemberPathChanged As EventHandler(Of PropertyChangedEventArgs(Of String))

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


VisibilityChanged Event

[image]

.NET Framework Class Library
DataGridColumn..::.VisibilityChanged Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<Visibility>> VisibilityChanged
Visual Basic (Declaration)
Public Event VisibilityChanged As EventHandler(Of PropertyChangedEventArgs(Of Visibility))

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


WidthChanged Event

[image]

.NET Framework Class Library
DataGridColumn..::.WidthChanged Event
DataGridColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<GridLength>> WidthChanged
Visual Basic (Declaration)
Public Event WidthChanged As EventHandler(Of PropertyChangedEventArgs(Of GridLength))

See Also

DataGridColumn Class
C1.Silverlight.DataGrid Namespace


DataGridColumnEventArgs Class

[image]

.NET Framework Class Library
DataGridColumnEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridColumnEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridColumnEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridColumnEventArgs

See Also

DataGridColumnEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridColumnEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridColumnEventArgs Members
DataGridColumnEventArgs Class Constructors Methods Properties See Also

The DataGridColumnEventArgs type exposes the following members.

Constructors

Name | Description
DataGridColumnEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Column |

See Also

DataGridColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnEventArgs Constructor

[image]

.NET Framework Class Library
DataGridColumnEventArgs Constructor
DataGridColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumnEventArgs(
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    column As DataGridColumn _
)

Parameters

column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

DataGridColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridColumnEventArgs Methods
DataGridColumnEventArgs Class See Also

The DataGridColumnEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridColumnEventArgs Properties
DataGridColumnEventArgs Class See Also

The DataGridColumnEventArgs type exposes the following members.

Properties

Name | Description
Column |

See Also

DataGridColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridColumnEventArgs..::.Column Property
DataGridColumnEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; private set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridColumnEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Class

[image]

.NET Framework Class Library
DataGridColumnHeader Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Filtering", GroupName = "OptionsStates")]
[TemplatePartAttribute(Name = "Resize", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "NotAvailable", GroupName = "OptionsStates")]
[TemplatePartAttribute(Name = "Options", Type = typeof(C1DropDown))]
[TemplatePartAttribute(Name = "Sort", Type = typeof(ToggleButton))]
[TemplateVisualStateAttribute(Name = "Available", GroupName = "OptionsStates")]
public class DataGridColumnHeader : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Filtering", GroupName := "OptionsStates")> _
<TemplatePartAttribute(Name := "Resize", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "NotAvailable", GroupName := "OptionsStates")> _
<TemplatePartAttribute(Name := "Options", Type := GetType(C1DropDown))> _
<TemplatePartAttribute(Name := "Sort", Type := GetType(ToggleButton))> _
<TemplateVisualStateAttribute(Name := "Available", GroupName := "OptionsStates")> _
Public Class DataGridColumnHeader _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight.DataGrid..::.DataGridColumnHeader

See Also

DataGridColumnHeader Members
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Members

[image] [image]

.NET Framework Class Library
DataGridColumnHeader Members
DataGridColumnHeader Class Constructors Methods Fields Properties Events See Also

The DataGridColumnHeader type exposes the following members.

Constructors

Name | Description
DataGridColumnHeader |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateOptions |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CanUserFilterProperty |
CanUserMoveProperty |
CanUserResizeProperty |
CanUserSortProperty |
IsFilteringProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserFilter |
CanUserMove |
CanUserResize |
CanUserSort |
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsFiltering |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SortingState |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
AutoSized |
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
Resized |
SizeChanged | (Inherited from FrameworkElement.)
SortingStateChanged |

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Constructor

[image]

.NET Framework Class Library
DataGridColumnHeader Constructor
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumnHeader()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Fields

[image] [image]

.NET Framework Class Library
DataGridColumnHeader Fields
DataGridColumnHeader Class See Also

The DataGridColumnHeader type exposes the following members.

Fields

Name | Description
CanUserFilterProperty |
CanUserMoveProperty |
CanUserResizeProperty |
CanUserSortProperty |
IsFilteringProperty |

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserFilterProperty Field

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserFilterProperty Field
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserFilterProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserFilterProperty As DependencyProperty

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserMoveProperty Field

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserMoveProperty Field
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserMoveProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserMoveProperty As DependencyProperty

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserResizeProperty Field

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserResizeProperty Field
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserResizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserResizeProperty As DependencyProperty

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserSortProperty Field

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserSortProperty Field
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserSortProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserSortProperty As DependencyProperty

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


IsFilteringProperty Field

[image]

.NET Framework Class Library
DataGridColumnHeader..::.IsFilteringProperty Field
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsFilteringProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsFilteringProperty As DependencyProperty

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Methods

[image] [image]

.NET Framework Class Library
DataGridColumnHeader Methods
DataGridColumnHeader Class See Also

The DataGridColumnHeader type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateOptions |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateOptions Method

[image]

.NET Framework Class Library
DataGridColumnHeader..::.ChangeVisualStateOptions Method
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateOptions(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateOptions ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridColumnHeader..::.HitTest Method
DataGridColumnHeader Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridColumnHeader Class
DataGridColumnHeader Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridColumnHeader..::.OnApplyTemplate Method
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Properties

[image] [image]

.NET Framework Class Library
DataGridColumnHeader Properties
DataGridColumnHeader Class See Also

The DataGridColumnHeader type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserFilter |
CanUserMove |
CanUserResize |
CanUserSort |
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEnabled | (Inherited from ContentControl.)
IsFiltering |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SortingState |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserFilter Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserFilter Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserFilter { get; set; }
Visual Basic (Declaration)
Public Property CanUserFilter As Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserMove Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserMove Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserMove { get; set; }
Visual Basic (Declaration)
Public Property CanUserMove As Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserResize Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserResize Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResize { get; set; }
Visual Basic (Declaration)
Public Property CanUserResize As Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


CanUserSort Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.CanUserSort Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserSort { get; set; }
Visual Basic (Declaration)
Public Property CanUserSort As Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.Filter Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IDataGridFilter Filter { get; set; }
Visual Basic (Declaration)
Public Property Filter As IDataGridFilter

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


IsFiltering Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.IsFiltering Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsFiltering { get; set; }
Visual Basic (Declaration)
Public Property IsFiltering As Boolean

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


SortingState Property

[image]

.NET Framework Class Library
DataGridColumnHeader..::.SortingState Property
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridSortingState SortingState { get; set; }
Visual Basic (Declaration)
Public Property SortingState As DataGridSortingState

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader Events

[image] [image]

.NET Framework Class Library
DataGridColumnHeader Events
DataGridColumnHeader Class See Also

The DataGridColumnHeader type exposes the following members.

Events

Name | Description
AutoSized |
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
Resized |
SizeChanged | (Inherited from FrameworkElement.)
SortingStateChanged |

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


AutoSized Event

[image]

.NET Framework Class Library
DataGridColumnHeader..::.AutoSized Event
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler AutoSized
Visual Basic (Declaration)
Public Event AutoSized As EventHandler

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridColumnHeader..::.FilterChanged Event
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


Resized Event

[image]

.NET Framework Class Library
DataGridColumnHeader..::.Resized Event
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<GridLength>> Resized
Visual Basic (Declaration)
Public Event Resized As EventHandler(Of PropertyChangedEventArgs(Of GridLength))

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


SortingStateChanged Event

[image]

.NET Framework Class Library
DataGridColumnHeader..::.SortingStateChanged Event
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event DataGridColumnHeader..::.SortingStateChangedEventHandler SortingStateChanged
Visual Basic (Declaration)
Public Event SortingStateChanged As DataGridColumnHeader..::.SortingStateChangedEventHandler

See Also

DataGridColumnHeader Class
C1.Silverlight.DataGrid Namespace


DataGridColumnHeader.SortingStateChangedEventHandler Delegate

[image]

.NET Framework Class Library
DataGridColumnHeader..::.SortingStateChangedEventHandler Delegate
DataGridColumnHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public delegate bool SortingStateChangedEventHandler(
    Object sender,
    PropertyChangedEventArgs<DataGridSortingState> e
)
Visual Basic (Declaration)
Public Delegate Function SortingStateChangedEventHandler ( _
    sender As Object, _
    e As PropertyChangedEventArgs(Of DataGridSortingState) _
) As Boolean

Parameters

sender
Type: System..::.Object
e
Type: C1.Silverlight..::.PropertyChangedEventArgs <(Of <( DataGridSortingState >)>)

See Also

C1.Silverlight.DataGrid Namespace


DataGridColumnReorderingEventArgs Class

[image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridColumnReorderingEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridColumnReorderingEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridColumnReorderingEventArgs

See Also

DataGridColumnReorderingEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridColumnReorderingEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs Members
DataGridColumnReorderingEventArgs Class Constructors Methods Properties See Also

The DataGridColumnReorderingEventArgs type exposes the following members.

Constructors

Name | Description
DataGridColumnReorderingEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel |
Column |
TargetColumnIndex |

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnReorderingEventArgs Constructor

[image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs Constructor
DataGridColumnReorderingEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumnReorderingEventArgs(
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    column As DataGridColumn _
)

Parameters

column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnReorderingEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs Methods
DataGridColumnReorderingEventArgs Class See Also

The DataGridColumnReorderingEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnReorderingEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs Properties
DataGridColumnReorderingEventArgs Class See Also

The DataGridColumnReorderingEventArgs type exposes the following members.

Properties

Name | Description
Cancel |
Column |
TargetColumnIndex |

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


Cancel Property

[image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs..::.Cancel Property
DataGridColumnReorderingEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs..::.Column Property
DataGridColumnReorderingEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; private set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


TargetColumnIndex Property

[image]

.NET Framework Class Library
DataGridColumnReorderingEventArgs..::.TargetColumnIndex Property
DataGridColumnReorderingEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int TargetColumnIndex { get; set; }
Visual Basic (Declaration)
Public Property TargetColumnIndex As Integer

See Also

DataGridColumnReorderingEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Class

[image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridColumnsHeaderPanel : Panel
Visual Basic (Declaration)
Public Class DataGridColumnsHeaderPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.DataGrid..::.DataGridColumnsHeaderPanel

See Also

DataGridColumnsHeaderPanel Members
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Members

[image] [image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Members
DataGridColumnsHeaderPanel Class Constructors Methods Properties Events See Also

The DataGridColumnsHeaderPanel type exposes the following members.

Constructors

Name | Description
DataGridColumnsHeaderPanel |

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ColumnsChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Constructor

[image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Constructor
DataGridColumnsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumnsHeaderPanel()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Methods

[image] [image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Methods
DataGridColumnsHeaderPanel Class See Also

The DataGridColumnsHeaderPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridColumnsHeaderPanel..::.ArrangeOverride Method
DataGridColumnsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridColumnsHeaderPanel..::.HitTest Method
DataGridColumnsHeaderPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridColumnsHeaderPanel Class
DataGridColumnsHeaderPanel Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridColumnsHeaderPanel..::.MeasureOverride Method
DataGridColumnsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Properties

[image] [image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Properties
DataGridColumnsHeaderPanel Class See Also

The DataGridColumnsHeaderPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridColumnsHeaderPanel Events

[image] [image]

.NET Framework Class Library
DataGridColumnsHeaderPanel Events
DataGridColumnsHeaderPanel Class See Also

The DataGridColumnsHeaderPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
ColumnsChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


ColumnsChanged Event

[image]

.NET Framework Class Library
DataGridColumnsHeaderPanel..::.ColumnsChanged Event
DataGridColumnsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event RoutedEventHandler ColumnsChanged
Visual Basic (Declaration)
Public Event ColumnsChanged As RoutedEventHandler

See Also

DataGridColumnsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Class

[image]

.NET Framework Class Library
DataGridComboBoxColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridComboBoxColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridComboBoxColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridComboBoxColumn

See Also

DataGridComboBoxColumn Members
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Members

[image] [image]

.NET Framework Class Library
DataGridComboBoxColumn Members
DataGridComboBoxColumn Class Constructors Methods Properties Events See Also

The DataGridComboBoxColumn type exposes the following members.

Constructors

Name | Description
DataGridComboBoxColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
DisplayMemberPath |
DropDownHeight |
DropDownWidth |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
ItemsSource |
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SelectedValuePath |
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridComboBoxColumn Constructor
DataGridComboBoxColumn Class See Also

Overload List

Name | Description
DataGridComboBoxColumn()()() |
DataGridComboBoxColumn(PropertyInfo) |

See Also

DataGridComboBoxColumn Class
DataGridComboBoxColumn Members
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Constructor

[image]

.NET Framework Class Library
DataGridComboBoxColumn Constructor
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridComboBoxColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridComboBoxColumn Class
DataGridComboBoxColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridComboBoxColumn Constructor (PropertyInfo)
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridComboBoxColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridComboBoxColumn Class
DataGridComboBoxColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Methods

[image] [image]

.NET Framework Class Library
DataGridComboBoxColumn Methods
DataGridComboBoxColumn Class See Also

The DataGridComboBoxColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.BeginEdit Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control editingElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    editingElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

editingElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.CancelCellEdit Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.GetCellContent Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.GetCellEditingContent Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.GetFilter Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overrides Function GetFilter As IDataGridFilter

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.Initialize Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.PrepareCellForEdit Method
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Properties

[image] [image]

.NET Framework Class Library
DataGridComboBoxColumn Properties
DataGridComboBoxColumn Class See Also

The DataGridComboBoxColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
DisplayMemberPath |
DropDownHeight |
DropDownWidth |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
ItemsSource |
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SelectedValuePath |
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DefaultConverter Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.DefaultConverter Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override IValueConverter DefaultConverter { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultConverter As IValueConverter

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DisplayMemberPath Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.DisplayMemberPath Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string DisplayMemberPath { get; set; }
Visual Basic (Declaration)
Public Property DisplayMemberPath As String

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DropDownHeight Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.DropDownHeight Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double DropDownHeight { get; set; }
Visual Basic (Declaration)
Public Property DropDownHeight As Double

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DropDownWidth Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.DropDownWidth Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double DropDownWidth { get; set; }
Visual Basic (Declaration)
Public Property DropDownWidth As Double

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


ItemsSource Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.ItemsSource Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IEnumerable

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


SelectedValuePath Property

[image]

.NET Framework Class Library
DataGridComboBoxColumn..::.SelectedValuePath Property
DataGridComboBoxColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string SelectedValuePath { get; set; }
Visual Basic (Declaration)
Public Property SelectedValuePath As String

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxColumn Events

[image] [image]

.NET Framework Class Library
DataGridComboBoxColumn Events
DataGridComboBoxColumn Class See Also

The DataGridComboBoxColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridComboBoxColumn Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Class

[image]

.NET Framework Class Library
DataGridComboBoxFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "FilterAllCheckBox", Type = typeof(CheckBox))]
[TemplatePartAttribute(Name = "FilterItemsControl", Type = typeof(ItemsControl))]
public class DataGridComboBoxFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "FilterAllCheckBox", Type := GetType(CheckBox))> _
<TemplatePartAttribute(Name := "FilterItemsControl", Type := GetType(ItemsControl))> _
Public Class DataGridComboBoxFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridComboBoxFilter

See Also

DataGridComboBoxFilter Members
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Members

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter Members
DataGridComboBoxFilter Class Constructors Methods Fields Properties Events See Also

The DataGridComboBoxFilter type exposes the following members.

Constructors

Name | Description
DataGridComboBoxFilter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
ItemsSourceProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource |
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Values |
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Constructor

[image]

.NET Framework Class Library
DataGridComboBoxFilter Constructor
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridComboBoxFilter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Fields

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter Fields
DataGridComboBoxFilter Class See Also

The DataGridComboBoxFilter type exposes the following members.

Fields

Name | Description
ItemsSourceProperty |

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


ItemsSourceProperty Field

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.ItemsSourceProperty Field
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty ItemsSourceProperty
Visual Basic (Declaration)
Public Shared ReadOnly ItemsSourceProperty As DependencyProperty

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Methods

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter Methods
DataGridComboBoxFilter Class See Also

The DataGridComboBoxFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.ClearFilter Method
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ClearFilter()
Visual Basic (Declaration)
Public Sub ClearFilter

Implements

IDataGridFilter..::.ClearFilter()()()

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.CreateFilter Method
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CreateFilter()
Visual Basic (Declaration)
Public Sub CreateFilter

Implements

IDataGridFilter..::.CreateFilter()()()

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter..::.HitTest Method
DataGridComboBoxFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridComboBoxFilter Class
DataGridComboBoxFilter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.OnApplyTemplate Method
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Properties

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter Properties
DataGridComboBoxFilter Class See Also

The DataGridComboBoxFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
ItemsSource |
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
Values |
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.Filter Property
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As FilterDescription

Implements

IDataGridFilter..::.Filter

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


ItemsSource Property

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.ItemsSource Property
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable<ComboValueInfo> ItemsSource { get; set; }
Visual Basic (Declaration)
Public Property ItemsSource As IEnumerable(Of ComboValueInfo)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


Values Property

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.Values Property
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable<ComboValueInfo> Values { get; set; }
Visual Basic (Declaration)
Public Property Values As IEnumerable(Of ComboValueInfo)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridComboBoxFilter Events

[image] [image]

.NET Framework Class Library
DataGridComboBoxFilter Events
DataGridComboBoxFilter Class See Also

The DataGridComboBoxFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridComboBoxFilter..::.FilterChanged Event
DataGridComboBoxFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

Implements

IDataGridFilter..::.FilterChanged

See Also

DataGridComboBoxFilter Class
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Class

[image]

.NET Framework Class Library
DataGridDateColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridDateColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridDateColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridDateColumn

See Also

DataGridDateColumn Members
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Members

[image] [image]

.NET Framework Class Library
DataGridDateColumn Members
DataGridDateColumn Class Constructors Methods Properties Events See Also

The DataGridDateColumn type exposes the following members.

Constructors

Name | Description
DataGridDateColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Inherited from DataGridBoundColumn.)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridDateColumn Constructor
DataGridDateColumn Class See Also

Overload List

Name | Description
DataGridDateColumn()()() |
DataGridDateColumn(PropertyInfo) |

See Also

DataGridDateColumn Class
DataGridDateColumn Members
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Constructor

[image]

.NET Framework Class Library
DataGridDateColumn Constructor
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridDateColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridDateColumn Class
DataGridDateColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridDateColumn Constructor (PropertyInfo)
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridDateColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridDateColumn Class
DataGridDateColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Methods

[image] [image]

.NET Framework Class Library
DataGridDateColumn Methods
DataGridDateColumn Class See Also

The DataGridDateColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Inherited from DataGridBoundColumn.)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.CancelCellEdit Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.GetCellEditingContent Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


GetDesignTimeText Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.GetDesignTimeText Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override string GetDesignTimeText(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Overrides Function GetDesignTimeText ( _
    row As DataGridRow _
) As String

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.GetFilter Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overrides Function GetFilter As IDataGridFilter

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.Initialize Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridDateColumn..::.PrepareCellForEdit Method
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Properties

[image] [image]

.NET Framework Class Library
DataGridDateColumn Properties
DataGridDateColumn Class See Also

The DataGridDateColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


DefaultConverter Property

[image]

.NET Framework Class Library
DataGridDateColumn..::.DefaultConverter Property
DataGridDateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override IValueConverter DefaultConverter { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultConverter As IValueConverter

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridDateColumn Events

[image] [image]

.NET Framework Class Library
DataGridDateColumn Events
DataGridDateColumn Class See Also

The DataGridDateColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridDateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Class

[image]

.NET Framework Class Library
DataGridDateFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "EndDate", Type = typeof(DatePicker))]
[TemplatePartAttribute(Name = "StartDate", Type = typeof(DatePicker))]
public class DataGridDateFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "EndDate", Type := GetType(DatePicker))> _
<TemplatePartAttribute(Name := "StartDate", Type := GetType(DatePicker))> _
Public Class DataGridDateFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridDateFilter

See Also

DataGridDateFilter Members
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Members

[image] [image]

.NET Framework Class Library
DataGridDateFilter Members
DataGridDateFilter Class Constructors Methods Properties Events See Also

The DataGridDateFilter type exposes the following members.

Constructors

Name | Description
DataGridDateFilter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Constructor

[image]

.NET Framework Class Library
DataGridDateFilter Constructor
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridDateFilter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Methods

[image] [image]

.NET Framework Class Library
DataGridDateFilter Methods
DataGridDateFilter Class See Also

The DataGridDateFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
DataGridDateFilter..::.ClearFilter Method
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ClearFilter()
Visual Basic (Declaration)
Public Sub ClearFilter

Implements

IDataGridFilter..::.ClearFilter()()()

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
DataGridDateFilter..::.CreateFilter Method
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CreateFilter()
Visual Basic (Declaration)
Public Sub CreateFilter

Implements

IDataGridFilter..::.CreateFilter()()()

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridDateFilter..::.HitTest Method
DataGridDateFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridDateFilter Class
DataGridDateFilter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridDateFilter..::.OnApplyTemplate Method
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Properties

[image] [image]

.NET Framework Class Library
DataGridDateFilter Properties
DataGridDateFilter Class See Also

The DataGridDateFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridDateFilter..::.Filter Property
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As FilterDescription

Implements

IDataGridFilter..::.Filter

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


DataGridDateFilter Events

[image] [image]

.NET Framework Class Library
DataGridDateFilter Events
DataGridDateFilter Class See Also

The DataGridDateFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridDateFilter..::.FilterChanged Event
DataGridDateFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

Implements

IDataGridFilter..::.FilterChanged

See Also

DataGridDateFilter Class
C1.Silverlight.DataGrid Namespace


DataGridEditingUnit Enumeration

[image]

.NET Framework Class Library
DataGridEditingUnit Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum DataGridEditingUnit
Visual Basic (Declaration)
Public Enumeration DataGridEditingUnit

Members

Member name | Description
Cell |
Row |

See Also

C1.Silverlight.DataGrid Namespace


DataGridEndingEditEventArgs Class

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridEndingEditEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridEndingEditEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridEndingEditEventArgs

See Also

DataGridEndingEditEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridEndingEditEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridEndingEditEventArgs Members
DataGridEndingEditEventArgs Class Constructors Methods Properties See Also

The DataGridEndingEditEventArgs type exposes the following members.

Constructors

Name | Description
DataGridEndingEditEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Cancel |
Column |
EditingElement |
EditingUnit |
Row |

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridEndingEditEventArgs Constructor

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs Constructor
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridEndingEditEventArgs(
    DataGridRow row,
    DataGridColumn column
)
Visual Basic (Declaration)
Public Sub New ( _
    row As DataGridRow, _
    column As DataGridColumn _
)

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow
column
Type: C1.Silverlight.DataGrid..::.DataGridColumn

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridEndingEditEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridEndingEditEventArgs Methods
DataGridEndingEditEventArgs Class See Also

The DataGridEndingEditEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridEndingEditEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridEndingEditEventArgs Properties
DataGridEndingEditEventArgs Class See Also

The DataGridEndingEditEventArgs type exposes the following members.

Properties

Name | Description
Cancel |
Column |
EditingElement |
EditingUnit |
Row |

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Cancel Property

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs..::.Cancel Property
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Cancel { get; set; }
Visual Basic (Declaration)
Public Property Cancel As Boolean

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Column Property

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs..::.Column Property
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridColumn Column { get; private set; }
Visual Basic (Declaration)
Public Property Column As DataGridColumn

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


EditingElement Property

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs..::.EditingElement Property
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FrameworkElement EditingElement { get; internal set; }
Visual Basic (Declaration)
Public Property EditingElement As FrameworkElement

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


EditingUnit Property

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs..::.EditingUnit Property
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridEditingUnit EditingUnit { get; private set; }
Visual Basic (Declaration)
Public Property EditingUnit As DataGridEditingUnit

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridEndingEditEventArgs..::.Row Property
DataGridEndingEditEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; private set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridEndingEditEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridFilter Class

[image]

.NET Framework Class Library
DataGridFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "FilterButton", Type = typeof(Button))]
[TemplatePartAttribute(Name = "ClearButton", Type = typeof(Button))]
[TemplatePartAttribute(Name = "InnerControlContainer", Type = typeof(ContentControl))]
public class DataGridFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "FilterButton", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "ClearButton", Type := GetType(Button))> _
<TemplatePartAttribute(Name := "InnerControlContainer", Type := GetType(ContentControl))> _
Public Class DataGridFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridFilter

See Also

DataGridFilter Members
C1.Silverlight.DataGrid Namespace


DataGridFilter Members

[image] [image]

.NET Framework Class Library
DataGridFilter Members
DataGridFilter Class Constructors Methods Properties Events See Also

The DataGridFilter type exposes the following members.

Constructors

Name | Description
DataGridFilter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InnerControl |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


DataGridFilter Constructor

[image]

.NET Framework Class Library
DataGridFilter Constructor
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridFilter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


DataGridFilter Methods

[image] [image]

.NET Framework Class Library
DataGridFilter Methods
DataGridFilter Class See Also

The DataGridFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
DataGridFilter..::.ClearFilter Method
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ClearFilter()
Visual Basic (Declaration)
Public Sub ClearFilter

Implements

IDataGridFilter..::.ClearFilter()()()

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
DataGridFilter..::.CreateFilter Method
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CreateFilter()
Visual Basic (Declaration)
Public Sub CreateFilter

Implements

IDataGridFilter..::.CreateFilter()()()

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridFilter..::.HitTest Method
DataGridFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridFilter Class
DataGridFilter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridFilter..::.OnApplyTemplate Method
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


DataGridFilter Properties

[image] [image]

.NET Framework Class Library
DataGridFilter Properties
DataGridFilter Class See Also

The DataGridFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
InnerControl |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridFilter..::.Filter Property
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As FilterDescription

Implements

IDataGridFilter..::.Filter

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


InnerControl Property

[image]

.NET Framework Class Library
DataGridFilter..::.InnerControl Property
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IDataGridFilter InnerControl { get; set; }
Visual Basic (Declaration)
Public Property InnerControl As IDataGridFilter

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


DataGridFilter Events

[image] [image]

.NET Framework Class Library
DataGridFilter Events
DataGridFilter Class See Also

The DataGridFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridFilter..::.FilterChanged Event
DataGridFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

Implements

IDataGridFilter..::.FilterChanged

See Also

DataGridFilter Class
C1.Silverlight.DataGrid Namespace


DataGridFilterManager Class

[image]

.NET Framework Class Library
DataGridFilterManager Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridFilterManager
Visual Basic (Declaration)
Public Class DataGridFilterManager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridFilterManager

See Also

DataGridFilterManager Members
C1.Silverlight.DataGrid Namespace


DataGridFilterManager Members

[image] [image]

.NET Framework Class Library
DataGridFilterManager Members
DataGridFilterManager Class Constructors Methods See Also

The DataGridFilterManager type exposes the following members.

Constructors

Name | Description
DataGridFilterManager |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterBy |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridFilterManager Class
C1.Silverlight.DataGrid Namespace


DataGridFilterManager Constructor

[image]

.NET Framework Class Library
DataGridFilterManager Constructor
DataGridFilterManager Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridFilterManager(
    DataConnection dataConnection
)
Visual Basic (Declaration)
Public Sub New ( _
    dataConnection As DataConnection _
)

Parameters

dataConnection
Type: C1.Silverlight.DataGrid..::.DataConnection

See Also

DataGridFilterManager Class
C1.Silverlight.DataGrid Namespace


DataGridFilterManager Methods

[image] [image]

.NET Framework Class Library
DataGridFilterManager Methods
DataGridFilterManager Class See Also

The DataGridFilterManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FilterBy |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridFilterManager Class
C1.Silverlight.DataGrid Namespace


FilterBy Method

[image]

.NET Framework Class Library
DataGridFilterManager..::.FilterBy Method
DataGridFilterManager Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void FilterBy(
    DataGridColumn column,
    FilterDescription filter
)
Visual Basic (Declaration)
Public Sub FilterBy ( _
    column As DataGridColumn, _
    filter As FilterDescription _
)

Parameters

column
Type: C1.Silverlight.DataGrid..::.DataGridColumn
filter
Type: C1.Silverlight.DataGrid..::.FilterDescription

See Also

DataGridFilterManager Class
C1.Silverlight.DataGrid Namespace


DataGridHeaders Enumeration

[image]

.NET Framework Class Library
DataGridHeaders Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum DataGridHeaders
Visual Basic (Declaration)
Public Enumeration DataGridHeaders

Members

Member name | Description
All |
Column |
Row |
None |

See Also

C1.Silverlight.DataGrid Namespace


DataGridImageColumn Class

[image]

.NET Framework Class Library
DataGridImageColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridImageColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridImageColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridImageColumn

See Also

DataGridImageColumn Members
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Members

[image] [image]

.NET Framework Class Library
DataGridImageColumn Members
DataGridImageColumn Class Constructors Methods Properties Events See Also

The DataGridImageColumn type exposes the following members.

Constructors

Name | Description
DataGridImageColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Inherited from DataGridBoundColumn.)
CancelCellEdit | (Inherited from DataGridBoundColumn.)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Inherited from DataGridBoundColumn.)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Inherited from DataGridBoundColumn.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridBoundColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridImageColumn Constructor
DataGridImageColumn Class See Also

Overload List

Name | Description
DataGridImageColumn()()() |
DataGridImageColumn(PropertyInfo) |

See Also

DataGridImageColumn Class
DataGridImageColumn Members
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Constructor

[image]

.NET Framework Class Library
DataGridImageColumn Constructor
DataGridImageColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridImageColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridImageColumn Class
DataGridImageColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridImageColumn Constructor (PropertyInfo)
DataGridImageColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridImageColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridImageColumn Class
DataGridImageColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Methods

[image] [image]

.NET Framework Class Library
DataGridImageColumn Methods
DataGridImageColumn Class See Also

The DataGridImageColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Inherited from DataGridBoundColumn.)
CancelCellEdit | (Inherited from DataGridBoundColumn.)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridBoundColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Inherited from DataGridBoundColumn.)
GetDesignTimeText | (Inherited from DataGridBoundColumn.)
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Inherited from DataGridBoundColumn.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridImageColumn..::.GetCellContent Method
DataGridImageColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridImageColumn..::.Initialize Method
DataGridImageColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Properties

[image] [image]

.NET Framework Class Library
DataGridImageColumn Properties
DataGridImageColumn Class See Also

The DataGridImageColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridBoundColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


IsEditable Property

[image]

.NET Framework Class Library
DataGridImageColumn..::.IsEditable Property
DataGridImageColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override bool IsEditable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEditable As Boolean

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


DataGridImageColumn Events

[image] [image]

.NET Framework Class Library
DataGridImageColumn Events
DataGridImageColumn Class See Also

The DataGridImageColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridImageColumn Class
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Class

[image]

.NET Framework Class Library
DataGridMainPanel Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridMainPanel : Panel
Visual Basic (Declaration)
Public Class DataGridMainPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.DataGrid..::.DataGridMainPanel

See Also

DataGridMainPanel Members
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Members

[image] [image]

.NET Framework Class Library
DataGridMainPanel Members
DataGridMainPanel Class Constructors Methods Properties Events See Also

The DataGridMainPanel type exposes the following members.

Constructors

Name | Description
DataGridMainPanel |

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
Clear |
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FocusElement |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Constructor

[image]

.NET Framework Class Library
DataGridMainPanel Constructor
DataGridMainPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridMainPanel()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Methods

[image] [image]

.NET Framework Class Library
DataGridMainPanel Methods
DataGridMainPanel Class See Also

The DataGridMainPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
Clear |
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridMainPanel..::.ArrangeOverride Method
DataGridMainPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


Clear Method

[image]

.NET Framework Class Library
DataGridMainPanel..::.Clear Method
DataGridMainPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridMainPanel..::.HitTest Method
DataGridMainPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridMainPanel Class
DataGridMainPanel Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridMainPanel..::.MeasureOverride Method
DataGridMainPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Properties

[image] [image]

.NET Framework Class Library
DataGridMainPanel Properties
DataGridMainPanel Class See Also

The DataGridMainPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FocusElement |
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


FocusElement Property

[image]

.NET Framework Class Library
DataGridMainPanel..::.FocusElement Property
DataGridMainPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Control FocusElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property FocusElement As Control

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


DataGridMainPanel Events

[image] [image]

.NET Framework Class Library
DataGridMainPanel Events
DataGridMainPanel Class See Also

The DataGridMainPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridMainPanel Class
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Class

[image]

.NET Framework Class Library
DataGridNumericColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridNumericColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridNumericColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridNumericColumn

See Also

DataGridNumericColumn Members
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Members

[image] [image]

.NET Framework Class Library
DataGridNumericColumn Members
DataGridNumericColumn Class Constructors Methods Properties Events See Also

The DataGridNumericColumn type exposes the following members.

Constructors

Name | Description
DataGridNumericColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
Maximum |
MaxWidth | (Inherited from DataGridColumn.)
Minimum |
MinWidth | (Inherited from DataGridColumn.)
ShowButtons |
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridNumericColumn Constructor
DataGridNumericColumn Class See Also

Overload List

Name | Description
DataGridNumericColumn()()() |
DataGridNumericColumn(PropertyInfo) |

See Also

DataGridNumericColumn Class
DataGridNumericColumn Members
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Constructor

[image]

.NET Framework Class Library
DataGridNumericColumn Constructor
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridNumericColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridNumericColumn Class
DataGridNumericColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridNumericColumn Constructor (PropertyInfo)
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridNumericColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridNumericColumn Class
DataGridNumericColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Methods

[image] [image]

.NET Framework Class Library
DataGridNumericColumn Methods
DataGridNumericColumn Class See Also

The DataGridNumericColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.BeginEdit Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control editingElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    editingElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

editingElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.CancelCellEdit Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.GetCellEditingContent Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


GetDesignTimeText Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.GetDesignTimeText Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override string GetDesignTimeText(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Overrides Function GetDesignTimeText ( _
    row As DataGridRow _
) As String

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.GetFilter Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overrides Function GetFilter As IDataGridFilter

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.Initialize Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridNumericColumn..::.PrepareCellForEdit Method
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Properties

[image] [image]

.NET Framework Class Library
DataGridNumericColumn Properties
DataGridNumericColumn Class See Also

The DataGridNumericColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Overrides DataGridBoundColumn..::.DefaultConverter.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
Maximum |
MaxWidth | (Inherited from DataGridColumn.)
Minimum |
MinWidth | (Inherited from DataGridColumn.)
ShowButtons |
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


DefaultConverter Property

[image]

.NET Framework Class Library
DataGridNumericColumn..::.DefaultConverter Property
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override IValueConverter DefaultConverter { get; }
Visual Basic (Declaration)
Protected Overrides ReadOnly Property DefaultConverter As IValueConverter

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


Maximum Property

[image]

.NET Framework Class Library
DataGridNumericColumn..::.Maximum Property
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double Maximum { get; set; }
Visual Basic (Declaration)
Public Property Maximum As Double

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


Minimum Property

[image]

.NET Framework Class Library
DataGridNumericColumn..::.Minimum Property
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double Minimum { get; set; }
Visual Basic (Declaration)
Public Property Minimum As Double

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


ShowButtons Property

[image]

.NET Framework Class Library
DataGridNumericColumn..::.ShowButtons Property
DataGridNumericColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool ShowButtons { get; set; }
Visual Basic (Declaration)
Public Property ShowButtons As Boolean

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


DataGridNumericColumn Events

[image] [image]

.NET Framework Class Library
DataGridNumericColumn Events
DataGridNumericColumn Class See Also

The DataGridNumericColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridNumericColumn Class
C1.Silverlight.DataGrid Namespace


DataGridNumericFilter Class

[image]

.NET Framework Class Library
DataGridNumericFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridNumericFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
Public Class DataGridNumericFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridNumericFilter

See Also

DataGridNumericFilter Members
C1.Silverlight.DataGrid Namespace


DataGridNumericFilter Members

[image] [image]

.NET Framework Class Library
DataGridNumericFilter Members
DataGridNumericFilter Class Methods Properties Events See Also

The DataGridNumericFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridNumericFilter Class
C1.Silverlight.DataGrid Namespace


DataGridNumericFilter Methods

[image] [image]

.NET Framework Class Library
DataGridNumericFilter Methods
DataGridNumericFilter Class See Also

The DataGridNumericFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from Control.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridNumericFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridNumericFilter..::.HitTest Method
DataGridNumericFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridNumericFilter Class
DataGridNumericFilter Members
C1.Silverlight.DataGrid Namespace


DataGridNumericFilter Properties

[image] [image]

.NET Framework Class Library
DataGridNumericFilter Properties
DataGridNumericFilter Class See Also

The DataGridNumericFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridNumericFilter Class
C1.Silverlight.DataGrid Namespace


DataGridNumericFilter Events

[image] [image]

.NET Framework Class Library
DataGridNumericFilter Events
DataGridNumericFilter Class See Also

The DataGridNumericFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridNumericFilter Class
C1.Silverlight.DataGrid Namespace


DataGridRow Class

[image]

.NET Framework Class Library
DataGridRow Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridRow
Visual Basic (Declaration)
Public Class DataGridRow

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridRow Members
C1.Silverlight.DataGrid Namespace


DataGridRow Members

[image] [image]

.NET Framework Class Library
DataGridRow Members
DataGridRow Class Methods Properties Events See Also

The DataGridRow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CanUserResize |
DataItem |
DetailsVisibility |
Height |
Index |
IsEditing |
IsMouseOver |
IsSelected |
MaxHeight |
MinHeight |

Events

Name | Description
CanUserResizeChanged |
HeightChanged |
IsEditingChanged |
IsMouseOverChanged |
IsSelectedChanged |

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DataGridRow Methods

[image] [image]

.NET Framework Class Library
DataGridRow Methods
DataGridRow Class See Also

The DataGridRow type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DataGridRow Properties

[image] [image]

.NET Framework Class Library
DataGridRow Properties
DataGridRow Class See Also

The DataGridRow type exposes the following members.

Properties

Name | Description
CanUserResize |
DataItem |
DetailsVisibility |
Height |
Index |
IsEditing |
IsMouseOver |
IsSelected |
MaxHeight |
MinHeight |

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


CanUserResize Property

[image]

.NET Framework Class Library
DataGridRow..::.CanUserResize Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResize { get; set; }
Visual Basic (Declaration)
Public Property CanUserResize As Boolean

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DataItem Property

[image]

.NET Framework Class Library
DataGridRow..::.DataItem Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object DataItem { get; internal set; }
Visual Basic (Declaration)
Public Property DataItem As Object

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DetailsVisibility Property

[image]

.NET Framework Class Library
DataGridRow..::.DetailsVisibility Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Visibility DetailsVisibility { get; set; }
Visual Basic (Declaration)
Public Property DetailsVisibility As Visibility

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


Height Property

[image]

.NET Framework Class Library
DataGridRow..::.Height Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GridLength Height { get; set; }
Visual Basic (Declaration)
Public Property Height As GridLength

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


Index Property

[image]

.NET Framework Class Library
DataGridRow..::.Index Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int Index { get; internal set; }
Visual Basic (Declaration)
Public Property Index As Integer

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsEditing Property

[image]

.NET Framework Class Library
DataGridRow..::.IsEditing Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsEditing { get; internal set; }
Visual Basic (Declaration)
Public Property IsEditing As Boolean

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
DataGridRow..::.IsMouseOver Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsMouseOver { get; set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsSelected Property

[image]

.NET Framework Class Library
DataGridRow..::.IsSelected Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


MaxHeight Property

[image]

.NET Framework Class Library
DataGridRow..::.MaxHeight Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MaxHeight { get; set; }
Visual Basic (Declaration)
Public Property MaxHeight As Double

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


MinHeight Property

[image]

.NET Framework Class Library
DataGridRow..::.MinHeight Property
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public double MinHeight { get; set; }
Visual Basic (Declaration)
Public Property MinHeight As Double

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DataGridRow Events

[image] [image]

.NET Framework Class Library
DataGridRow Events
DataGridRow Class See Also

The DataGridRow type exposes the following members.

Events

Name | Description
CanUserResizeChanged |
HeightChanged |
IsEditingChanged |
IsMouseOverChanged |
IsSelectedChanged |

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


CanUserResizeChanged Event

[image]

.NET Framework Class Library
DataGridRow..::.CanUserResizeChanged Event
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> CanUserResizeChanged
Visual Basic (Declaration)
Public Event CanUserResizeChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


HeightChanged Event

[image]

.NET Framework Class Library
DataGridRow..::.HeightChanged Event
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<GridLength>> HeightChanged
Visual Basic (Declaration)
Public Event HeightChanged As EventHandler(Of PropertyChangedEventArgs(Of GridLength))

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsEditingChanged Event

[image]

.NET Framework Class Library
DataGridRow..::.IsEditingChanged Event
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsEditingChanged
Visual Basic (Declaration)
Public Event IsEditingChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
DataGridRow..::.IsMouseOverChanged Event
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


IsSelectedChanged Event

[image]

.NET Framework Class Library
DataGridRow..::.IsSelectedChanged Event
DataGridRow Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsSelectedChanged
Visual Basic (Declaration)
Public Event IsSelectedChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRow Class
C1.Silverlight.DataGrid Namespace


DataGridRowCollection Class

[image]

.NET Framework Class Library
DataGridRowCollection Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[DefaultMemberAttribute("Item")]
public class DataGridRowCollection : IEnumerable<DataGridRow>,
    IEnumerable
Visual Basic (Declaration)
<DefaultMemberAttribute("Item")> _
Public Class DataGridRowCollection _
    Implements IEnumerable(Of DataGridRow), IEnumerable

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridRowCollection

See Also

DataGridRowCollection Members
C1.Silverlight.DataGrid Namespace


DataGridRowCollection Members

[image] [image]

.NET Framework Class Library
DataGridRowCollection Members
DataGridRowCollection Class Methods Properties See Also

The DataGridRowCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
Item | Overloaded.

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


DataGridRowCollection Methods

[image] [image]

.NET Framework Class Library
DataGridRowCollection Methods
DataGridRowCollection Class See Also

The DataGridRowCollection type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
DataGridRowCollection..::.GetEnumerator Method
DataGridRowCollection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerator<DataGridRow> GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator(Of DataGridRow)

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


DataGridRowCollection Properties

[image] [image]

.NET Framework Class Library
DataGridRowCollection Properties
DataGridRowCollection Class See Also

The DataGridRowCollection type exposes the following members.

Properties

Name | Description
Count |
Item | Overloaded.

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


Count Property

[image]

.NET Framework Class Library
DataGridRowCollection..::.Count Property
DataGridRowCollection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int Count { get; internal set; }
Visual Basic (Declaration)
Public Property Count As Integer

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


Item Property

[image] [image]

.NET Framework Class Library
DataGridRowCollection..::.Item Property
DataGridRowCollection Class See Also

Overload List

Name | Description
Item[([(Int32])]) |
Item[([(Object])]) |

See Also

DataGridRowCollection Class
DataGridRowCollection Members
C1.Silverlight.DataGrid Namespace


Item Property (Int32)

[image]

.NET Framework Class Library
DataGridRowCollection..::.Item Property (Int32)
DataGridRowCollection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow this[
    int rowIndex
] { get; internal set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    rowIndex As Integer _
) As DataGridRow

Parameters

rowIndex
Type: System..::.Int32

See Also

DataGridRowCollection Class
Item Overload
C1.Silverlight.DataGrid Namespace


Item Property (Object)

[image]

.NET Framework Class Library
DataGridRowCollection..::.Item Property (Object)
DataGridRowCollection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow this[
    Object item
] { get; }
Visual Basic (Declaration)
Public ReadOnly Default Property Item ( _
    item As Object _
) As DataGridRow

Parameters

item
Type: System..::.Object

See Also

DataGridRowCollection Class
Item Overload
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsEventArgs Class

[image]

.NET Framework Class Library
DataGridRowDetailsEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridRowDetailsEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridRowDetailsEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridRowDetailsEventArgs

See Also

DataGridRowDetailsEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridRowDetailsEventArgs Members
DataGridRowDetailsEventArgs Class Constructors Methods Properties See Also

The DataGridRowDetailsEventArgs type exposes the following members.

Constructors

Name | Description
DataGridRowDetailsEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
DetailsElement |
Row |

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsEventArgs Constructor

[image]

.NET Framework Class Library
DataGridRowDetailsEventArgs Constructor
DataGridRowDetailsEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowDetailsEventArgs(
    DataGridRow row,
    FrameworkElement detailsElement
)
Visual Basic (Declaration)
Public Sub New ( _
    row As DataGridRow, _
    detailsElement As FrameworkElement _
)

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow
detailsElement
Type: System.Windows..::.FrameworkElement

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridRowDetailsEventArgs Methods
DataGridRowDetailsEventArgs Class See Also

The DataGridRowDetailsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridRowDetailsEventArgs Properties
DataGridRowDetailsEventArgs Class See Also

The DataGridRowDetailsEventArgs type exposes the following members.

Properties

Name | Description
DetailsElement |
Row |

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DetailsElement Property

[image]

.NET Framework Class Library
DataGridRowDetailsEventArgs..::.DetailsElement Property
DataGridRowDetailsEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FrameworkElement DetailsElement { get; private set; }
Visual Basic (Declaration)
Public Property DetailsElement As FrameworkElement

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridRowDetailsEventArgs..::.Row Property
DataGridRowDetailsEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; private set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridRowDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowDetailsVisibilityMode Enumeration

[image]

.NET Framework Class Library
DataGridRowDetailsVisibilityMode Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum DataGridRowDetailsVisibilityMode
Visual Basic (Declaration)
Public Enumeration DataGridRowDetailsVisibilityMode

Members

Member name | Description
VisibleWhenSelected |
Visible |
Collapsed |

See Also

C1.Silverlight.DataGrid Namespace


DataGridRowEventArgs Class

[image]

.NET Framework Class Library
DataGridRowEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridRowEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridRowEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridRowEventArgs

See Also

DataGridRowEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridRowEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridRowEventArgs Members
DataGridRowEventArgs Class Constructors Methods Properties See Also

The DataGridRowEventArgs type exposes the following members.

Constructors

Name | Description
DataGridRowEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Row |

See Also

DataGridRowEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowEventArgs Constructor

[image]

.NET Framework Class Library
DataGridRowEventArgs Constructor
DataGridRowEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowEventArgs(
    DataGridRow dataGridRow
)
Visual Basic (Declaration)
Public Sub New ( _
    dataGridRow As DataGridRow _
)

Parameters

dataGridRow
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridRowEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridRowEventArgs Methods
DataGridRowEventArgs Class See Also

The DataGridRowEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridRowEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridRowEventArgs Properties
DataGridRowEventArgs Class See Also

The DataGridRowEventArgs type exposes the following members.

Properties

Name | Description
Row |

See Also

DataGridRowEventArgs Class
C1.Silverlight.DataGrid Namespace


Row Property

[image]

.NET Framework Class Library
DataGridRowEventArgs..::.Row Property
DataGridRowEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRow Row { get; private set; }
Visual Basic (Declaration)
Public Property Row As DataGridRow

See Also

DataGridRowEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Class

[image]

.NET Framework Class Library
DataGridRowHeader Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Editing", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Resize", Type = typeof(FrameworkElement))]
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
public class DataGridRowHeader : ContentControl
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Editing", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Resize", Type := GetType(FrameworkElement))> _
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
Public Class DataGridRowHeader _
    Inherits ContentControl

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
C1.Silverlight.DataGrid..::.DataGridRowHeader

See Also

DataGridRowHeader Members
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Members

[image] [image]

.NET Framework Class Library
DataGridRowHeader Members
DataGridRowHeader Class Constructors Methods Fields Properties Events See Also

The DataGridRowHeader type exposes the following members.

Constructors

Name | Description
DataGridRowHeader |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CanUserResizeProperty |
IsEditingProperty |
IsMouseOverProperty |
IsSelectedProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserResize |
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver |
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
AutoSized |
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
Resized |
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Constructor

[image]

.NET Framework Class Library
DataGridRowHeader Constructor
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowHeader()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Fields

[image] [image]

.NET Framework Class Library
DataGridRowHeader Fields
DataGridRowHeader Class See Also

The DataGridRowHeader type exposes the following members.

Fields

Name | Description
CanUserResizeProperty |
IsEditingProperty |
IsMouseOverProperty |
IsSelectedProperty |

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


CanUserResizeProperty Field

[image]

.NET Framework Class Library
DataGridRowHeader..::.CanUserResizeProperty Field
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CanUserResizeProperty
Visual Basic (Declaration)
Public Shared ReadOnly CanUserResizeProperty As DependencyProperty

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsEditingProperty Field

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsEditingProperty Field
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsEditingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsEditingProperty As DependencyProperty

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsMouseOverProperty Field
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsSelectedProperty Field
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Methods

[image] [image]

.NET Framework Class Library
DataGridRowHeader Methods
DataGridRowHeader Class See Also

The DataGridRowHeader type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnContentChanged | (Inherited from ContentControl.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnIsEnabledChanged | (Inherited from ContentControl.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
DataGridRowHeader..::.ChangeVisualStateCommon Method
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateSelection Method

[image]

.NET Framework Class Library
DataGridRowHeader..::.ChangeVisualStateSelection Method
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateSelection(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateSelection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridRowHeader..::.HitTest Method
DataGridRowHeader Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridRowHeader Class
DataGridRowHeader Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridRowHeader..::.OnApplyTemplate Method
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Properties

[image] [image]

.NET Framework Class Library
DataGridRowHeader Properties
DataGridRowHeader Class See Also

The DataGridRowHeader type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
CanUserResize |
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsEnabled | (Inherited from ContentControl.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver |
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


CanUserResize Property

[image]

.NET Framework Class Library
DataGridRowHeader..::.CanUserResize Property
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanUserResize { get; set; }
Visual Basic (Declaration)
Public Property CanUserResize As Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsEditing Property

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsEditing Property
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsEditing { get; set; }
Visual Basic (Declaration)
Public Property IsEditing As Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsMouseOver Property
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsSelected Property

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsSelected Property
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowHeader Events

[image] [image]

.NET Framework Class Library
DataGridRowHeader Events
DataGridRowHeader Class See Also

The DataGridRowHeader type exposes the following members.

Events

Name | Description
AutoSized |
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
Resized |
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


AutoSized Event

[image]

.NET Framework Class Library
DataGridRowHeader..::.AutoSized Event
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler AutoSized
Visual Basic (Declaration)
Public Event AutoSized As EventHandler

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
DataGridRowHeader..::.IsMouseOverChanged Event
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


Resized Event

[image]

.NET Framework Class Library
DataGridRowHeader..::.Resized Event
DataGridRowHeader Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<GridLength>> Resized
Visual Basic (Declaration)
Public Event Resized As EventHandler(Of PropertyChangedEventArgs(Of GridLength))

See Also

DataGridRowHeader Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Class

[image]

.NET Framework Class Library
DataGridRowPresenter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplateVisualStateAttribute(Name = "Unselected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Disabled", GroupName = "CommonStates")]
[TemplatePartAttribute(Name = "Details", Type = typeof(Grid))]
[TemplatePartAttribute(Name = "Cells", Type = typeof(DataGridCellsPanel))]
[TemplateVisualStateAttribute(Name = "MouseOver", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Normal", GroupName = "CommonStates")]
[TemplateVisualStateAttribute(Name = "Selected", GroupName = "SelectionStates")]
[TemplateVisualStateAttribute(Name = "Editing", GroupName = "SelectionStates")]
public class DataGridRowPresenter : Control
Visual Basic (Declaration)
<TemplateVisualStateAttribute(Name := "Unselected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Disabled", GroupName := "CommonStates")> _
<TemplatePartAttribute(Name := "Details", Type := GetType(Grid))> _
<TemplatePartAttribute(Name := "Cells", Type := GetType(DataGridCellsPanel))> _
<TemplateVisualStateAttribute(Name := "MouseOver", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Normal", GroupName := "CommonStates")> _
<TemplateVisualStateAttribute(Name := "Selected", GroupName := "SelectionStates")> _
<TemplateVisualStateAttribute(Name := "Editing", GroupName := "SelectionStates")> _
Public Class DataGridRowPresenter _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridRowPresenter

See Also

DataGridRowPresenter Members
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Members

[image] [image]

.NET Framework Class Library
DataGridRowPresenter Members
DataGridRowPresenter Class Constructors Methods Fields Properties Events See Also

The DataGridRowPresenter type exposes the following members.

Constructors

Name | Description
DataGridRowPresenter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CommitChanges |
EditCompleted |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillRow |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveEditingCell |
RemoveSelectedCell |
SetBinding | (Inherited from FrameworkElement.)
SetEditingCell |
SetSelectedCell |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
CellsProperty |
DetailsVisibilityProperty |
EditingBorderBrushProperty |
EditingBorderThicknessProperty |
EditingBrushProperty |
IsEditingProperty |
IsMouseOverProperty |
IsSelectedProperty |
MouseOverBorderBrushProperty |
MouseOverBorderThicknessProperty |
MouseOverBrushProperty |
SelectedBorderBrushProperty |
SelectedBorderThicknessProperty |
SelectedBrushProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Cells |
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DetailsVisibility |
Dispatcher | (Inherited from DependencyObject.)
EditingBorderBrush |
EditingBorderThickness |
EditingBrush |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver |
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseOverBorderBrush |
MouseOverBorderThickness |
MouseOverBrush |
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBorderBrush |
SelectedBorderThickness |
SelectedBrush |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Constructor

[image]

.NET Framework Class Library
DataGridRowPresenter Constructor
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowPresenter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Fields

[image] [image]

.NET Framework Class Library
DataGridRowPresenter Fields
DataGridRowPresenter Class See Also

The DataGridRowPresenter type exposes the following members.

Fields

Name | Description
CellsProperty |
DetailsVisibilityProperty |
EditingBorderBrushProperty |
EditingBorderThicknessProperty |
EditingBrushProperty |
IsEditingProperty |
IsMouseOverProperty |
IsSelectedProperty |
MouseOverBorderBrushProperty |
MouseOverBorderThicknessProperty |
MouseOverBrushProperty |
SelectedBorderBrushProperty |
SelectedBorderThicknessProperty |
SelectedBrushProperty |

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


CellsProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.CellsProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty CellsProperty
Visual Basic (Declaration)
Public Shared ReadOnly CellsProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DetailsVisibilityProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.DetailsVisibilityProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty DetailsVisibilityProperty
Visual Basic (Declaration)
Public Shared ReadOnly DetailsVisibilityProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBorderBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBorderBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty EditingBorderBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly EditingBorderBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBorderThicknessProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBorderThicknessProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty EditingBorderThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly EditingBorderThicknessProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty EditingBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly EditingBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsEditingProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsEditingProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsEditingProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsEditingProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsMouseOverProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsMouseOverProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsMouseOverProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsMouseOverProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsSelectedProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsSelectedProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsSelectedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsSelectedProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBorderBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBorderBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MouseOverBorderBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseOverBorderBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBorderThicknessProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBorderThicknessProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MouseOverBorderThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseOverBorderThicknessProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty MouseOverBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly MouseOverBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBorderBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBorderBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedBorderBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedBorderBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBorderThicknessProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBorderThicknessProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedBorderThicknessProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedBorderThicknessProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBrushProperty Field

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBrushProperty Field
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty SelectedBrushProperty
Visual Basic (Declaration)
Public Shared ReadOnly SelectedBrushProperty As DependencyProperty

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Methods

[image] [image]

.NET Framework Class Library
DataGridRowPresenter Methods
DataGridRowPresenter Class See Also

The DataGridRowPresenter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
ChangeVisualStateCommon |
ChangeVisualStateSelection |
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
CommitChanges |
EditCompleted |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
FillRow |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
RemoveEditingCell |
RemoveSelectedCell |
SetBinding | (Inherited from FrameworkElement.)
SetEditingCell |
SetSelectedCell |
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.ArrangeOverride Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateCommon Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.ChangeVisualStateCommon Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateCommon(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateCommon ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


ChangeVisualStateSelection Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.ChangeVisualStateSelection Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void ChangeVisualStateSelection(
    bool useTransitions
)
Visual Basic (Declaration)
Protected Sub ChangeVisualStateSelection ( _
    useTransitions As Boolean _
)

Parameters

useTransitions
Type: System..::.Boolean

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


CommitChanges Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.CommitChanges Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CommitChanges()
Visual Basic (Declaration)
Public Sub CommitChanges

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditCompleted Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditCompleted Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void EditCompleted(
    int columnIndex
)
Visual Basic (Declaration)
Public Sub EditCompleted ( _
    columnIndex As Integer _
)

Parameters

columnIndex
Type: System..::.Int32

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


FillRow Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.FillRow Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void FillRow(
    Size availableSize
)
Visual Basic (Declaration)
Public Sub FillRow ( _
    availableSize As Size _
)

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridRowPresenter..::.HitTest Method
DataGridRowPresenter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridRowPresenter Class
DataGridRowPresenter Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MeasureOverride Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.OnApplyTemplate Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


RemoveEditingCell Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.RemoveEditingCell Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void RemoveEditingCell()
Visual Basic (Declaration)
Public Sub RemoveEditingCell

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


RemoveSelectedCell Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.RemoveSelectedCell Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void RemoveSelectedCell()
Visual Basic (Declaration)
Public Sub RemoveSelectedCell

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SetEditingCell Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SetEditingCell Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Control SetEditingCell(
    int columnIndex
)
Visual Basic (Declaration)
Public Function SetEditingCell ( _
    columnIndex As Integer _
) As Control

Parameters

columnIndex
Type: System..::.Int32

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SetSelectedCell Method

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SetSelectedCell Method
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void SetSelectedCell(
    int columnIndex
)
Visual Basic (Declaration)
Public Sub SetSelectedCell ( _
    columnIndex As Integer _
)

Parameters

columnIndex
Type: System..::.Int32

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Properties

[image] [image]

.NET Framework Class Library
DataGridRowPresenter Properties
DataGridRowPresenter Class See Also

The DataGridRowPresenter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Cells |
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
DetailsVisibility |
Dispatcher | (Inherited from DependencyObject.)
EditingBorderBrush |
EditingBorderThickness |
EditingBrush |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsEditing |
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver |
IsSelected |
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
MouseOverBorderBrush |
MouseOverBorderThickness |
MouseOverBrush |
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
SelectedBorderBrush |
SelectedBorderThickness |
SelectedBrush |
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


Cells Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.Cells Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<FrameworkElement> Cells { get; private set; }
Visual Basic (Declaration)
Public Property Cells As IList(Of FrameworkElement)

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DetailsVisibility Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.DetailsVisibility Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Visibility DetailsVisibility { get; set; }
Visual Basic (Declaration)
Public Property DetailsVisibility As Visibility

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBorderBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBorderBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush EditingBorderBrush { get; set; }
Visual Basic (Declaration)
Public Property EditingBorderBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBorderThickness Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBorderThickness Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Thickness EditingBorderThickness { get; set; }
Visual Basic (Declaration)
Public Property EditingBorderThickness As Thickness

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


EditingBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.EditingBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush EditingBrush { get; set; }
Visual Basic (Declaration)
Public Property EditingBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsEditing Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsEditing Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsEditing { get; set; }
Visual Basic (Declaration)
Public Property IsEditing As Boolean

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsMouseOver Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsMouseOver Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsMouseOver { get; internal set; }
Visual Basic (Declaration)
Public Property IsMouseOver As Boolean

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsSelected Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsSelected Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsSelected { get; set; }
Visual Basic (Declaration)
Public Property IsSelected As Boolean

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBorderBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBorderBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush MouseOverBorderBrush { get; set; }
Visual Basic (Declaration)
Public Property MouseOverBorderBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBorderThickness Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBorderThickness Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Thickness MouseOverBorderThickness { get; set; }
Visual Basic (Declaration)
Public Property MouseOverBorderThickness As Thickness

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


MouseOverBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.MouseOverBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush MouseOverBrush { get; set; }
Visual Basic (Declaration)
Public Property MouseOverBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBorderBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBorderBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush SelectedBorderBrush { get; set; }
Visual Basic (Declaration)
Public Property SelectedBorderBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBorderThickness Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBorderThickness Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Thickness SelectedBorderThickness { get; set; }
Visual Basic (Declaration)
Public Property SelectedBorderThickness As Thickness

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


SelectedBrush Property

[image]

.NET Framework Class Library
DataGridRowPresenter..::.SelectedBrush Property
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Brush SelectedBrush { get; set; }
Visual Basic (Declaration)
Public Property SelectedBrush As Brush

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowPresenter Events

[image] [image]

.NET Framework Class Library
DataGridRowPresenter Events
DataGridRowPresenter Class See Also

The DataGridRowPresenter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
IsMouseOverChanged |
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


IsMouseOverChanged Event

[image]

.NET Framework Class Library
DataGridRowPresenter..::.IsMouseOverChanged Event
DataGridRowPresenter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<bool>> IsMouseOverChanged
Visual Basic (Declaration)
Public Event IsMouseOverChanged As EventHandler(Of PropertyChangedEventArgs(Of Boolean))

See Also

DataGridRowPresenter Class
C1.Silverlight.DataGrid Namespace


DataGridRowRequestingDetailsEventArgs Class

[image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridRowRequestingDetailsEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridRowRequestingDetailsEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridRowRequestingDetailsEventArgs

See Also

DataGridRowRequestingDetailsEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridRowRequestingDetailsEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs Members
DataGridRowRequestingDetailsEventArgs Class Constructors Methods Properties See Also

The DataGridRowRequestingDetailsEventArgs type exposes the following members.

Constructors

Name | Description
DataGridRowRequestingDetailsEventArgs |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Template |

See Also

DataGridRowRequestingDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowRequestingDetailsEventArgs Constructor

[image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs Constructor
DataGridRowRequestingDetailsEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowRequestingDetailsEventArgs(
    DataTemplate template
)
Visual Basic (Declaration)
Public Sub New ( _
    template As DataTemplate _
)

Parameters

template
Type: System.Windows..::.DataTemplate

See Also

DataGridRowRequestingDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowRequestingDetailsEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs Methods
DataGridRowRequestingDetailsEventArgs Class See Also

The DataGridRowRequestingDetailsEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridRowRequestingDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowRequestingDetailsEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs Properties
DataGridRowRequestingDetailsEventArgs Class See Also

The DataGridRowRequestingDetailsEventArgs type exposes the following members.

Properties

Name | Description
Template |

See Also

DataGridRowRequestingDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


Template Property

[image]

.NET Framework Class Library
DataGridRowRequestingDetailsEventArgs..::.Template Property
DataGridRowRequestingDetailsEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataTemplate Template { get; private set; }
Visual Basic (Declaration)
Public Property Template As DataTemplate

See Also

DataGridRowRequestingDetailsEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Class

[image]

.NET Framework Class Library
DataGridRowsHeaderPanel Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridRowsHeaderPanel : Panel
Visual Basic (Declaration)
Public Class DataGridRowsHeaderPanel _
    Inherits Panel

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Panel
C1.Silverlight.DataGrid..::.DataGridRowsHeaderPanel

See Also

DataGridRowsHeaderPanel Members
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Members

[image] [image]

.NET Framework Class Library
DataGridRowsHeaderPanel Members
DataGridRowsHeaderPanel Class Constructors Methods Properties Events See Also

The DataGridRowsHeaderPanel type exposes the following members.

Constructors

Name | Description
DataGridRowsHeaderPanel |

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Constructor

[image]

.NET Framework Class Library
DataGridRowsHeaderPanel Constructor
DataGridRowsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridRowsHeaderPanel()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Methods

[image] [image]

.NET Framework Class Library
DataGridRowsHeaderPanel Methods
DataGridRowsHeaderPanel Class See Also

The DataGridRowsHeaderPanel type exposes the following members.

Methods

Name | Description
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Overrides FrameworkElement..::.ArrangeOverride(Size).)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Overrides FrameworkElement..::.MeasureOverride(Size).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


ArrangeOverride Method

[image]

.NET Framework Class Library
DataGridRowsHeaderPanel..::.ArrangeOverride Method
DataGridRowsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size ArrangeOverride(
    Size finalSize
)
Visual Basic (Declaration)
Protected Overrides Function ArrangeOverride ( _
    finalSize As Size _
) As Size

Parameters

finalSize
Type: System.Windows..::.Size

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridRowsHeaderPanel..::.HitTest Method
DataGridRowsHeaderPanel Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridRowsHeaderPanel Class
DataGridRowsHeaderPanel Members
C1.Silverlight.DataGrid Namespace


MeasureOverride Method

[image]

.NET Framework Class Library
DataGridRowsHeaderPanel..::.MeasureOverride Method
DataGridRowsHeaderPanel Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override Size MeasureOverride(
    Size availableSize
)
Visual Basic (Declaration)
Protected Overrides Function MeasureOverride ( _
    availableSize As Size _
) As Size

Parameters

availableSize
Type: System.Windows..::.Size

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Properties

[image] [image]

.NET Framework Class Library
DataGridRowsHeaderPanel Properties
DataGridRowsHeaderPanel Class See Also

The DataGridRowsHeaderPanel type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Panel.)
Children | (Inherited from Panel.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
IsHitTestVisible | (Inherited from UIElement.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
Tag | (Inherited from FrameworkElement.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridRowsHeaderPanel Events

[image] [image]

.NET Framework Class Library
DataGridRowsHeaderPanel Events
DataGridRowsHeaderPanel Class See Also

The DataGridRowsHeaderPanel type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridRowsHeaderPanel Class
C1.Silverlight.DataGrid Namespace


DataGridSortChangedEventArgs Class

[image]

.NET Framework Class Library
DataGridSortChangedEventArgs Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridSortChangedEventArgs : EventArgs
Visual Basic (Declaration)
Public Class DataGridSortChangedEventArgs _
    Inherits EventArgs

Inheritance Hierarchy

System..::.Object
System..::.EventArgs
C1.Silverlight.DataGrid..::.DataGridSortChangedEventArgs

See Also

DataGridSortChangedEventArgs Members
C1.Silverlight.DataGrid Namespace


DataGridSortChangedEventArgs Members

[image] [image]

.NET Framework Class Library
DataGridSortChangedEventArgs Members
DataGridSortChangedEventArgs Class Methods Properties See Also

The DataGridSortChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
SortDescriptions |

See Also

DataGridSortChangedEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridSortChangedEventArgs Methods

[image] [image]

.NET Framework Class Library
DataGridSortChangedEventArgs Methods
DataGridSortChangedEventArgs Class See Also

The DataGridSortChangedEventArgs type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridSortChangedEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridSortChangedEventArgs Properties

[image] [image]

.NET Framework Class Library
DataGridSortChangedEventArgs Properties
DataGridSortChangedEventArgs Class See Also

The DataGridSortChangedEventArgs type exposes the following members.

Properties

Name | Description
SortDescriptions |

See Also

DataGridSortChangedEventArgs Class
C1.Silverlight.DataGrid Namespace


SortDescriptions Property

[image]

.NET Framework Class Library
DataGridSortChangedEventArgs..::.SortDescriptions Property
DataGridSortChangedEventArgs Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public SortDescription[] SortDescriptions { get; internal set; }
Visual Basic (Declaration)
Public Property SortDescriptions As SortDescription()

See Also

DataGridSortChangedEventArgs Class
C1.Silverlight.DataGrid Namespace


DataGridSortingManager Class

[image]

.NET Framework Class Library
DataGridSortingManager Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridSortingManager
Visual Basic (Declaration)
Public Class DataGridSortingManager

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridSortingManager

See Also

DataGridSortingManager Members
C1.Silverlight.DataGrid Namespace


DataGridSortingManager Members

[image] [image]

.NET Framework Class Library
DataGridSortingManager Members
DataGridSortingManager Class Constructors Methods See Also

The DataGridSortingManager type exposes the following members.

Constructors

Name | Description
DataGridSortingManager |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortBy |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSortDescriptions |

See Also

DataGridSortingManager Class
C1.Silverlight.DataGrid Namespace


DataGridSortingManager Constructor

[image]

.NET Framework Class Library
DataGridSortingManager Constructor
DataGridSortingManager Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridSortingManager(
    DataConnection dataConnection
)
Visual Basic (Declaration)
Public Sub New ( _
    dataConnection As DataConnection _
)

Parameters

dataConnection
Type: C1.Silverlight.DataGrid..::.DataConnection

See Also

DataGridSortingManager Class
C1.Silverlight.DataGrid Namespace


DataGridSortingManager Methods

[image] [image]

.NET Framework Class Library
DataGridSortingManager Methods
DataGridSortingManager Class See Also

The DataGridSortingManager type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
SortBy |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSortDescriptions |

See Also

DataGridSortingManager Class
C1.Silverlight.DataGrid Namespace


SortBy Method

[image]

.NET Framework Class Library
DataGridSortingManager..::.SortBy Method
DataGridSortingManager Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void SortBy(
    DataGridColumn column,
    DataGridSortingState state,
    bool preservePreviousSorting
)
Visual Basic (Declaration)
Public Sub SortBy ( _
    column As DataGridColumn, _
    state As DataGridSortingState, _
    preservePreviousSorting As Boolean _
)

Parameters

column
Type: C1.Silverlight.DataGrid..::.DataGridColumn
state
Type: C1.Silverlight.DataGrid..::.DataGridSortingState
preservePreviousSorting
Type: System..::.Boolean

See Also

DataGridSortingManager Class
C1.Silverlight.DataGrid Namespace


UpdateSortDescriptions Method

[image]

.NET Framework Class Library
DataGridSortingManager..::.UpdateSortDescriptions Method
DataGridSortingManager Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void UpdateSortDescriptions()
Visual Basic (Declaration)
Public Sub UpdateSortDescriptions

See Also

DataGridSortingManager Class
C1.Silverlight.DataGrid Namespace


DataGridSortingState Enumeration

[image]

.NET Framework Class Library
DataGridSortingState Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum DataGridSortingState
Visual Basic (Declaration)
Public Enumeration DataGridSortingState

Members

Member name | Description
None |
Ascending |
Descending |

See Also

C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Class

[image]

.NET Framework Class Library
DataGridTemplateColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridTemplateColumn : DataGridColumn
Visual Basic (Declaration)
Public Class DataGridTemplateColumn _
    Inherits DataGridColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridTemplateColumn

See Also

DataGridTemplateColumn Members
C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Members

[image] [image]

.NET Framework Class Library
DataGridTemplateColumn Members
DataGridTemplateColumn Class Constructors Methods Properties Events See Also

The DataGridTemplateColumn type exposes the following members.

Constructors

Name | Description
DataGridTemplateColumn |

Methods

Name | Description
BeginEdit | (Overrides DataGridColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridColumn..::.CancelCellEdit(FrameworkElement, Object).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridColumn..::.GetCellEditingContent(DataGridRow).)
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Inherited from DataGridColumn.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellEditingTemplate |
CellStyle | (Inherited from DataGridColumn.)
CellTemplate |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
ValueMemberPath |
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
CancelingCell |
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
PreparingCell |
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Constructor

[image]

.NET Framework Class Library
DataGridTemplateColumn Constructor
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridTemplateColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Methods

[image] [image]

.NET Framework Class Library
DataGridTemplateColumn Methods
DataGridTemplateColumn Class See Also

The DataGridTemplateColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridColumn..::.CancelCellEdit(FrameworkElement, Object).)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Overrides DataGridColumn..::.GetCellContent(DataGridRow).)
GetCellEditingContent | (Overrides DataGridColumn..::.GetCellEditingContent(DataGridRow).)
GetFilter | (Inherited from DataGridColumn.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Inherited from DataGridColumn.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.BeginEdit Method
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control cellElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    cellElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

cellElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.CancelCellEdit Method
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


GetCellContent Method

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.GetCellContent Method
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override FrameworkElement GetCellContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellContent ( _
    row As DataGridRow _
) As FrameworkElement

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.GetCellEditingContent Method
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.PrepareCellForEdit Method
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Properties

[image] [image]

.NET Framework Class Library
DataGridTemplateColumn Properties
DataGridTemplateColumn Class See Also

The DataGridTemplateColumn type exposes the following members.

Properties

Name | Description
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellEditingTemplate |
CellStyle | (Inherited from DataGridColumn.)
CellTemplate |
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Overrides DataGridColumn..::.IsEditable.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
ValueMemberPath |
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


CellEditingTemplate Property

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.CellEditingTemplate Property
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataTemplate CellEditingTemplate { get; set; }
Visual Basic (Declaration)
Public Property CellEditingTemplate As DataTemplate

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


CellTemplate Property

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.CellTemplate Property
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataTemplate CellTemplate { get; set; }
Visual Basic (Declaration)
Public Property CellTemplate As DataTemplate

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


IsEditable Property

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.IsEditable Property
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override bool IsEditable { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property IsEditable As Boolean

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


ValueMemberPath Property

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.ValueMemberPath Property
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string ValueMemberPath { get; set; }
Visual Basic (Declaration)
Public Property ValueMemberPath As String

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTemplateColumn Events

[image] [image]

.NET Framework Class Library
DataGridTemplateColumn Events
DataGridTemplateColumn Class See Also

The DataGridTemplateColumn type exposes the following members.

Events

Name | Description
CancelingCell |
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
PreparingCell |
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


CancelingCell Event

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.CancelingCell Event
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event CancellingCellEditEventHandler CancelingCell
Visual Basic (Declaration)
Public Event CancelingCell As CancellingCellEditEventHandler

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


PreparingCell Event

[image]

.NET Framework Class Library
DataGridTemplateColumn..::.PreparingCell Event
DataGridTemplateColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event PreparingCellEditEventHandler PreparingCell
Visual Basic (Declaration)
Public Event PreparingCell As PreparingCellEditEventHandler

See Also

DataGridTemplateColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Class

[image]

.NET Framework Class Library
DataGridTextColumn Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataGridTextColumn : DataGridBoundColumn
Visual Basic (Declaration)
Public Class DataGridTextColumn _
    Inherits DataGridBoundColumn

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataGridColumn
C1.Silverlight.DataGrid..::.DataGridBoundColumn
C1.Silverlight.DataGrid..::.DataGridTextColumn

See Also

DataGridTextColumn Members
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Members

[image] [image]

.NET Framework Class Library
DataGridTextColumn Members
DataGridTextColumn Class Constructors Methods Properties Events See Also

The DataGridTextColumn type exposes the following members.

Constructors

Name | Description
DataGridTextColumn | Overloaded.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Constructor

[image] [image]

.NET Framework Class Library
DataGridTextColumn Constructor
DataGridTextColumn Class See Also

Overload List

Name | Description
DataGridTextColumn()()() |
DataGridTextColumn(PropertyInfo) |

See Also

DataGridTextColumn Class
DataGridTextColumn Members
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Constructor

[image]

.NET Framework Class Library
DataGridTextColumn Constructor
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridTextColumn()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridTextColumn Class
DataGridTextColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Constructor (PropertyInfo)

[image]

.NET Framework Class Library
DataGridTextColumn Constructor (PropertyInfo)
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridTextColumn(
    PropertyInfo property
)
Visual Basic (Declaration)
Public Sub New ( _
    property As PropertyInfo _
)

Parameters

property
Type: System.Reflection..::.PropertyInfo

See Also

DataGridTextColumn Class
DataGridTextColumn Overload
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Methods

[image] [image]

.NET Framework Class Library
DataGridTextColumn Methods
DataGridTextColumn Class See Also

The DataGridTextColumn type exposes the following members.

Methods

Name | Description
BeginEdit | (Overrides DataGridBoundColumn..::.BeginEdit(Control, KeyEventArgs).)
CancelCellEdit | (Overrides DataGridBoundColumn..::.CancelCellEdit(FrameworkElement, Object).)
CopyBinding | (Inherited from DataGridBoundColumn.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetCellContent | (Inherited from DataGridBoundColumn.)
GetCellEditingContent | (Overrides DataGridBoundColumn..::.GetCellEditingContent(DataGridRow).)
GetDesignTimeText | (Overrides DataGridBoundColumn..::.GetDesignTimeText(DataGridRow).)
GetFilter | (Overrides DataGridColumn..::.GetFilter()()().)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Initialize | (Overrides DataGridBoundColumn..::.Initialize()()().)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
PrepareCellForEdit | (Overrides DataGridBoundColumn..::.PrepareCellForEdit(FrameworkElement, RoutedEventArgs).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.BeginEdit Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override bool BeginEdit(
    Control editingElement,
    KeyEventArgs routedEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function BeginEdit ( _
    editingElement As Control, _
    routedEventArgs As KeyEventArgs _
) As Boolean

Parameters

editingElement
Type: System.Windows.Controls..::.Control
routedEventArgs
Type: System.Windows.Input..::.KeyEventArgs

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


CancelCellEdit Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.CancelCellEdit Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override void CancelCellEdit(
    FrameworkElement editingElement,
    Object uneditedValue
)
Visual Basic (Declaration)
Protected Friend Overrides Sub CancelCellEdit ( _
    editingElement As FrameworkElement, _
    uneditedValue As Object _
)

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
uneditedValue
Type: System..::.Object

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


GetCellEditingContent Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.GetCellEditingContent Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Control GetCellEditingContent(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Friend Overrides Function GetCellEditingContent ( _
    row As DataGridRow _
) As Control

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


GetDesignTimeText Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.GetDesignTimeText Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override string GetDesignTimeText(
    DataGridRow row
)
Visual Basic (Declaration)
Protected Overrides Function GetDesignTimeText ( _
    row As DataGridRow _
) As String

Parameters

row
Type: C1.Silverlight.DataGrid..::.DataGridRow

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


GetFilter Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.GetFilter Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override IDataGridFilter GetFilter()
Visual Basic (Declaration)
Protected Friend Overrides Function GetFilter As IDataGridFilter

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


Initialize Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.Initialize Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected override void Initialize()
Visual Basic (Declaration)
Protected Overrides Sub Initialize

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


PrepareCellForEdit Method

[image]

.NET Framework Class Library
DataGridTextColumn..::.PrepareCellForEdit Method
DataGridTextColumn Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected internal override Object PrepareCellForEdit(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Protected Friend Overrides Function PrepareCellForEdit ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Properties

[image] [image]

.NET Framework Class Library
DataGridTextColumn Properties
DataGridTextColumn Class See Also

The DataGridTextColumn type exposes the following members.

Properties

Name | Description
AllowNull | (Inherited from DataGridBoundColumn.)
Binding | (Inherited from DataGridBoundColumn.)
CanUserFilter | (Inherited from DataGridColumn.)
CanUserResize | (Inherited from DataGridColumn.)
CellEditingStyle | (Inherited from DataGridColumn.)
CellStyle | (Inherited from DataGridColumn.)
DefaultConverter | (Inherited from DataGridBoundColumn.)
EditOnSelection | (Inherited from DataGridColumn.)
FilterMemberPath | (Inherited from DataGridColumn.)
Format | (Inherited from DataGridBoundColumn.)
Header | (Inherited from DataGridColumn.)
HorizontalAlignment | (Inherited from DataGridColumn.)
Index | (Inherited from DataGridColumn.)
IsEditable | (Inherited from DataGridBoundColumn.)
IsReadOnly | (Inherited from DataGridColumn.)
MaxWidth | (Inherited from DataGridColumn.)
MinWidth | (Inherited from DataGridColumn.)
SortingState | (Inherited from DataGridColumn.)
SortMemberPath | (Inherited from DataGridColumn.)
TextWrapping | (Inherited from DataGridBoundColumn.)
VerticalAlignment | (Inherited from DataGridColumn.)
Visibility | (Inherited from DataGridColumn.)
Width | (Inherited from DataGridColumn.)

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTextColumn Events

[image] [image]

.NET Framework Class Library
DataGridTextColumn Events
DataGridTextColumn Class See Also

The DataGridTextColumn type exposes the following members.

Events

Name | Description
FilterMemberPathChanged | (Inherited from DataGridColumn.)
LoadingFilter | (Inherited from DataGridColumn.)
SortingStateChanged | (Inherited from DataGridColumn.)
SortMemberPathChanged | (Inherited from DataGridColumn.)
VisibilityChanged | (Inherited from DataGridColumn.)
WidthChanged | (Inherited from DataGridColumn.)

See Also

DataGridTextColumn Class
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Class

[image]

.NET Framework Class Library
DataGridTextFilter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TemplatePartAttribute(Name = "FilterBox", Type = typeof(TextBox))]
[TemplatePartAttribute(Name = "Label", Type = typeof(TextBlock))]
public class DataGridTextFilter : Control,
    IDataGridFilter
Visual Basic (Declaration)
<TemplatePartAttribute(Name := "FilterBox", Type := GetType(TextBox))> _
<TemplatePartAttribute(Name := "Label", Type := GetType(TextBlock))> _
Public Class DataGridTextFilter _
    Inherits Control _
    Implements IDataGridFilter

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.DataGridTextFilter

See Also

DataGridTextFilter Members
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Members

[image] [image]

.NET Framework Class Library
DataGridTextFilter Members
DataGridTextFilter Class Constructors Methods Properties Events See Also

The DataGridTextFilter type exposes the following members.

Constructors

Name | Description
DataGridTextFilter |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Constructor

[image]

.NET Framework Class Library
DataGridTextFilter Constructor
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridTextFilter()
Visual Basic (Declaration)
Public Sub New

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Methods

[image] [image]

.NET Framework Class Library
DataGridTextFilter Methods
DataGridTextFilter Class See Also

The DataGridTextFilter type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearFilter |
ClearValue | (Inherited from DependencyObject.)
CreateFilter |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
DataGridTextFilter..::.ClearFilter Method
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void ClearFilter()
Visual Basic (Declaration)
Public Sub ClearFilter

Implements

IDataGridFilter..::.ClearFilter()()()

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
DataGridTextFilter..::.CreateFilter Method
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void CreateFilter()
Visual Basic (Declaration)
Public Sub CreateFilter

Implements

IDataGridFilter..::.CreateFilter()()()

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
DataGridTextFilter..::.HitTest Method
DataGridTextFilter Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

DataGridTextFilter Class
DataGridTextFilter Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
DataGridTextFilter..::.OnApplyTemplate Method
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Properties

[image] [image]

.NET Framework Class Library
DataGridTextFilter Properties
DataGridTextFilter Class See Also

The DataGridTextFilter type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
Filter |
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
DataGridTextFilter..::.Filter Property
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription Filter { get; }
Visual Basic (Declaration)
Public ReadOnly Property Filter As FilterDescription

Implements

IDataGridFilter..::.Filter

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


DataGridTextFilter Events

[image] [image]

.NET Framework Class Library
DataGridTextFilter Events
DataGridTextFilter Class See Also

The DataGridTextFilter type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
FilterChanged |
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
DataGridTextFilter..::.FilterChanged Event
DataGridTextFilter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Public Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

Implements

IDataGridFilter..::.FilterChanged

See Also

DataGridTextFilter Class
C1.Silverlight.DataGrid Namespace


DataSourceView Class

[image]

.NET Framework Class Library
DataSourceView Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class DataSourceView : IDataSourceView,
    IEnumerable, INotifyCollectionChanged
Visual Basic (Declaration)
Public Class DataSourceView _
    Implements IDataSourceView, IEnumerable, INotifyCollectionChanged

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.DataSourceView

See Also

DataSourceView Members
C1.Silverlight.DataGrid Namespace


DataSourceView Members

[image] [image]

.NET Framework Class Library
DataSourceView Members
DataSourceView Class Constructors Methods Properties Events See Also

The DataSourceView type exposes the following members.

Constructors

Name | Description
DataSourceView |

Methods

Name | Description
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Filter |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataItem |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Group |
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveCurrentTo |
MoveCurrentToFirst |
MoveCurrentToLast |
MoveCurrentToNext |
MoveCurrentToPosition |
MoveCurrentToPrevious |
OnCollectionChanged | Overloaded.
Sort |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
CanFilter |
CanGroup |
CanSort |
Count |
Culture |
CurrentItem |
CurrentPosition |
FilterDescriptions |
GroupDescriptions |
Groups |
IsCurrentAfterLast |
IsCurrentBeforeFirst |
IsEmpty |
SortDescriptions |
SourceCollection |

Events

Name | Description
CollectionChanged |
CurrentChanged |
CurrentChanging |

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


DataSourceView Constructor

[image]

.NET Framework Class Library
DataSourceView Constructor
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataSourceView(
    IEnumerable enumerable
)
Visual Basic (Declaration)
Public Sub New ( _
    enumerable As IEnumerable _
)

Parameters

enumerable
Type: System.Collections..::.IEnumerable

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


DataSourceView Methods

[image] [image]

.NET Framework Class Library
DataSourceView Methods
DataSourceView Class See Also

The DataSourceView type exposes the following members.

Methods

Name | Description
Contains |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Filter |
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetDataItem |
GetEnumerator |
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Group |
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MoveCurrentTo |
MoveCurrentToFirst |
MoveCurrentToLast |
MoveCurrentToNext |
MoveCurrentToPosition |
MoveCurrentToPrevious |
OnCollectionChanged | Overloaded.
Sort |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Contains Method

[image]

.NET Framework Class Library
DataSourceView..::.Contains Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool Contains(
    Object item
)
Visual Basic (Declaration)
Public Function Contains ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

Implements

IDataSourceView..::.Contains(Object)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Filter Method

[image]

.NET Framework Class Library
DataSourceView..::.Filter Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Filter(
    AsyncCallback FilterComplete
)
Visual Basic (Declaration)
Public Sub Filter ( _
    FilterComplete As AsyncCallback _
)

Parameters

FilterComplete
Type: System..::.AsyncCallback

Implements

IDataSourceView..::.Filter(AsyncCallback)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


GetDataItem Method

[image]

.NET Framework Class Library
DataSourceView..::.GetDataItem Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object GetDataItem(
    int index
)
Visual Basic (Declaration)
Public Function GetDataItem ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32

Implements

IDataSourceView..::.GetDataItem(Int32)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


GetEnumerator Method

[image]

.NET Framework Class Library
DataSourceView..::.GetEnumerator Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerator GetEnumerator()
Visual Basic (Declaration)
Public Function GetEnumerator As IEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Group Method

[image]

.NET Framework Class Library
DataSourceView..::.Group Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Group(
    AsyncCallback GroupComplete
)
Visual Basic (Declaration)
Public Sub Group ( _
    GroupComplete As AsyncCallback _
)

Parameters

GroupComplete
Type: System..::.AsyncCallback

Implements

IDataSourceView..::.Group(AsyncCallback)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


IndexOf Method

[image]

.NET Framework Class Library
DataSourceView..::.IndexOf Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int IndexOf(
    Object dataItem
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    dataItem As Object _
) As Integer

Parameters

dataItem
Type: System..::.Object

Implements

IDataSourceView..::.IndexOf(Object)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentTo Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentTo Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentTo(
    Object item
)
Visual Basic (Declaration)
Public Function MoveCurrentTo ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

Implements

IDataSourceView..::.MoveCurrentTo(Object)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentToFirst Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentToFirst Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentToFirst()
Visual Basic (Declaration)
Public Function MoveCurrentToFirst As Boolean

Implements

IDataSourceView..::.MoveCurrentToFirst()()()

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentToLast Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentToLast Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentToLast()
Visual Basic (Declaration)
Public Function MoveCurrentToLast As Boolean

Implements

IDataSourceView..::.MoveCurrentToLast()()()

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentToNext Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentToNext Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentToNext()
Visual Basic (Declaration)
Public Function MoveCurrentToNext As Boolean

Implements

IDataSourceView..::.MoveCurrentToNext()()()

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentToPosition Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentToPosition Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentToPosition(
    int position
)
Visual Basic (Declaration)
Public Function MoveCurrentToPosition ( _
    position As Integer _
) As Boolean

Parameters

position
Type: System..::.Int32

Implements

IDataSourceView..::.MoveCurrentToPosition(Int32)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


MoveCurrentToPrevious Method

[image]

.NET Framework Class Library
DataSourceView..::.MoveCurrentToPrevious Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool MoveCurrentToPrevious()
Visual Basic (Declaration)
Public Function MoveCurrentToPrevious As Boolean

Implements

IDataSourceView..::.MoveCurrentToPrevious()()()

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


OnCollectionChanged Method

[image] [image]

.NET Framework Class Library
DataSourceView..::.OnCollectionChanged Method
DataSourceView Class See Also

Overload List

Name | Description
OnCollectionChanged(NotifyCollectionChangedEventArgs) |
OnCollectionChanged(Object, NotifyCollectionChangedEventArgs) |

See Also

DataSourceView Class
DataSourceView Members
C1.Silverlight.DataGrid Namespace


OnCollectionChanged Method (NotifyCollectionChangedEventArgs)

[image]

.NET Framework Class Library
DataSourceView..::.OnCollectionChanged Method (NotifyCollectionChangedEventArgs)
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs args
)
Visual Basic (Declaration)
Protected Overridable Sub OnCollectionChanged ( _
    args As NotifyCollectionChangedEventArgs _
)

Parameters

args
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs

See Also

DataSourceView Class
OnCollectionChanged Overload
C1.Silverlight.DataGrid Namespace


OnCollectionChanged Method (Object, NotifyCollectionChangedEventArgs)

[image]

.NET Framework Class Library
DataSourceView..::.OnCollectionChanged Method (Object, NotifyCollectionChangedEventArgs)
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
protected void OnCollectionChanged(
    Object sender,
    NotifyCollectionChangedEventArgs args
)
Visual Basic (Declaration)
Protected Sub OnCollectionChanged ( _
    sender As Object, _
    args As NotifyCollectionChangedEventArgs _
)

Parameters

sender
Type: System..::.Object
args
Type: System.Collections.Specialized..::.NotifyCollectionChangedEventArgs

See Also

DataSourceView Class
OnCollectionChanged Overload
C1.Silverlight.DataGrid Namespace


Sort Method

[image]

.NET Framework Class Library
DataSourceView..::.Sort Method
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Sort(
    AsyncCallback SortComplete
)
Visual Basic (Declaration)
Public Sub Sort ( _
    SortComplete As AsyncCallback _
)

Parameters

SortComplete
Type: System..::.AsyncCallback

Implements

IDataSourceView..::.Sort(AsyncCallback)

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


DataSourceView Properties

[image] [image]

.NET Framework Class Library
DataSourceView Properties
DataSourceView Class See Also

The DataSourceView type exposes the following members.

Properties

Name | Description
CanFilter |
CanGroup |
CanSort |
Count |
Culture |
CurrentItem |
CurrentPosition |
FilterDescriptions |
GroupDescriptions |
Groups |
IsCurrentAfterLast |
IsCurrentBeforeFirst |
IsEmpty |
SortDescriptions |
SourceCollection |

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CanFilter Property

[image]

.NET Framework Class Library
DataSourceView..::.CanFilter Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanFilter { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanFilter As Boolean

Implements

IDataSourceView..::.CanFilter

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CanGroup Property

[image]

.NET Framework Class Library
DataSourceView..::.CanGroup Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanGroup { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanGroup As Boolean

Implements

IDataSourceView..::.CanGroup

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CanSort Property

[image]

.NET Framework Class Library
DataSourceView..::.CanSort Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool CanSort { get; }
Visual Basic (Declaration)
Public ReadOnly Property CanSort As Boolean

Implements

IDataSourceView..::.CanSort

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Count Property

[image]

.NET Framework Class Library
DataSourceView..::.Count Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer

Implements

IDataSourceView..::.Count

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Culture Property

[image]

.NET Framework Class Library
DataSourceView..::.Culture Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public CultureInfo Culture { get; set; }
Visual Basic (Declaration)
Public Property Culture As CultureInfo

Implements

IDataSourceView..::.Culture

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CurrentItem Property

[image]

.NET Framework Class Library
DataSourceView..::.CurrentItem Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object CurrentItem { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentItem As Object

Implements

IDataSourceView..::.CurrentItem

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CurrentPosition Property

[image]

.NET Framework Class Library
DataSourceView..::.CurrentPosition Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public int CurrentPosition { get; }
Visual Basic (Declaration)
Public ReadOnly Property CurrentPosition As Integer

Implements

IDataSourceView..::.CurrentPosition

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


FilterDescriptions Property

[image]

.NET Framework Class Library
DataSourceView..::.FilterDescriptions Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<FilterDescription> FilterDescriptions { get; private set; }
Visual Basic (Declaration)
Public Property FilterDescriptions As IList(Of FilterDescription)

Implements

IDataSourceView..::.FilterDescriptions

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


GroupDescriptions Property

[image]

.NET Framework Class Library
DataSourceView..::.GroupDescriptions Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ObservableCollection<GroupDescription> GroupDescriptions { get; }
Visual Basic (Declaration)
Public ReadOnly Property GroupDescriptions As ObservableCollection(Of GroupDescription)

Implements

IDataSourceView..::.GroupDescriptions

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


Groups Property

[image]

.NET Framework Class Library
DataSourceView..::.Groups Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ReadOnlyCollection<Object> Groups { get; }
Visual Basic (Declaration)
Public ReadOnly Property Groups As ReadOnlyCollection(Of Object)

Implements

IDataSourceView..::.Groups

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


IsCurrentAfterLast Property

[image]

.NET Framework Class Library
DataSourceView..::.IsCurrentAfterLast Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsCurrentAfterLast { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurrentAfterLast As Boolean

Implements

IDataSourceView..::.IsCurrentAfterLast

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


IsCurrentBeforeFirst Property

[image]

.NET Framework Class Library
DataSourceView..::.IsCurrentBeforeFirst Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsCurrentBeforeFirst { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsCurrentBeforeFirst As Boolean

Implements

IDataSourceView..::.IsCurrentBeforeFirst

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


IsEmpty Property

[image]

.NET Framework Class Library
DataSourceView..::.IsEmpty Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public bool IsEmpty { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsEmpty As Boolean

Implements

IDataSourceView..::.IsEmpty

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


SortDescriptions Property

[image]

.NET Framework Class Library
DataSourceView..::.SortDescriptions Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IList<SortDescription> SortDescriptions { get; private set; }
Visual Basic (Declaration)
Public Property SortDescriptions As IList(Of SortDescription)

Implements

IDataSourceView..::.SortDescriptions

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


SourceCollection Property

[image]

.NET Framework Class Library
DataSourceView..::.SourceCollection Property
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public IEnumerable SourceCollection { get; }
Visual Basic (Declaration)
Public ReadOnly Property SourceCollection As IEnumerable

Implements

IDataSourceView..::.SourceCollection

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


DataSourceView Events

[image] [image]

.NET Framework Class Library
DataSourceView Events
DataSourceView Class See Also

The DataSourceView type exposes the following members.

Events

Name | Description
CollectionChanged |
CurrentChanged |
CurrentChanging |

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CollectionChanged Event

[image]

.NET Framework Class Library
DataSourceView..::.CollectionChanged Event
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event NotifyCollectionChangedEventHandler CollectionChanged
Visual Basic (Declaration)
Public Event CollectionChanged As NotifyCollectionChangedEventHandler

Implements

INotifyCollectionChanged..::.CollectionChanged

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CurrentChanged Event

[image]

.NET Framework Class Library
DataSourceView..::.CurrentChanged Event
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler CurrentChanged
Visual Basic (Declaration)
Public Event CurrentChanged As EventHandler

Implements

IDataSourceView..::.CurrentChanged

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


CurrentChanging Event

[image]

.NET Framework Class Library
DataSourceView..::.CurrentChanging Event
DataSourceView Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public event EventHandler CurrentChanging
Visual Basic (Declaration)
Public Event CurrentChanging As EventHandler

Implements

IDataSourceView..::.CurrentChanging

See Also

DataSourceView Class
C1.Silverlight.DataGrid Namespace


EditableCheckBox Class

[image]

.NET Framework Class Library
EditableCheckBox Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class EditableCheckBox : CheckBox
Visual Basic (Declaration)
Public Class EditableCheckBox _
    Inherits CheckBox

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
System.Windows.Controls..::.ContentControl
System.Windows.Controls.Primitives..::.ButtonBase
System.Windows.Controls.Primitives..::.ToggleButton
System.Windows.Controls..::.CheckBox
C1.Silverlight.DataGrid..::.EditableCheckBox

See Also

EditableCheckBox Members
C1.Silverlight.DataGrid Namespace


EditableCheckBox Members

[image] [image]

.NET Framework Class Library
EditableCheckBox Members
EditableCheckBox Class Constructors Methods Properties Events See Also

The EditableCheckBox type exposes the following members.

Constructors

Name | Description
EditableCheckBox |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsEnabledChanged | (Inherited from ToggleButton.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

EditableCheckBox Class
C1.Silverlight.DataGrid Namespace


EditableCheckBox Constructor

[image]

.NET Framework Class Library
EditableCheckBox Constructor
EditableCheckBox Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public EditableCheckBox()
Visual Basic (Declaration)
Public Sub New

See Also

EditableCheckBox Class
C1.Silverlight.DataGrid Namespace


EditableCheckBox Methods

[image] [image]

.NET Framework Class Library
EditableCheckBox Methods
EditableCheckBox Class See Also

The EditableCheckBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Inherited from ToggleButton.)
OnClick | (Inherited from ToggleButton.)
OnContentChanged | (Inherited from ToggleButton.)
OnCreateAutomationPeer | (Inherited from UIElement.)
OnGotFocus | (Inherited from ButtonBase.)
OnIsEnabledChanged | (Inherited from ToggleButton.)
OnIsPressedChanged | (Inherited from ButtonBase.)
OnKeyDown | (Inherited from ButtonBase.)
OnKeyUp | (Inherited from ButtonBase.)
OnLostFocus | (Inherited from ButtonBase.)
OnMouseEnter | (Inherited from ButtonBase.)
OnMouseLeave | (Inherited from ButtonBase.)
OnMouseLeftButtonDown | (Inherited from ButtonBase.)
OnMouseLeftButtonUp | (Inherited from ButtonBase.)
OnMouseMove | (Inherited from ButtonBase.)
OnToggle | (Inherited from ToggleButton.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | (Inherited from ToggleButton.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

EditableCheckBox Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
EditableCheckBox..::.HitTest Method
EditableCheckBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

EditableCheckBox Class
EditableCheckBox Members
C1.Silverlight.DataGrid Namespace


EditableCheckBox Properties

[image] [image]

.NET Framework Class Library
EditableCheckBox Properties
EditableCheckBox Class See Also

The EditableCheckBox type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
ClickMode | (Inherited from ButtonBase.)
Clip | (Inherited from UIElement.)
Content | (Inherited from ContentControl.)
ContentTemplate | (Inherited from ContentControl.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked | (Inherited from ToggleButton.)
IsEnabled | (Inherited from ContentControl.)
IsFocused | (Inherited from ButtonBase.)
IsHitTestVisible | (Inherited from UIElement.)
IsMouseOver | (Inherited from ButtonBase.)
IsPressed | (Inherited from ButtonBase.)
IsTabStop | (Inherited from Control.)
IsThreeState | (Inherited from ToggleButton.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
TextAlignment | (Inherited from ContentControl.)
TextDecorations | (Inherited from ContentControl.)
TextWrapping | (Inherited from ContentControl.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

EditableCheckBox Class
C1.Silverlight.DataGrid Namespace


EditableCheckBox Events

[image] [image]

.NET Framework Class Library
EditableCheckBox Events
EditableCheckBox Class See Also

The EditableCheckBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
Checked | (Inherited from ToggleButton.)
Click | (Inherited from ButtonBase.)
GotFocus | (Inherited from UIElement.)
Indeterminate | (Inherited from ToggleButton.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)
Unchecked | (Inherited from ToggleButton.)

See Also

EditableCheckBox Class
C1.Silverlight.DataGrid Namespace


Extensions Class

[image]

.NET Framework Class Library
Extensions Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static class Extensions
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class Extensions

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.Extensions

See Also

Extensions Members
C1.Silverlight.DataGrid Namespace


Extensions Members

[image] [image]

.NET Framework Class Library
Extensions Members
Extensions Class Methods See Also

The Extensions type exposes the following members.

Methods

Name | Description
AddChildren |
BinarySearch |

See Also

Extensions Class
C1.Silverlight.DataGrid Namespace


Extensions Methods

[image] [image]

.NET Framework Class Library
Extensions Methods
Extensions Class See Also

The Extensions type exposes the following members.

Methods

Name | Description
AddChildren |
BinarySearch |

See Also

Extensions Class
C1.Silverlight.DataGrid Namespace


AddChildren Method

[image]

.NET Framework Class Library
Extensions..::.AddChildren Method
Extensions Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static void AddChildren(
    this DataGridMainPanel grid,
    FrameworkElement child,
    int row,
    int column,
    int rowSpan,
    int colSpan
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Sub AddChildren ( _
    grid As DataGridMainPanel, _
    child As FrameworkElement, _
    row As Integer, _
    column As Integer, _
    rowSpan As Integer, _
    colSpan As Integer _
)

Parameters

grid
Type: C1.Silverlight.DataGrid..::.DataGridMainPanel
child
Type: System.Windows..::.FrameworkElement
row
Type: System..::.Int32
column
Type: System..::.Int32
rowSpan
Type: System..::.Int32
colSpan
Type: System..::.Int32

See Also

Extensions Class
C1.Silverlight.DataGrid Namespace


BinarySearch Method

[image]

.NET Framework Class Library
Extensions..::.BinarySearch Method
Extensions Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static int BinarySearch(
    this List<DataGridColumn> list,
    double x
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function BinarySearch ( _
    list As List(Of DataGridColumn), _
    x As Double _
) As Integer

Parameters

list
Type: System.Collections.Generic..::.List <(Of <( DataGridColumn >)>)
x
Type: System..::.Double

See Also

Extensions Class
C1.Silverlight.DataGrid Namespace


FilterDescription Class

[image]

.NET Framework Class Library
FilterDescription Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class FilterDescription
Visual Basic (Declaration)
Public Class FilterDescription

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.FilterDescription

See Also

FilterDescription Members
C1.Silverlight.DataGrid Namespace


FilterDescription Members

[image] [image]

.NET Framework Class Library
FilterDescription Members
FilterDescription Class Constructors Methods Properties See Also

The FilterDescription type exposes the following members.

Constructors

Name | Description
FilterDescription | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
PropertyFilter |
PropertyName |
Tag |

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


FilterDescription Constructor

[image] [image]

.NET Framework Class Library
FilterDescription Constructor
FilterDescription Class See Also

Overload List

Name | Description
FilterDescription()()() |
FilterDescription(String, Func<(Of <(Object, Boolean>)>)) |

See Also

FilterDescription Class
FilterDescription Members
C1.Silverlight.DataGrid Namespace


FilterDescription Constructor

[image]

.NET Framework Class Library
FilterDescription Constructor
FilterDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription()
Visual Basic (Declaration)
Public Sub New

See Also

FilterDescription Class
FilterDescription Overload
C1.Silverlight.DataGrid Namespace


FilterDescription Constructor (String, Func(Object, Boolean))

[image]

.NET Framework Class Library
FilterDescription Constructor (String, Func<(Of <(Object, Boolean>)>))
FilterDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FilterDescription(
    string propertyName,
    Func<Object, bool> propertyFilter
)
Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String, _
    propertyFilter As Func(Of Object, Boolean) _
)

Parameters

propertyName
Type: System..::.String
propertyFilter
Type: System..::.Func <(Of <( Object, Boolean >)>)

See Also

FilterDescription Class
FilterDescription Overload
C1.Silverlight.DataGrid Namespace


FilterDescription Methods

[image] [image]

.NET Framework Class Library
FilterDescription Methods
FilterDescription Class See Also

The FilterDescription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


FilterDescription Properties

[image] [image]

.NET Framework Class Library
FilterDescription Properties
FilterDescription Class See Also

The FilterDescription type exposes the following members.

Properties

Name | Description
PropertyFilter |
PropertyName |
Tag |

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


PropertyFilter Property

[image]

.NET Framework Class Library
FilterDescription..::.PropertyFilter Property
FilterDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Func<Object, bool> PropertyFilter { get; set; }
Visual Basic (Declaration)
Public Property PropertyFilter As Func(Of Object, Boolean)

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


PropertyName Property

[image]

.NET Framework Class Library
FilterDescription..::.PropertyName Property
FilterDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


Tag Property

[image]

.NET Framework Class Library
FilterDescription..::.Tag Property
FilterDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object Tag { get; set; }
Visual Basic (Declaration)
Public Property Tag As Object

See Also

FilterDescription Class
C1.Silverlight.DataGrid Namespace


FinalizeEditingException Class

[image]

.NET Framework Class Library
FinalizeEditingException Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class FinalizeEditingException : Exception
Visual Basic (Declaration)
Public Class FinalizeEditingException _
    Inherits Exception

Inheritance Hierarchy

System..::.Object
System..::.Exception
C1.Silverlight.DataGrid..::.FinalizeEditingException

See Also

FinalizeEditingException Members
C1.Silverlight.DataGrid Namespace


FinalizeEditingException Members

[image] [image]

.NET Framework Class Library
FinalizeEditingException Members
FinalizeEditingException Class Constructors Methods Properties See Also

The FinalizeEditingException type exposes the following members.

Constructors

Name | Description
FinalizeEditingException |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FinalizeEditingException Class
C1.Silverlight.DataGrid Namespace


FinalizeEditingException Constructor

[image]

.NET Framework Class Library
FinalizeEditingException Constructor
FinalizeEditingException Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public FinalizeEditingException(
    string message
)
Visual Basic (Declaration)
Public Sub New ( _
    message As String _
)

Parameters

message
Type: System..::.String

See Also

FinalizeEditingException Class
C1.Silverlight.DataGrid Namespace


FinalizeEditingException Methods

[image] [image]

.NET Framework Class Library
FinalizeEditingException Methods
FinalizeEditingException Class See Also

The FinalizeEditingException type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)

See Also

FinalizeEditingException Class
C1.Silverlight.DataGrid Namespace


FinalizeEditingException Properties

[image] [image]

.NET Framework Class Library
FinalizeEditingException Properties
FinalizeEditingException Class See Also

The FinalizeEditingException type exposes the following members.

Properties

Name | Description
Data | Gets a collection of key/value pairs that provide additional, user-defined information about the exception. (Inherited from Exception.)
HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Message | Gets a message that describes the current exception. (Inherited from Exception.)
Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)

See Also

FinalizeEditingException Class
C1.Silverlight.DataGrid Namespace


GridLengthConverter Class

[image]

.NET Framework Class Library
GridLengthConverter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class GridLengthConverter : TypeConverter
Visual Basic (Declaration)
Public Class GridLengthConverter _
    Inherits TypeConverter

Inheritance Hierarchy

System..::.Object
System.ComponentModel..::.TypeConverter
C1.Silverlight.DataGrid..::.GridLengthConverter

See Also

GridLengthConverter Members
C1.Silverlight.DataGrid Namespace


GridLengthConverter Members

[image] [image]

.NET Framework Class Library
GridLengthConverter Members
GridLengthConverter Class Constructors Methods See Also

The GridLengthConverter type exposes the following members.

Constructors

Name | Description
GridLengthConverter |

Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertTo | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
ConvertFrom | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertTo | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridLengthConverter Class
C1.Silverlight.DataGrid Namespace


GridLengthConverter Constructor

[image]

.NET Framework Class Library
GridLengthConverter Constructor
GridLengthConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GridLengthConverter()
Visual Basic (Declaration)
Public Sub New

See Also

GridLengthConverter Class
C1.Silverlight.DataGrid Namespace


GridLengthConverter Methods

[image] [image]

.NET Framework Class Library
GridLengthConverter Methods
GridLengthConverter Class See Also

The GridLengthConverter type exposes the following members.

Methods

Name | Description
CanConvertFrom | Returns whether this converter can convert an object of the given type to the type of this converter. (Inherited from TypeConverter.)
CanConvertTo | Returns whether this converter can convert the object to the specified type. (Inherited from TypeConverter.)
ConvertFrom | Converts the given value to the type of this converter. (Inherited from TypeConverter.)
ConvertFromString | Converts the specified text to an object. (Inherited from TypeConverter.)
ConvertTo | Converts the given value object to the specified type, using the arguments. (Inherited from TypeConverter.)
ConvertToString | Converts the specified value to a string representation. (Inherited from TypeConverter.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GridLengthConverter Class
C1.Silverlight.DataGrid Namespace


GroupDescription Class

[image]

.NET Framework Class Library
GroupDescription Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class GroupDescription
Visual Basic (Declaration)
Public Class GroupDescription

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.GroupDescription

See Also

GroupDescription Members
C1.Silverlight.DataGrid Namespace


GroupDescription Members

[image] [image]

.NET Framework Class Library
GroupDescription Members
GroupDescription Class Constructors Methods See Also

The GroupDescription type exposes the following members.

Constructors

Name | Description
GroupDescription |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupDescription Class
C1.Silverlight.DataGrid Namespace


GroupDescription Constructor

[image]

.NET Framework Class Library
GroupDescription Constructor
GroupDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public GroupDescription()
Visual Basic (Declaration)
Public Sub New

See Also

GroupDescription Class
C1.Silverlight.DataGrid Namespace


GroupDescription Methods

[image] [image]

.NET Framework Class Library
GroupDescription Methods
GroupDescription Class See Also

The GroupDescription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

GroupDescription Class
C1.Silverlight.DataGrid Namespace


IDataGridFilter Interface

[image]

.NET Framework Class Library
IDataGridFilter Interface
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public interface IDataGridFilter
Visual Basic (Declaration)
Public Interface IDataGridFilter

See Also

IDataGridFilter Members
C1.Silverlight.DataGrid Namespace


IDataGridFilter Members

[image] [image]

.NET Framework Class Library
IDataGridFilter Members
IDataGridFilter Interface Methods Properties Events See Also

The IDataGridFilter type exposes the following members.

Methods

Name | Description
ClearFilter |
CreateFilter |

Properties

Name | Description
Filter |

Events

Name | Description
FilterChanged |

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


IDataGridFilter Methods

[image] [image]

.NET Framework Class Library
IDataGridFilter Methods
IDataGridFilter Interface See Also

The IDataGridFilter type exposes the following members.

Methods

Name | Description
ClearFilter |
CreateFilter |

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


ClearFilter Method

[image]

.NET Framework Class Library
IDataGridFilter..::.ClearFilter Method
IDataGridFilter Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void ClearFilter()
Visual Basic (Declaration)
Sub ClearFilter

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


CreateFilter Method

[image]

.NET Framework Class Library
IDataGridFilter..::.CreateFilter Method
IDataGridFilter Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void CreateFilter()
Visual Basic (Declaration)
Sub CreateFilter

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


IDataGridFilter Properties

[image] [image]

.NET Framework Class Library
IDataGridFilter Properties
IDataGridFilter Interface See Also

The IDataGridFilter type exposes the following members.

Properties

Name | Description
Filter |

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


Filter Property

[image]

.NET Framework Class Library
IDataGridFilter..::.Filter Property
IDataGridFilter Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
FilterDescription Filter { get; }
Visual Basic (Declaration)
ReadOnly Property Filter As FilterDescription

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


IDataGridFilter Events

[image] [image]

.NET Framework Class Library
IDataGridFilter Events
IDataGridFilter Interface See Also

The IDataGridFilter type exposes the following members.

Events

Name | Description
FilterChanged |

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


FilterChanged Event

[image]

.NET Framework Class Library
IDataGridFilter..::.FilterChanged Event
IDataGridFilter Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
event EventHandler<PropertyChangedEventArgs<FilterDescription>> FilterChanged
Visual Basic (Declaration)
Event FilterChanged As EventHandler(Of PropertyChangedEventArgs(Of FilterDescription))

See Also

IDataGridFilter Interface
C1.Silverlight.DataGrid Namespace


IDataSourceView Interface

[image]

.NET Framework Class Library
IDataSourceView Interface
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public interface IDataSourceView : IEnumerable,
    INotifyCollectionChanged
Visual Basic (Declaration)
Public Interface IDataSourceView _
    Implements IEnumerable, INotifyCollectionChanged

See Also

IDataSourceView Members
C1.Silverlight.DataGrid Namespace


IDataSourceView Members

[image] [image]

.NET Framework Class Library
IDataSourceView Members
IDataSourceView Interface Methods Properties Events See Also

The IDataSourceView type exposes the following members.

Methods

Name | Description
Contains |
Filter |
GetDataItem |
GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Group |
IndexOf |
MoveCurrentTo |
MoveCurrentToFirst |
MoveCurrentToLast |
MoveCurrentToNext |
MoveCurrentToPosition |
MoveCurrentToPrevious |
Sort |

Properties

Name | Description
CanFilter |
CanGroup |
CanSort |
Count |
Culture |
CurrentItem |
CurrentPosition |
FilterDescriptions |
GroupDescriptions |
Groups |
IsCurrentAfterLast |
IsCurrentBeforeFirst |
IsEmpty |
SortDescriptions |
SourceCollection |

Events

Name | Description
CollectionChanged | (Inherited from INotifyCollectionChanged.)
CurrentChanged |
CurrentChanging |

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IDataSourceView Methods

[image] [image]

.NET Framework Class Library
IDataSourceView Methods
IDataSourceView Interface See Also

The IDataSourceView type exposes the following members.

Methods

Name | Description
Contains |
Filter |
GetDataItem |
GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Group |
IndexOf |
MoveCurrentTo |
MoveCurrentToFirst |
MoveCurrentToLast |
MoveCurrentToNext |
MoveCurrentToPosition |
MoveCurrentToPrevious |
Sort |

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Contains Method

[image]

.NET Framework Class Library
IDataSourceView..::.Contains Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool Contains(
    Object item
)
Visual Basic (Declaration)
Function Contains ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Filter Method

[image]

.NET Framework Class Library
IDataSourceView..::.Filter Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void Filter(
    AsyncCallback FilterComplete
)
Visual Basic (Declaration)
Sub Filter ( _
    FilterComplete As AsyncCallback _
)

Parameters

FilterComplete
Type: System..::.AsyncCallback

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


GetDataItem Method

[image]

.NET Framework Class Library
IDataSourceView..::.GetDataItem Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
Object GetDataItem(
    int index
)
Visual Basic (Declaration)
Function GetDataItem ( _
    index As Integer _
) As Object

Parameters

index
Type: System..::.Int32

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Group Method

[image]

.NET Framework Class Library
IDataSourceView..::.Group Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void Group(
    AsyncCallback GroupComplete
)
Visual Basic (Declaration)
Sub Group ( _
    GroupComplete As AsyncCallback _
)

Parameters

GroupComplete
Type: System..::.AsyncCallback

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IndexOf Method

[image]

.NET Framework Class Library
IDataSourceView..::.IndexOf Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
int IndexOf(
    Object dataItem
)
Visual Basic (Declaration)
Function IndexOf ( _
    dataItem As Object _
) As Integer

Parameters

dataItem
Type: System..::.Object

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentTo Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentTo Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentTo(
    Object item
)
Visual Basic (Declaration)
Function MoveCurrentTo ( _
    item As Object _
) As Boolean

Parameters

item
Type: System..::.Object

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentToFirst Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentToFirst Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentToFirst()
Visual Basic (Declaration)
Function MoveCurrentToFirst As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentToLast Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentToLast Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentToLast()
Visual Basic (Declaration)
Function MoveCurrentToLast As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentToNext Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentToNext Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentToNext()
Visual Basic (Declaration)
Function MoveCurrentToNext As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentToPosition Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentToPosition Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentToPosition(
    int position
)
Visual Basic (Declaration)
Function MoveCurrentToPosition ( _
    position As Integer _
) As Boolean

Parameters

position
Type: System..::.Int32

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


MoveCurrentToPrevious Method

[image]

.NET Framework Class Library
IDataSourceView..::.MoveCurrentToPrevious Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool MoveCurrentToPrevious()
Visual Basic (Declaration)
Function MoveCurrentToPrevious As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Sort Method

[image]

.NET Framework Class Library
IDataSourceView..::.Sort Method
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void Sort(
    AsyncCallback SortComplete
)
Visual Basic (Declaration)
Sub Sort ( _
    SortComplete As AsyncCallback _
)

Parameters

SortComplete
Type: System..::.AsyncCallback

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IDataSourceView Properties

[image] [image]

.NET Framework Class Library
IDataSourceView Properties
IDataSourceView Interface See Also

The IDataSourceView type exposes the following members.

Properties

Name | Description
CanFilter |
CanGroup |
CanSort |
Count |
Culture |
CurrentItem |
CurrentPosition |
FilterDescriptions |
GroupDescriptions |
Groups |
IsCurrentAfterLast |
IsCurrentBeforeFirst |
IsEmpty |
SortDescriptions |
SourceCollection |

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CanFilter Property

[image]

.NET Framework Class Library
IDataSourceView..::.CanFilter Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool CanFilter { get; }
Visual Basic (Declaration)
ReadOnly Property CanFilter As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CanGroup Property

[image]

.NET Framework Class Library
IDataSourceView..::.CanGroup Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool CanGroup { get; }
Visual Basic (Declaration)
ReadOnly Property CanGroup As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CanSort Property

[image]

.NET Framework Class Library
IDataSourceView..::.CanSort Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool CanSort { get; }
Visual Basic (Declaration)
ReadOnly Property CanSort As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Count Property

[image]

.NET Framework Class Library
IDataSourceView..::.Count Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
int Count { get; }
Visual Basic (Declaration)
ReadOnly Property Count As Integer

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Culture Property

[image]

.NET Framework Class Library
IDataSourceView..::.Culture Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
CultureInfo Culture { get; set; }
Visual Basic (Declaration)
Property Culture As CultureInfo

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CurrentItem Property

[image]

.NET Framework Class Library
IDataSourceView..::.CurrentItem Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
Object CurrentItem { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentItem As Object

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CurrentPosition Property

[image]

.NET Framework Class Library
IDataSourceView..::.CurrentPosition Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
int CurrentPosition { get; }
Visual Basic (Declaration)
ReadOnly Property CurrentPosition As Integer

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


FilterDescriptions Property

[image]

.NET Framework Class Library
IDataSourceView..::.FilterDescriptions Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
IList<FilterDescription> FilterDescriptions { get; }
Visual Basic (Declaration)
ReadOnly Property FilterDescriptions As IList(Of FilterDescription)

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


GroupDescriptions Property

[image]

.NET Framework Class Library
IDataSourceView..::.GroupDescriptions Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
ObservableCollection<GroupDescription> GroupDescriptions { get; }
Visual Basic (Declaration)
ReadOnly Property GroupDescriptions As ObservableCollection(Of GroupDescription)

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


Groups Property

[image]

.NET Framework Class Library
IDataSourceView..::.Groups Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
ReadOnlyCollection<Object> Groups { get; }
Visual Basic (Declaration)
ReadOnly Property Groups As ReadOnlyCollection(Of Object)

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IsCurrentAfterLast Property

[image]

.NET Framework Class Library
IDataSourceView..::.IsCurrentAfterLast Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool IsCurrentAfterLast { get; }
Visual Basic (Declaration)
ReadOnly Property IsCurrentAfterLast As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IsCurrentBeforeFirst Property

[image]

.NET Framework Class Library
IDataSourceView..::.IsCurrentBeforeFirst Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool IsCurrentBeforeFirst { get; }
Visual Basic (Declaration)
ReadOnly Property IsCurrentBeforeFirst As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IsEmpty Property

[image]

.NET Framework Class Library
IDataSourceView..::.IsEmpty Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
bool IsEmpty { get; }
Visual Basic (Declaration)
ReadOnly Property IsEmpty As Boolean

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


SortDescriptions Property

[image]

.NET Framework Class Library
IDataSourceView..::.SortDescriptions Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
IList<SortDescription> SortDescriptions { get; }
Visual Basic (Declaration)
ReadOnly Property SortDescriptions As IList(Of SortDescription)

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


SourceCollection Property

[image]

.NET Framework Class Library
IDataSourceView..::.SourceCollection Property
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
IEnumerable SourceCollection { get; }
Visual Basic (Declaration)
ReadOnly Property SourceCollection As IEnumerable

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IDataSourceView Events

[image] [image]

.NET Framework Class Library
IDataSourceView Events
IDataSourceView Interface See Also

The IDataSourceView type exposes the following members.

Events

Name | Description
CollectionChanged | (Inherited from INotifyCollectionChanged.)
CurrentChanged |
CurrentChanging |

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CurrentChanged Event

[image]

.NET Framework Class Library
IDataSourceView..::.CurrentChanged Event
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
event EventHandler CurrentChanged
Visual Basic (Declaration)
Event CurrentChanged As EventHandler

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


CurrentChanging Event

[image]

.NET Framework Class Library
IDataSourceView..::.CurrentChanging Event
IDataSourceView Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
event EventHandler CurrentChanging
Visual Basic (Declaration)
Event CurrentChanging As EventHandler

See Also

IDataSourceView Interface
C1.Silverlight.DataGrid Namespace


IEditableObject Interface

[image]

.NET Framework Class Library
IEditableObject Interface
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public interface IEditableObject
Visual Basic (Declaration)
Public Interface IEditableObject

See Also

IEditableObject Members
C1.Silverlight.DataGrid Namespace


IEditableObject Members

[image] [image]

.NET Framework Class Library
IEditableObject Members
IEditableObject Interface Methods See Also

The IEditableObject type exposes the following members.

Methods

Name | Description
BeginEdit |
CancelEdit |
EndEdit |

See Also

IEditableObject Interface
C1.Silverlight.DataGrid Namespace


IEditableObject Methods

[image] [image]

.NET Framework Class Library
IEditableObject Methods
IEditableObject Interface See Also

The IEditableObject type exposes the following members.

Methods

Name | Description
BeginEdit |
CancelEdit |
EndEdit |

See Also

IEditableObject Interface
C1.Silverlight.DataGrid Namespace


BeginEdit Method

[image]

.NET Framework Class Library
IEditableObject..::.BeginEdit Method
IEditableObject Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void BeginEdit()
Visual Basic (Declaration)
Sub BeginEdit

See Also

IEditableObject Interface
C1.Silverlight.DataGrid Namespace


CancelEdit Method

[image]

.NET Framework Class Library
IEditableObject..::.CancelEdit Method
IEditableObject Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void CancelEdit()
Visual Basic (Declaration)
Sub CancelEdit

See Also

IEditableObject Interface
C1.Silverlight.DataGrid Namespace


EndEdit Method

[image]

.NET Framework Class Library
IEditableObject..::.EndEdit Method
IEditableObject Interface See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
void EndEdit()
Visual Basic (Declaration)
Sub EndEdit

See Also

IEditableObject Interface
C1.Silverlight.DataGrid Namespace


LoadingFilterEventHandler Delegate

[image]

.NET Framework Class Library
LoadingFilterEventHandler Delegate
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public delegate IDataGridFilter LoadingFilterEventHandler(
    Object sender,
    EventArgs e
)
Visual Basic (Declaration)
Public Delegate Function LoadingFilterEventHandler ( _
    sender As Object, _
    e As EventArgs _
) As IDataGridFilter

Parameters

sender
Type: System..::.Object
e
Type: System..::.EventArgs

See Also

C1.Silverlight.DataGrid Namespace


MergeStrategy Enumeration

[image]

.NET Framework Class Library
MergeStrategy Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum MergeStrategy
Visual Basic (Declaration)
Public Enumeration MergeStrategy

Members

Member name | Description
Default |

See Also

C1.Silverlight.DataGrid Namespace


NumericComparator Class

[image]

.NET Framework Class Library
NumericComparator Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class NumericComparator
Visual Basic (Declaration)
Public Class NumericComparator

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.NumericComparator

See Also

NumericComparator Members
C1.Silverlight.DataGrid Namespace


NumericComparator Members

[image] [image]

.NET Framework Class Library
NumericComparator Members
NumericComparator Class Methods Properties See Also

The NumericComparator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Comparison |
ComparisonSymbol |

See Also

NumericComparator Class
C1.Silverlight.DataGrid Namespace


NumericComparator Methods

[image] [image]

.NET Framework Class Library
NumericComparator Methods
NumericComparator Class See Also

The NumericComparator type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericComparator Class
C1.Silverlight.DataGrid Namespace


NumericComparator Properties

[image] [image]

.NET Framework Class Library
NumericComparator Properties
NumericComparator Class See Also

The NumericComparator type exposes the following members.

Properties

Name | Description
Comparison |
ComparisonSymbol |

See Also

NumericComparator Class
C1.Silverlight.DataGrid Namespace


Comparison Property

[image]

.NET Framework Class Library
NumericComparator..::.Comparison Property
NumericComparator Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public NumericComparison Comparison { get; set; }
Visual Basic (Declaration)
Public Property Comparison As NumericComparison

See Also

NumericComparator Class
C1.Silverlight.DataGrid Namespace


ComparisonSymbol Property

[image]

.NET Framework Class Library
NumericComparator..::.ComparisonSymbol Property
NumericComparator Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string ComparisonSymbol { get; set; }
Visual Basic (Declaration)
Public Property ComparisonSymbol As String

See Also

NumericComparator Class
C1.Silverlight.DataGrid Namespace


NumericComparison Enumeration

[image]

.NET Framework Class Library
NumericComparison Enumeration
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public enum NumericComparison
Visual Basic (Declaration)
Public Enumeration NumericComparison

Members

Member name | Description
equal |
notEqual |
lessThan |
greaterThan |
lessThanEqual |
greaterThanEqual |

See Also

C1.Silverlight.DataGrid Namespace


NumericConverter Class

[image]

.NET Framework Class Library
NumericConverter Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class NumericConverter : IValueConverter
Visual Basic (Declaration)
Public Class NumericConverter _
    Implements IValueConverter

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.NumericConverter

See Also

NumericConverter Members
C1.Silverlight.DataGrid Namespace


NumericConverter Members

[image] [image]

.NET Framework Class Library
NumericConverter Members
NumericConverter Class Constructors Methods See Also

The NumericConverter type exposes the following members.

Constructors

Name | Description
NumericConverter |

Methods

Name | Description
Convert |
ConvertBack |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericConverter Class
C1.Silverlight.DataGrid Namespace


NumericConverter Constructor

[image]

.NET Framework Class Library
NumericConverter Constructor
NumericConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public NumericConverter()
Visual Basic (Declaration)
Public Sub New

See Also

NumericConverter Class
C1.Silverlight.DataGrid Namespace


NumericConverter Methods

[image] [image]

.NET Framework Class Library
NumericConverter Methods
NumericConverter Class See Also

The NumericConverter type exposes the following members.

Methods

Name | Description
Convert |
ConvertBack |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

NumericConverter Class
C1.Silverlight.DataGrid Namespace


Convert Method

[image]

.NET Framework Class Library
NumericConverter..::.Convert Method
NumericConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object Convert(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function Convert ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.Convert(Object, Type, Object, CultureInfo)

See Also

NumericConverter Class
C1.Silverlight.DataGrid Namespace


ConvertBack Method

[image]

.NET Framework Class Library
NumericConverter..::.ConvertBack Method
NumericConverter Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public Object ConvertBack(
    Object value,
    Type targetType,
    Object parameter,
    CultureInfo culture
)
Visual Basic (Declaration)
Public Function ConvertBack ( _
    value As Object, _
    targetType As Type, _
    parameter As Object, _
    culture As CultureInfo _
) As Object

Parameters

value
Type: System..::.Object
targetType
Type: System..::.Type
parameter
Type: System..::.Object
culture
Type: System.Globalization..::.CultureInfo

Implements

IValueConverter..::.ConvertBack(Object, Type, Object, CultureInfo)

See Also

NumericConverter Class
C1.Silverlight.DataGrid Namespace


PerformanceClock Class

[image]

.NET Framework Class Library
PerformanceClock Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class PerformanceClock
Visual Basic (Declaration)
Public Class PerformanceClock

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.PerformanceClock

See Also

PerformanceClock Members
C1.Silverlight.DataGrid Namespace


PerformanceClock Members

[image] [image]

.NET Framework Class Library
PerformanceClock Members
PerformanceClock Class Constructors Methods See Also

The PerformanceClock type exposes the following members.

Constructors

Name | Description
PerformanceClock |

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Print |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformanceClock Class
C1.Silverlight.DataGrid Namespace


PerformanceClock Constructor

[image]

.NET Framework Class Library
PerformanceClock Constructor
PerformanceClock Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public PerformanceClock()
Visual Basic (Declaration)
Public Sub New

See Also

PerformanceClock Class
C1.Silverlight.DataGrid Namespace


PerformanceClock Methods

[image] [image]

.NET Framework Class Library
PerformanceClock Methods
PerformanceClock Class See Also

The PerformanceClock type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Print |
Reset |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

PerformanceClock Class
C1.Silverlight.DataGrid Namespace


Print Method

[image]

.NET Framework Class Library
PerformanceClock..::.Print Method
PerformanceClock Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Print(
    string action,
    bool reset
)
Visual Basic (Declaration)
Public Sub Print ( _
    action As String, _
    reset As Boolean _
)

Parameters

action
Type: System..::.String
reset
Type: System..::.Boolean

See Also

PerformanceClock Class
C1.Silverlight.DataGrid Namespace


Reset Method

[image]

.NET Framework Class Library
PerformanceClock..::.Reset Method
PerformanceClock Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public void Reset()
Visual Basic (Declaration)
Public Sub Reset

See Also

PerformanceClock Class
C1.Silverlight.DataGrid Namespace


PreparingCellEditEventHandler Delegate

[image]

.NET Framework Class Library
PreparingCellEditEventHandler Delegate
See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public delegate Object PreparingCellEditEventHandler(
    FrameworkElement editingElement,
    RoutedEventArgs editingEventArgs
)
Visual Basic (Declaration)
Public Delegate Function PreparingCellEditEventHandler ( _
    editingElement As FrameworkElement, _
    editingEventArgs As RoutedEventArgs _
) As Object

Parameters

editingElement
Type: System.Windows..::.FrameworkElement
editingEventArgs
Type: System.Windows..::.RoutedEventArgs

See Also

C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Class

[image]

.NET Framework Class Library
ReadOnlyCheckBox Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class ReadOnlyCheckBox : Control
Visual Basic (Declaration)
Public Class ReadOnlyCheckBox _
    Inherits Control

Inheritance Hierarchy

System..::.Object
System.Windows..::.DependencyObject
System.Windows..::.UIElement
System.Windows..::.FrameworkElement
System.Windows.Controls..::.Control
C1.Silverlight.DataGrid..::.ReadOnlyCheckBox

See Also

ReadOnlyCheckBox Members
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Members

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox Members
ReadOnlyCheckBox Class Constructors Methods Fields Properties Events See Also

The ReadOnlyCheckBox type exposes the following members.

Constructors

Name | Description
ReadOnlyCheckBox |

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

Fields

Name | Description
IsCheckedProperty |

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Constructor

[image]

.NET Framework Class Library
ReadOnlyCheckBox Constructor
ReadOnlyCheckBox Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public ReadOnlyCheckBox()
Visual Basic (Declaration)
Public Sub New

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Fields

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox Fields
ReadOnlyCheckBox Class See Also

The ReadOnlyCheckBox type exposes the following members.

Fields

Name | Description
IsCheckedProperty |

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


IsCheckedProperty Field

[image]

.NET Framework Class Library
ReadOnlyCheckBox..::.IsCheckedProperty Field
ReadOnlyCheckBox Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static readonly DependencyProperty IsCheckedProperty
Visual Basic (Declaration)
Public Shared ReadOnly IsCheckedProperty As DependencyProperty

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Methods

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox Methods
ReadOnlyCheckBox Class See Also

The ReadOnlyCheckBox type exposes the following members.

Methods

Name | Description
ApplyTemplate | (Inherited from Control.)
Arrange | (Inherited from UIElement.)
ArrangeOverride | (Inherited from FrameworkElement.)
CaptureMouse | (Inherited from UIElement.)
CheckAccess | (Inherited from DependencyObject.)
ClearValue | (Inherited from DependencyObject.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindName | (Inherited from FrameworkElement.)
Focus | (Inherited from Control.)
GetAnimationBaseValue | (Inherited from DependencyObject.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetTemplateChild | (Inherited from Control.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetValue | (Inherited from FrameworkElement.)
HitTest | Overloaded.
InvalidateArrange | (Inherited from UIElement.)
InvalidateMeasure | (Inherited from UIElement.)
Measure | (Inherited from UIElement.)
MeasureOverride | (Inherited from FrameworkElement.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
OnApplyTemplate | (Overrides ControlOnApplyTemplate()()().)
OnCreateAutomationPeer | (Inherited from UIElement.)
ReadLocalValue | (Inherited from DependencyObject.)
ReleaseMouseCapture | (Inherited from UIElement.)
SetBinding | (Inherited from FrameworkElement.)
SetValue | (Inherited from DependencyObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TransformToVisual | (Inherited from UIElement.)
UpdateLayout | (Inherited from UIElement.)

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


HitTest Method

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox..::.HitTest Method
ReadOnlyCheckBox Class See Also

Overload List

Name | Description
HitTest(Point) | (Inherited from UIElement.)
HitTest(Rect) | (Inherited from UIElement.)

See Also

ReadOnlyCheckBox Class
ReadOnlyCheckBox Members
C1.Silverlight.DataGrid Namespace


OnApplyTemplate Method

[image]

.NET Framework Class Library
ReadOnlyCheckBox..::.OnApplyTemplate Method
ReadOnlyCheckBox Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public override void OnApplyTemplate()
Visual Basic (Declaration)
Public Overrides Sub OnApplyTemplate

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Properties

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox Properties
ReadOnlyCheckBox Class See Also

The ReadOnlyCheckBox type exposes the following members.

Properties

Name | Description
ActualHeight | (Inherited from FrameworkElement.)
ActualWidth | (Inherited from FrameworkElement.)
Background | (Inherited from Control.)
BorderBrush | (Inherited from Control.)
BorderThickness | (Inherited from Control.)
Clip | (Inherited from UIElement.)
Cursor | (Inherited from FrameworkElement.)
DataContext | (Inherited from FrameworkElement.)
DefaultStyleKey | (Inherited from Control.)
DesiredSize | (Inherited from UIElement.)
Dispatcher | (Inherited from DependencyObject.)
FontFamily | (Inherited from Control.)
FontSize | (Inherited from Control.)
FontStretch | (Inherited from Control.)
FontStyle | (Inherited from Control.)
FontWeight | (Inherited from Control.)
Foreground | (Inherited from Control.)
Height | (Inherited from FrameworkElement.)
HorizontalAlignment | (Inherited from FrameworkElement.)
HorizontalContentAlignment | (Inherited from Control.)
IsChecked |
IsHitTestVisible | (Inherited from UIElement.)
IsTabStop | (Inherited from Control.)
Language | (Inherited from FrameworkElement.)
Margin | (Inherited from FrameworkElement.)
MaxHeight | (Inherited from FrameworkElement.)
MaxWidth | (Inherited from FrameworkElement.)
MinHeight | (Inherited from FrameworkElement.)
MinWidth | (Inherited from FrameworkElement.)
Name | (Inherited from FrameworkElement.)
Opacity | (Inherited from UIElement.)
OpacityMask | (Inherited from UIElement.)
Padding | (Inherited from Control.)
Parent | (Inherited from FrameworkElement.)
RenderSize | (Inherited from UIElement.)
RenderTransform | (Inherited from UIElement.)
RenderTransformOrigin | (Inherited from UIElement.)
Resources | (Inherited from FrameworkElement.)
Style | (Inherited from FrameworkElement.)
TabIndex | (Inherited from Control.)
TabNavigation | (Inherited from Control.)
Tag | (Inherited from FrameworkElement.)
Template | (Inherited from Control.)
Triggers | (Inherited from FrameworkElement.)
VerticalAlignment | (Inherited from FrameworkElement.)
VerticalContentAlignment | (Inherited from Control.)
Visibility | (Inherited from UIElement.)
Width | (Inherited from FrameworkElement.)

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


IsChecked Property

[image]

.NET Framework Class Library
ReadOnlyCheckBox..::.IsChecked Property
ReadOnlyCheckBox Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
[TypeConverterAttribute(typeof(NullableBoolConverter))]
public Nullable<bool> IsChecked { get; set; }
Visual Basic (Declaration)
<TypeConverterAttribute(GetType(NullableBoolConverter))> _
Public Property IsChecked As Nullable(Of Boolean)

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


ReadOnlyCheckBox Events

[image] [image]

.NET Framework Class Library
ReadOnlyCheckBox Events
ReadOnlyCheckBox Class See Also

The ReadOnlyCheckBox type exposes the following members.

Events

Name | Description
BindingValidationError | (Inherited from FrameworkElement.)
GotFocus | (Inherited from UIElement.)
KeyDown | (Inherited from UIElement.)
KeyUp | (Inherited from UIElement.)
LayoutUpdated | (Inherited from FrameworkElement.)
Loaded | (Inherited from FrameworkElement.)
LostFocus | (Inherited from UIElement.)
MouseEnter | (Inherited from UIElement.)
MouseLeave | (Inherited from UIElement.)
MouseLeftButtonDown | (Inherited from UIElement.)
MouseLeftButtonUp | (Inherited from UIElement.)
MouseMove | (Inherited from UIElement.)
SizeChanged | (Inherited from FrameworkElement.)

See Also

ReadOnlyCheckBox Class
C1.Silverlight.DataGrid Namespace


SortDescription Class

[image]

.NET Framework Class Library
SortDescription Class
Members See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public class SortDescription
Visual Basic (Declaration)
Public Class SortDescription

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid..::.SortDescription

See Also

SortDescription Members
C1.Silverlight.DataGrid Namespace


SortDescription Members

[image] [image]

.NET Framework Class Library
SortDescription Members
SortDescription Class Constructors Methods Properties See Also

The SortDescription type exposes the following members.

Constructors

Name | Description
SortDescription | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Direction |
PropertyName |

See Also

SortDescription Class
C1.Silverlight.DataGrid Namespace


SortDescription Constructor

[image] [image]

.NET Framework Class Library
SortDescription Constructor
SortDescription Class See Also

Overload List

Name | Description
SortDescription()()() |
SortDescription(String, DataGridSortingState) |

See Also

SortDescription Class
SortDescription Members
C1.Silverlight.DataGrid Namespace


SortDescription Constructor

[image]

.NET Framework Class Library
SortDescription Constructor
SortDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public SortDescription()
Visual Basic (Declaration)
Public Sub New

See Also

SortDescription Class
SortDescription Overload
C1.Silverlight.DataGrid Namespace


SortDescription Constructor (String, DataGridSortingState)

[image]

.NET Framework Class Library
SortDescription Constructor (String, DataGridSortingState)
SortDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public SortDescription(
    string propertyName,
    DataGridSortingState direction
)
Visual Basic (Declaration)
Public Sub New ( _
    propertyName As String, _
    direction As DataGridSortingState _
)

Parameters

propertyName
Type: System..::.String
direction
Type: C1.Silverlight.DataGrid..::.DataGridSortingState

See Also

SortDescription Class
SortDescription Overload
C1.Silverlight.DataGrid Namespace


SortDescription Methods

[image] [image]

.NET Framework Class Library
SortDescription Methods
SortDescription Class See Also

The SortDescription type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. GetHashCode()()() is suitable for use in hashing algorithms and data structures like a hash table. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

SortDescription Class
C1.Silverlight.DataGrid Namespace


SortDescription Properties

[image] [image]

.NET Framework Class Library
SortDescription Properties
SortDescription Class See Also

The SortDescription type exposes the following members.

Properties

Name | Description
Direction |
PropertyName |

See Also

SortDescription Class
C1.Silverlight.DataGrid Namespace


Direction Property

[image]

.NET Framework Class Library
SortDescription..::.Direction Property
SortDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public DataGridSortingState Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As DataGridSortingState

See Also

SortDescription Class
C1.Silverlight.DataGrid Namespace


PropertyName Property

[image]

.NET Framework Class Library
SortDescription..::.PropertyName Property
SortDescription Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public string PropertyName { get; set; }
Visual Basic (Declaration)
Public Property PropertyName As String

See Also

SortDescription Class
C1.Silverlight.DataGrid Namespace


C1.Silverlight.DataGrid.Primitives Namespace

[image]

.NET Framework Class Library
C1.Silverlight.DataGrid.Primitives Namespace

Classes

Class | Description
PredicateBuilder |


PredicateBuilder Class

[image]

.NET Framework Class Library
PredicateBuilder Class
Members See Also

Namespace: C1.Silverlight.DataGrid.Primitives
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static class PredicateBuilder
Visual Basic (Declaration)
<ExtensionAttribute> _
Public NotInheritable Class PredicateBuilder

Inheritance Hierarchy

System..::.Object
C1.Silverlight.DataGrid.Primitives..::.PredicateBuilder

See Also

PredicateBuilder Members
C1.Silverlight.DataGrid.Primitives Namespace


PredicateBuilder Members

[image] [image]

.NET Framework Class Library
PredicateBuilder Members
PredicateBuilder Class Methods See Also

The PredicateBuilder type exposes the following members.

Methods

Name | Description
And<(Of <(T>)>) |
False<(Of <(T>)>) |
Or<(Of <(T>)>) |
True<(Of <(T>)>) |

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


PredicateBuilder Methods

[image] [image]

.NET Framework Class Library
PredicateBuilder Methods
PredicateBuilder Class See Also

The PredicateBuilder type exposes the following members.

Methods

Name | Description
And<(Of <(T>)>) |
False<(Of <(T>)>) |
Or<(Of <(T>)>) |
True<(Of <(T>)>) |

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


And(T) Method

[image]

.NET Framework Class Library
PredicateBuilder..::.And<(Of <(T>)>) Method
PredicateBuilder Class See Also

Namespace: C1.Silverlight.DataGrid.Primitives
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static Expression<Func<T, bool>> And<T>(
    this Expression<Func<T, bool>> expr1,
    Expression<Func<T, bool>> expr2
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function And(Of T) ( _
    expr1 As Expression(Of Func(Of T, Boolean)), _
    expr2 As Expression(Of Func(Of T, Boolean)) _
) As Expression(Of Func(Of T, Boolean))

Parameters

expr1
Type: System.Linq.Expressions..::.Expression <(Of <( Func <(Of <(T, Boolean >)>)>)>)
expr2
Type: System.Linq.Expressions..::.Expression <(Of <( Func <(Of <(T, Boolean >)>)>)>)

Type Parameters

T

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


False(T) Method

[image]

.NET Framework Class Library
PredicateBuilder..::.False<(Of <(T>)>) Method
PredicateBuilder Class See Also

Namespace: C1.Silverlight.DataGrid.Primitives
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static Expression<Func<T, bool>> False<T>()
Visual Basic (Declaration)
Public Shared Function False(Of T) As Expression(Of Func(Of T, Boolean))

Type Parameters

T

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


Or(T) Method

[image]

.NET Framework Class Library
PredicateBuilder..::.Or<(Of <(T>)>) Method
PredicateBuilder Class See Also

Namespace: C1.Silverlight.DataGrid.Primitives
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static Expression<Func<T, bool>> Or<T>(
    this Expression<Func<T, bool>> expr1,
    Expression<Func<T, bool>> expr2
)
Visual Basic (Declaration)
<ExtensionAttribute> _
Public Shared Function Or(Of T) ( _
    expr1 As Expression(Of Func(Of T, Boolean)), _
    expr2 As Expression(Of Func(Of T, Boolean)) _
) As Expression(Of Func(Of T, Boolean))

Parameters

expr1
Type: System.Linq.Expressions..::.Expression <(Of <( Func <(Of <(T, Boolean >)>)>)>)
expr2
Type: System.Linq.Expressions..::.Expression <(Of <( Func <(Of <(T, Boolean >)>)>)>)

Type Parameters

T

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


True(T) Method

[image]

.NET Framework Class Library
PredicateBuilder..::.True<(Of <(T>)>) Method
PredicateBuilder Class See Also

Namespace: C1.Silverlight.DataGrid.Primitives
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
public static Expression<Func<T, bool>> True<T>()
Visual Basic (Declaration)
Public Shared Function True(Of T) As Expression(Of Func(Of T, Boolean))

Type Parameters

T

See Also

PredicateBuilder Class
C1.Silverlight.DataGrid.Primitives Namespace


Send comments about this topic to ComponentOne.
Copyright © 1987-2008 ComponentOne LLC. All rights reserved.


Search Helpcentral Search HelpCentral


IRenderer.Changed Event

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.Changed Event
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
event EventHandler IRenderer.Changed
Visual Basic (Declaration)
Private Event Changed As EventHandler Implements IRenderer.Changed

Implements

IRenderer..::.Changed

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


INotifyPropertyChanged.PropertyChanged Event

[image]

.NET Framework Class Library
LegendItemCollection..::.INotifyPropertyChanged..::.PropertyChanged Event
LegendItemCollection Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
event PropertyChangedEventHandler INotifyPropertyChanged.PropertyChanged
Visual Basic (Declaration)
Private Event PropertyChanged As PropertyChangedEventHandler
    Implements INotifyPropertyChanged.PropertyChanged

Implements

INotifyPropertyChanged..::.PropertyChanged

See Also

LegendItemCollection Class
C1.Silverlight.Chart Namespace


ICollection.CopyTo Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.ICollection..::.CopyTo Method
C1ZipEntryCollection Class See Also
Copies the elements of the ICollection to an Array, starting at a particular Array index.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
void ICollection.CopyTo(
    Array array,
    int index
)
Visual Basic (Declaration)
Private Sub CopyTo ( _
    array As Array, _
    index As Integer _
) Implements ICollection.CopyTo

Parameters

array
Type: System..::.Array
The one-dimensional Array that is the destination of the elements copied from ICollection. The Array must have zero-based indexing.
index
Type: System..::.Int32
The zero-based index in array at which copying begins.

Implements

ICollection..::.CopyTo(Array, Int32)

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


IEnumerable.GetEnumerator Method

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.IEnumerable..::.GetEnumerator Method
C1ZipEntryCollection Class See Also

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


IDisposable.Dispose Method

[image]

.NET Framework Class Library
C1ZipFile..::.IDisposable..::.Dispose Method
C1ZipFile Class See Also

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
void IDisposable.Dispose()
Visual Basic (Declaration)
Private Sub Dispose Implements IDisposable.Dispose

Implements

IDisposable..::.Dispose()()()

See Also

C1ZipFile Class
C1.C1Zip Namespace


IRenderer.AddSeries Method

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.AddSeries Method
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void IRenderer.AddSeries(
    IDataSeriesInfo seriesInfo
)
Visual Basic (Declaration)
Private Sub AddSeries ( _
    seriesInfo As IDataSeriesInfo _
) Implements IRenderer.AddSeries

Parameters

seriesInfo
Type: C1.Silverlight.Chart..::.IDataSeriesInfo

Implements

IRenderer..::.AddSeries(IDataSeriesInfo)

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


IRenderer.Clear Method

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.Clear Method
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void IRenderer.Clear()
Visual Basic (Declaration)
Private Sub Clear Implements IRenderer.Clear

Implements

IRenderer..::.Clear()()()

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


IDataSeriesInfo.GetDataNames Method

[image]

.NET Framework Class Library
DataSeries..::.IDataSeriesInfo..::.GetDataNames Method
DataSeries Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
string[] IDataSeriesInfo.GetDataNames()
Visual Basic (Declaration)
Private Function GetDataNames As String()
    Implements IDataSeriesInfo.GetDataNames

Implements

IDataSeriesInfo..::.GetDataNames()()()

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


IDataSeriesInfo.GetValueCoordinates Method

[image]

.NET Framework Class Library
DataSeries..::.IDataSeriesInfo..::.GetValueCoordinates Method
DataSeries Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
ValueCoordinate[] IDataSeriesInfo.GetValueCoordinates()
Visual Basic (Declaration)
Private Function GetValueCoordinates As ValueCoordinate()
    Implements IDataSeriesInfo.GetValueCoordinates

Implements

IDataSeriesInfo..::.GetValueCoordinates()()()

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


IDataSeriesInfo.GetValues Method

[image]

.NET Framework Class Library
DataSeries..::.IDataSeriesInfo..::.GetValues Method
DataSeries Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
double[,] IDataSeriesInfo.GetValues()
Visual Basic (Declaration)
Private Function GetValues As Double(,)
    Implements IDataSeriesInfo.GetValues

Implements

IDataSeriesInfo..::.GetValues()()()

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


IDataSeriesInfo.SetResolvedValues Method

[image]

.NET Framework Class Library
DataSeries..::.IDataSeriesInfo..::.SetResolvedValues Method
DataSeries Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void IDataSeriesInfo.SetResolvedValues(
    int index,
    Object[] vals
)
Visual Basic (Declaration)
Private Sub SetResolvedValues ( _
    index As Integer, _
    vals As Object() _
) Implements IDataSeriesInfo.SetResolvedValues

Parameters

index
Type: System..::.Int32
vals
Type: array< System..::.Object >[]()[]

Implements

IDataSeriesInfo..::.SetResolvedValues(Int32, array<Object>[]()[])

See Also

DataSeries Class
C1.Silverlight.Chart Namespace


IPlotElement.IsCompatible Method

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.IsCompatible Method
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IPlotElement.IsCompatible(
    IRenderer rend
)
Visual Basic (Declaration)
Private Function IsCompatible ( _
    rend As IRenderer _
) As Boolean Implements IPlotElement.IsCompatible

Parameters

rend
Type: C1.Silverlight.Chart..::.IRenderer

Implements

IPlotElement..::.IsCompatible(IRenderer)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IPlotElement.Render Method

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.Render Method
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IPlotElement.Render(
    RenderContext rc
)
Visual Basic (Declaration)
Private Function Render ( _
    rc As RenderContext _
) As Boolean Implements IPlotElement.Render

Parameters

rc
Type: C1.Silverlight.Chart..::.RenderContext

Implements

IPlotElement..::.Render(RenderContext)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IPlotElement.SetShape Method

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.SetShape Method
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
void IPlotElement.SetShape(
    ShapeStyle ss
)
Visual Basic (Declaration)
Private Sub SetShape ( _
    ss As ShapeStyle _
) Implements IPlotElement.SetShape

Parameters

ss
Type: C1.Silverlight.Chart..::.ShapeStyle

Implements

IPlotElement..::.SetShape(ShapeStyle)

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IComparer(Object).Compare Method

[image]

.NET Framework Class Library
CollectionView..::.IComparer<(Of <(Object>)>)..::.Compare Method
CollectionView Class See Also

Namespace: C1.Silverlight.Data
Assembly: C1.Silverlight.Data (in C1.Silverlight.Data.dll)

Syntax

C#
int IComparer<Object>.Compare(
    Object obj1,
    Object obj2
)
Visual Basic (Declaration)
Private Function Compare ( _
    obj1 As Object, _
    obj2 As Object _
) As Integer Implements IComparer(Of Object).Compare

Parameters

obj1
Type: System..::.Object
obj2
Type: System..::.Object

Implements

IComparer<(Of <(T>)>)..::.Compare(T, T)

See Also

CollectionView Class
C1.Silverlight.Data Namespace


IEnumerable.GetEnumerator Method

[image]

.NET Framework Class Library
DataGridRowCollection..::.IEnumerable..::.GetEnumerator Method
DataGridRowCollection Class See Also

Namespace: C1.Silverlight.DataGrid
Assembly: C1.Silverlight.DataGrid (in C1.Silverlight.DataGrid.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

DataGridRowCollection Class
C1.Silverlight.DataGrid Namespace


IEnumerable(ColorPaletteEntry).GetEnumerator Method

[image]

.NET Framework Class Library
ColorPalette..::.IEnumerable<(Of <(ColorPaletteEntry>)>)..::.GetEnumerator Method
ColorPalette Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
IEnumerator<ColorPaletteEntry> IEnumerable<ColorPaletteEntry>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of ColorPaletteEntry)
    Implements IEnumerable(Of ColorPaletteEntry).GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


IEnumerable.GetEnumerator Method

[image]

.NET Framework Class Library
ColorPalette..::.IEnumerable..::.GetEnumerator Method
ColorPalette Class See Also

Namespace: C1.Silverlight.Extended
Assembly: C1.Silverlight.Extended (in C1.Silverlight.Extended.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ColorPalette Class
C1.Silverlight.Extended Namespace


IEnumerable(C1TextElement).GetEnumerator Method

[image]

.NET Framework Class Library
C1TextElement..::.IEnumerable<(Of <(C1TextElement>)>)..::.GetEnumerator Method
C1TextElement Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
IEnumerator<C1TextElement> IEnumerable<C1TextElement>.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator(Of C1TextElement)
    Implements IEnumerable(Of C1TextElement).GetEnumerator

Implements

IEnumerable<(Of <(T>)>)..::.GetEnumerator()()()

See Also

C1TextElement Class
C1.Silverlight.RichTextBox.Documents Namespace


IEnumerable.GetEnumerator Method

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IEnumerable..::.GetEnumerator Method
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
IEnumerator IEnumerable.GetEnumerator()
Visual Basic (Declaration)
Private Function GetEnumerator As IEnumerator
    Implements IEnumerable.GetEnumerator

Implements

IEnumerable..::.GetEnumerator()()()

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace


ICollection.IsSynchronized Property

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.ICollection..::.IsSynchronized Property
C1ZipEntryCollection Class See Also
Gets a value that indicates whether access to the ICollection is synchronized (thread-safe).

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
bool ICollection.IsSynchronized { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsSynchronized As Boolean
    Implements ICollection.IsSynchronized

Implements

ICollection..::.IsSynchronized

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


ICollection.SyncRoot Property

[image]

.NET Framework Class Library
C1ZipEntryCollection..::.ICollection..::.SyncRoot Property
C1ZipEntryCollection Class See Also
Gets an object that can be used to synchronize access to the ICollection.

Namespace: C1.C1Zip
Assembly: C1.Silverlight.Zip (in C1.Silverlight.Zip.dll)

Syntax

C#
Object ICollection.SyncRoot { get; }
Visual Basic (Declaration)
Private ReadOnly Property SyncRoot As Object
    Implements ICollection.SyncRoot

Implements

ICollection..::.SyncRoot

See Also

C1ZipEntryCollection Class
C1.C1Zip Namespace


IRenderer.Dirty Property

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.Dirty Property
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IRenderer.Dirty { get; set; }
Visual Basic (Declaration)
Private Property Dirty As Boolean Implements IRenderer.Dirty

Implements

IRenderer..::.Dirty

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


IRenderer.Options Property

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.Options Property
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
string IRenderer.Options { get; set; }
Visual Basic (Declaration)
Private Property Options As String
    Implements IRenderer.Options

Implements

IRenderer..::.Options

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


IRenderer.Visual Property

[image]

.NET Framework Class Library
BaseRenderer..::.IRenderer..::.Visual Property
BaseRenderer Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
UIElement IRenderer.Visual { get; set; }
Visual Basic (Declaration)
Private Property Visual As UIElement Implements IRenderer.Visual

Implements

IRenderer..::.Visual

See Also

BaseRenderer Class
C1.Silverlight.Chart Namespace


IPlotElement.IsClustered Property

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.IsClustered Property
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
bool IPlotElement.IsClustered { get; }
Visual Basic (Declaration)
Private ReadOnly Property IsClustered As Boolean
    Implements IPlotElement.IsClustered

Implements

IPlotElement..::.IsClustered

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IPlotElement.Label Property

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.Label Property
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
UIElement IPlotElement.Label { get; set; }
Visual Basic (Declaration)
Private Property Label As UIElement Implements IPlotElement.Label

Implements

IPlotElement..::.Label

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IPlotElement.LegendShape Property

[image]

.NET Framework Class Library
PlotElement..::.IPlotElement..::.LegendShape Property
PlotElement Class See Also

Namespace: C1.Silverlight.Chart
Assembly: C1.Silverlight.Chart (in C1.Silverlight.Chart.dll)

Syntax

C#
Shape IPlotElement.LegendShape { get; }
Visual Basic (Declaration)
Private ReadOnly Property LegendShape As Shape
    Implements IPlotElement.LegendShape

Implements

IPlotElement..::.LegendShape

See Also

PlotElement Class
C1.Silverlight.Chart Namespace


IList.Item Property

[image]

.NET Framework Class Library
ProxyCollection<(Of <(T>)>)..::.IList..::.Item Property
ProxyCollection<(Of <(T>)>) Class See Also

Namespace: C1.Silverlight.RichTextBox.Documents
Assembly: C1.Silverlight.RichTextBox (in C1.Silverlight.RichTextBox.dll)

Syntax

C#
Object IList.Item[
    int index
] { get; set; }
Visual Basic (Declaration)
Private Property Item ( _
    index As Integer _
) As Object Implements IList.Item

Parameters

index
Type: System..::.Int32

Implements

IList..::.Item[([(Int32])])

See Also

ProxyCollection<(Of <(T>)>) Class
C1.Silverlight.RichTextBox.Documents Namespace